Sahih Muslim

Free Program, By: http://www.islamspirit.com

Translator: Abdul Hamid Siddiqui

Books:
  1. Faith (Kitab Al Iman)
  2. Purification (Kitab Al-Taharah)
  3. Menstruation (Kitab Al-Haid)
  4. Prayer (Kitab Al-Salat)
  5. Zakat (Kitab Al-Zakat)
  6. Fasting (Kitab Al-Sawm)
  7. Pilgrimage (Kitab Al-Hajj)
  8. Marriage (Kitab Al-Nikah)
  9. Divorce (Kitab Al-Talaq)
  10. Pertaining To Business Transactions (Kitab Al-Buyu)
  11. Pertaining To The Rules Of Inheritance (Kitab Al-Faraid)
  12. Gifts (Kitab Al-Hibat)
  13. Bequests (Kitab Al-Wasiyya)
  14. Vows (Kitab Al-Nadhr)
  15. Oaths (Kitab Al-Iman)
  16. Pertaining To The Oath, For Establishing The Resposibility Of Murders, Fighting, Requital And Blood-Wit (Kitab Al-Qasama Wal-Muharaba Wal-Qisas Wal-Diyat)
  17. Pertaining To Punishments Prescribed By Islam (Kitab Al-Hudud)
  18. Pertaining To Judicial Decisions (Kitab Al-Aqdiyya)
  19. Jihad And Expedition (Kitab Al-Jihad Wal-Siyar)
  20. On Government (Kitab Al-Imara)
  21. Games And Animals Which May Be Slaughtered And The Animals That Are To Be Eaten (Kitab-Us-Said Wa'L-Dhaba'Ih Wa Ma Yu'Kalu Min Al-Hayawan)
  22. Sacrifices (Kitab Al-Adahi)
  23. Drinks (Kitab Al-Ashriba)
  24. Pertaining To Clothes And Decoration (Kitab Al-Libas Wa'L-Zinah)
  25. On General Behavior (Kitab Al-Adab)
  26. On Salutations And Greetings (Kitab As-Salam)
  27. Concerning The Use Of Correct Words (Kitab Al-Alfaz Min Al-Adab Wa Ghairiha)
  28. Poetry (Kitab Al-Shi'r)
  29. Vision (Kitab Al-Ruya)
  30. Pertaining To The Excellent Qualities Of The Holy Prophet (May Peace Be Upon Him) And His Companions (Kitab Al-Fada'Il)
  31. Pertaining To The Merits Of The Companions (Allah Be Pleased With Them) Of The Holy Prophet (May Peace Be Upon Him)
  32. Virtue, Good Manners And Joining Of The Ties Of Relationship (Kitab Al-Birr Wa'S-Salat-I-Wa'L-Adab)
  33. Destiny (Kitab-Ul-Qadr)
  34. Knowledge (Kitab Al-'Ilm)
  35. Pertaining To The Remembrance Of Allah, Supplication, Repentance And Seeking Of Forgiveness (Kitab Al-Dhikr)
  36. Heart Melting Traditions (Kitab Al-Riqaq)
  37. Pertaining To Repentance And Exhortation Of Repentance (Kitab Al-Tauba)
  38. Pertaining To The Charateristics Of The Hypocrites And Command Concerning Them (Kitab Sifat Al-Munafiqin Wa Ahkamihim)
  39. Giving Description Of The Day Of Judgement, Paradise And Hell (Kitab Sifat Al-Qiyama Wa'L Janna Wa'N-Nar)
  40. Pertaining To Paradise, Its Description, Its Bounties And Its Intimates (Kitab Al-Jannat Wa Sifat Na'Imiha Wa Ahliha)
  41. Pertaining To Turmoil And Portents Of The Last Hour (Kitab Al-Fitan Wa Ashrat As-Sa'Ah)
  42. Pertaining To Piety And Softening Of Hearts (Kitab Al-Zuhd Wa Al-Raqa'iq)
  43. Commentary (Kitab Al-Tafsir)


BOOK 1: The Book of Faith (KITAB AL-IMAN) (part I)

KITAB AL-IMAN
(THE BOOK OF FAITH)

Back
Chapter 1 : ...

Book 1, Number 0001:

    It is narrated on the authority of Yahya b. Ya'mur that the first man who discussed about Qadr(Divine Decree) in Basra was Ma'bad al-Juhani. I along with Humaid b. 'Abdur-Rahman Himyari set out for prilgrimage or for 'Umrah and said: Should it so happen that we come into contact with one of the Companions of the Messenger of Allah (peace be upon him) we shall ask him a bout what is talked about Taqdir (Division Decree). Accidentally we came across Abdullah ibn Umar ibn al-Khattab, while he was entering the mosque. My companion and I surrounded him. One of us (stood) on his right and the other stood on his left. I expected that my companion would authorize me to speak. I therefore said: Abu Abdur Rahman! there have appeared some people in our land who recite the Holy Qur'an and pursue knowledge. And then after talking about their affairs, added: They (such people) claim that there is no such thing as Divine Decree and events are not predestined. He (Abdullah ibn Umar) said: When you happen to meet such people tell them that I have nothing to do with them and they have nothing to do with me. And verily they are in no way responsible for my (belief). Abdullah ibn Umar swore by Him (the Lord) (and said): If any one of them (who does not believe in the Divine Decree) had with him gold equal to the bulk of (the mountain) Uhud and then, it (in the way of Allah), Allah would not accept it unless he affirmed his faith in Divine Decree. He further said: My father, Umar ibn al-Khattab, told me: One day we were sitting in the company of Allah's Apostle (peace be upon him) when there appeared before us a man dressed in pure white clothes, his hair extraordinarily black. There were no signs of travel on him. None amongst us recognized him. At last he sat with the Apostle (peace be upon him) He knelt before him placed his palms on his thighs and said: Muhammad, inform me about al-Islam. The Messenger of Allah (peace be upon him) said: Al-Islam implies that you testify that there is no god but Allah and that Muhammad is the messenger of Allah, and you establish prayer, pay Zakat, observe the fast of Ramadan, and perform pilgrimage to the (House) if you are solvent enough (to bear the expense of) the journey. He (the inquirer) said: You have told the truth. He (Umar ibn al-Khattab) said: It amazed us that he would put the question and then he would himself verify the truth. He (the inquirer) said: Inform me about Iman (faith). He (the Holy Prophet) replied: That you affirm your faith in Allah, in His angels, in His Books, in His Apostles, in the Day of Judgment, and you affirm your faith in the Divine Decree about good and evil. He (the inquirer) said: You have told the truth. He (the inquirer) again said: Inform me about al-Ihsan (performance of good deeds). He (the Holy Prophet) said: That you worship Allah as if you are seeing Him, for though you don't see Him, He, verily, sees you. He (the enquirer) again said: Inform me about the hour (of the Doom). He (the Holy Prophet) remarked: One who is asked knows no more than the one who is inquiring (about it). He (the inquirer) said: Tell me some of its indications. He (the Holy Prophet) said: That the slave-girl will give birth to her mistress and master, that you will find barefooted, destitute goat-herds vying with one another in the construction of magnificent buildings. He (the narrator, Umar ibn al-Khattab) said: Then he (the inquirer) went on his way but I stayed with him (the Holy Prophet) for a long while. He then, said to me: Umar, do you know who this inquirer was? I replied: Allah and His Apostle knows best. He (the Holy Prophet) remarked: He was Gabriel (the angel). He came to you in order to instruct you in matters of religion.

Book 1, Number 0002:

    It is narrated on the authority of Yahya b. Ya'mur that when Ma'bad discussed the problem pertaining to Divine Decree, we refuted that. He (the narrator) said: I and Humaid b. Abdur-Rahman Himyari argued. And they carried on the conversation about the purport of the hadith related by Kahmas and its chain of transmission too, and there is some variation of words.

Book 1, Number 0003:

    It is narrated on the authority of Yahya b. Ya'mur and Humaid b. 'Abdur-Rahman that they said: We met Abdullah b. 'Umar and we discussed about the Divine Decree, and what they talked about it and he narrated the hadith that has been transmitted by 'Umar (may Allah be pleased with him) from the Apostle (may peace be upon him). There is a slight variation in that.

Chapter 2 : WHAT IS IMAN AND WHAT ARE ITS CHARACTERISTICS

Book 1, Number 0004:

    Abu Huraira reported: One day the Messenger of Allah (may peace be upon him) appeared before the public that a man came to him and said: Prophet of Allah, (tell me) what is Iman. Upon this he (the Holy Prophet) replied: That you affirm your faith in Allah, His angels, His Books, His meeting, His Messengers and that you affirm your faith in the Resurrection hereafter. He (again) said: Messenger of Allah, (tell me) what does al-Islam signify. He (the Holy Prophet) replied: Al-Islam signifies that you worship Allah and do not associate anything with Him and you establish obligatory prayer and you pay the obligatory poor-rate (Zakat) and you observe the fast of Ramadan. He (the inquirer) again said: Messenger of Allah, what does al-Ihsan imply ? He (the Holy Prophet) replied: That you worship Allah as if you are seeing Him, and in case you fail to see Him, then observe prayer (with this idea in your mind) that (at least) He is seeing you. He (the inquirer ) again said: Messenger of Allah, when would there be the hour (of Doom) ? He (the Holy Prophet) replied: The one who is asked about it is no better informed than the inquirer. I, however, narrate some of its signs (and these are): when the slave-girl will give birth to he master, when the naked, barefooted would become the chiefs of the people - these are some of the signs of (Doom). (Moreover) when the shepherds of the black (camels) would exult themselves in buildings, this is one of the signs of (Doom). (Doom) is one of the five (happenings wrapped in the unseen) which no one knows but Allah. Then he (the Messenger of Allah) recited (the verse) : "Verily Allah! with Him alone is the knowledge of the hour and He it is Who sends (down the rain) and knows that which is in the wombs and no person knows whatsoever he shall earn tomorrow, and a person knows not in whatsoever land he shall die. Verily Allah is Knowing, Aware . He (the narrator, Abu Huraira) said: Then the person turned back and went away. The Messenger of Allah (may peace be upon him) said: Bring that man back to me. They (the Companions of the Holy Prophet present there) went to bring him back, but they saw nothing there. Upon this the Messenger of Allah remarked : he was Gabriel, who came to teach the people their religion.

Book 1, Number 0005:

    This hadith is narrated to us on the authority of Muhammad b. 'Abdullah b. Numair, on the authority of Muhammad b. Bishr, on the authority of Abd Hayyan al-Taymi with the exception that in this narration (instead of the words (Iza Waladat al'amah rabbaha), the words are (Iza Waladat al'amah Ba'laha), i,e, when slave-girl gives birth to her master.

Book 1, Number 0006:

    It is narrated on the authority of Abu Huraira that the Messenger of Allah (may peace be upon him) said: Ask me (about matters pertaining to religion), but they (the Companions of the Holy Prophet) were too much overawed out of profound respect for him to ask him (anything). In the meanwhile a man came there, and sat near his knees and said: Messenger of Allah, what al-lslam is?-to which he (the Holy Prophet)replied: You must not associate anything with Allah, and establish prayer, pay the poor-rate (Zakat) and observe (the fasts) of Ramadan. He said : You (have) told the truth. He (again) said: Messenger of Allah, what al-Iman (the faith) is? He (the Holy Prophet) said: That you affirm your faith in Allah, His angels, His Books, His meeting, His Apostles, and that you believe in Resurrection and that you believe in Qadr (Divine Decree) in all its entirety, He (the inquirer) said: You (have) told the truth. He (again) said: Messenger of Allah, what al-Ihsan is? Upon this he (the Holy Prophet) said: (Al-Ihsan implies) that you fear Allah as if you are seeing Him, and though you see Him not, verily He is seeing you. He (the inquirer) said: You(have) told the truth. He (the inquirer) said: When there would be the hour (of Doom)? (Upon this) he (the HolyProphet said:The one who is being asked about it is no better informed than the inquirer himself. I,however,narrate some of its signs (and these are):when you see a slave(woman)giving birth to her master - that is one of the signs of (Doom); when you see barefooted, naked, deaf and dumb (ignorant and foolish persons) as the rulers of the earth - that is one of the signs of the Doom. And when you see the shepherds of black camels exult in buildings - that is one of the signs of Doom. The (Doom) is one of the five things (wrapped) in the unseen. No one knows them except Allah. Then(the Holy Prophet) recited (the folowing verse): "Verily Allah ! with Him alone is the knowledge of the hour and He it is Who sends down the rain and knows that which is in the wombs and no person knows whatsoever he shall earn on morrow and a person knows not in whatsoever land he shall die. Verily Allah is Knowing,Aware. He (the narrator, Abu Huraira) said: Then the person stood up an (made his way). The Messenger of Allah (may peace be upon him) said: Bring him back to me. He was searched for, but they (the Companions of the Holy Prophet) could not find him. The Messenger of Allah (may peace be upon him) thereupon said: He was Gabriel and he wanted to teach you (things pertaining to religion) when you did not ask (them yourselves).

Chapter 3 : ON PRAYER (SALAT) WHICH IS ONE OF THE PILLARS OF ISLAM

Book 1, Number 0007:

    It is reported on the authority of Talha b. 'Ubaidullah that a person with dishevelled hair, one of the people of Nejd, came to the Messenger of Allah (may peace be upon him). We heard the humming of his voice but could not fully discern what he had been saying, till he came nigh to the Messenger of Allah (may peace be upon him). It was then (disclosed to us) that he was asking questions pertaining to Islam. The Messenger of Allah (may peace be upon him) said: Five prayers during the day and the night. (Upon this he said: Am I obliged to say any other (prayer) besides these? He (the Holy Prophet,) said: No, but whatever you observe voluntarily, out of your own free will, and the fasts of Ramadan. The inquirer said: Am I obliged to do anything else besides this? He (the Holy Prophet) said: No, but whatever you do out of your own free will. And the Messenger of Allah told him about the Zakat (poor-rate). The inquirer said: Am I obliged to pay anything else besides this ? He (the Holy Prophet) said: No, but whatever you pay voluntarily out of your own free will. The man turned back and was saying: I would neither make any addition to this, nor will decrease anything out of it. The Prophet remarked: He is successful, if he is true to what he affirms.

Book 1, Number 0008:

    Another hadith, the like of which has been narrated by Malik (b. Anas) (and mentioned above) is also reported by Talha b. 'Ubaidullah, with the only variation that the Holy Prophet remarked: By his father, he shall succeed if he were true (to what he professed), or: By his father, he would enter heaven if he were true (to what he professed).

Chapter 4 : PERTAINING TO FAITH IN ALLAH

Book 1, Number 0009:

    It is reported on the authority of Anas b. Malik that he said: We were forbidden that we should ask anything (without the genuine need) from the Holy Prophet. It, therefore, pleased us that an intelligent person from the dwellers of the desert should come and asked him (the Holy Prophet) and we should listen to it. A man from the dwellers of the desert came (to the Holy Prophet) and said: Muhammad, your messenger came to us and told us your assertion that verily Allah had sent you (as a prophet). He (the Holy Prophet) remarked: He told the truth. He (the bedouin) said: Who created the heaven? He (the Holy Prophet) replied: Allah. He (the bedouin again) said: Who created the earth? He (the Holy Prophet) replied: Allah. He (the bedouin again) said: Who raised these mountains and who created in them whatever is created there? He (the Holy Prophet) replied: Allah. Upon this he (the bedouin) remarked: By Him Who created the heaven and created the earth and raised mountains thereupon, has Allah (in fact) sent you? He (the Holy Prophet) said: Yes. He (the bedouin) said: Your messenger also told us that five prayers (had been made) obligatory for us during the day and the night. He (the Holy Prophet) remarked: He told you the truth. He (the bedouin) said: By Him Who sent you, is it Allah Who ordered you about this (i.e. prayers)? He (the Holy Prophet) said: Yes. He (the bedouin) said: Your messenger told us that Zakat had been made obligatory in our riches. He (the Holy Prophet) said. He has told the truth. He (the bedouin) said: By Him Who sent you (as a prophet), is it Allah Who ordered you about it (Zakat)? He (the Holy Prophet) said: Yes. He (the bedouin) said: Your messenger told us that it had been made obligatory for us to fast every year during the month of Ramadan. He (the Holy Prophet) said: He has told the truth. He (the bedouin) said: By Him Who sent you (as a prophet), is it Allah Who ordered you about it (the fasts of Ramadan)? He (the Holy Prophet) said: Yes. He (the bedouin) said: Your messenger also told us that pilgrimage (Hajj) to the House (of Ka'bah) had been made obligatory for him who is able to undertake the journey to it. He (the Holy Prophet) said: Yes. The narrator said that he (the bedouin) set off (at the conclusion of this answer, but at the time of his departure) remarked:'By Him Who sent you with the Truth, I would neither make any addition to them nor would I diminish anything out of them. Upon this the Holy Prophet remarked: If he were true (to what he said) he must enter Paradise.

Book 1, Number 0010:

    It is narrated on the authority of Thabit that Anas said: We were forbidden in the Holy Qur'an that we should ask about anything from the Messenger of Allah (may peace be upon him) and then Anas reported the hadith in similar words.

Chapter 5 : CONCERNING IMAN BY WHICH A PERSON WOULD ENTER HEAVEN

Book 1, Number 0011:

    It is narrated on the authority of Abu Ayyub Ansari that once during the journey of the Holy Prophet (may peace of Allah be upon him) a bedouin appeared before him and caught hold of the nosestring of his she-camel and then said, Messenger of Allah (or Muhammad), inform me about that which takes me near to Paradise and draws me away from the Fire (of Hell). He (the narrator) said: The Prophet (may peace be upon him) stopped for a while and cast a glance upon his companions and then said: He was afforded a good opportunity (or he had been guided well). He (the Holy Prophet) addressing the bedouin said: (Repeat) whatever you have uttered. He (the bedouin) repeated that. Upon this the Apostle (may peace be upon him) remarked: The deed which can draw you near to Paradise and take you away from Hell is, that you worship Allah and associate none with Him, and you establish prayer and pay Zakat, and do good to your kin. After having uttered these words, the Holy Prophet asked the bedouin to release the nosestring of his she-camel.

Book 1, Number 0012:

    This hadith is transmitted by Muhammad b. Hatim on the authority of Abu Ayyub Ansari.

Book 1, Number 0013:

    It is narrated on the authority of Abu Ayyub that a man came to the Prophet (may peace be upon him) and said: Direct me to a deed which draws me near to Paradise and takes me away from the Fire (of Hell). Upon this he (the Holy Prophet) said: You worship Allah and never associate anything with Him, establish prayer, and pay Zakat, and do good to your kin. When he turned his back, the Messenger of Allah (may peace be upon him) remarked : If he adheres to what he has been ordered to do, he would enter Paradise.

Book 1, Number 0014:

    It is reported on the authority of Abu Huraira that a bedouin came to the Messenger of Allah (may peace be upon him) and said: Messenger of Allah, direct me to a deed by which I may be entitled to enter Paradise. Upon this he (the Holy Prophet) remarked: You worship Allah and never associate anything with Him, establish the obligatory prayer, and pay the Zakat which is incumbent upon you, and observe the fast of Ramadan. He (the bedouin) said: By Him in Whose hand is my life, I will never add anything to it, nor will I diminish anything from it. When he (the bedouin) turned his back, the Prophet (may peace be upon him) said: He who is pleased to see a man from the dwellers of Paradise should catch a glimpse of him.

Book 1, Number 0015:

    It is narrated on the authority of Jabir that Nu'man b. Qaufal came to the Holy Prophet (may peace be upon him) and said: Would I enter Paradise if I say the obligatory prayers and deny myself that which is forbidden and treat that as lawful what has been made permissible (by the Shari'ah) ? The Holy Prophet (may peace be upon him) replied in the affirmative.

Book 1, Number 0016:

    A similar hadith is narrated on Jabir's authority in which the following words are added: I will do nothing more.

Book 1, Number 0017:

    It is narrated on the authority of Jabir that a man once said to the Messenger of Allah (may peace be upon him): Shall I enter Paradise in case I say the obligatory prayers, observe the (fasts) of Ramadan and treat that as lawful which has been made permissible (by the Shari'ah) and deny myself that what is forbidden, and make no addition to it? He (the Holy Prophet) replied in the affirmative. He (the inquirer) said: By Allah, I would add nothing to it.

Chapter 6 : CONCERNING THE SAYING OF THE APOSTLE: ISLAM IS FOUNDED ON FIVE (FUNDAMENTS)

Book 1, Number 0018:

    It is narrated on the authority of ('Abdullah) son of Umar (may Allah be pleased with them) that the Holy Prophet (may peace of Allah be upon him) said: (The superstructure of) al-Islam is raised on five (pillars), i.e. the oneness of Allah, the establishment of prayer, payment of Zakat, the, fast of Ramadan, Pilgrimage (to Mecca).
    A person said (to 'Abdullah b. Umar the narrator): Which of the two precedes the other-Pilgrimage or the fasts of Rarnadan? Upon this he (the narrator) replied: No (it is not the Pilgrimage first) but the fasts of Ramadan precede the Pilgrimage.

Book 1, Number 0019:

    It is narrated on the authority of ('Abdullah) son of 'Umar, that the Holy Prophet (may peace of Allah be upon him) said: (The superstructure of) al-Islam is raised on five (pillars), i.e. Allah (alone) should be worshipped, and (all other gods) beside Him should be (categorically) denied. Establishment of prayer, the payment of Zakat, Pilgrimage to the House, and the fast of Ramadan (are the other obligatory acts besides the belief in the oneness of Allah and denial of all other gods).

Book 1, Number 0020:

    It is narrated on the authority of 'Abdullah son of 'Umar that the Messenger of Allah (may peace be upon him) said: (The superstructure of) al-Islam is raised on five (pillars), testifying (the fact) that there is no god but Allah, that Muhammad is His bondsman and messenger, and the establishment of prayer, payment of Zakat, Pilgrimage to the House (Ka'ba) and the fast of Ramadan.

Book 1, Number 0021:

    It is reported on the authority of Ta'us that a man said to 'Abdullah son of 'Umar (may Allah be pleased with him). Why don't you carry out a military expedition? Upon which he replied: I heard the messenger of Allah (may peace be upon him) say: Verily, al-Islam is founded on five (pillars): testifying the fact that there is no god but Allah, establishment of prayer, payment of Zakat, fast of Ramadan and Pilgrimage to the House.

Chapter 7 : RELATING TO THE COMMAND FOR BELIEF IN ALLAH AND HIS PROPHET AND THE LAWS OF ISLAM AND INVITING (PEOPLE TO) THEM

Book 1, Number 0022:

    It is narrated on the authority of Ibn 'Abbas that a delegation of Abdul Qais came to the Messenger of Allah (may peace be upon him) and said: Messenger of Allah, verily ours is a tribe of Rabi'a and there stand between you and us the unbelievers of Mudar and we find no freedom to come to you except in the sacred month. Direct us to an act which we should ourselves perform and invite those who live beside us. Upon this the Prophet remarked: I command you to do four things and prohibit you against four acts. (The four deeds which you are commanded to do are): Faith in Allah, and then he explained it for them and said: Testifying the fact. that there is no god but Allah, that Muhammad is the messenger of Allah, performance of prayer, payment of Zakat, that you pay Khums (one-fifth) of the booty fallen to your lot, and I prohibit you to use round gourd, wine jars, wooden pots or skins for wine. Khalaf b. Hisham has made this addition in his narration: Testifying the fact that there is no god but Allah, and then he with his finger pointed out the oneness of the Lord.

Book 1, Number 0023:

    Abu Jamra reported: I was an interpreter between Ibn Abbas and the people, that a woman happened to come there and asked about nabidh or the pitcher of wine. He replied: A delegation of the people of 'Abdul-Qais came to the Messenger of Allah (may peace be upon him). He (the Holy Prophet) asked the delegation or the people (of the delegation about their identity). They replied that they belonged to the tribe of Rabi'a. He (the Holy Prophet) welcomed the people or the delegation which were neither humiliated nor put to shame. They (the members of the delegation) said: Messenger of Allah, we come to you from a far-off distance and there lives between you and us a tribe of the unbelievers of Mudar and , therefore, it is not possible for us to come to you except in the sacred months. Thus direct us to a clear command, about which we should inform people beside us and by which we may enter heaven. He (the Holy Prophet) replied: I command you to do four deeds and forbid you to do four (acts), and added : I direct you to affirm belief in Allah alone, and then asked them: Do you know what belief in Allah really implies ? They said: Allah and His Messenger know best. The Prophet said: It implies testimony to the fact that there is no god but Allah, and that Muhammad is the messenger of Allah, establishment of prayer, payment of Zakat, fast of Ramadan, that you pay one-fifth of the booty (fallen to your lot) and I forbid you to use gourd, wine jar, or a receptacle for wine. Shu'ba sometimes narrated the word naqir (wooden pot) and sometimes narrated it as muqayyar. The Holy Prophet also said : Keep it in your mind and inform those who have been left behind.

Book 1, Number 0024:

    There is another hadith narrated on the authority of Ibn Abbas (the contents of which are similar to the one) narrated by Shu'ba in which the Holy Prophet (may peace be upon him) said: I forbid you to prepare nabidh in a gourd, hollowed block of wood, a varnished jar or receptacle. Ibn Mu'adh made this addition on the authority of his father that the Messenger of Allah said to Ashajj, of the tribe of 'Abdul-Qais: You possess two qualities which are liked by Allah: insight and deliberateness.

Book 1, Number 0025:

    It is reported on the authority of Qatada that one among the delegates of the 'Abdul-Qais tribe narrated this tradition to him. Sa'id said that Qatada had mentioned the name of Abu Nadra on the authority of Abu Sa'id Khudri who narrated this tradition: That people from the- tribe of 'Abdul-Qais came to the Messenger of Allah (may peace be upon him) and said: Messenger of Allah, we belong to the tribe of Rabi'a and there live between you and us the unbelievers of the Mudar tribe and we find it impossible to come to you except in the sacred months; direct us to a deed which we must communicate to those who have been left behind us and by doing which we may enter heaven. Upon this the Messenger of Allah (may peace be upon him) said: I enjoin upon you four (things) and forbid you to do four (things): worship Allah and associate none with Him, establish prayer, pay Zakat, and observe the fast of Ramadan, and pay the fifth part out of the booty. And I prohibit you from four (things): dry gourds, green-coloured jars, hollowed stumps of palm-trees, and receptacles. They (the members of the delegation) said: Do you know what al-naqir is? He replied: Yes, it is a stump which you hollow out and in which you throw small dates.Sa'id said: He (the Holy Prophet) used the word tamar (dates). (The Holy Prophet then added): Then you sprinkle water over it and when its ebullition subsides, you drink it (and you are so intoxicated) that one amongst you, or one amongst them (the other members of your tribe, who were not present there) strikes his cousin with the sword. He (the narrator) said: There was a man amongst us who had sustained injury on this very account due to (intoxication), and he told that he tried to conceal it out of shame from the Messenger of Allah (may peace be upon him). I, however, inquired from the Messenger of Allah (it we discard those utensils which you have forbidden us to use), then what type of vessels should be used for drink? He (the Holy Prophet) replied: In the waterskin the mouths of which are tied (with a string). They (again) said: Prophet of Allah, our land abounds in rats and water-skins cannot remain preserved. The holy Prophet of Allah (may peace be upon him) said: (Drink in water-skins) even if these arenibbled by rats. And then (addressing) al-Ashajj of 'Abdul-Qais he said: Verily, you possess two such qualities which Allah loves: insight and deliberateness.

Book 1, Number 0026:

    It is narrated on the authority of Abu Said al-Khudri that when the delegation of the tribe of Abdul-Qais came to the Prophet of Allah (may peace be upon him), (its members) said: Apostle of Allah, may God enable us to lay down our lives for you, which beverage is good for us? He (the Prophet) said: (Not to speak of beverages, I would lay stress) that you should not drink in the wine jars. They said: Apostle of Allah, may God enable us to lay down our lives for you, do you know what al-naqir is? He (the Holy Prophet) replied: Yes, it is a stump which you hollow out in the middle, and added : Do not use gourd or receptacle (for drink). Use water-skin the mouth of which is tied with a thong (for this purpose).

Chapter 8 : CALLING PEOPLE TO TESTIFICATIONS AND THE CANONS OF ISLAM

Book 1, Number 0027:

    It is reported on the authority of Ibn 'Abbas that Mu'adh said: The Messenger of Allah sent me (as a governor of Yemen) and (at the time of departure) instructed me thus: You will soon find yourself in a community one among the people of the Book, so first call them to testify that there is no god but Allah, that I (Muhammad) am the messenger of Allah, and if they accept this, then tell them Allah has enjoined upon them five prayers during the day and the night and if they accept it, then tell them that Allah has made Zakat obligatory for them that it should be collected from the rich and distributed among the poor, and if they agree to it don't pick up (as a share of Zakat) the best of their wealths. Beware of the supplication of the oppressed for there is no barrier between him and Allah.

Book 1, Number 0028:

    It is narrated on the authority of Ibn 'Abbas that when the Messenger of Allah (may peace be upon him) sent Mu'adh towards Yemen (as governor) he said to him: Verily you would reach a community of the people of the Book, the very first thing to which you should call them is the worship of Allah, may His Glory be Magnificent, and when they become fully aware of Allah, instruct them that He has enjoined five prayers on them during the day and the night, and when the begin observing it, then instruct them that verily Allah has made Zakat obligatory for them which would be collected from the wealthy amongst them and distributed to their needy ones, and when they submit to it, then collect it from them and avoid (the temptation) of selecting the best (items) of their riches.

Chapter 9 : COMMAND FOR FIGHTING AGAINST THE PEOPLE SO LONG AS THEY DO NOT PROFESS THAT THERE IS NO GOD BUT ALLAH AND MUHAMMAD IS HIS MESSENGER

Book 1, Number 0029:

    It is narrated on the authority of Abu Huraira that when the Messenger of Allah (may peace be upon him) breathed his last and Abu Bakr was appointed as his successor (Caliph), those amongst the Arabs who wanted to become apostates became apostates. 'Umar b. Khattab said to Abu Bakr: Why would you fight against the people, when the Messenger of Allah declared : I have been directed to fight against people so long as they do not say: There is no god but Allah, and he who professed it was granted full protection of his property and life on my behalf except for a right? His (other) affairs rest with Allah. Upon this Abu Bakr said: By Allah, I would definitely fight against him who severed prayer from Zakat, for it is the obligation upon the rich. By Allah, I would fight against them even to secure the cord (used for hobbling the feet of a camel) which they used to give to the Messenger of Allah (as zakat) but now they have withheld it. Umar b. Khattab remarked: By Allah, I found nothing but the fact that Allah had opened the heart of Abu Bakr for (perceiving the justification of) fighting (against those who refused to pay Zakat) and I fully recognized that the (stand of Abu Bakr) was right.

Book 1, Number 0030:

    It is reported on the authority of Abu Huraira that the Messenger of Allah said: I have been commanded to fight against people so long as they do not declare that there is no god but Allah, and he who professed it was guaranteed the protection of his property and life on my behalf except for the right affairs rest with Allah.

Book 1, Number 0031:

    It is reported on the authority of Abu Huraira that he heard the Messenger of Allah say: I have been commanded to fight against people, till they testify to the fact that there is no god but Allah, and believe in me (that) I am the messenger (from the Lord) and in all that I have brought. And when they do it, their blood and riches are guaranteed protection on my behalf except where it is justified by law, and their affairs rest with Allah.

Book 1, Number 0032:

    It is narrated on the authority of Jabir that the Messenger of Allah said: I have been commanded that I should fight against people till they declare that there is no god but Allah, and when they profess it that there is no god but Allah, their blood and riches are guaranteed protection on my behalf except where it is justified by law, and their affairs rest with Allah, and then he (the Holy Prophet) recited (this verse of the Holy Qur'an): "Thou art not over them a warden" (lxxxviii, 22).

Book 1, Number 0033:

    It has been narrated on the authority of Abdullah b. 'Umar that the Messenger of Allah said: I have been commanded to fight against people till they testify that there is no god but Allah, that Muhammad is the messenger of Allah, and they establish prayer, and pay Zakat and if they do it, their blood and property are guaranteed protection on my behalf except when justified by law, and their affairs rest with Allah.

Book 1, Number 0034:

    It Is narrated on the authority of Abu Malik: I heard the Messenger of Allah (may peace be upon him) say: He who professed that there is no god but Allah and made a denial of everything which the people worship beside Allah, his property and blood became inviolable, an their affairs rest with Allah.

Book 1, Number 0035:

    Abu Malik narrated on the authority of his father that he heard the Apostle (may peace be upon him) say: He who held belief in the unity of Allah, and then narrated what has been stated above.

Chapter 10 : HE WHO ACCEPTS ISLAM AT THE DEATH-BED, BEFORE THE ACTUAL AGONY OF DEATH, IS A MUSLIM IT IS FORBIDDEN TO SUPPLICATE BLESSINGS FOR THE POLYTHEISTS. HE WHO DIES AS A POLYTHEIST IS ONE AMONG THE DENIZENS OF HELL AND NO MEANS WOULD BE EFFECTIVE ENOUGH TO GET HIM OUT OF THAT

Book 1, Number 0036:

    It is reported by Sa'id b. Musayyib who narrated it on the authority of his father (Musayyib b. Hazm) that when Abu Talib was about to die, the Messenger of Allah (may peace be upon him) came to him and found with him Abu Jahl ('Amr b. Hisham) and 'Abdullah b. Abi Umayya ibn al-Mughirah. The Messenger of Allah (may peace be upon him) said: My uncle, you just make a profession that there is no god but Allah, and I will bear testimony before Allah (of your being a believer), Abu Jahl and 'Abdullah b. Abi Umayya addressing him said: Abu Talib, would you abandon the religion of 'Abdul-Muttalib? The Messenger of Allah (may peace be upon him) constantly requested him (to accept his offer),and(on the other hand) was repeated the same statement (of Abu Jahl and 'Abdullah b. Abi Umayya) till Abu Talib gave his final decision and be stuck to the religion of 'Abdul-Muttalib and refused to profess that there is no god but Allah. Upon this the Messenger of Allah remarked: By Allah, I will persistently beg pardon for you till I am forbidden to do so (by God), It was then that Allah, the Magnificent and the Glorious, revealed this verse:

      "It is not meet for the Prophet and for those who believe that they should beg pardon for the polytheists, even though they were their kith and kin, after it had been made known to them that they were the denizens of Hell" (ix. 113)

    And it was said to the Messenger of Allah (may peace be upon him):

      "Verily thou canst not guide to the right path whom thou lovest. And it is Allah Who guideth whom He will, and He knoweth best who are the guided"(xxviii, 56).

Book 1, Number 0037:

    It is narrated on the authority of Abu Huraira that the Messenger of Allah said to his uncle at the time of his death: Make a profession of it that there is no god but Allah and I will bear testimony (of your being a Muslim) on the Day of judgment. But he (Abu Talib) refused to do so. Then Allah revealed this verse:

      "Verily thou canst not guide to the right path whom thou lovest. And it is Allah Who guideth whom He will and He knoweth best who are the guided" (xxviii. 56).

Book 1, Number 0038:

    It is narrated on the authority of Abu Huraira that the Messenger of Allah said to his uncle (at the time of his death):Make a profession of it that there is no god but Allah and I will bear testimony (of your being a Muslim) on the Day of judgment. He (Abu Talib) said: Were it not the fear of the Quraysh blaming me (and) saying that it was the fear of (approaching death) that induced me to do so, I would have certainly delighted your eyes. It was then that Allah revealed:

      "Verily thou canst not guide to the right path whom thou lovest. And it is Allah Who guideth whom He will and He knoweth best who are the guided" (xxviii-56).

Chapter 11 : HE WHO MEETS HIS LORD WITH IMPLICIT FAITH WOULD ENTER HEAVEN AND FIRE WOULD BE FORBIDDEN HARM HIM

Book 1, Number 0039:

    It is narrated on the authority of 'Uthman that the Messenger of Allah (may peace be upon him) said. He who died knowing (fully well) that there is no god but Allah entered Paradise.

Book 1, Number 0040:

    It is narrated on the authority of Humran that he heard Uthman saying this: I heard the Messenger of Allah (may peace be upon him) uttering these words (as stated above).

Book 1, Number 0041:

    It is narrated on the authority of Abu Huraira: We were accompanying the Apostle (may peace be upon him) in a march (towards Tabuk). He (the narrator) said: The provisions with the people were almost depleted. He (the narrator) said: (And the situation became so critical) that they (the men of the army) decided to slaughter some of their camels. He (the narrator) said: Upon this Umar said: Messenger of Allah, I wish that you should pool together what has been left out of the provisions with the people and then invoke (the blessings of) Allah upon it. He (the narrator) said: He (the Holy Prophet) did it accordingly. He (the narrator) said: The one who had wheat in his possession came there with wheat. He who had dates with him came there with dates. And Mujahid said: He who possessed stones of dates came there with stones. I (the narrator) said: What did they do with the date-stones. They said: They (the people) sucked them and then drank water over them. He (the narrator said): He (the Holy Prophet) invoked the blessings (of Allah) upon them (provisions). He (the narrator) said: (And there was such a miraculous increase in the stocks) that the people replenished their provisions fully. He (the narrator) said: At that time he (the Holy Prophet) said: I bear testimony to the fact that there is no god but Allah, and I am His messenger. The bondsman who would meet Allah without entertaining any doubt about these (two fundamentals) would enter heaven.

Book 1, Number 0042:

    It is narrated either on the authority of Abu Huraira or that of Abu Sa'id Khudri. The narrator A'mash has narrated this hadith with a little bit of doubt (about the name of the very first narrator who was in direct contact with the Holy Prophet. He was either Abu Huraira or Abu Sa'id Khudri. Both are equally reliable transmitters of the traditions). He (the narrator) said: During the time of Tabuk expedition, the (provisions) ran short and the men (of the army) suffered starvation; they said: Messenger of Allah, would you permit us to slay our camels? We would eat them and use their fat. The Messenger of Allah (may peace be upon him) said: Do as you please. He (the narrator) said: Then 'Umar came there and said: Messenger of Allah, if you do that (if you give your consent and the men begin to slay their camels), the riding animals would become short. But (I would suggest you to) summon them along with the provisions left with them Then invoke Allah's blessings on them (different items of the provisions) It is hoped Allah shall bless them. The Messenger of Allah replied in the affirmative. (the narrator) said: He called for a leather mat to be used as a table cloth and spread it out. Then he called people along with the remaining portions of their provisions. He (the narrator) said: Someone was coming with handful of mote, another was coming with a handful of dates, still another was coming with a portion of bread, till small quantities of these things were collected on the table cloth. He (the narrator said): Then the messenger of Allah invoked blessing (on them) and said: Fill your utensils with these provisions. He (the narrator) said: They filled their vessel to the brim with them, and no one amongst the army (which comprised of 30,000 persons) was left even with a single empty vessel. He (the narrator) aid: They ate to their fill, and there was still a surplus. Upon this the Messenger of Allah (may peace be upon him) remarked: I bear testimony that there is no god but Allah and I am the messenger of Allah. The man who meets his Lord without harboring any doubt about these two (truths) would never be kept away from Paradise.

Book 1, Number 0043:

    It is narrated on the authority of Ubadah b. Samit that the messenger of Allah (may peace be upon him) observed : He who said: "There is no god but Allah, He is One and there is no associate with Him, that Muhammad is his servant and His messenger, that Christ is servant and the son of His slave-girl and he (Christ) His word which He communicated to Mary and is His Spirit, that Paradise is a fact and Hell is a fact," Allah would make him (he who affirms these truths enter Paradise through any one of its eight doors which he would like.

Book 1, Number 0044:

    It is narrated on the authority of Umar b. Hani with the same chain of transmitters with the exception of these words: Allah would make him (he who affirms these truths) enter Paradise through one of the eight doors which he would like.

Book 1, Number 0045:

    It is narrated on the authority of Sunabihi that he went to Ubada b. Samit when he was about to die. I burst into tears. Upon this he said to me: Allow me some time (so that I may talk with you). Why do you weep? By Allah , if I am asked to bear witness, I would certainly testify for you (that you are a believer). Should I be asked to intercede, I would certainly intercede for you, and if I have the power, I would certainly do good to you, and then observed: By Allah, never did I hear anything from the Messenger of Allah (may peace be upon him) which could have been a source of benefit to you and then not conveyed it to you except this single hadith. That I intend to narrate to you today, since I am going to breathe my last. I heard the Messenger of Allah (may peace be upon him) say: He who testifies that there is no god but Allah and that Muhammad is the messenger of Allah, Allah would prohibit the fire of Hell for him.

Book 1, Number 0046:

    It is narrated on the authority of Mu'adh b. Jabal: I was riding behind the Prophet (may peace be upon him) and there was nothing between him and me but the rear part of the saddle, when he said: Mu'adh b.Jabal : To which I replied: At your beck and call, and at your pleasure, Messenger of Allah ! He moved along for a few minutes, when again he said: Mu'adh b. Jabal : To which I replied: At your beck and call, and at your pleasure, Messenger of Allah ! He then again moved along for a few minutes and said: Mu'adh b. Jabal : To which I replied . At your beck and call, and at your pleasure. Messenger of Allah He,(the Holy Prophet) said: Do you know what right has Allah upon His servants? I said: Allah and His Messenger know best. He (the Holy Prophet) said: Verily the right of Allah over His servants is that they should worship Him, not associating anything with Him. He (the Holy Prophet) with Mu'adh behind him, moved along for a few minutes and said: Mu'adh b. Jabal: To which I replied: At your beck and call, and at your pleasure, Messenger of Allah ! He (the Holy Prophet) said: Do you know what rights have servants upon Allah in case they do it (i.e. they worship Allah without associating anything with Him)? I (Mu'adh b. Jabal) replied: Allah and His Messenger know best. (Upon this) he (the Holy Prophet) remarked: That He would not torment them (with the fire of Hell).

Book 1, Number 0047:

    It is narrated on the authority of Mu'adh b. Jabal that he observed: I was riding behind the Messenger of Allah (may peace be upon him) on an ass known as 'Ufair. He (Mu'adh) observed: He (the Holy Prophet) said: Mu'adh, do you know what right has Allah over His bondsmen and what right have His bondsmen over Him ? Mu'adh added: I replied: Allah and his Messenger know best. Upon this he(the Holy Prophet remarked: The right of Allah over His bondsmen is that they should worship Allah and should not associate anything with Him, and the right of His bondsmen over Allah, Glorious and Sublime, is that He does not punish him who associates not anything with Him. He (Mu'adh) added: I said to the Messenger of Allah: Should I then give the tidings to the people? He (the Holy Prophet) said: Do not tell them this good news, for they would trust in it alone.

Book 1, Number 0048:

    It is narrated on the authority of Mu'adh b. Jabal that the Messenger of Allah (may peace be upon him) said: Mu'adh, do you know the right of Allah over His bondsmen? He (Mu'adh) said: Allah and His Apostle know best. He (the Messenger of Allah) said: That Allah alone should be worshipped and nothing should be associated with Him. He (the Holy Prophet) said: What right have they (bondsmen) upon Him in case they do it? He (Mu'adh) said: Allah and His Apostle know best. He (the Holy Prophet) said: That He would not punish them.

Book 1, Number 0049:

    It is narrated on the authority of Aswad b. Hilal that he heard Mu'adh say this: The Messenger of Allah (may peace be upon him) called, me and I replied to him. He (the Holy Prophet) said: Do you know the right of Allah upon the people ? and then followed the hadith (mentioned above).

Book 1, Number 0050:

    It is reported on the authority of Abu Huraira: We were sitting around the Messenger of Allah (may peace and blessings be upon him). Abu Bakr and Umar were also there among the audience. In the meanwhile the Messenger of Allah got up and left us, He delayed in coming back to us, which caused anxiety that he might be attacked by some enemy when we were not with him; so being alarmed we got up. I was the first to be alarmed. I, therefore, went out to look for the Messenger of Allah (may peace and blessings be upon him) and came to a garden belonging to the Banu an-Najjar, a section of the Ansar went round it looking for a gate but failed to find one. Seeing a rabi' (i.e. streamlet) flowing into the garden from a well outside, drew myself together, like a fox, and slinked into (the place) where God's Messenger was. He (the Holy Prophet) said: Is it Abu Huraira? I (Abu Huraira) replied: Yes, Messenger of Allah. He (the Holy Prophet) said: What is the matter with you? replied: You were amongst us but got up and went away and delayed for a time, so fearing that you might be attacked by some enemy when we were not with you, we became alarmed. I was the first to be alarmed. So when I came to this garden, I drew myself together as a fox does, and these people are following me. He addressed me as Abu Huraira and gave me his sandals and said: Take away these sandals of mine, and when you meet anyone outside this garden who testifies that there is no god but Allah, being assured of it in his heart, gladden him by announcing that he shall go to Paradise. Now the first one I met was Umar. He asked: What are these sandals, Abu Huraira? I replied: These are the sandals of the Messenger of Allah with which he has sent me to gladden anyone I meet who testifies that there is no god but Allah, being assured of it in his heart, with the announcement that he would go to Paradise. Thereupon 'Umar struck me on the breast and I fell on my back. He then said: Go back, Abu Huraira, So I returned to the Messenger of Allah (may peace be upon him), and was about to break into tears. 'Umar followed me closely and there he was behind me. The Messenger of Allah (may peace and blessings be on him) said: What is the matter with you, Abu Huraira? I said: I happened to meet 'Umar and conveyed to him the message with which you sent me. He struck me on my breast which made me fall down upon my back and ordered me to go back. Upon this the Messenger of Allah (may peace be upon him) said: What prompted you to do this, 'Umar? He said: Messenger of Allah, my mother and father be sacrificed to thee, did you send Abu Huraira with your sandals to gladden anyone he met and who testified that there is no god but Allah, and being assured of it in his heart, with the tidings that he would go to Paradise? He said: Yes. Umar said: Please do it not, for I am afraid that people will trust in it alone; let them go on doing (good) deeds. The Messenger of Allah (may peace be upon him) said: Well, let them.

Book 1, Number 0051:

    It is reported on the authority of Anas b. Malik that the Prophet of Allah (may peace and blessings be upon him) addressed Mu'adh b. Jabal as he was riding behind him to which he replied: At thy beck and call, and at thy pleasure, Messenger of Allah. He again called out: Mu'adh, to which he (again) replied: At thy beck and call, and at thy pleasure. He (the Holy Prophet) addressed him (again): Mu'adh, to which he replied: At thy beck and call, and at thy pleasure, Messenger of Allah. Upon this he (the Holy Prophet) observed: If anyone testifies (sincerely from his heart) that there is no god but Allah, and that Muhammad is His bondsman and His messenger, Allah immuned him from Hell. He (Mu'adh) said: Messenger of Allah, should I not then inform people of it, so that they may be of good cheer? He replied: Then they would trust in it alone. Mu'adh told about it at the time of his death, to avoid sinning.

Book 1, Number 0052:

    It is narrated on the authority of 'Itban b. Malik that he came to Medina and said: Something had gone wrong with my eyesight. I, therefore, sent (a message to the Holy Prophet): Verily it is my ardent desire that you should kindly grace my house with your presence and observe prayer there so, that I should make that corner a place of worship.He said: The Prophet (may peace be upon him) came there,and those amongst the Companions whom Allah willed also accompanied him. He entered (my place) and offered prayer at my residence and his Companions began to talk amongst themselves (and this conversation centered round hypocrites), and then the conspicuous one, Malik b. Dukhshum was made the target and they wished that he (the Holy Prophet) should curse him and he should die or he should meet some calamity. In the meanwhile the Messenger of Allah (may peace and blessings be upon him) completed his prayer and said: Does Malik b. Dukhshum not testify the fact that there is no god but Allah and verily I am the messenger of Allah. They replied: He makes a profession of it (no doubt) but does not do it out of (sincere) heart. He (the Holy Prophet) said: He who testifies that there is no god but Allah and I am the messenger of Allah would not enter Hell or its (flames) would not consume him. Anas said: This hadith impressed me very much and I told my son to write it down.

Book 1, Number 0053:

    It is narrated on the authority of Anas that 'Itban b. Malik told him that he became blind. He sent a message to the Messenger of Allah (may peace be upon him) that he should come and mark a place of worship for him. Thereupon came the Messenger of Allah (may peace be upon him) and his people and then there was a discussion among them about a man who was known as Malik b. Dukhshum, and subsequently the narrator described the hadith of Sulaiman b. Mughira as stated above.

Chapter 12 : HE RELISHED THE FLAVOR OF IMAN WHO WAS PLEASED WITH ALLAH AS HIS LORD

Book 1, Number 0054:

    It is narrated on the authority of 'Abbas b. 'Abdul-Muttalib that he heard the Messenger of Allah saying: He relished the flavor of faith (Iman) who became the book of faith pleased with Allah as Lord, with al-Islam as the code of life and with Muhammad as the Messenger (of Allah).

Chapter 13 : CONCERNING THE BRANCHES OF IMAN

Book 1, Number 0055:

    It is narrated on the authority of Abu Huraira that the Prophet (may peace be upon him) said: Iman has over seventy branches, and modesty is a branch of Iman.

Book 1, Number 0056:

    It is narrated on the authority of Abu Huraira that the Messenger of Allah (may peace and blessings be upon him) said: Faith has over seventy branches or over sixty branches, the most excellent of which is the declaration that there is no god but Allah, and the humblest of which is the, removal of what is injurious from the path: and modesty is the branch of faith.

Book 1, Number 0057:

    Salim reported on the authority of his father that the Prophet (may peace and blessings be upon him) heard a man instruction his brother about modesty. Upon this the Prophet remarked: Modesty is an ingredient of Iman (faith).

Book 1, Number 0058:

    Zuhri has narrated this hadith with the addition of these words: He (the Holy Prophet) happened to pass by a mass of Ansar who was instructing his brother (about modesty).

Book 1, Number 0059:

    It is narrated on the authority of 'Imran b. Husain that the Prophet (may peace and blessings be upon him) said: Modesty brings forth nothing but goodness. Bushair b. Ka'b said: It is recorded in the books of wisdom, there lies sobriety in it and calmness of mind in it, Imran said: I am narrating to you the tradition of the Messenger of Allah (may peace and blessings be upon him) and you talk of your books.

Book 1, Number 0060:

    It is narrated on the authority of Qatada. We were sitting with 'Imran b. Husain in a company and Bushair ibn Ka'b was also amongst us. 'Imran narrated to us that on a certain occasion the Messenger of Allah (may peace and blessings be upon him) said: Modesty is a virtue through and through, or said: Modesty is a goodness complete. Upon this Bushair ibn Ka'b said: Verily we find in certain books or books of (wisdom) that it is God-inspired peace of mind or sobriety for the sake of Allah and there is also a weakness in it. Imran was so much enraged that his eyes became red and he said: I am narrating to you the hadith of the Messenger of Allah (may peace be upon him) and you are contradicting it. He (the narrator) said: Imran reported the hadith, He (the narrator) said: Bushair repeated,(the same thing). Imran was enraged. He (the narrator) said: We asserted: Verily Bushair is one amongst us. Abu Nujaid ! There is nothing wrong, with him (Bushair).

Book 1, Number 0061:

    Ishaq b. Ibrahim narrates this hadith of the Holy Prophet on the authority of Imran b. Husain, like the one narrated by Hammad b. Zaid.

Chapter 14 : CONCERNING THE COMPREHENSIVE ATTRIBUTES OF ISLAM

Book 1, Number 0062:

    It is narrated on the authority of Sufyan b. 'Abdulla al-Thaqafi that he said: I asked the Messenger of Allah to tell me about Islam a thing which might dispense with the necessity of my asking anybody after you. In the hadith of Abu Usama the (words) are: other than you. He (the Holy Prophet) remarked: Say I affirm my faith in Allah and then remain steadfast to it.

Chapter 15 : CONCERNING THE EMINENCE OF ISLAM AND OF THE AFFAIRS WHICH ARE EXCELLENT

Book 1, Number 0063:

    It is narrated on the authority of 'Abdullah b. 'Amr that a man asked the Messenger of Allah (may peace and blessings be upon him) which of the merits (is superior) in Islam. He (the Holy Prophet) remarked: That you provide food and extend greetings to one whom you know or do not know.

Book 1, Number 0064:

    'Abdullah b. Amr b. al-As is reported to have said: Verily a person asked the Messenger of Allah (may peace and blessings be upon him) who amongst the Muslims was better. Upon this (the Holy Prophet) remarked: From whose hand and tongue the Muslims are safe.

Book 1, Number 0065:

    It is narrated on the authority of Jabir that he heard the (Holy Prophet) say: A Muslim is he from whose hand and tongue the Muslim's are safe.

Book 1, Number 0066:

    It is narrated on the authority of Abu Musa Ash'ari : I asked the Messenger of Allah which (attribute) of Islam is more excellent. Upon this he remarked: One in which the Muslims are safe, protected from the tongue and hand of (other Muslims). Ibrahim b. Sa'id al-Jauhari has narrated this hadith with the same words in addition to these. The Messenger of Allah (may peace and blessings be upon him) was asked as to who amongst the Muslims is better, and the rest of the hadith was narrated like this.

Chapter 16 : CONCERNING THE ATTRIBUTES BY WHICH ONE GETS THE RELISH OF IMAN

Book 1, Number 0067:

    It is reported on the authority of Anas that the Prophet of Allah (may peace and blessings be upon him ) said: There are three qualities for which anyone who is characterised by them will relish the sweetness of faith: he to whom Allah and His Messenger are dearer than all else; he who loves a man for Allah's sake alone; and he who has as great an abhorrence of returning to unbelief after Allah has rescued him from it as he has of being cast into Hell.

Book 1, Number 0068:

    It is reported on the authority of Anas that the Messenger of Allah (may peace be upon him) said: There are three qualities for which any one who is characterised by them will relish the savour of faith: that he loves man and he does not love him but for Allah's sake alone; he is to whom Allah and His Messenger are dearer than all else; he who prefers to be thrown into fire than to return to unbelief after Allah has rescued him out of it.

Book 1, Number 0069:

    A similar hadith has been reported on the authority of Anas (with another chain of transmitters) with the exception of these words: that he again becomes a Jew or a Christian.

Chapter 17 : IT IS OBLIGATORY TO LOVE THE PROPHET MORE THAN THE MEMBERS OF ONE'S HOUSEHOLD: ONE'S CHILD, FATHER OR EVEN THE WHOLE OF HUMANITY

Book 1, Number 0070:

    It is reported on the authority of Anas that the Messenger of Allah (may peace be upon him) said: No bondsman believes, and, in the hadith narrated by Abdul Warith, no person believes, till I am dearer to him than the members of his household, his wealth and the whole of mankind.

Book 1, Number 0071:

    It is reported on the authority of Anas b. Malik that the Messenger of Allah said: None of you is a believer till I am dearer to him than his child, his father and the whole of mankind.

Chapter 18 : CONCERNING THE FACT THAT IT IS ONE OF THE CHARACTERISTICS OF IMAN THAT ONE SHOULD LIKE THE SAME THING FOR ONE'S BROTHER-IN-ISLAM AS ONE LIKES FOR ONE'S SELF

Book 1, Number 0072:

    It is arrested on the authority of Anas b. Malik that the Prophet (may peace and blessings be upon him) observed: one amongst you believes (truly) till one likes for his brother or for his neighbour that which he loves for himself.

Book 1, Number 0073:

    It is narrated on the authority of Anas that the Prophet (may peace blessings be upon him) observed: By Him in whose Hand is my life, no, bondsman (truly) believes till he likes for his neighbour, or he (the Holy Prophet) said: for his brother, whatever he likes for himself.

Chapter 19 : CONCERNING THE PROHIBITION TO HARM NEIGHBOUR

Book 1, Number 0074:

    It is narrated on the authority of Abu Huraira that the Messenger of Allah (may peace and blessing be upon him) observed: He will not enter Paradise whose neighbour is not secure from his wrongful conduct.

Chapter 20 : CONCERNING EXHORTATION TO ACCORD HONOUR AND RESPECT TO THE NEIGHBOUR AND TO THE GUEST AND OBLIGATION TO OBSERVE SILENCE EXCEPT IN GOODNESS, AND ALL THESE QUALITIES COME WITHIN THE ORBIT OF IMAN

Book 1, Number 0075:

    It is reported on the authority of Abu Huraira that the Messenger of Allah (may peace be upon him) observed: He who believes in Allah and the Last Day should either utter good words or better keep silence; and he who believes in Allah and the Last Day should treat his neighbour with kindness and he who believes in Allah and the Last Day should show hospitality to his guest.

Book 1, Number 0076:

    It is reported on the authority of Abu Huraira that the Messenger of Allah (may peace and blessings be upon him) observed: He who believes in Allah and the Last Day does not harm is neighbour, and he who believes in Allah and the Last Day shows hospitality to his guest and he who believes in Allah and the Last Day speaks good or remains silent.

Book 1, Number 0077:

    Another hadith similar to one narrated (above) by Abu Husain is also reported by Abu Huraira with the exception of these words: He (the Prophet) said: He should do good to the neighbour.

Book 1, Number 0078:

    It is narrated on the authority of Abu Shuraih al-Khuzai' that the Prophet (may peace and blessings of Allah be upon him) observed: He who believes in Allah and the Last Day should do good to his neighbour and he who believes in Allah and the Last Day should show hospitality to the guest and he who believes in Allah and the Last Day should either speak good or better remain silent.

Chapter 21 : CONCERNING THE FACTS THAT INTERDICTION AGAINST ABOMINABLE IS A PART OF FAITH, THAT FAITH INCREASES AND DIMINISHES; ENJOINING THAT WHICH IS GOOD AND FORBIDDING THAT WHICH IS ABOMINABLE ARE OBLIGATORY (ACTS)

Book 1, Number 0079:

    It is narrated on the authority of Tariq b. Shihab: It was Marwan who initiated (the practice) of delivering khutbah (address) before the prayer on the 'Id day. A man stood up and said: Prayer should precede khutbah. He (Marwan) remarked, This (practice) has been done away with. Upon this Abu Sa'id remarked: This man has performed (his duty) laid on him. I heard the Messenger of Allah as saying: He who amongst you sees something abominable should modify it with the help of his hand; and if he has not strength enough to do it, then he should do it with his tongue, and if he has not strength enough to do it, (even) then he should (abhor it) from his heart, and that is the least of faith.

Book 1, Number 0080:

    The same hadith of the Holy Prophet (may peace and blessings be upon him) has been reported by Abu Sa'id al-Khudri in connection with the story of Marwan.

Book 1, Number 0081:

    It is narrated on the authority 'Abdullah b. Mas'ud that the Messenger of Allah (may peace and blessings be upon him) observed: Never a Prophet had been sent before me by Allah towards his nation who had not among his people (his) disciples and companions who followed his ways and obeyed his command. Then there came after them their successors who said whatever they did not practise, and practised whatever they were not commanded to do. He who strove against them with his hand was a believer: he who strove against them with his tongue was a believer, and he who strove against them with his heart was a believer and beyond that there is no faith even to the extent of a mustard seed. Abu Rafi' said: I narrated this hadith to 'Abdullah b. 'Umar; he contradicted me. There happened to come 'Abdullah b. Mas'ud who stayed at Qanat, and 'Abdullah b 'Umar wanted me to accompany him for visiting him(as 'Abdullah b. Mas'ud was ailing), so I went along with him and as we sat (before him) I asked Ibn Mas'ud about this hadith. He narrated it in the same way as I narrated it to Ibn 'Umar.

Book 1, Number 0082:

    The same hadith has been transmitted by another chain of narrators on the authority of 'Abdullah b. Mas'ud who observed: Never was there one among the prophets who had had not disciples who followed his direction and followed his ways. The remaining part of the hadith is like that as narrated by Salih but the arrival of Ibn Mas'ud and the meeting of Ibn 'Umar with him is not mentioned.

Chapter 22 : PRECEDENCE OF THE BELIEVERS OVER ONE ANOTHER AND THE SUPERIORITY OF THE PEOPLE OF YEMEN IN THIS RESPECT

Book 1, Number 0083:

    It is narrated on the authority of Ibn Mas'ud that the Apostle of Allah (may peace and blessings be upon him) pointed towards Yemen with his hand and said: Verily Iman is towards this side, and harshness and callousness of the hearts is found amongst the rude owners of the camels who drive them behind their tails (to the direction)where emerge the two horns of Satan, they are the tribes of Rabi'a and Mudar.

Book 1, Number 0084:

    It is narrated on the authority of Abu Huraira that the Messenger of Allah observed: There have come the people of Yemen; they are tender of hearts, the belief is that of the Yemenites, the understanding (of the faith) is that of the Yemenites and sagacity is that of the Yemenites.

Book 1, Number 0085:

    Abu Huraira reported the same hadith which is transmitted to us by another chain of transmitters, e.g. Muhammad b. al-Muthanna, Ishaq b. Yusuf Azraq, Ibn 'Aun, etc.

Book 1, Number 0086:

    Abu Huraira reported: The Messenger of Allah (may peace and blessings be upon him) observed: There came to you the people from Yemen; they are tender of hearts and mild of feelings, the understanding is Yemenite, the sagacity is Yemenite.

Book 1, Number 0087:

    It is narrated on the authority of Abu Huraira that the Messenger of Allah (may peace and blessings be upon him) remarked: The summit of unbelief is towards the East and the pride and conceitedness is found among the owners of horses and camels who are rude and uncivil, people of the tents, and tranquillity is found among those who rear goats and sheep.

Book 1, Number 0088:

    It is narrated on the authority of Abu Huraira that the Messenger of Allah (may peace and blessings be upon him) observed: The belief is among the Yemenites, and the unbelief is towards the East, and tranquillity is among those who rear goats and sheep, and pride and simulation is among the uncivil and rude owners of horses and camels.

Book 1, Number 0089:

    It is reported on the authority of Abu Huraira: I heard the Messenger of Allah saying this: Pride and conceitedness is found among the uncivil owners of the camels and tranquillity is found among the owners of sheep and goats.

Book 1, Number 0090:

    The same hadith has been narrated by Zuhri with the same chain of authorities with the addition: The belief is among the Yemenites, the sagacity is that of the Yemenites.

Book 1, Number 0091:

    Abu Huraira said: I heard the Prophet (may peace and blessings be upon him) saying: There came the people of Yemen, they are tender of feelings and meek of hearts. The belief is that of the Yemenites, the sagacity is that of the Yemenites, the tranquillity is among the owners of goats and sheep, and pride and conceitedness is among the uncivil owners of the camels, the people of the tents in the direction of sunrise.

Book 1, Number 0092:

    It is reporter on the authority of Abu Huraira that the Messenger of Allah (may peace and blessings be upon him) observed: There came the people of Yemen who are soft of hearts, tender in feelings: the belief is that of the Yemenites, the sagacity is that of the Yemenites and the summit of unbelief is towards the East.

Book 1, Number 0093:

    Qutaiba b. Sa'id and Zubair b. Harb say: Jarir narrated this on the authority of A'mash with the same chain of narrators (as mentioned above).

Book 1, Number 0094:

    Shu'ba narrated the hadith as reported by Jarir with the same chain of narrators with this addition : Pride and conceitedness is among the owners of the camels and tranquillity and sobriety is found amongst the owners of sheep.

Book 1, Number 0095:

    It is reported on the authority of Jabir b. Abdullah that the Messenger of Allah (may peace and, blessings be upon him) observed: The callousness of heart and sternness is in the East and faith is among the people of the Hijaz.

Chapter 23 : CONCERNING THE FACT THAT NO ONE WILL ENTER PARADISE EXCEPT BELIEVERS, THAT LOVE FOR BELIEVERS IS (A CHARACTERISTIC FEATURE OF) FAITH AND GIVING CURRENCY TO (THE PRACTICE OF PAYING SALUTATION BY SAYING) AS-SALAMU'ALAIKUM (PEACE BE UPON YOU) IS THE MEANS TO ACHIEVE IT (FAITH)

Book 1, Number 0096:

    Abu Huraira reported: The Messenger of Allah (may peace and blessing be upon him) observed: You shall not enter Paradise so long as you do not affirm belief (in all those things which are the articles of faith) and you will not believe as long as you do not love one another. Should I not direct you to a thing which, if you do, will foster love amongst you: (i.e.) give currency to (the practice of paying salutation to one another by saying) as-salamu alaikum.

Book 1, Number 0097:

    Zuhair b. Harb said: Jarir reported on the authority of A'mash with this chain of transmitters that the Messenger of Allah (may peace be upon him) observed: By him in Whose hand is my life, you shall not enter Paradise unless you believe. The rest of the hadith is the same as narrated by Abd Mu'awiya and Waki'.

Chapter 24 : DIN IS SINCERITY AND GOOD-WILL

Book 1, Number 0098:

    It is narrated on the authority of Tamim ad-Dari that the Apostle of Allah (may peace and blessings be upon him) observed: Al-Din is a name of sincerity and well wishing . Upon this we said: For whom? He replied: For Allah, His Book, His Messenger and for the leaders and the general Muslims.

Book 1, Number 0099:

    Muhammad b. Hatim and others narrate the same hadith of the Apostle (may peace and blessings be upon him) on the authority of Tamim ad-Dari.

Book 1, Number 0100:

    Umayya b. Bistam narrates the same hadith of the Messenger of Allah (may peace and blessings be upon him) on the authority of Tamim ad-Dari.

Book 1, Number 0101:

    It is narrated on the authority of Jarir that he observed I gave pledge of allegiance to the Messenger of Allah(may peace and blessings be upon him) on the observance of prayer, payment of Zakat, and sincerity and well-wishing for every Muslim.

Book 1, Number 0102:

    Sufyan narrated on the authority of Ziyad b. 'Ilaqa that he heard Jarir b. 'Abdullah saying: I pledged allegiance to the Apostle of Allah may peace and blessings be upon him) on sincerity and well-wishing for every Muslim.

Book 1, Number 0103:

    It is narrated on the authority of Jarir that he observed: I owed allegiance to the Apostle of Allah (may peace and blessings be upon him) on hearing ( is commands) and obeying (them) and the Prophet) instructed me (to act) as lay in my power, and sincerity and goodwill for every Muslim.

Chapter 25 : CONCERNING DIMINUTION OF BELIEF DUE TO SINS AND ITS SEPARATION FROM THE SINNER: NEGATION OF THE EXCELLENCE OF IMAN AT THE TIME OF COMMITTING SIN

Book 1, Number 0104:

    Abu Huraira reported that the Messenger of Allah observed : The fornicator who fornicates is not a believer so long as he commits it and no thief who steals is a believer as long as he commits theft, and no drunkard who drinks wine is a believer as long as he drinks it. 'Abdul-Malik b. Abi Bakr' narrated this on the authority of Abu Bakr b. Abdur-Rahman b. Harith and then said: Abu Huraira made this addition : No plunderer who plunders a valuable thing that attracts the attention of people is a believer so long as he commits this act.

Book 1, Number 0105:

    'Abdul-Malik b. Shu'aib narrated this hadith on the authority of Abu Huraira that he observed: The Messenger of Allah said that a fornicator does not fornicate, and then narrated the hadith like this, and he also made mention of plundering too, but did not mention of a thin having value. Ibn Shihab said: Sa'id b. al-Musayyib and Abu Salama narrated this hadith on the authority of Abu Huraira a hadith like that of Abu Bakr with the exception of (the mention) of plundering.

Book 1, Number 0106:

    Muhammad b. Mihran narrates this hadith on the authority of Abu Huraira and made mention of plundering but did not talk of (a thing) having value.

Book 1, Number 0107:

    Imam Muslim has reported this hadith by Hasan b. 'Ali al-Halwani and other traditions.

Book 1, Number 0108:

    It is reported on the authority of Qutaiba b. Sa'id who reported on the authority of Abu Huraira the hadith like that narrated from Zuhri with this exception that in the hadith narrated by 'Ala ' and Safwan b. Sulaim there is no mention of: People raise there eyes towards him, and in the hadith narrated by Hammam: The believers raise their eyes towards him, and such like words, so long as he plunders (is not) a believer, and these words were added: And no exploiter who makes an exploitation is a believer as long as he exploits It; therefore avoid and shun (these evils).

Book 1, Number 0109:

    It is narrated on the authority of Abu Huraira: A fornicator who fornicates is not a believer as long as he commits fornication, and no one who steals is a believer as long as he commits theft, and no one who drinks wine is a believer as long as he drinks it, and repentance may be accepted after that.

Book 1, Number 0110:

    Muhammad b. Rafi', Abdur-Razzaq, Sufyan, A'mash narrated this hadith like one narrated by Shu'ba, on the authority of Abu Huraira tracing, it (right to the Holy Prophet).

Chapter 26 : CONCERNING THE PECULIARITIES OF A HYPOCRITE

Book 1, Number 0111:

    It is narrated on the authority of Abdullah b. 'Amr that the Prophet observed: Four characteristics made anyone who possessed them, a sheer hypocrite; anyone who possessed one of them possessed a characteristic of hypocrisy till be abandons it: when he talked he lied, when he made a covenant he acted treacherously, and when he quarreled he deviated from the truth.

Book 1, Number 0112:

    It is reported on the authority of Abu Huraira that the Messenger of Allah (may peace and blessings be upon him) said: Three are the signs of a hypocrite: when he spoke he told a lie, when he made a promise he acted treacherously against it, when he was trusted he betrayed.

Book 1, Number 0113:

    Abu Huraira reported that the Messenger of Allah (may peace and blessings be upon him) observed: There are three characteristics of a hypocrite: when he spoke he told a lie, when he made promise he acted treacherously, and when he was trusted he betrayed.

Book 1, Number 0114:

    'Uqba b. Mukarram al-'Ami reported that he heard 'Ala' b. 'Abdur-Rahman narrating this hadith with this chain of transmitters and he said: Three are the signs of a hypocrite, even if he observed fast and prayed and asserted that he was a Muslim.

Book 1, Number 0115:

    It is reported on the authority of Abu Huraira that the Messenger of Allah (may peace and blessings of Allah be upon him) made observations like them embodied in the hadith narrated by Yahya b. Muhammad on the authority of 'Ala', and added to it: even if he observed fast and prayed and asserted that he was a Muslim.

Chapter 27 : THE CONDITION OF THE FAITH OF ONE WHO CALLS HIS BROTHER MUSLIM AN UNBELIEVER

Book 1, Number 0116:

    It is reported on the authority of Ibn 'Umar that the Apostle (may peace and blessings be upon him) observed: When a man calls his brother an unbeliever, it returns (at least) to one of them.

Book 1, Number 0117:

    It is reported on the authority of Ibn 'Umar that the Messenger of Allah (may peace and blessings be upon him) said: Any person who called his brother: or unbeliever (has in fact done an act by which this unbelief) would return to one of them. If it were so, as he asserted (then the unbelief of man was confirmed but if it was not true), then it returned to him (to the man who labeled it on his brother Muslim).

Chapter 28 : THE CONDITION OF THE FAITH OF ONE WHO KNOWINGLY DENIES HIS TRUE PARENTAGE

Book 1, Number 0118:

    It is reported on the authority of Abu Dharr that he heard the Messenger of Allah (may peace and blessings be upon him) saying: No person who claimed knowingly anyone else as his father besides(his own)committed nothing but infidelity, and he who made a claim of anything, which (in fact) did not belong to him, is not amongst us; he should make his abode in Fire, and he who labeled anyone with unbelief or called him the enemy of Allah, and he was in fact not so, it rebounded on him.

Book 1, Number 0119:

    It is narrated on the authority of Abu Huraira that the Messenger of Allah (may peace and blessings be upon him) observed: Do not detest your fathers; he who detested his father committed infidelity.

Book 1, Number 0120:

    It is reported on the authority of Sa'd b. Abi Waqqas: Both of my ears heard the Messenger of Allah saying this: He who claimed the fatherhood of anyone else besides his real father knowingly (committed a great sin);Paradise is forbidden to him. Abu Bakra asserted that he too heard it from the Messenger of Allah (may peace be upon him ).

Book 1, Number 0121:

    Sa'd and Abu Bakra each one of them said: My ears heard and my hearing preserved it that Muhammad (peace and blessings be upon him) observed: He who claimed for another one his fatherhood besides his own father knowingly that he was not his father-to him Paradise is forbidden.

Chapter 29 : ABUSING A MUSLIM IS AN OUTRAGE AND FIGHTING AGAINST HIM IS UNBELIEF

Book 1, Number 0122:

    It is narrated on the authority of 'Abdullah b. Mas'ud that the Messenger of Allah (may peace and blessings be upon him) observed: Abusing a Muslim is an outrage and fighting against him is unbelief. Zubaid said: I asked Abu Wa'il: Did you hear it from Abdullah narrating if from the Messenger of Allah (may peace and blessings be upon him)? He replied: Yes. But there is mention of the talk between Zubaid and Abu Wa'il in the hadith narrated by Shu'ba.

Book 1, Number 0123:

    Abu Bakr b. Abu Shaiba narrated a hadith like this from the Apostle (may peace and blessings be upon him) on the authority of Abdullah.

Chapter 30 : DON'T BECOME UNBELIEVERS AFTER ME BY STRIKING THE NECKS OF 0NE ANOTHER

Book 1, Number 0124:

    It is narrated on the authority of Jarir b. 'Abdullah that the Apostle of Allah (may peace and blessings be upon him) asked him on the occasion of the Farewell Pilgrimage to make the people silent and then said: Do not return to unbelief after me by striking the necks of one another.

Book 1, Number 0125:

    Abdullah b. Mu'adh narrated from the Apostle(may peace and blessings be upon him) a hadith like this on the authority on Ibn Umar.

Book 1, Number 0126:

    It is narrated on the authority of Abdullah b. Umar that the Apostle(may peace and blessings be upon him) observed on the occasion of the Farewell Pilgrimage Woe unto you distress unto you! Don't turn back as unbelievers after me by striking the necks of one another.

Book 1, Number 0127:

    Harmala b. Yahya, Abdullah b. Wahb, Umar b. Muhammad, Ibn Umar narrated like the hadith reported by Shu'ba on the authority of Waqid.

Chapter 31 : THE USE OF THE WORD "UNBELIEF" IN CASE OF SLANDERING (ANYONE) OR ONE'S LINEAGE, AND LAMENTATION

Book 1, Number 0128:

    It is narrated on the authority of Abu Huraira that the Messenger of Allah (may peace and blessings be upon him) observed: Two (things) are found among men which are tantamount to unbelief: slandering one's lineage and lamentation on the dead.

Chapter 32 : CALLING THE FUGITIVE SLAVE AS INFIDEL

Book 1, Number 0129:

    It is narrated on the authority of Jarir that he heard (the Holy Prophet) saying, The slave who fled from his master committed an act of infidelity as long as he would not return to him. Mansur observed: By God, this hadith was narrated from the Apostle (may peace and blessings be upon him), but I do not like that this should be narrated on my authority here in Basra.

Book 1, Number 0130:

    It is narrated on the authority of Jarir that the Messenger of Allah (may peace and blessings be upon him) observed: The slave who fled from his master, responsibility with regard to him was absolved.

Book 1, Number 0131:

    Jarir b. Abdullah reported it from the Holy Prophet: When the slave runs away from his master, his prayer is not accepted.

Chapter 33 : THE UNBELIEF OF ONE WHO SAID: WE GOT RAINFALL BY THE MOVEMENT (OF THE STARS)

Book 1, Number 0132:

    It is narrated on the authority of Zaid b. Khalid al-Juhani: The Messenger of Allah (may peace and blessings be upon him) led the morning prayer at Hudaybiya. There were some marks of the rainfall during the night. At the conclusion of prayer he turned towards people and observed: Do you know what your Lord has said? They replied: Allah and His Messenger know best. Upon this he (the Holy Prophet) remarked: He (Allah) said: Some of My bondsmen entered the morning as My believers and some as unbelievers. He who said: We have had a rainfall due to the Blessing and Mercy of Allah, he is My believer and a disbeliever of stars, and who said: We have had a rainfall due to the rising of such and such (star) disbelieved Me and affirmed his faith in the stars.

Book 1, Number 0133:

    It is reported on the authority of Abu Huraira that the Messenger of Allah (may peace and blessings be upon him) said: Don't you know what your Lord said? He observed: I have never endowed My bondsmen with a favor, but a section amongst them disbelieved it and said: Stars, it was due to the stars.

Book 1, Number 0134:

    It is reported on the authority of Abu Huraira that the Messenger of Allah (may peace and blessing be upon him) observed: Allah does not shower His blessings from the heaven that in the morning a group of men disbelieve it (to be a blessing from Allah). Allah sends down rain, but they (the disbelievers) say: Such and such star (is responsible for that).

Book 1, Number 0135:

    It is reported on the authority of Ibn 'Abbas that there was (once) a downpour during the life of the Apostle (may peace and blessings be upon him Upon this the Apostle (may peace and blessings be upon him) observed: Some people entered the morning with gratitude and some with ingratitude (to Allah). Those who entered with gratitude said: This is the blessing of Allah, and those who entered with ingratitude said: Such and such asterism was right. It was upon this that the verse was revealed:

      I swear by the setting of the stars to the end and make your provision that you should disbelieve it.

Chapter 34 : THE LOVE OF ANSAR (HELPERS) AND 'ALI (MAY ALLAH BE PLEASED WITH ALL OF THEM) IS (AN INGREDIENT) OF IMAN AND (ONE OF) ITS SIGNS, AND HATRED AGAINST THEM IS A SIGN OF DISSEMBLANCE

Book 1, Number 0136:

    It is reported on the authority of Anas that the Messenger of Allah (may peace and blessings Be upon him) observed: The sign of a hypocrite is the hatred against the Ansar and the sign of a believer is the love for the Ansar.

Book 1, Number 0137:

    It is narrated on the authority of Anas that the Apostle(may peace and blessings be upon him) said: The love of the Ansar is the sign of faith and hatred against them is the sign of dissemblance.

Book 1, Number 0138:

    Al-Bara reported it from the Apostle(may peace and blessing be upon him) that he observed with regard to the Ansar, None but the believer loves them, none but the hypocrite hates them. He who loved them loved Allah and he who hated them hated Allah. I (the narrator) said: Did you hear this hadith from al-Bara'? He said: To me, he narrated it.

Book 1, Number 0139:

    It is reported on the authority of Abu Huraira that the Messenger of Allah (may peace and blessings be upon him) said: A person who believes in Allah and the Last Day never nurses a grudge against the Ansar.

Book 1, Number 0140:

    It is narrated on the authority of Abu Sa'id Khudri that the Messenger of Allah observed: The person who believes in Allah and the Last Day never nurses a grudge against the Ansar.

Book 1, Number 0141:

    Zirr reported: 'Ali observed: By Him Who split up the seed and created something living, the Apostle(may peace and blessings be upon him) gave me a promise that no one but a believer would love me, and none but a hypocrite would nurse grudge against me.

Chapter 35 : DIMINUTION OF IMAN BY FAILING IN SUBMISSION AND THE USE OF THE WORD "KUFR" FOR THINGS BESIDES UNBELIEF OF ALLAH, FOR EXAMPLE UNGRATEFULNESS AND INGRATITUDE

Book 1, Number 0142:

    It is narrated on the authority of 'Abdullah b. Umar that the Messenger of Allah observed: O womenfolk, you should give charity and ask much forgiveness for I saw you in bulk amongst the dwellers of Hell. A wise lady among them said: Why is it, Messenger of Allah, that our folk is in bulk in Hell ? Upon this the Holy Prophet observed: You curse too much and are ungrateful to your spouses. I have seen none lacking in common sense and failing in religion but (at the same time) robbing the wisdom of the wise, besides you. Upon this the woman remarked: What is wrong with our common sense and with religion? He (the Holy Prophet) observed: Your lack of common sense (can be well judged from the fact) that the evidence of two women is equal to one man, that is a proof of the lack of common sense, and you spend some nights (and days) in which you do not offer prayer and in the month of Ramadan (during the days) you do not observe fast, that is a failing in religion. This hadith has been narrated on the authority of Abu Tahir with this chain of transmitters.

Book 1, Number 0143:

    A hadith like this as narrated by Ibn 'Umar has also been transmitted by Abu Huraira.

Chapter 36 : APPLICATION OF THE WORD "KUFR" TO ONE WHO NEGLECTS PRAYER

Book 1, Number 0144:

    It is narrated on the authority of Abu Huraira that when, the son of Adam recites the Ayat of Sajdah (prostration) and then falls down in prostration, the Satan goes into seclusion and weeps and says: Alas, and in the narration of Abu Kuraib the words are: Woe unto me, the son of Adam was commanded to prostrate, and he prostrated and Paradise was entitled to him and I was commanded to prostrate, but I refused and am doomed to Hell.

Book 1, Number 0145:

    A'mash narrated this hadith with the same chain of transmitters, with this change of words that he (the Satan) said: I disobeyed and I am doomed to Hell.

Book 1, Number 0146:

    It is narrated on the authority of Jabir that he heard the Apostle (may peace and blessings be upon him) saying. Verily between man and between polytheism and unbelief is the negligence of prayer.

Book 1, Number 0147:

    It is narrated on the authority of Abu Zubair that he heard Jabir b. 'Abdullah saying. I heard the Messenger of Allah (may peace and blessings be upon him) observing this: Between man and polytheism and unbelief is the abandonment of salat.

Chapter 37 : BELIEF IN ALLAH IS THE BEST OF DEEDS

Book 1, Number 0148:

    Abu Huraira reported: The Messenger of Allah was asked about the best of deeds. He observed: Belief in Allah. He (the inquirer) said: What next? He (the Holy Prophet) replied: Jihad (struggle to the utmost) in the cause of Allah. He (the inquirer) again said: What next? He (the Holy Prophet) replied: Pilgrimage accepted into the grace of the Lord. In the. tradition narrated on the authority of Muhammad b. Ja'far (the words are) that he (the Holy Prophet) said: Belief in Allah and His Messenger. Muhammad b. Rafi and 'Abd b. Humaid, 'Abdur-Razzaq and Ma'mar and Zuhri have narrated a hadith like this on the authority of the same chain of transmitters.

Book 1, Number 0149:

    Abu Dharr reported: I said: Messenger of Allah, which of the deeds is the best? He (the Holy Prophet) replied: Belief in Allah and Jihad in His cause. I again asked: Who is the slave whose emancipation is the best ? He (the Holy Prophet) replied: One who is valuable for his master and whose price is high. I said: If I can't afford to do it? He (the Holy Prophet) replied: Help an artisan or make anything for the unskilled (labourer). I (Abu Dharr) said: Messenger of Allah, you see that I am helpless in doing some of these deeds. He (the Holy Prophet) replied: Desist from doing mischief to the people. That is the charity of your person on your behalf.

Book 1, Number 0150:

    Muhammad b. Abu Rafi' narrated the hadith on the authority of Abu Dharr with a slight difference.

Book 1, Number 0151:

    It is narrated on the authority of 'Abdullah b. Mas'ud that he observed. I asked the Messenger of Allah (may peace be upon him) which deed was the best. He (the Holy Prophet) replied: Prayer at its appointed hour. I (again) said: Then what? He (the Holy Prophet) replied: Kindness to the parents. I (again) said: Then what? He replied: Earnest endeavour (Jihad) in the cause of Allah. And I would have not ceased asking more questions but out of regard (for his feelings).

Book 1, Number 0152:

    'Abdullah b. Mas'ud reported: I said: Messenger of Allah, which of the deeds (takes one) nearer to Paradise ? He (the Holy Prophet) replied: Prayer at its proper time, I said: What next, Messenger of Allah? He replied: Kindness to the parents. I said: What next? He replied: Jihad in the cause of Allah.

Book 1, Number 0153:

    It was heard from Abu 'Amr Shaibani that, pointing towards the house of Abdullah, he said: The owner of this house told me that he asked the Messenger of Allah (may peace be upon him): Which of the deeds are liked by Allah? He (the Holy Prophet) observed: Prayer at its proper time. I (again) said: What next ? He replied: Then goodness to the parents. I (again) said: What then? He replied: Then Jihad in the cause of Allah. He ('Abdullah) said: This is what I was told (by the Holy Prophet). Had I questioned further, he would have made additions for me.

Book 1, Number 0154:

    This hadith has been transmitted by Muhammad b. Bashshar, Muhammad b. Ja'far Shu'ba with this chain of narrators, with the addition that he pointed towards the house of 'Abdullah, but he did not mention his name for us.

Book 1, Number 0155:

    It is reported on the authority of 'Abdullah that the Apostle of Allah observed: The best of' the deeds or deed is the (observance of) prayer at its proper time and kindness to the parents.

Chapter 38 : POLYTHEISM IS THE MOST SHAMEFUL OF SINS AND THE MENTIONING OF THE GRAVEST SIN NEXT TO IT

Book 1, Number 0156:

    'Abdullah reported: I asked the Messenger of Allah (may peace be upon him): Which sin is the gravest in the eye of Allah? He (the Holy Prophet) replied: That you associate a partner with Allah (despite the fact) that He has created you. He (the reporter) said: I told him (the, Holy Prophet) : Verily it is indeed grave. He (the reporter) said: I asked him what the next (gravest sin) was. He (the Holy Prophet) replied: That you kill your child out of fear that he shall join you in food. He (the reporter)said: I asked (him) what the next (gravest sin)was. He (the Holy Prophet) observed : Then (the next gravest sin) is that you commit adultery with the wife of your neighbour.

Book 1, Number 0157:

    It is narrated on the authority of Abdullah b. Mas'ud that a man said: Messenger of Allah, which offence is the most grievous in the eye of Allah? He (the Holy Prophet) replied: That you associate a partner with Allah (despite the fact) that He created you. He (the man) said: What next? He (the Holy Prophet) replied: That you kill your child out of fear that he would join you in food. He (the inquirer) said (again): What next? He (the Holy Prophet) replied: That you commit adultery with the wife of your neighbour. And the Almighty and Exalted Lord testified it (with this verse) :

      All those who call not unto another god along with Allah, and slay not any soul which Allah has forbidden, except in the cause of justice, nor commit fornication, and he who does this shall meet a requital of sin (xxv. 68).

Chapter 39 : MAJOR SINS AND THE GRAVEST AMONG THESE

Book 1, Number 0158:

    It is narrated on the authority of 'Abdur-Rahman b. Abu Bakra that his father said: We were in the company of the Messenger of Allah (may peace be upon him) that he observed: Should I not inform you about the most grievous of the grave sins? (The Holy Prophet) repeated it three times, and then said: Associating anyone with Allah, disobedience to parents, false testimony or false utterance. The Holy Prophet was reclining, then he sat up, and he repeated it so many times that we wished that he should become silent.

Book 1, Number 0159:

    Anas narrated from the Apostle (may peace be upon him) about the major sins. He (the Holy Prophet) observed: Associating anyone with Allah, disobedience to parents, killing a person and false utterance.

Book 1, Number 0160:

    Ubaidullah b. Abu Bakr said: I heard Anas b. Malik saying: The Messenger of Allah (may peace be upon him) talked about the major sins, or he was asked about the major sins. Upon this he observed: Associating anyone with Allah, killing of a person, disobedience to parents. He (the Holy Prophet further) said: Should I not inform you about the gravest of the major sins, and (in this connection) observed: False utterance or false testimony. Shu'ba said . It was most probably "false testimony".

Book 1, Number 0161:

    It is reported on the authority of Abu Huraira that the Messenger of Allah (may peace be upon him) observed: Avoid the seven noxious things. It was said (by the hearers): What are they, Messenger of Allah? He (the Holy Prophet) replied: Associating anything with Allah, magic, killing of one whom God has declared inviolate without a just cause, consuming the property of an orphan, and consuming of usury,turning back when the army advances, and slandering chaste women who are believers, but unwary.

Book 1, Number 0162:

    It is narrated on the authority of 'Abdullah b. Amr b. al-'As that the Messenger of Allah (may peace be upon him) observed: Abusing one's parents is one of the major sins. They (the hearers) said: Messenger of Allah, does a man abuse his parents too? He (the Holy Prophet) replied: Yes, one abuses the father of another man, who in turn abuses his father. One abuses his mother and he in turn abuses his (the former's) mother.

Book 1, Number 0163:

    This hadith has also been transmitted on the authority of Sa'd b. Ibrahim with this chain of narrators.

Chapter 40 : FORBIDDANCE OF PRIDE

Book 1, Number 0164:

    It Is narrated on the authority of Abdullah b. Mas'ud that the Apostle of Allah (may peace be upon him), observed: He who has in his heart the weight of a mustard seed of pride shall not enter Paradise. A person (amongst his hearers) said: Verily a person loves that his dress should be fine, and his shoes should be fine. He (the Holy Prophet) remarked: Verily, Allah is Graceful and He loves Grace. Pride is disdaining the truth (out of self-conceit) and contempt for the people.

Book 1, Number 0165:

    It is narrated on the authority of 'Abdullah b. Mas'ud that the Messenger of Allah (may peace be upon him) observed: None shall enter the Fire (of Hell) who has in his heart the weight of a mustard seed of Iman and none shall enter Paradise who has in his heart the weight of a mustard seed of pride.

Book 1, Number 0166:

    It is narrated on the authority of 'Abdullah that the Apostle of Allah (may peace be upon him) observed: He who as in his heart the weight of a mustard seed of pride shall not enter Paradise.

Chapter 41 : HE WHO DIES ASSOCIATING NONE WITH ALLAH WOULD ENTER PARADISE AND HE WHO DIES AS A POLYTHEIST WOULD ENTER THE FIRE OF HELL

Book 1, Number 0167:

    It is narrated on the authority of Abdullah b. Mas'ud that Waki told (him) that the Messenger of Allah had observed and Ibn Numair asserted: I heard the Messenger of Allah (may peace be upon him) saying: He who dies associating anything with Allah would enter the Fire (of Hell). 'Abdullah b. Mas'ud said: I say that he who died without associating anything with Allah entered Paradise.

Book 1, Number 0168:

    It is narrated on the authority of Jabir that a man came to the Apostle of Allah (may peace be upon him) and said: Messenger of Allah, what are the two things quite unavoidable? He replied: He who dies without associating anyone with Allah would (necessarily) enter Paradise and he who dies associating anything with Allah would enter the (Fire of) Hell.

Book 1, Number 0169:

    It is narrated on the authority of Jabir b. Abdullah: I heard the Messenger of Allah (may peace be upon him) saying: He who met Allah without associating anything with Allah entered Paradise and he who met Him associating (anything) with Him entered Fire.

Book 1, Number 0170:

    The same hadith has been narrated by Ishaq b. Mansur on the authority of Jabir with another chain of transmitters.

Book 1, Number 0171:

    I heard Abu Dharr narrating it from the Apostle (may peace be upon him) that he observed: Gabriel came to me and gave me the tidings: Verily he who died amongst your Ummah without associating anything with Allah would enter Paradise. I (the narrator) said: Even if he committed adultery and theft. He (the Holy Prophet) said: (Yes), even if he committed adultery and theft.

Book 1, Number 0172:

    Abu Dharr reported,: I came to the Apostle (may peace be upon him ) and he was asleep with a white mantle over him. I again came, he was still asleep, I came again and he had awakened. I sat by his side and (the Holy Prophet) observed: There is none among the bondsmen who affirmed his faith in La illaha ill-Allah there is no God but Allah) and died in this state and did not enter Paradise. I (Abu Dharr) said: Even if he committed adultery and theft? He (the Holy Prophet) replied : (Yes) even though he committed adultery and theft. I (again said) : Even if he committed adultery and theft ? He replied : (Yes) even though he committed adultery and theft. (Th Holy Prophet repeated it three times) and said for the fourth time: In defiance of Abu Dharr. Abu Dharr then went out and he repeated (these words): In defiance of Abu Dharr.

Chapter 42 : PROHIBITION OF THE KILLING OF AN INFIDEL AFTER HE SAYS: "THERE IS NO GOD BUT ALLAH"

Book 1, Number 0173:

    It is narrated on the authority of Miqdad b. Aswad that he said. Messenger of Allah, you just see (here is a point) : If I encountered a person amongst the infidels (in the battlefield) and he attacked me and struck me and cut off one of my hands with the sword. Then he (in order to protect himself from me) took shelter of a tree and said: I become Muslim for Allah's sake. Messenger of Allah, can I kill him after he had uttered this? The Messenger of Allah (may peace be upon him) said: Do not kill him. I (the narrator) said: Messenger of Allah , he cut off my hand and uttered this after amputating it; should I then kill him? The Messenger of Allah (may peace be upon him) said: Don't kill him , for I you kill him, verily he would be in a position where you had been before killing him and verily you would be in a position where he had been before uttering (kalima).

Book 1, Number 0174:

    The same hadith has been transmitted by the same chain of narrators. The hadith transmitted by Auza'i and Ibn Juraij contains these words: I embraced Islam for Allah's sake. and in the hadith narrated by Ma'mar the words are: I knelt down to kill him, that he said; There is no god but Allah.

Book 1, Number 0175:

    It is narrated by Miqdad, and he was an ally of B. Zuhra and was of those who participated in the Battle of Badr along with the Messenger of Allah, that he said: Messenger of Allah, here is a point: If I happened to encounter a person amongst the infidels (in the battle). Then he narrated a hadith similar to the one transmitted by Laith.

Book 1, Number 0176:

    It is narrated on the authority of Usama b. Zaid that the Messenger of Allah (may peace be upon him) sent us in a raiding party. We raided Huraqat of Juhaina in the morning. I caught hold of a man and he said: There is no god but Allah, I attacked him with a spear. It once occurred to me and I talked about it to the Apostle (may peace be upon him). The Messenger of Allah (may peace be upon him) said: Did he profess "There is no god but Allah," and even then you killed him? I said: Messenger of Allah, he made a profession of it out of the fear of the weapon. He (the Holy Prophet) observed: Did you tear his heart in order to find out whether it had professed or not ? And he went on repeating it to me till I wished I had embraced Islam that day. Sa'd said: By Allah, I would never kill any Muslim so long as a person with a heavy belly, i.e., Usama, would not kill. Upon this a person remarked: Did Allah not say this: And fight them until there is no more mischief and religion is wholly for Allah ? Sa'd said: We fought so that there should be no mischief, but you and your companions wish to fight so that there should be mischief.

Book 1, Number 0177:

    It is narrated on the authority of Usama b. Zaid: The Messenger of Allah may peace be upon him) sent us to Huraqat, a tribe of Juhaina. We attacked that tribe early in the morning and defeated them and I and a man from the Ansar caught hold of a person (of the defeated tribe). When we overcame him, he said: There is no god but Allah. At that moment the Ansari spared him, but I attacked him with my spear and killed him. The news had already reached the Apostle (peace be upon him), so when we came back he (the Apostle) said to me: Usama, did you kill him after he had made the profession: There is no god but Allah? I said. Messenger of Allah, he did it only as a shelter. The Holy Prophet observed: Did you kill him after he had made the profession that there is no god but Allah? He (the Holy Prophet) went on repeating this to me till I wished I had not embraced Islam before that day.

Book 1, Number 0178:

    It is narrated by Safwan b. Muhriz that Jundab b. 'Abdullah al-Bajali during the stormy days of Ibn Zubair sent a message to 'As'as b. Salama: Gather some men of your family so that I should talk to them. He ('As'as) sent a messenger to them (to the members of his family). When they had assembled, Jundab came there with a yellow hooded cloak on him, He said: Talk what you were busy in talking. The talk went on by turns, till there came his (Jundab's) turn. He took off the hooded cloak from his head and said: I have come to you with no other intention but to narrate to you a hadith of your Apostle: Verily the Messenger of Allah (may peace be upon him) sent a squad of the Muslims to a tribe of the polytheists. Both the armies confronted one another. There was a man among the army of polytheists who (was so dashing that), whenever he intended to kill a man from among the Muslims, he killed him. Amongst the Muslims too was a man looking forward to (an opportunity of) his (the polytheist's) unmindfulness. He (the narrator) said: We talked that he was Usama b, Zaid. When he raised his sword, he (the soldier of the polytheists) uttered: "There is no god but Allah," but he (Usama b. Zaid) killed him. When the messenger of the glad tidings came to the Apostle (may peace be upon him) he asked him (about the events of the battle) and he informed him about the man (Usama) and what he had done He (the Prophet of Allah) called for him and asked him why he had killed him. He (Usama) said: Messenger of Allah, he struck the Muslims and killed such and such of them. And he even named some of them. (He continued): I attacked him and when he saw the sword he said: There is no god but Allah. The Messenger of Allah (may peace be upon him) said: Did you kill him? He (Usama) replied in the affirmative. He (the Holy Prophet) remarked: What would you do with: "There is no god but Allah," when he would come (before you) on the Day of Judgment ? He (Usama) said: Messenger of Allah, beg pardon for me (from your Lord). He (the Holy Prophet) said: What would you do with: "There is no god but Allah" when he would come (before you) on the Day of Judgment? He (the Holy Prophet) added nothing to it but kept saying: What would you do with: "There is no god but Allah," when he would come (before you) on the Day of Judgment?

Chapter 43 : THE UTTERANCE OF THE APOSTLE (MAY PEACE BE UPON HIM): HE WHO TAKES,UP ARMS AGAINST US IS NOT OF US (I.E. HE CEASES TO RE A MUSLIM)

Book 1, Number 0179:

    It is narrated on the authority of Abdullah b. Umar who narrates from the Prophet of Allah (may peace be upon him) who said: He who took up arms against us is not of us.

Book 1, Number 0180:

    Iyas b. Salama narrated from his father that the Apostle (may peace be upon him) observed: He who draws the sword against us is not of us.

Book 1, Number 0181:

    It is narrated on the authority of Abu Musa Ash'ari: He who took up arms against us is not of us.

Chapter 44 : THE UTTERANCE OF THE APOSTLE (PEACE BE UPON HIM): HE WHO ACTED DISHONESTLY TOWARDS US IS NOT OF US (I.E. HE IS NOT TO BE COUNTED AMONGST MUSLIMS)

Book 1, Number 0182:

    It is narrated on the authority of Abu Huraira that the Messenger of Allah (may peace be upon him) observed: He who took up arms against us is not of us and he who acted dishonestly towards us is not of us.

Book 1, Number 0183:

    It is narrated on the authority of Abu Huraira that the Messenger of Allah (may peace be upon him) happened to pass by a heap of eatables (corn). He thrust his hand in that (heap) and his fingers were moistened. He said to the owner of that heap of eatables (corn): What is this? He replied: Messenger of Allah, these have been drenched by rainfall. He (the Holy Prophet) remarked: Why did you not place this (the drenched part of the heap) over other eatables so that the people could see it ? He who deceives is not of me (is not my follower).

Chapter 45 : BEATING OF THE CHEEKS, TEARING OF THE FRONT OPENING OF THE SHIRT, AND CALLING THE CALLS OF THE JAHILIYA (IGNORANCE) ARE FORBIDDEN

Book 1, Number 0184:

    It is narrated on the authority of Abdullah b. Mas'ud that the Holy Prophet observed: He is not one of us (one among the Ummah of Islam) who beat the cheeks or tore the front opening of the shirt or uttered the slogans of (the days of) Jahiliya (ignorance). Ibn Numair and Abu Bakr said (instead of the word "au"(or) it is "wa" [and] the words are) and tore and uttered (the slogans) of Jahiliya without "alif".

Book 1, Number 0185:

    This hadith has been narrated by A'mash with the same chain of narrators and the transmitters said: He tore and called.

Book 1, Number 0186:

    It is narrated on the authority of Abu Burda b. Abu Musa that Abu Musa was afflicted with grave pain and he became unconscious and his head was in the lap of a lady of his household. One of the women of his household walled. He (Abu Musa) was unable (because of weakness) to say anything to her. But when he was a bit recovered he said: I have no concern with one with whom the Messenger of Allah (may peace be upon him) has no concern, Verily the Messenger of Allah (may peace be upon him) has no concern with that woman who wails loudly, shaves her hair and tears (her garment in grief).

Book 1, Number 0187:

    It is narrated on the authority of Abu Burda that Abu Musa fell unconscious and his wife Umm Abdullah came there and wailed loudly. When he felt relief he said: Don't you know?-and narrated to her: Verily the Messenger of Allah (may peace be upon him) said: I have no concern with one who shaved her hair, lamented loudly and tore (her clothes in grief).

Book 1, Number 0188:

    This hadith is narrated on the authority of Abu Musa with this change only: That (the Holy Prophet) did not say that he had no concern but said: He is not one of us.

Chapter 46 : SERIOUS PROHIBITION OF TALE-CARRYING

Book 1, Number 0189:

    It is reported from Hudhaifa that news reached him (the Holy Prophet) that a certain man carried tales. Upon this Hudhaifa remarked: I heard Allah's Messenger (may peace be upon him) saying: The tale-bearer shall not enter Paradise.

Book 1, Number 0190:

    It is reported on the authority of Hammam b, al-Harith that a man used to carry tales to the governor. We were sitting in the mosque. the people said: He is one who carries tales to the governor. He (the narrator) said: Then he came and sat with us. Thereupon Hudhaifa remarked: I heard the Messenger of Allah (may peace be upon him) saying: The beater of false tales would never enter heaven.

Book 1, Number 0191:

    It is narrated on the authority of Hammam b. al-Harith: We were sitting with Hudhaifa in the mosque. A man came and sat along with us. It was said to Hudhaifa that he was the man who carried tales to the ruler. Hudhaifa remarked with the intention of conveying to him: I have heard the Messenger of Allah (may peace be upon him) saying: The tale-bearer will not enter Paradise.

Chapter 47 : SERIOUS PROHIBITION OF LETTING DOWN THE LOWER GARMENT, OF LAYING OBLIGATION, OF SELLING GOODS BY FALSE OATHS, AND DESCRIPTION OF THOSE THREE- (PERSONS) WITH WHOM ALLAH WOULD NOT SPEAK ON THE DAY OF RESURRECTION, NOR WOULD HE SEE T0WARDS THEM NOR WOULD ABSOLVE THEM, AND FOR THEM IS A PAINFUL CHASTISEMENT

Book 1, Number 0192:

    It is narrated o the authority of Abu Dharr that the Messenger of Allah (may ace he upon him) observed: Three are the (persons) with whom Allah would neither speak on the Day of Resurrection, nor would look at them nor would absolve the and there is a painful chastisement for them. The Messenger of Allah (may peace be upon him) repeated it three times. Abu Dharr remarked: They failed and they lost; who are these persons, Messenger of Allah? Upon this he (the Holy) Prophet) observed: They are: the dragger of lower garment, the recounter of obligation the seller of goods by false oath.

Book 1, Number 0193:

    It is narrated on the authority of Abu Dharr who narrates that the Prophet (may peace be upon him) observed: Three are the persons with whom Allah would not speak on the Day of Resurrection: the bestower of gift who does not give anything but by laying obligation on him, the seller of goods who sells them by taking false oath and one who hangs low his lower garment.

Book 1, Number 0194:

    Bishr b. Khalid has narrated this hadith on the authority of Sulaiman with the same chain of transmitters with this addition: Allah shall neither speak nor look at nor absolve then, and there is a tormenting punishment for them.

Book 1, Number 0195:

    It is narrated on the authority of Abu Huraira that the Messenger of Allah (may peace be upon him) observed: Three (are the persons) with whom Allah would neither speak, nor would He absolve them on the Day of Resurrection. Abu Mu'awiya added: He would not look at them and there is grievous torment for them: the aged adulterer, the liar king and the proud destitute.

Book 1, Number 0196:

    Abu Huraira narrated on the authority of Abu Bakr that the Messenger of Allah (may peace be upon him) said: Three are the persons with whom Allah would neither speak on the Day of Resurrection, nor would He look towards them, nor would purify them (from sins), and there would be a tormenting chastisement for them: a person who in the waterless desert has more water (than his need) and he refuses to give it to the traveller and a person who sold a commodity to another person in the afternoon and took an oath of Allah that he had bought it at such and such price and he (the buyer) accepted it to be true though it was not a fact, and a person who pledged allegiance to the Imam but for the sake of the world (material gains). And if the Imam bestowed on him (something) out of that (worldly riches) he stood by his allegiance and if he did not give him, he did not fulfil the allegiance.

Book 1, Number 0197:

    The same hadith has been transmitted by another chain of transmitters with the exception of these words: He offered for sale a commodity to another person.

Book 1, Number 0198:

    This hadith has been narrated on the authority of Abu Huraira that he (the Apostle of Allah)observed: Three are the persons with whom Allah would neither speak (on the Day of Resurrection) nor would He look at them, and there would be a painful chastisement for them, a person who took an oath on the goods of a Muslim in the afternoon and then broke it. The rest of the hadith is the same as narrated by A'mash.

Chapter 48 : SUICIDE IS THE GRAVEST SIN

Book 1, Number 0199:

    It is narrated on the authority of Abu Huraira that the Messenger of Allah (may peace be upon him) observed: He who killed himself with steel (weapon) would be the eternal denizen of the Fire of Hell and he would have that weapon in his hand and would be thrusting that in his stomach for ever and ever, he who drank poison and killed himself would sip that in the Fire of Hell where he is doomed for ever and ever; and he who killed himself by falling from (the top of) a mountain would constantly fall in the Fire of Hell and would live there for ever and ever.

Book 1, Number 0200:

    This hadith has been narrated by another chain of transmitters.

Book 1, Number 0201:

    Thabit b. Dahhak reported that he pledged allegiance to the Messenger of Allah (may peace be upon him) under the Tree, and verily the Messenger of Allah (may peace be upon him) observed: He who took an oath of a religion other than Islam, in the state of being a liar, would became so, as he professed. He who killed himself with a thing would be tormented on the Day of Resurrection with that very thing. One is not obliged to offer votive offering of a thing which is not in his possession.

Book 1, Number 0202:

    It is narrated on the authority of Thabit b. al-Dahhak that the Apostle of Allah (may peace be upon him) observes: None is obliged to give votive offering (of a thing) which is not in his possession and the cursing of a believer is tantamount to killing him, and he who killed himself with a thing in this world would be tormented with that (very thing) on the Day of Resurrection, and he who made a false claim to increase(his wealth), Allah would make no addition but that of paucity, and he who perjured would earn the wrath of God

Book 1, Number 0203:

    It is narrated on the authority of Thabit b. Dahhak that the Apostle of Allah (may peace be upon him) observed: He who took deliberately a false oath on a religion other than Islam would become that which he had professed. And he who killed himself with anything Allah would torment him with that in the Fire of Hell.

Book 1, Number 0204:

    In the hadith narrated by Shu'ba the words are: Verily the Messenger of Allah (may peace be upon him) said: He who took an oath on a religion other than Islam as a liar would become so as he said, and he who slaughtered himself with a thing would be slaughtered with that on the Day of Resurrection.

Book 1, Number 0205:

    It is narrated on the authority of Abu Huraira: We participated in the Battle of Hunain along with the Messenger of Allah (may peace be upon him). He (the Holy Prophet) said about a man who claimed to be a Muslim that he was one of the denizens of the Fire (of Hell). When we were in the thick of the battle that man fought desperately and was wounded. It was said: Messenger of Allah, the person whom you at first called as the denizen of Fire fought desperately and died. Upon this the Apostle of Allah (may peace be upon him) remarked: He was doomed to the Fire (of Hell). Some men were on the verge of doubt (about his fate) when it was said that he was not dead but fatally wounded. When it was night he could not stand the (pain of his) wound and killed himself. The Apostle (may peace be upon him) was informed of that. He (the Holy Prophet) observed: Allah is Great, I bear testimony to the fact that I am the servant of Allah and His messenger. He then commanded Bilal to announce to the people that none but a Muslim would enter Paradise. Verily Allah helps this faith even by a sinful person.

Book 1, Number 0206:

    It is reported on the authority of Sahl b. Sa'd al-Sa'idi that there was an encounter between the Messenger of Allah (may peace be upon him) and the polytheists, and they fought (against one another). At the conclusion of the battle the Messenger of Allah (may peace be upon him) bent his steps towards his army and they (the enemies) bent their steps towards their army. And there was a person (his name was Quzman and he was one of the hypocrites) among the Companions of the Messenger of Allah (may peace be upon him) who did not spare a detached (fighter of the enemy) but pursued and killed him with the sword. They (the Companions of the Holy Prophet) said: None served us better today than this man Upon this the Messenger of Allah (may peace be upon him) remarked: Verily he is one of the denizens of Fire. One of the people (Muslims) said: I will constantly shadow him. Then this man went out along with him. He halted whenever he halted, and ran along with him whenever he ran. He (the narrator) said: The man was seriously injured. He (could not stand the pain) and hastened his own death. He placed the blade of the sword on the ground with the tip between his chest and then pressed himself against the sword and killed himself. Then the man (following him) went to the Messenger of Allah (may peace be upon him) and said: I bear testimony that verily thou art the Messenger of Allah, He (the Holy Prophet) said: What is the matter? He replied: The person about whom you just mentioned that he was one among the denizens of Fire and the people were surprised (at this) and I said to them that I would bring (the news about him) and consequently I went out in search of him till I (found him ) to be very seriously injured. He hastened his death. He placed the blade of the sword upon the ground and its tip between his chest and then pressed himself against that and killed himself. Thereupon the Messenger of Allah (may peace be upon him) remarked: A person performs the deeds which to the people appear to be the deeds befitting the dweller of Paradise, but he is in fact one of the denizens of Hell. And verily a person does an act which in the eyes of public is one which is done by the denizens of Hell, but the person is one among the dwellers of Paradise.

Book 1, Number 0207:

    It is reported on the authority of Hasan: A person belonging to the people of the past suffered from a boil, when it pained him, he drew out an arrow from the quiver and pierced it. And the bleeding did not stop till he died. Your Lord said: I forbade his entrance into Paradise. Then he (Hasan) stretched his hand towards the mosque and said: By God, Jundab transmitted this hadith to me from the Messenger of Allah (may peace be upon him) in this very mosque.

Book 1, Number 0208:

    It is reported on the authority of Hasan: Jundab b. 'Abdullah al-Bajali narrated this hadith in this mosque which we can neither forget and at the same time we have no apprehension that Jundab could attribute a lie to the Messenger of Allah (may peace be upon him). He (the Holy Prophet) observed: A person belonging to the people of the past suffered from a boil, and then the rest of the hadith was narrated.

Chapter 49 : STRICT FORBIDDANCE OF ACTING DISHONESTLY IN RESPECT OF THE SPOILS OR BOOTY. THE BELIEVERS ALONE WOULD ENTER PARADISE

Book 1, Number 0209:

    It is narrated on the authority of 'Umar b. Khattab that when it was the day of Khaibar a party of Companions of the Apostle (may peace be upon him) came there and said: So and so is a martyr, till they happened to pass by a man and said: So and so is a martyr. Upon this the Messenger of Allah remarked: Nay, not so verily I have seen him in the Fire for the garment or cloak that he had stolen from the booty, Then the Messenger of Allah (may peace be upon him) said: Umar son of Khattab, go and announce to the people that none but the believers shall enter Paradise. He ('Umar b. Khattab) narrated: I went out and proclaimed: Verily none but the believers would enter Paradise.

Book 1, Number 0210:

    It is narrated on the authority of Abu Huraira: We went to Khaibar along with the Apostle (may peace be upon him) and Allah granted us victory. We plundered neither gold nor silver but laid our hands on goods, corn and clothes, and then bent our stops to a valley; along with the Messenger of Allah (may peace be upon him) there was a slave who was presented to him by one Rifa'a b. Zaid of the family of Judham, a tribe of Dubayb. When we got down into the valley the slave of the Messenger of Allah stood up and began to unpack the saddle-bag and was suddenly struck by a (stray) arrow which proved fatal. We said: There is a greeting for him, Messenger of Allah, as he is a martyr. Upon this the Messenger of Allah (may peace be upon him) remarked: Nay, not so. By Him in Whose hand is the life of Muhammad, the small garment which he stole from the booty on the day of Khaibar but which did not (legitimately) fall to his lot is burning like the Fire (of Hell) on him. The people were greatly perturbed (on hearing this). A person came there with a lace or two laces and said: Messenger of Allah, I found (them) on the day of Khaibar. He (the Holy Prophet) remarked: This is a lace of fire or two laces of fire.

Chapter 50 : ARGUMENT IN FAVOUR OF THE FACT THAT HE WHO KILLS HIMSELF DOES NOT BECOME UNBELIEVER

Book 1, Number 0211:

    It is narrated on the authority of Jabir that Tufail son of Amr al-Dausi came to the Apostle (may peace be upon him) and said: Do you need strong, fortified protection? The tribe of Daus had a fort in the pre-Islamic days. The Apostle (may peace be upon him) declined this offer, since it (the privilege of protecting the Holy Prophet) had already been reserved for the Ansar. When the Apostle(may peace be upon him) migrated to Medina, Tufail son of Amr also migrated to that place, and there also migrated along with him a man of his tribe. But the climate of Medina did not suit him, and he fell sick. He felt very uneasy. So he took hold of an iron head of an arrow and cut his finger-joints. The blood streamed forth from his hands, till he died. Tufail son of Amr saw him in a dream. His state was good and he saw him with his hands wrapped. He (Tufail) said to him: What treatment did your Allah accord to you? He replied. Allah granted me pardon for my migration to the Apostle(may peace be upon him): He (Tufail) again said: What is this that I see you wrapping up your hands? He replied: I was told (by Allah): We would not set right anything of yours which you damaged yourself. Tufail narrated this (dream) to the Messenger of Allah (may peace be upon him). Upon this he prayed: O Allah I grant pardon even to his hands.

Continue to next page: Click here


BOOK 1: The Book of Faith (KITAB AL-IMAN) (part II)

KITAB AL-IMAN
(THE BOOK OF FAITH)
(Continued)

Back
Chapter 51 : CONCERNING THE WIND WHICH WOULD BLOW NEAR THE DAY OF RESURRECTION AND WOULD CAUSE TO DIE ANYONE HAVING ANKTHING LIKE FAITH IN HIS HEART

Book 1, Number 0212:

    It is narrated on the authority of Abu Huraira that the Messenger of Allah (may peace be upon him) said: Verily Allah would make a wind to blow from the side of the Yemen more delicate than silk and would spare none but cause him to die who, in the words of Abu 'Alqama, has faith equal to the weight of a grain ; while Abdul-'Aziz said: having faith equal to the weight of a dust particle.

Chapter 52 : EXHORTATION TO BE PROMPT IN DOING GOOD DEEDS BEFORE THE APPEARANCE OF TURBULANCE

Book 1, Number 0213:

    It is narrated on the authority of Abu Huraira that the Messenger of Allah (may peace be upon him) observed: Be prompt in doing good deeds (before you are overtaken) by turbulence which would be like a part of the dark night. During (that stormy period) a man would be a Muslim in the morning and an unbeliever in the evening or he would be a believer in the evening and an unbeliever in the morning, and would sell his faith for worldly goods.

Chapter 53 : PERTAINING TO THE FEAR OF A BELIEVER LEST HIS DEEDS SHOULD BE LOST

Book 1, Number 0214:

    It is narrated on the authority of Anas b. Malik that when this verse: "O ye who believe I raise not your voices above the voice of the Prophet, nor shout loud unto him in discourse, as ye shout loud unto one another, lest your deeds should become null and void, while you perceive not" (xlix. 2-5), was revealed. Thabit b. Qais confined himself in his house and said: I am one of the denizens of Fire, and he deliberately avoided coming to the Apostle (may peace be upon him). The Apostle (may peace be upon him) asked Sa'd b, Mu'adh about him and said, Abu Amr, how is Thabit? Has he fallen sick? Sa'd said: He is my neighbour, but I do not know of his illness. Sa'd came to him (Thabit), and conveyed to him the message of the Messenger of Allah (may peace be upon him). Upon this Thabit said: This verse was revealed, and you are well aware of the fact that, amongst all of you, mine is the voice louder than that of the Messenger of Allah, and so I am one amongst the denizens of Fire, Sa'd Informed the Holy Prophet about it. Upon this the Messenger of Allah observed: (Nay, not so) but he (Thabit) is one of the dwellers of Paradise.

Book 1, Number 0215:

    This hadith has been narrated on the authority of Anas b. Malik by another chain of transmitters in which these words are found: Thabit b. Qais was the orator of the Ansar, when this verse was revealed: the rest of the hadith is the same with the exception that there is no mention of Sa'd b. Mu'adh in it. This hadith is also transmitted by Ahmad b. Sa'id, Habban, Sulaiman b. Mughira on the authority of Anas who said: When the verse was revealed: "Do not raise your voice louder than the voice of the Apostle," no mention was made of Sa'd b, Mu'adh in it.

Book 1, Number 0216:

    This hadith is narrated on the authority of Anas by another chain of transmitters in which there is no mention of Sa'd b. Mu'adh, but the following words are there: We observed a man, one of the dwellers of Paradise, walking about amongst us.

Chapter 54 : WOULD (PEOPLE) BE HELD RESPONSIBLE FOR THE DEEDS COMMITTED DURING THE STATE OF IGNORANCE?

Book 1, Number 0217:

    It is narrated on the authority of Abdullah b. Mas'ud that some people said to the Messenger of Allah (may peace be upon him): Messenger of Allah, would we be held responsible for our deeds committed in the state of ignorance (before embracing Islam)? Upon his he (the Holy Prophet) remarked: He who amongst you performed good deeds in Islam , He would not be held responsible for them (misdeeds which he committed in ignorance) and he who committed evil (even after embracing Islam) would be held responsible or his misdeeds that he committed in the state of ignorance as well as in that of Islam.

Book 1, Number 0218:

    It is narrated on the authority of Abdullah b. Mas'ud: We once said: Messenger of Allah, would we be held responsible for our deeds committed in the state of ignorance? He (the Holy Prophet) observed: He who did good deeds in Islam would not be held responsible for what he did in the state of ignorance, but he who committed evil (after having come within the fold of Islam) would be held responsible for his previous and later deeds.

Book 1, Number 0219:

    This hadith has been transmitted by Minjab b. al-Harith Tamimi with the same chain of transmitters.

Chapter 55 : ISLAM EFFACES ALL THE PREVIOUS MISDEEDS AND SO DO MIGRATION AND PILGRIMAGE

Book 1, Number 0220:

    It is narrated on the authority of Ibn Shamasa Mahri that he said: We went to Amr b. al-As and he was about to die. He wept for a long time and turned his face towards the wall. His son said: Did the Messenger of Allah (may peace be upon him not give you tidings of this? Did the Messenger of Allah (may peace be upon him) not give you tidings of this? He (the narrator) said: He turned his face (towards the audience) and said: The best thing which we can count upon is the testimony that there is no god but Allah and that Muhammad is the Apostle of Allah. Verily I have passed through three phases. (The first one) in which I found myself averse to none else more than I was averse to the Messenger of Allah (may peace be upon him) and there was no other desire stronger in me than the one that I should overpower him and kill him. Had I died in this state, I would have been definitely one of the denizens of Fire. When Allah instilled the love of Islam in my heart, I came to the Apostle (may peace be upon him) and said: Stretch out your right hand so that may pledge my allegiance to you. He stretched out his right hand, I withdrew my hand, He (the Holy Prophet) said: What has happened to you, O 'Amr? replied: I intend to lay down some condition . He asked: What condition do you intend to put forward? I said: should be granted pardon. He (the Holy Prophet) observed: Are you not aware of the fact that Islam wipes out all the previous (misdeeds) ? Verily migration wipes out all the previous (misdeeds), and verily the pilgrimage wipes out all the (previous) misdeeds. And then no one as or dear to me than the Messenger of Allah and none was more sublime in my eyes than he, Never could I, pluck courage to catch a full glimpse of his face due to its splendour. So if I am asked to describe his features, I cannot do that for I have not eyed him fully. Had I died in this state had every reason to hope that I would have bee among the dwellers of Paradise. Then we were responsible for certain things (in the light of which)I am unable to know what is in store for me. When I die, let neither female mourner nor fire accompany me. When you bury me, fill my grave well with earth, then stand around it for the time within which a camel is slaughtered and its meat is distributed so that I may enjoy your intimacy and (in your company) ascertain what answer I can give to the messengers (angels) of Allah.

Book 1, Number 0221:

    It is narrated on the authority of Ibn 'Abbas that some persons amongst the polytheist had committed a large number of murders and had excessively indulged in fornication. Then they came to Muhammad (may peace be upon him) and said: Whatever you assert and whatever you call to is indeed good. But if you inform us that there is atonement of our past deeds (then we would embrace Islam). Then it was revealed :

      And those who call not unto another god along with Allah and slay not any soul which Allah has forbidden except in the cause of justice, nor commit fornication; and he who does this shall meet the requital of sin. Multiplied for him shall be the torment on the Day of Resurrection, and he shall therein abide disgraced, except him who repents a believes and does good deeds. Then these! for the Allah shall change their vices into virtues. Verily Allah is Ever Forgiving, Merciful (xxv. 68-70).

      Say thou: O my bondsmen woo have committed extravagance against themselves despair not of the Mercy of Allah I Verily Allah will forgive the sins altogether. He is indeed the Forgiving, the Merciful (xxxix. 53).

Chapter 56 : PERTAINING TO THE VIRTUOUS ACT OF A MAN BEFORE EMBRACING ISLAM

Book 1, Number 0222:

    Hakim b. Hizam reported to 'Urwa b. Zubair that he said to the Messenger of Allah: Do you think that there is any thing for me (of he reward with the Lord) for the deed of religious purification that I did in the state of ignorance? Upon this he (the Apostle of Allah) said to him : You accepted Islam with all the previous virtues that you practised.

Book 1, Number 0223:

    Hakim b. Hizam reported to 'Urwa b. Zubair that he said to the Messenger of Allah (may peace be upon him): Messenger of Allah, do you think if there is any reward (of the Lord with me on the Day of Resurrection) for the deeds of religious purification that I performed in the state of ignorance, such as charity, freeing a slave, cementing of blood-relations ? Upon this he (the Apostle of Allah) said to him: You have accepted Islam with all the previous virtues that you had practised.

Book 1, Number 0224:

    It is narrate on the authority of Hakim b. Hizam: I said: Messenger of Allah , I did so some of the deeds in the state of ignorance. (One of the transmitters Hisham b. Urwa explained them as acts of piety. Upon this the Messenger, of Allah remarked: You have embraced Islam with all the previous acts of virtue. I said: By God, I would leave nothing undone in Islam the like of which I did in the state of ignorance.

Book 1, Number 0225:

    Hisham b. Urwa narrated it on the authority of his father: Hakim b. Hizam freed one hundred slave and donated one hundred camels (for the sake of Allah) during the state of ignorance. Then he freed one hundred slaves and donated one hundred camel(for the sake of Allah) after) he had embraced Islam. He subsequently came to the Apostle (may peace be upon him). The rest of the hadith is the same as narrated above.

Chapter 57 : THE VERACITY OF FAITH AND ITS SINCERITY

Book 1, Number 0226:

    It is narrated on the authority of 'Abdullah (b. Mas'ud) that when this verse was revealed: "It is those who believe and confound not their belief with wrongdoing" (vi. 82), the Companions of the Messenger of Allah wore greatly perturbed. They said: Who amongst us (is so fortunate) that he does not wrong himself? Upon this the Messenger of Allah (may peace be upon him) remarked: It does not mean that which you presume It implies that which Luqman said to his son: O my son, do not associate anything with Allah, for indeed it is the gravest wrongdoing (xxxi. 13).

Book 1, Number 0227:

    This hadith is narrated by another chain of transmitters, (namely) lshaq b. Ibrahim. Ibn Idris says: My father transmitted it from Aban b. Taghlib who heard it from A'mash; then I heard it also from him (A'mash).

Chapter 58 : CONCERNING THE WORDS OF ALLAH WHETHER YOU MANIFEST WHATEVER IS IN YOUR MIND OR HIDE IT

Book 1, Number 0228:

    It is reported on the authority of Abu Huraira that when it was revealed to the Messenger of Allah (may peace be upon him): To Allah belongs whatever is in the heavens and whatever is in the earth and whether you disclose that which is in your mind or conceal it, Allah will call you to account according to it. Then He forgives whom He pleases and chastises whom He Pleases; and Allah is over everything Potent"(ii. 284). the Companions of the Messenger of Allah (may peace be upon him) felt it hard and severe and they came to the Messenger of Allah (may peace be upon him) and sat down on their knees and said: Messenger of Allah, we were assigned some duties which were within our power to perform, such as prayer, fasting, struggling (in the cause of Allah), charity. Then this (the above-mentioned) verse was revealed unto you and it is beyond our power to live up to it. The Messenger of Allah (may peace be upon him) said: Do you intend to say what the people of two books (Jews and Christians) said before you: "We hear and disobey"? You should rather say: "We hear and we obey, (we seek) Thy forgiveness, our Lord! and unto Thee is the return." And they said: "We hear and we obey, (we seek) Thy forgiveness, Our Lord! and unto Thee is the return." When the people recited it and it smoothly flowed on their tongues, then Allah revealed immediately afterwards: "The Apostle believes in that which is sent down unto him from his Lord, and so do the believers. Each one believes in Allah and His Angels and His Books and His Apostles, saying: We differentiate not between any of His Apostles and they say: We hearken and we obey: (we seek) Thy forgiveness, our Lord! and unto Thee is the return" (ii. 285). When they did that, Allah abrogated this (verse) and the Great, Majestic Allah revealed: "Allah burdens not a soul beyond its capacity. It gets every good that it earns and it suffers every ill that it earns. Our Lord, punish us not if we forget or make a mistake." (The Prophet said:) Yes, our Lord! do not lay on us a burden as Thou didst lay on those before us. (The Prophet said:) Yes, our Lord, impose not on us (burdens) which we have not the strength to bear (The Prophet said:) Yes, and pardon us and grant us protection! and have mercy on us. Thou art our Patron, so grant us victory over the disbelieving people" (ii. 286). He (the Lord) said: Yes.

Book 1, Number 0229:

    It is narrated on the authority of Ibn 'Abbas: When this verse: "Whether you disclose that which is in your mind or conceal it, Allah will call you to account according to it" (ii 284), there entered in their minds something (of that fear) such as had never entered their hearts (before). The Apostle (may peace be upon him) observed: Say: We have heard and obeyed and submitted ourselves. He (the reporter) said: Allah instilled faith in their hearts and He revealed this verse: "Allah burdens not a soul beyond its capacity. It gets every good that it earns and it suffers every ill that it earns. Our Lord, call us not to account if we forget or make a mistake. He the (Lord) said: I indeed did it. Our Lord! do not lay on us a burden as Thou didst lay on those before us. He (our Lord) said: I indeed did it. And pardon us, have mercy on us. Thou art our Protector" (ii. 286). He said: I indeed did it.

Chapter 59 : ALLAH DISREGARDS THE PREMONITION OR THE EVIL PROMPTINGS OF THE HEART SO LONG AS THEY DO NOT TAKE A FIRM ROOT

Book 1, Number 0230:

    It is narrated on the authority of Abu Huraira that the Messenger of Allah (may peace be upon him) observed: Verily Allah forgave my people the evil promptings which arise within their hearts as long as they did not speak about them or did not act upon them.

Book 1, Number 0231:

    It is narrated on the authority of Abu Huraira that the Messenger of Allah (may peace be upon him) observed: Verily the Great and Mighty Allah forgave my people the evil promptings arising in their minds, but they neither talked about them nor acted upon them.

Book 1, Number 0232:

    The same hadith has been narrated by Zuhair b. Harb, Waki, Ishaq b. Mansur, Husain b. 'Ali.

Chapter 60 : WHENEVER A PERSON INTENDS TO DO A GOOD DEED, IT IS RECORDED BUT WHENEVER HE INTENDS TO COMMIT EVIL, IT IS NOT WRITTEN

Book 1, Number 0233:

    It is narrated on the authority of Abu Huraira that the Messenger of Allah (may peace be upon him) said: The Great and the Glorious Lord said (to angels) : Whenever My bondsman intends to corn it an evil, do not record it against him, but if he actually commits it, then write it as one evil. And when he intends to do good but does not do it, then take it down is one act of goodness, but if he does it, then write down ten good deeds (in his record).

Book 1, Number 0234:

    It is narrated on the authority of Abu Huraira that the Messenger of Allah (may peace be upon him) observed: Allah, the Great and Glorious, said: Whenever my bondsman intends to do good, but does not do it, I write one good act for him, but if he puts it into practice I wrote from ten to seven hundred good deeds in favour of him. When he intends to commit an evil, but does not actually do it, do not record it. But if he does it, I write only one evil.

Book 1, Number 0235:

    Abu Huraira reported that Muhammad, the Messenger of Allah (may peace be upon him), said: When it occurs to my bondsman that he should do a good deed but he actually does not do it, record one good to him, but if he puts it into practice, I make an entry of ten good acts in his favour. When it occurs to him to do evil, but he does not commit it, I forgive that. But if he commits it, I record one evil against his name. The Messenger of Allah (may peace be upon him) observed. The angels said: That bondsman of Yours intends to commit evil. though His Lord is more Vigilant than he. Upon this He (the Lord) said: Watch him; if he commits (evil), write it against his name but if he refrains from doing it, write one good deed or him, for he desisted from doing it for My sake. The Messenger of Allah said: He who amongst you is good of faith, all his good acts are multiplied from ten to seven hundred times (and are recorded in his name) and all the evils that he commits are recorded as such (i,e. without increase) till he meets Allah.

Book 1, Number 0236:

    It is narrated on the authority of Abu Huraira that the Messenger of Allah (may peace be upon him) observed: He who intended to do good, but did not do it, one good was recorded for him, and he who intended to do good and also did it, ten to seven hundred good deeds were recorded for him. And he who intended evil, but did not commit it, no entry was made against his name, but if he committed that, it was recorded.

Book 1, Number 0237:

    It is narrated on the authority of Ibn Abbas that the Messenger of Allah (may peace be upon him) transmitted it from the Blessed and Great Lord: Verily Allah recorded the good and the evil and then made it clear that he who intended good but did not do it, Allah recorded one complete good in his favour, but if he intended it and also did it, the Glorious and Great Allah recorded ten to seven hundred virtues and even more to his credit. But it he intended evil, but did not commit it, Allah wrote down full one good in his favour. If he intended that and also committed it,Allah made an entry of one evil against him.

Book 1, Number 0238:

    This hadith has been narrated with another chain of transmitters with the addition of these words: Allah would even wipe out (the evil committed by a man) and Allah does not put to destruction anyone except he who is doomed to destruction.

Chapter 61 : PERTAINING TO EVIIL SUGGESTION OR PROMPTING IN FAITH AND WHAT SHOULD BE SAID WHEN IT OCCURS TO THE MIND OF A MAN

Book 1, Number 0239:

    It is narrated on the authority of Abu Huraira that some people from amongst the Companions of the Apostle (may peace be upon him) came to him and said: Verily we perceive in our minds that which every one of us considers it too grave to express. He (the Holy Prophet) said: Do you really perceive it? They said : Yes. Upon this he remarked: That is the faith manifest.

Book 1, Number 0240:

    The same hadith has been transmitted by Muhammad b. 'Amr, Abu Baker b. Ishaq, Abu'l-Jawwab, A'mash and Abu Huraira.

Book 1, Number 0241:

    It is narrated on the authority of 'Abdullah b. Mas'ud that the Apostle (may peace be upon him) was asked about evil prompting, to which he replied: It is pure faith.

Book 1, Number 0242:

    It is narrated on the authority of Abu Huraira that the Messenger of Allah (may peace be upon him) said: Men will continue to question one another till this is propounded: Allah created all things but who created Allah? He who found himself confronted with such a situation should say: I affirm my faith in Allah.

Book 1, Number 0243:

    This hadith has been transmitted by Mahmud b. Ghailan by another chain of transmitters (and the words are) : The Messenger of Allah (may peace be upon him) said: The Satan will come to everyone of you and say: Who created the heaven, who created the earth? (And the man) replies: It is Allah, Then the remaining part of the hadith was narrated as mentioned above and the words 'His prophets" were added to it.

Book 1, Number 0244:

    It is narrated on the authority of Abu Huraira that the Messenger of Allah may peace be upon him) observed : The Satan comes to everyone. of you and says : Who created this and that? till he questions: Who created your Lord? When he comes to that, one should seek refuge in Allah and keep away (from such idle thoughts).

Book 1, Number 0245:

    This hadith is transmitted by Urwa b. Zubair on the authority of Abu Huraira (and the words are):The Satan comes to the bondsman (of Allah) and says: Who created this and that? The remaining part of the hadith is the same.

Book 1, Number 0246:

    It is narrated on the authority of Abu Huraira that the Apostle of Allah (may peace be upon him) observed: People will constantly ask you questions pertaining to knowledge till they would say: Allah created us, but who created Allah? he (the narrator) says: he (Abu Huraira) was (at the time of narrating this hadith) catching hold of the hand of a man and he said: Allah and the Messenger told the truth. Two persons have already put me this question, and this is the third one, or he said: One man has put me this question and he is the second one.

Book 1, Number 0247:

    It is narrated on the authority of Abu Huraira that he said: The people will constantly, and the rest of the hadith is the same as that transmitted by 'Abdul-Warith with the exception that there is no mention of the Apostle of Allah in that, but he observed at the end of the hadith: Allah and His Messenger told the truth.

Book 1, Number 0248:

    Abu Huraira reported: The Messenger of Allah (may peace be upon him) said to me: they (the people) till constantly ask you, Abu Huraira, (about different things pertaining to religion) the they would say: Well, there is Allah, but after all who created Allah? He (Abu Huraira) narrated: Once we were in the mosque that some of the Bedouins came there and said: Well, there is Allah, but who created Allah? He (the narrator) said: I took hold of the pebbles in my fist and flung at them and remarked: Stand up, stand up (go away) my friend (the Holy Prophet) told the truth.

Book 1, Number 0249:

    Yazid b. al-Asamm said: I heard Abu Huraira saying that the Messenger of Allah (may peace be upon him) observed: people will certainly ask you about everything till they will propound: Allah created every thing, but who created Allah?

Book 1, Number 0250:

    Anas b. Malik transmitted it from the Messenger of Allah (may peace be upon him) that the Great and Glorious Allah said: Verily your people would constantly question about this and that till they would say: Well, it is Allah Who created the creation, but who created Allah?

Book 1, Number 0251:

    This hadith has been narrated by another chain of transmitters with the exception that Ishaq made no mention of this: Allah said: Verily your people.

Chapter 62 : WARNING FOR ONE APPROPRIATING THE RIGHT OF A MUSLIM BY TAKING A FALSE OATH: THE FIRE (OF HELL) IS HIS CHASTISEMENT

Book 1, Number 0252:

    It is narrated on the authority of Abu Umama that the Messenger of Allah (may peace be upon him) observed: He who appropriated the right of a Muslim by (swearing a false) oath, Allah would make Hell-fire necessary for him and would declare Paradise forbidden for him. A person said to him : Messenger of Allah, even if it is something insignificant? He (the Holy Prophet) replied:(Yes)even if it is the twig of the arak tree.

Book 1, Number 0253:

    This hadith has been transmitted by another chain of narrators: Abu Bakr b. Abi Shaiba, Ishaq b. Ibrahim, Harun b. Abdullah, Abi Usama, Walid b. Kathir, Muhammad b. Ka'b, his brother Abdullah b. Ka'b and Abi Usama.

Book 1, Number 0254:

    It is narrated on the authority of Abdullah (b. Umar) that the Messenger of Allah (may peace be upon him) observed : He who perjured with a view to appropriating the property of a Muslim , and he is in fact a liar and would meet Allah in a state that He would be angry with him . He (the narrator) said : There came Ash'ath b. Qais and said (to the people): What does Abu Abdur-Rahman (the Kunya of Abdullah b. Umar) narrate to you? They replied : So and so. Upon this he remarked: Abu Abdur-Rahman told the truth. This (command) has been revealed in my case. There was a piece of land in Yemen over which I and another person had a claim. I brought the dispute with him to the Apostle of Allah (to decide) He (the Holy Prophet) said: Can you produce an evidence (in your support) ? I said: No. He (the Holy Prophet) observed: (Then the decision would be made) on his oath. I said : He would readily take an oath. Upon this the Messenger of Allah (may peace be upon him) remarked : He who perjured for appropriating the wealth of a Muslim, whereas he is a liar, would meet Allah while He would be angry with him. This verse was then revealed : "Verily those who barter Allah's covenant and their oaths at a small price . . ." (iii 77).

Book 1, Number 0255:

    It is narrated on the authority of Abdullah that he heard the Prophet (may peace be upon him) saying: He who took an oath in order to entitle himself (to the possession) of a property, whereas he is a liar, would meet Allah in a state that He would be very much angry with him. Then the remaining part of the hadith was narrated as transmitted by A'mash but with the exception of these words: There was a dispute between me and another person in regard to a well. We referred this dispute to the Messenger of Allah (may peace be upon him). Upon this he remarked : Either (you should produce) two witnesses (to support your contention) or his oath (would be accepted as valid).

Book 1, Number 0256:

    Ibn Mas'ud says: I heard the Messenger of Allah observing: He who took an oath on the property of a Muslim without legitimate right would meet Allah and He would be angry, with him. Then the Messenger of Allah (may peace be upon him) in support of his contention recited the verse : "Verily those who barter Allah's covenant and their oaths at a small price.

Book 1, Number 0257:

    It is narrated on the authority of Wa'il that there came a person from Hadramaut and another one from Kinda to the Apostle (may peace be upon him). One who had come from Hadramaut said : Messenger of Allah, only this man has appropriated my land which belonged to my father. The one who had came from Kinda contended . This is my land and is in my possession: I cultivate it. There is no right for him in it. The Messenger of Allah said to the Hadramite: Have you any evidence (to support you)? He replied in the negative. He (the Apostle of Allah) said: Then your case is to be decided on his oath. He (the Hadramite) said: Messenger of Allah, he is a liar and cares not what he swears and has no regard for anything. Upon this he (the Messenger of Allah) remarked: For you then there is no other help to it. He (the man from Kinda) set out to take an oath. When he turned his back the Messenger of Allah (may peace be upon him) observed: If he took an oath on his property with a view to usurping it, he would certainly meet his Lord in a state that He would turn away from him.

Book 1, Number 0258:

    Wa'il reported it on the authority of his father Hujr: I was with the Messenger of Allah (may peace be upon him) that two men came there disputing over a piece of land. One of them said: Messenger of Allah, this man appropriated my land without justification in the days of ignorance. The (claimant) was Imru'l-Qais b.'Abis al-Kindi and his opponent was Rabi'a b. 'Iban He (the Holy Prophet) said (to the claimant): Have you evidence (to substantiate your claim) ? He replied: I have no evidence. Upon this he (the Messenger of Allah) remarked: Then his (that is of the defendant) is the oath. He (the claimant) said: In this case he (the defendant) would appropriate this (the property). He (the Holy Prophet) said: There is than no other way left for you but this. He (the narrator) said: When he (the defendant) stood up to take oath, the Messenger of Allah (may peace be upon him) said: He who appropriated the land wrongfully would meet Allah in a state that He would be angry with him. Ishaq in his narration mentions Rabi'a b. 'Aidan (instead of Rabi'a b. 'Ibdan).

Chapter 63 : CONCERNING THE FACT THAT VIOLABLE IS THE BLOOD OF ONE WHO MAKES AN ATTEMPT TO TAKE POSSESSION OF THE PROPERTY OF ANOTHER WITHOUT ANY LEGITIMATE RIGHT. IF SUCH MAN IS KILLED HIS ABODE IS FIRE AND HE WHO DIES IN PROTECTING HIS PROPERTY IS A MARTYR

Book 1, Number 0259:

    Abu Huraira reported: A person came to the Messenger of Allah (may peace be upon him) and said: Messenger of Allah, what do you think if a man comes to me in order to appropriate my possession ? He (the Holy Prophet) said: Don't surrender your possession to him. He (the inquirer) said: If he fights me? He (the Holy Prophet) remarked: Then fight (with him). He (the inquirer) again said: What do you think if I am killed? He (the Holy Prophet) observed: You would be a martyr. He (the inquirer) said : What do you think of him (Messenger of Allah) If I kill him. He (the Holy Prophet) said: he would be in the Fire.

Book 1, Number 0260:

    It is narrated on the authority of Thabit, that when 'Abdullah b. 'Amr and 'Anbasa b. Abi Sufyan were about to fight against each other, Khalid b. 'As rode to 'Abdullah b. 'Amr and persuaded him (not to do so). Upon this Abdullah b. 'Amr said: Are you not aware that the Messenger of Allah (may peace be upon him) had observed: "He who died in protecting his property is a martyr."
    This hadith has been narrated by Muhammad b. Hatim, Muhammad b. Bakr, Ahmad b. 'Uthman Naufali, Abu 'Asim, Ibn Juraij.

Chapter 64 : THE RULER WHO, IS UNJUST TO HIS SUBJECTS DESERVES PUNISHMENT OF FIRE

Book 1, Number 0261:

    Hasan reported : 'Ubaidullah b. Ziyad paid a visit to Ma'qil b. Yasar Muzani in his illness of which he (later on) died. (At this juncture) Ma'qil said: I am going to narrate to you a hadith which I have heard from the Messenger of Allah (may peace be upon him) and which I would not have transmitted if I knew that I would survive. Verily I have heard the Messenger of Allah (may peace be upon him) say: There is none amongst the bondsmen who was entrusted with the affairs of his subjects and he died in such a state that he was dishonest in his dealings with those over whom he ruled that the Paradise is not forbidden for him.

Book 1, Number 0262:

    Hasan reported: Ubaidullah b. Ziyad went to see Ma'qil b. Yasir and he was ailing. He ('Ubaidullah) inquired (about his health) to which he (Ma'qil) replied: I am narrating to you a hadith which I avoided narrating to you (before). Verily the Messenger of Allah (may peace be upon him) observed: Allah does not entrust to his bondsman the responsibility of managing the affairs of his subjects and he dies as a dishonest (ruler) but Paradise is forbidden by Allah for such a (ruler). He (Ibn Ziyad) said: Why did you not narrate it to me before this day ? He replied : I (in fact) did not narrate it to you as it was not (fit) for me to narrate that to you.

Book 1, Number 0263:

    Hasan reported: We were with Ma'qil b. Yasar inquiring about his health that Ubaidullah b. Ziyad came there. Ma'qil said to him: Verily I am going to narrate to you a hadith which I heard from the Messenger of Allah (may peace be upon him). Then he narrated the hadith like those two (mentioned above).

Book 1, Number 0264:

    It is narrated on the authority of Abu Malih that Ubaidullah b. Ziyad visited Ma'qil b. Yasar in his illness. Ma'qil said to him: I am narrating to you a hadith which I would have never narrated to you had I not been in death-bed. I heard Allah's apostle (may peace be upon him) say: A ruler who has been entrusted with the affairs of the Muslims but he makes no endeavors( for the material and moral uplift) and does not sincerely mean (their welfare) would not enter Paradise along with them.

Chapter 65 : REMOVAL OF TRUSTWORTHINESS AND FAITH FROM SOME HEARTS AND APPEARANCE OF DISCORD THEREIN

Book 1, Number 0265:

    Hudhaifa reported: The Messenger of Allah (may peace be upon him) narrated to us two ahadith. I have seen one (crystallized into reality), and I am waiting for the other. He told us: Trustworthiness descended in the innermost (root) of the hearts of people. Then the Qur'an was revealed and they learnt from the Qur'an and they learnt from the Sunnah. Then he (the Holy Prophet) told us about the removal of trustworthiness. He said : The man would have a wink of sleep and trustworthiness would be taken away from his heart leaving the impression of a faint mark. He would again sleep and trustworthiness would be taken away from his heart leaving an impression of a blister, as if you rolled down an ember on your foot and it was vesicled. He would see a swelling having nothing in it. He (the Holy Prophet) then took up a pebble and rolled it down over his foot and (said) : The people would enter into transactions amongst one another and hardly a person would be left who would return (things) entrusted to him. (And there would be so much paucity of honest persons) till it would be said: There in such a such tribe is a trustworthy man. And they would also say about a person: How prudent he is, how broad-minded he is and how intelligent he is, whereas in his heart there would not be faith even to the weight of a mustard seed. I have passed through a time in which I did not care with whom amongst you I entered into a transaction, for if he were a Muslim his faith would compel him to discharge his obligations to me and it he were a Christian or a Jew, the ruler would compel him to discharge his obligations to me. But today I would not enter into a transaction with you except so and so.

Book 1, Number 0266:

    This hadith has been transmitted by another chain of transmitters: Ibn Numair, Waki', Ishaq b. Ibrahim, 'Isa b. Yunus on the authority of A'mash.

Book 1, Number 0267:

    It is narrated on the authority of Hudhaifa : We were sitting in the company of Umar and he said: Who amongst you has heard the Messenger of Allah (may peace be upon him) talking about the turmoil ? Some people said : It is we who heard it. Upon this be remarked: Perhaps by turmoil you presume the unrest of man in regard to his household or neighbour, they replied : Yes. He ('Umar) observed : Such (an unrest) would be done away with by prayer, fasting and charity. But who amongst you has heard from the Apostle (may peace be upon him) describing that turmoil which would come like the wave of the ocean. Hudhaifa said: The people hushed into silence, I replied : It is I. He ('Umar) said : Ye, well, your father was also very pious. Hudhaifa said : I heard the Messenger of Allah (may peace be, upon him ) observing: Temptations will be presented to men's hearts as reed mat is woven stick by stick and any heart which is impregnated by them will have a black mark put into it, but any heart which rejects them will have a white mark put in it. The result is that there will become two types of hearts: one white like a white stone which will not be harmed by any turmoil or temptation, so long as the heavens and the earth endure; and the other black and dust-coloured like a vessel which is upset, not recognizing what is good or rejecting what is abominable, but being impregnated with passion. Hudhaifa said: I narrated to him ('Umar): There is between you and that (turmoil) a closed door, but there is every likelihood of its being broken. 'Umar said: Would it be broken? You have, been rendered fatherless. Had it been opened, it would have been perhaps closed also. I said: No, it would be broken, and I narrated to him: Verily that door implies a person who would be killed or die. There is no mistake in this hadith. Abu Khalid narrated: I said to Sa'd, O Abu Malik, what do you mean by the term "Aswad Murbadda"? He replied: High degree of whiteness in blackness. I said: What is meant by "Alkoozu Mujakhiyyan"? He replied: A vessel turned upside down.

Book 1, Number 0268:

    It is narrated on the authority of Rib'i (b. Hirash). When Hudhaifa came from 'Umar he sat down to narrate to us and said: Verily yesterday when I was sitting with the Commander of the believers he asked his companions: When amongst you retains in his memory the utterance of the Messenger of Allah (may peace be upon him) with regard to the turmoil ?-and he cited the hadith like the hadith narrated on the authority of Abu Khalid, but he did not mention the exposition of his words (Murbaddan) and (Mujakhiyyan).

Book 1, Number 0269:

    It is transmitted by Rib'i b. Hirash. who narrated it on the authority of Hudhaifa that verily 'Umar said: Who would narrate to us or who amongst you would narrate to us (and Hudhaifa was one amongst them) what the Messenger of Allah (may peace be upon him) had said about the turmoil? Hudhaifa said: I will, and recited the hadith like that transmitted by Abu Malik on the authority of Rib'i and he observed in connection with this hadith that Hudhaifa remarked: I am narrating to you a hadith and it has no mistake, and said: That it is transmitted from he Messenger of Allah (may peace be upon him).

Chapter 66 : ISLAM WAS INITIATED AS SOMETHING STRANGE, AND IT WOULD REVERT TO ITS (OLD POSITION) OF BEING STRANGE, AND IT WOULD CONCENTRATE BETWERN THE TWO MOSQUES

Book 1, Number 0270:

    It is narrated on the authority of Abu Huraira that the Messenger of Allah (may peace be upon him) said: Islam initiated as something strange, and it would revert to its (old position) of being strange. so good tidings for the stranger.

Book 1, Number 0271:

    It is narrated on the authority of Ibn 'Umar ('Abdullah b. 'Umar) that the Messenger of Allah (may peace be upon him) observed: Verily Islam started as something strange and it would again revert (to its old position) of being strange just as it started, and it would recede between the two mosques just as the serpent crawls back into its hole.

Book 1, Number 0272:

    It is narrated on the authority of Abu Huraira that the Messenger of Allah (may peace be upon him) said: Verily the faith would recede to Medina just as the serpent crawls back into its hole.

Chapter 67 : THE EFFACING OF FAITH IN THE LATER AGE

Book 1, Number 0273:

    It is narrated on the authority of Anas that verily the Messenger of Allah (may peace be upon him) observed: The Hour (Resurrection) would not come so long as Allah is supplicated in the world.

Book 1, Number 0274:

    It is narrated on the authority of Anas that the Messenger of Allah (may peace be upon him) said: The Hour (Resurrection) would not come upon anyone so long as he supplicates Allah.

Chapter 68 : PERMISSIBILITY OF CONCEALING THE FAITH OF ONE WH0 FEARS

Book 1, Number 0275:

    Hudhaifa reported: We were in the company of the Messenger of Allah (may peace be upon him) when he said. Count for me those who profess al-Islam. We said: Messenger of Allah, do you entertain any fear concerning us and we are (at this time) between six hundred and seven hundred (in strength). He (the Holy Prophet) remarked: You don't perceive; you may be put to some trial, He (the narrator) said: We actually suffered trial so much so that some of our men were constrained to offer their prayers in concealment.

Chapter 69 : TO HABITUATE THE HEART WITH FAITH WHICH DUE TO ITS WEAKNESS, IS SCARED AND THE FORBIDDANCE TO CALL POSITIVELY ONE A BELIEVER WITHOUT A DEFINITE PROOF

Book 1, Number 0276:

    Sa'd narrated it on the authority of his father (Abi Waqqas) that he observed: The Messenger of Allah (may peace be upon him) distributed shares (of booty among his Companions). I said: Messenger of Allah! Give it to so and so, for verily he is a believer. Upon this the Apostle of Allah remarked: Or a Muslim. I (the narrator) repeated it (the word "believer") thrice and he (the Holy Prophet) turned his back upon me (and substituted the word) "Muslim," and then observed: I bestow it (this share) to a man out of apprehension lest Allah should throw him prostrate into the fire (of Hell) whereas in fact the other man is dearer to me than he.

Book 1, Number 0277:

    It is narrated on the authority of Sa'd that the Messenger of Allah (may peace be upon him) bestowed upon a group of persons (things), and Sa'd was sitting amongst them. Sa'd said: The Messenger of Allah (may peace be upon him) ignored some of them. And he who was ignored seemed to be more deserving in my eyes (as compared with others). I (Sa'd) said: Messenger of Allah I why is it that you did not give to such and such (man)? Verily I see him a believer. Upon this the Messenger of Allah (may peace be upon him) observed: Or a Muslim ? I kept quiet for some time but I was again impelled (to express) what I knew about him. I said: Messenger of Allah why is it that you did not give it to such and such ? Verily, by Allah, see him a believer. Upon this the Messenger of Allah (may peace be upon him) remarked: (Nay, not a believer) but a Muslim. He (Sa'd) said: I again kept quite for some time but what I knew about him again impelled me (to express my opinion) and I said: Why is it that you did not give (the share) to so and so: By Allah, verily I see him a believer. The Messenger of Allah (may peace be upon him) remarked; (Nay, not so) but a Muslim. Verily (at times) I give (a share) to a certain man apprehending that he may not be thrown prostrate in the Fire, whereas the other man (who is not given) is dearer to me (as compared with him).

Book 1, Number 0278:

    Sa'd reported: The Messenger of Allah (may peace be upon him) bestowed upon a group of persons (booty) and I was sitting with them. The remaining part of the hadith is the same as mentioned (above) with the additionI stood up and went to the Messenger of Allah (may peace be upon him) and whispered to him : Why did you omit such and such a man ?

Book 1, Number 0279:

    The same hadith has been narrated on the authority of Muhammad b Sa'd and these words (are also there) : The Messenger of Allah (may peace be upon him) gave a stroke on my neck or between my two shoulders and said: Sa'd, do you fight with me simply because I gave (a share) to a man ?

Chapter 70 : THE HEART IS MORE SATISFIED ON SEEING EVIDENCE

Book 1, Number 0280:

    It is narrated on the authority of Abu Huraira that the Messenger of Allah (may peace be upon him) observed: We have more claim to doubt than Ibrahim (may peace be upon him) when he said: My Lord! Show me how Thou wilt quicken the dead. He said : Believeth thou not ? He said : Yes! But that my heart may rest at ease. He (the Holy Prophet) observed: May Lord take mercy on Lot, that he wanted a strong support, and had I stayed (in the prison) as long as Yusuf stayed, I would have responded to him who invited me.

Book 1, Number 0281:

    'Abdullah b. Muhammad narrated the same hadith on the authority of Abu Huraira and in the transmission by Malik the words are that he (the Holy Prophet) recited the verse : "but that my heart may rest at ease" and completed it.

Book 1, Number 0282:

    This hadith has also been narrated by Abd b. Humaid Ya'qub, i.e. son of Ibrahim b. Sa'd, Abu Uwais, Zuhri, like the one narrated by Malik with the same chain of transmission and said : He recited this verse till he completed it.

Chapter 71 : THE NECESSITY OF AFFIRMING THE PROPHETHOOD OF OUR APOSTLE MUHAMMAD (MAY PEACE BE UPON HIM) WHO IS THE APOSTLE SENT TO THE WHOLE OF HUMANITY, AND THE ABROGATION OF OTHER RELIGIONS WITH HIS RELIGION

Book 1, Number 0283:

    It is narrated on the authority of Abu Huraira that the Messenger of Allah (may peace be upon him) observed: There has never been a Prophet amongst the prophets who was not bestowed with a sign amongst the signs which were bestowed (on the earlier prophets). Human beings believed in it and verily I have been conferred upon revelation (the Holy Qur'an) which Allah revealed to me. I hope that I will have the greatest following on the Day of Resurrection.

Book 1, Number 0284:

    It is narrated on the authority of Abu Huraira that the Messenger of Allah (may peace be upon him) observed: By Him in Whose hand is the life of Muhammad, he who amongst the community of Jews or Christians hears about me, but does not affirm his belief in that with which I have been sent and dies in this state (of disbelief), he shall be but one of the denizens of Hell-Fire.

Book 1, Number 0285:

    It is narrated on the authority of Sha'bi that one among the citizens of Khurasan asked him: 0 Abu! some of the people amongst us who belong to Khurasan say that a person who freed his bondswoman and then married her is like one who rode over a sacrificial animal. Sha'bi said: Abu Burda b. Abi Musa narrated it to me on the authority of his father that verily the Messenger of Allah (may peace be upon him) said : There are three (classes of persons) who would be given a double reward. One who is amongst the People of the Book and believed in his apostle and (lived) to see the time of Apostle Muhammad (may peace be upon him) and affirmed his faith in him and followed him and attested his truth, for him is the double reward; and the slave of the master who discharges all those obligations that he owes to Allah and discharges his duties that he owes to his master, for him there is a double reward. And a man who had a bondswoman and fed her and fed her well, then taught her good manners, and did that well and later on granted her freedom and married her, for him is the double reward. Then Sha'bi said : Accept this hadith without (giving) anything. Formerly a man was (obliged) to travel to Medina even for a smaller hadith than this.

Book 1, Number 0286:

    This hadith has been narrated by another chain of transmitters like Abu Bakr b. Abi Shaiba, 'Abda b. Sulaiman Ibn Abi 'Umar Sufyan, 'Ubaidullah b. Mu'adh, Shu'ba ; all of them heard it from Salih b. Salih.

Chapter 72 : THE DESCENT OF JESUS SON OF MARY, AND HE WILL JUDGE ACCORDING TO THE SHARIIAH OF OUR APOSTLE, MUHAMMAD (MAY PEACE BE UPON HIM)

Book 1, Number 0287:

    Abu Huraira reported that the Messenger of Allah (may peace be upon him) said: By Him in Whose hand is my life, the son of Mary (may peace be upon him) will soon descend among you as a just judge. He will break crosses, kill swine and abolish Jizya and the wealth will pour forth to such an extent that no one will accept it.

Book 1, Number 0288:

    The same hadith is transmitted from Zuhri with the same chain of transmission. But in the tradition narrated by Ibn 'Uyaina the words are : "impartial leader and just judge" and in the tradition narrated by Yunus : the "judge judging with justice" and "impartial leader" are not mentioned. And in the hadith narrated by Salih like the one transmitted by Laith the words are : "impartial judge". And in the hadith transmitted by Ziyad the words are : "Till one sajda is better than the worldand what it contains. Then Abu Huraira used to say, "recite" if you like: Not one of the People of the Book will fail to believe in him before his death.

Book 1, Number 0289:

    It is narrated on the authority of Abu Huraira that the Messenger or Allah (may peace be upon him) observed: I swear by Allah that the son of Mary will certainly descend as a just judge and he would definitely break the cross, and kill swine and abolish Jizya and would leave the young she-camel and no one would endeavour to (collect Zakat on it). Spite, mutual hatred and jealousy against one another will certainly disappear and when he summons people to accept wealth, not even one would do so.

Book 1, Number 0290:

    It is narrated on the authority of Abu Huraira that the Messenger of Allah (may peace be upon him) observed: What will be your state when the son of Mary descends amongst you and there will be an Imam amongst you?

Book 1, Number 0291:

    It is narrated on the authority of Abu Huraira that he heard the Messenger of Allah (may peace be upon him) as saying: What would you do when the son of Mary would descend and lead you?

Book 1, Number 0292:

    It is narrated on the authority of Abu Huraira that the Messenger of Allah (may peace be upon him) observed: What would you do when the son of Mary would descend amongst you and would lead you as one amongst you ? Ibn Abi Dhi'b on the authority of Abu Huraira narrated: Your leader amongst you. Ibn Abi Dhi'b said: Do you know what the words: "He would lead as one amongst you" mean? I said: Explain these to me. He said: He would lead you according to the Book of your : Lord (hallowed be He and most exalted) and the Sunnah of your Apostle (may peace be upon him).

Book 1, Number 0293:

    Jabir b. 'Abdullah reported: I heard the Messenger of Allah (may peace be upon him) say: A section of my people will not cease fighting for the Truth and will prevail till the Day of Resurrection. He said: Jesus son of Mary would then descend and their (Muslims') commander would invite him to come and lead them in prayer, but he would say: No, some amongst you are commanders over some (amongst you). This is the honour from Allah for this Ummah.

Chapter 73 : DESCRIPTION OF THE PERIOD IN WHICH IMAN WOULD NOT BE ACCEPTABLE TO ALLAH

Book 1, Number 0294:

    It is narrated on the authority of Abu Huraira that the Messenger of Allah (may peace be upon him) said: The (Last) Hour shall not came till the sun rises from the place of its setting And on the day when it rises from the place of its setting even if all the people together affirmed their faith, it would not be of any avail to one who did not believe previously and derived no good out of his belief.

Book 1, Number 0295:

    This hadith has been narrated by another chain of transmitters, Abu Bakr b. Abi Shaiba, Ibn Numair, Abu Kuraib, Ibn Fudail.

Book 1, Number 0296:

    It is narrated on the authority of Abu Huraira that the Messenger of Allah (may peace be upon him) observed: When three things appear faith will not benefit one who has not previously believed or has derived no good from his faith: the rising of the sun in its place of setting, the Dajjal, and the beast of the earth.

Book 1, Number 0297:

    It is narrated on the authority of Abu Dharr that the Messenger of Allah (may peace be upon him) one day said: Do you know where the sun goes? They replied: Allah and His Apostle know best. He (the Holy Prophet) observed: Verily it (the sun) glides till it reaches its resting place under the Throne. Then it falls prostrate and remains there until it is asked: Rise up and go to the place whence you came, and it goes back and continues emerging out from its rising place and then glides till it reaches its place of rest under the Throne and falls prostrate and remains in that state until it is asked : Rise up and return to the place whence you came, and it returns and emerges out from it rising place and the it glides (in such a normal way) that the people do not discern anything ( unusual in it) till it reaches its resting place under the Throne. Then it would be said to it: Rise up and emerge out from the place of your setting, and it will rise from the place of its setting. The Messenger of Allah (may peace be upon him) said . Do you know when it would happen ? It would happen at the time when faith will not benefit one who has not previously believed or has derived no good from the faith.

Book 1, Number 0298:

    It is narrated on the authority of Abu Dharr that the Apostle of Allah(may peace be upon him) one day said : Do you know where the sun goes ? The remaining part of the hadith is the same.

Book 1, Number 0299:

    Abu Dharr reported : I entered the mosque and the Messenger of Allah (may peace be upon him) was sitting there. When the sun disappeared (from the sight) he said : O Abu Dharr! Do you know where it goes? He (the narrator) said : Allah and His Apostle know best. He (the Holy Prophet) said . Verily it goes and begs permission, for prostration (to Allah) and the permission is granted to it. Once it would be said: Return to the place whence you came, and then it would rise from its setting place. Then he, after the recitation of 'Abdullah recited it: And that is its appointed term.

Book 1, Number 0300:

    Abu Dharr reported: I asked the Messenger of Allah (may peace be upon him) the (implication of the) words of Allah, the Exalted : The sun glides to its appointed resting place. He replied: Its appointed resting place is under the Throne.

Chapter 74 : THE BEGINNING OF REVELATION TO THE MESSENGER OF ALLAH (MAY PEACE BE UPON HIM)

Book 1, Number 0301:

    A'isha, the wife of the Apostle of Allah (may peace be upon him), reported: The first (form) with which was started the revelation to the Messenger of Allah was the true vision in sleep. And he did not see any vision but it came like the bright gleam of dawn. Thenceforth solitude became dear to him and he used to seclude himself in the cave of Hira', where he would engage in tahannuth (and that is a worship for a number of nights) before returning to his family and getting provisions again for this purpose. He would then return to Khadija and take provisions for a like period, till Truth came upon him while he was in the cave of Hira'. There came to him the angel and said : Recite, to which he replied : I am not lettered. He took hold of me [the Apostle said] and pressed me, till I was hard pressed ; thereafter he let me off and said : Recite. I said : I am not lettered. He then again took hold of me and pressed me for the second time till I was hard pressed and then let me off and said : Recite, to which I replied : I am not lettered. He took hold of me and pressed me for the third time, till I was hard pressed and then let me go and said: Recite in the name of your Lord Who created, created man from a clot of blood. Recite. And your most bountiful Lord is He Who taught the use of pen, taught man what he knew not (al-Qur'an, xcvi. 1-4). Then the Prophet returned therewith, his heart was trembling, and he went to Khadija and said : Wrap me up, wrap me up ! So they wrapped him till the fear had left him. He then said to Khadija: O Khadija! what has happened to me ? and he informed her of the happening, saying: I fear for myself. She replied: It can't be. Be happy. I swear by Allah that He shall never humiliate you. By Allah, you join ties of relationship, you speak the truth, you bear people's burden, you help the destitute, you entertain guests, and you help against the vicissitudes which affect people. Khadija then took him to Waraqa b. Naufal b. Asad b. 'Abd al-'Uzza, and he was the son of Khadija's uncle, i.e., the brother of her father. And he was the man who had embraced Christianity in the Days of Ignorance (i.e. before Islam) and he used to write books in Arabic and, therefore, wrote Injil in Arabic as God willed that he should write. He was very old and had become blind Khadija said to him: O uncle! listen to the son of your brother. Waraqa b. Naufal said: O my nephew! what did you see? The Messenger of Allah (may peace be upon him), then, informed him what he had seen, and Waraqa said to him: It is namus that God sent down to Musa. Would that I were then (during your prophetic career) a young man. Would that I might be alive when your people would expel you! The Messenger of Allah (may peace be upon him) said: Will they drive me out ? Waraqa said: Yes. Never came a man with a like of what you have brought but met hostilities. If I see your day I shall help you wholeheartedly.

Book 1, Number 0302:

    This hadith has been narrated on the authority of 'A'isha with another chain of narrators like one transmitted by Yunus, i.e. the first thing with which the revelation was initiated with the Messenger of Allah (may peace be upon him) except the words: By Allah, Allah would never humiliate you, and Khadija said: O son of my uncle! Listen to the son of your brother.

Book 1, Number 0303:

    This hadith has been reported from 'A'isha by another chain of transmitters and the words are: He (the Holy Prophet) came to Khadija an his heart was trembling. The rest of the hadith has been narrated like one transmitted by Yunus and Ma'mar, but the first part is not mentioned, i.e. the first thing with which was started the revelation to the Holy Prophet was the true vision. And these words like those transmitted by Yunus are mentioned thus: By Allah, Allah would never humiliate you. And there is also a mention of the words of Khadija: O son of my uncle! Listen to the son of your brother.

Book 1, Number 0304:

    Jabir b. 'Abdullah al-Ansari who was one of the Companions of the Messenger of Allah (may peace be upon him) reportedThe Messenger of Allah (may peace be upon him) told about the intermission of revelation and narrated While I was walking I heard a voice from the sky, and raising my head I saw the angel who had come to me in Hira', sitting on a Throne between heaven and earth I was terror-stricken on that account and came back (to my family) and said: Wrap me up, wrap me up ! So they wrapped me up, and the Blessed and Most Exalted Allah sent down: "You who are shrouded, arise and deliver warning, your Lord magnify, your clothes cleanse, and defilement shun," and "defilement" means idols; and then the revelation was followed continuously.

Book 1, Number 0305:

    It is narrated on the authority of Jabir b. Abdullah that he heard the Messenger of Allah (may peace be upon him) says: The wahi was intermitted for me for a small span of time and while I was walking, and then the hadith like the one narrated by Yunus was transmitted but with the exception of these words: I was terror-stricken till I fell on the ground. Abu Salama said: Defilement means idols. After this the revelation was speeded up and followed rapidly.

Book 1, Number 0306:

    This hadith, the like of one narrated by Yunus has also been transmitted by Ma'mar on the authority of al-Zuhri who narrated: Allah the Most Glorious and Exalted revealed this: "You who are shrouded, arise and deliver warning, your Lord magnify, your clothes cleanse and defilement shun," before making the prayer obligatory. I felt terror-stricken as narrated by Uqail.

Book 1, Number 0307:

    Yahya reported: I asked Abu Salama what was revealed first from the Qur'an. He said:" 0, the shrouded one." I said: Or "Recite." Jabir said: I am narrating to you what was narrated to us by the Messenger of Allah (may peace be upon him). He said: I stayed in Hira' for one month and when my stay was completed, I come down and went into the heart of the valley. Somebody called me aloud. I looked in front of me, behind me, on the right of my side and on my left, but I did not see any body. I was again called and I looked about but saw nothing. I was called again and raised my head, and there on the Throne in the open atmosphere he, i.e. Gabriel (peace be upon him) was sitting. I began to tremble on account of fear. I came to Khadija and said: Wrap me up. They wrapped me up and threw water on me and Allah, the Exalted and Glorious, sent down this: you who are shrouded! arise and deliver warning, your Lord magnify, your clothes cleanse."

Book 1, Number 0308:

    Yahya b Abi Kathir has reported this hadith with the same chain of transmitters and narrated: And there he was sitting on the Throne between the heaven and the earth.

Chapter 75 : NIGHT JOURNEY OF THE MESSENGER OF ALLAH (MAY PEACE BE UPON HIM) TO HEAVEN, AND THE PRAYER MADE OBLIGATORY

Book 1, Number 0309:

    It is narrated on the authority of Anas b. Malik that the Messenger of Allah (may peace be upon him) said: I was brought al-Buraq Who is an animal white and long, larger than a donkey but smaller than a mule, who would place his hoof a distance equal to the range of version. I mounted it and came to the Temple (Bait Maqdis in Jerusalem), then tethered it to the ring used by the prophets. I entered the mosque and prayed two rak'ahs in it, and then came out and Gabriel brought me a vessel of wine and a vessel of milk. I chose the milk, and Gabriet said: You have chosen the natural thing Then he took me to heaven. Gabriel then asked the (gate of heaven) to be opened and he was asked who he was He replied: Gabriel. He was again asked: Who is with you? He (Gabriel) said: Muhammad. It was said: Has he been sent for? Gabriel replied: He has indeed been sent for. And (the door of the heaven) was opened for us and lo ! we saw Adam. He welcomed me and prayed for my good. Then we ascended to the second heaven. Gabriel (peace be upon him) (asked the door of heaven to be opened), and he was asked who he was. He answered: Gabriel; and was again asked: Who is with you? He replied: Muhammad. It was said: Has he been sent for? He replied: He has indeed been sent for. The gate was opened. When I entered 'Isa b. Maryam and Yahya b. Zakariya (peace be upon both of them), cousins from the maternal side. welcomed me and prayed for my good Then I was taken to the third heaven and Gabriel asked for the opening (of the door). He was asked: Who are you? He replied: Gabriel. He was (again) asked: Who is with you? He replied Muhammad (may peace be upon him). It was said: Has he been sent for? He replied He has indeed been sent for. (The gate) was opened for us and I saw Yusuf (peace of Allah be upon him) who had been given half of (world) beauty. He welcomed me prayed for my well-being. Then he ascended with us to the fourth heaven. Gabriel (peace be upon him) asked for the (gate) to be opened, and it was said: Who is he? He replied: Gabriel. It was (again) said: Who is with you? He said: Muhammad. It was said: Has he been sent for? He replied: He has indeed been sent for. The (gate) was opened for us, and lo! Idris was there. He welcomed me and prayed for my well-being (About him) Allah, the Exalted and the Glorious, has said: "We elevated him (Idris) to the exalted position" (Qur'an xix. 57). Then he ascended with us to the fifth heaven and Gabriel asked for the (gate) to be opened. It was said: Who is he? He replied Gabriel. It was (again) said: Who is with thee? He replied: Muhammad. It was said Has he been sent for ? He replied: He has indeed been sent for. (The gate) was opened for us and then I was with Harun (Aaron-peace of Allah be upon him). He welcomed me prayed for my well-being. Then I was taken to the sixth heaven. Gabriel (peace be upon him) asked for the door to be opened. It was said: Who is he? He replied: Gabriel. It was said : Who is with thee? He replied: Muhammad. It was said : Has he been sent for ? He replied : He has indeed been sent for. (The gate) was opened for us and there I was with Musa (Moses peace be upon him) He welcomed me and prayed for my well-being. Then I was taken up to the seventh heaven. Gabriel asked the (gate) to be opened. It was said: Who is he ? He said : Gabriel It was said . Who is with thee ? He replied : Muhammad (may peace be upon him.) It was said : Has he been sent for ? He replied : He has indeed been sent for. (The gate) was opened for us and there I found Ibrahim (Abrahampeace be upon him) reclining against the Bait-ul-Ma'mur and there enter into it seventy thousand angels every day, never to visit (this place) again Then I was taken to Sidrat-ul-Muntaha whose leaves were like elephant ears and its fruit like big earthenware vessels. And when it was covered by the Command of Allah, it underwent such a change that none amongst the creation has the power to praise its beauty. Then Allah revealed to me a revelation and He made obligatory for me fifty prayers every day and night. Then I went down to Moses (peace be upon him) and he said : What has your Lord enjoined upon your Ummah ? I said : Fifty prayers. He said : Return to thy Lord and beg for reduction (in the number of prayers), for your community shal1 not be able to bear this burden. as I have put to test the children of Isra'il and tried them (and found them too weak to bear such a heavy burden). He (the Holy Prophet) said: I went back to my Lord and said: My Lord, make things lighter for my Ummah. (The Lord) reduced five prayers for me. I went down to Moses and said. (The Lord) reduced five (prayers) for me, He said: Verily thy Ummah shall not be able to bear this burden ; return to thy Lord and ask Him to make things lighter. I then kept going back and forth between my Lord Blessed and Exalted and Moses, till He said: There are five prayers every day and night. O Muhammad, each being credited as ten, so that makes fifty prayers. He who intends to do a good deed and does not do it will have a good deed recorded for him ; and if he does it, it will be recorded for him as ten; whereas he who intends to do an evil deed and does not do, it will not be recorded for him; and if he does it, only one evil deed will be recorded. I then came down and when I came to Moses and informed him, he said: Go back to thy Lord and ask Him to make things lighter. Upon this the Messenger of Allah remarked : I returned to my Lord until I felt ashamed before Him.

Book 1, Number 0310:

    It is narrated on the the outhority of Anas b. Malik that the Messenger of Allah (may peace be upon him) said: (the angels) came to me and took me to the Zamzam and my heart was opened and washed with the water of Zamzam and then I was left (at my place).

Book 1, Number 0311:

    Anas b. Malik reported that Gabriel came to the Messenger of Allah (may peace be upo him) while he was playing with his playmates. He took hold of him and lay him prostrate on the ground and tore open his breast and took out the heart from it and then extracted a blood-clot out of it and said : That was the part of Satan in thee. And then he washed it with the water of Zamzam in a golden basin and then it was joined together and restored to it place. The boys came running to his mother, i.e. his nurse, and said: Verily Muhammad has been murdered. They all rushed toward him (and found him all right) His color was changed, Anas said. I myself saw the marks of needle on his breast.

Book 1, Number 0312:

    Anas b. Malik,while recountig the Night journey of the Holy Prophet (may peace be upon him), from the mosque of Ka'bah, reported : Three beings (angels) came to him in the osque of the Ka'bah, while he was sleeping in the sacred mosque before it (the Command of Night Journey and Accension) was revealed to him. The rest of the hadith is narrated like that of Thabit. However, some portions have occurred before and some of them have occurred after ; some have been added and some deleted.

Book 1, Number 0313:

    Anas b. Malik reported : Abu Dharr used to relate that the Messenger of Allah (may peace be upon him) said: The roof of my house was cleft when I was in Mecca and Gabriel descended and opened my heart and then washed it with the water of Zamzam.He then brought a gold basin full of wisdom and faith and after emptying it into my breast, he closed it up. Then taking me by he hand, he ascended with me to th heaven, and when we came to the lowest heaven, Gabriel said to the guardian of the lowest heaven: Open. He asked who was there? He replied . It is Gabriel. He again asked whe he there was someone with him. He replied: Yes, it is Muhammad with me. He was asked if he had been sent for, He (Gabriel) said: Yes . Then he opened (the gate). When we ascended the lowest heaven (I saw) a man seated with parties on his right side and parties on his left side. When he looked up to his right, he laughed and when he looked to his left, he wept. He said: Welcome to the righteous apostle and the righteous son. I asked Gabriel who he was and he replied: He is Adam (peace be upon him) and these parties on his right and on his left are the souls of his descendants. Those of them on his right are the inmates of Paradise and the parties which are on his left side are the inmates of Hell ; so when he looked towards his right side, he laughed, and when he looked towards his left side, he wept. Then Gabriel ascended with me to the second heaven. He asked its guardian to open (its gate), and its guardian replied in the same way as the guardian of the lowest heaven had said. He (opened it). Anas b. Malik said: He (the Holy Prophet) mentioned that he found in the heavens Adam, Idris, Jesus, Moses and Abraham (may peace be on all of them), but he did not ascertain as to the nature of their abodes except that he had found Adam in the lowest heaven and Abraham in the sixth heaven. When Gabriel and the Messenger of Allah (may peace be upon him) passed by Idris (peace be upon him) he said : Welcome to the righteous apostle and righteous brother. He (the narrator) said: He then proceeded and said : Who is he ? Gabriel replied : It is Idris. Then I passed by Moses (peace be upon him) and he said: Welcome tothe righteous apostle and righteous brother. I said to (Gabriel) : Who is he ? He replied : It is Moses. Then I passed by Jesus and he said : Welcome to the righteous apostle and righteous brother. I said (to Gabriel) : Who is he ? He replied : Jesus, son of Mary. He (the Holy Prophet) said: Then I went to Ibrahim (peace be upon him). He said: Welcome to the righteous apostle and righteous son. I asked : Who is he ? He (Gabriel) replied : It is Abraham. Ibn Shihab said: Ibn Hazm told me that Ibn 'Abbas and Abd Habba al-Ansari used to say that the Messenger of Allah (may peace be upon him) said : Thereafter he ascended with me till I was taken to such a height where I heard the scraping of the pens. Ibn Hazm and Anas told that the Messenger of Allah (may peace be upon him) said : Allah then made fifty prayers obligatory for my Ummah and I returned with that and passed by Moses. Moses, (peace be upon him) said : What has thy Lord enjoined on thy people ? I said : Fifty prayers have been made obligatory on them. Moses (peace be upon him) said : Return to thy Lord, for thy Ummah would not be able to bear this burden. Then I came back to my Lord and He remitted a portion out of thut. I then again went to Moses (peace be upon him) and informed him about it He said : Return to thy Lord, for thy Ummah shall not be able to bear this burden. I then went back to my Lord and He said : They are five and at the same time fifty, and what has been said will not be changed. I then returned to Moses and he said: Go back to thy Lord. whereupon I said : I feel ashamed of my Lord. Gabriel then travelled with me till we came to the farthest lote-tree Many a colour had covered it which I do not know. Then I was admitted to Paradise and saw in it domes of pearls, and its soil of musk.

Book 1, Number 0314:

    Anas b. Malik reported on the authority of Malik b. Sa sa', perhaps a person of his tribe, that the Prophet of Allah (may peace be upon him) said: I was near the House (i.e. Ka'bah) in a state between sleep and wakefulness when I heard someone say : He is the third among the two persons. Then he came to me and took me with him. Then a golden basin containing the water of Zamzam was brought to me and my heart was opened up to such and such (part). Qatada said: I asked him who was with me (i e. the narrator) and what he meant by such and such (part). He replied: (It means that it was opened) up to the lower part of his abdomen (Then the hadith continues): My heart was extracted and it was washed with the water of Zamzam and then it was restored in its original position, after which it was filled with faith and wisdom. I was then brought a white beast which is called al-Buraq, bigger than a donkey and smaller than a mule. Its stride was as long as the eye could reach. I was mounted on it, and then we went forth till we reached the lowest heaven. Gabriel asked for the (gate) to be opened, and it was said: Who is he? He replied: Gabriel .It was again said: Who is with thee? He replied: Muhammad (may peace be upon him). It was said: Has he been sent for? He (Gabriel) said: Yes. He (the Prophet) said : Then (the gate) was opened for us (and it was said) : Welcome unto him ! His is a blessed arrival. Then we came to Adam (peace be upon him). And he (the narrator) narrated the whole account of the hadith. (The Holy Prophet) observed that he met Jesus in the second heaven, Yahya (peace be on both of them) in the third heaven, Yusuf in the third, Idris in the fourth, Harun in the fifth (peace and blessings of Allah be upon them). Then we travelled on till we reached the sixth heaven and came to Moses (peace be upon him) and I greeted him and he said: Welcome unto righteous brother and righteous prophet. And when I passed (by him) he wept, and a voice was heard saying: What makes thee weep ? He said: My Lord, he is a young man whom Thou hast sent after me (as a prophet) and his followers will enter Paradise in greater numbers than my followers. Then we travelled on till we reached the seventh heaven and I came to Ibrahim. He (the narrator) narrat- ed in this hadith that the Prophet of Allah (may peace be upon him) told that he saw four rivers which flowed from (the root of the lote-tree of the farthest limits) : two manifest rivers and two hidden rivers. I said : ' Gabriel ! what are these rivers ? He replied :The two hidden rivers are the rivers of Paradise, and as regards the two manifest ones, they are the Nile and the Euphrates. Then the Bait-ul-Ma'mur was raised up to me. I said : O Gabriel! what is this? He replied: It is the Bait-ul-Ma'mur. Seventy thousand angels enter into it daily and, after they come out, they never return again. Two vessels were then brought to me. The first one contained wine and the second one contained milk, and both of them were placed before me. I chose milk. It was said: You did right. Allah will guide rightly through you your Ummah on the natural course. Then fifty prayers daily were made obligatory for me. And then he narrated the rest of the hadith to the end.

Book 1, Number 0315:

    It is reported on the authority of Malik b. Sa'sa' that the Messenger of Allah (may peace be upon him) narrated the hadith (mentioned above) and added to it : I was brought a gold basin full of wisdom and faith, and then the (part of the body) right from the upper end of the chest to the lower part of the abdomen was opened and it was washed with the water of Zamzam and then flled with wisdom and faith.

Book 1, Number 0316:

    Qatada reported that he heard Abu al-'Aliya saying that the cousin of your Prophet (may peace be upon him), i.e. Ibn Abbas, told him: The Messenger of Allah (may peace be upon him), while narrating his night journey observed : Musa (peace be upon him) was a man of high stature as if he was of the people of the Shanu'a (tribe), and Jesus was a well-built person having curly hair. He also mentioned Malik, the guardian of Hell, and Dajjal.

Book 1, Number 0317:

    Abu al-'Aliya reported : Ibn Abbas, the son of your Prophet's uncle, told us that the Messenger of Allah (may peace be upon him) had observed : On the night of my night journey I passed by Moses b. 'Imran (peace be upon him), a man light brown in complexion, tall. well-built as if he was one of the men of the Shanu'a, and saw Jesus son of Mary as a medium-statured man with white and red complexion and crisp hair, and I was shown Malik the guardian of Fire, and Dajjal amongst the signs which were shown to me by Allah. He (the narrator) observed : Then do not doubt his (i.e. of the Holy Prophet) meeting with him (Moses). Qatada elucidated it thus: Verily the Apostle of Allah (may peace be upon him), met Moses (peace be upon him).

Book 1, Number 0318:

    Abu al-'Aliya narrated it on the authority of Ibn 'Abbas that the Messenger of Allah (may peace be upon him) passed through the valley of Azraq, and he asked: Which valley is this? They said: This is the valley of Azraq, and he observed: (I perceive) as if I am seeing Moses (peace be upon him) coming down from the mountain track, and he is calling upon Allah loudly (saying: Here I am ! at your service ! ). Then he came to the mountain track of Harsha. He (the Holy Prophet) said : Which is this mountain track ? They said : It is the mountain track of Harsha. He observed (I feel) as If I am seeing Yunus (Jonah-peace be upon him) son of Matta on a well- built red dromedary, with a cloak of wool around him and the rein of his dromedary is made of the fibres of date-palm, and he is calling upon Allah (saying: Here I am ! at your service, my Lord!). Ibn Hanbal said in the hadith narrated by him: Hushaim said that the meaning of khulba was fibre of date-palm.

Book 1, Number 0319:

    Abu al-'Aliya narrated it on the authority of Ibn 'Abbas that he said: We travelled with the Messenger of Allah (may peace be upon him) between Mecca and Medina and we passed by a valley. He (the Holy Prophet) asked: Which valley is this? They said: This is the valley of Azraq Upon this he (the Holy Prophet) remarked: (I feel) as if I am seeing Moses (peace be upon him), and then he described something about his complexion and hair, which Diwud (the narrator) could not remember. He (Moses, as described by the Holy Prophet) was keeping his fingers in his ears and was responding loudly to Allah (saying: I am as Thy service, my Lord) while passing through that valley. We then travelled (further) till we came to the mountain trail. He (the Holy Prophet) said: Which mountain trail is this? They said: It is the Harsha or Lift. He (the Holy Prophet) said: (I perceive) as if I am seeing Yunus on a red camel, with a cloak of wool around him. The halter of his camel was that of the fibre of date-palm, and he was passing through the valley saying: I am at Thy service! my Lord.

Book 1, Number 0320:

    It is narrated on the authority of Mujahid that he said: We were with Ibn 'Abbas and (the people) talked about al-Dajjal. (One of them remarked. There is written between his eyes (the word) Kafir (infidel). The narrator said: Ibn 'Abbas remarked: I did not hear him (the Holy Prophet) say it, but he said: So far as Ibrahim is concerned. you may see your companion and so far as Moses is concerned, he is a well-built man with wheat complexion (riding) on a red camel with its halter made of the fibre of date-palm (and I perceive) as if I am seeing towards him as he is going down in the valley saying: I am at Thy service ! my Lord.

Book 1, Number 0321:

    It is narrated on the authority of Jabir that the Messenger of Allah (may peace be upon him) said: There appeared before me the apostles, and Moses was among men as if he was one of the people of Shanu'a, and I saw Jesus son of Mary (peace be upon him) and I saw nearest in resemblance with him was 'Urwa b. Mas'ud, and I saw Ibrahim (blessings of Allah be upon him) and I see your companions much in resemblance with him, i.e. his personality, and I saw Gabriel (peace be upon him) and I saw Dihya nearest in resemblance to him; but in the narration of Ibn Rumh it is Dihya b. Khalifa.

Book 1, Number 0322:

    It is narrated on the authority of Abu Huraira that the Apostle of Allah (may peace be upon him) said: When I was taken for the night journey I met Moses peace be upon him). The Apostle of Allah (may peace be upon him) gave his description thus: He was a man, I suppose-and he (the narrator) was somewhat doubtful (that the Holy Prophet observed): (Moses) was a man erect in stature with straight hair on his head as it he was one of the men of the Shanu'a; and I met Jesus and the Apostle of Allah (may peace be upon him) described him as one having a medium stature and a red complexion as if he had (just) come out of the bath He observed: I saw Ibrahim (peace be upon him) and amongst his children I have the greatest resemblance with him. He said: There were brought to me two vessels. In one of them was milk and in the other one there was wine. And it was said to me: Select any one you like. So I selected the vessel containing milk and drank it. He (the angel) said: You have been guided on al-fitra or you have attained al-fitra. Had you selected wine, your Ummah would have been misled.

Chapter 76 : PERTAINING TO JESUS SON OF MARY AND AL-MASIH AL-DAJJAL

Book 1, Number 0323:

    It is narrated on the authority of 'Abdullah b. Umar that the Messenger of Allah (may peace be upon him) said: I found myself one night near the Ka'bah, and I saw a man with wheat complexion amongst the fair-complexioned men that you ever saw. He had a lock of hair the most beautiful of the locks that you ever saw. He had combed it. Water was trickling out of them. He was leaning on two men, or on the shoulders of two men, and he was circumscribing the Ka'bah. I asked, What is he? It was said: He is al-Masih son of Mary. Then I saw another person, stout and having too much curly hair , and blind in his right eye as if it was a full swollen grape. I asked Who is he? It was said:He is al-Masih al-Dajjal.

Book 1, Number 0324:

    It is narrated on the authority of 'Abdulldh b. Umar that one day the Messenger of Allah (may peace be upon him) mentioned in the presence of people about al-Masih al-Dajjal. He said: Verily Allah (hallowed be He and High) is not blind of one eye. Behold, but the Masih al-Dajjal is blind of right eye as if his eye is like a swollen grape, and the Messenger of Allah (may peace be upon him) said: I was shown in a dream in the night that near the Ka'bah there was a man fair-complexioned, fine amongst the white-complexioned men that you ever saw, his locks of hair were falling on his shoulders. He was a man whose hair were neither too curly nor too straight, and water trickled down from his head. He was placing his bands on the shoulders of two persons and amidst them was making a circuit around the Ka'bah. I said: Who is he? They replied: Al-Masih son of Mary. And I saw behind him a man with intensely curly hair, blind of right eye. Amongst the persons I have ever seen Ibn Qatan has the greatest resemblance with him. He was making a circuit around the Ka'bah by placing both his hands on the shoulders of two persons. I said: Who is he? They said; It is al-Masih al-Dajjal.

Book 1, Number 0325:

    It is narrated on the authority of Ibn 'Umar that the Messenger of Allah (may peace be upon him) said: I saw near the Ka'bah a man of fair complexion with straight hair, placing his hands on two persons. Water was flowing from his head or it was trickling from his head. I asked: Who is he? They said: He is Jesus son of Mary or al-Masih son of Mary. The narrator) says: I do not remember which word it was. He (the Holy Prophet) said: And I saw behind him a man with red complexion and thick curly hair, blind in the right eye. I saw in him the greatest resemblance with Ibn Qitan I asked: Who is he? They replied: It is al-Masih al-Dajjal.

Book 1, Number 0326:

    It is narrated on the authority of Jabir b. 'Abdullah that the Messenger of Allah (may peace be upon him) said: When the Quraish belied me, I was staying in Hatim and Allah lifted before me Bait-ul-Maqdis and I began to narrate to them (the Quraish of Mecca) its signs while I was in fact looking at it.

Book 1, Number 0327:

    'Abdullah reported on the authority of his father 'Umar b. Khattab that he heard from the Messenger of Allah (may peace he upon him) say: I was sleeping when I saw myself making circuit around the Ka'bah, and I saw there a man of fair complexion with straight hair between two men. Water was flowing from his head or water was falling from his head. I said: Who is he? They answered: He is the son of Mary. Then I moved forward and cast a glance and there was a bulky man of red complexion with thick locks of hair on his head, blind of one eye as it his eye was a swollen grape. I asked: Who is he? They said : He is Dajjal. He had close resemblance with Ibn Qatan amongst men.

Book 1, Number 0328:

    It is narrated on the authority of Abu Huraira that the Messenger of Allah (may peace be upon him) said : I found myself in Hijr and the Quraish were asking me about my might journey. I was asked about things pertaining to Bait-ul-Maqdis which I could not preserve (in my mind). I was very much vexed, so vexed as I had never been before. Then Allah raised it (Bait-ul-Maqdis) before my eyes. I looked towards it, and I gave them the information about whatever they questioned me I also saw myself among the group of apostles. I saw Moses saying prayer and found him to be a well-built man as if he was a man of the tribe of Shanu'a. I saw Jesus son of Mary (peace be upon him) offering prayer, of all of men he had the closest resemblance with 'Urwa b. Masu'd al-Thaqafi. I saw Ibrahim (peace be upon him) offering prayer; he had the closest resemblance with your companion (the Prophet himself) amongst people. When the time of prayer came I led them. When I completed the prayer, someone said: Here is Malik, the keeper of the Hell; pay him salutations. I turned to him, but he preceded me in salutation.

Chapter 77 : CONCERNING SIDRAT-UL-MUNTAHA (REMOTEST LOTE-TREE)

Book 1, Number 0329:

    It is narrated on the authority of Abdullah (b. Umar) that when the Messenger of Allah (may peace be upon him) was taken for the Night journey, he was taken to Sidrat-ul-Muntaha, which is situated on the sixth heaven, where terminates everything that ascends from the earth and is held there, and where terminates every- thing that descends from above it and is held there. (It is with reference to this that) Allah said: "When that which covers covered the lote-tree" (al-Qur'an, Iiii. 16). He (the narrator) said: (It was) gold moths. He (the narrator further) said: The Messenger of Allah (may peace be upon him) was given three (things): he was given five prayers, be was given the concluding verses of Sura al-Baqara, and remission of serious Sins for those among his Ummah who associate not anything with Allah

Book 1, Number 0330:

    Al-Shaibini reported to us: I asked Zirr b. Hubaish about the words of Allah (the Mighty and Great): "So he was (at a distance) of two bows or nearer" (al-Qur'an, Iiii 8). He said: Ibn Mas'ud informed me that, verily, the Apostle of Allah (may peace be upon him) saw Gabriel and he had six hundred wings.

Book 1, Number 0331:

    Al-Shaibani narrated on the authority of Zirr who narrated it on this authority of Abdullah that the (words of Allah): "The heart belied not what he saw" (al Qur'an, Iiii. 11) imply that he saw Gabriel (peace be upon him) and he had six hundred wings.

Book 1, Number 0332:

    Zirr b. Hubaish narrated it on the authority of 'Abdullah (that the words of Allah): "Certainly he saw of the greatest signs of Allah" (al-Qur'an, liii. 18) imply that he saw Gabriel in his (original) form and he had six hundred wings.

Book 1, Number 0333:

    It is narrated on the authority of Abu Huraira that the (words of Allah): "And certainly he saw him in another descent" (al-Qur'an, Iiii. 13) imply that he saw Gabriel.

Chapter 78 : THE MEANING OF THE WORDS OF ALLAH: "HE SAW HIM IN ANOTHER DESCENT" (AL-QUR'AN, LIII. 13). DID THE APOSTLE (MAY PEACE BE UPON HIM) SEE HIS LORD ON THE NIGHT OF HIS JOURNEY (TO HEAVEN)?

Book 1, Number 0334:

    It is narrated on the authority of Ibn 'Abbas that he (the Holy Prophet) saw (Allah) with, his heart.

Book 1, Number 0335:

    It is narrated on the authority of Ibn Abbas that the words: "The heart belied not what he saw" (al-Qur'an, Iiii. 11) and "Certainly he saw Him in another descent" (al-Qur'an, Iiii. 13) imply that he saw him twice with his heart.

Book 1, Number 0336:

    Abu Bakr b. Abi Shaiba narrated it on the same authorities.

Book 1, Number 0337:

    It is narrated on the authority of Masruq that he said: I was resting at (the house of) 'A'isha that she said: O Abu 'A'isha (kunya of Masruq), there are three things, and he who affirmed even one of them fabricated the greatest lie against Allah. I asked that they were. She said: He who presumed that Muhammad (may peace be upon him) saw his Lord (with his ocular vision) fabricated the greatest lie against Allah. I was reclining but then sat up and said: Mother of the Faithful, wait a bit and do not be in a haste. Has not Allah (Mighty and Majestic) said: "And truly he saw him on the clear horizon" (al-Qur'an, lxxxi. 23) and "he saw Him in another descent" (al-Qur'an, iiii. 13)? She said: I am the first of this Ummah who asked the Messenger of Allah (may peace be upon him) about it, and he said: Verily he is Gabriel. I have never seen him in his original form in which he was created except on those two occasions (to which these verses refer); I saw him descending from the heaven and filling (the space) from the sky to the earth with the greatness of his bodily structure. She said: Have you not heard Allah saying. "Eyes comprehend Him not, but He comprehends (all) vision. and He is Subtle, and All-Aware" (al-Qur'an, v. 104)? (She, i.e. 'A'isha, further said): Have you not heard that, verily, Allah says: "And it is not vouchsafed to a human being that Allah should speak unto him otherwise than by revelation, or from behind a veil, or that He sendeth a messenger (angel), so that he revealth whatsoever He wills. Verily He is Exalted. Wise" (al. Qur'an, xii. 51)She said: He who presumes that the Messengerof Allah (may peace be upon him) concealed anything, from the Book, of Allah fabricates the greatest lie against Allah. Allah says: "O Messenger ! deliver that which has been revealed to thee from thy Lord, and if thou do (it) not, thou hast not delivered His message" (al-Qur'an, v. 67). She said: He who presumes that he would inform about what was going to happen tomorrow fabricates the greatest lie against Allah. And Allah says "Say thou (Muhammad): None in the heavens and the earth knoweth the unseen save Allah" (al-Qur'an, xxvii 65).

Book 1, Number 0338:

    Dawud reported on the same authorities the hadith as narrated above by Ibn 'Uliyya and added: She ('A'isha) said: If Muhammad were to conceal anything which was sent to him, he would have certainly concealed this verse: "And when thou saidst to him on whom Allah had conferred favour and thou too had conferred favour: Keep thy wife to thyself and fear Allah, and thou wast concealing in thy heart that which Allah was going to disclose, and thou wast fearing men while Allah has a better right that thou shouldst fear Him."

Book 1, Number 0339:

    Masruq reported: I asked 'A'isha if Muhammad (may peace be upon him) had seen his Lord. She replied: Hallowed be Allah, my hair stood on end when you said this, and he (Masruq) narrated the hadith as narrated above. The hadith reported by Diwud is more complete and longer.

Book 1, Number 0340:

    Masruq reported: I said to 'A'isha: What about the words of Allah: "Then he drew nigh and came down, so he was at a distance of two bows or closer still: so He revealed to His servant what He revealed" (al-Qur'an, liii. 8-10)? She said: It implies Gabriel. He used to come to him (the Holy Prophet) in the shape of men; but he came at this time in his true form and blocked up the horizon of the sky.

Chapter 79 : PERTAINING TO HIS (PROPHET'S) WORDS: HE IS A LIGHT; HOW COULD I SEE HIM?-AND HIS WORDS: I SAW THE LIGHT

Book 1, Number 0341:

    It is narrated on the authority of Abu Dharr : I asked the Messenger of Allah (may peace be upon him): Did you see thy Lord? He said: He is a Light;.bow could I see Him?

Book 1, Number 0342:

    Abdullah b. Shaqiq reported: I said to Abu Dharr: Had I seen the Messenger of Allah, I would have asked him. He (Abu Dharr) said: What is that thing that you wanted to inquire of him ? He said: I wanted to ask him whether he had seen his Lord. Abu Dharr said: I, in fact, inquired of him, and he replied: I saw Light.

Book 1, Number 0343:

    Abu Musa reported: The Messenger ofallah (may peace be upon him) was standing amongst us and he told us five things. He said: Verily the Exalted and Mighty God does not sleep, and it does not befit Him to sleep. He lowers the scale and lifts it. The deeds in the night are taken up to Him before the deeds of the day. and the deeds of the day before the deeds of the night. His veil is the light. In the hadith narrated by Abu Bakr (instead of the word "light") it is fire. If he withdraws it (the veil), the splendour of His countenance would consume His creation so far as His sight reaches.

Book 1, Number 0344:

    A'mash has narrated this hadith on the same authority and said: The Messenger of Allah (may peace be upon him) was standing amongst us and he told us four things. He then narrated the hadith like the one reported by Abu Mua'wiya, but did not mention the words "His creation" and said: His veil is the light.

Book 1, Number 0345:

    Abu Musa reported: The Messenger of Allah (znay peace be upon him) was standing amongst us and (he said) four (things) : Verily Allah dock not sleep and it does not befit Him to sleep. He raises the scale and lowers it. The deeds of the day are presented to Him in the night and the deeds of the night in the day.

Chapter 80 : IN PROOF OF THE FACT THAT THE BELIEVERS WOULD SEE THEIR LORD (HALLOWED BE HE AND EXALTED) ON THE LAST DAY

Book 1, Number 0346:

    'Abdullah b. Qais transmitted on the authority of his father (Abu Musa Ash'ari) that the Apostle (may peace be upon him) said: There would be two gardens (in Paradise) the vessels and contents of which would be of silver, and two gardens whose vessels and contents would be of gold. The only thing intervening to hinder the people from looking at their Lord will be the mantle of Grandeur over His face in the Garden of Eden.

Book 1, Number 0347:

    Suhaib reported the Apostle (may peace be upon him) saying: When those deserving of Paradise would enter Paradise, the Blessed and the Exalted would ask: Do you wish Me to give you anything more? They would say: Hast Thou not brightened our faces? Hast Thou not made us enter Paradise and saved us from Fire? He (the narrator) said: He (God) would lift the veil, and of things given to them nothing would he dearer to them than the sight of their Lord, the Mighty and the Glorious.

Book 1, Number 0348:

    Hammad b. Salama narrated it on the same authority and added: He then recited the verse: "Those who do good will have the best reward and even more" (x. 26)

Chapter 81 : THE WAY IN WHICH THE BELIEVERS WOULD SEE THE LORD

Book 1, Number 0349:

    Abu Haraira reported: The people said to the Messenger of Allah (may peace be upon him): Messenger of Allah, shall we see our Lord on the Day of Resurrection? The Messenger of Allah (may peace be upon him) said: Do you feel any trouble in seeing the moon on the night when it is full? They said: Messenger of Allah, no. He (the Messenger) further said: Do you feel any trouble in seeing the sun, when there is no cloud over it? They said: Messenger of Allah. no. He (the Holy Prophet) said: Verily you would see Him like this (as you see the sun and the moon). God will gather people on the Day of Resurrection and say: Let every people follow what they worshipped. Those who worshipped the sun would follow the sun, and those who worshipped the moon would follow the moon, and those who worshipped the devils would follow the devils. This Ummah (of Islam) alone would be left behind and there would be hypocrites too amongst it. Allah would then come to them in a form other than His own Form, recognisable to them, and would say: I am your Lord. They would say: We take refuge with Allah from thee. We will stay here till our Lord comes to us. and when our Lord would come we would recognise Him. Subsequently Allah would come to them in His own Form, recognisable to them, and say: I am your Lord. They would say: Thou art our Lord. And they would follow Him, and a bridge would be set over the Hell; and I (the Holy Prophet) and my Ummah would be the first to pass over it; and none but the messengers would speak on that day, and the prayer of the messengers on that day would be: O Allah ! grant safety, grant safety. In Hell, there would be long spits like the thorns of Sa'dan He (the Holy Prophet) said: Have you seen Sa'dan? They replied: Yea, Messenger of Allah. He said: Verily those (hooks) would be like the thorns of Sa'dan, but no one knows their size except Allah. These would seize people for their misdeeds. Some of them would escape for their (good) deeds, and some would be rewarded for their deeds till they get salvation. When Allah would finish judging His bondsmen and because of His mercy decide to take out of Hell such people as He pleases. He would command the angels to bring out those who had not associated anything with Allah; to whom Allah decided to show mercy. those who would say: There is no god but Allah. They (the angels) would recognise them in the Fire by the marks of prostration, for Hell-fire will devour everything (limb) of the sons of Adam except the marks of prostra- tion. Allah has forbidden the fire to consume the marks of prostration. They will be taken out of the Fire having been burnt, and the water of life would be poured over them, and they will sprout as seed does In the silt carried by flood. Then Allah would finish judging amongst His bondsmen; but a man who will be the last to enter Paradise will remain facing Hell and will say: O my Lord I turn my face away from Hell, for its air has poisoned me ard its blaze has burnt me. He will then call to Allah as long as Allah would wish that he should call to Him. Then Allah, Blessed and Exalted, would say: If I did that, perhaps you would ask for more than that. He would say: I would not ask You more than this, and he would give his Lord covenants and agreements as Allah wished, and so He would turn his face away from the Fire When he turns towards the Paradise and sees it, he will remain silent as long as Allah wishes him to remain so. He will then say: O my Lord I bring me forward to the gate of the Paradise. Allah would say to him: Did you not give covenants and agreements that you would not ask for anything besides what I had given you. Woe to thee ! O son of Adam, how treacherous you are ! He would say: O my Lord ! and would continue calling to Allah till He. would say to him: If I grant you that, perhaps you will ask for more. He will reply: No, by Thy greatness, and he will give His Lord promises and covenants as Allah had wished He would then bring him to the gate of the Paradise, and when he would stand at the gate of the Paradise, it would lay open before him. and he would see the bounty and the joy that there is in it. He would remain quiet as long as Allah would desire him to remain silent. He would then say: O my Lord, admit me to Paradise. Allah. Blessed and Exalted, would say: Did you not give covenants and agreements that you would not ask for anything more than what I had granted you? Woe to you ! son of Adam, how treacherous you are! And he would say: O my Lord, I do not wish to be the most miserable of Thy creatures. He would continue calling upon Allah till Allah. Blessed and Exalted. would laugh. When Allah would laugh at him. He would say: Enter the Paradise. When he would enter, Allah would say: State your wish. He would express his wishes till Allah would remind him (the desire of) such and such (things). When his desires would be exhausted Allah would say: That is for thee and, besides it, the like of it also. 'Ata' b. Yazid said: Abu Sa'id al-Khudri was with Abu Huraira and be did not reject anything from the hadith narrated by him, but when Abu Huraira narrated: "Allah said to that man; ind its like along with it," Abu Sa'id said: "Ten like it along with it," O Abu Huraira. Abu Huraira said: I do not remember except the words: "That is for you and a similar one along with it." Abu Sa'id said: I bear witness to the fact that I remembered from the Messenger of Allah (may peace be upon him) his words: "That is for thee and ten like it." Abu Huraira said: That man was the last of those deserving of Paradise to enter Paradise.

Book 1, Number 0350:

    Abu Huraira reported: The people said to the Apostle of Allah (may peace be upon him): Messenger of Allah I shall we see our Lord on the Day of Resurrection? The rest of the hadith was narrated according to the narration of Ibrahim b. Sa'd.

Book 1, Number 0351:

    Hammam b.Munabbih said: This is what Abu Huraira transmitted to us from the Messenger of Allah (may peace be upon him), and he narrated many of them;- one of them was: The Messenger of Allah (may peace be upon him) said: The lowest in rank among you in Paradise would be asked: Desire (whatever you like). And he would express his desire and again and again express a desire. tHe would be asked: Have you expressed your desire? He would say: Yes. Then He (Allah) would say: For thee is (granted) what thou desirest, and the like of it along with it.

Book 1, Number 0352:

    Abu Sa'id al-Khudri reported: Some people during the lifetime of the Messenger of Allah (may peace be upon him) said: Messenger of Allah ! shall we see our Lord on the Day of Resurrection? The Messenger of Allah (may peace be upon him) said: Yes, and added: Do you feel any trouble in seeing the sun at noon with no cloud over it, and do you feel trouble in seeing the moon (open) in the full moonlit night with no cloud over it? They said: No, Messenger of Allah ! He (the Holy Prophet) said: You will not feel any trouble in seeing Allah on the Day of Resurrection any more than you do in seeing any one of them. When the Day of Resurrection comes a Mu'adhdhin (a proclaimer) would proclaim: Let every people follow what they used to worship. Then all who worshipped idols and stones besides Allah would fall into the Fire, till only the righteous and the vicious and some of the people of the Book who worshipped Allah are left. Then the Jews would be summoned, and it would be said to them: What did you worship? They will say: We worshipped 'Uzair, son of Allah. It would be said to them: You tell a lie; Allah had never had a spouse or a son. What do you want now? They would say: We feel thirsty, O our Lord I Quench our thirst. They would be directed (to a certain direction) and asked: Why don't you go there to drink water? Then they would be pushed towards the Fire (and they would find to their great dismay that) it was but a mirage (and the raging flames of fire) would be consuming one another, and they would fall into the Fire. Then the Christians would be summoned and it would be said to them: What did you worship? They would say: We worshipped Jesus, son of Allah. It would be said to them: You tell a lie; Allah did not take for Himself either a spouse or a son. Then it would be said to them: What do you w4nt? They would say: Thirsty we are, O our Lord ! Quench our thirst. They would be directed (to a certain direction) and asked: Why don't you go there to get water? But they would be pushed and gathered together towards the Hell, which was like a mirage to them, and the flames would consume one another. They would fall Into the Fire, till no one is left except he who worshipped Allah, be he pious or sinful. The Lord of the Universe, Glorified and Exalted, would come to them in a form recognisable to them and say; What are you looking for? Every people follow that which they worshipped. They would say: Our Lord, we kept ourselves separate from the people in the world, though we felt great need of them; we, however, did not associate ourselves with them. He would say: I am your Lord. They would say: We take refuge with Allah from thee and do not associate anything with Allah. They would repeat it twice or thrice, till some of them would be about to return. It would be said: Is there any sign between you and Him by which you will recognise Him? They would say: Yes. and the things would be laid bare. Those who used to prostrate themselves before God of their own accord would be permitted by God to prostrate themselves. But there would remain none who used to prostrate out of fear (of people) and ostentation but Allah would make his back as one piece, and whenever he would attempt to prostrate he would fall on his back. Then they would raise their heads and He would assume the Form in which they had seen Him the first time and would say: I am your Lord. They would say: Thou art our Lord. Then the bridge would be set up over the Hell and intercession would be allowed and they will say: O God, keep safe, keep safe. It was asked: Messenger of Allah, what is this bridge? He said: The void in which one Is likely to slip. There would be hooks, tongs, spits like the thorn that is found in Najd and is known as Sa'dan. The believers would then pass over within the twinkling of an eye, like lightning, like wind, like a bird, like the finest horses and camels.Some will escape and be safe, some will be lacerated and let go, and some will be pushed into the fire of Hell till the believers will find rescue from the Fire. By One in Whose hand is my life, there will be none among you more eager to claim a right than the believers on the Day of Resurrection for (saying their) brethren in the Fire who would say: O our Lord, they were fasting along with us, and praying and performing pilgrimage. It will be said to them: Take out those whom you recognise. Then their persons would be forbidden to the Fire; and they would take out a large number of people who had been overtaken by Fire up to the middle of the shank or up to the knees. They would then say: O our Lord I not one of those about whom Thou didst give us command remains in it. He will then say: Go back and bring out those in whose hearts you find good of the weight of a dinar Then they will take out a large number of people. Then they would say: O our Lord ! we have not left anyone about whom You commanded us. He will then say: Go back and bring out those in whose hearts you find as much as half a dinar of good. Then they will take out a large number of people, and would say: O our Lord ! not one of those about whom Thou commanded us we have left in it. Then He would say: Go back and in whose heart you find good to the weight of a particle bring him out. They would bring out a large number of people, and would then say: O our Lord, now we have not left anyone in it (Hell) having any good in him.
    Abu Sa'id Khudri said: If you don't testify me in this hadith, then recite if you like: "Surely Allah wrongs not the weight of an atom; and if it is a good deed. He multiplies it and gives from Himself a great reward" (al-Qur'an, iv. 40). Then Allah, Exalted and Great, would say: The angels have interceded, the apostles have inter- ceded and the believers have interceded, and no one remains (to grant pardon) but the Most Merciful of the mercifuls. He will then take a handful from Fire and bring out from it people who never did any good and who had been turned into charcoal, and will cast them into a river called the river of life, on the outskirts of Paradise. They will come out as a seed comes cut from the silt carried by flood. You see it near the stone or near the tree. That which is exposed to the sun is yellowish or greenish and which is under the shade is white. They said: Messenger of Allah ! it seems as if you had been tending a flock in the jungle. He (the Holy Prophet) said: They will come forth like pearls with seals on their necks. The inhabitants of Paradise would recognise them (and say): Those are who have been set free by the Compassionate One. Who has admitted them into Paradise without any (good) deed that they did or any good that they sent in advance Then He would say: Enter the Paradise; whatever you see in it is yours. They would say: O Lord, Thou hast bestowed upon us (favours) which Thou didst not bestow upon anyone else in the world. He would say: There is with Me (a favour) for you better than this. They would say: O our Lord ! which thing is better than this? He would say: It is My pleasure. I will never be angry with you after this

Book 1, Number 0353:

    It is narrated on the authority of Abu Sa'id al-Khudri: We said: Messenger of Allah, shall we see our Lord? The Messenger of Allah (may peace be upon him) said: Do you feel any trouble in seeing the sun on a cloudless day? We said: No. And the remaining part of the hadith has been narrated to the end like the hadith transmitted by Hafs b. Maisara with the addition of these words: Without the deed that they did or any good that they had sent before. It would be said to them: For you is whatever you see (in it) and with it the like of it. Abu Sa'id said: I have come to know that the bridge would be thinner even than the hair and sharper than the sword; and in the hadith narrated by Laith these words are not found: They would say, O our Lord ! Thou hast bestowed upon us (favours) which thou didst not bestow on anyone else in the world.

Book 1, Number 0354:

    Abu Bakr b. Abi Shaiba, Ja'far b. 'Aun, Hisham b. Sa'd, Zaid b. Aslam narrated the hadith as transmitted by Hafs b. Maisara, with certain additions and omissions.

Chapter 82 : AFFIRMATION OF INTERCESSION AND RESCUE FROM FIRE OF THE BELIEVERS IN ONENESS OF ALLAH

Book 1, Number 0355:

    Abu Sa'id al-Khudri reported: Verily the Messenger of Allah (may peace be upon him) said: Allah will admit into Paradise those deserving of Paradise, and He will admit whom He wishes out of His Mercy, and admit those condemned to Hell into the Fire (of Hell). He would then say: See, he whom you find having as much faith in his heart as a grain of mustard, bring him out. They will then be brought out burned and turned to charcoal, and would be cast into the river of life, and they would sprout aj does a seed in the silt carried away by flood. Have you not seen that it comes out yellow (fresh) and intertwined ?

Book 1, Number 0356:

    This hadith is transmitted by 'Amr b. Yahya with the same chain of transmitters who narrated: They would be cast into the river which is called (the river of) life, and (both the narrators) did not doubt the hadith. The text transmitted by Khalid is: just as seeds sprout beside the flood water; and in the hadith of Wuhaib it is: Just as the seed sprouts in the silt or deposit left by flood.

Book 1, Number 0357:

    It is reported by Abu Sa'id that the Messenger of Allah (may peace be upon him) said: The (permanent) inhabitants of the Fire are those who are doomed to it, and verily they would neither die nor live in it (al-Qur'an, xx. 47 ; lxxxvii. 13). But the people whom the Fire would afflict (temporarily) on account of their sins, or so said (the narrator) "on account of their misdeeds," He would cause them to die till they would be turned into charcoal. Then they would be granted intercession and would be brought in groups and would be spread on the rivers of Paradise and then it would be said: O inhabitants of Paradise, pour water over them; then they would sprout forth like the sprouting of seed in the silt carried by flood. A man among the people said: (It appears) as if the Messenger of Allah lived in the steppe.

Book 1, Number 0358:

    Abu Nadra narrated it from Abu Sa'id al-Khudri who reported it from the Apostle (may peace be upon him) a similar (hadith) up to the words: "in the mud of the flood," and he did not mention (the words narrated) after it.

Book 1, Number 0359:

    Abdullah b. Mas'ud reported that the Messenger of Allah (may peace be upon him) said: I know the last of the inhabitants of Fire to be taken out therefrom, and the last of the inhabitants of Paradise to enter it. A man will come out of the Fire crawling. Then Allah, the Blessed and Exalted will say to him: Go and enter Paradise. So he would come to it and it would appear to him as if it were full. He would go back and say: O my Lord ! I found it full. Allah, the Blessed and Exalted, would say to him: Go and enter Paradise. He would come and perceive as if it were full. He would return and say: O my Lord ! I found it full. Allah would say to him: Go and enter Paradise, for there is for you the like of the world and ten times like it, or for you is ten times the like of this world. He (the narrator) said . He (that man) would say: Art Thou making a fun of me ? or Art Thou laughing at me. though Thou art the King? He (the narrator) said: I saw the Messenger of Allah laugh till his front teeth were visible. And it was said: That would be the lowest rank among the inhabitants of Paradise.

Book 1, Number 0360:

    It is narrated on the authority of Abdullah b. Mas'ud that the Messenger of Allah (may peace be upon him said : I recognise the last of the inhabitants of Fire to be taken out thereof. A man will come out of it crawling. It will be said to him: Go and enter Paradise. He (the Holy Prophet) said: He would go there to enter Paradise, but would find persons who have already occupied all its apartments. It would be said to him: Do you recall the time when you were in it (in the Hell) ? He would say: Yes. It would be said to him: Express any desire. And he would express the desire. It would be said to him: For thee is that which thou desireth and ten times the world (worldly resources). He (the Holy Prophet) said: He would say: Art Thou making a fun of me, though Thou art the King ? I saw the Messenger of Allah laugh till his front teeth were visible.

Book 1, Number 0361:

    Ibn Mas'ud reported: Verily the Messenger of Allah said: The last to enter Paradise would be a man who would walk once and stumble once and be burnt by the Fire once. Then when he gets beyond it, he will turn to it and say: Blessed is He Who has saved me from thee. Allah has given me something He has not given to any one of those in earlier or later times. Then a tree would be raised up for him and he will say: O my Lord I bring me near this tree so that I may take shelter in its shade and drink of its water. Allah, the Exalted and Great, would say: O son of Adam, if I grant you this, you will ask Me for something else. He would say: No. my Lord. And he would promise Him that he would not ask for anything else. His Lord would excuse him because He sees what he cannot help desiring; so He would bring him near it, and he would take shelter in its shade and drink of its water. Afterwards a tree more beautiful than the first would be raised up before him and he would say: O my Lord ! bring me near this tree in order that I may drink of its water and take shelter in its shade and I shall not ask Thee for anything else. He (Allah) would say: O son of Adam, if I bring you near it you may ask me for something else. He would promise Him that he would not ask for anything else. His Lord will excuse him because He would see something he cannot help desiring. So He would bring him near it and he would enjoy its shade and drink its water. Then a tree would be raised up for him at the gate of the Paradise, more beautiful than the first two. He would say: O my Lord ! bring me near this (tree) so that I may enjoy its shade and drink from its water. I shall not ask Thee for anything else. He (Allah) would say: O son of Adam ! did you not promise Me that you would not ask Me anything else? He would say: Yes, my Lord, but I shall not ask Thee for anything else. His Lord would excuse him for He sees something the temptation of which he could not resist. He (Allah) would bring him near to it, and when He would bring him near it he would hear the voices of the inhabitants of the Paradise. He would say: O my Lord ! admit me to it. He (Allah) would say: O son of Adam, what will bring an end to your requests to Me? Will it please you if I give you the whole world and a like one along with it? He will say: O my Lord ! art Thou mocking at me, though Thou art the Lord of the worlds? Ibn Mas'ud laughed and asked (the hearers) : Why don't you ask me what I am laughing at. They (then) said : Why do you laugh? He said: It is in this way that the Messenger of Allah (may peace be upon him) laughed. They (the companions of the Holy Prophet) asked: Why do you laugh. Messenger of Allah? He said: On account of the laugh of the Lord of the universe, when he ldesirer of Paradise) sai Thou mocking at me though Thou art the Lord of the worlds? He would say: I am not mocking at you, but I have power to do whatever I will.

Chapter 83 : THE LOWEST OF THE RANKS IN PARADISE

Book 1, Number 0362:

    It is transmitted from Abu Sa'id al-Khudri that, verily, the Messenger of Allah (may peace be upon him) said: Amongst the inhabitants of Paradise the lowest in rank will be the person whose face Allah would turn away from the Fire towards the Paradise, and make a shady tree appear before him. He would say: O my Lord ! direct my steps to this tree so that I (should enjoy) its shade; and the rest of the hadith is like that narrated by Ibn Mas'ud, but he did not mention: "He (Allah) would say: O son of Adam ! what will bring an end to your making requests to Me" to the end of the tradition. In it, he added: Allah will remind him: Ask such and such, and when his expectations would be realised, Allah would say: That is for you, and ten times as much. He said that he would then enter his house and his two wives with large and dark eyes would enter after him. They will say: Praise be to Allah, Who has created you for us and us for you. He will say: No one has been given the like of what I have been given.

Book 1, Number 0363:

    It is reported on the authority of al-Mughira b. Shu'ba that the Messenger of Allah (may peace be upon him) said: Moses asked his Lord: Who amongst the inhabitants of Paradise is the lowest to rank? He (Allah) said : The person who would be admitted into Paradise last of all among those deserving of Paradise who are admitted to it. I would be said to him: Enter Paradise. He would gay : O my Lord ! how (should I enter) while the people have settled in their apartments and taken the shares (portions) ? It would be said to him: Would you be pleased if there be for you like the kingdom of a king amongst the kings of the world? He would say: I am pleased my Lord. He (Allah) would say: For you is that, and like that, and like that, and like that, and that. He would say at the fifth (point): I am well pleased. My Lord. He (Allah) would say: It is for you and, ten times like it, and for you is what your self desires and your eye enjoys. He would say: I am well pleased, my Lord. He (Moses) said: (Which is) the highest of their (inhabitants of Paradise) ranks? He (Allah) said: They are those whom I choose. I establish their honour with My own hand and then set a seal over it (and they would be blessed with Bounties) which no eye has seen, no ear has heard and no human mind has perceived: and this is sub- stantiated by the Book of Allah, Exalted and Great: "So no soul knows what delight of the eye is hidden for them; a reward for what they did" (xxxii. 17).

Book 1, Number 0364:

    Sha'bi reported he had heard al-Mughira b. Shu'ba say on the pulpit that Moses (peace be upon him) had asked Allah, Exalted and Great, about the reward of the lowest of the inhabitants of Paradise, and the remaining part of hadith is the same (as narrated) above.

Book 1, Number 0365:

    Abu Dharr reported that Allah's Messenger (may peace be upon him) said: I know the last of the inhabitants of Paradise to enter it and the last of the inhabitants of Hell to come out of it. He is a man who would be brought on the Day of Resurrection and it will be said: Present his minor sins to him, and withhold from him his serious Sins. Then the minor sins would be placed before him, and it would be said : On such and such a day you did so and so and on such and such a day you did so and so. He would say: Yes. It will not be possible for him to deny, while he would be afraid lest serious sins chould be presented before him. It would be said to him: In place of every evil deed you will have good deed He will say: My Lord ! I have done things I do not see here. I indeed saw the Messenger of Allah laugh till his front teeth were exposed.

Book 1, Number 0366:

    This hadith is also narrated by another chain of narrators, i.e. Ibn Numair, Abu Mu'awiya, Waki', Abu Bakr b. Abi Shaiba, Abu Kuraib, A'mash.

Book 1, Number 0367:

    It is reported on the authority of Abu Zubair that he heard from Jabir b 'Abdullah, who was asked about the arrival (of people on the Day of Resurrection). He said . We would come on the Day of Resurrection like this, like this, and see. carefully. that which concerns "elevated people". He (the narrator) said: Then the people would be summoned along with their idols whom they worshipped, one after another. Then our Lord would come to us and say: Whom are you waiting for? They would say: We are waiting for our Lord. He would say: I am your Lord. They would say: (We are not sure) till we gaze at Thee, and He would manifest Himself to them smilingly, and would go along with them and they would follow Him; and every person, whether a hypocrite or a believer, would be endowed with a light, and there would be spikes and hooks on the bridge of the Hell, which would catch hold of those whom Allah willed. Then the light of the hypocrites would be extinguished, and the believers would secure salvation. and the first group to achieve it would comprise seventy thousand men who would have the brightness of full moon on their faces, and they would not be called to account. Then the people immediately following them would have their faces as the brightest stars in the heaven. This is how (the groups would follow one after another). Then the stage of intercession would come, and they (who are permitted to intercede) would intercede, till he who had declared: "There is no god but Allah" and had in his heart virtue of the weight of a barley grain would come out of the Fire. They would be then brought in the courtyard of Paradise and the inhabitants of Paradise would begin to sprinkle water over them till they would sprout like the sprouting of a thing in flood water, and their burns would disappear. They would ask their Lord till they would be granted (the bounties) of the world and with it ten more besides it.

Book 1, Number 0368:

    Jabir reported that he had heard with his ears the Apostle (may peace be upon him) saying: Allah will bring out people from the Fire and admit them into Paradise.

Book 1, Number 0369:

    Hammad b. Zaid, reported: I said to 'Amr b. Dinar: Did you hear Jabir b. 'Abdullah narrating from the Messenger of Allah (may peace be upon him) that Allah would bring out people from the Fire through intercession. He said: Yes.

Book 1, Number 0370:

    Jabir b. 'Abdullah repotted : The Messenger of Allah (may peace be upon him) said: Verily people would be brought out from the Fire, and they would be burnt except the exterior (surfaces, fronts) of their faces; and they would enter Paradise.

Book 1, Number 0371:

    Yazid al-Faqir said: This view of the Khwarij (i.e. those who commit major sins and would be eternally doomed to Hell) had obsessed me, and we set out in a large group intending to perform the hajj and then going to the people (for the propagation of the views of the Khwarij). He (the narrator) said: We happened to past by Medina and found there Jabir b. 'Abdullah sitting near a column narrating to the people (the ahadith of) the Holy Prophet (may peace be upon him). When he mentioned the inhabitants of Hell, I said: O companion of the Messenger of Allah what is this that thou narrateth, whereas Allah sayeth: "Verily whomsoever Thou shall commit to the Fire, Thou indeed humillateth him" (al-Qur'an, iii. 192); and All those who endeavoured to get out of that would be thrown back into it" (al-Qur'an, xxxi i. 20) ? So what is it that you say? He said: Have you read the Qur'an ? I said: Yes. He said: Have you heard about' the (exalted) position of Muhammad (may peace be upon him), i.e. to which Allah would raise, him? I said: Yes. He said: Verily the position of Muhammad (may peace be upon him) is that of great glory and that is by which Allah would bring out whornsoever He would wish to bring out. He then described the Path (the Bridge) and the passing of the people over it, and said : I am afraid I may not have remembered (other things) but this much is still in my memory that people would come out of the Hell after having gone into it, and he said: They would come out of it as if they were the wood of the ebony tree. He (the narrator said: They would enter a river, one or the rivers of Paradise, and would bathe in it, and then come out as if they were (white like) paper. We then turned back and said: Woe be upon you ! How can this old man tell a lie against the Messenger of Allah (may peace be upon him)? We turned back (from the views of the Khwarij), and by God every one of us abandoned this (band of Khwarij) except one man. A similar statement has been made by Abu Nu'aim.

Book 1, Number 0372:

    It is narrated on the authority of Anas b. Malik that the Messenger of Allah (may peace be upon him) said: Four persons would be brought out from the Fire and would be presented to Allah. One of them would turn (towards the He))) and say: O my Lord, when Thou hast brought me out from it, do not throw me back into it, and Allah would rescue him from it.

Book 1, Number 0373:

    Anas b Malik reported: The Messenger of Allah (may peace be upon him) said: Allah would gather people on the Day of Resurrection and they would be concerned about it, and Ibn Ubaid said. They would get a Divine inspiration about it, and would say: If we could seek intercession with our Lord, we may be relieved from this predicament of ours. He (the Holy Prophet) said: They would come to Adam andsay, Thou art Adam, the father of mankind. Allah created thee with His own hand and breathed unto thee of His Spirit and commanded the angels and they prostrated before thee. So intercede for us with thy Lords, that He may relieve us from this position of ours. He would say: I am not in a position to do this, and would recall his error, and would fight shy of his Lord on account of that; go to Noah the first messenger (after me) sent by Allah. He (the Holy Prophet) said: So they would come to Noah (peace be upon him). He would say: I am not in a position to do that for you, and recall his fault which he had committed, and would fight shy of his Lord on account of that, (and would say): You better go to Ibrahim (peace be upon him) whom Allah took for a friend. They would come to Ibrahim (peace be upon him) and he would say: I am not in a position to do that for you, and would recall his fault that he had committed and would, therefore, fight shy of his Lord on that account (and would say): You better go to Moses (peace be upon him) with whom Allah conversed and con- ferred Torah upon him. He (the Holy Prophet) said: So they would come to Moses (peace be upon him) He would say: I am not in a position to do that for you, and would recall his fault that he had committed and would fight shy of his Lord on account of that (and would say) : You better go to Jesus, the Spirit of Allah and His word He would say: I am not in a position to do that for you; you better go to Muhammad (may peace be upon him), a servant whose former and later sins have been forgiven. He (the narrator) said: The Messenger or Allah (may peace be upon him) observed: So they would come to me and I would ask the permission of my Lord and it would be granted to me, and when I would see Him, I would fall down in prostration, and He (Allah) would leave me thus as long as He would wish, and then it would be said: O Muhammad, raise your head, say and you would be heard; ask and it would be granted; intercede and intercession would be accepted. Then I would raise my head and extrol my Lord with the praise which my Lord would teach me. I shall then inter- cede, but a limit would be set for me I would bring them out from the Fire and make them enter Paradise (according to the limit). I shall return then ard fall down in pros- tration and Allah would leave me (in that position) as long as He would wish to leave me it would be said: Rise, O Muhammad, say and you would be heard; ask and it would be conferred; intercede and intercession would be granted. I would raise my head and extrol my Lord with praise that He would teach me. I would theft intercede and a limit would be set for me. I would bring them out of the Fire (of Hell) and make them enter Paradise. He (the narrator) said: I do not remember whether he (the Holy Prophet) said at tLe third time or at the fourth time: O my Lord, none has been left in the Fire, but thise restrained by the Holy Qur'an, i e. those who were eternally doomed. Ibn Ubaid said in a narration: Qatada observed: whose everlasting stay was imperative".

Book 1, Number 0374:

    Anas reported: The Messenger of Allah (may peace be upon him) said: The believers would gather on the Day of Resurrection, and they would be concerned about it, or would be made mindful of it (i.e. the trjuble for it), (and the remaining part of the hadith w,)uld be narrated) like the one transmitted by Abu Uwana, and he said in the hadith: Then I would come for the fourth time, or I would return the fourth time, and would say: O my Lord, no one has been left but he whom the Holy Qur'an has restrained.

Book 1, Number 0375:

    Anas b. Malik reported : The Prophet of Allah (may peace be,upon him) said: Allah will gather the believers on the Day of Resurrection and they would be made mindful of it; and the rest (of the hadith) is like the one narrated above; and then he mentioned the fourth time: And I (the Holy Prophet) would say: O my Lord, no one is left in the Fire except he whom the Qur'an has restrained, i e. eternally doomed.

Book 1, Number 0376:

    Anas b. Malik reported: Verily the Apostle (may peace be upon him) said: He who professed: There is no god but Allah, would be brought out of the Fire even though he has in his heart virtue equal to the weight of a barley grain. Then he who professed: There is no god but Allah, would come out of the Fire, even though he has in his heart virtue equal to the weight of a wheat grain. He would then bring out from the Fire he who professed: There is no god but Allah, even though he has in his heart virtue equal to the weight of an atom. Ibn Minhal has made an addition (of these words) in his narration: Yazid said: I met Shu'ba and narrated to him this hadith. Shu'ba said: Qatada transmitted to us this hadith from Anas b. Malik who heard it from the Apostle of Allah (may peace be upon him) with this alteration that he substituted the word Zurra (grain) in place of Zarra (atom). Yazid said: Abu Bistam has made a change in it.

Book 1, Number 0377:

    Ma'bad b. Hilal al 'Anazi reported: We went to Anas b. Malik through Thabit and reached there (his house) while he was offering the forenoon prayer. Thabit sought permission for us and we entered, and he seated Thabit with him on his bedstead. He (Thabit) said to him (Anas b. Malik): O Abu Hamza (kunya of Anas b. Malik), your brothers from among the inhabitants of Basra ask you to narrate to them the hadith of intercession. He said: Muhammad (may peace be upon him) narrated to us: When it would be the Day of Resurrection, some of the people would rush to one another in bewilderment. They would come to Adam and say: Intercede (with your Lord) for your progeny. He would say: I am not fit to do this, but go to Ibrabim (peace be upon him) for he is the Friend of Allah. They would come to Ibrahim, but he would say: I am not fit to do this, but go to Moses, for he is Allah's Interlocutor. They would come to Moses, but he would say: I am not fit to do this, but you should go to Jesus, for he is the Spirit of Allah and His word. They would come to Jesus, and he would say, I am not fit to do this; you better go to Muhammad (may peace be upon him). They would come to me, and I would say: I am in a position to do that, I would go and ask the permission of my Lord and it would be granted to me. I would then stand before Him and would extol Him with praises which I am not able to do now, but with which Allah would inspire me, then I would fall in prostration and it would be said to me: O Muhammad, raise thy head, and say and it would be listened to; ask and it would be granted, intercede and it would be accepted. I shall say: My Lord, my people, my people It would be said: Go, and bring forth from it (Hell) him who has in his heart faith equal to the weight of a wheat grain or a barley seed. I would go and do that; then I would return to my Lord and extol Him with those praises (taught to me by Allah), then I would fall in prostration. It would be said to me: O Muhammad, raise your head, and say and it would be heard ; ask and it would be granted; intercede and intercession would be accepted. So I would say: My people. my people. It would be said to me: Go and take out from it (Hell) him who has in his heart faith equal to the weight of a mustard seed. I would go and do that. I would again return to my Lord and extol Him with those praises. I would then fall in prostration. It would be said to me: O Muhammad, raisevour head: say, and you would be listened to; ask and it would be granted; intercede and intercession would be accepted. I would say: My Lord, my people, my people. It would be said to me: Go, and bring out of the Fire him who has in his heart as much faith as the smallest, smallest, smallest grain of mustard seed. I would go and do that.
    This is the hadith which Anas narrated to us. We went out of his (house) and when we reached the upper part of Jabban (graveyard) we said: Would that we meet Hasan and salute him and he was hiding in the house of Abu Khalifa. He (Ma'bad b. Hilal, the narrator) said: We went to him and greeted him and we said: O Abu Sa'id, we come from your brother Abu Hamza (kunya of Anas), and we have never heard a hadith like this relating to intercession, which he has narrated to us. He said: Narrate it, we narrated the hadith. He said: Narrate it (still further). We said: He did not (narrate it) before us more than this. He said: He (Anas) had narrated it to us twenty years back, when he was strong and healthy. He has in fact missed something. I cannot make out whether the old man has forgotten or he has (intentionally) avoided to narrate it to you lest you should rely (absolutely) upon it (and abandon doing good deeds). We said to him: Relate that to us, and he laughed and said: There is haste in the nature of man. I did not make mention of it to you but for the fact that I wanted to narrate that to you (and added that the Holy Prophet said) : I would then return to my Lord for the fourth time and extol Him with these praises. I would then fall in prostration. It would be said to me: O Muhammad, raise your head: say and it will be listened to; ask and it will be granted; intercede and intercession would be accepted. I would say: O my Lord, permit me regarding him who professed: There is no god but Allah. He (the Lord) would say: That is not for thee or that is not what lies with thee, but by My Honour, Glory, Greatness and Might, I would certainly take him out who professed it: There is no god but Allah. He (the narrator, Ma'bad) said: I hear testimony to the fact that the hadith transmitted to us-by Hasan was heard by him from Anas b. Malik and I can see that he reported it twenty years back, when he was hale and hearty.

Book 1, Number 0378:

    Abu Huraira reported: Meat was one day brought to the Messenger of Allah (may peace be upon him) and a foreleg was offered to him, a part which he liked. He sliced with his teeth a piece out of it and said: I shall be the leader of mankind on the Day of Resurrection. Do you know why? Allah would gather in one plain the earlier and the later (of the human race) on the Day of Resurrection. Then the voice of the proclaimer would be heard by all of them and the eyesight would penetrate through all of them and the sun would come near. People would then experience a degree of anguish, anxiety and agony which they shall not be able to bear and they shall not be able to stand. Some people would say to the others: Don you see in which trouble you are ? Don't you see what (misfortune) has overtaken you? Why don't you find one who should intercede for you with your Lord? Some would say to the others: Go to Adam. And they would go to Adam and say: O Adam, thou art the father of mankind. Allah created thee by His own Hand and breathed in thee of His spirit and ordered the angels to prostrate before thee. Intercede for us with thy Lord Don't you see in what (trouble) we are? Don't you see what (misfortune) has overtaken us? Adam would say: Verily, my Lord is angry,to an extent to which He had never been angry before nor would He be angry afterward. Verily, He forbade me (to go near) that tree and I disobeyed Him.I am concerned with my own self. Go to someone else; go to Noah. They would come to Noah and would say: O Noah, thou art the first of the Messengers (sent) on the earth (after Adam), and Allah named thee as a "Grateful Servant," intercede for us with thy Lord. Don't you see in what (trouble) we are? Don't you see what (misfortune) has overtaken us? He would say: Verily, my Lord is angry today as He had never been angry before, and would never be angry afterwards. There had emanated a curse from me with which I cursed my people. I am concerned with only myself, I am concerned only with myself; you better go to Ibrahim (peace be upon him). They would go to Ibrahim and say: Thou art the apostle of Allah and His Friend amongst the inhabitants of the earth ; intercede for us with thy Lord. Don't you see in which (trouble) we are? Don't you see what (misfortune) has overtaken us? Ibrahim would say to them: Verily, my Lord is today angry as He had never been angry before and would never be angry afterwards. and (Ibrahim) would mention his lies (and then say): I am concerned only with myself, I am concerned only with myself. You better go to someone else: go to Moses. They would come to Moses (peace be upon him) and say: O Moses, thou art Allah's messenger, Allah blessed thee with His messengership and His conversation amongst people. Intercede for us with thy Lord. Don't you see in what (trouble) we are? Don't you see what (misfortune) has overtaken us? Moses (peace be upon him) would say to them: Verily. my Lord is angry as He had never been angry before and would never be angry afterwards. I, in fact, killed a person whom I had not been ordered to kill. I am concerned with myself, I am concerned with myself. You better go to Jesus (peace be upon him). They would come to Jesus and would say: O Jesus, thou art the messenger of Allah and thou conversed with people in the cradle, (thou art) His Word which I-Ie sent down upon Mary. and (thou art) the Spirit from Him; so intercede for us with thy Lord. Don't you see (the trouble) in which we are ? Don't you see (the misfortune) that has overtaken us? Jesus (peace be upon him) would say: Verily, my Lord is angry today as He had never been angry before or would ever be angry after- wards. He mentioned no sin of his. (He simply said:) I am concerned with myself, I am concerned with myself; you go to someone else: better go to Muhammad (may peace be upon him). They would come to me and say: O Mahammad, thou art the messenger of Allah and the last of the apostles. Allah has pardoned thee all thy previous and later sins. Intercede for us with thy Lord ; don't you see in which (trouble) we are ? Don't you see what (misfortune) has overtaken us ? I shall then set off and come below the Throne and fall down prostrate before my Lord; then Allah would reveal to me and inspire me with some of His Praises and Glorifications which He had not revealed to anyone before me. He would then say: Muhammad, raise thy head ; ask and it would be granted; intercede and intercession would be accepted I would then raise my head and say: O my Lord, my people, my people. It would be said: O Muhammad, bring in by the right gate of Paradise those of your people who would have no account to render. They would share with the people some other door besides this door. The Holy Prophet then said: By Him in Whose Hand is the life of Muhammad, verify the distance between two door leaves of the Paradise is as great as between Mecca and Hajar, or as between Mecca and Busra.

Book 1, Number 0379:

    It is reported on the authority of Abu Huraira that there was placed before the Messenger of Allah a cup of soft bread, soup and meat. He took part of the foreleg which he liked most. He sliced (with his teeth) a slice (out of that) and said: I would be the leader of mankind on the Day of Resurrection. He then sliced (that meat) for the second time and said: I am the leader of mankind on the Day of Resurrection. When he saw that his companions did not ask him (about this assertion) he said: Why don't you say: How would that be ? They said: How would be it, Messenger of Allah? He said : People would stand before the Lord of the worlds. And the rest of the hadith was narrated like the one transmitted by Abu Hayyan, on the authority of Abu Zur'a, and in the story of Ibrahim, this addition was made. He said and made mention of his words with regard to the star: This is my Lord. And his words with regard to their gods: But the big among them has done that. And his words: I am ailing. He (the Holy Prophet) said: By Him in Whose Hand is the life of Muhammad, the distance between two leaves of the door from their supporting frames is as the distance between Mecca and Hajar or Hajar and Mecca. I do not remember how he said it (whether Mecca and Hajar or Hajar and Mecca).

Book 1, Number 0380:

    It is narrated on the authority of Abu Huraira and Hudhaifa that the Messenger of Allah (may peace be upon him) said: Allah, the Blessed and Exalted, would gather people. The believers would stand till the Paradise would be brought near them. They would come to Adam and say: O our father, open for us the Paradise. He would say: What turned ye out from the Paradise was the sin of your father Adam. I am not in a position to do that ; better go to my son Ibrahim, the Friend of Allah. He (the Holy Prophet) said: He (Ibrahim) would say: I am not in a position to do that. Verily I had been the Friend (of Allah) from beyond, beyond; you better approach Moses (peace be upon him) with whom Allah conversed. They would come to Moses (peace be upon him), but he would say: I am not in a position to do that; you better go to Jesus, the Word of Allah and His Spirit. Jesus (peace be upon him) would say: I am not in a position to do that. So they would come to Mubammad (may peace be upon him). He would then be permitted (to open the door of Paradise). Trust worthiness and kinship would be despatched, and these would stand on the right and left of the Path and the first of you would pass with (the swiftness) of lightning. He (the narrator) said: I said, O thou who art far dearer to me than my father and my mother I which thing is like the passing of lightning? He said: Have you not seen lightning, how it passes and then comes back within the twinkling of an eye? Then (they would pass) like the passing of the wind, then like the passing of a bird, and the hastening of persons would be according to their deeds, and your Apostle would be standing on the Path saying: Save, O my Lord, save. (The people would go on passing) till the deeds of the servants would be failing in strength, till a man would come who would find it hard to go along (that Path) but crawlingly. He (the narrator) said: And on the sides of the Path hooks would be suspended ready to catch anyone whom these would be required (to catch). There would be those who would somehow or other succeed in trasversing that Path and some would be piled up in Hell. By Him in Whose Hand is the life of Abu Huraira it would take one seventy years to fathom the depth of Hell.

Chapter 84 : PERTAINING TO THE WORDS OF THE APOSTLE OF ALLAH (MAY PEACE BE UPON HIM): "I WOULD BE THE FIRST AMONG PEOPLE TO INTERCEDE IN THE PARADISE AND AMONG THE APOSTLES I WOULD HAVE THE LARGEST FOLLOWING"

Book 1, Number 0381:

    Anas b. Malik reported: The Messenger of Allah (may peace be upon him) said: I would be the first among people to intercede in the Paradise and amongst the apostles I would have the largest following (on the Day of Resurrection).

Book 1, Number 0382:

    Anas b. Malik reported: The Messenger of Allah (may peace be upon him) said: Amongst the apostles I would have the largest following on the Day of Resurrec tion, and I would be the first to knock at the door of Paradise.

Book 1, Number 0383:

    Anas b. Malik said: The Apostle of Allah (may peace be upon him) said: I would be the first intercessor in the Paradise and no apostle amongst the apostles has been testified (by such a large number of people) as I have been testified. And verily there woald be an apostle among the apostles who would be testified to by only one man from his people.

Book 1, Number 0384:

    Anas b. Malik reported: The Messenger of Allah (may peace be upon him) said: I will come to the gate of Paradise on the Day of Resurrection. and would seek its opening. and the keeper would say: Who art thou? I would say: Muhammad. He would then say: It is for thee that I have been ordered, and not to open it for anyone before thee.

Book 1, Number 0385:

    Abu Huraira reported: Verity the Messenger of Allah (may peace be upon him) said: There is for every apostle a (special) prayer with which he would pray. I wish I could reserve, my prayer for intercession of my Ummah on the Day of Resurrection.

Book 1, Number 0386:

    Abu Huraira reported: The Messenger of Allah (may peace be upon him) said: There is for every apostle a prayer, and I intend (if Allah so willed) that I would reserve my prayer for the intercession of my Ummah on the Day of Resurrection.

Book 1, Number 0387:

    'Amr b. Abu Sufyan transmitted a hadith like this from Abu Huraira who narrated it from the Messenger of Allah (may peace be upon him).

Book 1, Number 0388:

    Amr b. Abu Sufyan reported: Abu Huraira said to Ka'b al-Ahbar that the Apostle of Allah (may peace be upon him) had said: For every apostle there Is a (special) prayer by which he would pray (to his Lord). I, however, intend (if Allah so willed) that I would reserve my prayer for the intercession of my Ummah on the Day of Resurrection. Ka'b said to Abu Huraira: Did you hear this from the Messenger of Allah (may peace be upon him)? Abu Huraira said: Yes.

Book 1, Number 0389:

    Abu Huraira said: The Prophet of Allah (may peace be upon him) said: There is for every apostle a prayer which is granted, but every prophet showed haste in his prayer. I have, however, reserved my prayer for the intercession of my Ummah on the Day of Resurrection, and it would be granted, if Allah so willed, in case of everyone amongst my Ummah provided he dies without associating anything with Allah.

Book 1, Number 0390:

    Abu Huraira said: The Messenger of Allah (may peace be upon him) said: Every Messenger is endowed with a prayer which is granted and by which he would (pray to his Lord) and it would he granted for him. I have, however, reserved my prayer for the intercession of my Ummab on the Day of Resurrection.

Book 1, Number 0391:

    Abu Huraira reported: The Messenger of Allah (may peace be upon him) said: There was for every apostle a prayer with which he prayed for his Ummah and it was granted to him; but I wish, if Allah so wills, to defer my prayer for the intercession of my Ummah on the Day of Resurrection.

Book 1, Number 0392:

    Anas b. Malik reported: Verily the Apostle of Allah (may peace be upon him) said: There is for every apostle a prayer with which he prays (to Allah) for his Ummah. I have reserved my prayer for the intercession of my Ummah on the Day of Resurrection.

Book 1, Number 0393:

    This hadith is narrated with the same chain of narrators by Qatada.

Book 1, Number 0394:

    Mis'ar transmitted it with the same chain of narrators from Qatada except that in the hadith narrated by Waki' (the Prophet) said: "He was endowed," and in the hadith reported by Abu Usama (the words are): "It is reported from the Apostle of Allah (may peace be upon him)."

Book 1, Number 0395:

    Muhammad b. 'Abd al-A'la reported it to me: Mu'tamir narrated to us on the authority of his father who transmitted it liom Anas that verity the Apostle of Allah (may peace be upon him) said, and then narrated the hadith like the one transmitted by Qatada on the authority of Anas.

Book 1, Number 0396:

    Abu Zubair heard Jabir b. Abdullah reporting it from the Apostle of Allah (may peace be upon him): For every apostle was a prayer with which he prayed (to his Lord) for his Ummah, but I have reserved my prayer for the intercession of my Ummah on the Day of Resurrection.

Chapter 85 : PRAYER OF THE APOSTLE (MAY PEACE BE UPON HIM) FOR HIS UMMAH AND HIS BEING MOVED TO TEARS ON ACCOUNT OF HIS AFFECTION FOR THEM

Book 1, Number 0397:

    'Abdullah b. Amr b. al-'As reported: Verily the Apostle of Allah (may peace be upon him) recited the words of Allah, the Great and Glorious, that Ibrahim uttered. My Lord ! lo! they have led many of mankind astray: "But whoso followeth me, he verily is of me" (al-Qur'an, xiv. 35) and Jesus (peace be upon him) said: "If thou punisheth them, lo! they are Thy slaves, and if Thou forgiveth them-verily Thou art the Mighty, the Wise" (al-Qur'an, v 117). Then he raised his hands and said: O Lord, my Ummah, my Ummah, and wept; so Allah the High and the Exalted said: O Gabriel, go to Muhammad (though your Lord knows it fully well) and ask him: What makes thee weep? So Gabriel (peace be upon him) came to him and asked him, and the Messenger of Allah (may peace be upon him) informed him what he had said (though Allah knew it fully well). Upon this Allah said: O Gabriel, go to Muhammad any say: Verily We will please thee with regard to your Ummah and would not displease thee.

Chapter 86 : HE WHO DIED WITH UNBELIEF WOULD BE (THROWN) INTO THE FIRE, INTERCESSION WOULD BE OF NO AVAIL TO HIM AND THE RELATIONSHIP OF HIS FAVOURITES WOULD NOT BENEFIT HIM

Book 1, Number 0398:

    Anas reported: Verily, a person said: Messenger of Allah, where is my father? He said: (He) is in the Fire. When he turned away, he (the Holy Prophet) called him and said: Verily my father and your father are in the Fire.

Chapter 87 : REGARDING THE WORDS OF ALLAH: "AND WARN THY NEAREST KINDRED"

Book 1, Number 0399:

    Abu Huraira reported: When this verse was revealed: "And warn thy nearest kindred (al-Qur'an, xxvi. 214), the Messenger of Allah (may peace be upon him) called the Quraish; so they gathered and he gave them a general warning. Then he made a particular (reference to certain tribes) and said: O sons of Ka'b b. Luwayy, rescue yourselves from the Fire; O sons of Murra b. Ka'b, rescue yourselves from the Fire: O sons of Abd Shams, rescue yourselves from the Fire; 0 sons of Abd Manaf rescue yourselves from the Fire; O sons of Hashim, rescue yourselves from the Fire; 0 sons of Abd al-Muttalib, rescue yourselves from the Fire; O Fatimah, rescue thyself from the Fire, for I have no power (to protect you) from Allah in anything except this that I would sustain relationship with you.

Book 1, Number 0400:

    The same hadith is narrated by Ubaidallah b. Umar al-Qawariri from Abu 'Uwana, who transmitted it to 'Abd al-Malik b. 'Umair on the same chain of transmitter and the hadith of Jarir is more perfect and comprehensive.

Book 1, Number 0401:

    It is narrated on the authority of 'A'isha that when this verse was revealed: "And warn thy nearest kindred," the Messenger of Allah (may peace be upon him) stood up on Safa' and said: O Fatima, daughter of Muhammad. O Safiya, daughter of 'Abd al-Muttalib, O sons of 'Abd al-Muttalib. I have nothing which can avail you against Allah; you may ask me what you want of my worldly belongings.

Book 1, Number 0402:

    Abu Huraira reported: When (this verse) was revealed to him: "Warn your nearest kinsmen." the Messenger of Allah (may peace be upon him) said: O people of Quraish, buy yourselves from Allah, I cannot avail you at all against Allah; O sons of Abd al-Muttalib. I cannot avail you at all against Allah; 0 Abbas b. 'Abd al- Muttalib, I cannot avail you at all against Allah; O Safiya (aunt of the Messenger of Allah), I cannot avail you at all against Allah; 0 Fatima, daughter of Muhammad, ask me whatever you like, but I cannot avail you at all against Allah.

Book 1, Number 0403:

    This hadith is narrated from the Apostle (may peace be upon him) by another chain of narrators, 'Amr al-Naqid, Mu'awiya b. 'Amr, Abdullah b. Dhakwan, A'raj on the authority of Abu Huraira.

Book 1, Number 0404:

    Qabisa b. al-Mukhariq and Zuhair b. 'Amr reported: When this verse was revealed: "And warn thy nearest kindred," the Apostle of Allah (may peace be upon him) set off towards a rock of the hill and ascended the highest of the rocks and then called: 0 sons of 'Abd Manaf! I am a warner; my similitude and your similitude is like a man who saw the enemy and went to guard his people, but, being afraid they might get there before him, he shouted: Be on your guard!

Book 1, Number 0405:

    This hadith is narrated from the Apostle of Allah (may peace be upon him) by another chain of narrators, Muhammad b. Abd al-A'la, Mu'tamir, Abu 'Uthman, Zuhair b. 'Amr, Qabisa b. Mukhariq.

Book 1, Number 0406:

    It is reported on the authority of Ibn 'Abbas that when this verse was revealed: "And warn thy nearest kindred" (and thy group of selected people among them) the Messenger of Allah (may peace be upon him) set off till he climbed Safa' and called loudly: Be on your guard! They said: Who is it calling aloud? They said: Muhammad. They gathered round him, and he said: O sons of so and so, O sons of so and so, O sons of 'Abd Manaf, O sons of 'Abd al-Muttalib, and they gathered around him. He (the Apostle) said: If I were to inform you that there were horsemen emerging out of the foot of this mountain, would you believe me? They said: We have not experienced any lie from you. He said: Well, I am a warner to you before a severe torment. He (the narrator) said that Abu Lahab then said: Destruction to you! Is it for this you have gathered us? He (the Holy Prophet) then stood up, and this verse was revealed: "Perish the hands of Abu Lahab, and he indeed perished" (cxi. 1). A'mash recited this to the end of the Sura.

Book 1, Number 0407:

    This hadith was narrated by A'mash on the authority of the same chain of narrators and he said: One day the Messenger of Allah (may peace be upon him) climbed the hill of Safa' and said: Be on your guard, and the rest of the hadith was narrated like the hadith transmitted by Usama ; he made no mention of the revelation of the verse: "Warn thy nearest kindred."

Chapter 88 : INTERCESSION OF THE MESSENGER OF ALLAH (MAY PEACE BE UPON HIM) FOR ABU TALIB AND SOME REMISSION FOR HIM ON THIS ACCOUNT

Book 1, Number 0408:

    It is reported on the authority of 'Abbas b. Abd al-Muttalib that he said: Messenger of Allah, have you benefited Abu Talib in any way for he defended you and was fervent in your defence ? The Messenger of Allah (may peace he upon him) said: Yes; he would be in the most shallow part of the Fire: and but for me he would have been in the lowest part of Hell.

Book 1, Number 0409:

    Abdullah b. al-Harith reported: I heard Abbas say: I said: Messenger of Allah, verily Abu Talib defended you and helped you; would it be beneficial for him? He (the Holy Prophet) said: Yes; I found him in the lowest part of the Fire and I brought him to the shallow part.

Book 1, Number 0410:

    This hadith is narrated from the Apostle (may peace be upon him) like one narrated by Abu 'Uwana on the authority of the chain of transmitters like Muhammad b. Hatim, Yahya b. Sa'id, Abu Sufyan, 'Abbas b. 'Abd al-Muttalib and others.

Book 1, Number 0411:

    Abu Sa'id al-Khudri reported: A mention was made of his uncle Abu Talib before the Messenger of Allah (may peace be upon him) He said: My intercession may benefit him on the Day of Resurrection and he may be placed in the shallow part of the Fire which would reach his ankles and his brain would be boiling.

Book 1, Number 0412:

    Abu Sa'id al-Khudri reported: Verily, the Messenger of Allah (may peace be upon him) said: The least tormented of the inhabitants of the Fire would be he who would wear two shoes of Fire and his brain would boil on account of the heat of the shoes.

Book 1, Number 0413:

    Ibn 'Abbas reported: The Prophet (may peace be upon him) said: Among the inhabitants of the Fire Abu Talib would have the least suffering, and he would be wearing two shoes (of Fire) which would boil his brain.

Book 1, Number 0414:

    Nu'man b. Bashir was delivering an address and saying: I heard the Messenger of Allah (may peace be upon him) say: the least suffering for the inhabitants of Hell on the Day of Resurrection would be for the man under whose soles would be placed two embers and his brain would boil on account of them.

Book 1, Number 0415:

    Nu'man b. Bashir reported: The Messenger of Allah (may peace be upon him) said: Verily the least suffering for the inhabitants of Fire would be for him who would have two shoes and two laces of Fire (on his feet), and with these would boil his brain as boils the cooking vessel, and he would think that he would not see anyone in a more grievous torment than him, whereas he would be in the least torment.

Chapter 89 : PROOF IN SUPPORT OF THE FACT THAT HE WHO DIED IN UNBELIEF HIS DEED WOULD NOT BE OF ANY AVAIL TO HIM

Book 1, Number 0416:

    'A'isha reported: I said: Messenger of Allah, the son of Jud'an established ties of relationship, fed the poor. Would that be of any avail to him? He said: It would be of no avail to him as he did not ever say: O my Lord, pardon my sins on the Day of Resurrection.

Chapter 90 : FRIENDSHIP WITH BELIEVERS AND DISSOCIATION WITH NON-BELIEVERS AND SEVERANCE FROM THEM

Book 1, Number 0417:

    'Amr b. 'As reported: I heard it from the Messenger of Allah (may peace be upon him) quite audibly and not secretly: Behold! the posterity of my fathers, that is, so and so, are not my friends. Verily Allah and the pious believers are my friends.

Chapter 91 : THE ADMITTANCE INTO PARADISE OF A GROUP OF MUSLIMS WITHOUT RENDERING ANY ACCOUNT AND SUFFERING PUNISHMENT (TORMENT)

Book 1, Number 0418:

    It is narrated on the authority of Abu Huraira that the Apostle of Allah (may peace be upon him) said: Seventy thousand (persons) of my Ummah would enter Paradise without rendering an account. Upon this a person said: Messenger of Allah. pray to Allah that He make me one of them. He (the Holy Prophet) said: O Allah! make him one of them. Then another stood up and said: Messenger of Allah, pray to Allah that He make me one of them. He (the Holy Prophet) said: 'Ukkasha has preceded you in this matter.

Book 1, Number 0419:

    Muhammad b. Ziyad reported: I heard Abu Huraira narrate this: I heard it from the Messenger of Allah(may peace be upon him) saying a hadith like one narrated by al-Rabi'.

Book 1, Number 0420:

    Abu Huraira reported: I heard it from the Messenger of Allah (may peace be upon him) saying: A group of my Ummah consisting of seventy thousand persons would enter Paradise; their faces would be as bright as the brightness of the full moon. Abd Huraira said: 'Ukkasha b. Mihsan al-Asadi then stood up wrapping the blanket around him and said: Messenger of Allah, supplicate (before) Allah that He should make me one among them. Upon this the Messenger of Allah (may peace be upon him) said: O Allah, make him among them. Then stood up a man from the Ansa and said: Messenger of Allah, pray to Allah that He should make me one among them. The Messenger of Allah (may peace be upon him) said: 'Ukkasha has preceded you in this matter.

Book 1, Number 0421:

    Abu Huraira reported: The Messenger of Allah (may peace be upon him) said: Seventy thousand (persons) would enter Paradise as one group and among them (there would be people) whom faces would be bright like the moon.

Book 1, Number 0422:

    It is reported on the authority of 'Imran that the Apostle of Allah (may peace be upon him) said: Seventy thousand people of my Ummah would be admitted into Paradise without rendering any account. They (the companions) said: Who would be of those (fortunate persons)? He (the Holy Prophet) said: Those who do not cauterise and practise charm, but repose trust in their Lord, 'Ukkasha then stood up and said: Supplicate (before) Allah that He should make me one among them. He (the Holy Prophet) said: Thou art one among them He (the narrator) said: A man stood up and said: Apostle of Allah, supplicate (before) Allah that He should make me one among them. He (the Holy Prophet said: 'Ukkasha has preceded you (in this matter).

Book 1, Number 0423:

    'Imran b. Husain reported: Verily the Messenger of Allah (may peace be upon him) said: Seventy thousand men of my Ummah would enter Paradise without rendering account. They (the companions of the Holy Prophet) said: Who would be those, Messenger of Allah? He (the Holy Prophet) said: They would be those who neither practise charm, not take omens, nor do they cauterise, but they repose their trust in their Lord.

Book 1, Number 0424:

    Abu Hazim narrated it on the authority of Ibn Sa'd that the Messenger of Allah (may peace be upon him) said: Seventy thousand persons or seven hundred thousand persons (Abu Hazim does not remember the exact number) would enter Paradise holding and supporting one another, and the first among them would not enter till the last among them would enter (therein); (they would enter simultaneously) and their faces would be bright like the full moon.

Book 1, Number 0425:

    Husain b. 'Abd al-Rahman reported: I was with Sa'id b. Jubair when he said: Who amongst you saw a star shooting last night? I said: It was I; then I said: I was in fact not (busy) in prayer, but was stung by a scorpion (and that is the reason why I was awake and had a glimpse of the shooting star). He said: Then what did you do? I said: I practised charm. He said: What urged you to do this? I said: (I did this according to the implied suggestion)of the hadith which al-Shu'ba narrated. He said: What did al-Shu'ba narrate to you? I said: Buraida b. Husaib al-Aslami narrated to us. The charm is of no avail except in case of the (evil influence) of an eye or the sting of a scorpion. He said: He who acted according to what he had heard (from the Holy Prophet) acted rightly, but Ibn 'Abbas narrated to us from the Apostle of Allah (may peace be upon him) that he said: There were brought before me the peoples and I saw an apostle and a small group (of his followers) along with him, another (apostle) and one or two persons (along with him) and (still another) apostle having no one with him. When a very large group was brought to me I conceived as if it were my Ummah. Then it was said to me: It is Moses and his people. You should look at the horizon, and I saw a very huge group. It was again said to me: See the other side of the horizon, and there was (also) a very huge group. It was said to me: This is your Ummah, and amongst them there were seventy thousand persons who would be made to enter Paradise without rendering any account and without (suffering) any torment. He then stood up and went to his house. Then the people began to talk about the people who would be admitted to Paradise without rendering any account and without (suffering) any torment. Some of them said: They may be those who (have had the good fortune of living) in the company of the Messenger of Allah (may peace be upon him) and some of them said: They be those who were born in Islam and did not associate anything with Allah. Some people mentioned other things. Thereupon came forth the Messenger of Allah (may peace be upon him) before them and he said: What was that which you were talking about? They informed him. He said: They are those persons who neither practise charm, nor ask others to practise it, nor do they take omens, and repose their trust in their Lord. Upon this 'Ukkasha b. Mihsan stood up and said: Supplicate for me that He should make me one among them. Upon this he (Messenger of Allah) said: Thou are one among them. Then another man stood up and said: Supplicate before Allah that He should make me one among them. Upon this he said: 'Ukkisha has preceded you.

Book 1, Number 0426:

    Ibn 'Abbas reported: The Messenger of Allah (may peace be upon him) said: Peoples would be presented to me (on the Day of Resurrection), and then the remaining part of the hadith was narrated like the one transmitted by Hushaim, but he made no mention of the first portion.

Chapter 92 : THIS UMMAH (UMMAH OF ISLAM) WOULD CONSTITUTE HALF OF THE INHABITANTS OF PARADISE

Book 1, Number 0427:

    Abdullah b. Mas'ud reported: The Messenger of Allah (may peace be upon him) addressing us said: Aren't you pleased that you should constitute one-fourth of the inhabitants of Paradise? He (the narrator) said: We glorified (our Lord, i.e. we called aloud Allah-o Akbar, Allah is the Greatest). He, then, again said: Aren't you pleased that you should constitute one-third of the inhabitants of Paradise? He (the narrator) said: We glorified (our Lord) and he (the Holy Prophet) then again said: I hope that you would constitute half of the inhabitants of Paradise and I shall explain to you its (reason). The believers among the unbelievers would not be more than a white hair on (the body of a) black ox or a black hair on (the body of a) white ox.

Book 1, Number 0428:

    'Abdullah (b. Mas'ud) reported: We, about forty men, were with the Messenger of Allah (may peace be upon him) in a camp when he said: Aren't you pleased that they should constitute one-fourth of the inhabitants of Paradise? He (the narrator) said: Yes. He (the Holy Prophet) again said: Aren't you pleased that you should constitute one-third of the inhabitants of Paradise? They said: Yes. Upon this he again said: By Him in Whose Hand is my life, I hope that you would constitute one-half of the inhabitants of Paradise and the reason is that no one would be admitted into Paradise but a believer and you are no more among the polytheists than as a white hair on the skin of a black ox or a black hair on the skin of a red ox.

Book 1, Number 0429:

    Abdullah b Mas'ud reported: The Messenger of Allah (may peace be upon him) addressed us and then supported his back (by reclining) against a leather tent and said: Behold, no one but a believing person would enter Paradise. O Allah, (see) have I conveyed (it not)? 0 Allah, be witness (to it that I have conveyed it). (Then addressing the companions) he said: Don't you like that you should constitute one-fourth of the inhabitants of Paradise? We said: Yes, Messenger of Allah. He again said: Don't you like that you should constitute one-third of the inhabitants of Paradise? They said: Yes, Messenger of Allah. He said: I hope that you would constitute one- half of the inhabitants of Paradise and you would be among the peoples of the world, like a black hair on (the body of) a white ox or like a white hair on the body of a black ox.

Book 1, Number 0430:

    Abu Sa'id reported: The Messenger of Allah (may peace be upon him) said: Allah, the High and Glorious, would say: O Adam I and he would say: At Thy service, at thy beck and call, O Lord, and the good is in Thy Hand. Allah would say: Bring forth the group of (the denizens of) Fire. He (Adam) would say: Who are the denizens of Hell? It would be said: They are out of every thousand nine hundred and ninety-nine. He (the Holy Prophet) said : It is at this juncture that every child would become white-haired and every pregnant woman would abort and you would see people in a state of intoxication, and they would not be in fact intoxicated but grievous will be the torment of Allah. He (the narrator) said: This had a very depressing effect upon them (upon the companions of the Holy Prophet) and they said : Messenger of Allah, who amongst us would be (that unfortunate) person (who would be doomed to Hell)? He said: Good tidings for you, Yajuj Majuj would be those thousands (who would be the denizens of Hell) and a person (selected for Paradise) would be amongst you. He (the narrator) further reported that he (the Messenger of Allah) again said: By Him in Whose Hand is thy life, I hope that you would constitute one-fourth of the inhabitants of Paradise. We extolled Allah and we glorified (Him). He (the Holy Prophet) again said: BY Him in Whose Hand is my life, I wish you would constitute one-third of the inhabitants of Paradise. We extolled Allah and Glorified (Him). He (the Holy Prophet) again said: By Him in Whose Hand is my life, I hope that you would constitute half of the inhabitants of Paradise. Your likeness among the people is the likeness of a white hair on the skin of a black ox or a strip on the foreleg of an ass.

Book 1, Number 0431:

    The same hadith has been narrated from A'mash on the authority of the same chain of transmitters with the exception of these words: You would be no more among men (on the Day of Resurrection) but like a white hair on (the body of) a black ox, or like a black hair on (the body of) a white ox, and he made no mention of: a strip on the foreleg of an ass.

EPILOGUE

    Before we close the "Kitab-ul-Iman," it seems necessary to bring a few facts before our readers. This book deals with the beliefs, i.e. those unseen realities which we have a strong yearning to comprehend, but which elude the grasp of our senses.

    Every person, who is endowed with consciousness, is instinctively impelled to know whence he came and where he would return. What would become of him after crossing the bar of life? Is the short span of this wordly life the culmination of all his hopes and desires and nothing remains after it? These are the questions which agitate the mind of every man, whether he is a believer or a non-believer, whether he is a monotheist or a polytheist or an atheist. We cannot silence the echoes of our souls by simply saying that nothing can be said with certainty about them. The mind yearns for definite and satisfactory answers to all of them. That is what is embedded in our very nature and so long as we are human beings we cannot afford to ignore them. We approach scientists for the solution of these spiritual problems of ours which have a direct bearing on our social life, but scientists have no definite answers to give since they are concerned only with observable facts, that is to say, the optically present source of sensation, which forms only a fraction of man's life and the vast sea of "unseen world" lies hidden before them. That is the reason why even a scientist has to fall back upon chance-a very imortant admission as to the limits of the so-called scientific knowledge and the possibility of another knowledge unknown to science and altogether different from that with the help of which we observe physical phenomena and their laws.

    Moreover, the scientific method cannot help us solve the problem of "whence" and "whither". There is always an urge in our hearts to peep across this life hemmed in by space and time and find out our ultimate destiny. Since science deals with "actual," with what is here and now, particularly what can be comprehended with the helpof senses, there is inherent in science a natural tendency to assure that man, too, like inanimate matter, is a bubble that bursts and a vision that fades. If we take this view of man, which is the inevitable conclusion of the so-called "scientific inquiry," the whole of human life in which man plays such a prominent role becomes a meaningless riddle, for he is denied the existence of spiritual yearning in him which is nothing but a sort of cruel joke with man. "Life," says Dr Muhammad Iqbal (Reconstruction of Religious Thought in Islam, pp 50-1), "with its intense feeling of spontaneity constitutes a centre of indetermination, and thus falls outside, the domain of necessity. . . The biologist who seeks a mechanical explanation of life is led to do so because he confines his study to the lower forms of life whose behaviour discloses resemblances to mechanical action. If he studies life as manifested in himself, i.e., his own mind freely choosing, rejecting, reflecting, surveying the past and the present, and dynarnically imagining the future. he is sure to be convinced of the inadequacy of his mechancal concepts."

    The observable facts or, in other words, the physical entities form only a part of the Reality. On how to know and comprehend the other parts which concern us more intimately than the physical entities. science has nothing definite to say except a meaningful silence which betrays its natural limitation in solving these vital problems of life.

    Psychology, too, is inherently incompetent to comprehend the unseen Realities of the universe. Life, as we all know. is a great mystery everrin its biological aspects; how mysterious it is in its spiritual and moral aspects, we cannot imagine. Psychology has been-able to grope in the darkness of unconscious and ,ub-conscious chambers and has not been able to bring into light the secrets of the human soul. "Psychology," says Waiter Leibrecht (Religion and Culture, p. 33), "can show us what man is not. It cannot tell us what man, each one of us, is. The legitimate aim of psychology is the negative, the removal of distortions and illusions, but not the positive, the full and complete knowledge of human being." The fact is that human knowledge and intellect, in spite of their boastful claims, are by nature so much handicapped that they, unaided by revelation, cannot in any way comprehend the unseen Realities. What the intellect at the most can do is to transform the sense-data into conceptual forms, but it has to depend ultimately upon experience and is, therefore, subjected to the same limitations to which the knowledge of pysical sciences is subjected. "The intellect," say Ibn Khaldun, is a correct scale. Its indications are completely certain and in no way wrong. However, the intellect should not be used to weigh such matters as the oneness of God, the Hereafter, the truth of prophecy, the real character of Divine Attributes, or anything else that lies beyond the level of the intellect. That would mean to aspire for the impossible. One might compare it with a man who sees a scale in which gold is being weighed, and wants to weigh mountains in it. This (the fact that it is impossible) does not prove that the indications of the scale are not true (when it is used for its proper purpose). However, there is a limit at which intellect must stop. It cannot go beyond its own level" (The Muqaddimah, translated by Franz Rosenthal, Vol. III. p. 38). What a man in the cold regions of an arid intellectualism can, at his best, infer is only the existence of a Prime Cause, but to far as His Attributes, His will, His behaviour with humanity and His Creation, and our relation with Him are concerned. Intellect has nothing positive to say. It is at this stage that man instinctively feels the need of an agency which shoure provide him authentic information about unseen rmuties of life. This agencv is known as Prophethoud. The Great Lord, Who has provided man with materiaf resources for the satisfaction of his macerial needs, has also made suitable arrangements to acquaint us fully with the Unseen Realities which our souls yearn to know. This knowledge of the Unseen is vouchsafed to us through His trusted Messengers (prophets).This is an immense savour from our Lord, immeasurably more valuable then the material resources for, without it, human souls would have suffered the pangs of privation and would have ultimately died. The Qur'an says:

      All praise is due to Allah.Who guided us to this.And we would not have found the way if Allah had not guided us. Certainly the Messengers of our Lord brought the Truth (vii. 43).

    Just as the information of the Holy Prophet pertaining to our worldly life is perfectly correct judged by any standard, in the same way his revelations concerning the Unseen. e.g. the Day of Resurrection, Paradise and Hell, will also be perfectly true. because he As Amin. the Truthful.We should, however, bear in mind that since we are living in a world of senses it is, therefore, through sensory experiences that we comprehend it. A man's mind is so much hemmed in by space and time and his vision is so much limited by the material aspects of his life that it is only through material concepts that his mind is led to the knowledge of the Unseen. That is the reason why one can easily find frequent use of metaphors and similes in the language of the Holy Prophet as be explained the Unseen Realities of existence. These are not myths, but the Great undeniable Truths which our souls yearn to know, affirm and believe. but which our own intelligence fails to comprehend.


BOOK 2: Purification (Kitab Al-Taharah)

KITAB AL-TAHARAH
(THE BOOK OF PURIFICATION)

Back
INTRODUCTION

    We have read in the first Book that the love of Allah is the highest aim of a true believer. It is for the achievement of this single end that he affirms his faith in Him by renouncing all other types of godhood.

    The love of God is not something inert or lifeless; it is dynamic in the sense that it calls for a complete change in the life of man: change in his thoughts and ideas and change in his conduct and behaviour. One who claims to be a believer in Allah has to make a good deal of effort with a view to pleasing his :lord. He has to purify his soul from all evil thoughts and fancies so that the love of God should reside in it. Unless the soul is purged of all impurities one cannot achieve salvation. This is known as Tahdrah in Islam, and it is the foundation-stone of Imin. This high objective of the purification of the soul requires intentional and deliberate efforts and a good deal of sacrifice on the part of man, and the most elementary stage in this sacred path is the cleanliness of body.

    By enjoining cleanliness of body upon man Islam awakens him to the realisation of the fact that when impurities on the body of a man produce such unhealtby effects on his physical being and corrode his mental health, how miserable his life would be when his soul is polluted with impurities. The process of the purification of the soul should, therefore, start with the purification of the body.

Chapter 1 : MERIT OF WUDU'

Book 2, Number 0432:

    Abu Malik at-Ash'ari reported: The Messenger of Allah (may peace be upon him) said : Cleanliness is half of faith and al-Hamdu Liliah (Praise be to Allah) fills the scale, and Subhan Allah (Glory be to Allah) and al-Hamdu Liliah (Praise be to Allah) fill upwhat is between the heavens and the earth, and prayer is a light, and charity is proof (of one's faith) and endurance is a brightness and the Holy Qur'an is a proof on your behalf or against you. All men go out early in the morning and sell themselves, thereby setting themselves free or destroying themselves.

Chapter 2 : PURIFICATION IS ESSENTIAL FOR PRAYER

Book 2, Number 0433:

    Mus'ab b. Sa'd reported:'Abdullah son of Umar came to Ibn'Amir in order to inquire after his health as he was ailing. He said Ibn 'Umar, why don't you prayto Allah for me? He said: I heard of Allah's Messenger (may peace be upon him) say: Neither the prayer is accepted without parification nor is charity accepted out of the ill-gotten (wealth), and thou wert the (governor) of Basra.

Book 2, Number 0434:

    A hadith like this is narrated from the Apostle (may peace be upon him) with the same chain of transmitters by Muhammad b. Muthanna, Ibn Bashshar, Muhammad b. Ja'far, Shu'ba.

Book 2, Number 0435:

    Hammam b. Munabbih who is the brother of Wahb b. Munabbih. said: This is what has been transmitted to us by Abu Huraira from Muhammad, the Messenger of Allah (may peace be upon him) and then narrated a hadith out of them and observed that the Messenger of Allah (may peace be upon him) said: The prayer of none amongst you would be accepted in a state of impurity till he performs ablution.

Chapter 3 : HOW TO PERFORM ABLUTION

Book 2, Number 0436:

    Humran, the freed slave of 'Uthman, said: Uthman b. 'Affan called for ablution water and this is how he performed the ablution. He washed his hands thrice. He then rinsed his mouth and cleaned his nose with water (three times). He then washed his face three times, then washed his right arm up to the elbow three times, then washed his left arm like that, then wiped his head; then washed his right foot up to the ankle three times, then washed his left foot like that, and then said: I saw the Messenger of Allah (may peace be upon him) perform ablution like this ablution of mine. Then the Messenger of Allah (may peace be upon him) said: He who performs ablution like this ablution of mine and then stood up (for prayer) and offered two rak'ahs of prayer without allowing his thoughts to be distracted, all his previous sins are expiated. Ibn Shihab said: Our scholars remarked: This is the most complete of the ablutions performed for prayer.

Book 2, Number 0437:

    Humran, the freed slave of 'Uthman said: I saw Uthman call for a vessel (of water) and poured water over his hands three times and then washed them. Then he put his right hand in the vessel and rinsed his mouth and cleaned his nose. Then he washed his face three times and his hands up to the elbow three times; then wiped his head, then washed his feet three times. Then he said that the Messenger of Allah (may peace be upon him) had said: He who performed ablution like this ablution of mine and offered two raklahs of prayer without allowing his thoughts to be distracted, all his previous sins would be expiated.

Chapter 4 : THE MERIT OF WUDU AND THAT OF PRAYER AFTER IT

Book 2, Number 0438:

    Humran. the freed slave of 'Uthman. said: I heard from 'Uthman b. 'Affan and he was in the courtyard of the mosque, when the Mu'adhdhin (announcer of the prayer) came to him at the time of afternoon prayer. So the ('Uthman) called for the ablution water and performed ablution and then said: By Allah, I am narrating to you a hadith. If there were not a verse in the Book of Allah, I would have never narrated it to you. I heard Allah's Messenger (may peace be upon him) say: If a Muslim performs ablution and does it well and offers prayer, all his (sins) daring the period from one prayer to another would be pardoned by Allah.

Book 2, Number 0439:

    This hadith is also narrated on the authority with the same chain of transmitters and in the hadith of Abu Usama the words are: "He who performed the ablution well and then offered the obligatory prayer."

Book 2, Number 0440:

    Humran reported when 'Uthman performed ablution he said: By Allah, I am narrating to you a hadith had there not been this verse in the Book of Allah. I would not have narrated it to you. Verily I heard the Messenger of Allah (may peace be upon him) say: Not a person is there who performed ablution, and did it well, then offered prayer, but his sins (which he committed) were not pardoned between the prayer that he offered and the next one. 'Urwa said: The verse is this: "Those who suppress the clear proofs and the guidance which We have sent down"... to His words: "the Cursers" (ii. 15).

Book 2, Number 0441:

    'Amr b Sa'id b al-As reported: I was,with Uthman that he called for ablution water and said: I heard Allah's Messenger (may peace be upon him) say: When the time for a prescribed prayer comees, if any Muslim perform ablution well and offers his prayer) with humility and bowing, it will be an expiation for his past sins, so long as he has not committed a major sin; and this applies to for all times.

Book 2, Number 0442:

    Humran, the freed slave of 'Uthman reported: I brought for Uthman b. 'Affan the ablution water. He performed ablution and then said: Verily the people narrate from the Messenger of Allah (may peace be upon him) a hadith. I do not know what these are. but (I know this fact) that I saw the Messenger of Allah (may peace be upon him) perform ablution like this ablution of mine and then he said: He who performed ablution like this, all his previous sins would be expiated and his prayer and going towards the mosque would have an extra reward. In the tradition narrated by Ibn 'Abda (the words are): "I came to Uthman and he performed ablution."

Book 2, Number 0443:

    Abu Anas reported that Uthman performed ablution at Maqi'aid and said: Should I not show you the ablution performed by Allah's Messenger (may peace be upon him) ? And he then washed (the different parts of the body) three times.4" Qutaiba has added in his narration the words: "There were with him (with Uthman) Companions of Allah's Messenger (may peace be upon him)."

Book 2, Number 0444:

    Humran b. Abin reported: I used to fetch water for 'Uthman for his purification. Never was there a day that he did not take a bath with a small quantity of water. And Uthman said: The Messenger of Allah (may peace be upon him) at the time of our returning from our prayer told us (certain things pertaining to purification). Mis'ar said: I find that it was afternoon prayer. He said: I do not know whether I should tell you a thing or keep quiet. We said: Messenger of Allah, tell us if it is good and if it is otherwise, Allah and His Apostle know better. Upon this he said: A Muslim who purifies (himself) and completes purification as enjoined upon him by Allah and then offers the prayers, that will be expiatious (of his sins he committed) between these (prayers).

Book 2, Number 0445:

    Jami' b. Shaddad reported: I heard Humran b. Aban narrate to Abu Burda in this very mosque during the governorship of Bishr that 'Uthman b. Alfan said: The Messenger of Allah (may peace be upon him) observed: He who completed ablution as Allah, the Exalted, enjoined upon him, his obligatory prayers would be explatious (for his minor sins that he would commit) during (the interval) between them. This hadith is transmitted by Ibn Mu'adh, and in the hadith narrated by Ghundar, the words "during the governorship of Bishr" are omitted and there is no mention of the obligatory prayers.

Book 2, Number 0446:

    Humran, the freed slave of Uthman reported: One day Uthman b. Affan performed the ablution well, and then said: I saw Allah's Messenger (may peace be upon him) perform ablution, the best ablution, and then observed: He who performed ablution like this and then went towards the mosque and nothing (but the love of) prayer urged him (to do so), all his previous (minor) sins would be expiated.

Book 2, Number 0447:

    Humran, the freed slave of 'Uthman b. 'Affan, reported on the authority of 'Uthman b. 'Affan that he heard Allah's Messenger (may peace be upon him) say: He who performed ablution for prayer and performed it properly and then went (to observe) obligatory prayer and offered it along with people or with the congregation or in the mosque, Allah would pardon his sins.

Book 2, Number 0448:

    Abu Huraira reported: The Messenger of Allah (may peace be upon him)said: Five prayers and from one Friday prayer to (the next) Friday prayer is an expiation (of the sins committed in between their intervals) if major sins are not committed.

Book 2, Number 0449:

    Abu Huraira reported that the Messenger of Allah (way peace be upon him) said : Five prayers and one Friday prayer to (the next) Friday prayer are expiatious (for the sins committed in the intervals) between them.

Book 2, Number 0450:

    Abu Huraira reported: Verily the Messenger of Allah (may peace be upon him) said: Five (daily) prayers and from one Friday prayer to the (next) Friday prayer, and from Ramadhan to Ramadhan are expiatious for the (sins) committed in between (their intervals) provided one shuns the major sins.

Book 2, Number 0451:

    'Uqba b. 'Amir reported: We were entrusted with the task of tending the camels. On my turn when I came back in the evening after grazing them in the pastures, I found Allah's Messenger (may peace be upon him) stand and address the people. I heard these words of his: If any Muslim performs ablution well, then stands and prays two rak'ahs setting about them with his heart as well as his face, Paradise would be guaranteed to him. I said: What a fine thing is this ! And a narrator who was before me said: The first was better than even this. When I cast a glance, I saw that it was 'Umair who said : I see that you have just come and observed : If anyone amongst you performs the ablution, and then completes the ablution well and then says: I testify that there is no god but Allah and that Muhammad is the servant of Allah and His Messenger, the eight gates of Paradise would be opened for him and he may enter by whichever of them he wishes.

Book 2, Number 0452:

    Uqba b. 'Amir al-Juhani reported: Verily the Messenger of Allah (may peace be upon him) said and then narrated (the hadith) like one (mentioned above) except (this) that he said: He who performed ablution and said : I testify that there is no god but Allah, the One, there is no associate with Him and I testify that Muhammad is His servant and His Messenger.

Book 2, Number 0453:

    'Abdullah b. Zaid b. 'Asim al-Ansari, who was a Companion (of the Holy Prophet), reported: It was said to him (by people) : Perform for us the ablution (as it was performed) by the Messenger of Allah (way peace be upon him). He ('Abdullah b. Zaid) called for a vessel (of water), and poured water from it on his hands and washed them three times. Then he inserted his hand (in the vessel) and brought it (water) out, rinsed his mouth and snuffed up water from the palm of one hand doing that three times, He again inserted his hand and brought it out and washed his face three times, then inserted his hand and brought it out and washed each arm up to the elbow twice, then inserted his hand and brought it out and wiped his head both front and back with his hands. He then washed his feet up to the ankles, and then said: This is how God's Messenger (peace be upon him) performed ablution.

Book 2, Number 0454:

    This hadith is narrated by Amr b. Yahya with the same chain of transmitters, but there is no mention of ankles.

Book 2, Number 0455:

    Malik b. Anas narrated it from 'Amr b. Yahya with the same chain of transmitters, transmitters and mentioned the rinsing (of mouth) and snuffing (of water into the nostrils) three times, but he did not mention "from one palm," and made this addition: He moved them (his hands) for wiping to the front of his head and then the nape of his neck, then bringing them back till he reached the place from which he had begun, after which he washed his feet.

Book 2, Number 0456:

    Babz reported: This hadith has been narrated by Wuwb on the authority of 'Amr b. Yahyi with the same chain of transmitters and it has been mentioned therein: He rinsed his mouth. snuffed up water in nostrils and cleaned the nose with three handfuls and wiped his head moving (his hand) in front and then back once. Bahz said: Wuhaib narrated this hadith to me and Wuhaib said: Amr b. Yahya narrated to me this hadith twice.

Book 2, Number 0457:

    'Abdullah b. Zaid b. 'Asim al-Mazini reported: He saw Allah's Messenger (may peace be upon him) perform the ablution. He rinsed his mouth then cleaned his nose, then washed his face three times, then washed his right hand thrice and then the other one, thrice. He then took fresh water and wiped his head and then washed his feet till he cleaned them.

Chapter 5 : WHILE CLEANING THE NOSE AND USING OF PEBBLES IN TOILET, THE ODD NUMBER IS PREFERABLE

Book 2, Number 0458:

    Abu Huraira reported Allah's Apostle (may peace be upon him) as saying: When anyone wipes himself with pebbles (after answering the call of nature) he must make use of an odd number and when any one of you performs ablution he must snuff in his nose water and then clean it.

Book 2, Number 0459:

    Hammam b. Munabbih reported: This is what Abu Huraira transmitted to us from Muhammad, the Messenger of Allah (may peace be upon him), and he mentioned a number of a hadith, of which this is one: that the Messenger of Allah (may peace be upon him) said: When anyone amongst you (performs ablution) he must snuff his nostrils with water and then clean them.

Book 2, Number 0460:

    Abu Huraira reported: The Messenger of Allah (way peace he upon him) said: When anyone performs ablution he must clean his nose and when anyone wipes himself with pebbles (after answering the call of nature) he must do that odd number of times.

Book 2, Number 0461:

    It has been transmitted by Abu Huraira and Abu Sa'id al-Khudri (both of them the reputed Companions of the Holy Prophet) that the Messenger of Allah (may peace be upon him) said like that.

Book 2, Number 0462:

    Abu Huraira reported: The Apostle of Allah (may peace be upon him) said. When any one of you awakes up from sleep and performs ablution, he must clean his nose three times, for the devil spends the night in the interior of his nose.

Book 2, Number 0463:

    Jabir b. 'Abdullah reported that he heard the Messenger of Allah (may peace be upon him) say: When anyone wipes himself with pebbles (after answering the call of nature) he should do this odd number of times.

Chapter 6 : THE WASHING OF FEET PROPERLY IS AN INTEGRAL PART OF WUDU

Book 2, Number 0464:

    Salim, the freed slave of Shaddad, said: I came to 'A'isha, the wife of the Holy Prophet (may peace be upon him), on the day when Sa'db. Abi Waqqas died. 'Abd al-Rahman b. Abu Bakr also came there and he performed ablution in her presence. She (Hadrat 'A'isha) said: Abd al-Rahman, complete the ablution as I heard the Allah's Messenger (may peace be upon him) say: Woe to the heels because of hell-fire.

Book 2, Number 0465:

    Abdullah, the freed slave of Shahddad, came to 'A'isha and transmitted from her a hadith like this (which she narrated) from the Holy Prophet (may peace be upon him).

Book 2, Number 0466:

    Salim, the freed slave of Mahri, reported: I and 'Abd al-Rahman b. Abu Bakr went out (in order to join) the funeral procession of Sa'd b. Abi Waqqas and passed by the door of the residence of 'A'isha, and then he transmitted a hadith like this from her who (narrated it) from the Holy Prophet (may peace be upon him).

Book 2, Number 0467:

    Salim, the freed slave of Shaddad b. al-Had said: I was in the presence of 'A'isha, and then narrated on her authority a hadith like this from the Holy Prophet (way peace be upon him).

Book 2, Number 0468:

    'Abdullah b. 'Amr reported: We returned from Mecca to Medina with the Messenger of Allah (may peace be upon him), and when we came to some water on the way, some of the people were in a hurry at the time of the afternoon prayer and performed ablution hurriedly; and when we reached them, their heels were dry, no water had touched them. The Prophet (may peace be upon him) said: Woe to (dry) heels, because of Hell-fire. Make your ablution thorough.

Book 2, Number 0469:

    In the hadith transmitted by Shu'ba these words are not there: "Complete the Wudu," and there is the name of Abu Yahya al-A'raj (a narrator).

Book 2, Number 0470:

    'Abdullah b. Amr reported: The Messenger of Allah (may peace be upon him) lagged behind us on a journey. We travelled (back) and be took him; and then came the time of the afternoon prayer, and as we were going to wipe our feet he (the Holy Prophet) called out: Woe to the heels because of Hell-fire.

Book 2, Number 0471:

    Abu Huraira reported: Allah's Apostle (may peace be upon him) saw a man who did not wash his heel and he remarked: Woe to the heels because of hell-fire.

Book 2, Number 0472:

    Abu Huraira reported: He saw people perform ablution with the help of a water jar and he said: Complete the Wudu for i heard Abu al-Qasim (may peace be upon him) say: Woe to the hamstrings because of hell-fire.

Book 2, Number 0473:

    Abu Huraira reported: The Messenger of Allah (may peace be upon him) said: Woe to the heels because of hell-fire.

Chapter 7 : IT IS OBLIGATORY TO WASH ALL PARTS OF THE BODY NECESSARY FOR PURIFICATION

Book 2, Number 0474:

    Jabir reported: 'Umar b. Khattab said that a person performed ablution and left a small part equal to the space of a nail (unwashed). The Apostle of Allah (may peace be upon him) saw that and said: Go back and perform ablution well. He then went back (performed ablution well) and offered the prayer.

Chapter 8 : PURGING OF SINS WITH ABLUTION WATER

Book 2, Number 0475:

    Abu Huraira reported: Allah's Messenger (may peace be upon him) said: When a bondsman-a Muslim or a believer-washes his face (in course of ablution), every sin he contemplated with his eyes,will be washed away from his face along with water, or with the last drop of water; when he washes his hands, every sin they wrought will be effaced from his hands with the water, or with the last drop of water; and when he washes his feet, every sin towards which his feet have walked will be washed away with the water or with the last drop of water with the result that he comes out pure from all sins.

Book 2, Number 0476:

    Uthman b. 'Affan reported : The Messenger of Allah (way peace be upon him) said : He who performed ablution well, his sins would come out from his body, even coming out from under his nails.

Chapter 9 : IT IS COMMENDABLE TO INCLUDE FOREHEAD IN WASHING THE FACE AND ELBOW AND ANKLE IN WASHING THE HANDS AND FEET, WHILE PERFORMING ABLUTION

Book 2, Number 0477:

    Nu'aim b. 'Abdullah al-Mujmir reported: I saw Abu Huraira perform ablution. He washed his face and washed it well. He then washed his right hand including a portion of his arm. He then washed his left hand including a portion of his arm. He then wiped his head. He then washed his right foot including his shank, and then washed his left foot including shank, and then said: This is how I saw Allah's Messenger (may peace be upon him) perform his ablution. And (Abu Huraira) added that the Messenger of Allah (may peace be upon him) had observed: You shall have your faces hands and feet bright on the Day of Resurrection because of your perfect ablution. He who can afford among you, let him increase the brightness of his forehead and that of hands and legs.

Book 2, Number 0478:

    Nu'aim b. 'Abdallah reported: He saw Abu Huraira perform ablution. He washed his face and washed his hands up to the arms. He then washed his feet and reached up to the shanks and then said: I heard Allah's Messenger (may peace be upon him) say: My people would come with bright faces and bright hands and feet on account of the marks of ablution, so he who can increase the lustre of his forehead (and that of his hands and legs) should do so.

Book 2, Number 0479:

    Abu Huraira reported: Verily Allah's Messenger (may peace be upon him) said: My Cistern has its dimensions wider than the distance between Aila and Aden, and its water is whiter than ice and sweeter than the honey diluted with milk, and its cups are more numerous than the numbers of the stars. Verily I shall prevent the (faithless) people therefrom just as a man prevents the camels of the people from his fountain. They said: Messenger of Allah,will you recognise us on that day? He said: Yes, you will have distinctive marks which nobody among the peoples (except you) will have; you would come to me with blazing forehead and bright hands and feet on account of the traces of ablution.

Book 2, Number 0480:

    Abu Huraira reported the Messenger of Allah (may peace be upon him) said: My people would come to me on the Cistern and I would drive away persons (from it) just as a person drives away other people's camels from his camels. They (the hearers) said: Apostle of Allah, would you recognize us? He replied: Yea, you would have a mark which other people will not have. You would come to me with a white blaze on your foreheads and white marks on your feet because of the traces of ablution. A group among you would be prevented from coming to me, and they would not meet me, and I would say: O my Lord, they are my companions. Upon this an angel would reply to me saying: Do you know what these people did after you.

Book 2, Number 0481:

    Hudhaifa reported: The Messenger of Allah (may peace be upon him) said: My Cistern is bigger than the space between Aila and Aden. By Him in Whose Hand is my life, I will drive away persons (from it) just as a person drives away unknown camels from his cistern. They (the companions) said: Messenger of Allab, would you recognise us? He said: Yes, you would come to me with white faces, and white hands and feet on account of the traces of ablution. None but you would have (this mark).

Book 2, Number 0482:

    Abu Huraira reported: The Messenger of Allah (may peace be upon him) came to the graveyard and said: Peace be upon you ! the abode of the believing people and we, if God so wills, are about to join you. I love to see my brothers. They (the hearers) said: Arn't we your brothers-Messenger of Allah? He said: You are my companions, and our brothers are those who have, so far, not come into the world. They said: Messenger of Allah, how would you recognise those persons of your Ummah who have not yet been born? He said: Supposing a man had horses with white blazes on fore- heads and legs among horses which were all black, tell me, would he not recognise his own horses? They said: Certainly. Messenger of Allah. He said: They would come with white faces and arms and legs owing to ablution, and I would arrive at the Cistern before them. Some people would be driven away from my Cistern as the stray camel is driven away. I would call out. Come. come. Then it would be said (to me): These people changed themselves after you, and I would say: Be off, be off.

Book 2, Number 0483:

    Abu Huraira reported: The Messenger of Allah (may peace The upon him) went out to the graveyard and said: Peace be upon you, the abode of the believing people. and If Allah so wills we shall join you.... (and so on and so forth) like the hadith narrated by Isma'il b. Ja'far except the words of Malik: Then some persons would be driven away from my Cistern.

Book 2, Number 0484:

    Abu Hazim reported: I was (standing) behind Abu Huraira and he was performing the ablution for prayer. He extended the (washing) of his hand that it went up to his armpit. I said to him: O Abu Huraira, what is this ablution? He said: O of the tribe of Faruukh, you are here; if I knew that you were here, I would have never performed ablution like this; I have heard my Friend (may peace be upon him) say. In a believer adornment would reach the places where ablution reaches.

Book 2, Number 0485:

    Abu Huraira reported: The Messenger of Allah (may peace be upon him) said: Should I not suggest to you that by which Allah obliterates the sins and elevates the ranks (of a man). They (the hearers) said: Yes, Messenger of Allah. He said: Performing the ablution thoroughly despite odds, tranverside of more paces towards the mosque, and waiting for the next prayer after observing a prayer, and that is mindfulness.

Book 2, Number 0486:

    This hadith has been narrated on the authority of Ali' b. 'Abd al-Rahman with the same chain of transmitters and there is no mention of the word of al-Ribat in the hadith transmitted by Shu'ba and in the badith narrated by Malik "Ribat" has been mentioned twice. This is the "Ribat" for you, this is the "Ribat" for you.

Chapter 10 : PERTAINING TO TOOTH-STICK (brushing the teeth)

Book 2, Number 0487:

    Abu Huraira reported: The Apostle (may peace be upon him) said: Were it not that I might over-burden the believers-and in the hadith transmitted by Zuhair "people"-I would have ordered them to use toothstick at every time of prayer.

Book 2, Number 0488:

    Miqdam b. Shuraih narrated it from his father who said: I asked A'isha what Allah's Apostle (may peace be upon him) did first when he entered his house, and she replied: He used tooth-stick (first of all).

Book 2, Number 0489:

    'A'isha reported: Whenever Allah's Messenger (may peace be upon him) entered his house, he used tooth-stick first of all.

Book 2, Number 0490:

    Abu Musa reported: I went to the Apostle (may peace be upon him) and found one end of the tooth-stick upon his tongue (i.e. he was rinsing his mouth).

Book 2, Number 0491:

    Huddaifa reported: Whenever the Messenger of Allah (may peace be upon him) got up for Tahajjud prayer, he cleansed his mouth with the tooth-stick.

Book 2, Number 0492:

    This hadith is reported from Hudaifa by another chain of transmitters. Whenever he (the Holy Prophet) got up in the night, they (the transmitters) have not mentioned the words: for offering Tahajjud prayer.

Book 2, Number 0493:

    (493) Hudaifa reported: Whenever he (the Holy Prophet) got up for prayer during the night, he cleansed his mouth with the tooth-stick.

Book 2, Number 0494:

    Ibn 'Abbas reported that he spent a night at the house of the Apostle of Allah (may peace be upon him), The Apostle of Allah (way peace be upon him) got up for prayer in the latter part of the night. He went out and looked towards the sky and then recited this verse (190th) of AI-i-'Imran: "Verily in the creation of the heavens and the earth and the alternation of night and day." up to the (words) "save us from the torment of Hell." He then returned to his house, used the tooth-stick, performed the ablution, and then got up and offered the prayer. He than lay down on the bed. and again got up and went out and looked towards the sky and recited this verse (mentioned above), then returned, used the tooth-stick, performed ablution and again offered the prayer.

Chapter 11 : CHARACTERISTICS OF FITRA

Book 2, Number 0495:

    Abu Huraira reported: Five are the acts quite akin to the Fitra, or five are the acts of Fitra: circumcision, shaving the pubes, cutting the nails, plucking the hair under the armpits and clipping the moustache.

Book 2, Number 0496:

    Abu Huraira reported: Five are the acts of fitra: circumcision, removing the pubes, clipping the moustache, cutting the nails, plucking the hair under the armpits.

Book 2, Number 0497:

    Anas reported: A time limit has been prescribed for us for clipping the moustache, cutting the nails, plucking hair under the armpits, shaving the pubes, that it should not be neglected far more than forty nights.

Book 2, Number 0498:

    Ibn Umar said: The Apostle of Allah (may peace be upon him) said: Trim closely the moustache, and let the beard grow.

Book 2, Number 0499:

    Ibn Umar said : The Apostle of Allah (may peace be upon him) ordered us to trim the moustache closely and spare the beard.

Book 2, Number 0500:

    Ibn Umar said: The Messenger of Allah (may peace be opon him) said: Act against the polytheists, trim closely the moustache and grow beard.

Book 2, Number 0501:

    Abu Huraira reported: The Messenger of Allah (may peace be upon him) said: Trim closely the moustache, and grow beard, and thus act against the fire-worshippers.

Book 2, Number 0502:

    'A'isha reported: The Messenger of Allah (may peace be npon him) said: Ten are the acts according to fitra : clipping the moustache, letting the beard grow, using the tooth-stick, snuffing water in the nose, cutting the nails, washing the finger joints, plucking the hair under the armpits, shaving the pubes and cleaning one's private parts with water. The narrator said : I have forgotten the tenth, but it may have been rinsing the mouth.

Book 2, Number 0503:

    This hadith has been narrated by Mus'ab b. Shaiba with the same chain of transmitters except for these words: "His father said : I forgot the tenth one."

Chapter 12 : HOW TO CLEANSE ONESELF AFTER RELIEVING ONESELF

Book 2, Number 0504:

    Salman reported that it was said to him: Your Apostle (may peace be upon him) teaches you about everything, even about excrement. He replied: Yes, he has forbidden us to face the Qibla at the time of excretion or urination, or cleansing with right hand or with less than three pebbles, or with dung or bone.

Book 2, Number 0505:

    Salman said that (one among) the polytheists remarked: I see that your friend even teaches you about the excrement. He replied; Yes, he has in fact forbidden us that anyone amongst us should cleanse himself with his right hand, or face the Qibla. He has forbidden the use of dung or bone for it, and he has also instructed us not to use less than three pebbles (for this purpose).

Book 2, Number 0506:

    Jabir reported: The Messenger of Allah (may peace be upon him) forbade the use of bone or the droppings of camels for wiping (after excretion).

Book 2, Number 0507:

    Abu Ayyub reported: The Apostle of Allah (may peace be upon him) said: Whenever you go to the desert, neither turn your face nor turn your back towards the Qibla while answering the call of nature, but face towards the east or the west. Abu Ayyub said: When we came to Syria we found that the latrines already built there were facing towards the Qibla. We turned our faces away from them and begged forgiveness of the Lord. He said: Yes.

Book 2, Number 0508:

    Abu Huraira said:When any one amongst you squats for answering the call of nature, he should neither turn his face towards the Qibla nor turn his back towards it.

Book 2, Number 0509:

    Wasi' b. Habban reported: I was offering my prayer in the mosque and Abdullah b. Umar was sitting there reclining with his back towards the Qibla. After completing my prayer. I went to him from one side. Abdullah said: People say when you go to the latrine, you should neither turn your face towards the Qibla nor towards Bait-ul-Maqdis. 'Abdullah said (farther) : I went up to the roof of the house and saw the Messenger of Allah (may peace be upon him) squatting on two bricks for relieving himself with his face towards Bait-al-Maqdis.

Book 2, Number 0510:

    Abdullah b. Umar said: I went up to the roof of the house of my sister Hafsa and saw the Messenger of Allah (may peace be upon him) relieving himself facing Syria. with his back to the Qibla.

Book 2, Number 0511:

    Abu Qatada reported it from his father: The Messenger of Allah (may peace be upon him) said: None of you should hold penis with his right hand while urinating, or wipe himself with his right hand in privy and should not breathe into the vessel (from which he drinks).

Book 2, Number 0512:

    Abu Qatada reported it from his father that the Messenger of Allah(may peace be upon him) said: When anyone amongst you enters the privy he should not touch his penis with his right hand.

Book 2, Number 0513:

    Aba Qatada reported : The Messenger of Allah (way peace be upon him) forbade (us) to breathe into the venel, to touch the penis with the right hand and to wipe after relieving with right hand.

Chapter 13 : STARTING FROM THE RIGHR HAND SIDE FOR ABLUTION, ETC

Book 2, Number 0514:

    'A'isha reported: The Messenger of Allah (way peace be upon him) loved to start from the right-hand side for performing ablution, for combing (the hair) and wearing the shoes.

Book 2, Number 0515:

    'A'isha reported: The Messenger of Allah (may peace be upon him) loved to start from the right-hand side in his every act i.e. in wearing shoes, in combing (his hair) and in performing ablution.

Chapter 14 : EASING IS FORBIDDEN IN THE STREETS AND UNDER THE SHADE

Book 2, Number 0516:

    Abu Huraira reported: The Messenger of Allah (may peace be upon him) said: Be on your guard against two things which provoke cursing. They (the companions present there) said: Messenger of Allah, what are those things which provoke cursing? He said: Easing on the thoroughfares or under the shades (where they take shelter and rest).

Book 2, Number 0517:

    Anas b. Malik reported: The Messenger of Allah (may peace be upon him) entered an enclosure while a servant was following him with a jar of water and he was the youngest amongst us and he placed it by the side of a lote-tree. When the Messenger of Allah,(may peace be upon him) relieved himself, he came out and had cleansed himself with water.

Book 2, Number 0518:

    Anas b. Malik reported: When the Messenger of Allah (may peace be upon him) entered the privy, a servant and I used to carry a skin of water, and a pointed staff, and he would cleanse himself with water.

Book 2, Number 0519:

    Anas b. Malik reported: The Messenger of Allah (may peace be upon him) went to a far-off place in the desert (hidden from the sight of human beings) for relieving himself. Then I brought water for him and he cleansed himself.

Chapter 15 : WIPING OVER THE SOCKS

Book 2, Number 0520:

    Hummam reported: Jarir urinated, then performed ablution and wiped over the socks. It was said to him: Do you do like this? He said: Yes, I saw that the Messenger of Allah (may peace be upon him) urinated, then performed ablution and then wiped over his shoes. A'mash said: Ibrahim had observed that this hadith was a surprise for them (the people) because Jarir had embraced Islam after the revelation of Surat al-Ma'ida.

Book 2, Number 0521:

    This hadith is narrated on the same authority from A'mash by another chain of transmitters like one transmitted by Abu Mu'awyia. The hadith reported by 'Isa and Sufyan has these words also: "This hadith surprised the friends of Abdullab'" for Jarir had embraced Islam after the revelation of al-Ma'ida.

Book 2, Number 0522:

    Hudhaifa reported: I was with the Apostle of Allah (may peace be upon him) when he came to the dumping ground of filth belonging to a particular tribe. He urinated while standing, and I went aside. He (the Holy Prophet) asked me to come near him and I went so near to him that I stood behind his heels. He then performed ablution and wiped over his socks.

Book 2, Number 0523:

    Abu Wa'il reported : Abu Musa inflicted extreme rigour upon himself in the matter of urination and urinated in a bottle and said: When the skin of anyone amongst the people of Israel was besmeared with urine, he cut that portion with a cutter. Hudhaifa said: I wish that'your friend should not inflict such an extreme rigour. I and the Messenger of Allah (may peace be upon him) were going together till we reached the dumping ground of filth behind an enclosure. He stood up as one among you would stand up. and he urinated, I tried to turn away from him, but he beckoned to me, so I went to him and I stood behind him, till he had relieved himself.

Book 2, Number 0524:

    The son of Mughira b. Shu'ba reported: The Messenger of Allah (may peace be upon him) went out for relieving himself. Mughira went with him carrying a jug full of water. When he (the Holy Prophet) came back after relieving himself, he poured water over him and he performed ablution and wiped over his socks; and in the narration of Ibn Rumh there is "till" instead of "when".

Book 2, Number 0525:

    This hadith has been transmitted with the same chain of transmitters by Yahya b. Sa'id with the addition of these words: "He washed his face and hands, and wiped his head and then wiped his socks."

Book 2, Number 0526:

    Mughira b. Shu'ba reported: I was with the Messenger of Allah (may peace be upon him) one night. He came down (from the ride) and relieved himself. He then came and I poured water upon him from the jar that I carried with me. He performed ablution and wiped over his socks.

Book 2, Number 0527:

    Mughira b. Shu'ba reported: I was in the company of the Messenger of Allah (may peace be upon him) on a journey when he said : Mughira take hold of this jar (of water). I took hold of it and I went out with him. (I stopped but) the Messenger of Allah (may peace be upon him) proceeded on till he was out of my sight. He relieved himself and then came back and he was wearing a tight-sleeved Syrian gown. He tried to get his forearms out. but the sleeve of the gown was very narrow, so he brought his hands out from under the gown. I poured water over (his hands) and he performed ablution for prayer, then wiped over his socks and prayed.

Book 2, Number 0528:

    Mughira b. Shu'ba reported: The Messenger of Allah (may peace be upon him) went out for relieving himself. When he came back I brought for him a jar (of water) and poured water upon his hands and He washed his face. He tried to wash his forearms, but as the (sleeves of the) gown were tight. He, therefore, brought them out from under the gown. He then washed them, wiped his head, and wiped his socks and then prayed.

Book 2, Number 0529:

    'Urwa b. Mughira reported his father having said: I was one night with the Apostle of Allah (may peace be upon him) on a journey. He said to me: Have you any water with you? I said: Yes. He (the Holy Prophet) came down from his ride and went on till he disappeared in the darkness of night. He then came back and I poured water for him from the jar. He washed his face, He had a woollen gown on him and he could not bring out his forearms from it (i.e. from its sleeves) and consequently he brought them out from under his gown. He washed his forearms, wiped over his head. I then bent down to take off his socks. But he said: Leave them, for my feet were clean when I put them in, and he only wiped over them.

Book 2, Number 0530:

    'Urwah al Mughira reported it from his father: He(Mughira) helped the Apostle (may peace be upon him) in performing the ablution, and he performed it and wiped over his shoes. He (Mughira) said to him (about the washing of the feet after putting them off), but he (the Holy Prophet) said : I put them (feet) in when these were clean.

Chapter 16 : WIPING (OVER) THE FORELOCK AND TURBAN

Book 2, Number 0531:

    'Urwa b. al Mughira b. Shu'ba reported it on the authority of his father that he said : The Messenger of Allah (may peace be upon him) lagged behind (in a journey) and I also lagged behind along with him. After having relieved himself he said : Have you any water with you ? I brought to him a jar of water ; he washed his palms, and face, and when he tried to get his forearms out (he could not) for the sleeve of the gown was tight. He, therefore, brought them out from under the gown and, throwing it over his shoulders, he washed his forearm. He then wiped his forelock and his turban and his socks. He then mounted and I also mounted (the ride) and came to the people. They had begun the prayer with 'Abd ar-Rabmin b. 'Anf leading them and had completed a rak'a. When he perceived the presence of the Apostle of Allah (may peace be upon him) he began to retire. He (the Holy Prophet) signed to him to continue and offered prayer along with them. Then when he had pronounced the salutation, the Apostle (may peace be upon him) got up and I also got up with him, and we offered the rak'a which had been finished before we came.

Book 2, Number 0532:

    Ibn Mughira narrated it from his father: The Apostle of Allah (may peace be upon him) wiped over his socks and over his forehead and over his turban.

Book 2, Number 0533:

    This hadith has been transmitted by Ibn Mughira on the authority of his father by another chain of transmitters.

Book 2, Number 0534:

    Bakr reported that he had heard from the son of Mughira that verily the Apostle of Allah (may peace be upon him) performed ablution and wiped over his forehead and wiped over his turban and over his socks.

Book 2, Number 0535:

    It is narrated from Bilal that the Messenger of Allah (may peace be upon him) wiped over the socks and turban, and in the hadith transmitted by 'Isa b. Yaunus the words are: "Bilal narrated it to me."

Book 2, Number 0536:

    This tradition is transmitted by A'mash with this addition; ,I saw the Messenger of Allah (may peace be upon him)."

Chapter 17 : TIME LIMIT FOR WIPING OVER THE SHOES

Book 2, Number 0537:

    Shuraih b. Hani said: I came to 'A'isha to ask her about wiping over the socks. She said: You better ask ('Ali) son of Abu Talib for he used to travel with Allah's Messenger (may peace be upon him). We asked him and he said: The Messenger of Allah (may peace be upon him) stipulated (the upper limit) of three days and three nights for a traveller and one day and one night for the resident.

Book 2, Number 0538:

    This hadith is narrated by Ubaidullah b. 'Amr and Zaid b. Abu Unaisa with the same chain of transmitters.

Book 2, Number 0539:

    Shuraib b. Hani reported: I asked 'A'isha about wiping over the shoes. She said: You better go to 'Ali, for he knows more about this than I. I, therefore, came to 'Ali and he narrated from the Apostle (may peace be upon him) like this.

Book 2, Number 0540:

    Sulaiman b. Buraida narrated it from his father that the Apostle of Allah (may peace be upon him) offered prayers with one ablution on the day of the Conquest (of Mecca) and wiped over the socks. 'Umar said to him: You have today done something that you have not been accustomed to before. He (the Holy Prophet) said: 0 'Umar, I have done that on purpose.

Chapter 18 : IT IS UNDESIRABLE TO PUT ONE'S HAND IN THE UTENSIL BEFORE WASHING IT

Book 2, Number 0541:

    Abu Huraira said: When anyone amongst you wakes up from sleep, he must not put his hand in the utensil till he has washed it three times, for he does not know where his hand was during the night.

Book 2, Number 0542:

    This hadith is transmitted from Abu Huraira by another chain of transmitters.

Book 2, Number 0543:

    Zahri and Ibn Musayyab have both transmitted a hadith like this from Abu Huraira who narrated it from the Apostle (may peace be upon him).

Book 2, Number 0544:

    Abu Huraira reported: The Apostle of Allah (may peace be upon him) said: When anyone amongst you wakes up from sleep, he should wash his hands three times before putting it in the utensil, for he does not know wher.. his hand was during the night.

Book 2, Number 0545:

    This hadith has been transmitted through other chains of transmitters on the authority of Abu Huraira in which it is reported that the Apostle of Allah (may peace be upon him) made a mention of washing the hand, and did not instruct to wash it three times. But the hadith narrated from Jabir and Ibn Musayyab. Abu Salama, and Abdullah b. Shaqiq, Abu Salih, Abla Razin, there is a mention of "three times".

Chapter 19 : INSTRUCTIONS PERTAINING TO THE LICKING OF A DOG

Book 2, Number 0546:

    Abu Huraira reported the Messenger of Allah (may peace be upon him) to have said: When a dog licks a utensil belonging to any one of you, (the thing contained in it) should be thrown away and then (the utensil) should be washed seven times.

Book 2, Number 0547:

    This hadith has been transmitted by another chain of transmitters in which there is no mention of "throwing away".

Book 2, Number 0548:

    Abu Huraira reported: The Messenger of Allah (may peace be upon him) said: When a dog drinks out of a vessel belonging to any one of you, he must wash it seven times.

Book 2, Number 0549:

    Abu Huraira reported: The Messenger of Allah (may peace be upon him) said: The purification of the utensil belonging to any one of you, after it is licked by a dog, lies in washing it seven times, using sand for the first time.

Book 2, Number 0550:

    Hammam b. Munabbih reported : Of the a hadith narrated by Abu Huraira from Muhammad, the Messenger of Allah (may peace be upon him), one is this: The Messenger of Allah (may peace be upon him) said : The purification of the utensil belonging to one amongst you, after it is licked by a dog, lies in washing it seven times.

Book 2, Number 0551:

    Ibn Mughaffal reported : The Messenger of Allah (may peace be upon him) ordered killing of the dogs, and then said : What about them, i.e. about other dogs? and then granted concession (to keep) the dog for hunting and the dog for (the security) of the herd, and said: When the dog licks the utensil, wash it seven times, and rub it with earth the eighth time.

Book 2, Number 0552:

    A hadith like this has been narrated from Shu'ba with the same chain of transmitters except for the fact that in the hadith transmitted by Yahya those words are: "He (the Holy Prophet) gave concession in the case of the dog for looking after the herd, for hunting and for watching the cultivated land," and there is no mention of this addition (i.e. concession in case of watching the cultivated lands) except in the hadith transmitted by Yahya.

Chapter 20 : IT IS FORBIDDEN TO URINATE IN STAGNANT WATER

Book 2, Number 0553:

    Jabir reported: The Messenger of Allah (may peace be upon him) forbade to urinate in stagnant water.

Book 2, Number 0554:

    Abu Huraira reported: the Messenger of Allah (may peace be upon him) said: None amongst you should urinate in standing water, and then wash in it.

Book 2, Number 0555:

    Hammam b. Munabbih said: Of the ahadith narrated to us by Abfi Huraira from Muhammad the Messenger of Allah (may peace be upon him) one is this: The Messenger or Allah (may peace be upon him) said: You should not urinate in standing water, that is not flowing, then wash in it.

Chapter 21 : IT IS FORBIDDEN TO WASH ONESELF IN STANDING WATER

Book 2, Number 0556:

    Abu Huraira reported the Messenger of Allah (may peace be upon him) saying : None of you must wash in standing water when he is in a state of Junub. And Abu Huraira was asked how it was to be done; he said: It was to be taken out in handfuls.

Chapter 22 : IT IS OBLIGATORY TO CLEANSE THE MOSQUE WHEN THERE ARE IMPURITIES IN IT AND THE EARTH BECOMES CLEAN OF IMPURITIES WITH THE HELP OF WATER WITHOUT SCRAPING (THE PART OF IT)

Book 2, Number 0557:

    Anas reported: A Bedouin urinated in the mosque. Some of the persons stood up (to reprimand him or to check him from doing so), but the Messenger of Allah (may peace be upon him) said: Leave him alone; don't interrupt him. He (the narrator) said: And when he had finished, he called for a bucket of water and poured it over.

Book 2, Number 0558:

    Anas b. Malik narrated that a desert Arab (Bedouin) stood in a corner of the mosque and urinated there. The people (the Companions of the Holy Prophet who were present there) shouted, but the Messenger of Allah (may peace be upon him) said: Leave him alone. When he had finished, the Messenger of Allah (may peace be upon him) ordered that a bucket (of water) should be brought and poured over it.

Book 2, Number 0559:

    Anas b. Malik reported: While we were in the mosque with Allah's Messenger (may peace be upon him), a desert Arab came and stood up and began to urinate in the mosque. The Companions of Allah's Messenger (may peace be upon him) said: Stop, stop, but the Messenger of Allah (may peace be upon him) said : Don't interrupt him; leave him alone. They left him alone, and when he finished urinating, Allah's Messenger (may peace be upon him) called him and said to him: These mosques are not the places meant for urine and filth, but are only for the remembrance of Allah, prayer and the recitation of the Qur'an, or Allah's Messenger said something like that. He (the narrator) said that he (the Holy Prophet) then gave orders to one of the people who brought a bucket of water and poured It over.

Chapter 23 : PERTAINING TO THE URINE OF THE SUCKLING BABE, AND HOW IT IS TO BE WASHED AWAY

Book 2, Number 0560:

    A'isha, the wife of the Apostle (may peace be upon him) said: Babies were brought to the Messenger of Allah (may peace be upon him) and he blessed them, and after having chewed (something, e.g. dates or any other sweet thing) he rubbed there with their soft palates. A baby was brought to him and he passed water over him (over his garment), so he asked water to be brought and sprinkled it, but he did not wash it.

Book 2, Number 0561:

    A'isha reported: A suckling babe was brought to the Messenger of Allah (way peace be upon him) and he urinated in his tap. He (the Holy Prophet) sent for water and poured it over.

Book 2, Number 0562:

    Hisham narrated the hadith like one transmitted by Ibn Numair (the above mentioned one) with the same chain of transmitters.

Book 2, Number 0563:

    Umm Qais daughter of Mihsan reported that she came to the Messenger of Allah (may peace be upon him) with her child. who was not yet weaned, and she placed him in his lap; and he urinated in his (Holy Prophet's) lap. He (the Holy Prophet) did nothing more than spraying water over it.

Book 2, Number 0564:

    This hadith has also been narrated from al-Zuhri with the same chain of narrators. (but for the words): "He (the Holy Prophet) sent for water and sprinkled it over."

Book 2, Number 0565:

    Ubaidullah b. Abdullah b. 'Utba b. Mas'ud said: Umm Qais, daughter of Mihsan, was among the earliest female emigrants who took the oath of allegiance to the Messenger of Allah (may peace be upon him), and she was the sister of 'Ukkasha b. Mihsan, one amongst the sons of Asad b. Khuzaima. He (the narrator) said: She (Umm Qais) told me that she came to the Messenger of Allah (may peace he upon him) with her son and he had not attained the age of eating food. He (the narrator, 'Ubaidullah), said: She told me that her son passed urine in the lap of the Messenger of Allah (may peace be upon him). The Messenger of Allah (may peace be upon him) sent for water and sprayed it over his garment (over that part which was contaminated with the urine of the child) and he did not wash it thoroughly.

Chapter 24 : WASHING AWAY OF'THE SEMEN FROM THE GARMENT AND ITS SCRAPING

Book 2, Number 0566:

    Alqama and Aswad reported: A person stayed in the house of A'isha and in the morning began to wash his garment. A'isha said: In case you saw it (i.e. drop of semen), it would have served the purpose (of purifying the garment) if you had simply washed that spot; and in case you did not see it, it would have been enough to sprinkle water around it, for when I saw that on the garment of the Messenger of Allah (may peace be upon him). I simply scraped it off and he offered prayer, while putting that on.

Book 2, Number 0567:

    Al-Aawad and Hammam reported A'isha as saying: I used to scrape off the (drop of) semen from the garment of the Messenger of Allah (may peace be upon him).

Book 2, Number 0568:

    Qutaiba b. Sa'id, Ishaq b. Ibrahim, Ibn Abi 'Aruba, Abu Ma'shar, Abu Bakr b. Abu Shaiba, Mansur and Mughira have all transmitted from Ibrahim, who transmitted it on the authority of A'isha's narration pertaining to the scraping off of the (drop) of semen from the garment of the Messenger of Allah (may peace be upon him) like the hadith of Khalid on the authority of Abu Ma'shar.

Book 2, Number 0569:

    Hammam narrated the hadith from A'isha like the (above-mentioned)traditions.

Book 2, Number 0570:

    'Amr b. Maimun said: I asked Sulaiman b. Yasir whether the semen that gets on to the garment of a person should be washed or not. He replied : A'isha told me: The Messenger of Allah (may peace be upon him) washed the semen, and then went out for prayer in that very garment and I saw the mark of washing on it.

Book 2, Number 0571:

    Abu Kuraib, Ibn al-Mubarak, Ibn Abu Za'ida all of them narrated from Amr b. Maimun with the same chain of transmitters. Ibn Abu Za'ida narrated as was transmitted from Ibn Bishr that the Messenger of Allah (may peace be upon him) washed semen, and in the hadith transmitted on the authority of Ibn Mabarak and Abdul Wahid the words are: "She (A'isha) reported: I used to wash it from the garment of the Messenger of Allah (may peace be upon him)."

Book 2, Number 0572:

    Abdullah b. Shihab al-Khaulani reported: I stayed in the house of 'A'isha and had a wet dream (and perceived its effect on my garment), so (in the morning) I dipped both (the clothes) in water. This (act of mine) was watched by a maid-servant of A'isha and she informed her. She (Hadrat A'isha) sent me a message: Whatprompted you to act like this with your clothes? He (the narrator) said: I told that I saw in a dream what a sleeper sees. She said: Did you find (any mark of the fluid) on your clothes? I said: No. She said: Had you found anything you should have washed it. Incase I found that (semen) on the garment of the Messenger of Allah (may peace be upon him) dried up, I scraped it off with my nails.

Chapter 25 : THE IMPURITY OF THE BLOOD OF MENSES AND ITS WASHING

Book 2, Number 0573:

    Asma (daughter of Abu Bakr) reported: A woman came to the Apostle of Allah (may peace be upon him) and said: What should one do if the blood of menses smears the garment of one amongst us? He (the Holy Prophet) replied: She should scrape it, then rub it with water, then pour water over it and then offer prayer in it.

Book 2, Number 0574:

    This tradition is narrated by Abu Kuraib, Ibn Numair, Abu Tahir, Ibn Wahb, Yahya b. 'Abdullah b. Salim, Malik b. Anas, 'Amr b. Harith on the authority of Hisham b. 'Urwa, with the same chain of transmitters like one transmitted by Yahya b. Sa'id like the above-mentioned.

Chapter 26 : PROOF OF THE IMPURITY OF URINE AND THAT IT IS OBLIGATORY TO SAFEGUARD ONESELF FROM IT

Book 2, Number 0575:

    Ibn Abbas reported: The Messenger of Allah (may peace be upon him) happened to pass by two graves and said: They (their occupants) are being tormented, but they are not tormented for a grievous sin. One of them carried tales and the other did not keep himself safe from being defiled by urine. He then called for a fresh twig and split it into two parts, and planted them on each grave and then said: Perhaps, their punishment way be mitigated as long as these twigs remain fresh.

Book 2, Number 0576:

    This hadith is transmitted from A'mash by Abmad b. Yusuf al-Azdi, Mu'alla b. Asad, Abd al-Wahid, Sulaiman with the same chain of transmitters but for the words: "The other did not keep himself safe from being defiled by urine."


BOOK 3: The Book of Menstruation (Kitab Al-Haid)

KITAB AL-HAID
(MENSRUATION)

Back
Chapter 1 : LYING WITH ONE IN MENSTRUATION ABOVE THE WAIST-WRAPPER

Book 3, Number 0577:

    'A'isha reported: When anyone amongst us (amongst the wives of the Holy Prophet) menstruated, the Messenger of Allah (may peace be upon him) asked her to tie a waist-wrapper over her (body) and then embraced her.

Book 3, Number 0578:

    'A'isha reported: When anyone amongst us was menstruating the Messenger of Allah (may peace be upon him) asked her to tie waist-wrapper daring the time when the menstrual blood profusely flowed and then embraced her ; and she ('A'isha) observed: And who amongst you can have control over his desires as the Messenger of Allah (may peace be upon him) had over his desires.

Book 3, Number 0579:

    Maimuna (the wife of the Holy Prophet) reported: The Messenger of Allah (may peace be upon him) contacted and embraced his wives over the waist-wrapper when they were menstruating.

Book 3, Number 0580:

    Kuraibthe freed slave of Ibn Abbas, reported: I heard it from Maimuna, the wife of the Apostle of Allah (way peace be upon him): The Messenger of Allah (may peace be upon him) used to lie with me when I menstruated, and there was a cloth between me and him.

Book 3, Number 0581:

    Umm Salama reported: While I was lying with the Messenger of Allah (may peace be upon him) in a bed cover I menstruated, so I slipped away and I took up the clothes (which I wore) in menses. Upon this the Messenger of Allah (may peace be upon him) said : Have you menstruated ? I said: Yes. He called me and I lay down

Chapter 2 : THE MENSTRUATING WOMAN IS PERMITTED TO WASH THE HEAD OF HER HUSBAND, COMB HIS HAIR, AND HER LEFT-OVER AS CLEAN, AND ONE IS PERMITTED TO RECLINE IN HER LAP AND RECITE THE QUR'AN

Book 3, Number 0582:

    It is reported from 'A'isha that she observed: When the Messenger of Allah (may peace be upon him) was in I'tikaf, he inclined his head towards me and I combedhis hair, and he did not enter the house but for the natural calls (for relieving himself).

Book 3, Number 0583:

    'Amra daughter of 'Abd al-Rahman reported : 'A'isha, wife of the Apostle of Allah (may peace be upon him) observed : When I was (in I'tikaf), I entered the house for the call of nature, and while passing I inquired after the health of the sick (in the. family), and when the Messenger of Allah (may peace be upon him) was (in I'tikaf), he put out his head towards me, while he himself was in the mosque, and I combed his hair; and he did not enter the house except for the call of nature so long as he was In I'tikaf; and Ibn Rumh stated: As long as they (the Prophet and his wives) were among the observers of I'tikaf.

Book 3, Number 0584:

    'A'isha, the wife of the Apostle (may peace he upon him), reported: The Messenger of Allah (may peace be upon him) put out from the mosque his head for me as he was in I'tikaf, and I washed it in the state that I was menstruating.

Book 3, Number 0585:

    'Urwa reported it from 'A'isha that she observed: The Messenger of Allah (may peace be upon him) inclined his head towards me (from the mosque) while I was in my apartment and I combed it in a state of menstruation.

Book 3, Number 0586:

    Al-Aswad narrated it from 'A'isha that she observed : I used to wash the head of the Messenger of Allah (may peace be upon him), while I was in a state of menstruation.

Book 3, Number 0587:

    'A'isha reported: The Messenger of Allah (may peace be upon him) said to me: Get me the mat from the mosque. I said: I am menstruating. Upon this he remarked: Your menstruation is not in your hand.

Book 3, Number 0588:

    'A'isha reported: The Messenger of Allah (may peace be upon him) ordered me that I should get him the mat from the mosque. I said: I am menstruating. He (the Holy Prophet) said: Do get me that, for menstruation is not in your hand.

Book 3, Number 0589:

    Abu Huraira reported: While the Messenger of Allah (may peace be upon him) was in the mosque, he said: O 'A'isha, get me that garment. She said: I am menstruating. Upon this he remarked: Your menstruation is not in your hand, and she, therefore, got him that.

Book 3, Number 0590:

    'A'isha reported: I would drink when I was menstruating, then I would hand it (the vessel) to the Apostle (may peace be upon him) and he would put his mouth where mine had been, and drink, and I would eat flesh from a bone when I was menstruating, then hand it over to the Apostle (may peace be upon him) and he would put his mouth where mine had been. Zuhair made no mention of (the Holy Prophet's) drinking.

Book 3, Number 0591:

    'A'isha reported: The Messenger of Allah (may peace be upon him) would recline in my lap when I was menstruating, and recite the Qur'an.

Book 3, Number 0592:

    Thabit narrated it from Anas: Among the Jews, when a woman menstruated, they did not dine with her, nor did they live with them in their houses; so the Companions of the Apostle (may peace be upon him) asked The Apostle (may peace be upon him), and Allah, the Exalted revealed: "And they ask you about menstruation; say it is a pollution, so keep away from woman during menstruation" to the end (Qur'an, ii. 222). The Messenger of Allah (may peace be upon him) said: Do everything except intercourse. The Jews heard of that and said: This man does not want to leave anything we do without opposing us in it. Usaid b. Hudair and Abbad b. Bishr came and said: Messenger of Allah, the Jews say such and such thing. We should not have, therefore, any contactwith them (as the Jews do). The face of the Messenger of Allah (way peace be upon him) underwent such a change that we thought he was angry with them, but when they went out, they happened to receive a gift of milk which was sent to the Apostle of Allah (may peace be upon him). He (the Holy Prophet) called for them and gave them drink, whereby they knew that he was not angry with them.

Chapter 3 : ON AL-MADHI

Book 3, Number 0593:

    'Ali reported: I was one whose prostatic fluid flowed readily and I was ashamed to ask the Apostle (may peace be upon him) about it, because of the position of his daughter. I, therefore, asked Miqdad.b. al-Asad and he inquired of him (the Holy Prophet). He (the Holy Prophet) said: He should wash his male organ and perform ablution.

Book 3, Number 0594:

    'Ali reported: I felt shy of asking about prostatic fluid from the Apostle (may peace be upon him) because of Fatimah. I, therefore, asked al-Miqdad (to ask on my behalf) and he asked. He (the Holy Prophet) said: Ablution is obligatory in such a case.

Book 3, Number 0595:

    Ibn 'Abbas reported it from 'Ali: We sent al-Miqdad b. al-Aswad to the Messenger of Allah (may peace be upon him) to ask him what must be done about prostatic fluid which flows from (the private part of) a person. The Messenger of Allah (may peace be upon him) said: Perform ablution and wash your sexual organ.

Chapter 4 : WASHING OF FACE AND HANDS AFTER WAKING UP FROM SLEEP

Book 3, Number 0596:

    Ibn 'Abbas reported: The Apostle (may peace be upon him) woke up at night; relieved himself, and then washed his face and hands and then again slept.

Chapter 5 : IT IS PERMISSIBLE FOR A PERSON TO SLEEP AFTER SEXUAL INTERCOURSE (WITHOUT A BATH) AND THE DESIRABILITY OF ABLUTION FOR HIM, AND WASHING OF THE SEXUAL ORGAN AS HE INTENDS TO FAT, DRINK, OR SLEEP OR COHABIT

Book 3, Number 0597:

    'A'isha reported: Whenever the Messenger of Allah (may peace be upon him) intended to sleep after having sexual intercourse, he performed ablution as for the prayer before going to sleep.

Book 3, Number 0598:

    'A'isha reported: Whenever the Messenger of Allah (may peace be upon him) had sexual intercourse and intended to eat or sleep, he performed the ablution of prayer.

Book 3, Number 0599:

    This hadith has been transmitted by Shu'ba with the same chain of transmitters. Ibn at-Muthanna said in his narration: AI-Hakam narrated to us who heard from Ibrahim narrating that.

Book 3, Number 0600:

    Ibn 'Umar reported: Umar said: Is one amongst us permitted to sleep in a state of impurity (i.e. after having sexual intercourse)? He (the Holy Prophet) said: Yes, after performing ablution.

Book 3, Number 0601:

    Ibn 'Umar said: 'Umar asked the verdict of the Shari'ah from the Apostle (may peace be upon him) thus: Is it permissible for any one of us to sleep in a state of impurity? He (the Holy Prophet said: Yes, he must perform ablution and then sleep and take a bath when he desires.

Book 3, Number 0602:

    Ibn Umar reported: Umar b. al-Khattab said to the Messenger of Allah (may peace be upon him), that he became Junbi during the night. The Messenger of Allah (may peace be upon him) said to him: Perform ablution, wash your sexual organ and then go to sleep.

Book 3, Number 0603:

    'Abdullah b. Abu'l-Qais reported: I asked 'A'isha about the Witr (prayer) of the Messenger of Allah (may peace be upon him) and made mention of a hadith, then I said: What did he do after having sexual intercourse ? Did he take a bath before going to sleep or did he sleep before taking a bath? She said: He did all these. Some- times he took a bath and then slept, and sometimes he performed ablution only and went to sleep. I (the narrator) said: Praise be to Allah Who has made things easy (for human beings).

Book 3, Number 0604:

    This hadith has been transmitted with the same chain of transmitters from Mu'awyia b. Salih by Zuhair b. Harb, 'Abd al-Rahman b. Mahdi, Harun b. Sa'id al-'Aili and Ibn Wahb.

Book 3, Number 0605:

    Abu Sa'id al-Khudri reported: The Messenger of Allah (may peace be upon him) said: When anyone amongst you has sexual intercourse with his wife and then he intends to repeat it, he should perform ablution . In the hadith transmitted by Abu Bakr. (the words are): "Between the two (acts) there should be an ablution," or he (the narrator) said: "Then he intended that it should be repeated."

Book 3, Number 0606:

    Anas reported: The Messenger of Allah (may peace be upon him) used to have sexual intercourse with his wives with a single bath.

Chapter 6 : BATHING IS OBLIGATORY FOR A WOMAN AFTER EXPERIENCING ORGASM IN DREAM

Book 3, Number 0607:

    Anas b. Malik reported: Umm Sulaim who was the grandmother of Ishaq came to the Messenger of Allah (may peace be upon him) in the presence of 'A'isha and said to him: Messenger of Allah, in case or woman sees what a man sees in dream and she experiences in dream what a man experiences (i.e. experiences orgasm)? Upon this 'A'isha remarked: O Umm Sulaim, you brought humiliation to women;may your right hand be covered with dust. He (the Holy Prophet) said to 'A'isha: Let your hand be covered with dust, and (addressing Umm Sulaim) said: Well, O Umm Sulaim, she should take a bath if she sees that (i.e. she experiences orgasm in dream).

Book 3, Number 0608:

    Anas b. Malik reported that Umm Sulaim narrated it that she asked the Apostle of Allah (may peace be upon him) about a woman who sees in a dream what a man sees (sexual dream). The Messenger of Allah (may peace be upon bi m) said: In case a woman sees that, she must take a bath. Umm Sulaim said: I was bashful on account of that and said: Does it happen ? Upon this the Apostle of Allah (may peace be upon him) said: Yes (it does happen), otherwise how can (a child) resemble her ? Man's discharge (i.e. sperm) is thick and white and the discharge of woman is thin and yellow; so the resemblance comes from the one whose genes prevail or dominate.

Book 3, Number 0609:

    Anas b. Malik reported : A woman asked the Messenger of Allah (way peace be upon him) about a woman who sees in her dream what a man sees in his dream (sexual dream). He (the Holy Prophet) said : If she experiences what a man experiences, she should take a bath.

Book 3, Number 0610:

    Umm Salama reported: Umm Sulaim went to the Apostle of Allah (may peace be upon him) and said: Apostle of Allah, Allah is not ashamed of the truth. Is bathing necessary for a woman when she has a sexual dream? Upon this the Messenger of Allah (may peace be upon him) said: Yes, when she sees the liquid (vaginal secretion). Umm Salama said : Messenger of Allah, does a woman have sexual dream ? He (the Holy Prophet) said: Let your hand be covered with dust, in what way does her child resemble her ?

Book 3, Number 0611:

    This hadith with the same sense (as narrated above) bus been transmitted from Hisham b. ‘Urwa with the same chain of narrators but with this addition that she (Umm Salama) said: "You humiliated the women.

Book 3, Number 0612:

    'A'isha the wife of the Apostle (may peace be upon him) narrated: Umm Sulaim, the mother of Bani Abu Talha, came to the Messenger of Allah (may peace be upon him), and a hadith (like that) narrated by Hisham was narrated but for these words. A'isha said: I expressed disapproval to her, saying : Does a woman see a sexual dream ?

Book 3, Number 0613:

    It is reported on the authority of 'A'isha that a woman came to the Messenger of Allah (may peace be upon him) and inquired: Should a woman wash herself when she sees a sexual dream and sees (the marks) of liquid ? He (the Holy Prophet) said: Yes. 'A'isha said to her: May your hand be covered with dust and injured. She narrated: The Messenger of Allah (may peace be upon him) said: Leave her alone. In what way does the child resemble her but for the fact that when the genes contributed by woman prevail upon those of man, the child resembles the maternal family, and when the genes of man prevail upon those of woman the child resembles the paternal family.

Chapter 7 : THE CHARACTERISTIC OF THE MALE REPRODUCTIVE SUBSTANCE (SPERM) AND FEMALE REPRODUCTIVE SUBSTANCE (OVUM), AND THAT THE OFFSPRING IS PRODUCED BY THE CONTRIBUTION OF BOTH

Book 3, Number 0614:

    Thauban, the freed slave of the Messenger of Allah (may peace be upon him), said: While I was standing beside the Messenger of Allah (may peace be upon him) one of the rabbis of the Jews came and said: Peace be upon you, O Muhammad. I pushed him backwith a push that he was going to fall. Upon this he said: Why do you push me? I said: Why don't you say: O Messenger of Allah? The Jew said: We call him by the name by which he was named by his family. The Messenger of Allah (may peace be upon him) said: My name is Muhammad with which I was named by my family. The Jew said: I have come to ask you (something). The Messenger of Allah (may peace be upon him) said: Should that thing be of any benefit to you, if I tell you that ? He (the Jew) said: I will lend my ears to it. The Messenger of Allah (may peace be upon him) drew a line with the help of the stick that he had with him and then said: Ask (whatever you like). Thereupon the Jew said: Where would the human beings be on the Daywhen the earth would change into another earth and the heavens too (would change into other heavens) ? The Messenger of Allah (may peace be upon him) said: They would be in darkness beside the Bridge. He (the Jew) again said: Who amongst people would be the first to cross (this bridge).? He said: They would be the poor amongst the refugees. The Jew said: What would constitute their breakfast when they would enter Paradise? He (the Holy Prophet) replied: A caul of the fish-liver. He (the Jew) said. What would be their food alter this ? He (the Holy Prophet) said : A bullockwhich was fed in the different quarters of Paradise would be slaughtered for them. He (the Jew) said: What would be their drink ? He (the Holy Prophet) said: They would be given drink from the fountain which is named "Salsabil". He (the Jew) said: I have come to ask you about a thing which no one amongst the people on the earth knows except an apostle or one or two men besides him. He (the Holy Prophet) said: Would it benefit you if I tell you that? He (the Jew) said: I would lend ears to that. He then said: I have come to ask you about the child. He (the Holy Prophet) said: The reproductive substance of man is white and that of woman (i.e. ovum central portion) yellow, and when they have sexual intercourse and the male's substance (chromosomes and genes) prevails upon the female's substance (chromosomes and genes), it is the male child that is created by Allah's Decree, and when the substance of the female prevails upon the substance contributed by the male, a female child is formed by the Decree of Allah. The Jew said: What you have said is true; verily you are an Apostle. He then returned and went away. The Messenger of Allah(may peace be upon him) said: He asked me about such and such things of which I have had no knowledge till Allah gave me that.

Book 3, Number 0615:

    This tradition has been narrated by Mu'awyia b. Salim with the same chain of transmitters except for the words: I was sitting beside the Messenger of Allah" and some other minor alterations.

Chapter 8 : BATHING AFTER SEXUAL INTERCOURSE OR SEMINAL EMISSION

Book 3, Number 0616:

    'A'isha reported: When Allah's Messenger (may peace be upon him) bathed because of sexual intercourse, he first washed his hands: he then poured water with his right hand on his left hand and washed his private parts. He then performed ablution as is done for prayer'. He then took some water and put his fingers and moved them through the roots of his hair. And when he found that these had been properly mois- tened, then poured three handfuls on his head and then poured water over his body and subsequently washed his feet.

Book 3, Number 0617:

    This hadith is narrated by Abu Kuraib. Ibn Numair and others, all on the authority of Hisham with the same chain of transmitters, but in their narration these words are not there: "washed his feet."

Book 3, Number 0618:

    Hisham narrated it from his father, who narrated it on the authority of 'A'isha that when the Apostle (may peace be upon him) took a bath because of sexual inter-course, he first washed the palms of his hands three times, and then the whole hadith was transmitted like that based on the authority of Abu Mu'awyia, but no mention is made of the washing of feet.

Book 3, Number 0619:

    'Urwa has narrated it on the authority of 'A'isha that when Allah's Messenger (may peace be upon him) took a bath because of sexual intercourse, he first washed his hands before dipping one of them into the basin, and then performed ablu- tion as is done for prayer.

Book 3, Number 0620:

    Ibn 'Abbas reported it on the authority of Maimuna, his mother's sister, that she said: I placed water near the Messenger of Allah (may peace be upon him) to take a bath because of sexual intercourse. He washed the palms of his bands twice or thrice and then put his hand In the basin and poured water over his private parts and washed them with his left hand. He then struck his hand against the earth and rubbed it with force and then performed ablution for the prayer and then poured three handfuls of water on his head and then washed his whole body after which he moved aside from that place and washed his feet, and then I brought a towel (so that he may wipe his body). but he returned it.

Book 3, Number 0621:

    This hadith is narrated by A'mash with the same chain of transmitters, but in the hadith narrated by Yahya b. Yahya and Abu Kuraib there is no mention of: "Pouring of three handfuls of water on the head." and in the hadith narrated by Waki' all the features of ablution have been recorded : rinsing (of mouth), snuffing of water (in the nostrils) ; and in the hadith transmitted by Abu Mu'awyia, there is no mention of a towel.

Book 3, Number 0622:

    Ibn Abbas narrated It on the authority of Maimuna that the Apostle of Allah (may peace be upon him) was given a towel, but he did not rub (his body) with it, but he did like this with water, i.e. he shook it off.

Book 3, Number 0623:

    'A'isha reported: When the Messenger of Allah (may peace be upon him) took a bath because of sexual intercourse, he called for a vessel and took a handful of water from it and first (washed) the right side of his head, then left, and then took a handful (of water) and poured it on his head.

Chapter 9 : THE QUANTITY OF WATER THAT IS DESIRABLE FOR A BATH BECAUSE OF SEXUAL INTERCOURSE, BATHING OF THE MALE AND FEMALE WITH ONE VESSEL IN THE SAME CONDITION AND WASHING OF ONE OF THEM WITH THE LEFT-OVER OF THE OTHER

Book 3, Number 0624:

    'A'isha reported: The Messenger of Allah (may peace be upon him) washed himself with water from a vessel (measuring seven to eight seers) because of sexual intercourse.

Book 3, Number 0625:

    'A'isha reported: The Messenger of Allah (may peace be upon him) took a bath from the vessel (which contained seven to eight seers, i.e. fifteen to sixteen pounds) of water And I and he (the Holy Prophet) took a bath from the same vessel. And in the hadith narrated by Sufyan the words are: "from one vessel". Qutaiba said : Al-Faraq is three Sa' (a cubic measuring of varying magnitude).

Book 3, Number 0626:

    Abu Salamab. 'Abd al-Rahman reported: I along with the foster brother of 'A'isha went to her and he asked about the bath of the Apostle (may peace be upon him) because of sexual intercourse. She called for a vessel equal to a Sa' and she took a bath. and there was a curtain between us and her. She poured water on her head thrice and he (Abu Salama) said : The wives of the Apostle (may peace be upon him) collectedhair on their heads and these lopped up to ears(and did rot go beyond that).

Book 3, Number 0627:

    Salama b. Abd al-Rahman narrated it on the authority of A'isha that when the Messenger of Allah (may peace be upon him) took a bath, he started from the right hand and poured water over it and washed it, and then poured water on the impurity with the right band and washed it away with the help of the left hand. and after having removed it, he poured water on his head. A'isha said: I and the Messenger of Allah (may peace be upon him) took a bath from the same vessel, after sexual intercourse.

Book 3, Number 0628:

    Hafsa, daughter of 'Abd al-Rahman b. Abu Bakr, reported that 'A'isha narrated to her that she and the Apostle of Allah (may peace be upon him) took a bath from the same vessel which contained water equal to three Mudds or thereabout.

Book 3, Number 0629:

    'A'isha reported: I and the Messenger (may peace be upon him) took a bath from the same vessel and our hands alternated into it in the state that we had had sexual intercourse.

Book 3, Number 0630:

    'A'isha reported : I and the Messenger of Allah (may peace be upon him) took a bath from one vessel which was placed between me and him and he would get ahead of me, so that I would say : Spare (some water for) me, spare (some water for) me; and she said that they had had sexual intercourse.

Book 3, Number 0631:

    Ibn Abbas said: Maimuna (the wife of the Holy Prophet)reported to me that she and the Apostle of Allah (may peace be upon him) took a bath from one vessel.

Book 3, Number 0632:

    Ibn Abbas reported that the Messenger of Allah (may peace be upon him) took a bath with the water left over by Maimuna.

Book 3, Number 0633:

    Zainab bint Umm Salama (the wife of the Holy Prophet) reported that Umm Salama and the Messenger of Allah (may peace be upon him) took a bath from the same vessel.

Book 3, Number 0634:

    Anas reported that the Messenger of Allah (may peace he upon him) took a bath with five Makkuks of water and performed ablution with one Makkuk. Ibn Muthanna has used the words five Makakiyya, and Ibn Mu'adh narrated it from 'Abdullah b. 'Abdullah and he made no mention of Ibn Jabr.

Book 3, Number 0635:

    Anas said: The Apostle of Allah (may peace be upon him) performed ablution with one Mudd and took bath with a Sa' up to five Mudds.

Book 3, Number 0636:

    Safina reported: The Messenger of Allah (may peace be upon him) took a bath with one g' of water because of sexual intercourse and performed ablution with one Mudd.

Book 3, Number 0637:

    Safina reported that Abd Bakr, the Companion of the Messenger of Allah (way peace be upon him), observed: The Messenger of Allah (may peace.1)e upon him) took a bath with one Sa' of water and performed ablution with one Mudd (of water); and in the hadith narrated by Ibn Hujr the words are: One Mudd sufficed for his (Holy Prophet's) ablution. And Ibn Hujr said that (his Shaikh) Isma'il was much advanced in age, and it was because of this that he could not fully rely on him for this tradition.

Chapter 10 : THE DESIRABILITY OF POURTNG WATER THRICE ON THE HEAD AND OTHER PARTS (OF THE BODY)

Book 3, Number 0638:

    Jubair b. Mut'im reported: The people contended amongst themselves in the presence of the Messenger of Allah (may peace be upon him) with regard to bathing. Some of them said: We wash our heads like this and this. Upon this the Messenger (may peace be upon him) said: As for me I pour three handfuls of water upon my head.

Book 3, Number 0639:

    Jubair b. Mut'im reported it from the Apostle of Allah (may peace be upon him) that a mention was made before him about bathing because of sexual intercourse and he said: I pour water over my head thrice.

Book 3, Number 0640:

    Jabir b. Abdullah reported: A delegation of the Thaqif said to the Apostle of Allah (may peace be upon him): Our land is cold; what about our bathing then? He (the Holy Prophet) said: I pour water thrice over my head.

Book 3, Number 0641:

    Ibn Salim in his narration reported : "The delegation of the Thaqif said: Messenger of Allah."

Book 3, Number 0642:

    Jabir b. 'Abdullah reported: When the Messenger of Allah (may peace be upon him) took a bath because of sexual intercourse, he poured three handfuls of water upon his head. Hasan b. Muhammad said to him (the narrator): My hair is thick. Upon this Jabir observed. I said to him: O son of my brother, the hair of the Messenger of Allah (may peace be upon him) was thicker than your hair and these were more fine (than yours).

Chapter 11 : LAW OF SHARI'AH PERTAINING TO THE PLAITED HAIR OF THE WOMAN WHO TAKES A BATH

Book 3, Number 0643:

    Umm Salama reported: I said: Messenger of Allah, I am a woman who has closely plaited hair on my head; should I undo it for taking a bath, because of sexual intercourse? He (the Holy Prophet) said: No, it is enough for you to throw three handfuls of water on your head and then pour water over yourself, and you shall be purified.

Book 3, Number 0644:

    This hadith has been narrated by Amr al-Naqid, Yazid b. Harun, 'Abd b. Humaid, Abd al-Razzaq, Thauri, Ayyub b. Musa, with the same chain of transmitters. In hadith narrated by Abd al-Razzaq there is a mention of the menstruation and of the sexual intercourse. The rest of the hadith has been transmitted like that of Ibn 'Uyaina.

Book 3, Number 0645:

    This hadith is narrated by the same chain of transmitters by Ahmad al. Darimi, Zakariya b. 'Adi, Yazid, i.e.' Ibn Zurai', Rauh b. al-Qasim, Ayyub b. Musa with the same chain of transmitters, and there is a mention of these words: "Should I undo the plait and wash it, because of sexual intercourse?" and there is no mention of menstruation.

Book 3, Number 0646:

    'Ubaid b. Umair reported: It was conveyed to 'A'isha that 'Abdullah b. 'Amr ordered the women to undo the (plaits) of hair on their heads. She said: How strange it is for Ibn 'Amr that he orders the women to undo the plaits of their head while taking a bath; why does he not order them to shave their beads? I and the Messenger of Allah (may peace be upon him) took bath from one vessel. I did no more than this that I poured three handfuls of water over my head.

Chapter 12 : THE DESIRABILITY OF USING MUSK AT THE SPOT OF BLOOD WHILE BATHING AFTER MENSTRUATION

Book 3, Number 0647:

    'A'isha reported: A woman asked the Apostle of Allah (may peace be upon him) how to wash herself after menstruation. She mentioned that he taught her how to take bath and then told her to take a piece of cotton with musk and purify herself. She said: How should I purify myself with that? He (the Holy Prophet) said: Praise be to Allah, purify yourself with it, and covered his face, Sufyan b. 'Uyaina gave a demonstration by covering his face (as the Holy Prophet had done). 'A'isha reported: I dragged her to my side for I had understood what the Apostle of Allah (may peace be upon him) intended and, therefore, said: Apply this cotton with musk to the trace of blood. Ibn 'Umar in his hadith (has mentioned the words of 'A'isha thus): Apply it to the marks of blood.

Book 3, Number 0648:

    'A'isha reported: A woman asked the Apostle of Allah (may peace be upon him) how he should wash herself after the menstrual period. He (the Holy Prophet) said: Take a cotton with musk and purity yourself, and the rest of the hadith was narrated like that of Sufyan.

Book 3, Number 0649:

    'A'isha reported: Asma (daughter of Shakal) asked the Apostle of Allah (may peace be upon him) about washing after menstruation. He said: Everyone amongst you should use water (mixed with the leaves of) the lote-tree and cleanse herself well, and then pour water on her head and rub it vigorously till it reaches the roots of the hair. Then she should pour water on it. Afterwards she should take a piece of cotton smeared with musk and cleanse herself with it. Asma' said: How should she cleanse herself with the help of that? Upon this he (the Apostle of Allah) observed: Praise be to Allah, she should cleanse herself. 'A'isha said in a subdued tone that she should apply it to the trace of blood. She (Asma) then further asked about bathing after sexual intercourse. He (the Holy Prophet) said: She should take water and cleanse herself well or complete the ablution and then (pour water) on her head and rub it till it reaches the roots of the hair (of her) head and then pour water on her. 'A'isha said: How good are the women of Ansar (helpers) that their shyness does not prevent them from learning religion.

Book 3, Number 0650:

    This hadith is narrated by 'Ubaidullah b. Mu'adh with the same chain of transmitters (but for the words) that he (the Holy Prophet) said: Cleanse yourself with it, and he covered (his face on account of shyness).

Book 3, Number 0651:

    'A'isha reported: Asma' b. Shakal came to the Messenger of Allah (may peace be upon him) and said: Messenger of Allah, how one amongst us should take a bath after the menstruation, and the rest of the hadith is the same and there is no mention of bathing because of sexual intercourse.

Chapter 13 : THE WOMAN WHO HAS A PROLONGED FLOW OF BLOOD, HER BATHING AND PRAYER

Book 3, Number 0652:

    'A'isha reported: Fatimah b. Abu Hubaish came to the Apostle (may peace be upon him) and said: I am a woman whose blood keeps flowing (even after the menstruation period). I am never purified ; should I, therefore, abandon prayer? He (the Holy Prophet) said: Not at all, for that is only a vein, and is not a menstruation, so when menstruation comes, abandon prayer, and when it ends wash the blood from yourself and then pray.

Book 3, Number 0653:

    The hadith narrated by Waki' and with its chain of narrators has been transmitted on the authority of Hisham b. 'Urwa, but in the hadith narrated by Qutaiba on the authority of Jarir, the words are: "There came Fatimah b. Abu Hubaish, b. 'Abd al-Muttalib b. Asad, and she was a woman amongst us," and in the hadith of Hammid b. Zaid there is an addition of these words: "We abandoned mentioning him."

Book 3, Number 0654:

    'A'isha reported: Umm Habiba b. Jahsh thus asked for a verdict from the Messenger of Allah (may peace be upon him): I am a woman whose blood keeps flowing (after the menstrual period).He (the Holy Prophet) said: That is only a vein, so take a bath and offer prayer; and she took a bath at the time of every prayer. Laith b. Sa'd said: Ibn Shihab made no mention that the Messenger of Allah (may peace be upon him) had ordered her to take a bath at the time of every prayer, but she did it of her own accord. And in the tradition transmitted by Ibn Rumh there is no mention of Umm Habiba (and there is mention of the daughter of Jahsh only.)

Book 3, Number 0655:

    'A'isha, the wife of the Messenger of Allah (may peace be upon him)reported: Umm Habiba b. Jahsh who was the sister-in-law of the Messenger of Allah (may peace be upon him) and the wife of 'Abd al-Rahman b. Auf, remained mustahada for seven years, and she, therefore, asked for the verdict of Shari'ah from the Messenger of Allah (may peace be upon him) about it The Messenger of Allah (may peace be upon him) said: This is not menstruation, but (blood from) a vein: so bathe yourself and offer prayer. 'A'isha said: She took a bath in the wash-tub placed in the apartment of her sister Zainab b. Jahsh, till the redness of the blood came over the water. Ibn Shihab said: I narrated it to Abu Bakr b. 'Abd al-Rahman b. al-Harith b. Hisham about it who observed: May Allah have mercy on Hinda! would that she listened to this verdict. By Lord, she wept for not offering prayer.

Book 3, Number 0656:

    This hadith has been thus reported by another chain of transmitters: Umm Habiba b. Jahsh came to the Messenger of Allah (may peace be upon him) and she had been a mustahada for seven years, and the rest of the hadith was narrated like that of 'Amr b. al-Harith up to the words: "There came the redness of the blood over water." and nothing was narrated beyond it.

Book 3, Number 0657:

    The hadith has been narrated by 'A'isha through another chain of transmitters (in these words): I The daughter of jahsh had been mustabida for seven years," and the rest of the hadith is the same (as mentioned above).

Book 3, Number 0658:

    On the authority of 'A'isha: Umm Habiba asked the Messenger of Allah (may peace be upon him) about the blood (which flows beyond the period of menstruation). 'A'isha said: I saw her wash-tub full of blood. The Messenger of Allah (may peace be upon him) said: Remain away (from prayer) equal (to the length of time) that your menses prevented you. After this (after the period of usual courses) bathe yourself and offer prayer.

Book 3, Number 0659:

    'A'isha, the wife of the Apostle (may peace be upon him), said: Umm Habiba b. Jahsh who was the spouse of Abd al- Rahman b. Auf made a complaint to the Messenger of Allah (may peace be upon him) about blood (which flows beyond the menstrual period). He said to her: Remain away (from prayer) equal (to the length of time) that your menstruation holds you back. After this, bathe yourself. And she washed herself before every prayer.

Chapter 14 : IT IS OBLIGATORY FOR A MENSTRUATING WOMAN TO COMPLETE THE ABANDONED FASTS BUT NOT THE ABANDONED PRAYERS

Book 3, Number 0660:

    Mu'adha reported: A woman asked 'A'isha: Should one amongst us complete prayers abandoned during the period of menses? 'A'isha said: Are you a Haruriya? When any one of us during the time of the Messenger of Allah (may peace be upon him) was in her menses (and abandoned prayer) she was not required to complete them.

Book 3, Number 0661:

    It is reported from Mu'adha that she asked 'A'isha: Should a menstruating woman complete the prayer (abandoned during the menstrual period) ? 'A'isha said: Are you a Hurariya? The wives of the Messenger of Allah (may peace be upon him) have had their monthly courses, (but) did he order them to make compensation (for the abandoned prayers)? Muhammad b. Ja'far said: (Compensation) denotes their completion.

Book 3, Number 0662:

    Mu'adha said: I asked 'A'isha: What is the reason that a menstruating woman completes the fasts (that she abandons during her monthly course). but she does not complete the prayers? She (Hadrat 'A'isha) said: Are you a Haruriya? I said: I am not a Haruriya, but I simply want to inquire. She said: We passed through this (period of menstruation), and we were ordered to complete the fasts, but were not ordered to complete the prayers.

Chapter 15 : ONE SHOUL1D DRAW AROUND A CURTAIN WHILE TAKING A BATH

Book 3, Number 0663:

    Umm Hani b. Abu Talib reported: I went to the Messenger of Allah (may peace be upon him) on the day of the conquest (of Mecca) and found him take a bath. while his daughter Fatimah was holding a curtain around him.

Book 3, Number 0664:

    Umm Hani b. Abu Talib reported : It was the day of the conquest (of Mecca) that she went to the Messenger of Allah (may peace be upon him) and he was staying at a higher part (of that city). The Messenger of Allah (may peace be upon him) got up for his bath. Fatimah held a curtain around him (in order to provide him privacy). He then put on his garments and wrapped himself with that and then offered eight rak'ahs of the forenoon prayer.

Book 3, Number 0665:

    This hadith is narrated by Sa'id b. Abu Hind with the same chain of transmitters and said: His (the Holy Prophet's) daughter Fatimah provided him privacy with the help of his cloth, and when he had taken a bath he took it up and wrapped it around him and then stood and offered eight rak'ahs of the forenoon prayer.

Book 3, Number 0666:

    Maimuna reported: I placed water for the Apostle (may peace be upon him) and provided privacy for him, and he took a bath.

Chapter 16 : IT IS FORBIDDEN TO SEE THE PRIVATE PARTS OF SOMEONE ELSE

Book 3, Number 0667:

    'Abd al-Rahman, the son of Abu Sa'id al-Khudri, reported from his father: The Messenger of Allah (may peace be upon him) said: A man should not see the private parts of another man, and a woman should not see the private parts of another woman, and a man should not lie with another man under one covering, and a woman should not lie with another woman under one covering.

Book 3, Number 0668:

    This hadith has been narrated by Ibn Abu Fudaik and Dabbik b. 'Uthman with the same chain of transmitters and they observed: Private parts of man are the nakedness (which is concealed).

Chapter 17 : IT IS PERMISSIBLE TO TAKE A BATH NAKED IN COMPLETE PRIVACY

Book 3, Number 0669:

    Amongst the traditions narrated from Muhammad, the Messenger of Allah (may peace be upon him) on the authority of Abu Huraira, the one is that Banu Isra'il used to take a bath naked, and they looked at the private parts of one another. Moses (peace be upon him), however, took a bath alone (in privacy); and they said (tauntingly): By Allah, nothing prohibits Moses to take a bath along with us, but sacrotal hernia. He (Moses) once went for a bath and placed his clothes on a stone and the stone moved on with his clothes. Moses ran after it saying: 0 stone, my clothes, 0 stone, my clothes, and Banu Isra'il had the chance to see the private parts of Moses, and said : By Allah, Moses does not suffer from any ailment. The stone then stopped, till Moses had been seen by them, and he then took hold of his clothes and struck the stone. Abu Huraira said: By Allah, there are the marks of six or seven strokes made by Moses on the stone.

Chapter 18 : UTMOST CARE FOR KEEPING-PRIVATE PARTS OF BODY CONCEALED

Book 3, Number 0670:

    Jabir b. 'Abdullah reported: When the Ka'ba was constructed the Apostle of Allah (may peace be upon him) and Abbas went and lifted stones. Abbas said to the Messenger of Allah (may peace be upon him): Place your lower garment on your shoulder (so that you may protect yourself from the roughness and hardness of stones). He (the Holy Prophet) did this, but fell down upon the ground in a state of unconciousness and his eyes were turned towards the sky. He then stood up and said: My lower garment, my lower garment ; and this wrapper was tied around him. In the hadith transmitted by Ibn Rafi', there is the word : "On his neck" and he did not say : "Upon his shoulder."

Book 3, Number 0671:

    Jabir b. 'Abdullah reported: The Messenger of Allah (may peace be upon him) was carrying along with them (his people) stones for the Ka'ba and there was a waist wrapper around him. His uncle, "Abbas, said to him: 0 son of my brother! if you take off the lower garment and place it on the shoulders underneath the stones, it would be better. He (the Holy Prophet) took it off and placed it on his shoulder and fell down unconscious. He (the narrator) said: Never was he seen naked after that day.

Book 3, Number 0672:

    Al-Miswar b. Makhrama reported : I was carrying a heavy stone and my lower garment was loose, and it, therefore, slipped off (so soon) that I could not place the stone (on the ground) and carry to its proper place. Upon this the Messenger of Allah (may peace be upon him) said: Return to your cloth (lower garment), take it (and tie it around your waist) and do not walk naked.

Chapter 19 : CONCEALING ONE'S PRIVATE PARTS WHILE RELIEVING ONESELF

Book 3, Number 0673:

    'Abdullah b. Ja'far reported : The Messenger of Allah (may peace be upon him) one day made me mount behind him and he confided to me something secret which I would not disclose to anybody; and the Messenger of Allah (may peace be upon him) liked the concealment provided by a lofty place or cluster of dates (while answering the call of nature), Ibn Asma' said in his narration : It implied an enclosure of the date-trees.

Chapter 20 : EMISSION OF SEMEN MAKES BATH OBLIGATORY

Book 3, Number 0674:

    Sa'id al-Khudri narrated it from his father : I went to Quba' with the Messenger of Allah (may peace be upon him) on Monday till we reached (the habitation) of Banu Salim. The Messenger of Allah (may peace be upon him) stood at the door of 'Itban and called him loudly. So he came out dragging his lower garnment. Upon this the Messenger of Allah (may peace be upon him) said : We have made this man to make haste 'Itban said : Messenger of Allah, if a man parts with his wife suddenly without seminal emission, what is he required to do (with regard to bath) ? The Messenger of Allah (may peace be upon him) said : It is with the seminal emission that bath becomes obligatory.

Book 3, Number 0675:

    Abu al.'Ala' b. al-Shikhkhir said: The Messenger of Allah (may peace be upon him) abrogated some of his commands by others, just as the Qur'an abrogates some part with the other.

Book 3, Number 0676:

    Abu Sa'id al-Khudri reported: The Messenger of Allah (may peace be upon him) happened to pass by (the house) of a man amongst the Ansar, and he sent for him. He came out and water was trickling down from his head. Upon this he (the Holy Prophet) said: Perhaps we put you to haste. He said : Yes. Messenger of Allah. He (the Holy Prophet) said : When you made haste or semen is not emitted, bathing is not obligatory for you, but ablution is binding. Ibn Bashshir has narrated it with a minor alteration.

Book 3, Number 0677:

    Ubayy Ibn Ka'b reported: I arked the Messenger of Allah (may peace be upon him) about a man who has sexual intercourse with his wife, but leaves her before orgasm. Upon this he (the Holy Prophet) said: He should wash the secretion of his wife, and then perform ablution and ofier prayer.

Book 3, Number 0678:

    Ubayy ibn Ka'b narrated it from the Messenger of Allah (may peace be upon him) that he said : If a person has sexual intercourse with his wife, but does not experience orgasm, he should wash his organ and perform an ablution.

Book 3, Number 0679:

    Abu Sa'id al-Khudri reported: The Apostle of Allah (may peace be upon him) observed: Bathing is obligatory in case of seminal emission.

Book 3, Number 0680:

    Zaid b. Khalid al-Jubani reported that he askad Uthman b. 'Affan: What is your opinion about the man who has sexual intercourse with his wife, but does not experience orgasm? Uthman said: He should perform ablution as he does for prayer, and wash his organ. 'Uthmin also said : I have heard it from the Messenger of Allah (may peace be upon him).

Book 3, Number 0681:

    Abu Ayyub reported that he had heard like this from the Messenger of Allah (may peace be upon him).

Chapter 21 : ABROGATION OF (THE COMMAND THAT) BATH IS OBLIGATORY (ONLY) BECAUSE OF SEMINAL EMISSION AND INSTEAD CONTACT OF THE CIRCUMCISED PARTS MAKES BATH OBLIGATORY

Book 3, Number 0682:

    Abu Huraira reported: The Apostle of Allah (may peace be upon him) said: When a man has sexual intercourse, bathing becomes obligatory (both for the male and the female). In the hadith of Matar the words are: Even if there is no orgasm. Zuhair has narrated it with a minor alteration of words.

Book 3, Number 0683:

    This hadith is narrated by Qatida with the same chain of transmitters, but with minor alterations. Here instead of the word -(jahada, (ijtahada) has been used, and the words; "Even if there is no orgasm" have been omitted.

Book 3, Number 0684:

    Abu Musa reported: There cropped up a difference of opinion between a group of Muhajirs (Emigrants and a group of Ansar (Helpers) (and the point of dispute was) that the Ansar said: The bath (because of sexual intercourse) becomes obligatory only-when the semen spurts out or ejaculates. But the Muhajirs said: When a man has sexual intercourse (with the woman), a bath becomes obligatory (no matter whether or not there is seminal emission or ejaculation). Abu Musa said: Well, I satisfy you on this (issue). He (Abu Musa, the narrator) said: I got up (and went) to 'A'isha and sought her permission and it was granted, and I said to her: 0 Mother, or Mother of the Faithful, I want to ask you about a matter on which I feel shy. She said : Don't feel shy of asking me about a thing which you can ask your mother, who gave you birth, for I am too your mother. Upon this I said: What makes a bath obligatory for a person ? She replied: You have come across one well informed! The Messenger of Allah (may peace be upon him) said: When anyone sits amidst four parts (of the woman) and the circumcised parts touch each other a bath becomes obligatory.

Book 3, Number 0685:

    'A'isha the wife of the Apostle of Allah (may peace be upon him) reported. A person asked the Messenger of Allah (may peace be upon him) about one who has sexual intercourse with his wife and parts away (without orgasm) whether bathing is obligatory for him. 'A'isha was sitting by him. The Messenger of Allah (may peace be upon him) said: I and she (the Mother of the Faithful) do it and then take a bath.

Chapter 22 : ABLUTION IS ESSENTIAL WHEN ONE TAIZES SOMETHING COOKED WITH THE HELP OF FIRE

Book 3, Number 0686:

    Zaid b Thabit reported: I heard the Messenger of Allah (may peace be upon him) say this: Ablution is obligatory (for one who takes anything) touched by fire.

Book 3, Number 0687:

    'Abdullah b. Ibrahim b. Qariz reported that he found Abu Huraira performing ablution in the mosque, who said: I am performing ablution because of having eaten pieces of cheese, for I heard the Messenger of Allah (may peace be upon him) say: Perform ablution (after eating anything) touched by fire.

Book 3, Number 0688:

    'Urwa reported on the authority of'A'isha, the wife of the Messenger of Allah (may peace be upon him), saying this: The Messenger of Allah (may peace be upon him) said. Perform ablution (after eating) anything touched by fire.

Chapter 23 : ABROGATION OF THE HADITH THAT ABLUTION IS OBLIGATORY FOR HIM WHO TAKES SOMETHING COOKED WITH THE HELP OF FIRE

Book 3, Number 0689:

    Ibn 'Abbas reported: The Messenger of Allah (may peace be upon him) took (meat of) goat's shoulder and offered prayer and did not perform ablution.

Book 3, Number 0690:

    Ibn 'Abbas reported: The Messenger of Allah (may peace be upon him) took flesh from the bone or meat, and then offered prayer and did not perform ablution, and (in fact) he did not touch water.

Book 3, Number 0691:

    Ja'far b. Amr b. Umayya al-Damari reported on the authority of his father who said: I saw the Messenger of Allah (may peace be upon him) take slices from goat's shoulder, and then eat them, and then offer prayer without having performed ablution.

Book 3, Number 0692:

    Ja'far b. 'Amr b. Umayya al-Damari reported on the authority of his father who said: I saw the Messenger of Allah (may peace be upon him) take slices from goat's shoulder and then eat them. He was called for prayer and he got'up, leaving aside the knife, and offered prayer but did not perform ablution.

Book 3, Number 0693:

    Ibn 'Abbas reported it on the authority of Maimuana, the wife of the Apostle of Allah (may peace be upon him), that the Apostle of Allah (may peace be upon him) took (a piece of goat's) shoulder at her place, and then offered prayer but did not perform ablution.

Book 3, Number 0694:

    This hadith has been narrated by Ibn 'Abbas on the authority of Maimuna. the wife of the Apostle (may peace be upon him), by another chain of transmitters.

Book 3, Number 0695:

    Abu Rafi' reported: I testify that I used to roast the liver of the goat for the Messenger of Allah (may peace be tipcn him) and then he offered praver but did not perform ablution.

Book 3, Number 0696:

    Ibn Abbas reported: The Apostle (may peace be upon him) took milk and then called for water and rinsed (his mouth) and said: It contains greasiness.

Book 3, Number 0697:

    This hadith has been narrated by another chain of transmitters.

Book 3, Number 0698:

    Ibn Abbas reported: The Messenger of Allah (may peace be upon him) dressed himself, and then went out for prayer, when he was presented with bread and meat. He took three morsels out of that, and then offered prayer along with other people and did not touch water.

Book 3, Number 0699:

    This hadith is narrated by Muhammad b. 'Amr b. Ata' with these words: I was with Ibn 'Abbas, and Ibn 'Abbas saw the Apostle of Allah (may peace be upon him) doing like this, and it is also said that the words are: He (the Holy Prophet) offered prayer; and the word "people" is not mentioned.

Chapter 24 : THE QUESTION OF ABLUTION AFTER EATING THE FLESH OF THE CAMEL

Book 3, Number 0700:

    Jabir b. Samura reported: A man asked the Messenger of Allah (may peace he upon him) whether he should perform ablution after (eating) mutton. He (the Messenger of Allah) said: Perform ablution it you so desire, and if you do not wish, do not perform it. He (again) asked: Should I perform ablution (after eating) camel's flesh? He said: Yes, perform ablution (after eating) camel's flesh. He (again) said: May I say prayer in the sheepfolds? He (the Messenger of Allah) said: Yes. He (the narrator) again said: May I say prayer where camels lie down? He (the Holy Prophet) said: No.

Book 3, Number 0701:

    This hadith is also narrated by another chain of transmitters.

Chapter 25 : A MAN WHO IS SURE OF HIS PURIFICATION, BUT ENTERTAINS DOUBT OF ANYTHING BREAKING IT, CAN SAFELY OFFER PRAYER WITHOUT PERFORMING A NEW ABLUTION

Book 3, Number 0702:

    'Abbad b. Tamim reported from his uncle that a person made a complaint to the Apostle (may peace be upon him) that he entertained (doubt) as it something had happened to him breaking his ablution. He (the Holy Prophet) said: He should not return (from prayer) unless he hears a sound or perceives a smell (of passing wind). Abu Bakr and Zuhair b. Harb have pointed out in their narrations that it was 'Abdullah b. Zaid.

Book 3, Number 0703:

    Abu Huraira reported: The Messenger of Allah (may peace be upon him) said: If any one of you has pain in his abdomen, but is doubtful whether or not anything has issued from him, be should not leave the mosque unless he hears a sound or perceives a smell.

Chapter 26 : PURIFICATION OF THE SKINS OF THE DEAD ANIMALS BY TANNING THEM

Book 3, Number 0704:

    The freed slave-girl of Maimuna was given a goat in charity but it died. The Messenger of Allah (may peace be upon him) happened to pass by that (carcass). Upon this be said : Why did you not take off its skin? You could put it to use, after tanning it. They (the Companions) said: It was dead. Upon, this he (the Messenger of Allah) said: Only its eating is prohibited. Abu bakr and Ibn Umar in their narrations said: It is narrated from Maimuna (may Allah be pleased with her).

Book 3, Number 0705:

    Ibn 'Abbas said: The Messenger of Allah (may peace be upon him) saw a dead goat, which had been given in charity to the freed slave-girl of Maimuna. The Messenger of Allah (may peace be upon him) said: Why don't you make use of its skin? They (the Companions around the Holy Prophet) said: It is dead. Upon this he said: It is the eating (of the dead animal) which is prohibited.

Book 3, Number 0706:

    This hadith is narrated by Ibn Shihab with the same chain of transmitters as transmitted by Yunus.

Book 3, Number 0707:

    Ibn Abbas reported: The Messenger of Allah (may peace be upon him) happened to pass by a goat thrown (away) which had been in fact given to the freed slave-girl of Maimuna as charity. Upon this the Messenger of Allah (way peace he upon him) said: Why did they not get its skin ? They had better tan it and make use of it.

Book 3, Number 0708:

    Ibn'Abbas reported on the authority of Maimuna that someone amongst the wives of the Messenger of Allah (may peace be upon him) had a domestic animal and it died. Upon this the Messenger of Allah (may peace be upon him) said: Why did you not take off its skin and make use of that?

Book 3, Number 0709:

    Ibn 'Abbas reported: The Apostle of Allah(may peace be upon him)happened to pass by (the dead body) of the goat which belonged to the freed slave-girl of Maimuna and said: Why did you not make use of its skin?

Book 3, Number 0710:

    Abdullah b. Abbas said: I heard the Apostle of Allah (may peace be upon him) say: When the skin is tanned it becomes purified.

Book 3, Number 0711:

    This hadith has been transmitted on the authority of Ibn 'Abbas by another chain of transmitters.

Book 3, Number 0712:

    Abu al-Khair reported: I saw Ibn Wa'la al-Saba'i wear a fur. I touched it. He said: Why do you touch it ? I asked Ibn 'Abbas saying: We are the inhabitants of the western regions, and there (live) with us Berbers and Magians. They bring with them rams and slaughter them, but we do not eat (the meat of the animals) slaughtered by them, and they come with skins full of fat. Upon this Ibn 'Abbas said: We asked the Messenger of Allah (may peace be upon him) about this and he said: Its tanning makes it pure.

Book 3, Number 0713:

    Ibn Wa'la al-Saba'i reported: I asked 'Abdullah b. 'Abbas saying: We are the inhabitants of the western regions. The Magians come to us with skins full of water and fat. He said : Drink. I said to him: Is it your own opinion ? Ibn Abbas said: I heard the Messenger of Allah (may peace be upon him) say: Tanning purifies it (the skin).

Chapter 27 : TAYAMMUM

Book 3, Number 0714:

    'A'isha reported: We went with the Apostle of Allah (may peace be upon him) on one of his journeys and when we reached the place Baida' or Dhat al-jaish, my necklace was broken (and fell somewhere). The Messenger of Allah (way peace be upon him) along with other people stayed there for searching it. There was neither any water at that place nor was there any water with them (the Companions of the Holy Prophet). Some persons came to my father Abu Bakr and said: Do you see what 'A'isha has done? She has detained the Messenger of Allah (may peace be upon him) and persons accompanying him, and there is neither any water here or with them. So Abu Bakr came there and the Messenger of Allah (may peace be upon him) was sleeping with his head on my thigh. He (Abu Bakr) said: You have detained the Messenger of Allah (may peace be upon him) and other persons and there is neither water here nor with them. She ('A'isha) said : Abu Bakr scolded me and uttered what Allah wanted him to utter and nudged my hips with his hand. And there was nothing to prevent me from stirring but for the fact that the messenger of Allah (may peace be upon him) was lying upon my thigh. The Messenger of Allah (may peace be upon him) slept till it was dawn at a waterless place. So Allah revealed the verses pertaining to tayammum and they (the Holy Prophet and his Companions) performed tayammum. Usaid b. al-Hudair who was one of the leaders said: This is not the first of your blessings, 0 Family to Abu Bakr. 'A'isha said: We made the came) stand which was my mount and found the necklace under it.

Book 3, Number 0715:

    'A'isha reported she had borrowed from Asma' (her sister) a necklace and it was lost. The Messenger of Allah (may peace be upon him) sent men to search for it. As it was the time for prayer, they offered prayer without ablution (as water was not available there). When they came to the Messenger of Allah (may peace be upon him), they made a complaint about it, and the verses pertaining to tayammum were revealed. Upon this Usaid b. Hadair said (to 'A'isha): May Allah grant you a good reward! Never has been there an occasion when you were beset with difficulty and Allah did not make you come out of that and made it an occasion of blessing for the Muslims.

Book 3, Number 0716:

    Shaqiq reported : I was sitting in the company of Abdullah and Abu Musa when Abu Musa said: 0 'Abd al-Rahman (kunya of 'Abdullah b. Mas'ud), what would you like a man to do about the prayer if he experiences a seminal emission or has sexual intercourse but does not find water for a month ?'Abdullah said: He should not perform tayammum even if he does not find water for a month. 'Abdullah said: Then what about the verse in Sura Ma'ida: "If you do not find water, betake yourself to clean dust" ? 'Abdullah said : If they were granted concession on the basis of this verse, there is a possibility that they would perform tayammum with dust on finding water very cold for themselves. Abu Musa said to Abdullah: You have not heard the words of 'Ammar: The Messenger of Allah (may peace be upon him) sent me on an errand and I had a seminal emission, but could find no water, and rolled myself in dust just as a beast rolls itself. I came to the Messenger of Allah (may peace be upon him) then and made a mention of that to him and he (the Holy Prophet)said: It would have been enough for you to do thus. Then he struck the ground with his hands once and wiped his right hand with the help of his left hand and the exterior of his palms and his face. 'Abdullah said: Didn't you see that Umar was not fully satisfied with the words of 'Ammar only ?

Book 3, Number 0717:

    This hadith is narrated by Shaqiq with the same chain of transmitters but with the alteration of these words: He (the Holy Prophet) struck hands upon the earth, and then shook them and then wiped his face and palm.

Book 3, Number 0718:

    Abd al-Rabmin b. Abza narrated It on the authority of his father that a man came to 'Umar and said: I am (at times) affected by seminal emission but find no water. He ('Umar) told him not to say prayer. 'Ammar then said. Do you remember, 0 Commander of the Faithful, when I and you were in a military detachment and we had had a seminal emission and did not find water (for taking bath) and you did not say prayer, but as for myself I rolled in dust and said prayer, and (when it was mentioned before) the Apostle (may peace be upon him) said: It was enough for you to strike the ground with your hands and then blow (the dust) and then wipe your face and palms. Umar said: 'Ammar, fear Allah. He said: If you so like, I would not narrate it.
    A hadith like this has been transmitted with the same chain of transmitters but for the words: 'Umar said: We hold you responsible for what you claim."

Book 3, Number 0719:

    'Abd al-Rahman b. Abza mnated it on the authority of his father that a man came to Umar and said : I have had a seminal emission but I found no water, and the rest of the hadith is the same but with this addition: 'Amr said: 0 Commander of the Faithful, because of the right given to you by Allah over me, if you desire, I would not narrate this hadith to anyone.

Book 3, Number 0720:

    Umair, the freed slave of Ibn 'Abbas, reported: I and 'Abd al-Rahmin b. Yasir, the freed slave of Maimuna, the wife of the Apostle (way peace be upon him). came to the house of Abu'l-Jahm b. al-Harith al-Simma Ansari and he said: The Messenger of Allah (may peace be upon him) came from the direction of Bi'r Jamal and a man met him; he saluted him but the Messenger of Allah (may peace be upon him) made no response, till he (the Holy Prophet) came to the wall, wiped his face and hands and then returned his salutations.

Book 3, Number 0721:

    Ibn Umar reported: A person happened to pass by the Messenger of Allah (may peace be upon him) when he was making water and saluted him, but he did not respond to his salutation.

Chapter 28 : A MUSLIM IS NOT DEFILED

Book 3, Number 0722:

    Abu Huraira reported that he met the Apostle of Allah (may peace be upon him)on one of the paths leading to Medina in a state of (sexual) defilement and he slipped away and took a bath. The Apostle of Allah (may peace be upon him) searched for him and when he came, he said to him: 0 Abu Huraira, where were you? He said: Messenger of Allah, you met when I was (sexually) defiled and I did not like to sit in your company before taking a bath. Upon this the Messenger of Allah (may peace be upon him) said: Hallowed be Allah, verily a believer is never defiled.

Book 3, Number 0723:

    Hudhaifa reported: The Messenger of Allah (may peace be upon him) happened to meet him and he was (sexually) defiled, and he slipped away and took a bath and then came and said: I was (sexually) defiled. Upon this he (the Holy Prophet) remarked: A Muslim is never defiled.

Chapter 29 : REMEMBRANCE OF ALLAH EVEN IN A STATE OF SEXUAL DEFILEMENT

Book 3, Number 0724:

    'A'isha said: The Apostle of Allah (may peace be upon him) used to remember Allah at all moments.

Chapter 30 : IT IS PERMISSIBLE TO EAT WITHOUT ABLUTION AND THERE IS NO ABHORRENCE IN IT AND PERFORMING OF ABLUTION IMMEDIATELY (AFTER THAT) IS NOT ESSENTIAL

Book 3, Number 0725:

    Ibn 'Abbas reported: The Apostle of Allah (may peace be upon him) came out of the privy, and he was presented with some food, and the people reminded him about ablution, but he said: Am I to say prayer that I should perform ablution ?

Book 3, Number 0726:

    Ibn 'Abbas reported: We were with the Apostle of Allah (may peace be upon him) and he had come out of the privy. Food was presented to him. It was said to him (by the Companions around him) : Wouldn't you perform ablution? Upon this he said: Why, am I to say prayer that I should perform ablution ?

Book 3, Number 0727:

    Ibn 'Abbas reported: The Messenger of Allah (may peace be upon him) went to the privy and when he came back, he was presented with food. It was said to him; Messenger of Allah, wouldn't you perform ablution. He said : Why, am I to say prayer?

Book 3, Number 0728:

    Ibn Abbas, reported: The Apostle of Allah (may peace be upon him) came out of the privy after relieving himself, and food was brought to him and he took it, and did not touch water. In another narration transmitted by Sa'id b. al-Huwairith it is like this: It was said to the Apostle of Allah (may peace be upon him) You have not performed ablution. He said: I do not intend to say prayer that I should perform ablution.

Chapter 31 : WHAT SHOULD BE UTIERED WHILE ENTERING THE PRIVY?

Book 3, Number 0729:

    Anas reported: When the Messenger of Allah (may peace be upon him) entered the privy, and in the hadith transmitted by Hushaim (the words are): When the Messenger of Allah (may peace be upon him) entered the lavatory, be used to say: O Allah, I seek refuge in Thee from wicked and noxious things.

Book 3, Number 0730:

    This hadith is also transmitted by 'Abd al-'Aziz with the same chain of transmitters, and the words are: I seek refuge with Allah from the wicked and noxious things.

Chapter 32 : ABLUTION DOES NOT BREAK BY DOZING IN A SITTING POSTURE

Book 3, Number 0731:

    Anas reported: (The people) stood up for prayer and the Messenger of Allah (may peace be upon him) was whispering to a man, and in the narration of 'Abd al-Warith (the words are): The Apostle of Allah (may peace be upon him) was having a private conversation with a man, and did not start the prayer till the people dozed off.

Book 3, Number 0732:

    Anas b. Malik reported: (The people) stood up for prayer and the Apostle of Allah (may peace be upon him) was talking in whispers with a man, and he did not discontinue the conversation till his Companions dozed off; he then came and led the prayer.

Book 3, Number 0733:

    Qatida reported: I heard Anas as saying that the Companion of the Messenger of Allah (may peace be upon him) dozed off and then offered prayer and did not perform ablution. He (the narrator) said: I asked him if he had actually heard it from Anas. He said: By Allah. yes.

Book 3, Number 0734:

    Anas reported: (The people) stood up for the night prayer when a man spoke forth: I need to say something. The Apostle of Allah (may peace be upon him) entered into secret conversation with him, till the people dozed off or some of the people (dozed off), and then they said the prayer.


BOOK 4: The Book of Prayers (Kitab Al-Salat)(Part I)

KITAB AL-SALAT
(THE BOOK OF PRAYERS)

Back
INTRODUCTION

    Prayer is the soul of religion. Where there is no prayer , there can be no purification of the soul. The non-praying man is rightly considered to be a soulless man. Take prayer out of the world, and it is all over with religion because it is with prayer that man has the consciousness of God and selfless love for humanity and inner sense of piety.Prayer is, therefore, the first, the highest, and the most solemn phenomenon and manifestation of religion.

    The way in which prayer is offered and the words which are recited in it explain the true nature of religion of which it is the expression of man's contact with the Lord.

    Prayer in Islam gives in a nutshell the teachings of Islam. The very first thing which comes into prominence in Islamic prayer is that it is accompanied by bodily movements. It implies that Islam lifts not only the soul to the spiritual height, but also illuminates the body of man with the light of God-consciousness.It aims at purifying both body and soul, for it finds no cleavage between them.Islam does not regard body and soul as two different entities opposed to each other, or body as the prison of the soul from which It yearns to secure freedom in order to soar to heavenly heights. "The soul is an organ of the body which exploits it for physiological purposes, or body is an instrument of the soul" (Iqbal, Reconstruction of Religious Thought in Islam, p 105), and thus both need spiritual enlightenment.

    Secondly, Islamic prayer does not aim at such a spiritual contact with God in which the world and self are absolutely denied, in which human personality is dissolved, disappears and is absorbed in the Infinite Lord.Islam does not favour such a meditation and absorption in which man ceases to be conscious of his own self and feels himself to be perfectly identified with the Infinite, and claims in a mood of ecstasy: My "I" has become God, or rather he is God. Islam wants to inculcate the consciousness of the indwelling of the light of God in body and soul but does allow him to transport himself in the realm of lnfinity. It impresses upon his mind that he is the humble servant of the Great and Glorious Lord and his spiritual development and religious piety lies in sincere and willing obedience to Allah.The very first step towards the achievement of this objective is that man should have a clear consciousness of his own finiteness and Infiniteness of the Lord, and clearly visualise and feel that he is created as a human being by the Creator and Master of the universe, and he cannot, therefore, become demi-god or god.His success lies in proving himself by his outlook and behaviour that he is the true and loyal servant of his Great Master.Islamic prayer is, therefore, the symbol of humble reverence before the Majesty of the Glorious Lord.

Chapter I:THE BEGINNING OF ADHAN

Book 4, Number 0735:

    Ibn Umar reported: When the Muslims came to Medina, they gathered and sought to know the time of prayer but no one summoned them.One day they discussed the matter, and some of them said: Use something like the bell of the Christians and some of them said: Use horn like that of the Jews.Umar said: Why may not a be appointed who should call (people) to prayer?The Messenger of Allah (may peace be upon him) said: O Bilal, get up and summon (the people) to prayer.

Book 4, Number 0736:

    Anas reported: Bilal was commanded (by the Apostle of Allah) to repeat (the phrases of) Adhan twice and once in Iqama. The narrator said: I made a men- tion of it before Ayyub who said : Except for saying: Qamat-1s-Salat [the time for prayer has come].

Book 4, Number 0737:

    Anas b. Malik reported: They (the Companions) discussed that they should know the timings of prayer by means of something recognized by all.Some of them said that fire should be lighted or a bell should be rung.But Bilal was ordered to repeat the phrases twice in Adhan, and once in Iqama.

Book 4, Number 0738:

    This hadith is transmitted by Khalid Hadhdha with the same chain of transmitters (and the words are): When the majority of the people discussed they should know, like the hadith narrated by al-Thaqafi (mentioned above) except for the words: "They (the people) should kindle fire."

Book 4, Number 0739:

    Anas reported: Bilal was commanded (by the Holy Prophet) to repeat the phrases twice in Adhan, and once in lqama.

Chapter 2 :HOW ADHAN IS TO BE PRONOUNCED

Book 4, Number 0740:

    Abu Mahdhura said that the Apostle of Allah (may peace be upon him) taught him Adhan like this: Allah is the Greatest, Allah is the Greatest; I testify that there is no god but Allah, I testify that there is no god but Allah ; I testify that Muhammad Is the Messenger of Allah, I testify that Muhammad is the Messenger of Allah, and it should be again repeated : I testify that there is no god but Allah, I testify that there is no god but Allah; I testify that Muhammad Is the Messenger of Allah, I testify that Muhammad is the Messenger of Allah.Come to the prayer (twice).Come to the prayer (twice).Ishaq added: Allah is the Greatest, Allah is the Greatest ; there Is no god but Allah.

Chapter 3 :THERE CAN BE TWO PRONOUNCERS OF ADHAN FOR ONE MOSQUE

Book 4, Number 0741:

    Ibn Umar reported: The Messenger of Allah (may peace be upon him) had two Mu'adhdhins, Bilal and 'Abdullah b. Umm Maktum, who (latter) was blind.

Book 4, Number 0742:

    This hadith has been narrated on the authority of 'A'isha by another chain of transmitters.

Book 4, Number 0743:

    A'isha reported: Ibn Umm Maktum used to pronounce Adhan at the behest of the Messenger of Allah (may peace be upon him) (despite the fact) that he was blind.

Book 4, Number 0744:

    A hadith like this has been transmitted by Hisham.

Chapter 4 : THE HOLY PROPHET REFRAINED FROM ATTACKING PEOPLE LIVING IN DAR AL-KUFR ON HEARING ADHAN FROM THEM

Book 4, Number 0745:

    Anas b. Malik reported: The Messenger of Allah (may peace be upon him) used to attack the enemy when it was dawn. He would listen to the Adhan ; so if he heard an Adhan, he stopped, otherwise made an attack.Once on hearing a man say: Allah is the Greatest, Allah is the Greatest, the Messenger of Allah (may peace be upon him) remarked: He is following al-Fitra (al-Islam).Then hearing him say: I testify that there is no god but Allah. there is no god but Allah, the Messenger of Allah (may peace be upon him) said: You have come out of the Fire (of Hell).They looked at him and found that he was a goatherd.

Chapter 5 : HE WHO HEARS THE ADHAN SHOULD RESPOND LIKE IT, INVOKE BLESSINGS UPON THE APOSTLE (MAY PEACE BE UPON HIM)AND THEN BEG FOR HIM THE WASILA

Book 4, Number 0746:

    Abu Sa'id al-Khudri reported: When you hear the call (to prayer), repeat what the Mu'adhdhin pronounces.

Book 4, Number 0747:

    'Abdullah b. Amr b. al-As reported Allah's Messenger (may peace be upon him) as saying : When you hear the Mu'adhdhin, repeat what he says, then invoke a blessing on me, for everyone who invokes a blessing on me will receive ten blessings from Allah; then beg from Allah al-Wasila for me, which is a rank in Paradise fitting for only one of Allah's servants, and I hope that I may be that one.If anyone who asks that I be given the Wasila, he will be assured of my intercession.

Book 4, Number 0748:

    'Umar b. al-Khattab reported: The Messenger of Allah (may peace be upon him) said: When the Mu'adhdhin says: Allah is the Greatest, Allah is the Greatest, and one of you should make this response: Allah is the Greatest, Allah is the Greatest; (and when the Mu'adhdhin) says: I testify that there is no god but Allah, one should respond: I testify that there is no god but Allah, and when he says: I testify that Muhammad is the Messenger of Allah, one should make a response: I testify that Muhammad is Allah's Messenger.When he (the Mu'adhdhin) says: Come to prayer, one should make a response: There is no might and no power except with Allah.When he (the Mu'adhdhin) says: Come to salvation, one should respond: There is no might and no power except with Allah, and when he (the Mu'adhdhin) says: Allah is the Greatest, Allah is the Greatest, then make a response: Allah is the Greatest, Allah is the Greatest. When he (the Mu'adhdhin) says: There is no god but Allah, and he who makes a re- sponse from the heart: There is no god but Allah, he will enter Paradise.

Book 4, Number 0749:

    Sa'd b. Abu Waqqas reported: The Messenger of Allah (may peace be upon him) said: If anyone says on hearing the Mu'adhdhin : I testify that there is no god but Allah alone.Who has no partner, and that Muhammad is His servant and His Messenger, (and that) I am satisfied with Allah as my Lord, with Muhammad as Messenger. and with Islam as din (code of life), his sins would be forgiven.In the narration transmitted by Ibn Rumh the words are: "He who said on hearing the Mu'adhdhin and verity I testify."' Qutaiba has not mentioned his words: "And I."

Chapter 6 :THE EXCELLENCE OF ADHAN AND RUNNING AWAY OF THE SATAN ON HEARING IT

Book 4, Number 0750:

    Yahya narrated it on the authority of his uncle that he had been sitting in the company of Mu'awiya b. Abu Sufyan when the Mu'adhdhin called (Muslims) to prayer. Mu'awiya said: I heard the Messenger of Allah (may peace be upon him) saying The Mu'adhdhins will have the longest necks on the Day of Resurrection.

Book 4, Number 0751:

    Abu Sufyan reported it on the authority of Jabir that he had heard the Apostle of Allah (may peace be upon him) say : When Satan hears the call to prayer, he runs away to a distance like that of Rauha.Sulaimin said: I asked him about Rauha.He replied : It is at a distance of thirty-six miles from Medina.

Book 4, Number 0752:

    Abu Mu'awiya narrated it on the authority of A'mash with the same chain of transmitters.

Book 4, Number 0753:

    AbuHuraira reported the Messenger of Allah (may peace be upon him) as saying: When Satan hears the call to prayer, he turns back and breaks the wind so as not to bear the call being made, but when the call is finished he turns round and distracts (the minds of those who pray), and when he bears the Iqama he again runs away so as not to hear its voice and when it subsides, he comes back and distracts (the minds of those who stand for prayer).

Book 4, Number 0754:

    Abu Huraira reported: The Messenger of Allah (may peace be upon him) said: When the Mu'adhdhin calls to prayer, Satan runs back vehemently.

Book 4, Number 0755:

    Suhail reported that his father sent him to Banu Haritha along with a boy or a man. Someone called him by his name from an enclosure. He (thenarrator) said: The person with me looked towards the enclosure, but saw nothing. I made a mention of that to my father.He said: If I knew that you would meet such a situation I would have never sent you (there), but (bear in wind) whenever you hear such a call (from the evil spirits) pronounce the Adhan. for I have heard Abu Huraira say that the Messenger of Allah (may peace be upbn him) said: Whenever Adhan is proclaimed, Satan runs back vehemently.

Book 4, Number 0756:

    Abu Huraira reported: The Apostle (may peace be upon him) said When the call to prayer is made, Satan runs back and breaks wind so as not to hear the call being made, and when the call is finished. he turns round.When Iqama is proclaimed he turns his back, and when it is finished he turns round to distract a man, saying: Re- member such and such; remember such and such, referring to something the man did not have in his mind, with the result that he does not know how much he has prayed.

Book 4, Number 0757:

    A hadith like it has been narrated by Abu Huraira but for these words : "He (the man saying the prayer) does not know how much he has prayed.

Chapter 7 :THE DESIRABILITY OF RAISING THE HANDS APPOSITE THE SHOULDERS AT THE TIME OF BEGINNING THE PRAYER AND AT THE TIME OF BOWING AND AT THE TIME OF RETURNING TO THE ERECT POSITION AFTER BOWING

Book 4, Number 0758:

    Salim narrated it on the authority of his father who reported: I saw the Messenger of Allah (may peace be upon him) raising his hands apposite the shoulders at the time of beginning the prayer and before bowing down and after coming back to the position after bowing. but he did not raise them between two prostrations.

Book 4, Number 0759:

    Ibn Umar reported that the Messenger of Allah (may peace be upon him), when he stood up for prayer, used to raise his hands apposite the shoulders and then recited takbir (Allah-o-Akbar), and when he was about to bow he again did like it and when he raised himself from the ruku' (bowing posture) he again did like it, but he did not do it at the time of raising his head from prostration.

Book 4, Number 0760:

    This hadith has been transmitted with the same chain of transmitters by al. Zuhri as narrated by Ibn Juraij (who) said . When the Messenger of Allah (may peace be upon him) stood up for prayer, he raised hands (to the height) apposite the shoulders and then recited takbir.

Book 4, Number 0761:

    Abu Qilaba reported that he saw Malik b. Huwairith raising his hands at the beginning of prayer and raising his hands before kneeling down, and raising his hands after lifting his head from the state of kneeling, and he narrated that the Messenger of Allah (may peace be upon him) used to do like this.

Book 4, Number 0762:

    Malik b. Huwairith reported: The Messenger of Allah (may peace be upon him) raised his hands apposite his ears at the time of reciting the takbir (i.e. at the time of beginning the prayer) and then again raised his hands apposite the ears at the time of bowing and when he lifted his head after bowing he said: Allah listened to him who praised Him, and did like it (raised his hands up to the ears).

Book 4, Number 0763:

    This hadith has been transmitted by Qatada with the same chain of trans. mitters that he saw the Apostle of Allah (may peace be upon him) doing like this (i.e. raising his hands) till they were apposite the lobes of cars.

Chapter 8 :THE RECITING OF TAKBIR AT THE TIME OF BOWING AND RISING IN PRAYER EXCEPT RISING AFTER RUKU, WHEN IT IS SAID: ALLAH LISTENED TO HIM WHO PRAISED HIM

Book 4, Number 0764:

    Abu Salama reported: Abu Huraira led prayer for them and recited takbir when he bent and raised himself (in ruku' and sujud) and after completing (the prayer) he said: By Allah I say prayer which has the best resemblance with the prayer of the Holy Prophet (may peace be upon him) amongst you.

Book 4, Number 0765:

    Abu Huraira reported: When the Messenger of Allah (may peace be upon him) got up for prayer, he would say the takbir (Allah-o-Akbar) when standing, then say the takbir when bowing. then say: "Allah listened to him who praised him," when coming to the erect position after bowing, then say while standing: "To Thee, our Lord, be the praise", then recite the takbir when getting down for prostration, then say the takbir on raising his head, then say the takbir on prostrating himself, then say the takbir on raising his head.He would do that throughout the whole prayer till he would complete it, and he would say the takbir when he would get up at the end of two rak'as after adopting the sitting posture.Abu Huraira said: My prayer has the best resemblance amongst you with the prayer of the Messenger of Allah (may peace be upon him).

Book 4, Number 0766:

    Ibn al-Harith reported: He had heard Abu Huraira say: The Messenger of Allah (may peace be upon him) recited takbir on standing for prayer, and the rest of the hadith is like that transmitted by Ibn Juraij (recorded above), but he did not mention Abu Huraira as saying: "My prayer has the best resemblance amongst you with the prayer of the Messenger of Allah (may peace be upon him)."

Book 4, Number 0767:

    Abu Salama b. 'Abd al-Rahman reported.. When Marwan appointed Abu Huraira as his deputy in Medina, he recited takbir whenever he got up for obligatory prayer, and the rest of the hadith is the same as transmitted by Ibn Juraij (but with the addition of these words): On completing the prayer with salutation, and he turned to the people in the mosque and said....

Book 4, Number 0768:

    Abu Salama reported that Abu Huraira recited takbir in prayer on all occasions of rising and kneeling.We said: O Abu Huraira, what is this takbir?He said: Verily it is the prayer of the Messenger of Allah (may peace be upon him).

Book 4, Number 0769:

    Suhail reported on the authority of his father that Abu Huraira used to recite takbir on all occasions of rising and bending (in prayer) and narrated that the Messenger of Allah (may peace be upon him) used to do like that.

Book 4, Number 0770:

    Mutarrif reported: I and 'Imran b. Husain said prayer behind 'Ali b. Abu, Talib.He recited takbir when he prostrated, and he recited takbir when he raised his head and he recited takbir while rising up (from the sitting position at the end of two rak'ahs).When we had finished our prayer, 'Imran caught hold of my hand and said: He (Hadrat Ali) has led prayer like Muhammad (may peace be upon him) or he said: He in fact recalled to my mind the prayer of Muhammad (may peace be upon him.)

Chapter 9 :THE RECITING OF AL-FATIHA IN EVERY RAK'AH OF PRAYER IS OBLIGATORY

Book 4, Number 0771:

    'Ubada b. as-Samit reported from the Apostle of Allah (may peace be upon him ): He who does not recite Fatihat al-Kitab is not credited with having observed the prayer.

Book 4, Number 0772:

    Ubada b. as-Samit reported : The Messenger of Allah (may peace be upon him) said: He who does not recite Umm al-Qur'an is not credited with having observed the prayer.

Book 4, Number 0773:

    Mahmud b. al-Rabi', on whose face the Messenger of Allah (may peace be upon him) squirted water from the well, reported on the authority of 'Ubada b. as- Samit that the Messenger of Allah (may peace be upon him) said : He who does not recite Umm al-Qur'an is not credited with having observed prayer.

Book 4, Number 0774:

    This hadith has also been transmitted by Ma'mar from al-Zuhri with the same chain of transmitters with the addition of these words : "and something more".

Book 4, Number 0775:

    Abu Huraira reported : The Apostle of Allah (may peace be upon him) said: If anyone observes prayer in which he does not recite Umm al-Qur'an, It is deficient [he said this three times] and not complete.It was said to Abu Huraira: At times we are behind the Imam.He said: Recite it inwardly, for he had heard the Messenger of Allah (may peace be upon him) declare that Allah the Exalted had said : I have divided the prayer into two halves between Me and My servant, and My servant will receive what he asks.When the servant says: Praise be to Allah, the Lord of the universe, Allah the Most High says: My servant has praised Me.And when he (the servant) says: The Most Compassionate, the Merciful, Allah the Most High says: My servant has lauded Me.And when he (the servant) says: Master of the Day of judg- ment, He remarks: My servant has glorified Me. and sometimes He would say: My servant entrusted (his affairs) to Me.And when he (the worshipper) says: Thee do we worship and of Thee do we ask help, He (Allah) says: This is between Me and My servant, and My servant will receive what he asks for.Then, when he (the worshipper) says: Guide us to the straight path, the path of those to whom Thou hast been Gracious not of those who have incurred Thy displeasure, nor of those who have gone astray, He (Allah) says: This is for My servant, and My servant will receive what he asks for.Sufyan said: 'Ala b. 'Abd al-Rahman b. Ya'qub narrated it to me when I went to him and he was confined to his home on account of illness, and I asked him about it.

Book 4, Number 0776:

    It is naratted on the authority of Abu Huraira that he had heard the Messenger of Allah (may peace be upon him) say: He who observed prayer but he did not recite the Umm al-Qur'an in it, and the rest of the hadith is the same as transmitted by Sufyan, and in this hadith the words are: "Allah the Most High said: the prayer is divided into two halves between Me and My servant. The half of it is for Me and the half of it is for My servant."

Book 4, Number 0777:

    Abu Huraira reported: The Messenger of Allah (may peace be upon him) said : He who said his prayer, but did not recite the opening chapter of al-Kitab, his prayer is incomplete.He repeated it thrice.

Book 4, Number 0778:

    Abu Huraira reported: The Messenger of Allah (may peace be upon him) said : One is not credited with having observed the prayer without the recitation (of al-Fatiha).So said Abu Huraira: (The prayer in which) the Messenger of Allah (may peace be upon him) recited in a loud voice, we also recited that loudly for you (and the prayer in which) he recited inwardly we also recited inwardly for you (to give you a practical example of the prayer of the Holy Prophet).

Book 4, Number 0779:

    'Ata' narrated on the authority of Abu Huraira who said that one should recite (al-Fatiha) in every (rak'ah of) prayer.What we heard (i.e. recitation) from the Messenger of Allah (may peace be upon him), we made you listen to that.And that which he (recited) inwardly, we (recited) inwardly for you.A person said to him: If I add nothing to the (recitation) of the Umm al Qur'an (Surat al-Fatiha), would it make the prayer incomplete?He (AbuHuraira) said: If you add to that (if you recite some of verses of the Qur'an along with Surat at-Fatiha) that is better for you.But if you are contented with it (Surat al-Fatiha) only, it is sufficient for you.

Book 4, Number 0780:

    'Ata' reported it on the authority of Abu Huraira who said: Recitation (of Surat al-Fatiha) in every (rak'ah) of prayer in essential. (The recitation) that we listened to from the Apostle of Allah (may peace be upon him) we made you listen to it. And that which he recited inwardly to us, we recited it inwardly for you.And he who recites Umm al-Qur'an, it is enough for him (to complete the prayer), and he who adds to it (recites some other verses of the Holy Qur'an along with Surat al-Fatiha), it is preferable for him.

Book 4, Number 0781:

    Abu Huraira reported: The Messenger of Allah (may peace be upon him) entered the mosque and a person also entered therein and offered prayer, and then came and paid salutation to the Messenger of Allah (may peace be upon him).The Mes- senger of Allah (may peace be upon him) returned his salutation and said:Go back and pray, for you have not offered the prayer.He again prayed as he had prayed before, and came to the Apostle of Allah (may peace be upon. him) and saluted him.The Messenger of Allah (may peace be upon him) returned the salutation and said: Go back and say prayer, for you have not offered the prayer.This (act of repeating the prayer) was done three times.Upon this the person said : By Him Who hast sent you with Truth, whatever better I can do than this, please teach me.He (the Holy Prophet) said: When you get up to pray, recite takbir, and then recite whatever you conveniently can from the Qur'an, then bow down and remain quietly in that position, then raise your- self and stand erect ; then prostrate yourself and remain quietly in that attitude; then raise yourself and sit quietly ; and do that throughout all your prayers.

Book 4, Number 0782:

    Abu Huraira reported: A person entered the mosque and said prayer while the Messenger of Allah (may peace be upon him) was sitting in a nook (of the mosque), and the rest of the hadith is the same as mentioned above, but with this addition: "When you get up to pray, perform the ablution completely, and then turn towards the Qibla and recite takbir (Allah o Akbar =Allah is the Most Great)."

Chapter 10 : THE ONE LED IN PRAYER IS FORBIDDEN TO RECITE LOUDLY BEHIND THE imam

Book 4, Number 0783:

    lmrin b. Husain reported: The Messenger of Allah (may peace beupon him) led us In Zuhr or 'Asr prayer (noon or the afternoon prayer). (On concluding it) he said: Who recited behind me (the verses): Sabbih Isma Rabbik al-a'la (Glorify the name of thy Lord, the Most High)?There upon a person said: It was I, but I in- tended nothing but goodness.I felt that some one of you was disputing with me in it (or he was taking out from my tongue what I was reciting), said the Holy Prophet (may peace be upon him).

Book 4, Number 0784:

    'Imran b. Husain reported: The Messenger of Allah (may peace be upon him) observed the Zuhr prayer and a person recited Sabbih Isma Rabbik al-a'la (Glorify the name of thy Lord, the Most High) behind him.When he (the Holy Pro- phet) concluded the prayer he said: Who amongst you recited (the above-mentioned verse) or who amongst you was the reciter?A person said: It was I. Upon this he (the Holy Prophet) observed: I thought as if someone amongst you was disputing with me (in what I was reciting).

Book 4, Number 0785:

    This hadith has been narrated by Qatada with the same chain of transmitters that the Messenger of Allah (may peace be upon him) observed Zuhr prayer and said: I felt that someone amongst you was disputing with me (in what I was reciting).

Chapter 11 :ARGUMENT OF THOSE WHO SAY THAT HE (THE HOLY PROPHET) DID NOT RECITE BISMILLAH (IN THE NAME OF ALLAH) LOUDLY

Book 4, Number 0786:

    Anas reported: I observed prayer along with the Messenger of Allah (may peace be upon him) and with Abu Bakr, Umar and Uthman (may Allah be pleased with all of them), but I never heard any one of them reciting Bismillah-ir-Rahman-ir-Rahim loudly.

Book 4, Number 0787:

    Shu'ba reported it with the same chain of transmitters. with she addition of these words: "I said to Qatada: Did you hear it from Anas?He replied in the affir- mative and added: We had inquired of him about it."

Book 4, Number 0788:

    'Abda reported: 'Umar b. al-Khattab used to recite loudly these words: Subhanak Allahumma wa bi hamdika wa tabarakasmuka wa ta'ala jadduka wa la ilaha ghairuka [Glory to Thee, 0 Allah, and Thine is the Praise, and Blessed is Thy Name. and Exalted is Thy Majesty. and there is no other object of worship beside Thee]. Qatada informed in writing that Anas b. Malik had narrated to him: I observed prayer behind the Apostle of Allah (may peace be upon him) and Abu Bakr and Umar and 'Uthman.They started (loud recitation) with: AI-hamdu lillahi Rabb al-'A1amin [All Praise is due to Allah, the Lord of the worlds] and did not recite Bismillah ir- Rahman-ir-Rahim (loudly) at the beginning of the recitation or at the end of it.

Book 4, Number 0789:

    It is reported on the authority of Abu Talha that he had heard Anas b. Malik narrating this.

Chapter 12 :ARGUMENT OF THOSE WHO ASSERT THAT BISMILLAH IS A PART OF EVERY SURA EXCEPT SURA TAUBA

Book 4, Number 0790:

    Anas reported: One day the Messenger of Allah (may peace be upon him) was sitting amongst us that he dozed off.He then raised his head smilingly.We said: What makes you smile.Messenger of Allah?He said: A Sura has just been revealed to me, and then recited: In the name of Allah, the Compassionate, the Merciful.Verily We have given thee Kauthar (fount of abundance).Therefore turn to thy Lord for prayer and offer sacrifice, and surely thy enemy is cut off (from the good). Then he (the Holy Prophet) said : Do you know what Kauthar is?We said: Allah and His Messenger know best. The Holy Prophet (may peace be upon him) said : It (Kauthar) is a canal which my Lord, the Exalted and Glorious has promised me, and there is an abundance of good in it.It is a cistern and my people would come to it on the Day of Resurrection, and tumblers there would be equal to the number of stars.A servant would be turned away from (among the people gathered there).Upon this I would say: My Lord, he is one of my people, and He (the Lord) would say: You do not know that he innovated new things (in Islam) after you.Ibn Hujr made this addition in the hadith : "He (the Holy Prophet) was sitting amongst us in the mosque, and He (Allah) said : (You don't know) what he innovated after you"

Book 4, Number 0791:

    Mukhtar b. Fulful reported that he had heard Anas b. Malik say that the Messenger of Allah (may peace be upon him) dozed off, and the rest of the hadith is the same as transmitted by Mus-hir except for the words that he (the Holy Prophet) said: It (Kauthar) is a canal which my Lord the Exalted and the Glorious has promised me in Paradise.There is a tank over it, but he made no mention of the tumblers like the number of the stars.

Chapter 13 :THE PLACING OF THE RIGHT HAND OVER THE LEFT HAND AFTER THE FIRST TAKBIR IN PRAYER (TAKBIR-I-TAHRIMA) BELOW THE CHEST AND ABOVE THE NAVEL AND THEN PLACING THEM APPOSITE THE SHOULDERS IN PROSTRATION

Book 4, Number 0792:

    Wa'il b. Hujr reported : He saw the Apostle of Allah (may peace be upon him) raising his hands at the time of beginning the prayer and reciting takbir, and according to Hammam (the narrator), the hands were lifted opposite to ears.He (the Holy Prophet) then wrapped his hands in his cloth and placed his right hand over his left hand.And when he was about to bow down, he brought out his hands from the cloth, and then lifted them, and then recited takbir and bowed down, and when (he came back to the erect position) he recited: "Allah listened to him who praised Him." And when prostrates. he prostrated between the two palms.

Chapter 14 : THE TASHAHHUD IN PRAYER

Book 4, Number 0793:

    'Abdullah (b.Mas'ud) said: While observing prayer behind the Messenger of Allah (may peace be upon him) we used to recite: Peace be upon Allah, peace be upon so and so.One day the Messenger of Allah (may peace be upon him) said to us: Verily Allah is Himself Peace.When any one of you sits during the prayer. he should say: All services rendered by words, by acts of worship, and all good things are due to Allah.Peace be upon you, 0 Prophet, and Allah's mercy and blessings.Peace be upon us and upon Allah's upright servants, for when he says this it reaches every upright servant in heaven and earth (and say further): I testify that there is no god but Allah and I testify that Muhammad is His servant and Messenger.Then he may choose any supplication which pleases him and offer it.

Book 4, Number 0794:

    Shu'ba has narrated this on the authority of Mansur with the same chain of transmitters, but he made no mention of this: "Then he may choose any supplication which pleases him."

Book 4, Number 0795:

    This hadith has been narrated on the authority of Mansur with the same chain of transmitters and he made a mention of this: "Then he may choose any supplication which pleases him or which he likes."

Book 4, Number 0796:

    Abdullah b. Mas'ud reported: We were sitting with the Apostle (may peace be upon him) in prayer, and the rest of the hadith is the same as narrated by Mansur He (also said) : After (reciting tashahud) he may choose any prayer.

Book 4, Number 0797:

    Ibn Mas'ud is reported to have said: The Messenger of Allah (may peace be upon him) taught me tashahhud taking my hand within his palms, in the same way as he taught me a Sura of the Qur'an, and he narrated it as narrated above.

Book 4, Number 0798:

    Ibn 'Abbas reported : The Messenger of Allah (may peace be upon him) used to teach us tashahbud just as he used to teach us a Sura of the Qur'an, and he would say: All services rendered by.,words, acts of worship. and all good thirgs are due to Allah.Peace be upon you, 0 Prophet. and Allah's mercy and blessings.Peace be upon us and upon Allah's upright servants.I testify that there is no god but Allah, and I testify that Muhammad is the Messenger of Allah.In the narration of Ibn Rumb (the words are): "As he would teach us the Qur'an."

Book 4, Number 0799:

    Tawus narrated it on the authority of Ibn 'Abbas that he said: The Messenger of Allah (may peace be upon him) used to teach us tashahhud as he would teach us a Sura of the Qur'an.

Book 4, Number 0800:

    Hattan b. 'Abdullah al-Raqiishi reported: I observed prayer with Abu Musu al-Ash'ari and when he was in the qa'dah, one among the people said: The prayer has been made obligatory along with piety and Zakat.He (the narrator) said: When Abu Musa had finished the prayer after salutation he tuined (towards the people) and said : Who amongst you said such and such a thing ? A hush fell on the people.He again said.. Who amongst you has said such and such a thing ? A hush fell on the people.He (Abu Musa) said : Hattan, It is perhaps you that have uttered it.He (Hattan) said No. I have not uttered it.I was afraid that you might be annoyed with me on account of this.A person amongst the people said: It was I who said it, and In this I intended nothing but good.Abu Musa said: Don't you know what you have to recite in your prayers?Verily the Messenger of Allah (may peace be upon him) addressed us and explained to us all Its aspects and taught us how to observe prayer (properly).He (the Holy Prophet) said: When you pray make your rows straight and let anyone amongst you act as your Imim.Recite the takbir when he recites it and when be recites : Not of those with whom Thou art angry. nor of those who go astray, say: Amin.Allah would respond you.And when he (the Imim) recites the takbir, you may also recite the takbir, for the Imam bows before you and raises himself before you.Then the Messenger of Allah (may peace be upon him) said : The one is equivalent to the other.And when he says: Allah listens to him who praises Him, you should say: 0 Allah, our.Lord, to Thee be the praise, for Allah, the Exalted and Glorious, has vouchsafed (us) through the tongue of His Apostle (may peace be upon him) that Allah listens to him who praises Him.And when he (the Imim) recites the takbir and prostrates, you should also recite the takbir and prostrate, for the Imim prostrates before you and raises himself before you.The Messenger' of Allah (may peace be upon him) said: The one is equi- valent to the other.And when he (the Imim) sits for Qa'da (for tashahhud) the first words of every one amongst you should be: All services rendered by words, acts of worship and all good things are due to Allah.Peace be upon you, 0 Apostle, and Allah's mercy and blessings.Peace be upon us and upon the upright servants of Allah. I testify that there is no god but Allah, and I testify that Mubammad is His servant and His Messenger.

Book 4, Number 0801:

    Qatida has narrated a badith like this with another chain of transmitters. In the badith transmitted by Jarir on the authority of Sulaiman, Qatida's further words are: When (the Qur'in) is recited (in prayer), you should observe silence, and (the following words are) not found in the hadith narrated by anyone except by Abu Kamil who heard it from Abu 'Awina (and the words are): Verily Allah vouchsafed through the tongue of the Apostle of Allah (may peace be upon him) this: Allah listens to him who praises Him.Abu Ishaq (a student of Imam Muslim) said: Abu Bakr the son of Abu Nadr's sister has (critically) discussed this hadith.Imam Muslim said: Whom can you find a more authentic transmitter of badith than Sulaiman ? Abu Bakr said to him (Imam Muslim) : What about the hadith narrated by Abd Huraira, i.e. the hadith that when the Qur'in is recited (in pray er) observe silence? He (Abu Bakr again) said: Then, why.have you not included it (in your compilation) ? He (Imam Muslim) said: I have not included in this every hadith which I deem authentic; I have recorded only such ahadith on which there is an agreement (amongst the Muhaddithin apart from their being authentic).

Book 4, Number 0802:

    This hadith has been transmitted by Qatida with the same chain of transmitters (and the words are) : "Allah, the Exalted and the Glorious, commanded it through the tongue of His Apostle (may peace be upon-him) : Allah listens to him who praises Him."

Chapter 15 : BLESSINGS ON THE PROPHET (MAY PEACE BE UPON HIM) AFTER TASHAHHUD

Book 4, Number 0803:

    Abdullah b. Zaid-he who was shown the call (for prayer in a dream) narrated it on the authority of Mas'ad al-Ansiri who said: We were sitting in the company of Sa'id b. 'Ubida when the Messenger of Allah (may peace be upon him) came to us.Bashir b. S'ad said : Allah has commanded us to bless you. Messenger of Allah!But how should we bless you ? He (the narrator) said: The Messenger of Allah (may peace be upon him) kept quiet (and we were so much perturbed over his silence) that we wished we had not asked him.The Messenger of Allah (may peace be upon him) then said: (For blessing me) say: "0 Allah, bless Muhammad and the members of his household as Thou didst bless the mernbers of Ibrahim's household. Grant favours to Muhammad and the members of his household as Thou didst grant favours to the members of the household of Ibrahim in the world.Thou art indeed Praiseworthy and Glorious"; and salutation as you know.

Book 4, Number 0804:

    Ibn Abi Laila reported: Ka'b b. 'Ujra met me and said: Should I not offer you a present (and added) : The Messenger of Allah (may peace be upon him) came to us and we said: We have learnt how to invoke peace upon you; (kindly tell us) how we should bless you.He (the Holy Prophet) said: Say: "O Allah: bless Muhammad and his family as Thou didst bless the family of Ibrahim.Verily Thou art Praiseworthy and Glorious, O Allah."

Book 4, Number 0805:

    A hadith like this has been narrated by Mis'ar on the authority of al-Hakam, but in the hadith transmitted by Mis'ar these words are not found: "Should I not offer you a present ?"

Book 4, Number 0806:

    A hadith like this has been narrated by al-Hakam except that he said: "Bless Muhammad (may peace be upon him)" and he did not say: "O Allah I

Book 4, Number 0807:

    Abu Humaid as-Sa'idi reported: They (the Companions of the Holy Prophet) said : Apostle of Allah, how should we bless you ? He (the Holy Prophet) observed: Say: "O Allah! bless Muhammad, his wives and his offspring as Thou didst bless Ibrahim, and grant favours to Muhammad, and his wives and his offspring as Thou didst grant favours to the family of Ibrahim ; Thou art Praiseworthy and Glorious."

Book 4, Number 0808:

    Abu Huraira reported: The Messenger of Allah (may peace be upon him) said: He who blesses me once, Allah would bless him ten times.

Chapter 16 : THE RECITING OF TASMI' (ALLAH LISTENS TO HIM WHO PRAISES HIM), TABMID (O, OUR LORD, FOR THEE IS THE PRAISE), AND TAMIN (AMIN)

Book 4, Number 0809:

    Abu Huraira reported: The Messenger of Allah (may peace be upon him) said: When the Imam says: "Allah listens to him who praises Him." you should say: "O Allah, our Lord for Thee is the praise." for if what anyone says synchronises with what the angels say, his past sins will be forgiven.

Book 4, Number 0810:

    A hadith like this is narrated by Abd Huraira by another chain of transmitters.

Book 4, Number 0811:

    Abu Huraira reported: The Messenger of Allah (may peace be upon him) said: SayAmin when the Imam says Amin, for it anyone's utterance of Amin synchronises with that of the angels,he will be forgiven his past sins.

Book 4, Number 0812:

    Abu Huraira said: I heard from the Messenger of Allah (may peace be upon him) the hadith like one transmitted by Malik, but he made no mention of the words of Shibab.

Book 4, Number 0813:

    Abu Huraira reported: The Messenger of Allah (may peace be upon him) said: When anyone amongst you utters Amin in prayer and the angels in the sky also utter Amin, and this (utterance of the one) synchronises with (that of) the other, all his previous sins are pardoned.

Book 4, Number 0814:

    Abu Harare reported: The Messenger of Allah (may peace be upon him) said: When anyone amongst you utters Amin and the angels In the heaven also utter Amin and (the Amin) of the one synchronises with (that of) the other, all his previous sins are pardoned.

Book 4, Number 0815:

    'A hadith like this is transmitted by Ma'mar from Hammam b. Munabbih on the authority of Abu Huraira who reported it from the Apostle of Allah (may peace be upon him).

Book 4, Number 0816:

    Abu Huraira reported: The Messenger of Allah (may peace be upon him) said: When the reciter (Imam) utters: "Not of those on whom (is Thine) wrath and not the erring ones," and (the person) behind him utters Amin and his utterance synchronises with that of the dwellers of heavens, all his previous sins would be pardoned.

Chapter 17 : THE MUQTADI (FOLLOWER) SHOULD STRICTLY FOLLOW THE IMAM IN PRAYER

Book 4, Number 0817:

    Anas b. Malik reported: The Apostle of Allah (may peace be upon him) fell down from a horse and his right side was grazed.We went to him to inquire after his health when the time of prayer came.He led us in prayer in a sitting posture and we said prayer behind him sitting, and when he finished the prayer hesaid : The Imam is appointed only to be followed; so when he recites takbir, you should also recite that; when he prostrates, you should also prostrate; when he rises up, you should also rise up, and when he said"God listens to him who praises Him," you should say: "Our Lord, to Thee be the praise," and when he prays sitting, all of you should pray sitting.

Book 4, Number 0818:

    Anas b. Malik reported: The Messenger of Allah (may peace be upon him) fell down from a horse and he was grazed and he led the prayer for us sitting, and the rest of the hadith is the same.

Book 4, Number 0819:

    Anas b. Malik reported: The Messenger of Allah (may peace be upon him) fell down from a horse and his right side was grazed, and the rest of the hadith is the same with the addition of these words: "When he (the Imam) says prayer standing, you should also do so."

Book 4, Number 0820:

    Anas reported: The Messenger of Allah (may peace be upon him) rode a horse and fell down from it and his right side was grazed, and the rest of the hadith is the same, and (these words) are found in it: "When he (the Imam) says prayer in an erect posture, you should also say it in an erect posture."

Book 4, Number 0821:

    Anas b. Malik reported: The Messenger of Allah (may peace be upon him) fell down from his horse and his right side was grazed, and the rest of the hadith is the same.In this hadith there are no additions (of words) as transmitted by Yunus and Malik.

Book 4, Number 0822:

    'A'isha reported: The Messenger of Allah (may peace be upon him) fell ill and some of his Companions came to inquire after his health.The Messenger of Allah (may peace he upon him) said prayer sitting, while (his Companions) said it (behind him) standing.He (the Holy Prophet) directed them by his gesture to sit down, and they sat down (in prayer).After finishing the (prayer) lie (the Holy Prophet) said: The Imam is appointed so that be should be followed, so bow down when lie bows down, and rise rip when he rises up and say (prayer) sitting when he (the Imam) says (it) sitting.

Book 4, Number 0823:

    This hadith is narrated with the same chain of transmitters by Hisham b. 'Urwa.

Book 4, Number 0824:

    Jabir reported: The Messenger of Allah (may peace be upon him) was ill and we said prayer behind him and he was sitting. And Abu Bakr was making audible to the people his takbir.As he paid his attention towards us he saw us standing and (directed us to sit down) with a gesture.So we sat down and said our prayer with his prayer in a sitting posture.After uttering salutation he said: You were at this time about to do an act like that of the Persians and the Romans. They stand before their kings while they sit, so don't do that; follow your Imams. If they say prayer standing, you should also do so, and if they say prayer sitting, you should also say prayer sitting.

Book 4, Number 0825:

    Jabir said: The Messenger of Allah (may peace be upon him) led the prayer and Abu Bakr was behind him. When the Messenger of Allah (may peace be upon him) recited the takbir, Abu Bakr also recited (it) in order to make it audible to us.And the rest of the hadith is like one transmitted by Laith.

Book 4, Number 0826:

    Abu Huraira reported: The Messenger of Allah (may peace be upon him) said: The Imam is appointed, so that he should be followed, so don't be at variance with him.Recite takbir when he recites it; bow down when he bows down and when he says: "Allah listens to him who praises Him," say: "O Allah, our Lord, to Thee be the Praise." And when he (the Imam) prostrates, you should also prostrate, and when he says prayer sitting, you should all observe prayer sitting.

Book 4, Number 0827:

    A hadith like this has been transmitted by Hammam b. Munabbih from the Apostle of Allah (may peace be upon him) on the authority of Abu Huraira.

Book 4, Number 0828:

    Abu Huraira reported: The Messenger of Allah (may peace be upon him) while teaching us (the principles of faith), said: Do not try to go ahead of the Imam, recite takbir when he recites it. and when he says: "Nor of those who err," you should say Amin, bow down when lie bows down, and when he says: "Allah listens to him who praises Him," say: "O Allah, our Lord, to Thee be the praise".

Book 4, Number 0829:

    Abu Huraira reported from the Apostle of Allah (may peace be upon him) (a hadith) like it, except the words: "Nor of those who err, say Amin" and added: "And don't rise up ahead of him."

Book 4, Number 0830:

    Abu Huraira reported: The Messenger of Allah (may peace be upon him) said: Verily the Imam is a shield,say prayer sitting when he says prayer sitting.And when he says: "Allah listens to him who praises Him," say: "O Allah, our Lord, to Thee be the praise." and when the utterance of the people of the earth synchronises with that of the beings of heaven (angels), all the previous sins would be pardoned.

Book 4, Number 0831:

    Abu Huraira reported Allah's Messenger (may peace be upon him) saying: The Imamis appointed to be followed.So recite takbir when he recites it, and bow down when he bows down and when he utters: "Allah listens to him who praises Him," say"O Allah, our Lordfor Thee be the praise." And when he prays, standing, you should pray standing.And when he prays sitting, all of you should pray sitting.

Chapter 18 : THE IMAM IS AUTHORISED TO APPOINT ONE AS HIS DEPUTY WHEN THERE IS A VALID REASON FOR IT (FOR EXAMPLE, ILLNESS OR JOURNEY OR ANY OTHER), AND IF AN IMAM LEADS THE PRAYER SITTING AS HE CANNOT DO SO STANDING, HIS FOLLOWERS SHOULD SAY PRAYER STANDING PROVIDED THEY ARE ABLE TO DO IT AND THERE IS AN ABROGATION OF SAYING PRAYER SITTING BEHIND A SITTING IMAM

Book 4, Number 0832:

    Ubaidullah b. Abdullah reported: I visited 'A'isha and asked her to tell about the illness of the Messenger of Allah (may peace be upon him).She agreed and said: The Apostle (may peace be upon him) was seriously ill and he asked whether the people had prayed.We said: No, they are waiting for you, Messenger of Allah.He (the Holy Prophet) said: Put some water in the tub for me.We did accordingly and he (the Holy Prophet) took a bath ;and, when he was about to move with difficulty, he fainted.When he came round, he again said: Have the people said prayer?We said: No, they are waiting for you, Messenger of Allah. He (the Holy Prophet) again said: Put some water for me in the tub.We did accordingly and he took a bag, but when he was about to move with difficultyhe fainted.When he came round, he asked whether the people had prayed.We said: No, they are waiting for you, Messenger of Allah.He said: Put some water for me in the tub.We did accordingly and he took a bath and he was about to move with difficulty when he fainted.When he came roundhe said: Have the people saidprayer?We said: No, they are waiting for you, Messenger of Allah.She ('A'isha) said: The people were staying in the mosque and waiting for the Messenger of Allah (may peace be upon him) to lead the last (night) prayer.She ('A'isha) said: The Messenger of Allah (may peace be upon him) sent (instructions) to Abu Bakr to lead the people in prayer.When the messenger came, he told him (Abd Bakr): The Messenger of Allah (may peace be upon him) has ordered you to lead the people in prayer.Abu Bakr who was a man of very tenderly feelings asked Umar to lead the prayer.'Umar said: You are more entitled to that.Abu Bakr led the prayers during those days.Afterwards the Messenger of Allah (may peace be upon him) felt some relief and he went out supported by two men, one of them was al-'Abbas, to the noon prayer.Abu Bakr was leading the people in prayer.When Abu Bakr saw him. he began to withdraw, but the Apostle of Allah (may peace be upon him) told him not to withdraw.He told his two (companions) to seat him down beside him (Abu Bakr). They seated him by the side of Abu Bakr.Abu Bakr said the prayer standing while following the prayer of the Apostle (way peace be upon him) and the people Bald prayer (standing) while following the prayer of Abu Bakr.The Apostle (may peace be upon him) was seated.Ubaidullah said: I visited 'Abdullah b. 'Abbas, and said: Should I submit to you what 'A'isha had told about the illness of the Apostle (may peace be upon him)?He said: Go ahead.I submitted to him what had been transmitted by her ('A'isha).He objected to none of it, only asking whether she had named to him the man who accompanied al-'Abbas. I said: No. He said: It was 'Ali.

Book 4, Number 0833:

    'A'isha reported: It was in the house ofMaimuna that the Messenger of Allah (may peace be upon him) first fell ill. He asked permission from his wives to stay in her ('A'isha's) house during his illness. They granted him permission. She ('A'isha) narrated: He (the Holy Prophet) went out (for prayer) with his hand over al-Fadl b. 'Abbas and on the other hand there was another person and (due to weakness) his feet dragged on the earth.'Ubaidullah said: I narrated this hadith to the son of 'Abbas ('Abdullah b. 'Abbas) and he said: Do you know who the man was whose name 'A'isha did not mention? It was 'Ali.

Book 4, Number 0834:

    'A'isha, the wife of the Apostle (may peace be upon him), said: When the Messenger of Allah (may peace be upon him) fell ill and his illness became serious, he asked permission from his wives to stay in my house during his illness. They gave him permission to do so.He stepped out (of'A'isha's apartment for prayer) supported by two persons. (He was so much weak) that his feet dragged on the ground and he was being supported by 'Abbas b. 'Abd al-Muttalib and another person. 'Ubaidullah said: I informed 'Abdullah (b.'Abbas) about that which 'A'isha had said.'Abdullah b. 'Abbas said: Do you know the man whose name 'A'isha did not mention ? He said: No. Ibn 'Abbas said: It was 'Ali.

Book 4, Number 0835:

    'A'isha, the wife of the Apostle of Allah (may peace be upon him), said: I tried to dissuade the Messenger of Allah (may peace be upon him) from it (i.e. from appointing Abu Bakr as the Imam.) and my insistence upon it was not due to the fact that I entertained any apprehension in my mind that the people would not love the man who would occupy his (Prophet's) place (i.e. who would be appointed as his caliph) and I feared that the people would be superstitious about one who would occupy his place. I, therefore, desired that the Messenger of Allah (may peace be upon him) should leave Abu Bakr aside in this matter.

Book 4, Number 0836:

    'A'isha reported: When the Messenger of Allah (may peace be upon him) came to my house, he said: Ask Abu Bakr to lead people in prayer.'A'isha narrated: I said, Messenger of Allah, Abu Bakr is a man of tenderly feelings; as he recites the Qur'an, he cannot help shedding tears: so better command anyone else to lead the prayer.By Allah, there is nothing disturbing in it for me but the idea that the people may not takeevil omen with regard to one who is the first to occupy the place of the Messenger of Allah (may peace be upon him).I tried to dissuade him (the Holy Prophet) twice or thrice (from appointing my father as an Imam in prayer), but he ordered Abu Bakr to lead the people in prayer and said: You women are like those (who had) surrounded Yusuf.

Book 4, Number 0837:

    'A'isha reported: When the Messenger of Allah (may peace be upon him) was confined to bed, Bilal came to him to summon him to prayer.He (the Holy Prophet) said: Ask Abu Bakr to lead the people in prayer.She ('A'isha) reported: I said: Messenger of Allah,Abu!Bakr is a tenderhearted man,go when ]be would stand at your place (he would be so overwhelmed by feelings) that he would not be able to make the people hear anything (his recitation would not be audible to the followers in prayer).You should better order Umar (to lead the prayer).He (the Holy Prophet) said: Ask Abu Bakr to lead people in- prayer.She ('A'isha) said: I asked Hafsa to (convey) my impression to him (the Holy Prophet) that Abu Bakr was a tenderhearted man, so when he would stand at his place, he would not be able to make the people bear anything. He better order Umar.Hafsa conveyed this (message of Hadrat 'A'isha) to him (the Holy Prophet).The Messenger of Allah (may peace be upon him) said: (You are behaving) as if you are the females who had gathered around Yusuf.Order Abd Bakr to lead the people in prayer.She ('A'isha) reported: So Abu Bakr was ordered to lead the people in prayer.As the prayer began, the Messenger of Allah (may peace he upon him) felt some relief; he got up and moved supported by two persons and his feet dragged on earth (due to excessive weakness).'A'isha reported: As he (the Holy Prophet) entered the mosque.Abu Bakr perceived his (arrival).He was about to with. draw, but the Messenger of Allah (may peace be upon him) by the gesture (of This hand) told him to keep standing at his place.The Messenger of Allah (may peace be upon him) came and seated himself on the left side of Abu Bakr.She ('A'isha) reported: The Messenger of Allah (may peace be upon him) was leading people in prayer sitting.Abu Bakr was following the prayer of the Apostle (may peace be upon him) in a standing posture and the people were following the prayer of Abu Bakr.

Book 4, Number 0838:

    A'mash reported: When the Messenger of Allah (may peace be upon him) suffered from illness of which he died, and in the hadith transmitted by Ibn Mus-hir, the words are: The Messenger of Allah (may peace be upon him) was brought till he was seated by his (Abu Bakr's) side and the Apostle (may peace be upon him) led the people in prayer and Abu Bakr was making takbir audible to them, and in the hadith transmitted by 'Isa the (words are): "The Messenger of Allah (may peace be upon him) sat and led the people in prayer and Abu Bakr was by his side and he was making (takbir) audible to the people."

Book 4, Number 0839:

    'A'isha reported: The Messenger of Allah (may peace be upon him) ordered Abu Bakr that he should lead people in prayer during his illness, and he led them In prayer.'Urwa said: The Messenger of Allah (may peace be upon him) felt relief and went (to the mosque) and Abd Bakr was leading the people in prayer.When Abel Bakr saw him he began to withdraw, but the Messenger of Allah (may peace be upon him) signed him to remain where he was.The Messenger of Allah (may peace be upon him) sat opposite to Abu Bakr by his side.Abu Bakr said prayer following the prayer of the Messenger of Allah (may peace be upon him), and the people said prayer following the prayer of Abu Bakr.

Book 4, Number 0840:

    Anas b. Malik reported, Abu Bakr led them in prayer due to the illness of the Messenger of Allah (may peace be upon him) of which be died.It was a Monday and they stood in rows for prayer.The Messenger of Allah (may peace be upon him) drew aside the curtain of ('A'isha's) apartment and looked at us while he was standing, and his (Prophet's) face was (as bright) as the paper of the Holy Book. The Messenger of Allah (may peace be upon him) felt happy and smiled.And we were confounded with joy while in prayer due to the arrival (among our midst) of the Messenger of Allah (may peace be upon him), Abu Bakr stepped back upon his heels to say prayer in a row perceiving that the Messenger of Allah (may peace be upon him) had come out for prayer.The Messenger of Allah (may peace be upon him) with the help of his hand signed to them to complete their prayer.The Messenger of Allah (may peace be upon him) went back (to his apartment) and drew the curtain.He (the narrator) said: The Messenger of Allah (may peace be upon him) breathed his last on that very day.

Book 4, Number 0841:

    Anas reported: The last glance that I have had of the Messenger of Allah (may peace be upon him) (before his death) was that when he on Monday drew the curtain aside.The hadith transmitted by Salih is perfect and complete.

Book 4, Number 0842:

    This hadith is narrated on the authority of Anas b. Malik by another chain of transmitters.

Book 4, Number 0843:

    Anas reported: The Apostle of Allah (may peace be upon him) did not come to us for three days.When the prayer was about to start.Abu Bakr stepped forward (to lead the prayer), and the Apostle of Allah (may peace be upon him) lifted the curtain.When the face of the Apostle of Allah (may peace be upon him) became visible to us, we (found) that no sight was more endearing to us than the face of the Apostle of Allah (may peace be upon him) as it appeared to us.The Apostle of Allah (may peace be upon him) with the gesture of his hand directed Abu Bakr to step forward (and lead the prayer).The Apostle of Allah (may peace be upon him) then drew the curtain, and we could not see him till he died.

Book 4, Number 0844:

    Abu Musa reported: When the Messenger of Allah (may peace be upon him) became ill and illness became serious he ordered Abu Bakr to lead the people in prayer.Upon this 'A'isha said: Messenger of Allah, Abd Bakr is a man of tenderly feelings: when he would stand in your place (he would be so much overwhelmed -by grief that) he would not be able to lead the people in prayer.He (the Holy Prophet) said: You order Abu Bakr to lead the people in prayer, and added: You are like the female companions of Yusuf.So Abu Bakr led the prayer (during this period of illness) in the life of the Messenger of Allah (may peace be upon him).

Chapter 19 :IF THE IMAM ARRIVES LATE AND THERE IS NO DANGER OF AN UNPLEASANT HAPPENING, ANOTHER IMAM CAN BE APPOINTED TO LEAD THE PRAYER

Book 4, Number 0845:

    Sahl b. Sa'd al-Sa'idi reported: The Messenger of Allah (may peace be upon him) went to the tribe of Bani Amr b. Auf in order to bring reconciliation amongst (its members), and It was a time of prayer.The Mu'adhdhin came to Abu Bakr and said: Would you lead the prayer in case I recite takbir (tahrima, with which the prayer begins)?He (Abu Bakr) said : Yes.He (the narrator) said: He (Abu Bakr) started (leading) the prayer.The people were engaged in observing prayer when the Messenger of Allah (may peace be upon him) happened to come there and made his way (through the people) till he stood in a row.The people began to clap (their hands), but Abu Bakr paid no heed (to it) in prayer.When the people clapped more vigorously, he (Abu Bakr) then paid heed and saw the Messenger of Allah (may peace be upon him) there. (He was about to withdraw when) the Messenger of Allah (may peace be upon him) signed to him to keep standing at his place.Abu Bakr lifted his hands and praised Allah for what the Messenger of Allah (may peace be upon him) had commanded him and then Abu Bakr withdrew himself till he stood in the midst of the row and the Messenger of Allah (may peace be upon him) stepped forward and led the prayer. When (the prayer) was over, he (the Holy Prophet) said: 0 Abu Bakr, what prevented you from standing (at that place) as I ordered you to do?Abu Bakr said : It does not become the son of Abu Quhafa to lead prayer before the Messenger of Allah (may peace be upon him).The Messenger of Allah (may peace be upon him) said (to the people) around him : What is it that I saw you clapping so vigorously? (Behold) when anything happens in prayer, say: Subha Allah, for when you would utter it, it would attract the attention, while clapping of hands is meant for women.

Book 4, Number 0846:

    This hadith is transmitted by Sahl b. Sa'd in the same way as narrated by Malik, with the exception of these words: "Abu Bakr lifted his hands and praised Allah and retraced his (steps) till he stood in a row."

Book 4, Number 0847:

    Sahl b. Sa'd al-Sa'idi reported: The Apostle of Allah (may peace be upon him) went to Bani Amr b. 'Auf in order to bring about reconciliation amongst them. The rest of the hadith is the same but with (the addition of these words): "The Messenger of Allah (may peace be upon him) came and made his way through the rows till he came to the first row and Abu Bakr retraced his steps."

Book 4, Number 0848:

    Mughira b. Shu'ba reported that he participated In the expedition of Tabuk along with the Messenger of Allah (may peace be upon him).The Messenger of Allah (may peace be upon him) went out to answer the call of nature before the morning prayer. and I carried along with him a jar (full of water).When the Messenger of Allah (may peace be upon him) came back to me (after relieving himself). I began to pour water upon his hands out of the jar and he washed his hands three times, then washed his face three times.He then tried to tuck up the sleeves of his cloak upon his forearms but since the sleeves were tight he inserted his hands in the cloak and then brought out his forearms up to the elbow below the cloak, and then wiped over his shoes and then moved on.Mughira said: I also moved along with him till he came to the people and (he found) that they had been saying their prayer under the Imamah of 'Abd al-Rahman b. 'Auf. The Messenger of Allah (may peace be upon him) could get one rak ah out of two and said (this) last rak'ah along with the people.When Abd al-Rahman b. 'Auf pronounced the salutation, the Messenger of Allah (may peace be upon him) got up to complete the prayer.This made the Muslims terrified and most of them began to recite the glory of the Lord.When the Apostle of Allah (may peace be upon him) finished his prayer, he turned towards them and then said: You did well, or said with a sense of joy: You did the right thing that you said prayer at the appointed hour.

Book 4, Number 0849:

    This hadith is narrated by Hamza b. Mughira by another chain of trans- mitters (but with the addition of these words) : I made up my mind to hold Abd al-Rahman b. 'Auf back, but the Messenger of Allah (may peace be upon him) said: Leave him."

Chapter 20 : IF SOMETHING HAPPENS IN PRAYER, MEN SHOULD GLORIFY ALLAH AND WOMEN SHOULD CLAP HANDS

Book 4, Number 0850:

    Abu Huraira reported: The Messenger of Allah (may peace be upon him) said : Glorification of Allah is for men and clapping of hands is meant for women (if something happens in prayer). Harmala added in his narration that Ibn Shihab told him: I saw some of the scholars glorifying Allah and making a gesture.

Book 4, Number 0851:

    This hadith is narrated on the authority of Abu Huraira by another chain of transmitters.

Book 4, Number 0852:

    This hadith is transmitted by Muhammad b. Rafi', Abu'I-Razzaq.Ma'mar, Hammam on the authority of Abu Huraira with the addition of (the word) "prayer".

Chapter 21 : COMMAND TO OBSERVE PRAYER WELL,PERFECTING IT, AND DEVOTION IN IT

Book 4, Number 0853:

    Abu Huraira reported: one day the Messenger of Allah (may peace be upon him) led the prayer.Then turning (towards his Companions) he said: 0 you, the man, why don't you say your prayer well? Does the observer of prayer not see how he is performing the prayer for he performs it for himself ? By Allah, I see behind me as I see In front of me.

Book 4, Number 0854:

    Abu Huraira reported: The Messenger of Allah (may peace be upon him) said: Do you find me seeing towards the Qibla only?By Allah, your bowing and your prostrating are not hidden from my view.Verily I see them behind my back.

Book 4, Number 0855:

    Anas b. Malik reported.The Messenger of Allah (may peace be upon him) said : Perform bowing and prostration well.By Allah.I see you even if you are behind me, or he said'. (1 see you) behind my back when you bow or prostrate.

Book 4, Number 0856:

    Anas reported: The Apostle of Allah (may peace be upon him) said: Complete the bowing and prostration well.By Allah, 1 see you behind my back as to how you bow and prostrate or when you bow and prostrate.

Chapter 22 : IT IS FORBIDDEN TO BOW AND PROSTRATE AHEAD OF THE IMAM

Book 4, Number 0857:

    Anas reported: The Messenger of Allah (may peace be upon him) one day led us in the prayer. and when he completed the Prayer he turned his face towards us and said : 0 People, I am your Imam, so do not precede me in bowing and prostration and in standing and turning (faces, i.e. In pronouncing salutation), for I see you in front of me and behind me, and then said : By Him in Whose hand Is the life of Muhammad, if you could see what I see, you would have laughed little and wept much more.They said : What did you see, Messenger of Allah?He replied: (I saw) Paradise and Hell.

Book 4, Number 0858:

    This hadith is narrated by Anas with another chain of transmitters, and in the hadith transmitted by Jarir there is no mention of "turning (faces)".

Book 4, Number 0859:

    Abu Huraira reported: The Messenger of Allah (may peace be upon him) said: Does the man who lifts his head ahead of the Imam (from prostration) not fear that Allah may change his head into the head of an ass?

Book 4, Number 0860:

    Abu Huraira reported : The Messenger of Allah (may peace be upon him) said: Does the man who lifts his head before the Imam not fear that Allah may change his face into that of an ass?

Book 4, Number 0861:

    This hadith has been narrated by Abu Huraira by another chain of transmitters except for the words narrated by Rabi' b. Muslim : "Allah may make his face like the face of an ass."

Chapter 23 : IT IS FORBIDDEN TO LIFT ONE'S EYES TOWARDS THE SKY IN PRAYER

Book 4, Number 0862:

    Jabir b. Samura reported : The Messenger of Allah (may peace be upon him) said : The people who lift their eyes towards the sky in Prayer should avoid it or they would lose their eyesight.

Book 4, Number 0863:

    Abu Huraira reported: People should avoid lifting their eyes towards the sky while supplicating in prayer, otherwise their eyes would be snatched away.

Chapter 24 : THE COMMAND TO OBSERVE PRAYER WITH TRANQUILLITYAND CALMNESS AND PROHIBITION OF MAKING GESTURES WITH HANDS AND LIFTING THEMWHILE PRONOUNCING SALUTATION, ANDTHE COMPLETING OF FIRST ROWSAND JOINING TOGETHER WELL IN THEM

Book 4, Number 0864:

    Jabir b. Samura reported: The Messenger of Allah (may peace be upon him) came to us and said: How is it that I see you lifting your hands like the tails of headstrong horses? Be calm in prayer.He (the narrator) said: He then again came to us and saw us (sitting) in circles; he said: How is it that I see you in separate groups? He (the narrator) said: He again came to us and said: Why don't you draw yourselves up in rows as angels do in the presence of their Lord?We said: Messenger of Allah, bow do the angels draw themselves up in rows in the presence of their Lord?He (the Holy Prophet) said: They make the first rows complete and keep close together in the row.

Book 4, Number 0865:

    This hadith has been narrated by A'mash with the same chain of transmitters.

Book 4, Number 0866:

    Jabir b. Samura reported: When we said prayer with the Messenger of Allah (may peace be upon him), we pronounced: Peace be upon you and Mercy of Allah, peace be upon you and Mercy of Allah, and made gesture with the hand on both the sides.Upon this the Messenger of Allah (may peace be upon him said: What do you point out with your hands as if they are the tails of headstrong horses?This is enough for you that one should place one's hand on one's thigh and then pronounce salutation upon one's brother on the right side and then on the left.

Book 4, Number 0867:

    Jabir b. Samura reported: We said our prayer with the Messenger of Allah (may peace be upon him) and, while pronouncing salutations, we made gestures with our hands (indicating) "Peace be upon you, peace be upon you." The Messenger of Allah (may peace be upon him) looked towards us and said: Why is it that you make gestures with your hands like the tails of headstrong horses?When any one of you pro- nounces salutation (in prayer) he should only turn his face towards his companion and should not make a gesture with his hand.

Chapter 25 : STRAIGHTENING OF ROWS AND THE EXCELLENCE OF THE FIRST ROW AND THEN OF THE SUBSEQUENT ROWS AND COMPETING AND VYING WITH ONE ANOTHER FOR THE FIRST ROW AND PRIORITY OF THE MEN OF VIRTUES AND THEIR NEARNESS TO THE IMAM

Book 4, Number 0868:

    Abu Mas'ud reported: The Messenger of Allah (may peace he upon him) used to touch our shoulders in prayer and say: Keep straight, don't be irregular, for there would be dissension in your hearts. Let those of you who are sedate and prudent be near me, then those who are next to them, then those who are next to them. Abu Mas'ud said: Now-a-days there is much dissension amongst you.

Book 4, Number 0869:

    This hadith is narrated by Ibn Uyaina with the same chain of transmitters.

Book 4, Number 0870:

    Abdullah b. Mas'ud reported: The Messenger of Allah (may peace be upon him) said: Let those who are sedate and prudent be near me, then those who are next to them (saying it tliree tinies), and beware of the tumult of the markets.

Book 4, Number 0871:

    Anas b. Malik reported: The Messenger of Allah (may peace be upon him) said: Straighten your rows. for the straightening of a row is a part of the perfection of prayer.

Book 4, Number 0872:

    Anas b. Malik reported: The Messenger of Allah (may peace be upon him) said: Complete the rows, for I can see you behind my back.

Book 4, Number 0873:

    Hammam b. Munabbih reported: This is what was transmitted to us by Abu Huraira from the Messenger of Allah (may peace be upon him) and, while making a mention of a few ahadith, said: (The Messengerof Allah directed us thus): Establish rows in prayer, for the making of a row (straight) is one of the merits of prayer.

Book 4, Number 0874:

    Nu'man b. Bashir reported: I heard the Messenger of Allah (may peace be upon him) say: Straighten your rows, or Allah would create dissension amongst you.

Book 4, Number 0875:

    Nu'man b. Bashir reported: The Messenger of Allah (may peace-be upon him) used to straighten our rows as it lie were straightening an arrow with their help until be saw that we had learnt it from him.One day he came out, stood up (for prayer) and was about to say: Allah is the Greatest, when he saw a man, whose chest was bulging out from the row, so he said: Servants of Allah, you hint straighten your rows or Allah would create dissension amongst you.

Book 4, Number 0876:

    Abu 'Awana reported this hadith with the same chain of transmitters.

Book 4, Number 0877:

    Abu Huraira reported: The Messenger of Allah (may peace be upon him) said: If the people were to know what excellence is there in the Adhan and in the first row, and they could not (get these opportunities) except by drawing lots, they would have definitely done that.And if they were to know what excellence lies in joining the prayer in the first takbir (prayer), they would have vied with one another.And if they were to know what excellence lies in the night prayer and morning prayer, they would have definitely come even if crawling (on their knees).

Book 4, Number 0878:

    Abu Sa'id al-Khudri reported: The Messenger of Allah (may peace be upon him) saw (a tendency ) among his Companions to go to the back, so he said to them: Come forward and follow my lead, and let those who come after you follow your lead. People will continue to keep back till Allah will put them at the back.

Book 4, Number 0879:

    Abu Sa'id al-Khudri reported: The Messenger of Allah (may peace be upon him) saw people at the end of the mosque, and then the (above-mentioned hadith) was narrated.

Book 4, Number 0880:

    Abu Huraira reported: The Messenger of Allah (may peace be upon him) said: If you were to know, or if they were to know, what (excellence) lies in the first rows, there would have been drawing of lots (for filling them); and Ibn Harb said: For (occupying) the first row there would have been drawing of lots.

Book 4, Number 0881:

    Abu Huraira said: The best rows for men are the first rows, and the worst ones the last ones, and the best rows for women are the last ones and the worst ones for them are the first ones.

Book 4, Number 0882:

    This hadith is narrated by Suhail with the same chain of transmitters.

Chapter 26 : THE PRAYING WOMEN HAVE BEEN COMMANDED NOT TO PRECEDE MEN IN LIFTING THEIR HEADS FROM PROSTRATION

Book 4, Number 0883:

    Sahl b. Sa'd reported: I saw men having tied (the ends) of their lower garments around their necks, like children, due to shortage of cloth and offering their prayers behind the Apostle of Allah (may peace be upon him).One of the proclaimers said: O womenfolk, do not lift your heads till men raise (them).

Chapter 27 : WOMEN COMING OUT (FROM THEIR HOUSES) FOR GOING TO THE MOSQUE WHEN THERE IS NO APPREHENSION OF WICKEDNESS, BUT THEY SHOULD NOT COME OUT SCENTED

Book 4, Number 0884:

    Salim narrated it from his father ('Abdullah b. Umar) that the Messenger of Allah (may peace be upon him) said: When women ask permission for going to the mosque, do not prevent them.

Book 4, Number 0885:

    Abdullah b. Umar reported: I heard Allah's Messenger (may peace be upon him) say: Don't prevent your women from going to the mosque when they seek your permission.Bilal b. 'Abdullah said: By Allah, we shall certainly prevent them. On this'Abdullah b. Umar turned towards him and reprimanded him to harshly as I had never heard him do before. He ('Abdullah b. Umar) said: I am narrating to you that which comes from the Messenger of Allah (may peace be upon him) and you (have the audicity) to say: By Allah, we shall certainly prevent them.

Book 4, Number 0886:

    Ibn 'Umar reported:'The Messenger of Allah (may peace be upon him) said: Do not prevent the maid-servants of Allah from going to the mosque.

Book 4, Number 0887:

    lbn Umar reported: I heard the Messeinger of Allah (may peace be upon him) say: When your women seek your permission for going to the mosque, you grant them (permission).

Book 4, Number 0888:

    Ibn 'Umar reported: The Messenger of Allah (may peace be upon him) said: Do not prevent women from going to the mosque at night.A boy said to 'Abdullah b. Umar: We would never let them go out, that they may not be caught in evil.He (the narrator) said: Ibn Umar reprimanded him and said.. I am saying that the Messenger of Allah (may peace be upon him) said this, but you say: We would not allow !

Book 4, Number 0889:

    A hadith like this has been narrated by A'mash with the same chain of transmitters.

Book 4, Number 0890:

    Ibn 'Umar reported: Grant permission to women for going to the mosque in the night.His son who was called Waqid said: Then they would make mischief.He (the narrator) said: He thumped his (son's) chest and said: I am narrating to you the hadith of the Messenger of Allah (may peace be upon him), and you say: No !

Book 4, Number 0891:

    Ibn Umar reported: The Messenger of Allah (may peace be upon him) said: Do not deprive women of their share of the mosques, when they seek permission from you. Bilal said: By Allah, we would certainly prevent them.'Abdullah said: I say that the Messenger of Allah (may peace be upon him) said it and you say: We would certainly prevent them !

Book 4, Number 0892:

    Zainab Thaqafiya reported: The Messenger of Allah (may peace be upon him) said: When any one of you (women) participates in the 'Isha' prayer, she should not perfume herself that night.

Book 4, Number 0893:

    Zainab, the wife of Abdullah (b.'Umar), reported: The Messenger of Allah (may peace be upon him) said to us: When any one of you comes to the mosque, she should not apply perfume.

Book 4, Number 0894:

    Abu Huraira said: The Messenger of Allah (may peace be upon him) said: Whoever (woman) fumigates herself with perfume should not join us in the 'Isha' prayer.

Book 4, Number 0895:

    'Amra, daughter of Abd al-Rahmin, reported: I heard 'A'isha, the wife of the Apostle of Allah (may peace be upon him). say: If the Messenger of Allah (may peace be upon him) had seen what new things the women have introduced (in their way of life) he would have definitely prevented them from going to the mosque, as the women of BaniIsra'il were prevented.

Book 4, Number 0896:

    This hadith has been narrated by Yahya b. Sa'id with the same chain of transmitters.

Chapter 28 : MODERATION BETWEEN LOUD AND LOW RECITATION IN JAHRI PRAYER, WHEN THERE IS A FEAR OF TURMOIL IN RECITING LOUDLY

Book 4, Number 0897:

    Ibn 'Abbas reported: The word of (Allah) Great and Glorious: 'And utter not thy prayer loudly, nor be low in it" (xvii. 110) was revealed as the Messenger of Allah (may peace beupon him) was hiding himself in Mecca. When he led his Companions in prayer he raised his voice (while reciting the) Qur'an. And when the polytheists heard that, they reviled the Qur'an and Him Who revealed it and him who brought it. Upon this Allah, the Exalted, said to His Apostle (may peace be upon him): Utter not thy prayer so loudly that the polytheists may hear thy recitation and (recite it) not so low that it may be inaudible to your Companions. Make them hear the Qur'an, but do not recite it loudly and seek a (middle) way between these. Recite between loud and low tone.

Book 4, Number 0898:

    'A'isha reported that so far as these words of (Allah) Glorious and High are concerned: "And utter not thy prayer loudly, not be low in it" (xvii. 110) relate to supplication (du'a').

Book 4, Number 0899:

    A hadith like this has been narrated by Hisham with the same chain of transmitters.

Chapter 29 : LISTENING TO THE RECITATION OF THE QUR'AN

Book 4, Number 0900:

    Ibn 'Abbas reported with regard to the words of Allah, Great and Glorious: "Move not thy tongue therewith" (Ixxv. 16) that when Gabriel brought revelation to him (the Holy Prophet) he moved his tongue and lips (with a view to committing it to memory instantly). This was something hard for him and it was visible (from his face). Then Allah, the Exalted. revealed this a "Move not thy tongue therewith to make haste (in memorising it). Surely on us rests the collecting of it and the reciting of it" (ixxv.16), i.e. Verily it rests with Us that We would preserve it in your heart and (enable you) to recite it You would recite it when We would recite it and so follow its recitation, and He (Allah) said: "We revealed it, so listen to it attentively. Verily its exposition rests with Us. i.e. We would make it deliver by your tongue." So when Gabriel came to him (to the Holy Prophet), he kept silence, and when he went away he recited as Allah had promised him.

Book 4, Number 0901:

    Ibn Abbas reported with regard to the words: "Do not move thy tongue there with to make haste," that the Apostle of Allah (may peace be upon him) felt it hard and he moved his lips.Ibn 'Abbas said to me (Sa'id b. Jubair) : I move them just as the Messenger of Allah (may peace be upon him) moved them. Then said Sa'id: I move them just as Ibn 'Abbas moved them, and he moved his lips. Allah, the Exalted, revealed this: "Do not move your tongue therewith to make haste. It is with US that its collection rests and its recital" (al-Qur'an, ixxv. 16). He said: Its preservation in your heart and then your recital. So when We recite it, follow its recital.He said: Listen to it, and be silent and then it rests with Us that you recite it. So when Gabriel came to the Messenger of Allah (may peace be upon him), he listened to him attentively, and when Gabriel went away, the Apostle of Allah (may peace be upon him) recited as he (Gabriel) had recited it.

Chapter 30 : RECITATION OF THE QUR'AN LOUDLY IN THE' DAWN PRAYER

Book 4, Number 0902:

    Ibn 'Abbas reported: The Messenger of Allah (may peace be upon him) neither recited the Qur'an to the Jinn nor did he see them. The Messenger of Allah (may peace be upon him) went out with some of his Companions with the intention of going to the bazaar of 'Ukaz And there had been (at that time) obstructions between satans and the news from the Heaven, and there were flung flames upon them. So satan went back to their people and they said: What has happened to you ? They said : There have been created obstructions between us and the news from the Heaven. And there have been flung upon us flames. They said: It cannot happen but for some (important) event. So traverse the eastern parts of the earth and the western parts and find out why is it that there have been created obstructions between us and the news from the Heaven. So they went forth and traversed the easts of the earth and its wests. Some of them proceeded towards Tihama and that is a nakhl towards the bazaar of 'Ukaz and he (the Holy Prophet) was leading his Companions in the morning prayer. So when they heard the Qur'an. they listened to it attentively and said: It is this which has caused obstruction between us and news from the Heaven. They went back to their people and said: O our people, we have heard a strange Qur'an which directs us to the right path; so we affirm our faith in it and we would never associate anyone with our Lord. And Allah, the Exalted and Glorious, revealed to His Apostle Muhammad (may peace be upon him): "It has been revealed to me that a party of Jinn listened to it" (Qur'an, lxxii. 1).

Book 4, Number 0903:

    Dawud reported from 'Amir who said: I asked 'Alqama if Ibn Mas'ud was present with the Messenger of Allah (may peace be upon him) on the night of the Jinn (the night when the Holy Prophet met them). He (Ibn Mas'uad) said: No, but we were in the company of the Messenger of Allah (may peace be upon him) one night and we missed him. We searched for him in the valleys and the hills and said. He has either been taken away (by jinn) or has been secretly killed. He (the narrator) said. We spent the worst night which people could ever spend. When it was dawn we saw him coming from the side of Hiri'. He (the narrator) reported. We said: Messenger of Allah, we missed you and searched for you, but we could not find you and we spent the worst night which people could ever spend. He (the Holy Prophet) said: There came to me an inviter on behalf of the Jinn and I went along with him and recited to them the Qur'an. He (the narrator) said: He then went along with us and showed us their traces and traces of their embers. They (the Jinn) asked him (the Holy Prophet) about their provision and he said: Every bone on which the name of Allah is recited is your provision. The time it will fall in your hand it would be covered with flesh, and the dung of (the camels) is fodder for your animals. The Messenger of Allah (may peace be upon him) said: Don't perform istinja with these (things) for these are the food of your brothers (Jinn).

Book 4, Number 0904:

    This hadith has been reported by Dawud with the same chain of transmitters up to the word(s) : "The traces of their embers." Sha'bi said : They (the Jinn) asked about their provision, and they were the Jinn of al-jazira, up to the end of the hadith, and the words of Sha'bi have been directly transmitted from the hadith of Abdullah.

Book 4, Number 0905:

    This hadith has been narrated on the authority of 'Abdullah from the Apostle (may peace be upon him) up to the words: "The traces of the embers," but he made no mention of what followed afterward.

Book 4, Number 0906:

    Abdullah (b. Mas'ud) said: I was not with the Messenger of Allah (may peace be upon him) but I wish I were with him.

Book 4, Number 0907:

    Ma'n reported.. I heard it from my father who said: I asked Masruq who informed the Messenger of Allah (may peace be upon him) about the night when they heard the Qur'an. He said: Your father, Ibn Mas'ud, narrated it to me that a tree informed him about that.

Chapter 31 : RECITATION IN THE NOON AND AFTERNOON PRAYERS

Book 4, Number 0908:

    Abu Qatada reported: The Messenger of Allah (may peace be upon him) led us in prayer and recited in the first two rak'ahs of the noon and afternoon prayers Surat al-Fitiha and two (other) surahs. And he would sometimes recite loud enough for us the verses. He would prolong the first rak'ah more than the second. And he acted similarly in the morning prayer.

Book 4, Number 0909:

    Abu Qatada reported it on the authority of his father: The Messenger of Allah (may peace be upon him) would recite in the first two rak'ahs of the noon and afternoon prayers the opening chapter of the Book and another surah. He would sometimes recite loud enough to make audible to us the verse and would recite in the last two rak'ahs Surat al-Faitiha (only).

Book 4, Number 0910:

    Abu Sa'id al-Khudri reported: We used to estimate how long Allah's Messenger (may peace be upon him) stood in the noon and afternoon prayers, and we estimated hat he stood in the first two rak'ahs of the noon prayer as long as it takes to recite Alif Lam Mim, Tanzil, i.e. as-Sajda. We estimated that he stood half that time in the last two rak'ahs; that he stood in the first two of the afternoon as long as he did in the last two at noon; and in the last two of the afternoon prayer about half that time.
    Abu Bakr in his narration has made no mention of Alif Lam Mim, Tanzil, but said: As long as it takes to recite thirty verses.

Book 4, Number 0911:

    Abu Sa'id al-Khudri reported: The Apostle of Allah (may peace be upon him) used to recite in every rak'ah of the first two rak'ahs of the noon prayer about thirty verses and in the last two about fifteen verses or half (of the first rak'ah) and in every rak'ah of the 'Asr prayer of the first two rak'ahs about fifteen verses and in the last two verses half (of the first ones).

Book 4, Number 0912:

    Jabir b. Samura reported: The people of Kufa complained to Umar b. Khattab about Sa'id and they made a mention of his prayer. 'Umar sent for him. He came to him. He ('Umar) totd him that the people had found fault with his prayer. He said: I lead them in prayer in accorance with the prayer of the Messenger of Allah (may peace be upon him). I make no decrease in it. I make them stand for a longer time in the first two (rak'ahs) and shorten it in the last two. Upon this 'Umar remarked: This is what I deemed of thee, O Abu Ishaq

Book 4, Number 0913:

    This hadith his been narrated by 'Abu al-Malik with the same chain of transmitters.

Book 4, Number 0914:

    Jabir b. Samura reported: 'Umar said to Sa'd: They complain against you in every matter, even in prayer. He (Sa'd) said: I prolong (standing) in the first two (rak'ahs) and shorten it in the last two, and I make no negligence in following the prayer of the Messenger of Allah (may peace be upon him). He ('Umar) remarked: This is what is expected of you, or, that is what I deemed of you.

Book 4, Number 0915:

    This hadith is narrated by Jabir b. Samura but with the addition of these words: "(Sa'd said): These bedouins presume to teach me prayer."

Book 4, Number 0916:

    Abu Sa'id al-Khudri reported: The noon prayer would start and one would go to al-Baqi' and after having relieved himself he would perform ablution and then come, while the Messenger of Allah (may peace be upon him) would be in the first rak'ah, because he would prolong it so much.

Book 4, Number 0917:

    Qaz'a reported: I came to Abu Sa'id al-Khudri and he was surrounded by people. When the people departed from him I said: I am not going to ask you what these people have been asking you. I want to ask you about the prayer of the Messenger of Allah (may peace be upon him). He (Abu Sa'id) said: There is no good for you in this. He (Qaz'a), however, repeated (his demand). He then said: The noon prayer would start and one of us would go to Baqi' and, having relieved himself, would come to his home, then perform ablution and go to the mosque, and (he would find) The Messenger of Allah (may peace be upon him) in the first rak'ah.

Chapter 32 : RECITATION IN THE MORNING PRAYER

Book 4, Number 0918:

    Abdullah b. Sa'id reported: The Apostle of Allah (may peace be upon him) led us in the morning prayer in Mecca and began Sarat al-Mu'minin (xxiii ) but when he came to the mention of Moses and Aaron (verse. 45) or to the mention of Jesus (verse 50), a cough got the better of him, and he bowed. 'Abdullah b. Sa'ib was present there, and in the hadith narrated by Abd al-Razzaq (the words are): He cut short (the recitation) and bowed.

Book 4, Number 0919:

    'Amr b. Huwairith reported: I heard the Apostle of Allah (may peace be upon him) recite in the morning prayer " Wa'l-lail-i-idhd 'As'asa" (ixxxi. 17).

Book 4, Number 0920:

    Qutba b. Malik reported : I said prayer and the Messenger of Allah (may peace be upon him) led it and he recited "Qaf. (I.). By the Glorious Qur'an," till he recited "and the tall palm trees" (l. 10). I wanted to repeat it but I could not follow its significance.

Book 4, Number 0921:

    Qutba b. Malik reported that he had heard the Messenger of Allah (may peace be upon him) reciting in the morning prayer this: "And the tall palm trees having flower spikes piled one above another" (l. 10).

Book 4, Number 0922:

    Ziyad b. 'Ilaqa reported it on the authority of his uncle that he said the morning prayer with the Apostle of Allah (may peace be upon him) and he recited in the first rak'ah: "And the tall palm trees having flower spikes piled one above another (l. 10) or perhaps Sarah Qaf.

Book 4, Number 0923:

    Jabir b. Samura reported: The Apostle of Allah (may peace be upon him) used to recite in the morning prayer "Qaf. By the Glorious Quran." and his prayer afterward shortened.

Book 4, Number 0924:

    Simak asked Jabir b. Samura about the prayer of the Apostle (may peace be upon him). He said: He (the Holy Prophet) shortened the prayer and he did not pray like these people then, and he informed me that the Messenger of Allah (may peace be upon him) used to recite "Qaf. By the (Glorious) Qur'an," and a passage of similar length.

Book 4, Number 0925:

    Jabir b. Samura reported: The Apostle of Allah (may peace be upon him) used to recite in the noon prayer: "By the night when it envelopes" (xcii.), and in the afternoon like this, but he prolonged the morning prayer as compared to that (noon and afternoon prayers).

Book 4, Number 0926:

    Jabir b. Samura reported: The Apostle of Allah (may peace be upon him) used to recite in the noon prayer: "Glorify the name of thy Most High Lord in the morning prayer longer than this" (lxxxvii.)

Book 4, Number 0927:

    Abu Barza reported: The Messenger of Allah (may peace be upon him) used to recite in the morning prayer from sixty to one hundred verses.

Book 4, Number 0928:

    Abu Barza Aslami reported: The Messenger of Allah (may peace be upon him) used to recite from sixty to one hundred verses in the morning prayer.

Book 4, Number 0929:

    Ibn Abbas reported: Umm al-Fadl daughter of al-Harith heard him reciting: "By those sent forth to spread goodness" (lxxvii.). (Upon this) she remarked: O my son, you reminded me by the recitation of this surah (the fact) that it was the last surah that I heard from the Messenger of Allah (may peace be upon him) and he recited it in the evening prayer.

Book 4, Number 0930:

    This hadith has been narrated by Zuhri with the same chain of transmitters but with this addition: "And he did not lead the player after this till his death."

Book 4, Number 0931:

    Jubair b. Mut'im reported: I heard the Messenger of Allah (may peace be upon him) reciting Surat al-Tur (Mountain) (lii) in the evening prayer.

Book 4, Number 0932:

    This hadith has been narrated by Zuhri with the same chain of transmitters.

Chapter 33 : RECITATION IN THE NIGHT PRAYER

Book 4, Number 0933:

    'Adi reported: I heard al-Bara' narrating it from the Apostle of Allah (may peace be upon him) that while in a journey he said the night prayer and recited in one of the two rak'ahs: "By the Fig and the Olive" (Su'rah xcv.).

Book 4, Number 0934:

    Al-Bara' b. 'Azib reported that he said prayer with the Messenger of Allah (may peace be upon him) and he recited: "By the Fig and the Olive."

Book 4, Number 0935:

    Al-Bara' b. 'Azib reported: I heard the Apostle of Allah (may peace be upon him) reciting in the night prayer: "By the Fig and the Olive," and I have never heard anyone with a sweeter voice than he.

Book 4, Number 0936:

    Jabir reported that Mu'adh b. jabal used to pray with the Apostle (may peace be upon him), then came and led his people in prayer. One night he said the night prayer with the Apostle of Allah (may peace be upon him). He then came to his people and led them in prayerbeginning with Surat al-Baqara. A man turned aside, pronounced the taslim (salutation for concluding the prayer), then prayed alone and departed. The people said to him: Have you become a hypocrite, so and so? He said: I swear by Allah that I have not, but I will certainly go to Allah's Messenger (may peace be upon him) and will inform (him) about this. He then came to the Messenger of Allah (may peace be upon him) and said: Messenger of Allah, we look after camels used for watering and work by day. Mu'idh said the night prayer with you. He then came and began with Surat al-Baqara. Allah's Messenger (may peace be upon him) then turned to Mu'adh and said: Are you there to (put the people) to trial ? Recite such and recite such (and such a surah). It is transmitted on the authority of Jabir, as told by Sufyan, that he (the Holy Prophet) had said: "By the Sun and its morning brightness" (Sarah xci.), "By brightness" (Surah xciii)"By the night when it spreads" (Surah xcii.), and "Glorify the name of thy most high Lord" (Surah lxxxii.).

Book 4, Number 0937:

    Jabir reported: 'Mu'adh b jabal al-Ansari led his companions in the night prayer and prolonged it for them. A person amongst us said prayer (after having separated himself from the congregation). Mu'adh was informed of this, and he remarked that he wasa hypocrite. When it (the remark) was conveyed to the man, he went to the Messenger of Allah (may peace be upon him) and informed him of what Mu'adh had said. Upon this the Apostle of Allah (may peace be upon him) said to him: Mu'adh, do you want to become a person putting (people) to trial? When you lead people in prayer, recite: "By the Sun and its morning brightness" (Surah xci.), "Glorify the name of thy most high Lord" (Surah lxxxvi.) and "Read in the name of Lord" (Surah xcvi.), and "By the night when it spreads" (Surah xcii.).

Book 4, Number 0938:

    Jabir b. 'Abdullah reported: Mu'adh b. Jabal said the night prayer with the Messenger of Allah (may peace be upon him) and then returned to his people and then led them in this prayer.

Book 4, Number 0939:

    Jabir b. Abdullah reported: Mu'adh said the night prayer with the Messenger of Allah (may peace be upon him). He then came to the mosque of his people and led them in prayer.

Chapter 34 : THE DUTY OF THE IMAM IS TO BE BRIEF AND PERFECT IN PRAYER

Book 4, Number 0940:

    Abu Mas'ud al-Ainsari reported: A person came to the Messenger of Allah (may peace be upon him) and said: I keep away from the morning prayer on account of such and such (a man), because; he keeps us so long. I never saw God's Messenger (may peace be upon him) more angry when giving an exhortation than he was that day. He said: 0 people, some of you are scaring people away. So whoever of you leads the people in prayer he must be brief, for behind him are the weak, the aged, and the people who have (argent) business to attend.

Book 4, Number 0941:

    This hadith like one narrated by Hashalm has been narrated from Isma'il with the same chain of transmitters.

Book 4, Number 0942:

    Abu Huraira reported: The Apostle of Allah (may peace be upon him) said: When any one of you leads the people in prayer, he should be brief for among them are the young and the aged, the weak and the sick. But when one of you prays by himself, he may (prolong) as he likes.

Book 4, Number 0943:

    Hammam b. Munabbih reported: This is what Abu Huraira transmitted to us from Muhammad the Messenger of Allah (may peace be upon him), and he narrated (some) ahadith out of (these narrations and one of them is this): The Messenger of Allah (may peace be upon him) said: When any one of you stands to lead people In prayer, he should shorten it, for amongst them are the aged, and amongst them are the weak, but when he prays by himself, he may prolong his prayer as he likes.

Book 4, Number 0944:

    Abu Huraira reported: The Messenger of Allah (may peace be upon him) said: When any one of you leads people in prayer, he must shorten it for among them are the weak, the infirm and those who have business to attend.

Book 4, Number 0945:

    Abu Bakr b. 'Abd al-Rahman reported that he had heard Abu Huraira say that the Messenger of Allah (may peace be upon him) said like it, but he substituted "the aged" for 'the infirm".

Book 4, Number 0946:

    Uthman b. Abu'l-'As at-Thaqafi reported: The Apostle of Allah (may peace be upon him) said to him: Lead your people in prayer. I said: Messenger of Allah. I perceive something (disturbing) in my soul. He (the Holy Prophet) asked me to draw near him and making me sit down in front of him he placed his hand on my breast between my nipples. and then, telling me to turn round, he placed it on my back between my shoulders. He then said: Act as an Imam for your people. He who acts as Imam of the people, he must be brief, for among them are the aged, among them are the sick, among them are the weak, and among them are the people who have business to attend. But when any of you prays alone, he may pray as he likes.

Book 4, Number 0947:

    Uthman b. Abu'l-'As reported: The last thing which the Messenger of Allah (may peace be upon him) instructed me was: When you lead the people in prayer, be brief .

Book 4, Number 0948:

    Anas reported: The Apostle of Allah (may peace be upon him) used to be brief and perfect in prayer.

Book 4, Number 0949:

    Anas reported: The Messenger of Allah (may peace be upon him) was among those whose prayers was brief and perfect.

Book 4, Number 0950:

    Anas reported: I never prayed behind an Imam who was more brief and more perfect in prayer than the Messenger of Allah (may peace be upon him).

Book 4, Number 0951:

    Anas reported: The Messenger of Allah (may peace be upon him) would listen to the crying of a lad in the company of his mother, in prayer, and he would recite a short surah or a small surah.

Book 4, Number 0952:

    Anas b. Malik reported the Messenger of Allah (may peace be upon him) having said: When I begin the prayer I Intend to make it long, but I hear a boy cry. ing; I then shorten it because of his mother's feelings.

Chapter 35 : MODERATION IN THE ARTICLES OF PRAYER AND THEIR SHORTENING AND PERFECTION

Book 4, Number 0953:

    Al-Bara' b. 'Azib reported: I noticed the prayer of Muhammad (may peace be upon him) and saw his Qiyam (standing), his bowing, and then going back to the standing posture after bowing, his prostration, his sitting between the two prostrations, and his prostration and sitting between salutation and going away, all these were nearly equal to one another.

Book 4, Number 0954:

    Hakam reported: There dominated in Kufa a man whose name was men- tioned as Zaman b. al-Ash'ath, who ordered Abu 'Ubaidah b. 'Abdullah to lead people in prayer and he accordingly used to lead them. Whenever he raised his head after bowing, he stood up equal to the time that I can recite (this supplication): O Allah! our Lord! unto Thee be the praise which would fill the heavens and the earth, and that which will please Thee besides them I Worthy art Thou of all praise and glory. None can prevent that which Thou bestowest, and none can bestow that whichthou preventest. And the greatness of the great will not avail him against Thee. Hakam (the narrator) said: I made a mention of that to Abd al-Rahman ibn Abi Laila who reported: I heard al-Bara' b. 'Azib say that the prayer of the Messenger of Allah (may peace be upon him) and his bowing, and when he lifted his head from bowing, and his prostration, and between the two prostrations (all these acts) were nearly proportionate. I made a mention of that to 'Ar b. Murrah and he said: I saw Ibn Abi Laili (saying the prayer), but his prayer was not like this.

Book 4, Number 0955:

    Hakam reported: When Matar b. Najiya dominated Kufa he ordered Abu Ubaida to lead people in prayer, and the rest of the hadith is the same.

Book 4, Number 0956:

    Thabit reported it on the authority of Anas: While leading you in prayer I do not shorten anything in the prayer. I pray as I saw the Messenger of Allah (may peace be upon him) leading us. He (Thabit) said: Anas used to do that which I do not see you doing; when he lifted his head from bowing he stood up (so long) that one would say: He has forgotten (to baw down in prostration). And when he lifted his head from prostration, he stayed in that position, till someone would say: He has forgotten (to bow down in prostration for the second sajda).

Book 4, Number 0957:

    Thabit reported it on the authority of Anas: I have never said such a light and perfect prayer as I said behind the Messenger of Allah (may peace be upon him). The prayer of the Messenger. of Allah (may peace be upon him) was well balanced. And so too was the prayer of Abu Bakr well balanced. When it was the time of 'Umar b. al-Khattab he prolonged the morning prayer. When the Messenger of Allah (may peace be upon him) said: Allah listened to him who praised Him, he stood erect till we said: He has forgotten. He then prostrated and sat between two prostration till we said: He has forgotten.

Chapter 36 : FOLLOWING THE IMAM AND ACTING AFTER HIM

Book 4, Number 0958:

    Al-Bara' (b. 'Azib), and he was no liar (but a truthful Companion of the Holy Prophet), reported: They used to say prayer behind the Messenger of Allah (may peace be upon him). I never saw anyone bending his back at the time when he (the Holy Prophet) raised his head, till the Messenger of Allah (may peace be upon him) placed his forehead on the ground. They then fell in prostration after him.

Book 4, Number 0959:

    Al-Bara' reported, and he was no liar: When the Messenger of Allah (may peace be upon him) said: Allah listened to him who praised Him, none of us bent his back till he (the Holy Prophet) prostrated; we then, afterwards, went down in prostration.

Book 4, Number 0960:

    Al-Bara' reported: They (the Companions) said prayer with the Messenger of Allah (may peace be upon him), and they bowed when he (the Holy Prophet) bowed. and when he raised his head after bowing, he pronounced: "Allah listened to him who praised Him," and we kept standing till we saw him placing his face on the ground and then we followed him.

Book 4, Number 0961:

    Al-Bara' reported: When we were (in prayer) with the Messenger of Allah Allah (may peace be upon him) none of us benfft his back till we saw he prostrated. Zuhair and others reported: "till we saw him prostrating".

Book 4, Number 0962:

    'Amr b. Huraith reported: I said the dawn prayer behind the Apostle of (may peace be upon him) and heard him reciting: 'Nay. I call to witness the stars, running their courses and setting" (al-Qur'an, lxxxi. 15-16) and Done of us bent his back till he completed prostration.

Book 4, Number 0963:

    ('Abdullah b ) Ibn Abi Aufa reported: When the Messenger of Allah (may peace be upon him) raised his back from the rukd' he pronounced: Allah listened to him who praised Him. O Allah ! our Lord ! unto Thee be praise that would fill the heavens and the earth and fill that which will please Thee besides them.

Book 4, Number 0964:

    'Abdullah b. Aufa reported: The Messenger of Allah (may peace be upon him) used to recite this supplication: O Allah ! our Lord, unto Thee be praise that would fill the heavens and the earth and fill that which will please Thee besides them.

Book 4, Number 0965:

    Abdullah b. Abu Aufa reported that the Apostle of Allah (may peace be upon him) used to recite (this supplication): O Allah! our Lord, unto Thee be praise that would fill the heavens and the earth and fill that which will please Thee besides (them). O Allah ! purify me with snow, (water of) hail and with cold water; O Allah. cleanse me from the sins and errors just as a white garment is cleansed from dirt.

Book 4, Number 0966:

    This hadith with the same chain of transmitters has been narrated by Shu'ba, and in the narration of Mu'adh the words are: "just as the white garment is cleansed from filth," and in the narration of Yazid: "from dirt".

Book 4, Number 0967:

    Abu Sa'id al-Khudri reported: When the Messenger of Allah (may peace be upon him) raised his head after bowing, he said : O Allah! our Lord, to Thee be the praise that would fill all the heavens and the earth, and all that it pleases Thee besides (them). O, thou art worthy of praise and glory, most worthy of what a servant says, and we all are Thy servants, no one can withhold what Thou givest or give what Thou withholdest, and riches cannot avail a wealthy person against Thee.

Book 4, Number 0968:

    Ibn Abbas reported : When the Apostle of Allah (may peace be upon him) raised his head after bowing, he said : Allah ! our Lord, to Thee be the praise that would fill the heavens and the earth and that which is between them, and that which will please Thee besides (them). Worthy art Thou of all praise and glory. No one can withhold what Thou givest, or give what Thou withholdest. And the greatness O! the great availeth not against Thee.

Book 4, Number 0969:

    Ibn Abbas reported from the Apostle of Allah (may peace be upon him) the words: "And that would fill that which will please Thee besides (them) !" and he did not mention the subsequent (portion of supplication).

Book 4, Number 0970:

    Ibn 'Abbas reported: The Messenger of Allah (may peace be upon him) drew aside the curtain (of his apartment) and (he saw) people in rows (saying prayer) behind Aba Bakr. And he said: Nothing remains of the glad tidings of apostlehood, except good visions which a Muslim sees or someone is made to see for him. And see that I have been forbidden to recite the Qur'an in the state of bowing and prostration. So far as Ruk'u is concerned, extol in it the Great and Glorious Lord, and while prostrating yourselves be earnest in supplication, for it is fitting that your supplications should be answered.

Book 4, Number 0971:

    'Abdullah b. 'Abbas reported: The Messenger of Allah (may peace be upon him) drew aside the curtain and his head was bandaged on account of illness in which he died. He said : O Allah, have I not delivered (Thy Message)? (He repeated it) three times. Nothing has been left out of the glad tidings of apostlebood, but good vision. which a pious servant (of Allah) sees or someone else is made to see for him. He then narrated like the hadith transmitted by Sufyan.

Book 4, Number 0972:

    'Ali b. Abi Talib reported : The Messenger of Allah (may peace be upon him) forbade me to recite (the Qur'an) in a state of bowing and prostration.

Book 4, Number 0973:

    'Ali b. Abi Talib reported : The Messenger of Allah (may peace be upon him) forbade to recite the Qur'an, while I am in the state of bowing and prostration.

Book 4, Number 0974:

    'Ali b. Abi Talib reported: The Messenger of Allah (may peace be upon him) forbade me from the recitation (of the Qur'an) in bowing and prostration and I do not say that he forbade you.

Book 4, Number 0975:

    'Ali reported: My loved one (the Holy Prophet) forbade me that I should recite (the Qur'an) in a state of bowing and prostration.

Book 4, Number 0976:

    This hadith has been narrated by some other narrators, Ibn 'Abbas and others, and they all reported that 'Ali said: The Apostle of Allah (may peace be upon him) forbade me to recite the Qur'an while I am in a state of bowing and prostration, and in their narration (there is a mention of) forbiddance from that (recital) in the state of prostration as it has been transmitted by Zuhri, Zaid b. Aslam, al-Wahid b. Kathir, and Dawud b. Qais.

Book 4, Number 0977:

    This hadith is transmitted on the authority of 'Ali, but he made no mention of "while in prostration".

Book 4, Number 0978:

    Ibn 'Abbas reported : I was forbidden to recite (the Qur'an) while I was bowing, and there is no mention of 'Ali in the chain of transmitters.

Chapter 37 : WHAT IS TO BE RECITED IN BOWING AND PROSTRATION

Book 4, Number 0979:

    Abu Huraira reported: The Messenger of Allah (may peace be upon him) said: The nearest a servant comes to his Lord is when he is prostrating himself, so make supplication (in this state).

Book 4, Number 0980:

    Abu Huraira reported: The Messenger of Allah (may peace be upon him) used to say while prostrating himself: O Lord, forgive me all my sins, small and great, first and last, open and secret.

Book 4, Number 0981:

    'A'isha reported: The Messenger of Allah (may peace be upon him') often said while bowing and prostrating himself: "Glory be to Thee, O Allah, our Lord, and praise be to Thee, O Allah, forgive me," thus complying with the (command in) the Qur'an.

Book 4, Number 0982:

    'A'isha reported that the Messenger of Allah (may peace be upon him) before his death recited often: Hallowed be Thou, and with Thy praise, I seek forgiveness from Thee and return to Thee. She reported: I said: Messenger of Allah, what are these words that I find you reciting? He said: There has been made a sign for me in my Ummah; when I saw that, I uttered them (these words of glorification for Allah), and the sign is: "When Allah's help and victory ..... to the end of the surah.

Book 4, Number 0983:

    'A'isha reported: Never did I ,see the Apostle of Allah (may peace be upon him) after the revelation (of these verses): "When Allah's help and victory came." observin- his prayer without making (this supplication) or he said in it (supplication): Hallowed be Thee, my Lord, and with Thy praise, O Allah, forgive me.

Book 4, Number 0984:

    'A'isha reported: The Messenger of Allah (may peace be upon him) recited often these words: Hallowed be Allah and with His praise, I seek the forgiveness of Allah and return to Him. She said: I asked: Messenger of Allah, I see that you often repeat the saying "subhan allahi bihamdihi astag firullahi watubuilaih" whereupon he said: My Lord informed me that I would soon see a sign in my Ummah,so when I see it I often recite (these) words: Hallowed be Allah and with His Praise, I seek forgiveness of Allah and return to Him. Indeed I saw it (when this verse) was revealed: "When Allah's help and victory came, it marked the victory of Mecca, and you see people entering into Allah's religion in troops, celebrate the praise of Thy Lord and ask His forgiveness. Surely He is ever returning to Mercy."

Book 4, Number 0985:

    Ibn Juraij reported: I asked 'Ata': What do you recite when you are in a state of bowing (in prayer) ? He said: "Hallowed be Thou, and with Thy praise, there is no god but Thou." Son of Abd Mulaika narrated to me on the anthority of 'A'isha (who reported): I missed one night the Apostle of Allah (may peace be upon him) (from his bed). I thought that he might have gone to one of his other wives. I searched for him and then came back and (found him) in a state of bowing, or prostration, saying: Hallowed be Thou and with Thy praise; there is no god but Thou. I said: With my father mayest thou be ransomed and with my mother. I was thinking of (another) affair, whereas you are (occupied) in another one.

Book 4, Number 0986:

    'A'isha reported: One night I missed Allah's Messenger (may peace be upon him) from the bed, and when I sought him my hand touched the soles of his feet while he was in the state of prostration; they (feet) were raised and he was saying: "O Allah, I seek refuge in Thy pleasure from Thy anger, and in Thy forgiveness from Thy punishment, and I seek refuge in Thee from Thee (Thy anger). I cannot reckon Thy praise. Thou art as Thou hast lauded Thyself."

Book 4, Number 0987:

    'A'isha reported that the Messenger of Allah (way peace he upon him) used to pronounce while bowing and prostrating himself: All Glorious, All Holy, Lord of the Angels and the Spirit.

Book 4, Number 0988:

    This hadith has been narrated on the authority of 'A'isha by another chain of transmitters.

Chapter 38 : THE EXCELLENCE OF PROSTRATION AND EXHORTATION TO OBSERVE IT

Book 4, Number 0989:

    Ma'dan b. Talha reported: I met Thauban, the freed slave. of Allah's Messenger (may peace be upon him), and asked him to tell me about an act for which, if I do it, Allah will admit me to Paradise, or I asked about the act which was loved most by Allah. He gave no reply. I again asked and he gave no reply. I asked him for the third time, and he said: I asked Allah's Messenger (may peace be upon him) about that and he said: Make frequent prostrations before Allah, for you will not make one prostration without raising you a degree because of it, and removing a sin from you, because of it. Ma'dan said that then lie met Abu al-Darda' and when he asked him, he received a reply similar to that given by Thauban.

Book 4, Number 0990:

    Rabi'a b. Ka'b said: I was with Allah's Messenger (may peace be upon him) one night. and I brought him water and what he required. He said to me: Ask (anything you like). I said: I ask your company in Paradise. He (the Holy Prophet) said: Or anything else besides it. I said: That is all (what I require). He said: Then help me to achieve this for you by deyoting yourself often to prostration.

Chapter 39 : HOW THE LIMBS SHOULD WORK IN PROSTRATION AND FORBIDDANCE TO FOLD CLOTHING AND HAIR AND PLAITING OF HAIR IN THE PRAYER

Book 4, Number 0991:

    Ibn 'Abbas reported: The Apostle of Allah (may peace be upon him) had been commanded that he should prostrate on the seven (bones) and he was forbidden to fold back the hair and clothing. And in the narration transmitted by Abu Rabi' (the words are): "on the seven bones and I was forbidden to fold back the hair and clothing". According to Abu'l-Rabi' (the seven bones are): The hands, the knees, and the (extremities) of the feet and the forehead.

Book 4, Number 0992:

    Ibn 'Abbas reported from the Apostle of Allah (may peace be upon him): I was commanded to prostrate myself on seven bones and not to fold back clothing or hair.

Book 4, Number 0993:

    Ibn 'Abbas reported: The Messenger of Allah (may peace be upon him) had been commanded to prostrate on seven (bones) and forbidden to fold back hair and clothing.

Book 4, Number 0994:

    Ibn Abbas reported that the Messenger of Allah (may peace be upon him) said: I have been commanded to prostrate myself on seven bones: "forehead," and then pointed with his hand towards his nose, hands, feet, and the extremities of the feet; and we were forbidden to fold back clothing and hair.

Book 4, Number 0995:

    Ibn Abbas reported : The Messenger of Allah (may peace be upon him) said: I was commanded to prostrate myself on the seven (bones) and forbidden to fold back hair and clothing. (The seven bones are): forehead, nose, bands, knees and feet.

Book 4, Number 0996:

    Abdullah b. Abbas reported that he saw 'Abdullah b. al-Harith observing the prayer and (his hair) was plaited behind his head. He ('Abdullah b. 'Abbas) stood up and unfolded them. While going back (from the prayer) he met Ibn 'Abbas and said to him: Why is it that you touched my head? He (Ibn 'Abbas) replied: (The man who observes prayer with plaited hair) is like one who prays with his hands tied behind.

Chapter 40 : MODERATION IN PROSTRATION, PLACING THE PALMS ON THE EARTH (GROUND) AND KEEPING AWAY ELBOWS FROM THE SIDES AND THE BELLY FROM THE THIGHS WHILE PROSTRATING

Book 4, Number 0997:

    Anas reported: The Messenger of Allah (may peace be upon him) said: Observe moderation in prostration, and let none of you stretch out his forearms (on the ground) like a dog.

Book 4, Number 0998:

    This hadith has been narrated by Shu'ba with the same chain of transmitters. And in the hidith transmitted by Ibn Ja'far (the words are): "None of you should stretch out his forearms like the stretching out of a dog."

Book 4, Number 0999:

    Al-Bira' (b. 'Azib) reported: The Messenger of Allah (may peace be upon him) said . When you prostrate yourself, place the palms of your hands on the ground and raise your elbows.

Book 4, Number 1000:

    'Abdullah b. Malik ibn Bujainah reported: When the Prophet (may peace be upon him) prostrated, lie spread out his arms so that the whiteness of his armpits was visible.

Book 4, Number 1001:

    This hadith has been narrated by Ja'far b. Rabi' with the same chain of transmitters. And in the narration transmitted by 'Amr b. al-Harith (the words are): "When the Messenger of Allah (rtiay peace be upon him) prostrated, he spread out his arms so that the whiteness of his armpits was visible." And in the narration transmitted by al-Laith (the words are : "When the Messenger of Allah (may peace be upon him) prostrated. he spread his hands from the armpits so that I saw their whiteness."

Book 4, Number 1002:

    Maimuna reported: When the Apostle of Allah (may peace be upon him) prostrated himself, if a lamb wanted to pass between his arms, it could pass.

Book 4, Number 1003:

    Maimuna, the wife of the Apostle of Allah (may peace be upon him), reported: When the Messenger of Allah (may peace be upon him) prostrated himself, he spread his arms, i.e. he separated them so much that the whiteness of his armpits became visible from behind and when he sat (for Jalsa) he rested on his left thigh.

Book 4, Number 1004:

    Maimuna daughter of Harith reported: When the Messenger of Allah (may peace be upon him) prostrated, he kept his hands so much apart from each other that when it was seen from behind the armpits became visible. Waki' said: That is their whiteness.

Chapter 41 : THE EXCELLENCE OF THE PRAYER AND THE WAY IT IS BEGUN AND THE EXCELLENCE OF RUKU' AND MODERATION IN IT, AND PROSTRATION AND MODERATION IN IT, ETC.

Book 4, Number 1005:

    'A'isha reported: The Messenger of Allah (may peace be upon him) used to begin prayer with takbir (saying Allih-o-Akbar) and the recitation: "Praise be to Allah, the Lord of the Universe." When he bowed he neither kept his head up nor bent it down, but kept it between these extremes; when he raised his bead after bow- ing he did not prostrate himself till he had stood erect; when he raised his head after prostration he did not prostrate himself again till he satup. At the end of every two rak'ahs he recited the tahiyya; and he used to place his left foot flat (on the ground) and raise up the right; he prohibited the devil's way of sitting on the heels, and he forbade people to spread out their arms like a wild beast. And he used to finish the prayer with the taslim.

Chapter 42 : SUTRA FOR PRAYER

Book 4, Number 1006:

    Musa b. Talha reported it on the authority of his father: The Messenger of Allah (may peace be upon him) said: When one of you places in front of him so me. thing such as the back of a saddle, he should pray without caring who passes on the other side of it.

Book 4, Number 1007:

    Musa b. Talha reported on the authority of his father: We used to say prayer and the animals moved in front of us. We mentioned it to the Messenger of Allah (may peace be upon him) and he said: If anything equal to the back of a saddle is in front of you, then what walks in front, no harm would come to him. Ibn Numair said: No harm would come whosoever walks in front.

Book 4, Number 1008:

    'A'isha reported: The Messenger of Allah (may peace be upon him) was asked about sutra of a worshipper; he said: Equal to the back of the saddle.

Book 4, Number 1009:

    'A'isha reported: The Messenger of Allah (may peace be upon him) was asked in the expedition of Tabuk about the sutra the worshipper; he said: Like the back of the saddle.

Book 4, Number 1010:

    Ibn Umar reported: When the Messenger of Allah (may peace he upon him) went out on the 'Id day, he ordered to carry a spear-and it was fixed in front of him, and he said prayer towards its (direction), and the people were behind him. And he did it in the journey, and that is the reason why the Amirs carried it.

Book 4, Number 1011:

    Ibn Umar reported: The Apostle of Allah (may peace be upon him) set up (sutra), and Abu Bakr said: He implanted iron-tipped spear and said prayer towards its direction. Ibn Abu Shaiba made this addition to it: " Ubaidullah said that it was a spear."

Book 4, Number 1012:

    Ibn 'Umar said: The Apostle of Allah (may peace be upon him) used to place his camel (towards the Ka'ba) and said prayer in its direction.

Book 4, Number 1013:

    Ibn 'Umar reported: The Apostle of Allah (may peace be upon him) used to say prayer towards his camel. Ibn Numair said: The Apostle of Allah (may peace be upon him) said prayer towards the camel.

Book 4, Number 1014:

    Abu Juhaifa reported it on the authority of his father: I came to the Apostle of Allah (may peace be upon him) in Mecca and he was (at that time) at al- Abtah in a red leather tent. And Bilal stepped out with ablution water for him. (And what was left out of that water) some of them got it (whereas others could not get it) and (those who got it) rubbed themselves with it. Then the Apostle of Allah (may peace be upon him) stepped out with a red mantle on him and I was catching a glimpse of the whiteness of his shanks. The narrator said: He (the Holy Prophet) performed the ablution. and Bilal pronounced Adhan and I followed his mouth (as he turned) this side and that as he said on the right and the left: "Come to prayer, come to success."' A spear was then fixed for him (on the ground). He stepped forward and said two rak'ahs of Zuhr, while there passed in front of him a donkey and a dog, and these were not checked. He then said two rak'ahs of the 'Asr prayer, and he then continued saying two rak'ahs till he came back to Medina.

Book 4, Number 1015:

    Abu Juhaifa reported on the authority of his father: I saw the Messenger of Allah (may peace be upon him) (in Mecca at al-Abtah) in a red leather tent. and I saw Bilal take the ablution water (left by Allah's Messenger), and I saw the people racing, with one another to get that ablution water. If anyone got some of it, he rubbed himself with it, and anyone who did not get any got some of the moisture from his companion's hand. I then saw Bilal take a staff and fix it in the ground, after which the Messenger of Allah (may peace be upon him) came out quickly in a red mantle and led the people in two rak'ahs facing the staff, and I saw people and animals passing in front of the staff.

Book 4, Number 1016:

    'Aun b. Abu Juhaifa narrated from the Apostle of Allah (may peace be upon him) on the authority of his father a hadith like that of Sufyan, and 'Umar b. Abu Za'ida made this addition: Some of them tried to excel the others (in obtaining water), and in the hadith transmitted by Malik b. Mighwal (the words are): When it was noon, Bilal came out and summoned (people) to (noon) prayer.

Book 4, Number 1017:

    Abu Juhaifa reported: The Messenger of Allah (may peace be upon him) went at noon towards al-Batha', he performed ablution, and said two rak'ahs of the Zuhr prayer and two of the 'Asr prayer, and there was a spear in front of him. Shu'ba said and Aun made this addition to it on the authority of his father Abu Juhaifa: And the woman and the donkey passed behind it.

Book 4, Number 1018:

    Shu'ba narrated the same on the basis of two authorities and in the hadith transmitted by Hakam (the words are) : The people began to get water that was left out of his (the Prophet's) ablution.

Book 4, Number 1019:

    Ibn 'Abbas reported: I came riding on a she-ass, and I was on the threshold of maturity, and the Messenger of Allah (may peace be upon him) was leading people in prayer at Mina. I passed in front of the row and got down, and sent the she-ass for grazing and joined the row, and nobody made any objection to it.

Book 4, Number 1020:

    Abdullah b. Abbas reported that he came riding on a donkey, and the Messenger of Allah (may peace be upon him) was leading the people in prayer at Mina on the occasion of the Farewell Pilgrimage and (the narrator) reported: The donkey passed in front of the row and then he got down from it And joined the row along with the people.

Book 4, Number 1021:

    This hadith has been narrated by Ibn 'Uyaina on the authority of al-Zuhri with the same chain of transmitters and he reported: The Apostle of Allah (may peace be upon him) was leading prayer at 'Arafa.

Book 4, Number 1022:

    This hadith has been reported by Ma'mar on the authority of al-Zuhri with the came chain of transmitters, but here no mention has been made of Mina or 'Arafa, and he said: It was in the Farewell Pilgrimage or on the Day of Victory.

Book 4, Number 1023:

    Abu Sa'id al-Khudri reported that the Messenger of Allah (may peace be upon him) said: When any one of you prays he should not let anyone pass in front of him (if there is no sutra), and should try to turn him away as far as possible, but if he refuses to go, he should turn him away forcibly for he is a devil.

Book 4, Number 1024:

    Abu Salih al-Samman reported: I narrate to you what I heard and saw from Abu Sa'id al-Khudri: One day I was with Abu Sa'id and he was saying prayer on Friday turning to a thing which concealed him from the people when a young man from Banu Mu'ait came there and he tried to pass in front of him; he turned him back by striking his chest. He looked about but finding no other way to pass except in front of Abu Sa'id, made a second attempt. He (Abu Sa'id) turned him away by Striking his chest more vigorously than the first stroke. He stood up and had a scuffle with Abu Sa'id. Then the people gathered there He came out and went to Marwan and complained to him what had happened to him. Abu Sa'id too came to Marwan. Marwin said to him: What has happened to you and the son of your brother that he came to complain against you? Abu Sa'id said: I heard from the Messenger of Allah (may peace be upon him) saying: When any one of you prays facing something which conceals him from people and anyone tries to pass in front of him, he should be turned away, but if he refuses, he should be forcibly restrained from it, for he is a devil.

Book 4, Number 1025:

    'Abdullah b. 'Umar reported that the Messenger of Allah (may peace be upon him) said: When any one of you prays, he should not allow anyone to pass before him, and if he refuses, he should be then forcibly resisted, for there is a devil with him.

Book 4, Number 1026:

    This hadith has been narrated by Ibn Umar by another chain of transmitters.

Book 4, Number 1027:

    Busr b Sa'id reported that Zaid b Khalid al-Juhani sent him to Abu Juhaim in order to ask him what he had heard from the Messenger of Allah (may peace be upon him) with regard to the passer in front of the worshipper. Abu Juhaim reported that the Messenger of Allah (may peace be upon him) said: If anyone who passes in front of a man who is praying knew the responsibility he incurs, he would stand still forty (years) rather than to pass in front of him Abu Nadr said: I do not know whether he said forty days or months or years.

Book 4, Number 1028:

    This hadith has been narrated from Abu Juhaim Ansari by another chain of transmitters.

Book 4, Number 1029:

    Sahl b. Sa'd al-Si'idi reported: Between the place of worship where the Messenger of Allah (may peace be upon him) prayed and the wall, there was a gap through which a goat could pass.

Book 4, Number 1030:

    Salama b. Akwa' reported: He sought the place (in the mosque) where the copies of the Qur'an were kept and glorified Allah there, and the narrator made a mention that the Messenger of Allah (may peace be upon him) sought that place and that was between the pulpit and the qibla-a place where a goat could pass.

Book 4, Number 1031:

    Yazid reported: Salama sought to say prayer near the pillar which was by that place where copies of the Qur'an were kept. I said to him: Abu Muslim. I see you striving to offer your prayer by this pillar. He said: I saw the Messenger of Allah (may peace be upon him) seeking to pray by its side.

Book 4, Number 1032:

    Abu Dharr reported: The Messenger of 'Allah (may peace be upon him) said: When any one of you stands for prayer and there is a thing before him equal to the back of the saddle that covers him and in case there is not before him (a thing) equal to the back of the saddle, his prayer would be cut off by (passing of an) ass, woman, and black Dog.I said: O Abu Dharr, what feature is there in a black dog which distinguish it from the red dog and the yellow dog? He said: O, son of my brother, I asked the Messenger of Allah(may peace be upon him) as you are asking me, and he said: The black dog is a devil.

Book 4, Number 1033:

    This hadith has been transmitted by Humaid b. Hilal on the authority of Yunus.

Book 4, Number 1034:

    Abu Huraira reported: The Messenger of Allah (may peace be upon him) said: A woman, an ass and a dog disrupt the prayer, but something like the back of a saddle guards against that.

Book 4, Number 1035:

    'A'isha reported: The Prophet (may peace be upon him) used to pray at night while I lay interposed between him and the Qibla like a corpse on the bier.

Book 4, Number 1036:

    'A'isha reported: The Apostle of Allah (may peace be upon him) said his whole prayer (Tahajjud prayer) during the night while I lay between him and the Qibla. When he intended to say Witr (prayer) he awakened me and I too said witr (prayer).

Book 4, Number 1037:

    'Urwa b. Zubair reported: 'A'isha asked: What disrupts the prayer? We said: The woman and the ass. Upon this she remarked: Is the woman an ugly animal? I lay in front of the Messenger of Allah (may peace be upon him) like the bier of a corpse and he said prayer.

Book 4, Number 1038:

    Masruq reported: It was mentioned before'A'isha that prayer is invalidated (in case of passing) of a dog, an ass and a woman (before the worshipper, when he is not screened). Upon this 'A'isha said: You likened us to the asses and the dogs. By Allah I saw the Messenger of Allah (may peace be upon him) saying prayer while I lay on the bedstead interposing between him and the Qibla. When I felt the need, I did not like to wit to front (of the Holy Prophet) and perturb the Messenger of Allah (may peace be upon him) and quietly moved out from under its (i.e. of the bedstead) legs.

Book 4, Number 1039:

    Al-Aswad reported that 'A'isha said: You have made us equal to the dogs and the asses, whereas I lay on the bedstead and the Messenger of Allah (may peace be upon him) came there and stood in the middle of the bedstead and said prayer. I did not like to take off the quilt from me (in that state), so I moved away quietly from the front legs of the bedstead and thus came out of the quilt.

Book 4, Number 1040:

    'A'isha reported: I was sleeping in front of the Mcsseinger ef Allah (may peace be upon him) with my legs between him and the Qibla. When he prostrated himself he pinched me and I drew up my legs, and when be stood up, I stretched them out. She said: At that time there were no lamps in the houses.

Book 4, Number 1041:

    Maimuna, the wife of the Apostle (may peace be upon him), reported: The Messenger of Allah (may peace be upon him) said prayer and I (lay) opposite to him while I was in menses. Sometimes his clothes touched me when he prostrated.

Book 4, Number 1042:

    'A'isha reported: The Apostle of Allah (may peace be upon him) said prayer at night and I was by his side in a state of meanses and I had a sheet pulled over me a portion of which was on his side.

Chapter 43 : PRAYER IN A SINGLE GARMENT

Book 4, Number 1043:

    Abu Huraira reported: An inquirer asked the Messenger of Allah (may peace be upon him) about the prayer in a single garment. He (the Holy Prophet) add: Has everyone of you two garments?

Book 4, Number 1044:

    A hadith like this has been narrated by Abu Huraira with another chain of transmitters.

Book 4, Number 1045:

    Abu Huraira reported: A person addressed the Apostle of Allah (may peace be upon him) and said to him: Can any one of us say prayer in one garment? He said: Do all of you possess two garments?

Book 4, Number 1046:

    Abu Huraira reported: The Messenger of Allah (may peace be upon him) said: None of you must pray in a single garment of which no part comes over his shoulders.

Book 4, Number 1047:

    Umar b. Abu Salama reported: I saw the Messenger of Allah (may peace be upon him) praying in Umm Salama's house in a single garment, placing its two ends over his shoulders.

Book 4, Number 1048:

    This hadith has been narrated by Hisham b. 'Urwa with the same chain of transmitters except (with this difference) that the word mutawashshihan was used and not the word mushtamilan .

Book 4, Number 1049:

    'Umar b. Abu Salama reported: I saw the Messenger of Allah (may peace be upon him) saying prayer in the house of Umm Salama in a single garment with its extremities crossing each other.

Book 4, Number 1050:

    Umar b. Abu Salama reported: I saw the Messenger of Allah (may peace be upon him) praying in a single garment with its ends crossing each other. 'Isa b. Hammad added: "placing on his shoulders".

Book 4, Number 1051:

    Jabir reported: I saw the Messenger of Allah (may peace be upon him) praying in a single garment crossing the two ends.

Book 4, Number 1052:

    This hadith has been narrated by Sufyan with the same chain of transmitters and in the hadith transmitted by Numair the words are: I called upon the Messenger of Allah (may peace be upon him)."

Book 4, Number 1053:

    Abu Zubair reported that he saw Jabir b. 'Abdullah praying in a single garment crossing Its ends even though he had the garments, and Jabir said: He saw the Messenger of Allah (may peace be upon him) doing like this.

Book 4, Number 1054:

    Abu Sa'id al Khudri reported: I visited the Apostle (may peace be upon him) and saw him praying on a reed mat on which he was prostrating himself. And I saw him praying in a single garment with ends crossed with each other.

Book 4, Number 1055:

    This hadith has been narrated by A'mash with the came chain of transmitters, and in the narration of Abu Karaib the words are: "Placing its (mantle's) ends on his shoulders"; and the narration transmitted by Abu Bakr and Suwaid (the words are): "the ends crossing with each other".

Chapter 44 : MOSQUES AND THE PLACE OF WORSHIP

Book 4, Number 1056:

    Abu Dharr reported: I said: Messenger of Allah, which mosque was set up first on the earth? He said: Al-Masjid al-Haram (the sacred). I (again) said: Then which next? He said: It was the Masjid Aqsa.I (again) said: How long the space of time (between their setting up)? He (the Holy Prophet) said: It was forty years. And whenever the time comes for prayer, pray there, for that is a mosque; and in the hadith transmitted by Abu Kamil (the words are): "Whenever time comes for prayer, pray, for that is a mosque (for you)."

Book 4, Number 1057:

    Ibrahim b. Yazid al-Tayml reported: I used to read the Qur'an with my father in the vestibule (before the door of the mosque). When I recited the ayat (verses) concerning prostration, he prostrated himself. I said to him: Father, do you prostrate yourself in the path? He said: I heard Abu Dharr saying: I asked the Messenger of Allah (may peace be upon him) about the mosque that was first set up on the earth. He said: Masjid Harim. I said: Then which next? He said: The Masjid al-Aqsa. I said: How long is the space of time between the two? He said: Forty years. He (then) further said: The earth is a mosque for you, so wherever you are at the time of prayer, pray there.

Book 4, Number 1058:

    Jabir b.'Abdullah al-Ansari reported: The Prophet (may peace be upon him) said: I have been conferred upon five (things) which were not granted to anyone before me(and these are): Every apostle wassent particularly to his own people,whereas I have been sent to all the red and the black the spoils of war have been made lawful for me, and these were never made lawful to anyone before me, and the earth has been made sacred and pure and mosque for me, so whenever the time of prayer comes for any one of you he should pray whenever he is,and I have been supported by awe (by which the enemy is overwhelmed) from the distance (which one takes) one month to cover and I have been granted intercession.

Book 4, Number 1059:

    Jabir b. 'Abdullah related that the Messenger of Allah (may peace be upon him) said, and he related like this.

Book 4, Number 1060:

    Hudhaifa reported: The Messenger of Allah (may peace be npon him) said: We have been made to excel (other) people in three (things) : Our rows have been made like the rows of the angels and the whole earth has been made a mosque for us, and its dust has been made a purifier for us in case water is not available. And he mentioned another characteristic too

Book 4, Number 1061:

    Hudhaifa reported : The Messenger of Allah (may peace be upon him) said like this.

Book 4, Number 1062:

    Abu Huraira reported that the Messenger of Allah (may peace be upon hlmg) said: I have been given superiority over the other prophets in six respects: I have been given words which are concise but comprehensive in meaning; I have been helped by terror (in the hearts of enemies) : spoils have been made lawful to me: the earth has been made for me clean and a place of worship; I have been sent to all mankind and the line of prophets is closed with me.

Book 4, Number 1063:

    Abu Huraira reported: The Messenger of Allah (may peace be upon him) said : I have been commissioned with words which are concise but comprehensive in meaning ; I have been helped by terror (in the hearts of enemies): and while I was asleep I was brought the keys of the treasures of the earth which were placed in my hand. And Abfi Huraira added: The Messenger of Allah (may peace be upon him) has left (for his heavenly home) and you are now busy in getting them.

Book 4, Number 1064:

    Abu Huraira reported: I heard the Messenger of Allah (may peace be upon him) saying a hadith like that of Yunus.

Book 4, Number 1065:

    This hadith has been narratted by Abu Huraira by another chain of transmitters.

Book 4, Number 1066:

    Abu Huraira reported: The Messenger of Allah (may peace be upon him) said: I have been helped by terror (in the heart of the enemy); I have been given words which are concise but comprehensive in meaning; and while I was asleep I was brought the keys of the treasures of the earth which were placed in my hand.

Book 4, Number 1067:

    Hammam b. Munabbih reported: That is what Abu Huraira reported to us from the Messenger of Allah (may peace be upon him) and he narrated (some) ahadith one of which is that the Messenger of Allah (may peace be upon him) said: I have been helped by terror (in the hearts of enemies) and I have been given words which are concise but comprehensive in meaning.

Chapter 45 : BUILDING OF THE PROPHET'S MOSQUE IN MEDINA

Book 4, Number 1068:

    Anas b. Malik reported: The Messenger of Allah (may peace be upon him) came to Medina and stayed in the upper part of Medina for fourteen nights with a tribe called Banu 'Amr b 'Auf. He then sent for the chiefs of Banu al-Najir, and they came with swords around their inecks. He (the narrator) said: I perceive as if I am seeing the Messenger of Allah (may peace be upon him) on his ride with Abu Bakr behind him and the chiefs of Banu al-Najjar around him till he alighted in the courtyard of Abu Ayyub. He (the narrator) said: The Messenger of Allah (may peace be upon him) said prayer when the time came for prayer, and he prayed in the fold of goats and sheep. He then ordered mosques to be built and sent for the chiefs of Banu al-Najjar, and they came (to him). He (the Holy Prophet) said to them: O Banu al-Najjar, sell these lands of yours to me. They said: No, by Allah. we would not demand their price, but (reward) from the Lord. Anas said: There (in these lands) were trees and graves of the polytheists, and ruins. The Messenger of Allah (may peace he upon him) ordered that the trees should be cut, and the graves should be dug out, and the ruins should be levelled. The trees (were thus) placed in rows towards the qibla and the stones were set on both sides of the door, and (while building the mosque) they (the Companions) sang rajaz verses along with the Messenger of Allah (may peace be upon him):

      O Allah: there is no good but the good of the next world, So help the Ansar and the Muhajirin.

Book 4, Number 1069:

    Anas reported: The Messenger of Allah (may peace be upon him) used to pray in the folds of the sheep and goats before the mosque was built.

Book 4, Number 1070:

    Abu al-Tiyyah reported: I heard from Anas a narration like this from the Messenger of Allah (may peace be upon him).

Chapter 46 : CHANGE OF QIBLA FROM BAIT-UL-MAQDIS TO KA'BA

Book 4, Number 1071:

    Al-Bara' b. 'Azib reported: I said prayer with the Apostle (may peace be upon him) turning towards Bait-ul-Maqdis for sixteen months till this verse of Surah Baqara wis revealed: "And wherever you are turn your faces towards it" (ii. 144). This verse was revealed when the Apostle (may peace be upon him) had said prayer. A person amongst his people passed by the people of Ansar as they were engaged in prayer. He narrated to them (this command of Allah) and they turned their faces towards the Ka'ba.

Book 4, Number 1072:

    Abu Ishaq reported: I heard al-Bara' saying: We prayed with the Messenger of Allah (may peace be upon him) (with our faces) towards Bait-ul-Maqdis for sixteen months or seventeen months. Then we were made to change (our direction) towards the Ka'ba.

Book 4, Number 1073:

    Ibn 'Umar reported: As the people were praying at Quba' a man came to them and said: It has been revealed to file Messenger of Allah (may peace be upon him) during the night and he has been directed to turn towards the Ka'ba. So turn towards it. Their faces were towards Syria and they turned round towards Ka'ba.

Book 4, Number 1074:

    Ibn 'Umar reported: As the people were engaged in the morning prayer a man came to them. The rest of the hadith is the same.

Book 4, Number 1075:

    Anas reported: The Messenger of Allah (may peace be upon him) used to pray towards Bait-ul-Maqdis, that it was revealed (to him): "Indeed We see the turning of the face to heaven, wherefore We shall assuredly cause thee to turn towards Qibla which shall please thee. So turn thy face towards the sacred Mosque (Ka'ba)" (ii. 144). A person from Banu Salama was going; (he found the people) in ruk'u (while) praying the dawn prayer and they had said one rak'ah. He said in a loud voice: Listen ! the Qibla has been changed and they turned towards (the new) Qibla (Ka'ba) in that very state.

Chapter 47 : FORBIDDANCE TO BUILD MOSQUES ON THE GRAVES AND DECORATING THEM WITH PICTURES AND FORBIDDANCE TO USE THE GRAVES AS MOSQUES

Book 4, Number 1076:

    'A'isha reported: Umm Habiba and Umm Salama made a mention before the Messenger of Allah (may peace be upon him) of a church which they had seen in Abyssinia and which had pictures in it. The Messenger of Allah (may peace be upon him) said: When a pious person amongst them (among the religious groups) dies they build a place of worship on his grave, and then decorate it with such pictures. They would be the worst of creatures on the Day of judgment in the sight of Allah.

Book 4, Number 1077:

    'A'isha reported: They (some Companions of the Holy Prophet) were conversing with one another in the presence of the Messenger of Allah (may peace be upon him) (during his last) illness. Umm Salama and Umm Habiba made a mention of the church and then (the hadith was) narrated.

Book 4, Number 1078:

    'A'isha reported: The wives of the Apostle of Allah (may peace be Upon him) made a mention of the church which they had seen in Abyssinia which was called Marya, and the rest of the hadith is the same.

Book 4, Number 1079:

    'A'isha reported: The Messenger of Allah (may peace be upon him) said during his illness from which he never recovered: Allah cursed the Jews and the Christians that they took the graves of their prophets as mosques. She ('A'isha) reported: Had it not been so, his (Prophet's) grave would have been in an open place, but it could not be due to the fear that it may not be taken as a mosque.

Book 4, Number 1080:

    Abu Huraira reported: The Messenger of Allah (may peace be upon him) said: Let Allah destroy the Jews for they have taken the graves of their apostles as places of worship.

Book 4, Number 1081:

    Abu Huraira reported: The Messenger of Allah (may peace be upon him) said: Let there be curse of Allah upon the Jews and the Christians for they have taken the graves of their apostles as places of worship.

Book 4, Number 1082:

    'A'isha and Abdullah reported: As the Messenger of Allah (may peace be upon him) was about to breathe his last, he drew his sheet upon his face and when he felt uneasy, he uncovered his face and said in that very state: Let there be curse upon the Jews and the Christians that they have taken the graves of their apostles as places of worship. He in fact warned (his men) against what they (the Jews and the Christians) did.

Book 4, Number 1083:

    Jundub reported: I heard from the Apostle of Allah (may peace be upon him) five days before his death and he said: I stand acquitted before Allah that I took any one of you as friend, for Allah has taken me as His friend, as he took Ibrahim as His friend. Had I taken any one of my Ummah as a friend, I would have taken Abu Bakr as a friend. Beware of those who preceded you and used to take the graves of their prophets and righteous men as places of worship, but you must not take graves as mosques; I forbid you to do that.

Chapter 48 : THE VIRTUE OF BUILDING THE MOSQUES AND EXHORTATION TO IT

Book 4, Number 1084:

    Ubaidullah al-Khaulini reported: 'Uthman b. 'Affan listened to the opinion of the people (which was not favourable) when he rebuilt the mosque of the Messenger of Allah (may peace be upon him). Thereupon he said: You have not been fair to me for I have heard from the Messenger of Allah (may peace be upon him) saying: He who built a mosque for Allah, the Exalted, Allah would build for him a house in Paradise. Bukair said: I think he (the Holy Prophet) said: While he seeks the pleasure of Allah (by building the mosque). And in the narration of Ibn 'Isa (the words are): "(a house) like that (mosque) in Paradise."

Book 4, Number 1085:

    Mahmud b. Labid reported: When 'Uthman b. 'Affan intended to build the mosque (of the Prophet) the people did not approve of it. They liked that it should be kept in the same state. Thereupon he said: I heard the Messtnger of Allah (may peace be upon him) say : He who built a mosque for Allah, Allah would build a house for him like it in Paradise.

Chapter 49 : CONCERNING THE COMMAND OF PLACING ONE'S HANDS ON THE KNEES WHILE IN RUKU'AND ABROGATION OF AL-TATBIQ

Book 4, Number 1086:

    Al-Aswad and 'Alqama reported: We came to the house of 'Abdullah b. Mas'ud. He said: Have these people said prayer behind you? We said: No. He said: Then stand up and say prayer. He neither ordered us to say Adhan nor Iqama. We went to stand behind him. He caught hold of our hands and mode one of us stand on his right hand and the other on his left side. When we bowed, we placed our hands on our knees. He struck our hands and put his hands together, palm to palm, then put them between his thighs. When he completed the prayer he said. There would soon come your Amirs, who would defer prayers from their appointed time and would make such delay that a little time is left before sunset. So when you see them doing so, say prayer at its appointed time and then say prayer along with them as (Nafl), and when you are three, pray together (standing in one row), and when you are more than three, appoint one amongst you as your Imam. And when any one of you bows he must place his hands upon hie thighs and kneel down. and putting his palms together place (them within his thighs). I perceive as if I am seeing the gap between the fingers of the Messenger of Allah (may peace he upon him).

Book 4, Number 1087:

    This hadith is narrated on the authority of Alqama and Aswad by another chain of transmitters and in the hadith transmitted by Ibn Mus-hir and Jabir the words are: "I perceive as if I am seeing the gap between the fingers of the Messenger of Allah (may peace be upon him) as he was bowing."

Book 4, Number 1088:

    'Alqama and Aswad reported that they went to 'Abdullah. He said: Have (people) behind you said prayer? They said: Yes. He stood between them ('Alqama and Aswad). One was on his right aide and the other was on his left. We then bowed and placed our hands on our knees. He struck our hands and then putting his hands together, palm to palm, placed them between his thighs. When he completed the prayer he said: This is how the Messenger of Allah (may peace be upon him) used to do.

Book 4, Number 1089:

    Mus'ab b. Sa'd reported: I said prayer by the side of my father and placed my hands between my knees. My father said to me: Place your hands on your knees. I repeated that (the previous act) for the second time, and he struck at my hands and said: We have been forbidden to do so and have been commanded to place our palms on the knees.

Book 4, Number 1090:

    This hadith has been narrated by Abu Ya'fur with the same chain of transmitters up to these words: We have been forbidden from it and no mention of that has been made what follows it.

Book 4, Number 1091:

    Ibn Sa'd reported: I bowed and my hands were in this state, i.e. they were put together, palm to palm, and were placed between his thighs. My father said: We used to do like this but were later on commanded to place them on the knees.

Book 4, Number 1092:

    Mus'ab b. Sa'd b. Abu Waqqas reported: I said prayer by the side of my father. When I bowed I intertwined my fingers and placed them between my knees. He struck my hands. When he completed the prayer he said: We used to do that but then were commanded to lift (our palms) to the knees.

Chapter 50 : SITTING ON THE BUTTOCKS

Book 4, Number 1093:

    Tawus reported: We asked Ibn Abbas about sitting on one's buttocks (in prayer). (ala alqad mein)He said: It is sunnah. We said to him: We find it a sort of cruelty to the foot. Ibn 'Abbas said: It is the sunnah of your Apostle (may peace be upon him).

Continue to next page: Click here


BOOK 4: The Book of Prayers (Kitab Al-Salat)(Part II)

KITAB AL-SALAT
(THE BOOK OF PRAYERS)
--Continued--

Back
Chapter 51 : FORBIDDANCE OF TALKING IN PRAYER AND ABROGATION OF WHAT WAS PERMISSIBLE

Book 4, Number 1094:

    Mu'awiya b. al-Hakam said: While I was praying with the Messenger of Allah (may peace be upon him), a man in the company sneezed. I said: Allah have mercy on you ! The people stared at me with disapproving looks, so I said: Woe be upon me, why is it that you stare at me ? They began to strike their hands on their thighs, and when I saw them urging me to observe silence (I became angry) but I said nothing. When the Messenger of Allah (may peace be upon him) had said the prayer (and I declare that neither before him nor after him have I seen a leader who gave better instruction than he for whom I would give my father and mother as ransom).I swear that he did not scold, beat or revile me but said: Talking to persons is not fitting during the prayer, for it consists of glorifying Allah, declaring his Greatness. and recitation of the Qur'an or words to that effect. I said: Messenger of Allah. I was till recently a pagan, but Allah has brought Islam to us; among us there are men who have recourse to Kahins. He said, Do not have recourse to them. I said. There are men who take omens. That is something which they find in their breasts, but let it not turn their way (from freedom of action).I said: Among us there are men who draw lines. He said: There was a prophet who drew lines, so if they do it as they did, that is allowable.I had a maid-servant who tended goats by the side of Uhud and Jawwaniya. One day I happened to pass that way and found that a wolf had carried a goat from her flock. I am after all a man from the posterity of Adam. I felt sorry as they (human beings) feel sorry. So I slapped her. I came to the Messenger of Allah (may peace be upon him) and felt (this act of mine) as something grievous I said: Messenger of Allah, should I not grant her freedom? He (the Holy Prophet) said: Bring her to me. So I brought her to him. He said to her: Where is Allah? She said: He is in the heaven. He said: Who am I? She said: Thou art the Messenger of Allah. He said: Grant her freedom, she is a believing woman.

Book 4, Number 1095:

    This hadith has been narrated by Yahya b. Abu Kathir with the same chain of transmitters.

Book 4, Number 1096:

    Abdullah (b. Masu'd) reported: We used to greet the Messenger of Allah (may peace be upon him) while he was engaged in prayer and he would respond to our greeting. But when we returned from the Negus we greeted him and he did not respond to us; so we said: Messenger of Allah. we used to greet you when you were engaged in prayer and you would respond to us. He replied: Prayer demands whole attention.

Book 4, Number 1097:

    This hadith has been reported by A'mash with the same chain of transmitters.

Book 4, Number 1098:

    Zaid b. Arqam reported: We used to talk while engaged in prayer and a person talked with a companion on his side in prayer till (this verse) was revealed: "And stand before Allah in devout obedience" (ii, 238) andwe were commanded to observe silence (in prayer) and were forbidden to speak.

Book 4, Number 1099:

    A hadith like this has been transmitted by Isma'il b. Abu Khalid.

Book 4, Number 1100:

    Jabir reported: The Messenger of Allah (may peace be upon him) sent me on an errand. I (having done the business assigned to me came back and) joined him as he was going (on a ride). Qutaiba said that he was saying prayer while he rode. I greeted him. He gestured to me. When he completed the prayer. he called me and said: You greeted me just now while I was engaged in prayer. (Qutaiba said) : His (Prophet's face) was towards the east, as he was praying.

Book 4, Number 1101:

    Jabir reported: The Messenger of Allah (may peace be upon him) sent me (on an errand) while he was going to Banu Mustaliq. I came to him and he was engaged in prayer on the back of his camel. I talked to him and he gestured to me With his hand, and Zuhair gestured with his hand. I then again talked and he again (gestured to me with his hand). Zuhair pointed with his hand towards the ground. I heard him (the Holy Prophet) reciting the Qur'an and making a sign with his head. When he com- pleted the prayer he sa'id: What have you done (with regard to that business) for which I sent you? I could not talk with you but for the fact that I was engaged in prayer. Zuhair told that Abu Zubair was sitting with his face turned towards Qibla (as he transmitted this hadith). Abu Zuhair pointed towards Banu Mustaliq with his hand and the direction to which he pointed with his hand was not towards the Ka'ba.

Book 4, Number 1102:

    Jabir reported: We were in the company of the Messenger of Allah (may peace be upon him), and he sent me on an errand, and when I came back (I saw him) saying prayer on his ride and his face was not turned towards Qibla. I greeted him but he did not respond to me. As he completed the prayer, he said : Nothing prevented me from responding to your greeting but the fact that I was praying.

Book 4, Number 1103:

    This hadith that the Messenger of Allah (may peace be upon him) sent Jabir on an errand has been reported by him through another chain of transmitters.

Chapter 52 : IT'IS ALLOWABLE TO CURSE SATAN DURING PRAYER AND SEEK THE PROTECTION (OF THE LORD) AND MINOR ACTS (OF COMMISSION) IN PRAYER

Book 4, Number 1104:

    Abu Huraira reported that he heard the Messenger of Allah (may peace be upon him) saying: A highly wicked one amongst the Jinn escaped yesternight to interrupt my prayer, but Allah gave me power over him, so I seized him and intended to tie him to one of the pillars of the mosque in order that you, all together or all, might look at him, but I remembered the supplication of my brother Sulaiman: "My Lord, forgive me, give me such a kingdom as will not be possible for anyone after me" (Qur'an, xxxvii. 35).

Book 4, Number 1105:

    This hadith has been transmitted by Ibn Abi Shaiba.

Book 4, Number 1106:

    Abu Darda' reported : Allah's Messenger (may peace be upon him) stood up (to pray) and we heard him say: "I seek refuge in Allah from thee." Then said: " curse thee with Allah's curse" three times, then he stretched out his hand as though he was taking hold of something. When he finished the prayer, we said: Messenger of Allah, we heard you say something during the prayer which we have not heard you say before, and we saw you stretch out your hand. He replied : Allah's enemy Iblis came with a flame of fire to put it in my face, so I said three times: "I Seek refuge in Allah from thee." Then I said three times: "I curse thee with Allah's full curse." But he did not retreat (on any one of these) three occasions. Thereafter I meant to seize him. I swear by Allah that had it not been for the supplication of my brother Sulaiman he would have been bound, and made an object of sport for the children of Medina.

Chapter 53 : PERMISSIBILITY OF CARRYING CHILDREN IN PRAYER

Book 4, Number 1107:

    Abu Qatadi reported: I saw the Messenger of Allah (may peace be upon him) saying the prayer while he was carrying Umama, daughter of Zainab, daughter of the Messenger of Allah (may peace be upon him). and Abu'l-'As b. al-Rabi'. When he stood up, he took her up and when he prostrated he put her down,Yahya said: Malik replied in the affirmative.

Book 4, Number 1108:

    Abu Qatada al-Ansari reported: I saw the Apostle (may peace be upon him) leading the people in prayer with Umima, daughter of Abu'l-'As and Zainab, daughter of the Apostle of Allah (may peace be upon him), on his shoulder. When he bowed, he put her down, and when he got up after prostration, he lifted her again.

Book 4, Number 1109:

    Abu Qatada reported: I saw the Messenger of Allah (may peace be upon him) leading the people in prayer with Umama daughter of Abu'l-'As on his neck; and when he prostrated he put her down.

Book 4, Number 1110:

    Abu Qatada reported : As we were sitting in the mosque, the Messenger of Allah (may peace be upon him) came to us, and the rest of the hadith is the same except that he made no mention that he led people in this prayer.

Chapter 54 : THE PERMISSIBILITY OF MOVING TWO STEPS IN THE PRAYER

Book 4, Number 1111:

    Abu Hazim is reported on the authority of his father: Some people came to Sahl b. Sa'd and began to differ about the wood of which the (Prophet's pulpit was made. He (Sahl b. Sa'd) said: By Allah, I know of which wood it is made and who made it, and the day when I saw the Messenger of Allah (may peace be upon him) seated himself on it on the first day. I said to him: O Abu Abbas (kunyah of Sabl b. Sa'd), narrate to us (all these facts), He said: The Messenger of Allah (may peace be upon him) sent a person to a woman asking her to allow her slave, a carpenter, to work on woods (to prepare a pulpit) so that I should talk to the people (sitting on it). Abu Hazim said: He (Sahl b. Sa'd) pointed out the name of (that lady) that day. So he (the carpenter) made (a pulpit) with these three steps. Then the Messengerof Allah (may peace be upon him) commanded it to be placed here (where it is lying now). It was fashioned out of the wood of al-Ghaba. And I saw the Messenger of Allah (may peace he upon him) standing upon it and glorifying Allah and the people also glorified Allah after him, while he was on the pulpit. He then raised (his head from prostration) and stepped back (on his heels) till he prostrated himself at the base of pulpit, and then returned (to the former place and this movement of one or two steps continued) till the prayer was complete. He then turned towards the people and said: O people, I have done it so that you should follow me and learn (my mode of) prayer.

Book 4, Number 1112:

    Abu Hazim reported: They (the people) came to Sahl b. Sa'd and they asked him of what thing the pulpit of the Apostle of Allah (may peace be upon him) was made, and the rest of the hadith is the same.

Chapter 55 : IT IS NOT ADVISABLE TO SAY PRAYER WHILE KEEPING ONE'S HAND ON ONE'S WAIST

Book 4, Number 1113:

    Abu Huraira reported from the Apostle of Allah (may peace be upon him) that he forbade keeping one's hand on one's waist while praying, and in the narration of Abu Bakr (the words are): The Messenger of Allah (may peace be upon him) forbade to do so.

Chapter 56 : IT IS FORBIDDEN TO REMOVE PEBBLES AND SMOOTH THE GROUND WHILE ENGAGED IN PRAYER

Book 4, Number 1114:

    Mu'aiqib quoted the Apostle of Allah (may peace be upon him) mentioning the removal of pebbles from the ground where he prostrated himself. He (the Prophet) said: It you must do so, do it only once.

Book 4, Number 1115:

    Mu'aiqib said: They asked the Apostle (may peace be upon him) about the removal of (pebbles) in prayer, whereupon he said: If you do it, do it only once.

Chapter 57 : FORBIDDANCE TO SPIT IN THE MOSQUE WHILE ENGAGED IN PRAYER

Book 4, Number 1116:

    Abdullah b. Umar reported: The Messenger of Allah (may peace be upon him) saw spittle on the wall towards Qibla, and scratched it away and then turning to the people said: When any one of you prays, he must not spit in front of him, for Allah is in front of him when he is engaged in prayer.

Book 4, Number 1117:

    Ibn Umar reported that the Messenger of Allah (may peace be upon him) saw sputum sticking to the Qibla wall of the mosque, the rest of the hadith is the same.

Book 4, Number 1118:

    Abu Sa'id al-Khudri reported: The Apostle of Allah (may peace be upon him) saw sputum sticking to the Qibla of the mosque. He scratched it off with a pebble and then forbade spitting on the right side or in front, but (it is permissible) to spit on the left side or under the left foot.

Book 4, Number 1119:

    Abu Huraira and Abu Sa'id narrated that the Messenger of Allah (may peace be upon him) saw sputum, and the rest of the hadith is the same.

Book 4, Number 1120:

    'A'isha reported: The Apostle of Allah (may, peace be upon him) saw spittle or snot or sputum, sticking to the wall towards Qibla and scratched it off.

Book 4, Number 1121:

    Abu Huraira reported that the Messenger of Allah (may peace be upon him) saw some sputum in the direction of the Qibla of the mosque. He turned towards people and said : How Is it that someone amongst you stands before his Lord and then spits out in front of Him? Does any one of you like that he should be made to stand in front of someone and then spit at his face? So when any one of you spits, he must spit on his left side under his foot. But if he does not find (space to spit) he should do like this. Qasim (one of the narrators) spat in his cloth and then folded it and rubbed it.

Book 4, Number 1122:

    Abu Huraira reported: I perceive as if I am looking at the Messenger of Allah (may peace be upon him) folding up a part of his cloth with another one.

Book 4, Number 1123:

    Anas b. Malik reported: The Messenger of Allah (may peace be upon him) said: When any one of you is engaged in prayer, he is holding intimate conversation with his Lord, so none of you must spit in front of him, or towards his right side, but towards his left side under his foot.

Book 4, Number 1124:

    Anas b. Malik reported: The Messenger of Allah (may peace be upon him) said: Spitting in a mosque is a sin, and its expiation is that it should be buried.

Book 4, Number 1125:

    Shu'ba reported: I asked Qatada about spitting, in the mosque. He said: I heard Anas b. Malik say: I heard the Messenger of Allah (may peace be upon him) say: Spitting in the mosque is a sin, and its expiation is that it should be buried.

Book 4, Number 1126:

    Abu Dharr reported: The Apostle of Allah (may peace be upon him) said: The deeds of my people, good and bad, were presented before me, and I found the removal of something objectionable from the road among their good deeds, and the sputum mucus left unburied in the mosque among their evil deeds.

Book 4, Number 1127:

    Abdullah b.Shakhkhir reported on the authority of his father that he said: I said prayer with the Messenger of Allah (may peace be upon him) and saw him spitting and rubbing it off with his shoe.

Book 4, Number 1128:

    'Abdullah b. Shakhkhir narrated it on the authority of his father that he said prayer with the Messenger of Allah (may peace be upon him), and he spat and then rubbed it off with his left shoe.

Chapter 58 : PERMISSIBILITY OF WEARING SHOES IN PRAYER

Book 4, Number 1129:

    Sa'd b. Yazid reported: I said to Anas b. Malik: Did the Messenger of Allah (may peace be upon him) pray while putting on the shoes? He said: Yes.

Book 4, Number 1130:

    Sa'd b. Yazid Abu Mas'ama reported: I said to Anas like (that mentioned above).

Chapter 59 : IT IS NOT ADVISABLE TO PRAY WEARING A CLOTH WHICH HAS DESIGNS OR MARKINGS OVER IT

Book 4, Number 1131:

    'A'isha reported: The Apostle of Allah (may peace be upon him) prayed in a garment which had designs over it, so he (the Holy Prophet) said: Take it to Abu Jahm and bring me a plain blanket from him,because its designs have distracted me.

Book 4, Number 1132:

    'A'isha reported: The Messenger of Allah (may peace be upon him) stood for prayer with a garment which had designs over it. He looked at these designs and after completing the prayer said: Take this garment to Abu Jahm b. Hudhaifa and bring me a blanket for it has distracted me just now.

Book 4, Number 1133:

    'A'isha reported: The Apostle of Allah (way peace be upon him) had a garment which had designs upon it and this distracted him in prayer. He gave it to Abu Jahm and took a plain garment in its place which is known anbijaniya.

Chapter 60 : WHEN FOOD IS BROUGHT BEFORE A MAN AND HE IS INCLINED TO TAKE IT, HE SHOULD NOT SAY PRAYER BEFORE EATING IT AND UNDESIRABILITY OF PRAYING WHILE FEELING THE CALL OF NATURE

Book 4, Number 1134:

    Anas b. Malik reported the Apostle of Allah (may peace be upon him) saying: When the supper is brought and the prayer begins, one, should first take food.

Book 4, Number 1135:

    Anas b. Malik reported: The Messenger of Allah (may peace be upon him) said: When the supper is brought before you, and it is also the time to say prayer, first take food before saying evening prayer and do not hasten (to prayer, leaving aside the food).

Book 4, Number 1136:

    This hadith has been narrated on the authority of Anas by another chain of transmitters.

Book 4, Number 1137:

    Ibn 'Umar reported: The Messenger of Allah (may peace be upon him) said: When the supper is served to any one of you and the prayer also begins. (in such a case) first take supper, and do not make haste (for prayer) till you have (taken the food).

Book 4, Number 1138:

    A hadith like this has been narrated from the Apostle of Allah (may peace be upon him) on the authority of Ibn 'Umar with another chain of transmitters.

Book 4, Number 1139:

    Ibn Atiq reported: Al-Qasim was in the presence of 'A'isha (Allah be pleased with her) that I narrated a hadith and Qasim was a man who committed errors in (pronouncing words) and his mother was a freed slave-girl. 'A'isha said to him: What is the matter with you that you do not narrate as this son of my brother narrated (the ahaditb)? Well I know from where you picked it up. This is how his mother brought him up and how your mother brought you up. Qasim felt angry (on this remark of Hadrat 'A'isha) and showed bitterness towards her. When he saw that the table had been spread for 'A'isha, he stood up, 'A'isha, said: Where are you going? He said: (I am going) to say prayer. She said: Sit down (to take the food). He said: I must say prayer. She said: Sit down, ) faithless, for I have heard the Messenger of Allah (may peace be upon him) say: No prayer can be (rightly said) when the food is there (before the worshipper), or when he is prompted by the call of nature.

Book 4, Number 1140:

    'Abdullah b. 'Atiq narrated from the Apostle (may peace be upon him) on the authority of 'A'isha, but he made no mention of the account of Qasim.

Chapter 61: FORBIDDANCE TO EAT GARLIC, ONIONS, AND ANYTHING OF OFFENSIVE SMELL WHILE COMING TO THE MOSQUE

Book 4, Number 1141:

    Ibn 'Umar reported: The Messenger of Allah (may peace be upon him) said during the battle of Khaybar: He who ate of this plant, i.e. garlic, should not come to the mosques. In the narration of Zubair, there is only a mention of "battle" and not of Khaybar.

Book 4, Number 1142:

    Ibn 'Umar reported: The Messenuer of Allah (may peace be upon him) said: He who eats of this (offensive) plant must not approach our mosque, till its odour dies: (plant signifies) garlic.

Book 4, Number 1143:

    Ibn Suhaib reported: Anas was asked about the garlic; he stated that the Messenger of Allah (may peace be upon him) had said: He who eats of this plant (garlic) should not approach us and pray along with us.

Book 4, Number 1144:

    Abu Huraira reported: The Messenger of Allah (may peace be upon him) said: He who eats of this plant (garlic) should not approach our mosque and should not harm us with the odour of garlic.

Book 4, Number 1145:

    Jabir reported: The Messenger of Allah (may peace be upon him) forbade eating of onions and leek. When we were overpowered by a desire (to eat) we ate them. Upon this he (the Holy Prophet) said: He who eats of this offensive plant must not approach our mosque, for the angels are harmed by the same things as men.

Book 4, Number 1146:

    Jabir reported: The Messenger of Allah (may peace be upon him) said: He who eats garlic or onion should remain away from us or from our mosque and stay in his house. A kettle was brought to him which had (cooked) vegetables in it, He smelt (offensive) odour in it. On asking he was informed of the vegetables (cooked in it). He said: Take it to such and such Companion. When he saw it, he also disliked eating it. (Upon this). he (the Holy Prophet) said: You may eat it, for I converse wkh one with whom you do not converse.

Book 4, Number 1147:

    Jabir b. 'Abdullah reported the Apostle of Allah (may peace be upon him) mying: He who eats of this (offensive) plant, i.e garlic, and sometirres he said: He who eats onion and garlic and leek, should not approach our mosque for the angels are harmed by the same things as the children of Adam.

Book 4, Number 1148:

    Ibn Juraij has narrated it with the same chain of transmitters: He who eats of this plant, i.e. garlic, should not come to us in our mosque, and he made no mention of onions or leek.

Book 4, Number 1149:

    Abu Sa'id reported: We made no transgression but Khaybar was conquered. We, the Companions of the Messenger of Allah (may peace be upon him), fell upon this plant. i e. garlic. because the people were hungry. We ate it to our heart's content and then made our way towards the mosque. The Messenger of Allah (may peace be upon him) sensed its odour and he said: He who takes anything of this offensive plant must not approach us in the mosque. The people said: Its (use) has been forbidden; its (use) bu been forbidden. This reached the Apostle of Allah (may peace be upon him) and he said: O people, I cannot forbid (the use of a thing) which Allah has made lawful, but (this garlic) is a plant the odour of which is repugnant to me.

Book 4, Number 1150:

    Abu Sa'id al-Khudri reported: The Messenger of Allah (may peace be upon him) along with his Companions happened to pass by a field in which onions were sown. The people stopped there and ate out of that, but some of them did not eat. Then they (Propbet's Companions) went to him. He (first) called those who had not eaten the onions and kept the others (who had taken onions) waiting till its odour vanished.

Book 4, Number 1151:

    Ma'dan b. Talha reported: 'Umar b. Khattab, delivered the Friday sermon and he made a mention of the Apostle of Allah (may peace be upon him) and Abu Bakr. He (further) said: I saw in a dream that a cock pecked me twice, and I perceive that my death is near. Some people have suggested me to appoint my successor. And Allah would not destroy His religion. His caliphate and that with which He sent His Apostle (may peace be upon him) If death approaches me soon, the (issue) of Caliphate (would be decided) by the consent of these six men with whom the Messenger of Allah (may peace be upon him) remained well pleased till his death. And I know fully well that some people would blame me that I killed with these very hands of mine some persons who apparently professed (Islam). And if they do this (blame me) they are the enemies of Allah, and are non-believers and have gone astray. And I leave not after me anything which to my mind seems more important than Kalala. And I never turned towards the Messenger of Allah (may peace be upon him) (for guidance) more often than this Kalala, and he (the Holy Prophet) was not annoyed with me on any other (issue) than this: (And he was so perturbed) that he struck his fingers on my chest and said: Does this verse. that is at the end of Surat al-Nisa'. which was revealed in the hot season not suffice you? And if I live longer I would decide this (problem so clearly) that one who reads the Qur'an, or one who does not read it, would be able to take (correct),decisions (under its light). He ('Umar) further said: Allah ! I call You witness on these governors of lands, that I sent them to (the peoples of these lands) so that they should administer justice amongst them, teach them their religion and the Sunnah of the Apostle of Allah (may peace be upon him), and distribute amongst them the spoils of war and refer to me that which they find difficult to perform. O people. you eat 'these two plants and these are onions and garlic. and I find them nothing but repugnant for I saw that when the Messenger of Allah (may peace be upon him) sensed the odour of these two from a person in a mosque, he was made to go to al-Baqi'. So he who eats it should (make its odour) die by cooking it well.

Book 4, Number 1152:

    This hadith has been narrated by Qatada with the same chain of transmitters.

Chapter 62 : IT IS FORBIDDEN TO CRY OUT FOR FINDING OUT THE LOST THING IN THE MOSQUE

Book 4, Number 1153:

    Abu Huraira reported: The Messenger of Allah (may peace be upon him) said: If anyone bears a man crying out in the mosque about something lie has lost, he should say: May Allah not restore it to you, for the mosques were not built for this.

Book 4, Number 1154:

    Abu Huraira reported Allah's Messenger (may peace be upon him) saying like this.

Book 4, Number 1155:

    Sulaiman b. Buraida narrated it on the authority of his father that a man cried out in the mosque saying: Who had called out for the red camel? Upon this the Apostle of Allah (may peace be upon him) said: May it not be restored to you! The mosques are built for what they are meant.

Book 4, Number 1156:

    Sulaiman b. Buraida reported on the authority of his father that when the Apostle of Allah (may peace be upon him) had said prayer a man stood up and said: Who called for a red camel? (Upon this) the Apostle of Allah (may peace be upon him) said: May it not be restored to you! The mosques are built for what they are meant.

Book 4, Number 1157:

    Ibn Buraida narrated it on the authority of his father that a Bedouin came when the Apostle of Allah (may peace be upon him) had completed the morning prayer. He thrust his head in the door of the mosque, and then the hadith (as narrated above) was narrated.

Book 4, Number 1158:

    This hadith has been reported by another chain of transmitters.

Chapter 63 : FORGETFULNESS IN PRAYER AND PROSTRATION AS COMPENSATION FOR IT

Book 4, Number 1159:

    Abu Huraira reported: The Messenger of Allah (may peace be upon him) said: When any one of you stands up to pray. the devil comes to him and confuses him to that he does not know how much he has prayed. If any one of you h" such an experience he should perform two prostrations while sitting down (in qa'da).

Book 4, Number 1160:

    This hadith has been narrated by al-Zubri with the same chain of transmitters.

Book 4, Number 1161:

    Abu Huraira reported: The Messenger of Allah (may peace be upon him) said: When there is a call to prayer the devil runs back breaking the wind so that he may not hear the call, and when the call is complete he comes back. And when the takbir is pronounced he again runs back, and when takbir is over he comes back and distracts a man saying: Remember such and such, remember such and such, referring to something the man did not have in his mind. with the result that he does not know how much he has prayed; so when any one of you is not sure how much he has prayed. he should perform two prostrations while sitting (qa'da).

Book 4, Number 1162:

    Abu Huraira reported: The Messenger of Allah (may peace be upon him) said: The devil takes to his heels breaking wind when the prayer begins. and the rest is the same but with this addition: "He (the devil) makes him think of pleasant things (or things productive of enjoyment) and of the things wished for, and reminds him of such needs which he had forgotten."

Book 4, Number 1163:

    'Abdullah b. Buhaina reported: The Messenger of Allah (may peace be upon him) led us two rak'ahs of prayer in one of the (obligatory) prayers and then got up and did not sit. and the people stood up along with him. When he finished the prayer and we expected him to pronounce salutation. he said: “Allah is Most Great” while sitting and made two prostrations before salutation and then pronounced (the, final) salutation.

Book 4, Number 1164:

    'Abdullah b. Buhaina al-Asadi, the ally of Abual-Muttalib, reported: The Messenger of Allah (may peace be upon him) stood up in the noon prayer (though) he hadith sit (after the two rak'ahs). When he completed the prayer he performed two prostrations and said, "Allah is the Most Great" in each prostration, while he was sitting before pronouncing salutation, and the people performed prostration along with him. That was a compensation for he had forgotten to observe jalsa (after two rak’ahs).

Book 4, Number 1165:

    'Abdullah b. Malik ibn Buhaina al-Asadi reported: The Messenger of Allah (may peace be upon him) stood up (at the end of two rak’ahs) when he had to sit and proceeded on with the prayer. But when he was at the end of the prayer, he performed a prostration before the salutation and then pronounced the salutation.

Book 4, Number 1166:

    Abu Sa'id al-Khudri reported: The Messenger of Allah (may peace be upon him) said: When any one of you is in doubt about his prayer and he does Dot know how much he has prayed, three or four (rak'ahs). he should cast aside his doubt and base his prayer on what he is sure of. then perform two prostrations before giving salutations. If he has prayed five rak’ahs, they will make his prayer an even number for him, and if he has prayed exactly four, they will be humiliation for the devil.

Book 4, Number 1167:

    This hadith has been narrated by Zaid b. Aslam with the same chain of transmitters and he said: He should perform two prostrations before the salutation, as it was mentioned by Sulaiman b. Bilal.

Book 4, Number 1168:

    ‘Alqama narrated It on the authority of 'Abdullah (b. Mas’ud) who said: The Messenger of Allah (may peace be upon him) said the prayer; (the narrator added): He made some act of omission or commission when he pronounced salutation; it was said to him: Messenger of Allah, is there something new about (he prayer? He (the Holy Prophet) said: What is it? They said: You said prayer in such and such away. He (the narrator) said: He (the Holy Prophet) turned his feet and faced the Qibla and performed two prostrations and then pronounced salutations, and then turned his face towards us and said: If there is anything new about prayer (new command from the Lord) I informed you of that. But I am a human being and I forget as you for. get, so when I forget, remind me, and when any one of you is in doubt about his prayer. he should aim at what Is correct. and complete his prayer in that respect and then make two prostrations.

Book 4, Number 1169:

    This hadith has been narrated by Mansur with the same chain of transmitters, with a slight modification of words.

Book 4, Number 1170:

    This hadith is reported by Mansur with the same chain of transmitters, but with these words: "He should aim at correct (prayer) and it is advisable."

Book 4, Number 1171:

    This hadith has been narrated by Mansur with the same chain of transmitters with the words: I, He should aim at what is correct and complete."

Book 4, Number 1172:

    This hadith has been narrated by Mansur with the same chain of transmitters and said: "He should aim at correctness and that is right."

Book 4, Number 1173:

    This hadith has been reported by Mansur with the same chain of transwitters and he said: "He should aim at what is according to him correct."

Book 4, Number 1174:

    This hadith has been narrated by Mansur and he said: "He should aim at correctness."

Book 4, Number 1175:

    'Abdullah (b. Mas’ud) reported: The Apostle of Allah (may peace be upon him) said five rak'ahs of the noon prayer and when he completed the prayer, It was said to him: Has there been (commanded) an addition In prayer? He said: What is it? They said: You have said five rak’ahs, so he performed two prostrations.

Book 4, Number 1176:

    Alqama reported: He (the Holy Prophet) had led them five rak’ahs in prayer.

Book 4, Number 1177:

    Ibrahim b.Suwaid-reported: 'Alqama led us in the noon prayer and be offered five rak'ahs; when the prayer was complete, the people said to him: Abu Shibl, you have offered five rak’ahs. He said: No, I have not done that. They said: Yes (you said five rak’ahs). He (the narrator) said: And I was sitting in a corner among people and I was just a boy. I (also) said: Yes, you have offered five (rak’ahs). He said to me: O, one-eyed, do you say the same thing ? I said: Yes. Upon this he turned (his face) and performed two prostrations and then gave salutations, and then reported 'Abdullah as saying: The Messenger of Allah (may peace be upon him) led us in prayer and offered five rak'ahs. And as he turned away the people began to whisper amongst themselves. He (the Holy Prophet) said: What is the matter with you ? They said: Has the prayer been extended? He said: No. They said: You have in fact said five rak’ahs. He (the Holy Prophet) then turned his back (and faced the Qibla) and performed two prostrations and then gave salutations and further said: Verily I am a human being like you, I forget just as you forget. Ibn Numair made this addition: "When any one of you forgets, he must perform two prostrations."

Book 4, Number 1178:

    'Abdullah (b. Mas'ud) reported: The Messenger of Allah (may peace be upon him) led us five (rak’ahs in prayer). We said: Messenger of Allah, has the prayer been extended? He said: What is the matter? They said: You have said five (rak’ahs). He (the Holy Prophet) said: Verily I am a human being like you. I remember as you remember and I forget just as you forget. He then performed two prostrations as (compensation of) forgetfulness.

Book 4, Number 1179:

    'Abdullah (b. Mas’ud) reported: The Messenger of Allah (may peace be upon him) said prayer and he omitted or committed (something). Ibrahim (one of the narrators of this hadith) said: It is my doubt, and it was said: Messenger of Allah, has there been any addition to the prayer? He (the Holy Prophet) said: Verily I am a human being like you. I forget just as you forget so when any one of you forgets, he must perform two prostrations, and he (the Holy Prophet) was sitting and then the Messenger of Allah (may peace be upon him) turned (his face towards the Qibla) and performed two prostrations.

Book 4, Number 1180:

    'Abdullah b. Mas’ud reported: The Apostle of Allah (may peace be upon him) performed two prostrations for forgetfulness after salutation and talking.

Book 4, Number 1181:

    Abdullah reported: We prayed along with the Messenger of Allah (may peace he upon him) and he committed or omitted (something). Ibrahim said: By Allah, this is a misgiving of mine only. We said: Messenger of Allah, is there something new about the prayer ? He (the Holy Prophet) said: No. We told him about what he had done. He (the Holy Prophet) said : When a man commits or omits (something in prayer), he should perform two prostrations, and he then himself performed two prostrations.

Book 4, Number 1182:

    Ibn Sirin reported Abu Huraira as saying: The Messenger of Allah (may peace be upon him) led us in one of the two evening prayers, Zuhr or 'Asr, and gave salutations after two rak'ahs and going towards a piece of wood which was placed to the direction of the Qibla in the mosque, leaned on it looking as if he were angry. Abu Bakr and Umar were among the people and they were too afraid to speak to him and the people came out in haste (saying) : The prayer has been shortened. But among them was a man called Dhu'I-Yadain who said: Messenger of Allah, has the prayer been shortened or have you forgotten ? The Apostle of Allah (may peace be upon him) looked to the right and left and said: What was Dhu'I-Yadain saying? They said: He is right. You (the Holy Prophet) offered but two rak'ahs. lie offered two (more) rak’ahs and gave salutation, then said takbir and prostrated and lifted (his head) and then said takbir and prostrated, then said takbir and lifted (his head). He (the narrator) says: It has been reported to me by Imran b. Husain that he said : He (their) gave salutation.

Book 4, Number 1183:

    Abu Huraira reported : The Messenger of Allah (may peace be upon him) led us in one of the evening prayers. And this hadith was narrated like one transmitted by Sufyan.

Book 4, Number 1184:

    Abu Huraira reported: The Messenger of Allah (may peace be upon him) led us in the 'Asr prayer and gave salutation after two rak'ahs. Dhu'l-Yadain (the possessor of long arms) stood up and said: Messenger of Allah, has the prayer been shortened or have you forgotten ? The Messenger of Allah (may peace be upon him) said: Nothing like this has happened (neither the prayer has been shortened nor have I forgotten). He (Dhu'l-Yadain) said: Messenger of Allah, something has definitely happened. The Messenger of Allah (may peace be upon him) turned towards people and said: Is Dhu'l-Yadain true (in his assertion) ? They said : Messenger of Allah, he is true. Then the Messenger of Allah (may peace be upon him) completed the rest of the prayer. and then performed two prostrations while he was sitting after salutation.

Book 4, Number 1185:

    Abu Huraira reported: The Messenger of Allah (may peace be upon him) said two rak'ahs of the noon prayer and then gave salutation when a man from Band Sulaim came to him and said: Messenger of Allah. has the prayer been shortened, or have you forgotten ?-and the rest of the hadith is the same.

Book 4, Number 1186:

    Abu Huraira reported : I offered with the Apostle of Allah (may peace be upon him) the noon prayer and the Messenger of Allah (may peace be upon him) gave salutation after two rak'ahs. A person from Bani Sulaim stood up, and the rest of the hadith was narrated as mentioned above.

Book 4, Number 1187:

    'Imran b. Husain reported: The Messenger of Allah (may peace be upon him) said the afternoon prayer and gave the salutation. at the end of three rak’ahs and then went into his house. A man called al-Khirbaq, who bad long aims, got up and went to him, and addressed him as Messenger of Allah and mentioned to him what he had done. He came out angrily trailing his mantle, and when he came to the people he said: Is this man telling the truth ? They said : Yes. He then said one rak'ah and then gave salutation and then performed two prostrations and then gave salutation.

Book 4, Number 1188:

    Imran b. Husain reported: The Messenger of Allah (may peace be upon him) said three rak'ahs of the 'Asr prayer and then got up and went to his apartment. A man possessing large arms stood up and said: Messenger of Allah, bias the player been shortened ? He came out angrily, and said the rak'ah which he had omitted and then gave salutation. then performed two prostrations of forgetfulness and then gave salutation.

Chapter 64 : PROSTRATION WHILE RECITING THE QUR'AN

Book 4, Number 1198:

    Ibn 'Umar reported: The Messenger of Allah (may peace be upon him) while reciting the Qur’an recited its scarab containing sajda, and he performed prostration and we also prostrated along with him (but we were so overcrowded) that some of us could not find a place for our forehead (when prostrating ourselves).

Book 4, Number 1190:

    Ibn 'Umar reported: Sometimes the Messenger of Allah (may peace be upon him) recited the Qur’an, and would pass by (recite) the verse of sajda and performed prostration and he did this along with us, but we were so crowded in his company that none of us could find a place for performing prostration. (and it was done on occasions) other than prayer.

Book 4, Number 1191:

    Abdullah (b. 'Umar) reported: The Apostle of Allah (may peace be upon him) recited (Surat) al Najm and performed prostration during its recital and all those who were along with him also prostrated themselves except one old man who took a handful of pebbles or dust in his palm and lifted it to his forehead and said: This is sufficient for me. 'Abdullah said: 1 saw that he was later killed in a state of unbelief.

Book 4, Number 1192:

    'ta’ b. Yasar reported that he had asked Zaid b. Thabit about recital along with the Imam, to which he said: There should be no recital along with the Imam in anything, and alleged that he recited: "By the star when it sets"(Surah Najm) before the Messenger of Allah (may peace be upon him) and he did not prostrate himself.

Book 4, Number 1193:

    Abu Salama b. 'Abual-Rahman reported: Abu Huraira recited before them : "hen the heaven burst asunder" (al-Qur'an, lxxxiv. 1) and performed prostration. After completing (the prayer) he informed them that the Messenger of Allah (may peace be upon him) has prostrated himself at it (this verse).

Book 4, Number 1194:

    A hadith like this has been narrated by AbuSalama on the authority of Abu Huraira.

Book 4, Number 1195:

    Abu Huraira reported: We performed prostration along with the Messenger of Allah (may peace be upon him) (as he recited these verses:) "When the heaven burst asunder" and "Read in the name of Thy Lord" (al-Qur'an, xcvi. 1).

Book 4, Number 1196:

    Abu Huraira reported: The Messenger of Allah (may peace be upon him) prostrated himself (while reciting these verses). "When the heaven burst asunder"; “Read in the name of Thy Lord”.

Book 4, Number 1197:

    A hadith like this has been transmitted by Abual-Rahman al-Araj on the authority of Abu Huraira.

Book 4, Number 1198:

    Abu Rafi’ reported: I said the night prayer along with Abu Huraira and -as he recited: "When the heaven burst asunder," he performed prostration. Isaid to him: What prostration is this? He said: I prostrated myself (on this occasion of recital) behind Abu'I-Qasim (Muhammad. may peace be upon him), and Iwould go on doing this till I meet him (in the next world). Ibn 'Abu al-A'la said: (Abu Huraira uttered this:) I would not abandon performing prostration.

Book 4, Number 1199:

    This hadith has been narrated by Tamimi with the same chain of transmitters except for this that they made no mention of: "Behind Abu’l-Qasim" (may peace be upon him).

Book 4, Number 1200:

    Abu Rafi’ reported: I saw Abu Huraira performing prostration (while reciting this verse:) "When the heaven burst asunder." I said to him: Do you prostrate yourself (while reciting) i? He said: Yes, I saw my best Friend (may peace be upon him) prostrating himself on (the recital of this verse) and I shall continue prostrating till I meet him. Shu’ba asked: Do you mean (by Friend) the Apostle of Allah (may peace be upon him)? He said: Yes.

Chapter 65 : HOW JALSA IS TO BE OBSERVED

Book 4, Number 1201:

    Abdullah b. Zubair narrated on the authority of his father: When the Messenger of Allah (may peace be upon him) sat in prayer. he placed the left foot between his thigh and shank and stretched the right foot and placed his left hand or his left knee and placed his right hand on his right thigh, and raised his finger.

Book 4, Number 1202:

    'Abdullah b. Zubair narrated on the authority of his father that when the Messenger of Allah (may peace be upon him) sat for supplication, i.e. tashahhud (blessing and supplication), he placed his right hand on his right thigh and his left hand on his left thigh, and pointed with his forefinger , and placed his thumb on his (milddle) finger, and covered his knee with the palm of his left hand..

Book 4, Number 1203:

    Ibn 'Umar reported that when the Messenger of Allah (may peace be upon him) sat for tashahhud he placed his left hand on his left knee. and his right hand on his right knee. and he raised his right finger, which is next to the thumb, making supplication in this way, and he stretched his left hand on his left knee. Another version on the authority of Ibn Umar says: When the Messenger of Allah (may peace be upon him) sat for tashahhud, he placed his left hand on his left knee and placed his right hand on his right knee, and he formed a ring like (fifty-three) and pointed with his finger of attestation.

Book 4, Number 1204:

    'Ali b. 'Abual-Rahman al-Mu'awi reported: 'Abdullah b. Umar saw me playing with pebbles during prayer. After finishing the prayer he forbade me (to do it) and said: Do as the Messenger of Allah (may peace be upon him) used to do. I said: How did Allah's Messenger (may peace be upon him) do? He said that he (the Messenger of Allah) sat at tashahhud, placed his right palm on the right thigh and closed all his fingers and pointed with the help of finger next to the thumb, and placed his left palm on his right thigh.

Book 4, Number 1205:

    This hadith has been narrated by another chain of transmitters.

Chapter 66 : TASLIM AT THE COMPLETION OF THE PRAYER

Book 4, Number 1206:

    Abu Ma'mar reported: There was an Amir in Mecca who pronounced taslim twice. Abdullah said: Where did he get this sunnah? Al-Hakam said: There is a hadith to the effect that the Messenger of Allah (may peace be upon him) did like It.

Book 4, Number 1207:

    'Abdullah reported: An Amir or a person pronounced taslim twice. ‘Abdullah said: Where did he get this sunnah?

Book 4, Number 1208:

    'Amir b. Sa'd reported: I saw the Messenger of Allah (may peace be open him) pronouncing taslim on his right and on his left till I saw the whiteness of his cheek.

Chapter 67 : DHIKR AFTER THE PRAYER

Book 4, Number 1209:

    Ibn 'Abbas said: We used to know that Allah’s Messenger (may peace be upon him) had finished his prayer when we heard the takbir (Allah-O-Akbar).

Book 4, Number 1210:

    Ibn 'Abbas reported: We knew the finishing of the prayer of the Messenger of Allah (may peace be upon him) through takbir. 'Amr (b. Dinar) said: I made a mention of it to Abu Mas'ud. hue he rejected it and said: I never narrated it to you. 'Amr said: He did narrate it before this.

Book 4, Number 1211:

    Ibn 'Abbas reported: Dhikr (mentioning the name of Allah) in a loud voice after obligatory prayers was (a common practice) during the lifetime of the Apostle of Allah (may peace be upon him); and when I heard that I came to knew that they (the people) had finished the prayer.

Chapter 68 : DESIRABILITY OF SEEKING REFUGE FROM THE TORMENT OF THE GRAVE

Book 4, Number 1212:

    'A'isha reported: The Holy Prophet (may peace be upon him) entered my house when a Jewess was with me and she was saying: Do you know that you would be put to trial in the grave? The Messenger of Allah (may peace be upon him) trembled (on hearing this) and said: It is the Jews only who would-be put to trial. 'A'isha said: We passed some nights and then the Messenger of Allah (may peace be upon him) said: Do you know that it has been revealed to me: "You would be put to trial in the grave"? 'A'isha said: 1 heard the Messenger of Allah (may peace be upon him) seeking refuge from the torment of the grave after this.

Book 4, Number 1213:

    Abu Huraira reported. I heard the Messenger of Allah (may peace be upon him) seeking refuge from the torment of the grave after this (after the revelation).

Book 4, Number 1214:

    'A'isha reported: There came to me two old women from the old Jewesses of Medina and said: The people of the grave are tormented in their graves. I contradicted them and I did not deem it proper to testify them. They went away and the Messenger of Allah (may peace be upon him) came to me and I said to him: Messenger of Allah I there came to me two old women from the old Jewesses of Medina and asserted that the people of the graves would be tormented therein. He (the Prophet) said: They told the truth; they would be tormented (so much) that the animals would listen to it. She ('A'isha) said: Never did I see him (the Holy Prophet) afterwards but seeking refuge from the torment of the grave in prayer.

Book 4, Number 1215:

    Masruq reported this hadith on the authority of 'A'isha who said: Never did he (the Holy Prophet) say prayer after this in which I did not hear him seeking refuge from the torment of the grave.

Book 4, Number 1216:

    'A'isha reported: 1 heard the Messenger of Allah (may peace be upon him) seeking refuge from the trial of Dajjal (Antichrist) in prayer.

Book 4, Number 1217:

    Abu Huraira reported: The Messenger of Allah (way peace be upon him) said: When any one of you utters tashahhud (in prayer) he must seek refuge with Allah from four (trials) and should thus say: “O Allah ! I seek refuge with Thee from the torment of the Hell, from the torment of the grave, from the trial of life and death and from the evil of the trial of Masih al-Dajjal" (Antichrist).

Book 4, Number 1218:

    ‘A'isha, the wife of the Apostle of Allah (may peace be upon him) reported: The Apostle of Allah (may peace be upon him) used to supplicate in prayer thus: “O Allah ! I seek refuge with Thee from the torment of the grave, and I seek refuge with Thee from the trial of the Masih al-Dajjal (Antichrist) and I seek refuge with Thee from the trial of life and death. O Allah ! I seek refuge with Thee from sin and debt." She ('A'isha) reported: Someone said to him -(the Holy Prophet) : Messenger of Allah ! why is it that you so often seek refuge from debt? He said : When a (person) incurs debt, (he is obliged) to tell lies and break promise.

Book 4, Number 1219:

    Abu Huraira reported: The Messenger of Allah (may peace be upon him) said: When any one of you completes the last tashahhud. he should seek refuge with Allah from four (trials). I.e. from the torment of Hell, from the torment of grave, from the trial of life and death.-and from the mischief of Masih at-Dajjal (Antichrist). This hadith has been narrated by al-Auza’i with the same chain of transmitters but with these words: "When any one of you completes the tashahhud" and he made no mention of the words "the last".

Book 4, Number 1220:

    Abu Huraira reported: The Apostle of Allah (may peace be upon him) said: O Allah ! I seek refuge with Thee from the torment of the grave, and the torment of Hell, and the trial of life and death and the mischief of Masih al-Dajjal.

Book 4, Number 1221:

    Abu Huraira reported the Messenger of Allah (may peace be upon him) as saying: Seek refuge with Allah from the torment of Hell, seek refuge with Allah from the torment of the grave, and seek refuge with Allah from the trial of Masih al-Dajjal and seek refuge with Allah from the trial of life and death.

Book 4, Number 1222:

    A hadith like this has been transmitted by Ibn Tawus from his father on the authority of AbuHuraira.

Book 4, Number 1223:

    A hadith like this has been transmitted by A'raj on the authority of Abu Huraira.

Book 4, Number 1224:

    Abu Huraira reported that the Apostle of Allah (may peace be upon him) use(t to seek refuge from the torment of the grave, torment of Hell and the trial of Dajjal.

Book 4, Number 1225:

    Ibn 'Abbas reported that the Messenger of Allah (may peace he upon him) used to teach them this supplication (in the same spirit) with which he used to teach them a surah of the Qur’an. He would thus instruct us: "Say, O Allah I we seek refuge with Thee from the torment of Hell, and I seek refuge with Thee from the torment of the grave, and I seek refuge with Thee from the trial of Masih al-Dajjal. and I seek refuge with Thee from the trial of life and death." Muslim b. Hajjaj said: It has reached me that Tawus said to his son: Did you make this supplication in prayer? He said: No. (Upon this) he (Tawus) said: Repeat the prayer. Tawus has narrated this hadith through three or four (transmitters) with words to the same effect.

Chapter 69 : EXCELLENCE OF DHIKR AFTER PRAYER AND ITS DESCRIPTION

Book 4, Number 1226:

    Thauban reported: When the Messenger of Allah (may peace be upon him) finished his prayer. he begged forgiveness three times and said: O Allah ! Thou art Peace, and peace comes from Thee; Blessed art Thou, O Possessor of Glory and Honour. Walid reported: I said to Auza’i: How Is the seeking of forgiveness? He replied: You should say: ,I beg forgiveness from Allah, 1 beg forgiveness from Allah."

Book 4, Number 1227:

    ‘A'isha reported: When the Messenger of Allah (may peace be upon him) pronounced salutation, he salutation longer than it took him to say : O Allah: Thou art Peace, and peace comes from Thee, blessed art Thou, Possessor of Glory and ]Honour; and in the narration of Ibn Numair the words are: "O Possessor of Glory and Honour."

Book 4, Number 1228:

    Ibn Numair narrated it with the same chain of transmitters and said: O Possessor of Glory and Honour.

Book 4, Number 1229:

    A hadith like this has been transmitted by Abdullah b. Harith on the authority of A'isha except for the words that he (the Holy Prophet) used to say: " 0 Possessor of Glory and Honour."

Book 4, Number 1230:

    Mughira b. Shu'ba wrote to Mu'awiya: When the Messenger of Allah (may peace be upon him) finished the prayer and pronounced salutation he uttered (this supplication) : "There is no god but Allah. He is alone, Who has no partner. To Him belongs the sovereignty and to Him praise is due and He is Potent over every. thing. O Allah ! no one can withhold what Thou givest, or give what Thou withholdest, and the riches cannot avail a wealthy person with Thee."

Book 4, Number 1231:

    A hadith like this has been narrated by Mughira b. Shu'ba with another chain of transmitters. Abu Bakr and Abu Kuraib narrated in their narration (that Warrad reported): Mughira gave me dictation of it and 1 wrote it to Mu’awiya.

Book 4, Number 1232:

    Warrad, the freed slave of Mughira b. Shu’ba, reported: Mughira b. Shu’ba wrote to Mu’awiya (it was Warrad who wrote this letter for him, i.e. Mughira): I heard the Messenger of Allah (may peace be upon him) saying: "When the salutation is pronounced." and the rest of the hadith is the same except this that he made no mention of: "He is Potent over everything."

Book 4, Number 1233:

    Warrad, the scribe of Mughira b. Shu'ba, reported: Mu’awiya wrote to Mughira (the contents) of the hadith as transmitted by Mansur and A'mash.

Book 4, Number 1234:

    Warrad, the scribe of Mughira b. Shu’ba, reported: Mu'awiya wrote to Mughira: Write to me anything which you heard from the Messenger of Allah (may peace be upon him). So he (Mughira) wrote to him (Mu’awiya): I heard the Messenger of Allah (may peace be upon him) uttering (these words) at the completion of prayer: "There is no god but Allah. He is alone and there is no partner with Him. Sovereignty belongs to Him and to Him is praise due and He is Potent over everything. O Allah ! no one can withhold what Thou givest, or give what Thou withholdest, and riches cannot avail a wealthy person with Thee."

Book 4, Number 1235:

    Abu Zubair reported: Ibn Zubair uttered at the end of every prayer after pronouncing salutation (these words): "There is no god but Allah. He is alone. There is no partner with Him. Sovereignty belongs to Him and He is Potent over everything. There is no might or power except with Allah. There is no god but Allah and we do not worship but Him alone. To Him belong all bounties, to Him belongs all Grace, and to Him is worthy praise accorded. There is no god but Allah, to Whom we are sincere in devotion, even though the unbelievers should disapprove it." (The narrator said): He (the Holy Prophet) uttered it at the end of every (obligatory) prayer.

Book 4, Number 1236:

    Abu Zubair reported: Abdullah b Zubair used to say La ilaha il-Allah at the end of every prayer like the hadith narrated by Ibn Numair and he reported it in the end, and then reported Ibn Zubair saying: The Messenger of Allah (may peace be upon him) uttered La ilaha il-Allah at the end of every prayer.

Book 4, Number 1237:

    Abu Zubair reported: I heard Abdullah b. Zubair addressing (people) on the pulpit and saying: When the Messenger of Allah (may peace be upon him) pronounced salutation at the end of the prayer or prayers, and then he made a mention of the hadith as transmitted by Hisham b. 'Urwa.

Book 4, Number 1238:

    Abu Zubair al-Makki reported that he had heard 'Abdullah b. Zubair uttering (the words) like that of the hadith (narrated above) at the end of the prayer after pronouncing salutation. He at the conclusion also said that he was making a mention of that from the Messenger of Allah (may peace be upon him).

Book 4, Number 1239:

    Abu Huraira reported: The poor amongst the emigrants came to the Messenger of Allah (may peace be upon him) and said: The possessors of great wealth have obtained the highest ranks and the lasting bliss. lie (the Holy Prophet) said: How Is that? They said: They pray as we pray, and they observe fast as we observe fast, and they give charity but we do not give charity, and they set slaves free but we do not set slaves free. Upon this the Messenger of Allah (may peace be upon him) said: Shall A not teach you something by which you will catch upon those who have preceded you, and get ahead of those who come after you, only those who do as you do being more excellent than you? They said: Yes, Messenger of Allah. He (the Holy Prophet) said: Extol Allah, declare His Greatness, and Praise Him thirty-three times after every prayer. Abu Salih said: The poor amongst the emigrants returned to the Messenger of Allah (may peace upon him) saying: Our brethren, the possessors, of property have heard what we have done and they did the same. So the Messenger of Allah (may peace be upon him) said: This is Allah's Grace which He gives to whom He wishes. Sumayy reported: I made a mention of this hadith to some members of my family (and one of them) said: You have forgotten; he (the Holy Prophet) had said (like this):."Extol Allah thirty-three time. praise Allah thirty-three times and declare His Greatness thirty-three times. Ibn 'Ajjan said: 1 made a mention of this hadith to Raja' b. Haiwata and he narrated to me a hadith like this from AbuSalih from the Messenger of Allah (may peace be upon him) on the authority of Abu Huraira.

Book 4, Number 1240:

    Abu Huraira narrated it from the Messenger of Allah (may peace be upon him) that they (the poor among the emigrants) said: Messenger of Allah, the possessors of great wealth have obtained the highest ranks and lasting bliss, and the rest of the hadith is the same as transmitted by Qutaiba on the authority of Laith except that he inserted the words of Abu Salih in the narration of Abu Huraira that "the poor of the emigrants came back," to the end of the hadith,, but this addition was made that Suhail said (that every part of the supplication, i.e. Glorification of Allah, His Praise and declaration of His Greatness) should be uttered eleven times making the total as thirty-three.

Book 4, Number 1241:

    Ka'b b. 'Ujra reported Allah's Messenger (may peace be upon him) as saying: There are certain ejaculations, the repeaters of which or the performers of which after every prescribed prayer will never be caused disappointment: "Glory be to Allah " thirty-three times. "Praise be to Allah" thirty-three times, and "Allah is most Great" thirty-four times.

Book 4, Number 1242:

    Ka'b b. 'Ujra reported Allah's Messenger (may peace be upon him) as saying: There are certain ejaculations, the repeaters of which or the performers of which at the end of every prayer will never be caused disappointment: "Glory be to Allah" thirty-three times, "Praise be to Allah" thirty-three times, and "Allah is most Great" thirty-four times.

Book 4, Number 1243:

    Abu Huraira reported Allah's Messenger (may peace be upon him) as saying : If anyone extols Allah after every prayer thirty-three times, and praises Allah thirty-three times, and declares His Greatness thirty-three times, ninety-nine times in all, and says to complete a hundred: "There is no god but Allah, having no partner with Him, to Him belongs sovereignty and to Him is praise due, and He is Potent over everything, " his sins will be forgiven even If these are as abundant as the foam of the sea.

Book 4, Number 1244:

    This hadith has been narrated by Abu Huraira by another chain of transmitters.

Chapter 70 : WHAT IS TO BE RECITED BETWEEN TAKBIR TAHRIMA AND RECITATION OF THE QUR'AN

Book 4, Number 1245:

    Abu Huraira reported that Allah's Messenger (may peace be upon him) used to observe, silence for a short while between the takbir (at the time of opening the prayer) and the recitation of the Qur’an. I said to him: Messenger of Allah, for whom I would give my father and mother in ransom, what do you recite during your period of silence between the takbir and the recitation? He said: I say (these words): “ O Allah , remove my sins from me as Thou hast removed the East from the West. O Allah purify me from sins as a white garment is purified from filth. O Allah !wash away my sins with water, snow and hall."

Book 4, Number 1246:

    Abu Huraira reported that when the Messenger of Allah (may peace be upon him) stood up for the second rak’ah he opened it with the recitation of the praise of Allah, the Lord of universe (al-Fatiha), and he did not observe silence (before the recitation of al-Fatiha).

Book 4, Number 1247:

    Anas reported: A man came panting and entered the row of worshippers and said : Praise be to Allah, much praised and blessed. When the Messenger of Allah (may peace be upon him) finished the prayer he said: Who amongst you uttered these words? The people remained silent. He (the Holy Prophet again said)-: Who amongst you uttered these words? He said nothing wrong. Then a man said: I came and had a difficulty in breathing, so I uttered them. He replied: I saw twelve angels facing one another as to who will take them up (to Allah).

Book 4, Number 1248:

    Ibn 'Umar reported: While we said prayer with the Messenger of Allah (may peace be upon him), one among the people said: Allah is truly Great, praise be to Allah in abundance. Glory be to Allah in the morning and the evening. The Messenger of Allah (may peace be upon, him) said: Who uttered such and such a word? A person among the people said: It is I, Messenger of Allah (who have recited these words). He (the Holy Prophet) said: It (its utterance) surprised me, for the doors of heaven were opened for It. Ibn 'Umar said: I have not abandoned them (these words) since I heard the Messenger of Allah (may peace be upon him) saying this.

Chapter 71 : DESIRABILITY OF GOING TO PRAYER WITH DIGNITY AND TRANQUILLITY AND FORBIDDANCE OF GOING TO IT IN HOT HASTE

Book 4, Number 1249:

    Abu Huraira reported: I heard the Messenger of Allah (may peace be upon him) saying: When the Iqama has been pronounced for prayer, do not go running to it, but go walking in tranquillity and pray what you are in time for, and complete what you have missed.

Book 4, Number 1250:

    Abu Huraira reported that the Messenger of Allah (may peace be upon him) said: When the words of Iqama are pronounced, do not come to (prayer) running, but go with tranquillity, and pray what you are in time for, and complete (what you have missed) for when one of you is preparing for prayer he is in fact engaged in prayer.

Book 4, Number 1251:

    Abu Huraira reported ahadith from the Messenger of Allah (may peace be upon him), and one of them is that the Messenger of Allah (may peace be upon), said: When the call is made for prayer come to it walking with tranquillity, and pray what you are in time for, and complete what you have missed.

Book 4, Number 1252:

    Abu Huraira reported: The Messenger of Allah (may peace be upon him) said: When the words of Iqama are pronounced, none of you should run to it (to join the prayer) but walk with tranquillity and dignity, and pray what you are in time for and complete what has gone before (what the Imam has completed).

Book 4, Number 1253:

    Abdullah b. Abu Qatada reported on the authority of his father: While we said our prayer with the Messenger of Allah (may peace be upon him) he heard tumult. (At the end of the prayer) he (the Holy Prophet) said: What is the matter with you? They said: We hastened to prayer. He (the Holy Prophet) said: Don't do that; when you come for prayer, there should be tranquillity upon you. Pray (along with the Imam) what you can find and complete what preceded you.

Book 4, Number 1254:

    This hadith has been narrated by Shaiban with the same chain of transmitters

Chapter 72 : WHEN SHOULD THE PEOPLE STAND UP FOR PRAYER

Book 4, Number 1255:

    Abu Qatada reported: The Messenger of Allah (may peace be upon him) said: When the Iqama is pronounced do not get up till you see me Ibn Hatim was in doubt whether it was said: "When the Iqama is pronounced" or "When call is made".

Book 4, Number 1256:

    Abu Salama son of Abd al-Rahman b. Auf reported Abu Huraira as saying: Iqama was pronounced and we stood up and made rows straight till he (the Holy Prophet) stood at his place of worship (the place ahead of the rows where he stood to lead the prayer) before takbir tahrima. He reminded to (himself something) and went back saying that we should stand at our places and not leave them. We waited, till he came back to us and he had taken a bath and water trickled out of his head and then led us in prayer.

Book 4, Number 1257:

    Abu Salama reported Abu Huraira as saying: Iqama was pronounced. ant the people had formed themselves into rows. The Messenger of Allah (may peace be upon him) came out and stood at his place, and then pointed out with his hand that we should stand at our places. He then went away and took a bath and water trickled from his head and then led them in prayer.

Book 4, Number 1258:

    Abu Salama reported on the authority of Abu Huraira that when Iqama was pronounced for the Messenger of Allah (may peace be upon him), the people occupied their places in the rows before the Apostle of Allah (way peace be upon him) stood up at his place.

Book 4, Number 1259:

    Jabir b. Samura reported: Bilal summoned to prayer as the sun declined but did not pronounce Iqama till the Apostle of Allah (may peace be upon him) came out and the Iqama was pronounced on seeing him.

Chapter 73 : HE WHO CAME UP WITH THE RAKIAH, HE IN FACT CAME UP WITH THE PRAYER (LED IN CONGREGATION WITH THE IMAM)

Book 4, Number 1260:

    Abu Huraira reported the Apostle of Allah (may peace be upon him) as saying: He who finds a rak’ah of the prayer, he in fact finds the prayer.

Book 4, Number 1261:

    Abu Huraira reported the Messenger of Allah (may peace be upon him) as saying: He who finds one rak'ah of the prayer with the Imam, he in fact finds the prayer.

Book 4, Number 1262:

    This hadith has been narrated on the authority of Malik and there is no mention of "along with the Imam" and In the hadith transmitted by Abdullah the words are: "he in fact finds the entire prayer".

Book 4, Number 1263:

    Abu Huraira reported: The Messenger of Allah (may peace be upon him) said: He who finds one rak'ah at dawn before the rising of the sun, he in fact finds the dawn prayer. and he who finds one rak'ah of the afternoon prayer before sunset, he in fact finds the afternoon prayer.

Book 4, Number 1264:

    A'isha reported: The Messenger of Allah (may peace be upon him) said: He who finds a prostration before sunset or at dawn (prayer) before the rising (of the sun) he Id fact finds that (prayer), and prostration implies a rak’ah.

Book 4, Number 1265:

    This hadith is narrated by Abu Huraira with another chain of transmitters.

Book 4, Number 1266:

    Abu Huraira reported: The Messenger of Allah (may peace be upon him) said: He who finds (gets) a rak'ah of the afternoon (prayer) before the setting of the sun, he in fact gets (the full prayer), and he who gets a rak'ah of the morning (prayer) before the rising of the sun he in fact gets (the full prayer).

Book 4, Number 1267:

    This hadith has been reported by Ma'mar with another chain of transmitters.

Chapter 74 : TIMES OF PRAYER

Book 4, Number 1268:

    Ibn Shibab reported: 'Umar b. 'Abd al-'Aziz deferred the afternoon prayer somewhat and 'Urwa said to him: Gabriel came down and he led the Messenger of Allah (may peace be upon him) in prayer. 'Umar said to him: O 'Urwa, are you aware of what you are saying? Upon this he ('Urwa) said: I heard Bashir b. Abu Mas’ud say that he heard Abu Mas’ud say that he heard the Messenger of Allah (may peace be upon him) say: Gabriel came down and acted as my Imam, then I prayed with him, then I prayed with him, then I prayed with him. then I prayed with him. then I prayed with him. reckoning with his fingers five times of prayer.

Book 4, Number 1269:

    Ibn Shibab reported: Umar b. 'Abd al-’Aziz one day deferred the prayer. 'Urwa b. Zubair came to him and informed him that one day as Mughira b. Shu’ba was in Kufa (as its governor), he deferred the prayer, Abu Mas’ud al-Ansari came to him and said: What is this, O Mughira? Did you know that it was Gabriel who came and said prayer and (then) the Messenger of Allah (may peace be upon him) said the prayer (along with him), then (Gabriel) prayed and the Messenger of Allah (may peace be upon him) also prayed, then (Gabriel) prayed and the Messenger of Allah (may peace be upon him) also prayed, then (Gabriel) prayed and the Messenger of Allah (may peace be upon him) prayed (along with him). then Gabriel prayed and the Messenger of Allah (may peace be upon him) also prayed (along with him) and then said: This is how I have been ordered to do. 'Umar (b. 'Abd al-’Aziz) said . O 'Urwa be mindful of what you are saying that Gabriel (peace be upon him) taught the Messenger of Allah (may peace be upon him) the times of prayer. Upon this 'Urwa said: This is how Bashir b. Abu Mas’ud narrated on the authority of his father and (also said): ‘A’isha?, the wife of the Apostle (may peace be upon him). narrated it to me that the Messenger of Allah (may peace be upon him) used to say the afternoon prayer, when the light of the sun was there in her apartment before it went out (of it).

Book 4, Number 1270:

    A'isha reported: The Apostle of Allah (may peace be upon him) said the afternoon" prayer as the sun shone in my apartment, and the afternoon shadow did not extend further. Abu Bakr said: The afternoon shadow did not appear to extend further.

Book 4, Number 1271:

    ‘A’isha, the wife of the Apostle (may peace be upon him), said that the Messenger of Allah (may peace be upon him) said the afternoon prayer (at the time) when the sun shone in her apartment and its shadow did not extend beyond her apartment.

Book 4, Number 1272:

    A’isha reported: The Messenger of Allah (may peace be upon him) said the afternoon prayer (at a time) when the (light) of the sun was there in my apartment.

Book 4, Number 1273:

    Abdullah b. 'Amr reported the Apostle (may peace be upon him) saying: The time of the noon prayer(lasts)as long as it is not afternoon, and the time of the afternoon prayer (lasts) as long as the sun does not turn pale and the time of the evening prayer (lasts) as long as the spreading appearance of the redness above the horizon after sunset does not sink down, and the, time of the night prayer (lasts) by midnight and the time of the morning prayer (lasts) as long as the sun dots not rise.

Book 4, Number 1274:

    Abu Bakr b Abu Shaiban and Yahya b Abu Bukair both of them narrated this hadith with the same chain of transmitters.

Book 4, Number 1275:

    'Abdullah b. 'Amr reported: The Messenger of Allah (may peace be upon him) said: The time of the noon prayer is when the sun passes the meridian and a man's shadow is the same (length) as his height, (and it lasts) as long as the time for the afternoon prayer has not come; the time for the afternoon prayer is as long as the sun has not become pale ; the time of the evening prayer is as long as the twilight has not ended; the time of the night prayer is up to the middle of the average night and the time of the morning prayer is from the appearance of dawn, as long as the sun has not risen; but when the sun rises, refrain from prayer for it rises between the horns of the devil.

Book 4, Number 1276:

    'Abdullah b. 'Amr b. al-'As reported: The Messenger of Allah (may peace be upon him) was asked about the times of prayers. He said: The time for the morning prayer (lasts) as long as the first visible part of the rising sun does not appear and the time of the noon prayer is when the sun declines from the zenith and there is not a time for the afternoon prayer and the time for the afternoon prayer is so long as the sun does not become pale and its first visible part does not set, and the time for the evening prayer is that when the sun disappears and (it lasts) till the twilight is no more and the time for the night prayer is up to the midnight.

Book 4, Number 1277:

    'Abdullah narrated it on the authority of his father Yahya: Knowledge cannot be acquired with sloth.

Book 4, Number 1278:

    Sulaiman b. Buraida narrated it on the authority of his father that a person asked the Apostle of Allah (may peace be upon him) about the time of prayer. Upon this he said: Pray with us these two, meaning two days. When the sun passed the meridian. he gave command to Bilal who uttered the call to prayer. then lie commanded him and pronounced Iqama for noon prayer (Then at the tine of the afternoon prayer) he again commanded and Iqama for the afternoon prayer was pronounced when the sun was high, white and clear. He then commanded and Iqama for the evening prayer was pronounced, when the sun had set. He then commanded him and the Iqama for the night prayer was pronounced When the twilight had disappeared. He then commanded him and the Iqama for the morning prayer was pronounced, when the dawn had appeared. When it was the next day, he commanded him to delay the noon prayer till the extreme heat had passed and he did so, and he allowed it to be delayed till the extreme heat had passed. He observed the afternoon prayer when the sun was high, delaying it beyond the time he had previously observed it. He observed the evening prayer before the twilight had vanished ; he observed the night prayer when a third of the night had passed; and he observed the dawn prayer when there was clear daylight. He (the Holy Prophet) then said: Where is the man who inquired about the time of prayer? He (the inquirer) said : Messenger of Allah I here I am. He (the Holy Prophet) said: The time for your prayer is within the limits of what you have seen.

Book 4, Number 1279:

    Buraida narrated on the authority of his father that a man came to the Prophet (may peace be upon him) and asked about the times of prayer. He said: You observe with us the prayer. He commanded Bilal, and he uttered the call to prayer in the darkness of night preceding daybreak and he said the morning prayer till dawn had appeared. He then commanded him (Bilal) to call for the noon prayer when the sun had declined from the zenith. He then commanded him (Bilal) to call for the afternoon prayer when the sun was high. He then commanded him for the evening prayer when the sun had set. He then commanded him for the night prayer when the twilight had disappeared. Then on the next day he commanded him (to call for prayer) when there was light in the morning. He then commanded him (to call) for the noon prayer when the extreme heat was no more. He then commanded him for the afternoon prayer when the sun was bright and clear and yellowness did not blend with it. He then commanded him to observe the sunset prayer. He then commanded him for the night prayer when a third part of the night bad passed or a bit less than that. Harami (the narrator of this hadith) was in doubt about that part of the mentioned hadith which concerned the portion of the night. When it was dawn, he (the Holy Prophet) said: Where is the inquirer (who inquired about the times of prayer and added): Between (these two extremes) is the time for prayer.

Book 4, Number 1280:

    Abu Musa narrated on the authority of his father that a person came to the Messenger of Allah (may peace be upon him) for inquiring about the times of prayers. He (the Holy Prophet) gave him no reply (because he wanted to explain to him the times by practically observing these prayers). He then said the morning player when it was daybreak, but the people could hardly recognise one another. He then commanded and the Iqama for the noon prayer was pronounced when the tan had passed the meridian and one would say that it was midday but he (the Holy Prophet) knew batter than them. He then again commanded and the Iqama for the afternoon prayer was pronounced when the sun was high. He then commanded and Iqama for the evening prayer was pronounced when the sun had sunk. He then commanded and Iqama for the night prayer was pronounced when the twilight had disappeared. He then delayed the morning prayer on the next day (so much so) that after returning from it one would say that the sun had risen or it was about to rise. He then delayed the noon prayer till it was near the time of afternoon prayer (as it was observed yesterday). He then delayed the afternoon prayer till one after returning from it would say that the sun had become red. He then delayed the evening prayer till the twilight was about to disappear. He then delayed the night prayer till it was one-third of the night. He then called the inquirer in the morning and said: The time for prayers is between these two extremes).

Book 4, Number 1281:

    Abu Musa reported on the authority of his father that an Inquirer came to the Prophet (may peace be upon him) and asked him about the times of prayers, and the rest of the hadith is the same (as narrated above) but for these words: "On the second day he (the Holy Prophet) observed the evening prayer before the disappearance of the twilight."

Chapter 75 : DESIRABILITY OF SAYING THE NOON PRAYER WHEN THE EXTREME HEAT IS OVER

Book 4, Number 1282:

    Abu Huraira reported that the Messenger of Allah (may peace he upon him) said: When it is very hot, say (the noon prayer) when the extreme beat passes away, for intensity of beat is from the exhalation of Hell.

Book 4, Number 1283:

    Another hadith like this has been transmitted by Abu Huraira.

Book 4, Number 1284:

    Abu Huraira reported: The Messenger of Allah (may peace be upon him) said: When it is a hot day, (delay) the prayer till the extreme heat passes away, for the intensity of heat is from the exhalation of Hell.

Book 4, Number 1285:

    Abu Huraira reported: Refrain from saying (the noon prayer) till the extreme heat passes away, for the Intensity of heat is from the exhalation of Hell.

Book 4, Number 1286:

    Abu Huraira narrated this hadith from the Messenger of Allah (may peace be up on him) by another chain of transmitters.

Book 4, Number 1287:

    Abu Huraira reported that the Messenger of Allah (may peace be upon him) said: This heat is from the exhalation of Hell-fire, so delay the prayer till it is cool.

Book 4, Number 1288:

    Hammam b. Munabbih reported: This is what Abu Huraira narrated to us from the Holy Prophet and he transmitted some ahadith-one of them was that the Messenger of Allah (may peace be upon him) said: Let the heat become less severe before prayer, for the intensity of heat is from the exhalation of Hell.

Book 4, Number 1289:

    Abu Dharr reported: The Mu'adhdbin (the announcer of the hour of prayer) of the Messenger of Allah (may peace be upon him) called for the noon prayer. Upon this the Apostle of Allah (may peace be upon him) said: Let it cool down, let it cool down, or he said: Wait, wait for the intensity of heat is from the exhalation of Hell. When the heat is intense, delay the prayer till it becomes cooler. Abu Dharr said: (We waited) till we saw the shadow of the mounds.

Book 4, Number 1290:

    Abu Huraira reported: The Messenger of Allah (may peace be upon him) said: The Fire made a complaint before the Lord saying. "O Lord, some parts of mine have consumed the others." So it was allowed to take two exhalations, one exhalation in winter and the other exhalation in summer. That is why you find extreme heat (in summer) and extreme cold (in winter).

Book 4, Number 1291:

    Abu Huraira reported: The Messenger of Allah (may peace be upon him) said: When it is hot, make delay (in the noon prayer) till it cools down, for the intensity of beat is from the Exhalation of Hell; and lie also mentioned that the Hellfire complained to the Lord (about the congested atmosphere) and so it was permitted to take two exhalation during the whole year, one exhalation during the winter and one exhalation during the summer.

Book 4, Number 1292:

    Abu Huraira reported that the Messenger of Allah (may peace be upon him) said: The Fire said to the Lord: O Lord! some parts of mine have consumed the others, so allow me to exhale (in order to find some relief from this congestion). It was granted permission to take two exhalations, one exhalation during the winter and the other exhalation during the summer So whatever you perceive in the form of intense cold or hurting cold is from the exhalation of Hell. And whatever you perceive in the form of extreme heat or intense beat is from the exhalation of Hell.

Chapter 76 : DESIRABILITY OF OBSERVING THE NOON PRAYER AT THE EARLIER HOUR (OF TIMES PRESCRIBED FOR IT) WHEN THERE IS NO INTENSE HEAT

Book 4, Number 1293:

    Jabir b. Samura reported: The Apostle of Allah (may peace be upon him) used to offer the noon prayer when the sun declined.

Book 4, Number 1294:

    Khabbab reported: We complained to the Messenger of Allah (may peace be upon him) (the difficulty of) saying prayer on the intensely heated (ground or sand), but he paid no heed to our complaint.

Book 4, Number 1295:

    Khabbab reported: We came to the Messenger of Allah (may peace be upon him) and we complained to the Messenger of Allah (may peace be upon him) about (saying prayer) on the extremely heated ground (or sand), but he paid no heed to us. Zuhair said: I asked Abu Ishaq whether it was about the noon prayer. He said: Yes. I again said whether it concerned the (offering) of the noon (prayer) in earlier hours. He said: Yes. I said: Did it concern expediting it? He said: Yes.

Book 4, Number 1296:

    Anas b. Malik reported: We used to say (the noonprayer) with the Messenger of Allah (may peace be upon him) in the intense heat, but when someone amongst us found it hard to place his forehead on the ground, he spread his cloth and prostrated on it.

Chapter 77 : PREFERENCE FOR SAYING THE'ASR PRAYER AT THE COMMENCEMENT OF THE PRESCRIBED TIME

Book 4, Number 1297:

    Anas b. Malik reported that the Messenger of Allah (may peace be upon him) used to pray the afternoon prayer when the sun was high and bright, then one would go off to al-'Awali and get there while the sun was still high. Ibn Qutaiba made no mention of "one would go off to al-'Awali".

Book 4, Number 1298:

    This hadith that the Messenger of Allah (may peace be upon him) used to offer the afternoon prayer like the one narrated above has been transmitted by Anas b. Malik by another chain of transmitters.

Book 4, Number 1299:

    Anas b. Malik reported: We used to offer the 'Asr prayer, then one would go to Quba' and reach there and the sun would be still high.

Book 4, Number 1300:

    Anas b. Malik reported: We used to offer the afternoon prayer (at such a time) that a person would go to Bani 'Amr b. Auf and he would find them busy offering the afternoon prayer.

Book 4, Number 1301:

    'Ala' b. 'Abd al-Rahman reported that they came to the house of Anas b. Malik in Basra after saying the noon prayer. His (Anas) house was situated by the side of the mosque. As revisited him he (Anas) said: Have you said the afternoon prayer? We said to him: It is just a few minutes before that we finished the noon prayer. He said: Offer the afternoon prayer. So we stood up and said our prayer. And when we completed it, he said: I have heard the Messenger of Allah (may peace be upon him) saying: This is how the hypocrite prays: he sits watching the sun, and when it is between the horns of devil, he rises and strikes the ground four times (in haste) mentioning Allah a little during it.

Book 4, Number 1302:

    Abu Umama b. Sahl reported: We offered the noon prayer with Umar b. 'Abd al-'Aziz. We then set out till we came to Anas b. Malik and found him busy in saying the afternoon prayer. I said to him: O uncle! which is this prayer that you are offering? He said: It is the afternoon prayer and this is the prayer of the Messenger of Allah (may peace be upon him) that we offered along with him.

Book 4, Number 1303:

    Anas b. Malik reported: The Messenger of Allah (may peace be upon him) led us in the afternoon prayer. When he completed it, a person from Bani Salama came to him and said: Messenger of Allah, we intend to slaughter our came and we are desirous that you should also be present there (on this occasion). He (the Holy Prophet) said: Yes. He (the person) went and we also went along with him and we found that the camel had not been slaughtered yet. Then it was slaughtered, and it was cut into pieces and then some of those were cooked, and then we ate (them) before the setting of the sun. This hadith has also been narrated by another chain of transmitters.

Book 4, Number 1304:

    Rafi' b. Khadij reported: We used to say the afternoon prayer with the Messenger of Allah (may peace be upon him), and then the camel was slaughtered and ten parts of it were distributed; then it was cooked and then we ate this cooked meat before the sinking of the sun.

Book 4, Number 1305:

    This hadith has been reported by 'Auza'i with the same chain of transmitters: We used to slaughter the camel during the lifetime of the Messenger of Allah (may peace be upon him) after the 'Asr prayer, but he made no mention of: "We used to pray along with him."

Chapter 78 : THE SEVERITY (OF PUNISHMENT) IN MISSING THE 'ASR PRAYER

Book 4, Number 1306:

    Ibn Umar reported that the Messenger of Allah (may peace be upon him) said: He who misses the afternoon prayer, it is as though he has been deprived of his family and his property.

Book 4, Number 1307:

    This hadith has been narrated as Marfu by another chain of transmitters.

Book 4, Number 1308:

    Abdullah relates on the authority of his father. He who missed his afternoon prayer it is as though he was deprived of his family and property.

Book 4, Number 1309:

    'Ali reported: When it was the day (of the Battle) of Ahzab, the Messenger of Allah (may peace be upon him) said: May Allah fill their graves and houses with fire, as they detained us and diverted us from the middle prayer, till the sun set.

Book 4, Number 1310:

    This hadith has been narrated by Hisham with the same chain of transmitters.

Book 4, Number 1311:

    'Ali reported: The Messenger of Allah (may peace be upon him) said: On the day (of the Battle) of Ahzab we were diverted from the middle prayer, till the sun set. May Allah fill their graves or their houses, or their stomachs with fire. The narrator is in doubt about "houses" and "stomachs".

Book 4, Number 1312:

    This hadith has heed narrated by Qatada with the same chain of transmitters. And he said: Their houses and their graves (be filled with fire), and did not express doubt over the words, "houses" and "graves".

Book 4, Number 1313:

    Yahya heard 'Ali saying that the Messenger of Allah (may peace be upon him) said on the day (of the Battle) of Ahzab, while sitting in one of the openings of the ditch: They (the enemies) have diverted us from the middle prayer till the sun set. May Allah fill their graves and their houses with fire, or their graves and stomachs with fire.

Book 4, Number 1314:

    'Ali reported: The Messenger of Allah (may peace be upon him) said on the day (of the Battle) of Ahzab: They diverted us from saying the middle prayer, i.e. the 'Asr prayer. May Allah fill their houses and graves with fire; he then observed this prayer between the evening prayer and the night prayer.

Book 4, Number 1315:

    'Abdullah (b. Mas'ud) reported that the polytheists detained the Messenger of Allah (may peace be upon him) from observing the afternoon prayer till the sun became red or it became yellow. Upon this the Messenger of Allah (may peace be upon him) said: They have diverted us from (offering) the middle prayer. i.e. the 'Asr prayer. May Allah fill their bellies and their graves with fire, or he said: May Allah stuff their bellies and their graves with fire.

Book 4, Number 1316:

    Abu Yunus, the freed slave of 'A'isha said: 'A'isha ordered me to transcribe a copy of the Qur'an for her and said: When you reach this verse: "Guard the prayers and the middle prayer" (ii. 238), inform me; so when I reached it, I informed her and she gave me dictation (like this): Guard the prayers and the middle prayer and the afternoon prayer, and stand up truly obedient to Allah. 'A'isha said: This is how I have heard from the Messenger of Allah (may peace be upon him).

Book 4, Number 1317:

    Al-Bara' b. 'Azib reported: This verse was revealed (in this way): "Guard the prayers and the 'Asr prayer." We recited it (in this very way) so long as Allah desired. Allah, then, abrogated it and it was revealed: "Guard the prayers, and the middle prayer." A person who was sitting with Shaqiq (one of the narrators in the chain of transmitters) said: Now it implies the 'Asr prayer. Upon this al-Bara' said: I have already informed you how this (verse) was revealed and how Allah abrogated it, and Allah knows best. Imam Muslim said: Ashja'i narrated it from Sufyan al-Thauri, who narrated it from al-Aswad b. Qais, who narrated it from 'Uqba, who narrated it from al-Bara' b. 'Azib who said: We recited with the Prophet (may peace be upon him) (the above-mentioned verse like this, i.e. instead of Salat al- Wusta, Salat al-'Asr) for a certain period. as It has been mentioned (in the above-quoted hadith).

Book 4, Number 1318:

    Jabir b. 'Abdullah reported that Umar b. al-Khattab had been cursing the pagans of the Quraish an the day (of the Battle) of Khandaq (Ditch). (He came to the Holy Prophet) and said: Messenger of Allah, by God, I could not say. the 'Asr prayer till the sun set. Upon this the Messenger (may peace be upon him) said: By Allah I, too, have not observed it. So we went to a valley. The Messenger of Allah (may peace be upon him) performed ablution and we too performed ablution, and then the Messenger of Allah (may peace be upon him) said the 'Asr prayer after the sun had set. and then said the evening prayer after it.

Book 4, Number 1319:

    This hadith has been reported by Yahya b. Abd Kathir with the same chain of transmitters.

Chapter 79 : MERIT OF THE MORNING AND AFTERNOON PRAYERS AND EXHORTATION TO GUARD THEM

Book 4, Number 1320:

    Abu Huraira reported: The Messenger of Allah (may peace be upon him) said: Angels take turns among you by night and by day, and they all assemble at the dawn and afternoon prayers. Those (of the angels) who spend the night among you, then, ascend, and their Lord asks them, though He is the best informed about them : How did you leave My servants? -they say: We left them while they were praying and we came to them while they were praying.

Book 4, Number 1321:

    Abu Huraira reported Allah's Messenger (may peace be upon him) as saying: Angels take turns among you by night and by day, and the rest of the hadith is the same.

Book 4, Number 1322:

    Jarir b. Abdullah is reported to have said: We were sitting with the Messenger of Allah (may peace be upon him) that he looked at the full moon and observed: You shall see your Lord as you are seeing this moon, and you will not be harmed by seeing Him. So if you can, do not let -yourselves be overpowered in case of prayer observed before the rising of the sun and its setting, i.e. the 'Asr prayer and the morning prayer. Jarir then recited it: "Celebrate the praise of thy Lord before the rising of the sun and before Its setting" (xx. 130).

Book 4, Number 1323:

    Waki' reported (this hadith) with the same chain of transmitters (that the Holy Prophet) said: You will be soon presented before your Lord, and you will see Him as you are seeing this moon, and then recited (the above-mentioned verse). But (in this hadith) no mention is made of Jarir.

Book 4, Number 1324:

    'Umara b. Ruwaiba is reported to have said on the authority of his father: I heard the Messenger of Allah (may peace be upon him) saying: He who observed prayer before the rising of the son and its setting, i. e. the dawn prayer and the afternoon prayer, would not cater the (Hell) fire. A person belonging to Basra said to him : Did you yourself bear it from the Messenger of Allah (may peace be upon him)? He said: Yes. The person (from Basra) said: I bear witness that I heard it from the Messenger of Allah (may peace be upon him); my ears heard it and my heart retained it.

Book 4, Number 1325:

    Umara b. Ruwaiba reported on the authority of his father that the Messenger of Allah (may peace be upon him) said: He who said prayer before the rising of the sun and its setting would not enter the fire (of Hell), and there was a man from Basra (sitting) beside him who said: Did you hear it from the Apostle of Allah (way peace be upon him)? He said: Yes, I bear witness to it. The man from Basra said: I bear witness that I did hear from the Apostle of Allah (may peace be upon him) saying it from the place that you heard from him.

Book 4, Number 1326:

    Abu Bakr reported on the authority of his father that the Messenger of Allah (may peace be upon him) said: He who observed two prayers at two cool (hours) would enter Paradise.

Book 4, Number 1327:

    This hadith has been narrated by the same chain of transmitters by Hammam, and said about Abu Bakr that he was Ibn Abu Musa.

Chapter 79 : COMMENCEMENT OF THE TIME FOR THE EVENING PRAYER IS IMMEDIATELY AFTER SUNSET

Book 4, Number 1328:

    Salama b. al-Akwa' reported that the Messenger of Allah (may peace be upon him) used to say the evening prayer when the sun had set and disappeared (behind the horizon).

Book 4, Number 1329:

    Rafi' b. Khadij reported: We used to observe the evening prayer with the Messenger of Allah (may peace be upon him) and then one of us would go away and he could see the (distant) place where his arrow would fall.

Book 4, Number 1330:

    A hadith like this, i.e. "We used to observe evening prayer …." so on and so forth, has been narrated by Rafi' b. Khadij by another chain of transmitters.

Chapter 80 : TIME FOR THE NIGHT PRAYER AND ITS DELAY

Book 4, Number 1331:

    'A'isha. the wife of the Apostle of Allah (may peace be upon him), reported: The Messenger of Allah (may peace be upon him) deferred one night the 'Isya' prayer. And this is called 'Atama. And the Messenger of Allah (may peace be upon him) did not come out till Umar b. Khattab told (him) that the women and children had gone to sleep. So the Messenger of Allah (may peace be upon him) came out towards them and said to the people of the mosque: None except you from the people of the earth waits for it (for the night prayer at this late hour), and it was before Islam had spread amongst people. And in the narration transmitted by Ibn Shihab the Messenger of Allah (may peace be upon him) is reported to have said: It is not meant that you should compel the Messenger of Allah (may peace be upon him) for prayer. And (this he said) when 'Umar b. Khattab called (the Holy Prophet) in a loud voice.

Book 4, Number 1332:

    A hadith like this has been narrated by Ibn Shihab with the same chain of transmitters, but therein no mention has been made of the words of al-Zuhri: It was narrated to me, and that which followed.

Book 4, Number 1333:

    'A'isha reported: The Apostle of Allah (may peace be upon him) one night delayed (observing the 'Isya' prayer) till a great part of the night was over and the people in the mosque had gone to sleep. He (the Holy Prophet) then came out and observed prayer and said: This is the proper time for it; were it not that I would impose a burden on my people (I would normally pray at this time). In the hadith transmitters by 'Abd al-Razzaq (the words are): "Were it not that it would impose burden on my people."

Book 4, Number 1334:

    Abdullah b. Umar reported: We waited one night in expectation of the Messenger of Allah (may peace be upon him) for the last prayer of the night, and he came out to us when a third of the night had passed even after that. We do not know whether he had been occupied with family business or something else. When he came cut he said: You are waiting for prayer, for which the followers of no other religion wait. except you. Were it not a burden for my Ummah, I would have led them (in the 'Isya' prayer) at this hour. He then ordered the Mu'adhdbin (to call for prayer) and then stood up for prayer and observed prayer.

Book 4, Number 1335:

    Abdullah b. 'Umar reported that the Messenger of Allah (may peace be upon him) was one night occupied (in some work) and he delayed it ('Isya' prayer) till we went to sleep in the mosque. We then woke up and again went to sleep and again woke up. The Messenger of Allah (may peace be upon him) then came to us and said: None among the people of the earth except you waits for prayer in the night.

Book 4, Number 1336:

    Thabit reported: They (the believers) asked Anas about the ring of the Messenger of Allah (may peace be upon him) and he said: One night the Messenger of Allah (may peace be upon him) delayed (observing) the 'Isya' prayer up to the midnight or midnight was about to be over. He then came and said: (Other) people have offered prayers and slept, but you are constantly in prayer as long as you wait for prayer. Anas said: I perceive as if I am seeing the lustre of his silver ring, and lifted his, small left finger (in order to show how the Holy Prophet had lifted it).

Book 4, Number 1337:

    Anas b. Malik reported: We waited for the Messenger of Allah (may peace be upon hi n) one night, till it was about midnight. He (the Holy Prophet) came and observed prayer and then turned his face towards us, as it I was seeing the lustre of the silver ring on his finger.

Book 4, Number 1338:

    This hadith has been narrated by Qurra with the same chain of transmitters, but therein he did not mention: "He turned his face towards us."

Book 4, Number 1339:

    Abu Musa reported: I and my companions who had sailed along with me in the boat landed with me in the valley of Buthan while the Messenger of Allah (may peace be upon him) was staying in Medina. A party of people amongst them went to the Messenger of Allah (may peace be upon him) every night at the time of the 'Isya' prayer turn by turn. Abu Musa said: (One night) we (I and my companions) went to the Messenger of Allah (may peace be upon him) and he was occupied in some matter till there was a delay in prayer so much so that it was the middle of the night. The Messenger of Allah (may peace be upon him) then came out and led them (Musa's companions) in prayer. And when he had observed his prayer he said to the audience present: Take it easy, I am going to give you information and glad tidings that it is the blessing of Allah upon you for there is none among the people, except you, who prays at this hour (of the night), or he said: None except you observed prayer at this. (late) hour. He (i.e. the narrator) said: I am not sure which of these two sentences he actually uttered. Abu Musa, said: We came back happy for what we heard from the Messenger of Allah (may peace be upon him).

Book 4, Number 1340:

    Ibn Juraij reported: I said to Ata': Which time do you deem fit for me to say the 'Isya' prayer,-as an Imam or alone,-that time which is called by people 'Atama? He said: I heard Ibn 'Abbas saying: The Apostle of Allah (may peace be upon him) one night delayed the 'Isya' prayer till the people went to sleep. They woke up and again went to sleep and again woke up. Then 'Umar b. Khattab stood up and said (loudly) "Prayer." Ata' further reported that Ibn 'Abbas said: The Apostle of Allah (may peace be upon him) came out, and as if I am still seeing him with water trickling from his head, and with his hand placed on one side of the head, and he said: Were it not hard for my Ummah, I would have ordered them to observe this prayer like this (i.e. at late hours). I inquired from 'Ata' how the Apostle of Allah (may peace be upon him) placed his hand upon his head as Ibn Abbas had informed. So Ata' spread his fingers a little and then placed the ends of his fingers on the side of his head. He then moved them like this over his head till the thumb touched that part of the ear which is near the face and then it (went) to the earlock and the part of the heard. It (the bind) neither held nor caught anything but this is how (it moved oil). I said to Ata': Was it mentioned to you (by Ibn Abbas) how long did the Apostle (may peace be upon him) delay it (the prayer) during that eight? He said: I do not know (I cannot give you the exact time). Ali' said: I love that I should say prayer, whether as an Imam or alone at delayed hours as the Apostle of Allah (may peace be upon him) said that night, but if It is hard upon you in your individual capacity or upon people in the congregation and you are their Imam, then say prayer ('Isya') at the middle hours neither too early nor too late.

Book 4, Number 1341:

    Jabir b. Samura reported that the Messenger of Allah (may peace be upon him) postponed the last 'Isya' prayer.

Book 4, Number 1342:

    Jabir b. Samura reported: The Messenger of Allah (may peace be upon him) used to observe prayers like your prayers, but he would delay the prayer after nightfall to a little after the time you observed it, and he would shorten the prayer.

Book 4, Number 1343:

    Abdullah b. 'Umar reported: I heard the Messenger of Allah (may peace be upon him) as saying: Let the bedouin not gain upper hand over you in regard to the name of your prayer. See I (The night prayer should be called) 'Isya' (and the bedouins call it Atama (because) they milk their camels late.

Book 4, Number 1344:

    Ibn 'Umar said: The Messenger of Allah (may peace be upon him) said: Let the bedouin not gain upper band over you In regard to the name of your prayer, i.e. night prayer, for it is mentioned 'Isya' in the Book of Allah (i.e. the Qur'an). (The bedouin call it 'Atama because) they make delay in milling their she-camels.

Chapter 81 : DESIRABILITY OF OBSERVING THE MORNING PRAYER AT EARLIER HOUR AND THAT IS THE TIME WHEN THERE IS DARKNESS BEFORE DAWN AND THE INFORMATION REGARDING THE LENGTH OF RECITATION IN IT

Book 4, Number 1345:

    'A'isha reported: The believing women used to pray the morning prayer with the Messenger of Allah and then return wrapped in their mantles. No one could recognise them.

Book 4, Number 1346:

    'A'isha, the wife of the Apostle of Allah (may peace be upon him), reported: The believing women observed the morning prayer with the Messenger of Allah (may peace be upon him) wrapped in their mantles. They then went back to their houses and were unrecognisable, because of the Messenger of Allah's (may peace be upon him) praying in the darkness before dawn.

Book 4, Number 1347:

    'A'isha reported: The Messenger of Allah (may peace be upon him) used to observe the morning prayer, and the women would go back wrapped in their mantles being unrecognisable because of the darkness before dawn. (Ishaq b. Musa) al-Ansari (one of the transmitters in this chain of narration) narrated "wrapped" (only) in his narration. (No mention was made of mantles.)

Book 4, Number 1348:

    Muhammad b. 'Amr b. al-Hasan b. 'All reported: When Hajjaj came to Medina we asked Jabir b. Abdullah (about the timings of prayer as observed by the Holy Prophet). He said: The Messenger of Allah (may peace be upon him) used to pray afternoon prayer in the midday heat; the afternoon prayer when the sun was bright; the evening prayer when the sun had completely set; and as for the night prayer, he sometimes delayed and sometimes (observed it) at earlier hours. When he found them (his Companions) assembled (at earlier hours) he (prayed) early. and when he saw them coming late, he delayed the (prayer). and the morning prayer the Apostle of Allah (may peace be upon him) observed in the darkness before dawn.

Book 4, Number 1349:

    Muhammad b. 'Amr al-Hasan b. 'All reported: Hajjaj used to delay the prayers, and so we asked Jabir b. 'Abdullah, and the rest of the hadith is the same.

Book 4, Number 1350:

    Sayyar b. Salama reported: I heard my father asking Abu Barza (al- Aslami) about the prayer of Allah's Messenger (may peace be upon him) I (Shu'ba, one of the narrators) said: Did you hear it (from Abu Barza) ? He said: 1 feel as if I am bearing you at this very time. He said: I heard my father asking about the prayer of the Messenger of Allah (may peace be upon him) and he (Abu Barza) making this reply: He (the Holy Prophet) did not mind delaying-some (prayer) i.e. 'Isya' prayer, even up to the midnight and did not like sleeping before observing it, and talking after it. Shu'ba said: I met him subsequently and asked him (about the prayers of the Holy Prophet) and he said: He observed the noon prayer when the sun was past the meridian, he would pray the afternoon prayer, after which a person would o to the outskirts of Medina and the sun was still bright; (I forgot what he said about the evening prayer); I then met him on a subsequent occasion and asked him (about the prayers of the Holy Prophet; and he said: He would observe the morning prayer (at such a time) so that a man would go back and would recognise his neighbour by casting a glance at his face, and he would recite from sixty to one hundred verses in it.

Book 4, Number 1351:

    Sayyar b. Salama reported: I heard Abu Barza saying that the Messenger of Allah (may peace be upon him) did not mind some delay in the 'Isya' prayer even up to the midnight and he did not like sleeping before (observing it) and talking after it. Shu'ba said: I again met him (Sayyar b. Salama) for the second time and he said: Even up to the third (part) of the night.

Book 4, Number 1352:

    Abu Barza b. Aslami is reported to have said: The Messenger of Allah (may peace be upon him) delayed the night prayer till a third of the night had passed and he did not approve of sleeping before it, and talking after it, and he used to recite in the morning prayer from one hundred to sixty verses (and completed the prayer at such hours) when we recognised the faces of one another.

Chapter 82 : DISAPPROVAL OF DELAYING THE PRAYER FROM ITS PRESCRIBED TIME; WHAT ONE WHO IS LED IN PRAYER SHOULD DO WHEN THE IMAM DELAYS IT?

Book 4, Number 1353:

    Abu Dharr reported: The Messenger of Allah (may peace be upon him) said to me: How would you act when you are under the rulers who would delay the prayer beyond its prescribed time, or they would make prayer a dead thing as far as its proper time is concerned? I said: What do you command? He (the Holy Prophet) said: Observe the prayer at Its proper time, and if you can say it along with them do so, for it would be a superetogatory prayer for you. Khalaf (one of the narrators in the above hadith) has not mentioned "beyond their (prescribed) time".

Book 4, Number 1354:

    Abu Dharr reported: The Messenger of Allah (may peace be upon him) said to me: O Abu Dharr, you would soon find after me rulers who would make their prayers dead. You should say prayer at its prescribed time. If you say prayer at its prescribed time that would be a supererogatory prayer for you, otherwise you saved your prayer.

Book 4, Number 1355:

    Abu Dharr reported: My friend (the Holy Prophet) bade me to hear and obey (the ruler) even if he is a slave having his feet and arms cut off, and observe prayer at its prescribed time. (And further said) : It you find people having observed the prayer, you in fact saved your prayer, otherwise (if you join with them) that would be a Nafl prayer for you.

Book 4, Number 1356:

    Abu Dharr reported: The Messenger of Allah (may peace be upon him) struck my thigh and said: How would you act if you survive among the people who would delay prayers beyond their (prescribed) time? He (Abu Dharr) said: What do you command (under this situation)? He (the Holy Prophet) slid: Observe prayer at its prescribed time, then go (to meet) your needs, and if the Iqama is pronounced, and you are present in the mosque, then observe prayer (along with the Jama'at).

Book 4, Number 1357:

    'Abu'l-'Aliyat al-Bara reported: Ibn Ziyad delayed the prayer. 'Abdullah b. Samit came to me and I placed a chair for him and he sat in it and I made a mention of whit Ibn Ziyad had done. He bit hit lips (as a sign of extreme anger and annoyance) and struck at my thigh and said: I asked Abu Dharr as you have asked me, and he struck my thigh just as I have struck your thigh, and said : I asked the Messenger of Allah (may peace be upon him) as you have asked me and he struck my thigh just as I have struck your thigh, and he (the Holy Prophet) said: Observe prayer at its prescribed time, and if you can say prayer along with them. do so, and do not say. "I have observed prayer and so I shall not pray."

Book 4, Number 1358:

    Abu Dharr reported: (The Messenger of Allah) said: How would you, or how would thou, act if you survive to live among people who defer prayer beyond the (prescribed) time? (The narrator said: Allah and His Messenger know best). whereupon he said: Observe prayer at its prescribed time, but if the Iqama is pronounced for (congregational) prayer, then observe prayer along with them. for herein is an excess of virtue.

Book 4, Number 1359:

    Abu'l-'Aliyat al-Bara' reported: I said to 'Abdullah b. Samit: We say our Jumu'a prayer behind those rulers who defer the prayer. He ('Abdullah b. Samit), struck. my thigh that I felt pain and said: I asked Abu Dharr about it, he struck my thigh and said: I asked the Messenger of Allah (may peace be upon him) about it. Upon this he said: Observe prayer at its prescribed time, and treat prayer along with them (along with those Imams who deter prayer) as Nafl. 'Abdullah said: It was narrated to me that the Messenger of Allah (may peace be upon him) struck the thigh of Abd Dharr.

Chapter 83 : EXCELLENCE OF PRAYERS IN CONGREGATION AND GRIM WARNING FOR REMAINING AWAY FROM IT

Book 4, Number 1360:

    Abu Huraira reported Allah's Messenger (may peace be upon him) as saying: Prayer said in a congregation is twenty-five degrees more excellent than prayer said by a single person.

Book 4, Number 1361:

    Abu Huraira reported Allah's Apostle (may peace be upon him) as saying: Prayer said in a congregation is twenty-five degrees more excellent than prayer said by a single person. He (Abu Huraira further) said: The angels of the night and the angels of the day meet together. Abu Huraira said: Recite it you like: "Surely the recital of the Qur'an at dawn is witnessed" (al-Qur'an, xvii. 78).

Book 4, Number 1362:

    A hadith like this has been narrated by Abu Huraira with another chain of transmitters with a very slight change of words.

Book 4, Number 1363:

    Abu Huraira reported Allah's Messenger (may peace be upon him) as saying: Prayer said in a congregation is equivalent to twenty-five (prayers) as compared with the prayer said by a single person.

Book 4, Number 1364:

    Abu Huraira reported: The Messenger of Allah (way peace be upon him) said: Prayer along with the Imam is twenty-five times more excellent than prayer said by a single person.

Book 4, Number 1365:

    Ibn Umar reported Allah's Messenger (may peace be upon him) assaying: Prayer said in a congregation is twenty-seven degrees more excellent than prayer said by a single person.

Book 4, Number 1366:

    Ibn 'Umar reported Allah's Apostle (may peace be upon him) as saying: The prayer of a person in congregation is twenty-seven times in excess to the prayer said alone.

Book 4, Number 1367:

    Ibn Numair reported it on the authority of his father (a preference of) more than twenty (degrees) and Abu Bakr in his narration (has narrated it) twenty- seven degrees.

Book 4, Number 1368:

    Ibn 'Umar reported from the Apostle of Allah (may peace be upon him) as some and twenty (degrees).

Book 4, Number 1369:

    Abu Huraira reported: The Messenger of Allah (may peace be upon him) found some people absenting from certain prayers and he said: I intend that I order (a) person to lead people in prayer, and then go to the persons who do not join the (congregational prayer) and then order their houses to be burnt by the bundles of fuel. If one amongst them were to know that he would find a fat fleshy bone he would attend the night prayer.

Book 4, Number 1370:

    Abu Huraira reported Allah's Messenger (may peace be upon him) as saying: The most burdensome prayers for the hypocrites are the night prayer and the morning prayer. If they were to know the blessings they have in store, they would have come to them, even though crawling, and I thought that I should order the prayer to be commenced and command a person to lead people in prayer, and I should then go along with some persons having a fagot of fuel with them to the people who have not attended the prayer (in congregation) and would burn their houses with fire.

Book 4, Number 1371:

    Hammam b. Munabbih reported: This is what Abu Huraira reported to us from the Messenger of Allah (may peace be upon him) and (in this connection) he narrated some ahadith, one of them is: The Messenger of Allah (may peace be upon him) said: I intend that I should command my young men to gather bundles fuel for me, and then order a person to lead people in prayer, and then burn the houses with their inmates (who have not joined the congregation).

Book 4, Number 1372:

    A hadith like this has been narrated by Abu Huraira.

Book 4, Number 1373:

    'Abdullah reported Allah's Messenger (may peace be upon him) as saying about people who are absent from Jumu'a prayer: I intend that I should command a person to lead people in prayer, and then burn those persons who absent themselves from Jumu'a prayer in their houses.

Chapter 84 : HE WHO HEARS THE CALL FOR PRAYER IT IS ESSENTIAL FOR HIM TO COME TO THE MOSQUE

Book 4, Number 1374:

    Abu Huraira reported: There came to the Apostle of Allah (may peace be upon him) a blind man and said: Messenger of Allah, I have no one to guide me to the mosque. He, therefore, asked. Allah's Messenger (may peace be upon him) permission to say prayer in his house. He (tee Holy Prophet) granted him permission. Then when the man turned away he called him and said: Do you hear the call to prayer? He said: Yes. He (the Holy Prophet then) said: Respond to it.

Book 4, Number 1375:

    'Abdullah (b. Mas'ud) reported: I have seen the time when no one stayed away from prayer except a hypocrite, whose hypocrisy was well known, or a sick man, but it a sick man could walk between two persons (i.e. with the help of two persons with one on each side) he would come to prayer. And (further) said: The Messenger of Allah (may peace be upon him) taught us the paths of right guidance. among which is prayer in the mosque in which the Adzan is called.

Book 4, Number 1376:

    Abdullah (b. Mas'ud) reported: He who likes to meet Allah tomorrow as Muslim, he should persevere in observing these prayers, when a call is announced for them, for Allah has laid down for your Prophet the paths of right guidance, and these (prayers) are among the paths of right guidance. If you were to pray in your houses as this man why stays away (from the mosque) prays in his house, you would abandon the practice of your Prophet, and if you were to abandon the practice of your Prophet, you would go astray. No man purifies himself, doing it well, then makes for one of those mosques without Allah recording a blessing for him for every step he takes raising him a degree for it, and effacing a sin from him for it. I have seen the time when no one stayed away from it, except a hypocrite, who was well known for his hypocrisy, whereas a man would be brought swaying (due to weakness) between two men till he was set up in a row.

Chapter 85 : FORBIDDANCE TO GO OUT OF THE MOSQUE AFTER THE ADZAN HAS BEEN ANNOUNCED BY MU'ADHDHIN

Book 4, Number 1377:

    Abu Sha'tha' reported: While we were sitting with Abu Huraira in a mosque a man went out of the mosque after the call to prayer had been announced. (A man stood up in the mosque and set off.) Abu Huraira's eyes followed him till he went out of the mosque. Upon this Abu Huraira said : This man has disobeyed Abu'l- Qasim (Muhammad) (may peace be upon him).

Book 4, Number 1378:

    Abu Sha'tha' al-Muharibi reported on the authority of his father, who said: I heard it from Abu Huraira that he saw a person getting out of the mosque after the call to prayer had been announced. Upon this he remarked: This (man) disobeyed Abu'l-Qasim (may peace be upon him).

Chapter 86 : EXCELLENCE OF PRAYING THE 'ISHA'AND MORNING PRAYERS IN CONGREGATION

Book 4, Number 1379:

    'Abd al-Rahman b. Abd 'Amr reported: 'Uthman b. 'Affan (narrated the mosque after evening prayer and sat alone. I also sat alone with him, so he said: 0, son of m brother, I heard tile Messenger of Allah (may peace be upon him) say: He who observed the 'Isya' prayer in congregation, it was as if he prayed up to the midnight, and he who prayed the morning prayer in congregation, it was as if he prayed the whole night.

Book 4, Number 1380:

    This hadith has been narrated by the chain of transmitters by Abu Sahl 'Uthman b. Hakim.

Book 4, Number 1381:

    Jundab b. 'Abdullah reported Allah's Messenger (may peace be upon him) as saying: He who prayed the morning prayer (in congregation) he is in fact under the protection of Allah. And it can never happen that Allah should demand anything from you in connection with the protection (that He guarantees) and one should not get it. He would then throw him in the fire of Hell.

Book 4, Number 1382:

    Anas b. Sirin reported: I heard Jundab b. Qasri saying that the Messenger of Allah (may peace be upon him) said: He who observed the morning prayer (in congregation), he is in fact under the protection of Allah and it never happens that Allah should make a demand in connection with the protection (that He guarantees and should not get it) for when he asks for anything in relation to His protection, he definitely secures it. He then throws him flatly in the Hell-fire.

Book 4, Number 1383:

    This hadith has been narrated by Jundab b. Sufyan in from the Apostle of Allah (may peace be upon him) with the same chain of transmitters, but this has not been mentioned: "He would throw him in fire."

Chapter 87 : PERMISSION TO REMAIN AWAY FROM THE CONGREGATIONAL PRAYER FOR ANY GENUINE REASON

Book 4, Number 1384:

    Mahmud b. al-Rabi' reported that 'Ibn b. Malik, who was one of the Companions of the Apostle of Allah (may peace be upon him) and who participated in the (Battle of) Badr and was among the Ansar (of Medina), told that he came to the Messenger of Allah (may peace be upon him) and said: Messenger of Allah, I have lost my eyesight and I lead my people in prayer. When there is a downpour there is then a current (of water) in the valley that stands between me and them and I find it impossible to go to their mosque and lead them in prayer. Messenger of Allah, I earnestly beg of you that you should come and observe prayer at a place of worship (in my house) so that I should then use it as a place of worship. The Messenger of Allah (may peace be upon him) said: Well, it God so wills. I would soon do so. 'Itban said: On the following day when the day dawned, the Messenger of Allah (may peace he upon him) came along with Abu Bakr at-Siddiq, and the Messenger of Allah (may peace be upon him) asked permission (to get into the house). I gave him the permission, and be did not sit after entering the house, when he said: At what place in your house you desire me to say prayer? I ('Itban b. Malik) said: I pointed to a corner in the house, The Messenger of Allah (may peace be upon him) stood (at that place for prayer) and pronounced Allah-o-Akbar (Allah is the Greatest) (as an expression for the commencement of prayer). We too stood behind him, and he said two rak'ahs and then pronounced salutation (marking the end of the prayer). We detained him (the Holy Prophet) for the meat curry we had prepared for, him. The people of the neighbouring houses came and thus there was a good gathering in (our house). One of them said: Where is Malik b. Dukhshun? Upon this one of them remarked: He is a hypocrite; he does not love Allah and His Messenger. Thereupon the Messenger of Allah (may peace be upon him) said: Do not say so about him. Don't you see that he utters La ilaha ill-Allah (There is no god but Allah) and seeks the pleasure of Allah through it? They said: Allah and His Messenger know beet. One (among the audience) said: We see his inclination and wellwishing for hypocrites only. Upon this the Messenger of Allah'(may peace be upon him) again said: Verily Allah has forbidden the Fire for one who says: There is no god but Allah, thereby seeking Allah's pleasure. Ibn Shihab said: I asked Husain b. Muhammad al-Ansar (he was one of the leaders of Banu Salim) about the hadith transmitted by Mahmud b. Rabi' and he testified it.

Book 4, Number 1385:

    'Itban b. Malik reported : I came to the Messenger of Allah (may peace be upon him) and the rest of the hadith is the same as narrated (above) except this that a man said: Where is Malik b. Dukhshun or Dukhaishin, and also made this addition that Mahmud said: I narrated this ver hadith to many people and among them was Abu Ayyub al-Ansari who said: I cannot think that the Messenger of Allah (may peace be upon him) could have said so as you say. He (the narrator) said: I took an oath that if I ever go to 'Itban. I would ask him about it. So I went to him and found him to be a very aged man, having lost his eyesight, but he was the Imam of the people. I sat by his side and asked about this hadith and he narrated it In the same way as he had narrated it for the first time. Then so many other obligatory acts and commands were revealed which we see having been completed. So he who wants that he should not be deceived would not be deceived.

Book 4, Number 1386:

    Mahmud b. Rabi' reported: I well remember the disgorge of the Messenger of Allah (may peace be upon him) that he did (with water) from a bucket of our house. Mahmud said: 'Itban b. Malik narrated it to me that he had said: Messenger of Allah, I have lost my eyesight, and the rest of the hadith is the same up to these words: "He led us in two rak'ahs of prayer and we detained the Messenger of Allah (may peace be upon him) for serving him the pudding that we had prepared for him," and no mention has been made of what follows next from the addition made by Yunus and Ma'mar.

Chapter 88 : PERMISSIBILITY OF OBSERVING NAFL (SUPEREROGATORY) PRAYER IN CONGREGATION AND THAT TOO ON THE MAT OR THE COVERING CLOTH OR ANY OTHER THING WHICH IS FREE FROM FILTH AND RUBBISH

Book 4, Number 1387:

    Anas b. Malik reported that his grandmother, Mulaika, invited the Messenger of Allah (may peace be upon him) to a dinner which she had prepared. He (the Holy Prophet) ate out of that and then said: Stand up so that I should observe prayer (in order to bless) you Anas b. Malik said: I stood up on a mat (belonging to us) which had turned dark on account of its long use. I sprinkled water over it (in order to soften it), and the Messenger of Allah (may peace be upon him) stood upon it, and I and an orphan formed a row behind him (the Holy Prophet) and the old woman was behind us, and the Messenger of Allah (may peace be upon him) led us in two rak'ahs of prayer and then went back.

Book 4, Number 1388:

    Anas b. Malik reported that the Messenger of Allah (may peace be upon him) wits the best among people in character. On occasions, the time of prayer would come while he was in our house. He would then order to spread the mat lying under him. That was dusted and then water was sprinkled over it. The Messenger of Allah (may peace be upon him) then led the prayer and we stood behind him, and that mat was made of the leaves of date-palm.

Book 4, Number 1389:

    Thabit reported on the authority of Anas: The Apostle of Allah (may peace be upon him) came to us and there was none in our house but I, my mother and my aunt Umm Haram. He (the Holy Prophet) said: Stand up so that I may lead you in prayer (and there was no time for prescribed prayer). He led us in prayer. A person said to Thabit: Where stood Anas with him (the Holy Prophet)? He replied: He was on the right side. He then blessed us, the members of the household with every good of this world and of the Hereafter. My mother said: Messenger of Allah (and then, pointing towards Anas, said), here is your little servant, invoke the blessing of Allah upon him too. He then blessed me with every good, and he concluded his blessings for me (with these words): Allah ! increase his wealth, and his children and make (them the source of) blessing for him.

Book 4, Number 1390:

    Abdullah b. al-Mukhtar heard Musa b. Anas narrating on the authority of Anas b. Malik that the Messenger of Allah (may peace be upon him) led him, his mother or his aunt in prayer. He made me, stand on his right side and made the woman stand, behind us.

Book 4, Number 1391:

    This hadith has also been narrated by Shu'ba with this chain of transmitters.

Book 4, Number 1392:

    Maimuna, the wife of the Apostle of Allah (may peace be upon him), reported: The Messenger of Allah (may peace be upon him) said prayer while I was by his side, and at times when he prostrated his cloth touched me, and he prayed on a small mat.

Book 4, Number 1393:

    Abu Sa'id al-Khudri reported that he went to the Messenger of Allah (may peace be upon him) and found him observing prayer on a mat and prostrating on that.

Chapter 89 : MERIT OF PRAYING IN CONGREGATION AND WAITING FOR PRAYER

Book 4, Number 1394:

    Abu Huraira reported Allah's Messenger (may peace be upon him) as saying: A man's prayer in congregation is more valuable than twenty degrees and some above them as compared with his prayer in his house and his market, for when he performs ablution doing it well, then goes out to the mosque, and he is impelled (to do so) only by (the love of congregational) prayer, he has no other objective before him but prayer. He does not take a step without being raised a degree for it and having a sin remitted for it, till he enters the mosque, and when he is busy in prayer after having entered the mosque. the angels continue to invoke blessing on him as long as he is in his place of worship. saying: O Allah, show him mercy, and pardon him ! Accept his repentance (and the angels continue this supplication for him) so long as he does not do any harm in it, or as long as his ablution is not broken.

Book 4, Number 1395:

    A hadith having the same meaning (as mentioned above) has been transmitted by A'mash.

Book 4, Number 1396:

    Abu Huraira reported Allah's Messenger (may peace be upon him) as saying: The angels invoke blessings on everyone among you so long as he is in a place of worship with these words: O Allah ! pardon him, O Allah, have mercy upon him, (and they continue to do so) as long as, he ablution (of the worshipper) is not broken, and one among you is in prayer and so long as he is detained for the prayer.

Book 4, Number 1397:

    Abu Huraira reported Allah's Messenger (may peace be upon him) as saying: The servant is constantly in prayer so long as he is in a place of worship waiting for the prayer (to be observed in congregation), and the angels invoke (blessings upon him in these words): O Allah ! pardon him. O Allah ! show mercy to him, (and they continue to do so) till he returns (from the mosque having completed the prayer) or his ablution breaks. I said: How is the ablution broken? He said: By breaking of the wind noiselessly or with noise.

Book 4, Number 1398:

    Abu Huraira reported the Messenger of Allah (may peace be upon him) as saying: Everyone among you is constantly in prayer so long as the prayer detains him (for this noble objective) and nothing prevents him to return to his family but the prayer.

Book 4, Number 1399:

    Abu Huraira reported: The Messenger of Allah (may peace be upon him) said: Anyone amongst you who sat in a place of worship waiting for the prayer is in prayer and his ablution is not broken, the angels invoke blessing upon him (in these words): O Allah !pardon him. O Allah ! have mercy upon him.

Book 4, Number 1400:

    A hadith like this has been narrated by Hammam b. Munabbih on the authority of Abu Huraira.

Chapter 90 : EXCELLENCE OF TAKING MANY STEPS FOR REACHING THE MOSQUE

Book 4, Number 1401:

    Abu Musa reported Allah's Messenger (may peace be upon him) as saying: The most eminent among human beings (as a recipient of) reward (is one) who lives farthest away, and who has to walk the farthest distance, and he who waits for the prayer to observe it along with the Imam, his reward is greater than one who prays (alone) and then goes to sleep. In the narration of Abu Kuraib (the words are): "(He waits) till he prays along with the Imam in congregation."

Book 4, Number 1402:

    Ubayy b. Ka'b reported: There was a man, and I do not know of any other man, whose house was farther than his from the mosque and he never missed the prayer (in congregation). It was said to him or I said to him: It you were to buy a donkey you could ride upon it In the dark nights and in the burning sand. He said: I do not like my house to be situated by the side of the mosque, for I (eagerly) desire that my steps towards the mosque and back from it, should be recorded when I return to my family. Upon this the Messenger of Allah (may peace be upon him) said: Allah has gathered all (rewards) for you.

Book 4, Number 1403:

    This hadith has been transmitted by Taimi with the same chain of narrators.

Book 4, Number 1404:

    Ubayy b. Ka'b reported: There was a person among the Ansar whose house was situated at the farthest end of Medina, but he never in missed any prayer along with the Messenger of Allah (may peace be upon him). We felt pity for him and said to him: O, so and so, had you bought a donkey it would have saved you from the burning sand and would have saved you from the reptiles of the earth. He said : Listen I by Allah, I do not like my house to be situated by the side of Muhammad (may peace be upon him). I took (these words of his) ill and came to the Apostle of Allah (may peace be upon him) and informed him about (these words). He (the Holy Prophet) called him and he said exactly like that (which he had mentioned to Ubbay b. Ka'b), but made a mention of this (also) that he wanted a reward for his steps. Upon this the Apostle of Allah (may peace be upon him) said: In fact for you is the reward which you expect.

Book 4, Number 1405:

    A hadith like this has been narrated by 'Asim with the same chain of transmitters.

Book 4, Number 1406:

    Jabir b. 'Abdullah narrated: Our houses were situated far away from the mosque; we, therefore, decided to sell our houses so that we may be able to come near the mosque. The Messenger of Allah (may peace be upon him) forbade us (to do so) and said: There is for every step (towards the mosque) a degree (of reward) for you.

Book 4, Number 1407:

    Jabir b. Abdullah reported: There were some plots vacant around the mosque. Banu Salama decided to shift (to this land) and come near the mosque. This (news) reached the Messenger of Allah (may peace be upon him) and he said to them (Banu Salama): I have received (information) that you intend to shift near the mosque. They said: Yes, Messenger of Allah, we have taken this decision. Upon this he (the Holy Prophet) said: O Banu Salama, live in your houses, for your steps are recorded; live in your houses, for your steps are recorded.

Book 4, Number 1408:

    Jabir b. Abdullah reported that Banu Salama decided to shift near the mosque (as there were) some plots vacant. This (news) reached the Apostle of Allah (may peace be upon him), whereupon he said: O people of the Salama tribe, you better stay in your houses (where you are living), for your footsteps are recorded They said. We could not be more delighted even by shifting (near the mosque) as we were delighted (on hearing these words from the Messenger of Allah (may peace be upon him).

Book 4, Number 1409:

    Abu Huraira reported: The Messenger of Allah (may peace be' upon him) said: He who purified himself in his house, and then he walked to one of the houses of Allah for the sake of performing a Fard (obligatory act) out of the Fara'id (obligatory acts) of Allah, both his steps (would be significant) as one of them would obliterate his sin and the second one would raise his status.

Book 4, Number 1410:

    In the hadith narrated of the authority of Abd Huraira the Messenger of Allah (may peace be upon him) is reported to have said. while in the hadith narrated by Bakr (the words are like this) : He heard the Messenger of Allah (may peace be upon him) as saying: just see, can anything of his filthiness remain (on the body of) any one of you if there were a river at his door in which he washed himself five times daily? They, said: Nothing of his filthiness will remain (on his body). He said: That is like the five prayers by which Allah obliterates sins.

Book 4, Number 1411:

    Jabir b. 'Abdullah reported that the Messenger of Allah (may peace be upon him) said: The similitude of five prayers is like an overflowing river passing by the gate of one of you in which he washes five times daily Hasan said: No filthiness can remain on him.

Book 4, Number 1412:

    Ata' b. Yasar reported, on the authority of Abu Huraira, the Apostle of Allah (may peace be upon him) as saying: He who went towards the mosque in the morning or evening, Allah would arrange a feast for him morning or evening in Paradise.

Chapter 91 : EXCELLENCE OF SITTING AT THE PLACE'OF WORSHIP AFTER THE DAWN PRAYER AND EXCELLENCE OF THE MOSQUE

Book 4, Number 1413:

    Simak b. Harb reported: I said to Jabir b. Samura: Did you sit in the company of the Messenger of Allah (may peace he upon him)? He said: Yes, very often. He (the Holy Prophet) used to sit at the place where he observed the morning or dawn prayer till the sun rose or when it had risen; he would stand, and they (his Companions) would talk about matters (pertaining to the days) of ignorance, and they would laugh (on these matters) while (the Holy Prophet) only smiled.

Book 4, Number 1414:

    Simak narrated on the authority of Jabir b. Samura that when the Apostle of Allah (may peace be upon him) observed the dawn prayer, he sat at the place of worship till the sun had risen enough.

Book 4, Number 1415:

    This hadith has been narrated by Simak with the same chain of transmitters, but no mention has been made of ,enough".

Book 4, Number 1416:

    Abu Huraira reported that the Messenger of Allah (may peace be upon him) said: The parts of land dearest to Allah are its mosques, and the parts most hateful to Allah are markets.

Chapter 92 : WHO DESERVES MOST TO ACT AS IMAM

Book 4, Number 1417:

    Abu Sa'id al-Khudri reported Allah's Messenger (may peace be upon him) as saying: When there are three persons, one of them should lead them. The one among them most worthy to act as Imam is one who is best versed in the Qur'an.

Book 4, Number 1418:

    A hadith like this has been narrated by Qatida with the same chain of transmitters.

Book 4, Number 1419:

    This hadith has been narrated by Abu Sa'id al-Khudri by another chain of transmitters.

Book 4, Number 1420:

    Abu Mas'ud al-Ansari reported Allah's Messenger (may peace be upon him) as saying: The one who is most versed in Allah's Book should act as Imam for the people, but If they are equally versed in reciting it, then the one who has most knowledge regarding Sunnah if they are equal regarding the Sunnah, then the earliest one to emigrate; it they emigrated at the same time, then the earliest one to embrace Islam. No man must lead another in prayer where (the latter) has authority, or sit in his place of honour in his house, without his permission. Ashajj in his narration used the word , "age" in place of "Islam".

Book 4, Number 1421:

    A hadith like this has been narrated by A'mash by the same chain of transmitters

Book 4, Number 1422:

    Abu Mas'ud al-Ansari reported: The Messenger of Allah (may peace be upon him) said to us: The one who is well grounded in Allah's Book and is distinguished among them in recitation should act as ; Imam for the people. and if they are equally versed in reciting it, then the one who has most knowledge regarding Sunnah; if they are equal regarding the Sunnah, then the earliest one to emigrate; If they emigrated at the same time, then the oldest one in age. No man must lead another in prayer in latter's house or where (the latter) has authority, or sit in his place of honour in his house, except that he gives you permission or with his permission.

Book 4, Number 1423:

    Malik b. Huwairith rejected: We came to the Messenger of Allah (may peace be upon him) and we were all young men of nearly equal age. We stayed with him (the Holy Prophet) for twenty nights, and as the Messenger of Allah may peace be upon him) was extremely kind and tender of heart, he. therefore, thought that we were eager (to see) our family (we felt home-sickness). So he asked us about the members of the family that we had left behind and when we informed him, he said: Go back to your family, stay with them, and teach them (beliefs and practices of Islam) and exhort them to good, and when the time for prayer comes, one amongst you should-announce Adzan and then the oldest among you should lead the prayer.

Book 4, Number 1424:

    This hadith has been transmitted by Ayyub with the same chain of narrator.

Book 4, Number 1425:

    Malik b. Huwairith Abu Sulaiman reported: I came to the Messenger of Allah (may peace be upon him) along with other persons and we were young men of nearly equal age, and the rest of the hadith was transmitted like the hadith narrated before.

Book 4, Number 1426:

    Malik b Huwairith reported: I came to the Apostle of Allah (may peace be upon him) along with a companion of mine, and when we intended to return from him, he said: When there is time for prayer, announce prayer, pronounce Iqama, and the oldest amongst you should lead the prayer.

Book 4, Number 1427:

    This hadith has been narrated with the same chain of transmitters, but al-Hadra' made this addition: "They both were equal in recitation."

Chapter 93 : THE EXCELLENCE OF QUNUT IN ALL THE PRAYERS WHEN ANY CALAMITY BEFALLS THE MUSLIMS

Book 4, Number 1428:

    Abu Salama b. Abd al-Rahman b. 'Auf heard Abu Huraira say: (When) Allah's Messenger (may peace be upon him) (wished to invoke curse or blessing on someone, he would do so at the end) of the recitation in the dawn prayer, when he had pronounced Allah-o-Akbar (for bending) and then lifted his head (saying): "Allah listened to him who praised Him; our Lord ! to Thee is all praise"; he would then stand up and say: "Rescue al-Walid b. Walid, Salama b. Hisham, and 'Ayyash b. Abd Rabi'a, and the helpless among the Muslims. O Allah ! trample severely Mudar and cause them a famine (which broke out at the time) of Joseph. O Allah! curse Lihyan, Ri'l, Dhakwan, 'Usayya, for they disobeyed Allah and His Messenger." (The narrator then adds): The news reached us that he abandoned (this) when this verse was revealed: "Thou but no concern in the matter whether He turns to them (mercifully) or chastises them ; surely they are wrongdoers" (ill. 127)

Book 4, Number 1429:

    This hadith has been narrated on the authority of Abu Huraira by another chain of transmitters up to the words: "And cause them a famine like that (which broke out at the time) of Joseph," but the subsequent portion was not mentioned.

Book 4, Number 1430:

    Abu Salama reported it on the authority of Abu Huraira that the Apostle of Allah (may peace be upon him) recited Qunut after ruku' in prayer for one mouth at the time of reciting (these words): "Allah listened to him who praised Him," and he said in Qunut: "0 Allah! rescue al-Walid b. al-Walid; O Allah! rescue Salama b. Hisham; O Allah! rescue 'Ayyash b. Abu Rabi'a; O Allah! rescue the helpless amongst the Muslims; O Allah! trample Mudar severely; O Allah! cause them a famine like that (which was caused at the time) of Joseph." Abu Huraira (further) said: I saw that the Messenger of Allah (may peace be upon him) afterwards abandoned this supplication. I, therefore said: I see the Messenger of Allah (may peace be upon him) abandoning this blessing upon them. It was raid to him (Abu Huraira): Don't you see that (those for whom was blessing invoked by the Holy Prophet) have come (i.e. they have been rescued)?

Book 4, Number 1431:

    Abu Salama narrated that Abu Huraira told him that when the Messenger of Allah (may peace be upon him) pronounced: "Allah listened to him who praised Him." and before prostration, he would recite this in the 'Isya' prayer: O Allah! rescue 'Ayyash b. Abu Rabi'a, and the rest of the hadith is the same as narrated by Auza'i to the words: "Like the famine (at the time) if Joseph." but he made no mention of that which follows afterwards.

Book 4, Number 1432:

    Abu Salama b. 'Abd al-Rahman is reported to have said that he had heard Abu Huraira saying: I would say prayer along with you which is near to the prayer of the Messenger of Allah (may peace be upon him). and Abu Huraira recited Qunut in the noon and in the 'Isya' and in the morning prayer, and invoked blessing (of Allah) upon Muslims-and curse upon the unbelievers.

Book 4, Number 1433:

    Anas b. Malik reported that the Messenger of Allah (may peace be upon him) invoked curse in the morning (prayer) for thirty days upon those who killed the Companions (of the Holy Prophet) at Bi'r Ma'una. He cursed (the tribes) of Ri'l, Dhakwan, Lihyan, and Usayya, who had disobeyed Allah and His Messenger (may peace be upon him). Anas said: Allah the Exalted and Great revealed (a verse) regarding those who were killed at Bi'r Ma'una, and we recited it, till it was abrogated later on (and the verse was like this): ,convey to it our people the tidings that we have met our Lord, and He was pleased with us and we were pleased with Him".

Book 4, Number 1434:

    Muhammad reported: I asked Anas whether the Messenger of Allah (may peace be upon him) observed Qunut in the dawn prayer. He said: Yes, (he did so) after the ruku', for a short while.

Book 4, Number 1435:

    Anas b. Malik reported: The Messenger of Allah (may peace be upon him) observed Qunut for a month in the dawn prayer after ruku' and invoked curse upon Ri'l, Dhakwan, and said that 'Usayya had disobeyed Allah and His Apostle (may peace be upon him).

Book 4, Number 1436:

    Anas b. Malik reported that the Messenger of Allah (may peace be upon him) observed Qunut for a month in the dawn prayer after ruku' and invoked curse upon Bani Usayya.

Book 4, Number 1437:

    Asim reported: I asked Anas whether Qunut was observed (by the Holy prophet) before ruku' or after ruku'. He replied: Before ruku' . I said: People conceive that the Messenger of Allah (may peace be upon him) observed Qunut after the ruku'. He said: The Messenger of Allah (may peace be upon him) observed Qunut (after the ruku' as the people conceive it) for a mouth invoking curse upon those persons who had killed men among his Companions who were called the reciter (of the Qur'an).

Book 4, Number 1438:

    'Asim reported - I heard Anas saying: Never did I ace the Messenger of Allah (may peace be upon him) so much grieved (at the loss of a) small army as I saw him grieved at those seventy men who were called "reciters" (and were killed) at Bi'r Ma'una; and he invoked curse for full one month upon their murderers.

Book 4, Number 1439:

    This hadith has been narrated by Anas with another chain of transmitters and with minor additions.

Book 4, Number 1440:

    Anas b. Malik reported that the Messenger of Allah (may peace be upon him) observed Qunut for one month Invoking curse upon Ri'l, Dhakwan, 'Usayya. those who disobeyed Allah and His Messenger (may peace be upon him).

Book 4, Number 1441:

    A hadith like this has been transmitted by Anas from the Apostle of Allah (way peace be upon him).

Book 4, Number 1442:

    Anas reported that the Messenger of Allah (may peace be upon him) observed Qunut for one month invoking curse upon some tribes of Arabia (those who were responsible for the murders in Bi'r Ma'una and Raji'), but then abandoned it.

Book 4, Number 1443:

    Al-Bari' b. 'Azib reported that the Messenger of Allah (may peace be upon him) observed Qunut in the morning and evening (prayers).

Book 4, Number 1444:

    Al-Bari' reported that the Messenger of Allah (may peace be upon him) observed Qunut in the dawn and evening (prayers).

Book 4, Number 1445:

    Khufaf b. Ima' al-Ghifari reported that the Messenger of Allah (may peace be upon him) aid in prayer: 0 Allah I curse the tribes of Lihyan, Ri'l, Dhakwan, and 'Usayya for they disobeyed Allah and His Messenger (may peace be upon him). Allah pardoned (the tribe of) Ghifar and Allah granted protection to (the tribe of) Aslam

Book 4, Number 1446:

    Khufaf b. Ima' reported that the Messenger of Allah (may peace he upon him), bowed (in prayer) and then lifted his head and then said: So far as the tribe of Ghifar is concerned, Allah had pardoned it, and Allah had granted protection to the tribe of Aslam, and as for the tribe of Usayya, It had disobeyed Allah and His Messenger, (and further said): O Allah! curse the tribe of Lihyan curse Ri'l, and Dhakwan, and then fell in prostration. It is after this that the cursing of the unbelievers got a sanction.

Book 4, Number 1447:

    A hadith like this has been transmitted by Khufaf b. Ima' except this that he did not mention (these words): "cursing of unbelievers got a sanctions.

Chapter 94 : COMPENSATION OF THE MISSED PRAYER AND EXCELLENCE OF OBSERVING IT PROMPTLY

Book 4, Number 1448:

    Abu Huraira reported that when the Messenger of Allah (may peace be upon him) returned from the expedition to Khaibar, he travelled one night, and stopped for rest when he became sleepy. He told Bilal to remain on guard during the night and he (Bilal) prayed as much as he could, while the Messenger of Allah (may peace be upon him) and his Companions slept. When the time for dawn approached Bilal leaned against his camel facing the direction from which the dawn would appear but he was overcome by sleep while he was leaning against his camel, and neither the Messenger of Allah (may peace be upon him) nor Bilal, nor anyone else among his Companions got up, till the sun shone on them. Allah's Messenger (may peace be upon him) was the first of them to awake and, being startled, he called to Bilal who said: Messenger of Allah I may my father and mother be offered as ransom for thee, the same thing overpowered me which overpowered you. He (the Holy Prophet, then) said: Lead the beasts on: so they led their camels to some distance. The Messenger of Allah (may peace be upon him) then performed ablution and gave orders to Bilal who pronounced the Iqama and then led them in the morning prayer. When he finished the prayer he said: When anyone forgets the prayer, he should observe it when he remembers it, for Allah has said: "And observe the prayer for remembrance of Me" (Qur'an. xx. 14). Yunus said: Ibn Shilab used to recite it like this: "(And observe the prayer) for remembrance."

Book 4, Number 1449:

    Abu Huraira reported : We stopped for rest along with the Apostle of Allah (may peace be upon him) and did not awake till the sun rose. The Apostle of Allah (may peace be upon him) then told us that everybody should take hold of his camel's nosestring (get out of this ground) for it was the place where devil had visited us. We did accordingly. He then called for water and performed ablution and then performed two prostrations. Ya'qub said: Then he prayed (performed) two prostrations. then takbir was pronounced for prayer and then he offered the morning prayer (in congregation).

Book 4, Number 1450:

    Abu Qatida reported: The Messenger of Allah (way peace be upon him) addressed us and said: You would travel In the evening and the might till (God willing) you would come in the morning to a place of water. So the people travelled (self absorbed) without paying any heed to one another, and the Messenger of Allah (may peace be upon him) also travelled till It was midnight. I was by his side. The Messenger of Allah (may peace be upon him) began to doze and leaned (to one side) of his camel. I came to him and I lent him support without awaking him till he sat poised on his ride. He went on travelling till a major part of the night was over and (he again) leaned (to one side) of his camel. I supported him without awaking him till he sat "bed on his ride. and then travelled till it was near dawn. He (again) leaned which was far more inclined than the two earlier leanings and he was about to fall down. So I came to him and supported him and he lifted his head and said ; Who is this? I said: it is Abu Qatida. He (the Holy Prophet again) said: Since how long have you been travelling along with me like this? I said: I have been travelling in this very state since the night. He said: May Allah protect you, as you have protected His Apostle (from falling down), and again said: Do you see that we are hidden from the people?- and again said: Do you see anyone? I said: Here is a rider. I again said: Here Is another rider till we gathered together and we were seven riders. The Messenger of Allah (may peace be upon him) stepped aside of the highway and placed his head (for sleep and said): Guard for us our prayers. The Messenger of Allah (may peace be upon him) was the first to wake up and the rays of the sun were falling on his back. We got up startled He (the Holy Prophet) said: Ride on So we rode on till the sun had (sufficiently) risen. He then came down from his camel and called for a jug of water which I had with me. There was a little water in that. He performed ablution kith that which was less thorough as compared with his usual ablutions and some water of that had been left. He (the Holy Prophet) said to Abu Qatida: Keep a watch over your jug of water; it would have (a miraculous) condition about it. Then Bilal summoned (people) to prayer and then the Messenger of Allah (may peace be upon him) observed two rak'ahs and then said the morning prayer as he said every day. The Messenger of Allah (may peace be upon him) (then) rode on and we rode along with him and some of us whispered to the others saying: How would there be compensation for omission in our prayers? Upon this he (the Apostle of Allah) said: Is there not in me (my life) a model for you ? There is no omission in sleeping. The (cognizable) emission is that one should not say prayer (intentionally) till the time of (he other prayer comes. So he who did like it (omitted prayer in sleep or due to other unavoidable circumstances) should say prayer when he becomes aware of it and on the next day he should observe it at its prescribed time. He (the Holy Prophet) said: What do you think the people would have done (at this hour)? They would have in the morning found their Apostle missing from amongst them and then Abu Bakr and 'Umar would have told them that the Messenger of Allah (may peace be upon him) must be behind you, he cannot leave you behind (him), but the people said: The Messenger of Allah (may peace be upon him) is ahead of you. So if you had obeyed Abu Bakr and Umar, you would have gone on the right path. So we proceeded on till we came up to the people (from whom we had lagged behind) and the day had considerably risen and everything became hot, and they (the Companions of the Holy Prophet) said: Messenger of Allah, we are dying of thirst. Upon this he (the Holy Prophet) remarked: There is no destruction for you. And again said: Bring that small cup of mine and he then asked for the jug of water to be brought to him. The Messenger of Allah (may peace be upon him) began to pour water (in that small cup) and Abu Qatida gave them to drink. And when the people saw that there was (a little) water in the jug, they fell upon it. Upon this the Messenger of Allah (may peace be upon him) said: Behave well; the water (is enough) to satiate all of you. Then they (the Companions) began to receive (their share of) water with calmness (without showing any anxiety) and the Messenger of Allah (may peace be upon him) began to fill (the cap), and I began to serve them till no one was left except me and the Messenger of Allah (may peace be upon him). He then filled (the cup) with water and said to me: Drink it. I said: Messenger of Allah, I would not drink till you drink. Upon this he said: The server of the people Is the last among them to drink. So I drank and the Messenger of Allah (may peace be upon him) also drank and the people came to the place of water quite happy and satiated. 'Abdullah b. Rabah said: I am going to narrate this hadith in the great mosque, when 'Imran b. Husain said: See, O young man, how will you narrate for I was also one of the riders on that night? I said: So you must be knowing this hadith well. He said: Who are you? I said: I am one of the Ansar. Upon this he said: You narrate, for you know your hadith better. I, therefore, narrated it to the people. 'Imran said: I was also present that night, but I know not anyone else who learnt it so well as you have learnt.

Book 4, Number 1451:

    'Imran b. Husain reported: I was with the Apostle of Allah (may peace be upon him) in a journey. We travelled the whole of the night, and when it was about to dawn, we got down for rest, and were overpowered (by sleep) till the sun shone. Abu Bakr was the first to awake amongst us. and we did not awake the Apostle of Allah (may peace be upon him) from his sleep allowing him to wake up (of his own accord). It was 'Umar who then woke up. He stood by the side of the Apostle of Allah (may peace be upon him) and recited takbir in a loud voice till the Messenger of Allah (may peace be upon him) woke up. When he lifted his head, he saw that the sun had arisen; he then said: Proceed on. He travelled along with us till the sun shone brightly. He came down (from his camel) and led us in the morning prayer. A person, however, remained away from the people and did not say, prayer along with us. After having completed the prayer, the Messenger of Allah (may peace be upon him) said to him: O, so and so, what prevented you from observing prayer with us? He said: Apostle of Allah! I was not in a state of purity. The Messenger of Allah (may peace be upon him) ordered him arid lie performed Tayammum with dust and said prayer. He then urged me to go ahead immediately along with other riders to find out water, for we felt very thirsty. We were traveling when we came across a woman who was sitting (on a camel) with her feet hanging over two leathern water bags. We said to her: How far is water available? She , said: Far, very far, very far. You cannot get water. We (again) said: How much distance is there between (the residence of) your family and water? She said: It is a day and night journey. We said to her: You go to the Messenger of Allah (may peace be upon him). She said: Who is the Messenger of Allah ? We somehow or the other managed to bring her to the Messenger of Allah (may peace be upon him) and he asked about her, and she informed him as she had informed us that she was a widow having orphan children. He ordered that her camel should be made to kneal down and he gargled in the opening (of her leathern water-bag). The camel was then raised up and we forty thirsty men drank water till we were completely satiated, and we filled up all leathern water-bags and water-skins that we had with us and we washed our companions, but we did not make any camel drink, and (the leathern water-bags) were about to burst (on account of excess of water). He then said: Bring whatever you have with you. So we collected the bits (of estable things) and dates and packed them up in a bundle, and said to her : Take it away. This is meant for your children, and know that we have not its any way done any loss to your water.W hen she came to her family she said: I have met the greatest magician amongst human beings, or he is an apostle, as he claims to be, and she then narrated what had happened and Allah guided aright those people through that woman. She affirmed her faith in Islam and so did the people embrace Islam.

Book 4, Number 1452:

    'Imran b. Husain reported : We were with the Messenger of Allah (may peace be upon him) in a journey and we travelled throughout the night till at the end, just before dawn, we lay down (for rest), and nothing is sweeter for a traveller than this and none awakened us but the heat of the sun, and the rest of the hadith is the same (as mentioned above) except this additien : "When 'Umar b. Khattab woke up, he saw what had happened to the people. And he was a man having a big belly and strongly built ; he recited takbir in a loud voice till the Messenger of Allah (may peace be upon him) woke up by the loudness of his voice in takbir. When the Messenger of Allah (may peace be upon him) got up, the people told him what had happened. Upon this the Messenger of Allah (may peace be upon him) said: There is no harm; you better proceed further," and (the rest of the hadith) was narrated.

Book 4, Number 1453:

    Abu Qatada reported that when the Messenger of Allah (may peace be upon him) was in a journey he got down for rest at night, and he used to lie down on his right side, and when he lay down for rest before the dawn, he used to stretch his forearm and place his head over his palm.

Book 4, Number 1454:

    Qatada reported from Anas b. Malik that the Messenger of Allah (may peace be upon him) said: He who forgets the prayer should say it when he remembers it, there is no explation for it, except this. Qatada said : (Allah says) "And observe prayer for remembrance of Me "

Book 4, Number 1455:

    This hadith has been narrated by Qatada, but here no mention has been made of "There is no explation for it except this."

Book 4, Number 1456:

    Qatada narrated it on the authority of Anas b. Malik that the Apostle of Allah (may peace be upon him) said : He who forgets tte prayer, or he slept (and it was omitted), its expiation is this only that he should observe it when he remembers it.

Book 4, Number 1457:

    Qatada reported it on the authority of Anas b. Malik that the Messenger of Allah (may peace be upon him) said : When any one of you omits the prayer due to sleep or he forgets it, he should observe it when he remembers it, for Allah has said: "Observe prayer for remembrance of Me."

Chapter 95 : THE PRAYER OF TRAVELLERS AND SHORTENING OF IT

Book 4, Number 1458:

    'A'isha, the wife of the Messenger of Allah (may peace be upon him), reported : The prayer was prescribed as two rak'abs, two rak'ahs both in journey and at the place of residence. The prayer while travelling remained as it was (originally prescribed), but an addition was made in the prayer (observed) at the place of residence.

Book 4, Number 1459:

    'A'isha, the wife of the Messenger of Allah (may peace be upon him), said Allah prescribed the prayer as two rak'ahs, then it was completed (to four rak'ahs) at the place of residence, but was retained in the same position in journey as it was first made obligatory.

Book 4, Number 1460:

    'A'isha reported: The prayer was prescribed as consisting of two rak'abs, the prayer in travelling remained the same, but the prayer at the place of residence was completed. (Zuhri said he asked 'Urwa why 'A'isha said prayer in the complete form during journey, and he replied that she interpreted the matter herself as 'Uthman did.)

Book 4, Number 1461:

    Yahya b. Umayya said: I told 'Umar b. al-Khattab that Allah had said: "You may shorten the prayer only if you fear that those who are unbelievers may afflict you" (Qur'an, iv. 101), whereas the people are now safe. He replied : I wondered about it in the same way as you wonder about it, so I asked the Messenger of Allah (may peace be upon him) about it and he said: It is an act of charity which Allah has done to you, so accept His charity.

Book 4, Number 1462:

    Ya'la b. Umayya reported : I said to 'Umar b. al-Khattab, and the rest of the hadlth is the same.

Book 4, Number 1463:

    Ibn 'Abbas reported : Allah has prescribed the prayer through the word of your Prophet (may peace be upon him) as four rak'ahs when resident, two when travelling, and one when danger is present.

Book 4, Number 1464:

    Ibn 'Abbas reported : Allah has prescribed the prayer by the tongue of your Apostle (may peace be upon him) as two rak'ahs for the traveller, four for the resident, and one in danger.

Book 4, Number 1465:

    Musa b. Salama Hudhali said: I asked Ibn 'Abbas: How should I say prayer when I am in Mecca, and when I do not pray along with the Imam? He said: Two rak'ahs (of prayer) is the Sunnah of Abu'l-Qasim (may peace be upon him).

Book 4, Number 1466:

    A hadith like this has been narrated by Abu Qatada with the same chain of transmitters.

Book 4, Number 1467:

    Hafs b. 'Asim said: I accompanied Ibn 'Umar on the road to Mecca and he led us in two rak'ahs at the noon prayer, then he went forward and we too went along with him to a place where he alighted, and he sat and we sat along with him, and he cast a glance to the side where he said prayer and he saw people standing and asked: What are they doing? I said: They are engaged in glorifying Allah, offering Sunnah prayer. He said: If I had done so I would have perfected my prayer; O my nephew ! I accompanied the Messenger of Allah (may peace be upon him) on a journey, and he made no addittion to two rak'ahs, till Allah called him. I accompanied Abu Bakr and he made no addition to two rak'ahs till Allah caused him to die. I accompanied 'Umar and he made no addition to two rak'ahs till Allah caused him to die. I accompanied 'Uthman and he made no addition to two rak'ahs, till Allah caused him to die, and Allah has said: "There is a model pattern for you in the Messenger of Allah" (al-Qur'an, xxxiii. 21).

Book 4, Number 1468:

    Hafs b. 'Asim reported: I fell ill and lbn 'Umar came to inquire after my health, and I asked him about the glorification of Allah (i.e. prayer) while travelling. Thereupon he said: I accompanied the Messenger of Allah (may peace be upon him) on a journey but I did not see him glorifying Him, and were I to glorify (Him). I would have completed the prayer. Allah, the Exalted, has said: "Verily there is a model pattern for you in the Messenger of Allah."

Book 4, Number 1469:

    Anas reported: The Messenger of Allah (may peace be upon him) said four rak'ahs in the noon prayer while at Medina, but he offered two rak'ahs in the afternoon prayer at Dhu'l-Hulaifa.

Book 4, Number 1470:

    Anas b. Malik is reported to have said: I observed four rak'ahs in the noon prayer with the Messenger of Allah (may peace be upon him) at Medina, and said two rak'ahs in the afternoon prayer at Dhu'l-Hulaifa.

Book 4, Number 1471:

    Yahya b. Yazid al-Huna'i reported: I asked Anas b. Malik about shortening of prayer. He said: When the Messenger of' Allah (may peace be upon him) had covered a distance of three miles or three farsakh (Shu'ba, one of the narrators, had some doubt about it) he observed two rak'ahs.

Book 4, Number 1472:

    Jubair b. Nufair reported: I went along with Shurahbil b. al-Simt to a village which was situated at a distance of seventeen or eighteen miles, and he said only two rak'ahs of prayer. I said to him (about it) and he said: I saw 'Umar observing two rak'ahs at Dhu'l-Hulaifa and I (too) said to him (about it) and he said: I am doing the same as I saw the Messenger of Allah (may peace be upon him) doing. (This hadith has been transmitted by Shu'ba with the same chain of narrators and it is narrated from Simt, and the name of Shurahbil has not been mentioned, and he said that he had gone to a place called Dumin, situated at a distance of eighteen miles from Hims.)

Book 4, Number 1473:

    Anas b. Malik reported: We went out from Medina to Mecca with the Messenger of Allah (may peace be upon him) and he prayed two rak'ahs at each time of prayer till we returned to Medina. I said: For how long did he stay in Mecca? He said: (For) ten (days).

Book 4, Number 1474:

    A hadith like this has been narrated by Anas by another chain of transmitters.

Book 4, Number 1475:

    Yahya b. Abu Ishaq reported: I heard Anas b. Malik say: We went out for Pilgrimage from Medina. The rest is the same.

Book 4, Number 1476:

    A hadith like this has been transmitted by Anas, but no mention has been made of Pilgrimage.

Book 4, Number 1477:

    Salim b. 'Abdullah (b. 'Umar) reported on the authority of his father that Allah's Messenger (way peace be upon him) observed the prayer of a traveller, i.e. two rak'ahs in Mina, and other places; so did Abu Bakr and 'Umar, and 'Uthman too observed two rak'abs at the beginning of his caliphate, but he then completed four.

Book 4, Number 1478:

    A hadith like this has been reported by Zuhri, with the same chain of transmitters, and in it mention was made of Mina only, but not of other places.

Book 4, Number 1479:

    Ibn 'Umar reported: The Messenger of Allah (may peace be upon him) said two rak'ahs at Mina, and Abu Bakr after him, and 'Umar after Abu Bakr, and 'Uthman at the beginning of his caliphate; then 'Uthman observed four rak'ahs, and when Ibn 'Umar prayed with the Imam, he said four rak'ahs, but when he observed prayer alone, he said two rak'ahs.

Book 4, Number 1480:

    A hadith like this has been narrated by the same chain of transmitters.

Book 4, Number 1481:

    Ibn 'Umar reported: The Apostle of Allah (may peace be upon him) said in Mina the prayer of a traveller (short prayer); Abu Bakr and 'Umar did the same and 'Uthmia did it for eight years or six years. Hafs (one of the narrators) said: Ibn 'Umar would also say two rak'ahs at Mina and then go to bed. I said to him: O uncle, I wish you could have said two rak'ahs (of Sunnah prayer after shorenting the Fard prayer). He said: Were I to do that, I would have completed the prayer.

Book 4, Number 1482:

    This hadith has been narrated by Shu'ba with the same chain of transmitters but no mention has been made of Mina, but they (the narrators) only said: He prayed while travelling.

Book 4, Number 1483:

    Ibrahim reported: I heard 'Abd al-Rahman as saying; 'Uthman led us four rak'ahs of prayer at Mina. It was reported to Abdullah b. Mas'ud and he recited: "Surely we are Allah's and to Him shall we return," and then said: I prayed with the Messenger of Allah (may peace be upon him) at Mina two rak'ahs of prayer. I prayed along with Abu Bakr al-Siddiq two rak'ahs of prayer at Mina. I prayed along with 'Umar b. Khattab two rak'ahs of prayer at Mina. I wish I had my share of the two rak'ahs acceptable (to God) for the four rak'ahs.

Book 4, Number 1484:

    A hadith like this has been reported by A'mash with the same chain of transmitters.

Book 4, Number 1485:

    Haritha b. Wahb reported: I prayed with the Messenger of Allah (may peace be upon him) two rak'abs and most of them offered two rak'ahs only in Mina, while the people felt secure.

Book 4, Number 1486:

    Wahb al-Khuza'i reported: I prayed behind the Messenger of Allah (way peace be upon him) at Mina, and there was the greatest number of people, and they prayed two rak'ahs on the occasion of the Farwell Pilgrmage. (Muslim said: Haritha b. Wahb al-Khuza'i is the brother of 'Ubaidullah b. 'Umar son of Khattab from the side of mother.)

Chapter 96 : PRAYING IN HOUSES WHEN IT RAINS

Book 4, Number 1487:

    Ibn 'Umar announced Adhan for prayer on a cold, windy night. Then added: Pray in your dwellings; and then said: When it was a cold, rainy night, the Messenger of Allah (may peace be upon him) used to command the Mu'adhdhin to say "Pray in your dwellings."

Book 4, Number 1488:

    Ibn 'Umar reported that he summoned (people) to pray on a cold, windy and rainy night, and then observed at the end of the Adhin : Pray in your dwellings, pray in your dwellings, and then said: When it was a cold night or it was raining in a journey the Messenger of Allah (may peace he upon him) used to command the Mu'adhdhin to announce: Pray in your dwellings.

Book 4, Number 1489:

    Ibn 'Umar reported that he summoned (people) to prayer at a place (known as) Dajnan, and the rest of the hadith is the same, and then said: Pray in your dwellings, but he did not repeat for the second time words of Ibn 'Umar (Pray in your dwellings).

Book 4, Number 1490:

    Jabir reported : We set cut with the Messenger of Allah (may peace be upon him) on a journey when it began to rain. Upon this he said: He who desires may pray in his dwelling.

Book 4, Number 1491:

    'Abdullah b. 'Abbas reported that he said to the Mu'adhdhin on a rainy day: When you have announced "I testify that there is no god but Allah; I testify that Muhammad is the Messenger of Allah," do not say : "Come to the prayer," but make this announcement : "Say prayer in your houses." He (the narrator) said that the people disapproved of it. Ibn 'Abbas said : Are you astonished at it ? He (the Holy Prophet), who is better than I, did it. Jumu'a prayer is no doubt obligatory, but I do not like that I should (force you) to come out and walk in mud and slippery ground.

Book 4, Number 1492:

    'Abd al-Hamid reported: I heard 'Abdullah b. al-Harith say: 'Abdullah b. 'Abbas addressed us on a rainy day, and the rest of the hadith is the same, but he made no mention of Jumu'a prayer, and added : He who did it (who commanded us to say prayer in our houses), i.e. the Apostle of Allah (may peace be upon him), is better than I.

Book 4, Number 1493:

    This hadith has been narrated by Ayyub and 'Asim al-Ahwal with the same chain of transmitters, but in this hadith it is not recorded : "i.e. the Apostle of Allah (may peace be upon him)."

Book 4, Number 1494:

    'Abdullah b. Harith reported that Ibn 'Abbas commanded the Mu'adhdhin to (summon the people to prayer on Friday and make announcement to say prayer in their houses) when it was rainy, and the rest of the hadith is the same (except this) that he said: I do not like you should walk in muddy slippery place.

Book 4, Number 1495:

    'Abdullah b. Harith reported that the Mu'adhdhin of Ibn 'Abba said Adhan on Friday (and then made the announcement to say prayer in houses) because it was a rainy day; as it has been narrated by Ma'mar and others, and in this hadith it was mentioned: He who did it, i.e. the Apostle of Allah (may peace be upon him), was better than I.

Book 4, Number 1496:

    A hadith like this that Ibn 'Abbas ordered his Mu'adhdhin (to summon people to prayer and then make announcement to say prayer in their houses) on Friday which was a rainy day, has been transmitted by 'Abdullah b. Harith. Wuhaib, however, says that he did not hear it from him.

Chapter 97 : PERMISSIBILITY OF SAYING NAFL PRAYER ON A RIDING BEAST WHILE ON A JOURNEY, IN WHATEVER DIRECTION IT TURNS

Book 4, Number 1497:

    Ibn 'Umar reported that the Messenger of Allah (may peace be upon him) used to say Nafl prayer on (the back of) his camel in whatever direction it took him.

Book 4, Number 1498:

    Ibn 'Umar reported that the Apostle (may peace be upon him) used to pray on (the back of) his camel in whatever direction it took him.

Book 4, Number 1499:

    Ibn 'Umar reported that the Messenger of Allah (may peace be upon him) used to say prayer on his camel while coming from Mecca to Medina, in whatever direction his face had turned ; and its was (in this context) that this verse was revealed: "So whether you turn thither is Allah's face" (ii. 115).

Book 4, Number 1500:

    This hadith has been narrated by another chain of transmitters and in the one narrated by Ibn Mubarak and Ibn Abu Za'ida (these words are narrated). Ibn 'Umar then recited: "Whether you turn thither is Allah's face," and it was revealed in this context.

Book 4, Number 1501:

    Ibn 'Umar reported: I saw the Messenger of Allah (may peace be upon him) praying (Nafl prayer) on a donkey's back while his face was turned towards Khaibar.

Book 4, Number 1502:

    Sa'id b. Yasar reported: I was travelling along with Ibn 'Umar on the way to Mecca. Sa'id said: When I apprehended dawn, I dismounted (the ride) and observed Witr prayer and then again joined him. Ibn 'Umar said to me: Where were you? I said: I apprehended the appearance of dawn, so I dismounted and observed Witr prayer. Upon this 'Abdullah said: Is there not a model pattern for you in the Messenger of Allah (may peace be upon him)? I said: Yes, by Allah, and (then) he said: The Messenger of Allah (may peace be upon him) used to observe Witr prayer on the camel's back.

Book 4, Number 1503:

    'Abdullah b. Dinar reported on the authority of Ibn 'Umar that the Messenger of Allah (may peace be upon him) used to observe prayer on his ride (no matter) in which direction it had its face turned. 'Abdullah b. Dinar said that Ibn 'Umar used to do like that.

Book 4, Number 1504:

    'Abdullah b. 'Umar reported that the Messenger of Allah (may peace be upon him) used to observe Witr prayer on his ride.

Book 4, Number 1505:

    Salim b. 'Abdullah reported on the authority of his father that the Messenger of Allah (may peace be. upon him) used to observe Nafl (supererogatory) prayer on his ride no matter in what direction it turned its face, and he observed Witr too on it, but did not observe obligatory prayer on it.

Book 4, Number 1506:

    'Abdullah b. 'Amir b. Rabi'a has reported on the authority of his father that he had seen the Messenger of Allah (may peace be upon him) observing Nafl player at night on a journey on the back of his ride in whichever direction it turned its face.

Book 4, Number 1507:

    Anas b. Sirin reported: We met Anas b. Malik as he came to Syria at a place known as 'Ain-al-Tamar and saw him observing prayer on the back of his donkey with his face turned in that direction. (Hammam one of the narrators) pointed towards the left of Qibla, so I said to him: I find you observing prayer towards the side other than that of Qibla. Upon this he said: Had I not seen the Messenger of Allah (may peace be upon him) doing like this, I would not have done so at all.

Chapter 98 : PERMISSIBILITY OF COMBINING TWO PRAYERS ON A JOURNEY

Book 4, Number 1508:

    Ibn 'Umar reported: When the Messenger of Allah (may peace be upon him) was in a state of hurry on a journey, he combined the sunset and 'Isha' prayers.

Book 4, Number 1509:

    Nafi' reported that when Ibn 'Umar was in a state of hurry on a journey, he combined the sunset and 'Isha' prayers after the twilight had disappeared, and he would say that when the Messenger of Allah (may peace be upon him) was in a state of hurry on a journey, he combined the sunset and 'Isha' prayers.

Book 4, Number 1510:

    Salim reported from his father to be saying: I saw the Messenger of Allah (may peace be upon him) combining the sunset and Isha' prayers when he was in a hurry on a journey.

Book 4, Number 1511:

    Salim b. 'Abdullah reported that his father had said: I saw the Messenger of Allah (may peace be upon him) delaying the sunset prayer till he would combine it with the 'Isha' when he hastened to set out on a journey.

Book 4, Number 1512:

    Anas b. Malik reported: When the Messenger of Allah (may peace be upon him) set out on a journey before the sun declined (from the meridian), he delayed the noon prayer till the afternoon prayer, and then dismounted (his ride) and combined them (noon and afternoon prayers), but if the sun had declined before his setting out on a journey, he observed the noon prayer and then mounted (the ride).

Book 4, Number 1513:

    Anas reported: When the Apostle of Allah (may peace be upon him) intended to combine two prayers on a journey, he delayed the noon prayer till came the early time of the afternoon prayer, and then combined the two.

Book 4, Number 1514:

    Anas reported that when the Apostle of Allah (may peace be upon him) had to set out on a journey hurriedly, he delayed the noon prayer to the earlier time for the afternoon prayer, and then he would combine them, and he would delay the sunset prayer to the time when the twilight would disappear and then combine it with the 'Isha' prayer.

Chapter 99 : COMBINATION OF PRAYERS, WHEN ONE IS RESIDENT

Book 4, Number 1515:

    Ibn 'Abbas reported: The Messenger of Allah (may peace be upon him) observed the noon and afternoon prayers together, and the sunset and Isha' prayers together without being in a state of fear or in a state of journey.

Book 4, Number 1516:

    Ibn 'Abbas reported: The Messenger of Allah (may peace be upon him) observed the noon and afternoon prayers together in Medina without being in a state of fear or in a state of journey. (Abu Zubair said: I asked Sa'id [one of the narrators] why he did that. He said: I asked Ibn 'Abbas as you have asked me, and he replied that he [the Holy Prophet] wanted that no one among his Ummah should be put to [unnecessary] hardship.)

Book 4, Number 1517:

    Ibn 'Abbas reported that the Messenger of Allah (may peace be upon him) combined the prayers as he set on a journey in the expedition to Tabuk. He combined the noon prayer with the afternoon prayer and the sunset prayer with the 'Isha' prayer. Sa'id (one of the rawis) said to Ibn 'Abbas: What prompted him to do this? He said: He wanted that his Ummah should not be put to (unnecessary) hardship.

Book 4, Number 1518:

    Mu'adh reported: We set out with the Messenger of Allah (may peace be upon him) on the Tabuk expedition, and he observed the noon and afternoon prayers together and the sunset and 'Isha' prayers together.

Book 4, Number 1519:

    Mu'adh b. Jabal reported: The Messenger of Allah (may peace be upon him) combined in the expedition to Tabuk the noon prayer with the afternoon prayer and the sunset prayer with the 'Isha' prayer. He (one of the narrators) said: What prompted him to do that? He (Mu'adh) replied that he (the Holy Prophet) wanted that his Ummah should not be put to (unnecessary) hardship.

Book 4, Number 1520:

    Ibn 'Abbas reported that the Messenger of Allah (may peace be upon him) combined the noon prayer with the afternoon prayer and the sunset prayer with the 'Isha' prayer in Medina without being in a state of danger or rainfall. And in the hadith transmitted by Waki' (the words are): "I said to Ibn 'Abbas: What prompted him to do that? He said: So that his (Prophet's) Ummah should not be put to (unnecessary) hardship." And in the hadith transmitted by Mu'awiya (the words are): "It was said to Ibn 'Abbas: What did he intend thereby? He said he wanted that his Ummah should not be put to unnecessary hardship."

Book 4, Number 1521:

    Ibn 'Abbas reported: I observed with the Apostle of Allah (may peace be upon him) eight (rak'ahs) in combination, and seven rak'ahs in combination. I (one of the narrators) said: O Abd Sha'tha', I think that he (the Holy Prophet) had delayed the noon prayer and hastened the afternoon prayer, and he delayed the sunset prayer and hastened the 'Isha' prayer. He said: I also think so.

Book 4, Number 1522:

    Ibn 'Abbas reported that the Messenger of Allah (may peace be upon him) observed in Medina seven (rak'ahs) and eight (rak'ahs), i.e. (be combined) the noon and afternoon prayers (eight rak'ahs) and the sunset and 'Isha' prayers (seven rak'ahs).

Book 4, Number 1523:

    'Abdullah b. Shaqiq reported: Ibn 'Abbas one day addressed us in the afternoon (after the afternoon prayer) till the sun disappeared and the stars appeared, and the people began to say: Prayer, prayer. A person from Banu Tamim came there. He neither slackened nor turned away, but (continued crying): Prayer, prayer. Ibn 'Abbas said: May you be deprived of your mother, do you teach me Sunnah? And then he said: I saw the Messenger of Allah (may peace be upon him) combining the noon and afternoon prayers and the sunset and 'Isha' prayers. 'Abdullah b. Shaqiq said: Some doubt was created in my mind about it. So I came to Abu Huraira and asked him (about it) and he testified his assertion.

Book 4, Number 1524:

    'Abdullah b. Shaqiq al-'Uqaili reported: A person said to Ibn 'Abbas (as he delayed the prayer): Prayer. He kept silence. He again said: Prayer. He again kept silence, and he again cried: Prayer. He again kept silence and said: May you be deprived of your mother, do you teach us about prayer? We used to combine two prayers during the life of the Messenger of Allah (may peace be upon him).

Chapter 100 : PERMISSIBILITY OF TURNING TO THE RIGHT AND LEFT IN PRAYER

Book 4, Number 1525:

    Abdullah reported: None of you should give a share to Satan out of your self. He should not deem that it is necessary for him to turn but to the right only (after prayer). I saw the Messenger of Allah (may peace be upon him) turning to the left.

Book 4, Number 1526:

    A hadith like this has been narrated by A'mash, with the same chain of transmitters.

Book 4, Number 1527:

    Suddi reported : I asked Anas how I should turn-to the right or to the left-when I say my prayers. He said : I have very often seen the Messenger of Allah (may peace be upon him) turning to the right.

Book 4, Number 1528:

    Anas reported: The Apostle of Allah (may peace be upon him) used to turn to the right (at the end of the prayer).

Continue to next page: Click here


BOOK 4: The Book of Prayers (Kitab Al-Salat) (Part III)

KITAB AL-SALAT
(THE BOOK OF PRAYERS)
--Continued--

Back
Chapter 101 : EXCELLENCE TO BE ON THE RIGHT SIDE OF THE IMAM

Book 4, Number 1529:

    Bara' reported: When we prayed behind the Messenger of Allah (may peace be upon him) we cherished to be on his right side so that his face would turn towards us (at the end of the prayer), and he (the narrator) said: I heard him say: O my Lord ! save me from Thy torment on the Day when Thoil, wouldst raise or gather Thy servants.

Book 4, Number 1530:

    This hadith has been reported by Mis'ar with the same chain of transmitters, but he made no mention of: "His face would turn towards us."

Chapter 102 : THE UNDESIRABILITY OF OBSERVING NAFL PRAYER, WHEN THE MU'ADHDHIN BEGINS ADHAN

Book 4, Number 1531:

    Abu Huraira reported the Apostle of Allah (may peace be upon him) as saying: When the prayer commences then there is no prayer (valid), but the obligatory prayer. This hadith has been narrated by Warqa' with the same chain of transmitters.

Book 4, Number 1532:

    Abu Huraira reported the Apostle of Allah (may peace be upon him) as saying: When the prayer commences, there is no prayer but the obligatory one.

Book 4, Number 1533:

    A hadith like this has been reported by Ishaq with the same chain of transmitters.

Book 4, Number 1534:

    This hadith has been narrated by Abu Huraira with another chain of transmitters. Hammad (one of the narrators) said : I then met 'Amr (the other narrator) and he narrated it to me, but it was not transmitted directly from the Messenger of Allah (may peace be upon him).

Book 4, Number 1535:

    'Abdullah b. Malik b. Buhaina reported: The Messenger of Allah (may peace be upon him) happened to pass by a person who was busy in praying while the (Fard of the) dawn prayer had commenced. He said something to him, which we do not know what it was. When we turned back we surrounded him and said: What is it that the Messenger of Allah (may peace be upon him) said to you ? He replied : He (the Holy Prophet) had said to me that he perceived as if one of them was about to observe four (rak'ahs) of the dawn prayer. Qa'nabi reported that 'Abdullah b. Malik b. Buhaina narrated it on the authority of his father. (Abu'l-Husain Muslim said) : His assertion that he has narrated this hadith on the authority of his father is not correct.

Book 4, Number 1536:

    Ibn Buhaina reported: The dawn prayer had commenced when the Messen- ger of Allah (may peace be upon him) saw a person observing prayer, whereas the Mu'adhdhin had pronounced the Iqama. Upon this he (the Holy Prophet) remarked: Do you say four (rak'ahs) of Fard in the dawn prayer?

Book 4, Number 1537:

    'Abdullah b. Sarjis reported: A person entered the mosque, while the Messenger of Allah (may peace be upon him) was leading the dawn prayer. He observed two rak'ahs in a corner of the mosque, and then joined the Messenger of Allah (may peace be upon him) in prayer. When the Messenger of Allah (may peace be upon him) had pronounced salutations (he had concluded the prayer), he said: O, so and so, which one out of these two prayers did you count (as your Fard prayer), the one that you observed alone or the prayer that you observed with us ?

Chapter 103 : WHAT IS TO BE RECITED WHILE ENTERING THE MOSQUE

Book 4, Number 1538:

    Abu Usaid reported that the Messenger of Allah (may peace be upon him) said: When any one of you enters the mosque, he should say: "O Allah ! open for me the doors of Thy mercy"; and when he steps out he should say: 'O Allah ! I beg of Thee Thy Grace." (Imam Muslim said: I heard Yahya saying: I transcribed this hadith from the compilation of Sulaiman b. Bilal.)

Book 4, Number 1539:

    A hadith like this has been narrated from the Apostle of Allah (may peace be upon him) by Abu Usaid.

Chapter 104 : EXCELLENCE OF GREETING THE MOSQUE WITH TWO RAK'AHS AND UNDESIRABILITY OF SITTING DOWN BEFORE OBSERVING THEM

Book 4, Number 1540:

    Abu Qatada (a Companion of the Prophet) reported Allah's Messenger (may peace be upon him) as saying: When any one of you enters the mosque, he should observe two rak'ahs (of Nafl prayer) before sitting.

Book 4, Number 1541:

    Abu Qatada, a Companion of the Messenger of Allah (may peace be upon him), said: I entered the mosque, when the Messenger of Allah (may peace be upon him) had been sitting among people, and I also sat down among them. Upon this the Messenger of Allah (may peace be upon him) said: What prevented you from offering two rak'ahs (of Nafl prayer) before sitting down? I said: Messenger of Allah, I saw you sitting and people sitting (around you and I, therefore, sat in your company). He (the Holy Prophet) then said: When anyone among you enters the mosque, he should not sit till he has observed two rak'ahs.

Book 4, Number 1542:

    Jabir b. 'Abdullah reported: The Apostle of Allah (may peace be upon him) owed me a debt; he paid me back and made an addition (of this). I entered the mosque and he (the Holy Prophet) said to me: Observe two rak'ahs of prayer.

Chapter 105 : EXCELLENCE OF OBSERVING TWO RAK'AHS IN THE MOSQUE FOR ONE WHO COMES BACK FROM A JOURNEY

Book 4, Number 1543:

    Jabir b. 'Abdullah reported: The Messenger of Allah (may peace be upon him) bought a camel from me. When he came back to Medina, he ordered me to come to the mosque and observed two rak'ahs of prayer.

Book 4, Number 1544:

    Jabir b. 'Abdullah reported: I went with the Messenger of Allah (may peace be upon him) on an expedition and my camel delayed me and I was exhausted. The Messenger of Allah (may peace be upon him) thus came earlier than I, whereas I came on the next day and went to the mosque and found him (the Holy Prophet) at the gate of the mosque. He said: It is now that you have come. I said. Yes. He said: Leave your camel and enter (the mosque) and observe two rak'ahs. He (the narrator) said: So I entered and observed (two rak'ahs) of prayer and then went back.

Book 4, Number 1545:

    Ka'b b. Malik reported: The Messenger of Allah (may peace be upon him) did not come back from the journey but by day in the forenoon, and when he arrived, he went first to the mosque, and having prayed two rak'ahs in it he sat down in it.

Chapter 106 : EXCELLENCE OF THE FORENOON PRAYER, TWO ARE ITS MINIMUM RAK'AHS AND EIGHT ARE ITS MAXIMUM RAK'AHS. AND AVERAGE RAK'AHS ARE FOUR OR SIX, AND EXHORTATION FOR THE OBSERVANCE OF THE PRAYER

Book 4, Number 1546:

    'Abdullah b. Shaqiq reported: I asked 'A'isha whether the Apostle of Allah (may peace be upon him) used to observe the forenoon prayer. She said: No, but when he came back from the journey.

Book 4, Number 1547:

    'Abdullah b. Shaqiq reported: I aksed 'A'isha whether the Apostle of Allah (may peace be upon him) used to observe the forenoon prayer. She said: No, except when he came back from a journey.

Book 4, Number 1548:

    'Urwa reported 'A'isha to be sayidg: I have never seen the Messenger of Allah (may peace be upon him) observing the supererogatory prayer of the forenoon, but I observed it. And if the Messenger of Allah (way peace be upon him) abandoned any act which he in fact loved to do, it was out of fear that if the people practised it constantly, it might become obligatory for them.

Book 4, Number 1549:

    Mu'adha asked 'A'isha (Allah be pleased with her) how many rak'ahs Allah's Messenger (may peace be upon him) prayed at the forenoon prayer. She replied: Four rak'ahs, but sometimes more as he pleased.

Book 4, Number 1550:

    A hadith like this has been reported by the same chain of transmitters, but with this alteration that the transmitter said: "As Allah pleased."

Book 4, Number 1551:

    Mua'ada 'Adawiyya reported 'A'isha as saying: The Messenger of Allah (may peace be upon him) used to observe four rak'ahs in the forenoon prayer and he sometimes observed more as Allah pleased.

Book 4, Number 1552:

    A hadith like this has been narrated by Qatada with the same chain of transmitters.

Book 4, Number 1553:

    Abd al-Rahman b. Abu Laila reported : No one has ever narrated to me that he saw the Apostle of Allah (may peace be upon him) observing the forenoon prayer, except Umm Hani. She, however, narrated that the Apostle of Allah (may peace be upon him) entered her house on the day of the Conquest of Mecca and prayed eight rak'ahs (adding) : I never saw a shorter prayer than it except that he performed the bowing and prostration completely. But (one of the narrators) Ibn Bashshar in his narration made no mention of the word : "Never".

Book 4, Number 1554:

    'Abdullah b. Harith b. Naufal reported : I had been asking about, as I was desirous to find one among people who should inform me, whether the Messenger of Allah (may peace be upon him) observed the forenoon prayer, but I found none to narrate that to me except Umm Hani, daughter of Abu Talib (the real sister of Hadrat 'Ali), who told me that on the day of the Conquest the Messenger of Allah (may peace be upon him) came (to our house) after the dawn had (sufficiently) arisen. A cloth was brought and privacy was provided for him (the Holy Prophet). He took a bath and then stood up and observed eight rak'ahs. I do not know whether his Qiyam (standing posture) was longer, or bending or prostration or all of them were of equal duration. She (Umm Hani) further said : I never saw him saying this Nafl prayer prior to it or subsequently. (Al-Muradi narrated on the authority of Yunus that he made no mention of the words: "He informed me.")

Book 4, Number 1555:

    Abu Murra, the freed slave of Umm Hani, daughter of Abu Talib, reported Umm Hani to be saying: I went to the Messenger of Allah (may peace be upon him) on the day of the Conquest of Mecca and found him taking bath, and Fatimah, his daughter, had provided him privacy with the help of a cloth. I gave him salutation and he said: Who is she? I said: It is Umm Hani, daughter of Abu Talib. He (the Holy Prophet) said : Greeting for Umm Hani. When he had completed the bath, he stood up and observed eight rak'ahs wrapped up in one cloth. When he turned back (after the prayer), I said to him: Messenger of Allah, the son of my mother 'Ali b. Abu Talib is going to kill a person, Fulan b. Hubaira whom I have given protection. Upon this the Messenger of Allah (way peace be upon him) said: We too have given protection whom you have given protection, O Umm Hani. Umm Hani said: It was the forenoon (prayer).

Book 4, Number 1556:

    Abu Murra narrated on the authority of Umm Hani that the Messenger of Allah (may peace be upon him) on the day of the Conquest of Mecca observed in her house eight rak'abs of prayer in one cloth, its opposite corners having been tied from the opposite sides.

Book 4, Number 1557:

    Abu Dharr reported Allah's Apostle (may peace be upon him) as saying: In the morning charity is due from every bone in the body of every one of you. Every utterance of Allah's glorification is an act of charity. Every utterance of praise of Him is an act of charity, every utterance of profession of His Oneness is an act of charity, every utterance of profession of His Greatness is an act of charity, enjoining good is an act of charity, forbidding what is distreputable is an act of charity, and two rak'ahs which one prays in the forenoon will suffice.

Book 4, Number 1558:

    Abu Huraira reported. My friend (the Holy Prophet, may peace be upon him) has instructed me to do three things : three fasts during every month, two rak'ahs of the forenoon prayer, and observing Witr prayer before going to bed.

Book 4, Number 1559:

    A hadith like this has been narrated by Abu Huraira by another chain of transmitters.

Book 4, Number 1560:

    Abu Huraira reported: My friend Abu'l-Qasim (may peace be upon him) instructed me to do three things, and the rest of the hadith is the same.

Book 4, Number 1561:

    Abu Murra, the freed slave of Umm Hani, narrated on the authority of Abu Darda' : My Friend (may peace be upon him) instructed me in three (acts), and I would never abandon them as long as I live. (And these three things are) : Three fasts during every month, the forenoon prayer, and this that I should not sleep till I have observed the Witr prayer.

Chapter 107 : EXCELLENCE OF OBSERVING TWO RAK'AHS OF SUNNAH IN THE DAWN PRAYER

Book 4, Number 1562:

    Ibn 'Umar reported that Hafsa, the Mother of the Believers, informed him that when the Mu'adhdhin became silent after calling (people) to the dawn prayer, the Messenger of Allah (may peace be upon him) commenced the dawn (prayer) when it dawned by observing two short rak'ahs before the commencement of the (Fard) prayer.

Book 4, Number 1563:

    This hadith has been transmitted by Nafi' with the same chain of narrators.

Book 4, Number 1564:

    Hafsa reported that when it was dawn, the Messenger of Allah (may peace be upon him) did not observe (any other prayers) but two short rak'ahs.

Book 4, Number 1565:

    A hadith like this has been narrated by Shu'ba with the same chain of transmitters.

Book 4, Number 1566:

    Hafsa reported: When the dawn appeared, the Apostle of Allah (may peace be upon him) observed two rak'ahs (of Sunnah prayers).

Book 4, Number 1567:

    'A'isha reported: The Messenger of Allah (may peace be upon him) used to observe two rak'ahs of Sunnah (prayer) when he heard the Adhin and shortened them. (This hadith has been narrated by the same chain of transmitters and in the hadith narrated by Usama the words are: "When it was dawn".)

Book 4, Number 1568:

    'A'isha reported that the Apostle of Allah (may peace be upon him) used to observe two (supererogatory) rak'ahs in between the call to prayer and the Iqama of the dawn prayer.

Book 4, Number 1569:

    'A'isha reported that the Messenger of Allah (may peace be upon him) observed two rak'ahs of the dawn prayer and he shortened them (to the extent) that I (out of surprise) said: Did he recite in them Surah Fatiha (only)?

Book 4, Number 1570:

    'A'isha reported: When it was dawn, the Messenger of Allah (may peace be upon him) observed two rak'ahs, and I would say: Does he recite only the opening chapter of the Qur'an in it?

Book 4, Number 1571:

    'A'isha reported that the Apostle (may peace be upon him) was not so much particular about observing supererogatory rak'ahs as in case of the two rak'ahs of the dawn prayer.

Book 4, Number 1572:

    'A'isha reported: I have never seen the Messenger of Allah (may peace be upon him) hastening as much in observing supererogatory as two rak'ahs before the (Fard) of the dawn prayer.

Book 4, Number 1573:

    'A'isha reported Allah's Messenger as saying: The two rak'ahs at dawn are better than this world and what it contains.

Book 4, Number 1574:

    'A'isha reported that the Apostle of Allah (may peace be upon him) said about the two (supererogatory) rak'ahs of the dawn: They are dearer to me than the whole world.

Book 4, Number 1575:

    Abu Huraira reported that the Messenger of Allah (may peace be upon him) recited in the two (supererogatory) rak'ahs of the dawn (prayer): "Say: O unbelievers," (Qur'an, cix.) and "Say: Allah is one" (cxii.).

Book 4, Number 1576:

    Ibn 'Abbas reported that the Messenger of Allah (may peace be upon him) used to recite in first of the two (supererogatory) rak'ahs of the dawn: "Say: We believed in Allah and what was revealed to us.. ." verses 285-286 from Surah Baqara, and in the second of the two: "I believe in Allah and I bear testimony that we are Muslims" (iii. 51).

Book 4, Number 1577:

    Ibn 'Abbas reported that the Messenger of Allah (may peace be upon him) used to recite in the two (supererogatory) rak'ahs of the dawn prayer: "Say: We believed in Allah and what was revealed to us" and that which is found in Surah Al-i-'lmran:"Come to that word (creed) which is common between you and us"(iii. 64).

Book 4, Number 1578:

    This hadith has been transmitted by another chain of narrators.

Chapter 108 : THE VIRTUE OF SUNAN PRAYERS BEfORE AND AFTER THE FARD RAK'AHS AND THEIR NUMBER

Book 4, Number 1579:

    Umm Habiba (the wife of the Holy Prophet) reported Allah's Messenger (may peace be upon him) as saying: A house will be built in Paradise, for anyone who prays in a day and a night twelve rak'ahs; and she added: I have never abandoned (observing them) since I heard it from the Messenger of Allah (may peace be upon him). Some of the other narrators said the same words: I have never abandoned (observing them) since I heard (from so and so).

Book 4, Number 1580:

    Nu'man b. Salim reported with the same chain of transmitters: He who observed twelve voluntary rak'ahs, a house will be built for him in Paradise.

Book 4, Number 1581:

    Umm Habiba, the wife of the Apostle of Allah (may peace be upon him), reported Allah's Messenger (may peace be upon him) as saying: If any Muslim servant (of Allah) prays for the sake of Allah twelve rak'ahs (of Sun'an) every day, over and above the obligatory ones, Allah will build for him a house in Paradise, or a house will be built for him in Paradise; and I have not abandoned to observe the in after (hearing it from the Messenger of Allah). (So said also 'Amr and Nu'man.)

Book 4, Number 1582:

    Umm Habiba reported the Messenger of Allah (may peace be upon him) having said: If any Muslim servant (of Allah) performed ablution, and performed it well, and then observed every day, the rest of the hadith is the same.

Book 4, Number 1583:

    Ibn 'Umar reported: I prayed along with Allah's Messenger (may peace be upon him) two rak'ahs before and two rak'ahs after the noon prayer, two rak'ahs after the sunset prayer and two rak'ahs after the 'Isha' prayer and two rak'ahs after the Friday prayer; and so far as the sunset, 'Isha' and Friday prayers are concerned, I observed (them) along with the Apostle of Allah (may peace be upon him) in his house.

Chapter 109 : PERMISSIBILITY OF OBSERVING NAFL (VOLUNTARY PRAYER) STANDING OR SITTING AND OBSERVING SOME PART OF IT IN SITTING OR STANDING POSTURES

Book 4, Number 1584:

    'Abdullah b. Shaqiq said: I asked 'A'isha about the Messenger of Allah's (may peace be upon him) voluntary prayers, and she replied : Before the noon prayer, he used to pray four rak'abs in my house; then would go out and lead the people in prayer ; then come in and pray two rak'ahs. He would then lead the people in the sunset prayer; then come in and pray two rak'abs. Then he would lead the people in the 'Isha' prayer, and enter my house and pray two rak'ahs. He would pray nine rak'ahs during the night, including Witr. At night he would pray for a long time standing and for a long time sitting, and when he recited the Holy Qur'an while standing, he would bow and prostrate himself from the standing position, and when he recited while sitting, he would bow and prostrate himself from the sitting position, and when it was dawn he would pray two rak'ahs.

Book 4, Number 1585:

    'A'isha reported that the Messenger of Allah (may peace be upon him) would pray in the night for a long time, and when he prayed standing be bowed in a standing posture, and when he prayed sitting, he bowed in a sitting posture.

Book 4, Number 1586:

    'Abdullah b. Shaqiq reported: I fell ill in Persia and therefore, prayed in a sitting posture, and I asked 'A'isha about it and she said: The Messenger of Allah (may peace be upon him) prayed for a long time in the night sitting.

Book 4, Number 1587:

    'Abdullah b. Shaqiq al-'Uqaili reported: I asked 'A'isha about the prayer of the Messenger of Allah (may peace be upon him) during the night (i.e. Tahajjud prayer) She replied: He used to pray for a long time standing and for a long time sitting in the night, and when he recited the Qur'an while standing, he would bow himself from the standing position, and when he recited while sitting, he would bow from the sitting position.

Book 4, Number 1588:

    'Abdullah b. Shaqiq al-'Uqaili reported: I asked 'A'isha about the prayer of the Messenger of Allah (may peace be upon him). She said: The Messenger of Allah (may peace be upon him) would observe prayer (Nafl) in a standing position as well as in a sitting position, and when he commenced the prayer in a standing position, he bowed in this very position, and when he commenced the prayer in a sitting position, he bowed in this very position.

Book 4, Number 1589:

    'A'isha reported: I did not see the Messenger of Allah (may peace be upon him) reciting (the Qur'an) in the night prayer in a sitting position, till he grew old and then he recited (it) in a sitting position, but when thirty or forty verses were left out of the Surah, he would then stand up, recite them and then bowed.

Book 4, Number 1590:

    'A'isha reported: The Messenger of Allah (may peace be upon him) used to pray while sitting (when he grew old) and he recited in this position and when the recitation equal to thirty or forty verses was left, he would then stand up and recite (for this duration) in a standing position and then bowed himself and then prostrated himself and did the same in the second rak'ah.

Book 4, Number 1591:

    'A'isha reported: The Messenger of Allah (may peace be upon him) used to recite in sitting position (while observing the Tahajjud prayer) and when he intended to bow, he would stand up and recite (for the duration in which) a man (ordinarily) recites forty verses.

Book 4, Number 1592:

    Alqama b. Waqqas reported: I asked 'A'isha how the Messenger of Allah (may peace be upon him) did in the two rak'ahs as he (observed them) sitting. She said: He would recite (the Qur'an) in them, and when he intended to bow, he would stand up and then bowed.

Book 4, Number 1593:

    'Abdullah b. Shaqiq reported: I asked 'A'isha whether the Apostle of Allah (may peace be upon him) observed (Nafl) sitting. She said: Yes, when the people had made him old.

Book 4, Number 1594:

    'Abdullah b. Shaqiq reported: I said to 'A'isha and she made a mention of that (recorded above) about the Apostle of Allah (may peace be upon him).

Book 4, Number 1595:

    'A'isha reported that the Messenger of Allah (may peace be upon him) died (in this very state) that he observed most of his (Nafl) prayers in a sitting position.

Book 4, Number 1596:

    'A'isha reported: When the Messenger of Allah (may peace be upon him) grew bulky and heavy he would observe (most of his Nafl) prayers sitting.

Book 4, Number 1597:

    Hafsa reported: Never did I see the Messenger of Allah (may peace be upon him) observing supererogatory prayer sitting till one year before his death when he would observe Nafl prayer in a sitting position, and he would recite the Surah (of the Qur'an) in such a slow-measured tone (that duration of its recital) became more lengthy than the one longer than this.

Book 4, Number 1598:

    Zuhri reported this hadith with the same chain of transmitters, except this that he made a mention of one year or two years.

Book 4, Number 1599:

    Jabir b. Samura reported that the Apostle of Allah (may peace be upon him) observed (Nafl) prayer sitting before his death.

Book 4, Number 1600:

    'Abdullah b. 'Amr reported: It was narrated to me that the Messenger of Allah (may peace be upon him) had said: The prayer observed by a person sitting is half of the prayer. I came to him (may peace be upon him) and found him praying in a sitting position. I placed my hand on his head. He said: O 'Abdullah b. 'Amr, what is the matter with you? I said: Messenger of Allah, it has been narrated to me that you said: The prayer of a man in a sitting position is half of the prayer, whereas you are observing prayer sitting. He (the Holy Prophet) said: Yes, it is so, but I am not like anyone amongst you.

Book 4, Number 1601:

    A hadith like this has been narrated by Abu Yahya al-A'raj with the same chain of transmitters.

Chapter 110 : PRAYER DURING THE NIGHT AND THE NUMBER OF THE RAK'AHS WHICH THE APOSTLE (MAY PEACE BE UPON HIM) OBSERVED IN THE NIGHT AND OBSERVANCE OF ONE RAKIAH OF WITR

Book 4, Number 1602:

    'A'isha reported that the Messenger of Allah (may peace be upon him) used to pray eleven rak'ahs at night, observing the Witr with a single rak'ah, and when he had finished them, he lay down on his right side, till the Mu'adhdhin came to him and he (the Holy Prophet) then observed two short rak'ahs (of Sunan of the dawn prayer).

Book 4, Number 1603:

    'A'isha, the wife of the Apostle of Allah (may peace be upon him), said that between the time when the Messenger of Allah (may peace be upon him) finished the 'Isha' prayer which is called 'Atama by the people, he used to pray eleven rak'ahs, uttering the salutation at the end of every two rak'ahs, and observing the Witr with a single one. And when the Mu'adhdhin had finished the call (for the) dawn prayer and he saw the dawn clearly and the Mu'adhdhin had come to him, he stood up and prayed two short rak'ahs. Then he lay down on his right side till the Mu'adhdhin came to him for lqama. (This hadith has been narrated with the same chain of transmitters by Ibn Shihab, but in it no mention has been made of Iqama )

Book 4, Number 1604:

    'A'isha reported: The Messenger of Allah (may peace be upon him) used to observe thirteen rak'ahs of the night prayer. Five out of them consisted of Witr, and he did not sit, but at the end (for salutation).

Book 4, Number 1605:

    This hadith has been narrated by Hisham with the same chain of transmitters.

Book 4, Number 1606:

    'A'isha reported that the Messenger of Allah (may peace be upon him) used to pray thirteen rak'ahs during the night including the two rak'ahs (Sunan) of the dawn prayer.

Book 4, Number 1607:

    Abu Salama b. Abd al-Rahman asked 'A'isha about the (night) prayer of the Messenger of Allah (may peace be upon him) during the month of Ramadan. She said: The Messenger of Allah (may peace be upon him) did not observe either in Ramadan or in other months more than eleven rak'ahs (of the night prayer). He (in the first instance) observed four rak'ahs. Ask not about their excellence and their length (i.e. these were matchless in perfection and length). He again observed four rak'ahs, and ask not about their excellence and their length. He would then observe three rak'ahs (of the Witr prayer). 'A'isha again said: I said: Messenger of Allah, do you sleep before observing the Witr prayer? He said: O 'A'isha, my eyes sleep but my heart does not sleep.

Book 4, Number 1608:

    Abu Salama asked 'A'isha about the prayer of the Messenger of Allah (may peace be upon him) She said: He observed thirteen rak'ahs (in the night prayer). He observed eight rak'ahs and would then observe Witr and then observe two rak'ahs sitting, and when he wanted to bow he stood up and then bowed down, and then observed two rak'ahs in between the Adhan and lqama of the dawn prayer.

Book 4, Number 1609:

    Abu Salama reported that he asked 'A'isha about the prayer of the Messenger of Allah (may peace he upon him) (during the night). The rest of the hadith is the same but with this exception that he (the Holy Prophet) observed nine rak'ahs including Witr.

Book 4, Number 1610:

    Abu Salama is reported to have said. I came to 'A'isha. I said: O mother, inform me about the prayer of the Messenger of Allah (may peace be upon him). She said: His (night prayer) in Ramadan and (during other months) was thirteen rak'ahs at night including two rak'ahs of fajr.

Book 4, Number 1611:

    It is reported on the authority of 'A'isha that the prayer of Allah's Messenger (may peace be upon him) in the night consisted of ten rak'ahs. He observed a Witr and two rak'ahs (of Sunan) of the dawn prayer, and thus the total comes to thirteen rak'ahs.

Book 4, Number 1612:

    'A'isha thus reported about the (night prayer) of the Messenger of Allah (may peace be upon him): He used to sleep in the early part of the night, and woke up in the latter part. If he then wished intercourse with his wife, he satisfied his desire, and then went to sleep; and when the first call to prayer was made he jumped up (by Allah, she, i.e. 'A'isha, did not say "he stood up"), and poured water over him (by Allah she, i.e. 'A'isha, did not say that he took a bath but I know what she meant) and if he did not have an intercourse, he performed ablution, just as a man performs ablution for prayer and then observed two rak'ahs.

Book 4, Number 1613:

    'A'isha observed that the Messenger of Allah (may peace be upon him) used to observe prayer in the night and the last of his (night) prayer was Witr.

Book 4, Number 1614:

    Masruq is reported to have asked 'A'isha about the action (most pleasing to) the Messenger of Allah (may peace be upon him). She said: He (the Holy Prophet) loved (that action) which one keeps on doing regularly. I said (to 'A'isha): When did he pray (at night)? She replied: When he heard the cock crow, he got up and observed prayer.

Book 4, Number 1615:

    'A'isha reported: Never did the earlier part of the dawn find the Messenger of Allah (may peace be upon him) but sleeping in my house or near me.

Book 4, Number 1616:

    'A'isha reported: When the Apostle of Allah (may peace be upon him) had prayed the two rak'ahs (Sunan) of the dawn prayer, he would talk to me if I was awake, otherwise he would lie down.

Book 4, Number 1617:

    A hadith like this has been narrated by 'A'isha by another chain of transmitters.

Book 4, Number 1618:

    'A'isha reported: The Messenger of Allah (may peace be upon him) used to pray in the night and when he observed Witr, he said to me: O 'A'isha, get up and observe Witr.

Book 4, Number 1619:

    'A'isha reported that the Messenger of Allah (may peace be upon him) used to offer prayer at night while she lay in front of him, and when the Witr prayer was yet to be observed, he would awaken her and she observed Witr.

Book 4, Number 1620:

    'A'isha reported: The Messenger of Allah (may peace be upon him) observed the Witr prayer every night and he completed Witr at the time of dawn.

Book 4, Number 1621:

    Masruq reported on the authority of 'A'isha that she said that the Messenger Of Allah (may peace be upon him) used to observe the Witr prayer every night, maybe in the early part of night, at midnight and in the latter part, finishing his Witr at dawn.

Book 4, Number 1622:

    'A'isha reported that the Messenger of Allah (may peace be upon him) used to observe Witr every night, and he would (at times) complete his Witr at the end of the night.

Book 4, Number 1623:

    Sa'd b. Hisham b. 'Amir decided to participate in the expedition for the sake of Allah, so he came to Medina and he decided to dispose of his property there and buy arms and horses instead and fight against the Romans to the end of his life. When he came to Medina, he met the people of Medina. They dissuaded him to do such a thing, and informed him that a group of six men had decided to do so during the lifetime of the Apostle of Allah (may peace be upon him) and the Apostle of Allah (may peace be upon him) forbade them to do it, and said: Is there not for you a model pattern in me? And when they narrated this to him (Sa'd b. Hisham), he returned to his wife, though he had divorced her and made (people) witness to his reconciliation. He then came to Ibn 'Abbas and asked him about the Witr of the Messenger of Allah (may peace be upon him). Ibn 'Abbas said: Should I not lead you to one who knows best amongst the people of the world about the Witr of the Messenger of Allah (may peace be upon him)? He said: Who is it? He (Ibn 'Abbas) said: It is 'A'isha. So go to her and ask her (about Witr) and then come to me and inform me about her answer that she would give you. So I came to Hakim b. Aflah and requested him to take me to her. He said : I would not go to her, for I forbade her to speak anything (about the conflict) between the two groupS, but she refused (to accept my advice) and went (to participate in that corflict). I (requested) him (Hakim) with an oath to lead me to her. So we went to 'A'isha and we begged permission to meet her. She granted us permission and we went in. She said: Are you Hakim? (She recognised him.) He replied: Yes. She said: Who is there with you ? He said: He is Sa'd b. Hisham. She said: Which Hisham ? He said: He is Hisham b. 'Amir. She blessed him ('Amir) with mercy from Allah and spoke good of him (Qatada said that he died as a martyr in Uhud). I said: Mother of the Faithful, tell me about the character of the Messenger of Allah (may peace be upon him). She said: Don't you read the Qur'an ? I said: Yes. Upon this she said: The character of the Apostle of Allah (may peace be upon him) was the Qur'an. He said: I felt inclined to get up and not ask anything (further) till death. But then I changed my mind and said: Inform me about the observance (of the night prayer) of the Messenger of Allah (may peace be upon him). She said: Did you not recite: "O thou wrapped up"? He said: Yes. She said: Allah, the Exalted and the Glorious, made the observance of the night prayer at the beginning of this Surah obligatory. So the Apostle of Allah (may peace be upon him and his Companions around him observed this (night prayer) for one year. Allah held back the concluding portion of this Surah for twelve months in the Heaven till (at the end of this period) Allah revealed the concluding verses of this Surah which lightened (the burden of this prayer), and the night prayer became a supererogatory prayer after being an obligatory one. I said: Mother of the Faithful, inform me about the Witr of the Messenger of Allah (may peace be upon him). She said: I used to prepare tooth stick for him and water for his ablution, and Allah would rouse him to the extent He wished during the night. He would use the tooth stick, and perform ablution, and would offer nine rak'ahs, and would not sit but in the eighth one and would remember Allah, and praise Him and supplicate Him, then he would get up without uttering the salutation and pray the ninth rak'ah. He would then sit, remember, praise Him and supplicate Him and then utter a salutation loud enough for us to hear. He would then pray two rak'ahs sitting after uttering the salutation, and that made eleven rak'ahs. O my son, but when the Apostle of Allah (may peace be upon him) grew old and put on flesh, he observed Witr of seven, doing in the two rak'ahs as he had done formerly, and that made nine. O my son, and when the Apostle of Allah (may peace be upon him) observed prayer, he liked to keep on observing it, and when sleep or pain overpowered him and made it impossible (for him) to observe prayer in the night, he prayed twelve rak'ahs daring the day. I am not aware of Allah's Prophet (may peace be upon him) having recited the whole Qur'an during one single night, or praying through the night till morning, or fasting a complete month, except Ramadan. He (the narrator) said: I then went to Ibn 'Abbas and narrated to him the hadith (transmitted from her), and he said : She says the truth If I went to her and got into her presence, I would have listened to it orally from her. He said : If I were to know that you do not go to her. I would not have transmitted this hadith to you narrated by her.

Book 4, Number 1624:

    Zurara b. Aufa said that Sa'd b. Hisham divorced his wife, and then proceeded to Medina to sell his property, and the rest of the hadith is the same.

Book 4, Number 1625:

    Sa'd b. Hisham reported: I went to 'Abdullah b. 'Abbas and asked him about the Witr prayer, and the rest of the hadith is the same as recorded in this event. She (Hadrat 'A'isha) said: Who is that Hisham ? I said: Son of 'Amir. She said: What a fine man 'Amir was ! He died as a martyr in the Battle of Uhud.

Book 4, Number 1626:

    Zurara b. Aufa reported that Sa'd b. Hisham was his neighbour and he informed him that he had divorced his wife and he narrated the hadith like the one transmitted by Sa'd. She ('A'isha) said: Who is Hisham? He said: The son of 'Amir. She said: What a fine man he was; he participated in the Battle of Uhud along with the Messenger of Allah (may peace be upon him). Hakim b. Aflah said: If I ever knew that you do not go to 'A'isha, I would not have informed you about her hadith (So that you would have gone to her and heard it from her orally).

Book 4, Number 1627:

    'A'isha reported that when the Messenger of Allah (may peace be upon him) missed the night prayer due to pain or any other reason, he observed twelve rak'ahs during the daytime.

Book 4, Number 1628:

    'A'isha reported that when the Messenger of Allah (may peace be upon him) decided upon doing any act, he continued to do it, and when he slept at night or fell sick he observed twelve rak'ahs during the daytime. I am not aware of Allah's Messenger (may peace be upon him) observing prayer during the whole of the night till morning, or observing fast for a whole month continuously except that of Ramadan.

Book 4, Number 1629:

    'Umar b. Khattab reported Allah's Messenger (may peace be upon him) as saying: Should anyone fall asleep and fail to recite his portion of the Qur'an, or a part of it, if he recites it between the dawn prayer and the noon prayer, it will be recorded for him as though he had recited it during the night.

Chapter 111 : FORENOON PRAYER SHOULD BE OFFERED WHEN IT IS SUFFICIENTLY HOT

Book 4, Number 1630:

    Zaid b. Arqam, on seeing some people praying in the forenoon, said: They well know that prayer at another time than this is more excellent, for Allah's Messenger (may peace be upon him) said: The prayer of those who are penitent is observed when your weaned camels feel the heat of the sun.

Book 4, Number 1631:

    Zaid b. Arqam reported that the Messenger of Allah (may peace be upon him) went out to the people of Quba' and saw them observing prayer; upon this he said: The prayer of the penitent should be observed when the young weaned camels feel heat of the sun.

Chapter 112 : NIGHT PRAYER CONSISTS OF PAIRS OF RAK'AHS AND WITR IS A RAK'AH AT THE END OF THE NIGHT

Book 4, Number 1632:

    Ibn 'Umar reported that a person asked the Messenger of Allah (may peace be upon him) about the night prayer. The Messenger of Allah (may peace be upon him) said : Prayer during the night should consist of pairs of rak'ahs, but if one of you fears morning is near, he should pray one rak'ah which will make his prayer an odd number for him.

Book 4, Number 1633:

    Salim reported on the authority of his father that a person asked the Apostle of Allah (may peace be upon him) about the night prayer. He said: It consists of pairs of rak'ahs, but if one fears morning is near, he should make it an odd number by praying one rak'ah.

Book 4, Number 1634:

    'Abdullah b. 'Umar reported: A man stood up and said. Messenger of Allah, how is the night prayer? The Messenger of Allah (may peace be upon him) said: The night prayer consists of pair, but if you apprehend the rise of dawn, make it odd number by observing one rak'ah.

Book 4, Number 1635:

    'Abdullah b. 'Umar reported: A person asked the Apostle of Allah (may peace be upon him) as I stood between him (the Holy Prophet) and the inquirer and he said: Messenger of Allah, how is the night prayer? He (the Holy Prophet) said: It consists of pairs of rak'ahs, but if you apprehend morning, you should pray one rak'ah and make the end of your prayer as Witr. Then a person asked him (the Holy Prophet) at the end of the year and I was at that place near the Messenger of Allah (may peace be upon him); but I do not know whether he was the same person or another person, but he (the Holy Prophet) gave him the same reply.

Book 4, Number 1636:

    This hadith his been narrated by Ibn 'Umar by another chain of trans- mitters but it does not have these words: "Then a person asked him at the end of the year," and what follows subsequently.

Book 4, Number 1637:

    Ibn 'Umar reported the Apostle of Allah (may peace be upon him) as say- ing: Hasten to pray Witr before morning.

Book 4, Number 1638:

    Ibn 'Umar said: He who prayed at night should make Witr the end of his prayer, for the Messenger of Allah (way peace be upon him) ordered this.

Book 4, Number 1639:

    Ibn 'Umar reported Allah's Messenger (may peace be upon him) as saying: Make Witr the end of your night prayer.

Book 4, Number 1640:

    Nafi' reported Ibn 'Umar as saying: He who observed the night prayer should make Witr the end of his prayer before dawn. The Messenger of Allah (may peace be upon him) used to order them thus.

Book 4, Number 1641:

    Ibn 'Umar reported Allah's Messenger (way peace be upon him) as saying: Witr is a rak'ah at the end of the prayer.

Book 4, Number 1642:

    Ibn Umar reported Allah's Messenger (may peace be upon him) as saying: Witr is a rak'ah at the end of the night prayer.

Book 4, Number 1643:

    Abu Mijlaz reported: I asked Ibn 'Abbas about the Witr prayer. He said: I heard the Messenger of Allah (may peace be upon him) as saying: It is a rak'ah at the end of the night prayer.

Book 4, Number 1644:

    Ibn 'Umar reported: A person called (the attention) of the Messenger of Allah (may peace be upon him) as he was in the mosque, and said: Messenger of Allah, how should I make the rak'ahs of the night prayer an odd number? Upon this the Messenger of Allah (way peace he upon him) said: He who prays (night prayer) he should observe it in pairs, but if he apprehends the rise of morning, he should observe one rak'ah; that would make the number odd (for the rak'ahs) observed by him. This was narrated by Abd Kuraib 'Ubaidullah b. 'Abdullah and Ibn 'Umar did not make mention of it.

Book 4, Number 1645:

    Anas b. Sirin reported: I asked Ibn 'Umar to tell me about the practice of the Holy Prophet (may peace be upon him) in regard to two rak'ahs before the dawn prayer: Should I make lengthy recitation in them? He said: The Messenger of Allah (may peace be upon him) used to observe, the night prayer in pairs and then made the number odd by observing one rak'ah. I said: I am not asking you about it. He said: You are a bulky man, will you not show me the patience to narrate to you the hadith completely? The Messenger of Allah (may peace be upon him) used to observe the night prayer in pairs and then made the number odd by observing one rak'ah, and then he observed two rak'ahs before dawn quite close to the call for prayer (Khalaf said: "Did you see [yourself the Holy Prophet observing] the two rak'ahs before the dawn?" and he made no mention of prayer.)

Book 4, Number 1646:

    Anas b. Sirin reported: I asked Ibn 'Umar like this (as recorded in the previous hadith) and he made this addition: "And he (the Holy Prophet) made the end of the night prayer as odd number by one rak'ah." And there is also (this addition): "Stop, stop, you are bulky."

Book 4, Number 1647:

    Ibn 'Umar reported Allah's Messenger (may peace be upon him) as saying: The night prayer consists of pairs and when you see the approach of dawn, make this number odd by one rak'ah. It was said to Ibn 'Umar: What does the (word) pair imply? He said: (It means) that salutation is uttered after every two rak'ahs.

Book 4, Number 1648:

    Abu Sa'id (al Khudri) reported Allah's Apostle (may peace be upon him) as saying: Observe Witr prayer before it is morning. Abu Sa'id reported that they (the Prophet's Companions) asked the Apostle of Allah (may peace be upon him) about Witr (prayer). (In reply to their inquiry) he said: Observe Witr prayer before it is morning.

Book 4, Number 1649:

    Abu Sa'id reported that they (some of the Companions) of the Holy Prophet (may peace be upon him) asked the Apostle of Allah (may peace be upon him) about Witr. He said: Observe Witr before morning.

Chapter 113 : HE WHO FEARS THAT HE WOULD NOT BE ABLE TO OBSERVE (TAHAJJUD) PRAYER AT THE END OF NIGHT SHOULD OBSERVE WITR IN THE FIRST PART OF IT

Book 4, Number 1650:

    Jabir reported Allah's Messenger (may peace be upon him) as saying: If anyone is afraid that he may not get up in the latter part of the night, he should observe Witr in the first part of it; and if anyone is eager to get up in the last part of it, he should observe Witr at the end of the night, for prayer at the end of the night is witnessed (by the angels) and that is preferable.

Book 4, Number 1651:

    Jabir reported Allah's Messenger (may peace be upon him) as saying: He who amongst you is afraid that he may not be able to get up at the end of the night should observe Witr (in the first part) and then sleep, and he who is confident of getting up and praying at night (i.e. Tahajjud prayer) should observe it at the end of it, for the recitation at the end of the night to visited (by angels), and that is excellent.

Chapter 114 : THE MOST EXCELLENT PRAYER IS ONE IN WHICH ONE STANDS FOR A LONGER TIME

Book 4, Number 1652:

    Jabir reported Allah's Messenger (may peace be upon him) as saying: The most excellent prayer is that in which the duration of standing is longer.

Book 4, Number 1653:

    Jabir reported: The Messenger of Allah (may peace be upon him) was asked about the prayer which was most excellent. He said: That in which the standing is longer. (This hadith is narrated by another chain of transmitters too.)

Book 4, Number 1654:

    Jabir said he heard Allah's Messenger (may peace be upon him) say: There is an hour during the night in which no Muslim individual will ask Allah for good in this world and the next without His giving it to him; and that applies to every night.

Book 4, Number 1655:

    Jabir reported: I heard the Apostle of Allah (may peace be upon him) as saying: There is an hour during the night in which no Muslim bondman will ask Allah for good in this world and the next but He will grant it to him.

Chapter 115 : EXHORTATION TO SUPPLICATE AND MAKE MENTION (OF ALLAH) AT THE END OF THE NIGHT AND ITS ACCEPTANCE BY THE LORD

Book 4, Number 1656:

    Abu Huraira reported Allah's Messenger (may peace be upon him) as saying: Our Lord, the Blessed and the Exalted, descends every night to the lowest heaven when one-third of the latter part of the night is left, and says: Who supplicates Me so that I may answer him ? Who asks Me so that I may give to him ? Who asks Me forgiveness so that I may forgive him ?

Book 4, Number 1657:

    Abu Huraira reported Allah's Messenger (may peace be upon him) as saying: Allah descends every night to the lowest heaven when one-third of the first part of the night is over and says: I am the Lord; I am the Lord: who is there to supplicate Me so that I answer him ? Who is there to beg of Me so that I grant him ? Who is there to beg forgiveness from Me so that I forgive him ? He continues like this till the day breaks.

Book 4, Number 1658:

    Abu Huraira reported Allah's Messenger (may peace be upon him) as saying: When half of the night or two-third of it is over. Allah, the Blessed and the Exalted, descends to the lowest heaven and says: Is there any beggar, so that he be given ? Is there any supplicator so that he be answered ? Is there any beggar of forgiveness so that he be forgiven? (And Allah continues it saying) till it is daybreak.

Book 4, Number 1659:

    Abu Huraira reported Allah's Messenger (may peace be upon him) as saying: Allah descends to the lowest heaven at half of the night or at one-third of the latter part and says: Who is there to supplicate Me so that I answer him? Who is there to ask Me so that I grant him? And then says: Who will lend to One Who is neither indigent nor tyrant? (This hadith has been narrated by Sa'd b. Sa'id with the same chain of transmitters with this addition: "Then the Blessed and the Exalted (Lord) stretches His Hands and says: Who will lend to One Who is neither indigent nor tyrant?)

Book 4, Number 1660:

    Abu Sa'id and Abu Huraira reported Allah's Messenger (may peace be upon him) as saying: Allah waits till when one-third of the first part of the night is over; He descends to the lowest heaven and says: It there any supplicator of forgiveness? Is there any penitant? Is there any petitioner (for mercy and favour) ? Is there any solicitor ?-till it is daybreak.

Book 4, Number 1661:

    This hadith is narrated by Ishaq with the same chain uf transmitters except this that the hadith transmitted by Mansur (the above one) is more comprehensive and lengthy.

Chapter 116 : ENCOURAGEMENT TO OBSERVE PRAYERS DURING RAMADAN AND THAT IS TARAWIH

Book 4, Number 1662:

    Abu Huraira reported Allah's Messenger (may peace be upon him) as saying: He who observed prayer at night during Ramadan, because of faith and seeking his reward from Allah, his previous sins would be forgiven.

Book 4, Number 1663:

    Abu Huraira reported: The Messenger of Allah (may peace be upon him) used to exhort (his Companions) to pray (at night) during Ramadan without commanding them to observe it as an obligatory act, and say: He who observed the night prayer in Ramadan because of faith and seeking his reward (from Allah), all his previous sins would be forgiven. When Allah's Messenger (may peace be upon him) died, this was the practice, and it continued thus during Abu Bakr's caliphate and the early part of 'Umar's caliphate.

Book 4, Number 1664:

    Abu Huraira reported Allah's Messenger (may peace be upon him) as saying: He who observed the fasts of Ramadan with faith and seeking reward (from Allah), all his previous sins would be forgiven, and he who observed prayer on Lailat-ul- Qadr with faith and seeking reward (from Allah), all his previous sins would be forgiven.

Book 4, Number 1665:

    Abu Huraira reported Allah's Apostle (may peace be upon him) as saying: He who prayed on the Lailat-ul-Qadr (the Majestic Night) knowing that it is (the same night). I (believe) that he (the Holy Prophet also) said: (He who does) it with faith and seeking reward (from Allah), his sins would be forgiven.

Book 4, Number 1666:

    'A'isha reported that the Messenger of Allah (may peace be upon him) prayed one night in the mosque and people also prayed along with him. He then prayed on the following night and there were many persons. Then on the third or fourth night (many people) gathered there, but the Messenger of Allah (may peace be upon him) did not come out to them (for leading the Tarawih prayer). When it was morning he said: I saw what you were doing, but I desisted to come to you (and lead the prayer) for I feared that this prayer might become obligatory for you. (He the narrator) said: It was the month of Ramadan.

Book 4, Number 1667:

    'A'isha reported: The Messenger of Allah (may peace be upon him) came out during the night and observed prayer in the mosque and some of the people prayed along with him. When it was morning the people talked about this and so a large number of people gathered there. The Messenger of Allah (may peace be upon him) went out for the second night, and they (the people) prayed along with him. When it was morning the people began to talk about it. So the mosque thronged with people on the third night. He (the Holy Prophet) came out and they prayed along with him. When it was the fourth night, the mosque was filled to its utmost capacity but the Messenger of Allah (may peace be upon him) did not come out. Some persons among then cried: "Prayer." But the Messenger of Allah (may peace be upon him) did not come to them till he came out for the morning prayer. When he had completed the morning prayer, he turned his face to the people and recited Tashahhud (I bear testi- mony that there is no god but Allah and I bear testimony that Muhammad is His Messen- ger) and then said: Your affair was not hidden from me in the night, but I was afraid that (my observing prayer continuously) might make the night prayer obligatory for you and you might be unable to perform it.

Book 4, Number 1668:

    Zirr (b. Hubaish) reported: I heard from Ubayy b. Ka'b a statement made by 'Abdullah b. Mas'ud in which he said : He who gets up for prayer (every night) during the year will hit upon Lailat-ul-Qadr. Ubayy said: By Allah I there is no god but He, that (Lailat-ul-Qadr) is in Ramadhan (He swore without reservation:) By Allah, I know the night; it is the night on which the Messenger of Allah (may peace be upon him) commanded us to pray. It is that which precedes the morning of twenty-seventy and its indication is that the sun rises bright on that day without rays.

Book 4, Number 1669:

    Ubayy b Ka'b reported: By Allah, I know about Lailat-ul Qadr and I know it fully well that it is the twenty-seventh night (during Ramadan) on which the Messenger of Allah (may peace be upon him) commanded us to observe prayer. (Shu'ba was in doubt about these words: "the night on which the Messenger of Allah [may peace be upon him] commanded us to observe the prayer." This has been transmitted to me by a friend of mine.)

Book 4, Number 1670:

    Shu'ba reported this hadith with the same chain of transmitters, but he made no mention that Shu'ba was in doubt and what follows subsequently.

Chapter 117 : SUPPLICATION IN THE NIGHT PRAYER

Book 4, Number 1671:

    Ibn 'Abbas reported : I spent a night with my material aunt (sister of my mother) Maimuna. The Apostle of Allah (may peace be upon him) got up during the night and relieved himself, then washed his face and hands and went to sleep. He then got up again, and came to the water skin and loosened its straps, then performed good ablution between the two extremes. He then stood up and observed prayer. I also stood up and stretched my body fearing that he might be under the impression that I was there to find out (what he did at night). So I also performed ablution and stood up to pray, but I stood on his left. He took hold of my hand and made me go round to his right side. The Messenger of Allah (may peace be upon him) completed thirteen rak'abs of his night prayer. He then lay down and slept and snored (and it was his habit to snore while asleep). Then Bilal came and he informed him about the prayer. He (the Holy Prophet) then stood up for prayer and did not perform ablution, and his supplication included there words: "O Allah, place light in my heart, light in my sight, light in my hearing, light on my right hand, light on my left hand, light above me, light below me, light in front of me, light behind me, and enhance light for me."
    Kuraib (the narrator) said: There are seven (words more) which are in my heart (but I cannot recall them) and I met some of the descendants of 'Abbas and they narrated these words to me and mentioned in them: (Light) in my sinew, in my flesh, in my blood, in my hair, in my skin, and made a mention of two more things.

Book 4, Number 1672:

    Kuraib, the freed slave of Ibn 'Abbas, reported that Ibn 'Abbas narrated to him that he spent a night in the house of Maimuna, the mother of the believers, who was his mother's sister. I lay down across the cushion, whereas the Messenger of Allah (may peace be upon him) and his wife lay down on it length-wise. The Messenger of Allah (may peace be upon him) slept up till midnight, or a little before midnight of a little after midnight, and then got up and began to cast off the effects of sleep from his face by rubbing with his hand, and then recited the ten concluding verses of Surah 'Imran. He then stood up near a hanging water-skin and performed ablution well, and then stood up and prayed, 'Ibn 'Abbas said: I also stood up and did the same, as the Messenger of Allah (may peace be upon him) had done, and then went to him and stood by his side. The Messenger of Allah (may peace be upon him) placed his right hand upon my head and took hold of my right ear and twistedit, and then observed a pair of rak'ahs, again a pair of rak'ahs, again a pair of rak'ahs, again a pair of rak'ahs, again a pair of rak'ahs, again a pair of rak'ahs, and then observed Witr and then lay down till the Mu'adhdhin came to him. He (the Holy Prophet) then stood up and observed two short rak'ahs, and then went out (to the mosque) and observed the dawn prayer.

Book 4, Number 1673:

    Makhrama b. Sulaiman narrated it with the same chain of narrators and he made this addition : "He then went to the water-skin and brushed his teeth and performed ablution well. He did not pour water but a little. He then awakened me and I stood up," and the rest of the hadith is the same.

Book 4, Number 1674:

    Ibn Abbas reported: I slept (one night) in the house of Maimuna, the wife of the Apostle of Allah (may peace be upon him), and the Apostle of Allah (may peace be upon him) was with her that night. He (after sleeping for half of the night got up and) then performed ablution and then stood up and observed prayer. I too stood on his left side. He took hold of me and made me stand on his right side. He (the Holy Prophet) observed thirteen rak'ahs on that night. The Messenger of Allah (may peace be upon him) then slept and snored and it was a habit with him to snore while sleeping. The Mu'adhdbin then came to him (to inform him about the prayer). He then went out and observed prayer without performing ablution. ('Amr said: Bukair b. Ashajj had narrated it to me )

Book 4, Number 1675:

    Ibn 'Abbas reported : I spent one night in the house of my mother's sister Maimuna, daughter of Harith, and said to her: Awake me when the Messenger of Allah (may peace be upon him) stands to pray (at night). (She woke me up when) the Messenger of Allah (may peace be upon him) stood up for prayer. I stood on his left side. He took hold of my hand and made me stand on his right side, and whenever I dozed off he took hold of my earlobe (and made me alert). He (the narrator) said: He (the Holy Prophet) observed eleven rak'ahs. He then sat with his legs drawn and wrapped in his garment and slept so that I could bear his breathing while asleep. And when the dawn appeared, he observed two short rak'ahs of (Sunnah) prayer.

Book 4, Number 1676:

    Ibn 'Abbas reported that he spent a night in the house of his matenial aunt, Maimuna. The Messenger of Allah (may peace he upon him) got up at night and performed short ablution (taking water) from the water-skin hanging there. (Giving a description of the ablution Ibn 'Abbas said: It was short and performed with a little water.) I also got up and did the same as the Apostle of Allah (may peace be upon him) had done. I then came (to him) and stood on his left. He then made me go around to his right side. He then observed prayer and went to sleep till he began to snore. Bilal came to him and informed him about the prayer. He (the Holy Prophet) then went out and observed the dawn prayer without performing ablution. Sufyan said: It was a special (prerogative of the) Apostle of Allah (may peace be upon him) for it has been conveyed to us that the eyes of the Apostle of Allah (may peace be upon him) sleep, but his heart does not sleep.

Book 4, Number 1677:

    Ibn 'Abbas said: I spent the night in the house of my mother's sister, Maimuna, and observed how the Messenger of Allah (may peace be upon him) prayed (at night). He got up and relieved himself. He then washed his face and hands and then went to sleep. He again got up and went near the water-skin and loosened its straps and then poured some water in a bowl and inclined it with his hands (towards himself). He then performed a good ablution between the two extremes and then stood up to pray. I also came and stood by his left side. He took hold of me and made me stand on his right side. It was in thirteen rak'ahs that the (night) prayer of the Messenger of Allah (may peace be upon him) was completed. He then slept till he began to snore, and we knew that he had gone to sleep by his snoring. He then went out (for the dawn prayer) and then again slept, and said while praying or prostrating himself: "O Allah ! place light in my heart, light in my hearing, light in my sight, light on my right, light on my left, light in front of me, light behind me, light above me, light below me, make light for me," or he said: "Make me light."

Book 4, Number 1678:

    Salama said: I met Kuraib and he reported Ibn 'Abbas as saying: I was with my mother's sister Maimuna that the Messenger of Allah (may peace be upon him) came there, and then he narrated the rest of the hadith as was narrated by Ghundar and said these words: "Make me light," beyond any doubt.

Book 4, Number 1679:

    Ibn 'Abbas reported: I spent a night in the house of my mother's sister, Maimuna, and then narrated (the rest of the) haditb, but he made no mention of the washing of his face and two hands but he only said: He then came to the water-skin and loosened its straps and performed ablution between the two extremes, and then came to his bed and slept. He then got up for the second time and came to the waterskin and loosened its straps and then performed ablution which was in fact an ablution (it was performed well), and implored (the Lord) thus: "Give me abundant light," and he made no raention of: "Make me light."

Book 4, Number 1680:

    Kuraib reported that Ibn 'Abbas spent a night in the house of the Messenger of Allah (may peace be upon him) and he said: The Messenger of Allah may peace be upon him) stood near the water-skin and poured water out of that and performed ablution in which he neither used excess of water nor too little of it, and the rest of the hadith is the same, and in this mention is also made (of the fact) that on that night the Messenger of Allah (may peace be upon him) made supplication before Allah in nineteen words. Kuraib reported: I remember twelve words out of these, bux have forgotten the rest. The Messenger of Allah said: "Place light in my heart, light in my tongue, light in my hearing, light in my sight, light above me, light below me, light on my right, light on my left, light in front of me, light behind me, place light in my soul, and make light abundant for me."

Book 4, Number 1681:

    Ibn 'Abbas reported: I slept one night in the house of Maimuna when the Apostle of Allah (may peace be upon him) was there, with a view to seeing the prayer of the Apostle of Allah (may peace be upon him) at night. The Apostle of Allah (may peace be upon him) entered into conversation with his wife for a short while, and then went to sleep, and the rest of the hadith is the same and in it mention is made of: "He then got up, performed ablution and brushed his teeth."

Book 4, Number 1682:

    'Abdullah b. 'Abbas reported: He spent (one night) in the house of the Messenger of Allah (may peace be upon him). He (the Holy Prophet) got up, brushed his teeth and performed ablution and said: "In the creation of the heavens and the earth, and the alternation of the night and the day, there are indeed signs for people of understanding" (al-Qur'an, iii. 190), to the end of the Surah. He then stood up and prayed two rak'ahs, standing, bowing and prostrating himself at length in them. Then he finished, went to sleep and snored. He did that three times, six rak'ahs altogether, each time cleaning his teeth, performing ablution, and reciting these verses. Then he observed three rak'ahs of Witr. The Mu'adhdhin then pronounced the Adhan and he went out for prayer and was saying,: "O Allah I place light in my heart, light in my tongue, place light in my hearing, place light in my eyesight, place light behind me, and light in front of me, and place light above me, and light below me. O Allah ! grant me light."

Book 4, Number 1683:

    Ibn Abbas reported: I spent a night in the house of my mother's sister Maimuna. The Apostle of Allah (way peace be upon him) got up for observing voluntary prayer (Tahajjud) at night. The Apostle of Allah (may peace be upon him) stood by the water-skin and performed ablution and then stood up and prayed. I also got up when I saw him doing that. I also performed ablution from the water-skin and then stood at his left side. He took hold of my hand from behind his back and then turned me from his back to his right side. I ('Ata', one of the narrators) said: Did it concern the voluntary prayer (at night)? He ('Ibn 'Abbas) said: Yes.

Book 4, Number 1684:

    Ibn 'Abbas reported: (My father) Abbas sent me to the Apostle of Allah (may peace be upon him) and he was in the house of my mother's sister Maimuna and spent that night along with him. He (the Holy Prophet) got up and prayed at night, and I stood up on his left side. He caught hold of me from behind his back and made me stand on his right side.

Book 4, Number 1685:

    Ibn 'Abbas reported: I spent a night in the house of my mother's sister Maimuna, and the rest of the hadith is the same as narrated above.

Book 4, Number 1686:

    Abu Jamra reported : I heard Ibn 'Abbas saying that the Messenger of Allah (may peace be upon him) observed thirteen rak'ahs at night.

Book 4, Number 1687:

    Zaid b Khalid al-Juhani said: I would definitely watch at night the prayer observed by the Messenger of Allah (may peace be upon him). He prayed two short rak'ahs, then two long, long, long rak'ahs, then he prayed two rak'ahs which were shorter than the two preceding rak'ahs, then he prayed two rak'ahs which were shorter than the two preceding, then he prayed two rak'ahs which were shorter than the two preceding, then observed a single one (Witr), making a total of thirteen rak'ahs

Book 4, Number 1688:

    Jabir b. 'Abdullah reported: I accompanied the Messenger of Allah (may peace be upon him) in a journey and we reached a watering place. He said: Jabir, are you going to enter it? I said: Yes. The Messenger of Allah (may peace be upon him) then got down and I entered it. He (the Holy Prophet) then went away to relieve himself and I placed for him water for ablution. He then came back and performed ablution, and then stood and prayed in one garment, having its ends tied from the opposite sides. I stood.behind him and he caught hold of my ear and made me stand on his right side.

Book 4, Number 1689:

    'A'isha reported that when the Messenger of Allah (may peace be upon him) stood up at night to pray, he began his prayer with two short rak'ahs.

Book 4, Number 1690:

    Abu Huraira reported Allah's Apostle (may peace be upon him) as saying When any one of you gets up at night, he should begin the prayer with two short rak'ahs.

Book 4, Number 1691:

    Ibn Abbas reported that when the Messenger of Allah (may peace be upon him) got up during the night to pray, he used to say: O Allah, to Thee be the praise Thou art the light of the heavens and the earth. To Thee be the praise; Thou art the Supporter of the heavens and the earth. To Thee be the praise; Thou art the Lord of the heavens and the earth and whatever is therein. Thou art the Truth; Thy promise is True, the meeting with Thee is True. Paradise is true, Hell is true, the Hour is true. O Allah, I submit to Thee; affirm my faith in Thee; repose my trust in Thee, and I reurn to Thee for repentance; by Thy help I have disputed; and to Thee I have come for decision, so forgive me my earlier and later sins, the sins that I committed in secret and openly. Thou art my God. There is no god but Thee.

Book 4, Number 1692:

    This hadith has been narrated on the authority of Ibn 'Abbas through another chain of transmitters and with slight alteration of two words. Instead of the word Qayyam (Supporter, as used in the above hadith here the word) Qayyim (the Custodian) has been used, and he (further said): "What I did in secret." And in the hadith narrated by Ibn 'Uyaina there is some addition.

Book 4, Number 1693:

    This hadith has been narrated by Ibn 'Abbas by another chain of transmitters and the words are nearly the same (as recorded in the above-mentioned hadith).

Book 4, Number 1694:

    'Abd al-Rahman b. 'Auf reported: I asked 'A'isha, the mother of the believers, (to tell me) the words with which the Apostle of Allah (may peace be upon him) commenced the prayer when he got up at night. She said: When he got up at night he would commence his prayer with these words: O Allah, Lord of Gabriel, and Michael, and Israfil, the Creator of the heavens and the earth, Who knowest the unseen and the seen; Thou decidest amongst Thy servants concerning their differences. Guide me with Thy permission in the divergent views (which the people) hold about Truth, for it is Thou Who guidest whom Thou wilt to the Straight Path.

Book 4, Number 1695:

    'Ali b. Abu Talib reported that when the Messenger of Allah (may peace be upon him) got up at night for prayer he would say: I turn my face in complete devotion to One Who is the Originator of the heaven and the earth and I am not of the polytheists. Verily my prayer, my sacrifice, my living and my dying are for Allah, the Lord of the worlds; There is no partner with Him and this is what I have been commanded (to profess and believe) and I am of the believers. O Allah, Thou art the King, there is no god but Thee, Thou art my Lord, and I am Thy bondman. I wronged myself and make a confession of my Sin. Forgive all my sins, for no one forgives the sins but Thee, and guide me in the best of conduct for none but Thee guideth anyone (in) good conduct. Remove sins from me, for none else but Thou can remove sins from me. Here I am at Thy service, and Grace is to Thee and the whole of good is in Thine hand, and one cannot get nearneststo Thee through evil. My (power as well as existence) is due to Thee (Thine grace) and I turn to Thee (for supplication). Thou art blessed and Thou art exalted. I seek forgiveness from Thee and turn to Thee in repentance: and when he would bow, he would say: O Allah, it is for Thee that I bowed. I affirm my faith in Thee and I submit to Thee, and submit humbly before Thee my hearing, my eyesight, my marrow, my bone, my sinew; and when he would raise his head, he would say: O Allah, our Lord, praise is due to Thee, (the praise) with which is filled the heavens and the earth, and with which is filled that (space) which exists between them, and filled with anything that Thou desireth afterward. And when he prostrated himself, he (the Holy Prophet) would say: O Allah, it is to Thee that I prostrate myself and it is in Thee that I affirm my faith, and I submit to Thee. My face is submitted before One Who created it, and shaped it, and opened his faculties of hearing and seeing. Blessed is Allah, the best of Creators; and he would then say between Tashahhud and the pronouncing of salutation: Forgive me of the earlier and later open and secret (sins) and that where I made transgression and that Thou knowest better than I. Thou art the First and the Last. There is no god, but Thee.

Book 4, Number 1696:

    A'raj reported that when the Messenger of Allah (may peace be upon him) would start the prayer, he would pronounce takbir (Allah-o-Akbar) and then say: I turn my face (up to Thee), I am the first of the believers; and when he raised his head from ruku' he said: Allah listened to him who praised Him; O our Lord, praise be to Thee; and he said: He shaped (man) and how fine is his shape? And he (the narrator) said: When he pronounced salutation he said: O Allah, forgive me my ear- lier (sins), to the end of the hadith; and he did not say it between the Tashahhud and salutation (as mentioned above).

Chapter 118 : PREFERENCE FOR PROLONGING RECITATION IN THE NIGHT PRAYER

Book 4, Number 1697:

    Hudhaifa reported: I prayed with the Apostle of Allah (may peace be upon him) one night and he started reciting al-Baqara. I thought that he would bow at the end of one hundred verses, but he proceeded on; I then thought that he would perhaps recite the whole (surah) in a rak'ah, but he proceeded and I thought he would perhaps bow on completing (this surah). He then started al-Nisa', and recited it; he then started Al-i-'Imran and recited leisurely. And when he recited the verses which referred to the Glory of Allah, he glorified (by saying Subhan Allah-Glory to my Lord the Great), and when he recited the verses which tell (how the Lord) is to be begged, he (the Holy Prophet) would then beg (from Him), and when he recited the verses dealing with protection from the Lord, he sought (His) protection and would then bow and say: Glory be to my Mighty Lord; his bowing lasted about the same length of time as his standing (and then on returning to the standing posture after ruku') he would say: Allah listened to him who praised Him, and he would then stand about the same length of time as he had spent in bowing. He would then prostrate himself and say: Glory be to my Lord most High, and his prostration lasted nearly the same length of time as his standing. In the hadith transmitted by Jarir the words are: "He (the Holy Prophet) would say: "Allah listened to him who praised Him, our Lord, to Thee i the praise."

Book 4, Number 1698:

    'Abdullah reported: I prayed with the Messenger of Allah (may peace be upon him) and he lengthened it till I entertained an evil thought. It was said to him what that thought was. He said: I thought that I should sit down and forsake him.

Book 4, Number 1699:

    A hadith like this has been narrated by A'mash with the same chain of transmitters.

Chapter 119 : WHAT HAS BEEN RELATED (FROM THE HOLY PROPHET) ABOUT ONE WHO SLEEPS THE WHOLE NIGHT TILL MORNING

Book 4, Number 1700:

    'Abdullah (b. Mas'ud) reported that a mention was made of a man who slept the whole night till morning. He (the Holy Prophet) remarked: That is a man in whose ears (or in whose ear) the devil urinated.

Book 4, Number 1701:

    Husain b. 'Ali narrated on the authority of (his father) 'Ali b. Abu Talib that the Apostle of Allah (may peace be upon him) came one night to see him ('Ali) and Fatimah (the daughter of the Holy Prophet) and said: Don't you observe (Tahajjud) prayer? I ('Ali) said: Messenger of Allah, verily our souls are in the hands of Allah and when He wants to awaken us, He awakens us. The Messenger of Allah (may peace be upon him) went back when I said this to him . He was striking his hand on his thigh while returning, and I heard him say: Verily the man disputes with many things.

Book 4, Number 1702:

    Abu Huraira transmitted it from the Apostle of Allah (may peace be upon him): When any one of you goes to sleep, the devil ties three knots at the back of his neck, sealing every knot with: "You have a long night, so sleep." So if one awakes and mentions Allah, a knot will be loosened; if he performs ablution two knots are loosened; and if he prays (all) knots will be loosened, and in the morning he will be active and in good spirits; otherwise we will be in bad spirits and sluggish in the morning.

Chapter 120 : PREFERENCE FOR OBSERVING NAFL PRAYER IN THE HOUSE, AND PERMISSIBILITY OF OBSERVING iT IN THE MOSQUE ALSO

Book 4, Number 1703:

    Ibn 'Umar reported Allah's Apostle (may peace be upon him) as saying: Observe some of your prayers in your houses and do not make them graves.

Book 4, Number 1704:

    Ibn 'Umar reported Allah's Apostle (may peace be upon him) as saying: Pray in your houses, and do not make them graves.

Book 4, Number 1705:

    Jabir reported Allah's Messenger (may peace be upon him) as saying: When any one of you observes prayer in the mosque he should reserve a part of his prayer for his house, for Allah would make the prayer as a means of betterment in his house.

Book 4, Number 1706:

    Abu Musa reported Allah's Apostle (may peace be upon him) as saying: The house in which remembrance of Allah is made and the house in which Allah is not remembered are like the living and the dead.

Book 4, Number 1707:

    Abu Huraira reported Allah's Messenger (may peace be upon him) as saying: Do not make your houses as graveyards. Satan runs away from the house in which Surah Baqara is recited.

Book 4, Number 1708:

    Zaid b. Thabit reported: The Messenger of Allah (may peace be upon him) made an apartment with the help of the leaves of date trees or of mats. The Messenger of Allah (may peace be upon him) went out to pray in it. People followed him and came to pray with him. Then they again came one night and waited (for him), but the Messenger of Allah (may peace be upon him) delayed in coming out to them. And when he did not come out, they cried aloud and threw pebbles at the door. The Messenger of Allah (may peace be upon him) came out in anger and said to them: By what you have been constantly doing, I was inclined to think that it (prayer) might not become obligatory for you. So you must observe prayer (optional) in your houses, for the prayer observed by a man in the house is better except an obligatory prayer.

Book 4, Number 1709:

    Zaid b. Thabit reported that the Apostle of Allah (may peace be upon him) made an apartment in the mosque of mats, and he observed in it prayers for many nights till people began to gather around him, and the rest of the hadith is the same but with this addition: "Had this (Nafl) prayer become obligatory for you, you would not be able to observe it."

Chapter 121 : EXCELLENCE OF AN ACT (I.E. OBSERVING OF THE NIGHT PRAYER, ETC.) DONE CONSTANTLY

Book 4, Number 1710:

    'A'isha reported that the Messenger of Allah (may peace be upon him) had a mat and he used it for making an apartment during the night and observed prayer in it, and the people began to pray with him, and he spread it (the mat) during the day time. The people crowded round him one night. He (the Holy Prophet) then Eaid: O people, perform such acts as you are capable of doing, for Allah does not grow weary but you will get tired. The acts most pleasing to Allah are those which are done continuously, even if they are small. And it was the habit of the members of Muhammad's (may peace be upon him) household that whenever they did an act they did it continuously.

Book 4, Number 1711:

    'A'isha is reported to have said that the Messenger of Allah (may peace be upon him) was asked about the act most pleasing to Allah. He replied: That which is done continuously, even if it is small.

Book 4, Number 1712:

    Alqama reported: I asked 'A'isha, the mother of the believers, saying O mother of the believers, how did the Messenger of Allah (may peace be upon him) act? Did he choose a particular act for a particular day? She said: No. He act was continuous, and who amongst you is capable of doing what the Messenger of Allah (may peace be upon him) did?

Book 4, Number 1713:

    'A'isha reported Allah's Messenger (may peace be upon him) as saying: The acts most pleasing to Allah are those which are done continuously, even if they are small. and when 'A'isha did any act she did it continuously.

Book 4, Number 1714:

    Anas reported that the Messenger of Allah (may peace be upon him) entered the mosque (and he found) a rope tied between the two pillars; so he said: What is this? They said: It is for Zainab. She prays and when she slackens or feels tired she holds it. Upon this he (the Holy Prophet) said: Untie it. Let one pray as long as one feels fresh but when one slackens or becomes tired one must stop it. (And in the hadith transmitted by Zuhair it is: "He should sit down.")

Book 4, Number 1715:

    A hadith like this has been narrated from the Apostle of Allah (may peace be upon him) on the authority of Anas by another chain of transmitters.

Book 4, Number 1716:

    'Urwa b. Zubair reported that 'A'isha, the wife of the Apostle of Allah (may peace be upon him), told him that (once) Haula' dint Tuwait b. Habib b. Asad b. 'Abd al-'Uzzi passed by her (at the time) when the Messenger of Allah (may peace be upon him) was with her. I ('A'Isha) said: It Is Haula' bint Tuwait and they say that she does not sleep at night. Upon this the Messenger of Allah (may peace be upon him) said: (Oh) she does not sleep at night ! Choose an act which you are capable of doing (continuously). By Allah, Allah would not grow weary, but you will grow weary.

Book 4, Number 1717:

    'A'isha said: The Messenger of Allah (way peace be upon him) came to me when a woman was sitting with me. He said: Who is she? I said: She is a woman who does not sleep but prays. He said: Do such acts which you are capable of doing. By Allah, Allah does not grow weary but you will grow weary. The religious act most pleasing to Him is one the doer of which does it continuously. (And in the hadith transmitted by Abu Usama [the words are]: "She was a woman from Banu Asad.")

Chapter 122 : CONCERNING DOZING OFF IN PRAYER, OR FALTERING OF ONE'S TONGUE IN THE RECITATION OF THE QUR'AN, OR IN MENTIONING OF ALLAH, ONE SHOULD SLEEP, OR STOP lT TILL ONE BECOMES LIVELY

Book 4, Number 1718:

    'A'isha reported Allah's Apostle (may peace be upon him) as saying: When anyone amongst you dozes in prayer, he should sleep, till sleep is gone, for when one of you prays while dozing he does not know whether he may be asking pardon or vilifying himself.

Book 4, Number 1719:

    Abu Huraira reported Allah's Messenger (may peace be upon him) as saying: When any one of you gets up at night (for prayer) and his tongue falters in (the recitation) of the Qar'an, and he does not know what he is reciting, he should go to sleep.

Chapter 123 : CONCERNING THE CAREFUL REMEMBERING OF THE QUR'AN

Book 4, Number 1720:

    'A'isha reported that the Apostle of Allah (may peace be upon him) heard a person reciting the Qur'an at night. Upon this he said: May Allah show mercy to him; he has reminded me of such and such a verse which I had missed in such and such a surah.

Book 4, Number 1721:

    'A'isha reported that the Apostle of Allah (may peace be upon him) listened to the recitation of the Qur'an by a man in the mosque. Thereupon he said: May Allah have mercy upon him; be reminded me of the verse which I had been made to forget.

Book 4, Number 1722:

    'Abdullah b. 'Umar reported Allah's Messenger (may peace be upon him) as saying: The example of a man who has memorised the Qur'an is like that of a hobbled camel. If he remained vigilant, he would be able to retain it (with him), and if he loosened the hobbled camel it would escape.

Book 4, Number 1723:

    This hadith has been narrated by Ibn 'Umar from the Apostle of Allah (may peace be upon him), but in the hadith transmited by Musa b. 'Uqba, this addition is made: "When one who had committed the Qur'an to memory(or who is familiar with it) gets up (for night prayer) and recites it night and day, it remains fresh in his mind, but if he does not get up (for prayer and thus does not recite it) he forgets it."

Book 4, Number 1724:

    'Abdullah reported Allah's Messenger (may peace be upon him) as saying: What a wretched person is he amongst them who says: I have forgotten such and such a verse. (He should instead of using this expression say): I have been made to forget it. Try to remember the Qur'an for it is more apt to escape from men's minds than a hobbled camel.

Book 4, Number 1725:

    'Abdullah is reported to have said: Keep refreshing your knowledge of the sacred books (or always renew your knowledge of these sacred books) and sometimes he would mention the Qur'an for it is more apt to escape from men's minds than animals which are hobbled, and the Messenger of Allah (may peace be upon him) said: None of you should say: I forgot such and such a verse, but he has been made to forget.

Book 4, Number 1726:

    Ibn Mas'ud reported Allah's Messenger (may peace be upon him) as saying: Wretched is the man who says: I forgot such and such a sura, or I forget such and such a verse, but he has been made to forget.

Book 4, Number 1727:

    Abu Musa al-Ash'ari reported Allah's Apostle (may peace be upon him) as saying: Keep refreshing your knowledge of the Qur'an, for I swear by Him in Whose Hand is the life of Mahammad that it is more liable to escape than camels which are hobbled.

Chapter 124 : DESIRABILITY OF RECITING THE QUR'AN IN A SWEET VOICE

Book 4, Number 1728:

    Abu Huraira reported this directly from the Messenger of Allah (may peace be upon him): God has not listened to anything as He listens to a Prophet reciting the Qur'an in a sweet voice.

Book 4, Number 1729:

    This hadith has been narrated by Ibn Shihab with the same chain of transmitters with words: "As He listens to a Prophet reciting the Qur'an in a sweet voice."

Book 4, Number 1730:

    Abu Huraira is reported to have heard Allah's Messenger (may peace be upon him) as saying: Allah does not listen to anything, (more approvingly) as He listens to a Prophet reciting loudly the Qur'an in a sweet voice.

Book 4, Number 1731:

    This hadith has been narrated with the same chain of transmitters by Ibn al-Had except this that Abu Huraira reported Allah's Messenger (may peace be upon him) as saying and he did not say: "He heard it."

Book 4, Number 1732:

    Abu Huraira reported Allah's Messenger (may peace be upon him) as saying: Allah has not heard anything (more pleasing) than listening to the Prophet reciting the Qur'an in a sweet loud voice.

Book 4, Number 1733:

    This hadith has been narrated by another chain of transmitters but with a slight modification of words.

Book 4, Number 1734:

    Buraida reported on the authority of his father that the Messenger of Allah (may peace be upon him) had said: 'Abdullah b. Qais or al-Ash'ari has been gifted with a sweet melodious voice out of the voices of the family of David.

Book 4, Number 1735:

    Abu Burda narrated on the authority of Abu Musa that the Messenger of Allah (may peace be upon him) had said to Abu Musa: If you were to see me, as I was listening to your recitation (of the Qur'an) yester-night (you would have felt delighted). You are in fact endowed with a sweet voice like that of David himself.

Chapter 125 : THE RECITATION BY THE APOSTLE (MAY PEACE BE UPON HIM) OF SURAT AL-FATH ON THE DAY OF THE CONQUEST OF MECCA

Book 4, Number 1736:

    Mu'awiya b. Qurra reported 'Abdullah b. Mughaffal al-Muzani as saying: The Apostle of Allah (may peace be upon him) recited on his ride Surat al Fath during a journey in the year of the Conquest (of Mecca), and he repeated(the words) in his recitation. Mu'awiya said: If I were not afraid that the people would crowd around me, I would have given a demonstration of (the Prophet's) recitation before you.

Book 4, Number 1737:

    Mu'awiya b. Qurra is reported to have heard 'Abdullah b. Mughaffal as saying: I saw the Messenger of Allah (may peace be upon him) reciting Surah Fath on his camel on the day of the Conquest of Mecca. He (the narrator) said: Ibn Mughaffal recited it and repeated it. Mu'awiya said: Had there been (no crowed of) people, I would have given a practical demonstration of that which Ibn Mughaffal had mentioned from the Apostle of Allah (may peace be upon him).

Book 4, Number 1738:

    This hadlth has been narrated by Khalid al-Harith with the same chain of transmitters (with these words:) (The Holy Prophet) was reciting Surat al-Fath as he was travelling on his mount.

Chapter 126 : DESCENDING OF TRANQUILLITY BY THE RECITATION OF THE QUR'AN

Book 4, Number 1739:

    Al-Bara' reported that a person was reciting Surat al-Kahf and there was a horse tied with two ropes at his side, a cloud overshadowed him, and as it began to come nearer and nearer his horse began to take fright from it. He went and mentioned that to the Prophet (may peace be upon him) in the morning, and he (the Holy Prophet) said: That was tranquillity which came down at the recitation of the Qur'an.

Book 4, Number 1740:

    Ibn Ishaq reported: I heard al-Bara' as saying that a man recited al-Kahf when an animal was there in the house and it began to take fright. And as he looked around, he found a cloud overshadowing it. He mentioned that to the Apostle of Allah (may peace be upon him). Upon this he said: O so and so, recite on (the surah) as- Sakina descends at the (recitation of the Qur'an) or on account (of the recitation) of the Qur'an.

Book 4, Number 1741:

    This hadith has been narrated on the authority of al-Bara' with a slight modification of words.

Book 4, Number 1742:

    Abu Sa'id al-Khudri told of Usaid b. Hudair saying that one night he recited the Qur'an in his enclosure, when the horse began to jump about. He again recited and (the horse) again jumped. He again recited and it jumped as before. Usaid said: I was afraid lest it should trample (his son) Yahya. I stood near it (the horse) and saw something like a canopy over my head with what seemed to be lamps in it, rising up in the sky till it disappeared. I went to the Messenger of Allah (may peace be upon him) on the next day and said: Messenger of Allah, I recited the Qur'an during the night in my enclosure and my horse began to jump. Upon this the Messenger of Allah (may peace be upon him) said: You should have kept on reciting, Ibn Hudair. He (Ibn Hudair) said: I recited. It jumped (as before). Upon this the Messenger of Allah (may peace be upon him) again said: You should have kept on reciting, Ibn Hudair. He (Ibn Hudair) said: I recited and it again jumped (as before). The Messenger of Allah (may peace be upon him) again said: You should kave kept on reciting, Ibu Hudair. He (Ibn Hudair) said: (Messenger of Allah) I finished (the recitation) for Yahya was near (the horse) and I was afraid lest it should trample him. I saw something like a canopy with what seemed to be lamps in it rising up in the sky till it disappeared. Upon this the Messenger of Allah (may peace be upon him) said: Those were the angels who listened to you; and if you had continued reciting, the people would have seen them in the morning and they would not have concealed themselves from them.

Chapter 127 : EXCELLENCE OF THE HAFIZ (ONE WHO COMMITS THE QUR'AN TO MEMORY) OF THE QUR'AN

Book 4, Number 1743:

    Abu Musa al-Ash'ari reported Allah's Messenger (may peace be upon him) as saying: A believer who recites the Qur'an is like an orange whose fragrance is sweet and whose taste is sweet; a believer who does not recite the Qur'an is like a date which has no fragrance but has a sweet taste; and the hypocrite who recites the Qur'an is like a basil whose fragrance is sweet, but whose taste is bitter; and a hypocrite who does not recite the Qur'an is like the colocynth which has no fragrance and has a bitter taste.

Book 4, Number 1744:

    This hadith has been narrated by Qatada with the same chain of transmitters but with one alteration that instead of the word: "hypocrite" (Munafiq), there it is "wicked" (fajir).

Chapter 128 : EXCELLENCE OF THE ONE WHO IS PROFICIENT IN THE QUR'AN AND ONE WHO FALTERS IN IT

Book 4, Number 1745:

    'A'isha reported Allah's Messenger (may peace be upon him) (as saying): One who is proficient in the Qur'an is associated with the noble, upright, recording angels; and he who falters in it, and finds it difficult for him, will have a double reward.

Book 4, Number 1746:

    This hadith has been reported with the same chain of transmitters by Qatada except with this change: "He who finds it hard (to recite the Qur'an) will have a double reward."

Chapter 129 : EXCELLENCE OF THE RECITING OF THE QUR'AN BY ONE WHO IS MORE SKILLED AND PROFICIENT BEFORE ONE WHO IS INFERIOR TO HIM

Book 4, Number 1747:

    Anas reported Allah's Messenger (may peace be upon him) as saying to Ubayy b. Ka'b: Allah has commanded me to recite the Qur'an to you. He said: Did Allah mention me to you by name? He (the Holy Prophet) said: Allah made a mention of your name to me. (On hearing this) Ubayy b. Ka'b wept.

Book 4, Number 1748:

    Anas reported Allah's Messenger (may peace be upon him) as saying to Ubayy b. Ka'b: Aliah has commanded me to recite to you: "Those who disbelieve were not.. ." (al-Qur'an, xcviii. 1). He said: Did He mention me by name? He (the Holy Prophet said): Yes. Upon this he shed tears (of gratitude).

Book 4, Number 1749:

    Qatada said: I heard Anas saying that the Messenger of Allah (may peace be upon him) said to Ubayy the same thing.

Chapter 130 : EXCELLENCE OF LISTENING TO THE QURAN AND ASKING ONE WHO HAS MEMORISED IT AND TO RECITE IT FROM HIS MEMORY AND SHEDDING TEARS WHILE LISTENING TO THE RECITATION, AND DELIBERATING OVER IT

Book 4, Number 1750:

    'Abdullah (b. Mas'ud) reported: The Messenger of Allah (may peace be upon (him) asked me to recite the Qur'an. He said: Messenger of Allah, (how) should I recite to you whereas it has been sent down to you? He (the Holy Prophet) said: I desire to hear it from someone else. So I recited Surat al-Nisa' till I reached the verse: How then shall it be when We shall bring from every people a witness and bring you against them as a witness?" (verse 41). I lifted my head or a person touched me in my side, and so I lifted my head and saw his tears falling (from the Holy Prophet's eyes).

Book 4, Number 1751:

    This hadith has been narratted by A'mash with the same chain of transmitters but with this addition: "The Messenger of Allah (may peace be upon him) was on the pulpit when he asked me to recite to him."

Book 4, Number 1752:

    Ibrahim reported that the Apostle of Allah (may peace be upon him) asked 'Abdullah b. Mas'ud to recite to him (the Qur'an). He said: Should I recite it to you while it has been sent down or revealed to you? He (the Holy Prophet) said: I love to hear it from someone else. So he ('Abdullah b. Mas'ud) recited to him (from the beginning of Surat al Nisa' up to the verse: " How shall then it be when We bring from every people a witness and bring you as a witness against them?" He (the Holy Prophet) wept (on listening to it). It is narrated on the authority of Ibn Mas'ud through another chain of transmitters that the Apostle of Allah (may peace be upon him) also said that he had been a witness to his people as long as (said he) : I lived among them or I had been among them.

Book 4, Number 1753:

    'Abdullah (b. Mas'ud) reported: I was in Hims when some of the people asked me to recite the Qur'an to them. So I recited Surah Yusuf to them. One of the persons among the people said: By Allah, this is not how it has been sent down. I said: Woe upon you ! By Allah, I recited it to the Messenger of Allah (may peace be upon him) and he said to me: You have (recited) it well. I was talking with him (the man who objected to my recitation) that I sensed the smell of wine from him. So I said to him . Do you drink wine and belie the Book (of Allah)? You would not depart till I would whip you. So I lashed him according to the prescribed punishment (for the offence of drinking wine).

Book 4, Number 1754:

    This hadith has been narrated by A'mash with the same chain of transmitters but with an exception that it is not mentioned in it: "He said to me: You recited (the Qur'an) well."

Chapter 131 : EXCELLENCE OF THE RECITATION OF THE QURAN IN PRAYER AND THAT OF ITS LEARNING

Book 4, Number 1755:

    Abu Huraira reported Allah's Messenger (may peace be upon him) as saying: Would any one of you like, when he returns to his family, to find there three large, fat, pregnant she-camels? We said: Yes. Upon this he said: Three verses that one of you recites in his prayer are better for him than three large, fat, pregnant she-camels.

Book 4, Number 1756:

    'Uqba b. 'Amir reported: When we were in Suffa, the Messenger of Allah (may peace be upon him) came out and said: Which of you would like to go out every morning to Buthan or al-'Aqiq and bring two large she-camels without being guilty of sin or without severing the ties of kinship? We said: Messenger of Allah, we would like to do it. Upon this he said: Does not one of you go out in the morning to the mosque and teach or recite two verses from the Book of Allah. the Majestic and Glorious? That is better for him than two she-camels, and three verses are better (than three she-camels).and four verses are better for him than four (she-camels), and to on their number in camels.

Chapter 132 : EXCELLENCE OF THE RECITATION OF THE QUR'AN AND THAT OF SURAH AL-BAQARA

Book 4, Number 1757:

    Abu Umama said he heard Allah's Messenger (may peace be upon him) say: Recite the Qur'an, for on the Day of Resurrection it will come as an intercessor for those who recite It. Recite the two bright ones, al-Baqara and Surah Al 'Imran, for on the Day of Resurrection they will come as two clouds or two shades, or two flocks of birds in ranks, pleading for those who recite them. Recite Surah al-Baqara, for to take recourse to it is a blessing and to give it up is a cause of grief, and the magicians cannot confront it. (Mu'awiya said: It has been conveyed to me that here Batala means magicians.)

Book 4, Number 1758:

    This hadith has been narrated by Mu'awiya with the same chain of transmitters but with this exception that in this the words of Mu'awiya: "It has been conveyed to me.. . " have not been mentioned.

Book 4, Number 1759:

    An-Nawwas b. Sam'an said he heard the Apostle (may peace be upon him) say: On the Day of Resurrection the Qur'an and those who acted according to it will be brought with Surah al-Baqara and AI 'Imran preceding them. The Messenger of Allah (may peace be upon him) likened them to three things, which I did not forget afterwards. He (the Holy Prophet) likened them to two clouds, or two black canopies with light between them, or like two flocks of birds in ranks pleading for one who recited them.

Chapter 133 : EXCELLENCE OF SURAH AL-FATIHA AND CONCLUDING VERSES OF SURAH AL-BAQARA AND EXHORTATION TO RECITE THE LAST TWO VERSES OF SURAH AL-BAQARA

Book 4, Number 1760:

    Ibn 'Abbas reported that while Gabriel was sitting with the Apostle (may peace be upon him) he heard a creaking sound above him. He lifted his head and said: This As a gate opened in heaven today which had never been opened before. Then when an angel descended through it, he said: This is an angel who came down to the earth who had-never come down before. He greeted and said: Rejoice in two lights given to you which have not been given to any prophet before you: Falihat al-Kitab and the concluding verses of Suarah al-Baqara. You will never recite a letter from them for which you will not be given (a reward).

Book 4, Number 1761:

    'Abd al-Rahman b. Yazid reported: I met Abu Mas'ud near the House (Ka'ba) and said to him: A hadith has been conveyed to me on your authority about the two (concluding verses of Surah al-Baqara. He said: Yes. The Messenger of Allah (may peace be upon him) (in fact) said: Anyone who recites the two verses at the end of Surah al-Baqara at night, they would suffice for him.

Book 4, Number 1762:

    This hadith has been narrated by Mansur with the same chain of transmitters.

Book 4, Number 1763:

    Abu Mas'ud reported Allah's Messenger (may peace be upon him) as saying: If anyone recites the two verses at the end of Surah al-Baqara at night, they would suffice for him 'Abd al-Rahman said: I met Abu Mas'ud and he was circumambulating the House (of Allah) and asked him about this (tradition) and he narrated it to me from the Apostle of Allah (may peace be upon him).

Book 4, Number 1764:

    A hadith like this has been narrated by Abu Mas'ud from the Apostle of Allah (may peace be upon him) through another chain of transmitters.

Book 4, Number 1765:

    It is through another chain of transmitters that this hadith has been reported by Abu Mas'ud from the Apostle of Allah (may peace be upon him).

Chapter 134 : EXCELLENCE OF SURAH AL-KAHF AND AYAT AL-KURSI

Book 4, Number 1766:

    Abu Darda' reported Allah's Apostle (may peace be upon him) as saying: If anyone learns by heart the first ten verses of the Surah al-Kahf, he will be protected from the Dajjal.

Book 4, Number 1767:

    This hadith has been transmitted by Qatada with the same chain of transmitters. But Shu'ba (one of the narrators) said: At the end of Surah al-Kahf, but Hammam said: At the beginning of Surah al-Kahf.

Book 4, Number 1768:

    Ubayy b. Ka'b said: Allah's Messenger (may peace be upon him) said: O Abu' al-Mundhir, do you know the verse from the Book of Allah which, according to you, is the greatest? I said: Allah and His Apostle (may peace be upon him) know best. He again said: Abu'l-Mundhir, do you know the verse from the Book of Allah which, according to you, is the greatest? I said: Allah, there is no god but He, the Living, the Eternal. Thereupon he struck me on my breast and said: May knowledge be pleasant for you, O Abu'l-Mundhir!

Chapter 135 : EXCELLENCE OF THE RECITATION OF "SAY: HE IS ALLAH, THE ONE" (SURAH IKHLAS)

Book 4, Number 1769:

    Abu Darda' reported Allah's Apostle (may peace be upon him) as saying: Is any one of you incapable of reciting a third of the Qur'an in a night? They (the Companions) asked: How could one recite a third of the Qur'an (in a night)? Upon this he (the Holy Prophet) said: "He is Allah, One" (Qur'An. cxii.) is equivalent to a third of the Qur'an.

Book 4, Number 1770:

    This hadith has been narrated by Qatada with the same chain of transmitters in these words: He (the Apostle of Allah) said: Allah divided the Qur'an into three parts, and he made: "Say: He, Allah is One." one part out of the (three) parts of the Qur'an.

Book 4, Number 1771:

    It is reported on the authority of Abu Huraira that the Messenger of Allah (may peace be upon him) said: Get together. for I am going to recite one-third of the Qur'an before you. And those who could get together gathered there. Then the Apostle of Allah (may peace be upon him) came out and recited: "Say: He, Allah, is One." He then entered (his house). Some of us said to the others: Perhaps there has been some news from the heaven on account of which he has gone Inside (the house). The Apostle of Allah (may peace be upon him) again came out and said: I told you that I was going to recite one-third of the Qur'in; keep in mind, this (Surah Ikhlas) is equivalent to one-third of the Qur'an.

Book 4, Number 1772:

    Abu Huraira reported: The Messenger of Allah (may peace be upon him) came out to us and said: I am going to recite before you one-third of the Qur'an. He (the Holy Prophet) then recited: "Say: He is Allah, One--Allah, the Eternal," to the end of the Surah.

Book 4, Number 1773:

    'A'isha reported: The Messenger of Allah (may peace be upon him) sent a man in charge of an expedition and he would recite for his Companions during their prayer, ending (recitation) with: "Say, He is God, One." When they returned mention was made of it to the Messenger of Allah (may peace be upon him). He (the Holy Prophet) told them to ask him why he had done like that. So they asked him and he said: Verily, it is an attribute of the Compassionate One, and (for this reason) I love to recite it. The Messenger of Allah (may peace be upon him) thereupon said: Inform him that Allah loves him.

Chapter 136 : EXCELLENCE OF THE RECITATION OF THE TWO SURAHS CONCERNING THE TAKING OF REFUGE

Book 4, Number 1774:

    'Uqba b. 'Amir reported Allah's Messenger (may peace be upon him) as saying: What wonderful verses have been sent down today. the like of which has never been seen ! They are: "Say: I seek refuge with the Lord of the dawn," and "Say: I seek refuge with the Lord of men."

Book 4, Number 1775:

    'Uqba b. 'Amir reported: The Messenger of Allah (may peace be upon him) said to me: There have been sent down to me verses the like of which had never been seen before. They are the Mu'awwadhatain.

Book 4, Number 1776:

    This hadith has been narrated through another chain of transmitters directly from the Companions of Muhammad (may peace be upon him).

Chapter 137 : EXCELLENCE OF ONE WHO ACTS UPON (THE TEACHINGS OF THE) QUR'AN AND ONE WHO TEACHES IT

Book 4, Number 1777:

    Salim narrated on the authority of his father (Ibn 'Umar) that the Apostle of Allah (may peace be upon him) said: Envy is not justified but in case of two persons only: one who, having been given (knowledge of) the Qur'an by Allah, recites it during the night and day (and also acts upon it) and a man who, having been given wealth by God, spends it during the night and the day (for the welfare of others. seeking the pleasure of the Lord).

Book 4, Number 1778:

    Salim son of Abdullah b. 'Umar is reported to have said on the authority of his father that the Messenger of Allah (may peace be upon him) observed : Envy is not justified but in case of two persons only: one who, having been given (knowledge of) the Qur'an by Allah, recites it during the night and during the day (and acts upon it), and the person who, having been given wealth by God, gives it in charity during the night and the day.

Book 4, Number 1779:

    'Abdullah b. Mas'ud reported Allah's Messenger (may peace be upon him) as saying: There should be no envy but only in case of two persons: one having been endowed with wealth and power to spend it in the cause of Truth, and (the other) who has been endowed with wisdom and he decides cases with the help of it and teaches it (to others).

Book 4, Number 1780:

    'Amir b. Wathila reported that Nafi' b. 'Abd al-Harith met 'Umar at 'Usfan and 'Umar had employed him as collector in Mecca. He (Hadrat 'Umar) said to him (Nafi'): Whom have you appointed as collector over the people of the valley? He said: Ibn Abza. He said: Who is Ibn Abza? He said: He is one of our freed slaves. He (Hadrat 'Umar) said: So you have appointed a freed slave over them. He said: He is well versed In the Book of Allah. the Exalted and Great, and he is well versed In the commandments and injunctions (of the Shari'ah). 'Umar said: So the Holy Prophet (may peace be upon him) said: By this Book, Allah would exalt some peoples and degrade others.

Book 4, Number 1781:

    This hadith has been narrated by Zuhri through another chain of transmitters.

Chapter 138 : "THE QUR'AN HAS BEEN REVEALED IN SEVEN MODES OF READING" AND ITS MEANING

Book 4, Number 1782:

    'Umar b. Khattab said: I heard Hisham b. Hakim b. Hizam reciting Surah al-Furqan in a style different from that in which I used to recite it, and in which Allah's Messenger (may peace be upon him) had taught me to recite it. I was about to dispute with him (on this style) but I delayed till he had finished that (the recitation). Then I caught hold of his cloak and brought him to the Messenger of Allah (may peace be upon him) and said: Messenger of Allah, I heard this man reciting Surah al-Furqan in a style different from the one in which you taught me to recite. Upon this the Messenger of Allah (may peace be upon him) told (me) to leave him alone and asked him to recite. He then recited in the style in which I beard him recite it. The Messenger of Allah (may peace be upon him) then said: Thus was it sent down. He then told me to recite and I recited it, and he said: Thus was it sent down. The Qur'an was sent down in seven dialects. So recite what seems easy therefrom.

Book 4, Number 1783:

    This hadith has been transmitted thus by 'Umar b. Khattab (with a slight change of words): "I heard Hisham b. Hakim reciting Surah al-Furqan during the lifetime of Allah's Messenger (may peace be upon him)." The rest is the same but with this addition: "I was about to catch hold of him in prayer, but I exercised patience till he pronounced salutation.

Book 4, Number 1784:

    This hadith has been transmitted by Zuhri.

Book 4, Number 1785:

    Ibn 'Abbas reported Allah's Messenger (may peace be upon him) as saying: Gabriel taught me to recite in one style. I replied to him and kept asking him to give more (styles), till he reached seven modes (of recitation). Ibn Shibab said: It has reached me that these seven styles are essentially one, not differing about what is permitted and what is forbidden.

Book 4, Number 1786:

    This hadith has been narrated by Zuhri with the same chain of trans- mitters.

Book 4, Number 1787:

    Ubayy b. Ka'b reported: I was in the mosque when a man entered and prayed and recited (the Qur'in) in a style to which I objected. Then another man entered (the mosque) and recited in a style different from that of his companion. When we had finished the prayer, we all went to Allah's Messenger (may peace be upon him) and said to him: This man recited in a style to which I objected, and the other entered and recited in a style different from that of his companion. The Messenger of Allah (may peace be upon him) asked them to recite and so they recited, and the Apostle of Allah (may peace be upon him) expressed approval of their affairs (their modes of recitation). and there occurred In my mind a sort of denial which did not occur even during the Days of Ignorance. When the Messenger of Allah (may peace be upon him) saw how I was affected (by a wrong idea), he struck my chest, whereupon I broke into sweating and felt as though I were looking at Allah with fear. He (the Holy Prophet) said to me: Ubayy. a message was sent to me to recite the Qur'an in one dialect, and I replied: Make (things) easy for my people.It was conveyed to me for the second time that it should be recited in two dialects. I again replied to him: Make affairs easy for my people. It was again conveyed to me for the third time to recite in seven dialects And (I was further told) : You have got a seeking for every reply that I sent you, which you should seek from Me. I said: O Allah ! forgive my people, forgive my people, and I have deferred the third one for the day on which the entire creation will turn to me, including even Ibrahim (peace be upon him) (for intercession).

Book 4, Number 1788:

    Ubayy b. Ka'b reported that he was sitting in a mosque that a person entered it and he observed prayer, and made recitation, the rest of the hadith is the same.

Book 4, Number 1789:

    Ubayy b. Ka'b reported that the Apostle of Allah (may peace be upon him) was near the tank of Banu Ghifar that Gabriel came to him and said: Allah has commanded you to recite to your people the Qur'an in one dialect. Upon this he said: I ask from Allah pardon and forgiveness. My people are not capable of doing it. He then came for the second time and said: Allah has commanded you that you should recite the Qur'an to your people in two dialects. Upon this he (the Holy prophet) again said: I seek pardon and forgiveness from Allah, my people would not be able to do so. He (Gabriel) came for the third time and said: Allah has commanded you to recite the Qur'an to your people in three dialects. Upon this he said: I ask pardon and forgiveness from Allah. My people would not be able to do it. He then came to him for the fourth time and said: Allah has commanded you to recite the Qur'an to your people in seven dialects, and in whichever dialect they would recite, they would be right.

Book 4, Number 1790:

    This hadith has been narrated by Shu'ba with the same chain of transmitters.

Chapter 139 : RECITING THE QUR'AN LEISURELY AND DISTINCTIVELY AND ABSTAINING FROM RECITING IT VERY HURRIEDLY, AND PERMISSIBILITY OF RECITING TWO SURAHS OR MORE THAN TWO IN A RAK'AH

Book 4, Number 1791:

    Abu Wa'il reported that a person named Nabik b. Sinan came to Abdullah (b. Mas'ud) and said: Abu 'Abd al-Rahman, how do you recite this word (alif) or (ya)? Would you read It as: min ma'in ghaira asin or au min ma'in ghaira ghaira yasin.(al-Qur'an, xlvii. 15) ?'Abdullah said: You (seem to) have memorised the whole of the Qur'an except this. He (again) said:I recite all the mufassal surahs in one rak'ah. Upon this 'Abdullah said: (You must have been reciting It) hastily like the recitation of poetry. Verily. there are people who recite the Qur'an, but it does not go down beyond their collar bones. It is (a fact with the Qur'an) that it is beneficial only when it settles in the heart and is rooted deeply in it. The best of (the acts) in prayer are bowing and prostration. I am quite aware of the occasions when the Messenger of Allah (may peace be upon him) combined together two surahs in every rak'ah. 'Abdullah then stood up and went out with 'Alqama following in his footstep. He said Ibn Numair had told him that the narration was like that: "A person belonging to Banu Bajila came to 'Abdullah," and he did not mention (the name of) Nahik b. Sinan.

Book 4, Number 1792:

    Abu Wa'il reported: A person came to 'Abdullah, who was called Nahik b. Sinan, and the rest of the hadith is the same but for this: " Alqama came to him ('Abdullah b. Mas'ud) and we said to him: Ask him about the manners in which he combined (two surahs) in one rak'ah. So he went to him and asked him and then came to us and said: Twenty are the mufassal surahs in the compilation (of the Qur'an) made by 'Abdullah."

Book 4, Number 1793:

    This hadith has been narrated by A'mash with the same chain of transmitters in which ('Abdullah b. Mas'ud) said: "I know the manners in which the Messenger of Allah (may peace be upon him) recited the two surahs in one rak'ah and then twenty surahs in ten rak'ahs."

Book 4, Number 1794:

    Abu Wa'il reported: One day we went to 'Abdullah b. Mas'ud after we had observed the dawn prayer and we paid salutation at the door. He permitted us to enter, but we stayed for a while at the door, when the slave-girl came out and said: Why don't you come in? So we went in and (we found 'Abdullah b. Mas'ud) sitting and glorifying Allah (i.e. he was busy in dhikr) and he said: What obstructed you from coming in though you had been granted permission for it? We said: There was nothing (behind it) but we entertained the idea that some inmate of the house might be sleeping. He said: Do you presume any idleness on the part of the family of Ibn Umm 'Abd (the mother of Abdullah b. Mas'ud)? He was again busy with the glorification of Allah till he thought that the sun had risen. He said: Girl, see whether (the sun) has arisen. She glanced but it had not risen (by that time). He was again busy with the glorification (of Allah) and he (again) thought that the sun had arisen. She glanced (and confirmed) that,it had risen. Upon this he ('Abdullah b. Mas'ud) said: Praise be to Allah Who did not call us to account for our sins today. Mahdi said: I think that he said, He did not destroy us for our sins. One among the people said: I recited all the mufassal surahs during the night. 'Abdullah said: (You must have recited them) like the (recitation) of poetry. I heard (the Holy Prophet) combining (the sarahs) and I remember the combinations which the Messenger of Allah (may peace be upon him) made In the recitation (of surahs). These were constituted of eighteen mufassal surahs and two surahs (commencing with) Ha-Mim.

Book 4, Number 1795:

    Shaqiq reported: A person from Banu Bajila who was called Nabik b. Sinan came to Abdullah and said: I recite mufassal surahs in one rak'ah. Upon this 'Abdullah said: (You recite) like the recitation of poetry. I know the manner in which the Messenger of Allah (may peace be upon him) recited two surahs in one rak'ah.

Book 4, Number 1796:

    Abu Wa'il reported: A person came to 'Abdullah b. Mas'ud and said: I recited all the mufassal surahs in one rak'ah during the night. 'Abdullah said: You must have recited hastily like the recitation of poetry. 'Abdullah said: I remember well the manner in which the Messenger of Allah (may peace be upon him) used to combine them, and he then mentioned twenty of the mufassal surahs, and (their combinations in) two in every rak'ah.

Chapter 140 : THAT WHICH CONCERNS RECITATION

Book 4, Number 1797:

    Abu Ishaq reported: I saw a man asking Aswad b. Yazid who taught the Qur'an in the mosque: How do you recite the verse (fahal min muddakir) whether (the word muddakir) Is with (d) or (dh)? He (Aswad) said: It was with (d). I heard Abdullah b. Mas'ud saying that he had heard the Messenger of Allah (may peace be upon him) reciting (muddakir) with (d).

Book 4, Number 1798:

    Ishaq is reported to have said on the authority of Aswad who quoted on the authority of 'Abdullah b. Mas'ud that the Apostle of Allah (may peace be upon him) used to recite these words as (fahal min muddakir).

Book 4, Number 1799:

    'Alqama reported. We went to Syria and Abu Darda' came to us and said: Is there anyone among you who recites according to the recitation of Abdullah? I said: Yes, it is I. He again said: How did you hear 'Abdullah reciting this verse: (wa'l-lail-i-idha yaghsha = when the night covers)? He ('Alqama) said: I heard him reciting it (like this) (wa'l-lail-i-idha yaghsha) wa-dhakar wal untha = when the night covers and the males and the females). Upon this he said: By Allah, I heard the Messenger of Allah (may peace be upon him) reciting in this way, but they (the Muslims of Syria) desire us to recite: (wa ma khalaqa), but I do not yield to their desire.

Book 4, Number 1800:

    Ibrahim reported: 'Alqama came to Syria and entered the mosque and prayed there and then went to a (place where people were sitting in a) circle and he sat therein. Then a person came there and I perceived that the people were annoyed and perturbed (on this arrival). and he sat on my side and then said: Do you remember how 'Abdullah used to recite (the Qur'an)? And then the rest of the hadith was narrated.

Book 4, Number 1801:

    'Alqama reported: I met Abu Darda', and he said to me: To which country do you belong? I said: I am one of the people of Iraq. He again said: To which city? I replied: City of Kufa. He again said: Do you recite according to the recitation of 'Abdullah b. Mas'ud? I said: Yes. He said: Recite this verse (By the night when it covers) So I recited it: (By the night when it covers, and the day when it shines, and the creating of the male and the female). He laughed and said: I have heard the Messenger of Allah (may peace be upon him) reciting like this.

Book 4, Number 1802:

    This hadith has been narrated by another chain of transmitters.

Chapter 141 : TIMES WHEN PRAYER IS PROHIBITED

Book 4, Number 1803:

    Abu Huraira is reported to have said that the Messenger of Allah (may peace be upon him) prohibited to observe prayer after the 'Asr prayer till the sun is set, and after the dawn till the sun rises.

Book 4, Number 1804:

    Ibn 'Abbas reported: I heard it from so many Companions of the Messenger of Allah (may peace be upon him) and one among them is 'Umar b. Khattab, and he is most dear to me among them that the Messenger of Allah (may peace be upon him) prohibited observing of prayer after the dawn prayer till the sun rose and after the 'Asr till the sun set. This hadith has been narrated by Qatada with the same chain of transmitters with a minor alteration of words.

Book 4, Number 1805:

    Abu Sa'id al-Khudri reported Allah's Messenger (may peace be upon him) as saying: No prayer is valid after the 'Asr prayer till the sun sets and no prayer is valid after the dawn prayer till the sun rises.

Book 4, Number 1806:

    Ibn 'Umar reported Allah's Messenger (may peace be upon him) as saying: Let not any one of you intend to observe prayer at the time of the rising of the sun or of the setting sun.

Book 4, Number 1807:

    Ibn 'Umar reported Allah's Messenger (may peace be upon him) as saying: Do not intend to observe prayer at the time of the rising of the sun nor at its setting, for it rises between the horns of Satan.

Book 4, Number 1808:

    Ibn 'Umar reported Allah's Messenger (may peace be upon him) as saying: When the rim of the sun starts appearing defer prayer till it completely appears, and when the rim of the sun disappears defer prayer till it completely disappears.

Book 4, Number 1809:

    Abu Basra Ghifari reported: The Messenger of Allah (may peace be upon him) led us in the 'Asr prayer at (the place known as) Mukhammas, and then said: This prayer was presented to those gone before you, but they lost it, and he who guards it has two rewards in store for him. And no prayer is valid after till the onlooker appears (by onlooker is meant the evening star).

Book 4, Number 1810:

    This hadith has been narrated by Abu Basra Ghifari through another chain of transmitters.

Book 4, Number 1811:

    Uqba b. 'Amir said: There were the times at which Allah's Messenger (may peace be upon him) forbade us to pray, or bury our dead: When the sun begins to rise till it is fully up, when the sun is at its height at midday till it passes over the meridian, and when the sun draws near to setting till it sets.

Chapter 142 : HOW 'AMR B. 'ABASA EMBRACED ISLAM

Book 4, Number 1812:

    'Amr b. 'Abasa Sulami reported: I in the state of the Ignorance (before embracing Islam) used to think that the people were in error and they were not on anything (which may be called the right path) and worshipped the idols. In the meanwhile I heard of a man in Mecca who was giving news (on the basis of his prophetic knowledge); so I sat on my ride and went to him. The Messenger of Allah (may peace be upon him) was at that time hiding as his people had made life hard for him. I adopted a friendly attitude (towards the Meccans and thus managed) to enter Mecca and go to him (the Holy Prophet) and I said to him: Who are you? He said: I am a Prophet (of Allah). I again said: Who is a Prophet? He said: (I am a Prophet in the sense that) I have been sent by Allah. I said: What is that which you have been sent with? He said: I have been sent to join ties of relationship (with kindness and affection), to break the Idols, and to proclaim the oneness of Allah (in a manner that) nothing is to be associated with Him. I said: Who is with you in this (in these beliefs and practices)? He said: A free man and a slave. He (the narrator) said: Abu Bakr and Bilal were there with him among those who had embraced Islam by that time. I said: I intend to follow you. He said: During these days you would not be able to do so. Don't you see the (hard) condition under which I and (my) people are living? You better go back to your people and when you hear that I have been granted victory, you come to me. So I went to my family. I was in my home when the Messengerof Allah (may peace be upon him)came to Medina. I was among my people and used to seek news and ask people when he arrived in Medina. Then a group of people belonging to Yathrib (Medina) came. I said (to them): How is that person getting on who has come to Medina? They said: The people are hastening to him, while his people (the polytheists of Mecca) planned to kill him, but they could not do so. I (on hearing It) came to Medina and went to him and said: Messenger of Allah, do you recognise me? He said: Yes, you are the same man who met me at Mecca. I said: It is so. I again said: Prophet of Allah, tell me that which Allah has taught you and which I do not know, tell me about the prayer. He said: Observe the dawn prayer, then stop praying when the sun is rising till it Is fully up, for when it rises it comes up between the horns of Satan, and the unbelievers prostrate themselves to it at that time. Then pray, for the prayer is witnessed and attended (by angels) till the shadow becomes about the length of a lance; then cease prayer, for at that time Hell is heated up. Then when the shadow moves forward, pray, for the prayer is witnessed and attended by angels, till you pray the afternoon prayer, then cease prayer till the sun sets, for it sets between the horns of devil, and at that time the unbelievers prostrate themselves before it. I said: Apostle of Allah, tell me about ablution also. He said: None of you who uses water for ablution and rinses his mouth, snuffs up water and blows it, but the sins of his face, and his mouth and his nostrils fall out. When he washes his face, as Allah has commanded him, the sins of his face fall out from the end of his beard with water. Then (when) he washes his forearms up to the elbows, the sins of his arms fall out along with water from his finger-tips. And when he wipes his head, the sins of his head fall out from the points of his hair along with water. And (when) he washes his feet up to the ankles, the sins of his feet fall out from his toes along with water. And if he stands to pray and praises Allah, lauds Him and glorifies Him with what becomes Him and shows wholehearted devotion to Allah, his sins would depart leaving him (as innocent) as he was on the day his mother bore him. 'Amr b. 'Abasa narrated this hadith to Abu Umama, a Companion of the Messenger of Allah (may peace be upon him), and Abu Umama said to him: 'Amr b. 'Abasa, think what you are saying that such (a great reward) is given to a man at one place (only in the act of ablution and prayer). Upon this 'Amr said: Abu Umama, I have grown old and my bones have become weak and I am at the door of death; what impetus is there for me to attribute a lie to Allah and the Messenger of Allah (may peace be upon him)? Had I heard it from the Messenger of Allah (may peace be upon him) once, twice, or three times (even seven times), I would have never narrated it, but I have heard it from him on occasions more than these.

Chapter 143 : DO NOT GET INTO THE HABIT OF OBSERVING PRAYER AT THE TIME OF THE RISING SUN AND AT THE TIME OF ITS SETTING

Book 4, Number 1813:

    'A'isha reported that 'Umar misconstrued the fact that the Messenger of Allah (may peace be upon him) had prohibited the observance of prayer at the time of the rising sun and at the time of its setting.

Book 4, Number 1814:

    'A'isha said that the Messenger of Allah (may peace be upon him) did not abandon observing two rak'ahs after 'Asr, but she reported Allah's Messenger (may peace be upon him) as saying: Do not get used to observe prayer at the time of the rising sun and at the time of its setting and (exhorted the Muslims) to pray at their times.

Book 4, Number 1815:

    Kuraib, the freed slave of Ibn 'Abbas, reported that 'Abdullah b. 'Abbas, 'Abd al-Rahman b. Azhar, al-Miswar b. Makhrama sent him to 'A'isha, the wife of the Messenger of Allah (may peace be upon him), telling him to give her their greetings, and ask her about the two rak'ahs after the afternoon prayer, (for) "we have heard that you observe them whereas it has been conveyed to us that the Messenger of Allah (may peace be upon him) prohibited their observance." Ibn 'Abbas said: I along with 'Umar b. al-Khattab dissuaded people to do so (to observe two rak'ahs of prayer). Kuraib said: I went to her ('A'isha) and conveyed to her the message with which I was sent. She said: (Better) ask Umm Salama. So I went to them (those who had sent him to Hadrat 'A'isha) and informed them about what she had said. They sent me back to Umm Salama with that with which I was sent to 'A'isha. Umm Salama said: I beard the Messenger of Allah (may peace be upon him) prohibiting them, and then afterwards I saw him observing them. And when he observed them (two rak'ahs) he had already observed the 'Asr prayer. Then he (the Holy Prophet) came, while there were with me ladies of Banu Haram, a tribe of the Ansar and he (the Holy Prophet) observed them (the two rak'ahs). I sent a slave-girl to him asking her to stand by his side and say to him that Umm Salama says: Messenger of Allah, I heard you prohibiting these two rak'ahs, whereas I saw you observing them; and if he (the Holy Prophet) points with his hand (to wait), then do wait. The slave-girl did like that. He (the Holy Prophet) pointed out with his hand and she got aside and waited, and when he had finished (the prayer) he said: Daughter of Abu Umayya. you have asked about the two rak'ahs after the 'Asr prayer. Some people of 'Abu al-Qais came to me for embracing Islam and hindered me from observing the two rak'ahs which come after the noon prayer. So those are the two I have been praying.

Book 4, Number 1816:

    Abu Salama asked 'A'isha about the two prostrations (i.e. rak'ahs) which the Messenger of Allah (may peace be upon him) made after the 'Asr. She said: He (the Holy Prophet) observed them before the 'Asr prayer, but then he was hindered to do so, or he forgot them and then he observed them after the 'Asr, and then he continued observing them. (It was his habit) that when he (the Holy Prophet) observed prayer, he then continued observing it. Isma'il said: It implies that he always did that.

Book 4, Number 1817:

    'A'isha reported: The Messenger of Allah (may peace be upon him) did not abandon at all observing two rak'ahs after the 'Asr in my house.

Book 4, Number 1818:

    'A'isha reported: Two are the prayers which the Messenger of Allah (may peace be upon him) always observed in my house-openly or secretly-two rak'ahs before the dawn and two rak'ahs after the 'Asr.

Book 4, Number 1819:

    Aswad and Masruq reported: We bear testimony to the fact that 'A'isha said: Never was there a day that he (the Holy Prophet) was with me and he did not observe two rak'ahs of prayer in my house, i.e. two rak'ahs after the Asr.

Chapter 144 : EXCELLENCE OF OBSERVING TWO RAK'AHS BEFORE THE EVENING PRAYER

Book 4, Number 1820:

    Mukhtar b. Fulful said: I asked Anas b. Malik about the voluntary prayers after the afternoon prayer, and he replied: 'Umar struck hit hands on prayer observed after the 'Asr prayer and we used to observe two rak'ahs after the sun set before the evening prayer during the time of the Apostle of Allah (may peace be upon him). I said to him: Did the Messenger of Allah (may peace be upon him) observe them? He said: He saw us observing them, but he neither commanded us nor forbade us to do so.

Book 4, Number 1821:

    Anas b. Malik reported: When we were in Medina, the moment the Mu'adhdhin made the call to the sunset prayer, the people hastened to the pillars of the mosque and prayed two rak’ahs with the result that any stranger coming into the mosque would think that the obligatory prayer had been observed owing to the number who were praying then.

Book 4, Number 1822:

    Abdullah b. Mughaffal reported Allah's Messenger (may peace be upon him) u saying: There Is between the two calls (Adhan and Iqama) a prayer. And he mentioned it three times, and at the third time he said: This applies to those who wish to do it.

Book 4, Number 1823:

    This hadith has been narrated by Abdullah b. Mughaffal by another chain of transmitters, but with this variation that he (the Holy Prophet) said at the fourth time: "He who wishes (may do to)."

Chapter 145 : PRAYER IN TIME OF DANGER

Book 4, Number 1824:

    Salim b. Abdullah b. 'Umar reported: The Messenger of Allah (may peace he upon him) led on* of the two groups In one rak’ah of prayer in danger, while the other group faced the -enemy. Then they (the members of the first group) went back and replaced their companions who were facing the enemy. and then they (the members of the second group) came and the Apostle of Allah (may peace be upon him) led them in one rak’ah of prayer. Then the Apostle of Allah (may peace be upon him) pronounced salutation, and then they (the members of the Ant group) completed the rak’ah and they (the members of the second group) completed the rak’ah. This hadith has been narrated by another chain of tranamitters.

Book 4, Number 1825:

    Ibn Umar reported that the Messenger of Allah (may peace be upon him) observed prayer in danger on some day (in this way): a group stood with him (the Holy Prophet) (for prayer) and the other group stood In front of the enemy. Then those who were with (him) observed one rak’ah of prayer and they went back and the others came and they observed one rak’ah (with him). Then both the groups completed one rak’ah each. Ibn Umar said: When there is greater danger, then observe prayer even on the ride or with the help of gestures in a standing posture.

Book 4, Number 1826:

    Jabir b. 'Abdullah reported: I observed prayer in danger with the Messenger of Allah (may peace be upon him). We drew ourselves up in two rows, one row behind him with the enemy between us and the Qibla. The Apostle of Allah (may peace be upon him) said: Allah is Most Great, and we all said it. He then bowed and we all bowed. He then raised his head from bowing, we all raised (our heads). He then went down in prostration along with the row close to him, and the rear row faced the enemy; then when the Apostle of Allah (may peace be upon him) completed the prostration,; and then stood up, the row near to him also did it; then went down the rear row in prostration; then they stood up; then the rear row went to the front and the front row went to the rear. Then the Apostle of Allah (may peace he upon him) bowed down and we all bowed. He then raised his head from bowing and we also raised (our heads). He and the row close to him which I had been in the rear then went down in prostration In the first rak’ah, whereas the rear row faced the enemy. And when the Apostle of Allah (may peace be upon him) and the rear row close to him had finished the prostration, the rear row went down and prostrated themselves; then the Apostle of Allah pronounced the salutation and we also pronounced the salutation. (Jabir said we hadith) as your guards behave with their chiefs.

Book 4, Number 1827:

    Jabir reported: We fought In the company of the Messenger of Allah (may peace be upon him) with the tribe of Juhaina. They fought with us terribly. When we had finished the noon prayer, the polytheists said: Had we attacked them at once. we would have killed them. Gabriel informed the Messenger of Allah (may peace be upon him) about It (about their evil design). The Messenger of Allah (may peace be upon him) made a mention of it to us, adding that they (the polytheists) had also said: Shortly there would be time for the 'Asr prayer. which is dearer o them (the Muslims) than even their children. So when the time of the 'Asr prayer came. we formed ourselves into two rows, while the polytheists were between us and the Qibla. The Messenger of Allah (may peace be upon him) said: Allah is Most Great, and we also said so. He bowed and we also bowed. He went down in prostration and the first row prostrated along with him. When they stood up, the second row went down in prostration. Then the first row went into the rear, and the second row came in the front and occupied the place of the first row. The Messenger of Allah (may peace be upon him) then said: Allah is Most Great, and we also said so. He then bowed, and we also bowed. He then went down in prostration and along with him the row also (went down in prostration), and the second row remained standing. And when the second row had also prostrated and all of them sat down then the Messenger of Allah (may peace be upon him) pronounced salutation to them. Abu Zubair said: Jabir made a mention specially of this thing: just as your chiefs observe prayer.

Book 4, Number 1828:

    Sahl b. Abu Hathma reported that the Messenger of Allah (may peace be upon him) led his Companions in prayer in danger. He made them stand in two rows behind him. He led them who were close to him in one rak’ah. He then stood up and kept standing till those who were behind them observed one rak’ah. Then they (those standing in the second row) came in front and those who were in front went into the rear. He then led them In one rak’ah. He then sat down, till those who were behind him observed one rak’ah and then pronounced salutation.

Book 4, Number 1829:

    Yazid b. Ruman told on the authority of Salih b. Khawwat on the authority of one who prayed in time of danger with Allah's Messenger (may peace he upon him) at the Battle of Dhat ar-Riqa' that a group formed a row and prayed along with him, and a group faced the enemy. He led the group which was along with him in a rak’ah, then remained standing while they finished the prayer by themselves. Then they departed and formed a row facing the enemy. Then the second group came and he led them in the remaining rak'ah, after which he remained seated while they finished the prayer themselves. He then led them in salutation.

Book 4, Number 1830:

    Jabir reported: We went forward with the Messenger of Allah (may peace be upon him) and when we reached Dhat ar-Riqa’, we came to a shady tree which -we left for him One of the polytheists came there and, seeing the sword of the Messenger (may peace be upon him) hanging by a free. took it up. drew it from the scabbard and said to the Messenger of Allah (may peace be upon him): Are you afraid of Me? He (the Holy Prophet) said: No. He again said: Who would protect you from me? He said: Allah will protect me from you. The Companions of the Messenger of Allah (may peace be upon him) threatened him. He sheathed the sword and hung it up. Then call to prayer was made and he (the Holy Prophet) led a group in two rak’ah. Then (the members of this group) withdrew and he led the second group in two rak’ah. So the Messenger of Allah (may peace be upon him) observed four rak’ah and people observed two rak’ah.

Book 4, Number 1831:

    Abu Salama b. ‘Abd al-Rahman reported that Jabir told him that he had observed the prayer in danger with the Messenger of Allah (may peace be upon him). The Messenger of Allah (may peace be upon him) (first) led one of the two groups in two rak’ah of prayer. and then led the second group in two rak’ah of prayer. So the Messenger of Allah (may peace be upon him) observed four rak’ah and led in two rak’ah each of the groups.

Chapter 146 : KITAB AL-JUMU'A

    We have already explained that Islam exhorts its followers to make their social life a visible expression of God-consciousness. Prayer is the most effective means of fostering this virtue in man That is the reason why it has been made essential for the Muslims to observe obligatory prayers in congregation. Jumu'a is a step forward in this respect. The purpose behind it is to provide opportunities to the greater number of Muslims to attend larger congregations in the mosques in an atmosphere of religions piety. Apart from prayer, sermon has also been made an integral part of the Jumu'a prayer. The Imam delivers the sermon and instructs people in religion. He explains to them the day-to-day problems in the light of Islam.

Book 4, Number 1832:

    Abdullah is reported to have heard Allah's Messenger (may peace be upon him) as saying: When any one of you intends to come for Jumu’a prayer, he should take a bath.

Book 4, Number 1833:

    Abdullah b. Umar is reported to have said that The Messenger of Allah (may peace be up on him)was standing on the pulpit when he said this: He who comes for Jumu'a he should take a bath.

Book 4, Number 1834:

    This hadith has been narrated by Ibn Umar by another chain of transmitters.

Book 4, Number 1835:

    'Abdullah (b. Umar) reported on the authority of his father that he beard like this from the Messenger of Allah (may peace be upon him).

Book 4, Number 1836:

    'Abdullah (b. 'Umar) reported from his father that while he was addressing the people on Friday (sermon), a person, one of the Companions of the Messenger of Allah (may peace be upon him), entered (the mosque). Umar said to him loudly: What is this hour (for attending the prayer)? He said: I was busy today and I did not return to my house when I heard the call (to Friday prayer), and I did no more but performed ablution only. Upon this Umar said: just ablution ! You know that the Messenger of Allah (may peace be upon him) commanded (us) to take a bath (on Friday).

Book 4, Number 1837:

    Abu Huraira reported: Umar b. Khattab was delivering a sermon to the people on Friday when 'Uthman b. 'Affan came there. 'Umar hinting to him said: What would become of those persons who come after the call to prayer? Upon this 'Uthman said: Commander of the faithful, I did no more than this that after listening to the call, I performed ablution and came (to the mosque). 'Umar said: Just ablution ! Did you not bear the Messenger of Allah (my peace be upon him) say this: When any one of you comes for Jumu’a, he should take a bath.

Chapter 147 : THE ESSENTIALITY OF TAKING A BATH ON FRIDAY

Book 4, Number 1838:

    Sa’id al-Khudri reported Allah's Messenger (may peace be upon him) as saying: Taking a bath on Friday is essential for every adult person.

Book 4, Number 1839:

    'Aisha reported: The people came for Jumu’a prayer from their houses in the neighbouring villages dressed in woollen garments on which dust was settled and this emitted a foal smell. A person among them (those who were dressed so) came to the Messenger of Allah (may peace be upon him) while he was in my house. The Messenger of Allah (may peace he upon him) said to him: Were you to cleanse yourselves on this day.

Book 4, Number 1840:

    ‘Aisha reported: The people (mostly) were workers and they had no servants. Ill-smell thus emitted out of them. It was said to them: Were you to take bath on Friday.

Chapter 148 : PERFUME AND USING OF MISWAK ON FRIDAY

Book 4, Number 1841:

    ‘Abd al-Rahman son of Abd Sa’id al-Khudri reported on the authority of his father that the Messenger of Allah (may peace be upon him) said: Bathing on Friday for every adult, using of Miswak and applying some perfume, that is available-these are essential. So far as the perfume is concerned, it may be that used by a lady.

Book 4, Number 1842:

    Tawus reported that Ibn Abbas narrated the words of the Apostle of Allah (may peace be upon him) about taking bath on Friday. Tawus said: I asked Ibn Abbas it one should apply to oneself perfume or oil which is available with his wife. He (Ibn Abbas) said: I do not know of it.

Book 4, Number 1843:

    This hadith has been narrated by Ibn Juraij with the came chain of transmitters.

Book 4, Number 1844:

    Abu Huraira reported that the Apostle of Allah (may peace be upon him) said. it is the right of Allah upon every Muslim that he should take a bath (at least) on one day (Friday) during the seven days (of the week) and he should wash his head and body .

Book 4, Number 1845:

    Abu Huraira reported that the Messenger of, Allah (may peace be upon him) said. He who takes a bath on Friday, the bath which is obligatory after the sexual discharge and then goes (to the mosque), he is like one who offers a she-camel as a sacrifice, and he who comes at the second hour would be like one who offers a cow, and he who comes at the third hour is live one who offers a ram with horns, and he who comes at the fourth hour is like one who offers a hen, and he who comes at the fifth hour is like one who offers an egg. And when the Imam comes out, the angels are also present and listen to the mention of God (the sermon).

Chapter 149 : OBSERVANCE OF SILENCE IN SERMON ON FRIDAY

Book 4, Number 1846:

    Abu Huraira reported Allah's Messenger (may peace be upon him) as saying: If you (even) ask your companion to be quiet on Friday while the Imam is delivering the sermon, you have in fact talked irrelevance.

Book 4, Number 1847:

    A hadith like this has been narrated by Abu Huraira by another chain of transmitters.

Book 4, Number 1848:

    The same hadith has been narrated by Abu Huraira, but instead of the word laghauta the word laghita has been used. Abu Zinad (one of the narrators) says that laghita is the dialect of Abu Huraira, whereas it is laghauta.

Chapter 150 : THERE IS A SPECIAL (FORTUNATE) TIME ON FRIDAY

Book 4, Number 1849:

    Abu Huraira reported Allah's Messenger (may peace be upon him) as saying: There is a time on Friday at which no Muslim servant would pray and would ask Allah for a thing (that is good) but He would give it to him. Qutaiba pointed with the help of his hand that it (the time) is short.

Book 4, Number 1850:

    Abu Huraira reported Abu'l-Qasim (the kunya of the Holy Prophet) (may peace be upon him) as saying: There is a time on Friday at which no Muslim would stand and pray and beg Allah for what Is good but He would give it to him; and he pointed with his hand that (this time) is short and narrow.

Book 4, Number 1851:

    A hadith like this has been narrated by Abu Huraira.

Book 4, Number 1852:

    This hadith has been narrated by Abu Huraira by another chain of transmitters.

Book 4, Number 1853:

    Abu Huraira reported Allah's Apostle (way peace be upon him) as saying. There is a time on Friday at which no Muslim would ask Allah for what is good but He would give it to him. And further said: This is a very short time.

Book 4, Number 1854:

    Hammam b. Munabbih reported this hadith from Abu Huraira who reported from the Apostle of Allah (may peace be upon him) but he did not say: "That time is short."

Book 4, Number 1855:

    Abu Burda b. Abu Musa al-Ash’ari reported: 'Abdullah b. Umar said to me: Did you hear anything from your father narrating something from the messenger of Allah (may peace be upon him) about the time on Friday? I said: Yes, I heard him say from the Messenger of Allah (may peace be upon him) (these words): "It is between the time when the Imam sits down and the end of the prayer."

Continue to next page: Click here


BOOK 4: The Book of Prayers (Kitab Al-Salat)(Part IV)

KITAB AL-SALAT
(THE BOOK OF PRAYERS)
--Continued--

Back
Chapter 151 : EXCELLENCE OF FRIDAY

Book 4, Number 1856:

    Abu Huraira reported Allah's Messenger (may peace be upon him) as saying: The best day on which the sun has risen is Friday; on it Adam was created, on it he was made to enter Paradise, on it he. was expelled from it.

Book 4, Number 1857:

    Abu Huraira reported the Apostle of Allah (may peace be upon him) as saying: The best day on which the sun has risen is Friday; on it Adam was created. on it he was made to enter Paradise, on it he was expelled from it. And the last hour will take place on no day other than Friday.

Book 4, Number 1858:

    Abu Huraira reported Allah's Messenger (may peace be upon him) as saying: We who are the last shall be the first on the Day of Resurrection, except that every Ummah was given the Book before us and we were given it after them. It was this day which Allah prescribed for us and guided us to it and the people came after us with regard to it, the Jews observing the next day and the Christians the day following that.

Book 4, Number 1859:

    A hadith like this has been narrated by Abu Huraira that the Messenger of Allah (way peace be upon him) said: We are the last and would be the first on the Day of Resurrection.

Book 4, Number 1860:

    Abu Huraira reported Allah's Messenger (may peace be upon him) as saying: We are the last (but) we would be the first on the Day of Resurrection, and we would be the first to enter Paradise, but that they were given the Book before us and we were given after them. They disagreed and Allah guided us aright on whatever they disagreed regarding the truth. And it was this day of theirs about which they disagreed, but Allah guided us to it, and that is Friday for us; the next day is for the Jews and the day following for the Christians.

Book 4, Number 1861:

    Abu Huraira reported Muhammad, the Messenger of Allah (may peace be upon him), as saying: We who are the last would be the first on the Day of Resurrection but they (other Ummahs) were given the Book before us and we were given after them, and this was the day that was prescribed for them but they disagreed on it. And Allah guided us to it. and they came after us with regard to it, the Jews observing the next day and the Christians the day following that.

Book 4, Number 1862:

    It is narrated by Abu Huraira and Huraira that the Messenger of Allah (may peace be upon him) said: It was Friday from which Allah diverted those who were before us. For the Jews (the day set aside for prayer) was Sabt (Saturday), and for the Christians it was Sunday. And Allah turned towards us and guided us to Friday (as the day of prayer) for us. In fact, He (Allah) made Friday, Saturday and Sunday (as days of prayer). In this order would they (Jews and Christians) come after us on the Day of Resurrection. We are the last of (the Ummahs) among the people in this world and the first among the created to be judged on the Day of Resurrection. In one narration it is: ',to be judged among them".

Book 4, Number 1863:

    Huraira reported Allah's Messenger (may peace be upon him) as saying: We were guided aright to Friday (as a day of prayer and meditation), but Allah diverted those who were before us from it. The rest of the hadith is the same.

Chapter 152 : EXCELLENCE OF GOING OUT EARLY ON FRIDAY

Book 4, Number 1864:

    Abu Huraira reported Allah's Messenger (may peace be upon him) as saying: When it is Friday, the angels stand at every door of the mosque and record the people in the order of their arrival, and when the Imam sits (on the pulpit for delivering the sermon) they fold up their sheets (manuscripts of the Qur’an) and listen to the mention (of Allah). And he who comes early is like one who offers a she-camel as a sacrifice, the next like one who offers a cow, the next a ram, the next a hen, the next an egg.

Book 4, Number 1865:

    This hadith has been narrated by Abu Huratra through another chain of transmitters.

Book 4, Number 1866:

    Abu Huraira reported Allah Messenger (way peace be upon him) as saying: There is an angel on every door of the mosque recording him first who (conies) first (a the mosque for Friday prayer). And he [the Prophet] likened him as one who offers a camel as a sacrifice and then he went on in the descending order till he reached the point at which the minimum (sacrifice) is that of an egg. And when the Imam sits (on the pulpit) the sheets are folded and they (the angels) attend to the mention of Allah.

Chapter 153 : EXCELLENCE OF ONE WHO LISTENS TO THE KHUTBA (SERMON) WITH PERFECT SILENCE

Book 4, Number :

    Abu-Huraira reported Allah's Apostle (may peace be upon him) as saying: He who took a bath and then came for Jumu’a prayer and then prayed what was fixed for him, then kept silence till the Imam finished the sermon, and then prayed along with him, his sins between that time and the next Friday would be forgiven, and even of three days wore.

Book 4, Number 1868:

    Abu Huraira reported Allah’s Messenger (may peace be upon him) as saying: He who performed ablution well, then came to Friday prayer, listened (to the sermon), kept silence all (his sins) between that time and the next Friday would be forgiven with three days extra, and he who touched pebbles caused an interruption.

Chapter 154 : JUMU'A PRAYER IS TO BE OBSERVED WHEN THE SUN PASSES OVER THE MERIDIAN

Book 4, Number 1869:

    Jabir b. 'Abdullah reported: We used to observe (Jumu’a) prayer with the Messenger of Allah (may peace be upon him) and then we returned and gave rest to our camels used for carrying water. Hassan[ (one of the narrators) said: I asked Ja'far what time that was. He said.. It is the time when the sun passes the meridian.

Book 4, Number 1870:

    Ja’far reported on the authority of his father that he asked Jabir b. 'Abdullah when the Messenger of Allah (may peace be upon him) observed Jumu’a prayer. Re said: He used to observe prayer, and we then went (back) to our camels and gave them rest. 'Abdullah made this addition in his narration: "Till the sun passed the meridian. and the camels used for carrying water (took rest)."

Book 4, Number 1871:

    Sahl b. Said said: We did not have a siesta or lunch till after the Friday prayer. (Ibn Hujr added:) "Daring the lifetime of the Messenger of Allah (may peace be upon him)."

Book 4, Number 1872:

    Iyas b. Salama b. al-Akwa’ reported on the authority of his father: We used to observe the Friday prayer with the Messenger of Allah (may peace be upon him) when the sun passed the meridian. and we then returned and tried to find out afternoon shadow (of the walls for protecting themselves from the heat of the sun).

Book 4, Number 1873:

    Iyas b. Salama b. Akwa' reported on the authority of his father, saying: We used to observe the Friday prayer with the Messenger of Allah (may peace be upon him), and when we returned we did not find the shadow of the walls in which we could take protection (from the heat of the sun).

Chapter 155 : CONCERNING THE TWO SERMONS BEFORE THE FRIDAY PRAYER AND SITTING FOR A WHILE BETWEEN THE TWO

Book 4, Number 1874:

    Ibn 'Umar said that the Messenger of Allah (may peace be upon him) used to deliver the sermon on Friday while standing. He would then sit and then stand (for the second sermon) as they (the Muslims) do nowadays.

Book 4, Number 1875:

    Jabir b. Samura said: The Apostle of Allah (may peace be upon him) gave two sermons between which he sat, recited the Qur'an and exhorted the people.

Book 4, Number 1876:

    Jabir b. Samura said that the Messenger of Allah (may peace be upon him) used to deliver the sermon while standing. He would then sit down and then stand up and address in a standing posture; and whoever informed you that he (the Holy Prophet) delivered the sermon while sitting told a lie. By Allah. I prayed with him more than two thousand times.

Chapter 156 : CONCERNING THE WORDS OF THE QUR'AN: "AND WHEN THEY SEE MERCHANDISE OR SPORT, THEY BREAK AWAY T0 IT, AND LEAVE THEE STANDING" (lxii. 11)

Book 4, Number 1877:

    Jabir b. Abdullah reported that the Apostle (may peace be upon him) was delivering the sermon on Friday in a standing posture when a caravan from Syria arrived. The people flocked towards it till no one was left (with the Holy Prophet) but twelve persons, and it was on this occasion that this verse in regard to Jumu’a was revealed. "And when they see merchandise or sport. they break away to it and leave thee standing."

Book 4, Number 1878:

    This hadith has been narrated by Husain with the same chain of transmitters but with this alteration that he did not make mention of the standing position.

Book 4, Number 1879:

    Jabir b. Abdullah reported: I was along with the Apostle of Allah (may peace be upon him) on Friday when a caravan arrived. The people went to it, and none but twelve persons were left behind and I was one of them; and it was on this occasion that this verse was revealed: "And when they see merchandise or sport away to it, and leave thee standing" (lxii. 1 1). they break

Book 4, Number 1880:

    Jabir b. Abdullah reported: While the Apostle of Allah (may peace be upon him) was delivering (a sermon) on Friday, a caravan of merchandise came to Medina. The Companions of the Messenger of Allah (may peace be upon him) rushed towards it till only twelve persons were left with him including Abu Bakr and 'Umar; and it was at this occasion that this verse was revealed. "And when they see merchandise or sport, they break away to it."

Book 4, Number 1881:

    Ka’b b. 'Ujra reported that he entered the mosque and saw Abd al-Rahman b. Umm Hakam delivering the sermon in a sitting posture. Upon this he said: Look at this wretched person; he delivers the sermon while sitting, whereas Allah said: "And when they see merchandise or sport, they break away to it and leave thee standing."

Chapter 157 : WARNING ON NEGLECTING JUMU'A

Book 4, Number 1882:

    Abdullah b. Umar and Abu Huraira said that they heard Allah’s Messenger (way peace be upon him) say on the planks of his pulpit: People most cease to neglect the Friday prayer or Allah will seal their hearts and then they will be among the negligent.

Chapter 158 : SHORTNESS OF PRAYER AND SERMON

Book 4, Number 1883:

    Jabir b. Samura reported: I used to pray with the Messenger of Allah (may peace be upon him) and both his prayer and sermon were of moderate length.

Book 4, Number 1884:

    Jabir b. Samura reported: I used to observe prayer with the Apostle of Allah (may peace be upon him) and his prayer was of moderate length and his sermon too was of moderate length.

Book 4, Number 1885:

    Jabir b. Abdullah said: When Allah's Messenger (may peace he upon him) delivered the sermon, his eyes became red, his voice rose. and his anger increased so that he was like one giving a warning against the enemy and saying: "The enemy has made a morning attack on you and in the evening too." He would also say: "The last Hour and I have been sent like these two." and he would join his forefinger and middle finger; and would further say: "The best of the speech is embodied in the Book of Allah, and the beet of the guidance is the guidance given by Muhammad. And the most evil affairs are their innovations; and every innovation is error." He would further say: ,I am more dear to a Muslim even than his self; and he who left behind property that is for his family. and he who dies under debt or leaves children (in helplessness). the responsibility (of paying his debt and bringing up his children) lies on me."

Book 4, Number 1886:

    Ja’far b. Muhammad said on the authority of his father: I heard Jabir b. 'Abdullah saying that in the sermon of the Apostle of Allah (may peace be upon him) he praised Allah, lauded Him (and subsequently said [other words] and raised his voice, and the rest of the hadith is the same).

Book 4, Number 1887:

    Jabir reported that the Messenger of Allah (may peace be upon him), while delivering the sermon' to the people, praised Allah, and lauded Him for what He deserves, and would then say: He whom Allah guides aright, there is none to mislead him, and he who is led astray, there is none to guide him (aright), and the best of the talk is embodied in the Book of Allah. And the rest of the hadith is the same.

Book 4, Number 1888:

    Ibn 'Abbas reported: Dimad came to Mecca and he belonged to the tribe of Azd Shanu'a, and he used to protect the person who was under the influence of charm. He heard the foolish people of Mecca say that Muhammad (may peace be upon him) was under the spell. Upon this he said: If 1 were to come across this man, Allah might cure him at my hand. He met him and said: Muhammad, I can protect (one) who is under the influence of charm, and Allah cures one whom He so desires at my hand. Do you desire (this)? Upon this the Messenger of Allah (may peace be upon him) said: Praise is due to Allah, we praise Him, ask His help; and he whom Allah guides aright there is none to lead him astray, and he who is led astray there is none to guide him, and I bear testimony to the fact that there is no god but Allah, He is One, having no partner with Him, and that Muhammad is His Servant and Messenger. Now after this he (Dimad) said: Repeat these words of yours before me, and the messenger of Allah (may peace be upon him) repeated these to him thrice; and he said I have heard the words of soothsayers and the words of magicians, and the words of poets, but I have never heard such words as yours, and they reach the depth (of the ocean of eloquence); bring forth your hand so that I should take oath of fealty to you on Islam. So he took an oath of allegiance to him. The Messenger of Allah (may peace be upon him) said: It (this allegiance of yours) is on behalf of your people too. He said: It is on behalf of my people too. The Messenger of Allah (may peace be upon him) sent an expedition and the flying column passed by his people. The leader of the flying column said to the detachment: Did you find anything from these people? One of the people said: I found a utensil for water. Upon this he (the commander) said: Return it, for he is one of the people of Dimad.

Book 4, Number 1889:

    Abu Wa'il reported: 'Ammar delivered to us the sermon. It was short and eloquent. When he (,Ammir) descended (from the pulpit) we said to him: 0 Abd al-Yaqzn, you have delivered a short and eloquent sermon. Would that you had lengthened (the sermon). He said: I have heard the Messenger of Allah (may peace be upon him) as saying: The lengthening of prayer by a man and the shortness of the sermon is the sign of his understanding (of faith). So lengthen the prayer and shorten the sermon, for there is charm (in precise) expression.

Book 4, Number 1890:

    ‘Adi b. Hatim reported that a person recited a sermon before the Apostle of Allah (may peace be upon him) thus: He who obeys Allay and His Apostle, he in fact follows the right path, and he who disobeys both of them, he goes astray. Upon this the Messenger of Allah (may peace be upon him) said: What a bad speaker you are; say: He who disobeys Allah and His Apostle. Ibn Numair added: He in fact went astray.

Book 4, Number 1891:

    Safwan b. Ya'la reported on the authority of his father that he heard the Apostle of Allah (may peace be upon him) reciting (verses of the Qur'an) on the pulpit. and "They cried: 0 Malik."

Book 4, Number 1892:

    'Amra daughter of Abd al-Rahman reported on the authority of the sister of Amra, I memorised (surah) Qaf=surah l.): "By the glorious Qur’an" from the mouth of the Messenger of Allah (may peace be upon him) on Friday for he recited it on the pulpit on-every Friday.

Book 4, Number 1893:

    The daughter of Haritha b. Nu'man said: I did not memorise (Surah) Qaf but from the mouth of the Messenger of Allah (may peace be upon him) as he used to deliver the. sermon along with it on every Friday. She also added: Our oven and that of the Messenger of Allah (may peace be upon him) was one.

Book 4, Number 1894:

    Umm Bisham hint Haritha b. Nu'man said: Our oven and that of the Messenger of Allah (may peace be upon him) was one for two years, or for one year or for a part of a year; and I learnt "Qaf. By the Glorious Qur’an" from no other source than the tongue of Allah's Messenger (may peace be upon him) who used to recite it every Friday on the pulpit when he delivered the sermon to the people.

Book 4, Number 1895:

    Umara b. Ruwaiba said he saw Bishr b. Marwan on the pulpit raising his hands and said: Allah, disfigure these hands! I have seen Allah's Messenger (may peace be upon him) gesture no more than this with his hands, and he pointed with his forefinger.

Book 4, Number 1896:

    This hadith has been narrated by another chain of transmitters on the authority of Husain b. Abd al-Rahman.

Chapter 159 : OBSERVING OF TWO RAKIAHS AS A SALUTATION OF THE MOSQUE WHILE THE IMAM IS DELIVERING (THE SERMON)

Book 4, Number 1897:

    Jabir b. 'Abdullah reported that while Allah's Messenger (may peace be upon him) was delivering the sermon on Friday a person came there, and the Apostle of Allah (may peace be upon him) said to him: So and so, have you prayed (two rak’ahs)? He said: No. He (the Holy Prophet) said: Then stand and pray.

Book 4, Number 1898:

    This hadith is narrated by Jabir through another chain of transmitters but Hammad (one of the narrators) made no mention of the two rak'ahs.

Book 4, Number 1899:

    Jabir b. 'Abdullah said that a person entered the Mosque while the Messenger of Allah (may peace be upon him) was delivering the sermon on Friday. Upon this he (the Holy Prophet) said: Have you observed prayer? He said: No. He (the Holy Prophet) said: Stand and offer the two rak'ahs. According to Qutaiba, the words are: "He said: Offer two rak'ahs."

Book 4, Number 1900:

    Jabir b. 'Abdullah reported that a person came (in the Mosque) while the Apostle of Allah (may peace be upon him) was delivering the sermon on Friday (standing) on the pulpit. He (the Holy Prophet) said to him: Have you offered two rak'ahs? He said: No. Upon this he said: Then observe (them).

Book 4, Number 1901:

    Jabir b. 'Abdullah said that the Apostle of Allah (may peace be upon him) delivered the sermon and said: When any one of you comes for the Friday (prayer) and the Imam comes out (from his apartment), (even then) should observe two rak'ahs (of prayer).

Book 4, Number 1902:

    Jabir reported that Sulaik Ghatafani came on Friday (for prayer) while the Messenger of Allah (may peace be upon him) was sitting on the pulpit. Sulaik also sat down before observing prayer. The Apostle of Allah (may peace be upon him) said: Have you observed two rak'ahs? He said: No. He (the Holy Prophet) said: Stand and observe them

Book 4, Number 1903:

    Jabir b. 'Abdullah reported: Sulaik Ghatafani came on Friday when the Messenger of Allah (may peace be upon him) was delivering the sermon. He (Sulaik) sat down. He (the Holy Prophet) said to him: 0 Sulaik I stand and observe two rak'ahs and make them short, and then said: When any one of you comes on Friday, while the Imam delivers the sermon, he should observe two rak'ahs and should make them short.

Chapter 160 : HADITH PERTAINING TO GIVING INSTRUCTION IN KHUTBA

Book 4, Number 1904:

    Abu Rifa’a reported: I came to the Holy Prophet (way peace be upon him) when he was delivering the sermon, and I said: Messenger of Allah, here is a stranger and he wants to learn about this religion and he does not know what this religion is. The Messenger of Allah (may peace be upon him) looked at me and left his sermon till he came to me, and he was given a chair and I thought that Its legs were made of iron. The Messenger of Allah (may peace be upon him) sat In it and he began to teach me what Allah had taught him. He then came (to the pulpit) for his sermon and completed it to the end.

Chapter 161 : WHAT IS TO BE RECITED IN THE JUMUIA PRAYER?

Book 4, Number 1905:

    Ibn Abu Rafi’ said: Marwan appointed Abu Huraira as his deputy in Medina and he himself left t for Mecca. Abu Huraira led as in the Jumu’a prayer and recited after Surah Jumu’a in the second rak’ah: "When the hypocrites came to thee" (Surah lxiii.). I then met Abu Huraira as he came back and said to him: You have recited two surahs which 'Ali b. Abu Talib used to recite in Kufah. Upon this Abu Huraira said: I heard the Messenger of Allah (may peace: be upon him) 'reciting these two in the Friday (prayer).

Book 4, Number 1906:

    This hadith is narrated by Abdullah b. Abu Rafi’ with the same chain of transmitters but with this modification: "That he recited Surah Jumu’a (lxii.) in the first rak’ah and "The hypocrites came" in the second rak'ah.

Book 4, Number 1907:

    Nu’man b. Bashir reported that the Messenger of Allah (may peace be upon him) used to recite on two 'Ids and in Friday prayer: "Glorify The name of Thy Lord, the Most High" (Surah lxxxvii.), and: "Has there come to thee the news of the overwhelming event" (lxxxviii.). And when the ‘Id and Jumu’a combined on a day he recited these two (surah) in both the prayers.

Book 4, Number 1908:

    This hadith has been narrated by Ibrahim b Muhammad b. al-Muntashir with the same chain of transmitters.

Book 4, Number 1909:

    Dahhak b. Qais wrote to Nu’man b. Bashir asking him what the Messenger of Allah (may peace be upon him) recited on Friday besides Surah Jumu’a He said that he recited: "Has there reached . . . " (Surah lxxxviii,).

Book 4, Number 1910:

    Ibn Abbas reported: The Apostle of Allah (way peace be upon him) used to recite in the morning prayer on Friday Surah "Alif-Lam-Mim, Tanz'il ul-Sajda"(Surah xxxii.): Surely there came over the man a time" (Surah lxxvii) and he used to recite in Jumu’a prayer Surahs Jumu’a and al-Munafiqin.

Book 4, Number 1911:

    A hadith like this has been narrated by Sufyan with the same chain of transmitters.

Book 4, Number 1912:

    Mukhawwil has narrated this hadith on the authority of Sufyan.

Book 4, Number 1913:

    Abu Huraira reported that the Apostle of Allah (may peace be upon him) used to recite in the dawn prayer on Friday "Alif-Lam-Mim, Tanzil" and "Surely there came."

Book 4, Number 1914:

    Abu Huraira reported that the Apostle of Allah (may peace be upon him) used to recite in the dawn prayer on Friday: "Alif-Lam-Mim, Tanzil" in the first rak'ah, and in the second one: "Surely there came over the man a time when he was nothing that could be mentioned."

Chapter 162 : PRAYER (SUNAN) AFTER THE JUMU'A PRAYER (FARD)

Book 4, Number 1915:

    Abu Huraira reported Allah's Messenger (may peace be upon him) as saying: When any one of you observes the Jumu'a prayer (two obligatory rak'ahs in congregation), he should observe four (rak'ahs) afterwards.

Book 4, Number 1916:

    Suhail reported on the authority of Abu Huraira that the Messenger of Allah (may peace be upon him) said: When you observe prayer after (the two obligatory raklabs) of Jumu'a, you should observe four rak'ahs (and 'Amr in his narration has made this addition that Ibn Idris said this on the authority of Suhail): And if you are in a hurry on account of something, you should observe two rak'ahs in the mosque and two when you return (to your house).

Book 4, Number 1917:

    Abu Huraira reported Allah's Messenger (may peace be upon him) as saying: When any one amongst you observes prayer after Jumu'a, he should observe four rak'ahs. (In the hadith transmitted by Jarir the word minkum is not recorded.)

Book 4, Number 1918:

    Nafi' reported that when 'Abdullah (b. 'Umar) observed the Friday prayer and came back he observed two rak'ahs in his house, and then said: The Messenger of Allah (may peace be updn him) used to do this.

Book 4, Number 1919:

    'Abdullah b. 'Umar, while describing the Nafl prayer of the Messenger of Allah (may peace be upon him), said: He did not observe (Nafl) prayer after Jumu'a till he went back and observed two rak'ahs in his house. Yahya said: I guess that I uttered these words (before Imam Malik) that he of course observed (them).

Book 4, Number 1920:

    Salim narrated on the authority of his father that the Apostle of Allah (may peace be upon him) used to observe two rak'ahs after Jumu'a.

Book 4, Number 1921:

    'Umar b. 'Ata' b. Abu Khuwar said that Nafi' b. Jubair sent him to al- Sa'ib the son of Namir's sister with a view to asking him about what he had seen in the prayer of Mu'awiya. He said: Yes, I observed the Jumu'a prayer along with him in Maqsura and when the Imam pronounced salutation I stood up at my place and observed (Sunan rak'ahs). As he entered (the apartment) he sent for me and said: Do not repeat what you have done. Whenever you have observed the Jumu'a prayer, do not observe (Sunan prayer) till you, have talked or got out For the Messenger of Allah (may peace be upon him) had ordered us to do this and not to combine two (types of) prayers without talking of going out.

Book 4, Number 1922:

    The same hadith is narrated on the authority of 'Umar b. Ata' but with this modification: When he (the Imam) pronounced salutation I stood up at my place. No mention was made of the Imam in it.

Chapter 163 : THE PRAYER OF THE TWO 'IDS

Book 4, Number 1923:

    Ibn 'Abbas reported: I participated in the Fitr prayer with the Apostle of Allah (may peace be upon him) and Abu Bakr, 'Umar and 'Uthman, and all of them observed this prayer before the Khutba, and then he (the Holy Prophet) delivered the sermon. Then the Apostle of Allah (may peace be upon him) descended (from the pulpit) and I (perceive) as if I am seeing him as he is commanding people with his hand to sit down. He then made his way through their (assembly) till he came to the women. Bilal was with him. He then recited (this verse): O Prophet, when believing women come to thee giving thee a pledge that they will not associate aught with Allah" (lx. 12) till he finished (his address to) them and then said: Do you conform to it (what has been described in the verse)? Only one woman among them replied: Yes, Apostle of Allah, but none else replied. He (the narrator) said: It could not be ascertained who actually she was. He (the Holy Prophet) exhorted them to give alms. Bilal stretched his cloth and then said: Come forward with alms. Let my father and mother be taken as ransom for you. And they began to throw rings and ringlets in the cloth of Bilal.

Book 4, Number 1924:

    Ibn 'Abbas reported: I bear testimony to the Messenger of Allah (may peace be upon him) offering prayer before Kbutba. He (after saying prayer) delivered the Kutba, and he found that the women could not hear it, so he came to them and exhorted them and preached them and commanded them to give alms, and Bilal had stretched his cloth and the women were throwing rings, earrings and other things. This hadith has been narrated on the authority of Ayyub with the same chain of transmitters.

Book 4, Number 1925:

    Jabir b. 'Abdullah reported: The Apostle of Allah (may peace be upon him) stood up on the day of 'Id al-Fitr and observed prayer. And he commenced the prayer before the sermon. He then delivered the sermon. When the Apostle of Allah (may peace be upon him) had finished (the sermon) he came down from (the pulpit), and made his way to the women and exhorted them (to do good acts), and he was leaning on the hand of Bilal. Bilal had stretched his cloth in which women were throwing alms. I (one of the narrators) said to 'Ata' (the other narrator) : It must be Zakat on the day of Fitr. He ('Ata') said: No. It was alms (which) they were giving on that occasion, and a woman gave her ring, and then others gave, and then others gave. I said to 'Ata': Is It right now for the Imam to come to the women when he has finished (his address to the men) that he should exhort them (to good deeds)? He said: (Why not) by my life, it is right for them (to do so). What is the matter with them that they do not do it now ?

Book 4, Number 1926:

    Jabir b. 'Abdullah reported: I observed prayer with the Messenger of Allah (may peace be upon him) on the 'Id day. He commenced with prayer before the sermon without Adhan and Iqama. He then stood up leaning on Bilal, and he commanded (them) to be on guard (against evil for the sake of) Allah, and he exhorted (them) on obedience to Him, and he preached to the people and admonished them. He then walked on till he came to the women and preached to them and admonished them, and asked them to give alms, for most of them are the fuel for Hell. A woman having a dark spot on the cheek stood up and said: Why is it so, Messenger of Allah? He said: For you grumble often and show ingratitude to your spouse. And then they began to give alms out of their ornaments such as their earrings and rings which they threw on to the cloth of Bilal.

Book 4, Number 1927:

    Ibn 'Abbas and Jaibir b. 'Abdullah al-Ansari reported: There was no Adhan on the (occasion) of Id-ul-Fitr and Id-ul-Adha. I (Ibn Juraij) said: I asked him after some time about it. He ('Ata', one of the narrators) said: Jabir b. 'Abdullah al-Ansari told me: There is neither any Adhan on Id-ul-Fitr when the Imam comes out, nor even after his coming out; their is neither lqama nor call nor anything of the sort of calling on that day and nor Iqama.

Book 4, Number 1928:

    'Ata' reported that Ibn 'Abbas sent (him) to Ibn Zubair at the commencement of the oath of allegiance to him (for Caliphate saying): As there is no Adhan on 'Id-ul-Fitr, so you should not pronounce it. Ibn Zubair did not pronounce Adhan on that day. He (Ibn 'Abbas) also sent him (with this message) that sermon (is to be delivered) after the prayer, and thus it was done. So lbn Zubair observed prayer before Khutba.

Book 4, Number 1929:

    Jabir b. Samura said: I prayed with the Messenger of Allah (may peace be upon him) prayers on two I'ds wore than once or twice without there being Adhan and Iqama.

Book 4, Number 1930:

    Ibn 'Umar reported that the Apostle of Allah (may peace be upon him), Abu Bakr and 'Umar used to observe the two 'Id prayers before the sermon.

Book 4, Number 1931:

    Abu Sa'id al-Khudri reported that the Messenger of Allah (may peace be upon him) used to go out on the day of Adha and on the day of Fitr and commenced the prayer. And after having observed his prayer and pronounced the salutation, he stood up facing people as they were seated at their places of worship. And if he intended to send out an army he made mention of it to the people, and if he intended any other thing besides it, he commanded them (to do that). He used to say (to the people): Give alms, give alms, give alms, and the majority that gave alms was of women. He then returned and this (practice) remained (in vogue) till Marwan b. al- Hakam (came into power). I went out hand in hand with Marwan till we came to the place of worship and there Kathir b. Salt had built a pulpit of clay and brick. Marwan began to tug me with his hand as though he were pulling me towards the pulpit, while I was pulling him towards the prayer. When I saw him doing that I said: What has happened to the practice of beginning with prayer? He said: No, Abu Sa'id, what you are familiar with has been abandoned. I thereupon said (three times and went back): By no means, by Him in Whose hand my life is, you are not doing anything better than what I am familiar with.

Chapter 164 : PERMISSIBILITY OF WOMEN'S GOING OUT ON 'ID DAYS TOWARDS THE PLACE OF WORSHIP AND THEIR PRESENCE IN THE KHUTBA (SITTING) AT A DISTANCE FROM MEN

Book 4, Number 1932:

    Umm 'Atiyya said: He (the Apostle of Allah) commanded us that we should take out unmarried women and purdah-observing ladies for 'Id prayers, and he commanded the menstruating women to remain away from the place of worship of the Muslims.

Book 4, Number 1933:

    Umm Atiyya reported: We were commanded to bring out on old days purdah-observing ladies and those unmarried, and menstruating women came out but remained behind people and pronounced takbir (Allah-o-Akbar) along with them.

Book 4, Number 1934:

    Umm 'Atiyya reported: The Messenger of Allah (may peace be upon him) commanded us to bring out on'Id-ul-Fitr and 'Id-ul-Adha young women, menstruating women and purdah-observing ladies, menstruating women kept back from prayer, but participated in goodness and supplication of the Muslims. I said: Messenger of Allah, one of us does not have an outer garment (to cover her face and body). He said: Let her sister cover her with her outer garment.

Chapter 165 : ABANDONING OF PRAYER BEFORE 'ID AND AFTER IT IN THE PLACE OF WORSHIP (OURSIDE THE HABITATION) ESPECIALLY MEANT FOR 'ID

Book 4, Number 1935:

    Ibn 'Abbas reported that the Messenger of Allah (may peace be upon him) went out on the day of Adha or Fitr and observed two rak'ahs, and did not observe prayer (at that place) before and after that. He then came to the women along with Bilal and commanded them to give alms and the women began to give their rings and necklaces.
    This hadith has been narrated on the authority of Shu'ba with the same chain of transmitters.

Chapter 166 : WHAT IS TO BE RECITED IN 'ID PRAYERS

Book 4, Number 1936:

    'Abdullah b. 'Umar reported that (his father) 'Umar b. Khattab asked Abu Waqid al-Laithi what the Messenger of Allah (may peace be upon him) used to recite on 'Id-ul-Adha and 'Id-ul-Fitr. He said: He used to recite in them: "Qaf. By the Glorious Qur'an" (Surah 1), "The Hour drew near, and the moon was rent asunder" (Surah liv.).

Book 4, Number 1937:

    'Utba reported that his father Waqid al-Laithi said: 'Umar b. Khattab asked me what the Messenger of Allah (may peace be upon him) recited on 'Id day. I said: "The Hour drew near" and Qaf. By the Glorious Qur'an".

Chapter 167 : PERMISSION FOR INNOCENT SPORT ON 'ID DAYS

Book 4, Number 1938:

    'A'isha reported: Abu Bakr came to see me and I had two girls with me from among the girls of the Ansar and they were singing what the Ansar recited to one another at the Battle of Bu'ath. They were not, however, singing girls. Upon this Abu Bakr said: What I (the playing of) this wind instrument of Satan in the house of the Messenger of Allah (may peace be upon him) and this too on 'Id day? Upon this the Messenger of Allah (may peace be upon him) said : Abu Bakr, every people have a festival and it is our festival (so let them play on).

Book 4, Number 1939:

    This hadith has been narrated by Hisham with the same chain of transmitters, but there the words are: "Two girls were playing upon a tambourine."

Book 4, Number 1940:

    'A'isha reported that Abu Bakr came to her and there were with her two girls on Adha days who were singing and beating the tambourine and the Messenger of Allah (may peace be upon him) had wrapped himself with his mantle. Abu Bakr scolded them. The Messenger of Allah (may peace he upon him) uncovered (his face) and said: Abu Bakr, leave them alone for these are the days of 'Id. And 'A'isha said: I recapitulate to my mind the fact that once the Messenger of Allah (may peace be upon him) screened me with his mantle and I saw the sports of the Abyssinians, and I was only a girl, and so you can well imagine how a girl of tender age is fond of watching the sport.

Book 4, Number 1941:

    'A'isha reported: BY Allah, I remember the Messenger of Allah (may peace be upon him) standing on the door of my apartment screening me with his mantle enabling me to see the sport of the Abyssinians as they played with their daggers in the mosque of the Messenger of Allah (may peace be upom him). He (the Holy Prophet) kept standing for my sake till I was satiated and then I went back; and thus you can well imagine how long a girl tender of age who is fond of sports (could have watched it).

Book 4, Number 1942:

    'A'isha reported: The Messenger of Allah (way peace be upon him) came (in my apartment) while there were two girls with me singing the song of the Battle of Bu'ath. He lay down on the bed and turned away his face. Then came Abu Bakr and he scolded me and said: Oh ! this musical instrument of the devil in the house of the Messenger of Allah (may peace be upon him) ! The Messenger of Allah (may peace be upon him) turned towards him and said: Leave them alone. And when he (the Holy Prophet) became unattentive, I hinted them and they went out, and it was the day of 'Id and negroes were playing with shields and speare. (I do not remember) whether I asked the Messenger of Allah (may peace be upon him) or whether he said to me if I desired to see (that sport). I said: Yes. I stood behind him with his face parallel to my face, and he said: O Banu Arfada, be busy (in your sports) till I was satiated. He said (to me): Is that enough? I said: Yes. Upon this he asked me to go.

Book 4, Number 1943:

    'A'isha reported that some Abyssinians came and gave a demonstration of armed fight on the 'Id day in the mosque. The Apostle of Allah (may peace be upon him) invited me (to see that fight). I placed my head on his shoulder and began to see their sport till it was I who turned away from watching them.

Book 4, Number 1944:

    This hadith has been narrated by Hisham with the same chain of transmitters but (the narrators) did not make mention of the mosque.

Book 4, Number 1945:

    'A'isha said that she sent a message to the players (of this armed fight) saying: I like to see them (fighting). She further said: The Messenger of Allah (may peace be upon him) stood up and I stood at the door (behind him) and saw (this fight) between his ears and his shoulders they played in the mosque. 'Ata' (one of the narra- tors) said: Were they persians or Abyssinians? Ibn 'Atiq told me they were Abyssinians.

Book 4, Number 1946:

    Abu Huraira reported: While the Abyssinians were busy playing with their arms in the presence of the Messenger of Allah (may peace be upon him) 'Umar b. Khattab came there. He bent down to take up pebbles to throw at them (in order to make them go off). The Messenger of Allah (may peace be upon him) said to him: 'Umar, leave them alone.

Chapter 168 : PRAYER FOR RAIN

Book 4, Number 1947:

    'Abdullah b. Zaid b. Mazini reported: The Messenger of Allah (may peace be upon him) went to the place of prayer and prayed for rain and turned round his mantle while facing the Qibla.

Book 4, Number 1948:

    Ibn Tamim narrated on the authority of his uncle ('Abdullah b. Zaid) that the Apostle of Allah (may peace be upon him) went out to the place of prayer and prayed for rain and faced towards Qibla, and turned round his mantle and prayed two rak'ahs.

Book 4, Number 1949:

    'Abdullah b. Zaid al-Ansari reported that the Messenger of Allah (may peace be upon him) went out to the place of prayer in order to offer prayer for rainfall. And when he intended to make supplication he faced Qibla and turned round his mantle.

Book 4, Number 1950:

    'Abbad b. Tamim Mazini heard his uncle, who was one of the Companions of the Messenger of Allah (may peace be upon him), as saying: The Messenger of Allah (may peace be upon him) went out one day in order to pray for rain. He turned his back towards people, supplicated before Allah, facing towards Qibla, and turned his mantle round and then observed two rak'ahs of prayer.

Book 4, Number 1951:

    Anas reported: I saw the Messenger of Allah (may peace be upon him) raising his hands (high enough) in supplication (for rain) that the whiteness of his armpits became visible.

Book 4, Number 1952:

    Anas b. Malik reported that the Apostle of Allah (may peace be upon him) prayed for rain pointing the back of his hands to the sky.

Book 4, Number 1953:

    Anas reported that the Apostle of Allah (may peace be upon him) was not accustomed to raice his hands in any supplication he made except when praying for rain. (He would then raise [his hands] high enough) that the whiteness of his armpits became visible. 'Abd al-A'la said that (he was in doubt whether it was) the whiteness of his armpit or armpits.

Book 4, Number 1954:

    This hadith has been narrated by Anas b. Malik through another chain of transmitters.

Chapter 169 : SUPPLICATION IN PRAYER FOR RAIN

Book 4, Number 1955:

    Anas b. Malik reported that a person entered the mosque through the door situated on theside of Daral-Qada' during Friday (prayer) and the messenger of Allah (may peace be upon him) was delivering the sermon while standing. He came and stood in front of the Messenger of Allah (may peace be upon him) and said: Messenger of Allah, the camels died and the passages were blocked; so supplicate Allah to send down rain upon us. The Messenger of Allah (may peace be upon him) raised his hands and then said: (O Allah, send down rain upon us; O Allah, send dowp rain upon us; O Allah, send down rain upon us. Anas said: By Allah, we did not see any cloud or any patch of it, and there was neither any house or building standing between us and the (hillock) Sal'a. There appeared a cloud in the shape of a shield from behind it, and as it (came high) in the sky it spread and then there was a downpour of rain. By Allah, we did not see the sun throughout the week. Then (that very man) came on the coming Friday through the same door when the Messenger of Allah (may peace be upon him) was standing and delivering the sermon. He stood in front of him and said: Messenger of Allah, our animals died and the passages blocked. Supplicate Allah to stop the rain for us. The Messenger of Allah (may peace be upon him) again raised his hands and said: O Allah, let it (rain) fall in our suburbs and not on us, O Allah (send it down) on the hillocks and small mountains and the river-beds and at places where trees grow. The rain stopped, and as we stepped out we were walking in sun- shine. He (the narrator) said to Sharik: I asked Anas b. Malik if he was the same man. He said: I do not know.

Book 4, Number 1956:

    Anas b. Malik reported: The people were in the grip of famine during the lifetime of the Messenger of Allah (may peace be upon him), and (once) as the Messenger of Allah (may peace be upon him) was delivering the sermon standing on the pulpit on Friday, a bedouin stood up and said: Messenger of Allah, the animals died and the children suffered starvation. The rest of the hadith is the same (and the words are) that he (the Holy Prophet) said: O Allah, send down rain in our suburbs but not on us. He (the narrator) said: To whichever directions he pointed with his hands, the clouds broke up and I saw Medina like the opening of a (courtyard) and the stream of Qanat flowed for one month, and none came from any part (of Arabia) but with the news of heavy rainfall.

Book 4, Number 1957:

    Anas b. Malik reported that while the Apostle of Allah (may peace be upon him) was delivering the sermon on Friday, people stood up before him and said in a loud voice: Apostle of Allah, there is a drought and the trees have become yellow, the animals have died; and the rest of the hadith is the same, and in the narration transmitted by 'Abd al-A'la the words are: " The clouds cleard from Medina and it began to rain around it and not a single drop of rain fell in Medina. And as I looked towards Medina, I found it hollow like (the hollowness of) a basin.

Book 4, Number 1958:

    This hadith has been narrated on the authority of Anas but with this addition: "Allah gathered the clouds and as we (were obliged) to stay back I saw that even the strong man, impelled by a desire to go to his family, (could not do so)."

Book 4, Number 1959:

    'Ubaidullah b. Anas b. Malik heard (his father) Anas b. Malik as saying: A bedouin came to the Messenger of Allah (may peace be upon him) on Friday as he was (delivering the sermon on his) pulpit; and the rest of the hadith is the same but with this addition: "I saw the cloud clearing just as a sheet is folded."

Book 4, Number 1960:

    Anas (b. Malik) reported: It rained upon us as we were with the Messenger of Allah (may peace be upon him). The Messenger of Allah (way peace be upon him) removed his cloth (from a part of his body) till the rain fell on it. We said: Messenger of Allah, why did you do this? He said: It is because it (the rainfall) has just come from the Exalted Lord.

Chapter 170 : (PRAYER FOR) PROTECTION (OF ALLAH) WHEN THERE IS A WINDSTORM, OR (TERRIBLY DARK) CLOUD, AND FEELING OF JOY WHEN THERE IS A RAINFALL

Book 4, Number 1961:

    'Ata' b. Abi Rabah reported that he heard 'A'isha, the wife of the Apostle of Allah (way peace be upon him), as saying: When there was on any day windstorm or dark cloud (its effects) could be read on the face of the Messenger of Allah (may peace be upon him), and he moved forward and backward (in a state of anxiety); and when it rained, he was delighted and it (the state of restlessness) disappeared. 'A'isha said: I asked him the reason of this anxiety and he said : I was afraid that it might be a calamity that might fall upon my Ummah, and when he saw rainfall he said: It is the mercy (of Allah).

Book 4, Number 1962:

    'Ata' b. Rabah reported on the authority of 'A'isha, the wife of the Apostle of Allah (way peace be upon him), who said: Whenever the wind was stormy, the Apostle of Allah (may peace be upon him) used to say: O Allah ! I ask Thee for what is good in it, and the good which it contains, and the good of that which it was sent for. I seek refuge with Thee from what is evil in it, what evil it contains, and the evil of that what it was sent for; and when there was a thunder and lightning in the sky, his colour underwent a change, and he went out and in, backwards and forwards; and when the rain came, he felt relieved, and I noticed that (the sign of relief) on his face. 'A'isha asked him (about it) and he said: It may be as the people of 'Ad said: When they saw a cloud formation coming to their valley they said: "It is a cloud which would give us rain" (Qur'an, xlvi. 24).

Book 4, Number 1963:

    'A'isha, the wife of the Apostle of Allah (may peace be upon him), reported: I never saw Allah's Messenger (may peace be upon him) laugh to such an extent that I could see his uvula-whereas he used to smile only-and when he saw dark clouds or wind, (the signs of fear) were depicted on his face. I said: Messenger of Allah, I find people being happy when they ace the dark cloud in the hope that it would bring rain, but I find that when you see that (the cloud) there is an anxiety on your face. He said: 'A'isha, I am afraid that there may be a calamity in it, for a people was afflicted with wind, when the people saw the calamity they said: "It is a cloud which would give us rain" (Qur'an. xlvi. 24).

Book 4, Number 1964:

    Ibn 'Abbas reported Allah's Messenger (may peace be upon him) as saying: I have been helped by the east wind and the 'Ad were destroyed by the west wind.

Book 4, Number 1965:

    This hadith has been narrated on the authority of Ibn 'Abbas through another chain of transmitters.

Chapter 171 : PRAYER AT THE TIME OF SOLAR ECLIPSE

Book 4, Number 1966:

    'A'isha reported that there was a solar eclipse in the time of the Messenger of Allah (may peace be upon him). He stood up to pray and prolonged his stand very much. He then bowed and prolonged very much his bowing. He then raised his head and prolonged his stand much, but it was less than the (duration) of the first stand. He then bowed and prolonged bowing much, but it was less than the duration of his first bowing. He then prostrated and then stood up and prolonged the stand, but it was less than the first stand. He then bowed and prolonged his bowing, but it was less than the first bowing. He then lifted his head and then stood up and prolonged his stand, but it was less than the first stand. He then bowed and prolonged bowing and it was less than the first bowing. He then prostrated himself ; then he turned about, and the sun had become bright, and he addressed the people. He praised Allah and landed Him and said: The sun and the moon are two signs of Allah; they are not eclipsed on account of anyones death or on account of anyone's birth. So when you see them, glorify and supplicate Allah, observe prayer, give alms. O Ummah of Muhammad, none is more indignant than Allah When His servant or maid commits fornication. O people of Muhammad, by Allah, if you knew what I know, you would weep much and laugh little.

Book 4, Number 1967:

    This hadith has been narrated by Hisham b. 'Urwa with the same chain of transmitters but with this addition: "Verily the sun and the moon are among the signs of Allah." And similarly this addition was made: "He then lifted his hands and said: O Allah ! have I not conveyed it? "

Book 4, Number 1968:

    'A'isha, the wife of the Apostle of Allah (may peace be upon him), reported There was an eclipse of the sun during the lifetime of the Messenger of Allah (may peace be upon him). So, the Messenger of Allah (may peace he upon him) went to the mosque and stood up and glorified Allah, and the people formed themselves in rows behind him. The Messenger of Allah (may peace be upon him) made a long recital (of the Qur'an) and then pronounced takbir and then observed a long ruku'. He then raised his head and said: Allah listened to him who praised Him: our Lord, praise is due to Thee. He then again stood up and made a long recital, which was less than the first recital. He pronounced takbir and observed a long ruku', and it was less than the first one. He again said: Allah listened to him who praised Him; our Lord, praise is due to Thee. (Abu Tahir, one of the narrators) made no mention of: "He then prostrated himself." He did like this in the second rak'ah, till he completed four rak'ahs and four prostrations and the sun became bright before he deported. He then stood up and addressed people, after lauding Allah as He deserved, and then said: The sun and the moon are two signs among the signs of Allah These do not eclipse either on the death of anyone or on his birth. So when you see them, hasten to prayer. He also said this: Observe prayer till Allah dispels the anxiety (of this extraordinary phenomenon) from you. The Messenger of Allah (may peace be upon him) said: I saw in my place everything which you have been promised. I even saw myself desiring to pluck a bunch (of grapes) from Paradise (and it was at the time) when you saw me moving forward. And I saw Hell and some of its parts crushing the others, when you saw me moving back; and I saw in it Ibn Luhayy and he was the person who made the she-camels loiter about. In the hadith transmitted by Abu Tahir the words are: "He hastened to prayer," and he made no mention of what follows.

Book 4, Number 1969:

    'A'isha reported that there was a solar eclipse during the lifetime of the Messenger of Allah (way peace be upon him) and he sent the announcer (to summon them) for congregational prayer. The people gathered together and he pronounced takbir and he observed four rak'ahs, in the form of two rak'ahs (i.e. he observed two qiyams and two ruku's in one rak'ah) and four prostrations.

Book 4, Number 1970:

    'A'isha reported that the Apostle of Allah (may peace be upon him) recited loudly in the eclipse prayer, and he observed four rak'ahs in the form of two rak'ahs and four prostrations. Zuhri said: Kathir b. 'Abbas narrated on the authority of Ibn 'Abbas that the Apostle of Allah (may peace be upon him) observed four rak'ahs and four prostrations in two rak'ahs.

Book 4, Number 1971:

    Zuhri said: Kathir b. Abbas used to narrate that Ibn 'Abbas used to relate about the prayer of the Messenger of Allah (may peace be upon him) in regard to the eclipse of the sun like that what was narrated by 'Urwa on the authority of 'A'isha.

Book 4, Number 1972:

    'Ata' reported: I heard 'Ubaid b. 'Umair say: It has been narrated to me by one whom I regard as truthful, (the narrator says: I can well guess that he meant 'A'isha) that the sun eclipsed during the lifetime of the Messenger of Allah (may peace be upon him) and he stood up (in prayer) for a rigorously long time. He then bowed and then stood up and then bowed and then stood up and then bowed, thus observing three ruku's in two rak'ahs and four prostrations. He then departed and the sun brightened. He pronounced "Allah is the Greatest" while bowing. He would then bow and say: "Allah listened to him who praised Him" while lifting up his head. He then stood up, and praised Allah and lauded Him, and then said: The sun and the moon do not eclipse on the death of anyone or on his birth. But both of them are among the signs of Allah with which Allah terrifies His servants. So when you see them under eclipse, remember Allah till they are brightened. This hadith is narrated thus on the authority of 'A'isha through another chain of transmitters: "The Messenger of Allah (may peace be upon him) observed six ruku's and four prostration in (two rak'ahs)."

Chapter 172 : MENTION OF THE TORMENT OF GRAVE IN ECLIPSE PRAYER

Book 4, Number 1973:

    'Amra reported that a Jewess came to 'A'isha to ask (about something) and said: May Allah protect you from the torment of the grave ! 'A'isha said: Messenger of Allah, would people be tormented in the graves? The Messenger of Allah (may peace be upon him) said: (May there be) protection of Allah ! The Messenger of Allah (may peace be upon him) mounted one morning on the ride, and the sun eclipsed. 'A'isha said: I came in the company of the women in the mosque from behind the rooms. The Messenger of Allah (way peace he upon him) dismounted from his ride and came to the place of worship where he used to pray. He stood up (to pray) and the people stood behind him. 'A'isha said: He stood for a long time. He then bowed and it was a long ruku'. He then raised his head and he stood for a long time, less than the first standing. He then bowed and his ruku' was long, but it was less than that (the first) ruku'. He then raised (his head) and the sun had become bright. He (the Holy Prophet) then said: I saw you under trial in the grave like the turmoil of Dajjal. 'Amra said: I heard 'A'isha say: I listened after this to the Messenger of Allah (may peace be upon him) seeking refuge from the torment of Fire and the torment of the grave.

Book 4, Number 1974:

    This hadith has been narrated by Yahya b. Sa'id with the same chain of transmitters.

Book 4, Number 1975:

    Jabir b. 'Abdullah reported: The sun eclipsed on one extremely hot day during the lifetime of the Messenger of Allah (may peace be upon him). The Messenger of Allah (may peace be upon him) prayed along with his Companions. He prolonged his qiyam (standing posture in prayer) till they (his Companions) began to fall down. He then observed a long ruku'. He raised his head (and stood up for long) and then observed a long ruku'. He then raised (his head and stood up) for a long time and then made two prostrations. He then stood up and did like this and thus he observed four ruku's and four prostrations (in two rak'ahs) and then said: All these things were brought to me in which you will be made to enter. Paradise was brought to me till (I was so close to it) that if I (had intended) to pluck a bunch (of grapes) out of it. I would have got it, or he (the Holy Prophet) said: I intended to get a bunch (out of that) but my hand could not reach it. Hell was also brought to me and I saw in it a woman belonging to the tribe of Israel who was tormented for a cat whom she had tied, but did not give it food nor set it free to eat the creatures of the earth; and I saw Abu Thumama 'Amr b. Malik who was dragging his intestines in Hell. They (the Arabs) used to say that the sun and the moon do not eclipse but on the death of some great person; but (in reality) both these (the sun and the moon) are among the signs of Allah which are shown to you; so when there is an eclipse, observe prayer till it (the sun or the moon) brightens. This hadith has been narrated by Hisham with the same chain of transmitters except this "I saw a dark woman with a tail stature and loud voice," but he made no mention of "from among Bani Israel".

Book 4, Number 1976:

    Jabir reported that the sun eclipsed during the lifetime of the Messenger of Allah (may peace be upon him) on that very day when Ibrahim (the Prophet's son) died. The Apostle of Allah (may peace be upon him) stood up and led people in (two rak'ahs of) prayer with six ruku's and four prostrations. He commenced (the prayer) with takbir (Allah-o-Akbar) and then recited and prolonged his recital. He then bowed nearly the (length of time) that he stood up. He then raised his head from the ruku' and recited but less than the first recital. He then bowed (to the length of time) that he stood up. He then raised his head from the ruku' and again recited but less than the second recital. He then bowed (to the length of time) that he stood up. He then lifted his head from the ruku'. He then fell in prostration and observed two prostrations. He stood up and then bowed, observing six ruku's like it, without (completing) the rak'ah in them, except (this difference) that the first (qiyam of ruku') was longer than the later one, and the ruku' was nearly (of the same length) as prostration. He then moved backward and the rows behind him also moved backward till we reached the extreme (Abu Bakr said: till he reached near the women) He then moved forward and the people also moved forward along with him till he stood at his (original) place (of worship). He then completed the prayer as it was required to complete and the sun brightened and he said: O people ! verily the sun and the moon are among the signs of Allah and they do not eclipse at the death of anyone among people (Abu Bakr said: On the death of any human being). So when you see anything like it (of the nature of eclipse), pray till it is bright. There is nothing which you have been promised (in the next world) but I have seen it in this prayer of mine. Hell was brought to me as you saw me moving back on account of fear lest its heat might affect me; and I saw the owner of the curved staff who dragged his intestines in the fire, and he used to steal (the belongings) of the pilgrims with his curved staff. If he (the owner of the staff) became aware, he would say: It got (accidentally) entangled in my curved staff, but if he was unaware of that, he would take that away. I also saw in it (in Hell) the owner of a cat whom she had tied and did not feed her nor set her free so that she could eat the creatures of the earth, till the cat died of starvation. Paradise was brought to me, and it was on that occasion that you saw me moving forward till I stood at my place (of worship). I stretched my hand as I wanted to catch hold of its fruits so that you may see them. Then I thought of not doing it. Nothing which you have been promised was there that I did not see in this prayer of mine.

Book 4, Number 1977:

    Asma' reported: The sun eclipsed during the lifetime of the Messenger of Allah (may peace be upon him). As I went to 'A'isha who was busy in prayer. I said: What is the matter with the people that they are praying (a special prayer)? She ('A'isha) pointed towards the sky with her head. I said: Is it (an unusual) sign? She said: Yes. The Messenger of Allah (may peace be upon him) stood up for prayer for such a long time that I was about to faint. I caught hold of a waterskin lying by my side, and began to pour water over my head, or (began to sprinkle water) on my face. The Messenger of Allah (may peace be upon him) then finished and the sun had brightened. The Messenger of Allah (may peace be upon him) then addressed the people, (after) praising Allah and lauding Him, and then said: There was no such thing as I did not see earlier, but I saw it at this very place of mine. I ever saw Paradise and Hell. It was also revealed to me that you would be tried in the graves, as you would he tried something like the turmoil of the Dajjal. Asma' said: I do not know which word he actually used (qariban or mithl), and each one of you would be brought and it would be said: What is your knowledge about this man? If the person is a believer, (Asma' said: I do not know whether it was the word al-Mu'min or al-Mu'qin) he would say: He is Muhammad and he is the Messenger of Allah. He brought to us the clear signs and right guidance. So we responded and obeyed him. (He would repeat this three times), and it would be said to him: You should go to sleep.We already knew that you are a believer in him. So the pious man would go to sleep. So far as the hypocrite or sceptic is concerned (Asma' said: I do not know which word was that: al-Munafiq (hypocrite) or al-Murtad (doubtful) he would say: I do not know. I only uttered whatever I heard people say.

Book 4, Number 1978:

    Asma' said: I came to 'A'isha when the people were standing (in prayer) and she was also praying. I said: What is this excitement of the people for? And the rest of the hadith was narrated like one, (narrated above). 'Urwa said: Do not say Kasafat-ush-Shamsu, but say Khasafat-ush-Shamsu.

Book 4, Number 1979:

    Asma' bint Abu Bakr said: The Apostle of Allah (may peace be upon him) was one day (i.e. on the day when the sun eclipsed) so perturbed that he (in haste) took hold of the outer garment (of a female member of his family) and it was later on that his (own) cloak was sent to him. He stood in prayer along with people for such a long time that if a man came he did not realise that the Apostle of Allah (may peace be upon him) had observed ruku', as it has been narrated about ruku' in connection with long qiyam.

Book 4, Number 1980:

    Abu Juraij narrated this hadith with the same chain of transmitters (but with the addition of these words): "It was for a long duration that he (the Holy Prophet) observed qiyam and he would then observe ruku'. (The narrator also added) I (Asma') looked at a woman who was older than I, and at another who was weaker than I.

Book 4, Number 1981:

    Asma' daughter of Abu Bakr reported: The sun eclipsed during the lifetime of the Apostle of Allah (may peace be upon him); so he felt perturbed and he, by mistake, took hold of the outer garment of a woman till he was given his own cloak. After this I satisfied my need and then came and entered the mosque. I saw the Messenger of Allah (may peace be upon him) standing in prayer. I stood along with him. He prolonged his qiyam till I wished to sit down. Then I cast a glance towards an old woman. So I said: She is older than I. I, therefore, kept standing. He (the Holy Prophet) then observed ruku', and prolonged his ruku'. He then raised his head. He then prolonged his qiyam to such an extent that if a person happened to come he would have thought that he had not observed the ruku'.

Book 4, Number 1982:

    Ibn 'Abbas reported: There was an eclipse of the sun during the lifetime of the Messenger of Allah (may peace be upon him). The Messenger of Allah, (may peace be upon him) prayed accompanied by the people. He stood for a long time, about as long as it would take to recite Surah al-Baqara; then he bowed for a long time; then he raised his head and stood for a long time, but it was less than the first qiyam. He then bowed for a long time but for a shorter while than the first. He then prostrated and then stood for a long time, but it was less than the first qiyam. He then bowed for a long time, but it was less than the first bowing. He then raised (his head) and stood for a long time, but it was less than the first qiyam. He then bowed for a long time but it was less than the first bowing. He then observed prostration, and then he finished, and the sun had cleared (by that time). He (the Holy Prophet) then said : The sun and moon are two signs from the signs of Allah. These two do not eclipse on account of the death of anyone or on account of the birth of anyone. So when you see that, remember Allah. They (his Companions) said: Messenger of Allah, we saw you reach out to something, while you were standing here, then we saw you restrain yourself. He said: I saw Paradise and reached out to a bunch of its grapes; and had I taken it you would have eaten of it as long as the world endured. I saw Hell also. No such (abominable) sight have I ever seen as that which I saw today; and I observed that most of its inhabitants were women. They said: Messenger of Allah, on what account is it so? He said: For their ingratitude or disbelief (bi-kufraihinna). It was said: Do they disbelieve in Allah? He said: (Not for their disbelief in God) but for their ingratitude to their husbands and ingratitude to kindness. If you were to treat one of them kindly for ever, but if she later saw anything (displeasing) in you, she would say: i have never seen any good in you.

Book 4, Number 1983:

    This hadith has been narrated on the authority of Zaid b. Aslam with the same chain of transmitters except with this difference that he (the narrator said): " then we saw you keeping aloof (back)."

Book 4, Number 1984:

    Ibn 'Abbas reported: When there was a solar eclipse the Messenger of Allah (way peace be upon him) observed eight ruku's and four prostrations (in two rak'ahs). This has been narrated by 'Ali also.

Book 4, Number 1985:

    Ibn 'Abbas reported: The Apostle of Allah (may peace be upon him) observed prayer while it was (solar) eclipse. He recited (the Qur'an in qiyam) and then bowed. He again recited and again bowed. He again recited and again bowed and again recited and again bowed, and then prostrated; and the second (rak'ah) was like this.

Book 4, Number 1986:

    'Amr b. al-'As reported: When the sun eclipsed during the lifetime of the Messenger of Allah (may peace be upon him), they (the people) were called to congregational prayers. The Messenger of Allah (may peace be upon him) observed two ruku's in one rak'ah. He then stood and observed two ruku's in (the second) rak'ah. The sun then became bright, and 'A'isha said; Never did I observe, ruku' and prostration longer than this (ruku' and prostration).

Book 4, Number 1987:

    Abu Mas'ud al-Ansari reported Allah's Messenger (may peace be upon him) as saying: Verily the sun and the moon are the two signs among the signs of Allah by which He frightens his servants and they do not eclipse on account of the death of any one of the people. So when you see anything about them, observe prayer, supplicate Allah till it is cleared from you.

Book 4, Number 1988:

    Abu Mas'ud reported that the Messenger of Allah (may peace be upon him) said: Verily the sun and the moon do not eclipse on account of the death of any one of the people, but they are the two signs among the signs of Allah. So when you see it, stand up and observe prayer.

Book 4, Number 1989:

    This hadith has been narrated on the authority of Isma'il with the same chain of transmitters and in the hadith narrated by Sufyan and Waki' (the words are): "The sun eclipsed on the day when Ibrahim died, and the people said: It has eclipsed on the death of Ibrahim."

Book 4, Number 1990:

    Abu Musa reported: The sun eclipsed during the time of the Apostle of Allah (may peace be upon him). He stood in great anxiety fearing that it might be the Doomsday, till he came to the mosque. He stood up to pray with prolonged qiyam, ruku', and prostration which I never saw him doing in prayer; and then he said: These are the signs which Allah sends, not on account of the death of anyone or life of any one, but Allah sends them to frighten thereby His servants. So when you see any such thing, hasten to remember Him, supplicate Him and beg pardon from Him, and in the narration transmitted by Ibn 'Ala the words are: "The sun eclipsed"." "He frightens His servants."

Book 4, Number 1991:

    'Abd al-Rahman b. Samura said: During the lifetime of Allah's Messenger (may peace be upon him) I was shooting my arrows in Medina, when an eclipse of the sun took place. I, therefore, threw them away and said, I must see how the Messenger of Allah (may peace be upon him) acts in a solar eclipse today. When I came to him, he had been supplicating with his hands, raised, pronouncing Allah-o-Akbar, praising Him, acknowledging that He is One God till the eclipse was over, then he recited two surahs and prayed two rak'ahs.

Book 4, Number 1992:

    'Abd al-Rahman b. Samura, who was one of the Companions of the Messenger of Allah (may peace be upon him) said: During the lifetime of Allah's Messenger (may peace be upon him) I was shooting some of my arrows in Medina, when the sun eclipsed. I threw (the arrows) and said: By Allah, I must see how the Messenger of Allah (may peace be upon him) acts in solar eclipse. So I came to him and he was standing in prayer, raising his hands, glorifying Him, praising Him, acknowledging His Oneness, declaring His greatness, and supplicating Him, till the sun cleared. When the eclipse was over, he recited two surahs and prayed two rak'ahs.

Book 4, Number 1993:

    'Abd al-Rahman b. Samura reported: I was shooting some of my arrows during the lifetime of the Messenger of Allah (may peace be upon him) that the sun eclipsed. The rest of the hadith is the same.

Book 4, Number 1994:

    'Abdullah b. 'Umar reported that the Messenger of Allah (may peace be upon him) observed: Verily the sun and the moon do not eclipse on account of the death or life of anyone. They are in fact the signs among the signs of Allah. So when you see them, observe prayer.

Book 4, Number 1995:

    Ziyad b. 'Ilaqa reported: I heard Mughira b. Shu'ba saying that the sun eclipsed during the lifetime of the Messenger of Allah (may peace be upon him) on the day when Ibrahim died. Upon this the Messenger of Allah (may peace be upon him) said: Verily the sun and the moon are the two signs among the signs of Allah. They do not eclipse on account of the death of anyone or on account of the birth of anyone. So when you see them, supplicate Allah, and observe prayer till it is over.

KITAB-UL-JANA'IZ
BOOK RELATING TO THE DEAD

    A Divine Service is held over the dead body of every Muslim, young or old, even of infants who have lived only for a few minutes. A Muslim opens his eyes in the world with the words of Adhan in his ears in which he is told that he is a moral being having moral and spiritual responsibilities far more important than the physical needs. He should live in the world with a firm belief in the Creator of the Universe as his only Deity. Then he should spend his life as a sincere and devoted follower of Muhammad (may peace be upon him), for it is through him that he has received full information about the Will of God and the Divine Code of life. It Is also imprinted upon his fresh and clear mind that prayer elevates the soul of man and herein lies his success in this world and the world to come. With this sacred message he is made to start his life. Both the paths are shown to him, the path of righteousness and religious piety and the path of evil and irreligiousness, and then it is left to his discretion to choose the path he likes. After spending the allotted length of time he is called back to his Master.

    When the soul leaves the body, preparations are made for bidding him the last farewell. He is washed and perfumed and is wrapped in white sheets. Then the funeral prayer is observed keeping his dead body in front of the Imam in which God to requested in congregation to grant him pardon for his minor and major sins, for all his failings and to wrap him in His Mercy.

    A Muslim is received in this world with Adhan and lqama and he is given a send- off with prayer and supplication to Allah for treating him kindly in his heavenly home.

    There is neither Adhan nor Iqama in the funeral prayer which has very deep significance. It implies that the Adhan and lqama for the funeral prayer had been pronounced at the time of his birth. He is thus awakened to the realisation of the fact that he should spend the whole span of his life with such single-minded devotion as is found in a worshipper waiting for the commencement of prayer after the Adhan and Iqama are pronounced.

Chapter 173 : EXHORTATION TO RECITE LA ILAHA ILL-ALLAH (THERE IS NO GOD BUT ALLAH) TO THE DYING PERSON

Book 4, Number 1996:

    Abu Sa'id al-Khudri reported Allah's Messenger (may peace be upon him) as saying: Exhort to recite "There is no god but Allah" to those of you who are dying.

Book 4, Number 1997:

    This hadith has been narrated by Sulaiman b. Bilal with the same chain of transmitters.

Book 4, Number 1998:

    Abu Huraira reported Allah's Messenger (may peace be upon him) as saying: Exhort to recite "There is no god but Allah" to those of you who are dying.

Chapter 174 : WHAT IS TO BE SAID AT THE TIME OF CALAMITY

Book 4, Number 1999:

    Umm Salama reported Allah's Messenger (may peace be upon him) as saying: If any Muslim who suffers some calamity says, what Allah has commanded him, "We belong to Allah and to Him shall we return; O Allah, reward me for my affliction and give me something better than it in exchange for it," Allah will give him something better than it in exchange. When Abu Salama died she said: What Muslim is better than Abu Salama whose family was the first to emigrate to the Messenger of Allah (may peace be upon him). I then said the words, and Allah gave me God's Messenger (may peace be upon him) in exchange. She said: The Messenger of Allah (may peace be upon him) sent Hatib b. Abu Balta'a to deliver me the message of marriage with him. I said to him: I have a daughter (as my dependant) and I am of jealous temperament. He (the Holy Prophet) said: So far as her daughter is concerned, we would supplicate Allah, that He may free her (of her responsibility) and I would also supplicate Allah to do away with (her) jealous (temperament).

Book 4, Number 2000:

    Umm Salama, the wife of the Apostle of Allah (may peace be upon him), reported Allah's Messenger (may peace be upon him) as saying: If any servant (of Allah) who suffers a calamity says: "We belong to Allah and to Him shall we return; O Allah, reward me for my affliction and give me something better than it in exchange for it,"' Allah will give him reward for affliction, and would give him something better than it in exchange. She (Umm Salama) said: When Abu Salama died. I uttered (these very words) as I was commanded (to do) by the Messenger of Allah (may peace be upon him). So Allah gave me better in exchange than him. i.e. (I was taken as the wife of) the Messenger of Allah (may peace be upon him).

Book 4, Number 2001:

    Umm Salama, the wife of the Apostle of Allah (way peace be upon him), reported Allah's Messenger (may peace be upon him) saying like the hadith transmitted by Abu Usama, but with this addition that she said: "When Abu Salama died I said: Who is better than Abu Salama, the Companion of the Messenger of Allah (may peace be upon him), and Allah decided for me and I said (these words contained in the supplication mentioned above) and I was married to the Messenger of Allah (may peace be upon him).

Chapter 175 : WHAT IS TO BE SAID BY THE SIDE OF THE SICK AND THE DEAD

Book 4, Number 2002:

    Umm Salama reported Allah's Messenger (may peace be upon him) as saying: Whenever you visit the sick or the dead, supplicate for good because angels say "Amen" to whatever you say. She added: When Abu Salama died, I went to the Apostle of Allah (may peace be upon him) and said: Messenger of Allah, Abu Salama has died. He told me to recite: "O Allah ! forgive me and him (Abu Salama) and give me a better substitute than he." So I said (this), and Allah gave me in exchange Muhammad, who is better for me than him (Abu Salama).

Chapter 176 : CLOSING THE (EYES) OF THE DEAD AND SUPPLICATION FOR HIM ON VISITING HIM

Book 4, Number 2003:

    Umm Salama reported: The Messenger of Allah (may peace be upon came to Abu Salama (as he died). His eyes were fixedly open. He closed them, and then said: When the soul is taken away the sight follows it. Some of the people of his family wept and wailed. So he said: Do not supplicate for yourselves anything but good, for angels say "Amen" to what you say. He then said: O Allah, forgive Abu Salama, raise his degree among those who are rightly guided, grant him a successor in his descendants who remain. Forgive us and him, O Lord of the Universe, and make his grave spacious, and grant him light in it.

Book 4, Number 2004:

    This hadith has been narrated by Khalid al Hadhdha' with the same chain of transmitters but with this alteration that he said: (O Allah !) let Thee be the caretaker of what is left by him, and he said: Grant him expansion of the grave, but he did not say: Make his grave spacious. Khalid said: He supplicated for the seventh (thing too) which I have forgotten.

Book 4, Number 2005:

    Abu Huraira reported Allah's Messenger (may peace be upon him) as saying: Did you not see when the man died and his eyes were fixedly open? He (Abu Huraira) said: Yes. He (the Holy Prophet) said: It is due to the fact that when (the soul leaves the body) his eyesight follows the soul.

Book 4, Number 2006:

    This hadith is narrated on the authority of 'Ala' with the same chain of transmitters.

Chapter 177 : WEEPING FOR THE DEAD

Book 4, Number 2007:

    Umm Salama reported: When Abu Salama died I said: I am a stranger in a strange land; I shall weep for him in a manner that would be talked of. I made preparation for weeping for him when a woman from the upper side of the city came there who intended to help me (in weeping). She happened to come across the Messenger of Allah (may peace be upon him) and he said: Do you intend to bring the devil into a house from which Allah has twice driven him out? I (Umm Salama), therefore, refrained from weeping and I did not weep.

Book 4, Number 2008:

    Usama b. Zaid reported: While we were with the Apostle of Allah (may peace be upon him), one of his daughters sent to him (the Messenger) to call him and inform him that her child or her son was dying. The Messenger of Allah (may peace be upon him) told the messenger to go back and tell her that what Allah had taken belonged to Him, and to him belonged what He granted; and He has an appointed time for everything. So you (the messenger) order her to show endurance and seek reward from Allah. The messenger came back and said: She adjures him to come to her. He got up to go accompanied by Sa'd b. 'Ubada, Mu'adh b. Jabal, and I also went along with them. The child was lifted to him and his soul was feeling as restless as if it was in an old (waterskin). His (Prophet's) eyes welled up with tears. Sa'd said: What is this, Messenger of Allah? He replied: This is compassion which Allah has placed in the hearts of His servants, and God shows compassion only to those of His servants who are compassionate.

Book 4, Number 2009:

    This hadith has been narrated by another chain of transmitters on the authority of 'Asim al-Ahwal.

Book 4, Number 2010:

    'Abdullah b. 'Umar said that Sa'd b. Ubada complained of illness. The Messenger of Allah (may peace be upon him) came to visit him accompanied by 'Abd al-Rahman b. 'Auf, Sa'd b. Abi Waqqas and 'Abdullah b. Mas'ud. As he entered (his room) he found him in a swoon. Upon this he said: Has he died? They said: Messenger of Allah, it is not so. The Messenger of Allah (may peace be upon him) wept. When the people saw Allah's Messenger (may peace be upon him) weeping, they also began to weep. He said. Listen, Allah does not punish for the tears that the eye sheds or the grief the heart feels, but He punishes for this (pointing to his tongue), or He may show mercy.

Chapter 178 : VISITING THE SICK

Book 4, Number 2011:

    'Abdullah b. 'Umar reported: While we were sitting with the Messenger of Allah (may peace be upon him), a person, one of the Ansar, came to him and greeted him. The Ansari then turned back. Upon this the Messenger of Allah (may peace be upon him) said: o brother of Ansar, how is my brother Sa'd be 'Ubada? He said: He is better. The Messenger of Allah (may peace be upon him) said: Who amongst you would visit him? He (the Holy Prophet) stood up and we also got up along with him, and we were more than ten persons. We had neither shoes with us, nor socks, nor caps, nor shirts. We walked on the barren land till we came to him. The people around him kept away till the Messenger of Allah (may peace be upon him) and his Companions with him came near him (Sa'd b. 'Ubada).

Chapter 179 : ENDURANCE IN TROUBLE AT THE FIRST BLOW

Book 4, Number 2012:

    Anas b. Malik reported Allah's Messenger (may peace be upon him) as saying: Endurance is to be shown at the first blow.

Book 4, Number 2013:

    Anas b. Malik reported that Allah's Messenger (may peace be upon him) came to a woman who had been weeping for her (dead) child, and said to her: Fear Allah and show endurance. She (not recognising him) said: You have not been afflicted as I have been. When he (the Holy Prophet) had departed, it was said to her that he was the Messenger of Allah (may peace be upon him), she was mortally shocked. She came to his door and she did not find doorkeepers at his door. She said: Messenger of Allah. I did not recognise you. He said: Endurance is to be shown at first blow, or at the first blow.

Book 4, Number 2014:

    A hadith like this is narrated with the same chain of transmitters but with the addition of these words: "The Apostle of Allah (may peace be upon him) happened to pass by a woman (who was sitting) by the side of a grave."

Chapter 180 : THE DEAD BODY IS PUNISHED FOR THE LAMENTATION OF HIS FAMILY

Book 4, Number 2015:

    'Abdullah b. 'Umar reported that Hafsa wept for 'Umar (when he was about to due). He ('Umar) said: Be quiet, my daughter. Don't you know that the Messenger of Allah (may peace be upon him) had said: "The dead is punished because of his family's weeping over it"?

Book 4, Number 2016:

    Umar reported Allah's Apostle (may peace be upon him) as saying: The dead is punished in the grave because of wailing on it.

Book 4, Number 2017:

    The same hadith is narrated on the authority of 'Umar through another chain of transmitters.

Book 4, Number 2018:

    Ibn 'Umar reported: When 'Umar was wounded he fainted, and there was a loud lamentation over him. When he regained consciousness he said: Didn't you know that the Messenger of Allah (may peace be upon him) said: "The dead is punished because of the weeping of the living" ?

Book 4, Number 2019:

    Abu Burda narrated on the authority of his father that when 'Umar was wounded Suhaib uttered (loudly in lamentation): O brother! Upon this 'Umar said: Suhaib, did you not know that the Messenger of Allah (may peace be upon him) said: "The dead is punished because of the lamentation of the living"?

Book 4, Number 2020:

    Abu Musa reported that when 'Umar was wounded, there came Suhaib from his house and went to 'Umar and stood by his side, and began to wail. Upon this 'Umar said: What are you weeping for? Are you weeping for me? He said: By Allah, it is for you that I weep, O Commander of the believers. He said: By Allah, you already know that the Messenger of Allah (may peace be upon him) had said: He who is lamented upon is punished. I made a mention of it to Musa b. Talha, and he said that 'A'isha told that it concerned the Jews (only).

Book 4, Number 2021:

    Anas reported that when 'Umar b. Khattab was wounded Hafsa lamented for him. Upon this he said: O Hafsa, did you not hear the Messenger of Allah (may peace be upon him) saying: "One who is lamented would be punished"? Suhaib also lamented over him. 'Umar told him also: O Suhaib, didn't you know that one who is lamented is punished?

Book 4, Number 2022:

    'Abdullah b. Abu Mulaika reported: I was sitting by the side of Ibn 'Umar, and we were waiting for the bier of Umm Aban, daughter of 'Uthman, and there was also 'Amr b. 'Uthman. In the meanwhile there came Ibn 'Abbas led by a guide. I conceive that he was informed of the place of Ibn 'Umar. So he came till he sat by my side. While I was between them (Ibn 'Abbas and Ibn 'Umar) there came the noise (of wailing) from the house. Upon this Ibn 'Umar said (that is, he pointed out to 'Amr that he should stand and forbid them, for): I heard the Messenger of Allah (may peace be upon him) as saying: The dead is punished because of the lamentation of his family. 'Abdullah made it general (what was said for a particular occasion). Ibn 'Abbas said: When we were with the Commander of the believers, 'Umar b. Khattab, we reached Baida', and there was a man under the shadow of the tree. He said to me: Go and inform me who is that person. So I went and (found) that he was Suhaib. I returned to him and said: You commanded me to find out for you who that was, and he is Suhaib. He (Hadrat 'Umar) said: Command him to see us. I said: He has family along with him. He said: (That is of no account) even if he has family along with him. So he (the narrator) told him to see (the Commander of the believers and his party). When we came (to Medina), it was before long that the Commander of the believers was wounded, and Suhaib came weeping and crying: Alas for the brother, alas for the companion. Upon this 'Umar said: Didn't you know, or didn't you hear, that the Messenger of Allah (may peace be upon him) said: "The dead is punished because of the lamentation of his family " ? Then 'Abdullah made it general and 'Umar told it of certain occasions. So I ('Abdullah b. Abu Mulaika) stood up and went to 'A'isha and told her what Ibn 'Umar had said. Upon this she said: I swear by Allah that Allah's Messenger (may peace be upon him) never said that dead would be punished because of his family's lamenting (for him). What he said was that Allah would increase the punishment of the unbeliever because of his family's lamenting for him. Verily it is Allah Who has caused laughter and weeping. No bearer of a burden will bear another's burden. Ibn Abu Mulaika said that al-Qasim b. Muhammad said that when the words of 'Umar and Ibn 'Umar were conveyed to 'A'Isha, she said: You have narrated it to me from those who are neither liar nor those suspected of lying but (sometimes) hearing misleads.

Book 4, Number 2023:

    'Abdullah b. Abu Mulaika said: The daughter of 'Uthman b. 'Affan died in Mecca. We came to attend her (funeral). Ibn 'Umar and Ibn 'Abbas were also present there, and I was sitting between them. He added: I (first sat) by the side of one of them, then the other one came and he sat by my side. 'Abdullah b. 'Umar said to 'Amr b. 'Uthman who was sitting opposite to him: Will you not prevent the people from lamenting, for the Messenger of Allah (may peace be upon him) had said: "The dead is punished because of the lamenting of his family for him"? Ibn 'Abbas then said that Umar used to say someting of that nature, and then narrated saying: I proceeded from Mecca along with 'Umar till we reached al-Baida' and there was a party of riders under the shade of a tree. He said (to me): Go and find out who this party is. I cast a glance and there was Suhaib (in that party). So I informed him ('Umar) about it. He said: Call him to me. So I went back to Suhaib and said: Go and meet the Commander of the believers. When 'Umar was wounded, Suhaib came walling: Alas, for the brother ! alas for the companion ! 'Umar said: O Suhaib, do you wail for me, whereas the Messenger of Allah (may peace be upon him) said: "The dead would be punished on account of the lamentation of the (members of his family)"? Ibn 'Abbas said: When 'Umar died I made a mention of it to 'A'isha. She said: May Allah have mercy upon 'Umar ! I swear by Allah that Allah's Messenger (may peace be upon him) never said that Allah would punish the believer because of the weeping (of any one of the members of his family), but he said that Allah would increase the punishment of the unbeliever because of the weeping of his family over him. 'A'isha said: The Qur'an is enough for you (when it states): "No bearer of burden will bear another's burden" (vi. 164). Thereupon Ibn 'Abbas said: Allah is He Who has caused laughter and weeping. Ibn Abu Mulaika said: By Allah, Ibn 'Umar said nothing.

Book 4, Number 2024:

    'Amr reported on the authority of Ibn Abu Mulaika: We were with the bier of Umm Aban, daughter of 'Uthman, and the rest of the hadith is the same, but he did not narrate it as a marfu' hadith on the authority of 'Umar from the Apostle of Allah (may peace be upon him) as it was narrated by Ayyub and Ibn Juraij, and the hadith narrated by them (Ayyub and Ibn Juraij) is more complete than that of 'Amr.

Book 4, Number 2025:

    'Abdullah b. 'Umar reported that the Messenger of Allah (may peace be upon him) said: The dead is punished because of the lamentation of the living.

Book 4, Number 2026:

    Hisham b. 'Urwa narrated on the authority of his father that the saying of Ibn 'Umar, viz. "The dead would be punished because of the lamentation of his family over him" was mentioned to 'A'isha. Upon this she said: May Allah have mercy upon Abu 'Abd al-Rahman (the kunya of Ibn 'Umar) that he heard something but could not retain it (well). (The fact is) that the bier of a Jew passed before the Messenger of Allah (may peace be upon him) and (the members of his family) were waiting over him. Upon this he said: You are wailing and he is being punished.

Book 4, Number 2027:

    Hisham narrated on the authority of his father that it was mentioned to 'A'isha that Ibn 'Umar had narrated as marfu' hadith from the Apostle of Allah (may peace be upon him) that the dead would be punished in the grave because of the lamentation of his family for him. Upon this she said: He (Ibn 'Umar) missed (the point). The Messenger of Allah (may peace be upon him) had (in fact) said: He (the dead) is punished for his faults or for his sins, and the members of his family are wailing for him now. (This misunderstanding of Ibn 'Umar is similar to his saying:) The Messenger of Allah (may peace be upon him) stood by the well in which were lying the dead bodies of those polytheists who had been killed on the Day of Badr, and he said to them what he had to say, i.e.: They hear what I say. But he (Ibn 'Umar) misunderstood. The Holy Prophet (may peace be upon him) had only said: They (the dead) understand that what I used to say to them was truth. She then recited: "Certainly, thou canst not make the dead hear the call" (xxvii. 80), nor can you make those hear who are in the graves, nor can you inform them when they have taken their seats in Hell.

Book 4, Number 2028:

    This hadith has been narrated by Ibn 'Urwa with the same chain of transmitters. The hadith narrated by Abu Usama is more complete.

Book 4, Number 2029:

    'Amra daughter of 'Abd al Rahman narrated that she heard (from) 'A'isha and made a mention to her about 'Abdullah b. 'Umar as saying: The dead is punished because of the lamentation of the living. Upon this 'A'isha said: May Allah have mercy upon the father of 'Abd al-Rahman (Ibn 'Umar). He did not tell a lie, but he forgot or made a mistake. The Messenger of Allah (may peace be upon him) happened to pass by a (dead) Jewess who was being lamented. Upon this he said: They weep over her and she is being punished in the grave.

Book 4, Number 2030:

    'Ali b. Rabi'a reported that the first one who was lamented upon in Kufa was Qaraza b. Ka'b. Mughira b. Shu'ba said: I heard the Messenger of Allah (may peace be upon him) saying: He who is lamented upon would be punished because of the lamentation for him on the Day of judgment.

Book 4, Number 2031:

    A hadith like this has been narrated by Mughira b. Shu'ba from the Apostle of Allah (may peace be upon him).

Book 4, Number 2032:

    This hadith has been narrated from the Apostle of Allah (may peace be upon him) through another chain of transmitters.

Book 4, Number 2033:

    Abu Malik al-Ash'ari reported Allah's Messenger (may peace be upon him) as saying: Among my people there are four characteristics belonging to pre-Islamic period which they do not abandon: boasting of high rank, reviling other peoples' genealogies, seeking rain by stars, and walling. And he (further) said: If the wailing woman does not repent before she dies, she will be made to stand on the Day of Resurrection wearing a garment of pitch and a chemise of mange.

Book 4, Number 2034:

    'A'isha reported that when the Messenger of Allah (may peace be upon him) was told that Ibn Haritha, Ja'far b. Abu Talib and Abdullah b. Rawaha were killed, he sat down, showing signs of grief. She (further) said: I was looking (at him) through the crevice of the door. A man came to him and mentioned that Ja'far's women were lamenting. He (the Holy Prophet) commanded him to go and forbid them (to do so). So he went away but came back and told (him) that they did not obey (him). He commanded him a second time to go and forbid them (to do so). He again went but came back to him and said: I swear by God, Messenger of Allah, that they have overpowered us. She ('A'isha) said that she thought the Messenger of Allah (may peace be upon him) had told (her) to throw dust in their mouths. Thereupon 'A'isha said: May Allah humble you ! You did not do what Allah's Messenger (may peace be upon him) ordered you, nor did you stop annoying Allah's Messenger (may peace be upon him).

Book 4, Number 2035:

    This hadith has been narrated by Yahya b. Sa'id with the same chain of transmitters like one narrated by 'Abd al-'Aziz (with the change of these words): "You did not spare the Messenger of Allah (may peace be upon him) the botheration."

Book 4, Number 2036:

    Umm 'Atiyya reported: The Messenger of Allah (may peace be upon him) took a promise from us along with the oath of Allegiance that we would not lament. But only five among us fulfilled the promise (and they are) Umm Sulaim, and Umm al-'Ala', and the daughter of Abu Sabra the wife of Mu'adh, or daughter of Abu Sabra and wife of Mu'adh.

Book 4, Number 2037:

    Umm 'Atiyya reported that the Messenger of Allah (may peace be upon him) took pledge from us (including this promise) that we would not lament. Only five amongst us fulfilled the promise, and one of them (who fulfilled the promise) was Umm Sulaim.

Book 4, Number 2038:

    Hafsa narrated on the authority of Umm 'Atiyya that she said: When this verse was revealed: "When believing women came to thee giving thee a pledge that they will not associate aught with Allah, and will not disobey thee in good" (lx. 12), she (Umm Atiyya) said: In (this pledge) was also included wailing. I said: Messenger of Allah I except members of such a tribe who helped me (in lamentation) during pre-Islamic days, there is left no alternative for me, but that I should also help them. Upon this the Messenger of Allah (may peace be upon him) said: (Yes) but only in case of the members of such a tribe.

Chapter 181 : WOMEN FORBIDDEN TO FOLLOW THE BIER

Book 4, Number 2039:

    Umm 'Atiyya reported: We were forbidden to follow the bier, but it was not made absolute on us.

Book 4, Number 2040:

    Umm 'Atiyya reported: We were refrained from following the bier, but it was not made absolute on us.

Chapter 182 : WASHING OF THE DEAD BODY

Book 4, Number 2041:

    Umm 'Atiyya reported: The Apostle of Allah (may peace be upon him) came to us when we were bathing his daughter, and he told us: Wash her with water and (with the leaves of) the lote tree, three or five times, or more than that if you think fit, and put camphor or something like camphor in the last washing; then inform me when you have finished. So when we had finished, we informed him, and he gave to us his (own) under-garment saying: "Put it next her body."

Book 4, Number 2042:

    Umm 'Atiyya reported: We braided her hair in three plaits.

Book 4, Number 2043:

    Umm 'Atiyya reported: One of the daughters of the Apostle of Allah (may peace be upon him) died. And in the hadith transmitted by Ibn 'Ulayya (the words are): The Messenger of Allah (may peace be upon him) came to us and we were washing his daughter. And in the hadith transmitted by Malik (the words are): There came in (our apartment) the Messenger of Allah (way peace be upon him) when his daughter died. The rest of the hadith is the same as narrated by Yazid b. Zurai' from Ayyub from Muhammad from Umm 'Atiyya.

Book 4, Number 2044:

    A hadith like this has been transmitted by Hafsa on the authority of Umm 'Atiyya with the exception (of these words that the Holy Prophet asked them to wash her dead body): "three times, five times, seven times, or more than that, if you deem fit:" Hafsa (further) said on the authority of Umm 'Atiyya: We braided (the hair) of her head in three plaits.

Book 4, Number 2045:

    Umm 'Atiyya reported: We washed her an odd number of times, i.e. three, five or seven times; and Umm 'Atiyya (further) said: We braided her hair in three plaits.

Book 4, Number 2046:

    Umm 'Atiyya reported: When Zainab the daughter of the Messenger of Allah (may peace be upon him) died, he said to us: Wash her odd number of times, i.e. three or five times, and put camphor or something-like camphor at the fifth time, and after you have washed her inform me. So we informed him and he gave us his under-garment, saying: "Put it next her body."

Book 4, Number 2047:

    Umm 'Atiyya reported: There came to us the Messenger of Allah (may peace be upon him) as we were washing one of his daughters. So he said: Wash her (dead body) an odd number of times, five times or more than that, the rest of the hadith is the same. She (further) said: We braided her hair in three plaits: (two) on the sides of her head and one on her forehead.

Book 4, Number 2048:

    Umm 'Atiyya reported that when the Messenger of Allah (may peace be upon him) asked her to wash his daughter, he told her to start from the right side, and with those parts of the body over which Wudu' is performed.

Book 4, Number 2049:

    Umm 'Atiyya reported that the Messenger of Allah (may peace be upon him) said to them (the women) in regard to the washing of his daughter to start from the right side and with those parts of the body over which Wudu' is performed.

Chapter 183 : CONCERNING THE SHROUDING OF THE DEAD BODY

Book 4, Number 2050:

    Khabbab al-Aratt reported: We migrated with the Messenger of Allah (may peace be upon him) in the path of Allah seeking Allah's pleasure alone. Thus our reward was assured with Allah. And amongst us were those who spent life (in such a state of piety and austerity) that nothing consumed their reward. Mus'ab b. 'Umair was one of them. He was killed on the Day of Uhud, and nothing but a woollen cloak was found to shroud him. When we covered his head with it, his feet became uncovered, and when we covered his feet, his head was uncovered. Upon this the Messenger of Allah (may peace be upon him) said: Place it (this cloak) on the side of his head and cover his feet with grass. And there is one amongst us for whom the fruit is ripened and he enjoys it.

Book 4, Number 2051:

    A hadith like this has been narrated by 'Uyaina on the authority of A'mash with the same chain of transmitters.

Book 4, Number 2052:

    'A'isha reported that the Messenger of Allah (may peace be upon him) was shrouded in three cotton garments of white Yamani stuff from Sahul, among which was neither a shirt nor a turban; and so far as Hullah is concerned there was some doubt about it in the minds of people, that it was brought for him in order to shroud him with it, but it was abandoned, and he was shrouded in three cotton garments of white Yamani stuff from Sahul. Then 'Abdullah b. Abu Bakr got it and said: I would keep it in order to shroud myself in it. He then said: If Allah, the Exalted and Majestic, would have desired it for His Apostle, he would have been shrouded with it. So he sold it and gave its price in charity.

Book 4, Number 2053:

    'A'isha reported that the Messenger of Allah (may peace be upon him) was wrapped in a Yamani wrapper which belonged to 'Abdullah b Abu Bakr; then it was removed from him, and he was shrouded in three cotton sheets of white Yamani stuff from Sahul among which was neither a shirt nor a turban. 'Abdullah took up the Hullah and said: I would be shrouded in it, but then said: How is it that I should be shrouded in it in which the Messenger of Allah (may peace be upon him) was not shrouded ! So he gave it in charity.

Book 4, Number 2054:

    This hadith is narrated on the authority of Hisham with the same chain of transmitters, but in the hadith narrated by him there is no mention of the story of 'Abdullah b. Abu Bakr.

Book 4, Number 2055:

    Abu Salama said: I asked 'A'isha with how many garments the Messenger of Allah (may peace be upon him) was shourded. She said: With three garments of Sahul.

Chapter 184 : COVERING THE DEAD BODY WITH A CLOTH

Book 4, Number 2056:

    'A'isha reported: When the Messenger of Allah (may peace be upom him) died, he was covered with a Yamani wrapper.

Book 4, Number 2057:

    This hadith has been narrated by Zuhri with the same chain of transmitters.

Chapter 185 : EXHORTATION TO SHROUD THE DEAD BODY WELL

Book 4, Number 2058:

    Jabir b. 'Abdullah reported: Allah's Messenger (may peace be upon him) one day in the course of his sermon made mention of a person among his Companions who had died and had been wrapped in a shroud not long (enough to cover his whole body) and was buried during the night. The Apostle of Allah (may peace be upon him) reprimanded (the audience) that a person was buried during the night (in a state that) funeral prayer could not be offered (over him by the Messenger of Allah). (And this is permissible only) when it becomes a dire necessity for a man. The Apostle of Allah (may peace be upon him) also said: When any one of you shrouds his brother, he should shroud him well.

Chapter 186 : MAKING HASTE IN FUNERAL

Book 4, Number 2059:

    Abu Huraira reported Allah's Apostle (may peace be upon him) as saying: Make haste at a funeral; if the dead person was good, it is a good state to which you are sending him on; but if he was otherwise it is an evil of which you are ridding yourselves.

Book 4, Number 2060:

    This hadith has been narrated by another chain of transmitters except with this variation (of words) that in the hadith narrated by Ma'mar (the words are): "I do not know whether the hadith is marfu'."

Book 4, Number 2061:

    Abu Huraira reported Allah's Messenger as saying: Hasten at a funeral, for if (the dead person) is good, you would (soon) bring him close to the good. And if it is otherwise, it is an evil of which you are ridding yourselves.

Chapter 187 : MERIT OF THE FUNERAL PRAYER AND FOLLOWING THE BIER

Book 4, Number 2062:

    Abu Huraira reported Allah's Messenger (may peace be upon him) as saying: He who attends the funeral till the prayer is offered for (the dead), for him is the reward of one qirat, and he who attends (and stays) till he is buried, for him is the reward of two qirats. It was said: What are the qirats? He said: They are equivalent to two huge mountains. Two other narrators added: Ibn 'Umar used to pray and then depart (without waiting for the burial of the dead). When the tradition of Abu Huraira reached him, he said: "We have lost many qirats."

Book 4, Number 2063:

    This hadith has been narrated on the authority of Abu Huraira through another chain of narrators up to these words: "two great mountains." No mention is made of what followed (these words); and in the hadith transmitted by 'Abd al- A'la (the words are): "till (the burial) is complete." In the hadith transmitted by 'Abd ar-Razzaq (the words are): "till he is placed in the grave."

Book 4, Number 2064:

    This hadith is narrated on thp authority of Abu Huraira through another chain of transmitters (with these words): "He who followed it (the bier) till he (the dead) is buried."

Book 4, Number 2065:

    Abu Huraira reported Allah's Apostle (may peace be upon him) as saying: He who offered prayer over the dead, but did not follow the bier, for him is the reward of one qirat, and he who followed it, for him is the reward of two qirats. It was asked what the qirats were. He said: The smaller amongst the two is equivalent to Uhud.

Book 4, Number 2066:

    Nafi' narrated that it was said to Ibn 'Umar that Abu Huraira reported to have heard Allah's Messenger (may peace be upon him) as saying: He who follows the bier, for him is the reward of one qirat. Ibn 'Umar said: Abu Huraira narrated it too often. So he sent (a messenger to) 'A'isha to ascertain (the fact). She ('A'isha) testified Abu Huraira. Ibn 'Umar said: We missed so many qirats.

Book 4, Number 2067:

    Abu Huraira reported Allah's Messenger (may peace be upon him) as saying: He who offers prayer for the dead, for him is (the reward of) one qirat; and he who follows the bier till it is placed in the grave, for him (is the reward of) two qirats. I (Abu Hazim, one of the narrators) raid: Abu Huraira, what is this qirat? He said: It is like the hill of Uhud.

Book 4, Number 2068:

    Dawud b. 'Amir b. Sa'd b. Abu Waqqas reported on the authority of his father that while he was sitting along with 'Abdullah b. 'Umar, Khabbab, the owner of Maqsura, said: Ibn 'Umar, do you hear what Abu Huraira says that he heard the Messenger of Allah (may peace be upon him) say: "He who goes out with the bier when taken out from its residence and offers prayer for it and he then follows it till it is buried, he would have two qirats of reward, each qirat being equivalent to Uhud; and he who, after having offered prayer, (directly) came back would have his reward (as great) as Uhud"? Ibn 'Umar sent Khabbab to 'A'isha in order to ask her about the words of Abu Huraira (and also told him) to come back to him (Ibn 'Umar) and inform him what 'A'isha said. (In the meanwhile) Ibn 'Umar took up a handful of pebbles and turned them over in his hand till the messenger (Khabbab) came back to him and told (him) that 'A'isha testified (the statement of) Abu Huraira. Ibn 'Umar threw the pebbles he had in his hand on the ground and then said: We missed a large number of qirats.

Book 4, Number 2069:

    Thauban, the freed slave of the Messenger of Allah (may peace be upon him) reported Allah's Messenger (may peace be upon him) as saying: He who offered prayer for the dead, for him is the reward of one qirat, and he who attended its burial, he would have two qirats as his reward. And qirat is equivalent to Uhud.

Book 4, Number 2070:

    This hadith has been narrated by Qatada with the same chain of transmitters. And in the hadith transmitted by Sa'id and Hisham, (the words are): "The Apostle of Allah (may peace be upon him) was asked about qirat, and he said: It is equivalent to Uhud."

Chapter 188 : IF ONE HUNDRED MUSLIMS OFFER PRAYER FOR THE DEAD, ALL OF THEM INTERCEDING FOR HIM (IT WOULD BE ACCEPTED)

Book 4, Number 2071:

    'A'isha reported Allah's Apostle (may peace be upon him) saying: If a company of Muslims numbering one hundred pray over a dead person, all of them interceding for him, their intercession for him will be accepted.

Book 4, Number 2072:

    'Abdullah b. 'Abbas reported that his son died in Qudaid or 'Usfan. He said to Kuraib to see as to how many people had gathered there for his (funeral). He (Kuraib) said: So I went out and I informed him about the people who had gathered there. He (Ibn 'Abbas) said: Do you think they are forty? He (Kuraib) said: Yes. Ibn 'Abbas then said to them: Bring him (the dead body) out for I have heard Allah's Messenger (may peace be upon him) as saying: If any Muslim dies and forty men who associate nothing with Allah stand over his prayer (they offer prayer over him), Allah will accept them as intercessors for him.

Chapter 189 : THE DEAD WHO IS PRAISED IN GOOD WORDS, OR WHO IS CONDEMNED IN BAD WORDS

Book 4, Number 2073:

    Anas b. Malik reported: There passed a bier (being carried by people) and it was lauded in good terms. Upon this the Apostle of Allah (may peace be upon him) said: It has become certain, it has become certain, it has become certain. And there passed a bier and it was condemned in bad words. Upon this the Apostle of Allah (may peace be upon him) said: It has become certain, it has become certain, it has become certain. 'Umar said: May my father and mother be ransom for you ! There passed a bier and it was praised in good terms, and you said: It has become certain, it has become certain, it has become certain. And there passed a bier and it was condemned in bad words, and you said: It has become certain, it has become certain, it has become certain. Upon this the Messenger of Allah (way peace be upon him) said: He whom you praised in good terms, Paradise has become certain for him, and he whom you condemned in bad words, Hell has become certain for him. You are Allah's witnesses in the earth, you are Allah's witnesses in the earth, you are Allah's witnesses in the earth.

Book 4, Number 2074:

    This hadith has been narrated through another chain of transmitters.

Chapter 190 : WHAT IS SAID IN CASE OF ONE WHO GETS RELIEF AND THE ONE FROM WHOM THE OTHER GETS RELIEF

Book 4, Number 2075:

    Qatada b. Rib'i reported Allah's Messenger (may peace be upon him) as saying: Whenever a bier passed before him, he said: He is the one to find relief and the one with (the departure of him) other will find relief. They said: Apostle of Allah, who is al-Mustarih and al-Mustarah? Upon this he said: The believing servant finds relief from the troubles of the world, and in the death of a wicked person, the people, towns, trees and animals find rellef.

Book 4, Number 2076:

    In the hadith transmitted by Yahya b. Sa'id on the authority of Qatada (the words are): (The believing servant) finds relief from the troubles of the world and its hardships and (gets into) the Mercy of Allah.

Book 4, Number 2077:

    Abu Huraira reported that the Messenger of Allah (may peace be upon him) gave the people news of the death of Negus on the day he died, and he took them out to the place of prayer and observed four takbirs.

Book 4, Number 2078:

    Abu Huraira reported: The Messenger of Allah (may peace be upon him) gave us the news of the death of Negus, the ruler of Abyssinia, on the day when he died, and he said (to us): Beg pardon for your brother. Ibn Shihab said that Sa'id b. Musayyib had told that Abu Huraira had narrated to him that the Messenger of Allah (may peace be upon him) drew them up in a row in a place of prayer, and offered prayer and recited four takbirs for him.

Book 4, Number 2079:

    This hadith is narrated through another chain of transmitters.

Book 4, Number 2080:

    Jabir b. 'Abdullah reported that the Messenger of Allah (may peace be upon him) offered prayer for Ashama, the Negus, and recited four takbirs.

Book 4, Number 2081:

    Jabir b. 'Abdullah reported Allah's Messenger (may peace be upon him) as saying: There died today the pious servant of Allah, Ashama. So he stood up and led us in (funeral prayer) over him.

Book 4, Number 2082:

    Jabir b. 'Abdullah reported Allah's Messenger (may peace be upon him) as saying: A brother of yours has died, so stand up and offer prayer over him. So we stood up and drew ourselves up into two rows.

Book 4, Number 2083:

    'Imran b. Husain reported Allah's Messenger (may peace be upon him) as saying: A brother of yours has died; so stand up and offer prayer for him, i.e. Negus. And in the hadith transmitted by Zubair (the words are): "Your brother."

Chapter 191 : PRAYER OVER THE GRAVE

Book 4, Number 2084:

    Sha'bi reported that the Messenger of Allah (may peace be upon him) observed prayer over a grave after the dead was buried and he recited four takbirs over him. Shaibani said: I said to Sha'bi: Who narrated it to you? He said: An authentic one, 'Abdullah b. 'Abbas. This is the word of a hasan hadith. In the narration of Ibn Numair (the words are): The Messenger of Allah (may peace be upon him) went to the grave which had been newly prepared and prayed over it, and they also prayed who were behind him and he recited four takbirs. I said to 'Amir: Who narrated it to you? He said: An authentic one who saw him, i e. Ibn 'Abbas.

Book 4, Number 2085:

    This hadith has been narrated through another chain of transmitters, but in one of them (these words are found): "The Apostle of Allah (may peace be upon him) recited four takbirs."

Book 4, Number 2086:

    The hadith as narrated by Shaibani has been narrated through another chain of transmitters.

Book 4, Number 2087:

    Anas reported that the Apostle of Allah (may peace be upon him) observed prayer on the grave.

Book 4, Number 2088:

    It is narrated on the authority of Abu Huraira that a dark-complexioned woman (or a youth) used to sweep the mosque. The Messenger of Allah (may peace be upon him) missed her (or him) and inquired about her (or him). The people told him that she (or he) had died. He asked why they did not inform him, and it appears as if they had treated her (or him) or her (or his) affairs as of little account. He (the Holy Prophet) said: Lead me to her (or his) gtave. They led him to that place and he said prayer over her (or him) and then remarked: Verily, these graves are full of darkness for their dwellers. Verily, the Mighty and Glorious Allah illuminates them for their occupants by reason of my prayer over them.

Book 4, Number 2089:

    It is narrated on the authority of 'Abd al-Rahman b. Abu Laila that Zaid used to recite four takbirs on our funerals and he recited five takbirs on one funeral. I asked him the reason (for this variation), to which he replied: The Messenger of Allah (may peace be upon him) recited thus.

Chapter 192 : STANDING UP ON SEEING A BIER

Book 4, Number 2090:

    It is narrated on the authority of 'Amir Ibn Rabi'a (may Allah be pleased with him) that the Prophet (may peace be upon him) said: Whenever you see a funeral procession, stand up for that until it moves away or is lowered on the ground.

Book 4, Number 2091:

    It is narrated on the authority of 'Amir ibn Rabi'a (may Allah be pleased with him) that the Holy Prophet (may peace be upon him) said: Should any one of you come across a funeral procession, and if he does not intend to accompany it, he must stand up until it passes by him or is placed upon the ground before it passes him.

Book 4, Number 2092:

    It is reported on the authority of Ibn Juraij that the Holy Prophet (may peace be upon him) said: Should anyone amongst you see a bier he must stand up so long as it is within sight in case he does not intend to follow it.

Book 4, Number 2093:

    It is narrated on the authority of Abu Sa'id al-Khudri that the Holy Prophet (may peace be upon him) said: When you follow a bier, do not sit until it is placed on the (ground).

Book 4, Number 2094:

    It is narrated on the authority of Abu Sa'id al-Khudri that the Holy Prophet (may peace be upon him) said: Whenever you come across a bier you should stand up, and he who follows it should not sit down till it is placed on the ground.

Book 4, Number 2095:

    It is narrated on the authority of Jabir ibn 'Abdullah: There passed a bier and the Holy Prophet (may peace be upon him) stood up for it and we also stood up along with him. We said: Messenger of Allah, that was the bier of a Jewess. Upon this he remarked: Verily, death is a matter of consternation, so whenever you come across a bier stand up.

Book 4, Number 2096:

    Ibn Juraij told me that Abu Zubair heard Jabir say that the Holy Prophet (may peace be upon him) kept standing for a bier until it disappeared.

Book 4, Number 2097:

    Again Abu Zubair heard Jabir say that the Holy Prophet (may peace be upon him) and his Companions kept standing for a bier of a Jew until it disappeared from sight.

Book 4, Number 2098:

    It is narrated on the authority of Ibn Abu Laila that while Qais b. Sa'd and Sahl b. Hunaif were both in Qadislyya a bier passed by them and they both stood up. They were told that it was the bier of one of the people of the land (non-Muslim). They said that a bier passed before the Holy Prophet (may peace be upon him) and he stood up. He was told that he (the dead man) was a Jew. Upon this he remarked: Was he not a human being or did he not have a soul? And in the hadith narrated by 'Amr b. Murra with the same chain of transmitters, (the words) are: "There passed a bier before us."

Chapter 193 : ABROGATION OF THE ACT OF STANDING UP FOR THE BIER

Book 4, Number 2099:

    It is narrated on the authority of Waqid: Nafi' b. Jubair saw me and we were standing for a bier, while he was sitting and waiting for the bier to be placed on the ground. He said to me: What makes you keep standing? I said: I am waiting that the bier may be placed on the ground (and I am doing that) on the hadith narrated to me by Abu Sa'id al-Khudri. Upon this Nafi' said: Verily, Mas'ud b. Hakam reported to me on the authority of Hadrat 'Ali b. Abu Talib that the Holy Prophet (may peace be upon him) stood up first (for a bier) and then sat down.

Book 4, Number 2100:

    Mas'ud b. al-Hakam al-Ansari informed Nafi' that he had heard Hadrat 'Ali (may Allah be pleased with him), son of Abu Talib, say about the biers: Verily, the Holy Prophet (may peace be upon him) used to stand first but later on kept sitting; but it is also narrated that Nafi' ibn Jubair saw Waqid b. 'Amr standing for a bier till it was placed down.

Book 4, Number 2101:

    This hadith has been narrated by Yahya b. Sa'id with the same chain of transmitters.

Book 4, Number 2102:

    It is narrated on the authority of Muhammad b. Munkadir that he said: I heard from Mas'ud b. al-Hakam who narrated it on the authority of Hadrat 'Ali that he said: We saw the Holy Prophet (may peace be upon him) stood up for a (bier) and we also stood up; he sat down and we too sat down.

Book 4, Number 2103:

    This hadith has been narrated by Shu'ba with the same chain of transmitters.

Chapter 194 : SUPPLICATION FOR THE DEAD IN THE FUNERAL PRAYER

Book 4, Number 2104:

    Jubair b. Nufair says: I heard it from 'Auf b. Malik that the Holy Prophet (may peace be upon him) said prayer on the dead body, and I remembered his prayer: "O Allah ! forgive him, have mercy upon him, give him peace and absolve him. Receive him with honour and make his grave spacious; wash him with water, snow and hail. Cleanse him from faults as Thou wouldst cleanse a white garment from impurity. Requite him with an abode more excellent than his abode, with a family better than his family, and with a mate better than his mate. Admit him to the Garden, and protect him from the torment of the grave and the torment of the Fire." ('Auf bin Malik) said: I earnestly desired that I were this dead body.

Book 4, Number 2105:

    A hadith like this has been narrated through another chain of transmitters.

Book 4, Number 2106:

    'Anas b. Malik said: I heard the Holy Prophet (may peace be upon him) say (while offering prayer on a dead body): O Allah ! forgive him, have mercy upon him. Give him peace and absolve him. Receive him with honour and make his grave spacious. Wash him with water, snow and hail, cleanse him from faults as is cleaned a white garment from impurity. Requite him with an abode more excellent than his abode, with a family better than his family, and with a mate better than his mate, and save him from the trial of the grave and torment of Hell. 'Auf b. Malik said: I earnestly desired that I were the dead person to receive the prayer of the Messenger of Allah (may peace be upon him) as this dead body had (received).

Chapter 195 : WHERE SHOULD THE IMAM STAND FOR OFFERING PRAYER OVER THE DEAD BODY

Book 4, Number 2107:

    Samura b. Jundub said: I prayed behind the Messenger of Allah (may peace be upon him) and he prayed for a woman who had died in the state of delivery. He stood in front of her waist.

Book 4, Number 2108:

    This hadith has been narrated by Husain with the same chain of transmitters, but no mention is made of Umm Ka'b.

Book 4, Number 2109:

    Samura b. Jundub said: I was a young boy during the time of the Holy Prophet (may peace be upon him) and I retained in my mind (what I learnt from him), and nothing restrained me from speaking except the fact that there were persons far more advanced in age than I. Verily, I said prayer behind the Messenger of Allah (may peace be upon him) over a woman who had died in the state of delivery, and the Messenger of Allah (may peace be upon him) stood up to say prayer in front of the middle part of her body. And in the tradition narrated on the authority of Ibn Muthanna the words are: "(The Holy Prophet) stood in the middle part of her body for offering prayer for her."

Chapter 196 : IT IS PERMISSIBLE TO RIDE BACK AFTER OFFERING FUNERAL PRAYER

Book 4, Number 2110:

    It is reported on the authority of Jabir ibn Samura that an unsaddled horse was brought to the Holy Prophet (may peace be upon him) and he rode on it when he returned after having offered the funeral prayer of Ibn Dahdah and we walked on foot around him.

Book 4, Number 2111:

    Jabir ibn Samura reported that the Holy Prophet (may peace be upon him) said (funeral) prayer on Ibn Dahdah: then an unsaddled horse was brought to him and a person hobbled it, and he (the Messenger of Allah) rode upon it and it bounded and we followed it and ran after it. One of the people said that the Holy Prophet (may peace be upon him) remarked: How many among hanging bunches in the Paradise are meant for Ibn Dahdah ?

Chapter 197 : NICHE IN THE GRAVE AND SETTING UP OF MUD BRICKS OVER THE DEAD

Book 4, Number 2112:

    'Amir b. Sa'd b. Abu Waqqas told that Sa'd b. Abu Waqqas said during his illness of which he died: "Make a niche for me in the side of the grave and set up bricks over me as was done in case of Allah's Messenger (may peace be upon him).

Book 4, Number 2113:

    Ibn 'Abbas said that a piece of red stuff was put in the grave of Allah's Messenger (may peace be upon him).

Chapter 198 : COMMANDMENT IN REGARD TO THE LEVELLING OF THE GRAVE

Book 4, Number 2114:

    Thumama b. Shafayy reported: When we were with Fadala b. 'Ubaid in the country of the Romans at a place (known as) Rudis, a friend of ours died. Fadala b. 'Ubaid ordered to prepare a grave for him and then it was levelled; and then he said: I heard the Messenger of Allah (may peace be upon him) commanding (us) to level the grave.

Book 4, Number 2115:

    Abu'l-Hayyaj al-Asadi told that 'Ali (b. Abu Talib) said to him: Should I not send you on the same mission as Allah's Messenger (may peace be upon him) sent me? Do not leave an image without obliterating it, or a high grave without levelling It. This hadith has been reported by Habib with the same chain of transmitters and he said: (Do not leave) a picture without obliterating it.

Chapter 199 : IT IS FORBIDDEN TO PLASTER THE GRAVE OR CONSTRUCTING ANYTHING OVER IT

Book 4, Number 2116:

    Jabir said: Allah's Messenger (may peace be upon him) forbade that the graves should be plastered or they be used as sitting places (for the people), or a building should be built over them.

Book 4, Number 2117:

    A hadith like this has been transmitted on the authority of Jabir b. 'Abdullah.

Book 4, Number 2118:

    Jabir said that he was forbidden to build pucca graves.

Chapter 200 : IT IS FORBIDDEN TO SIT OVER THE GRAVE AND OBSERVE PRAYER FACING TOWARDS IT

Book 4, Number 2119:

    Abu Huraira reported Allah's Messenger (may peace be upon him) as saying: It is better that one of you should sit on live coats which would burn his clothing and come in contact with his skin than that he should sit on a grave.

Book 4, Number 2120:

    A hadith like this has been narrated by Suhail with the same chain of transmitters.

Book 4, Number 2121:

    Abu Marthad al-Ghanawi reported Allah's Messenger (may peace be upon him)as saying: Do not sit on the graves and do not pray facing towards them.

Book 4, Number 2122:

    Abu Marthad al-Ghanawi reported Allah's Messenger (may peace be upon him) as saying: Do not pray facing towards the graves, and do not sit on them.

Chapter 201 : FUNERAL PRAYER IN THE MOSQUE

Book 4, Number 2123:

    'Abbad b. 'Abdullah b. Zubair reported that 'A'isha ordered the bier of Sa'd b. Abu Waqqas to be brought into the mosque so that she should pray for him. The people disapproved this (act) of hers. She said: How soon the people have forgotten that the Messenger of Allah (may peace be upon him) offered not the funeral prayer of Suhail b al-Baida' but in a mosque.

Book 4, Number 2124:

    'Abbad b. 'Abdullah b. Zubair reported on the authority of 'A'isha that when Sa'd b. Abu Waqqas died, the wives of the Apostle of Allah (may peace be upon him) sent message to bring his bier into the mosque so that they should offer prayer for him. They (the participants of the funeral) did accordingly, and it was placed in front of their apartments and they offered prayer for him. It was brought out of the door (known as) Bab al-Jana'iz which was towards the side of Maqa'id, and the news reached them (the wives of the Holy Prophet) that the people bad criticised this (i.e. offering of funeral prayer in the mosque) saying that it was not desirable to take the bier inside the mosque. This was conveyed to 'A'isha. She said: How hastily the people criticise that about which they know little. They criticise us for carrying the bier in the mosque. The Messenger of Allah (may peace be upon him) offered not the funeral prayer of Suhail b. Baida' but in the innermost part of the mosque.

Book 4, Number 2125:

    Abu Salama b. 'Abd al-Rahman reported on the authority ot 'A'isha that when Sa'd b. Abu Waqqas died she said: Bring it (the bier) into the mosque so that I offer prayer for him. But, this act of hers was disapproved. She said: By Allah, the Messenger of Allah (may peace be upon him) offered prayer in the mosque for the two sons of Baida', viz, for Suhail and his brother.

Chapter 202 : WHAT IS TO BE SAID WHILE VISITING THE GRAVEYARD AND THE SUPPLICATION TO BE OFFERED FOR THE DEAD LYING IN THE GRAVES

Book 4, Number 2126:

    'A'isha reported (that whenever it was her turn for Allah's Messenger [may peace be upon him] to spend the night with her) he would go out towards the end of the night to al-Baqi' and say: Peace be upon you, abode of a people who are believers. What you were promised would come to you tomorrow, you receiving it after some delay; and God willing we shall join you. O Allah, grant forgiveness to the inhabitants of Baqi' al-Gharqad. Qutaiba did not mention his words: "would come to you".

Book 4, Number 2127:

    Muhammad b. Qais said (to the people): Should I not narrate to you (a hadith of the Holy Prophet) on my authority and on the authority of my mother? We thought that he meant the mother who had given him birth. He (Muhammad b. Qais) then reported that it was 'A'isha who had narrated this: Should I not narrate to you about myself and about the Messenger of Allah (may peace be upon him)? We said: Yes. She said: When it was my turn for Allah's Messenger (may peace be upon him) to spend the night with me, he turned his side, put on his mantle and took off his shoes and placed them near his feet, and spread the corner of his shawl on his bed and then lay down till he thought that I had gone to sleep. He took hold of his mantle slowly and put on the shoes slowly, and opened the door and went out and then closed it lightly. I covered my head, put on my veil and tightened my waist wrapper, and then went out following his steps till he reached Baqi'. He stood there and he stood for a long time. He then lifted his hands three times, and then returned and I also returned. He hastened his steps and I also hastened my steps. He ran and I too ran. He came (to the house) and I also came (to the house). I, however, preceded him and I entered (the house), and as I lay down in the bed, he (the Holy Prophet) entered the (house), and said: Why is it, O 'A'isha, that you are out of breath? I said: There is nothing. He said: Tell me or the Subtle and the Aware would inform me. I said: Messenger of Allah, may my father and mother be ransom for you, and then I told him (the whole story). He said: Was it the darkness (of your shadow) that I saw in front of me? I said: Yes. He struck me on the chest which caused me pain, and then said: Did you think that Allah and His Apostle would deal unjustly with you? She said: Whatsoever the people conceal, Allah will know it. He said: Gabriel came to me when you saw me. He called me and he concealed it from you. I responded to his call, but I too concealed it from you (for he did not come to you), as you were not fully dressed. I thought that you had gone to sleep, and I did not like to awaken you, fearing that you may be frightened. He (Gabriel) said: Your Lord has commanded you to go to the inhabitants of Baqi' (to those lying in the graves) and beg pardon for them. I said: Messenger of Allah, how should I pray for them (How should I beg forgiveness for them) ? He said: Say, Peace be upon the inhabitants of this city (graveyard) from among the Believers and the Muslims, and may Allah have mercy on those who have gone ahead of us, and those who come later on, and we shall, God willing, join you.

Book 4, Number 2128:

    Sulaiman b. Buraida narrated on the authority of his father that the Messenger of Allah (may peace be upon him) used to teach them when they went out to the graveyard. One of the narrators used to say this in the narration transmitted on the authority of Abu Bakr: "Peace be upon the inhabitants of the city (i.e. graveyard)." In the hadith transmitted by Zuhair (the words are): "Peace be upon you, the inhabitants of the city, among the believers, and Muslims, and God willing we shall join you. I beg of Allah peace for us and for you."

Chapter 203 : THE APOSTLE OF ALLAH (MAY PEACE BE UPON HIM) SEEKING PERMISSION FROM THE LORD, THE EXALTED AND HIGH, FOR VISITING THE GRAVE OF HIS MOTHER

Book 4, Number 2129:

    Abu Huraira reported Allah's Messenger, (may peace be upon him) as saying: I sought permission to beg forgiveness for my mother, but He did not grant it to me. I sought permission from Him to visit her grave, and He granted it (permission) to me.

Book 4, Number 2130:

    Abu Huraira reported: The Apostle of Allah (may peace be upon him) visited the grave of his mother and he wept, and moved others around him to tears, and said: I sought permission from my Lord to beg forgiveness for her but it was not granted to me, and I sought permission to visit her grave and it was granted to motel So visit the graves, for that makes you mindful of death.

Book 4, Number 2131:

    Ibn Buraida reported on the authority of his father that the Messenger of Allah (may peace be upon him) said: I forbade you to visit graves, but you may now visit them; I forbade you to eat the flesh of sacrificial animals after three days, but you way now keep it as along as you feel inclined; and I forbade you nabidh except in a water-skin, you may drink it from all kinds of water-skins, but you must not drink anything intoxicating.

Book 4, Number 2132:

    This hadith has been narrated through another chain of transmitters.

Chapter 204 : ABANDONING OF FUNERAL PRAYER FOR HIM WHO COMMITTED SUICIDE

Book 4, Number 2133:

    Jabir b. Samura reported: (The dead body) of a person who had killed himself with a broad-headed arrow was brought before the Apostle of Allah (may peace be upon him), but he did not offer prayers for him.


BOOK 5: The Book of Zakat (Kitab Al-Zakat)

KITAB AL-ZAKAT
THE BOOK OF ZAKAT

Back
INTRODUCTION

    Of the five fundamentals of Islam, Zakat occupies the second positioin, the first being prayer (salat). This word is derived from Zakd, which means it (a plant) grew. The second derivative of this word carries the sense of purificatin, e.g. Qad aflaha man zakkaha (he is indeed successful who purified himself). The other word used for zakat both in the Qur'an and the Hadith is sadaqa which is derived from sidq (the truth). Both these words are highly meaningful. The spending of wealth for the sake of Allah purifies the heart of man of the love of material wealth. The man who spends it offers that as a humble gift before the Lord and thus affirms the truth that nothing is dearer to him in life than the love of Allah and that he is full prepared to sacrifice everything for His sake. Secondly, zakat is the most effective measure to improve the economic condition of the have-nots. It is not, however, a mere tax, but a form of worship whereby a man comes close to his Lord. The Muslims have, therefore, been enjoined to pay zakat with the same sense of earnestness and devotion in which the seeker of the Lord observes the prayer. The primary motive of zakat is religious and spiritual, while the social and economic aspects are subservient to it. Its social significance is that it awakens in man the sense of brotherhood with less fortunate members of society, and stirs his moral conscience to make sacrifice for their sake. From the economic point of view it discourages hoarding and concentration of wealth and helps its steady and constant flow from the rich to the poor. It is in fact a good means of providing purchasing power to the poor, for ameliorating their hard lot and enabling them to stand on their own legs.

    It should also be remembered that zakat or sadaqa in Islam is not a voluntary act of charity which a rich man gives to the poor out of his own sweet will, but it is an obligatory act which every Muslim is enjoined upon to perform if he is sincere in his belief in God and the Hereafter. Thus there is no burden of obligation on one who receives zakat, but a sense of thankfulness and gratitude on the part of the giver, since he has been enabled by the recipient to discharge his obligation that he owes to God and society.

      (O Prophet), take sadaqa (zakat) out of their property-thou wouldst cleanse them and purify them thereby (Qur'an, ix. 103). And away from it (the Hell) shall be kept the most faithful to duty who gives his wealth, purifying himself (xcii. 17-18).

    So much is the importance of zakat in Islam that it has been mentioned at eightytwo places in the Qur'an in close connection with prayer. The Companions of the Holy Prophet (may peace be upon him) knew its basic importance in Islam. It is a known fact that after the death of the Apostle of Allah (may peace he upon him) when some of the tribes, who believed in the oneness of God and observed prayer, refused to pay zakat, the first Caliph Abu Bakr Siddiq (Allah be pleased with him), in an answer to the advice of Hadrat 'Umar (Allah be pleased with him) to show tolerance towards such people. said in explicit terms, By Allah, I would definitely wage war against them who dissociate prayer from Zakat. Zakat is paid on the surplus of wealth which is left over after the passage of a year. It is thus a payment on the accumulated wealth. Leaving aside animals and agricultural yield, zakat is paid at almost a uniform rate of two and a half %. The minimum standard of surplus wealth over which zakat is charged is known as Nisab. It differs with different kinds of property, the most important being 200 dirhams or 521 tolas (nearly 21 oz.) In case of silver, and 20 mithqals or 71 tolas (nearly 3 oz.) in case of gold. The nisab of cash is the same as that of gold and silver.

    As regards the persons to whom zakat is to be paid, they have been clearly described in the Holy Qur'an: Alms are only for the poor, the needy, the officials charged with the duty of collection, those whose hearts are inclined to truth, the ransoming of captives, those in debt, in the way of Allah, and the wayfarer (ix 60).

Chapter 1 : ...

Book 5, Number 2134:

    Abu Sa'id al-Khudri reported Allah's Messenger (way peace be upon him) as saying: No sadaqa (zakat) is payable on less than five wasqs of (dates or grains), on less than five camel-heads and on less than five uqiyas (of silver).

Book 5, Number 2135:

    A hadith like this has been narrated by 'Amr b. Yahya with the same chain of transmitters.

Book 5, Number 2136:

    'Umara reported: I heard Abd Sa'id al-Khudri as saying that he had heard Allah's Messenger (may peace be upon him) make (this) observation with a gesture of his five fingers, and then he narrated the hadith as transmitted by 'Uyaina (hadith 2134).

Book 5, Number 2137:

    Abu Sa'id al-Khudri reported Allah's Messenger (may peace be upon him) as saying: Sadaqa (zakat) is payable on less than five wasqs of (dates or grains), on less than five camel-heads, and on less than five uqiyas (of silver).

Book 5, Number 2138:

    Abu Sa'id al-Khudri reported Allah's Messenger (may peace be upon him) as saying: No Sadaqa is payable on less than five wasqs of dates or grains.

Book 5, Number 2139:

    Abu Sa'id al-Khudri reported Allah's Messenger (may peace be upon him) as saying: No Sadaqa is payable on the grains and dates till it (comes to the Weight) of five wasqs, or less than five heads of camels, or less than five uqiyas (of silver).

Book 5, Number 2140:

    A hadith like this has been narrated by Isma'il b. Umayya with the same chain of transmitters.

Book 5, Number 2141:

    A hadith like this has been narrated by Isma'il b. Umayya with the same chain of transmitters, but instead of the word dates, fruit has been used.

Book 5, Number 2142:

    Jabir b. 'Abdullah reported Allah's Messenger (may peace be upon him) as saying: No Sadaqa is payable on less than five fiqiyas of silver, and on less than five heads of camels, and less than five wasqs of dates.

Book 5, Number 2143:

    Jabir b. Abdullah reported Allah's Messenger (may peace be upon him) as saying: A tenth is payable on what is watered by rivers, or rains, and a twentieth on what is watered by camels.

Chapter 2 : NO ZAKAT IS DUE FROM A MUSLIM ON HIS SLAVE OR HIS HORSE

Book 5, Number 2144:

    Abu Huraira reported Allah's Messsenger (may peace be upon him) as saying: No Sadaqa is due from a Muslim on his slave or horse.

Book 5, Number 2145:

    Abu Huraira reported Allah's Messenger (may peace be upon him) as saying: No Sadaqa is due from a Muslim on his slave or horse.

Book 5, Number 2146:

    A hadith like this has been narrated by Abu Huraira through another chain of transmitters.

Book 5, Number 2147:

    Abu Huraira reported Allah's Messenger (may peace be upon him) as saying: There is no Sadaqa on a slave except Sadaqat-ul-Fitr.

Chapter 3 : SENDING OFF FOR THE PAYMENT OF ZAKAT AND OF REFUSING TO PAY IT

Book 5, Number 2148:

    Abu Huraira reported that the Messenger of Allah (may peace be upon him)sent Umar for (collecting) Sadaqa (zakat), and it was said that Ibn Jamil, Khalid b. Walid and 'Abbas the uncle of the Messenger of Allah (may peace be upon him), refused (to pay it). Upon this the Messenger of Allah (may peace be upon him) said: Ibn Jamil is taking revenge but for this that he was destitute and Allah made him rich. As regards Khalid, you are unjust to Khalid, for be reserved his armours and weapons for the sake of Allah, and as for 'Abbas, I shall be responsible for it and an equal amount along with it. And he again said: 'Umar, bear this in mind, the uncle of a person is like his father.

Chapter 4 : ZAKAT (SADAQA) FITR IS BINDING ON EVERY MUSLIM

Book 5, Number 2149:

    Ibn Umar said that Allah's Messenger (way peace be upon him) prescribed the payment of Zakat-ul-Fitr (on breaking the fast) of Ramadan for people, for every freeman, or slave, male and female among the Muslims-one sa' of dried dates, or one sa' of barley.

Book 5, Number 2150:

    Ibn 'Umar said that the Messenger of Allah (may peace be upon him) prescribed Zakat-ul-Fitr one sa' of dates or one sa' of barley for every slave or freeman, young or old.

Book 5, Number 2151:

    Ibn 'Umar said that the Apostle of Allah (may peace be upon him) prescribed the Sadaqa of Ramadan (Sadaqat-al-Fitr) one sa' of dates or one sa' of barley for every free man or a slave, male or female, and then the people equalised (one sa' of dates or barley) with half a sa' of wheat.

Book 5, Number 2152:

    Abdullah b. Umar reported that the Messenger of Allah (may peace be upon him) ordered the (payment of) Zakat-ul-Fitr one sa' of dates, or one sa' of barley. Ibn 'Umar ('Abdullah b. 'Umar) further said: The people equalised it (then) with two mudds of fine wheat.

Book 5, Number 2153:

    Ibn Umar reported that the Messenger of Allah (may peace be upon him) prescribed Zakat-ul-Fitr of Ramadan one sa' of dates or one sa' of barley for every individual among the Muslims (whether) free man or slave, male or female, young or old.

Book 5, Number 2154:

    Sad b. Abu Sarh heard Abu Sa'id al-Khudri as saying: We used to take out as the Zakat of Fitr one sa' of grain, or one sa' of barley or one sa' of dates, or one sa' of cheese or one sa' of raisins.

Book 5, Number 2155:

    Abd Sa'id al-Khudri reported: We, on behalf of every young or old, free man or slave (amongst us), used to take out during the lifetime of the Messenger of Allah (may peace be upon him) as the Zakat of Fitr one sa' of grain, or one sa' of cheese or one sa' of raisins. And we continued taking out these till Mu'awiya b. Abu Sufyan came to us for pilgrimage or 'Umra, and addressed the people on the pulpit and said to them: I see that two mudds of zakat out of the wheat (red) of Syria is equal to one sa' of dates. So the people accepted it. But Abu Sa'id said: I would continue to take out as I used to take out (before, i e. one sa') as long as I live.

Book 5, Number 2156:

    Sa'd b. Abu Sarh heard Abu Sa'id al-Khudri as saying: We, on behalf of young or old, free or slave, used to take out the Zakat of Fitr while the Messenger of Allah (may peace he upon him) was among us, in three kinds, one sa' of dates, one sa' of cheese, or one sa' of barley, and we continued to take that out till the time of Mu'awiya, for he saw that two mudds of wheat were equal to one sa' of dates . Abu Sa'id sald: I would continue to take that out as before (i e. one sa' of wheat).

Book 5, Number 2157:

    Abu Sa'id al Khudri reported: We used to take out the Zakat of Fitr in three kinds, cheese, dates and barley.

Book 5, Number 2158:

    Abu Sa'id al-Khudri reported that when Mu'awiya prescribed half a sa' of wheat equal to one sa' of dates, he (Abu Sa'id al-Khudri) objected to it, and said: I would take out (Sadaqat-ul-Fitr) but that which I used to bring forth during the lifetime of the Messenger of Allah (may peace be upon him) one sa' of dates, or one sa' of raisins, or one sa' of barley, or one sa' of cheese.

Chapter 5 : TAKING OUT OF SADAQAT-UL-FITR BEFORE OBSERVING FITR PRAYER

Book 5, Number 2159:

    Ibn 'Umar reported that the Messenger of Allah (may peace be upon him) ordered that the Sadaqat-ul-Fitr should be paid before the people go out for prayer.

Book 5, Number 2160:

    Abdullah b 'Umar reported that the Messenger of Allah (may peace be upon him) ordered the payment of Sadaqat-ul-Fitr before people go out for prayer.

Chapter 6 : SIN OF ONE WHO DOES NOT PAY ZAKAT

Book 5, Number 2161:

    Abu Huraira reported Allah's Messenger (way peace be upon him) as saying: If any owner of gold or silver does not pay what is due on him, when the Day of Resurrection would come, plates of fire would be beaten out for him; these would then be heated in the fire of Hell and his sides, his forehead and his back would be cauterized with them. Whenever these cool down, (the process is) repeated during a day the extent of which would be fifty thousand years, until judgment is pronounced among servants, and he sees whether his path is to take him to Paradise or to Hell. It was said: Messenger of Allah, what about the camel? He (the Holy Prophet) said: If any owner of the camel does not pay what is due on him, and of his due in that (camel) is (also) to milk it on the day when it comes down to water. When the Day of Resurrection comes a soft sandy plain would be set for him, as extensive as possible, (he will find) that not a single young one is missing, and they will trample him with their hoofs and bite him with their mouths. As often as the first of them passes him, the last of them would be made to return during a day the extent of which would be fifty thousand years, until judgment is pronounced among servants and he sees whether his path is to take him to Paradise or to Hell. It was (again) said: Messenger of Allah, what about cows (cattle) and sheep? He said: It any owner of the cattle and sheep does not pay what is due on them, when the Day of Resurrection comes a soft sandy plain would be spread for them, he will find none of them missing, with twisted horns, without horns or with a broken horn, and they will gore him with their horns and trample him with their hoofs. As often as the first of them passes him the last of them would be made to return to him during a day the extent of which would be fifty thousand years, until judgment would be pronounced among the servants. And he would be shown his path-path leading him to Paradise or to Hell. It was said: Messenger of Allah, what about the horse? Upon this he said: The horses are of three types. To one than (these are) a burden, and to another man (these are) a covering, and still to another man (these are) a source of reward. The one for whom these are a burden is the person who rears them in order to show off, for vainglory and for opposing the Muslims; so they are a burden for him. The one for whom these are a covering is the person who rears them for the sake of Allah but does not forget the right of Allah concerning their backs and their necks, and so they are a covering for him. As for those which bring reward (these refer to) the person who rears them for the sake of Allah to be used for Muslims and he puts them in meadow and field. And whatever thing do these eat from that meadow and field would be recorded on his behalf as good deeds, as would also the amount of their dung and urine. And these would not break their halter and prance a course or two without having got recorded the amount of their hoof marks and their dung as a good deed on his behalf (on behalf of their owner). And their master does not bring them past a river from which they drink, though he did not intend to quench their thirst, but Allah would record for him the amount of what they drink on his behalf as deeds. It was said: Messenger of Allah, what about the asses?, Upon this he said: Nothing has been revealed to me in regard to the asses (in particular) except this one verse of a comprehensive nature: "He who does an atom's weight of good will see it, and he who does an atom's weight of evil will see it" (xcix. 7)

Book 5, Number 2162:

    This hadith has been narrated by Zaid b. Aslam with the same chain of transmitters except that he said: "None among the owners of camels who does not pay their due," but did not say "their due (Zakat) out of them." and he make a mention: "He did not miss a single young one out of them." and he said: "Their sides. their foreheads and their backs would be cauterised."

Book 5, Number 2163:

    Abu Huraira reported Allah's Messenger (may peace be upon him) as saying: No owner of the treasure who does not pay Zakat (would be spared) but (his hoards) would be heated in the Fire of Hell and these would be made into plates and with these his sides, his forehead would be cauterised till Allah would pronounce judgment among His servants during a day, the extent of which would be fifty thousand years. He would then see his path, leading either to Paradise or to Hell. And no owner of the camels who does not pay Zakat (would be spared) but a soft sandy plain would be set for him and they (the camels) would be made to pass over him till the last of them would be made to return till Allah would pronounce judgment among His servants during a day the extent of which would be fifty thousand years. He would then see his path leading him to Paradise or leading him to Hell. And no owner of the (cattle and) goats who does not pay Zakat (would be spared) but a soft sandy plain would be set for him, he would find none of them missing, with twisted horns, without horns, or with broken horns, and they will gore him with their horns and trample him with their hoofs and they would be made to pass over him till the last of them would be made to return till Allah would pronounce judgment among His servants, during a day the extent of which would be fdty thousand years, and he would see the paths leading to Paradise or to Hell. Suhail said: I do not know whether he made mention of the cows. They said: Messenger of Allah(may peace be upon him), what about the horses? He said: The horses have goodness in their foreheads (or he said) or goodness is ingrained in the foreheads of the horses (Suhail said: I am in doubt as to what was actually said) up till the Day of judgement. The horses are of three kinds. They are a source of reward to a person, they are a covering to a person, and they are a burden to a person. As for those which bring reward is that a person would get reward who rears them for the sake of Allah and trains them for Him, and nothing disappears in their stomachs but Allah would record for him a good deed. And if they were to graze in the meadow, they would eat nothing but Allah would record for him a reward. And if they were to drink water from the canal, with every drop that, would disappear in their stomachs there would be reward (for the owner). He went on describing till a reward was mentioned for their urine and dung. And if they pranced a course or two, there would be recorded a reward for every pace that they covered. As for one for whom they are a covering, he is the man who rears them for honour and dignity but does not forget the right of their backs and their stomachs, in plenty and adversity, As regards one for whom they are a burden, he is that who rears them for vainglory and showing off to the people; for him they are, the burden. They said: Messenger of Allah, what about asses? He said: Allah has not revealed to me anything in regards to it except this one comprehensive verse : "He who does an atom's weight of good will see it, and he who does an atom's weight of evil will see it" (xcix. 7).

Book 5, Number 2164:

    This hadith has been narrated by Suhail b. Abu Salih with the same chain of transmitters, and he said he substituted the word aqsa' with 'adba' and said: "his side and his back," but he made no mention of his forehead.

Book 5, Number 2165:

    This hadith has been narrated by Abu Huraira through another chain of transmitters: The Messenger of Allah (may peace be upon him) said: "When a person does not pay what is due to Allah or Sadaqa of his camels. . . . " The rest of the hadith is the same.

Book 5, Number 2166:

    Jabir b. 'Abdullah al-Ansari reported Allah's Messenger (may peace be upon him) as saying: The owner of a camel who does not pay what is due on it (would be punished in this way) that on the Day of Resurrection many more (along with his camel) would come and the owner would be made to sit on a soft sandy ground and they would trample him with their feet and hooves. And no owner of the cattle who does not pay what is due on them (would be spared the punishment) but on the Day of Resurrection, many more would come and he (the owner) would be made to sit on the soft sandy ground and would be gored by their horns and trampled under their feet. And no owner of the goats and sheep who does not pay what is due on them (would be spared of punishment) but many more would come on the Day of Resurrection and he (the owner) would be made to sit on a soft sandy ground and they would gore him with their horns and trample him under their hooves. And there would be more (among this flock of sheep and goat) without horns or with broken horns. And no owner of the treasure who does not pay its due but his treasure would come on the Day of Resurrection like a bald snake and would pursue him with its mouth open, and when it would come near he would run away from it, and he would be called thus: "Take your treasure which you concealed, for I do not need it." When he would find no way out he would put his hand in its mouth and it would gnaw it like a he-camel. Abu Zubair said: We heard Ubaid b. Umair saying this. We then asked Jabir b. 'Abdullah about this. And he also said like Ubaid b. Umair, Abu Zubair said: I heard 'Ubaid b. 'Umair saying: A man said: Messenger of Allah, what is due on camels? He said: Milking them near water, and lending of bucket (used for drawing water from it), or lending its male for mating with a she-camel and providing it as a ride for the sake of Allah.

Book 5, Number 2167:

    Jabir b. Abdullah reported the Apostle of Allah (may peace be upon him) as saying: No owner of camels or cattle or flock of sheep or goats who does not pay his due (would be spared punishment) but would be made to sit on the Day of Resurrection on a soft sandy ground and the hoofed animals would trample him with their hoofs and gore him with their horns. And none of them on that day would be without horns, or with broken horns. We said: Messenger of.Allab, but what is due on them? He said: Lending of the male (for use) and lending of the bucket (used for drawing water for them) and for mating and milking them near water and providing them as a ride for the sake of Allah. And no owner of the property who does not pay Zakat (would be spared punishment) but it (his property) would turn into a bald snake and would follow its owner wherever he would go, and he would run away from it, and it would be said to him: That is your property about which you were stingy. And when he would find no other way out he would thrust his hand in its mouth and it would gnaw it like a male camel.

Chapter 7 : PLEASING OF THE COLLECTOR

Book 5, Number 2168:

    Jabir b. 'Abdullah reported: There came people from among the Bedouins to the Messenger of Allah (may peace be upon him) and said: Collectors of Sadaqa come to us and treat us unjustly. Upon this the Messenger of Allah (may peace be upon him) said: Please your collectors. Jarir said: Ever since I heard it from the Messenger of Allah (may peace be upon him) no collector had departed but was pleased with me.

Book 5, Number 2169:

    This hadith has been narrated by Muhammad b. Isma'il with the same chain of transmitters.

Chapter 8: THE GRAVITY OF PUNISHMENT FOR ONE WHO DOES NOT PAY ZAKAT

Book 5, Number 2170:

    Abu Dharr reported: I went to the Apostle of Allah (may peace be upon him) and he was sitting under the shade of the Ka'ba. As he saw me he said: By the Lord of the Ka'ba, they are the losers. I came there till I sat and I could not stay (longer) and (then) stood up. I said: Messenger of Allah, let my father, be ransom for you, who are they (the losers)? He said: They are those having a huge amount of wealth except so and so and (those who spend their wealth generously on them whom they find in front of them, behind them and on their right side and on their left side) and they are a few. And no owner of camels, or cattle or goat and sheep, who does not pay Zakat (would be spared punishment) but these (camels, cattle, goats and sheep) would come on the Day of Resurrection wearing more flesh and would gore him with their horns and trample them with their hooves. And when the last one would pass away, the first one would return (to trample him) till judgment would be pronounced among people.

Book 5, Number 2171:

    Abu Dbarr reported: I went to the Apostle of Allah (may peace be upon him) and he was sitting under the shade of the Ka'ba, and the rest of the hadith it the same but for this that he (the Holy Prophet) said: "By Allah, in Whose hand is my life, no person on earth who dies and leaves behind camels, or cattle or goat and sheep, and does not pay Zakat (would be spared the punishment)."

Book 5, Number 2172:

    Abu Huraira reported that the Prophet (may peace be upon him) said: Nothing is more delighting to me than this that Uhud should be of gold for me, and no dinar is left with me out of it before three nights pass except a dinar which I would set aside for the repayment of debt upon me.

Book 5, Number 2173:

    Abu Huraira reported the same from the Prophet (may peace be upon him).

Chapter 9 : EXHORTATION TO GIVE SADAQA

Book 5, Number 2174:

    Abu Dharr reported: I walked with the Messenger of Allah (may peace be upon him) on the stony ground of Medina in the afternoon and we were looking at Uhud. The Messenger of Allah (way peace by upon him) said : Abu Dharr ! I said: Messenger of Allah, I am here at thy beck and call. He said: What I desire is that Uhud be gold with me and three nights should pass and there is left with me any dinar but one coin which I would keep to pay debt. (I love) to spend it among the servants of Allah like this and he pointed in front of him, and on his right side and on his left side. We then proceeded on and he said: Abu Dharr. I said: At thy beck and call, Messenger of Allah. He (the Holy Prophet) said: The rich would be poor on the Day of Resurrection, but he who spent like this and like this and like this, and he pointed as at the first time. We again went on when he said. Abu Dharr, stay where you are till I come back to you. He (the Holy Prophet) then moved on till he disappeared from my sight He (Abu Dharr) said: I heard a sound and I heard a noise. I said (to myself): The Messenger of Allah (may peace be upon him) might have met (mishap or an enemy). I wished to follow him but I remembered his command for not departing till he would come back. So I waited for him, and when he came I made a mention of what I heard. He said: it was Gabriel, who came to me and said: "He who dies among your Ummah without associating Anything with Allah would enter Paradise. I said: Even if he committed fornication or theft? He said: Even if he committed fornication or theft.

Book 5, Number 2175:

    Abu Dharr reported: I went out one night (and found) the Messenger of Allah (may peace be upon him) walking all alone. There was no man with him. I thought that he did not like anyone walking along with him. So I began to walk in the light of the moon. He, however turned his attention to me and saw me and said: Who is this? I said: It is Abu Dharr. Let Allah make me as ransom for you. He said: Abu Dharr, come on. He (Abu Dharr) said: So I walked along with him for some time and he said: The wealthy persons would have little (reward) on the Day of Resurrection, except upon whom Allah conferred goodness (wealth). He dispensed it to his right, left, in front of him and at his back (just as the wind diffuses fragrance) and did good with it (riches). I went along with him for some time when He said: Sit here. And he made me sit at a safe place and there were stones around it, and he said to me: Sit here till I come to you. He went away on the stony ground till I could not see him. He stayed away from me, and he prolonged his stay. Then I heard him as he came back and he was saying: Even if he committed theft and even if he committed fornication. When he came I could not help asking him: Apostle of Allah, let Allah make me ransom for you, whom were you speaking on the stony ground? I heard nobody responding to you. He (the Holy Prophet) said: It was Gabriel who met me by the side of the stony ground and said: Give glad tidings to your Ummah that he who died without associating ought with Allah would go into Paradise. I said: Gabriel, even if he committed theft and fornication ? He said : Yes. I said : Even it he committed theft and fornication? He said: Yes, I again said: Even if he committed theft and fornication? He said: Yes, even if he drank wine.

Chapter 10 : HOARDERS OF WEALTH AND PUNISHMENT TO THEM

Book 5, Number 2176:

    Ahnaf b. Qais reported : I came to Medina and when I was in the company of the grandees of Quraish a man with a crude body and an uncouth face wearing coarse clothes came there. He stood up before them and said: Give glad tidings to those whom who amass riches of the stones which would be heated in the Fire of Hell, and would be placed at the tick of the chest till it would project from the shoulder bone and would he put on the shoulder bone till it would project from the tick of his chest, and it (this stone) would continue passing and repassing (from one side to the other). He (the narrator) said: Then people hung their heads and I saw none among them giving any answer. He then returned and I followed him till he sat near a pillar. I said: I find that these (people) disliked what you said to them and they do not understand anything. My friend Abu'l-Qasim (Muhammad) (may peace he upon him) called me and I responded to him, and he said: Do you see Uhud? I saw the sun (shining) on me and I thought that he would send me on an errand for him. So I said: I see it. Upon this he said: Nothing would delight me more than this that I should have gold like it (equal to the bulk of Uhud), and I should spend it all except three dinars. (How sad it is) that they hoard worldly riches, and they know nothing. I said: What about you and your brothers Quraish? You do not go to thein for any need and do not accept anything from them. He said: By Allah, I neither beg anything from them (from worldly goods), nor do I ask them anything about religion till I meet my Allah and His Messenger.

Book 5, Number 2177:

    Ahnaf b. Qais reported: While I was in the company of the (elites) of Quraiah, Abu Dharr came there and he was saying: Give glad tidings to the hoarders of riches that their backs would be branded (so deeply) that (the hot Iron) would come out of their sides, and when the backs of their necks would be branded, it would come out of their foreheads. He (Abu Dharr) then went away and sat down. I asked who he was. They said: He is Abu Dharr. I went to him and said to him: What is this that I heard from you which you were saying before? He said : I said nothing but only that which I heard from their Prophet (may peace be upon him). I again said: What do you say about this gift? He said: Take it, for today it is a help. But when it becomes a price for your religion, then abandon it.

Chapter 11 : EXHORTATION TO SPEND AND TIDINGS TO HIM WHO SPENDS (ON GOOD DEEDS)

Book 5, Number 2178:

    Abu Huraira reported Allah's Messenger (may peace be upon him) as saying that Allah, the Most Blessed and High, said: O son of Adam, spend. I will spend on you. The right hand of Allah is full and overflowing and in nothing would diminish it, by overspending day and night.

Book 5, Number 2179:

    Abu Huraira reported Allah's Messenger (may peace be upon him) as saying that Allah said to him: "Spend, I will bestow upon you." And the Messenger of Allah (may peace be upon him) said: The right hand of Allah is full and spending (the riches) liberally during day and night will not diminish (the resources of Allah). Don't you see what (an enormous amount of resources) He has spent since He created the heaven and the earth, and what is in His right hand has not decreased? His Throne is upon the water. And in His other hand is death, and He elevates and degrades (whom He likes).

Chapter 12 : EXCELLENCE OF SPENDING ON ONE'S FAMILY, AND SERVANT, AND SIN OF ONE WHO NEGLECTS OR WITHHOLDS THEIR SUBSISTENCE

Book 5, Number 2180:

    Thauban reported Allah's Messenger (may peace be upon him) as saying: The most excellent dinar is one that a person spends on his family, and the dinar which he spends on his animal in Allah's path, and the dinar he spends on his companions in Allah's path. Abu Qilaba (one of the narrators) said: He (the narrator) started with family, and then Abu Qilaba said: Who is the person with greater reward than a person who spends on young members of his family (and thus) preserves (saves them from want) (and by virtue of which) Allah brings profit for them and makes them rich.

Book 5, Number 2181:

    Abu Huraira reported Allah's Messenger (may peace be upon him) as saying: Of the dinar you spend as a contribution in Allah's path, or to set free a slave, or as a sadaqa given to a needy, or to support your family, the one yielding the greatest reward is that which you spent on your family.

Book 5, Number 2182:

    Khaithama reported: While we were sitting in the company of 'Abdullah b. 'Umar there came in his steward. He (Ibn 'Umar) said: Have you supplied the provision to the slaves? He said: No. Upon this he said: Go and give (the provision) to them, for the Messenger of Allah (may peace be upon him) has said: This sin is enough for a man that he withholds the subsistence from one whose master he is.

Chapter 13 : BEGINNING OF SPENDING FOR ONE'S OWN SELF, THEN FOR ONE'S FAMILY AND THEN FOR RELATIVES

Book 5, Number 2183:

    Jabir reported: A person from the Banu 'Udhra set a slave free after his death. This news reached the Messenger of Allah (may peace be upon hhn).Upon this he said: Have you any property besides it? He said: No. Upon this he said: Who would buy (this slave) from me? Nulaim b. Abdullah bought it for eight hundred dirhams and (this amount was) brought to the Messenger of Allah (may peace be upon him) who returned it to him (the owner), and then said: Start with your own self and spend it on yourself, and if anything is left, it should be spent on your family, and if anything is left (after meeting the needs of the family) it should be spent on relatives, and if anything is left from the family, it should be spent like this, like this. And he was saying: In front of you, on your right and on your left.

Book 5, Number 2184:

    Jabir reported that a person among the Ansar who was called Abu Madhkur granted posthumous freedom to his slave who was called Ya'qub. The rest of the hadith is the same.

Chapter 14 : EXCELLENCE OF SPENDING AND GIVING SADAQA TO RELATIVES, TO WIFE, TO CHILDREN, AND PARENTS EVEN IF THEY ARE POLYTHEISTS

Book 5, Number 2185:

    Anas b. Malik is reported as saying: Abu Talha was the one among the Ansar of Medina who possessed the largest property and among his property he valued most was his garden known as Bairaha' which was opposite the mosque, and the Messenger of Allah (may peace be upon him) often visited it and he drank of its sweet water. When this verse was revealed: "You will never attain righteousness till you give freely of what you Have" (iii. 91), Abu Talha got up and, going to Allah's Messenger (may peace be upon him), said: Allah says in His Book: "You will never attain righteousness till you give freely of what you love," and the dearest of my property is Bairaha' so I give it as Sadaqa to God from Whom I hope for reward for it and the treasure with Allah; so spend it, Messenger of Allah, on whatever purpose you deem it proper. The Messenger of Allah (may peace be upon him) said: Bravo I that is profit earning property. I have heard what you have said, but I think you should spend it on your nearest relatives. So Abu Talha distributed it among the neatest relatives and his cousins on his father's side.

Book 5, Number 2186:

    Anas reported that when this verse was tevealed: "You will not attain righteousness till you give freely of what you love," Abu Talha said: I see that our Lord has demanded from us out of our property; so I make you a witness, Messenger of Allah. that I give my land known as Bairaha' for the sake of Allah. Upon this the Messenger of Allah (may peace be upon him) said: Give that to your relatives. So he gave it to Hassan b. Thabit and Ubayy b. Ka'b.

Book 5, Number 2187:

    Maimuna bint Harith reported that she set free a slave-girl during the lifetime of the Messenger of Allah (may peace be upon him) and she made a mention of that to the Messenger of Allah (may peace be upon him) and he said: Had you gives her to your maternal uncles, you would have a greater reward.

Book 5, Number 2188:

    Zainab, the wife of 'Abdullah(b. Mas'ud ), reported that the Messenger of Allah (may peace be upon him) said: 0 women, give sadaqa even though it be some of your jewellery. She returned to 'Abdullah and said: You are a person with empty hands, whereas the Messenger of Allah (may peace be upon him) has commanded us to give sadaqa, so better go to him and ask and if this will suffice for me; otherwise I shall give it to someone else. 'Abdullah said to me (his wife): You better go yourself. So I went and there was another woman of the Ansar at the door of the Messenger of Allah (may peace be upon him) having the same porpose as I had. Now Allah's Messenger (may peace be upon him) was invested with awe (so we did not like to knock). Then Bilal came out and we said to him: Go to the Messenger of Allah (may peace be upon him) and inform him that there are two women at the door asking him whether it will serve them to give sadaqa to their spouses and to orphans who are under their charge, but do not inform him who we are. Bilal went to the Messenger of Allah (may peace be upon him) and asked him (what these women had instructed him to ask). The Messenger of Allah (may peace be upon him) asked him who these women were. He (Bilal) said: They are women from Ansar and Zainab. Upon this the Messenger of Allah (may peace be upon him) said: Which of the Zainabs? He said: The wife of 'Abdullah. The Messenger of Allah (may peace be upon him) said: There are two rewards for them, the reward of kinship and the reward of Sadaqa.

Book 5, Number 2189:

    A hadith like this has been narrated on the authority of Zainab the wife of 'Abdullah, and she said: I was in the mosque and the Prophet of Allah (may peace be upon him) saw me and said: Give Sadaqa even though it is out of your jewellery. The rest of the hadith is the same.

Book 5, Number 2190:

    Umm Salama said: I asked the Messenger of Allah (may peace be upon him) whether there is a reward for me if I spend oh Abu Salama's sons, and I am not going to abandon them in this state (of helplessness) for they are my sons. He (the Holy Prophet) said: Yes. For you is the reward for what you spend on them.

Book 5, Number 2191:

    This hadith has been narrated by Ibn 'Urwa with the same chain of transmitters.

Book 5, Number 2192:

    Abu Mas'ud reported Allah's Messenger (way peace be upon him) as saying: When a Muslim spends on his family seeking reward for it from Allah, it counts for him as sadaqa.

Book 5, Number 2193:

    This hadith has been narrated by Shu'ba with the same chain of transmitters.

Book 5, Number 2194:

    Asma' daughter of Abu Bakr reported: I said: Messenger of Allah, my mother, who is inclined or scared has come to me. Should I (even An her position of being opposed to Islam) treat her well? He said: Yes.

Book 5, Number 2195:

    Asma' bint Abu Bakr reported: My mother who was a polytheist came to me when he (the Holy Prophet) entered into treaty with, the Quraish (of Mecca). I inquired from the Messenger of Allah (may peace be upon him) saying: Messenger of Allah, there has come to me my mother and she is inclined; should I (in this state of her mind) show her kindness? He said: Yes, treat her kindly.

Chapter 15 : GETTING OF REWARD FOR SADAQA FOR THE DEAD GIVEN ON HIS OR HER BEHALF

Book 5, Number 2196:

    'A'isha said that a person came to the Apostle of Allah (may peace be upon him) and said: My mother died suddenly without having made any will. I think she would have definitely given Sadaqa if she had been able to speak. Would she have a reward if I gave Sadaqa on her behalf? He (the Holy Prophet) said:Yes. This hadith has been narrated on the authority of Hisham with the same chain of transmitters. And in the hadith transmitted by Abu Usama the words are: "She did not make any will," as it has been reported by Ibn Bishr, but it was not reported by the rest of the narrators.

Chapter 16 : SADAQA INCLUDES ALL TYPES OF GOOD ACTS

Book 5, Number 2197:

    Hudhaifa and Abu Shaiba reported Allah's Messenger (may peace be upon him) as saying: Every act of goodness is sadaqa.

Book 5, Number 2198:

    Abu Dharr reported: some of the people from among the Companions of the Apostle of Allah (may peace be upon him) said to him: Messenger of Allah, the rich have taken away (air the) reward. They observe prayer as we do; they keep the fasts as we keep, and tray give Sadaqa out of their surplus riches. Upon this he (the Holy Prophet) said: Has Allah not prescribed for you (a course) by following which you can (also) do sadaqa? In every declaration of the glorification of Allah (i.e. saying Subhan Allah) there is a Sadaqa, and every Takbir (i.e. saying Allah-O-Akbar) is a sadaqa, and every praise of His (saying al-Hamdu Lillah) is a Sadaqa and every declaration that He is One (La illha ill-Allah) is a sadaqa, and enjoining of good is a sadaqa, and forbidding of that which is evil is a Sadaqa, and in man's sexual Intercourse (with his wife,) there is a Sadaqa. They (the Companions) said: Messenger of Allah, is there reward for him who satisfies his sexual passion among us? He said: Tell me, if he were to devote it to something forbidden, would it not be a sin on his part? Similarly, if he were to devote it to something lawful, he should have a reward.

Book 5, Number 2199:

    'A'isha reported Allah's Messenger (may peace be upon him) as saying: Every one of the children of Adam has been created with three hundred and sixty joints; so he who declares the Glory of Allah, praises Allah, declares Allah to be One, Glorifies Allah, and seeks forgiveness from Allah, and removes stone, or thorn, or bone from people's path, and enjoins what is good and forbids from evil, to the number of those three hundred and sixty-four, will walk that day haviing removed himself from Hell.

Book 5, Number 2200:

    This hadith has been narrated on the authority of Zaid with the same chain of transmitters except with (a slight) change of words (i.e. he [the Holy Prophet]) said: Or he enjoined what is good,. . . and said: He enters the evening [ie. he walks till eveningl.

Book 5, Number 2201:

    This hadith has been narrated by 'A'isha through anothr chain of transmitters in which she reported Allah's Messenger (may peace be ulon him) as saying: "Every man is created"; the rest of the hadith is the same and he said: "He walks on that day."

Book 5, Number 2202:

    Sa'id b. Abu Burda reported on the authority of his grandfather that the Apostle of Allah (may peace be upon him) said: Giving of Sadaqa is essential for every Muslim. It was said (to him): What do you say of him who does not find (the means) to do so? He said: Let him work with both his hands, thus doing benefit to himself and give Sadaqa. It was said to him: What about him who does not have (the means) to do so? He said: Then let him assist the needy, the aggrieved. It was said: What do you say of one who cannot even do this? He said: Then he should enjoin what is reputable or what is good. He said: What about him if he cannot do that? He (the Holy Prophet) said: He should then abstain from evil, for verify that is Sadaqa on his behalf.

Book 5, Number 2203:

    This hadith has been narrated by Shu'ba with the same chain of transmitters.

Book 5, Number 2204:

    Hammam b. Munabbih reported that-this is out of (those ahadith) which Abu Huraira narrated to us from Muhammad, the Messenger of Allah (may peace be upon him). And he while making a mention of ahadith reported from Allah's Messenger (may peace be upon him) said this: Sadaqa is due on every joint of a person, every day the sun rises. Administering of justice between two men is also a Sadaqa. And assisting a man to ride upon his beast, or helping him load his luggage upon it, is a Sadaqa; and a good word is a Sadaqa; and every step that you take towards prayer is a Sadaqa, and removing of harmful things from the pathway is a Sadaqa.

Chapter 17 : CONCERNING ONE WHO SPENDS AND WHO WITHHOLDS

Book 5, Number 2205:

    Abu Huraira reported Allah's Messenger (may peace be upon him) as saying: There is never a day wherein servants (of God) get up at morn, but are not visited by two angels. One of them says: 0 Allah, give him more who spends (for the sake of Allah), and the other says: 0 Allah, bring destruction to one who withholds.

Book 5, Number 2206:

    Haritha b. Wahb reported Allah's Messenger (may peace be upon him) as saying: Give Sadaqa for a time is about to come when a person would walk with alms and the one whom it is to be given would say: Had you brought it yesterday, I would have accepted it. For the present I do not need it. (And the giver of Sadaqa) I would not find anyone to accept it.

Book 5, Number 2207:

    Abu Musa reported Allah's Messenger (may peace be upon him) as saying: There would come a time for the people when a person would roam about with Sadaqa of gold, but he would find no one to accept it from him. And a man would be seen followed by forty women seeking refuge with him on account of the scarcity of males and abundance of females."

Book 5, Number 2208:

    Abu Huraira reported Allah's Messenger (way peace be upon him) as saying: The Last Hour will not come before wealth becomes abundant and overflowing, so much so that a man takes Zakat out of his property and cannot find anyone to accept it from him and till the land of Arabia becomes meadows and rivers.

Book 5, Number 2209:

    Abu Huraira reported Allah's Messenger (may peace be upon him) as saying: The Last Hour will not come till wealth is abundant and overflowing, so much so that the owner of the property will think as to who will accept Sadaqa from him, and a person would be called to accept Sadaqa and he would say: I do not need it.

Book 5, Number 2210:

    Abu Huraira reported Allah's Messenaer (may peace be upon him) as saying: The earth will vomit long pieces of its liver like columns of gold and silver, and the murderer will come and say: It was for this that I committed murder. The breaker of family ties will come and say: It was for this that I broke the family ties; and the thief will come and say: It is for this that my hands were cut off. They will then leave it and will not take anything out of it.

Chapter 18 : ACCEPTANCE OF SADAQA BY HONEST WORK AND ITS GROWTH

Book 5, Number 2211:

    Abu Huraira reported Allah's Messenger (tray peace be upon him) as saying: If anyone gives as Sadaqa the equivalent of a date from that (earning) earned honestly, for Allah accepts that which is lawful, the Lord would accept it with His Right Hand, and even if it is a date, it would foster in the Hand of the lord, as one of you fosters his colt, till it becomes bigger than a mountain.

Book 5, Number 2212:

    Abu Huraira reported Allah's Messenger (may peace be upon him) as saying: No one gives Sadaqa of a date out of his honest earning, but Allah accepts it with His Right Hand, and then fosters it as one of you fosters the colt or a young she-camel, till it becomes like a mountain or even greater.

Book 5, Number 2213:

    This hadith has been narrated through another chain of transmitters with a change of words. In the hadith transmitted Rauh (the words are): "Out of the honest earning and its spending at what is its (due) right"; and in the hadith transmitted by Sulaiman (the words are): "And its spending at its proper place."

Book 5, Number 2214:

    Abu Huraira reported Allah's Messenger (may peace be upon him) as saying: 0 people, Allah is Good and He therefore, accepts only that which is good. And Allah commanded the believers as He commanded the Messengers by saying: "O Messengers, eat of the good things, and do good deeds; verily I am aware of what you do" (xxiii. 51). And He said: ' 0 those who believe, eat of the good things that We gave you" (ii. 172) He then made a mention of a person who travels widely, his hair dishevelled and covered with dust. He lifts his hand towards the sky (and thus makes the supplication): "O Lord, 0 Lord," whereas his diet is unlawful, his drink is unlawful, and his clothes are unlawful and his nourishment is unlawful. How can then his supplication be accepted ?

Chapter 19 : EXHORTATION TO SADAQA EVEN THOUGH IT IS HALF A DATE, OR A GOOD WORD, FOR THEY ARE PROTECTION AGAINST FIRE

Book 5, Number 2215:

    'Adi b. Hatim reported that he heard Allah's Messenger (way peace be upon him) as saying: He who among you can protect himself against Fire, he should do so, even if it should be with half a date.

Book 5, Number 2216:

    'Adi b. Hatim reported Allah's Messenger (may peace be upon him) as saying: Allah will speak with everyone amongst you without any interpreter between them. He (the man) would see towards his right and would not find anything but (the deeds) which he had done before, and he would see towards the left and would not find anything but (the deeds) which he had done before. He would see in front of him and would find nothing but Fire just before his face. So protect (yourselves) against Fire even if it is with the help of half a date. A hadith like this has been transmitted by Khaithama and addition has been made in this of (these words); "Even if it is with a good word."

Book 5, Number 2217:

    'Adi b. Hatim reported that the Messenger of Allah (may peace be upon him) made a mention of Fire. He turned his face aside and diverted his attention and then said: Guard (yourselves) against Fire. He turned his face and diverted his attention till we thought as if he were (actually seeing it and then said: Protect yourselves against Fire even if it is with half a date, and he who does not find it, (he should do so) with pleasant words. Abu Kuraib did not mention the word: (as if).

Book 5, Number 2218:

    Adi b. Hatim reported that the Messenger of Allah (may peace be upon him) made a mention of the Fire and sought refuge (with Allah against it). He turned aside his face three times and then said: Protect yourselves against Fire even if with half a date. But if you fail to find it (then protect yourselves against Fire) with the help of a pleasant word).

Book 5, Number 2219:

    Mundhir b. Jarir reported on the authority of his father: While we were in the company of the Messenger of Allah (may peace be upon him) in the early hours of the morning, some people came there (who) were barefooted, naked, wearing striped woollen clothes, or cloaks, with their swords hung (around their necks). Most of them, nay, all of them, belonged to the tribe of Mudar. The colour of the face of the Messenger of Allah (may peace be upon him) underwent a change when he saw them in poverty. He then entered (his house) and came out and commanded Bilal (to pronounce Adhan). He pronounced Adhan and Iqima, and he (the Holy Prophet) observed prayer (along with his Companion) and then addressed (them reciting verses of the Holy Qur'an): '"0 people, fear your Lord, Who created you from a single being" to the end of the verse, "Allah is ever a Watcher over you" (iv. 1). (He then recited) a verse of Sura Hashr: "Fear Allah. and let every soul consider that which it sends forth for the morrow and fear Allah" (lix. 18). (Then the audience began to vie with one another in giving charity.) Some donated a dinar, others a dirham, still others clothes, some donated a sa' of wheat, some a sa' of dates; till he (the Holy Prophet) said: (Bring) even if it is half a date. Then a person from among the Ansar came there with a money bag which his hands could scarcely lift; in fact, they could not (lift). Then the people followed continuously, till I saw two heaps of eatables and clothes, and I saw the face of the Messenger (may peace be upon him) glistening, like gold (on account of joy). The Messenger of Allah (may peace be upon him) said: He who sets a good precedent in Islam, there is a reward for him for this (act of goodness) and reward of that also who acted according to it subsequently, without any deduction from their rewards; and he who sets in Islam an evil precedent, there is upon him the burden of that, and the burden of him also who acted upon it subsequently, without any deduction from their burden.

Book 5, Number 2220:

    This hadith has been narrated on the authority of Mandhir through another chain of transmitters. And the hadith transmitted by Ibn Mu'adh contains an addition: "He then observed the noon prayer and then gave the sermon."

Book 5, Number 2221:

    Mundhir b. Jarir narrated on the authority of his father: When we were sitting in the company of the Apostle of Allah (may peace be upon him). There came people dressed in striped woollen clothes, and the rest of the hadith in the same, and there (it is also mentioned): "He observed the Zuhr prayer and then climbed up a small pulpit, praised Allah, lauded Him, and then said: Verily Allah in His Book has revealed: 'O people, fear your Lord,' etc." (iv. 1).

Book 5, Number 2222:

    Jarir b.'Abdullah reported :People came to to the Messenger of Allah (may peace be upon him) and they ware dressed in woollen clothes. He (the Holy Prophet) saw their dismal state, as they were suffering from want and the rest of the hadith is the same.

Chapter 20 : THE LABOURER SHOULD GIVE CHARITY OUT OF HIS WAGES AND IT IS SEVERELY FORBIDDEN TO BELITTLE ONE WHO CONTRIBUTES LESS

Book 5, Number 2223:

    Abu Mas'ud reported: We were commanded to give charity (despite the fact.) that we were coolies. Abu 'Aqil donated half a sa'. And there came another man with more than this. The hypocrites said: Verily Allah does not stand in need of the charity of this, and the second one has done nothing but only made a show (of his charity). Then this verse was revealed. "Those who scoff at the voluntary givers of charity among the believers as well as those who cannot find anything (to give) but with their hard labour"(ix. 80). And Bishr did not utter the word Muttawwi'in.

Book 5, Number 2224:

    This hadith has been narrated by Shu'ba with the same chain of transmitters and in the hadith transmitted by Sa'id b. al Rabi (the words are): "We used to carry loads on our backs."

Chapter 21 : EXCELLENCE OF GIVING A GIFT

Book 5, Number 2225:

    It is narrated on the authority of Abu Huraira (that the Messenger of Allah) said: Of course the person who gives to the family a she-camel as a gift, which gives milk morning and evening equal to a large bowl, its reward (the reward of the gift) is great.

Book 5, Number 2226:

    Abu Huraira reported that the Apostle of Allah (may peace be upon him) forbade (to do certain things) and then he made a mention of certain habits and said: He who gives a she-camel as a gift, for him is the reward (of the gift) both morn- ing and evening-a reward for drinking milk in the morning and a reward for drinking milk in the evening.

Chapter 22 : THE LIKENESS OF ONE WHO SPENDS (IN THE PATH OF ALLAH) AND ONE WHO WITHHOLDS

Book 5, Number 2227:

    Abu Haraira reported that the likeness of one who spends or one who gives charity is that of a person who has two cloaks or two coats-of-mail over him right from the breast to the collar bones. And when the spender (and the other narrator said, when the giver of charity) makes up his mind to give charity, it (coat-mail) becomes expanded for him. But when a miserly person intends to spend, it contracts and every ring grips the place where it is. For the giver of charity, this coat-of. mail expands to cover his whole body and obliterates even his footprints. Abu Huraira said: (The miserly man) tries to expand it (the coat-of-mail) but it does not expand.

Book 5, Number 2228:

    Abu Haraira reported that the Messenger of Allah (may peace be upon him) gave similitudes of a miserly man and the giver of charity as two persons who have two coats-of-mail over them with their hands pressed closely to their breasts and their collar bones. Whenever the giver of charity gives charity it (the coat-of mail) expands so much as to cover his finger tips and obliterate his foot prints. And whenever the miserly person intends to give charity (the coat-of-mail) contracts and every ring grips the place where it is. He (Abu Huraira) said: I saw the Messenger of Allah (may peace be upon him) saying with fingers in the opening of his shirt: "If you had seen him trying to expand it, it will not expand."

Book 5, Number 2229:

    Abu Haraira reported Allah's Messenger (may peace be upon him) as-saying:. The similitude of a miserly man and the giver of charity is that of two persons with coatsof mail over them; when the giver of charity intends to give charity, it expands over him (to much so) that the footprints are also obliterated. And when the miserly man intends to give charity, it contracts over him, and his hands are tied up to his collar bone, and every ring is fixed up to another. He (the narrator) said: I heard the Messenger of Allah (may peace be upon him) as saying: He would try to expand it. but he would not be able to do so.

Chapter 23 : PROOF OF REWARD FOR THE GIVER OF CHARITY EVEN IF IT GOES INTO THE HANDS OF AN UNDESERVING PERSON

Book 5, Number 2230:

    Abu Huraira reported Allah's Apostle (may peace be upon him) as saying: A man expressed his intention to give charity, so he came out with charity and placed it in the hand of an adulteress. In the morning, the people were talking and saying: charity was given to an adulteress last night. He (the giver of Sadaqa) said: 0 Allah, to Thee be the praise-to an adulteress. He then again expressed his intention to give charity; so he went out with the charity and placed it in the hand of a rich person. In the morning the people were talking and saying: Charity was given to a rich person. He (the giver of charity) said: 0 Allah, to Thee be the praise-to a well-to-do person. He then expressed his intention to give charity, so he went out with charity and placed it in the hand of a thief. In the morning, the people were talking and saying: Charity was given to a thief. So (one of the persons) said: 0 Allah, to Thee be the praise (what a misfortune it is that charity has been given to) the adulteress, to a rich person. to a thief! There came (the angel to him) and he was told: Your charity has been accepted. As for the adulteress (the charity might become the means) whereby she might restrain herself from fornication. The rich man might perhaps learn a lesson and spend from what Allah has given him, and the thief might thereby refrain from committing theft.

Chapter 24 : THE REWARD FOR AN HONEST TRUSTEE AND FOR THE WOMAN AS SHE GIVES CHARITY FROM THE HOUSEHOLD OF HER HUSBAND EITHER WITH HIS EXPLICIT SANCTION OR AS IT IS CUSTOMARY

Book 5, Number 2231:

    Abu Musa reported Allah's Apostle (may peace be upon him) as saying: The honest Muslim trustee who spends (sometimes he said "who gives") what he is commanded to do and he gives that in full with his heart overflowing with cheerfulness and he gives it to one to whom he is ordered, he is one of the givers of charity.

Book 5, Number 2232:

    'A'isha reported Allah's Messenger (may peace be upon him) as saying: When a woman gives in charity some of the food in her house, without causing any damage, there is reward for her for whatever she has given, and a reward for her husband for what he earned. The same applies to the trustee. In no respect does the one diminish the reward of the other.

Book 5, Number 2233:

    This hadith has been narrated by Mansur with the same chain of transmitters (with this alteration of words): "from the food of her husband".

Book 5, Number 2234:

    'A'isha reported Allah's Messenger (may peace be upon him) as saying: When a woman spends (something as Sadaqa) out of the household of her husband without causing any damage, there is a reward for her and for him too like it for whatever he earned, and for her (for the wife) because of her spending (for the sake of Allah), and for the trustee also (there is a reward like it), without any reduction from their rewards.

Book 5, Number 2235:

    This hadith has been narratedby A'mash with the same chain of transmitters.

Book 5, Number 2236:

    Umair, the freed slave of Abi'l-Lahm reported: 1 was the slave (of Abi'l-Lahm). I asked the Messenger of Allah (may peace be upon him) if I could give some charity out of my master's wealth. He said: Yes, and the reward is half and half between you two.

Book 5, Number 2237:

    'Umair, the freed slave of Abi'l-Lahm, said: My master commanded me to cut some meat in strips; (as I was doing it) a poor man came to me and I gave him some of it to eat. My master came to know of that, and he beat me. I came to the Messenger of Allah (may peace be upon him) and narrated it to him. He (the Holy Prophet) summoned him and said: Why did you beat him? He (Abi'l-Lahm) said: He gives away my food without being commanded to do so. Upon this he (the Holy Prophet) sbid: The reward would be shared by you two.

Book 5, Number 2238:

    Hammam b. Munabbih said: These are some of the a hadith of Muhammad. the Messenger of Allah (may peace be upon him), transmitted to us on the authority of Abu Huraira. So he narrated one hadith out of them (as this): The Messenger of Allah (may peace be upon him) said: No woman should observe fast when her spouse is present (in the house) but with his permission. And she should not admit any (mahram) in his house, while he (her husband) is present, but with his permission. And whatever she spends from his earnings without his sanction, for him is half the reward.

Chapter 25 : CONCERNING THE COLLECTION OF SADAQA AND DOING OF GOOD DEEDS

Book 5, Number 2239:

    Abu Huraira reported Allah's Messenger (may peace be upon him) assaying: If anyone contributes a pair of anything for the sake of Allah, he would be invited to enter Paradise (with these words): O servant of Allah. it is good (for you). These who engage in prayer will he invited to enter by the gate of prayer; those who take part in Jihad will be Invited to enter by the gate of Jihad; those wto give charity will be invited to enter by the gate of charity; and those who observe fast will be invited to enter by the gate ar-Rayyan. Abu Bakr Siddiq said: Messenger of Allah, is it necessary that a person be invited through one of these gates? Will anyone he invited to enter by all those gates? The Messenger of Allah (way peace be upon him) said: Yes, and I hope you will be one of them.

Book 5, Number 2240:

    This hadith has been narrated by Zuhri through another chain of transmitters.

Book 5, Number 2241:

    Abu Huraira reported Allah's Messenger (may peace be upon him) as saying: He who spent pairs for the sake of Allah, the guardians of Paradise would call him, (in fact) every guardian of the door (of Paradise would welcome him saying): O, so and so, come on. Upon this Abu Bakr said: Messenger of Allah, (it means) there would be no distress on this person. The Messenger of Allah (may peace be upon him) said. I hope you would be among them.

Book 5, Number 2242:

    Abu Huraira reported that the Messenger of Allah (may peace be upon him) said: Who has observed fast among you today? Abu Bakr (Allah be pleased with him) replied: It is I. He (the Holy Prophet again) said: Who among you follow. ed the bier today? Abu Bakr (Allah be pleased with him) replied: It is I. He (the Holy Prophet again) said: Who among you led a poor man today? Abu Bakr (Allah he pleased with him) replied: It is I. He (again) said: Who among you visited an invalid today? Abu Bakr (Allah be pleased with him) said: It is I. Upon this the Messenger of Allah (may peace be upon him) said: Anyone in whom (these good deeds) are combined will certainly,enter paradise.

Chapter 26 : EXHORTATION TO SPEND (FOR THE SAKE OF ALLAH)AND DISAPPROVAL OF CALCULATING (THE ARTICLES OF CHARITY)

Book 5, Number 2243:

    Asma', daughter of Abu Bakr (Allah be pleated with him), reported: The Messenger of Allah (may peace be upon him) said to me: Spend, and do not calculate, or otherwise Allah would also calculate in your case.

Book 5, Number 2244:

    Asma' reported Allah's Messenger (way peace be upon him) as saying (to her): Spend and do not calculate, (for) Allah would calculate in your case; and do not hoard, otherwise Allah would be withholding from you.

Book 5, Number 2245:

    This hadith has been narrated on the authority of Asma' through another chain of transmitters.

Book 5, Number 2246:

    Asma', daughter of Abu Bakr, reported that abe came to the Apostle of Allah (may peace he upon him) and said: Apostle of Allah, I have nothing with me, but only, that which is given to me by Zubair (for household expenses). Is there any sin for me if I spend out of that which is given to me (by Zabair)? Upon this he (the Holy Prophet) said: Spend according to your means; and do not hoard, for Allah will withhold from you.

Chapter 27 : EXHORTATION TO GIVE CHARITY EVEN THOUGH IT IS SMALL (THE ONE WHO GIVES) SMALL AMOUNT SHOULD NEITHER BE DISCOURAGED NOR LOOKED DOWN UPON

Book 5, Number 2247:

    Abu Huraira reported Allah's Messenger (may peace be upon him) as saying: 0 Muslim women, none of you should consider even a sheep's trotter too insignificant to give to her neighbour.

Chapter 28 : EXCELLENCE OF GIVING SADAQA SECRETLY

Book 5, Number 2248:

    Abu Huraira reported that the Apostle of Allah (may peace be upon him) had said: Seven are (the persons) whom Allah would give protection with His Shade on the Day when there would be no shade but that of Him (i.e. on the Day of Judgment, and they are): a just ruler, a youth who grew up with the worship of Allah; a person whose heart is attached to the mosques; two persons who love and meet each other and depart from each other for the sake of Allah; a man whom a beautiful woman of high rank seduces (for illicit relation), but he (rejects this offer by saying): "I fear Allah" ; a person who gives charity and conceals it (to such an extent) that the right hand does not know what the left has given: and a person who remembered Allah in privacy and his eyes shed tears.

Book 5, Number 2249:

    This hadith has been narrated, on the authority, of Abu Huraira (with this change of words). "A person whose heart is attached to the mosque when he goes out of it till he returns to it."

Chapter 29 : THE MOST EXCELI,ENT SADAQA IS THAT WHICH IS GIVEN WHEN ONE IS HEALTHY AND CLOSE-FISTED

Book 5, Number 2250:

    Abu Huraira reported that there came a person to the Messenger of Allah (may peace be upon him) and said: Messenger of Allah, which charity is the best? Upon this he said: That you should give charity (in a state when you are) healthy and close-fisted, one haunted by the fear of poverty, hoping to become rich (charity in such a state of health and mind is the best). And you must not defer (charity to such a length) that you are about to die and would he saying: This is for so and so, and this is for so and so. Lo, it has already come into (the possession of so and so).

Book 5, Number 2251:

    Abu Huraira reported that a person came to the Apostle of Allah (may peace be upon him) and said: Messenger of Allah, which charity is the greatest in reward? (The Holy Prophet said): By your father, beware, you should give charity (in a state when you are) healthy and close-fisted, haunted by the fear of poverty, and still hoping to live (as rich). And you must not defer charity (to the time) when you are about to die, and would then say : "This is for so and so, and this for so and so." It has already become the possession of so and so.

Book 5, Number 2252:

    This hadith has been narrated with the same chain of transmitters except with this change (of words): "Which charity is most excellent?"

Chapter 30 : CONCERNING THE STATEMENT THAT THE UPPER HAND IS BETTER THAN, THE LOWER HAND, AND THE UPPER HAND IS THAT WHICH GIVES AND THE LOWER ONE IS THAT WHICH RECEIVES

Book 5, Number 2253:

    Abdullah b. Umar reported that as Allah's Messenger (may peace be upon him) was sitting on the pulpit and talking about Sadaqa and abstention from begging, he said: The upper hand is better than the lower one, the upper being the one which bestows and the lower one which begs.

Book 5, Number 2254:

    Hakim b. Hizam reported Allah's Messenger (may peace be upon him) having said this: The most excellent Sadaqa or the best of Sadaqa is that after giving which the (giver) remains rich and the upper hand is better than the lower hand, and begin from the members of your household.

Book 5, Number 2255:

    Hakim b. Hizam reported: I begged the Apostle of Allah (may peace be upon him), and he gave me. I again begged, he again gave me. I again begged, he again gave me, and then said: This property is green and sweet; he who receives it with a cheerful heart is blessed in it, and he who receives it with an avaricious mind would not be blessed in it, he being like one who eats without being satished, and the upper hand is better thad the lower hand.

Book 5, Number 2256:

    Abu Umama reported Allah's Messenger (may peace be upon him) as saying: 0 son of Adam, it is better for you if you spend your surplus (wealth), but if you withhold it, it is evil for you. There is (however) no reproach for you (if you withhold means necessary) for a living. And begin (charity) with your dependants; and the upper hand is better than the lower hand.

Chapter 31 : IT IS FORBIDDEN TO BEG

Book 5, Number 2257:

    Mu'awiya said: Be cautious about ahadith except those which were current during the reign of Umar, for he exhorted people to ftar Allah, the Exalted and majestic. I heard the Messenger of Allah (may peace be upon him) as saying: He upon whom Allah intends to bestow goodness, He confers upon him an insight in religion; and I heard the Messenger of Allah (way peace be upon him) as saying: I am the treasurer. To one whom I give out of (my own) sweet will, he would be blessed in that, but he whom I give (yielding to his constant begging and for his covetousness is like one who would eat, but would not be satisfied.

Book 5, Number 2258:

    Mu'awiya reported AUah's Messenger (may prom be upon him) as saying: Do not beg importunately, for, I swear by Allah, none of you who asks me for anything and manages to get what he asks for when I disapprove td it will he be blessed in that which I give him.

Book 5, Number 2259:

    'Amr b. Dinar reported from Wahb b. Munabbih: I went to his house in San'a' and he offered me nuts grown in his house to eat. And his brother said: I heard Mu'awiya b. Abu Sufyan saying that he had heard the Messenger of Allah (may peace be upon him) as saying, and then he made a mention (of a hadith) like one mentioned above.

Book 5, Number 2260:

    Abd al-Rahman b. Auf reported: I heard Mu'awiya b. Abu Sufyan saying in an address that he had heard the Messenger of Allah (may peace be upon him) as saying : He to whom Allah intends to do good, He gives him insight into religion. And I am only the distributor while Allah is the Bestower.

Chapter 32 : MISKIN (POOR MAN) IS ONE WHO DOES NOT FIND ENOUGH TO SATISFY HIM AND THE PROPLR DO NOT CONSIDER HIM (NEEDY) AS TO GIVE HIM CHARITY

Book 5, Number 2261:

    Abu Huraira reported Allah's Messenger (may peace be upon him) as saying: The poor man (miskin) is not the one who goes round to the people and is dismissed with one or two morsels. and one or two dates. They (the Prophet's Companions) said: Messenger of Allah, then who is miskin? He said: He who does not get enough to satisfy him, and he is not considered so (as to elicit the attention of the benevolent people), so that charity way be given to him. and he does not beg anything from people.

Book 5, Number 2262:

    Abu Huraira reported Allah's Messenger (may peace be upon him) as saying: Miskin is not he who is dismissed with one or two dates, and with one morsel or two morsels. (In fact) miskin is he who abstains (from begging). Read if you so desire (the verse): "They beg not of men importunately)" (ii. 273).This hadith has been narrated through another chain of transmitters.

Chapter 33 : DISAPPROVAL OF BEGGING FROM PEOPLE

Book 5, Number 2263:

    Hamza. son of 'Abdullah, reported on the authority of his father that the Apostle of Allah (may peace be upon him) said: When a man is always begging from people. he would meet Allah (in a state) that there would be no flesh on his face.

Book 5, Number 2264:

    This hadith has been narrated on the authority of the brother of Zuhri with the same chain of transmitters, but no mention has been made of the word "muz'a" (piece).

Book 5, Number 2265:

    Hamza b. 'Abdullah b. Umar heard his father cay that the Messenger of Allah (may peace be upon him) had said: The person would continue begging from people till he would come on the Day of Resurrection and there would be no flesh on his face.

Book 5, Number 2266:

    Abu Huraira reported Allah's Messenger (may peace be upon him) as saying: He who begs the riches of others to increase his own is asking only for live coals, so let him ask a little or much.

Book 5, Number 2267:

    Abu Huraira is reported to have heard the Messenger of Allah (may peace be upon him) as saying: It is letter for one among you to bring a load of firewood on his back and give charity out of it (and satisfy his own need) and be independent of people, than that he should beg from people, whether they give him anything or refuse him. Verily the upper hand is better than the lower hand, and begin (charity) with your dependants.

Book 5, Number 2268:

    Qais b. Abu Hizam reported: We came to Abu Huraira and he told Allah's Messenger (may peace be upon him) having said this: By Allah, (it is better) that one among you should go and bring a load of firewood on his back and he should sell it, and the rest of the hadith was narrated (like the previous one).

Book 5, Number 2269:

    Abu Huraira reported Allah's Messenger (may peace be upon him) as saying: It is better for any one of you to tie a bundle of firewood and carry it on his back and sell it than to beg a person, he may give or may refuse.

Book 5, Number 2270:

    Malik al-Ashja'i reported: We, nine, eight or seven men, were in the company of the Messenger of Allah (may peace be upon him) and he said: Why don't you pledge allegiance to the Messenger of Allah?-while we had recently pledged allegiance. So we said: Messenger of Allah, we have already pledged allegiance to you. He again said: Why don't you pledge allegiance to the Messenger of Allah? And we said: Messenger of Allah, we have already pledged allegiance to you. He again said: Why don't you pledge allegiance to the Messenger of Allah? We stretched our hands and said: Messenger of Allah. we have already pledged allegiance to you. Now tell (on what things) should we pledge allegiance to you. He said I (You must pledge allegiance) that you would worship Allah only and would not associate with Him anything, (and observe) five prayers, and obey-(and he said onething in an undertone)-that you would not beg people of anything. (And as a consequence of that) I saw that some of these people did not ask anyone to pick up the whip for them if it fell down.

Chapter 34 : ONE FOR WHOM BEGGING IS PERMISSIBLE

Book 5, Number 2271:

    Qabisa b. Mukhariq al-Hilali said: I was under debt and I came to the Messenger of Allah (may peace be upon him) and begged from him regarding it. He said: Wait till we receive Sadaqa, so that we order that to be given to you. He again said: Qabisa, begging is not permissible but for one of the three (classes) of persons: one who has incurred debt, for him begging is permissible till he pays that off, after which he must stop it; a man whose property has been destroyed by a calamity which has smitten him, for him begging is permissible till he gets what will support life, or will provide him reasonable subsistence; and a person who has been smitten by poverty. the genuineness of which is confirmed by three intelligent members of this peoples for him begging is permissible till he gets what will support him, or will provide him subsistence. Qabisa, besides these three (every other reason) for begging is forbidden, and one who engages in such consumes that what is forbidden.

Chapter 35 : PERMISSIBILITY TO ACCEPT WHAT IS GIVEN WITHOUT BEGGING, OR WITHOUT BEING AVARICIOUS

Book 5, Number 2272:

    Salim b. Abdullah b. 'Umar reported on the authority of his father ('Abdullah b. 'Umar) that he had heard 'Umar b. Khattab (Allah be pleased with him) saying: The Messenger of Allah (may peace be upon him) gave me a gift, but I said : Give it to one who needs it more than I. He gave me wealth for the second time but I said: Give it to one who needs it more than I. Upon this the Messenger of Allah (may peace be upon him) said: Take out of this wealth which comes to you without your being avaricious and without begging, but in other circumstance's do not let your heart hanker after it.

Book 5, Number 2273:

    Salim b. 'Abdullah reported on the authority of his father that the Messenger of Allah (may peace be upon him) gave to 'Umar b. Khattab some gift. Umar said to him: Messenger of Allah, give it to one who needs it more than I. Upon this the Messenger of Allah (may peace be upon him) said: Take it; either keep it with you or give it as a charity, and whatever comes to you in the form of this type of wealth, without your being avaricious or begging for it, accept it, but in other circumstances do not let your heart hanker after it. And it was on account of this that Ibn 'Umar never begged anything from anyone, nor refused anything given to him.

Book 5, Number 2274:

    This hadith has been narrated by Abdullah b. al-Sa'di from 'Umar b. al-Khattab who heard it from the Messenger of Allah (may peace be upon him).

Book 5, Number 2275:

    Ibn al-Sa'di Maliki reported: 'Umar b. Khattab (Allah be pleased with him) appointed me as a collector of Sadaqa. When I had finished that (the task assigned to me) and I handed over that to him (to 'Umar), he commanded me to (accept) some remuneration (for the work). I said: I performed this duty for Allah and my reward is with Allah. He said: Take whatever has been given to you, for I also performed this duty during the time of the Messenger of Allah (may peace be upon him). He assigned me the task of a collector and I said as you say, and the Messenger of Allah (may peace be upon him) said to me: When you are given anything without your begging for it, (then accept it), eat it and give it in charity.

Book 5, Number 2276:

    Ibn al-Sa'di reported: 'Umar b. Khattab (Allah be pleased with him) appointed me as a collector of Sadaqat. The rest of the hadith in the same.

Chapter 36 : DISAPPROVAL OF THE LONGING FOR THE (POSSESSIONS OF THE MATERIAL) WORLD

Book 5, Number 2277:

    Abu Huraira reported from the Messenger of Allah (may peace be upon him) as having said this: The heart of an old person feels young for the love of two things: love for long life and wealth.

Book 5, Number 2278:

    Abu Huraira reported that the Messenger of Allah (may peace be upon him) had said this: The heart of an old person is young for two things: for long life and love for wealth.

Book 5, Number 2279:

    Anas reported Allah's Messenger (may peace be upon him) as saying: The son of Adam grows old, but two (desires) in him remain young: desire for wealth and desire for life.

Book 5, Number 2280:

    A hadith like this has been narrated by Anas through another chain of transmitters.

Book 5, Number 2281:

    This hadith has been narrated on the authority of Anas through another chain of transmitters.

Chapter 37 : IF THERE WERE TWO VALLEYS (OF GOLD) FOR THE SON OF ADAM, HE WOULD LONG FOR THE THIRD ONE

Book 5, Number 2282:

    Anas reported Allah's Messenger (may peace be upon him) as saying: If the son of Adam were to possess two valleys of riches. he would long for the third one. And the stomach of the son of Adam is not filled but with dust. And Allah returns to him who repents.

Book 5, Number 2283:

    Anas b. Malik reported: I heard the Messenger of Allah (may peace be upon him) as saying this, but 1 do not know whether this thing was revealed to him or not, but he said to.

Book 5, Number 2284:

    Anas b. MILlik reported Allah's Messenger (may peace be upon him) as saying: If there were two valleys of gold for the son of Adam, he would long for an- other one. and his mouth will not be filled but with dust, and Allah returns to him who repents.

Book 5, Number 2285:

    Ibn Abbas reported Allah's Messenger (may peace be upon him) as saying: If there were for the son of Adam a valley full of riches, he would long to possess another one like it. and Ibn Adam does not feel satiated but with dust.1413 And Allah returns to him who returns (to HiM).1414 Ibn Abbas said: I do not know whether it is from the Qur'an or not; and in the narration transmitted by Zuhair it was said: I do not know whether it is from the Qur'an, and he made no mention of Ibn Abbas.

Book 5, Number 2286:

    Abu Harb b. Abu al-Aswad reported on the authority of his father that Abu Musa al-Ash'ari sent for the reciters of Basra. They came to him and they were three hundred in number. They recited the Qur'an and he said: You are the best among the inhabitants of Basra, for you are the reciters among them. So continue to recite it. (But bear in mind) that your reciting for a long time may not harden your hearts as were hardened the hearts of those before you. We used to recite a surah which resembled in length and severity to (Surah) Bara'at. I have, however, forgotten it with the exception of this which I remember out of it:"If there were two valleys full of riches, for the son of Adam, he would long for a third valley, and nothing would fill the stomach of the son of Adam but dust." And we used so recite a slirah which resembled one of the surahs of Musabbihat, and I have forgotten it, but remember (this much) out of it: "Oh people who believe, why do you say that which you do not practise" (lxi 2.) and "that is recorded in your necks as a witness (against you) and you would be asked about it on the Day of Resurrection" (xvii. 13).

Chapter 38 : ONE IS NOT RICH BECAUSE OF THE ABUNDANCE OF GOODS

Book 5, Number 2287:

    Abu Huraira reported that the Messenger of Allah (may peace be upon him) had said: Richness does not lie in the abundance of (worldly) goods but richness is the richness of the soul (heart, self).

Chapter 39 : FEAR OF WHAT WOULD COME OUR OF THE ADORNMENT OF THE WORLD

Book 5, Number 2288:

    Abu Sa'id al-Khudri reported that the Messenger of Allah (may peace be upon him) stood up and addressed the people thus: 0 people, by Allah, I do not entertain fear about you in regard to anything else than that which Allah would bring forth for you in the form of adornment of the world. A person said: Messenger of Allah, does good produce evil? The Messenger of Allah (may peace be upon him) remained silent for a while and he then said: What did you say? He replied: Messenger of Allah, I said: Does good produce evil? The Messenger of Allah (may peace be upon him)said to him: The good does not produce but good. but among the plants the spring rain produces There some which kill with a tremour or nearly kill all but the animal which feeds on vegetation. It eats and when its flanks are distended, it faces the can. then when it has donged or urinated and chewed it returns and eats. He who accepts wealth rightly, Allah confers blessing on it for him. and he who takes wealth without any right, he is like one who eats and is not satisfied.

Book 5, Number 2289:

    Abu Sa'id al-Khudri reported that the Messenger of Allah (may peace be upon him) had said: The most dreadful thing I fear in your case is what Allah brings forth for you in the form of the adornment of the world. They (the Prophet's Com panions) said: Messenger of Allah, what is the adornment of the world? He said: Blessings (the natural resources) of the earth. They (again) said: Messenger of Allah, does good produce evil? He said: No, only good comes out of good. No, only good comes out of good. No. only good comes out of good. All that which the spring rain helps to grow kills or is about to kill but (the animal) which feeds on vegetation. It eats and when its flanks are distended, it faces the sun, it chews the cud, it has dunged and urinated. it returns and eats. This wealth is green and sweet, and he who accepts it and applies it rightly, finds it a good help, but he who takes it wrongfully is like one who eats without being satisfied.

Book 5, Number 2290:

    Abu Said al-Khudri reported: The Messenger of Allah (may peace be upon him) was sitting on the pulpit and we were sitting around him, and he said: What I am afraid of in regard to you after my death is that there would be opened for you the adornments of the world and its beauties. A person said: Messenger of Allah, does good produce evil? The Messenger of Allah (may peace be upon him) remained silent. And it was said to him (the man who had asked the question from the Holy Prophet): What Is the matter with you, that you speak with the Messenger of Allah (may peace be upon him) but he does not speak with you? We thought as if revelation was descending upon him. He regained himself and wiped the sweat from him and said: He was the inquirer (and his style of expression showed as if he praised him and then added): Verily good does not produce evil. Whatever the spring rainfall causes to grow kills or is about to kill, but that (animal) which feeds on vegetation. It eats till its flanks are filled ; it faces the sun and dungs and urinates. and then returns to eat. And this Wealth is a sweet vegetation, and it is a good companion for a Muslim who gives out of it to the needy, to the orphan. to the wayfarer, or something like that as the Messenger of Allah (may peace be upon him) said: He who takes it without his right is like one who eats but does not feel satisfied, and it would stand witness against him on the Day of judgment.

Chapter 40 : EXCELLENCE OF ABSTAINING FROM BEGGING AND THAT OF ENDURANCE

Book 5, Number 2291:

    Abu Sa'id al-Khudri reported that some people from among the Ansar begged from the Messenger of Allah (may peace be upon him) and he gave them. They again begged him and he again gave them, till when what was in his possession was exhausted he said: Whatever good (riches, goods) I have, I will not withhold it from you. He who refrains from begging Allah safeguards him against want. and he who seeks sufficiency, Allah would keep him in a state of sufficiency, and he who shows endurance. Allah would grant him power to endure, and none is blessed with an endowment better and greater than endurance.

Book 5, Number 2292:

    This hadith has been narrated by Zuhri with the same chain of transmitters.

Book 5, Number 2293:

    'Amr b. al-'As reported Allah's Messenger (may peace be upon him) as saying: He Is successful who has accepted Islam, who has been provided with sufficient for his want and been made contented by Allah with what He has given him.

Book 5, Number 2294:

    Abu Huraira reported Allah's Messenger (may peace be upon him) as saying: 0 Allah, make the provision of Mahammad's family sufficient just to sustain life.

Chapter 41 : GIVING CHARITY TO ONE WHO BEGGED IMPORTUNATELY OR WITH UNCIVILITY

Book 5, Number 2295:

    Umar b. Khattab (Allah be pleased with him) reported that the Messenger of Allah (may peace be upon him) distributed something. Upon this I said: Messenger of Allah, I swear by God, the others besides them were more deserving than these (to whom you gave charity). He said: They had in fact left no other alternative for me. but (that they should) either beg importunately from me or they would regard me as a miser, but I am not a miser.

Book 5, Number 2296:

    Anas b. Malik reported: I was walking with the Messenger of Allah (may peace be upon him) and he had put on a mantle of Najran with a thick border. A bedouin met him and pulled the mantle so violently that I saw this violent pulling leaving marks of the border of the mantle on the skin of the neck of the Messenger of Allah (may peace be upon him). And he (the bedouin) said: Muhammad, issue command that I should be given out of the wealth of Allah which is at your disposal. The Messenger of Allah (may peace be upon him) turned his attention to him and smiled, and then ordered for him a gift (provision).

Book 5, Number 2297:

    This hadith has been narrated on the authority of Anas b. Malik through another chain of transmitters. And In the hadith transmitted by Ikrima b. 'Ammir there is an addition: "He (the bedouin) pulled his (mantle) so violently that the Apostle of Allah (may peace be upon him) was drifted very close to the bedouin." And in the hadith transmitted by Hammam, (the words are): "He pulled it so violently that the mantle was torn and the border was left around the neck of the Messenger of Allah (may peace be upon him)."

Book 5, Number 2298:

    Miswar b. Makhrama reported that the Messenger of Allah (may peace be upon him) distributed some cloaks but did not bestow one upon Makhrama. Upon this Makhrama said: 0 my son, come along with me to the Messenger of Allah (may peace be upon him). So I went with him. He said: Enter the house and call him (to come out) for me. So I called him and he (the Holy Prophet) came out, and there was a cloak (from those already distributed) on him. He (the Holy Prophet) said: I had kept it for you. He (Makhrama), looked at it and was pleased.

Book 5, Number 2299:

    Miswar b. Makhrama reported: Some cloaks were presented to the Messenger of Allah (may peace be upon him). My father Makhrama said to me: Come along with me to him; perhaps we may be able to get anything out of that (stock of cloaks). My father stood at the door and began to talk. The Apostle of Allah (may peace be upon him) recognised him by his voice and came out and there was a cloak with him, and he was showing its beauties and saying: I kept it for you, I kept it for you.

Chapter 42 : BESTOWAL UPON ONE WHO IS NOT FIRM IN FAITH

Book 5, Number 2300:

    Sa'd reported that the Messenger of Allah (may peace be upon him) bestow- ed (some gifts) upon a group of people and I was sitting amongst them. The Messenger of Allah (may peace be upon him), however, left a person and he did not give him any. thing. and he seemed to me the most excellent among them (and thus deserved the gifts more than anyone else). So I stood up before the Messenger of Allah (may peace be upon him) and said to him in undertone: Messenger of Allah, what obout so and so? By Allah, I find him a believer. He (the Messenger of Allah) said: He may be a Muslim. I kept quiet for a short while, and then what I knew of him urged me (to plead his case again) and I said: Messenger of Allah, what about so and so? By Allah, I find him a believer. Upon this he (the Holy Prophet) said: He may,be a Muslim. I again remained quiet for a short while, and what I knew of him again urged me (to plead his case so I) said: Messenger of Allah, what about so and so? By Allah, I find him a believer. Upon this he (the Holy Prophet) said: He may be a Muslim. I often bestow (something) upon a person, whereas someone else is dearer to me than he, because of the fear that he may fall headling into the fire. And in the hadith transmitted by Hulwani this statement was repeated twice.

Book 5, Number 2301:

    This hadith has been narrated on the authority of Zuhri with the same chain of transmitters.

Book 5, Number 2302:

    This hadith has been narrated on the authority of Muhammad b. Sa'd through another chain of transmitters (and the words are): "The Messenger of Allah (may peace be upon him) struck between my neck and shoulder with his hand and said: Do you wrangle, 0 Sa'd, because I bestow (some gifts) upon a person?"

Chapter 43 : BESTOWAL UPON THOSE WHO ARE MADE TO INCLINE (TO TRUTH)

Book 5, Number 2303:

    Anas b. Malik reported that when on the Day of Hunain Allah conferred upon His Apostle (may peace be upon him) the riches of Hawazin (without armed encounter), the Messenger of Allah (may peace be upon him) set about distributing to some persons of Quraish one hundred camels Upon this they (the young people from the Ansar) said: May Allah grant pardon to the Messenger of Allah (may peace be upon him) that he bestowed (these camels) upon the people of Quraish, and he ignored us, whereas our swords are still dripping blood. Anas b. Malik said: Their statement was conveyed to the Messenger of Allah (may peace be upon him) and he sent (someone) to the Ansar and gathered them under a tent of leather. When they had assembled, the Messenger of Allah (may peace be upon him) came to thera and said: What is this news that has reached me from you? The wise people of the Ansar said: Messenger of Allah, so far as the sagacious amongst us are concerned they have said nothing, but we have amongst us persons of immature age; they said: May Allah grant pardon to the Messenger of Allah (may peace be upon him) that he gave to the Quraish and ignored us (despite the fact) that our swords are besmeared with their blood. Upon this the Messenger of Allah (may peace be upon him) said: I give (at times material gifts) to persons who were quite recently in the state of unbelief, so that I may incline them to truth Don't you feel delighted that people should go with riches, and you should go back to your places with the Apostle of Allah? By Allah, that with which you would return is better than that with which they would return. They said: Yes, Messenger of Allah, we are pleased. The Holy Prophet said too: You would find marked preference (in conferring of the material gifts) in future, so you should show patience till you meet Allah and His Messenger and I would he at the Haud Kauthar. They said: We would show patience.

Book 5, Number 2304:

    Anas b. Malik reported that when Allah conferred upon His Messenger (may peace be upon him) the riches of Hawazin (without armed encounter); the rest of the hadith is the same except some variation (of words): "Anas said: We could not tolerate it and he also said: The people were immature in age."

Book 5, Number 2305:

    This hadith has been narrated on the authority of Anas b. Malik through another chain of transmitters.

Book 5, Number 2306:

    Anas b. Malik reported that the Messenger of Allah (may peace be upon him) gathered the Ansar and said: Is there someone alien among you? They said: No, but only the son of our sister. Upon this the Messenger of Allah (may peace be upon him) said: The son of the sister of the people is included among the tribe, and (farther) said: The Quraish have recently abandoned Jahillyya and have just been delivered from distress; I, therefore, intend to help them and conciliate them. Don't you feel happy that the people should return with worldly riches and you return with the Messenger of Allah to your houses? (So far as my love for you is concerned I should say) if the people were to tread a valley and the Ansar tread a narraw path (in a mountain) I would tread the narrow path of the Ansar.

Book 5, Number 2307:

    Anas b. Malik reported: When Mecca was conquered, he (the Holy Prophet) distributed the spoils among the Quraish. Upon this the Ansar said: It is strange that our swords are dripping with their blood, whereas our spoils have been given to them (to the Quraish). This (remark) reached the Messenger of Allah (may peace be upon him), and so he gathered them and said: What is this that has been conveyed to me about you? They said: (Yes) it is that very thing that, has reached you-and they were not (the people) to speak lie. Upon this he said: Don't you like that the people should return to their houses along with worldly riches, whereas you should return to your houses with the Messenger of Allah? If the people were to tread a valley or d narrow path, and the Ansar were also to tread a valley or a narrow path, I would tread the valley (along with the) Ansar or the narrow path (along with the) Ansar.

Book 5, Number 2308:

    Anas b. Malik reported that when it was the Day of Hunain there came the tribes of Hawazin, Ghatafan and others along with their children and animals, and there were with the Apostle of Allah (may peace be upon him) that day ten thousand (soldiers), and newly freed men (of Mecca after its conquest). All these men (once) turned their backs, till he (the Holy Prophet) was left alone. He (the Messenger of Allah) on that day called twice and he did not interpose anything between these two (announcements) He turned towards his right and said: 0 people of Ansar ! They said: At thy beck and call (are we), Messenger of Allah. Be glad we are with thee. He then turned towards his left and said: 0 people of Ansar. They said: At thy beck and call (are we). Be glad we are with thee. He (the Holy Prophet) was riding a white mule. He dismounted and said: I am the servant of Allah and His Apostle. The polytheists suffered defeat. and the Messenger of Allah (may peace he upon him) acquired a large quantity of spoils, and he distributed them among the refugees and the people recently delivered (of Mecca) but did not give anything to the Ansar. The Ansar said: In the hour of distress it is we who are called (for help). but the spoils are given to other people besides us. This (remark) reached him (the Holy Prophet). and he gathered them In a tent. and said: What is this news that has reached me on your behalf? They kept silence. Upon this he said: 0 people of Ansar, don't you like that people should go away with worldly (riches), and you go away with Muhammad taking him to your houses? They said: Yes, happy we are. Messenger of Allah. He (the Holy Prophet) said: If the people were to tread a valley, and the Ansar were to tread a narrow path, I would take the narrow path of the Ansar. Hisham said: I asked Abu Hamza if he was present there. He said: How could Ibe absent from him?

Book 5, Number 2309:

    Anas b. Malik reported: We conquered Mecca and then we went on an expedition to Hunain. The polytheists came, forming themselves into the best rows that I have seen. They first formed the rows of cavalry, then those of infantry, and then those of women behind them. Then there were formed the rows of sheep and goats and then of other animals. We were also people large in number, and our (number) had reached six thousand. And on one side Khalid b. Walid was in charge of the cavalry. And our horses at once turned back from our rear. And we could hardly hold our own when our horses were exposed, and the bedouins and the peoplewhom we knew took to their heels. (Seeing this) the Messenger of Allah (may peace be upon him) called thus: 0 refugees, 0 refugees. He then.said: 0 Ansar, 0 Ansar. (Anas said: This hadith is transmitted by a group of eminent persons.) We said: At thy beck and call are we, Messenger of Allah. The Messenger of Allah (may peace be upon him) then advanced and he (Anas) said: By Allah, we had not yet reached them when Allah defeated them. and we took possession of the wealth and we then marched towards Ta'if, and we besieged them for forty nights. and then came back to Mecca and encamped (at a place), and the Messenger of Allah (may peace be upon him) began to bestow a hundred camels upon each individual. The rest of the hadith is the same.

Book 5, Number 2310:

    Rafi' b. Khadij reported that the Messenger of Allah; (may peace be upon him) gave to Abu Sufyan b. Harb and Saf wan. b. Umayya and 'Uyaina b. Hisn and Aqra' b. Habis, i.e. to every one of these persons, one hundred of camels, and gave to 'Abbas b. Mirdas less than this number. Upon this 'Abbas b. Mirdis said:

      You allot the share of my booty and that of my horse between 'Uyaina and Aqra'.
      Both Uyaina and Aqra' are in no way more eminent than Mirdas (my father) in the assembly.
      I am in no way inferior to any one of these persons.
      And he who is let downtoday would not be elevated.

    He (the narrator) said: The Messenger of Allah (may peace be upon him) then complet- ed one hundred camels for him.

Book 5, Number 2311:

    This hadith has been narrated by Sa'id b. Masruq with the same chain of transmitters (with the words): "The Apostle of Allah (may peace be upon him) distributed the spoils of Hunain, and he (the Holy Prophet) gave one hundred camels to Abu Sufyan b. Harb. The rest of the hadith is the same, but with this addition: "He bestowed upon "Alqama b. 'Ulatha one hundred (camels)."

Book 5, Number 2312:

    This hadith has been narrated by Sa'id with the same chain of transmitters, but no mention has been made of Alqama b. 'Ulatha, nor of safwin b. Umayya, and he did not mention the verse in his hadith.

Book 5, Number 2313:

    Abdullah b. Zaid reported that when the Messenger of Allah (may peace be upon him) conquered Hunain he distributed the booty, and he bestowed upon those whose hearts it was intended to win. It was conveyed to him (the Holy Prophet) that the Ansar cherished a desire that they should be given (that very portion) which the people (of Quraish) had got. Upon this the Messenger of Allah (may peace be upon him) stood up and, after having praised Allah and lauded Him, addressed them thus: 0 people of Ansar, did I not find you erring and Allah guided you aright through me, and (in the state of) being destitute and Allah made you free from want through me, and in a state of disunity and Allah united you through me, and they (the Ansar) said: Allah and His Messenger are most benevolent. He (again) said: Why do you not answer me? They said: Allah and His Messenger are the most benevolent. He said, If you wish you should say so and so, and the event (should take) such and such course (and in this connection he made a mention) of so many things. 'Amr is under the impressionthat he has not been able to remember them. He (the Holy Prophet) further said: Don't you feel happy (over this state of affairs) that the people should go away with goats and camels, and you go to your places along with the Messenger of Allah? The Ansar are inner garments (more close to me) and (other) people are outer garments. Had there not been migration, I would have been a man from among the Ansar. If the people were to tread a valley or a narrow path, I would tread the valley (chosen) by the Ansar or narrow path (trodden) by them. And you would soon find after me preferences (over you in getting material benefits). So you should show patience till you meet me at the Haud (Kauthar).

Book 5, Number 2314:

    Abdullah reported: On the day of Hunain, the Messenger of Allah(may peace be upon him) showed preference (to some) People in the distribution of the spoils. He bestowed on Aqra' b. Habis one hundred camels, and bestowed an equal (number) upon 'Uyaina, and bestowed on people among the elites of Arabia, and pre. ferred them) (to others) on that day, in the distribution (of spoils). Upon this a person said: By Allah, neither justice has been done In this distribution (of spoils), nor has the pleasure of Allah been sought in it. I (the Narrator ) said: By Allah, I will certainly inform the Messenger of Allah (may peace be upon him) about it. so I came to him and informed him about what he had said.- The colour of his (the Prophet's) face changed red like blood and he then said: Who would do justice, if Allah and His Messenger do not do justice? He further said: May Allah have mercy upon Moses; he was tormented more than this, but he showed patience. I said: Never would I convey him (the Holy Prophet) after this (unpleasant) narration.

Book 5, Number 2315:

    Abdullah reported: The Messenger of Allah (may peace be upon him) distributed spoils (of war). Upon this a person said: This is a distribution In which the pleasure of Allah has not been sought. I came to the Apostle of Allah (may peace be upon him) and informed him in an undertone. He (the Holy Prophet) was deeply angry at this and his face became red till I wished that I had not made a mention of it to him. He (the Holy Prophet) then said: Moses was tormented more than this, but he showed patience.

Chapter 44 : THE KHWARIJ AND THEIR CHARACTERISTICS

Book 5, Number 2316:

    Jabir b. Abdullah reported that a person came to the Messenger of Allah (may peace be upon him) at Jirana on his way back from Hunain, and there was in the clothes of Bilal some silver. The Messenger of Allah (may peace be upon him) took a handful out of that and bestowed it upon the people. He (the person who had met the Prophet at Ji'rana) said to him: Muhammad, do justice. He (the Holy Prophet) said: Woe be upon thee, who would do justice if I do not do justice, and you would be very unfortunate and a loser if I do not do justice. Upon this Umar b. Khattab (Allah be pleased with him) said: Permit me to kill this hypocrite. Upon this he (the Holy Prophet) said: May there be protection of Allah ! People would say that I kill my companions. This man and his companions would recite the Qur'an but it would not go beyond their throat, and they swerve from it just as the arrow goes through the prey.

Book 5, Number 2317:

    This hadith has been narrated on the authority of Jabir b. 'Abdullah through another chain of transmitters.

Book 5, Number 2318:

    Abu Said Khudri reported that 'Ali (Allah be pleased with him) sent some gold alloyed with dust to the Messenger of Allah (may peace be upon him), and the Messenger of Allah (may peace be upon him) distributed that among four men, al-Aqra b. Habis Hanzali and Uyaina b. Badr al-Fazari and 'Alqama b. 'Ulatha al-'Amiri, then to one person of the tribe of Kilab and to Zaid al-Khair al-Ta'l, and then to one person of the tribe of Nabhan. Upon this the people of Quraish felt angry and said: He (the Holy Prophet) gave to the chiefs of Najd and ignored us. Upon this the Messenger of Allah (may peace be upon him) said: I have done it with a view to con- cillating them. Then there came a person with thick beard, prominent cheeks, deep sunken eyes and protruding forehead and shaven head. He said: Muhammad, fear Allah. Upon this the Messenger of Allah (may peace be upon him) said: If I disobey Allah, who would then obey Him? Have I not been (sent as the) most trustworthy among the people of the-world?-but you do not repose trust in me. That person then went back. A person among the people then sought permission (from the Holy Prophet) for his murder. According to some, it was Khalid b. Walid who sought the permission. Upon this the Messenger of Allah (may peace be upon him),said: From this very person's posterity there would arise people who would recite the Qur'an, but it would not go beyond their throat; they would kill the followers of Islam and would spare the idol-worshippers. They would glance through the teachings of Islam so hurriedly just as the arrow passes through the pray. If I were to ever find them I would kill them like 'Ad.

Book 5, Number 2319:

    Abu Said al-Khudri reported: 'Ali b. Abu Talib sent to the Messenger of Allah (may peace be upon him) from Yemen some gold alloyed with clay in a leather bag dyed in the leaves of Mimosa flava.He distributed it among four men. 'Uyaina b. Hisna, Aqra' b. Habis and Zaid al-Khail, and the fourth one was either Alqama b. 'Ulatha or 'Amir b. Tufail. A person from among his(Prophet's) Companions said: We had a better claim to this (wealth) than these (persons). This (remark) reached the Apostle of Allah (may peace be upon him) upon which he said: Will you not trust me, whereas I am a trustee of Him Who is in the heaven? The news come to me from the heaven morning and evening. Then there stood up a person with deep snnken eyes, prominent cheek bones, and elevated forehead, thick beard, shaven head, tucked up loin cloth, and he said: Messenger of Allah, fear Allah. He (the Holy Prophet) said: Woe to thee. do I not deserve most to fear Allah amongst the people of the earth? That man then returned. Khalid b. Walid then said: Messenger of Allah, should I not strike his neck? Upon this he (the Holy Prophet) said: Perhaps he may be observing the prayer. Khalid said: How many observers of prayer are there who profess with their tongue what is not in their heart? Upon this the Messenger of Allah (may peace be upon him) said: I have not been commanded to pierce through the hearts of people, nor to split their bellies (insides). He again looked at him and he was going back. Upon this he (the Holy Prophet) said: There would arise a people from the progeny of this (man) who would recite the Qur'an glibly, but it would not go beyond their throats; they would (hurriedly) pass through (the teachings of their) religion just as the arrow passes through the prey. I conceive that he (the Holy Prophet) also said this: If I find them I would certainly kill them as were killed the (people of) Thamud.

Book 5, Number 2320:

    This hadith has been narrated through another chain of transmitters and (the narrator) made a mention of elevated forehead, but he made no mention of tucked-up loin cloth and made this addition: "There stood up 'Umar b. Khattab (Allah be pleased with him), and said: Should I not strike his neck? Upon this he said: No. Then he turned away, and Khalid the Sword of Allah stood up against him, and said: Prophet of Allah. shall I not strike off his neck? He said, No, and then said: A people would rise from his progeny who would recite the Book of Allah glibly and fluently. 'Umar said: I think he (the Holy Prophet) also said this: If I find them I would certainly kill them like Thamud."

Book 5, Number 2321:

    This hadith has been narrated through another chain of transmitters, but no mention has been made of: "If I find them, I would kill them as the Thamud were killed."

Book 5, Number 2322:

    Abu Salama and 'Ata' b. Yasar came to Abu Sa'id al-Khudri and asked him about Haruriya, saying: Did you hear the Messenger of Allah (may peace be upon him) making a mention of them? He (Abu Sai'd al-Khudri) said: I don't know who the Haruriya are, but I heard the Messenger of Allah (may peace be upon him) as saying: There would arise in this nation (and he did not say "out of them") a people and you would hold insignificant your prayers as compared with their prayers. And they would recite the Qur'an which would not go beyond their throats and would swerve through the religion (as blank) just as a (swift) arrow passes through the prey. The archer looks at his arrow, at its iron head and glances at its end (which he held) in the tip of his fingers to see whether it had any stain of blood.

Book 5, Number 2323:

    Abu Sai'd al-Khudri reported: When we were in the company of the Messenger of Allah (may peace be upon him) and he was distributing the spoils of war, there came to him Dhul-Khuwasira, one of Banu Tamim. He said: Messenger of Allah, do justice. Upon this the Messenger of Allah (may peace be upon him) said: Woe be upon thee I Who would do justice, if I do not do justice? You would be unsuccessful and incurring a loss, if I do not do justice. Upon this Umar b. Khattab (Allah be pleased with him) said: Messenger of Allah, permit me to strike off his neck. The Messenger of Allah (may peace be upon him) said: Leave him, for he has friends (who would outwardly look to be so religious and pious) that everyone among you would consider his prayer insignificant as compared with their prayer, and his fast as com- pared with their fasts. They would recite the Qur'an but it would not go beyond their collar-bones. They would pass through (the teachings of Islam so hurriedly) just as the arrow passes through the prey. He would look at its Iron head, but would not find anything ticking) there. He would then see at the lowest end, but would not find anything sticking there. He would then see at its grip but would not find anything sticking to it. He would then see at its feathers and he would find nothing sticking to them (as the arrow would pass so quickly that nothing would stick to it) neither excre- ment nor blood. They would be recognised by the presence of a black man among them whose upper arms would be like a woman's breast, or like a piece of meat as it quivers, and they would come forth at the time when there is dissension among the people. Abu Sai'd said: I testify to the fact that I heard it from the Messenger of Allah (may peace be upon him),and I testify to the fact that 'Ali b. Abu Talib fought against them and I was with him. He gave orders about that man who was sought for, and when he was brought in, and when I looked at him, he was exactly as the Messenger of Allah (may peace be upon him) had described him.

Book 5, Number 2324:

    Abu Sa'id al-Khudri said that the Apostle of Allah (may peace be upon him) made a mention of a sect that would be among his Ummah which would emerge out of the dissension of the people. Their distinctive mark would be shaven heads. They would be the worst creatures or the worst of the creatures. The group who would be nearer to the truth out of the two would kill them. The Apostle of Allah (may peace be upon him) gave an example (to give their description) or he said: A man throws an arrow at the prey (or he said at the target), and sees at its iron head, but finds no sign (of blood there), or he sees at the lowest end, but would not see or find any sign (of blood there). He would then see into the grip but would not find (anything) sticking to it. Abu Sai'd then said: People of Iraq. it is you who have killed them.

Book 5, Number 2325:

    Abu Sa'id al-Khudri reported that the Messenger of Allah (may peace be upon him) said: A group would secede itself (from the Ummah) when there would be dissension among the Muslims. Out of the two groups who would be nearer the truth would kill them.

Book 5, Number 2326:

    Abu Sa'id al-Khudri reported Allah's Messenger (may peace be upon him) as saying: There would be two groups in my Ummah, and there would emerge another group (seceding itself from both of them), and the party nearer to the truth among the two would kill them (the group of the Khwarij).

Book 5, Number 2327:

    Abu Sa'id al-Khudri reported from the Apostle of Allah (may peace be upon him) that a group (Khwarij) would emerge from the different parties (the party of Hadrat 'Ali and the party of Amir Mu'awiya), the group nearer the truth between the two would kill them.

Chapter 45 : EXHORTATION TO KILL THE KHWARIJ

Book 5, Number 2328:

    'Ali said: Whenever I narrate to you anything from the Messenger of Allah (may peace be upon him) believe it to be absolutely true as falling from the sky is dearer to me than that of attributing anything to him (the Holy Prophet) which he never said. When I talk to you of anything which is between me and you (there might creep some error in it) for battle is an outwitting. I heard the Messenger of Allah (may peace be upon him) as saying: There would arise at the end of the age a people who would be young in age and immature in thought, but they would talk (in such a manner) as if their words are the best among the creatures. They would recite the Qur'an, but it would not go beyond their throats, and they would pass through the religion as an arrow goes through the prey. So when you meet them, kill them, for in their killing you would get a reward with Allah on the Day of judgmelat.

Book 5, Number 2329:

    A hadith like this has been narrated through another chain of transmitters.

Book 5, Number 2330:

    This hadith has been narrated on the authority of A'mash with the same chain of transmitters, but (these words) are not there: "They pass through the religion clean as the arrow passes through the prey."

Book 5, Number 2331:

    'Abida narrated from 'Ali that he made a mention of the Khwarij (and in this connection) said that there would be a person among them with a defective hand. (or with a short hand) or a fleshy hand. If you were to exercise restraint, I would tell you what Allah has promised to those who would kill them on the order of Mubarrmad (may peace be upon him). I (the narrator) said to him: Did you hear it from Muhammad: (may peace be upon him)? He (Hadrat 'Ali) said: Yes, by the Lord of the Ka'ba; Yes, by the Lord of the Ka'ba; yes, by the Lord of the Ka'ba.

Book 5, Number 2332:

    'Abida said: I will not narrate to you except what I heard from him (Hadrat 'Ali), and then he narrated from him.

Book 5, Number 2333:

    Zaid b. Wahb Jahani reported and he was among the squadron which wall under the command of Ali (Allah be pleased with him) and which set out (to curb the activities) of the Khwarij. 'Ali (Allah be pleased with him) said: 0 people, I heard the Messeinger of Allah (may peace be upon him) say: There would arise from my Ummah a people who would recite the Qur'an, and your recital would seem insignificant as compared with their recital, your prayer as compared with their prayer, arid your fast,as compared with their fast. They would recite the Qur'an thinking that it sup- ports them, whereas it is an evidence against them. Their prayer does not get beyond their collar bone; they would swerve through Islam just as the arrow passes through the prey. If the squadron which is to encounter them were to know (what great boon) has been assured to them by their Apostle (may peace be upon him) they would completely rely upon this deed (alone and cease to do other good deeds), and their (that of the Khwarij) distinctive mark is that there would be (among them) a person whose wrist would be without the arm, and the end of his wrist would be fleshy like the nipple of the breast on which there would be white hair. You would be marching towards Muawiya and the people of Syria and you would leave them behind among your children and your property (to do harm). By Allah, I believe that these are the people (against whom you have been commanded to fight and get reward) for they have shed forbidden blood, and raided the animals of the people. So go forth in the name of Allah (to fight against them). Salama b. Kuhail mentioned that Zaid b. Wahb made me alight at every stage, till we crossed a bridge. 'Abdullah b. Wahb al-Rasibi was at the head of the Khwarij when we encountered them. He ('Abdullah) said to his army: Throw the spears and draw out your swords from their sheaths, for I fear that they would attack you as they attacked you on the day of Harura. They went back and threw their spears and drew out their swords, and people fought against them with spears and they were killed one after another. Only two persons were killed among the people (among the army led by Hadrat 'Ali) on that day. 'Ali (Allah be pleased with him) said: Find out from among them (the dead bodies of the Khwarij) (the maimed). They searched but did not find him. 'Ali (Allah be pleased with him) then himself stood up and (walked) till he came to the people who had been killed one after another. He ('Ali) said: Search them to the last, and then ('Ali's companions) found him (the dead body of the maimed) near the earth. He (Hadrat 'Ali) then pronounced Allah-O-Akbar (Allah is the Greatest) and then said, Allah told the Truth and His Messenger (may peace be upon him) conveyed it. Then there stood before him 'Abida Salmani who said: Commander of the Believers, by Allah, besides Whom there is no god but He, (tell me) whether you heard this hadith from the Messenger of Allah (may peace be upon him). He said: Yes, by Allah, besides Whom there is no god but He. He asked him to take an oath thrice and he took the oath.

Book 5, Number 2334:

    'Ubaidullah b. Abu Rafi', the freed slave of the Messenger of Allah (may peace be upon him), said: When Haruria (the Khwarij) set out and as he was with 'Ali b. Abu Talib (Allah be pleased with him) they said, "There is no command but that of Allah." Upon this 'Ali said: The statement is true but it is intentionally applied (to support) a wrong (cause). The Messenger of Allah (may peace be upon him described their characteristics and I found these characteristics in them. They state the truth with their tongue, but it does not go beyond this part of their bodies (and the narrator pointed towards his throat). The most hateful among the creation of Allah us one black man among them (Khwarij). One of his hand is like the teat of a goat or the nipple of the breast. When 'Ali b. Abu Talib (Allah be pleased with him) killed them, he said: Search (for his dead body). They searched for him, but they did not find it (his dead body). Upon this he said: Go (and search for him). By Allah, neither I have spoken a lie nor has the lie been spoken to me. 'Ali said this twice and thrice. They then found him (the dead body) in a rain. They brought (his dead) body till they placed it before him (Hadrat 'Ali). 'Ubaidullah said: And, I was present at (that place) when this happened and when 'Ali said about them. A person narrated to me from Ibn Hanain that he said: I saw that black man.

Book 5, Number 2335:

    Abu Dharr reported Allah's Messenger (may peace be upon him) as saying: Verily there would arise from my Ummah after me or soon after me a group (of people) who would recite the Qar'an, but it would not go beyond their throats, and they would pass clean through their religion just as the arrow passes through the prey, and they would never come back to it. They would be the worst among the creation and the creatures. Ibn Samit (one of the narrators) said: I met Rafi' b. 'Amr Ghifari, the brother of Al-Hakam Ghifari and I said: What is this hadith that I heard from Abu Dharr, i.e. so and so?-and then I narrated that hadith to him and said: I heard it from the Messenger of Allah (may peace be upon him).

Book 5, Number 2336:

    Yusair b. 'Amr reported that he inquired of Sahl b. Hunaif: Did you hear the Apostle of Allah (may peace be upon him) making a mention of the Khwarij? He said: I heard him say (and he pointed with his hand towards the east) that these would be a people who would recite the Qur'an with their tongues and it would not go beyond their collar bones. They would pass clean through their religion just as the arrow passes through the prey.

Book 5, Number 2337:

    This hadith had been transmitted by Sulaiman Shaibani with the same chain of narrators (and the words are), "There would arise out of (this group) many a group "

Book 5, Number 2338:

    Sahl b. Hunaif reported Allah's Apostle (may peace be upon him) as saying: There would arise from the east a people with shaven heads.

Chapter 46 : IT'IS FORBIDDEN TO PAY ZAKAT TO THE MESSENGER OF ALLAH (MAY PEACE BE UPON HIM) AND BANU HASHIM AND BANU MUTTALIB

Book 5, Number 2339:

    Abu Huraira reported that Hasan b. 'Ali took one of The dates of the sadaqa and put it in his mouth, whereupon the Prophet (may peace be upon him) said: Leave it, leave it, throw it; don't you know that we do not eat the sadaqa?

Book 5, Number 2340:

    This hadith has been narrated on the authority of Shu'ba with the same chain of transmitters (and the words of the Holy Prophet) are:"Sadaqa is not permis- sible for us."

Book 5, Number 2341:

    This very hadith has been narrated on the authority of Sbu'ba with the same chain of transmitters.

Book 5, Number 2342:

    Abu Huraira reported Allah's Messenger (may peace be upon him) as saying: I go back to my family and I find a date lying on my bed. I then take it up to eat it, but then I throw it away fearing that it may be a Sadaqa.

Book 5, Number 2343:

    Out of so many ahadith which Hammam b. Munabbih narrated on the authority of Abu Huraira from the Messenger of Allah (may peace be upon him) one is this that the Messenger of Allah (may peace be upon him) said: I go back to my family and I find a date lying on my bed or in my house, and I take it up to eat it, but then I throw it away fearing that it may be a Sadaqa or from Sadaqa.

Book 5, Number 2344:

    Anas b. Malik reported that the Apostle of Allah (may peace be upon him) found a date in the street and said: If it were not of sadaqa I would have eaten it.1457

Book 5, Number 2345:

    Anas b. Malik reported that the Messenger of Allah (may peace be upon him) found a date lying on the path and said: If it were not out of Sadaqa, I would have eaten it.

Book 5, Number 2346:

    Anas b. Malik reported that the Apostle of Allah (may peace be upon him) found a date and said: Were it not (that I fear) it may be part of sadaqa, I would have eaten it.

Chapter 47 : THE POSTERITY OF THE HOLY PROPHET (MAY PEACE BE UPON HIM) IS NOT ALLOWED TO MAKE USE OF SADAQA

Book 5, Number 2347:

    'Abd al-Muttalib b. Rabi'a b. al-Harith reported that Rabi'a b. al-Harith and Abbas b. Abd al-Muttalib gathered together and said: By Allah, if we had sent these two young boys (i.e. I and Fadl b. 'Abbas) to the Messenger of Allah (may peace be upon him) and they had spoken to him, he would have appointed them (as the collectors) of these sadaqat; and they would (collect them) and pay (to the Holy Prophet) as other people (collectors) paid and would get a share as other people got it. As they were talking about it there came 'Ali b. Abu Talib and stood before them, and they made a mention of it to him. 'Ali b. Abu Talib said: Don't do that; by Allah he (the Holy Prophet) would not do that (would not accept your request). Rabi'a b. Harith turned to him and said: By Allah, you are not doing so but out of jealousy that you nurse against us By Allah, you became the son-in-law of the Messenger of Allah (may peace be upon him) but we felt no jealousy against you (for this great privilege of yours). 'Ali then said: Send them (if you like). They set out and 'Ali lay on the bed. When the Messenger of Allah (may peace be upon him) offered the noon prayer. we went ahead of him to his apartment and stood near it till he came out. He took hold of our ears (out of love and affection) and then said: Give out what you have kept in your hearts. He then entered (the apartment) and we also went in and he (the Holy Prophet) was on that day (in the house of) Zainab b. jahsh. We urged each (of us) to speak. Then one of us thus spoke: Messenger of Allah, you are the best of humanity and the best to cement the ties of blood-relations. We have reached the-marriageable age. We have come (to you) so that you may appoint us (as collectors) of these sadaqat. and we would pay you just as thin people (other collectors) pay you, and get our share as others get it. He (the Holy Prophet) kept silence for a long time till we wished that we should speak with him (again), and Zainab pointied to us from behind the curtain not to talk (any more). He (the Holy Prophet) said; It does not become the family of Muhammad (to accept) sadaqat for they are the impurities of people. You call to me Mahmiya (and he was in charge of khums, i.e, of the one-fifth part that goes to the treasury out of the spoils of war), and Naufal b. Harith b. 'Abd al-Muttalib. They both came to him, and he (the Holy Prophet) said to Mahmiya: Marry your daughter to this young man (i.e. Fadl b. 'Abbas), and he married her to him And he said to Naufal b. Harith: Marry your daughter to this young man (i e. 'Abd al-Muttalib b. Rabi'a, the narrator of this hadith) and he married her to me, and he said to Mahmiya: Pay so much mahr on behalf of both of them from this khums Zuhri, however. said: He did not determine (the amount of mahr).

Book 5, Number 2348:

    Rabi'a b. Harith b. 'Abd al-Muttalib and Abbas b. 'Abd al-Muttalib said to Abd al-Muttalib b. Rabi'a and Fadl b. Ibn Abbas: Go to the Messenger of Allah (may peace be upon him), and the rest of the hadith is the same (but with this addition): "'Ali spread his cloak and then lay down on it and said: I am the father of Hasan, and I am the chief. By Allah, I would not move from my place till your sons come back to you with the reply to that for which you sent them to the Messenger of Allah (may peace be upon him). And he then also said: Verily these sadaqat are the impurities of people, and they are not permissible for Muhammad (may peaace be upon him), and for the family of Muhammad. And he also said: The Messenger of Allah (may peace be upon him) also said to me: Call Mahmiya b. Jaz', and he was person from Banu Asad. and the Messenger of Allah (may peace be upon him) had apointed him as a collector of khums.

Book 5, Number 2349:

    Juwayriya, the wife of the Messenger of Allah (may peace be upon him)" said that Messenger of Allah (may peace be upon him) came to her and said: Is there anything to eat? She said: Messenger of Allah, I swear by God, there is no food with us except a bone of goat which my freed maid-servant was given as sadaqa. Upon this he said : Bring that to me, for it (the sadaqa) has reached its destination.

Book 5, Number 2350:

    This hadith has been narrated by Zuhri with the same chain of trainsmitters.

Book 5, Number 2351:

    Anas b. Malik reported that Barira presented to the Apostle of Allah (may peace be upon him) a piece of meat which had been given to her as sadaqa. Upon this he (the Holy Prophet) said: That is a Sadaqa for her and a gift for us.

Book 5, Number 2352:

    'A'isha reported that (once) the Apostle of Allah (may peace be upon him,) was presented with beef.It was said (by someone) that it had been given to Barira as Sadaqa. Upon this he (the Prophet) said: It is a Sadaqa for her and a gift for us.

Book 5, Number 2353:

    'A'isha (Allah be pleased with her) said: Three are the decions (of the Shari'ah that we have come to know) through Barira. The people gave her sadaqa and she offered us as gift. We made a mention of it to the Apostle of Allah (may peace be upon him), whereupon he said: It is a sadaqa for her and a gift for you; so eat it.

Book 5, Number 2354:

    This hadith has been narrated on the authority of A'isha through another chain of transmitters.

Book 5, Number 2355:

    This hadith has been transmitted on the authority of 'A'isha in a similar manner except a slight variation that he said: "That is a gift for us out of it."

Book 5, Number 2356:

    Umm 'Atiyya, said: The Messenger of Allah (may peace be upon him) sent me some mutton of sadaqa. I sent a piece out of that to 'A'isha. When the Messenger of Allah (may peace be upon him) came to 'A'isha, he said: Have you anything with you (to eat)? She said: Nothing, except only that mutton sent to us by Nusaiba (the kunya of Umm 'Atiyya) which you had sent to her. Whereupon he said: It has reached its proper place.

Chapter 48 : ACCEPTING OF GIFT BY THE HOLY PROPHET (MAY PEACE BE UPON HIM) AND REFUSING THE SADAQA

Book 5, Number 2357:

    Abu Huraira reported: Whenever the Apostle of Allah (may peace be upon him) was presented with food, he asked about it, If he was told that it was a gift, he ate out of that, and if he was told that it was a sadaqa he did not eat out of that.

Chapter 49 : BLESSING FOR HIM WHO PRESENTS SADAQA

Book 5, Number 2358:

    'Abdullah b. Abu Aufa said that it was the common practice of the Mes- senger of Allah (may peace be upon him) that when the people brought to him sadaqa he blessed them: 0 Allah, bless them. So when Abu Aufa brought to him Sadaqa he (the Holy Prophet) said: 0 Allah, bless,the posterity of Abu Aufa.

Book 5, Number 2359:

    This hadith has been narrated by Shu'ba with the same chain of transmitters (but with a slight variation of words, that he said): (0 Allah), bless them."

Chapter 50 : TO PLEASE THE COLLECTOR OF ZAKAT, UNLESS HE MAKES AN UNJUST DEMAND

Book 5, Number 2360:

    Jarir b. 'Abdullah said:'When the collector of sadaqat (Zakat) comes to you, (you should see) that he goes away pleased with you.


BOOK 6: The Book Of Fasting (KITAB AL-SAWM)

KITAB AL-SAWM
THE BOOK OF FASTING

Back
INTRODUCTION

    After prayer the second obligatory duty which every Muslim is required toper- form is that of fasting during the month of Ramadan. The word sawm which has been used in the Holy Qur'an and the Hadith for fasting means "to abstain"; thus a horse that abstains from moving about or from eating the fodder is said to be sa'im. In the technical language sawm signifies fasting or abstaining from food and drink and sexual intercourse from the dim beginning of dawn till sunset.

    Fasting as an institution for the purification of the soul is common to all Divine religions. The writer of the article on "Fasting" in the Encyclopadia Britannica states that "it would be difficult to name any religious system of any description in which it is wholly unrecognized." This institution was well established among the Jews and the Christians.

    The records of the Hadith bear ample testimony to the fact that fasting was a common religious practice among the pre-Islamic Arabs too, and they used to observe fast on the tenth of Muharram because it was on this very day that Allah saved Moses and his companions from the clutches of the Pharaoh who was drowned in the sea along with his army. The Arabs and other people too were familiar with fasting as an act of penitence or of propitiation or a preparatory rite before some act of sacramental eating or an initiation or a mourning ceremony.

    In Islam fasting is primarily an institution for a spiritual discipline and selfcontrol. It is in fact an exercise in religious devotion in the form of cheerful and willing renunciation, for a definite period, of all the appetites of flesh lawful in themselves (the unlawful ones being ruled out of course). The Qur'an says:

      0 ye who believe ! prescribed unto you is fasting even as it was prescribed unto those before you. that haply you may become God-conscious (ii. 183).

    Of all the creation of God only man deviates from His path. We will find that two things are mainly responsible for this: the love for material possessions and the tempta- tions of the flesh. Islam has, through the institutions of Zakat and Sadaqat, purged the hearts of its followers from the love of wealth, and has inculcated in him the habit to part with it readily for the sake of God.

    Fasting has been ordained as a religious duty for the Muslims for subduing their lust and keeping their appetites well within reasonable bounds so that man may not become their slave and lose control over himself. The Qur'an clearly states that a man cannot attain salvation unless he learns to restrain his self from low desires. "And as for him who fears to stand before his Lord and restrains himself from low desires, Paradise is surely the abode" (lxxix. 40-41).

    The exercise of abstaining from things otherwise lawful in the ordinary course of life, at the behest of Allah, strengthens man's morality and self-control and deepens in him the consciousness of the Lord. This is what distinguishes fasting in Islam from fasting in other religions.

    It should also be borne in mind that fasting does not aim at inflicting punishment upon people or sadding upon them unbearable burdens. The underlying idea behind it is to teach moderation and spiritual discipline so that human temptations may not become so wild and uncontrollable as to flout the commands of the Great Master. To be a true servant of Allah, it is essential that man should be able to conform his behaviour to the moral and spiritual discipline embodied in the Shari'ah of Islam. One cannot achieve this end if one finds oneself helpless before untamed and turbulent desires. Fasting is indispensable for this moral and spiritual training.

    Another distinguishing feature of Islamic fasting is that it does not train a person for complete renunication but for perfect and cheerful obedience to the Lord All those things from which man is commanded to abstain during fast, e.g. eating, drinking and sexual intercourse, become permissible for him at the end of the fast. This shows that Islam does not look down upon the appetite of flesh as something ignoble and thus fit to be exterminated root and branch from the human soul. According to Islam, there is nothing profane or ignoble in human personality: both soul and body are sacred and worthy of respect. No aspect is to be ignored and no urge is to be completely curbed. What is required is to keep all these urges well within their proper limits so that none of them transgresses natural bounds and becomes the source of trouble.

    That fasting is an institution for moral elevation can be judged from the fact that Allah does not impose check only upon eating, drinking and sexual intercourse from dawn to sunset, but also exhorts His servants to refrain from other foul acts, for ex- ample, backbiting, indulging in foul speech, telling lies, etc. Abu Huraira reported Allah's Messenger (may peace be upon him) as saying : If one does not abandon falsehood and other actions like it, God has no need that one should abandon one's food and drink (Sahih Bukhari).

    The social aspect of fasting in Ramadan is that the whole atmosphere is permeated with religious piety and devotion to Allah. There is one extra congregational prayer, Tarawih, during the night, in which the Qur'an is recited and the Muslim is reminded of the fact that it was in the month of Ramadan that the revelation of the Qur'an commenced. The sadaqqt are also given with greater zeal and fervour in this month. Thus the whole Muslim society is inspired by the love of God. Abu Huraira reported Allah's Messenger (may peace be upon him) as saying: When Ramadan begins, the gates of Heaven are opened, the gates of Hell are locked, and the devils are chained (Bukhari and Muslim).

    Muhammad Asad, while elucidating the spiritual and moral significance of fast says: "Twofold I learned, is the purpose of this month of fasting. One has to abstain from food and drink in order to feel in one's body what the poor and hungry feel :thus social responsibility is being hammered into human consciousness as a religious postulate. The other purpose of fasting during Ramadan is self-discipline, an aspect of individual morality strongly accentuated in all Islamic teachings (as, for instance, in the total prohibition of all intoxicants, which Islam regards as too easy an avenue of escape from consciousness and responsibility). In these two elements-brotherhood of man and Individual self-discipline -I began to discern nhe outline of Islam's ethical out look" (Road to Mecca, London, 1954, p. 188).

Chapter 1 : EXCELLENCE OF THE MONTH OF RAMADAN

Book 6, Number 2361:

    Abu Huraira reported Allah's Messenger (may peace be upon him) as saying: When there comes the month of Ramadan, the gates of mercy are opened, and the gates of Hell are locked and the devils are chained,

Book 6, Number 2362:

    This hadith is reported by Abu Huraira (with a slight alteration of words) that the Messenger of Allah (may peace be upon him) said: "When (the month of) Ramadan begins."

Chapter 2 : FASTING IN RAMADAN SHOULD NECESSARILY BE COMMENCED WITH THE SIGHT OF THE NEW MOON AND FINISHED WITH THE SIGHT OF THE NEWMOON IF THE WEATHER IS CLOUDY AT THE BEGINNING OR AT THE END, THEN COMPLETE THIRTY DAYS

Book 6, Number 2363:

    Ibn Umar (Allah be pleased with both of them) reported Allah's Messenger (may peace be upon him) as saying in connection with Ramadan: Do not fast till you see the new moon, and do not break fast till you see it; but if the weather is cloudy calculate about it.

Book 6, Number 2364:

    Ibn Umar reported that Allah's Messenger (may peace be upon him) made a mention of Ramadan and he with the gesture of his hand said: The month is thus and thus. (He then withdrew his thumb at the third time). He then said: Fast when you see it, and break your fast when you see it, and if the weather is cloudy calculate it (the months of Sha'ban and Shawwal) as thirty days.

Book 6, Number 2365:

    This hadith is narrated on the authority of 'Ubaidullah with the same chain of transmitters, and he said: If (the sky) is cloudy for you, then calculate thirty days (for the month of Ramadan).

Book 6, Number 2366:

    'Ubaidullah narrated on the authority of the same chain of transmitters that the Messenger of Allah (may peace be upon him) made a mention of Ramadan and said: The month may consist of twenty-nine days, and it may be thus, thus and thus, and (he further) said: Calculate it, but he did not say thirty.

Book 6, Number 2367:

    Ibn'Umar (Allah be pleased with-both of them) reported Allah's Messenger (may peace be upon him) as saying: The month of Ramadan may consist of twenty-nine days. So do not fast till you have sighted it (the new moon) and do not break fast, till you have sighted it (the new moon of Shawwal), and if the sky is cloudy for you, then calculate.

Book 6, Number 2368:

    'Abdullah b. 'Umar (Allah be pleased with both of them) reported Allah's Messenger (may peace be upon him) as saying: The month (of Ramadan) may consist of twenty nine days; so when you see the new moon observe fast and when you see (the new moon again at the commencement of the month of Shawwal) then break It, and if the sky is cloudy for you, then calculate it (and complete thirty days).

Book 6, Number 2369:

    'Abdullah b. Umar (Allah be pleased with both of them) reported Allah's Measenger (may peace be upon him) as saying: When you see the new moon, observe fast, and when you see it (again) then break it, and if the sky is cloudy for you, then calculate it.

Book 6, Number 2370:

    Ibn 'Umar (Allah be pleased with both of them) reported Allah's Messenger (may peace be upon him) as saying: The month may consist of twenty-nine nights. So do not fast till you have sighted it (the new moon) and do not break it till you have sighted it, except when the sky is cloudy for you, and if it is so, then calculate it.

Book 6, Number 2371:

    Ibn Umar (Allah be pleased with both of them) reported Allah's Messenger (may peace be upon him) as saying: The month is thus and thus and thus (i.e. pointing with his fingers thrice), and he held back his thumb at the third time (in order to show that it can also consist of twenty-nine days).

Book 6, Number 2372:

    Ibn Umar (Allah be pleased with both of them) reported Allah's Messenger (may peace be upon him) as saying: The month may consist of twenty-nine days.

Book 6, Number 2373:

    Abdullah b. 'Umar (Allah be pleased with both of them) reported Allah's Messenger (may peace be upon him) as saying: The mouth (of Ramadan) is thus and thus, and thus. i.e. ten, ten and-nine.

Book 6, Number 2374:

    Ibn Umar (Allah be pleased with both of them) reported Allah's Messenger (may peace be upon him) as saying: The month is thus, and thus, and thus, and he flapped his hands with all their fingers twice. but at the third turn, folded his right thumb or left thumb (in order to give an idea of twenty-nine).

Book 6, Number 2375:

    Ibn 'Umar (Allah be pleased with both of them) reported Allah's Messenger (may peace be upon him) as saying: The month (of Ramadan) may consist of twenty. nine days, and Shu'ba (one of the narrators) (gave a practical demonstration how the Holy prophet (may peace be upon him) explained to them) by unfolding his hands thrice and folding his thumb at the third turn. 'Uqba (one of the narrators in this chain of trans- mitters) said: I think that he said that the month consists of thirty days and unfolded his palm three times.

Book 6, Number 2376:

    Ibn 'Umar(may Allah be pleased with both of them)reported Allah's Apostle (may peace be upon him) as saying: We are an unlettered people who can neither write nor count. The month is thus, and thus. folding his thumb when he said it the third time. This hadith has been narrated on the authority of Aswad b. Qais with the same chain of transmitters, but herein no mention has been made of the other month (consisting of) thirty days.

Book 6, Number 2377:

    Sa'd b.'Ubaida reported that Ibn'Umar(Allah be pleased with both of them) heard a person saying: This night is the midnight (of the month). Upon this he said to him: How do you know that it is the midnight (of the month), for I heard the Mes- senger of Allah (may peace be upon him) as saying: The month is thus and thus (and he pointed with his ten fingers twice) and thus (i.e. at the third time he pointed with all his fingers but withdrew or folded his thumb)?

Book 6, Number 2378:

    Abu Huraira reported Allah's Messenger (may peace be upon him) as saying: Whenever you sight the new moon (of the month of Ramadan) observe fast. and when you sight it (the new moon of Shawwal) break it, and if the sky is cloudy for you, then observe fast for thirty days.

Book 6, Number 2379:

    Abu Huraira reported Allah's Messenger (may peace be upon him) as saying: Observe fast on sighting it (the new moon) and break (fast) on sighting it (the new moon), but if the sky is cloudy for you, then complete the number (of thirty).

Book 6, Number 2380:

    Abu Huraira reported Allah's Messenger (may peace be upon him) as saying: Observe fast on sighting it (the new moon) and break it on sighting it. But if (due to clouds) the actual position of the month is concealed from you, you should then count thirty (days).

Book 6, Number 2381:

    Abu Huraira (Allah be pleased with him) narrated that the Messenger of Allah (may peace he upon him) made a mention of the new moon and (in this connection) said: Observe fast when you see it (the new moon) and break fast when you see it (the new moon of Shawwal), but when (the actual position of the month is) concealed from you (on account of cloudy sky), then count thirty days.

Chapter 3 : DO NOT FAST FOR A DAY OR TWO DAYS AHEAD OF RAMADAN

Book 6, Number 2382:

    Abu Huraira (Allah be pleased with him) reported Allah's Messenger (may peace be upon him)as saying: Do not observe fast for a day, or two days ahead of Ramadan except a person who is in the habit of observing a particular fast; he may fast on that day.

Book 35, Number 2383:

    This hadith has been narrated on the authority of Yahya b. Abi Kathir with the same chain of transmitters.

Chapter 4 : THE MONTH MAY CONSIST OF TWENTY-NINE DAYS

Book 6, Number 2384:

    Zuhri reported that (once) the Apostle of Allah (may peace be upon him) took an oath that he would not go to his wives for one Month. Zuhri said that 'Urwa narrated to him from 'A'isha (Allah be pleased with her) that she said: When twenty-nine nights were over, which I had counted, the Messenger of Allah (may peace be upon him) came to me (he came to me first of all). I said: Messenger of Allah, you had taken an oath that you would not come to us for a month, whereas you have come after twenty nine days which I have counted. Whereupon he said: The month may also consist of twenty-nine days.

Book 35, Number 2385:

    Jabir (Allah be pleased with her) narrated that the Holy Prophet (may peace be upon him) separated himself from his wives for a month. (His wives said:) He came to us on the twenty-ninth day, whereupon we said: It is the twenty-ninth (day) today. Thereupon he said: So far as the month is concerned, (and he, with a view to explaining it) flapped his hands thrice, but held back one finger at the last turn.

Book 35, Number 2386:

    Abu Zubair is reported to have heard Jabir b. 'Abdullah (Allah be pleased with both of them) as saying: The Apostle of Allah (may peace be upon him) separated himself from his wives for a month. (His wives said:) He came to us on the morning of the twenty-ninth. Upon this some, of the people said: It is the morning of twenty- ninth (according to our calculation). Upon this the Apostle of Allah (may peace be upon him) said: The month. may also consist of twenty-nine days. The Apostle of Allah (may peace be upon him) then flapped his bands thrice, twice with all the fingers of both his hand (to indicate twenty-nine) and by the third time with nine (fingers).

Book 35, Number 2387:

    Umm Salama (Allah be pleased with him) reported that the Apostle of Allah (may peace be upon him) took an oath that he would not go to some of his wives for the whole of the month. When twenty-nine days bad passed he (the Holy Prophet) went to them in the morning or in the evening. Upon this it was said to him: Apostle of Allah, you took an oath that you would not come to us for a month, whereupon he said: The month may also consist of twenty-nine days.

Book 35, Number 2388:

    A hadith like this has been narrated on the authority of Ibn Juraij with the same chain of transmitters.

Book 35, Number 2389:

    Sa'd b. Abi Waqqas (Allah be pleased with him) said that the Messenger of Allah (may peace be upon him) struck his hand against the other and (then with the gesture of his two hands) said: The month is thus, thus (two times). He then withdrew (one of) his fingers at the third turn.

Book 35, Number 2390:

    Muhammad b. Sa'd reported on the authority of his father (Sa'd b. Abi Waqqas (Allah be pleased with him) that the Apostle of Allah (may peace be upon him) had said: Tho month is thus and thus, and thus, i.e. ten, ten and nine. This hadith has been narrated by Abu Khalid with the same chain of transmitters.

Chapter 5 : THERE IS A SIGHTING OF THE MOON FOR EVERY TOWN; THE SIGHTING AT ONE TOWN CANNOT BE HELD VALID FOR THE OTHER TOWN SITUATED AT A CONSIDERABLE DISTANCE FROM IT

Book 6, Number 2391:

    Kuraib reported that Umm Fadl, daughter of Harith, sent him (Fadl, i.e. her son) to Mu'awiya in Syria. I (Fadl) arrived in Syria, and did the needful for her. It was there in Syria that the month of Ramadan commenced. I saw the new moon (of Ramadan) on Friday. I then came back to Medina at the end of the month. Abdullah b. 'Abbas (Allah be pleased with him) asked me (about the new moon of Ramadan) and said: When did you see it? I said.: We saw it on the night of Friday. He said: (Did) you see it yourself?-I said: Yes, and the people also saw it and they observed fast and Mu'awiya also observed fast, whereupon he said: But we saw it on Saturday night. So we would continue to observe fast till we complete thirty (lasts) or we see it (the new moon of Shawwal). I said: Is the sightidg of the moon by Mu'awiya not valid for you? He said: No; this is how the Messenger of Allah (may peace be upon him) has commanded us. Yahya b. Yahya was in doubt (whether the word used in the narration by Kuraib) was Naktafi or Taktafi.

Chapter 6 : IT IS IMMATERIAL WHETHER THE NEW MOON IS LARGE (ON ACCOUNT OF APPEARING AFTER THIRTY NIGHTS) OR SMALL (ON ACCOUNT OF APPEARING ON THE THIRTIETH NIGHT); AND ALLAH DEFERS IT TO MAKE IT SUITABLE FOR SIGHTING AND IF THE SKY IS CLOUDY, THEN THIRTY (FASTS) ARE TO BE COMPLETED

Book 6, Number 2392:

    Abu'l-Bakhtari reported: We went out to perform Umra and when we encamped in the valley of Nakhla, we tried to see the new moon. Some of the people said: It was three nights old, and others (said) that it was two nights old. We then met Ibn 'Abbas and told him we had seen the new moon, but that some of the people said it was three nights old and others that it was two nights old. He asked on which night we had seen it; and when we told him we had seen it on such and such night, he said the Prophet of Allah (may peace be upon him) had said: Verily Allah deferred it till the time it is seen, so it is to be reckoned from the night you saw it.

Book 35, Number 2393:

    Abu'l-Bakhtari reported: We saw the new moon of Ramadan as we were at Dhit-i-'Irq. We sent a man to Ibn Abbas (Allah be pleased with both of them) to ask him (whether the sighting of a small moon had something of the nature of defect in it). Upon this Ibn 'Abbas (Allah be pleased with both of them) said that the Messenger of Allah (may peace be upon him) had said: Verily Allah deferred its sight, but if (the new moon) is hidden from you, then,complete its number (thirty).

Chapter 7 : THE MONTHS OF 'ID ARE NOT INCOMPLETE

Book 6, Number 2394:

    The son of Abu Bakra reported it on the authority of his father that the Apostle of Allah (may peace be upon him) had said: The two months of 'Id, Ramadan and Dhu'l-Hijja (are not incomplete).

Book 35, Number 2395:

    'Abd ar-Rahman b. Abu Bakra reported on the authority of Abu Bakra that the Apostle of Allah (may peace be upon him) had said: The months of 'Id are not incomplete. And in the hadith narrated by Khalid (the words are): "The months, of 'Id are Ramadan and Dhu'l-Hijja."

Chapter 8 : THE TIMING OF FAST BEGINS WITH DAWN

Book 6, Number 2396:

    'Adi b. Hatim (Allah be pleased with him) reported that when (this verse) was revealed: "Until the white streak of the dawn becomes distinct from the dark streak" (ii. 187) Adi b. Hatim said: Messenger of Allah, verily I keep underneath my pillow two strings, one white and the other black, by which I distinguish night from dawn. Upon this the Messenger of Allah (may peace be upon him) said: Your pillow seems to be very large. For the word khait implies the blackness of the night and the whiteness of the dawn.

Book 35, Number 2397:

    Sahl b. Sa'd said that when this verse was revealed: "Eat and drink till the white streak is distinct from the dark streak," a person would take hold of a white thread and a black thread and keep on eating till he could find them distinct (in the light of the dawn). It was then that Allah, the Majestic and Great, reveiled (the words) min al-fajr (from the dawn), and then it became clear (that the word khait refers to the streak of light in the dawn).

Book 35, Number 2398:

    Sahl b. Sa'd (Allah be pleased with him) said : When this verse was reveal- ed. "Eat and drink till the white streak becomes distinct from the dark streak for you," the person who decided to observe fast tied on one of his feet a black thread and on the other a white thread. And he went on eating and drinking till he could distinguish (between their colour) on seeing them. It was after this that Allah reveal- ed (the words): min al-fajr. And they (the Muslims) came to know that (the word khait) refers to the night and day.

Book 35, Number 2399:

    'Abdullah b. Mas'ud (Allah be pleased with him) reported that the Messenger of Allah (may peace be upon him) had said: Bilal would pronounce Adhan (at the fag end of the night in order to inform the people about the time of the Sahri). So you eat and drink till you hear the Adhan of Ibn Umm Maktum (which was pro- nounced at the conclusion of the Sahri and the commencement of the fast).

Book 35, Number 2400:

    Abdullah b. 'Umar (Allah be pleased with both of them) reported: I heard the Messenger of Allah (may peace be upon him) as saying: Bilal announces Adhan during the night, so you eat and drink, till you hear the Adhan of Ibn Umm Maktum.

Book 35, Number 2401:

    Ibn 'Umar(Allah be pleased with both of them)reported that the Messenger of Allah (may peace be upon him) had two Mu'adhdhins,Bilal and son of Umm Maktum, the blind. The Messenger of Allah (may peace be upon him) said: Bilal announces Adhan at (the fag end of the) night (i.e. Sahri), so eat and drink till the son of Umm Maktum announces Adhan.And he (the narrator) said: And the (difference of time) between their (Adhans) was not more than this that one climbed down (from the minaret) and the other climbed up (to announce Adhan).

Book 35, Number 2402:

    A hadith like this has been transmitted on the authority of 'A'isha (Allah be pleased with her).

Book 35, Number 2403:

    A hadith like this has been narrated on the authority of 'Ubaidullah on the two chains of transmitters.

Book 35, Number 2404:

    Ibn Mas'ud (Allah be pleased with him) reported Allah's Messenger (may peace be upon him) as saying The Adhan of Bilal should not restrain anyone among you from eating Sahur (last meal before daybreak during the month of Ramadan) for he announces Adhan (or he calls) at (the fag end of) the night to make him turn who stands for prayer among you, and to awaken those who are sleeping among you. And he said: The dawn is not like it, as one says (and he lifted his hand) till he (dispersed his fingers) and said: It is like this.

Book 35, Number 2405:

    This hadith has been narrated by Sulaiman al-Taimi with the same chain of transmitters (but with a slight variation of words) that he (the Holy Prophet) said: The dawn is not like it as it is said; he then gathered his fingers and lowered them. But he said, it is like this (and he placed the index finger upon the other one and spread his hand).

Book 35, Number 2406:

    This hadith has been narrated on the authority of Sulaiman Taimi with the same chain of transmitters and, at the end, it was said that the first Adhan was meant to awaken those who were in slumber amongst them and in order to make them turn who stand in (prayer) among them (towards food at the commencement of the fast). Jarir (one of the narrators) said that the Messenger (may peace be upon him) did not say like this but he said like it (true dawn) that the streaks of (true dawn ) are horizontal and not vertical.

Book 35, Number 2407:

    Samura b. Jandub reported Muhammad (may peace be upon him) as saying. The call of Bilal may not mislead any one of you (and he may, under the wrong impression gathered from it, refrain) from taking meal before the commencement of the fast (for the streaks) of this whiteness (which are vertical indicate the false dawn and the true dawn with which the fast commences is that when the streaks of light are) spread.

Book 35, Number 2408:

    Samura b. Jundub reported Allah's Messenger (may peace be upon him) as saying: The Adhan of Bilal should not mislead you nor the whiteness (of the pillar) of dawn, for it is not the whiteness of the true dawn, but that of the false dawn which is vertical like a pillar and you can eat food till the streaks of whiteness spread like it.

Book 35, Number 2409:

    Samura b. Jundub (Allah be pleased with him) reported Allah's Messenger (may peace be upon him) as saying: The Adhan of Bilal may not mislead you with regard to your food at the commencement of the fast, nor the vertical (streaks) of whiteness in the horizon (for it is an indication of false dawn). You should stop eating (food) till (the whiteness) spreads like it.Hammad narrated it and with the gesture of his band he explained,the horizontal position (of the streaks of light).

Book 35, Number 2410:

    Samura b. Jundub addressed and narrated from the Apostle of Allah (may peace be upon him) having said (these words): Neither the call of Bilal should mislead you nor this whiteness (of false dawn) till (the true) dawn appears (or he said) till the dawn breaks.

Book 35, Number 2411:

    A hadith like this has been narrated on the authority of Samura b.Jundub.

Chapter 9 : EXCELLENCE OF TAKING MEAL BEFORE DAWN, STRESS ON GIVING IT PREFERENCE AND PREFERENCE FOR DEFERRING IT (AT THE FAG END OF THE NIGHT) AND HASTENING IN BREAKING IT

Book 6, Number 2412:

    Anas (Allah be pleased with him) reported Allah's Messenger (may peace be upon him) as saying: Take meal a little before dawn, for there is a blessing in taking meal at that time.

Book 35, Number 2413:

    'Amr b. al-'As reported Allah's Messenger (may peace be upon him) as saying: The difference between our fasting and that of the people of the Book is eating shortly before dawn.

Book 35, Number 2414:

    Musa b. 'Ali has narrated this hadith through the same chain of transmitters.

Book 35, Number 2415:

    Zaid b. Thabit (Allah be pleased with him) said: We took meal shortly before dawn along with the Messenger of Allah (may peace be upon him). We then stood up for prayer. I said: How much span of time was there between the two (acts, i.e. taking of Sahri and observing of prayer)? He said (a span of reciting) fifty verses.

Book 35, Number 2416:

    This hadith has been transmitted on the authority of Qatada too.

Book 35, Number 2417:

    Sahl b. Sa'd (Allah be pleased with him) repotted Allah's Messenger (may peace be upon him) as saying: The people will continue to prosper as long as they hasten the breaking of the fast.

Book 35, Number 2418:

    A hadith like this has been transmitted by Sahl b. Sa'd.

Book 35, Number 2419:

    Abu 'Atiyya reported: I and Masruq went to 'A'isha and said to her: Mother of the Believers, there are two persons among the Companions of Muhammad (may peace be upon him) one among whom hastens in breaking the fast and in observing prayer, and the other delays breaking the fast and delays observing prayer. She said: Who among the two hastens in breaking fast and observing prayers? We said, It is 'Abdullah. i.e. son of Mas'ud. whereupon she said: This is how the Messenger of Allah (may peace be upon him) did. Abu Kuraib added: The second one was Abu Musa.

Book 35, Number 2420:

    Abu 'Atiyya reported: I and Misruq went to 'A'isha (Allah be pleased with her) and Masruq said to her: There are two persons among the Companions of Muhammad (may peace be upon him) none of whom abandons the good, but one of them hastens to observe sunset prayer and break the fast, and the other delays in observing the sunset prayer and in breaking the fast, whereupon she said: Who hastens to observe sunset prayer and break the fast ? He said: It is 'Abdullah. Upon this she said: This is how the Messenger of Allah(may peace be upon him) used to do.

Chapter 10 : THE TIME FOR BREAKING THE FAST AND ENDING OF DAY

Book 6, Number 2421:

    'Umar (Allah be pleased with him) reported Allah's Messenger (may peace be upon him) as saying: When the night approaches and the day retreates and the sun sinks down, then the observer of the fast should break it. Ibn Numair made no mention of the word "then".

Book 35, Number 2422:

    'Abdullah b. Abi Aufa reported: We were with the Messenger of Allah (may peace be upon him) on a journey during the month of Ramadan. When the sun had sunk he said: So and so, get down (from your ride) and prepare the meal of parched barley for us. He said: Messenger of Allah, still (there is light of) day. He (the Holy Prophet) said: Get down and prepare meal of parched barley for us. So he got down and prepared the meal of parched barley and offered him, and the apostle of Allah (may peace be upon him) drank that (liquid meal). He then told with the gesture of his hand that when the sun sank from that side and the night appeared from that side, then the observer of the fast should break it.

Book 35, Number 2423:

    Ibn Abi Aufa (Allah be pleased with him) reported: We were with the Messenger of Allah (may peace be upon him) on a journey. When the sun sank he said to a person: Get down and prepare barley meal for us. Upon this he said: Messenger of Allah, let there be dusk. (He the Holy Prophet) said: Get down and prepare barley meal for us. He (the person) said: There is still (the light of) day upon us. (But) he got down (in obedience to the command of the Holy Prophet) and prepared a barley meal for him and he (the Holy Prophet) drank that (liquid meal) and then said: When you see the night approaching from that side (west) (and he pointed towards the east with his hand), then the observer of the fast should break it.

Book 35, Number 2424:

    Abdullah b. Abi Aufa (Allah be pleased with him) reported: We travelled with the Messenger of Allah (may peace be upon him) as he had been observing fast. When the sun sank he said: So and so, get down and prepare barley meal for us. The rest of the hadith is the same.

Book 35, Number 2425:

    This hadith has been narrated on the authority of Ibn Abi Aufa (Allah be pleased with him) through another chain of transmitters (but with a sight alteration of words): In this hadith transmitted by one of the narrators (neither these words are found): During the month of Ramadan." nor his statement: "And the night prevails from that side (the eastern side)." (These words are found in the narration of)Hushaim only.

Chapter 11 : IT IS FORBIDDEN TO OBSERVE UNINTERRUPTED FASTING

Book 6, Number 2426:

    Ibn 'Umar (Allah be pleased with both of them) said that the Apostle of Allah (may peace be upon him) forbade uninterrupted fasting. They (some of the Companions) said: You yourself fast uninterruptedly, whereupon he said: I am not like you. I am fed and supplied drink (by Allah).

Book 35, Number 2427:

    Ibn 'Umar reported that the Messenger of Allah (may peace be upon him) abserved fasts uninterruptedly in Ramadan and the people (in his wake) did this. But he forbade them to do so. It was said to him (to the Holy Prophet): You yourself observe the fasts uninterruptedly (but you forbid us to do so) Upon this he said:I am not like you; I am fed and supplied drink (by Allah).

Book 35, Number 2428:

    A hadith like this has been transmitted by Ibn 'Umar (Allah be pleased with both of them), but he did not make mention of (the words): "During the month of Ramadan."

Book 35, Number 2429:

    Abu Huraira (Allah be pleased with him) reported: The Messenger of Allah (may peace be upon him) forbade (his Companions) from observing fast unintermptedly. One of the Muslims said: Messenger of Allah, you yourself observe Saum Wisal. whereupon the Messenger of Allah (may peace be upon him) said: Who among you is like me? I spend night (in a state) that my Allah feeds me and provides me drink. When they (the Companions of the Holy Prophet) did not agree in abandoning the uninterrupted fast, then the Holy Prophet (may peace.be upon him) also observed this fast with them for a day, and then for a day. They then saw the new moon and he (the Holy Prophet) said: If the appearance of the new moon were delayed. I would have observed more (fasts) with you (and he did it) by way of warning to them as they had not agreed to refrain (from observing Saum Wisal)

Book 35, Number 2430:

    Abu Huraira (Allah be pleased with him) reported Allah's Messenger (may peace be upon him) as saying: Abstain from Saum-Wisal.They (his Companions) said: Messenger of Allah, but you observe Saum Wisal. Upon this he said: You are not like me in this matter, for I spend my night (in a state) that my Lord feeds me and provides me drink Devote yourselves to the deeds (the burden of which) you can bear.

Book 35, Number 2431:

    Abu Huraira (Allah be pleased with him) reported Allah's Apostle (may peace be upon him) as saying (the words as said in the previous hadith) but with this alteration (of words): "Take upon yourselves (the burden of the deeds) for which you have the strength to bear."

Book 35, Number 2432:

    Abu Huraira reported that the Apostle of Allah (may peace be upon him) forbade (his Companions) to observe Saum Wisal.

Book 35, Number 2433:

    Anas (Allah be pleased with him) reported The Messenger of Allah (may peace be upon him) was observing prayer during Ramedan. I came and stood by his side. Then another man came and he stood likewise till we became a group.When the Apostle of Allah (may peace be upon him) perceived that we were behind him, he lightened the prayer. He then went to his abode and observed such (a long) prayer (the like of which) he never observed with us. When it was morning we said to him: Did you perceive us during the night? Upon this he said: Yes, it was this (realisation) that induced me to do that which I did. He (the narrator) said: The Messenger of Allah (may peace be upon him) began to observe Saum Wisal at the end of the month (of Ramadan), and some persons among his Companions began to observe this uninter- rupted fast, whereupon the Apostle of Allah (may peace be upon him) said: What about such persons who observe uninterrupted fasts? You are not like me. By Allah. if the month were lengthened for me, I would have observed Saum Wisal, so that those who act with an exaggeration would (have been obliged) to abandon their exaggeration.1501

Book 35, Number 2434:

    Anas (Allah be pleased with him) reported that the Messenger of Allah (may peace be upon him) observed Saum Wisal during the early part of the month of Ramadan. The people among Muslims also observed uninterrupted fast. This (news) reached him (the Holy Prophet) and he said: Had the month been lengthened for me I would have continued observing Saum Wisal, so that those who act with forced hardness would (have been obliged) to abandon it. You are not like me (or he said): I am not like you. I continue to do so (in a state) that my Lord feeds me and provides me drink.

Book 35, Number 2435:

    'A'isha (Allah be pleased with her) said: The Apostle of Allah (may peace be upon him) forbade them (his Companions) to observe Saum Wisal out of mercy for them. They said: You (Holy Prophet) yourself observe it. Upon this he said: I am not like you. My Lord feeds me and provides me drink.

Chapter 12 : KISSING IS NOT FORBIDDEN WHILE FASTING IF ONE IS NOT URGED BY SEXUAL LUST

Book 6, Number 2436:

    'A'isha (Allah be pleased with her) said that the Messenger of Allah (may peace be upon him) kissed one of his wives while he was fasting, and then she ('A'isha) smiled (as she narrated).

Book 35, Number 2437:

    Sufyan reported: I said to 'Abd al-Rahman b. Qasim: Have you heard from your father narrating from 'A'isha (Allah be pleased with her) that he kissed her while observing fast? He ('Abd al-Rahman b. Qasim) kept silence for a short while and then said: "Yes."

Book 35, Number 2438:

    'A'isha reported: Allah's Messenger (may peace be upon him) used to kiss me while observing fast; and who among you can control his desire as the Messenger of Allah (may peace be upon him) could control his desire.

Book 35, Number 2439:

    'A'isha (Allah be pleased with her) reported: Allah's Messenger (may peace be upon him) used to kiss (his wives) while fasting and embraced (them) while fasting; but he had the greatest mastery over his desire among you.

Book 35, Number 2440:

    'A'isha (Allah be pleased with her) reported: The Messenger of Allah (may peace be upon him) used to kiss (his wives) while fasting; and he had the greatest control over his desire (as compared with you).

Book 35, Number 2441:

    'A'isha (Allah be pleased with her) said that the Messenger of Allah (may peace be upon him) used to embrace (his wives) while fasting.

Book 35, Number 2442:

    Aswad reported: I and Masruq went to 'A'isha (Allah be pleased with her) and asked. her if the Messenger of Allah (may peace be upon him) embraced (his wives) while fasting. She said: Yes; but he had the greatest control over his desire among you: or he was one of those who had control over his desire. It is further narrated on the authority of Aswad and Masruq that they went to the Mother of the Believers and they asked her (and the rest of the hadith is the same)

Book 35, Number 2443:

    'Urwa b. Zubair narrated that 'A'isha the Mother of the Believers (Allah be pleased with her) informed him that the Messenger of Allah (may peace be upon him) kissed her while fasting.

Book 35, Number 2444:

    A hadith like this has been narrated by Yahya b. Abu Kathir with the same chain of transmitters.

Book 35, Number 2445:

    'A'isha (Allah be pleased with her) reported that the Messenger of Allah (may peace be upon him) used to kiss her during the month of fasting.

Book 35, Number 2446:

    'A'isha (Allah be pleased with her) reported that Allah's Messenger (may peace be upon him) kissed (his wives) during Ramadan while observing fast.

Book 35, Number 2447:

    'A'isha (Allah be pleased with her) reported that Allah's Apostle (peace be upon him) kissed (his wives) while fasting.

Book 35, Number 2448:

    Hafsa (Allah be pleased with her) reported that the Messenger of Allah (may peace be upon him) kissed (his wives) while fasting.

Book 35, Number 2449:

    A hadith like this has been narrated by Hafsa (Allah be pleased with her) through another chain of transmitters.

Book 35, Number 2450:

    Umar b Abu Salama reported that he asked the Messenger of Allah (may peace be upon him): Should one observing fast kiss (his wife)? The Messenger of Allah (may peace be upon him) said to him: Ask her (Umm Salama). She informed him that the Messenger of Allah (may peace be upon him) did that, where upon he said: Messenger of Allah, Allah pardoned thee all thy sins, the previous and the later ones. Upon this the Messenger of Allah (may peace be upon him)) said: By Allah, I am the most God conscious among you and I fear Him most among you.

Chapter 13 : THERE IS NO HARM IN OBSERVING FAST IF ONE IS JUNBI EVEN AFTER DAWN

Book 6, Number 2451:

    Abu Bakr (he is Abu Bakr b. Abd al-Rahman b. Harith) reported: I heard Abu Huraira (Allah be pleased with him) narrating that he who is overtaken by dawn in a state of seminal emission should not observe fast. I made a mention of it to 'Abd al-Rahman b. Harith (i.e. to his father) but he denied it. 'Abd al-Rahman went and I also went along with him till we came to'A'isha and Umm Salama (Allah be pleased with both of them) and Abd al-Rahman asked them about it. Both of them said: (At times it so happened) that the Apostle of Allah (may peace be upon him) woke up in the morning in a state of junub (but without seminal emission in a dream) and observed fast He (the narrator) said: We then proceeded till we went to Marwan and Abd al-Rahman made a mention of it to him. Upon this Marwan said: I stress upon you (with an oath) that you better go to Abu Huraira and refer to him what is said about it. So we came to Abu Huraira and Abu Bakr had been with us throughout and 'Abd al-Rahman made a mention of it to him, whereupon Abu Huraira said: Did they (the two wives of the Holy Prophet) tell you this? He replied: Yes Upon this (Abu Huraira) said: They have better knowledge. Abu Huraira then attributed that what was said about it to Fadl b. 'Abbas and said: I heard it from Fadl and not from the Apostle of Allah (may peace be upon him). Abu Huraira then retracted from what he used to say about it. Ibn Juraij (one of the narrators) reported: I asked 'Abd al-Malik, if they (the two wives) said (made the statement) in regard to Ramadan, whereupon he said: It was so, and he (the Holy Prophet) (woke up in the) morning in a state of junub which was not due to the wet dream and then observed fast.

Book 35, Number 2452:

    'A'isha, the wife of the Apostle of Allah (may peace be upon him), said: The dawn broke upon the Messenger of Allah (may peace be upon him) during the Ramadan in a state of junub not because of sexual dream (but on account of intercourse) and he washed himself and observed fast.

Book 35, Number 2453:

    Abu Bakr reported that Marwan sent him to Umm Salama to ask whether a person should observe fast who is in a state of junub and the dawn breaks upon him, whereupon she said that the Messenger of Allah (may peace be upon him) (was at times) junbi on account of intercourse and not due to sexual dream, and the dawn broke upon him, but he neither broke the fast nor recompensed.

Book 35, Number 2454:

    Abu Bakr b. 'Abd al-Rahman b. al-Harith b. Hisham reported on the authority of 'A'isha and Umm Salama, the wives of the Apostle of Allah (may peace be upon him): The Messenger of Allah (may peace be upon him) at times got up in the morning in a state of junub on account of having a sexual intercourse (with his wives during night) but not due to sexual dreams in the month of Ramadan, and would observe fast.

Book 35, Number 2455:

    'A'isha reported that a person came to the Apottle of Allah (may peace be upon him) asking for a fatwa (religious verdict). She ('A'isha) had been overhearing it from behind the curtain. 'A'isha added that he (the person) had said: Messenger of Allah, (the time) of prayer overtakes me as I am in a state of junub; should I observe fast (in this state)? Upon this the Messenger of Allah (may peace be upon him) said: (At times the time) of prayer overtakes me while I am in a state of junub, and I observe fast (in that very state), whereupon he said: Messenger of Allah, you are not like us Allah has pardoned all your sins, the previous ones and the later ones. Upon this he (the Holy Prophet) said: By Allah, I hope I am the most God-fearirg of you, and possess the best knowledge among you of those (things) against which I should guard.

Book 35, Number 2456:

    Sulaiman b. Yasar reported that he asked Umm Salama whether a person (who gets up) in the morning in a state of junub should observe fast. She said: The Messenger of Allah (may peace be upon him) (at times) got up in the morning in a state of junub, not because of sexual dreams (but on account of intercourse at night), and then observed fast.

Chapter 14 : SEXUAL INTERCOURSE IS COMPLETELY FORBIDDEN DURING THE DAY IN THE MONTH OF RAMADAN

Book 6, Number 2457:

    Abu Huraira (Allah be pleased with him) reported that a person came to the Apostle of Allah (may peace be upon him) and said: Messenger of Allah, I am undone. He (the Holy Prophet) said: What has brought about your ruin? He said: I have had intercourse with my wife during the month of Ramadan. Upon this he (the Holy prophet) said: Can you find a slave to set him free? He said: NO He (the Holy Prophet again) said: Can you observe fast for two consecutive months? He said: No. He (the Holy Prophet) said: Can you provide food to sixty poor people?, He said: No. He then sat down and (in the meanwhile) there was brought to the Apostle of Allah (may peace be upon him) a basket which contained dates. He (the Holy Prophet) said: Give these (dates) in charity. He (the man) said: Am I to give to one who is poorer than I? There is no family poorer than mine between the two lava plains of Medina. The Apostle of Allah (may peace be upon him) laughed so that his molar teeth became visible and said: Go and give it to your family to eat.

Book 35, Number 2458:

    A hadith like this has been narrated on the authority of Mubammad b. Muslim al-Zuhri with the same chain of transmitters, and he said: There was brought an 'araq containing dates, an 'araq being a huge basket. But in this hadith no men- tion has been made of (the fact) that the Apostle of Allah (may peace be upon him) laughed till his molar teeth became visible.

Book 35, Number 2459:

    Abu Huraira reported that a person had intercourse with his wife during Ramadan (while fasting). He asked for the religious verdict (about it) from the Messenger of Allah (may peace be upon him), whereupon he (the Holy Prophet) said: Can you find a slave (to grant him freedom) ? He said: No. He (the Holy Prophet again) said: Can you afford to observe fasts for two (consecutive) months ? He said: No. He (the Holy Prophet) said: Then feed sixty poor men.

Book 35, Number 2460:

    This hadith has been narrated on the authority of Zuhri with the same chain of transmitters that a person broke fast in Ramadan whereupon the Messenger of Allah (may peace be upon him) commanded him to free a slave (as an atonement), and the rest of the hadith is the same as narrated by Ibn Uyaina.

Book 35, Number 2461:

    Humaid b. 'Abd al-Rahman reported that Abu Huraira had narrated to him that the Apostle of Allah (may peace be upon him) commanded the person (who) broke the fast in Ramadan to free a slave or observe fasts for two (consecutive) months or feed sixty poor persons.

Book 35, Number 2462:

    This hadith has been narrated with the same chain of transmitters on the authority of Zuhri.

Book 35, Number 2463:

    'A'isha (Allah be pleased with her) reported that a person came to the Messenger of Allah (may peace be upon him) and said: I am burnt, whereupon the Messenger of Allah (may peace be upon him) said: How is it? He (the person) said: I had intercourse with my wife during the day in Ramadan. Upon this (the Holy Prophet) said: Give charity, give charity. He (the person) said: There is nothing with me. He commanded him to sit down, (In the meanwhile) there were brought to him (to the Holy Prophet) two baskets containing eatables, whereupon the Messenger of Allah (may peace be upon him) told him to give them as sadaqa.

Book 35, Number 2464:

    'Abbad b. Abdullah b. Zubair narrated that he heard 'A'isha (Allah be pleased with her) saying: A person came to the Messenger of Allah (may peace be upon him), and he then narrated the hadith. But (neither these words are found):"Give charity, give charity" (nor) his words: "during the day time".

Book 35, Number 2465:

    Abbad b. Abdullah b. Zubair reported that he had heard 'A'isha, the wife of the Apostle of Allah (may peace be upon him), as saying: A person came to the Messenger of Allah (may peace be upon him) in the mosque during (the month of) Ramadan and said: Messenger of Allah, I am burnt I am burnt, whereupon the Mes- senger of Allah (may peace be upon him) asked him as to what the matter was. Upon this he said: I had intercourse with my wife (in a state of fasting) Thereupon he (the Holy Prophet) said: Give charity. Upon this he said: Apostle of Allah, I swear by God, there is nothing with me (to give in charity) as I do not possess anything. He (the Holy Prophet) said: Sit down. So he sat down and he was in this very state when there came a person urging a donkey with a load of eatables upon it. The Mes- senger of Allah (may peace be upon him) said: Where is that burnt one who was just here? Thereupon the person stood up. The Messenger of Allah (may peace be upon him) said: Give this (eatables brought by the man) in charity. Upon this the person said: Messenger of Allah, can there be anyone else (more deserving than I)? By Allah. we are hungry, we have nothing with us. Upon this he (the Holy Prophet) said: Then eat (these eatables).

Chapter 15 : PERMISSIBILITY OF OBSERVING THE FAST OR NOT OBSERVING IT IN THE MONTH OF RAMADAN FOR A TRAVELLER

Book 6, Number 2466:

    Ibn Abbas (Allah be pleased with him) reported that the Messenger of Allah (may peace be upon him) went out during the month of Ramadan in the year of Victory (when Mecca was conquered) and was fasting till he reached Kadid (a canal situated at a distance of forty-two miles from Mecca) and he then broke the fast. And it was the habit of the Companions of the Messenger of Allah (may peace be upon him) to follow him in every new thing (or act). So they followed him also (in this matter).

Book 35, Number 2467:

    This hadith is narrated on the authority of Zuhri with the same chain of transmitters. Yahya (one of the narrators) said that Sufyan (the narrator) had stated: I do not know whose statement it is: "It is the last word of the Messenger of Allah (may peace be upon him) which is accepted as (final as it abrogates the previous ones)."

Book 35, Number 2468:

    It has been narrated on the authority of Zuhri with the same chain of transmitters that breaking of fast (in a journey) is the final of the two commands (whether one may fast or one may break it), and it is the last command of the Messenger of Allah (may peace be upon him) which is to be accepted as final. Zuhri said: The Messenger of Allah (may peace be upon him) marched on Mecca on the morning of 14th of Ramadan (lit. when thirteen nights had passed).

Book 35, Number 2469:

    A hadlth like this has been transmitted on the authority of Ibn Shibab who said that they (the Compnions of the Holy Prophet) followed the latest of his commands and looked upon it as one abrogating (the previous ones) and the most firm.

Book 35, Number 2470:

    Ibn 'Abbas (Allah be pleased with him) reported that the Messenger of Allah (may peace be upon him) journeyed during the month of Ramadan in a slate of fasting till he reached 'Usfan. He then ordered a cup containing drinking water and he drank that openly so that the people might see it, and broke the fast (and did not resume it) till he reached Mecca. Ibn 'Abbas (Allah be pleased with him) said: Allah's Messenger (may peace be upon him) fasted and broke the fast, so he who wished fasted and he who wished to break it broke it.

Book 35, Number 2471:

    Ibn Abbas (Allah be pleased with him) reported: Do not condemn one who observes fast, or one who does not observe (in a journey). for the Messenger of Allah (may peace be upon him) observed fast in a journey or he did not observe it (too).

Book 35, Number 2472:

    Jabir b. 'Abdullah (Allah be pleased with both of them) reported that Allah's Messenger (may peace be upon him) went out to Mecca in Ramadan in the year of Victory, and he and the people fasted till he came to Kura' al-Ghamim and the people also fasted. He then called for a cup of water which he raised till the people saw it, and then he drank. He was told afterwards that some people had continued to fast, and he said: These people are the disobedient ones; these are the disobedient ones.

Book 35, Number 2473:

    This hadith has been narrated by Ja'far with the some chain of trans- mitters and he added: It was said to him (to the Holy Prophet): There are people to whom fasting has become unbearable and they are waiting how you do. He (the Holy Prophet) then called for a cup of water when it was afternoon. The rest of the hadith is the same.

Book 35, Number 2474:

    Jabir b. 'Abdullah (Allah be pleased with both of them) reported that in the course of a journey Allah's Messenger (may peace be upon him) saw a man, people crowding around him and providing him a shade. Upon this he (the Holy Prophet) said: What is the matter with him? They said: He is a person observing fast. Whereupon the Messenger of Allah (may peace be upon him) said: It is no righteousness that you fast on journey.

Book 35, Number 2475:

    'Amr b. al-Hasan is reported to have said that he heard Jabir b. 'Abdullah (Allah be pleased with both of them) as saying that the Messenger of Allah (may peace be upon him) saw a man. The rest of the hadith is the same as mentioned above.

Book 35, Number 2476:

    This hadith has been narrated on the authority of Shu'ba with the same chain of transmitters but with this addition that he (the Holy Prophet) said: "Take advantage of the concession of Allah Who Wanted it to you." When he (one of the narrators) asked him (the other one, Yabya b. Abi Kathar) he did not retain it in his mind.

Book 35, Number 2477:

    Abu Sa'id al-Khudri (Allah be pleased with him) reported: We went out on an expedition with Allah's Messenger(may peace be upon him)on the 16th of Ramadan. Some of us fasted and some of us broke the fast. But neither the observer of the fast found fault with one who broke it, nor the breaker of the fast found fault with one who observed it.

Book 35, Number 2478:

    A hadith like this has been narrated on the authority of Qatada with the same chain of transmitters by different narrators (except this difference) that in the hadith transmitted by Taimi and Umar b. Amir and Hisham (the date of setting out is) 18th, and in the hadith transmitted by Sa'id it is the 12th, and in the one transmitted by Shu'ba it is the 17th or 19th.

Book 35, Number 2479:

    Abu Sa'id al-Khudri (Allah be pleased with him) reported: We went out on an expedition with the Messenger of Allah (may peace be upon him) during Ramadan and neither the observer of the fast was found fault with for his fasting, nor the breaker of the fast for breaking it.

Book 35, Number 2480:

    Abu Sa'id al-Khudri (Allah be pleased with him) reported: We went out on an expedition with the Messenger of Allah (may peace be upon him) during Ramadan. Some of us observed the fast and some of us broke it. Neither the observer of the fast had any grudge against one who broke it, nor the breaker of the fast had any grudge against one who had fasted They knew that he who had strength enough (to bear its rigour) fasted and that was good, and they also found that he who felt weakness (and could not bear the burden) broke it, and that was also good.

Book 35, Number 2481:

    Abu Nadra reported Abu Sa'id al.Khudri and Jabir b. Abdullah as saying: We travelled with the Messenger of Allah (may peace be upon him). The observer of the fast observed it, and the breaker of the fast broke it, but none of them found fault with each other.

Book 35, Number 2482:

    Humaid reported that Anas (Allah be pleased with him) was asked about fasting during Ramadan while travelling. He said: We travelled with the MesseDger of Allah (may peace be upon him) during the month of Ramadan, but neither the ob- server of the fast found fault with the breaker of the fast, nor the breaker of the fast found fault with the observer of the fast.

Book 35, Number 2483:

    Abu Khalid al-Ahmar narrated from Humaid who said: I went out and was fasting; they said to me: Break (lit go back, repeat). He said that Anas reported that the Companions of the Messenger of Allah (may peace be upon him) used to set out on a journey and neither the observer of the fast found fault with the breaker of the fast, nor the breaker of the fast found fault with the observer of the fast. (One of the narrators Humaid said): I met Ibn Abi Mulaika who informed me the same thing on the authority of 'A'isha.

Chapter 16 : THE REWARD OF ONE WHO DOES NOT OBSERVE FAST BECAUSE OF A RELIGIOUS DUTY

Book 6, Number 2484:

    Anas (Allah be pleased with him) reported: We were with the Apostle of Allah (may peace be upon him) on a journey. Some of us had been observing the fast and some of us had not been fasting. We got down at a place on a hot day. Most of us had the cloth for shelter. There were also those amongst us who sheltered (themselves against the rays of the) sun with the help of their hands. The observers of the fast fell down (on account of weakness). Those who had not observed it got up and pitched tents and watered the mounts. Thereupon the Messenger of Allah (may peace be upon him) said: The breakers of the fast have taken away the reward today.

Book 35, Number 2485:

    Anas (Allah be pleased with him) reported that the Messenger of Allah (may peace be upon him) was journeying (along with his Companions). Some of them had observed the fast whereas the others had broken it. Those who did not fast girded up their loins and worked, but the observers of the fast were too weak to work. Upon this he (the Apostle of Allah) said: Today the breakers of the fast have gone with the reward.

Book 35, Number 2486:

    Qaza'a reported: I came to Abu Sa'id al-Khudri (Allah be pleased with him) and he was surrounded (by people), and when they dispersed I said to him: I am not going to ask you about what these people were asking. I ask you about fasting on a journey. Upon this he said: We travelled with the Messenger of Allah (may peace be upon him) towards Mecca and we had been observing fast. We halted at a place. There the Messenger of Allah (may peace be upon him) said: You are nearing your enemy and breaking of fast would give you greater strength, and that was a concession (given to us). But some of us continued to observe the fast and some of us broke it. We then got down at another place and he (the Holy Prophet) said: You are going to encounter the enemy in the morning and breaking of the fast would give you strength, so break the fast. As it was a point of stress, so we broke the fast. But subsequently we saw ourselves observing the fast with the Messenger of Allah (may peace be upon him) on a journey.

Chapter 17 : CHOICE FOR OBSERVING FAST AND BREAKING IT ON A JOURNEY

Book 6, Number 2487:

    'A'isha (Allah be pleased with her) reported that Hamza b. 'Amr al-Aslami asked the Messenger of Allah (may peace be upon him) about fasting on a journey, and he (the Holy Prophet) said: Fast if you like and break it if you like.

Book 35, Number 2488:

    'A'isha (Allah be pleased with her) reported that Hamza b. Amr al-Aslami asked the Messenger of Allah (may peace be upon him) thus: Messenger of Allah, I am a person devoted much to fasting. Should I fast during the journey? He (the Holy Prophet) said: Fast if you like and break it if you like.

Book 35, Number 2489:

    This hadith has been narrated on the authority of Hisham with the same chain of transmitters.

Book 35, Number 2490:

    This hadith has been narrated on the authority of Hisham with the same chain of transmitters that Hamza said: I am a person much used to fasting. Should I fast during the journey? (The rest of the hadith is the same.)

Book 35, Number 2491:

    Hamza b. 'Amr al-Aslami (Allah be pleased with him) said: Messenger of Allah, I find strength in me for fasting on a journey; is there any sin upon me (in doing it) ? Thereupon the Messenger of Allah (may peace be upon him) said: It is a concession from Allah.He who took advantage of it, it is good for him, and he who preferred to observe fast, there is no sin upon him. Harun (one of the narrators) in his narration said:'lt is a concession, and he made no mention of "from Allah".

Book 35, Number 2492:

    Abu Darda' (Allah be pleased with him) reported: We set out during the month of Ramadan with the Messenger of Allah (may peace be upon him) in such an intense heat that one of us would place his hand over his head (in order to protect himself) against the excessive heat, and none among us was observing the fast, except the Messenger of Allah (may peace be upon him) and 'Abdullah b. Rawaha.

Book 35, Number 2493:

    Abu Darda' reported: We were with the Messenger of Allah (may peace be upon him) on some of his journeys on an intensely hot day so much so that a person would place his hand on his head (in order to protect himself) against excessive heat, and none amongst us was fasting but the Messenger of Allah (may peace be upon him) and Abdullah b. Rawaha

Chapter 18 : IT IS PREFERABLE FOR THE PILGRIM NOT TO OBSERVE FAST IN 'ARAFAT ON THE DAY OF 'ARAFA

Book 6, Number 2494:

    Umm al-Fadl bint- al-Harith reported that some people argued about the fasting of the Messenger of Allah (may peace be upon him) on the day of 'Arafa. Some of them said that he had been fasting, whereas the others said that he had not been fasting.I sent a cup of milk to him while he was riding his camel at 'Arafa, and he drank it.

Book 35, Number 2495:

    This hadith has been narrated on the authority of Abu Nadr with the same chain of transmitters, but he did not mention that he was mounting (riding on) his camel.

Book 35, Number 2496:

    This hadith has been narrated by Abu Nadr on the authority of Umair, the freed slave of Umm al-Fadl, through the same chain of transmitters.

Book 35, Number 2497:

    Umm al-Fadl (Allah be pleased with her) is reported to have said that some people among the Companions of the Messenger of Allah (may peace be upon him) were in doubt about fasting on the day of 'Arafa and we were with him on that day. I (Umm al-Fadl) sent him a cup of milk and he was halting at 'Arafa, and he drank that.

Book 35, Number 2498:

    Kuraib, the freed slave of Ibn 'Abbas (Allah be pleased with him), reported from Maimuna, the wife of the Apostle of Allah (may peace be upon him), that people had doubt about the fasting of Allah's Messenger (may peace be upon him) on the day of 'Arafa. Maimuna sent him a cup of milk and he was halting at a place and he drank it and the people were seeing him.

Chapter 19 : FASTING ON THE DAY OF 'ASHURA (1OTH OF MUHARRAM)

Book 6, Number 2499:

    'A'isha (Allah be pleased with her)reported that the Quraish used to fast on the day of 'Ashura in the pre-Islamic days and the Messenger ot Allah (may peace be upon him) also observed it. When he migrated to Medina, he himself observed this fast and commanded (others) to observe it. But when fasting during the month of Ramadan was made obligatory he said: He who wishes to observe this fast may do so, and he who wishes to abandon it may do so.

Book 35, Number 2500:

    This hadith is narrated on the authority of Hisham with the same chain of transmitters, but he made no mention in the first part of the hadith that the Messenger of Allah (may peace be upon him) used to observe fast, and said about the second part that he abandoned the (fast) of Ashura, and he who wished observed the fast and who wished otherwise abandoned it,and he did not hold it as the words of the Apostle of Allah (may peace be upon him) as mentioned in the narration transmitted by Jarir.

Book 35, Number 2501:

    'A'isha (Allah be pleased with her) reported. In the pre-Islamic days fast was observed on the day of Ashura, but with the advent of Islam (its position was ascertained as that of a voluntary fast). Then he who wished to fast fasted, and he who liked to abandon it abandoned it.

Book 35, Number 2502:

    'A'isha (Allah be pleased with her) reported that the Messenger of Allah (may peace be upon him) had ordered to observe fast (on 'Ashura) before the fasting in Ramadan was made obligatory. But when it became obligatory, then he who wished fasted on the day of Ashura, and he who wished did not observe it (on that day).

Book 35, Number 2503:

    'A'isha (Allah be pleased with her) reported that the Quraish used to observe fast on the day of Ashura during the pre-Islamic days. The Messenger of Allah (may peace be upog him) then commanded to fast on that day till (fasting) in Ramadan became obligatory. Then the Messenger of Allah (may peace be upon him) said: He who wished to fast should do so. and he who wished to break it may do so.

Book 35, Number 2504:

    Abdullah b. 'Umar (Allah be pleased with them) reported that (the Arabs of) pre-Islamic days used to observe fast on the day of Ashura and the Messenger of Allah (may peace be upon him) observed it and the Muslims too (observed it) before fasting in Ramadan became obligatory. But when it became obligatory, the Messenger of Allah (may peace be upon him) said: 'Ashura is one of the days of Allah, so he who wished should observe fast and he who wished otherwise should abandon it.

Book 35, Number 2505:

    A hadith like this has been narrated on the authority of Abdullah through the same chain of transmitters.

Book 35, Number 2506:

    Ibn 'Umar (Allah be pleased with them) said that the day of 'Ashura was mentioned before the Messenger of Allah (may peace he upon him). Thereupon the Messenger of Allah,(may peace be upon him) said: That was a day on which the people of pre-Islamic days used to observe fast. So he who amongst you likes to observe fast should do so, and he who does not like it should abandon it.

Book 35, Number 2507:

    Abdullah b. 'Umar (Allah be pleased with both of them) reported that he heard the Messenger of Allah (may peace be upon him) say about the day of Ashura: It is a day on which the people of pre-Islamic days observed fast. So he who liked to fast on this day should do so, and he who liked to abandon it should abandon it. 'Abdullah (Allah be pleased with him) did not observe fast except when it coincided (with the days when he was in the habit of observing voluntary fasts during every month).

Book 35, Number 2508:

    Abdullah b. Umar (Allah be pleased with them) reported that the day of 'Ashura was mentioned before the Apostle of Allah (may peace be upon him) and he narrated a hadith like one (narrated above).

Book 35, Number 2509:

    'Abdullah b. Umar (Allah be pleased with them) reported that the day of 'Ashura was mentioned before the Messenger of Allah (may peace be upon him) and he said: It is a day when the people in the pre-Islamic days need to observe fast, so he who wishes to observe fast should do so, and he who wishes to abandon it should do so.

Book 35, Number 2510:

    Abd al-Rahman b. Yazid said: When al-Ash'ath b. Qais entered the house of 'Abdullah he was having his breakfast. He ('Abdullah b. Umar) said: Abd Muhammad (al-Asha'th), come near to the breakfast. Thereupon he said: Is not today the day of 'Ashura? He ('Abd al-Rahman) said: Do you know what the day of 'Ashura is? He said: What is it? He said: It is a day on which the Messenger of Allah (may peace be upon him) used to observe fast before the (fasting) in the month of Ramadan (became) obligatory. But when it became obligatory the (fasting of 'Ashura) was abandoned (as compulsory). Abu Kuraib said: He (the Holy Prophet) abandoned it.

Book 35, Number 2511:

    This hadith has been narrated from Jarir on the authority of A'mash with the same chain of transmitters and he said (these words with a little bit of variation from the previous hadith) : When (fasting) in Ramadan was (made) obligatory, he aban- doned it (the practice of observing fast on Ashura).

Book 35, Number 2512:

    Qais b Sakan reported that al-Ash'ath b. Qais went to 'Abdullah on the day of 'Ashura while he was eating. He said: Abu Muhammad, come near and dine. Upon this he said: I am fasting. Thereupon he said: We used to observe fast and then (this practice) was abandoned.

Book 35, Number 2513:

    'Alqama reported that Ash'ath b. Qais went to Ibn Mas'udd while he was eating on the day of Ashura. Thereupon he said: Abu Abd al-Rahman, it is the day of 'Ashura (and you are eating). Upon this he said: Fast was observed on (this day) before the (fasting) in Ramadan was made obligatory, but when it was made obligatory, (fasting on the day of 'Ashura) was abandoned. So if you are not fasting, then take food.

Book 35, Number 2514:

    Jabir b Samura reported that the Messenger of Allah (may peace be upon him) commanded us to observe fast on the day of Ashura and exhorted us to do it and was particular about it But when (fasting) in Ramadan was made obligatory, he hence. forth neither commanded us nor forbade us, nor was he so particular about it.

Book 35, Number 2515:

    Abd al-Rahman reported that he heard Mu'awiya b. Abu Sufyan delivering a sermon in Medina. i.e. when he came there (for Hajj). He delivered a sermon on the day of 'Ashura and said: People of Medina, where are your scholars? I heard the Messenger of Allah (may peace be upon him) say on this very day: It is the day of 'Ashura. Allah has not made fasting on This day obligatory for you but I am fasting. He who likes to observe fast among you should do so, and he who likes not to observe it may not observe it.

Book 35, Number 2516:

    A hadith like this has been narrated on the authority of Ibn Shihab through the same chain of transmitters.

Book 35, Number 2517:

    This hadith has been narrated on the authority of Zuhri with the same chain of transmitters that be heard Allah's Apostle (may peace be upon him) as saying on a similar day: I am fasting today, so he who wishes to observe fast should do so; but he did not make mention of the rest of the hadith.

Book 35, Number 2518:

    Ibn Abbas (Allah be pleased with both of them) reported that when Allah's Messenger (may peace be upon him) came to Medina, he found the Jews observing the fast on the day of Ashura. They (the Jews) were asked about it and they said: It is the day on which Allah granted victory to Moses and (his people) Bani Isra'il over the Pharaoh and we observe fast out of gratitude to Him. Upon this the Apostle of Allah (may peace be upon him) said: We have a closer connection with Moses than you have, and he commanded to observe fast on this day.

Book 35, Number 2519:

    This hadith has been narrated by Ibn Bishr with the same chain of trans- mitters (but with a slight variation) that he (the Holy Prophet) inquired of them (Jews) about it (fasting on the day of 'Ashura).

Book 35, Number 2520:

    Ibn'Abbas (Allah be pleased with both of them) reported that the Messenger of Allah (may peace be upon him) arrived in Medina and found the Jews observing fast on the day of 'Ashura. The Messenger of Allah (may peace be upon him) said to them: What is the (significance) of this day that you observe fast on it? They said: It is the day of great (significance) when Allah delivered Moses and his people, and drowned the Pharaoh and his people, and Moses observed fast out of gratitude and we also observe it. Upon this the Messenger of Allah (may peace be upon him) said: We have more right, and we have a closer connection with Moses than you have; so Allah's Messenger (may peace be upon him) observed fast (on the day of 'Ashura), and gave orders that it should be observed.

Book 35, Number 2521:

    This hadith has been narrated on the authority of Ayyub with the same chain of transmitters.

Book 35, Number 2522:

    Abu Musa (Allah be pleased with him) reported: The day of 'Ashura was one which the Jews respected and they treated it as Id. The Messenger of Allah (may peace be upon him) said: You also observe fast on this day.

Book 35, Number 2523:

    Abu Musa reported that the people of Khaibar (most of them were Jews) observed fast on tht day of 'Ashura and they treated it as 'Id and gave their women ornaments and beautiful dresstowear. The Messenger of Allah (may peace be upon him) said: You (only) observe fast on this day.

Book 35, Number 2524:

    Ibn Abbas was asked about observing of fast on the day of Ashura, whereupon he said: I do not know Allah's Messenger (may peace be upon him) singling out any day's fast and considering it more excellent than another, except this day (the day of Ashura) and this month, meaning the month of Ramadan.

Book 35, Number 2525:

    A hadith like this has been narrated on the authority of 'Ubaidullah b. Abi Yazid.

Chapter 20 : ON WHICH DAY THE FAST IS TO BE OBSERVED IN MUHARRAM

Book 6, Number 2526:

    Hakam b. al-'Araj reported: I went to Ibn 'Abbas (Allah be Pleased with both of them) and he was reclining using his mantle as a pillow near the fountain of Zamzam. I said to him: Tell me about fasting on Ashura. He said: When you see the new moon of Muharram then count the (days) and observe fast on the 9th. I said to him: Is it how the Messenger of Allah (may peace be upon him) observed the fast? He said: Yes.

Book 35, Number 2527:

    Hakam b. 'Araj reported: I asked Ibn Abbas (Allah be pleased with them) as he was reclining using his cloak as a pillow near Zamzam about fasting on 'Ashura. The rest of the hadith is the same.

Book 35, Number 2528:

    Ibn 'Abbas reported that when the Messenger of Allah (may peace be upon him) fasted on the day of 'Ashura and commanded that it should he observed as a fast, they (his Companions) said to him : Messenger of Allah, it is a day which the Jews and Christians hold in high esteem. Thereupon the Messenger of Allah (may peace be upon him) said: When the next year comes, God willing, we would observe fast on the 9th But the Messenger of Allah (may peace be upon him) died before the advent of the next year.

Book 35, Number 2529:

    Abdullah b 'Abbas reported that the Messenger of Allah (may peace be upon him) had said: If I live till the next (year), I would definitely observe fast on the 9th, and the narration transmitted by Abu Bakr is: "He meant the day of Ashura."

Chapter 21 : HE WHO ATE ON THE DAY OF ASHVRA SHOULD ABSTAIN (FROM EATING) FOR THE REST OF THE DAY (AS A MARK OF RESPECT)

Book 6, Number 2530:

    Salama b. al-Akwa' (Allah be pleased with him) reported that the Messenger of Allah (may peace be upon him) sent a person of the tribe of Aslam on the day of 'Ashura and commanded him to declare to the people to observe fast in case they had not observed it, and to complete fast till evening if they had taken food

Book 35, Number 2531:

    Rubayyi' daughter of Mu'awwidh b. 'Afra' said that the Messenger of Allah (may peace be upon him) sent (a person) on the morning of Ashura to the villages of Ansar around Medina (with this message): He who got up in the morning fasting (without eating anything) he should complete his fast, and he who had had his breakfast in the morning, he should complete the rest of the day (without food). The Companions said; We henceforth observed fast on it (on the day of 'Ashura) and, God willing, made our children observe that. We went to the mosque and made toys out of wool for them and when anyone felt hungry and wept for food we gave them these toys till it was the time to break the fast.

Book 35, Number 2532:

    Khalid b. Dhakwan reported: I asked Rubayyi' daugther of Mu'awwidh about fasting on the day of 'Ashura. Thereupon she said: The Messenger of Allah (may peace he upon him) sent his messenger to the villages of the Ansar, and the rest of the hadith is the same (but with this variation that one of the Companions) said: "We used to make toys out of wool and took (them to the mosque) along with us. When they (the children)asked us for food, we gave them these toys to play with, and these made them forgetful till they completed their fast."

Chapter 22 : FORBIDDANCE TO OBSERVE FAST ON 'ID-UL-FITR AND 'ID-UL-ADHA

Book 6, Number 2533:

    Abu Ubaid, the freed slave of Ibn Azhar, reported: I observed Id along with Umar b. al-Khattab (Allah be pleased with him). He came (out in an open space) and prayed and (after) completing it addressed the people and said: The Messenger of Allah (may peace be upon him) has forbidden the observing of fast on these two days. One is the day of Fitr (at the end of your fasts), and the second one, the day when you eat (the meat) of your sacrifices.

Book 35, Number 2534:

    Abu Huraira (Allah be pleased with him) reported that the Messenger of Allah (may peace be upon him) forbade to observe fast on these two days. 'Id-ul-Adha bi and 'Id-ul-Fitr.

Book 35, Number 2535:

    Qaza'a related from Abu Sa'id. He said: I heard from him (Abu Sa'id) a hadith which impressed me, and I said to him: Did you hear it from the Messenger of Allah (may peace be upon him)? Thereupon he said: (Is it possible) that (I should) say about the Messenger of Allah (may peace be upon him) that which I have not heard? I heard him saying: It is not proper to fast on two days, Adha and Fitr (at the end) of Ramadan.

Book 35, Number 2536:

    Abu Sa'id al-Khudri (Allah be pleased with him) reported that the Messenger of Allah (may peace be upon him) forbade to observe fast on two days the day of Fitr and the day of Sacrifice ('Id-ul-Adha).

Book 35, Number 2537:

    Ziyad b. Jubair reported that a person came to Ibn 'Umar (Allah be pleased with them) and said: I had taken a vow that I would fast on the day (but it accidentally) synchronises with the day of Adha or the day of Fitr. Thereupon Ibn 'Umar (Allah be pleased with him) said: Allah, the Exalted, has commanded fulfilling of the vow, but the Messenger of Allah (may peace be upon him) has forbidden the observance of fast on this day.

Book 35, Number 2538:

    'A'isha (Allah be pleased with her) said that the Prophet (may peace be upon him) forbade to observe fast on two days-the day of Fitr and the day of Adha.

Book 35, Number 2539:

    Nubaisha al-Hudhali reported Allah's Messenger (may peace be upon him) as saying: The days of Tashriq are the days of eating and drinking.

Book 35, Number 2540:

    Nabaisha reported that Khalid said: I met Abu Malih and asked him and he narrated it to me from the Apostle of Allah (may peace be upon him). a hadith like one (narrated above) with this addition: "And remembrance of Allah"

Book 35, Number 2541:

    Ibn Ka'b b. Malik reported on the authority of his father that the Messenger of Allah (may peace be upon him) sent him and Aus b. Hadathan during the days of Tashriq to make this announcement: None but the believer would be admitted into Paradise, and the days of Mina' are the days meant for eating and drinking.

Book 35, Number 2542:

    This hadith has been narrated on the authority of Ibrahim b. Tahman with the same chain of transmitters but with this variation that he said: Both of them made the announcement."

Chapter 23 : DISAPPROVAL OF FASTING ON FRIDAY ALONE

Book 6, Number 2543:

    Muhammad b. 'Abbas b. Ja'far reported: I asked Jabir b. 'Abdullah (Allah be pleased with both of them) as he was circumambulating the House (Ka'ba) whether the Messenger of Allah (may peace be upon him) had forbidden the fasting on Friday, whereupon he said: Yes, by the Lord of this House.

Book 35, Number 2544:

    Muhammad b. 'Abbas b. Ja'far reported that he asked Jabir b. Abdullah (Allah be pleased with them), whether he had heard like this from the Apostle of Allah (may peace be upon him).

Book 35, Number 2545:

    Abu Huraira (Allah be pleased with him) reported the Apostle of Allah (may peace be upon him) as saying: None among you should observe fast on Friday, but only that he observes fast before it and after it.

Book 35, Number 2546:

    Abu Huraira (Allah be pleased with him) reported Allah's Apostle (may peace be upon him) as saying: Do not single out the night (preceding) Friday among the nights for prayer and do not single out Friday among days for fasting but only when anyone among you is accustomed to fast (on dates) which coincide with this day (Friday).

Chapter 24 : ABROGATION OF THE WORDS OF ALLAH: "AND AS FOR THOSE WHO CAN FAST (BUT DO NOT) THE EXPIATION IS" BY THE WORDS: "WHOSOEVER WITNESSES IT HE SHALL HAVE TO FAST THE WHOLE MONTH" (ii. 184)

Book 6, Number 2547:

    Salama b. Akwa' (Allah be pleased with him) reported that when this verse was revealed: "And as for those who can fast (but do not) expiation is the feeding of a needy person" (ii. 183), (he who liked to observe fast did observe it) and he who felt reluctant to observe it ate and expiated till the verse was revealed which abro- gated it.

Book 35, Number 2548:

    Salama b. Akwa' reported: We, during the lifetime of the Messenger of Allah (may peace be upon him), in one month of Ramadan (observed fast according to our liking). He who wished to fast lasted and he who wished to break broke it and fed a needy person as an expiation 1544 till this verse was revealed: "He who witnesses among you the month (of Ramadan) he should observe fast during it" (ii. 184).

Chapter 25 : PERMISSIBILIY OF COMPLETING THE (MISSED) FASTS OF RAMADAN BEFORE THE COMMENCEMENT OF THE COMING RAMADAN

Book 6, Number 2549:

    Abu Salama reported: I heard 'A'isha (Allah be pleased with her) as saying: I had to complete some of the fasts of Ramadan, but I could not do it but during the month of Sha'ban due to my duties to the Messenger of Allah (may peace be upon him) or with the Messenger of Allah (may peace be upon him).

Book 35, Number 2550:

    This hadith is narrated on the authority of Yahya b. Sa'id with the same chain of transmitters but with this variation that he said that ('A'isha did not observe fast but in Sha'ban) out of regard for the Messenger of Allah (may peace be upon him). (In another version, the words are): "Yahya said: I think it was due to the regard for the Apostle of Allah (may peace be upon him)."

Book 35, Number 2551:

    This hadith is reported on the authority of Yahya with the same chain of transmitters but no mention is made of the duty to the Messenger of Allah (may peace be upon him).

Book 35, Number 2552:

    'A'isha reported: If one amongst us had to break fasts (of Ramadan due to natural reasons, i.e. menses) during the life of the Messenger of Allah (may peace be upon him) she could not find it possible to complete them so long she had been in the presence of Allah's Messenger (may peace be upon him) till Sha'ban commenced.

Chapter 26 : COMPLETING OF THE FAST ON BEHALF OF THE DEAD

Book 6, Number 2553:

    'A'isha (Allah be pleased with her) reported Allah's Messenger (may peace be upon him) as saying: If anyone dies in a state (that he had to complete) some fasts, his heir must fast on his behalf.

Book 35, Number 2554:

    Ibn 'Abbas (Allah be pleased with both of them) reported: A woman came to the Messenger of Allah (may peace be upon him) and said: My mother has died, and fasts of a month are due from her. Thereupon he said: Don't you see that if debt was due from her, would you not pay it? She said: Yes (I would pay on her behalf). Thereupon he said: The debt of Allah deserves its payment more than (the payment of anyone else).

Book 35, Number 2555:

    Ibn 'Abbas (Allah be pleased with them) reported: A man came to the Apostle of Allah (may peace be upon him) and said: Messenger of Allah, my mother has died (in a state) that she had to observe fasts of a month (of Ramadan). Should I complete (them) on her behalf? thereupon he (the Holy Prophet) said: Would you not pay the debt if your mother had died (without paying it)? He said: Yes. He (the Holy Prophet) said: The debt of Allah deserves more that it should he paid.

Book 35, Number 2556:

    This hadith has been narrated on the authority of Ibn 'Abbas (Allah be pleased with them) from the Apostle of Allah (may peace be upon him).

Book 35, Number 2557:

    Ibn Abbas (Allah be pleased with them) reported:A woman came to the Messenger of Allah (may peace be upon him) and said: Messenger of Allah, my mother has died and there is due from her a fast of vow; should I fast on her behalf? Thereupon he said: You see that if your mother had died in debt, would it not have been paid on her behalf? She said: Yes. He (the Holy Prophet) said: Then observe fast on behalf of your mother.

Book 35, Number 2558:

    Abdullah b. Buraida (Allah be pleased with him) reported on the authority of his father: When we were sitting with the Messenger of Allah (may peace be upon him), a woman came to him and said: I had gifted to my mother a maid-servant, and now she (the mother) has died. Thereupon he (the Holy Prophet) said: There is a definite reward for you and she (the maid-servant) has been returned to you as an inheritance. She (that woman) again said: Fasts of a month (of Ramadan) are due upon her; should I observe them on her behalf ? He (the Holy Prophet) said: Observe fasts on her behalf. She (again) said: She did not perform Hajj , should I perform it on her behalf? He (the Holy Prophet) said: Perform Hajj on her behalf.

Book 35, Number 2559:

    'Abdullah b. Buraida (Allah be pleased with him) reported on the authority of his father: I was sitting with the Apostle of Allah (may peace be upon him); the rest of the hadith is the same but with this variation that the (the narrator) said: "Fasts of two months."

Book 35, Number 2560:

    Ibn Buraida (Allah be pleased with him) reported on the authority of his father: A woman came to the Apostle of Allah (may peace be upon him), and the rest of the hadith is the same, but he said: "Fasting of one month." This hadith has been narrated on the authority of Sufyan with the same chain of transmitters in which it is said: "Fasting of two months."

Book 35, Number 2561:

    Buraida (Allah be pleased with him) reported a similar hadith on the authority of his father that a woman came to the Apostle of Allah (may peace be upon him) and he said: "Fasting for one month."

Chapter 27 : WHEN AN OBSERVER OF FAST IS INVITED TO A FEAST, OR SOMEONE FIGHTS WITH HIM, HE SHOULD SAY:"I AM FASTING"

Book 6, Number 2562:

    Abu Huraira (Allah be pleased with him) reported Allah's Apostle (may peace be upon him) as saying: If any one of you is invited to a meal when he is fasting, he should say: "I am fasting."

Book 35, Number 2563:

    Abu Huraira (Allah be pleased with him) reported: When any one of you gets up in the morning in the state of fasting, he should neither use obscene language nor do any act of ignorance. And if anyone slanders him or quarrels with him, he should say: "I am fasting, I am fasting."

Chapter 28 : EXCELLENCE OF FASTING

Book 6, Number 2564:

    Abu Huraira reported Allah's Messenger (may peace be upon him) as saying: Allah, the Majestic and the Exalted, said: Every act of the son of Adam is for him except fasting. It is done for My sake, and I will give a reward for it. By Allah in Whose Hand is the life of Muhammad, the breath of the observer of fast is sweeter to Allah than the fragrance of musk.

Book 35, Number 2565:

    Abu Huraira reported Allah's Messenger (may peace be upon him) as saying: Fasting is a shield.

Book 35, Number 2566:

    Abu Huraira reported Allah's Messenger (may peace be upon him) as saying: Allah the Exalted and Majestic said: Every act of the son of Adam is for him, except fasting. It is (exclusively) meant for Me and I (alone) will reward it. Fasting is a shield. When any one of you is fasting on a day, he should neither indulge in obscene language, nor raise the voice; or if anyone reviles him or tries to quarrel with him he should say: I am a person fasting. By Him, in Whose Hand is the life of Muhammad, the breath of the observer of fast is sweeter to Allah on the Day of judgment than the fragrance of musk. The one who fasts has two (occasions) of joy, one when he breaks the fast he is glad with the breaking of (the fast) and one when he meets his Lord he is glad with his fast.

Book 35, Number 2567:

    Abu Huraira (Allah be pleased with him) reported Allah's Messenger (may peace be upon him) as saying: Every (good) deed of the son of Adam would be multiplied, a good deed receiving a tenfold to seven hundredfold reward. Allah, the Exalted and Majestic, has said: With the exception of fasting, for it is done for Me and I will give a reward for it, for one abandons his passion and food for My sake. There are two occasions of joy for one who fasts, joy when he breaks it, and joy when he meets his Lord, and the breath (of an observer of fast) is sweeter to Allah than the fragrance of musk.

Book 35, Number 2568:

    Abu Huraira and Abu Sa'id (Allah be pleased with both of them) reported Allah's Messenger (may peace be upon him) (as saying): Allah, the Exalted and Majestic, said: Fast (is exclusively) meant for Me and I would give its reward. There are two (occasions) of joy for the observer of fast. He feels joy when he breaks the fast and he is happy when he meets Allah. By Allah in Whose Hand is the life of Muhammad, the breath of the observer of fast is sweeter to Allah than the fragrance of musk. A hadith like this is narrated on the authority of Abu Sinan with the same chain of transmitters (and the words are): "As he meets Allah, He rewards him, and he is happy."

Book 35, Number 2569:

    Sahl b. Sa'd (Allah be pleased with him) reported Allah's Messenger (may peace be upon him) as saying: In Paradise there is a gate which is called Rayyan through which only the observers of fast would enter on the Day on Resurrection. None else would enter along with them. It would be proclaimed: Where are the observers of fast that they should be admitted into it?-and when the last of them would enter, it would be closed and no one would enter it.

Book 35, Number 2570:

    Abu Sa'id al Khudri (Allah be pleased with him) reported Allah's Messenger (may peace be upon him) as saying: Every servant of Allah who observes fast for a day in the way of Allah, Allah would remove, because of this day, his face farther from the Fire (of Hell) to the extent of seventy years' distance.

Book 35, Number 2571:

    This hadith has been narrated by Suhail with the ,arne chainof trausmitters.

Book 35, Number 2572:

    Abu Sa'id al-Khudri (Allah be pleased with him) reported Allah's Messenger (may peace be upon him) as saying: He who observes fast for a day in the way of Allah He would remove his face from the Hell to the extent of seventy years' distance.

Chapter 29 : PERMISSIBILITY OF MAKING AN INTENTION FOR VOLUNTARY FASTING BEFORE NOON AND PERMISSIBILITY OF BREAKING VOLUNIARY FAST WITHOUT REASON

Book 6, Number 2573:

    'A'isha, the Mother of the Believers (Allah be pleased with her), reported that one day the Messenger of Allah tpay peace be upon him) said to me: 'A'isha, have you anything (to eat)? I said:'Messenger of Allah, there is nothing with us. Thereupon he said: I am observing fast. She said: The Messenger of Allah (may peace be upon him) went out, and there was a present, for us and (at the same time) some visitors dropped in. When the Messenger of Allah (may peace be upon him) came back, I said to him: Messenger of Allah, a present was given to us, (and in the meanwhile) there came to us visitors (a major Portion of it has been spent on them), but I have saved something for you. He said: What is it? I said: It is hais (a compound of dates and clarified butter). He said: Bring that. So I brought it to him and he ate it and then said: I woke up in the morning observing fast. Talha said: I narrated this hadith to Mujahid and he said: This (observing of voluntary fast) is like a person who sets apart Sadaqa out of his wealth. He may spend it if he likes, or he may retain it if he so likes.

Book 6, Number 2574:

    'A'isha, the Mother of the Believers (Allah be pleased with her), reported: The Apostle of Allah (may peace be upon him) came to me one day and said: Is there anything with you (to eat) ? I said: No. Thereupon he said: I shall then be fasting. Then he came to us another day and we said: Messenger of Allah, hais has been offered to us as a gift. Thereupon he said: Show that to me; I had been fasting since morning. He then ate it.

Chapter 30 : EATING AND DRINKING (AND SEXUAL INIERCOURSE) IN FORGETFULNESS DOES NOT BREAK THE FAST

Book 6, Number 2575:

    Abu Huraira reported Allah's Messenger (may peace be upon him) as saying: If anyone forgets that he is fasting and eats or drinks he should complete his fast, for it is only Allah Who has fed him and given him drink.

Chapter 31 : THE FAST OBSERVED BY THE APOSTLE OF ALLAH (MAY PEACE BE UPON HIM) BESIDES RAMADAN

Book 6, Number 2576:

    Abdullah b. Shaqiq reported: I said to'A'isha (Allah be pleased with her): Did the Apostle of Allah (may peace be upon him) observe fast for full one month besides Ramadan? She said: I do not know of any month in which he fasted through- out, but that of the month of Ramadan and (the month) in which he did not fast at all, till he ran the course of his life.

Book 6, Number 2577:

    'Abdullah b. Shaqiq reported: I said to 'A'isha (Allah be pleased with her): Did the Messenger of Allah (may peace be upon him) observe fast during a month? She said, I do not know of any month in which he fasted throughout except Ramedan and (the month) in which he did not fast at all till he ran the course of his life. May peace be upon him.

Book 6, Number 2578:

    Abdullah b. Shaqiq reported. I asked 'A'isha (Allah be pleased with her) about fasting of the Messenger of Allah (may peace be upon him). She said: He used to observe fast (at times) so continuously that we said: He has fasted, he has fasted. And (at times) he did not observe fast (for days) and we began to say: He has abandoned fasting, he has abandoned fasting. She said: I did not see him observing fast throughout the whole of the month since he arrived in Medina, but that of Ramadan.

Book 6, Number 2579:

    A hadith like this has been narrated on the authority of Abdullah b. Shaqiq but in the chain of transmitters no mention is made of Hisham and Muhammad.

Book 6, Number 2580:

    'A'isha, the Mother of the Believers (Allah be pleased with her), reported that the Messenger of Allah (may peace be upon him) used to observe fasts (so conti- nuously) that we said that he would not break, and did not observe (them) till we said that he would not fast: and I did not see the Messenger of Allah (may peace be upon him) completing the fast of a month, but that of Ramadan, and I did not see him fasting more in any other month than that of Sha'ban.

Book 6, Number 2581:

    Abu Salama reported: I asked 'A'isha (Allah be pleased with her) about the fasting of the Messenger of Allah (may peace be upon him). She said: He used to observe fast (at times so continuously) that we said: He has fasted (never to break), and he did not observe fast till we said: He has given up perhaps never to fast, and I never saw him observing (voluntary fasts) more in any other month than that of Sha'ban.(lt appeared as if) he observed fast throughout the whole of Sha'ban except a few (days).

Book 6, Number 2582:

    'A'isha (Allah be pleased with her) reported: The Messenger of Allah (may peace be upon him) did not observe fast in any month of the year more than in the month of Sha'ban, and used to say: Do as many deeds as you are capable of doing, for Allah will not become weary (of giving you reward), but you would be tired (of doing good deeds); and he also said: The deed liked most by Allah is one to which the doer adheres constantly even if it is small.

Book 6, Number 2583:

    Ibn Abbas (Allah be pleased with both of them) reported: The Messenger of Allah(may peace be upon him) did not fast throughout any month except during ramadan. And when he observed fast (he fasted so continuously) that one would say that he would not break (them) and when he Abandoned, he abandoned (so continuously) that one would say: By Allah, perhaps he would never fast.

Book 6, Number 2584:

    This hadith has been narrated on the authority of Abu Bishr with the same chain of transmitters (with a slight variation of words and these are), that he (the narrator) said: "During any month continuously since he came to Medina."

Book 6, Number 2585:

    'Uthman b. Hakim al-Ansari said: I asked Sa'id b. Jubair about fasting In Rajab, and we were then passing through the month of Rajab, whereupon he said: I heard Ibn 'Abbas (Allah be pleased with both of them) as saying: The Messenger of Allah (may peace be upon him) used to observe fast (so continuously) that we (were inclined) to say that he would not break (them) and did not observe them so conti- nuously) that we (were inclined to say) that he would not observe fast.

Book 6, Number 2586:

    Anas (Allah be pleased with him) reported that the Messenger of Allah (may peace be upon him) used to observe fast till it was said that he had observed fast, he had observed fast (perhaps never to break it), and he did not fast till it was said that he had given up fast, he had given up fast (perhaps never to observe it).

Chapter 32 : FORBIDDANCE TO OBSERVE PERPETUAL FAST AND EXCELLENCE OF OBSERVING FAST ON ALTERNATE DAYS

Book 6, Number 2587:

    'Abdullah b. 'Amr b. al-'As reported that the Messenger of Allah (may peace be upon him) was informed that he could stand up for (prayer) throughout the night and observe fast every day so long as he lived. Thereupon the Messenger of Allah (may peace be upon him) said: Is it you who said this? I said to him: Messenger of Allah. it is I who said that. Thereupon the Messenger of Allah may peace be upon him) said: You are not capable enough to do so. Observe fast and break it; sleep and stand for prayer, and observe fast for three days during the month; for every good is multiplied ten times and this is like fasting for ever. I said: Messenger of Allah. I am capable of doing more than this. Thereupon he said: Fast one day and do not fast for the next two days. I said: Messenger of Allah, I have the strength to do more than that. The Holy Prophet (may peace be upon him), said: Fast one day and break on the other day. That is known as the fasting of David (peace be upon him) and that is the best fasting. I said: I am capable of doing more than this. Thereupon the Messenger of Allah (may peace be upon him) said: There is nothing better than this. 'Abdullah b. 'Amr (Allah be pleased with them) said: Had I accepted the three days (fasting during every month) as the Messeinger of Allah (may peace be upon him) had said, it would have been more dear to me than my family and my property.

Book 6, Number 2588:

    Yahya reported: I and 'Abdullah b. Yazid set out till we came to Abu Salama. We sent a messenger to him (in his house in order to inform him about our arrival) and he came to us. There was a mosque near the door of his house, and we were in that mosque, till he came out to us. He said: If you like you may enter (the house) and, if you like, you may sit here (in the mosque). We said: We would rather sit here and (you) relate to us. He (Yahya) then narrated that 'Abdullah b Amr b. al-'As (Allah be pleased with them) told him: I used to observe fast uninterruptedly and recited the (whole of the) Qur'an every night. It (the uninterrupted fasting and recital of the Qur'in every night) was mentioned to the Apostle of Allah (may peace be upon him) or he sent for me, and I went to him and he said to me: I have been informed that you fast continuously and recite (the whole of the Qur'An) every night. I said: Apostle of Allah, it is right, but I covet thereby nothing but good, whereupon he said: It suffices for you that you should observe fast for three days during every mouth. I said: Apostle of Allah, I am capable of doing more than this. He said: Your wife has a right upon you, your visitor has a right upon you, your body has a right upon you; so observe the fast of David, the Apostle of Allah (peace be upon him), for he was the best worshipper of Allah. I said: Apostle of Allah, what is the fast of David? He said: He used to fast one day and did not fast the other day. He (also) said: Recite the Qur'an during every month. I said: Apostle of Allah, I am capable of doing more than this, whereupon he said : Recite it in twenty days; recite it in ten days. I said: I am capable of doing more than this, whereupon he said: Recite it every week, and do not exceed beyond this, for your wife has a right upon you, your visitor has a right upon you, your body has a right upon you. He ('Amr b. 'As) said: I was hard to myself and thus I was put to hardship. The Apostle of Allah (may peace be upon him) had told me: 'You do not know you may live long (thus and bear the hardships for a long time), and I accepted that which the Apostle of Allah (may peace be upon him) had told me. When I grew old I wished I had availed myself of the conces- sion (granted by) the Apostle of Allah (may-peace be upon him). This hadith has been narrated by Yahya b. Abu Kathir with the same chain of transmitters and he made this addition after these words: During every month, (fasting) for three days, there is for you ten times for every good and that is perpetual fasting (for three days would bring a reward for full thirty days). I said: What is the fast of the Apostle of Allah, David? He said: Half of the age (observing fast on alternate days for the whole life). And in the hadith no mention has been made of the recital of the Qur'an, and he did not say: Your visitor has a right upon you, but (instead) he said: Your son has a right upon you.

Book 6, Number 2589:

    'Abdullah b. 'Amr (Allah be pleased with them) reported: The Messenger of Allah (may peace be upon him) said to me: Recite the whole of the Qur'An during every nonth. I said : I find power (to recite it) in a shorter period. He said: Then recite it in twenty nights. I said: I find power (to recite it in a shorter period even than this), whereupon he said: Then recite it in seven (nights) and do not exceed beyond it.

Book 6, Number 2590:

    'Abdullah b. 'Amr b. al-'As (Allah be pleased with them) reported that the Messenger of Allah (may peace be upon him) said: 'Abdullah, don't be like so and so who observed prayer during the whole night and then abandoned it (altogether).

Book 6, Number 2591:

    Abdu'llah b. 'Amr b. 'As (Allah be pleased with them) reported: It was conveyed to the Apostle of Allah (may peace be upon him) that I observe fast succes- sively and pray during the whole night. He sent for me or I met him and he (the Holy Prophet) said: It has been conveyed to me that you observe fast continuously and do not break it and pray during the whole night. Don't do that. for there is share for your eyes, share for your own self, share for your family; so observe fast and break it, pray and sleep and observe fast for one day during the ten days, and there is a reward for you (for other) nine (days besides the tenth day of the fast). I said: Apostle of Allah, I find myself more powerful than this. He said: Then observe the fast of David (peace be upon him). He ('Amr) said: Apostle of Allah, how did David observe fast? He (the Holy Prophet) said: He used to fast one day and break it on the other day, and he did not run (from the battlefield) as he encountered (the enemy). He said: Apostle of Allah, who can guarantee this for me (will I also encounter the enemy dauntlessly)? 'Ata', the narrator of the hadith, said: I do not know how there (crept in) the matter of perpetual fast. The Apostle of Allah (may peace be upon him), however, said: He who observed perpetual fast did not fast at all; he who observed perpetual fast did not fast at all, he who observed perpetual fast did not fast at all. This hadith has been narrated by Ibn Juraij with the same chain of transmitters. Imam Muslim has narrated this hadith on the authority of Abu 'Abbas al-Sa'ib b. Farrukh and he was a trustworthy and reliable (narrator) among the people of Mecca.

Book 6, Number 2592:

    Abdullah b. Amr (Allah be pleased with both of them) reported: The Messenger of Allah (may peace be upon him) said to me: 'Abdullah b. Amr, you fast continuously and stand in prayer for the whole of night. If you do like that, your eyes would be highly strained and would sink and lose sight. There is no (reward for) fasting (for him) who fasts perpetually. Fasting for three days during the month is like fasting, the whole of the month. I said: I am capable of doing more than this, whereupon he said: Observe the fast of David. He used to fast one day and break (the other) day. And he did not turn back in the encounter.

Book 6, Number 2593:

    This hadith is narrated on the authority of Habib b. Abu Thabit with the same chain of transmitters and he said: "And you would become exhausted."

Book 6, Number 2594:

    'Abdullah b. 'Amr (Allah be pleased with both of them) reported: The Messenger of Allah (may peace be upon him) said to me: I have been informed that you stand for prayer the whole of night and fast during the day. I said: I do that, whereupon he said: If you did that you in fact strained heavily your eyes and made yourself weak. There is a right of your eyes (upon you) and a right of your self (upon you) and a right of your family (upon you). Stand for prayer and sleep. observe fasts and break (them).

Book 6, Number 2595:

    'Abdullah b. 'Amr (Allah be pleased with both of them) reported Allah's Messenger (may peace be upon him) as saying: With Allah the best fasting is that of David and the best prayer is that of David (peace be upon him) for he slept half of the night and stood for prayer for the third of it and (then) slept the sixth part of it and he observed fast one day and broke on the other.

Book 6, Number 2596:

    'Abdullah b. 'Amr b. al-'As reported Allah's Messenger (may peace be upon him) as saying: The best fasting in the eye of Allah is that of David, for he fasted for half of the age (he fasted on alternate days), and the best prayer in the eye of Allah, the Exalted and Majestic, is that of David (peace be upon him), for he slept for half of the night and then stood for prayer and then again slept. He prayed for one-third of the night after midnight. He (the narrator) said: I asked 'Amr b. Dinar whether 'Amr b. Aus said that he stood for prayer one-third of the night after midnight. He said: Yes.

Book 6, Number 2597:

    Abu Qatada reported that Abu al Malih informed me: I went along with your father to 'Abdullah b. Amr, and he narrated to us that the Messenger of Allah (may peace be upon him) was informed about my fasting and he came to me, and I placed a leather cushion filled with fibre of date-palms for him. He sat down upon the ground and there was that cushion between me and him, and he said to me: Does three days' fasting in a month not suffice you? I said: Messenger of Allah, (I am capable of observing more fasts). He said: (Would) five (not suffice for you) ? I said: Messenger of Allah, (I am capable of observing more fasts) He said: (Would) seven (fasts) not suffice you? I said: Messenger of Allah, (I am capable of observing more fasts). He (the Holy Prophet) then said: (Would) nine (fasts not suffice you)? I said: Messenger of Allah, (I am capable of observing more fasts). He said: (Would) eleven (fasts not suffice you)? I said: Messenger of Allah, (I am capable of observing more fasts than these). Thereupon the Apostle of Allah (may peace be upon him) said: There is no fasting (better than) the fasting of David which comprises half of the age, fasting a day and not fasting a day.

Book 6, Number 2598:

    'Abdullah b. Amr (Allah be pleased with them) reported that the Messenger of Allah (may peace be upon him) had said to him: Observe fast for a day and there would be reward for you for the rest (of the days). He said: I am capable of doing more than this. He then said: Observe fast for two days, and there would be reward for you for the rest (of the days). He said: I am capable of doing more than this. He (the Holy Prophet) said: Observe fast for three days and there would be reward for you for the rest of the days. He said: I am capable of doing more than this, whereupon he said: Observe fast for four days and there would be reward for you for the rest of the days. He said: I am capable of doing more than this. Thereupon he said: Then observe fast (which is the) best in the eye of Allah, the fast of David (peace be upon him); he used to observe fast one day and break on the other day.

Book 6, Number 2599:

    'Abdullah b. 'Amr (Allah be pleased with them) reported that the Messenger of Allah (may peace be upon him) said to me ! 'Abdullah b. 'Amr, it has been conveyed to me that you observe fast during the day and stand in prayer during the whole night. Don't do that, for your body has a share of its own in you, your eye has a share of its own in you, your wife has a share of her own in you. Observe fast and break it too. Fast for three days in every month and that is a prepetual fasting. I said! Messenger of Allah, I have got strength enough (to do more than this), whereupon he said: Then observe the fast of David (peace be upon him). Observe fast one day and break it (on the other) day. And he ('Abdullah b. 'Amr) used to say: Would that I had availed myself of this concession.

Chapter 33 : EXCELLENCE OF OBSERVING FAST FOR THREE DAYS DURING EVERY MONTH. AND FASTING ON THE DAY OF 'ARAFA AND 'ASHURA AND MONDAY AND THURSDAY

Book 6, Number 2600:

    Mu'adha al-'Adawiyya reported that she asked 'A'isha, the wife of the Apostle of Allah (may peace be upon him), whether the Messenger of Allah (may peace be upon him) observed fasts for three days during every month. She said: Yes I said to her: Which were (the particular) days of the month on which he observed fast? She said: He was not particular about the days of the month on which to observe fast.

Book 6, Number 2601:

    'Imran b. Husain (Allah be pleased with them) reported that the Apostle of Allah (may peace be upon him) said to him (or he said to another person and he was listening to it): O, so and so, did you observe fast in the middle of the month? He said: No. Thereupon he (the Messenger of Allah) said: When you break it, then observe fast for two days.

Book 6, Number 2602:

    Abu Qatada reported that a person came to the Apostle of Allah (may peace be upon him) and said: How do you observe fast? The Messenger of Allah (may peace be upon him) felt annoyed.1560 When 'Umar (Allah be pleased with him) noticed his annoyance, he said: We are well pleased with Allah as our Lord, with Islam as our Code of Life, and with Muhammad as our Prophet. We seek refuge with Allah from the anger of Allah and that of His Messenger. 'Umar kept on repeating these words till his (the Prophet's) anger calmed down. Then Umar said: Messenger of Allah. what is the position of one who perpetually observes fasts? Thereupon he said: He neither fasted nor broke it, or he said: He did not fast and he did not break it. He said: What about him who observes fast for two days and breaks one day. There- upon he said: Is anyone capable of doing it? He ('Umar) said: What is the position of him who observes fast for a day and breaks on the other day? Thereupon he (the Holy Prophet) said: That is the fast of David (peace be upon him). He ('Umar) said: What about him who observes fast one day and breaks it for two days. Thereupon he (the Messenger of Allah) said: I wish,I were given strength to observe that. Thereafter he said: The observance of three days' fast every Month and that of Ramadan every year is a perpetual fasting. I seek from Allah that fasting on the day of 'Arafa may atone for the sins of the preceding and the coming years. and I seek from Allah that fasting on the day of Ashura may atone for the sins of the preceding year.

Book 6, Number 2603:

    Abu Qatada al-Ansari (Allah be pleased with him) reported that the Messenger of Allah (may peace be upon him) was asked about his fasting. The Messenger of Allah (may peace be upon him) felt annoyed. Thereupon 'Umar (Allah be pleased with him) said: We are pleased with Allah as the Lord, with Islam as our Code of Life, with Muhammad as the Messenger and with our pledge (to you for willing and cheerful submission) as a (sacred) commitment. He was then asked about perpetual fasting, whereupon he said: He neither fasted nor did he break it,or he did not fast and he did not break it. He was then asked about fasting for two days and breaking one day. He (the Holy Prophet) said: And who has strength enough to do it? He was asked about fasting for a day and breaking for two days, whereupon he said: May Allah bestow upon us strength to do it. He was then asked about fasting for a day and breaking on the other, whereupon he said: That is the fasting of my brother David (peace be upon him). He was then asked about fasting on Monday, whereupon he said: It was the day on which I was born. on which I was commissioned with prophethood or revelation was sent to me, (and he further) said: Three days' fasting every month and of the whole of Ramadan every year is a perpetual fast. He was asked about fasting on the day of 'Arafa (9th of Dhu'I-Hijja), whereupon he said: It expiates the sins of the preceding year and the coming year. He was asked about fasting on the day of 'Ashura (10th of Muharram), whereupon be said: It expiates the sins of the preceding year. (Imam Muslim said that in this hadith there is a) narration of Imam Shu'ba that he was asked about fasting on Monday and Thursday, but we (Imam Muslim) did not mention Thursday for we found it as an error (in reporting).

Book 6, Number 2604:

    This hadith has been narrated by Shu'ba with the same chain of transmitters.

Book 6, Number 2605:

    This hadith has been narrated by Ghailan b. Jarir with the same chain of transmitters, but with one variation, that there has been made mention of Monday and not of Thursday.

Book 6, Number 2606:

    Abu Qatada Ansari (Allah be pleased with him) reported that Allah's Massenger (may peace be upon him) was asked about fasting on Monday, whereupon he said: It is (the day) when I was born and revelation was sent down to me.

Chapter 34 : FASTING IN THE MONTH OF SHA'BAN

Book 6, Number 2607:

    'Imran b. Husain (Allah be pleased with them) reported Allah's Messenger (may peace he upon him) having said to him or to someone else: Did you fast in the middle of Sha'ban? He said: No. Thereupon he (the Holy Prophet) said: If you did not observe fast, then you should observe fast for two days.

Book 6, Number 2608:

    Imran b. Husain (Allah be pleased with them) reported that Allah's Apostle (way peace heupon him) said. to a person: Did you observe any fast in the middle of this month (Sha'ban)? He said: No. Thereupon the Messenger of Allah (may peace be upon him) said: Fast for two days instead of (one fast) when you have completed (fasts of) Ramadan.

Book 6, Number 2609:

    'Imran b. Husain (Allah be pleased with them) reported that the Apostle of Allah (may peace be upon him) said to a person: Did you observe fast in the middle of this month. i.e. Sha'ban? He said: No. Thereupon he said to him: When it is the end of Ramadan, then observe fast for one day or two (Shu'ba had some doubt about it) but he said: I think that he has said: two days.

Book 6, Number 2610:

    This hadith is narrated by 'Abdullah b. Hani b. Akhi Mutarrif with the same chain of transmitters.

Chapter 35 : EXCELLENCE OF THE FAST OF MUHARRAM

Book 6, Number 2611:

    Abu Haraira (Allah be pleased with him) reported Allah's Messenger (may peace be upon him) as saying: The most excellent fast after Ramadan is God's month. al-Muharram, and the most excellent prayer after what is prescribed is prayer during the night.

Book 6, Number 2612:

    Abu Huraira (Allah be pleased with him) reported that he (the Messenger of Allah) was asked as to which prayer was most excellent after the prescribed prayer, and which fast was most excellent after the month of Ramadan. He said: Prayer offered in the middle of the night and the most excellent fast after (fasting) in the month of Ramadan is the fast in God's month al-Muharram.

Book 6, Number 2613:

    A hadith like this has been reported from the Apostle of Allah (may peace be upon him) by 'Abd al-Malik with the same chain of transmitters in connection with fast.

Chapter 36 : EXCELLENCE OF OBSERVING FAST FOR SIX DAYS IN THE MONTH OF SHAWWAL AFTER RAMADAN

Book 6, Number 2614:

    Abu Ayyub al-Ansari (Allah be pleased with him) reported Allah's Messenger (may peace be upon him) as saying: He who observed the fast of Ramadan and then followed it with six (fasts) of Shawwal. it would be as if he fasted perpetually.

Book 6, Number 2615:

    Abu Ayyub al-Ansari reported (through another chain of transmitters): I heard Allah's Messenger (may peace be upon him) saying like this.

Book 6, Number 2616:

    Abu Ayyub reported a hadith like this (through another chain of transmitters).

Chapter 37 : EXCELLENCE OF LAILAT-UL-QADR AND EXHORTATION TO FIND IT

Book 6, Number 2617:

    Ibn 'Umar (Allah be pleased with them) reported that some persons among the Companions of the Apostle of Allah (may peace be upon him) were shown Lailat- ul-Qadr while sleeping in the last week (of Ramadan). Thereupon Allah's Messenger (may peace be upon him) said: I see that your dreams agree regarding the last week; so he who wants to seek it should seek it in the last week (during the night).

Book 6, Number 2618:

    Ibn 'Umar (Allah be pleased with them) reported Allah's Apostle (may peace be upon him) as saying: Seek Lailat-ul-Qadr in the last week (of Ramadan).

Book 6, Number 2619:

    Salim reported on the authority of his father that a person saw Lailat-ul- Qadr on the 27th (of Ramadan).Thereupon Allah's Apostle (may peace be upon him) said: I see that your dreams agree regarding the last ten (nights of Ramadan). So seek it on an odd number (of these ten nights).

Book 6, Number 2620:

    Salim b. 'Abdullah b. 'Umar reported that his father said: I heard Allah's Messenger (may peace be upon him) as saying: So far as Lailat-ul-Qadr is concerned. some persons among you have seen it (in a dream) in the first week and some persons among you have been shown that it is in the last week; so seek it in the last ten (nights).

Book 6, Number 2621:

    Ibn Umar (Allah be pleased with them) reported Allah's Messenger (may peace be upon him) as saying: Seek it (Lailat-ul-Qadr) in the last (ten nights).If one among you shows slackness and weakness (in the earlier part of Ramadan), it should not be allowed to prevail upon him in the last week.

Book 6, Number 2622:

    Ibn Umar (Allah be pleased with them) reported Allah's Messenger (may peace be upon him) as saying: He who is anxious to seek it (Lailat-ul-Qadr) should seek it in the last ten (nights of Ramadan).

Book 6, Number 2623:

    'Ibn 'Umar (Allah be pleased with both of them) reported Allah's Messenger (may peace be upon him) as saying: Seek the time of Lailat-ul-Qadr in the last (ten nights), or he said: in the last nine (nights).

Book 6, Number 2624:

    Abu Huraira (Allah be pleased with him) reported Allah's Messenger (may peace be upon him) as saying: I was shown Lailat-ul-Qadr; then some members of my family awoke me up, then I was caused to forget it. So seek it in the last week. Harmala said: (The Holy Prophet did not say: "I was made to forget," but he stated): "But I forgot it."

Book 6, Number 2625:

    Abu Sa'id al-Khudri (Allah be pleased with him) reported that Allah's Messenger (may peace be upon him) spent in devotion (in i'tikaf) the middle ten nights of the month of Ramadan, and when twenty nights were over and it was the twenty-first night, he went back to his residence and those who were along with him also returned (to their respective residences).He spent one month in devotion.Then he addressed the people on the night he came back (to his residence) and commanded them as Allah desired (him to command) and then said: I used to devote myself (observe i'tikaf) during these ten (nights).Then I started devoting myself in the last ten (nights).And he who desires to observe i'tikaf along with me should spend the night) at his place of i'tikaf. And I saw this night (Lailat-ul-Qadr) but I forgot it (the exact night); so seek it ;In the last ten nights on odd numbers. I saw (the glimpses of that dream) that I was prostrating in water and mud.Abu Sa'id al-Khudri said: It rained on the twenty-first night and the water dripped (from the roof) of the mosque at the place where the Messenger of Allah (may peace be upon him) observed prayer. I looked at him and as he completed the dawn prayer, (I found) his face was wet with mud and water.

Book 6, Number 2626:

    Abu Sa'id al-Khudri (Allah be pleased with him) reported that the Messenger of Allah (may peace be upon him) devoted (himself to prayer) in the middle (ten nights) of Ramadan. The rest of the hadith is the same except for these words: "That he adhered to his place of i'tikaf and his forehead was besmeared with mud and water."

Book 6, Number 2627:

    Abu Sa'id al-Khudri (Allah be pleased with him) reported that the Messenger of Allah (may peace be upon him) observed i'tikaf (confined himself for devotion and prayer) in the first ten (days) of Ramadan; he then observed i'tikaf in the middle ten (days) in a Turkish tent with a mat hanging at its door. He (the Holy Prophet) took hold of that mat and placed it in the nook of the tent. He then put his head out and talked with people and they came near him, and he (the Holy Prophet) said: I observed i'tikaf in the first ten (nights and days) in order to seek that night (Lailat-ul-Qadr). I then observed i'tikaf in the middle ten days. Then (an angel) was sent to me and I was told that this (night) is among the last ten (nights). He who among you likes to observe i'tikaf should do so; and the people observed it along with him, and he (the Holy Prophet) said: That (Lailat-ul-Qadr) was shown to me on an odd (night) and I (saw in the dream) that I was prostrating in the morning in clay and water. So in the morning of the twenty-first night when he (the Holy Prophet) got up for dawn (prayer). there was a rainfall and the mosque dripped, and I saw clay and water. When he came out after completing the morning prayer (I saw) that his forehead and the tip of his nose had (traces) of clay and water, and that was the twenty-first night among the last ten (nights).

Book 6, Number 2628:

    Abu Salama reported:'We discussed amongst ourselves Lailat-ul-Qadr. I came to Abu Sa'id al-Khudri (Allah be pleased with him) who was a friend of mine and said to him: Would you not go with us to the garden of date trees? He went out with a cloak over him. I said to him: Did you hear the Messenger of Allah (may peace be upon him) making mention of Lailat-ul-Qadr? He said: Yes, (and added) we were observing i'tikaf with the Messenger of Allah (may peace be upon him) in the middle ten days of Ramadan, and came out on the morning of the twentieth and the Messenger of Allah (may peace be upon him) addressed us and said: I was shown Lailat-ul-Qadr, but I forgot (the exact night) or I was caused to forget it, so seek it in the last ten odd (nights), and I was shown that I was prostrating in water and clay. So he who wanted to observe i'tikaf with the Messenger of Allah (inay peace be upon him) should return (to the place of i'tikaf). He (Abu Sa'id al-Khudri) said: And we returned and did not find any patch of cloud in the sky. Then the cloud gathered and there was (so heavy) a downpour that the roof of the mosque which was made of the branches of date-palms began to drip. Then there was prayer and I saw the Messenger of Allah (may peace be upon him) prostrating in water and clay till I saw the traces of clay on his forehead.

Book 6, Number 2629:

    This badith has been reported on the authority of Yahya b. Abu Kathir with the same chain of transmitters (with a slight variation of these words): I saw the Messenger of Allah (may peace be upon him) after he had completed (the prayer) and there was a trace of clay on his forehead and tip (of the nose).

Book 6, Number 2630:

    Abu Sa'id al-Khudri (Allah be pleased with him) reported: The Messenger of Allah (may peace be upon him) observed i'tikaf in the middle ten days of Ramadan to seek Lailat-ul-Qadr before it was made manifest to him. When (these nights) were over, he commanded to strike the tent. Then it was made manifest to him that (Lailat-ul-Qadr) was in the last ten nights (of Ramadan), and commanded to pitch the tent (again). He then came to the people and said: O people, Lailat-ul-Qadr was made manifest to me and I came out to inform you about it that two persons came contend- ing with each other and there was a devil along with them and I forgot it. So seek it in the last ten nights of Ramadan. Seek it on the ninth, on the seventh and on the fifth. I (one of the narrators) said: Abu Sa'id, you know more than us about numbers. He said: Yes, indeed we have better right than you. I said: What is this ninth, seventh, and fifth? He said: When twenty-one (nights are over) and the twenty-second begins, it is the ninth, and when twenty-three (nights) are over, that which follows (the last night) is the seventh, and when twenty-five nights are over, what follows it is fifth. Ibn Khallad said: Instead of the word Yahliqan (contending), he said Yakhtasiman, (they are disputing).

Book 6, Number 2631:

    'Abdullah b. Unais reported Allah's Messenger (may peace beupon him) as saying: I was shown Lailat-ul-Qadr; then I was made to forget it, and saw that I was prostrating in water and clay in the morning of that (night). He (the narrator) said: There was a downpour on the twenty-third night and the Messenger of Allah (may peace be upon him) led us in prayer, and as he went back, there was a trace of water and clay on his forehead and on his nose. He (the narrator) said: 'Abdullah b. Unais used to say that it was the twenty-third (night).

Book 6, Number 2632:

    'A'isha (Allah be pleased with her) and Ibn Numair reported Allah's Mes- senger (may peace be upon him) as saying: Look for (and in the words of Waki, seek) Lailat-ul-Qadr in the last ten nights of Ramadan.

Book 6, Number 2633:

    Zirr b. Habaish reported: I thu asked Ubayy b. Ka'b (Allah be pleased with him): Your brother (in faith) Ibn Mas'ud says: He who stands (for the night prayer) throughout the year would find Lailat-ul-Qadr, whereupon he said: May Allah have mercy upon him; (he said these words) with the intention that people might not rely only (on one night), whereas he knew that it (Lailat-ul-Qadr) is in the month of Ramadan and it is the twenty-seventh night. He then took oath (without making any exception, i.e. without saying Innsha Allah) that it was the twenty-seventh night. I said to him: Abu Mundhir, on what ground do you say that? Thereupon he said: By the indication or by the sign which the Messenger of Allah (may peace be upon him) gave us, and that is that on that day (the sun) would rise without having any ray in it.

Book 6, Number 2634:

    Zirr b. Hubaish reported that Ubayy b. Ka'b (Allah be pleased with him) said about Lailat-ul-Qadr: By Allah, I know well about it. Shu'ba said: To the best of my knowledge it was the twenty-seventh night for which the Messenger of Allah (may peace be upon him) commanded us to stand for prayer. Shu'ba doubted these words: That it was the night for which the Messenger of Allah (may peace be upon him) commanded us to stand for prayer. And (he further) said: This was narrated to me by a friend of mine from him (the Holy Prophet).

Book 6, Number 2635:

    Abu Huraira (Allah be pleased with him) reported: We were talking about Lailat-ul-Qadr in the presence of the Messenger of Allah (may peace be upon him) and he said: He who amongst you remembers (the night) when the moon arose and it was like a piece of plate (at the fag end of the month in a state of waning).

Chapter 38 : OBSERVING OF I'TIKAF IN THE LAST TEN DAYS OF RAMADAN

Book 6, Number 2636:

    Ibn 'Umar (Allah be pleased with both of them) reported that the Apostle of Allah (may peace be upon him) used to observe i'tikaf in the last ten days of Ramadan.

Book 6, Number 2637:

    Abdullah b. Umar (Allah be pleased with both of them) reported that the Messenger of Allah (may peace be upon him) used to observe i'tikaf in the last ten days of Ramadan. Nafi' said: Abdullah (Allah be pleased with him) showed me the place in the mosque where the Messenger of Allah (may peace be upon him) used to observe i'tikaf.

Book 6, Number 2638:

    'A'isha (Allah be pleased with her) reported that the Messenger of Allah (may peace be upon him) used to observe i'tikaf in the last ten days of Ramadan.

Book 6, Number 2639:

    This hadith has been narrated by 'A'isha (Allah be pleased with her) through another chain of transmitters.

Book 6, Number 2640:

    'A'isha (Allah be pleased with her) reported that the Messenger of Allah (may peace he upon him) used to observe i'tikif in the last ten days of Ramadan till Allah called him back (to his heavenly home). Then his wives observed i'tikaf after him.

Chapter 39 : WHEN SHOULD A PERSON ENTER THE PLACE OF I'TIKAF AS HE INTENDS TO OBSERVE IT

Book 6, Number 2641:

    'A'isha (Allah be pleased with her) reported that when the Messenger of Allah (may peace be upon him) decided to observe i'tikaf, he prayed in the morning and then went to the place of his i'tikaf, and he commanded that a tent should be pitched for him, and it was pitched. He (once) decided to observe i'tikaf in the last ten days of Ramadan. Zainab (the wife of the Holy Prophet) commanded that a tent should be pitched for her. It was pitched accordingly. And some other wives of Allah's Apostle (may peace be upon him) commanded that tents should be pitched for them too. And they were pitched. When the Messenger of Allah (may peace he upon him) offered the morning prayer, he looked and found (so many) tents. Thereupon he said: What is this virtue that these (ladies) have decided to acquire? He commanded his tent to be struck and abandoned i'tikaf in the month of Ramadan and postponed it to the first ten days of Shawwal.

Book 6, Number 2642:

    This hadith has been reported through another chain of transmitters, and there it is mentioned that. 'A'isha, Hafsa and Zainab (Allah be pleased with them) pitched the tents for i'tikaf.

Chapter 40 : ONE SHOULD EXERT MORE (IN DEVOTION AND PRAYER) IN THE LAST TEN DAYS OF RAMADAN

Book 6, Number 2643:

    'A'Isha (Allah be pleased with her) reported that when the last ten nights began Allah's Messenger (may peace be upon him) kept awake at night (for prayer and devotion), wakened his family, and prepared himself to observe prayer (with more vigour).

Book 6, Number 2644:

    'A'isha (Allah be pleased with her) reported that Allah's Messenger (may peace be upon him) used to exert himself in devotion during the last ten nights to a greater extent than at any other time.

Chapter 41 : FASTING ON THE 10TH OF DHU'L-HIJJA

Book 6, Number 2645:

    'A'isha (Allah be pleased with her) reported: I never saw the Messenger of Allah (may peace be upon him) fasting in the ten days of Dhu'I-Hijja.

Book 6, Number 2646:

    'A'isha (Allah be pleased with her) reported: The Apostle of Allah (may peace be upon him) did not observe fast in the ten days of Dhul-Hijja.


BOOK 7: The Book of Pilgrimage (Kitab Al-Hajj) (part I)

KITAB AL-HAJJ
THE BOOK OF Pilgrimage

Back
INTRODUCTION

    The word Hajj means, literally, repairing to a place for the sake of visit (al-qasd li-ziyarah), and in the terminology of the Islamic Shari'ah, it implies the repairing to Bait-Allah (the house of Allah) to observe the necessary devotion (iqamat-an-li-nusuk) Bait-Allah is one of the names by which the Ka'ba is called.

    Hajj is not a new institution which Islam has introduced in its Shari'ah. This institution is as old as the Ka'ba itself which is called in the Holy Qur'an to be "the first House of Divine Worship appointed for men" (iii. 95). This verse of the Holy Qur'an corroborates the hadith which tells us that the Ka'ba was first built by Adam, the first man upon the earth. It was later on rebuilt by Hadrat Ibrahim and his illustrious son Hadrat Isma'il (peace be upon both of them). And when Ibrahim and Isma'al raised the foundations of the house, they said: "Our Lord ! accept from us" (ii. 127). An earlier revelation makes it clear that the Ka'ba was already there when Hadrat Ibrahim left Hadrat Isma'il in the wilderness of Arabia: "Our Lord ! I have settled a part of my offspring in a valley unproductive of fruit near Thy sacred House"(xiv. 37).

    The whole ceremony of Hajj is commemorative of Hadrat Ibrahim and his family's acts of devotion to God Almighty. This shows that the Holy Prophet (may peace be upon him) did not innovate this institution but purged it of all evil practices and made it an obligatory act of piety by which one can develop God-consciousness.

    It is rightly said that it is the perfection of faith since it combines in itself all the distinctive qualities of other obligatory acts. It represents the quality of salat since a pilgrim offers prayers in the Ka'ba, the House of the Lord. It encourages the spending of material wealth for the sake of the Lord, the chief characteristic of Zakat. When a pilgrim sets out for Hajj, he dissociates himself from his hearth and home, from his dear and near ones to please the Lord. He suffers privation and undertakes the hardship of journey-the lessons we learn from fasting and i'tikaf. In Hajj one is trained to be completely forgetful of the material comforts and show of worldly thing. One has to sleep on stony ground, circumambulate the Ka'ba, run between Safa and Marwa and spend his night and day wearing, only two pieces of unsewn cloth. He is required to avoid the use of oil or scent or any other perfume. He is not even allowed to get his hair cut or trim his beard. In short, he is commanded to abandon everything for the sake of Allah and submit himself before his Lord, the ultimate aim of the life of a Muslim. In fact, physical pilgrimage is a prelude to spiritual pilgrimage to God, when man would bid goodbye to everything of the world and present himself before Him as His humble servant saying: "Here I am before Thee, my Lord, as a slave of Thine." "Down through the ages." says Professor Hitti, "this institution has continued to serve as the major unifying influence in Islam and the most effective common bond among the diverse believers. It rendered almost every capable Moslem perforce a traveller for once in his lifetime. The socializing influence of such a gathering of the brotherhood of believers from the far quarters of the earth is hard to overestimate. It afforded opportunity for negroes, Berbers, Chinese, Persians, Syrians, Turks-rich and poor, high and low-to fraternize and meet together on the common ground of faith" (History of the Arabs, p. 136).

Chapter 1 :WHAT IS PERMITTED FOR THE MUHRIM (WEARER OF IHRAM) IN HAJJ AND UMRA, WHAT IS NOT PERMISSIBLE AND FORBIDDANCE OF THE USE OF PERFUME

Book 7, Number 2647:

    Ibn 'Umar (Allah be pleased with them) reported that a person asked the Messenger of Allah (may peace be upon him) what a Muhrim should put on as dress. Thereupon the Messenger of Allah (may peace be upon him) said: Do not put on a shirt or a turban, or trousers or a cap, or leather stockings except one who does not find shoes; he may put on stockings but he should trim them below the ankles. And do not wear clothes to which saffron or wars is applied.

Book 7, Number 2648:

    Salim reported on the authority of his father ('Abdullah b. 'Umar) that the Apostle of Allah (may peace be upon him) was asked what a Muhrim should wear, whereupon he said: A Muhrim should not wear a shirt, or a turban, or a cap, or trousers, or a cloth touched with wars or with saffron, nor (should he wear) stock- ings, but in case he does not find shoes, but (before wearing stockings) be should trim them (in such a way) that these should become lower than the ankles.

Book 7, Number 2649:

    Ibn 'Umar reported that the Messenger of Allah (may peace be upon him) forbade the Muhrim to put on a cloth dyed in saffron or wars and he further said: One who does not find shoes (to wear) he way wear stockings, but (only) after trimming them below the ankles.

Book 7, Number 2650:

    Ibn 'Abbas (Allah be pleased with both of them) reported: I heard Allah's Messenger (may peace be upon him) say as he was delivering an address: So far as the trousers are concerned, one who does not find lower garment, he may wear them; as also socks, he may wear them who does not find shoes. It concerns the Muhrim.

Book 7, Number 2651:

    'Amr b. Dinar narrated with the same chain of transmitters that he heard the Messenger of Allah (may peace be upon him) delivering sermon at 'Arafat, and he made a mention of this hadith (as quoted above).

Book 7, Number 2652:

    This hadith has been narrated on the authority of 'Amr b. Dinar with the same chain of transmitters, but none of them (the narrators) made a mention that he (the Holy Prophet) was delivering address at 'Arafia except Sbu'ba.

Book 7, Number 2653:

    Jabir (Allah be pleased with him) reported Allah's Messenger (may peace be upon him) as saying: He who does not find shoes to wear may wear socks, and he who does not find lower garment to wear may put on trousers.

Book 7, Number 2654:

    Ya'la b. Umayya reported on the authority of his father (Allah be pleased with them) that a person came to the Apostle of Allah (may peace be upon him) as he was at Ji'rana and he (the person) had been putting on a cloak which was perfumed, or he (the narrator) said: There was a trace of yellowness on it. He said (to the Holy Prophet): What do you command me to do during my Umra? (It was at this juncture) that the revelation came to the Apostle of Allah (way peace be upon him) and he was covered with a cloth, and Ya'la said: Would that I see revelation coming to the Apostle of Allah (may peace be upon him). He (Hadrat 'Umar) said: Would it please you to see the Apostle of Allah (may peace be upon him) receiving the revelations 'Umar lifted a corner of the cloth and I looked at him and he was emitting a sound of snorting. He (the narrator) said: I thought it was the sound of a camel. When he was relieved of this he said: Where is he who asked about Umra? When the person came, the Holy Prophet (may peace be upon him) said: Wash out the trace of yellowness, or he said: the trace of perfume and put off the cloak and do in your 'Umra what you do in your Hajj.

Book 7, Number 2655:

    Safwan b. Ya'la reported on the authority of his father (who said): A person came to the Apostle of Allah (may peace be upon him) as he was staying at Ji'rana and I (the narrator's father) was at that time in the apostle's (may peace be upon him) company and (the person) was donning a cloak having the marks of perfume on it, and he said: I am in a state of Ihram for the sake of Umra, and it (this cloak) is upon me and I am perfumed. The Apostle of Allah (may peace be upon him) said to him: What would you do in your Hajj ? He said: I would take off the clothes and would wash from me this perfume. Thereupon the Apostle of Allah (may peace be upon him) said: What you do in your Hajj do it in your Umra.

Book 7, Number 2656:

    Safwan b. Ya'la b. Umayya reported that Ya'la used to say to 'Umar b. Khattab (Allah be pleased with him): Would that I see revelation descending upon the Apostle of Allah (may peace be upon him). (Once) when the Apostle of Allah (may peace be upon him) was in Ji'rana and there was a cloth which provided shade over him, and there were his Companions with him. 'Umar being one of them, there came a person with a cloak of wool on him daubed with perfume and he said: Messenger of Allah, what about the person who, entered upon the state of Ihram with a cloak after daub- ing it with perfume ? The Apostle of Allah (may peace be upon him) looked at him for a short while, and then became quiet, and revelation began descending upon him, and 'Umar gestured (with his hand) to Ya'la b Umayya to come. Ya'la came and he enter- ed his head (beneath the cloth and saw) the Apostle of Allah (may peace be upon him) with his face red, and breathing with a snore. Then he felt relieved (of that burden) and he said: Where is the man who was just asking me about Umra ? The man was searched for and he was brought, and the Apostle of Allah (may peace be upon him) said: So far as the perfume is concerned, wash it three times, and remove the cloak too (as it was sewn) and do in 'Umra as you do in Hajj.

Book 7, Number 2657:

    Ya'la b. Umayya (Allah be pleased with him) reported that a person came to the Apostle of Allah (may peace be upon him) as he was staying at Ji'rana and he had put on Ihram for 'Umra and he had dyed his beard and his head with yellow colour and there was a cloak on him. He said: I put on Ihram for 'Umra and I am in this state as you see (with dyed beard and head and a cloak over me). He (the Holy Prophet) said: Take off the cloak and wash the yellowness and do in your 'Umra what you do in Hajj.

Book 7, Number 2658:

    Ya'la reported: We were with the Messenger of Allah (may peace be upon him) that a person came to him with a cloak on him having the traces of scent. He said, Messenger of Allah, I put on Ihram for 'Umra: what should I do ? He (the Holy Prophet) kept quiet and did not make him any reply. And 'Umar screened him and it was (usual) with 'Umar that when the revelation descended upon him, he provided him shade (with the help of a piece of cloth). I (the person who came to the Holy Prophet) said: I said to 'Umar I wish to project my head into the cloth (to see how the Holy Prophet receives revelation). So when the revelation began to descend upon him 'Umar wrapped him (the Holy Prophet) with cloth I came to him and projected my head with him into the cloth, and saw him (the Holy Prophet) (receiving the revelation). When he (the Holy Prophet) was relieved (of its burden), he said: Where is the inquirer who was just inquiring about 'Umra? That man came to him. Thereupon he (the Apostle of Allah) said: Take off the cloak from (your body) and wash the traces of perfume which were upon you, and do in 'Umra what you did in Hajj.

Chapter 2:THE PLACE WHERE THE PILGRIMS ENTER UPON THE STATE OF IHRAM

Book 7, Number 2659:

    Ibn 'Abbas (Allah be pleased with them) reported that the Messenger of Allah (may peace be upon him) specified Dhu'l-Hulaifa, for the people of Medina; Juhfa for the people of Syria; Qarn al-Manazil, for the people of Najd; Yalamlam for the people of Yemen (the Mawaqit) and those (Mawaqit) are also meant for those who live at these (places) and for those too who come from without towards them for the sake of Hajj or 'Umra. And those who live within them (within the bounds of these places) or in the suburbs of Mecca or within Mecca, they should enter upon the state of Ihram at these very places.

Book 7, Number 2660:

    Ibn 'Abbas (Allah be pleased with them) reported that the Messenger of Allah (may peace be upon him) specified Dhu'l-Hulaifa for the people of Medina; Juhfa for the people of Syria, Qarn al-Manazil for the people of Najd, Yalamlam for the people of Yemen (as their respective Mawaqit), and he also said: These are (Mawaqit) of them too (who live there) and everyone who comes from outside (through) their (directions) for the sake of Hajj and 'Umra and for those who live within (those bounds their Miqat is that) from which they commenced (their journey), and for the people of Mecca, Mecca itself is (the Miqat).

Book 7, Number 2661:

    Ibn 'Umar (Allah be pleased with them) reported that the Messenger of Allah (may peace be upon him) said: The people of Medina should enter upon the state of Ihram at Dhu'l-Hulaifa, and people of Syria at Juhfa, and people of Najd at Qarn (al-Manazil), and 'Abdullah (further) said: It has reached me that the Messenger of Allah (may peace be upon him) also caid: The people of Yemen should enter upon the state of Ihram at Yalamlam.

Book 7, Number 2662:

    Salim reported on the authority of his father ('Abdullah b. 'Umar) that the Messenger of Allah (may peace be upon him) said: The people of Medina should enter upon the state of Ihram at Dhu'l-Hulaifa; the people of Syria at Juhfa, the people of Najd at Qarn (al-Manazil). Ibn 'Umar (Allah be pleased with them) said: It was mentioned to me but I did not myself bear it (directly) from the Messenger of Allah (may peace be upon him) having said this: The people of Yemen should enter upon the state of Ihram at Yalamlam.

Book 7, Number 2663:

    Salim b. 'Abdullah b. 'Umar b. al-Khattab (Allah be pleased with them) reported his father as saying: I heard the Messenger of Allah (may peace be upon him) as saying that the people of Medina should enter upon the state of Ihram at Dhu'l- Hulaifa, the people of Syria at Mahya'a and that is Juhfa, and the people of Najd at Qarn (al-Manazil). 'Abdullah b. 'Umar (Allah be pleased with them) said: (I did not hear it myself from him) but heard from them saying that the Messenger of Allah (may peace be upon him) had (also) said: The people of Yemen should enter upon the state of Ihram at Yalamlam.

Book 7, Number 2664:

    Ibn 'Umar (Allah be pleased with them) reported that the Messenger of Allah (may peace be upon him) had commanded the people of Medina to enter upon the state of Ihram at Dhu'l-Hulaifa; the people of Syria at Juhfa; the people of Najd at Qarn (al-Manazil). 'Abdullah b. 'Umar (Allah be pleased with them) said: I was informed that he said that the people of Yemen should enter upon the state of Ihram at Yalamlam.

Book 7, Number 2665:

    Abu Zubair reported that he heard Jabir b. 'Abdullah (Allah be pleased with them) saying that as he was asked about (the places for entering upon the) state of ihram, he said: I heard (and he then carried the narration directly, I think to) the Apostle of Allah (may peace be upon him).

Book 7, Number 2666:

    Abu Zubair heard Jabir b.'Abdullah (Allah be pleased with them) as saying as he was asked about (the place for entering upon the) state of Ihram: I heard (and I think he carried it directly to the Apostle of Allah) him saying: For the people of Medina Dhu'l-Hulaifa is the place for entering upon the state of Ihram, and for (the people coming through the other way, i.e. Syria) it is Juhfa; for the people of Iraq it is Dbat al-'Irq; for the people uf Najd it is Qarn (al-Manazil) and for the people of Yemen it is Yalamlam.

Chapter 3: TALBIYA, ITS CHARATERISTICS AND ITS TIME

Book 7, Number 2667:

    'Abdullah b. 'Umar (Allah be pleased with them) reported that the Talbiya of the Messenger of Allah (may peace be upon him) was this: Here I am at Thy service. O Allah, here I am at Thy service, here I am at Thy service. There is no associate with Thee; here I am at Thy service. Verily all praise and grace is due to Thee, and the sovereignty (too). There is no associate with Thee. He (the narrator) further said that 'Abdullah b. 'Umar (Allah be pleased with them) made this addition to it: Here I am at Thy service; here I am at Thy service; ready to obey Thee, and good is in Thy Hand; here 1 am at Thy service; unto Thee is the petition, and deed (is also for Thee).

Book 7, Number 2668:

    'Abdullah b. 'Umar (Allah be pleased with them) reported that the Mes- senger of Allah (may peace be upon him) entered upon the state of Ihram near the mosque at Dhu'l-Hulaifa as his camel stood by it and he said: Here I am at Thy service, O Lord; here I am at Thy service: here I am at Thy service. There is no associate with Thee. Here I am at Thy service. All praise and grace is due to Thee and the sovereignty (too). There is no associate with Thee. They (the people) said that 'Abdullah b. 'Umar said that that was the Talbiya of the Messenger of Allah (may peace be upon him). Nafi' said: 'Abdullah (Allah be pleased with him) made this addition to it: Here I am at Thy service; here I am at Thy service; ready to obey Thee. The Good is in Thy Hand. Here I am at Thy service. Unto Thee is the petition and deed (is also for Thee).

Book 7, Number 2669:

    Ibn 'Umar (Allah be pleased with him) reported: I immediately learnt Talbiya from the Messenger of Allah (may peace be upon him), and he then narrated the hadith.

Book 7, Number 2670:

    'Abdullah b. 'Umar (Allah be pleased with them) reported: I heard the Messenger of Allah (may peace be upon him) pronouncing Talbiya with compacted hair: Here I am at Thy service. O Allah: here I am at Thy service; here I am at Thy service. There is no associate with Thee; here I am at Thy service. Verily all praise and grace is due to Thee and the Sovereignty (too). There is no associate with Thee; and he did not make any addition to these words. 'Abdullah b. 'Umar (Allah be pleased with them) (further) said: The Messenger of Allah (may peace be upon him) used to offer two rak'ahs of prayer at Dhu'l-Hulaifa and then when his camel stood up with him on its back near the mosque at Dhu'l-Hulaifa, he pronounced these words (of Talbiya). And 'Abdullah b. 'Umar (Allah be pleased'with them) said that 'Umar b. Khattab (Allah be pleased with him) pronounced, the Talbiya of the Messenger of Allah (may peace be upon him) in these words of his (Prophet's words) and said: Here I am at Thy service, O Lord; here I am at Thy service, ready to obey Thee, and good is in Thy Hand, Here I am at Thy service. Unto Thee is the petition and deed (is also for Thee).

Book 7, Number 2671:

    Ibn 'Abbas (Allah be pleased with them) reported that the polytheists also pronounced (Talbiya) as: Here I am at Thy service, there is no associate with Thee. The Messenger of Allah (may peace be upon him) said: Woe be upon them, as they also said: But one associate with Thee, you possess mastery over him, but he does not possess mastery (over you). They used to say this and circumambulate the Ka'ba.

Chapter 4:THF PEOPLE OF MEDINA ARE COMMANDED TO ENTER UPON THE STATE OF IHRAM AT A MOSQUE IN DHU'L-HULAIFA

Book 7, Number 2672:

    Salim b. 'Abdullah (Allah be pleased with them) reported that he heard his father saying: This place Baida' is for you that about which you attribute lie to the Messenger of Allah (may peace be upon him). And the Messenger of Allah (may peace be upon him) did not enter upon the state of Ihram but near the mosque at Dhu'l- Hulaifa.

Book 7, Number 2673:

    Salim reported that when it was said to Ibn 'Umar (Allah be pleased with them) that the state of Ihram (commences from) al-Baida' he said: Al-Baida', you attribute lie about it to the Messenger of Allah (may peace be upon him). And the Messenger of Allah (mav peace be upon him) did not enter upon the state of Ihram but near the-tree when his camel stood up with him.

Chapter 5:ENTERING UPON THE STATE OF IHRAM AS THE RIDE PROCEEDS TOWARDS (MECCA)

Book 7, Number 2674:

    'Ubaid b. Juraij said to 'Ahdullah b. 'Umar (Allah be pleased with them): 'Abd al-Rahman, I find you doing four things which I do not see anyone among your companions doing. He said: Son of Juraij, what are these? Thereupon he said: You (while circumambulating the Ka'ba) do not touch but the two pillars situated on the side of yaman (south), and I find you wearing the sandals of tanned leather, and I find you with dyed beard and head, and I also found that, when you were at Mecca, the people pronounced Talbiya as they saw the new moon (Dhu'l-Hijja), but you did not do it till the 8th of Dhu'l-Hijja. Upon this 'Abdullab b. 'Umar said: (So far as the touching of) the pillars is concerned, I did not see the Messenger of Allah (may peace be upon him) touching them but only those situated on the side of yaman. (So far asthe wearing of) the shoes of tanned leather is concerned, I saw the Messenger of Allah (may peace be upon him) wearing shoes without hair on them, and he (wore them with wet feet) after performing ablution, and I like to wear them. So far as the yellowness is concerned, I saw the Messenger of Allah (may peace be upon him) dyeing (head, beard and cloth)with this colour and I love to dye (my head, beard or cloth) with this colour. And so far as the pronouncing of Talbiya is concerned, I did not see the Messenger of Allah (may peace be upon him) pronouncing it until his camel proceeded on (to Dhu'l-Hulaifa).

Book 7, Number 2675:

    'Ubaid b. Juraij reported: I remained in the company of 'Abdullah b. 'Umar b. al-Khattab (Allah be pleased with them) its twelve Hajjs and 'Umras and I said to him: I saw four characteristics (peculiar in you), and the rest of the hadith is the same except the case of Talbiya. There he offered the narration given by al-Maqburi and he stated the facts excepting the one given above.

Book 7, Number 2676:

    Ibn 'Umar (Allah be pleased with them) reported that the Messenger of Allah (may peace be upon him) pronounced Talbiya in Dhu'l-Hulaifa as he put his feet in the stirrup and his camel stood up and proceeded.

Book 7, Number 2677:

    Ibn 'Umar (Allah be pleased with them) reported that the Apostle of Allah (may peace be upon him) pronounced Talbiya as his camel stood up.

Book 7, Number 2678:

    'Abdullah b. 'Umar reported: I saw the Messenger of Allah (may peace be upon him) riding on his camel at Dhu'l-Hulaifa and pronouncing Talbiya as it stood up with him.

Book 7, Number 2679:

    'Abdullah b. 'Umar (Allah be pleased with them) reported that the Mes- senger of Allah (may peace be upon him) spent the night at Dhu'l-Hulaifa while com- mencing (the rites of) Pilgrimage and he observed prayer in the mosque.

Chapter 6: APPLYING OF PERFUME TO THE BODY BEFORE ENTERING UPON THE STATE OF IHRAM

Book 7, Number 2680:

    'A'isha (Allah be pleased with her) reported: I applied perfume to the Messenger of Allah (may peace be upon him) before he entered upon the state of lhram and (concluding) before circumambulating the (sacred) House.

Book 7, Number 2681:

    'A'isha (Allah be pleased with her), the wife of the Apostle of Allah (may peace be upon him), reported: I applied perfume to the Messenger of Allah (may peace be upon him) with my own hand before he entered upon the state of Ihram, and as he concluded it before-circumambulating the House (for Tawaf-i-lfada).

Book 7, Number 2682:

    'A'isha (Allah be pleased with her) reported: I used to apply perfume to the Messenger of Allah (may peace be upon him) before his entering upon the state of Ihram and at the conclusion of it, before circumambulating the House (for Tawf-i- Ifada).

Book 7, Number 2683:

    'A'isha (Allah be pleased with her) said: I applied perfume to the Messenger of Allah (may peace be upon him) as he became free from Ihram and as he entered upon it.

Book 7, Number 2684:

    'A'isha (Allah be pleased with her) said: I applied perfume of Dharira to the Messenger of Allah (may peace be upon him) with my hand (on the occasion of) the Farewell Pilgrimage on freeing from the state of Ihram and entering upon it.

Book 7, Number 2685:

    'Uthman b. 'Urwa reported on the authority of his father that he said: I asked 'A'isha with what thing she perfumed the Messenger of Allah (may peace be upon him) at the time of entering upon the state of Ihram. She said: With the best of perfume.

Book 7, Number 2686:

    'A'isha (Allah be pleased with her) reported: I applied the best perfume, which I could get, to the Messenger of Allah (may peace be upon him) before entering upon the state of Ihram (and after this) he put on the Ihram.

Book 7, Number 2687:

    'A'isha (Allah be pleased with her) reported: I applied the best available perfume I could find to the Messenger of Allah (may peace be upon him) before he entered upon the state of Ihram and after he was free from it.

Book 7, Number 2688:

    'A'isha (Allah be pleased with her) reported: I still seem to see the glisten- ing of the perfume where the hair parted on Allah's Messenger's (may peace be upon him) head as he was in the state of Ihram, and Khalaf (one of the narrators) did not say: As he was in the state of Ihram, but said: That was the perfume of Ihram.

Book 7, Number 2689:

    'A'isha (Allah be pleased with her) reported: I still seem to see the glisten- ing of the perfume where the hair parted on Allah's Messenger's (may peace be upon him) head and he was free from Ihram.

Book 7, Number 2690:

    'A'isha (Allah be pleased with her) reported: I still seem to see the glisten- ing of the perfume where the hair parted on Allah's Messenger's (may peace be upon him) head, while he was pronouncing Talbiya.

Book 7, Number 2691:

    'A'isha (Allah be pleased with her) reported: I still seem to see; the rest of the hadith is the same.

Book 7, Number 2692:

    'A'isha (Allah be pleased with her) said: I still seem to see the glistening of the perfume where the hair was parted on Allah's Messeinger's (may peace be upon him) head while he was in the state of Ihram.

Book 7, Number 2693:

    'A'isha (Allah be pleased with her) reported: I still seem to perceive the glistening of perfume where the hair was parted on Allah's Messenger's (may peace be upon him) head as he was in the state of Ihram.

Book 7, Number 2694:

    'A'isha (Allah be pleased with her) reported that when the Messenger of Allah (may peace be upon him) intended to enter upon the state of Ihram he perfumed himself with the best of perfumes which he could find and after that I saw the glisten- ing of oil on his head and beard.

Book 7, Number 2695:

    'A'isha (Allah be pleased with her) reported: I still seem to see the glisten- ing of musk (in the parting of the head) of the Messenger of Allah (may peace be upon him) while he was in the state of Ihram.

Book 7, Number 2696:

    This hadith has been narrated by 'Ubaidullah with the same chain of trans- mitters.

Book 7, Number 2697:

    'A'isha (Allah be pleased with her) reported: I used to perfume the Apostle of Allah (may peace be upon him) with a perfume containing musk before entering upon the state of Ihram and on the day of sacrifice (10th of Dhu'l-Hijja) and (at the conclusion of Ihram) before circumambulating the House (for Tawaf-i-Ifada).

Book 7, Number 2698:

    Muhammad b. al-Muntashir reported on the authority of his father: I asked 'Abdullah b. 'Umar (Allah be pleased with them) about a person who applied perfume and then (on the following) morning entered upon the state of lhram. There- upon he said: I do not like to enter upon the state of Ihram shaking off the perfume. Rubbing of tar (upon my body) is dearer to me than doing this (i.e. the applying of perfume), I went to 'A'isha (Allah be pleased with her) and told her that Ibn 'Umar stated: "I do not like to enter upon the state of Ihram shaking off the perfume. Rubbing of tar (upon my body) is dearer to me than doing it (the applying of perfume)." Thereupon 'A'isha said: I applied perfume to the Messenger of Allah (may peace be upon him) at the time of his entering upon the state of Ihram. He then went round his wives and then put on Ihram in the morning.

Book 7, Number 2699:

    'A'isha (Allah be pleased with her) reported: I used to apply perfume to the Messenger of Allah (may peace be upon him). He then went round his wives, and entered upon the state of Ihram in the morning and the perfume was shaken off.

Book 7, Number 2700:

    Muhammad b. al-Muntashir reported on the authority of his father: I heard from Ibn 'mar having said this: "It is dearer to me to rub tar (on my body) than to enter upon the state of Ihram (in a state) of shaking off the perfume." He (the narrator) said: I went to 'A'isha and told her about this statement of his (of Ibn 'Umar). Thereupon she said: I applied perfume to the Messenger of Allah (may peace be upon him) and he then went round his wives and then entered upon the state of Ihram in the morning.

Chapter 7: HUNTING IS FORBIDDEN FOR ONE WHO IS IN THE STATE OF IHRAM

Book 7, Number 2701:

    Al-Sa'b b. Jaththama al-Laithi reported that he presented a wild ass to Allah's Messenger (may peace be upon him) when he was at al-Abwa', or Waddan, and he refused to accept it. He (the narrator) said: When the Messenger of Allah (may peace be upon him) looked into my face (which had the mark of dejection as my present had been rejected by him) he (in order to console me) said: We have refused it only because we are in a state of Ihram.

Book 7, Number 2702:

    A hadith (pertaining to this topic),has been narrated on the authority of Zuhri (and the words are): "I presented to him (the Holy Prophet) a wild ass."

Book 7, Number 2703:

    It is narrated on the authority of Zuhri with the same chain of transmitters (the narrator having) said this: "I presented to him the flesh of a wild ass."

Book 7, Number 2704:

    Ibn 'Abbas (Allah be pleased with them) reported that al-Sa'b b. Jaththama presented to the Apostle of Allah (may peace be upon him) a wild ass as he was in a state of Ihram, and he returned it to him saying: If we were not in a state of Ihram, we would have accepted it from you.

Book 7, Number 2705:

    The narration transmitted by Hakam (the words are): Al-Sa'b b. Jaththama presented to the Apostle of Allah (may peace be upon him) the leg of a wild ass. And in the narration transmitted by Shu'ba (the words are) : (He presented to him) the rump of a wild ass as the blood was trickling from it. In the narration transmitted by Shu'ba on the authority of Habib (the words are) : A part of a wild ass was presented to the Apostle (may peace he upon him) and he returned it to him (who presented it).

Book 7, Number 2706:

    Tawus reported on the authority of Ibn 'Abbas (Allah be pleased with them) that one Zaid b. Arqamwent to him (Ibn 'Abbas) and said : Narrate how you informed me about the meat of the game presented to the Messenger of Allah (may peace be upon him) as he was in the state of Ihram. Thereupon he said: He was pre- sented with a slice of the meat of game, but he returned it to him (who presented it) saying : We are not going to eat it, as we are in the state of Ihram.

Book 7, Number 2707:

    Abu Qatada reported: We went with the Messenger of Allah (may peace be upon him) till we reached al-Qaha (a place three stages away from Medina). Some of us were in the state of Ihram and some of us were not. I saw my companions looking towards something, and as I saw I found It to be a wild ass. I saddled my horse and took up my spear and then mounted upon (the horse) and my whip, fell down. I said to my companions as they were in the state of Ihram to pick up the whip for me but they said : By Allah, we cannot help you in any (such) thing (i.e. hunting). So i dis- mounted (the horse) and picked it (whip) up and mounted again and caught the wild ass after chasing it. It was behind a hillock and I attacked it with my spear and killed it. Then I brought it to my companions. Some of them said : Eat it, while others said: Do not eat it. The Apostle of Allah (may peace be upon him) was in front of us. I moved my horse and came to him (and asked him), whereupon he said: It is permis- sible, so eat it.

Book 7, Number 2708:

    Abu Qatada (Allah be pleased with him) reported that while he was with the Messenger of Allah (may peace be upon him) on one of the highways of Mecca, he lagged behind him (the Holy Prophet) along with companions who were in the state of Ihram, whereas he was himself not Muhrim. He saw a wild ass. As he was mounting his horse he asked his companions to pick up for him his whip (which had dropped) but they refused to do so. He asked them to hand him over the spear, but they refused. He then himself took hold of it and chased the wild ass and killed it. Some of the Companions of the Apostle of Allah (way peace be upon him) ate (its meat), but some of them refused to do so. They overtook the Messenger of Allah (may peace be upon him) and asked him about it, and he said: It is a food which Allah provided you (so eat it).

Book 7, Number 2709:

    This hadith pertaining to the wild ass is reported on the authority of Abu Qatada. The rest of the hadith is the same but with this (variation of words) that the Messenger of Allah (may peace be upon him) said: "Is there with you some of its flesh?"

Book 7, Number 2710:

    'Abdullah b. Abu Qatada reported: My father went with the Messenger of Allah (may peace be upon him) in the year of Hudaibiya. His Companions entered upon the state of Ihram whereas he did not, for it was conveyed to the Messenger of Allah (may peace be upon him) that the enemy (was hiding at) Ghaiqa. The Messenger of Allah (may peace be upon him) went forward. He (Abu Qatada) said: Meanwhile I was along with his Companions, some of them smiled (to one another) As I cast a glance I saw a wild ass. I attacked It with a spear and held it, and begged for their (i.e. of his companions) assistance, but they refused to help me and we ate its meat. But we were afraid lest we should be separated (from the Messenger of Allah). So I proceeded on (with a view to) seeking the Messenger of Allah (may peace be upon him). Some- times I'dashed my horse and sometimes I made it run at a leisurely pace (keeping pace with others). (In the meanwhile) I met a person from Banfu Ghifar in the middle of the night. I said to him: Where did you meet the messenger of Allah (may peace be upon him) ? He said: I left him at Ta'bin and he intended to halt at Suqya to spend the afternoon. I met him and said: Messenger of Allah. your Companions convey salutations and benedictions of Allah to you and they fear that they may not be separated from you (and the enemy may do harm to you), so wait for them, and he (the Holy Prophet) waited for them. I said: Messenger of Allah, I killed a game and there is left with me (some of the meat). The Apostle of Allah (may peace be upon him) said to his people: Eat it. And they were in the state of Ihram.

Book 7, Number 2711:

    'Abdullah b. Abo. Qatada reported on the ant 'hority of his father (Allah be pleased with him): The Messenger of Allah (may peace be upon him) set out for Pil- grimage and we also set out along with him. He (Abu Qatada) said: There proceeded on some of his Companions and Abu Qatada was (one of them). He,(the Holy Prophet) said: You proceed along the coastline till you meet me. He (Abfl Qatida) said: So they proceeded ahead of the Prophet of God (may peace be upon him), all of them had entered upon the state of Ihram, except Abu Qatada; he had not put on ]hram. As they went on they saw a wild ass, and Abu Qatada attacked it and cut off its hind legs. They got down and ate its meat. They said: We ate meat In the state of Ihram. They carried the meat that was left of it. As they came to the Messenger of Allah (way peace be upon him) they said: Messenger of Allah, we were in the state of Ibrim where as Abu Qatada was not. We saw a wild ass and Abu Qatada attacked it and cut off its hind legs. We got down and ate its meat and we thus ate the meat of a game while we were In the state of Ihram. We have (carried to you) what was left out of its meat. There upon he (the holy Prophet) said: Did anyone among you command him (to hunt) or point to him with anythiny (to do so) ? They said: No. There upon he said: Then eat what is left out of its meat.

Book 7, Number 2712:

    This hadith is narrated'on the authority of 'Uthman b. 'Abdullah b. Mauhab with the same chain of transmitters. And in the narration transmitted on the authority of Shaiban (the words are): "The Messenoer of Allah (may peace be upon him) said: Did any one of you command him to attack it or point towards it ?" And in the narration transmitted by Shu'ba (the words are) : "Did you point out or did you help or did you hunt ?" Shu'ba said: I do not know whether he said: "Did you help or did you hunt?"

Book 7, Number 2713:

    Abdullah b. Abu Qatada narrated on the authority of his father (Allah be pleased with him) that they went with the Messenger of Allah (may peace be upon him) on an expedition to Hudaibiya. He (further) said: They had entered upon the state of Ihram except I for 'Umra. He (again) said: I (Abu Qatada) hunted a wild ass and fed my companions In the state of their being Muhrim. 1 then came to the Messenger of Allah (may peace be upon him) and informed him that we had with us the meat that was left out of it Thereupon he said: Eat It, while they were in the state of Ibrim.

Book 7, Number 2714:

    'Abdullah b. Abu Qatada reported on the authority of his father (Allah be pleased with him) that they went out with the Messenger of Allah (may peace be upon him) and they were Muhrim except Abu Qatada. The rest of the hadith Is the same (but with the exception of these words): "He (the Holy Prophet) said: 15 there any- thing out of it? They said: We have its leg with us. The Messenger of Allah (may peace be upon him) took it and ate it."

Book 7, Number 2715:

    Abdullah b. Abi Qatada reported that Abu Qatada was among the party of those who had entered upon the state of Ihram whereas he was not. The rest of the hadith is the same (and herein it is also narrated): "He (the Holy Prophet) said: Did any person among you point to him (to hunt) or command him (in any form)? They said: Messenger of Allah, not at all. Thereupon he said: Then eat it."

Book 7, Number 2716:

    Abd al-Rahman b. 'Uthman Taimi reported on the authority of his father; While we were with Talha b. Ubaidullah and were in the state of Ihram we were pre- sented a (cooked) bird. Talha was sleeping. Some of us ate it and some of us refrained from (eating) it. When Talba awoke he agreed,with him who ate it, and said: We ate it along with the Messenger of Allah (may peace be upon him).

Chapter 8: WHICH ANIMAL THE MUHRIM AND THE NON-MUHRIM ARE PERMITTED TO KILL IN THE STATE OF IRRAM AND AT THE CONCLUSION OF IT (WITHIN THE PRECINCTS OF THE KA'BA)

Book 7, Number 2717:

    A'isha, the wife of the Apostle of Allah (may peace be upon him). said: I heard Allah's Messenger (may peace be upon him) as saying: Four are the vicious (birds, beasts and reptiles) which should be killed in the state of Ihram or otherwise: kite (and vulture), crow, rat, and the voracious dog I (one of the narrators, 'Ubaid- ullah b. Miqsam) said to Qasim (the other narrator who beard it from 'A'isha): What about the snake? lie said: Let it be killed with disgrace.

Book 7, Number 2718:

    A'isha (Allah be pleased with her) reported Allah'* Apostle (may peace be upon him) as saying: Five are the harmful things which should be killed in the state of Ihram or otherwise: snake, speckled crow. rat. voracious dog, and kite.

Book 7, Number 2719:

    A'isha (Allah be pleased with her) reported Allah's Messenger (may peace be upon him) as saying: Five are the vicious beasts which should be killed even in the state of Ihram: scorpion, rat, kite, crow and voracious dog.

Book 7, Number 2720:

    This hadith has been narrated on the authority of Hisham with the same chain of transmitters.

Book 7, Number 2721:

    A'isha reported Allah's Mdssenger (may peace be upon him) having said this: Five are the vicious and harmful things which should be killed even within the precincts of Haram: rat, scorpion, crow. kite and voracious dog.

Book 7, Number 2722:

    This hadith has been narrated on the authority Zuhri with the same chain of transmitters that she (A'isha) reported: The Messenger of Allah (may peace be upon him) commanded to kill five harmful things in the state of lhram or other- wise. The rest of the badith is the same.

Book 7, Number 2723:

    IA'isha (Allah be pleased with her) reported Allah's Messenger (may peace be upon him) as saying: Five are the beasts 1618 harmful and vicious and these must be killed even within the precincts of the Ka'ba : crow, kite, voracio@s dog, kcorpion and rat.

Book 7, Number 2724:

    Salim reported on the authority of his father (Allah be pleased with them) that the Apostle of Allah (may peace be upon him) said: Five are the (beasts) which if one kills them in the precincts of the Ka'ba or in the state of lhram entail no sin: rat, scorpion, crow, kite and voracious dog. In another version the words are : "as a Muhrim and in the state of lhram".

Book 7, Number 2725:

    Hafsa, the wife of Allah's Apostle (may peace be upon him), reported Allah's Messenger (may peace be upon him) having said this : There are five beasts, all of them are vicious and harmful and there is no tin for one who kills them (and these are): scorpion, crow. kite, rat and voracious dog.

Book 7, Number 2726:

    Zaid b. Jubair reported: A person asked Ibn Umar which beast a Muhrim could kill. Thereupon he said: One of the wives of Allah's Apostle (may peace be upon him) told me: He (the Holy Prophet) commanded to kill rat, scorpion, kite, voracious dog and crow.

Book 7, Number 2727:

    Zaid b. Jubair reported: A person asked Ibn 'Umar which beast a Mubrim could kill, whereupon he said: One of the wives of Allab's Apostle (may peace be upon him) told me: He (the Holy Prophet) commanded to kill voracious dcg, rat, scorpion, kite, crow, and snake (and this is allowed) likewise in prayer.

Book 7, Number 2728:

    Ibn 'Umar (Allah be pleased with them) reported Allah's Messenger (may peace be upon him) as saying: Five are the beasts for killing which there is no sin for the Muhrim : crow, kite, 5corpiou, rat and voracious dog.

Book 7, Number 2729:

    Ibn Juraij reported: I said to Nafi: What is that which you heard Ibn ,Umar declaring permissible for a Mubrim to kill some of the beasts? Nafi, said to me that 'Abdullah had reported: I heard Allah's Messenger (may peace be upon him) as saying: Five are the beasts in killing which or their being killed, there is no sin: crow, kite, scorpion, rat and voracious dog.

Book 7, Number 2730:

    This hadith has been narrated on the authority of Ibn 'Umar through be upon him) as saying: Five (are the beasts) in killing which or their being killed in the precinct of the Ka'ba there is no sin." The rest of the hadith is the same.

Book 7, Number 2731:

    'Abdullah b. Umar (Allah be pleased with them) reported Allah's Messen- ger (may peace be upon him) as saying: Five (are the animals) which, it one kills them In the state of Ihram, entail no sin for one (who does it) : scorpion, rat, voracious dog, crow and kite.

Chapter 9 : IT IS PERMISSIBLE TO SHAVE THE HEAD IN THE STATE OF IHRAM IF THERE IS A TROUBLE, AND EXPIATION BECOMES OBLIGATORY FOR SHAVING

Book 7, Number 2732:

    Ka'b b. 'Ujra (Allah be pleased with him) reported: The Messenger of Allah (may peace be upon him) came to me on the occasion of Hudaibiya and I was kindling fire under my cooking pot and lice were creeping on my face. Thereupon he (the Holy Prophet) said: Do the vermins harm your head ? I said: Yes. He said: Get your head shaved and (in lieu of it) observe fasts for three days or feed six needy persons, or offer sacrifice (of an animal). Ayyub said: I do not know with what (type of expiation) did he commence (the statement).

Book 7, Number 2733:

    This hadith is narrated on the authority of Ayyub.

Book 7, Number 2734:

    Kalb b. Ujra (Allah be pleased with him) reported: It was I for whom this verse was revealed (to the Holy Prophet): "Whoever among you is sick or has an ail- ment of the head, he (may effect) a compensation by lasting or alms or a sacrifice" He said: I came to him (the Holy Prophet) and he said: Come Dear. So Iwent near. He (again) said: Come near. So I went near. Thereupon the Messenger of Allah (may peace be upon him) said: Do the vermins trouble you? Ibn Aun (one of the narrators) said: I think he (Ka'b b. Ujra) replied in the affirmative. He (the Holy Prophet) then commanded to do compensation by fasting or by giving @adaqa (feed- ing six needy persons) or by sacrifice (of a animal) that is available.

Book 7, Number 2735:

    Ka'b b. 'Ujra (Allah be pleased with him) reported that the Messenger of Allah (may peace be, upon him) stood near him and lice were falling from his head. Thereupon he (the Holy Prophet) said: Do these vermins trouble you? I said: Yes. Thereupon he said: Then shave your head; and it was in connection with me that this verse was revealed: "Whoever among you is sick or has an ailment of the head, he (may effect) a compensation by fasting or alms or a sacrifice" . He (the Holy Prophet, therefore) said to me: Observe fast for three days or give a quantity of alms enough to feed six needy persons or offer sacrifice (of an animal) that is available.

Book 7, Number 2736:

    Ka'b b. 'Ujra (Allah be pleased with him) reported that the Apostle of Allah (may peace be upon him) happened to pass by him at Hudaibiya before entering Mecca in a state of Ibrim and he (Ka'b) was kindling fire under the cooking pot and virmins were creeping on his (Kalb's) face. Thereupon (the Holy Prophet) said:Dothese vermins trouble you? He (Ka'b) said: Yes. The Messenger of Allah (way peace be upon him) said: Shave your head and give some quantity of food enough to feed six needy persons (faraq is equal to three sa's), or observe fast for three days or offer sacri- fice of a sacrificial animal. Ibn Najih (one of the narrators) said: "Or sacrifice a goat."

Book 7, Number 2737:

    Ka'b b. Ujra (Allah be pleased with him) reported that the Messenger of Allah (may peace be upon him) happened to pass by him during the period of Hudaibiya. Thereupon he (the Holy Prophet) said to him (Ka'b b. Ujra): Do these vermins trouble your head? He said: Yes. Thereupon he (the Holy Prophet) said: Shave your head. Then sacrifice a goat or observe fasts for three days or give three sits of dates to feed six needy persons.

Book 7, Number 2738:

    Abdullah b. Ma'qil said: I sat with Ka'b (Allah be pleased with him) and he was in the mosque. I asked him about this verse: "Compensation in (the form of) fasting, or Sadaqa or sacrifice." Ka'b (Allah be pleased with him) said: It was reveal- ed In my case. There was some trouble in my head. I was taken to the Messenger of Allah (may peace be upon him) and lice were creeping upon my face. Thereupon he said: I did not think that your trouble had become so unbearable as I see. Would you be able to afford (the sacrificing) of a goat? I (Ka'b) said: Then this verse was revealed: "Com- pensation (in the form of) fasting or alms or a sacrifice." He (the Holy Prophet) said: (It Implies) fasting for three days, or feeding six needy perscins, half sa' of food for every needy person. This verse was revealed particularly for me and (now) Its applica- tion is general for all of you.

Book 7, Number 2739:

    Ka'b b. Ujra (Allah be pleased with him) reported that he went out with the Apostle of Allah (may peace be upon him) in the state of Ihram, and his (Ka'b's) head and beard were infested with lice. This was conveyed to the Apostle of Allah (may peace be upon him). He sent for him (Ka'b) and called a barber (who) shaved his head. He (the Holy Prophet) said. Is there any sacrificial animal with you? He (Kalb) said: I cannot afford it. He then commanded him to observe fasts for three days or feed six needy persons, one sa' for every two needy persons. And Allah the Exalted and Majestic revealed this (verse) particular with regard to him: "So whosoever among you is sick and has an ailment of the head . . "; then (its application) became general for the Muslims.

Chapter 10:PERMISSIBILITY OF CUPPING FOR A MUHRIM

Book 7, Number 2740:

    Ibn 'Abbas (Allah be pleased with them) reported that the Apostle of Allah (may peace be upon him) got himself cupped in the state of lhrim.

Book 7, Number 2741:

    Ibn Buhaina reported that the Apostle of Allah (may peace be upon him) got himself cupped in the middle of his head on his way to Mecca.

Chapter 11: THE MUHRIM IS PERMITTED TO GET THE TRREATMENT FOR HIS EYES

Book 7, Number 2742:

    Nubaih b. Wabb reported: We went with Aban b. Uthman (in a state of lhram). When we were at Malal the eyes of Umar b. Ubaidullah became sore and, when we reached Rauba' the pain grew intense. He (Nubaib b. Wahb) sent (one) to Aban b. Uthman to ask him (what to do). He sent him (the message) to apply aloes to them, for 'Uthman (Allah be pleased with him) reported that the Messenger of Allah (may peace be upon him) applied aloes to the person whose eyes were sore and he was in the state of Ihram.

Book 7, Number 2743:

    Nubaih b Wahb reported that the eyes of Umar b. Ubaidnllah b. Ma'mar were swollen, and he decided to use antimony. Aban b. 'Uthman forbade him to do so and commanded him to apply aloes on them, and reported on the authority of 'Uthman b. Affan that the Apostle of Allah (may peace be upon him) had done that.

Chapter 12: PERMISSIBILITY OF WASHING THE BODY AND HEAD OF A MUHRIM

Book 7, Number 2744:

    Ibrahim b. 'Abdullah narrated on the authorrity of his father that there cropped up a difference of opinion between Abdullah b. 'Abbas and al-Miswar b. Makhrama at a place (called) Abwa'. Abdullah b. 'Abbas contended that a Muhrim (is permitted) to wash his head, whereas Miswar contended that a Muhrim is not (permitted) to wash his head. So Ibn Abbas sent me (the father of Ibrabim) to Abu Ayyub al- Ansari to ask him about it. (So I went to him) and found him taking bath behind two poles covered by a cloth. I gave him salutation, whereupon be asked: Who is this? I said: I am 'Abdullah b. Hunain. 'Abdullah b. 'Abbas has sent me to you to find out how the Messenger of Allah (may peace be upon him) washed his head in the state of Ihram. Abu Ayyub (Allah be pleased with him) placed his hand on the cloth and lowered it (a little) till his head became visible to me; and he said to the man who was pouring water upon him to pour water. He poured water on his head. He then moved his head with the help of his hands and moved them (the hands) forward and backward and then said: This is how I saw him (the Messenger of Allah) doing.

Book 7, Number 2745:

    This hadith has been narrated on the authority of Zaid b. Aslam with the same chain of transmitters that Abu Ayyub rubbed his whole head with his hands and then moved them forward and backward. Miswar said to Ibn 'Abbas: I would never dispute with you (in future).

Chapter 13:WHAT MUST BE DONE TO A MUHRIM IN CASE OF HIS DEATH

Book 7, Number 2746:

    Ibn Abbas (Allah be pleased with them) reported that a person fell down from his camel (in a state of Ihram) and his neck was broken and he died. Thereupon Allah's Apostle.(may peace be upon him) said: Bathe him with water mixed with the leaves of the lote tree and shroud him in his two (pieces of) cloth (Ihbram), and do not cover his head for Allah will raise him on the Day of Resurrection Pronouncing Talbiya.

Book 7, Number 2747:

    Ibn Abbas (Allah be pleased with them) reported: While a person was standing in 'Arafat with the Messenger of Allah (may peace be upon him) he fell down from his camel and broke his neck. This was mentioned to the Apostle of Allah (may peace be upon him), whereupon he said: Bathe him with water mixed with the leaves of the lote tree and shroud him in two (pieces of) cloth and neither perfume him nor cover his head; (Ayyub said) for Allah would raise him on the Day of Resurrection in the state of pronouncing Talbiya. ('Amr. however, said): Verily Allah would raise him on the Day of Resurrection pronouncing Talbiya. Sa'id b. Jubair narrated this hadith on the authority of Ibn 'Abbas (Allah be pleased with them) that a person was standing with the Apostle of Allah (may peace be upon him) as he was in the state of Ihram. The rest of the hadith is the same.

Book 7, Number 2748:

    Ibn Abbas (Allah be pleased with them) reported that a person proceeded along with the Apostle of Allah (may peace he upon him) in the state of Ihram and fell down from his camel and his neck was broken, and he died. The Messenger of Allah (may peace be upon him) said: Bathe him with water mixed with lote (leaves) and shroud him in two (pieces of) cloth and do'not cover his head for he would come on the Day of Resurrection pronouncing Talbiya.

Book 7, Number 2749:

    Sa'id b. Jubair reported on the authority of Ibn Abbas (Allah be pleased with him) that a person proceeded with the Messenger of Allah (may peace be upon him) in the state of Ihram. The rest of the hadith th is the same except that he (the Holy Prophet) (is reported to have) said: He would be raised on the Day of Resurrection pronouncing Talbiya. Sa'id b. Jubair did not name the place where he fell down.

Book 7, Number 2750:

    Ibn Abbas (Allah be pleased with them) reported that there was a person in the state of Ihram whose camel broke his neck and he died. Thereupon the Mes- senger of Allah (may peace be upon him) said: Bathe him with water mixed (with the leaves of) lote tree and shroud him In his two (pieces of) cloth and cover neither his head nor his face, for he would be raised on the Day of Resurrection pronouncing Talbiya.

Book 7, Number 2751:

    Ibn 'Abbas (Allah be pleased with them) reported that when a person who was in the state of Ihram was in the company of the Messenger of Allah (may peace be upon him), his camel broke his neckand he died. Upon this the Messenger of Allah (may peace be upon him) said: Bathe him with water (mixed with the leaves) of the lute tree and shroud him in his two (pieces of) cloth and, neither perfume him nor cover his head, for he would be raised on the Day of Resurrection pronouncing Talbiya.

Book 7, Number 2752:

    Sa'id b. Jubair reported on the authority of Ibn 'Abbas (Allah be pleased with them) that a camel broke the neck of its owner while he was in the state of lhram and he was at that time in the company of the Messenger of Allah (may peace be upon him). Allah's Messenger (may peace be upon him) commanded that he should be bathed with water mixed with (leaves of the) lote (tree) and no perfume should be applied to him and his head should not be covered, for he would be raised on the Day of Resurrection pronouncing Talblya.

Book 7, Number 2753:

    Sa'id b. Jubair heard Ibn 'Abbas (Allah be pleased with them) as saying: A person came to Allah's Apostle (may peace be upon him) while he was in the state of lhram. He fell down from his camel and broke his neck. Thereupon Allah's Apostle (may peace be upon him) commanded to bathe him with water (mixed with the leaves of) the lote (tree), and shroud him in two (pieces of) cloth and not to apply perfume (to him), keeping his head out (of the shroud). Shu'ba said: He then narrated to me after this (the words) "keeping his head out," his face out, for he would be raised on the Day of Resurrection pronouncing Talbiya.

Book 7, Number 2754:

    Sa'id b. Jubair reported on the authority of Ibn 'Abbas (Allah be pleased with them) that the camel of a person broke his neck as he was in the company of Allah's Messenger (may peace be upon him). The Messenger of Allah, (way peace be upon him) commanded them (Companions) to wash him with water mixed (with the leaves of) the lote (tree) and to keep his face exposed; (he, the narrator) said: And his head (too), for he would be raised on the Day of Resurrection pronouncing Talbiya.

Book 7, Number 2755:

    Ibn 'Abbas (Allah be pleased with him) reported that there was a person in the company of Allah's Messenger (may peace' be upon him) whose camel broke his neck and he died. thereupon Allah's Apostle (may peace be upon him) said: Wash him, but do not apply perfume and do not cover his face, for he would be raised (on the Day of Resurrection) pronouncing Talbiya.

Chapter 14 : PERMISSIBILITY OF ENTERING INTO THE STATE OF IHRAM PROVISIONALLY BECAUSE OF ILLNESS

Book 7, Number 2756:

    A'isha (Allah be pleased with her) reported that Allah's Messenger (may peace be upon him) went (into the house of) Duba'a bint Zubair and said to her: Did you intend to perform Hajj? She said: By Allah, (I intend to do so) but I often remain ill, whereupon he (the Holy Prophet) said to her: Perform Hajj but with con- dition, and say:O Allah, I shall be free from Ihram where you detain me. And she (Duba'a) was the wife of Miqdad.

Book 7, Number 2757:

    A'isha (Allah be pleased with her) reported that Allah's Apostle (may peace be upon him) went (to the house of) Duba'a bint al-Zubair b. Abd al-Muttalib. She said: Messenger of Allah, I intend to perform Hajj, but I am ill. Thereupon Allah's Apostle (may peace be upon him) said: Enter Into the state of Ihram on condition that you would abandon it when Allah would detain you.

Book 7, Number 2758:

    This hadith has been reported on the authority of A'isha through another chain of transmitters.

Book 7, Number 2759:

    Ibn Abbas reported that Duba'a bint al-Zubair b. 'Abd al-Muttalib (Allah be pleased with her) came to Allah's Messenger (may peace be upon him) and said: I am an ailing woman but I intend to perform Hajj; what you command me (to do)? He (the Holy Prophet) said: Enter into the state of Ihram (uttering these words) of condition: I would be free from it when Thou wouldst detain me.'He (the narrator) said: But she was able to complete (the Hajj without breaking down).

Book 7, Number 2760:

    Ibn Abbas (Allah be pleased with him) reported that Duba'a intended to perform Hajj. and the Apostle of Allah (may peace be upon him) commanded her (to enter into the state of Ihram) with condition. She did it in compliance with the com- mand of Allah's Apostle (may peace be upon him).

Book 7, Number 2761:

    This hadith has been narrated on the authority of Ibn 'Abbas with a slight variation of words.

Chapter 15: DONNING OF IHRAM FOR WOMEN WHO ARE IN THE STATE OF MENSES AND PARTURITION AND EXCELLENCE OF BATH WHILE ENTERING INTO THE STATE OF IHRAM

Book 7, Number 2762:

    A'isha (Allah be pleased with her) reported that Asma' hint 'Umais gave birth to Muhammad b Abu Bakr near Dhu'I-Hulaifa. The Messenger of Allah (may peace be upon him) commanded Abu Bakr to convey to her that she should take a bath and then enter into the state of Ihram.

Book 7, Number 2763:

    Jabir b. Abdullah (Allah be pleased with them) reported that when Asma' hint Umais gave birth (to a child) in Dhu'I-Hulaifa. Allah's Messenger (may peace be upon him) commanded Abyl Bakr (to convey to her) that she should take a bath and enter Into the state of Ihram.

Chapter 16 : TYPES OF IHRAM-IT IS PERMISSIBLE TO ENTER INTO THE STATE'OF IHRAM SINGULARLY FOR THE SAKE OF HAJJ, OR FOR TAMATTU'BI'L-UMRA ILA'L-HAJJ OR FOR BOTH HAJJ AND'UMRA TOGETHER

Book 7, Number 2764:

    'A'isha (Allah be pleased with her) said: We went with the Messenger of Allah (may peace be upon him) during the year of the Farewell Pilgrimage. We entered into the state of Ibrim for Umra. Then the Messenger of Allah (may peace be upon him) said: Who has the sacrificial animal with him, he should put on Ihram for Hajj along with Umra. and should not put it off till he has completed them (both Hajj and Umra). She said: When I came to Mecca. I was having menses, I neither circumambulated the House, nor ran between as-safa' and al-Marwa. I complained about it to the Messenger of Allah (may peace be upon him) and he said: Undo your hair,comb it, and pronounce Talbiya for Hajj, and give up Umra (for the time being), which I did. When we had performed the Hajj, the Messenger of Allah (way peace he upon him) sent me with Abd al-Rabman b. Abu Bakr to Tan'im saying: This is the place for your Umra. Those who had put on Ibrim for Umra circumambulated the House, and ran between al-safa' and al-Marwa. They then put off Ihram and then made the last circuit after they had returned from Mina after performing their Hajj, but those who had combined the Hajj and the Umra made only one circuit (as they had combined Hajj and 'Umra).

Book 7, Number 2765:

    'A'isha, the wife of the Apostle of Allah (may peace be upon him), said: We went out with the Messenger of Allah (may peace be upon him) during the year of the Farewell Pilgrimage. There were some amongst us who had put on IHram for Umra and there were some who had put on Ihram for Hajj. (We proceeded on till) we came to Mecca. The Messenger of Allah (may peace be upon him) said: He who put on Ihram for 'Umra but did not bring the sacrificial animal with him should put it off. and he who put on Ihram for Umra and he who had brought the sacrificial animal with him should not put it off until he had slaughtered the animal; and he who put on lhram for Hajj should complete it. A'isha (Allah be pleased with her) said: I was in the monthlyperiod, and I remained In this state till the day of 'Arafa, and I had entered into the state of Ihram for 'Umra. The Messenger of Allah (may peace be upon him) thus commanded me to undo my hair and comb them (again) and enter into the state of Ihram for Hajj, and abandon (the rites of 'Umra). She ('A'isha) said: I did so, and when I had completed my Pilgrimage, the Messenger of Allah (may peace be upon him) sent with me 'Abd al-Rabman b. Abu Bakr and commanded me to (resume the rites of) 'Umra at Tan'im. the place where (I abandoned) 'Umra and put on Ihram for Hajj (before completing Umra).

Book 7, Number 2766:

    A'isha (Allah be pleased with her) reported: We went with the Messenger of Allah (may peace be upon him) during the year of the Farewell Pilgrimage. I put on Ihram for Umra and did not bring the sacrificial animal. The Apostle of Allah (may peace be upon him) said: He who has the sacrihcial animal with him should enter into the state of Ibrim for Hajj along with 'Umra, and. he should not put the Ibrim off till he has completed both of them. She (Hadrat A'isha) said: The monthly period began. When it was the nigt of Arafa,I said to the Messenger of Allah (may peace be upon him): I entered into the state of Ihram for 'Umra. but now how should I perform the Hajj? Thereupon he said: Undo your hair and comb them, and desist from performing Umra, and put on Ihram for Hajj She (A'isha, said: When I had completed my Hajj he commanded 'Abd al-Rahman b. Abu Bakr to carry me behind him (on boneback) in order to enable me to resume the rituals of Umra from Tan'im, the place where I abandoned its rituals.

Book 7, Number 2767:

    'A'isha (Allah be pleased with her) reported: 'We went with the Messenger of Allah (may peace be upon him) (to Mecca). He said: He who intended among you to put on Ihram for Hajj and Umra should do so. And he who intended to put on Ihram for Hajj may do so. and he who intended to put on Ihram for 'Umra only may do so. A'isha (Allah be pleased with her) said: The Messenger of Allah (way peace be upon him) put on Ihram for Hajj and some people did that along with him. And some people put on Ihram for Umra and Hajj (both). and some persons put on Ihram for Umra only, and I was among those who put on Ihram for Umra (only).

Book 7, Number 2768:

    A'isha (Allah be pleased with her) reported: We went with the Messenger of Allah (may peace be upon him? (in his) Farewell Pilgrimage near the time of the appearance of the new moon of Dhu'I-Hijja. The Messenger of Allah (may peace be upon him) said: He who amongst you intends to put on Ihram for Umra may do so; bad I not brought sacrificial animal along with me, I would have put on Ihram for Umra. She (further said). There were some persons who put on Ihram for Umrs, and some persons who put on Ibrim for gajj, and 1 was one of those who put on Ihram for Umra. We went on till we reached Mecca, and on the day of 'Arafa I found myself In a state of menses, but I did not put off the Ihram for Umra. I told about (this state of mine) to the Apostle of Allah (may peace be upon him). whereupon he said: Abandon your 'Umra, and undo the hair of your head and comb (them), and put on Ihram for Hajj 'she('A'isha)said:I did accordingly.When it was the night at Hasba and Allah enabled us to complete our Hajj, he (the Holy Prophet) sent with me Abd al-Rahman b. Abu Bakr, and he mounted me behind him on his camel and took me to Tan'im and I put on Ihram for 'Umra, and thus Allah enabled us to complete our Hajj and Umra and (we wore required to observe) neither sacrifice nor alms nor fasting.

Book 7, Number 2769:

    'A'isha (Allah be pleased with her) said: We set out with the Messenger of Allah (may peace be upon him) just at the appearance of the new moon of Dhu'l- Hijja. We had no other intention but that of performing the Hajj, whereupon the Messenger of Allah (may peace be upon him) said: He who among you intends to put on Ihram for 'Umra should do so for 'Umra. The rest of the badith is the same.

Book 7, Number 2770:

    A'isha (Allah be pleased with her) reported: We went with the Messenger of Allah (may peace be upon him) at the appearance of the new moon of Dhu'I-Hijja. There were amongst us those who had put on Ihram for Umra, and those also who had put on Ihram both for Hajj and Umra, and still those who had put on Ihram for Hajj (alone). I was one of those who had put on Ihram for . Umra (only). 'Urwa (one of the narrators) said: Allah enabled her (Hdrat A'isha) to complete both Hajj and Umra (according to the way as mentioned above). Hisham (one of the narrators) said: She had neither the sacrificial animal nor (was she required to) fast, nor (was she obliged to give) alms.

Book 7, Number 2771:

    A'isha (Allah be pleased with her) said: We proceeded with the Messenger of Allah (may peace be upon him) during the year of the Farewell Pilgrimage. There were those amongst us who had put on Ihram for Umra, and those who had put on Ibrim both for Hajj and "Umra, and those amongst us who had put on Ihram for Hajj (only), while the Messenger of Allah (may peace be upon him) had put on Ihram for Hajj (only). He who put on Ihrim for Umra put it off (after performing #Umra), and he who had put on Ihram for Hajj or for both Hajj and 'Umra did not put it off before the day of sacrifice (10th of Dhu'I-Hijja).

Book 7, Number 2772:

    A'isba (Allah be pleased with her) said: We proceeded with the Apostle of Allah (may peace be upon him) with no other Intention but that of performing the Hajj. As I was at Sarif or near it, 1 entered in the state of menses. The Apostle of Allah (may peace be upon him) came to me and I was weeping, whereupon he said: Are you in a state of menses? I said. Yes. whereupon he said: This is what Allah has ordained for all the daughters, of Adam. Do whatever the pilgrim does. except that you should not circumambulate the House till you have washed yourself (at the end of the menses period). And the Messenger of Allah (may peace be upon him) offered sacrifice of a cow on behalf of his wives.

Book 7, Number 2773:

    A'isha (Allah be pleased with her) reported: We went with the Messenger of Allah (may peace be upon him) with no other aim but that of Hajj till we came (to the place known as) Sarif; and there I entered in the state of menses. The Messenger of Allah (may peace be upon him) came to me while I was weeping. He said: What makes you weep? I said: Would that I had not come (for Pilgrimage) this year. He (the Holy Prophet) said: What has happened to you? You have perhaps entered the period of menses. I said: Yes. He said: This is what has been ordained for the daughters of Adam. Do what a pilgrim does except that you should not circumambu- late the House, till you are purified (of the menses). She ('A'isha) said: When I came to Mecca, the Messenger of Allah (may peace be upon him) said to his companions: Make this (Ihram) the Ihram for 'Umra. So the people put off Ihbaim except those who had sacrificial animals with them. She ('A'isha) said: The Apostle of Allah (may peace be upon him) had the sacrificial animal with him, and so had Abd Bakr, 'Umar and other persons of means. They (those who had put off lhram again) put on Ihram (for Hajj) when they marched (towards Mina), and it was the 8th of Dhu'I-Hijja. She ('A'isha) said: When it was the day of sacrifice (10th of Dhu'I-Hijia), I was purified, and the Messenger of Allah (may peace be upon him) commanded me and I did the circuthambulation of Ifada. She said that the flesh of cow was sent to us. I said: What is It? They said: The Messenger of Allah (may peace be upon him) has offered cow as sacrifice on behalf of his wives. When it was the might at Hasba, I said: Messenger of Allah, people are coming back from Hajj and Umra, where as I am coming back from Hajj (alone). She (IA'isha) reported: He (the Holy Prophet) commanded "Abd al- Rahman b. Abu Bakr to mount me upon his camel behind him. She ('A'isha) said: I was very young and I well remember that I dozed oil and my face touched the bind part of the haudaj (camel litter) till we came to Tan'im, and entered into the state of Ihram in lieu of Umra (which I for the time being abandoned) and which the people had performed.

Book 7, Number 2774:

    A'isha (Allah be pleased with her) reported: We entered into the state of. Ihram for Hajj till we were at Sarif and I was in menses. The Messenger of Allah (may peace be upon him) came to me and I was weeping. The rest of the hadith is the same but (with this portion) that there were sacrificial animals with Allah's Apostle (may peace be upon him) and with Abu Bakr, Umar and with rich persons. And they pro- nounced Talbiya as they proceeded on. And there is no mention of this (too): "I was a girl of tender age and I dozed off and my face touched the bind part of the Haudaj."

Book 7, Number 2775:

    'A'Isha reported that the Messenger of Allah (may peace be upon him) entered into the state of Ihram for Hajj Ifrid.

Book 7, Number 2776:

    'A'isha (Allah be pleased with her) reported: We proceeded with the Mes- senger of Allah (may peace be upon him) putting on the Ihram for Hajj during the months of Hajj and the night of Hajj till we encamped at Sarlf. He (the Holy Prophet) went to his Companiens and said: He who has no sacrificial animal with him, in his case I wish that he should perform Umra (with this Ihram), and he who has the sacrificial animal with him should not do it. So some of thtm performed Hajj whereas others who had no sacrificial animals with them did not do (Hajj, but per- formed only 'Umra). The Messenger of Allah (may peace be upon him) had the sacrificial animal with him and those too who could afford it (performed) Hajj). The Messenger of Allah (may peace be upon him) came to me (i.e. A'isha) while I was weeping, and he said: What makes thee weep? I said: I heard your talk with Companions about Umra. He said: What has happened to you? I said: I do not observe prayer (due to the monthly period), whereupon besaid: It would not harm you; you should perform (during this time) the rituals of Hajj (which you can do outside the House). Maybe Allah will compensate you for this. You are one among the daughters of Adam and Allah has ordained for you as He has ordained for them. So I proceeded on (with the rituals of Hajj) till we came to Mina. I washed myself and then circumambuleted the House, and the Messenger of Allah (may peace be upon him) encamped at Muhassab and called ,Abd al-Rahman b. Abua Bakr. and said: Take out your sister from the precincts of the Ka'ba in order to put on Ihram for Umra and circumambulate the House. and I shall wait for you here. She said: So I went out and put on Ihram and then circu- mambulated the House. and (ran) between al-Safa and al-Marwa, and then we came to the Messenger of Allah (may peace be upon him) and he was in his bouse in the middle of the night. He said: Have you completed your (rituals)? I said: Yes. He then announced to his Companions to march on. He came out, and went to the House and circumambulated it before the dawn prayer and then proceeded to Medina.

Book 7, Number 2777:

    A'isha (Allah be pleased with her) said: Some among us put on Ihram for Hajj alone (Hajj Mufrad); some of us for Hajj and Umra together (Qiran), and some of us for Tamattal (first for Umra and after completing it for Haii).

Book 7, Number 2778:

    Al-Qasim b. Muhammad reported that A'isha had come for Hajj.

Book 7, Number 2779:

    'Umra reported: I heard A'isha (Allah be pleased with her) as saying: We went out with the Messenger of Allah (may peace be upon him) five days before the end of Dhi Qa'dah, and we did see but that he intended to perform Hajj (only), but as we came near Mecca the Messenger of Allah (may peace be upon him) commanded that he who did not have the sacrificial animal with him should put off Ibrim after circumambulating the House and running between al-Safa and aI-Marwa (and thus convert his Ihram from that of Hajj to 'Umra). 'A'isha (Allah be pleased with her) said: The flesh of cow was sent to us on the Day of Sacrifice (10th of Dhu'I-Hijja). I said. What is this? It was said: The Messenger of Allah (may peace be upon him) sacrificed (the cow) on behalf of his wives. Yabyi said: I made a mention of this hadith (what has been stated by Umra) to Qisim b. Muhammad, whereupon be said: By Allah, she has rightly narrated it to you.

Book 7, Number 2780:

    This hadlth has been narrated by Yahyi through the same chain of transmitters.

Book 7, Number 2781:

    Al-Qasim narrated from the Mother of the Believers (Hadrat 'A'isha) that she said: Messenger of Allah. the people return (from Mecca) having done two worships (both Hajj and Umra), but I am coming back with one (only). whereupon he said: You should wait and when the period of menses is over, you should go to Tan'im and put on lhram and then meet us at such and such time (and I think he said tomorrow); and (the reward of this Umra) is for you equal to your hardship or your spending.

Book 7, Number 2782:

    Ibn al-Muththanna reported on the authority of Ibn Abu'Adi who transmit- ted on the authority of Ibn'Aun who narrated from al-Qasim and Ibrahim having said: I cannot differentiate the badith of one from the other (Q[Lsim and Ibribim) that the Mother of the Believers (Allah be pleased with her) said this: Messenger of Allah, people have come back with two acts of worship. The rest of the hadith is the same.

Book 7, Number 2783:

    A'isha (Allah be pleased with her) reported: We went with the Messenger of Allah (may peace be upon him) and we did not see but that he (intended to perform) Rajj (only), but when we reached Mecca we circmambulated the House; and the Messenger of Allah (may peace be upon him) commanded that he who did not have with him a sacrificial animal should put off Ihram. She (A'isha) said: (And consequent- ly) those who did not bring the sacrificial anima)s with them put off Ihram; and among his wives (too) who had not brought the sacrificial animals with them put off Ihram. A'isha said: I entered in the monthly period and could not (therefore) circumambulate the House. When it was the night of Hasba she said: Messenger of Allah, people are coming.back (after having performed @oth) Hajj and'Umra, whereas I am coming back only with Hajj, whereupon he said: Did you not eircumambulate (the Ka'ba) that very night we intered Mecca? She (A'isha) said: No, whereupon he said: Go along with your brother to Tan'im and put on the Ihram for Umra, and it is at such and such a place that you can meet (us). (In the meanwhile) Safiyya (the wife of the Holy Prophet) said: I think, I will detain you (since I have entered in the monthly) period and you shall have to wait for me for the farewell circuit). Thereupon he (the Holy Prophet) said: May you be wounded and your head shorn did you not circumambulate on the Day of Sacrifice (10th of Dhu'I-Hijja)? She said: Yes. The Holy Prophet (way peace be upon him) said: There is no harm. You should go forward. 'A'isha said: The Messenger of Allah (may peace be upon him) was going upwards to the side of Mecca, whereas I was coming down from it, or I was going upward, whereas he was coming down. Isbiq said: She was clim bing down, and he was climbing down.

Book 7, Number 2784:

    'A'isha (Allah be pleased, with her) reported: We went out with the Mes. senger of Allah (may peace be upon him) pronouncing Talbiya having no explicit inten- tion of Pilgrimage or 'Umra. The rest of the hadith is the same.

Book 7, Number 2785:

    'A'isha (Allah be pleased with her) reported that the Messenger of Allah (may peace be upon him) came out on the 4th or 5th of Dhul'I-Hijja (for Pilgrimage to Mecca) and came to me, and he was very angry. I said: Messenger of Allah, who has annoyed you ? May Allah cast him in fire I He said: Don't you know that I commanded the people to do an act, but they are hesitant. (Hakam said : I think that he said: They seem to be hesitant.) And if I were to know my affair before what I had to do subsequently, I would not have brought with me the sacrificial animals, and would have bought them (at Mecca) and would have put off lhram as others have done.

Book 7, Number 2786:

    A'isha (Allah be pleased with her) reported that the Apostle of Allah (may peace be upon him) came out (for Pilgrimage) on The 4th or 5th of Dbu'l Hjjja. The rest of the hadith is the same, but he (the narrator) made no mention of the doubt of Hakam about his (the Prophet's) words: "They were reluctant."

Book 7, Number 2787:

    A'isha (Allah be pleased with her) reported that she put on Ihram for ,Umra and arrived 'at Mecca) but did not circumambulate the House as she had entered in the period of menses, and then put on Ihram for Hajj and performed all the rituals concerning it (except circumambulating the House). The Apostle of Allah (may peace be upon him) said to her on the day of march (when pilgrims come to Mina) : Your circumambulation would suffice both Hajj and Umra. She, however, felt reluc- tant.Thereupon the Holy Prophet (may peace be upon him) sent her with 'Abd al- Rahman to Tan'im and she performed Umra (with separate rituals) after Hajj.

Book 7, Number 2788:

    'A'isha (Allah be pleased with her) reported that she entered in the monthly period at Sarif, and took bath at 'Arafa (after the period was over). The messenger of Allah (may peace be upon him) said to her: Your circumambulation between al Safa and al-Marwa is enough for your Hajj and 'Umra.

Book 7, Number 2789:

    Safiyya hint Shaiba reported that 'A'isha (Allah be pleased with her) said: Messenger of Allah, lo ! the people are returning with two rewards whereas I am return- ing with one reward. Thereupon he commanded 'Abd al-Rahman b. Abu Bakr to take her to al-Tan'im. She ('A'isha) said: He seated me behind him on his camel. She(further) stated: I lifted my head covering and took it off from my neck. He struck my foot as if he was striking the camel. I said to him: Do you find anyone bere? She (further) said : I entered into the state of Ihram fond. 'Umra till we reached the Messen- ger of Allah (may peace be upon him) and he was at Hasba.

Book 7, Number 2790:

    Abd al-Rahman b. Abu Bakr reported that the Apostle of Allah (may peace be upon him) ordered him to mount A'isha behind him and enable her to (enter into the state of Ibrim for 'Umra) at Tan'im.

Book 7, Number 2791:

    Jabir (Allah be pleased with him) said: We, in the state of lhram, came with the Messenger of Allah (may peace be upon him) for Hajj Mufrad (with the aim of Hajj only), and 'A'isha set out for Umra, and when we reached Sarif, she (Hadrat A'isha) entered in the state of monthly period; we proceeded on till we reached (Mecca) and circutnambulated the Ka'ba and ran between (al-Safa) and al-Marwa; and the Messenger of Allah (may peace be upon him) commanded that one who amongst us had no sacrificial animal with him should put off Ihram. We said: What does this "Putting off" imply? He said: Getting out completely from the state of lhram, (so we put off Ihram), and we turned to our wives and applied perfume and put on our clothes. and we were at a four night's distance from 'Arafa. And we again put on Ihram on the day of Tarwiya (8th of Dhu'l-Hijja). The Messenger of Allah (may peace be upon him) came to 'A'isha (Allah be pleased with her) and found her weeping, and said: What is the matter with you? She said: The matter is that I have entered in the monthly period, and the people had put off lhram, but I did not and I did not circumambulate the House, and the people are going for Hajj now (but I can't go), whereupon he said: It is the matter which Allah has ordaiucd for the daughters of Adam, so now take a bath and put on Ihram for Hajj. She ('A'isha) did accordingly, and stayed at the places of staying till the monthly period was over. She then circu- mambulated the House, and (ran between) al-Safa and al-Marwa. He (the Holy Prophet) then said: Now both your Hajj and 'Umra are complete, whereupon she said: I feel in my mind that I did not circumambulate the House till I performed Hajj (I missed the circumambulation of 'Umra). Thereupon he (Allah's Apostle) said: 'Abd al- Rahman, take her to Tan'im (so as to enable her) to perform Umra (separately), and it was the night at Hasba.

Book 7, Number 2792:

    Jabir b. Abdullah is reported to have said that the Apostle of Allah (may peace be upon him) came to 'A'isha (Allah be pleased with her) and she was weeping. The rest of the hadith is the same.

Book 7, Number 2793:

    Jabir b. 'Abdullah reported that A'isha (Allah be pleased with her) enter- ed into the state of Ihram (separately) for 'Umra while the Prophet (may peace be upon him) was performing Hajj. The rest of the hadith is the same, but with this addi- tion: The Messenger of Allah (may peace be upon him) was a person of gentle disposi- tion, so when she (A'Isha) wished for a thing, he accepted it (provided it did not contravene the teachings of Islam). So he (in pursuance of her desire for a separate lhram for Umra) sent her with 'Abd al-Rahman b. Abu Bakr and she put on Ihram for 'Umra at al-Tan'im. Matar and Abu Zubair (the two narrators amongst the chain of transmitters) said: Whenever 'A'isha performed Hajj she did as she bad done along with Allah's Apostle (may peace be upon him).

Book 7, Number 2794:

    Jabir (Allah be pleased with him) said.: We went with Allah's Messenger (may peace be upon him) in 'a state of Ihram for the Hajj. There were women and children with us. When we reached Mecca we circumambulated the House and (ran) between al-Safa and al-Marwa. The Messenger of Allah (may peace be upon him) said: He who has no sacrificial animal with him should put off lhram. We said: What kind of putting off? He said: Getting out of lhram completely. So we came to our wives, and put on our clothes and applied perfume. When it was the day of Tarwiya, we put on Ihram for Hajj. and the first circumambulation and (running) between al-Safa and al-Marwa sufficed us..Allah's Messenger (may peace be upon him) commanded us to become seven partners (in the sacrifice) of a camel and a cow.

Book 7, Number 2795:

    Jabir b. Abdullah reported that the Apostle of Allah (may peace be upon him) ordered us to put on Ihram (again) as we proceeded towards Mina after we had put it off (i.e.'on the 8th of Dhu'l-Hijja). So we pronounced Talbiya at al-Abtah.

Book 7, Number 2796:

    Jabir b. Abdullah is reported to have said: Neither Allah's Apostle (may peace be upon him) nor his Companions (circumambulated the Ka'ba and) ran between al-Safa and al-Marwa but once (sufficing both for Hajj and 'Umra). But in the hadith transmitted by Muhammad b. Bakr there is an addition: "That is first circumambu- lation."

Book 7, Number 2797:

    'Ata'reported: I, along with some people, heard Jabir b. 'Abdullah saying: We the Companions of Muhammad (may peace be upon him) put on Ihram for Hajj only. Ata' further said that Jabir stated: Allah's Apostle (may peace be upon him) came on the 4th of Dhu'l-Hijja and he commanded us to put off Ihram. 'Ata'said that he (Allah's Apostle) commanded them to put off Ihram and to go to their wives (for inter- course). 'Ata' said: It was not obligatory for them, but (intercourse) with them had become permissible. We said: When only five days had been left to reach 'Arafa, he (the Holy Prophet) commanded us to have intercourse with our wives. And we reached 'Arafa in a state as if we had just intercoursed (with tbem). He ('Ata') said: Jabir pointed with his hand and I (perceive) as if I am seeing his hand as it moved. In the (meantime) the Apostle of Allah (may peace be upon him) stood amongst us and said: You are well aware that I am the most God-fearing, most truthful and most pious amongst you. And if there were not sacrificial animals with me, I would also have put off Ihram as you have put off. And if I were to know this matter of mine what I have come to know later on. I would not have brought sacrificial'animals with me. SO they (the Companions) put.olf Ihrim and we also put off and listened to (the Holy Prophet) and obeyed (his command). Jabir said: 'All came with the revenue of the taxes (from Yemen). He (the Holy Prophet) said: For what (purpose) have you entered into the state of Ihram (whether you entered into the state purely for Hajj and ,Umra jointly or Hajj and Umra separately)? He said: For the purpose for which the Apostle of Allah (may peace be upon him) had entered. (The Holy Prophet had entered as a Qiran, i.e. Ihram covering both Umra and Hajj simultaneously.) Thereupon Allah's Messenger (may peace be upon him) said: Offer a sacrifice of animal, and retain Ihram. And 'All brought a sacrificial animal for him (for the Holy Prophet). Suraqa b. Malik b. Ju'shum said: Messenger of Allah, is it (this concession putting off Ihram of Hajj or Umra) meant for this year or is it for ever?.He said: It is for ever.

Book 7, Number 2798:

    Jabir b. 'Abdullah (Allah be pleased with them) reported: We entered with the Messenger of Allah (may peace be upon him) in the state of Ihram for Hajj. When we came to Mecca he commanded us to put off Ihrim and make it for 'Umra. We felt It (the command) hard for us, and our hearts were anguished on account of this and it (this reaction of the people) reached the Apostle of Allah (may peace be upon him). We do not know whether he received (this news) from the Heaven (through revelation) or from the people. (Whatever the case might be) he said; O people, put off Ihram. If there were not the sacrificial animals with me, I would have done as you do. So we put off the Ihram (after performing Umra), and we bad intercourse with our wives and did everything which a non-Muhrim does (applying perfume, putting on clothes, etc.), and when It was the day of Tarwiya (8th of Dhu'l-Hijja) we turned our back to Mecca (in order to go to Mini, 'Arafat) and we put on lhram for Hajj.

Book 7, Number 2799:

    Musa b. Nafi reported: I came to Mecca as a Mutamattil for Umra (per- forming Umra first and then putting off lhram and again entering into the state of Ihram for Hajj) four days before the day of Tarwiya (i.e. on tee 4th of Dhu'l-Hijja). Thereupon the people said: Now yours is the Hajj of the Meccans. I went to 'Ata' b. Abi Rabah and asked his religious verdict. Ata' said: Jabir b. 'Abdullah al'Ans-ari (Allah be pleased wa'th them) narrated to me that he peirforfned Hajj with the Messenger of Allah (may peace be upon him) in the year when he took sacrificial animals with him (i.e. during the 10th year of Hijra known as the Farewell Pilgrimage) and they had put on Ihram for Hajj only (as Mufrid). The Messenger of Allah (may peace be upon him) said: Put off Ihram and circumambulate the House, and (run) between al-Safa and al-Marwa. and get your hair cut and stay as non-Muhrims. When it was the day of Tarwiya, then put on Ihram for Hajj and make lhram for Mut'a (you had put on Ihram i f or Hajj, but take it off af ter perf orming Umra and then again put on Ihram for Hajj). They said: How should we make it Mut'a although we entered upon lhram in the name of Hajj? He said: Do whatever I command you to do. Had I not brought sacrificial animals with me, I would have done as I have commanded you to do. But it is not permissible for me to put off Ihram till tLe sacrifice is offered. Then they also did accordingly.

Book 7, Number 2800:

    Jabir b. 'Abdullah (Allah be pleased with them) reported: We set out with Allah's Messenger (may peace be upon him) as Muhrim for Hajj. The Messenger of Allah (may peace be upon him) commanded us to make this Ihram for Umra, and some put it off (af ter performing 'Umra), but the Prophet (may peace be upon him) had sacrificial animals with him, so he could not make it (this Ihram) as that of Umra.

Chapter 17: PERFORMING HAJJ AND UMRA SEPARATELY

Book 7, Number 2801:

    Abu Nadra reported: Ibn'Abbas commanded the performance of Mut'a putting lhram for 'Umra during the months of Dhu'I-Hijja and after completing it. then putting on Ibrim for Hajj), but Ibn Zubair forbade to do it. I made a mention of it to Jabir b. Abdullih and he said: It is through me that this hadith has been circulated. We entered into the state of Ihram as Tamattu' with the Messenger of Allah (may peace be upon him). When 'Umar was Installed as Caliph, he said: Verily Allah made permissible for His Messenger (may peace be upon him) whatever He liked and as Re liked. And (every command) of the Holy Qur'an has been revealed for every occasion. So accomplish Hajj and Umra for Allah as Allah has commanded you; and confirm by (proper conditions) the marriage of those women (with whom you have performed Mut'a). And any person would come to me with a marriage of appointed duration (Mut'a), I would stone him (to death). Qatada narrated this hadith with the same chain of transmitters saying: (That 'Umar also said): Separate your Hajj from 'Umra, for that is the most complete Hajj, and complete your Umra.

Book 7 ,Number 2802:

    Jabir b. 'Abdullah (Allah be pleased with them) reported: We came with the Messenger of Allah (May peace be upon him) pronouncing Talbiya for Hajj, and the Messenger of Allah (May peace be upon him) commanded us to make (our Ihram) into that of Umra.

FAREWELL PILGRIMAGE OF THE APOSTLE OF ALLAH (MAY PEACE BE UPON HIM)

    Just as the first revelation in the cave of Hira' marks the advent of the apostolic mission of Muhammad (May peace be upon him), similarly his Farewell Pilgrimage marks its crowning glory. Opinions differ as to when Hajj became obligatory but the commonly accepted opinion is that it was in the eighth year of Hijra that Allah declared it as one of the five fundamentals of Islam. In the ninth year of Hijra the Holy Prophet (may peace be upon him) sent Abu Bakr as the leader of the Hajj delegation but he himself did not go. Hadrat Abu Bakr was later on joined by Hadrat Ali in order to make a sure declaration on behalf of the Holy Prophet (may peace be upon him) which concerned the freedom from obligation in regard to those idolatrous tribes who had shown no respect for the treaties which they had entered into with the Holy Prophet (May peace be upon him). This declaration is contains in the opening verses of Sura Tauba.

    The Holy Prophet (May peace be upon him) spent this year in making preparations for the Hajj in the tenth year of Hijra which coincided with the sixty-third year (the last year) of his life. Every attempt was, therefore, made to take full advantage of this great assembly. Messengers were sent to all parts of Arabia inviting people to join him in this great Pilgrimage. It was necessary for them since they should learn by first-hand knowledge the several injunctions and practices of the Pilgrimage-free from all taints of ignorance-an ideal pattern which was to be kept intact in its pristine glory for all times to come. Not only the rites and rituals of the Pilgrimage were to be finally explained by the Holy Prophet (May peace be upon him) but all those things which had any concern with Islam had been finalized.

    The Holy Prophet (May peace be upon him) delivered a khutba on the 24th of Dhi-Qa'da on the occasion of the Friday prayer and gave the Muslims necessary instructions relating to Hajj. Next day, I.e. on the 25th of Dhi-Qa'da, he set out after Zuhr prayer on a journey for Hajj along with thousands of his devoted Companions. The 'Asr prayer was offered at Dhu'l-Hulaifa. The caravan spent the night there and it was there after the Zuhr prayer that the Holy Prophet (May peace be upon him) and his Companions put on Ihram and proceeded towards Mecca. They reached their destination on the 4th of Dhu'l-Hijja pronouncing Talbiya (Labbaik, Labbaik, Allahumma Labbaik).

    As the caravan moved on the number of participants swelled till, according to some of the narrators, it reached more than one lakh and thirty thousands. The Farewell Pilgrimage is one of the most important occasions in the sacred life of Muhammad (May peace be upon him). Apart from the rites and rituals, the addresses and speeches of the Holy Prophet (May peace be upon him) succinctly sum up the teachings of Islam.

Book 7 ,Number 2803:

    Ja'far b Muhammad reported on the authority of his father: We went to Jabir b. Abdullah and he began inquiring about the people (who had gone to see him) till it was my turn. I said: I am Muhammad b. 'Ali b. Husain. He placed his hand upon my head and opened my upper button and then the lower one and then placed his palm on my chest (in order to bless me), and I was, during those days, a young boy, and he said: You are welcome, my nephew. Ask whatever you want to ask. And I asked him but as he was blind (he could not respond to me immediately), and the time for prayer came. He stood up covering himself in his mantle. And whenever he placed its ends upon his shoulders they slipped down on account of being short (in size). Another mantle was, however, lying on the clothes rack near by. And he led us in the prayer. I said to him: Tell me about the Hajj of Allah's Messenger (May peace be upon him). And he pointed with his hand nine, and then stated: The Messenger of Allah (may peace be upon him) stayed in (Medina) for nine years but did not perform Hajj, then he made a public announcement in the tenth year to the effect that Allah's Messenger (may peace be upon him) was about to perform the Hajj. A large number of persons came to Medina and all of them were anxious to follow the Messenger of Allah (May peace be upon him) and do according to his doing. We set out with him till we reached Dhu'l-Hulaifa. Asma' daughter of Umais gave birth to Muhammad b. Abu Bakr. She sent message to the Messenger of Allah (May peace be upon him) asking him: What should 1 do? He (the Holy Prophet) said: Take a bath, bandage your private parts and put on Ihram. The Messenger of Allah (May peace be upon him) then prayed in the mosque and then mounted al-Qaswa (his she-camel) and it stood erect with him on its back at al-Baida'. And I saw as far as I could see in front of me but riders and pedestrians, and also on my right and on my left and behind me like this. And the Messenger of Allah (may peace be upon him) was prominent among us and the (revelation) of the Holy Qur'an was descending upon him . And it is he who knows (its true) significance. And whatever he did, we also did that. He pronounced the Oneness of Allah (saying): "Labbaik, 0 Allah, Labbaik, Labbaik. Thou hast no partner, praise and grace is Thine and the Sovereignty too; Thou hast no partner." And the people also pronounced this Talbiya which they pronounce (today). The Messenger of Allah (May peace be upon him) did not reject anything out of it. But the Messenger of Allah (May peace.be upon him) adhered to his own Talbiya. Jabir (Allah be pleased with him) said: We did not have any other intention but that of Hajj only, being unaware of the Umra (at that season), but when we came with him to the House, he touched the pillar and (made seven circuits) running three of them and walking four. And then going to the Station of Ibrahim, he recited: "And adopt the Station of Ibrahim as a place of prayer." And this Station was between him and the House. My father said (and I do not know whether he had made a mention of it but that was from Allah's Apostle [May peace be upon him] that he recited in two rak'ahs: "say: He is Allah One," and say: "Say: 0 unbelievers." He then returned to the pillar (Hajar Aswad) and kissed it. He then went out of the gate to al-Safa' and as he reached near it he recited: "Al-Safa' and al-Marwa are among the signs appointed by Allah," (adding:) I begin with what Allah (has commanded me) to begin. He first mounted al-Safa' till he saw the House, and facing Qibla he declared the Oneness of Allah and glorified Him, and said: "There is no god but Allah, One, there is no partner with Him. His is the Sovereignty. to Him praise is due. and He is Powerful over everything. There is no god but Allah alone, Who fulfilled His promise, helped His servant and routed the confederates alone." He then made supplication in the course of that saying such words three times. He then descended and walked towards al-Marwa, and when his feet came down in the bottom of the valley, he ran, and when he began to ascend he walked till he reached al-Marwa. There he did as he had done at al-Safa'. And when it was his last running at al-Marwa he said: If I had known beforehand what I have come to know afterwards, I would not have brought sacrificial animals and would have performed an 'Umra. So, he who among you has not the sacrificial animals with him should put off Ihram and treat it as an Umra. Suraqa b. Malik b. Ju'sham got up and said: Messenger of Allah, does it apply to the present year, or does it apply forever? Thereupon the Messenger of Allah (May peace be upon him) intertwined the fingers (of one hand) into another and said twice: The 'Umra has become incorporated in the Hajj (adding): "No, but for ever and ever." 'All came from the Yemen with the sacrificial animals for the Prophet (May peace be upon him) and found Fatimah (Allah be pleased with her) to be one among those who had put off Ihram and had put on dyed clothes and had applied antimony. He (Hadrat'Ali) showed disapproval to it, whereupon she said: My father has commanded me to do this. He (the narrator) said that 'Ali used to say in Iraq: I went to the Messenger of Allah (may peace be upon him) showing annoyance at Fatimah for what she had done, and asked the (verdict) of Allah's Messenger (may peace be upon him) regarding what she had narrated from him, and told him that I was angry with her, whereupon he said: She has told the truth, she has told the truth. (The Holy Prophet then asked 'Ali): What did you say when you undertook to go for Hajj? I ('Ali) said: 0 Allah, I am putting on Ihram for the same purpose as Thy Messenger has put it on. He said: I have with me sacrificial animals, so do not put off the Ihram. He (Jabir) said: The total number of those sacrificial animals brought by 'Ali from the Yemen and of those brought by the Apostle (may peace be upon him) was one hundred. Then all the people except the Apostle (may peace be upon him) and those who had with them sacrificial animals, put off Ihram , and got their hair clipped; when it was the day of Tarwiya (8th of Dhu'l-Hijja) they went to Mina and put on the Ihram for Hajj and the Messenger of Ailah (may peace be upon him) rode and led the noon, afternoon, sunset 'Isha' and dawn prayers. He then waited a little till the sun rose, and commanded that a tent of hair should be pitched at Namira. The Messenger of Allah (may peace be upon him) then set out and the Quraish did not doubt that he would halt at al-Mash'ar al-Haram (the sacred site) as the Quraish used to do in the pre-Islamic period. The Messenger of Allah (may peace be upon him), however, passed on till he came to 'Arafa and he found that the tent had been pitched for him at Namira. There he got down till the sun had passed the meridian; he commanded that al-Qaswa should be brought and saddled for him. Then he came to the bottom of the valley, and addressed the people saying: Verily your blood, your property are as sacred and inviolable as the sacredness of this day of yours, in this month of yours, in this town of yours. Behold ! Everything pertaining to the Days of Ignorance is under my feet completely abolished. Abolished are also the blood-revenges of the Days. of Ignorance. The first claim of ours on blood-revenge which I abolish is that of the son of Rabi'a b. al-Harith, who was nursed among the tribe of Sa'd and killed by Hudhail. And the usury of she pre-Islamic period is abolished, and the first of our usury I abolish is that of 'Abbas b. 'Abd al-Muttalib, for it is all abolished. Fear Allah concerning women ! Verily you have taken them on the security of Allah, and intercourse with them has been made lawful unto you by words of Allah. You too have right over them, and that they should not allow anyone to sit on your bed whom you do not like. But if they do that, you can chastise them but not severely. Their rights upon you are that you should provide them with food and clothing in a fitting manner. I have left among you the Book of Allah, and if you hold fast to it, you would never go astray. And you would be asked about me (on the Day of Resurrection), (now tell me) what would you say? They (the audience) said: We will bear witness that you have conveyed (the message), discharged (the ministry of Prophethood) and given wise (sincere) counsel. He (the narrator) said: He (the Holy Prophet) then raised his forefinger towards the sky and pointing it at the people (said): "O Allah, be witness. 0 Allah, be witness," saying it thrice. (Bilal then) pronounced Adhan and later on Iqama and he (the Holy Prophet) led the noon prayer. He (Bilal) then uttered Iqama and he (the Holy Prophet) led the afternoon prayer and he observed no other prayer in between the two. The Messenger of Allah (may peace be upon him) then mounted his camel and came to the place of stay, making his she-camel al-Qaswa, turn towards the side where there we are rocks, having the path taken by those who went on foot in front of him, and faced the Qibla. He kept standing there till the sun set, and the yellow light had somewhat gone, and the disc of the sun had disappeared. He made Usama sit behind him, and he pulled the nosestring of Qaswa so forcefully that its head touched the saddle (in order to keep her under perfect control), and he pointed out to the people with his right hand to be moderate (in speed), and whenever he happened to pass over an elevated tract of sand, he slightly loosened it (the nose-string of his camel) till she climbed up and this is how he reached al-Muzdalifa. There he led the evening and 'Isha prayers with one Adhan and two Iqamas and did not glorify (Allah) in between them (i.e. he did not observe supererogatory rak'ahs between Maghrib and 'Isha' prayers). The Messenger of Allah (may peace be upon him) then lay down till dawn and offered the dawn prayer with an Adhan and Iqama when the morning light was clear. He again mounted al-Qaswa, and when he came to al-Mash'ar al-Haram, he faced towards Qibla, supplicated Him, Glorified Him, and pronounced His Uniqueness (La ilaha illa Allah) and Oneness, and kept standing till the daylight was very clear. He then went quickly before the sun rose, and seated behind him was al-Fadl b. 'Abbas and he was a man having beautiful hair and fair complexion and handsome face. As the Messenger of Allah (May peace be upon him) was moving on, there was also going a group of women (side by side with them). Al-Fadl began to look at them. The Messenger of Allah (may peace be upon him) placed his hand on the face of Fadl who then turned his face to the other side, and began to see, and the Messenger of Allah (may peace be upon him) turned his hand to the other side and placed it on the face of al-Fadl. He again turned his face to the other side till he came to the bottom of Muhassir.1680 He urged her (al-Qaswa) a little, and, following the middle road, which comes out at the greatest jamra, he came to the jamral682which is near the tree. At this be threw seven small pebbles, saying Allah-o-Akbar while throwing every one of them in a manner in which the small pebbles are thrown (with the help of fingers) and this he did in the bottom of the valley. He then went to the place of sacrifice, and sacrificed sixty-three (camels) with his own hand.1694 Then he gave the remaining number to 'All who sacrificed them, and he shared him in his sacrifice. He then commanded that a piece of flesh from each animal sacrificed should be put in a pot, and when it was cooked, both of them (the Holy Prophet and Hadrat 'All) took some meat out of it and drank its soup. The Messenger of Allah (May peace be upon him) again rode and came to the House, and offered the Zuhr prayer at Mecca. He came to the tribe of Abd al-Muttalib, who were supplying water at Zamzam, and said: Draw water. 0 Bani 'Abd al-Muttalib; were it not that people would usurp this right of supplying water from you, 1 would have drawn it along with you. So they handed him a basket and he drank from it.

Book 7 ,Number 2804:

    Ja'far b. Muhammad narrated on the authority of his father thus: I came to Jabir b. Abdullah and asked him about the (Farewell) Pilgrimage of Allah's Messenger (may peace be upon him). The rest of the hadith is the same, but with the addition of this: "There was one Abu Sayyara among the Arabs, (of pre-Islamic period) who carried (people from Muzdalifa to Mini). As the Messenger of Allah (May peace be upon him) set out from Muzdalifa to al-Mash'ar al-Haram, the Quraish were certain that he would halt there and that would be his station. But he passed on (without staying) there. and paid no heed to it till he came to 'Arafat and there he stayed."

Book 7 ,Number 2805:

    Jabir reported Allah's Messenger (May peace be upon him) as saying: I have sacrificed (the animals) here, and the whole of Mini is a place for sacrifice; so sacrifice your animals at your places. 1 have stayed here (near these rocks), and the whole of Arafat is a place for stay. And I have stayed here (at Muzdalifa near Mash'ar al-Haram and the whole of Muzdalifa) is a place for stay (i.e. one is permitted to spend night in any part of it, as one likes).

Book 7 ,Number 2806:

    Jabir b. Abdullah (Allah be pleased with them) reported that when Allah's Messenger (may peace be upon him) proceeded to Mecca, he came to it (the Black Stone). he kissed it. and moved to his right. and moved quickly in three circuits, and walked in four circuits.

Chapter 18:STAYING AND THE SIGNIFICANCE OF THE VERSE: ,THEN HASTEN ON FROM WHERE THE PEOPLE HASTEN ON (ii. 199)

Book 7, Number 2807:

    'A'isha (Allah be pleased with her) reported that the Quraish (of the pre-Islamic days) and those who followed their religions practices stayed at Muzdalifa, and they named themselves as Hums, whereas all other Arabs stayed at 'Arafa. With the advent of Islam, Allah, the Exalted and Glorious, commanded His Apostle (may peace be upon him) to come to 'Arafat and stay there, and then hurry from there, and this is the significance of the words of Allah: "Then hasten on from where the people hasten on."

Book 7 ,Number 2808:

    Hisham narrated on the authority of his father that the Arabs with the exception of Hums who were Quraish, and their descendants, circumambulated the House naked. They kept circumambulating In this state of nudity unless the Hums supplied to them the clothes. The male provided (clothes) to the male and the female provided clothes to the female. And the Hums did not get out of Muzdalifa, whereas the people (other than the Quraish) went t o 'Arafat. Hisham said on the authority of his father who related from 'A'isha (Allah be pleased with her) who said: Hums are those about whom Allah, the Exalted and Glorious, revealed this verse: "Then hasten to where the people hasten." She (further) said: The people hastened on from 'Arafat, whereas Hums hastened from Muzdalifa, and said: We'do not hasten but from Haram. But when this (verse) was revealed: "Hasten on from that (place) where the people hasten on," they (the Quraish) then went to 'Arafat.

Book 7 ,Number 2809:

    Jubair. b. Mut'im reported: I lost my camel and went in search of it on the day of 'Arafa, and I saw the Messenger of Allah (may peace be upon him) staying along with people in 'Ara'fit. Thereupon I said: By Allah, he is among the Hums (Quraish) ; what has happened to him that he has come to this (place)? The Quraish were counted among Hums.

Chapter 19:PERMISSIBILITY OF SAYING ONE HAS ENTERED INTO IHRAM LIKE THE IHRAM OF THE OTHER ONE OR ABROGATION OF PUTTING OFF IHRAM AND COMPLETING (HAJJ AND.UMRA)

Book 7, Number 2810:

    Abu Musa (Allah be pleased with him) said: I came to the Messenger of Allah (may peace be upon him) as he was encamping at Batha. He said to me: Did you intend to perform Hajj? I said: Yes. He again said: With what intention have you entered into the state of Ihram (for Ifrad, Qiran or Tamattu'). I said: I pronounced Talbiya (I have entered into the state of Ihram ) with that very aim with which the Apostle of Allah (may peace be upon him) is pronouncing Talbiya. He (the Holy Prophet) said; You have done well. Then circumambulate the House and run between al-Safa' and al-Marwa' and put off Ihram (as you have not brought the sacrificial animals along with you). So I circumambulated the House, and ran between al-Safa' and al-Marwa' and then came to a woman of the tribe of Qais and she rid my head of the lice. I again put on Ihram for Hajj. and continued giving religious verdict (according to this practice) till during the Caliphate of Umar (Allah be pleased with him) when a person said to him: Abu Musa, or Abdullah b. Qais, exercise restraint in delivering some religious verdict of yours, for you do not know what has been introduced after you by the Commander of the Believers in the rites (of Hajj). Thereupon he said: 0 people, whom we gave the religious verdict (concerning putting off Ihram ) they should wait, for the Commander of the Believers is about to come to you, and you should follow him. Umar (Allah be pleased with him) then came and I made a mention of it to him. whereupon he said: If we abide by the Book of Allah (we find) the Book of Allah has commanded us to complete the (.Hajj and 'Umra), and if we abide by the Sunnah of Allah's Messenger (may peace be upon him), we find that Allah's Messenger (may peace be upon him) did not put off Ihram till the sacrificial animal was brought to its end (till it was sacrificed).

Book 7 ,Number 2811:

    This hadith has been narrated by Shu'ba with the same chain of transmitters.

Book 7 ,Number 2812:

    Abu Musa (Allah be pleased with him) reported: I came to the Messenger of Allah (may peace be upon him) and he was encamping at Batha. He (the Holy Prophet) said: With what purpose have you entered into the state of Ihram ? I said: I have entered into the state of Ihram in accordance with the Ihram of Allah's Apostle (may peace be upon him). He said: Have you brought sacrificial animals along with you? I said: No. whereupon he said: Then circumambulate the House and run between al-Safa' and al-Marwa and put off Ihram . So I circumambulated the House, ran between al-Safa' and al-Marwa, and then came to a woman of my tribe. She combed and washed my head. I used to give religious verdict (according to the above mentioned command of the Holy Prophet) during the Caliphate of Abu Bakr and also during that of 'Umar. And it was during the Hajj season that a person came to me and said: You (perhaps) do not know what the Commander of the Believers has introduced in the rites (of Hajj). I said: 0 people, those whom we have given religious verdict about a certain thing should wait, for the Commander of the Believers is about to arrive among you, so follow him. When the Commander of the Believers arrived, I said: What is this that you have introduced in the rites (of Hajj)? -where upon he said: If we abide by the Book of Allah (we find) that there Allah, Exalted and Majestic, has said: Complete Hajj and 'Umra for Allah." And if we abide by the Sunnah of our Apostle (may peace be upon him) (we find) that the Apostle of Allah (May peace be upon him) did not put off Ihram till he had sacrificed the animals.

Book 7 ,Number 2813:

    Abu Musa (Allah be pleased with him) reported: The Messenger of Allah (May peace be upon im) had sent me to Yemen and I came back In the year in which he (the Holy Prophet) performed the (Farewell) Pilgrimage. Allah's Messenger (may peace be upon, him) said to me: Abu Musa, what did you ' say when you entered into the state of Ihram? I said: At thy beck and call; my (Ihram) is that of the Ihram of Allah's Apostle (May peace be upon him). He said: Have you brought the sacrificial animals? I said: No. Thereupon he said: Go and circumambulate the House, and (run) between al-Safa' and al-Marwa and then put off Ihram. The rest of the hadith is the same.

Book 7 ,Number 2814:

    Abu Musa, (Allah be pleased with him) reported that he used to deliver religious verdict in favor of Hajj Tamattu'. A person said to him: Exercise restraint in delivering some of your religious verdicts, for you do not know what the Commander of Believers has introduced in the rites (of Hajj) after you (when you were away in Yemen). He (Abu Musa,) met him (Hadrat Umar) subsequently and asked him (about it), whereupon 'Umar said: I know that Allah's Apostle (May peace be upon him) and also his Companions did that (observed Tamattu'), but I do not approve that the married persons should have intercourse with their wives under the shade of the trees, and then set out for Hajj with water trickling down from their beads.

Chapter 20:PERMISSIBILITY OF THE TAMATTU, (FORM OF PILGRIMAGE)

Book 7, Number 2815:

    'Abdullah b. Shaqiq reported that 'Uthman (Allah be pleased with him) used to forbid Tamattu', whereas 'Ali (Allah be pleased with him) ordered to do it. 'Uthman said a word to 'Ali, but 'Ali said: You know that we used to perform Tamattu' with the Messenger of Allah (may peace be upon him) , whereupon he said: It is right, but we entertained fear. This hadith has been narrated by Shu'ba with the same chain of transmitters.

Book 7 ,Number 2816:

    Sa'id b. al-Musayyab reported that 'Ali and 'Uthman (Allah be pleased with them) met at 'Usfan; and Uthman used to forbid (people) from performing Tamattu' and 'Umra (during the period of Hajj), whereupon 'Ali said: What is your opinion about a matter which the Messenger of Allah (may peace be upon him) did but you forbid it? Thereupon Uthman said: You leave us alone, whereupon he ('Ali) said: I cannot leave you alone. When 'Ali saw this, he put on Ihram for both of them together (both for Hajj and 'Umra).

Book 7 ,Number 2817:

    Abu Dharr (Allah be pleased with him) said that Tamattu' in Ha was a special (concession) 1694 for the Companions of Muhammad (may peace be upon him).

Book 7 ,Number 2818:

    Abu Dharr (Allah be pleased with him) reported: Tamattu' in Hajj was a special concession for us.

Book 7 ,Number 2819:

    Abu Dharr (Allah be pleased with him) said: Two are the Mut'as which were not permissible but only for us, i.e. temporary marriage with women and Tamattu' in Hajj.

Book 7 ,Number 2820:

    'Abd al-Rahman b. Abi al-Sha'tha' reported: I came to Ibrahim al-Nakha'I and Ibrahim Taimi and said: I intend to combine 'Umra and Hajj this year, whereupon Ibrahim al-Nakha'i said: But your father did not make such intention. Ibrahim narrated on the authority of, his father that he passed by Abu Dharr (Allah be pleased with him) at Rabdha, and made a mention of that, whereupon he said: It was a special concession for us and not for you.

Book 7 ,Number 2821:

    Ghunaim b. Qais said: I asked Sa'd b. Abu Waqqas (Allah be pleased with him) about Mut'a, whereupon he said: We did that, and it was the day when he was an unbeliever living in (one of the) houses of Mecca.

Book 7 ,Number 2822:

    This hadith has been narrated on the authority of Sulaiman Taimi with the same chain of transmitters and in his narration (he) refers to Mu'awiya.

Book 7 ,Number 2823:

    This hadith has been transmitted on the authority of Sulaiman (but with a slight modification of words).

Book 7 ,Number 2824:

    Mutarrif reported: 'Imran b. Husain said to me: Should I not narrate to you a hadith today by which Allah will benefit you subsequently-and bear in mind that Allah's Messenger (may peace be upon him) made some members of his family perform 'Umra within ten days of Dhu'l-Hijja. No verse was revealed to abrogate that, and he (the Holy Prophet) did not refrain from doing it till he died. So after him everyone said as he liked, (but it would be his. personal opinion and not the verdict of the Shari'ah).

Book 7 ,Number 2825:

    This hadith been narrated on the authority of Jurairi with the same chain of transmitters, and Ibn Hatim said in his narration: "A person said according to his personal opinion, and it was Umar."

Book 7 ,Number 2826:

    Imran b. Husain reported: I am narrating to you a hadith by which Allah will benefit you (and the hadith is) that Allah's Messenger (may peace be upon him) combined Hajj and 'Umra, and he did not forbid (this combination) till he died. (Moreover) nothing was revealed in the Holy Qur'an which forbade it. And I was always blessed till I was branded and then it (blessing) was abandoned. I then abandoned branding and it (the blessing was restored).

Book 7 ,Number 2827:

    This hadith has been narrated on the authority of Mutarrif with the same chain of transmitters.

Book 7 ,Number 2828:

    Mutarrif reported: 'Imran b. Husain sent for me during his illness of which he died, and said: I am narrating to you some ahadith which may benefit you after me. If I live you conceal (the fact that these have been transmitted by me), and if I die, then you narrate them if you like (and these are): I am blessed, and bear in mind that the Messenger of Allah (may peace be upon him) combined Hajj and Umra. Then no verse was revealed in regard to it in the Book of Allah (which abrogated it) and the Apostle of Allah (may peace be upon him) did not forbid (from doing it). And whatever a person (,Umar) said was out of his personal opinion.

Book 7 ,Number 2829:

    'Imran b. al-Husain (Allah be pleased with him) said: Know well that Allah's Messenger (may peace be upon him) combined 'Hajj and 'Umra, and nothing was revealed in the Book (to abrogate it), and the Messenger of Allah (may peace be upon him) too did not forbid us from (combining) them. And whatever a person said was out of his personal opinion.

Book 7 ,Number 2830:

    'Imran b. Husain (Allah be pleased with him) reported: We performed Tamattu' (Hajj and 'Umra combining together) in the company of Allah's Messenger (may peace be upon him), and nothing was revealed in the Qur'an (concerning the abrogation of this practice), and whatever a person (Hadhrat 'Umar) said was his personal opinion. 'Imran b. Husain narrated this hadith (in these words also): "Allah's Apostle (may peace be upon him) performed Hajj Tamattu' and we also performed it along with him."

Book 7 ,Number 2831:

    'Imran b. Husain said: There was revealed the verse of Tamattu' in Hajj in the Book of Allah and the Messenger of Allah (may peace be upon him) commanded us to perform it. and then no verse was revealed abrogating the Tamattu' (form of Hajj), and the Messenger of Allah (may peace be upon him) did not forbid to do it till he died. So whatever a person said was his personal opinion. A hadith like this is transmitted on the authority of Imran b. Husain, but with this variation that he ('Imran) said: We did that (Tamattu') in the company of Allah's Messenger (may peace be upon him) and he did not say anything but he (the Holy Prophet) commanded us to do it.

Chapter 21:SACRIFICING OF ANIMAL IS OBLIGATORY FOR TAMATTU., BUT HE WHO DOES NOT DO IT IS REQUIRED TO OBSERVE FAST FOR THREE DAYS DURING THE HAJJ AND FOR SEVEN DAYS WHEN HE RETURNS TO THE FAMILY

Book 7, Number 2832:

    Abdullah b. 'Umar (Allah be pleased with them) reported: Allah's Messenger (may peace be upon him) observed Tamattu' in Hajjat-ul-Wada' .He first put on Ihram for 'Umra and then for Hajj. and then offered animal sacrifice. So he drove the sacrificial animals with him from Dhu'l-Hulaifa. Allah's Messenger (may peace be upon him) commenced Ihram of Umra and thus pronounced Talbiya for 'Umra. and then (put on Ihram for Hajj) and pronounced Talbiya for Hajj. And the people performed Tamattu' in the company of Allah's Messenger (may peace be upon him). They put on Ihram for Umra (first) and then for Hajj. Some of them had sacrificial animals which they had brought with them, whereas some of them had none to sacrifice. So when Allah's Messenger (may peace be upon him) came to Mecca, he said to the people: He who amongst you has brought sacrificial animals along with him must not treat as lawful anything which has become unlawful for him till he has completed the Hajj; and he,who amongst you has not brought the sacrificial animals should circumambulate the House, and run between al-Safa' and al-Marwa and clip (his hair) and put off the Ihram, and then again put on the Ihram for Hajj and offer sacrifice of animals. But he who does not find the sacrificial animal, he should observe fast for three days during the Hajj and for seven days when he returns to his family. Allah's Messenger (may peace be upon him) circumambulated (the House) when he came to Mecca: he first kissed the corner (of the Ka'ba containing the Black Stone), then ran in three circuits out of seven and walked in four circuits. And then when he had finished the circumambulation of the House he observed two rak'ahs of prayer at the Station (of Ibrahim), and then pronounced Salaam (for concluding the rak'ahs), and departed and came to al-Safa' and ran seven times between al-Safa' and al-Marwa. After that he did not treat anything as lawful which had become unlawful till he had completed his Hajj and sacrificed his animal on the day of sacrifice (10th of Dhu'l-Hijja). and then went back quickly (to Mecca) and performed circumambulation of the House (known as tawaf ifada) after which all that was unlawful for him became lawful; and those who had brought the sacrificial animals along with them did as Allah's Messenger (may peace be upon him) had done. This hadith has been narrated on the authority of 'A'isha. The wife of Allah's Messenger (may peace be upon him), concerning his Tamattu' of Hajj and 'Umra and performing of Tamattu' by people in his company.

Chapter 22:THE QARIN SHOULD NOT PUT OFF THE IHRAM BUT AT THE TIME WHEN A MUFRID PILGRIM TAKES IT OFF

Book 7, Number 2833:

    Hafsa (Allah be pleased with her), the wife of Allah's Apostle (may peace be upon him), said: Messenger of Allah. what about people who have put off Ihram whereas you have not put it off after your 'Umra? He said: I have stuck my hair and have driven my sacrificial animal, and would not, therefore, put off Ihram until I have sacrificed the animal.

Book 7 ,Number 2834:

    Hafsa (Allah be pleased with her) reported: I said: Messenger of Allah what is the matter with you that you have not put off Ihram ? The rest of the hadith is the same.

Book 7 ,Number 2835:

    Hafsa (Allah be pleased with her) reported: I said to Allah's Messenger (may peace be upon him): What is the matter with people that they have put off Ihram, whereas you have not put it off after your Umra'? He said: I have driven my sacrificial animal and stuck my hair, and it is not permissible for me to put off Ihram unless I have completed the Hajj.

Book 7 ,Number 2836:

    Hafsa (Allah be pleased with her) said: Messenger of Allah; the rest of the hadith is the same and (the concluding words of the Holy Prophet): "I won't put off Ihram until I have sacrificed the animal."

Book 7 ,Number 2837:

    Hafsa (Allah be pleased with her) said that Allah's Apostle (may peace be upon him) commanded his wives that they should put off Ihram during the year of Hajj (at-ul-Wada'). whereupon she (Hafsa) said: What hinders you that you have not put off Ihram? Thereupon he said: I have stuck my hair and driven my sacrificial animal along with men and it is not permissible to put off Ihram (under this condition until I have sacrificed the animal .

Chapter 23:PERMISSIBILITY OF PUTTING OFF IHRAM (IN THE MIDST OF HAJJ CEREMONIES) IN CASE OF OBSTRUCTION AND PERMISSIBILITY OF QIRAN

Book 7, Number 2838:

    Nafi' reported that 'Abdullah b. Umar (Allah be pleased with them) set out for Umra during the turmoil, and he said: If I am detained (from going to) the House, we would do the same as we did with Allah's Messenger (may peace be upon him). So he went out and put on Ihram for 'Umra and moved on until he reached al-Baida'. He turned towards his Companions and said: There is one command for both of them. and 1 call you as my witness (and say) that verify I have- made Hajj with 'Umra compulsory for me. He proceeded until, when he came to the House, he circumambulated it seven times and ran between al-Safa' and al-Marwa seven times, and made no addition to it and thought it to be sufficient for him and offered sacrifice.

Book 7 ,Number 2839:

    Nafi' reported that 'Abdullah b. 'Abdullah and Salim b. Abdullah said to 'Abdullah (b. 'Umar) at the time when Hajjaj came to fight against Ibn Zubair: There would be no harm if you do not (proceed) for Hajj this year, for we fear that there would be fight among people which would cause obstruction between you and the House, whereupon he said: If there would be obstruction between me and that (Ka'ba), I would do as Allah's Messenger (may peace be upon him) did. I was with him (the Holy Prophet) when the infidels of Quraish caused obstructions between him (the Holy Prophet) and the House. I call you as my witness (to the fact) that I have made 'Umra essential for me. He proceeded until he came to Dhu'l-Hulaifa and pronounced Talbiya for Umra, and said: If the way Is clear forme, I would then complete my 'Umra but If there is some obstruction between me and that (the Ka'ba). I would then do what Allah's Messenger (may peace be upon him) had done (at the occasion of Hudaibiya), and I was with him (the Holy Prophet). and then recited: "Verily in the Messenger of Allah, there is a model pattern for you" (xxxiii. 21). He then moved on until he came to the rear side of al-Baida' and said: There is one command for both of them automatically)(Hajj and Umra). If I am detained (in the performance) of 'Umra, I am ( automatically detained (in the performance) of Hajj (too). I call you as witness that Hajj along with 'Umra I had made essential for me. (I am performing Hajj and 'Umra as Qiran.) He then bought sacrificial animals at Qudaid and then circumambulated the House and ran between al-Safa' and al-Marwa once (covering both Hajj and Umra), and did not put off Ihram until on the Day of Sacrifice in the month of Dhu'l-Hijja.

Book 7 ,Number 2840:

    Nafi' reported that Ibn Umar intended to go to Hajj (during the year) when Hajjaj attacked Ibn Zubair, and he narrated the account as (narrated above), and he used to say at the end of the hadith: He who combines Hajj with Umra, for him one single circumambulation is sufficient, and he did not put off Ihram until he had completed both of them.

Book 7 ,Number 2841:

    Nafi' reported that Ibn Umar intended to go for Hajj during the year when Hajjaj attacked Ibn Zubair. It was said to him: There is a state of war between people and we fear that they would detain you, whereupon he ('Abdullah b. Umar) said: "Verily in the Messenger of Allah there is a model pattern for you." I would do as Allah's Messenger (may peace be upon him) did. I call you as witness that I have undertaken to perform 'Umra. He then set out until, when he reached the rear side of al-Baida', he said: There is one command both for Hajj and Umra. so bear witness. Ibn Rumh said: I call you as witness that I have undertaken to perform my Hajjalong with my Umra (i.e. I am performing both of them as Qiran), and he offered the sacrifice of animals which he had bought at Qudaid. He then proceeded pronouncing Talbiya for both of them together until he reached Mecca, He circumambulated the House. and (ran) between al-Safa' and al-Marwa and made no addition to it. He neither sacrificed the animal, nor got his head shaved, nor got his hair clipped, nor did he make anything lawful which was unlawful (due to Ihram) until it was the Day of Sacrifice (10th of Dhu'l-Hijja). He then offered sacrifice, and got his hair cut, and saw that circumambulation of Hajj and 'Umra was complete with the first circumambulation. Ibn 'Umar said: This is how Allah's Messenger (may peace be upon him) had done.

Book 7 ,Number 2842:

    This hadith has been narrated from Ibn Umar through another chain of transmitters except with (this variation) that Allah's Apostle (may peace be upon him) was mentioned in the first part of the hadith ,.i.e. when it was said to him: They would bar you (from going) to the House. He said: In that, case I would do what Allah's Messenger (may peace be upon him) had done. He did not mention at the end of this hadith (i.e. these words): "This is how the Messenger of Allah (may peace be upon him) had done," as it Is narrated by al-Laith.

Chapter 24:IFRAD AND QIRAN (COMBINING HAJJ AND 'UMRA UNDER ONE IHRAM) DURING THE PERFORMANCE OF PILGRIMAGE

Book 7, Number 2843:

    Nafi' thus reported on the authority of Ibn Umar: We entered into the state of Ihram with Allah's Messenger (may peace be upon him) for Hajj Mufrad and in the narration of Ibn 'Aun (the words are): "Allah's Messenger (may peace be upon him) entered into the state of Ihram (with the intention) of Hajj Mufrad."

Book 7 ,Number 2844:

    Anas (Allah be pleased with him) said: I heard Allah's Apostle (way peace be upon him) pronouncing Talbiya for both Hajj and Umra. Bakr (one of the narrators) said: I narrated it to Ibn 'Umar, whereupon he said: He (the Holy Prophet) pronounced the Talbiya for Hajj alone. I met Anas and narrated to him the words of Ibn 'Umar, whereupon he said: You treat us not but only as children. I heard Allah's Messenger (may peace be upon him) pronouncing Talbiya both for 'Umra and Hajj.

Book 7 ,Number 2845:

    Bakr b. 'Abdullah reported: Anas (Allah be pleased with him) had narrated to us that he saw Allah's Apostle (may peace be upon him) combining Hajj and 'Umra. He (Bakr) said: I asked (about it) from Ibn 'Umar, whereupon he said: We entered into the state of Ihram for Hajj (only). I came to Anas and told him what Ibn Umar had said, whereupon he remarked: (You are treating us) as if we were children.

Chapter 25:WHAT IS ESSENTIAL FOR HIM WHO ENTERS INTO THE STATE OF IHRAM FOR HAJJ AND THEN COMES TO MECCA FOR CIRCUMAMBULATION AND RUNNING

Book 7, Number 2846:

    Wabara reported: While I was sitting in the company of Ibn 'Umar, a person came to him and said: Is it right for me to circumambulate the House before I come to stay (at 'Arafat)? Ibn 'Umar said: Yes. whereupon he said: Ibn Abbas, however, says: Do not circumambulate the House until you come to stay at 'Arafat. Thereupon Ibn 'Umar said: Allah's Messenger (may peace be upon him) Performed the Hajj and circumambulated the House before coming to stay (at 'Arafat). If you say the Truth, is it more rightful to follow the saying of the Prophet (may peace be upon him) or the words of Ibn Abbas?

Book 7 ,Number 2847:

    Wabara reported: A person asked Ibn Umar (Allah be pleased with him): May I circumambulate the House, whereas I have entered-into the state of Ihram for Hajj? Thereupon he said: What prevents you from doing it? He said: I saw the son of so and so showing disapproval of it, and you are dearer to us as compared with him. And we see that he is allured by the world, whereupon he said: Who amongst you and us is not allured by the world? And said (further) ':'We saw that Allah's Messenger (may peace be upon him) put on Ihram for Hajj and circumambulated the House and run between al Safa' and al-Marwa. And the way prescribed by Allah and that prescribed by His Apostle (may peace be upon him) deserve more to be followed than the way shown by so and so, if you speak the truth.

Book 7 ,Number 2848:

    Amr b. Dinar said: We asked Ibn Umar about a person who came for Umra and circumambulated the House, but he did not run between al-Safa' and al-Marwa, whether he is allowed to (put off Ihram) and have intercourse with his wife. He replied: Allah's Messenger (may peace be upon him) circumambulated the House seven times and offered two rak'ahs of prayer after staying (at 'Arafat), and ran between al-Safa and al-Marwa seven times. "Verily there is in Allah's Messenger a model pattern for you" (xxxill. 21).

Book 7 ,Number 2849:

    This hadith is narrated by another chain of transmitters.

Chapter 26:ONE WHO UNDERTAKES TO PERFORM 'UMRA IS NOT ALLOWED TO PUT OFF IHRAM BEFORF, SA'I AND THE PILGRIM AND THE (QIRAN) IS NOT ALLOWED TO PUT OFF IHRAM AT TAWAF QUDUM CIRCUMAMBULATION OF ARRIVAL)

Book 7, Number 2850:

    Muhammad b. 'Abd al-Rahman reported: A person from Iraq said to him to inquire from 'Urwa b. Zubair for him whether a person who puts on Ihram for Hajj is allowed to put it off or not as he circumambulates the House. And if he says: "No, it can't be put off," then tell him that there is a person who makes such an assertion. He (Muhammad b. 'Abd al-Rahman) then said: I asked him ( Urwa b. Zubair), where- upon he said: The person who has entered into the state of Ihram for Hajj cannot get out of it unless he has, completed the Hajj I (further) said (to him): (What) if a person makes that assertion? Thereupon he said : It is indeed unfortunate that he makes such an assertion. That person ('Iraqi) then met me and he asked me and I narrated to him (the reply of 'Urwa), whereupon he (the Iraqi) said: Tell him ('Urwa) that a person had informed him that Allah's Messenger (may peace be upon him) had done that; and why is it that Asma' and Zubair have done like this? He (Muhammad b. 'Abd al-Rahman) said: I went to him and made a mention of that to him, whereupon he ('Urwa) said: Who is he (the 'Iraqi) ? I said: I do not know, whereupon he said: What is the matter that he does not come to me himself and ask me? I suppose he is an 'Iraqi. I said: I do not know, whereupon he said: He has told a lie. Allah's Messenger (may peace be upon him) performed Hajj, and 'A'isha (Allah be pleased with her) has told me that the first thing with which he commenced (the rituals) when he arrived at Mecca was that he performed ablution and then circumambulated the Ka'ba. Then Abu Bakr performed Hajj and the first thing with which he commenced (the Hajj) as the circumambulation of the Ka'ba and nothing besides it. So did 'Umar. Then 'Uthman performed Hajj and I saw that the first thing with which he commenced the Hajj was the circumambulation of the Ka'ba and nothing besides it. Then Mu'awiya and Abdullah b. 'Umar did that. Then I performed Hajj with my father Zubair b. al-'Awwam, and the first thing with which he commenced (Hajj) was the circumambulation of the House. He then did nothing besides it. I then saw the emigrants (Muhajirin) and the helpers (Ansar) doing like this and nothing besides it. And the last one whom I saw doing like this was Ibn 'Umar. And he did not break it (the Hajj) after performing 'Umra. And Ibn 'Umar is with them. Why don't they ask him (to testify it)? And none amongst those who had passed away commenced (the rituals of Hajj) but by circumambulating the Ka'ba on their (first arrival) and they did not put off Ihram (without completing the Hajj), and I saw my mother and my aunt commencing (their Hajj) with the circumambulation of the House, and they did not put off Ihram. My mother informed me that she came and her sister, and Zubair and so and so for 'Umra, and when they had kissed the corner (the Black Stone, after Sa'i and circumambulation), they put off Ihram. And he (the 'Iraqi) has told a lie in this matter.

Book 7 ,Number 2851:

    Asma bint Abu Bakr (Allah be pleased with both of them) reported: We set out (to Mecca) in a state of Ihram. Allah's Messenger (may peace be upon him) said: He who has the sacrificial animal with him should remain in the state of Ihram, but he who has not the sacrificial animal with him should put off Ihram. As I had not the sacrificial animal with me, I put off Ihram. And since Zubair (her husband)- had the sacrificial animal with him, he did not put off Ihram. She (Asma) said: I put on my clothes and then went out and sat by Zabair, whereupon he said: Go away from me, whereupon I said: Do you fear that I would jump upon you?

Book 7 ,Number 2852:

    Asma bint Abu Bakr (Allah be pleased with th(m) said: We came for Hajj in the state of Ihram with Allah's Messenger (may peace be upon him). The rest of the hadith is the same except (for the words) that he (Zubair) said: Keep away from me, keep away from me, whereupon I said: Do you fear that I will jump upon you?

Book 7 ,Number 2853:

    Abdullah, the freed slave of Asma' bint Abu Bakr (Allah be pleased with them), narrated that he used to hear Asma,' whenever she passed by Hajun, saying (these words): "May there be peace and blessing of Allah upon His Messenger." We used to stay here along with him with light burdens. Few were our rides, and small were our provisions. I performed 'Umra and so did my sister 'A'isha, and Zubair and so and so. And as we touched the House (performed circumambulation and Sa'i) we put off Ihram, and then again put on Ihram in the afternoon for Hajj. Harun (one of the narrators) in one of the narrations said: The freed slave of Asma' and he did not mention 'Abdullah.

Chapter 27:CONCERNING TAMATTU' IN HAJJ

Book 7, Number 2854:

    Muslim al-Qurri reported: I asked Ibn Abbas (Allah be pleased with them) about Tamattu' in Hajj and he permitted it, whereas Ibn Zubair had forbidden it. He (Ibn 'Abbas) said: This is the mother of Ibn Zubair who states that Allah's Messenger (may peace be upon him) had permitted it, so you better go to her and ask her about it. He (Muslim al-Qurri said): So we went to her and she was a bulky blind lady and she said: Verily Allah's Messenger (may peace be upon him) permitted it.

Book 7 ,Number 2855:

    This hadith has been narrated on the authority of Shu'ba with the same chain of transmitters, but with a slight variation of words.

Book 7 ,Number 2856:

    Muslim al-Qurri heardlbn 'Abbas (Allah be pleased with them) saying that Allah's Apostle (may peace be upon him) entered into the state of Ihram for Umra and his Companions for Hajj. Neither Allah's Apostle (may peace be upon him) nor those among his Companions who had brought sacrificial animals with them put off Ihram, whereas the rest (of the pilgrims) did so. Talha b. Ubaidullah was one of those who had brought the sacrificial animals along with them so he did not put off Ihram.

Book 7 ,Number 2857:

    This hadith has been narrated on the authority of Shu'ba with the same chain of transmitters but with this variation (of words): "Talha and another person also were among those who had not brought the sacrificial animals with them and so they put off Ihram."

Chapter 28:PERMISSIBILITY OF 'UMRA DURING THE MONTHS OF HAJJ

Book 7, Number 2858:

    Ibn Abbas (Allah be pleased with them) reported that they (the Arabs of pre-Islamic days) looked upon Umra during the months of Hajj as the greatest of sins on the earth. So they intercalated the month of Muharram for Safar and said: When the backs of their camels would become all right and traces (if the pilgrims) would be effaced (from the paths) and the month of Safar would be over, then Umra would be permissible for one who wants to perform it. When Allah's Apostle (may peace be upon him) and his Companions came in the state of Ihram for performing Hajj on the fourth (of Dhu'l-Hijja) he (Allah's Apostle) commanded them to change their state of Ihram (from Hajj) to that of 'Umra. It was something inconceivable for them. So they said: Messenger of Allah, is it a complete freedom (of the obligation) of Ihram? Thereupon he said: It is a complete freedom (from Ihram).

Book 7 ,Number 2859:

    Ibn 'Abbas (Allah be pleased with them)'is reported to have said: The Messenger of Allah (may peace be upon him) put on Ihigm for Hajj. When four days of Dhu'l-Hijja were over, he led the dawn prayer, and when the prayer was complete, he said: He who wants to change it to Umra may do so.

Book 7 ,Number 2860:

    Rauh and Yahya b. Kathir narrated as Na5r reported that the Messenger of Allah (may peace be upon him) entered into the state of Ihram for Hajj. And in the narration of Abu Shihab (the words are): We went out with the Messenger of Allah (may peace be upon him) pronouncing Talbiya for Hajj, And in an the ahadith (narrated in this connection the words are): He led the morning prayer at al-Batha', except al- jahdami who did not make mention of it.

Book 7 ,Number 2861:

    Ibn 'Abbas (Allah be pleased with them) reported: Allah's Messenger (may peace be upon him) came along with his Companions when four days had passed out of ten days (of Dhu'l-Hijja) and they were pronouncing Talbiya for Hajj, and he (the Holy Prophet) commanded them to change (this Ihram) into that of 'Umra.

Book 7 ,Number 2862:

    Ibn Abbas (Allah be pleased with them) reported that Allah's Messenger (may peace be upon him) observed the morning prayer at Dhu Tawa (a valley near Mecca) and arrived (in Mecca) when four days of Dhul-Hijja had passed and he commanded his Companions that they should change their Ihram (of Hajj) to that of Umra, except those who had brought sacrificial animals with them.

Book 7 ,Number 2863:

    Ibn 'Abbas (Allah be pleased with them) reported Allah's Messenger (may peace be upon him) as saying: This is the 'Umra of which we have taken advantage. So he who has not the sacrificial animal with him should get out of the state of Ihram completely, for 'Umra has been incorporated in Hajj until the Day of Resurrection,

Book 7 ,Number 2864:

    Abu Jam at al-Dubu'i reported: I performed Tamattu' but the people dis- couraged me to do so. I came to Ibn 'Abbas and asked him about it. He ordered me to do so. I came to the House (Ka'ba) and slept. I saw a visitant in the dream who said: 'Umra is acceptable and so is the Hajj performed for God's sake. I came to Ibn Abbas and informed him about that Which I saw in the dream whereupon he said: Allah is the Greatest, Allah is the Greatest This is the Sunnah of Abu'l-Qasim (the Holy Pro- phet) (may peace be upon him).

Chapter 29: GARLANDING THE SACRIFICIAL ANIMALS, AND MARKING THEM

Book 7, Number 2865:

    Ibn 'Abbas (Allah be pleased with them) reported that Allah's Messenger (may peace be upon him) observed the Zuhr prayer at Dhu'l-Hulaifa; then called for his she-camel and marked it on the right side of its bump, removed the blood from it, and tied two sandals round its neck. He then mounted his camel, and when it brought him up to al-Baida', he pronounced Talbiya for the Pilgrimage.

Book 7 ,Number 2866:

    This hadith has been narrated on the authority of Qatada with the same chain of transmitters but with this variation (of words): "When Allah's Apostle (may peace be upon him) came to Dhu'l-Hulaifa" and he made no mention (of the fact) that he led the Zuhr prayer.

Chapter 30:SAYING OF PEOPLE TO IBN 'ABBAS: WHAT IS THIS RELIGIOUS VERDICT OF YOURS THAT HAS ENGAGED THE ATTENTION OF THE PEOPLE?

Book 7, Number 2867:

    Abu Hassan al-A'raj reported that a person from Bani Hujaim said to Ibn 'Abbas (Allah be pleased with them): What is this religious verdict of yours which has engaged the attention of the people or which has become a matter of dispute among them that he who circumambulated the House can be free from Ihram? Thereupon he said: That is the Sunnah of your Apostle (may peace be upon him), even though you may not approve of it.

Book 7 ,Number 2868:

    Abu Hassan reported: It was said to Ibn 'Abbas (Allah be pleased with them) that this affair had engaged the attention of the people that he who circumambu- lates the House was permitted to circumambulate for Umra (even though he was in a state of Ihram for Hajj), whereupon he said: That is the Sunnah of your Apostle (may peace be upon him), even though you may not approve of it.

Book 7 ,Number 2869:

    Ata' said: Ibn 'Abbas (Allah be pleased with them) used to say that a pilgrim or non-pilgrim (one performing 'Umar) who circumambulates the House is free from the responsibility of Ihram. I (Ibn Juraij, one of the narrators) said to 'Ata': On what authority does he (Ibn Abbas) say this? He said: On the authority uf Allah's words: "Then their place of sacrifice is the Ancient House" (al-Qur'an, xxii. 33). I said: It concerns the time after staying at 'Arafat, whereupon he said: Ibn 'Abbas (Allah be pleased with them) had stated (that the place of sacrifice is the Ancient House); it way be after staying at 'Arafat or before (staying there). And he (Ibn Abbas) made this deduction I from the command of Allah's Apostle (may peace be upon him) when he had ordered to put off Ihram on the occasion of the Farewell Pilgrimage.

Chapter 31: CLIPPING OF HAIR IN 'UMRA

Book 7, Number 2870:

    Ibn Abbas reported that Mu'awiya had said to them: Do you know that I clipped some hair from the head of Allah's Messenger (may peace be upon him) at al- Marwa with the help of a clipper? I said: I do not know it except as it verdict against you.

Book 7 ,Number 2871:

    Ibn Abbis (Allah be pleased with him) reported that Mu'awiya b. Abu Safyin had told him: I clipped the hair (from the head of) Allah's Messenger (may peace he upon him) with a clipper while he was at al-Marwa, or I saw him getting his hair clipped with a clipper as he was at al-Marwa.1722

Chapter 32: TALBIYA OF THE APOSTLE, (MAY PEACE BE UPON HIM) AND HIS SACRIFICE

Book 7, Number 2872:

    Abu Sa'id (Allah be pleased with him) reported: We went out with Allah's messenger (may peace be upon him) pronouncing loudly the Talbiya for Hajj When we came to Mecca, he commanded us that we should change this (Ibrim for Hajj) to that of Umra except one who had brought the sacrificial animal with him. When it was the day of Tarwiya (8th of Dhu'l-Hijja) and we went to Mini, we (again) pronounced Talbiya for Hajj.

Book 7 ,Number 2873:

    jibir and Abil Salld al-Khudri (Allah be pleased with them) reported: We went with Allah's Apostle (may peace be upon him) and we were pronouncing Talbiya for Hajj loudly.

Book 7 ,Number 2874:

    Abd Nadra reported: While I was in the company of Jibir, a person came and said: There is difference of opinion amomg Ibn Abbas and Ibn Zubair about two Mut'as (benefits, Tamattul in Hajj and temporary marriage with women), whereupon jibir said: We have been doing this during the lifetime of Allah's Messenger (way peace be upon him), and then 'Umar forbade us to do so, and we never resorted to them.

Book 7 ,Number 2875:

    Anas (Allah be pleased with him) reported that 'All (Allah be pleased with him) came from the Yemen, and the Apostle (may peace be upon him) said: With (what intention) have you put on Ihram? He said: I have put on Ibram in accordance with the intention with which Allah's Apostle (may peace be upon him) has put on Ibram, whereupon he (the Holy Prophet) said: Had there not been the sacrificial animals with me, I would have put off Ibram (after performing 'Umra). This hadith is narrated by Salim b. Hayyin with the same chain of transmitters, but with a slight variation of words.

Book 7 ,Number 2876:

    Anas (Allah be pleased with him) reported: I heard Allah's Messenger (may peace be upon him) pronouncing Talbiya for both simultaneously, Talbiya for 'Umra and Hajj. Talbiya for Uwra and Hajj (he performed both Hajj and Umra as a Qarin). In another version words are: I heard Allah's Messenger (may peace be upon him) pronouncing Talbiya for Umra and Hajj (simultaneously)."

Book 7 ,Number 2877:

    Hanzala al-Aslami reported: I heard Abu Huraira (Allah be pleased with him) as narrating from Allah's Apostle (may peace be upon him) who said: By Him in Whose Hand is my life. Ibn Maryam (Jesus Christ) would certainly pronounce Talbiya for Hajj or for Umra or for both (simultaneously as a Qiran) In the valley of Rauha

Book 7 ,Number 2878:

    Hanzala b. 'Ali al-Aslaml reported that he had heard Abu Huraira (Allah be pleased with him) as saying that Allah's Messenger (may peace be upon him) bed said: By Him In Whose Hand is my life; the rest of the hadith is the same.

Chapter 33: CONCERNING THE UMRAS PERFORMED BY ALLAH'S APOSTLE (MAY PEACE BE UPON HIM) AND THEIR RESPECTIVE TIMES

Book 7, Number 2879:

    Qatida saia. that Anas (Allah be pleased with him) had informed him that Allah's Messenger (may peace be upon him) performed four 'Umras, all during the month of Dhu'l-Qa'da except the one he performed along with Hajj (and these are) the Umra that he performed from al-Hudaibiya or during the time of (the truce of) Hudaibiya in the month of Dhu'l-Qa'da then the Umra of the next year in the month of Dhu'l-Qa'da, then the Umra for which b'e had started from ji'rana, the place where he distributed the spoils of (the battle of) Hunain in the month of Dhu'l-Qa'da, and then the 'Umra that he performed along with his Hajj (on the occasion of the Farewell Pilgrimage).

Book 7 ,Number 2880:

    Qatida said: I asked Anas (Allah be pleased with him) as to bow many Pilgrimages had been performed by Allah's Messenger (may peace be upon him), and he replied: One Hajj and four 'Umras were performed by him. The rest of the badith is the same.

Book 7 ,Number 2881:

    Abu lshaq said: I asked Zaid b. Arqam: In how many military expeditions have you participated with Allah's Messenger (may peace be upon him)? He said: In seventeen (expeditions). He (Abu Ishaq) said: Zaid b. Arqam reported to me that Allah's Messenger (may peace be upon him) had led nineteen expeditions. And he performed Hajj only once after Migration, and that was the Farewell Pilgrimage. Abu Ishaq also said: The second (Hajj) he performed at Mecca (before his Migration to Medina)

Book 7 ,Number 2882:

    'Ataa reported that 'Urwa b. Zubair (Allah be pleased with him) had informed him (this): I and Ibn 'Umar were reclining against the (wall) of the apartment of A'isha and we were listening to the sound produced by the brushing of her teeth. I said Abu Abd al-Rahman (the kunya of 'Abdullah b. Umar), did Allah's Apostle (may peace be upon him) perform 'Umra in the month of Rijab? He said: Yes. I said to 'A'isha: Mother, are you listening to what Abu Abd al-Rabman is saying? She said: What is he Saying? I said: He is saying that Allah's Apostle (may peace be upon him) performed 'Umra during the month of Rajab, whereupon she said: May Allah grant pardon to Abu Abd al-Rahman I By my life he (the Holy Prophet) did not perform 'Umra during the month of Rajab. And never was there an Umra performed by him (the Holy Prophet) in which he ('Abdullah b. 'Umar) did not join him. Ibn 'Umar heard this and said nothing to affirm It or to deny it, but kept quiet.

Book 7 ,Number 2883:

    Mujihid reported: I and 'Urwa h Zubair entered the mosque and there found 'Abdullah b. 'Umar sitting near the apartment of IA'isha and the people were observing the forenood"prayer (when the sun bad sufficiently risen). We asked him about their prayer, and he said: It is bid'a (innovation), Urwa said to him: Abd al-Rahman, how many,'Umras had Allah's Messenger (may peace be upon him) performed? He said: Four Umras, one he performed during the month of Rajab. We were reluctant either to belie him or reject him. We heard the noise of brushing of her teeth by 'A'isha in her apartment. 'Urwa said: Mother of the Faithful, are you not hearing what Abfi 'Abd al-Rahman is saying? She said: What is he saying? Thereupon he ('Urwa) said: He (Ibn 'Umar) states that Allah's Apostle (may peace be upon him) performed four Umras and one of them during the month of Rajab. Thereupon she remarked: May Allah have merely upon Abu 'Abd al-Rahman. Never did Allah's Messenger (may peace be upon him) perform 'Umra in which he did not accompany him, and he (Allah's Apostle) never performed 'Umra during the month of Rajab.

Chapter 34:EXCELLENCE OF PERFORMING'UMRA IN THE MONTH OF RAMADAN

Book 7, Number 2884:

    Ataa reported: I heard Ibn Abbas (Allah be pleased with him) narrating to us that Allah's Messenger (may peace be upon him) said to a woman of the Ansar (Ibn Abbas had mentioned her name but I have forgotten it):'What has prevented you that you do not perform Hajj along with us? She said: We have only two camels for carrying water. One of the camels has been taken by my husband and my son for performing Hajj and one has been left for us for carrying water, whereupon he (the Holy Prophet) said: So when the month of Ramadan come, perform Umra, for'Umra in this (month) is equal to Hajj (in reward).

Book 7 ,Number 2885:

    Ibn Abbis reported that Allah's Apostle (may peace be upon him) said to a woman of the Ansar who was called Umm Sinan: What has prevented you that you did not perform Hajj with us? She said: The father of so and so (i.e. her husband) had only two camels. One of them had been taken away by him (my busbard) and his son for Hajj, whereas the other one is used by our boy to carry water. Upon this he (the Holy Prophet) said: Umra during the month of Rawadin would suffice for Hajj or Hajj along with me.

Chapter 35: EXCELLENCE OF ENTRY INTO MECCA FROM THE UPPER SIDE AND EXIT FROM IT FROM THE LOWER SIDE, AND EN FERING THE TOWN FROM THE SIDE OTHER THAN THAT FROM WHICH. ONE GETS OUT

Book 7, Number 2886:

    Ibn 'Umar reported that Allah's Messenger (may peace be upon him) used to come out (of Medina) by way of al-Shajarah and entered it by the way of al-Mu'arras and whenever he entered Mecca, he entered it from the upper side and went out of it from the lower side. This hadith has been narrated on the authority of 'Ubaidullah with the same chain of transmitters and in the narration transmitted by Zubair (it is mentioned) that the upper side is that'which is at al-Batha

Book 7 ,Number 2887:

    'A'isha (Allah be pleased with her) reported that when Allah's Messenger may peace be upon him) came to Mecca he entered from its upper side and came out from its lower side.

Book 7 ,Number 2888:

    A'isha (Allah be pleased with her) reported that Allah's Messenger (may peace be upon him) entered Mecca during the year of Victory from Kada I.e. from the upper side. Hisham said.. My father entered It from both the Fides, but generally he entered from Kada.

Chapter 36: EXCELLENCE OF SPENDING THE NIGHT AT DHI TUWA FOR ENTERING MECCA (FOR H.Ajj) AND GETTING l@TO IT AFTER A BATH AND ENTERING DURING THE DAY

Book 7, Number 2889:

    Ibn Umar (Allah be pleased with him) reported that Allah's Messenger may peace be upon him) spent the night at Dhi Tuwa till it was dawn and then entered Mecca. 'Abdullah (b. 'Umar) himself did like it. And in the narration transmitted by Ibn Sa'ld (the words are): Until he obrerved the dawn prayer. Yahya (another narrator) said: Until it was dawn.

Book 7 ,Number 2890:

    Nafi' reported that Ibn Umar (Allah be pleased with them) did not enter Mecca without spending the night at Dhi Tawu until it was dawn, when he took a bath, and then entered Mecca in the morning, and made a mention that Allah's Apostle (may peace be upon him) did that.

Book 7 ,Number 2891:

    Abdullah (b. 'Umar) reported that whenever Allah's Messenger (may peace be upon him) entered Mecca, he got down at Dhi Tuwa and spend the night there until he observed the dawn prayer. And Allah's Messenger (may peace be upon him) observed this prayer on a rough hillock, and not in the mosque which had been then built there, but to the lower side of it (the mosque) on a hillock.

Book 7 ,Number 2892:

    Nafi' reported that Abdullah (b. 'Umar) informed him that Allah's Messenger (may peace be upon him) turned his face to the two hillocks which intervened between him and the long mountain by the side of the Ka'ba, and the mosque which had been built there was thus on the left of the hillock. Allah's Messenger's (may peace be upon him) place of prayer was lower than the black hillock, at a distance of ten cubits or near it. He (may peace be upon him) would then observe prayer facing these two hillocks of the long mountain that is intervening between you and the Ka'ba.

Chapter 37: EXCELLENCE OF WALKING AT A QUICK PACE IN TAWAF IN 'UMRA AND ON THE OCCASION OF FIRST TAWAF IN HAJJ

Book 7, Number 2893:

    Nafi' reported on the authority of Ibn Umar (Allah be pleased with them) that when Allah's Messenger (may peace be upon him) circumambulated the House, while observing the first circomambulation, he walked swiftly in three (circuits), and walked in four circuits, and ran in the bottom of the valley as he moved between al-Safa and al-Marwa. Ibn 'Umar (Allah be pleased with them) also used to do like this.

Book 7 ,Number 2894:

    Ibn'Umar(Allah be pleased with them) reported that when Allah's messenger (may peace be upon him) circumambulated in Hajj and Umra he walked swiftly in the first three circuit about the House, and then walked in four circuits, and then observed two rak'ahs of prayer, and then ran between al-Safa and al-Marwa.

Book 7 ,Number 2895:

    Abdullah b. 'Umar (Allah be pleased with them) reported: I saw that when Allah's Messenger (may peace be upon him) came to Mecca and kissed the Black Stone, (in the first circurnambulation) he moved quickly in three circuits out of seven circuits.

Book 7 ,Number 2896:

    Nafi' reported on the authority of Ibn Umar (Allah be pleased with them) that Allaws Messenger (may peace be upon him) walked swiftly from stone to stone in three circuits and walked (normally) in four.

Book 7 ,Number 2897:

    Nafi' reported that Ibn Umar (Allah he pleased with them) walked swiftly from stone to stone, and stated that Allah's Messenger (may peace be upon him) did like this.

Book 7 ,Number 2898:

    jabir b. Abdullah (Allah be pleased with them) reported: I saw Allah's Messenger (may peace be upon him) walking swiftly from the Black Stone till he completed three circuits up to it.

Book 7 ,Number 2899:

    Jabir b. "Abdullah (Allah be pleased with them) reported that Allah's Messenger (may peace be upon him) walked swiftly in three circuitsfrom stone to stone.

Book 7 ,Number 2900:

    Abu Tufail reported: I said to Ibn Abbas (Allah be pleased with them): Do you think that walking swiftly round the House in three circuits, and just walking in four circuits is the Sunnah (of the Holy Prophet), for your people say that it is Sunnah? Thereupon he (Ibn 'Abbas) said: They have told the truth and the lie (too). I said: What do your words "They have told the truth and the lie (too)" imply? Thereupon he said: Allah's Messenger (may peace be upon him) came to Mecca and the polytheists said that Mubammad and his Companions had emaciated and would, therefore, be unable to circumambulate the House; and they felt jealous of him (the Holy Prophet). (It was due to this) that Allah's Messenger (may peace be upon him) commanded them to walk swiftly in three (circuits) and walk (normally) in four. I said to him: Inform me if it is Sunnah to observe Tawaf between al-Safa and al-Marwa while riding, for your people look upon it as Sunnah. He (Ibn Abbas) said: They have told the truth and the lie too. I said: What do your words "They have told the truth and the lie tool, iMply? He said: as Allah's Messenger (may peace be upon him) had come to Mecca, there was such a large gathering of people around him that even the virgins had come out of their houses (to catch a glimpse of his face). and they were saying: He is Muhammad; He is Muhammad. Allah's Messenger (may peace be upon him) (was so gentle and kind) that the people were not beaten back (to make way) in front of him. When there was a; throng (of people) around him, he rode (the she-camel) but walking and trotting is, however, better.

Book 7 ,Number 2901:

    This hadith has been narrated on the authority of jurairi with the same chain of transmitters but with a slight variation of words (and this is) that he (the narrator) did not say: "They felt jealous of him. but said: The people of Mecca, were jealous people."

Book 7 ,Number 2902:

    Abu Tufail reported: I said to Ibn 'Abbas (Allah be pleased with them): People are of the view that Allah's Messenger (may peace be upon him) moved quickly round the House and between al-Safa and al-Marwa, and (thus) it is Sunnah. He said: They told the truth and they told the lie.

Book 7 ,Number 2903:

    Abu Tufail reported; I. said to Ibn 'Abbas (Allah be pleased with them): I think that I saw Allah's Messenger (may peace be upon him). He (Ibn 'Abbis) said' Give a description of him to me. I said: I saw him near al-Marwa on the back of a she- camel, and people had thronged around him. Thereupon Ibn'Abbis said: It was Allah's Messenger (may peace be upon him) for they (the Compainions of the Holy Prophet) were neither pushed aside from him, nor were they turned away.

Book 7 ,Number 2904:

    Ibn 'Abbas (At lab be pleased with them) reported: Allah's Messenger (may peace be upon him) and his Companions came to Mecca and the fever in Medina had weakened them. Thereupon the polytheists (of Mecca) said: There would come to you a people whom the fever has made weak and they have suffered severely from it. They sat in Hatim. Thereupon Allah's Apostle (may peace be upon him) commanded them to walk quickly ift three circuits and walk (in four) between the two corners. so that the polytheists should. see their endurance. The polytheists then said (to one anothery You were under the impression that fever had emaciated them. whereas they are stronger than so and so. Ibn Abbas said: He (the Holy Prophet) did not command them (the Muslims) to walk quickly in all the circuits out of kindness to them.

Book 7 ,Number 2905:

    Ibn Abbas (Allah be pleased with them) reported: Allah.'s Messenger (peace be upon him) observed Sa'i and walked quickly round the House with a view to showing his strength to the polytheists.

Chapter 38:EXCELLENCE OF TOUCHING THE TWO CORNERS (RUKNAIN AL-YAMANITYAIN) IN 'FAWAF

Book 7, Number 2906:

    Ahdullah b. Umar (reported) that he had not seen Allah's Messenger (way peace he upon him) touching anything in the House, except the two Yamani corners.

Book 7 ,Number 2907:

    Salim reported on the authority of his father (Allah he pleased with him) that Allah'& Messenger (tinny peace be upon him) did not touch any of the corners of the House. except that of Black Corner (in which the Black Stone is embedded and that (portion) near it, towards the houses of the tribe of jumuhi.

Book 7 ,Number 2908:

    Nafi' reported on the authority of 'Abdullah (Allah be pleased with him) that Allah's Messenger (way peace be upon him) did not touch but the Stone and the Yamani corner.

Book 7 ,Number 2909:

    Ibn 'Umar (Allah be pleased with them) reported: I have not abandoned touching of Yamani corners (and kissing of) the Stone since I saw Allah's messneger (may peace be upon him) touching them both In hardship and ease.

Book 7 ,Number 2910:

    NAfi' (Allah be pleased with him) reported: I saw'lbn 'Umar (Allah be pleased with them) touching the Stone with his hand and then kissing his hand. and he said: I have never abandoned it since I saw Allah's Messenger (way peace be upon him) doing It.

Book 7 ,Number 2911:

    Ibn 'Abbas (Allah be pleased with them) is reported to have said that he did not see Allah's Messenger (may peace be upon him) touching other than the Yamani corners.

Chapter 39: EXCEI,LENCE OF KISSING THE BLACK STONE WHILE CIRCUMAMBULATING

Book 7, Number 2912:

    Salim narrated on the authority of his father (Allah be pleased with him) that 'Umar b. al-Khattib (Allah be pleased with him) kissed (the Black Stone) and then said: By Allah, I know that you are a stone and if I were not to see Allah's Messenger (may peace be upon him) kissing you, I would not have kissed you. Harun said in his narration: A hadith like this has been transmitted to me by Zaid b. Aslam on the authority of his father Aslam.

Book 7 ,Number 2913:

    Ibn 'Umar (Allah be pleased with them) reported that Umar (Allah be pleased with him) kissed the Stone and said: I am kissing you, whereas I know that you are a stone, but I saw Allah's Messenger (may peace be upon him) kissing you (that Is why I kiss you).

Book 7 ,Number 2914:

    Abdullah b. Sarjis reported: I saw the bald one, i.e. 'Umar b. Khattib (Allah be pleased with him). kissing the Stone and saying: By Allah. I am kissing with full consciousness of the fact that you are a stone and that you can neither do any harm nor good; and if I had not seen Allah's Messenger (may peace be upon him) kissing you. I would not have kissed you. The rest of thebadith is the same.

Book 7 ,Number 2915:

    Abis b. Rabi'a reported: I saw 'Umar (Allah'be pleased with him) kissing the Stone and saying: I am kissing you and I know that you are a stone. And if I had not seen Allah's Messenger (may peace be upon him) kissing you, I would not have kissed you.

Book 7 ,Number 2916:

    Suwaid b. Ghafala reported: I saw Umar (Allah be pleased with him) kissing the Stone and clinging to it and saying: 1 saw Allah's Messenger (may peace be upon him) having great love for you. This hadith has been narrated on the authority of Sufyin with the same chain of transmitters (and the words are): "That he ('Umar) said: But I saw Abu'l-Qasim (way peace be upon him) having great love for you." And he did not'mention about clinging to it.

Chapter 40:IT IS PERMISSIBLE TO OBSERVE TAWAF ON THE BACK OF A CAMEL OR ANY OTHER RIDING BEAST, AND TO TOUCH THE BLACK STONE WITH A STICK

Book 7, Number 2917:

    Ibn 'Abbas (Allah be pleased with him) reported that Allah's Messenger (may peace be upon him) circumambulated the House on the occasion of the Farewell Pilgrimage on the back of his camel and touched the Corner (of Black Stone) with a stick.

Book 7 ,Number 2918:

    Jabir (Allah be pleased with him) reported that Allah's Messenger (may peace be upon him) circumambulated the House on the back of his riding camel on the occasion of the Farewell Pilgrimage and touched the Stone with his stick so that the people should see him, and he should be conspicuous, and they should be able to ask him (questions pertaining to religion) as the people had crowded round him.

Book 7 ,Number 2919:

    jabir b. 'Abdullah (Allah be pleased with them) reported that Allah's Apostle (may peace be upon him) circumambulated the House (and ran) between al-Safa and al-Marwa on the back of his she-camel, at the occasion of the Farewell Pilgrimage. so that the people should see him and he should be conspicuous, and they should be able to ask him (questions pertaining to religion), and the people had crowded round him. In the hadith transmitted on the authority of Ibn Khashram no mention Is made of: "So that they should ask him."

Book 7 ,Number 2920:

    'A'isha (Allah be pleased with her) reported that Allah's Apostle (may peace be upon him) circumambulated the Ka'ba on the back of his camel on the occasion of the Farewell Pilgrimage and touched the corner and he did not like that the people should be pushed away from him.

Book 7 ,Number 2921:

    Abu Tufail reported: I saw Allah's Messenger (may peace be upon him) ciscumambulati'hg the House. and touching the corner with a stick that he had with him, and then kissing the stick.

Book 7 ,Number 2922:

    Umm Salama reported: I made a complaint to Allah's Messenger (may peace be upon him) of my ailment, whereupon be said: Circumambulate behind the people while riding. She said: So I circumambulated and Allah's Messenger (may peace be upon him) was at that time praying towards the side of the House and he was reciting al-Tur and a Book Inscribed (i.e. Sura Iii. of the Qur'un).

Chapter 41: SA'I BETWEEN AL-SAFA' AND AL-MARWA IS AN ESSENTIAL RITE OF HAJJ AND HAJJ IS NOT COMPLETE WITHOUT IT

Book 7, Number 2923:

    Hisham b. 'Urwa reported on the authority of his father who narrated from 'A'isha. He said to 'A'isha: I think if a person does not run between al- Safa' and al-Marwa, It does not do any harm to him (so far as Hajj is concerned). She said: Why (do you think so)? I said: For Allah says: "Verily al-Safa' and al-Marwa are among the Signs of Allah" (ii. 158) (to the end of the verse), whereupon she said: Allah does not complete the Hajj of a person or his Umra if he does not observe Sa'i between al-Safa' and al-marwa; and if it were so as you state, then (the wording would have been(fala janah an la yatufu biha)["There is no harm for him if he does not circumambulate between them'].Do you know in what context (this verse was revealed)? (It was revealed in this context) that the Ansar in the Days of Ignorance pronounced the Talbiya for two idols. (fixedl on the bank of the river which were called Isaf and Na'ila. The people went there, and then circumambulated between al-Safa' and al-Marwa and then got their heads shaved. With the advent of Islam they (the Muslims) did not like to circumambulate between them as they used to do during the Days of Ignorance. It was on account of this that Allah. the Exalted and Majestic, revealed: "Verily al-Safe and al-Marwa are among the Signs of Allah" to the end of the verse.She said: Then people began to observe Sa'i.

Book 7 ,Number 2924:

    Hisham b. 'Urwa narrated on the authority of his father who reported: I said to 'A'isha: I do not see any harm to me if I do not circumambulate betweez al-Safa' and al-Marwa. She said: On what ground do you say so? (I said:) Since Allah, the Exalted and Majestic, says: "Verily al-Safa' and al-Marwa are among the Signs of Allah." It (your assertion) were (correct), it would have been said like this: "There is no harm for him, that he should not circumambulate between them." It (this verse) has been revealed about the people of Ansar. Whenever they pronounced the Talbiya, they pronounced it in the name of al-Manat during the Days of Ignorance; so they (thought) that it was not permissible for them (for the Muslims) to circumambulate between and al-Marwa. When they (the Muslims) came with Allah's Apostle (may peace he upon him) for Hajj, they mentioned it to him. So Allah, the Exalted and Majestic, revealed this verse. By my life, Allah will not complete the Hajj of one who has not circumambulated between al-Safa and al-Marwa.

Book 7 ,Number 2925:

    'Urwa b. Zabair reported: I said to 'A'isha, the wife of Allah's Apostle (may peace be upon him): I do not see any (fault) in one who does not circumambl"te between al-Safa' and al-Marwa, and I do not mind if I do not circumambulate between them, whereupon she said: O, the son of my sister, what you say is wrong. Allah's Messenger (may peace be upon him) observed Sa'i and so did the Muslims. So it is a Sunnah (of the Prophet). And it was a common practice (with the pagan Arabs) that those who pronounced Talbiya for the wretched al-Manat, situated at Mushalla, did not observe Sa'i between al-Safa' and al-Marwa. With the advent of Islam, we asked Allah's Apostle (may peace be upon him) about this practice, and (it was on this occasion) that Allah, the Exalted and Majestic, revealed this verse: "Verily al-Safa' and al-Marwa are among the Signs of Allah"; so he who performed Hajj or 'Umra it is no sin on him if he circumambulates them. And if it were as you state, (then the wording would have been): "There is no harm for him, that he should not circumambulate round them." Zuhri said: I made a mention of that to Abu Bakr b. 'Abd al- Rahman b. al-Harith b. Hisham; he was impressed by that and said: This is what is called knowledge. And I have heard many a scholar saying: Many of the Arabs who did not circumambulate between al-Safa' and al-Marwa caid: Our circumambulation between these two hills is an act of ignorance; whereas others among the Ansar said: We have been commanded to circumambulate the House, and not Commanded to run between al-Safa' and al-Marwa. So Allah, the Exalted and Majestic, revealed thia verse: "Verily al-Safa' and al-Marwa are among the Signs of Allah." Abu Bakr b. 'Abd al-Rahman said: I think that this (verse) has been revealed for such and such (persons).

Book 7 ,Number 2926:

    'Urwa b. Zubair reported: I asked 'A'isha (Allah be pleased with her); the rest of the hadith is the same. And in this hadith (these words are also found): "When they (the Companions of the Holy Prophet) asked Allah's Messenger (may peace be upon him) about this, they said: Messenger of Allah, we felt reluctant to circumambulate between al-Safa' and al-Marwa. Then Allah, the Exalted and Majestic, revealed this verse: "Verily al-Safa' and al-Marwa are among the Signs of. Allah so he who perform Hajj or Umra it is no sin on him if he should circumambulate between them. 'A'isha (Allah be pleased with her) said: Allah's Messenger (may peace be upon him) laid down this Sa'i between them as Sunnah (of the Holy Prophet). So it is not advisable for anyone to abandon this Sa'i between them.

Book 7 ,Number 2927:

    'Urwa b. Zabair narrated on the authority of 'A'isha (Allah be pleased with her) who informed him that the Ansar and the people of the tribe of Ghassan before embracing Islam pronounced Talbiya for Manat, and so they avoided circumambulating' between al-Safa' and al-Marwa, and it was a common practice with their forefather, that he who put on Ihram for Manat did not circumambulate between al-Safa' and al-Marwa. And when they embraced Islam, they asked Allah's Messenger (may peace be upon him) about it, and then Allah, the Exalted and Majestic, revealed this verse: "Verily al-Safa' and al-Marwa are among the Signs of Allah"; so he who performs Hajj or Umra, for him there is no harm if he should circumambulate between them, and he who does good spontaneously-surely Allah is Bountiful in rewarding and Knowing.

Book 7 ,Number 2928:

    Anas (Allah be pleased with him) reported that the Ansar felt reluctant that they should circumambulate between al-Safa' and al-Marwa until it was revealed: "Verily al-Safa' and al-Marwa are among the Signs of Allah"; so whoever performs Hajj or 'Umra, for him there is no harm that he should circumambulate between them.

Chapter 42: SA'I SHOULD NOT BE REPEATED

Book 7, Number 2929:

    Jabir b. 'Abdullah reported that Allah's Apostle (may peace be upon him) and his Companions did not observe Sa'i between al-Safa' and al-Marwa but only one Sa'i.

Book 7 ,Number 2930:

    Ibn Juraij reported on the same authority a hadith like that, and said: But one Tawaf and that was the first Tawaf.

Chapter 43:THE PILGRIM SHOULD CONTINUE TO PRONOUNCE TALBIYA UNTIL THE STONING OF JAMRAT AL-'AQABA ON THE DAY OF SACRIFICE (1OTH OF DHU'L-HIJJA)

Book 7, Number 2931:

    Usama b. Zaid (Allah be pleased with him) reported: I was sitting behind Allah's Messenger (may peace be upon him) on the riding animal from 'Arafat. As Allah's Messenger (may peace be upon him) reached the left side of the mountain which was situated near Muzdalifa, he made the camel kneel down and made water and then came back. I poured water and he, performed light ablution. I then said: Messenger of Allah, it is time for prayer. Thereupon Allah's Messenger (may peace be upon him) said: The prayer awaits you (at the next station, Muzdalifa). Allah's Messenger (may peaced be upon him) rode on until he came to Muzdalifa and observed prayer. Then al-Fadl (Allah be pleased with him) sat behind Allah's Messenger (may peace be upon him) and reached (Muzdalifa) in the morning. Kuraib said: 'Abdullah b. 'Abbas (Allah be pleased with them) narrated from al-Fadl (Allah be pleased with him) that Allah's Messenger (may peace be upon him) continued pronouncing Talbiya until he reached al-Jamara (al-'Aqaba).

Book 7 ,Number 2932:

    Ibn Abbas (Allah be pleased with them) reported that Allah's Apostle (may peace be upon him) made al-Fadl sit behind him (on the camel back) from the place (where the two prayers) are combined (Muzdalifa). Ibn Abbas (Allah be pleased with them) also informed that Allah's Apostle (may peace be upon him) did not stop pronouncing Talbiya till he threw pebbles at Jamrat al-'Aqaba.

Book 7 ,Number 2933:

    Ibn 'Abbas narrated from al-Fadl b. Abbas (Allah be pleased with them) who sat behind Allah's Messenger (may peace be upon him) that he (the Holy Prophet) said to the people on the evening of 'Arafa and on the morning to the gathering of people (at Muzdalifa) as they were pushing on to proceed slowly. And he himself drove his she-camel with restraint until he entered Muhassir (it is a place in Mina), and further told them to take up pebbles which were to be thrown at Jamra. And Allah's Messenger (may peace be upon him) continued pronouncing Talbiya till he stoned the Jamra. This hadith has been narrated on the authority of Abd Zubair with the same chain of transmitters but with this variation that in the hadith no mention is made of (this) that Allah's Messenger (may peace be upon him) continued pronouncing Talbiya till he stoned the Jamra, and he made this addition in his hadith: "The Apostle (may peace be upon him) pointed with his hand how a person should catch hold of pebbles (in order to throw them)."

Book 7 ,Number 2934:

    'Abdullah narrated to us as we had gathered (at Muzdalifa): I have heard from one upon whom Surah al-Baqara was revealed (the Holy Prophet) pronouncing Talbiya at this place.

Book 7 ,Number 2935:

    'Abd al-Rahman b. Yazid reported that 'Abdullah (b. Mas'ud) pronounced Talbiya as he returned from the gathering of the people (at Muzdalifa). It was said: He might be a Bedouin (not knowing correctly the rituals of Hajj and, therefore, pronouncing Talbia at this stage), whereupon Abdullah said: Hive the people forgotten (this Sunnah of the Holy Prophet) or have they gone astray? I heard him, upon whom Sibrah al-Baqara was revealed, pronouncing Talbiya at the very place.

Book 7 ,Number 2936:

    'Abd al-Rahman b. Yazid and al-Aswad b. Yazid reported: We heard 'Abdullah b. Mas'ud saying to the gathering of people (at Muzdalifa) that he had heard Talbiya from him, upon whom Surah al-Baqara was revealed, at this very place. And so he ('Abdullah b. Mas'ud) pronounced Talbiya and we also pronounced it with him.

Chapter 44: PRONOUNCING OF TALBIYA AND TAKBIR WHILE GOING FROM MINA TO'ARAFAT ON THE DAY OF 'ARAFA

Book 7, Number 2937:

    'Abdullah b. 'Umar reported on the authority of his father (Allah be pleased with them). He said: As we proceeded in the morning along with AUbs Messenger (may peace be upon him) from Mina to 'Arafat, some of us prounced Talbiya, and some pronounced Takbir (Allah-o-Akbar).

Book 7 ,Number 2938:

    Abdullah b. 'Umar reported on the authority of his father (Allah be pleased with them): We were along with Allah's Messenger (way peace he upon him) in the morning of 'Arafa (9th of Dhu'l-Hijja). Some of us pronounced Takbir and some of us Tahlil La ilaha ill-Allah). And to those of us who pronounced Takbir, I said: By Allah, how strange it is that you did not care to ask him: What did you see Allah's Messenger (may peace be upon him) doing (on this occasion)?

Book 7 ,Number 2939:

    Muhammad b. Abu Bakr al-Thaqafi asked Anas b. Malik (Allah be pleased with him), while on their way from Mina to 'Arafa in the morning: What did you do on this day in the company of Allah's Messenger (may peace be upon him)? Thereupon he said: One of us pronounced Tahlil, and he met with no disapproval, and one of us pronounced Takbir, and he also met with no disapproval.

Book 7 ,Number 2940:

    Muhammad b. Abu Bakr reported: I said to Anas b. Malik in the morning of 'Arafa: What do you say as to pronouncing Talbiya on this day? He said: I travelled with Allah's Apostle (may peace he upon him) and his Companions in this journey. Some of us pronounced Takbir and some of us pronounced Tahlil, and none of us found fault with his companion.

Chapter 45: RETURNING FROM 'ARAFAT TO MUZDALIFA AND EXCELLENCE OF OBSERVING SUNSET AND 'ISHA' PRAYERS TOGETHER AT MUZDALIFA

Book 7, Number 2941:

    Kuraib, the freed slave of Ibn Abbas, narrated from Usama b. Zaid (Allah be pleased with him) that he had heard him saying: Allah's Messenger (may peace be upon him) proceeded from 'Arafa, and as he approached the creek of a hill, he got down (from his camel) and urinated, and then performed a light ablution. I said to him: Prayer, whereupon he said: The prayer awaits you (at Muzdalifa). So he rode again, and as he came to Muzdalifa, he got down and performed ablution well. Then Iqima was pronounced for prayer, and he 'observed the sunset prayer. Then every person made his camel kneel down there, and then Iqama was pronounced for 'Isha' prayer and he observed it, and he (the Holy Prophet) did not observe any prayer (either Sunan or Nawifil) in between them (He observed the Fard of sunset and 'Isha' prayers successively.)

Book 7 ,Number 2942:

    Usama b. Zaid (Allah be pleased with him) reported: Allah's Messenger (may peace be upon him) on his way back from 'Arafat got down in one of these creeks (to answer the call of nature), and after he had done that I poured water (over his hands) and said: Are you going to pray? Thereupon he said: The place of prayer is ahead of you.

Book 7 ,Number 2943:

    Usama b. Zaid (Allah be pleased with him) narrated: AHah's Messenger (may peace be upon him) was on his way back from 'Arafat and as he reached the creek (of a hillock) he got down and urinated (Usama did not say that he poured water), but said: He (the Holy Prophet) called for water and performed ablution, but it was not a thorough one. I said: Messenger of Allah, the prayer ! Thereupon he said: Prayer awaits you ahead (at Muzdalifa). He then proceeded, until he reached Muzdalifa and observed sunset and 'Isha' prayers (together) there.

Book 7 ,Number 2944:

    Kuraib reported that he asked Usama b. Zaid (Allah be pleased with him) What did you do in the evening of 'Arafa as you rode behind Allah's Messenger (may peace be upon him)? He said: We came to a valley where people generally halted their (camels) for the sunset prayer. Allah's Messenger (may peace be upon him) halted his camel and urinated (and he did not say that he had poured water). He then called for water and performed light ablution. I said: Messenger of Allah, the prayer ! Thereupon he said: Prayer awaits you (at Muzdalifa). and he rode on until we came to Muzdalifa. Then he offered the sunset prayer. and the people halted their camels at their places, and did not untie them until Iqama was pronounced for the 'Isha' prayer and he observed the prayer, and then they untied (their camels). I said: What did you do in the morning? He said: Al-Fadl b. Abbas (Allah be pleased with them) sat behind him (the Holy Prophet) in the morning, whereas I proceeded on foot with the Quraish who had gone ahead.

Book 7 ,Number 2945:

    Usama b. Zaid (Allah be pleased with him) reported that when Allah's Messenger (may peace jbe upod him) came to the valley where the rich (people of Mecca) used to get down. he got down. and urinated (and he did not mention about pouring water); he then called for water and performed a light ablution. I said: Messenger of Allah, the prayer I Thereupon he said: Prayer awaits you ahead.

Book 7 ,Number 2946:

    Usama b. Zaid (Allah be pleased with him) reported that he sat behind Allah's Messenger (may peace be upon him) on his ride as he came back from 'Arafa. And as he came to the valley, he halted his camel, and then went to the wilderness (to urinate). And when he came back, I poured water on him from the jug and he performed ablution, and then rode on until he came to Muzdalifa and there he combined the sunset and 'Isha' prayers.

Book 7 ,Number 2947:

    Ibn Abbas (Allah be pleased with him) reported that Allah's Messenger (may peace be upon, him) came back from 'Arafa and Usama (Allah be pleased with him) was seated behind him. Usama said that he (the Holy Prophet) continued the journey in this very state until he came to Muzdalifa.

Book 7 ,Number 2948:

    Hisham (Allah be pleased with him) reported from his father: Usama (Allah be pleased with him) was asked in my presence or I asked Usama b. Zaid andhe rode behind Allah's Messenger (may peace be upon him) as he came back from 'Arafat. I said (to him): How did Allah's Messenger (may peace be upon him) journey as he came back from 'Arafat? Thereupon he said: He made it (his riding camel) walk at a slow speed, and when he found an open space, he made it walk briskly.

Book 7 ,Number 2949:

    This hadith has been narrated on the authority of 'Urwa with the same chain of transmitters. and in the hadith narrated by Humaid there is an addition (of these words): "Hisham said: Al-nass (speed of camel) is faster than al-'anaq."

Book 7 ,Number 2950:

    Abdullah b. Yazid al-Khatmi reported on the authority of Abu Ayyub (Allah be pleased with him) that he prayed the sunset and 'Isha' prayers (together) at Muzdalifa in the company of Allah's Messenger (may peace be upon him) on the occasion of the Farewell Pilgrimage.

Book 7 ,Number 2951:

    Ibn Umar (Allah be pleased with them) reported that Allah's Messenger (may peace be upon him) observed the sunset and 'Isha' prayers together at Muzdalifa.

Book 7 ,Number 2952:

    Ubaidullah b. 'Abdullah b. 'Umar reported on the authority of his father (Allah be pleased with them) that Allah's Messenger (may peace be upon him) combined the sunset and 'Isha', prayers at Muzdalifa and there was no prostration (i.e. any rak'ahs of Sunan or Nawafil prayers) in between them. He observed three rak'ahs of the sunset prayer and two rak'ahs of the 'Isha' prayer, and 'Abdullah (b. 'Umar) observed the prayers in this very manner (at Muzdalifa) until he met his Lord.

Book 7 ,Number 2953:

    Sa'id b. Jubair reported that he observed the sunset and 'Isha' prayers at Muzdalifa with (one) iqama. He narrated on the authority of Ibn 'Umar (Allah be pleased with them) that he observed prayers like this. and Ibn 'Umar (Allah be pleased with them) narrated that Allah's Apostle (may peace be upon him) did like this. Shu'ba reported this hadith with the same chain of transmitters and said : He (the Holy Prophet) observed the two prayers (together) with one iqama.

Book 7 ,Number 2954:

    Ibn 'Umar rep rte that Allah's Messenger (may peace be upon him) combined the sunset and 'Isha ' prayers at Muzdalifa. He observed three rak'ahs of the sunset prayer and two rak'ahs of the 'Isha' prayer with one Iqama.

Book 7 ,Number 2955:

    Sa'id b. Jubair reported: We came back along with Ibn 'Umar till we reached Muzdalifa. There he led us in the sunset and 'Isha' prayers with one iqama and we then proceeded and he said: This is how Allah's Messenger (may peace be upon him) led us in prayer at this place.

Chapter 46:EXCELLENCE OF OBSERVING THE DAWN PRAYER AT THE EARLIEST PART OF THE DAWN ON THE 1OTH OF DHU'L-HIJJA AT MUZDALIFA

Book 7, Number 2956:

    A'bdullah (b. 'Umar) reported: I have never seen Allah's Messenger, (may peace be upon him) but observing the prayers at their appointed times except two players, sunset and 'Isha,' at Muzdalifa (where he deferred the sunset prayer to combine it with 'Isha' and he observed the dawn prayer before its stipulated time on that day (10th of Dhu'l-Hijja).

Book 7 ,Number 2957:

    This badith has been transmitted by A'mash with a slight variation of words, i.e. he said before its time when it was still dark.

Chapter 47: IT IS EXCELLENT THAT THE AGED AND THE WEAK, ESPECIALLY AMONG THE WOMEN, SHOULD HASTEN FROM MUZDALIFA TO MINA AT THE LATTER PART OF THE NIGHT BEFORE THE PEOPLE MOVE IN MULTITUDE, AND EXCELLENCE OF STAYING THERE FOR OTHERS UNTIL THEY OBSERVE THE DAWN PRAYER AT MUZDALIFA

Book 7, Number 2958:

    'A'isha (Allah be pleased with her) reported: Sauda (the wife of the Holy Prophet) who was bulky sought the permission of Allah's Messenger (may peace be upon him) on the night of Muzdalifa to move from (that place) ahead of him and before the multitude (set forth). He (Allah's Apostle) gave her the permission. So she set forth before his (Holy Prophet's) departure. But we stayed there until it was dawn and we moved on, when he departed. And if I were to seek the permission of Allah's Messenger.(may peace be upon him) as Sauda had sought permission, I could have also gone with his permission and it would have been better for me than that for which I was happy.

Book 7 ,Number 2959:

    A'isha (Allah be pleased with her) reported that (hadrat) Sauda was a bulky lady, so she sought permission from Allah's Messenger (may peace be upon him) to proceed from Muzdalifa (to Mina) in the (latter part of the) night. He granted her permission. 'A'isha said: I wish I had also sought permission from Allah's Messenger (may peace be upon him) as Sauda had. sought permission from him. 'A'isha did not proceed but with the Imam.

Book 7 ,Number 2960:

    'A'isha said: I wish I had sought permission from Allah's Messenger (may peace be upon him) as Sauda had sought, and observed the dawn prayer at Mina and stoned at al-Jamra before the people had come there. It was said to 'A'isha (Allah be pleased with her): Did Sauda seek permission from him (the Holy Prophet)? She said: Yes. She was a bulky lady and so she sought permission from Allah's Messenger (may peace be upon him) (to proceed to mina from Muzdalifa ahead of him), and he granted her permission.

Book 7 ,Number 2961:

    A hadith like this has been narrated by 'Abd al-Rahman b. al-Qasim with the same chain of transmitters.

Book 7 ,Number 2962:

    Abdullah, the freed slave of (Hadrat) Asma', reported: Asma' (Allah be pleased with her), as she was in the house at Muzdalifa, asked me whether the moon had set. I said: No. She prayed for some time, and again said: My son has the moon set ? I said: Yes. And she said: Set forth along with me, and so we set forth until (we reached Mini) and the stoned at al-Jamra. She then prayed in her place. I said to her: Respected lady, we set forth (in the very early part of dawn) when it was dark, whereupon she said: My son, there is no harm in it; Allah's Apostle (may peace be upon him) had granted permission to women. This hadith has been narrated by Ibn Juraij with the same chain of transmitters, and In his narration (the words are): "She (Asma') said: My son, Allah's Apostle (may peace be upon him) granted permission to women."

Book 7 ,Number 2963:

    Ibn Shawwal (the freed slave of Umm Habiba) reported that he went to Umm Habiba (the wife of Allah's Apostle) who informed him that Allah's Apostle (may peace be upon him) sent her from Muzdalifa during the night.

Book 7 ,Number 2964:

    It is narrated from Umm Habiba: We used to set forth from Muzdalifa to Mina, (very early in the dawn) when it was dark. And in the narration of Naqid (the words are): "We set from Muzdalifa in the darkness (of the dawn)."

Book 7 ,Number 2965:

    Ibn 'Abbas reported: Allah's Messenger (may peace be upon him) sent me from Muzdalifa ahead (of the caravan) along with the luggage or with the weak ones during (the latter part of the) night.

Book 7 ,Number 2966:

    Ibn 'Abbas (Allah be pleased with them) reported: I was among those (i.e. women and children) whom Allah's Messenger (may peace be upon him) sent forth with the weak members of his family.

Book 7 ,Number 2967:

    This hadith has been transmitted by Ibn 'Abbas (Allah be pleased with them) with a slight variation of words.

Book 7 ,Number 2968:

    'Ata' reported from Ibn Abbas (Allah be pleased with them): Allah's Messenger (may peace be upon him) sent me from Muzdalifa along with his luggage (in the very early part of @he dawn). I (Ibn Juraij, one of the narrators) said (to 'Ati') : Has this (news) reached you that Ibn 'Abbas (Allah be pleased with them) had said: "He (Allah's Messenger) had sent me in the latter p4art of the night" ?Thereupon he said: No, it was the dawn. I (again) said to him: (Did you hear) Ibn 'Abbas (Allah be pleased with them) having said this (too): "We stoned al-Jamra before the dawn prayer"? So where did he observe the dawn prayer? He said: No. But he said only so much (as described above).

Book 7 ,Number 2969:

    Salim b. 'Abdullah reported that 'Abdullah b. 'Umar (Allah be pleased with them) used to send ahead of him the weak members of his household to stay during the night at Mash'ar al-Haram at Muzdalifa. They remembered Allah so long as they could afford, and then they proceeded before the stay of the Imam, and before his return. So some of them reached Mina for the dawn prayer and some of them reached there after that; and as they reached there, they stoned al-Jamra; and Ibn 'Umar (Allah be pleased with them) used to say: Allah's Messenger (may peace be upon him) has granted this concession to them.

Chapter 48:STONING AT JAMRAT AL-'AQABA FROM THE HEART OF THE VALLEY IN THE STATE THAT MECCA IS ON THE LEFT SIDE AND PRONOUNCING OF TAKBIR WHILE THROWING EVERY PEBBLE

Book 7, Number 2970:

    'Abd al-Rahman b. Yazid reported that 'Abdullah b. Mas'ud (Allah be pleased with them) threw seven pebbles at Jamrat al-'Aqaba from the heart of the valley. He pronounced Takbir with every pebble. It was said to him that people fling stones from the upper side (of the valley), whereupon 'Abdullah b. Mas'ud (Allah he pleased with them) said: By him, besides Whom there is no other god, that is the place (of flinging stones) of one upon whom Surah al-Baqara was revealed (the Holy Prophet).

Book 7 ,Number 2971:

    A'mash reported: I heard Hajjaj b. Yusuf saying as he was delivering sermon on the pulpit: Observe the order of the (Holy) Qur'an which has been observed by Gabriel. (Thus state the surahs in this manner) "one in which mention has been made of al-Baqara," "one in which mention has been made of women (Surah al-Nisa')" and then the surah in which mention has been made of the Family of 'Imrin. He (the (narrator) said: I met Ibrahim and informed him about these words of his (the statement of Hajjaj b. Yusuf). He cursed him and said: Abd al-Rahman b. Yazid has narrated to me that when he was in the company of 'Abdullah b. Mas'udd (Allah be pleased with them) he came to Jamrat al-'Aqaba and then entered the heart of the valley and faced towards it (the Jamra) and then flung seven pebbles at it from the heart of the valley pronouncing Takbir with every pebble. I said: Abu 'Abd al-Rahman, people fling pebbles at it (Jamra) from the upper side, whereupon he said: By Him besides Whom there is no god, that is the place (of flinging pebbles of one) upon whom Surah al-Baqara was revealed;

Book 7 ,Number 2972:

    A'mash reported: I heard Hajjaj saying I Do not say Surah al-Baqara. The rest of the hadith is the same.

Book 7 ,Number 2973:

    Abd al-Rahman b. Yazid reported that he performed Hajj along with 'Abdullah (Allah be pleased with him) and he flung seven pebbles at al-Jamra (from a position) that the House was on his left and Mina was on his right and said: That is the place (of flinging pebbles of one) upon whom Surah al-Baqara was revealed.

Book 7 ,Number 2974:

    This hadith nas been narrated on the authority of Shu'ba with the same chain of transmitters except with this variation of (words): As he came to Jamrat al-'Aqaba."

Book 7 ,Number 2975:

    Abd al-Rahman b. Yazid reported: It was said to 'Abdullah (Allah be pleased with bird) that people threw pebbles at the Jamra from the upper side of 'Aqaba, whereas he threw stones at it from the heart of the valley, whereupon he said: By Him besides Whom there is no god, it is at this very place that one upon whom was revealed Surah al-Baqara threw stones at it.

Chapter 49: EXCELLENCE OF FLINGING PEBBLES AT JAMRAT AL-'AQABA ON THE DAY OF SACRIFICE (IOTH OF DHU'L-HIJJA) WHILE RIDING

Book 7, Number 2976:

    Jabir (Allah be pleased with him) reported: I saw Allah's Apostle (may peace be upon him) flinging pebbles while riding his camel on the Day of Nahr, and he was saying: Learn your rituals (by seeing me performing them), for I do not know whether I would be performing Hajj after this Hajj of mine.

Book 7 ,Number 2977:

    Umm al-Husain (Allah be pleased with her) reported: I performed Hajj along with Allah's Messenger (may peace be upon him) on the occasion of the Farewell Pilgrimage and saw him when he flung pebbles at Jamrat al-'Aqaba and returned while he was riding the camel, and Bilal and Usama were with him. One of them was leading his camel, while the other was raising his cloth over the head of Allah's Messenger (may peace be upon him) to protect him from the sun. She (further) said: Allah's Messenger (may peace be upon him) said so many things, and I heard him saying: If a slave having some limb of his missing and having dark complexion is appointed to govern you according to the Book of Allah the Exalted. listen to him and obey him.

Book 7 ,Number 2978:

    Umm al-Husain (Allah be pleased with her) reported: I performed Hajj along with Allah's Messenger (may peace be upon him) on the occasion of the Farewell Pilgrimage and saw Usama and Bilal (too), one of whom had caught hold of the lose string of the she-camel of Allah's Apostle (may peace be upon him) while the other one was raising his cloth (over his head) protecting him from the heat, till he flung pebbles at Jamrat al-'Aqaba.

Chapter 50:THE PEBBLES TO BE USED FOR THROWING SHOULD BE SMALL

Book 7, Number 2979:

    Jabir b. 'Abdullah reported: I saw Allah's Apostle (may peace be upon him) throwing stones (at Jamrat al 'Aqaba) like pelting of small pebbles.

Continue to next page: Click here


BOOK 7: The Book of Pilgrimage (Kitab Al-Hajj (part II)

KITAB AL-HAJJ
(THE BOOK OF PILGRIMAGE)
(Continued)

Back
Chapter 51:WHAT IS THE EXCELLENT TIME FOR THROWING PEBBLES (AT THE JAMRAS)

Book 7, Number 2980:

    Jabir (Allah be pleased with him) reported that Allah's Messenger (may peace be upon him) flung pebbles at jamra on the Day of Nahr after sunrise, and after that (i.e. on the 11th, 12th and 13th of Dhu'l-Hijja when the sun had declined.

Book 7 ,Number 2981:

    Jabir b. Abdullah reported a hadith like this from Allah's Apostle (may peace be upon him).

Chapter 52: WHAT SHOULD BE THE NUMBER OF THE PEBBLES

Book 7, Number 2982:

    Jabir (b. Abdullab) (Allah be pleased with him) reported Allah's Messenger (may peace be upon him) as saying: Odd number of stones are to be used for cleaning (the private parts after answering the call of nature), and casting of pebbles at the Jamras is to be done by odd numbers (seven), and (the number) of circuits between al-Safa' and al-Marwa is also odd (seven), and the number of circuits (around the Ka'ba) is also odd (seven). Whenever any one of you is required to use stones (for cleaning the private parts) he should use odd number of stones (three, five or seven).

Chapter 53:IT IS PREFERABLE TO GET ONE'S HAIR CUT (AS A RITUAL OF PILGRIMAGE) BUT CLIPPING IS ALSO PERMISSIBLE

Book 7, Number 2983:

    'Abdullah reported that Allah's Messenger (may peace be upon him) got his head shaved (after slaughtering the sacrificial animal on the 10th of Dhu'l-Hijja), and so did a group of Companions, while some of them got their hair clipped. Abdullah said: Allah's Messenger (may peace'be upon him) observed once or twice: "May Allah have mercy upon those who get their heads shaved." And he also said: "Upon those too who got their hair clipped."

Book 7 ,Number 2984:

    Abdullah b. Umar (Allah be pleased with him) reported Allah's Messenger (may peace be upon him) as having observed: O Allah, have mercy upon those who get their heads shaved. They (the Companions) said: Messenger of Allah, (what about those) who have got their hair clipped? He said: O Allah, have mercy upon those who have got their heads shaved. They (again) said: Allah's Messenger, (what about those) who have got their hair clipped? Thereupon he said: (O Allah, have mercy upon those) who have got their hair clipped.

Book 7 ,Number 2985:

    Ibn 'Umar reported that Allah's Messenger (may peace be upon him) said: May Allah have mercy upon those who have got their heads shaved. They said: Messenger of Allah, (what about) those who got their hair clipped? He said: May Allah have mercy upon those who have got their heads shaved. They said: Messenger of Allah, (what about those who have got their hair clipped)? He said: May Allah have mercy upon those who got their hair shaved. They said: Messenger of Allah, (what about) those who got their hair clipped? He said: (O Allah, have mercy upon) those who got their hair clipped.

Book 7 ,Number 2986:

    Ubaidullah reported this hadith with the same chain of transmitters and (it is said) that it was on the fourth turn that he (the Holy Prophet) said: (May Allah have mercy upon) those who got their hair clipped."

Book 7 ,Number 2987:

    Abu Huraira reported Allah's Messenger (may peace be upon him) as having said: O Allah, grant pardon to those who got their heads shaved They (Companions of the Holy Prophet) said: Messenger of Allah, (what about those) who get their hair cut? He said: O Allah, grant pardon to those who get their heads shaved. They said: Messenger of Allah, (what about those) who got their hair clipped? He said: O Allah, grant pardon to those who get their heads shaved. They said: Messenger of Allah, (what about those) who get their hair clipped? He said: O Allah, grant pardon to those who get their heads shaved. They said: (What about those) who get their hair clipped? He said: (O Allah, grant pardon to) those who get their hair clipped.

Book 7 ,Number 2988:

    A hadith like this is narrated on the authority of Abu Huraira.

Book 7 ,Number 2989:

    Yahya b. al-Husain reported on the authority of his grandfather that Allah's Apostle (may peace be upon him) invoked blessing on the occasion of the Farewell Pilgrimage three times for those who got their heads shaved and once for those who got their hair clipped. In the narration transmitted by Waki' there is no mention of the Farewell Pilgrimage.

Book 7 ,Number 2990:

    Ibn Umar reported that Allah's Messenger (may peace be upon him) got his head shaved on the occasion of the Farewell Pilgrimage.

Chapter 54: IT IS A SUNNAH THAT ON THE DAY OF NAHR ONE SHOULD THROW PEBBLES, THEN SLAUGHTER ANIMAL THEN GET ONE'S HEAD SHAVED, AND ONE SHOULD START SHAVING ONE'S HEAD FROM THE RIGHT SIDE

Book 7, Number 2991:

    Anas b. Malik (Allah be pleased wish him) reported that Allah's Messenger (may peace be upon him) came to Mina; he went to the Jamra and threw pebbles at it, after which he went to his lodging in Mina,and sacrificed the animal. He then called for a barber and, turning his right side to him, let him shave him; after which he tiimed his left side. He then gave (these hair) to the people.

Book 7 ,Number 2992:

    Abu Bakr reported: (He called for) the barber and, pointing towards the right side of his head, said: (Start from) here, and then distributed his hair among those who were near him. He then pointed to the barber (to shave) the left side and he shaved it, and he gave (these hair) to Umm Sulaim (Allah be pleased with her). And in the narration of Abu Kuraib (the words are): "He started from the right half (of his head), and he distributed a hair or two among the people. and then (asked the barber) to shave the left side and he did similarly, and he (the Holy Prophet) said: Here is Abu Talha and he gave these (hair) to Abu Talha."

Book 7 ,Number 2993:

    Anas b. Malik (Allah be pleased with him) reported that Allah's Messenger (may peace be upon him) threw stones at Jamrat al-'Aqaba. He then want to his sacrificial animal and sacrificed it, and there was sitting the barber, and he pointed with his hand towards his head, and he shaved the right half of it, and he (the Holy Prophet) distributed them (the hair) among those who were near him. And he again said: Shave the other half, and said: Where is Abu Talha and gave it (the hair) to him.

Book 7 ,Number 2994:

    Anas b. Malik (Allah be pleased with him) reported: When Allah's Messenger (may peace be upon him) had thrown pebbles at the Jamra and had sacrificed the animal, he turned (the right side) of his head towards the barber, and i.e shaved it. He then called Abu Talha al-Ansari and gave it to him. He then turned his left side and asked him (the barber) to shave. And he (the barber) shaved. and gave it to Abu Talha and told him to distribute it amongst the people.

Chapter 55: REGARDING ONE WHO SHAVES BEFORE OFFERING TLIE SACRIFICE OR OFFERS SACRIFICE BEFORE THROWING (TIIE STONES AT JAMRA)

Book 7, Number 2995:

    Abdullah b. 'Amr b. al-'As said that Allah's Messenger (may peace be upon him) stopped during the Farewell Pilgrimage at Mina for people who had something to ask. A man came and said: Messenger of Allah, being ignorant. I shaved before sacrificing, whereupon he (the Holy Prophet) said: Now sacrifice (the animal) and there is no harm (for you). Then another man came and he said: Messenger of Allah, being ignorant, I sacrificed before throwing the pebbles, whereupon he (the Holy Prophet) said: (Now) throw the pebbles, and there is no harm (for you). Allah's Messenger (may peace be upon him) was not asked about anything which had been done before or after (its proper time) but he said: Do it, and no harm is there (for you).

Book 7 ,Number 2996:

    'Abdullah b. 'Amr b. al-'As (Allah be pleased with them) reported: Allah's Messenger (may peace be upon him) stopped while riding his camel and the people began to ask him. One of the inquirers said: Messenger of Allah, I did not know that pebbles should be thrown before sacrificing the animal, and by mistake I sacrificed the animal before throwing pebbles, whereupon Allah's Messenger (may peace be upon him) said: (Now) throw pebbles and there is no harm in it.Then another(person) came saying: I did not know that the animal was to be sacrificed before shaving, but I got myself shaved before sacrificing the animal, whereupon he (the Holy Prophet) said: Sacrifice the animal (now) and there is no harm in it. He (the narrator) said: I did not hear that anything was asked on that day (shout a matter) which a person forgot and could not observe the sequence or anything like it either due to forgetfulness or ignorance, but Allah's Messenger (may peace be upon him) said (about that): Do it; there is no harm in it.

Book 7 ,Number 2997:

    This hadith has been narrated on the authority of Zuhri.

Book 7 ,Number 2998:

    Abdullah b. Amr b. al-'As (Allah be pleased with them) reported: As Allah's Apostle. (may peace be upon him) was delivering sermon on the Day of Nahr, a man stood up before him and said: Messenger of Allah, I did not know that such and such (rite was to be performed) before such and such (rite). Then another man came and said: Messenger of Allah, I thought that such and such (rite) should precede such and such (rite), and then another man came and said: Messenger of Allah, I had thought that such and such was before such and such, and such and such (is the sequence) of the three (rites, viz. throwing of pebbles, sacrificing of animal and shaving of one's head). He said to all these three : Do now (if you have not observed the cequence); there is no harm in it.

Book 7 ,Number 2999:

    This hadith has been narrated on the authority of Ibn Juraij with the same chain of transmitters. And the narration of Ibn Bakr is like one transmitted by 'Isa but with this (variation): "There are not these words in it: To all these three rites (throwing of pebbles sacrificing of animal and shaving of one's head)." And so far as the narration of Yahya al-Umawi (the words are): I got (my head) shaved before I sacrificed the animal, and I sacrified the animal before throwing pebbles, and like that.

Book 7 ,Number 3000:

    Adullah b. 'Amr (b. al-'As) (Allah be pleased with him) reported that a person came to Allah's Apostle (may peace be upon him) and said: I got (my head) shaved before sacrificing the ,animal, whereupon be (the Holy Prophet) said: Sacrifice the animal (now); there is no harm in it. He (the person said): I sacripced the animal before throwingpebbles. whereupon he said: Throw pebbles (now); there is no harm in it.

Book 7 ,Number 3001:

    This hadith has been narrated on the authority of Zuhri with the same chain of transmitters (and the words are): I saw Allah's Messenger (may peace be upon him) on the back of the camel at Mina, and a person came to him," and the rest of the hadith Is like that transmitted by Ibn 'Uyaina.

Book 7 ,Number 3002:

    'Abdullah b. 'Amr b. al-As (Allah be pleased with them) said: As Allah's Messenger (may peace be'upon him) was standing near the jamra, a person came to him on the Day of Nahr and said: Messenger of Allah, I got (my head shaved) before throwing pebbles, whereupon he (the Holy Prophet) said: Throw pebbles (now); there is no harm in it. Another man (then) came and said: I have sacrificed before throwing the stones. He said: Throw stones (now) and there is no harm. Another came to him and said: I have observed the circumambulation of Ifada of the House before throwing pebbles. He said: Throw pebbles (now); there is no harm in it, He (the narrator) said: I did not see that he (the Holy Prophet) was asked about anything on that day, but he said: Do, and there is no harm in it.

Book 7 ,Number 3003:

    Ibn Abbas (Allah be pleased with them) reported that it was said to Allah's Apostle (may peace be upon him) about sacrificing of animals, shaving of one's head, throwing of pebbles, and (the order of) precedence and succession, and he said: There is no harm in it.

Chapter 56:EXCELLENCE OF OBSERVING CIRCUMAMBULATION OF IFADA ON THE DAY OF NAHR

Book 7, Number 3004:

    Ibn Umar reported that Allah's Messenger (may peace be upon him) observed the circumambulation of Ifada on the Day of Nabr (10th of Dhu'l-Hijja), and then came back and observed the noon prayer at Mina. Nafi' (one of the narrators) said that Ibn Umar used to observe the circomambulation of Ifada on the Day of Nahr, and then return and observe the noon prayer at Mina, and mentioned that Allah's Apostle (may peace be upon him) did that.

Chapter 57: EXCELLENCE OF MAKING A HALT AT AL-MUHASSAB, ON THE DAY OF NAHR, AND OBSERVING PRAYER THERE

Book 7, Number 3005:

    Abd al-'Aziz b. Rufai' (Allah be pleased with him) said: I asked Anas b. Malik to tell me about something he knew about Allah's Messenger (may peace be upon him), viz. where he observed the noon prayer on Yaum al-Tarwiya. He said: At Mina. I said: Where did he observe the afternoon prayer on the Yaum an-Nafr? and he said: It was at al-Abtah. He then said: Do as your rulers do.

Book 7 ,Number 3006:

    Ibn 'Umar (Allah be pleased with him) reported that Allah's Messenger (may peace be upon him) and Abu Bakr and 'Umar observed halt at al-Abtah.

Book 7 ,Number 3007:

    Nafi' reported that Ibn 'Umar regarded halt at Muhassab as Sunnah (of the Holy Prophet) and observed the noon prayer on Yaum al-Nafr at that place. Nafi' said: Allah's Messenger (may peace be upon him) halted at Muhassab and the Caliphs did the same after him.

Book 7 ,Number 3008:

    'A'isha (Allah be pleased with her) reported.: Halt at al-Abtah is not the Sunnah. Allah's Messenger (may peace be upon him) halted there simply because it was easier for him to depart from there, when he left.

Book 7 ,Number 3009:

    This hadith is narrated on the authority of Hisham with the same chain of transmitters.

Book 7 ,Number 3010:

    Salim reported that Abu Bakr, 'Umar and Ibn Umar used to halt at Abtah. 'Urwa narrated from 'A'isha (Allah be pleased with her) that he did not observe this practice and said : Allah's Messenger (may peace be upon him) halted there, for it is a place from where it was easy to depart.

Book 7 ,Number 3011:

    Ibn 'Abbas (Allah be pleased with them) reported: Halt at Muhassab is not something (significant from the point of view of the Shari'ah). It is a place of halt where Allah's Messenger (way peace be upon him) halted.

Book 7 ,Number 3012:

    Abu Rafi' reported: Allah's Messenger (may peace be upon him) did not command me to observe halt at al-Abtah when be departed from Mina, but I came and set up his (the Holy Prcphet's) tent (of my own accord); and he (Allah's Apostle) came and observed halt. This hadith is narrated through another chain of transmitters from Abu Rafi' who was (in charge) of the luggage of Allah's Apostle (may peace be upon him).

Book 7 ,Number 3013:

    Abu Huraira (Allah be pleated with him) reported that Allah's Messenger (may peace be upon him) said: God willing, we will get down tomorrow, at Khaif of Banu Kinanah, the place where they had taken an oath on unbelief.

Book 7 ,Number 3014:

    Abu Huraira (Allah be pleased with him) reported: Allah's Messenger (may peace be upon him) said to us as we were at Mina: We would observe halt tomorrow at-Khaif of Banu Kinanah, where (the polytheists) had taken an oath on unbelief, and that was that the Quraish and Banu Kinanah had, pledged against Banu Hashim and Banu Muttalib that they would neither marry nor do any transaction with them unless they deliver Allah's Messenger (way peace be upon him) to them. And (this pledge was) taken at this (place) Muhassab.

Book 7 ,Number 3015:

    Abu Huraira (Allah be pleased with him) reported Allah's Apostle (may peace be upon him) as saying: God willing, when Allah has granted us victory, our halt tomorrow will be at Khaif, where they (the unbelievers of Mecca) had taken an oath on unbelief.

Chapter 58:IT IS ESSENTIAL TO STAY (FOR TWO OR THREE NIGHTS) AT MINA DURING THE DAYS OF TASHRIQ (11th, 12th AND 13th) AND EXEMPTION FROM THIS COMMAND FOR THE SUPPLIERS OF WATER

Book 7, Number 3016:

    Ibn Umar (Allah be pleased with them) reported that al-'A'bbas b. Abd al-Muttalib (Allah be pleased with him) sought permission from Allah's Messenger (may peace be upon him) to spend in Mecca the nights (which be was required to spend) at Mina on account of his office of supplier of water, and he (the Holy Prophet) granted him permission.

Book 7 ,Number 3017:

    A hadith like this has been narrated by 'Ubaidullah b. Umar with the the same chain of transmitters.

Book 7 ,Number 3018:

    Bakr b. 'Abdullah al-Muzani said: While I was sitting along with Ibn 'Abbas (Allah be pleased with him) near the Ka'ba, there came a bedouin to him and said: What is the matter that I see that the progeny of your uncle supply honey and milk (as drink to the travellers), whereas you supply al-nabidh (water sweetened with dates)? Is it due to your poverty or due to your close-fistedness? Thereupon Ibn 'Abbas said: Allah be praised, it is neither due to poverty nor due to close-fistedness (but due to the fact) that Allah's Apostle (may peace be upon him) came here riding his she-came, and there was sitting behind him Usama. He asked for water, and we gave him a cup full of nabidh and he drank it, and gave the remaining (part) to Usama; and he (the Holy Prophet) said: You have done Food, You have done well. So continue doing like it So we do not like to change what Allah's Messenger (may peace be upon him) had commanded us to do.

Chapter 59: ONE SHOULD OFFER AS SADAQA THE MEAT AND HIDE OF THE SACRIFICIAL ANIMAL

Book 7, Number 3019:

    'All (Allah be pleased with him) reperted: Allah's Messenger (may peace be upon him) put me in charge of his sacrificial animals, that I should give their flesh. skins and saddle cloths as sadaqa, but not to give anything to the butcher, saying: We would pay him ourselves.

Book 7 ,Number 3020:

    This hadith has been narrated on the authority of Abd al-Karim al-Jazari with the same chain of transmitters.

Book 7 ,Number 3021:

    This hadith has been narrated on the authority of 'Ali (Allah be pleased with him) with another chain of transmitters, but there is no mention of the wages of the butcher in it.

Book 7 ,Number 3022:

    Ali b. Abi Talib (Allah be pleased with him) reported: Allah's Apostle (may peace be upon him) put him in charge of his sacrificial animals, and commanded him to distribute the whole of their meat, hides, and saddle cloths to the poor, and not to give to the butcher anything out of them.

Book 7 ,Number 3023:

    A hadith like this has been narrated on the authority of Hadrat 'Ali (Allah be pleased with him).

Chapter 60:IT IS PERMISSIBLE TO JOIN SEVEN PERSONS IN A COW OR A CAMEL

Book 7, Number 3024:

    Jabir b. 'Abdullah (Allah be pleased with him) reported: In the year of Hudaibiya (6 H ), we, along with Allah's Messenger (way peace be upon him), sacrificed a camel for seven persons and a cow for seven persons.

Book 7 ,Number 3025:

    Jabir (Allah be pleased with him) reported: We set out in the state of Ihram for Hajj along, with Allah's Messenger (may peace be upon him). He commanded us that seven perons should join in a camel and a cow for offering sacrifice.

Book 7 ,Number 3026:

    Jabir b. 'Abdullah (Allah be pleased with him) reported: We performed Hajj along with Allah's Messenger (may peace be upon him), and we sacrificed a camel on behalf of seven persons, and a cow on behalf of seven persons.

Book 7 ,Number 3027:

    Jabir b. 'Abdullah (Allah be pleased with them) reported: We joined Allah's Apostle (may pea,@.e be upon him) in Hajj and Umra and seven persons shared in the sacrifice of an animal. A person said to Jabir (Allah be pleased with him): Can seven persons share in the sacrifice of al-Badnah (a camel) as he shares in al- Jazur (a cow)? He, (Jabir) said: It (al-Jazur) is nothing but one among the budun. Jabir was present at Hudaibiya and he said: We sacrificed on that day seventy camel, and seven men shared in each sacrifice (of camel).

Book 7 ,Number 3028:

    Jabir b. 'Abdullah (Allah be pleased with them), describing the Hajj of Allah's Apostle (may peace be upon him) said: He (the Holy Prophet) commanded us as we had entered into the state of Ihram to sacrifice the animals (as a rite of Hajj) and a group (of person; amongst us, i.e. seven) shared in the sacrifice of one (camel or cow), and it happened at that time when he commanded them to put off Ihram for Hajj (after performing 'Umra).

Book 7 ,Number 3029:

    Jaibir b. 'Abdullah (Allah be pleased with them) reported: We performed Hajj Tamattu' along with Allah's Messenger (may peace be upon him) and we slaughtered a cow on behalf of seven persons sharing in it.

Book 7 ,Number 3030:

    Jabir reported that Allah's Messenger (may peace be upon him) sacrificed a cow on behalf of 'A'isha on the Day of Nahr (10th of Dhu'l-Hijja).

Book 7 ,Number 3031:

    Jabir b. 'Abdullah (Allah be pleased with them) reported that Allah's Messenger (may peace be upon him) sacrificed (animals) on behalf of his wives, and in the hadith transmitted by Ibn Abu Bakr (the words are): "A cow on behalf of 'A'isha on the occasion of the Hajj."

Chapter 61: THE CAMEL IS TO BE SACRIFICED IN A STANDING POSTURE AND FETTERED

Book 7, Number 3032:

    Ziyad b. Jubair reported that Ibn 'Umar came upon a person who was slaughtering (sacrificing) his camel and had made him kneel down. So he told him to make it stand up festered (and then sacrifice it) according to the Sunnah of the Holy Prophet (may peace be upon him).

Chapter 62:IT IS MERITORIOUS FOR ONE WHO DOES IN FEND TO GO HIMSELF TO SEND THE SACRIFICIAL ANIMAL TO AL-HARAM

Book 7, Number 3033:

    'A'isha (Allah be pleased with her) reported that Allah's Messenger (may peace be upon him) sent the sacrificial animals from Medina. I wove garlands for his sacrificial animals (and then he hung them round their necks), and he would not avoid doing anything which the Muhrim avoids A hadith like this has been transmitted on the authority of Ibn Shihab.

Book 7 ,Number 3034:

    'A'isha narrated (in another badith narrated through another chain of transmitters) these words: "As if I am seeing myself weaving the garlands for the sacrificial animals of Allah's Messenger (may peace be upon him)."

Book 7 ,Number 3035:

    Abd al-Rahman b. al-Qasim reported on the authority of his father that he heard 'A'isha (Allah be pleased with her) saying: I used to weave garlands for the sacrificial animals of Allah's Messenger (may peace be upon him) with these hands of mine, but he (Allah's Apostle) neither avoided anything nor gave up anything (which a Muhrim should avoid or give up).

Book 7 ,Number 3036:

    'A'isha reported: I wove the garlands for the sacrificial animals of Allah's Messenger (may peace be upon him) with my own bands, and then he (the Holy Prophet) marked them, and garlanded them, and then sent them to the House, and stayed at Medina and nothing was forbidden to him which was lawful for him (before).

Book 7 ,Number 3037:

    'A'isha (Allah be pleased with her) reported: Allah's Messenger (may peace be upon him) sent the sacrificial animals and I wove garlands for them with my own 'hands, and he did not refrain from doing anything which he did not avoid in the state of non-Muhrim.

Book 7 ,Number 3038:

    Al-Qasim reported the Mother of the Faithful (Hadrat 'A'isha Siddiqa) (Allah be pleased with her) as saying: I used to weave these garlands from the multicoloured wool which was with us. The Messenger of Allah (may peace be upon him) was in the state of non Muhrim among us, and he would do all that was lawful for a lion-Muhrim with his wife.

Book 7 ,Number 3039:

    'A'isha (Allah be pleased with her) reported: I recall how I wove garlands for the sacrificial animals (the goats) of Allah's Messenger (may peace be upon him). He sent them and then stayed with us as a non-Muhrim.

Book 7 ,Number 3040:

    'A'isha (Allah,be pleased,with her) reported: I often wove garlands for the sacrificial animals of Allah's Messenger (may peace be upon him), and he garlanded his sacrificial animals, and then he sent them and stayed in the ouse) avoiding nothing which a Muhrim avoids.

Book 7 ,Number 3041:

    'A'isha (Allah be pleased with her) reported: Allah's Messenger (may peace be upon, him) sent some goats as sacrificial animals to the House and He garlanded them.

Book 7 ,Number 3042:

    'A'isha (Allah be pleased with her) reported: We used to garland the goats and send them (to Mecca), and Allah's Messenger (may peace be upon him) stayed back in Medina as a non-Muhrim ard nothing was forbidden for him (which is forbidden for a Muhrim).

Book 7 ,Number 3043:

    'Amra daughter of Abd al-Rahman reported that Ibn Ziyad had written to 'A'isha (Allah be pleased with him) that 'Abdullah b. Abbas (Allah be pleased with them) bad said that he who sent a sacrificial animal (to Mecca) for him was forbidden what is forbidden for a pilgrim (in the state of Ihram) until the animal is sacrificed I have myself sent my sacrificial animal (to Mecca), so write to me your opinion. Amra reported 'A'isha (Allah be pleased with her) as saying: It is not as Ibn 'Abbas (Allah be pleased with them) had asserted, for I wove the garlands for the sacrificial animals of Allah's Messenger (may peace be upon him) with my own hands. Allah's Messenger (may peace be upon him) then garlanded them with his own hands, and then sent them with my father, and nothing was forbidden for Allah's Messenger (may peace be upon him) which had been made lawful for him by Allah until the animals were sacrificed.

Book 7 ,Number 3044:

    Masruq reported: I heard 'A'isha (Allah be pleased with her) clapping her hands behind the curtain and saying: I used to weave garlands for the sacrificial animals of Allah's Messenger (may peace be upon him) with my own hands, and then he (the Holy Prophet) sent them (to Mecca), and he did not avoid doing anything which a Muhritn avoids until his animal was sacrificed.

Book 7 ,Number 3045:

    A hadith like this has been narrated on the authority of 'A'isha (Allah be pleased with her) through another chain of transmitters.

Chapter 63:IT IS PERMISSIBLE TO RIDE THE SACRIFICIAL ANIMAL (CAMEL) FOR ONE WHO IS IN NEED OF IT

Book 7, Number 3046:

    Abu Huraira (Allah be pleased with him) rerorted that Allah's Messenger (may peace be upon him) saw a person who was driving a sacrificial camel (and told him to ride on it. Thereupon he said: Messenger of Allah, it is a sacrificial camel. He told him again to ride on it; (when he received the same reply) he said: Woe to you, (he uttered these words on the second or the third reply).

Book 7 ,Number 3047:

    This hadith has been narrated by A'raj with the same chain of transmitters (and the words are): "Whereas the person was driving a sacrificial camel which was garlanded."

Book 7 ,Number 3048:

    Hammam b. Munabbih reported: It is one out of these (narrations) that Abu Huraira (Allah be pleased with him) narrated to us from Muhammad the Messenger of Allah (may peace be upon him), and he narrated to us traditions out of which is that he said : When there was a person who was driving a garlanded sacrificial camel, Allah's Messenger (may peace be upon him) said to him: Woe to you; ride on it. He said: Messenger of Allah, it is a sacrificial animal, whereupon Allah's Messenger (may peace be upon him) said: Woe to you, ride on it; woe to you, ride on it.

Book 7 ,Number 3049:

    Anas reported that Allah's Messenger (may peace be upon him) happened to pass by a person who was driving a sacrificial camel, whereupon he (the Holy Prophet) said: Ride on It. He said: It is a sacrificial camel. Thereupon he (the Holy Prophet) said twice or thrice: Ride on it.

Book 7 ,Number 3050:

    Anas reported: Someone happened to pass by Allah's Apostle (may peace be upon him) with a sacrificial camel, or a sacrificial animal, whereupon he said: Ride on it. He said: It is a sacrificial camel, or animal, whereupon he said: (Ride) even if (it is a sacrificial camel).

Book 7 ,Number 3051:

    Anas (Allah be pleased with him) reported: There happened to pass (a person) with a sacrificial camel by Allah's Apostle (may peace be upon him) and the rest of the hadith is the same.

Book 7 ,Number 3052:

    Jabir b. 'Abdullah (Allah be pleased with them) reported that he was asked about riding on a sacrificial animal, and he said: I heard Allah's Messenger (may peace be upon him) as saying: Ride on it gently, when you have need for it, until you find (another) mount.

Book 7 ,Number 3053:

    Abu Zubair reported: I asked Jabir (Allah be pleased with him) about riding on the sacrificial animal, to which he replied: I heard Allah's Apostle (may peace be upon him) as saying: Ride on them gently until you find another mount.

Chapter 64: WHAT SHOULD BE DONE WITH THE SACRIFICIAL ANIMAL, WHEN IT IS COMPLETELY EXHAUSTED AND BECOMES POWERLESS TO MOVE

Book 7, Number 3054:

    Musa b. Salama al-Hudhali reported: I and Sinan b. Salama proceeded (to Mecca to perform Umra. Sinan had a sacrificial camel with him which he was driving. The camel stopped in the way being completely exhausted and this state of it made him (Sinan) helpless.(He thought) if it stops proceeding further how he would be able to take it ,along with him and said: I would definitely find out (the religious verdict) about it. I moved on in the morning and as we encamped at al-Batha', (Sinan) said: Come (along with me) to Ibn 'Abbis (Allah be pleased with them) so that we should narrate to him (this incident), and he (Sinan) reported to him the incident of the sacrificial camel. He (Ibn Abbas) said: You have referred (the matter) to the well informed person. (Now listen) Allah's Messenger (may peace be upon him) sent sixteen sacrificial camels with a man whom he put in change of them. He set out and came back and said: Messenger of Allah, what should I do with those who are completely exhausted and become powerless to move on, whereupon he said: Slaughter them, and dye their hoofs in their blood, and put them on the sides of their humps, but neither you nor anyone among those who are with you must eat any part of them.

Book 7 ,Number 3055:

    Ibn Abbas (Allah be pleased with them) reported that Allah's Messenger (may peace be upon him) sent eighteen sacrificial camels with a person. The rest of the hadith is the same, and the first part (of the above-mentioned hadith) is not mentioned.

Book 7 ,Number 3056:

    Ibn Abbas (Allah be pleased with them) reported that Dhuwaib, father of Qabisa (Allah be pleased with him) narrated to him that Allah's Messenger (may peace be upon him) sent under his charge the sacrificial camels, and said: If any of these is completely exhausted and you apprehend its death, then slaughter it, then dip its hoofs in its blood and imprint it on its hump; but neither you nor any one of your comrades should eat it.

Chapter 65:IT IS OBLIGATORY TO PERFORM FAREWELL CIRCUMAMBULATION, WHILE A MENSTRUATING WOMAN IS EXEMPTED FROM IT

Book 7, Number 3057:

    Ibn 'Abbas (Allah be pleased with them) reported that the people used to return through every path, whereupon Allah's Messenger (way peace be upon him) said: None amongst you should depart until he performs the last circumambulation round the House. Zuhair said (the words are): [ARABIC: YANSWARIFUWN KULLA WAJH] and the word [arabic:FIY] was not mentioned.

Book 7 ,Number 3058:

    Ibn Abbas reported: The people were commanded (by the Holy Prophet) to perform the last circumambulation round the House, but menstruating women were exempted.

Book 7 ,Number 3059:

    Tawus reported: I was in the company of Ibn Abbas (Allah be pleased with them) when Zaid b. Thabit said: Do you give religious verdict that the woman who is in menses is allowed to go without performing the last circumambulation of the House? Ibn 'Abbas (Allah be pleased with them) said to him: Ask such and such woman of the Ansar, if you do not (believe my religious verdict) whether Allah's Messenger (may peace be upon him) had coimmanded her this. Zaid b Thabit (went to that lady and after getting this verdict attested by her) came back to Ibn Abbas (Allah be pleased with them) smilingly and said: I did not find you but telling the truth.

Book 7 ,Number 3060:

    'A'isha (Allah be pleased with her) reported: Safiyyah bint Huyayy entered the period of menses after performing Tawaf Ifada. I made a mention of her menses to Allah's Messenger (may peace be upon him), whereupon Allah's.Messenger (may peace be upon him) remarked: Well, then she will detain us. I said: Messenger of Allah. she has performed Tawif Ifada and circumambulated the House, and it was after this that she entered the period of menses. Thereupon Allah's Messenger (may peace be upon him) said: (If it is so), then proceed forth.

Book 7 ,Number 3061:

    This hadith is narrated (from 'A'isha) on the authority of Ibn Shihab with the same chain of transmitters (and the words are): Safiyyah bint Huyayy, the wife of Allah's Apostle (may peace be upon him), entered the period of menses at the occasion of the Farewell Pilgrimage after she had performed Tawaf Ifada in the state of cleanliness; the rest of the hadith is the same.

Book 7 ,Number 3062:

    Abd al-Rahman b. al Qasim narrated on the authority of 'A'isha (Allah be pleased with her) that she made a mention to Allah's Messenger (may peace be upon him) that Safiyyah had entered the period of menses. The rest of the hadith is the same.

Book 7 ,Number 3063:

    'A'isha (Allah be pleased with her) reported: We feared that Safiyyah might have entered the period of menses before performing Tawaf Ifada. Allah's Messenger (may peace be upon him) came to us and said: Is Safiyyah going to detain us? Thereupon we said: She has performed Tawaf Ifada. He (the Holy Prophet) said: Then there is no detention (for us) now.

Book 7 ,Number 3064:

    'A'isha (Allah be pleased with her) said to the Messenger of Allah (may peace be upon him): Messenger of Allah, Safiyyah bint Huyayy has entered the state of menses, whereupon Allah's Messenger (may peace be upon him) said: Perhaps she is going to detain us. Has she not clicumambulated the House along with you (i.e. whether she has not performed Tawaf Ifada)? They said: Yes. He said: Then they should set out.

Book 7 ,Number 3065:

    'A'isha (Allah be pleased with her) reported that Allah's Messenger (may peace be upon him) inclined to do with Safiyyah what a man feels inclined to do with his wife. They said: Messenger of Allah, she has entered the state of menses, whereupon he said: (Well) she is going to detain us. They (his wives) said: Messenger of Allah, she performed Tawaf Ziyara (Tawaf Ifada) on the Day of Nahr. Thereupon he said: Then she should proceed along with you

Book 7 ,Number 3066:

    'A'isha (Allah be pleased with her) reported: When Allah's Apostle (may peace be upon him) decided to march (for return journey), he found Safiyyah at the door of her tent, sad and downcast. He remarked. Barren, shaven-head, you are going to detain us, and then said: Did you perform Tawaf Ifada on the Day of Nahr? She replied in the affirmative, whereupon he said: Then march on.

Book 7 ,Number 3067:

    This hadith is narrated by 'A'isha (Allah be pleased with her) through another chain of transmitters, but no mention is made of "sad and downcast".

Chapter 66: THE MERIT OF ENTERING THE KA'BA FOR A PILGRIM AND OBSERVING OF PRAYER IN IT

Book 7, Number 3068:

    Ibn Umar (Allah be pleased with them) reported that Allah's Messenger (may peace, be upon him) entered the Ka'ba. Usama, Bilal and 'Uthman b. Talha, the keeper (of the Ka'ba), were along with him. He closed the door and stayed in it for some time. Ibn 'Umar (Allah be pleased with them) said: I asked Bilal as he came out what Allah's Messenger (may peace be upon him) had done there. He said: He prayed there in (such a position) that two pillars were on his left side, one pillar on his right, and three pillars were behind him, and the House at that time was resting on six pillars.

Book 7 ,Number 3069:

    Ibn Umar (Allah be pleased with them) reported: Allah's Messenger (may peace be upon him) came on the Day of Victory, and got down in the courtyard of the Ka'ba and he sent (a message) for 'Uthman b. Talha (Allah be pleased with them). He came with the key and opened the door. Allah's Apostle (may peace be upon him) then entered therein and Bilal, Usama b. Zaid, and 'Uthman b. Talha (along with him), and then commanded the door to be closed. They stayed there for a considerable time, and then the door was opened, and Abdullah said: I was the first to meet Allah's Messenger. (may peace be upon him). outside (the Ka'ba), and Bilal was close behind him. I said to Bilal: Did Allah's Messenger (may peace be upon him) observe prayer therein? He said: Yes. I said: Where? He said: Between the two pillars in front of his face. He said: I forgot to ask him as to the number of rakahs he prayed.

Book 7 ,Number 3070:

    lbn Umar (Allah be pleased with them) reported: Allah's Messenger (may peace be upon him) came daring the year of Victory on the she-camel of Usama b. Zaid until he made her kneel down in the courtyard of the Ka'ba (and got down). He then sent for 'Uthman b. Talha and said: Bring me the key. He went to his mother and she refused to give that to him. He said: By Allah, give that to him or this sword would be thrust into my side. So she gave that to him, and he came with that to Allah's Apostle (may peace be upon him) and gave that to him, and he opened the door. The rest of the hadith is the same as the above one.

Book 7 ,Number 3071:

    Ibn 'Umar (Allah be pleased with them) reported: Allah's Messenger,(may peace be upon him) entered the House, and Usama, Bilal and Uthman b. Talha were with him, and they kept the door closed for a considerable time. Then it was opened and I was the first to enter the House and meet Bilal, and I said: Where did Allah's Messenger (may peace be upon him) observe prayer? He said: Between these two front pillars. I, however, forgot to ask him the number of rak'ahs that he observed.

Book 7 ,Number 3072:

    Abdullah b. Umar reported that he reached the Ka'ba and Allah's Apostle (may peace be upon him) had entered therein, and Bilal and Usama too. 'Uthman b. Talha closed the door to them, and they stayed there for a considerable time, and then the door was opend and Allah's Apostle (may peace be upon him) came out, and I went upstairs and entered the House and said: Where did Allah's Apostle (may peace be upon him) observe prayer? They said: At this very place. I, however, forgot to ask them about the (number of) rak'ahs that he observed.

Book 7 ,Number 3073:

    Salim narrated on the authority of his father (Allah be pleased with him) that Allah's Messenger (may peace be upon him) entered the House along with Usama b. Zaid, Bilal and Uthman b. Talha. They closed the door from within, and, as they opened it, I was the first to get into it and meet Bilal, and I asked him: Did Allah's Messenger (may peace be upon him) observe prayer in it? He said: Yes, he observed prayer between these two Yemenite pillars (pillars situated towards the side of Yemen).

Book 7 ,Number 3074:

    Salim b. Abdullah reported his father (Allah be pleased with him) saying: I saw Allah's Messenger (may peace be upon him) entering the Ka'ba, and Usama b. Zaid, Bilal and 'Uthman b. Talha were along with him, but none (else) entered therein along with them. Then the door was closed for them from within. 'Abdullah b. Umar (Allah be pleased with them) said: Bilal and Uthman b. Talha informed me that Allah's Messenger (may peace be upon him) observed prayer in the interior of the Ka'ba between the two Yemenite pillars.

Book 7 ,Number 3075:

    Ibn Juraij reported: I said to 'Ata': Have you heard Ibn 'Abbas saying: You have been commanded to observe circumambulation, and not commanded to enter it (the Ka'ba) ? He ('Ata') said: He (Ibn Abbas) (at the same time) did not forbid entrance into it. I, however, heard him saying: Usama b. Zaid informed me that when Allah's Apostle (may peace be upon him) entered the House, he supplicated in all sides of it; and he did not observe prayer therein till he came out, and as he came out he observed two rak'ahs in front of the House, and said: This is your Qibla. I said to him: What is meant by its sides? Does that mean its corners? He said: (In all sides and nooks of the House) there is Qibla.

Book 7 ,Number 3076:

    Ibn Abbas (Allah be pleased with them) reported that Allah's Apostle (may peace be upon him) entered the Ka'ba, and in it there were six pillars, and he stood near a pillar and made supplication, bnt did not observe the prayer.

Book 7 ,Number 3077:

    Isma'il b. Abu Khalid reported: I asked Abdullah b. Abu Aufa (Allah be pleased with him), a Companion of Allah's Messenger (may peace be upon him), whether Allah's Apostle (may peace be upon him) had entered the House, while performing 'Umra, He said: NO.

Chapter 67: THE DEMOLISHING OF THE KA'BA AND ITS RECONSTRUCTION

Book 7, Number 3078:

    'A'isha (Allah be pleased with her) reported: Allah's Messenger may peace be upon him) said to me: Had your people not been unbelievers in the recent past (had they not quite recently accepted Islam), I would have demolished the Ka'ba and would have rebuilt it on the foundation (laid) by Ibrahim; for when the Quraish had built the Ka'ba, they reduced its (area), and I would also have built (a door) in the rear.

Book 7 ,Number 3079:

    This hadith has been narrated on the authority of Hisham with the same chain of transmitters.

Book 7 ,Number 3080:

    'A'isha, the wife of Allah's Apostle (may peace be upon him), reported Allah's Messenger (may peace be upon him) as having said this: Didn't you see that when your people built the Ka'ba, they reduced (its area with the result that it no longer remains) on the foundations (laid) by Ibrahim. I said: Messenger of Allah, why don't you rebuild it on the foundations (laid by) Ibrahim? Thereupon Allah's Messenger (may peace be upon him) said: Had your people not been new converts to Islam, I would have done that. 'Abdullah b. 'Umar (Allah be pleased with them) said: If 'A'isha (Allah be pleased with her) had heard it from Allah's Messenger (may peace be up(vn him), I would not have seen Allah's Messenger (may peace be upon him) abandoning the touching of the two corners situated near al-Hijr, but (for the fact) that it was not completed on the foundations (laid) by Ibrihim.

Book 7 ,Number 3081:

    'A'isha (Allah be pleased with her), wife of Allah's Apostle (may peace be upon him), heard Allah's Messenger (may peace be upon him) as saying: If your people, had not been recent converts to Islam, I would have spent the treasure of the Ka'ba in the way of Allah and would have constructed its door just on the level of the ground and would have encompassed in it the space of Hijr.

Book 7 ,Number 3082:

    'Abdullah b. Zubair (Allah be pleased with him) reported on the authority of his mother's sister ('A'isha) saying that Allah's Messenger (may peace be upon him) said: 'A'isha, if your people had not been recently polytheists (and new converts to Islam), I would have demolished the Ka'ba, and would have brought it to the level of the ground and would have constructed two doors, one facing the east and the other one to the west, and would have added to it six cubits of area from Hijr, for the Quraish had reduced it when they rebuilt it.

Book 7 ,Number 3083:

    'Ata' reported: The House was burnt during the time of Yazid b. Muawiya when the people of Syria had fought (in Mecca). And it happened with it (the Ka'ba) what was (in store for it). Ibn Zubair (Allah be pleased with him) felt it (in the same state) until the people came in the season (of Hajj). (The idea behind was) that he wanted to exhort them or incite them (to war) against the people of Syria. When the people had arrived he said to them: O people, advise me about the Ka'ba. Should I demolish it and then build it from its very foundation, or should I repair whatever has been damaged of it? Ibn 'Abbas said: An idea has occurred to me according to which I think that you should only repair (the portion which has been) damaged, and leave the House (in that very state in which) people embraced Islam (and leave those very stones in the same state) when people embraced Islam, and over which Allah's Apostle (may peace be upon him) had raised it. Thereupon Ibn Zubair said: It the house of any one of you is burnt, he would not be contented until he had reconstructed it, then what about the House of your Lord (which is far more Important than your house)? I would seek good advice from my Lord thrice and then I would make up (my mind) about this affair. After seeking good advice thrice, he made up his mind to demolish it. The people apprehended that calamity might fall from heaven on those persons who would be first to climb (over the building for the purpose of demolishing it), till one (took up courage, and ascended the roof), and threw down one of its stones. When the people saw no calamity befalling him, they followed him, demolished it until it was razed to the ground. Then Ibn Zubair erected pillars and hung cartains on them (in order to provide facilities to the people for observing the time of its construction). And the walls were raised; and Ibn Zubair said: I heard 'A'isha (Allah be pleased with her) say that Allah's Apostle (may peace be upon him) had observed: If the people had Rot recently (abandoned) unbelief, find I had means enough to reconstruct it, which I had not, I would have definitely excompassed in it five cubits of area from Hijr. And I would also have constructed a door for the people to enter, and a door for their exit. I today have (the means to spend) and I entertain no fearfrom the side of people (that they would protest against this change). So he added five cubits of area from the side of Hatim to it that there appeared (the old) foundation (upon which Hadrat Ibrahim had built the Ka'ba). and the people saw that and it was upon this foundation that the wall was raised. The length of the Ka'ba was eighteen cubits. when addition was made to it (which was in its breadth), then naturally the length appears to be) small (as compared with its breadth). Then addition of ten cubits (of area) was made in its length (also). Two doors were also constructed, one of which (was meant) for entrance and the other one for exit. When Ibn Zubair (Allah be pleased with him) was killed, Hajjaj wrote to 'Abd al-Malik (b. Marwan) informing him about it, and telling him that Ibn Zubair (Allah be pleased with him) had built (the Ka'ba) on those very foundations (which were laid by Ibrahim) and which reliable persons among the Meccans had seen. 'Abd al-Malik wrote to him: We are not concerned with the censuring of Ibn Zubair in anything. Keep intact the addition made by him in the side of length, and whatever he has added frem the side of Hijr revert to (its previous) foundation, and wall up the door which he had opened. Thus Hajjaj at the command of Abd al-Malik) demolished it (that portion) and rebuilt it on (its previous) foundations.

Book 7 ,Number 3084:

    Abdullah b. 'Ubaid reported that Harith b. 'Abdullah led a deputation to 'Abd al-Malik b. Marwan during his caliphate. 'Abd al-Malik said: I do riot think that Abu Khubaib (i.e. Ibn Zabair) had heard from 'A'isha (Allah be pleased with her) (about the intended wish of the Holy Prophet [may peace be upon him) In regard to the alteration of the Ka'ba). Harith said: Yes, I myself did hear from her. He ('Abd al-Malik) said: Well, tell me what you heard from her. He stated that she (Hadrat 'A'isha) had said that Allah's Messenger (may peace be upon him) remarked: Verily your people have reduced (the area) of the House from its (original foundations, and if they had not recently abandoned polytheism (and embraced Islam) I would have reversed it to (those foundations) which they had left out of it. nd if your people would take initiative after me in rebuilding it, then come along with me so that I should show you what they have left out of it. He showed her about fifteen cubits of area from the side of Hatim (that they had separated). This is the narration transmitted by 'Abdullah b. Ubaid. Walid b. 'Ata' has, however, made this addition to it: "Allah's Apostle (may peace be upon him) said: I would have made two doors on the level of the ground (facing) the east and the west. Do you know why your people raised the level of its door (i.e. the door of the Ka'ba)? She said: No. He said: (They did it) out of vanity so that (they might be in a position) to grant admittance to him only whom they wished. When a person intended to get into it, they let him climb (the stairs), and as he was about to enter, they pushed him and he fell down." 'Abd al-Malik said to Harith; Did you yourself hear her saying this? He said: Yes. He (Harith) said that he ('Abd al-Malik) scratched the ground with his staff for some time and then said: I wish I had left his (Ibn Zubair's) work there.

Book 7 ,Number 3085:

    This hadith has been narrated on the authority of Juraij with the same chain of transmitters.

Book 7 ,Number 3086:

    Abu Qaza'ah reported that while Abd al-Malik b. Marwan was circumambulating the Ka'ba he said: May Allah ruin Ibn Zubair that he lies in attributing to the Mother of the Faithful, as he says: I heard her stating that Allah's Messenger (may'peace be upon him) had said: 'A'isha, if your people had not been new converts to Islam, I would have demolished the House and would have added (in it area) from the Hijr for your people have reduced the area from its foundations. Harith b. 'Abdullah b. Abu Rabi'a (Allah be pleased with him) said: Commander of the Faithful, don't say that, for I heard the Mother of the Faithful saying this, whereupon he said: If I had heard this before demolishing it, I would have left it in the state in which Ibn Zabair had built it.

Chapter 68:THE WALL OF THE KA'BA AND ITS DOOR

Book 7, Number 3087:

    'A'isha (Allah be pleased with her) reported: I asked Allah's Messenger (may peace be upon him) about the wall, circumpassing the House (i.e. whether the wall on the side of Hijr was included in the Ka'ba). He said, Yes. I said: Then why did they not include it in the House? He said: 'Your people ran short of the means (to do so). I said: Why is it that the level of its door is raised high? He said: Your people did it so that they should admit one whom they liked, and forbid him whom they disliked, and if your people were not new converts to faith, and I did not apprehend that their hearts would feel agitated at this. I would have definitely included (the area of) this wall-in the House and would have brought the door to the level of the ground.

Book 7 ,Number 3088:

    'A'isha reported: I asked Allah's Messenger (may peace be upon him) about Hijr, and the rest of the hadith is the same. I also said: Why is it that the door has been made on a higher level, and one cannot (get into it) but with the help of a ladder? The rest of the hadith is the same as reported above and the concluding words are: (I do not change it) out of the apprehension that their hearts may disapprove of it."

Chapter 69: ONE MAY PERFORM HAJJ ON BEHALF OF THE MAIMED THE OLD AND THE DECEASED

Book 7, Number 3089:

    'Abdullah b. 'Abbas reported that while al-Fadl b. Abbas had been riding behind Allah's Messenger (may peace be upon him) a women of the tribe of Khath'am came to him (to the Holy Proppet) asking for a religious verdict. Fadl looked at her and she looked at him. Allah's Messenger (may peace be upon him) turned the face of al-Fadl to the other side. She said: Messenger of Allah, there is an obligation from Allah upon His servants in regard to Hajj. (But) my father is an aged man; he is incapable of riding safely. May I perform Hajj on his behalf? He said: Yes. It was during the Farewell Pilgrimage.

Book 7 ,Number 3090:

    Fadl reported that a woman of Banu Khath'am said: Messenger of Allah, my father is very old. There is an old obligation of Hajj upon him from Allah, but he is not capable of sitting on the back of the camel. Thereupon Allah's Apostle (may peace be upon him) said: Perform Hajj on his behalf.

Chapter 70:THE VALIDITY OF THE HAJJ PERFORMED BY A BOY AND REWARD FOR ONE WHO ENABLES HIM TO PERFORM IT (BY ACCOMPANYING HIM AND BEARING EXPENSES FOR HIM)

Book 7, Number 3091:

    Ibn Abbas reported that Allah's Apostle (may peace be upon him) met some riders at al-Rauha and asked who they were. They replied that they were Muslims. They said: Who art thou? He said: (I am) Messengef of Allah. A woman (then) lifted up a boy to him and said: Would this child be credited with having performed the Hajj? Thereupon he said: Yes, and you will have a reward.

Book 7 ,Number 3092:

    Ibn Abbas (Allah be pleased with them) reported: A woman lifted up her child and said: Messenger of Allah, would the child be credited with having performed the Hajj? Thereupon he said: Yes, and there would be a reward for you.

Book 7 ,Number 3093:

    Karaib reported: A woman lifted a child and said: Messenger of Allah, would he be credited with Hajj ? He said: Yes. and for you there would be a reward.

Book 7 ,Number 3094:

    A hadith like this has been narrated on the authority of Ibn 'Abbas through another chain of transmitters.

Chapter 71:PERFORMANCE OF HAJJ IS OBLIGATORY ONLY ONCE IN LIFE

Book 7, Number 3095:

    Abu Huraira (Allah be pleased with him) reported: Allah's Messenger (may peace be upon him) addressed us and said: O people, Allah has made Hajj obligatory for you; so perform Hajj. Thereupon a person said: Messenger of Allah, (is it to be performed) every year? He (the Holy Prophet) kept quiet, and he repeated (these words) thrice, whereupon Allah's Messenger (may peace be upon him) said: If I were to say "Yes," it would become obligatory (for you to perform it every year) and you would not be able to do it. Then he said: Leave me with what I have left to you, for those who were before you were desroyed because of excessive questioning, and their opposition to their apostles. So when I command you to do anything, do it as much as it lies in your power and when I forbid you to do anything, then abandon it.

Chapter 72: TRAVELLING OF A WOMAN WITH HER MAHRAM FOR HAJJ, ETC.

Book 7, Number 3096:

    Ibn Umar (Allah be pleased with them) reported Allah's Messenger (may peace be upon him) as saying: A woman should not set out on three (days' journey) except when she has a Mahram with her.

Book 7 ,Number 3097:

    This hadith has been narrated on the same authority by Ubaidullah. And in the narration of Abu Bakr (the words are): "More than three (days)." Ibn Numair narrated on the authority of his father, (and the words are): "Three (days) except (when) she has a Mahram with her."

Book 7 ,Number 3098:

    'Abdullah b. Umar (Allah -be pleased with them) reported Allah's Apostle (may peace be upon him) as saying: It is not lawful for a woman who believes in Allah and the Hereafter to travel for more than three nights journey except when there is a Mahram with her.

Book 7 ,Number 3099:

    Qaza'ah reported: I heard a hadith from Abu Sa'id (Allah be pleased with him) and it impressed me (very much), so I said to him: Did you hear it (yourself) from Allah's Messenger (may peace be upon him) ? Thereupon he said: (Can) I speak of anything about Allah's Messenger (may peace be upon him) which I did not bear? He said: I heard Allah's Messenger (may peace be upon him) saying: Do not set out on a journey (for religious devotion) but for the three mosques-for this mosque of mine (at Medina) the Sacred Mosque (at Mecca), and the Mosque al-Aqsa (Bait al-Maqdis), and I heard him saying also: A woman should not travel for two days duration, but only when there is a Mahram with her or her husband.

Book 7 ,Number 3100:

    Qaza'ah reported: I heard Abu Sa'id al-Khudri (Allah be pleased with him) saying: I heard four things from Allah's Messenger (may peace be upon him) which impressed me and captivated me (and one out of these is this), that he forbade a woman to undertake journey extending over two days but with her husband, or with a Mahram; and he then narrated the rest of the hadith.

Book 7 ,Number 3101:

    Abu Sa'id (Allah be pleased with him) reported Allah's Messenger (may peace be upon him) as saying: A woman should not set out on three (days') journey, but in the company of a Mahram.

Book 7 ,Number 3102:

    Abu Sa'id Khudri (Allah be pleased with him) reported Allah's Apostle (may peace be upon him) as saying: A woman should not set out on a journey extending beyond three nights but with a Mahram.

Book 7 ,Number 3103:

    This hadith has been narrated on the authority of Qatada with the same chain of transmitters and he said: "More than three (days) except in the company of a Mahram."

Book 7 ,Number 3104:

    Abu Huraira (Allah be pleased with him) reported Allah's Messenger (may peace be upon him) as saying: It is not lawful for a Muslim woman to travel a night's journey except when there is a Mahram with her.

Book 7 ,Number 3105:

    Abu Huraira (Allah be pleased with him) reported Allah's Apostle (may peace be upon him) as saying: It is not lawful for a woman who believes in Allah and the Hereafter to undertake a day's journey except in the company of a Mahram.

Book 7 ,Number 3106:

    Abu Huraira (Allah be pleased with him) reported Allah's Messenger (may peace be upon him) as saying: It is not lawful for a woman believing in Allah and the Hereafter to undertake journey extending over a day and a night except when there is a Mahram with her.

Book 7 ,Number 3107:

    Abu Huraira (Allah be pleased with him) reported Allah's Messenger (may peace be upon him) as saying: It is not lawful for a woman to undertake three (days,) journey except when there is a Mahram with her.

Book 7 ,Number 3108:

    Abu Sa'id al-Khudri (Allah be pleased with him) reported Allah's Messenger (may peace be upon him) as saying: It is not lawful for a woman believing in Allah and the Hereafter to undertake journey extending over three days or more, except when she is in the company of her father, or her son, or her husband, or her brother, or any other Mahram.

Book 7 ,Number 3109:

    A hadith like this has been narrated by A'mash with the same chain of transmitters.

Book 7 ,Number 3110:

    Ibn 'Abbas (Allah be pleased with them) reported: I heard Allah's Messenger (may peace be upon him) delivering a sermon and making this observation: "No person should be alone with a woman except when there is a Mahram with her, and the woman should not undertake journey except with a Mahram." A person stood up and said: Allah's Messenger, my wife has set out for pilgrimage, whereas I am enlisted to fight in such and such battle, whereupon he said: "You go and perform Hajj with your wife."

Book 7 ,Number 3111:

    A hadith like this has been narrated by 'Amr on the authority of the same chain of transmitters.

Book 7 ,Number 3112:

    Ibn Juraij narrated this hadith with the same chain of transmitters, but he made no mention of it: "No person should be alone with a woman except when there is a Mahram with her."

Chapter 73:WHAT IS TO BE UTTERED WHEN ONE SETS OUT FOR HAJJ OR ANY OTHER JOURNEY

Book 7, Number 3113:

    Ibn Umar (Allah be pleased with them) reported that whenever Allah's Messenger (may peace be upon him) mounted his camel while setting out on a journey, he glorified Allah (uttered Allah-o-Akbar) thrice, and then said: Hallowed is He Who subdued for us this (ride) and we were not ourselves powerful enough to use It as a ride, and we are going to return to our Lord. O Allah, we seek virtue and piety from Thee in this journey of ours and the act which pleaseth Thee. O Allah, lighten this journey of ours, and make its distance easy for us. O Allah, Thou art (our) companion during the journey, and guardian of (our) family. O Allah, I seek refuge with Thee from hardships of the journey, gloominess of the sights, and finding of evil changes in property and family on return. And he (the Holy Prophet) uttered (these words), and made this addition to them: We are returning, repentant, worshipping our Lord. and praising Him.

Book 7 ,Number 3114:

    Abdullah b. Sarjis (Allah be pleased with him) reported that when Allah's Messenger (may peace be upon him) set forth on a journey, he sought refuge (with Allah) from the hardships of the travelling, and finding of evil changes on return, and disgrace after honour, and the curse of the oppressed and a gloomy sad scene in family and property.

Book 7 ,Number 3115:

    A hadlth like this has been narrated on the authority of Asim With the same chain of transmitters except (this difference) that the hadith transmitted by 'Abd al-Wahid (one of the narrators) the (word) "property" precedes the family, and in the hadith transmitted by Mahammad b. Khazim (the word) "family" precedes (theword "Property"), on returning home, in the narrations of both the narrators (these words are found): "O Allah I seek refuge with Thee from the hardships of the journey."

Chapter 74:WHAT IS TO BE RECITED ON RETURN FROM THE JOURNEY OF HAJJ OR ANY OTHER JOURNEY

Book 7, Number 3116:

    Abdullah b. 'Umar reported that whenever Allah's Messenger (may peace be upon him) came back from the battle or from expeditions or from Hajj or Umra and as he reached the top of the hillock or upon the elevated hard ground, he uttered Allah-o- Akbar thrice, and then said: There is no god but Allah. He is One, there is no partner with Him, His is the sovereignty and His is the praise and He is Potent over everything. (We are) returning,repenting, worshipping, prostrating before our Lord, and we praise Him Allah fulfilled His promise and helped His servant, and routed the confederates alone.

Book 7 ,Number 3117:

    This hadith has been narrated on the authority of Ibn Umar through another chain of transmitters (but with one alteration) that here Allah-o-Akbar is mentioned twice.

Book 7 ,Number 3118:

    Anas b. Malik (Allah be pleased with him) reported: I and Abu Talha (both) came back along with Allah's Apostle (may peace be upon him). Safiyyah (the wife of the Holy Prophet) rode behind him on his camel and as we came to the out- skirts of Medina he said: (We are those) who return, who repent, who worship our Lord, who praise (Him), and he went on uttering this until we entered Medina.

Book 7 ,Number 3119:

    A hadith like this has been narrated by Anas b. Malik (Allah be pleased with him) through another chain of transmitters.

Chapter 75: STAYING AT DHU'L-HULAIFA AND OBSERVING OF PRAYER THERE, WHILE RETURNING FROM HAJJ OR 'UMRA

Book 7, Number 3120:

    Abdullah b. 'Umar (Allah be pleased with them) reported that Allah's Messenger (may peace be upon him) made (his camel) kneel down (i,e. halt at the stony ground of Dhu'l-Hulaifa) and prayed there, and so did Abdullah b. Umar (Allah be pleased with them).

Book 7 ,Number 3121:

    Nafi' reported that 'Abdullah b. Umar (Allah be pleased with them) used to halt his camel in the stony ground at Dhu'l-Hulaifa, where Allah's Messenger (may peace be upon him) used to make a halt (and pray).

Book 7 ,Number 3122:

    Nafi' reported that when 'Abdullah b. 'Umar returned from Hajj or 'Umra he made his camel kneel down (i.e. halted) in the stony ground of Dhu'l-Hulaifa where Allah's Messenger (may peace be upon him) had made his camel halt.

Book 7 ,Number 3123:

    Salim (b. Abdullah b. 'Umar) reported on the authority of his father (Allah be pleased with them) that Allah's Apostle (may peace be upon him) was visited by (someone, i.e. an angel) during the fag end of the night at Dhu'l-Hulaifa, and it was said to him: Verily it is a blessed stony-ground.

Book 7 ,Number 3124:

    Salim b. Abdullah b. Umar reported on the authority of his father (Allah be pleased with them) that Allah's Apostle (may peace be upon him) came to Dhu'l- Hulaifa in the heart of the valley at the fag end of the night, and it was said to him: It is a blessed stony ground. Musa (one of the narrators) said: Salim made his came) halt at the mosque where 'Abdullah made his camel halt as seeking the place of stay of Allah's Messenger (may peace be upon him). It is, in fact, situated at a lower plain than the mosque, which stands in the heart of the valley, and it is between it (the mosque) (and Qibla) that that place (where Allah's Apostle used to get down for rest and prayer) is situated.

Chapter 76:NO POLYTHEIST IS AUTHORISED TO PERFORM PILGRIMAGE OF THE KA'BA AND CIRCUMAMBULATE THE HOUSE NAKED AND THE DESCRIPTION OF THE GREAT HAJJ

Book 7, Number 3125:

    Abu Huraira (Allah be pleased with him) reported: Abu Bakr Siddiq (Allah be pleased with him) sent me during Hajj before the Farewell Pilgrimage for which Allah's Messenger (may peace be upon him) had appointed him an Amir, among a group of people whom he had ordered to make announcement to the people on the Day of Nahr: "After this year no polytheist may perform the Pilgrimage and no naked person may circumambulate the House." Ibn Shihab stated that Humaid b. Abd al-Rahman said that according to this narration of Abu Huraira (Allah be pleased with him) the day of Hajj al-Akbar (Great Hajj) is this Day of Nahr (10th of Dhu'l-Hijja).

Chapter 77:THE MERIT OF HAJJ AND UMRA AND THE DAY OF 'ARAFA (THE 9TH OF DHU'L-HIJJA)

Book 7, Number 3126:

    'A'isha (Allah be pleased with her) reported Allah's Messenger (may peace be upon him) as saying: There is no day when God sets free more servants from Hell than the Day of 'Arafa. He draws near, then praises them to the angels, saying: What do these want?

Book 7 ,Number 3127:

    Abu Huraira (Allah be pleased with him) reported Allah's Messenger (may peace be upon him) as saying: An Umra is an expiation for the sins committed between it and the next, and Hajj which is accepted will receive no other reward than Paradise.

Book 7 ,Number 3128:

    This hadith has been narrated on the authority of Abu Huraira (Allah be pleased with him) through another chain of transmitters.

Book 7 ,Number 3129:

    Abu Huraira (Allah be pleased with him) reported Allah's Messenger (may peace be upon him) as saying. He who came to this House (Ka'ba) (with the intention of performing Pilgrimage), and neither spoke indecently nor did he act wickedly. would return (free from sin) as on the (very first day) his mother bore him.

Book 7 ,Number 3130:

    This hadith has been narrated on the authority of Mainsur with the same chain of transmitters (and the words are): "He who performed Pilgrimage but neither spoke indecently nor acted wickedly."

Book 7 ,Number 3131:

    A hadith like this has been narrated on the authority of Abu Huraira (Allah be pleased with him).

Chapter 78: ENCAMPING OF PILGRIMS IN MECCA AND INHERITING OF (THE PROPERTY OF THEIR ANCESTORS)

Book 7, Number 3132:

    Usama b. Zaid b. Haritha (Allah be pleased with him) said to Alla's Messenger (may peace be upon him): Will you stay in your house at Mecca (which you abandoned at the time of migration)? Thereupon he said: Has 'Aqil left for as any land or house? And 'Aqil and Talib became the Inheritors of Abu Talib's (property), and neither Ja'far nor 'Ali inherited anything from him, for both (Ja'far and 'Ali) were Muslims whereas 'Aqil and Talib were non-Muslims.

Book 7 ,Number 3133:

    Usama b. Zaid (Allah be pleased with him) said: Allah's Messenger,God willing, where will you stay tomorrow? And it was at the time of the Conquest (of Mecca). Thereupon he (the Holy Prophet) said: Has 'Aqil left any accommodation for us?

Chapter 79:THE MUHAJIR IS PERMITTED TO STAY FOR THREE DAYS IN MECCA AFTER HAJJ AND UMRA AND NOT MORE THAN THIS

Book 7, Number 3134:

    Al-'Ali' b. al-Hadrami reported Allah's Messenger (may peace he upon as saying: For a Mahijir, it is only three (days') stay at Mecca, after completing (the Hajj or 'Umra) that is allowed, and it seemed as if he was saying that he should not (stay) beyond this (period).

Book 7 ,Number 3135:

    Al-'Ali,' b. al-Hadrami reported Allah's Messenger (may peace be upon him) as saying: The Muhijir should stay at Mecca after performing the rituals (of Hajj) but for three (days) only.

Book 7 ,Number 3136:

    Al-'Ala' b. al-Hadrami reported Allah's Messenger (may peace be upon him) as saying: It is only for three nights that a Muhajir should stay at Mecca after the completion of the rituals of Hajj.

Book 7 ,Number 3137:

    Al-"Ala' b. al-Hadrami reported Allah's Messenger (may peace be upon him) as saying: The stay at Mecca after the completion of his rituals (of Hajj) is only for three days.

Book 7 ,Number 3138:

    Ibn Juraij narrated this hadith with the same chain of transmitters.

Chapter 80: THE SACRED TERRITORY OF MECCA AND ITS INVIOLABILITY AND THE PROHIBITION TO DO HUNTING IN IT AND ITS SUBURBS, AND FELLING DOWN OF ITS TREES AND CUTTING ITS GRASS

Book 7, Number 3139:

    Ibn 'Abbas (Allah be pleased with him) reported Allah's Messenger (may peace be upon him) as saying on the Day of Victory over Mecca: There is no Hijra (emigration) but only Jihad and good intention; and when you are called to battle, then go forth. He also said on the Day of Victory over Mecca: Allah made this town sacred on the day He created the earth and the heavens; so it is -sacred by the sacred- ness conferred on it by Allah until the Day of Resurrection and fighting in it was not lawful to anyone before me, and it was made lawful for me only during an hour on one day, for it is sacred by the sacredness conferred on it by Allah until the Day of Resurrection. Its thorns are not to be cut, its game is not to be molested, and the things dropped are to be picked up only by one who makes a public announcement of it, and its fresh herbage is not to be cut. Abbas (Allah be pleased with him) said: Messenger of Allah, exception may be made in case of rush, for it is useful for their blacksmiths and for their houses. He (the Holy Prophet) conceding the suggestion of 'Abbas) said: Except rush.

Book 7 ,Number 3140:

    A hadith like this has been narrated on the authority of Mansur, but he did not mention: "On that very day He created the heavens and the earth," and he (the narrator) substituted the word "fighting" (qital) for "killing" (qatl), and further said: "No one is to pick up the dropped thing except one who makes a public announcement of it."

Book 7 ,Number 3141:

    Abu Shuraih al-'Adawi reported that he said to Amr b. Sa'id when he was sending troops to Mecca: Let me tell you something. O Commander, which Allah's Messenger (may peace be upon him) said on the day following, the Conquest which my ears heard and my heart has retained, and my eyes saw as he spoke it. He praised Allah and extolled Him and then said: Allah, not men, has made Mecca sacred; so it is not permissible for any person believing in Allah and the Last Day to shed blood in it, or lop a tree in it. If anyone seeks a concession on the basis of fighting of Allah's Messenger (may peace be upon him), tell him that Allah permitted His Messenger, but not you, and He gave him permission only for an hour on one day, and its sacredness was restored on the very day like that of yesterday. Let him who is present convey the information to him who is absent. It was said to Abu Shuraih: What did Amr say to you? He said: I am better informed of that than you, Abu Shuraih, but the sacred territory does not grant protection to one who is disobedient, or one who runs away after shedding blood, or one who runs away after committing

Book 7 ,Number 3142:

    Abu Huraira, (Allah be pleased with him) reported. When Allah, the Exalted and Majestic, granted Allah's Messenger (may peace be upon him) victory over Mecca, he stood before people and praised and extolled Allah and then said: Verily Allah held back the elephants from Mecca and gave the domination of it to His Messenger and believers, and it (this territory) was not violable to anyone before me and it was made violable to me for an hour of a day, and it shall not be violable to anyone after me. So neither molest the game, nor weed out thorns from it. And it is not lawful for anyone to pick up a thing dropped but one who makes public announcement of it. And it a relative of anyone is killed he is entitled to opt for one of two things. Either he should be paid blood-money or he can take life as (a just retribution). 'Abbas (Allah be pleased with him) said: Allah's Messenger, but Idhkhir (a kind of herbage), for we use it for our graves and for our houses, whereupon Allah's Messenger (may peace be upon him) said: With the exception of Idhkhir. A person known as Abu Shah, one of the people of Yemen, stood up and said: Messenger of Allah, (kindly) write it for me. Thereupon Allah's Messenger (may peace be upon him) said I Write it for Abu Shah. Walid said: I asked al-Auzai': What did his saying mean: "Write it for me, Messenger of Allah"? He said: This very address that he had heard from Allah's Messenger (may peace be upon him).

Book 7 ,Number 3143:

    Abu Huraira(Allah be pleased with him)reported: The people of the Khuza'ah tribe killed a man of the tribe of Laith in the Year of Victory as a retaliation for one whom they had killed (whom the people of the tribe of Laith had killed). It was reported to Allah's Messenger (may peace be upon him). He mounted his camel and delivered this address: Verily Allah, the Exalted and Majestic, held back the Ele- phants from Mecca, and gave its domination to His Messenger and believers. Behold, it was not violable for anyone before me and it will not be violable for anyone after me. Behold, it was made violable for me for an hour of a day; and at this very hour it has again been made inviolable (for me as well as for others). So its thorns are not to be cut, its trees are not to be lopped, and (no one is allowed to) pick up a thing dropped, but the one who makes an announcement of it. And one whose fellow is killed is allowed to opt between two alternatives: either he should receive blood-money or get the life of the (murderer) in return. He (the narrator said): A person from the Yemen, who was called Abu Shah, came to him and said: Messenger of Allah, write it down for me, whereupon he (Allah's Messenger) said: Write it down for Abu Shah. One of the persons from among the Quraish also said: Except Idhkhir, for we use it in our houses ant our graves. Thereupon Allah's Messenger (may peace be upon him) said: Except Idhkhir.

Book 7 ,Number 3144:

    Jabir (Allah be pleased with him) reported: I heard Allah's Apostle (may peace be upon him) say: It is not permissible for any one of you to carry weapons in Mecca.

Chapter 81: IT IS PERMISSIBLE TO ENTER MECCA WITHOUT IHRAM

Book 7, Number 3145:

    Anas b. Malik (Allah be pleased with them) reported that Allah's Apostle (may peace be upon him) entered Mecca in the Year of Victory with a helmet on his head; and when he took it off, a man came to him and said: Ibn Khatal is hanging on to the curtains of the Ka'ba, whereupon he said: Kill him. Malik (one of the narrators) attested this statement having been made.

Book 7 ,Number 3146:

    Jabir b. 'Abdullah al-Ansari (Allah be pleased with them) reported that Allah's Messenger (may peace be upon him) entered Mecca and Qutaiba (another narrator) stated that he entered Mecca in the Year of Victory, wearing a black turban, but not wearing the Ihram.

Book 7 ,Number 3147:

    Jabir b. Abdullah reported that Allah's Apostle (may peace be upon him) entered on the day of Victory of Mecca wearing a black turban on his head. and she said: In case Allah cures me I will certainly go and observe prayer in Bait al-Maqdis. She recovered and so she made preparations to go out (to that place). She came to Maimuna. the wife of Allah's Apostle (may peace be upon him). and after greeting her she informed her about it, whereupon she said: Stay here. and eat the provision (which you had made) and observe prayer In the mosque of the Messenger (may peace be upon him). for I heard Allah's Messenger (may peace be upon him) say: Prayer in it is better than a thousand prayers observed in other mosques except the mosque of the Ka'ba.

Book 7, Number 3148:

    Amr b. Huraith reported on the authority of his father that Allah's Messenger (may peace be upon him) addressed the people (on the day of the Victory of Mecca) with a black turban on his head.

Book 7, Number 3149:

    Ja'far b. 'Amr b. Huraith reported his father as saying: As if I am seeing Allah's Messenger (may peace be upon him) on the pulpit with a black turban on his head, and its two ends hanging between his shoulders. Abu Bakr (another narrator) did not make mention of: "Upon the pulpit".

Chapter 82 : EMINENCE OF MEDINA. ALLAH'S APOSTLE (MAY PEACE BE UPON HIM) SHOWERED BLESSINGS UPON IT, ITS SACREDNESS,AND UNLAWFULNESS OF HUNTING AND LOPPING OF TREES AND DEMARCATION ITS PRECINCTS

Book 7, Number 3150:

    'Abdullah b. Zaid b. 'Asim (Allah be pleased with him) reported Allah's Messenger (may peace be upon him) as saying: Verily Ibrahim declared Mecca sacred and supplicated (for blessings to be showered) upon its inhabitants, and I declare Medina to be sacred as lbrahim had declared Mecca to be sacred. I have supplicated (Allah for His blessings to be showered) in its sa' and its mudd (two standards of weight and measurement) twice as did Ibrahim for the inhabitants of Mecca. This hadith has been narrated through another chain of transmitters with a slight varia- tion of words.

Book 7, Number 3151:

    Rafi' b. Khadij reported Allah's Messenger (may peace be upon him) as saying: Ibrahim declared Mecca as sacred and I declare sacred the area between its two stony grounds (lava lands by which he meant Medina).

Book 7, Number 3152:

    Nafi' b. Jubair reported that Marwan b. al-Hakam (Allah be pleased with him) addressed people and made mention of Mecca and its inhabitants and its sacredness, but he made no mention of Medina, its inhabitants and its sacredness. Rafi' b. Khadij called to him and said: What is this that I hear you making mention of Mecca and its inhabitants and its sacredness, but you did not make mention of Medina and its inhabitants and its sacredness, while the Apostle of Allah (may peace be upon him) has also declared sacred (the area) between its two lava lands (Medina) ? And (we have record of this) with us written on Khaulani parchment. If you like, I can read it out to you. Thereupon Marwan became silent, and then Said: I too have heard some part of it.

Book 7, Number 3153:

    Jabir (Allah be pleased with him) reported Allah's Apostle (may peace be upon him) as saying: Ibrahim declared Mecca as sacred; I declare Medina, that between the two mountains, as inviolable. No tree should be lopped and no game is to be molested.

Book 7, Number 3154:

    Amir b. Sa'd reported on the authority of his father (Allah be pleased with him) that Allah's Messenger (may peace be upon him) said: I have declared sacred the territory between the two lava plains of Medina, so its trees should not be cut down, or its game killed; and he also said: Medina is best for them if they knew. No one leaves it through dislike of it without Allah putting in it someone better than he in place of him; and no one will stay there in spite of its hardships and distress without my being an intercessor or witness on behalf of him on the Day of Resurrection.

Book 7, Number 3155:

    'Amir b. Sa'd b. Abu Waqqas reported on the authority of his father (Allah be pleased with him) that Allah's Messenger (may peace be upon him) said, and then the (above-mentioned) hadith was narrated with this addition: "None should nurse ill-will towards the people of Medina, or Allah will melt him in fire like the melting of lead or the dissolution of salt in water.

Book 7, Number 3156:

    'Amir b. Sa'd reported that Sa'd rode to his castle in al-'Aqiq and found a slave cutting down the trees, or beating off their leaves, so he stripped him off his belongings. When Sa'd returned, there came to him the masters of the slave and negotiated with him asking him to return to their slave or to them what he had taken from their slave, whereupon he said: God forbid that I should return anything which Allah's Messenger (may peace be upon him) has given me as spoil, and refused to return anything to them.

Book 7, Number 3157:

    Anas b. Malik (Allah be pleased with him) reported that Allah's Messenger (may peace be upon him) said to Abu Talha (Allah be pleased with him): Find for me a servant from amongst your boys to serve me. Abu Talha went out along with me and made me sit behind him. And I used to serve Allah's Messenger (may peace be upon him) whenever he got down from the camel. And in one hadith he said: He proceeded and when (the mountain of) Uhud was within sight, he said: This is the mountain which loves us and we love it. And as he came close to Medina he said: O Allah, I declare (the area) between the two mountains of it (Medina) sacred just as Ibrahim declared Mecca as sacred. O Allah, bless them (the people of Medina) in their mudd and sa'.

Book 7, Number 3158:

    Anas b. Malik reported a hadith like this from Allah's Apostle (may peace be upon him) except with this variation that he said: "I declare sacred the area between its two lava mountains."

Book 7, Number 3159:

    'Asim reported: I asked Anas b. Malik whether Allah's Messenger (may peace be upon him) had declared Medina as sacred. He said: Yes. (the area) between so and so. He who made any innovation in it, and further said to me: It is something serious to make any innovation in it (and he who does it) there is upon him the curse of Allah, and that of the angels and of all the people, Allah will not accept from him on the Day of Resurrection either obligatory acts or the surpererogatory acts. Ibn Anas said: Or he accommodates an innovator.

Book 7, Number 3160:

    'Asim reported: I asked Anas (Allah be pleased with him) whether Allah's Messenger (may peace be upon him) had declared Medina as sacred. He said: Yes, it is sacred, so its tree is not to be cut; and he who did that let the curse of Allah and that of the angels and of all people be upon him.

Book 7, Number 3161:

    Anas b. Malik (Allah be pleased with him) reported that Allah's Messenger (may peace be upon him) said: Allah bless them in their measurements, bless them in their sa's and bless them in their mudd.

Book 7, Number 3162:

    Anas b. Malik (Allah he pleased with him) reported that Allah's Messenger (may peace be upon him) said: O Allah, increase in Medina twice the blessings (Thou showered) on Mecca.

Book 7, Number 3163:

    Ibrahim al-Taimi reported on the authority of his father: 'Ali b. Abi Talib (Allah be pleased with him) addressed us and said: He who thought that we have besides the Holy Qur'an anything else that we recite, he told a lie. And this document which is hanging by the sheath of the sword contains but the ages of the camels, and the nature of the wounds. He (Hadrat 'Ali) reported Allah's Apostle (may peace be upon him) as saying: Medina is sacred from 'Air to Thaur; So if anyone makes an innovation or accommodates an innovator, the curse of Allah, the angels, and all persons will fall upon him, and Allah will not accept any obligatory or supererogatory act as recompense from them. And the protection granted by the Muslims is one and must be respected by the humblest of them. If anyone makes a false claim to paternity, or being a client of other than his own masters, there is upon him the curse of Allah, the angels, and all the people. Allah will not accept from him any recompense in the form of obligatory acts or supererogatory acts. The hadith transmitted on the authority of Abu Bakr and Zabair ends with (these words): The humblest among them should respect it; and what follows after it is not mentioned there, and in the hadith transmitted by them (these words are) not found: (The document was hanging) on the sheath of his sword.

Book 7, Number 3164:

    A hadith like this has been narrated on the authority of A'mash with the same chain of transmitters (but at the end) these words are added: "He who violated the covenant with a Muslim, there is upon him the curse of Allah, of angels and of all people. Neither an obligatory act nor a supererogatory act would be accepted from him as recompense on the Day of Resurrection; and in the hadith transmitted by two other narrators these words are not found: "He who claimed false paternity." And in the hadith transmitted by Waki' there is no mention of the Day of Resurrection.

Book 7, Number 3165:

    A hadith like this has been narrated with the same chain of transmitters by A'mash with a slight variation of words.

Book 7, Number 3166:

    Abu Huraira (Allah be pleased with him) reported Allah's Apostle (may peace be upon him) as saying: Medina is a sacred territory, so he who made any innovation in it. or gave protection to an innovator, there is upon him the curse of Allah, that of the angels and that of all the people. There would not be accepted on the Day of Resurrection either obligatory acts or supererogatory acts from him.

Book 7, Number 3167:

    A hadith like this has been narrated on the authority of A'mash with the same chain of transmitters, but no mention has been made of the Day of Resurrection. But this addition is made: "The protection granted by Muslims is one and must be respected by the humblest of them. And he who broke the covenant made by a Muslim, there is a curse of Allah, of his angels, and of the whole people upon him, and neither an obligatory act nor a supererogatory act would be accepted from him as recompense on the Day of Resurrection."

Book 7, Number 3168:

    Abu Huraira (Allah be pleased with him) reported: If I were to see deer grazing in Medina, I would have never molested them, for Allah's Messenger (may peace be upon him) has stated: There is between the two lava mountains a sacred territory.

Book 7, Number 3169:

    Abu Huraira (Allah be pleased with him) reported that Allah's Messenger (may peace be upon him) declared sacred the territory between two lava mountains of Medina. Abu Huraira said: If I were to find deer in the territory between the two mountains, I would not molest them, and he (the Holy Prophet) declared twelve miles of suburb around Medina as a prohibited pasture.

Book 7, Number 3170:

    Abu Huraira (Allah be pleased with him) reported that when the people saw the first fruit (of the season or of plantation) they brought it to Allah's Apostle (may peace be upon him). When he received it he said: O Allah, bless us in our fruits; and bless us in our city; and bless us in our sa's and bless us in our mudd. O Allah, Ibrahim was Thy servant, Thy friend, and Thy apostle; and I am Thy servant and Thy apostle. He (Ibrahim) made supplication to Thee for (the showering of blessings upon) Mecca, and I am making supplication to Thee for Medina just as he made supplication to Thee for Mecca, and the like of it in addition. He would then call to him the youngest child and give him these fruits.

Book 7, Number 3171:

    Abu Huraira (Allah be pleased with him) reported that Allah's Messenger (may peace be upon him) was given the first fruit and he said: O Allah, shower blessings upon us in our city, and in our fruits, in our mudd and in our sa's, blessings upon blessings, and he would then give that to the youngest of the children present there.

Book 7, Number 3172:

    Abu Sa'id Maula al-Mahri reported that they were hard pressed by the distress and hardship of Medina, and he come to AbU Sa'Id al-Khudri and said to him: I have a large family (to support) and we are enduring hardships; I have, therefore, made up my mind to take my family to some fertile land. Thereupon Abu Sa'id said: Don't do that, stick to Medina, for we have come out with Allah's Apostle (may peace be upon him), and (I think that he also said) until we reached 'Usfan, and he (the Holy Prophet along with his Companions) stayed there for some nights. There the people said: By Allah, we are lying here idle, whereas our children are unprotected behind us, and we do not feel secure about them. This (apprehension of theirs) reached Allah's Apostle (may peace be upon him), whereupon he said: What is this matter concerning you that has reached me? (I do not retain how he said it, whether he said like this:) By Him (in the name of Whom) I take oath, (or he said like this:) By Him in Whose Hand is my life, I made up my mind or if you like (I do not retain what word did he actually say), I should command my camel to proceed and not to let it halt until it comes to Medina and then said: Ibrahim declared Mecca as the sacred territory and it became sacred, and I declare Medina as the sacred territory-the area between the two mountains ('Air and Uhud). Thus no blood is to be shed within its (bounds) and no weapon is to be carried for fighting, and the leaves of the trees there should not be beaten off except for fodder. O Allah, bless us in our city; O Allab, bless us in our sil; O Allah, bless us in our mudd; O Allah, bless us in our sa; O Allah, bless us in our mudd. O Allah, bless us in our city. O Allah, bless with this blessing two more blessings. By Him in Whose Hand is my life, there is no ravine or mountain path of Medina which is not protected by two angels until you reach there. (He then said to the people:) Proceed, and we, therefore, proceeded and we came to Medina By Him (in Whose name) we take oath and (in Whose name) oath is taken (Hammad is in doubt about it), we had hardly put down our camel saddles on arriving at Medina that we were attacked by the people of the tribe of 'Abdullah b. Ghatafan but none dared to do it before.

Book 7, Number 3173:

    Abu Sa'id al-Kbudri (Allah be pleased with him) reported that Allah's Messenger (may peace be upon him) said: O Allah, bless us in our sa' and mud and shower with its blessings two other blessings (multiply blessings showerted upon it).

Book 7, Number 3174:

    A hadith like this has been narrated by Yabya b. Abu Kathir with the same chain of transmitters.

Book 7, Number 3175:

    Abu Sa'id Maula al-Mahri reported that he came to Abu Sa'id al-Khudri during the nights (of the turmoil) of al-Barrah, and sought his advice about leaving Medina, and complained of the high prices prevailing therein and his large family, and informed him that he could not stand the hardships of Medina and its rugged surrounding. He said to him: Woe to you; I will not advise you to do it, for I heard Allah's Messenger (may peace be upon him) as saying: No one will endure hardships of Medina without my being an intercessor or a witness on his behalf on the Day of Resurrectiar), if he is a Muslim.

Book 7, Number 3176:

    Abd al-Rahman reported on the authority of his father Abu Sa'id (Allah be pleased with him) that he heard Allah's Messenger (may peace be upon him) as saying: I have declared sacred what is between the two lava grounds of Medina just as Ibrahim (peace be upon him) declared Mecca as sacred. He (the narrator) then said: Abu Sa'id caught hold of (Abu Bakr, another narrator, used the word "found") a bird in his hand and then released it from his hand and set it free.

Book 7, Number 3177:

    Sahl b. Hunif reported that Allah's Messenger (may peace be upon him) pointed with his hands towards Medina and said: That is a sacred territory and a place of safety.

Book 7, Number 3178:

    'A'isha (Allah be pleased with her) reported: When we came to Medina, and it was an unhealthy, uncogenial place, Abu Bakr fell sick and Bilal also fell sick; and when Allah's Messenger (may peace be upon him) saw the illness of his Companions he said: O Allah, make Medina as congenial to us as you made Mecca congenial or more than that; make it conducive to health, and bleesus in its sa' and in its mudd, and transfer its fever to al-juhfa.

Book 7, Number 3179:

    This hadith has been narrated by Hisham b. 'Urwa with the same chain of transmitters.

Book 7, Number 3180:

    Ibn 'Umar (Allah be pleased with them) reported Allah's Messenger (may peace be upon him) as saying: He who patiently endures the hardships of it (of this city of Medina), I would be an intercessor or a withness on his behalf on the Day of Resurrection.

Book 7, Number 3181:

    Yuhannis, the freed slave of Zubair, narrated that when he was sitting with Abdullah b. 'Umar (Allah be pleased with him) during the days of turmoil, his freed slave-girl came to him. After saluting him she said: Abu Abd al-Rahmin, I have decided to leave (Medina) for the time is hard for us, whereupon Abdullah said to her: Stay here, foolish lady, for I have heard Allah's Messenger (may peace be upon him) as saying: For one who shows endurance on the hardships and rigour of it (of Medina) I would be an intercessor or a witness on his behalf on the Day of Resurrection.

Book 7, Number 3182:

    Abdullah b. 'Umar (Allah be pleased with them) said: I heard Allah's Messenger (may peace be upon him) as saying: He who patiently endured the hardships and rigours of (this city, i.e. Medina), I would be his witness and intercessor on the Day of Resurrection.

Book 7, Number 3183:

    Abu Huraira (Allah be pleased with him) reported the Apostle of Allah (may peace be upon him) as saying: For one among my Ummah who shows endurance against the hardships and rigours of Medina, I would be an intercessor or a witness on his behalf on the Day of Resurrection.

Book 7, Number 3184:

    A hadith like this has been narrated on the authority of Abu Huraira (Allah be pleased with him) through another chain of transmitters.

Book 7, Number 3185:

    Abu Huraira (Allah be pleased with him) reported Allah's Messenger (may peace be upon him) as saying: None who shows endurance on the hardships of Medina, ... (the rest of the hadith is the same).

Chapter 83 : THE SECURITY OF MEDINA AGAINST PLAGUE AND DAJJAL

Book 7, Number 3186:

    Abu Huraira (Allah be pleased with him) reported Allah's Messenger (may peace be upon him) as saying: There are at the approaches of Medina angels so that plague and the Dajjal shall not penetrate into it.

Book 7, Number 3187:

    Abu Huraira (Allah be pleased with him) reported Allah's Messenger (may peace be upon him) as saying: Dajjal will come from the eastern side with the intention of attacking Medina until he will get down behind Uhud. Then the angels will turn his face towards Syria and there he will perish.

Chapter 84 : MEDINA WIPES OUT EVIL FROM IT AND ITS OTHER NAMES ARE TABBA AND TAIBA

Book 7, Number 3188:

    Abu Huraira (Allah be pleased with him) reported Allah's Messenger (may peace be upon him) as saying: A time will come for the people (of Medina) when a man will invite his cousin and any other near relation: Come (and settle) at (a place) where living is cheap, come to where there is plenty, but Medina will be better for them; would they know it! By Him in Whose Hand is my life, none amongst them would go out (of the city) with a dislike for it, but Allah would make his successor in it someone better than be. Behold. Medina is like furnace which eliminates from it the impurities. And the Last Hour will not come until Medina banishes its evils just as a furnace eliminates the impurities of iron.

Book 7, Number 3189:

    Abu Huraira (Allah be pleased with him) reported Allah's Messenger (way peace be upon him) as saying: I have been commanded (to migrate) to a town (Medina) which would overpower other towns. They (the people) call it Yathrib; its correct name is (in fact) Medina. It eliminates (bad) people just as a furnace removes the alloy of iron.

Book 7, Number 3190:

    This hadith has been narrated by Yabya b. Sa'id with the same chain of transmitters (and the words are): "Just as a furance removes impurity," but no mention is made of iron.

Book 7, Number 3191:

    Jabir b. Abdullah (Allah be pleased with them) reported that a desert Arab swore allegiance to Allah's Messenger (may peace be upon him). He suffered frozn a severe fever in Medina (and) so he came to Allah's Messenger (may peace be upon him) saying: Mubammad. cancel my oath of allegiance, but Allah's Messenger (may peace be upon him) refused it. He again came and caid: Cancel my oath of allegiance. but he (the Holy Prophet) refused it. He again came to him and said: Cancel my oath of allegiance, but he refused. The desert Arab, however, went away (cancelling the allegiance himself); thereupon Allah's Messenger (may peace be upon him) said: Medina is like a furnace which drives away its impurity and purifies what is good.

Book 7, Number 3192:

    Zaid b. Thabit reported Allah's Apostle (may peace be upon him) as saying: It is Taiba, thereby meaning Medina. It drives away impurity just as fire removes the impurity of silver.

Book 7, Number 3193:

    Jabir b. Samura (Allah be pleased with him) reported that he heard Allah's Messenger (may peace be upon him) say: Allah named Medina as Tabba.

Chapter 85 : ALLAH WILL PUNISH THOSE WHO INTEND TO DO ANY HARM TO THE CITIZENS OF MEDINA

Book 7, Number 3194:

    Abu Huraira (Allah be pleased with him) reported that Abu'I-Qasim (Mubammad, may peace be upon him) said: He who intends to do harm to the people of this city (that is, Medina). Allah would efface him as salt is dissolved in water.

Book 7, Number 3195:

    Abu Huraira reported Allah's Messenger (may peace be upon him) as saying: He who intends to do harm to its people (he meant Medina), Allah would efface him as salt is dissolved in water. Ibn Hatim (one of the narrators) substituted the word "harm" for "mischief".

Book 7, Number 3196:

    This hadith is narrated on the authority of Abu Huraira by another chain of transmitters.

Book 7, Number 3197:

    Sa'd b. Abu Waqqas reported Allah's Messenger (may peace be upon him) as saying: He who intends to do harm to the people of Medina, Allah would efface him just as water dissolves salt.

Book 7, Number 3198:

    Sa'd b. Malik heard Allah's Messenger (may peace be upon him) saying like this except (this variation) that he said: "Sudden attack or harm."

Book 7, Number 3199:

    Abu Huraira and Sa'd reported Allah's Messenger (way peace be upon him) as saying: O Allah, bless the people of Medina in their mudd, the rest of the hadith being the same, and in It (this is also mentioned): "He wo intends to do harm to its people, Allah would efface him just as salt it dissolved in water."

Chapter 86 : EXHORTATION TO STAY IN MEDINA WHEN THE TOWNS WILL BE CONQUERED

Book 7, Number 3200:

    Sufyan b. Abd Zuhair reported Allah's Messenger (may peace be upon him) as saying: Syria will be conquered and some people will go out of Medina along with their families driving their camels. and Medina is better for them if they were to know it. Then Yemen will be conquered and some people will go out of Medina along with their families driving their camels, and Medina is better for them if they were to know it. Then Iraq will be conquered and some people will go out of it along with their families driving their camels, and Medina is better for them if they were to know it.

Book 7, Number 3201:

    Sufyan b. Abu Zuhair heard Allah's Messenger (may peace be upon him) say: Yemen will be conquered and some people will go away (to that country) driving their camels and carrying their families on them and those who are under their authority, while Medina is better for them if they were to know it. Then Syria will be conquered and some people will go away driving their camels along with them and carrying their families with them and those who are under their authority, while Medina is better for theni if they were to know it. Thtn lraq will be conquered and some people will go away (to that country) driving their camels and carrying their families with them and those who are under their authority. while Medina is better for them if they were to know it.

Chapter 87 : WHEN PEOPLE WILL ABANDON MEDINA

Book 7, Number 3202:

    Salid b. Musayyib heard Abu Huraira (Allah be pleased with him) say that 'Allah's Messenger (may peace be upon him) said about Medina: Its inhabitants will abandon it, whereas it is good for them and it will become the haunt of beasts and birds. (Imam Muslim said that Abu Safwan, one of the narrators whose name was 'Abdullah b. 'Abd al-Malik, was an orphan and I bn juraij took him under his care for ten years.)

Book 7, Number 3203:

    Abu Huraira (Allah be pleased with him) heard Allah's Messenger (may peace be upon him) say: They (the residents of) Medina will abandon Medina whereas it is good for them and it will be haunted by beasts and birds, and two shepherds will come out from Muzainah intending (to go) towards Medina and tending their herd, and will find nothing but wilderness there until when they will reach the mountain path of Wada, they will fall down on their faces.

Chapter 88 : BETWEEN THE GRAVE (OF THE HOLY PROPHET) AND THE PULPIT THERE IS A GARDEN FROM THE GARDENS OF PARADISE

Book 7, Number 3204:

    AbduUah b. Zaid al-Mazini (Allah be pleased with him) reported Allah's Messenger (may peace be upon him) as saying: That which is between my house" and my pulpit is a garden from the gardens of Paradise.

Book 7, Number 3205:

    Abdullah b. Zaid al-Ansari heard Allah's Messenger (may peace be upon him) as saying: That which exists between my pulpit and my house is a garden from the gardens of Paradise.

Book 7, Number 3206:

    Abu Huraira (Allah be pleased with him) reported Allah's Messenger (may peace be upon him) as saying: That which exists between my house and my pulpit is a garden from the gardens of Paradise, and my pulpit is upon my cistern.

Chapter 89 : UHUD IS A MOUNTAIN: IT LOVES US AND WE LOVE IT

Book 7, Number 3207:

    Abu Humaid (Allah be pleased with him) reported: We went out along with Allah's Messenger (may peace be upon him) in the expedition of Tabuk, and Humaid further related: We proceeded until we reached the valley of Qura; and Allah's Messenger (may peace be upon him) said: I am going forth, so he who among you wants to move fast with me may do so; and he who likes to go slowly may do so. We proceeded until Medina wag within our sight. and he said: This is Tibba (another name of Medina); this is Ubud, the mountain which loves us and we love it.

Book 7, Number 3208:

    Anas b. Malik (Allah be pleased with him) reported Allah's Messenger (way peace be upon him) as saying: Ohud is a mountain which loves us and which we love. This hadith is narrated by Anas b. Malik (Allah be pleased with him) with another chain of transmitters (and the words are): "AIlah's Messenger (may peace be upon him) cast a glance at Ubud and said: Ubud is a mountain which loves us and we love it."

Chapter 90 : THE MERIT OF PRAYING IN THE TWO MOSQUES, AT MECCA AND MEDINA

Book 7, Number 3209:

    Abu Huraira (Allah be pleased with him) narrated It directly from Allah's Apostle'(may peace be upon him) having said this: A prayer in my mosque is a thousand times more excellent than a prayer in any other mosque, except Masjid al-Haram (Mosque of the Ka'ba).

Book 7, Number 3210:

    Abu Huraira (Allah be pleased with him) reported Allah's Messenger (may peace be upon him) as saying: Prayer in my mosque is more excellent than a thousand prayers observed in other mosques except the Masjid al- Haram.

Book 7, Number 3211:

    Abu Huraira (Allah be pleased with him) reported: Prayer in the mosque of Allah's Messenger (may peace be upon him) is more excellent than a thousand prayers in other mosques except the Masjid al-Haram, for Allah's Messenger (may peace be upon him) is the last of the Apostles, and his mosque is the last of the mosques. Abu Salama and Abu Abdullah (two of the narrators in this chain of narrations said: We had no doubt that what Abu Haraira (Allah be pleased with him) had said was from Allah's Messenger (may peace be upon him), and so we did not like to get an attestation from Abu Huraira about this hadith until Abu Huraira (Allah be pleased with him) died. We discussed it (the issue of getting attestation from Abu Huraira) amongst ourselves and blamed one another as to why we did not talk about it to Abu Huraira regarding it so that he could attribute its transmission to Allah's Messenger (may peace be upon him) in case he had heard It from him. While we were discussing it as we sat with 'Abdullah b. Ibrahlm b. Qariz; we made a mention of this hadith, and our omission (in getting its attestation) about its direct transmission by Abu Huraira from him (the Holy Proohet); thereupon Abdullah b. Ibrahim said to us: I bear witness to the fact that I heard Abu Huraira (Allah be pleased with him) say that Allah's Messenger (may peace be upon him) said: I am the last of the Apostles and my mosque is the last of the mosques.

Book 7, Number 3212:

    Yahya b. Sa'id (Allah be pleased with him) reported: I said to Abu Salih: Did you hear Abu Huraira (Allah be pleased with him) making a mention of the excellence of prayer in the mosque of Allah's Messenger (may peace be upon him)? He said: No (I did not hear directly from Abu Huraira), but I heard Abdullah b. Ibrahlm b. Qariz; say that' he had heard from Abu Huraira (Allah be pleased with him) that Allah's Messenger(may peace be upon him) had said: Prayer in this mosque of mine is better than a thousand prayers. or. is like one thousand prayers observed in other mosques besides It, except that it be in al-Masjid al-Haram. This hadith has been narrated by Yabya b. Sa'id with the same chain of transmitters.

Book 7, Number 3213:

    Ibn 'Umar (Allah be pleased with them) reported Allah's Apostle (may peace be upon him) as saying: Prayer in this mosque of mine is better than a thousand prayers (observed in other mosque.) besides it, except that of Masjid al-Haram.

Book 7, Number 3214:

    A hadith like this has been narrated on the authority of Ubaidullah with the same chain of transmitters.

Book 7, Number 3215:

    Ibn 'Umar reported: I heard Allah's Messenger (may peace be upon him) saying like this.

Book 7, Number 3216:

    Ibn Umar narrated from Allah's Apostle (may peace be upon him) a hadlth like this.

Book 7, Number 3217:

    Ibn Abbas (Allah be pleased with them) reported that a woman fell ill and she said: In case Allah cures me I will certainly go and observe prayer in Bait al-Maqdis. She recovered and so she made preparations to go out (to that place). She came to Maimuna. the wife of Allah's Apostle (may peace be upon him). and after greeting her she informed her about it, whereupon she said: Stay here. and eat the provision (which you had made) and observe prayer In the mosque of the Messenger (may peace be upon him). for I heard Allah's Messenger (may peace be upon him) say: Prayer In it is better than a thousand prayers observed in other mosques except the mosque of the Ka'ba.

Chapter 91 :DO NOT UNDERTAKE JOURNEY (PURELY FOR VISIT TO THE SACRED PLACES) BUT TO THREE MOSQUES

Book 7, Number 3218:

    Abu Huraira (Allah be pleased with him) reported it directly from Allah's Apostle (may peace be upon him) that he said: Do not undertake journey but to three mosques: this mosque of mine, the Mosque of al-Haram and the Mosque of Aqsa (Bait al-Maqdis).

Book 7 ,Number 3219:

    This hadith has been narrated on the authority of Zuhri (but with this change of words) that he (Allah's Apostle) said: "Undertake journey to three mosques."

Book 7 ,Number 3220:

    Abu Haraira (Allah be pleased with him) reported Allah's Messenger (way peace be upon him) as saying: One should undertake journey to three mosques: the mosque of the Ka'ba, my mosque, and the mosque of Elia (Bait al-Maqdis).

Chapter 92 : THE MOSQUE FOUNDED ON PIETY IS THE MOSQUE OF THE APOSTLE (MAY PEACE BE UPON HIM) AT MEDINA

Book 7, Number 3221:

    Abu Salama b. Abd al-Rabman reported: 'Abd al-Rabman b. Abu Sa'id al-Khudri (Allah be pleased with him) happened to pass by me and I said to him. How did you hear your father making mention of the mosque founded on Piety? He said: My father said: I went to Allah's Messenger (may peace be upon him) as he was in the house of one of his wives, and said: Messenger of Allah, which of the two mosques is founded on piety? Thereupon he took a handful of pebbles and threw them on the ground and then said: This is the very mosque of yours (mosque at Medina). He (the narrator) said: I bear witness that I heard your father making mention of it.

Book 7 ,Number 3222:

    Abu Sa'id reported from Allah's Apostle (may peace be upon him) a hadlth like this, but in the chain of transmitters no mention was made of Abd al- Rahman b. Abu Sa'id.

Chapter 93 : EMINENCE OF THE MOSQUE OF QUBA'AND EXCELLENCE OF PRAYER IN IT

Book 7, Number 3223:

    Ibn Umar reported that Allah's Messenger (may peace be upon him) visited (the mosque) at Quba' riding and on foot.

Book 7 ,Number 3224:

    Ibn Umar (Allah be pleased with them) reported that Allah's Messenger (may peace be upon him) came to the mosque at Quba' riding and on foot, and he observed two rak'ahs of (Nafl prayer) in it.

Book 7 ,Number 3225:

    Ibn 'Umar reported that Allah's Messenger (may peace be upon him) came to Quba' riding as well as on foot.

Book 7 ,Number 3226:

    This hadith has been reported on the authority of Ibn Umar (Allah be pleased with them) with another chain of transmitters.

Book 7 ,Number 3227:

    Abdullah b. Umar (Allah be pleased with them) reported that Allah's Messenger (may peace be upon him) used to come to Quba' riding and on foot

Book 7 ,Number 3228:

    Ibn 'Umar had narrated this hadith through another chain of transmitters.

Book 7 ,Number 3229:

    Ibn Umar used to come to Quba' on every Saturday and he said: I saw Allah's Apostle (may peace be upon him) coming (to this place) on every Saturday.

Book 7 ,Number 3230:

    'Abdullah b. 'Umar reported that Allah's Messenger (may peace be upon him) used to come to Quba', i.e. (he came) on every Saturday, and he used to come riding or on foot. Ibn Dinar (another narrator) said that Ibn Umar used to do like this. This hadlth has been narrated on the authority of Ibn Dinar, but he made no mention of: "Every Saturday."


BOOK 8: The Book Of Marriage (KITAB AL-NIKAH)

KITAB AL-NIKAH
(THE BOOK OF MARRIAGE)

Back
INTRODUCTION

    Marriage is a social institution as old as the human race itself.It may be defined as a relation between a man and a woman which is recognised by custom or law and involves certain rights and duties, both in the case of the parties entering the Union, and in case of the children born of it.Marriage has thus two main functions to perform: it is the means adopted by human society for regulating relations between the sexes; and it furnishes the mechanism by means of which the relations of a child to the community is determined.

    The rites and ceremonies of marriage have been different with different peoples and in different ages.but these two functions mentioned above are common even where in marriage.It always implies the right of sexual intercourse as allowed and recognised by society and the duties of the parents in bringing up children.

    Islam recognises this institution and accepts it as the basis of human society after purging it of all those evils which had penetrated it.

    Firstly, Islam does not regard it as a union only for the gratification of sexual lost, but a social contract with wide and varied responsibilities and duties.The reason behind it is that, according to the Divine Faith, a woman is not a plaything in the hand of man. but a spiritual and moral being who is entrusted to him on the sacred pledge to which Allah is made a witness.The wife is, therefore, not meant. to provide sensuous pleasure only to the male, but to fully co-operate with him in making the life of the family and ultimately of the whole humanity significantly meaningful.

    The Holy Qur'an has in so many verses pointed out the different purposes of marriage.It states: "And of His signs is that He has created wives for you from yourselves that you might find quiet of wind in them, and He put between you love and affection" (xxx. 21).In this verse it has been said that the female is not inferior to the male in the sense that the former is created out of a superior stuff while the latter comes of a base origin.Both man and woman are the progeny of Adam and thus both have the same soul.The purpose of marriage, according to the Holy Qur'an, is therefore, the union of the two souls which are one in essence.Their separate existence is an unnatural state of their being which changes Into the natural state when they are united by marriage and thus are brought close to each other physically, mentally and emotionally.

    Both man and woman are the joint heirs of the grace of life, and unless there is a very close and intimate form of companionship in them, they cannot enjoy the true grace of life. "He it is Who created you from a single soul, and of the same did He make his spouse, that he might find comfort in her" (vii. 189)."Comfort" implies much more than a mere sexual gratification.It is not too much to say that the whole conception of the marriage relation in Islam is charged with spiritual and moral ideas, and must of necessity elevate the status of matrimonial alliance in the individual and social life.

    In Islam the union of the sexes has been purified and the joy of the married relation secured by the absolute prohibition of every kind of extra-matzimonial connection.The Holy Qur'an stresses upon the people to marry as it is the most effective means whereby one can lead a virtuous life free from immorality and emotional inhibition. The Holy Qur'an says: "They (your wives) are as a garment to you, and you are as a garment to them" (ii. 187).The mutual relation of husband and wife is here described in words which could not be surpassed in beauty.Herein is the correct description of the relationship between the two.The husband and the wife are for mutual support, mutual comfort and mutual protection, fitting into each other as garments fit into each other.

    Then the Holy Qur'an also makes it clear that this union is not a temporary relationship between two individuals of opposite sexes: It is a permanent and enduring relationship in the sense that both the parties should put in their earnest endeavours to lead their lives in perfect harmony and acquitting themselves creditably of the responsibilities saddled upon them by entering into this sacred contract.

    The Holy Qur'an farther points out that sexual gratification in the married life is not meant only for the satisfaction of the physical lust, but it mustbe directed to some higher ends."Your women are tilth for you, so go into your tilth as ye like, and provide beforehand for your souls, and fear Allah and know that you are going to meet Him" (iii. 223).Here the wives are likened to the cultivable land which are ploughed for sowing and reaping the produce (in the form of offspring) and not merely for carnal indulgence.The concluding part of the verse refers to still higher and sublimer ends which tell that even in the height of carnal pleasures the moral and spiritual responsibilities should not in any way be lost sight of ; rather one should be more conscious to them when one is enjoying physical pleasures as these are the moments when the fear of the Lord and the accountability in the Hereafter is likely to be blurred or effaced from one's mind.

Chapter 1 : ONE WHO CAN SUPPORT A WIFE SHOULD MARRY

Book 8, Number 3231:

    'Alqama reported: While I was walking with 'Abdullah at Mina, 'Uthman happened to meet him.He stopped there and began to talk with him. Uthman said to him: Abu 'Abd al-Rahman, should we not marry you to a young girl who may recall to you some of the past of your bygone days; thereupon he said: If you say so, Allah's Messenger (may peace be upon him) said: 0 young men, those among you who can support a wife should marry, for it restrains eyes from casting (evil glances). and preserves one from immorality; but those who cannot should devote themselves to fasting for it is a means of controlling sexual desire.

Book 8, Number 3232:

    'Alqama reported: While I was going along with 'Abdullah b. Ma'sud (Allah he pleased with him) in Mina, 'Uthman b. 'Affan (Allah be pleased with him) happened to meet him and said: Come here, Abu 'Abd al-Rahman (kunya of Abdullah b. Mas'ud), and he isolated him (from me), and when 'Abdullah (b.Mas'ud) saw that there was no need (for this privacy), he said to me: 'Alqama, come on, and so I went there. (Then) 'Uthman said to him: Abu Abd al-Rahman, should we not marry you to a virgin girl that your past may be recalled to your mind?'Abdullah said: If you say so, the rest of the hadith is the same as narrated above.

Book 8, Number 3233:

    Abdullah (b. Mas'ud) (Allah be pleased with him) reported that Allah's Messenger (may peace be upon him) said to us: 0 young men, those among you who can support a wife should marry, for it restrains eyes (from casting evil glances) and preserves one from immorality; but he who cannot afford It should observe fast for it is a means of controlling the sexual desire.

Book 8, Number 3234:

    Abu al-Rahman b. Yazid said:I and my uncle 'Alqama and al-Aswad went to 'Abdullah b. Mas'ud (Allah be pleased with him).He (the narrator further) said: I was at that time young, and he narrated a hadith which it seemed he narrated for me that Allah's Messenger (may peace be upon him) said like one transmitted by Mu'awiya, and further added: I lost no time in marrying.

Book 8, Number 3235:

    'Abd al-Rahman b. Yazid reported on the authority of Abdullah: We went to him, and I was the youngest of all (of us), but he did not mention: "I lost no time in marrying."

Book 8, Number 3236:

    Anas (Allah be pleased with him) reported that some of the Companions of Allah's Apostle (may peace be upon him) asked his (the Prophet's) wives about the acts that he performed in private.Someone among them (among his Companions) said: I will not marry women; someone among them said: I will not eat meat; and someone among them said: I will not lie down in bed.He (the Holy Prophet) praised Allah and glorified Him, and said: What has happened to these people that they say so and so, whereas I observe prayer and sleep too; I observe fast and suspend observing them; I marry women also?And he who turns away from my Sunnah, he has no relation with Me

Book 8, Number 3237:

    Sa'd b. Abi Waqqas (Allah be pleased with him) reported: The Messengger of Allah (may peace be upon him) rejected (the idea) of Uthman b. Muz'unliving in celibacy (saying): And if he (the Holy Prophet) had given me permission We would have got ourselves castrated.

Book 8, Number 3238:

    Sa'id b. al-Musayyib reported: I heard Sa'd (b.Abi Waqqas) saying that the idea of 'Uthman b. Maz'un for living in celibacy was rejected (by the Holy Prophet), and if he had been given permission they would have got themselves castrated.

Book 8, Number 3239:

    Sa'id b. al Musayyib heard Sa'd b. Abi Waqqas (Allah be pleased with him) saying that Uthman b. Maz'un decided to live in celibacy, but Allah's Messenger (may peace be upon him) forbade him to do so, and if he had permitted him, we would have got ourselves castrated.

Chapter 2 :HE WHO SEES A WOMAN, AND HIS HEART IS AFFECTED, SHOULD COME TO HIS WIFE, AND SHOULD HAVE INTERCOURSE WITH HER

Book 8, Number 3240:

    Jabir reported that Allah's Messenger (may peace be upon him) saw a woman, and so he came to his wife, Zainab, as she was tanning a leather and had sexual intercourse with her.He then went to his Companions and told them: The woman advances and retires in the shape of a devil, so when one of you sees a woman, he should come to his wife, for that will repel what he feels in his heart.

Book 8, Number 3241:

    Jabir b. 'Abdullah reported that Allah's Apostle (may peace be upon him) saw a woman; and the rest of the hadith was narrated but (with this exception) that he said he came to his wife Zainab, who was tanning a (piece of) leather, and he made no mention of: "She retires in the shape of satan."

Book 8, Number 3242:

    Jabir heard Allah's Apostle (may peace be upon him) say: When a woman fascinates any one of you and she captivates his heart, he should go to his wife and have an intercourse with her, for it would repel what he feels.

Chapter 3 :TEMPORARY MARRIAGE AND ITS PROHIBITION FOR ALL TIMES TO COME

Book 8, Number 3243:

    Abdullah (b. Mas'ud) reported: We were on an expedition with Allah's Messenger (may peace be upon him) and we had no women with us.We said: Should we not have ourselves castrated?He (the Holy Prophet) forbade us to do so He then granted us permission that we should contract temporary marriage for a stipulated period giving her a garment, and 'Abdullah then recited this verse: 'Those who believe do not make unlawful the good things which Allah has made lawful for you, and do not transgress.Allah does not like trangressers" (al-Qur'an, v. 87).

Book 8, Number 3244:

    This hadith has been narrated on the authority of Jarir with the same chain of transmitters and he also recited this (above-mentioned verse) to us, but he did not say that 'Abdullah recited it.

Book 8, Number 3245:

    This hadith has been narrated on the authority of Isma'il with the same chain of transmitters (and the words are): "We were young, so we said: Allah's Messenger, should we not have ourselves castrated?But he (the narrator) did not say; We were on an expedition."

Book 8, Number 3246:

    Jabir b. 'Abdullah and Salama b. al-Akwa' said: There came to us the proclaimer of Allah's Messenger (may peace be upon him) and said: Allah's Messenger (may peace be upon him) has granted you permission to benefit yourselves, i.e. to contract temporary marriage with women.

Book 8, Number 3247:

    Salama b. al.Akwa' and Jabir b. Abdullah reported: Allah's Messenger (may peace be upon him) came to us and permitted us to contract temporary marriage.

Book 8, Number 3248:

    Ibn Uraij reported: 'Ati' reported that jibir b. Abdullah came to perform 'Umra, and we came to his abode, and the people asked him about different things, and then they made a mention of temporary marriage, whereupon he said: Yes, we had been benefiting ourselves by this temporary marriage during the lifetime of theHoly Prophet (may peace be upon him) and during the tinie of Abi! Bakr and 'Umar.

Book 8, Number 3249:

    Jabir b. 'Abdullah reported: We contracted temporary marriage giving a handful of (tales or flour as a dower during the lifetime of Allah's Messenger (may peace be upon him) and durnig the time of Abu Bakr until 'Umar forbade it in the case of 'Amr b. Huraith.

Book 8, Number 3250:

    Abu Nadra reported: While I was in the company of Jabir b. Abdullah, a person came to him and said that Ibn 'Abbas and Ibn Zubair differed on the two types of Mut'as (Tamattu' of Hajj 1846 and Tamattu' with women), whereupon Jabir said: We used to do these two during the lifetime of Allah's Messenger (may peace be upon him).Umar then forbade us to do them, and so we did not revert to them.

Book 8, Number 3251:

    Iyas b. Salama reported on the authority of his father that Allah's Messenger (may peace be upon him) gave sanction for contracting temporary marriage for three nights in the year of Autas 1847 and then forbade it.

Book 8, Number 3252:

    Sabra Juhanni reported: Allah's Messenger (may peace be upon him) permitted temporary marriage for us.So I and another person went out and saw a woman of Bana 'Amir, who was like a young long-necked she-camel. We presented ourselves to her (for contracting temporary marriage), whereupon she said: What dower would you give me?I said: My cloak.And my companion also said: My cloak. And the cloak of-my companion was superior to my cloak, but I was younger than he. So when she looked at the cloak of my companion she liked it, and when she cast a glance at me I looked more attractive to her.She then said: Well, you and your cloak are sufficient for me.I remained with her for three nights, and then Allah's Messenger (may peace be upon him) said: He who has any such woman with whom he had contracted temporary marriage, he should let her off.

Book 8, Number 3253:

    Rabi' b. Sabra reported that his father went on an expedition with Allah's Messenger (may peace be upon him) during the Victory of Mecca, and we stayed there for fifteen days (i.e. for thirteen full days and a day and a night), and Allah's Messenger (may peace be upon him) permitted us to contract temporary marriage with women.So I and another person of my tribe went out, and I was more handsome than he, whereas he was almost ugly.Each one of us had a cloaks, My cloak was worn out, whereas the cloak of my cousin was quite new. As we reached the lower or the upper side of Mecca, we came across a young woman like a young smart long-necked she-camel.We said: Is it possible that one of us may contract temporary marriage with you? She said: What will you give me as a dower?Each one of us spread his cloak. She began to cast a glance on both the persons. My companion also looked at her when she was casting a glance at her side and he said: This cloak of his is worn out, whereas my cloak is quite new. She, however, said twice or thrice: There is no harm in (accepting) this cloak (the old one). So I contracted temporary marriage with her, and I did not come out (of this) until Allah's Messenger (may peace be upon him) declared it forbidden.

Book 8, Number 3254:

    Rabi' b. S'abra al-jahanni reported on the authority of his father.We went with Allah's Messenger (may peace be upon him) to Mecca during the year of Victory and he narrated like this a hadith transmitted by Bishr (the previous one) but with this addition: "She said: Can it be possible?" And it is also mentioned in it: "He said: The cloak of this (man) is old and worn out."

Book 8, Number 3255:

    Sabra al-Juhanni reported on the authority of his father that while he was with Allah's Messenger (may peace be upon hm) he said: 0 people, I had permitted you to contract temporary marriage with women, but Allah has forbidden it (now) until the Day of Resurrection.So he who has any (woman with this type of marriage contract) he should let her off, and do not take back anything you have given to then (as dower).

Book 8, Number 3256:

    This hadith has been narrated on the authority of 'Abd al-'Aziz b 'Umar with the same chain of transmitters, and he said: I saw Allah's Messenger (may peace be upon him) standing between the pillar and the gate (of the Ka'ba) and he was relating a hadith as narrated by Ibn Numair.

Book 8, Number 3257:

    'Abd al-Malik b. Rabi' b. Sabraal-Juhanni reported on the authority of his father who narrated it on the authority of his father (i e. 'Abd al-Malik's grandfather, Sabura al-juhanni): Allah's Messenger (may peace be upon him) permitted us to contract temporary marriage in the Year of Victory, as we entered Mecce, and we did come out of it but he forbade us to do it.

Book 8, Number 3258:

    Sabra b. Ma'bad reported that Allah's Apostle (may peace be upon him) permitted his Companions to contract temporary marriage with women in the Year of Victory.So I and a friend of mine from Banu Sulaim went out, until we found a young woman of Banu Amir who was like a young she-camel having a long neck.We made proposal to her for contracting temporary marriage with us, and presented to her our cloaks (as dower).She began to look and found me more handsome than my friend, but found the cloak of my friend more beautiful than my cloak. She thought in her wind for a while, but then preferred me to my friend.So I remained with her for three (nights), and then Allah's Messenger (may peace be upon him) commanded us to part with them (such women).

Book 8, Number 3259:

    Rabi' b. Sabra reported on the authority of his father that Allah's Apostle (may peace be upon him) prohibited the contracting of temporary marriage.

Book 8, Number 3260:

    Rabi' b. Sabra reported on the authority of his father that Allah's Messenger (may peace be upon him) forbade on the Day of Victory to contract temporary marriage with women.This hadith has been narrated on the authority of Rabi' b. Sabra that Allah's Messenger (may peace be upon him) forbade to contracf temporary marriage with women at the time of Victory, and that his father had contracted the marriage for two red cloaks.

Book 8, Number 3261:

    'Urwa b. Zabair reported that 'Abdullah b. Zubair (Allah be pleased with him) stood up (and delivered an address) in Mecca saying: Allah has made blind the hearts of some people as He has deprived them of eyesight that they give religious verdict in favour of temporary marriage, while he was alluding to a person (Ibn 'Abbas). Ibn Abbas called him and said: You are an uncouth person, devoid of sense.By my life, Mut'a was practised during the lifetime of the leader of the pious (he meant Allah's Messenger, may peace be upon him), and Ibn Zubair said to him: just do it yourselves, and by Allah, if you do that I will stone you with your stones.Ibn Shihab said.Khalid b. Muhajir b. Saifullah informed me: While I was sitting in the company of a person, a person came to him and he asked for a religious verdict about Mut'a and he permitted him to do it.Ibn Abu 'Amrah al-Ansari (Allah be pleased with him) said to him: Be gentle.It was permitted in- the early days of Islam, (for one) who was driven to it under the stress of necessity just as (the eating of) carrion and the blood and flesh of swine and then Allah intensified (the commands of) His religion and prohibited it (altogether).Ibn Shihab reported: Rabi' b. Sabra told me that his father (Sabra) said: I contracted temporary marriage with a woman of Banu 'Amir for two cloaks during the lifetime of Allah's Messenger (may peace be upon him); then he forbade us to do Mut'a.Ibn Shihab said: I heard Rabi' b. Sabra narrating it to Umar b. 'Abd al-'Aziz and I was sitting there.

Book 8, Number 3262:

    Sabra al-Juhanni reported on the authority of his father: Allah's Messenger (may peace be upon him) prohibited the contracting of temporary marriage and said: Behold, it is forbidden from this very day of yours to the Day of Resurrection, and he who has given something (as a dower) should not take it back.

Book 8, Number 3263:

    'Ali b. AbiTalib reported that Allah's Messenger (may peace be upon him) prohibited on the Day of Khaibar the contracting of temporary marriage with women and the eating of the flesh of domestic asses.

Book 8, Number 3264:

    Malik narrated this hadith on the authority of the same chain of trans- witters that 'Ali b. Abil Talib said to a person: You are a person led astray; Allah's Messenger (may peace be upon him) forbade us (to do Mut'a), as is stated In the hadith transmitted on the authority of Yahya b. Malik.

Book 8, Number 3265:

    Muhammad b. 'Ali narrated on the authority of his father 'Ali that Allah's Apostle (may peace be upon him) on the Day of Khaibar prohibited for ever the contracting of temporary marriage and eating of the flesh of the domestic asses.

Book 8, Number 3266:

    'Ali (Allah be pleased with him) heard that Ibn Abbas (Allah be pleased with them) gave some relaxation in connection with the contracting of temporary marriage, whereupon he said: Don't be hasty (in your religious verdict), Ibn 'Abbas, for Allah's Messenger (may peace be upon him) on the Day of Khaibar prohibited for ever the doing of it-And eating of the flesh of domestic asses.

Book 8, Number 3267:

    'Ali (Allah be pleased with him) said to Ibn 'Abbas (Allah be pleased with them) that Allah's Messenger (may peace be upon him) on the Day of Khaibar forbade forever the contracting of temporary marriage and the eating of the flesh of domestic asses.

Chapter 4 :IT IS FORBIDDEN TO COMBINE A WOMAN AND HER FATHER'S SISTER, OR A WOMAN AND HER MOTHER'S SISTER TOGETHER IN MARRIAGE

Book 8, Number 3268:

    Abu Huraira (Allah be pleased with him) reported Allah's Messenger (may peace upon him) having said this: One should not combine a woman and her father's sister, nor a woman and her mother's sister in marriage.

Book 8, Number 3269:

    Abu Huraira (Allah be pleased with him) reported that Allah's Messenger (may peace be upon him) forbade combining of four women in marriage: a woman with her tather's sister, and a woman with her mother's sister.

Book 8, Number 3270:

    Abu Huraira (Allah be pleased with him) reported: I heard Allah's Messenger (may peace be upon him) say: Father's sister should not be combined with her brother's daughter, nor the daughter of a sister with her mother's sister.

Book 8, Number 3271:

    Abu Huraira (Allah be pleased with him) reported that Allah's Messenger (may peace be upon him) forbade a person to combine in marriage a womanarid her father's sister, and a woman and her mother's sister.Ibn Shihab said: So we regarded the paternal aunt of her (wife's) father and the maternal aunt of her (wife's) father at the same level.

Book 8, Number 3272:

    Abu Huraira (Allah be pleased with him) reported Allah's Messenger (may peace be upon him) as saying: One should not combine in marriage a woman with her father's sister, or her mother's sister.

Book 8, Number 3273:

    A hadith like this has been narrated on the authority of Abu Huraira (Allah be pleased with him) through another chain of transmitters.

Book 8, Number 3274:

    Abu Huraira (Allah be pleased with him) reported Allah's Apostle (may peace be upon him) as saying: A man must not make proposal of marriage to a woman when his brother has done so already.And he must not offer a price for a thing for which his brother had already offered a price; and a woman must not be combined in marriage with her father's sister, nor with her mother's sister, and a woman must not ask to have her sister divorced in order to deprive her of what belongs to her,but she must marry, because she will have what Allah has decreed for her.

Book 8, Number 3275:

    Abu Huraira (Allah be pleased with him) reported that Allah's Messenger (may peace be upon him) forbade the combining of a woman in marriage with her father's sister, or with her mother's sister, or that a woman should ask for divorce for her sister in order to deprive her of what belongs to her.Allah, the Exalted'and Majestic, is her Sustainer too.

Book 8, Number 3276:

    Abu Huraira (Allah be pleased with him) reported that Allah's Messenger (may peace be upon him) forbade to combine a woman and her father's sister, and a woman and her mother's sister.

Book 8, Number 3277:

    A hadith like this has been transmitted on the authority of Amr b. Dinar

Chapter 5 : MUHRIM (ONE WHO IS IN THE STATE OF IHRAM) IS FORBIDDEN TO MARRY AND THE DISAPPROVAL OF GIVING THE PROPOSAL (IN THIS STATE)

Book 8, Number 3278:

    Nubaih b. Wahb reported that 'Umar b. Ubaidullah intended to marry Talha b. 'Umar with the daughter of Shaiba b. Jubair; so he sent a messenger to Aban b. Uthman to attend the marriage, and he was at that time the Amir of Hajj. Aban said: I heard 'Uthman b. 'Affan say that Allah's Messenger (may peace be upon him) had stated: A Muhrim must neither marry himself, nor arrange the marriage of another one, nor should he make the proposal of marriage.

Book 8, Number 3279:

    Nubaih b. Wahb reported: Umar b. Ubaidullah b. Ma'mar sent me to Aban b. Uthman as he wanted to make the proposal of the marriage of his son with the daughter of Shaiba b. Uthman.He (Aban b. Uthman) was at that time (busy) in the season of Pilgrimage.He said: I deem him to be a man of the desert (for it is a common thing) that a Muhrim can neither marry, nor is he allowed to be married to anyone.It is Uthman (b.Affan) who reported this to us from Allah's Messenger (may peace be upon him).

Book 8, Number 3280:

    Uthman b. 'Affan reported that Allah's Messenger (may peace be upon him) had said: A Muhrim should neither marry himself, nor should he be got married to anyone, nor should he make the proposal of marriage.

Book 8, Number 3281:

    'Uthman (b.'Affan) reported it directly from Allah's Apostle (may peace be upon him) that he said: A Muhrim should neithermarry (in that state) nor make the proposal of marriage.

Book 8, Number 3282:

    Nabaih b. Wahb reported that Umar b. 'Ubaidullah b. Ma'mar intended to marry his son Talha with the daughter of Shaiba b. Jubair during the Pilgrimage. Aban b. Uthman was at that time the Amir of Pilgrims.So he ('Umar b. Ubaidullah) sent someone (as a messenger) to Aban saying: I intend to marry Talha b. 'Umar and I earnestly desire you to be present there (in this ceremony of marriage).Aban said to him: I find you a block-headed 'Iraqi. I heard 'Uthman b. 'Affan say that Allah's Messenger (may peace be upon him) said: A Muhrim should not marry.

Book 8, Number 3283:

    Ibn Abbas (Allah be pleased with them) reported that Allah's Apostle (may peace be upon him) married Maimulna in the state of Ihram.Ibn Numair made this addition: "I narrated it to Zuhri and he said: Yazid b. al-Asamm (Allah be pleased with him)told me that he (the Holy Prophet) married her when he was not a muhrim."

Book 8, Number 3284:

    Ibn 'Abbas (Allah be pleased with them) reported: Allah's Messenger. (may peace be upon him) married Maimuna while he was a Muhrim.

Book 8, Number 3285:

    Yazid b. al-Asamm reported: Maimuna daughter of al-Harith narrated to me that Allah's Messenger (may peace be upon him) married her and he was not in the state of Ihram.And she (Maimuna) was my mother's sister and that of Ibn 'Abbas (Allah be pleased with them).

Chapter 6 :PROHIBITION OF ONE"S MAKING THE PROPOSAL OF MARRIAGE WHEN IT HAS ALREADY BEEN MADE BY ONE'S BROTHER UNTIL HE PERMITS OR GIVES HER UP

Book 8, Number 3286:

    Ibn Umar (Allah be pleased with them) reported Allah's Apostle (may peace be upon him) as having said this: None amongst you should outbid another in a transaction, nor should he make proposals of marriage upon the proposal made by someone else.

Book 8, Number 3287:

    Ibn Umar (Allah be pleased with them) reported Allah's Apostle (may peace be upon him) as having said this: A person should not enter into a transaction when his brother (had already entered into but not finalised), and he should not make proposal of marriage upon the proposal already made by his brother, until he permits it.

Book 8, Number 3288:

    A hadith like this has been reported on the authority of Nafi' with the same chain of transmitters.

Book 8, Number 3289:

    Abu Huraira (Allah be pleased with him) reported Allah's Apostle (may peace be upon him) as having forbidden a dweller of the town selling the merchandise of a villager or outbidding in a sale (in order that another might fall into a snare), or a person making the proposal of marriage when his brother has already made such a proposal, or entering into a transaction when his brother has already entered; and a woman asking the divorce of her sister in order to deprive her of what belongs to her. 'Amr made this addition: "The person should not purchase in opposition to his brother."

Book 8, Number 3290:

    Abu Huraira (Allah be pleased with him) reported Allah's Messenger (may peace be upon him) as having said this: Do not outbid in a sale in order to ensnare. No man should enter into a transaction in which his brother has already entered, and no dweller of the town should sell on behalf of the villager.And no man should make a proposal of marriage which his brother has already made and no woman should ask for the divorce of another (co-wife) in order to deprive her of what belongs to her.

Book 8, Number 3291:

    A hadith like this has been narrated on the authority of Zuhri with the same chain of transmitters but with a slight alteration.

Book 8, Number 3292:

    Abu Huraira (Allah be pleased with him) reported Allah's Messenger (may peace be upon him) as saying: The Muslim should not purchase in opposition to his brother, and he should not make the proposal of marriage on the proposal already made by his brother.

Book 8, Number 3293:

    This hadith has been narrated on the authority of Abu Huraira (Allah be pleased with him) through another chain of transmitters.

Book 8, Number 3294:

    'Uqba b. 'Amir said on the pulpit that Allah's Messenger (may peace be upon him) said: A believer is the brother of a believer, so it is not lawful for a believer to outbid his brother, and he should not propose an engagement when his brother has thus proposed until he gives it up.

Chapter 7 : IT IS PROHIBITED TO CONTRACT SHIGHAR MARRIAGE

Book 8, Number 3295:

    Ibn Umar (Allah be pleased with them) said that Allah's Messenger (may peace be upon him) prohibited Shighar which means that a man gives his daughter in marriage on the condition that the other gives his daughter to him in marriage with- out any dower being paid by either.

Book 8, Number 3296:

    A hadith like this has been narrated on the authority of "Abdullah b. 'Umar (Allah be pleased with them) but with a slight variation of words.

Book 8, Number 3297:

    Ibn Umar (Allah be pleased with them) reported that Allah's Messenger (may peace be upon him) prohibited Shighar.

Book 8, Number 3298:

    Ibn 'Umar (Allah be pleased with them) reported Allah's Messenger (may peace be upon him) as having said: There is no Shighar in islam.

Book 8, Number 3299:

    Abu Huraira (Allah be pleased with him) reported that Allah's Messenger (may peace be upon him) prohibited Shighar.Ibn Numair added: Shighar means that a person should say to the other person: Give me the hand of your daughter in marriage and I will (in return) marry my daughter to you; or merry me your sister, and I will marry my sister to you.

Book 8, Number 3300:

    This hadith has been narrated on the authority of Ibn Vmar with the same chain of transmitters, but there is no mention of Ibn Numair.

Book 8, Number 3301:

    Jabir b. Abdullah (Allah be pleased with him) reported that Allah's Messenger (may peace be upon him) prohibited Shighar.

Chapter 8 :FULFILLING OF CONDITION IN MARRIAGE

Book 8, Number 3302:

    'Uqba b. Amir (Allah be pleased with him) reported Allah's Messenger (may peace be upon him) as saying: The most worthy condition which must be fulfilled is that which makes sexual intercourse lawful.In the narration transmitted by Ibn Muthanna (instead of the word "condition") it is "conditions".

Chapter 9 :SEEKING CONSENT OF AL-THAYYIBIN MARRIAGE IN WORDS AND OF A VIRGIN IN (MEANINGFUL) SILENCE

Book 8, Number 3303:

    Abu Huraira (Allah be pleased with him) reported Allah's Messenger (may peace be upon him) as having said: A woman without a husband (or divorced or a widow) must not be married until she is consulted, and a virgin must not be married until her permission is sought.They asked the Prophet of Allah (may peace be upon him): How her (virgin's) consent can be solicited ? He (the Holy Prophet) said: That she keeps silence.

Book 8, Number 3304:

    This hadith has been narrated through another chain of transmitters.

Book 8, Number 3305:

    'A'isha (Allah be pleased with her) reported: I asked Allah's Messenger (may peace be upon him) about a virgin whose marriage is solemnised by her guardian, whether it was necessary or not to consult her.Allah's Messerger (may peace be upon him) said : Yes, she must be consulted.'A'isha reported: I told him that she feels shy, whereupon Allah's Messenger (may peace be upon him) said: Her silence implies her consent.

Book 8, Number 3306:

    Ibn 'Abbas (Allah be pleased with him) reported Allah's Apostle (may peace be upon him) as saying: A woman without a husband has wore right to her person than her guardian, and a virgin's consent must be asked from her, and her silence implies her consent.

Book 8, Number 3307:

    Ibn Abbas (Allah be pleased with them) reported Allah's Messenger (may peace be upon him) as saying: A woman who has been previously married (Thayyib) has more right to her person than her guardian.And a virgin should also be consulted, and her silence implies her consent.

Book 8, Number 3308:

    Sufyan reported on the basis of the same chain of transmitters (and the words are): A woman who has been previously married (Thayyib) has more right to her person than her guardian; and a virgin's father must ask her consent from her, her consent being her silence, At times he said: Her silence is her affirmation.

Chapter 10 : IT IS PERMISSIBLE FOR THE FATHER TO GIVE THE HAND OF HIS DAUGHTER IN MARRIAGE EVEN WHEN SHE IS NOT FULLY GROWN UP

Book 8, Number 3309:

    'A'isha (Allah be pleased with her) reported: Allah's Messenger (may peace be upon him) married me when I was six years old, and I was admitted to his house at the age of nine.She further said: We went to Medina and I had an attack of fever for a month, and my hair had come down to the earlobes.Umm Ruman (my mother) came to me and I was at that time on a swing along with my playmates. She called me loudly and I went to her and I did not know what she had wanted of me.She took hold of my hand and took me to the door, and I was saying: Ha, ha (as if I was gasping), until the agitation of my heart was over.She took me to a house, where had gathered the women of the Ansar.They all blessed me and wished me good luck and said: May you have share in good.She (my mother) entrusted me to them.They washed my head and embellished me and nothing frightened me.Allah's Messenger (,may peace be upon him) came there in the morning, and I was entrusted to him.

Book 8, Number 3310:

    'A'isha (Allah be pleased with her) reported: Allah's Apostle (may peace be upon him) married me when I was six years old, and I was admitted to his house when I was nine years old.

Book 8, Number 3311:

    'A'isha (Allah be pleased with her) reported that Allah's Apostle (may peace be upon him) married her when she was seven years old, and he was taken to his house as a bride when she was nine, and her dolls were with her; and when he (the Holy Prophet) died she was eighteen years old.

Chapter 11 : EXCELLENCE OF MARRYING OR BEING MARRIED DURING THE MONTH OF SHAWWAL AND EXCELLENCE OF TAKING BRIDE IN THE HOUSE DURING THIS MONTH

Book 8, Number 3312:

    'A'isha (Allah be pleased with her) reported: Allah's Messenger (may peace be upon him) contracted marriage with me in Shawwal and took me to his house as a bride during Shawwal.And who among the wives of Allah's Messenger (may peace be upon him) was dearer to him than I, and' A'isha liked that the women (of her family) should enter the houses as brides during the month of Shawwal.

Book 8, Number 3313:

    This hadith has been narrated on the authority of Sufyan with the same chain of transmitters, but he made no mention of the act of 'A'isha (being admitted as a wife in the house of the Holy Prophet).

Chapter 12 : IT IS PERMISSIBLE TO CAST A GLANCE AT THE FACE AND THE PALMS OF A WOMAN WHOM ONE INTENDS TO MARRY

Book 8, Number 3314:

    Abu Huraira (Allah be pleased with him) reported: I was in the company of Allah's Messenger (way peace be upan him) when there came a man and informed him that he had contracted to marry a woman of the Ansar.Thereupon Allah's Messenger (may peace be upon him) said: Did you cast a glance at her?He said: No. He said: Go and cast a glance at her, for there is something in the eyes of the Ansar.

Book 8, Number 3315:

    Abu Huraira (Allah be pleased with him) reported: A man came to Allah's Messenger (may peace be upon him) and said: I have contracted marriage with a woman of the Ansar, whereupon Allah's Apostle (may peace be upon him) said: Did you cast a glance at her, for there is something in the eyes of the Ansar?He said: I did cast a glance at her, whereupon he said: For what (dower) did you marry her?He said: For four 'uqiyas.Thereupon Allah's Apostle (may peace be upon him) said: For four 'uqiyas; it seems as if you dig out silver from the side of this mountain (and that is why you are prepared to pay such a large amount of dower).We have nothing which we should give you.There is a possibility that we may send you to an (expedition) where you may get (booty).So he sent that man (in the expedition) which was despatched to Banu 'Abs.

Chapter 13 :THE DOWER

Book 8, Number 3316:

    Sahl b. Sa'd al-Sa'idi (Allah be pleased with him) reported: A woman came to Allah's Messenger.(may peace be upon him) and said: Messerbger of Allah, I have come to you to entrust myself to you(you may contract my marriage with anyone at your discretion). Allah's Messenger (may peace be upon him) saw her and cast a glance at her from head to foot.Allah's Messenger (may peace be upon him) then lowered his head.When the woman saw that he had made no decision in regard to her, she sat down.There stood up a person from amongst his companions and said: Messenger of Allah, marry her to me if you have no need of her.He (the Holy Prophet) said: is there anything with you (which you con give as a dower) ? He said: No, Messenger of Allah, by Allah I have nothing.Thereupon Allah's Messenger (may peace be upon him) said: Go to your people (family) and see if you can find something.He returned and said: I have found nothing.The Apostle of Allah (may peace be upon him) said: See even if it is an Iron ring.He went and returned and said : No, by God, not even an iron ring, but only this lower garment of mine (Sahl said that he had no upper garment), half of which (I am prepared to part with) for her.Thereupon Allah's Messenger (may peace be upon him) said: How can your lower garment serve your purpose, for it you wear it, she would not be able to make any use of it and if she wears it there would not be anything on you ? The man sat down and as the sitting prolonged he stood up (in disappointment) and as he was going back Allah's Messenger (may peace be upon him) commanded (him) to be called back, and as he came, he said to him: Do you know any part of the Qur'an?He said: I know such and such surahs (and he counted them). whereupon he said: Can you recite them from heart (from your memory)? He said: Yes, whereupon he (Allah's Messenger) said: Go, I have given her to you in marriage for the part of the Qur'an which you know.

Book 8, Number 3317:

    This hadith has been narrated on the authority of Sahl b. Sa'd with a minor alteration of words, but the hadith transmitted through Za'idah (the words are that the Holy Prophet) said : Go, I have married her to you, and you teach her something of the Qur'an.

Book 8, Number 3318:

    Abu Salama b. 'Abd al-Rahman reported: I asked 'A'isha, the wife of Allah's Messenger (may peace be upon him): What is the amount of dower of Allah's Messenger (may peace be upon him)?She said: It was twelve 'uqiyas and one nash. She said: Do you know what is al-nash?I said: No. She said: It is half of uqiya, and it amounts to five hundred dirhams, and that was the dower given by Allah's Messenger (may peace be upon him) to his wives.

Book 8, Number 3319:

    Anas b. Malik reported that Allah's Apostle (may peace be upon him) saw the trace of yellowness on 'Abd al-Rahman b. 'Auf and said: What is this? Thereupon he said: Allah's Messenger, I have married a woman for a date-stone's weight of gold.He said: God bless you ! Hold a wedding feast, even if only with a sheep.

Book 8, Number 3320:

    Anas b. Malik (Allah be plca3ed with him) reported that 'Abd al-Rahman b. 'Auf (Allah be pleased with him) married during the lifetime of Allah's Messenger (may peace be upon him) for a nawat weight of gold and the messenger of Allah (may peace be upon him) said to him: Give a feast even with a sheep.

Book 8, Number 3321:

    Anas b. Malik (Allah be pleased with him) reported that 'Abd al-Rahman b. 'Auf (Allah be pleased with him) married a woman for a date-stone's weight of gold and Allah's Apostle (may peace be upon him) said to him: Hold a wedding feast, even if only with a sheep.

Book 8, Number 3322:

    This hadith has been narrated on the authority of Humaid with the same chain of transmitters except (with this minor alteration of words) that 'Abd al-Rahman said: "I married a woman."

Book 8, Number 3323:

    Abd al-Rahman b. 'Auf (Allah be pleased with him) reported that Allah's Messenger (may peace be upon him) saw the signs of the happiness of wedding in me, and I said: I have married a woman of the Ansar.He said: How much Mahr have you paid? I said: For a date-stone weight of gold.And in the hadith transmitted by Ishaq (it is): (nawat weight) of gold.

Book 8, Number 3324:

    Anas b. Malik reported that 'Abd al-Rahman married a woman for a datestone weight of gold.Shu'ba has narrattd this hadith with the same chain of transmitters except for (this alteration) that he said that a person from among the sons of 'Abd al Rahman said: "from gold".

Chapter 14 :EXCELLENCE OF EXMANCIPATING A SLAVE-GIRL AND THEN MARRYING HER

Book 8, Number 3325:

    Anas (Allah be pleased with him) reported that Allah's Messenger (may peace be upon him) set out on an expedition to Khaibar and we observed our morning prayer in early hours of the dawn.The Apostle of Allah (may peace be upon him) then mounted and so did Abu Talha ride, and I was seating myself behind Abu Talha.Allah's Apostle (may peace be upon him) moved in the narrow street of Khaibar (and we rode so close to each other in the street) that my knee touched the leg of Allah's Apostle (may peace be upon him). (A part of the) lower garment of Allah's Apostle (may peace be upon him) slipped from his leg and I could see the whiteness of the leg of Allah's Apostle (may peace be upon him).As he entered the habitation he called: Allah-o-Akbar (Allah is the Greatest).Khaibar is ruined.And when we get down in the valley of a people evil is the morning of the warned ones.He repeated it thrice.In the meanwhile the people went out for their work, and said: By Allah, Muhammad (has come).Abd al-'Aziz or some of our com- panions said: Muhammad and the army (have come).He said: We took it (the territory of Khaibar) by force, and there were gathered the prisoners of war.There came Dihya and he said: Messenger of Allah, bestow upon me a girl ont of the prisones. He said: Go and get any girl.He made a choice for Safiyya daughter of Huyayy (b. Akhtab).There came a person to Allah's Apostle (may peace be upon him) and said: Apostle of Allah, you have bestowed Safiyya bint Huyayy, the chief of Quraiza and al-Nadir, upon Dihya and she is worthy of you only.He said: Call him along with her.So he came along with her.When Allah's Apostle (may peace be upon him) saw her he said: Take any other woman from among the prisoners.He (the narrator) said: He (the Holy Prophet) then granted her emancipation and married her.Thabit said to him: Abu Hamza, how much dower did he (the Holy Prophet) give to her?He said: He granted her freedom and then married her.On the way Umm Sulaim embellished her and then sent her to him (the Holy Prophet) at night.Allah's Apostle (may peace be upon him) appeared as a bridegroom in the morning.He (the Holy Prophet) said: He who has anything (to eat) should bring that.Then the cloth was spread.A person came with cheese, another came with dates, and still another came with refined butter, and they prepared hais and that was the wedding feast of Allah's Messenger (may peace be upon him)

Book 8, Number 3326:

    This hadith has been narrated through another chain of transmitters on the authority of Anas that Allah's Apostle (may peace be upon him) emancipated Safiyya, and her emancipation was treated as her wedding gift, and in the hadith transmitted by Mu'adh on the authority of his father (the words are): "He (the Holy Prophet) married Safiyya and bestowed her emancipation as her wedding gift."

Book 8, Number 3327:

    Abu Musa reported that Allah's Messenger (may peace be upon him) said about one who emancipated a slave woman, and then married her, that for him there are two rewards.

Book 8, Number 3328:

    Anas (Allah be pleased with him) reported: I was sitting behind Abu Talha on the Day of Khaibar and my feet touched the foot of Allah's Messenger (may peace be upon him), and we came (to the people of Khaibar) when the sun had risen and they had driven out their cattle, and had themselves come out with their axes, large baskets and hatchets, and they said: (Here come) Muhammad and the army. Allah's Messenger (may peace be upon him) said: Khaibar is ruined.Verily when we get down in the valley of a people, evil is the morning of the warned ones (al-Qur'an, xxxvii. 177).Allah, the Majestic and the Glorious, defeated them (the inhabitants of Khaibar), and there fell to the lot of Dihya a beautiful girl, and Allah's Messenger (may peace be upon him) got her in exchange of seven heads, and then entrusted her to Umm Sulaim so that she might embellish her and prepare her (for marriage) with him. He (the narrator) said: He had been under the impression that he had said that so that she might spend her period of 'Iddah in her (Umm Sulaim's) house. (The woman) was Safiyya daughter of Huyayy.Allah's Messenger (may peace be upon him) arranged the wedding feast consisting of dates, cheese, and refined butter, and pits were dug and tiers were set in them dining cloths, and there was brought cheese and refined butter, and these were placed there.And the people ate to their fill, and they said: We do not know whether he (the Holy Prophet) had married her (as a free woman), or as a slave woman.They said: If he (the Holy Prophet) would make her wear the veil, then she would be a (free married) woman, and if he would not make her wear the veil, then she should be a slave woman.When he intended to ride, he made her wear the veil and she sat on the hind part of the camel; so they came to know that he had married her.As they approached Medina, Allah's Messenger (may peace be upon him) drove (his ride) quickly and so we did.'Adba' (the name of Allah's Apostle's camel) stumbled and Allah's Messenger (may peace be upon him) fell down and she (Radrat Safiyya: also fell down.He (the Holy Prophet) stood up and covered her. woman looked towards her and said: May Allah keep away the Jewess! He (the narrator) said: I said: Aba Hamza, did Allah's Messenger (may peace be upon him) really fall down? He said: Yes, by Allah, he in fact fell down.Anas said: I also saw the wedding feast of Zainab, and he (the Holy Prophet) served bread and meat to the people, and made them eat to their heart's content, and he (the Holy Prophet) sent me to call people, and as he was free (from the ceremony) he stood up and I followed him.Two persons were left and they were busy in talking and did not get out (of the apartment).He (the Holy Prophet) then proceeded towards (the apartments of) his wives.He greeted with as-Salamu 'alaikum to every one of them and said: Members of the household, how are you? They said: Messenger of Allah, we are in good state 'How do you find your family?He would say: In good state.When he was free from (this work of exchanging greetings) he came back, and I also came back along with him.And as he reached the door, (he found) that the two men were still busy in talking.And when they saw him having returned, they stood up and went out; and by Allah ! I do not know whether I had informed him, or there was a revelation to him (to the affect) that they had gone. He (the Holy Prophet) then came back and I also returned along with him, and as he put his step on the threshold of his door he hung a curtain between me and him, and (it was on this occasion) that Allah revealed this verse: ("O you who believe), do not enter the houses of the Prophet unless permission is given to 'you" (xxxiii. 53).

Book 8, Number 3329:

    Anas,(Allah be pleased with him) reported: Safiyya (Allah be pleased with her) fell to the lot of Dihya in the spoils of war, and they praised her in the presence of Allah's Messenger (may peace be upon him) and said: We have not seen the like of her among the captives of war.He sent (a messenger) to Dihya and he gave him whatever he demanded. He then sent her to my mother and asked her to embellish her.Allah's Messenger (may peace be upon him) then got out of Khaibar until when he was on the other side of it, he halted, and a tent was pitched for him. When it was morning Allah's Messenger (may peace be upon him) said: He who has surplus of provision with him should bring that to us.Some persons would bring the surplus of dates, and the other surplus of mush of barley until there became a heap of bals.They began to eat the hais and began to drink out of the pond which had the water of rainfall in it and which was situated by their side.Anas said that that constituted the wedding feast of Allah's Messenger (may peace be upon him).He (further) said: We proceeded until we saw the walls of Medina, and we were delighted.We made our mounts run quickly and Allah's Messenger (may peace be upon him) also made his mount run quickly.And Safiyya (Allah be pleased with her) was at his back, and Allah's Messenger (may peace be upon him) had seated her behind him.The camel of Allah's Messenger (may peace be upon him) stumbled and he (the Holy Prophet) fell down and she also fell down.And none among the people was seeing him and her, until Allah's Messeuger (may peace be upon him) stood up and he covered her, and we came to him and he said: We have received no injury.We entered Medina and there came out the young ladies of the household.They saw her (hadrat Safiyya) and blamed her for falling down.

Chapter 15 : PERTAINING TO THE MARRIAGE OF ZAINAB BINT JAHSH WITH THE HOLY PROPHET (MAY PEACE BE UPON HIM) AND VERSES PERTAINING TO PURDAH (VEIL)

Book 8, Number 3330:

    Anas (Allah be pleased with him) reported: When the 'Iddah of Zainab was over, Allah's Messenger (may peace be upon him) said to Zaid to make a mention to her about him. Zaid went on until he came to her and she was fermenting her flour. He (Zaid) said: As I saw her I felt in my heart an idea of her greatness so much so that I could not see towards her (simply for the fact) that Allah's Messenger (may peace be upon him) had made a mention of her. So I turned my back towards her. and I turned upon my heels, and said: Zainab, Allah's Messenger (may peace be upon him) has sent (me) with a message to you.She said: I do not do anything until I solicit the will of my Lord.So she stood at her place of worship and the (verse of) the Qur'an (pertaining to her marriage) were revealed, and Allah's Messenger (may peace be upon him) came to her without permission.He (the narrator) said: I saw that Allah's Messenger (may peace be upon him) served us bread and meat until it was broad day light and the people went away, but some persons who were busy in con- versation stayed on in the house after the meal.Allah's Messenger (may peace be upon him) also went out and I also followed him, and he began to visit the apartments of his wives greeting them (with the words): As-Salamu 'alaikum, and they would say: Allah's Messenger, how did you find your family (hadrat Zainab) ? He (the narrator) stated: I do not know whether I had informed him that the people had gone out or he (the Holy Prophet) informed me (about that).He moved on until he entered the apartment, and I also went and wanted to enter (the apartment) along with him, but he threw a curtain between me and him, as (the verfes pertaining to seclusion) had been revealed, and people were instructed in what they had been instructed.Ibn Rafii had made this addition in his narration : "O you who believe, enter not the houses of the Prophet unless permission is given to you for a meal, not waiting for its cooking being finished ... " to the words ". . . Allah forbears not from the truth."

Book 8, Number 3331:

    Anas (Allah be pleased with him) reported: I did not see Allah's Messenger (may peace be upon him) giving a wedding feast (on the marriage) of any one (of his wives) as he did in the case of (his marriage with) Zainab, for then he sacrificed a goat (on this occasion).

Book 8, Number 3332:

    Anas b. Malik (Allah be pleased with him) reported: Allah's Messenger (may peace be upon him) gave no better wedding feast than the one he did (on the occasion of his marriage with) Zainab.Thabit al-Bunani (one of the narrators) said: What did he serve in the wedding feast?He (Anas) said: He fed them bread and meat (so lavishly) that they (the guests) abandoned it (of their own accord after having taken them to their hearts' content).

Book 8, Number 3333:

    Anas b. Malik (Allah be pleased with him) reported: When Allah's Apostle (may peace be upon him) married Zainab bint jahsh, he invited people (to the wedding feast) and they ate food. They then sat there and entered into conversation. He (the Holy Prophet) made a stir as if he was preparing to stand up, but (the persons busy in talking) did not stand up.When he (the Holy Prophet) saw it, he stood up and when he did so, some other persons stood up.'Asim and Abd al-A'la in their narrations made this addition: Three (persons) sat there, and Allah's Apostle (may peace be upon him) came there to enter (the apartment) but he found the people sitting there.Then they stood up and went away.He said: Then I came and informed Allah's Apostle (may peace be upon him) that they had gone away.He (the Holy Prophet) then came there until he entered (the apartment).I also went and was about to enter, when he hung a curtain between me and him (and it was on this occasion that) Allah, the Exalted and Majestic, revealed this verse: "O you who believe, enter not the houses of the Prophet unless permission is given to you for a meal, not waiting for its cooking being finished to the (words) "Surely this is serious in the sight of Allah" (xxxiii. 53).

Book 8, Number 3334:

    Anas b. Malik (Allah be pleased with him) reported: I was the best informed among the people pertaining to Hijab (veil and seclusion).Ubayy b. Ka'b used to ask me about it.Anas (Allah be pleased with him) thus narrated: The Messenger of Allah (may peace be upon him) got up in the morning as a bridegroom of Zainab bint jahsh (Allah be pleased witt her) as he had married her at Medina.He invited people to the wedding feast after the day had well risen.There sat Allah's Messenger (may peace be upon him) and there kept sitting along with him some persons after the people had stood up (for departure); then Allah's Messenger (may peace be upon him) stood up and walked on and I also walked along with him until he reached the door of the apartment of 'A'isha (Allah be pleased with her).He then thought that they (those who had been sitting there after meal) had gone away.So he returned and I also returned with him, but they were still sitting at their places. So he returned for the second time and I also returned until he reached the apartment of 'A'isha. He again returned and I also returned and they had (by that time) stood up, and he hung a curtain between me and him (at the door of the apartment of Hadrat Zainab, where he had to stay), and Allah revealed the verse pertaining to veil.

Book 8, Number 3335:

    Anas b. Malik (Allah be pleased with him) reported: Allah's Messenger (may peace be upon him) contracted marriage and he went to his wife.My mother Umm Sulaim prepared hais and placed it in an earthen vessel and said: Anas, take it to Allah's Messenger (may peace be upon him) and say: My mother has sent that to you and she offers greetings to you, and says that it is a humble gift for you on our behalf, Messenger of Allah.So I went along with it to Allah's Messenger (may peace be upon him) and said: My mother offers you salutations, and says that it is a humble gift for you on our behalf.He said: Place it here, and then said: Go and invite on my behalf so and so and anyone whom you meet, and he even named some persons. He (Anas) said: I invited whom he had named and whom I met.I (one of the narrators) said: I said to Anas: How many (persons) were there?He (Anas) said: They were about three hundred persons.Then Allah's Messenger (may peace be upon him) (said to me): Anas, bring that earthen vessel.They (the guests) then began to enter until the courtyard and the apartment were fully packed.Allah's Messenger (may peace be upon him) said: Make a circle of ten (guests), and every person should eat from that nearest to him.They began to eat, until they ate to their fill.A group went out (after eating the food), and another group came in until all of them had eaten.He (the Holy Prophet) said to me: Anas, lift it (the earthen vessel), so I lifted it, but I could not assess whether it had more (food) when I placed it (before Allah's Messenger) or when I lifted it (after the people had been served out of it).A group among them (the guests) began to talk in the house of Allah's Messenger (may peace be upon him) and the Messenger of Allah (may peace be upon him) was sitting and his wife had been sitting with her face turned towards the wall.It was troublesome for Allah's Messenger (may peace be upon him), so Allah's Messenger (may peace be upon him) went out and greeted his wives.He then returned.When they (the guests) saw that Allah's Messenger (may peace be upon him) had returned they thought that it (their overstay) was something troublesome for him.He (the narrator) said: They hastened towards the door and all of them went out.And there came Allah's Messenger (may peace be upon him) and he hung a curtain and went in, and I was sitting in his apartment and he did not stay but for a short while.He then came to me and these verses were revealed.Allah's Messenger (may peace be upon him) came out and recited them to the people: "O you who believe, enter not the houses of the Prophet unless permission is given to you for a meal, not waiting for its cooking being finished-but when you are invited, enter, and when you have taken food, disperse not seeking to listen to talk.Surely this gives the Prophet trouble" , to the end of verse (xxxiii. 53). (Al-Ja'd said that Anas [b.Malik] stated: I am the first amongst the people to hear these verses), and henceforth the wives of the Apostle (may peace be upon him) began to observe seclusion (al-hijab).

Book 8, Number 3336:

    Anas (Allah be pleased with him) reported: When Allah's Apostle (may peace be upon him) contracted marriage with Zainab (Allah be pleased with bet), Umm Sulaim sent him hats in a vessel of stone as a gift.Anas stated that Allah's Messenger (may peace be upon him) said to him: Go and invite on my behalf all the Muslims whom you meet.So I invited on his behalf everyone whom I met.They entered (his house) and they ate and went out.And Allah's Messenger (may peace be upon him) had kept his hand on the food, and he invoked blessing on that, and said whatever Allah wished him to say, and none whom I met was left uninvited.They ate to their fill and went out, but a group among them remained there and was engaged in lengthy discussion. Allah's Apostle (may peace be upon him) felt shy of saying them anything.So he went out and left them in his house and Allah the Great and Majestic revealed this verse: "0 you who believe, enter not the houses of the Prophet unless permission is given to you for a meal, not waiting for its cooking being finished." Qatada (instead of using the word Ghaira Nazirina) used the word Ghaira Mutahayyinina (i.e. not waiting for the time of the food). But when you are invited, enter..."up to this verse. This is purer for your hearts and their hearts.

Chapter 16 : WHEN ONE IS INVITED TO A WEDDING FEAST, ONE SHOULD ACCEPT IT

Book 8, Number 3337:

    Ibn Umar (Allah be pleased with him) reported that Allah's Messenger (may peace be upon him) said: When any one of you is invited to a feast, he should attend it.

Book 8, Number 3338:

    Ibn 'Umar (Allah be pleased with them) reported Allah's Apostle (may peace be upon him) as saying: When any one of you is invited to a feast, he should accept.'Ubaidallah took this feast to be a wedding feast.

Book 8, Number 3339:

    Ibn Umar (Allah be pleased withthem) reported Allah's Apostle (may peace be upon him) having said this: When any one of you is invited to a wedding feast, he should accept that.

Book 8, Number 3340:

    Ibn Umar (Allah be pleased with them) reported Allah's Messenger (may be upon him) having said this: Accept the feast, when you are invited.

Book 8, Number 3341:

    Ibn Umar (Allah be pleased with them) reported Allah's Apostle (may peace be upon him) as saying: When any one of you invites his brother, he (the latter) should accept his wedding feast, or any other like it.

Book 8, Number 3342:

    Ibn 'Umar (Allah be pleated with them) reported Allah's Messenger (may peace be upon him) having said : He who is invited to a wedding feast or like it, he should accept it.

Book 8, Number 3343:

    "Abdullah b. Umar (Allah be pleased with them) reported Allah's Messen- ger (may peace be upon him) as saying: Come to the feast, when you are invited.

Book 8, Number 3344:

    Nafil reported: I heard Abdullah b. Umar (Allah be pleased with them) narrating that Allah's Messenger (may peace be upon him) said: Accept the feast when you are invited to it.And Abdullah (b.Umar) used to come to the feast, whether it was a wedding feast or other than that, and he would come there even in the state of fasting.

Book 8, Number 3345:

    Ibn Umar (Allah be pleased with them) reported Allah's Apostle (may peace be upon him) having said: When you are invited to a feast (even though it is) the leg of the sheep, you should accept it.

Book 8, Number 3346:

    Jabir (Allah be pleased with him) reported that Allah's Messenger (may peace he upon him) said: When any one of you is invited to a feast, he should accept it. He may eat if he likes, or he may abandon (eating) if he likes.Ibn Mathanni did not make mention of the word "feast".

Book 8, Number 3347:

    A hadith like this has been narrated on the authority of Abd Zubair with the same chain of transmitters.

Book 8, Number 3348:

    Abu Haraira (Allah be pleased with him) reported Allah's Messenger (may peace be upon him) as saying: If any one of you is invited, he should accept (the invitation).In case he is fasting, he should pray (in order to bless the inmates of the house), and if he is not fasting he should eat.

Book 8, Number 3349:

    Abu Huraira (Allah be pleased with him) used to say: The worst kind of food is the wedding feast to which the rich are invited and the poor are ignored.He who does not come to the feast, he in fact disobeys Allah and His Messenger (may peace be upon him).

Book 8, Number 3350:

    Sufyan reported: I said to Zuhri: Abu Bakr, what does this hadith mean: "The worst kind of food is at a wedding feast of the rich"?He laughed and said: The food served in the feast given by the rich is not worst (in itself).Sufyan said: My father was rich, so I felt disturbed when I heard this hadith, so I asked Zuhri who said: I heard from 'Abd al-Rahman al-Alraj that he heard Abu Huraira (Allah he pleased with him) say: The worst kind of food is that served at the wedding feast. The rest of the hadith is the same.

Book 8, Number 3351:

    This hadith has been narrated on the authority of Abu Huraira (Allah be pleased with him) through another chain of transmitters.

Book 8, Number 3352:

    A hadith like this has been narrated by Abu Huraira (Allah be pleased with him) through another chain of transmitters.

Book 8, Number 3353:

    Abu Haraira (Allah be pleased with him) reported Allah's Apostle (may peace be upon him) as saying.The worst kind of food is at the wedding feast from which one who comes is turned away, and he who refuses it is invited, and he who did not accept the invitation disobeyed Allah and His Messenger (may peace be upon him).

Chapter 17 :IT IS NOT PERMISSIBLE TO MARRY A WOMAN WHO IS DIVORCED BY THREE PRONOUNCEMENTS UNTIL SHE IS MARRIED TO ANOTHER MAN AND HE HAS A SEXUAL INTERCOURSE WITH HER, AND THEN HE ABANDONS HER AND SHE COMPLETES HER 'IDDA

Book 8, Number 3354:

    'A'isha (Allah he pleased with her) reported: There came the wife of Rifa'a to Allah's Apostle (may peace be upon him) and said: I was married to Rifa'a but he divorced me, making may divorce irrevocable.Afterwards I married Abd al-Rahman b. al-Zubair, but all he possesses is like the fringe of a garment (i.e. he is sexually weak).Thereupon Allah's Messenger (may peace be upon him) smiled, and said: Do you wish to return to Rifa'a. (You) cannot (do it) until you have tasted his sweetness and he ('Abd al-Rahman) has tasted your sweetness.Abu Bakr was at that time near him (the Holy Prophet) and Khalid (b. Sa'id) was at the door waiting for the permission to be granted to him to enter), He (Khalid) said; Abu Bakr, do you hear what she is saying loudly in the presence of Allah's Messenger (may peace be upon him)?

Book 8, Number 3355:

    'A'isha (Allah be pleased with her), the wife of Allah's Apostle (may peace be upon him), reported that Rifa'a al-Quraid (Allah be pleased with him) divorced his wife, making her divorce irrevocable.Afterwards she married Abd at-Rahman b. al-Zubair (Allah be pleased with him), She came to Allah'sApostle (may peace be upon him and said to Allah's messenger (may peace be upon him) that she had been the wife of Rifa'a (Allah be pleased with him) and he had divorced her by three pronouncements and afterwards she married 'Abd al-Rahman b. al-Zubair.By Allah, all he possesses is like the fringe of a garment, and she took hold of the fringe of her garment.Thereupon Allah's Messenger (may peace be upon him) laughed and said: Perhaps you wish to return to Rifa'a, (but you) cannot (do it) until he has tasted your sweetness and you have tasted his sweetness.Abu Bakr al-siddiq (Allah be pleased with him) was sitting at that time with Allah's Messenger (may peace be upon him) and Khalid b. Sa'id b. al-'As (Allah be pleased with him) was sitting at the door of his apartment and he was not permitted to (enter the room), and Kbalid called loudly saying: Abu Bakr, why don't you scold her for what she is saying loudly in the presence of Allah's Messenger (may peace be upon him)?

Book 8, Number 3356:

    'A'isha (Allah bjpl'eased with her) reported that Rifa'a al Qurazi divorced his wife and afterwards Abd al-Rahman b. al-Zubair married her.She came to Allah's Apostle (may peace he upon him) and said: Messenger of Allah, Rifa'a has divorced me by three pronouncements. (The rest of the hadith is the same.)

Book 8, Number 3357:

    'A'isha (Allah be pleased with her) reported that Allah's Messenger (may peace be upon him) was asked about a woman whom a man married and then divorced her, and then she married (another) person, and she was divorced before sexual intercourse with her, whether it was lawful for her first husband (to marry her in this state).He (the Holy Prophet) said: No, until he has tasted her sweetness.

Book 8, Number 3358:

    A hadith like this has been narrated on the authority of Hisham with the same chain of transmitters.

Book 8, Number 3359:

    'A'Asha (Allah be pleased with her) reported: A person divorced his wife by three pronouncements; then another person married her and he also divorced her without having sexual intercourse with her.Then the first husband of her intended to remarry her.It was about such a case that Allah's Messenger (may peace be upon him) was asked, whereupon he said: No, until the second one has tasted her sweetness as the first one had tasted.

Book 8, Number 3360:

    A hadith like this has been narrated on the same chain of transmitters by 'A'isha (Allah be pleased with her).

Chapter 18 : WHAT IS TO BE SUPPLICATED AT THE TIME OF SEXUAL INTERCOURSE

Book 8, Number 3361:

    Ibn "Abbas (Allah be pleased with thern) reported that Allah's Messenger (may peace be upon him) said: If anyone amongst you intends to go to his wife he should say: In the name of Allah, 0 Allah protect us against Satan and keep away the Satan from the one that you have bestowed upon us, and if He has ordained a male child for them, Satan will never be able to do any harm to him.

Book 8, Number 3362:

    This hadith is narrated through another chain of transmitters and there is no mention of (the words) "Bismillah" (In the name of Allah) in it.

Chapter 19 : PERMISSIBILITY OF HAVING SEXUAL INTERCOURSE WITH ONE'S WIFE FROM THE FRONT OR FROM BEHIND AVOIDING THE ANUS

Book 8, Number 3363:

    Jabir (Allah be pleased with him) declared that the Jews used to say: When a man has intercourse with his wife through the vagina but being on her back. the child will have squint, so the verse came down: "Your wives are your tilth; go then unto your tilth as you may desire"(ii. 223)

Book 8, Number 3364:

    Jabir (b.Abdullah) (Allah be pleased with him) reported that the Jews used to say that when one comes to one's wife through the vagina, but being on her back, and she becomes pregnant, the child has a squint. So the verse came down: "Your wives are your ti'Ith; go then unto your tilth, as you may desire."

Book 8, Number 3365:

    This hadith has been reported on the authority of Jabir through another chain of transmitters, but in the hadith transmitted on the authority of Zuhri there is an addition (of these words): "If he likes he may (have intercourse) being on the back or in front of her, but it should be through one opening (vagina)."

Chapter 20 : IT IS NOT PERMISSIBLE FOR A WOMAN TO ABANDON THE BED OF HER HUSBAND

Book 8, Number 3366:

    Abu Huraira (Allah be pleased with him) reported that Allah's Apostle (may peace be upon him) said: When a woman spends the night away from the bed of her husband, the angels curse her until morning.This hadith has been narrated through the same chain of transmitters (with a slight variation): "He said: Until she comes back."

Book 8, Number 3367:

    Abu Huraira (Allah be pleased with him) reported Allah's Messenger (may peace be upon him) as saying: By Him in Whose Hand is my life, when a man calls his wife to his bed, and she does not respond, the One Who is in the heaven is displeased with her until he (her husband) is pleased with her.

Book 8, Number 3368:

    Abu Huraira (Allah he pleased with him) reported Allah's Messenger (may, peace be upon him) as saying: When a man invites his wife to his bed and she does not come, and he (the husband) spends the sight being angry with her, the angels curse her until morning.

Chapter 21 : IT IS FORBIDDEN TO DIVULGE THE SECRET OF THE WOMAN

Book 8, Number 3369:

    Abu Sa'id al-Khudri (Allah he pleased with him) reported that Allah's Messenger (may peace be upoin him)said : The most wicked among the people in the eye of Allah on the Day of judgment is the men who goes to his wife and she comes to him, and then he divulges her secret.

Book 8, Number 3370:

    Abu Sirma al-Khudri (Allah he pleased with him ) reported Allah's Messen- ger (may peace be upon him) as saying: The most important of the trusts in the sight of Allah on the Day of judgment is that a man goes to his wife and she goes to him (and the breach of this trust is) that he should divulge her secret Ibn Numair narrates this hadith with a slight change of wording.

Chapter 22 : AL AZL (INCOMPLETE SEXUAL INTERCOURSE): COITUS INTERRUPTUS

Book 8, Number 3371:

    Abu Sirma said to Abu Sa'id al Khadri (Allah he pleased with him): 0 Abu Sa'id, did you hear Allah's Messenger (may peace be upon him) mentioning al-'azl ?He said: Yes, and added: We went out with Allah's Messenger (may peace be upon him) on the expedition to the Bi'l-Mustaliq and took captive some excellent Arab women; and we desired them, for we were suffering from the absence of our wives, (but at the same time) we also desired ransom for them.So we decided to have sexual intercourse with them but by observing 'azl (Withdrawing the male sexual organ before emission of semen to avoid-conception).But we said: We are doing an act whereas Allah's Messenger is amongst us; why not ask him?So we asked Allah's Mes- senger (may peace be upon him), and he said: It does not matter if you do not do it, for every soul that is to be born up to the Day of Resurrection will be born.

Book 8, Number 3372:

    A hadith like this has been narrated on the authority of Habban with the same chain of transmitters (but with this alteration) that he said: "Allah has ordained whom he has to createuntil the Day of judgment."

Book 8, Number 3373:

    Abu Sa'id al-Khudri (Allah be pleased with him) reported: We took women captives, and we wanted to do 'azl with them.We then asked Allah's Messen- ger (may peace be upon him) about it, and he said to us: Verily you do it, verily you do it, verily you do it, but the soul which has to be born until the Day of judg- ment must be born.

Book 8, Number 3374:

    Abu Sa'id al-Khudri (Allah be pleased with him) (was asked if he had heard it himself), to which he said: Yes. (I heard) Allah's Apostle (may peace be upon him) as saying: There is no harm if you do not practise it, for it (the birth of the child) is something ordained (by Allah).

Book 8, Number 3375:

    This hadith is reported on the authority of Abu Sa'id with the same chain of transmitters but with a slight variation (of words).

Book 8, Number 3376:

    Abu Sa'id al-Khudri (Allah be pleased with him) reported that Allah's Apostle (may peace be upon him) was asked about 'azl, whereupon he said: There is no harm if you do not do that, for it (the birth of the child) is something ordained. Muhammad (one of the narrators) said: (The words) La 'alaykum (there is no harm) implies its Prohibition.

Book 8, Number 3377:

    Abu Sa'id al-Khudri (Allah be pleased with him) reported that mention was made of 'azl in the presence of Allah's Apostle (may peace be upon him) whereupon he said: Why do you practise it?They said: There is a man whose wife has to suckle the child, and if that person has a sexual intercourse with her (she may conceive) which he does not like, and there is another person who has a slave-girl and he has a sexual intercourse with her, but he does not like her to have conception so that she may not become Umm Walad, whereupon he (the Holy Prophet) said: There is no harm if you do not do that, for that (the birth of the child) is something pre- ordained.Ibn 'Aun said: I made a mention of this hadith to Hasan, and he said: By Allah, (it seems) as if there is upbraiding in it (for 'azl).

Book 8, Number 3378:

    Ibn 'Aun reported: I reported to Muhammad on the authority of Ibrahim the hadith reported by 'Abd al-Rahmann b. Bishr (the hadith concerning 'azl), where- upon he said: That (hadith) Abd al-Rahman b. Bishr had narrated to me (also).

Book 8, Number 3379:

    Ma'bad b. Sirin said to Abu Sa'id (Allah be pleased with him): Did you hear Allah's Messenger (may peace be upon him) making a mention of something in regard to al-'azl? Thereupon he said: Yes.The rest (of the hadith is the same)

Book 8, Number 3380:

    Abu Sa'id al-Khudri (Allah be pleased with him) reported: Mention was made about al-'azl in the presence of Allah's Messenger (may peace be upon him), whereupon he said: Why any one of you practises it ? (He did not say: One of you should not do it), for there is no created soul, whose creator is not Allah.

Book 8, Number 3381:

    Abu Sa'id al-Khudri (Allah be pleased with him) reported that Allah's Messenger (may peace be upon him) was asked about 'azl, whereupon he said: The child does not come from all the liquid (sermen) and when Allah intends to create anything nothing can prevent it (from coming into existence).

Book 8, Number 3382:

    A hadith like this has been transmitted by Abu Sa'id from Allah's Apostle (may peace be upon him).

Book 8, Number 3383:

    Jabir (Allah be pleased with him) reported that a man came to Allah's Messenger (may peace be upon him) and said: I have a slave-girl who is our servant and she carries water for us and I have intercourse with her, but I do not want her to conceive.He said: Practise 'azl, if you so like, but what is decreed for her will come to her.The person stayed back (for some time) and then came and said: The girl has become pregnant, whereupon he said: I told you what was decreed for her would come to her.

Book 8, Number 3384:

    Jabir b. 'Abdullah (Allah be pleased with them) reported that a person asked Allah's Apostle (may peace be upon him) saying: I have a slave-girl and I practise 'azl with her, whereupon Allah's Messenger (may peace be upon him) said: This cannot prevent that which Allah has decreed.The person then came (after some time) and said: Messenger of Allah, the slave-girl about whom I talked to you has conceived, whereupon Allah's Messeuger (may peace be upon him) said: I am the servant of Allah and His Messenger.

Book 8, Number 3385:

    Jabir b. 'Abdullah (Allah be pleased with them) reported: A person came to Allah's Apostle (the rest of the hadith is the same).

Book 8, Number 3386:

    Jabir (Allah be pleased with him) reported: We used to practise 'azl while the Qur'an was revealed (during the days when the Holy Prophet was alive).

Book 8, Number 3387:

    Jabir (Allah be pleased with him) reported: We used to practise 'azl during the life of Allah's Messenger (may peace be upon him).

Book 8, Number 3388:

    Jabir (Allah be pleased with him) reported: We used to practise 'azl during the lifetime of Allah's Messenger (may peace be upon him).This (the news of this practise) reached Allah's Apostle (may peace be upon him), and he did not forbid us.

Chapter 23 : IT IS FORBIDDEN TO HAVE INTERCOURSE WITH A PREGNANT SLAVE-WOMAN

Book 8, Number 3389:

    Abu Darda' (Allah be pleased with him) related from the Prophet of Allah (may peace be upon him) that he came upon a woman who was in the advanced stage of pregnancy at the door of a tent.He (the Holy Prophet) said: Perhaps he (the man accompanying her) intends to cohabit with her.They said: Yes.Thereupon Allah's Messenger (may peace be upon him) said: I have decided to curse him with such a curse as may go along with him to his grave.How can he own him (the child to be born) and that is not lawful for him, and how can he take him as a servant for that is not lawful for him?

Book 8, Number 3390:

    A hadith like this has been transmitted on the authority of Shu'ba.

Chapter 24 : PERMISSIBILITY OF INTERCOURSE WITH A SUCKLING LADY AND DISAPPROVAL OF 'AZL

Book 8, Number 3391:

    Judaima daughter of Wahb al-Asadiyya (Allah be pleased with her) reported that she heard Allah's Messenger (may peace be upon him) assaying: I intended to prohibit cohabitation with a suckling woman until I considered that the Romans and the Persians do it without any injury being caused to their children thereby. (Imam Muslim said: Khalaf reported it from Judamat al-'Asadiyya, but the correct wording is what has been stated by Yahya.)

Book 8, Number 3392:

    Judama daughter of Wahb, sister of Ukkasha (Allah be pleased with her). reported: I went to Allah's Messenger (may peace be upon him) along with some persons and he was saying: I intended to prohibit cohabitation with the suckling women, but I considered the Greeks and Persians, and saw that they suckle their children and this thing (cohabitation) does not do any harm to them (to the suckling women).Then they asked him about 'azl, whereupon he said.That is the secret (way of) burying alive, and Ubaidullah has made this addition in the hadith transmitted by al-Muqri and that is: "When the one buried alive is asked."

Book 8, Number 3393:

    Judama bint Wahb al-Asadiyya (Allah be pleased with her) reported: I heard Allah's Messenger (may peace be upon him) saying this. The rest of the hadith is the same concerning 'azl and ghila (cohabitating with a suckling woman), but with a slight variation of words.

Book 8, Number 3394:

    Sa'd b. Abu Waqqas (Allah be pleased with him) reported that a person came to Allah's Messenger (may peace be upon him) and said: I do 'azi with my wife. Thereupon Allah's Messenger (may peace be upon him) said: Why do you do that? The person said: I fear harm to her child or her children.Thereupon Allah's Messenger (way peace be upon him) said:If that were harmful it would harm the Persians and the Greeks.

Chapter 25 :KITAB AL-RADA'A-BOOK PERTAINING TO FOSTERAGE

Book 8, Number 3395:

    'A'isha (Allah be pleased with her) reported tha Allah's Messenger (may peace be upon him) was with her and she heard the voice of a person seeking permission to enter the house of Hafsa.'A'isha (Allah he pleased with her) said: Allah's Messenger, he is the person who seeks permission to enter your house, whereupon Allah's Messenger (may peace be upon him) said: I think he is so and so (uncle of Hafsa by reason of fosterage).'A'isha said : Messenger of Allah, if so and so (her uncle by reason of fosterage) were alive, could he enter my house?Allah's Messenger (may peace be upon him) said: Yes.Fosterage makes unlawful what consanguinity makes unlawful.

Book 8, Number 3396:

    'A'isha (Allah be pleased with her) reported Allah's Messenger (may peace be upon him) as saying: Fosterage makes unlawful what consanguinity makes unlawful.

Book 8, Number 3397:

    'A'isha (Allah be pleased with her) reported that Aflah, the brother of Abu'l-Qu'ais, who was her uncle by reason of fosterage, came, and asked her permission (to enter the house) after seclusicin was instituted.I refused to admit him. When Allah's Messenger (may peace be upon him) came, I Informed him what I had done.He commanded me to grant him permission (as the brother of her foster-father was also her uncle).

Book 8, Number 3398:

    'A'isha (Allah be pleased with her) reported: There came to me Aflah b. Abu Qulais, my uncle by reason of fosterage; the rest of the hadith is the same (but with this) addition: "I ('A'isha) said (to the Holy Prophet): It was the woman who suckled me and not the man, whereupon he (Allah's Messenger) said: May your hands or your right hand be besmeared with dust (you were mistaken)."

Book 8, Number 3399:

    'A'isha (Allah be pleased with her) reported that there came Aflah the brother, of Abu'l-Qu'ais, who sought her permission (to enter) after seclusion was instituted, and AbuQu'ais was the father of 'A'isha by reason of fosterage.'A'isha said: By Allah, I would not permit Aflah unless I have solicited the opinion of Allah's Messenger (may peace be upon him) for Abu Qulais has not suckled me, but his wife has given me suck. 'A'isha'(Allah be pleased with her) said: When Allah's Messenger (may peace be upon him) entered, I said: Allah's Messenger, Aflah is the brother of Abu'l-Qulais; he came to me to seek my permission for entering (the houst).I did not like the idea of granting him permission until I had solicited your opinion.Thereupon Allah's Apostle (may peace be upon him) said: Grant him permission.'Urwa said it was on account of this that 'A'isha used to say.What is unlawful by reason of consanguinity is unlawful by reason of fosterage.

Book 8, Number 3400:

    This ha0dith has been narrated on the authority of Zuhri with the same chain of transmitters (that 'A'isha said): There came Aflah, the brother of Abu'l Qulais (Allah be pleased with him), and sought permission from her,the rest of the hadith is the same (except for the words that the Holy Prophet) said: "He is your uncle.Let your hand be besmeared with dust.Abu'l Qulais was the husband of the woman who had suckled 'A'isha (Allah be pleased with her).

Book 8, Number 3401:

    'A'isha (Allah be pleased with her) reported: My foster uncle came to me and sought permission (to enter the house), but I refused him permission until I had solicited the opinion of Allah's Messenger (may peace be upon him).When Allah's Messenger (may peace be upon him) came, I said to him: My foster-uncle sought my permission to (enter the house), but I did not permit him, whereupon Allah's Messenger (may peace be upon him) said: You better admit your uncle (into the house). I ('A'isha) said: It was the woman who suckled me and not the man. (But he) said: He is your uncle, admit him.

Book 8, Number 3402:

    This hadith has been narrated on the authority of Hisham with the same chain of transmitters (and the words are): "The brother of Abu'l-Qu'ais sought permission from her ('A'isha) (to enter the house).The rest is the same.

Book 8, Number 3403:

    This hadith has been narrated on the authority of Hisham with the same chain of transmitters but with a slight variation of words.

Book 8, Number 3404:

    'A'isha (Allah be pleased with her) reported: My foster-uncle Abu'l Ja'd (kunya of Aflah) sought permission from me, which I refused. (Hisham said to me that Abu'l-Ja'd was in fact Abu'l-Qu'ais).When Allah's Apostle (may peace be upon him) came, I ('A'isha) informed him about it.He said: Why did you not permit him?Let your right hand or hand be besmeared with dust.

Book 8, Number 3405:

    'A'isha (Allah be pleased with her) reported that her foster-uncle whose name was Aflah sought permission from her (to enter the house) but she observed seclusion from him, and informed Allah's Messenger (may peace be upon him) who said to her: Don't observe veil from him for he is Mahram (one with whom marriage cannot be contracted) on account of fosterage as one is Mahram on account of consanguinity.

Book 8, Number 3406:

    'A'isha (Allah be pleased with her) reported: Aflah b. Qu'ais sought permission from me (to enter the house), but I refused to grant him the permission, and he sent me (the message saying): I am your uncle (in the sense) that the wife of my brother has suckled you, (but still) I refused to grant him permission.There came the Messenger of Allah (may peace be upon him) and I made a mention of it to him, and he said: He can enter (your house), for he is your uncle.

Book 8, Number 3407:

    'Ali (Allah be pleased with him) reported having said this : Messenger of Allah, why is it that you select (your wife) from among the Quraish, but you ignore us (the nearest of the kin)?Thereupon he said: Have you anything for me (a suitable match for me)? I said; Yes, the daughter of Hamza, whereupon Allah's Messenger (may peace be upon him) said: She is not lawful for me, for she is the daughter of my brother by reason of fosterage.

Book 8, Number 3408:

    A hadith like this has been narrated on the authority of A'mash with the same chain of transmitters.

Book 8, Number 3409:

    Ibn Abbas (Allah be pleased with them) reported: It was proposed that he (the Holy Prophet) be married to the daughter of Hamza, whereupon he said: She is not lawful for me for she is the daughter of my foster-brother, and that is unlawful by reason of fosterage what is unlawful by reason of genealogy.

Book 8, Number 3410:

    A hadith like this is narrated on the authority of Hammam, Sa'id, Bishr b 'Umar, but with a small variation of words.

Book 8, Number 3411:

    Umm Salama (Allah be pleased with her), the wife of Allah's Apostle (may peace be upon him), said: It was said to the Messenger of Allah (may peace be upon him): Is not the daughter of Hamza a suitable match for you?Or it was said: Why don't you propose to marry the daughter of Hamza, the son of Abd al-Muttalib? Thereupon he said: Hamza is my brother by reason of fosterage.

Chapter 26 : IT IS FORBIDDEN TO MARRY THE STEP-DAUGHTER AND THE SISTER OF THE WIFE (WHEN WIFE IS ALIVE AND NOT DIVORCED)

Book 8, Number 3412:

    Umm Habiba, the daughter of AbuSufyan, reported: The Messenger of Allah (may peace be upon him) came to me and I said to him: Have you any inclination towards my the daughter of Abu Sufyan? He (the Holy Prophet) said: Then what should I do ? I said : Marry her.He said : Do you like that ? I said: I am not the exclusive (wife) of yours; I, therefore, wish to join my sister in good. He,said: She is not lawful for me. I said: I have been informed that you have given the proposal of marriage to Durrah daughter of Abu Salama He raid: You mean the daughter of Umm Salama? I said: Yes.He said: Even if she had not been my step-daughter brought up under my guardianship, she would not have been lawful for me, for she is the daughter of my foster-brother (Hamza), for Thuwaiba had suckled me and her father.So do not give me the proposal of the marriage of your daughters and sisters. This hadith has been narrated on the authority of Hisham with the same chain of transmitters.

Book 8, Number 3413:

    Umm Habiba, the wife of Allah's Apostle (may peace be upon him), reported that she said to Allah's Messenger (may peace be upon him): Messenger of Allah, marry my sister 'Azza, whereupon Allah's Messenger (may peace be upon him) said: Do you like it? She said: Yes, Messenger of Allah, I am not the exclusive wife of yours, and I wish that the person who joins me in good should be my sister. Thereupon Allah's Messenger (may peace be upon him) said: That is not lawful for me. I said: Messenger of Allah, we discussed that You intend to marry Durrah bint Abu Salama.He (the Holy Prophet) said: You mean the daughter of Abu Salama? She said: Yes, whereupon Allah's Messenger (may. peace be upon him) said: Even if she were not the step-daughter of mine, brought up under my guardianship, she would not have been lawful for me, for she is the daughter of my foster-brother. Thuwaiba gave me suck and to Abu Salama (also), so do not offer to me your daughters and sisters.

Chapter 27 : ONE SUCKLING OR TWO DO NOT MAKE MARRIAGE UNLAWFUL

Book 8, Number 3414:

    'A'isha (Allah be pleased with her), Suwaid and Zubair reported Allah's Apostle (may peace be upon him) as saying: One suckling or two do not make (marriage) unlawful.

Book 8, Number 3415:

    Umm al-Fadl reported: A bedouin came to Allah's Apostle (may peace be upon him) when he was in my house and said: Allah's Apostle, I have had a wife and I married another besides her, and my first wife claimed that she had suckled once or twice my newly married wife, thereupon Allah's Apostle (may peace be upon him) said: One suckling or two do not make the (marriage) unlawful.

Book 8, Number 3416:

    Umm Fadl (Allah be pleased with her) reported that a person from Banu 'Amir b. Sa'sa said: Allah's Apostle, does one suckling make the (marriage) unlawful? He said: No.

Book 8, Number 3417:

    Umm Fadl (Allah be pleased with her) reported that Allah's Apostle (may peace be upon him) said: Being suckled once or twice, or one suckling or two, do not make marriage unlawful.

Book 8, Number 3418:

    In the narration transmitted on the authority of Ibn Bishr there is a mention of two sucklings and Ibn Abu Shaiba has narrated it with a small variation of wording.

Book 8, Number 3419:

    Umm Fadl (Allah be pleased with her) reported Allah's Apostle (may peace be'apon him) having said this: One or two sucklings do not make (the marriage) unlawful.

Book 8, Number 3420:

    Umm Fadl (Allah be pleased with her) reported that a person asked Allah's Apostle (may peace be upon him): Does one suckling make (the marriage) unlawful? He said: No.

Book 8, Number 3421:

    'A'isha (Allah be pleased with, her) reported that it had been revealed in the Holy Qur'an that ten clear sucklings make the marriage unlawful, then it was abrogated (and substituted) by five sucklings and Allah's Apostle (may peace be upon him) died and it was before that time (found) in the Holy Qur'an (and recited by the Muslims).

Book 8, Number 3422:

    'Amra reported that she beard 'A'isha (Allah he pleased with her) discussing fosterage which (makes marriage) unlawful; and she ('A'isha) said: There was revealed in the Holy Qur'an ten clear sucklings, and then five clear (sucklings).

Book 8, Number 3423:

    Ahadith like this is transmitted by 'A'isha through another chain of narrators.

Chapter 28 :SUCKLING OF A YOUNG (BOY)

Book 8, Number 3424:

    ' A'isha (Allah be pleased with her) reported that Sahla bint Suhail came to Allah's Apostle (may peace be eupon him) and said: Messengerof Allah, I see on the face of Abu Hudhaifa (signs of disgust) on entering of Salim (who is an ally) into (our house), whereupon Allah's Apostle (may peace be upon him) said: Suckle him.She said: How can I suckle him as he is a grown-up man?Allah's Messenger (may peace be upon him) smiled and said: I already know that he is a young man 'Amr has made this addition in his narration that he participated in the Battle of Badr and in the narration of Ibn 'Umar (the words are): Allah's Messenger (may peace be upon him) laughed.

Book 8, Number 3425:

    'A'isha (Allah be pleased with her) reported that Salim, the freed slave of Abu Hadhaifa, lived with him and his family in their house.She (i.e. the daughter of Suhail came to Allah's Apostle (may peace be upon him) and said: Salim has attained (purbety) as men attain, and he understands what they understand, and he enters our house freely, I, however, perceive that something (rankles) in the heart of Abu Hudhaifa, whereupon Allah's Apostle (may peace be upon him) said to her: Suckle him and you would become unlawful for him, and (the rankling) which Abu Hudhaifa feels in his heart will disappear. She returned and said: So I suckled him, and what (was there) in the heart of Abu Hudhaifa disappeared.

Book 8, Number 3426:

    Ibn Abu Mulaika reported that al-Qasim b. Muhammad b. Abu Bakr had narrated to him that 'A'isha (Allah be pleased with her) reported that Sahla bint Suhail b. 'Amr came to Allah's Apostle (may peace be upon him) and said: Messenger of Allah, Salim (the freed slave of Abu Hudhaifa) is living with us in our house, and he has attained (puberty) as men attain it and has acquired knowledge (of the sex problems) as men acquire, whereupon he said: Suckle him so that he may become unlawful (in regard to marriage) for you He (Ibn Abu Mulaika) said: I refrained from (narrating this hadith) for a year or so on account of fear.I then met al-Qasim and said to him: You narrated to me a hadith which I did not narrate (to anyone) afterwards.He said: What is that? I informed him, whereupon he said: Narrate it on my authority that 'A'isha (Allah be pleased with her) had narrated that to me.

Book 8, Number 3427:

    Umm Salama said to 'A'isha (Allah be pleased with her): A young boy who is at the threshold of puberty comes to you. I, however, do not like that he should come to me, whereupon 'A'isha (Allah be pleased with her) said: Don't you see in Allah's Messenger (may peace be upon him) a model for you? She also said: The wife of Abu Hudhaifa said: Messenger of Allah, Salim comes to me and now he is a (grown-up) person, and there is something that (rankles) in the mind of Abu Hudhaifa about him, whereupon Allah's Messenger (may peace be upon him) said: Suckle him (so that he may become your foster-child), and thus he may be able to come to you (freely).

Book 8, Number 3428:

    Zainab daughter of Abu Salama reported: I heard Umm Salama, the wife of Allah's Apostle (may peace be upon himy, saying to 'A'isha: By Allah, I do not like to be seen by a young boy who has passed the period of fosterage, whereupon she ('A'isha) said: Why is it so?Sahla daughter of Suhail came to Allah's Messenger (may peace be upon him) and said: Allah's Messenger, I swear by Allah that I see in the face of Abu Hudhaifa (the signs of disgust) on account of entering of Salim (in the house), whereupon Allah's Messenger (may peace be upon him) said: Suckle him.She (Sahla bint Suhail) said: He has a heard.But he (again) said: Suckle him, and it would remove what is there (expression of disgust) on the face of Abu Hudhaifa.She said: (I did that) and, by Allah, I did not see (any sign of disgust)on the face of Abu Hadhaifa.

Book 8, Number 3429:

    Umm Salama, the wife of Allah's Apostle (may peace be upon him), used to say that all wives of Allah's Apostle (may peace be upon him) disclaimed the idea that one with this type of fosterage (having been suckled after the proper period) should come to them. and said to 'A'isha: By Allah, we do not find this but a sort of concession given by Allah's Messenger (may peace be upon him) only for Salim, and no one was ging to be allowed to enter (our houses) with this type of fosterage and we do not subscribe to this view.

Book 8, Number 3430:

    'A'isha (Allah be pleased with her) reported: Allah's Messenger (may peace be upon him) visited me when a man was sitting near me, and he seemed to disapprove of that.And I saw signs of anger on his face and I said: Messenger of Allah, he is my brother by forsterage, whereupon he said: Consider who your brothers are because of fosterage since fosterage is through hunger (i.e. in infancy).

Book 8, Number 3431:

    This hadith is narrated on the authority of Abd al-Ahwas with another chain of transmitters and a slight variation of words.

Chapter 29 : IT IS PERMISSIBLE TO HAVE SEXUAL INTERCOURSE WITH A CAPTIVE WOMAN AFTER SHE IS PURIFIED (OF MENSES OR DELIVERY) IN CASE SHE HAS A HUSBAND, HER MARRIAGE IS ABROGATED AFTER SHE BECOMES CAPTIVE

Book 8, Number 3432:

    Abu Sa'id al-Khudri (Allah her pleased with him) reported that at the Battle of Hanain Allah's Messenger (may peace be upon him) sent an army to Autas and encountered the enemy and fought with them.Having overcome them and taken them captives, the Companions of Allah's Messenger (may peace te upon him) seemed to refrain from having intercourse with captive women because of their husbands being polytheists.Then Allah, Most High, sent down regarding that: "And women already married, except those whom your right hands possess (iv. 24)" (i.e. they were lawful for them when their 'Idda period came to an end).

Book 8, Number 3433:

    Abu Sa'id al-Khudri (Allah be pleased with him) reported that Allah's Apostle (may peace be upon him) sent a small army.The rest of the hadith is the same except this that he said: Except what your right hands possessout of them are lawful for you; and he did not mention "when their 'idda period comes to an end". This hadith has been reported on the authority of AbuSa'id (al-Khudri) (Allah be pleased with him) through another chain of transmitters and the words are: They took captives (women) on the day of Autas who had their husbands. They were afraid (to have sexual intercourse with them) when this verse was revealed: "And women already married except those whom you right hands posses" (iv. 24)

Book 8, Number 3434:

    Qatada reported a hadith like this with the same chain of transmitters.

Chapter 30 : THE CHILD IS TO BE ATTRIBUTED TO ONE ON WHOSE BED IT IS BORN AND ONE MUST AVOID SUSPICION

Book 8, Number 3435:

    'A'isha (Allah be pleased with her) reported: Sa'd b. Abu Waqqas and Abd b. Zam'a (Allah be pleased with them) disputed with each other over a young boy.Sa'd said: Messenger of Allah, he is the son of my brother 'Utba b. Abu Waqqas as he made it explicit that he was his son.Look at his resemblance.Abd b. Zam'a said Messenger of Allah, he is my brother as he was born on the bed of my father from his slave-girl.Allah's Messenger (way peace he upon him) looked at his resembl-. ance and found a clear resemblance with 'Utba. (But) he said: He is yours 0 'Abd (b. Zam'a), for the child is to be attributed to one on whose bed it is born, and stoning for a fornicator.Sauda bint Zam'a,O you should observe veil from him. So he did not see Sauda at all.Muhammad b. Rumh did not make a mention(of the words): "O Abd."

Book 8, Number 3436:

    A hadith like this is narrated on the authority of Ibn 'Uyaiyna and Ma'mar (and the words are): The child is attributed to him on whose bed he is born; but they did not mention this: "For a fornicator there is stoning."

Book 8, Number 3437:

    Abu Huraira (Allah be pleased with him) reported Allah's Messenger (may peace be upon him) as saying: The child is to be attributed to one on whose bed he is born, and for a fornicator there is stoning.

Book 8, Number 3438:

    A hadith like this is narrated on the authority of Abu Huraira.

Chapter 31 : TRACING OF RELATIONSHIP FROM PHYSICAL FEATURES

Book 8, Number 3439:

    'A'isha (Allah be pleased with her) reported: Allah's Messenger (may peace be upon him) visited me looking pleased as if his face was glistening and said: Did you see that Mujazziz cast a glance at Zaid b. Haritha and Usama b. Zaid, and (then) said: Some (of the features) of their feet are found in the others?

Book 8, Number 3440:

    'A'isha (Allah be pleased with her) reported: One day Allah's Apostle (may peace be upon him) visited me looking pleased and he said: 'A'isha, don't you see Mujazziz al-Mudliji?(He) entered (my house) and saw Usama and Zaid with a rug over them covering their heads, but their feet appeared, and (he) said: These feet are related to one another.

Book 8, Number 3441:

    'A'isha (Allah be pleased with her) reported: A physiognomist visited (our house) and Allah's Messenger (may peace be upon him) was present, and Usama b. Zaid and Zaid b. Haritha were both lying asleep, and he (the physiognomist), said: These feet are related to one another. Allah's Apostle (may peace be upon him) was pleased to hear this, and he was happy and informed 'A'isha (Allah be pleased with her) about it.

Book 8, Number 3442:

    A hadith like this has been narrated on the authority of Zuhri and Yunus said: Mujazziz was a physiognomist.

Chapter 32 : HOW LONG AFTER MARRYING ONE SHOULD STAY WITH A VIRGIN OR A WOMAN PREVIOUSLY MARRIED

Book 8, Number 3443:

    'Abd al-Malik b.Abu Bakr b. Abd al-Rahman b.al-Harith b.Hisham reported on the authority of his father from Umm Salama (Allah be pleased with her) that when Allah's Messenger (may peace be upon him) married Umm Salama, he stayed with her for three nights, and said: There is no lack of estimation on the part of your husband for you.If you wish I can stay with you for a week, but in case I stay with you for a week, then I shall have to stay for a week with all my wives.

Book 8, Number 3444:

    Ibn Abu Bakr b. Abd al-Rahman reported that when Allah's Messenger (may peace be upon him) married Umm Salama and she stayed with him (during the night), and it was dawn, he (the Holy Prophet) said to her: There is no lack of estimation for you on the part of your husband.So if you desire I can spend a week with you, and if you like I may spend three (nights). and then I will visit you in turn. She said: Spend three (nights).

Book 8, Number 3445:

    Abu Bakr b. 'Abd al-Rahman reported that when Allah's Messenger (may peace be upon him) married Umm Salama and he visited her, and when he intended to come out, she caught hold of his cloth. whereupon Allah's Messenger (may peace be upon him) said: If you so desire, I can extend the time (of my stay) with you, but then I shall have to calculate the time (that I stay with you and shall have to spend the same time with other wives).For the virgin woman, (her husband has to stay with her) for a week, and for the woman previously married it is three days.

Book 8, Number 3446:

    A hadith like this has been narrated on the authority of Ibn Humaid.

Book 8, Number 3447:

    Umm Salama (Allah be pleased with her) reported that Allah's Messenger (may peace be upon him) married her, and he (the narrator) made mention of so many things in this connection (and one of them was this) that he said: If you desire that I spend a week with you, I shall have to spend a week with my (other) wives, and if spend a week with you, I shall have to spend a week with my (other) wives.

Book 8, Number 3448:

    Anas b. Malik reported: When anyone who has already a wife marries virgin, he should stay with her for seven nights (and then turn to his other wife), but when anyone having a virgin with him (as his wife) marries a woman who has been previously married he should stay with her for three nights.Khalid (one of the narrators) said.If I were to say that it could be directly traced to the Holy Prophet (may peace be upon him). I would have told the truth, but he (Hadrat Anas) said: Such is the tradition.

Book 8, Number 3449:

    Abu Qilaba reported on the authority of Anas: It is the Sunnph to stay with a virgin (after having married her) for a week.Khalid (one of the narrators) said: If wish I can say that it can be traced up to the Holy Prophet (may peace be upon him).

Chapter 33 :SHARING VISITS TO ONE'S WIVES EQUALLY

Book 8, Number 3450:

    Anas (Allah be pleased with him) reported that Allah's Apostle (may peace be upon him) had ninewives.So when he divided (his stay) with them, the turn of the first wife did not come but on the ninth (day). They (all the wives) used to gather every night in the house of one where he had to come (and stay that night).It was (the night when he had to stay) in the house of 'A'isha (Allah be pleased with her), when Zainab came there.He (the Holy Prophet) stretched his hand towards her (Zainab), whereupon she ('A'isha) said: It is Zainab. Allah's Apostle (may peace be upon him) withdrew his hand.There was an altercation between the two until their voices became loud (and it was at that time) when Iqama was pronounced for prayer.There happened to come Abu Bakr and he heard their voices and said: Messenger of Allah, (kindly) come for prayer, and throw dust in their moths. So the Prophet (may peace be upon him) went out.'A'isha said: When Allah's Apostle (may peace be upon him) would finish his prayer there would also come Abu Bakr and he would do as he does (on such occasions, i.e. reprimanding).When Allah's Apostle (may peace be upon him) had finished his prayer, there came to her Abu Bakr. and spoke to her ('A'isha) in stern words and said: Do you behave like this?

Chapter 34 : PERMISSIBILITY OF BESTOWING THE TURN ON ONE'S FELLOW-WIFE

Book 8, Number 3451:

    'A'isha (Allah be pleased with her) reported: Never did I find any woman more loving to me than Sauda bint Zam'a.I wished I could be exactly like her who was passionate.As she became old, she had made over her day (which she had to spend) with Allah's Messenger (may peace be upon him) to 'A'isha. She said: I have made over my day with you to 'A'isha. So Allah's Messenger (may peace be upon him) allotted two days to 'A'isha, her own day (when it was her turn) and that of Sauda.

Book 8, Number 3452:

    A hadith like this has been transmitted on the authority of Hisham with the same chain of narrators (and the words are): When Sauda became old (the rest of the hadith is the same) and in the narration of Sharik there is an addition (of these words: "She was the first woman whom he (Allah's Apostle) married after me."

Book 8, Number 3453:

    'A'isha (Allah be pleased with her) reported: I felt jealous of the women who offered themselves to Allah's Messenger(may peace be upon him) and said: Then when Allah, the Exalted and Glorious, revealed this: "You may defer any one of them you wish, and take to yourself any you wish; and if you desire any you have set aside (no sin is chargeable to you)" (xxxiii. 51), I ('A'isha.) said: It seems to me that your Lord hastens to satisfy your desire.

Book 8, Number 3454:

    Hisham reported on the authority of his father that 'A'isha (Allah be pleased with her) used to say: Does the woman not feel shy of offering herself to a man?Then Allah the Exalted and Glorious revealed this verse: "You may defer any of them you wish and take to yourself any you wish." I ('A'isha said): It seems to me that your Lord hastens to satisfy your desire.

Book 8, Number 3455:

    'Ata related that when they were with Ibn 'Abbas (Allah be pleased with them) at the funeral of Maimuna In Sarif, Ibn 'Abbas (Allah be pleased with them) said: This is the wife of Allah's Apostle (may peace be upon him); so when you lift her bier, do not shake her or disturb her, but be gentle, for Allah's Messenger (may peace be upon him) had nine wives, with eight of whom he shared his time, but to one of them, he did not allot a share.'Ati said: The one to whom he did not allot a share of time was Safiyya,daughter of Huyayy b. Akhtab.

Book 8, Number 3456:

    Ibn Juraij narrated a hadith with the same chain of transmitters, and she (Hadrat Maimuna) was the last of them to die at Medina.

Chapter 35 : EXCELLENCE OF CONTRACTING MARRIAGE WITH A PIOUS LADY

Book 8, Number 3457:

    Abu Huraira (Allah be pleased with him) reported Allah's Messenger (may peace be upon him) as saying: A woman may be married for four reasons: for her property, her status. her beauty and her religion, so try to get one who is religious, may your hand be besmeared with dust.

Chapter 36 : EXCELLENCE OF MARRYING A VIRGIN

Book 8, Number 3458:

    Jabir b. 'Abdullah (Allah be pleased with them) reported: I married a woman during the lifetime of Allah's Messenger (may peace be. upon him).I met the Apostle of Allah (may peace be upon him), whereupon he said: Jabir, have you married?I said: Yes.He said: A virgin or one previously marrried? I said: With due previously married, whereupon he said: Why did you not marry a virgin with whom you could sport? I said: Allah's Messenger, I have sisters; I was afraid that she might intervene between me and them, whereupon he said: Well and good, if it is so.A woman is married for four reasons, for her religion, her property, her status, her beauty, so you should choose one with religion.May your hands cleave to dust.

Book 8, Number 3459:

    Jabir b. 'Abdullah (Allah be pleased with them) reported: I married a woman, whereupon Allah's Messenger (may peace be upon him) said to me: Have you married?I said: Yes.He said: Is it a virgin or a previously married one (widow or divorced)?I said: With a previously married one, whereupon he said: Where had you been (away) from the amusements of virgins? Shu'ba said: I made a mention of it to 'Amr b. Dinar and he said: I too heard from Jabir making mention of that (that Allah's Apostle) said: Why didn't you marry a girl, so that you might sport with her and she might sport with you?

Book 8, Number 3460:

    Jabir b. 'Abdullah (Allah be pleased with them) reported: 'Abdullah died and he left (behind him) nine or seven daughters. I married a woman who had been previously married.Allah's Messenger (may peace be upon him) said to me: Jabir, have you married?I said: Yes.He (again) said: A virgin or one previously married?I said: Messenger of Allah, with one who was previously married, whereupon he said: Why didn't you marry a young girl so that you could sport with her and she could sport with you, or you could amuse with her and she could amuse with you?I said to him: 'Abdullah died (he fell as martyr in Uhud) and left nine or seven daughters behind him; I, therefore, did not approve of the idea that I should bring a (girl) like them, but I preferred to bring a woman who should look after them and teach them good manners, whereupon he (Allah's Messenger) said: May Allah bless you, or he supplicated (for the) good (to be) conferred on me (by Allah).

Book 8, Number 3461:

    Jabir b. 'Abdullah (Allah be pleased with them) reported Allah's Messenger (may peace be upon him) said to me: Jabir, have you married ? The rest of the hadith is the same up to (the words): "The woman would look after them and comb them." He (Allah's Messenger), said: You did well.But no mention is made of the subsequent portion.

Book 8, Number 3462:

    Jabir b. 'Abdullah (Allah be pleased with them) reported: We were with Allah's Messenger (may peace be upon him) in an expedition.When we returned I urged my camel to move quickly as it was slow.There met me a rider from behind me and he goaded it with an iron-tipped stick which he had with him.My camel moved forward like the best that you have ever seen. As I turned (my face) I found him to be Allah's Messenger (may peace be upon him) He said: Jabir, what hastens you?I said: Messenger of Allah, I am newly wedded. whereupon he said: Is it a virgin that you have married or one previously married? I said: With one previously married.He said: Why not a young girl so that you could play with her and she could play with you?Then when we arrived at and were about to enter Medina he said: Wait, so that we may enter by night (i.e. in the evening) in order that the woman with dishevelled hair may comb it, and the woman whose husband had been away may get herself clean; and when you enter (then you have the) enjoyment (of tho wife's company).

Book 8, Number 3463:

    Jabir b. 'Abdullah (Allah be pleased with him) reported: I went out with Allah's Messenger (may peace be upon him) on an expedition, but my camel delayed me. Allah's Messenger (may peace be upon him) came to me and said to me: Jabir,I said: Yes.Allah's Messenger, (here I am at your beck and call) He said: What is the matter with you? I said: My camel has delayed me and is tired, so I have lagged behind.He (the Holy Prophet) got down and goaded it with a crooked stick and then said: Mount it.So I mounted and (to my great surprise) I saw it (moving so quickly that) I had to restrain it (from going ahead of) Allah's Messenger (may peace be upon him).He (the Holy Prophet) (in the course of journey said to me): Have you married? I said: Yes.He (again) said: Is it with a virgin or one previously married?I said. With one previously married, whereupon he (again) said: Why not with a young girl with whom you could sport and she could have sported with you? I said: I have sisters, so I preferred to marry a woman who could keep them together (as one family). who could comb them and look after them.He said: You are about to go (to your house), and there you have the enjoyment (of the wife's company).He again said: Do you want to sell your camel? I said: Yes.So he bought it from me for one u'qiya (of silver), Then Allah's Messenger (may peace be upon him) arrived (at Medina) and I arrived in the evening.I went to the mosque and found him at the door of the mosque, and said: Is it now that you have arrived?I said: Yes, He said: Leave your camel, and enter (the mosque) and offer two rak'ahs.So I entered and offered two rak'ahs of prayer, and then returned.He (the Holy Prophet) then commanded Bilal to weigh out one 'uqiya (of silver) tor me.Bilal weighed that out for me (lowering the scale of) balance.So I proceeded and as I turned my back he said: Call for me, Jabir.So I was called back, and I said (to myself): He would return me the camel, and nothing was more displeasing to me than this (that after having received the price I should also get the camel).He said: Take your camel and keep its price with you, (also).

Book 8, Number 3464:

    Jabir b. 'Abdullah (Allah be pleased with them) reported: We were with Allah's Messenger (may peace be upon him) in a journey, and I was riding a camel meant for carrying water and it lagged behind all persons.Allah's Messenger (may peace be upon him) hit it or goaded it (I think) with something he had with him.And after it (it moved so quickly) that it went ahead of all persons and it struggled with me (to move faster than I permitted It) and I had to restrain it. Allah's Messenger (may peace be upon him) said: Do you sell it at such and such (price)?May Allah grant you pardon.I said: Allah's Apostle, it is yours.He (again) said: Do you sell it at such and such (price)?May Allah grant you pardon.' I said: Allah's Apostle, it is yours.He said to me: Have you married after the death of your father? I said: Yes. He (again) said: With one previously married or a virgin ? I said: With one previously married.He said: Why didn't you marry a virgin who might amuse you and you might amuse her, and she might sport with you and you might sport with her? Abu Nadra said: That was the common phrase which the Muslims spoke: "You do such and such (thing) and Allah may grant you pardon."

Chapter 37 :THE GOOD OF THIS WORLD IS THE PIOUS WOMAN

Book 8, Number 3465:

    'Abdullah b. Amr reported Allah's Messenger (may peace be upon him) as saying: The whole world is a provision, and the best object of benefit of the world is the pious woman.

Chapter 38 : ADVICE IN REGARD TO WOMEN

Book 8, Number 3466:

    AbuHuraira (Allah be pleased with him) reported Allah's Messenger (may peace be upon him) as saying: Woman is like a rib. When you attempt to straighten it, you would break it.And if you leave her alone you would benefit by her, and crookedness will remain in her.A hadith like this is reported by another chain of narrators

Book 8, Number 3467:

    Abu Huraira (Allah be pleased with him) reported: Woman has been created from a rib and will in no way be straightened for you; so if you wish to benefit by her, benefit by her while crookedness remains in her. And if you attempt to straighten her, you will break her, and breaking her is divorcing her.

Book 8, Number 3468:

    Abu Huraira (Allah be pleased with him) reported Allah's Apostle (may peace be upon him) as saying: He who believes in Allah and the Hereafter, if he witnesses any matter he should talk in good terms about it or keep quiet.Act kindly towards woman, for woman is created from a rib, and the most crooked part of the rib is its top.If you attempt to straighten it, you will break it, and if you leave it, its crookedness will remain there.So act kindly towards women.

Book 8, Number 3469:

    Ab Huraira (Allah be pleased with him) reported Allah's Messenger (may peace be upon him) as saying: A believing man should not hate a believing woman; if he dislikes one of her characteristics, he will be pleased with another.

Book 8, Number 3470:

    A hadith like this has been narrated on the authority of Abu Huraira (Allah be pleased with him).

Book 8, Number 3471:

    Abu Huraira (Allah be pleased with him) reported Allah's Messenger (may peace be upon him) as saying: Had it not been for Eve, woman would have never acted unfaithfully towards her husband.

Book 8, Number 3472:

    Hammam b. Munabbih said: These are some of the ahadith which Abu Huraira (Allah be pleased with him) narrated to us from Allah's Messenger (may peace be upon him), and one of these (this one): Allah's Messenger (may peace be upon him) said: Had it not been for Bani Isra'il, food would not have become stale, and meal would not have gone bad; and had it not been for Eve, a woman would never have acted unfaithfully toward her husband.


BOOK 9: The Book of Divorce (Kitab Al-Talaq)

KITAB AL-TALAQ
(THE BOOK OF DIVORCE)

Back
INTRODUCTION

    The Arabic word for divorce is talaq which means "freeing or undoing the knot" (Imam Raghib).In the terminology of the jurists. Talaq signifies the dissolution of marriage, or the annulment of its legality by the pronouncement of certain words.

    Divorce is of three kinds: the Ahsan, or most laudable, the Hasan, or laudable, and the Bid'a or irregular.

    Talaq Ahsan or the most laudable divorce is where the husband repudiates his wife by making one pronouncement within the term of Tahr (purity. when the woman is not passing through the period of menses) during which he has not had sexual intercourse with her, and she is left to observe her 'Idda.

    Talaq Hasan or laudable divorce is where a husband repudiates an enjoyed wife by three sentences of divorce, in three Tuhrs

    Talaq Bid'a or irregular divorce is where a husband repudiates his wife by three divorces at once. According to the majority of the jurists, the Talaq holds good, but it is against the spirit of the Shari'ah, and, therefore, the man who follows this course in divorce is an offender in the eye of Islamic Law.

    The right of woman in demanding the dissolution of marriage is known as Khula' (meaning, literally,the putting off or taking off a thing).It is a kind of facility provided to the wife in securing Talaq from her husband by returning a part or full amount of the bridal gift.

    We have described before that, according to Islam, marriage is a civil contract; yet the rights and responsibilities consequent upon it are of such importance to the welfare of humanity that a high degree of sanctity is attached to it.But, in spite of the sacredness of the character of the marriage tie,Islam recognises the eternity of divorce in cases when marital relations are poisoned to a degree which makes a peaceful home life impossible.But Islam does not believe in unlimited opportunities for divorce on frivolous and flimsy grounds, because any undue increase in tht facilities for divorce would destroy the stability of family life.Therefore, while allowing divorce even on genuine grounds, Islam has taken great care to introduce checks designed to limit the use of available facilities. The French legists Planiol and Ripert have explicitly emphasised Islam's point of view in regard to divorce in these words: "Divorce is a mischief.However, it is a measure that cannot be avoided for the welfare of the community, because it is the only remedy for another harm which may be wore dangerous The prohibition of divorce, whatever harm it may imply, is like the prohibition of surgery, because the surgeon is compelled to amputate some of the limbs of the patient's body.However, there is no danger whatsoever, in legislating for divorce (in accordance with the practice established by Islam) since it is not divorce that spoils married life and dissolves its sacred tie, but the misunderstanding that arises between the married couple and hinders the strengthening of this (union by marriage) and demolished it.Divorce alone puts an end to the hatred that may occur between the husband and his wife before it is aggravated and becomes an intolerable mischief to society" (quoted by Hasan Ibrihim Hasan, Islam, Religious, Political.Social and Economic Study, p. 274).

Chapter 1 : IT IS FORBIDDEN TO DIVORCE THE WOMAN DURING HER MENSES

Book 9, Number 3473:

    Ibn 'Umar (Allah be pleased with them) reported that he divorced his wife while she was menstruating during the lifetime of Allah's Messenger (may peace be upon him).'Umar b. Khattib (Allah be pleased with him) asked Allah's Messenger (may peace be upon him) about it, whereupon Allah's Messenger (may peace be upon him) said: Command him ('Abdullah b. 'Umar) to take her back (and keep her) and pronounce divorce when she is purified and she again enters the period of menstruation and she is again purified (after passing the period of menses), and then if he so desires he may keep her and if he desires divorce her (finally) before touching her (without having an intercourse with her), for that is the period of waiting ('ldda) which God, the Exalted and Glorious, has commanded for the divorce of women.

Book 9, Number 3474:

    Abdullah (b.'Umar) reported that he divorced a wife of his with the pronouncement of one divorce during the period of menstruation.Allah's Messenger (may peace be upon him) commanded him to take her back and keep her until she was purified, and then she entered the period of menses in his (house) for the second time. And he should wait until she was purified of her menses.And then if he would decide to divorce her, he should do so when she was purified before having a sexual intercourse with her; for that was the 'Idda which Allah had commanded for the divorce of women.Ibn Rumh in his narration made this addition: When 'Abdullah was asked about it, he said to one of them: If you have divorced your wife with one pronouncement or two (then you can take her back), for Allah's Messenger (may peace be upon him) commanded me to do it; but if you have divorced her with three pronouncements, then she is forbidden for you until she married another husband, and you disobeyed Allah in regard to the divorce of your wife what He had commanded you. (Muslim said: The word "one divorce" used by Laith is good.)

Book 9, Number 3475:

    Ibn Umar (Allah be pleased with them) reported: I divorced my wife during the lifetime of Allah's Messenger (may peace be upon him) when she was in the state of menses.'Umar (Allah be pleased with him) made a mention of it to Allah's Messenger (may peace be upon him), whereupon he said: Command him to take her back and leave her (in that state) until she is purified.Then (let her) enter the period of second menses, and when she is purified, then divorce her (finally) before having a sexual intercourse with her, or retain her (finally).That is the 'Idda (the prescribed period) which Allah commanded (to be kept in view) while divorcing the women. 'Ubaidullah reported: I said to Nafi': What became of that divorce (pronounced within 'Idda) ? He said: It was as one which she counted.

Book 9, Number 3476:

    A hadith like this has been narrated on the authority of 'Ubaidullah, but he made no mention of the words of Ubaidullah that he said to Nafi'.

Book 9, Number 3477:

    Ibn 'Umar (Allah be pleased with them) reported that he divorced his wife during the period of menses. 'Umar (Allah be, pleas'ed with him) asked Allah's Apostle (may peace be upon him), and he commanded him ('Abdullah b. 'Umar) to have her back and then allow her respite until she enters the period of the second menses, and then allow her respite until she is purified, then divorce her (finally) before touching her (having a sexual intercourse with her), for that is the prescribed period which Allah commanded (to be kept in view) for divorcing the women.When Ibn 'Umar (Allah be pleased with them) was asked about the person who divorces his wife in the state of menses, he said: If you pronounced one divorce or two, Allah's Messenger (may peace be upon him) had commanded him to take her back, and then allow her respite until she enters the period of the second menses, and then allow her respite until she is purified, and then divorce her (finally) before touching her (having a sexual intercourse with her); and if you have pronounced (three divorces at one and the same time) you have in fact disobeyed your Lord with regard to what He commanded you about divorcing your wife.But she is however (finally separated from you).

Book 9, Number 3478:

    Abdullah b. 'Umar (Allah be pleased with them) reported: I divorced my wife while she was in the state of menses.'Umar (Allah be pleased with him) made mention of it to Allah's Apostle (may peace be upon him) and he was enraged and he said: Command him to take her back until she enters the second ensuing menses other than the one in which he divorced her and in case he deems proper to divorce her, he should pronounce divorce (finally) before touching her (in the period) when she is purified of her menses, and that is the prescribed period in regard to divorce as Allah has commanded.'Abdullah made a pronouncement of one divorce and it was counted in case of divorce.'Abdullah took her back as Allah's Messenger (may peace be upon him) had commanded him.A hadith like this was reported on the authority of Zuhri with the same chain of narrators.Ibn Umar (Allah be pleased with them), however, said: I took her back, and counted this pronouncement of divorce (as valid) with which I divorced her.

Book 9, Number 3479:

    Ibn 'Umar (Allah be pleased with them) reported that he divorced his wife while she was in the state of menses.'Umar (Allah be pleased with him) made mention of it to Allah's Apostle (may peace be upon him) and he said: Command him to take her back, then divorce her when she is pure or she is pregnant.

Book 9, Number 3480:

    Ibn 'Umar (Allah be pleased with them) reported that he divorced his wife while she was in her menses.'Umar (Allah be pleased with him) asked Allah's Apostle (may peace be upon him) about that, and he said: Command him to take her back until she is pure and then she enters the second menses and then becomes pure.Then either divorce her (finally) or retain her.

Book 9, Number 3481:

    Ibn Sirin reported: One who was blameless (as a narrator) narrated to me for twenty years that Ibn 'Umar (Allah be pleased with him) pronounced three divorces to his wife while she was in the state of menses.He was commanded to take her back. I neither blamed them (the narrators) nor recognised the hadith (to be perfectly genuine) until I met Abu Ghallab Yunus b. Jubair al-Bahili and he was very authentic, and he narrated to me that he had asked Ibn 'Umar (Allah be pleased with there) and he narrated it to him that he made one pronouncement of divorce to his wife as she was in the state of menses, but he was commanded to take her back.I said: Was it counted (as one pronouncement)?He said: Why not, was I helpless or foolish ?

Book 9, Number 3482:

    A hadith like this has been transmitted on the authority of Ayyub with a slight variation of words.

Book 9, Number 3483:

    Ayyub reported a hadith like this with the same chain of narrators and he said: Umar (Allah be pleased with him) asked Allah's Apostle (may peace be upon him) about it and he commanded him that he should take her back until she is divorced in the state of purity without having a sexual intercourse with her, and said: Divorce her in the beginning of her 'Idda or her 'Idda commences.

Book 9, Number 3484:

    Yunus b. Jubair reported: I said to Ibn'Umar (Allah be pleased with them): A person divorcedhis wife while she was in the state of menses, whereupon he said: Do you know 'Abdullah b. Umar (Allah be pleased with them), for he divorced his wife in the state of menses. 'Umar (Allah be pleased with him) came to Allah's Apostle (may peace be upon him) and asked him, and he (the Holy Prophet) commanded him that he should take her back, and she started her 'Idda. I said to him: When a person divorces his wife, and she is in the state of menses, should that pronouncement of divorce be counted?He said: Why not, was he hopless or foolish?

Book 9, Number 3485:

    Ibn 'Umar (Allah be pleased with them) reported: I divorced my wife while she was in the state of menses. 'Umar (Allah he pleased wish him) came toAllah's Apostle (may peace be upon him) and made mention of that to him, whereupon Allah's Apostle (may peace be upon him) told that be should take her back, and when she is pure he may divorce her. if he would so wish. I (one of the narrators) said to Ibn 'Umar (Allah be pleased with them): Did you count (this pronouncement of divorce) in her case?He said: What (after all) prevents him from doing so?Do you find him (Ibn Umar) either helpless or foolish?

Book 9, Number 3486:

    Anas b. Sirin reported: I asked Ibn 'Umar (Allah be pleased with them) about the woman whom he had divorced.He said: I divorced her while she was in the state of menses.It was mentioned to 'Umar (Allah be pleased with him) and he then made a mention of that to Allah's Apostle (may peace be upon him), whereupon he said: Command him to take her back and when the period of menses is over, then (he may divorce her in the state of her purity.He (Ibn Umar) said: So I took her back, then divorced her in her purity.I (the narrator) said: Did you count that divorce which you pronounced in the state of menses?He said: Why should I not have counted that?Was I helpless or foolish?

Book 9, Number 3487:

    Anas b. Sirin reported that he had heard Ibn 'Umar (Allah be pleased with them) as saying.I divorced my wife while she was in the state of menses.'Umar (Allah be pleased with him) came to Allah's Apostle (may peace be upon him) and informed him about it, whereupon he (Allah's Apostle) said: Command him to take her back and when she is pure, then divorce her.I said to Ibn 'Umar Allah be pleased with them): Did you count that pronouncement of divorce? He said: Why not? This hadith has been narrated on the authority of Shu'ba with the same chain of transmitters but with a slight variation in wording.

Book 9, Number 3488:

    Ibn Tawus narrated on the authority of his father that Ibn 'Umar (Allah be pleased with them) was asked about the person who divorced his wife in the state of menses, whereupon he said: Do you know 'Abdullah b. Umar?He said: Yes.He said: It was he who divorced his wife jn the state of menses and 'Umar went to Allah's Apostle (may peace be upon him) and gave him this information. and he commanded him that he should take her back; and he (Abu Tawus) said: I did not hear any addition to this (hadith) from my father.

Book 9, Number 3489:

    Abu Zubair reported that he heard 'Abd al-Rahman b. Aiman (the freed slave of 'Azza) say that he asked Ibn 'Umar (Allah be pleased with them) and Abu Zubair heard: What is your opinion about the person who divorced his wife in the state of menses?Thereupon he said: Ibn Umar (Allah be pleased with them) divorced his wife during the lifetime of Allah's Messenger (may peace be upon him) while she was in the state of menses. Upon this Allah's Messenger (may peace be upon him) told him to take her back and so he took her back and he (further) said: When she is pure, then either divorce her or retain her.Ibn 'Umar (Allah be pleased with them) said that Allah's Apostle (may peace be upon him) then recited this verse: "O Apostle, when you divorce women, divorce them at the commencement of their prescribed period" (Ixv 1).

Book 9, Number 3490:

    A hadith like this is reported on the same authority (but with this difference that the narrator) 'Abd al-Rahman b. Aiman (was mentioned) as the freed slave of 'Urwa (Imam Muslim said: He made a mistake who said that it was 'Urwa; it was in fact the freed slave of 'Azza.)

Chapter 2 : PRONOUNCEMENT OF THREE DIVORCES

Book 9, Number 3491:

    Ibn 'Abbas (Allah be pleased with them) reported that the (pronouncement) of three divorces during the lifetime of Allah's Messenger (may peace be upon him) and that of Abu Bakr and two years of the caliphate of Umar (Allah be pleased with him) (was treated) as one.But Umar b. Khattab (Allah be pleased with him) said: Verily the people have begun to hasten in the matter in which they are required to observe respite.So if we had imposed this upon them, and he imposed it upon them.

Book 9, Number 3492:

    Abu Sahba' said toIbn 'Abbas (Allah be pleased with them): Do you know that three (divorces) were treated as one during the lifetime of Allah's Apostle (may peace be upon him), and that of Abu Bakr, and during three (years) of the caliphate of Umar (Allah be pleased with him)?Ibn Abbas (Allah be pleased with them) said: Yes.

Book 9, Number 3493:

    Abu al-Sahba' said to Ibn 'Abbas: Enlighten us with your information whether the three divorces (pronounced at one and the same time) were not treated as one during the lifetime of Allah's Messenger (may peace be upon him) and Abu Bakr.He said: It was in fact so, but when during the caliphate of 'Umar (Allah be pleased with him) people began to pronounce divorce frequently, he allowed them to do so (to treat pronouncements of three divorces in a single breath as one).

Chapter 3 : ATONEMENT IS ESSENTIAL FOR ONE WHO MADE HIS WIFE UNLAWFUL FOR HIMSELF WITHOUT THE INTENTION OF DIVORCE

Book 9, Number 3494:

    Ibn Abbas (Allah be pleased with them) reported about (declaring of one's woman) unlawful as an oath which must be atoned, and Ibn 'Abbas said: Verily, there is in the Messenger of Allah (may peace be upon him) a model pattern for you.

Book 9, Number 3495:

    Ibn Abbas (Allah be pleased with them) reported: When a man declares his wife unlawful for himself that is an oath which must be atoned, and he said: There is in the Messenger of Allah (may peace be upon him) a noble pattern for you.

Book 9, Number 3496:

    'A'isha (Allah be pleased with her) narrated that Allah's Apostle (may peace be upon him) used to spend time with Zainab daughter of Jahsh and drank honey at her house.She ('A'isha further) said: I and Hafsa agreed that one whom Allah's Apostle (may peace be upon him) would visit first should say: I notice that you have an odour of the Maghafir (gum of mimosa).He (the Holy Prophet) visited one of them and she said to him like this, whereupon he said: I have taken honey in the house of Zainab bint Jabsh and I will never do it again.It was at this (that the following verse was revealed): 'Why do you hold to be forbidden what Allah has made lawful for you ... (up to).If you both ('A'isha and Hafsa) turn to Allah" up to: "And when the Holy Prophet confided an information to one of his wives" (lxvi. 3). This refers to his saying: But I have taken honey.

Book 9, Number 3497:

    'A'isha (Allah be pleased with her) reported Allah's Messenger (may peace be upon him) liked sweet (dish) and honey.After saying the afternoon prayer he used to visit his wives going close to them.So he went to Hafsa and stayed with her more than what was his usual stay.I ('A'isha) asked about that.It was said to me: A woman of her family had sent her a small vessel of honey as a gift, and she gave to Allah's Messenger (may peace be upon him) from that a drink. I said: By Allah, we would also contrive a device for him. I mentioned that to Sauda, and said: When he (Allah's Apostle) would visit you and draw close to you, say to him: Allah's Messenger, have you taken maghafir? And he would'say to you: No. Then say to him: What is this odour? And Allah's Messenger (may peace be upon him) felt it very much that unpleasant odour should emit from him.So he would say to you: Hafsa has given me a drink of honey. Then you should say to him: The honey-bees might have sucked 'Urfut, and I would also say the same to him and. Safiyya, you should also say this.So when he (the Holy Prophet) came to Sauda, she said: By Him besides whom there is no god, it was under compulsion that I had decided to state that which you told me when he would be at a little distance at the door.So when Allah's Messenger (may peace be upon him) came near, she said: Messenger of Allah, did you eat Maghafir?He said: No. She (again) said: Then what is this odour?He said: Hafsa gave me honey to drink.She said: The honey-bee might have sucked 'Urfut.When he came to me I told him like this.He then visited Safiyya and she also said to him like this.When he (again) visited Hafsa, she said: Messenger of Allah, should I not give you that (drink)? He said: I do not need that. Sauda said: Hallowed be Allah, by Him we have (contrived) to make that (honey) unlawful for him.I said to her: Keep quiet.This hadith has been narrated on the authority of 'Urwa with the same chain of transmitters.

Chapter 4 : MERE GIVING OF OPTION OF DIVORCE TO WOMEN DOES NOT MAKE THE DIVORCE EFFECTIVE, BUT WHEN IT IS REALLY INTENDED

Book 9, Number 3498:

    'A'isha (Allah be pleased with her) reported: When the Messenger of Allah (may peace be upon him) was commanded to give option to his wives, he started it from me saying: I am going to mention to you a matter which you should not (decide) in haste until you have consulted your parents.She said that he already knew that my parents would never allow me to seek separation from him She said: Then he said: Allah, the Exalted and Glorious, said: Prophet, say to thy wives: If you desire this world's life and its adornment, then come, I will give you a provision and allow you to depart a goodly departing; and if you desire Allah and His Messenger and the abode of the Hereafter, then Allah has prepared for the doers of good among you a great reward She is reported to have said : About what should I consult my parents, for I desire Allah and His Messenger and the abode of the Hereafter? She ('A'isha) said: Then all the wives of Allah's Messenger (may peace be upon him) did as I had done.

Book 9, Number 3499:

    'A'isha (Allah be pleased with her) reported that Allah's Messenger (may peace be upon him) sought our permission when he had a (turn to spend) a day with (one of his wives) amongst us (whereas he wanted to visit his other wives too).It was after this that this verse was revealed: "Thou mayest put off whom thou pleasest of them, and take for thee whom thou pleasest" (xxxiii. 5). Mu'adha said to her: What did you say to Allah's Messenger (may peace be upon him) when he sought your permission ? She said: I used to say: If it had the option in this I would not have (allowed anyone) to have precedence over me.

Book 9, Number 3500:

    'A'isha reported: Allah's Messenger (may peace be upon him) gave us the option (to get divorce) but we did not deem it as divorce.

Book 9, Number 3501:

    Masruq reported: I do not mind if I give option to my wife (to get divorce) once, hundred times, or thousand times after (knowing it) that she has chosen me (and would never seek divorce).I asked 'A'isha (Allah be pleased with her) (about it) and she said: Allah's Messenger (may peace be upon him) gave us the option, but did it imply divorce? (It was in fact not a divorce; it is effective when women actually avail themselves of it.)

Book 9, Number 3502:

    'A'isha reported that Allah's Messenger (may peace be upon him) gave option to his wives, but it was not a divorce.

Book 9, Number 3503:

    'A'isha (Allah be pleased with her) reported: Allah's Messenger (may peace be upon him) gave us the option (to get divorce) and we chose him and he did not count it a divorce.

Book 9, Number 3504:

    'A'isha (Allah be pleased with her) reported: Allah's Messeinger (may peace be upon him) gave us the option (to get divorce), but me made a choice of him and he did not count anything (as divorce) in regard to us.

Book 9, Number 3505:

    A hadith like this has been transmitted on the authority of 'A'isha through another chain of narrators.

Book 9, Number 3506:

    Jabir b. 'Abdullah (Allah be pleased with them) reported: Abu Bakr (Allah be pleased with him) came and sought permission to see Allah's Messenger (may peace be upon him).He found people sitting at his door and none amongst them had been granted permission, but it was granted to Abu Bakr and he went in.Then came 'Umar and he sought permission and it was granted to him, and he found Allah's Apostle (may peace be upon him) sitting sad and silent with his wives around him.He (Hadrat 'Umar) said: I would say something which would make the Holy Prophet (may peace be upon him) laugh, so he said: Messenger of Allah, I wish you had seen (the treatment meted out to) the daughter ofKhadija when you asked me some money, and I got up and slapped her on her neck.Allah's Messenger (mav peace be upon him) laughed and said: They are around me as you see, asking for extra money.Abu Bakr (Allah be pleased with him) then got up went to 'A'isha (Allah be pleased with her) and slapped her on the neck, and 'Umar stood up before Hafsa and slapped her saying: You ask Allah's Messenger (may peace be upon him) which he does not possess.They said: By Allah, we do not ask Allah's Messenger (may peace be upon him) for anything he does not possess.Then he withdrew from them for a month or for twenty-nine days.Then this verse was revealed to him: "Prophet: Say to thy wives . . . for a mighty reward" (xxxiii. 28).He then went first to 'A'isha (Allah be pleased with her) and said: I want to propound something to you, 'A'isha, but wish no hasty reply before you consult your parents.She said: Messenger of Allah, what is that?He (the Holy Prophet) recited to her the verse, whereupon she said: Is it about you that I should consult my parents, Messenger of Allah?Nay, I choose Allah, His Messenger, and the Last Abode; but I ask you not to tell any of your wives what I have said He replied: Not one of them will ask me without my informing her.God did not send me to be harsh, or cause harm, but He has sent me to teach and make things easy.

Chapter 5 :ILA'AND KEEPING AWAY FROM THE WIVES

Book 9, Number 3507:

    'Umar b. al-Khattab (Allah be pleased with him) reported: When Allah's Apostle (may peace be upon him) kept himself away from his wives, I entered the mosque, and found people striking the ground with pebblesand saying: Allah's Messenger (may peace be upon him) has divorced his wives, and that was before they were commanded to observe seclusion 'Umar said to himself: I must find this (actual position) today.So I went to 'A'isha (Allah be pleased with her) and said (to her): Daughter of Abu Bakr, have you gone to the extent of giving trouble to Allah's Messenger (may peace be upon him)?Thereupon she said: Son of Khattab, you have nothing to do with me, and I have nothing to do with you.You should look to your own receptacle. He ('Umar) said: I visited Hafsa daughter of 'Umar, and said to her: Hafsa, the (news) has reached me that you cause Allah's Messenger (may peace be upon him) trouble.You know that Allah's Messenger (may peace be upon him) does not love you, and had I not been (your father) he would have divorced you. (On hearing this) she wept bitterly.I said to her: Where is Allah's Messenger (may peace be upon him)?Shesaid: He is in the attic room.I went in and found Rabah, the servant of Allah's Messenger (may peace be upon him),sitting on the thresholds of the window dangling his feet on the hollow wood of the date-palm with the help of which Allah's Messenger (may peace be upon him) climbed (to the apartment) and came down.I cried: 0 Rabah, seek permission for me from Allah's Messenger (way peace be upon him). Rabah cast a glance at the apartment and then looked toward me but said nothing. I again said: Rabah, seek permission for me from Allah's Messenger (may peace be upon him).Rabah looked towards the apartment and then cast a glance at me, but said nothig. I then raised my voice and said: 0 Rabah, seek permission for me from Allah's Messenger (may peace be upon him). I think that Allah's Messenger (may peace be upon him) is under the impression that I have come for the sake of Hafsa.By Allah, if Allah's Messenger (may peace be upon him) would command me to strike her neck, I would certainly strike her neck. I raised my voice and he pointed me to climb up (and get into his apartment). I visited Allah's Messenger (may peace be upon him), and he was lying on a mat.I sat down and he drew up his lower garment over him and he had nothing (else) over him, and that the mat had left its marks on his sides. I looked with my eyes in the store room of Allah's Messenger (may peace be upon him). I found only a handful of barley equal to one sa' and an equal quantity of the leaves of Mimosa Flava placed in th(t nook of the cell, and a semi-tanned leather bag hanging (in one side), and I was moved to tears (on seeing this extremely austere living of the Holy Piophet), and he said: Ibn Khattab, what wakes you weep? I said: Apostle of Allah, why should I not shed tears?This mat has left its marks on your sides and I do not see in your store room (except these few things) that I have seen ; Ceasar and Closroes are leading their lives in plenty whereas you are Allah's Messenger.His chosen one, and that is your store ! He said: Ibn Khattab, aren't you satisfied that for us (there should be the prosperity) of the Hereafter, and for them (there should be the prosperity of) this world?I said: Yes.And as I had entered I had seen the signs of anger on his face, and I therefore, said: Messenger of Allah, what trouble do you feel from your wives, and if youhave divorced them, verily Allah is with you, His angels, Gabriel, Mika'il, I and Abu Bakr and the believers are with you.And seldom I talked and (which I uttered on that day) I hoped that Allah would testify to my words that I uttered. And so the verse of option (Ayat al-Takhyir) was revealed.Maybe his Lord, if he divorce you, will give him in your place wives better than you . . ." (Ixv. 5).And if you back up one another against him, then surely Allah is his Patron, and Gabriel and the righteous believers, and the angels after that are the aidera (lvi. 4).And it was 'A'isha,daughter of Abu Bakr, and Hafsa who had prevailed upon all the wives of Allah's Prophet (way peace be upon him) for (pressing them for mote money).I said: Messenger of Allah, have you divorced them?He said: No. I said: Messenger of Allah, I entered the mosque and found the Muslims playing with pebbles (absorbed in thought) and saying: Allah's Messenger has divorced his wives.Should I get down and inform there that you have not divorced them?He said: Yes, if you so like. And I went on talking to him until I (found) the signs of anger disappeared on his face and (his seriousness was changed to a happy mood and as a result thereof) his face had the natural tranquillity upon it and he laughed and his teeth were the most charming (among the teeth) of all people.Then Allah's Apostle (may peace be upon him) climbed down and I also climbed down and catching hold of the wood of the palm-tree and Allah's Messenger (may peace be upon him) came down (with such ease) as if he was walking on the ground, not touching anything with his hand (to get support). I said: Messenger of Allah, you remained in your apartment for twenty-nine days.He said: (At times) the month consists of twenty-nine days.I stood at the door of the mosque and I called out at the top of my voice: The Messenger of Allah (may peace be upon him) has not divorced his wives (and it was on this occasion that this) verse was revealed: "And if any matter pertaining to peace or alarm comes within their ken, they broadcast it; whereas, if they would refer it to the Apostle and those who have been entrusted with authority amongst them, those of them who are engaged in obtaining intelligence would indeed know (what to do with) it" (iv 83). And it was I who understood this matter, and Allah revealed the verse pertaining to option (given to the Holy Prophet (may peace be upon him in regard to the retaining or divorcing of his wives).

Book 9, Number 3508:

    Abdullah b. Abbas (Allah be pleased with tlicm) reported: I intended to ask 'Umar b. al-Khattab (Allah be pleased with him) about a verse, but I waited for one year to ask him out of his fear, until he went out for Pilgrimage and I also accompanied him.As he came back and we were on the way he stepped aside towards an Arak tree to ease himself.I waited for him until he was free. I then walked along with him and said: Commander of the Faithful, who are the two among the wives of Allah's Messenger (may peace be upon him) who backed up one another (in their demand for extra money)?He said: They were Hafsa and 'A'isha (Allah be pleased with them).I said to him: It is for one year that I intended to ask you about this matter but I could not date so on account of the awe for you.He said: Don't do that.If you think that I have any knowledge, do ask me about that.And if I were to know that, I would inform you. He (the narrator) stated that 'Umar had said: By Allah, during the days of ignorance we had no regard for women until Allah the Exalt- ed revealed about them what He has revealed, and appointed (turn) for them what he appointed.He said: It so happened that I was thinking about some matter that my wife said: I wish you had done that and that.I said to her: It does not concern you and you should not feel disturbed in a matter which I intend to do.She said to me: How strange is it that you, O son of Khattab, do not like anyone to retort upon you, whereas your daughter retorts upon Allah's Messenger (may peace be upou him) until he spends the day in vexation.'Umar said: I took hold of my cloak, then came out of my house until I visited Hafsa and said to her: O daughter, (I heard) that you retort upon Allah's Messenger (may peace be upon him) until he spends the day in vexation, whereupon Hafsa said: By Allah, we do retort upon him.I said: You should bear in mind, my daughter, that I warn you against the punishment of Allah and the wrath of His Messenger (may peace be upon him).You may not be misled by one whose beauty has fascinated her, and the love of Allah's Messenger (may peace be upon him) for her.I ('Umar) then visited Umm Salama because of my relationship with her and I talked to her.Umm Salama said to me: Umar b. al-Khattab, how strange is it that you meddle with every matter so much so that you are anxious to interfere between Allah's Messenger (may peace be upon him) and his wives, and this perturbed me so much that I refrained from saying what I had to say, so I came out of her apartment, and I had a friend from the Anar.When I had been absent (from the company of the Holy Prophet) he used to bring me the news and when he had been absent I used to bring him the news, and at that time we dreaded a king of Ghassan. It was mentioned to us that he intended to attack us, and our minds were haunted by him. My friend, the Ansari, came to me, and he knocked at the door and said: Open it, open it. I said: Has the Ghassani come?He said: (The matter is) more serious than that.The Messenger of Allah (may peace be upon him) has separated himself from his wives.I said: Let the nose of Hafsa and 'A'isha be besmeared with dust.I then took hold of my cloth and went out until I came and found Allah's Messenger (may peace be upon him) in his attic to which he climbed by means of a ladder made of date-palm, and the servant of Allah's Messenger (may peace be upon him) who was black had been sitting at the end of the ladder.I said: This is Umar. So permission was granted to me.I narrated this news to Allah's Messenger (may peace be upon him) and as I narrated the news concerning Umm Salama, Allah's Messenger (may peace be upon him) smiled.He was lying on the mat and there was nothing between him and that (mat), and under his head there was a pillow made of leather and it was stuffed with plam fibres and at his feet were lying a heap of sant tree (acacia niloctica, meant for dyeing) and near his head there was hanging a hide.And I saw the marks of the maton the side of Allah's Messenger (may peace be upon him), and so I wept.He said: What makes you weep? I said: Messenger of Allah, the Khusrau and the Ceasars (spendd their lives in) the midst of (luxuries), whereas you being Allah's Messenger (are leading your life in this poverty).Thereupon Allah's Messenger (may peace be upon him) said: Don't you like that they should have riches of their world, and you have the Hereafter.

Book 9, Number 3509:

    Ibn Abbas (Allah be pleased with them) said: I came along with Umar until we reached Marr al-Zahran (the name of a place), and the rest of the hadith is the same as narrated by Sulaiman b. Bilal (except with) the variation (of words) that I said: (What) about these two women?He said: They were Hafsa and Umm Salama. And he made this addition: I came to the apartments and in every apartment there was (the noise) of weeping.And this addition was also made: And he (the Holy Prophet) had taken an oath of remaining away from them for a month, and when twenty-nine days had passed, he visited them.

Book 9, Number 3510:

    Ibn Abbas (Allah be pleased with them) is reported to have said: I intended to ask Umar about those two ladies who had pressed for (worldly riches) during the lifetime of the Holy Prophet (may peace be upon him), and I kept waiting for one year, but found no suitable opportunity with him until I happened to accompany him to Mecca.And as he reached Marr al Zahran he went away to answer the call of nature, and he said (to me): Bring me a jug of water, and I took that to him.After having answered the call of nature, as he came back, I began to pour water (over his hands and feet), and I remembered (this event of separation of Allah's Apostle [may peace be upon him] from his wives).So I said to him: Commander of the Faithful, who are the two ladies (who had pressed the Holy Prophet [may peace be upon him] for providing comforts of life) and I had not yet finished my talk when he said: They were 'A'isha and Hafsa.

Book 9, Number 3511:

    Ibn 'Abbas (Allah be pleased with them) reported.I had always been anxious to ask 'Umar (Allah be pleased with him) about the two ladies amongst the wives of Allah's Prophet (may peace be upon Lim) about whom Allah, the Exalted, said: "If you both turn in repentance to Allah, then indeed your hearts are inclined (to this)" (Ixvi. 4), until 'Umar (Allah be pleased with him) set out for Hajj and I also went along with him. And as we were going along a path, 'Umar (Allah be pleased with hiyn) went aside and I also went aside with him with a jug (of water).He answered the call of nature, and then came to me and I poured water over his hands and he performed ablution I said: Commander of the Faithful, who are the two ladies amongst the wives of Allah's Prophet (may peace be upon him) about whom Allah, the Exalted and Majestic, said: 'If you both turn to Allah in repentance, then indeed your heart are inclined to it"? 'Umar (Allah he pleased with him) said: How strange is it for you, Ibn 'Abbas! (Zuhri said: By Allah, he disliked what he asked about, but did not keep it a secret.) He ('Umar) said: They are Hafsa and 'A'isha; and he then began to narrate the hadith and said: We were such people among the Quraish who dominated women, and as we reached Medina we found there people who were dominated by their women, and our women began to learn (the habits) of their women. He further said: And my house was situated in the suburb of Aledina in the tribe of Banu Umayya b. Zaid.One day I became angry with my wife and she retorted upon me. I did not like that she should retort upon me.She said: You disapprove of my retorting upon you By Allah, the wives of Allah's Apostle (may peace be upon him) retort upon him, and one of them detaches herself from him for the day until the night.So I ('Umar) went out and visited Hafsa and said: Do you retort upon Allah's Messenger (may peace be upon him)?She said: Yes.I said; Does any one of you detach herself from him from the day to the night?She said: Yes.He said: She who did like it amongst you in fact failed and incurred loss.Does everyone amongst you not fear the wrath of Allah upon her due to the wrath of His Messenger (may peace be upon him), and (as a result thereof) she may perish?So do not retort upon Allah's Messenger (may peace be upon him) and do not ask him for anything, but ask me that which you desire, (and the frank behaviour) of your companion may not mislead you, if she is more graceful and is dearer to Allah's Messenger (may peace be upon him) than you (meaning 'A'isha) (Allah be pleased with her).He (Hadrat 'Umar further) said: I had a compalaion from the Ansar and, we used to remain in the company of the Messenger (may peace be upon him) turn by turn.He remained there for a day while I remained there on the other day, and he brought me the news about the revelation and other (matter), and I brought him (the news) like this.And we discussed that the Ghassanids were shoeing the horses in order to attack us.Id y companion once attended (the Apostle). and then came to me at night and knocked at my door and called me, and I came out to him, and he said: A matter of great importance has happened. I said: What is that?Have the Ghassanids come?He said: No, but even more serious and more significant than that: the Holy Prophet (may peace be upon him) has divorced his wives.I said: Hafsa has failed and has incurred loss. and I feared that it would happen.When it was dawn I observed the dawn prayer and dressed myself, and then came there (in the house of the Holy Prophet) and visited Hafsa, and she was weeping. I said: Has Allah's Messenger (may peace be upon him) divorced you (all)?She said: I do not know.He has, however, separated himself in his attic. I came to a black servant and said to him: Seek permission for 'Umar.He went in and then came to me and said: I made mention of you to him, but he kept quiet. I then went to the pulpit and sat there, and there was a group of people sitting by it and some of then were weeping. I sat there for some time, until I was overpowered (by that very idea) which was in my mind.I then came back to the boy and said to him: Seek permission for Umar. He went in and came to me and said: I made mention of you to him but he kept quiet.I was about to turn back when the boy called me and said: Go in; permission has been granted to you.I went in and greeted Allah's Messenger (may peace be upon him) and he was reclining against the couch of mat and it had left its marks upon his side. I said: Messenger of Allah, have you divorced your wives?He raised his head towards me and said: No. I said: Allah is the Greatest.Messenger of Allah, I wish if you had seen how we the people of Quraish had domination over women but when we came to Medina we found people whom their women dominated. So our women began to learn from their women.One dily I became angry with my wife and she began to retort upon me. I did not approve that she should retort upon me. She said: You do not like that I should retort upon you, but, by Allah. the wives of Allah's Apostle (may peace be upon him) retort upon him and any one of them separates herself from him for a day until night. I said: He who did that amongst them in fact failed and incurred loss. Does any of them feel sate from the wrath of Allahupon her due to the wrath of Allah's Messenger (may peace be upon him), and she has certainly perished.Allah's Messtnger (may peace be upon him) smiled, I said: Messenger of Allah, I visited Hafsa and said: (The behaviour) of your companion ('A'isha) may not mislead you, If she is more graceful than you and is dearer to Allah's Messenger (may peace be upon him) than you.Allah's Messenger (may peace be upon him) smiled for the second time.I said: Allah's Messenger, way I talk to you about agreeable things?He said: Yes. I sat down and lifted my head (to see things) in the house and, by Allah, I did not see anything significant besides three hides.I said: Messenger of Allah, supplicate the Lord that He should make (life) prosperous for your Ummah as He has made plentiful for the people of Persia and Rome (in spite of the fact) that they do no, worship Allah, the Exalted and Majestic, whereupon he (Allah's Messenger) sat up an I then said : Ibn Khattab, do you doubt that they are a nation whom their nice things have been given immediately in the life of this world.I said: Allah's Messenger! seek pardon for me.And he (Allah's Messenger) had taken an oath that he would not visit them for a month due to extreme annoyance with them until Allah showed His displeasure to him (Allah's Messenger).Zuhri said: 'Urwa informed me that 'A'Isha (Allah be pleased with her) said: When twenty-nine nights were over, Allah's Messenger (may peace be upon him) visited me, and he began (his visit) with me. I said: Messenger of Allah, you had taken an oath that you would not visit us for a month, while you have visited after I have counted only twenty-nine (nights). Thereupon he said: The month may also be of twenty-nine (days).He then said: 'A'isha, I am going to talk to you about a matter, and you should not be hasty in it (and do not give your final decision) until you have consulted your parents.He then recited this verse to me: "O Prophet, say to your wives" till he reached "mighty reward" (xxxiii. 28). 'A'isha (Allah be pleased with her) said: By Allah, he knew that my parents would not allow me to separate from him. I said: Is there any need to consult my parents in this matter? I in fact choose Allah and His Messenger (may peace be upon him) and the abode in the Hereafter.Ma'mar said: Ayyub reported to me that 'A'isha said: Don't inform your wives that I have chosen you, whereupon Allah's Apostle (may peace be upon him) said: Verily Allah has sent me as a conveyer of message, and He has not sent me as a source of hardship (to others).Qatada said: "Saghat qulubukum" means "Your hearts have inclined."

Chapter 6 :THERE IS NO MAINTENANCE ALLOWANCE FOR ONE WHO HAS BEEN GIVEN IRREVOCABLE DIVORCE

Book 9, Number 3512:

    Fatima bint Qais reported that Abu 'Amr b. Hafs divorced her absolutely when he was away from home, and he sent his agent to her with some barley.She was displeased with him and when he said: I swear by Allah that you have no claim on us. she went to Allah's Messenger (may peace be upon him) and mentioned that to him. He said: There is no maintenance due to you from him, and he commanded her to spend the 'Idda in the house of Umm Sharik, but then said: That is a woman whom my companions visit. So better spend this period in the house of Ibn Umm Maktum, for he is a blind man and yon can put off your garments. And when the 'Idda is over, inform me. She said: When my period of 'Idda was over, I mentioned to him that Mu'awiya b. Abu Sufyan and Jahm had sent proposal of marriage to me, whereupon Allah's Messenger (may peace be upon him) said: As for Abu Jahm, he does not put down his staff from his shoulder, and as for Mu'awiya, he is a poor man having no property; marry Usama b. Zaid.I objected to him, but he again said: Marry Usama; so I married him.Allah blessed there in and I was envied (by others).

Book 9, Number 3513:

    Fatima bint Qais reported that her husband divorced her during the life time of Allah's Prophet (may peace be upon him) and gave her a meagre maintenance allowance.When she saw that, she said: By Allah, I will inform Allah's Messenger (may peace be upon him), and if maintenance allowance is due to me then I will accept that which will suffice me, and if it is not due to me, I will not accept anything from him.She said: I made a mention of that to Allah's Messenger (may peace be upon him) and he said: There is neither maintenance allowance for you nor lodging.

Book 9, Number 3514:

    Fatima bint Qais reported that her husband al-Makhzulmi divorced her and refused to pay her maintenance allowance.So she came to Allah's Messenger (may peace he upon him) and informed him, whereupon he said: There is no maintenance allowance for you, and you better go to the house of Ibn Umm Maktum and live with him for he is a blind man and you can put off your clothes in his house (i.e. you shall not face much difficulty in observing purdah there).

Book 9, Number 3515:

    Abu Salama reported that Fatima bint Qais, the sister of al-Dahhak b. Qais informed him that Abu Hafs b. Mughira al-Makhzumi divorced her three times and then he proceeded on to the Yemen.The members of his family said to her: There is no maintenance allowance due to you from us.Khalid b. Walid along with a group of persons visited Allah's Messenger (may peace be upon him) in the house of Maimuna and they said: Abu Hafs has divorced his wife with three pronouncements; is there any maintenance allowance due to her?Thereupon Allah's Messenger (may peace be upon him) said: No maintenance allowance is due to her, but she is required to spend the 'Idda; and he sent her the message that she should not be hasty in making a decision about herself and commanded her to move to the house of Umm Sharik, and then sent her the message that as the first immigrants (frequently) visit the house of Umm Sharik, she should better go to the house of Ibn Umm Maktum, the blind, (and further said: In case you put off your head-dress, he (Ibn Umm Makhtum) will not see you.So she went to his house, and when the 'Idda was over, Allah's Messenger (may peace be upon him) married her to Usama b. Zaid b. Haritha.

Book 9, Number 3516:

    Fatima bint Qais reported: I had been married to a person from Banu Makhzum and he divorced me with irrevocable divorce. I sent a message to his family asking for maintenance allowance, and the rest of the hadith has been transmitted with a slight change of words.

Book 9, Number 3517:

    Fatima bint Qais (Allah be pleased with her) reported that she had been married to Abu 'Amr b. Hafs b. al-Mughira and he divorced her with three pronouncements. She stated that she went to Allah's Messenger (may peace be upon him) asking him about abandoning that house.He commanded her to move to the house of Ibn Umm Maktum, the blind.Marwan refused to testify the divorced woman abandoning her house (before the 'Idda was over).'Urwa said that 'A'isha objected to (the words of) Fatima bint Qais.This hadith has been transmitted through another chain of narrators.

Book 9, Number 3518:

    'Ubaidullah b. 'Abdullah b. 'Utba reported that 'Amr b. Hafs b. al-Mughira set out along with 'Ali b. Abi Talib (Allah be pleased with him) to the Yemen and sent to his wife the one pronouncement of divorce which was still left from the (irrevocable) divorce; and he commanded al-Harith b. Hisham and 'Ayyash b. Abu Rabi'a to give her maintenance allowance.They said to her: By Allah, there is no maintenance allowance for you, except in case you are pregnant.She came to Allah's Apostle (may peace he upon him) and mentioned their opinion to him, whereupon he said: There is no maintenance allowance for you.Then she sought permission to move (to another place), and he (the Holy Prophet) permitted her.She said: Allah's Messenger, where (should I go)?He said: To the house of Ibn Umm Maktum and, as he is blind, she could put off her garmeqts in his presence and he would not see her.And when her 'Idda was over. Allah's Apostle (may peace be upon him) married her to Usama b. Zaid.Marwan (the governor of Medina) sent Qabisa b. Dhuwaib in order to ask her about this hadith, and she narrated it to him, whereupon Marwan said: We have not heard this hadith but from a woman.We would adopt a safe (path) where we found the people.Fatima said that when these words of, Marwan were conveyed to her.There is between me and you the word of Allah,the Exalted and Majestic: Do "not turn them out"of their houses.She asserted: This is in regard to the revocable divorce what new (turn can the event take) after three pronouncements (separation between irrevocable).Why do you say there is no maintenance allowance for her if she is not pregnant ? Then on what ground do you restrain her ?

Book 9, Number 3519:

    Sha'bi reported: I visited Fatima bint Qais and asked her about the verdict of Allah's Messenger (may peace be upon him) about (board and lodging during the 'Idda) and she said that her husband divorced her with an irrevocable divorce. She (further.said): I contended with him before Allah's Messerger (may peace be upon him) about lodging and maintenance allowance, and she said: He did not provide me with any lodging or maintenance allowance, and he commanded me to spend the 'Idda in the house of Ibn Umm Maktum.

Book 9, Number 3520:

    A hadith like this has been trarismitted on the authority of Hushaim through another chain of narrators.

Book 9, Number 3521:

    Sha'bi reported: We visited Fitima hint Qais and she served us fresh dates and a drink of barley flour, and I asked where should a woman who has been divorced by three pronouncements, spend the period of her 'Idda.She said: My husband divorced me with three pronouncements, and Allah's Apostle (may peace be upon him) permitted me to spend my 'Idda period in my family (with my parents).

Book 9, Number 3522:

    Fatima bint Qais (Allah be pleased with her) reported from Allah's Messenger (may peace be upon him) that there is no lodging and maintenance allowance for a woman who has been given irrevocable divorce.

Book 9, Number 3523:

    Fatima bint Qais (Allah be pleased with her) reported: My husband divorced me with three pronouncements.I decided to move (from his house to another place).So I came to Allah's Messenger (may peace be upon him), and he said: Move to the house of your cousin 'Amr b. Umm Maktum and spend your period of 'Idda there.

Book 9, Number 3524:

    Abu Ishaq reported: I was with al-Aswad b. Yazid sitting in the great mosque, and there was with us al-Sha'bi, and he narrated the narration of Fatima bint Qais (Allah be pleased with her) that Allah's Messenger (may peace be upon him) did not make any provision for lodging and maintenance allowance for her.Al-Aswad caught hold of some pebbles in his fist and he threw them towards him saying: Woe be to thee, you narrate like it, whereas Umar said: We cannot abandon the Book of Allah and the Sunnah of our Apostle (may peace be upon him) for the words of a woman.We do not know whether she remembers that or she forgets.For her, there is a provision of lodging and maintenance allowance.Allah, the Exalted and Majestic, said: "Turn them not from their houses nor should they themselves go forth unless they commit an open indecency" (lxv. 1).

Book 9, Number 3525:

    A hadith like this has been narrated on the authority of Ishaq with the same chain of transmitters.

Book 9, Number 3526:

    Fatima bint Qais (Allah be pleased with her) reported that her husband divorced her with three, pronouncements and Allah's Messenger (may peace be upon him) made no provision for her lodging and maintenance allowance.She (further said): Allah's Messenger (may peace be upon him) said to me: When your period of 'Idda is over, inform me.So I informed him. (By that time) Mu'awiya, Abu Jahm and Usama b. Zaid had given her the proposal of marriage.Allah's Messenger (may peace be upon him) said: So far as Mu'awiya is concerned, he is a poor man without any property.So far as Abu Jahm is concerned, he is a great beater of women, but Usama b. Zaid ... She pointed with her hand (that she did not approve of the idea of marrying) Usama.But Allah's Messenger (may peace be upon himn) said: Obedience to Allah and obedience to His Messenger is better for thee.She said: So I married him, and I became an object of envy.

Book 9, Number 3527:

    Fatima bint Qais (Allah be pleased with her) reported: My husband Abu 'Amr b. Hafs b. al-Mughira sent 'Ayyish b. Abu Rabi'a to me with a divorce, and he also sent through him five si's of dates and five si's of barley.I said: Is there no maintenance allowance for me but only this, and I cannot even spend my 'Idda period in your house?He said: No. She said: I dressed myself and came to Allah's Messenger (may peace be upon him).He said: How many pronouncements of divorce have been made for you?I said: Three.He said what he ('Ayyish b. Abu Rabi'a) had stated was true.There is no maintenance allowance for you.Spend 'Idda period in the house of your cousin, Ibn Umm Maktum.He is blind and you can put off your garment in his presence.And when you have spent your Idda period, you inform me. She said: Mu'awiya and Abu'l-Jahm (Allah be pleased with them) were among those who had given me the proposal of marriage.Thereupon Allah's Apostle (may peace be upon him) said: Mu'awiya is destitute and in poor condition and Abu'l-Jahm is very harsh with women (or he beats women, or like that), you should take Usama b. Zaid (as your husband).

Book 9, Number 3528:

    Abu Bakr b. Abu'l-Jahm reported: I and Abu Salama b 'Abd al-Rahman came to fatima bint Qais (Al!ah be pleased with her) and asked her (about divorce, etc.). She said: I was the wife of Abu 'Amr b. Hafs b. al-Mughira, and he set out to join the battle of Najran. The rest of the hadith is the same, but he made this addition: "She said: I married him and Allah hornoured me on account of Ibn Zaid and Allah favoured me because of him."

Book 9, Number 3529:

    Abu Bakr reported: I and Abu Salama came to Fatima bint Qais (Allah be pleased with her) during the time of Ibn Zubair (Allah be pleased with him) and she narrated to us that her husband gave her an irrevocable divorce. (The rest of the hadith is the same.)

Book 9, Number 3530:

    Fatima bint Qais (Allah be pleased with her) reported: My husband divorced me with three pronouncements and Allah's Messenger (may peace be upon him) made no provision for lodging and maintenance allowance.

Book 9, Number 3531:

    Hisham reported on the authority of his father that Yahya b. Sa'id b. al-'As married the daughter of 'Abd al-Rahman b. al-Hakam, and he divorced her and he turned her out from his house.'Urwa (Allah be -pleased with him) criticised this (action) of theirs (the members of the family of her in-laws).They said: Verily, Fatima too went out (of her in-laws' house).'Urwa said: I came to 'A'isha (Allah be pleased with her) and told her about it and she said: There is no good for Fatima bint Qais (Allah be pleased with her) in making mention of it.

Book 9, Number 3532:

    Fatima bint Qais (Allah be pleased with her) reported that she said: Allah's Messenger, my husband has divorcee me with three pronouncements and I am afraid that I may be put to hardship, and so he commanded her and so she moved (to another house).

Book 9, Number 3533:

    'A'isha (Allah be pleased with her) said: It is no good for Fatima to make mention of it, i.e. her statement: " There is no lodging and maintenance allowance (for the divorced women)."

Book 9, Number 3534:

    Ibn al-Qasim narrated on the authority of his father that 'Urwa b. Zubair (Allah be pleased with him) said to 'A'isha (Allah be pleased with her): Didn't you see that such and such daughter of al-Hakam was divorced by her husband with an irrevocable divorce, and she left (the house of her husband) ? Thereupon 'A'isha (Allah be pleased with her) said: It was bad that she did.He ( Urwa) said: Have you not heard the words of Fatima?Thereupon she said : There if no good for her in making mention of it.

Chapter 7 : ONE WHO IS DIVORCED BY THREE PRONOUNCEMENTS OR WHOSE HUSBAND HAS DIED CAN GET OUT OF HER HOUSE FOR A NEED DURING HER PERIOD OF 'IDDA

Book 9, Number 3535:

    Jabir b. 'Abdullah (Allah be pleased with them) reported: My maternal aunt was divorced, and she intended to pluck her dates.A person scolded her for having come out (during the period of 'Idda).She came to Allah's Prophet (may peace be upon him.) and he said: Certainly you can pluck (dates) from your palm trees, for perhaps you may give charity or do an act of kindness.

Chapter 8 : THE PERIOD OF 'IDDA COMES TO AN END WITH THE BIRTH OF THE CHILD

Book 9, Number 3536:

    'Ubaidullah b. 'Abdullah b. 'Utba (b. Mas'ud) reported that his father wrote to Umar b. 'Abdullah b al Arqam al-Zuhri that he would go to Subai'ah bint al-Hirith al-Aslamiyya (Allah be pleased with her) and ask her about a verdict from him which Allah's Messenger (may peace be upon him) gave her when she had asked that from him (in regard to the termination of 'Idda at the birth of a child) 'Umar b. Abdullah wrote to 'Abdullah b.'Utba informing him that Subai'ah had told him that she had been married to Sa'd b. Khaula and he belonged to the tribe of Amir b. Lu'ayy, and was one of those who participated in the Battle of Badr, and he died in the Farewell Pilgrimage and she had been in the family way at that time.And much time had not elapsed that she gave birth to a child after his death and when she was free from the effects of childbirth she embellished herself for those who had to give proposals of marriage.Abd al-Sunabil b. Ba'kak (from Banu 'Abd al-Dar) came to her and said: What is this that I see you embellished ; perhaps you are inclined to marry, By Allah, you cannot marry unless four months and ten days (of 'Idda are passed). When he said that. I dressed myself, and as it was evening I came to Allah's Messenger (may peace be upon him) and asked him about it, and he gave me a religious verdict that I was allowed to marry when I had given birth to a child and asked me to marry if I so liked.Ibn Shihab said: I do not find any harm fur her in marrying when she has given birth to a child even when she is bleeding (after the birth of the child) except that her husband should not go near her until she is purified.

Book 9, Number 3537:

    Abu Salama b. 'Abd al-Rahman and Ibn 'Abbas.(Allah be pleased with them) got together in the house of Abu Huraira (Allah be pleased with him) and began to discuss about the woman who gave birth to a child a few nights after the death of her husband.Ibn 'Abbas (Allah be pleased with then)) said: Her 'Idda is that period which is longer of the two (between four months and ten days and the birth of the child, whichever is longer).AbuSalama,however said: Her period of 'Idda is over (with the birth of the child), and they were contending with each other over this issue, whereupon Abu Huraira (Allah be pleased with him) said: I subscribe (to the view) held by my nephew (i.e. Abu Salama). They sent Kuraib (the freed slave of Ibn 'Abbas) to Umm Salama to ask her about it.He came (back) to them and informed them that Umm Salama (Allah be pleased with her) said that Subai'ah al-Aslamiyya gave birth to a child after the death of her husband when the few flights (had hardly) passed and she made mention of that to Allah's Messenger (may peace be upon him) and he commanded her to marry.

Book 9, Number 3538:

    This hadith has been narated with the same chain of transrmitters except with a small change of words (and that is): They sent him to Umm Salama, but no mention was made of Kuraib.

Chapter 9 :IT IS OBLIGATORY TO ABSTAIN FROM ADORNMENT DURING THE 'IDDA PERIOD, BUT MOURNING BEYOND THREE DAYS IS PROHIBITED

Book 9, Number 3539:

    Zainab (bint Abu Salama) (Allah be pleased with her) reported: I went to Umm Habiba, the wife of Allah's Apostle (may peace be upon him), when her father Abu Sufyan had died.Umm Habiba sent for a perfume having yellowness in it or something else like it, and she applied it to a girl and then rubbed it on her cheeks and then said: By Allah, I need no perfume but for the fact that I heard Allah's Messenger (may peace be upon him) say on the pulpit: "It is not permissible for a woman believing in Allah and the Hereafter to mourn for the dead beyond three days, but (in case of the death) of the husband it is permissible for four months and ten days." Zainab said: I then visited Zainab hint Jahsh (Allah be pleased with her) when her brother died and she sent for perfume and applied it and then said: By Allah, I don't feel any need for the perfume but that I heard Allah's Messenger (may peace be upon him) say on the pulpit: "It is not permissible for a woman believing in Allah and the Hereafbler to mourn the dead beyond three days except in case of her husband (for whom she can mourn) for four months and ten days." Zainab (Allah be pleased with her) said: I heard my mother Umm Salama (Allah be pleased with her) as saying: A woman came to Allah's Messenger (may peace be upon him) and said: Allah's Messenger.I have a daughter whose husband has died and there has developed some trouble in her eye; should we apply collyrium to it?Thereupon Allah's Messenger (may peace be upon him) said: No (repeating it twice or thrice, saying only ,NO" all the time).Then he said: It is only four mouths and ten days, whereas in the preIslamic period none of you threw away the dung until one year had passed.Humaid said: I said to Zainab: What is this throwing of dung until a year is passed? Zainab said: When the husband of a woman died, she went into a hut and put on her worst clothes, and did not apply perfume or something like it until a year was over.Then an animal like a donkey, or a goat, or a bird was brought to her and she rubbed her hand over it, and it so happened that one on which she rubbed her hand died.She then came out of her house and she was given dung and she threw it and then she made use of anything like perfume or something else as she liked.

Book 9, Number 3540:

    Zainab bint Umm Salama (Allah be pleased with her) reported that a relative of Umm Habiba (Allah he pleased with her) died. She sent for a yellow (perfume) and applied that to her forearm and said: I, am doing it, for I have heard Allah's Messenger (may peace be upon him) saying: It is not permissible for a woman believing in Allah and the Hereafter to mourn beyond three days except the husband (for whom she can mourn) for four months and ten days, This hadith was narrated by Zainab from her mother and from Zainab, the wife of Allah's Apostle (may peace be upon him), or from some other lady from among the wives of the Prophet (may peace be upon him).

Book 9, Number 3541:

    Zainab bint Umm Salama (Allah be pleased with her) reported on the authority of her mother that a woman lost her husband. (As her eyes were ailing) they (her kith and kin) entertained fear about her eyes, so they came to Allah's Apostle (may peace be upon him) and sought permission for the use of collyrium, whereupon Allah's Messenger (may peace be upon him) said: One among you used to spend one year in a dungeon dressed in worst clothes. (And at the end of this period) she threw dung at the dog which happened to pass that way and then she came out (of her 'Idda). Can't she (wait) even for four months and ten days?

Book 9, Number 3542:

    Humaid b. Nafi' narrated two traditions from Umm Salama dealing with collyrium and the other hadith from the wives of Allah's Prophet (may peace be upon him) except with this that no mention was made of Zainab.

Book 9, Number 3543:

    Zainab bint Abu Salama reported: Umm Salama and Umm Habiba (Allah be pleased with them) were talking with each other (and saying) that a woman came to Allah's Messenger (may peace be upon him) and mentioned to him that her daughter had lost her husband, and her eyes were sore and she wnted to use collyrium, whereupon Allah's Messenger (may peace be upon him) said: One among you used to throw dung at the end of a year, and now (this abstinence from adornment) is only for four months and ten days.

Book 9, Number 3544:

    Zainab bint Abu Salama reported that when the news of the death of Abu Safyan came to Umm Habiba she sent for yellow (perfume) on the third day and rubbed it on her forearms and on her cheeks and said: I had in fact no need of it, but I heard Allah's Messenger (may peace be upon him) as saying: It is not permissible for the women believing in Allah and the Hereafter to abstain from adornment beyond three days except (at the death of) husband (in which case she must abstain from adornment) for four months and ten days.

Book 9, Number 3545:

    Safiyya bint Abu 'Ubaid reported on the authority of Hafsa or 'A'isha (Allah be pleased with thein) or from both of them that Allah's Messenger (may peace he upon him) said: It is not permissible for a woman believing in Allah and the Hereafter (or believing in Allah and His Messenger) that she should observe mourning for the dead beyond three days except in case of her husband.

Book 9, Number 3546:

    A hadith like this is transmitted on the authority of Nafi'

Book 9, Number 3547:

    Safiyya bint Abu 'Ubaid reported that she heard Hafsa daughter of Umar (Allah be pleased with them), (and) wife of Allah's Prophet (may peace be upon him), narrating a hadith like this from Allah's Apostle (may peace be upon him), and she made this addition: "She should abstain from adorning herself (in case of the death of her husband) for four months and ten days."

Book 9, Number 3548:

    Safiyya bint Abu 'Ubaid narrated this tradition of Allah's Prophet (may peace be upon him) on the authority of some wives of Allah's Apostle (may peace be upon him)

Book 9, Number 3549:

    'A'isha (Allah be pleased with her) reported Allah's Messenger (may peace be upon him) as saying: It is not permissible for a woman believing in Allah and the Hereafter to observe mourning on the dead for more than three (days), except in case of her husband.

Book 9, Number 3550:

    Umm 'Atiyya (Allah be pleased with her) reported that Allah's Messenger (may peace be upon him) had said: A woman must not observe mouriaing for one who had died for more than three (days) except for four months and ten days in the case of her husband. and she must not wear a dyed garment except one of the types made of dyed yarn, or apply collyrium, or touch perfume except a little perfume or incense, when she has been purified after her courses.

Book 9, Number 3551:

    A hadith like this has been narrated on the authority of Hisham with the same chain of narrators but with a slight variation of words.

Book 9, Number 3552:

    Umm 'Atiyya ('Allah be pleased with her) said: We were forbidden to observe mourning for the dead beyond three days except in the case of husband (where it is permissible) for four months and ten days, and (that during this period) we should neither use collyrium nor touch perfume, nor wear dyed clothes, but concession was given to a woman when one of us was purified of our courses to make use of a little incense or scent.

Chapter 10 :LI'AN (INVOKING CURSE)

Book 9, Number 3553:

    Sahl b. Sa'd al-Sa'idi reported that'Uwaimir al-'Ajlani came to 'Asim b. 'Adi al-Ansari and said to him. Tell me about a person who finds a man with his wife; should he kill him, and be killed In retaliation; or how should he act? 'Asim, ask for me (religious verdict about it) from Allah's Messenger (may peace be upon him).So 'Asim asked Allah's Messenger (may peace be upon him) and he did not like this question and he disapproved of it so much that'Asim felt aggrieved at what he had heard from Allah's Messenger (may peace be upon him).When 'Asim came back to his family, 'Uwaimir came to him and said: 'Asim, what did Allah's Messenger (may peace be upon him) say to you?'Asim said to 'Uwaimir: You did not bring something good.Allah's Messenger (may peace be upon him) did not like this religious verdict that I sought from him. 'Uwaimir said: By Allah, I will not rest until I have asked him about it.'Uwaimir proceeded until he came to Allah's Messenger (may peace be upon him) as he was sitting amidst people, and said: Messenger of Allah, tell me about a person who found a man with his wife.Should he kill him, and then you would kill him, or how should he act?Thereupon Allah's Messenger (may peace be upon him) said: (Verses) have been revealed concerning you and your wife; so go and bring her.Sahl said that they both invoked curses (and further said): I was along with people in the company of Allah's Messenger (may peace be upon him).And when they had finished, Uwaimir said: Allah's Messenger, I shall have told a lie against her if I keep her (now).So he divorced her with three pronouncements before Allah's Messenger (may peace be upon him) had commanded him.Ibn Shihab said: Subsequently that was the practice of invokers of curses (al Mutala'inain)

Book 9, Number 3554:

    Sahl b. Sa'd reported.. 'Uwaimir al-Ansari (Allah be pleased with him) from Banu'l-'Ajlan came to 'Asim b. 'Adi (Allah be pleased with him) the remaining part of the hadith is the same and it was also reecorded in it: "And subsequebtly the separation became the practice of al-Mutala'inain." And this addition was also made: "She was pregnant and her son was ascribed to her, and it became customary that such (a son) would inherit her and she would inherit him in the share prescribed by Allah for her.

Book 9, Number 3555:

    Ibn Shihab narrated about the invokers of curses and the practice of (li'an) based on the authority of Sahl b. Sa'd, of the tribe of Sa'ida. that a person from the Ansar came to Allah's Apostle (may peace be upon him) and said: Allah's Messenger, tell me about the person who found a man with his wife.The remaining part of the hadith is the same (but) with this addition: They invoked curses in the mosque and I was present there.And he narrated in the hadith: He divorced her with three pronouncements before Allah's Messenger (may peace be upon him) commanded him (to get separation).He separated from her in the presence of Allah's Apostle (may peace be upon him), whereupon he said: There is a separation between the invokers of curses.

Book 9, Number 3556:

    Sa'id b Jubair reported: I was asked about the invokers of curses during the reign of Mus'ab (b.Zubair) whether they could separate (themselves by this process). He said: I did not understand what to say.So I went to the house of Ibn 'Umar (Allah be pleased with them) in Mecca.I said to his servant: Seek permission for Me. He said that he (Ibn 'Umar) had been taking rest.He (Ibn 'Umar) heard my voice. and said: Are you Ibn Jubair?I said: Yes.He'said: Come in.By Allah, it must be some (great) need which has brought you here at this Hour.So I got in and found him lying on a blanket reclining against a pillow stuffed with fibres of date-palm. I said: O Abu'Abd al-Rahman, should there be separation between the invokers of curses? He said: Hallowed be Allah, yes,The first one who asked about it was so and so. he said: Messenger of Allah, tell me If one of us finds his wife committing adultery: what should he do?If he talks, that is something great, and if he keeps quiet that is also (something great) (which he cannot afford to do).Allah's Prophet (may peace be upon him) kept quiet (or some time). After some time he (that very person) came to him (Allah's Messenger) and said: I have been involved in that very cage about which I had asked you Allah the Exalted and Majestic then revealed (these) verses of Surah Nur: "Those who accuse their wives" (verse 6), and he (the Holy Prophet) recited them to him and admonished him, and exhorted him and informed him that the torment of the world is less painful than the torment of the Hereafter.He said: No, by Him Who sent you with Truth, I did not tell a lie against her.He (the Holy Prophet) then called her (the wife of that person who had accused her) and admonished her, and exhorted her, and informed her that the torment of this world is less painful than the torment of the Hereafter.She said: No, by Him Who sent thee with Truth, he is a liar. (it was) the man who started the swearing of oath and he swore in the name of Allah four times that he was among the truthful. and at the fifth turn he said: Let there be curse of Allah upon him if he were among the liars.Then the woman was called and she swore four times in the name of Allah that he (her husband) was among the liars, and at the fifth time (she said): Let there be curse upon her if he were among the truthful.He (the Holy Prophet) then effected separation between the two.A hadith like this is narrated by Ibn Numair with a slight variation of words.

Book 9, Number 3557:

    Ibn Umar (Allah be pleased with them) reported Allah's Messenger (may peace be upon him) saying to the invokers of curse: Your account is with Allah. One of you must be a liar.You have now no right over this woman.He said: Messenger of Allah, what about my wealth (dower that I paid her at the time of marriage)? He said: You have no claim to wealth.If you tell the truth, it (dower) is the recompense for your having had the right to intercourse with her, and if you tell a lie against her, it is still more remote from you than she is. Zuhair said in his narration: Sufyan reported to us on the authority of 'Amr that he had heard Sa'id b Jubair saying: I heard Ibn Umar (Allah be pleased with them) saying that Allah's Messenger (may peace be upon him) had said it.

Book 9, Number 3558:

    Ibn 'Umar (Allah be pleased with them) said that Allah's Messenger (may peace be upon him) effected separation between the two members of Banu al-'Ajlan, and said: Allah knows that one of you is a liar.Is there one to repent among you?

Book 9, Number 3559:

    Sa'id b. Jubair reported: I asked Ibn 'Umar (Allah be pleased with them) about invoking curse (li'an), and he narrated Similarly from Allah's Apostle (may peace be upon him).

Book 9, Number 3560:

    Sa'id b. Jubair reported that Mus'ab b. Zubair did not effect separation between the Mutala'inain (invokers of curses).Sa'id said: It was mentioned to 'Abdullah b. Umar (Allah be pleased with them) and he said: Allah's Apostle (may peace be upon him) effected separation between the two members of Banu al-'Ajlan.

Book 9, Number 3561:

    Nafi' reported on the authority of Ibn Umar (Allah be pleased with them) that a person invoked curse on the wife during the lifetime of Allah s Messenger (may peace be upon him), so he effected separation between them and traced the lineage of the son to his mother.

Book 9, Number 3562:

    Ibn 'Umar (Allah be pleased with them) reported: Allah's Messenger (may peace be upon him) asked a person from the Anger and his wife to invoke curse (upon one another in order to testify to their truthfulness), and then effected separation between them.

Book 9, Number 3563:

    A hadith like this has been narrated on the authority of 'Ubaidulah with the same chain of transmitters.

Book 9, Number 3564:

    'Abdullah reported: We were on the night of Friday staying in the mosque when a person from the Ansar came there and said: If a person finds hiswoman along with a man, and he speaks about it, you would lash him, and if he kills, you will kill him, and if he keeps quiet he shall have to consume anger.By Allah, I will definitely ask about him from Allah's Mescenger (may peace be upon him). On the following day he came to Allah's Messenger (may peace be upon him) and asked him thus: If a man were to find with his wife a man and if he were to talk about it, you would lash him; and if he killed, you would kill him, and if he were to keep quiet. he would consume anger, whereupon he (the Holy Prophet) said: Allah, solve (this problem), and he began to supplicate (before Him), and then the verses pertaining to li'an were revealed: "Those who accuse their wives and have no witnesses except themselves" (xxiv. 6).The person was then put to test according to these verses in the presence of the people.There came he and his wife in the presence of Allah's Messenger (may peace be upon him), and they invoked curses (in order to testify their claim).The man swore four times in the name of Allah that he was one of the truthful and then invoked curse for the fifth time saying: Let there be curse of Allah upon him if he were among the liars.Then she began to invoke curse.Allah's Messenger (may peace be upon him) said to her: just wait (and curse after considering over it), but she refused and invoked curse and when she turned away, he (Allah's Apostle) said: It seems that this woman shall give birth to a curly-haired black child, And so she did gave birth to a curly-haired black child.

Book 9, Number 3565:

    A hadith like this is narrated on the authority of A'mash.

Book 9, Number 3566:

    Muhammad (one of the narrators) reported: I asked Anas b. Malik (Allah be pleased with him) knowing that he had a knowledge of (the case of li'an).He said: Hilal b. Umayya (Allah be pleased with him) accused his wife with the charge of fornication with Sharik b. Sahma, the brother of al-Bara'b Malik from the side of his mother.And he was the first person who invoked curse (li'an) in Islam.He in fact invoked curse upon her.Allah's Messenger (may peace be upon him) said: See to her if she gives birth to a white-complexioned child having dark hair and bright eyes; he must be the son of Hilal b. Umayya; and if she gives birth to a child with dark eyelids, curly hair and lean shanks, he must be the offspring of Sharik b. Sahma . He said: I was informed that she gave birth to a child having dark eyelids, curly hair and lean shanks.

Book 9, Number 3567:

    Ibn Abbas (Allah be pleased with them) reported: Mention was made of li'an in the presence of Allah's Messenger (may peace be upon him).And Asim b. 'Adi passed a remark about it and then turned away, and a man of his tribe came to him complaining that he had found a man with his wife, whereupon 'Asim said: I have been taken by my words.He took him to Allah's Messenger (may peace be upon him) and told him about the man whom he had found with his wife and this man was a lean, yellow-coloured man with lank hair, and the person who was accused of committing adultery with her (his wife) had fleshy shanks, with wheat complexion and heavy bulk.Allah's Messenger (may peace be upon him) said: O Allah, make (this case) manifest.And as she gave birth to a child, whose face resembled that person about whom her husband had made mention that he had found her with, and Allah's Messenger (may peace be, upon him) had asked them to invoke curses. A person said to Ibn 'Abbas (Allah be pleased with him): Is she (that woman) about whom Allah's Messenger (may peace be upen him) (said): "If I were to stone anybody without evidence, I would have stoned her"? Ibn 'Abbas (Allah be pleased with him) said: No, it is not she.That woman was one who openly spread evil in society. This hadith has been narrated on the authority of Ibn 'Abbas (Allah be pleased with them) through another chain of transmitters with the addition of these words: 'With flesh, and curly tangled hair."

Book 9, Number 3568:

    'Abdullah b Shaddad reported that mention was made about the invokers of curses before Ibn 'Abbas (Allah be pleased with them).Ibn Shaddad said: Are these the two about whom Allah's Apostle (clay peace be upon him) said. "If I were to stone one without evidence, I would have definitely stoned her"? Ibn Abbas (Allah be pleased with them) said: She is not this woman; but she is the one who (committed adultery) openly.

Book 9, Number 3569:

    Abu Huraira (Allah be pleased with him) reported that Sa'd b. 'Ubada al-Ansari said: Messenger of Allah, tell the if a man finds his wife with another person, should he kill him?Allah's Messenger (may peace be upon him) said: No. Sa'd said: Why not? I swear by Him Who has honoured you with Truth. There upon Allah's Messenger (may peace be upon him) said: Listen to what your chief says.

Book 9, Number 3570:

    Abu Huraira (Allah be pleased with him) reported that Sa'd b. Ubada (Allah be pleased with him) said: Messenger of Allah, if I were to find with my wife a man, should I wait until I bring four witnesses?He said: Yes.

Book 9, Number 3571:

    Abu Huraira (Allah be pleased with him) reported that Sa'd b. Ubada (Allah be pleased with him) said: Messenger of Allah, if I were to find with my wife a man, should I not touch him before bringing four witnesses?Allah's Messenger (may peace be upon him) said: Yes.He said: By no means.By Him Who has sent you with the Truth, I would hasten with my sword to him before that. Allah's Messenger (may peace be upon him) said: Listen to what your chief says.He is jealous of his honour, I am more jealous than he (is) and God is more jealous than I.

Book 9, Number 3572:

    AI-Mughira b. Shu'ba (Allah be pleased with him) reported that Sa'd b. 'Ubada (Allah be pleased with him) said: If I were to see a man with my wife, I would have struck him with the sword, and not with the flat part (side) of it.When Allah's Messenger (may peace be upon him) heard of that, he said: Are you surprised at Sa'd's jealousy of his honour?By Allah, I am more jealous of my honour than he, and Allah is more jealous than I. Because of His jealousy Allah has prohibited abomination, both open and secret And no person is more jealous of his honour than Allah, and no persons, is more fond of accepting an excuse than Allah, on account of which He has sent messengers, announcers of glad tidings and warners; and no one is more fond of praise than Allah on account of which Allah has promised Paradise.

Book 9, Number 3573:

    A hadith like this has been transmitted on the authority, of 'Abd al-Malik b. Umair with the same chain of narraters but with a slight change of words.

Book 9, Number 3574:

    Abu Huraira (Allah be pleased with him) reported: There came a person to the Holy Prophet (may peace he upon him)) from Banu Fazara and said: My wife has given birth to a child who is black, whereupon Allah's Apostle (may peace be upon him) said: Have you any camels?He said: Yes. He again said: What is this colour? He said: They are red.He said: Is there a dusky one among them? He said: Yes, there are dusky ones among them He said: How has it come about? He said: It is perhaps the strain to which it has reverted, whereupon he (the Holy Prophet) said: It is perhaps the strain to which he (the child) has reverted.

Book 9, Number 3575:

    This hadith has been narrated on the authority of Zuhri with the same chain of transmitters.In the hadith transmitted on the authority of Ma'mar, the (words are): "Messenger of Allah, my wife has given birth to a dark-complexioned boy, and he at that time was intending to disown him." And this addition has been made at the end of the hadith: "He (the Holy Prophet) did not permit him to disown him."

Book 9, Number 3576:

    Abu Huraira (Allah be pleased with him) reported: A desert Arab came to Allah's Messenger (may peace be upon him) and said: My wife has given birth to a dark-complexioned child and I have disowned him.Thereupon Allah's Apostle (may peace be upon him) said: Have you any camels? He said: Yes. He said: What is their colour?He said?They are red.He said: Is there anyone dusky among them? He said: Yes.Allah's Messenger (may peace be upon him) said: How has it come about? He said: Messenger of Allah, it is perhaps due to the strain to which it has reverted, whereupon the Holy Prophet (may peace be upon him) said: It (the birth) of the black child may be due to the strain to which he (the child) might have reverted.

Book 9, Number 3577:

    A hadith like this has been narrated on the authority of Abu Huraira (Allah be pleased with him) through another chain of transmitters.

Chapter 11 : EMANCIPATING A SLAVE

Book 9, Number 3578:

    Ibn Umar (Allah be pleased with them) reported Allah's Messenger may peace be upon him) as saying: If anyone emancipates his share ina slave and has enough money to pay the full price for him, a fair price for the slave should be fixed, his partners given their shares, and the slave be thus emancipated, otherwise he is emancipated only to the extent of the first man's share.

Book 9, Number 3579:

    This hadith has been reported on the authority of Ibn 'Umar through another chain of transmitters.

Book 9, Number 3580:

    Abu Huraira (Allah be pleased with him) reported Allah's Messenger (may peace be upon him) as saying: The slave who is jointly owned by two persons, and is emancipated by one of them, (this one) has liability (upon him to secure complete freedom for that slave).

Book 9, Number 3581:

    Abu Huraira (Allah be pleased witli him) reported Allah's Prophet (may peace be upon him) as saying: If anyone emancipates a share in a slave, he is to be completely emancipated if he has money; but if he has none, the slave will be required to work to pay for his freedom, but must not be over-burhened.

Book 9, Number 3582:

    This hadith has been narrated on the authority of Sa'id b. Abu 'Aruba with the same chain of transmitters but with the addition: "If he (one of the joint owners emancipating the slave) has not (enough) money (to secure freedom for the other half) a fair price for the slave should be fixed, and he will be required to work to pay for his freedom, but must not be over-burdened.

Book 9, Number 3583:

    A hadith like this is reported on the authority of the same chain of transmitters but with a slight change of words.

Chapter 12 :THE RIGHT OF INHERITANCE OF PROPERTY VESTS WITH ONE WHO EMANCIPATES THE SLAVE

Book 9, Number 3584:

    Ibn Umar reported that 'A'isha decided to buy a slave-girl and then set her free, but her masters said: We are prepared to sell her to you on the condition that her right of inheritance would vest with you. She (Hadrat A'isha) made a mention of that to Allah's Messenger (may peace be upon him) whereupon he said: This should not stand in your way. The right of inheritance vests in one who emancipates.

Book 9, Number 3585:

    'A'isha (Allah be pjeased with her) reported that Barira came to her in order to seek her help in securing freedom,but she had (so far) paid nothing out of that sum stipulated in the contract.'A'isba said to her.Go to your family (who owns you), and if they like that I should pay the amount (of the contract) on your behalf (for purchasing your freedom), then I shall have the right in your inheritance. (If they accepted it) I am prepared (to make this payment).Barira made a mention of that to the (members of) her family, but they refused and said: If she (Hadrat 'A'isha) wants to do good to You for the sake of Allah, she may do it, but the right of inheritance will be ours.She (Hadrat 'A'isha) made a mention of that to Allah's Messenger (may peace be upon him), and he said to her: Buy her, and emancipate her, for the right of inheritance vests with one who emancipates (the slave).Allah's Messenger, may peace be upon him) then stood up and said: What has happened to the people that they lay down conditions which are not (found) in the Book of Allah?And he who laid down a condition not found in the Book of Allah, that is not valid. even if it is laid down hundred times.The condition laid down by Allah is the most weighty and the most valid.

Book 9, Number 3586:

    'A'isha, the wife of Allah's Apostle (may peace be upon him), reported: Barira came to me and said: 'A'isha, I have entered into contract for securing freedom with my family (who owns me) for nine 'uqiyas (of silver), one 'uqiya every year The rest of the hadith is the same (but with this addition): "This (the problem of the right of inheritance) should not stand in your way.Buy her, and set her free. He said in a hadith: Allah's Messenger (may peace be upon him) stood up among men, extolled Allah, praised Him, and then said: "for......"

Book 9, Number 3587:

    'A'isha (Allah be pleased with her) reported: Barira came to me and said: My family (owners) have made contract with me (for granting freedom) for nine 'uqiyas (of silver) payable in nine years, one 'uqiya every year.Help me (in making this payment). I said to her: If your family so desires, I am prepared to make them the full payment in one instalment, and thus secure freedom for you, but the right of inheritance will vest in me,if I do so.She (Barira) made a mention of that to her family, but they refused (except) on the condition that the right of inheritance would vest in them.She came to me and made mention of if She ('A'isha) said: I scolded her.She (Barira) said: By Allah, it is not possible (they will never agree to it).And as she was saying it, Allah's messenger (may peace be upon him) heard, and he asked me, I informed him and he said: Buy her and emancipate her, and let the right of inherit- ance vest in them, for they cannot claim it (rightfully) since the right of inherritance vests with one who emancipates (the slave; therefore, these people have no right to lay such false claims).And I did so.She ('A'isha) said: Then Allah's Messenger (may peace be upon him) delivered a sermon in the evening.He extolled Allah and praised Him with what He deserves, and then said afterwards,: What has happened to the people that they lay down conditions which are not found in the Book of Allah? And the condition which is not found in the Book of Allah is invalid, even if its number is one hundred.The Book of Allah is more true (than any other deed) and the condition laid down by Allah is more binding (than any other condition). What has happened to the people among you that someone among you says: "Emancipate so and so, but the right of inheritance vests in me"?Verily, the right of inheritance vests in one who emancipates.

Book 9, Number 3588:

    Hisham b. 'Urwa narrated a hadith like this with the same chain of trans- mitters except (with this change) that in the hadith transmitted on the authority of jartr (the words are): Her (Barira's) husband was a slave, so Allah's Messenger (may peace be upon him) gave her the option (either to retain her matrimonial relation with her husband or sever it off). She opted to break off (and secure freedom for her even from the matrimonial alliance). And if he were free he would not have given her the option. In the hadith narrated on the authority (of this chain of transmitters) these words are not found: Amma ba'du.

Book 9, Number 3589:

    'Abd al-Rahman b. al.Qasim reported on the authority of his father: 'A'isha (Allah be pleased with her) said: There were three issues which were clarified in case of Barira: her owners had decided to sell her on the condition that the right of her inheritance would vest with them.She ('A'isha) said: I made a mention of that to Allah's Apostle (may peace be upon him) and he said: Buy her and emancipate her, for verily the right of inheritance vests with one who emancipates. She said that she emancipated (her) and Allah's Messenger (may peace be upon him) gave her the option (either to retain her matrimonial alliance or break it after emancipation).She (taking advantage of the option) opted for herself (the severing of matrimonial alliance). 'A'isha said: The people used to give her charity and she gave us that as gift. I made a mention of it to Allah's Apostle (may peace be upon him), whereupon he said: That is charity for her but gift for you, so take that.

Book 9, Number 3590:

    'A'isha (Allah's be pleased with her) reported that she had bought Barira from the people of Ansar, but they laid down the condition that the right of inheritance (would vest in them), whereupon Allah's Messenger (may peace be upon him) said: The right of inheritance vests with one who shows favour (who emancipates) and Allah's Messenger (may peacebe upon him) gave her the choice (either to retain) her matrimonial alliance or break it).Her husband was a slave.She (Barira also) gave 'A'isha some meat as gift.Allah's Messenger (may peace be upon him) said:I wish you could prepare (cook) for us out of this meat. 'A'isha said,It has been given as charity to Barira, whereupon he said: That is charity for her and gift for us.

Book 9, Number 3591:

    'A'isha (Allah be pleased with her) reported: She wanted to buy Barira with a view to emancipating her.They (the sellers) laid down the condition that the right of inheritance would vest (with them).She (Hadrat 'A'isha) made a mention of that to Allah's Messenger (may peace be upon him), whereupon he said: Buy her and emancipate her for the right of inheritance vests with one who emancipates.Allah's Messenger (may peace be upon him) was given meat as gift.They (his Companions) said to Allah's Apostle (may peace be upon him): This was given as charity to Barira, whereupon he said: That is charity for her but gift for us.And she was given option (to retain her matrimonial alliance or to break it).Abd al-Rahman said: Her husband was a free man.Shu'ba said: I then asked him (one of the narrators) about Barira's husband (whether he had been a free mart or a slave), whereupon he said: I do not know.

Book 9, Number 3592:

    This hadith has been narrated on the authority of Shu'ba with the same chain of transmitters.

Book 9, Number 3593:

    'A'isha reported that the husband of Barira was a slave.

Book 9, Number 3594:

    'A'isha (Allah be pleased with her). the wife of Allah's Apostle (may Peace be upon him) said: Three are the Sunan (usages) (that we came to know in case of Bairara).She was given option in regard to her husband when she was emancipated. Sbe was given meat as charity.Allah's Messenger (way peace be upon him) visited me when an earthen pot with meat in it was placed on the fire.He asked for food and be was given bread with ordinary meat (usually cooked in the) house. Thereupon he (Allah's Messenger) said: Don't I see the earthen pot on fire with meat in it? They said: Yes.Allah's Messenger, there is meat in it which was given as charity to Barira. We did not deem it advisable that we should give you that to eat, whereupon he said: It is charity for her, but it is gift for us.Allah's Apostle (may peace be upon him) also said: The right of inheritance vests with one who emancipates.

Book 9, Number 3595:

    Abu Huraira (Allah be pleased with him) reported: 'A'isha (Allah be pleated with her) thought of buying a slave-girl and emancipating her, but her owners refused to (sell her but on the condition) that the right of inheritance would vest in them.She made a mention of that to Allah's Messenger (may peace be upon him). whereupon he said: Let this (condition) not stand in your way for the right of inheritance vests with one who emancipates.

Chapter 13 : IT IS FORBIDDEN TO SELL AL-WALA' (THE RIGHT OF INHERITANCE OF A SLAVE) AND ITS CONFERRING ON OTHERS

Book 9, Number 3596:

    Ibn Umar (Allah be pleased with them) reported that Allah's Messenger (may peace he upon him) forbade the selling and making a gift of the right of inheritance of a slave.Imam Muslim said: All the persons depend upon Abdullah b. Dinar in regard to this hadith.

Book 9, Number 3597:

    This hadith has been narrated on the authority of Ibn 'Umar (Allah be pleased with them) through another chain of transmitters but with this change that in tba hadith narrated by al-Thaqafi from Ubaidullah there is only a mention of selling (or right of inheritance, al-Wala' ) but not that of making a gift.

Chapter 14 : IT IS FORBIDDEN FOR A SLAVE TO TAKE ANYONE AS HIS ALLY EXCEPT ONE WHO EMANCIPATES HIM

Book 9, Number 3598:

    Jabir b. Abdullah (Allah be pleased with them) reported that Allah's Apostle (may peace be upon him) made it obligatory for every tribe (the payment) of blood-wit; he then also made it explicit that it is not permissible for a Muslim to make himself the ally (of the slave emancipated by another) Muslim without his permission. He (the narrator further added): I was informed that he (the Holy Prophet) cursed the one who did that (and it was recorded) in his Sahifa (in a document).

Book 9, Number 3599:

    Abu Huraira (Allah be pleased with him) reported that Allah's Messenger (may peace be upon him) said: He who takes anyone as his ally without the consent of his previous master, there will be the curse of Allah and that of His angels upon him, and neither, any obligatory act of his nor the supererogatory one will be accepted (by Allah).

Book 9, Number 3600:

    Abu Huraira (Allah be pleased with him) reported Allah's Apostle (may peace be upon him) as saying: He who took the freed slave as his ally without the consent of his previous master, there is upon him the curse of Allah and that of His angels and that of the whole mankind, and there will not be accepted from him his obligatory acts or supercrogatory acts on the Day of Resurrection.This hadith is narrated through the same chain of transmitters, but with a slight change of words.

Book 9, Number 3601:

    Ibrahim al-Taimi reported on the authority of his father: 'Ali b. Abu Talib (Allah be pleased with him) addressed us and said: He who thinks that we (the members of the Prophet's family) read anything else besides the Book of Allah and this Sahifa (and he said that Sahifa was tied to the scabbard of the sword) tells a lie. (This Sahifa) contains (problems) pertaining to the ages of the camels and (the recompense) of the injuries, and it also records the words of the Prophet (may peace be upon him): Medina is a sacred territory from 'Ayr to Thaur (it is most probably Uhud).He who innovates (an act or practice) or gives protection to an innovator, there is a curse of Allah and that of His angels and that of the whole humanity upon him.Allah will not accdpt from him (as a recompense) any obligatory act or supererogatory act, and the responsibility of the Muslims is a joint responsibility; even the lowest in rank can undertake the responsibility (on behalf of others), and he who claims anyone else as his father besides his own father or makes one his ally other than the one (who freed him), there is a curse of Allah. that of His angels and that of the wholemankind upon him.Allah will not accept the obligatory act of the supererogatery act (as a recompense) from him.

Chapter 15 : EXCELENCE OF EMANCIPATING A SLAVE

Book 9, Number 3602:

    Abu Huraira (Allah be pleased with him) reported Allah's Messenger (may peace be upon him) as saying: If anyone emancipates a Muslim slave, Allah will set free from Hell an organ of his body for every organ of his (slave's) body.

Book 9, Number 3603:

    Abu Huraira (Allah be pleased with him) reported Allah's Messenger (may peace benpon him) as saying: He who emancipates a slave, Allah will set free from Hell every limb (of his body) for every limb of his (slave's) body, even his private parts.

Book 9, Number 3604:

    Abu Huraira (Allah be pleased with him) reported: I heard Allah's Messenger (may peace be upon him) as saying: He who emancipates a believing slave. Allah will set free from Fire his every limb for every limb of his (slave's), even his private parts for his.

Book 9, Number 3605:

    Abu Huraira (Allah be pleased with him) reported Allah's Messenger (may peace be upon him) as saying: A Muslim who emancipates a Muslim (slave). Allah will save from Fire every limb of his for every limb (of the slave).Sa'id b. Marjana said: When I heard this hadith from Abu Huraira (Allah be pleased with him), I went away and made a mention of it to 'Ali b. Husain and he at once emancipated the slave for which Ibn ja'far was prepared to pay ten thousand dirhams or one thousand dinars.

Chapter 16 :EXCELLENCE OF SECURING THE EMANCIPATION OF FATHER

Book 9, Number 3606:

    Abu Huraira (Allah be pleased with him) reported Allah's Messenger (may peace be upon him) as saying: A son does not repay what he owes his father unless he buys him (the father) in case he is a slave and then emancipates him. In the narration transmitted by Ibn Abu Shaiba there is a slight change of words.

Book 9, Number 3607:

    A hadith like this has been narrated on the authority of Suhail with the same chain of transmitters.


BOOK 10: Transactions (Kitab Al-Buyu')

KITAB AL-BUYU'
(THE BOOK OF TRANSACTIONS)

Back
INTRODUCTION

    Honesty in commercial dealings is more strictly enjoined by Islam than by any other religion. It is because Islam is a religion which regulates and directs life in all its departments. It is not to be regarded, like the modern man's religion. as a personal, private affair, which has nothing to do with his economic and political life. It is not merely a body of dogmas or a bundle of rites and rituals; it is a practical code which governs life in all its spheres. Its laws are as effectively operative in our commerce and politics as in our domestic life and social relations. Islam censures political chicanery and economic exploitation as strongly as social excesses and individual dishonesty. Indeed, a true Islamic society is based upon honesty, justice and fraternity, and is absolutely intolerant of dishonesty in all its various forms. That is the reason why perfect honesty in business and truthfulness in trade are much emphasised by the Holy Prophet (may peace be upon him). It will not be an exaggeration to say that absolute honesty in business and commerce is really an Islamic concept. The Hindus and Jews were (and still, are) worshippers of the Mammon. Both of them have been mercenary nations, notorious for their greed. The pre-Islamic Christians. too, did not possess any high standard of business morality. It was Prophet Muhammad (may peace be upon him) who, on the one hand, urged his followers to adopt trade as their profession, and, on the other band, exhorted them to observe truthfulness and honesty in their business transactions.

    Islam lays the greatest emphasis on Qat Haldl (food earned through lawful means). The pious among us believe that just as nasty food spolis our physical health, similarly. food earned through unlawful means spoils our spiritual and moral health. A man who liver on income derived through illicit means and fraudulent practices cannot be morally advanced and spiritually elevated. If we try to comprehend the exact, implications of the term Haram (unlawful) we can form an idea of the high standard of morality on which Islam wants us to conduct our business. And, if business is conducted strictly in accordance with the Islamic principles of commerce, there can be absolutely no scope for any kind of commercial dishonesty varying from the simplest and most glaring type of business fraud to the most cunning and subtle type of profiteering which is often masked under a semblance of honesty.

    Islam is most vehement in its condemnation of commercial dishonesty. It denounced, in the strongest possible terms, all sorts of deceitful dealings and illegal profits. It has disallowed all transactions not based upon justice and fairplay The Holy Prophet (may peace be upon him), while reprimanding the dishonest dealer, said: "Laisa minna man gashshdna" (Whosoever deceives us is not one of us).

    According to Imam Ghazali, a Muslim who makes up his mind to adopt trade as a profession or to set up his own business should first acquire a thorough understanding of the rules of business transactions codified in the Islamic Shari'ah. Without such understanding he will go astray and fail into serious lapses making his earning unlawful. No people in the world have ever attached so much importance to lawful trading as did the early Muslims, nor has any other nation evinced such a dread of unlawful trading as they did. That is why al-Ghazali said stress on a clear understanding of the rules and laws governing business transactions as a necessary prerequisite to adopting trade or business as a profession.

    The Holy Qur'an has stressed the importance of fairness in business: "And, O my people, give full measure and weight justly, and defraud not men of their things, and act not corruptly in the land making mischief. What remains with Allah is better for you, if you are believers" (xi. 85-86).

    In these words addressed by Hadrat Shu'aib to his people, the Holy Qur'an enunciates the fundamental principles of commerce as follows

    1. To give just measure and weight.
    2. Not to withhold from the people the things that are their due.
    3. Not to commit evil on the earth with the intent of doing mischief.
    4. To be contented with the profit that is left with us by God after we have paid other people their due.

    We are told in these verses that commerce can flourish under conditions of peace and security. The people are, therefore, warned not to disturb the peace of the land so that there is a free and untrammelled trade between different parts of the world. In commercial relations we are expected to be absolutely just and honest, liberally giving other people their due. We are not to be guilty of selfish greed and not to indulge in profiteering; and we are told that the lawful profit which has God's blessings is the one that we are able to make through perfectly honest dealings with others. The injunctions contained in these Qur'anic verses and found elsewhere in the Holy Book close the door of all dishonest and unjust transactions. We should not forget that justice is a master virtue. If we give others just measure and just weight that tantamounts to saying that we should be fair and just in our dealings.

    A careful study of "Kitab al-Buyu`" (the book pertaining to business transactions) will reveal the fact that the Holy Prophet (may peace be upon him) based business dealings strictly on truth and justice. He has strongly disapproved all transactions which involve any kind of injustice or hardship to the buyer or the seller. He wanted that both, the buyer and the seller, should be truly sympathetic and considerate towards each other. One should not take undue advantage of the simplicity or ignorance of the other. The seller should not think that he has unrestricted liberty to extort as much as possible from the buyer. He has to be just; he should take his own due and give the buyer what is his.

    Islam, which condemns every kind of injustice and exploitation in human relations, wants its followers to conduct business in a sublime spirit of justice tempered with human kindness. The conduct of the seller in a transaction should be characterised not only by Insaf (justice), but also by Ihsan (magnanimity). "God will forgive the sins of a Muslim who absolves a fellow-Muslim from a sale-contract not liked by the latter," says the Holy Prophet (may peace be upon him).

    All transactions should be based on the fundamental principle of "Ta'auanu ala birri wa't-taqwa" (mutual co-operation for the cause of goodness or piety). A transaction not based upon this sound principle is not lawful. Unlawful transactions are motivated by lust for money and an ignoble desire to build up prestige. Islam strikes at the root of the passion for money and suggests a different yardstick to measure the prestige of a person. The Holy Qur'an, on the one hand, condemns hoarding and the excessive love for wealth, and, on the other, declares virtue and piety to be the criterion for determining a person's worth. "Inna akramakum `ind-Allahi atqakum" (The noblest in the eyes of God is the most pious among you). Thus does Islam minimise in every possible way the temptation to illegal trade and traffic. Let us now take note of the forms of business transactions which have been prohibited in Islam. The Holy Prophet (may peace be upon him) has not only disapproved of certain forms of business transactions, but has also laid down some basic conditions that should be fulfilled in every transaction if it is to be lawful.

    The following are some of these basic conditions:

    1. Things sold and money offered as their price to be lawfully acquired. The things sold and the money to be offered as their price should both be lawfully acquired and clearly specified. This condition demands that the goods sold should have been lawfully obtained. One has no business to sell goods which one has stolen or which one has acquired in a fraudulent manner. nor should one purchase anything with the money which one has accepted as illegal gratification or has aceuired in some other deceitful way. This condition holds the buyer and the seller responsible for lawful possession of the goods on the partof one and of the money on the part of other.
    2. Goods not to be sold before obtaining their possession. The Holy Prophet (may peace be upon him) has warned the Muslims against indulging in forward transactions which means selling goods before obtaining their possession. "Whoever buys cereals shall not tell them until he has obtained their possession," says the Holy Prophet (may peace be upon him). According to Ibn 'Abbas, what applies to cereals also applies to other categories of goods. On another occasion the Holy Prophet (may peace be upon him) has said: "Bargain not about that which is not with you."
    3. Goods to be bought in the open market. Goods and commodities for sale should go into the open market, and the seller or his agents must be aware of the state of the market before proposals are made for the purchase by the buyers. The seller should not be taken unawares lest the buyers should take undue advantage of his ignorance of the conditions and prices prevailing in the market.
    4. No trade and traffic in things, the use of which is prohibited by Islam. A Muslim can trade in those goods and commodities only the use of which has been declared to be Halal (lawful). There can be no trade and traffic in things the use of which is proliibited by Islam. For example, there can be no trade in wine, swine, dead bodies of animals and idols. A devout Muslim merchant would not even traffic in thin and transparent stuff for ladies because the use of such stuff by ladies is unlawful. One cannot sell the carcass of an animal. He can, however, flay its skin which can be used for making shoes and which can therefore, be sold, but not the flesh of the dead animal. What is true of the usable skin of animals is also true of the tusks of an elephant.

    Prohibited forms of Business

    1. Monopoly business. As monopoly means concentration of supply in one hand, it leads to exploitation of the consumers and the workers, it has, therefore, been declared unlawful by the Holy Prophet (may peace be upon him). Gigantic trusts. cartels and monopolies should not exist in the Islamic society. The monopoly-dominated economic order betrays lack of harmony between private and social good and is, thus, a negation of the principle of maximum social advantage which the Islamic society sets out to achieve.
    2. Speculative business basd on selfish interest. Speculation means buying something cheap in bulk at a time and selling it dear at another and, thus, controlling the whole market to achieve personal gains. A close observation will reveal that speculators are primarily interested in private gains regardless of the larger interest of the society. These speculators try to create artificial scarcity of goods and commodities and thereby create an inflationary pressure on the economy. As the poor masses have to pay for this. Islam has condemned such speculative business.
    3. Interest transactions. All transactions involving interest are forbidden in Islam. Some people find it hard to submit to the injunction prohibiting interest, because they think interest and profit earned in trade are similar. Capital invested in trade brings an excess called profit; invested in banking it brings interest. Why should one excess be considered lawful and the other unlawful? They fail to take note of the basic difference between the two. Trade involves risk of loss. Also in its case, it is not only the capital invested that brings profit which is equally the result of initiative, enterprise and efficiency of the entrepreneur. Hence its rate cannot be predetermined and fixed. Moreover, trade is productive. A person reaps a benefit after undergoing labour and hardship. It creates conditions of full employment and economic growth. It will also be noted that trade acts as one of the dominant factors in the process of building up civilisation through co-operation and mutual exchange of ideas. The spread of Islam and Islamic civilisation In the Far East has been mostly due to the efforts of Muslim traders. Interest has no redeeming feature at all. The fixed rate of profit which a person gets from a financial investment without any risk of loss and without augmenting it with human labour creates in man the undesirable weakness of miserliness and Shylockian selfishness and lack of sympathy. In the economic sphere it initiates and aggravates crisis.
      Rightly, therefore, has Islam strictly prohibited all transactions based on it or involving it in some form or other.Advancing money on interest, keeping deposits in a bank for the sake of earning interest, or getting concessions in rates of goods or commodities against advance payments of price, mortgaging and utilising an income-yielding property against a certain sum,to be returned in full when the property is redeemed and investing money in a trade against a predetermined and fixed rate of profit-are all unlawfnl business transactions because they involve Riba (interest) in some form or the other.
    4. Transactions similar (in nature) to gambling. The Arabic equivalent to gambling is Maisir which literarily means "getting something too easily", "getting a profit without working for it". The literal meaning of the term explains the principle on account of which gambling is prohibited in Islam. Any monetary gain which cornes too easily, so much so that one does not have to work for it, is unlawful.
      The most familiar form of gambling amang the Arabs in the days of the Holy Prophet (may peace be upon him) was gambling by casting of lots by means of arrows drawn from a bag. Some were blank and those who drew them got nothing. Others indicated prizes-big or small ones. Whether one got anything or nothing depended on pure luck. unless there was fraud on the part of someone concerned. The principle on which objection to gambling is based is that you gain what you have not earned, or lose on a mere chance. Dice, lottery, prize bonds and betting on horse races are to be held within the definition of gambling.
    5. Munabadha and Mulamasa. Islam recognises barter trade subject to the injunctions of the Qur'an and the Sunnah. In fact, Islam has closed all doors of dishonesty and deceit in business dealings. It has prohibited all forms of transactions which admit of fraud in the least degree. It has impressed on the traders that defective and worthless goods should not be given in exchange for good ones, and if there is a defect in the goods sold it must be pointed out and made manifest to the purchaser. The Messenger of Allah (may peace be upon him) said: "The buyer and the seller have the option of cancelling the contract as long as they have not separated; then. if they both speak the truth and make manifest, their transaction shall be blessed, and it they conceal and tell lies, the blessing of their transaction shall be obliterated".

    Besides issuing the instructions which govern all forms of trade, particularly barter trade, Islam has banned two forms of sale contract that were prevalent before Islam. These were Munabadha and Mulamasa. In neither of these was the purchaser offered an opportunity to examine the thing purchased. Munabadha means that the seller should throw the cloth to the buyer before he has carefully examined it. The very act of throwing the cloth will mean that the bargain has been struck. Mulamasa means touching the cloth without examining it, ie. the buyer was just supposed to touch the cloth to strike the bargain. Both these forms of transaction were prohibited because in either case the purchaser got no opportunity to examine the things sold to him, and the bargain was likely to prove unduly disadvantageous to one side.
    In fact, Islam demanlds that goods and commodities for we should go to the open market and the seller or his agents must be aware of the state of the market before proposals are made for the purchase of goods or communities in bulk. He should not be taken unawares lest advantage be taken of his ignorance of the state of the market, and the prevailing prices. All this is ver clearly laid down by the Prophet (may peace he upon him).
    As mentioned above, Islam tries to be fair to both parties to a transaction. Any step on the part of one, that is advantageous to him and disadvantageous to the other, is not permissible. The seller is expected to make the defects (if any) in the goods manifest to the buyer, nor is the buyer expected to take undue advantage of the ignorance of the seller.

    • Mozabana. It is the exchange of fresh fruits for dry ones in a way that the quantity of the dry fruit is actually measured and fixed, but the quantity of the fresh fruit to be given in exchange is guessed while it is still on the trees (Mishkat, 2710). The Holy Prophet (may peace be upon him) has forbidden this exchange because the quantity of the fruit on the trees cannot be definitely Determined and the transaction is just a leap into the dark.
    • Mu'awama. It consists in selling the fruit on the trees for a period of one, two or three years even before it has made its appearance. It is prohibited because like Muzabana it is also a leap into the dark. Such transactions may result in bitterness and frustration.
    • Bai' al-Gharar. It is to sell a thing which one doesn't have in one's possession, nor expects to bring it under one's control, e g. fish in the river, or birds in the air. Possession is one of the basic conditions of a sale. One cannot sell a thing which is not in one's possession.
    • Bai' al-'Uryan. It is getting a thing against a nominal advance on the condition that if the bargain is struck, the advance will be adjusted and if the bargain is cancelled, the seller will riot return the advance. The advance being nominal, the buyer has practically no liability. He will abide by the contract if he finds it advantageous to him and will withdraw himself from it otherwise.
    • Bai' al-Mudtar. It is to buy a thing forcibly or to purchase a thing when its owner is compelled under stress of want to dispose it of. Instead of purchasing the thing, and taking undue advantage of the seller's helplessness, one should help him. Bai' alal-Bai' (sale over and above the sale of another). When one person has sold goods to another, a third Person should not upset the bargain trying to sell his own goods to the latter, offering them at lower rates or pointing out the defect in the goods already sold to him by the former. "A Muslim should not purchase in opposition to his brother, nor should he send a marriage proposal over and above the proposal of another."
    • Bai' al-Hast (i.e. sale by means of pebbles). The purchaser will tell the seller that when he will throw a pebble on his goods, the sale contract will be confirmed or the seller tell the purchaser that on whatever thing a pebble thrown by him falls will be sold to him. Sale contract is a serious matter and it should not be accomplished by such hit-and-miss methods like throwing the pebbles on the goods. A sale completed in this way may lead to injustice and hardship to one side and is consequently prohibited.
    • Sale of unripe fruit and unripe corn. The Holy Prophet (may peace be upon him), according to Hadrat Anas (Allah be pleased with him), has prohibited the sale of grapes before they become dark and that of the corn before it ripens. Similarly, he has forbidden the sale of raw dates. The fruit of the date palms should not be sold until it becomes red or yellow.

    Here is a brief account of the sale transactions prohibited by Islam. If one ponders over these forms of transaction described above and described in greater detail in "Kitab al-Buyu," one can arrive at the following conclusions:

    1. Islam insists upon absolute justice and fairplay in business dealings.
    2. According to Islam, a person who sacrifices his faith, and loses the good pleasure of his Lord to make a monetary gain has not made a good bargain. A Muslim will not go in for such a bad bargain. A Muslim merchant is not a worshipper of the Mammon with an inordinate love for money. He prizes faith, piety and righteousness above all.
    3. Islam does not believe in the view that all is fair in business and that every kind of cleverness and deceit is justifiable in business transactions. Islam regards business or commerce as an economic activity to be carried on in a spirit of humanity. tarianism and justice. It does not approve of the cut-throat competition. Indeed, the very concept is un-Islamic.
    4. Islam expects the buyer and the seller to look upon each other as Muslim brethren or fellow human beings, each trying to go all his way to help and serve the other. It the seller happens to overcharge the buyer, he, instead of feeling proud of his cleverness in doing so, should somehow compensate him for the excessive payment received.
    5. All bargains that are clenched without giving the purchaser a fair chance of examining the things are prohibited because this amounts to denying him a right that was his due.
    6. Forcible transactions or transactions in which the buyer takes undue. advantage of the helplessness or misery of the seller are also discouraged.
    7. Islam has prohibited traffic in wine, swine, dead bodies of animals and other goods the use of which has been declared to be Haram (unlawful).
    8. It has also forbidden trading in things that have a debasing or vitiating influence on the Muslim society.
Chapter 1 : PROHIBITION OF BAI' MULAMASA AND BAI' MUNABAZA

Book 10, Number 3608:

    Abu Huraira (Allah be pleased with him) reported that Allah's Messenger (may peace be upon him) forbade (two types of transactions) Mulamasa and Munabadha

Book 10, Number 3609:

    Abu Huraira (Allah be pletsed with him) reported like this from Allah's Messenger (may peace be upon him).

Book 10, Number 3610:

    Abu Huraira reported from Allah's Messenger (may peace be upon him) a hadith like this through another chain cf transmitters.

Book 10, Number 3611:

    A hadith like this has been narrated on the authority of Abu Huraira (Allah be pleased with him) through another chain of transmitters.

Book 10, Number 3612:

    Abu Huraira (Allah be pleased with him) reported : Two types of trarisactions have been forbidden (by the Holy Prophet), al-Mlulamasa and al-Munabadha. As far as Mulamasa transaction is concerned, it is that every one of them (the parties entering into transaction) should touch the garment of the other without careful consideration, and al-Munabadha is that every one of them should throw his cloth to the other and one of them should not see the cloth of his friend.

Book 10, Number 3613:

    Abu Sa'id al-Khudri (Allah be pleased with him) reported: Allah's Messenger (may peace be upon him) forbade us (from),two types of business transactions and two ways of dressing. He forbade Mulamasa and Munabadha in transactions.Mulamasa means the touching of another's garment with his hand, whether at night or by day, without turning it over except this much. Munabadha means that a man throws his garment to another and the other throws his garment, and thus confirming their contract without the inspection of mutual agreement. This hadith has been narrated on the authority of Ibn Shihab through the same chain of transmitters.

Chapter 2 : INVALIDITY OF A TRANSACTION BY THROWING A STONE

Book 10, Number 3614:

    Abu Huraira (Allah be pleased with him) reported that Allah's Messenger (may peace be upon him) forbade a transaction determined by throwing stones, and the type which involves some uncertainty.

Chapter 3 : PROHIBITION OF HABAL AL-HABALA TRANSACTION

Book 10, Number 3615:

    'Abdullah (b.'Umar) (Allah be pleased with him) said that Allah's Messenger (may peace be upon him) forbade the transaction called habal al-habala.

Book 10, Number 3616:

    Ibn 'Umar (Allah be pleased with them) reported that the people of pre-Islamic days used to sell the meat of the slaughtered camel up to habal al-habala. And habal al-habala implies that a she-camel should give birth and then the (born one should grow young) and become pregnant. Allah's Messenger (may peace be upon him) forbade them that (this transaction).

Chapter 4 : IT IS FORBIDDEN THAT ONE SHOULD ENTER INTO A TRANSACTION ON WHICH ONE'S BROTHER HAS ALREADY BEEN NEGOTIATING, OR ONE SHOULD PURCHASE (IN OPPOSITION) TO ONE'S BROTHER, OR ONE SHOULD CHEAT AND RETAIN MILK IN THE UDDER (IN ORDER TO DECEIVE THE PURCHASER)

Book 10, Number 3617:

    Ibn 'Umar (Allah be pleased with them) reported Allah's Messenger (may peace be upon him) as having said this: One amongst you should not enter into a transaction when another is bargaining.

Book 10, Number 3618:

    Ibn 'Umar (Allah be pleased with them) reported Allah's Messenger (may peace be upon him) as saying: A person should not enter into a transaction when his brother is already making a transaction and he should not make a proposal of marriage when his brother has already made a proposal except when lie gives permission.

Book 10, Number 3619:

    Abu Huraira reported Allah's Messenger (may peace be upon him) as saying: A Muslim should not purchase (in opposition) to his brother. This hadith has been narrated on the authority of Abu Huraira through another chain of transmitters but with a slight change of words.

Book 10, Number 3620:

    Abu Huraira reported Allah's Messenger (may peace'be upon him) as saying: Do not go out to meet riders to enter into transaction with them; none of you must buy in opposition to another, nor must you bid against one another; a townsman must not sell for a man from the desert, and do not tie up udders of carnels and sheep, and he who buys them after that has been done has two courses open to him: after he has milked them he may keep them if he is pleased with them, or he may return them along with a sit of dates if he is displeased with them.

Book 10, Number 3621:

    Abu Huraira (Allah be pleased with him) reported that Allah's Messenger (may peace be upon him) forbade the (people) meeting the caravan (for entering into business transaction with them), and the selling of goods by a townsman on behalf of a man of the desert, and seeking by a woman the divorce of her sister (from her husband), and outbidding (against one another), and tying up the udders (of animals), and buying of (things) in opposition to one's brother. This hadith has been narrated through another chain of transmitters.

Book 10, Number 3622:

    Ibn Umar (Allah be pleased with them) reported that Allah's Messenger (may peace be upon him) forbade the outbidding (against another).

Chapter 5 : IT IS FORBIDDEN TO MEET THE TRADERS IN THE WAY FOR GETTING UNDUE ADVANTAGE

Book 10, Number 3623:

    Ibn 'Umar (Allah be pleased with them) reported Allah's Messenger (may peace be upon him) as saying: Do not go out to meet merchandise in the way, (wait)until it is brought into the market. This hadith has been reported on the authority of Ibn Numair but with a slight change of words.

Book 10, Number 3624:

    This hadith has been reported on the authority of 'Ubaidullah.

Book 10, Number 3625:

    Abdullah (Allah be pleased with him) reported Allah's Apostle (may peace be upon him) as saying: Do not meet the traders (in the way).

Book 10, Number 3626:

    Abu Huraira (Allah be pleased with him) reported Allah's Messenger (may peace he upon him) as saying: Do not meet the merchandise (in the way).

Book 10, Number 3627:

    Abu Huraira (Allah be pleased with him) reported Allah's Messenger (may peace be upon him) as saying: Do not meet the merchant in the way and enter into business transaction with him, and whoever meets him and buys from him (and in case it is done, see) that when the owner of (merchandise) comes into the market (and finds that he has been paid less price) he has the option (to declare the transaction null and void).

Chapter 6 : IT IS FORBIDDEN FOR THE TOWNSMAN TO SELL ON BEHALF OF THE MAN OF THE DESERT

Book 10, Number 3628:

    Abu Huraira (Allah be pleased with him) reported it directly from Allah's Apostle (may peace be upon him): The townsman'should not sell for a man from the desert (with a view to taking advantage of his ignorance of the market conditions of the city). And Zuhair reported from the Holy Prophet (may peace be upon him) that he forbade the townsman to sell on behalf of the man from the desert.

Book 10, Number 3629:

    Ibn 'Abbas (Allah be pleased with them) reported Allah's Messenger (may peace be upon him) as saying: The riders (carrying merchandise) should not be met in the way, and townsman should not sell for a man of the desert. The narrator reported. I said to Ibn 'Abbas: What do these words really imply-"The townsman for the man of the desert"? He said: That he should work as a broker on his behalf.

Book 10, Number 3630:

    Jabir (Allah be pleased with him) reported Allah's Messenger (may peace be upon him) as saying: The townsman should not sell for a man from the desert, leave the people alone, Allah will give them provision from one another. Yahya reported it with a slight change of words.

Book 10, Number 3631:

    Jabir (Allah be pleased with him) reported a similar hadith from Allah's Apostle (may peace be upon him) through another chain of transmitters.

Book 10, Number 3632:

    Anas b. Malik (Allah be pleased with him) reported: We were forbidden that a townsman should sell for a man of the desert, even if he is his brother or father.

Book 10, Number 3633:

    Anas b. Malik (Allah be pleased with him) said: We were forbidden that a townsman should sell for a man of the desert.

Chapter 7 COMMAND PERTAINING TO THE SELLING OF ANIMAL WHOSE UDDER IS TIED UP

Book 10, Number 3634:

    Abu Huraira (Allah be pleased with him) reported Allah's Messenger (may peace be'upon him) as saying: He who bought a goat having its udder tied up should go back with it, milk it, and, if he is satisfied with its milk, he should retair it, otherwise he should return it along with a sa' of dates.

Book 10, Number 3635:

    Abu Huraira (Allah be pleased with him) reported Allah's Messenger (may peace be upon him) as saying: He who buys a goat with its udder tied up has the option to retain the goat if he so desires or return it within three days, and in case he returns it he should do so along with a sa' of dates.

Book 10, Number 3636:

    Abu Huraira (Allah be pleased with him) reported Allah's Apostle (may peace be upon him) as saying: lie who buys a goat having its udder tied up has the option to return it within three days. If he returns it he should pay a sa' of dates. Wheat is not essential.

Book 10, Number 3637:

    Abu Huraira (Allah be pleased with him) reported Allah's Messenger (may peace be upon him) as saying: He who buys a goat having its udder tied up has two courses left for him. He may retain it, and if he desires may return it along with a sa' of dates and not wheat.

Book 10, Number 3638:

    Ayyub narrated with the same chain of transmitters but with this change of words: "He who buys a goat has the option. . . ."

Book 10, Number 3639:

    Hammam b. Munabbih said: Out of the ahadith which Abu Huraira (Allah be pleased with him) reported to us from Allah's Messenger (may peace be upon him) one is this that Allah's Messenger (may peace be upon him) said: If one among you buys a she-camel having its udder tied up he has the two options for him after milking it either (to retain it) or return it with a sa' of dates.

Chapter 8: IT IS INVALID TO SELL THE COMMODITY BEFORE TAKING POSSESSION OF IT

Book 10, Number 3640:

    Ibn Abbas (Allah be pleased with them) reported Allah's Messenger (may peace be upon him) as saying: He who buys foodgrain should not sell it until he has taken possession of it.

Book 10, Number 3641:

    A hadith like this has been narrated through the same chain of transmitters.

Book 10, Number 3642:

    Ibn Abbas (Allah be pleased with them) reported Allah's Messenger (may peace be upon him) as saying: He who buys food-rain should not sell it until he has taken possession of it. Ibn Abbas (Allah be pleased with them) said: I regard everything like food (so far as this principle is concerned).

Book 10, Number 3643:

    Ibn Abbas (Allah be pleased with them) reported Allah's Messenger (may peace be upon him) as saying: He who buys foodgrain should not sell it, until he has weighed it (and then taken possession of it). I (Tawus) said to Ibn Abbas (Allah be pleased with them): Why is it so? Thereupon he said: Don't you see that they (the people) sell foodgrains against gold for the stipulated time. Abu Kuraib did not make any mention of the stipulated time.

Book 10, Number 3644:

    Ibn 'Umar (Allah be pleased with them) reported Allah's Messenger (may peace be upon him) as saying: He who buys foodgrain should not sell it until he has taken full possession of it.

Book 10, Number 3645:

    Ibn Umar (Allah be pleased with them) reported: We used to buy foodgrains during the lifetime of Allah's Messenger (may peace be upon him). He (the Holy Prophet) would then send to us one who commanded us to take them (the foodgrains) to a place other than the one where we had bought them before we sold it.

Book 10, Number 3646:

    Ibn Umar (Allah be pleased with them) reported Allah's Messenger (may peace be upon him) as saying: He who buys foodgrain should not sell that before taking possession of it. He (the narrator) said: We used to buy foodgrain from the caravans in bulk, but Allah's Messenger (may peace be upon him) forbade us to re-sell that until we had shifted it to some other place.

Book 10, Number 3647:

    Ibn 'Umar (Allah be pleased with them) reported Allah's Messenger (may peace be upon him) as saying: He who bought foodgrain should not sell it until he had taken full possession of it (after measuring it).

Book 10, Number 3648:

    Ibn 'Umar (Allah be pleased with them) reported Allah's Messenger (may peace be upon him) as saying,: He who bought foodgrain should not sell it until he had taken possession of it.

Book 10, Number 3649:

    Ibn 'Umar (Allah be pleased with them) reported that they were beaten during the lifetime of Allah's Messenger (may peace be upon him) if they had bought foodgrains in bulk and then sold them in the spot without shifting them (to some other place).

Book 10, Number 3650:

    Salim b.'Abdullah (Allah be pleased with them) reported his father havingsaid this: I saw people being beaten during the lifetime of Allah's Messenger (may peace be upon him) in case they bought the foodgrain in bulk, and then sold them at that spot before taking it to their places. This hadith is narrated on the authority of 'Ubaidullah b. Abdullah b. 'Umar through another chain of transmitters (and the words are): "His father (Ibn 'Umar) used to buy foodgrains in bulk and then carried them to his people."

Book 10, Number 3651:

    Abu Huraira (Allah be pleased with him) reported Allah's Messenger (may peace be upon him) as saying: He who bought foodgrain should not sell it until he had measured it. In the narration of Abu Bakr there the word is Ibta' instead of Ishtara.

Book 10, Number 3652:

    Abu Huraira (Allah be please with him) is reported to have said to Marwan: Have you made lawful the transactions involving interest? Thereupon Marwan said: I have not done that. Thereupon Abu Huraira (may peace be upon him) said: You have made lawful the transactions with the help of documents only, whereas Allah's Messenger (may peace be upon him) forbade the transaction of foodgrains until full possession is taken of them. Marwan then addressed the people and forbade them to enter into such transactions (as are done with the help of documents). Sulaiman said: I saw the sentinels snatching (these documents) from the people.

Book 10, Number 3653:

    Jabir b. Abdullah (Allah be pleased with them) reported Allah's Messenger (may peace be upon him) as saying: When you purchase foodgrains, do not sell them until you have taken possession of them.

Chapter 9:IT IS FORBIDDEN TO SELL THE REAP OF DATES THE WEIGHT OF WHICH IS UNKNOWN

Book 10, Number 3654:

    Jabir b. Abdullah (Allah be pleased with them) is reported to have said that Allah's Messenger (may peace be upon him) forbade the sale of a heap of dates the weight of which is unknown in accordance with the known weight of dates.

Book 10, Number 3655:

    This hadith is narrated on the authority of Jabir b. Abdullah (Allah be pleased with them) but with this variation that no mention is made of the dates(which one finds) at the end of the previous hadith.

Chapter 10: BOTH THE BUYERS AND THE SELLERS HAVE THE OPTION TO WITHDRAW THE TRANSACTION BEFORE LEAVING THE MEETING (WHERE THE BARGAIN IS STRUCK)

Book 10, Number 3656:

    Ibn 'Umar (Allah be pleased with them) reported Allah's Messenger (may peace be upon him) as saying : Both parties in a business transaction have the right to annul it so long as they have not separated; except in transactions which have been made subject to the right of parties to annul them.

Book 10, Number 3657:

    This hadith has been narrated on the authority of Ibn 'Umar (Allah be pleased with them) through another chain of transmitters.

Book 10, Number 3658:

    Ibn 'Umar (Allah be pleased with thcm) reported Allah's Messenger (may peace be upon him) as saying : When two persons enter into a transaction, each of them has the right to annul it so long as they are not separated and are together (at the place of transaction); or if one gives the other the right (to annul the transaction) But if one gives the other the option, the transaction is made on this condition (i.e. one has the right to annul the transaction), it becomes binding. And if they are separated after they have made the bargain and none of them annulled it, even then the transaction is binding.

Book 10, Number 3659:

    Abdullah b. 'Umar (Allah be pleased with them) reported Allah's Messenger (may peace be upon him) as saying: When two persons enter into a transac.tion, each one of them has the right to annul it so long as they are not separated, or their transaction gives one another (as a condition) the right of annulling, and if their transaction,has the right of annulling it the transaction becomes binding. Ibn Abi Umar made this addition that whenever he (Ibn Umar) entered into a transaction with a person with the intention of not breaking it, he walked a while and then returned to him.

Book 10, Number 3660:

    Ibn Umar reported Allah's Messenger (may peace be upon him) as saying: There is no transaction between two persons entering a transaction until they separate, but only when there is an option to annul it.

Chapter 11: TRUTHFULNESS IN TRANSACITION AND DESCRIPTION (OF THE DEFECT IN THE COMMODITY)

Book 10, Number 3661:

    Hakim b. Hazim (Allah be pleased with him) reported Allah's Messenger(may peace be upon him) as saying : Both parties in a business transaction have the right to annul it so long as they have not separated; and if they speak the truth and make everything clear they will be blessed in their transaction; but if they tell a lie and conceal anything the blessing on their transaction will be blotted out.

Book 10, Number 3662:

    A hadith like this has been transmitted on the authority of Hakim b. Hizam (Imam Muslim) said : Hakim b. Hizam was born inside the Ka'ba and lived for one hundred and twenty years.

Chapter 12: HE WHO DECEIVES IN BUSINESS TRANSACTION

Book 10, Number 3663:

    Abdullah b. Dinar narrated that he heard Ibn 'Umar (Allah be pleased with them) saying : A man mentioned to the Messenger of Allah (may peace be upon him) that he was deceived in a business transaction, whereupon Allah's Messenger (may peace be upon him) said : When you enter into a transaction, say : There should be no attempt to deceive.

Book 10, Number 3664:

    This hadith has been narrated on the authority of 'Abdullah b. Dinar with the same chain of transmitters but these words are not found in it . "When he buys he should say: There should be no attempt to deceive."

Chapter 13: PROHIBITION OF THE SALE OF FRUITS UNTIL THEY ARE CLEARLY IN GOOD CONDITION

Book 10, Number 3665:

    Ibn 'Umar (Allah be pleased with them) reported that Allah's Messenger (may peace be upon him) forbade the sale of fruits until they were clearly in good condition, he forbade it both to the seller and to the buyer.

Book 10, Number 3666:

    Ibn 'Umar (Allah be pleased with them) reported that Allah's Messenger (may peace be upon him) forbade the sale of palm-trees (i.e. their trults) until the dates began to ripen, and ears of corn until they were white and were safe from blight. He forbade the seller and the buyer.

Book 10, Number 3667:

    Ibn Umar (Allah be pleased with them) reported Allah's Messenger (may peace be upon him) as saying: Do not buy fruit until its good condition becomes clear, and (the danger) of blight is no more. He said: Its good condition becoming clear implies that it becomes red or yellow.

Book 10, Number 3668:

    This hadith is reported or the authority of Yahya with the same chain of transmitters up to "until its good condition becomes clear," but lie did not mention what follows (these words).

Book 10, Number 3669:

    This hadith has been narrated on the authority of Ibn 'Umar through another chain of transmitters.

Book 10, Number 3670:

    Nafi, reported on the authority of Ibn Umar (Allah be pleased with them) a hadith like that narrated before.

Book 10, Number 3671:

    Ibn Umar (Allah be pleased with them) reported Allah's Messenger'(may peace be upon him) as saying: Do not buy fruits (on the trees) until their good condition becomes clear. In the hadith transmitted on the authority of Shu'ba it was stated that Ibn Umar (Allah be pleased with them) was asked what good condition implied. He said: When (the danger of) blight is no more.

Book 10, Number 3672:

    Jabir (Allah be pleased with him) reported that Allah's Messenger (may peace be upon him) forbade (or forbade us) the sale of fruits until they are ripe in a good condition.

Book 10, Number 3673:

    Jabir b. Abdullah (Allah be pleased with them) reported Allah's Messenger (may peace be upon him) forbidding the sale of fruit until its good condition is obvious.

Book 10, Number 3674:

    Abu Bakhtari reported: I asked Ibn 'Abbas (Allah be pleased with them) about the sale of dates. He said: Allah's Messenger (may peace be upon him) forbade the sale of dates of the trees until one eats them or they are eaten (i.e. they are fit to be eaten) or until they are weighed (or measured). I said: What does it imply: "Until it is weighed"? Thereupon a person who was with him (Ibn Abbas) said: Until he is able to keep it with him (after plucking them).

Book 10, Number 3675:

    Abu Huraira (Allah be pleased with him) reported Allah's Messenger (may peace be upon him) as saying: Do not sell the fruits until their good condition becomes evident."

Chapter 14 : IT IS FORBIDDEN TO SELL FRESH DATES AGAINST DRY DATES, EXCEPT IN CASE OF AL-ARAYA

Book 10, Number 3676:

    Ibn Umar (Allah be pleased with them) reported Allah's Apostle (may peace be upon him) forbidding the sale of fruits until their good condition becomes evident and the purchase of dates for dates. Zaid b. Thabit (Allah be pleased with him) said that Allah's Messenger (may peace be upon him) gave a concession in case of the sale known as al-araya, there is an addition of the word an tuba'a in the hadith transmitted by Ibn Numair.

Book 10, Number 3677:

    Abu Huraira (Allah be pleased with him) reported Allah's Messenger (may peace be upon him) as saying: Do not buy the fruit until their condition is clear, and do not buy the fresh dates. A hadith like this has been reported by Ibn 'Umar through another chain of transmitters.

Book 10, Number 3678:

    Sa'id b. al-Musayyib said that Allah's Messenger (may peace be upon him) forbade the transaction of Af Muzabana and Muhaqala. Muzabana means that fresh dates on the trees should be sold against dry dates. Muhaqala implies that the wheat in the ear should be sold against the wheat and getting the land on rent for the wheat (produced in it). He (the narrator) said that the Holy Prophet (may peace be upon him) had aid: Do not sell fresh fruits on the trees until their good condition becomes manifest, and do not sell fresh dates on the trees against dry dates. Salim said: Abdullah informed me on the authority of Zaid b. Thabit, Allah's Messenger (may peace be upon him) having given concession afterwards in case of ariyya transactions by which dry dates can be exchanged with fresh dates, but he did not permit it in other cases.

Book 10, Number 3679:

    Zaid b. Thabit (Allah be pleased with him) reported Allah's Messenger (may peace he upon him) having given concession in case of 'ariyya for selling dry dates (with) fresh dates after measuring them out.

Book 10, Number 3680:

    Zaid b. Thabit reported that Allah's Messenger (may peace be upon him) give concession in case of 'ariyya transactions according to which the members of the household give dry dates according to a measure and then eat fresh dates (in exchange for it)

Book 10, Number 3681:

    A hadith like this has been narrated on the authority of Nafi' with the same chain of transmitters.

Book 10, Number 3682:

    Yahya b. Sa'id reported this hadith with the same chain of transmitters but with this change: 'Ariyya implies that date-palm trees should be donated to the people and then they sell it with a measure of dry dates.

Book 10, Number 3683:

    Zaid b Thabit (Allah be pleased with him) reported that Allah's Messenger (may peace be upon him) gave concession in case of al-'ariyya transactions (for exchanging dates) for dates with measure. Yahya said: 'Ariyya implies that a person should buy fresh dates on the tree for his family to eat against a measure of dry dates.

Book 10, Number 3684:

    Zaid b. Thabit (Allah be pleased with him) reported Allah's Messenger (may peace be upon him) granting concession in case of 'ariyya transactions and that implies selling of (dry dates for fresh dates) according to a measure.

Book 10, Number 3685:

    Ubaidullah reported this hadith with a slight change of words on the same authority (as quoted above).

Book 10, Number 3686:

    Nafi, reported this hadith with the same chain of transmitters stating that Allah's Messengtr (may peace be upon him) granted concession in case of 'ariyya transactions (for exchange of the same commodity) with measure.

Book 10, Number 3687:

    Bashair b. Yasir reported on the authority of some of the Companions of Allah's Messenger (may peace be upon him) among the members of his family among whom one was Sahl b. Abu Hathma that Allah's Messenger (may peace be upon him) forbade buying of fresh dates against dry dates and that it is Riba and this is Muzabana, but he made an exemption of 'ariyya (donations) of a tree or two in which case the members of a family sell dry dates and buy fresh dates for eating them.

Book 10, Number 3688:

    Bushair b. Yasar reported on the authority of some of the Companion of Allah's Messenger (may peace be upon him) that he exempted the transactions, of 'ariyya (from the direct exchange of one kind) after measuring the dry dates (in exchange for fresh dates).

Book 10, Number 3689:

    Bushair b. Yasir reported on the authority of some of the Companions of Allah's Messenger (may peace be upon hinn) from among the members of his family that he forbade (the direct exchange of a commodity having different qualities) but with the change that Ishaq and Ibn al-Muthanna used the word Zabn in place ot Riba and Ibn Abu 'Umar used the word Riba (interest).

Book 10, Number 3690:

    A hadith like this has been narrated on the authority of Sahl b. Abu Hathma.

Book 10, Number 3691:

    Sahl b. Abu Hathma reported Allah's Messenger (may peace be upon him) having forbidden Muzabana, i.e. exchange of fresh dates with dry dates. except in case of those to whom donations of some trees have been made. It is for them that concession has been given.

Book 10, Number 3692:

    Abu Huraira (Allah be pleased with him) reported Allah's Messenger (may peace be upon him) having given exemption of 'ariyya transactions measuring less than five wasqs or up to five wasqs (the narrator Dawud is in doubt whether it was five or less than five).

Book 10, Number 3693:

    Ibn Umar (Allah be pleased them) reported Allah's Messenger (may peace be upon him) having forbidden Muzabana, and Muzabana implies the selling of fresh dates for dry dates by measuring them out and the selling of raisins by measure for grapes.

Book 10, Number 3694:

    'Abdullah (b. Umar) reported that Allah's Apostle (may peace be upon him) forbade Muzabana, i.e. buying of fresh dates (on) the trees for dry dates by measure, and the buying of grapes for raisins by measure and the selling of field of corn for corn by measure.

Book 10, Number 3695:

    A hadith like this has been narrated on the authority of 'Ubaidullah with the same chain of transmitters.

Book 10, Number 3696:

    Ibn 'Umar (Allah be pleased with them) reported Allah's Messenger (may peace be upon him) having forbidden Muzabana, and Muzabana is the selling of dry dates by measure for fresh dates and the selling of raisins by measure for grapes and selling of all Ports of fruits on the basis of calculation.

Book 10, Number 3697:

    Ibn 'Umar (Allah be pleased with them) reported Allah's Messenger (may peace be upon him) having forbidden Muzabana, and Muzabana implies the selling of dry dates for fresh dates on the tree with a definite measure (making it clear) that in case it increases, it belongs to me and if it is less, it is my responsibility.

Book 10, Number 3698:

    A hadith like this has been transmitted on the authority of Ayyub.

Book 10, Number 3699:

    Abdullah (b. Umar) (Allah be pleased with them) reported Allah's Messenger (may peace be upon him) having forbidden Mazabana, and it implies that one should sell the fresh fruits of his orchard (for dry fruits) or, if it is fresh dates, for dry dates with a measure, or if it is grapes for raisins or if it is corn in the field for dry corn with a measure He (the Holy Prophet) in fact forbade all such transactions.Qutaiba has narrated it with a slight variation of words.This hadith has been narrated on the authority of Nafi with another chain of transmitters.

Chapter 15 : PERTAINING TO ONE WHO SELLS DATE-PALM TREE WITH DATES HANGING ON ITS BRANCHES

Book 10, Number 3700:

    Ibn Umar (Allah be pleased with them) reported Allah's Messenger (may peace be upon him) as saying: If anyone buys palm-trees after they have been fecundated the fruit belongs to the seller unless the buyer makes a proviso.

Book 10, Number 3701:

    Nafi reported on the authority of Ibn Umar (Allah be pleased with them) that the Messenger of Allah (may peace be upon him) said: Whichever tree is bought with its roots, and if it is fecundatedits fruit would belong to one who has grafted it except when the provision is laid down by the buyer.

Book 10, Number 3702:

    Ibn Umar (Allah be pleased with them) reported Allah's Apostle (may peace be upon him) as saying: Whosoever grafts the tree and then sells its roots, its fruit will belong to one who grafts it except when provision is laid down by the buyer.

Book 10, Number 3703:

    This hadith has been narrated on the authority of Nafi, with the same chain of transmitters.

Book 10, Number 3704:

    Abdullah b. Umar (Allah be pleased with them) reported Allah's Massenger (may peace be upon him) as saying: He who buys a tree after it has been fecundated, its fruit belongs to one who sells it except when the provision has been laid down by the buyer (that it will belong to him), and he who buys a slave, his property belongs to one who sells him except when a provision has been laid down by the buyer (that it will be transferred to him with the slave).

Book 10, Number 3705:

    A hadith like this has been narrated on the authority of al Zuhri.

Book 10, Number 3706:

    Ibn Umar reported on the authority of his father as Allah's Apostle (may peace be upon him) saying so.

Chapter 16 : FORBIDDANCE OF AL-MUHAQALA, AND AL MUZABANA, AND AL- MUKHABARA, AND THE SALE OF FRUITS BEFORE THEIR GOOD CONDITION IS CLEAR, AND AL-MU'AWAMA. I.E. THE SALE FOR SOME YEARS

Book 10, Number 3707:

    Jabir b. Abdullah (Allah be pleased with them) reported that Allah's Messenger (may peace be upon him) had forbidden Muhaqala. and Muzabana, Mukhibara and the sale of fruits until their good condition becomes clear, and (he commanded) that (commodities) should not be sold but for the dinar and dirham except in case of araya.

Book 10, Number 3708:

    Jabir b. 'Abdullah (Allah be pleased with them) reported that Allah's Messenger (may peace be upon him) forbade the types of sales as described before.

Book 10, Number 3709:

    Jabir b. 'Abdullah (Allah be pleased with them) reported that Allah's Messenger (may peace be upon him) forbade Mukhabara and Muhaqala, and Muzabana, and the sale of the fruit until it is fit for eating, and its sale but with dirham and dinar. Exception is made in case of 'araya. Ata' said: Jabir explained (these terms) for us. As for Mukhabara it is this that a wasteland is given by a person to another and he makes an investment in it and then gets a share in the produce. According to him (Jabir), Muzabana is the sell of fresh dates on the tree for dry dates with a measure, and Muhaqala in agriculture implies that one should sell the standing crop for grains with a measure.

Book 10, Number 3710:

    Jabir b. Abdullah (Allah be pleased with them) reported Allah's Messenger (may peace be upon him) forbidding Muhaqala, and Muzabana, and Mukhabara, and the buying of date-palm until its fruit is ripened (ripening means that its colour becomes red or yellow, or it is fit for being eaten). And Muhaqala implies that crops in the field are bought for grains according to a customary measure. Muzabana implies that date-palm should be sold for dry dates by measuring them with wisqs, and al-Mukhabara is (a share), maybe one-third or one-fourth (in produce) or something like it. Zaid (one of the narrators) said to Ata' b. Abu Rabah (the other narrator): Did You bear Jabir b. Abdullah (Allah be pleased with them) making a mention of it that he had heard it directly from Allah's Messenger (may peace be upon him)? He said: Yes.

Book 10, Number 3711:

    Jabir b. Abdullah (Allah be pleased with them) reported Allah's Messenger (may peace be upon him) forbidding Muzabana and Muhaqala, and Mukhabara, and the sale of fruits until they are ripe. I (the narrator) said to Sa'id (the other narrator): What does ripening imply? He said: It meant that they become red or become yellow and are fit for eating.

Book 10, Number 3712:

    Jabir b. Abdullah (Allah be pleased with them) reported Allah's Messenger (may peace be upon him) forbidding Muhaqala and Muzabana and Mu'awama and Mukhabara. (One of the narrators)'said: Sale years ahead is Mu'awama, and making exceptional but he made an exemption of arraya.

Book 10, Number 3713:

    A hadith like this has been narrated on the authority of Jabir (Allah be pleased with him) from Allah's Apostle (may peace be upon him). but he made no mention of transactions years (ahead) implying Mu'awama.

Chapter 17 : LEASING OUT LAND

Book 10, Number 3714:

    Jabir b. Abdullah (Allah be pleased with them) reported that Allah's Messenger (may peace be upon him) forbade leasing of land, and selling ahead for years and selling of fruits before they become ripe.

Book 10, Number 3715:

    Jabir b. Abdullah (Allah be pleased with them) reported Allah's Messenger (may peace be upon him) having forbidden the renting of land.

Book 10, Number 3716:

    Jabir b. Abdullah (Allah be pleased with them) reported Allah's Messenger (may peace be upon him) as saying: He who has land should cultivate it himself, but if he does not cultivate it himself, then he should let his brother cultivate it.

Book 10, Number 3717:

    Jabir b. Abdullah (Allah be pleased with them) reported some of the Companions of Allah's Messenger (may peace be upon him) had surplus of land. Thereupon Allah's Messenger (may peace be upon him) said: He,who has surplus land (in his possession) should cultivate it, or he should lend it to his brother for benefit, but if he refuses to accept it, he should retnai it.

Book 10, Number 3718:

    Jabir b. Abdullah (Allah be pleased with them) reported Allah's Messenger (may peace be upon him) having forbidden taking of rent or share of land.

Book 10, Number 3719:

    Jabir (Allah be pleased with him) reported Allah's Messenger (may peace be upon him) as saying: He who has land should cultivate it, but if he does not find it possible to cultivate it, or finds himself helpless to do so, he should lend it to his Muslim brother, but he should not accept rent from him.

Book 10, Number 3720:

    Sulaiman b. Musa asked Ata': Did Jabir b. 'Abdullah (Allah be pleased with them) reported Allah's Apostle (may peace be upon him) as saying: "He who has land should cultivate it himself, or let his brother cultivate it, and should not give on rent"? He said: Yes.

Book 10, Number 3721:

    Jabir (Allah be pleased with him) reported Allah's Apostle (may peace be upon him) having forbidden Mukhabara.

Book 10, Number 3722:

    Jabir b. Abdullah (Allah be pleased with them) heard Allah's Messenger (may peace be upon him) say: He who has surplus of land should either cultivate it himself, or let his brother cultivate it, an should not sell it. I (the narrator) said to Sa'id: What does his statement "do not sell it" mean? Does it imply "rent"? He said: Yes.

Book 10, Number 3723:

    Jabir b. 'Abdullah reported: We used to cultivate land on rent during the lifetime of Allah's Apostle (may peace be upon him) and we got a share out of the grain left in the ears after threshing them and something unspecified. Allah's Messenger (may peace be upon him) said: He who has land should cultivate it or let his brother till it, otherwise he should leave it.

Book 10, Number 3724:

    Jabir b. Abdullah (Allah be pleased with them) reported: We used to get land (on rent) during the lifetime of Allah's Messeuge, (may peace be upon him) with a share of one-third or one-fourth (of the produce from the land irrigated) with the help of canals. Thereupon Allah's Messenger (may peace be upon him) stood up (to address) and said: HRe who has land should cultivate it, and if he does not cultivate it, he should lend it to his brother, and if he does not lend it to his brother, he should then retain it.

Book 10, Number 3725:

    Jabir (Allah he pleased with him) reported: I heard Allah's Apostle (may peace be upon him) as saying: He who has (surplus) land should donate it (to others), or lend it. This hadith has been narrated on the authority of A'mash with the same chain of transmitters, but with a slight change of words.

Book 10, Number 3727:

    Jabir (Allah be pleased with him) reported Allah's Messenger (may peace be upon him) forbidding the selling (renting of) uncultivated land for two years or three.

Book 10, Number 3728:

    Jabir (Allah be pleased with him) reported Allah's Apostle (may peace be upon him) forbidding selling of (produce) in advance for two years, and in the narmtion of Ibu Abd Shaiba (the words are) : "Selling of the fruits (on the tree) in advance for two years."

Book 10, Number 3729:

    Abu Huraira (Allah be pleased with him) reported Allah's Messenger (may peace be upon him) as saying: He who has land should cultivate it or lend it to his brother, but if he refuses, he should retain his land.

Book 10, Number 3730:

    Jabir b. Abdullah (Allah be pleased with them) reported: I heard Allah's Messenger (may peace be upon him) forbidding Muzabana, and Huqul. Jabir b. Abdullah (Allah be pleased with them) said: Muzabana means the selling of fruits for dry dates and Huqul is the renting of land.

Book 10, Number 3731:

    Abu Huraira (Allah be pleased with him) reported Allah's Messenger (may peace be upon him) forbidding Muhaqala and Muzabana.

Book 10, Number 3732:

    Abu Sa'id al-Khudri (Allah be pleased with him) reported Allah's Messenger (may peace be upon him) having forbidden Mazabana and Muhaqala. Muzibana means the buying of fruits on the trees and Muhaqala is the renting of land.

Book 10, Number 3733:

    Zaid b. Amr reported: I heard Ibn Umar (Allah be pleased with them) say: We did not see any harm in renting of the land, but as the first year was over Rafi' alleged Allah's Apostle (may peace be upon him) having forbidden that.

Book 10, Number 3734:

    This hadith has been narrated on the authority of Amr b. Dinar with the same chain of transmitters but (in) the hadith transmitted on the authority of 'Uyainah (the words are) : "We abandoned it (renting) on account of that."

Book 10, Number 3735:

    Ibn 'Umar (Allah be pleased with them) reported: Rafi forbade us from benefitting from our land (in the form of rent).

Book 10, Number 3736:

    Nafi reported that Ibn Umar (Allah be pleased with them) rented his land during the lifetime of Allah's Messenger (may peace be upon him) and during the caliphate of Abu Bakr and that of Umar and that of Uthman (Allah be pleased with them) and during the early period of Muawiya's caliphate until at the end of Muawiya's reign, it reached him (Ibn 'Umar) that Rafi b. Khadij (Allah be pleased with him) narratted (a hadith) in which (there was a decree) of prohibition by Allah's Apostle (may peace be upon him). He (Ibn'Umar) went to him (Rafi b. Khadij) and I was with him and he asked him, whereupon he said: Allah's Messenger (may peace be upon him) used to forbid the renting of land. So Ibn Umar (Allah be pleased with them) abandoned it, and subsequently whenever he was asked about it, he said: Rafi b. Khadij (Allah be pleased with him) alleged that Allah's Messenger (may peace be upon him) forbade it.

Book 10, Number 3737:

    This hadith has been narrated on the authority of Ayyub and he made an addition in the hadith narrated by Ibn Ulayya in which he said: Ibn Umar abandoned it afterwards and he did not rent it (the land).

Book 10, Number 3738:

    Nafi reported: I went to Rafi b. Khadij in the company of Ibn 'Umar (All be pleased with them) until he (Ibn 'Umar) came to him at Balat (a place near Prophet's Mosque at Medina) and he (Rafi b. Khadij) informed him that Allah's Messenger (may peace be upon him) had forbidden the renting of land.

Book 10, Number 3739:

    Nafi, reported from Ibn Umar (Allah be pleated with them) that he came to Rafi and he narrated this hadith from Allah's Apostle (way peace be upon him).

Book 10, Number 3740:

    Nafi, reported that Ibn Umar (Allah be pleased with them) used to rent the land, and that he was conveyed the hadith transmitted on the authority of Rafi b. Khadij. He (the narrator) said: He then went to him along with me. He (Rafi) narrated from some of his uncles in which it was mentioned that Allah's Apostle (may peace be upon him) forbade the renting of land. Ibn 'Umar (Allah be pleased with them) then abandoned this practice of renting. This hadith has been narrated through another chain of transmitters.

Book 10, Number 3741:

    Salim b. Abdullah reported that AbduUah b. Umar (Allah be pleased with them) used to give land on rent until (this news) reached him that Rafi b. Khadij Ansari used to forbid the renting of land. Abdullah met him and said: Ibn Khadij, what is this that you narrate from Allah's Messenger (may peace be upon him) pertaining to renting of land? Rafi b. Khadij said to Abdullah: I heard it from two uncles of mine and they had participated in the Battle of Badr who narrated to the members of the family that Allah's Messenger (may peace be upon him) forbade the renting of land. Abdullah said: I knew it that the land was rented during the lifetime of Allah's Messenger (may peace be upon him). Abdullah then apprehended that Allah's Messenger (may peace be upon him) might have said something new in this connection (in regard to prohibition of renting) which I failed to know. So he abandoned the renting of land.

Book 10, Number 3742:

    Rafi b. Khadij (Allah be pleased with him) reported: We used to give on rent land during the lifetime of Allah's Messenger (may peace be upon him). We rented it on the share of one-third or one-fourth of the (produce) along with a definite quantity of corn. One day a person from among my uncles came to us and said: Allah's Messenger (may peace be upon him) forbade us this act which was a source of benefit to us, but the obedience to Allah and to His Messenger (may peace be upon him) is more beneficial to us. He forbade us that we should rent land with one-third or one-fourth of (the produce) and the corn of a measure, and he commanded the owner of land that he should cultivate it or let it be cultivated by other (persons) but he showed disapproval of renting it or anything besides it.

Book 10, Number 3743:

    Rafi b. Khadij (Allah be pleased with him) reported: We used to give land on rent, and we rented it on one-third or one-fourth share. The rest of the hadith is the same.

Book 10, Number 3744:

    This hadith has been narrated on the authority of Rafi' b. Khadij with the same chain of transmitters, but in it no mention is made of some of his uncles.

Book 10, Number 3745:

    Rafi (Allah be pleased with him) reported that Zuhair b. Rafi (who was his uncle) came to me and said: Allah's Messenger (may peace be upon him) forbade a practice which was useful for us. I said: What is this? (I believe) that whatrver Allah's Messenger (may peace be upon him) says is absolutely true. He (Zuhair) said that he (the Holy Prophet) asked me: What do you do with your cultivable lands? I said: Allah's Messenger, we rent those irrigated by canals for dry dates or barley. He said: Don't do that. Cultivate them or let them be cultivated (by others) or retain them yourself.

Book 10, Number 3746:

    This hadith has been transmitted on the authority of Rafi from the Prophet (may peace be upon him) about this, but he did not make mention of his uncle Zuhair.

Book 10, Number 3747:

    Hanzala b. Qais reported that he asked Rafi b. Khadij (Allah be pleased with him) about renting of land, whereupon he said: Allah's Messenger (may peace be upon him) forbade the renting of land. I said: Is it forbidden (even if it is paid) in gold (dinar) and silver (dirham)? Thereupon he said: If it is paid in gold and silver, there is no harm in it.

Book 10, Number 3748:

    Hanzala b. Qais al-Ansri reported: I asked Rafi' b. Khadij about the renting of land for gold and silver, whereupon he said: There is no harm in it for the people let out land situated near canals and at the ends of the streamlets or portion of fields. (But it so happened) that at times this was destroyed and that was saved. whereas (on other occasions) this portion was saved and the other was destroyed and thus no rent was payable to the people (who let out lands) but for this one (which was saved). It was due to this that he (the Holy Prophet) prohibited it. But if there is something definite and reliable (e.g. money). there is no harm in it.

Book 10, Number 3749:

    Hanzala reported that he heard Rafi' b. Khadij (Allah be pleased with him) say: We were the major agriculturists of the Ansar and so we let out land (saying): The produce of this (part of land) would be ours and (the produce) of that would be theirs. But it so happened that at times this (land) gave harvest, but the other one produced nothing. So he (the Holy Prophet) forbade this. But so far as the payment in silver (dirham, a coin) is concerned, he did not forbid.

Book 10, Number 3750:

    This hadith has been narrated on the authority of Yahya b. Sa'id with the same chain of transmitters.

Book 10, Number 3751:

    Abdullah b. al Sa'ib reported: I asked Abdullah b. Ma'qil about Muzara'a (cultivating land on share basis in the produce). He said: Thabit b. Dahhak informed me that Allah's Messenger (may peace be upon him) forbade Muzara'a as Ibn Abu Shaiba forbade it with a slight change of words. He (the narrator) said: I asked Ibn Ma'qil but he did not name 'Abdullah.

Book 10, Number 3752:

    Abdullah b. al-Sa'ib reported: We visited 'Abdullah b. Ma'qil and asked him about sharing of crops, whereupon he said: Thabit alleged that Allah's Messenger (may peace be upon him) forbade Muzara'a and commanded leasing it out on rent (for money) and said: There is no harm in it.

Book 10, Number 3753:

    Mujahid said to Tiwus: Come along with me to Ibn Rafi b. Khadij in order to listen from him the hadith transmitted on the authority of his father (pertaining to the renting of land) from Allah's Apostle (may peace be upon him). He (Tawus) scolded him and said: By Allah, it I were to know that Allah's Messenger (may peace be upon him) had forbidden it, I would have never done it. But it has been narrated to me by one who has better knowledge of it amongst them (and he meant Ibn 'Abbas) that Allah's Messenger (may peace be upon him) said: It is better if a person lends, his land to his brother (for cultivation) than that he gets recognised rent on it.

Book 10, Number 3754:

    Tawus reported that he let out his land on rent, whereupon Amr said: I said to him: Abu Abd al-Rahrman, I wish if you abandon this renting of land, for they alleged that Allah's Apostle (may peace be upon him) forbade Mukhabara. He siad: Amr, one who has informed me has the best knowledge of it among them (he meant Ibn Abbas). (He said) that Allah's Apostle (may peace be upon him) did not prohibit it altogether, but said: Lending of land by one among you to his brother is better for him than getting a specified amount of produce from it.

Book 10, Number 3755:

    A hadith like this has been transmitted on the authority of Ibn Abbas (Allah be pleased with them).

Book 10, Number 3756:

    Ibn Abbas (Allah be pleased with them) reported Allah's Apostle (may peace be upon him) as saying: If one among you lets out land to his brother, that is better for him than if he receives such and such (the definite thing). Ibn 'Abbis (Allah be pleased with them) said: It is Haql, and in the parlance of the Ansr it is Muhaqala.

Book 10, Number 3757:

    Ibn Abbas (Allah be pleased with them) reported Allah's Apostle (may peace be upon him) as saying: He who has land, it is better for him that he should let it out to his brother.

Chapter 19 : SHARING OF FRUITS

Book 10, Number 3758:

    Ibn Umar (Allah be pleased with them) reported that Allah's Messenger (may peace be upon him) contracted with the people of Khaibar the (trees) on the condition that he would have half the produce in fruits and harvest.

Book 10, Number 3759:

    Ibn Umar (Allah be pleased with them) reported: Allah's Messenger (may peace be upon him) handed over the land of Khaibar (on the condition) of the share of produce of fruits and harvest, and he also gave to his wives every year one hundred wasqs: eighty wasqs of dates and twenty wasqs of barley. When 'Umar became the caliph he distributed the (lands and trees) of Khaibar, and gave option to the wives of Allah's Apostle (may peace be upon him) to earmark for themselves the land and water or stick to the wasqs (that they got) every year. They differed in this matter. Some of them opted for land and water, and some of them opted for wasqs every year. 'A'isha and Hafsa were among those who opted for land and water.

Book 10, Number 3760:

    Abdullah b. Umar (Allah be pleased with them) reported that Allah's Messenger (may peace be upon him) contracted with the people of Khaibar (land and trees on the condition that they should give) half of the yield from land and trees. The rest of the hadith is the same. In the hadith transmitted on the authority of AIi b. Mushir there is no mention of it, but that A'isha and Hafsa were those who opted for land and water, but he (the narrator) said: He (Hadrat 'Umar, gave option to the wives of Allah's Apostle (may peace be upon him) that land would be earmarked for them, but he made no mention of water.

Book 10, Number 3761:

    'Abdullah b. Umar (Allah be pleased with them) reported that when Khaibar had been conquered, the Jews asked Allah's Messenger (may peace be upon him) to let them continue (cultivation in those lands) on half of the share of yield in fruits and crop, whereupon Allah's Messenger (may peace be upon him) said: I will allow you to continue here, so long as we would desire. The rest of the hadith is the same, but with this addition: "The fruit would be distributed equal to the half of Khaibar. And out of hall of the produce of the land, Allah's Apostle (may peace be be upon him) got the fifth part."

Book 10, Number 3762:

    Abdullah b. Umar (Allah be pleased with them) reported that Allah's Messenger (may peace be upon him) returned to the Jews of Khaibar the date-palms of Khaibar and its land on the condition that they should work upon them with their own wealth (seeds, implements), and give half of the yield to Allah's Messenger (may peace be upon him).

Book 10, Number 3763:

    Ibn Umar reported that 'Umar b. al-Khattab (Allah be pleased with him) expelled the Jews and Christians from the land of Hijaz, and that when Allah's Messenger (may peace be upon him) conquered Khaibar he made up his mind to expel the Jews from it (the territory of Khaibar) because, when that land was conquered, it came under the sway of Allah, that of His Messenger (may peace be upon him) and that of the Muslims. The jews asked Allah's Messenger (may peace be upon him) to let them continue there on the condition that they would work on it, and would get in turn half of the fruit (of the trees), whereupon Allah's Messenger (may peace be upon him) said : We would let you continue there so long as we will desire. So they continued (to cultivate the lands) till 'Umar externed them to Taima' ang Ariha (two villages in Arabia, but out of Hijaz).

Chapter 20 : EXCELLENCE OF PLANTING OF TRESS AND TILLING OF LAND

Book 10, Number 3764:

    Jabir (Allah be pleased with him) reported Allah's Messenger (may peace be upon him) as saying: Never a Muslim plants a tree, but he has the reward of charity for him, for what is eaten out of that is charity; what is stolen out of that, what the beasts eat out of that, what the birds eat out of that is charity for him. (In short) none incurs a los!k to him but it becomes a charity on his part.

Book 10, Number 3765:

    Jabir (Allah be pleased with him) reported that Allah's Apostle (may peace be upon him) visited Umm Mubashshir al-Ansariya at her orchard of date-palms and said to her: Who has planted these trees of dates-a Muslim or a non-Musim ? She said : A Muslim, of course, whereupon he said: Never a Muslim plants, or cultivates a land, and it out of that men eat, or the animals eat, or anything else eats, but that becomes charity on his (planter's) behalf.

Book 10, Number 3766:

    Jabir b. 'Abdullah (Allah be pleased with them) reported: I heard Allah's Messenger (may peace be upon him) saying: Never does a Muslim plant, or cultivate, but has reward for him for what the beasts eat, or the birds eat or anything else eats out of that.

Book 10, Number 3767:

    Jabir b. Abdullah (Allah be pleased with them) reported: Allah's Apostle (may peace be upon him) visited the orchard of Umm Ma'sud and said: Umm Ma'bad. he who has planted this tree, is he a Muslim or a non-Muslim? She said: Of course, he is a Muslim, whereupon he (the Holy Prophet) said: No Muslim who plants (trees) and from their fruits the human beings or the beasts or birds eat, but that would be taken as an act of charity on the Day of Resurrection.

Book 10, Number 3768:

    This hadith is transmitted on the authority of Abu Muawiya (but With a slight change of words).

Book 10, Number 3769:

    Anas reported Allah's Messenger (may peace be upon him) as saying Never does a Muslim plant trees or cultivate land and birds or a man or a beast eat out of them but that is a charity on his behalf.

Book 10, Number 3770:

    Anas b. Malik (Allah be pleased with him) reported that Allah's Apostle (may peace be upon him) visited the date-palms of Umm Mubashshir (Allah be pleased with her), a lady from the Ansar, and said: Who planted this palm-a Muslim or an unbelievers The rest of the hadith is the same.

Chapter 21 : REMISSION IN THE PAYMENT OF YIELD STRICKEN BY CALAMITY

Book 10, Number 3771:

    Jabir b. Abdullah (Allah be pleased with them) reported Allah's Messenger (may peace be upon him) saying: If You sell fruits to your brother (and Jabir b. Ahduthh reported through another chain of narrators: If you were to sell fruits to your brother) and these is a stricken with Calamity, it is not permissible for you to get anything from him. Why do you get the wealth of your brother, without jutification?

Book 10, Number 3772:

    A hadith like this has been narrated on the authority of Juraij with the same chain of transmitters.

Book 10, Number 3773:

    Anas (Allah be pleased with him) reported that Allah's Apostle (may peace be upon him) forbade the sale of the fruit of date-palms until it becomes mellow. We (some of the other narrators in the chain of transmitters) said: What does the word "mellow" mean? He said: (There the fruit) turns red or yellow. Don't you see if Allah had checked (the growth of) fruits; then what for the wealth of your brother would be permissible for you?

Book 10, Number 3774:

    Anas b. Malik (Allah be pleased with him) reported that Allah's Messenger (may peace be upon him) forbade the sale of fruits until these are mellow. They (the companions of Anas) said: What is meant by "mellow"? He said: It implies that these became red. He said: When Allah hinders the growth of fruits, (then) what for the wealth of your brother would become permissible for you?

Book 10, Number 3775:

    Anas (Allah be pleased with him) reported Allah's Apostle (may peace be upon him) as saying: If Allah does not fructify them, then what is permissible for one of you to take the wealth of his brother?

Book 10, Number 3776:

    Jabir (Allah be pleased with him) reported that Allah's Apostle (may peace be upon him) commanded to make deductions in the payment of that stricken with a Calamity.

Chapter 22 : EXCELLENCE OF MAKING REDUCTION IN THE DEBT

Book 10, Number 3777:

    Abu Sa'id al-Khudri (Allah be pleeased with him) reported that in the time of Allah's Messenger (may peace be upon him) a man suffered loss in fruits he had bought and his debt increased; so Allah's Messenger (may peace be upon him) told (the people) to give him charity and they gave him charity, but that was not enough to pay the debt in full, whereupon Allah's Messenger (may peace be upon him) said to his creditors: "Take what you find, you will have nothing but alms.

Book 10, Number 3778:

    This hadith has been narrated on the authority of Bukair b. al-Ashajj with the same chain of transmitters.

Book 10, Number 3779:

    A'isha (Allah be pleased with her) reported: Allah's Messenger (may peace be upon him) heard the voices of altercation of two disputants at the door; both the voices were quite loud. The one demanded some remission and desired that the other one should show leniency to him, whereupon the (other one) was saying: By Allah will not do that. Then there came Allah's Messenger (may peace be upon him) to them and said: Where is he who swears by Allah that he would not do good? He said: Massenger of Allah, it is I. He may do as he desires.

Book 10, Number 3780:

    Abdullah b. Ka'ab b. Malik reported from his father that he pressed in the mosque Ibn Abu Hadrad for the payment of the debt that he owed to him during the lifetime of Allah's Messenger (may peace be upon him). (In this altercation) their voices became loud, until Allah's Messenger (may peace be upon him) heard them, while he was in the house, so Allah's Messenger (may peace be upon him) came out towards them, and he lifted the curtain of his apartment and he called upon Ka'b b. Malik and said: O Ka'b. He said: At thy beck and call, Allah's Messenger. He pointed out with the help of his hand to remit half of the loan due to him. Ka'b said: Allah's Messenger, I am ready to do that, whereupon Allah's Messenger (may peace be upon him) said (to Ibn Abu Hadrad): Stand up and make him the payment (of the rest).

Book 10, Number 3781:

    Ka'b b. Malik reported that he made a demand for the payment of the debt that Ibn Abu Hadrad owed to him. This hadith is narrated through another chain of transmitters and (the words are): "He had to get the loan from Abdullah b. Hadrad al-Aslami. He met him and pressed him for payment. There was an altercation between them, until their voices became loud. There happened to pass by them Allah's Messenger (may peace be upon him) and he said: O Ka'b, and pointed out with his hand in such a way as he meant half. So he got half of what he (Ibn Abu Hadrad) owed to him and remitted the half."

Chapter 23 : IF THE BUYER BECOMES INSOLVENT AND THE SELLER FINDS THE COMMODITY SOLD TO THE BUYER INTACT, HE CAN TAKE IT BACK

Book 10, Number 3782:

    Abu Huraira (Allah be pleased with him) reported Allah's Messenger (may peace be upon him) as saying: He who found his property intact with a person (who bought it but who later on) became insolvent (or a person who became insolvent), he (the seller) is entitled to get it more than anyone else.'

Book 10, Number 3783:

    This hadith has been narrated on the authority of Yahya b. Sa'id with the same chain of transmitters (but with a slight variation of words and these are) "Whenever a man becomes poor."

Book 10, Number 3784:

    Abu Huraira (Allah be pleased with him) reported Allah's Apostle (may peace be upon him) saying about a person who becomes insolvent and (the thing bought by him) is found intact with him, that belongs to one who sold it.

Book 10, Number 3785:

    Abu Huraira (Allah be pleased with him) reported Allah's Apostle (may peace be upon him) as saying: When a man becomes insolvent (and the other) man (the seller) finds his commodity intact with him, he is more entitled to get it (than anyone else)

Book 10, Number 3786:

    This hadith has been narrated on the authority of Qatada with the same chain of transmitters (but with a change of these words): "He is more entitled to get it than any other creditor."

Book 10, Number 3787:

    Abu Huraira (Allah be pleased with him) reported Allah's Messenger (may peace be upon him) as saying : When a inan becomes insolvent, and the other person (seller) finds his goods intact with him, he is more entitled to get them than anyone else.

Chapter 24 : MERIT OF GIVING RESPITE TO ONE WHO IS IN STRAITENED CIRCUMSTANCES

Book 10, Number 3788:

    Hudhaifa reported Allah's Messenger (may peace be upon him) as saying The angels took away the soul of a person who had lived among people who were before you. They (the angels) said : Did you do anything good ? He said: No. they said: Try to recall. He said : I used to lend to people and order my servants to give respite to one in straitened circumstances and give allowance to the solvent, for Allah, the Exalted and Majestic, said (to the angels) : You should ignore (his failing).

Book 10, Number 3789:

    Hudhaifa reported: A person met his Lord (after death) and He said: What (good) did you do ? He said: I did no good except this that I was a rich man, and I demanded from the people (the repayment of debt that I advanced to them). I, however, accepted that which the solvent gave and remitted (the debt) of the insolvent, whereupon He (the Lord) said: You should ignore (the faults) of My servant. Abu Mas'ud (Allah be pleased with him) said: This is what I heard Allah's Messenger (may peace be upon him) as saying.

Book 10, Number 3790:

    Hudhaifa (Allah be pleased with him) reported Allah's Apostle (may peace be upon him) as saying: A person died and he entered Paradise. It was said to him What (act) did you do? (Either he recalled it himself or he was made to recall), he said I used to enter into transactions with people and I gave respite to the insolvent and did not show any strictness in case of accepting a coin or demanding cash payment. (For these acts of his) he was granted pardon. Abu Mas'ud said : I heard this from Allah's Messenger (may peace be upon him).

Book 10, Number 3791:

    Hudhaifa (Allah be pleased with him) reported : A servant from amongst the servants of Allah was brought to Him whom Allah had endowed with riches. He (Allah) said to him: What (did you do) in the world ? (They cannot conceal anything from Allah) He (the person) said: O my Lord, You endowed me with Your riches. I used to enter into transactions with people. It was my nature to be lenient to (my debtors). I showed leniency to the solvent and gave respite to the insolvent, whereupon Allah said : I have more right than you to do this to connive at My servant. 'Uqba b. 'Amir al-Juhani and Abu Mas'ud said: This is what we heard from Allah's Messenger (may peace be upon him).

Book 10, Number 3792:

    Abu Mas'ud (Allah be pleased with him) reported Allah's Messenger (may peace be upon him) as saying: A person from people who lived before you was called to account (by Allah at the Day of Judgment) and no good was found in his account except this that lie being a rich man had (financial) dealings with people and had commanded his servants to show leniency to the straitened ones. Upon this Allah, the Exalted and Majestic, said: We have more right to this, so overlook (his faults).

Book 10, Number 3793:

    Abu Huraira (Allah be pleased with him) reported Allah's Messenger (may peace be upon him) as saying : There was a person who gave loans to the people and said to his men: When an insolvent comes to you show him leniency that Allah may overlook our (faults). So when he met Allah, He overlooked his faults (forgave him).

Book 10, Number 3794:

    A hadith like this is narrated on the authority of Abu Huraira (Allah be pleased with him).

Book 10, Number 3795:

    Abdullah b. Abu Qatida reported that Abu Qatada (Allah be pleased with him) demanded (the payment of his debt) from his debtor but he disappeared; later on he found him and he said: I am hard up financially, whereupon he said: (Do you state it) by God? He said: By God. Upon this he (Qatada) said: I heard Allah's Messenger (may peace be upon him) as saying : He who loves that Allah saves him from the torments of the Day of Resurrection should give respite to the insolvent or remit (his debt) This hadith has been narrated on the authority of Ayyob with the same chain of transmitters.

Chapter 25 : IT IS FORBIDDEN FOR A SOLVENT TO MAKE DELAY IN THE PAYMENT OF DEBT, AND THE DESIRABILITY OF A REFERENCE, AND IT IS EXCELLENT FOR THE RICH MAN TO ACCEPT THAT WHEN REFERENCE IS MADE TO HIM

Book 10, Number 3796:

    Abu Huraira (Allah be pleased with him) reported Allah's Messenger (may peace be upon him) as saying: Delay (in the payment of debt) on the part of a rich man is injustice, and when one of you is retired to a rich man, he should follow him.

Book 10, Number 3797:

    A hadith like this has been transmitted on the authority of Abu Huraira (Allah be pleased with him).

Chapter 26 : PROHIBITION OF THE SALE OF EXCESS WATER IN THE BARREN LANDS, AND PREVENTING PEOPLE TO USE IT, AND HIRING A CAMEL TO COVER A SHE-CAMEL

Book 10, Number 3798:

    Jabir b. 'Abdullah (,Allah be pleased with him) reported that Allah's Messenger (may peace be upon him) forbade the sale of excess water.

Book 10, Number 3799:

    Jabir b. 'Abdullah (Allah be pleased with him) reported that Allah's Messenger (may peace be upon him) forbade the hiring of a Camel to cover a she-Camel and from selling water and land to be tilled. So from all this the Messenger of Allah (may peace be upon him) forbade.

Book 10, Number 3800:

    Abu Huraira (Allah be pleased with him) reported Allah's Messenger (may peace be upon him) as saying: Excess water must not be withheld so that the growth of herbage may be hindered.

Book 10, Number 3801:

    Abu Huraira (Allah be pleased with him) reported Allah's Messenger (may peace be upon him) as saying: Do not withhold excess of water, so that you may prevent the growth of herbage.

Book 10, Number 3802:

    Abu Huraira (Allah be pleased with him) reported Allah's Messenger (may peace be upon him) as saying: The excess of water should not be sold in order to enable the sate of herbage.

Chapter 27 : THE PRICE OF A DOG, THE SWEETS OF A KAHIN, THE EARNINGS OF A PROSTITUTE AND THE SELLING OF A CAT ALL FORBIDDEN

Book 10, Number 3803:

    Aba Mas'ud al-Ansari (Allah be pleased with him) reported that Allah's Messenger (may peace be upon him) forbade the charging of price of the dog, and earnings of a prostitute and sweets offered to a kahin.

Book 10, Number 3804:

    A hadith like this is reported on the authority of Abu Mas'ud through another chain of transmitters.

Book 10, Number 3805:

    Rafi b. Khadij (Allah be pleased with him) reported: I heard Allah's Apostle (may peace be upon him) as saying: The worst earning is the earning of a prostitute, the price of a dog and the earning of a cupper.

Book 10, Number 3806:

    Rafi b. Khadij reported Allah'& Messenger (may peace be upon him) as saying: The price of a dog is evil, the earning of a prostitute is evil and the earning of a cupper is evil.

Book 10, Number 3807:

    A hadith like this has been narrated on the authority of Rifi' b. Khadlj through another chain of transmitters.

Book 10, Number 3808:

    Abu Zubair said: I asked Jabir about the price of a dog and a cat; he said: Allah's Messenger (may peace be upon him) disapproved of that.

Chapter 28 : COMMAND OF KILLING DOGS AND THEN ITS ABROGATION, AND PROHIBITION OF KEEPING THEM BUT FOR HUNTING AND PROTECTION OF LANDS OR CATTLE OR LIKE THAT

Book 10, Number 3809:

    Ibn 'Umar (Allah be pleased with them) reported Allah's Messenger (may peace be upon him) giving command for killing dogs.

Book 10, Number 3810:

    Ibn 'Umar (Allah be pleased with them) reported: Allah's Messenger (may peace be upon him) ordered to kill dogs, and he sent (men) to the corners of Medina that they should be killed.

Book 10, Number 3811:

    Abdullah (b. Umar) (Allah be pleased with them) reported: Allah's Messenger (may peace be upon him) ordered the killing of dogs and we would send (men) in Medina and its corners and we did not spare any dog that we did not kill, so much so that we killed the dog that accompanied the wet she-camel belonging to the people of the desert.

Book 10, Number 3812:

    Ibn Umar (Allah be pleased with them) reported that Allah's Messenger (may peace be, upon him) ordered the killing of dogs except the dog tamed for hunting, or watching of the herd of sheep or other domestic animals. It was said to Ibn Umar (Allah be pleased with them) that Abu Huraira (Allah be pleased with him) talks of (exception) about the dog for watching the field, whereupon he said: Since Abu Huraira (Allah be pleased with him) possessed land.

Book 10, Number 3813:

    Abu Zubair heard Jabir b. 'Abdullah (Allah be pleased with him) saying: Allah's Messenger (may peace be upon him) ordered us to kill dogs, and we carried out this order so much so that we also kill the dog coming with a woman from the desert. Then Allah's Apostle (may peace be upon him) forbade their killing. He (the Holy Prophet further) said:It is your duty the jet-black (dog) having two spots (on the eyes), for it is a devil.

Book 10, Number 3814:

    Ibn Mughaffal reported: Allah's Messenger (may peace be upon him) ordered the killing of dogs and then said: what is the trouble with them (the people of Medina) ? How dogs are nuisance to them (the citizens of Medina) ? He then permitted keehing of dogs for hunting and (the protection of) herds. In the hadith transmitted on the authority of Yahya, he (the Holy Prophet) permitted the keeping of dogs for (the protection of) herds, for hunting and (the protection of) cultivated land.

Book 10, Number 3815:

    Ibn Umar (Allah be pleased with him) reported Allah's Messenger (may peace be upon him) as saying: He who keeps a dog other than that meant for watching the herd or for hunting loses every day out of his deeds equal to two qirat.

Book 10, Number 3816:

    Salim reported on the authority of his father that Allah's Apostle (may peace be upon him) said: He who kept a dog other than one meant for hunting or for watching the herd, lost two qirat of his reward every day.

Book 10, Number 3817:

    Ibn 'Umar reported Allah's Messenger (may peace be upon him) as saying He who kept a dog other than one meant for hunting or for watching the herd lost out of his deeds (equal to) two qirat every day.

Book 10, Number 3818:

    Salim b. 'Abdullah reported on the authority of his father that Allah's Messenger (may peace be upon him) said: He who kept a dog other than one meant for watching the herd or for hunting would lose every day two qirat of his good deeds. 'Abdullah and Abu Huraira also said: Or dog meant for watching the field.

Book 10, Number 3819:

    Salim reported on the authority of his father (Allah be pleased with him) that Allah's Messenger (may peace be upon him) said: He who kept a dog other than one meant for hunting or for the protection of the herd would lose two qirat of his deeds every day. Salim said: Abu Huraira (Allah be pleased with him) used to say: Or the dog meant for watching the field, and he was the owner of the land.

Book 10, Number 3820:

    Salim b. Abdullah reported on the authority of his father that Allah's Messenger (may peace be upon him) said: Whosover amongst the owners of the house keeps a dog other than one meant for watching the herd or for hunting loses two qirat of his deeds every day.

Book 10, Number 3821:

    Ibn Umar (Allah be pleased with them) narrated Allah's Messenger (may peace be upon him) as saying: He who kept a dog ther than one meant for watching the fields or herds or hunting would lose one qirat every day out of his reward (with God).

Book 10, Number 3822:

    Abu Huraira reported Allah's Messenger (may peace be upon him) as saying : He who kept a dog which is neither meant for hunting nor for watching the anitmals nor for watching the fields would lose two qirat every day out of his reward; and there is no mention of the fields in the hadith transmitted by Abu Tahir.

Book 10, Number 3823:

    Abu Huraira (Allah be pleased with him) reported Allah's Messenger (may peace be upon him) as saying: He who kept a dog except one meant for watching the herd, or for hunting or for watching the fields. he lost two qirat of reward every day. Zuhri said: The words of Abu Huraira (Allah be pleased with him) were conveyed to Ibn Umar who said: May Allah have mercy upon Abu Huraira; he owned a field.

Book 10, Number 3824:

    Abu Huraira (Allah be pleased with him) reported Allah's Messenger (may peace be upon him) as saying: He who kept a dog would lose out of his deeds equal to one qirat every day. except (one kept) for watching the field or herd.

Book 10, Number 3825:

    A hadith like this has been transmitted on the authority of Abu Huraira.

Book 10, Number 3826:

    This hadith has been reported on the authority of Yahya b. Abu Kathir with the same chain of transmitters.

Book 10, Number 3827:

    Abu Huraira (Allah be pleased with him) reported Allah's Messenger (may peace be upon him) as saying: He who kept a dog, but not meant for hunting or watching the herd, would lose one qirat of reward every day.

Book 10, Number 3828:

    Sufyan b. Abu Zuhair (he was a person belonging to the tribe of Shanu'a and was amongst the Conpanions of Allah's Messenger [may peace be upon him ) said: I heard Messenger of Allah (may peace be upon him) as saying: He who kept a dog (other than that) which is indispensable for watching the field or the animals would lose one qirat out of his deeds every day. As-Sa'ib b Yazid (one of the narrators) said: Did you hear it from Allah's Messenger (may peace be upon him)? He said: Yes. by the Lord of this mosque.

Book 10, Number 3829:

    This hadith has been narrated on the authority of Sufyan b. Abu Zuhair al-Shana'i.

Chapter 29 : IT IS PERMISSIBLE TO GET THE WAGES OF CUPPING

Book 10, Number 3830:

    It is narrated on the authority of Humaid that Anas b. Malik was asked about the earnings of the cupper. He said: Allah's Messenger (may peace be upon him) got himself cupped. His cupper was Abu Taiba and he (the Holy Prophet) commanded to give him two sa's of corn. He (the Holy Prophet) talked with the members of his family and they lightened the burden of Kharaj (tax) from him (i.e. they made remis- sion in the charges of their own accord). He (Allah's Apostle) said: The best (treat- ment) which you take is cupping, or it is the best of your treatments.

Book 10, Number 3831:

    Rumaid reported that Anas b. Malik (Allah be pleased with him) has asked about the earnings of a cupper. Then (the above-mentioned hadith was reported but with this addition) that he said: The best treatment which you get is cupping. or aloeswood and do not torture your children by pressing their uvula.

Book 10, Number 3832:

    Humaid reported Anas (Allah be pleased with him) having said this: Allah's Apostle (may peace be upon him) called for young cupper belonging to us. He capped him and he (the Holy Prophet) commanded that he should be paid one sa' or one mudd or two mudds (of wheat). It was said (that charges were high) and a reduction was made in the charges.

Book 10, Number 3833:

    Ibn Abbas (Allah be pleased with them) reported that Allah's Messenger (may peace be upon him) got himself cupped and he paid the clipper his charges and he put medicine in his nostrils.

Book 10, Number 3834:

    Ibn 'Abbas (Allah be pleased with them) reported: The slave of Banu Bayada cupped Allah's Apostle (may peace be upon him) and he gave him his wages, and talked to his master and he reduced the charges, and if this earning was unlawful Allah's Apostle (may peace be upon him) would not have given it.

Chapter 30 : THE SALE QF WINE IS FORBIDDEN

Book 10, Number 3835:

    Abu Sa'id al-Khudri (Allah be pleased with him) reported: I heard Allah's Messenger (may peace be upon him) addressing in Medina. He said: O people, Allah is giving an indication (of the prohibition) of wine. and He is probably soon going to give an order about it. So he who has anything of it with him should sell that, and derive benefit out of it. He (the narrator) said: We waited for some time that Allah's Apostle (may peace be upon him)said: Verily Allah, the Exalted, has forbidden wine. So who hears this verse and he has anything of it with him, he should neither drink it nor sell it. He (the narrator) said: The people then brought whatever they had of it with them on the streets of Medina and spilt that.

Book 10, Number 3836:

    'Abd al-Rahman b. Wa'ala as-Saba'i (who was an Egyptian) asked 'Abdullah b. Abbas; (Allah be pleased with them) about that which is extracted from the grapes, whereupon he said: A person presented to Allah's Messenger (may peace be upon him) a small water-skin of wine. Allab's Messenger (may peace be upon him) said to him: Do you know that Allah has forbidden it? He said: No. He then whisper- ed to another man. Allah's Messenger (may peace be upon him) asked him what he had whispered. He said: I advised him to sell that, whereupon he (the Holy Prophet) said: Verily He Who has forbidden its drinking has forbidden its sale also. He (the narrator) said: He opened the waterskin until what was contained in it was spilt.

Book 10, Number 3837:

    'Abd al-Rahman b. Wa'ala narrated this on the authority of 'Abdullah b. Abbas.

Book 10, Number 3838:

    'A'isha (Allah be pleased with her) reported: When the concluding verses of Sura Baqara were revealed, Allah's Messenger (may peace be upon him) went out and read them out to the people and then forbade them to trade in wine.

Book 10, Number 3839:

    'A'isha (Allah be pleased with her) reported: When the concluding verses of Sura Baqara pertaining to Riba were revealed, Allah's Messenger (may peace be upon him) went out to the mosque and he forbade the trade in wine.

Chapter 18 : PROHIBITION OF THE SALE OF WINE, CARCASS, SWINE AND IDOLS

Book 10 ,Number 3840:

    Jabir b. 'Abdullah (Allah be pleased with them) reported Allah's Messenger (may peace be upon him) as saying in the Year of Victory while he was in Mecca: Verily Allah and His Messenger have forbidden the sale of wine, carcass, swine and idols, It was said: Allah's Messenger, you see that the fat of the carcass is used for coating the boats and varnishing the hides and people use it for lighting purposes, whereupon he said: No, it is forbidden, Then Allah's Messenger (may peace be upon him) said: May Allah the Exalted and Majestic destroy the Jews; when Allah forbade the use of fat of the carcass for them, they melted it, and then sold it and made use of its price (received from it).

Book 10, Number 3841:

    Yazid b. Abu Habib reported: 'Ata' reported to me that he heard Jabir (b. 'Abdullah) saying it that he had heard that from Allah's Messenger (may peace be upon him) in the Year of Victory.

Book 10, Number 3842:

    Ibn Abbas (Allah be pleased with him) reported: This news reached 'Umar that Samura had sold wine, whereupon he said: May Allah destroy Samura; does he not know that Allah's Messenger (may peace be upon him) said: "Let there be the curse of Allah upon the Jews that fat was declared forbidden for them, but they melted it and then sold it" ?

Book 10, Number 3843:

    This hadith has been narrated on the authority of 'Amr b. Dinar with the same chain of transmitters.

Book 10, Number 3844:

    Abu Huraira (Allah be pleased with him) reported Allah's Messenger (may peace be upon him) as saying: May Allah destroy the Jews for Allah forbade the use of fat for them, but they sold it and made use of its price.

Chapter 19 : RIBA (USURY)

Book 10 ,Number 3845:

    Abu Salid al-Khudri reported Allah's Messenger (may peace be upon him) as saying: Do not sell gold for gold, except like for like, and don't increase something of it upon something; and don't sell silver unless like for like, and don't increase some thing of it upon something, and do not sell for ready money something to be given later.

Book 10, Number 3846:

    Nafi' reported that Ibn 'Umar told him that a person of the tribe of Laith said that Abu Sa'id al-Kludri narrated it (the above-mentioned hadith) from tile Messenger of Allah (may peace be upon him) in a narration of Qutaiba. So 'Abduliali and Nafi' went along with him, and in the hadith transmitted by Ibn Rumh (the words are) that Nafi' said: 'Abdullah (b.'Umar) went and I along with the person belonging to Banu Laith entered (the house) of Sa'id al-Khudri, and he ('Abdullah b. Umar) said: I have been informed that you say that Allah's Messenger (may peace be upon him) forbade the sale of silver with silver except in case of like for like, and sale of gold for gold except in case of like for like. Abu Sa'id pointed towards this eyes and his ears with his fingers and said: My eyes saw, and my ears listened to Allah's Messenger (may peace be upon him) saying: Do not sell gold for gold, and do not sell silver for silver except in case of like for like, and do not increase something of it upon something, and do not sell for ready money something, not present, but hand to hand.

Book 10, Number 3847:

    This hadith has been narrated on the authority of Abu Sa'id al-Khudri through another chain of transmitters.

Book 10, Number 3848:

    Abu Sa'id al-Khudri (Allah be pleased with him) reported Allah'sMessenger (may peace be upon him) as saying: Do not sell gold for gold and silver for silver weight for weight or of the same quality.

Book 10, Number 3849:

    'Uthman b. 'Affan reported Allah's Messenger (may peace be upon him)as saying: Do not sell a dinar for two dinars and one dirham for two dirhams.

Chapter 20 : CONVERSION OF CURRENCY AND SELLING OF GOLD FOR SILVER ON THE SPOT

Book 10 ,Number 3850:

    Malik b. Aus b. al-Hadathan reported: I came saying who was prepared toexchange dirhams (for my gold), whereupon Talha b. Ubaidullah (Allah be pleased with him) (as he was sitting with 'Umar b. Khattib) said: Show us your gold and then come to us (at a later time). When our servant would come we would give you your silver (dirhams due to you). Thereupon 'Umar b. al-Khattib (Allah be pleased with him) said: Not at all. By Allah, either give him his silver (coins). or return his gold to him, for Allah's Messenger (may peace be upon him) said: Exchange of silver for gold (has an element of) interest in it. except when (it is exchanged) on the spot;and wheat for wheat is an interest unless both are handed over on the spot: barley for barley is interest unless both are handed over on the spot; dates for dates is interest unless both are handed over on the Spot.

Book 10, Number 3851:

    This hadith has been narrated on the authority of Zuhri with the same chain of transmitters.

Book 10, Number 3852:

    Abil Qiliba reported: I was in Syria (having) a circle (of friends). in which was Muslim b. Yasir. There came Abu'l-Ash'ath. He (the narrator) said that they(the friends) called him: Abu'l-Ash'ath, Abu'l-Ash'ath, and he sat down. I said to him: Narrate to our brother the hadith of Ubada b. Samit. He said: Yes. We went out on an expedition, Mu'awiya being the leader of the people, and we gained a lot of spoils of war. And there was one silver utensil in what we took as spoils. Mu'awiya ordered a person to sell it for payment to the people (soldiers). The people made haste in getting that. The news of (this state of affairs) reached 'Ubada b. Samit, and he stood up and said: I heard Allah's Messenger (may peace be upon him) forbidding the sale of gold by gold, and silver by silver, and wheat by wheat, and barley by barley, and dates by dates, and salt by salt, except like for like and equal for equal. So he who made an addition or who accepted an addition (committed the sin of taking)interest. So the people returned what they had got. This reached Mu'awiya. and he stood up to deliver an address. He said: What is the matter with people that they narrate from the Messenger (may peace be upon him) such tradition which we did not hear though we saw him (the Holy Prophet) and lived in his company? Thereupon, Ubida b. Samit stood up and repeated that narration, and then said: We will definitely narrate what we heard from Allah's Messenger (may peace be upon him)though it may be unpleasant to Mu'awiya (or he said: Even if it is against his will). I do not mind if I do not remain in his troop in the dark night. Hammad said this or something like this.

Book 10, Number 3853:

    Ubida b. al-Simit (Allah be pleased with him) reported Allah's Messenger(may peace be upon him) as saying: Gold is to be paid for by gold, silver by silver,wheat by wheat, barley by barley, dates by dates, and salt by salt, like for like and equal for equal, payment being made hand to hand. If these classes differ, then sell as you wish if payment is made hand to hand.

Book 10, Number 3854:

    Abu Sa'id al-Khudri (Allah be pleased with him) reported Allah's Messenger(may peace be upon him) as saying: Gold is to be paid for by gold, silver by silver,wheat by wheat, barley by barley, dates by dates, salt by salt, like by like, payment being made hand to hand. He who made an addition to it, or asked for an addition, in fact dealt in usury. The receiver and the giver are equally guilty.

Book 10, Number 3855:

    This hadith has been narrated on the authority of Abu Sa'id al-Khudri(Allah be pleased with him) through another chain of transmitters.

Book 10, Number 3856:

    Abu Huraira (Allah be pleased with him) reported Allah's Messenger(may peace be upon him) as saying: Dates are to be paid for by dates, wheat by wheat,barley by barley, salt by salt, like for like, payment being made on the spot. He who made an addition or demanded an addition, in fact, dealt in usury except in case where their classes differ. This hadith has been narrated on the authority of Fudail b.Ghazwan with the same chain of transmitters, but he made no mention of (payment being) made on the spot.

Book 10, Number 3857:

    Abu Huraira (Allah be pleased with him) reported Allah's Mess-.,nger (may peace be upon him) as saying: Gold is to be paid for by gold with equal weight, like for like, and silver is to be paid for by silver with equal weight, like for like. He who made an addition to it or demanded an addition dealt in usury.

Book 10, Number 3858:

    Abu Huraira (Allah be pleased with him) reported Allah's Messenger (may peace be upon him) as saying: Let dinar be exchanged for dinar, with no addition on either side and dirham be exchanged for dirham with no addition on either side. This hadith has been narrated on the authority of Musa b. Abu Tamim with the same chain of transmitters.

Chapter 21 : THE SALE OF SILVER FOR GOLD IS PROHIBITED WHEN PAYMENT IS TO BE MADE IN FUTURE

Book 10 ,Number 3859:

    Abu Minhal reported: My partner sold silver to be paid in the (Hajj)season or (in the days of) Hajj. He (my partner) came to me and informed me, and I said to him: Such transaction is not desirable. He said: I sold it in the market (on loan) but nobody objected to this. I went to al-Bara' b. 'Azib and asked him, and he said: Allah's Apostle (may peace be upon him) came to Medina and we made such transaction, whereupon he said: In case the payment is made on the spot, there is no harm in it, and in case (it is 'sold) on loan, it is usury. You better go to Zaid b.Arqam, for he is a greater trader than I; so I went to him and asked him, and he said like it.

Book 10, Number 3860:

    Habib reported that he heard Abu Minhal as saying: I asked al-Bara' b.Azib about the exchange of (gold for silver or vice versa), whereupon he said: you better ask Zaid b. Arqam for he knows more than I. So I asked Zaid but he said: You better ask al-Bara' for he knows more than I. Then both of them said: Allah's Messenger(may peace be upon him) forbade the sale of silver for gold when payment is to be made in future.

Book 10, Number 3861:

    Abd al-Rabman b. Abia Bakra reported on the authority of his father that Allah's Messenger (may peace be upon him) forbade the sale of gold for gold, and silver for silver except equal for equal, and commanded us to buy silver for gold as we desired and buy gold for silver as we desired. A person asked him (about the nature of payment), whereupon he said: It is to be made on the spot. This is what I heard(from Allah's Messenger (may peace be upon him ).

Book 10, Number 3862:

    Abd al-Rabman b. Abu Bakra said: Allah's Messenger (may peace be upon him) prohibited us. The rest of the hadith is the same.

Chapter 22 : THE SALE OF GOLD NECKLACE STUDDED WITH PEARLS

Book 10 ,Number 3863:

    Fadala b. Ubaid al-Ansari reported: A necklace having gold and gems in it was brought to Allah's Messenger (may peace be upon him) in Khaibar and it was one of the spoils of war and was put to sale. Allah's Messenger (may peace be upon him) said: The gold used in it should be separated, and then Allah's Messenger (may peace be upon him) further said : (Sell) gold for gold with equal weight.

Book 10, Number 3864:

    Fadila b. 'Ubaid (Allah be pleased with him) reported: I bought on the day (of the Victory of Khaibar) a necklace for twelve dinars (gold coins).It was made of gold studded with gems. I separated (gold from gems) in it,and found (gold) of more (worth) than twelve dinars. I made a mention of it to Allah's Apostle (may peace be upon him), whereupon he said: It should not be sold unless it is separated.

Book 10, Number 3865:

    A hadith like this is narrated on the authority of Sa'id b. Yazid with the same chain of transmitters.

Book 10, Number 3866:

    Fadala b. 'Ubaid reported: We were in the company of Allah's Messenger ( may peace be upon him) on the day (of the Victory of) Khaibar, and made transaction with the Jews for the 'uqiya of gold for the dinars or three (gold coins), whereupon Allah's Messenger (may peace be upon him) said: Do not sell gold for gold but for equal weight

Book 10, Number 3867:

    Hanash reported: We were along with Fadala b. Ubaid (Allah be pleased with him)in an expedition. There fell to my and my friend's lot a necklace made of gold, silver and jewels. I decided to buy that. I asked Fadala b. 'Ubaid, whereupon he said: Separate its gold and place it in one pan (of the balance) and place your gold in the other pan, and do not receive but equal for equal, for I heard Allah's Messenger(may peace be upon him) as saying: He who believes in Allah and the Hereafter should not take but equal for equal.

Chapter 23: SALE OF WHEAT LIKE FOR LIKE

Book 10 ,Number 3868:

    Ma'mar b. Abdullah reported that he sent his slave with a sa' of wheat and said to him: Sell it, and then buy with it barley. The slave went away and he got a sa' (of barley) and a part of sa' over and above that. When he came to Ma'mar he informed him about that, whereupon Ma'mar said to him: Why did you do that? Go back and return that, and do not accept but weight, for weight, for I used to hear from Allah's Apostle (may peace be upon him) as saying: Wheat for wheat and like for like. He (one of the narrators) said: Our food in those days consisted of barley.It was said to him (Ma'mar) that (wheat) is not like that (barley). He replied: I am afraid these may not be similar

Book 10, Number 3869:

    Abu Huraira and Abu Sa'id al-Khudri (Allah be pleased with them) reported that Allah's Messenger (may peace be upon him) deputed a person from Banu 'Adi al-Ansari to collect revenue from Khaibar. He came with a fine quality of dates, whereupon Allah's Messenger (may peace be upon him) said to him: Are all the dates of Khaibar like this? He said: Allah's Messenger, it is not so. We buy one sa' of (fine quality of dates) for two sa's out of total output (including even the inferior quality of dates), whereupon Allah's Messenger (may peace be upon him) said: Don't do that, but like for like, or sell this (the inferior quality and receive the price) and then buy with the price of that, and that would make up the measure.

Book 10, Number 3870:

    Abu Huraira (Allah be pleased with him) reported that Allah's Messenger(may peace be upon him) deputed a person to collect revenue from Khaibar. He brought fine quality of dates, whereupon Allah's Messenger (may peace be upon him) said: Are all the dates of Khaibar like this)? He said: No. We got one sa' (of fine dates) for two sa's (of inferior dates), and (similarly) two sa's for three sa's. Thereupon Allah's Messenger (may peace be upon him) said: Don't do that rather sell the inferior quality of dates for dirhams (money), and then buy the superior quality with the help of dirhams.

Book 10, Number 3871:

    Abd Sa'id reported: Bilal (Allah be pleased with him) came with fine quality of dates. Allah's Messenger (may peace be upon him) said to him: From where (you have brought them)? Bilal said: We had inferior quality of dates and I exchanged two sa's (of inferior quality) with one sa (of fine quality) as food for Allah's Apostle(may peace be upon him), whereupon Allah's Messenger (may peace be upon him) said: Woe! it is in fact usury; therefore, don't do that. But when you intend to buy dates(of superior quality), sell (the inferior quality) in a separate bargain and then buy (the superior quality). And in the hadith transmitted by Ibn Sahl there is no mention of "whereupon".

Book 10, Number 3872:

    Abu Sa'id (Allah be pleased with him) reported: Dates were brought to Allah's Messenger (may peace be upon him), and he said: These dates are not like our dates, whereupon a man said: We sold two sa's of our dates (in order to get) one sa', of these (fine dates), whereupon Allah's Messenger (may peace be upon him) said: That is interest; so return (these dates of fine quality), and get your (inferior dates) ; then sell our dates (for money) and buy for us (with the help of money) such (fine dates).

Book 10, Number 3873:

    Abu Sa'id (Allah be pleased with him) reported: We were given to eat, during the lifetime of Allah's Messenger (may peace be upon him), dates of different qualities mixed together, and we used to sell two sa's of these for one sa, (of fine quality of dates). This reached Allah's Messenger (may peace be upon him), whereupon he said: There should be no exchange of two sa's of (inferior) dates for one sa (of fine dates) and two sa's of (inferior) wheat for one sa' of (fine) wheat. and one dirham for two dirharms.

Book 10, Number 3874:

    Abu Nadra reported: I asked Ibn Abbas (Allah be pleased with them) about the conversion (of gold and silver for silver and gold). We said: Is it hand to hand exchange? I said: Yes. whereupon he said: There is no harm in it. I informed Abu Sa'id about it, telling him that I had asked Ibn 'Abbas about it and he said: Is it hand to hand exchange? I said: Yes, whereupon he said: There is no harm in it. He(the narrator) said, or he said like it: We will soon write to him, and he will not give you this fatwa (religious verdict). He said: By Allah, someone of the boy-servants of Allah's Messenger (may peace be upon him) brought dates, but he refused to accept them (on the plea) that those did not seem to be of the dates of our land. He said: Something had happened to the dates of our land, or our dates. So I got these dates (in exchange by giving) excess (of the dates of our land), whereupon he said: You made an addition for getting the fine dates (in exchange) which tantamounts, to interest; don't do that (in future). Whenever you find some doubt (as regards the deteriorating quality of) your dates, sell them, and then buy the dates that you like.

Book 10, Number 3875:

    Abu Nadra reported: I asked Ibn Umar and Ibn Abbas (Allah be pleased with them) about the conversion of gold with gold but they did not find any harm in that. I was sitting in the company of Abd Sa'id al-Khudri (Allah be pleased with him) and asked him about this exchange, and he said: Whatever is addition is an' interest. I refused to accept it on account of their statement (statement of Ibn 'Abbas and Ibn 'Umar). He said: I am not narrating to you except what I heard from Allah's Messenger(may peace be upon him). There came to him the owner of a date-palm with one sa' of fine dates, and the dates of Allah's Apostle (may peace be upon him) were of that colour.Allah's Apostle (may peace be upon him) said to him: Where did you get these dates? I went with two sa's of (inferior dates) and bought one sa' of (these fine dates), for that is the prevailing price (of inferior dates) in the market and that is the price (of the fine quality of dates in the market), whereupon Allah's Messenger (may peace be upon him) said: Woe be upon you! You have dealt in interest, when you decide to do it (i.e. exchange superior quality of dates for inferior quality); so you should sell your dates for another commodity (or currency) and then with the help of that commodity buy the dates you like. Abu Sa'ad said: When dates are exchanged for dates (with different qualities) there is the possibility (of the element of) interest (creeping into that) or when gold is exchanged for gold having different qualities. I subsequently came to Ibn 'Umar and he forbade me (to do it), but I did not come to Ibn 'Abbas; (Allah be pleased with them). He (the narrator) said: Abu as-Sahba' narrated to me:He asked Ibn Abbas (Allah be pleased with them) in Mecca, and he too disapproved of it.

Book 10, Number 3876:

    Abu Salih reported: I heard Abu Sa'id al-Khudri (Allah be pleased with him) said: Dinar (gold) for gold and dirham for dirham can be (exchanged) with equal for equal; but he who gives more or demands more in fact deals in interest. I sald to him: Ibn 'Abbas (Allah be pleased with them) says otherwise, whereupon he said: I met Ibn 'Abbas (Allah be pleased with them) and said: Do you see what you say ; have you heard it from Allah's Messenger (may peace be upon him), or found it in the Book of Allah, the Glorious and Majestic? He said: I did not hear it from Allah's Messenger (may peace be upon him). and I did not find it in the Book of Allah (Glorious and Majestic), but Usama b. Zaid narrated it to me that Allah's Apostle(may peace be upon him) said: There can be an element of interest in credit.

Book 10, Number 3877:

    Ubaidullah b. Abu Yazid heard Ibn 'Abbas (Allah be pleased with them) as saying: Usama b. Zaid reported Allah's Apostle (may peace be upon him) as saying: There can be an element of interest in credit (when the payment is not equal).

Book 10, Number 3878:

    Ibn 'Abbas; (Allah be pleased with them) reported on the authority of Usama b. Zaid Allah's Messenger (may peace be upon him) as having said this: There is no element of interest when the money or commodity is exchanged hand to hand.

Book 10, Number 3879:

    Ata' b. Abu Rabah reported: Abu Sa'id al-Khudri (Allah be pleased with them) met Ibn 'Abbas (Allah be pleased with them) and said to him: What do you say in regard to the conversion (of commodities or money) did you hear it from Allah's Messenger (may peace be upon him), or is it something which you found In Allah's Book, Majestic and Glorious? Thereupon Ibn Abbas (Allah be pleated with them) said: I don't say that. So far at Allah's Massenger (may peace be upon him) is concerned, you know him better, and to far as the Book of Allah to concerned, I do not know it (more than you do), but 'Usama b. Zaid (Allah be pleased with him) narrated to me Allah's Messenger (may peace be upon him) as having said this: Beware, there can be an element of interest in credit.

Chapter 24 : HE (THE HOLY PROPHET) CURSED THE ONE WHO ACCEPTSINTEREST AND THE ONE WHO PAYS IT

Book 10 ,Number 3880:

    'Abdullah (b. Mas'ud) (Allah be pleased with him) said that Allah's Messenger (may peace be upon him) cursed the one who accepted interest and the one who paid it I asked about the one who recorded it, and two witnesses to it. He(the narrator) said: We narrate what we have heard.

Book 10, Number 3881:

    Jabir said that Allah's Messenger (may peace be upon him) cursed the accepter of interest and its payer, and one who records it, and the two witnesses, and he said: They are all equal.

Chapter 25 :ACCEPTING THAT WHICH IS LAWFUL AND ABANDONING THAT WHICH IS DOUBTFUL

Book 10 ,Number 3882:

    Nu'man b. Bashir (Allah be pleased with him) reported: I heard Allah's Messenger (may peace be upon himn) as having said this (and Nu'man) pointed towards his ears with his fingers): What is lawful is evident and what is unlawful is evident, and in between them are the things doubtful which many people do not know. So he who guards against doubtful things keeps his religion and honour blameless, and he who indulges in doubtful things indulges in fact in unlawful things, just as a shepherd who pastures his animals round a preserve will soon pasture them in it. Beware, every king has a preserve, and the things God his declaced unlawful are His preserves. Beware, in the body there is a piece of flesh ; if it is sound, the whole body is sound and if it is corrupt the whole body is corrupt, and hearken it is the heart.

Book 10, Number 3883:

    This hadith has been narrated on the authority of Zakariya with the same chain of transmitters.

Book 10, Number 3884:

    AI-Nu'man b. Bashir reported it from Allah's Apostle (may peace be upon him). The hadith narrated by Zakariya is, however, more complete and lengthy than the other ones.

Book 10, Number 3885:

    Nu'man b. Bashir b. Sa'd, a Companion of Allah's Messenger (may peace be upon him) was heard delivering a sermon at Hims and was saying: I heard Allah's Messenger (way peace be upon him) as saying: The lawful is evident and the unlawful is evident , the rest of the hadith is the same as related by Zakariya.

Chapter 26: THE SELLING OF THE CAMEL AND STIPULATION OF RIDING ON IT

Book 10 ,Number 3886:

    Jabir b. 'Abdullah (Allah be pleased with them) reported that he was travelling on his camel which had grown jaded, and he decided to let it off. When Allah's Apostle (may peace be upon him) met him and prayed for him and struck it, so it trotted as it had never trotted before. He said: Sell it to me for an 'uqaya. I said: No. He again said: Sell it to me. So I sold it to him for an 'uqaya, but made the stipulation that I should be allowed to ride back to my family. Then when I came to (my place) I took the camel to him and he paid me its price in ready money. I then went back and he sent :(someone) behind me (and as I came) he said: Do you see that I asked you to reduce price for buying your camel. Take your camel and your coins; these are yours.

Book 10, Number 3887:

    This hadith has been narrated on the authority of Jabir through another chain of transmitters.

Book 10, Number 3888:

    Jabir b. 'Abdullah (Allah be pleased with them) reported: I went on an expedition with Allah's Messenger (may peace be upon him). He overtook me and I was on a water-carrying camel who had grown tired and did not walk (trot). He (the Holy Prophet) said to me: What is the matter with your camel ? I said: It is sick. He (the Holy Prophet) stepped behind and drove it and prayed for it, and then it always moved ahead of other camels. He (then) said: How do you find your camel? I said: It is, by the grace of your prayer, all right. He said: Would you sell this (camel) to me? I felt shy (to say him, "No") as we had no other camel for carrying water, but (later on) I said: Yes, and to I sold it to him on the condition that (I would be permitted) to ride it until I reached Madina. I said to him: Allah's Messenger,I am newly married, so I asked his permission (to go ahead of the caravan). He permitted me, and I reached Medina well in advance of other people, until I reached my destination. There my maternal uncle met me and asked me about the camel, and I told him what I had done with regard to it. He reproved me in this connection. He (Jabir) said: When I asked his permission (to go ahead of the caravan) Allah's Messenger (may peace be upon him) inquired of me whether I had married a virgin or a non-virgin. I said to him: I have married a non-virgin. He said: Why did you not marry a virgin who would have played with you and you would have played with her? I said to him: Allah's Messenger, my father died (or he fell as a martyr), and I have small sisters to (look after), so I did not like the idea that I should marry a woman who is like them and thus be not able to teach them manners and look after them properly. So I have married a non-virgin so that she should be able to look after them and teach them manners, When Allah's Messenger (may peace be upon him) came to Medina, I went to him in the morning with the camel. He paid me its price and returned that (the camel) to me.

Book 10, Number 3889:

    Jabir reported: We went from Mecca to Medina with Allah's Messenger(may peace be upon him) when my camel fell ill, and the rest of the hadith is the same. (But it in also narrated in it:) He (the Holy Prophet) said to me: Sell your camel to me. I said: No, but it is yours. He said: No. (it can't be), but sell it to me.I said: No, but, Allah's Messenger, it is yours. He said: No, it can't be, but sell it to me. I said: Then give me an 'uqaya of gold for I owe that to a person and then it would be yours. He (the Holy Prophet) said: I take it (for an 'uqiya of gold) and you reach Medina on it. As I reached Medina, Allah's Messenger (may peace be upon him)said to Bilal: Give him an 'uqiya of gold and make some extra payment too. He (Jabir) said: He gave me an 'uqiya of gold and made an addition of a qirat. He (Jabir) said: The addition made by Allah's Messenger (may peace be upon him) was with me (as a sacred trust for belssing) and lay with me in a pocket until the people of Syria took it on the Day of Harra.

Book 10, Number 3890:

    Jabir b. 'Abdullah (Allah be pleased with them) reported: We were with Allah's Messenger (may peace be upon him) in a journey and my camel meant for carrying water lagged behind. The rest of the hadith is the same and it is mentioned also:Allah's Messenger (may peace be upon him) pricked it and then said to me: Ride in the name of Allah. He constantly made addition (in prayers for me) and went on saying.May Allah forgive you!

Book 10, Number 3891:

    Jabir (Allah be pleased with him) reported: My camel had grown tired as Allah's Messenger (may peace be upon him) came to me. He goaded it and it began to jump. After that I tried to restrain its rein so that I could listen to his (Prophet's) words, but I could not do that. Allah's Apostle (may peace be upon him) met me and said: Sell it to me, and I sold it for five 'uqiyas. I said: On the condition that I may use it as a ride (for going back) to Medina. He (the Holy Prophet) said: Well, you may use it as a ride up till Medina. When I came to Medina I handed over that to him and he made an addition of an uqiya (to that amount which had been agreed upon) and then presented that (camel) to me.

Book 10, Number 3892:

    Abd Mutawakkil al-Najl reported from Jabir b. 'Abdullah (Allah be pleased with them) who said: I accompanied Allah's Messenger (may peace be upon him) in one of his journeys (the narrator says, he said in Jihad), and he narrated the rest of the hadith, and made this addition: He (the Holy Prophet) said: Jabir, have you received the price? I said: Yes, whereupon he said: Yours is the price as well as the camel ; yours is the price as well as the camel.

Book 10, Number 3893:

    Jabir b. 'Abdullah (Allah be pleased with them) reported: Allah's Messenger (may peace be upon him) bought a camel from me for two 'uqiyas and a dirham or two dirhams. As he reached Sirar (a village near Medina), he commanded a cow to be slaughtered and it was slaughtered, and they ate of that, and as he (the Holy Prophet) reached Medina he ordered me to go to the mosque and offer two rak'ahs of prayer, and he measured for me the price of the camel and even made an excess payment to me.

Book 10, Number 3894:

    Jabir b. 'Abdullah (Allah be pleased with them) reported this narration from Allah's Apostle (may peace be upon him) but with this variation that he said: He (the Holy Prophet) bought the camel from me on a stipulated price. And he did not mention two 'uqiyas and a dirham or two dirhams, and he comanded a cow (to be slaughtered) and it was slaughtered, and he then distributed its flesh.

Book 10, Number 3895:

    Jabir (Allah be pleased with him) reported that Allah's Apostle (may peace be upon him) said to him: I have taken your camelfor four dinars, and you may ride upon it to Medina.

Chapter 27: HE WHO TOOK SOMETHING AS A LOAN AND MADE ITS PAYMENT BACK, OVER AND ABOVE THAT (IS APPROVED) AND BEST AMONG YOU IS ONE WHO IS BEST IN MAKING PAYMENT

Book 10 ,Number 3896:

    Abu Rafi' reported that Allah's Messenger (may peace be upon him) took from a man as a loan a young camel (below six years). Then the camels of Sadaqa were brought to him. He ordered Abu Rafi' to return to that person the young camel (as a return of the loan). Abu Rafi' returned to him and said: I did not find among them but better camels above the age of six. He (the Holy Propet) said: Give that to him for the best men are those who are best in paying off the debt.

Book 10, Number 3897:

    Abu Rafi', the freed slave of Allah's Messenger (may peace be upon him), said: Allah's Messenger (may peace be upon him) took as a loan (the rest of the hadith is the same), but with this variation that he (the Holy Prophet) said: Good amongst the servants of Allah is he who is best in paying off the debt.

Book 10, Number 3898:

    Abu Huraira (Allah be pleased with him) reported: Allah's Messenger (may peace be upon him) owed (something) to a person. He behaved in an uncivil manner with him. This vexed the Companions of the Holy Prophet (may peace be upon him), whereupon Allah's Apostle (may peace be upon him) said: He who has a right is entitled to speak, and said to them (his Companions): Buy a camel for him and give that to him. They said: We do not find a camel (of that age) but one with better age than that. He said: Buy that and give that to him, for best of you or best amongst you are those who are best in paying off debt.

Book 10, Number 3899:

    Abu Huraira (Allah be pleased with him) reported: Allah's Messenger (may peace be upon him) took a camel on loan, and then returned him (the lender) the camel of a more mature age and said: Good among you are those who are good in clearing off the debt.

Book 10, Number 3900:

    Abu Huraira (Allah be pleased with him) reported: There came a person demanding a camel from Allah's Messenger (may peace be upon him). He (the Holy Prophet) said: Give him (the camel) of that age or of more mature age, and said: Best among you is one who is best in clearing off the debt.

Book 10, Number 3901:

    Jabir (Allah be pleased with him) reported: There came a slave and pledg- ed allegiance to Allah's Apostle (may peace be upon him) on migration; he (the Holy Prophet) did not know that he was a slave. Then there came his master and demanded him back, whereupon Allah's Apostle (may peace be upon him) said: Sell him to me. And he bought him for two black slaves, and he did not afterwards take allegiance from anyone until he had asked him whether he was a slave (or a free man)

Chapter 28: PLEDGE AND ITS PERMISSIBILITY WHETHER AT RESIDENCE OR IN A JOURNEY

Book 10 ,Number 3902:

    'A'isha (Allah be pleased with her) reported that Allah's Messenger (may peace be upon him) bought some grain from a Jew on credit and gave him a coat-of- mail of his as a pledge.

Book 10, Number 3903:

    'A'isha (Allah be pleased with her) reported: Allah's Messenger (may peace be upon him) bought from a Jew grain (as loan) and pledged him his iron coat-of-mail.

Book 10, Number 3904:

    'A'isha (Allah be pleased with her) reported that Allah's Messenger (may peace be upon him) bought from a Jew grain for a specified time; and gave him iron coat-of-mail of his as a pledge.

Book 10, Number 3905:

    This hadith has been narrated on the authority of 'A'isha (Allah be pleased with her), through another chain ol transmitters, but no mention was made of (its being made) of iron.

Chapter 29: OF SALAM SALE

Book 10 ,Number 3906:

    Ibn 'Abbas (Allah be pleased with them) reported that when Allah's Prophet (may peace be upon him) came to Medina, they were paying one and two years in advance for fruits, so he said: Those who pay in advance for anything must do so for a specified weight and for a definite time.

Book 10, Number 3907:

    Ibn 'Abbas (Allah be pleased with them) reported that when Allah's Messenger (may peace be upon him) came to (Medina) and the people were paying in advance (for the fruits, etc.), he said to them: He who makes an advance payment should not make advance payment except for a specified measure and weight (and for a specified period).

Book 10, Number 3908:

    Ibn Abu Najih has narrated a hadith like this with the same chain of transmitters, but he has not mentioned: "for a definite period".

Book 10, Number 3909:

    This hadith has been narrated by Ibn Abu Najih through another chain of transmitters mentioning in it "for a specified period".

Chapter 30 : HOARDING OF FOODSTUFF IS FORBIDDEN

Book 10 ,Number 3910:

    Ma'mar (Allah be pleased with him) reported Allah's Messenger (may peace be upon him) as saying: He who hoards is a sinner. It was said to Sa'id (b. al-Musayyib):You also hoard. Sa'id said: Ma'mar who narrated this badith also hoarded.

Book 10, Number 3911:

    Ma'mar b. Abdullah reported Allah's Messenger (may peace be upon him) as saying: No one hoards but the sinner.

Book 10, Number 3912:

    This hadith has been transmitted on the authority of Sulaiman b. Bilal from Yahya.

Chapter 31: PROHIBITION OF TAKING OATH IN BUSINESS TRANSACTION

Book 10 ,Number 3913:

    Abu Huraira (Allah be pleased with him) said he heard Allah's Messenger(may peace be upon him) as saying: Swearing produces a ready sale for a commodity, but blots out the blessing.

Book 10, Number 3914:

    Abu Qatada al-Ansari (Allah be pleased with him) reported he heard Allah's Messenger (may peace be upon him) say: Beware of swearing; it produces a ready sale for a commodity, but blots out the blessing.

Chapter 32: SHUF'A (PRE-EMPTION)

Book 10 ,Number 3915:

    Jabir b. 'Abdullah (Allah be pleased with them) reported Allah's Messenger(may peace be upon him) as saying: He who has a partner in a dwelling or a garden, it is not lawful for him to sell that until he is permitted by his partner. If he (the partner) agrees, he should go in for that, and if he disapproves of that, he should abandon(the idea of selling it).

Book 10, Number 3916:

    Jabir bin 'Abdullah (Allah be pleased with them) said that the Messenger of Allah (may peace be upon him) decreed pre-emption in every joint ownership and not divided-the one-it may be a dwelling or a garden. It is not lawful for him(for the partner) to sell that until his partner gives his consent. He (the partner) is entitled to buy it when he desires and he can abandon it if he so likes. And if he (the one partner) sells it without getting the consent of the (other partner), he has the greatest right to it.

Book 10, Number 3917:

    Jabir b. 'Abdullah (Allah be pleased with them) reported Allah's Messenger(may peace be upon him) as saying: There is pre-emption in everything which is shared, be it land, or a dwelling or a garden. It is not proper to sell it until he informs his partner; he may go in for that, or he may abandon it; and it he (the partner intending to sell his share) does not do that, then his partner has the greatest right to it until he permits him.

Book 10, Number 3918:

    Abu Huraira (Allah be pleased with him) reported Allah's Messenger (may peace be upon him) as saying: None among you should prevent his neighbour from fixing a beam in his wall. Abu Huraira (Allah be pleased with him) then said: What is this that I see you evading (this injunction of the Holy Prophet) ? By Allah, I will certainly throw it between your shoulders (narrate this to you.)

Book 10, Number 3919:

    This hadith is narrated on the authority of Zuhri with the same chain of transrmitters.

Chapter 33: IT IS FORBIDDEN TO SEIZE LAND AND OTIIER THINGS WITHOUT LEGITIMATE RIGHT

Book 10 ,Number 3920:

    Sa'id b. Zaid b. 'Amr b. Nufail (Allah be pleased with them) reported Allah's Messenger (may peace be upon him) as saying: He who wrongly took a span of land, Allah shall make him carry around his neck seven earths.

Book 10, Number 3921:

    Sa'id b. Zaid b. 'Amr b. Nufail (Allah be pleased with them) reported that Arwi (bint Uwais) disputed with him (in regard to a part of the land) of his hodse. He said: Leave it and take off your claim from it, for I heard Allah's Messenger (may peace be upon him) as saying: He who took a span of land without his right would be made to wear around his neck seven earths on the Day of Resurrection. He (Sa'id b. Zaid) said: O Allah, make her blind if she has told a lie and make her grave in her house. He (the narrator) said: I saw her blind groping (her way) by touching the walls and saying: The curse of Sa'id b. Zaid has hit me. And it so happened that as she was walking in her house, she passed by a well in her house and fell therein and that be- came her grave.

Book 10, Number 3922:

    Hisham b. Urwa reported on the authority of his father (Allah be pleased with him) that Arwa bint Uwais disputed with Sa'id b. Zaid that he had seized some of the land belonging to her. She brought this dispute before Marwan b. al-Hakam. Sa'id said: How could I take a part of her land, after what I heard from Allah's Messenger (may peace be upon'him)? He (Marwan) said: What did you hear from Allah's Messenger (may peace be upon him) ? He said: I heard Allah's Messenger (may peace be upon him) say: He who wrongly took a span of land would be made to wear around his neck seven earths. Marwan said: I do not ask any evidence from you after this. He (Sa'id) said: O Allah, make her blind if she has told a lie and kill her in her own land. He (the narrator) said: She did not die until she had lost her eyesight, and (one day) as she was walking in her land, she fell down into a pit and died.

Book 10, Number 3923:

    Sa'id b. Zaid reported: I heard Allah's Apostle (may peace be upon him) say: He who took a span of earth wrongly would be made to wear around his neck seven earths on the Day of Resurrection.

Book 10, Number 3924:

    Abu Huraira (Allah be pleased with him) reported Allah's Messenger (may peace he upon him) as saying: One should not take a span of land without having legitimate right to it, otherwise Allah would make him wear (around his neck) seven earths on the Day of Resurrection.

Book 10, Number 3925:

    Muhammad b. Ibrahim said that Abu Salama reported to him that there was between him and his people dispute over a piece of land, and he came to 'A'isha and mentioned that to her, whereupon she said: Abu Salama, abstain from getting this land, for Allah's Messenger (may peace be upon him) said: He who usurps even a span of land would be made to wear around his neck seven earths.

Book 10, Number 3926:

    This hadith has been narrated on the authority of Abu Salama with another chain of transmitters.

Chapter 34: HOW MUCH LAND IS TO BE SPARED WHEN THERE IS DISAGREEMENT OVER THE BREADTH OF PATH

Book 10 ,Number 3927:

    Abu Haraira reported Allah's Apostle (may peace be upon him) as saying: When you disagree about a path, its breadth should be made seven cubitS.


BOOK 11: The Book Pertaining to the Rules of Inheritance (KITAB AL-FARA'ID)

KITAB AL-FARA'ID
(THE BOOK PERTAINING TO THE RULES OF INHERITANCE)

Back
INTRODUCTION

    Inheritance is the entry of living persons into possession of dead persons'property and exists in some form wherever the institution of private property is recognised as the basis of the social and economic system. The actual forms of inheritance and the laws governing it, however, differ according to the ideals of different societies.

    The law of inheritance in Islam is based upon five main considerations:

    1. To break up the concentration of wealth in individuals and spread it out in society.
    2. To respect the property right of ownership of an individual earned through honest means.
    3. To hammer in the consciousness of man the fact that man is not the absolute master of wealth he produces but he is its trustee and is not,therefore, authorised to pass it on to others as he likes.
    4. To consolidate the family system which is the social unit of an Islamic society.
    5. To give incentive to work and encourage economic activity as sanctioned by Islam.

    In the pre-Islamic world and even in modern societies the law of inheritance has so many evils in it, which may be summed up in the following points:

    1. Women had been completely denied the share of inheritance. They were rather regarded as part of the property of the deceased and, therefore,their right to property by inheritance was out of question.
    2. In pre-Islamic Arabia and other countries where there had been tribal societies not only women were deprived of the right of inheritance but even weak and sick persons and minor children were given no share in it, as the common principle of inheritance was that he alone is entitled to inherit who wields the sword.
    3. Then in certain societies there had been existing the law of primogeniture and it exists even today in some of the so-called civilised parts of the world which entitles only the eldest son to inherit the whole of the father's property or to get the lion's share.

    Islam introduced so many reforms in the laws of inheritance which can be succinctly summed up as follows.

    1. It defined and determined in clear-cut terms the share of each inheritor and imposed limits on the right of the property-owner to dispose of his property according to his whim and caprice.
    2. It made the female, who had been prevously thought a chattel, the co-sharer with the male and thus not only restored her dignity, but safeguarded her social and economic rights.
    3. It laid the rules for the break-up of the concentrated wealth in the society and helped in its proper and equitable distribution amongst a large number of persons.
    4. It gave a death-blow to the law of primogeniture and thus provided the democratic basis for the division of the property of the deceased.

    The above are some of the distinguishing features of the Islamic law of inheritance. While laying down the rules for the distribution of the estate of the deceased,the first principle to be observed is that the property both movable and immovable can be distributed after meeting the following obligations :

    1. funeral expenses;
    2. clearing off the debts incurred by the deceased;
    3. payment of bequest, if any, to the extent of one-third of the total assets. It may be remembered that the Mahr of the wife, if it had not been paid, is included in the debt. Moreover, it is not lawful to make a bequest in favour of a person who is entitled to a share in the inheritance.

    Four persons cannot get inheritance:

      (a) a fugitive slave who has fled away from his master,
      (b) one who has murdered one's predecessor intentionally or unintentionaly
      (c) one who professes a religion other than Islam,
      (d) one living in Dar-ul-Harb cannot inherit the property of one living in Dar-ul-Islam and vice versa.

    According to Islam, the heirs have been divided into three classes.

    (A) Dhaw-u'l-Fara'id are those persons who have a right to definite shares in assets left by the deceased. These sharers are twelve in number; four males: father, grandfather, uterine brothers and husband; and eight females: wife, single daughter, son's daughter, mother, grandmother, full sister, consanguine sister, uterine sister.

    1. Father's share is one-sixth when the deceased leaves a son or a son's son, but if the deceased is not survived by a son or grandson his father will, in addition to this share (one-sixth), also get a share of being 'Asaba.
    2. The grandfather's share is like that of father's share but in three conditions:
      1. According to Imam Bukhiri and Imam Muslim, the presence of father deprives even the brothers of their share in the inheritance.but this is not the case with the grandfather. Imam Abu Hanifa is of the opinion that the presence of grandfather deprives the brother of his share in the inheritance.
      2. If the father of the deceased is alive, then the share of the mother is of what is left from the share of the wife of the deceased. The presence of grandfather does not reduce the share of the mother of the deceased.
      3. The grandmother of the deceased has no share in the presence of the father of the deceased but she has a share in the presence of the grandfather.
    3. The third set of sharers are uterine brothers and sisters. They are entitled to one-sixth if their number is one, and one-third if they are more than one.
    4. The husband's share is one-half of the property of the deceased wife if she has no children, but in case of children it is one-fourth.
    5. The wife is entitled to one-fourth if the husband dies childless; otherwise it is one-eighth.
    6. Real daughter: one-half when alone, and two-thirds if more than one. If the deceased is survived by a male child also. the daughters are then treated as Asaba and the male child would get double of what falls to the lot of daughters. The granddaughters stand on the same level as daughters. But in case the deceased is survived by one real daughter and one or more than one granddaughter they would get one-sixth. The granddaughter is not entitled to any share if the deceased is survived by a son, but if he is survived by grandsons and granddaughters, they would be treated as 'Asaba and the male grandchild would get double of what goes to the female grandchild.
    7. Full sister gets one-half if she is alone, and two-thirds if they are more than one.
    8. Consanguine sister is entitled to one-half if one, and two thirds if more.
    9. Mother is entitled to one-sixth when she has a child or grandchild, and in case of being childless she gets one-third of the share.
    10. If the deceased is survived either by paternal grandmother or maternal grand- mother or even by both, they are entitled to one-sixth. The grandmother (maternal) is deprived of her share if the mother of the deceased is alive; and if father is alive the paternal grandmother is deprived of this share.

    (B) When the heirs of the first group have received the respective shares, the residue of the assets falls to the share of those relatives who are called Asaba which, according to the Shari'ah, implies those relatives in whose line of relationship no female enters. This is the second group of inheritors.

    There is no fixed share of the 'Asabat. If the deceased is not survived by any Dhaw-u'l-Fara'id, the whole of the property falls to their share; and If Dhaw-u'I.Fara'id are there to get their due share, the residue will be taken by the Asabat. The following are the 'Asabat:

    1. Son: He is the first to get the residue in order of succession. The daughters are entitled to half of the share as given to the son. The grandsons are not entitled to any share in the presence of the son. If the son is not living, then the grandson is entitled to a share in the inheritance. If there are more than one son, the inheritance will be distributed equally amongst them.
    2. The father, grandfather and the great-grandfather are included in the category of Dhaw-u'l-Fara'id. If, however, the deceased is not survived by category of a son, grandson of great-grandson, then the father will fall under the category of 'Asaba, and, in the absence of the father, the grandfather assumes that position.
    3. If the deceased is not survived by son, or grandson or father or grandfather, i.e. none amongst the 'Asabat, then the brother, and in the absence of brother his son, and in the absence of son, his grandson will be entitled to share in the inheritance as 'Asaba and the female would also join them in share claiming half of the share as compared with male.
    4. If unfortunately the deceased is survived by none of the above-mentioned relatives amongst the 'Asabat, then consanguine brother will be entitled to share in the inheritance and he will be preferred to full brother's son.
    5. Then comes the turn of full paternal uncle.

    (C) The last category of inheritors are known ad Dhaw-u'l Arham, i.e. relations connected through females, but it is in extremely rare cases that they get any share in the inheritance. The following relatives come under this category.

    1. The son of the daughter and daughter of the daughter.
    2. The son of the daughter of the son, and daughter of the daughter of the son and their children.
    3. Maternal grandfather, maternal grandfather of the father, the grandfather of the mother, maternal grandfather of the mother, the grandmother of the mother, the children of the sisters, the sisters of the father and those of the mother, etc.
Chapter 1 : GIVE THE INHERITANCE TO THOSE ENTITLED TO IT

Book 11, Number 3928:

    Usama b. Zaid reported Allah's Messenger (may peace be upon him) as saying: A Muslim is not entitled to inherit from a non-Muslim, and a non-Muslim is not entitled to inherit from a Muslim.

Book 11, Number 3929:

    Ibn Abbas (Allah be pleased with them) reported Allah's Messenger (may peace be upon him) as saying: Give the shares to those who are entitled to them, and what remains over goes to the nearest male heir.

Book 11, Number 3930:

    Ibn 'Abbas (Allah be pleased with them) reported Allah's Messenger (may peace be upon him) as saying: Give the shares to those who are entitled to them, and what is left from those wno are entitled to it goes to the nearest male heir.

Book 11, Number 3931:

    Tawus reported on the authority of his father Ibn Abbas (Allah be pleased with them) narrating that Allah's Messenger (may peace be upon him) said: Distribute the property amongst Ahl al-Fara'id, according to the Book of Allah, and what is left out of them goes to the nearest male heir.

Chapter 2 : THE LAW OF INHERITANCE IN REGARD TO AL-KALALA (THE PERSON WHO DIES LEAVING NO CHILD OR PARENT)

Book 11, Number 3932:

    Jabir b. 'Abdullah (Allah be pleased with them) reported: I fell sick and there came to me on foot Allah's Messenger (may peace be upon him) and Abu Bakr for inquiring after my health. I fainted. He (the Holy Prophet) performed ablution and then sprinkled over me the water of his ablution. I felt some relief and said: Allah's Messenger, how should I decide about my property? He said nothing to me in response until this verse pertaining to the law of inheritance was revealed: "They ask you for a decision ; say: Allah gives you a decision concerning the person who has neither parents nor children" (iv. 177).

Book 11, Number 3933:

    Jabir b. 'Abdullah (Allah be pleased with him) reported: Allah's Apostle(may peace be upon him) and Abi Bakr (Allah be pleased with him) visited me on foot in Banu Salama, and found me unconscious. He (the Holy Prophet) called for water and performed ablution and sprinkled out of it (the water) over me. I felt relieved. I said: Allah's Messenger, what should I do with my property? And this verse was revealed: "Allah enjoins you concerning your children: for the male is equal of the portion of two females."

Book 11, Number 3934:

    Jabir b. 'Abdullah (Allah be pleased with them) reported: While I had been ill Allah's Messenger (may peace be upon him) visited me and Abu akr (Allah be pleased with him) was with him, and they both came walking on foot. He (the Holy Prophet) found me unconscious. Allahs Messenger (may peace be upon him) performed ablution and then sprinkled over me the water of his ablution. I felt relieved regained my consciousness) and found Allah's Messenger (may peace be upon him) there. I said:Allah's Messenger, what should I do with my property ? He gave me no reply until the verse (iv. 177) relating to the law of inheritance was revealed.

Book 11, Number 3935:

    Jabir b. Abdullah (Allah be pleased with him)reported: Whilo I was ill Allah's Messenger (may peace be upon him) came to me and found me unconscious. He(the Holy Prophet) performed ablution, and sprinkled over me the water of his ablution. I regained my consciousness and said: Allah's Messenger, my case of inheritance is that of Kalala. Then the verse pertaining to the inheritance ( of Kalala) was revealed. I (one of the narrators) said: I said to Muhammad b. Munkadir: (Do you mean this verse) "They ask you ; say: Allah gives you decision in regard to Kalala" (iv. 177) ? He said: Yes, it was thus revealed.

Book 11, Number 3936:

    This hadith is transmitted on the authority of Shu'ba but with a slight variation of words.

Book 11, Number 3937:

    Abu Talha reported: 'Umar b. al-Khattab (Allah be pleased with him) delivered a sermon on Friday and made a mention of Allah's Apostle (may peace be upon him) and he also made a mention of Abu Bakr (Allah be pleased with him) and then said: I do not leave behind me any problem more difficult than that of Kalala. I did not refer to Allah's Messenger (may peace be upon him) more repeatedly than in case of the problem of Kalala, and he (the Holy Prophet) never showed more annoyance to me than in regard to this problem, so much so that he struck my chest with his fingers and said: 'Umar, does the verse revealed in summer season, at the end of Sura al-Nisa' not suffice you ? Hadrat 'Umar (then) said : If I live I would give such verdict about (Kalala) that everyone would be able to decide whether he reads the Qur'an or he does not.

Book 11, Number 3938:

    This hadith has been narrated on the authority of Qatada with the same chain of transmitters.

Chapter 3 : THE LAST VERSE REVEALED WAS THAT PERTAINING TO KALALA

Book 11, Number 3939:

    Al-Bara' (Allah be pleased with him) reported that the last verse revealed in the Holy Qur'an is: "They ask thee for a religious verdict; say: Allah gives you a religious verdict about Kalala (the person who has neither parents nor children)"(iv 177).

Book 11, Number 3940:

    Abu Ishaq said that he heard al-Bara' b. 'Azib (Allah be pleased with him say: The last verse revealed (in the Holy Quran) is that pertaining to Kalala, and the last sura revealed is Sura al-Bara'at.

Book 11, Number 3941:

    Abu Ishaq said that he heard al-Bara' b. 'Azib (Allah be pleased with him)say : The last complete sura revealed (in the Holy Qur'an) is Sura Tauba (i e. al-Bara'at, ix.), and the last verse revealed is that pertaining to Kalala.

Book 11, Number 3942:

    Aba Ishaq reported this hadith on the authority of al-Bara' (Allah be pleased with him) with a slight variation of words, viz. the last sura that was revealed complete.

Book 11, Number 3943:

    Al-Bara' (Allah be pleased with him) reported that the last verse revealed was: "They ask of thee religious verdict . . " (iv. 177).

Chapter 4 : HE WHO LEAVES BEHIND PROPERTY, THAT IS FOR THE HEIRS

Book 11 ,Number 3944:

    Abu Huraira (Allah be pleased with him) reported that when the body of a dead person having burden of debt upon him was brought to Allah's Messenger(may peace be upon him) he would ask whether he had left property enough to clear off his debt, and if the property left had been sufficient for that (purpose), he observed funeral prayer for him, otherwise he said (to his companions): You observe prayer for your companion. But when Allah opened the gateways of victory for him, he said: I am nearer to the believers than themselves, so if anyone dies leaving a debt, its payment is my responsibility, and if anyone leaves a property, it goes to his heirs.

Book 11, Number 3945:

    This hadith has been narrated on the authority of al-Zuhri through another chain of transmitters.

Book 11, Number 3946:

    Abn Huraira (Allah be pleased with him) reported Allah's Apostle (may peace be upon him) having said this: By Him in Whose Hand is the life of Muhammad, there is no believer on the earth with whom I am not the nearest among all the people. He who amongst you (dies) and leaves a debt, I am there to pay it, and he who amongst you (dies) leaving behind children I am there to look after them. And he who amongst You leaves behind property, that is for the inheritor whoever he is.

Book 11, Number 3947:

    Hammam b. Munabbih reported: This is what Abu Huraira (Allah be pleased with him) narratted to us from Allah's Messenger (may peace he upon him). And he narrated many ahadith, and one was this: Allali's Messenger (may peace be upon him said: I am, according to the Book of Allah, the Exalted and Majestic, nearest to the believers of all the human beings. So whoever amongst you dies in debt or leaves behind destitute children, you should call me (for help)), for I am his guardian. And who amongst you leaves property, his inheritor is entitled to get it, whoever he is.

Book 11, Number 3948:

    Abu Huraira (Allah be pleased with him) reported Allah's Apostle (may peace be upon him) as saying : He who leaves property, that is for the inheritors; and he who leaves behind destitute children, then it is my responsibility (to look after them).This hadith has been narrated on the authority of Shu'ba with the same chain of transmitters.


BOOK 12: Gifts (KITAB AL-HIBAT)

KITAB AL-HIBAT
THE BOOK OF GIFTS

Back
INTRODUCTION

    A Hiba is defined as the transfer of the possession of property, movable and immovable, from one person to the other willingly and without any reward. The one who makes this transfer is known as donor (Wahib), and the thing transferred is known as Mauhubah, and the one who is donated is known as Mauhub lahu (donee). The other words used in the language of the Shar'i'ah are Nihla or 'Atiyya.

    The act of Hiba is not complete unless the donor surrenders the possession of the thing donated. Moreover, the declaration of donation should be in clear terms without any ambiguity (around them). This act of donation is based on the following hadith of the Holy Prophet (may peace be upon him): "Give presents to one another for this would increase your mutual love." This not only implies the legality of gifts, but the exhortation to give these to one another. There is perfect agreement amongst all the jurists that Hiba is valid in Islam.

    The act of donation can be made verbally or in writing by any person capable of making a contract. A gift by a person involved in debt is invalid, and gift in death illness cannot take effect beyond one-third of the assets of the deceased after defraying all necessary expenses. The donation can be made to a living person and not to one who is dead.

    The Shari'ah imposes certain restrictions on the property which is to be donated. In the first place, the property must be in existence at the time when the gift is given; hence the gift of oil in the sesame or of butter in the milk would not be valid. The property once given as a gift cannot be revoked except in some extraordinary circumstances. The father is entitled to get back the donation given by him from his children if be finds it contrary to the laws and spirit of the Shari'ah. The right to revoke a gift is called Raj'. This act of revocation can be done with the decree of a competent court.

Chapter 1 :DISAPPROVAL OF BEUYING THE DONATED PROPERTY BY THE DONOR HIMSELF

Book 12, Number 3949:

    Umar b. Khattab (Allah be pleased with him) reported: I donated a pedigree horse in the path of Allah. Its possesser made it languish. I thought that he would sell it at a cheap price. I asked Allah's Menengsr (may peace be upon him) about it, whereupon he said: Don't buy it and do not get back your charity, for one who gets back the charity is like a dog who swallows its vomit. This hadith has been narrated on the authority of Malik b. Anas with the same chain of transmitters but with this addition: "Don't buy that even if he gives you for one dirham."

Book 12, Number 3950:

    Zaid b. Aslam reported on the authority of his father that 'Umar (Allah be pleased with him) donated a horse in the path of Allah. He found that it had languished in the hand of its possessor, and he was a man of meagre resources He (Hadrat 'Umar) intended to buy it. He came to Allah's Messenger (may peace be upon him) and made a mention of that to him, whereupon he said: Don't buy that even if you get it for a dirham for he who gets back the charity is like a dog which swallows its vomit.

Book 12, Number 3951:

    This hadith has been narrated on the authority of Zaid b. Aslam with the same chain of transmitters but with this (change) that the hadith transmitted on the authority of Malik and Rauh (he was the son of Qisirn) is more complete and lengthy.

Book 12, Number 3952:

    Ibn 'Umar reported that 'Umar b. al-Khattib (Allah be pleased with him) donated a horse in the path of Allah and (later on) he found it being sold, and he decided to buy that. He asked the Messenger of Allah (may peace be upon him) about it. whereupon he (the Holy prophet) said: Don't buy that and do not get back what you gave in charity.

Book 12, Number 3953:

    This hadith has been narrated on the authority of Ibn Umar through another chain of transmitters.

Book 12, Number 3954:

    Salim reported from Ibn Umar (Allah be pleased with them) that 'Umar donated a horse in the path of Allah and then found it being sold, and he decided to buy that. He asked Allah's Apostle (may peace be upon him) about it, whereupon Allah's Messenger (may peace be upon him) said: Umar, do not get back what you gave as charity.

Book 12, Number 3955:

    Ibn 'Abbas (Allah be pleased with them) reported Allah's Apostle (may peace be upon him) having said this: He who gets back his charity is like a dog which vomit, and then returns to that and eats it.

Book 12, Number 3956:

    A hadith like this is reported on the authority of Muhammad son of Fatima (Allah be pleased with her) daughter of Allah's Messenger (may peace be upon him).

Book 12, Number 3957:

    Ibn Abbas (Allah be pleased with them) reported: I heard Allah's Messenger (may peace be upon him) say: The similitude of one who gives a charity and then gets it back is like that of a dog which vomits and then eats its vomit.

Book 12, Number 3958:

    Ibn Abbas (Allah be pleased with them) reported Allah's Apostle (may peace be upon him) as saying: One who gets back the gift is like one who eats vomit.

Book 12, Number3959 :

    This hadith has been narrated on the authority of Qatada with the same chain of transmitters.

Book 12, Number 3960:

    Abdullah b. Tawus reported on the authority of his father who reported from Ibn Abas(Allah be pleased with them) who reported from Allah's Messenger 'may peace be upon him) that he said: One who gets back his gift is like a dog which vomits and then swallows that vomit.

Chapter 2 : DISAPPROVAL OF GIVING PREFERENCE TO SOME CHILDREN WHILE MAKING DONATION

Book 12, Number 3961:

    Nu'man b. Bashir reported that his father brought him to Allah's Messenger (may peace be upon him) and said: I have donated this slave of mine to my son. Allah's Messenger (may peace be upon him) said: Have you donated to every one of your sons (a slave) like this? He said: No. Thereupon Allah's Messenger (may peace he upon him) said: Then take him back.

Book 12, Number 3962:

    Nu'man b. Bashir reported: My father brought me to Allah's Messenger (may peace be upon him) and said: I have donated this slave to my son. whereupon he said: Have you made (such) donation to every one or your sons? He said: No. Thereupon he (the-Holy Prophet) said: Then take him back.

Book 12, Number 3963:

    This hadith has been narrated on the authority of Zubri with different chains of transmitters and a slight variation of words.

Book 12, Number 3964:

    Nu'man b. Bashir reported that his father had donated a slave to him. Allah's Apostle (may peace he upon him) said: Who is this slave (how have you come to possess it)? Thereupon he (Nu'man b. Bashir) said: My father has donated it to me, whereupon he said: Have all brothers (of yours) been given this gift as given to you? He said: No. Thereupon he (the Holy Prophet) said: Then return him.

Book 12, Number 3965:

    Nu'man b. Bashir reported: My father donated to me some of his property. My mother Amra bint Rawaha said: I shall not be pleased (with this act) until you make Allah's Messenger (may peace be upon him) a witness to it. My father went to Allah's Apostle (may peace be upon him) in order to make him the witness of the donation given to me. Allah's Messenger (may peace be upon him) said to him: Have you done the same with every son of yours? He said: No. Thereupon he (the Holy Prophet) said: Fear Allah, and observe equity in case of your children. My father returned and got back the gift.

Book 12, Number 3966:

    Nu'man b. Bashir reported that his mother bint Rawaha asked his (Nu'man's) father about donating some gifts from his property to his son. He deferred the matter by one year, and then set forth to do that. She (Nu'man's mother) said : I shall not be pleased unless you call Allah's Messenger (may peace be upon him) as witness to what you confer as a gift on your son. (Nu'man said): So father took hold of my hand and I was at that time a boy, and came to Allah's Messenger (may peace be upon him). and said: Allah's Messenger, the mother of this son (of mine), daughter of Rawaha wishes that I should call you witness to what I confer as gift to her son. Allah's Messenger (may pease be upon him) said: Bashir, have you any other son besides this (son of yours)? He said : Yes. He (the Holy Prophet) said : Have you given gifts to all of them like this? He said: No. Thereupon he (the Holy Prophet) said: Then call me not as witness, for I cannot be witness to an injustice.

Book 12, Number 3967:

    Nu'man b. Bashir, reported that Allah's Messenger (may peace be upon him) had said: Have you, besides him, other sons? He said: Yes. Thereupon he (the Holy Prophet) said: Have you given gifts to all of them like this (as you have given to Nu'man)? He said: No. Thereupon he (the Holy Prophet) said: I cannot bear witness to an injustice.

Book 12, Number 3968:

    Nu'man b. Bashir (Allah be pleased with them) reported that Allah's Messenger (may peace be upon him) said to his father: Call me not as witness to an injustice.

Book 12, Number 3969:

    Nu'man b. Bashir (Allah be pleased with them) reported: My father took me to Allah's Messenger (may peace be upon him) and said: Allah's Messenger, bear witness that I have given such and such gift to Nu'man from my property, whereupon he (the Holy Prophet) said: Have you conferred upon all of your sons as you have conferred upon Nu'man? He said: No. Thereupon he (the Holy Prophet) said: Call someone else besides me as a witness. And he further said: Would it, please you that they (your children) should all behave virtuously towards you ? He said: Yes. He (the Holy Prophet) said: Then don't do that (i e. don't give gift to one to the exclusion of others).

Book 12, Number 3970:

    Nu'man b. Bashir reported: My father conferred a gift upon me, and then brought me to Allah's Messenger (may peace be upon him) to make him a witness (to it). He (the Holy Prophet) said: Have you given such gift to every son of yours (as you have given to Nu'man)? He said: No. Thereupon he (the Holy Prophet) said: Don't you expect goodness from them as you expect from him? He said: Yes. of course. He (the Holy Prophet) said: I am not going to bear witness to it (as it is injustice). Ibn Aun (one of the narrators) said: I narrated this hadith to Muhammad (the other narrator) who said: Verily we narrated that lie (the Holy Prophet) had said: Observe equity amongst your children.

Book 12, Number 3971:

    Jabir (Allah be pleased with him) reported that the wife of Bashir said (to her husband): Give to my son your slave as a gift, and make for me Allah's Messenger (may peace be upon him) a witness He came to Allah's Messenger (may peace be upon him) and said: The daughter of so and so (his wife Amra bint Rawaha) asked me to give my slave as a gift to her son, and call for me Allah's Messenger (may peace be upon him) as a witness. Thereupon he (the Holy Prophet) said: Has he (Nu'man) brothers? He (Bashir) said: Yes. He (further) said: Have you given to all others as you have given to him? He said: No. He said: Then it is not fair; and verily I cannot bear witness but only to what is just.

Chapter 3 : AL-'UMRA (LIFE GRANT)

Book 12, Number 3972:

    Jabir b. 'Abdullah (Allah be pleased with them) reported Allah's Messenger (may peace be upon him) as saying: Whoever a person is gifted a life grant, then it is for him (belongs to him and to his posterity, for it belongs to him who has been gven it). It would not return to him who gave it for he conferred it as a gift (it becomes the property of the donee and as such) rules of inheritance will apply to it.

Book 12, Number 3973:

    Jaber b. 'Abdullah (Allah be pleased with them) reported Allah's Messenger (may peace be upan him) as saying: He who conferred a life grant upon a person, it becomes his possession and that of his successors, for he surrendered his right in that by his declaration. (This property) now belongs to one to whom this lifelong grant has been made, and to his successors. Yahya narrated in the beginning of his narration: Whatever man is given a life grant, then it belongs to him and his posterity.

Book 12, Number 3974:

    Jabir b. 'Abdullah al-Ansari (Allah be pleased with him) said: Allah's Messenger (may peace be upon him) said: Whoever a person conferred Umra (life grant) upon a person and he says: I confer upon you this and upon your descendants and anyone who survives you, and that becomes his possession and that of his posterity. It would become (a permanent possession) of those who were conferred upon this gift, and it would not return to its owner (donor), for he gave that as a gift in which accrued the right of inheritance.

Book 12, Number 3975:

    Jabir (Allah be pleased with him) said: The Umra for which Allah's Messenger (may peace be upon him) gave sanction that a person way say: This (property) is for you and for your descendants. And when he said: That is for you as long as you live, then it will return to its owner (after the death of the donee). Ma'mar said: Zuhri used to give religious verdict according to this.

Book 12, Number 3976:

    Jabir b. 'Abdullah (Allah be pleased with him) reported that Allah's Messenger (may peace be upon him) commanded that whoever is conferred upon a life grant along with his descendants is entitled to make use of the property conferred so long as he lives and his successors (also enjoy this privilege). That (property) becomes the their defect belonging. The donor cannot (after declaring Umra) lay down any condition or make any exception. Abu Salama said: For he conferred a grant and as such it becomes heritage. and the right of inheritance abrogated his condition.

Book 12, Number 3977:

    Jabir (b. 'Abdullah) (Allah be pleased with him) reported Allah's Messenger (may peace be upon him) as saying: Life grant is for one upon whom it is bestowed.

Book 12, Number 3978:

    Jabir b. 'Abdullah reported a hadith like this through another chain of transmitters.

Book 12, Number 3979:

    Jabir reported this hadith directly from Allah's Apostle (may peace be upon him)

Book 12, Number 3980:

    Jabir (b. 'Abdullah) (Allah be pleased with him) reported Allah's Messenger (may peace be upon him) having said: Keep your property to yourselves and do not squander it, for he who conferred a life grant upon another that property will belong to him upon whom it is conferred whether he lives or dies, and (would pass on) to his successors (as heritage).

Book 12, Number 3981:

    This hadith is narrated on the authority of Jabir through other chains of transmitters, but (with this addition of words) that thehadith transmitted on the authority of Ayyub (these words are found): "The Helpers (Ansar) conferred the benefit of 'Umra, upon the Emigrants (Muhajirin), whereupon Allah's Messenger (may peace be upon him) said: Keep your property to yourselves.

Book 12, Number 3982:

    Jabir (Allah be pleased with him) reported that a woman gave her garden as a life grant to her son. He died and later on she also died and left a son behind and brothers also, The sons of the woman making life grant said (to those who had been conferred upon this 'Umra): This garden has returned to us. The sons of the one who had been given life grant said: This belonged to our father, during his lifetime and in case of his death. They took their dispute to Tariq, the freed slave of 'Uthman. He called Jabir and he gave testimony of Allah's Messenger (may peace be upon him) having said: Life grant belongs to one who is conferred upon this (privilege). Tariq gave this decision and then wrote to Abd al-Malik and informed him, Jabir bearing witness to it. Abd al-Malik said: Jabir has told the truth. Then Tariq gave a decree and, as a result thereof, it is to this day that the garden belongs to descendants of one who was conferred upon the life grant.

Book 12, Number 3983:

    Sulaiman b. Yasir reported that Jabir gave this verdict. The inheritor has a right (to inherit) the life grant according to the statement of Jabir (b. 'Abdullah) (Allah be pleased with him) which he narrated from Allah's Messenger (may peace be upon him).

Book 12, Number 3984:

    Jabir b. 'Abdullah reported Allah's Apostle (may peace be upon him) as saying: Life grant is permissible.

Book 12, Number 3985:

    Jabir b. Abdullah (Allah be pleased with them) reported Allah's Apostle (may peace be upon him) as saying: Life grant is the heritage of one upon whom it is conferred.

Book 12, Number 3986:

    Abd Huraira (Allah be pleased with him) reported Allah's Apostle (may peace be upon him) as saying: Life grant is permissible. This hadith is narrated on the authority of Qatada with the same chain of transmitters.


BOOK 13: Bequest (Wills) (KITAB AL-WASIYYA)

KITAB AL-WASIYYA
(THE BOOK OF BEQUESTS)

Back
INTRODUCTION

    A bequest (WasIyya) or will is defined as a transfer to come into operation after the testator's death. The testator is called Musi, and the legatee or devisee is called Musa lahu, and the executor is called Wasi. It is a spiritual testament of a man enabling him to make up his shortcomings in the worldly life and securing rewards in the Hereafter.

    According to the Shar'iah, one is entitled to make a will for one-third of one's property and not beyond that so that the rights of the legal heirs are not adversely affected.

    "Again, the principle on which the legality of a testamentary disposition is based being in defeance pro tanto of the rights of heirs generally the law requires that such disposition should be for the benefit of non-heirs alone.

    "A further reason why a bequest in favour of an heir is not allowed is that it would amount to giving preference to some heirs over others, thus defeating the spirit of the law which has fixed the portion of each in the inheritance and causing disputes among persons related to one another. If the other heirs consent to a bequest to one of them or to a bequest of more than one-third of the estate, the above reasons no longer hold good and the bequest as made will be valid" (Abdur Rahim, The Principles of Muhammadan jurisprudence, pp. 311-2).

    It is, however, preferable and most advisable not to will away the property if the legal heirs are poor, because it manifests benevolence to the heirs who have superior claim to it from the relations in which they stand.

    Another principle which is observed in case of bequest is that the proprietary right of a legatee in a bequest is establislied if he accepts it.

Chapter 1 : ONE SHOULD MAKE IT A POINT TO WRITE THE WILL

Book 13, Number 3987:

    Ibn Umar (Allah be pleased with them) reported Allah's Messenger (may peace be upon him) as saying: It is the duty of a Muslim who has something which is to be given as a bequest not to have it for two nights without having his will written down regarding it.

Book 13, Number 3988:

    This hadith has been narrated on the authority of 'Ubaidullah with the same chain of transmitters. but with a slight variation of words.

Book 13, Number 3989:

    A hadith like this have been narrated on the authority of Nifi', who based his narrations of the words of Ibn 'Umar but with a slight variation of words.

Book 13, Number 3990:

    Salim reported on the authority of his father ('Abdullah b. Umar) that he (his father) had heard Allah's Messenger (may peace be upon him) as saying: It is not proper for a Muslim who has got something to bequeathe to spend even three nights without having his will written down with him regarding it. 'Abdullah b. 'Umar (Allah be pleased with them) said: Ever since I heard Allah's Messenger (may peace be upon him) say this I have not spent a night without having my will (written) along with me. This hadith has been narrated on the authority of Zuhri with the same chain of transmitters.

Chapter 2 : WILL CAN BE MADE ONLY FOR ONE-THIRD

Book 13, Number 3991:

    Amir b. Sa'd reported on the authority of his father (Sa'd b. Abi Waqqas): Allah's Messenger (may peace be upon him) visited me in my illness which brought me near death in the year of Hajjat-ul-Wada' (Farewell Pilgrimage). I said: Allah's Messenger, you can well see the pain with which I am afflicted and I am a man possessing wealth, and there is none to inherit me except only one daughter. Should I give two-thirds of my property as Sadaqa ? He said: No. I said: Should I give half (of my property) as Sadaqa? He said: No. He (further) said: Give one-third (in charity) and that is quite enough. To leave your heirs rich is better than to leave them poor, begging from people; that you would never incur an expense seeking therewith the pleasure of Allah, but you would be rewarded therefor, even for a morsel of food that you put in the mouth of your wife. I said: Allah's Messenger. would I survive my companions? He (the Holy Prophet) said: If you survive them, then do such a deed by means of which you seek the pleasure of Allah, but you would increase in your status (in religion) and prestige; you may survive so that people would benefit from you, and others would be harmed by you. (The Holy Prophet) further said: Allah, complete for my Companions their migration, and not cause them to turn back upon their heels. Sa'd b. Khaula is, however, unfortunate. Allah's Messenger (may peace be upon him) felt grief for him as he had died in Mecca.

Book 13, Number 3992:

    This hadith is narrated on the authority of Zuhri with the same chain of transmitters.

Book 13, Number 3993:

    'Amir b. Sa'd reported from S'ad (b. Abu Waqqas): Allah's Apostle (may peace be upon him) visited me to inquire after my health, the rest of the hadith is the same as transmitted on the authority of Zuhri, but lie did not make mention of the words of Allah's Apostle (may peace be upon him) in regard to Sa'd b. Khaula except this that he said: "He (the Holy Prophet) did not like death in the land from which lie had migrated."

Book 13, Number 3994:

    Mus'ab b. Sa'd reported on the authority of his father. I was ailing. I sent message to Allah's Apostle (may peace be upon him) saying: Permit me to give away my property as I like. He refused. I (again) said: (Permit me) to give away half. He (again refused). I (again said): Then one-third. He (the Holy Prophet) observed silence after (I had asked permission to give away) one-third. He (the narrater) said: It was then that endowment of one-third became permissible.

Book 13, Number 3995:

    This hadith has been narrated on the authority of Simak with the same chain of transmitters. But he did not mention: "It was then that one-third became permissible."

Book 13, Number 3996:

    Ibn Sa'd reported his father as saying: Allah's Apostle (may peace be upon him) visited me during my illness. I said: I am willing away the whole of my property. He said: No. I said: Then half ? He said: No. I said: Should I will away one-third? He said: Yes, and even one-third is enough.

Book 13, Number 3997:

    Humaid b. 'Abd al-Rahman al-Himyari reported from three of the sons of Sa'd all of whom reported from their father that Allah's Apostle (may peace be upon him) visited Sa'd as he was ill in Mecca. He (Sa'd) wept. He (the Holy Prophet) said : What makes you weep ? He said : I am afraid I may die in the land from where I migrated as Sa'd b. Khaula had died. Thereupon Allah's Apostle (may peace be upon him) said : O Allah, grant health to Sa'd. O Allah, grant health to Sad. He repeated it three times. He (Sa'd) said : Allah's Messenger, I own a large property and I have only one daughter as my inheritor. Should I not will away the whole of my property ? He (the Holy Prophet) said : No. He said: (Should I not will away,) two-thirds of the property ? he (the Holy Prophet) said: No. He (Sa'd) (again) said : (Should I not will away) half (of my property) ? He said : No. He (Sa'd) said: Then one-third ? Thereupon he (the Holy Prophet) said : (Yes), one-third, and one-third is quite substanial. And what you spend as charity from your property is Sadaqa and flour spending on your family is also Sadaqa, and what your wife eats from your property is also Sadaqa, and that you leave your heirs well off (or he said : prospreous) is better than to leave them (poor and) begging from people. He (the Holy Prophet) pointed this with his hands.

Book 13, Number 3998:

    Humaid b. Abd al-Rahmin al-Himayri reported on the authority of the three of the sons of Sa'd : They said: Sa'd fell ill in Mecca. Allah's Messenger (may peace be upon him) visited him to inquire after his health. The rest of the hadith is the same.

Book 13, Number 3999:

    Humaid b. Abd al-Rahman reported this hadith on the authority of three of Sa'd's sons: Sa'd fell ill in Mecca and Allah's Apostle (may peace be upon him) visited him. The rest of the hadith is the same.

Book 13, Number 4000:

    Ibn 'Abbas (Allah be pleased with them) said: (I wish) if people would reduce from third to fourth (part for making a will of their property), for Allah's Messenger (may peace be upon him) said: So far as the third (part) is concerned it is quite substantial. In the hadith transmitted on the authority of Waki (the words are) "large" or "much".

Chapter 3 :THE DECEASED IS ENTITLED TO REWARD FOR THE SADAQA GIVEN AFTER HIS DEATH

Book 13, Number 4001:

    Abu Huraira (Allah be pleased with him) reported that a person said to Allah's Apostle (may peace be upon him) : My father died and left behind property without making any will regarding it. Would he be relieved of the burden of his sing if I give sadaqa on his behalf ? He (the Holy Prophet) said: Yea.

Book 13, Number 4002:

    A'isha (Allah be pleased with her) reported that a man said to Allah's Apostle (may peace be upon him) : My mother died all of a sudden, and I think if she (could have the opportunity) to speak she would have (made a will) regarding Sadaqa'. Will I be entitled to reward if I give charity on her behalf ? He (the Holy Prophet) said: Yes.

Book 13, Number 4003:

    A'isha (Allah be pleased with her) reported that a man came to Allah's Apostle (may peace be upon him) and said: Allah's Messenger, my mother died all of a sudden without making any will. I think if (she could have the opportunity) to speak she would have made a Sadaqa. Would there be any reward for her if I give charity on her behalf ? He (the Holy Prophet) said: Yes.

Book 13, Number 4004:

    This hadith has been narrated on the authority of Hisham b. 'Urwa with the same chain of transmitters.

Chapter 4 : WHAT REWARD MAN GETS AFTER HIS DEATH

Book 13, Number 4005:

    Abu Huraira (Allah be pleased with him) reported Allah's Messenger (may peace be upon him) as saying: When a man dies, his acts come to an end, but three, recurring charity, or knowledge (by which people) benefit, or a pious son, who prays for him (for the deceased).

Chapter 5 : WAQF

Book 13, Number 4006:

    Ibn Umar reported: Umar acquired a land at Khaibar. He came to Allah's Apostle (may peace be upon him) and sought his advice in regard to it. He said: Allah's Messenger, I have acquired land in Khaibar. I have never acquired property more valuable for me than this, so what do you command me to do with it? Thereupon he (Allah's Apostle) said: If you like, you may keep the corpus intact and give its produce as Sadaqa. So 'Umar gave it as Sadaqa declaring that property must not be sold or inherited or given away as gift. And Umar devoted it to the poor, to the nearest kin, and to the emancipation of slaves, aired in the way of Allah and guests. There is no sin for one,who administers it if he eats something from it in a reasonable manner, or if he feeds his friends and does not hoard up goods (for himself). He (the narrator) said: I narrated this hadith to Muhammad, but as I reached the (words) "without hoarding (for himself) out of it." he (Muhammad' said: "without storing the property with a view to becoming rich." Ibn 'Aun said: He who read this book (pertaining to Waqf) informed me that in it (the words are) "without storing the property with a view to becoming rich."

Book 13, Number 4007:

    This hadith has been narrated on the authority of Ibn 'Aun with the same chain of transmitters up to the words: "Or he may feed the friend withoiut hoarding from it" and he made no mention of what follows.

Book 13, Number 4008:

    'Umar reported: I acquired land from the lands of Khaibar. I came to Allah's Messenger (may peace be upon him) and said: I have acquired a piece of land. Never have I acquired land more loved by me and more cherished by me than this. The rest of the hadith is the same, but he made no mention of this: "I narrated it to Muhammad" and what follows.

Chapter 6 :HE WHO HAS NOT ANYTHING WITH HIM TO WILL AWAY SHOULD NOT DO IT

Book 13, Number 4009:

    Talha b. Musarrif reported: I asked 'Abdullah b. Abu Aufa whether Allah's Messenger (may peace be upon him) had made any will (in regard to his property). He said: NO. I said: Then why has making of will been made necessary for the Muslims, or why were they commanded to make will? Thereupon he said: He made the will according to the Book of Allah, the Exalted and Majestic.

Book 13, Number 4010:

    This hadith has been narrated on the authority of Malik b. Mighwal with the same chain of transmitters but with a slight variation of words. In the hadith related by Waki (the words are) "I said: How the people have been ordered about the will"; and in the hadith of Ibn Numair (the words are): "How the will has been prescribed for the Muslims,'.

Book 13, Number 4011:

    A'isha reported: Allah's Messenger (may peace be upon him) left neither dinar nor dirham (wealth in the form of cash), nor goats (and sheep), nor camels. And he made no will about anything (in regard to his material possessions, as he had none),

Book 13, Number 4012:

    This hadith has been narrated on the authority of A'mash with the same chain of transmitters.

Book 13, Number 4013:

    Aswad b. Yazid reported: It was mentioned before A'isha that will had been made (by the Holy Prophet) in favour of 'Ali (as the Prophet's first caliph), whereupon she said: When did he make will in his favour? I had been providing support to him (to the Holy Prophet) with my chest (or with my lap). He asked for a tray, when he fell in my lap (relaxing his body), and I did not realise that he had breathed his last. When did he make any will in his ('Ali's) favour?

Book 13, Number 4014:

    Sa'id b. Jubair reported that Ibn 'Abbas said: Thursday, (and then said): What is this Thursday? He then wept so much that his tears moistened the pebbles. I said: Ibn 'Abbas, what is (significant) about Thursday? He (Ibn 'Abbas) said: The illness of Allah's Messenger (may peace be upon him) took a serious turn (on this day), and he said: Come to me, so that I should write for you a document that you may not go astray after me. They (the Companions around him) disputed, and it is not meet to dispute in the presence of the Apostle. They said: How is lie (Allah's Apostle) ? Has he lost his consciousness? Try to learn from him (this point). He (the Holy Prophet) said: Leave me. I am better in the state (than the one in which you are engaged). I make a will about three things: Turn out the polytheists from the territory of Arabia; show hospitality to the (foreign) delegations as I used to show them hospitality. He (the narrator) said: He (Ibn Abbas) kept silent on the third point, or he (the narrator) said: But I forgot that.

Book 13, Number 4015:

    Sa'id b. Jubair reported from Ibn Abbas that he said: Thursday, and what about Thursday? Then tears began to flow until I saw them on his cheeks as it they were the strings of pearls. He (the narrator) said that Allah's Messenger (may peace be upon him) said: Bring me a shoulder blade and ink-pot (or tablet and inkpot), so that I write for you a document (by following which) you would never go astray. They said: Allah's Messenger (may peace upon him) is in the state of unconsciousness.

Book 13, Number 4016:

    Ibn Abbas reported: When Allah's Messenger (may peace be upon him) was about to leave this world, there were persons (around him) in his house, 'Umar b. al-Kbattab being one of them. Allah's Apostle (may peace be upon him) said: Come, I may write for you a document; you would not go astray after that. Thereupon Umar said: Verily Allah's Messenger (may peace be upon him) is deeply afflicted with pain. You have the Qur'an with you. The Book of Allah is sufficient for us. Those who were present in the house differed. Some of them said: Bring him (the writing material) so that Allah's Messenger (may peace be upon him) may write a document for you and you would never go astray after him And some among them said what 'Umar had (already) said. When they indulged in nonsense and began to dispute in the presence of Allah's Messenger (may peace be upon him), he said: Get up (and go away) 'Ubaidullah said: Ibn Abbas used to say: There was a heavy loss, indeed a heavy loss, that, due to their dispute and noise. Allah's Messenger (may peace be upon him) could not write (or dictate) the document for them.


BOOK 14: The Book of Vows (KITAB AL-AL-NADHR)

KITAB AL-AL-NADHR
(THE BOOK OF VOWS)

Back
Chapter 1 :

Book 14, Number 4017:

    Ibn Abbas reported that Sa'd b. Ubida asked Allah's Messenger (may peace be upon him) for a decision about a vow taken by his mother who had died before fulfilling it. Allah's Messenger (may peace be upon him) said: Fulfil it on her behalf.

Book 14, Number 4018:

    This hadith has been narrated on the authority of Zuhri with a different chains of transmitters.

Book 14, Number 4019:

    'Abdullah b. Umar reported: Allah's Messenger (may peace he upon him) singled out one day forbidding us to take vows and said: It would not avert anything; it is by which something is extracted from the miserly person.

Book 14, Number 4020:

    Ibn Umar reported Allah's Apostle (may peace be upon him) as saying: The vow neither hastens anything nor defers anything, but is the means whereby (something) is extracted from the miserly person.

Book 14, Number 4021:

    Ibn Umar reported that Allah's Apostle (may peace be upon him) forbade (people) taking vows, and said: It does not (necessarily) bring good (in the form of substantial,and tangible results), but it is the meant whereby something is extracted from the miserly persons.

Book 14, Number 4022:

    This hadith has been narrated on the authority of Mansur with the same chain of transmitters.

Book 14, Number 4023:

    Abu Heraira reported Allah's Messenger (may peace be upon him) as saying: Do not take vows, for a vow has no effect against Fate; it is only from the miserly that something is extracted.

Book 14, Number 4024:

    Abu Huraira reported Allah's Messenger (may peace be upon him) forbidding taking of vows, and said: It does not avert Fate, but is the means by which something is extracted from the miser.

Book 14, Number 4025:

    Abu Huraira reported Allah's Apostle (may peace be upon him) as saying: The vow does not bring anything near to the son of Adam which Allah has not ordained for him, but (at times) the vow coincides with Destiny, and this is how something is extracted from the miserly person, which that miser was not willing to give.

Book 14, Number 4026:

    This hadith has been transmitted on the authority of 'Amr b. Abu 'Amr.

Chapter 2 : THE VOW IS NOT TO BE FULFILLED WHICH IS MADE IN DISOBEDIENCE TO ALLAH, NOR THAT OVER WHICH A MAN HAS NO CONTROL

Book 14, Number 4027:

    Imran b. Husain reported that the tribe of Thaqif was the ally of Banu 'Uqail. Thaqif took two persons from amongst the Companiobs of Allah's Messenger (may peace be upon him) as prisoners. The Campanions of Allah's Messenger (may peace be upon him) took one person at Banu Uqail as prisoner, and captured al-'Adbi (the she-camel of the Holy Prophet) along with him. Allah's Messenger (may peace be upon him) came to him and he was tied with ropes. He said: Muhammad. He came near him and said: What is the matter with you? Thereupon he (the prisoner) said: Why have you taken me as prisoner and why have you caught hold of one proceeding the pilgrims (the she-camel as she carried the Holy Prophet on her back and walked ahead of the multitude) ? He (the Holy Prophet) said: (Yours is a great fault). I (my men) have caught hold of you for the crime of your allies, Banu Thaqif. He (the Holy Prophet) then turned away. He again called him and said: Muhammad, Muhammad, and since Allah's Messenger (may peace be upon him) was very compassionate, and tenderhearted, he returned to him, and said: What is the matter with you? He said: I am a Muslim, whereupon he (the Holy Prophet) said: Had you said this when you had been the master of yourself, you would have gained every success. He then turned away. He (the prisoner) called him again saying: Muhammad, Muhammad. He came to him and said: What is the matter with you? He said: I am hungry, feed me, and I am thirsty, so provide me with drink. He (the Holy Prophet) said: That is (to satisfy) your want. He was then ransomed for two persons (who had been taken prisoner by Thaqif). He (the narrator) said: A woman of the Ansar had been taken prisoner and also al-Adbi' was caught. The woman had been tied with ropes. The people were giving rest to their animals before their houses. She escaped one night from the bondage and came to the camels. As she drew near the camels, they fretted and fumed and so she left them until she came to al-,Adbi'. It did not fret and fume; it was docile She rode upon its back and drove it away and she went off. When they (the enemies of Islam) were warned of this, they went in search of it, but it (the she-camel) exhausted them. She (the woman) took vow for Allah, that in case He would save her through it, she would offer that as a sacrifice. As she reached Medina, the people saw her and they said: Here is al-Adbi, the she-camel of Allah's Messanger (may peace be upon him). She (the woman) said that she had taken a vow that if Allah would save her on its back, she would sacrifice it. They (the Prophet's Companions) came to Allah's Messenger (may peace be upon him) and made a mention of that to him, whereupon he said: Hallowed be Allah, how ill she rewarded it that she took vow to Allah that if He saves her on its back, she would sacrifice it ! There is no fulfilment of the vow in an act of disobedience, nor in an act over which a person has no control. In the version of Ibn Hujr (the words are): "There is no vow in disobedience to Allah."

Book 14, Number 4028:

    This hadith is narrated on the authority of Ayyub with the same chain of transmitters and a slight variation of words.

Chapter 3 : HE WHO TOOK THE VOW THAT HE WOULD GO ON FOOT TO THE KA'BA

Book 14, Number 4029:

    Anas reported that Allah's Apostle (may peace be upon him) saw an old man being supported between his two sons. He (the Holy Prophet) said: What is the matter with him? They said: He had taken the vow to walk (on foot to the Ka'ba). Thereupon he (Allah's Apoitle) said: Allah is indifferent to his inflicting upon himself chastisement, and he commanded him to ride.

Book 14, Number 4030:

    Abu Huraira reported: Allah's Apostle (may peace be upon him) found an old man walking between his two sons supported by them, whereupon Allah's Apostle (may peace be upon him) said: What is the matter with him? He (the narrator) said: Allah's Messenger, they are his sons and there is upon him the (fulfilment) of the vow, whereupon Allah's Apostle (may peace be upon him) said: Ride, old man, for Allah is not in need of you and your vow.

Book 14, Number 4031:

    This hadith has been narrated on the authority of 'Amr b. Abu 'Amr with the same chain of transmitters.

Book 14, Number 4032:

    'Uqba b. Amir reported: My sister took a vow that she would walk bare foot to the house of Allah (Ka'ba). She asked me to inquire from Allah's Messenger (may peace be upon him) about it. I sought his decision and he said: She should walk on foot and ride also.

Book 14, Number 4033:

    This hadith has been narrated on the authority of 'Uqba b. Amir Juhani. but in this no mention has been made of "barefoot".

Book 14, Number 4034:

    'Uqba.b. Amir reported Allah's Messenger (may peace be upon him) as saying: The expiation of the (breach of) a vow is the same as that of the (breach of an oath).


BOOK 15: The Book of Oaths (Kitab Al-Aiman)

KITAB AL-AIMAN
(THE BOOK OF OATHS)

Back
Chapter 1 : IT IS FORBIDDEN TO TAKE THE OATHS IN THE NAME OF ANYONE ELSE BESIDES ALLAH

Book 15, Number 4035:

    'Umar b. al-Khattib reported Allah's Messenger (may peace be upon him) as saying: Allah, the Great and Majestic, forbids you to swear by your fathers. Umar said: By Allah. I have never sworn (by my father) since I heard Allah's Messenger (may peace be upon him) forbidding it mentioning them "on my behalf" nor on behalf of someone else.

Book 15, Number 4036:

    This hadith has been transmitted on the authority of Zuhri except that in the hadith narrated on the authority of Uqail the words are: "I did not take oath by (anyone else except Allah) since I heard Allah's Messenger forbidding it. nor did I speak in such terms, and the narrator did not say, "on my own behalf or on behalf of someone else".

Book 15, Number 4037:

    Salim reported on the authority of his father that Allah's Apostle (may peace be upon him) heard 'Umar while he was taking oath by his father. The rest of the hadith is the same.

Book 15, Number 4038:

    'Abdullah (b. Umar) reported that Allah's Messenger (may peace be upon him) found , Umar b. al-Khattab amongst the riders and he was taking oath by his father Allah's Messenger (may peace be upon him) called them (saying); Our Allah, the Exated and Majestic, has forbidden you that you take oath by your father. He who bag to take an oath, he must take it by Allah or keep quiet.

Book 15, Number 4039:

    This hadith is narrated on the authority of Ibn Umar through another chain of transmitters.

Book 15, Number 4040:

    Ibn 'Umar heard Allah's Messenger (may peace be upon him) as saying: He who has to take an oath, he must not take oath but by Allah. The Quraish used to take oath by their fathers. So he (the Holy Prophet) said: Do not take oath by your fathers.

Chapter 2 : HE WHO TAKES AN OATH BY LAT AND UZZA, HE SHOULD SAY: THERE IS NO GOD BUT ALLAH

Book 15, Number 4041:

    Abu Huraira reported Allah's Messenger (may peace be upon him) as saying: He who takes an oath in the course of which he says: By Lat (and al-'Uzza), he should say: There is no god but Allah; and that it anyone says to his friend: "Come and I will gamble with you," he should pay sadaqa.

Book 15, Number 4042:

    This hadith has been narrated on the authority of Zuhri.

Book 15, Number 4043:

    Abd al-Rahman b. Samura reported Allah's Messenger (may peace be upon him) as saying: Do not swear by idols, nor by your fathers.

Chapter 3 : IT IS EXCELLENT TO BREAK THE VOW IF ONE FINDS IT BETTER DOING THAT WHICH IS AGAINST THIS VOW ONE SHOULD EXPIATE IT

Book 15, Number 4044:

    Abu Musa al-Ash'ari reported: I came to Allah's Apostle (may peace be upon him) along with a group of Ash'arites requesting to give us a mount. He (the Holy Prophet) said: By Allah, I cannot provide you with a mount, and there is nothing with me which I should give you as a ride. He (the narrator) said: We stayed there as long as Allah willed. Then there were brought to him (to the Holy Prophet) camels. He (the Holy Prophet) then ordered to give us three white humped camels, We started and said (or some of us said to the others): Allah will not bless us. We came to Allah's Messenger (may peace be upon him) begging him to provide us with riding camels. He swore that he could not provide us with a mount, but later on he provided us with that. They (some of the Prophet's Companions) came and informed him about this (rankling of theirs), whereupon he said: It was not I who provided you with a mount, but Allah has provided you with that. So far as I am concerned, by Allah, if He so wills, I would not swear, but if, later on, I would see better than it, I (would break the vow) and expiate it and do that which is better.

Book 15, Number 4045:

    Abu Musa reported: My friends sent me to Allah's Messenger (may peace be upon him) asking him to provide them with mounts as they were going along with him in jaish al-'Usrah (the army of destitutes or of meagre means or army setting out during the hard times and that is the occasion of the expedition of Tabuk) I said: Apostle of Allah, my friends have sent me to you so that you may provide them with mounts. He (the Holy Prophet) said: By Allah, I cannot provide you with anything to ride. And it so happened that he was at that time much perturbed. I little knew of it, so I came back with a heavy heart on account of the refusal of Allah's Messenger (may peace be upon him), and the fear that Allah's Messenger (may peace be upon him) might have some feelings against me. I returned to my friends and informed them about what Allah's Messenger (may peace be upon him) had said. I had hardly stayed for a little that I heard Bilal calling: 'Abdullah b. Qais. I responded to his call. He said: Hasten to Allah's Messenger (may peace be upon him), he is calling you, When I came to the Holy Prophet (may peace be upon him) he said: Take this pair,this pair, and this pair (i.e. six camels which he had bought from Sa'd), and take them to y,our friends and say: Verily Allah (or he said: Verily Allah's Messenger (may peace be upon him) has provided you with these animals. So ride upon them. Abu Musa said: I went along with them to my friends and said: Verily Allah's messenger (may peace be upon him) has provided you with these animals for riding; but by Allah, I shall not leave you until some of you go along with me to him who had heard the talk of Allah's Messenger (may peace be upon him) then I asked him for you, and his refusal for the first time, and then his granting them to me subsequently; so you should not think that I narrated to you something which he did not say. They said to me: By Allah, in our opinion you are certainly truthful, and we would do as you like. So Abu Musa went along withsome of the menfrom them until they came to those who had heard the words of Allah's Messenger (may, peace be upon him) and his refusal to (provide) them with (animals) ; and subsequently his granting (the animals) to them; and they narrated to them exactly as Abu Masa had narrated to them.

Book 15, Number 4046:

    Ayyub said: We were sitting in the company of Abu Musa that he called for food and it consisted of flesh of fowl. It was then that a person from Banu Tamim visited him. His complexion was red having the resemblance of a slave. He said to him: Come and (join me in food). He showed reluctance. He (Abu Masa) said: Come on, for I saw Allah's Messenger (may peace be upon him) eating it (fowl's meat), whereupon that person said: I saw it eating something (of filth and rubbish) and I found it repugnant and took an oath that I would never eat that. He (Abu Muds) said: Come, so that I would narrate to you about that (the incident pertaining to vow). (And he narrated thus) : I came to Allah's Messenger (may peace be upon him) along with a group of people belonging to the tribe of Ash'ari, asking him to provide us with riding camels. He (the Holy Prophet) said: By Allah, I cannot provide you with riding animals. And there is nothing with me with which I can provide you a mount. We stayed (for some time) there as Allah willed, and there was brought to Allah's Messenger (may peace be upon him) booty of camels. He called us and commanded that we should be given five white humped camels. As we were about to go back, some of us said to the other: As we made Allah's Messenger (may peace be upon him) forget oath, there would be no blessing for us (in his gift). We went back to him and said: Allah's Messenger, we came to you to provide us with riding animals and you took an oath that you would never equip us with mounts and then you have provided us with the riding beasts Allali's Messenger, have you forgotten ? Thereupon he said: I swear by Allah that if Allah so wills, I shall not swear an oath, and then consider something else to be better than it without making atonement for my oath and doing the thing that is better. So you go; Allah, the Exalted and Glorious, has given you riding animals.

Book 15, Number 4047:

    This hadith has been narrated on the authority of Abu Musa al-Ash'ari with a slight variation of words.

Book 15, Number 4048:

    Zahdam al-Jarmi reported : We were in the company of Abu Musa. The rest of the hadith is the same.

Book 15, Number 4049:

    Zahdam al-Jarmi reported: I visited Abu Musa and lie was eating fowl's meat. The rest of the hadith is the same with this addition that he (the Holy Prophet) said: By Allah, I did not forget it.

Book 15, Number 4050:

    Abu Musa al-Ash'ari reported: We came to Allah's Messenger (may peace be upon him) requesting him to provide us with riding camels. He (the Holy Prophet) said: There is nothing with me with which I should equip you. By Allah, I would not provide you with (riding camels). Then Allah's Messenger (may peace be upon him) sent to us three camels with spotted bumps. We said: We came to Allah's Messenger (may peace be upon him) asking him to equip us with riding animals. He took an oath that he could not equip us. We came to him and informed him. He said: By Allah, I do not take an oath, but when I find the other thing better than that, I do that which is better.

Book 15, Number 4051:

    Abu Musa reported: We walked on foot and came to Allah's Apostle (may peace he upon him) asking him to provide us with mounts. The rest of the hadith is the same.

Book 15, Number 4052:

    Abu Huraira reported: A person sat late in the night with Allah's Apostle (may peace be upon him), and then came to his family and found that his children had gone to sleep. His wife brought food for him. but he took an oath that he would not eat because of his children (having gone to sleep without food) He then gave precedence (of breaking the vow and then expiating it) and ate the food He then came to Allah s Messenger (may peace be upon him) and made mention of that to him, whereupon Allah's Messenger (may peace he upon him) said: He who took an oath and (later on) found something better than that should do that, and expiate for (breaking) his vow.

Book 15, Number 4053:

    Abu Huraira reported Allah's Messenger (may peace be upon him) as saying: He who took an oath and then found another thing better than (this) should expiate for the oath (broken) by him and do (the better thing).

Book 15, Number 4054:

    Abu Huraira reported Allah's Messenger (may peace be upon him) as saying: He who took an oath and (later on) found another thing better than that, he should do that which is better, and expiate for the vow (broken by him).

Book 15, Number 4055:

    This hadith is narrated on the authority of Suhail with the same chain of transmitters (with these words): "He should expiate for (breaking) the vow and do that which is better."

Book 15, Number 4056:

    Tamim b. Tarafa reported: A beggar came to 'Adi b. Hatim and he begged him to give him the price of a slave, or some portion of the price of the slave. He ('Adi) said: I have nothing to give you except my coat-of-mail and helmet. I will, however, write to my family to give that to you, but he did not agree to that. Thereupon 'Adi was enraged, and said: By Allah, I will not give you anything. The person (then) agreed to accept that, whereupon he said: By Allah, had I not heard Allah's Messenger (may peace be upon him) saying: "He who took an oath, but then found something more pious in the sight of Allah, he should (break the oath) and do that which is more pious," I would not have broken the oath (and thus paid you anything).

Book 15, Number 4057:

    'Adi b. Hatim reported Allah's Messenger (may peace be upon him) as saying: He who took an oath, but he found something else better than that, should do that which is better and break his oath.

Book 15, Number 4058:

    'Adi reported Allah's Messenger (may peace be upon him) as saying: When anyone amongst you takes an oath, but he finds (something) better than that he should expiate (the breaking of the oath), and do that which is better.

Book 15, Number 4059:

    This hadith is reported on the authority of Adi b. Hatim through another chain of transmitters.

Book 15, Number 4060:

    Tamim b. Tarafa reported that he beard 'Adi b. Hatim say that a person came to him and asked for one hundred dirhams. He ('Adi) said: You asked Me for one hundred dirhams and I am the son of Hatim; by Allah, I will not give you. But then he said: (I would have done that) if I had not heard Allah's Messenger (may peace be upon him) say: He who takes an oath, but then finds something better than that, should do that which is better.

Book 15, Number 4061:

    Tamim b. Tarafa reported: I heard 'Adi b. Hatim say that a person asked that and then narrated (the hadith) like one (mentioned above), but he made this addition: "Here are four hundred (dirhams) for you out of my gift."

Book 15, Number 4062:

    Abd al-Rahman b. Samura reported that Allah's Messenger (may peace be upon him) said to me: Abd al-Rahman b. Samura, don't ask for authority for if it is granted to you for asking for it, you would be commissioned for it (without having the support of Allah), but if you are granted it without your asking for it. You would be helped (by Allah) in it. And when you take an oath and find something else better than that, expiate for (breaking) your oath, and do that which is better. This hadith has also been transmitted on the authority of Ibn Farrukh.

Book 15, Number 4063:

    This hadith has been narrated on the authority of 'Abd al-Rahman b. Samura through another chain of transmitters but there is no mention of the word "authority".

Chapter 4 : THE OATH WOULD BE CONSIDERED ON THE BASIS OF THE INTENTION OF ONE WHO TAKES AN OATH

Book 15, Number 4064:

    Abu Haraira reported Allah's Messenger (may peace be upon him) as saying: Your oath should be about something regarding which your companion will believe you. 'Amr said: By which your companion will believe you.

Book 15, Number 4065:

    Abu Huraira reported Allah's Messenger (may peace be upon him) as saying: An oath is to be interpreted according to the intention of the one who takes it.

Chapter 5 : EXPRESSING THE WORDS "GOD WILLING" IN THE OATH

Book 15, Number 4066:

    Abu Huraira reported that (Hadrat) Sulaiman had sixty wives. He (one day) said: I will visit each one of them every night, and every one of them will become pregnant and give birth to a male child who will be a horseman and fight in the cause of Allah. But (it so happened) that none of them became pregnant except one, but she gave birth to an incomplete child. Thereupon Allah's Messenger (may peace be upon him) said: Had he said Insha' Allah (if God so wills), then every one of them would have given birth to a child who would have been a horseman and fought in the cause of Allah

Book 15, Number 4067:

    Abu Huraira reported Allah's Prophet (may peace be upon him) as saying that Sulaiman b. Dawud, the Apostle of Allah, observed: I will have an intercourse with seventy wives during the night; all of them will give birth to a male child who will fight in the cause of Allah. His companion or the ang I said to him : Say, "If God wills." But he (Hadrat Sulaimin) did not say so, and he forgot it. And none of his wives gave birth to a child, but one who gave birth to a premature child. Allah's Messenger (may peace be upon him) said: Had he said Insha' Allah (if God so will). he would not have failed and his desire would have been materialised.

Book 15, Number 4068:

    Abu Huraira reported this hadith from the Apostle of Allah (may peace be upon him) through another chain of transmitters.

Book 15, Number 4069:

    Abu Huraira reported that Sulaiman b. Dawud said: I will certainly have intercourse with seventy wives during the night, and every wife amongst them will give birth to a child, who will fight in the cause of Allah. It was said to him: Say: "Insha' Allah" (God willing), but he did not say so and forgot it. He went round them but none of them give birth to a child except one woman and that too was an incomplete person. Upon this Allah's Messenger (may peace be upon him) said: If he had said "Insha' Allah." he would not have failed, and his desire must have been fulfilled.

Book 15, Number 4070:

    Abu Huraira reported Allah's Apostle (may peace be upon him) as saying that Sulaiman b. Dawud (once) said: I will go round in the night to my ninety wives, and every one of them will give birth to a child (who will grow up) as a horseman and fight in the cause of Allah His companions said to him: Say "Insha' Allah." but he did not say Inshii' Allah. He went round all of them but none of them became pregnant but one, and she gave birth to a premature child. And by Him in Whose hand is the life of Muhammad, if he had said ,Insha' Allah (his wives would have given birth to the children who would all have grown up into horsemen and fought in the way of Allah). This hadith has been narrated on the authority of Abu Zinad with the same chain of transmitters with a variation of (these words): "Every one of them giving birth to a child, who would have fought in the cause of Allah."

Chapter 6 : IT IS FORBIDDEN TO PERSIST IN AN OATH WHICH CAUSES TROUBLE TO THE FAMILY, AND IS NOT LAWFUL

Book 15, Number 4071:

    Hammam b. Munabbih reported : This is what Abu Huraira reported to us from Allah's Messenger (may peace be upon him), and he narrated a hadith and (one) of them is that Allah's Messenger (may peace be upon him) said: I swear by Allah, it is more sinful in Allah's sight for one of you to persist in an oath regarding his family than payment of its expiation which Allah has imposed upon him (for breaking the oath).

Chapter 7 : WHAT A NON-BELIEVER SHOULD DO WITH HIS VOW WHEN HE EMBRACES ISLAM

Book 15, Number 4072:

    Ibn 'Umar reported that Umar (b. Khattab) said : Messenger of Allah, I had taken a vow during the days of Ignorance (Jahiliyya) that I would observe I'tikaf for a night in the Sacred Mosque. He (the Holy Prophet) said: Fulfil your vow.

Book 15, Number 4073:

    This hadith is transmitted on the authority of Ibn Umar with a slight variation of words.

Book 15, Number 4074:

    'Abdullah b. 'Umar reported that 'Umar b. Khattab asked the Messenger of Allah (may peace be upon him) as he was at ji'rana (a town near Mecca) on his way back from Ta'if: Messenger of Allah, I had taken a vow during the days of Ignorance that I would observe I'tikaf for one day in the Sacred Mosque. So what is your opinion? He said: Go and observe I'tikaf for a day. And Allah's Messenger (may peace be upon him) gave him a slave girl out of the one-fifth (of the spoils of war meant for the Holy Prophet). And when Allah's Messenger (inay peace be upon him) set the war prisoners free. 'Umar b. Khattab heard their voice as they were saying: Allah's Messenger (may peace be upon him) has set as free. He (Hadrat 'Umar) said: What is this? They said: Allah's Messenger (may peace be upon him) has set free the prisoners of war (which had fallen to the lot of people). Thereupon he (Hadrat 'Umar) said: Abdullah, go to that slave-girl and set her free.

Book 15, Number 4075:

    lbn 'Umar reported: When Allah's Apostle (may peace be upon him) came back from the Battle of Hunain, Umar asked Allah's Messenger (may peace be upon him) about the vow he had taken during the days of Ignorance that he would observe I'tikaf for a day. The rest of the hadith is the same.

Book 15, Number 4076:

    Nafi' reported: A mention of Allah's Messenger (may peace be upon him) observing 'Umra from ja'rina was made before Ibn 'Umar. He said: He did not enter into the state of Ihram from that (place), and Umar had taken a vow of observing I'tikaf for a night during the days of Ignorance. The rest of the hadith is the same.

Book 15, Number 4077:

    This hadith has been transmitted on the authority of Ibn Umar through another chain of transmitters but with a slight variation of words.

Chapter 8 : HOW SHOULD THE MASTERS TREAT THEIR SLAVES AND EXPIATION IF THEY SHOW HIGH-HANDEDNESS

Book 15, Number 4078:

    Zadhan Abl Umar reported: I came to Ibn 'Umar as he had granted freedom to a stave. He (the narrator further) said: He took hold of a wood or something like it from the earth and said: It (freedom of a slave) has not the reward evert equal to it, but the fact that I heard Allah's Messenger (way peace be upon him) say: He who slaps his slave or beats him, the expiation for it is that he should set him free.

Book 15, Number 4079:

    Zadhan reported that Ibn Umar called his slave and he found the marks (of beating) upon his back. He said to him: I have caused you pain. He said: No. But he (Ibn Umar) said: You are free. He then took hold of something from the earth and said: There is no reward for me even to the weight equal to it. I heard Allah's Messenger (may peace be upon him) as saying: He who beats a slave without cognizable offence of his or slaps him (without any serious fault), then expiation for it is that he should set him free.

Book 15, Number 4080:

    This hadith has been narrated through another chain of transmitters with a slight variation of words.

Book 15, Number 4081:

    Mu'awiya b. Suwaid reported: I slapped a slave belonging to us and then fled away. I came back just before noon and offered prayer behind my father. He called him (the slave) and me and said: Do as he has done to you. He granted pardon. He (my father) then said: We belonged to the family of Muqarrin during the lifetime of Allah's Messenger (may peace be upon him . and had only one slave-girl and one of us slapped her. This news reached Allah's Apostle (may peace be upon him) and he said: Set her free. They (the members of the family) said: There is no other servant except she. Thereupon he said: Then employ her and when you can afford to dispense with her services, then set her free.

Book 15, Number 4082:

    Hilal b. Yasaf reported that a person got angry and slapped his slave-girl. Thereupon Suwaid b. Muqarrin said to him: You could find no other part (to slap) but the prominent part of her face. See I was one of the seven sons of Muqarrin, and we had but only one slave-girl. The youngest of us slapped her, and Allah's Messenger (may peace be upon him) commanded us to set her free.2097

Book 15, Number 4083:

    Hilal b. Yasaf reported: We used to sell cloth in the house of Suwaid b. Muqarrin, the brother of Nu'man b. Muqarrin. There came out a slave-girl, and she said something to a person amongst us, and he slapped her. Suwaid was enraged-the rest of the hadlth is the same.

Book 15, Number 4084:

    Suwaid b. Muqarrin reported that he had a slave-girl and a person (one of the members of the family) slapped her, whereupon Suwaid said to him: Don't you know that it is forbidden (to strike the) face. He said: You see I was the seventh one amongst my brothers during the lifetime of Allah's Messenger (may peace be upon him), and we had but only one servant. One of us got enraged and slapped him. Thereupon Allah's Messenger (may peace be upon him) commanded us to set him free.

Book 15, Number 4085:

    Wahb b. Jarir reported: Shu'ba informed that Muhammad b. Munkadir said to me: What is your name? The rest of the hadith is the same.

Book 15, Number 4086:

    Abu Mas'ud al-Badri reported: I was beating my slave with a whip when I heard a voice behind me: Understand, Abu Masud; but I did not recognise the voice due to intense anger. He (Abu Mas'ud) reported: As he came near me (I found) that he was the Messenger of Allah (may peace be upon him) and he was saying: Bear in mind, Abu Mas'ud; bear in mind. Abu Mas'ud. He (Aba Maslad) said: threw the whip from my hand. Thereupon he (the Holy Prophet) said: Bear in mind, Abu Mas'ud; verily Allah has more dominance upon you than you have upon your slave. I (then) said: I would never beat my servant in future.

Book 15, Number 4087:

    This hadith has been narrated on the authorityo A'mash but with this variation of words: "There fell from my hand the whip on account of his (the Prophet's) awe."

Book 15, Number 4088:

    Abu Mas'ud al-Ansari reported: When I was beating my servant, I heard a voice behind me (saying): Abu Mas'ud, bear in mind Allah has more dominance over you than you have upon him. I turned and (found him) to be Allah's Messenger (may peace be upon him). I said: Allah's Messenger, I set him free for the sake of Allah. Thereupon he said: Had you not done that, (the gates of) Hell would have opened for you, or the fire would have burnt you.

Book 15, Number 4089:

    Abu Mas'ud reported that he had been beating his slave and he had been saying: I seek refuge with Allah, but he continued beating him, whereupon he said: I seek refuge with Allah's Messenger, and he spared him. Thereupon Allah's Messenger (may peace be upon him) said: By Allah, God has more dominance over you than you have over him (the slave). He said that he set him free. This hadith has been narrated on the authority of Shu'ba with the same chain of transmitters, but made no mention of (these words) of his: I seek refuge with Allah, I seek refuge with Allah's Messenger (may peace be upon him).

Chapter 9 : IT IS IMPROPER TO ACCUSE THE SLAVE OF ADULTERY

Book 15, Number 4090:

    Abu Huraira reported that Abu'l-Qasim (one of the names of Allah's Messenger [may peace be upon him]) said: He who accused his slave of adultery, punishment would be imposed upon him on the Day of Resurrection, except in case the accusation was as he had said.

Book 15, Number 4091:

    This hadith has been narrated on the authority of Ibn Ghazwan (and the words are): "I heard Abu'l-Qasim (may peace be upon him) as the Prophet of repentance."

Chapter 10 : FEEDING OF SLAVE WITH WHAT THE MASTER EATS HIMSELF AND CLOTHING HIM WITH WHAT HE WEARS HIMSELF AND NOT TO BURDEN HIM BEYOND CAPACITY

Book 15, Number 4092:

    Al-Ma'rur b. Suwaid said: We went to Abu Dharr (Ghifari) in Rabadha and he had a mantle over him, and his slave had one like it. We said: Abu Dharr, had you joined them together, it would have been a complete garment. Thereupon he said: There was an altercation between me and one of the persons among my brothers. His mother was a non-Arab. I reproached him for his mother. He complained against me to Allah's Apostle (may peace be upon him). As I met Allah's Apostle (may peace be upon him) he said: Abu Dharr, you are a person who still has (in him the remnants) of the days (of Ignorance). Thereupon I said: Allah's Messenger, he who abuses (other) persons, they abuse (in return) his father and mother. He (the Holy Prophet) said: Abu Dharr, you are a person who still has (the remnants) of Ignorance in him They (your servants and slaves) are your brothers. Allah has put them in your care, so feed them with what you eat, clothe them with what you wear. and do not burden them beyond their capacities; but if you burden them (with an unbearable burden), then help them (by sharing their extra burden).

Book 15, Number 4093:

    This hadith has been narrated on the authority of A'mash but with a slight variation of words, e.g. in the hadith transmitted on the authority of Zuhair and Abu Mu'awiya after his words (these words of the Holy Prophet) : " You are a person having the remnants of Ignorance in him." (these words also occur, that Abu Dharr) said: Even up to this time of my old age? He (the Holy Prophet) said: Yes. In the tradition transmitted on the authority of Abu Mu'awiya (the words are): "Yes, in this time of your old age." In the tradition transmitted on the authority of 'Isa (the words are): "If you burden him (with an unbearable burden), you should sell him (and get another slave who can easily undertake this burden)." In the hadith transmitted on the authority of Zuhair (the words are): "Help him in that (work)." In the hadith transmitted by Abu Mu'awiya (separately) there is no such word: Then sell him or help him." This hadith concludes with these words: "Do not burden him beyond his capacity."

Book 15, Number 4094:

    Ma'rur b. Suwaid reported: I saw Abu Dharr wearing clothes, and his slave wearing similar ones. I asked him about it, and he narrated that he had abused a person during the lifetime of Allah's Messenger (may peace be upoe.him) and he reproached him for his mother. That person came to Allah's Apostle (may peace be upon him) and made mention of that to him. Thereupon Allah's Apostle (may peace be upon him) said: You are a person who has (remnants of) Ignorance in him. Your slaves are brothers of yours. Allah has placed them in your hand, and he who has his brother under him, he should feed him with what he eats, and dress him with what he dresses himself, and do not burden them beyond their capacities, and if you burden them,(beyond their capacities), then help them.

Book 15, Number 4095:

    Abu Huraira reported Allah's Messenger (may peace be upon him) as saying: It is essential to feed the slave, clothe him (properly) and not burden him with work which is beyond his power.

Book 15, Number 4096:

    Abu Huraira reported Allah's Messenger (may peace be upon him) as saying: When the slave of anyone amongst you prepares food for him and he serves him after having sat close to (and undergoing the hardship of) heat and smoke, he should make him (the slave) sit along with him and make him eat (along with him), and if the food seems to run short, then he should spare some portion for him (from his own share)-(another narrator) Dawud said: "i.e. a morsel or two".4097

Chapter 11 : REWARD OF THE SALVE WHEN HE IS LOYAL TO HIS MASTER AND IS GOOD IN WORSHIPPING ALLAH

Book 15, Number 4097:

    Ibn Umar reported Allah's Messenger (may peace be upon him) as saying: When a slave looks to the welfare of his master and worships Allah well, he has two rewards for him.

Book 15, Number 4098:

    This hadith has been narrated on the authority of Ibn 'Umar through another chain of transmitters.

Book 15, Number 4099:

    Abu Huraira reported Allah's Messenger (may peace be upon him) as saying: For a faithful slave there are two rewards. By him in Whose hand is the life of Abu Huraira, but for Jibad in the cause of Allah, and Pilgrimage and kindness to my mother, I would have preferred to die as a slave. He (one of the narrators in the chain of transmitters) said: This news reached us that Abu Huraira did not perform Pilgrimage until his mother died for (keeping himself constantly) in her service. This hadith has been transmitted on the authority of Abu Tahir but with a slight variation of words.

Book 15, Number 4100:

    Abu Huraira reported Allah's Messenger (may peace be upon him) as saying: When a slave fulfils obligation of Allah and obligation of his master, he has two rewards for him. I narrated this to Ka'b, and Ka'b said: (Such a slave) has no accountability, nor has a poor believer.

Book 15, Number 4101:

    Abu Huraira reported Allah's Messenger (may peace be upon him) as saying: It is good for a slave that he worships Allah well, and serves his master (well). It is good for him.

Chapter 12 : HE WHO EMANCIPATES HIS SHARE IN THE SLAVE

Book 15, Number 4102:

    Ibn 'Umar reported Allah's Messenger (may peace be upon him) as saying: He who gives up his share in a slave, and has enough money to pay the full price of the slave, then full emancipation devolves upon him; but if he has not the money, then he emancipated what he emancipated.

Book 15, Number 4103:

    Ibn 'Umar reported Allah's Messenger (may peace be upon him) as saying: He who emancipates his share in the slave, it is his responsibility to secure full freedom for him provided he (the slave) has enough money to pay the (remaining) price, but it he has not so much money he would be emancipated to the extent that the first man emancipated.

Book 15, Number 4104:

    'Abdullah b. 'Umar reported Allah's Messenger (may peace be upon him) as saying: He who gives up his share in a slave, and he has money enough to meet the full price, a fair price for him should be fixed; otherwise be has emancipated him to the extent that he has emancipated.

Book 15, Number 4105:

    This hadith has been narrated through another chain of transmitters with a slight variation of words.

Book 15, Number 4106:

    Salim b. 'Abdullah reported on the authority of his father that Allah's Apostle (may peace be upon him) said: He who emancipates a slave (shared) by him and another one, his full price may be justly assessed from his wealth, neither less nor more, and he (the slave) would be emancipated if he (the partner) would be solvent enough (to forgo the amount of his share).

Book 15, Number 4107:

    Ibn 'Umar reported Allah's Apostle (may peace be upon him) as saying: He who gives up his share in a slave, the remaining (share) will be paid out of his riches if his riches are enough to meet the price of the slave.

Book 15, Number 4108:

    Abu Huraira reported Allah's Apostle (may peace be upon him) as saying: In case the slave is owned by two persons, and one of them emancipates him, he will guarantee (his full freedom).

Book 15, Number 4109:

    This hadith has been narrated on the authority of Shu'ba with the same chain of transmitters (and the words are): "He who emancipates a portion in a slave, he should (secure full) freedom for him from his property."

Book 15, Number 4110:

    Abu Huraira reported Allah's Apostle (may peace be upon him) as saying: He who emancipates his portion in a slave, full emancipation may be secured for him out of his property (if he has money) if he has enough property to meet (the required expenses), but if he has not enough property, the slave should be put to extra labour (in order to earn money for buying his freedom), but he should not be overburdened.

Book 15, Number 4111:

    This hadith has been narrated through another chain of transmitters (and the words are): "He will be required to work (in order to secure freedom) for that por- tion in which he has not been emancipated, without overburdening him."

Book 15, Number 4112:

    'Imran b. Husain reported that a person who had no other property emancipated six slaves of his at the time of his death. Allah's Messenger (may peace be upon him) called for them and divided them into three sections, cast lots amongst them, and set two free and kept four in slavery; and he (the Holy Prophet) spoke severely of him.

Book 15, Number 4113:

    This hadith has been narrated through another chain of transmitters (and the words are): "A person from among the Ansar willed away the freedom of six slaves of his at the time of his death."

Book 15, Number 4114:

    This hadith has been reported on the authority of Imran b. Husain through another chain of narrators.

Chapter 13 : THE PERMISSIBILITY OF BUYING A MUDABBAR SLAVE

Book 15, Number 4115:

    Jabir b. 'Abdullah said that a person among the Ansar declared his slave free after his death, as he had no other property. This news reached the Apostle of Allah (may peace be upon him) and he said: Who will buy him from me? And Nu'aim b. al-Nahham bought him for eight hundred dirhams and he handed them over to him, 'Amr (one of the narrators) said: I heard Jabir b. 'Abdullah as saying: He was a Coptic slave, and he died in the first year (of the Caliphate of 'Abdullah b. Zubair).

Book 15, Number 4116:

    Jabir is reported to have said: A person amongst the Ansar who had no other property declared a slave free after his death. Allah's Messenger (may peace be upon him) sold him, and Ibn al-Nahham bought him and he was a Coptic slave (who) died in the first year of the Caliphate of Ibn Zubair.

Book 15, Number 4117:

    A hadith like this has been narrated on the authority of Jabir through another chain of transmitters.

Book 15, Number 4118:

    This hadith has been narrated from Allah's Messenger (may peace be upon him) through other chains of transmitters.


BOOK 16: The Book Pertaining To The Oath, For Establishing The Resposibility Of Murders, Fighting, Requital And Blood-Wit (Kitab Al-Qasama Wal-Muharaba Wal-Qisas Wal-Diyat)

KITAB AL- KITAB AL-QASAMA WA'L-MUHARABA WA'L-QISAS WA'L-DIYAT
(THE BOOK PERTAINING TO THE OATH, FOR ESTABLISHING THE RESPONSIBILITY OF MURDERS FIGHTING, REQUITAL AND BLOOD-WIT)

Back
Chapter 1 : AL-OASAMAH

Book 16, Number 4119:

    Sahl b. Abu Hathma and Rafi' b. Khadij reported that 'Abdullah b. Sahl b. Zaid and Muhayyisa b. Mas'ud b. Zaid went out and as they reached Khaibar they were separated. Then Muhayyisa found 'Abdullah b. Sahl having been killed. He buried him, and then came to Allah's Messenger (may peace be upon him). They were Huwayyisa b. Mas'ud and 'Abd al-Rahman b. Sahl, and he (the latter one) was the youngest of the people (those three who had come to seek an interview with the Holy Prophet) began to talk before his Companions (had spoken). Thereupon Allah's Messenger (may peace be upon him) said: The eldest one (eldest in regard to age should speak). So he kept quiet, and his companions (Muhayyisa and Huwayyisa) began to speak, and he ('Abd al Rahman) spoke along with them and they narrated to Allah's Messenger (may peace be upon him) the murder of 'Abdullah b. Sahl. Thereupon he said to them: Are you prepared to take fifty oaths so that you may be entitled (to blood-wit) of your companion (or your man who has murdered)? They said: How can we take an oath on a matter which we have not witnessed? He (the Holy Prophet) said: Then the Jews will exonerate themselves by fifty oaths. They said: How can we accept the oaths of people who are unbelievers? When Allah's Messenger (may peace be upon him) saw that, he himself paid his blood-wit.

Book 16, Number 4120:

    Sahl. b. Abu Hathma and Rafi' b. Khadij reported that Muhayyisa b. Mas'ud and 'Abdullah b. Sahl went towards Khaibar and they separated near the palm-trees. 'Abdullah b. Sahl was killed. They accused the Jews (for this act). And there came to Allah's Apostle (may peace be upon him) his brother (the brother of the slain person) 'Abd al-Rahman and his cousins Huwayyisa and Muhayyisa; and 'Abd al-Rahman talked to him about the matter pertaining to (the murder of) his brother, and he was the youngest among them. Thereupon Allah's Messenger (may peace be upon him) said:Show regard for the greatness of the old, or he said: Let the eldest begin speaking. Then they (Huwayyisa and Muhayyisa) spoke about the matter of their companion (murder of their cousin, 'Abdullah b. Sahl). Thereupon Allah's Messenger (may peace be upon him) said: Let fifty (persons) among you take oath for levelling the charge (of murder) against a person amongst them, and he would be surrendered to you. They said: We have not witnessed this matter ourselves. How can we then take oath? He (the Holy Prophet) said: The Jews will exonerate themselves by the oaths of fifty of them. They said: Messenger of Allah, they are non-believing people. Thereupon Allah's Messenger (may peace be upon him) paid the blood wit for him. Sahl said: As one day I entered the fold a she-camel amongst those camels hit me with its leg.

Book 16, Number 4121:

    Sahl b. Abu Hathma has narrated this hadith through another chain of transmitters with a slight variation of words, but no mention has been made of the hitting by the she-camel.

Book 16, Number 4122:

    This hadith has been narrated on the authority of Sahl b. Abu Hathma through another chain of transmitters.

Book 16, Number 4123:

    Bushair b. Yasar reported that 'Abdullah b. Sahl b. Zaid and Muhayyisa b. Mas'ud b. Zaid, both of them were Ansar belonging to the tribe of Banu Haritha, set out to Khaibar during the lifetime of Allah's Messenger (may peace be upon him). There was peace during those days and (this place) was inhabited by the Jews. They parted company for their (respective) needs. 'Abdullab b. Sahl was killed, and his dead body was found in a tank. His companion (Muhayyisa) buried him and came to Medina, and the brothers of the slain 'Abd al-Rahman b. Sahl. and Muhayyisa and Huwayyisa told Allah's Messenger (may peace be upon him) the case of 'Abdullah and the place where he had been murdered. Bushair reported on the authority of one who had seen Allah's Messenger (may peace be upon him) that he had said to them: You take fifty oaths and you are entitled to blood-wit of (one) slain among you (or your companion). They said: Messenger of Allah, we neither saw (with our own eyes this murder) nor were we present there. Thereupon (Allah's Messenger is reported to have said): Then the Jews will exonerate themselves by taking fifty oaths. They said: Allah's Messenger, how can we accept the oath of unbelieving people? Bushair said that Allah's Messenger (may peace be upon him) paid the blood-wit himself.

Book 16, Number 4124:

    Bushair b. Yasar reported that a person from the Ansar belonging to the tribe of Banu Haritha who was called 'Abdullah b. Sahl b. Zaid set out and the son of his uncle called Muhayyisa b. Mas'ud b. Zaid, the rest of the hadith is the same up to the words: "Allah's Messenger (may peace be upon him) paid the blood-wit himself." Bushair b. Yasar reported that Sahl b. Abu Hathma said: One camel amongst the camels paid as blood-wit kicked me while I was in the (camel) enclosure.

Book 16, Number 4125:

    Bushair b. Yasar al-Ansari reported on the authority of Sahl b. Abu Hathma al-Ansari that some men (of his tribe went to Khaibar, and they were separated from one another, and they found one of them slain. The rest of the hadith is the same. And it was said in this connection: Allah's Messenger (may peace be him) did not approve of his blood go waste. He paid blood-wit of one hundred camels of Sadaqa.

Book 16, Number 4126:

    Abu Laila 'Abdullah b. 'Abd al-Rahman b. Sahl reported that the elderly persons of (the tribe) had informed Sahl b. Abu Hathma that 'Abdullah b. Sahl and Muhayyisa went out to Khaibar under some distress which had afflicted them. Muhayyisa came and informed that Abdutlah b. Sahl had been killed, and (his dead body) had been thrown in a well or in a ditch. He came to the Jews and said: By Allah, it is you who have killed him. They said: By Allah, we have not killed him. He then came to his people, and made mention of that to them. Then came he and his brother Huwayyisa, and he was older than he, and 'Abd al-Rahman b. Sahl. Then Muhayyisa went to speak, and it was he who had accompanied ('Abdullah) to Khaibar, whereupon Allah's Messenger (may peace be upon him) said to Muhayyisa: Observe greatness of the great (he meant the seniority of age). Then Huwayyisa spoke and then Muhayyisa also spoke. Thereupon Allah's Messenger (may peace be upon him) said: They should either pay blood-wit for your companion, or be prepared for war. Allah's Messenger (may peace be upon him) wrote about it to them (to the Jews). They wrote: Verily, by Allah, we have not killed him. Thereupon Allah's Messenger (may peace be upon him) said to Huwayyisa and Muhayyisa and Abd al-Rahman: Are you prepared to take oath in order to entitle yourselves for the blood-wit of your companion? They said: No. He (the Holy Prophet) said: Then the Jews will take oath (of their innocence). They said: They are not Muslims. Allah's Messenger (may peace be upon him), however, himself paid the blood-wit to them and sent to them one hundred camels until they entered into their houses, Sahl said: One red she-camel among them kicked me.

Book 16, Number 4127:

    Sulaiman b. Yasar, the freed slave of Maimuna, the wife of Allah's Apostle (may peace be upon him), narrated from one of the Ansari Companions of Allah's Messenger (may peace be upon him) that Allah's Messenger (may peace be upon him) retained (the practice) of Qasama as it was in the pre-Islamic days.

Book 16, Number 4128:

    This hadith has been narrated on the authority of Ibn Shihab with the same chain of transmitters but with this addition: "Allah's Messenger (may peace be upon him) decided (according to Qasama) between the persons of Ansar (and yours) about a slain (Muslim) for which they made claim against the Jews

Book 16, Number 4129:

    This hadith has been narrated on the authority of Abu Salama b. 'Abd al-Rahman and Sulaiman b. Yasar.

Chapter 2 : PERTAINING TO THE COMBATANTS AND APOSTATES

Book 16, Number 4130:

    Anas b. Malik reported that some people belonging (to the tribe) of 'Uraina came to Allah's Messenger (may peace be upon him) at Medina, but they found its climate uncogenial. So Allah's Messenger (may peace be upon him) said to them: If you so like, you may go to the camels of Sadaqa and drink their milk and urine. They did so and were all right. They then fell upon the shepherds and killed them and turned apostates from Islam and drove off the camels of the Prophet (may peace be upon him). This news reached Allah's Apostle (may peace be upon him) and he sent (people) on their track and they were (brought) and handed over to him. He (the Holy Prophet) got their hands cut off, and their feet, and put out their eyes, and threw them on the stony ground until they died.

Book 16, Number 4131:

    Anas reported: Eight men of the tribe of 'Ukl came to Allah's Messenger (may peace be upon him) and swore allegiance to him on Islam, but found the climate of that land uncogenial to their health and thus they became sick, and they made complaint of that to Allah's Messenger (may peace be upon him), and he said: Why don't you go to (the fold) of our camels along with our shepherd, and make use of their milk and urine. They said: Yes. They set out and drank their (camels') milk and urine and regained their health. They killed the shepherd and drove away the camels. This (news) reached Allah's Messenger (may peace be upon him) and he sent them on their track and they were caught and brought to him (the Holy Prophet). He commanded about them, and (thus) their hands and feet were cut off and their eyes were gouged and then they were thrown in the sun, until they died.
    This hadith has been narrated on the authority of Ibn al-Sabbah with a slight variation of words.

Book 16, Number 4132:

    Anas b. Malik reported that some people of the tribe of 'Ukl or 'Uraina came to Allah's Messenger (may peace be upon him), and they found the climate of Medina uncogenial. Allah's Messenger (may peace be upon him) commanded them to the milch she-camels and commanded them to drink their urine and their milk. The rest of the hadith is the same (and the concluding words are): "Their eyes were pierced, and they were thrown on the stony ground. They were asking for water, but they were not given water."

Book 16, Number 4133:

    Abu Qilaba reported: I was sitting behind 'Umar b. 'Abd al-'Aziz and he said to the people: What do you say about al-Qasama? Thereupon 'Anbasa said: Anas b Malik narrated to us such and such (hadith pertaining to al-Qasama). I said: This is what Anas had narrated to me: People came to Allah's Apostle (may peace be upon him), and the rest of the hadith is the same. When I (Abu Qilaba) finished (the narration of this hadith), 'Anbasa said: Hallowed be Allah. I said: Do you blame me (for telling a lie)? He ('Anbasa) said: No. This is how Anas b Malik narrated to us. O people of Syria, you would not be deprived of good, so long as such (a person) or one like him lives amongst you.

Book 16, Number 4134:

    Anas b. Malik reported: There came to Allah's Messenger (may peace be upon him) eight persons from the tribe of 'Ukl, but with this addition that he did not cauterise (the wounds which hid been inflicted upon them while punishing them).

Book 16, Number 4135:

    Anas reported: There came to Allah's Messenger (may peace be upon him) some ponple from 'Uraina. They embraced Islam and swore allegiance to him and there had spread at that time pleurisy. The rest of the hadith is the same (but with this addition): "There were by his (the Prophet's) side about twenty young men of the Ansar; he sent them (behind) them (culprits), and he also sent along with them one expert in following the track so that he might trace their footprints."

Book 16, Number 4136:

    This hadith has been narrated on the authority of Anas b. Malik through another chain of transmitters.

Book 16, Number 4137:

    Anas reported that Allah's Messenger (may peace be upon him) pierced their eyes because they had pierced the eyes of the shepherds.

Chapter 3 : THE JUSTIFICATION OF QISAS (RETRIBUTION) WHEN ONE IS KILLED WITH STONE OR ANY OTHER HEAVY THING AND KILLING OF A MALE FOR THE MURDER OF A FEMALE

Book 16, Number 4138:

    Anas b. Malik reported that a Jew killed a girl with a stone for her silver ornaments. She was brought to Allah's Messenger (may peace be upon him) when there was yet some life in her. He (the Holy Prophet) said to her: Has so and so killed you? She indicated with the nod of her head: No. He said for the second time, and she again said: No with the nod of her head. He asked for the third time, and she said: Yes with the nod of her head and Allah's Messenger (may peace be upon him) commanded to crush his head between two stones.

Book 16, Number 4139:

    This hadith has been narrated on the authority of Shu'ba with the same chain of transmitters and in the hadith narrated on the authority of Ibn Idris (the words are): "He (commanded) to crush his head between two stones."

Book 16, Number 4140:

    Anas reported that a Jew killed a girl of the Ansar for her ornaments and then threw her in a well and smashed her head with a stone. He was caught and brought to the Messenger of Allah (may peace be upon him), and he commanded that he should be stoned to death. So he was stoned until he died.

Book 16, Number 4141:

    This hadith has been narrated on the authority of Ayyub with the same chain of transmitters.

Book 16, Number 4142:

    Anas b. Malik reported: A girl was found with her head crushed between two stones. They asked her as to who had done that-has so and so (done it) until they mentioned a Jew. She indicated with the nod of her head (that it was so). So the Jew was caught, and he made confession (of his guilt). And Allah's Messenger (may peace be upon him) commanded that his head be smashed with stones.

Chapter 4 : WHEN ANYONE ATTACKS THE LIFE OF A PERSON, OR HIS LIMB, AND THE VICTIM WARDS OFF THE ATTACK AND IN SELFDEFENCE EITHER THE LIFE OF THE ASSAILANT IS LOST OR HIS LIMB BROKEN, THERE WOULD BE NO PENALTY ON THE VICTIM

Book 16, Number 4143:

    Imran b. Husain reported: Ya'la b. Munya or Ibn Umayya fought with a person, and the one bit the hand of the other. And he tried to draw his hand from his mouth and thus his foreteeth ware pulled out. They referred their dispute to Allah's Apostle (may peace be upon him), whereupon he said: Does any one of you bite as the camel bites? So there is no blood-wit for it.

Book 16, Number 4144:

    This hadith has been transmitted on the authority of Ya'la.

Book 16, Number 4145:

    'Imran b. Husain reported that a person bit the arm of another person; he pulled it out and his foretooth fell down. This matter was taken to Allah's Apostle (may peace be upon him), and he turned it down saying: Did you want to eat his flesh ?

Book 16, Number 4146:

    Safwan b. Ya'la reported that a person bit the arm of the servant of Ya'la b. Munya. He pulled it and his foretooth fell. The matter was referred to Allah's Apostle (may peace be upon him) and he turned it down and said: Did you intend to bite his hand, as the camel bites?

Book 16, Number 4147:

    'Imran b. Husain reported that a person bit the hand of a person. He withdrew his hand and his foretooth or foreteeth fell down. He (the man who lost his teeth) referred the matter to Allah's Messenger (may peace be upon him) and he said, What do you want me to do? Do you ask me that I should order him to put his hand in your month, and you should bite it as the camel bites? (If you want retaliation, then the only way out is) that you put your hand in his mouth (allow him) to bite that and then draw it away.

Book 16, Number 4148:

    Safwan b. Ya'la b. Munya reported on the authority of his father that there came to Allah's Apostle (may peace be upon him) a person who had bitten the hand of another person and who had withdrawn his hand (and as a result thereof) his foreteeth had fallen (those which had bitten). The Apostle of Allah (may peace be upon him) turned down his (claim), and said : Do you wish to bite as the camel bites ?

Book 16, Number 4149:

    Safwan b. Ya'la b. Umayya thus reported from his father: I participated in the expedition to Tabuk with Allah's Apostle (may peace be upon him). And Ya'la used to say : That was the most weighty of my deeds, in my opinion. Safwan said that Ya'la had stated : I had a servant ; he quarrelled with another person, and the one bit the hand of the other. ('Ata' said that Safwan had told him which one had bitten the hand of the other.) So he whose hand was bitten drew ill from (the mouth) of the one who had bitten it and (in this scuffle) one of his foreteeth was also drawn out. They both came to Allah's Apostle (may peace be upon him) and he declared his (claim for the compensation of) tooth as invalid.

Book 16, Number 4150:

    This hadith has been narrated on the authority of Juraij with the same chain of transmitters.

Chapter 5 : THE VERACITY OF RFTRIBUTION IN CASE OF TOOTH

Book 16, Number 4151:

    Anas reported that Umm Haritha, the sister of Rubayyi' (she was the father's sister of Hadrat Anas) injured a person (she broke his teeth). The dispute was referred to Allah's Apostle (may peace be upon him). Allah's Messenger (may peace be upon him) said: Retribution, retribution. Umm Rubayyi' said: Messenger of Allah, will retribution be taken from so and so? By Allah, it shall not be taken from her (i.e. from Umm Haritha). Thereupon Allah's Apostle said: Hallowed be Allah. O Umm Rubayyi', Qisas (retribution is a command, prescribed) in the Book of Allah. She said: No, by Allah, Qisas will never be taken from her; and she went on saying this until they (the relatives of the one who had been injured) accepted the blood-wit. Thereupon Allah's Messenger (may peace be upon him) said : Verily there are amongst the servants of Allah (such pious persons) who, if they take oath of Allah, He honours it.

Chapter 6 : WHEN IT IS PERMISSIBLE TO TAKE THE LIFE OF A MUSLIM

Book 16, Number 4152:

    'Abdullah (b. Mas'ud) reported Allah's Messenger (may peace be upon him) as saying : It is not permissible to take the life of a Muslim who bears testimony (to the fact that there is no god but Allah, and I am the Messenger of Allah, but in one of the three cases: the married adulterer, a life for life, and the deserter of his Din (Islam), abandoning the community.

Book 16, Number 4153:

    This hadith has been narrated on the authority of A'mash.

Book 16, Number 4154:

    'Abdullah (b. Mas'ud) reported: Allah's Messenger (may peace be upon him) stood up and said : By Him besides Whom there is no god but He, the blood of a Muslim who bears the testimony that there is no god but Allah, and I am His Messenger, may be lawfully shed only in case of three persons: the one who abandons Islam, and deserts the community [Ahmad, one of the narrators, is doubtful whether the Holy Prophet (may peace be upon him) used the word li'l-jama'ah or al-jama'ah), and the married adulterer, and life for life.

Book 16, Number 4155:

    This hadith has been reported on the authority of A'mash with the same chain of narrators but with a slight variation of words, i.e. he did not say : By Him besides Whom there is no god.

Chapter 7 : HE WHO SHEDS THE BLOOD FIRST OF ALL BEARS THE BURDEN OF ALL SUBSEQUENT MURDERS

Book 16, Number 4156:

    'Abdullah (b. Mas'ud) reported: Allah's Apostle (may peace be upon him) having said: No person who is killed unjustly, but the share of (this offence of his also) falls upon the first son of Adam, for he was the first to introduce killing.

Book 16, Number 4157:

    This hadith has been narrated on the authority of Jarir and 'Isa b. Yunus with a slight variation of words.

Chapter 8 : THE (CASES OF) BLOODSHED WOULD BE DECIDED FIRST OF ALL ON THE DAY OF JUDGMENT

Book 16, Number 4158:

    'Abdullah b. (Mas'ud) reported Allah's Messenger (may peace be upon him) as saying: The first (thing) that will be decided among people on the Day of Judgment will pertain to bloodshed.

Book 16, Number 4159:

    This hadith has been narrated on the authority of 'Abdullah through another chain of transmitters with a slight variation of words.

Book 16, Number 4160:

    Abu Bakra reported that (in the Farewell Address) Allah's Apostle (may peace be upon him) said: Time has completed a cycle and come to the state of the day when Allah created the heavens and the earth. The year is constituted of twelve months,of which four are sacred; three of them consecutive, viz. Dhu'l-Qa'da, Dhu'l- Hijja and Muharram, and also Rajab the month of Mudar which comes between Jumada and Sha'ban. He (the Holy Prophet) then said: which month is this? We said Allah and His Messenger know best. He (the narrator) said: He (the Holy Prophet) remained silent for some time until we thought that he would give it a name other than that (by which it was known). He said: Is it not Dha'l-Hijja? We said: Yes. He (the Holy Prophet) said: Which city is this? We said: Allah and His Messenger know best. He (the Holy Prophety remained silent until we thought that he would give it another name. He (the Holy Prophet) said: Is it not the Balda (the city of Mecca)? We said: Yes. He said: What day is this? We said: Allah and His Messenger know best. He (the Holy Prophet) remained silent until we thought that he would give it another name. He said: Is it not the Day of Sacrifice? We said: Allah's Messenger. yes. Thereupon he said: Your blood, your property (Muhammad, one of the narrators, said: I think, he also said this) and your honour are sacred to you like the sacredness of this day of yours, in this city of yours, and in this month of yours. You will soon meet your Lord and He will ask you about your deeds. So do not turn after me unbelievers (or misguided), some of you striking the necks of the others. Behold I let him who is present convey to him who is absent, for many a one whom a message is conveyed has a more retentive memory than one who hears. He again said: Behold! have I not delivered (the message) to you? This hadith has been narrated through another chain of transmitters, but with a slight variation of words.

Book 16, Number 4161:

    Abu Bakra reported that when it was that day (the 10th of Dhu'l-Hijja) he mounted his camel and a person caught its nosestring, whereupon he said: Do you know which day is this? They said: Allah and His Messenger know best. (The Holy Prophet [may peace be upon him] kept silent) until we thought that he would give that another name. He said: Is it not the day of Nahr (Sacrifice) (10th of Dhu'l- Hijja)? We said: Allah's Messenger, yes. He (again) said: Which month is it? We said: Allah and His Messenger knows best. He said: Is it not Dhu'l-Hijja? We said: Allah's Messenger, yes. He said: Which city is this? We said: Allah and His Messenger know best. He (the narrator) said (that the Holy Prophet kept silent until we thought that he would give it another name besides its (original) name. He said: Is it not Balda (the city of Mecca)? We said: Yes, Allah's Messenger. He (then) said: Verily your blood (lives) and your property and your honour are as sacred unto you as sacred is this day of yours, in this month of yours, in this city of yours. Let him who is present convey it to one who is absent. He then turned his attention towards two multicoloured (black and white) rams and slaughtered them, and two goats, and distributed them amongst us.

Book 16, Number 4162:

    Abu Bakra reported that when it was the day of (Dhu'l-Hijja) Allah's Apostle (may peace be upon him) mounted the camel and addressed and a person had been holding its nosestring. The rest of the hadith is the same.

Book 16, Number 4163:

    This hadith has been narrated on the authority of Abu Bakra through another chain of transmitters (and the words are):" Allah's Messenger (may peace be upon him) addressed us on the day of Nahr (Sacrifice) and said: What day is this? And the rest of the hadith is the same except that he did not make mention of "your honour," and also did not make mention of this: He then turned his attention towards two rams and what follows, and in a hadith (the words pertaining to sacred- ness are recorded in this way): "Like the sacredness of this day of yours, in this month of yours, in this city of yours to the day when you will meet your Lord. Behold, have I not conveyed (the Message of God) ? They said: Yes. He said: O Allah, bear witness."

Chapter 9 : THE CONFESSION OF MURDER IS HELD VALID AND THE PERSON WHOSE MAN IS KILLED IS ENTITLED TO GET RETRIBUTION. THE OFFENDER HAS A RIGHT TO BEG FOR REMISSION

Book 16, Number 4164:

    'Alqama b. Wa'il reported on the authority of his-father: While I was sitting in the company of Allah's Apostle (may peace be upon him), a person came there dragging another one with the help of a strap and said: Allah's Messenger, this man has killed my brother. Allah's Messenger (may peace be upon him) said to him: Did you kill him? And the other man said: (In case he did not make a confession of this, I shall brine, a witness against him). He (the murderer) said: Yes, I have killed him. He (the Holy Prophet) said: Why did you kill him? He said: I and he won striking down the leaves of a tree and he abused me and enraged me, and to I struck his head with an axe and killed him, whereupon Allah's Messenger (may peace be upon him) said: Have you anything with you to pay blood-wit on your behalf? He said: I do not possess any property but this robe of mine and this axe of mine. He (the Holy, Prophet) said: Do you think your people will pay ransom for you? He said: I am more insignificant among my people than this (that I would not be able to get this benefit from my tribe). He (the Holy Prophet) threw the strap towards him (the claimant of the blood-wit) saying: Take away your man. The man took him away, and as he returned, Allah's Messenger (may peace be upon him) said: If he kills him, he will be like him. He returned and said: Allah's Messenger, it has reached me that you have said that "If he killed him, he would be like him." I caught hold of him according to your command, whereupon Allah's Messenger (may peace be upon him) said: Don't you like that he should take upon him (the burden) of your sin and the sin of your companion (your brother)? He said: Allah's Apostle, why not? The Messenger of Allah (may peace be.upon him) said: If it is so, then let it be. He threw away the strap (around the offender) and set him free.

Book 16, Number 4165:

    'Alaqama b. Wa'il reported on the authority of his father that a person was brought to the Messenger of Allah (may peace be upon him) who had killed another person, and the heir of the person slain had dragged him (to the Holy Prophet) with a strap around his neck. As he turned away Allah's Messenger (may peace be upon him) said: The killer and the killed are (doomed) to fire. A person came to the other person (the heir of the deceased) and he reported to him the words of the Messenger of Allah (may peace be upon him), and so he let him off. Isma'il b. Salim said: I made a mention of it to Habib b. Abu Thabit and he said: Ibn Ashwa' reported to me that Allah's Apostle (may peace be upon him) had asked him to pardon him, but he refused.

Chapter 10 : BLOOD-WIT OF THE CHILD IN THE WOMB, AND THE ESSENTIALITY OF BLOOD-WIT IN CASE OF UNINTENTIONAL MURDER AND IN CASE OF THE QUASI-INTENTIONAL MURDER

Book 16, Number 4166:

    Abu Huraira reported that among two women of the tribe of Hudhail one flung a stone upon the other causing an abortion to her Allah's Apostle (may peace he upon him) gave judgment that a male or a female slave of best quality be given as compensation.

Book 16, Number 4167:

    Abu Huraira reported that Allah's Messenger (may peace be upon him) gave judgment in case of the abortion of a woman of Banu Lihyan (that the offender and near relative should give compensation in the form of) good quality of a slave or a slave-girl. And the woman about whom the judgment was given for compensation died and thereupon Allah's Messenger (may peace be upon him) gave judgment that her inheritance goes to her sons and her husband, and the payment of the blood-wit lies with the family of (one who struck her).

Book 16, Number 4168:

    Abu Huraira reported that two women of the tribe of Hudhail fought with each other and one of them flung a stone at the other, killing her and what was in her womb. The case was brought to Allah's Messenger (may peace be upon him) and he gave judgment that the diyat (indemnity) of her unborn child is a male or a female slave of the best quality, and he also decided that the diyat of the woman is to be paid by her relative on the father's side, and he (the Holy Prophet) made her sons and those who were with them her heirs. Hamal b. al-Nabigha al-Hudhali said: Messenger of Allah, why should I play blood-wit for one who neither drank, nor ate, nor spoke, nor made any noise ; it is like a nonentity (it is, therefore, not justifiable to demand blood-wit for it). Thereupon Allah's Messenger (may peace be upon him) said: He seems to be one of the brothers of soothsavers on account of the rhymed speech which he has composed.

Book 16, Number 4169:

    Abu Huraira reported that two women fought-the rest of the hadith is the same but herein no mention has been made of: He made her son and those who were with them her heirs. Someone said: Why should we pay blood-wit? And he did not name Hamal b. Malik.

Book 16, Number 4170:

    Al-Mughira b. Shu'ba reported that a woman struck her co-wife with a tent-pole and she was pregnant and she killed her. One of them belonged to the tribe of Lihyan. Allah's Messenger (may peace be upon him) made the relatives of the murderer responsible for the payment of blood-wit on her behalf, and fixed a slave or a female slave as the indemnity for what was in her womb. One of the persons amongst the relatives of the murderer said: Should we pay indemnity for one who,neither ate, nor drank, nor made any noise, who was just like a nonentity? Thereupon Allah's Messenger (may peace be upon him) remarked: He speaks rhymed phrases like the people of the desert. He did impose indemnity upon them.

Book 16, Number 4171:

    Al-Mughira b. Shu'ba reported: A woman killed her fellow-wife with a tent-pole. Her case was brought to Allah's Messenger (may peace be upon him), and he gave judgment that blood-wit should be paid by the relatives (of the offender) on the father's side. And as she was pregnant, he decided regarding her unborn child that a male or a female slave of good quality be given. Some of her offender's) relatives said: Should we make compensation for one who never ate, nor drank, nor made any noise, who was like a nonentity? Thereupon Allah's Messenger (may peace be upon him) said: He was talking rhymed phrases like the rhymed phrases of desert Arabs.

Book 16, Number 4172:

    This hadith has been narrated on the authority of Mansur with the same chain of transmitters.

Book 16, Number 4173:

    Mansur transmitted this hadith with a slight variation of words.

Book 16, Number 4174:

    Miswar b. Makhrama reported that 'Umar b. Khattab consulted people about the diyat of abortion of an unboam child. Mughira b. Shu'ba said: I bear witness to the fact that Allah's Messenger (may peace be upon him) gave judgment about it that a good quality of slave or female slave should be given for it. Thereupon 'Umar said: Bring one who may bear witness to you. Then Muhammad b. Maslama bore witness to him.


BOOK 17: The Book Pertaining to Punishments Prescribed by Islam (Kitab Al-Hudud)

KITAB AL-HUDUD
(THE BOOK PERTAINING TO PUNISHMENTS PRESCRIBED BY ISLAM)

Back
INTRODUCTION

    The penal laws of Islam are called Hudud in the Hadith and Fiqh. This word is the plural of Hadd, which means prevention, hindrance, restraint, prohibition, and hence a restrictive ordinance or statute of God, respecting things lawful and unlawful.

    Punishments are divided into two classes, one of which is called Hadd and the other Ta'zir. The Hadd is a measure of punishment defined by the Qur'an and the Sunnah. In Ta'zir, the court, is allowed to use its discretion in regard to the form and measure in which such punishment is to be inflicted.

    Punishments by way of Hadd are of the following forms: death by stoning, amputation of a limb or limbs, flogging by one hundred or eighty strokes. They are prescribed respectively for the following offences: adultery committed by married persons, theft, highway robbery, drunkenness and slander imputing unchastity to women.

    The punishments described above are the maximum punishments for the above mentioned crimes. These can be reduced keeping in view the circumstances in which the crimes were committed, the nature of the evidence, and the motive of the criminal with which he committed the crime.

Chapter 1 : PUNISHMENT FOR THEFT AND THE MINIMUM LIMIT ACCORDING TO WHICH IT IS IMPOSED UPON AN OFFENDER

Book 17, Number 4175:

    'A'isha reported that Allah's Messenger (may peace be upon him) cut off the hand of a thief for a quarter of a dinar rid upwards.

Book 17, Number 4176:

    This hadith has been transmitted on the authority of Zuhri.

Book 17, Number 4177:

    'A'isha reported Allah's Messenger (may peace be upon him) as saying: The hand of a thief should not be cut off but for a quarter of a dinar and upwards.

Book 17, Number 4178:

    'A'isha reported: I heard Allah's Messenger (may peace be upon him) as saying: The hand (of a thief) should not be cut off but for a quarter of a dinar and what is above that.

Book 17, Number 4179:

    'A'isha reported that she heard Allah's Apostle (may peace be upon him) as saying: The hand of the thief may not be cut off but for a quarter of a dinar and upwards.

Book 17, Number 4180:

    A hadith like this has been narrated on the authority of Yazid b. 'Abdullah b. al-Had with the same chain of transmitters.

Book 17, Number 4181:

    'A'isha reported that during the lifetime of Allah's Messenger (may peace be upon him) the hand of the thief was not cut off for less than the price of a shield, iron coat or armour and both of them are valuable.

Book 17, Number 4182:

    This hadith has been narrated on the authority of Hisham through another chain of transmitters, and in the hadith narrated by 'Abd al-Rahim and Abu Usama (the words are): "That (the shield) was valuable those days."

Book 17, Number 4183:

    Ibn 'Umar reported that Allah's Messenger (may peace upon him) cut off the hand of a thief (in case of the theft) of a shield the price of which was three dirhams.

Book 17, Number 4184:

    This hadith has been narrated on the authority of Ibn 'Umar through some other chains of transmitters but with a slight variation of words.

Book 17, Number 4185:

    Abu Huraira reported Allah's Messenger (may peace be upon him) as saying: Let there be the curse of Allah upon the thief who steals an egg and his hand is cut off, and steals a rope and his hand is cut off.

Book 17, Number 4186:

    This hadith is narrated on the authority of A'mash with the same chain of transmitters with a slight variation of words.

Chapter 2 : PROHIBITION OF IN RERCESSION REGARDING PRESCRIBED PUNISHMENT FOR THEFT AND OTHER (CRIMES) IN CASE OF IMPORTANT PERSONS

Book 17, Number 4187:

    'A'isha reported that the Quraish had been anxious about the Makhzumi woman who had committed theft, and said: Who will speak to Allah's Messenger (may peace be upon him) about her? They said: Who dare it, but Usama, the loved one of Allah's Messenger (may peace be upon him) ? So Usama spoke to him. Thereupon Allah's Messenger (may peace be upon him) said: Do you intercede regarding one of the punishments prescribed by Allah? He then stood up and addressed (people) saying: O people, those who have gone before you were destroyed, because if any one of high rank committed theft amongst them, they spared him; and it anyone of low rank committed theft, they inflicted the prescribed punishment upon him. By Allah, if Fatima, daughter of Muhammad, were to steal, I would have her hand cut off. In the hadith transmitted on the authority of Ibn Rumh (the words are): "Verily those before you perished."

Book 17, Number 4188:

    'A'isha, the wife of Allah's Apostle (may peace be upon him), reported that the Quraish were concerned about the woman who had committed theft during the lifetime of Allah's Apostle (may peace be upon him), in the expedition of Victory (of Mecca). They said: Who would speak to Allah's Messenger (may peace be upon him) about her? They (again) said: Who can dare do this but Usama b Zaid, the loved one of Allah's Messenger (may peace be upon him) ? She was brought to Allah's Messenger (may peace be upon him) and Usama b. Zaid spoke about her to him (interceded on her behalf). The colour of the face of Allah's Messenger (may peace be upon him) changed, and he said: Do you intercede in one of the prescribed punishments of Allah? He (Usama) said: 'Messenger of Allah, seek forgiveness for me. When it was dusk. Allah's Messenger (may peace be upon him) stood up and gave an address. He (first) glorified Allah as He deserves, and then said: Now to our topic. This (injustice) destroyed those before you that when any one of (high) rank committed theft among them, they spared him, and when any weak one among them committed theft, they inflicted the prescribed punishment upon him. By Him in Whose Hand is my life, even if Fatima daughter of Muhammad were to commit theft, I would have cut off her hand. He (the Holy Prophet) then commanded about that woman who had committed theft, and her hand was cut off. 'A'isha (further) said: Hers was a good respentance, and she later on married and used to come to me after that, and I conveyed her needs (and problems) to Allah's Messenger (may peace be upon him).

Book 17, Number 4189:

    'A'isha reported that a woman from the tribe of Makhzum used to borrow things (from people) and then denied (having taken them). Allah's Apostle (may peace be upon him) commanded her hand to be cut off. Her relatives came to Usama b. Zaid and spoke to him (requesting him to intercede on her behalf). He spoke to Allah's Messenger (may peace be upon him) about her. The rest of the hadith is the same.

Book 17, Number 4190:

    Jaibir reported that a woman from the tribe of Makhzum committed theft. She was brought to Allah's Apostle (may peace be upon him) and she sought refuge (intercession) from Umm Salama, the wife of Allah's Apostle (may peace be upon him). Thereupon Allah's Apostle (may peace be upon him) said: By Allah, even if she were Fatima, I would have her hand cut off. And thus her hand was cut off.

Chapter 3 : PRESCRIBED PUNISHMENT FOR AN ADULTERER AND AN ADULTERESS

Book 17, Number 4191:

    'Ubada b. as-Samit reported: Allah's Messenger (may peace be upon him) as saying: Receive (teaching) from me, receive (teaching) from me. Allah has ordained a way for those (women). When an unmarried male commits adultery with an unmarried female (they should receive) one hundred lashes and banishment for one year. And in case of married male committing adultery with a married female, they shall receive one hundred lashes and be stoned to death.

Book 17, Number 4192:

    'Ubada b. as-Samit reported that whenever Allah's Apostle (may peace be upon him) received revelation, he felt its rigour and the complexion of his face changed. One day revelation descended upon him, he felt the same rigour. When it was over and he felt relief, he said: Take from me. Verily Allah has ordained a way for them (the women who commit fornication),: (When) a married man (commits adultery) with a married woman, and an unmarried male with an unmarried woman, then in case of married (persons) there is (a punishment) of one hundred lashes and then stoning (to death). And in case of unmarried persons, (the punishment) is one hundred lashes and exile for one year.

Book 17, Number 4193:

    This hadith has been reported on the authority of Qatada with the same chain of transmitters except with this variation that the unmarried is to be lashed and exiled, and the married one is to be lashed and stoned. There is neither any mention of one year nor that of one hundred.

Chapter 4 : STONING OF A MARRIED ADULTERER

Book 17, Number 4194:

    'Abdullah b. 'Abbas reported that 'Umar b. Khattab sat on the pulpit of Allah's Messenger (may peace be upon him) and said: Verily Allah sent Muhammad (may peace be upon him) with truth and He sent down the Book upon him, and the verse of stoning was included in what was sent down to him. We recited it, retained it in our memory and understood it. Allah's Messenger (may peace be upon him) awarded the punishment of stoning to death (to the married adulterer and adulteress) and, after him, we also awarded the punishment of stoning, I am afraid that with the lapse of time, the people (may forget it) and may say: We do not find the punishment of stoning in the Book of Allah, and thus go astray by abandoning this duty prescribed by Allah. Stoning is a duty laid down in Allah's Book for married men and women who commit adultery when proof is established, or it there is pregnancy, or a confession.

Book 17, Number 4195:

    This hadith has been narrated on the authority of Zuhri with the same chain of transmitters.

Chapter 5 : HE WHO CONFESSES HIS GUILT OF ADULTERY

Book 17, Number 4196:

    Abu Huraira reported that a person from amongst the Muslims came to Allah's Messenger (may peace be upon him) while he was in the mosque. He called him saying: Allah's Messenger. I have committed adultery. He (the Holy Prophet) turned away from him, He (again) came round facing him and said to him: Allah's Messenger, I have committed adultery. He (the Holy Prophet) turned away until he did that four times, and as he testified four times against his own self, Allah's Messenger (may peace be upon him) called him and said: Are you mad? He said: No. He (again) said: Are you married ? He said: Yes. Thereupon Allah's Messenger (may peace be upon him) said : Take him and stone him. Ibn Shihab (one of the narrators) said: One who had heard Jabir b. 'Abdullah saying this informed me thus: I was one of those who stoned him. We stoned him at the place of prayer (either that of 'Id or a funeral). When the stones hurt him, he ran away. We caught him in the Harra and stoned him (to death). This hadith has been narrated through another chain of transmitters.

Book 17, Number 4197:

    This hadith has been narrated on the authority of Abu Huraira through other chains of transmitters.

Book 17, Number 4198:

    Jabir b. Samura reported: As he was being brought to Allah's Apostle (may peace be upon him) I saw Ma'iz b. Malik-a short-statured person with strong sinews, having no cloak around him. He bore witness against his own self four times that he had committed adultery, whereupon Allah's Messenger (may peace be upon him) said: Perhaps (you kissed her or embraced her). He said: No. by God, one deviating (from the path of virtue) has committed adultery. He then got him stoned (to death), and then delivered the address: Behold, as we set out for Jihad in the cause of Allah, one of you lagged behind and shrieked like the bleating of a male goat, and gave a small quantity of milk. By Allah, in case I get hold of him, I shall certainly punish him.

Book 17, Number 4199:

    Jabir b. Samura reported that there was brought to Allah's Messenger (may peace be upon him) a short-statured person with thick uncombed hair, muscular body, having a mantle around him and he had committed adultery. He turned him away twice and then made pronouncement about him and he was stoned. Then Allah's Messenger (may peace be upon him) said: We set out for Jihad in the cause of Allah and one of you lagged behind and shrieked like the bleating of a male goat and one of then (goats' gave a small quantity of milk. In case Allah gives me power over one of them, I will punish him (in such a way that it may have a deterrent effect upon others). In another narration transmitted on the authority of Sa'id b Jubair (the words are) ,that He (the Holy Prophet) turned him away four times."

Book 17, Number 4200:

    This hadith has been narrated on the authority of Jabir b. Samura through another chain of transmitters with the difference that along with the mentioning (of the fact) that he (the Holy Prophet) turned him away twice, or thrice.

Book 17, Number 4201:

    Ibn Abbas reported that Allah's Apostle (may peace be upon him) said to Ma'iz b. Malik : Is it true what has reached me about you ? He said : What has reached you about me ? He said: It has reached me that you have committed (adultery) with the slave-girl of so and so? He said: Yes. He (the narrator) said: He testified four times. He (the Holy Prophet) then made pronouncement about him and he was stoned (to death).

Book 17, Number 4202:

    Abu Sa'id reported that a person belonging to the clan of Aslam, who was called Ma,iz b. Malik, came to Allah's Messenger (may peace be upon him) and said: I have committed immorality (adultery), so inflict punishment upon me. Allah's Apostle (may peace be upon him) turned him away again and again. He then asked his people (about the state of his mind). They said: We do not know of any ailment of his except that he has committed something about which he thinks that he would not be able to relieve himself of its burden but with the Hadd being imposed upon him. He (Ma'iz) came back to Allah's Apostle (may peace be upon him) and he commanded us to stone him. We took him to the Baqi' al-Gharqad (the graveyard of Medina). We neither tied him nor dug any ditch for him. We attacked him with bones, with clods and pebbles. He ran away and we ran after him until he came upon the ston ground (al-Harra) and stopped there and we stoned him with heavy stones of the Harra until he became motionless (lie died). He (the Holy Prophet) then addressed (us) in the evening saying Whenever we set forth on an expedition in the cause of Allah, some one of those connected with us shrieked (under the pressure of sexual lust) as the bleating of a male goat. It is essential that if a person having committed such a deed is brought to me, I should punish him. He neither begged forgiveness for him nor cursed him.

Book 17, Number 4203:

    Dawud narrated the hadith with the same chain of transmitters (and the words are) : Allah's Apostle (may peace be upon him) stood tip (to address the audience) in the evening and praised Allah, glorified Him and then said : What about the people, that as we set out on an expedition, one of you remained behind us and he shrieked like the bleating of a male goat ? But he did not mention (these words) :People connected with us."

Book 17, Number 4204:

    This hadith has been narrated on the authority of Dawud with the same chain of transmitters but with this variation that in the hadith narrated by Sufyan (the words are) : "He made a confession of having committed adultery, thrice."

Book 17, Number 4205:

    Sulaiman b. Buraida reported on the authority of his father that Ma,iz b. Malik came to Allah's Apostle (may peace be upon him) and said to him : Messenger of Allah, purify me, whereupon he said: Woe be upon you, go back, ask forgiveness of Allah and turn to Him in repentance. He (the narrator) said that he went back not far, then came and said: Allah's Messenger, purify me. whereupon Allah's Messenger (may peace be upon him) said : Woe be upon you, go back and ask forgiveness of Allah and turn to Him in repentance. He (the narrator) said that he went back not far, when he came and said: Allah's Messenger, purify me. Allah's Apostle (may peace be upon him) said as he had said before. When it was the fourth time, Allah's Messenger (may, peace be upon him) said : From what am I to purify you ? He said : From adultery, Allah's Messenger (may peace be upon him) asked if he had been mad. He was informed that he was not mad. He said: Has he drunk wine ? A person stood up and smelt his breath but noticed no smell of wine. Thereupon Allah's Messenger (may peace be upon him) said: Have you committed adultery ? He said : Yes. He made pronouncement about him and he was stoned to death. The people had been (divided) into two groups about him (Ma'iz). One of them said : He has been undone for his sins had encompassed him, whereas another said : There is no repentance more excellent than the repentance of Ma'iz, for he came to Allah's Apostle (may peace be upon him) and placing his hand in his (in the Holy Prophet's) hand said : Kill me with stones. (This controversy about Ma'iz) remained for two or three days. Then came Allah's Messenger (may peace be upon him) to them (his Companions) as they were sitting. He greeted them with salutation and then sat down and said: Ask forgiveness for Ma'iz b. Malik. They said : May Allah forgive Ma'iz b. Malik. Thereupon Allah's Messenger (may peace be upon him) said : He (Ma'iz) has made such a repentance that if that were to be divided among a people, it would have been enough for all of them. He (the narrator) said : Then a woman of Ghamid, a branch of Azd, came to him and said: Messenger of of Allah, purify me, whereupon he said : Woe be upon you ; go back and beg forgiveness from Allah and turn to Him in repentance. She said : I find that you intend to send me back as you sent back Ma'iz. b. Malik. He (the Holy, Prophet) said : What has happened to you ? She said that she had become pregnant as a result of fornication. He (the Holy Prophet) said : Is it you (who has done that) ? She said : Yes. He (the Holy Prophet) said to her : (You will not be punished) until you deliver what is there in your womb. One of the Ansar became responsible for her until she was delivered (of the child). He (that Ansari) came to Allah's Apostle (may peace be upon him) and said the woman of Ghamid has given birth to a child. He (the Holy Prophet) said : In that case we shall not stone her and so leave her infant with none to suckle him. One of the Ansar got up and said : Allah's Apostle, let the responsibility of his suckling be upon me. She was then stoned to death.

Book 17, Number 4206:

    'Abdullah b. Buraida reported on the authority of his father that Ma'iz b. Malik al-Aslami came to Allah's Messenger (may peace be upon him) and said : Allah's Messenger, I have wronged myself ; I have committed adultery and I earnestly desire that you should purify me. He turned him away. On the following day, he (Ma'iz) again came to him and said : Allah's Messenger, I have committed adultery. Allah's Messenger (may peace be upon him) turned him away for the second time, and sent him to his people saying: Do you know if there is anything wrong with his mind. They denied of any such thing in him and said: We do not know him but as a wise good man among us, so far as we can judge. He (Ma'iz) came for the third time, and he (the Holy Prophet) sent him as he had done before. He asked about him and they informed him that there was nothing wrong with him or with his mind. When it was the fourth time, a ditch was dug for him and he (the Holy Prophet) pronounced judg- ment about him and he wis stoned. He (the narrator) said : There came to him (the Holy Prophet) a woman from Ghamid and said : Allah's Messenger, I have committed adultery, so purify me. He (the Holy Prophet) turned her away. On the following day she said : Allah's Messenger, Why do you turn me away ? Perhaps, you turn me away as you turned away Ma'iz. By Allah, I have become pregnant. He said: Well, if you insist upon it, then go away until you give birth to (the child). When she was delivered she came with the child (wrapped) in a rag and said : Here is the child whom I have given birth to. He said : Go away and suckle him until you wean him. When she had weaned him, she came to him (the Holy Prophet) with the child who was holding a piece of bread in his hand. She said : Allah's Apostle, here is he as I have weaned him and he eats food. He (the Holy Prophet) entrusted the child to one of the Muslims and then pronounced punishment. And she was put in a ditch up to her chest and he commanded people and they stoned her. Khalid b Walid came forward with a stone which he flung at her head and there spurted blood on the face of Khalid and so he abused her. Allah's Apostle (may peace be upon him) heard his (Khalid's) curse that he had huried upon her. Thereupon he (the Holy Prophet) said: Khalid, be gentle. By Him in Whose Hand is my life, she has made such a repentance that even if a wrongful tax-collector were to repent, he would have been forgiven. Then giving command regarding her, he prayed over her and she was buried.

Book 17, Number 4207:

    Imran b. Husain reported that a woman from Juhaina came to Allah's Apostle (may peace be upon him) and she had become pregnant because of adultery. She said: Allah's Apostle, I have done something for which (prescribed punishment) must be imposed upon me, so impose that. Allah's Apostle (may peace be upon him) called her master and said: Treat her well, and when she delivers bring her to me. He did accordingly. Then Allah's Apostle (may peace be upon him) pronounced judgment about her and her clothes were tied around her and then he commanded and she was stoned to death. He then prayed over her (dead body). Thereupon Umar said to him: Allah's Apostle, you offer prayer for her, whereas she had committed adultery ! Thereupon he said: She has made such a repentance that if it were to be divided among seventy men of Medina, it would be enough. Have you found any repentance better than this that she sacr ficed her life for Allah, the Majestic?

Book 17, Number 4208:

    This hadith has been transmitted on the authority of Yahya b. Abu Kathir.

Book 17, Number 4209:

    Abu Huraira and Zaid b Khalid al-Juhani reported that one of the desert tribes came to Allah's Messenger (may peace be upon him) and said: Messenger of Allah, I beg of you in the name of Allah that you pronounce judgment about me according to the Book of Allah. The second claimant who was wiser than him said: Well, decide amongst us according to the Book of Allah, but permit me (to say something). Thereupon Allah's Messenger (may peace be upon ham) said: Say. He said: My son was a servant in the house of this person and he committed adultery with his wife. I was informed that my son deserved stoning to death (as punishment for this offence). I gave one hundred goats and a slave girl as ransom for this. I asked the scholars (if this could serve as an expiation for this offence). They informed me that my son deserved one hundred lathes and exile for one year. and this woman deserved stoning (as she was married). Thereupon Allah's Messenger (may peace he upon him) said: By Him in Whose Hand is my life. I will decide between you according to the Book of Allah. The slave-girl and the goats should be given back, and your son is to be punished with one hundred lashes and exile for one year. And, O Unais (b. Zuhaq al-Aslami), go to this woman in the morning, and if she makes a confession, then stone her. He (the narrator) said: He went to her in the morning and she made a confession. And Allah's Messenger (may peace be upon him) made pronouncement about her and she was stoned to death.

Book 17, Number 4210:

    This hadith has been narrated on the authority of Zuhri with the same chain of transmitters.

Chapter 6 : STONING TO DEATH OF JEWS AND OTHER DHIMMIS IN CASE OF ADULTERY

Book 17, Number 4211:

    Abdullah b. 'Umar reported that a Jew and a Jewess were brought to Allah's Messenger (may peace be upon him) who had committed adultery. Allah's Messenger (may peace be upon him) came to the Jews and said: What do you find in Torah for one who commits adultery? They said: We darken their faces and make them ride on the donkey with their faces turned to the opposite direction (and their backs touching each other), and then they are taken round (the city). He said: Bring Torah if you are truthful. They brought it and recited it until when they came to the verse pertaining to stoning, the person who was reading placed his hand on the verse pertaining to stoning, and read (only that which was) between his hands and what was subsequent to that. Abdullah b. Salim who was at that time with the Messenger of Allah (may peace be upon him) said: Command him (the reciter) to lift his hand. He lifted it and there was, underneath that, the verse pertaining to stoning. Allah's Messenger (may peace be upon him) pronounced judgment about both of them and they were stoned. Abdullah b. 'Umar said: I was one of those who stoned them, and I saw him (the Jew) protecting her (the Jewess) with his body.

Book 17, Number 4212:

    Ibn Umar reported that Allah's Messenger (may peace be upon him) stoned to death the Jews, both male and female, who had committed adultery. The Jews brought them to Allah's Messenger (may peace he upon him). The rest of the hadith is the same.

Book 17, Number 4213:

    Ibn 'Umar reported that the Jews brought to Allah's Messenger (may peace be upon him) a man and a woman who had committed adultery. The rest of the hadith is the same.

Book 17, Number 4214:

    Al-Bara' b. 'Azib reported: There happened to pass by Allah's Apostle (may peace be upon him) a Jew blackened and lashed. Allah's Apostle (may peace be upon him) called them (the Jews) and said: Is this the punishment that you find in your Book (Torah) as a prescribed punishment for adultery ? They said: Yes. He (the Holy Prophet) called one of the scholars amongst them and said: I ask you in the name of Allah Who sent down the Torah on Moses if that is the prescribed punishment for adultery that you find in your Book. He said: No. Had you not asked me in the name of Allah, I would not have given you this information. We find stoning to death (as punishment prescribed in the Torah). But this (crime) became quite common amongst our aristocratic class. So when we caught hold of any rich person (indulging in this offence) we spared him, but when we caught hold of a helpless person we imposed the prescribed punishment upon him. We then said : Let us argree (on a punishment) which we can inflict both upon the rich and the poor. So We decided to blacken the face with coal and flog as a substitute punishment for stoning. Thereupon Allah's Messenger (may peace be upon him) said: O Allah, I am the first to revive Thy command when they had made it dead. He then commanded and he (the offender) was stoned to death. Allah, the Majestic and Glorious, sent down (this verse): "O Messenger, (the behaviour of) those who vie with one another in denying the truth should not grieve you . .." up to "is vouchsafed unto you, accept it" (v. 41)2176 It was said (by the Jews): Go to Muhammad; it he commands you to blacken the face and award flogging (as punishment for adultery), then accept it, but it he gives verdict for stoning, then avoid it. It was (then) that Allah, the Majestic and Great, sent down (these verses): "And they who do not judge in accordance with what Allah has revealed are, indeed, deniers of the truth" (v. 44); "And they who do not judge in accordance with what Allah has revealed-they, they indeed are the wrongdoers" (v. 45) ; "And they who do not judge in accordance with what God has revealed-they are the iniquitous (v. 47). (All these verses) were revealed in connection with the non-believers.

Book 17, Number 4215:

    This hadith has been narrated on the authority of A'mash up to the words: "Allah's Apostle (may peace be upon him) pronounced judgment and he was stoned (to death) " And he mentioned nothing subsequent to that pertaining to the revelation of verses.

Book 17, Number 4216:

    Jabir b.'Abdullah reported that Allah's Apostle (may peace be upon him) stoned (to death) a person from Banu Aslam, and a Jew and his wife.

Book 17, Number 4217:

    This hadith has been transmitted on the authority of Juraij with a slight variation of words.

Book 17, Number 4218:

    Abu Ishaq Shaibani said: I asked 'Abdullah b. Abu Aufi if Allah's Messenger (may peace be upon him) awarded (the punishment) of stoning (to death). He said: Yes. I said: After Sura al-Nur was revealed or before that ? He said: I do not know.

Book 17, Number 4219:

    Abu Huraira reported that he heard Allah's Messenger (may peace be upon him) as saying: When the slave-woman of any of you commits adultery and this (offence of hers) becomes clear, she should be flogged (as the presribed) punishment, but hurl no reproach at her. If she commits adultery again, she should (again be punished) by flogging, but hurl no reproach upon her. It she commits fornication for the third time. and it becomes clear, then he should sell her, even if only for a rope of hair.

Book 17, Number 4220:

    This hadith his been narrated on the authority of Abu Huraira through another chain of transmitters with a slight variation of words.

Book 17, Number 4221:

    Abu Huraira reported that Allah's Messenger (may peace be upon him) was asked about the slave-woman who committed adultery and was not protected (married). He said: If she commits adultery, then flog her and it she commits adultery again, then flog her and then sell her even for a rope. Ibn Shihab said: I do not know whether he said this (his statement pertaining to the sale of slave-woman) at the third or the fourth time. Ibn Shihab said that the word) dafir (used in the text) means rope.

Book 17, Number 4222:

    This hadith has been narrated on the authority of Abu Huraira and Zaid b. Khalid al-Jubani, but in this no merition is made of the words of Ibn Shihab that dafir means rope.

Book 17, Number 4223:

    This hadith has been transmitted on the authority of Abu Huraira and Zaid b. Khalid al-Juhani in the same way as transmitted by Malik with this (difference) tnat there is a doubt whether her sale (that of the slave-girl committing adultery) was mentioned after the third or the fourth time.

Chapter 7 : THE PRESCRIBED PUNISHMENT SHOULD BE DEFERRED IN CASE OF ONE WHO IS IN A STATE OF PARTURITION

Book 17, Number 4224:

    Abd al-Rahman reported that 'Ali, while delivering the address said: O people, impose the prescribed punishment upon your slaves, those who are married and those not married, for a slave-woman belonging to Allah's Messenger (may peace be upon him) had committed adultery, and he committed me to flog her. But she had recently given birth to a child and I was afraid that if I flogged her I might kill her. So I mentioned that to Allah's Apostle (may peace be upon him) and he said: You have done well.

Book 17, Number 4225:

    This hadith has been narrated on the authority of as-Suddi with the same chain of trznsmitters, but he did not mention: "Those who are married and those who are not married." There is also an addition in it:"I spare her until she is all right."

Chapter 8 : PRESCRIBED PUNISHMENT FOR (DRINKING) WINE

Book 17, Number 4226:

    Anas b. Malik reported that a person who had drink wine was brought to Allah's Apostle (may peace be upon him). He gave him forty stripes with two lashes. Abu Bakr also did that, but when Umar (assumed the responsibilities) of the Caliphate, he consulted people and Abd al-Rahman said: The mildest punishment (for drinking) is eighty (stripes) and 'Umar their prescribed this punishment.

Book 17, Number 4227:

    This hadith has been narrated on the authority of Anas through another chain of transmitters.

Book 17, Number 4228:

    Anas b. Malik reported that Allah's Apostle (may peace be upon him) gave a beating with palm branches and shoes, and that Abu Bakr gave forty lashes. When Umar (became the Commander of the Faithful) and the people went near to pastures and towns, he said (to the Companions of the Holy Prophet). What is your opinion about lashing for drinking? Thereupon Abd al-Rahman b. Auf said: My opinion is that you fix it as the mildest punishment. Then 'Umar inflicted eighty stripes.

Book 17, Number 4229:

    This hadith has been narrated on the authority of Hisham with the same chain of transmitters.

Book 17, Number 4230:

    Anas reported that Allah's Apostle (may peace be upon him) used to strike forty times with shoes and palm branches (in case of drinking of) wine. The rest of the hadith is the same and there is no mention of pastures and towns.

Book 17, Number 4231:

    Hudain b. al-Mundhir Abu Sasan reported: I saw that Walid was brought to Uthmin b. 'Affan as he had prayed two rak'ahs of the dawn prayer, and then he said: I make an increase for you. And two men bore witness against him. One of them was Humran who said that he had drunk wine. The second one gave witness that he had seen him vomiting. Uthman said: He would not have vomited (wine) unless he had drunk it. He said: 'Ali, stand up and lash him. 'Ali said: Hasan, stand up and lash him. Thereupon Hasan said: Let him suffer the heat (of Caliphate) who has enjoyed its coolness. ('Ali felt annoyed at this remark) and he said: 'Abdullah b. Ja'far, stand up and flog him, and he began to flog him and 'Ali counted the stripes until these were forty. He (Hadrat 'Ali) said: Stop now, and then said: Allah's Apostle (may peace be upon him) gave forty stripes, and Abu Bakr also gave forty stripes, and Umar gave eighty stripes, and all these fall under the category of the Sunnab, but this one (forty stripes) is dearer to me.

Book 17, Number 4232:

    Ali reported: If I impose Hadd on anyone, and he (in course of punish ment) dies, I would not mind except in case of a drunkard. If he dies. I would pay indemnity for him because the Messenger of Allah (may peace be upon him) has laid down no rule for it.

Book 17, Number 4233:

    This hadith is narrated on the authority of Sufyan.

Chapter 9 : NUMBER OF STRIPES IN CASE OF TA'ZIR

Book 17, Number 4234:

    Abu Barda Ansari reported Allah's Messenger (may peace be upon him) as saying: None should be given more than ten lashes, but in case of any Hadd out of the Huded of Allah.

Chapter 10 : IMPOSITION OF HADD OBLITERATES SINS

Book 17, Number 4235:

    Ubida b. as-Samit reported: While we were in the company of Allah's Messenger (may peace be upoi him) he said: Swear allegiance to me that you will not associate anything with Allah, that you will not commit adultery, that you will not steal, that you will not take any life which it is forbidden by Allah to take but with (legal) justification; and whoever among you fulfils it, his reward is with Allah and he who commits any such thing and is punished for it, that will be all atonement for it And if anyone commits anything and Allah conceals (his faultfls), his matter rests with Allah. He may forgive if He likes, and He may punish him if He likes.

Book 17, Number 4236:

    This hadith has been narrated on the authority of Zuhri with the same chain of transmitters with this addition: "He recited to us the verse pertaining to women, viz, that they will not associate anything with Allah.

Book 17, Number 4237:

    'Ubida b. as-Samit reported: Allah's Messenger (may peace be upon him) took (a pledge) from us as he took from the women that we will not associate anything with Allah and we will not steal, and we will not commit adultery, and we will not kill our children, and we will not bring calumny upon one another. And he who amongst you fulfils (this pledge), his reward rests with Allah , and he upon whom amongst you is imposed the prescribed punishment and that is carried out, that is his expiation (for that sin), and he whose (sins) were covered by Allah, his matter rests with Allah. He may punish him if He likes or may forgive him if He so likes.

Book 17, Number 4238:

    Ubida b. as-Samit repnrted: I was one of those headmen who swore allegiance to Allah's Messenger (may peace be upon him) that we will not associate anything with Allah, and will not commit adultery, and will not steal, and will not kill any soul which Allah has forbidden, but with justice nor plunder, nor disobey (Allah and His Apostle), then Paradise (will be the reward) in case we do these (acts); and if we commit any outrage (and that goes unpunished in the world), it is Allah Who would decide about it. Ibn Rumh said: Its judgment lies with Allah.

Chapter 11 : IF THE BEAST DOES ANY HARM, OR IF ONE FALLS IN A MINE OR A WELL, THERE WILL BE NO BLOOD-WIT FOR THAT

Book 17, Number 4239:

    Abu Huraira reported Allah's Messenger (may peace be upon him) as saying: No requital is payable for a wound caused by an animal, for (falling into) a well and a mine, and one-fifth (is the share of the government) in the buried treasure (treasure-trove).

Book 17, Number 4240:

    A hadith like this has been transmitted on the authority of Zuhri.

Book 17, Number 4241:

    A hadith like this has been transmitted on the authority of Abu Huraira.

Book 17, Number 4242:

    Abu Huraira reported Allah's Messenger (may peace be upon him) as saying: The wound caused (by falling) in the well, in the mine, and caused bv the animal has no requital for it ; and there is one-fifth (for the government) in the buried treasure.

Book 17, Number 4243:

    A hadith like this has been transmitted on the authority of Abu Huraira.


BOOK 18: The Book Pertaining To Judicial Decisions (Kitab Al-Aqdiyya)

KITAB AL-AQDIYYA
(THE BOOK PERTAINING TO JUDICIAL DECISIONS)

Back
Chapter 1 : IT IS THE DEFENDANT WHO SHOULB SWEAR (TO PROVE HIS INNOCENCE)

Book 18, Number 4244:

    Ibn Abbas reported Allah's Apostle (may peace be upon him) as saying: If the people were given according to their claims, they would claim the lives of persons and their properties, but the oath must be taken by the defendant.

Book 18, Number 4245:

    Ibn 'Abbas reported that Allah's Messenger (may peace be upon him) pronounced judgment on the basis of oath by the defendant.

Book 18, Number 4246:

    Ibn 'Abbas reported that Allah's Messenger (may peace be upon him) pronounced judgment on the basis of an oath and a witness (by the plaintiff).

Chapter 2 : JUDGMENT IS TO BE PRONOUNCED ON EVIDENCE, AND ONE WHO IS ELOQUENT IN HIS PLEA (MAY WIN THE CASE)

Book 18, Number 4247:

    Umm Salama reported Allah's Messenger (may peace be upon him) as saying: You bring to me, for (judgment) your disputes, some of you perhaps being more eloquent in their plea than others, so I give judgment on their behalf according to what I hear from them. (Bear in mind, in my judgment) if I slice off anything for him from the right of his brother, he should not accept that, for I sliced off for him a portion from the Hell.

Book 18, Number 4248:

    This hadith has been narrated on the authority of Hisham with the same chain of transmitters.

Book 18, Number 4249:

    Umm Salama, the wife of Allah's Apostle (may peace be upon him), reported that Allah's Messenger (may peace be upon him) heard the clamour of contenders at the door of his apartment. He went to them, and said: I am a human being and the claimants bring to me (the dispute) and perhaps some of them are more eloquent than the others. I judge him to be on the right, and thus decide in his favcur. So he whom I, by my judgment, (give the undue share) out of the right of a Muslim,. I give him a portion of Fire; he may burden himself with it or abandon it.

Book 18, Number 4250:

    This hadith has been transmitted on the authority of Ma'mar with a slight variation of words.

Book 18, Number 4251:

    A'isha reported: Hind. the daughter of 'Utba, wife of Abu Sufyan, came to Allah's Messenger (may peace be upon him) and said: Abu Sufyan is a miserly person. He does not give adequate maintenance for me and my children, but (I am constrained) to take from his wealth (some part of it) without his knowledge. Is there any sin for me? Thereupon Allah's Messenger (may peace be upon him) said: Take from his property what is customary which may suffice you and your children.

Book 18, Number 4252:

    This hadith has been narrated on the authority of Hisham with the same chair of transmitters.

Book 18, Number 4253:

    A'isha reported that Hind came to Allah's Apostle (may peace be upon him) and said: Messenger of Allah, by Allah, there was no other household upon the surface of the earth than your household about which I cherished Allah bringing disgrace upon it, (and now) there is no other household upon the surface of the earth than your household about which I cherish Allah granting it honour. Allah's Apostle (may peace be upon him) said: It is so, by Him in Whose Hand is my life She said: Allah's Messenger, Abu Sufyan is a niggardly person. Is there any harm for me if I spend upon his children out of his wealth without his permission? Thereupon Allah's Apostle (may peace be upon him) said: There is no harm for you if you spend upon them what is reasonable.

Book 18, Number 4254:

    A'isha reported that Hind, daughter of Utba h. Rabi', came to Allah's Messenger (may peace be upon him) and said: Allah's Messenger, by Allah, there was no household upon the surface of the earth than your household about which I cherished that it should be disgraced. But today there is no household on the surface of the earth than your household about which I cherish that it be honoured Thereupon Allah's Messenger (may peace be upon him) said. It will increase, by Him in Whose Hand is my life. She then said: Messenger of Allah, Abu Sufyan is a niggardly person; is there any harm for me if I spend out of that which belongs to him on our children? He said to her: No, but only that what is reasonable.

Chapter 3 : IT IS FORBIDDEN TO ASK MANY QUESTIONS AND WASTING OF WEALTH

Book 18, Number 4255:

    Abu Huraira reported Allah's Messenger (may peace be upon him) as saying: Verily Allah likes three things for you and He disapproves three things for you. He is pleased with you that you worship Him and associate nor anything with Him, that you hold fast the rope of Allah, and be not scattered; and He disapproves for you irrelevant talk, persistent questioning ane the wasting of wealth.

Book 18, Number 4256:

    This hadith has been narrated on the authority of Suhail with the same chain of transmitters, but with a slight variation of words.

Book 18, Number 4257:

    Mughira b. Shu'ba reported Allah's Messenger (may peace be upon him) as saying: Verity Allah, the Glorious and Majestic, has forbidden for you: disobedience to mothers, and burying alive daughters, withholding the right of others in spite of having the power to return that to them and demanding that (which is not one's legitimate right). And He disapproved three things for you; irrelevant talk, persistent questioning and wasting of wealth.

Book 18, Number 4258:

    A hadith like this has been trransmitted on the authority of Mansur with a slight vairiation of words.

Book 18, Number 4259:

    Sha'bi reported that the scribe of al-Mughira b. Shu'ba said: Mu'awiya wrote to Mughira: Write for me something which you heard from Allah's Messenger (may peace be upon him); and he wrote: I heard Allah's Messenger (may peace be upon him) as saying. Verily Allah disapproves three thingq for you: irrelevant talk, wasting of wealth and persistent questioning.

Book 18, Number 4260:

    Warrad reported that al-Mughira wrote to Mu'awiya: Peace be upon you, and then coming to the poirt (I should say) that I heard Allah's Messenger (may peace be upon him) as saying: Verily Allah has Prohibited three things and has forbidden three things. He has declared absolutely haram the disobedience of father, burying of daughters alive, and withholding that which you have power to return, and has forbidden three things: irrelevant talk, persistent questioning, and wasting of wealth.

Chapter 4 : THE REWARD OF THE JUDGE WHEN HE TRIES TO ARRIVE AT A DECISION, WHETHER THAT DECISION IS CORRECT OR INCORRECT

Book 18, Number 4261:

    'Amr b. al-'As reported that he heard Allah's Messenger(may peace be upon him) as saying: When a judge gives a decision, having tried his best to decide correctly and is right, there are two rewards for him; and if he gave a judgment after having tried his best (to arrive at a correct decision) but erred, there is one reward for him.

Book 18, Number 4262:

    This hadith has been narrated on the authority of Abu Huraira with another chain of transmitters.

Book 18, Number 4263:

    This hadith has been transmitted on the authority of Usama b. al-Had al-Laithi.

Chapter 5 : IT IS NOT DESIRABLE TO GIVE JUDGMENT IN A FIT OF RAGE

Book 18, Number 4264:

    Abd al-Rabmin b. Abu Bakra reported: My father dictated (and I wrote for him) to Ubaidullah b. Abu Bakra while he was the judge of Sijistan: Do not judge between two persons when you are angry, for I have heard Allah's Messenger (may peace be upon him) as saying: None of you should judge between two persons when he is angry.

Book 18, Number 4265:

    This hadith has been narrated on the authority of 'Abd al-Rahman b. Abu Bakra through another chain of transmitters.

Chapter 6 : REJECTING OF THE WRONG THINGS AND THE INNOVATIONS (IN RELIGION)

Book 18, Number 4266:

    'A'isha reported Allah's Messenger (may peace be upon him) as saying: He who innovates things in our affairs for which there is no valid (reason) (commits sin) and these are to be rejected.

Book 18, Number 4267:

    Sa'd b. Ibrahim reported: I asked Qasim b. Muhammad about a person who had three dwelling houses and he willed away the third part of every one of these houses; he (Qasim b. Muhammad) said: All of them could be combined in one house; and then said: 'A'isha informed me that Allah's Messenger (may peace be upon him) said: He who did any act for which there is no sanction from our behalf, that is to be rejected.

Chapter 7 : AN EXCELLENT WITNESS

Book 18, Number 4268:

    Zaid b. Khalid al-Juhani reported Allah's Apostle (may peace be upon him) as saying: Should I not tell you of the best witnesses? He is the one who produces his evidence before he is asked for it.

Chapter 8 : THE DIFFERENCE OF THOSE WHO ENDEAVOUR TO ARRIVE AT THE CORRECT DECISION

Book 18, Number 4269:

    Abu Huraira reported Allah's Apostle (may peace be upon him) as saying: While two women had been going along witn their two sons, a wolf came and made away with the child of one of them. One of them said to her companion: It is with your child that it (the wolf) has run away The other one said: It has run away with your child. They brought the matter to (Hadrat) Dawud (David) for decision and he made a decision in favour of the elder one. They then went to Sulaiman b. Dawud (may there be peace upon both of them) and told them (the story). He said: Bring me a knife so that I may cut him (the child) (into two parts) for you. The younger one said: No, it can't be, may Allah have mercy upon you, he (the child) belongs to her (the elder). So he gave a decision in favour of the younger one. abu Huraira said: If ever I heard of the word as-sikin at all, it was that day. We called it by no other name but al-Mudya.

Book 18, Number 4270:

    This hadith has been narrated on the authority of Abu az-Zinad with the same chain of transmitters.

Chapter 9 : IT IS MERITORIOUS FOR A JUDGE TO BRING ABOUT CONCILIATION BETWEEN TWO CONTENDING PERSONS OR PARTIES

Book 18, Number 4271:

    Hammim b. Munabbih said: Abu Huraira reported (so many) ahadith of Allah's Messenger (may peace be upon him), and one of them is this: A person bought from another person a piece of land, and the person who had, bought that land found in it an earthen ware which contained gold. The person who had bought the land said (to the seller of the land): Take your gold from me, for I bought only the land from you and not the gold. The man who had sold the land said: I sold the land to you and whatever was in it. They referred the matter to a person. One who was made as a judge said to them: Have you any issue? One of them said: I have a boy, and the other said: I have a young daughter He (the judge) said: Marry this young boy with the girl, and spend something on yourselves and also give (some) charity out of it.

Chapter 10 : STRAY THING FOUND BY ANYONE

Book 18, Number 4272:

    Zaid b. Khalid al-Juhani reported: A man came to Allah's Apostle (may peace be upon him) and asked him about picking up of stray articles. He said: Recognise (well) its bag and the strap (by which it is tied) then make announcement of that for a year. If its owner comes (within this time return that to him), otherwise it is yours. He (again) said: (What about) the lost goat? Thereupon he (the Holy Prophet) said: It is yours or for your brother, or for the wolf. He said: (What about) the lost camel? Thereupon he said: You have nothing to do with it; it has a leather bag along with it, and its shoes also. It comes to the watering-place, eats (the leaves of the) trees until its master finds him.

Book 18, Number 4273:

    Zaid b. Khalid al-Juhani reported that a person asked Allah's Apostle (may peace be upon him) about picking up of stray articles, whereupon he said: Make announcement about it for a year, and recognise well the strap and the bag (containing that); then spend that; and if its owner comes, make him the payment of that. He (the inquirer) said: Messenger of Allah, what about the lost goat? he said: Take it, for that is yours or for your brother, or for the wolf. He (again) said: (What about) the lost camel? The Messenger of Allah (may peace be upon him) was enraged until his cheeks became red (or his face became red) and then said: You have nothing to do about that; it has feet and a leather bag (to quench its thirst) until its owner finds it.

Book 18, Number 4274:

    This hadith has been narrated on the authority of Rabi'a b. Abu Abd al-Rahman with the same chain of transmitters but with this addition: "There came a person to Allah's Messenger (may peace be upon him) while I was with him, and he asked him about picking up of a stray article, and he said: When none comes to demand it, then spend that."

Book 18, Number 4275:

    Zaid b. Khalid al-Juhani reported. There came to Allah's Messenger (may peace be upon him) a person, the rest of the hadith is the same but with the variation (of these words): His face became red, his forehead too, and he felt annoyed; and made an addition after the words: He should make announcement of that for a year, and if its owner does not turn up, then it is a trust with you.

Book 18, Number 4276:

    Zaid b. Khalid al-Juhani, the Companion ot Allah's Messenger (may peace be upon him), said that Allah's Messenger (may peace be upon him) was asked about the picking up of stray gold or silver, whereupon he said: Recognise well the strap and the bag (containing) that and then make an announcement regarding that for one year, but if none recognises it, then spend that and it would be a trust with you; and if someone comes one day to make demand of that, then pay that to him. He (the inquirer) asked about the lost camel, whereupon he said: You have nothing to do with that. Leave that alone, for it has feet and also a leather bag, it drinks water, and eats (the leaves) of the trees. He asked him about sheep, whereupon he said: Take it, it is for you, or for your brother, or for the wolf.

Book 18, Number 4277:

    Zaid b. Khalid al-Juhani reported: A person asked Allah's Apostle (may peace be upon him) about a lost camel; Rabi'a made this addition: He (the Holy Prophet) was so much annoyed that his cheeks became red." The rest of the hadith is the same. He (the narrator) made this addition: "If its (that of the article) owner comes and he recognises the bag (which contained it) and its number, and the strap. then give that to them, but if not, then it is for you."

Book 18, Number 4278:

    Zaid b. Khalid al-Juhani reported that Allah's Messenger (may peace be upon him) was asked about picking up of stray things, whereupon he said: Make announcement of that for one year, but if it is not recognised (by the owner), then recognise its big and strap, then eat it; and if its owner comes, then give that to him. This hadith has been narrated on the authority of Al-Dahhak b. Uthman with the same chain of transmitters but with a slight variation of words.

Book 18, Number 4279:

    Salama b. Kuhail reported: I heard Sowaid b. Ghafala say: I went out, and also Zaid b. Suhan and Salman b. Rabi'a for Jibad, and I found a whip and took it up. They said to me: Leave it. I said: No. but I will make announcement of it and if its owner comes (then I will return that), otherwise I will use it, and I refused them. When we returned from Jihad. by a good fortune for me, I performed Pilgrimage. I came to Medina and met Ubayy b. Ka'b, and related to him the affair of the whip and their opinion (the opinion of Zaid b. Suhan and Salman b. Rabi'a) about it (i.e. I should throw it). Thereupon he said: I found a money bag during the lifetime of Allah's Messenger (may peace be upon him) which contained one hundred dinars. I came to him along with it, and he said: Make an announcement of it for one year; so I announced it, but did not find anyone who could (claim it after) recognising it. I again came to him and he said: Make announcement for one year. So I made announcement of it, but I found none who could recognise it. I came to him he said: Make announcement of it for one year. I made announcement of that but did not find one who could recognise it, whereupon he said: Preserve (in your mind) its number, its bag and its strap, and if its owner comes (then return that to him), otherwise make use of it. So I made use of that. I (Shu'ba) met him (Salama b. Kuhail) after this in Mecca, and he said: I do not know whether he said three years or one year.

Book 18, Number 4280:

    Shu'ba reported: Salama b. Kuhail informed me or he informed people and I was among them. He said: I heard Sawaid b. Ghafala who reported: I went out along with Zaid b. Suhan and Salman b. Rabi'a, and found a whip, the rest of the hadith is the same up to the words: "I made use of that." Shu'ba said: I heard him say after ten years, that he made an announcement of it for one year.

Book 18, Number 4281:

    This hadith has been narrated on the authority of Salama b. Kuhail through different chains of transmitters. In their ahadith, it is three years, except in the hadith of Hammid b. Salama it is two years or three years. In the hadith transmitted on the authority of Sufyan and Zaid b. Abu Unaisa and Hammid b. Salama (the words are): "If someone comes and informs you about the number (of articles) of the bag and the straps, then give that to him." Sufyan has made this addition in the narration of Waki': "Otherwise it is like your property." And in the narration of Ibn Numair the words are: "Otherwise make use of that."

Chapter 11 : STRAY THINGS OF THE PILGRIMS

Book 18, Number 4282:

    'Abd al-Rahman b. 'Uthman al-Taimi reported that Allah's Messenger (may peace be upon him) forbade taking into custody the stray thing of the pilgrims.

Book 18, Number 4283:

    Zaid b. Khalid al-Juhani reported Allah's Messenger (may peace be upon him) as sayin.: He who found a stray article is himself led astray if he does not advertise it.

Chapter 12 : IT IS FORBIDDEN TO MILK AN ANIMAL WITHOUT THE PERMISSION OF ITS OWNER

Book 18, Number 4284:

    Ibn 'Umar reported Allah's Messenger (may peace be upon him) having said this: None (of you) should milk the animal of another, but with his permission. Does any one of you like that his chamber be raided, and his vaults be broken, and his foodstuff be removed ? Verily the treasures for them (those who keep animals) are the udders of the animals which feed them. So none of you should milk the animal of another but with his permission.

Book 18, Number 4285:

    This hadith has been narrated through another chain of transmitters with a slight variation of words.

Chapter 13 : ENTERTAINMENT OF THE GUEST

Book 18, Number 4286:

    Abd Shuraib al-Adawi reported: My eare listened and my eye saw when Allah's Messenger (may peace be upon him) spoke and said: He who believes In Allah and the eireafter should show respect to the guest even with utmost kindness and courtesy. They said: Messenger of Allah, what is this utmost kindness and courtesy? He replied: It is for a day and a night. Hospitality extends for three days, and what is beyond that is a Sadaqa for him; and he who believes in Allah and the Hereafter should say something good or keep quiet.

Book 18, Number 4287:

    Abu Shuriah al-Khuza'i reported Allah's Messenger (may peace be upon him) as saying: (The period of the entertainment of a guest is three days, and utmost kindness and courtesy is for a day and a night.=" It is not permissible for a Muslim to stay with, his brother until he makes him sinful. They said: Messenger of Allah, how he would make him sinful? He (the Holy Prophet) said: He stays with him (so long) that nothing is left with him to entertain him.

Book 18, Number 4288:

    Sa'id al-Maqburi reported: I heard Abu Shuraih al-Khuzill saying: My ears heard and my eyes saw and my mind retained it, when Allah's Messenger (may peace be upon him) spok this, and he then narrated the hadith and made mention of this: "It is not permissible for any one of you to stay with his brother until he makes him sinful."

Book 18, Number 4289:

    'Uqba b. Amir reported: We said to Allah's Messenger (may peace be upon him): You send us out and we come to the people who do not give us hospitality, so what is your opinion? Thereupon Allah's Messenger (may peace be upon him) said: If you come to the people who order for you what is befitting a guest, accept it; but if they do not. take from them what befits them to give to a guest.

Chapter 14 : IT IS MERITORIOUS TO SPEND THE SURPLUS WEALTH FOR ONE'S BROTHER

Book 18, Number 4290:

    Abu Sa'id al-Khudri reported: While we were with the Apostle of Allah (may peace be upon him) on a journey, a person came upon his mount and began to stare on the right and on the left, (it was at this moment) that Allah's Messenger (may peace be upon him) said: He who has an extra mount should give that to one who has no mount for him, and he who has surplus of provisions should give them to him who has no provisions, and he made mention of so many kinds of wealth until we were of the opinion that none of us has any right over the surplus.

Chapter 15 : IN CASE THE PROVISIONS RUN SHORT, THESE SHOULD BE POOLED

Book 18, Number 4291:

    Iyas b. Salama reported on the authority of his father: We set out on an expedition with, Allah's Messenger (may peace be upon him). We facts hardship (in getting provisions) until we decided to slaughter some of our riding animals. Allah's Apostle (may peace be upon him), commanded us to pool our provisions of food. So we spread a sheet of leather and the provisions of the people were collected on it. I stretched myself to measure how much that was (the length and, breadth of the sheet on which the provisions were laid). I measured it and (found) that it was (in length and breadth) of (so much size) on which a goat could sit. We were fourteen hudnred persons. We (all) ate until we were fully satisfied and then filled our bags with provisions. Then Allah's Apostle (may peace be upon him) said: Is there any water for performing ablution. Then there came a man with a small bucket containing some water. He threw it in a basin. We all fourteen hundred persons performed ablution using the water in plenty. Then there came after that eight persons and they said: Is there any water to perform ablution? Thereupon Allah's Messenger (may peace be upon him) said: The ablution has already been performed.


BOOK 19: The Book of Jihad And Expedition (Kitab Al-Jihad Wal-Siyar)

KITAB AL-JIHAD WA'L-SIYAR
(THE BOOK OF JIHAD AND EXPEDITION)

Back
INTRODUCTION

    The word Jihad is derived from the verb jahada which means: "he exerted himself". Thus literally, Jihad means exertion, striving; but in juridico-religious sense, it signifies the exertion of one's power to the utmost of one's capacity in the cause of Allah. This is why the word Jihad has been used as the antonym to the word Qu,ud (sitting) in the Holy Qur'an (iv. 95). Thus Jihad in Islam is not an act of violence directed indiscriminately against the non-Muslims; it is the name given to an all-round struggle which a Muslim should launch against evil in whatever form or shape it appears. Qital fi sabilillah (fighting in the way of Allah) is only one aspect of Jihad. Even this qital in Islam is not an act of mad brutality. It has its material and moral functions, i.e. self-preservation and the preservation of the moral order in the world. The verdict of all religious and ethical philosophies-ancient and modern-justify war on moral grounds. When one nation is assailted by the ambitions and cupidity of another, the doctrine of non-resistance is anti-social, as it involves non-assertion, not only of one's own rights, but of those of others who need protection against the forces of tyranny and oppression. A Muslim is saddled with the responsibilities to protect himself and all those who seek his protection. He cannot afford to abandon the defenceless people, old man, women and children to privation, suffering and moral peril. Fighting in Islam, therefore, represents in Islamic Law what is known among Western jurists as "just war".

    The very first revelation in which the permission to wage war against the forces of evil sums up the aims and objects of qital in Islam:

      "Permitted'are those who are fought against, because they have been oppressed. and verily God is more Powerful for their aid. Those who have been driven from their homes unjustly only because they said: 'Our Lord is Allah,' for had it not been for 'Allah's repelling someone by means of others, cloisters and churches and mosques, wherein the name of Allah is oft-mentioned, would assuredly have been pulled down. Verily Allah helps one who helps Him. Lo! Allah is Strong. Almighty" (xxii. 39.41).

    These verses eloquently speak of 'the fact that it is neither for the acquisition of territory nor for the love of power and distinction that the Muslims have been permitted to raise arms against the enemy. They were allowed to do so because their very existence had been made difficult by the high-handedness of the Meccans. The Holy Qur'an has elucidated this point in the following verse:

      "And what reason have you not to fight in the way of Allah and for the oppressed among men and women and children who say: Our Lord ! take us forth from the town whereof the people are oppressors and grant us from Thee a friend and grant us from Thee a helper" (iv. 75).

    The war in Islam is waged with a view to securing liberty and freedom for those who are groaning under the oppression of heartless tyrants. It is the bounden duty of the Muslims to alleviate their sufferings and create for them an atmosphere of peace and security.

    Then in the succeeding verse a distinction is also drawn between two types of war: one which is fought for the sake of Allah and the other which is waged for evil ends:

      " Those who believe fight in the way of Allah and those who disbelieve fight in the way of devil. So fight against the friends of Satan; verily weak indeed is the strategy of the devil" (iv. 76).

    It has been made clear that those people who fight for self-glorification or for the exploitation of the weak are in fact friends of the devil; wheres those who raise arms to curb tyranny and aggression, to eradicate evil from the human society, fight in the way of Allah. Mere fighting is not, therefore, Jihad in Islam; it is the noble objective alone which makes it a sacred pursuit like devotion and prayer. It is narrated on the authority of Abu Musa Ash'ari that once a man went to the Holy Prophet (may peace be upon him) and said: One man fights for the sake of spoils of war, the second one fights for fame and glory and the third to display his courage and skill; which among them is the fighter for the cause of Allah ? Upon this the Holy Prophet (may peace be upon him) replied: He who fights with the sole objective that the word of Allah should become supreme is a Mujahid in the cause of the Lord.

    A Mujahid is thus a noble person who offers his life for the achievement of lofty ends. He is actuated by human considerations lifts arms not under the impulse of fury and revenge, but with will, fore-thought, tenacity and fellow-feeling, and his conduct bears the imprint of human intellect, human sympathy and sense of justice.

    The Holy Qur'an has explained this point in Sura Anfal in these words:

      "O you who believe, when you meet an enemy, be firm, and remember Allah much, that you may be successful. And obey Allah and His Apostle. And fall with no disputes, lest ye falter and your strength fail; but be steadfast! For Allah is with those who patiently persevere. Be not as those who came forth from their dwellings boastfully. And to be seen of men and debar (men) from the way of Allah. And Allah encompasses what they do" (viii. 45-46).

    Here the Muslims have been exhorted to observe five principles of war:

    1. Be steadfast in the face of the enemy.
    2. Have full reliance on the help of Allah and remember Him much.
    3. Have the unity of purpose and solidarity of corporate life always before your eyes.
    4. Be fully aware of the lofty purpose before you in fighting.
    5. Don't be proud and boastful in your attitude and behaviour.

    Islam has purified even war of all its cruelty and horrors and has made it a "reformative process" to deal with evil. The Holy Qur'an bserves:

      "And fight in the way of Allah against those who fight against you and transgress not the limits. Verily Allah loves not the transgressors" (ii. 190).

    The Holy Prophet (may peace be upon him) has given clear instructions about the behaviour of the Muslim army. He observed:

      "Set out for Jibad in the name of Allah and for the sake of Allah. Do not lay hands on the old verging on death, on women, children and babes. Do not steal anything from the booty and collect together all that falls to your lot in the battlefield and do good, for Allah loves the virtuous and the pious."

    So great is the respect for humanly feelings in Islam that even the wanton destruction of enemy's crops or property is strictly forbidden. The righteous Caliphs followed closely the teachings of Allah and those of His Apostle in letter and spirit the celebrated address which the first Caliph Abu Bakr (Allah be pleased with him) gave to his army while sending her on the expedition to the Syrian borders is permeated with the noble spirit with which the war in Islam is permitted. He said:

      "Stop, O people, that I may give you ten rules for your guidance in the battlefield. Do not commit treachery or deviate from the right path. You must not mutilate dead bodies. Neither kill a child, nor a woman. nor an aged man. Bring no harm to the trees, nor burn them with fire, especially those which are fruitful. Slay not ary of the enemy's flock. save for your food. You are likely to pass by people who have devoted their lives to monast ic services; leave them alone"

    It is said that once at the time of conquest, a singing girl was brought to al-Muhajir b. Abu Umayya who had been publicly singing satirical poems about Hadrat Abu Bakr. Muhajir got her hand amputated. When the Caliph heard this news, he was shocked and wrote a letter to Muhajir in the following words:

      "I have learnt that you laid hands on a woman who had hurled abuses on me, and, therefore, got her hand amputated. God has not sought vengeance even in the case of polytheism, which is a great crime. He has not permitted mutilation even with regard to manifest infidelity. Try to be considerate and sympathetic in your attitude towards others in future. Never mutilate, because it is a grave offence. God purified Islam and the Muslims from rashness and excessive wrath. You are well aware of the fact that those enemies fell into the hands of the Messenger of Allah (may peace be upon him) who had been recklessly abusing him; who had turned him out of his home; and who fought against him, but he never permitted their mutilation."

    Another letter written by hadrat 'Umar the Second Caliph, which is addressed to sa'd b. Abu Waqqas, speaks eloquently of the noble spirit with which the Muslims have bear exhorted to take up arms:

      "Always search your minds and hearts and stress upon your men the need of perfect integrity and sincerity in the cause of Allah. There should be no material end before them in laying down their lives. but they abould deem it a means whereby they can please their Lord and entitle them. selves to His favour: such a spirit of selflessness should be inculcated in the minds of those who unfortunately lack it. Be firm in the thick of the battle as Allah helps man according to the perseverance that he shows in the cause of His faith and he would be rewarded in accordance with the spirit of sacrifice which he displays for the sake of the Lord. Be careful that those who have been entrusted to your care receive no harm at your hands and are never deprived of any of their legitimate rights.

    Such in fact is the humane and noble attitude which Islam exhorts its followers to adopt on the battlefield where passions are generally let loose. It is an attitude the like of which is not to be found in the history of any other nation. Has the world any code of military ethics more noble and compassionate than this? "The moral tone adopted by the Caliph Abu Bakr in his instructions to the Syrian army was," says a Christian historian, "so unlike the principles of the Roman government that it must have commanded profound attention from the subject people-such a proclamation announced to Jews and Christians sentiments of justice and principles of toleration which neither Roman emperors nor orthodox bishops had ever adopted as the rule of conduct."

    Western scholars have indulged in a good deal of mud-slinging on the question of the use of the sword in Islam. But if one were to reflect calmly on this point one would be convinced that the sword has not been used recklessly by the Muslims; it has been wielded purely with humane feelings in the wider interest of humanity. Utmost regard was always shown to human life, honour and property even on the battlefield. That is why in all the eighty-two encounters between the Muslims and the non-Muslims during the life of the Holy Prophet (may peace he upon him), only 1018 persons lost their lives on both sides. Out of this 259 were Muslims, whereas the remaining 759 belonged to the opposite camp. One wonders at the audacity of these writers only when one compares the religious wars of Charles the Great, in which 4300 pagan Saxons were killed in cold blood, when one recalls the "famous answer by which the Papal Legate, in the Albigensian war, quieted the scruples of a too conscientious general, 'Kill all, God will know His own'. . . . When we recall the Spanish Inquisition, the conquest of Mexico and Peru, the massacre of St. Bartholomew, and the sack of Magdeburg by Tilly."

    It is indeed strange that the criticism on the use of sword by Muslims emanates from those whose hands are soiled in the blood of countless innocent human beings, by those who exult in the techniques of homicide, who have depersonalised warfare to such an extent that millions of innocent men and women are put to death and numberless are thrown into concentration camps and flogged with steel rods and ox-hide whips, and all this is done without any qualm of conscience. As human beings. we hang our heads down in shame when we think of the horrifying atrocities which have been perpetrated by the modern civilised men. It is estimated that.in the First World War, ten million soldiers were killed and an equal number of civilians lost their lives, and twenty million died on account of widespread epidemics and famines throughout the world as an aftermath of this war. Economic costs are estimated at $ 338,000,000,000 of which $ 186,000,000,000 were direct costs.

    The losses in the Second World War were staggeringly greater as compared to those in the first one. Twenty-two million persons were killed and thirty-four million were wounded. The estimated cost of the war was $ 1,348.000,000,000 of which $ 1,167,000,000,000 consisted of direct military costs.

    It is significant that in the Korean War, the first instance in which an international organisation for establishing peace utilised military force to suppress aggression, more than one million persons were killed which added to the civilian deaths in Korea and totalled about five millions.

Chapter 1 : REGARDING PERMISSION TO MAKE A RAID, WITHOUT AN ULTIMATUM, UPON THE DISBELIEVERS WHO HAVE ALREADY BEEN INVITED TO ACCEPT ISLAM

Book 19, Number 4292:

    Ibn 'Aun reported: I wrote to Nafi' inquiring from him whether it was necessary to extend (to the disbelievers) an invitation to accept (Islam) before m". ing them in fight. He wrote (in reply) to me that it was necessary in the early days of Islam. The Messenger of Allah (may peace be upon him) made a raid upon Banu Mustaliq while they were unaware and their cattle were having a drink at the water. He killed those who fought and imprisoned others. On that very day, he captured Juwairiya bint al-Harith. Nafi' said that this tradition was related to him by Abdullah b. Umar who (himself) was among the raiding troops.

Book 19, Number 4293:

    This hadith has been narrated on the authority of Ibn 'Aun and the name of Juwairiya bint al-Harith was mentioned beyond any doubt.

Chapter 2 : APPOINTMENT OF THE LEADERS OF EXPEDITIONS BY THE IMAM AND HIS ADVICE TO THEM ON ETIQUETTES OF WAR AND RELATED MATTERS

Book 19, Number 4294:

    It has been reported from Sulaiman b. Buraid through his father that when the Messenger of Allah (may peace be upon him) appointed anyone as leader of an army or detachment he would especially exhort him to fear Allah and to be good to the Muslims who were with him. He would say: Fight in the name of Allah and in the way of Allah. Fight against those who disbelieve in Allah. Make a holy war, do not embezzle the spoils ; do not break your pledge; and do not mutilate (the dead) bodies; do not kill the children. When you meet your enemies who are polytheists, invite them to three courses of action. If they respond to any one of these, you also accept it and withold yourself from doing them any harm. Invite them to (accept) Islam; if they respond to you, accept it from them and desist from fighting against them. Then invite them to migrate from their lands to the land of Muhairs and inform them that, if they do so, they shall have all the privileges and obligations of the Muhajirs. If they refuse to migrate, tell them that they will have the status of Bedouin Muilims and will be subjected to the Commands of Allah like other Muslims, but they will not get any share from the spoils of war or Fai' except when they actually fight with the Muslims (against the disbelievers). If they refuse to accept Islam, demand from them the Jizya. If they agree to pay, accept it from them and hold off your hands. If they refuse to pay the tax, seek Allah's help and fight them. When you lay siege to a fort and the besieged appeal to you for protection in the name of Allah and His Prophet, do not accord to them the guarantee of Allah and His Prophet, but accord to them your own guarantee and the guarantee of your companions for it is a lesser sin that the security given by you or your companions be disregarded than that the security granted in the name of Allah and His Prophet be violated When you besiege a fort and the besieged want you to let them out in accordance with Allah's Command, do not let them come out in accordance with His Command, but do so at your (own) command, for you do not know whether or not you will be able to carry out Allah's behest with regard to them.

Book 19, Number 4295:

    Sulaiman b. Buraida repotted on the authority of his father that when Allah's Messenger (may peace be upon him) sent an Amir with a detachment he called him and advised him. The rest of the hadith is the same.

Book 19, Number 4296:

    This hadith has been transmitted on the authority of Shu'ba.

Chapter 3 : COMMAND TO SHOW LENIENCY AND TO AVOID CREATING AVERSION (TOWARDS RELIGION)

Book 19, Number 4297:

    It has been narrated on the authority of Abu Masa that when the Messenger of Allah (may peace be upon him) deputed any of his Companions on a mission, he would say : Give tidings (to the people); do not create (in their minds) aversion (towards religion); show them leniency and do not be hard upon them.

Book 19, Number 4298:

    It has also been narrated by Sa'd b. Abu Burda through his father through his grandfather that the Prophet of Allah (may peace be upon him) sent him and Mu'adh (on a mission) to the Yemen, and said (by way of advising them) : Show leniency (to the people); don't be hard upon them; give them glad tidings (of Divine favours in this world and the Hereafter); and do not create aversion. Work in collaboration and don't be divided.

Book 19, Number 4299:

    This hadith has been transmitted on the authority of Buraida but for the last two words.

Book 19, Number 4300:

    The Messenger of Allah (may peace he upon him) has been reported by Anas b. Malik to have said: Show leniency; do not be hard; give solace and do not create aversion.

Chapter 4 : PROHIBITION (DENUNCIATION) OF BREACH OF FAITH

Book 19, Number 4301:

    It has been narrated on the authority of Ibn 'Umar that the Messenger of Allah (may peace be upon him) said: When Allah will gather together, on the Day of Judgment, all the earlier and later generations of mankind, a flag will be raised (to mark off) every person guilty of breach of faith, and it will be announced that this is the perfidy of so and so, son of so and so (to attract the attention of people to his guilt).

Book 19, Number 4302:

    This hadith has been narrated on the authority of Ibn Umar through some other Chains of transmitters.

Book 19, Number 4303:

    This hadith has been narrated by another chain of transmitters on the authority of the same narrator, with the wording: Allah will set up a flag for every person guilty of breach of faith on the Day of Judgment, and it will be announced: Look, this is the perfidy of so and so.

Book 19, Number 4304:

    Ibn Umar reported that he heard the Messenger of Allah (may peace be upon him) saying: There will be a flag for every perfidious person on the Day of Judgment.

Book 19, Number 4305:

    'Abdullah reported Allah's Prophet (may peace be upon him) as saying: There will be a flag for every perfidious person on the Day of Judgment, and it would be said : Here is the perfidy of so and so.

Book 19, Number 4306:

    This hadith has been narrated on the authority of Shu'ba with a slight variation of wording.

Book 19, Number 4307:

    It has been narrated on the authority of Abdullah that the Messenger of Allah (may peace be upon him) said : There will be for every perfidious person on the Day of Judgment a flag by which he will be recognised. It will be announced: Here is the breach of faith of so and so.

Book 19, Number 4308:

    Anas reported Allah's Messenger (may peace be upon him) having said this: There would be a flag for every perfidious person on the Day of Judgment by which he will be recognised.

Book 19, Number 4309:

    It is narrated on the authority of Abu Sa'id that the Messenger of Allah (may peace be upon him) said : On the Day of Judgment there will be a flag fixed behind the buttocks of every person guilty of the breach of faith.

Book 19, Number 4310:

    It is narrated on the authority of Abu Sa'id that the Messenger of Allah (may peace be upon him) said : On the Day of Judgment there will be a flag for every person guilty of the breach of faith. It will be raised in proportion to the extent of his guilt; and there is no guilt of treachery more serious than the one committed by the ruler of men.

Chapter 5 : JUSTIFICATION FOR THE USE OF STRATAGEM IN WAR

Book 19, Number 4311:

    It is narrated on the authority of Jabir that the Messenger of Allah (may peace be upon him) said: War is a stratagem.

Book 19, Number 4312:

    This hadith has also been narrated on the authority of Abu Huraira.

Chapter 6 : ONE SHOULD NOT DESIRE AN ENCOUNTER WITH THE ENEMY, BUT IT IS ESSENTIAL TO SHOW PATIENCE DURING THE ENCOUNTER

Book 19, Number 4313:

    It has been narrated on the authority of Abu Huraira that the Messenger of Allah (may peace be upon him) said : Do not desire an encounter with the enemy; but when you encounter them, be firm.

Book 19, Number 4314:

    It is narrated by Abu Nadr that he learnt from a letter sent by a man from the Aslam tribe, who was a Companion of the Holy Prophet (may peace be upon him) and whose name was 'Abdullah b. Abu Aufa, to 'Umar b. 'Ubaidullah when the latter marched upon Haruriyya (Khawarij) informing him that the Messenger of Allah (may peace be upon him) in one of those days when lie was confronting the enemy waited until the sun had declined. Then he stood up (to address the people) and said: O ye men, do not wish for an encounter with the enemy. Pray to Allah to grant you security; (but) when you (have to) encounter them exercise patience, and you should know that Paradise is under the shadows of the swords. Then the Messenger of Allah (may peace be upon him) stood up (again) and said: O Allah. Revealer of the Book, Disperser of the clouds, Defeater of the hordes, put our enemy to rout and help us against them.

Chapter 7 : DESIRABILITY OF PRAYING FOR VICTORY AT THE TIME OF CONFRONTATION WITH THE ENEMY

Book 19, Number 4315:

    It is narrated on the authority of Ibn Abu Aufa that the Messenger of Allah (may peace be upon him) cursed the tribes (who had marched upon Medina with a combined force in 5 H) and said: O Allah, Revealer of the Book, swift in (taking) account, put the tribes to rout. O Lord, defeat them and shake them.

Book 19, Number 4316:

    This hadith has been transmitted on the authority of Ibn Abu Aufa with a slight variation of words.

Book 19, Number 4317:

    This hadith has been narrated on the authority of Ibn 'Uyaina through another chain of transmitters (who added the words) "the Disperser of clouds" in his narration.

Book 19, Number 4318:

    It is narrated on the authority of Anas that the Messenger of Allah (may peace be upon him) said on the day of the Battle of Ubud: O Allah, if Thou wilt (defeat Muslims), there will be none on the earth to worship Thee.

Chapter 8 : PROHIBITION OF KILLING WOMEN AND CHILDREN IN WAR

Book 19, Number 4319:

    It is narrated on the authority of 'Abdullah that a woman was found killed in one of the battles fought by the Messenger of Allah (may peace be upon him). He disapproved of the killing of women and children.

Book 19, Number 4320:

    It is narrated by Ibn 'Umar that a woman was found killed in one of these battles; so the Messenger of Allah (may peace be upon him) forbade the killing of women and children.

Chapter 9 : PERMISSIBILITY OF KILLING WOMEN AND CHILDREN IN THE NIGHT RAIDS, PROVIDED IT IS NOT DELIBERATE

Book 19, Number 4321:

    It is reported on the authority of Sa'b b. Jaththama that the Prophet of Allah (may peace be upon him), when asked about the women and children of the polytheists being killed during the night raid, said: They are from them.

Book 19, Number 4322:

    It is narrated by Sa'b b. Jaththama that he said (to the Holy Prophet): Messenger of Allah, we kill the children of the polytheists during the night raids. He said: They are from them.

Book 19, Number 4323:

    Sa'b b. Jaththama has narrated that the Prophet (may peace be upon him) asked: What about the children of polytheists killed by the cavalry during the night raid? He said: They are from them.

Chapter 10 : JUSTIFICATION FOR CUTTING DOWN THE TREES AND BURNING THEM

Book 19, Number 4324:

    It is narrated on the authority of 'Abdullah that the Messenger of Allah (may peace be upon him) ordered the date-palms of Banu Nadir to be burnt and cut. These palms were at Buwaira. Qutaibah and Ibn Rumh in their versions of the tradition have added: So Allah, the Glorious and Exalted, revealed the verse: "Whatever trees you have cut down or left standing on their trunks, it was with the permission of Allah so that He may disgrace the evil-doers" (lix. 5).

Book 19, Number 4325:

    It is narrated on the authority of Ibn Umar that the Messenger of Allah (may peace be upon him) caused the date-palms of Banu Nadir to be cut down and burnt. It is in this connection that Hassan (the poet) said:

      It was easy for the nobles of Quraish to barn Buwaira whose sparks were flying in all directions.

    in the same connection was revealed the Qur'anic verse: "Whatever trees you have cut down or left standing on their trunks."

Book 19, Number 4326:

    'Abdullah b. Umar reported that Allah's Apostle (may peace be upon him) burnt the date-palms of Banu Nadir.

Chapter 11 : THE SPOILS OF WAR ESPECIALLY MADE LAWFUL FOR THIS UMMA

Book 19, Number 4327:

    It has been narrated by Abu Huraira that the Messenger of Allah (may peace be upon him) said: One of the Prophets made a holy war. He said to his followers: One who has married a woman and wants to consummate to his marriage but has not yet done so; another who has built a house but has not yet erected its roof; and another who has bought goats and pregnantshe-camels and is waiting for their offspring-will not accommpany me. So he marched on and approached a village at or about the time of the Asr prayers. He said to the sun: Thou art subserviant (to Allah) and so am I. O Allah, stop it for me a little. It was stopped for him until Allah granted him victory. The people gathered the spoils of war (at one place). A fire approached the spoils to devour them, but it did not devour them. He (the Holy Prophet) said: Some of you have been guilty of misappropriation. So one man from each tribe should swear fealty to me. The did so (putting their hands into his). The hand of one man stuck to his hand and the Prophet (may peace be upon him) said: Your tribe is guilty of misappropriation. Let all the members of your tribe swear fealty to me one by one. They did so, when the hands of two or three persons got stuck with his hand. He said: You have misappropriated. So they took out gold equal in volume to the head of a cow. They-placed it among the spoils on the earth. Then the fire approached the spoils and devoured them. The spoils of war were not made lawful for any people before us, This is because Allah saw our weakness and humility and made them lawful for us.

Chapter 12 : SPOILS OF WAR

Book 19, Number 4328:

    A hadith has been narrated by Mus'ab b. Sa'd who heard it from his father as saying: My father took a sword from Khums and brought it to the Holy Prophet (may peace be upon him) and said: Grant it to me. He refused. At this Allah revealed (the Qur'anic verse): "They ask thee concerning the spoils of war. Say: The spoils of war are for Allah and the Apostle" (viii. 1).

Book 19, Number 4329:

    A hadith has been narrated by Mus'ab b. Sa'd who heard it from his father as saying: "Four verses of the Qur'an have been revealed about me. I found a sword (among the spoils of war). It was brought to the Holy Prophet (may peace be upon him). He (my father) said: Messenger of Allah, bestow it upon me. The Apostle of Allah (may peace be upon him) said: Place it there. Then he (my father) stood up and the Messenger of Allah (may peace be upon him) said to him: Place it from where you got it. (At this) he (my father) said again: Messenger of Allah, bestow it upon me Shall I be treated like one who has no share in (the booty) ? The Apostle of Allah (may peace be upon him said: Place it from where you got it. At this was revealed the verse: "They ask thee about the spoils of war.... Say: The spoils of war are for Allah and the Messenger "

Book 19, Number 4330:

    It has been narrated on the authority of Ibn Umar that the Prophet (may peace be upon him) sent an expedition to Najd and I was among the troops. They got a large number of camels as a booty. Eleven or twelve camels fell to the lot of every fighter and each of them also got one extra camel.

Book 19, Number 4331:

    Ibn 'Umar reported that Allah's Messenger (may peace be upon him) sent an expedition to Najd and Ibn Umar was also among the troops, and their share (of the spoils) came to twelve camels and they were given one camel over and above that. and Allah's Messenger (may peace be upon him) did not make any change in it.

Book 19, Number 4332:

    It has been narrated by Ibn 'Umar that the Messenger of Allah (may peace be upon him) sent an expedition to Najd, and I (also) went with the troops. We got camels and goats as spoils of war, and our share amounted to twelve camels per head, and the Messenger of Allah (may peace be upon him) gave an extra camel to each of us.

Book 19, Number 4333:

    This hadith has been narrated on the authority of 'Ubaidullah with the same chain of transmitters.

Book 19, Number 4334:

    Ibn Aun said: I wrote to Nafi' asking him about Nafl (spoils of war) and be wrote to me that Ibn 'Umar was among that expedition. (The rest of the hadith is the same.)

Book 19, Number 4335:

    A hadith has been narrated by Salim who learnt it from his father and said: The Messenger of Allah (may peace be upon him) gave us an extra (camel) besides our share of Khums; (and in this extra share) I got a Sharif (and a Sharif is a big old camel).

Book 19, Number 4336:

    Ibn Shihab reported: It reached me through Ibn Umar that Allah's Messenger (may peace be upon him) gave a share of spoils to the troop. The rest of the hadith is the same.

Book 19, Number 4337:

    It has been narrated on the authority of Abdullah b. 'Umar that the Messenger of Allah (may peace be upon him) used to give (from the spoils of war) to small troops seat on expeditions something more than the due share of each fighter in a large force. And Khums (one-fifth of the total spoils) was to be reserved (for Allah and His Apostle) in all cases.

Book 19, Number 4338:

    Abu Muammad al-Ansari, who was the close companion of Abu Qatada. narrated the hadith (which follows).

Book 19, Number 4339:

    Abu Muhammad, the freed slave of Abu Qatada reported on the authority of Abu Qatda and narrated the hadith.

Chapter 13 : REGARDING THE RIGHT OF THE FIGHTER TO THE BELONGINGS OF THE ONE KILLED BY HIM IN THE FIGHT

Book 19, Number 4340:

    Abu Qatada reported: We accompanied the Messenger of Allah (my peace be upon him) on an expedition in the year of the Battle of Hunain. When we encountered the enemy, (some of the Muslims turned back (in fear). I saw that a man from the polytheists overpowered one of the Muslims. I turned round and attacked him from behind giving a blow between his neck and shoulder. He turned towards me and grappled with me in such a way that I began to see death staring me in the face. Then death overtook him and left me alone. I joined 'Umar b. al-Khattab who was saying: What has happened to the people (that they are retreating)? I said: It is the Decree of Allah. Then the people returned. (The battle ended in a victory for the Muslims) and the Messenger of Allah (may peace be upon him) sat down (to distribute the spoils of war). He said: One who has killed an enemy and can bring evidence to prove it will get his belongings. So I stood up and said: Who will give evidence for me? Then I sat down. Then he (the Holy Prophet) said like this. I stood up (again) and said: Who will bear witness for me? He (the Holy Prophet) made the same observation the third time, and I stood up (once again). Now the Messenger of Allah (may peace be upon him) said: What has happened to you, O Abu Qatada? Then I related the (whole) story, to him. At this, one of the people said: He has told the truth. Messenger of Allah 1 The belongings of the enemy killed by him are with me. Persuade him to forgo his right (in my favour). (Objecting to this proposal) Abu Bakr said: BY Allah, this will not happen. The Messenger of Allah (may peace be upon him) will not like to deprive one of the lions from among the lions of Allah who fight in the cause of Allah and His Messenger and give thee his share of the booty. So the Messenger of Allah (may peace he upon him) said: He (Abu Bakr) has told the truth, and so give the belongings to him (Abu Qatada). So he gave them to me. I sold the armour (which was a part of my share of the booty) and bought with the sale proceeds a garden in the street of Banu Salama. This was the first property I acquired after embracing Islam.
    In a version of the hadith narrated by Laith, the words uttered by Abu Bakr are: "No, never ! He will not give it to a fox from the Quraish leaving aside a lion from the lions of Allah among. . . ." And the hadith is closed with the words: "The first property I acquired."

Book 19, Number 4341:

    It has been narrated on the authority of 'Abd al-Rahman b. Auf who said: While I was standing in the battle array on the Day of Badr, I looked towards my right and my left, and found myself between two boys from the Ansar quite young in age. I wished I were between stronger persons. One of them made a sign to me and. said: Uncle, do you recognise Abu Jahl? 1 said: Yes. What do you want to do with him, O my nephew? He said: I have been told that he abuses the Messenger of Allah (may peace be upon him). By Allah, in Whose Hand is my life, if I see him (I will grapple with him) and will not leave him until one of us who is destined to die earlier is killed. The narrator said: I wondered at this. Then the other made a sign to me and said similar words. Soon after I saw Abu Jahl. He was moving about among men. I said to the two boys: Don't you see? He is the man you were inquiring about. (As soon as they heard this), they dashed towards him, struck him with their swords until he was killed. Then they returned to the Messenger of Allah (may peace be upon him) and informed him (to this effect). He asked: Which of you has killed him? Each one of them said: I have killed him. He said: Have you wiped your swords? They said: No. He examined their swords and said: Both of you have killed him. He then decided that the belongings of Abu Jahl he handed over to Mu'adh b. Amr b. al-Jamuh. And the two boys were Mu'adh b. Amr b. Jawth and Mu'adh b. Afra.

Book 19, Number 4342:

    Auf b. Malik has narrated that a man from the Himyar tribe killed an enemy and wanted to take the booty. Khalid b. Walid, who was the commander over them, forbade, him. 'Auf b Malik (the narrator) came to the Messenger of Allah (may peace be upon him) and informed him (to this effect). The latter asked Khalid: What prevented you from giving the booty to him? Khalid said: I thought it was too much. He (the Holy Prophet) said: Hand it over to him. Now when Khalid by Auf, the latter pulled him by his cloak and said (by way of chafing him): Hasn't the same thing happened what I reported to you from the Messenger of Allah (may peace he upon him)? When the Messenger of Allah (may peace be upon him) heard it. he was angry (and said): Khalid, don't give him, Khalid, don't give him. Are you going to desert the commanders appointed by roe? Your similitude and theirs is like a person who took camels and sheep for grazing. He grazed them and when it was time for them to have a drink, he brought them to a pool. So they drank from it, drinking away its clear water and leaving the turbid water below So the clear water (i.e. the best reward) is for you and the turbid water (i e. blame) is for them.

Book 19, Number 4343:

    It has been narrated on the authority of Auf b. Malik al-Ashja'i who said: I joined the expedition that marched under Zaid b. Haritha to Muta, and I received reinformcement from the Yemen. (After this introduction), the narrator narrated the tradition that had gone before except that in his version Auf was reported to have said (to Khalid): Khalid, didn't you know that the Messenger of Allah (way peace be upon him) had decided In favour of giving the booty (sized from an enemy) to one who killed him? He (Khalid) said: Yes. but I thought it was too much.

Book 19, Number 4344:

    It has been reported by Salama b. al-Akwa': We fought the Battle of Hawazin along with the Messenger of Allah (may peace be upon him). (One day) when we were having our breakfast with the Messenger of Allah (may peace he upon him), a man came riding a red camel. He made it kneel down, extracted a strip of leather from its girth and tethered the camel with it. Then he began to take food with the people and look (curiously around). We were in a poor condition as some of us were on foot (being without any riding animals). All of a sudden, he left us hurriedy, came to his camel, untethered it, made it kneel down, mounted it and urged the beast which ran off with him. A man on a brown rhe-camel chased him (taking him for a spy). Salama (the narrator) said: I followed on foot. I ran on until I was near the thigh of the she-camel. I advanced further until I was near the haunches of the camel. I advanced still further until I caught hold of the nosestring of the camel. I made it kneel down. As soon as it placed its knee on the ground, I drew my sword and struck at the head, of the rider who fell down. I brought the camel driving it along with the man's baggage and weapons. The Messenger of Allah (may peace be upon him) came forward to meet me and the people were with him. He asked: Who has killed the man? The people said: Ibn Akwa'. He said: Everything of the man is for him (Ibn Akwa').

Chapter 14 : ADDITIONAL AWARD TO THE FIGHTERS AND REPATRIATION OF THE ENEMY PRISONERS AS A RANSOM FOR THE MUSLIMS

Book 19, Number 4345:

    It has been narrated on the authority of Salama (b. al-Akwa') who said: We fought against the Fazara and Abu Bakr was the commander over us. He had been appointed by the Messenger oi Allah (may peace be upon him). When we were onlv at an hour's distance from the water of the enemy, Abu Bakr ordered us to attack. We made a halt during the last part of the night tor rest and then we attacked from all sides and reached their watering-place where a battle was fought. Some of the enemies were killed and some were taken prisoners. I saw a group of persons that consisted of women and children. I was afraid lest they should reach the mountain before me, so I shot an arrow between them and the mountain. When they saw the arrow, they stopped. So I brought them, driving them along. Among them was a woman from Banu Fazara. She was wearing a leather coat. With her was her daughter who was one of the prettiest girls in Arabia. I drove them along until I brought them to Abu Bakr who bestowed that girl upon me as a prize. So we arrived in Medina. I had not yet disrobed her when the Messenger of Allah (may peace be upon him) met me in the street and said: Give me that girl, O Salama. I said: Messenger of Allah, she has fascinated me. I had not yet disrobed her. When on the next day. the Messenger of Allah (may peace be upon him) ag;tin met me in the street, he said: O Salama, give me that girl, may God bless your father. I said: She is for you. Messenger of Allah ! By Allah. I have not yet disrobed her. The Messenger of Allah (may peace be upon him) sent her to the people of Mecca, and surrendered her as ransom for a number of Muslims who had been kept as prisoners at Mecca.

Chapter 15 : FAI' (PROPERTY TAKEN FROM THE ENEMY WITHOUT A FORMAL WAR)

Book 19, Number 4346:

    It has been narrated on the authority of Abu Huraira that the Messenger of Allah (may peace be upon him) said: If you come to a township (which has surrendered without a formal war) and stay therein, you have a share (that will be in the form of an award) in (the properties obtained from) it. If a township disobeys Allah and His Messenger (and actually fights against the Muslims) one-fifth of the booty seized therefrom is for Allah and His Apostle and the rest is for you.

Book 19, Number 4347:

    It has been narrated on the authority of Umar, who said: The properties abandoned by Banu Nadir were the ones which Allah bestowed upon His Apostle for which no expedition was undertaken either with cavalry or camelry. These properties were particularly meant for the Holy Prophet (may peace be upon him). He would meet the annual expenditure of his family from the income thereof, and would spend what remained for purchasing horses and weapons as preparation for Jihad.

Book 19, Number 4348:

    This hadith has been narrated on the authority of Zuhri.

Book 19, Number 4349:

    It is reported by Zuhri that this tradition was narrated to him by Malik b. Aus who said: Umar b. al-Khattab sent for me and I came to him when the day had advanced. I found him in his house sitting on his bare bed-stead, reclining on a leather pillow. He said (to me): Malik, some people of your tribe have hastened to me (with a request for help). I have ordered a little money for them. Take it and distribute it among them. I said: I wish you had ordered somebody else to do this job. He said: Malik, take it (and do what you have been told). At this moment (his man-servant) Yarfa' came in and said: Commander of the Faithful, what do you say about Uthman, Abd al-Rabman b. 'Auf, Zubair and Sa'd (who have come to seek an audience with you)? He said: Yes, and permitted them. so they entered. Then he (Yarfa') came again and said: What do you say about 'Ali and Abbas (who are present at the door)? He said: Yes, and permitted them to enter. Abbas said: Commander of the Faithful, decide (the dispute) between me and this sinful, treacherous, dishonest liar. The people (who were present) also said: Yes. Commander of the Faithful, do decide (the dispute) and have mercy on them. Malik b. Aus said: I could well imagine that they had sent them in advance for this purpose (by 'Ali and Abbas).'Umar said: Wait and be patient. I adjure you by Allah by Whose order the heavens and the earth are sustained, don't you know that the Messenger of Allah (may peace be upon him) said: "We (prophets) do not have any heirs; what we leave behind is (to be given in) charity"? They said: Yes. Then he turned to Abbas and 'Ali and said: I adjure you both by Allah by Whose order the heavens and earth are sustained, don't you know that the Messenger of Allah (may peace be upon him) said:"We do not have any heirs; what we leave behind is (to be given in) charity"? They (too) said: Yes. (Then) Umar said: Allah, the Glorious and Exalted, had done to His Messenger (may peace be upon him) a special favour that He has not done to anyone else except him. He quoted the Qur'anic verse: "What Allah has bestowed upon His Apostle from (the properties) of the people of township is for Allah and His Messenger". The narrator said: I do not know whether he also recited the previous verse or not. Umar continued: The Messenger of Allah (may peace be upon him) distrbuted among you the properties abandoned by Banu Nadir. By Allah, he never preferred himself over you and never appropriated anything to your exclusion. (After a fair distribution in this way) this property was left over. The Messenger of Allah (may peace be upon him) would meet from its income his annual expenditure, and what remained would be deposited in the Bait-ul-Mal. (Continuing further) he said: I adjure you by Allah by Whose order the heavens and the earth are sustained. Do you know this? They said: Yes. Then he adjured Abbas and 'All as he had adjured the other persons and asked: Do you both know this? They said: Yes. He said: When the Messenger of Allah (may peace be upon him) passed away, Abu Bakr said: "I am the successor of the Messenger of Allah (may peace be upon him)." Both of you came to demand your shares from the property (left behind by the Messenger of Allah). (Referring to Hadrat 'Abbas), he said: You demanded your share from the property of your nephew, and he (referring to 'Ali) demanded a share on behalf of his wife from the property of her father. Abu Bakr (Allah be pleased with him) said: The Messenger of Allah (may peace be upon him) had said: "We do not have any heirs; what we leave behind is (to be given in) charity." So both of you thought him to be a liar, sinful, treacherous and dishonest. And Allah knows that he was true, virtuous, well-guided and a follower of truth. When Abu Bakr passed away and (I have become) the successor of the Messenger of Allah (may peace be upon him) and Abu Bakr (Allah be pleased with him), you thought me to be a liar, sinful, treacherous and dishonest. And Allah knows that I am true, virtuous, well-guided and a follower of truth. I became the guardian of this property. Then you as well as he came to me. Both of you have come and your purpose is identical. You said: Entrust the property to us. I said: If you wish that I should entrust it to you, it will be on the condition that both of you will undertake to abide by a pledge made with Allah that you will use it in the same way as the Messenger of Allah (may peace be upon him) used it. So both of you got it. He said: Wasn't it like this ? They said: Yes. He said: Then you have (again) come to me with the request that I should adjudge between you. No, by Allah. I will not give any other judgment except this until the arrival of the Doomsday. If you are unable to hold the property on this condition, return it to me.

Book 19, Number 4350:

    The same hadith has been narrated by a different chain of transmitters with a slight variation in wording: 'Umar b. al-Khattab sent for me and said: Some families from your tribe have come to me (then follows the foregoing hadith) by Malik with the difference that the Messenger of Allah (may peace be upon him) would spend on his family for a year. And sometimes Ma'mar said: He would retain sustenance for his family for a year, and what was left of that he spent in the cause of Allah, the Majestic and Exalted.

Chapter 16 : THE SAYING OF THE PROPHET (MAY PEACE BE UPON HIM): "WE (PROPHETS) DO NOT HAVE ANY HEIRS; WHAT WE LEAVE BEHIND IS (TO BE GIVEN IN) CHARITY"

Book 19, Number 4351:

    It is narrated on the authority of 'A'isha who said: When the Messenger of Allah (may peace be upon him) passed away, his wives made up their minds to send 'Uthman b. 'Affan (as their spokesman) to Abu Bakr to demand from him their share from the legacy of the Holy Prophet (may peace be upon him). (At this), A'isha said to them: Hasn't the Messenger of Allah (may peace be upon him) said: "We (Prophets) do not have any heirs; what we leave behind is (to be given in) charity"?

Book 19, Number 4352:

    It is narrated on the authority of Urwa b. Zubair who narrated from A'isha that she informed him that Fatima, daughter of the Messenger of Allah (may peace be upon him), sent someone to Abu Bakr to demand from him her share of the legacy left by the Messenger of Allah (may peace be upon him) from what Allah had bestowed upon him at Medina and Fadak and what was left from one-filth of the income (annually received) from Khaibar. Abu Bakr said: The Messenger of Allah (may peace be upon him) said: "We (prophets) do not have any heirs; what we leave behind is (to be given in) charity." The household of the Messenger of Allah (may peace be upon him) will live on the income from these properties, but, by Allah, I will not change the charity of the Messenger of Allah (may peace be upon him) from the condition in which it was in his own time. I will do the same with it as the Messenger of Allah (may peace be upun him) himself used to do. So Abu Bakr refused to hand over anything from it to Fatima who got angry with Abu Bakr for this reason. She forsook him and did not talk to him until the end of her life. She lived for six months after the death of the Messenger of Allah (may peace be upon him). When she died, her husband. 'Ali b. Abu Talib, buried her at night. He did not inform Abu Bakr about her death and offered the funeral prayer over her himself. During the lifetime of Fatima, 'All received (special) regard from the people. After she had died, he felt estrangement in the faces of the people towards him. So he sought to make peace with Abu Bakr and offer his allegiance to him. He had not yet owed allegiance to him as Caliph during these months. He sent a person to Abu Bakr requesting him to visit him unaccompanied by anyone (disapproving the presence of Umar). 'Umar said to Abu Bakr: BY Allah, you will not visit them alone. Abu Bakr said: What will they do to me? By Allah, I will visit them. And he did pay them a visit alone. 'All recited Tashahhud (as it is done in the beginning of a religious sermon); then said: We recognise your moral excellence and what Allah has bestowed upon you. We do not envy the favour (i.e. the Catiphate) which Allah nas conferred upon you; but you have done it (assumed the position of Caliph) alone (without consulting us), and we thought we had a right (to be consulted) on account of our kinship with the Messenger of Allah (may peace be upon him). He continued to talk to Abu Bakr (in this vein) until the latter's eyes welled up with tears. Then Abd Bakr spoke and said: By Allah, in Whose Hand is my life, the kinship of the Messenger of Allah (may peace be upon him) is dearer to me than the kinship of my own people. As regards the dispute that has arisen between you and me about these properties, I have not deviated from the right course and I have not given up doing about them what the Messenger of Allah (may peace be upon him) used to do. So 'Ali said to Abu Bakr: This aftetnoon is (fixed) for (swearing) allegiance (to you). So when Abu Bakr had finished his Zuhr prayer, he ascended the pulpit and recited Tashahhud, and described the status of 'Ali, his delay in swearing allegiance and the excuse which lie had offered to him (for this delay). (After this) he asked for God's forgiveness. Then 'Ali b. Abu Talib recited the Tashahhud. extolled the merits of Abu Bakr and (said that) his action was nott prompted by any jealousy of Abu Bakr on his part or his refusal to accept the high position which Allah had conferred upon him, (adding :) But we were of the opinion that we should have a share in the government, but the matter had been decided without taking us into confidence, and this displeased us. (Hence the delay in offering allegiance. The Muslims were pleased with this (explanation) and they said: You have done the right thing. The Muslims were (again) favourably inclined to 'Ali since he adopted the proper course of action.

Book 19, Number 4353:

    It has been narrated on the authority of 'A'isha that Fatima and 'Abbas approached Abu Bakr, soliciting transfer of the legacy of the Messenger of Allah (may peace be upon him) to them. At that time, they were demanding his (Holy Prophet's) lands at Fadak and his share from Khaibar. Abu Bakr said to them: I have heard from the Messenger of Allah (may peace be upon him). Then he quoted the hadith having nearly the same meaning as the one which has been narrated by Uqail on the authority of al-Zuhri (and which his gone before) except that in his version he said : Then 'Ali stood up, extolled the merits of Abu Bakr mentioned his superiority, and his earlier acceptance of Islam. Then he walked to Abu Bakr and swore allegiance to him. (At this) people turned towards 'Ali and said: you have done the right thing. And they became favourably inclined to 'Ali after he had adopted the proper course of action.

Book 19, Number 4354:

    It has been narrated by 'Urwa b Zubair on the authority of 'A'isha, wife of the Holy Prophet (may peace be upon him), that Fatima, daughter of the Messenger of Allah (may peace be upon him), requested Abu Bakr, after the death of the Messenger of Allah (may peace he upon him), that he should set apart her share from what the Messenger of Allah (may peace be upon him) had left from the properties that God had bestowed upon him. Abu Bakr said to her: The Messenger of Allah (may peace be npon him) said: "We do not have any heirs; what we leave behind is Sadaqa (charity)." The narrator said: She (Fatima) lived six months after the death of the Messenger of Allah (may peace be upon him) and she used to demand from Abu Bakr her share from the legacy of the Messenger of Allah (may peace be upon him) from Khaibar, Fadak and his charitable endowments at Medina. Abu Bakr refused to give her this, and said: I am not going to give up doing anything which the Messenger of Allah (may peace be upon him) used to do. I am afraid that it I go against his instructions in any matter I shall deviate from the right course. So far as the charitable endowments at Medina were concerned, 'Umar handed them over to 'All and Abbas, but 'Ali got the better of him (and kept the property under his exclusive possession). And as far as Khaibar and Fadak were concerned 'Umar kept them with him, and said: These are the endowments of the Messenger of Allah (may peace be upon him) (to the Umma). Their income was spent on the discharge of the responsibilities that devolved upon him on the emergencies he had to meet. And their management was to be in the hands of one who managed the affairs (of the Islamic State). The narrator said: They have been managed as such up to this day.

Book 19, Number 4355:

    It has been narrated on the authority of Abu Huraira that the Messenger of Allah (may peace be upon him) said: My heirs cannot share even a dinar (from my legacy) ; what I leave behind after paving mtintenance allowance to my wives and remuneration to my manager is (to go in) charity.

Book 19, Number 4356:

    A similar hadith has been narrated on the authority of Abu Zinad through a different chain of transmitters.

Book 19, Number 4357:

    It his been narrated on the authority of Abu Huraira that the Messenger of Allah (may peace be upon him)said: "We do not have any heirs; what we leave behind is a charitable endowment."

Chapter 17 : DISTRIBUTION OF THE SPOILS AMONG THE FIGHTERS

Book 19, Number 4358:

    It has been narrated on the authority of Ibn Umar that the Messenger of Allah (may peace be upon him) allowed two shares from the spoils to the horseman and one share to the footman.

Book 19, Number 4359:

    The same tradition has been narrated on the authority of Ubaidullah by a different chain of transmitters who do not mention the words: "from the booty".

Chapter 18 : THE HELP WITH ANGELS IN BADR AND THE PERMISSIBILITY OF THE SPOILS OF WAR

Book 19, Number 4360:

    It has been narrated on the authority of 'Umar b. al-Khattab who said: When it was the day on which the Battle of Badr was fought, the Messenger of Allah (may peace be upon him) cast a glance at the infidels, and they were one thousand while his own Companions were three hundred and nineteen. The Holy Prophet (may peace be upon him) turned (his face) towards the Qibla Then he stretched his hands and began his supplication to his Lord: "O Allah, accomplish for me what Thou hast promised to me. O Allah, bring about what Thou hast promised to me. O Allah, if this small band of Muslims is destroyed. Thou will not be worshipped on this earth." He continued his supplication to his Lord, stretching his hands, facing the Qibla, until his mantle slipped down from his shoulders. So Abu Bakr came to him, picked up his mantle and put it on his shoulders. Then he embraced him from behind and said:. Prophet of Allah, this prayer of yours to your Lord will suffice you, and He will fulfil for you what He has promised you. So Allah, the Glorious and Exalted, revealed (the Qur'anic verse): "When ye appealed to your Lord for help, He responded to your call (saying): I will help you with one thousand angels coming in succession." So Allah helped him with angels.
    Abu Zumail said that the badith was narrated to him by Ibn 'Abbas who said: While on that day a Muslim was chasing a disbeliever who was going ahead of him, he heard over him' the swishing of the whip and the voice of the rider saying: Go ahead, Haizi'm ! He glanced at the polytheist who had (now) fallen down on his back. When he looked at him (carefully he found that) there was a scar on his nose and his face was torn as if it had been lashed with a whip, and had turned green with its poison. An Ansari came to the Messenger of Allah (may peace be upon him) and related this (event) to him. He said: You have told the truth. This was the help from the third heaven. The Muslims that day (i.e. the day of the Battle of Badr) killed seventy persons and captured seventy. The Messenger of Allah (may peace be upon him) said to Abu Bakr and 'Umar (Allah be pleased with them): What is your opinion about these captives? Abu Bakr said: They are our kith and kin. I think you should release them after getting from them a ransom. This will be a source of strength to us against the infidels. It is quite possible that Allah may guide them to Islam. Then the Messenger of Allah (may peace be upon him) said: What is your opinion. Ibn Khattab? He said: Messenger of Allah. I do not hold the same opinion as Abu Bakr. I am of the opinion that you should hand them over to us so that we may cut off their heads. Hand over 'Aqil to 'Ali that he may cut off his head, and hand over such and such relative to me that I may but off his head. They are leaders of the disbelievers and veterans among them. The Messenger of Allah (may peace be upon him) approved the opinion of Abu Bakr and did not approve what I said The next day when I came to the Messenger of Allah (may peace be upon him), I found that both he and Abu Bakr were sitting shedding tears. I said: Messenger of Allah, why are you and your Companion shedding tears? Tell me the reason. For I will weep ate, if not, I will at least pretend to weep in sympathy with you. The Messenger of Allah (may peace be upon him) said: I weep for what has happened to your companions for taking ransom (from the prisoners). I was shown the torture to which they were subjected. It was brought to me as close as this tree. (He pointed to a tree close to him.) Then God revealed the verse: "It is not befitting for a prophet that he should take prisoners until the force of the disbelievers has been crushed. . . " to the end of the verse: "so eat ye the spoils of war, (it is) lawful and pure. So Allah made booty lawful for them."

Chapter 19 : BINDING THE PRISONERS AND PUTTING THEM IN CONFINMENT AND JUSTIFICATION FOR SETTING THEM FREE WITHOUT ANY RANSOM

Book 19, Number 4361:

    It has been narrated on the authority of Abu Huraira who said: The Messenger of Allah (may peace be upon him) sent some horsemen to Najd. They captured a man. He was from the tribe of Banu Hanifa and was called Thumama b. Uthal. He was the chief of the people of Yamama. People bound him with one of the pillars of the mosque. The Messenger of Allah (may peace be upon him) came out to (see) him. He said: O Thumama, what do you think? He replied: Muhammad, I have good opinion of you. If you kill me, you will kill a person who has spilt blood. If you do me a favour, you will do a favour to a grateful person. If you want wealth, ask and you will get what you will demand. The Messenger of Allah (may peace be pon him) lefthim (in this condition) for two days, (and came to him again) and said: What do you think, O Thumama? He replied: What I have already told you. If you do a favour, you will do a favour to a grateful person. If you kill me, you will kill a person who has spilt blood. If you want wealth, ask and you will get what you will demand. The Messenger of Allah (may peace be upon him) left him until the next day when he (came to him again) and said: What do you think, O Thumama? He replied: What I have already told you. If you do me a favour, you will do a favour to a grateful person. If you kill me, you will kill a person who has spilt blood. If you want wealth ask and you will get what you will demand. The Messenger of Allah (may peace be upon him) said: Set Thumama free. He went to a palm-grove near the mosque and took a bath. Then he entered the mosque and said: I bear testimony (to the truth) that there is no god but Allah and I testify that Muhammad is His bondman and His messenger. O Muhammad, by Allah, there was no face on the earth more hateful to me than your face, but (now) your face has become to me the dearest of all faces. By Allah, there was no religion more hateful to me than your religion, but (now) your religion has become the dearest of all religions to me. By Allah, there was no city more hateful to me than your city, but (now) your city has become the dearest of all cities to me. Your horsemen captured me when I intended going for Umra. Now what is your opinion (in the matter)? The Messenger of Allah (may peace be upon him) announced good tidings to him and told him to go on 'Umra. When he reached Mecca, somebody said to him: Have you changed your religion? He said: No! I have rather embraced Islam with the Messenger of Allah (may peace be upon him). By Allah, you will not get a single grain of wheat from Yamama until it is permitted by the Messenger of Allah (may peace be upon him).

Book 19, Number 4362:

    The same tradition has been narrated by a different chain of transmitters with a slight difference in the wording.

Chapter 20 : EVACUATION OF THE JEWS FROM THE HIJAZ

Book 19, Number 4363:

    It has been narrated on the authority of Abu Huraira who said: We were (sitting) in the mosque when the Messenger of Allah (may peace be upon him) came to us and said: (Let us) go to the Jews. We went out with him until we came to them. The Messenger of Allah (may peace be upon him) stood up and called out to them (saying): O ye assembly of Jews, accept Islam (and) you will be safe. They said: Abu'l-Qasim, you have communicated (God's Message to us). The Messenger of Allah (may peace be upon him) said : I want this (i.e. you should admit that God's Message has been communicated to you), accept Islam and you would be safe. They said: Abu'l-Qisim, you have communicated (Allah's Message). The Messenger of Allah (may peace be upon him) said: I want this. . . - He said to them (the same words) the third time (and on getting the same reply) he added: You should know that the earth belongs to Allah and His Apostle, and I wish that I should expel you from this land Those of you who have any property with them should sell it, otherwise they should know that the earth belongs to Allah and His Apostle (and they may have to go away leaving everything behind).

Book 19, Number 4364:

    It has been narrated on the authority of Ibn Umar that the Jews of Banu Nadir and Banu Quraizi fought against the Messenger of Allah (may peace be upon him) who expelled Banu Nadir, and allowed Quraiza to stay on, and granted favour to them until they too fought against him Then he killed their men, and distributed their women, children and properties among the Muslims, except that some of them had joined the Messenger of Allah (may peace be upon him) who granted them security. They embraced Islam. The Messenger of Allah (may peace be upon him) turned out all the Jews of Medlina. Banu Qainuqa' (the tribe of 'Abdullah b. Salim) and the Jews of Banu Haritha and every other Jew who was in Medina.

Book 19, Number 4365:

    A similar hadith has been transmitted by a different chain of narrators, but the hadith narrated by Ibn Juraij is more detailed and complete.

Book 19, Number 4366:

    It has been narrated by 'Umar b. al-Khattib that he heard the Messenger of Allah (may peace be upon him) say: I will expel the Jews and Christians from the Arabian Peninsula and will not leave any but Muslim.

Book 19, Number 4367:

    This hadith has been narrated on the authority of Zubair with the same chain of transmitters.

Chapter 21 : JUSTIFICATION FOR KILLING THOSE GUILTY OF BREACH OF TRUST AND MAKING THE PEOPLE OF THE FORT SURRENDER ON THE ARBITRATION OF A JUST PERSON

Book 19, Number 4368:

    It has been narrated on the authority of Abu Sa'id al-Khudri who said: The people of Quraiza surrendered accepting the decision of Sa'd b. Mu'adh about them. Accordingly, the Messenger of Allah (may peace be upon him) sent for Sa'd who came to him riding a donkey. When he approached the mosque, the Messenger of Allah (may peace be upon him) said to the Ansar: Stand up to receive your chieftain. Then he said (to Sa'd): These people have surrendered accepting your decision. He (Sa'd) said: You will kill their fighters and capture their women and children. (Hearing this), the Propbot (may peace he tpon him) said: You have adjudged by the command of God. The narrator is reported to have said: Perhaps he said: You have adjuged by the decision of a king.
    Ibn Muthanna (in his version of the tradition) has not mentioned the alternative words.

Book 19, Number 4369:

    Through the same chain of transmitters Shu'ba has narrated the same tradition in which he says that the Messenger of Allah (may peace be upon him) said (to Sa'd): You have adjudged according to the command of God. And once he said: you have adjudged by the decision of a king.

Book 19, Number 4370:

    It has been narrated on the authority of A'isha who said: Sa'd was wounded on the day of the Battle of the Ditch. A man from the Quraish called Ibn al-Ariqah shot at him an arrow which pierced the artery in the middle of his forearm. The Messenger of Allah (may peacce be upon him) pitched a tent for him in the mosque and would inquire after him being in close proximity. When he returned from the Ditch and laid down his arms and took a bath, the angel Gabriel appeared to him and he was removing dust from his hair (as if he had just returned from the battle). The latter said: You have laid down arms. By God, we haven't (yet) laid them down. So march against them. The Messenger of Allah (may peace be upon him) asked: Where? He poirftad to Banu Quraiza. So the Messenger of Allah (may peace he upon him) fought against them. They surrendered at the command of the Messenger of Allah (may peace be upon him), but he referred the decision about them to Sa'd who said: I decide about them that those of them who can fight be killed, their women and children taken prisoners and their properties distributed (among the Muslims).

Book 19, Number 4371:

    It has been narrated on the authority of Hisham (who learnt it from his father) that the Messenger of Allah (may peace be upon him) said (to Sa'd): You have adjudged their case with the judgment of God. the Exalted and Glorified.

Book 19, Number 4372:

    It has been narrated on the authority of 'A'isha that Sa'd's wound became dry and was going to heal when he prayed: O God, surely Thou knowest that nothing is dearer to me than that I should fight for Thy cause against the people who disbeliever Your Messenger (may peace be upon him) and turned him out (from his native place). If anything yet remains to be decided from the war against the Quraish, spare my life so that I may fight against them in Thy cause. O Lord, I think Thou hast ended the war between us and them. If Thou hast done so, open my wound (so that it may discharge) and cause my death thereby. So the wound begin to bleed from the front part of his neck. The people were not scared except when the blood flowed towards them, and in the mosque along with Sa'd's tent was the tent of Banu Ghifar. They said: O people of the tent, what is it that is coming to us from you? Lo ! it was Sa'd's wound that was bleeding and he died thereof.

Book 19, Number 4373:

    This tradition has been narrated by Hishim through the same chain of transmitters with a little difference in the wording. He said: (His wound) began to bleed that very night and it continued to bleed until he died. He has made the addition that it was then that (a non-believing) poet said:

      Hark, O Sa'd, Sa'd of Banu Mu'adh,
      What have the Quraiaa and Nadir done?
      By thy life ! Sa'd b. Mu'adh>br> Was steadfast on the morn they departed.
      You have left your cooking-pot empty,
      While the cooking-pot of the people is hot and boiling.
      Abu Hubab the nobleman has said,
      O Qainuqa', do not depart.
      They were weighty in their country
      just aa rocks are weighty in Maitan.

Chapter 22 : SHOWING PROMPTITUDE IN JIHAD AND GIVING PRECEDENCE TO THE MORE URGENT OF THE TWO ACTIONS WHILE MAKING A CHOICE BETWEEN THEM

Book 19, Number 4374:

    It has been narrated on the authority of Abdullah who said: On the day he returned from the Battle of Ahzab, the Messenger of Allah (may peace be upon him) made for us an announcement that nobody would say his Zuhr prayer but in the quarters of Banu Quraiza (Some) people, being afraid that the time for prayer would expire, said their prayers before reaching the street of Banu Quraiza. The others said: We will not say our prayer except where the Messenger of Allah (may peace be upon him) has ordered us to say it even if the time expires. (When he learned of the difference in the view of the two groups of the people, the Messenger of Allah (may peace be tipon him) did not blame anyone from the two groups.

Chapter 23 : RETURN OF THEIR GIFTS TO THE ANSAR BY THE MUHAJIRS WHEN THE LATTER GREW RICH AS A REBULT OF THE CONQUESTS

Book 19, Number 4375:

    It has been narrated on the authority of Anas b. Malik who said: When the Muhajirs migrated from Mecca to Medina; they came (in a state that) they had not anything(i.e. money) in theirhands,while the Ansar possessed lands and date palms. They divided their properties with the Muhajirs. The Ansar divided and gave them on the condition that they would give half the fruit from the orchards every year, and the Muhajirs would recompense them by working with them and putting in labour. The mother of Anas b. Malik was called Umm Sulaim and she was also the mother of 'Abdullah b. Talha who was a brother of Anas from his mother's side. The mother of Anas had given the Messenger of Allah (may peace be upon him) her date-palms. He bestowed them upon Umm Aiman, the slave-girl who had been freed by him and was the mother of Usama b. Zaid. When the Messenger of Allah (may peace be upon him) had finished the war with the people of Khaibar and returned to Medina, the Muhajirs returned to the Ansar all the gifts which they had given them out of the fruits. (Anas b. Malik said:) The Messenger of. Allah (may peace be upon him) returned to my mother her date-palms and gave to Umm Aiman instead of them date-palms from his orchard. Ibn Shihab says that Umm Aiman was the mother of Usama b. Zaid who was the slave-girl of 'Abdullah b. 'Abd-ul-Muttalib and hailed from Abyssinia. When Amina gave birth to the Messenger of Allah (may peace be upon him) after the death of his father, Umm Aiman used to nurse him until he grew up. He (later on) freed her and married her to Zaid b. Haritha. She died five months after the death of the Messenger of Allah (may peace be upon him).

Book 19, Number 4376:

    It has been narrated by Anas that (after his migration to Medina) a person placed at the Prophet's (may peace be upon him) disposal some date-palms growing on his land until the lands of Quraiza and Nadir were conquered. Then he began to return to him whatever he had received. (In this connection) my people told me to approach the Messenger of Allah (may peace be upon him) and ask from him what his people had given him or a portion thereof, but the Messenger of Allah (may peace be upon him) had bestowed those trees upon Umm Aiman. So I came to the Prophet (may peace be upon him) and he gave hem (back) to me. Umm Aiman (also) came (at this time). She put the cloth round my neck and said: No, by Allah, we will not give to, you what he has granted to me. The Holy Prophet (may peace be upon him) said: Umm Aiman, let him have them and for you are such and such trees instead. But she said: By Allah, there is no god besides Him. No, never ! The Holy Prophet (may peace be upon him) continued saying: (You will get) such and such. until he had granted her ten times or nearly ten times more (than the original gift).

Chapter 24 : JUSTIFICATION FOR TAKING FOOD IN THE LAND OF THE ENEMY

Book 19, Number 4377:

    It has been narrated on the authority of Abdullah b. Mughaffal who said I found a bag containing fat on the day of the Battle of Khaibar. I caught hold of it and said: I will not give anything today from it to anybody. Then I turned round and saw that the Messenger of Allah (may peace be upon him) was smiling (at my words).

Book 19, Number 4378:

    This tradition has been transmitted by a different chain of narrators with a different wording, the last in the chain being the same narrator, (i.e. 'Abdullah b. Mughaffal), who said: A bag containing food and fat was thrown to us. I lept forward to catch it. Then I turned round and saw (to my surprise) the Messenger of Allah (may peace be upon him) and I felt ashamed of my act in his presence.

Book 19, Number 4379:

    This hadith has been transmitted on the authority of Shu'ba with a slight variation of words.

Chapter 25 : THE HOLY PROPHET'S (MAY PEACE BE UPON HIM) LETTER TO HIRAQL (CEASAR) INVITING HIM TO ISLAM

Book 19, Number 4380:

    It has been narrated on the authority of Ibn Abbas who learnt the tradition personally from Abu Safyan. The latter said: I went out (on a mercantile venture) during the period (of truce) between me and the Messenger of Allah (may peace be upon him). While I was in Syria, the letter of the Messenger of Allah (may peace be upon him) was handed over to Hiraql (Ceasar), the Emperor of Rome (who was on a visit to Jerusalem at that time). The letter was brought by Dihya Kalbi who delivered it to the governor of Busra The governor passed it on to Hiraql, (On receiving the letter), he said: Is there anyone from the people of this man who thinks that he is a prophet. People said: Yes. So, I was called along with a few others from the Quraish. We were admitted to Hiraql and he seated usbefore him. He asked: Which of you has closer kinship with the man who thinks that he is a prophet ? Abu Sufyan said: I. So they seated me in front of him and stated my companions behind me. Then, he called his interpreter and said to him: Tell them that I am going to ask this fellow (i.e. Abu Sufyan) about the man who thinks that he is a prophet. It he tells me a lie, then refute him. Abu Sufyan told (the narrator): By God, if there was not the fear that falsehood would be imputed to me I would have lied. (Then) Hiraqi said to his interpreter: Inquire from him about his ancestry, I said: He is of good ancestry among us. He asked: Has there been a king among his ancestors? I said: No. He asked: Did you accuse him of falsehood before he proclaimed his prophethood ? I said: No. He asked: Who are his follower people of high status or low status? I said: (They are) of low status. He asked: Are they increasing in number or decreasing? I said. No. they are rather increasing. He asked: Does anyone give up his religion, being dissatisfied with it, after having embraced it? I said: No. He asked: Have you been at war with him? I said: Yes. He asked: How did you fare in that war? I said: The war between us and him has been wavering like a bucket, up at one turn and down at the other (i.e. the victory has been shared between us and him by turns). Sometimes he suffered loss at our hands and sometimes we suffered loss at his (hand). He asked: Has he (ever) violated his covenant? I said: No. but we have recently concluded a peace treaty with him for a petiod and we do not know what he is going to do about it. (Abu Sufyin said on oath that he could not interpolate in this dialogue anything from himself more than these words ) He asked: Did anyone make the proclamation (Of prophethood) before him? I said: No. He (now) said to his interpreter: Tell him, I asked him about his ancestry and he had replied that he had the best ancestry. This is the case with Prophets; they are the descendants of the noblest among their people (Addressing Abu Sufyan), he continued: I asked you if there had been a king among his ancestors. You said that there had been none. If there had been a king among his ancestors, I would have said that he was a man demanding his ancestral kingdom. I asked you about his followers whether they were people of high or low status, and you said that they were of rather low status. Such are the followers of the Prophets. I asked you whether you used to accuse him of falsehood before he proclaimed his prophethood, and you said that you did not. So I have understood that when he did not allow himself to tell a lie about the poeple, he would never go to the length of forging a falsehood about Allah. I asked you whether anyone renounced his religion being dissatisfied with it after he had embraced it, and you replied in the negative. Faith is like this when it enters the depth of the heart (it perpetuates them). I asked you whether his followers were increasing or decreasing. You said they were increasing. Faith is like this until it reaches its consummation. I asked you whether you had been at war with him, and you replied that you had been and that the victory between you and him had been shared by turns, sometimes he suffering loss at your hand and sometimes you suffering lost at his. This is how the Prophets are tried before the final victory its theirs. I asked you whether he (ever) violated his covenant, and you said that he did not. This is how the Prophets behave. They never violate (their covenants). I asked you whether anyone before him had proclaimed the same thing, and you replied in the negative. I said: If anyone had made the same proclamation before, I would have thought that he was a man following what had been proclaimed before. (Then) he asked: What does he enjoin upon you? I said: He exhorts us to offer Salat, to pay Zakat, to show due regard to kinship and to practise chastity. He said: It what you have told about him is true, he is certainly a Prophet. I knew that he was to appear but I did not think that he would be from among you. If I knew that I would be able to reach him. I would love to meet him; and it I had been with him. I would have washed his feet (out of reverence). His dominion would certainly extend to this place which is under my feet. Then he called for the letter of the Messenger of Allah (may pface be upon him) and read it. The letter ran as follows: "In the name of Allah, Most Gracious and Most Merciful. From Muhammad, the Messenger of Allah, to Hiraql, the Emperor of the Romans. Peace be upon him who follows the guidance. After this, I extend to you the invitation to accept Islam. Embrace Islam and you will be safe. Accept Islam, God will give you double the reward. And if you turn away, upon you will be the sin of your subjects. "O People of the Book, come to the word that is common between us that we should worship none other than Allah, should not ascribe any partner to Him and some of us should not take their fellows as Lords other than Allah. If they turn away, you should say that we testify to our being Muslims [iii. 64]."
    When he hid finished the reading of the letter, noise and confused clamour was raise around him, and he ordered us to leave. Accordingly, we left. (Addressing my companions) while we were coming out (of the place). I said: Ibn Abu Kabsha (referring sarcastically to the Holy Prophet) has come to wield a great power. Lo! (even) the king of the Romans is afraid of him. I continued to believe that the authority of the Messenger of Allah (may peace be upon him) would triumph until God imbued me with (the spirit of) Islam.

Book 19, Number 4381:

    This hadith has been narrated on the authority of Ibn Shihab with the same chain of transmitters but with the addition : "When Allah inflicted defeat on the armies of Persia, Caesar moved from Hims to Aelia (Bait al-Maqdis) for thanking Allah as He granted him victory." In this hadith these words occur: "From Muhammad, servant of Allah and His Messenger," and said: "The sin of your followers," and also said the words: "to the call of Islam".

Chapter 26 : LETTERS OF THE HOLY PROPHET (MAY PEACE BE UPON HIM) TO THE KINGS OF DISBELIEVERS INVITING THEM TO ALLAH, THE EXALTED AND GLORIOUS

Book 19, Number 4382:

    It has been narrated on the authority of Anas that the Prophet of Allah (may peace be upon him) wrote to Chosroes (King of Persia), Caesar (Emperor of Rome), Negus (King of Abyssinia) and every (other) despot inviting them to Allah, the Exalted. And this Negus was not the one for whom the Messenger of Allah (may peace be upon him) had said the funeral prayers.

Book 19, Number 4383:

    The tradition has been narrated on the authority of Anas b. Malik (the same narrator) through a different chain of transmitters, but this version does not mention: "And he was not the Negus for whom the Prophet (may peace be upon him) had said the funeral prayers."

Book 19, Number 4384:

    It has been narrated on the authority of the same narrator through another chain of transmitters with the same difference in the wording.

Chapter 27 : THE BATTLE OF HUNAIN

Book 19, Number 4385:

    It has been narrated on the authority of 'Abbas who said: I was in the company of the Messenger of Allah (may peace be upon him) on the Day of Hunain. I and Abd Sufyan b. Harith b. 'Abd al-Muttalib stuck to the Messenaer of Allah (may peace be upon him) and we did not separate from him. And the Messenger of Allah (may place be upon him) was riding on his white mule which had been presented to him by Farwa b. Nufitha al-Judhami. When the Muslims had an encounter with the disbelievers, the Muslims fled, falling back, but the Messenger of Allah (may peace be upon him) began to spur his mule towards the disbelievers. I was holding the bridle of the mule of the Messenger of Allah (may peace be upon him) checking it from going very fast, and Abu Sufyan was holding the stirrup of the (mule of the) Messenger of Allah (may peace be upon him), who said: Abbas, call out to the people of al-Samura. Abbas (who was a man with a loud voice) called out at the top of the voice: Where are the people of Samura? (Abbas said:) And by God, when they heard my voice, they came back (to us) as cows come back to their calves, and said: We are present, we are present ! 'Abbas said: They began to fight the infidels. Then there was a call to The Ansar. Those (who called out to them) shouted: O ye party of the Ansar ! O party of the Ansar ! Banu al-Harith b. al-Khazraj were the last to be called. Those (who called out to them) shouted: O Banu Al-Harith b. al-Khazraj! O BanU Harith b. al-Khazraj ! And the Messenger of Allah (may peace be upon him) who was riding on his mule looked at their fight with his neck stretched forward and he said: This is the time when the fight is raging hot. Then the Messenger of Allah (may peace be upon him) took (some) pebbles and threw them in the face of the infidels. Then he said: By the Lord of Muhammad, the infidels are defeated. 'Abbas said: I went round and saw that the battle was in the same condition in which I had seen it. By Allah, it remained in the same condition until he threw the pebbles. I continued to watch until I found that their force had been spent out and they began to retreat.

Book 19, Number 4386:

    A version of the tradition has been transmitted through another chain of narrators. In this version the words uttered by the Holy Prophet (may peace be upon him) (after he had thrown the pebbles in the face of the enemy) are reported as: "By the Lord of the Ka'ba, they have been defeated." And there is at the end the addition of the words: "Until Allah defeated them" (and I imagine) as if I saw the Prophet of Allah (may peace be upon him) chasing them on his mule.

Book 19, Number 4387:

    'Abbas reported: I was with Allah's Apostle (may peace be upon him) on the Day of Hunain. The rest of the hadith is the same but with this variation that the hadith transmitted by Yonus and Ma'mar is more detailed and complete.

Book 19, Number 4388:

    It has been narratedon the authority of Abu Ishaq who said: A man asked Bara' (b. 'Azib): Did you run away on the Day of Hunain. O, Abu Umira? He said: No, by Allah, The Messenger of Allah (may peace be upon him) did not turn his back; (what actually happened was that) some young men from among his companions, who were hasty and who were either without any arms or did not have abundant arms, advanced and met a party of archers (who were so good shots) that their arrows never missed the mark. This party (of archers) belonged to Banu Hawazin and Banu Nadir. They shot at the advancing young men and their arrows were not likely to miss their targets. So these young men turned to the Messenger of Allah (may peace be upon him) while he was riding on his white mule and Abu Sufyan b. al-Harith b. 'Abd al-Muttalib was leading him. (At this) he got down from his mule, invoked God's help, and called out : I am the Prophet. This is no untruth. I am the son of 'Abd al-Muttalib. Then he deplnved his men into battle array.

Book 19, Number 4389:

    It has been narrated (through a different chain of transmitters) by Abu Ishiq that a person said to Bara' (b. 'Azib) : Abu Umara, did you flee on the Day of Hunain? He replied: The Messenger of Allah (may peace be upon him) did not retreat. (What actually happened was that some hasty young men who were either inadequately armed or were unarmed met a group of men from Banu Hawazin and Banu Nadir who happened to be (excellent) archers. The latter shot at them a volley of arrows that did not miss. The people turned to the Messenger of Allah (may peace be upon him). Abu Sufyan b. Harith was leading his mule. So he got down, prayed and invoked God's help. He said: I am the Prophet. This is no untruth. I am the son of Abd al-Muttalib. O God, descend Thy help. Bara' continued: When the battle grew fierce. we, by God. would seek protection by his side, and the bravest among us was he who confronted the onslaught and it was the Holy Prophet (may peace be upon him).

Book 19, Number 4390:

    It has been narrated through a still different chain of transmitters by the same narrator (i.e. Abu Ishaq) who said: I heard from Bara' who was asked by a man from the Qais tribe: Did you run away from the Messenger of Allah (may peace be upon him) on the Day of Hunain? Bara' said: But the Messenger of Allah (may peace be upon him) did not run away. On that day Banu Hawzzin took part in the battle as archers (on the side of the disbelievers). When we attacked them, they retreated and we fell upon the booty; (they rallied) and advanced towards us with arrows. (At that time) I saw the Messenger of Allah (may peace be upon him) riding on his white mule and Abu Sufyan b. al-Harith was holding its bridle. He (the Messenger of Allah was saying: I am the Prophet. This is no untruth. I am a descendant of 'Abd al-Muttalib.

Book 19, Number 4391:

    This hadith has been narrated on the authority of Bara' with another chain of transmitters, but this hadith is short as compared with other ahadith which are more detailed.

Book 19, Number 4392:

    This tradition has been narrated on the authority of Salama who said: We fought by the side of the Messenger of Allah (may peace be upon him) at Hunain. When we encountered the enemy, I advanced and ascended a hillock. A man from the enemy side turned towards me and I shot him with an arrow. He (ducked and) hid himself from me. I could not understand what he did, but (all of a sudden) I saw that a group of people appeared from the other hillock. They and the Companions of the Prophet (may peace be upon him) met in combat, but the Companions of the Prophet turned back and I too turned back defeated. I had two mantles, one of which I was wrapping round the waist (covering the lower part of my body) and the other I was putting around my shoulders. My waist-wrapper got loose and I held the two mantles together. (In this downcast condition) I passed by the Messenger of Allah (may peace be upon him) who was riding on his white mule. He said: The son of Akwa' finds himself to be utterly perplexed. Wher. the Companions gathered round him from all sides. the Messenger of Allah (may peace be upon him) got down from his mule. picked up a handful of dust from the ground, threw it into their (enemy) faces and said: May these faces be deformed 1 There was no one among the enemy whose eyes were not filled with the dust from this handful. So they turned back fleeing. and Allah the Exalted and Glorious defeated them, and the Messenger of Allah (may peace be upon him) distributed their booty among the Muslims.

Chapter 28 : THE BATTLE OF TA'IF

Book 19, Number 4393:

    It has been narrated on the authority of Ibn 'Amr who said: The Messenger of Allah (may peace be upon him) besieged the people of Ta'if, but did get victory over them. He said: God willing, we shall return. His Companions said: Shall we depart without having conquered it? The Messenger of Allah (may peace be upon him) said: (All right) make a raid in the morning. They did so. and were wounded (with the arrows showered upon them). So the Messenger of Allah (may peace be upon him) said: We shall depart tomorrow. (The narrator says): (Now) this (announcement) pleased them, and the Messenger of Allah (may peace be upon him) laughed at (their waywardness).

Chapter 29 : THE BATTLE OF BADR

Book 19, Number 4394:

    It has been narrated on the authority of Anas that when (the news of) the advance of Abu Sufyan (at the head of a force) reached him. the Messenger of Allah (may peace be upon him) held consultations with his Companions. The narrator said: Abu Bakr spoke (expressing his own views), but he (the Holy Prophet) did not pay heed to him. Then spoke 'Umar (expressing his views), but he (the Holy Prophet) did not pay heed to him (too). Then Sa'd b. 'Ubada stood up and said: Messenger of Allah, you want us (to speak). By God in Whose control is my life, if you order us to plunge our horses into the sea, we would do so. If you order us to goad our horses to the most distant place like Bark al-Ghimad, we would do so. The narrator said: Now the Messenger of Allah (may peace be upon him) called upon the people (for the encounter). So they set out and encamped at Badr. (Soon) the water-carriers of the Quraish arrived. Among them was a black slave belonging to Banu al-Hajjaj. The Companions of the Messenger of Allah (may peace be upon him) caught him and interrogated him about Abu Sufyan and his companions. He said: I know nothing about Abu Sufyan, but Abu Jahl, Utba, Shaiba and Umayya b. Khalaf are there. When he said this, they beat him. Then he said: All right, I will tell you about Abu Sufyan. They would stop beating him and then ask him (again) about Abu Sufyan. He would again say', I know nothing about Abu Sufyan, but Abu Jahl. 'Utba, Shaiba and Umayya b. Khalaf are there. When he said this, they beat him likewise. The Messenger of Allah (may peace be upon him) was standing in prayer. When he saw this he finished his prayer and said: By Allah in Whose control is my life, you beat him when he is telling you the truth, and you let him go when he tells you a lie. The narrator said: Then the Messenger of Allah (may peace be upon him) said: This is the place where so and so would be killed. He placed his hand on the earth (saying) here and here; (and) none of them fell away from the place which the Messenger of Allah (may peace be upon him) had indicated by placing his hand on the earth.

Chapter 30 : THE CONQUEST OF MECCA

Book 19, Number 4395:

    It has been narrated by 'Abdullah b. Rabah from Abu Huraira, who said: Many deputations came to Mu'awiya. This was in the month of Ramadan. We would prepare food for one another. Abu Huraira was one of those who frequently invited us to his house. I said: Should I not prepare food and invite them to my place? So I ordered meals to be prepared Then I met Abu Huraira in the evening and said: (You will have) your meals with me tonight. He said: You have forestalled me. I said: Yes, and invited them. (When they had finished with the meals) Abu Huraira said: Should I not tell yon a tradition from your traditions, O ye assembly of the Ansar? He then gave an account of the Conquest of Mecca and said: The Messenger of Allah (may peace be upon him) advanced until he reached Mecca. He deputed Zubair on his right flank and Khalid on the left, and he despatched Abu Ubaida with the force that had no armour. They advanced to the interior of the valley. The Messenger of Allah (may peace be upon him) was in the midst of a large contingent of fighters. He saw me and said: Abu Huraira. I said: I am here at your call, Messenger of Allah I He said: Let no one come to me except the Ansar, so call to me the Ansar (only). Abu Huraira continued: So they gathered round him. The Quraish also gathered their ruffians and their (lowly) followers, and said: We send these forward. If they get anything, we shall be with them (to share it), and if misfortune befalls them, we shall pay (as compensation) whatever we are asked for. The Messenger of Allah (may peace be upon him) said (to the Ansar): You see the ruffians and the (lowly) followers of the Quraish. And he indicated by (striking) one of his hands over the other that they should be killed and said: Meet me at as-Safa. Then we went on (and) if any one of us wanted that a certain person should be killed, he was killed, and none could offer any resistance. Abu Huraira continued: Then came Abu Sufyan and said: Messenger of Allah, the blood of the Quraish has become very cheap. There will be no Quraish from this day on. Then he (the Holy Prophet) said: Who enters the house of Abu Sufyan, he will be safe. Some of the Ansar whispered among themselves: (After all), love for his city and tenderness towards his relations have overpowered him. Abu Huraira said: (At this moment) revelation came to the Holy Prophet (may peace be upon him) and when he was going to receive the Revelation, we understood it, and when he was (actually) receiving it, none of us would dare raise his eyes to the Messenger of Allah (may peace be upon him) until the revelation came to an end. When the revelation came to an end, the Messenger of Allah (may peace be upon him) said: O ye Assembly of the Ansar! They said: Here we are at your disposal, Messenger of Allah. He said: You were saying that love for his city and tenderness towards his people have overpowered this man. They said : So it was. He said: No, never. I am a bondman of God and His Messenger. I migrated towards God and towards you. I will live with you and will die with you. So, they (the Ansar) turned towards him in tears and they were saying: By Allah, we said what we said because of our tenacious attachment to Allah and His Messenger. The Messenger of Allah (may peace be upon him) said: Surely, Allah and His Messenger testify to your assertions and accept your apology. The narrator continued: People turned to the house of Abu Sufyan and people locked their doors. The Messenger of Allah (may peace be upon him) proceeded until he approached the (Black) Stone. He kissed it and circumambulated the Ka'ba. He reached near an idol by the side of the Ka'ba which was worshipped by the people. The Messenger of Allah (may peace be upon him) had a bow in his hand, and he was holding it from a corner. When he came near the idol, he began to pierce its eyes with the bow and (while doing so) was saying: Truth has been established and falsehood has perished. When he had finished the circumambulation, he came to Safa', ascended it to a height from where he could see the Ka'ba, raised his hands (in prayer) and began to praise Allah and prayed what he wanted to pray.
    The tradition has been narrated by a different chain of transmitters with the following additions: (i) Then be (the Messenger of Allah) said with his hands one upon the other: Kill them (who stand in your way).... (ii) They (the Ansar) replied: We said so, Messenger of Allah! He said: What is my name? I am but Allah's bondman and His Messenger.

Book 19, Number 4396:

    It has been narrated on the authority of Abdullah b. Rabah who said: We came to Mu'awiya b. Abu Sufyan as a deputation and Abu Huraira was among us. Each of us would prepare food for his companions turn by turn for a day. (Accordingly) when it was my turn I said: Abu Huraira, it is my turn today. So they came to my place. The food was not yet ready, so I said to Abu Huraira: I wish you could narrate to us a tradition from the Messenger of Allah (may peace be upon him) until the food was ready. (Complying with my request) Abu Huraira said: We were with the Messenger of Allah (may peace be upon him) on the day of the Conquest of Mecca. He appointed Khalid b. Walid as commander of the right flank, Zubair as commander of the left flank, and Abu 'Ubaida as commander of the foot-soldiers (who were to advance) to the interior of the valley. He (then) said: Abu Huraira, call the Ansar to me. So I called out to them and they came hurriedly. He said: O ye Assembly of the Ansaar, do you see the ruffians of the Quraish? They said: Yes. He said: See, when you meet them tomorrow, wipe them out. He hinted at this with his hand, placing his right hand on his left and said: You will meet us at as-Safa'. (Abu Huraira continued): Whoever was seen by them that day was put to death. The Messenger of Allah (may peace be upon him) ascended the mount of as-Safa'. The Ansar also came there and surrounded the mount. Then came Abu Sufyan and said: Messenger ot Allah, the Quraish have perished. No member of the Quraish tribe will survive this day. The Messenger of Allah (may peace be upon him) said: Who enters the house of Abu Safyin will be safe, who lays down arms will be safe, who locks his door will be safe. (some of) the Ansar said: (After all) the man has been swayed by tenderness towards his family and love for his city. At this, Divine inspiration descended upon the Messenger of Allah (may peace be upon him). He said: You were saying that the man has been swayed by tenderness towards his family and love for his city. Do you know what my name is? I am Muhammad, the bondman of God and His Messenger. (He repeated this thrice.) I left my native place for the take of Allah and joined you. So I will live with you and die with you. Now the Ansar said: By God, we said (that) only out of our greed for Allah and His Messenger. He said: Allah and His Apostle testify to you and accept your apology.

Chapter 31 : REMOVAL OF THE IDOLS FROM THE VICINITY OF THE KA'BA

Book 19, Number 4397:

    It has been narrated by Ibn Abdullah who said: The Holy Prophet (may peace be upon him) entered Mecca. There were three hundred and sixty idols around the Ka'ba. He began to thrust them with the stick that was in his hand saying: "Truth has come and falsehood has vanished. Lo! falsehood was destined to vanish" (xvii. 8). Truth has arrived, and falsehood can neither create anything from the beginning nor can It restore to life

Book 19, Number 4398:

    This tradition has been narrated by Ibn Abu Najah through a different chain of transmitters up to the word: Zahaqa, (This version) does not contain the second verse and substitutes Sanam for Nusub (both the words mean "idol" or "image" that is worshipped).

Chapter 32 : NO QURAISHITE WILL BE KILLED BOUND HAND AND FOOT AFTER THE CONQUEST OF MECCA

Book 19, Number 4399:

    It has been narrated on the authority of Abdullah b. Muti' who heard from his father and said: I heard the Holy Prophet (may peace be upon him) say on the day of the Conquest of Mecca: No Quraishite will be killed hound hand and foot from this day until the Day of judgment.

Book 19, Number 4400:

    The same tradition has been narrated on the authority of Zakriyya through the same chain of transmitters with the following addition: "No rebellious Quraishite with al-Asi as his name embraced Islam that day except Muti. His name-was al-Asi, but the Messenger of Allah (way peace be upon him) changed his name to Muti.

Chapter 33 : THE TREATY OF HUDAIBIYA

Book 19, Number 4401:

    It has been narrated on the authority of al-Bara' b. 'Azib who said: 'Ali b. Abu Talib penned the treaty between the Holy Prophet (may peace be upon him) and the polytheists on the Day of Hudaibiya. He wrote: This is what Muhammad, the Messenger of Allah, has settled. They (the polytheists) said: Do not write words "the Messenger of Allah". If we knew that you were the Messenger of Allah, we would not fight against you. The Prophet (may peace be upon him) said to 'Ali: Strike out these words. He (Ali) said: I am not going to strike them out. So the Prophet (may peace be upon him) struck them out with his own hand. The narrator said that the conditions upon which the two sides had agreed included that the Muslims would enter Mecca (next year) and would stay there for three days, and that they would not enter bearing arms except in their sheaths or bolsters.

Book 19, Number 4402:

    It has been narrated on the authority of Abu Ishaq, who heard Bars' b. Azib say: When the Messenger of Allah (may peace be upon him) made peace with the people of Hudaibiya, 'Ali drew up the agreement between them, and so he wrote: Muhammad, the Messenger of Allah. (This is followed by the same wording as we have in the previous tradition except the omission of the words: This is what he has settled.)

Book 19, Number 4403:

    It has been narrated on the authority of Bara' who said: When the Prophet (may peace be upon him) was checked from going to the Ka'ba, the people of Mecca made peace with him'on the condition that he would (be allowed to) enter Mecca (next year) and stay there for three days, that he would not enter (the city) except with swords in their sheaths and arms encased in their covers, that he would not take eway with him anyone from its dwellers, nor would he prevent anyone from those with him to stay on in Mecca (if he so desired). He said to 'Ali: Write down the terms settled between us. (So 'Ali wrote): In the name of Allah, most Gracious and most Merciful. This is what Muhammad, the Messenger of Allah, has settled (with the Meccans), The polytheists said to him: If we knew that thou art the Messenger of of Allah, we would follow you. But write: Muhammad b. 'Abdullah. So he told 'Ali to strike out these words. 'Ali said: No, by Allah, I will not strike them out. The Messenger of Allah (may Peace be upon him) said: Show me their place (on the parchment). So he ('Ali) showed him their place and he (the Holy Prophet) struck them out; and 'Ali wrote: Ibn 'Abdullah. (According to the terms of the treaty, next year) the Holy Prophet (may peace be upon him) stayed there for three days When it was the third day, they said to 'Ali: This is the last day according to the terms of your companion. So tell him to leave. 'Ali informed the Prophet (may peace be upon him) accordingly. He said: Yes, and left (the city). Ibn Janab in his version of the tradition used: "we would swear allegiance to you" instead of "we would follow you".

Book 19, Number 4404:

    It has been narrated on the authority of Anas that the Quraish made peace with the Prophet (may peace be upon him). Among them was Suhail b. Amr. The Prophet (may peace be upon him) said to 'Ali: Write "In the name of Allah, most Gracious and most Merciful." Suhail said: As for "Bismillah," we do not know what is meant by "Bismillah-ir-Rahman-ir-Rahim" (In the name of Allah most Gracious and most Merciful). But write what we understand, i.e. Bi ismika allahumma (in thy name. O Allah). Then, the Prophet (may peace be upon him) said: Write: "From Muhammad, the Messenger of Allah." They said: If we knew that thou welt the Messenger of Allah, we would follow you. Therefore, write your name and the name of your father. So the Holy Prophet (may peace be upon him) said: Write "From Muhammad b. 'Abdullah." They laid the condition on the Prophet (may peace be upon him) that anyone who joined them from the Muslims, the Meccans would not return him, and anyone who joined you (the Muslims) from them, you would send him back to them. The Companions said: Messenger of Allah, should we write this? He said: Yes. One who goes away from us to join them-may Allah keep him away ! and one who comes to join us from them (and is sent back) Allah will provide him relief and a way of escape.

Book 19, Number 4405:

    It has been narrated on the authority of Abu Wa'il who said: Sahal b. Hunaif stood up on the Day of Siffin and said: O ye people, blame yourselves (for want of discretion); we were with the Messenger of Allah (may peace be upon him) on the Day of Hudaibiya. If we had thought it fit to fight, we could fight. This was in the truce between the Messenger of Allah (may peace be upon him) and the polytheists. Umar b. Khattab came, approached the Messenger of Allah (may peace be upon him) and said: Messenger of Allah, aren't we fighting for truth and they for falsehood? He replied: By all means. He asked: Are not those killed from our side in Paradise and those killed. from their side in the Fire? He replied: Yes. He said: Then why should we put a blot upon our religion and return, while Allah has not decided the issue between them and ourselves ? He said: Son of Khattab, I am the Messenger of Allah. Allah will never ruin me. (The narrator said): Umar went away, but he could not contain himself with rage. So he approached Abu Bakr and said: 'Abu Bakr, aren't we fighting for truth and they for falsehood? He replied: Yes. He asked: Aren't those killed from our side in Paradise and those killed from their side in the Fire? He replied: Why not? He (then) said: Why should we then disgrace our religion and return while God has not yet decided the issue between them and ourselves? Abu Bakr said: Son of Khattab, verily, he is the Messenger of Allah, and Allah will never ruin him. (The narrator continued): At this (a Sura of) the Qur'an (giving glad tidings of the victory) was revealed to the Messenger of Allah (may peace be upon him). He sent for Umar and made him read it. He asked: Is (this truce) a victory? He (the Messenger of Allah) replied: Yes. At this Umar was pleased, and returned.

Book 19, Number 4406:

    It has been narrated on the authority of Shaqiq who said: I heard Sahl b. Hunaif say at Siffin: O ye people, find fault with your (own) discretion. By Allah, on the Day of Abu Jandal (i.e. the day of Hudaibiya), I thought to myself that, if I could, I would reverse the order of the Messenger of Allah (may peace be upon him) (the terms of the truce being unpalatable). By Allah, we have never hung our swords on our shoulders in any situation whatsoever except when they made easy for us to realise the goal envisaged by us, but this battle of yours (seems to be an exception). Ibn Numair (in his version) did not mention the words: "In any situatina whatsoever "

Book 19, Number 4407:

    The same tradition has been narrated through a different chain of transmitters on the authority of A'mash. This version contains the words: Ila amrin yofzi'una instead of Ila amrin na'rifuhu.

Book 19, Number 4408:

    It has been narrated through a different chain of transmitters on the authority of Abu Wa'il who said: I heard Sahl b. Hunaif say at Siffin: Blame (the hollowness) of your views about your religion. I thought to myself on the day of Abu Jandal that if I could turn down the order of the Messenger of Allah (may peace be upon him), I would. The situation was so difficult that if we mended it at one place, it was rent at another.

Book 19, Number 4409:

    It has been narrated on the authority of Anas b. Malik who said: When they (Companions of the Holy Prophet) were overwhelmed with grief and distress on his return from Hudaibiya where he had slaughtered his sacrificial beasts (not being allowed to proceed to Mecca), the Qur'anic verse: Inna fatahna. . . laka fathan mobinan to fauzan 'aziman, was revealed to him. (At this) he said: On me has descended a verse that is dearer to me than the whole world.

Book 19, Number 4410:

    This tradition has been narrated through a different chain of transmitters.

Chapter 34 : KEEPING A COVENANT

Book 19, Number 4411:

    It has been reported on the authority of Hudbaifa b. al-Yaman who said: Nothing prevented me from being present at !he Battle of Badr except this incident. I came out with my father Husail (to participate in the Battle), but we were caught by the disbelievers of Quraish. They said: (Do) you intend to go to Muhammad ? We said: We do not intend to go to him, but we wish to go (back) to Medina. So they took from us a covenant in the name of God that we would turn back to Medina and would not fight on the side of Muhammad (may peace be upon him). So, we came to the Messenger of Allah (may peace be upon him) and related the incident to him. He said: Both, of you proceed (to Medina) ; we will fulfil the covenant made with them and seek God's help against them.

Chapter 35 : THE BATTLE OF AHZAB OR THE BATTLE OF THE DITCH

Book 19, Number 4412:

    It has been narrated by Ibrahim al-Taimi on the authority of his father who said: We were sitting in the company of Hudhaifa. A man said: If I were in the time of the Messenger of Allah (may peace be upon him), I would have fought by his side and would have striven hard for his causes. Hudhaifa said: You might have done that, (but you should not make a flourish of your enthusiasm). I was with the Messenger of Allah (may peace be upon him) on the night of the Battle of Abzib and we were gripped by a violent wind and severe cold. The Messenger of Allah (may peace be him) said: Hark, the man who (goes reconnoitring and) brings me the news of the enemy shall be ranked with me on the Day of Judgment by Allah (the Glorious and Exalted). We all kept quiet and none of us responed to him. (Again) he said: Hark, a man who (goes reconnoitring and) brings me the news of the enemy shall be ranked with me on the Day of Judgment by Allah (the Glorious and Exalted). We kept quiet and none of us responded to him. He again said: Hark, a man who (goes reconnoitring and) brings me the news of the enemy shall be ranked with me on the Day of Judgtuent by Allah (the Glorious and Exalted) Then he said: Get up Hudhaifa, bring me the news of the enemy. When he called me by name I had no alternative but to get up. He said: Go and bring me information about the enemy, and do nothing that may provoke them against me. When I left him, I felt warm as if I were walking in a heated bath untill I reached them. I saw Abu Sufyan warming his back against fire I put an arrow in the middle of the bow. intending to shoot at him, when I recalled the words of the Messenger of Allah (may peace be upon him) "Do not provoke them against me." Had I shot at him, I would have hit him. But I returned and (felt warm as if) I were walking in a heated bath (hammam). Presenting myself before him, I gave him information about the enemy. When I had done so, I began to feel cold, so the Messenger of Allah (may peace be upon him) wrapped me in a blanket that he had in excess to his own requirement and with which he used to cover himself while saying his prayers. So I continued to sleep until it was morning. When it was morning he said: Get up, O heavy sleeper.

Chapter 36 : THE BATTLE OF UHUD

Book 19, Number 4413:

    It has been reported on the authority of Anas b. Malik that (when the enemy got the upper hand) on the day of the Battle of Uhud, the Messenger of Allah (may peace be upon him) was left with only seven men from the ansar and two men from the Quraish. When the enemy advanced towards him and overwhelmed him, he said: Whoso turns them away from us will attain Paradise or will be my Companion in Paradise. A man from the Ansar came forward and fought (the enemy) until he was killed. The enemy advanced and overwhelmed him again and he repeated the words: Whoso turns them away, from us will attain Paradise or will be my Companion in Paradise. A man from the Arsar came forward and fought until he was killed. This state continued until the seven Ansar were killed (one after the other). Now, the Messenger of Allah (may peace be upon him) said to his two Companions: We have not done justice to our Companions.

Book 19, Number 4414:

    It has been narrated on the authority of Abd-ul-'Aziz b. Abu Hazim, who learnt from his father (Abu Hazim). The latter heard it from Sahl b. Sa'd who was asked about the injury which the Messenger of Allah (may peace be upon him) got on the day of the Battle of Uhud. He said : The face of the Messenger of Allah (may peace be upon him) was injured, his front teeth were damaged and his helmet was crushed. Fatima, the daughter of the Messenger of Allah (may peace be upon him), was washing the blood (from his head), and 'Ali b. Abu Talib was pouring water on it from a shield. When Fatima saw that the bleeding had increased on account of (pouring) water (on the wound), she took a piece of mat and burnt it until it was reduced to ashes. She put the ashes on the wound and the bleeding stopped.

Book 19, Number 4415:

    It has been reported on the authority of Abu Hazim who heard from Sahl b. Sa'd. The latter was asked about the injury of the Messenger of Allah (may peace be upon him). He said: By God, I know the person who washed the wound of the Messenger of Allah (may peace be upon him), who poured water on it and with what the wound was treated. Then Sahl narrated the same tradition as has been narrated by 'Abd al-'Azlz except that he added the words:"And his face was injured" and replaced the word "Hushimat" by "Kusirat" (i.e. it was broken).

Book 19, Number 4416:

    The same tradition has been narrated on the authority of Sahl b. Sa'd through a different chain of transmitters with a slight difference in the wording.

Book 19, Number 4417:

    It has been narrated on the authority of Anas that the Messenger of Allah (may peace be upon him) had his front teeth damaged on the day of the Battle of Uhud, and got a wound on his head. He was wiping the blood (from his face) and was saying: How will these people attain salvation who have wounded their Prophet and broken his tooth while he called them towards God? At this time, God, the Exalted and Glorious, revealed the Verse: "Thou hast no authority" (iii. 127).

Book 19, Number 4418:

    It has been narrated on the authority of 'Abdullah who said: It appeared to me as if I saw the Messenger of Allah (may peace be upon him) (and heard him) relate the story of a Prophet who had been beaten by his people, was wiping the blood from his face and was saying. My Lord, forgive my people, for they do not know.

Book 19, Number 4419:

    A version of the tradition with a slightly different wording has been narrated by another chain of transmitters.

Chapter 37 : WRATH OF ALLAH UPON A PERSON WHO IS KILLED BY THE PROPHET HIMSELF (MAY PEACE BE UPON HIM)

Book 19, Number 4420:

    It has been narrated by Hammam b. Munabbih who said: This is what has been related to us by Abu Huraira from the Messenger of Allah (may peace be upon him). (With this introduction) he narrated a number of traditions. One of these was that the Messenger of Allah (may peace be upon him) said: Great is the wrath of Allah upon a people who have done this to the Messenger of Allah (may peace be upon him), and he was at that time pointing to his front teeth. The Messenger of Allah (may peace be upon him) also said: Great is the wrath of Allah upon a person who has been killed by the Messenger of Allah (may peace be upon him) in the way of Allah, the Exalted and Glorious.

Chapter 38 : THE PERSECUTION OF THE HOLY PROPHET (MAY PEACE BE UPON HIM) AT THE HANDS OF THE INFIDELS AND HYPOCRITES

Book 19, Number 4421:

    It has been narrated on the authority of Ibn Mas'ud who said: While the Messenger of Allah (may peace be upon him) was saying his prayer near the Ka'ba and Abu Jahl with his companions was sitting (near by), Abu Jahl said, referring to the she-camel that had been slaughtered the previous day: Who will rise to fetch the foetus of the she-camel of so and so, and place it between the shoulders of Muhammad when he goes down in prostration (a posture in prayer). The one most accursed among the people got up, brought the foetus and, when the Prophet (may peace be upon him) went down in prostration, placed it between his shoulders. Then they laughed at him and some of them leaned upon the others with laughter. And I stood looking. If I had the power, I would have thrown it away from the back of the Messenger of Allah (may peace be upon him). The Prophet (may peace be upon him) had bent down his head in prostration and did not raise it, until a man went (to his house) and informed (his daughter) Fatima, who was a young girl (at that time) (about this ugly incident). She came and removed (the filthy thing) from him. Then she turned towards them rebuking them (the mischief-mongers). When the Prophet (may peace be upon him) had finished his prayer, he invoked God's imprecations upon them in a loud voice. When he prayed, he prayed thrice, and when he asked for God's blessings, he asked thrice. Then he said thrice: O Allah, it is for Thee to deal with the Quraish. When they heard his voice, laughter vanished from them and they feared his malediction. Then he said: O God, it is for Thee to deal with Abu Jahl b. Hisham, 'Utba b. Rabi'a, Shaiba b. Rabi'a. Walid b. Uqba, Umayya b. Khalaf, Uqba b. Abu Mu'ait (and he mentioned the name of the seventh person. which I did not remember). By One Who sent Muhammad with truth, I saw (all) those he had named lying slain on the Day of Badr. Their dead bodies were dragged to be thrown into a pit near the battlefield.
    Abu Ishiq had said that the name of Walid b. 'Uqba has been wrongly mentioned in this tradition.

Book 19, Number 4422:

    It has been narrated by Abdullah (b. Mas'ud) who said: When the Messenger of Allah (may peace be upon him) was lying postrate in prayer and around him were some people from the Quraish, 'Uqba b. Abu Mu'ait brought the foetus of a she-camel and threw it on the back of the Messenger of Allah (may peace be upon him). He did not raise his head until Fatima arrived, removed it from his back and cured him who had done that (ugly act). He said: O Allah, it is for Thee to deal with the chiefs of the Quraish. Abu Jahl b. Hisham, 'Utba b. Rabi'a. Uqba b. Abu Mu'ait, Shaiba b. Rabi'a, Umayya b. Khalaf or Ubayy b. Khalaf (Shu'ba, one of the narrator of this tradition is in doubt about the exact person). I saw that all were slain in the Battle of Badr and their dead bodies were thrown into a well, except that of Umayya or Ubayy which was cut into pieces and was thrown into the well.

Book 19, Number 4423:

    Abu Ishiq has narrated a similar tradition through a different chain of transmitters and has added: He (the Messenger of Allah) loved to repeat the supplication thrice. He was saying: O Allah, it is for Thee to deal with the Quraish (repeating these words thrice). And among the Quraish, he mentioned (the names of) al-Walid b. 'Utba and Umayya b. Khalaf. (The narrator says there is no doubt about the names of these persons but he has forgotten the name of the seventh man).

Book 19, Number 4424:

    It has been narrated on the authority of 'Abdullah that, the Messenger of Allah (may peace be upon him) turned his face towards the Ka'ba and invoked God's imprecations upon six men of the Quraish, amorig whom were Abu Jahl. Umayya b. Khalaf, Utba b. Rabi'a, Shaiba b. Rabi'a and 'Uqba b. Abu Mu'ait I swear by God that I saw them lying slain in the battlefield of Badr. It being a hot day, their complexion had changed (showing signs of decay).

Book 19, Number 4425:

    It has been narrated on the authority of 'A'isha, the wife of the Prophet (may peace be upon him), who said to the Messenger of Allah (may peace he upon him): Messenger of Allah, has there come upon you a day more terrible than the day of Ubud. He said: I have experienced from thy people and the hardest treatment I met from them was what I received from them on the day of 'Aqaba. I betook myself to Ibn Abd Yalil b. Abd Kulal with the purpose of inviting him to Islam, but he did not respond to me as I desired. So I departed with signs of (deep) distress on my face. I did not recover until I reached Qarn al-Tha'alib. Where I raised my head, lo! near me was a cloud which had cast its shadow on me. I looked and lo ! there was in it the angel Jibril who called out to me and said.: God. the Honoured and Glorious, has heard what thy people have said to thee, and how they have reacted to thy call. And He has sent to thee the angel in charge of the mountains so that thou mayest order him what thou wishest (him to do) with, regard to them. The angel in charge of the mountains (then) called out to me, greeted me and said: Muhammad, God has listened to what thy people have said to thee. I am the angel in charge of the mountains. and thy Lord has sent me to thee so that thou mayest order me what thou wishest. If thou wishest that I should bring together the two mountains that stand opposite to each other at the extremities of Mecca to crush them in between, (I would do that). But the Messenger of Allah (may peace he upon him) said to him: I rather hope that God will produce from their descendants such persons as will worship Allah, the One, and will not ascribe partners to Him.

Book 19, Number 4426:

    It has been narrated on the authority of Jundub b. Sufyan who said: A finger of the Messenger of Allah (may peace be upon him) was wounded in one of the encounters He said: Thou art just a little finger which has bled, and what thou hast experienced is in the cause of Allah.

Book 19, Number 4427:

    It has been narrated on the authority of Aswad b. Qais who said: The Messenger of Allah (may peace be upon him) was in a cave (or raid) when his finger was hurt.

Book 19, Number 4428:

    It has been narrated on the authority of Aswad b. Qais who heard Jundub saying that Gabriel delayed his visit to the Messenger of Allah (may peace be upon him) The polytheists began to say that Muhammad has been forsaken. At this Allah, the Glorious and Exalted, revealed: "Wa'dd hd wa'l-laili iza saja, ma wadda'ka Rabbuka wa' ma qala" [By the glorious morning light, and by the night when it is still: thy Lord has not forsaken thee, nor is He displeased].

Book 19, Number 4429:

    It has been narrated on the authority of Aswad b. Qais who said: I heard Jundub b. Sufyan say: The Messenger of Allah (may peace be upon him) fell ill and did not wake up for two or three nights (for prayers) A woman came to him and said: Muhammad, I hope that your satan has left you. I haven't seen him approach you for two or three nights. The narrator says: At this, Allah, the Glorious and Exalted, revealed: "By the Glorious ......"

Book 19, Number 4430:

    This hadith has been narrated on the authority of Aswad b. Qais with the same chain of transmitters.

Chapter 39 : ABOUT TAE HOLY PROPHET'S (MAY PEACE BE UPON HIM) CALLING FOR ALLAH'S HELP AND HIS PATIENCE OVER THE PERSECUTION OF THE HYPOCRITES

Book 19, Number 4431:

    It has been narrated on the authority of Usama b. Zaid that the Prophet (may peace be upon him) rode a donkey. It had on it a saddle under which was a mattress made at Fadak (a place near Medina). Behind him he seated Usama. He was going to the street of Banu Harith al-Khazraj to inquire after the health of Sa'd b. Ubada This happened before the Battle of Badr. (He proceeded) until he passed by a mixed company of people in which were Muslims, polytheists, idol worshippers and the Jews and among them were 'Abdullah b. Ubayy and 'Abdullah b. Rawaha. When the dust raised by the hoofs of the animal spread over the company, 'Abdullah b. Ubayy covered his nose with his mantle and said: Do not scatter the dust over us (Not minding this remark), the Holy Prophet (may peace be upon him) greeted them, stopped, got down from his animal, invited them to Allah, and recited to them the Qur'an. 'Abdullah b. Ubayy said: O man, if what you say is the truth, the best thing for you would be not to bother us with it in our assemblies. Get back to your place. Whoso comes to you from us, tell him (all) this. Abdullah b. Rawaha said: Come to us in our gatherings, for we love (to hear) it. The narrator says : (At this), the Muslims, the polytheists and the Jews began to rebuke one another until they were determined to come to blows. The Holy Prophet (may peace be upon him) continued to pacify them. (When they were pacified), he rode his animal and came to Sa'd b. 'Ubida. He said: Sa'd, haven't you heard what Abu Hubab (meaning 'Abdullah b. Ubayy) has said? He has said so and so. Sa'd said: Messenger of Allah, forgive and pardon. God has granted you a sublime position, (but so far as he is concerned) the people of this settlement had-decided to make him their king by making him wear a crown and a turban (in token thereof), but God has circumvented this by the truth He has granted you. This has made him jealous and his jealousy (must have) prompted the behaviour that you have witnessed. So, the Holy Prophet (may peace upon him) forgave him.

Book 19, Number 4432:

    A similar tradition has been narrated through a different chain of transmitters by Ibn Shihab with the addition of the words: "Before Abdullah (b. Ubayy) became a Muslim."

Book 19, Number 4433:

    It has been narrated on the authority of Anas b. Malik that it was said to the Holy Prophet (may peace be upon him) : Would that you approached Abdullah b. Ubayy (to persuade him to accept Islam). The Holy Prophet (may peace be upon him) (accordingly) went to him, riding a donkey, and (a party of) Muslims also went (with him). On the way they had to walk over a piece of land affected with salinity. When the Holy Prophet (may peace be upon him) approached him, he said: Do not come near me. By Allah, the obnoxious smell of your donkey has offended me. (As a rejoinder to this remark), a man from the Ansar said: By God, the smell of the donkey of the Messenger of Allah (may peace be upon him) is better than your smell. (At this), a man from the tribe of 'Abdullah got furious. Then people from both sides got furious and exchanged blows with sticks, hands and shoes. (The narrator says) that (after this scuffle) we learnt that (the Qur'anic verse) : "It two parties of the Believers have a quarrel, make ye peace between them" (xlix. 9) was revealed about these fighting parties.

Chapter 40 : THE MURDER OF ABU JAHL

Book 19, Number 4434:

    It has been narrated on the authority of Anas b. Malik that the Messenger of Allah (may peace be upon him) said (after the encounter at Badr) : Who will ascertain for us what has happened to Abu Jahl? Ibn Mas'ud went (to gather this information). He found that the two sons of 'Afra' had struck him and he lay cold at the point of death. He caught him by his beard and said: Art thou Abu Jahl? He said: is there anybody superior to the person you have killed, or (he said) his people have killed him. Ibn Mas'ud says that, according to Abu Mijlaz, Abu Jahl said: Alas! a person other than a farmer would have killed me.

Book 19, Number 4435:

    A similar tradition has been transmitted by a different chain of narrators, on the same authority with a slight difference In the wording.

Chapter 41 : THE MURDER OF KA'B B. ASHRAF, (THE EVIL GENIUS) OF THE JEWS

Book 19, Number 4436:

    It has been narrated on the authority of Jabir that the Messenger of Allah (may peace be upon him) said: Who will kill Ka'b b. Ashraf? He has maligned Allah, the Exalted, and His Messenger. Muhammad b. Maslama said: Messenger of Allah, do you wish that I should kill him? He said: Yes. He said: Permit me to talk (to him in the way I deem fit). He said: Talk (as you like). So, Muhammad b. Maslama came to Ka'b and talked to him, referred to the old friendship between them and said: This man (i.e. the Holy Prophet) has made up his mind to collect charity (from us) and this has put us to a great hardship. When be heard this, Ka'b said: By God, you will be put to more trouble by him. Muhammad b. Maslama said: No doubt, now we have become his followers and we do not like to forsake him until we see what turn his affairs will take. I want that you should give me a loan. He said: What will you mortgage? He said: What do you want? He said: Pledge me your women. He said: You are the most handsome of the Arabs; should we pledge our women to you? He said: Pledge me your children. He said: The son of one of us may abuse us saying that he was pledged for two wasqs of dates, but we can pledge you (cur) weapons. He said: All right. Then Muhammad b. Maslama promised that he would come to him with Harith, Abu 'Abs b. Jabr and Abbad b. Bishr. So they came and called upon him at night. He came down to them. Sufyan says that all the narrators except 'Amr have stated that his wife said: I hear a voice which sounds like the voice of murder. He said: It is only Muhammad b. Maslama and his foster-brother, Abu Na'ila. When a gentleman is called at night even it to be pierced with a spear, he should respond to the call. Muhammad said to his companions: As he comes down, I will extend my hands towards his head and when I hold him fast, you should do your job. So when he came down and he was holding his cloak under his arm, they said to him: We sense from you a very fine smell. He said: Yes, I have with me a mistress who is the most scented of the women of Arabia. He said: Allow me to smell (the scent on your head). He said: Yes, you may smell. So he caught it and smelt. Then he said: Allow me to do so (once again). He then held his head fast and said to his companions: Do your job. And they killed him.

Chapter 42 : THE BATTLE OF KHAIBAR

Book 19, Number 4437:

    It has been narrated on the authority of Anas that the Messenger of Allah (may peace be upon him) raided Khaibar. One morning we offered prayers in the darkness of early dawn (near Khaibar). Then the Messenger of Allah (may peace be upon him) mounted (his horse). Abu Talha mounted his and I mounted behind Abu Talha on the same horse. The Prophet of Allah (may peace be upon him) rode through the streets of Khaibar and (I rode so close to him) that my knee touched the thigh of the Prophet of Allah (may peace be upon him). The wrapper got aside from his thigh, and I could see its whiteness. When he entered the town, he said: God is Great. Khaibar shall face destruction. When we descend in the city-square of a people, it is a bad day for them who have been warned (and have not taken heed). He said these words thrice. The people of the town had just come out from (their houses) to go about their jobs. They said (in surprise): Muhammad has come. We captured Khaibar by force.

Book 19, Number 4438:

    It has been narrated (through another chain of transmitters) on the authority of the same narrator (i.e. Anas) who said: I was riding behind Abu Talha on the day of the Battle of Khaibar (and we were riding so close to the Holy Prophet that) my foot would touch his We encountered the people at sunrise when they had come out with their axes, spades and strings driving their cattle along. They shouted (in surprise): Muhammad has come along with his force ! The Messenger of Allah (may peace be upon him) said: Khaibar shall face destruction. Behold ! when we descend in the city-square of a people, it is a bad day for those who have been warned (but have not taken heed). Allah, the Glorious and Majestic, inflicted defeat upon them.

Book 19, Number 4439:

    This hadith has been transmitted on the authority of Anas b. Malik with a slight variation of words.

Book 19, Number 4440:

    It has been narrated on the authority of Salama b. al-Akwa' who said: We marched upon Khaibar with the Messenger of Allah (may peace be upon him). We journeyed during the night. One of the people said to (my brother) 'Amir b. al-Akwa': Won't you recite to us some of your verses ? Amir was a poet. So he began to chant his verses to urge the camels, reciting:

      O God, if Thou hadst not guided us
      We would have neither been guided rightly nor practised charity,
      Nor offered prayers.
      We wish to lay down our lives for Thee; so forgive Thou our lapses,
      And keep us steadfast when we encounter (our enemies).
      Bestow upon us peace and tranquillity.
      Behold, when with a cry they called upon us to help.

    The Messenger of Allah (may peace be upon him) said: Who is this driver (of the camels)? They said: It is 'Amir. He said: God will show mercy to him. A man said: Martyrdom is reserved for him. Messenger of Allah, would that you had allowed us to benefit ourselves from his life. (The narrator says): We reached Khaibar and besieged them, and (we continued the siege) until extreme hunger afflicted us. Then the Messenger of Allah (may peace be upon him) said: Behold, God has conquered it for you. When it was evening of the day on which the city was conquered. the Muslims lit many fires. The Messenger of Allah (may peace be upon him) said: What are these fires? And what are they cooking? They said: They are cooking meat. He asked. Which meat? They said: That of domestic asses. He said: Let them throw it away and break the pots (in which it is being cooked). A man said: Or should they throw it away and wash the pots? He said: They may do that. When the people drew themselves up in battle array 'Amir caught hold of his sword that was rather short He drove a Jew before him to strike him with it. (As he struck him), his sword recoiled and struck his own knee, and 'Amir died of the wound. When the people returned (after the conquest of Kliaibar) and he (Salama) had caught hold of my hand, and said: The Messenger of Allah (may peace be upon him) saw that I was silent (and dejected); he said: What's the matter with thee? I said to him: My father and my mother be thy ransom, people presume that 'Amir's sacrifice has been in vain. He asked: Who has said that? I said: So and so and Usaid b. Hudair al-Ansari. He said: Who has said that has lied. For him (for 'Amir) there is a double reward. (He indicated this by putting two of his fingers together.) He was a devotee of God and a warrior fighting for His cause. There will be hardly any Arab who can fight as bravely as he did. Qutaiba has differed in a few words.

Book 19, Number 4441:

    It has been reported on the authority of Salama b. Akwa' who said: On the day of the Battle of Khaibar my brother fought a fierce fight by the side of the Messenger of Allah (may peace be upon him). His sword rebounded and killed him. The Companions of the Messenger of Allah (may peace be upon hill) talked about his death and doubted (whether it was martyrdom). (They said): (He is) a man killed by his own weapon, and expressed doubt about his affair. Salama said: When the Messenger of Allah (may peace be upon him) returned from Khaibar, I said: Messenger of Allah, permit me that I may recite to you some rajaz verses. The Messenger of Allah (may peace be upon him) permitted him. 'Umar b. Khattab said: I know what you will recite. I recited:

      By God, if God had guided us not,
      We would hive neither been guided aright nor practised charity,
      Nor offered prayers.

    The Messenger of Allah (may peace be upon him) said: What you have said is true, 'I (continued):

      And descend on us peace and tranquillity
      And keep us steadfast if we encounter (with our enemies)
      And the polytheists have rebelled against us.

    When I finished my rajaz, the Messenger of Allah (may peace be upon him) said: Who composed these verses? I said: They were composed by my brother. The Messenger of Allah (may peace be upon him) said: May God show mercy to him ! I said: By God, some people are reluctant to invoke God's mercy on him (because) they say he is a man who died by his own sword. (Hearing this) the Messenger of Allah (may peace be upon him) said: He died as God's devotee and warrior. Ibn Shihab has said: I asked one of the sons of Salama (b. Akwa') about (the death of 'Amir). He related to me a similar tradition except that he said: When I said some people were reluctant invoke God's blessings on him, the Messenger of Allah (may peace be, upon him said: They lied. ('Amir) died as God's devotee and warrior (in the cause of Allah). For him there is a double reward, and he pointed out this by putting his two fingers together.

Chapter 43 : THE BATTLE OF AHZAB OR KHANDAQ (THE TRIBES OR THE DITCH)

Book 19, Number 4442:

    It has been reported on the authority of Barra' who said: The Messenger of Allah (may peace be upon him) was carrying the earth with us on the Day of Ahzab and the whiteness of his belly had been covered with earth. (While engaged in this toil) he was reciting:

      By God, if Thou hadst not guided us
      We would have neither been guided aright nor practised charity,
      Nor offered prayers.
      Descend on us peace and tranquillity.
      Behold I these people (the Meccans) refused to follow us.

    According to another version, he recited:

      The chieftains (of the tribes) refused to follow us
      When they contemplated mischief, we rejected it.

    And with this (verse) he would raise his voice.

Book 19, Number 4443:

    It has been narrated on the authority of Abu Ishaq who said: I heard from Bara' a similar tradition except that he said: "These people (the Meccans) rebelled against us."

Book 19, Number 4444:

    It has been reported on the authority of Sahl b. Sa'd who said: The Messenger of Allah (may peace be upon him) came to us while we were digging the ditch and were carrying the earth on our shoulders. (Seeing our condition), he said:

      O God, there is no life but the life of the Hereafter.
      So forgive Thou the Muhajirs and the Ansar.

Book 19, Number 4445:

    It has been narrated on the authority of Anas b. Malik that the Messenger of Allah (may peace be upon him) said:

      O God, there is no life, but the life of the Hereafter,
      So forgive Thou the Ansar and the Muhajirs.

Book 19, Number 4446:

    According to another version of the tradition, reported on the authority of Anas b. Malik, the Messenger of Allah (may peace he upon him) is reported to have said:

      O God, there is no life but the life of the Hereafter,
      So grant honour to the Ansar and the Muhajirs.

Book 19, Number 4447:

    According to still another version of the tradition narrated by the same authority, and handed down through a different chain of transmitters, it has been reported that they (the Companions of the Holy Prophet) were reciting rajaz verses and the Messenger of Allah (may peace be upon him) was (reciting) with them. And they were chanting:

      O God, there is no good but the good of the Hereafter.
      So help Thou the Ansar and the Muhajirs.

    Shaiban substituted "So forgive Thou" for "So help Thou".

Book 19, Number 4448:

    It has been narrated (through a still difterent chain of transmitters) by Anas that the Companions of Muhammad (may peace be upon him) were chanting on the day of the Battle of the Ditch:

      We are those who have sworn allegiance to Muhammad
      (And made a covenant with him) to follow Islam as long as we live.

    Hammad is not sure whether Anas said: "Ala'l-Islam" or,"Ala'l-Jihad". And the Holy Prophet (may peace be upon him) was chanting:

      O God, the real good is the good of the Hereafter,
      So forgive Thou the Ansar and the Muhajirs.

Chapter 44 : DHU QARAD AND OTHER BATTLES

Book 19, Number 4449:

    It has been narrated on the authority of Yazid b. Abu 'Ubaid who said that he heard Salama b. al-Akwa' say: I went out before the Adhan for the morning prayer had been delivered. The milch she-camels of the Messenger of Allah (may peace be upon him) were grazing at Dhu Qarad. 'Abd al-Rahman b. Auf's slave met me and said: The milch she-camels of the Messenger of Allah (may peace be upon him) had been taken away. I said: Who has taken them away? He said: (the people belonging to the tribe of) Ghatafan. I cried thrice: Help ! I made the whole city between the two lavas hear my cry. Then I ran straight in their pursuit until I overtook them at Dhu Qarad where they were just going to water their animals. I, being an archer, began to shoot them with my arrows and was saying: I am the son of al-Akwa'. And today is the day when the cowards will meet their doom. I continued to chant until I rescued the milch she-camels from them, and snatched from them thirty mantles. Now, the Messenger of Allah (may peace be upon him) and some other people came along. I said: Prophet of Allah, I have prevented them from water while they were thirsty. So you should send a force (to punish them). He (the Holy Prophet) said: Ibn al-Akwa', you have taken (what, you have taken). Now let them go. Then we returned and the Messenger of Allah (may peace be upon him) made me mount behind him on his she-camel until we entered Medina.

Book 19, Number 4450:

    It has been narrated on the authority of Ibn Salama. He heard the tradition from his father who said: We arrived at Hudaibiya with the Messenger of Allah (may peace be upon him) and we were fourteen hundred in number. There were fifty goats for them which could not be watered (by the small quantity of water in the local well). So, the Messenger of Allah (may peace be upon him) sat on the brink of the well. Either he prayed or spat into the well The water welled up. We drank and watered (the beasts as well). Then the Messenger of Allah (may peace be upon him) called us to take the vow of allegiance, as he was sitting at the base of a tree. I was the first man to take the vow. Then other people took the vow. When half the number of people had done so, he said to me: You take the vow, Salama. I said: I was one of those who took the vow in the first instance. He said: (You may do) again. Then the Messenger. of Allah (may peace be upon him) saw that I was without weapons. He gave me a big or a small shield. Then he continued to administer vows to the people until it was the last batch of them. He said (to me) : Won't you swear allegiance, Salama? I said: Messenger of Allah, I took the oath with the first batch of the people and then again when you were in the middle of the people. He said: (Doesn't matter), you may (do so) again. So I took the oath of allegiance thrice. Then he said to me: Salama, where is the shield which I gave to thee? I said: Messenger of Allah, my uncle 'Amir met me and he was without any weapons. So I gave the shield to him. The Messenger of Allah (may peace be upon him) laughed and said: You are like a person of the days gone by who said: O God. I seek a friend who is dearer to me than myself. (When all Companions had sworn allegiance to the Holy Prophet), the polytheists sent messages of peace, until people could move from our camp to that of the Meccans and vice versa. Finally, the peace treaty was concluded.
    I was a dependant of Talha b. Ubaidullah. I watered his horse, rubbed its back. I served Talha (doing odd jobs for him) and partook from his food. I had left my family and my property as an emigrant in the cause of Allah and His Messenger (may peace be uron him). When we and the people of Mecca had concluded a peace treaty and the people of one side began to mix with those of the other, I came to a tree, swept away its thorns and lay down (for rest) at its base; (while I lay there), four of the polytheists from the Meccans came to me and began to talk ill of the Messenger of Allah (may peace be upon him). I got enraged with them and moved to another tree. They hung their weapons (to the branches of the tree) and lay down (for rest). (While they lay there), somebody from the lower part of the valley cried out: Run up, O Muhajirs ! Ibn Zunaim has been murdered. I drew my sword and attacked these four while they were asleep. I seized their arms and collected them up in my hand, and said: By the Being Who has conferred honour upon Muhammad, none of you shall raise his head, else I will smite his face. (Then) I came driving them along to the Holy Prophet (may peace be upon him). (At the same time). my uncle Amir came (to him) with a man from "Abalat called Mikraz. Amir was dragging him on a horse with a thick covering on its back along with seventy polytheists. The Messenger of Allah (may peace be upon him) cast a glance at them and said: Let them go (so that) they may prove guilty of breach of trust more than once (before we take action against them). So the Messenger of Allah (may peace be upon him) forgave them. On this occasion. God revealed the Qur'anic verse: "It is He Who restrained their hands from you and your hands from them in the valley of Mecca after He had granted you a victory over them" (xlviii. 24). Then we moved returning to Medina, and halted at a place where there was a mountain between us and Banu Lihyan who were polytheists. The Messenaer of Allah (may peace be upon him) asked God's forgiveness for one who ascended the mountain at night to act as a scout for the Messenger of Allah (may peace be upon him) and his Compinions. I ascended (that mountain) twice or thrice that night. (At last) we reached Medina. The Messenger of Allah (may peace be upon him) sent his camels with his slave, Rabah, and I was with him. I (also) went to the pasture with the horse of Talha along with the camels.
    When the day dawned, Abd al-Rahman al-Fazari made a raid and drove away all the camels of the Messenger of Allah (may peace be upon him), and killed the man who looked after them. I said: Rabah, ride this horse, take it to Talha b. 'Ubaidullah and Inform the Messenger of Allah (may peace be upon him) that the polytheists have made away with his camels. Then I stood upon a hillock and turning my face to Medina, shouted thrice: Come to our help I Then I set out in pursuit of the raiders, shooting at them with arrows and chanting a (self-eulogatory) verse in the Iambic metre:

      I am the son of al-Akwa'
      And today is the day of defeat for the mean.

    I would overtake a man from them, shoot at him an arrow which, piercing through the saddle, would reach his shoulder. and I would say: Take it, chanting at the same time the verse

      And I am the son of al-Akwa'
      And tody is the day of defeat for the mean.

    By God, I continued shooting at them and hamstringing their animals. Whenever a horseman turned upon me, I would come to a tree and (hid myself) sitting at its base. Then I would shoot at him and hamstring his horse. (At last) they entered a narrow mountain gorge. I ascended that mountain and held them at bay throwing stones at them. I continued to chase them in this way until I got all the camels of the Messenger of Allah (may peace be upon him) released and no camel was left with them. They left me; then I followed them shooting at them (continually) until they dropped more than thirty mantles and thirty lances. lightening their burden. On everything they dropped, I put a mark with the help of (a piece of) stone so that the Messenger of Allah (may peace be upon him) and his Companions might recognise them (that it was booty left by the enemy). (They went on) until They came to a narrow valley when so and so, son of Badr al-Fazari joined them. They (now) sat down to take their breakfast and I sat on the top of a tapering rock. Al-Fazari said: Who is that fellow I am seeing? They said: This fellow has harassed us. By God, he has not left us since dusk and has been (continually) shooting at us until he has snatched everything from our hands. He said: Four of you should make a dash at him (and kill him). (Accordingly), four of them ascended the mountain coming towards me. When it became possible for me to talk to them, I said: Do you recognise me? They said: No.Who are thou? I said: I am Salama, son of al-Akwa'. By the Being Who has honoured the countenance of Muhammad (may peace be upon him) I can kill any of you I like but none of you will be able to kill me. One of them said: I think (he is right). So they returned. I did not move from my place until I saw the horsemen of the Messenger of Allah (may peace be upon him), who came riding through the trees. Lo! the foremost among them was Akhram al-Asadi. Behind him was Abu Qatada al-Ansari and behind him was al-Miqdad b. al-Aswad al-Kindi. I caught hold of the rein of Akhram's horse (Seeing this). they (the raiders) fled. I said (to Akhram): Akhram, guard yourself against them until Allah's Messenger (may peace be upon him) and his Companions join you. He said: ) Salama, if you believe In Allah and the Day of Judgment and (if) you kaow that Paradise is a reality and Hell is a reality, you should not stand between me and martyrdom. so I let him go. Akhram and Abd al-Rahman (Fazari) met in combat. Akhram hamstrung Abd al-Rahman's horse and the latter struck him with his lance and killed him. Abd al-Rabman turned about riding Akhram's horse. Abu Qatada, a horse-man of the Messenger of Allah (may peace be upon him), met 'Abd al-Rahman (in combat), smote him with his lance and killed him. By the Being Who honoured the countenance of Muhammad (may peace oe upon him), I followed them running on my feet (so fast) that I couldn't see behind me the Companions of Muhammad (may peace be upon him), nor any dust raised by their horses. (I followed them) until before sunset they reached a valley which had a spring of water, which was called Dhu Qarad, so that they could have a drink, for they were thirsty. They saw me running towards them. I turned them out of the valley before they could drink a drop of its water. They left the valley and ran down a slope. I ran (behind them), overtook a man from them, shot him with an arrow through the shoulder blade and said: Take this. I am the son of al-Akwa'; and today is the day of annihilation for the people who are mean. The fellow (who was wounded) said: May his mother weep over him ! Are you the Akwa' who has been chasing us since morning? I said: Yes, O enemy of thyself, the same Akwa'. They left two horses dead tired on the hillock and I came dragging them along to the Messenger of Allah (may peace be upon him). I met 'Amir who had with him a container having milk diluted with water and a container having water. I performed ablution with the water and drank the milk. Then I came to the Messenger of Allah (may peace be upon him) while he was at (the spring of) water from which I had driven them away. The Messenger of Allah (may peace be upon him) had captured those camels and everything else I had captured and all the lances and mantles I had snatched from the polytheists and Bilal had slaughtered a she-camel from the camels I had seized from the people, and was roasting its liver and hump for the Messenger of Allah (may peace be upon him). I said: Messenger of Allah, let me select from our people one hundred men and I will follow the marauders and I will finish them all so that nobody is left to convey the news (of their destruction to their people). (At these words of mine), the Messenger of Allah (may peace be upon him) laughed so much that his molar teeth could be seen in the light of the fire, and he said: Salama, do you think you can do this? I said: Yes, by the Being Who has honoured you. He said: Now they have reached the land of Ghatafan where they are being feted. (At this time) a man from the Ghatafan came along and said: So and so slaughtered a camel for them. When they were exposing its skin, they saw dust (being raised far off). They said: They (Akwa' and his companions) have come. So. they went away fleeing. When it was morning, the Messenger of Allah (may peace be upon him) said: Our best horseman today is Abu Qatada and our best footman today is Salama. Then he gave me two shares of the booty-the share meant for the horseman and the share meant for the footman, and combined both of them for me. Intending to return to Medina, he made me mount behind him on his she-camel named al-Adba'. While we were travelling, a man from the Ansar who could not be beaten in a race said: Is there anyone who could compete (with me) in race to Medina ? Is there any competitor? He continued repeating this. When I heard his talk, I said: Don't you show consideration to a dignified person and don't you have awe for a noble man ? He said: No, unless he be the Messenger of Allah (may peace be upon him). I said: Messenger of Allah, may my father and mother be thy ransom, let me get down so that I may beat this man (in the race). He said: It you wish, (you may). I said (to the man): I am coming to thee, I then turned my feet. sprang up and tan and gasped (for a while) when one or two elevated places were left and again followed his heel and again gasped (for a while) when one or two elevated places were left and again dashed until I joined him and gave a blow between his shoulders. I said: You have been overtaken, by God. He said: I think so. Thus, I reached Medina ahead of him. By God, we had stayed there only three nights when we set out to Khaibar with the Messenger of Allah (may peace be upon him). (On the way) my uncle, Amir, began to recite the following rajaz verses for the people:

      By God, if Thou hadst not guided us aright,
      We would have neither practised charity nor offered prayers.
      (O God !) We cannot do without Thy favours;
      Keep us steadfast when we encounter the enemy,
      And descend tranquillity upon us.

    The Messenger of Allah (may peace be upon him) said: Who is this? 'Amir said: it is 'Amir. He said: May thy God forgive thee ! The narrator said: Whenever the Messenger of Allah (may peace be upon him) asked forgiveness for a particular person, he was sure to embrace martyrdom. Umar b. Khattab who was riding on his camel called out: Prophet of Allah, I wish you had allowed us to benefit from Amir. Salama continued: When we reached Khaibar, its king named Marhab advanced brandishing his sword and chanting:

      Khaibar knows that I am Marhab (who behaves like)
      A fully armed, and well-tried warrior.
      When the war comes spreading its flames.

    My uncle, Amir, came out to combat with him, saying:

      Khaibar certainly knows that I am 'Amir,
      A fully armed veteran who plunges into battles.

    They exchanged blows. Marbab's sword struck the shield of 'Amir who bent forward to attack his opponent from below, but his sword recoiled upon him and cut the main artery :in his forearm which caused his death. Salama said: I came out and beard some people among the Companions of the Holy Prophet (may peace be upon him) as saying: Amir's deed has gone waste; he has killed himself. So I came to the Holy Prophet (may peace be upon him) weeping and I said: Messenger of Allah. Amir's deed has gone waste. The Messenger (may peace be upon him) said: Who passed this remark? I said: Some of your Companions. He said: He who has passed that remark has told a lie, for 'Amir there is a double reward. Then he sent me to 'Ali who had tore eyes, and said: I will give the banner to a man who loves Allah and His Messenger or whom Allah and His Messenger love. So I went to 'Ali, brought him beading him along and he had sore eyes, and I took him to the Messenger of Allah (may peace be upon him), who applied his saliva to his eyes and he got well. The Messenger of Allah (may peace be upon him) gave him the banner (and 'Ali went to meet Marhab in a single combat). The latter advanced chanting:

      Khaibar knows certainly that I am Marhab,
      A fully armed and well-tried valorous warrior (hero)
      When war comes spreading its flames.

    'Ali chanted in reply:

      I am the one whose mother named him Haidar, (And am) like a lion of the forest with a terror-striking countenance. I give my opponents the measure of sandara in exchange for sa' (i.e. return thir attack with one that is much more fierce).

    The narrator said: 'Ali struck at the head of Mirhab and killed him, so the victory (capture of Khaibar) was due to him. This long tradition has also been handed down Through a different chain of transmitters.

Book 19, Number 4451:

    This hadith has been transmitted on the authority of 'Ikrama b. Ammar.

Chapter 45 : REGARDING THE WORD OF GOD, THE EXALTED:"IT IS HE WHO RESTRAINED THEIR HANDS FROM YOU" TO THE END OF THE VERSE

Book 19, Number 4452:

    It has been narrated on the authority of Anas b. Malik that eighty Persons from the inhabitants of Mecca swooped down upon the Messenger of Allah (may peace be upon him) from the mountain of Tan'im. They were armed and wanted to attack the Holy Prophet (may peace be upon him) and his Companions unawares. He (the Holy Prophet) captured them but spared their lives. So, God, the Exalted and Glorious, revealed the verses: "It is He Who restrained your hands from them and their hands from you in the valley of Mecca after He had given you a victory over them."

Chapter 46 : FIGHTING OF WOMEN SIDE BY SIDE WITH MEN

Book 19, Number 4453:

    It has been narrated on the authority of Anas that, on the Day of Hunain. Umm Sulaim took out a dagger she had in her possession. Abiu Talha saw her and said: Messenger of Allah, this is Umm Sulaim. She is holding a dagger. The Messenger of Allah (may peace be upon him) asked (her): What for are you holding this dagger? She said: I took it up so that I may tear open the belly of a polytheist who comes near me. The Messenger of Allah (may peace be upon him) began to smile (at these words). She said: Messenger of Allah, kill all those people-other than us-whom thou hast declared to be free (on the day of the Conquest of Mecca). (They embraced Islam because) they were defeated at your hands (and as such their Islam is not dependable). The Messenger of Allah (may peace be upon him) said: Umm Sulaim. God is sufficient (against the mischief of the polytheists) and He will be kind to us (so you need not carry this dagger).

Book 19, Number 4454:

    It has been narrated on the authority of Anas b. Malik who said that the Messenger of Allah (may peace be upon him) allowed Umm Sulaim and some other women of the Ansar to accompany him when he went to war; they would give water (to the soldiers) and would treat the wounded.

Book 19, Number 4455:

    It has been narrated on the authority of Anas b. Malik who said: On the Day of Ubud some of the people, being defeated, left the Holy Prophet (may peace he upon him), but Abu Talha stood before him covering him with a shield. Abu Talha was a powerful archer who broke two or three bows that day. When a man would pass by carrying a quiver containing arrows, he would say: Spare them for Abu Talha. Whenever the Holy Prophet (way peace be upon him) raised his head to look at the people, Abd Talba would say: Prophet of Allah, may my father and my mother be thy ransom, do not raise your head lest you be struck by an arrow shot by the enemy. My neck is before your neck. The narrator said: I saw A'isha bint Abu Bakr and Umm Sulaim. Both of them had tucked up their garments, so I could me the anklets on their feet. They were carrying water-skins on their backs and would pour water into the mouths of the people. They would then go back (to the well), would fill them again and would return to pour water into the mouths of the soldiers. (On this day). Abu Talha's sword dropped down from his hands twice or thrice because of drowsiness.

Chapter 47 : WOMEN PARTICIPANTS IN JIHAD TO BE GIVEN A PRIZE BUT NOT A REGULAR SHARE IN THE BOOTY, AND PROHIBITION TO KILL CHILDREN OF THE ENEMY

Book 19, Number 4456:

    It has been narrated on the authority of Yazid b. Hurmuz that Najda wrote to Ibn Abbas inquiring of him five things. Ibn Abbas said: If I had not the fear of committing (sin) for concealing the knowledge I would not have written to him. Najda wrote to him saying (after praising the Almighty and invoking blessings on the Prophet): Tell me whether the Messenger of Allah (may peace be upon him) took women to participate with him in Jihad; (if he did), whether he allotted them a regular share from the booty; whether he killed the children of (the enemy in the war how long an orphan would be entitled to consideration as such and for whom the Kbums (fifth part of the booty) was booty. Ibn Abbas wrote to him: You have written asking me whether the Messenger of Allah (may peace be upon him) took women with him to participate in Jihad. He did take them to the battle and sometimes he fought along with them. They would treat the wounded and were given a reward from the booty, but he did not assign any regular share for them. And the of Allah (may peace be upon him) did not kill the children of the enemy, so thou shouldst not kill the children. Also you have written to me asking me when the orphanhood of an orphan comes to an end. By my life, if a man has become bearded but is still incapable of getting his due from others as well u meeting his obligation towards them, (he is yet an orphan to be treated you such), but when he can look after his interests like grown-up people, he is no longer an orphan. And you have written to me inquiring about Khums as to whom it is meant for. (In this connection) we (the kinsmen of the Messenger of Allah) used to say: It is for us, but those people (i.e. Banu Umayya) have denied it to us.

Book 19, Number 4457:

    This tradition has been narrated by the game authority (Yazid b. Hurmus) through a different chain of transmitters with the following difference in the elucidation of one of the points raised by Najda in his letter to Ibn Abas: The Messenger of Allah (may peace be upon him) used not to kill the children, so thou shouldst not kill them unless you could know what Khadir had known about the child he killed, or you could distinguish between a child who would grow up to he a believer (and a child who would grow up to be a non-believer), so that you killed the (prospective) non-believer and left the (prospective) believer aside.

Book 19, Number 4458:

    It has been narrated on the authority of Yazid b. Hurmuz who said: Najda b. 'Amir al-Haruri wrote to Ibn Abbas asking him about the slave and the woman as to whether they would get a share from the booty (it they participated in Jihad); about the killing of (enemy) children (in war); about the orphan as to when his orphanhood comes to an end; about kinsmen (of the Holy Prophet) as to who they are. He said to Yazid: Write to him. (If he were not likely to fall into folly, I would not have written to him.) Write: You have written asking about the woman and the slave whether they would get a share of the booty if they participated in Jihad. (You should know that) there is nothing of the sort for them except that they will be given a prize. And you have written asking me about the killing of the enemy children in war. (You should understand that) the Messenger of Allah (may peare be upon him) did not kill them. and thou shouldst not kill them unless thou knew what the companion of Moses (i.e. Khadir) knew about the boy he had killed. And you have written asking me about the orphan as to when the period of his orphanhood comes to an end, so that the sobriquet of "orphan" is dropped from him. (In this regard, you should know that) the sobriquet "orphan" will not be dropped from him until he attains maturity of body and mind. And you have written asking me about the close relatives (of the Holy Prophet) as to who they are. We think that it is we, but our people have denied us this (position and its concomitant privileges).

Book 19, Number 4459:

    This hadith has been narrated on the authority of Yazid b. Hurmuz through another chain of transmitters.

Book 19, Number 4460:

    It has been narrated on the anthority of Yazid b. Hurmuz who said: Najda wrote to Ibn Abbas. I was sitting in the company of Ibn 'Abbas when he read his letter and wrote its reply. Ibn Abbas said: Were it not for preventing him from falling into wickedness. I would not have replied to his letter, may he never be joyful. He wrote in reply to him referring to the share of the close relatives (of the Holy Prophet) (from the booty) whom God has mentioned. (I have to tell you that) we thought we were the close relatives of the Messenger of Allah (may peace be upon him), but our people have refused to recognise us as such. You have asked about the orphan as to when his orphanhood comes to an end. (I have to say that) when he reaches the age of marriage, attains maturity of mind, and his property is returned to him, then he is no longer an orphan. You have inquired whether the Messenger of Allah (may peace be upo him) used to kill anyone from the children of the polytheists in the war. (You should know that) the Messenger of Allah (may peace be upon him) used not to kill any one of their children, and you (too) should not kill any one of them, except when you knew about them what Khadir had known about the boy whom he killed. And you have inquired whether there is a fixed share of the booty for women and slaves when they participate in a battle. (I have to tell you that) there is no fixed share for them except that they will be given some reward from the spoils of war.

Book 19, Number 4461:

    This hadith has been transmitted on the authority of Yazid b. Hurmuz. but not complete (as we find in the above mentioned ahadith).

Chapter 48 : THE NUMBER OF WARS WAGED BY THE HOLY PROPHET (MAY PEACE BE UPON HIM)

Book 19, Number 4462:

    It has been narrated on the authority of Umm 'Atiyya, the Ansarite, who said: I took part with the Messenger of Allah (may peace be upon him) in seven battles. I would stay behind in the camp of men, cook their food, treat the wounded and nurse the aick.

Book 19, Number 4463:

    A similar tradition has been narrated on the authority of Hisham b. Hassan through a different chain of transmitters.

Book 19, Number 4464:

    It has been narrated on the authority of Abu Ishaq that 'Abdullah b. Yazid went (out of the city) with people for offering "Istisqa"' prayer (for rainfall). He offered two rak'ahs. Then he prayed for rain. That day I met Zaid b. Arqam. There was only one man between me and him (at that time). I asked him: How many military expeditions did the Messenger of Allah (may peace be upon him) undertake? He said: Nineteen expeditions. I asked him: On how many expeditions did you accompany him ? He said: On seventeen expeditions. I asked : Which was the first expedition he led ? He answered: Dhat-ul-,Usair or 'Ushair.

Book 19, Number 4465:

    It has been narrated on the authority of Zaid b. Arqam that the Messenger of Allah (may peace be upon him) fought nineteen battles and after the Migration performed only one Pilgrimage called Hajjat-ul-Wada'.

Book 19, Number 4466:

    It has been reported on the authority of Abu Zubair who heard Jabir b. Abdullah say: I fought in the company of the Messenger of Allah (may peace be upon him) nineteen battles. Jabir said: I did not participate in the Battle of Badr and the Battle of Uhud. My father prevented me (from participating in these battles as my age was tender). After 'Abdullah (my father) was killed on the Day of Ubud, I never lagged behind the Messenger of Allah (may peace be upon him) and joined every battle (he fought).

Book 19, Number 4467:

    It has been narrated on the authority of Buraida (who heard the tradition from his father) that the Messenger of Allah (may peace be upon him) conducted nineteen military campaigns and he (actually) fought in eight of them.

Book 19, Number 4468:

    It has been narrated by Buraida who heard it from his father that he joined the Messenger of Allah (may peace be upon him) in sixteen military campaigns

Book 19, Number 4469:

    It has been narrated on the authority of Salama who said: I joined seven military expeditions led by the Messenger of Allah himself (may peace be upon him), and nine expeditions which he sent out once under Abu Bakr and once under Usama b. Zaid.

Book 19, Number 4470:

    The (foregoing) tradition has also been narrated on the authority of Hatim through the same chain of transmitters with the difference that according to this version both these types of expeditions were seven in number.

Chapter 49 : THE EXPEDITION CALLED DHAT-UR-RIQA'

Book 19, Number 4471:

    It has been narrated on the authority of Abu Musa (Ash'ari) who said: We set out on an expedition with the Messenger of Allah (may peace be upon him). We were six in number and had (with us) only one camel which we rode turn by turn Our feet were injured. My feet were so badly injured that my nails dropped off. We covered our feet with rags. so this expedition was called Dhat-ur-Riqa' (i.e. the expedition of rags) because we bandaged our feet with rags (on that day). Abu Burda said: Abu Musa narrated this tradition, and then disliked repeating it as he did not want to give any publicity to what he did in a noble cause Abu Usama said: Narrators other than Abu Buraida have added to the version of the words: "God will reward it."

Chapter 50 : DISAPPROVAL OF SEEKING HELP FROM A DISBELIEVER ON A MILITARY CAMPAIGN

Book 19, Number 4472:

    It has been narrated on the authority of A'isha, wife of the Holy Prophet (may peace be upon him), who said : The Messenger of Allah (may peace be upon him) set out for Badr. When he reached Harrat-ul-Wabara (a place four miles from Medina) a man met him who was known for his valour and courage. The Companions of the Messenger of Allah (may peace be upon him) were pleased to see him. He said : I have come so that I may follow you and get a share from the booty. The Messenger of Allah (may peace be upon him) said to him : Do you believe in Allah and His Apostle ? He said: No. The Messenger of Allah (may peace be upon him) said: Go back, I will not seek help from a Mushrik (polytheist). He went on until we reached Shajara, where the man met him again. He asked him the same question again and the man gave him the same answer. He said : Go back. Im will not seek help from a Mushrik. The man returned and overtook him at Baida'? He asked him as he had asked previously: Do you believe in Allah and His Apostle? The man said: Yes. The Messenger of Allah (may peace be upon him) said to him : Then come along with us.


BOOK 20: The Book On Government (Kitab Al-Imara)

KITAB AL-IMARA
(THE BOOK ON GOVERNMENT)

Back
INTRODUCTION

    Islam is a social religion, not in the sense that it is through society alone that religion breathes its sacred spirit in the individuals, but in the sense that it aims at inculcating God-consciousness both in individual and society. Jesus said: The Kingdom of Heaven is within you. Islam fully subscribes to this view, since no just kingdom can be founded on earth by unjust men, who have not first created the Kingdom of Heaven in their hearts, but Islam goes a step forward and says that the creation of the Kingdom of Heaven within heart is not enough; this Kingdom of Heaven within must be externalised into a Kingdom of Heaven on earth, so that the organised life of man may be built up on the basis of love, fraternity and justice.

    It thus becomes clear that the Islamic State is not an end in itself, but a means to an end, the end being the development of a community of people who stand up for equity and justice, for right against wrong or, to phrase it differently, for the creation of such conditions as would enable the greatest possible number of human beings to live spiritually, morally and physically in accordance with the teachings of Islam.

    Thus the founding of an Islamic State is not a sort of "worldly activity," something undesirable, as some people wrongly suppose, but the sine qua non of social justice, as demanded by Islam. "The state," says Dr lqbal, " from the Islamic standpoint, is an endeavour to transform these ideal principles into space-time forces, an aspiration to realize them in a definite human organization. It is in this sense alone that state in Islam is a theocracy, not in the sense that it is headed by a representative of God on earth who can always screen his despotic will behind his supposed infallibility.

    As this State is meant to enforce the law of the Shari'ah within its territorial jurisdiction, it is duty bound to make itself an efficient organ for transforming the high ideals of Islam into reality. The Qur'an, while enumerating the main functions of the Islamic State, says: "Those who, if We establish them in the land, observe worship, and pay the poor-due and enjoin good and forbid evil" (xxii. 41).

    This shows that the function of an Islamic State is not only to defend its citizens from external attack and internal disorder, but also to enable individual man and woman to realise the tenets of Islam and their beliefs. in the socioeconomic concerts of their practical life.

    So far as the nature of the Islamic State is concerned, it is theocracy with regard to God in the sense that the de jure sovereignty belongs to Allah Whose de facto sovereignty is inherent and manifest in the working of the entire universe and Who enjoys exclusively the sovereign prerogative over all the creation. The Holy Qur'an has stressed this point in so many verses:

      "The Command is for none but for Allah: He has commanded that ye obey
      none but Him: that is the right path" (xii. 40).
      "Follow the revelation sent unto you from your Lord, and do not follow the (so-called) guardians other than Him" (vii. 3).

    "And those who do not make their decisions in accordance with that revealed by Allah are (in fact) the deniers of Truth" (v. 44). It thus becomes quite clear that a State established on the basis of God's sovereignty cannot enforce any law in contravention of the Qur'an and the Sunnah even if all the citizens make a demand for it. An Islamic State is, therefore, theocratic in one aspect as it is run according to God-given laws, but it is altogether a differmt theocracy of which Europe has had the bitter experience and in which, a priestly clan is sharply marked off from the rest of the population and exercises an unchecked domination and enforces laws of its own making in the name of God, and thus imposes its own godhood upon the common people. The priest puts himself as a mediator between the masses and the unseen God. Such a system is quite un-Islamic. The theocracy built by Islam is not ruled by a particular religious class, but by the whole community of Muslims including the rank and file. as Allah has not appointed a particular individual, group, race or class as the representative of the Real Sovereign upon the earth, but the whole community. The Qur'an says: "Allah has promised to those among you who believe and do righteous deeds that He will assuredly make them to succeed (the present) rulers and grant them vicegerency in the land just as He made those before them to succeed (others)" (ixiv. 55). This verse makes it clear that all believers have been conferred upon the Caliphate and not a special class or dynasty. Moreover, the Caliphate granted by Allah to the faithful is the popular vicegerency and not a limited one and thus it is run with the consent of the people. The concepts of the Divine Right of Kingship and the infallibility of clergy are alien to the spirit of Islam. Every Muslim stands on equal level with the other Muslim as the vicegerent of the Lord upon the earth. None of them, therefore, enjoys any preference to the other by virtue of high birth or belonging to a special religious group. History is teplete with instances of Caliphs being brought to the court and publicly criticised by ordinary men and women. Even a lowliest villager could dare tell the Commander of the Faithful that he would set him straight like a spindle if he deviates an inch from the poth of righteousness. This shows that the rulers and the officials in the Islamic State are answerable both to God and man for their actions, and the people have every right to criticise. not only their public behaviour, but even their private activities.

    In the context of such heavy responsibilities the heading of the Islamic State or assumption of any other important portfolio in its set-up is a very difficult job so much so that that Holy Prophet (may peace be upon him) compared it to the slaughtering of one with a blunt knife. No person, therefore. who is conscious of the responsibilities of the job, covets to assume that; he rather shirks it and accepts it only when he is compelled to do so. The Holy Prophet (may peace be upon him) declared that person to be quite unfit for office in an Islamic State who is covetous of it, as he is either ignorant of its grave responsibilities or desires to take undue advantage of his official power.

    We enumerate below some of the important rights and duties of an Islamic State.

    As for the rights, the Islamic State can claim full loyalty from all its citizen wholehearted cooperation in all sectors of life and complete obedience to the law of the land and the commands of the rulers so long as they are in comformity with the Laws of the Shari'ah. But where the rulers transgress the limits of the citizens have the right, not only to withdraw co-operation, but also to check the rulers from acting against the Commands of Aliah and His Apostle (may peace be upon him).

    The citizens are also required to pay taxes due to the State quite willingly and not to misappropriate its funds, and to participate in Jihad in any capacity for which they are deemed fit by the authorities of the Islamic State.

    So far as the duties of the Islamic State are concerned, the first and foremost duty is to protect the life, property and honour of every citizen, irrespective of his caste, creed, colour, religion or social status.

    Moreover, it is also the duty of the Islamic State to protect the freedom and individual liberty of every citizen so long as there is no valid reason to curtail it. It cannot be done as an arbitrary act. The State is authorised to lay hands upon it through due process of law.

    Again, freedom of expression is one of the fundamental rights of the citizen which an Islamic State must respect.

    Then, it is also the duty of the Islamic State to see that no citizen remains unprovided for in respect of the basic necessities of life, viz, food, othing, shelter, medical aid and education, for the Holy Prophet (may peace be upon him) said: "The government is the guardian of those who have no guardian."

    Moreover, the State is bound to create such conditions in which the good reigns supreme in the society and evil is suppressed and exterminated, and its citizens learn to live as good Muslims.

Chapter 1 : THE PEOPLE ARE SUBSERVIENT TO THE QURAISH AND THE CALIPHATE IS THE RIGHT OF THE QURAISH

Book 20, Number 4473:

    It has been narrarted on the authority of Abu Huraira that the Messenger of Allah (may peace be upon him) said: People are subservient to the Quraish: the Muslims among them being subservient to the Muslims among them, and the disbelievers among the people being subservient to the disbelievers among them.

Book 20, Number 4474:

    It has been narrated on the authority of Hammam b. Munabbih who said: This is one of the traditions narrated by Abu Huraira from the Messenger of Allah (may peace be upon him) who said: People are subservient to the Quraish: the Muslims among them being subservient to the Muslims among them, and the disbelievers among them being subservient to the disbelievers among them.

Book 20, Number 4475:

    It has been narrated on the authority of Jabir b. 'Abdullah that the Messenger of Allah (may peace be upon him) said: People are the followers of Quraish in good as well as evil (i.e. in the customs of Islamic as well as pre-Islamic times).

Book 20, Number 4476:

    It has been narrated on the authority of 'Abdullah that the Messenger of Allah (may peace be upon him) said: The Caliphate will remain among the Quraish even if only two persons are left (on the earth),

Book 20, Number 4477:

    It has been narrated on the authority of Jabir b. Samura who said: I joined the company of the Holy Prophet (may peace be upon him) with my father and I heard him say: This Caliphate will not end until there have been twelve Caliphs among them. The narrator said: Then he (the Holy Prophet) said something that I could not follow. I said to my father: What did he say? He said: He has said: All of them will be from the Quraish.

Book 20, Number 4478:

    It has been reported on the authority of Jabir b. Samura who said: I heard the Messenger of Allah (may peace be upon him) say: The affairs of the people will continue to be conducted (well) as long as they are governed by twelve men. Then the Holy Prophet (may peace be upon him) said words which were obscure to me. I asked my father: What did the Messenger of Allah (may peace be upon him) say? He said: All of the (twelve men) will be from the Quraish.

Book 20, Number 4479:

    This hadith has been narrated on the authority of Jabir b. Samura through another chain of transmitters.

Book 20, Number 4480:

    It has been narrated on the authority of Jabir b. Samura who said: I heard the Messenger of Allah (may peace be upon him) say: Islam will continue to be triumphant until there have been twelve Caliphs. Then the Holy Prophet (may peace be upon him) said something which I could not understand. I asked my father: What did he say? He said: He has said that all of them (twelve Caliphs) will be from the Quraish.

Book 20, Number 4481:

    It has been narrated on the authority of Jabir b. Samura that the Holy Prophet (may peace be upon him) said: This order will continue to be dominant until there have been twelve Caliphs. The narrator says: Then he said something which I could not understand, and I said to my father: What did he say? My father told me that he said that all of them (Caliphs) would be from the Quraish.

Book 20, Number 4482:

    It has been reported on the authority of Jabir b. Samura who said: I went with my father to the Messenger of Allah (may peeace be upon him) and I heard him say: This religion would continue to remain powerful and dominant until there have been twelve Caliphs. Then he added something which I couldn't catch on account of the noise of the people. I asked my father: What did he say? My father said: He has said that all of them will be from the Quraish.

Book 20, Number 4483:

    It has been narrated on the authority of Amir b. Sa'd b. Abu Waqqas who said: I wrote (a letter) to Jabir b. Samura and sent it to him through my servant Nafi', asking him to inform me of something he had heard from the Messenger of Allah (may peace be upon him). He wrote to me (in reply): I heard the Messenger of Allah (may peace be upon him) say on Friday evening, the day on which al-Aslami was stoned to death (for committing adultery): The Islamic religion will continue until the Hour has been established, or you have been ruled over by twelve Caliphs, all of them being from the Quraish. also heard him say: A small force of the Muslims will capture the white palace, the police of the Persian Emperor or his descendants. I also heard him say: Before the Day of Judgment there will appear (a number of) impostors. You are to guard against them. I also heard him say: When God grants wealth to any one of you, he should first spend it on himself and his family (and then give it in charity to the poor). I heard him (also) say: I will be your forerunner at the Cistern (expecting your arrival).

Book 20, Number 4484:

    Ibn Samura al-'Adawi reported: I heard Allah's Messenger (may peace be upon him) say, and he then narrated (the above-mentioned hadith).

Chapter 2 : APPOINTING ANYONE AS A SUCCEEDING CALIPH OR LEAVING ASIDE THE QUESTION OF APPOINTMENT

Book 20, Number 4485:

    It has been narrated on the authority of 'Abdullah b. 'Umar who said: I was present with my father when he was wounded. People praised him and said: May God give you a noble recompense ! He said: I am hopeful (of God's mercy) as well as afraid (of His wrath) People said: Appoint anyone as your successor. He said: Should I carry the burden of conducting your affairs in my life as well as in my death? (So far as Caliphate is concerned) I wish I could acquit myself (before the Almighty) in a way that there is neither anything to my credit nor anything to my discredit. If I would appoint my successor, (I would because) one better than me did so. (He meant Abu Bakr.) If I would leave You alone, (I would do so because) one better than me, i.e. the Messenger of Allah (may peace be upon him), did so. 'Abdullah says: When he mentioned the Messenger of Allah (may peace be upon him) I understood that he would not appoint anyone as Caliph.

Book 20, Number 4486:

    It has been reported on the authority of Ibn 'Umar who said: I entered the apartment of (my sister) Hafsa. She said: Do yoa know that your father is not going to nominate his successor? I said: He won't do that (i.e. he would nominate). She said: He is going to do that. The narrator said: I took an oath that I will talk to him about the matter. I kept quiet until the next morning, still I did not talk to him, and I felt as if I were carryint, a mountain on my right hand. At last I came to him and entered his apartment. (Seeing me) he began to ask me about the condition of the people, and I informed him (about them). Then I said to him: I heard something from the people and took an oath that I will communicate it to you. They presume that you are not going to nominate a successor. If a grazer of camels and sheep that you had appointed comes back to you leaving the cattle, you will (certainly) think that the cattle are lost. To look after the people is more serious and grave. (The dying Caliph) was moved at my words. He bent his head in a thoughtful mood for some time and raised it to me and said: God will doubtlessly protect His religion. If I do not nominate a successor (I have a precedent before me), for the Messenger of Allah (may peace be upon him) did not nominate his successor. And if I nominate one (I have a precedent), for Abu Bakr did nominate. The narrator (Ibn Umar) said: By God. when he mentioned the Messenger of Allah (may peace be upon him) and Abu Bakr, I (at once) understood that he would not place anyone at a par with the Messenger of Allah (may peace be upon him) and would not nominate anyone.

Chapter 3 : PROHIBITION OF A DESIRE FOR A POSITION OF AUTHORITY AND COVETOUSNESS THEREOF

Book 20, Number 4487:

    It has been reported on the authority of 'Abd al-Rahman b. Samura who said: The Messenger of Allah (may peace be upon him) said to me: 'Abd al-Rahman, do not ask for a position of authority, for if you are granted this position as a result of your asking for it, you will be left alone (without God's help to discharge the responsibilities attendant thereon), and it you are granted it without making any request for it, you will be helped (by God in the discharge of your duties).

Book 20, Number 4488:

    The same tradition has been narrated through a different chain of transmitters.

Book 20, Number 4489:

    It has been narrated by Abu Musa who said: Two of my cousins and I entered the apartment of the Holy Prophet (may peace be upon him). One of them said: Messenger of Allah, appoint us rulers of some lands that the Almighty and Glorious God has entrusted to thy care. The other also said something similar. He said: We do not appoint to this position one who asks for it nor anyone who is covetous for the same.

Book 20, Number 4490:

    It has been reported on the authority of Abu Musa who said: I went to the Holy Prophet (may peace be upon him) and with me were two men from the Ash'ari tribe. One of them was on my right hand and the other on my left. Both of them made a request for a position (of authority) while the Holy Prophet (may peace be upon him) was brushing his teeth with a tooth-stick. He said (to me): Abu Musa (or 'Abdullah b. Qais), what do you say (about the request they have made)? I said: By God Who sent thee on thy mission with truth, they did not disclose to me what they had in their minds, and I did not know that they would ask for a position. The narrator says (while recalling this hadith): I visualise as if I were looking at the miswak of the Holy Prophet (may peace be upon him) between his lips. He (the Holy Prophet) said: We shall not or shall never appoint to the public offices (in our State) those who with to have them, but you may go, Abu Musa (or Abdullah b. Qais) (to take up your assignment). He sent him to Yemen as governor. then he sent Mu'adh b. jabal in his wake (to help him in the discharge of duties). When Mu'adh reached the camp of Abu Musa, the latter (received him and) said: Please get yourself down; and he spread for him a mattress, while there was a man bound hand and foot as a prisoner. Mu'adh said: Who is this? Abu Musa said: He was a Jew. He embraced Islam. Then he reverted to his false religion and became a Jew. Mu'adh said: I won't sit until he is killed according to the decree of Allah and His Apostle (may peace be upon him) (in this case). Abu Musa said: Be seated. It will be done. He said: I won't sit unless he is killed in accordance with the decree of Allah and His Apostle (may peace be upon him). He repeated these words thrice. Then Abu Musa ordered him (to be killed) and he was kilied. Then the two talked of standing in prayer at night. One of them, i.e. Mu'adh, said: I sleep (for a part of the night) and stand in prayer (for a part) and I hope that I shall get the same reward for steeping as I shall get for standing (in prayer).

Chapter 4 : UNDESIRABILITY OF GETTING A POSITION OF AUTHORITY WITHOUT NECESSITY

Book 20, Number 4491:

    It has been narrated on the authority of Abu Dharr who said: I said to the Holy Prophet (may peace be upon him): Messenger of Allah, will you not appoint me to a public office? He stroked my shoulder with his hand and said: Abu Dharr, thou art weak and authority is a trust. and on the Day of judgment it is a cause of humiliation and repentance except for one who fulfils its obligations and (properly) discharges the duties attendant thereon.

Book 20, Number 4492:

    It has been reported on the authority of Abu Dharr that the Messenger of of Allah (may peace be upon him) said: Abu Dharr, I find that thou art weak and I like for thee what I like for myself. Do not rule over (even) two persons and do not manage the property of an orphan.

Chapter 5 : THE MERITS OF A JUST RULER AND THE DEMERITS OF A TYRANT RULER

Book 20, Number 4493:

    It has been narrated on the authority of 'Abdullah b. 'Umar that the Messenger of Allah (may peace be upon him) said: Behold! the Dispensers of justice will be seated on the pulpits of light beside God, on the right side of the Merciful, Exalted and GlorioUS. Either side of the Being is the right side both being equally mrneritorious. (The Dispensers of justice are) those who do justice in their rules, in matters relating to their families and in all that they undertake to do.

Book 20, Number 4494:

    It has been reported on the authority of Abd al-Rahman b. Shumasa who said: I came to A'isha to inquire something from her. She said: From which people art thou? I said: I am from the people of Egypt. She said: What was the behaviour of your governor towards you in this war of yours? I said: We did not experience anything bad from him. If the camel of a man from us died, he would bestow on him a camel. If any one of us lost his slave, he would give him a slave. If anybody was in need of the basic necessities of life, he would provide them with provisions. She said: Behold! the treatment that was meted out to my brother, Muhammad b. Abu Bakr, does not prevent me from telling you what I heard from the Messenger of Allah (may peace be upon him). He said in this house of mine: O God, who (happens to) acquire some kind of control over the affairs of my people and is hard upon them-be Thou hard upon him, and who (happens to) acquire some kind of control over the affairs of my people and is kind to them-be Thou kind to him.

Book 20, Number 4495:

    This hadith has been narrated on the authority of Abd al-Rahman b. Shumasa with another chain of transmitters.

Book 20, Number 4496:

    It has been narrated on the authority of Ibn 'Umar that the Holy Prophet (May be upon him) said: Beware. every one of you is a shepherd and every one is answerable with regard to his flock. The Caliph is a shepherd over the people and shall be questioned about his subjects (as to how he conducted their affairs). A man is a guardian over the members of his family and shal be questioned about them (as to how he looked after their physical and moral well-being). A woman is a guardian over the household of her husband and his children and shall be questioned about them (as to how she managed the household and brought up the children). A slave is a guardian over the property of his master and shall be questioned about it (as to how he safeguarded his trust). Beware, every one of you is a guardian and every one of you shall be questioned with regard to his trust.

Book 20, Number 4497:

    This tradition has been narrated through more; than one chain of transmitters.

Book 20, Number 4498:

    This hadith has been transmitted on the authority of Ibn 'Umar, but there is (a slight change of wording) in the hadith transmitted through Zuhri that he said: "I think that he (the narrator) said: The man is a custodian of the wealth of his father, and he would be answerable for what is in his custody."

Book 20, Number 4499:

    A hadith having the same meaning has been transmitted on the authority of 'Abdullah b. 'Umar.

Book 20, Number 4500:

    It has been narrated on the authority of Hasan who said: Ubaidullah b Ziyad visited Ma'qil b. Yasir al-Muzani in his last iliness. Ma'qil said (to him) : I am narrating to you a tradition I heard from the Messenger of Allah (may peace be upon him). If I knew that I am to survive this illness. I would, not narrate it to you. I heard the Messenger of Allah (may peace be upon him) say: If God appointed anyone ruler over a people and he died while he was still treacherous to his people, God would forbid his entry into Paradige.

Book 20, Number 4501:

    It has been narrated through a different chain of transmitters on the authority of Hasan who said: Ibn, Ziyad paid a visit to Ma'qil b. Yasir who was seriously ill. Here follows the same tradition as has gone before with the addition that Ibn Ziyad asked: Why didn't you narrate this tradition to me before this day? Ma'qil reprimanded him and said: I did not narrate it to you or I was not going to narrate it to you.

Book 20, Number 4502:

    It has been narrated on the authority of Abu Malik that Ubaidullah b. Ziyad visited Ma'qil b. Yaser in the latter's illness. Ma'qil said to him: I am narrating to you a tradition. If I were not at death's door, I would not narrate it to you. I heard the Messenger of Allah (may peace he upon him) say: A ruler who, having obtained control over the affairs of the Muslims, does not strive for their betterment and does not serve them sincerely shall not enter Paradise with them.

Book 20, Number 4503:

    It has been narrated on the authority of Abu al-Aswad who said: My father related to me that Ma'qil b. Yasir fell ill. 'Ubaidullah b. Ziyad called on him to inquire after his health. Here follows the tradition as narrated by Hasan from Ma'qil.

Book 20, Number 4504:

    It has been narrated on the authority of Hasan that A'idh b. 'Amr who was one of the Companions of the Messenger of Allah (may peace be upon him) called on 'Ubaidullah b. Ziyad and said (to him) : O my son, I have heard the Messenger of Allah (may peace be upon him) say: The worst of guardians is the cruel ruler. Beware of being one of them. Ubaidullah said (to him out of arrogance): Sit you down. You are from the chaff of the Companions of Muhammad (may peace be upon him). A'idh said: Was there worthless chaff among them? Such worthless chaff appeared after them and among other people.

Chapter 6 : MISAPPROPRIATION OF BOOTY IS A SERIOUS OFFENCE

Book 20, Number 4505:

    It has been narrated on the authority of Abu Huraira who said: One day the Messenger of Allah (may peace be upon him) stood among us (to deliver a sermon). He talked about the misappropriation of booty, and declared it to be a serious matter and a grave sin. Then he said: I shouldn't find that any of you should come on the Day of Judgment with a growling camel mounted on his neck, and should appeal to me for help saying: "Messenger of Allah, help me." and I should say: I have no authority to help you; I already communicated to you. I shouldn't find that any of you should come on the Day of Judgment with a bleating ewe mounted on his neck, and he should say to me: "Messenger of Allah, help me," and I should say: I have no authority to help you; I conveyed to you. I shouldn't find that one of you should come on the Day of Judgment with a Person crying loudly mounted on his neck, and he should say to me: "Messenger of Allah, help me," and I should say: I have no authority to help you; I conveyed to you. I shouldn't find that any one of you should come on the Day of Judgment with fluttering clothes wrapped round his neck and he should say to me: "Messenger of Allah, help me," and I should say: I have no authority to help you; I conveyed to you. I shouldn't find that any of you should come on the Day of Judgment with a heap of gold and silver placed on his neck and he should say to me: "Messenger of Allah, help me." and I should say: I have no authority to help you; I already conveyed to you (the warning from the Almighty).

Book 20, Number 4506:

    The above tradition has been narrated on the same authority through different chains of transmitters.

Book 20, Number 4507:

    Abu Huraira has narrated this hadith with a slight variation of words.

Book 20, Number 4508:

    Abu Huraira has narrated this hadith similar to the above mentioned hadith.

Chapter 7 : ACCEPTANCE OF GIFTS ON THE PART OF STATE OFFICERS IS FORBIDDEN

Book 20, Number 4509:

    It has been narrated on the authority of Abu Humaid as-Sa'idi who said: The Messenger of Allah (may peace be upon him) appointed a man from the Asad tribe who was called Ibn Lutbiyya in charge of Sadaqa (i.e. authorised hign to receive Sadaqa from the people on behalf of the State. When he returned (with the collictions), he said: This is for you and (this is mine as) it was presented to me as a gift. The narrator said: The Messenger of Allah (may peace be upod him) stood on the pulpit and praised God and extolled Him. Then he said: What about a State official whom I give an assignment and who (comes and) says: This is for you and this has been presented to me as a gift? Why didn't he remain in the house of his father or the house of his mother so that he could observe whether gifts were presented to him or not. By the Being in Whose Hand is the life of Muhammad, any one of you will not take anything from it but will bring it on the Day of Judgment, carrying on his neck a camel that will be growling, or a cow that will be bellowing or an ewe that will be bleating. Then he raised his hands so that we could see the whiteness of his armpits. Then he said twice: O God, I have conveyed (Thy Commandments).

Book 20, Number 4510:

    It has been reported on the authority of Abu Humaid as-Sa'idi who said: The Holy Prophet (may peace be upon him) appointed Ibn Lutbiyya, a man from the Azd tribe, in charge of Sadaqa (authorising him to receive gifts from the people on behalf of the State). He came with the collectio, gave it to the Holy Prophet (may peace be upon him). and said: This wealth is for you and this is a gift presented to me. The Holy Prophet (may peace be upon him) said to him: Why didn't you remain in the house of your father and your mother to see whether gifts were presented to you or not. Then he stood up to deliver a sermon. Here follows the tradition like the tradition of Sufyan.

Book 20, Number 4511:

    It has been reported on the authority of Abu Humaid as-Sa'idi who said: The Messenger of Allah (may peace be upon him) appointed a man from the Azd tribe. called Ibn al-,Utbiyya, in charge of Sadaqat to be received from Banu Sulaim. When he came (back), the Messenger of Allah (may peace be upon him) asked him to render his account. He said: This wealth is for you (i.e. for the public treasury) and this is a gift (presented to me). The Messenger of Allah (may peace be upon him) said: You should have remained in the house of your father and your mother, until your gift came to you if you spoke the truth; then he addressed us. He praised God and extolled Him, and afterwards said: I appoint a man from you to a responsible post sharing with the authority that God has entrusted to me, and he comes to me saying: This wealth is for you (i.e. for the public treasury) and this is a gift presented to me. Why did he not remain in the house of his father and his mother and his gift came to him, if he was truthful? By God, any one of you will not take anything from (the public funds) without any justification, but will meet his Lord carrying it on himself on the Day of judgment. I will recognise any one of you meeting Allah and carrying a growling camel, or a cow bellowing or a goat bleating. Then he raised his hands so high that whiteness of his armpits could be seen. Then he said: O my Lord, I have conveyed (Thy Commandments). The narrator says: My eyes saw (the Holy Prophet standing in that pose) and my ears heard (what he said).

Book 20, Number 4512:

    This tradition has been hanoed down through a different chain of transmitters on the authority of Hisham with aslight variation in the wording.

Book 20, Number 4513:

    It has been narrated on the authority of Abu Humaid as-Sa'idi that the Messenger of Allah (may peace be upon him) appointed a man in charge of Sadaqa (authorising him to receive charity from the people on behalf of the State). He came (back to the Holy prophet) with a large number of things and started saying: This is for you and this has been presented to me as a gift. Here follows the tradition that has gone before except that 'Urwa (one of the narrators in the chain of transmitters) asked Abu Humaid: Did you hear it from the Messenger of Allah (himself) (may peace be upon him)? He replied: My ears heard it from his mouth.

Book 20, Number 4514:

    It has been reported on the authority of 'Adi b. 'Amira al-Kindi who said: I heard the Messenger of Allah (may peace be upon him) say: Whoso from you is appointed by us to a position of authority and he conceals from us a needle or something smaller than that, it would be misappropriation (of public funds) and will (have to) produce it on the Day of Judgment. The narrator says: A dark-complexioned man from the Ansar stood up-I can visualise him still-and said: Messenger of Allah, take back from me your assignment. He said: What has happened to you? The man said: I have heard you say so and so. He said: I say that (even) now: Whoso from you is appointed by as to a position of authority, he should bring everything, big of small, and whatever he is given therefrom he should take, and he should restrain himself from taking that which is forbidden.

Book 20, Number 4515:

    This hadith has been narrated on the authority of Isma'il with the same chain of transmitters.

Book 20, Number 4516:

    Adi b. 'Amira al-Kindi heard Allah's Messenger (may peace be upon him) as saying (as) was narrated in the (above-mentioned) hadith.

Chapter 8 : OBEDIENCE TO THE RULER IS FORBIDDEN IN MATTERS SINFUL, BUT IS OTHERWISE OBLIGATORY

Book 20, Number 4517:

    It has been narrated on the authority of Ibn Juraij that the Qur'anic injunction: "0 you who believe, obey Allah, His Apostle and those in authority from amongst You" (iv. 59)-was revealed in respect of 'Abdullah b. Hudhafa b. Qais b. Adi al-Sahmi who was despatched by the Holy Prophet (may peace be upon him) as leader of a military campaign. The narrator said: He was informed of this fact by Ya'la b. Muslim who was informed by Sa'id b. Jubair who in turn was informed by Ibn Abbas.

Book 20, Number 4518:

    It has been narrated on the authority of Abu Huraira that the Holy prophet (may peace be upon him) said: Whoso obeys me obeys God, and whoso disobeys me disobeys God. Whoso obeys the commander (appointed by me) obeys me, and whoso disobeys the commander disobeys me. The same tradition transmitted by different persons omits the portion: And whose disobeys the commander disobeys me.

Book 20, Number 4519:

    It has been narrated on the authority of Abu Huraira that the Messenger of Allah (may peace be upon him) said: Whoso obeys me obeys God; and whose disobeys me disobeys God. Whoso obeys my commander obeys me, and whoso disobeys my commander disobeys me.

Book 20, Number 4520:

    This hadith has been narrated on the authority of Abu Huraira through another chain of transmitters.

Book 20, Number 4521:

    This hadith has been narrated on the authority of Abu Huraira by more than one chain of transmitters.

Book 20, Number 4522:

    Hammam b. Munabbih has transmitted this hadith on the authority of Abu Huraira.

Book 20, Number 4523:

    According to one version of the tradition, the Messenger of Allah (may peace be upon him) said: Whoso obeys the commander. He did not say: "My commander."

Book 20, Number 4524:

    It has been narrated on the authority of Abu Huraira that the Messenger of Allah (may peace be upon him) said: It is obligatory for you to listen to the ruler and obey him in adversity and prosperity, in pleasure and displeasure, and even when another person is given (rather undue) preference over you.

Book 20, Number 4525:

    It has been narrated on the authority of Abu Dharr who said: My friend (i.e. the Holy Prophet) advised me to listen (to the man in position of authority) and obey (him) even if he were a slave maimed (and disabled).

Book 20, Number 4526:

    In another version of the tradition, we have the wording: "An Abyssinian slave maimed and disabled."

Book 20, Number 4527:

    Abu 'Imran narrated this hadith with a slight change of wording.

Book 20, Number 4528:

    It has been narrated on the authority of Yahya b. Husain who learnt the tradition from his grandmother. She said that she heard the Holy Prophet (may peace be upon him) delivering his sermon on the occasion of the Last Pilgrimage. He was saying: If a slave is appointed over you and he conducts your affairs according to the Book of Allah, you should listen to him and obeey (his orders).

Book 20, Number 4529:

    This hadith has been transmitted on the authority of Shu'ba with the same chain of transmitters, and he said :"a negro slave".

Book 20, Number 4530:

    In other versions of the above tradition, the wordings are "an Abyssinian slave." and "a maimed Abyssinian slave".

Book 20, Number 4531:

    Another version of the tradition does not qualify the slave with the epithets "maimed," "an Abyssinian" but makes the addition: "I have heard the Holy Prophet (may peace be upon him) (say this) at Mina or 'Arafat."

Book 20, Number 4532:

    It has been narrated on the authority of Yahya b. Husain who learnt the tradition from his grandmother. Umm Husain. He said': I heard her say: I performed Hajjat-ul-Wada' in the company of the Messenger of Allah (may peace be upon him). He said a lot of things (on this occasion). Then I heard him say: If a maimed slave is appointed a commander over you the narrator says: I think she said: "a black stave" who leads you according to the Book of Allah, then listen to him and obey him.

Book 20, Number 4533:

    It has been narrated on the authority of Ibn 'Umar that the Holy Prophet (may peace be upon him) said: It is obligatory upon a Muslim that he should listen (to the ruler appointed over him) and obey him whether he likes it or not, except that he is ordered to do a sinful thing. If he is ordered to do a sinful act, a Muslim should neither. listen to him nor should he obey his orders.

Book 20, Number 4534:

    This hadith has been transmitted on the authority of 'Ubaidullah.

Book 20, Number 4535:

    It has been narrated on the authority of Abu 'Abd al-Rahman from 'Ali that the Messenger of Allah (may peace be upon him) sent a force (on a mission) and appointed over them a man. He kindled a fire and said: Enter it. Some people made up their minds to enter it (the fire), (carrying out the order of their commander), but the others said : We fled from the fire (that's why we have come into the fold of Islam). The matter was reported to the Messenger of Allah (may peace be upon him). He said to those who Contemplated entering (the fire at the order of their commander) : If you had entered it, you would have remained there until the Day of Judgment. He commanded the act of the latter group and said: There is no submission in matters involving God's disobedience or displeasure. Submission is obligatory only in what is good (and reasonable).

Book 20, Number 4536:

    It has been narrated on the authority of 'All who said: The Mersenger of Allah (may peace be upon him) sent an expeditionand appointed over the Mujahids a man from the Ansar. (While making the appointment), he ordered that his work should be listened to and obeyed. They made him angry in a matter. He said: Collect for me dry wood. They collected it for him. Then he said: Kindle a fire. They kindled (the fire). Then he said: Didn't the Messenger of Allah (may peace be upon him) order you to listen to me and obey (my orders)? They said: Yes. He said: Enter the fire. The narrator says: (At this), they began to look at one another and said: We fled from the fire to (find refuge with) the Messenger of Allah (may peace be upon him) (and now you order us to enter it). They stood quiet until his anger cooled down and the fire went out. When they returned, they related the incident to the Messenger of Allah (may peace be upon him). He said: If they had entered it, they would not have come out. Obedience (to the commander) is obligatory only in what is good.

Book 20, Number 4537:

    This hadith has been transmitted on the authority of A'mash.

Book 20, Number 4538:

    It has been narrated on the authority of "Ubida who learnt the tradition from his father who, in turn, learnt it from his own father. 'Ubada's grandfather said: The Messenger of Allah (may peace be upon him) took an oath of allegiance from us on our listening to and obeying the orders of our commander in adversity and prosperity, in pleasure and displeasure (and even) when somebody is given preference over us, on our avoiding to dispute the delegation of powers to a person deemed to be a fit recipient thereof (in the eye of one who delegates it) and on our telling the truth in whatever position we be without fearing in the matter ef Allah the reproach of the reproacher.

Book 20, Number 4539:

    This hadith has been narrated on the authority of 'Ubada b. Walid with the same chain of transmitters.

Book 20, Number 4540:

    The same tradition has been handed down through more than one chain of transmitters.

Book 20, Number 4541:

    It has been narrated on the authority of Junida b. Abu Umayya who said: We called upon 'Ubada b. Samit who was ill and said to him: May God give you health I Narrate to us a tradition which God may prove beneficial (to us) and which you have heard from the Messenger of Allah (may peace be upon him). He said: The Messenger of Allah (may peace be upon him) called us and we took the oath of allegiance to him. Among the injunctions he made binding upon us was: Listening and obedience (to the Amir) in our pleasure and displeasure, in our adversity and prosperity, even when somebody is given preference over us, and without disputing the delegation of powers to a man duly invested with them (Obedience shall be accorded to him in all circumstances) except when you have clear signs of his disbelief in (or disobedience to) God-signs that could be used as a conscientious justification (for non-compliance with his orders).

Chapter 9 : WHEN A RULER ENJOINS GOD-CONSCIOUSNESS AND DOES JUSTICE, HE WILL HAVE A (GREAT) REWARD

Book 20, Number 4542:

    It has been narrated on the authority of Abu Huraira that the Prophet of Allah (may peace be upon him) said: A commander (of the Muslims) is a shield for them. They fight behind him and they are protected by (him from tyrants and aggressors). If he enjoins fear of God, the Exalted and Glorious, and dispenses justice, there will be a (great) reward for him; and if he enjoins otherwise, it redounds on him.

Chapter 10 : FULFILMENT OF THE COVENANT MADE WITH THE CALIPHS IS IMPERATIVE. THE CALIPH TO WHOM ALLEGIANCE IS SWORN IN THE FIRST INSTANCE HAS AN ESTABLISHED SUPREMACY OVER THOSE WHO ASSUME POWERS LATER

Book 20, Number 4543:

    It has been narrated by Abu Huraira that the Holy Prophet (may pceace be upon him) said: Banu Isra'il were ruled over by the Prophets. When one Prophet died, another succeeded him; but after me there is no prophet and there will be caliphs and they will be quite large in number. His Companions said: What do you order us to do (in case we come to have more than one Caliph) ? He said: The one to whom allegiance is sworn first has a supremacy over the others. Concede to them their due rights (i.e. obey them). God (Himself) will question them about the subjects whom He had entrusted to them.

Book 20, Number 4544:

    The same tradition has been transmitted by a different chain of narrators.

Book 20, Number 4545:

    It has been narrated on the authority of 'Abdullah who said: The Messenger of Allah (may peace be upon him) said: After me there will be favouritism anad many things that you will not like. They (his Companions) said: Messenger of Allah, what do you order that one should do it anyone from us has to live through such a time? He said: You should discharge your own responsibility (by obeying your Amir), and ask God to cuncede your right (by guiding the Amir to the right path or by replacing him by one more just and God-fearing).

Book 20, Number 4546:

    It has been narrated on the authority of 'Abd al-Rahman b. Abd Rabb al-Ka'ba who said: I entered the mosque when 'Abdullah b. 'Amr b. al-'As was sitting in the shade of the Ka'ba and the people had gathered around him. I betook myself to them and sat near him. (Now) Abdullah said: I accompanied the Messenger of Allah (may peace be upon him) on a journey. We halted at a place. Some of us began to set right their tents, others began to compete with one another in shooting, and others began to graze their beasts, when an announcer of the Messenger of Allah (may peace be upon him) announced that the people should gather together for prayer, so we gathered around the Messenger of Allah (may peace be upon him). He said: It was the duty of every Prophet that has gone before me to guide his followers to what he knew was good for them and warn them against what he knew was bad for them; but this Umma of yours has its days of peace and (security) in the beginning of its career, and in the last phase of its existence it will be afflicted with trials and with things disagreeable to you. (In this phase of the Umma), there will be tremendous trials one after the other, each making the previous one dwindle into insignificance. When they would be afflicted with a trial, the believer would say: This is going to bring about my destruction. When at (the trial) is over, they would be afflicted with another trial, and the believer would say: This surely is going to be my end. Whoever wishes to be delivered from the fire and enter the garden should die with faith in Allah and the Last Day and should treat the people as he wishes to be treated by them. He who swears allegiance to a Caliph should give him the piedge of his hand and the sincerity of his heart (i.e. submit to him both outwardly as well as inwardly). He should obey him to the best of his capacity. It another man comes forward (as a claimant to Caliphate), disputing his authority, they (the Muslims) should behead the latter. The narrator says: I came close to him ('Abdullah b. 'Amr b. al-'As) and said to him: Can you say on oath that you heard it from the Messenger of Allah (may peace be upon him)? He pointed with his hands to his ears and his heart and said: My ears heard it and my mind retained it. I said to him: This cousin of yours, Mu'awiya, orders us to unjustly consume our wealth among ourselves and to kill one another, while Allah says: "O ye who believe, do not consume your wealth among yourselves unjustly, unless it be trade based on mutual agreement, and do not kill yourselves. Verily, God is Merciful to you" (iv. 29). The narrator says that (hearing this) Abdullah b. 'Amr b. al-As kept quiet for a while and then said: Obey him in so far as he is obedient to God; and diqobey him in matters involving disobedience to God.

Book 20, Number 4547:

    This hadith has been narrated on the authority of A'mash with a different chain of transmitters.

Book 20, Number 4548:

    It has been narrated on the authority of 'Abd Rabb al-Ka'ba as-Sa'idl who said: I saw a group of people near the Ka'ba.... Then he narrated the tradition as narrated by A'mash.

Chapter 11 : PATIENCE AT THE TYRANNY OF THE GOVERNORS AND THEIR UNDUE PREFERENCES

Book 20, Number 4549:

    It has been narrated on the authority of Usaid b. Hudair that a man from the Ansar took the Messenger of Allah (may peace be upon him) aside and said to him: Will you not appoint me governor as you have appointed so and so? He (the Messenger of Allah) said: You will surely come across preferential treatment after me, so you should be patient until you meet me at the Cistern (Haud-i-Kauthar).

Book 20, Number 4550:

    This tradition has been narrated on the same authority through a different chain of transmitters. Another version of the tradition narrated on the authority of Shu'ba does not include the words: "He took the Messenger of Allah (may peace be upon him) aside."

Chapter 12 : OBEDIENCE TO BE SHOWN TO THE (CALIPHS) EVEN IF THEY WITHHOLD THE PEOPLE'S DUE RIGHTS

Book 20, Number 4551:

    It has been narrated on the authority of Alqama b. Wai'l al-Hadrami who learnt the tradition from his father. The latter said: Salama b. Yazid al-ju'afi asked the Messenger of Allah (may peace be upon him) : Prophet of Allah, what do you think if we have rulers who rule over us and demand that we discharge our obligations towards them, but they (themselves) do not discharge their own responsibilities towards us? What do you order us to do? The Messenger of Allah (may peace be upon him) avoided giving any answer. Salama asked him again. He (again) avoided giving any answer. Then he asked again-it was the second time or the third time-when Ash'ath b. Qais (finding that the Holy Prophet was unnecessarily being pressed for answer) pulled him aside and said : Listen to them and obey them, for on them shall he their burden and on you shall be your burden.

Book 20, Number 4552:

    It has been narrated through a different chain of transmitters. on the authority of Simak who said: Ash'ath b. Qais pulled him (Salama b. Yazid) when the Messenger of Allah (may peace be upon him) said: Listen to them and obey them, for on them shall be the burden of what tney do and on you shall be the burden of what you do.

Chapter 13 : INSTRUCTION TO STICK TO THE MAIN BODY OF THE MUSLIMS IN THE TIME OF TRIALS AND WARNING AGAINST THOSE INVITING PEOPLE TO DISBELIEF

Book 20, Number 4553:

    It has been narrated on the authority of Hudhaifa b. al-Yaman who said: People used to ask the Messenger of Allah (may peace be upon him) about the good times, but I used to ask him about bad times fearing lest they overtake me. I said: Messenger of Allah, we were in the midst of ignorance and evil, and then God brought us this good (time through Islam). Is there any bad time after this good one? He said: Yes. I asked : Will there be a good time again after that bad time ? He said: Yes, but therein will be a hidden evil. I asked: What will be the evil hidden therein? He said: (That time will witness the rise of) the people who will adopt ways other than mine and seek guidance other than mine. You will know good points as well as bad points. I asked: Will there be a bad time after this good one ? He said: Yes. (A time will come) when there will be people standing and inviting at the gates of Hell. Whoso responds to their call they will throw them into the fire. I said: Messenger of Allah, describe them for us. He said: All right. They will be a people having the same complexion as ours and speaking our language. I said: Messenger of Allah, what do you suggest if I happen to live in that time ? He said: You should stick to the main body of the Muslims and their leader. I said: If they have no (such thing as the) main body and have no leader ? He said : Separate yourself from all these factions, though you may have to eat the roots of trees (in a jungle) until death comes to you and you are in this state.

Book 20, Number 4554:

    It his been narrated through a different chain of transmitters, on the authority of Hudhaifa b. al-Yaman who said: Messenger of Allah, no doubt, we had an evil time (i.e. the days of Jahiliyya or ignorance) and God brought us a good time (i.e. Islamic period) through which we are now living Will there be a bad time after this good time ? He (the Holy Prophet) said: Yes. I said : Will there be a good time after this bad time? He said: Yes. I said: Will there be a bad time after good time? He said: Yes. I said: How ? Whereupon he said : There will be leaders who will not be led by my guidance and who will not adopt my ways ? There will be among them men who will have the hearts of devils in the bodies of human beings. I said: What should I do. Messenger of Allah, if I (happen) to live in that time ? He replied : You will listen to the Amir and carry out his orders; even if your back is flogged and your wealth is snatched, you should listen and obey.

Book 20, Number 4555:

    It has been narrated on the authority of Abu Huraira that the Messenger of Allah (may peace be upon him) said: One who defected from obedience (to the Amir) and separated from the main body of the Muslims-if he died in that state-would die the death of one belonging to the days of Jahiliyya (i.e. would not die as a Muslim). One who fights under the banner of a people who ate blind (to the cause for which they are fighting. i.e. do not know whether their cause is just or otherwise), who gets flared up with family pride, calls, (people) to fight for their. family honour, and supports his kith and kin (i.e. fignts not for the cause of Allah but for the sake of this family or tribe) -if he is killed (in this fight), he dies as one belonging to the days of Jhiliyya. Whoso attacks my Umma (indiscriminately) killing the righteous and the wicked of them, sparing not (even) those staunch in faith and fulfilling not his promise made with those who have been given a pledge of security-he has nothing to do with me and I have nothing to do with him.

Book 20, Number 4556:

    The same tradition has been narrated by the same authority through another chain of transmitters with a slight difference in wording.

Book 20, Number 4557:

    It has been narrated (through a different chain of transmitters) on the authority of Abu Huraira that the Messenger of Allah (may peace be upon him) said: Who defected from obedience (to the Amir) and separated from the main body of the Muslim-then he died in that state-would die the death of one belonging to the days of Jahillyya. And he who is killed under the banner of a man who is blind (to the cause for which he is fighting), who gets flared up with family pride and fights for his tribe-is not from my Umma, and whoso from my followers attacks my followers (indiscriminately) killing the righteous and the wicked of them, sparing not (even) those staunch in faith and fulfilling not his obligation towards them who have been given a pledge (of security), is not from me (i.e. is not my follower).

Book 20, Number 4558:

    This hadlth has been narrated on the authority of Jarir with the same chain of transmitters with a slight variation in wording.

Book 20, Number 4559:

    It has been narrated on the authority of Ibn 'Abbas that the messenger of Allah (may peace be upon him) said: One who found in his Amir something which he disliked should hold his patience, for one who separated from the main body of the Muslims even to the extent of a handspan and then he died would die the death of one belonging to the days of Jahiliyya.

Book 20, Number 4560:

    It has been narrated (through a different chain of transmitters) on the authority of Ibn Abbas that the Messenger of Allah (may peace be upoh him) said: One who dislikes a thing done by his Amir should be patient over it, for anyone from the people who withdraws (his obedience) from the government, even to the extent of a handspan and died in that conditions, would die the death of one belonging to the days of jahilliyya.

Book 20, Number 4561:

    It has been narrated on the authority of Ibn 'Abdullah al-Bajali that the Messenger of Allah (may peace be upon him) said: One who is killed under the banner of a man who is blind (to his just cause), who raises the slogan of family or supports his own tribe, dies the death of one belonging to the days of Jahiliyya.

Book 20, Number 4562:

    It has been reported on the authority of Nafi, that 'Abdullah b. Umar paid a visit to Abdullah b. Muti' in the days (when atrocities were perpetrated on the People Of Medina) at Harra in the time of Yazid b. Mu'awiya. Ibn Muti' said: Place a pillow for Abu 'Abd al-Rahman (family name of 'Abdullah b. 'Umar). But the latter said: I have not come to sit with you. I have come to you to tell you a tradition I heard from the Messenger of Allah (may peace be upon him). I heard him say: One who withdraws his band from obedience (to the Amir) will find no argument (in his defence) when he stands before Allah on the Day of Judgment, and one who dies without having bound himself by an oath of allegiance (to an Amir) will die the death of one belonging to the days of Jahillyya.

Book 20, Number 4563:

    It has been narrated on t4e authority of Abu 'Umar that he visited Ibn Muti', and related from the Holy Prophet (may peace be upon him) the tradition that has gone before.

Book 20, Number 4564:

    The same tradition has been transmitted by a different chain of narrators.

Chapter 14 : DECISION ABOUT ONE WHO TRIES TO DISRUPT THE UNITY OF THE MUSLIMS

Book 20, Number 4565:

    It has been narrated on the authority of 'Arfaja who said: I have heard the Messenger of Allah (may peace be upon him) say: Different evils will make their appearance in the near future. Anyone who tries to disrupt the affairs of this Umma while they are united you should strike him with the sword whoever he be. (If remonstrance does not prevail with him and he does not desist from his disruptive activities, he is to be killed.)

Book 20, Number 4566:

    In another version of the tradition narrated on the same authority through a different chains of transmitters we have the words: "Kill him."

Book 20, Number 4567:

    It has been narrated (through a still different chain of transmitters) on the Same authority (i.e.'Arfaja) who said similarly-but adding: "Kill all of them." I heard the Messenger of Allah (may peace be upon him) say: When you are holding to one single man as your leader, you should kill who seeks to undermine your solidarity or disrupt your unity.

Chapter 15 : WHEN THE OATH OF ALLEGIANCE HAS BEEN OBTAINED FOR TWO CALIPHS

Book 20, Number 4568:

    It has been narrated on the authority of Aba Sa'id al-Khudri that the Messenger of Allah (may peace be upon him) said: When oath of allegiance has been taken for two caliphs, kill the one for whom the oath was taken later.

Chapter 16 : JUSTIFICATION FOR HATING THE AMIRS FOR VIOLATING THE LAWS OF THE SHARI'AH

Book 20, Number 4569:

    It has been narrated on the authority of Umm Salama that the Messenger of Allah (may peace be upon him) said: In the near future there will be Amirs and you will like their good deeds and dislike their bad deeds. One who sees through their bad deeds (and tries to prevent their repetition by his band or through his speech), is absolved from blame, but one who hates their bad deeds (in the heart of his heart, being unable to prevent their recurrence by his hand or his tongue), is (also) fafe ( so far as God's wrath is concerned). But one who approves of their bad deeds and imitates them is spiritually ruined. People asked (the Holy Prophet): Shouldn't we fight against them? He replied: No, as long as they say their prayers.

Book 20, Number 4570:

    It has been narrated (through a different chain of tmnamitters) on the authority of Umm Salama (wife of the Holy Prophet) that he said: Amirs will be appointed over you, and you will find them doing good as well as bad deeds. One who hates their bad deeds is absolved from blame. One who disapproves of their bad deeds is (also) safe (so far as Divine wrath is concerned). But one who approves of their bad deeds and imitates them (is doomed). People asked: Messenger of Allah, shouldn't we fight against them? He replied: No, as long as they say their prayer. ("Hating and disapproving" refers to liking and disliking from the heart.)

Book 20, Number 4571:

    Another version of the tradition narrated on the same authority attributes the same words to the Messenger of Allah (may peace be upon him) except that it replaces kariha with ankhara and vice versa.

Book 20, Number 4572:

    Another version omits a portion at the end of the tradition-a portion which begins with man radiya wa taba and ends with the last word of the tradition.

Chapter 17 : THE BEST AND THE WORST OR YOUR RULERS

Book 20, Number 4573:

    It has been narrated on the authority of 'Auf b. Malik that the Messenger of Allah (may peace be upon him) said: The best of your rulers are those whom you love and who love you, who invoke God's blessings upon you and you invoke His blessings upon them. And the worst of your rulers are those whom you hate and who hate you and whom you curse and who curse you. It was asked (by those present): Shouldn't we overthrow them with the help of the sword? He said: No, as long as they establish prayer among you. If you then find anything detestable in them. You should hate their administration, but do not withdraw yourselves from their obedience.

Book 20, Number 4574:

    It has been narrated on the authority of Auf b. Malik al-Ashja'i who said that he heard the Messenger of Allah (may peace be upon him) say: The best of your rulers are those whom you love and who love you, upon whom you invoke God's blessings and who invoke His blessing upon you. And the worst of your rulers are those whom you hate and who hate you, who curse you and whom you curse. (Those present) said: Shouldn't we overthrow them at this? He said: No, as long as they establish prayer among you. No, as long as they establish prayer among you. Mind you! One who has a governor appointed over him and he finds that the governor indulges in an act of disobedience to God, he should condemn the governor's act, in disobedience to God, but should not withdraw himself from his obedience. Ibn Jabir said: Ruzaiq narrated to me this hadith. I asked him: Abu Miqdam, have you heard it from Muslim b. Qaraza or did he describe it to you and he heard it from 'Auf (b. Malik) and he transmitted this tradition of Allah's Messenger (may peace be upon him)? Upon this Ruzaiq sat upon his knees and facing the Qibla said: By Allah, besides Whom there is no other God, I heard it from Muslim b. Qaraza and he said that te had heard it from Auf(b. Malik) and he said that he had heard it from the Messenger of Allah (may peace be upon him).

Book 20, Number 4575:

    The above tradition has been narrated through a different chain of transmitters.

Chapter 18 : IT IS GOOD ON THE PART OF A LEADER TO TAKE THE OATH OF ALLEGIANCE FROM HIS FORCES WHEN INTENDING TO FIGHT AND AN ACCOUNT OF THE ALLEGIANCE OF GOD'S PLEASURE UNDER THE TREE

Book 20, Number 4576:

    It has been narrated on the authority of Jabir who said: We were one thousand and four hundred on the Day of Hudaibiya. We swore fealty to hiin (the Holy Prophet) and 'Umar was holding the latter's hand (when he was sitting) under the tree (called) Samura (to administer the oath to the Companions). The narrator added: We took oath to the effect that we would not flee (from the battlefield if there was an encounter with the Meccans), but we did not take oath to fight to death.

Book 20, Number 4577:

    It has been narrated (through a different chain of transmitters) on the authority of Jabir who said: While swearing fealty to the Holy Prophet (may peace be upon him) we did not take the oath to death but that we would not run away (from the battlefield).

Book 20, Number 4578:

    It has been narrated on the authority of Abu Zubair who heard Jabir being questioned as to how many people were there on the Day of Hudaibiya He replied: We wore fourteen hundred. We swore fealty to him, and Umar was holding his hand while he was sitting Under the tree (to administer the oath). The tree was Samura (a wild tree found in desers). All of as took tha oath of fealty at his hands except Jadd b. Qais al-Ansari who hid himself under the belly of his camel.

Book 20, Number 4579:

    It has been narrated (through a different chain of transmitters) on the authority of Abu Zubair who heard Jabir being questioned as to whether the Holy Prophet (may peace be upon him) took the oath of fealty at Dhu'l-Hulaifa. He said : No! But he offered his prayers at that place, and he administered the oath of fealty nowhere except near the tree in (the plain oo Hudaibiya. Ibn Juraij said that he was informed by Abu Zabair who heard Jabir b. Abdullah say: The Holy Prophet (may peace be upon him) prayed over the well at Hudaibiya (as a result of which its scanty water rose up and increased so as to be sufficient for the 1400 or 1500 men who had encamped at the place).

Book 20, Number 4580:

    It has been narrated (through a different chain of transmitters) on the authority of Jabir who said: We were one thousand and four hundred on the Day of Hudaibiya when the Holy Prophet (may peace be upon him) said to us: Today you are the best people on the earth. And Jabir said: If I had the eyesight, I could show you the place of the tree.

Book 20, Number 4581:

    It has been narrated on the authority of Salim b. Abu al-Ja'd who said: I asked Jabir b. 'Abdullah about the number of the Companions (of the Holy Prophet who took the oath of fealty under) the tree. He said: If we were a hundred thousand, it (i.e. the water in the well at Hudaibiya) would have sufficed us, but actually we were one thousand and five hundred.

Book 20, Number 4582:

    It has been narrated on the authority of Jabir who said: If we had been a hundred thousand in number, it (the water) would have sufficed us, but actually we were fifteen hundred.

Book 20, Number 4583:

    It has been narrated (through a different chain of transmitters) on the authority of Salim b. al-Ja'd who said: I asked Jabir: How many were you on the Day of Hudaibiya? He said: One thousand and four hundred.

Book 20, Number 4584:

    It has been narrated on the authority of 'Abdullah b. Abu Aufa who said: The Companions of the Tree (i e. those who swore fealty under the tree) were one thousand and three hundred, and the people of Aslam tribe were one-eighth of the Muhajirs.

Book 20, Number 4585:

    The same tradition has been handed down through a different chain of transmitters.

Book 20, Number 4586:

    It has been narrated on the authority of Ma'qil b. Yasar who aaid: I remember being present on the Day of the Tree, and the Holy Prophet (may peace be upon him) was taking the oath of the people and I was holding a twig of the tree over his head. We were fourteen hundred (in number). We did not take oath to the death, but to the effect that we would not run away from the battlefield.

Book 20, Number 4587:

    This hadith has been narrated on the authority of Yunus with the same chain of transmitters.

Book 20, Number 4588:

    It has been narrated on the authority of Sa'id b. Musayyab who said: My father was one of those who swore fealty to the Messenger of Allah (may peace be upon him) near the tree. When we passed that way next year intending to perform the Hajj, the place of the tree was hidden to us. If you could point out clearly, you would (certainly) be knowing better.
    It has also been narrated on the authority of Sa'id b. Musayyib who learnt from his father that they were with the Messenger of Allah (may peace be upon him) in the year of the Tree (i.e. in the year of the fealty of God's pleasure sworn under the tree at Hudaibiya), but next year they forgot the spot of the tree.

Book 20, Number 4589:

    The tradition has been narrated on the authority of Sa'id b. Musayyib who learnt it from his father. The latter said: I had seen the tree. When I came to the spot afterwards, I could not recognise it.

Book 20, Number 4590:

    It has been narrated on the authority of Yazid b. Abu Ubaid (the freed slave of Salama b. al-Akwa') who said: 1 asked Salama as to what effect he had sworn fealty to the Messenger of Allah (may peace be upon him) on the Day of Hudaibiya. He said: To the effect that we will die fighting.

Book 20, Number 4591:

    The above tradition has also been handed down through a different chain of transmitters.

Book 20, Number 4592:

    It has been narrated on the authority of Abdullah b. Zaid who said: A person came to him and said: Here is Ibn Hanzala who is making people swear allegiance to him. He (,Abdullah) asked: To what effect? He replied: To the effect that they will die for him. 'Abdullah said: I will never swear allegiance to this effect after the Messenger of Allah (may peace be upon him).

Chapter 19 : IT IS FORBIDDEN TO A MUHAJIR TO RETURN TO HIS NATIVE PLACE FOR THE PURPOSE OF RESETTLING THERE

Book 20, Number 4593:

    It has been narrated by Salama b. al-Akwa' that he visited al-Hajjaj who said to him: O son of al-Akwa', you have turned apostate and have come to live again in the desert with the Bedouins (after your migration). He said: No, but the Messenger of Allah (may peace be upon him) has permitted me to live in the desert.

Chapter 20 : NO MIGRATION AFTER THE CONQUEST OF MECCA BUT ALLEGIANCE COULD BE SWORN (TO A RIGHTFUL LEADER) ON SERVING THE CAUSE OF ISLAM, ON FIGHTING IN THE WAY OF ALLAH AND ON FOLLOWING THE PATH OF VIRTUE

Book 20, Number 4594:

    It has been reported on the authority of Mujashi' b. Mas'ud as-Sulami who said: I came to the Holy Prophet (may peace be upon him) to offer him my pledge of migration. He said: The period of migration has expired (and those who wereto get the reward for this great act of devotion have got it). You may now give your pledge to serve the cause of Islam, to strive in the way of Allah and to follow the path of virtue.

Book 20, Number 4595:

    It has been reported on the authority of Mujashi' b. Mas'ud who said: I brought my brother Abu Ma'bad to the Messenger of Allah (may peace he upon him) after the conquest of Mecca and said: Messenger of Allah, allow him to swear his pledge of migration at your hand. He said: The period of migration is over with those who had to do it (and now nobody can get this meritorious distinctions) I said: For what actions will you allow him to bind himself in oath? He said: (He can do so) for serving the cause of Islam, for fighting in the way of Allah and for fighting in the cause of virtue. Abd Uthman said: I met Abd Ma'bad and told him what I had heard from Mujashi'. He said: He has told the truth.

Book 20, Number 4596:

    Another version of the tradition transmitted on the authority of Asim has the same wording but does not mention the name of Abu Ma'bad.

Book 20, Number 4597:

    It has been narrated on the authority of Ibn 'Abbas that the Messenger of Allah (may peace be upon him) said on the day of the Conquest of Mecca: There is no Hijra now, but (only) Jihad (fighting for the cause of Islam) and sincerity of purpose (have great reward); when you are asked to set out (on an expedition undertaken for the cause of Islam) you should (readily) do so.

Book 20, Number 4598:

    The above tradition has been handed down through a different chain of transmitters.

Book 20, Number 4599:

    'A'isha reported that the Messenger of Allah (may peace be upon him) was asked about migration, whereupon he said: There is no migration after the Conquest (of Mecca), but Jihad and sincere intention. When you are asked to set out (for the cause of Islam), you should set out,

Book 20, Number 4600:

    It has been narrated on the authority of Abu Sa'id al-Khudari that a Bedouin asked the Messenger of Allah (may peace be upon him) about Migration. He replied: Do you talk of Hijra? The affair of Hijra is very difficult. But have you got camels? The bedouin said: Yes. He asked: Do you pay the poor-rate payable on their account? He replied: Yes. He (the Holy Prophet) said: Go on doing good deeds (across the seas), for surely God will not leave any of your deeds unrewarded.

Book 20, Number 4601:

    This tradition has been handed down through a different chain of transmitter with the addition of the following words at the end: "Do you milk them on the day they arrive at the water? He replied: Yes."

Chapter 21 : HOW THE WOMEN SWORE FEALTY (TO THE HOLY PROPHET)

Book 20, Number 4602:

    It has been narrated on the authority of 'A'isha, the wife of the Holy Prophet (may peace be upon him). She said: When the believing women migrated (to Medina) and came to the Messenger of Allah (may peace be upon him), they would be tested in accordance with the following words of Allah. the Almighty and Exalted: "O Prophet, when believing women come to thee to take the oath of fealty to thee that they will not associate in worship anything with God, that they will not steal. that, they will not commit adultery. . ." to the end of the verse (lx. 62).
    Whoso from the believing women accepted these conditions and agreed to abide by them were considered to have offered themselves for swearing fealty. When they had (formally) declared their resolve to do so, the Messenger of Allah (may peace he upon him) would say to them: You may go. I have confirmed your fealty. By God, the hand of the Messenger of Allah (may peace be upon him) never touched the hand of a woman. He would take the oath of fealty from them by oral declaration. By God, the Messenger of Allah (may peace be upon him) never took any vow from women except that which God had ordered him to take, and his palm never touched the palm of a woman. When he had taken their vow, he would tell them that he had taken the oath from them orally.

Book 20, Number 4603:

    It has been narrated on the authority of 'Urwa that 'A'isha described to him the way the Holy Prophet (may peace be upon him) took the oath of fealty from women. She said: The Messenger of Allah (may peace be upon him) never touched a woman with his hand. He would only take a vow from her and when he had taken the (verbal) vow, he would say: You may go. I have accepted your fealty.

Chapter 22 : SWEARING FEALTY FOR LISTENING TO AND OBEYING THE ORDERS OF THE LEADER AS FAR AS POSSIBLE

Book 20, Number 4604:

    It has been narrated on the authority of Abdullah b. 'Umar who said: We used to take oath to the Messenger of Allah (may peace be upon him) that we would listen to and obey his orders. He would tell us (to say in the oath): As far as it lies in my power.

Chapter 23 : THE AGE OF MAJORITY

Book 20, Number 4605:

    It has been narrated on the authority of Ibn 'Umar who said: The Messenger of Allah (may peace be upon him) inspected me on the battlefield on the Day of Uhud, and I was fourteen years old. He did not allow me (to take part in the fight). He inspected me on the Day of Khandaq-and I was fifteen yearsold, and he permitted me (to fight), Nafi' said: I came to 'Umar b. 'Abd al-'Aziz who was then Caliph, and narrated this tradition to him. He said: Surely, this is the demarcation between a minor and a major. So he wrote to his governors that they should pay subsistence allowance to one who was fifteen years old, but should treat those of lesser age among children.

Book 20, Number 4606:

    This tradition has been handed down through a different chain Of transmitters with the following change in the wording: "I was fourteen years old and he thought me too young (to participate in the fight)."

Chapter 24 : IT IS FORBIDDEN TO TAKE THE QUR'AN TO THE LAND OF THE INFIDELS WHEN IT IS FEARED THAT IT MIGHT FALL INTO THEIR HANDS

Book 20, Number 4607:

    It has been narrated on the authority of Ibn 'Umar who said: The Messenger of Allah (may peace be upon him) forbade that one should travel to the land of the enemy taking the Qur'an with him.

Book 20, Number 4608:

    It has been narrated on the authority of Abdullah b. Umar that the Messenger of Allah (may peace be upon him) used to forbid that one should travel to the land of the enemy taking the Qur'an (with him) lest it should fall into the hands of the enemy.

Book 20, Number 4609:

    It has been narrated on the authority of Ibn 'Umar that the Messenger of Allah (may peace be upon him) said: Do not take the Qur'an on a journey with you, for I am afraid lost it should fall into the hands of the enemy. Ayyub (one of the narrators in the chain of transmitters) said: The enemy may seize it and may quarrel with you over it.

Chapter 25 : RACE BETWEEN HORSES AND THEIR TRAINING FOR THE COMPETITION

Book 20, Number 4610:

    It has been narrated on the authority of Ibn 'Umar that the Messenger of Allah (may peace be upon him) had a race of the horses which had been especially prepared for the purpose from Hafya' to Thaniyyat al-Wada' (the latter being the winning post), and of those which had not been trained from Thaniyya to the mosque of Banu Zuraiq, and Ibn Umar was among those who took part in this race.

Book 20, Number 4611:

    This tradition has been handed down through another chain of transmitters with the addition of the following words from Abdullah b. 'Umar :"I came first in the race and my horse jumped into the mosque with me."

Chapter 26 : GREAT BENEFIT IN THE FORELOCKS OF THE HORSES

Book 20, Number 4612:

    It has been narrated on the authority of Ibn Umar that the Messenger of Allah (may peace be upon him) said: There will be great benefit in the forelock of the horses until the Day of judgment.

Book 20, Number 4613:

    The same tradition has been handed down through a different chain of transmitters.

Book 20, Number 4614:

    It has been narrated on the authority of Jarir b. Abdullah who said: I saw that the Messenger of Allah (may peace be upon him) was twisting the forelock of a horse with his fingers and he was saying: (A great) benefit. i.e. reward (for rearing them for Jihad) and spoils of war, has been tied to the forelocks of horses until the Day of Judgment.

Book 20, Number 4615:

    The above tradition has also been narrated on the authority of Yunus through a different chain of transmitters.

Book 20, Number 4616:

    The same tradition has been narrated on the authority of Urwat al-Bariqi who said that the Prophet (may peace be upon him) said: Great good is attached to the forelock of the horses until the Day of Judgment.

Book 20, Number 4617:

    'Urwat al-Bariqi reported Allah's Messenger (may peace be upon him) having said this: Good is tied to the forelock of the horses. It Was said to him: Messenger of Allah, why is it so? He (the Holy Prophet said): For reward and booty until the Day of Judgment.

Book 20, Number 4618:

    This hadith has been narrated with the same chain of transmitters with the difference that here instead of "Urwat al-Bariqi" there is "Urwa b. ja'd."

Book 20, Number 4619:

    A version of the tradition narrated on the authority of 'Urwat al-Bariqi does not mention (the words): "reward and booty".

Book 20, Number 4620:

    A version of the tradition transmitted on the authority of 'Urwa b. al-ja'd does not mention "reward and booty".

Book 20, Number 4621:

    It has been narrated on the authority of Anas b. Malik that the Messenger of Allah (may peace be upon him) said: There is a blessing in the forelocks of the war horses.

Book 20, Number 4622:

    A hadith like this has been narrated on the authority of Anas through another chain of transmitters.

Chapter 27 : THE HORSES OF UNDESIRABLE QUALITY

Book 20, Number 4623:

    It has been narrated on the authority of Abn Huraira that the Messenger of Allah (may peace be upon him) used to dislike the Shikal horse.

Book 20, Number 4624:

    This tradition has been narrated on the authority of Sufyan with the addition from Abd ar-Razzaq (one of the narrators) explaining the meaning of shikal as a bone whose right back foot and left front foot or left back foot and right front foot are white.

Book 20, Number 4625:

    The tradition has been handed down through a different chain of transmitters.

Chapter 28 : THE MERIT OF JIHAD AND CAMPAIGNING IN THE WAY OF ALLAH

Book 20, Number 4626:

    It has been narrated on the authority of Abu Huraira that the Messenger of Allah (may peace upon him) said: Allah has undertaken to look after the affairs of one who goes out to fight in His way believing in Him and affirming the truth of His Apostles. He is committed to His care that Re will either admit him to Paradise or bring him back to his home from where he set out with a reward or (his share of) booty. By the Being in Whose Hand is the life of Muhammad. If a person gets wounded in the way of Allah, he will come on the Day of Judgment with his wound in the same condition as it was when it was first inflicted; its colour being the colour of blood but its smell will be the smell of musk. By, the Being in Whose Hand is Muhammad's life, if it were not to be too hard upon the Muslime. I would not lag behind any expedition which is going to fight in the cause of Allah. But I do not have abundant means to provide them (the Mujahids) with riding beasts, nor have they (i.e. all of them) abundant means (to provide themselves with all the means of Jihad) so that they could he left behind. By the Being in Whose Hand is Mubammgls lac, I love to fight in the way of Allah and be killed, to fight and again be killed and to fight again and be killed.

Book 20, Number 4627:

    The same tradition has been melted through another chain of transmitters.

Book 20, Number 4628:

    It has been narrated on the authority of Abu Huraira who said: Allah has undertaken to provide for one who leaves his home (only) to fight for His cause and to affirm the truth of His word; Allah will either admit him to Paradise or will bring him back home from where he had come out, with his reward and booty.

Book 20, Number 4629:

    It has been narrated on the authority of Abu Huraira that the Messenger of Allah (may peace be upon him) said: One who is wounded in the way of Allah-and Allah knows better who is wounded in His way-will appear on the Day of Judgment with his wound bleediing. The colour (of its discharge) will be the colour of blood, (but) its smell will be the smell of musk.

Book 20, Number 4630:

    It has been narrated on the authority of Abu Haraira that the Messenger of Allah (may peace be upon him) said: Every wound received by a Muslim in the way of Allah will appear on the Day of Judgment in the same condition as it was when it was inflicted, and would be bleeding profusely. The colour (of its discharge) will be the colour of blood, but its smell will be the smell of musk. By the Being in Whose Hand is Muhammad's life, if it were not hard upon the Muslims, I would not lag behind any expedition undertaken for Jihad, but I do not possess abundant means to provide the Mujahids with riding animals, nor do they (i.e. all of them) have abundant means (to provide themselves with all the means of Jihad) to follow me, nor would it please their hearts to stay behind me.

Book 20, Number 4631:

    It has been narrated on the authority of Abu Huraira who said: I heard the Messenger of Allah (may peace be upon him) say: I would not stay behind (when) an expedition (for Jihad was being mobilised) if it were going to be too hard upon the believers. . . . This is followed by the same words as have appeared in the previous tradition, but this tradition has the same ending as the previous hadith with a slight difference in the wording: "By the Being in Whose Hand is my life, I love that I should be killed in the way of Allah; then I should be brought back to life and be killed again in His way. . . . "

Book 20, Number 4632:

    It has been narrated on the authority of Abu Huraira that the Messenger of Allah (may peace be upon him) said: If it were not hard upon my Umma (to follow my example), I would not lag behind any expedition-as in the traditions gone before.

Book 20, Number 4633:

    Another version of the tradition narrated through a different chain of transmitters on the authority of Abu Huraira has the same wording as the previous tradition:"Allah takes care of one who goes out in the way of Allah" but ends in the words:"I would not lag behind any expedition which is undertaken to fight in the way of Allah, the Exalted."

Chapter 29 : THE MERIT OF MARTYRDOM

Book 20, Number 4634:

    It has been narrated on the authority of Anas b. Malik that the Messenger of Allah (may peace be upon him) said :"Nobody who dies and has something good for him with Allah will (ever like to) return to this world even though he were offered the whole world and all that is in its (as an inducement), except the martyr who desires to return and be killed in the world for the (great) merit of martyrdom that he has seen.

Book 20, Number 4635:

    It has been narrated on the authority of Anas b. Malik (through a different chain of transmitters) that the Messenger of Allah (may peace be upon him) said: Nobody who enters Paradise will (ever like to) return to this world even if he were offered everything on the surface of the earth (as an inducement) except the martyr who will desire to return to this world and be killed ten times for the sake of the great honour that has been bestowed upon him.

Book 20, Number 4636:

    It has been narrated on the authority of Abu Huraira who said: The Messenger of Allah (may peace be upon him) was asked: What deed could be an equivalent of Jihad in the way of Allah, the Almighty and Exalted? He answered: You do not have the strength to do that deed. The narrator said : They repeated the question twice or thrice. Every time he answered: You do not have the strength to do it. When the question was asked for the third time, he said: One who goes out for Jibad is like a person who keeps fasts, stands in prayer (constantly), (obeying) Allah's (behests contained in) the verses (of the Qur'an), and does not exhibit any lassitude in fasting and prayer until the Mujihid returns from Jihad in the way of Allah, the Exalted.

Book 20, Number 4637:

    This tradition has been handed down through a different chain of transmitters.

Book 20, Number 4638:

    It has been narrated on the authority of Nu'man b. Bashir who said: As I was (sitting) near the pulpit of the Messenger of Allah (may peace be upon him), a man said: I do not care if, after embracing Islam, I do not do any good deed (except) distributing drinking water among the pilgrims. Another said: I do not care if, after embracing Islam, I do not do any good deed beyond maintenance service to the Sacred Mosque. Another said: Jihad in the way of Allah is better than what you have said. 'Umar reprimanded them and said: Don't raise your voices near the pulpit of the Messenger of Allah (may peace be upon him) on Friday. When prayer was over, I entered (the apartment of the Holy Prophet) and asked his verdict about the matter in which they had differed. (It was upon this that) Allah, the Almighty and Exalted, revealed the Qur'anic verse: "Do you make the giving of drinking water to the pilgrims and the maintenance of the Sacred Mosque equal to (the service of those) who believe in Allah and the Last Day and strive hard in the cause of Allah. They are not equal in the sight of God. And Allah guides not the wrongdoing people" (ix. 20). This tradition has been narrated on the authority of Nu'man b. Bashir through another chain of transmitters.

Chapter 30 : MERIT OF LEAVING FOR JIHAD IN THE MORNING AND EVENING

Book 20, Number 4639:

    It has been narrated on the authority of Anas b. Malik that the Messenger of Allah (may peace be upon him) said: Leaving (for Jihad) in the way of Allah in the morning or in the evening (will merit a reward) better than the world and all that is in it.

Book 20, Number 4640:

    It has been narrated on the authority of Sahl b. Sa'd as-Sa'idi that the Messenger of Allah (may peace be upon him) said: The journey undertaken by a person in the morning (for Jihad) in the way of Allah (will merit a reward) better than the world and all that is in it.

Book 20, Number 4641:

    It has been narrated on the authority of Sahl b. Sa'd as-Sa'idi that the Messenger of Allah (may peace be upon him) said: A journey undertaken in the morning or evening (fond Jihad) in the way of Allah (will merit a reward) better than the world and all that is in it.

Book 20, Number 4642:

    It has been narrated on the authority of Abu Huraira that the Messenger of Allah (may peace be upon him) said: If some persons of my Umma (were not to undertake the hardships of Jihad), and he (Abu Huraira) then narrated the rest of the hadith and then said: A journey undertaken for jihad in the evening or morning merits a reward better than the world and all that is in it.

Book 20, Number 4643:

    It has been narrated on the authority of Abu Ayyub that the Messenger of Allah (may peace be upon him) said: A journey undertaken in the morning or evening (for Jihad) in the way of Allah is better than (anything) on which the sun rises or sets.

Book 20, Number 4644:

    This tradition has been narrated on the authority of Abu Ayyub through a different chain of transmitters having the same wording.

Chapter 31 : THE HIGH POSITION RESERVED BY GOD FOR MUJAHIDS IN PARADISE

Book 20, Number 4645:

    It has been narrated on the authority of Abu Sa'id Khudri that the Messenger of Allah (may peace be upon him) said (to him): Abu Sa'id, whoever cheerfully accepts Allah as his Lord, Islam as his religion and Mubammad as his Apostle is necessarily entitled to enter Paradise. He (Abu Sa'id) wondered at it and said: Messenger of Allah, repeat it for me. He (the Messenger of Allah) did that and said: There is another act which elevates the position of a man in Paradise to a grade one hundred (higher), and the elevation between one grade and the other is equal to the height of the heaven from the earth. He (Abu Sa'id) said: What is that act ? He replied: Jihad in the way of Allah ! Jihad in the way of Allah !

Chapter 32 : ONE WHO IS KILLED IN THE WAY OF ALLAH WILL HAVE ALL HIS SINS BLOTTED OUT EXCEPF DEBT

Book 20, Number 4646:

    It has been narrated on the authority of Abu Qatada that the Messenger of Allah (may peace be upon him) stood up among them (his Companions) to deliver his sermon in which he told them that Jihad in the way of Allah and belief in Allah (with all His Attributes) are the most meritorious of acts. A man stood up and said: Messenger of Allah, do you think that if I am killed in the way of Allah, my sins will be blotted out from me? The Messenger of Allah (may peace be upon him) said: Yes, in case you are killed in the way of Allah and you were patient and sincere and you always fought facing the enemy, never turming your back upon him. Then he added: What have you said (now)? (Wishing to have further assurance from him for his satisfaction), he asked (again): Do you think if I am killed in the way of Allah, all my sins will be obliterated from me? The Messenger of Allah (may peace be upon him) said: Yes, it you were patient and sincere and always fought facing the enemy and never turning your back upon him, (all your lapses would be forgiven) except debt. Gabriel has told me this.

Book 20, Number 4647:

    The tradition has been narrated through a different chain of transmitters on the authority of Abu Qatada who said: A man came to the Messenger of Allah (may peace be upon him) while he was on the pulpit and said: Do you think if I am killed in the way of Allah ... (except this difference in its beginning, the rest of the tradition is the same as the previous one).

Book 20, Number 4648:

    Another version of the tradition differently transmitted begins with the words: "A man came to the Messenger of Allah (may peace be upon him) and he was sitting on the pulpit.... He said: What do you find if I strike with the sword?" (The rest of the tradition is the same as the previous one.)

Book 20, Number 4649:

    It has been reported on the authority of 'Amr b. al-'As that the Messenger of Allah (may peace be upon him) said: All the sins of a Shahid (martyr) are forgiven except debt.

Book 20, Number 4650:

    It has been reported on the authority of Amr b. al-'As through a different chain of transmitters that the Messenger of Allah (may peace be upon him) said: Death in the way of Allah blots out everything except debt.

Chapter 33 : THE SOULS OF THE MARTYRS ARE IN PARADISE; THEY ARE ALIVE AND FIND THEIR SUSTENANCE FROM THEIR LORD

Book 20, Number 4651:

    It has been narrated on the authority of Masruq Who said: We asked 'Abdullah about the Qur'anic verse: "Think not of those who are slain in Allah's way as dead. Nay, they are alive, finding their sustenance in the presence of their Lord. ." (iii. 169). He said: We asked the meaning of the verse (from the Holy Prophet) who said: The souls, of the martyrs live in the bodies of green birds who have their nests in chandeliers hung from the throne of the Almighty. They eat the fruits of Paradise from wherever they like and then nestle in these chandeliers. Once their Lord cast a glance at them and said: Do ye want anything? They said: What more shall we desire? We eat the fruit of Paradise from wherever we like. Their Lord asked them the same question thrice. When they saw that they will continue to be asked and not left (without answering the question). they said: O Lord, we wish that Thou mayest return our souls to our bodies so that we may be slain in Thy way once again. When He (Allah) saw that they had no need, they were left (to their joy in heaven).

Chapter 34 : MERIT OF JIHADAND OF KEEPING VIGILANCE (OVER THE ENEMY)

Book 20, Number 4652:

    It has been narrated on the authority of Abu Sa'id Khudri that a man came to the Holy Prophet (may peace he upon him) and said: Who is the best of men? He replied: A man who fights in the way of Allah spending his wealth and staking his life. The man then asked: Who is next to him (in excellence)? He said: Next to him is a believer who lives in a mountain gorge worshipping hid Lord and sparing men from his mischief.

Book 20, Number 4653:

    It has been narrated (through a diferent chain of transmetters) on the same authority (i.e. Abu Sa'id Khadri) who said: A man asked: Messenger of Allah, which of men is the best? He said : A believer who fights staking his life and spending his wealth in the way of Allah. He asked: Who is next to him (in excellence) ? He said: Next to him is a man who lives an isolated life in a mountain gorge, worshipping his Lord and sparing men from his mischief.

Book 20, Number 4654:

    A version of the tradition narrated on the authority of Ibn Shihab has a little differently worded ending. i.e. "A man in a mountain valley." but did not mention "next to him a man who...."

Book 20, Number 4655:

    It has been narrated on the authority of Abu Huraira that the Messenger of Allah (may peace be upon him) said: Of the men he lives the best life who holds the reins of his horse (ever ready to march) in the way of Allah, flies on its back whenever he hears a fearful shriek, or a call for help, flies to it seeking death at places where it can be expected. (Next to him) is a man who lives with his sheep at a hill-top or in a valley, says his prayers regularly, gives Zakat and worships his Lord until death comes to him. There is no better person among men except these two.

Book 20, Number 4656:

    This hadith has been transmitted on the authority of Abu Huraira with a slight variation of wording.

Book 20, Number 4657:

    Two more versions of the tradition narrated by 'Abdullah b. Badr and Abu Huraira, respectively, have been handed down through different chains of transmitters with negligible difference in the wording.

Chapter 35 : THE TWO MEN, BOTH OF WHOM WILL ENTER PARADISE THOUGH ONE OF THEM SLAYS THE OTHER

Book 20, Number 4658:

    It has been narrated on the authority of Abu Huraira that the Messenger of Allah (may peace be upon him) said: God laughs at the two men both of whom will enter Paradise (though) one of them kills the other. They said: Messenger of Allah, how is it? He said: One of them fights in the way of Allah, the Almighty and Exalted. and dies a martyr. Then God turns in mercy to the murderer who embraces Islam, fights in the way of Allah, the Almighty and Exalted, and dies a martyr.

Book 20, Number 4659:

    The same tradition has been narrated on the authority of Abu Zinad (with the same chain of transmitters).

Book 20, Number 4660:

    It has been reported on the authority of Abu Huraira that the Messenger of Allah (may peace be upon him) said: God laughs at the two men one of whom kills the other; both of them will enter Paradise. They (the Companions) said: How, Messenger of Allah? He said: One is slain (in the way of Allah) and enters Paradise. Then God forgives the other and guides him to Islam; then he fights in the way of Allah and dies a martyr.

Chapter 36 : ABOUT A MAN WHO KILLED A DISBELIEVER AND EMBRACED ISLAM

Book 20, Number 4661:

    It has been narrated on the authority of Abu Huraira that the Messenger Allah (may peace be upon him) said: A disbeliever and a believer who killed him will never be gathered together in Hell.

Book 20, Number 4662:

    It has been narrated on the authority of Abu Huraira that the Messenger of Allah (may peace be upon him) said: No two such persons shall be together in Hell as if one of them is such that his presence hurts the other. It was asked: Messenger of Allah, who are they? He said: A believer who killed a disbeliever and (then) kept to the right path."

Chapter 37 : THE EXCELLENCE OF CHARITY IN THE WAY OF ALLAH AND ITS MANIFOLD REWARD

Book 20, Number 4663:

    It has been narrated on the authority of Abu Mas'ud al-Ansari who said A man brought a muzzled she-camel and said: It is (offered) in the way of Allah. The Messenger of Allah (may peace be upon him) said: For this you will have seven hundred she-camels on the Day of Judgment all of which will be muzzled.

Book 20, Number 4664:

    A similar tradition has been narrated on the authority of al-A'mash.

Chapter 38 : THE MERIT OF HELPING THE WARRIOR (FIGHTING IN THE WAY OF ALLAH) WITH SOMETHING TO RIDE UPOW AND LOOKING AFTER HIS FAMILY IN HIS ABSENCE

Book 20, Number 4665:

    It has been narrated on the authority of Abu Mas'ud al-Ansari who said: A man came to the Messenger of Allah (may peace be upon him) and said: My riding beast has been killed, so give me some animal to ride upon. He (the Holy Prophet) said: I have none with me. A man said: Messenger of Allah, I can guide him to one who will provide him with a riding beast. The Messenger of Allah (may peace be upon him) said: One who guides to something good has a reward similar to that of its doer.

Book 20, Number 4666:

    The above tradition has been handed down through a different chain of transmitters.

Book 20, Number 4667:

    It has been narrated on the authority of Anas b. Malik that a young man from Aslam tribe said: Messenger of Allah, I wish to fight (in the way of Allah) but I don't have anything to equip myself with for fighting. He (the Holy Prophet) said: Go to so and so, for he had equipped himself (for fighting) but he fell ill. So, he (the young man) went to him and said: The Messenger of Allah (may peace be upon him) sends you his greetings and says that you should give me the equipage that you have provided yourself with. The man said (to his wife or maidservant): So and so, give him the equipage I have collected for myself and do not withhold anything from him. Do not withhold anything from him so that you may be blessed therein.

Book 20, Number 4668:

    It has been narrated on the authority of Zaid b. Kbalid al-Juhani that the Messenger of Allah (may peace be upon him) said: Anybody who equips a warrior (going to fight) in the way of Allah (is like one who actually) fights. And anybody who looks well after his family in his absence (is also like one who actually) fights.

Book 20, Number 4669:

    The above tradition has been narrated on the authority of Khalid al- Juhani who said: The Prophet of Allah (may peace be upon him) said: He who equips a warrior in the way of Allah (is like one who dctually fights) aud he who looks after the family of a warrior in the way of Allah in fact participated in the battle.

Book 20, Number 4670:

    It has been narrated on the authority of Abu Sa'id Khudri that the Messenger of Allah (may peace be upon him) sent a force to Banu Lihyan (who are from Banu Hudhail, and said: One man from every two and the reward (will be divided) between the two.

Book 20, Number 4671:

    The above tradition has also been narrated through two different chains of transmitters on the authority of Abu Sa'id Khudri and Yahya, respectively.

Book 20, Number 4672:

    It has been narrated (through a still different chain of transmitters) on the authority of Abu Sa'id Khudrl that the Messenger of Allah (may peace be upon him) despatched a force to Banu Lihyan. (and said:) One man from every two should join the force. Then he said to those who stayed behind: Those of you who will look well after the family and wealth of those who are going on the expedition will be getting half the reward of the warriors.

Chapter 39 : THE WIVES OF MUJAHIDS, A SACRED TRUST, AND SINFULNESS OF THOSE WHO BETRAY THIS TRUST

Book 20, Number 4673:

    It has been narrated on the authority of Sulaimin b. Buraida who learnt the tradition from his father. The latter said that the Messenger of Allah (may peace be upon him) said: The sanctity of the wives of Mujahids is like the sanctity of their mothers for those who sit at home (i.e do not go out for Jihad). Anyone who stays behind looking after the family of a Mujahid and betrays his trust will be made to stand on the Day of judgment before the Mujahid who will take away from his meritorious deeds whatever he likes. So what do you think (will he leave anything)?

Book 20, Number 4674:

    This tradition has been narrated by the same authority through different chain of transmitters.

Book 20, Number 4675:

    A version of the tradition narrated on the authority of 'Alqama b. Murthad has a differently worded end: It will be said to the Mujahid: Take from his noble deeds whatever you like. Then the Messenger of Allah (may peace be upon him) turned to us and asked: What do you think (will he leave anything)?-(i.e. he will take away everything).

Chapter 40 : JIHAD NOT COMPULSORY FOR THOSE WHO HAVE A GENUINE EXCUSE

Book 20, Number 4676:

    It has been narrated on the authority of Abu Ishaq, that he heard Bara' talking about the Qur'anic verse: "Those who sit (at home) from among the believers and those who go out for Jihad in the way of Allah are not aqual" (iv. 95). (He said that) the Messenger of Allah (may peace be upon him) ordered Zaid (to write the verse). He brought a shoulder-blade (of a slaughtered camel) and inscribed it (the verse) thereon. The son of Umm Maktum complained of his blindness to the Holy Prophet (may peace be upon him). (At this) descended the revelation: "Those of the believers who sit (at home) without any trouble (illness, incapacity, disability)" (iv. 95). The tradition has been handed down through two other chains of transmitters.

Book 20, Number 4677:

    It has been narrated on the authority of Bara' who said: When the Qur'anic verse: "Those who sit (at home) from among mu'min" (iv. 94) was revealed, the son of Umm Maktum spoke to him (the Holy Prophet). (At this). the words: "other than those who have a trouble (illness)" were revealed.

Chapter 41 : IN PROOF OF THE MARTYR'S ATTAINING PARADISE

Book 20, Number 4678:

    It has been reported on the authority of Jabir that a man said: Messenger of Allah, where shall I be if I am killed? He replied: In Paradise. The man threw away the dates he had in his hand and fought until he was killed (i.e. he did not wait until he could finish the dates).
    In the version of the tradition narrated by Suwaid we have the words: "A man said to the Holy Prophet (may peace be upon him). on the day of Uhud......"

Book 20, Number 4679:

    It has been reported on the authority of Bara!' who stated: A man from Banu Nabit (one of the Ansar tribes) came to the Holy Prophet (may peace be upon him) and said: I testify that there is no god except Allah and that thou art His bondman and Messenger. Then he went forward and fought until he was killed. The Holy Prophet (may peace be upon him) said: He has done a little but shall be given a great reward.

Book 20, Number 4680:

    It has been reported on the authority of Anas b. Malik who said: The Messenger of Allah (may peace be upon him) sent Busaisah as a scout to see what the caravan of Abu Sufyan was doing. He came (back and met the Holy Prophet in his house) where there was nobody except myself and the Messenger of Allah. I do not remember whether he (Hadrat Anas) made an exception of some wives of the Holy Prophet (may peace be upon him)or not and told him the news of the caravan. (Having heard the news), the Messenger of Allah (may peace be upon him) came out (hurriedly), spoke to the people and said: We are in need (of men); whoever has an animal to ride upon ready with him should ride with us. People began to ask him permission for bringing their riding animals which were grazing on the hillocks near Medina. He said : No. (I want) only those who have their riding animals ready. So the Messenger of Allah (may peace be upon him) and his Companions proceeded towards Badr and reached there forestalling the polytheists (of Mecca). When the polytheists (also) reached there, the Messenger of Allah (may peace be upon him) said: None of you should step forward to (do) anything unless I am ahead of him. The polytheists (now) advanced (towards us), and the Messenger of Allah (may peace be upon him) said . Get up to enter Paradise which is equal in width to the heavens and the earth. 'Umair b. al- Humam al-Ansari said: Messenger of Allah, is Paradise equal in extent to the heavens and the earth? He said: Yes. 'Umair said: My goodness ! The Messenger of Allah (may peace be upon him) asked him: What prompted you to utter these words (i.e. my goodness !') ? He said: Messenger of Allah, nothing but the desire that I be among its residents. He said: Thou art (surely) amona its residents. He took out dates from his bag and began to eat them. Then he said: If I were to live until I have eaten all these dates of mine, it would be a long life. (The narrator said): He threw away all the dates he had with him. Then he fought the enemies until he was killed.

Book 20, Number 4681:

    The tradition has been narrated on the authority of 'Abdullah b. Qais. He heard it from his father who, while facing the enemy, reported that the Messenger of Allah (may peace be upon him) said: Surely, the gates of Paradise are under the shadows of the swords. A man in a shabby condition got up and said; Abu Musa, did you hear the Messenger of Allah (may peace be upon him) say this? He said: Yes. (The narrator said): He returned to his friends and said: I greet you (a farewell greeting). Then he broke the sheath of his sword, threw it away, advanced with his (naked) sword towards the enemy and fought (them) with it until he was slain.

Book 20, Number 4682:

    It has been reported on the authority of Anas b. Malik that some people came to the Messenger of Allah (may peace be upon him) and said to him: Send with us some men who may teach us the Qur'an and the Sunnah. Accordingjy, he sent seventy men from the Ansar. They were called the Reciters and among them was my maternal uncle. Haram. They used to recite the Qur'an, discuss and ponder over its meaning at night. In the day they brought water and poured it (in pitchers) in the mosque, collected wood and sold it, and with the sale proceeds bought food for the people of the Suffa and the needy. The Holy Prophet (may peace be upon him) sent the Reciters with these people, but these (treacherous people) fell upon them and killed thern before they reached their destination (While dying), they said: O Allah, convey from us the news to our Prophet that we have met Thee (in a way) that we are pleased with Thee and Thou art pleased with us. (The narrator said): A man attacked Haram (maternal uncle of Anas)) from behind and smote him with a spear which pierced him. (While dying), Haram said: By the Lord of the Ka'ba, I have met with success. The Messenger of Allah (may peace be upon him) said to his Companions: Your brethren have been slain grid they were saying: O Allah, convey from us to our Prophet the news that we have met Thee in a way that we are pleased with Thee and Thou art pleased with us.

Book 20, Number 4683:

    It has been Deported on the authority of Anas who said: My uncle and I have been named after him was not present with the Messenger of Allah (mav peace be upon him) on the Day of Badr. He felt distressed about it. He would say: I have missed the first battle fought by the Messenger of Allah (may peace be upon him), and if God now gives me an opportunity to see a battlefield with the Messenger of Allah (may peace be upon him), God will see what I do therein. He was afraid to say more than this (lest he be unable to keep his word with God). He was present with the Messenger of Allah (may peace be upon him) on the Day of Uhud. He met Sa'd b. Mu'adh (who was retreating). Anas said to him: O Abu 'Amr, where (are you going)?Woe (to thee) ! I find the smell of Paradise beside the Uhud mountain. (Reprimanding Sa'd in these words) he went forward and fought thein (the enemy) until he was killed. (The narrator says). More than eighty wounds inflicted with swords, spears and arrows were found on his body. His sister, my aunt, ar-Rubayyi', daughter of Nadr, said: I could not recognise my brother's body (it was so badly mutilated) except from his finger-tips. (It was on this occasion that) the Qur'anic verse: "Among the Believers are men who have been true to their covenant with God. Of them some have completed their vow (to the extreme), and some still wait: but they have never changed (their determination) in the least" (xxxiii. 23).
    The narrator said that the verse had been revealed about him (Anas b. Nadr) and his Companions.

Chapter 42 : ONE WHO FIGHTS THAT THE WORD OF ALLAH IS EXALTED FIGHTS IN THE WAY OF ALLAH

Book 20, Number 4684:

    It has been narrated on the authority of Abu Musa Ash'ari that a desert Arab came to the Holy Prophet (may peace be upon him) and said: Messenger of Allah, one man fights fgr the spoils of war; another fights that he may be remembered, and another fights that he may see his (high) position (achieved as a result of his valour in fighting). Which of these is fighting in the cause of God? The Messenger of Allah (may peace be upon him) said: Who fights so that the word of Allah is exalted is fighting in the way of Allah.

Book 20, Number 4685:

    It has been narrated (through another chain of transmitters) on the authority of Abu Musa who said. The Messenger of Allah (may peace be upon him) was asked which of the men fights in the way of Allah: (one who fights) for displaying his valour; (a man who) fights out of his family pride and (a man who) fights for the sake of show, who amongst these fights in the way of Allah? The Messenger of Allah (may peace be upon him) said: Who fights that the word of Allah be exalted fights in the way of Allah.

Book 20, Number 4686:

    It has been narrated (through yet another chain of transmitters) on the same authority, i.e. Abu Musa, who said: We, came to the Messenger of Allah (may peace be upon him) and said: Messenger of Allah, one of us hho fights to display his valour. . . (followed by the same words as we have in the previous tradition).

Book 20, Number 4687:

    It has been narrated through a different chain of transmitters on the same authority, i.e. Abu Musa Ash'ari, that a man asked the Messenger of Allah (may peace be upon him) about fighting in the way of Allah, the Exalted and Majestic, a man who fights out of rage or out of family pride. He raised his head towards him-and he did so because the man was standing and said: Who fights that the word of Allah be exalted fights in the way of Allah.

Chapter 43 : WHO FOUGHT FOR OSTENTATION AND VANITY DESERVED (PUNISHMENT IN) HELL

Book 20, Number 4688:

    It has been narrated on the authority of Sulaiman b. Yasar who said: People dispersed from around Abu Huraira, and Natil, who was from the Syrians. said to him: O Shaikh, relate (to us) a tradition you have heard from the Messenger of Allah (may peace be upon him). He said: Yes. I heard the Messenger of Allah (may peace be upon him) say: The first of men (whose case) will be decided on the Day of Judgment will be a man who died as a martyr. He shall be brought (before the Judgment Seat). Allah will make him recount His blessings (i.e. the blessings which He had bestowed upon him) and he will recount them (and admit having enjoyed them in his life). (Then) will Allah say: What did you do (to requite these blessings)? He will say: I fought for Thee until I died as a martyr. Allah will say: You have told a lie. You fought that you might be called a "brave warrior". And you were called so. (Then) orders will be passed against him and he will be dragged with his face downward and cast into Hell. Then will be brought forward a man who acquired knowledge and imparted it (to others) and recited the Qur'an. He will be brought And Allah will make him recount His blessings and he will recount them (and admit having enjoyed them in his lifetime). Then will Allah ask: What did you do (to requite these blessings)? He will say: I acquired knowledge and disseminated it and recited the Qur'an seeking Thy pleasure. Allah will say: You have told a lie. You acquired knowledge so that you might be called "a scholar," and you recited the Qur'an so that it might be said: "He is a Qari" and such has been said. Then orders will be passed against him and he shall be dragged with his face downward and cast into the Fire. Then will be brought a man whom Allah had made abundantly rich and had granted every kind of wealth. He will be brought and Allah will make him recount His blessings and he will recount them and (admit having enjoyed them in his lifetime). Allah will (then) ask: What have you done (to requite these blessings)? He will say: I spent money in every cause in which Thou wished that it should be spent. Allah will say: You are lying. You did (so) that it might be said about (You): "He is a generous fellow" and so it was said. Then will Allah pass orders and he will be dragged with his face downward and thrown into Hell.

Book 20, Number 4689:

    This tradition has been handed down through a different chain of transmitters.

Chapter 44 : THE REWARD OF ONE WHO FOUGHT AND GOT HIS SHARE OF THE BOOTY AND OF ONE (WHO FOUGHT) BUT DID NOT GET ANY BOOTY

Book 20, Number 4690:

    It has been narrated on the authority of 'Abdullah b. 'Amr that the Messenger of Allah (may peace be upon him) said: A troop of soldiers who fight in tile way of Allah and get their share of the booty receive in advance two-thirds of their reward in the Hereafter and only one-third will remain (to their credit). If they do not receive any booty, they will get their full reward.

Book 20, Number 4691:

    It has been narrated on the authority of Abdullah b. Amr (through a different chain of transmitters) that the Messenger of Allah (may peace be upon him) said: A troop of soldiers, large or small, who fight (in the way of Allah), get their share of the booty and return safe and sound, receive in advance two-thirds of their reward (only one-third remaining to their credit to be received in the Hereafter); and a troop of soldiers, large or small, who return empty-handed and are afflicted or wounded, will receive their full reward (in the Hereafter).

Chapter 45 : THE VALUE OF AN ACTION DEPENDS ON THE INTENTION BEHIND IT

Book 20, Number 4692:

    It has been narrated on the authority of Umar b. al-Khattab that the Messenger of Allah (may peace be upon him) said: (The value of) an action depends on the intention behind it. A man will be rewarded only for what he intended. The emigration of one who emigrates for the sake of Allah and His Messenger (may peace be upon him) is for the sake of Allah and His Messenger (may peace be upon him); and the emigration of one who emigrates for gaining a worldly advantage or for marrying a woman is for what he has emigrated.

Book 20, Number 4693:

    It has been narrated through a different chain of transmitters on the authority of Sufyan who said that he heard 'Umar b. al-Khattab relate (this tradition) from the Holy Prophet (may peace be upon him) while he was delivering a sermon from the pulpit.

Chapter 46 : DESIRABILITY OF SEEKING MARTYRDOM

Book 20, Number 4694:

    It has been narrated on the authority of Anas b. Malik that the Messenger of Allah (may peace he upon him) said: Who seeks martyrdom with sincerity shall get its reward, though he may not achieve it.

Book 20, Number 4695:

    It has been reported on the authority of Sahl b. Aba Umama b. Sahl b. Hunaif who learned the tradition from his father who (in turn) learned it from his grandfather-that the Messenger of Allah (may peace be upon him) said: Who sought martyrdom with sincerity will be ranked by Allah among the martyrs even if he died on his bed. In his version of the tradition Abd Tahir did not mention the words: "with sincerity".

Chapter 47 : DENUNCIATION OF ONE WHO DIED BUT NEVER FOUGHT IN THE WAY OF ALLAH NOR DID HE EVER EXPRESS A DESIRE OR DETERMINATION FOR JIHAD

Book 20, Number 4696:

    It has been narrated on the authority of Abu Huraira that the Messenger of Allah (may peace be upon him) said: One who died but did not fight in the way of Allah nor did he express any desire (or determination) for Jihid died the death of a hypocrite.
    'Abdullah b. Mubarak said : We think the hadith pertained to the time of the Messenger of Allah (may peace be upon him).

Chapter 48 : REWARD OF THOSE WHO COULD NOT JOIN A JIHAD EXPEDITION ON ACCOUNT OF ILLNESS OR SOME OTHER EXCUSE

Book 20, Number 4697:

    It has been narrated on the authority of Jabir who said : We were with the Holy Prophet (may peace be upon him) on an expedition. He said: There are some people in Medina. They are with you whenever you cover a distance or cross a valley. They have been detained by illness.

Book 20, Number 4698:

    In a version of the tradition narrated on the authority of A'mash, we have the words: "They will share with you the reward (for Jihid)."

Chapter 49 : THE MERIT OF JOINING A NAVAL EXPEDITION FOR JIHAD

Book 20, Number 4699:

    It has been reported on the authority of Anas b. Malik that the Messenger of Allah (may peace be upon him) used to visit Umm Haram daughter of Milhan (who was the sister of his foster-mother or his father's aunt). She was the wife of 'Ubada b. Samit, One day the Messenger of Allah (may peace be upon him) paid her a visit. She entertained him with food and then sat down to rub his head. The Messenger of Allah (may peace be upon him) dozed off and when he woke up (after a while), he was laughing. She asked: What made you laugh. Messenger of Allah? He said: Some people from my Umma were presented to me who were fighters in the way of Allah and were sailing in this sea. (Gliding smoothly on the water), they appeared to be kings or like kings (sitting) on thrones (the narrator has a doubt about the actual expression used by the Holy Prophet). She said : Messenger of Allah, pray to Allah that He may include me among these warriors. He prayed for her. Then he placed his head (down) and dozed off (again). He woke up laughing, as before. (She said) I said: Messenger of Allah, what makes you laugh? He replied: A people from my Umma were presented to me. They were fighters in Allah's way. (He described them in the same words as he had described the first warriors.) She said: Messenger of Allah, pray to God that He may include me among these warriors. He said: You are among the first ones.
    Umm Haram daughter of Milhan sailed in the aea in the time of Mu'awiya. When she came out of the sea and (was going to mount a riding animal) she fell down and died.

Book 20, Number 4700:

    It has been narrated on the authority of Umm Haram (and she was the aunt of Anas) who said: The Holy Prophet (may peace be upon him) came to us one day and had a nap in our house. When he woke up, he was laughing. I said: Messenger of Allah, what made you laugh? He said: I saw a people from my followers sailing on the surface of the sea (looking) like kings (sitting) on their thrones. I said: Pray to Allah that He may include me among them. He said: You will hip among them. He had a (second) ntip, woke up and was laughing. I asked him (the reason for his laughter). He gave the same reply. I said: Pray to Allah that He may include me among them. He said: You are among the first ones. Anas said: 'Ubada b. Samit married her. He joined a naval expedition and took her along with him. When she returned, a mule was brought for her. While mounting it she fell down, broke her neck (and died).

Book 20, Number 4701:

    It has been reported on the authority of Umm Haram daughter of Milhan (through another chain of transmitters). She said: One day the Messenger of Allah (may peace be upon him) slept (at a place) near me. He woke up smiling. She said : Messenger of Allah. what made thee laugh ? He said: A people from my followers were presented to me. They were sailing on the surface of this green sea... (here follows the tradition that has gone before).

Book 20, Number 4702:

    It has been reported by 'Abdullah b. 'Abd al-Rahman that he heard Anas b. Malik say: The Messenger of Allah (may peace be upon him) paid a visit to Milhan's daughter, maternal aunt of Anas (and the sister of the Holy Prophet's foster-mother). He placed his head near her (from this point onward, the narrator carried on the previous tradition to its end).

Chapter 50 : THE MERIT OF KEEPING WATCH IN THE WAY OF ALLAH, THE ALMIGHTY AND EXALTED

Book 20, Number 4703:

    It has been narrated on the authority of Salman who said: I heard the Messenger of Allah (may peace be upon him) say: Keeping watch for a day and a night is better (in point of reward) than fasting for a whole month and standing in prayer every night. If a person dies (while, performing this duty), his (meritorious) activity will continue and he will go on receiving his reward for it perpetually and will be saved from the torture of the grave.

Book 20, Number 4704:

    This tradition has been handed down on the authority of Salman al-Khair through another chain of transmitters.

Chapter 51 : ABOUT THE MARTYRS

Book 20, Number 4705:

    It has been narrated on the authority of Abu Huraira that the, Messenger of Allah (may peace be upon him) said: While a man walks along a path, finds a thorny twig lying on the way and puts it aside, Allah would appreciate it and forgive him The Holy Prophet (may peace be upon him) said: The martyrs are of five kinds: one who dies of plague; one who dies of diarrhoea (or cholera); one who is drowned; one who is buried under debris and one who dies fighting in the way of Allah.

Book 20, Number 4706:

    It has been narrated on the authority of Abu Huraira (through another chain of transmitters) that the Messenger of Allah (may peace be upon him) said: Whom do you consider to be a martyr among you? They (the Companions) said: Messenger, of Allah, one who is slain in the way of Allah is a martyr. He said: Then (if this is the definition of a martyr) the martyrs of my Umma will be small in number. They asked: Messenger of Allah, who are they? He said: One who is slain in the way of Allah is a martyr; one who dies in the way of Allah, is a martyr; one who dies of plague is a martyr; one who dies of cholera is a martyr.
    Ibn Miqsam said: I testify the truth of your father's statement (with regard to this tradition) that the Holy Prophet (may peace be upon him) said: One who is drowned is a martyr.

Book 20, Number 4707:

    A version of the tradition narrated on the authority of Suhail contains the additional words: "And one who is drowned is a martyr."

Book 20, Number 4708:

    Another version of the tradition narrated on the authority of Suhail thouch a different chain of transmitters contains the additional words: "A drowned person is a martyr."

Book 20, Number 4709:

    It has been narrated on the authority of Hafsa daughter of Sirin who said: Anas b. Malik asked me the cause of death of Yahya b. 'Abu 'Amra. I said: (He died) of plague. He said: The Messenger of Allah (may peace be upon him) said that death by plague is martyrdom for a Muslim.

Book 20, Number 4710:

    This hadith has been narrated on the authority of 'Asim through the same chain of transmitters.

Chapter 52 : THE MERIT OF ARCHERY AND INDUCING OTHERS TO LEARN IT AND DENUNCIATION OF ONE WHO LEARNT THE ART AND THEN NEGLECTED IT

Book 20, Number 4711:

    It has been narrated on the authority of Ibn Amir who said: I heard the Messenger of Allah (may peace be upon him) say-and he was delivering a sermon from the pulpit : Prepare to meet them with as much strength as you can afford. Beware, strength consists in archery. Beware, strength consists in archery. Beware, strength consists in archery.

Book 20, Number 4712:

    It has been narrated on the authority of Uqba b. Amir who said: I heard the Messenger of Allah (may peace be upon him) say: Lands shall be thrown open to you and Allah will suffice you (against your enemies), but none of you should give up playing with his arrows.

Book 20, Number 4713:

    This tradition has also been narrated on the same authority through another chain of transmitters.

Book 20, Number 4714:

    It has been reported by 'Abd al-Rahman b. Shamasa that Fuqaim al- Lakhmi said to Uqba b. Amir: You frequent between these two targets and you are an old man, so you will be finding it very hard. 'Uqba said: But for a thing I heard from the Holy Prophet (may peace be upon him), I would not strain myself. Harith (one of the narrators in the chain of transmitters) said: I asked Ibn Shamasa: What was that? He said that he (the Holy Prophet) said: Who learnt archery and then gave it up is not from us. or he has been guilty of disobedience (to Allah's Apostle).

Chapter 53 : SAYING OF THE HOLY PROPHET (MAY PEACE BE UPON HIM): "A GROUP OF PEOPLE FROM MY UMMA WILL ALWAYS REMAIN ON THE RIGHT PATH AND CONTINUE TO BE TRIUMPHANT; THEIR OPPONENTS SHALL NOT BE ABLE TO DO THEM ANY HARM"

Book 20, Number 4715:

    It has been narrated on the authority of Thauban that the Messenger of Allah (may peace be upon him) said: A group of people from mv Umma will always remain triumphant on the right path and continue to be triumphant (against their opponents). He who deserts them shall not be able to do them any harm. They will remain in this position until Allah's. Command is executed (i.e. Qayamah is established). In Qutaiba's version of the tradition, we do not have the words : "They will remain in this position."

Book 20, Number 4716:

    It has been narrated on the authority of Mughira who said: I heard the Messenger of Allah (may peace be upon him) say: A group of people from my Umma will continue to be triumphant over the people until the Command of Allah overtakes them while they are still triumphant. The same tradition has been narrated through another chain of transmitters on the same authority.

Book 20, Number 4717:

    It has been narrated on the authority of Jabir b. Samura that the Holy Prophet (may peace be upon him) said: This religion will continue to exist, and a group of people from the Muslims will continue to fight for its protection until the Hour is established.

Book 20, Number 4718:

    It has been narrated on the authority of Jabir b. 'Abdullah who said: I heard the Messenger of Allah (may peace be upon him) say: A group of people from my Umma will continue to fight In defence of truth and remain triumphant until the Day of judgment.

Book 20, Number 4719:

    It his been narrated on the authority of Umair b. Umm Hani who said: I heard Mu'awiya say (while delivering a sermon from the pulpit) that he heard the Messenger of Allah (may peace be upon him) say: A group of people from my Umma will continue to obey Allah's Command, and those who desert or oppose them shall not be able to do them any harm. They will be dominating the peeple until Allah's Command is executed (i.e. Resurrection is established).

Book 20, Number 4720:

    It has been related by, Yazid b. al-Asamm that he heard Mu'awiya b. Abu Sfyan quote a tradition from the Holy Prophet (may peace be upon him) which he related from the Prophet (mail peace he upon him)-and he did not hear him quote from the Holy Prophet (masy peace be upon him) any tradition other than this in the course of his sermon from the pulpit-that whom Allah wants to do a favour, He grants him an understanding of religion. A group of people from the Muslims will remain on the Right Path and continue until the Day of Judgment to triumph over those who oppose them.

Book 20, Number 4721:

    It has been narrated on the authority of 'Abd al-Rahman b. Shamasa al- Mahri who said : I was in the company of Maslama b. Mukhallad, and 'Abdullah b. 'Amr b. 'As was with him. 'Abdullah said: The Hour shall some oniy when the worst type of people are left on the earth. They will be worse than the people of pre-Islamic days. They will get whatever they ask of Allah. While we were yet sitting when 'Uqba b. 'Amir came, and Maslama said to him: 'Uqba, listen to what 'Abdullah says. 'Uqba said: He knows better; so far as I am concerned, I heard the Messenger of Allah (may peace be upon him) say : A group of people from my Umma will continue to fight in obedience to the Command of Allah, remaining dominant over their enemies. Those who will oppose them shall not do them any harm. They will remain ill this condition until the Hour overtakes them. (At this) 'Abdullah said : Yes. Then Allah will raise a wild which will be fragrant like musk and whose touch will be like the touch of silk ; (but) it will cause the death of all (faithful) persons, not leaving behind a single person with an iota of faith in his heart. Then only the worst of men will remain to be overwhelmed by the Hour.

Book 20, Number 4722:

    It has been narrated by Sa'd b. Abu Waqqas that the Messenger of Allah (may peace be upon him) said : The people of the West will continue to triumphantly follow the truth until the Hour is established.

Chapter 54 : KEEPING THE GOOD OF THE ANIMALS IN VIEW DURING A JOURNEY AND FORBIDDANCE FROM HALTING FOR THE NIGHT ON THE TRACK

Book 20, Number 4723:

    It has been narrated on the authority of Abu Huraira that the Messenger of Allah (may peace be upon him) said: When you journey through a fertile land, you should (go slow and) give the camels a chance to graze in the land. When you travel In an arid (land) where there is scarcity of vegetation, you should quicken their pace (lest your camels grow feeble and emaciated for lack of fodder). When you halt for the night, avoid (pitching your tent on) the road, for it is the abode of noxious little animals at night.

Book 20, Number 4724:

    It has been narrated (through another chain of transmitters) on the authority of Abu Huraira that the Messenger of Allah (may peace be upon him) said: When you travel (through a land) where there is plenty of vegetation, you should (go slow and) give the camels a chance to enjoy the benefit of the earth. When you travel (through a land) where there is scarcity of vegetation, you should hasten with them (so that you may be able to cross that land while your animals ore still in a good condition of health). When you make a halt for the night, avoid (doing so on) the road, for the tracks are the pathways of wild beasts or the abode of noxious little animals.

Chapter 55 : TRAVELLING, A TORTUOUS EXPERIENCE-DESIRABILITY OF A TRAVELLER'S HASTENING HIS RETURN TO HIS FAMILY AFTER THE TRANSACTION OF HIS BUSINESS

Book 20, Number 4725:

    On the authority of Abu Huraira that the Prophet (may peace be upon him) said: Travelling is a tortuous experience. It deprives a person of his sleep. his food and drink. When one of you has accomplished his purpose, he should hasten his return to his family.

Chapter 56 : UNDESIRABILITY OF RETURNING TO ONE'S FAMILY AT NIGHT (AFTER A LONG ABSENCE FROM HOME)

Book 20, Number 4726:

    It has been narrated on the authority of Anas b. Malik that the Messenger of Allah (may peace be upon him) would not come (back) to his family by night. He would come to them in the morning or in the evening. Another version of the tradition narrated on the some authority is a little difierently worded. It says: (He) would not enter (upon his household at night).

Book 20, Number 4727:

    It has been narrated on the authority of Jabir b. 'Abdullah who said: We accompanied the Messenger of Allah (may peace be upon him) on an expedition. When we came (back) to Medina and were going to enter our houses, he said: Wait and enter (your houses) in the later part of the evening so that a woman with dishevelled hair may have used the comb, and a woman whose husband has been away from home may have removed the hair from her private parts.

Book 20, Number 4728:

    It has been narrated on the authority of Jabir that the Messenger of Allah (may peace be upon him) said: If one of you comes (back from a journey) at night. he should not enter his house as a night visitor (but should wait) until a woman whose husband has been away from house has removed the hair from her private parts and a woman with dishevelled hair has combed her hair.

Book 20, Number 4729:

    This tradition has been handed down through another chain of transmitters.

Book 20, Number 4730:

    It has been narrated (through a different chain of tranmitten) on the authority of Jabir who said: The Messenger of Allah (may peace be upon him) forbade that a man should come to his family like (an unexpected) night visitor doubting their fidelity and spying into their lapses.

Book 20, Number 4731:

    A version of the tradition narrated on the authority of Jabir (but through a different chain of transmitters) mentions the undesirability of coining to one's house like a night visitor, but does not contain the words: "Doubting their fidelity or spying into their lapses."


Book 21 : The Book of Games and the Animals which May be Slaughtered and the Aninals that Are to be Eaten (KITAB-US-SAID WA'L-DHABA'IH WA MA YU'KALU MIN AL-HAYAWAN)

KITAB-US-SAID WA'L-DHABA'IH WA MA YU'KALU MIN AL-HAYAWAN
(BOOK OF GAMES AND THE ANIMALS WHICH MAY BE SLAUGHTERED AND THE ANIMALS THAT ARE TO BE EATEN)

Back
Chapter 1 : HUNTING WITH THE HELP OF TRAINED DOGS

Book 21, Number 4732:

    'Adi b. Hatim reported: I said: Messenger of Allah, I set off trained dogs and they catch for me (the game) and I recite the came of Allah over it (I slaughter the game by reciting Bismillah-i-Allah-o-Akbar), whereupon he said: When you set off your trained dogs and you recited the name of Allah (while setting them off), then eat (the game). I said: Even if them (the trained dogs) kill that (the game)? He (the Holy Prophet) said: Even if these kill, but (on the condition) that no other dog, which you did not set off (along with your dogs), participates (in catching the game). I said to him: I throw Mi'rad, a heavy featherless blunt arrow, for hunting and killing (the game). Thereupon he said: When you throw Mi'rad, and it pierces, then eat, but if it falls flatly (and beats the game to death), then do not eat that.

Book 21, Number 4733:

    'Adi b. Hatim reported: I asked Allah's Messenger (may peace be upon him) saying: We are a people who hunt with these (trained) dogs, then (what should we do)? Thereupon he (the Holy Prophet) said: When you set of your trained dogs having recited the name of Allah, then eat what these (hounds) have caught for you, oven if it (the game) is killed, provided (the hunting dog) has not eaten (any part of the game). If it has eaten (the game), then you don't eat it as I fear that it might have caught for its own self. And do not eat in case other dogs have joined your trained dogs.

Book 21, Number 4734:

    'Adi b. Hatim reported that he asked the Messenger of Allah (may peace be upon him) about (hunting) with the help of an arrow having a stub end. He said: If it strikes (the game) with its point, then eat, but if it strikes flatly and it dies, that is Waqidh (beaten into death), do not eat that. I asked the Messenger of Allah (may peace be upon him) about (hunting with the help of) dogs, whereupon he said. When you send your dog (for hunting) reciting the name of Allah, then eat (the game), but if some part of it is eaten (by the dogs, then do not eat that, for it (your dog) has caught that (the-game) for itself. I (again) said: If I find along with my dog another dog, and do not know which of (the dogs) has caught (the game). then (what should I do) ? Thereupon he ('Allah's Messenger) said: Then don't eat that, for you recited the name of Allah on your dog and not on the other one.

Book 21, Number 4735:

    Adi b. Hatim reported: I asked Allah's Messenger (may peace be upon him) about Mi'rad (i.e. hunting with the help of arrow having a stub end, and he stated the same (as we find in the previous hadith).

Book 21, Number 4736:

    This hadith has been transmitted on the authority of 'Adi b. Hatim with a slight variation of words.

Book 21, Number 4737:

    'Adi b. Hatim reported: I asked Allah's Messenger (may peace be upon him) about hunting the game with the help of Mi'rad, whereupon he said: If it strikes (the game) with its point, then eat it,but if it strikes flat, that is (the game is) beaten (into death), (then do not eat that) 'Adi further said: I asked him about hunting with the help of a dog, whereupon he said: If that (the dog) catches it (the game) for you and does not eat out of that, then you eat (the game) for Dhakat (slaughtering) of that is its being caught by it (by the dog). But if you find another dog besides it, and you fear that that dog (the second one) had caught it (the game) along with that (your dog) and killed it. then don't eat; for you recited the name of Allah on your dog and did not recite that on the other one (which joined your dog incidentally).

Book 21, Number 4738:

    This hadith has been narrated on the authority of Zakariya b. Abu Za'ida with the same chain of transmitters.

Book 21, Number 4739:

    Sha'bi reported: I heard Adi b. Hatim say-and he was our neighbour, and our partner and co worker at Nahrain-that he asked Allah's Apostle (may peace he upon him) saying: I let off my dog and find another dog along with my dog and that (any one of them) catches the (game), but I do not know which one had caught it, whereupon he (the Holy Prophet) said: Then don't eat that, for you recited the name of Allah while letting off your dog and did not recite on the other.

Book 21, Number 4740:

    This hadith has been narrated oif the authority of 'Adi b. Hatim through another chain of transmitters.

Book 21, Number 4741:

    Adi b. Hatim reported: Allah's Messenger (way peace be upon him) said to me: When you let off your dog, recite the name of Allah, and if it catches (game for you) and you find it alive, then slaughter it; if you find it killed and that (your dog) has eaten nothing out of that, (even then) you may eat it; but if you find along with your dog another dog, and (the game an) dead, then don't eat, for you do not know which of the two has killed it. And if you shoot your arrow, recite the name of Allah, but if it (game) goes out of your sight for a day and you do not find on that but the mark of your arrow, then eat that it you so like, but if you find it drowned in water, then don't eat that.

Book 21, Number 4742:

    'Adi b. Hatim reported: I asked Allah's Messenger (may peace be upon him) about hunting. He said: When you shoot your arrow, recite the name of Allah, and if you find it (the arrow) killed (that). then eat, except when you find it fallen into water, for in that case you do not know whether it is water that caused its death or your arrow.

Book 21, Number 4743:

    Abu Tha'laba al-Khushani reported: I came to Allah's Messenger (may peace be upon him) and said: Allah's Messenger, we are in the land of the People of the Book, (so) we eat in their utensils, and (live) in a hunting region. where I hunt with, the help of my bow, and hunt with my trained dog, or with my dog which is not trained. So inform me what is lawful (Halal) for us out of that. He (the Holy Prophet) said: Regarding what you have mentioned of the fact that you live in the land belonging to the People of the Book and so you eat in their utensils, but if you can get utensils other than theirs, then don't eat in them; but if you do not find any, then wash them and eat in them. And regarding what you have mentioned about (your living) in a hunting region, what you hunt, (strike) with the help of your bow, recite the name of Allah (while shooting an arrow) and then eat; and what you catch with the help of your trained dog,recite the name of Allah (while letting oil) the dog and then eat it, and what you get with the help of your untrained dog, (if you find it alive) and slaughter it (according to the law of the Shari'ah), eat it.

Book 21, Number 4744:

    This hadith has been narrated on the authority of Haiwa with the same chain of transmitters, but with a slight variation of words.

Chapter 2 : WHEN THE GAME GOES OUT OF SIGHT, BUT IS LATER ON FOUND

Book 21, Number 4745:

    Abu Tha'laba reported Allah's Messenger (may peace be upon him) having said this: If you shoot with your arrow and (the game) goes out of your sight and you find it(later on), then eat that if it has not gone rotten.

Book 21, Number 4746:

    Abu Tha'laba reported Allah's Apostle (may peace be upon him) as saying about one who comes three days later on the game he has shot: Eat it, provided it has not gone rotten.

Book 21, Number 4747:

    This hadith has been transmitted on the authority of Abu Tha'laba al- Khushani with a slight variation of (words): He (the Holy Prophet) said in regard to the game killed by (a trained) dog: Eat after three days provided it has not gone rotten.

Chapter 3 : IT IS UNLAWFUL TO EAT FANGED BEASTS OF PREY AND BIRDS WITH TALONS

Book 21, Number 4748:

    Abu Tha'laba reported that Allah's Apostle (may peace be upon prohibited the eating of every fanged beast of prey. Zuhri added: We did not bear of it until we came to Syria.

Book 21, Number 4749:

    Abu Tha'laba al-Khushani reported that Allah's Messenger (may peace be upon him) prohibited the eating of all fanged beasts. Ibn Shihab said: I did not bear of this from our 'Ulama' in the Hijaz, until Abu Idris narrated that to me and he was one of the jurists of Syria.

Book 21, Number 4750:

    Abu Tha'laba al-Khushani reported Allah's Messenger (may peace be upon him) having prohibited the eating of all fanged beasts of prey. This hadith has been narrated through another chain of transmitters, but with a slight variation of words.

Book 21, Number 4751:

    Abu Huraira reported Allah's Messenger (may peace be upon him) as saying: The eating of all fanged beasts of prey is unlawful. This hadith has been narrated through another chain of transmitters.

Book 21, Number 4752:

    Ibn 'Abbas reported that Allah's Messenger (may peace be upon him) prohibited the eating of all fanged beasts of prey, and all the birds having talons.

Book 21, Number 4753:

    This hadith has been transmitted on the authority of Shu'ba.

Book 21, Number 4754:

    Ibn Abbas reported that Allah's Messenger (may peace be upon him) forbade (the eating) of all the fanged beasts of prey, and of all the birds having talons.

Book 21, Number 4755:

    This hadith has been narrated on the authority of Ibn 'Abbas through a different chain of transmitters.

Chapter 4 : IT IS PERMISSIBLE TO EAT THE ANIMALS OF WATER EVEN IF THEY ARE DEAD

Book 21, Number 4756:

    Jabir reported: Allah's Messenger (may peace he upon him) sent us (on an expedition) and appointed Abu 'Ubaida our chief that we might intercept a caravan of the Quraish and provided us with a bag of dates. And he found for us nothing besides it. Abu Ubaida gave each of us one date (everyday). I (Abu Zubair, one of the narrators) said: What did you do with that? He said: We sucked that just as a baby sucks and then drank water over that, and it sufficed us for the day until night. We beat off leaves with the help of our staffs, then drenched them with water and ate them. We then went to the coast of the sea, and there rose before us on the coast of the sea something like a big mound. We came near that and we found that it was a beast, called al-'Anbar (spermaceti whale). Abu 'Ubaida said. It is dead. He then said: No (but it does not matter), we have been sent by the Messenger of Allah (may peace be upon him) in the path of Allah and you are hard pressed (on account of the scarcity of food), so you eat that. We three hundred in number stayed there for a month, until we grew bulky. He (Jabir) said: I saw how we extracted pitcher after pitcher full of fat from the cavity of its eye, and sliced from it compact piece of meat equal to a bull or like a bull. Abu 'Ubaida called forth thirteen men from us and he made them sit in the cavity of its eye, and he took hold of one of the ribs of its chest and made it stand and then saddled the biggest of the camels we had with us and it passed under it (the arched rib), and we provided ourselves with pieces of boiled meat (especially for use in our journey). When we came back to Medina, we went to Allah's Messenger (may peace be upon him) and made a mention of that to him, whereupon he said: That was a provision which Allah had brought forth for you. Is there any piece of meat (left) with you, so tnat you give to us that ? He (Jabir) said: We sent to Allah's Messenger (may peace be upon him) tome of that (a piece of meat) and he ate it.

Book 21, Number 4757:

    Jabir b. 'Abdullah reported: Allah's Messenger (may peace he upon him) sent us (on an expedition). We were three hundred riders and our chief (leader) was 'Ubaida b. al-Jarrah. We were on the look out for a caravan of the Quraish. So we stayed on the coast for half a month, and were so much afflicted by extreme hunger that we (were obliged) to eat leaves. That is why it was called the Detachment of the Leaves. The ocean cast out for us an animal which was called al-'Anbar (whale). We ate of that for half of the month and rubbed its fat on our (bodies) until our bodies became stout. Abu 'Ubaida caught hold of one of its ribs and fixed that up. He then cast a glance at the tallest man of the army and the highest of the camels. and then made him ride over that, and that-tnan passed beneath it (the rib), and many a man could sit in its eye-socket, and we extracted many pitchers of fat from the cavity of its eye. We had small bags containing dates with us (before finding the whale). 'Ubaida gave every person amongst us a handful of dates (and when the provision ran short), he then gave each one of us one date. And when that (stock) was exhausted, we felt its loss.

Book 21, Number 4758:

    'Amr reported on the authority of Jabir that in the expedition of Khabat (leaves) a person slaughtered three camels, then three, then three, then Abu 'Ubaida forbade him (to do so fearing that the rides may become short).

Book 21, Number 4759:

    Jabir b. 'Abdullah reported: Allah's Apostle (may peace be upon him) sent us (on an expedition), and we were three hundred in number, and we were carrying our bags of provisions around our necks.

Book 21, Number 4760:

    Jabir b. 'Abdullah reported that Allah's Messenger (may peace be upon him) sent on in expedition a detachment consisting of three hundred (persons) and appointed Abu 'Ubaida b. Jarrah as their chief. Their provisions ran short: 'Abu 'Ubaida collected their provisions in the provision bag. and he fed us (for some time). Later on when the provisions ran short he gave us one date every day.

Book 21, Number 4761:

    Jabir b. Abdullah reported that Allah's Messenger (may peace be upon him) sent an expedition to the sea coast and I was one among them. The rest of the hadith is the same with a slight variation of wording that in the hadith transmitted on the authority of Wahb b. Kaisan (the words are): "The army ate out of that (the whale) for eighteen days."

Book 21, Number 4762:

    Jabir b. Abdullah reported that Allah's Messenger (may peace be upon him) sent an expedition to the land of the tribe of Juhaina, and appointed a person as a chief over them.

Chapter 5 : THE EATING OF THE FLESH OF DOMESTIC ASSES IS UNLAWFUL

Book 21, Number 4763:

    'Ali b. Abi Talib reported that Allah's Messenger (may peace be upon him) forbade on the Day of Khaibar temporary marriage (Muta') with women and the eating of the flesh of domestic asses.

Book 21, Number 4764:

    This hadith has been narrated on the authority of Zuhri through a different chain of transmitters with a slight variation of wording.

Book 21, Number 4765:

    Abu Tha'laba reported that Allah's Messenger (may peace be upon him) prohibited (the eating) of the flesh of domestic asses.

Book 21, Number 4766:

    Ibn Umar reported that Allah's Messenger (way peace be upon him) forbade the eating of the flesh of domestic asses.

Book 21, Number 4767:

    Ibn 'Umar reported that Allah's Messenger (may peace be upon him) forbade the eating of the (flesh) of domestic asses on the Day of Khaibar in spite of the fact that people needed that.

Book 21, Number 4768:

    Shaibani reported: I asked 'Abdullah b. Abu Aufa about (the lawfulness or unlawfulness of) the flesh of the domestic asses. He said: We experienced hunger on the Day of Khaibar as we were with the Messenger of Allah (may peace be upon him). We found domestic asses in the exterior of Medina. We slaughtered them and our earthen pots were boiling when the announcer of the Messenger of Allah (may peace be upon him) made an announcement that the earthen pots should be turned upside down and nothing of the flesh of the domestic asses should be eaten. I said: What kind of prohibition is it that he (the Holy Prophet) has made? He said: We discussed it amongst -ourselves. Some of us aaid that it has been declared unlawful for ever, (whereas others said) it has been declared unlawful since one-fifth (of the booty) has not been given (to the treasury, as is legally required).

Book 21, Number 4769:

    Sulaiman Shaibini reported: I heard Abdullah b. Abu Aufa say: We were smitten with hunger during the nights of Khaibar. On the Day of Khaibar, we fell upon domestic asses and we slaughtered them, and when our earthen pots boiled with them, the announcer of Allah's Messenger (may peace be upon him) made an annoancement that the earthen pots should be turned over, and nothing should be eaten of the flesh of the domestic asses. Some of the people said that Allah's Messenger (may peace be upon him) had forbidden (the use of this flesh) for one-fifth (due to the State) has not been paid, while others said: He prohibited it for ever.

Book 21, Number 4770:

    'Adi (he was the son of Thabit) said: I heard al-Bara' and 'Abdullah b. Abu Aufa say: We found domestic asses and we cooked them. Then the announcer of Allah's Messenger (may peace be upon him) made an announcement that the earthen pots should be turned over.

Book 21, Number 4771:

    Al-Bara' said: We found on the Day of Khaibar domestic asses, and the announcer of the Messenger of Allah (may peace be upon him) made an announcement that the earthen pots should be turned over.

Book 21, Number 4772:

    Bara was heard saying: We were forbidden (to eat) the flesh of the domestic asses.

Book 21, Number 4773:

    Bara' b. 'Azib reported: Allah's Messenger (may peace be upon him) commanded us to throw away the flesh of domestic asses whether uncooked or cooked; he then never commanded us to eat that. This hadith has been narrated on the authority of 'Asim with the same chain of transmitters.

Book 21, Number 4774:

    Ibn 'Abbas reported: I do not know whether Allah's Messenger (may peace be upon him) prohibited (the eating of the domestic ass) due to the fact that they were the beasts of burden for the people, so he (the Holy Prophet) did not like their beasts of burden to be destroyed (as a matter of expediency), or he prohibited the use of the flesh of domestic asses (not as an expediency but as a law of the Shari'ah) on the Day of Khaibar.

Book 21, Number 4775:

    Salama b. Akwa' reported : We went to Khaibar with Allah's Messenger (may peace be upon him). Then Allah granted (us) victory over them. On that very evening of the day when they had been granted victory, they lit many fires. Thereupon Allah's Messenger (may peace be upon him) said: What are those fires and what for those have been lit? They said: (These have been lit) for (cooking) the flesh. Thereupon he said: Of what flesh? They said : For the flesh of the domestic asses. Thereupon Allah's Messenger (may peace bo upon him) said: Throw that away and break them (the earthen pots in which the fiesa was being cooked). A person said: Messenger of Allah, should we throw it away and wash them (the cooking pots)? He said : You may do so.

Book 21, Number 4776:

    This hadith has been transmitted on the authority of Yazid b. Abu Ubaid.

Book 21, Number 4777:

    Anas reported: When Allah's Messenger (may peace be upon him) conquered Khaibar, we caught hold of the asses outside the village. We cooked them (their flesh). Then the announcer of Allah's Messenger (may peace be upon him) made the announcement: Listen, verily Allah and His Messenger have prohibited you (the eating of) their (flesh), for it is a loathsome evil of Satan's doing. Then the earthen pots were turned over along with what was in them, and these were brimming (with flesh) at that time.

Book 21, Number 4778:

    Anas b. Malik reported: When it was the Day of Khaibar a visitor came and said: Messenger of Allah, the asses have been eaten. Then another came and said:Messenger of Allah, the asses are being destroyed. Then Allah's Messenger (may peace be upon him) commanded Abu Talha to make an announcement that Allah and His Messenger have prohibited you (from eating) of the flesh of (domestic) asses, for these are loathsome or impure. He (the narrator) said : The earthein pots were turned over along with what was in them.

Chapter 6 : PERTAINING TO THE EATING OF THE FLESH OF THE HORSE

Book 21, Number 4779:

    Jabir b. 'Abdullah reported that Allah's Messenger (may peace be upon him) prohibited eating of the flesh of domestic asses on the Day of Khaibar, and permitted the cooking of the flesh of horses.

Book 21, Number 4780:

    Jabir b. 'Abdullah is reported to have said : We ate during the time of Khaibar the (flesh) of horses and of wild asses, but Allah's Messenger (may peace be upon him) prohibited us (to eat) the flesh of domestic asses. This hadith has hen transmitted on the authority of Ibn Juraij.

Book 21, Number 4781:

    Asma' reported: We slaughtered a horse and ate it during the lifetime of Allah's Messenger (may peace be upon him).

Book 21, Number 4782:

    This hadith has been transmitted on the authority of Hisham.

Chapter 7 : PERTAINING TO THE FLESH OF THE LIZARD

Book 21, Number 4783:

    Ibn 'Umar reported: Allah's Messenger (may peace be upon him) was asked about the eating of (the flesh) of the lizard, whereupon he said: I am neither the eater of it nor its prohibitor.

Book 21, Number 4784:

    Ibn 'Umar reported: A person asked Allah's Messenger (may peace be upon him) about the eating of the lizard, whereupon he said. I neither eat it, nor do I prohibit it.

Book 21, Number 4785:

    Ibn 'Umar reported that a person asked Allah's Messenger (may peace be upon him) as he was sitting on the pulpit about the eating of the lizard, whereupon he said: I neither eat it, nor do I prohibit it.

Book 21, Number 4786:

    This hadith has been narrated on the authority of 'Ubaidullah with the same chain of transmitters.

Book 21, Number 4787:

    A hadith pertaining to the eating of the lizard is transmitted from the Holy Prophet (may peace be upon him) on the authority of Ibn 'Umar, but in this very hadith narrated through a different chain of transmitters there is a slight variation of wording (and the words are): "A lizard was brought to Allah's Messenger (may peace be upon him) but he neither ate that nor declared it unlawful." And in the hadith transmitted through Usama (the words are): "The man (inquirer) was standing in the mosque and Allah's Messenger (may peace be upon him) was sitting on the pulpit."

Book 21, Number 4788:

    Ibn 'Umar reported that there were some persons with Allah's Apostle (may peace be upon him) from among his Companions, Sa'd being one of them. There was brought to them the flesh of the lizard when a lady amongst the wives of Allah's Apostle (may peace be upon him) said: It is the flesh of the lizard. Thereupon Allah's Messenger (way peace be upon him) &aid: Eat, for it is lawful, but it is not my diet.

Book 21, Number 4789:

    Taubat Al-'Anbari reported: Al-Sha'bi (one of the narrators) asked me if I had heard the hadith transmitted on the authority of Hasan from the Prophet (may peace be upon him). He said: I sat in the company if Ibn 'Umar for two years or a year and a half but I did not hear narrated from Allah's Apostle (may peace be upon him) but this one (pertaining to the flesh of the lizard) as narrated by Mu'adh.

Book 21, Number 4790:

    'Abdullah b. 'Abbas reported: I and Khalid b. Walid went to the apartment of Maimuna along with Allah's Messenger (may peace be upon him), and there was presented to him a roasted lizard. Allah's Messenger (may peace be upon him) stretched his hand towards It, whereupon some of the women who had been in the house of Maimuna said: Inform Allah's Messenger (may peace be upon him) what he intends to eat. Allah's Messenger (may peace be upon him) lifted his hand. I said: Messenger of Allah, Is it forbidden? He said: No. It is not found in the land of my people, and I feel that I have no liking for it. Khalid said: I then chewed and ate it, while, Allah's Messenger (may peace be upon him) was looking (at me).

Book 21, Number 4791:

    'Abdullah b. 'Abbas reported that Khalid b. Walid who is called the Sword of Allah had informed him that he visited Maimuna, the wife of Allah's Apostle (may peace be upon him), in the company of Allah's Messenger (may peace be upon him), and she was the sister of his mother (that of Khalid) and that of 'Ibn Abbas, and he found with her a roasted lizard which her sister Hufaida the daughter of al-Harith had brought from Najd, and she presented that lizard to Allah's Messenger (may peace be upon him). It was rare that some food was presented to the Holy Prophet (may peace be upon him) and it was not mentioned or named. While Allah's Messenger (may peace be upon him) was about to stretch forth his hand towards the lizard, a woman from amongst the women present there informed the Messenger of Allah (may peace be upon him) what they had presented to him. They said: Messenger of Allah, it is a lizard. Allah's Messenger (may peace be upon him) withdrew his hand, whereupon Khalid b. Walid said: Messenger of Allah, is a lizard forbidden ? There opon he said: No, but it is not found in the land of my people, and I feel that I have no liking for it. Khalid said: I then chewed and ate it, and Allah's Messenger (may peace be upon him) was looking at me and he did not forbid (me to eat it).

Book 21, Number 4792:

    Khalid b. Walid reported that he visited Maimuna daughter of al-Harith with the Messenger of Allah (may peace be upon him), and she was the sister of his mother. She presented to Allah's Messenger (may peace be upon him) the flesh of a lizard which Umm Hufaid daughter of al-Harith had brought from Najd, and she had been married to a person belonging to Banu Ja'far. It was the habit of Allah's Messenger (may peace be upon him) not to eat anything until he knew what that was. The rest of the hadith is the same but with this (addition): "Ibn al-Asamm narrated it from Maimuna and he was under her care."

Book 21, Number 4793:

    Ibn 'Abbas reported: While we were in the house of Maimuna there were brought to Allah's Messenger two roasted lizards. Here no mention is made of al- 'Asamm narrating from Maimuna.

Book 21, Number 4794:

    Ibn 'Abbas reported that there had been brought to Allah's Messenger (may peace be upon him) the flesh of a lizard and Khalid b. Walid was also present there. The rest of the hadith is the same.

Book 21, Number 4795:

    Sa'id b. Jubair reported that he heard Ibn 'Abbas says: The sister of my mother Umm Hufaid presented to Allah's Messenger (may peace be upon him) clarified butter (ghee), cheese and some lizards. He ate out of the clarified butter and cheese, but lett the lizard finding no liking for it. But it was eaten on the table of Allah's Messenger (may peace be upon him). Had it been forbidden (haram), it could not be eaten on the table of Allah's Messenger (may peace be upon him).

Book 21, Number 4796:

    Yazid b. al-Asamm reported: A newly wedded person of Medina invited us to a wedding feast, and he served us thirteen lizards. There were those who ate it and those who abandoned it. I met Ibn 'Abbas the next day, and informed him (about this) in the presence of many persons. Some of them said that the Messenger of Allah (may peace be upon him) had observed: I neither eat it nor forbid (anyone) from eating it, nor declare it to be unlawful. Thereupon Ibn 'Abbas said: Sad it is what you say ! Allah's Apostle (may peace be upon him) has not been sent, but (to declare in clear words) the lawful and the unlawful (things). We were once with Allah's Messenger (may peace be.upon him) as he was with Maimuna, and there were with him al-Fadl b. 'Abbas, Khalid b. Walid and some women (also) when a tray of food containing flesh was presented to him. As Allah's Apostle (may peace be upon him) was about to eat that, Maimuna said: It is the flesh of the lizard. He withdrew his hand saying: That is the flesh which I never eat; but he said to them (those who were present there): You may eat. Al-Fadl ate out of that, so did Khalid b Walid, and the women. Maimuna (however) said: I do not eat anything but that which Allah's Messenger (may peace be upon him) eats.

Book 21, Number 4797:

    Abu Zubair reported that he heard Jabir b. 'Abdullah saying that there was presented to Allah's Messenger (the flesh) of the lizard, but he refused to eat that, saying: I do not know; perhaps it (lizard) might (be one of those natives of) the distant past whose (forms) had beer, distorted.

Book 21, Number 4798:

    Abu Zubair reported: I asked Jabir about ithe eating) of the lizard, whereupon he said: Don't eat that as he (the Holy Prophet) felt disgust. He (the narrator) said that Umar b. al-Khattab reminded: Allah's Apostle (may peace be upon him) did not declare it to be unlawful. Allah, the Exalted and Majestic, has (made it a source) of benefit for more than one (persons). It is a common diet of the shepherds. Had it been with me, I would have eaten that.

Book 21, Number 4799:

    Abu Sa'id reported that a person said: Messenger of Allah, we live in a land abounding in lizards, so what do you command or what verdict you give (about eating of it) ? Thereupon he said: It was mentioned to me that a people from among Bani Isra'il were distorted (so there is a likelihood that those people might have been distorted in the shape of lizards). So he neither commanded (us to eat that) nor forbade (us). Abu Sa'id said: After some time Umar said: Allah, the Exalted and Majestic, has made it (a source of) benefit for more than one (person), for it is the common diet of shepherds. Had it been with me, I would have eaten that. Allah's Messenger (may peace be upon him) disliked it.

Book 21, Number 4800:

    Abu Sa'id reported that an Arab of the desert came to Allah's Messenger (may peace be upon him) and said: I live in a low land abounding in lizards, and these are the common diet of my family, but he (the Holy Prophet) did not make any reply. We said to him: Repeat it (your problem) and so he repeated it, but he did not make any reply. (It was repeated thrice ) Then Allah's Messenger (may peace be upon him) called him out at the third time saying: O man of the desert, verily Allah cursed or showed wrath to a tribe of Bani Isra'il and distorted them to beasts which move on the earth. I do not know, perhaps this (lizard) may be one of them. So I do not eat it, nor do I prohibit the eating of it.

Chapter 8 : PERMISSIBILITY OF EATING LOCUSTS

Book 21, Number 4801:

    Ibn Abu Aufa reported: We went on seven expeditions with Allah's Messenger (may peace be upon him) and ate locusts.

Book 21, Number 4802:

    This hadith has been narrated on the authority of Abu Ya'fur with the same chain of transmitters. Abu Bakr (one of the narrators) said "seven expeditions," whereas Ishaq said "six," and Ibn Umar said "six" or "seven".

Book 21, Number 4803:

    This hadith is narrated on the authority of Abu Ya'fur with the same chain of transmitters, and he mentioned seven expeditions.

Chapter 9 : PERMISSIBILITY OF EATING THE FLESH OF THE HARE

Book 21, Number 4804:

    Anas b. Malik reported: We chased a hare at Marr az-Zahrin (a valley near Mecca). They (my companions) ran, but felt exhausted; I also tried until I caught hold of it. I brought it to Abu Talha. He slaughtered it and sent its haunch and two hind legs to Allah's Messenger (may peace be upon him) through me; and he accepted them. This hadith has been transmitted on the authority of Yahya with a slight change of wording.

Chapter 10 : IT IS PERMISSIBLE TO MAKE USE OF THINGS NECESSARY FOR HUNTING AND CHASING BUT THE USE OF SMALL PEBBLES IS DISAPPROVED

Book 21, Number 4805:

    Ibn Buraida reported that Abdullah b. al-Mughaffal saw a person from amongst his companions throwing small pebbles, whereupon he said: Don't throw pebbles. for Allah's Messenger (may peace be upon him) did not like it, or he forbade flinging of pebbles since neither the game is taken thereby, nor an enemy defeated. but it may break a tooth or put out an eye. He, afterwards, again saw him flinging pebbles, and said to him: I inform you that the Messenger of Allah (may peace be upon him) did not approve or he forbade flinging of pebbles, but if I see you again flinging pebbles. I will not speak with you.

Book 21, Number 4806:

    This hadith has been transmitted on the authority of Kahmas.

Book 21, Number 4807:

    'Abdullah b. Mughaffal reported that Allah's Messenger (may peace be upon him) prohibited throwing of pebbles. Ibn Ja'far reported (in the narration transmitted by him) that he (the Holy Prophet) said: It neither inflicts defeat to the enemy nor kills the game but breaks the tooth and puts the eye out. This hadith has been transmitted on the authority of Ibn Mahdi with a slight variation of wording.

Book 21, Number 4808:

    Sa'id b. Jubair reported that. a near one of 'Abdullah b. Mughaffal threw pebbles. He prohibited him (to do so). He said that Allah's Messenger (may peace be upon him) had prohibited the throwing of pebbles by saying: It does not catch the game, nor does it inflict defeat on the enemy, but breaks the tooth and puts the eye out. He (the near one of Abdullah b. Mughadal) again repeated it (the act of throwing of pebbles) whereupon he said: I narrate to you that Allah's Messenger (may peace be upon hish) disliked and prohibited throwing of pebbles, but I see you again throwing pebbles; I (would therefore) not speak with you.

Book 21, Number 4809:

    This hadith has been narrated on the authority of Ayyi3b with the me chain of transmitters.

Chapter 11 : GOOD ATTITUDE EVEN IN SLAUGHTER AND KILLING AND SHARPENING OF LARGE KNIFE

Book 21, Number 4810:

    Shaddid b. Aus said: Two are the things which I remember Allah's Messenger (may peace be upon him) having said: Verily Allah has enjoined goodness to everything; so when you kill, kill in a good way and when you slaughter, slaughter in a good way. So every one of you should sharpen his knife, and let the slaughtered animal die comfortably.

Book 21, Number 4811:

    This hadith has been narrated on the authority of Khalid al-Hadhdha' through different chains o transmitters.

Chapter 12 : IT IS FORBIDDEN TO TIE THE ANIMALS (AND THEN KILL THEM)

Book 21, Number 4812:

    Hishim b. Zaid b. Anas b. Milik reported: I visited the house of al-Hakam b. Ayyub along with my grandfather Anas b. Milik, (and there) some people had made a hen a target and were shooting arrows at her. Thereupon Asas said that Allah's Messenger (may peace be upon him) had forbidden tying of the animals (and making them the targets of arrows, etc.). This hadith has been narrated on the authority of Shu'ba through other chains of transmitters.

Chapter 13 : IT IS FORBIDDEN TO TIE THE ANIMAL AND MAKE IT A TARGET OF ARROWS

Book 21, Number 4813:

    Ibn 'Abbas reported Allah's Messenger (may peace be upon him) having said this: Do not make anything having life as a target.

Book 21, Number 4814:

    This hadith has been narrated on the authority of Shu'ba through a different chain of transmitters.

Book 21, Number 4815:

    Sa'id b. Jubair reported that Ibn 'Umar happened to pass by a party of men who had tied a hen and were shooting arrows at it. As soon as they saw Ibn 'Umar, they scattered from it. Thereupon Ibn Umar said: Who has done this? Verily Allah's Messenger (may peace be upon him) has invoked curse upon him who does this.

Book 21, Number 4816:

    Sa'id b. Jubair reported that Ibn 'Umar happened to pass by some young men of the Quraish who had tied a bird (and th,is made it a target) at which they had been shooting arrows Every arrow that they missed came into the possession of the owner of the bird. So no sooner did they see Ibn 'Umar they went away. Thereupon Ibn 'Umar said: Who has done this ? Allah has cursed him who does this. Verily Allah's Messenger (may peace be upon him) invoked curse upon one who made a live thing the target (of one's marksmanship).

Book 21, Number 4817:

    Jabir b. 'Abdullah reported that Allah's Messenger (may peace be upon him) forbade that any beast should be killed after it has been tied.


Book 22 : The Book of Sacrifices (KITAB AL-ADAHI)

KITAB AL-ADAHI
(BOOK OF SACRIFICES )

Back
INTRODUCTION

    Religion, at its highest and best, is the devotion of the total self, through service and adoration, to the Almighty Who controls the universe. In this sense all the manifold rites, consecrations, and purifications, offerings and sacred feasts,all the working of asceticism and morality are only the indirect expression of the inner experience of religion-the experience of trust, surrender, yearning and enthusiasm. Sacrifice, whether that of wealth or desires, is the practical proof of man's devotion to his Creator. It is in fact religion in action.

    The Holy Qur'an expresses this attitude of mind and heart in the following words: "Say: Truly, my prayer and my service of sacrifice, and my living and my dying are for God (alone), the Sustainer of all the worlds, in Whose Divinity none has a share. Thus I have been bidden-and I am foremost among those who surrender themselves unto Him" (vi. 162-163).

    The 'Id al-Adha is commemorative of that unparalleled act of devotion of that noble soul. Abraham (peace be upon him), who, in obedience to the Command of his Lord, readily offered the life of his son Isma'il. The Holy Qur'an narrates this soul- stirring event in these words: "And when he (Isma'il) attained the age to assist him in his (Abrahm's) work, he (Abraham) said: O my son ! I see in vision that I offer thee in sacrifice. Now see what is thy view. The son said: O my father, do as thou art commanded. Thou wilt find me, if God so wills, patient. So when they both had surrendered themselves to (Allah), and he laid him down prostrate on his forehead (for sacrifice), We called out to him: O Abraham, thou hast indeed fulfilled the vision. Thus do We reward the doers of good. Surely this is a manifest trial. And We ransom- ed him with a great sacrifice. And We left (this blessing) for him among the later generations. Peace be upon Abraham I Thus indeed do We reward those who do good; for he was one of Our believing servants" (xxxvii. 102-111)

    In the above-quoted verses 'axim (great), the adjective qualifying "Sacrifice." may be understood both in literal and figurative sense. In literal sense it implies that a big ram was substituted. The figurative sense is even more important. It was indeed a great and momentous occasion, when two men with concentrated will ranged themselves in ranks of those to whom self-sacrifice in the service of God was the supreme thing in life. Similarly, the words "thou hast indeed fulfilled the vision" show that it was not in fact the act of slaughtering which was needed for the fulfilment of the vision, but it was the attitude of submission and surrender, an attitude of preparedness to sacrifice one's all in the path of Allah. that was demanded of Abraham and his illustrious son, and they eminently stood this test.

    Readiness to Sacrifice One's Life. In Islam the act of sacrifice is the symbol of a Muslim's readiness to lay down his life, and to sacrifice all his interests and desires in the cause of truth. The purpose of sacrifice is not fulfilled only by shedding the blood of an animal, but it is really fulfilled when a man submits himself completely to the command of Allah. This has been clearly laid down in Sura Hajj, verse 37; "Not their flesh, nor their blood reaches Allah, but it is the piety from you that reaches Him." This verse eloquently speaks of the fact that sacrifice in Islam is nothing else than a natural expression of homage and gratitude to the Creator. It is the spirit of willing devotion and cheerful obedience underlying sacrifices that is accepted by Allah Who is the Fountainhead of all morality. It is only piety of heart. nobility of soul and righteousness of conduct, that is acceptable to Him. It is essentially symbolic, an external symbol of dedication, devotion to Allah. Tafsir Ibn Kathir stresses this point: "The man who offers sacrifice should keep this fact uppermost in his mind that the most important motive behind this is the willing submission to Allah"'(Vol. VI, p. 183).

    Such truths, so self-evident to the Muslim readers, needed a clear and emphatic enunciation in view of the horrible misconceptions which had crowded round the act of sacrifice before Islam.

    "Throughout the Semitic field," observes Robertson Smith, in his well known book. The Religion of the Semitics, the fundamental idea of sacrifice was that of communion between the God and his worshipper by joint participation in the living flesh and blood of a sacred victim" (p. 49).

    "The Greeks also looked upon sacrifice as a 'Communion feast' with the Divinity, in which the God and his people became of one flesh by partaking together of the flesh of the victim; the animal was regarded, as in some degree, divine, as having the divine spirit incarnate in it. Among the Babylonians the gods feast in heaven, they eat the offerings, they scent the savour, like flies do they gather themselves together with the offerers" (Hastings, Encyclopedia of Rdigion & Ethics, Article "Sacrifice").

    The Holy Qur'an strikes at the very root of such wrong concepts of sacrifice and asserts that "it is neither the flesh nor the blood of (animals) that reaches Allah, but it is your piety that reaches Him," for God does not stand In need of food or blood. What He, in fact, desires is the devotion and piety of our hearts. and, as a symbol of such offer, the visible institution of sacrifice has been instituted. The Holy Qur'an has further elucidated the main parpose of the institution of sacrifice. "For every people did We appoint rites (of sacrifice) that they might celebrate the name of God over the sustenance He gave them from animals (fit for food). But your God is One God. Sub- mit then your wills to him (in Islam).. . . The sacrificial camels We have made for you as among the symbols from God. In them is (much) good for you So mention the name of Allah on them standing in a row. Then when they fall down on their sides, eat of them, feed the contented one and the beggar. Thus have We made them subservient to you that you may be grateful" (xxii. 34-3b).

    The Qur'an testifies to the historical fact that whatever may be the outward symbols of sacrifice, it has been accepted in one form or another by all the nations of the world. It had been a fundamental element of both Jewish and Gentile religions, and Christianity. It had been corrupted by many wrong practices and been overlaid by many wrong notions before the advent of Islam. Islam purifies it from all wrong notions and practices connected with it, and makes it explicitly clear that the act of sacrifice is an outward symbol of man's readiness to lay down his life, if required, and to surrender all his interests in the cause of truth and righteousness.

    The words "We have made them (subservient) to you" have a very wide significance. A Muslim has been awakened to the realisation of the fact that if they offer as a sacrifice an animal over which they hold control, it is their bounden duty to lay down their lives in the way of Allah, Who is not only their Master, but also their Creator and Sustainer and Who. therefore, exercises a far greater authority over them than they do over the animals. This should be the true motive of sacrifice, and it is with this spirit that this act should be performed.

    The Qur'anic words "To Him is acceptable observance of duty on your part" make it abundantly clear that the prevalent idea of atonement that "it is the blood that maketh an atonement for the soul" (Leviticus; 17: 11) has no foundation in Islam. The expiation of sin in Islam rests entirely on the good deeds of men, repentance of the Winners and the Forgiving and Merciful nature of God 'This fact cuts the ground from under the feet of any theory of an atoning sacrifice.

    The opening verse "For every people did We appoint rites (of sacrifice) that they might celebrate the name of God over the beast cattle wherewith He bath provided them," speaks of the fact that the very idea of human sacrifice is repugnant to the true religion and Allah has never given it sanction.

    This practice of human sacrifice was not uncommon before Islam. "Both on the mainland of Greece and in the Greek colonies human sacrifice was practised, usually as a means towards expulsion of evil" (Encydopaedia Britannica, Article'on "Sacrifice"). it occupied a prominent place in the ritual of the mother goddesses of ancient times.

    "The ordinary form of sacrifice," says E.O. James, in his famous book, The origins of Sacrifice, "consisted in stripping the victim of his ornaments, stretching him over the convex sacrificial stones and while fare priests held his arms, legs, head, the high priests or sacrificer cut open his breast with a flint or obsidian knife, and tore out the heart. This was held up to the sun to provide it with nourishment, before it was cast into a basin of Copal placed in a position to enable the blood and incense to ascend to the gods. The body was hurled down the steps of the temple to the court where it was seized by the priest or by the warrior who captured the victim. Some times a solemn feast was then held on the flesh, the skin having first been removed to be worn ceremonially by men who seem to have acquired thereby the fertilising nd health-giving qualities of the victim. Some of the blood was carried to certain temples and smeared on the hips of the images of gods" (pp. 84-6).

    Islam has not only exterminated the very idea of human sacrifice, but has completely ended all such inhuman practices which were very common with the people before Islam. The Holy Qur'an makes a pointed reference to the fact that this sacrifice of animals is commemorative of Abraham's offer of his son's life at the Command of Allah, who was substituted by a ram, and it has been perpetuated by Islam. It is narrated that once the Companions of the Holy Prophet (may peace be upon him) asked him about the sacrifice. He replied: "This is commemorative Sunnah of your father Abraham" (vide Ibn Kathir, Vol. III, p. 221). That this practice of sacrifice was already prevalent amongst the people before Islam can be well borne out by the fact that we find clear references to it in the poetry of pre-Islamic Arabia. The well. known poet Umayya observes:

      Abraham was one who would fulfil the pledges and offer sacrifices for Allah's sake.
      Thus he offered the life of his only son whose separation and whose risk of life, he could not bear.
      He said, "O my son I have pledged you to Allah.
      May I sacrifice my life for you !
      Be steadfast and firm."
      He had hardly taken off the shirt of his son, when Allah substituted Isma'il by a stout ram.

    Not only this practice of sacrifice has been preserved in Islam, but even the way of Abraham's has been declared to he one of righteousness and truthfulness:

      "Say: Behold, my Lord has guided me to a way that is straight-a religion of Right Path-the Path (trodden) by Abraham, who was wholly devoted to God, and was not of those who ascribe divinity to any beside him" (vi. 161).

    Even the Millat has been assigned a name after the name of Abraham:

      "He hath selected you and hath not placed upon you any hardship in religion-the religion of your father, Abraham. He named you Muslims before this, and in this, that the Messenger may be a witness to you and you may he witnesses to mankind" (xxii. 78).

    Historical Continuity, The constant reference to the earlier Prophets and the Qur'anic testimony to their righteousness and the preservation of some of their religious practices have been done to awaken the people to the realisation of a fundamental fact, i.e. the fact of the historical continuity of religious experience. The Muslims have been asked to believe in that which has been revealed unto Prophet Muhammad (may peace be upon him) as well as in that which was revealed before him. Life-so the Qur'an teaches us-is not a series of disconnected parts but a continuous, organic process: and this law applies also to the law of the mind, of which man's religious experience (in its cumulative sense) is a part. To make religious experience more living, to set Allah the Ever-living with loving vividness before the eyes of living men, to make them feel Him as actually and eternally present in their lives, man needs a path, clear-cut path, lightened with glories of the Messengers of Allah-a path on which one should not feel lonely but the strength of comradeship of those noble souls upon whom Allah has bestowed His choicest blessings.

    A few words may be said about the way how an animal should be slaughtered according to the teachings of Islam. Three are the aims which should be kept before the mind while slaughtering the animal:

    1. It should be slaughtered by reciting the name of Allah and glorifying Him.
    2. It should be slaughtered with a sharp knife so that its jugular vein may be cut with the minimum possible pain and its skin should not be removed and limbs should not be cut so long as there is any sign of life in it.
    3. The head should not be removed from the body abruptly but only the jugular vein should be cut so that even the last drop of blood flows out of its body. If the animal is beheaded with a stroke, the blood congeals in its veins which makes the flesh distasteful and pernicious to health.
Chapter 1 : THE PROPER TIME FOR SACRIFICE

Book , Number 4818:

    Jundab b. Sufyan reported: I was with Allah's Messenger (may peace be upon him) on the day of 'Id al-Adha. While he had not returned after having offered (the Id prayer) and finished it, he saw the flesh of the sacrificial animals which had been slaughtered before he had completed the prayer. Thereupon he (the Holy Prophet) said: One who slaughtered his sacrificial animal before his prayer or our prayer ('Id), he should slaughter another one in its stead, and he who did not slaughter, he should slaughter by reciting the name of Allah.

Book 22, Number 4819:

    Jundab b. Sufyan reported: I was with Allah's Messenger (may peace be upon him) (on the occasion) of 'Id al-Adha. After he had completed the prayer with people, he found that the goats had been slaughtered, whereupon he said: He who slaughtered sacrificial animal before the prayer should slaughter a goat (again) in its stead and he who has not slaughtered he should slaughter it by reciting the name of Allah.

Book 22, Number 4820:

    This hadith has been narrated on the authority of al-Aswad b. Qais with the same chain of transmitters.

Book 22, Number 4821:

    Jundab al-Bajali reported: I saw Allah's Messenger (may peace be upon him) observing ('Id) prayer on the Day of Sacrifice (10th of Dhu'l-Hijja) and then delivering a sermon and he said: He who sacrificed the (animal) before offering ('Id) prayer, he should offer again in its stead, and he who did not sacrifice the animal should slaughter it by reciting the name of Allah.

Book 22, Number 4822:

    This hadith has been narrated on the authority of Shu'ba through another chain of transmitters.

Book 22, Number 4823:

    Al-Bara' reported: My maternal uncle Abu Burda sacrificed his animal before ('Id) prayer. Thereupon Allah's Messenger (may peace be upon him) said: That is a goat (slaughtered for the sake of) flesh (and not as a sacrifice on the day of Adha). He said: I have a lamb of six months. Thereupon he said: Offer it as a sacrifice, but it will not justify for anyone except you, and then said: He who sacrificed (the animal) before ('Id) prayer, he in fact slaughtered it for his own self, and he who slaughtered after prayer, his ritual of sacrifice became complete and he in fact observed the religious practice of the Muslims.

Book 22, Number 4824:

    Al-Bara' b. 'Azib reported that his maternal'uncle Abu Burda b. Niyar sacrificed his animal earlier than the Holy Prophet (may peace be upon him) had sacrificed. Thereupon he said: Apostle of Allah, it is the day of meat and it is not desirable (to have longing for it and not to make use of it immediately), so I hastened in offering my animal as a sacrifice, so that I might feed my family and neighbours and my kith and kin. Thereupon Allah's Messenger (may peace be upon him) said: Offer again your sacrifice. He said: Messenger of Allah, I have a small milch goat of less than one year, and that is better than two dry goats (from which only) meat (can be acquired). Thereupon he said: That is better than the two animals of sacrifice on your behalf, and the sacrifice of a goat , of less than six months shall not be accepted as a sacrifice on behalf of anyone after your (sacrifice).

Book 22, Number 4825:

    Al-Bara' b. 'Azib reported: Allah's Messenger (may peace be upon him) delivered an address on the day (of Nahr) in which he said: None of you should offer sacrifice of animals until he has completed the ('Id) prayer. Thereupon my maternal uncle said: Messenger of Allah, it is the day of meat, so it is not desirable (to keep my family in the state of longing). The rest of the hadith is the same.

Book 22, Number 4826:

    Al-Bara' reported Allah's Messenger (may peace be upon him) having said: He who observes prayer like our prayer and turns his face towards our Qibla (in prayer) and who offers sacrifices (of animals) as we do, he must not slaughter the (animal as a sacrifice) until he has completed the prayer. Thereupon my maternal uncle said: Messenger of Allah, I have sacrificed the animal on behalf of my son. The Messenger of Allah (may peace be upon him) said : This is the thing in which you have made haste for your family. He said: I have a goat with me better than two goats. Thereupon he said: Sacrifice it for that is the best.

Book 22, Number 4827:

    Al-Bara' b. 'Azib reported Allah's Messenger (may peace be upon him) having said: The first (act) with which we started our day (the day of 'Id-ul Adha) was that we offered prayer. We then returned and sacrificed the animals and he who did that in fact adhered to our Sunnah (practice). And he who slaughtered the (animal on that day before the 'Id prayer), for him (the slaughtering of animal was directed to the acquiring of) meat for his family, and there is nothing of the sort of sacrifice in it. It was Abu Burda b. Niyar who had slaughtered (the animal before the 'Id prayer). He said: I have a small lamb, of less than one year, but better than that of more than a year. Thereupon Allah's Messenger (may peace be upon him) qaid: Sacrifice it, but it will not suffice (as a sacrifice) for anyone after you.

Book 22, Number 4828:

    A hadith like this has been narrated on the authority of al-Bara' b. 'Azib through another chain of transmitters.

Book 22, Number 4829:

    al-Bara' b. 'Azib reported: Allah's Messenger (may peace be upon him) addressed us on the day of Nahr after the ('Id) prayer. The rest of the hadith is the same.

Book 22, Number 4830:

    Al-Bara' b. 'Azib reported: Allah's Messenger (may peace be upon him) addressed us on the day of Nahr and said: None should sacrifice the animal unless he has completed the ('Id) prayer. A person said: I have a milch goat of less than one year, better than two fat goats. Thereupon he said: Sacrifice it, and no goat of less than a year of age will be accepted as sacrifice after you.

Book 22, Number 4831:

    Al-Bara' b. 'Azib reported that Abu Burda slaughtered the animal as a sacrifice before the ('Id) prayer. Thereupon Allah's Apostle (may peace be upon him) said: Offer a substitute for it (since it does not absolve you of the responsibility of sacrifice). Thereupon he said: Allah's Messenger. I have nothing with me but a goat of less than six months. Shu'ba (one of the narrators) said: I think he (al-Bara' b. 'Azib also) said: And it is better than a goat of one year. Thereupon Allah's Messenger (may peace be upon him) said: Make it a substitute for that (and sacrifice it), but it will not suffice for anyone (as a sacrifice) after you.

Book 22, Number 4832:

    This hadith has been narrated on the authority of Shu'ba with the same chain of transmitters, but did not mention tht doubt (expressed in his statement) That is (the goat of less than a year) is better than a goat of more than one year.

Book 22, Number 4833:

    Anas (b. Malik) reported Allah's Messenger (may peace be upon him) having said on the day of Nahr (Sacrifice): He who slaughtered (the animal as a sacrifice) before the ('Id) prayer. should repeat it (i.e. offer another animal). Thereupon a person stood up and said: Messenger of Allah, that is the day when meat is much desired, and he also made a mention of the need of his neighbour, and perhaps Allah's Messenger (may peace be upon him) attested it. He (the person who had sacrificed the animal before the 'Id prayer) said: I have a goat of less than one year of age with me and I like it more than two fleshy goats; should I offer it as a sacrifice? He permitted him to do so. He (the narrator) said: I do not know whether this permission was granted to anyone else besides him or not. Allah's Messenger (may peace be upon him) then turned towards two rams. and he slaughtered them, and the people' came to the goats and got them distributed amongst themselves (for offering them as sacrifice).

Book 22, Number 4834:

    Anas b. Malik reported that Allah's Messenger (may peace be upon him) offered the 'Id prayer and then delivered the sermon giving the command: He who slaughtered the animal before prayer should slaughter (another animal as a sacrifice). The rest of the hadith is the same.

Book 22, Number 4835:

    Anas b. Malik reported: Allah's Messenger (may peace be upon him) addressed us on the day of 'Id al-Adha. He smelt the odour of flesh and he prohibited thern from slaughtering (the animals before the 'Id prayer), saying: He who slaughtered the animals (before the 'Id prayer) should do that again (as it is not valid as a sacrifice).

Chapter 2 : OF WHAT AGE THE ANIMAL IS TO BE SACRIFICED

Book 22, Number 4836:

    Jabir reported Allah's Messenger (may peace be upon him) as saying: Sacrifice only a grown-up animal, unless it is difficult for you, in which case sacrifice a ram (of even less than a year, but more than six months' age).

Book 22, Number 4837:

    Jabir b. 'Abdullah reported: Allah's Messenger (may peace be upon him) led us in the 'Id prayer in Medina on the Day of Sacrifice. Some persons slaughtered their animals ahead of him under the impression that Allah's Apostle (may peace be upon him) had-already offered sacrifice. Thereupon Allah's Apostle (may peace be upon him) said: Those who had slaughtered their animals ahead of him should slaughter the other ones in their stead. And they should not sacrifice the animal before Allah's Messenger (may peace be upon him) had sacrificed (his animal)

Book 22, Number 4838:

    Uqba b. 'Amir reported that Allah's Messenger (may peace be upon him) gave the gifts of goats to be distributed amongst his Companions. They sacrificed them, but a lamb of one year of age was left. (Someone) made a mention of that to the Messenger of Allah (may peace be upon him), whereupon he said: You sacrifice it.

Book 22, Number 4839:

    Amir al-Juhani reported: Allah's Messenger (may peace be upon him) distributed sacrificial animals (amongst us for sacrificing them on 'Id al-Adha). So we sacrificed them. There fell to my lot a lamb of less than one year I said: Allah's Messenger, there has fallen to my lot a lamb (Jadha'a), whereupon he said: Sacrifice that.

Book 22, Number 4840:

    This hadith has been transmitted on the authority of 'Uqba b. 'Amir al-Juhan with a slight change of wording.

Chapter 3 : IT IS MERITORIOUS TO SACRIFICE THE ANIMAL WITH ONE'S OWN HAND AND SO IS MERITORIOUS THE RECITATION OF BISMILLAH (IN THE NAME OF ALLAH) AND TAKBIR (ALLAH-O-AKBAR)

Book 22, Number 4841:

    Anas reported that Allah's Messenger (may peace be upon him) sacrificed with his own hands two horned rams which were white with black markings reciting the name of Allah and glorifying Him (saying Allah-o-Akbar). He placed his foot on their sides (while sacrificing).

Book 22, Number 4842:

    Anas reported that Allah's Messenger (may peace be upon him) sacrificed two horned rams of white colour with black markings over them. He also stated: I saw him sacrificing them with his own hand and saw him placing his foot on their sides, and recited the name of Allah and Glorified Him.

Book 22, Number 4843:

    Shu'ba reported: Qatada informed me that he had heard Anas saying that Allah's Messenger (may peace be npon him) sacrificed (the horned rams) and like that. I said: Did you (Qatada) hear from Anas? He said. Yes.

Book 22, Number 4844:

    This hadith has been transmitted on the authority of Anas with a slight variation of wording.

Book 22, Number 4845:

    'A'isha reported that Allah's Messenger (may peace be upon him) commanded that a ram with black legs, black belly and black (circles) round the eyes should be brought to him, so that he should sacrifice it. He said to 'A'isha: Give me the large knife, and then said: Sharpen it on a stone. She did that. He then took it (the knife) and then the ram; he placed it on the ground and then sacrificed it, saying: Bismillah, Allah-humma Taqabbal min Muhammadin wa Al-i-Muhammadin, wa min Ummati Muhammadin (In the name of Allah, "O Allah, accept [this sacrifice] on behalf of Muhammad and the family of Muhammad and the Umma of Muhammad").

Chapter 4 : PERMISSIBILITY OF SLAUGHTERING THE ANIMAL WITH ANYTHING WHICH MAY MAKE ITS BLOOD FLOW, EXCEPT TOOTH, NAIL AND BONE

Book 22, Number 4846:

    Rafi' b. Khadij is reported to have said: Allah's Messenger, we are going to encounter the enemy tomorrow, but we have no knives with us. Thereupon Allah's Messenger (may peace be upon him) said: Make haste or be careful (in making arrangements for procuring knives) which would let the blood flow (and along with it) the name of Allah is also to be recited. Then eat, but not the tooth or nail. And I am going to tell you why it is not permissible to slaughter the animal with the help of tooth and bone; and as for the nail. it is a bone, and the bone is the knife of Abyssinians. He (the narrator) said: There fell to our lot as spoils of war camels and goats, and one of the camels among them became wild. A person (amongst usl struck It with an arrow which brought it under control. whereupon Allah's Messenger (may peace be upon him) said: This camel became wild like wild animals, so if you find any animal getting wild, you do the same with that

Book 22, Number 4847:

    Rafi' b. Khadij reported: While we were with Allah's Messenger (may peace he upon him) in Dhu'I-Hulaifa in Tihama, we got hold of goats and camels. Some persons (amongst us) made haste and boiled (the flesh of goats and camels) in their earthen pots. He then commanded and these were turned over; then he equalised ten goats for a camel. The rest of the hadith is the same.

Book 22, Number 4848:

    Rafi' b. Khadij reported from his grandfather that he said: Allah's Messenger, we are going to encounter the enemy tomorrow, but we do not have long knives with us, should we then slaughter them with the peel of the reed? The rest of the hadith is the same. (And at the end the words are): "A camel became wild (and got out of our control). We attacked it with arrows until we made it fall down." This hadith has been narrated on the authority of Sa'id b. Masruq with the same chain of transmitters with a slight variation of words.

Book 22, Number 4849:

    Rafi' b. Khadij reported that he said: Allah's Messenger, we are going to encounter the enemy tomorrow. and we do not have large knives with us. The rest of the hadith is the same, but no mention is made of this: "The people hastened and they boiled (flesh) in the earthen pots. He (the Holy Prophet),cammanded and these were turned over and the narrator narrated the whole event.

Chapter 5 : IT WAS NOT PERMISSIBLE TO EAT THE FLESH OF SACRIFICIAL ANIMALS BEYOND THREE DAYS AT THE BEGINNING OF ISLAM, BUT THIS PROHIBITION WAS ABROGATED, AND NOW IT IS PERMISSIBLE

Book 22, Number 4850:

    Abu Ubaid reported: I was with 'Ali b. Abi Talib on the occasion of the 'Id day. He started with the 'Id prayer before delivering the sermon, and said: Allah's Messenger (may peace be upon him) forbade us to eat the flesh of our sacrificial animals beyond three days.

Book 22, Number 4851:

    Abu 'Ubaid, the freed slave of Ibn Azhar, reported that he said 'Id (prayer) with Umar b. al-Khattab, and then said the 'Id (prayer) with 'Ali b. Abu Talib. He (the narrator further) reported: He led us in prayer before delivering the sermon and then addressed the people saying: Allah's Messenger (may peace be upon him) has forbidden you to eat the flesh of your sacrificial animals beyond three nights, so do not eat that.

Book 22, Number 4852:

    This hadith has been narrated on the authority of Zuhri with the same chain of transmitters.

Book 22, Number 4853:

    Ibn 'Umar reported kllah's Apostle (may peace be upon him) having said: None of you shculd eat the flesh of his sacrificial animal beyond three days.

Book 22, Number 4854:

    This hadith has been narrated on the authority of Ibn Umar through another chain of transmitters.

Book 22, Number 4855:

    Ibn 'Umar reported that Allah's Messenger (may peace be upon him) forbade that the flesh of sacrificial animals be eaten beyond three (days) Salim (son of Ibn Umar) said: Ibn 'Umar did not eat the flesh of the sacrificial animals beyond three (days). Ibn Abu 'Umar said : "Beyond three days."

Book 22, Number 4856:

    Abdullah b. Waqid reported: Allah's Messenger (may peace be upon him) forbade (people) to cat the flesh of sacrificed animals beyond three days. Abdullah b. Abu Bakr said, I made a mention of that to 'Amra, whereupon she said: He has told the truth, for I heard 'A'isha say: The poor among the people of the desert come (to the towns) on the occasion of Id al-Adha during the lifetime of Allah's Messenger (may peace be upon him). Upon this Allah's Messenger (may peace be upon him) said: Retain with you (the flesh) sufficing for three (days), and whatever is left out of that give in charity. After this. they (the Muslims) said: Allah's Messenger, the people make waterskins with the (hides) of their sacrificed animals and they melt fat out of them. Thereupon he said. What the then? They said: You forbade (us) to eat the flesh of sacrificial animals beyond threoq (days), whereupon he said: I forbade you for those (poor persons) who flocked (to the towns on this occasion for getting meat) but now when (this situation has improved) you may eat, preserve and give -in charity.

Book 22, Number 4857:

    Jabir reported that Allah's Apostle (may peace be upon him) forbade eating of the flesh of sacrificed animals beyond three (days). but afterwards said : Eat, make a provision, and keep it.

Book 22, Number 4858:

    Jabir b. Abdullah reported : We did not eat the flesh of our sacrificial animals beyond three days in Mina. Then Allah's Messenger (may peace be upon him) permitted us saying: Eat and make it a provision (for journey). I asked 'Ata' whether Jabir had also said: Till we came to Medina. He said: Yes.

Book 22, Number 4859:

    Jabir b. 'Abdullah reported: We did not eat the flesh of sacrificed animals beyond three (days), but then Allah's Messenger (may peace be upon him) commanded us to make it a provision for journey and cat it (beyond three days).

Book 22, Number 4860:

    Jabir reported: We made provision (out of the flesh of sacrificed animals for our journey) to Medina during the lifetime of Allah's Messenger (may peace be upon him).

Book 22, Number 4861:

    Abu Sa'id al-Khudri reported Allah's Messenger (may peace be upon him) having said: O people of Medina, do not eat the flesh of sacrificed animals beyond three days. Ibn al-Muthanni said: Three days. They (the Companions of the Holy Prophet) complained to the Messenger of Allah (may peace he upon him) that they had children and servants of theirs (to feed), whereupon he said: Eat, and feed others, and store, and make it a provision of food.

Book 22, Number 4862:

    Salama b. al-Akwa' reported Allah's Messenger (way peace be upon him) having said: He who sacrifices (animal) among you nothing should be left in his house (out of its flesh) on the morning of the third day. When it was the next year they (his Companions) said: Should we do this year as we did daring the previous year? Thereupon he said: Don't do that, for that was a year when the people were hard pressed (on account of poverty). so I wanted that the (flesh) might be distributed amongst them.

Book 22, Number 4863:

    Thauban reported that Allah's Messenger (way peace be upon him) slaughtered his sacrificial animal and then said: Thauban, make his meat usable (for journey), and I continuously served him that until he arrived in Medina.

Book 22, Number 4864:

    This hadith has been narrated on the authority of Mu'awiya b. Salih with the same chain of transmitters.

Book 22, Number 4865:

    Thauban, the freed slave of Allah's Messenger (may peace be upon him), reported: Allah's Messenger (may peace be upon him) said to me on the occasion of Hajjat-al-Wada' (the Farewell Pilgrimage): Make the flesh usable. So I made it usable (for him) and he ate it constantly until he reached Medina. This hadith has been narrated on the authority of Yabya b. Hamza with the same chain of transmitters, but he did not say: On the occasion of Hajjat-al-Wada'.

Book 22, Number 4866:

    Abdullah b. Buraida reported on the authority of his father that Allah's Messenger (may peace be upon him) said this: I prohibited you from visiting the graves, but (now) you may visit them, and I prohibited you (from eating) the flesh of sacrific- ed animals beyond three days, but now keep it as long as you like. I prohibited you from the use of Nabidh except (that preoared) in dry waterskins. Now drink (Nabidh prepared in any utensil), but do not drink when it becomes intoxicant.

Book 22, Number 4867:

    Ibn Buraida, on the authority of his father, reported Allah's Messenger (may peace be upon him) having said this: I used to forbid you. The rest of the hadith is the same.

Chapter 6 : SACRIFICING OF FARA' AND 'ATIRA ARE IDOLATROUS PRACTICES

Book 22, Number 4868:

    Abu Huraira reported Allah's Messenger (may peace be upon him) as saying: (The sacrifice of Fara' and 'Atira) has no (sanction in Islam). Ibn Rafi' made this addition in his narration that Fara' means the first-born young one of a camel.

Chapter 7 : IT IS NOT PERMISSIBLE FOR ONE WHO INTENDS TO SACRIFICE THE ANIMAL TO GET ONE'S HAIR OR NAILS CUT AFTER THE BEGINNING OF DHU'L-HIJJA

Book 22, Number 4869:

    Umm Salama reported Allah's Messenger (may peace be upon him) having said this: When any one of you intending to sacrifice the animal enters in the month (of Dhu'l-Hijja) he should not get his hair or nails touched (cut). It was said to Sufyan that some of the (scholars) did not deem this hadith to be Maffu'. He said: But I deem it as Marfu' (i.e. chain of narration traceable right up to the Holy Prophet).

Book 22, Number 4870:

    Umm Salama reported Allah's Apostle (may peace be upon him) as saying: If anyone of you intends to offer sacrifice he should not get his hair cut or nails trimmed.

Book 22, Number 4871:

    Umm Salama reported (these words) directly from Allah's Messenger (may peace be upon him): If anyone has in his possession a sacrificial animal to offer as a sacrifice (on 'Id al-Adha), he should not get his hair cut and nails trimmed after he has entered the first days of Dhu'l Hijja

Book 22, Number 4872:

    This hadith has been narrated on the authority of 'Amr b. Muslim with the same chain of transmitters.

Book 22, Number 4873:

    Umm Salama, the wife of Allah's Apostle (may peace be upon him), reported Allah's Messenger (may peace be upon him) to have said: He who has a sacrificial animal with him whom (he intends) to offer as sacrifice, and he enters the month of Dhu'I-Hijja, he should not get his hair cut or nails trimmed until he has sacrificed the animal.

Book 22, Number 4874:

    'Amr b. Muslim b. 'Ammar al-Laithi reported: While we were in a bathroom just before 'Id al-Adha some of the persons tried to remove the hair with the help of hair-removing chemicals. Thereupon some of the people owning the bath (or some of the people sitting therein) said that Sa'id b. Musayyib did not approve of it, or he prohibited it. Then I met Sa'id b. Musayyib and made a mention of that to him, whereupon he said: O my nephew, this is the hadith which has been forgotten, and abandoned. Umm Salama, the wife of Allah's Apostle (may peace be upon him), narrated to me Allah's Messenger (may peace be upon him) having said as narrated above.

Book 22, Number 4875:

    Amr b. Muslim al-Jundani reported that Ibn Musayyib had told him that it was Umm Salama, the wife of Allah's Apostle (may peace be upon him), who had informed him of that as narrated above.

Chapter 8 : IT IS FORBIDDEN TO SACRIFICE THE ANIMAL FOR ANYONE BESIDES ALLAH, THE EXALTED, AND CURSE UPON ONE WHO DOES IT

Book 22, Number 4876:

    Abu Tufail 'Amir b. Withila reported: I was in the company of 'Ali b. Abi Talib, when a person came to him, and said: What was it that Allah's Apostle (may peace be upon him) told you in secret? Thereupon he (liadrat 'All) was enraged and said: Allah's Apostle (may peace be upon him) did not tell me anything in secret that he hid from people, except that he told me four things. He said: Com- mader of Faithful, what are these? He said: Allah cursed him who cursed his father; Allah cursed him who sacrificed for anyone besides Allah; and Allah cursed him who accommodates an innovator (in religion) ; and Allah cursed him who changed the minarets (the boundary lines) of the land.

Book 22, Number 4877:

    Abu Tufail reported: We said to 'Ali b. Abi Talib: Inform us about something which Allah's Messenger (may peace be upon him) told you in secret, whereupon he said: He told me nothing in secret which he bid from people, but I heard him say: Allah cursed him who sacrificed for anyone besides Allah; and cursed him who accommodated an innovator; and Allah cursed him who cursed his parents and Allah cursed him who changed the boundary lines (of the land possessed by him).

Book 22, Number 4878:

    Abu Tufail reported: 'Ali was asked whether Allah's Messenger (may peace be upon him) had showed special favour (by disclosing to him) a thing (which he kept secret from others). Thereupon he said: Allah's Messenger (may peace be upon him) singled us not for (disclosing to us) anything (secret) which he did not make public, (but those few things) which lie in the sheath of my sword. He drew out the written document contained in it and on that (it was mentioned): Allah cursed him who sacrificed for anyone else besides Allah ; and Allah cursed him who stole the signposts (demarcating the boundary lines of the) land; and Allah cursed him who cursed his father; and Allah cursed him who accommodated an innovator (in religion).


Book 23 : The Book of Drinks (KITAB AL-ASHRIBA)

KITAB Al-ASHRIBA
(THE BOOK OF DRINKS)

Back
Chapter 1 : FORBIDDANCE OF WINE

Book , Number 4879:

    'Ali b. Abu Talib reported; There fell to my lot along with Allah's Messenger (may peace be upon him) an old she-camel from the spoils of Badr. Allah's Messenger (may peace be upon him) granted me another camel. I made them kneel down one day at the door of an Ansari, and I wanted to carry on them Idhkhir (a kind of grass) in order to sell that. There was with me a goldsmith of the tribe of Qainuqa'. I saught to give a wedding feast (on the occasion of marriage with) Fatima with the help of that (the price accrued from the sale of this grass). And Hamza b. 'Abd al-Muttalib was busy in drinking in that house in the company of a singing girl who was singing to him. She said: Hamza, get up for slaughtering the fat she-camels. Hamza attacked them with the sword and cut off their humps and ripped their haunches, and then took out their livers. I said to Ibn Shihab: Did he take out anything from the hump? He said: He cut off the humps altogether. Ibn Shihab reported 'Ali having said: I saw this (horrible) sight and it shocked me, and I came to Allah's Apostle (may peace be upon him) and there was Zaid b, Haritha with him and communicated to him this news. He came in the company of Zaid and I also went along with him and he went to Hamza and he expressed anger with him. Hamza raised his eyes and said: Are you (not) but the servants of my father? Allah's Messenger (may peace be upon him) turned back on his heels (on hearing this) until he went away from them.

Book 23, Number 4880:

    This hadith has been narrated on the authority of Juraij with the same chain of transmitters.

Book 23, Number 4881:

    Husain b. 'Ali reported 'Ali having said: There fell to my lot a she-camel out of the spoils of war on the Day of Badr, and Allah's Messenger (may peace be upon him) gave me (another) she-camel on that day out of the Khums (one-fifth reserved for Allah and His Messenger). When I made up my mind to consummate my marriage with Fatima, the daughter of Allah's Messenger (may peace be upon him), I prevailed upon a goldsmith of the tribe of Qainuqa' to go along with me so that we might bring Idhkhir wishing to sell that to the goldsmiths and thus I should be able to arrange my wedding feast. While I was arranging the equipments. i.e. litters, sacks and ropes, my two she-camels were sitting down at the side of the apartment of a person of the Ansar. I collected (the different articles of equipment) and found to my surprise that their humps had been chopped off and their haunches had been cut off and their livers had been taken out. I could not help weeping when I saw that plight of theirs. I said: Who has done that? They said: Hamza b. 'Abd al-Muttalib has done this. and he is in this house dead drunk in the company of some of the Ansair with asinging girl singing before him and his companions. She said in her song: O Hamza. get up and attack these falty she-camels. Thereupon Hamza stood up with a sword (in his hand) and cut off their humps and ripped their haunches and tore out their livers. 'Ali said: I went away until I came to Allah's Messenger (may peace be upon him) and there was with him Zaid b. Haritha. Allah's Messenger (may peace be upon him) recognised from my face what I had experienced, whereupon Allah's Messenger (may peace be upon him) said: What has happened to you? I said: Messenger of Allah, by Allah, I have never seen (such an unfortunate day) as this day. Hamza has committed aggression to my she-camels, and has cut off their humps. and ripped their haunches, and he is in a house in the company of some drunkards. (Hearing this) Allah's Messenger (may peace be upon him) sent for his mantle and, putting it on him, he proceeded, and I and Zaid b. Haritha followed him, until he came to the door (of the house) in which there was Hamza. He (the Holy Prophet) sought permission which they granted him. and they were all drunk. Allah's Messenger (may peace be upon him) began to reprimand Hamza for what he had done. Hamza's eyes were red. He cast a glance at Allah's Messenger (may peace be upon him) and then looked towards his knees. and then lifted his eyes and cast a glance at his waist and then lifted his eyes and saw his face. And then Hamza said: Are you anything but the slaves of my father? Alah's Messenger (may peace be upon him) came to know that he was intoxicated, and he thus turned upon his heels, and came out, and we also came out along with him.

Book 23, Number 4882:

    Anas b. Malik reported: I was the cup-bearer of some people in the house of Abu Talha on the day when liquor was forbidden. Their liquor had been prepared from dry dates or fresh dates when the announcer made the announcement. He (Abu Talha) said to me: Go out and find out (what the announcement is). I got out (and found) an announcer making this announcement: Behold, liquor has been declared unlawful. He said: The liquor (was spilt and) flawed in the lanes of Medina. Abu Talha said to me: Go out and Spill it, and I spilt it. They said or some of them said : Such and such were killed, such and such were killed for (the wine) had been in their stomachs. He (the narrator) said.I do not know whether it is the narration transmitted by Anas, (or by someone else). Then Allah, the Exalted and Majestic, revealed : "There shall be no sin (imputed) unto those who have believed and done good works for what they may have eaten as long as they fear (Allah) and believe and do good works" (v. 93).

Book 23, Number 4883:

    'Abd al-Aziz b. Suhaib reported: They (some persons) asked Anas b. Malik, about Fadikh (that is, a wine prepared from fresh dates), whereupon he said: There was no liquor with us except this Fadikih of yours. It was only this Fadikh that I had been serving to Abu Talha and Abu Ayyub and some persons from amongst the Companions of the Messenger of Allah (may peace be upon him) in our house. When a person came and said: Has the news reached you? We said, No. He said: Verily liquor has been declared forbidden. Thereupon, Abd Talha said: Anas, spill these large pitchers. He (the narrator) said: They then never reverted to it, nor even asked about this after the announcement by that person.

Book 23, Number 4884:

    Anas b. Malik reported: I was standing amongst the uncles of my tribe serving them Fadikh while I was the youngest of them, when a person came and said: Verily the use of liqour has been prohibited. They said : Anas, spill it away. So I spilt it. He (one of the narrators. Sulaiman Taimi) said that he asked Anas what that was (the Fadikh). He said: It had been prepared from unripe and ripe dates. Abu Bakr b. Anas said: It was their liquor in those days. Sulaiman said: A person narrated it to me from Anas b. Malik that he had said so.

Book 23, Number 4885:

    Anas reported: I was standing amongst the members of my (tribe) and serving them liquor. The rest of the hadith is the same, but with this variation that Abu Bakr b. Anas said: It was their liquor in those days (prepared from dates), and Anas was present there and he did not deny this (fact) Mu'tamir reported on the authority of his father: A person who was with me told me that he had heard Anas saying that that was their liquor in those days.

Book 23, Number 4886:

    Anas b. Malik reported I was serving wine to Abu Talha, and Abu Dujana. and Mu'adh b. jabal admidst a group of Ansar when a visitor came to us and said There is a fresh news ; the (verses) concerning the prohibition of liquor have been revealed. So we spilt it on that day ; and it was a mixture of dry dates and fresh dates. Anas b. Malik said: Whil Khamr was declared unlawful, the common liquor of theirs was then a mixture of dry dates and fresh dates.

Book 23, Number 4887:

    Anas b. Malik said: I was serving wine to Abu Talha, Abu Dujana, and Suhail b. Baida' from a waterskin which contained the mixture of unripe dates and fresh dates. The rest of the hadith is the same.

Book 23, Number 4888:

    Anas b. Malik is reported to have said that Allah's Messenger (may peace be upon him) had forbidden to mixture fresh dates and unripe dates and then drinking (the wine prepared out of it), and that was their common intoxicant when liquor was prohibited.

Book 23, Number 4889:

    Anas b. Malik reported: I was serving drink to Abu 'Ubaida b. jarrah, Abu Talha and Ubayy b. Ka'b prepared from unripe dates and fresh dates when a visitor came and he said: Verily liquor has been prohibited. Thereupon, Abu Talha said: Anas, stand up and break this pitcher. I stool up and (took hold) of a pointed stone and struck the pitcher with its lower part until it broke into pieces.

Book 23, Number 4890:

    Anas b. Malik reported : Allah revealed the verse in which Allah prohibited the use of liquor. In those days no other liquor was drunk but that prepared from dates.

Chapter 2 : IT IS FORBIDDEN TO PREPARE VINEGAR FROM KHAMR (WINE)

Book , Number 4891:

    Anas reported that Allah's Messenger (may peace be upon him) was asked about the use of Khamr from which vinegar is prepared. He said: No (it is prohibited).

Chapter 3 : IT IS FORBIDDEN TO USE WINE AS A MEDICINE

Book 23, Number 4892:

    Wa'il al-Hadrami reported that Tariq b. Suwaid a-Ju'fi asked Allah's Apostle (may peace be upon him) about liquor. He forbade (its use) and he expressed hatred that it should be prepared. He (Tariq) said: I prepare it as a medicine, whereupon he (the Holy Prophet) said: It is no medicine, but an ailment.

Chapter 4 : THE WINE WHICH IS PREPARED FROM DATES AND GRAPES IS ALSO KHAMR

Book 23, Number 4893:

    Abu Huraira reported Allah's Messenger (may peace be upon him) having said: Wine is prepared from the (fruit) of these two trees-date-palm and vine.

Book 23, Number 4894:

    This hadith has been narrated on the authority of Abu Huraira through a different chain of transmitters.

Book 23, Number 4895:

    Abu Huraira reported Allah's Messenger (may peace be upon him) as saying: Wine comes from vine and date-palms. Abu Kuraib has narrated it with a slight variation of words.

Chapter 5 : IT IS NOT APPROVED TO PREPARE NABIDH BY MIXING DRY DATES AND GRAPES

Book 23, Number 4896:

    Jabir b. 'Abdullah al-Ansari reported that Allah's Messenger (may peace upon him) prohibited the mixing of grapes and fresh dates, and dry dates and fresh dates.

Book 23, Number 4897:

    Jabir b. 'Abdullah al-Ansari reported that Allah's Messenger (may peace be upon him) prohibited the (preparation of) Nabidh by mixing together fresh dates and grapes, and he prohibited the preparation of Nabidh by mixing the fresh dates and unripe dates together.

Book 23, Number 4898:

    Jabir b. Abdullah reported Allah's Messenger (may peace be upon him) as saying: Do not mix fresh dates and dry dates, and grapes and fresh dates for preparing Nabidh.

Book 23, Number 4899:

    Jabir b. Abdullah al-Ansari reported that Allah's Messenger (may peace be upon him) Prohibited the preparation of Nabidh by mixing grapes and fresh dates. and he forbade the preparation of Nabidh by mixing unripe dates with fresh dates.

Book 23, Number 4900:

    Abu Sa'id reported that Allah's Apostle (may peace be upon him) prohibited that fresh dates and grapes be mixed together and that fresh dates and unripe dates be mixed together.

Book 23, Number 4901:

    Abu Sa'id reported that Allah's Messenger (may peace be upon him) prohibited us to mix grapes and dry dates together and unripe dates and dry dates (to prepare Nabidh.

Book 23, Number 4902:

    This hadith is narrated on the authority of Abi Maslama with the same chain of transmitters.

Book 23, Number 4903:

    Abu Sa'id al-Khudri reported Allah's Messenger (may peace be upon him) as saying: He who amongst you drinks Nabidh should drink that (prepared either from) grapes alone, or from dates alone, or from unripe dates alone (and not by mixing them with one another).
    Isma'il b. Muslim al-'Abadi reported on the authority of the same chain of transmitters: Allah's Messenger (may peace be upon him) prohibited us that we should mix dry dates with unripe dates or (mix) grapes with dry dates (and prepare Nabidh). He also said: He who amongst you drinks-the rest of the hadith is the same.

Book 23, Number 4904:

    Abu Qatada, on the authority of his father, reported Allah's Messenger (may peace be upon him) having said this: Do not prepare Nabidh by mixing nearly ripe dates and fresh dates together, and do not prepare Nabidh by mixing grapes and dates together, but prepare Nabidh from each (one of them) separately.

Book 23, Number 4905:

    This hadith has been narrated on the authority of Yahya b. Abu Kathir with the same chain of transmitters.

Book 23, Number 4906:

    Abu Qatada reported Allah's Messenger (may peace be upon him) as saying: Do not prepare Nabidh by mixing nearly ripe and fresh dates and do not prepare Nabidh by mixing together fresh dates and grapes, but prepare Nabidh out of each (one of them) separately. Yahya stated that he had met 'Abdullah b. Abu Qatada and he narrated it on the authority of his father that Allah's Apostle (may peace be upon him) said this. This hadith has been narrated on the authority of Yahya b. Abu Kathir through these two chains of transmitters but with a slight variation of words.

Book 23, Number 4907:

    'Abdullah b. Abu Qatada, on the authority of his father, reported Allah's Apostle (may peace be upon him) forbidding the preparation of the mixture of ripe dates and unripe dates, and the mixture of grapes and dates, and that of nearly ripe dates and fresh dates but the Prophet said: Prepare the Nabidh from each one of them separately.

Book 23, Number 4908:

    This hadith is narrated on the authority of Abu Qatada through another chain of transmitters.

Book 23, Number 4909:

    Abu Huraira reported that Allah's Messenger (may peace be upon him) forbade (the preparation of Nabidh) from grapes and dates, and unripe dates and dry dates (by mixing them together). He (the Holy Prophet also) said: Prepare Nabidh from each one of them separately. This hadith has been narrated on the authority of Abu Huraira through another chain of transmitters.

Book 23, Number 4910:

    Ibn 'Abbas reported that Allah's Apostle (may peace be upon him) forbade the mixing of dates and grapes together, and mixing of unripe dates and ripe dates together (for preparing Nabidh), and he wrote to the people of Jurash (in Yemen) forbidding them to prepare the mixture of dates and grapes. This hadith has been narrated through another chain of transmitters with a slight variation of words.

Book 23, Number 4911:

    Ibn Umar reported that he was forbidden to prepare Nabidh by mixing unripe dates and fresh dates, and dates with grapes.

Book 23, Number 4912:

    Ibn 'Umar reported that they were forbidden to prepare Nabidh by mixing dry dates and fresh dates and dates and grapes together.

Chapter 6 : IT IS FORBIDDEN TO PREPARE NABIDH IN VARNISHED JAR, GOURD, GREEN PITCHER, AND HOLLOW STUMPS

Book 23, Number 4913:

    Anas b. Malik reported that Allah's Messenger (may peace be upon him) forbade the preparation of Nabidh in gourd or varnished jar.

Book 23, Number 4914:

    Abu Huraira reported Allah's Messenger (may peace be upon him) as saying: Do not prepare Nabidh in gourd or jar or in a pitcher besmeared with pitch (known as green pitcher).

Book 23, Number 4915:

    Abu Huraira reported that Allah's Apostle (may peace be upon him) forbade (the preparation of Nabidh) in varnished jar, pitcher besmeared with green pitch and hollow stump. It was said to Abu Huraira: What that Hantama was ? He said: It is green pitcher (besmeared with pitch).

Book 23, Number 4916:

    Abu Huraira reported that Allah's Apostle (may peace be upon him) said to the group of Abd al-Qais: I forbid you (to prepare Nabidh) in gourd. and green pitcher, hollow stump and varnished jar and the waterskin having its upper end cut, but (prepare it) in your small waterskin, and tie its mouth

Book 23, Number 4917:

    'Ali reported that Allah's Messenger (may peace be upon him) forbade to prepare Nabidh in gourd and varnished jar. This hadith has been narrated through another chain of transmitters with a slight variation of wording.

Book 23, Number 4918:

    Ibrahim reported: I said to Aswad if he had asked the Mother of the Believers (in which utensils) he (the Holy Prophet) disapproved the preparation of Nabidh. He (Aswad) said: Yes. I said: Mother of the Believers, inform me about the utensils in which) Allah's Apostle forbade to prepare Nabidh. She (Hadrat 'A'isha) said: He forbade us, the members of his family, to prepare Nabidh in gourd, or varnished jar. I said to him: Do you remember green pitcher, and pitcher? He said: I narrated to you what I have heard; should I narrate to you which I did not hear?

Book 23, Number 4919:

    'A'isha reported that Allah's Apostle (may peace be upon him) forbade (the preparation) of Nabidh in gourd and varnished jar.

Book 23, Number 4920:

    Thumama b. Hazn Al-Qushairi reported: I met 'A'isha and asked her(about the utensils in which) Nabidh (may be prepared). She narrated to me that a group of 'Abd al-Qais came to Allah's Apostle (may peace be upon him) and asked: Allah's Apostle (may peace be upon him) about Nabidh. He (the Holy Prophet) forbade them to prepare Nabidh in varnished jar, hollow stumps and gourd and green pitcher.

Book 23, Number 4921:

    'A'isha reported Allah's Messenger (may peace be upon him) forbidding (the preparation of Nabidh) in varnished jar, green pitcher, gourd, and hollow stump,

Book 23, Number 4922:

    This hadith has been narrated on the authority of Ishaq b. Suwaid, with a slight variation of wording.

Book 23, Number 4923:

    Ishaq b. Suwaid reported through the same chain of transmitters but for the difference that he substituted the word "gourd" for "waterskin" (meant for preserving wine).

Book 23, Number 4924:

    Ibn 'Abbas reported that there came to Allah's Messenger (may peace be upon him) a group of people from the tribe of 'Abd al-Qais. Allah's Messenger (may peace be upon him) said to them: I forbid you to prepare Nabidh in gourd, in pitcher besmeared with pitch, in hollow stump and in waterskin (meant for preserving wine). In the hadith transmitted on the authority of Hammad the word. "gourd" has been used in place of "waterskin".

Book 23, Number 4925:

    Ibn 'Abbas reported that Allah's Messenger (may peace be upon him) forbade the (preparation of Nabidh) in gourd in pitcher besmeared with pitch, in varnished jar, and in hollow stumps.

Book 23, Number 4926:

    Ibn Abbas reported that Allah's Messenger (may peace be upon him) forbade, the preparation of Nabidh in gourd, in varnished jar, hollow stump and from mixing up ripe dates with nearly ripe dates.

Book 23, Number 4927:

    Ibn 'Abbas reported that Allah's Messenger (may peace be upon him) forbade (preparation) of Nabidh in gourd, in hollow stump and in varnished jar.

Book 23, Number 4928:

    Abu Sa'id reported that Allah's Messenger (may peace be upon him) forbade (the preparation) of Nabidh in a green pitcher (besmeared with pitch).

Book 23, Number 4929:

    Abu Sa'id Khudri reported that Allah's Messenger (may peace be upon him) forbade (the preparation) of Nabidh in gourd, in pitcher besmeared with green pitch, in hollow stump and in varnished jar.

Book 23, Number 4930:

    This hadith has been reported on the authority of Qatada with the same chain of transmitters that Allah's Apostle (may peace be upon him) forbade (the preparation of) Nabidh, the rest of the hadith is the same.

Book 23, Number 4931:

    Abu Sa'id reported that Allah's Messenger (may peace be upon him) forbade drinking in green pitcher, in gourd and in the hollow stump.

Book 23, Number 4932:

    Sa'id b. Jubair reported: I bear testimony to the fact that Ibn 'Umar and Ibn 'Abbas testified to the fact that Allah's Messenger (may peace be upon him) forbade (the preparation) of Nabidh in gourd in vessel besmeared with pitch and hollow stump.

Book 23, Number 4933:

    Sa'id b. Jubair reported: I asked Ibn 'Umar about (the preparation of) Nabidh in a green pitcher (besmeared with pitch), whereupon he said that Allah's Messenger (may peace be upon him) forbade the (preparation of) Nabidh in green pitcher (besmeared with pitch). I then came to Ibn Abbas and said: Do you hear what Ibn 'Umar has said? Thereupon he said: What does he say? I said: He stated that Allah's Messenger (may peace be upon him) has forbidden the (preparation of) Nabidh in a green pitcher (besmeared with pitch), whereupon he said: Ibn 'Umar has told the truth. Allah's Messenger (may peace be upon him) declared unlawful the preparation of Nabidh in a green pitcher (besmeared with pitch). I said: What is this thing, the Nabidh of a pitcher (Nabidh prepared in a pitcher)? Thereupon, he said: Everything that is prepared in earthen pitcher.

Book 23, Number 4934:

    Ibn 'Umar reported: Allah's Messenger (may peace be upon him) addressed people in one of his expeditions. Ibn 'Umar said: I went forward to him but he went away before I reached him. I asked (the people present there): What did he say? They said that he (the Holy Prophet) had forbidden the preparation of Nabidh in gourd and varnished jar.

Book 23, Number 4935:

    This hadith has been reported on the authority of Ibn 'Umar with different chains of transmitters but they have not mentioned: "In one of his expeditions" except Malik and Usama.

Book 23, Number 4936:

    Thabit reported: I said to Ibn 'Umar that Allah's Messenger (may peace be upon him) had forbidden the preparation of Nabidh in the green pitcher (besmeared with pitch). He said: This is what they stated. I said: Did Allah's Messenger (may peace be upon him) forbid this? He said: They said so.

Book 23, Number 4937:

    A person asked Ibn 'Umar if the Apostle of Allah (may peace be upon him) forbade the preparation of Nabidh in a green pitcher (besmeared with pitch). He said: Yes. Then Tawus said: By Allah, I heard it from him.

Book 23, Number 4938:

    Ibn 'Umar reported that a person came to him and said: Did Allah's Apostle (may peace be upon him) forbid the preparation of Nabidh in a green pitcher (besmeared with pitch and) in varnished jar? He said: Yes.

Book 23, Number 4939:

    Ibn 'Umar reported that Allah's Messenger (may peace be upon him) forbade (the preparation) of Nabidh in a green pitcher (besmeared with pitch) and in varnished jar.

Book 23, Number 4940:

    Ibrahim b. Maisarah reported that he heard Tawus as saying: I was sitting with Ibn 'Umar when a man came to him, and said: Did Allah's Messenger (may peace be upon him) forbid the preparation of Nabidh in a green pitcher (besmeared with pitch), in varnished jar and in gourd? Thereupon he said: Yes.

Book 23, Number 4941:

    Muharib b. Dithar reported: I heard Ibn 'Umar say: Allah's Messenger (may peace be upon him) forbade (the preparation of Nabidh) in a pitcher besmeared with pitch, in gourd, in varnished jar. He said, I heard it from him more than once.

Book 23, Number 4942:

    Muharib b. Dithar reported a hadith like this on the authority of Ibn 'Umar through a different chain of transmitters. He (the narrator) said: I think he also made a mention of hollow stump.

Book 23, Number 4943:

    'Uqba b. Huraith said: I heard Ibn 'Umar saying : The Messenger of Allah (may peace be upon him) forbade (the preparation of Nabidh) in a green pitcher (besmeared with pitch), in varnished jar, and in gourd, and he said: Prepare Nabidh in small waterskins.

Book 23, Number 4944:

    Jabalah reported: I heard Ibn 'Umar narrating that Allah's messenger (may peace be upon him) had forbidden (the preparation of Nabidh) in the pitcher besmeared with pitch. I said to him: What is Huntama? He said: It is a pitcher (besmeared with pitch).

Book 23, Number 4945:

    Zadhan reported: I said to Ibn 'Umar: Tell me in your own language and then explain it to me in any language because your language is different from our language (about the vessels) in which Allah's Apostle (may peace be upon him) has forbidden (us) to drink. He said: Allah's Messenger (may peace be upon him) has forbidden (the preparation) of Nabidh in Hantama and that is a pitcher (besmeared with pitch), in gourd and that is pumpkin, in the varnished jar, in hollow stump and in wooden vessels. This Naqir is the wood of date-palm from which the vessel is fashioned out or hollowed out, but he commanded us to prepare Nabidh in waterskins.

Book 23, Number 4946:

    This hadith has been narrated on the authority of Shu'ba with the same chain of transmitters.

Book 23, Number 4947:

    Sa'id b. Musayyib reported: I heard 'Abdullah b 'Umar saying this near the pulpit while pointing towards the pulpit of Allah's Messenger (may peace be upon him): A group of the tribe of 'Abd al-Qais came to Allah's Messenger (may peace be upon him) and asked him about (vessels) which might (be used for preparing Nabidh and) drinking in them. He (the Holy Prophet) forbade them (to use) gourd, hollow stump, vessel besmeared with pitch. I said to him: Abu Muhammad, (what about) varnished jar ? and we think he had forgotten to mention the word 'varnished jar". Thereupon he said: I did not hear it from him on that day, i.e. from 'Abdullah b. 'Umar, and he hated that (i.e. preparation of Nabidh in gourd).

Book 23, Number 4948:

    It is reported on the authority of Jabir and Ibn Umar that Allah's Messenger (may peace be upon him) forbade (the preparation) of Nabidh in hollow stump and varnished jar and gourd.

Book 23, Number 4949:

    Jabir b. 'Abdullah reported that Allah's Messenger (may peace be upon him) forbade (the preparation) of Nabidh in green pitcher, in varnished jar, in hollow stump, and when Allah's Messenger (may peace be upon him) did not find anything to prepare Nabidh in that (i.e. waterskin), it was prepared for him in a big bowl made of stone.

Book 23, Number 4950:

    This hadith is reported on the authority of Jabir b. Abdullah that Nabidh was prepared for him in a big bowl of stone.

Book 23, Number 4951:

    Jabir reported that Nabidh was prepared for Allan's Messenger (may peace be upon him) in a waterskin, but if they did not find waterskin it was prepared in a big bowl of stone. One of the persons and I had heard from Abu Zubair that it was Biram (a vessel made of stone).

Book 23, Number 4952:

    'Abdullah b. Buraida, on the authority of his father, reported Allah's Messenger (may peace be upon him) as saying: I had forbidden you from the preparation of Nabidh except in a waterskin. But now you may drink in all vessels, but do not drink what is intoxicant.

Book 23, Number 4953:

    Ibn Buraida, on the authority of his father, reported Allah's Messenger (may peace be upon him) as saying: I had forbidden you (from the preparation of Nabidh) and drinking it in certain vessels, (but now you may do so if you like) for it is not vessels or a vessel that makes a thing lawful or unlawful. It is every intoxicant that is unlawful.

Book 23, Number 4954:

    Ibn Buraida, on the authority of his father, reported Allah's Messenger (may Peace be upon him) as saying: I had forbidden you from the drinking (and preparation of) Nabidh in the vessels made out of leather, but (now) you may drink in all vessels, but you do not drink an intoxicant.

Book 23, Number 4955:

    'Abdullah b. 'Amr reported that when Allah's Messenger (may peace be upon him) forbade (the preparation) of Nabidh in vessels, they said all the people cannot (afford to have) them. He (the Holy Prophet) then granted them permission (to prepare) Nabidh in a green pitcher, but not in those besmeared with pitch.

Chapter 7 : EVERY INTOXICANT IS KHAMR AND EVERY KHAMR IS FORBIDDEN

Book 23, Number 4956:

    'A'isha reported: Allah's Messenger (may peace be upon him) was asked about Bit, whereupon he said: Every drink that causes intoxication is forbidden.

Book 23, Number 4957:

    'A'isha reported that Allah's Messenger (may peace be upon him) was asked about it, whereupon he said that everything that causes intoxication is forbidden.

Book 23, Number 4958:

    This hadith has been reported on the authority of Zuhri with this chain of transmitters but in the hadith transmitted on the authority of Sufyan and Salih (these words are not found) "she was asked about Bit". (These words are found in the hadith) transmitted on the authority of Ma'mar and in the hadith transmitted on the authority of Salih (only these words are found) that she (Hadrat 'A'isha) had heard Allah's Messenger (may peace be upon him) say: Every intoxicating drink is forbidden.

Book 23, Number 4959:

    Abu Musa reported: Allah's Apostle (may peace be upon him) sent me and Mu'adh b. Jabal to Yemen. I said: Allah's Messenger, there is prepared in our land a wine out of barley which is known as Mizr (beer of our times) and a wine from honey which is known as Bit, (are these also forbidden?), whereupon he said: Every intoxicant is forbidden.

Book 23, Number 4960:

    Abu Burda reported on the authority of his grandfather that Allah's Messenger (may peace be upon him) sent him and Mu'adh b. Jabal to Yemen and said to them : Give good tidings to the (people). and make things easy (for them), teach (them), and do not repel (them); and I think he also said: Cooperate cheerfully with each other. When he (the Holy Prophet) turned his back, Abu Musa returned to him and said: Allah's Messenger, they (the people of Yemen) have a drink which is (made) from honey and which is prepared by cooking it until it coagulates, and Mizr is prepared from barley, whereupon Allah's Messenger (may peace be upon him) said: Every intoxicant that detains you from prayer is forbidden.

Book 23, Number 4961:

    Abu Burda reported on the authority of his father: Allah's Messenger (may peace be upon him) sent me and Mu'adh to Yemen saying: Call people (to the path of righteousness) and give good tidings to the (people), and do not repel them, make things easy for them and do not make things difficult. I (Burda) said: Allah's Messenger, give us a religious verdict about two kinds of drinks which we prepare in Yemen. One is Bit' which is prepared from honey; it is a fermented Nabidh and is strong and turns into wine, and (the second is) Mizr which is prepared from millet and barley. Thereupon, Allah's Messenger (may peace be upon him), who had been gifted with the most eloquent and pithy expressions, said: I forbid you from every intoxicant that keeps you away from prayer.

Book 23, Number 4962:

    Jabir reported that a person came from Jaishan, a town of Yemen, and he asked Allah's Apostle (may peace be upon him) about the wine which was drunk in their land and which was prepared from millet and was called Mizr. Allah's Messenger (may peace be upon him) asked whether that was intoxicating. He said: Yes. Thereupon Allah's Messenger (may peace be upon him) said: Every intoxicant is forbidden. Verily Allah the Exalted and Majestic, made a covenant to those who drank intoxicants to make their drink Tinat al-Khabal. They said: Allah's Messenger, what is Tinat a]-Khabal? He said : It is the sweat of the denizens of Hell or the discharge of the denizens of Hell.

Book 23, Number 4963:

    Ibn 'Umar reported Allah's Messenger (may peace be upon him) as saying: Every intoxicant is Khamr and every intoxicant is forbidden. He who drinks wine in this world and dies while he is addicted to it, not having repented, will not be given a drink in the Hereafter.

Book 23, Number 4964:

    Ibn 'Umar, through another chain of transmitters; reported Allah's Messenger (may peace be upon him) having said this: Every intoxicant is Khamr and every intoxicant is forbidden.

Book 23, Number 4965:

    This hadith has been narrated on the authority of Musa b. Uqba with the same chain of transmitters.

Book 23, Number 4966:

    Nafi' reported Ibn 'Umar as saying: I do not know this but from Allah's Apostle (may peace be upon him) who said: Every intoxicant is Khamr and every Khamr is forbidden.

Book 23, Number 4967:

    Ibn 'Umar reported Allah's Messenger (may peace be upon him) as saying: He who drank (wine) in this world would be deprived of it in the Hereafter.

Book 23, Number 4968:

    Ibn 'Umar said: He who drank wine in the world and did not repent would be deprived of it (the pure drink) in the Hereafter. It was said to Malik: Is this hadith Marfu'? He said: Yes.

Book 23, Number 4969:

    Ibn 'Umar reported Allah's Messenger (may peace be upon him) as saying: He who drank wine in this world will not be provided with pure drink in the Hereafter, except in case he repents.

Book 23, Number 4970:

    Ibn 'Umar reported this hadith from Allah's Messenger (may peace be upon him) through another chain of transmitters.

Chapter 8 : PERMISSIBILITY TO USE NABIDH WHICH IS NOT STRONG AND HAS NOT TURNED INTO INTOXICANT

Book 23, Number 4971:

    Ibn 'Abbas reported that Nabidh was prepared for Allah's Messenger (may peace be upon him) in the beginning of the night and he would drink it in the morning and the following night and the following day and the night after that up to the afternoon. If anything was left out of that he gave it to his servant, or gave orders for it to be poured out.

Book 23, Number 4972:

    Ibn 'Abbas reported that Nabidh was prepared for Allah's Messenger (may peace be upon him) in the waterskin, Shu'ba said: It was the night of Monday. He drank it on Monday and on Tuesday up to the afternoon, and If anything was left out of it he gave it to his servant or poured it out.

Book 23, Number 4973:

    Ibn Abbas reported that raisins were steeped in water for the Messenger of Allah (may peace be upon him) and he would drink it on that day and on the next day and on the following day until the evening of the third day. He would then order it to be drunk by (other people) or to be thrown away.

Book 23, Number 4974:

    Ibn Abbas reported that Nabidh was prepared from raisins for Allah's Messenger (may peace be upon him) in the waterskin and he would drink it on that day and on the next day and the day following and when It was the evening of the third day, and he would drink it and give it to (his Companions) and if something was left over, he threw that away.

Book 23, Number 4975:

    Yahya Abu 'Umar al-Nakhai reported that some people asked Ibn Abbas about the sale and purchase of wine and its commerce. He asked (them): Are you Muslims? They said, Yes. Thereupon he said: Its sale and purchase and its trade are not permissible. They then asked him about Nabidh and he said: Allah's Messenger (may peace be upon him) went out on a journey and then came back and some persons amongst his Companions prepared Nabidh for him in green pitcher, hollow stump and gourd. He commanded it to be thrown away, and it was done accordingly. He then ordered them (to prepare it.) in a waterskin and it was prepared in that by steeping raisins in water, and it was prepared in the night. In the morning he drank out of that and on that day and then the next night, and then on the next day until the evening. He drank and gave others to drink. When it was morning (of the third night) he commanded what was left of that to be thrown away.

Book 23, Number 4976:

    Thumama (i.e. Ibn Hazn al-Qushairi) reported: I met 'A'isha and asked her about Nabidh (that was served to the Holy Prophet). 'A'isha called an Abyssinian maid (servant) and said: Ask her (about it) for it was he, who prepared the Nabidh for the Messenger of Allah (may peace be upon him). The Abyssinian (maid-servant) said: I prepared Nabidh for him in a waterskin in the night and tied its mouth and then suspended it; and when it was morning he (the Holy Prophet) drank from it.

Book 23, Number 4977:

    'A'isha reported: We prepared Nabidh for Allah's Messenger (may peace be upon him) in a waterskin, the upper part of which was tied and it (the waterskin) had a hole (in its lower part). We prepared the Nabidh in the morning and he drank it in the evening and we prepared the Nabidh in the night, and he would drink it in the morning.

Book 23, Number 4978:

    Sahl b. Sa'd reported that Abu Usaid al-Sa'idi invited Allah's Messenger (may peace be upon him) to his wedding feast, and his wife had been serving them on that day while yet a bride. Sahl said ' Do you know what she served as a drink to Allah's Messenger (may peace be upon him)? She steeped the dates in water during the night in a big bowl, and when he (the Holy Prophet) had eaten food she served him this drink.

Book 23, Number 4979:

    Sahl reported that Abu Usaid al-Sa'idi came to Allah's Messenger (may peace be upon him); the rest of the hadith is the same, but he did not mention this: when he had eaten (the food) she gave him this to drink".

Book 23, Number 4980:

    Sahl b. Sa'd reported (this hadith through another chain of transmitters) and he said (these words): "In a big bowl of stone, and when Allah's Messenger (may peace be upon him) had taken the food, she drenched the dates and served (this) especially to him."

Book 23, Number 4981:

    Sahl b. Sa'd reported: An Arab woman was mentioned before Allah's Messenger (may peace be upon him). He commanded Abu Usaid to send a message to her and he (accordingly) sent a message to her. She came and stayed in the fortresses of Banu Sa'idah. Allah's Messenger (may peace be upon him) went out until he came to her while she was (at that time) sitting with her head downcast. When Allah's Messenger (may peace be upon him) talked to her, she said: I seek refuge with Allah from you. Thereupon he said : I (have decided to) keep you away from me. They (the people near her) said: Do you know who he is? She said: No. They said: He is the Messenger of Allah (may peace be upon him). He came to you in order to give you the proposal of marriage. She said: Then I am the most unfortunate woman because of this (i.e. my defiance). Sahl said: Allah's. Messenger (may peace be upon him) then set forth on that day until he sat in the Saqifa of Banu Sa'idah along with his Companions. He then said to Sahl : Serve us drink. He (Sahl) said: I brought out for them this bowl (containing drink) and served them this. Abu Hazim said: Sahl brought out this cup for us and we also drank from that. Then 'Umar b. 'Abd al-'Aziz asked him to give that (cup) as a gift to him and he gave (it to) him as a gift. In the narration of Abu Bakr b. Ishaq (the words) are: "Sahl, serve us drink."

Book 23, Number 4982:

    Anas reported: I served drink to Allah's Messenger (may peace be upon him) in this cup of mine: honey, Nabidh, water and milk.

Chapter 9 : IT IS GOOD TO DRINK MILK

Book 23, Number 4983:

    Abu Bakr Siddiq reported: As we went along with Allah's Messenger (may peace be upon him) from Mecca to Medina, we passed by a shepherd and Allah's Messenger (may peace be upon him) was feeling thirsty. He (Abu Bakr Siddiq) said: I milked for him a small quantity of milk (from his goat) and brought it to him (the Holy Prophet), and he drank it and I was very happy.

Book 23, Number 4984:

    Al-Bara' reported: When Allah's Messenger (may peace be upon him) went forth from Mecca to Medina, Suraqa b. Malik b. Ju'shum pursued him. Allah's Messenger (may peace be upon him) invoked curse upon him, and his horse sank (in the desert). He (Suraqa) said: (Allah's Messenger), invoke blessings for me and I will do no harm to you. He (the Holy Prophet) then supplicated Allah. (At that time) he (the Holy Prophet) felt thirsty, and they happened to pass by a shepherd. Abu Bakr Siddiq said: I took hold of a bowl and milked some milk into it for Allah's Messenger (may peace be upon him) and gave it to him. He drank it and I was pleased.

Book 23, Number 4985:

    Abu Huraira reported that Allah's Messenger (may peace be upon him) was presented two cups at Bait al-Maqdis on the night of Heavenly Journey, one containing wine and the other containing milk. He looked at both of them, and be took the one containing milk, whereupon Gabriel (peace be upon him) said : Praise is due to Allah Who guided you to the true nature; had you taken the one containing wine, Your Umma would have gone astray.

Book 23, Number 4986:

    This hadith is narrated on the authority of Abu Huraira through another chain of transmitters, but he did not mention Aelia (Capitolina. i.e. Bait al-Maqdis).

Chapter 10 : COMMAND PERTAINING TO THE COVERING OF VESSELS, AND TIGHTENING (THE MOUTHS) OF WATERSKINS, ETC.

Book 23, Number 4987:

    Abu Humaid Sa'idi reported: I came to Allah's Messenger (may peace be upon him) with a cup of milk from Naqi' which had no cover over it, whereupon he said: Why did you not cover it ? - even if you had covered it only with a stick. Abu Humaid said that he had been ordered that waterskins be tied during the night, and the doors be closed during the night.

Book 23, Number 4988:

    Abu Humaid Sa'idi reported through another chain of transmitters that he brought to Allah's Messenger (may peace be upon him) a cup containing milk, but there is no mention of the word "in the night

Book 23, Number 4989:

    Jabir b 'Abdullah reported: We were with Allah's Messenger (may peace be upon him) and lie asked for water. A person said: Allah's Messenger, may we not give you Nabidh to drink? He (the Holy Prophet) said: Yes (you may). He (the narrator) said : Then that person went out speedily and brought a cup containing Nabidh, whereupon Allah's Messenger (may peace be upon him) said: Why did you not cover it ? - even if it is with a wood. He said that then he drank it.

Book 23, Number 4990:

    Jabir reported that a person who was known as Abu Humaid brought for him (the Holy Prophet) a cup of milk from al-Naqi'. Allah's Messenger (may peace be upon him) said to him: Why did you not cover it even with a wood across it?

Book 23, Number 4991:

    Jabir reported Allah's Messenger (may peace be upon him) as saying: Cover vessels, waterskins, close the doors and extinguish the lamps, for the Satan does not loosen the waterskin, does not open the door and does not uncover the vessels. And if one amongst you fails to find (something) to cover it well, he should cover it by placing (a piece of) wood across it. Qutaiba did not mention the closing of the doors in the hadith transmitted by him.

Book 23, Number 4992:

    This hadith is reported on the authority of Jabir but with a slight change of wording, and he did not mention the words: "Putting a stick across the vessel. "

Book 23, Number 4993:

    Jabir reported Allah's Messenger (may peace be upon him) as saying: Shut the doors; the rest of the hadith is the same but with a slight variation of wording: Cover the utensils, and further said: It (the mouse) may set fire to the clothes of the residents of the house.

Book 23, Number 4994:

    This hadith has been reported on the authority of Jabir through another chain of transmitters but with a slight variation of words: "The mouse may set the house on fire over its inhabitants."

Book 23, Number 4995:

    Jabir b. 'Abdullah reported Allah's Messenger (may peace be upon him) having said: When the wings of the night (spread) or it is night, restrain your children (from going out), for the Satan is abroad at that time, and when a part of the night is passed, free them and shut the doors. making mention of God's name, for the Satan does not open a closed door; and tighten the (mouths of waterskins and mention the name of Allah, cover your utensils and mention the name of Allah even though you should just put something on them, and extinguish your lamps.

Book 23, Number 4996:

    This hadith has been narrated on the authority of Jabir b. Abdullah through another chain of transmitters.

Book 23, Number 4997:

    This hadith has been transmitted on the authority of Ibn Juraij.

Book 23, Number 4998:

    Jabir reported Allah's Messenger (may peace be upon him) as saying: Do not let your animals and children go out when the sun sets until the first and the darkest part of the night is over, for the Satan is let loose with the sinking of the sun until the darkest part of the night is over.

Book 23, Number 4999:

    Jabir b. Abdullah reported this hadith through another chain of transmitters,

Book 23, Number 5000:

    Jabir b. 'Abdullah reported Allah's Messenger (may peace be upon him) as saying: Cover the vessels and tie the waterskin, for there is a night in a year when pestilence descends, and it does not pass an uncovered vessel or an untied waterskin but some of that pestilence descending into it.

Book 23, Number 5001:

    This hadith is reported on the authority of Laith b. Sa'd with the same chain of transmitters, but with a slight variation in wording (and that is that) he (the Holy Prophet) said: There is a day in a year when descends the pestilence; at the end of the hadith Laith said that the non Arabs save themselves from it in Kanun Awwal (this is the month of December).

Book 23, Number 5002:

    Salim, on the authority of his father, reported Allah's Messenger (may peace be upon him) having said: Do not leave the fire burning in your houses when you go to sleep.

Book 23, Number 5003:

    Abu Musa reported that a house was burnt down in Medina during the night over its inhabitants. When their matter was reported to Allah's Messenger (may peace be upon him), he said; This fire is an enemy of yours. So when you go to sleep, extinguish it.

Chapter 11 : ETIQUETTE RELATING TO EATING AND DRINKING

Book 23, Number 5004:

    Hudhaifa reported: When we attended a dinner along with the Messenger of Allah (may peace be upon him) we did not lay our hands on the food until Allah's Messenger (may peace be upon him) had laid his hand and commenced eating (the food). Once we went with him to a dinner when a girl came rushingly as it someone had been pursuing her. She was about to lay her hand on the food, when Allah's Messenger (may peace be upon him) caught her hand. Then a desert Arab came there (rushingly) as if someone had been pursuing him. He (the Holy Prophet) caught his hand; and then Allah's Messenger (may peace be upon him) said: Satan considers that food lawful on which Allah's name is not mentioned. He had brought this girl so that the food might be made lawful for him and I caught her hand. And he had brought a desert Arab so that (the food) might be lawful for him. So I caught his hand. By Him, in Whose hand is my life, it was (Satan's) hand that was in my hand along with her hand.

Book 23, Number 5005:

    Hudhaifa b. al-Yaman reported: When we were invited to a dinner with Allah's Messenger (may peace be upon him); the rest of hadith is the same but there is a slight variation of wording (and the variation is) that in that hadith the desert Arab precedes the arrival of that girl, and at the conclusion there is an addition (to this effect): "He (the Holy Prophet) then mentioned the name of Allah and ate." This hadith is reported on the authority of A'mash with the same chain of transmitters but with a slight variation of wording.

Book 23, Number 5006:

    Jabir b. 'Abdullah reported Allah's Messenger (may peace be upon him) as saying: When a person enters his house and mentions the name of Allah at the time of entering it and while eating the food, Satan says (addressing himself: You have no place to spend the night and no evening meal; but when he enters without mentioning the name of Allah, the Satan says: You have found a place to spend the night, and when he does not mention the name of Allah while eating food, he (the Satan) says: You have found a place to spend the night and evening meal. This hadith has been narrated on the authority of Jabir b. Abdullah through the same chain of transmitters but with a slight variation of wording.

Book 23, Number 5007:

    Jabir b. 'Abdullah reported Allah's Messenger (may peace be upon him) having said: Do not eat with your left hand, for the Satan eats with his left hand.

Book 23, Number 5008:

    Ibn 'Umar reported Allah's Messenger (may peace be upon him) as saying: When any one of you intends to eat (meal), he should eat with his right hand. and when he (intends) to drink he should drink with his right hand, for the Satan eats with his left hand and drinks with his left hand.

Book 23, Number 5009:

    This hadith is reported by Zuhri on the authority of Sufyan with a different chain of transmitters.

Book 23, Number 5010:

    Salim, on the authority of his father, reported Allah's Messenger (may peace be upon him) as saying: None of you should eat with his left hand and drink with that (left hand), for the Satan eats with left hand and drinks with that (hand). Nafi' has made this addition in that: "Do not take up anything with that (left hand) and do not give anything with that"; and in the narration transmitted on the authority of Abu Tahir there is a slight variation of wording.

Book 23, Number 5011:

    Salama b. Akwa' reported on the authority of his father that a person ate in the presence of Allah's Messenger (may peace be upon him) with his left hand, whereupon he said: Eat with your right hand. He said: I cannot do that, whereupon he (the Holy Prophet) said: May you not be able to do that. It was vanity that prevented him from doing it, and he could not raise it (the right hand) up to his mouth.

Book 23, Number 5012:

    'Umar b. Abu Salama reported: I was under the care of Allah's Messenger (way peace be upon him), and as my hand used to roam about in the dish he said to me: Boy, mention the name of Allah, and eat with your right hand and eat from what is near to you.

Book 23, Number 5013:

    Umar b. Abu Salama reported: I (had the opportunity) one day to dine with Allah's Messenger (may peace be upon him), and I picked up flesh from around the dish. Thereupon Allah's Messenger (may peace be upon him) said: Eat from that which is near to you.

Book 23, Number 5014:

    Abu Sa'id (Khudri) reported that Allah's Messenger (may peace be upon him) forbade from turning the waterskins upside down and drinking from its mouth.

Book 23, Number 5015:

    Abu Sa'id Khudri reported that Allah's, Messenger (may peace he upon him) forbade from turning the waterskins upside down and drinking from their mouths.

Book 23, Number 5016:

    This hadith has been reported from Zuhri with the same chain of transmitters, but he also said that Ikhtinath means that its head (i.e., of the waterskin) be turned upside down and then (water) be drank from that.

Chapter 12 : DISAPPROVAL OF DRINKING WATER WHILE STANDING

Book 23, Number 5017:

    Anas reported Allah's Apostle (may peace be upon him) disapproved the drinking of water while standing.

Book 23, Number 5018:

    Anas reported that Allah's Apostle (may peace be upon him) forbade that a person should drink while standing. Qatada reported: We said to him: What about eating? Thereupon he (Anas) said: That is even worse and more detestable (abominable).

Book 23, Number 5019:

    This hadith is reported on the authority of Anas with a different chain of transmitters, but no mention is mane of the words of Qatada.

Book 23, Number 5020:

    Abu Sa'id Khudri reported that Allah's Messenger (may peace be upon him) warned against drinking while standing.

Book 23, Number 5021:

    Abu Sa'id Khudri reported this hadith through another chain of transmitters but with a slight, variation of wording.

Book 23, Number 5022:

    Abu Huraira reported Allah's Messenger (may peace be upon him) as saying: None of you should drink while standing; and if anyone forgets, he must vomit.

Chapter 13 : PERMISSIBILITY OF DRINKING ZAMZAM (WATER) WHILE STANDING

Book 23, Number 5023:

    Ibn Abbas reported: I served.(water of) Zamzam to Allah's Messenger (may peace be upon him), and he drank it while standing.

Book 23, Number 5024:

    Ibn 'Abbas reported that Allah's Messenger (may peace be upon him) drank (water) from Zamzam in a bucket while he was standing.

Book 23, Number 5025:

    Ibn 'Abbas reported that Allah's Apostle (may peace be upon him) drank (water) from Zamzam while he was standing.

Book 23, Number 5026:

    Ibn 'Abbas reported: I served (water from) Zamzam to Allah's Messenger (may peace be upon him), and he drank while standing, and he asked for it while he was near the House (i.e. House of Allah-Ka'ba).

Book 23, Number 5027:

    This hadith is reported on the authority of Shu'ba with the same chain of transmitters but with a slight variation of wording.

Chapter 14 : IT IS REPUGNANT TO BREATHE IN A VESSEL AND APPRECIABLE TO BREATHE THREE TIMES OUTSIDE THE VESSEL IN COURSE OF DRINKING

Book 23, Number 5028:

    Abu Qatada reported on the authority of his father that Allah's Apostle (may peace be upon him) forbade breathing in a vessel.

Book 23, Number 5029:

    Anas reported that Allah's Messenger (may peace be upon him) used to breathe three times in the course of a drink (i.e. he drank in three gulps).

Book 23, Number 5030:

    Anas reported that Allah's Messenger (may peace be upon him) breathed three times (outside the vessel) in the course of a drink and said: It is more thirst- quenching, healthier and more wholesome. Anas said: So I also breathe three times in the course of a drink.

Book 23, Number 5031:

    This hadith is reported on the authority of Anas with a slight variation of wording.

Chapter 15 : IT IS DESIRABLE TO CIRCULATE WATER OR MILK (IN AN ASSEMBLY) FROM THE RIGHT-HAND SIDE OF THE ONE WHO SERVES

Book 23, Number 5032:

    Anas b. Malik reported that there was brought to Allah's Messenger (may peace be upon him) a cup of milk mixed with water, while there was on his right a desert Arab and on his left Abu Bakr. He (the Holy Prophet) drank; he then gave it to the desert Arab and said: (Give to one) who is on the right, then again who is on the right.

Book 23, Number 5033:

    Anas reported: The Apostle of Allah (may peace he upon him) came to Medina when I was ten years old and he died when I was twenty years old. My mother exhorted me to serve him. He (the Holy Prophet) came to our house, and we ruined a flabby goat for him and mixed it (the milk) with water from the well of the house. Allah's Messenger (may peace be upon him) drank that. Umar and Abu Bakr on his left side said to him: Allah's Messenger, give it to Abu Bakr, but he (the Holy Prophet) gave it to the desert Arab who was on his right. Allah's Messenger (may peace be upon him) said: He who is on the right, then he who is on the right.

Book 23, Number 5034:

    Anas b. Malik reported: Allah's Messenger (may peace be upon him) came to our house and he asked for a drink. We milked a goat for him and then mixed it (the milk) with the water of this well of mine. I gave it to Allah's Messenger (may peace be upon him) and he drank it, while Abu Bakr was on his left and 'Umar was in front of him, and a desert Arab was on his right. When Allah's Messenger (may peace be upon him) had finished the drink, Umar said: Allah's Messenger, here is Abu Bakr, give him to drink; but Allah's Messenger (may peace be upon him) gave it to the desert Arab and he left out Abu Bakr and Umar. And Allah's Messenger (may peace be upon him) said: Those on the right, those on the right, those on the right (deserve preference). Anas said: This is the Sunnah, this is the Sunnah, this is the Sunnah.

Book 23, Number 5035:

    Sahl b. Sa'd Sa'idi reported that Allah's Messenger (may peace be upon him) was given a drink, and he drank from that, and there was on his right side a boy. and on his left some old men. He said to the boy: Do you permit me to give it to them (the old men), but that boy said: by God. I will not give preference at your hand over me in my share. He (the narrator) said that Allah's Messenger (may peace be upon him) then gave it in his hand.

Book 23, Number 5036:

    This hadith is reported on the authority of Sahl b. Sa'd with a slight variation of wording.

Chapter 16 : THE MERIT OF LICKING THE FINGERS AFTER TAKING FOOD AND WIPING THE DISH (WITH FINGERS) AND EATING OF THE FALLEN MOUTHFUL AFTER REMOVING THE DIRT STICKING TO IT

Book 23, Number 5037:

    Ibn 'Abbas reported Allah's Messenger (may peace be upon him.) as saying: When any one of you eats food he should not wipe his hand until he has licked it himself or has given it to someone else to lick.

Book 23, Number 5038:

    Ibn 'Abbas reported Allah's Messenger (may peace be upon him) as saying: When any one of you eats food he should not wipe his hand until he has licked it or got it licked by (someone else).

Book 23, Number 5039:

    Ibn Ka'b b. Malik reported on the authority of his father that he saw Allah's Messenger (may peace be upon him) licking his three fingers (after having finished the food). Ibn Hatim made no mention of "three". This hadith is also narrated through another chain of transmitters.

Book 23, Number 5040:

    Ibn Ka'b b. Malik reported on the authority of his father that the Messenger of Allah (may peace be upon him) used to eat (food) with three fingers and he licked his hand before wiping it (with towel).

Book 23, Number 5041:

    'Abdullah b. Ka'b reported that his father Ka'b narrated to him that Allah's Messenger (may peace be upon him) used to eat with three fingers and when he had finished (eating), he licked them.

Book 23, Number 5042:

    A hadith like this has been reported on the authority of Ka'b b. Malik through another chain of transmitters.

Book 23, Number 5043:

    Jabir reported that Allah's Messenger (may peace be upon him) commanded the licking of fingers and the dish, saying: You do not know in what portion the blessing lies."

Book 23, Number 5044:

    Jabir reported Allah's Messenger (may peace be upon him) as saying: When any one of you drops a mouthful he should pick it up and remove any of the filth on it, and then eat it, and should not leave it for the Satan, and should not wipe his hand with towel until he has licked his fingers, for he does not know in what portion of the food the blessing lies.

Book 23, Number 5045:

    This hadith has been narrated on the authority of Sufyan with the same chain of transmitters but with a slight variation of wording.

Book 23, Number 5046:

    Jabir reported: I heard Allah's Apostle (may peace be upon him) as saying: The Satan is present with any one of you in everything he does; he is present even when he eats food; so if any one of you drops a mouthful he should remove away anything filthy on it and eat it and not leave for the devil; and when he finishes (food) he should lick his fingers, for he does not know in what portion of his food the blessing lies.

Book 23, Number 5047:

    This hadith is reported on the authority of A'mash with the same chain of transmitters but with a slight variation of words but no mention is made of the first part of the hadith, i.e. the Satan is present with any one of you.

Book 23, Number 5048:

    Jabir reported from Allah's Messenger. (may peace be upon him) about mentioning the licking (of fingers) and the (falling of) the mouthful.

Book 23, Number 5049:

    Anas reported that when Allah's Messenger (may peace be upon him) ate food he licked his three fingers, and he said: When any one of you drops a mouthful he should remove anything filthy from it and then eat it, and should not leave it for the Satan. He also commanded us that we should wipe the dish saying: You do not know in what portion of your food the blessing lies.

Book 23, Number 5050:

    Abu Huraira reported Allah's Messenger (may peace be upon him) as saying: When any one of you cats food he should lick his fingers, for hen does not know in what part of the food sticking to his fingers the blessing lies. This hadith has been reported on the authority of Hammad with the same chain of transmitters, but with a slight variation of wording.

Chapter 17 : WHAT SHOULD THE GUEST DO IF AN UNINVITED PERSON ACCOMPANIES HIM AND THE MERIT OF INVITING THAT PERSON TO FEAST

Book 23, Number 5051:

    Abu Mas'ud Ansari reported that a person from the Ansar who was called Abu Shu'aib had a slave who was a butcher (by profession). He (Abu Mas'ud) saw Allah's Messenger (may peace be upon him) and found signs of hunger on his face. He said to the servant: 0 ye, prepare for us food sufficient for five persons, for I intend to invite Allah's Apostle (may peace be upon him) who would be the fifth amongst the five. He (the narrator) reported that he then prepared the food and came to Allah's Apostle (may peace be upon him) and invited all the five (including him) who was the fifth amongst them to the feast. A man followed him and when Allah's Apostle (may peace be upon him) reached the door, he said: This man has followed us; if you like you may permit him (to join the meal) and if you like he can go back. Thereupon the person said: Allah's Messenger, I permit him.

Book 23, Number 5052:

    This hadith has been reported on the authority of Abu Mas'ud Ansari through another chain of transmitters.

Book 23, Number 5053:

    This hadith has been transmitted on the authority of Jabir also.

Book 23, Number 5054:

    Anas reported that Allah's Messenger (may peace be upon him) had a neighbour who was Persian (by descent), and he was expert in the preparation of soup. He prepared (soup) for Allah's Messenger (may peace be upon him) and then came to him to invite him (to that feast). He (Allah's Messenger) said: Here is 'A'isha also (and you should also invite her to the food). He said: No. Thereupon Allah's Messenger (may peace be upon him) also said: No (then I cannot join the feast). He returned inviting him, and Allah's Messenger (may peace be upon him) said: She is also there (i.e. 'A'isha should also be invited). He said: No. Thereupon Allah's Messenger (may peace be upon him) also said: No (and declined his offer). He returned again to invite him and Allah's Messenger (may peace be upon him) again said: She is also there. He (the host) said: "Yes" for the third time. Then he accepted his invitation, and both of them set out until they came to his house.

Chapter 18 : PERMISSIBILITY OF A PERSON'S TAKING ANYONE ALONG WITH HIM WHERE THE HOST IS VERY INTIMATE WITH THE GUEST

Book 23, Number 5055:

    Abu Huraira reported that Allah's Messenger (may peace be upon him) went out (of his house) one day or one night, and there he found Abu Bakr and 'Umar also. He said: What has brought you out of your houses at this hour? They said: Allah's Messenger, it is hunger. Thereupon he said: By Him in Whose Hand is my life, what has brought you out has brought me out too; get up. They got up along with him. and (all of them) came to the house of an Ansari, but he was not at home. When his wife saw him she said: Most welcome, and Allah's Messenger (may peace be Upon him) said to her: Where is so and so? She said: He has gone to get some fresh water for us. When the Ansari came and he saw Allah's Messenger (may peace be upon him) and his two Companions, he said: Praise be to Allah, no one has more honourable guests today than I (have). He then went out and brought them a bunch of ripe dates, dry dates and fresh dates, and said: Eat some of them. He then took hold of his long knife (for slaughtering a goat or a sheep). Allah's Messenger (may peace be upon him) said to him: Beware of killing a milch animal. He slaughtered a sheep for them and after they had eaten of it and of the bunch and drank, and when they had taken their fill and had been fully satisfied with the drink, Allah's Messenger (may peace be upon him) said to Abu Bakr and Umar: By Him in Whose Hand is my life, you will certainly be questioned about this bounty on the Day of judgment. Hunger brought you out of your house, then you did not return until this bounty came to you.

Book 23, Number 5056:

    Abu Huraira reported: One day while Abu Bakr was sitting and there was with him Umar also there came to them Allah's Messenger (may peace be upon him) and he said: What makes you stay here? They said: It is hunger that has brought us out from our houses. By Him Who has stint you with Truth; the rest of the hadith is the same.

Book 23, Number 5057:

    Jabir b. 'Abdullah reported: When the ditch was dug, I saw Allah's Messenger (may peace he upon him) feeling very hungry. I came to my wife and said to her: Is there anything with you? I have seen Allah's Messenger (may peace be upon him) feeling extremely hungry. She brought out a bag of provisions which contained a sa', of barley. We had also with us a lamb. I slaughtered it. She ground the flour. She finished (this work) along with me. I cut it into pieces and put it in the earthen pot and then returned to Allah's Apostle (may peace be upon him) (for inviting him). She said: Do not humiliate me in the presence of Allah's Messenger (may peace be upon him) and those who are with him. When I came to him I whispered to him saying: Allah's Messenger, we have slaughtered a lamb for you and she has ground a sa' of barley which we had with us. So you come along with a group of people with you. Thereupon Allah's Messenger (may peace be upon him) said loudly: O people of the ditch, Jabir has arranged a feast for you, so (come along). Allah's Messenger (may peace be upon him) said: Do not remove your earthen pot from the hearth and do not bake the bread from the kneaded flour until I come. So I came and Allah's Messenger (may peace be upon him) came and he was ahead of the people; and I came to my wife and she said (to me): You will be humbled. I said: I did what you had asked me to do. She (his wife) said: I brought out the kneaded flour and Allah's Messenger (may peace be upon him) put some saliva of his in that and blessed It. He then put saliva in the earthen pot and blessed it and then said. Call another baker who can bake with you. and bring out the soup from it, but do not remove it from the hearth, and the guests were one thousand. (Jabir said): I take an oath by Allah that all of them ate (the food to their fill) until they left it and went away and our earthen pot was brimming over as before, and so was the case with our flour, or as Dahhak (another narrator) said: It (the flour) was in the same condition and loaves had been prepared from that.

Book 23, Number 5058:

    Anas b. Malik reported that Abu Talha said to Umm Sulaim: I felt some feebleness in the voice of Allah's Messenger (may peace be upon him) and perceived that it was due to hunger; so have you anything with you ? She said: Yes. She brought out barley loaves, then took out a head-covering of hers, in a part of which she wrapped those loaves and then put them beneath my mantle and covered me with a part of it. She then sent me to Allah's Messenger (may peace be upon him). I set forth and found Allah's Messenger (may peace be upon him) sitting in the mosque in the company of some persons. I stood near them, whereupon Allah's Messenger (may peace be upon him) said: Has Abu Talha sent you ? I said, Yes. He said: Is it for a feast ? I said. Yes. Thereupon Allah's messenger (may peace be upon him) said to'those who were with him to get up He went forth and so I did before them, until I came to Abu Talha and informed him. Abu Talba said: Umm Sulaim, here comes Allah's Messenger (may peace be upon him) along with people and we do not have enough (food) to feed them. She said: Allah and His Messenger know best. Abu Talha went out (to receive him) Until he met Allah's Messenger (may peace be upon him) and Allah's Apostle (may peace be upon him) came forward along with him until they both (Allah's Messenger, along with Abu Talha) came in. Then Allah's Messenger (may peace be upon him) said: Umm Sulaim. bring forth that which you have with you. She brought the bread. Allah's Messenger (may peace be upon him) commanded that the bread be broken into small pieces, and when Umm Sulaim had squeezed a small waterskin and put seasoning on it, Allah's Messenger (may peace be upon him) recited something regarding it what Allah wished him to say. He then said: Allow ten (guests to come in and have their meals). He permitted them; they ate until they had their fill. They then went out. He (the Holy Prophet) again said: Permit ten (more) and he (the host gave permission to them. They ate until they had enough. Then they went out. he again said: Permit ten (more) until all the people had eaten to their fill, and they were seventy or eighty persons.

Book 23, Number 5059:

    Anas b. Malik reported : Abu Talha sent me to Allah's Messenger (may peace be upon him) in order to invite him (for meal). She had prepared a meal. So I came and found Allah's Messenger (may peace be upon him) along with some people. He looked at me, and I felt shy and said : Accept the invitation of Abu Talha. He (the Holy Prophet) asked the people to get up. Thereupon Abu Talha said : Allah's Messenger, I have prepared something for you. Allah's Messenger (may peace be upon him) touched (the food) and invoked blessings upon it, and then said : Let ten persons from my Companions enter (the house). He then said : Eat, and (in the meanwhile) brought out something from between his fingers for them. They then began to eat until they had their fill and then went out. He then asked ten more men (to have the meal) and they ate to their fill, and the ten persons went on getting in (and eating the food) and then getting out until none was left amongst them who had not got in and eaten to his fill. He then collected (the remaining part of the food) and it (the quantity of the food) was the same (as it had been prior to the serving of guests).

Book 23, Number 5060:

    Anas b Malik reported : Abu Talha sent me to Allah's Messenger (may peace be upon him) ; the rest of the hadith is the same, but 'there is a slight variation of wording that he said at the end (The Holy Prophet) took what was left (of the food) and collected it and then invoked blessings upon it and it returned to its original state. He (the Holy Prophet) then said Take this.

Book 23, Number 5061:

    Anas b. Malik reported : Abu Talha ordered Umm Sulaim to prepare a meal specially for Allah's Apostle (may peace be upon him). He then sent me to him (to the Holy Prophet) ; the rest of the hadith is the same (but there is a slight variation of wording) : "Allah's Messenger (may peace be upon him) placed his hand and mentioned the name of Allah upon that, and then said : Admit ten men. He (Abu Talha) admitted them and they got in. He (the Holy Prophet) said : Eat while mentioning the name of Allah upon it (the meal). They ate until eighty persons had taken the food. Then Allah's Apostle (may peace be upon him) had his meal and so the members of the household, and still they left some food."

Book 23, Number 5062:

    Anas b. Malik reported this incident pertaining to the feast given by Abu Talha to Allah's Apostle (may peace be upon him) with the addition of these words : "Abu Talha stood at the door (to welcome the honourable guest) until Allah's Messenger (may peacec be upon him) came there, He (Abu Talha) said to him : Allah's Messenger, the thing (we intend to offer you as a meal) is small in quantity. Thereupon he (the Holy Prophet) said : Bring that, for Allah will soon bless it (and increase it).

Book 23, Number 5063:

    Anas b. Malik reported this hadith (with a slight variation of wording) Then AlIah's Messenger (may peace be upon him) ate and the people of his house also ate. but (still) there was left a surplus, which they sent to their neighbours.

Book 23, Number 5064:

    Anas b. Malik reported: Abu Talha saw Allah's Messenger (may peace be upon him) lying down upon his belly in the mosque. He came to Umm Sulaim and said: I saw Allah's Messenger (may peace be upon him) lying down upon the belly in the mosque, and I think he is hungry. The rest of the hadith is the same (but with the addition of these words) that Allah's messenger (may peace be upon him) ate (the food) and so did Abu Talha, Umm Sulaim and Anas b. Malik, but there was left some. thing which we presented to our neighbours.

Book 23, Number 5065:

    Anas b. Malik reported: I visited Allah's Messenger (may peace be upon him) one day and found him sitting in the company of his Companions and talking to them, and he had tied his belly with a bandage. Usama said: I am in doubt whether there was stone on that (his belly) or not. I asked some of his Companions why Allah's Messenger (may peace be upon him) had bandaged his belly. They said: (He has done that to relieve) his hunger. I went to Abu Talha, the husband of Umm Sulaim, the daughter of Milhan, and said to him: Father, I saw Allah's Messenger (may peace be upon him) having bandaged his belly. I asked some of his Companions (the reason of it) and they said that it was due to hunger. Abu Talha came to mv mother and said: Is there anything? She said: Yes, I have some pieces of bread with me and some dates. If Allah's Messenger (may peace be upon him) comes to us alone we can feed him to his fill, but if someone comes along with him this would be insufficient for them. The rest of the hadith is the same.

Book 23, Number 5066:

    Anas b. Malik reported this hadith pertaining to the entertainment of Allah's Messenger (may peace be upon him) by Abu Talha through another chain of transmitters.

Chapter 19 : PERMISSIBILITY OF EATING SOUP AND MERIT OF EATING PUMPKIN

Book 23, Number 5067:

    Anas b. Malik reported: A tailor invited Allah's Messenger (may peace be upon him) to a meal which he had prepared. Anas b. Malik said: I went along with Allah's Messenger (may peace be upon him) to that feast. He presented to Allah's Messenger (may peace be upon him) barley bread and soup containing pumpkin, and sliced pieces of meat. Anas said: I saw Allah's Messenger (may peace be upon him) going after the pumpkin round the dish, so I have always liked the pumpkin since that day.

Book 23, Number 5068:

    Anas b. Malik reported that a person invited Allah's Messenger (may peace be upon him) to a meal. I also went along with him. He brought soup containing pumpkin. Allah's 'messenger (may peace be upon him) ate that pumpkin with relish. He (Anas) said: When I saw that I began to place it before him, and did not eat it (myself). Anas said: It was since then that pumpkin was always my favourite (food).

Book 23, Number 5069:

    Anas b. Malik rdported that a tailor invited Allah's Messenger (may peace be upon him) to a feast. There has been an addition to this that Thabit said: I heard Anas saying that any meal that was prepared for me after that I tried that it should contain pumpkin.

Chapter 20 : DESIRABILITY OF EXTRACTING STONES FROM THE DATES AND OF THE GUEST'S INVOKING BLESSING FOR THE HOST

Book 23, Number 5070:

    'Abdullah b. Busr reported: AUah's Messenger (may peace be upon him) came to my father and we brought to him a meal and a preparation from dates, cheese and butter. He ate out of that. He was then given dates which he ate but he placed their stones between his fingers, and he joined his forefinger and middle finger. Shu'ba reported: I think that this hadith God's willing also contains (these words): Putting of date stones between two fingers. Then a drink was brought for him and he drank it, and then gave it to one who was on his right side. He (the narrator) said: My father took hold of the rein of his riding animal and requested him to supplicate for us. Thereupon he said: O Allah. bless them in what Thou hast provided them as a sustenance; and forgive them and have mercy upon them.

Book 23, Number 5071:

    This hadith has been narrated on the authority of Shu'ba with the same chain of transmitters and they did not doubt about keeping the dates between his fingers (as is expressed in the previous hadith).

Chapter 21 : EATING CUCUMBER WITH DATES

Book 23, Number 5072:

    'Abdullah b. Ja'far reported: I saw Allah's Messenger (may peace be upon him) eating cucumber with fresh dates.

Chapter 22 : ONE SHOULD SHOW MODESTY WHILE EATING AND THE WAY HOW ONE SHOULD SIT

Book 23, Number 5073:

    Anas b. Malik reported: I saw Allah's Apostle (may peace be upon him) squatting and eating dates.

Book 23, Number 5074:

    Anas reported that there were brought to Allah's Messenger (may peace be upon him) dates. He distributed them in the state that he had been sitting upright (in an easy posture) and he had also been eating them a (bit) quickly.

Chapter 23 : IT IS FORBIDDEN TO EAT TWO DATES OR TWO MORSELS SIMULTANEOUSLY

Book 23, Number 5075:

    Jabala b. Suhaim reported: Ibn Zubair used to provide us with dates during the time that the people were hard pressed because of famine (Once) as we were busy in eating there happened to appear before us Ibn 'Umar. He said: Don't eat two dates together, for Allah's Messenger (may peace be upon him) forbade eating them together but only after seeking permission from his brother (partner). Shu'ba said: I do not think these words pertaining to seeking permission but from the words of Ibn 'Urnar.

Book 23, Number 5076:

    This hadith has been reported on the authority of Shu'ba with the same chain of transmitters but these words of his (are not found): "The people were hard pressed because of the famine during those days."

Book 23, Number 5077:

    Jabala b. Suhaim reported: I heard Ibn 'Umar as saying that Allah's Messenger (may peace be upon him) forbade anyone taking two dates together without seeking the consent of his companions.

Chapter 24 : IT IS PERMISSIBLE TO STORE DATES AND CORN FOR THE SUSTENANCE OF ONE'S CHILDREN

Book 23, Number 5078:

    'A'isha reported Allah's Messenger (may peace be upon him) as saying: A family which has dates will not be hungry.

Book 23, Number 5079:

    'A'isha reported Allah's Messenger (may peace be upon him) as saying: 'A'isha a family which has no dates (in their house) its members will be hungry; (or) 'A'isha the family which has no dates its members may be hungry. He said this twice or thrice.

Chapter 25 : EXCELLENCE OF THE DATES OF MEDINA

Book 23, Number 5080:

    Amir b. Sa'd b. Abu Waqqas, on the authority of his father, reported Allah's Messenger (may peace be upon him) having said: He who ate seven dates (of the land situated) between these two lava plains in the morning, no poison will harm him until it is evening.

Book 23, Number 5081:

    'Amir b. Sa'd b. Abu Waqqas reported Allah's Messenger (may peace be upon him) as saying: He who ate seven 'ajwa' dates in the morning, poison and magic will not harm him on that day.

Book 23, Number 5082:

    This hadith has been reported on the authority of Ibn Hashim with the same chain of transmitters but with a slight variation of wording.

Book 23, Number 5083:

    'A'isha reported Allah's Messenger (may peace be upon him) as saying: The 'ajwa' dates of 'Aliya' contain heating effects and these are antidote in the early morning.

Chapter 26 : EXCELLENCE OF TRUFFLES AND THEIR USE AS A MEDICINE FOR THE EYES

Book 23, Number 5084:

    Sa'id b. Zaid b. 'Amr b. Nufail reported: I heard Allah's Apostle (may peace be upon him) as saying: Truffles are a kind of 'Manna' and their juice is a medicine for the eyes.

Book 23, Number 5085:

    Sa'id b. Zaid reported: I heard Allah's Messenger (may peace be upon him) as saying: Truffles are a kind of blessing and their juice is a medicine for the eyes. Shu'ba said: When Hakam narrated this hadith to me, I did not deem it as a Munkar hadith because of the narration of Abd al-Malik.

Book 23, Number 5086:

    Sa'id b. Zaid b. 'Amr b. Nufail reported Allah's Messenger (may peace be upon him) as saying: Truffles are a kind of 'Manna' which Allah the Glorious and Exalted, sent down upon the people of Israil, and its juice is a medicine for the eyes.

Book 23, Number 5087:

    Sa'id b. Zaid reported Allal a Messenger (may peace be upon him) as saying: Truffles are a kind of 'Manna' which Allah sent down upon Moses and their juice is a medicine for the eyes.

Book 23, Number 5088:

    Sa'id b. Zaid reported Allah's Messenger (may peace be upon him) as saying : Truffles are 'Manna' which Allah, the Exalted the Majestic, sent to the people of Israil, and its juice is a medicine for the eyes.

Book 23, Number 5089:

    Sa'id b. Zaid reported Allah's Messenger (may peace be upon him) as saying: Truffles are 'Manna' and its juice is the medicine for the eyes.

Chapter 27 : THE MERIT OF THE FRUIT OF ARAK TREE

Book 23, Number 5090:

    Jabir b. Abdullah reported: We were with the Apostle of Allah (may peace be upon him) at Marr az-Zahran, and we were plucking the fruit of the Arak tree, whereupon Allah's Messenger (may peace he upon him) said: Pluck only its black ones (for they are the most pleasant). We said: Allah's Messenger, it seems you shepherded the flock. He said: Yes. Has there been a prophet who did not shepherd it (or some words like it) ?

Chapter 28 : THE MERIT OF VINEGAR AS A CONDIMENT

Book 23, Number 5091:

    'A'isha reported Allah's Apostle (may peace be upon him) as saying: The best of condiments or condiment is vinegar.

Book 23, Number 5092:

    This hadith has been reported on the authority of Sulaiman b. Bilal with the same chain of transmitters and he is reported to have said: "The best condiment." And he did not doubt (about this word).

Book 23, Number 5093:

    Jabir b. 'Abdullah reported that Allah's Apostle (may peace be upon him) asked his family for condiment. They (the members of his household) said: We have nothing with us but vinegar. He asked for it, he began to eat it, and then said: Vinegar is a good condiment, vinegar is a good condiment.

Book 23, Number 5094:

    Jabir b. 'Abdullah reported: Allah's Messenger (may peace be upon him) took hold of my hand one day (and led me) to his residence. There was presented to him some pieces of bread, whereupon he said: Is there no condiment? They (the members of his household) said: No, except some vinegar. He (the Holy Prophet) said: Vinegar is a good condiment. Jabir said: I have always loved vinegar since I heard it trom Allah's Apostle (may peace be upon him). Talha said: I have always loved vinegar since I heard about it from Jabir.

Book 23, Number 5095:

    This hadith is reported on the authority of Jabir b. 'Abdullah that Allah's Messenger (may peace be upon him) took hold of his hand and led him to his residence as narrated above up to the words: "Vinegar is a good condiment." But in the hadith transmitted through this chain of transmitters, there is no mention of the subsequent part.

Book 23, Number 5096:

    Jabir b. 'Abdullah reported : While I was sitting in my house there happened to pass by me Allah's Messenger (may peace be upon him). He made a gesture to me and I stood up for him. He took hold of my hand until we came to one of the apartments of his wives. He entered and then asked me to get in. So I entered and there was hanging a curtain beside her. He (the Holy Prophet) said: Is there any food (with you) ? They (the members of the household) said : Yes And then there were brought three loaves of bread for him (the Holy Prophet) and placed in the basket of palm leaves. Allah's Messenger (may peace be upon him) picked up one loaf and placed that before him, and then picked up another one and placed it before me. He then picked up the third one and broke it into two parts, and kept the one-half before him and the other half before me, and then said : Is there any condiment ? They (the members of the household) said: There is nothing (in the form of condiment) but some vinegar only. He said : Bring that, for vinegar is a good condiment.

Chapter 29 : PERMISSIBILITY OF EATING GARLIC, BUT AVOIDING IT WHEN ONE INTENDS TO TALK TO EMINENT PERSONS

Book 23, Number 5097:

    Abd Ayyub Ansari reported that when food was brought to Allah's Messenger (may peace be upon him) he ate out of that, and sent the remaining part to me, and one day he sent to me the left-over; (I found that he) had not taken from it at all for it included garlic. I asked him whether that was forbidden, whereupon he said : No, but I do not like it because of its odour. He (Abu Ayyub Ansiri) said: Then I also do not like what you do not like.

Book 23, Number 5098:

    This Hadith is narrated on the authority of Shu'ba with the same chain of transmitters.

Book 23, Number 5099:

    Aflah, the freed slave of Abu Ayyub Ansiri, reported: Allah's Messnger(may peace be upon him) had alighted in his house (viz. of Abu Ayyub Ansari at the time of his emigration to Medina) and he occupied the lower storey, whereas Abu Ayyub Ansari lived in the upper storey. One night, Abu Ayyub Ansari got up and said (to himself) : (How unfortunate it is) that we walk above the head of Allah's Messenger (may peace be upon him), so they went aside and spent the night in a nook and then told Allah's Apostle (may peace be upon him) about it whereupon Allah's Apostle (may peace be upon him) said: The lower storey is more comfortable (for me). but he (Abu Ayyub Ansari) said: We (would not live) over the roof under which you live. So Allah's Messenger (may peace be upon him) shifted to the upper storey, whereas Abu Ayyub Ansari shifted to the lower storey; and he (Abu Ayyub Ansari) used to prepare food for Allah's Apostle (may peace be upon him); and when it was brought (back) to him he asked (to locate) the part, where his fingers had touched (the food), and he followed his fingers on that part where his fingers (those of the Holy Prophet) had touched it. (One day) he prepared food which contained garlic, and when it was returned to him he asked (to locate) the part which the fingers of Allah's Apostle (may peace be upon him) had touched. It was said to him that he had not eaten (the food). He (Abd Ayyub Ansari) was distressed and went up to him (to the Holy Prophet) and said: Is it forbidden? But Allah's Messenger (may peace be upon him) said: No, (it is not forbidden), but I do not like it. and he (Abu Ayyub Ansari) said: I also do not like what you do not like or which you did not like. He (Abu Ayyub Ansari) said: (The Holy Prophet did not eat garlic) as Allah's Apostle (may peace be upon him) was visited (by angels) and brought him the message of Allah.

Chapter 30 : SHOWING HONOUR TO THE GUEST AND THE MERIT OF MAKING OF SACRIFICE FOR HIM

Book 23, Number 5100:

    Abu Huraira reported that a person came to Allah's Messenger (may peace be upon him) and said : I am hard pressed by hunger. He sent (message) to one of his wives (to procure food for him). but she said: By Him Who has sent you with Truth, thrre is nothing with me (to serve him) but only water. He (the Holy Prophet) then sent the (same) message to another, and she gave the same reply, until all of them gave the same reply : By Him Who has sent thee with the Truth, there is nothing with me but only water, whereupon he (the Holy Prophet) said: Allah would show mercy to him who will entertain this guest tonight. A person from the Ansar stood up and said : Messenger of Allah, I (am ready to entertain). He took him to his house and said to his wife : Is there anything with you (to serve the gdest) ? She said: No, but only a subsistence for our children. He said : Distract their attention with something, and when the guest enters extinguish the lamp and give him the impression that we are eating. So they sat down. and the guest had his meal. When it was morning he went to Allah's Apostle (may peace be upon him) who said: Allah was well pleased with what you both did for your guest this night.

Book 23, Number 5101:

    Abu Huraira reported that a guest spent the night with a person from the Ansar who had nothing with him but food (sufficient) for his own self and his children. He said to his wife: (Lull) the children to sleep, and put out the lamp, and serve the guest with what you have with you. It was on this occasion that this verse was revealed: "Those who prefer the needy to their own selves in spite of the fact that they are themselves in pressing need" (Lix. 9).

Book 23, Number 5102:

    Abu Huraira reported that a man came to Allah's Messenger (may peace be upon him) so that he should entertain him as a guest, but he had nothing with which he could entertain him. He, therefore, asked if there was any person who would entertain him (assuring the audience) that Allah would show mercy to him. A person from the Ansar who was called Abu Talha stood up and he took him to his house. The rest of the hadith is the same and mention is (also) made in that about the revelation of the verse as narrated by Waki'.

Book 23, Number 5103:

    Miqdad reported: I and two of my companions were so much afflicted by hunger that we had lost our power of seeing and hearing. We presented ourselves (as guests) to the Companions of the Holy Prophet (may peace be upon him), but none amongst them would entertain us. So we came to Allah's Apostle (may peace be upon him), and he took us to his residence and there were three goats. Allah's Apostle (may peace be upon him) said: Milk these for us. So we milked them and every person amongst us drank his share and we set aside the share of Allah's Apostle (may peace be upon him). (It was his habit) to come during the night and greet (the people present there) in a manner that would not wake up one in sleep but make one who was awake hear it. He would then go to the mosque and say prayer, then go to the milk and drink it. Miqdad added: One night the Satan came to me when I had taken my share, and he said: Muhammad has gone to the Ansar, who would offer him hospitality and he would get what is with them, and he has no need for this draught (of milk). So I took (that milk) and drank it, and when it had penetrated deeply in my stomach and I was certain that there was no way out (but to digest it), the Satan aroused (my sense of) remorse and said: Woe be to thee! what have you done? You have taken the drink reserved for Muhammad! When he would come and he would not find it, he would curse you, and you would be ruined, and thus there would go (waste) this world and the Hereafter (for) you. There was a sheet over me; as I placed (pulled) it upon my feet, my head was uncovered and as I placed it upon my head, my feet were uncovered, and I could not sleep, but my two companions had gone to sleep for they had not done what I had done. There came Allah's Apostle (may peace be upon him), and he greeted as he used to greet (by saying as-Salamu 'Alaikum). He then came to the mosque and observed prayer and then came to his drink (milk) and uncovered it, but did not find anything in it. He raised his head towards the sky, and I said (to myself) that he (the Holy Prophet) was going to invoke curse upon me and I would be thus ruined; but he (the Holy Prophet) said: Allah, feed him who fed me and give drink to him who provided me drink. I held tight the sheet upon myself (and when he had supplicated), I took hold of the knife and went to the goats (possessed by the Holy Prophet) so that I may slauhter one for Allah's Messenger (may peace be upon him) which was the fattest amongst them, and in fact all of them were milch goats; then I took hold of the vessel which belonged to the family of Allah's Messenger (may peace be upon him) in which they used to milk and drink therefrom, and milked them in that until it swelled up with foam. I came to Allah's Messenger (may peace be upon him) and he said: Have you taken your share of the milk during the night ? I said: Drink it. and he drank it; he then handed over (the vessel) to me and I said: Allah's Messenger, drink it, and he drank it and handed over (the vessel) to me again, I then perceived that Allah's Apostle (may peace be upon him) had been satiated and I had got his blessings. I burst into laughter (so much) so that I fell upon the ground, whereupon Allah's Messenger (may peace be upon him) said: Miqdad, it must be one of your mischiefs. I said: Allah's Messenger, this affair of mind is like this and this. and I have done so. Thereupon. Allah's Apostle (may peace be upon him) said: This is nothing but a mercy from Allah. Why is it that you did not give me an opportunity so that we should have awakened our two friends and they would have got their share (of the milk)? I said: By Him Who has sent you with Truth. I do not mind whatever you give (to them), and whatever the (other) people happen to get, when I had got it along with you from among the people.

Book 23, Number 5104:

    This hadith has been reported on the authority of Mughira with the same chain of transmitters.

Book 23, Number 5105:

    'Abd al-Rahman b. Abu Bakr reported: We were one hundred and thirty (persons) with Allah's Apostle (may peace be upon him). Allah's Apostle (may peace be upon him) said: Does any one of You possess food? There was a person with (us) who had a sa' of flour or something about that, and it was kneaded. Then a tall polytheist with dishevelled hair came driving his flock of sheep. Thereupon Allah's Apostle (may peace be upon him) said: Would you like to sell it (any one of these goats) or offer it as a gift or a present? He said: No, (I am not prepared to offer as a gift), but I would sell it. He (the Holy Prophet) bought a sheep from him, and it was slaughtered and its meat was prepared, and Allah's Messenger (may peace be upon him) commanded that its liver should be roasted. He (the narrator) said: By Allah, none among one hundred and thirty persons was left whom Allah's Messenger (may peace be upon him) had not given a part out of her liver; if anyone was present he gave it to him. but if he was absent it was set aside for him. And he (the Holy Prophet) filled two bowls (one with soup and the other with mutton) and we all ate out of them to our hearts' content, but (still) some part was (left) in (those) two bowls, and I placed it on the camel-(or words to the same effect).

Book 23, Number 5106:

    'Abd al-Rabman b. Abu Bakr reported that the people of Suffa were very poor. Once the Messenger of Allah (may peace be upon him) said (to his Companions): He who amongst you has food for two persons should take three (guests with him). and he who has with him food for four persons should take five or six (guests with him for entertaining them). It was (in accordance with these instructions of the Holy Prophet) that Abu Bakr brought three persons, and the Apostle of Allah (may peace be upon him) brought ten persons (as guests to their respective houses). Abu Bakr had brought three persons (he himself, and myself), my father and my mother (along with therm). He (the narrator) said: I do not know whether he also said: My wife and one servant who was common between our house and that of Abu Bakr. Abu Bakr had had his evening meal with Allah's Apostle (may peace be upon him). He stayed here until night prayer had been offered. He then came back (to the house of Allah's Apostle) and stayed there until Allah's Messenger (may peace be upon him) felt drowsy and (Abu Bakr) then came (back to his own house) when (a considerable) part of the night had been over, as Allah had desired. His wife said to him: What held you back from your guests? He said: Oh! have you not served them the evening meal (by this time)? She said: It was in fact served to them. but they refused to eat until you came. He ('Abd al-Rahman) said: I slunk away and bid myself. He (Abu Bakr) said: O, you stupid fellow, and he reprimanded me, and said to the guests: Eat, though it may not be pleasant now. He said: By Allah. I will never eat it He ('Abd al-Rahman) said: By Allah. we did not take a morsel when from beneath that (there appeared) more until they had eaten to their fill, and lo! it was more than what it was before. Abu Bakr saw that and found that it was so or more than that. He said to his wife: Sister of Band Firis, what is th-is? She said: By the coolness of my eyes. it is in excess by three times over the previous one. Then Abu Bakr ate saying: That was from the Satan (viz. his vow for not eating the food). He then took a morsel out of that and then took it (the rest) to the Messenger of Allah (may peace be upon him), and it was kept there until morning, and during (those days) there was a covenant between us and some other people, and the period of covenant was over, and we had appointed twelve officials with every person amongst them. It is Allah only Who knows as to how many people were there with each of them. He sent (this food to them) and all of them ate out of it.

Book 23, Number 5107:

    'Abd al-Rahman b. Abd Bakr reported: There came to our house some guests. It was a common practice with my father to (go) and talk to Allah's Messenger (may peace be upon him) during the night. While going he said: 'Abd al-Rahman, entertain the guests. When it was evening we served the food to them, but they refused saying: So long as the owner of the house does not come and join us, we would not take the meal. I said to them: He ('Abd Bakr) is a stern person, and if you would not do that (if you do not take the food). I fear, I may be harmed by him, but they refused. As he (my father) came, the first thing he asked was: Have you served the guests? They (the peopleof the household) said: We have not served them sofar. He said: Did I not command 'Abd al-Rahman (to do this)? He ('Abd al-Rahman) said: I slunk away and kept myself away by that time. He again said: O stupid fellow, I ask you on oath that In case you hear my voice you come to me. I came and said: By Allah, there is no fault of mine. These are your guests; you may ask them. I provided them with food but they refused to eat until you came. He said to them: Why is it that you did not accept our food? By Allah, I shall not even take food tonight (as you have not taken). They said: By Allah, we would not take until you join us. Thereupon he Abu Bakr) said: I have never seen a more unfortunate night than this. Woe be to thee! that you do not accept from us food prepared for you. He again said: What I did first (that is the taking of vow for not eating the food) was prompted by the Satan. Bring the food. The food was brought, and he ate by reciting the name of Allah and they also ate, and when it was morning he came to Allah's Apostle (may peace be upon him) and said: Allah's Messenger, their oath (that of the guests) came to be true, but mine was not true, and after that he informed him of the whole incident. He said: Your oath came to be the most true and you are the best of them. He (the narrator) said. I do not know whether he made an atonement for it.

Chapter 31 : EXCELLENCE OF SHARING THE SMALL FOOD

Book 23, Number 5108:

    Abu Huraira reported Allah's Messenger (may peace be upon him) as saying: Food for two persons suffices three persons and food for three persons suffices four persons.

Book 23, Number 5109:

    Jabir b. 'Abdullah reported: I heard Allah'.s Messenger (may peace be upon him) as saying: Food for one person suffices two persons and food for two persons suffices four persons, and food for four persons suffices eight persons; and in the tradition transmitted on the authority of Ishaq there is no mention of the fact that he heard it directly (from the Holy Prophet).

Book 23, Number 5110:

    A hadith like this is reported on the authority of Jabir but with a different chain of transmitters.

Book 23, Number 5111:

    Jabir reported Allah's Messenger (may peace be upon him) as saying: Food for one suffices two and food for two suffices for tour.

Book 23, Number 5112:

    Jabir reported Allah's Messenger (may peace be upon him) as saying: Food for one (person) sqffices two, and food for two (persons) suffices four persons and food for four persons suffices eight persons.

Chapter 32 : A BELIEVER RATS IN ONE INTESTINE WHEREAS A NON-BELIEVER EATS IN SEVEN INTESTINES

Book 23, Number 5113:

    Ibn 'Umar reported Allah's Messenger (may peace be upon him) as saying that a non-Muslim eats in seven intestines whereas a Muslim eats in one intestine.

Book 23, Number 5114:

    This hadith has been reported on the authority of Ibn 'Umar but with a different chain oi transmitters.

Book 23, Number 5115:

    Nafi' reported that Ibn 'Umar saw a poor man. He placed food before him and he ate much. He (Ibn 'Umar) said: He should not come to me. for I heard Allah's Messenger (may peace be upon him) as saying that the non-Muslim eats in seven intestines.

Book 23, Number 5116:

    Ibn 'Umar reported Allah's Messenger (may peace be upon him) as saying: A believer eats in one intestine, whereas a non-believer eats in seven intestines.

Book 23, Number 5117:

    This hadith has been transmitted on the authority of Jabir.

Book 23, Number 5118:

    Abu Musa reported Allah's Messenger (may peace be upon him) as saying: A believer eats in one intestine, whereas a non-believer eats in seven intestines.

Book 23, Number 5119:

    This hadith has been narrated on the authority of Abu Huraira with a different chain of transmitters.

Book 23, Number 5120:

    Abu Huraira reported that Allah's Messenger (may peace be upon him) invited a non-Muslim. Allah's Messenger (may peace be upon him) commanded that a goat be milked for him. It was milked and he drank its milk. Then the second one was milked and he drank its milk, and then the other one was milked and he drank its milk. till he drank the milk of seven goats. On the next morning he embraced Islam. And Allah's Messenger (may peace be upon him) commanded that a goat should be milked for him and he drank its milk and then another was milked but he did not finish it, whereupon Allah's Messenger (may peace be upon him) said: A believer drinks In one intestine whereas a non-believer drinks in seven intestines.

Chapter 33 : DON'T FIND FAULT WITH FOOD (SERVED TO YOU)

Book 23, Number 5121:

    Abu Huraira reported that Allah's Messenger (may peace be upon him) never found fault with food (served to him). If he liked anything, he ate it and if he did not like it he left it.

Book 23, Number 5122:

    This hadith has been narrated on the authority of A'mash with the same chain of transmitters.

Book 23, Number 5123:

    A hadith like this has been narrated on the authority of A'mash.

Book 23, Number 5124:

    Abu Huraira reported: I never saw Allah's Messenger (may peace be upon him) finding fault with food (served to him); if he liked it he ate it, and if did not like it he kept silent.

Book 23, Number 5125:

    This hadith has been narrated on the authority of Abu Huraira through a different chain of transmitters.


BOOK 24: The Book pertaining to Clothes and Decoration (KITAB AL-LIBAS WA'L-ZINAH)

KITAB AL-LIBAS WA'L-ZINAH
(BOOK PERTAINING TO CLOTHES AND DECORATION)

Back
Chapter 1 : THE USE OF GOLD AND SILVER VESSELS IS FORBIDDEN TO MEN AND WOMEN AND IT IS ALSO PROHIBITED TO DRINK IN THEM

Book 24, Number 5126:

    Umm Salama, the wife of Allah's Apostle (may peace be upon him), said: He who drinks in the vessel of silver in fact drinks down in his belly the fire of Hell.

Book 24, Number 5127:

    This hadith has been narrated on the authority of 'Ubaidullah through other chains of transmitters: He who eats or drinks in the vessel of silver and gold,- but there is no mention in any one of them of the words pertaining to eating and gold.

Book 24, Number 5128:

    Abd al-Rahman reported on the authority of his mother's sister Umm Salama who said that Allah's Messenger (may peace be upon him) said: He who drank in vessels of gold or silver he in fact drank down in his belly the fire of Hell.

Book 24, Number 5129:

    Mu'awiya b. Suwaid b. Muqarrin reporxed: I visited al-Bara' b. 'Azib and heard him say: Allah's Messenger (may peace be upon him) commanded us to do seven things and forbade us to do seven (things). He commanded us to visit the sick, to follow the funeral procession, to answer the sneezer, to fulfil the vow, to help the poor, to accept the invitation and to greet everybody, and he forbade us to wear rings or gold rings, to drink in silver (vessels), and to use the saddle cloth made of red silk, and to wear garments made of Qassi material, or garments made of silk or brocade and velvet.

Book 24, Number 5130:

    This hadith has been reported on the authority of Ash'ath b. Sulaim with the same chain of transmitters but with a slight change of wording that he made no mention of: "to fulfil the vows" but substituted these words: "finding of the lost articles".

Book 24, Number 5131:

    This hadith has been narrated on the authority of Ash'ath b. Abu ashSha'tha' with the same chain of transmitters (and with these words): There is no doubt about the words: To fulfil the vows were mentioned and this addition had been made in the. hadith: (The Holy Prophet) forbade drinking in silver vessels, for one who drinks (in them) in this world would not drink (in them) in the Hereafter.

Book 24, Number 5132:

    This hadith has been narrated on the authority of Ash'ath b. Sulaim with the same chain of transmitters but with this difference that instead of the words: Ifsha as-Salam (spreading the salutations), he substituted the words Radd as-Saldm (i.e. responding to the words of salutation) and he said : He forbade (the use of) gold ring.

Book 24, Number 5133:

    This hadith has been narrated on the auttiniity of Ash'ath b. Sulaim with the same chain of transmitters but the words (pertaining to) Ifsha as-Salam and the (use) of gold ring have been reported without doubt.

Book 24, Number 5134:

    'Abdullah b. Ukaim reported : While we were with Hudhaifa in Mada'in he asked for water. A villager brought a drink for him in a silver vessel. He (Hudhaifa) threw it away saying: I inform you that I have already conveyed to him that he should not serve me drink in it (silver vessel) for Allah's Messenger (may peace be upon him) had said: Do not drink in gold and silver vessels, and do not wear brocade or silk, for these are meant for them (the non-believers) in this world, but they are meant for you in the Hereafter on the Day, of Resurrection.

Book 24, Number 5135:

    This badith has been reported on the authority of 'Abdullah b. Ukaim with a slight variation of wording.

Book 24, Number 5136:

    This hadith has been narrated on the authority of lbn 'Ukaim through another chain of transmitters, but in this hadith no mention is made of the words: ,On the Day of Resurrection"

Book 24, Number 5137:

    Shu'ba reported from al-Hakam that he heard 'Abd al-Rahmin (i.e. Ibn Abu Laila) as saying: I personally saw Hudhaifa asking for water in Mada'in and a man giving it to him in a silver vessel. The rest of the hadith is the same.

Book 24, Number 5138:

    This badith has been narrated on the authority of Shu'ba through another chain of transmitters. but there is no mention of the fact: ',I personally saw him" in this hadith.

Book 24, Number 5139:

    This hadith has been reported on the authority of Hudhaila with the same chain of transmitters.

Book 24, Number 5140:

    'Abd al-Rahmin b. Abu Laili reported that Hudhaifa asked for water and a Magian gave him water in a silver vessel, whereupon he said: I heard Allah's Messenger (may peace be upon him) as saying: Do not wear silk or brocade and do not drink ifi vessels of gold and silver, and do not eat in the dishes made of them (i.e. gold and silver), for these are for them (the non-believers) in this world.

Book 24, Number 5141:

    Ibn Umar reported that Umar b. Khattab saw (some one selling) the garments of silk at the door of the mosque, whereupon he said: Allah's Messenger, would that you buy it and wear it for the people on Friday and for (receiving) the delegations when they come to you? Upon this. Allah's Messenger (may peace be upon him) said: go who wears it has no share (of reward) in the Hereafter. Then these garments were sent to Allah"s Messenger (may peace be upon him), and he presented one of these silk garment to Umar. Thereupon Umar said: You make me wear (this silk garment) Whereas you said about the silk garment of Utarid (the person who had been busy selling this garment at the door of the mosque) what you had to say, whereupon Allah's Messenger (may peace be upon him) said: I have not presented you this for wearing it (but to make use of its price) ; so 'Umar presented it to his polytheist brother in Mecca.

Book 24, Number 5142:

    This hadith has been narrated by Ibn Umar through another chain of transmitters.

Book 24, Number 5143:

    Ibn Umar reported that Umar saw Utarid al-Tamimi standing in the market (and selling) the silk garments, and he was the person who went to (courts of) kings and got (high prices) for these garments from them. Umar said: Allah's Messenger I saw 'Utarid standing in the market with a silk garment; would that you buy and wear it for (receiving) the delegations of Arabs when they visit you? I (the narrator) said: I think he ('Umar) also said: You may wear it on Friday (also). Thereupon, Allah's Messenger (may peace he upon him) said: He who wears silk in this world has no share in the Hereafter. Later on when these silk garments were presented to Allah's Massenger (may peace be upon him) he presented one silk garment to 'Umar and presented one also to Usama b. Zaid and gave one to 'Ali b. Abu 'Talib. saying: Tear them and make head coverings for your ladies. 'Umar came carrying his garment and said: Allah's Messenger, you have sent it to me, whereas you had said yesterday about the (silk)garment of Utarid what you had to say. He (the Holy Prophet) said: I have not sent it to you that you wear it, but I have sent It to you so that you may derive benefit out of it; and Usama (donned) the garment (presented to him) and appeared to be brisk, whereupon Allah's Apostle (may peace be upon him) looked at him with a look by which he perceived that the Messenger of Allah (may peace be upon him) did not like what he had done. He said: Allah's Messenger. why is it that you look at me like this. whereas you yourself presented it to me ? He said : I never sent it to you to wear it, but I sent It to you so that you may tear it and make out head covering for your ladies.

Book 24, Number 5144:

    Abdullah b. Umar reported: 'Umar b. at-Khattab found a silk garment being sold in the market ; he purchased it and brought it to Allah's Messenger (may peace be upon him) and said: Allah's Messenger, get it and adorn yourself (by wearing it) on the 'Id (days) and for the delegation. Thereupon, Allah's Messenger (may peace be upon him) said: That is the dress of one who has no share (in the Hereafter). 'Umar stayed there so long as Allah wished. Then Allah's Messenger (may peace be upon him) sent him a silk cloak. 'Umar came back with that to Allah's Messenger (may peace be upon him) and said: Allah's Messenger. you said that it is the dress of one who has no share in the Hereafter, but then you sent it to me. Thereupon, Allah's Messenger (may peace be upon him) said: You sell it and meet your need (with its proceeds).

Book 24, Number 5145:

    This hadith has been narrated on the authority of Ibn Shihab with the same chain of transmitters.

Book 24, Number 5146:

    lbn 'Umar reported that 'Umar saw a person of the tribe of 'Utirid selling a garment made of brocade or silk and said to Allah's Messenger (may peace be upon him): Would that you buy it? Thereupon he (the Holy Prophet) said: He who wears it has no share for him in the Hereafter. Then Allah's Messenger (may peace be upon him) was presented with a striped silk garment and he sent it to him ('Umar). He (,Umar) said: You sent it to me whereas I heard from you about it what you had to say, whereupon he (Allah's Messenger) said: I sent it to you so that you may benefit by it.

Book 24, Number 5147:

    This hadith has been narrated on the authority of Ibn Umar through another chain of transmitters but with a slight variation of wording (and the words are that the Holy Prophet) said: I sent it to you so that you might derive benefit from it. but I did not send it to you to wear it.

Book 24, Number 5148:

    Ibn 'Umar reported that 'Umar saw a person with a garment of brocade and he brought it to Allah's Apostle (may peace he upon him)-the rest of the hadith is the same,except for the words that he (the Holy Prophet) said: I sent it to you that you might get money thereby.

Book 24, Number 5149:

    Abdullah. the freed slave of Asma' (the daughter of Abu Bakr). the maternal uncle of the son of 'Ata, reported: Asma' sent me to 'Abdullah b. 'Umar saying: The news has reached me that you prohibit the use of three things: the striped robe. saddle cloth made of red silk. and the fasting in the holy month of Rajab. 'Abdullah said to me: So far as what you say about fasting in the month of Rajab, how about one who observes continuous fasting?-and so far as what you say about the striped garment, I heard Umar b. Khatab say that he had heard from Allah's Messenger (may peace be upon him) : He who wears silk garment has no share for him (in the Hereafter), and I am afraid it may not be that striped garment; and so far as the red saddle clotb is concerned that is the saddle cloth of Abdullah and it is red. I went back to Asma' and informed her. whereupon she said : Here is the cloak of Allah's Messenger (may peace be upon him). and she brought out to me that cloak made of Persian cloth with a hem of brocade, and its sleeves bordered with brocade and said: This wall Allah's Messenger's cloak with 'A'isha until she died, and when she died. I got possession of it. The Apostle of Allah (may peace be upon him) used to wear that, and we waslied it for the sick and sought cure thereby.

Book 24, Number 5150:

    Khalifa b. Ka'b AbCi Dhubyan reported: I heard 'Abdullah b. Zubair addressing the people and saying: Behold! do not dress yuor women with silk clothes for I heard 'Umar b. Khattab as sayinp that he had heard Allah's messenger(may peace be upon him) as saying:Do not wear silk, for one who wear it in this world will not wear it in the Hereafter.

Book 24, Number 5151:

    'Asim al-Abwal reported on the authority Abu Uthman saying: 'Umar wrote to us when we were in Adharba'ijan saying:'Utba b. Farqad, this wealth is neither the result of your own labour nor the result of the labour of your father, nor the result of the labour of your mother, so feed Muslims at their own places as you feed (members of your family and yourselves at your own residence), and beware of the life of pleasure, and the dress of the polytheists and wearing of silk garments, for Allah's Messenger(may peace be upon him) forbade the wearing of silk garments, but only this much, and Allah's Messenger (may peace be upon him) raised his.forefinger and middle finger and he joined. them (to indicate that only this much silk can be allowed in the dress of a man).'Asim said also: This is what is recorded in the lette., (sent to us), and Zuhair raised his two fingers (to give an idea of the extent to which silk may be used).

Book 24, Number 5152:

    This hadith has been transmitted on the authority of 'Asim.

Book 24, Number 5153:

    Abu 'Uthman reported: While we were with 'Utba b. Farqad there came a letter of 'Umar (containing the instructions) that Allah's Messenger (may peace be upon him) had said: None should wear silk (with the exception of so much) but he will have nothing of it in the Hereafter. Abu 'Uthman said: To the extent of two fingers which are close to the thumb, and I was shown the (silk) borders of the Tayalisa mantle (which were about two fingers in breadth and I saw them.

Book 24, Number 5154:

    Qatada reported: I heard Abe 'Uthman al-Nahdi as saying: There came to us a letter of 'Umar as we were in Adharba'ijan or in Syria in the company of 'Utba b. Farqad (and the letter ran thus): After (usual praise and glorification of Allah) it is stated that Allah's Messenger (may peace be upon him) has forbidden the use of silk btit to the extent of these two fingers, and Abu Uthman said: We at once understood by these words that he meant (silk) patterns on (the cloth).

Book 24, Number 5155:

    This hadith has been reported on the authority of Qatada but there is no mention of the words of Abd Uthman.

Book 24, Number 5156:

    Suwaid b. Ghafala said: 'Umar addressed us at a place known as Jabiya (Syria) and he said: Allah's Apostle (may peace be upon him) forbade us the wearing of silk but to the extent of two or three fingers or four fingers.

Book 24, Number 5157:

    This hadith has been narrated on the authority of Qatada with the same chain of transmitters.

Book 24, Number 5158:

    Jabir b. Abdullah reported that one day Allah's Apostle (may peace be upon him) put on a cloak made of brocade, which had been presented to him. He then quickly put it off and sent it to 'Umar b. Khattab, and it was said to him: Messenger of Allah. why is it that you put it of immediately. whereupon he said: Gabriel forbade me from it (i.e. wearing of Ods garment), and 'Umar came to him weeping and said: Messenger of Allah you disapproved a thing but you gave it to me. What about me, then? Thereupon be (the Holy Prophet) Wd: I did not give it to you to wear it, but I gave you that you might sell it; and so he (Hadrat Umar) sold it for two thousand dirhams.

Book 24, Number 5159:

    'Ali reported: A silk cloak was presented to Allah's Messenger (may peace be upon him). and he sent it to me and I wore it. but then found some sign of disapproval upon his face, whereupon he said: I did not send it to you that you wear it, but I sent it to you so that you might tear it and make out head dream for your women.

Book 24, Number 5160:

    This hadith has been narrated on the authority of Mubammad b. Ja'far but with a slight variation of wording.

Book 24, Number 5161:

    'Ali reported that Ukaidir of Duma presented to Allah's Apostle (may peace be upon him) a silk garment, and he presented it to 'Ali. and said: Tear it to make head covering for Fitimas out of it. This tradition is transmitted on the authority of Abu Bakr, and Abu Kuraib said: Among the women.

Book 24, Number 5162:

    'Ali b. Abu Talib reported that Allah's Messenger (may peace be upon him) gave me to wear a garment in the form of silk cloak. I went out wearing it, but saw signs of anger on his face, so I tore it and distributed it amongst my women.

Book 24, Number 5163:

    Anas b. Malik reported that Allah's Messenger (may Peace be upon him) sent a silk gown to 'Umar, whereupon 'Umar said: You sent it to me whereas you said what you had to, say (i.e. it is forbidden for men). Thereupon he (the Holy Prophet) said: I did not send it to you so that you might wear it, but I sent it to you so that you might derive benefit from its price.

Book 24, Number 5164:

    Anas reported that Allah's Messenger (may peace be upon him) said: He who wore silk in this world would not wear it in the Hereafter.

Book 24, Number 5165:

    Abu Umama reported Allah's Messenger (may peace be upon him) having said: He who wore silk in this world would not wear it in the Hereafter.

Book 24, Number 5166:

    Uqba b. 'Amir said: A silk go vn was presented to Allah's Messenger (may peace be upon him) and he wore it and observed prayer in it and then returned and put it off so violently as if he despised it. He then said: It does not befit the Godfearing persons.

Book 24, Number 5167:

    This hadith has been narrated on the authority of azid b. Abu Habib with the same chain of transmitters.

Chapter 2 : IT IS PERMISSIBLE FOR A MAN TO WEAR SILK BECAUSP OF ITCH OR SOME OTHER REASON

Book 24, Number 5168:

    Anas b. Malik reported to them (his companions) that Allah's Messnger (may peace be upon him) had granted concession to Abd al-Rahman b. *Anf and Zubair b. 'Awwam for the wearing of a silk shirt during the journey and because of itch which they both had or any other disease from which both of them had been suffering.

Book 24, Number 5169:

    This hadith has been narrated on the authority of Sa'd with the same chain of transmitters but there is no mention of the word "journey".

Book 24, Number 5170:

    Anas reported that Allah's Messenger (may peace be upon him) granted concession, or Zubair b. Awwam and 'Abd Al-Rahman b. Auf were granted concession, for the wearing of silk because of the itch that they both had.

Book 24, Number 5171:

    This hadith has been narrated on the authority of Shu'ba with the same chain of transmitters.

Book 24, Number 5172:

    Anas b. Malik reported that 'Abd al-Rahman b. Auf and Zu'bair. b. 'Awwam complained to Allah's Messenger (may peace be upon him) about lice; he granted them concession to wear shirts of silk.

Chapter 3 : IT IS NOT PERMISSIBLE FOR A MAN TO WEAR CLOTHES OF YELLOW COLOUR

Book 24, Number 5173:

    'Abdullah b. 'Amr b. al-As reported: Allah's Messenger (may peace be upon him) saw me wearing two clothes dyed in saffron. whereupon he said: These are the clothes (usually worn by) the non-believers, so do not wear them.

Book 24, Number 5174:

    This hadith has been reported on the authority of Yahya b. Abu Kathir with the same chain of trarnmitteis.

Book 24, Number 5175:

    'Abdullah b. 'Amr reported: Allah's Apostle (may peace be upon him) saw me in two clothes dyed in saffron, whereupon he said: Has your mother ordered you to do so? And I said: I will wash them. He said: But burn them.

Book 24, Number 5176:

    'Ali b. Abu Talib reported that Allah's Messenger (may peace be upon him) forbade wearing of silk and yellow clothes, and the gold ring, and the reciting of the Qur'an in the ruku' (state of kneeling in prayer).

Book 24, Number 5177:

    Ali b. Abu Talib reported: Allah's Apostle (may peace be upon him) forbade me to recite the Qur'an while I am in ruku; and the wearing of gold and clothes dyed in saffron.

Book 24, Number 5178:

    'Ali b. Abu Talib reported: Allah's Meisenger (may peace be upon him) forbade me to use gold rings. to wear silk clothes and to recite the Qur'an in ruku' and sajda (prostration), and to wear yellow garments.

Chapter 4 : EXCELLENCE OF WEARING THE MANTLES OF YEMEN

Book 24, Number 5179:

    Qatada said: We asked Anas b. Malik which garment did Allah's Messenger may peace be upon him) love or like (to wear). He said: The mantle of Yemen.

Book 24, Number 5180:

    Anas reported that the garment most liked by Allah's Messenger (may peace be upon him) was the mantle of Yemen.

Chapter 5 : MODESTY IN CASE OF GARMENTS AND PREFERENCE FOR TYIE COARSE CLOTH FOR WEARING AND THE PERMISSIBILITY OF WEARING CLOTH MADE OF (CAMEL'S) HAIR

Book 24, Number 5181:

    Abu Burda reported: I visited A'isha and she brought out for us the coarse lower garfnent (of Allah's Messenger) made in Yemen and clothes made out of Mulabbada cloth, and she swore in the name of Allah that Allah's Messenger (may peace be upon him) died in these two clothes.

Book 24, Number 5182:

    Abu Burda reported that A'isha brought out for us the lower garment and the upper garment made of the Mulabbada cloth and said : It was in these (clothes) that Allah's Messenger (may peace be upon him) died. Ibn Hatim(one of the narrators) in his narration Wd: The lower garment of coarse cloth.

Book 24, Number 5183:

    This hadith has been reported on the authority of Ayyub with a slight variation of wording.

Book 24, Number 5184:

    A'isha reported that Allah's Apostle (may peace be upon him) went out one morning wearing a blanket made of (camel's or sheep's) black hair with patterns of camel saddles upon it.

Book 24, Number 5185:

    A'isha reported that the pillow on which Allah's Messenger (may peace be upon him) reclined was of leather stuffed with palm fibre.

Book 24, Number 5186:

    A'isha reported that the bedding on which.Allah's Messenger (may peace be upon him) slept was made of leather stuffed with palm fibre.

Book 24, Number 5187:

    This hadith has been reported on the authority of Hisham b. 'Urwa with a slight variation of wording.

Chapter 6 : IT IS PERIIISSIBLE TO USE CARPETS

Book 24, Number 5188:

    Jabir reported: When I was married, Allah's Messenger (may peace he upon him) asked me if I had got the carpet. I said: How can we have carpets? (i.e. I am so poor that I cannot even think of carpets). whereupon he said: You shall soon possess them.

Book 24, Number 5189:

    Jabir b. Abdullah reported: When I was married. Allah's Messenger (may peace be upon him) asked me if I had got carpets. I said: How can we have carpets? Thereupon he Wd: You will soon have. Jabir said: My wife had possessed a carpet. and I said to her to remove that away from me, but she would say! Allah's Messenger (may peace be npon him) had said: Yon will soon have. This hadith has been narrated on the authority of Sufyin with the saule chain of transmitters but with a slight variation of wording.

Chapter 7 : DISAPPROVAL OF KEEPING MORE BEDDINGS AND CLOTHES THAN ARE GENUINELY NEEDED

Book 24, Number 5190:

    Jabir b. 'Abdullah reported that Allah's Messengor (may peace be upon him) said: There should be a bedding for a man. a bedding for his wife and the third one for the guest, and the fourth one is for the Satan.

Chapter 8 : IT IS FORBIDDEN TO TRAIL ONE'S GARMENT OUT OF CONCEIT OR PRIDE

Book 24, Number 5191:

    Ibn 'Umar reported Allah's Messenger (may peace be upon him) having said: Allah will not look upon him who trails his garment out of pride.

Book 24, Number 5192:

    This hadith has been narrated on the authority of Ibn 'Umar through other chains of transmitters also with the addition of these words: "On the Day of Resurrection."

Book 24, Number 5193:

    Ibn 'Umar reported Allah's Messenger(may peace be upon him) having said: He who trails his (lower) garment out of pride, Allah will not look toward him on the Day of Resurrection.

Book 24, Number 5194:

    This hadith has been narrated on the authority of Ibn 'Umar through another chain of transmitters.

Book 24, Number 5195:

    Ibn 'Umar reported Allah's Messenger (may peace be upon him) having said: He who trailed his garment out of pride, Allah would not look toward him on the Day of Resurrection.

Book 24, Number 5196:

    Salim reported: I heard Ibn Umar as saying that he had heard Allah's Messenger (may peace be upon him) as saying like this (as mentioned above) but with a slight variation of wording [that instead of the word thaub (cloth) there is the word thiyab (the clothes)].

Book 24, Number 5197:

    Muslim b. Yannaq reported that Ibn Umar saw a person trailing his lower garment, whereupon he said: From whom do you come? He described his relationship (with the tribe he belonged) and it was found that he belonged to the tribe of Laith. Ibn .Umar recognised him and said: I heard Allah's Messenger (may peace be upon him) with these two ears of mine saying: He who trailed his lower garment with no other intention but pride, Allah would not look toward him on the Day of Resurrection.

Book 24, Number 5198:

    This hadith has been narrated on the authority of Muslim b. Yannaq through another chain of transmitters but with a slight variation of wording.

Book 24, Number 5199:

    Mubammad b. 'Abbad b. ja'far reported: I ordered Muslim b. Yasar, the freed slave of Nafi' b. 'Abd al-Harith, while I was sitting between them, that he should ask Ibn 'Umar if he had heard anything from Allah's Messenger (may peace be upon him) pertaining to one who trails his lower garment out of pride. He said: I heard him (the Holy Prophet) as saying: Allah will not look toward him on the Day of Resurrection.

Book 24, Number 5200:

    Ibn 'Umar reported: I happened to pass before Allah's Messenger (may peace be upon bin) with my lower garment trailing (upon the ground). He said: 'Abdullah, tug up your lower garment,, I tugged it up, and he again said: Tug it still further, and I tugged it still further and I went on tugging it afterward, whereupon some of the people said: To what extent ? Thereupon he said: To the middle of the shanks.

Book 24, Number 5201:

    Abu Huraire reported that he saw a person whose lower garment bad been trailin. and he was striking the ground with his foot (conceitedly). He was the Amir of Bahrain and it was being said: Here comes the Amir, here comes the Amir. He (Abu Huraira) reported that Allah's Messenger (may peace be upon him) said: Allah will not look toward him who trails his lower garment out of pride.

Book 24, Number 5202:

    This hadith has been reported on the authority of Shu'ba with the same chain of transmitters and in the hadith transmitted on the authority of Ibn ja'far (the words are): Marwan had made Abu Huraira as his deputy. and in the hadith transmitted on the authority of Ibn Muthanna (the words are). Abu Huraira was the Governor of Medina.

Chapter 9 : IT IS FORBIDDEN TO WALK WITH PRIDE, OVER PLEASED WITH FINE CLOTHES

Book 24, Number 5203:

    Abu Huraira reported that Allah's Messenger (may peace be upon him) said that there was a person who used to walk with pride because of his thick hair and fine mantles. He was made to sink in the earth and he would go on sinking in the earth until the Last Hour would come.

Book 24, Number 5204:

    This hadith has been narrated on the authority of Abu Huraira but with a different chain of transmitters.

Book 24, Number 5205:

    Abu Huraira reported Allah's Messenger (may peace be upon him) as saying: There was a person who walked with pride because of his (fine) mantles and well pleased with his personality. Allah made him sink in the earth and he would go on sinking in that until the Day of Resurrection.

Book 24, Number 5206:

    This hadith has been transmitted on the authority of Abu Huraira but with a slight variation of wording: While there was a man who strutted in his two mantles.

Book 24, Number 5207:

    Abu Huraira reported Allah's Messenger(may peace be upon him) as saying: There was a person (living before you) who took pride in his cloak. the rest of the hadith is the same.

Chapter 10 : ABOUT THE SIGNET RING MADE OF GOLD

Book 24, Number 5208:

    Abu Huraira reported that Allah's Apostle (may peace be upon him) forbade the wearing of gold signet ring.

Book 24, Number 5209:

    Abdullah b. 'Abbas reported that Allah's Messenger (may peace be upon him) saw a person wearing a gold signet ring in his hand. He (the Holy Prophet) pulled it off and threw it away, saying: One of you is wishing live coal from Hell. and putting it on his hand. It was said to the person after Allah's Messenger (may peace be upon him) had left: Take your signet ring (of gold) and derive benefit out of it. whereupon he said: No, by Allah, I would never take it when Allah's Messenger (may peace be upon him) has thrown it away.

Book 24, Number 5210:

    'Abdullah reported that Allah's Messenger (may peace be upol him) got fashioned a signet ring of gold but he kept its stone on the inner side of his palm as he wore it, so the people (following his example) got fashioned (such rings). Then one day as he sat on the pulpit he pulled it away saying: I wore this ring and kept its stone towards the inner side. He then threw it away, and said: By Allah, I will never wear it; so the people threw their rings away.

Book 24, Number 5211:

    This hadith has been narrated on the authority of Ibn 'Umar through other chains of transmitters but with a slight variation of wording.

Chapter 11 : WEARING OF SILVER RING BY ALLAH'S APOSTLE (MAY PEACE BE UPON HIM) IN WHICH WERE ENGRAVED THE WORDS(MUHAMMAD THE MESSENGER OF ALLAH) AND AFTER HIM HIS SUCCESSORS WORE IT

Book 24, Number 5212:

    Ibn Umar reported that Allah's Messenger (may peace be upon him) had made for himself a ring of silver, and he (wore it in his finger). then it was in Abu Bakr's finger. then it was in'Umar's finger. then it was in 'Uthman's finger. until it fell into the well of Aris and it had these words engraved upon it (Muhammad, Messenger of Allah). Ibn Numair narrated it with a slight variation of words.

Book 24, Number 5213:

    Ibn Umar reported that Allah's Apostle (may peace be upon hirn) had made for himself a gold ring; then lie discarded it. and then made for himself a silver ring. and had these words engraved upon it (Mubamrnad, Messenger of Allah), and said: No one should engrave anything like the engraving of this signet ring of mine. and when he Wore it. he kept its stone towards the inside of his palm, and it was this which fell down (from the hands) of Mu'ayqib into the well of Aris.

Book 24, Number 5214:

    Anas b. Malik reported that Allah's Apostle (may peace be upon him) had made for him a silver ring. and got engraved on it (Mubamrnad, Messenger of Allah) and said to the people I have got made a ring of silver and engraved in it (these words) (Mubamrnad, Messenger of Allah). So none should engrave these (words) like this engravement.

Book 24, Number 5215:

    This hadith nas been reported on the authority of Anas through another chain of transmitters but there is no mention of the words (Mubamrnad, Messenger of Allah)in it.

Chapter 12 : ALLAH'S MESSENGER (MAY PEACE BE UPON HIM) GOT MADE FOR HIMSELF A SIGNET RING WHEN HE DECIDITD TO WRITE LETTERS TO THE NON-ARABS

Book 24, Number 5216:

    Anas b. Malik reported that when Allah's Messenger (may peace be upon him) decided to write letters to the Byzantine (Emperor) they (his Companions) told him that they would not read a letter unless it is sealed. (Then) Allah's Messenger (may peace be upon him) had a silver ring made (for himealf), (its shape is to vivid in my mind) as if I see its brightness in the band of Allah's Messenger (may peace be upon him) and its engravement was (Mubamrnad, Messenger of Allah).

Book 24, Number 5217:

    Anas reported that when Allah's Apostle (may peace be upon him) decided to write (letters) to non-Arabs (i.e. Persian and Byzantine Emperors) it was said to him that the non-Arabs would not accept a letter but that having a seal over it; so he (the Holy Prophet) got a silver ring made. He (Anas) said: I perceive as if I am looking at its brightness in his hand.

Book 24, Number 5218:

    Anas reported that when Allah's Apostle (may peace be upon him) decided to write to the Kisri (the King of Persia), Caesar (Emperor of Rome), and the Negus (the Emperor of Abyssinia), it was said to him that they would not accept the letter without the seal over it; so Allah's Messenger (may peace be upon him) got a seal made, the ring of which was made of silver and there was engraved on it. (Mubammad. the Messenger of Allab).

Chapter 13 : PERTAINING TO THE DISCARDING OF RINGS

Book 24, Number 5219:

    Anas b. Malik reported: I saw one day on the finger of Allah's Messenger (may peace be Upon him) a silver ring; so the people also got silver rings made and wore them Then Allah's Apostle (may peace be upon him) discarded his ring, and the people also discarded their rings.

Book 24, Number 5220:

    Anas b. Malik reported that one day he saw on the finger of Allah's Messenger (may peace be upon him) a silver ring, and the people also made silver rings and put them on. Then Allah's Apostle (may peace be upon him) threw his ring away, and so the people also threw away their rings.

Book 24, Number 5221:

    A hadith like this has been reported on the authority of Ibn Juraij with the same chain of transmitters.

Book 24, Number 5222:

    Anas b. Malik reported that the ring of Allah's Messenger (may peace be upon him) was made of silver and it had an Abyssinian stone in it.

Book 24, Number 5223:

    Anas b. Malik reported that Allah's Messenger (may peace be upon him) wore a silver ring on his right hand which had an Abyssinian stone in it, and he kept its stone towards the palm.

Book 24, Number 5224:

    This hadith has been narrated on the authority of Yunus b. Yazid with the same chain of transmitters.

Book 24, Number 5225:

    Anas reported that the ring of Allah's Apostle (may peace be upon him) was on this, and he pointed toward the little finger of his left hand.

Book 24, Number 5226:

    Ali reported: He the Holy Prophet (may peace be upon him), forbade me that I should wear my ring in this (forefinger) or in that near it. 'Asim (one of the narrators in the chain of transmitters) said: He did not remember which of the two (fingers) he pointed out; and he forbade to wear Qassi material (silk garments), and to sit on the silk saddle cloth, and he said: As regards Qassi, it is a variegated garment which was brought from Egypt and Syria which had figures upon it, and as regards Mayathir, it is something which women prepared for their husbands as red cloths for their saddles.

Book 24, Number 5227:

    A hadith like this has been reported on the authority of 'Ali through a different chain of transmitters.

Book 24, Number 5228:

    'Ali b. Abu Talib reported that he (Allah'.s Apostle) forbade or forbade me. the rest of the hadith is the same.

Book 24, Number 5229:

    'Ali reported: Allah's Messenger (may peace be upon him) forbade me that I should wear a ring in this and that finger of mine, and he pointed to the middle finger and the next one.

Chapter 14 : PERTAINING TO THE WEARING OF SANDALS (OR SHOES)

Book 24, Number 5230:

    Jabir reported: I heard Allah's Apostle (may peace be upon him) saying during an expedition in which we also participated: Make a general practice of wearing sandals, for a man is riding as it were when he wears sandals.

Book 24, Number 5231:

    Abu Huraire reported Allah's Messenger (may peace be upon him) as saying: When one of you puts on sandals, he should first put in the right foot, and when he takes off he should take off the left one first, or he should put them on together or take them off together.

Book 24, Number 5232:

    Abu Huraira reported Allah's Messenger (may peace be upon him) as saying: None of you should walk in one sandal; either he should wear the two or should take off the two.

Book 24, Number 5233:

    Abu Razin reported: Abu Huraira came to us and he struck his forehead with his hand and said: Behold I you talk amongst yourself that I attribute wrongly to Allah's Messenger (may peace be upon him) (certain things) in order to guide you to the right path.In such a case, I would myself go astray. Listen. I bear testimony to the fact that I heard Allah's Messenger (may peace be upon him) saying: When the thong of any one of you is broken, he should not walk in the second one until he has got it repaired. This hadith has been reported on the authority of Abu Huraira with a different chain of transmitters.

Chapter 15 : COMMAND CONCERNING THE WRAPPING UP OF GARMENT COMPLETELY LEAVING NO OPENING FOR THE ARMS AND SITTING WITH SINGLE GARMENT WRAPPED AROUND ONES KNEES

Book 24, Number 5234:

    Jabir reported that Allah's Messenger (may peace be upon him) forbade that a man should eat with the left hand or walk with one sandal or wrap himself completely leaving no opening for the arms (to draw out) or support himself when sitting with a single garment wrapped round his knees which may expose his private parts.

Book 24, Number 5235:

    Jabir reported Allah's Messenger (may peace be upon him) as saying: When the thong of the shoe of any one of you is cut off. he should not walk with one sandal until he has got the thong repaired, and he should not walk with one shoe and he should not eat with his left hand and should not wrap his cloth round his knees or wrap himself completely leaving no room for the arins.

Chapter 16 : IT IS PROHIBITED TO LIE DOWN ON ONE'S BACK AND PLACING OF ONE'S FOOT UPON THE OTHER

Book 24, Number 5236:

    Jabir reported that Allab's Messenger (may peace be upon him) forbade the wrapping of oneself completely leaving no room for the arm and supporting oneself when sitting with a single garment wrapped round one's knees and a person raising one of his feet and placing it on the other while lying on his back.2512

Book 24, Number 5237:

    Jabir. b. Abdullah reported Allah's Messenger (may peace be upon him) as saying: Do not walk in one sandal and do not wrap the lower garment round your knees and do not eat with your left hand and do not wrap yourself completely leaving no room for the arms (to draw out) and do not place one of your feet upon the other while lying on your back.

Book 24, Number 5238:

    Jalbir b. Abdullah reported Allah's Messenger (may peace be upon him) as saying: None of you should lie on his back and place one of his feet upon the other.

Chapter 17 : PERMISSIBILITY OF PLACING ONE'S FOOT UPON THE OTHER WHILE LYING

Book 24, Number 5239:

    'Abbad b. Tamim reported from his uncle that he saw Allah's Messenger (may peace be upon him) lying in the mosque and placing his one foot upon the other.

Book 24, Number 5240:

    This hadith has been narrated on the authority of Zuhri with the same chain of transmitter.

Chapter 18 : PROHIBITION OF USING CLOTHES DYED IN SAFERON FOR MEN

Book 24, Number 5241:

    Anas b. Malik reported that Allah's Apostle (may peace he upon him) forbade dyeing (one's cloth or hair) in saffron. Hammad said that it pertains to men only.

Book 24, Number 5242:

    Anas reported that Allah's Messenger (may peace be upon him) forbade that a person should (wear) clothes dyed in saffron.

Book 24, Number 5243:

    Jabir reported that when Abu Qubafa (father of Abu Bakr) came in the yeu of Victory or on the Day of Victory (to the Holy Prophet to pledge his allegiance to him) his head and his beard were white like hyssop. He (the Holy Prophet) commaded or the women were commanded by him that they should change this with something (that the colour of his hair should be changed).

Book 24, Number 5244:

    Jabir b. 'Abdullah reported that Abu Qubafa was led (to the andience of the Holy Prophet) on the day of the Conquest of Mecca and his head and beard were white like hyssop, whereupon Allah's Messenger (may peace be upon him) said: Change it with something but avoid black.

Book 24, Number 5245:

    Abu Horaira reported Allah's Messenger (may peace be upon him) as saying: The Jews and the Christians do not dye (their hair), so oppose them.

Chapter 19 : ANGELS DO NOT ENTER A HOUSE IN WHICH THERE IS A DOG OR A PICTURE

Book 24, Number 5246:

    A'isha reported that Gabriel (peace be upon him) made a promise with Allah's Messenger (may peace be upon him) to come at a definite hour; that hour came but he did not visit him. And there was in his hand (in the hand of Allah's Apostle) a staff. He threw it from his hand and said: Never has Allah or His messengers (angels) ever broken their promise. Then he cast a glance (and by chance) found a puppy under his cot and said: 'A'isha, when did this dog enter here ? She said: BY Allah, I don't know He then commanded and it was turned out. Then Gabriel came and Allah's Messenger (may peace be upon him) said to him: You promised me and I waited for you. but you did not come, whereupon he said: It was the dog in your house which prevented me (to come), for we (angels) do not enter a house in which there is a dog or a picture.

Book 24, Number 5247:

    This hadith has been narrated on the authority of Abu Hazim with the same chain of transmitters that Gabriel had promised Allah's Messenger (may peace be upon him) that he would come ; the rest of the hadith is the same, but it is not so lengthy as the other one.

Book 24, Number 5248:

    Maimuna reported that one morning Allah's Messenger (may peace be upon him) was silent with grief. Maimuna said: Allah's Messenger, I find a change in your mood today. Allah's Messenger (may peace be upon him) said: Gabriel had promised me that he would meet me tonight, but he did not meet me. By Allah, he never broke his promises, and Allah's Messenger (may peace be upon him) spent the day in this sad (mood). Then it occurred to him that there had been a puppy under their cot. He commanded and it was turned out. He then took some water in his hand and sprinkled it at that place. When it was evening Gabriel met him and he said to him: you promised me that you would meet me the previous night. He said: Yes, but we do not enter a house in which there is a dog or a picture. Then on that very morning he commanded the killing of the dogs until he announced that the dog kept for the orchards should also be killed, but he spared the dog meant for the protection of extensive fields (or big gardens).

Book 24, Number 5249:

    Abu Talha reported Allah's Apostle (may peace be upon him) having said: Angels do not enter a house in which there is a dog or a picture.

Book 24, Number 5250:

    Abu Talha reported: I heard Allah's Messenger (may peace be upon him) as saying: Angels do not enter the house in which there is a dog or a statue.

Book 24, Number 5251:

    This hadith has been reported on the authority of Zuhri with the same chain of transmitters.

Book 24, Number 5252:

    Abu Tilha, the Companion of Allah's Messenger (may peace be upon him), reported Allah's Messenger (may peace be upon him) having said: Verily, angels do not enter the house in which there is a picture. Busr reported : Zaid fell ill and we went to inquire after his health and (found) that there was hanging at his door a curtain with a picture on it. I said to 'Ubaidullah Khaulani who had been under the patronage of Maimuna, the wife of Allah's Apostle (may peace be upon him): Did not Zaid himself inform us before about (the Holy Prophet's command pertaining to the pictures), whereupon 'Ubaidullah said: Did you not hear when he said: "Except the prints on the cloth" ?

Book 24, Number 5253:

    Abu Talha reported that Allah's Messenger (may peace be upon him) said: Angels do not enter a house in which there is a picture. Busr said: Zaid b. Khalid fell sick and we visited him to inquire after his health. As we were in his house (we saw) a curtain having pictures on it. I said to 'Ubaidullah Khaulani: Did he not narrate to us (the Holy Prophet's command pertaining to pictures)? Thereupon he said: He in fact did that (but he also said): Except the prints upon the cloth. Did you not hear this? I said: No, whereupon He said: He had in fact made a mention of this.

Book 24, Number 5254:

    Abu Talha Ansari reported Allah's Messenger (may peace be upon him) as saying: Angels do not enter the house in which there is a picture or portraits. I came to 'A'isha and said to her: This is a news that I have received that Allah's Apostle (may peace be upon him) had said: Angels do not enter the house in which there is a picture or a dog, (and further added) whether she had heard Allah's Messenger (may peace be upon him) making a mention of it. She said: No (I did not hear this myself), but I narrate to you what I saw him doing. I bear testimony to the fact that he (the Holy Prophet) set out for an expedition. I took a carpet and screened the door with it. When he (the Holy Prophet) came back he saw that carpet and I perceived signs of disapproval on his face. He pulled it until it was torn or it was cut (into pieces) and he said: God has not commanded us to clothe stones and clay. We cut it (the curtain) and prepared two pillowa out of it by stuffing them with the fibre of date-palms and he (the Holy Prophet) did not find fault with it.

Book 24, Number 5255:

    A'isha reported: We had a curtain with us which had portraits of birds upon it. Whenever a visitor came, he found them in front of him. Thereupon Allah's Messenger (may peace be upop him) said to me: Change them, for whenever I enter the room) I see them and it brings to my mind (the pleasures) of worldly life. She said: We had with us a sheet which had silk badges upon it and we used to wear it. This hadith has been transmitted on the authority of Ibn Muthanna but with this addition: 'Allah's Messenger (may peace be upon him) did not command us to tear that."

Book 24, Number 5256:

    A'isha reported : Allah's Messenger (may peace be upon him) came back from the journey and I had screened my door with a curtain having portraits of winged horses upon it. He commanded me and I pulled it away.

Book 24, Number 5257:

    This hadith has been narrpted on the authority of Waki' with the same chain of transmitters but with a slight variation of wording.

Book 24, Number 5258:

    A'isha reported that Allah's Messenger (may peace be upon him) entered (my apartment) and I had hung (on the door of my apartment) a thin curtain having pictures on it. The colour of his face underwent a change. He then took hold of that curtain and tore it and then said: The most grievous torfnent for the people on the Day of Resurrection would be for those who try to imitate Allah in the act of creation.

Book 24, Number 5259:

    This hadith has been narrated on the authority of A'isha through another chain of transmitters but with a slight variation of wording (and the variation is that the narrator is reported to have said): He (the Holy Prophet) inclined towards that curtain and tore it with his hand.

Book 24, Number 5260:

    This hadith has been narrated on the authority of Zuhri with the same chain of transmitters but with a slight variation of wording.

Book 24, Number 5261:

    A'isha reported: Allah's Messenger (may peace be upon him) visited me. and I had a shelf with a thin cloth curtain hangin. over it and on which there were portraits. No sooner did he see it than he tore it and the colour of his face underwent a change and he said: A'isha, the most grievous torment from the Hand of Allah on the Day of Resurrection would be for those who imitate (Allah) in the act of His creation. A'isha said: We tore it into pieces and made a cushion or two cushions out of that.

Book 24, Number 5262:

    A'isha reported she had a cloth havinc, pictures upon it and it was hanging upon the shelf and Allah's Messenger (may peace be upon him) said: Take it (away) from me (from my sight), so I removed it and made cushions from that.

Book 24, Number 5263:

    This hadith has been narrated on the authority of Shu'ba with the same chain of transmitters.

Book 24, Number 5264:

    A'isha reported: Allah's Apostle (may peace be upon him) visited me when I had screened (my door) with a carpet having pictures on it. He removed it and we made cushions out of that.

Book 24, Number 5265:

    A'isha, the wife of Allah's Messenger (may peace be upon him), reported that she had hung a curtain which had pictures upon it. Allah's Messenger (may peace be upon him) entered (the room) and he pulled it. A'isha said: I then tore it and prepared two cushions out of that. A person who was then in that company and whose name was Rabi'a b. 'Ata, the freed slave of Banu Zuhra, asked: Did you hear Abu Mabammad making a mention of A'isha having stated that Allah's Messenger (may peace be upon him) used to recline upon them? lbn al-Qasim said: No, but I heard Qasim b. Muhammad saying so.

Book 24, Number 5266:

    A'isha reported that she bought a carpet which had pictures on it. When Allah's Messenger (may peace be upon him) saw that, he stayed at the door and did not get in. I perceived or I was made to perceive upon his face signs of disgust. She said: Allah's Messenger, I offer repentance to Allah and His Messenger. (but tell me) what is the sin that I have committed. Thereupon Allah's Messenger (may peace be upon him) said: What is this carpet? She said: I bought it for you so that you might sit on it and take rest. Thereupon Allah's Messenger (may peace be upon him) said: The owners of these pictures would be tormented and they would be asked to bring to life what they tried to create. He then said: Angels do not enter the house in which there is a picture.

Book 24, Number 5267:

    This hadith has been narrated on the authority of A'isha through another chain of transmitters also. Some of the other ahadith narrated through other chains of transmitters are more complete and there is an addition in them (transmitted through other chains of transmitters). In the hadith transmitted on the authority of the nephew of Majishun she (A'isha) is reported to have said: I took it and prepared two cushions out of that and he (the Holy Prophet) used to recline against them in the house.

Book 24, Number 5268:

    Ibn 'Umar reported Allah's Messenger (may peace be upon him) having said: Those who paint pictures would be punished on the Day of Resurrection and it would be said to them: Breathe soul into what you.have created.

Book 24, Number 5269:

    Ibn 'Umar reported a hadith like this through another chain of transmitters.

Book 24, Number 5270:

    'Abdullah reported Allah's Messenger (may peace be upon him) as saying: Verity the most grievously tormented people on the Day of Resurrection would be the painters of pictures. Ashajj (one of the narrators) in the hadith narrated by him did not make mention of the word "verity".

Book 24, Number 5271:

    This haditli has been reported on the authority of Abu Mu'awiya through another chain of tranmitters (and the words are): "Verity, the most grievously tormented people amongest the denizens of Hall on the Day of Resurrection would be the painters of pictures. The rest of the hadith is the same.

Book 24, Number 5272:

    Muslim b. Subaih reported: I was with Masriuq in the house which had the portrayals of Mary (hadrat Maryan). Thereupon Masriuq said: These are portraits of Kisra. I said: No, these are of Mary. Masruq said: I heard Abdullah b, Mas'ud as saying Allah's Messenger (may peace be upon him) had said : The most grievously tormented people on the Day of Resurrection would be the painters of pictures. (Muslim said): I read this before Nasr b.'Ali at-Jahdami and he read it before other narrators, the last one being Ibn Sa'id b Abl at Hasan that a person came to Ibn 'Abbas and said: I am the person who paints pictures; give me a religious verdict about them. He (Ibn 'Abbas) said to him: Come near me (still further). He came near him so much so that he placed his hand upon his head and said: I am going to narrate to yor what I heard from Allah's Messenger (may peace be upon him). I heard him say: All the painters who make pictures would be in the fire of Hell. The soul will be breathed in every picture prepared by him and it shall punish him in the Hell, and he (Ibn 'Abbas) said: If you have to do it at all, then paint the pictures of trees and lifeless things; and Nasr b.'Ali confirmed it.

Book 24, Number 5273:

    Anas b. Malik said: I was sitting with Ibn Ahbas when he gave religious verdicts but he did not say that it was Allah's Messenger (may peace be upon him) who had said that. However when a man said to him (Ibn 'Abbas) : I am the painter of these pictures. Ibn 'Abbas said: I heard Allah's Messenger (may peace be upon him) as saying: He who painted pictures in the world would be compelled to breathe soal in them on the Day of Resurrection, but he would not be able to breathe soul (in them).

Book 24, Number 5274:

    Nadr b. Anas reported that a person came to Ibn 'Abbas and he narrated (the above menlioned hadith) from Allah's Apostle (may peace be upon him).

Book 24, Number 5275:

    Abu Zur'a reported: I visited the house of Marwan in the company of Abu Huraira and he found pictures there. whereupon he said: I heard Allah's Messenger (may peace be upon him) as saying: Allah, the Glorious and Exalted, said: Who is a more wrongdoer than one who tries to create creation like Mine creation. Let him create an atom or a grain of wheat or that of barley. This hadith has been transmitted on the authority of Abu Zur'a and he said : Abu Huraira went to the house of Sa'ld or Marwan which they had built in Medina and he (Abu Huraira) saw a painter who had been painting pictures in his house, whereupon he told that Allah's Messenger (may peace be upon him) had said like this, but he made no mention of the words: "Let him create the grain of barley."

Book 24, Number 5276:

    Abu Huraira reported Allah's Messenger (may peace be upon him) as saying: Angels do not enter the house in which there are portrayals or pictures.

Chapter 20 : DISAPPROVAL OF SETTING OUT ON A JOURNEY ALONG WITH A DOG AND BELLS

Book 24, Number 5277:

    Abu Huraira reported Allah's Messenger (may peace be upon him) as saying: Angels do not accompany the travellers who have with them a dog and a bell.

Book 24, Number 5278:

    This hadith has been reported on the authority of Suhail with the same chain of transmitters.

Book 24, Number 5279:

    Abu Huraira reported Allah's Messenger (may peace be upon him) as saying: The bell is the musical instrument of the Satan.

Chapter 21 : DISAPPROVAL OF HANGING THE NECKLACE ROUND THE CAMELS' NECKS

Book 24, Number 5280:

    Abu Bashir Ansari reported that he had had (the opportunity of accompanying Allah's Messenger (may peace be upon him) in some of his journeys. Allah's Messenger (may peace be upon him) sent one of his messengers 'Abdullah b Abi Bakr said: I think he said (these words) when the people were at the places of rest: No necklace of strings be left on the necks of the camels or the necklace kept unbroken. Imam Malik said: To my mind (this practice) of wearing necklace round the necks of camels or animals was because of the fact that they (wanted to save them) from the influence of the evil eye.

Chapter 22 : IT IS FORBIDDEN TO BEAT THE ANIMAL ON THE FACE OR CAUTERISE AT THE FACE

Book 24, Number 5281:

    Jabir reported that Allah's Messenger (may peace be upon him) forbade (the animals to be beaten) on the face or cauterisation on the face.

Book 24, Number 5282:

    This hadith has been reported on the authority of Jabir b.'Abdullah through another chain of transmitters.

Book 24, Number 5283:

    Jabir reported that there happened to pass before Allah's Apostle(may peace be upon him) an ass the face of which had been cauterised, whereupon he said: Allah has cursed one who has cauterised it (on the face).

Book 24, Number 5284:

    Ibn Abbas reported that Allah's Messenger (may peace be upon him) saw an ass which had been cauterised on the face. He disapproved of it saying: By Allah, I do not cauterise (the animal) but on a part at a distance from the face, and commanded (for the cauterisation) of his ass and it was cauterised on the buttocks and he was the first to cauterise on the buttocks.

Book 24, Number 5285:

    Anas reported that Umm Sulaim gave birth to a child. She said to him: Anas, see that nothing is given to this child until he is brought to Allah's Apostle (may peace be upon him) in the morning, so that he should chew some dates and touch his palate with it. I went to him in the morning and he was in the garden at that time having the mantle of Jauniyya over him and he was bus in cauterising (the camels) which had been brought to him (as spoils of war) in victory (over the enemy).

Book 24, Number 5286:

    Anas reported that when his mother gave birth to a child they brought that child to Allah's Messenger (may peace be upon him) so that he might chew some dates and touch his palate with them. and Allah's Apostle (may peace be upon him) was at that time in the fold busy in cauterising the animals Shu'ba said: So far as I know (he was cauterising) their ears.

Book 24, Number 5287:

    Anas reported: We went to Allah's Messenger (may peace be upon him) as he was in the fold and he was cauterising the animals of the flock and I think (he was cauterising them) on their ears. This hadith has been narrated on the authority of Shu'ba through another chain of transmitters.

Book 24, Number 5288:

    Anas b. Malik reported: I saw in the hand of Allah's Messenger (may peace be upon him) an instrument for cauterisation and he was cauterising the caracia collected as Zakat.

Chapter 23 : DISAPPROVAL OF HAVING A PART OF THE HEAD SHAVEN AND LEAVING A PART UNSHAVED

Book 24, Number 5289:

    Ibn Umar reported that Allah's Messenger (may peace be upon him) forbade Qaza. I said to Nafi: What is Qaza'? He said: This means having a part of a boy's head shaved and leaving a part unshaven.

Book 24, Number 5290:

    This hadith has been reported on the authority of 'Ubaidullah with the same chain of transmitters. and the exposition of Qaza' is the same as that of Abu Usama.

Book 24, Number 5291:

    This hadith has been narrated on the authority of 'Umar b. Nafi' with the same chain of transmitters and Muhammad b. Muthanna as well as 'Umar b. Nafi have given the same exposition (of the word Qaza') in their narration.

Book 24, Number 5292:

    This hadith has been narrated on the authority of Ibn 'Umar through another chain of transmitters.

Chapter 24 : PROHIBITION OF SITTING ON THE ROADSIDES AND TO HONOUR THE OBLIGATIONS OF THE ROADSIDE

Book 24, Number 5293:

    Abu Sa'id Kbudri reported Allah's Apostle (may peace be upon him) as saying: Avoid sitting on the paths. They (his Companions) said: Allah's Messenger. there is no other help to it (but to sit here as we) hold our meetings and discuss matters there. Thereupon Allah's Messenger (may peace be upon him) said: If you have to sit at all, theg fulfil the rights, of the path. They said: What are their rights? Thereupon he said: Keeping the eye downward (so that you may not stare at the women), refraining from doing some harm to the other and exchanging mutual greetings (saying as-Salamu 'Alaikum to one another) and commanding the good and forbidding the evil.

Book 24, Number 5294:

    This hadith has been reported on the authority of Zaid b. Aslam with the same chain of transmitters.

Chapter 25 : IT IS FORBIDDEN TO ADD FALSE HAIR TO ONE'S HEAD, OR TO PLUCK THE EYEBROW OR TO SEPARATE THE TEETH

Book 24, Number 5295:

    Asma', daughter of Abu Bakr, reported that a woman came to Allah's Apostle (may peace be upon him) and said: I have a daughter who has been newly wedded. She had an attack of smallpox and thus her hair had fallen; should I add false hair to her head? Thereupon Allah's Messenger (may peace be upon him) said: Allah has cursed the woman who adds some false hair and the woman who asks for it.

Book 24, Number 5296:

    This hadith has been transmitted on the authority of Shu'ba with a slight variation of wording.

Book 24, Number 5297:

    Asma', daughter of Abu Bakr, reported that a woman came to Allah's Apostle (may peace be upon him) and said: I have married my daughter (whose) hair of head have fallen. Her spouse likes them (the long hair). Allah's Messenger(may add false hair to her head ? He forbade her to do this.

Book 24, Number 5298:

    A'isha reported that a girl of the Ansar who had fallen ill and had lost the hair was married. They (her relatives) thought of adding false hair (to her head). so they asked Allah's Messenger (may peace be upon him) about it, whereupon he cursed the woman who adds false hair and the woman who asks for it.

Book 24, Number 5299:

    A'isha reported that a woman from the Ansar married her daughter who had lost her hair because of illness. She came to Allah's Apostle (may peace be upon him) and said: Her husband wants that false hair should be aaded to her head. Thereupon Allah's Messenger (may peace be upon him) said: The woman who adds false hair has been cursed. This hadith has been narrated on the authority of Nafi' with the same chain of transmitters but with a slight variation of wording.

Book 24, Number 5300:

    Ibn Umar reported Allah's Messenger (may peace be upon him) cursing the woman who added false hair and the woman who asked for tattoos. This hadith has been reported on the authority of Abdullah through another chain of transmitters.

Book 24, Number 5301:

    'Abdullah reported that Allah had cursed those women who tattooed and who have themselves tattooed, those who pluck hair from their faces and those who make spaces between their teeth for beautification changing what God has created. This news reached a woman of the tribe of Asad who was called Umm Ya'qub and she used to recite the Holy Qur'an. She came to him and said: What is this news that has reached me from you that you curse those women who tattooed and those women who have themselves tattooed, the women who pluck hair from their faces and who make spaces between their teeth for beautification changing what God has created? Thereupon 'Abdullah said: Should I not curse one upon whom Allah's Messenger (may peace be upon him) has invoked curse and that is in the Book also. Thereupon that woman said: I read the Qur'an from cover to cover, but I did not find that in it. whereupon he said: If you had read (thoroughly) you would have definitely found this in that (as) Allah, the Exalted and Glorious, has said: "What Allah's Messenger brings for you accept that. and what he has forbidden you. refrain from that." That woman said: I find this thing in your wife even now. Thereupon he said: Go and see her. She reported: I went to the wife of 'Abdullah but found nothing of this sort in her. She came back to him and said: I have not seen anything. whereupon he said: Had there been anything like it in her, I would have never slept with her in the bed.

Book 24, Number 5302:

    This hadith has been reported on the authority of Mansur with the same chain of transmitters but with a slight variation of wording.

Book 24, Number 5303:

    This hadith has been narrated on the authority of Mansur without the story pertaining to Umm Ya'qub.

Book 24, Number 5304:

    This hadith has been transmitted on the authority of Abdullah.

Book 24, Number 5305:

    Jabir b. Abdullah reported that Allah's Apostle (may peace be upon him) reprimanded that a woman should add anything to her head (in the form of artificial hair).

Book 24, Number 5306:

    Abd al-Rahman b. 'Auf said that he heard Mu'awiya b Sufyin during the season of Hajj. (saying) as he sat upon the pulpit holding a bunch of hair in his hand which was (previously) in the hand of his sentinel: O people of Medina, where are your scholars? I heard Allah's Messenger (may peace be upon him) forbidding this and saying: That the people of Bani Isra'il were ruined at the time when their women wore shuch hair.

Book 24, Number 5307:

    This hadith has been transmitted on the authority of Zuhri but with a slight variation of wording.

Book 24, Number 5308:

    Sa'id b. Musayyib reported: Mu'awiya came to Medina and he addressed us and he took out a bunch of hair and said: What do I see that one of you does but that what the Jews did? (I can well recall) that when this act (adding of artificial hair) reached Allah's Messenger (may peace be upon him), he named it as cheating.

Book 24, Number 5309:

    Sa,id b. Musayyib reported that Mu'awiya said one day : Should I narrate to you the evil make-up. Allah's Apostle (may peace be upon him) forbade cheating. It was during that time that a person came with a staff and there was a cloth on its head, whereupon Mu,awiya said : Behold, that is cheating. Qatada said: This implies how women artificially increase their hair with the help of rags.

Chapter 26 : THE WOMEN WHO ARE NAKED EVEN IN THEIR DRESSES, WHO DEVIATE FROM THE RIGHT PATH AND LEAD THEIR HUSBANDS ASTRAY

Book 24, Number 5310:

    AbU Huraira reported Allah's Messenger (may peace be upon him) having said this: Two are the types of the denizens of Hell whom I did not see : people having flogs like the tails of the ox with them and they would be beating people, and the women who would be dressed but appear to be naked, who would be inclined (to evil) and make their husbands incline towards it. Their heads would be like the humps of the bukht camel inclined to one side. They will not enter Paradise and they would not smell its odour whereas its odour would be smelt from such and such distance.

Chapter 27 : PROHIBITION OF WEARING THE GARMENT OF FALSEHOOD

Book 24, Number 5311:

    A'isha reported that a woman said: Allah's Messenger, may I say to my (co-wife) that my husband has given me (such and such) a thing but which he has not in fact gives me? 'Thereupon Allah's Messenger (may peace be upon him) said: The one who makes a false statement of that which one has not been given is like one who wears a garment of falsehood.

Book 24, Number 5312:

    Asma' reported that a woman came to Allah's Apostle (may peace be upon him) and said: I have a co-wife. Is there any harm for me if I give her the false impression (of getting something from my husband which he has not in fact given me)? Thereupon Allah's Messenger (may peace be upon him) said: The one who creates such a (false impression) of receiving what one has not been given is like one who wears the garment of falsehood.

Book 24, Number 5313:

    This hadith has been reported on the authority of Hisham with the same chain of transmitters.


Book 25 : The Book on General Behaviour (KITAB AL-ADAB)

KITAB AL-ADAB
(THE BOOK ON GENERAL BEHAVIOUR)

Back
Chapter 1 : FORBIDDANCE IN CALLING ONE (OTHER THAN ALLAH'S APOSTLE) WITH THE KUNYA OF ABU'L-QASIM AND THE FACT PERTAINING TO GOOD NAMES

Book 25, Number 5314:

    Anas reported that person at Baqi' called another person as "Abu'l- Qasim," and Allah's Messenger (may peace be upon him) turned towards him. He (the person who had uttered these words) said: Messenger of Allah, I did not mean you, but I called such and such (person), whereupon Allah's Messenger (may peace be upon him) said: You may call yourself by my name, but not by my kunya.

Book 25, Number 5315:

    Ibn Umar reported that Allah's Messenger (may peace be upon him) said: The names dearest to Allah are 'Abdullah and 'Abd al-Rahman.

Book 25, Number 5316:

    Jabir b. 'Abdullah reported that a child was born to a perfon amongst us and he gave him the name of Muhammad. Thereupon his people said: We will not allow You to give the name of Muhammad (to your child) after the name of Allah's Messenger (may peace be upon him). He set forth with his son carrying him on his back and came to Allah's Apostle (may peace be upon him', and said: Allah's Messenger a son has been born to me and I havegiven him the name after the name of Allah's Messenger (may peace be upon him), whereupon Allah's Messenger (may peace be upon him) said: Give him my name but do not give him my kunya, for I am Qasim in the sense that I distribute (the spoils of war) and the dues of Zakat amongst you.

Book 25, Number 5317:

    Jabir b. 'Abdullah reported that a child was born to one of the persons amongst us and he decided to give him the name of Muhammad We said: We will not allow you to give the name after the name of Allah's Messenger (may peace be upon him) until you ask him (the Holy Prophet). So he (that person) came and said (to the Holy Prophet): A child was born in my house and I wanted to give him the name (of Muhammad) after the name of Allah's Messenger, whereas my people did not allow me that I should name him after that (sacred) name until I have asked Allah's Apostle (may peace be upon him) in this connection, whereupon he said: Give him the name after my name, but do not call him by my kunya, for I have been sent as a Qasim as I distribute amongst you.

Book 25, Number 5318:

    This hadith has been reported on the authority of Husain With the same chain of transmitters but no mention is made of these words: "(I have been sent as a distributor), so I distribute amongst you."

Book 25, Number 5319:

    Jabir b. Abdullah reported Allah's Messenger (may peace be upon him) as saying: Give the name after my name, but do not give (the kunya of Abu'l-Qasim after my) kunya, for I am Abu'l-Qasim (in the sense) that I distribute amongst you (the spoils of war) and disseminate the knowledge (of revelation). This hadith has been transmitted on the authority of Abu Bakr but with a slight variation of wording.

Book 25, Number 5320:

    This hadith has been reported on the authority of A'mash with the same chain of transmitters but there is a slight variation (of wording) that, instead of the word Bu'ithat (I have been sent), the word ju'ilat (I have been made) has been used.

Book 25, Number 5321:

    Jabir b. 'Abdullah reported that a child was born to a person from the Ansar and he made up his mind to give him the name of Muhammad. He came to Allah's Apostle (may peace be upon him) and, asked him (about it), whereupon he said: The Ansar have done well to give the name (to your children) after my name, but do nct give them the kunya after my kunya.

Book 25, Number 5322:

    This hadith has been narrated through different chains of transmitters on the authority of Shu'ba with a slight variation of wording.

Book 25, Number 5323:

    Jabir b. 'Abdullah reported: A child was born in the house of a person amongst us, and he gave him the name of Qasim. We said: We will not allow you (to give the name) to your child as Qasim (and thus adopt the kunya of Abu'l-Qasim) and coal your eyes. He (that person) came to Allah's Apostle (may peace be upon him) and made a mention of that to him, whereupon he said: Call your son 'Abd al-Rahman.

Book 25, Number 5324:

    This hadith has been reported on the authority of Ibn Uyaina, but there is no mention of this: "We will not allow you to cool your eyes."

Book 25, Number 5325:

    Abu Huraira reported that Abu'l-Qasim (may peace be upon him) said: Give name (to your children) after my name but do not give the kunya (of Abu'l- Qasim) after my kunya. 'Amr reported from Abu Huraira that he did not say that he had heard it directly from Allah's Apostle (may peace be upon him).

Book 25, Number 5326:

    Mughira b. Shu'ba reported: When I came to Najran, they (the Christians of Najran) asked me: You read "O sister of Harun" (i.e. Hadrat Maryam) in the Qur'an, whereas Moses was born much before Jesus. When I came back to Allah's Messenger (may peace be upon him) I asked him about that, whereupon he said: The (people of the old age) used to give names (to their persons) after the names of Apostles and pious persons who had gone before them.

Chapter 2 : DISAPPROVAL OF GIVING UGLY NAMES AND SUCH NAMES AS CAN BE TREATED AS ILL OMENS

Book 9, Number 5327:

    Samura b. Jundub reported: Allah's Messenger (may peace be upon him) forbade us to give names to our servants as these four names: Aflah (Successful), Rabdh (Profit), Yasar (Wealth), and Nafi' (Beneficial).

Book 25, Number 5328:

    Samura b. Jundub reported AUah's Messenger (may peace be upon him) as saying: Don't give names to your servants as Rabdh, 'Ya ar,Aflah and Nafi'.

Book 25, Number 5329:

    Samura b. Jundub reprted: The dearest words to Allah are four: Subhan Allah (Hallowed be Allah), Al-Hamdulillah (Praise be to Allah), Wa la ilaha illa-Allah (There is no god but Allah), Allah-o-Akbar (God is the Greatest). There is no harm for you in which order you begin (them while remembering Allah), and he also said: Do not give these names to your servants, Yasar and Rabah and Nafi and Najth.

Book 25, Number 5330:

    This hadith has been reported on the authority of Shu'ba and there is no mention but of the fact about giving the name to the servant and there is no mention of the four expressions (of remembrance) and he did not mention the four words

Book 25, Number 5331:

    Jabir b. 'Abdullah reported: Allah's Messenger (may peace be upon him) decided to forbid (his followers) to name persons as Ya'la (Elevated), Baraka (Blessing), Aflah (Successful), Yasar and Nafi', but I saw that he kept silent after that and he did not say anything until Allah's Messenger (may peace be upon him) died. And he did not forbid (his followers to do this), then 'Umar decided to prohibit (people) from giving these names, but later on gave up the idea.

Chapter 3 : EXCELLENCE OF CHANGING UGLY NAMES TO GOOD NAMES

Book 25, Number 5332:

    Ibn 'Umar reported that Allah's Messenger (may peace be upon him) changed the name of 'Asiya (Disobedient) and said: You are Jamila (i.e. good and handsome). Ahmad (one of the narrators) narrated it with a slight variation of wording.

Book 25, Number 5333:

    Ibn 'Umar reported that 'Umar had a daughter who was called 'Asiya. Allah's Messenger (may peace be upon him) gave her the name of Jamila.

Book 25, Number 5334:

    Ibn Abbas reported that the name of Juwairlya (the wife of the Holy Prophet) was Barra (Pious). Allah's Messenger (may peace be upon him) changed her name to Juwairiya and said : I did not like that it should be said: He had come out from Barra (Pious). The hadith transmitted on the authority of Ibn Abi 'Umar is slightly different from it.

Book 25, Number 5335:

    Abu Huraira reported that the name of Zainab was Barra. It was said of her: She presents herself to be innocent. Allah's Messenger (may peace be upon him) gave her the name of Zainab.

Book 25, Number 5336:

    Zainab, daughter of Umm Salama, reported: My name first was Barra. Allah's Messenger (may peace be upon him) gave me the name of Zainab. Then there entered (into the house of Allah's Prophet as a wife) Zainab, daughter of Jahsh, and her name was also Barra, and he gave her the name of Zainab.

Book 25, Number 5337:

    Muhammad b. 'Amr b. 'Ata' reported : I had given the name Barra to my daughter. Zainab, daughter of Abu Salama, told me that Allah's' Messenger (may peace be upon him) had forbidden me to give this name. (She said) : I was also called Barra, but Allah's Messenger (may peace be upon him) said : Don't hold yourself to be pious. It is God alone who knows the people of piety among you. They (the Companions) said: Then, what name should we give to her ? He said: Name her as Zainab.

Chapter 4 : IT IS FORBIDDEN TO CALL THE RULER AS THE KING OF KINGS OR SHAHINSHAH

Book 25, Number 5338:

    Abu Huraira reported Allah's Messenger (may peace be upon him) as saying: The vilest name in Allah's sight is Malik al-Amidh (King of Kings). The narration transmitted on the authority of Shaiba (contains these words) : There is no king but Allah, the Exalted and Glorious. Sufyan said: Similarly, the word Shahinshah (is also the vilest appellation). Ahmad b. Hanbal said: I asked Abu 'Amr about the meaning of Akhna. He said: The vilest.

Book 25, Number 5339:

    Abu Huraira reported from Allah's Messenger (may peace be upon him) so many ahadith and one of them was this that Allah's Messenger (may peace be upon him) said: The most wretched person in the sight of Allah on the Day of Resurrection and the worst person and target of His wrath would of the person who is called Malik al-Amlak (the King of Kings) for there is no king but Allah.

Chapter 5 : THE EXCELLENCE OF TAHNIK OF THE NEW-BORN CHILD AT THE TIME OF ITS BIRTH. AND, OF CARRYING IT TO A PIOUS PERSON SO THAT HE MAY SOVTEN SOME DATES AND RUB ITS PALATE WITH THEM, AND PERMISSIBILITY OF GIVING THE NAME ON THE DAY OF ITS BIRTH AND THE EXCELLENCE OF SUCH NAMES AS 'ABDULLAH, IBRAHIM AND THE NAMES OF ALL THE APOSTLES OF ALLAH (PEACE BE UPON THEM)

Book 25, Number 5340:

    Anas b. Malik reported: I took 'Abdullah b. Abi Talha Ansari to Allah's Messenger (may peace be upon him) at the time of his birth. Allah's Messenger (may peace be upon him) was at that time wearing a woollen cloak and besmearing the camels with tar. He said: Have you got with you the dates ? I said: Yes. He took hold of the dates and put them in his mouth and softened them, then opened the mouth of the infant and put that in it and the child began to lick it. Thereupon Allah's Messenger (may peace be upon him) said: The Ansar have a liking for the dates, and he (the Holy Prophet) gave him the name of 'Abdullah.

Book 25, Number 5341:

    Anas b. Malik reported that the son of Abu Talha had been ailing. Abu Talha set out (on a journey) and his son breathed his last (in his absence). When Abu Talha came back, he said (to his wife): What about my child? Umm Sulaim (the wife of Abu Talha) said: He is now in a more comfortable state than before. She served him the evening meal and he took it. He then came to her (and had sexual intercourse with her) and when it was all over she said: Make arrangements for the burial of the child. When it was morning. Abu Talha came to Allah's Messenger (may peace be upon him) and informed him, whereupon he said: Did you spend the night with her. He said : Yes. He (the Holy Prophet) then said : O Allah, bless both of them (and as a result of blessing) she gave birth to a child. Abu Talha said to me (Anas b. Malik) to take the child, (so I took him) and came to Allah's Messenger (may peace be upon him). She (Umm Sulaim) also had sent some dates (along with the child). Allah's Apostle (may peace be upon him) took him (the child) (in his lap) and said: Is there anything with you (for Tahnik). They (the Companions) said: Yes. Allah's Apostle (may peace be upon him) took hold of them (dates and chewed them). He then put them (the chewed dates) in the mouth of the child and then rubbed his palate and gave him the name of 'Abdullah.

Book 25, Number 5342:

    This hadith has been reported on the authority of Anas through another chain of transmit ters.

Book 25, Number 5343:

    Abu Musa reported: A child was born in my house and I brought him to Allah's Apostle (may peace be upod him) and he gave him the name of Ibrahim and he rubbed his palate with dates.

Book 25, Number 5344:

    'Urwa b. Zubair and Fatima daughter of Mandhir b. Zubair, reported that Asma' daughter of Abu Bakr was at the time of migration in the family way with 'Abdullah b. Zubair (in her womb). She came to Quba' and gave birth to 'Abdullah at that place and then sent him to Allah's Messenger (may peace be upon him) so that he should rub his palate with chewed dates. Allah's Messenger (may peace he upon him) took hold of him (the child) and he placed him in his lap and then called for dates. 'A'isha said: Some time was spent before we were able to find them. He (the Holy Prophet) chewed them and then put his saliva in his mouth. The first thing that entered his stomach, was the saliva of Allah's Messenger (may peace be upon him). Asma' said: He then rubbed him and blessed him and gave him the name of Abdullah. He ('Abdullah) went to him (the Holy Prophet) when he had attained the age of seven or eight years in order to pledge allegiance to Allah's Messenger (may peace be upon him) as Zubair had commanded him to do. Allah's Messenger (may peace be upon him) smiled when he saw him coming towards him and then accepted his allegiance.

Book 25, Number 5345:

    Asma' reported that she had become pregnant at Mecca with Abdullah b. Zubair (in her womt) and she (further) said: I set out (for migration to Medina) as I was in the advanced stage of pregnancy. I came to Medina and got down at the place known as Quba' and gave birth to a child there. Then I came to Allah's Messenger (may peace he upon him). He placed him (the child) in his lap and then commanded for the dates to be brought. He chewed them and then put the saliva in his mouth. The first thing which went into his stomach was the saliva of Allah's Messenger (may peace be upon him). He then rubbed his palate with dates and then invoked blessings for him and blessed him. He was the first child who was born in Islam (after Migration).

Book 25, Number 5346:

    Asma', daughter of Abu Bakr, reported that when she migrated to Allah's Messenger (may peace be upon him) in Medina she was in the family way with Abdullah b. Zubair in her womb.

Book 25, Number 5347:

    'A'isha reported that the new-born infants were brought to Allah's Messenger (may peace be upon him). He blessed them and rubbed their palates with dates.

Book 25, Number 5348:

    'A'isha reported: We took 'Abdullah b. Zubair to Allah's Apostle (may peace be upon him) so that he should put saliva in his mouth and we had to make a good deal of effort in order to procure them.

Book 25, Number 5349:

    Sahl b. Sa'd reported that Mundhir b. Aba Usaid was brought to Allah's Messenger (may peace be upon him) at the time of his birth Allah's.Apostle (may peace be upon him) placed him on his thigh and Abfi Usaid kept sitting there. Allah's Apostle (may peace be upon him) had been occupied with something else before him. Abu Usaid commanded his child to be lifted from the lap of Allah's Messenger (may peace be upon him) and so he was lifted. When Allah's Messenger (may peace be upon him) had finished the work he said: Where is the child? Abd Usaid said: Allah's Messenger, we took him away. He said: What is his name? He said; Allah's Messenger, it is so and so, whereupon he (the Holy Prophet) said: Nay, his name is Mundhir, and named him Mundhir on that day.

Book 25, Number 5350:

    Anas b. Malik reported that Allah's Messenger (may peace be upon him) had the sublimest character among mankind. I had a brother who was called Abd 'Umair. I think he was weaned. When Allah's Messenger (may peace he upon him) came to our house he saw him, and said: Abu 'Umair, what has the sparrow done? He (Anas) said that he had been playing with that.

Chapter 6 : PERMISSIBILITY OF CALLING ONE AS "MY SON," BESIDES ONE'S OWN SON

Book 25, Number 5351:

    Anas b Malik reported that Allah's Messenger (may peace be upon him) addressed me: O My Son.

Book 25, Number 5352:

    Mughira b. Shu'ba reported that none else had asked more questions from Allah's Messenger (may peace be upon him) about the Dajjal than I, but he simply said in a slight mood): O, myson, why are you worried because of him? He will not harm you. I said: The people think that he would have with him rivers of water and mountains of bread, whereupon he said: He would be more insignificant in the sight of Allah than all these things (belonging to him).

Book 25, Number 5353:

    This hadith has been reported on the authority of Ismail, with the same chain of transmitters but with a slight variation of wording.

Chapter 7 : ASKING PERMISSION TO ENTER A HOUSE

Book 25, Number 5354:

    Abu Sa'id Khudri reported: I wins sitting in Medina in the company of the Ansar that Abu Musa came trembling with fear. We said to him: What is the matter? He said: 'Umar (Allah be pleated with him) sent for me. I went to him and paid him salutation thrice at (his) door but he made no response to me and so I came back Thereupon he ('Umar) said: What stood in your way that you did not turn up? I said:I did come to you and paid you salutations at your door three times but I was not given any response, so I came back as the Messenger of Allah (may peace be upon him) has said: When any one of you seeks permission three times and he i.e not granted permission, he should come back. Umar said: Bring a witness to support that you say, otherwise I shall take you to task. Ubayy b. Ka'b said: None should stand with him (as a witness) but the youngest amongst the people. Abu Sa'id said: I am the youngest amongst the people, whereupon he said: Then you go with him (to support his contention).

Book 25, Number 5355:

    This hadith has been narrated on the authority of Yazid b. Khusaifa with the same chain of transmitters but with this addition: Abu Sa'id said: So I stood up, and went to 'Umar and gave witness (to what Abu Musa had said).

Book 25, Number 5356:

    Abd Sa'id Khudri reported: We were in the company of Ubayy b. Ka'b that Abu Musa Ash'ari came there in a state of anger. He stood (before us) and said: I ask you to bear witness in the name of Allah whether anyone amongst you heard Allah's Messenger (may peace be upon him) as saying: Permission (for entering the house) should be sought three times and if permission is granted to you (then get in). otherwise go back. Ubayy b. Ka'b said: What is the iiiatter? He said: I sought permission yesterday from 'Umar b. Khattab three times but he did not permit me, so I came back; then I went to him today and visited him and informed him that I had come to him yesterday and greeted him thrice, then came back, whereupon he said: Yes, we did hear you but be were at that time busy, but why did you not seek permission (further and you must have never gone back until you were permitted to do so). He said: I sought permission (in the manner) that I heard Allah's Messenger (may peace be upon him) having said (in connection 'With the seeking of permission for entering the house of a stranger). Thereupon he (Hadrat Umar) said: By Allah, I shall torture your back and your stomach unless you bring one who may bear witness to what you state. 'Ubayy b. Ka'b said: By Allah, none should stand with you (to bear testimony) but the youngest amongst us. And he therefore, said to Abu Sa'id: Stand up. So I stood up until I came to Umar and said: I heard Allah's Messenger (may peace be upon him) say this.

Book 25, Number 5357:

    Abu Sa'id reported that Abu Musa al-Ash'ari came to the door of 'Umar and sought his permission (to get into his house). Umar said: That is once. He again sought permission for the second time and 'Umar said: It is twice. He again sought permission for the third time and Umar said: It is thrice. He (Abu Musa) then went back. He (Hadrat 'Umar) (sent someone) to pursue him so that he should be brought back. Thereupon he (Hadrat Umar) said: If this act (of yours is in accordance with the command of Allah's Messenger (may peace be upon him) you have preserved in your mind, then it is all right, otherwise (I shall give you such a severe punishment) that it will serve as an example to others. Abu Sa'id said: Then he (Abu Musa) came to us and said: Do you remember Allah's Messenger (may peace be upon him) having said this: "Permission is for three times"? They (Companions sitting in that cothpany) began to laugh, whereupon he (Abu Musa) said: There comes to you your Muslim brother who had been perturbed and you laugh. Abu Sa'id said: (Well), you go forth. I shall be your participant in this trouble of yours. So he came to him (Hadrat Umar) and said: Here is Abu Sa'id (to support my statement).

Book 25, Number 5358:

    This hadith bu been narrated on the authority of Abu Sa'id Khudri through another chain of transmitters.

Book 25, Number 5359:

    'Ubaid b. Umair reported that Abu Musa brought permission from Umar (to enter the house) three times, and finding him busy came back, whereupon Umar said (to the Inmates of his house): Did you not hear the voice of 'Abdullah b. Qais (the Kunya of Abu Musa Ash'ari) ? He was called back. and he (Hadrat 'Umar) said: What did prompt you to do it? Thereupon, he said: This is how we have been commanded to act. He (Hadrat 'Umar) said: Bring evidence (in support of) it, otherwise I shall deal (strictly) with you. So he (Abu Musa) set out and came to the meeting of the Ansar and asked them to bear witness before hadrat Umar about this. They (the Companions present there) said: None but the youngest amongst us would bear out this fact. So Abu Sa'id Khudri (who was the youngest one in that company) said: We have been commanded to do so (while visiting the house of other people). Thereupon 'Umar said: This command of Allah's Messenger (may peace be upon him) had remained hidden from me up till now due to (my) business in the market.

Book 25, Number 5360:

    This hadith has been transmitted on the authority of Ibn Juraij, but there is no mention of the words "business in the market".

Book 25, Number 5361:

    Abu Musa Ash'ari reported that he went to 'Umar b. Khattab and greeted him by saying: As-Salamu-'Alaikum, here is 'Abdullah b. Qais, but he did not permit him (to get in). He (Abu Musa Ash'ari) again greeted him with as-Salamu-'Alaikum and said: Here is Abu Musa, but he (Hadrat 'Umar) did not permit him (to get in). He again said: As-Salam-u-'Alaikum, (and said) here is Ash'ari, (then receiving no response he came back). He (Hadrat 'Umar) said: Bring him back to me, bring him back to me So he went there (in the presence of Hadrat 'Umar) and he said to him: Abu Musa, what made you go back, while we were busy in some work? He said: I heard Allah's Messenger (may.peace be upon him) as saying: Permission should be sought thrice. And if you are permitted, (then get in), otherwise go back. He said: Bring witness to this fact, otherwise I shall do this and that, i.e. I shall punish you. Abu Musa went away and 'Umar said to him (on his departure): It he (Abu Musa) finds a witness he should meet him by the side of the pulpit in the evening and it he does not find a witness you would not find him there. When it was evening he (Hadrat 'Umar) found him (Abu Musa) there. He (Hadrat 'Umar) said: Abu Musa, have you been able to find a witness to what you have said? He said: Yes. Here is Ubayy bin Ka'b, whereupon he (Hadrat 'Umar) said: Yes, he is an authentic (witness). He (Hadrat 'Umar) said: Abu Tufail (the kunya of Ubayy b. Ka'b), what does he (Abu Musa say? Thereupon he said: Ibn Khattab,I heard Allah's Messenger (may peace be upon him) as saying so. Do not prove to be a hard (task-master) for the Companions of Allah's Messenger (may peace be upon him), whereupon he Hadrat 'Umar said: Hallowed be Allah. I had heard something (in this connection), but I wished it to be established (as an undeniable fact).

Book 25, Number 5362:

    This hadith has been narrated on the authority of Talha b. Yahya with the same chain of transmitters but with this variation of wording: He (Hadrat 'Umar) said: Abu Mundhir (the Kunya of Ubayy b. Ka'b), did you hear this from Allah's Messenger (may peace be upon him)? Thereupon he said: Yes. and he further said: Ibn Khattab, do not be a torment for the Companions of Allah's Messenger (may peace he upon him). No mention has, however, been made of the words of 'Umar: "Hallowed be Allah" and what follows subsequently.

Chapter 8 : DISAPPROVAL OF SAYING: "IT IS I" IN RESPONSE TO ONE'S INQUIRY WHILE SEEKING PERMISSION TO GET IN THE HOUSE

Book 25, Number 5363:

    Jabir b. Abdullah reported: I came to Allah's Apostle (may peace be upon him) and called him (with a view to seeking permission). whereupon Allah's Apostle (may peace be upon him) said: Who is it? I said: It is I. Thereupon he (the Holy Prophet) came out saying: It is I. it is I.

Book 25, Number 5364:

    Jabir b. Abdullah reported: I sought permission from Allah's Messenger (may peace be upoh him) to see him. He said: Who is it? I said: It is I. Thereupon Allah's Messenger (may peace be upon him) said: It is I. it is I (these words lead me to no conclusion).

Book 25, Number 5365:

    This hadith has been transmitted on the authority of Shu'ba with a slight variation of wording and that is: The Holy Prophet (may peace be upon him) uttered these words: It is I. it is I." in the manner as if he disapproved of this.

Chapter 9 : IT IS FORBIDDEN TO PEEP INTO THE HOUSE OF ANOTHER PERSON

Book 25, Number 5366:

    Sahl b. Sa'd as-Sa'id reported that a person peeped through the hole of the door of Allah's Messenger (may peace be upon him), and at that time Allah's Messenger (may peace be upon him) had with him a scratching instrument with which he had been scratching his head. When Allah's Messenger (may peace be upon him) saw him. he said: If I were to know that you had been peeping through the door, I would have thrust that into your eyes, and Allah's Messenger (may peace be upon him) said: Permission is needed as a protection against glance.

Book 25, Number 5367:

    Sahl b. Sa'd as-Sa'idi reported that a person peeped through the hole of the door of Allah's Messenger (may peace be upon him) and he had with him some pointed thing with which he had been adjusting (the hair of his head). Allah's Messenger (may peace be upon him) said to him: If I were to know that you had been peeping. I would have thrust it in your eyes. Allah has prescribed seeking permission because of protection against glance.

Book 25, Number 5368:

    This hadith has been transmitted on the authority of Sahl b. Sa'd as-Sa'idi with a slight variation of wording.

Book 25, Number 5369:

    Anas b. Malik reported that a person peeped in some of the holes (in the doors) of Allah's Messenger (may peace be upon him) (and he found him) standing up (lifting) an arrow or some arrows. The narrator said: I perceived as if Allah's Messenger (may peace be upon him) was going to pierce (his eyes).

Book 25, Number 5370:

    Abu Huraira reported having heard Allah's Messenger (may peace be upon him) say: He who peeped into the house of people without their consent, it is permissible for them to put out his eyes.

Book 25, Number 5371:

    Abu Huraira reported Allah's Messenger (may peace be upon him) as saying: If a person were to cast a glance in your (house) without permission, and you had in your hand a staff and you would have thrust that in his eyes, there is no harm for you.

Chapter 10 : SUDDEN GLANCE

Book 25, Number 5372:

    Jarir b. 'Abdullah reported: I asked Allah's Messenger (may peace be upon him) about the sudden glance (that is cast) on the face (of a non-Mahram). He commanded me that I should turn away my eyes.

Book 25, Number 5373:

    This hadith has been narrated on the authority of Yunus through another chain of transmitters.


Book 26 : The Book of Salutions and Greetings (KITAB AS-SALAM)

KITAB AS-SALAM
(THE BOOK ON SALUTIONS AND GREETINGS)

Back
INTRODUCTION

    Just as the face is the index to the mind, in the same way the words of greetings which are exchanged amongst people indicate the spiritual role of a society. The gestures, and the expressions of salutations are, therefore, the indicators of the ideals for which a particular society stands. The common practice with the pre-Islamic Arabs and thi modern West is to greet one another with Good Morning and Good Evening accompanied by a gesture of the hand or the nodding of head. These words have no spiritual and moral significance, but just a wish that one should find one's mornings and evenings happy. The words of greeting which Islam has exhorted its followers to use at the time of meeting are as-Salam-u-'Alaikum which have a deep spiritual and moral significance behind them Since the predominant feature of Islamic faith and practice is peace within and peace without, it has, therefore, been made a watchword which should be repeated on every occasion when two Muslims meet so that the utmost importance of peace should be constantly inculcated in the mind of every Muslim, and he should have full consciousness of the great reality that he lives in this world as a messenger of peace for mankind. peace amongst individuals and nations.-The second important feature of words of greeting in Islam is that they convey the message of peace not only to the person who is greeted but to the whole of the Muslim society as it is the plural pronoun that is used for the blessing of peace. (The pronoun 'Alaikum has a evry wide range and all the Muslims come within its orbit.)

    The two words as-Salam-u-'Alaikum may be called the irreducible minimum which are essential for greeting one another. The Muslims have been commanded to add to this expression some other words with a view to excelling one another in showering blessing upon the Muslims. The words as-Salam-u-'Alaikum are generally suffixed with these words Rahmat Allah wa Barakaatuh (mercy of Allah and His bleasings). These three words: "peace... ,mercy" and "blessings of Allah" in fact form the sum and substance of Islam and the Muslims are asked to shower upon one another these benedictions. so that they may be able to live in this world and the Hereafter in perfect peace and tranquillity and blessings and mercy of Allah around him.

    According to Imam Nawawi, greeting with the words of as-Salam-u-'Alaikum is a Sunnah, and responding to it is Wajib (obligatory), but this essentiality is of the nature of Kifaya, meaning thereby that if a few persons out of the whole assembly or group respond to the greeting it will absolve all of the responsibility of response but if no response comes forth from any quarter all are held responsible for it.

Chapter 1 : THE RIDER SHOULD FIRST GREET THE PEDESTRIAN AND THE SMALL NUMBER SHOULD GREET THE LARGE NUMBER OF PERSONS

Book 26, Number 5374:

    Abu Huraira reported Allah's Messenger (may peace be upon him) as saying: The rider should first greet the pedestrian, and the pedestrian the one who is seated and a small group should greet a larger group (with as-Salam-u-'Alaikum).

Chapter 2 : THE DUTY THAT ONE OWES ON THE ROADSIDE IS TO RESPOND THE GREETING OF AS-SALAAM-U-'ALAIKUM

Book 26, Number 5375:

    Abu Talha reported: While We were sitting in front of the houses and talking amongst ourselves, Allah's Messenger (may peace be upon him) happened to come there. He stood by us and said: What about you apd your meetings on the paths? Avoid these meetings on the paths. We said: We were sitting here without (any intention of doing harm to the passers-by) ; we are sitting to discuss matters and to hold conversation amongst ourselves. Thereupon he said: If there is no help (for you but to sit on these paths), then give the paths their rights and these are lowering of the gaze, exchanging of greetings and good conversation.

Book 26, Number 5376:

    Abu Sa'id Khudri reported Allah's Apostle (may peace be upon him) as saying : Avoid sitting on the paths. They (the Companions) said: Allah's Messenger, we cannot help but holding our meetings (in these paths) and discuss matters (there). Thereupon Allah's Messenger (may peace be upon him) said: If you insist on holding meetings, then give the path its due right. They said: What are its due rights ? Upon this he said: Lowering the gaze, refraining from doing harm, exchanging of greetings. commanding of good and forbidding from evil.

Book 26, Number 5377:

    This hadith has been narrated on the authority of Zaid b. Aslam with the same chain of transmitters.

Chapter 3 : THE RIGHT OF A MUSLIM UPON ANOTHER MUSLIM IS THAT HIS GREETING SHOULD BE RESPONDED

Book 26, Number 5378:

    Abu Huraira reported Allah's Messenger (may peace be upon him) as saying: Five are the rights of a Muslim over his brother: responding to salutation, saying Yarhamuk Allah when anybody sneezes and says al-Hamdulillah, visiting the sick. following the bier.' Abd al-Razzaq said that this hadith has been transmitted as mursal hadith from Zuhri and he then substantiated it on the authority of Ibn Musayyib.

Book 26, Number 5379:

    Abu Huraira reported Allah's Messenger (may peace be upon him) as saying: Six are the rights of a Muslim over another Muslim. It was said to him: Allah's Messenger, what are these? Thereupon he said: When you meet him, offer him greetings;when he invites you to a feast accept it. when he seeks your council give him, and when he sneezes and says: "All praise is due to Allah," you say Yarhamuk Allah (may Allah show mercy to you); and when he fails ill visit him; and when he dies follow his bier.

Chapter 4 : PROHIBITION OF SAYING FIRST AS-SALAM-U-'ALAIKUM TO THE PEOPLE OF THE BOOK, AND HOW THEIR SALUTATIONS SHOULD BE RESPONDED

Book 26, Number 5380:

    Anas b. Malik reported Allah's Messenger (may peace be upon him) as saying: When the People of the Book offer you salutations, you should say: The same to you.

Book 26, Number 5381:

    Anas reported that the Companions of Allah's Apostle (may peace be upon him) said to him: The People.of the Book offer us salutations (by saying as-Salamu- 'Alaikum). How should we reciprocate them ? Thereupon he said: Say: Wa 'Alaikum (and upon you too).

Book 26, Number 5382:

    Ibn 'Umar reported Allah's Messenger (may peace be upon him) as saying: When the Jews offer you salutations, tome of them say as-Sam-u-'Alaikum (death be upon you). You should say (in response to it): Let it be upon you.

Book 26, Number 5383:

    This hadith has been narrated on the authority of Ibn 'Umar through another chain of transmitters with a slight variation of wording.

Book 26, Number 5384:

    'A'isha reported that a group of Jews came to Allah's Messenger (may peace be upon him) and sought his audience and said: As-Sam-u-'Alaikum. A'isha said in response: As-Sim-u-'Alaikum (death be upon you) and curse also, whereupon Allah's Messenger (may peace be upon him) said : 'A'isha, verily Allah loes kindness in every matter. She said: Did you bear what they said ? Thereupon he said: Did you not hear that I said (to them): Wa 'Alaikum.

Book 26, Number 5385:

    This hadith has been transmitted on the authority of Zuhri that Allah's Messenger (may peace be upon him) said: I said 'Alaikam, and the transmitter did not make mention of the word "and".

Book 26, Number 5386:

    'A'isha reported that some Jews came to Allah's Apostle (may peace be upon him) and they said: Abu'l-Qasim (the Kunya of the Holy Prophet), as-Sam-u-'Alaikum, whereupon he (the Holy Prophet) said: Wa 'Alaikum. A'isha reported: In response to these words of theirs, I said: But let there be death upon you and disgrace also, whereupon Allah's Messenger (may peace be upon him) said: 'A'isha, do not use harsh words. She said: Did you hear what they said? Thereupon he (the Holy Prophet) said: Did I not respond to them when they said that; I said to them: Wa'Alaikum (let it be upon you).

Book 26, Number 5387:

    This hadith has been reported on the authority of A'znash with a slight variation of wording. 'A'isha understood their meaning and cursed them and Allah's Messenger (may peace be upon him) said: 'A'isha. (do not do that) for Allah does not like the use of harsh words, and it was at this stage that this verse of Allah. the Exalt. ed and Glorious. was revealed: "And when they come to thee, they greet thee with a greeting with which Allah greets thee not" (Iviii. 8) to the end of the verse.

Book 26, Number 5388:

    Jabir b. Abdullah reported that some people from amongst the Jews said to Allah's Messenger (may peace be upon him) Abu'l-Qasim. as-Sam-u-'Alaikum, whereupon he said : Wa 'Alaikum, A'isha was enraged and asked him (Allah's Apostle) whether he had not heard what they had said. He said, I did hear and I retorted to them (and the curse that I invoked upon them would receive response from Allah), but (the curse that they invoked upon us) would not be responded.

Book 26, Number 5389:

    Abu Huraira reported Allah's Messenger (may peace be upon him) as saying: Do not greet the Jews and the Christians before they greet you and when you meet any one of them on the roads force him to go to the narrowest part of it .

Book 26, Number 5390:

    This hadith has been narrated on the authority of Suhail with the same chain of transmitters but with a slight variation of wording. The hadith transmitted on the authority of Waki', the words are 'When you meet the Jews." And in the hadith transmitted on the authority of Shu'ba, the words are: 'When you meet the People of the Book." And in the hadith transmitted on the authority of Jarir the words are: "When you meet them," but none amongst the polytheists has been mentioned explicitly by name.

Chapter 5 : EXCELLENCE OF GREETING THE CHILDREN

Book 26, Number 5391:

    Anas b. Malik reported that when Allah's Messenger (may peace be upon him) happened to pass by young boys he would great them. This hadith has been narrated on the authority of Sayyar with the same chain of transmitters.

Book 26, Number 5392:

    Sayyar reported: I was walking with Thibit al-Bunani that he happened to pass by children and he greeted them. And Thibit reported that he walked with Anas and he happened to pass by children and he greeted them. and Anas reported that he walked with Allah's Apostle (may peace be upon.him) and he happened,to pass by children and he greeted them.

Chapter 6 : PERMISSIBILITY OF GIVING PERMISSION (TO ENTER THE HOUSE) BY RAISING THE CURTAIN OR MAKING SOME OTHER SIGNS LIKE IT

Book 26, Number 5393:

    Ibn Mas'ud reported : The Messenger of Allah (may peace be upon him) said to me : The sign that you have been permitted to come in is that the curtain is raised or that you hear me speaking quietly until I forbid you.

Book 26, Number 5394:

    This hadith has been narrated on the authority of 'Ubaidullah with the same chain of transmitters.

Chapter 7 : PERMISSIBILITY OF WOMEN GOING OUT IN THE FIELDS FOR EASING THEMSELVES

Book 26, Number 5395:

    A'isha reported that Sauda (Allah he pleated with her) went out (in the fields) in order to answer the call of nature even after the time when veil had been prescribed for women. She had been a bulky lady, significant in height amongst the women, and she could not conceal herself from him who had known her. 'Umar b. Khattab saw her and said: Sauda, by Allah, you cannot conceal from us. Therefore, be careful when you go out. She ('A'isha) said : She turned back. Allah's Messenger (may peace be upon him) was at that time in my house having his evening meal and there was a bone in his hand. She (Sauda) cline and said: Allah's Messenger. I went out and 'Umar said to me so and so. She ('A'isha) reported: There came the revelation to him and then it was over; the bone was then in his hand and he had not thrown it and he said: "Permission has been granted to you that you may go out for your needs."

Book 26, Number 5396:

    This hadith has been narrated on the authority of Hisham with the same chain of transmitters, and the words are: She (Sauda) was a woman who looked to be significant amongst the people (so far as the bulk of her) body was concerned. The rest of the hadith is the same.

Book 26, Number 5397:

    'A'isha reported that the wives of Allah's Messenger (may peace be upon him) used to go out in the cover of night when they went to open fields (in the outskirts of Medina) for easing themselves. 'Umar b Khattab used to say: Allah's Messenger, ask your ladies to observe veil , but Allah's Messenger (may peace be upon him) did not do that. So there went out Sauda, daughter of Zarn'a, the wife of Allah's Messenger (may peace be upon him), during one of the nights when it was dark. She was a tall statured lady. 'Umar called her saying : Sauda, we recognise you. (He did this with the hope that the verses pertaining to veil would be revealed.) 'A'isha said : Allah, the Exalted and Glorious, then revealed the verses pertaining to veil.

Book 26, Number 5398:

    This hadith has been narrated on the authority of Ibn Shihab with the same chain of transmitters.

Chapter 8 : IT IS PROHIBITED TO SIT WITH A STRANGE LADY IN PRIVACY OR TO ENTER HER HOUSE WHEN SHE IS ALONE

Book 26, Number 5399:

    Jabir reported Allah's Messenger (may peace be upon him) as saying: Behold, no person should spend the night with a married woman, but only in case he is married to her or he is her Mahram.

Book 26, Number 5400:

    'Uqba b. Amir reported Allah's Messenger (may peace be upon him) as saying: Beware of getting, into the houses and meeting women (in seclusion). A person from the Ansir said: Allah's Messenger, what about husband's brother, whereupon he said: Husband's brother is like death.

Book 26, Number 5401:

    This hadith has been narrated on the authority of Yazid b. Abu Habib with the same chain of transmitters.

Book 26, Number 5402:

    Ibn Wahb reported: I heard Laith b. Said as saying: Al-Hamv means the brother of husband or like it from amongst the relatives of the husband, for example, cousin, etc.

Book 26, Number 5403:

    'Abdullah b. 'Amr. b. al-'As reported that some persons from Banu Hisham entered the house of Asma' daughter of 'Umais when Abu Bakr also entered (and she was at that time his wife). He (Abu Bakr) saw it and disapproved of it and he made a mention of that to Allah's Messenger (may peace be upon him) and said: I did not see but good only (in my wife). Thereupon Allah's Messenger (may peace be upon him) said: Verily Allah has made her immune from all this. Then Allah's Messenger (may peace be upon him) stood on the pulpit and said: After this day no man should enter the house of another person in his absence, but only when he is accompanied by one person or two persons.

Chapter 9 : IT IS EXCELLENT TO TELL A MAN WHEN ONE IS ACCOMPANIED BY ONE'S WIFE OR MAHRAM LADY THAT SHE IS ONE'S WIFE OR MAHRAM AND TO REMOVE HIS DOUBT

Book 26, Number 5404:

    Anas reported that when Allah's Messenger (may peace be upon him) was in the company of one of his wives a person happened to pass by them. He called him and when he came, he said to him: 0 so and so, she was my such and such wife. Thereupon he said, Allah's Messenger, if I were to doubt at all, I would have entertained no doubt about you at least. Thereupon Allah's Messenger (may peace be upon him) said: Verily Satan circulates in the body like blood.

Book 26, Number 5405:

    Safiyya daughter of Huyyay (the wife of Allah's Apostle) reported that while Allah's Messenger (may peace be.upon him) had been observing I'tikaf, I came to visit him one night and talked with him for some time. Then I stood up to go back and he (Allah's Apostle) also stood up with me in order to bid me good-bye. She was at that time residing in the house of Usama b. Zaid. The two persons from the Ansar happened to pass by him. When they saw Allah's Apostle (may peace be upon him). they began to walk swiftly, thereupon Allah's Messenger (may peace be upon him) said to them: Walk calmy, she is Safiyya daughter of Huyyay... Both of them said: Messenger, hallowed be Allah, (we cannot conceive of ab., ug doubtful even in the remotest corners of our minds), whereupon he said: Satan circulates in the body of man like the circulation of blood and I was afraid lest it should instill any evil in your heart or anything. This hadith has been reported on the authority of Safiyya, the wife of Allah's Apostle (may peace be upon him), through another chain of transmitters (and the words) are: "She went to Allah's Apostle (may peace be upon him) to visit him as he was observing I'tikaf in the mosque during Ramadan. She talked with him for some time and then stood up to go back and Allikh's Apostle (may peace be upon him) stood up in order to bid her good-bye." The rest of the hadith is the same except with the variation of the words that Allah's Apostle (may peace be upon him) said: "Satan penetrates in man like the penetration of blood (in every part of body)."

Chapter 10 : IF A PERSON COMES TO A MEETING AND FINDS SPACE THERE HE SHOULD SIT THERE, OTHERWISE HE SHOULD DEPART

Book 26, Number 5406:

    Abu Waqid al-Laith reported that Allah's Messenger (may peace be upon him) was sitting in the mosque along wish tome people when there came to him three persons; two of them stepped forward to the direction of Allah's Messenger (may peace be upon him), and one of them went away. The two stood by the side of Allah's Messenger (may peace be upon him), and one of them found a space in his circle and he sat in that; and the other one sat behind him and the third one went away. When Allah's Messenger (may peace be upon him) had finished his work, he said. Should I not inform you about these three persons? One of them sought refuge with Allah and Allah gave him refuge and the second one felt shy and Allah showed kindness to has shyness (and so he was accommodated in that meeting), and the last one reverted and Allah turned away His attention from him.

Book 26, Number 5407:

    This hadith has been reported on the authority of Ishaq b. 'Abdullah b. Talha with the same chain of transmitters.

Chapter 11 : IF A PERSON GOES AWAY FROM THE PLACE OCCUPIED BY HIM, HE HAS A BETTER RIGHT TO OCCUPY IT AFTER COMING BACK

Book 26, Number 5408:

    Ibn 'Umar reported Allah's Messenger (may peace be upon him) having said: None of you should make another one stand in the meeting and then occupy his place.

Book 26, Number 5409:

    Ibn 'Umar reported Allah's Messenger (may peace be upon him) as saying: No person should ask another person to stand at his place and then he should himself sit there, but he should simply say: Make room and accommodate.

Book 26, Number 5410:

    This hadith has been reported on the authority of Ibn 'Umar through another chain of transmitters. but with a slight variation of wording.

Book 26, Number 5411:

    Ibn 'Umar reported Allah's Messenger (may peace be upon him) as saying: None should make one'& brother stand and then sit at his place (and it was common with) Ibn Umar that when any person stood in the company (with a view to making room for him) he did not sit there.

Book 26, Number 5412:

    This hadith hilt been reported on the authority of Ma'mar with the same chain of transmitters.

Book 26, Number 5413:

    Jabir reported Allah's Apostle (may peace he upon him) as saying: None amongst you should make his brother stand on Friday (during the congregational prayer) and then occupy his-place. but he should only say to him (Accommodate me).

Book 26, Number 5414:

    Abu Huraira reported Allah's Messenger (may peace be upon him) as saying: When anyone amongst you stands up, and in the badltb transmitted on the authority of Abu 'Awina, the words are: "He who stands in his place and (goes away) and then comes back to it, he his the greatest right (to occupy that).

Chapter 12 : THE ENTRANCE OF THE EUNUCH (IN A HOUSE WHERE THERE ARE FEMALE INMATES) IS PROHIBITED

Book 26, Number 5415:

    Umm Salama reported that she had a eunuch (as a slave) in her house. Allah's Messenger imay peace be upon him) was once in the house that he (the eunuch) said to the brother of Umm Salama: Abdullahb. Aba Umayya. if Allah grants you victory in Ta'if on the next day, I will show you the daughter of Ghailan for she has four folds (upon her body) on the front side of her stomach and eight folds on the back. Allah's Messenger (may peace be upon him) heard this and he said: Such (people) should not visit you.

Book 26, Number 5416:

    'A'isha reported that a eunuch used to come to the wives of Allah's Apostle (may peace be upon him) and they did not And anything objectionable in his visit considering him to be a male without any sexual desire. Allah's Apostle (may peace be upon him) one day came as he was sitting with some of his wives and he was busy in describing the bodily characteristics of a lady and saying: As the comes in front tour folds appear on her front side and as she turns her back eight folds appear on the back side. Thereupon Allah's Apostle (may peace be upon him) said: I me that he knows these things; do not, therefore. allow him to cater. She ("A'isha) said: Then they began to observe veil from him.

Chapter 13 : PERMISSION OF SEATING A WOMAN ON THE RIDE BEHIND ONE'S BACK IF ONE FINDS HER COMPLETELY EXHAUSTED IN THE WAY

Book 26, Number 5417:

    Asma' daughter of Abu Bakr reported that the was married to Zubair. He had neither land nor wealth nor slave nor anything else like it except a bom. She further said: I grazed his horse. provided fodder to it and looked after it, and ground dates for his camel. Besides this, I grazed the camel, made arrangements for providing it with water and patched up the leather bucket and kneaded the flour. But I was not proficient in baking the bread, so my female neighbours used to bake bread for me and they were sincere women. She further said: I was carrying on my head the stones of the dates from the land of Zubair which Allah's Messenger (may peace be upon him) had endowed him and it was at a distance of two miles (from Medina). She add: As I was one day carrying the atones of dates upon my head I happened to meet Allah's Messenger (may peace be upon him) along with a group of his Companions. He called me and said (to the camel) to sit down so that he should make cite ride behind hirn. (I told my husband:) I felt shy and remembered your jealousy, whereupon he said: By Allah. the carrying of the stone dates upon your bead is more severe a burden than riding with him. She said: (I led the life of hardship) until Abu Bakr sent afterwards a female servant who took upon herself the responsibility of looking after the horse and I felt as it she had emancipated me.

Book 26, Number 5418:

    Asma' reported: I performed the household duties of Zubair and he had a horse; I used to look after it. Nothing was more burdensome for me than looking after the horse I used to bring grass for it and looked after it, then I got a servant as Allah's Apustle (may peace be upon him) had some prisoners of war in his possession. He gave me a female servant. She (the female servant) then began to look after the horse and thus relieved me of this burden. A person came and he said: Mother of 'Abdullah, I am a destitute person and I intend that I should start business under the shadow of your house. I (Asma') said: If I grant you permission, Zubair may not agree to that, so you come and make a demand of it when Zubair is also present there. He came accordingly find said: Mother of 'Abdullah. I am a destitute person. I intend to start t mall business in the shadow of your house. I said: Is there not in Medina (any place for starting the business) except my house ? Zubair said: Why is it that you prohibit the destitute man to start business here? So he started business and he (earned so much) that we sold our slave-girl to him There came Zubair to me while the money was in my lap. He said: Give this to me. I said: (I intend) to spend it as charity.

Chapter 14 : IT IS PROHIBITED FOR TWO PERSONS TO CONVERSE SECRETLY WITHOUT THE CONSENT OF THE THIRD ONE

Book 26, Number 5419:

    Ibn Umar reported Allah's Messenger (may peace be upon him) as saying: When there are three (persons), two should not converse secretly between themselves to the exclusion of the (third) one.

Book 26, Number 5420:

    This hadith has been reported on the authority of lbn 'Umar through two different chains of transmitters.

Book 26, Number 5421:

    'Abdullah reported Allah's Messenger (may peace be upon him) as saying: If you are three, two amongst you should not converse secretly between yourselves to the exclusion of the other (third one), unti some other people join him (and dispel his loneliness), for it may hurt his feelings.

Book 26, Number 5422:

    'Abdullah reported Allah's Messenger (may peace be upon him) as saying: If you are three, two should not converse secretly to the exclusion of your companion for that hurts his feelings.

Book 26, Number 5423:

    This hadith has been reported on the authority of A'mash with the same chain of transmitters.

Chapter 15 : MEDICINE AND SPELL

Book 26, Number 5424:

    'A'isha (the wife of Allah's Apostle) said: When Allah's Messenger (may peace be upon him) fell ill. Gabriel used to recite these verses. "In the name of Allah. He may cure you from all kinds of illness and safeguard vou from the evil of a jealous one when he feels jealous and from the evil influence of eye."

Book 26, Number 5425:

    Abu Sa'id reported that Gabriel came to AJlah's Messenger (may peace be upon him) and said: Muhammad, have you fallen ill ? Thereupon he said: Yes. He (Gabriel) said: "In the name of Allah I exercise you from everything and safeguard you from every evil that may harm you and from the eye of a jealous one. Allah would cure you and I invoke the name of Allah for you."

Book 26, Number 5426:

    Abu Huraira reported so many abidith from Allah's Messenger (may peace be upon him) and he reported Allah's Messenger (may peace be upon him) as saying: The influence of an evil eye is a fact.

Book 26, Number 5427:

    Ibn 'Abbas reported Allah's Messenger (may peace be upon him) as saying: The influence of an evil eye is a fact; if anything would precede the destiny it would be the influence of an evil eye, and when you are asked to take bath (as a cure) from the influence of an evil eye, you should take bath.

Chapter 16 : MAGIC AND SPELL

Book 26, Number 5428:

    A'isha reported that a Jew from among the Jews of Banu Zuraiq who was called Labid b. al-A'sam cast spell upon Allah's Messenger (may peace be upon him) with the result that he (under the influence of the spell) felt that he had been doing something whereas in fact he had not been doing that. (This state of affairs lasted) until one day or during one night Allah's Messenger (may peace be upon him) made supplication (to dispel its effects). He again made a supplication and he again did this and said to 'A'isha: Do you know that Allah has told me what I had asked Him? There came to me two men and one amongst them sat near my head and the other one near my feet and he who sat near my head said to one who sat near my feet or one who sat near my feet said to one who sat near my head: What is the trouble with the man? He said: The spell has affected him. He said: Who has cast that? He (the other one) said: It was Labid b. A'sam (who has done it). He said: What is the thing by which he transmitted its effect? He said: By the comb and by the hair stuck to the comb and the spathe of the date-palm. He said: Where is tbap He replied: In the well of Dhi Arwan. She said : Allah's Messenger (may peace be upon him) sent some of the persons from among his Companions there and then said: 'A'isha. by Allah, its water was yellow like henna and its trees were like heads of the devils. She said that she asked Allah's Messenger (may peace be upon him) as to why he did not burn that. He said: No, Allah has cured me and I do not like that I should induce people to commit any high-handedness in regard (to one another), but I only commanded that it should be buried.

Book 26, Number 5429:

    'A'isha reported that Allah's Messenger (may peace be upon him) was affected with a spell, the rest of the hadith is the same but with this variation of wording: "Allah's Messenger (may peace be upon him) went to the well and looked towards it and there were trees of date-palm near it. I ('A'isha) said: I asked Allah'& Messenger (may peace be upon him) to bring it out, and 1 did not say: Why did not you burn it?" And there is no mention of these words: "I commanded (to bury them and they buried."

Chapter 17 : POISON

Book 26, Number 5430:

    Anas reported that a Jewess came to Allah's Messenger (may peace be upon him) with poisoned mutton and he took of that what had been brought to him (Allah's Messenger). (When the effect of this poison were felt by him) he called for her and asked her about that, whereupon she said: I had determined to kill you. Thereupon he said: Allah will never give you the power to do it. He (the narrator) said that they (the Companion's of the Holy Prophet) said: Should we not kill her? Thereupon he said: No. He (Anas) said: I felt (the affects of this poison) on the uvula of Aitah's Messenger.

Book 26, Number 5431:

    Anas b. Malik reported that a Jewess brought poisoned meat and then served it to Allah's Messenger (may peace be upon him)

Chapter 18 : THE EXCELLENCE OF CURING THE PATIENT WITH THE HELP OF INCANTATION

Book 26, Number 5432:

    'A'isha reported: When any person amongst us fell ill, Allah's Messenger (may peace he upon him) used to rub him with his right band and then say: O Lord of the people, grant him health, heal him, for Thou art a Greet Healer. There is no healere, but with Thy healing Power one is healed and illness is removed. She further added: When Allah's Messenger (may peace be upon him) fell ill, and his illness took a serious turn I took hold of hie hand to that I should do with it what he ward to do with that (i.e. I would rub his body with his sacred hand). But he withdrew his hand from my hand and then said: O Allah, pardon me and make me join the companion. ship on She said. I was gazing at him constantly whereas he had passed away.

Book 26, Number 5433:

    This. hadith has been reported on the authority of Shu'ba through another chain of transmitters (and the words are): "He rubbed him with his hand" and (in) the hadith transmitted on the authority of Thauri (the words are). "He used to rub with his right hand." This hadith has been reported through another chain of transmitters.

Book 26, Number 5434:

    'A'isha reported Allah's Messenger (may peace be upon him) as saying: When Allah's Messenger (may peace be upon him) visited the sick he would say: Lord of the people. remove the disease, cure him, for Thou art the great Curer, there is no cure but through Thine healing Power, which leaves nothing of the disease.

Book 26, Number 5435:

    'A'isha reported that when Allah's Messenger (may peace be upon him) came to visit any sick he supplicated for him and said: Lord of the people, remove the malady, cure him for Thou art a great Curer. There is no cure but through Thine healing Power which leaves no trouble, and in the narration transmitted on the authority of Abu Bakr there is a slight variation of wording.

Book 26, Number 5436:

    This hadith has been reported on the authority of 'A'isha through another chain of transmitters with a slight variation of wording.

Book 26, Number 5437:

    'A'isha reported: Allah's Messenger (may peace be upon him) used to recite (this supplication) as the words of incantation: "Lord of the people, remove the trouble for in Thine Hand is the cure; none is there to relieve him (the burden of disease) but only Thou.

Book 26, Number 5438:

    This hadith has been reported on the authority of Hisham with the same chain of transmitted.

Chapter 19 : CURING OF THE PATIENT WITH THE RECITATION OF MU'AWWIDHATAN (SURAS CXIII., CXIV.)

Book 26, Number 5439:

    'A'isha reported that when any of the members of the household fell ill Allah's Messenger (may peace be upon him) used to blow over him by reciting Mu'awwidhatan, and when he suffered from illness of which he died I used to blow over him and rubbed his body with his hand for his hand had greater healing power than my hand.

Book 26, Number 5440:

    'A'isha reported that when Allah's Messenger (may peace be upon him) fell ill, he recited over his body Mu'awwidhatan and blew over him and when his sickness was aggravated I used to recite over him and rub him with his band with the hope that it was more blessed.

Book 26, Number 5441:

    This hadith has been narrated through some other chains of transmitters but with a slight variation of wording. In the hadith transmitted on the authority of Yanus and Ziyari (the words are): "When Allah's Apostle (may peace be upon him) fell ill, he blew over his body by reciting Mu'awwidhatan and rubbed him with his hand.

Chapter 20 : THE EXCELLENCE OF CURING (WITH THE HELP OF INCANTATION) THE INFLUENCE OF THE EVIL EYE AND SMALL PUSTULES AND THE POISON (ESPECIALLY OF SNAKE AND SCORPION)

Book 26, Number 5442:

    'Abd al-Rahman b. al-Aswad reported on the authority of his father: I asked 'A'isha about incantation. She said: Allah's Messenger (may peace be upon him) had granted its sanction to the members of a family of the Ansir for incantation in curing every type of poison.

Book 26, Number 5443:

    'A'isha reported that Allah's Messenger (may peace be upon him) granted sanction to the members of a family of the Ansir for incantation (for removing the effects) of the poison of the scorpion.

Book 26, Number 5444:

    'A'isha reported that when any person fell ill with a disease or he had any ailment or he had any injury, the Apostle of Allah (may peace be upon him) placed his forefinger upon the ground and then lifted it by reciting the name of Allah. (and said): The dust of our ground with the saliva of any one of us would serve as a means whereby our illness would be cured with the sanction of Allab. This hadith has been transmitted on the authority of Ibn Abu Shaiba and Zubair with a slight variation of wording.

Book 26, Number 5445:

    'A'isha reported that Allah's Messenger (may peace be upon him) commanded the use of incantation for curing the influence of an evil eye.

Book 26, Number 5446:

    This hadith has been narrated on the authority of Mis'ar with the same chain of transmitters.

Book 26, Number 5447:

    'A'isha reported: Allah's Messenger (may peace he upon him) commanded me that I should make use of incantation for curing the influence of an evil eye.

Book 26, Number 5448:

    Anas b. Malik reported in connection with incantation that he had been granted sanction (to use incantation as a remedy) for the sting of the scorpion and for curing small pustules and dispelling the influence of an evil eye.

Book 26, Number 5449:

    Anas reported that Allah's Messenger (may peace be upon him) granted him sanction to use incantation (as a cure) for the, influence of an evil eye, the sting of the scorpion and small pustules.

Book 26, Number 5450:

    Umm Salama, the wife of Allah's Apostle (may peace be upon him), reported that Allah's Messenger (may peace be upon him) said to a small girl in the house of Umm Salama that he had been seeing on her face black stains and told her that that was due to the infiluence of an evil eye, and he asked that she should be cured with the help of incantation (hoping) that her face should become spotles.

Book 26, Number 5451:

    Jabir b. 'Abdullah reported that Allah's Apostle (may peace be upon him) granted sanction to the family of Hazm for incantation (in mitigating the effect of the poison of) the snake, and, he said -to Asma' daughter of 'Umais: What is this that I see the children of my brother lean? Are they not fed properly? She said: No, but they fall under the influence of an evil eve. He said : Use incantation She recited (the words of incantation before him), whereupon he (by approving them) said: Yes, use this incantation for them.

Book 26, Number 5452:

    Jabir b. 'Abdullah reported that Allah's Apostle (may peace be upon him) granted a special sanction for incantation in case of the snake poison to a tribe of 'Amr. Abu Zubair said: I heard Jabir b. 'Abdullah as saying that the scorpion stung one of us as we were sitting with Allah's Messenger (may peace upon him). A person said: Allah's Messenger, I use incantation (for curing the effect. of sting), whereupon he said: He who is competent amongst you to benefit his brother should do so.

Book 26, Number 5453:

    This hadith has been narrated on the authority of Ibn Juraij with the same chain of transmitters but with a slight variation of wording.

Book 26, Number 5454:

    Jabir b. 'Abdullah reported I had a maternal uncle who treated the sting of the scorpion with the help of incantation. Allah's Messenger (may peace be upon him) forbade incantation. He came to him and said: Allah's Messenger, you forbade to practise incantation, whereas I employ it for curing the sting of the scorpion, whereupon he said: He who amongst you is capable of employing it as a means to do good should do that.

Book 26, Number 5455:

    This hadith has been narrated on the authority of A'mash with the same chain of transmitters.

Book 26, Number 5456:

    Jabir reported Allah's Messenger (may peace be upon him) prohibited incantation. Then the people of Amr b. Hazm came to Allah's Messenger (may peace be upon him) and said: We know an incantation which we use for curing the sting of the scorpion but you have prohibited it. They recited (the words of incantation) before him, whereupon he said: I do not see any harm (in it), so he who amongst you is competent to do good to his brother should do that.

Book 26, Number 5457:

    'Auf b. Malik Ashja'i reported We practised incantation in the pre-Islamic days and we said: Allah's Messenger. what is your opinion about it? He said: Let me know your incantation and said: There is no harm in the incantation which does not smack of polytheism.

Chapter 21 : PERMISSIBILITY OF GETTING REWARD FOR INCANTATIONS FROM THE WORDS OF THE QUR'AN

Book 26, Number 5458:

    Abu Sa'id Khudri reported that some persons amongst the Companions of Allah's Messenger (may peace be upon him) set out on a journey and they happened to pass by a tribe from the tribes of Arabia. They demanded hospitality from the members of that tribe, but they did not extend any hospitality to them. They said to them : Is there any incantator amongst you, at the chief of the tribe has bgen stung by a scorpion? A person amongst us said: 'Yes. So he came to him and he practised incan- tation with the help of Sura al-Fatiha and the person became all right. He was given a flock of sheep (as recompense), but he refused to accept that, saying: I shall make a mention of it to Allah's Apostle (may peace be upon him), and if he approves of it. then I shall accept it. So we came to Allah's Apostle (may peace be upon him) and made a mention of that to him and he (that person) said: Allah's Messenger by Allah, I did not practice incantation but with the help of Sura al-Fatiha of the Holy Book. He (the Holy Prophet) smiled and said: How did you come to know that it can be used (as incactation) ?- and then said : Take out of that and allocate a share for me along with your share.

Book 26, Number 5459:

    This hadith has been reported on the authority of Abu Bishr with the same the same chain of transmitters (with these words): That he recited Umm-ul-Qur'an (Sura Fatiha), and he collected his spittle and he applied that and the person became all right.

Book 26, Number 5460:

    Abu Sa'id al-Khudri reported. We landed at a place where a woman came to us and said: A scorpiorn has bitten the chief of the tribe. Is there any incantator amongst you? A person amongst us stood up (and went with her). We had no idea that he had been a good incantator but he practised incantation with the help of Sura al -Fatiha and the (the chief) was all right. They gave him a flock of sheep and served us milk. We said (to him): Are you a good incantatory Thereupon he said: I did not do it but by the help of Sura al-Fitiha. He caid: Do not drive (these goats) until we go to Allah's Messenger (may peace be upon him) and find out (whether it is permissible to accept( this reward of incantation). So we came to Allah's Apostle (may peace be upon hin) and made a rrention of that to him, whereupon he said: How did you come to know that this (Sura al-Fatiha) could be used as an incantation? So distribute them (amongst those who had been present there with him) and allocate a share of mine also.

Book 26, Number 5461:

    This hadith has been narrated on the authority of Hisham with the same chain of transmitters and he said: There stood up with her a person amongst us whom we did not know before as an incantator.

Chapter 22 : EXCELLENCE OF PLACING ONE'S HANDS AT THE SPOT OF PAIN AT THE TIME OF PRACTISING INCANTATION

Book 26, Number 5462:

    Uthman b. Abu al-'As Al-Thaqafi reported that he nade a complaint of pain to Allah's Messenger (may peace be upon him) that he felt in his body at the time he had become Muslim. Thereupon Allah's Messenger (may peace be upon him) said: Place your hand at the place where you feel pain in your body and say Bismillah (in the name of Allah) three times and seven times A'udhu billahi wa qudratihi min sharri ma ajidu wa ukhdhiru (I seek refuge with Allah and with His Power from the evil that I find and that I fear).

Chapter 23 : SEEKING REFUGE AGAINST SATAN FROM THE EVIL PROMPTINGS IN THE PRAYER

Book 26, Number 5463:

    Uthman b. Abu al-'As reported that he came to Allah's Messenger (may peace be upon him) and said: Allah's Messenger, the Satan intervenes between me and my prayer and my reciting of the Qur'an and he confounds me. Thereupon Allah's Messenger (may peace be upon him) said:, That is (the doing of the Satan) who is known as Khinzab, and when you perceive its effect, seek refuge with Allah from it and spit three times to your left. I did that and Allah dispelled that from me.

Book 26, Number 5464:

    'Uthman b. Abu al-'As reported that he came to Allah's Apostle (may peace be upon him) and he narrated like this. In the hadith transmitted on the authority of Salam b. Nuh there is no mention of three times,

Book 26, Number 5465:

    This hadith has been transmitted on the authority of 'Uthman b. Abu al-'As with a slight variation of wording.

Chapter 24 : THERE IS A REMEDY FOR EVERY MALADY AND IT IS EXCELLENT TO GET TREATMENT

Book 26, Number 5466:

    Jabir reported Allah's Messenger (may peace be upon him) as saying: There is a remedy for every malady, and when the remedy is applied to the disease it is cured with the permission of Allah, the Exalted and Glorious.

Book 26, Number 5467:

    Jabir reported that he visited Muqanna' and then said : I will not go away unless you get yourself cupped, for I heard Allah's Messenger (may peace be upon him) say: It is a remedy.

Book 26, Number 5468:

    'Asim b. 'Umar b. Qatada reported: There came to our house 'Abdullah and another person from amongst the members of the household who complained of a wound.Jabir said: What ails you? He said: There is a wound which is very painful for me, whereupon he said: Boy, bring to me a cupper. He said: 'Abdullah, what do you intend to do with the cupper? I said: I would get this wound cupped. He said: By Allah. oven the touch of fly or cloth causes me pain (and cupping) would thus cause me (unbearable) pain. And when he saw him feeling pain (at the idea of cupping), he said: I heard Allah's Messenger (may peace be upon him) as saying: If there is any effective remedy amongst your remedies, these are (three): Cupping, drinking of honey and cauterisation with the help of fire. Allah's Messenger (may peace be upon him) had said: As for myself I do not like cauterisation. The cupper was called and he cupped him and he was all right.

Book 26, Number 5469:

    Jabir reported that Umm Salama sought permission from Allah's messenger (may Allah's peace upon him) tor getting herself cupped. The Apostle of Allah (may peace be upon him) asked Abu Taiba to cup her. He (Jabir) said: I think he (Abu Taiba) was her faster brother or a young boy before entering upon the adolescent period.

Book 26, Number 5470:

    Jabir reported that Allah's Messenger (may peace be upon him) sent a phystian to Ubayy b. Ka'b.He cut the vein and then cauterised it.

Book 26, Number 5471:

    A'mash reported this with the same chain of transmitters and he made no mention of the fact that he cut one of his veins.

Book 26, Number 5472:

    Jabir b. 'Abdillah reported that on the day of Ahzab Ubayy received the wound of an arrow in his medial arm vein. Allah's Messenger (may peace be upon him) cauterised it.

Book 26, Number 5473:

    Jabir reported that Sa'd b. Mu'adh received a wound of the arrow in his vein. Allah's Messenger (may peace be upon him) cauterised it with a rod and it was swollen, to the Messenger of Allah (may peace be upon him) did it for the second time.

Book 26, Number 5474:

    Ibn 'Abbas reported that Allah's Apostle (may peace be upon him) got himself cupped and gave to the cupper his wages and he put the medicine in the nostril.

Book 26, Number 5475:

    Anas b. Malik reported that Allah's Messenger (may peace be upon him) got himself cupped and never withheld the wages of anyone.

Book 26, Number 5476:

    Ibn Umar reported Allah's Messenger (may peace be upon him) as saying: The fever from the vehement raging of the (heat of Hell), so cool it with the help of water.

Book 26, Number 5477:

    Ibn Umar reported Allah's Apostle (may peace be upon him) as saying: Fever is due to vehemence of the beat of Hell,so cool it with water.

Book 26, Number 5478:

    Ibn Umar reported Allah's Messenger (may peace be upon him) as saying: Fever is from the vehement raging of the fire of Hell, so extinguish it with water.

Book 26, Number 5479:

    Ibn 'Umar reported Allah's Messenger (may peace be upon him) as saying: Fever is from the vehement Paging of the Hell-fire, so cool it with water.

Book 26, Number 5480:

    'A'isha reported Allah's messenger (may peace be upon him) as saying: Fever is from the vehement raging of the Hell-fire, so cool it with water.

Book 26, Number 5481:

    This hadith has been narrated on the authority of Hisham with the same chain of transmitters.

Book 26, Number 5482:

    Asma' reported that a woman running high fever was brought to her. She asked water to be brought and then sprinkled it in the opening of a shirt at the uppermost part of the chest and said that Allah's Messenger (may peace be upon him) had said: Cool (the fever) with water. for it is because of the vehemence of the beat of Hell.

Book 26, Number 5483:

    Hisham reported this hadith with the same chain of transmitters. In the hadith transmitted on the authority of Ibn Numair (the words are): "She poured water on her sides and in the opening of the shirt at the uppermost part of the chest." There is no mention of these words: "It is from the vehemence of the heat of the Hell." This hadith has been narrated on the authority of Abu Usama with the same chain of transmitters.

Book 26, Number 5484:

    Rafi' b. Khadij reported: I heard Allah's messenger (may peace be upon him) as saying: The fever is due to the intense heat of the Hell, so cool it with water.

Book 26, Number 5485:

    Rafi' b. Khadij reported: I heard Allah's Messenger (may peace be upon him) as saying: The fever is due to the intense heat of Hell, so cool it down in your (bodies) with water. Aba Bakr has made no mention of the word "from you" ('ankum), but he said that Rafi' b. Khadij had informed him of it.

Chapter 25 : DISAPPROVAL OF APPLYING REMEDY BY POURING THE MEDICINE IN THE MOUTH FORCIBLY

Book 26, Number 5486:

    'A'isha reported: we (intended to pour) medicine in the mouth of Allah's Messenger (may peace be upon him) in his illness, but he pointed out (with the gesture of his hand) that it should not be poured into the mouth against his will. We said: (It was perhaps due to the natural) aversion of the patient against medicine. When he recovered, he said: Medicine should be poured into the mouth of every one of you except Ibn 'Abbas, for he was not present amongst you.

Chapter 26 : TREATMENT WITH THE HELP OF INDIAN ALOESWOOD

Book 26, Number 5487:

    Umm Qais, daughter of Mihsan, the sister of 'Ukasha b. Mihsan said: I visited Allah's Messenger (may peace be upon him) along with my son who had not, by that time, been weaned and he pissed over his (clothes). He ordered water to be brought and sprinkled (it) over them. She (further) said: I visited him (Allah's Apostle) along with my son and I had squeezed the swelling in the uvula, whereupon he said: Why do you afflict your children by compressing like this? Use this Indian aloeswood, for it contains seven types of remedies, one among them being a remedy for pleurisy. It is applied through the nose for a swelling of the uvula and poured into the side of the mouth for pleurisy.

Book 26, Number 5488:

    Umm Qais, daughter of Mihsan, was one of the earlier female emigrants who had pledged allegiance to Allah's Messenger (may peace be upon him). She was the sister of Ukisha b. Mihsan, one of the posterity of Asad b. Khuzaima. She reported that she came to Allah's messenger (may peace be upon him) along with her son who had not attained the age of weaning and she had compressed the swelling of his uvula. (Yunus said: She compressed the uvula because she was afraid that there might be swelling of uvula.) Thereupon Allah's Messenger (may peace be upon him) said: Why do you afflict your children by compressing in this way? You should use Indian aloeswood, for it has seven remedies in it, one of them being the remedy for pleurisy. Ubaidullah reported that she had told that that was the child who pissed in the lap of Allah's Messenger (may peace be upon him), and Allah's Messenger (may peace be upon him)called for water and sprinkled it on his imrine, but he did not wash it well.

Chapter 27 : REMEDY BY APPLYING NIGELLA

Book 26, Number 5489:

    Abu Huraira reported that he heard Allah's Messenger (may peace be upon him) as saying: Nigella seed is a remedy for every disease except death. This hadith has been narrated through another chain of transmitters but with a slight variation of wording.

Book 26, Number 5490:

    Abu Huraira reported Allah's Messenger (may peace be upon him) as saying: There is no disease for which Nigella seed does not provide remedy.

Chapter 28 : TALBINA GIVES COMFORT TO THE PATIENT

Book 26, Number 5491:

    'A'isha the wife of Allah's Apostle (may peace be upon him) said: When there was any bereavement in her family the women gathered there for condolence and they departed except the members of the family and some selected persons. She asked to prepare talbina in a small couldron and it was cooked and then tharid was prepared and it was poured over talbina, then she said: Eat it, for I heard Allah's Messenger (may peade be upon him) as saying: Talbina gives comfort to the aggrieved heart and it lessens grief.

Chapter 29 : REMEDY WITH THE HELP OF HONEY

Book 26, Number 5492:

    Abu Sa'id Khudri reported that a person came to Allah's Apostle (may peace be upon him) and told him that his brother's bowels were loose. ThereuponAllah's Messenger (may peace be upon him) said: Give him honey. So he gave him that and then came and said: I gave him honey but it has only made his bowels more loose. He said this three times; and then he came the fourth time, and he (the Holy Prophet) said: Give him honey. He said: I did give him, but it has only made his bowels more loose, whereupon Allah's Messenger (may peace be upon him) said: Allah has spoken the truth and your brother's bowels are in the wrong. So he made him drink (honey) and he was recovered. This hadith has been narrated on the authority of Abu Sa'id Khudri through another chain of transmitters but with a slight variation of wording.

Chapter 30 : PLAGUE, ILL OMEN AND MAGIC

Book 26, Number 5493:

    'Amir b. Sa'd b. Abu Waqqas reported on the authority of his father that he asked Usama b. Zaid: What have you heard from Allah's Messenger (may peace be upon him) about plague? Thereupon Usama said: Allah's Messenger (may peace be upon him) said: Plague is a calamity which was sent to Bani Isra'il or upon those who were before you. So when you hear that it has broken out in a land, don't go to it, and when it has broken out in the land where you are, don't run out of it. In the narration transmitted on the authority of Abu Nadr there is a slight variation of wording.

Book 26, Number 5494:

    Usama b. Zaid reported that Allah's Messenger (may peace be upon him) had said: Plague is the sign of a calamity with which Allah, the Exalted and Glorious, affects people from His servants. So when you hear about it, don't enter there (where it has broken out), and when it has broken out in a land and you are there, then don't run away from it.

Book 26, Number 5495:

    Usama reported Allah's Messenger (may peace be upon him) as saying: Plague is a calamity which was inflicted on those who were before you, or upon Bani Isra'il. So when it has broken out in a land, don't run out of it, and when it has spread in a land, then don't enter it.

Book 26, Number 5496:

    'Amir b. Sa'd reported that a person asked Sa'd b. Abu Waqqas about the plague, whereupon Usama b. Zaid said: I would inform you about it. The Messenger of Allah (may peace be upon him) said: It is a calamity or a disease which Allah sent to a group of Bani Isra'il, or to the people who were before you; so when you hear of it in land, don't enter it and when it has broken out in your land, don't run away from it.

Book 26, Number 5497:

    This hadith has been narrated on the authority of Ibn Juraij through another chain of transmitters.

Book 26, Number 5498:

    Usama b. Zaid reported Allah's Messenger (may peace be upon him) having said this: This calamity or illness was a punishment with which were punished some of the nations before you. Then it was left upon the earth. It goes away once and comes back again. He who heard of its presence in a land should not go towards it, and he who happened to be in a land where it had broken out should not fly from it.

Book 26, Number 5499:

    This hadith has been narrated on the authority of Zuhri with a different chain of transmitters.

Book 26, Number 5500:

    Shu'ba reported from Habib: While we were in Medina we heard of plague having broken out in Kufa. 'Ata b. Yasir and others said to me that Allah's Messenger (may peace be upon him) had said. If you are in a land where it (this scourge) has broken out, don't get out of it, and if you were to know that it had broken (in another land, then don't enter it. I said to him: From whom (did you hear it) ? They said: 'Amir b. Sa'd has narrated it. So I came to him. They said that he was not present there. So I met his brother Ibrahim b. Sa'd and asked him. He said: I bear testimony to the fact that Usama narrated it to Sa'd saying: I heard Allah's Messenger (may peace be upon him) as saying that it is a God-sent punishment from the calamity or from the remnant of the calamity with which people were afflicted before you. So when it is in a land and you are there, don't get out of it, and if (this news reaches you) that it has broken out in a land, then don't enter therein. Habib said: I said to Ibrahim: Did you hear Usama narrating it to Sa'd and he was not denying it. He said: Yes.

Book 26, Number 5501:

    This hadith has been narrated on the authority of Shu'ba with the same chain of transmitters except for the fact that no mention has been made of the account of 'Ata b. Yasir as in the previous hadith.

Book 26, Number 5502:

    This hadith has been transmitted on the authority of Sa'd b. Malik, Khuzaima b. Thabit and Usama b. Zaid.

Book 26, Number 5503:

    Ibrahim b. Sa'd b. Abu Waqqas reported: Usama b. Zaid and Sa'd had been sitting and they had been conversing and they said this: This hadith has been transmitted by Ibrahim b. Sa'd b. Malik on the authority of his father.

Book 26, Number 5504:

    'Abdullah b. 'Abbas reported: Umar b. Khattab set out for Syria. As he came at Sargh (a town by the side of Hijaz on the way to Syria), there met him the commander of the forces, Abu Ubaida b. Jandb, and his companions. They informed him that a scourge had broken out in Syria. Ibn 'Abbas further reported that 'Umar said: Call to me tile earliest emigrants. So I called them. He (Hadrat 'Umar) sought their advice, and they told him that the scourge had broker, out in Syria. There was a difference of opinion (whether they should proceed further or go back to their homes in such a situation). Some of them said: You ('Umar) have set forth for a task, and, therefore, we would not advise you to go back, whereas some of them said: You have along with you the remnants (of the sacred galaxy) of men and (the blessed) Companions of Allah's Messenger (may peace be upon him), so we would not advise you to go forth towards this calamity (with such eminent persons and thus expose them deliberately to a danger). He (Hadrat 'Umar) said: You can now go away. He said: Call to me the Ansar. So I called them to him, and he consulted them, and they trod the same path as was trodden by the Muhajirin, and they differed in their opinions as they had differed. He said: Now, you can go. He again said: Call to me the old persons of the Quraish who had migrated before the Victory (that is the Victory of Mecca), so I called them (and 4mt 'Umar consulted them) and not even two persons differed (from the opinion held by the earlier delegates). They said: Our opinion is that you better go back along with the people and do not make them go to this scourge, So 'Umar made announcement to the people: In the morning I would be on the back of my side. So they (set forth in the morning), whereupon Abu 'Ubaida b. Jarrah said: Are you going to run away from the Divine Decree ? Thereupon 'Umar said: Had it been someone else to say this besides you! 'Umar (in fact) did not approve of his opposing (this decision) and he said: Yes, we are running from the Divine Decree (to the) Divine Decree. You should think if there had been camels for you and you happened to get down in a valley having two sides, one of them covered with verdure and the other being barren, would you not (be doing) according to the Divine Decree if you graze them in verdure ? And in case you graze them in the barren land (even then you would be grazing them) according to the Divine Decree.
    There happened to come 'Abd al-Rahman b. 'Auf and he had been absent in connection with some of his needs. He said: I have with me a knowledge of it, that I heard Allah's Messenger (may peace be upon him) as saying: If you hear of its presence (the presence of plague) in a land, don't enter it, but if it spreads in the land where you are, don't fly from it. Thereupon 'Umar b. Khattab praised Allah and then went back?

Book 26, Number 5505:

    This hadith has been reported on the authority of Ma'mar with the same chain of transmitters but with this addition: "Do you think that he would graze in the barren land but would abandon the green land? Would you not attribute it to be a failing on his part ? He said: Yes. He said: Then proceed. And he moved on until he came to Medina. And he said to me: This is the right place, or he said: That is the destination if Allah so wills." This hadith has been transmitted on the authority of 'Abdullah b. Harith with a slight variation of wording.

Book 26, Number 5506:

    'Amir b. Rabi'ah reported: 'Umar went to Syria and as he came to Sargh, information was given to him that an epidemic had broken out in Syria. 'Abd al-Rahman b. 'Auf narrated to him that Allah's Messenger (may peace be upon him) had said: When you hear of its presence in a land, don't move towards it, and when it breaks out in a land and you are therein, then don't run away from it. So 'Umar b. Khattab came back from Sargh. Salim b. 'Abdullah reported that 'Umar went back, along with people on hearing the hadith reported on the authority of 'Abd al-Rahman b. 'Auf.

Chapter 31 : THERE IS NO INFECTION, NO EVIL OMEN, NO HAMA, NO SAFAR, NO STAR PROMISING RAIN, NO GHOUL AND THE ILL SHOULD NOT GO TO THOSE WHO ARE HEALTHY

Book 26, Number 5507:

    Abu Huraira reported Allah's Messenger (may peace be upon him) as saying: There is no infection, no safar, no hama. A desert Arab said: Allah's Messenger, how is it that when the camel is in the sand it is like a deer-then a camel afflicted with scab mixes with it and it is affected by sub ? He (the Holy Prophet) said: Who infected the first one?

Book 26, Number 5508:

    Abu Huraira reported Allah's Messenger (may peace be upon him) as saying: There is no transitive disease, no evil omen, no safar, no hama. A desert Arab said: Allah's,Messenger.... The rest of the hadith is the same.

Book 26, Number 5509:

    Abu Huraira reported Allah's Messenger (may peace be upon him) as saying: There is no trahsitive disease. Thereupon a desert Arab stood up. The rest of the hadith is the same and in the hadith transmitted on the authority of Zuhri' the Prophet (may peace be upon him) is reported to have said: There is no transitive disease, no safar, no hama.

Book 26, Number 5510:

    Abu Salama h. 'Abd al-Rahman b. 'Auf reported Allah's Messenger (may peace be upon him) as saying: There is no transitive disease, but he is also reported to have said: A sick person should not be taken to one who is healthy. Abu Salama said that Abu Huraira used to narrate these two (different ahadith) from Allah's Messenger (may peace be upon him), but afterwards Abu Huraira became silent on these words: "There is no transitive disease," but he stuck to this that the sick person should not be taken to one who is healthy. Harith b. Abu Dhubab (and he was the first cousin of Abu Huraira) said: Abu Huraira, I used to hear from you that you narrated to us along with this hadith and the other one also (there is no transitive disease), but now you observe silence about it. You used to say that Allah's Messenger (may peace be upon him) said: There is no transitive disease. Abu Huraira denied having any knowledge of that, but he said that the sick camel should not be taken to the healthy one. Harith, however, did not agree with him, which irritated Abu Huraira and he said to him some words in the Abyssinian language. He said to Harith: Do you know what I said to you? He said: No. Abu Huraira said: I simply denied having said it. Abu Salama sad: By my life, Abu Huraira in fact used to report Allah's Messenger (may peace be upon him) having said: There is no transitive disease. I do not know whether Abu Huraira has forgotten it or he deemed it an abrogated statement in the light of the other one.

Book 26, Number 5511:

    Abu Huraira reported Allah's Messenger (may peace be upon him) as saying: There is no transitive disease and he also reported along with it: The ill should not be taken to the healthy.

Book 26, Number 5512:

    This hadith has been reported on the authority of Zuhri with the same chain of transmitters.

Book 26, Number 5513:

    Abu Huraira reported Allah's Messenger (may peace be upon him) as saying: There is no transitive disease, no huma, no star promising rain, no safar.

Book 26, Number 5514:

    Jabir reported Allal's Messenger (may peace be upon him) as saying: There is no transitive disease, no ill omen, no ghoul.

Book 26, Number 5515:

    Jabir reported Allah's Messenger (may peace be upon him) as saying: There is no transitive disease, no ghoul, no safar.

Book 26, Number 5516:

    Jabir b. 'Abdullah reported Allah's Apostle (may peace be upon him) as saying: There is no transitive disease, no safar, no ghoul. He (the narrator) said: I heard Abu Zubair say: Jabir explained for them the word safar. Abu Zubair said: safar means belly. It was said to Jabir: Why is it so? He said that it was held that safar implied the worms of the belly, but he gave no explanation of ghoul. Abu Zubair said: Ghoul is that which kills the travellers.

Chapter 32 : OMEN, DIVINATION AND THAT WHICH IS UNLUCKY

Book 26, Number 5517:

    Abu Huraira reported: I heard Allah's Messenger (may peace be upon him) as saying: There is no divination but the best type is the good omen. It was said to Allah's Messenger (may peace be upon him): What is good omen? Thereupon he said: A good word which one of you hears.

Book 26, Number 5518:

    This hadith has been narrated on the authority of Zuhri with the same chain of transmitters but with a slight variation of wording.

Book 26, Number 5519:

    Anas reported Allah's Messenger (may peace be upon him) as saying: There is no transitive disease, no divination, but good omen pleases me, i.e. the good word or a good word.

Book 26, Number 5520:

    Anas b. Malik reported Allah's Messenger (may peace be upon him) as saying: There is no transitive disease, no divination, but good omen pleases me. It was said: What is good omen? He said: Sacred words.

Book 26, Number 5521:

    Abu Huraira reported Allah's Messenger (may peace be upon him) as saying: There is no transitive disease, no divination, but I like good words.

Book 26, Number 5522:

    Abu Huraira reported Allah's Messenger (may peace be upon him) as saying: There is no transitive disease, no hama, no divination, but I like good omen.

Book 26, Number 5523:

    'Abdullah b. 'Umar reported Allah's Messenger (may peace be upon him) as saying: If there be bad luck, it is in the house, and the wife, and the horse.

Book 26, Number 5524:

    'Abdullah b. 'Umar reported Allah's Messenger (may peace be upon him) as saying. There is no transitive disease, no ill omen, and bad luck is lound in the house, or wife or horse.

Book 26, Number 5525:

    This hadith has been reported on the authority of Zuhri with other chains of transmitters but with slight variations of wording.

Book 26, Number 5526:

    'Umar b. Muhammad b. Zaid reported that he heard his father narrating from Ibn 'Umar that Allah's Messenger (may peace be upon him) had said. If bad luck is a fact, then it is in the horse, the woman and the house.

Book 26, Number 5527:

    This hadith has been narrated on the authority of Shu'ba with the same chain of transmitters but there is no mention of the word "Haqq"" (fact).

Book 26, Number 5528:

    'Abdullah b. 'Umar reported on the authority of his father that Allah's Messenger (may peace be upon him) said: If there is bad luck in anything, it is the horse, the abode and the woman.

Book 26, Number 5529:

    Sahl b. Sa'd reported Allah's Messenger (may peace be upon him) as saying: If bad luck were to be in anything, it is found in the woman, the horse and the abode.

Book 26, Number 5530:

    This hadith has been narrated on the authority of Sahl b. Sa'd with a difterent chain of transmitters.

Book 26, Number 5531:

    Jabir reported Allah's Messenger (may peace be upon him) as saying: If bad luck were to be in anything, it is found in the land, in the servant and in the horse.

Chapter 33 : KAHANAT (DIVINATION) IS PROHIBITED AND IT IS FORBIDDEN TO GO TO THE KAHIN

Book 26, Number 5532:

    Mu'awiya b. al-Hakam as-Sulami reported: I said: Messenger of Allah, there were things we used to do in the pre-Islamic days. We used to visit Kahins, whereupon he said: Don't visit Kahins. I said: We used to take omens. He said: That is a sort of personal whim of yours, so let it not prevent you (from doing a thing).

Book 26, Number 5533:

    This hadith has been transmitted on the authority of Zuhri with a slight variation of wording.

Book 26, Number 5534:

    This hadith has been narrated on the authority of Mu'awiya b. Hakam as-Sulami through another chain of transmitters. The hadith transmitted on the authority of Yahya b. Abu Kathir (there is an addition of these words) : I said: Among us there are men who draw lines and thus make divination. What about this? Thereupon he (the Holy Prophet) said: There was a Prophet who drew lines, so whose lines agree with his line for him it is allowable.

Book 26, Number 5535:

    'A'isha reported: I said: Allah's Messenger, the kahins used to tell us about things (unseen) and we found them to be true. Thereupon he said: That is a word pertaining to truth which a jinn snatches and throws into the ear of his friend, and makes an addition of one hundred lies to it.

Book 26, Number 5536:

    'Urwa reported from 'A'isha that she said that people asked Allah's Messenger (may peace be upon him) about the kahins. Allah's Messenger (may peace be upon him) said to them: It is nothing (i.e. it is a mere superstition). They said: Allah's Messenger, they at times narrate to us things which we find true. Thereupon Allah's Messenger (may peace be upon him) said: That is a word pertaining to truth which a jinn snatches away and then cackles into the ear of his friend as the hen does. And then they mix in it more than one hundred lies.

Book 26, Number 5537:

    This hadith has been narrated on the authority of Zuhri with the same chain of transmitters.

Book 26, Number 5538:

    'Abdullah. Ibn 'Abbas reported: A person from the Ansar who was amongst the Companions of Allah's Messenger (may peace be upon him) reported to me: As we were sitting during the night with Allah's Messenger (may peace be upon him), a meteor shot gave a dazzling light. Allah's Messenger (may peace be upon him) said: What did you say in the pre-Islamic days when there was such a shot (of meteor)? They said: Allah and His Messenger know best (the actual position), but we, however,used to say that that very night a great man had been born and a great man had died, whereupon Allah's Messenger (may peace be upon him) said: (These meteors) are shot neither at the death of anyone nor on the birth of anyone. Allah, the Exalted and Glorious, issues Command when He decides to do a thing. Then (the Angels) supporting the Throne sing His glory, then sing the dwellers of heaven who are near to them until this glory of God reaches them who are in the heaven of this world. Then those who are near the supporters of the Throne ask these supporters of the Throne: What your Lord has said? And they accordingly inform them what He says. Then the dwellers of heaven seek information from them until this information reaches the heaven of the world. In this process of transmission (the jinn snatches) what he manages to overhear and he carries it to his friends. And when the Angels see the jinn they attack them with meteors. If they narrate only which they manage to snatch that is correct but they alloy it with lies and make additions to it.

Book 26, Number 5539:

    The hadith has been narrated on the authority of Zuhri through the same chain of transmitters but with a slight variation of wording.

Book 26, Number 5540:

    Safiyya reported from some of the wives of Allah's Apostle (may peace be upon him) Allah's Apostle (may peace be upon him) having said: He who visits a divner ('Arraf) and asks him about anything, his prayers extending to forty nights will not be accepted.

Chapter 34 : IT IS ADVISABLE TO AVOID MIXING WITH THE LEPER

Book 26, Number 5541:

    'Amr b. Sharid reported on the authority of his father that there was in the delegation of Thaqif a leper. Allah's Apostle (may peace be upon him) sent a message to him: We have accepted your allegiance, so you may go.

Chapter 35 : KILLING OF SNAKES

Book 26, Number 5542:

    'A'isha reported that Allah's Messenger (may peace be upon him) commanded the killing of a snake having stripes over it, for it affects eyesight and miscarries pregnancy.

Book 26, Number 5543:

    This hadith has been transmitted on the authority of Hisham. He said : The short-tailed snake and the snake having stripes over it should be killed.

Book 26, Number 5544:

    Salim, on the authority of his father. reported Allah's Apostle (may peace be upon him) as saying : Kill the snakes having stripes over them and short-tailed snakes, for these two types cause miscarriage (of a pregnant woman) and they affect the eyesight adversely. So Ibn 'Umar used to kill every snake that he found. Abu Lubaba b. 'Abd al-Mundhir and Zaid b. Khattab saw him pursuing a snake, whereupon he said: They were forbidden (to kill) those snakes who live in houses.

Book 26, Number 5545:

    Ibn 'Umar reported : I heard Allah's Messenger (may peace be upon him) commanding the killing of dogs and the killing of the striped and the short-tailed snakes, for both of them affect the eyesight adversely and cause miscarriage. Zuhri said : We thought of their poison (the pernicious effects of these two). Allah, however, knows best. 'Abdullah b. 'Umar said: I did not spare any snake. I rather killed everyone that I saw. One day as I was pursuing a snake from amongst the snakes of the house, Zaid b. Khattab or Abu Lubaba happened to pass by me and found me pursuing it. He said: 'Abdullah, wait. I said: Allah's Messenger (may peace be upon him) commanded (us) to kill them, whereupon he said that Allah's Messenger (may peace be upon him) forbade the killing of the snakes of the houses. This hadith has been narrated on the authority of Zuhri with the same chain of transmitters but with a slight variation of wording.

Book 26, Number 5546:

    Nafi' reported that Abu Lubaba talked to Ibn 'Umar to open a door in his house which would bring them nearer to the mosque and they found a fresh slough of the snake, whereupon 'Abdullah said: Find it out and kill it. Abu Lubaba said: Don't kill them, for Allah's Messenger (may peace be upon him) forbade the killing of the snakes found in houses.

Book 26, Number 5547:

    Nafi' reported that Ibn 'Urnar used to kill all types of snakes until Abu Lubaba b. 'Abd al-Mundhir Badri reported that Allah's Messenger (may peace be upon him) had forbidden the killing of the snakes of the houses, and so he abstained from it.

Book 26, Number 5548:

    Nafi' reported that he heard Abu Lubaba informing Ibn 'Umar that Allah's Messenger (may peace be upon him) had forbidden the killing of domestic snakes.

Book 26, Number 5549:

    'Abdullah reported that Abu Lubaba had informed him that Allah's Messenger (may peace be upon him) had forbidden the killing of the snakes found in the house.

Book 26, Number 5550:

    Nafi' reported that Abu Lubaba b. 'Abd al-Mundhir al-Ansari (first) lived in Quba. He then shifted to Medina and as he was in the company of 'Abdullah b. 'Umar opening a window for him, he suddenly saw a snake in the house. They (the inmates of the house) attempted to kill that. Thereupon Abu Lubaba said: They had been forbidden to make an attempt to kill house snakes and they had been commanded to kill the snakes having small tails, small snakes and those having streaks over them, and it was said: Both of them affect the eyes and cause miscarriage to women.

Book 26, Number 5551:

    Nafi' reported on the authority of his father that as 'Abdullah b. 'Umar saw one day (standing) near the ruin (of his house) the slough of a snake and said (to the people around him): Pursue this snake and kill it. Abu Lubaba Ansari said: I heard Allah's Messenger (may peace be upon him). He forbade the killing of snakes found in the houses except the short-tailed snakes and those having streaks upon them, for both of them obliterate eyesight and affect that which is in the wombs of (pregnant) women.

Book 26, Number 5552:

    Nafi' reported that Abu Lubaba happened to pass by Ibn 'Umar who lived in the fortified place near the house of 'Umar b. Khattab and was busy in keeping his eyes upon a snake and killing it, the rest of the hadith is the same.

Book 26, Number 5553:

    'Abdullah reported: We were with Allah's Messenger (may peace be upon him) in a cave when there was revealed to him (the Sura al-Mursalat, i.e. Sura lxxvii.: "By those sent forth to spread goodness") and we had just heard (it) from his lips that there appeared before us a snake. He said: Kill it. We hastened to kill it, but it slipped away from us, thereupon Allah's Messenger (may peace be upon him) said: Allah saved it from your harm just as he saved you from its evil.

Book 26, Number 5554:

    This hadith has been narrated on the authority of al-A'mash with the same chain of transmitters.

Book 26, Number 5555:

    'Abdullah reported that Allah's Messenger (may peace be upon him) commanded a Muhrim (one who is in the state of pilgrimage) to kill the snake at Mina.

Book 26, Number 5556:

    'Abdullah reported: While we were with the Messenger of Allah (may peace be upon him) in the cave, the rest of the hadith is the same as the one narrated above.

Book 26, Number 5557:

    Abu as-Sa'ib, the freed slaved of Hisham b. Zuhra, said that he visited Abu Sa'id Khudri in his house, (and he further) said: I found him saying his prayer, so I sat down waiting for him to finish his prayer when I heard a stir in the bundles (of wood) lying in a comer of the house. I looked towards it and found a snake. I jumped up in order to kill it, but he (Abu Sa'id Khudri) made a gesture that I should sit down. So I sat down and as he finished (the prayer) he pointed to a room in the house and said: Do you see this room? I said: Yes. He said: There was a young man amongst us who had been newly wedded. We went with Allah's Messenger (may peace be upon him) (to participate in the Battle) of Trench when a young man in the midday used to seek permission from Allah's Messenger (may peace be upon him) to return to his family. One day he sought permission from him and Allah's Messenger (may peace be upon him) (after granting him the permission) said to him: Carry your weapons with you for I fear the tribe of Quraiza (may harm you). The man carried the weapons and then came back and found his wife standing between the two doors. He bent towards her smitten by jealousy and made a dash towards her with a spear in order to stab her. She said: Keep your spear away and enter the house until you see that which has made me come out. He entered and found a big snake coiled on the bedding. He darted with the spear and pierced it and then went out having fixed it in the house, but the snake quivered and attacked him and no one knew which of them died first, the snake or the young man. We came to Allah's Apostle (may peace be upon him) and made a mention to him and said: Supplicate to Allah that that (man) may be brought back to life. Thereupon he said: Ask forgiveness for your companion and then said: There are in Medina jinns who have accepted Islam, so when you see any one of them, pronounce a warning to it for three days, and if they appear before you after that, then kill it for that is a devil.

Book 26, Number 5558:

    Asma' b. 'Ubaid reported about a person who was called as-Sa'ib having said: We visited Abu Sa'id Khudri. When we had been sitting (with him) we heard a stir under his bed. When we looked we found a big snake, the rest of the hadith is the same. And in this Allah's Messenger (may peace be upon him) is reported to have said: Verily in these houses there live aged (snakes), so when you see one of them, make life hard for it for three days, and if it goes away (well and good), otherwise kill it for (in that case) it would be a nonbeliever. And he (the Holy Prophet) said (to his Companions): Go and bury your companion (who had died by the snake bite).

Book 26, Number 5559:

    Abu Sa'id Khudri reported Allah's Messenger having said: There is a group of jinns in Medina who accepted Islam, so he who would see anything from these occupants should warn him three times; and if he appears after that, he should kill him for he is a satan.

Chapter 36 : THE DESIRABILITY OF KILLING A GECKO (HOUSE LIZARD)

Book 26, Number 5560:

    Umm Sharik reported that Allah's Messenger (may peace be upon him) commanded her to kill geckos. This hadith has been transmitted on the authority of Ibn Abi Shaiba with a slight variation of wording.

Book 26, Number 5561:

    Umm Sharik reported that she consulted Allah's Apostle (may peace be upon him) in regard to killing of geckos, and he commanded to kill them and Umm Sharik is one of the women of Bani 'Amir b. Luwayy. This hadith has been reported through another chain of transmitters with the same meaning.

Book 26, Number 5562:

    'Amir b. Sa'd reported on the authority of his father that Allah's Apostle (may peace be upon him) commanded the killing of geckos, and he called them little noxious creatures.

Book 26, Number 5563:

    'A'isha reported that Allah's Messenger (may peace be upon him) said about the gecko as a noxious creature". Harmala made this addition that she said: I did not hear that he had commanded to kill them.

Book 26, Number 5564:

    Abu Huraira reported Allah's Messenger (may peace be upon him) as saying: He who killed a gecko with the first stroke for him is such and such a reward, and he who killed it with a second stroke for him is such and such reward less than the first one, and he who killed it with the third stroke for him is such and such a reward less than the second one.

Book 26, Number 5565:

    This hadith has been reported on the authority of Abu Huraira through another chain of transmitters (and the words are):- He who killed a gecko with the first stroke for him are ordained one hundred virtues, and with the second one less than that and with the third one less than that.

Book 26, Number 5566:

    Abu Huraira reported Allah's Messenger (may peace be upon him) as saying (that he who kills a gecko) with the first stroke there are seventy rewards for him.

Chapter 37 : PROHIBITION-OF KILLING THE ANTS

Book 26, Number 5567:

    Abu Huraira reported Allah's Messenger (may peace be upon him) as saying: An ant had bitten a Prophet (one amongst the earlier Prophets) and he ordered that the colony of the ants should be burnt. And Allah revealed to him: "Because of an ant's bite you have burnt a community from amongst the communities which sings My glory."

Book 26, Number 5568:

    Abu Huraira reported Allah's Messenger (may peace be upon him) as saying: An Apostle from amongst the Apostles of Allah encamped under a tree, and an ant bit him, and he commanded his belongings to be removed from underneath the tree. He then commanded and it was burnt, and Allah revealed to bin): "Why one ant (which had bitten you) was not killed?"

Book 26, Number 5569:

    Abu Huraira reported so many ahadith and one of them was this that Allah' Messenger (may peace be upon him) said: When an Apostle from amongst the Apostles of Allah came to sit under a tree an ant bit him. He commanded his luggage to be removed from under the tree and he commanded it to be burnt in the fire and Allah revealed to him: "Why one ant (which had bitten you) was not killed (and why did you burn the others)?

Chapter 38 : IT IS FORBIDDEN TO KILL THE CAT

Book 26, Number 5570:

    Nafi' reported from 'Abdullah that Allah's Messenger (may peace be upon him) said: A woman was punished because she had kept a cat tied until it died, and (as a punishment of this offence) she was thrown into the Hell. She had not provided it with food, or drink, and had not freed her so that she could eat the insects of the earth.

Book 26, Number 5571:

    This hadith has been narrated on the authority of Abu Huraira through another chain of transmitters.

Book 26, Number 5572:

    This hadith has been transmitted on the authority of Ibn 'Umar also.

Book 26, Number 5573:

    Abu Huraira reported Allah's Messenger (may peace be upon him) as saying: A woman was punished because of a cat. She had neither provided her with food nor drink, nor set her free so that she might eat the insects of the earth.

Book 26, Number 5574:

    This hadith has been narrated on the authority of Hisham with the same chain of transmitters, but with a slight variation of wording.

Book 26, Number 5575:

    Abu Huraira reported this hadith through another chain of transmitters.

Book 26, Number 5576:

    Hammam b. Manabbih reported this hadith on the authority of Abu Huraira.

Chapter 39 : THE MERIT OF SUPPLYING WATER AND FOOD TO ANIMALS

Book 26, Number 5577:

    Abu Huraira reported Allah's Messenger (may peace be upon 4im) as sayings: A person suffered from intense thirst while on a journey, when he found a well. He climbed down into it and drank (water) and then came out and saw a dog lolling its tongue on account of thirst and eating the moistened earth. The person said: This dog has suffered from thirst as I had suffered from it. He climbed down into the well, filled his shoe with water, then caught it in his mouth until he climbed up and made the dog drink it. So Allah appreciated this act of his and pardoned him. Then (the Companions around him) said: Allah's Messenger, is there for us a reward even for (serving) such animals? He said: Yes, there is a reward for service to every living animal.

Book 26, Number 5578:

    Abu Huraira reported Allah's Messenger (may pace be upon him) as saying: A prostitute saw a dog moving around a well on a hot day and hanging out its tongue because of thirst. She drew water for it in her shoe and she was pardoned (for this act of hers).

Book 26, Number 5579:

    Abu Huraira reported Allah's Messenger (may peace be upon him) as saying: There was a dog moving around a well whom thirst would have killed. Suddenly a prostitute from the prostitutes of Bani Isra'il happened to see it and she drew water in her shoe and made it drink, and she was pardoned because of this.


Book 27: THE BOOK CONCERNING THE USE OF CORRECT WORDS (KITAB AL-ALFAZ MIN AL-ADAB WA GHAIRIHA)

KITAB AL-ALFAZ MIN AL-ADAB WA GHAIRIHA (THE BOOK CONCERNING THE USE OF CORRECT WORDS)

Back
Chapter 1 : PROHIBITION OF ABUSING TIME (DAHR)

Book 27, Number 5580:

    Abu Huraira reported: I heard Allah's Messenger (may peace be upon him) as saying: Allah, the Exalted and Glorious, said: The son of Adam abuses Dahr (the time), whereas I am Dahr since in My hand are the day and the night.

Book 27, Number 5581:

    Abu Huraira reported Allah's Messenger (may peace be upon him) as saying: Allah, the Exalted and Glorious, said: The son of Adam displeases Me by abusing Dahr (time), whereas I am Dahr--I alternate the night and the day.

Book 27, Number 5582:

    Abu Huraira reported Allah's Messenger (may peace be upon him) as saying: Allah, the Exalted and Glorious, said: The son of Adam causes Me pain as he says: Woe be upon the Time. None of you should say this: Woe be upon the Time, as I am the Time (because) I alternate the day and the night, and when I wish I can finish them up.

Book 27, Number 5583:

    Abu Huraira reported Allah's Messenger (may peace be upon him) as saying: None of you should say: Woe be upon the Time, for verily Allah is the Time.

Book 27, Number 5584:

    Abu Huraira reported Allah's Apostle (may peace be upon him) as saying: Do not abuse Time, for it is Allah Who is the Time.

Chapter 2 : DISAPPROVAL OF NAMING THE VINE AS A KARM

Book 27, Number 5585:

    Abu Huraira reported Allah's Messenger (may peace be upon him) as saying: None of you should abuse Time for it is Allah Who is the Time, and none of you should call 'Inab (grape) as al-karm, for karm is a Muslim person.

Book 27, Number 5586:

    Abu Huraira reported Allah's Messenger (may peace be upon him) as saying: Do not use the word karm (for wine) for worthy of respect is the heart of a believer.

Book 27, Number 5587:

    Abu Huraira reported Allah's Messenger (may peace be upon him) as saying: Do not name grape as karm, for worthy of respect is a Muslim.

Book 27, Number 5588:

    Abu Huraira reported Allah's Messenger (may peace be upon him) as saying: None of you should use the word al-harin (for grape) for the heart of a believer is karm (worthy of respect).

Book 27, Number 5589:

    Abu Huraira reported from Allah's Messenger (may peace be upon him) various ahadith, one of which is this that he said: None of you should use the word al-karm for 'Inab, for karm (worthy of respect) is a Muslim person.

Book 27, Number 5590:

    'Alqama b. Wa'il reported, from his father, Allah's Apostle (may peace be upon him) having said: Do not say al-karm (for the word vine) but say al-habala (that is grape). This hadith has been reported by Alqama b. Wa'il on the authority of his father with a different chain of transmitters and with a slight variation of wording.

Chapter 3 : THE PROPER USE OF THE WORDS: BONDMAN, SLAVE-GIRL, AL-MAULA AND AS-SAYYID

Book 27, Number 5591:

    Abu Huraira reported Allah's Messenger (may peace be upon him) as saying: None of you should say: My bondman and my slave-girl, for all of you are the bondmen of Allah, and all your women are the slave-girls of Allah; but say: My servant, my girl, and my young man and my young girl.

Book 27, Number 5592:

    Abu Huraira reported Allah's Messenger (may peace be upon him) as saying: None of you should say: My bondman, for all of you are the bondmen of Allah, but say: My young man, and the servant should not say: My Lord, but should say: My chief.

Book 27, Number 5593:

    This hadith has been reported on the authority of al-A'mash with the same chain of transmitters, and the words are that the servant should not say to his chief: My Lord, and Abu Mu'awiya made an addition: "For it is Allah, the Exalted and Glorious, Who is your Lord."

Book 27, Number 5594:

    Abu Huraira reported Allah's Messenger (may peace be upon him) so many ahadith and one of them is this that Allah's Messenaer (may peace be upon him) said: None of you should say: Supply drink to your lord, feed your lord, hell) your lord in performing ablution, and none of you should say: My Lord. He should say: My chief, my patron; and none of you should say: My bondman, my slave-girl, but simply say: My boy, my girl, my servant.

Chapter 4 : DISAPPROVAL OF USING THE PHRASE: "MY SOUL HAS BECOME EVIL"

Book 27, Number 5595:

    'A'isha reported Allah's Messenger (may peace be upon him) having said: None of you should say: "My soul has become evil," but he should say: "My soul has become remorseless." This hadith has been transmitted on the authority of Abfl Bakr with a slight variation of wording.

Book 27, Number 5596:

    This hadith has been narrated on the authority of Abia Mu'iwiya with the same chain of transmitters.

Book 27, Number 5597:

    Abu Umama b. Sahl b. Hunaif, on the authority of his father, reported Allah's Messenger (may peace be upon him) as saying: None of you should say: "My soul has become evil," but he should say: "My soul has become remorseless."

Chapter 5 : THE USE OF MUSK AND THAT IS THE BEST SCENT, AND THE DISAPPROVAL OF REJECTING THE GIFT OF SCENT AND FLOWER

Book 27, Number 5598:

    Abd Sa'id Khudri reported Allah's Apostle (may peace be upon him) as saying: There was a woman from Bani Isra'il who was short-statured and she walked in the company of two tall women with wooden sandals in her feet and a ring of gold made of plates with musk filled in them and then looked up, and musk is the best of scents; then she walked between two women and they (the people) did not recognise her, and she made a gesture with her hand like this, and Shu'ba shook his hand in order to give an indication how she shook her hand.

Book 27, Number 5599:

    Abu Sa'id Khudri reported that Allah's Messenger (may peace be upon him) made a mention of a woman of Bana Isra'il who had filled her ring with musk and musk is the most fragrant of the scents.

Book 27, Number 5600:

    Abu Huraira reported Allah's Messenger (may peace be upon him) as saying: He who is presented with a flower should not reject it, for it is light to carry and pleasant in odour.

Book 27, Number 5601:

    Nafi' reported that when Ibn Umar wanted fumigation he got it from aloeswood without mixing anything with it, or he put camphor along with aloeswood and then said: This is how Allah's Messenger (may peace be upon him) fumigated.


Book 28 : The Book of Poetry (Kitab Al-Sh'ir)

Kitab Al-Sh'ir (Book of Poetry )

Back
Chapter 1 : ....

Book 28, Number 5602:

    'Amr b. Sharid reported his father as saying : One day when I rode ehind Allah's Messenger (may peace be upon him), he said (to me) : Do you remember any Poetry of Umayya b. Abu Salt. I said : Yes. He said: Then go on. I recited a couplet, and he said : Go on. Then I again recited a couplet and he said : Go on. I recited one hundred couplets (of his poetry). This hadith has been reported on the authority of Sharid through another chain of transmitters but with a slight variation of wording.

Book 28, Number 5603:

    'Amr b. Sharid reported on the authority of his father that Allah's Messeniger (may peace be upon him) asked him to recite poetrv, the rest of the hadith is the same, out with this addition : "He (that is Umayya b. Abu Sharid was about to become a muslim and in the hadith transmitted on the authority, of Ibn Mahdi (the words are) "He was almost a Muslim in his poetry."

Book 28, Number 5604:

    Abu Huraira reported Allah's Messenger (may peace be upon him) as saying: The truest word spoken by an Arab (pre-Islamic) in poetry is this verse of Labid: "Behold! apart from Allah everything is vain."

Book 28, Number 5605:

    Abu Huraira reported Allah's Messenger (may peace be upon him) as saying : The truest word uttered by a poet is this verse of Labid: "Behold ! apart from Allah everything is vain," and Umayya b. Abu Salt was almost a Muslim.

Book 28, Number 5606:

    Abu Huraira reported Allah's Messenger (may peace be upon him) as saying : The truest verse recited by a poet is: Beliold ! apart from Allah everything is vain, " and Ibn Abu Salt was almost a Muslim.

Book 28, Number 5607:

    Abu Huraira reported Allah's Apostle (may peace be upon him) as saying: The truest couplet recited by a poet is : "Behold ! apart from Allah everything is vain," and he made no addition to it.

Book 28, Number 5608:

    Abu Huraira reported: I heard Allah's Messenger (may peace be upon him) as saying : The truest word which the poet stated is the word of Labid : "Behold ! apart from Allah everything is vain."

Book 28, Number 5609:

    Abu Huraira reported Allah's Messenger(may peace be opon him)as saying : It is better for a man's belly to be stuffld with pus which corrodes it than to stuff) one's mind with frivolous poetry. Abd Bakr has reported it with a slight variation Of wording.

Book 28, Number 5610:

    Sa'd reported Allah's Apostle (may peace be upon him) as saying : It is better for the belly of any one of you to be stuffed with pus rather than to stuff (one's mind) with poetry.

Book 28, Number 5611:

    Abd 'Sa'id Khudri reported: We were going with Allah's Messenger (may peace be upon him). As we reached the place (known as) 'Arj there met (us) a poet who had been reciting a poem. Thereupon Allah's Messenger (may peace be upon him) said : Catch the satan or detain the satan, for filling the belly of a person with pus is better than stuffing his brain with poetry.

Chapter 2 : It is prohibited to play chess

Book 28, Number 5612:

    Buraida reported on the authority of his father that Allah's Apostle (may peace be upon him) said : He who played chess is like one who dyed his band with the flesh and blood of swine.


Book 29 : The Book of Vision (Kitab Al-Ruya)

Kitab Al-Ruya (Book of Vision)

Back
Chapter 1 : ....

Book 29, Number 5613:

    Abu Salama reported : I used to see dreams (and was so much perturbed) that I began to quiver and have temperature, but did not cover myself with a mantle. I met Abu Qatada and made a mention of that to him. He said: I heard Allali's Messenger (may peace be upon him) as saying: A good vision comes from Allah and a (bad) dream (hulm) from devil. So when one of.you sees a bad dream (hulm) which he does not like, he should spit on his left side thrice and seek refuge with Allah from its evil; then it will not harm him.

Book 29, Number 5614:

    This hadith has been narrated on the authority of Abu Qatada, but there is no mention of the words of Abu Salama: "I saw dreams (which perturbed me) but I did not cover myself with a mantle."

Book 29, Number 5615:

    This hadith has been reported on the authority of Zuhri with the same chain of transmitters, but it does not contain the words : "I felt disturbed because of that," and there is an addition of these words in the hadith transmitted on the authority of Yunus: "Then spit thrice on the left side when you get up from sleep."

Book 29, Number 5616:

    Abu Qatada reported Allah's Messenger (may peace be upon him) as saying: A good vision is from Allah and a bad dream (hulm) is from the satan; so if one of you sees anything (in a dream which he dislikes, he should spit on his left side thrice and seek refuge with Allah from its evil, and then it will never harm him. Abu Salama said: I used to see dreams weighing more heavily upon me than a mountain; but since I heard this hadith I don't care for it (its burden).

Book 29, Number 5617:

    Abu Salama reported Allah's Messenger (may peace be upon him) as saying: I used to see dreams, but the hadith transmitted on the authority of Laith b. Nu'man, the words of Abu Salama at the concluding part of the hadith are not mentioned. Ibn Rumh has reported in the hadith: "He (one who sleeps) should change the side on which he had been lying before."

Book 29, Number 5618:

    Abu Qatada reported Allah's Messenger (may peace be upon him) as saying : The good vision are from Allah and the evil dreams are from the satan. If one sees a dream which one does not like, one should spit on one's left side and seek the refuge of Allah from the satan; it will not do one any harm, and one should not disclose it to anyone and if one sees a good vision one should feel pleased but should not disclose it to anyone but whom one loves.

Book 29, Number 5619:

    Abu Salama replied: I used to see (such horrible dreams) that I fell ill. I saw Abu Qatada who also said: I used to see dreams which made me sick until I heard Allah's Messenger (may peace be upon him) as saying: Good dreams are from Allah, so if any one of you sees which he likes he should not disclose it to one but whow he loves, but if he sees something which he does not like he should spit on his left side thrice and seek refuge with Allah from the mischief of the satan and its mischief (i.e. of the dream), and he should not relate it to anyone, then it would not harm him.

Book 29, Number 5620:

    Jabir reported Allah's Messenger (may peace be upon him) as saying : If anyone sees a dream which he does not like, lie should spit on his left side.

Book 29, Number 5621:

    Abu Huraira reported Allah's Messenger (may peace be upon him) as saying : When the time draws near (when the Resurrection is near) a believer's dream can hardly be false. And the truest vision will be of one who is himself the most truthful in speech, for the vision of a Muslim is the forty-fifth part of Prophecy, and dreams are of three types: one good dream which is a sort of good tidings from Allah ; the evil dream which causes pain is from the satan ; and the third one is a suggestion of one's own mind; so if any one of you sees a dream which he does not like he should stand tip and offer prayer and he should not relate it to people, and he said: I would love to see fetters (in the dream), but I dislike wearing of necklace, for the fetters is (an indication of) one's steadfastness in religion. The narrator said: I do not know whether this is a part of the hadith or the words of Ibn Sirin.

Book 29, Number 5622:

    Abu Huraira reported: I love to see fetters but I hate necklace (in a dream), for fetters signifies one's steadfastness in religion, and he also reported Allah's Messenger (may peace be upon him) as saying: The vision of a believer is forty-sixth part of Prophecy.

Book 29, Number 5623:

    This hadith has been transmitted on the authority of Abu Huraira and the words are : "When the time draws near," the rest of the hadith is the same.

Book 29, Number 5624:

    Muhammad b. Sirin reported from Abu Huraira a hadith from Allah's Apostle (may peace be upon him) and he mentioned in his hadith his words: "I dislike shackles," up to the end of his statement, but he made no mention of this: "A vision is a forty-sixth part of Prophecy."

Book 29, Number 5625:

    Ubida b. as-Samit reported Allah's Messenger (may peace be upon him) as saying: The vision of a believer is the forty-sixth part of Prophecy.

Book 29, Number 5626:

    This hadith has been narrated on the authority of Anas b. Malik through another chain of transmitters.

Book 29, Number 5627:

    Abu Huraira reported Allah's Messenger (may peace be upon him) as saying: Verily the vision of a believer is one of the forty-sixth part of Prophecy.

Book 29, Number 5628:

    Allah's Messenger (may peace; be upon him) said: The vision of a Muslim which he sees or which is shown to him, and in the hadith transmitted on the authority of Ibn Alushir (the words are): "The pious dream is the forty-sixth part of Prophecy."

Book 29, Number 5629:

    Abu Huraira reported Allah's Messenger (may peace be upon him) as saying: The vision Qf a pious man is the forty-sixth part of Prophecy.

Book 29, Number 5630:

    This hadith has been narrated on the authority of Yahyi b. Abu Kathir with the same chain of transmitters.

Book 29, Number 5631:

    This hadith has been narrated on the authority of Abu Huiaira through another chain of transmitters.

Book 29, Number 5632:

    Ibn 'Umar reported Allah's Messenger (may peace be upon him) as saying: The pious dreams are the seventieth part of Prophecy.

Book 29, Number 5633:

    This hadith has been reported on tile authority of 'Ubaidullah with the same chain of transmitters.

Book 29, Number 5634:

    A hadith like this has been reported on the authority of Nafi' with the same chain of transmitters (and the words are): "I think Ibn 'Uniar said: The seventieth part from Prophecy."

Chapter 2 : THE SAYING OF THE HOLY PROPHET (MAY PEACE BE UPON HIM): HE WHO SEES ME IN A DREAM IN FACT SEES ME

Book 29, Number 5635:

    Abu Huraira reported Allah's Messenger (may peace be upon him) as saying: He who saw me in a dream in fact saw me, for the satan does not appear in my form.

Book 29, Number 5636:

    Abu Huraira reported: I heard Allah's Messenger (may peace be upon him) as saying: He who saw me in a dream would soon see me in the state of wakefulness, or as if he saw me in a state of wakefulness, for the satan does not appear in my form.

Book 29, Number 5637:

    Abu Qatada reported Allah's Messenger (may peace be upon him) as saying: He who saw me in dream in fact saw the truth (what is true).

Book 29, Number 5638:

    Jabir reported Allah's Messenger (may peace be upon him) as saying : He who saw me in sleep in fact saw me, for it is not possible for the satan to appear in my form; and he also said: When any one of you sees a hulm he should not inform anyone, for it is a sort of vain sport of devil in the state of sleep.

Chapter 3 : DO NOT INFORM THE VAIN SPORT OF DEVIL IN A DREAM

Book 29, Number 5639:

    Jabir b. 'Abdullah reported Allah's Messenger (may peace be upon him) as saying: He who saw me in a dream in fact saw me, for the satan cannot assume my form.

Book 29, Number 5640:

    Jabir reported Allah's Messenger (may peace be upon him) as saying: There came to him (the Holy Prophet) a desert Arab and said: I saw in a dream that I had been beheaded and I had been following it (the severed head). Allah's Apostle (may peace be upon him) reprimanded him saying: Do not inform about the vain sporting of devil with you during the night.

Book 29, Number 5641:

    Jabir reported that there came to Allah's Apostle (may peace be upon him) a desert Arab and said: Allah's Messenger, I saw in the state of steep as if my head had been cut off and I had been moving on haltingly after it. Thereupon Allah's Messenger (may peace be upon him) said to that desert Arab: Do not narrate to the people the vain sporting of satan with you in your sleep and (the narrator) also said: I heard Allah's Messenger (may peace be upon him) in his subsequent address: None amongst you should narrate the vain sporting of devil with him in the dream.

Book 29, Number 5642:

    Jabir reported that a'person came to Allah's Apostle (may peace be upon him) and said: Allah's Messenger, I have seen in the state of sleep as if my head had been cut off. Thereupon Allah's Apostle (may peace be upon him) laughed and said: When the satan plays with any one of you in the state of steep, do not inention it to the people; and in the hadith transmitted by Abu Bakr (the words are): "If one of you is played with, and he did not make any mention of the word: "Satan."

Chapter 4 : PERTAINING TO THE INTERPRETATION OF DREAMS

Book 29, Number 5643:

    It is reported eithfr on the authority of Ibn Abbas or on the authority of Abu Huraira that a person came to Allah's Messenger (may peace be upon him) and said: Allah's Messenger, I saw while I was sleeping during the night (this vision) that there was a canopy from which butter and honey were trickling and I also saw people collecting them in the palms of their hands, some more, some less, and I also saw a rope connecting the earth with the sky and I saw you catching hold of it and rising towards the heaven; then another person after you catching hold of it and rising towards(Heaven); then another person catching hold of it, but it was broken while it was rejoined for him and he also climbed up. Abu Bakr said: Allah's Messenger, may my father be sacrificed for you, by Allah, allow me to interpret it. Allah's Messenger (may peace be upon him) sail: Well, give its interpretation. Thereupon Abu Bakr said: The canopy signifies the canopy of Islam and that what it trickles out of it in the form of butter and honey is the Holy Qur'an and its sweetness and softness and what the people get hold of it in their palms implies major portion of the Qur'an or the small portion; and so far as the rope joining the sky with the earth is concerned, it is the Truth by which you stood (in the worldly life) and by which Allah would raise you (to Heaven). Then the person after you would take hold of it and he would also climb up with the help of it. Then another person would take hold of it and climb up with the help of it. Then another person would take hold of it and it would be broken; then it would be rejoined for him and he would climb up with the help of it. Allah's Messenger, may my father be taken as a ransom for you, tell me whether I have interpreted it currectly or I have made an error. Allah's Messenger (may peace be upon him) said: You have interpreted a part of it correctly and you have erred in interpreting a part of it. Thereupon he said: Allah's Messenger, by Allah, tell me that part where I have committed an error. Thereupon he said: Don't take oath.

Book 29, Number 5644:

    Ibn 'Abbas reported that there came to Allah's Apostle (may peace be upon him) a person as he was returning from Uhud and lie 'said: Allah's Messenger, I saw in sleep during the night a canopy trickling butter and honey; the rest of the hadith is the same.

Book 29, Number 5645:

    It is reported either on the authority of Ibn 'Abbas or on that of Abu Huraira that a person came to Allah's Messenger (may peace be upon him) and said: Verily I saw during the night a canopy ; the rest of the hadith is the same.

Book 29, Number 5646:

    Ibn 'Abbas reported that Allah's Messenger (may peace be upon him) used to say to his Companions: He who amongst you sees a vision should narrate it and I would interpret it for him, and a person came and said: Allah's Messenger, I saw a canopy. The rest of the hadith is the same.

Chapter 5 : THE VISION OF THE HOLY PROPHET (MAY PEACE BE UPON HIM)

Book 29, Number 5647:

    Anas b. Malik reported Allah's Messenger (may peace be upon him) as saying: I saw during the night that which a person sees during the sleep as if we are in the house of 'Uqba b. Rafi' that there was brought to us the fresh dates of Ibn Tab. I interpreted it as the sublimity for us in the world and good ending in the Hereafter and that our religion is good.

Book 29, Number 5648:

    Abdullah b. 'Umar reported Allah's Messenger (may peace be upon him) as saying: I saw in a dream that I was using miswak and the two persons contended to get it from me, the one being older than the other one. I gave the miswak to the younger one. It was said to me to give that to the older one and I gave it to the older one.

Book 29, Number 5649:

    Abu Musa reported Allah's Messenger (may peace be upon him) as saying: I saw in sleep that I was about to migrate from Mecca to a land abounding in palmtrees and I guessed that it would be Yamama or Hajar, but it was the city of Yathrib (the old name of Medina), and I saw in this dream of mine that I was brandishing a sword and its upper end was broken and this is what fell (in the form of misfortune to the believers on the Day of Ubud). I brandished (the sword) for the second time and it became all right and this is what came to be true when Allah granted us victory and solidarity of the believers. And I saw therein cows also and Allah is the Doer of good. These meant the group from amongst the believers on the Day of Ubud and the goodness which Allah brought after that and the reward of attestation of his Truth which Allah brought to us after the Day of Badr.

Book 29, Number 5650:

    Ibn Abbas reported that Musailima al-Kadhdhab (the greater liar) (who claimed prophethood after the death of the Holy Prophet) came during the lifetime of Allah's Apostle (may peace be upon him) to Medina and said: If Muhammad assigns his caliphate to me after him I would follow, and there came along with him a large body of persons of his tribe and there came to him Allah's Apostle (may peace be upon him) along with Thabit b. Qais b. Shammas and the Prophet of Allah (may peace be upon him) had a piece of wood in his hand until he came in front of Musailima in the company of his companions and said: If you were to ask even this (wood), I would never give it to you. I am not going to do anything against the will of God in your case, and if you turn away (from what I say) Allah will destroy you. And I find you in the same state which I was shown (in the dream) and here is Thabit and he would answer you on my behalf. He (the Holy Prophet) then went back. Ibn 'Abbas said: I asked the (meanings of the) words of Allah's Apostle (may peace be upon him): "You are the same what I was made to see about you in my dream." and Abu Huraira reported that Allah's Messenger. (may peace be upon him) said: While I was sleeping I saw in my hands two gold bangles. This had a disturbing effect upon me and I was given a suggestion in the sleep that I should blow over them, so I blew over them and they were no more. And I interpreted these (two bangles) as the two great liars who would appear after me and the one amongst them was 'Anasi the inhabitant of San'a' and the other one Musailima the inhabitant of Yamama.

Book 29, Number 5651:

    Abu Huraira reported Allah's Messenger (may peace be upon him) as saying: While I was sleeping, the treasures of the earth were presented to me and I was made to wear in my hands two gold bangles. I felt a sort of burden upon me and I was disturbed and it was suggested to me that I should blow over them, so I blew and both of them disappeared. I interpreted them as two great liars who would appear at any time, one is the inhabitant of Sana' and the other is that of Yamama.

Book 29, Number 5652:

    Samura b. Jundab reported that when Allah's Messenger (may peace be upon him) had performed his dawn prayer he turned his face towards them (that is towards his Companions) and said: Did any one of you see any vision last night?


Book 30 : The Book pertaining to excellent qualities of the Holy Prophet (May Peace Be Upon Him) (KITAB AL-FADA'IL)

KITAB AL-FADA'IL
(THE BOOK PERTAINING TO THE EXCELLENT QUALITIES OF THE HOLY PROPHET (MAY PEACE BE UPON HIM) AND HIS COMPANIONS )

Back
Chapter 1 : INTERCESSION BY THE APOSTLE OF ALLAH (MAY PEACE BE UPON HIM) AND THE PAYING OF SALUTATIONS BY A STONE TO HIM BEFORE HIS ADVENT AS A PROPHET

Book 30, Number 5653:

    Wathila b. al-Asqa' reported: I heard Allah's Messenger (may peace be upon him) as saying: Verily Allah granted eminence to Kinana from amongst the descendants of Isma'il and he granted eminence to the Quraish amongst Kinana and he granted eminence to the Quraish amongst Banu Hashim and he granted me eminencece from the tribe of Banu Hashim.

Book 30, Number 5654:

    Jabir b. Samura reported Allah's Messenger (may peace be upon him) as saying : I recognise the stone in Mecca which used to pay me salutations before my advent as a Prophet and I recognise that even now.

Chapter 2 : THE EMINENCE OF OUR PROPHET (MAY PEACE BE UPON HIM) OVER THE WHOLE CREATION

Book , Number 5655:

    Abu Huraira reported Allah's Messenger (may peace be upon him) as saying: I shall be pre-eminent amongst the descendants of Adam on the Day of Resurrection and I will be the first intercessor and the first whose intercession will be accepted (by Allah).

Chapter 3 : THE MIRACLES OF THE HOLY PROPHET (MAY PEACE BE UPON HIM)

Book 30, Number 5656:

    Anas reported that Allah's Apostle (may peace be upon him) called for water and he was given a vessel and the people began to perform ablution in that and I counted (the persons) and they were between fifty and eighty and I saw water which was spouting from his fingers.

Book 30, Number 5657:

    Anas b. Malik reported : I saw Allah's Messenger (may peace be upon him) during the time of the afternoon prayer and the people asking for water for performing ablution which they did not find. (A small quantity) of water was brought to Allah's Messenger (may peace be upon him) and he placed his hand in that vessel and commanded people to perform ablution. I raw water spouting from his fingers and the people performing ablution until the last amongst them performed it.

Book 30, Number 5658:

    Anas b. Malik reported that Allah's Apostle (may peace be upon him) and his Companions were at a place known as az-Zaura' (az-Zaurd' is a place in the bazar of Medina near the mosque) that he called for a vessel containing water. He put his hand in that. And there began to spout (water) between his fingers and all the Companions performed ablution. Qatada, one of the narrators in the chain of narrators, said: Abu Hamza (the kunya of Hadrat Anas b. Malik), how many people were they? He said: They were about three hundred.

Book 30, Number 5659:

    Anas reported Allah's Apostle (may peace be upon him) was at az-Zaura' and a vessel containing water was brought to him in which his finger could not be completely dipped or completely covered; the rest of the hadith is the same.

Book 30, Number 5660:

    Jabir reported that Umm Malik used to send clarified butter in a small skin to the Apostle of Allah (may peace be upon him). Her sons would come to her and ask for seasoning when they had nothing with them (in the form of condiments) and she would go to that (skin) in which she offered (clarified butter) to Allah's Apostle (may peace be upon him), and she would find in that clarified butter and it kept providing her with seasoning for her household until she had (completely) squeezed it. She came to Allah's Apostle (may peace be upon him) and (informed him about it). Thereupon, he (the Holy Prophet) said: Did you squeeze it? She said: Yes. Thereupon he said: If you had left it in that very state, it would have kept on providing you (the clarified butter) on end.

Book 30, Number 5661:

    Jabir reported that a person came to Allah's Apostle (may peace be upon him) and asked for food. And he gave him half a wasq of barley, and the person and his wife and their guests kept on making use of it (as a food) until he weighed it (in order to find out the actual quantity, and it was no more). He came to Allah's Apostle (may peace be upon him) (and informed him about it). He said: Had you not weighed it, you would be eating out of it and it would have remained intact for you.

Book 30, Number 5662:

    Mu'adh b. Jabal reported that he went along with Allah's Apostle (may peace be upon him) in the expedition of Tabuk and he (the Holy Prophet) combined the prayers. He offered the noon and afternoon prayers together and the sunset and night prayers together and on the other day he deferred the prayers; he then came out and offered the noon and afternoon prayers together. He then went in and (later on) came out and then after that offered the sunset and night prayers together and then said: God willing, you would reach by tomorrow the fountain of Tabuk and you should not come to that until it is dawn, and he who amongst you happens to go there should not touch its water until I come. We came to that and two persons (amongst) us reached that fountain ahead of us. It was a thin flow of water like the shoelace. Allah's Messenger (may peace be upon him) asked them whether they had touched the water. They said: Yes. Allah's Apostle (may peace be upon him) scolded them, and he said to them what he had to say by the will of God. The people then took water of the fountain in their palms until it became somewhat significant and Allah's Messenger (may peace be upon him) washed his hands and his face too in it, and then, took it again in that (fountain) and there gushed forth abundant water from that fountain, until all the people drank to their fill. He then said: Mu'adh, it is hoped that if you live long you would see its water irrigating well the gardens.

Book 30, Number 5663:

    Abu Humaid as-Sa'idi reported: We went out with Allah's Messenger (may peace be upon him) on the expedition to Tabuk and we came to a wadi where there was a garden belonging to a woman. Allah's Apostle (may peace be upon him) said. Make an assessment (of the price of its fruit). And Allah's Messenger (may peace be upon him) also made an assessment and it was ten wasqs. He asked that lady (to calculate the amount) until they would, God willing, come back to her. So we proceeded on until we came to Tabuk and Allah's Messenger (may peace be upon him) said: The violent storm will overtake you during the night, so none amongst you should stand up and he who has a camel with him should hobble it firmly. A violent storm blew and a person who had stood up was carried away by the storm and thrown between the mountains of Tayy. Then the messenger of the son of al 'Alma', the ruler of Aila, came to Allah's Messenger (may peace be upon him) with a letter and a gift of a white mule. Allah's Messenger (may peace be upon him) wrote him (the reply) and presented him a cloak. We came back until we halted in the Wadi al-Qura. Allah's Messenger (may peace be upon him) asked that lady about her garden and the price of the fruits in that. She said: Ten wasqs. Thereupon Allah's Messenger (may peace be upon him) said: I am going to depart, and he who amongst you wishes may depart with me but he who wants to stay may stay. We resumed the journey until we came to the outskirts of Medina. (It was at this time) that Allah's Messenger (may peace be upon him) said: This is Taba, this is Uhud, that is a mountain which loves us and we love it, and then said: The best amongst the houses of the Ansar is the house of Bani Najjar. Then the house of Bani Abd al-Ashhal, then the house of Bani Abd al-Harith b. Khazraj, then the house of Bani Sa'ida, and there is goodness in all the houses of the Ansar. Said b. Ubada came to us and Abu Usaid said to him: Did you not see that Allah's Messenger (may peace be upon him) has declared the houses of the Ansar good and he has kept us at the end. Said met Allah's Messenger (may peace be upon him) and said: Allah's Messenger, you have declared the house of the Ansar as good and have kept us at the end, whereupon he said: Is it not enough for you that you have been counted amongst the good.

Book 30, Number 5664:

    This hadith has been narrated on the authority of 'Amr b. Yahya with the same chain of transmitters up to the words: There is good in all the houses of the Ansar, and there is no mention of the subsequent event pertaining to Sa'd b. 'Ubada.

Chapter 4 : THE RELIANCE OF ALLAH'S MESSENGER (MAY PEACE BE UPON HIM) ON ALLAH THE EXALTED, AND ALLAH'S PROTECTING HIM AGAINST THE PEOPLE

Book 30, Number 5665:

    Jabir b. Abdullah reported: We went along with Allah's Messenger (may peace be upon him) on an expedition towards Najd and Allah's Messenger (may peace be upon him) found us in a valley abounding in thorny trees. Allah's Messenger (may peace be upon him) stayed for rest under a tree and he suspended his sword by one of its branches under which he was taking rest. The persons scattered in the valley and they also began to take rest under the shade of trees, and Allah's Messenger (may peace be upon him) said: A person came to me while I was asleep and he took hold of the sword. I woke up and found him standing upon my head and I had hardly become alert (and saw) that the sword was in his hand. And he said: Who can protect you from me? I said: Allah. He again said: Who can protect you from me? I said: Allah. He put his sword in the sheath (and you can see) this man sitting here. Allah's Messenger (may peace be upon him) did not in any way touch him.

Book 30, Number 5666:

    Jabir b.'Abdullah al-Ansiri, who was one amongst the Companions of Allah's Apostle (may peace be upon him), reported that he went on an expedition along with Allah's Messenger (may peace be upon him) towards Najd and Allah's Messenger (may peace be upon him) stayed there, and when Allah's Messenger (may peace be upon him) came back he also came back along with him. They, for one day, stayed for rest; the rest of the hadith is the same.

Book 30, Number 5667:

    Jabir b. 'Abdullah reported: We went along with Allah's Messenger (may peace be upon him) and as we reached the place Dhat-ur-Riqa'; the rest of the hadith is the same, but there is no mention of the word that Allah's Messenger (may peace be upon him) did not harm him.

Chapter 5 : PERTAINING TO THE SIMILITUDE WITH WHICH ALLAH'S APOSTLE (MAY PEACE BE UPON HIM) HAS BEEN SENT WITH GUIDANCE AND KNOWLEDGE

Book 30, Number 5668:

    Abu Musa reported Allah's Apostle (may peace be upon him) as saying: The similitude of that guidance and knowledge with which Allah, the Exalted and Glorious, has sent me is that of rain falling upon the earth. There is a good piece of land which receives the rainfall (eagerly) and as a result of it there is grown in it herbage and grass abundantly. Then there is a land hard and barren which retains water and the people derive benefit from it and they drink it and make the animals drink. Then there is another land which is barren. Neither water is retained in it, nor is the grass grown in it. And that is the similitude of the first one who develops the understanding of the religion of Allah and it becomes a source of benefit to him with which Allah sent me. (The second one is that) who acquires the knowledge of religion and imparts it to others. (Then the other type is) one who does not pay attention to (the revealed knowledge) and thus does not accept guidance of Allah with which I have been sent.

Chapter 6 : THE EXTREME LOVE OF ALLAH'S MESSENGER (MAY PEACE BE UPON HIM) FOR HIS UMMA, AND HIS EXTREME ANXIETY TO WARN THEM AGAINST THAT WHICH IS A SOURCE OF TROUBLE TO THEM

Book 30, Number 5669:

    Abu Musa reported Allah's Messenger (may peace be upon him) as saying: The similitude of mine and of that with which Allah sent me is that of a person who came to us and said: O people, I have seen an army with my eyes and I am a plain warner (and issue you warning) that you should immediately manage to find an escape. A group of people from amongst them paying heed (to his warning) fled to a place of protection and a group amongst them belied him and the morning overtook them in their houses and the army attacked them and killed them and they were routed. And that is the similitude of the one who obeyed me, followed with which I had been sent and the similitude of the other is of one who disobeyed and belied me and the Truth with which I have been sent.

Book 30, Number 5670:

    Abu Huraira reported Allah's Messenger (may peace be upon him) as saying: The similitude of mine and that of my Umma is that of a person who lit fire and there began to fall into it insects and moths. And I am there to hold you back, but you plunge into it.

Book 30, Number 5671:

    Hammam b. Munabbih reported: Abu Huraira reported us some ahadith from Allah's Messenger (may peace be upon him) amongst many, (and) one is this that Allah's Messenger (may peace be upon him) said: A person lit fire and when the atmosphere was aglow, moths and insects began to fall into the fire, but I am there to hold them back, but they are plunging into it despite my efforts, and he further added: That is your example and mine. I am there to hold you back from fire and to save you from it, but you are plunging into it despite my efforts.

Book 30, Number 5672:

    Jabir b. Abdullah reported Allah's Messenger (may peace be upon him) as saying. My example and your example is that of a person who lit the fire and insects and moths began to fall in it and he would be making efforts to take them out, and I am going to hold you back from fire, but you are slipping from my hand.

Chapter 7 : THE FINALITY OF ALLAH'S APOSTLE (MAY PEACE BE UPON HIM)

Book 30, Number 5673:

    Abu Huraira reported Allah's Messenger (may peace be upon him) as saying: The similitude of mine and that of the Apostles (before me) is that of a person who constructed a building and he built it fine and well and the people went round it saying: Never have we seen a building more imposing than this. but for one brick, and I am that brick (with which you give the finishing touch to the building).

Book 30, Number 5674:

    Abu Huraira reported Allah's Messenger (may peace be upon him) as saying: The similitude of mine and that of the Apostles before me is that of a person who built a house quite imposing and beautiful and he made it complete but for one brick in one of its corners. People began to walk round it, and the building pleased them and they would say: But for this brick your building would have been perfect. Muhammad (may peace be upon him) said: And I am that final brick.

Book 30, Number 5675:

    Abu Hurairh reported Allah's Messenger (may peace be upon him) as saying: The similitude of mine and that of the Apostles before me is that of a person who built a house quite imposing and beautiful, but for one brick in one of its corners. People would go round it, appreciating the building, but saying: Why has the brick not been fixed here? He said: I am that brick and I am the last of the Apostles.

Book 30, Number 5676:

    Abu Sa'id reported Allah's Messenger (may peace be upon him) as saying: The similitude of mine and that of the Apostles; the rest of the hadith is the same.

Book 30, Number 5677:

    Jabir reported Allah's Messenger (may peace be upon him) as saying: The similitude of mine and that of the Apostles is like that of a person who built a house and he completed it and made it perfect but for the space of a brick. People entered therein and they were surprised at it and said: Had there been a brick (it would have been complete in all respects). Allah's Messenger (may peace be upon him) said: I am that place where the brick (completing the building is to be placed), and I have come to finalise the chain of Apostles.

Book 30, Number 5678:

    This hadith has been narrated through another chain of transmitters but with a slight variation of wording.

Chapter 8 : WHEN ALLAH THE EXALTED INTENDS TO SHOW MERCY TO AN UMMA HIS PROPHET IS CALLED BACK TO HIS ETERNAL HOME WHEN THE UMMA IS SAFE FROM THE WRATH OF GOD

Book 30, Number 5679:

    Abu Musa reported Allah's Messenger (may peace be upon him) as saying: When Allah, the Exalted and Glorious, intends to show mercy to an Umma from amongst His servants He calls back His Apostle to his eternal home and makes him a harbinger and recompense in the world to come; and when He intends to cause destruction to an Umma, He punishes it while its Apostle is alive and He destroys it as he (the Apostle) witnesses it and he cools his eyes by destruction as they had belied him and disobeyed his command.

Chapter 9 : THE CISTERN OF OUR APOSTLE (MAY PEACE BE UPON HIM) AND ITS CHARACTERISTICS

Book 30, Number 5680:

    Jundab reported: I heard Allah's Messenger (may peace be upon him) as saying: I shall be there at the Cistern before you.

Book 30, Number 5681:

    This hadith has been narrated on the authority of Jundab through another chain of transmitters.

Book 30, Number 5682:

    Sahl (b. Sa'd) reported: I heard Allah's Apostle (may peace be upon him) as saying : I shall go to the Cistern before you and he who comes would drink and he who drinks would never feel thirsty, and there would come to me people whom I would know and who would know me. Then there would be intervention between me and them. Abu Hazim said that Nu'man b. Abu 'Ayyash heard it and I narrated to them this hadith, and said: Is it this that you heard Sahl saying? He said: Yes, and I bear witness to the fact that I heard it from Abu Sa'id Khudri also, but he made this addition that he (the Holy Prophet) would say: They are my followers, and it would be said to him: You do not know what they did after you and I will say to them: Woe to him who changes (his religion) after me.

Book 30, Number 5683:

    This hadith has been narrated on the authority of Abu Sa'id Khudri through another chain of transmitters.

Book 30, Number 5684:

    Abdullah b. 'Amr al-'As, reported Allah's Messenger (may peace be upon him) as saying: My Cistern (is as wide and broad that it requires) a motith's journey (to go round it) all, and its sides are equal and its water is whiter than silver, and its odour is more fragrant than the fragrance of musk, and its jugs (placed round it) are like stars in the sky; and he who would drink from it would never feel thirsty after that. Asma', daughter of Abu Bakr said: Allah's Messenger (may peace be upon him) said: I would be on the Cistern and so that I would be seeing those who would be coming to me from you, but some people would be detained (before reaching me). I would say: My Lord, they are my followers and belong to my Umma, and it would be said to me: Do you know what they did after you? By Allah, they did not do good after you, and they turned back upon their heels. He (the narrator) said: Ibn Abu Mulaika used to say (in supplication): O Allah, I seek refuge with Thee that we should turn back upon our heels or put to any trial about our religion.

Book 30, Number 5685:

    'A'isha reported : I heard Allah's Messenger (may peace be upon him) say in the company of his Companions: I would be on the Cistern waiting for those who would be coming to me from amongst you. By Allah, some persons would be prevented from coming to me, and I would say: My Lord, they are my followers and people of my Umma. And He would say,: You don't know what they did after you; they had been constantly turning back on their heels (from their religion).

Book 30, Number 5686:

    Umm Salama, the wife of Allah's Apostle (may peace be upon him), said I used to hear from people making a mention of the Cistern, but I did not hear about it from Allah's Messenger (may peace be upon him). One day while a girl was combing me I heard Allah's Messenger (may peace be upon him) say: "O people." I said to that girl: Keep away from me. She said : He (the Holy Prophet) has addressed the men only and he has not invited the attention of the women. I said: I am amongst the people also (and have thus every right to listen to the things pertaining to religion). Allah's Messenger (may peace be upon him) said : I shall be your harbinger on the Cistern; therefore, be cautious lest one of you should come (to me) and may be driven away like a stray camel. I would ask the reasons, and it would be said to me: You don't know what innovations they made after you. And I would then also say: Be away.

Book 30, Number 5687:

    Umm Salama reported that she heard Allah's Apostle (may peace be upon him) saying this as he was sitting on the pulpit and she was getting her hair combed. (He uttered these words) : "O people." And she said to one who was combing: Leave my head; the rest of the hadith is the same.

Book 30, Number 5688:

    Uqba b. 'Amir reported that Allah's Messenger (may peace be upon him) one day went out and he offered prayer over the martyrs of Uhud just as prayer is offered over the dead. He then came back and sat on pulpit and said: I shall be present there (at the Cistern) before you. I shall be your witness and, by Allah, I perceive as if I am seeing with my own eyes my Cistern at this very state and I have been given the keys of the treasures of the earth or the keys of the earth and, by Allah, I am not afraid concerning you that you would associate anything (with Allah after me), but I am afraid that you would be vying with one another (for the possession of) the treasures of the earth.

Book 30, Number 5689:

    Uqba b. 'Amir reported Allah's Messenger (may peace be upon him) as saying: Allah's Messenger offered prayer over those who had fallen matyrs at Uhud. He then climbed the pulpit as if someone is saying good-bye to the living and the dead, and then said: I shall be there as your predecesor on the Cistern before you, and it is as wide as the distance between Aila and Juhfa (Aila is at the top of the gulf of 'Aqaba). I am not afraid that you would associate anything with Allah after me, but I am afraid that you may be (allured) by the world and (vie) with one another (in possessing material wealth) and begin killing one another, and you would be destroyed as were destroyed those who had gone before you. 'Uqba said that that was the last occasion that he saw Allah's Massenger on the pulpit.

Book 30, Number 5690:

    'Abdullah reported Allah's Messenger (may peace be upon him) as saying; I shall be there at the Cistern before you, and I shall have to contend for some people, but I shall have to yield. I would be saying: My Lord, they are my friends, they are my friends, and it would be said: You don't know what innovations they made after you.

Book 30, Number 5691:

    The hadith has been narrated on the authority ot al-A'mash with the same chain of transmitters but no mention is made of: "They are my companions; they are my companions."

Book 30, Number 5692:

    This hadith has been narrated on the authority of 'Abdullah through another chain of transmitters.

Book 30, Number 5693:

    This hadith has been narrated on the authority of Hudhaifa through another chain of transmitters.

Book 30, Number 5694:

    Haritha reported that he heard Allah's Messenger (may peace be upon him) as saying: His Cistern would be as extensive as the distance between San'a' and Medina. Mustaurid (one of the narrators) said: Did you not hear anything about the utensils? Thereupon he said. No. Mustaurid said: You would find that the utensils would be like stars.

Book 30, Number 5695:

    Haritha b. Wahb al-Khuza'i reported Allah's Messeiiger's (may peace be upon him) words concerning the Cistern like it, but he made no mention of the words of Mustaurid.

Book 30, Number 5696:

    Ibn 'Umar reported Allah's Messenger (may peace be upon him) as saying: There is before you a Cistern and the distance between its two sides is as it is between Jarba' and Adhruh.

Book 30, Number 5697:

    This hadith has been transmitted on the authority of Ibn 'Umar and the words are: That he said there would be before you a Cistern extending from jarba' and Adhruh and the same has been transmitted on the authority of Ibn Muthanna and the wording is: "My Cistern."

Book 30, Number 5698:

    A hadith like this has been transmitted on the authority, of 'Ubaidullah with this addition: Ubaidullah was asked (about these two names, i.e. Jarba' and Adhruh). He said: These are the two towns of Syria and there is between them the distance which can be covered in three nights, and the hadith transmitted on the authority of Ibn Bishr (the words are). "Three days."

Book 30, Number 5699:

    A hadith like this has been narrated on the authority of Ibn Umar through another chain of transmitters.

Book 30, Number 5700:

    'Abdullah reported Allah's Messenger (may peace be upon him) as saying: There would be before you a Cistern (as extensive) as there is the distance between Jarba' and Adhruh and there would be jugs like stars in the sky; he who would come to that and drink from it would never feel thirsty after that.

Book 30, Number 5701:

    Abu Dharr said: Allah's Messenger, what about the vessels of that Cistern? He said: By Him in Whose Hand is the life of Muhammad, the vessels would outnumber the stars in the sky and its planets shining on a dark cloudless night. These would be the vessels of Paradise. He who drinks out of it (the Cistern) would never feel thirsty. There would flow in it two spouts from Paradise and he who would drink out of it would not feel thirsty; and the distance between its (two corners) is that between 'Amman and Aila, and its water is whiter than milk and sweeter than honey.

Book 30, Number 5702:

    Thauban reported Allah's Apostle (may peace be upon him) as saying: I would be pushing back from my Cistern the crowd of people. I would strike away from it (the Cistern) with my staff the people of Yemen until the water (of the Haud) would spout forth upon them. He was asked about its breadth. He said: From this place of mine to 'Amman, and he was asked about the drink and he said: It is whiter than milk and sweeter than honey. There would spout into it two streamlets having their sources in Paradise. the one is from gold and the other is from silver. This hadith has been narrated on the authority of Hisham with the same chain of transmitters and the words are: "I would be on the Day of Resurrection near the bank of the Cistern."

Book 30, Number 5703:

    Thaubin reported this hadith pertaining to the Cistern. Muhammad b. Bashshar said: I said to Yahya b. Hammad: This is the hadith that I heard from Abu 'Awana and he said: I also heard it from Shu'ba. I said: Narrate that to me and he narrated that to me.

Book 30, Number 5704:

    Abu Huraira reported Allah's Apostle (may peace be upon him) as saying: I will drive away from my Cistern people just as the stray camels are driven away. This hadith has been narrated on the authority of Abu Huraira through another chain ot transmitters.

Book 30, Number 5705:

    Anas b. Malik reported Allah's Messenger (may peace be upon him) as saying: My Cistern would be as extensive as the distance between Aila and San'a, of Yemen, and there would be in it jugs like stars in the sky.

Book 30, Number 5706:

    Anas b. Malik reported Allah's Apostle (may peace be upon him) as saying: Some persons from amongst my associates would turn to my Cistern; when I would see them and they would be presented to me, they would be detained in the way while coming to me. I would say: My Lord, they are my companions, they are my companions, and it would be said to me: You don't know what innovations they made after you.

Book 30, Number 5707:

    Anas reported a hadith like this from Allah's Apostle (may peace be upon him) and he made this addition: "The vessels would be as numerous as the number of stars.

Book 30, Number 5708:

    Anas b. Milik reported Allah's Messenger (may peace be upon him) as saying: There would be such a vast distance between the sides of my Cistern as it is between Sana' and Medina.

Book 30, Number 5709:

    Anas reported this hadith with this change that there was some doubt between (places mentioned) and there is a slight variation of wording.

Book 30, Number 5710:

    Anas reported Allah's Apostle (may peace be upon him) as saying: You would be shown in it jugs of gold and silver (as numerous) as the number of stars in the sky. This hadith has been transmitted on the authority of Anas b. Malik with this addition: "More numerous than stars in the sky."

Book 30, Number 5711:

    Jabir b. Samura reported Allah's Messenger (may peace be upon him) as saying: Behold, I shall be present ahead of you on the Cistern, and the distance between its different sides would be like that between Sana' and Aila, and its jugs would be like stars in the sky.

Book 30, Number 5712:

    'Amir b. Sa'd b. Abu Waqqas reported: I wrote (a letter) to Jabir b. Samura (and it was sent) through my servant Nafi' asking him to inform me about something (pertaining to the Haud Kauthar). He wrote to me: I heard him (the Holy Prophet) say: I shall be there ahead of you at the Haud Kauthar.

Chapter 10 : THE ANGELS FOUGHT ALONG WITH ALLAH'S APOSTLE (MAY PEACE BE UPON HIM) IN THE BATTLE OF UHUD

Book 30, Number 5713:

    Sa'd reported that on the Day of Ubud I saw on the right side of Allah's Messenger (may peace be upon him) and on his left side two persons dressed in white clothes and whom I did not see before nor after that, and they were Gabriel and Michael (Allah be pleased with both of them).

Book 30, Number 5714:

    Sa'd b. Abu Waqqas reported: I saw on the right side of Allah's Messenger (may peace be upon him) and on his left side two persons with white clothes on the Day of Uhtid fighting a desperate fight, and I saw them neither before nor after that.

Chapter 11 : THE VALOUR AND COURAGE OF ALLAH'S APOSTLE (MAY PEACE BE UPON HIM)

Book 30, Number 5715:

    Anas b. Malik reported that Allah's Messenger (may peace be upon him) was the sublimest among people (in character) and the most generous amongst them and he was the bravest of men. One night the people of Medina felt disturbed and set forth in the direction of a sound when Allah's Messenger (may peace be upon him) met them on his way back as he had gone towards that sound ahead of them. He was on the horse of Abu Talha which had no saddle over it, and a sword was slung round his neck, and he was saying: There was nothing to be afraid of, and he also said: We found it (this horse) like a torrent of water (indicating its swift-footedness), whereas the horse had been slow before that time.

Book 30, Number 5716:

    Anas reported that there was consternation in Medina. The Messenger of Allah (may peace be upon him) borrowed the horse from Abu Talha which was called Mandub. He rode it and said: We have found no reason for consternation, and we have found it to be (as quick as a torrent) of water.

Book 30, Number 5717:

    This hadith has been transmitted on the authority of Anas with a slight variation of wording.

Chapter 12 : ALLAH'S APOSTLE (MAY PEACE BE UPON HIM) WAS THE MOST GENEROUS OF PEOPLE; HIS GENEROSITY WAS LIKE THE BLOWING OF WIND

Book 30, Number 5718:

    Ibn 'Abbas reported that Allah's Messenger (may peace be upon him) was the most generous of people in charity, but he was generous to the utmost in the month of Ramadan. Gabriel (peace be upon him) would meet him every year during the month of Ramadin until it ended, and Allah's Messenger (may peace be upon him) recited to him the Qur'an; and when Gabriel met him Allah's Messenger (may peace be upon him) was most generous in giving charity like the blowing wind.

Book 30, Number 5719:

    This hadith has been narrated on the authority of Zuhri with the same chain of transmitters.

Chapter 13 : THE MESSENGER OF ALLAH (MAY PEACE BE UPON HIM) IS THE BEST AMONGST PEOPLE IN DISPOSITION AND BEHAVIOUR

Book 30, Number 5720:

    Anas b. Malik reported: I served the Messenger of Allah (may peace be upon him) for ten years, and, by Allah, he never said to me any harsh word, and he never said to me about a thing as to why I had done that and as to why I had not done that. Abu Rabi' has made this addition (in this narration): "The work which a servant should do." There is no mention of his words "By Allah".

Book 30, Number 5721:

    This hadith has been narrated on the authority of Anas through another chain of transmitters.

Book 30, Number 5722:

    Anas reported: When Allah's Messenger (may peace be upon him) came to Medina, Abla Talha took hold of my hand and brought me to Allah's Messenger (may peace be upon him) and said: Allah's Messenger, Anas is a prudent young boy, and he will serve you. He (Anas) said: I served him in journey and at home, but, by Allah, he never asked me about a thing which I did as to why I did so, nor about a thing which I did not do as to why I had not done that.

Book 30, Number 5723:

    Anas reported Allah's Messenger (may peace be upon him) as saying: I served the Messenger of Allah (may peace be upon him) for nine years, and I do not know (of any instance) when he said to me: Why you have done this and that, and he never found fault with me in anything.

Book 30, Number 5724:

    Anas reported that Allah's Messenger (may peace be upon him) had the best disposition amongst people. He sent me on an errand one day, and I said: By Allah, I would not go. I had, however, this idea in my mind that I would do as Allah's Apostle (may peace be upon him) had commanded me to do. I went out until I happened to come across children who had been playing in the street. In the meanwhile, Allah's Messenger (may peace be upon him) came there and he caught me by the back of my neck from behind me. As I looked towards him I found him smiling and he said: Unais, did you go where I commanded you to go? I said: Allah's Messenger, yes, I am going. Anas further said: I served him for nine years but I know not that he ever said to me about a thing which I had done why I did that, or about a thing I had left as to why I had not done that.

Book 30, Number 5725:

    Anas b. Malik reported that Allah's Messenger (may peace be upon him) was the best amongst people in disposition and behaviour.

Chapter 14 : IT IS VERY SELDOM THAT ALLAH'S APOSTLE (MAY PEACE BE UPON HIM) SAID "NO" TO ANYONE WHEN ASKED TO GIVE ANYTHING, AND HE GAVE CHARITY TO THE PEOPLE VERY FREELY

Book 30, Number 5726:

    Jabir b. 'Abdullah reported: It never happened that Allah's Messenger (may peace be upon him) was asked for anything and he said: No.

Book 30, Number 5727:

    This hadith has been narrated on the authority of Jabir b. 'Abdullah through another chain of transmitters.

Book 30, Number 5728:

    Musa b. Anas reported on the authority of his father: It never happened that Allah's Messenger (may peace be upon him) was asked anything for the sake of Islam and he did not give that. There came to him a person and he gave him a large flock (of sheep and goats) and he went back to his people and said: My people, embrace Islam, for Muhammad gives so much charity as if he has no fear of want.

Book 30, Number 5729:

    Anas 'b. Malik reported that a person requested Allah's Apostle (may peace be upon him) to give him a very large flock and he gave that to him. He came to his tribe and said: O people, embrace Islam. By Allah, Muhammad donates so much as if he did not fear want. Anas said that the person embraced Islam for the sake of the world but later he became Muslim until Islam became dearer to him than the world and what it contains.

Book 30, Number 5730:

    Ibn Shihab reported that Allah's Messenger (may peace be upon him) went on the expedition of Victory, i.e. the Victory of Mecca, and then he went out along with the Muslims and they fought at Hunain, and Allah granted victory to his religion and to the Muslims, and Allah's Messenger (may peace be upon him) gave one hundred camels to Safwan b. Umayya. He again gave him one hundred camels, and then again gave him one hundred camels. Sa'id b. Musayyib said that Safwan told him: (By Allah) Allah's Messenger (may peace be upon him) gave me what he gave me (and my state of mind at that time was) that he was the most detested person amongst people in my eyes. But he continued giving to me until now he is the dearest of people to me.

Book 30, Number 5731:

    Jabir b. 'Abdullah reported Allah's Messenger (may peace be upon him) as saying: In case we get wealth from Bahrain, I would give you so much and so much; he made an indication of it with both his hands. Allah's Apostle (may peace be upon him) died before wealth from Bahrain came, and it fell to the lot of Abu Bakr after him. He commanded the announcer to make announcement to the effect that he to whom Allah's Apostle (may peace be upon him) had held out promise or owed any debt should come (to him). I came and said: Allah's Apostle (may peace be upon him) had said to me: In case there comes to us the wealth of Bahrain I shall give you so much, and so much. Abu Bakr took a handful (of the coins) and gave that to me once and asked me to count them I counted them as five hundred dinars and he said: Here is double of this for you.

Book 30, Number 5732:

    Jabir b. 'Abdullah reported: When Allah's Apostle (may peace be upon him) died, there came to Abfi Bakr wealth from al-'Ala' b. al-Hadrami. Abu Bakr said: He to whom Allah's Apostle (may peace be upon him) owed any debt or held out any promise should come to us; the rest of the hadith is the same.

Chapter 15 : THE MERCY AND TENDERNESS SHOWN BY ALLAH'S APOSTLE (MAY PEACE BE UPON HIM) TOWARDS CHILDREN, MEMBERS OF HIS FAMILY, AND HIS HUMILITY AND HIS SUBLIME QUALITIES

Book 30, Number 5733:

    Anas b. Malik reported that Allah's Messenger (may peace be upon him) said: A child was born into me this night and I named him after the name of my father Ibrihim. He then sent him to Umm Saif, the wife of a blacksmith who was called Abu Saif. He (the Holy Prophet) went to him and I followed him until we reached Abu Saif and he was blowing fire with the help of blacksmith's bellows and the house was filled with smoke. I hastened my step and went ahead of Allah's Messenger (may peace be upon him) and said: Abu Saif, stop it, as there comes Allah's Messenger (may peace he upon him). He stopped and Allah's Apostle (may peace be upon him) called for the child. He embraced him and said what Allah had desired. Anas said: I saw that the boy breathed his last in the presence of Allah's Messenger (may peace be upon him). The eyes of Allah's Messenger (may peace be upon him) shed tears and he said: Ibrahim, our eyes shed tears and our hearts are filled with grief, but we do not say anything except that by which Allah is pleased. O Ibrahim, we are grieved for you.

Book 30, Number 5734:

    Anas b. Malik reported: I have never seen anyone more kind to one's family than Allah's Messenger (may peace be upon him), and Ibrahim was sent to the suburb of Medina for suckling. He used to go there and we accompanied him. He entered the house, and it was filled with smoke as his foster-father was a bricksmith. He took him (his son Ibrihim) and kissed him and then came back. 'Amr said that when Ibrihim died. Allah's LMessenger (may peace be upon him) said: Ibrihim is my son and he dies as a suckling babe. He has now two foster-mothers who would complete his suckling period in Paradise.

Book 30, Number 5735:

    'A'isha (Allah be pleased with her) reported that there came a few desert Arabs to Allah's Messenger (may peace be upon him) and said: Do you kiss your children? He said: Yes. Thereupon they said: By Allah but we do not kiss our children. Thereupon Allah's Messenger (may peace be upon him) said: Then what can I do if Allah has deprived you of mercy? Ibn Numair said: (We has deprived) your heart of mercy.

Book 30, Number 5736:

    Abu Huraira reported that al-Aqra' b. Habis saw Allah's Apostle (may peace be upon him) kissing Hasan. He said: I have ten children, but I have never kissed any one of them, whereupon Allah's Messenger (may peace be upon him) said: He who does not show mercy (towards his children), no mercy would be shown to him.

Book 30, Number 5737:

    This hadith has been narrated on the authority of Jabir b. 'Abdullah through different chains of transmitters and the words are: "That the Messenger of Allah (may peace be upon him) said: He who shows no mercy to the people, Allah, the Exalted and Glorious, does not show mercy to him."

Book 30, Number 5738:

    This hadith has been narrated on the authority of Jabir through another chain of transmitters.

Chapter 16 : THE UTMOST MODESTY OF ALLAH'S APOSTLE (MAY PEACE BE UPON HIM)

Book 30, Number 5739:

    Abu Sa'id Khudri reported that Allah's Messenger (may peace be upon him) was more modest than the virgin behind the curtain (or in the apartment), and when he disliked anything, we recognised that from his face.

Book 30, Number 5740:

    Masruq reported: We went to Abdullah b. 'Amr when Mu'dwiya came to Kufa, and he made a mention of Allah's Messenger (may peace be upon him) and said: He was never immoderate in his talk and he never reviled others. Allah's Messenger (may peace be upon him) also said: The best amongst you are those who are best in morals. Uthman said: When he came to Kufa along with Mu'awiya... (The rest of the hadith is the same).

Book 30, Number 5741:

    This hadith had been narrated on the authority of al-A'mash through another chain of transmitters also.

Chapter 17 : THE SMILING OF ALLAH'S APOSTLE (MAY PEACE BE UPON'HIM) AND HIS EXCELLENT BEHAVIOUR

Book 30, Number 5742:

    Simak b. Harb reported: I said to Jabir b. Samura: Did you have the privilege of sitting in the company of Allah's Messenger (may peace be upon him)? He said: Yes, very frequently, and added: He did not stand up (and go) from the place where he offered the dawn prayer until the sun rose, and after the rising of the sun he stood up, and they (his Companions) entered into conversation with one another and they talked of the things (that they did during the Days of Ignorance), and they laughed (on their unreasonable and ridiculous acts). Allah's Messenger (may peace be upon him) smiled only.

Chapter 18 : THE MERCY AND COMPASSION OF ALLAH'S APOSTLE (MAY PEACE BE UPON HIM) FOR WOMEN AND HIS COMMAND TO THE CAMEL-DRIVER TO DRIVE THE MOUNT SLOWLY ON WHICH THEY RIDE

Book 30, Number 5743:

    Anas reported that Allah's Messenger (may peace be upon him) had in one of his journeys his black slave who was called Anjasha along with him. He goaded by singing the songs of camel-driver. Thereupon Allah's Messenger (may peace be upon him) said: Anjasha, drive slowly as you are driving (the mounts who are carrying) glass vessels

Book 30, Number 5744:

    This hadith has been narrated on the authority of Anas through another chain of transmitters.

Book 30, Number 5745:

    Anas reported that Allah's Apostle (may peace be upon him) came to his wives as the camel-driver who was called Anjasha had been, driving (the camels) on which (they were riding). Thereupon he said: Anjasha, be careful, drive slowly for you are driving the mounts who carry vessels of glass. Abu Qilaba said that Allah's Messenger (may peace be upon him) uttered words which if someone had uttered amongst you, you would have found fault with him.

Book 30, Number 5746:

    Anas b. Malik reported that Umm Sulaim was with the wives of Allah's Apostle (may peace be upon him) and a camel-driver had been driving (the camels) oil which they were riding. Thereupon Allah's Apostle (may peace be upon him) said: Anjasha, drive slowly, for you are carrying (on the camels) vessels of glass.

Book 30, Number 5747:

    Anas reported that Allah's Messenger (may peace be upon him) had a camel-driver who had a very melodious voice. Allah's Messenger (may peace be upon him) said to him: Anjasha, drive slowly; do not break the vessels of glass, meaning the weak women.

Book 30, Number 5748:

    Anas reported this hadith through another chain of transmitters, but he made no mention of a camel-driver having a melodious voice.

Chapter 19 : THE NEARNESS OF ALLAH'S APOSTLE (MAY PEACE BE UPON HIM) TO THE PEOPLE AND THEIR SEEKING BLESSINGS FROM HIM (AND HIS POSSESSIONS)

Book 30, Number 5749:

    Anas b. Malik reported that when Allah's Messenger (may peace be upon him) had completed his dawn prayer, the servants of Medina came to him with utensils containing water, and no utensil was brought in which he did not dip his hand; and sometime they came in the cold dawn (and he did not feel reluctant in acceding to their request even in the cold weather) and dipped his hand in them.

Book 30, Number 5750:

    Anas reported: I saw when the Messenger of Allah (may peace be upon him) got his hair cut by the barber, his Companions came round him and they eagerly wanted that no hair should fall but in the hand of a person.

Book 30, Number 5751:

    Anas reported that a woman had a partial derangement in her mind, so she said. Allah's Messellaer, I want something from you. He said: Mother of so and so, see on which side of the road you would like (to stand and talk) so that I may do the needfull for you. He stood aside with her on the roadside until she got what she needed.

Chapter 20 : THE HATRED OF ALLAH'S APOSTLE (MAY PEACE BE UPON HIM) AGAINST SIN AND THE ADOPTING OF A COURSE OF ACTION WHICH IS EASIER TO ADOPT FROM AMONGST THE PERMISSIBLE ACTS

Book 30, Number 5752:

    'A'isha, the wife of Allah's Apostle (may peace be upon him), said that whenever he had to choose between two things he adopted the easier one, provided it was nor sin, but if it was any sin he was the one wio was the farthest from it of the people; and Allah's Messenger (may peace be upon him) never took revenge from anyone because of his personal grievance, unless what Allah, the Exalted and Glorious, had made inviolable had been violated.

Book 30, Number 5753:

    This hadith has been narrated on the authority of Ibn Shibab through another chain of transmitters.

Book 30, Number 5754:

    'A'isha reported: Never did Allah's Messenger (may peace be upon him) make a choice between two things but adopting the easier one as compared to the difficult one, but his choice for the easier one was only in case it did not involve any sin, but if it involved sin he was the one who was the farthest from it amongst the people.

Book 30, Number 5755:

    This hadith has been narrated on the authority of Hisham through another chain of transmitters but with a slight variation of wording.

Book 30, Number 5756:

    'A'isha reported that Allah's Messenger (may peace be upon him) never beat anyone with his hand, neither a woman nor a servant, but only, in the case when he had been fighting in the cause of Allah and he never took revenge for anything unless the things made inviolable by Allah were made violable; he then took revenge for Allah, the Exalted and Glorious.

Book 30, Number 5757:

    This hadith has been narrated on the authority of Hisham through another chain of transmitters but with a slight variation of wording.

Chapter 21 : THE FRAGRANCE OF THE SACRED BODY OF ALLAH'S APOSTLE (MAY PEACE BE UPON HIM) AND ITS AGILITY AND SOFTNESS AND THE BLESSINGS OF ITS TOUCH

Book 30, Number 5758:

    Jabir b. Samura reported: I prayed along with Allah's Messenger (may peace be upon him) the first prayer. He then went to his family and I also went along with him when he met some children (on the way). He began to pat the cheeks of each one of them. He also patted my cheek and I experienced a coolness or a fragrance of his hand as if it had been brought out from the scent bag of a perfumer.

Book 30, Number 5759:

    Anas reported: I never smelt ambergris or musk as fragrant as the fragrance of the body of Allah's Messenger (may peace be upon him) and I never touched brocade or silk and found it as soft as the body of Allah's Messenger (may peace be upon him).

Book 30, Number 5760:

    Anas reported that Allah's Messenger (may peace be upon him) had a very fair complexion and (the drops) of his perspiration shone like pearls, and when he walked he walked inclining forward, and I never touched brocade and silk (and found it) as soft as the softness of the palm of Allah's Messenger (may peace be upon him) and I never smelt musk or ambergris and found its fragrance as sweet as the fragrance of Allah's Messenger (may peace be upon him).

Book 30, Number 5761:

    Anas b. Malik reported that Allah's Apostle (may peace be upon him) used to come to our house and there was perspiration upon his body. My mother brought a bottle and began to pour the sweat in that. When Allah's Apostle (may peace be upon him) got up he said: Umm Sulaini, what is this that you are doing? Thereupon she said: That is your sweat which we mix in our perfume and it becomes the most fragrant perfume.

Book 30, Number 5762:

    Anas b. Malik reported that Allah's Apostle (may peace be upon him) came to the house of Umm Sulaim and slept in her bed while she was away from her house. On the other day too he slept in her bed. She came and it was said to her: It is Allah's Apostle (may peace be upon him) who is having siesta in your house, lying in your bed. She came and found him sweating and his sweat falling on the leather cloth spread on her bed. She opened her scent-bag and began to fill the bottles with it. Allah's Apostle (may peace be upon him) was startled and woke up and said: Umm Sulaim, what are you doing? She said: Allah's Messenger, we seek blessings for our children through it. Thereupon he said: You have done something right.

Book 30, Number 5763:

    Umm Sulaim reported that Allah's Apostle (may peace be upon him) visited her house and (took rest) and she spread a piece of cloth for him and he had had a siesta on it. And he sweated profusely and she collected his sweat and put it in a perfume and in bottles. Allah's Apostle (may peace be upon him) said: Umm Sulaim, what is this? She said: It is your sweat, which I put in my perfume. Allah's Apostle (may peace be upon him) sweated in cold weather when revelation descended upon him.

Chapter 22 : ALLAH'S APOSTLE (MAY PEACE BE UPON HIM) PERSHIRED WHEN REVELATION DESCENDED UPON HIM

Book 30, Number 5764:

    'A'isha reported: When revelation descended upon Allah's Messenger (may peace be upon him) even during the cold days, his forehead perspired.

Book 30, Number 5765:

    'A'isha reported that Harith b. Hisham asked Allah's Apostle (may peace be upon him): How does the the wahi (inspiration) come to you? He said: At times it comes to me like the ringing of a bell and that is most severe for me and when it is over I retain that (what I had received in the form of wahi), and at times an Angel in the form of a human being comes to me (and speaks) and I retain whatever he speaks.

Book 30, Number 5766:

    'Ubida b. Samit reported that when wahi (inspiration) descended upon Allah's Messenger (may peace be upon him), he felt a burden on that account and the colour of his face underwent a change.

Book 30, Number 5767:

    'Ubida b. Samit reported that when wahi descended upon Allah's Apostle (may peace be upon him), he lowered his head and so lowered his Companions their heads, and when (this state) was over, he raised his head.

Chapter 23 : PERTAINING TO THE HAIR OF THE HOLY PROPHET (MAY PEACE BE UPON HIM), HIS FEATURES

Book 30, Number 5768:

    Ibn Abbas reported that the People of the Book used to let their hair fall (on their foreheads) and the polytheists used to part them on their heads, and Allah's Messenger (may peace be upon him) liked to conform his behaviour to the People of the Book in matters in which he received no command (from God); so Allah's Messenger (may peace be upon him) let fall his hair upon his forehead, and then he began to part it after this.

Book 30, Number 5769:

    This hadith has been narrated on the authority of Ibn Shihab with the same chain of transmitters.

Chapter 24 : CONCERNING THE CHARACTERISTIC FEATURES OF AllAH'S APOSTLE (MAY PEACE BE UPON HIM), AND HE WAS THE MOST HANDSOME OF THE PEOPLE

Book 30, Number 5770:

    Al-Bara' reported that Allah's Messenger (may peace be upon him) was of medium height, having broad shoulders, with his hair hanging down on the lobes of his ears. He put on a red mantle over him, and never have I seen anyone more handsome than Allah's Apostle (may peace be upon him).

Book 30, Number 5771:

    Al-Bara' reported: Never did I see anyone more handsome than Allah's Apostle (may peace be upon him) in the red mantle. His hair had been hanging down on the shoulders and his shoulders were very broad, and he was neither very tall nor short-statured. Ibn Kuraib said he had hair.

Book 30, Number 5772:

    Al-Bara' reported that Allah's Messenger (may peace be upon him) had the most handsome face amongst men and he had the best disposition and he was neither very tall nor short-statured.

Book 30, Number 5773:

    Qatada reported: I asked Anas b. Malik: How was the hair of Allah's Messenger (may peace be upon him)? Thereupon he said: His hair was neither very curly nor very straight, and they hung over his shoulders and earlobes.

Chapter 25 : PERTAINING TO THE CHARACTERISTIC FEATURES OF THE FACE OF ALLAH'S MESSENGER (MAY PEACE BE UPON HIM) AND HIS EYES AND HIS HEELS

Book 30, Number 5774:

    Anas reported that the hair of Allah's Messenger (may. peace be upon him) came upon his shoulders.

Book 30, Number 5775:

    Anas reported that the hair of Allah's Apostle (may peace be upon him) reached half of the earlobe.

Book 30, Number 5776:

    Jabir b. Samura reported that Allah's Messenger (may peace be upon him) had a broad face with reddish (wide) eyes, and lean heels. Shu'ba reported: I said to Simak: What does this dali-ul-fam mean? And he said: This means broad face. I said: What does this ashkal mean? He said: Long in the slit of the eye. I said: What is this manhus-ul-aqibain? He said: It implies little flesh at the heels.

Chapter 26 : ALLAH'S MESSENGER (MAY PEACE AE UPON HIM) HAD A WHITE ELEGANT FACE

Book 30, Number 5777:

    Jurairi reported: I said to Abu Tufail: Did you see Allah's Messenger (may peace be upon him)? He said: Yes, he had a white handsome face. Muslim b. Hajjaj said: Abu Tufail who died in 100 Hijra was the last of the Companions of Allah's Messenger (may peace be upon him).

Book 30, Number 5778:

    Abu Tufail reported: I saw Allah's Messenger (may peace be upon him) and there is one amongst the people of the earth who (are living at the present time and) had seen him except me. I said to him: How did you find him? He said: He had an elegant white color, and he was of an average height.

Chapter 27 : PERTAINING TO THE OLD AGE OF ALLAH'S APOSTLE (MAY PEACE BE UPON HIM)

Book 30, Number 5779:

    Ibn Sirin reported: Anas b. Malik was asked whether Allah's Messenger (may peace be upon him) dyed his hair. He said: He had not become old enough to have white hair. Ibn Idris said that he had a few white hair. Abu Bakr and Umar, however, dyed hair with hina' (henna).

Book 30, Number 5780:

    Ibn Sirin reported: I asked Anas b. Malik whether Allah's Messenger (may peace be upon him) dyed his hair. He said: He had not reached the stage when (he needed) dyeing (of his white hair). He had a few white hair in his beard. I said to him: Did Abu Bakr dye his hair? He said: Yes, with hina' (henna).

Book 30, Number 5781:

    Muhammad b. Sirin reported: I asked Anas b. Malik whether Allah's Messenger (may peace be upon him) dyed his hair. He said: He had but little white hair.

Book 30, Number 5782:

    Thabit reported that Anas b. Malik was asked about the dyeing (of the hair of) Allah's Apostle (may peace be upon him). Thereupon he said.: (They were so few) that if I so liked I could count their number in his head, and he further said: (That is) he did not dye. Abu Bakr, however, dyed them and so did 'Umar dye them with pure henna.

Book 30, Number 5783:

    Anas b. Malik did not like that a person should pick out his white hair from his head or beard, and Allah's Messenger (may peace be upon him) did not dye, and there was some whiteness in his hair at his chin, on his temples and very little on his head. This hadith has been narrated on the authority of Muthanna through the same chain of transmitters.

Book 30, Number 5784:

    Anas (b. Malik) was asked about the old age of Allah's Apostle (may peace be upon him). He said: Allah did not blemish him with white hair.

Book 30, Number 5785:

    Abu Juhaifa reported: I saw Allah's Messenger (may peace be upon him) having some whiteness (in hair) at this place, and Zuhair placed one of his fingers at his chin. Juhaifa was asked how old he had been at that time. He said: I made arrows and put feathers to them (i.e. I had passed my childhood).

Book 30, Number 5786:

    Abu Juhaifa reported: I saw Allah's Messenger (may peace be upon him) that he had white complexion and had some white hair, and Hasan b. 'Ali resembled him.

Book 30, Number 5787:

    This hadith has been transmitted on the authority of Abu Juhaifa with a slight variation of wording.

Book 30, Number 5788:

    Jabir b. Samura was asked about the old age of Allah's Apostle (may peace be upon him). He said: When he oiled his head nothing was seen (as a mark of old age) and when he did not apply oil something (of the old age) became visible.

Book 30, Number 5789:

    Jabir b. Samura reported that there had appeared some whiteness on the front part of the head and beard of Allah's Messenger (may peace be upon him).When he applied oil, it did not become visible, but when he did not (apply) oil, it became apparent. And he had a thick beard. A person said: His face was as (bright) as the sword. Thereupon he (Jabir) said: No, it was round and like the sun and the moon. And I saw the seal near his shoulder of the size of a pigeon's egg and its color was the same as that of his body.

Chapter 28 : THE FACT PERTAINING TO THE SEAL OF HIS PROPHETHOOD, ITS CHARACTERISTIC FEATURE AND ITS LOCATION ON HIS BODY

Book 30, Number 5790:

    Jabir. Samura reported: I saw the seal on his back as if it were a pigeon's egg.

Book 30, Number 5791:

    This hadith has been narrated on the authority of Simak with the same chain of transmitters.

Book 30, Number 5792:

    As-Sa'ib b. Yazid reported : My mother's sister took me to Allah's Messenger (may peace be upon him) and said: Allah's Messenger, here is the son of my sister and he is ailing. He touched my head and invoked blessings upon me. He then performed ablution and I drank the water left from his ablution; then I stood behind him and I saw the seal between his shoulders.

Book 30, Number 5793:

    Abdullah b. Sarjis reported: I saw Allah's Apostle (may peace be upon him) and ate with him bread and meat, or he said Tharid (bread soaked in soup). I said to him: Did Allah's Apostle (may peace be upon him) seek forgiveness for you ? He said : Yes, and for you, and he then recited this verse : "Ask forgiveness for thy sin and for the believing men and believing women" (xlvii. 19). I then went after him and saw the Seal of Prophethood between his shoulders on the left side of his shoulder having spots on it like moles.

Chapter 29 : THE QUALITIES OF ALLAH'S APOSTLE (MAY PEACE BE UPON HIM) AND AGE WHEN HE WAS GIVEN THE MINISTRY OF APOSTLEHOOD AND THE DURATION OF HIS LIFE.

Book 30, Number 5794:

    Anas b. Malik reported that Allah's Messenger (may peace be upon him) was neither very conspicuously tall nor short-statured, and his color was neither glaringly white nor brown; his hair was neither very curly nor very straight; Allah commissioned him (as a Prophet) when he had reached the age of forty years, and he stayed in Mecca for ten years and for ten years in Medina; Allah took him away when he had just reached the age of sixty, and there had not been twenty white hair in his head and beard.

Book 30, Number 5795:

    This hadith has been transmitted on the authority of Anas b. Malik with this addition that instead of the word al-Amhaq there is the word Azhar.

Book 30, Number 5796:

    Anas b. Malik reported that Allah's Messenger (may peace be upon him) died when he was sixty-three years old, and so was the case with Abu Bakr, and so was the case with Umar who was also sixty-three (when he died).

Book 30, Number 5797:

    'A'isha reported that Allah's Messenger (may peace be upon him) died when he had attained the age of sixty-three. And a hadith like this had been transmitted on the authority of Sa'id b. Musayyib.

Book 30, Number 5798:

    This hadith has been narrated on the authority of Ibn Shihab through the same chain of transmitters.

Chapter 30 : HOW LONG DID THE APOSTLE OF ALLAH (MAY PEACE BE UPON HIM) STAY IN MEDINA AND MECCA

Book 30, Number 5799:

    'Amr reported: I said to 'Urwa: How long did Allah's Apostle -(may peace be upon him) stay in Mecca? He said: For ten years. I said: Ibn 'Abbas says (that he stayed in Mecca) for thirteen years.

Book 30, Number 5800:

    'Amr reported: I said to 'Urwa: How long did Allah's Apostle (may peace be upon him) stay in Mecca? He said: For ten years. I said: Ibn Abbas says it is some years above ten. He ('Urwa) sought forgiveness for him and said : His statement is based on the verse of a poet.

Book 30, Number 5801:

    Ibn 'Abbas reported that Allah's Messenger (may peace be upon him) stayed in Mecca for thirteen years and he died when he had attained the age of sixty three years.

Book 30, Number 5802:

    Ibn 'Abbas reported that Allah's Messenger (may peace be upon him) stayed in Mecca for thirteen years (after he had received revelation) and stayed in Medina for ten years, and he was sixty-three when he died.

Book 30, Number 5803:

    Abu Ishaq reported: I was sitting with 'Abdullah b. 'Utba and there was a discussion about the age of the Messenger of Allah (may peace be upon him). Some of the persons said: Abu Bakr was older than Allah's Messenger (may peace be upon him). 'Abdullah said: Allah's Messenger (may peace be upon him) died when he was sixty-three, and Abu Bakr died when he was sixty-three and so 'Umar fell as a martyr when he was sixty-three. A person from the people who was called 'Amir b. Sa'd reported that Jabir had said: We were sitting with Mu'awiya that there was a discussion about the age of Allah's Messenger (may peace be upon him). Thereupon Mu'awiya said: Allah's Messenger (may peace be upon him) died when he had attained the age of sixty-three, and Abu Bakr died when he had attained the age of sixty-three, and Umar fell as a martyr when he had attained the age of sixty-three.

Book 30, Number 5804:

    Jabir reported that he heard Mu'awiya say in his address that Allah's Messenger (may peace be upon him) died at the age of sixty-three, so was the case with Abu Bakr and 'Umar, and I (am now) sixty-three.

Book 30, Number 5805:

    'Ammar, the freed slave of Banu Hashim, reported: I asked Ibn 'Abbas how old was he when death overtook the Messenger of Allah (may peace be upon him). He said: I little know that such a thing is not known to a man like you who belong to his people. He said: I asked people about it but they differed with me, and I liked to know your opinion about it. He said: Do you know counting? He said: Yes. He then said: Bear this in mind very well that he was commissioned (as a Prophet) at the age of forty, and he stayed in Mecca for fifteen years; sometime in peace and sometime in dread, and (lived) for ten years after his migration to Medina.

Book 30, Number 5806:

    This hadith has been narrated on the authority of Yunus with the same chain of transmitters.

Book 30, Number 5807:

    Ammar, the freed slave of Banu Hashim, reported that Ibn 'Abbas said that Allah's Messenger (may peace be upon him) died when he had attained the age of sixty-five.

Book 30, Number 5808:

    This hadith has been narrated on the authority of Khalid with the same chain of transmitters.

Book 30, Number 5809:

    Ibn 'Abbas reported that Allah's Messenger (may peace be upon him) stayed in Mecca for fifteen years (after his advent as a Prophet) and he heard the voice of Gabriel and saw his radiance for seven years but did not see any visible form, and then received revelation for ten years, and he stayed in Medina for ten years.

Chapter 31 : PERTAINING TO THE NAME OF ALLAH'S APOSTLE (MAY PEACE BE UPON HIM)

Book 30, Number 5810:

    Jubair b. Mut'im reported on the authority of his father that he heard Allah's Messenger (may peace be upon him) as saying: I am Muhammad and I am Ahmad, and I am al-Mahi (the obliterator) by whom unbelief would be obliterated, and I am Hashir (the gatherer) at whose feet mankind will be gathered, and I am 'Aqib (the last to come) after whom there will be no Prophet.

Book 30, Number 5811:

    Jubair b. Mut'im reported on the authority of his father that he heard Allah's Messenger (may peace be upon him) as saying: I have many names: I am Muhammad, I am Ahmad, I am al-Mahi through whom Allah obliterates unbelief, and I am Hashir (the gatherer) at whose feet people will be gathered, and I am 'Aqib (after whom there would be none), and Allah has named him as compassionate and merciful.

Book 30, Number 5812:

    This hadith has been transmitted on the authority of Ma'mar (and the words are): I said to Zuhri: What does (the word) al-'Aqib imply? He said: One after whom there is no Prophet, and in the hadith transmitted on the authority of Ma'mar and 'Uqail there is a slight variation of wording.

Book 30, Number 5813:

    Abu Musa Ash'ari reported that Allah's Messenger (may peace be upon him) mentioned many names of his and said: I am Muhammad, Ahmad. Muqaffi (the last in succession), Hashir, the Prophet of repentance, and the Prophet of Mercy.

Chapter 32 : THE KNOWLEDGE OF ALLAH'S APOSTLE (MAY PEACE BE UPON HIM) ABOUT ALLAH AND HIS UTMOST FEAR OF HIM

Book 30, Number 5814:

    'A'isha reported Allah's Messenger (may peace be upon him) did an act, and held it to be valid. This news reached some persons amongst his Companions (and it was felt) that they did not approve of it and avoided (it). This reaction of theirs was conveyed to him. He stood to deliver an address; and said: What has happened to the people to whom there was conveyed on my behalf a matter for which I granted permission and they disapproved it and avoided it? By Allah, I have the best knowledge of Allah amongst them, and I fear Him most amongst them.

Book 30, Number 5815:

    This hadith has been narrated on the authority of A'mash through a different chain of transmitters.

Book 30, Number 5816:

    'A'isha reported that Allah's Messenger (may peace be upon him) granted permission for doing a thing, but some persons amongst the people avoided it. This was conveyed to Allah's Apostle (may peace be upon him), and he was so much annoyed that the sign of his anger appeared on his face. He then said: What has happened to the people that they avoid that for which permission has been granted to me? By Allah, I have the best knowledge of Allah amongst them, and fear Him most amongst them.

Chapter 33 : IT IS OBLIGATORY FOR A MUSLIM TO FOLLOW THE HOLY PROPHET (MAY PEACE BE UPON HIM) EARNESTLY

Book 30, Number 5817:

    'Urwa b. Zubair reported that 'Abdullah b. Zubair had narrated to him that a person from the Ansar disputed with Zubair in the presence of Allah's Messenger (may peace be upon him) in regard to the watering places of Harra from which they watered the date-palms. The Ansari said: Let the water flow, but he (Zubair) refused to do this and the dispute was brought to Allah's Messenger (may peace be upon him) and he said to Zubair: Zubair, water (your date-palms), then let the water flow to your neighbor. The Ansari was enraged and said: Allah's Messenger, (you have given this decision) for he is the son of your father's sister. The face of Allah's Apostle (may peace be upon him) underwent a change, and then said: Zubair, water (your date-palms), then hold it until it rises up to the walls. Zubair said: I think, by Allah, that this verse: "Nay, by the Lord, they will not (really) (believe) until they make thee a judge of what is in dispute among them, and find in this no dislike of what thou decidest and submit with full submission" (iv. 65).

Chapter 34 : RESPECT OF ALLAH'S MESSENGER AND ABANDONING OF TOO MANY QUESTIONS ESPECIALLY THOSE FOR WHICH THERE IS NO GENUINE NEED

Book 30, Number 5818:

    Abu Huraira reported that he heard Allah's Messenger (may peace be upon him) as saying: Avoid that which I forbid you to do and do that which I command you to do to the best of your capacity. Verily the people before you went to their doom because they had put too many questions to their Prophets and then disagreed with their teachings.

Book 30, Number 5819:

    This hadith has been narrated on the authority of Ibn Shihab with the same chain of transmitters.

Book 30, Number 5820:

    This hadith has been narrated by Abu Huraira through a different chain of transmitters (and the words are) that he reported Allah's Messenger (may peace be upon him) having said: Abandon that which I have asked you to abandon, for the people before you went to their doom (for asking too many questions).

Book 30, Number 5821:

    Amir b. Sa'd reported on the authority of his father that Allah's Messenger (may peace be upon him) said: The greatest sinner amongst the Muslims is one who asked about a thing (from Allah's Apostle) which had not been forbidden for the Muslims and it was forbidden for them because of his persistently asking about it.

Book 30, Number 5822:

    This hadith has been transmitted on the authority of 'Amir b. Sa'd and the words are. Allah's Messenger (may peace be upon him) said: The greatest sinner of the Muslims amongst Muslims is one who asked about a certain thing which had not been prohibited and it was prohibited because of his asking about it. This hadith has been narrated on the authority of Zuhri with the same chain of transmitters and with this addition: "A person asked about a thing from Allah's Apostle (may peace be upon him) and he indulged in hair-splitting."

Book 30, Number 5823:

    Anas b. Malik reported that something was conveyed to him (the Holy prophet) about his Companions, so he addressed them and said: Paradise and Hell were presented to me and I have never seen the good and evil as (I did) today. And if you were to know you would have wept more and laughed less. He (the narrator) said: There was nothing more burdensome for the Companions of Allah's Messenger (may peace be upon him) than this. They covered their heads and the sound of weeping was heard from them. Then there stood up 'Umar and he said: We are well pleased with Allah as our Lord, with Islam as our code of life and with Muhammad as our Apostle, and it was at that time that a person stood up and he said: Who is my father? Thereupon he (the Holy Prophet) said: Your father is so and so; and there was revealed the verse: "O you who believe, do not ask about matters which, if they were to be made manifest to you (in terms of law), might cause to you harm"(v. 101).

Book 30, Number 5824:

    Anas b. Malik reported that a person said: Allah's Messenger, who is my father? And he said: Your father is so and so, and there was revealed this verse: "Do not ask about matters which, if they were to be made manifest to you, might cause you harm" (v. 101).

Book 30, Number 5825:

    Anas b. Malik reported that Allah's Messenger (may peace be upon him stood when the sun had passed the meridian and he led them noon prayer and after observing salutations (completing the prayer) he stood upon the pulpit and talked about the Last Hour and made a mention of the important facts prior to it and then said: He who desires to ask anything from me let him ask me about it. By Allah, I shall not move from this place so long as I do not inform you about that which you ask. Anas b. Malik said: People began to shed tears profusely when they heard this from Allah's Messenger (may peace be upon him) and Allah's Messenger (may peace be upon him) said it repeatedly: You ask me. Thereupon 'Abdullah b. Hudhafa stood up and said: Allah's Messenger, who is my father? He said: Your father is Hudhafa, and Allah's Messenger (may peace be upon him) said repeatedly: Ask me, and (it was at this juncture that 'Umar knelt down and said): We are well pleased with Allah as our Lord, with Islam as our code of life and with Muhammad as the Messenger (of Allah). Allah's Messenger (may peace be upon him) kept quiet so long as 'Umar spoke. Then Allah's Messenger (may peace be upon him) said: (The Doom) is near; by Him, in Whose Hand is the life of Muhammad, there was presented to me the Paradise and Hell in the nook of this enclosure, and I did not see good and evil like that of the present day. Ibn Shihab reported: Ubaidullah b. 'Abdullah b. 'Utba told me that the mother of 'Abdullah b. Hudhafa told 'Abdullah b. Hudhafa: I have never heard of a son more disobedient than you. Do you feel yourself immune from the fact that your mother committed a sin which the women in the pre-Islamic period committed and then you disgrace her in the eyes of the people? 'Abdullah b. Hudhafa said: If my fatherhood were to be attributed to a black slave I would have connected myself with him.

Book 30, Number 5826:

    This hadith has been transmitted on the authority of Zuhri with a slight variation of wording.

Book 30, Number 5827:

    Anas b. Malik reported that the people asked Allah's Apostle (may peace be upon him) until he was hard pressed. He went out one day and he occupied the pulpit and said: Ask me and I shall leave no question of yours unanswered for you, and when the people heard about it they were overawed, as if (something tragic) was going to happen. Anas said: I began to look towards the right and the left and (found) that every person was weeping wrapping his head with the cloth. Then a person in the mosque broke the ice and they used to dispute with him by attributing his fatherhood to another man than his own father. He said: Allah's Apostle, who is my father? He said: Your father is Hudhafa. Then 'Umar b. Khattab (Allah be pleased with him) dared say something and said: We are well pleased with Allah as our Lord, with Islam as our code of life and with Muhammad as our Messenger, seeking refuge with Allah from the evil of Turmoil. Thereupon Allah's Messenger (may peace be upon him) said: Never did I see the good and evil as today. Paradise and Hell were given a visible shape before me (in this worldly life) and I saw both of them near this well.

Book 30, Number 5828:

    This hadith has been transmitted on the authority of Qatada.

Book 30, Number 5829:

    Abu Musa reported that Allah's Apostle (may peace be upon him) was asked such things which he disapproved and when they persisted on asking him he felt enraged and then said to the people: Ask me what you wish to ask. Thereupon a person said: Who is my father? He said: Your father is Hudhafa. Then another person stood up and said: Allah's Messenger, who is my father? He said: Your father is Salim, the freed slave of Shaiba. When 'Umar saw the signs of anger upon the face of Allah's Apostle (may peace be upon him), he said: Allah's Messenger, we ask repentance from Allah. And in the hadith transmitted on the authority of Abu Kuraib (the words are): "Allah's Messenger, who is my father? He said: Your father is Salim, the freed slave of Shaiba."

Chapter 35 : IT IS OBLIGATORY TO FOLLOW THE PROPHET (MAY PEACE BE UPON HIM) IN ALL MATTERS PERTAINING TO RELIGION, BUT ONE IS FREE TO ACT ON ONE'S OWN OPINION IN MATTERS WHICH PERTAIN TO TECHNICAL SKILL

Book 30, Number 5830:

    Musa b. Talha reported: I and Allah's Messenger (may peace be upon him) happened to pass by people near the date-palm trees. He (the Holy Prophet) said: What are these people doing? They said: They are grafting, i.e. they combine the male with the female (tree) and thus they yield more fruit. Thereupon Allah's Messenger (may peace be upon him) said: I do not find it to be of any use. The people were informed about it and they abandoned this practice. Allah's Messenger (may peace be upon him) (was later) on informed (that the yield had dwindled), whereupon he said: If there is any use of it, then they should do it, for it was just a personal opinion of mine, and do not go after my personal opinion; but when I say to you anything on behalf of Allah, then do accept it, for I do not attribute lie to Allah, the Exalted and Glorious.

Book 30, Number 5831:

    Rafi' b. Khadij reported that Allah's Messenger (may peace be upon him) came to Medina and the people had been grafting the trees. He said: What are you doing? They said: We are grafting them, whereupon he said: It may perhaps be good for you if you do not do that, so they abandoned this practice (and the date-palms) began to yield less fruit. They made a mention of it (to the Holy Prophet), whereupon he said: I am a human being, so when I command you about a thing pertaining to religion, do accept it, and when I command you about a thing out of my personal opinion, keep it in mind that I am a human being. 'Ikrima reported that he said something like this.

Book 30, Number 5832:

    Anas reported that Allah's Messenger (may peace be upon him) happened to pass by the people who had been busy in grafting the trees. Thereupon he said: If you were not to do it, it might be good for you. (So they abandoned this practice) and there was a decline in the yield. He (the Holy Prophet) happened to pass by them (and said): What has gone wrong with your trees? They said: You said so and so. Thereupon he said: You have better knowledge (of a technical skill) in the affairs of the world.

Chapter 36 : THE MERIT OF LOOKING AT THE FACE OF ALLAH'S MESSENGER (MAY PEACE BE UPON HIM) AND LONGING FOR IT

Book 30, Number 5833:

    Abu Huraira reported so many 'ahadith from Allah's Messenger (may peace be upon him) and one among them was that Allah's Messenger (may peace be upon him) is reported to have said: By Him in Whose Hand is the life of Muhammad, a day would come to you when you would not be able to see me, and the glimpse of my face would be dearer to one than one's own family, one's property and in fact everything. This hadith has been transmitted on the authority of Ishaq with a slight variation of wording.

Chapter 37 : THE MERITS OF JESUS CHRIST (PEACE BE UPON HIM)

Book 30, Number 5834:

    Abu Huraira reported Allah's Messenger (may peace be upon him) as saying: I am most akin to the son of Mary among the whole of mankind and the Prophets are of different mothers, but of one religion, and no Prophet was raised between me and him (Jesus Christ).

Book 30, Number 5835:

    Abu Huraira reported Allah's Messenger (may peace be upon him) as saying: I am most akin to Jesus Christ among the whole of mankind, and all the Prophets are of different mothers but belong to one religion and no Prophet was raised between me and Jesus.

Book 30, Number 5836:

    Abu Huraira reported many ahadith from Allah's Messenger (may peace be upon him) and one is that Allah's Messenger (may peace be upon him) said: I am most close to Jesus, son of Mary, among the whole of mankind in this worldly life and the next life. They said: Allah's Messenger how is it? Thereupon he said: Prophets are brothers in faith, having different mothers. Their religion is, however, one and there is no Apostle between us (between I and Jesus Christ).

Book 30, Number 5837:

    Abu Huraira reported Allah's Messenger (may peace be upon him) as saying: No child is born but he is pricked by the satan and he begins to weep because of the pricking of the satan except the son of Mary and his mother. Abu Huraira then said: You may recite if you so like (the verse): "I seek Thy protection for her and her offspring against satan the accursed" (iii. 36). This hadith has been narrated on the authority of Zuhri with the same chain of transmitters (and the words are): "The newborn child is touched by the satan (when he comes in the world) and he starts crying because of the touch of satan." In the hadith transmitted on the authority of Shu'aib there is a slight variation of wording.

Book 30, Number 5838:

    Abu Huraira reported Allah's Messenger (may peace be upon him) as saying: The satan touches every son of Adam on the day when his mother gives birth to him with the exception of Mary and her son.

Book 30, Number 5839:

    Abu Huraira reported Allah's Messenger (may peace be upon him) as saying: The crying of the child (starts) when the satan begins to prick him.

Book 30, Number 5840:

    Abu Huraira reported ahadith from the Messenger of Allah (may peace be upon him) (and one of them was) that Allah's Messenger (may peace be upon him) said Jesus son of Mary saw a person committing theft; thereupon Jesus said to him: You committed theft. He said: Nay. By Him besides Whom there is no god (I have not committed theft). Thereupon Jesus said: I affirm my faith in Allah It is my ownself that deceived me.

Chapter 38 : THE MERITS OF IBRAHIM, THE FRIEND OF ALLAH (PEACE BE UPON HIM)

Book 30, Number 5841:

    Anas b. Malik reported that a person came to Allah's Messenger (may peace be upon him) and said: O, the best of creation ; thereupon Allah's Messenger (may peace be upon him) said: He is Ibrahim (peace be upon him).

Book 30, Number 5842:

    This hadith has been narrated on the authority of Anas through a different chain of transmitters.

Book 30, Number 5843:

    Anas reported a hadith like this from Allah's Apostle (may peace be upon him) through another chain of transmitters.

Book 30, Number 5844:

    Abu Huraira reported Allah's Messenger (may peace be upon him) having said that Ibrahim circumcised himself with the help of adz when he was eiclhty years old.

Book 30, Number 5845:

    Abu Huraira reported Allah's Messenger (may peace be upon him) as saying: We have more claim to doubt than Ibrahim (peace be upon him) when he said , My Lord, show me how thou wilt quicken the dead. He said : Believeth thou not? He said: Yes, but that my heart rest at ease (the Holy Qur'an.260). May Lord have mercy on Lot that he wanted a strong support and had I stayed in the prison as long as Yusuf stayed I would have responded to him who invited me.

Book 30, Number 5846:

    This hadith has been narrated on the authority of Zuhri through another chain of transmitters.

Book 30, Number 5847:

    This hadith has been narrated on the authority of Abu Huraira through another chain of transmitters but with a slight variation of wording.

Book 30, Number 5848:

    Abu Huraira reported Allah's Messenger (may peace be upon him) as saying Prophet Ibrahim (peace be upon him) never told a lie but only thrice: two times for the sake of Allah (for example, his words) : "I am sick," and his words: "But it was the big one amongst them which has done that" and because of Sara (his wife). He had come in a land inhabited by haughty and cruel men along with Sara. She was very good-looking amongst the people, so he said to her: If these were to know that you are my wife they would snatch you away from me, so if they ask you tell that you are my sister and in fact you are my sister in Islam, and I do not know of any other Muslim in this land besides I and you. And when they entered that land the tyrants came to see her and said to him (the king): 'there comes to your land a woman, whom you alone deserve to possess, so he (the kings sent someone (towards her) and she was brought and Ibrahim (peace be upon him) stood in preyer, and when she visited him (the tyrant king came) he could help but stretch his hand towards her and his hand was tied up. He said: Supplicate Allah so that He may release my hand and I will do no harm to you. She did that and the man repeated (the same highhandedness) and his hand was again tied up more tightly than on the first occasion and he said to her like that and she again did that (supplicated), but he repeated (the same highhandedness and his hands were tied up more tightly than on the previous occasion). He then again said: Supplicate your Lord so that He may set my hand free; by .@ llah I shall do no harm to you. She did and his hand was freed. Then he called the person who had brought her and said to him: You have brought to me the satan and you have not brought to me a human being, so turn them out from my land, and he gave Hajira as a gift to her. She returned (along with Hajira) and when Ibrahim (peace be upon him) saw her, he said: How have you returned ? She said : With full safety (have I returned). Allah held the hand of that debauch and he gave me a maid-servant. Abu Hiaraira said: O sons of the rain of the sky, she is your mother.

Chapter 39 : PERTAINING TO THE MERITS OF MOSES (PEACE BE UPON HIM)

Book 30, Number 5849:

    Hammam b. Munabbih reported that Abu Huraira reported many ahadith from Allah's Messenger (may peace be upon him) and one, of them speaks that Allah's Messenger (may peace be upon him) is reported to have said: Banu Isra'il used to take bath (together) naked and thus saw private parts of one another, but Moses (peace be upon him) used to take bath alone (in privacy), and they said: By Allah, nothing prevents Moses to take bath along with us; but scrotal hernia. One day when he (Moses) was taking bath (alone) he placed his clothes upon a stone, but the stone began to move along with his clothes. Moses raced after it saying: My garment, stone ; until (some of the people) of Banu Isra'il looked at the private parts of Moses, and they said: By Allah, there is no trouble with Moses. The stone stopped after he (Moses) had been seen. He took hold of his garments and struck the stone. Abu Huraira said: I swear by Allah that there were six or seven scars on the stone because of the striking of stone by Moses (peace be upon him).

Book 30, Number 5850:

    Abu Huraira reported that Moses was a modest person. He was never seen naked and Banu Isra'iI said: (He was afraid to expose his private part) because he had been suffering from scrotal hernia. He (one day) took bath in water and placed his garments upon a stone. The stone began to move on quickly. He followed that and struck it with the help of a stone (saying): O stone, my garment; O stone, my garments, O stone; until it stopped near the big gathering of Isrii'll, and this verse was revealed (pertaining to the incident): "O you who believe, be not Iike those who maligned Moses, but Allah cleared him of what they said, and he was worthy of regard with Allah" (xxxiii. 69).

Book 30, Number 5851:

    Abu Huraira reported that the Angel of Death was sent to Moses (peace be upon him) to inform of his Lord's summons. When he came, he (Moses) boxed him and his eye was knocked out. He (the Angel of Death) came back to the Lord and said: You sent me to a servant. who did not want to die. Allah restored his eye to its proper place (and revived his eyesight), and then said: Go back to him and tell him that if he wants life he must place his hand on the back of an ox, and he would be granted as many years of life as the number of hair covered by his hand. He (Moses) said: My Lord what would happen then He said: Then you must court death. He said: Let it be now. And he supplicated Allah to bring him close to the sacred land . Thereupon Allah's Messenger (may peace be upon him) said: If I were there, I would have shown you his grave beside the road at the red mound.

Book 30, Number 5852:

    Abu Huraira reported Allah's Messenger (may peace be upon him) having said that the Angel of Death came to Moses and said: Respond (to the call) of Allah (i.e. be prepared for death). Moses (peace be upon him) gave a blow at the eye of the Angel of Death and knocked it out. The Angel went back to Allah (the Exalted) and said: You sent me to your servant who does not like to die and he knocked out my eye. Allah restored his eye to its proper place (and revived his eyesight) and said: Go to My servant and say: Do you want life? And in case you want life, keep your hand on the body of the ox and you would live such number of years as the (number of) hair your hand covers. He (Moses) said: What, then? He said: Then you would die, whereupon he (Moses) said: Then why not now? (He then prayed): Allah, cause me to die close to the sacred land. Allah's Messenger (may peace be upon him) said: Had I been near that place I would have shown his grave by the side of the path at the red mound. This hadith has been transmitted on the authority of Ma'mar.

Book 30, Number 5853:

    Abu Huraira reported: While a Jew was selling goods, he was given something which he did not accept or he did not agree (to accept) that 'Abdul 'Azlz (one of the narrators) is doubtful about it. He (the Jew) said: By Allah, Who chose Moses (peace be upon him) among mankind. A person from the Ansar heard it and gave a blow at his face saying: (You have the audacity) to say: By Him Who chose Moses amongst mankind, whereas Allah's Messenger (may peace be upon him) is living amongst us. The Jew went to Allah's Messenger (may peace be upon him) and said: Abu'l-Qasim, I am a Dhimmi and (thus need your protection) by a covenant, and added: Such and such person has given a blow upon my face. Thereupon Allah's Messenger (may peace be upon him) said: Why did you give a blow on his face? He said: Allah's Messenger, this man said: By Him Who chose Moses (peace be upon him) amongst mankind, whereas you are living amongst us. Allah's Messenger (may peace be upon him) became angry and signs of anger could be seen on his face, and then said: Don't make distinction amongst the Prophets of Allah. When the horn will be blown and whatever is in the heavens and the earth would swoon but he whom Allah grants exception, then another horn will be blown and I would be the first amongst those who would recover and Moses (peace be upon him) would be catching hold of the Throne and I do not know whether it is a compensation for that when he swooned on the Day of Tur or he would be resurrected before me and I do not say that anyone is more excellent than Yunus son of Matta (peace he upon him). This hadith has been narrated on the authority of Abu Salama with the same chain of transmitters.

Book 30, Number 5854:

    Abu Fluraira reported that two persons, one from amongst the Jews and the other from amongst the Muslims, fell into dispute and began to abuse one another. The Muslim said: By Him Who chose Muhammad (may peace be upon him) in the worlds. And the Jew said: By Him Who chose Moses in the worlds. Thereupon the Muslim lifted his hand and slapped at the face of the Jew. The Jew went to Allah's Messenger (may peace be upon him) and told him about his affair and the affair of the Muslim. Thereupon Allah's Messenger (may peace be upon him) laid:Don't make me superior to Moses for mankind will swoon and I would be the 'first to recover from it and Moses would be at that time seizing the side of the Throne and I do not know (whether) he would swoon and would recover before me or Allah would make an exception for him.

Book 30, Number 5855:

    Abu Huraira reported Allah's Messenger (may peace be upon him) as saying: A person from amongst the Muslims and a person from amongst the Jews fell into dispute and reviled each other. The rest of the hadith is the same.

Book 30, Number 5856:

    Abu Sa'id Khudri reported that a Jew who had received a blow at his face came to Allali',; Messenger (may peace be upon him) ; the rest of the hadith is the same, up to the hand (where the words are): That he (the Holy Prophet) said: I do not know whether he would be one who would fall into swoon and would recover before me or he would be compensated for his swooning at Tur (and thus he would not swoon on this occasion) of Resurrection.

Book 30, Number 5857:

    Abu Sa'id Kudari reported Allah's Messenger (may peace be upon him) having, said this: Don't make distinction amongst the Apostles. This hadith has been narrated through another chain of transmitters also.

Book 30, Number 5858:

    Anas b. malik reported Allah's Messenger(may peace be upon him)as saying: I came. And in the narration transmitted on the authority of Haddib (the words are): I happened to pass by Moses on the occasion of the Night journey near the red mound (and found him) saying his prayer in his grave.

Book 30, Number 5859:

    Anas reported Allah's Messenger (may peace be upon him) as saying: I happened to pass by Moses as he was busy in saying prayer in his grave, and in the hadith transmitted on the authority of 'Isa there is an addition of these words: ,I happened to pass on the occasion of the Night journey." In the hadith pertaining to Yunus (peace be upon him) the words of the Holy Prophet (may peace be upon him) are: "It is not meet for a, servant that he should say: "I am better than Yunus (jonah) son of Matta. "

Book 30, Number 5860:

    Abu Huraira reported Allah's Messenger (may prace be upon him) as saying that Allah, the Exalted and Majestic, said: It is not meet for a servant of Mine that he should say: I am better than Yunus b. Matta (peace be upon him).

Book 30, Number 5861:

    Abu al-Aliya said: The son of the uncle of your Prophet (may peace be upon him), i.e. Ibn Abbas, reported Allah's Messenger (may peace be upon him) as saying: It is not meet for a servant that he should say: I am better than Yunus b. Matta (and this Matta) is the name of his father.

Chapter 40 : THE MERITS OF YUSUF (JOSEPH) (PEACE BE UPON HIM)

Book 30, Number 5862:

    Abu Huraira reported: It was said to Allah's Messenger (may peace be upon him) as to who was the most worthy of respect amongst people. He said: The most God-conscious amongst you They said: It is not this that we are asking about, whereupon he said: Then he is Yusuf, the Apostle of Aliah and the son of Allah's Apostle, Ya'qub, who was also the son of Allah's Apostle, the friend of Allah (Ibrahim) They said: This is not what we are asking you. He said: You mean the tribes of Arabia? Those who are good in pre-Islamic days are good in Islam (after embracing Islam) when they get an understanding of it.

Book 30, Number 5863:

    Abu Huraira reported Allah's Messenger (may peace be upon him) as saying: Zakariyya (peace be upon him) was a carpenter.

Chapter 41 : THE MERITS OF HADRAT KHADIR (PEACE BE UPON HIM)

Book 30, Number 5864:

    Sa'id b. jubair reported: I said to Ibn Abbas that Nauf al-Bikali was of the opinion that Moses (peace be upon him), the Apostle of Bani Isra'il, was not the same who accompanied Khadir, whereupon he said: The enemy of Allah tells a lie. I heard Ubayy b. Ka'b say: Moses (peace be upon him) stood up to give sermon to the people of Isra'i1. He was asked as to who amongst the people has the best knowledge, whereupon he said: I have the best knowledge. Thereupon Allah was annoyed with him that he did not attribute (the best knowledge) to Him. He revealed to him: A servant amongst My servants is at the junction of two rivers who has more knowledge than yours. Moses said: How can I meet him? It was said to him: Carry a fish in the large basket and the place where you find it missing there you will find him. Thereupon Moses proceeded forth along with a young man (Yusha'). Joshua b. Nan and Moses (peace be upon him) put the fish in the basket and there went along with him the young man (Yusha') until they came to a certain rock and Moses and his companion went to sleep and the fish stirred in that basket and fell into the ocean and Allah stopped the current of water like a vault until the way was made for the fish. Moses and his youn. companion were astonished and they walked for the rest of the day and the night and the friend of Moses forgot to inform him of this incident. When it was morning, Moses (peace be upon him) said to the young man: Bring for us the breakfast for we are dead tired because of this journey, and they did not feel exhausted until they had passed that place where they had been commanded (to stay). He said: Don't you know that when we reached the Sakhra (rock) I forgot the fisii and noth ng made me forget it but the satan that I. could nit remember it? How strange is it that the fish found a way in the river? Moses said: That was what we had been aiming at. Then both of them retraced their steps until they reached Sakhra; there they saw a man covered with a cloth. Moses greeted him. Khadir said to him: Where is as-Salam in our country.? He said: I am Moses, whereupon he (Khadir) said: You mean the Moses of Bani Isra'il? He said: Yes. He (Khadir) said: You have a knowledge out of the knowledge of Allah which in fact Allah imparted to you and about that I know nothing and I have knowledge out of Allah's knowledge which He imparted to me and about that you do not know. Moses (peace be upon him) said to him: May I follow you so that you may teach me that with which you have been taught righteousness. He said: You will not be able to bear with me; how you will be able to bear that about which you do not know? Moses said: Thou wilt find me patient, nor shalt I disobey you in aught. Khadir said to him: If you were to follow me, then do not ask me about anything until I myself speak to you about it. He said: Yes. So Khadir and Moses set forth on the bank of the river that there came before them a boat. Both of theni talked to them (the owners of the boat) so that they might carry both of them.They had recognised Khadir and they carried them free. Khadir thereupon took hold of a plank in the boat and broke it away. Moses said: These people have carried us without any charge and you attempt to break their boat so that the people sailing in the boat may drown. This is (something) grievous that you have done. He said: Did I not say that you would not bear with me? He said: Blame me not for what I forgot and be not hard upon what I did. Then both of them got down from the boat and began to walk along the coastline that they saw a boy who had been playing with other boys. Khadir pulled up his head and killed him. Moses said: Have you killed an innocent person who is in no way guilty of slaying another? You have done something horrible. Thereupon he said : Did I not say to you that you will not be able to bear with me? He (Moses) said: This (act) is more grievous than the first one. He (Moses) further said. If I ask you about anything after this, keep not company with me, then you would no doubt find (a plausible) excuse for this. Then they both walked on until they reached the inhabitants of a village. They asked its inhabitants for food but they refused to entertain them as their guests. They found in it a wall which had been bent on one side and was about to fall. Khadir set it right with his own hand. Moses,said to him: It is the people to whom we came but they showed us no hospitality and they did not serve us food. If you wish you can get wages for it. He (Khadir) said: This is the parting of ways between mt and you. Now I wish to reveal to you the significance of that for which you could not bear with me. Allah's Messenger (may peace be upon him) said . May Allah have mercy upon Moses ! I wish if Moses could show patience and a (fuller) story of both of them could have been told. Allah's Messenger (may peace be upon him) said that the first thing which Moses said was out of forgetfulness. Then there came a sparrow until it perched on the wall of the boat and took water from the ocean. Thereupon, Khadir said: My knowledge and your knowledge in comparison with the knowledge of Allah is even less than the water taken by the sparrow in its beak in comparison to the water of the ocean, and Sa'id b. jubair used to recite (verses 79 and 80 of Sura Kahf) in this way: There was before them a king who used to seize every boat by force which was in order, the boy was an unbeliever.

Book 30, Number 5865:

    Sa,id b. jubair reported that it was said to Ibn 'Abbas that Nauf al-Bikali was of the opinion that Moses who went in search of knowledge was not the Moses of Bani Isra'il. He said: Sa'id, did you hear it from him? I said: Yes. Thereupon he said that Nauf had not stated the fact. Ubayy b. Ka'b narrated to us that he had heard Allah's Messenger (may peace be upon him) as saying: Moses had been delivering sermons to his people. And he made this remark: No person upon the earth has better knowledge than I or nothing better than mine. Thereupon Allah revealed to him: I know one who is better than you (in knowledge) or there is a person on the earth having more knowledge than you. Thereupon he said: My Lord, direct me to him. It was said to him: Keep a salted fish as a provision for journey. The place where that fish would be lost (there you will find that man). So he set forth and a young slave along with him until they came to a place Sakhra. but he did not find any clue. So he proceeded on and left that young man there. The fish began to stir in water and the water assumed the form of an ark over the fish. The young man said: I should meet Allah's Apostle (peace be upon him) and inform him, but he was made to forget and when they had gone beyond that place, he (Moses) said to the young man: Bring breakfast. We have been exhausted because of the journey, and he (Moses) was not exhausted until he had crossed that (particular) place (where he had) to meet Khadir, and the youth was reminded and said: Did you not see that as we reached Sakhra I forgot the fish and it is satan alone who has made me forgetful of it'? It is strange that he has been able to find way in the ocean too. He said: This is what we sought for us. They returned retracing their steps, and he (his companion) pointed to him the location (where) the fish (had been lost). Moses began to search him there. He suddenly saw Khadir wrapped in a cloth and lying on his back. He said to him: As-Salamu-'Alaikum. He removed the cloth from his face and said: Wa 'Alaikum-us-Salam! Who are you? He said: I am Moses. He said: Who Moses? He said: Moses Of Bani Isra'il. He said: What brought you here? He said: I have come so that you may teach me what you have been taught of righteousness. He said: You shall have to bear with me, and how can you have patience about a thing of which you have no comprehensive knowledge? You will not have patience when you see me doing a thing I have been ordered to do. He said: If Allah pleases, you will find me patient, nor shall I disobey you in aught. Khadir said: If you follow me, don't ask me about anything until I explain it to you. So they went on until they embarked upon a boat. He (Khadir) made a hole in that. Thereupon he (Moses) said: You have done this so that you may drown the persons sitting in the boat. You have done something grievous. Thereupon he said: Did I not tell you that you will not be able to bear with me? Thereupon he (Moses) said: Blame me not for what I forgot and be not hard upon me for what I did. (Khadir gave him another chance.) So they went on until they reached a place where boys were playing. He went to one of them and caught hold'of one (apparently) at random and killed him. Moses (peace be upon him) felt agitated and said: You have killed an innocent person not guilty of slaying another. You have done something aboininable. Thereupon Allah's Messenger (may peace be upon him) said: May Allah have mercy upon us and Moses. Had he shown patience he would have seen wonderful things, but fear of blame, with respect to his companion, seized him and he said: If I ask anything after this, keep not company with me. You will then have a valid excuse in my case, and had he (Moses) shown patience he would have seen many wonderful things. He (the narrator) said: Whenever he (the Holy Prophet) made mention of any Prophet, he always said : May there be mercy of Allah upon us and upon my brother so and so. They, however, proceeded on until they came to the inhabitants of a village who were very miserly. They went to the meeting places and asked for hospitality but they refused to show any hospitality to them. They both found in that village a wall which was about to fall. He (Khadir) set it right. Thereupon he (Moses) said: If you so liked. you could get wages for it. Thereupon he said: This is the partince, of ways between me and you, and, taking hold of his cloth, he said: Now I will explain to you the real significance (of all these acts) for which you could not show patience. As for the boat, it belonged to the poor people working on the river and I intended to damage it for there was ahead of them (a king) who seized boats by force. (When he came) to catch hold of it he found it a damaged boat, so he spared it (and later on) it was set right with wood. So far as the boy is concerned, he has been, by very nature, an unbeliever, whereas his parents loved him very much. Had he grown up he would have involved them in wrongdoing and unbelief, so we wished that their Lord should give them in its place one better in purity and close to mercy. And as for the wall it belonged to two orphan boys in the city and there was beneath it a (treasure) belongin to them, ...up to the last verse. This hadith has been transmitted on the authority of Abu Ishaq.

Book 30, Number 5866:

    Ibn 'Abbas has reported this hadith on the authority of Ubayy b. ka'b that Allah's Apostle (may peace be upon him) used to recite this.

Book 30, Number 5867:

    'Utba b. Mas,ud reported that 'Abdullah b. 'Abbas contended with Hurr b.Qais b. Hisn al-Fazari aboat the companion of Moses (peace be upon hiin). Ibn 'Abbas said that he was Khadir. There happened to pass Ubayy b. Ka'b Ansari. Ibn Abbas called him and said: Abu Tufail, come to us. There has been a difference of opinion between me and my friend about the companion of Moses whom he wanted to meet on the way.Did hear anything from Allah's meesenger (may peace be upon him) making a mention of anything? Ubayy said: I heard Allah's Messenger (may Peace be upon him) as saying: As Moses was amongst the group of Bani Isra'il, there came to him a person and he said to him: Do you know anyone having better knowledge than you? Moses said: No. Thereupon Allah revealed to Moses: Of course, there is amongst Our servants Khadir (who has better knowledge) than you. Moses asked the way of meeting him. Allah made the fish a sign and it was said to him: Where you miss the fish return to that (place) and you will soon find him. So Moses moved on as Allah wished him to move on. He then said to his young companion: Bring for us the breakfast. Thereupop that young man said to Moses. when he asked him for the breakfast: Don't you see that as we had reached the Sakhra I forgot the fish and nobody made it forget (in our mind) but the satan that I should remind you of it? Mosed said to that young man: This was what we wanted. So they retraced their steps and met Khadir and the events which followed have been described in His Book except that Yunus (the narrator) said that he followed the traces of fish in the ocean.


Book 31 : The Book pertaining to Merits of the Companions of the Holy Prophet (SAW) (KITAB AL-FADA'IL AL-SAHABAH

KITAB AL-FADA'IL AL-SAHABAH
(BOOK PERTAINING TO THE MERITS OF THE COMPANIONS(ALLAH BE PLEASED WITH THEM) OF THE HOLY PROPHET (MAY PEACE BE UPON HIM)

Back
Chapter 1: THE MERITS OF ABU BAKR SIDDIQ (ALLAH BE PLEASED WITH HIM)

Book 31, Number 5698:

    Anas b. Malik reported that Abu Bakr Siddiq reported him thus: I saw the feet of the polytheists very close to us as we were in the cave. I said: Allah's Messenger, if one amongst them were to see at his feet he would have surely seen us. Thereupon he said: Abu Bakr, what can befall twain who have Allah as the third One with them.

Book 31, Number 5869:

    Abu Sa'id reported that Allah's Messenger (may peace be upon him) sat on the pulpit and said: Allah gave a choice to His servant that he may opt the beauties of the world or that which is with Him and the servant chose that which was with Him. Thereupon Abu Bakr wept and he wept bitterly and said: Let our fathers and our mothers be taken as ransom for you. It was Allah's Messenger (may peace be upon him) who had been given the choice and Abu Bakr knew it better than us, and Allah's Messenger (may peace be upon him) is reported to have said: Behold, of all people the most generous toward me in regard to his companionship and his property was Abu Bakr and were I to choose anyone as my bosom friend, I would have chosen Abu Bakr as my dear friend, but (for him) I cherish Islamic brotherliness and love. There shall be left open no window in the mosque except Abu Bakr's window.

Book 31, Number 5870:

    This hadith has been narrated on the authority of Abu Sa'id Khudri through another chain of transmitters.

Book 31, Number 5871:

    'Abdullah b. Mas'ud reported Allah's Messenger (may peace be upon him) as saying: If I were to choose a bosom friend I would have definitely chosen Abu Bakr as my bosom friend, but he is my brother and my companion and Allah, the Exalted and Gliorious. has taken your brother and companion (meaning Prophet himself) as a friend.

Book 31, Number 5872:

    Abdullah reported Allah's Messenger (may peace be upon him) as saying: If I were to choose from my Umma anyone as my bosom friend, I would have chosen Abu Bakr.

Book 31, Number 5873:

    'Abdullah reported Allah's Messenger (may peace be upon him) as saying: If I were to choose as my bosom friend I would have chosen the son of Abu Quhafa (Abu Bakr) as my bosom friend.

Book 31, Number 5874:

    Abdullah reported Allah's Messenger (may peace be upon him) as saying: If I were to choose amongst the people of earth someone as my bosom friend, I would have chosen the son of Abu Quhafa as my friends but God has taken your companion as a friend.

Book 31, Number 5875:

    This hadith has been narrated through another chain of transmitters and the one narrated on the authority of Abdullah (the words are): "Allah's Messenger (may peace be upon him) is reported to have said: Behold I am free from the dependence of all bosom friends and if I were to choose anyone as bosom friend I would have taken Abu Bakr as my bosom friend. Allah has taken your companion as a friend.

Book 31, Number 5876:

    'Amr b. al-'As reported that Allah's Messenger (may peace be upon him) sent him in command of the army despatched to Dhat-as-Salasil. When 'Amr b. al-'As came back to the Holy Prophet (may peace be upon him) he said: Who amongst people are dearest to you? He said: A'isha. He then said: Who amongst men? He said: Her father, and I said: And who next? He said: Umar. He then enumerated some other men.

Book 31, Number 5877:

    Ibn Abu Mulaika reported: I heard A'isha as saying and she was asked as to whom Allah's Messenger (may peace be upon him) would have nominated his successor if he had to nominate one at all. She said: Abu Bakr. It was said to her: Then whom after Abu Bakr? She said: Umar. It was said to her. Then whom after 'Umar ? She said: Abu Ubaida b. Jarrab, and then she kept quiet at this.

Book 31, Number 5878:

    Muhammad b. Jubair b. Mut'im reported on the authority of his father that a woman asked Allah's Messenger (may peace be upon him) about something but lit, told her to come to him on some other occasion, whereupon she said: What in your opinion (should I do) if I come to you but do not find you, and it seemed as if she meant that he might die. Thereupon he said: If you do not find me, then come to Abu Bakr.
    This hadith has been narrated on the authority of Jubair b. Mut'im through another chain of transmitters (and the words are) that a woman came to Allah's Messenger (may peace be upon him) and discussed with him something and he gave a command as we find in the above-mentioned narration.

Book 31, Number 5879:

    A'isha reported that Allah's Messenger (may peace be upon him) in his (last) illness asked me to call Abu Bakr, her father, and her brother too, so that he might write a document, for he feared that someone else might be desirous (of succeeding him) and that some claimant may say: I have better claim to it, whereas Allah and the Faithful do not substantiate the claim of anyone but that of Abu Bakr.

Book 31, Number 5880:

    Abu Huraira reported that Allah's Messenger (may peace be upon him) said: Who amongst you is observing fastthis day? Abu Bake said: It is I. He (again) said: Who amongst you has followed the bier today? Abu Bakr said: It is I. He (the Holy Prophet) again said: Who amongst you has served food to the needy? Abu Bakr said: It is I. He (again) said: Who amongst you has today visited the sick? Abu Bakr said: It is I. Thereupon Allah's Messenger (may peace be upon him) said: He must get into Paradise who combines in himself (all these noble qualities and virtues).

Book 31, Number 5881:

    Abu Huraira reported Allah's Messenger (may peace be upon him) as saying: A person had been driving an ox loaded with luggage. The ox looked towards him and said: I have not been created for this but for lands (i.e. for ploughing the land and for drawing out water from the wells for the purpose of irrigating the lands). The people said with surprise and awe: Hallowed be Allah, does the ox speak? Allah's Messenger (may peace be upon him) said: I believe it and so do Abu Bakr and 'Umar. Abu Huraira reported Allah's Messenger (may peace be upon him) as saying: A shepherd was tendirig the flock when a wolf came there and took away one goat. Tile shepherd pursued it (the wolf) and rescued it (the goat) from that (wolf). The wolf looked towards him and said: Who would save it on the day when there will be no shepherd except me ? Thereupon people said: Hallowed be Allah I Thereupon Allah's Messenger (may peace be upon him) said: I believe in it and so do Abu Bakr and Umar believe.

Book 31, Number 5882:

    This hadith has been narrated on the authority of Ibn Shihab with the same chain of transmitters, but there is no mention of the story pertaining to the ox.

Book 31, Number 5883:

    This hadith has been transmitted on the authority of Zuhri, and there is a clear mention of the stories of ox and goat (and the words are): I believe in it and so do Abu Bakr and Umar, but they were not at that time present there.

Book 31, Number 5884:

    This hadith has been narrated on the authority of Abu Huraira through another chain of transrritters.

Chapter 2 : THE EXCELLENT QUALITIES OF 'UMAR (ALLAH BE PLEASED WITH HIM)

Book 31, Number 5885:

    Ibn Abu Mulaika reported: I heard Ibn 'Abbas as saying: Wlien 'Umar b. Khatab was placed in the coffin the people gathered around him. They praised him and supplicated for him before the bier was lifted up, and I was one amongst them. Nothing attracted my attention but a person who gripped my shoulder from behind. I saw towards him and found that he was 'All. He invoked Allah's mercy upon 'Umar and said: You have left none behind you (whose) deeds (are so enviable) that I love to meet Allah with them. By Allah, I hoped that Allah would keep you and your two associates together. I had often heard Allah's Messenger (may peace be upon him) as saying: I came and there came too Abu Bakr and 'Umar; I entered and there entered too Abu Bakr and 'Umar; I went out and there went out too Abu Bakr and 'Umar, and I hope and think that Allah will keep you along with them.

Book 31, Number 5886:

    This hadith has been narrated on the authority of 'Umar b. Sa'id with the same chain of transmitters.

Book 31, Number 5887:

    Abu Sa'id Khudri reported Allah's Messenger (may peace be upon him) as say ing: While I was asleep I saw people being presented to me (in a dream) and they wore shirts and some of these reached up to the breasts and some even beyond them. Then there happened to pass 'Umar b. Khattab and his shirt had been trailing. They said: Allah's Messeneer, how do you interpret the dream ? He said: (As strength of) faith.

Book 31, Number 5888:

    Hamza b. Abdullah b. 'Umar b. Khattab reported on the authority of his father that Allah's Messenger (may peace be upon him) said: While I was asleep I saw (in a dream) a cup containing milk bein. presented to me. I took out of that until I perceived freshness being reflected through my nails. Then I presented the leftover to 'Umar b. Khattab. They said: Allah's Messenger: Fow do you interpret it? He said: This implies knowledge.

Book 31, Number 5889:

    This hadith has beer. narrated on the authority of Yunus with the same chain of transmitters.

Book 31, Number 5890:

    Abu Huraira reported Allah's Messenger (may peace be upon him) as saying: While I was asleep I saw myself on a well with a leathern bucket on a pulley. I drew (water) out of that as Allah wished me (to draw). Then the son of Abu Quhafa (Abu Bakr) drew from it one bucketful or two and there was some weakness in drawing that (may Allah forgive him). Then that bucket (changed into a large bucket) and Ibn Khattab drew it. I did not see any strongest man drawing it like 'Umar b. Khattab. He brought out so much water that the camels of the people had enough to drink and then laid down (for rest).

Book 31, Number 5891:

    This hadith has been narrated on the authority of Yunus through another chain of transmitters.

Book 31, Number 5892:

    Abu Huraira reported Allah's Messenger (may peace be upon him) as saying: I saw Ibn Abu Quhafa drawing (water); the rest of the hadith is the same.

Book 31, Number 5893:

    Abu Huraira reported Allah's Messenger (may peace be upon him) as saying: While I was asleep I saw myself drawing water from my tank in order to quench the thirst of the people that there came to me Abu Bakr. He took hold of the leathern bucket from my hand so that he should serve water to the people. He drew two bucketfuls and there was some weakness in his drawing (Allah may forgive him). Then there came Ibn Khattab and he took hold of that, and I did not see a person stronger than he (drawing water) until the people went away with their thirst quenched and the tank filled with water.

Book 31, Number 5894:

    Abdullah b. 'Umar reported Allah's Messenger (may peace be upon him) as saying: I saw (in a dream) as if I was drawing water with a leathern bucket on a wooden pulley. There came Abu Bakr and he drew out a bucketful or two and as he drew out, some weakness (was perceived in it) (may Allah, the Exalted and Glorious, forgive him). Then Umar came in order to serve water -and the bucket was changed into a large leather bucket and I did not see such a wonderful man amongst persons (drawing water) and he went on serving water to the people until they were fully satisfied and then went to their resting places.

Book 31, Number 5895:

    Salim b. 'Abdullah reported on the authority of his father some of the dreams of Allah's Messenger (may peace be upon him) pertaining to Abu Bakr and Umar b. Khattab (Allah be pleased with them) and a hadith like this.

Book 31, Number 5896:

    Jabir reported Allah's Messenger (may peace be upon him) as saying: I entered Paradise and saw in it a house or a palace. I said: For whom is it resersred? They (the Angels) said: It is for 'Umar b. Khattab. (The Holy Prophet said to 'Umar b. Khattab): I intenied to get into it but I thought of your feelings. Thereupon 'Umar wept and said: Apostle of Allah, could I feel any jealousy in your case?

Book 31, Number 5897:

    This hadith has been narrated on the authority of Jabir through another chain of transmitters.

Book 31, Number 5898:

    Abu Huraira reported Allah's Messenger (may peace be upon him) as saying: Wtiile'l was asleep I saw myself in Paradise and a woman performing ablution by the side of a palace. I said: For whom is it meant? They said: It is meant for 'Umar b. Khattab. (The Holy Prophet) said: There came across my mind the feeling of Umar and so I turned back and went away. Abu Huraira said: 'Umar wept as we were present in that meeting with Allah's Messenger (may peace be upon him) amongst us and Umar said: Allah's Messenger, may my father and mother be taken as ransom for you. Could I at all feel any jealousy about you? This hadith has been narrated on the authority of Ibn Shihab with the same chain of transmitters.

Book 31, Number 5899:

    Sa'd b. Waqqas reported that Umar sought permission from Allah's Messenger (may peace be upon him) to visit him when some women of the Quraish were busy in talking with him and raising their voices above his Voiee. When'Umar sought permission they stood up and went hurriedly behind the curtain. Allah's Messenger (may peace be upon him) gave him permission smilingly. Thereupon 'Umar said: Allah's Messenger, may Allah keep you happy all your life. Then Allah's Messenger (may peace be upon him) said: I wonder at these women who were with me and no sooner did they hear your voice, they immediately went behind the curtain. Thereupon 'Umar said: Allah's Messenger, you have more right that they should fear you. Then Umar (addressing the women) said: O ye enemies of yourselves, do you fear me and fear not the Messenger of Allah (may peace be upon him)? They said: Yes, you are harsh and strict as compared to the Messenger of Allah (may peace be upon him). Thereupon, Allah's Messenger (maypeace be upon him) said: By Him in Whose Hand is my life, if satan would encounter you in the way he would certainly take a different way from that of yours.

Book 31, Number 5900:

    Abu Huraira reported that Umar b. Khattab came to Allah's Messenger (may peace be upon him) while there were some women with him and they were raising their voices above the voice of Allah's Messenger (may peace be upon him) and when Umar sought permission to get into the house they went behind the curtain hurriedly. The rest of the hadith is the same.

Book 31, Number 5901:

    A'isha reported Allah's Messenger (may peace be upon him) as saying: There had been among the people before you inspired persons and if there were any such among my Umma Umar b. Khattab would be one of them. Ibn Wahb explained the word Muhaddathun as those who receive hint from the High (Mulhamun).

Book 31, Number 5902:

    This hadith has been narrated on the authority of Sa'd b. Ibrahim with the same chain of transmitters.

Book 31, Number 5903:

    Ibn Umar reported Umar as saying: My lord concorded with (my judgments) on three occasions. In case of the Station of Ibrahim, in case of the observance of veil and in case of the prisoners of Badr.

Book 31, Number 5904:

    Ibn Umar reported that when 'Abdullah b. Ubayy b. Salul (the hypocrite) died, his son Abdullah b. Abdullah came to Allah's Messenger (may peace be upon -him) and asked him to give his shirt which should be used for the coffin of his father. He gave that to him. Allah's Messenger (may peace be upon him) stood up to say prayer over him Thereupon I Umar caught hold of the clothe of Allah's Messenger (may peace be upon him) and said: Allah's Messenger, are you going to offer prayer, whereas Allah has forbidden to offer prayer for him, whereupon Allah's Messenger (may peace be upon him) said : Allah has given me a choice saying: Ask forgiveness for them or you may not ask for them; even if you ask for them seventy times, I will make an addition to the seventy. He was a hypocrite and Allah's Messenger (may peace be upon him) said prayer over him that Allah, the Exalted and Glorious, revealed the verse : "And never pray over any one of them that has died and never should you stand by his grave" (ix. 84).

Book 31, Number 5905:

    This hadith has been narrated on the authority of 'Ubaidullah with the same chain of transmitter but with the addition of the words: "He abandoned saying prayer over the hypocrites who had died."

Chapter 3 : MERITS OF UTHAMN B.'AFFAN (ALLAH BE PLEASED WITH HIM)

Book 31, Number 5906:

    A'isha reported: Allah's Messenger (may peace be upon him) was lying in the bed in my apartment with his thigh or his shank uncovered that Abu Bakr sought permission to get in. It was given to him and he conversed in the same very state (the Prophet's thigh or shank uncovered). Then 'Umar sought permission for getting in and it was given to him and he conversed in that very state. Then 'Uthman sought permission for getting in; Allah's Messenger (may peace be upon him) sat down and he set right his clothes. Mubammad (one of the narrators) said: I do not say that it happened on the same day. He ('Uthman) then entered and conversed and as he went out, A'isha said : Abu Bakr entered aind you did not stir and did not observe much care (in arranging your clothes), then 'Umar entered and you did not stir and did not arrange your clothes, then 'Uthman entered and you got up and set your clothes right, thereupon he said: Should I not show modesty to one whom even the Angels show modesty.

Book 31, Number 5907:

    A'isha, the wife of Allah's Apostle (mav peace be upon him), and Uthman both reported that Abu Bakr sought permission from Allah's Messenger (may peace be upon him) for entrance (in his apartment) as he had been lying on his bed covered with the bed-sheet of A'isha, and he gave permission to Abu Bakr in that very state and he, having his need fulfilled, went back. Then Umar sought permission and it was given to him in that very state and, after having his need fulfilled, he went back. And 'Uthman reported: Then I sought permission from him and he got up and raid to A'isha: Wrap yourself well with your cloth, then I got my need fulfilled and came back. And A'isha said: Allah's Messenger, why is it that I did not see you feeling any anxiety in case of dressing properly in the presence of Abu Bakr and 'Umar (Allah be pleased with them) as you showed in case of 'Uthman. Thereupon Allah's Messenger (may peace be upon him) said: Verily Uthman is a person who is very modest and I was afraid that if I permitted him to enter in this very state he would not inform me of his need.

Book 31, Number 5908:

    This hadith has been transmitted on the authority of Uthman and A'isha with the same wording.

Book 31, Number 5909:

    Abu Musa al-Ash'ari reported that while Allah's Messenger (may peace be upon him) was in one of the gardens of Medina, reclining against a pillow and fixing a stick in a mud, that a person came asking for the gate to be opened, whereupon he said : Open it for him and give him glad tidings of Paradise and, lo, it was Abu Bakr. I opened (the gate) for him and gave him the glad tidings of Paradise. Then another person asked for the door to be opened, whereupon he said : Open it and give him the glad tidings of Piradise. He said : I went away and, lo, it was 'Umar. I opened it for him and gave him the glad tidings of Paradise. Then still another man asked for the door to be opened, and thereupon Allah's Apostle (may peace be upon him) said : Open it and give him the glad tidings of Paradise after a trial would afflict him. I went and, lo, it was 'Uthman b. 'Affan. 1 opened the door and gave him the glad tidings of Paradise and informed him (what the Holy Prophet had said). Thereupon he said : O Allah, grant me steadfastness. Allah is one Whose help is to be sought.

Book 31, Number 5910:

    This hadith has been transmitted on the authority of Abu Musa al-Ash'ari with a slight variation of wording.

Book 31, Number 5911:

    Abu Musa Ash'ari reported that he performed ablution in his house and then came out saying: I would remain with Allah's Messenger (may peace be upon him) the whole day long. He came to the mosque, and asked about Allah's Apostle (may peace be upon him). They (his Companions) said: He has gone in this direction. He (Abu Musa Ash'ari) said: I followed his steps asking about him until I came to Bi'r Aris (it is a well in the suburb of Medina). I sat by its wooden door until Allah's Messenger (may peace be upon him) had relieved himself and then performed ablution. I went to him and he was sitting with his shanks uncovered hp to the knees and his legs dangl- ing in that well. I offered him salutations. I then came back and sat at the door as if I had been a chamberlain at the door of Allah's Messenger (may peace be upon him) that day. There came Abu Bakr and knocked the door and I said: Who is it? He said: This is Abu Bakr. I said: Wait, please. I went and said: Allah's Messenger, here is Abu Bakr seeking permission. Thereupon he said: Admit him and give him glad tidings of Paradise. I came and I said to Abu Bakr to get in (and also told him) that Allah's Messenger (may peace be upon him) was giving him the glad tidings of Paradise. Abu Bakr got in and sat on the right side of Allah's Messenger (may peace be upon him) and dangled his feet in the well as Allah's Messenger (may peace be upon him) had done, and he uncovered his shanks. I then returned and sat there and I had left my brother as he had been performing ablution and he was to meet me and I said: If Allah would intend goodness for such and such he would intend goodness for his brother and He would bring him. I was thinking this that a person stirred the door. I said: Who is it. He said: This is Umar b., Khattab. I said: Wait. Then I came to Allah's Messenger (may peace be upon him), greeted him and said: Here is 'Umar seeking your. permission to get in. Thereupon he said: Let him come in and give him glad tid- ings of Paradise. I came to Umar and said: There is permission for you and glad tidings for you from Allah's Messenger (may peace be upon him) for Paradise. He got in and sat on the left side of Allah's Messenger (may peace be upon him) with his feet dangling in the well. I then returned and sat and said: If Allah would intend goodness for such and such (that is for his brother), He would bring him. And I was contemplat- ing over it that a man stirred the door and I said: Who is it? He said: This is Uthman b. Affan. I said: Wait, please. I then came to Allah's Messenger (may peace be upon him) and informed him. and he said: Admit him and give him glad tidings (and inform) him of the turmoil which he shall have to face. I came and said: Get in, Allah's Messenger (may peace be upon him) gives you the glad tidings of Paradise along with the trial which you shall have to face. He got in and saw the elevated plan round the well fully occupied. He sat on the other side. Sharik said that Sa'id b. al-Musayyib reported: I drew a conclusion from it that their groves would be (in this very state, the graves of Hadrat Abu Bakr, 'Umar Faruq by the tide of the Holy Prophet [may peace be upon him] and the grave of Hadrat 'Uthman away from their graves).
    Abu Musa. reported: I set out with the intention (of meeting) Allah's Messenger (may peace be upon him) and came to know that he had gone to the gardens (in the suburb of Medina). I followed him and found him in a garden sitting upon an elevated place round the well with his shanks uncovered which had been dangling in the well. The rest of the hadith is the same but with this variation that there is no mention of the words of Sa'id: all drew a conclusion from it pertaining to their graves."

Book 31, Number 5912:

    Sa'id b. al-Musayyib reported Abu Musa Ash'ari having said that Allah's Messenger (may peace be upon him) set out one day to the suburbs of Medina for reliev- ing himself. I followed his steps. The rest of the hadith is the same. Ibn Musayyib said: I concluded (from the manner of their sitting) the (order) of their graves. (The three) would be together (the graves of the Holy Prophet, Hadrat Abu Bakr and Hadrat Umar) and that of 'Uthman would be separate (from them).

Chapter 4 : THE MERITS OF 'ALI B. ABI TALIB (ALLAH BE PLEASED WITH HIM)

Book 31, Number 5913:

    Amir b Sa'd b. Abi Waqqas reporte(l on the authority of his father that Allah's Messenger (may peace be upon him) addressing 'All said: You are in the same position with relation to me as Aaron-(Harun) was in relation to Moses but with (this explicit difference) that there is no prophet after me. Sa'd said : I had an earnest desire to hear it directly from Sa'd, so I met him and narrated to him what (his son) Amir had narrated to me, whereupon he said: Yes, I did hear it. I said: Did you hear it yourself? Thereupon he placed his fingers upon his ears and said: Yes, and if not, let both my ears become deaf.

Book 31, Number 5914:

    Sa'd b. Abi Waqqas reported that Allah's Messenger (may peace be upon him) left 'Ali b. Abi Talib behind him (as he proceeded) to the expedition of Tabuk, whereupon he ('Ali) said: Allah's Messenger, are you leaving me behind amongst women 4nd children ? Thereupon he (the Holy Prophet) said: Aren't you satisfied with being unto me what Aaron was unto Moses but with this exception that there would be no prophet after me.

Book 31, Number 5915:

    This hadith has been narrated.on the authority of Shu'ba with the same chain of transmitters. Amir b. Sa'd b. Abi Waqqas reported on the authority of his father that Muawiya b. Abi Sufyin appointed Sa'd as the Governor and said: What prevents you from abusing Abu Turab (Hadrat 'Ali), whereupon be said : It is because of three things which I remember Allah's Messenger (may peace be upon him) having said about him that I would not abuse him and even if I find one of those three things for me, it would be more dear to me than the red camelg. I heard Allah's Messenger (may peace be upon him) say about 'Ali as he left behind hrin in one of his campaigns (that was Tabuk). 'All said to him: Allah's Messenger, you leave me behind along with women and children. Thereupon Allah's Messenger (may peace be upon him) said to him: Aren't you satisfied with being unto me what Aaron was unto Moses but with this exception that there is no prophethood after me. And I (also) heard him say on the Day of Khaibar: I would certainly give this standard to a person who loves Allah and his Messenger and Allah and his Messenger love him too. He (the narrator) said: We have been anxiously waiting for it, when he (the Holy Prophet) said: Call 'Ali. He was called and his eyes were inflamed. He applied saliva to his eyes and handed over the standard to him, and Allah gave him victory. (The third occasion is this) when the (following) verse was revealed: "Let us summon our children and your children." Allah's Messenger (may peace be upon him) called 'Ali, Fitima, Hasan and Husain and said: O Allah, they are my family.

Book 31, Number 5916:

    Sa'd reported Allah's Apostle (may peace be upon him) as saying to 'Ali: Aren't you satisfied with being unto me what Aaron was unto Moses?

Book 31, Number 5917:

    Suhail reported on the authority of Abu Huraira that Allah's Messenger (may peace be upon him) said on the Day of Khaibar: I shall certainly give this standard in the hand of one who loves Allah and his Messenger and Allah will grant victory at his hand. Umar b. Khattab said: Never did I cherish for leadership but on that day. I came before him with the hope that I may be called for this, but Allah's Messenger (may peace be upon him) called 'Ali b. Abu Talib and he conferred (this honour) upon him and said: Proceed on and do not look about until Allah grants you victory, and 'Ali went a bit and then halted and did not look about and then said in a loud voice: Allah's Messenger, on what issue should I fight with the people? Thereupon he (the Prophet) said : Fight with them until they bear testimony to the fact that there is no god but Allah and Muhammad is his Messenger, and when they do that then their blood and their riches are inviolable from your hands but what is justified by law and their reckoning is with Allah.

Book 31, Number 5918:

    Sahl b. Sa'd reported that Allah's Messenger (may peace be upon him) said on the Day of Khaibar : I would certainly give this standard to a person at whose hand Allah would grant victory and who loves Allah and His Messenger and Allah and His Messenger love him also. The people spent the night thinking as to whom it would be given. When it was morning the people hastened to Allah's Messenger (may peace be upon him) all of them hoping that that would be given to him. He (the Holy Prophet) said: Where is 'Ali b. Abu Talib? They said: Allah's Messenger, his eyes are sore. He then sent for him and he was brought and Allah's Messenger (may peace be upon him) applied saliva to his eyes and invoked blessings and he was all right, as if he had no ailment at all, and coraferred upon him the standard. 'Ali said: Allah's Messenger, I will fight them until they are like us. Thereupon he (the Holy Prophet) said: Advance cautiously until you reach their open places, thereafter invite them to Islam and inform them what is obligatory for them from the rights of Allah, for, by Allah, if Allah guides aright even one person through you that is better for you than to possess the most valuable of the camels.

Book 31, Number 5919:

    Salama b. Akwa' reported that it was 'Ali whom Allah's Apostle (may peace be upon him) left behind him (in the charge of his family and the Islamic State) on the occasion of the campaign of Khaibar, and his eyes were inflamed and he said: Is it for me to remain behind Allah's Messenger (may peace be upon him)? So he went forth and rejoined Allah's Apostle (may peace be upon him) and on the evening of that night (after which) next morning Allah granted victory. Allah's Messenger (may peace be upon him) said: I will certainly give this standard to a man whom Allah and His Messenger love. or he said: Who loves Allah or His Messenger and Allah will grant him victory through him, and, lo, we saw 'Ali whom we least expected (to be present on that occasion). They (the Companions) said: Here is 'Ali. Thereupon Allah's Messenger (may peace be upon hin) gave him the standard. Allah granted victory at his hand.

Book 31, Number 5920:

    Yazid b. Hayyan reported, I went along with Husain b. Sabra and 'Umar b. Muslim to Zaid b. Arqam and, as we sat by his side, Husain said to him: Zaid. you have been able to acquire a great virtue that you saw Allah's Messenger (may peace be upon him) listened to his talk, fought by his side in (different) battles, offered prayer behind me. Zaid, you have in fact earned a great virtue. Zaid, narrate to us what you heard from Allah's Messenger (may peace be upon him). He said: I have grown old and have almost spent my age and I have forgotten some of the things which I remembered in connection with Allah's Messenger (may peace be upon him), so accept whatever I narrate to you, and which I do not narrate do not compel me to do that. He then said: One day Allah's Messenger (may peace be upon him) stood up to deliver sermon at a watering place known as Khumm situated between Mecca and Medina. He praised Allah, extolled Him and delivered the sermon and. exhorted (us) and said: Now to our purpose. O people, I am a human being. I am about to receive a messenger (the angel of death) from my Lord and I, in response to Allah's call, (would bid good-bye to you), but I am leaving among you two weighty things: the one being the Book of Allah in which there is right guidance and light, so hold fast to the Book of Allah and adhere to it. He exhorted (us) (to hold fast) to the Book of Allah and then said: The second are the members of my household I remind you (of your duties) to the members of my family. He (Husain) said to Zaid: Who are the members of his household? Aren't his wives the members of his family? Thereupon he said: His wives are the members of his family (but here) the members of his family are those for whom acceptance of Zakat is forbidden. And he said: Who are they? Thereupon he said: 'Ali and the offspring of 'Ali, 'Aqil and the offspring of 'Aqil and the offspring of Ja'far and the offspring of 'Abbas. Husain said: These are those for whom the acceptance of Zakat is forbidden. Zaid said: Yes.

Book 31, Number 5921:

    This hadith has been narrated on the authority of Zaid b. Arqam through another chain of transmitters.

Book 31, Number 5922:

    This hadith has been transmitted on the authority of Abu Hayyan but with this addition: "The Book of Allah contains right guidance, the light, and whoever adheres to it and holds it fast, he is upon right guidance and whosoever deviates from it goes astray.

Book 31, Number 5923:

    Yazid b. Hayyan reported: We went to him (Zaid b. Arqam) and said to him. You have found goodness (for you had the honour) to live in the company of Allah's Messenger (may peace be upon him) and offered prayer behind him, and the rest of the hadith is the same but with this variation of wording that lie said: Behold, for I am leaving amongst you two weighty things, one of which is the Book of Allah, the Exalted and Glorious, and that is the rope of Allah. He who holds it fast would be on right guidance and he who abandons it would be in error, and in this (hadith) these words are also found: We said: Who are amongst the members of the household ? Aren't the wives (of the Holy Prophet) included amongst the members of his house hold? Thereupon he said: No, by Allah, a woman lives with a man (as his wife) for a certain period; he then divorces her and she goes back to her parents and to her people; the members of his household include his ownself and his kith and kin (who are related to him by blood) and for him the acceptance of Zakat is prohibited.

Book 31, Number 5924:

    Sahl b. Sa'd reported that a person from the offspring of Marwan was appointed as the governor of Medina. He called Sahl b. Sa'd and ordered him to abuse All Sahl refused to do that. He (the governor) said to him: If you do not agree to it (at least) say: May Allah curse Abu Turab. Sahl said: There was no name dearer to All than Abu Turab (for it was given to him by the Holy Prophet himself) and he felt delighted when he was called by this name. He (the governor) said to him: Narrate to us the story of his being nanied as Abu Turab. He said: Allah's Messenger (may peace be upon him) came to the house of Fatima and he did not find 'Ali in the house; whereupon he said: Where is your uncle's son? She said: (There cropped up something) between me and him which had annoyed him with me. He went out and did not rest here. Allah's Messenger (may peace be upon him) said to a person to find out where he was. He came and said: Allah's Messenger, he is sleeping in the mosque. Allah's Messenger (may peace be upon him) came to him and found him lying in the mosque and saw that his mantle had slipped from his back and his back was covered with dust and Allah's Messenger (may peace be upon him) began to wipe it away from him (from the body of Hadrat 'Ali) saying: Get up, covered with dust; get up, covered with dust.

Chapter 5 : MERITS OF SA'D B. ABI WAQQAS (ALLAH BE PLEASED WITH HIM)

Book 31, Number 5925:

    'A'isha reported that Allah's Messenger (may peace he upon him) lay on bed during one night and said: Were there a pious person from amongst my companions who should keep a watch for me during the nightt? She said: We heard the noise of arms, whereupon Allah's Messenger (may peace be upon him) said: Who is it ? And Sa'd b. Abi Waqqas said: Allah's MesseDger. I have come to serve as your sentinel. 'A'isha said: Allah' s Messenger (may peace be upon him) slept (such a sound sleep) that I heard the noise of his snoring.

Book 31, Number 5926:

    'A'isha reported that Allah's Messenger (may peace he upon him) laid down on bed during one night on his arrival at Medina and said: Were there a pious person from amongst my Companions who should keep a watch for me durin. the night? She (A'isha) reported: We were in this state that we heard the clanging noise of arms. lie (the Holy Prophet) said: Who is it? He said: This is Sa'd b. Abi Waqqas. Allah's Messenger (may peace be upon him) said to him: What brings you here? Thereupon he said: I harboured fear (lest any harm should come to) Allah's Messenger (may peace be upon him), so I came to serve as your sentinel. Allah's Messenger (may peace be upon him) invoked blessings upon him. He then slept. This hadith has been transmitted on the authority of Ibn Rumh with a slight variation of wording.

Book 31, Number 5927:

    'Abdullah b. 'Amir b. Rabi reported A'isha as saying: Allah's Messenger (may peace be upon him) went to bed one night; the rest of the hadith is the same.

Book 31, Number 5928:

    'Abdullah b. Shaddad reported that he heard 'Allahs saying: Allah's Messenger (may peace be upon him) did not gather his parents except in case of Sa'd b. Malik that he said to him on the Day of Ubud: Shoot an arrow, may my father and mother be taken as ransom for you.

Book 31, Number 5929:

    This hadith has been narrated on the authority of 'Ali through another chain of transmitters.

Book 31, Number 5930:

    Sa'd b Abi Waqqqs said: Allah's Messenger (may peace he upon him) gathered his parents for me on the Day of Uhud.

Book 31, Number 5931:

    This hadith has been narrated on the authority of Yabyl b. Sa'id with the same chain of transmitters.

Book 31, Number 5932:

    'Amir b. Sa'd reported oLi the authority of his father that Allah's Apostle (may peace be upon him) gathered for him on the Day of Uhud his parents when a polytheist had set fire to (i.e. attacked fiercely) the Muslims. Thereupon Allah's Apostle (may peace be upon him) said to him: (Sa'd), shoot an arrow, (Sa'd), may my mother and father be taken as ransom for you. I drew an arrow and I shot a featherless arrow at him aiming his side that lie fell down and his private parts were exposed. Allah's Messenger (may peace be upon him) laughed that I saw his front teeth.

Book 31, Number 5933:

    Mus'ab b. Sa'd reported on the authority of his father that many verses of the Qur'an had been revealed in connection with him. His mother Umm Sa'd had taken oath that she would never talk with him until he abandoned his faith and she neither ate nor drank and said: Allah has commanded you to treat well your parents and I am your mother and I command you to do this. She passed three days in this state until she fainted because of extreme hunger and at that time her son whose name was Umara stood up and served her drink and she began to curse Sa'd that Allah, the Exalted and Glorions, revealed these verses of the Holy Qur'an: "And We have enjoined upon a person goodness to his parents but if they contend with thee to associate (others) with Me of which you have no knowledge, then obey them not" (xxix. 8); Treat thein with customary good in this world" (xxxi. 15). He also reported that there fell to the lot of Allah's Messenger (may peace be upon him) huge spoils of war and there was one sword in them. I picked that up and came to Allah's Messenger (may peace be upon him) and said: Bestow this sword upon me (as my share in the spoils of war) and you know my state. Thereupon he said: Return it to the place from where you picked it up. I went back until I decided to throw it in a store but my soul repulsed me so I came back and asked him to give that sword to me. He said in a loud voice to return it to the place from where I had picked it up. It was on this occasion that this verse was revealed: "They asked about the spoils of war" (viii. 1). He further said: I once fell ill and sent a message to Allah's Apostle (may peace be upon him). He visited me and I said to him: Permit me to distribute (in charity) my property as much as I like. He did not agree. I said: (Permit me to distribute) half of it. He did not agree. I said : (Permit me to distribute) the third part, whereupon he kept quiet and it was after this (that the distribution of one's property in charity) to the extent of one-third was held valid. He further said: I came to a group of persons of the Ansir and Muhajirin and they said: Come, so that we may serve you wine, and it was before the use of wine had been prohibited. I went to them in a garden and there had been with them the roasted head of a camel and a small water-skin containing wine. I ate and drank along with them and there came under discussion the Ansr (Helpers) and Muhajirin (immigrants). I said : The immigrants are better than the Ansar, that a person picked up a portion of the head (of the camel and struck me with it that my nose was injured. I came to Allah's Messenger (may peace be upon him) and informed him of the situation that Aliah, the Exalted and Glorious, revealed verses pertaining to wine: "Intoxicants and the games of chance and (sacrificing to) stones set up and (divining by) arrows are only an uncleanliness, the devil's work" (v. 90).

Book 31, Number 5934:

    This hadith has been transmitted on the authority of Simak and the hadith transmitted on the authority of Shu'ba (the words are) : When they intended to feed her (Sa'd'.s mother), they opened her mouth with the help of a stick and then put the feed in her mouth, and in the same hadith the words are: He struck the nose of Sa'd and it was injured and Sa'd had (the mark) of wound on his nose.

Book 31, Number 5935:

    Sa'd reported: This verse was revealed in relation to six persons and I and Ibn Mas'ud were amongst them. The polytheists said to him (the Holy Prophet) : Do not keep such persons near you. It was upon this that (this verse was revealed) : "Drive not away those who call upon their Lord morning and evening desiring only His pleasure" (vi. 52).

Book 31, Number 5936:

    Sa'd reported: We were six men in the company of Allah's Messenger (,nay peace be upon him) that the polytheists said to Allah's Apostle (may peace be upon him) : Drive them away so that they may not be overbold upon us. He said : I, Ibn Mas'ud and a person from the tribe of Hudhail, Bilal and two other persons, whose names I do not know (were amongst such persons). And there occurred to Allah's Messenger (may peace be upon him) what. Allah wished and he talked with himself that Allah, the Exalted and Glorious, revealed: "Do not drive away those who call their Lord morning and evening desiring to seek His pleasure."

Chapter 6 : THE MERITS OF ZUBAIR AND TALHA (ALLAH BE PLEASED WITH BOTH OF THEM)

Book 31, Number 5937:

    Abu 'Uthman reported on one of the days when Allah's Messenger (may peace be upon him) was fighting and none remained with him save Talha and Sa'd.

Book 31, Number 5938:

    Jabir b. Abdullah reported: I heard Allah's Messenger (may peace be upon him) exhorting people on the Day of the Battle of the Ditch to fight. Zubair said: I am ready (to participate). He then again exhorted and he again said : I am ready to participate. Thereupon Allah's Messenger (may peace be upon him) said: Behold. for every Prophet there is a helper and my helper is Zubair.

Book 31, Number 5939:

    Jabir reported this hadith through another chain of transmitters.

Book 31, Number 5940:

    'Abdullah b. Zubair reported on the Day of the Battle of the Trench: I and Umar b. Abu Salama were with women folk in the fort of Hassan (b. Thabit). He at one time leaned for me and I cast a glance and at anothertime I leaned for him and he would see and I recognised my father as he rode on his horse with his arms towards the tribe of Quraizah. 'Abdullah b. 'Urwa reported from Abdullah b. Zubair: I made a mention of that to my father, whereupon he said: My son, did you see me (on that occasion) ? He said: Yes. Thereupon he said: By Allah, Allah's Messenger (may peace be upon him) addressed me saying : I would sacrifice for thee my father and my mother.

Book 31, Number 5941:

    'Abdullah b. Zubair reported: When it was the Day of the Battle of the Ditch I and 'Umar b. Salama were in the fort in which there were women, i.e. the wives of Allah's Apostle (may peace be upon him); the rest of the hadith is the same.

Book 31, Number 5942:

    Abu Huraira reported: Allah's Messenger (may peace be upon him) was upon the mountain of Hira,' and there were along with him Abu Bakr, Umar, Uthman. 'Ali, Talha, 'Zubair, that the mountain stirred; thereupon Allah's Messenger (may peace be upon him) said : Be calm, there is none upon you but a Prophet, a Fiddle (the testifier of truth) and a Martyr.

Book 31, Number 5943:

    Abu Huraira reported that Allah's Messenger (may peace be upon him) was on the mountain of Hira' that it stirred; thereupon Allah's Messenger (may peace be upon him) said: Hira! be calm, for there is none upon you but a Prophet, a Siddiq, a Shahid, and there were upon it Allah's Prophet (may peace be upon him), Abu Bakr, 'Umar, Uthman, 'Ali, Talha, Zubair, Sa'd b. Abi Waqqas (Allah be pleased witli them).

Book 31, Number 5944:

    Hisham reported on the authority of his father ('Urwa b. Zubair) that A'isha said : BY Allah, both fathers of yours are amongst those who have been men. tioned in this verse: "Those who responded to the call of Allah and the Messenger after the misfortune had fallen upon thein" .

Book 31, Number 5945:

    This hadith has been narrated on the authority of Hishan through the same chain of transmitters but with this addition (that by both fathers of yours) he meant Abu Bakr and Zubair.

Book 31, Number 5946:

    'Urwa reported: 'Aisha said to me: Your fathers (Zubair and Abu Bakr) were amongst those about whom (it has been revealed): "Those who responded to the call of Allah and His Messenger after the misfortune had fallen upon them."

Chapter 7 : THE MERITS OF ABU 'UBAIDA B. JARHAH (ALLAH BE PLEASED WITH HIM)

Book 31, Number 5947:

    Anas reported Allah's Messenger (may peace be upon him) as saying: For every Umma there is a man of trust and the man of trust of this Umma is Abu 'Ubaida b. Jarrah.

Book 31, Number 5948:

    Anas reported that the people of Yemen came to Allah's Messenger (may peace be upon him) and said: Send with us a person who should teach us Sunnah and al-Islam, whereupon he (the Holy Prophet) caught hold of the hand of Ubaida and said: He is a man of trust of this Umma.

Book 31, Number 5949:

    Hudhaifa reported that the people of Najran came to Allah's Messenger (may peace be upon him) and said: Allah's Messenger, send along with us a man of trust; whereupon he said: I would definitely send to you a man of trust, a man of trust in the true sense of the term. Thereupon his Companions looked up eagerly and he sent Abu Ubaida b. Jarrah.

Book 31, Number 5950:

    This hadith has been reported on the authority of Abu Ishaq with the same chain of transmitters.

Chapter 8 : THE MERITS OF HASAN AND HUSAIN (ALLAH BE PLEASED WITH BOTH OF THEM)

Book 31, Number 5951:

    Abu Huraira reported Allah's Messenger (may peace be upon him) as saying to Hasan: O Allah, behold, I love him. Thou too love him and love one who loves him.

Book 31, Number 5952:

    Abu Huraira reported: I went along with Allalh's Messenger (may peace be upon him) at a time during the day but he did not talk to me and I did not talk to him until he reached Bazar of Banfi Qainuqal. He came back to the tent of Fatima and said: Is the little chap (meaning Hasan) there ? We were under the impression that his mother had detained him in order to bathe him and dress him and garland him with a sweet garland. Not much time had passed that he (Hasan) came running until both of them embraced each other, thereupon Allah's Messenger (may peace be upon him) said: O Allah, I love him; love him Thou and love one who loves him (Hasan).

Book 31, Number 5953:

    Al-Bara' b. Azib reported: I saw Hasan b. 'Ali upon the shoulders of Allah's Apostle (may peace be upon him) and he was saying: O Allah, I love him, and love him Thou.

Book 31, Number 5954:

    Iyas reported on the authority of his father: I (had the honour of) leading the white mule on which rode Allah's Apostle (may peace be upon him) and with him were Hasan and Husain, till it reached the apartment of Allah's Apostle (may peace be upon him). The one amongst them was seated before him and the other one was seated behind him.

Chapter 9 : THEE MERITS OF THE FAMILY OF THE PROPHET (MAY PEACE BE UPON HIM)

Book 31, Number 5955:

    'A'isha reported that Allah's Apostle (may peace be upon him) went out one norning wearing a striped cloak of the black camel's hair that there came Hasan b. 'Ali. He wrapped hitn under it, then came Husain and he wrapped him under it along with the other one (Hasan). Then came Fatima and he took her under it, then came 'Ali and he also took him under it and then said: Allah only desires to take away any uncleanliness from you, O people of the household, and purify you (thorough purifying)

Chapter 10 : MERITS OF ZAID b. HARI'TH AND USAMA b. ZAID (ALLAH BE PLEASED WITH THEM)

Book 31, Number 5956:

    Salim b. 'Abdullah reported on the authority of his father: We were in the habit of calling Zaid b. Harith as Zaid b. Muhammad until it was revealed in the Qur'an: "Call them by the names of their fathers. This is more equitable with Allah" (This hadith has been transmitted on the authority of Qutaiba b. Sa'd)

Book 31, Number 5957:

    This hadith has been narrated on the authority 'Abdullah through another chain of transmitters.

Book 31, Number 5958:

    Ibn 'Umar reported that Allah's Messenger (may peace be upon him) sent an expedition and appointed Usama b. Zaid as its chief. The people objected to his command, whereupon Allah's Messenger (may peace be upon him) stood up and said: You object to his command and before this you objected to the command of his father (Zaid). By Allah, he was fit as the commander and he was one of the dearest of persons to me and after him, behold! this one (Usama) is one of the dearest of persons to me.

Book 31, Number 5959:

    Salim reported on the authority of his father that Allah's Messenger (may peace be upon him) said on the pulpit: You object to the command of Usima b. Zaid as you had objected before to the command of his father (Zaid). By Allah, he was most competent for it and, by Allah, he was dearest to me amongst people and, by Allah, the same is the case with Usama b. Zaid. He is most dear to me after him and I advise you to treat him well for he is pious amongst you.

Chapter 11 : THE MERITS OF'ABDULLAH B. JA'FAR (ALLAH BE PLEASED WITH HIM)

Book 31, Number 5960:

    Abdullah b. Abu Mulaika reported that Abdullah b. Jafar said to Ibn Zubair: Do you remember (the occasion) when we three (i.e. I, you and lbn 'Abbas) met Allah's Messenger (may peace be upon him) and he mounted us (on his camel) but left you? He said: Yes.

Book 31, Number 5961:

    This hadith has been transmitted on the authority of Habib b. Ash-Shahid.

Book 31, Number 5962:

    Abdullah b. Ja'far reported that when Allah's Messenger (may peace be, upon him) came back from a journey, the children of his family used to accord him welcome. It was in this way that once he came back from a journey and I went to him first of all. He mounted me before him. Then there came one of the two sons of Fatima and he mounted him behind him and this is how we three entered Medina riding on a beast.

Book 31, Number 5963:

    Abdullah b. Ja'a'far reported that when Allah's Messenger (may peace be upon him) came back from a journey he met us. Once he met me, Hasan or Husain, and he mounted one of us before him and the other one behind him until we entered Medina.

Book 31, Number 5964:

    Abdullah b. Ja'far reported that one day Allah's Messenger (may peace be upon him) mounted me behind him and narrated to me something in secret which I would narrate to none amongst people.

Chapter 12 : THE MERITS OF HADRAT KHADIJA, MOTHER OF THE FAITHFUL (ALLAH BE PLEASED WITH HER)

Book 31, Number 5965:

    Abdullah b. Ja'far reported that he heard 'All say in Kulfa that Allah's Messenger (may peace be upon him) said: The best of the women of her time was Mary, daughter of 'Imran, and the best of the women of her time was Khadija, daughter of khuwailid. Abu Kuraib said that Wakil pointed towards the sky and the earth

Book 31, Number 5966:

    Abu Musa reported Allali's Messenger (may peace be upon him) as saying: There are many persons amongst men who are quite perfect but there are not perfect amongst women except Mary, daughter of 'Imran, Asiya wife of Pharaoh, and the excellence of 'A'isha as compared to women is that of Tharid over all other foods.

Book 31, Number 5967:

    Abu Huraira reported that Gabriel came to Allah's Apostle (may peace be upon him) and said: Allah's Messenger, lo. Khadija is coming to you with a vessel of seasoned food or drink. When she comes to you, offer her greetings from her Lord, the Exalted and Glorious, and on my behalf and give her glad tidings of a palace of jewels in Paradise wherein there is no noise and no toil. This hadith has been narrated on the authority of Abu Huraira through another chain of transmitters with a slight variation of wording.

Book 31, Number 5968:

    Ismail reported: I said to 'Abdullah b. Abi Aufa: Did Allah's Messenger (may peace be upon him) give glad tidings of Paradise to Khadija ? He said : Yes. He did give glad tidings to her of a palace of jewels in Paradise wherein there would be no noise and no toil.

Book 31, Number 5969:

    This hadith has been narrated on the a tliority of Ibn Abi Aufa through other chains of transmitters.

Book 31, Number 5970:

    'A'isha reported that Allali's, Messenger (may peace he upon him) gave grid tidings to Khadija int Khuwailid of a palace in Paradise.

Book 31, Number 5971:

    'A'isha reported: Never did I feel jealous of any woman as I was jealous of Khadija. She had died three years before he (the Holy Prophet) married me. I often heard him praise her, and his lord, the Exalted and Glorious, had commanded him to give her the glad tidings of a palace of jewels in Paradise: and whenever he slaughtered a sheep he presented (its meat) to her female companions.

Book 31, Number 5972:

    'A'isha reported: Never did I feel jealous of the wives of Allah's Apostle (may peace be upon him) but in case of Khadija, although I did no, (have the privilege to) see her. She further added that whenever Allah's Messenger (may peace be upon him) slaughtered a sheep, he said : Send it to the companions of Khadija I annoyed him one day and said : (It is) Khadija only who always prevails upon your mind. Thereupon Allah's Messenger (may peace be upon him) said: Her love had been nurtured in my heart by Allah Himself.

Book 31, Number 5973:

    This hadith has been transmitted on the authority of Abu Usama up to the slaughtering of a sheep, but he. did not make mention of the subsequent words.

Book 31, Number 5974:

    'A'isha reported : Never did I feel jealous of any wife amongst the wives of Allah's Apostle (may peace be upon him) as I feel in case of Khadija (though I had never seen her), for he praised her very often.

Book 31, Number 5975:

    'A'isha reported that Allah's Apostle (may peace be upon him) did not marry any other woman till her (Khadija's) death.

Book 31, Number 5976:

    A'isha reported that Hala b.Khuwailid (sister of Khadija)sought permission from Allah's Messenger (may peace be upon him) to see him and he was reminded of Khadija's (manner of) asking leave to enter and (was overwhelmed) with emotions thereby and said: O Allah, it is Hala, daughter of Khuwailid, and I felt jealous and said: Why do you remember one of those old women of the Quraish with gums red and who is long dead-while Allah has given you a better one in her stead ?

Chapter 13 : THE MERITS OF 'A'ISHA (ALLAH BE PLEASED WITH HER)

Book 31, Number 5977:

    'A'isha reported Allah's Messenger (may peace be upon him) having said: I saw you in a dream for three nights when an angel brought you to me in a silk cloth and he said: Here is your wife, and when I removed (the cloth) from your face, lo, it was yourself, so I said: If this is from Allah, let Him carry it out.

Book 31, Number 5978:

    This hadith has been narrated on the authority of Hisham with the same chain of transmitters.

Book 31, Number 5979:

    'A'isha reported: Allah's Messenger (may peace be upon him) said to me: I can well discern when you are pleased with me and when you are annoyed with me. I said: How do you discern it ? Thereupon be said: When you are pleased with me you say; "No, by the Lord of Muhammad," and when you are annoyed with me, you say: "No, by the Lord of Ibrahim." I said: Allah's Messenger, by Allah, I in fact leave your name (when I am annoyed with you).

Book 31, Number 5980:

    This hadith has been reported on the authority of Hishim b. 'Urwa with the same chain of transmitters up to the words: "No, by the Lord of Ibrahim," and he did not make mention of what follows subsequently.

Book 31, Number 5981:

    'A'isha reported that she used to play with dolls in the presence of Allah's Messenger (may peace be upon him) and when her playmates came to her they left (the house) because they felt shy of Allah's Messenger (may peace be upon him), whereas Allah's Messenger (may peace be upon him) sent them to her.

Book 31, Number 5982:

    This hadith has been narrated on the authority of Hisham with the same chain of transmitters with a slight variation of wording.

Book 31, Number 5983:

    'A'isha reported that people sent their gifts when it was the turn of 'A'isha seeking thereby the pleasure of Allah's Messenger (may peace be upon him).

Book 31, Number 5984:

    'A'isha, the wife of Allah's Apostle (may peace be upon him), said: The wives of Allah's Apostle (may peace be upon him) sent Fatima, the daughter of Allah's Messenger (may peace be upon him), to Allah's Apostle (may peace be upon him).She ouaht permission to get in as he had been lying with me in my mantle. He gave her permission and she said : Allah's Messenger, verily, your wives have sent me to you in order to ask you to observe equity in case of the daughter of Abu Quhafa. She ('A'isha) said: I kept quiet. Thereupon Allah's Messenger (may peace be upon him) said to her (Fatima): 0 daughter, don't you love whom I love? She said: Yes, (I do). Thereupon he said: I love this one. Fatima then stood up as she heard this from Allah's Messenger (may peace be upon him) and went to the wives of Allatt's Apostle (may peace be upon him) and informed them of what she had said to him and what Allah's messenger (may peace be upon him) had said to her. Thereupon they said to her: We think that you have been of no avail to us. You may again go to Allah's Messenger (may peace be upon him) and tell him that his wives seek equity in case of the daughter of Abu Quhafa. Fitima said: By Allah, I will never talk to him about this matter. 'A'isha (further) reported: The wives of Allah's Apostle (may peace be upon him) then sent Zainab b. jahsh, the wife of Allah's Apostle (may peace be upon him), and she was one who was somewhat equal in rank with me in the eyes of Allah's Messenger (may peace be upon him) and I have never seen a woman more advanced in religious piety than Zainab, more God-conscious, more truthful, more alive to the ties of blood, more generous and having more.sense of self-sacrifice in practical life and having more charitable disposition and thus more close to God, the Exalted, than her. She, however, lost temper very soon but was soon calm. Allah's Messenger (may peace be upon him) permitted her to enter as she ('A'isha) was along with Allah's Messenger (may peace be upon him) in her mantle, in the same very state when Fatima had entered. She said: Allah's Messenger, your wives have sent me to you seeking equity in case of the daughter of Abu Quhafa. She then came to me and showed harshness to me and I was seeing the eyes of Allah's Messenger (may peace be upon him) whether he would permit me. Zainab went on until I came to know that Allah's Messenger (may peace be upon him) would not disapprove if I retorted. Then I exchanged hot words until I made her quiet. Thereupon Allah's Messenger (may peace be upon him) smiled and said: She is the daughter of Abu Bakr. This hadith has been narrated on the authority of Zuhri with the same chain of transmitters, but with a slight variation of wording.

Book 31, Number 5985:

    'A'isha reported that Allah's Messenger (may peace be upon him) during his last illness) inquired : Where I would be tomorrow, where I would be tomorrow (thinking, that the turn of 'A'isha was not very near) and when it was my turn, Allah called him to his Heavenly Home and his head was between my neck and chest.

Book 31, Number 5986:

    A'isha reported that Allah's Messenger (may peace be upon him) at the time of breathing his last was reclining against her chest and she was leaning over him and listening to him as he was saying: O Allah, grant me pardon, show mercy to me, enjoin me to companions (on High).

Book 31, Number 5987:

    This hadith has been narrated on the authority of Hisham through another chain of transmitters.

Book 31, Number 5988:

    'A'isha reported : I heard that never a prophet dies until he is given an option to opt the life of (this) world or that of the Hereafter. She further said: I heard Allah's Messenger (may peace be upon him) say in his last illness in which he' died. I heard him saying in gruffness of the voice: Along with those persons upon whom Allah bestowed favours from amongst the Apostles, the testifiers of truth, the martyrs, the pious and goodly company are they (iv. 69). (It was on bearing these words) that I thought that he had been given choice (and he opted to live with these pious persons in the Paradise).

Book 31, Number 5989:

    This hadith has been narrated on the authority of Sa'd with the same chain of transmitters.

Book 31, Number 5990:

    'A'isha, the wife of Allah's Apostle (may peace be upon him), reported that he used to say: Never a prophet dies in a state that he is not made to see his abode in Paradise, and then given a choice. 'A'isha said that when Allah's Messenger (may peace be upon him) was about to leave the world, his head was over her thigh and he had fallen into swoon three times. When he felt relief his eyes were fixed at the ceiling. He then said: O Allah, along with the high companions (i.e. along with the Apostles who live in the most elevated place of the Paradise). (On hearing these words), I then said (to myself) He is not going to opt us and I remembered a hadith which he had narrated to us as he was healthy and in which he said: No prophet dies until he sees his abode in Paradise, he is then given a choice. 'A'isha said : These were the last words which Allah's Messenger (may peace be upon him) spoke (the words are) : O Allah, with companions on High.

Book 31, Number 5991:

    'A'isha reported that when Allah's Messenger (may peace be upon him) set ont on a journey, he used to cast lots amongst his wives. Once this lot came out in my favour and that of Hafsa. They (Hafsi, and 'A'isha) both went along with him and Allah's Messenger (may peace be upon him) used to travel (on camel)when it was night along with 'A'isha and talked with her. Hafsa said to 'A'isha: Would you like to ride upon my camel tonight and allow me to ride upon your camel and you would see (what you do not generally see) and I would see (what I do not see) generally ? She said: Yes. So 'A'isha rode upon the camel of Hafsa and Hafsa rode upon the camel of 'A'isha and Allah's Messenger (may peace be upon him) came near the camel of 'A'isha. (whereas) Hafsa had been riding over that. He greeted her and then rode with her until they came down. She ('A'isha) thus missed (the company of the Holy Prophet) and when they sat down, 'A'isha felt jealous. She put her foot in the grass and said : O Allah, let the scorpion sting me or the serpent bite me. And so far as thy Messenger is concerned, I cannot say anything about him.

Book 31, Number 5992:

    Anas b. Malik reported Allah's Messenger (may peace be upon him) as saying: The excellence of 'A'isha over women is like the excellence of Tharid over all other foods.

Book 31, Number 5993:

    This hadith has been narrated on the authority of Anas b. Malik through other chains of transmitters.

Book 31, Number 5994:

    'A'isha reported that Allah's Messenger (may peace be upon him) said to her: Gabriel offered you greetings and I said: So there should be peace and mercy of Allah upon him.

Book 31, Number 5995:

    This hadith has been narrated on the authority of 'A'isha through another chain of transmitters.

Book 31, Number 5996:

    This hadith has been narrated on the authority of Zakriyya' through another chain of transmitters.

Book 31, Number 5997:

    'A'isha, the wife of Allah's Apostle (may peace be upon him), reported that Allah's Messenger (may peace be upon him) said : 'A'isha, here is Gabriel offering you greetings. She said: 1 made a reply : Let there be peace and blessings of Allah upon him, and added: He sees what I do not see.

Chapter : THE HADITH OF UMM ZARA

Book 31, Number 5998:

    'A'isha reported that (one day) there sat together eleven women making an explicit promise amongst themselves that they would conceal nothing about their spouses. The first one said: My husband is a sort of the meat of a lean camel placed at the top of a hill, which it is difficult to climb up, nor (the meat) is good enough that one finds in oneself the urge to take it away (from the top of that mountain).
    The second one said: My husband (is so bad) that I am afraid I would not be able to describe his faults-both visible and invisible completely.
    The third one said: My husband is a long-statured fellow (i.e. he lacks intelligence). If I give vent to my feelings about him, he would divorce me, and if I keep quiet I would be made to live in a state of suspense (neither completely abandoned by him nor entertained as wife).
    The fourth one said: My husband is like the night of Tihama (the night of Hijaz and Mecca), neither too cold nor hot, neither there is any fear of him nor grief.
    The fifth one said: My husband is (like) a leopard as he enters the house, and behaves like a lion when he gets out, and he does not ask about that which he leaves in the house.
    The sixth one said: So far as my husband is concerned, he eats so much that nothing is left back and when he drinks he drinks that no drop is left behind.And when he lies down he wraps his body and does not touch me so that he may know my grief.
    The seventh one said: My husband is heavy in spirit, having no brightness in him, impotent, suffering from all kinds of conceivable diseases, heaving such rough manners that he may break my head or wound my body, or may do both.
    The eighth one said: My husband is as sweet as the sweet-smelling plant, and as soft as the softness of the hare.
    The ninth one said: My husband is the master of a lofty building, long-statured, having heaps of ashes (at his door)and his house is near the meeting place and the inn.
    The tenth one said: My husband is Malik, and how fine Malik is, much above appreciation and praise (of mine). He has many folds of his camel, more in number than the pastures for them. When they (the camels) hear the sound of music they become sure that they are going to be slaughtered.
    The eleventh one said: My husband is Abu Zara'. How fine Abu Zara' is ! He has suspended in my ears heavy ornaments and (fed me liberally) that my sinews and bones are covered with fat. So he made me happy. He found me among the shepherds living in the side of the mountain, and he made me the owner of the horses, camels and lands and heaps of grain and he finds no fault with me. I sleep and get up in the morning (at my own sweet will) and drink to my heart's content. The mother of Abu Zara', how fine is the mother of Abu Zara'! Her bundles are heavily packed (or receptacles in her house are filled to the brim) and the house quite spacious. So far as the son of Abu Zara' is concerned, his bed is as soft as a green palm-stick drawn forth from its bark, or like a sword drawn forth from its scabbard, and whom just an arm of a lamb is enough to satiate. So far as the daughter of Abu Zara' is concerned, how fine is the daughter of Abu Zara', obedient to her father, obedient to her mother, wearing sufficient flesh and a source of jealousy for her co-wife. As for the slave-girl of Abu Zara', how fine is she ; she does not disclose our affairs to others (outside the four walls of the house). She does not remove our wheat, or provision, or take it forth, or squander it, but she preserves it faithfully (as a sacred trust). And she does not let the house fill with rubbish. One day Abu Zara' went out (of his house) when the milk was churned in the vessels, that he met a woman, having two children like leopards playing with her pomegranates (chest) under her vest. He divorced me (Umm Zara') and married that woman (whom Abu Zara') met on the way. I (Umm Zara') later on married another person, a chief, who was an expert rider, and a fine archer: he bestowed upon me many gifts and gave me one pair of every kind of animal and said: Umm Zara', make use of everything (you need) and send forth to your parents (but the fact) is that even if I combine all the gifts that he bestowed upon me, they stand no comparison to the least gift of Abu Zara'.
    'A'isha reported that Allah's Messenger (may peace be upon him) said to me: I am for you as Abu Zara' was for Umm Zara'.
    This hadith has been transmitted on the authority of Hisham b. 'Urwa but with a slight variation of wording.

Chapter 15 : THE MERITS OF FATIMA, DAUGHTER OF ALLAH'S APOSTLE (MAY PEACE BE UPON HIM)

Book 31, Number 5999:

    Miswar b. Makhramali reported that he heard Allah's Messenger (may peace be upon him) say, as he sat on the pulpit: The sons of Hisham b. Mughira have asked my permission to marry their daughter with 'Ali b. Abi Talib (that refers to the daughter of Abu Jahl for whom 'All had sent a proposal for marriage). But I would not allow them, I would not allow them, I would not allow them (and the only alternative possible is) that 'Ali should divorce my daughter (and then marry their daughter), for my daughter is part of me. He who disturbs her in fact disturbs me and he who offends her offends me.

Book 31, Number 6000:

    Miswar b. Makhramah reported Allah's Messenger (may peace be upon him) as saying: Fatima is a part of me. He in fact tortures me who tortures her.

Book 31, Number 6001:

    (Imam Zain-ul-'Abidin) 'Ali b. Husain reported that when they came to Medina from Yazid b. Mu'awiya after the martyrdom of Husain b. 'Ali (Allah be pleased with him) Miswar b. Makhramah met him and said to him: Is there any work for me which you ask me to do? I said to him: No. He again said to me: Would you not give me the sword of Allah's Messenger (may peace be upon him) for I fear that the people may snatch it from you? By Allah, if you give that to me, no one would be able to take it away, so long as there is life in me. Verily 'Ali b. Abi Talib sent a proposal of marriage to the daughter of Abu Jahl in spite of (the fact that his wife) Fatima (had been living in his house). Thereupon I heard Allah's Messenger (may peace be upon him) say while addressing the people on the pulpit. I was adolescing in those days. He said : Fatima is a part of me and I fear that she may be put to trial in regard to religion. He then made a mention of his son-in law who had been from the tribe of 'Abd Shams and praised his behaviour as a son-in-law and said: Whatever he said to me he told the truth and whatever he promised he fulfilled it for me. I am not going to declare forbidden what is lawful and make lawful what is forbidden, but, by Allah, the daaghter of Allah's Messenger and the daughter of the enemy of Allah can never be combined at one place.

Book 31, Number 6002:

    'Ali b. Husain reported that Miswar b. Makhramah informed him that 'Ali b. Abi Talib sent the proposal of marriage to the daughter of Abu Jahl as he had Fatima, the daughter of Allah's Messenger (may peace be upon him), (as his wife). When Fatima heard about it, she came to Allah's Apostle (may peace be upon him) and said: The people say that you never feel angry on account of your daughters and now 'Ali is going to marry the daughter of Abu Jahl. Makhramah said: Thereupon Allah's Messenger (may peace be upon him) rose up and I heard him reciting Tashahhud and say: Now to the point. I gave a daughter of mine (Zainab) to Abu'l-'As b. Rabi, and he spoke to me and spoke the truth. Verily Fatima, the daughter of Muhammad, is a part of me and I do not approve that she may be put to any trial and by Allah, the daughter of Allah's Messenger cannot be combined with the daughter of God's enemy (as the co-wives) of one person. Thereupon 'Ali gave up (the idea of his intended) marriage. This hadith has been narrated on the authority of Zuhri with the same chain of transmitters.

Book 31, Number 6003:

    'A'isha reported that Allah's Messenger (may peace be upon him) called his daughter Fatima (during his last illness). He said. to her something secretly and she wept. He again said to her something secretly and she laughed. 'A'isha further reported that she said to Fatima: What is that which Allah's Messenger (may peace be upon him) said to you secretly and you wept and then said to you something secretly and you laughed? Thereupon she said: He informed me secretly of his death and so I wept. He then again informed me secretly that I would be the first amongst the members of his family to follow him and so I laughed.

Book 31, Number 6004:

    'A'isha reported: We, the wives of Allah's Apostle (may peace be upon him), were with him (during his last illness) and none was absent therefrom that Fatima, who walked after the style of Allah's Messenger (may peace be upon him), came there, and when he saw her he welcomed her saying: You are welcome, my daughter. He their made her sit on his right side or on his left side. Then he said something secretly to her and she wept bitterly and when he found her (plunged) in grief he said to her something secretly for the second time and she laughed. I ('A'isha) said to her: Allah's Messenger has singled you amongst the women (of the family) for talking (to you something secretly) and you wept. When Allah's Messenger (may peace be upon him) recovered from illness, I said to her. What did Allah's Messenger (may peace be upon him) say to you? Thereupon she said: I am not going to disclose the secret of Allah's Messenger (may peace be upon him). When Allah's Messenger (may peace be upon him) died, I said to her: I adjure you by the right that I have upon you that you should narrate to me what Allah's Messenger (may peace be upon him) said to you. She said: Yes, now I can do that (so listen to it). When he talked to me secretly for the first time he informed me that Gabirel was in the habit of reciting the Qur'an along with him once or twice every year, but this year it had been twice and so he perceived his death quite near, so fear Allah and be patient (and he told me) that he would be a befitting forerunner for me and so I wept as you saw me. And when he saw me in grief he talked to me secretly for the second time and said: Fatima, are you not pleased that you should be at the head of the believing women or the head of this Umma ? I laughed and it was that laughter which you saw.

Book 31, Number 6005:

    'A'isha reported that all the wives of Allah's Apostle (may peace be upon him) had gathered (in her apartment) during the days of his (Prophet's) last illness and no woman was left behind that Fatima, who walked after the style of Allah's Messenger (may peace be upon him), came there. He welcomed her by saying: You are welcome, my daughter, and made her sit on his right side or on his left side, and then talked something secretly to her and Fitima wept. Then he talked something secretly to her and she laughed. I said to her: What makes you weep? She said; I am not going to divulge the secret of Allah's Messenger (may peace be upon him). I ('A'isha) said: I have not seen (anything happening) like today, the happiness being more close to grief (as I see today) when she wept. I said to her: Has Allah's Messenger (may peace be upon him) singled you out for saying something leaving us aside? She then wept and I asked her what he said, and she said: I am not going to divulge the secrets of Allah's Messenger (may peace be upon him). And when he died I again asked her and she said that he (the Holy Prophet) told her: Gabriel used to recite the Qur'an to me once a year and for this year it was twice and so I perceived that my death had drawn near, and that I ('A'isha) would be the first amongst the members of his family who would meet him (in the Hereafter). He shall be my good forerunner and it made me weep. He again talked to me secretly (saying): Arn't you pleased that you should be the sovereign amongst the believing women or the head of women of this Umma? And this made me laugh.

Chapter 16 : THE MERITS OF UMM SALAMA, THE MOTHER OF THE FAITHFUL (ALLAH BE PLEASED WITH HER)

Book 31, Number 6006:

    Salman reported: In case it lies in your power don't be one to enter the bazar first and the last to get out of that because there is a bustle and the standard of Satan is set there. He said: I was informed that Gabriel (Allah be pleased with him) came to Allah's Apostle (may peace be upon him) and there was with him Umin Salama and he began to talk with him. He then stood up, whereupon Allah's Apostle (may peace be upon him) said to Umm Salama: (Do you know) who was he and what did he say? She said: He was Dihya (Kalbi). He reported Umm Salama having said: By Allah, I did not deem him but only he (Dihya) until I heard the address of Allah's Apostle (may peace be upon him) informing him about us. He (the narrator) said: I said to Uthman: From whom did you hear it? He said: From Usima b. Zaid.

Chapter 17 : EXCELLENCE OF ZAINAB, THE MOTHER OF THE FAITHFUL (ALLAH BE PLEASED WITH HER)

Book 31, Number 6007:

    'A'isha, the Mother of the Faithful, reported that Allah's Messenger (may peace be upon him) said: One who has the longest hands amongst you would meet me most immediately. She farther said: They (the wives of Allah's Apostle) used to measure the hands as to whose hand was the longest and it was the hand of Zainab that was the longest amongst them, as she used to work with her hand and Spend (that income) on charity.

Chapter 18 : THE MERITS OF UMM AIMAN (ALLAH BE PLEASED WITH HER)

Book 31, Number 6008:

    Anas reported that Allah's Messenger (may peace be upon him) went to Umm Aiman and I went along with him and she served him a drink in a vessel and he reported that the narrator said: I do not know whether it was because of the fasting (or for any other reason) that he (the Holy Prophet) refused to accept that. She raised her voice and showed annoyance to him.

Book 31, Number 6009:

    Anas reported that after the death of Allah's Messenger (may peace be upon him) Abu Bakr said to 'Umar: Let us visit Umm Aiman as Allah's Messenger (may peace be upon him) used to visit her. As we came to her, she wept. They (Abu Bakr and Umar) said to her: What makes you weep? What is in store (in the next world) for Allah's-Messenger (may peace be upon him) is better than (this worldly life). She said : I weep not because I am ignorant of the fact that what is in store for Allah's Messenger (may peace be upon him) (in the next world) is better than (this world), but I weep because the revelation which came from the Heaven has ceased to come. This moved both of them to tears and they began to weep along with her.

Chapter 19 : THE MERITS OF UMM SULAIM, THE MOTHER OF ANAS B. MALIK, AND BILAL (ALLAH BE PLEASED WITH BOTH OF THEM)

Book 31, Number 6010:

    Anas reported that Allah's Apostle (may peace be upon him) did not enter the house of any woman except that of his wives and that of Umm Sulaim. He used to visit her. It was said to him why it was so, whereupon he said: I feel great compassion for her. Her brother was killed while he was with me.

Book 31, Number 6011:

    Anas reported that Allah's Apostle (may peace be upon him) said: I entered Paradise and heard the noise of steps. I said: Who is it ? They said: She is Ghumaisa, daughter of Milhan, the mother of Anas b. Malik.

Book 31, Number 6012:

    Jabir b. 'Abdullah reported: I was shown Paradise and I saw the wife of Abu Talha (i.e. Umm Sulaim) and I heard the noise of steps before me and, lo, it was that of Bilal.

Chapter 20 : THE MERITS OF ABU TALHA ANSARI

Book 31, Number 6013:

    Anas reported that the son of Abu Talba who was born of Umm Sulaim died. She (Umm Sulaim) said to the members of her family : Do not narrate to Abu Talha about his son until I narrate it to him. Abu Talha came (home); she presented to him the supper. He took it and drank water. She then embellished herself which she did not do before. He (Abu Talha) had a sexual intercourse with her and when she saw that he was satisfied after sexual intercourse with her, she said: Abu Talha, if some people borrow something from another family and then (the members of the family) ask for its return, would they resist its return? He said: No. She said: I inform you about the death of your son. He was annoyed, and said : You did not inform me until I had a sexual intercourse with you and you later on gave me information about my son. He went to Allah's Messenger (may peace be upon him) and informed him what had happened. Thereupon Allah's Messenger (may peace be upon him) said: May Allah bless both of you in the night spent by you! He (the narrator) said: She became pregnant. Allah's Messenger (may peace he upon him) was in the course of a journey and she was along with him and when Allah's Messenger (may peace be upon him) came back to Medina from the journey he did not enter (his house) (during the night). When the people came near Medina, she felt the pangs of delivery. He (Abu Talha) remained with her and Allah's Messenger (may peace be upon him) proceeded on. Abu Talha said: O Lord, you know that I love to go along with Allah's Messenger when he goes out and enter along with him when he enters and I have been detained as Thou seest. Umm Sulaim said: Abu Talha, I do not feel (so much pain) as I was feeling formerly, so better proceed on. So we proceeded on and she felt the pangs of delivery as they reached (Medina) and a child was born and my mother said to me: Anas, none should suckle him until you go to Allah's Messenger (may peace be upon him) tomorrow morning. And when it was morning I carried him (the child) and went along with him to Allah's Messenger (may peace beupon him). He said: I saw that he had in his hand the instrument for the cauterisation of the camels. When he saw me. he said: This is, perhaps, what Umm Sulaim has given birth to. I said: Yes. He laid down that instrument on the ground. I brought that child to him and placed it in his lap and Allah's Messenger (may peace be upon him) asked Ajwa dates of Medina to be brought and softened them in his month. When these had become palatable he placed them in the mouth of that child. The child began to taste them. Then Allah's Messenger (may peace be upon him) said: See what love the Ansar have for dates. He then wiped his face and named him 'Abdullah.

Book 31, Number 6014:

    This hadith has been narrated on the authority of Anas b. Malik through another chain of transmitters.

Chapter 21 : THE MERITS OF BILAL (ALLAH BE PLEASED WITH HIM)

Book 31, Number 6015:

    Abu Huraira reported that Allah's Messenger (may peace be upon him) said to Bilal: Bilal, narrate to me which act at the time of morning prayer you did in Islam for which you hope to receive good reward, for I heard during the night the sound of your steps before me in Paradise. Bilal said: I did not do any act in Islam for which I hope to get any benefit but this that when I perform complete ablution during the night or day I observe prayer with that purification what Allah has ordained for me to pray.

Chapter 22 : THE MERITS OF 'ABDULLAH B. MAS'UD AND THAT OF HIS MOTHER (ALLAH BE PLEASED WITH THEM)

Book 31, Number 6016:

    Abdullah reported that when this verse was revealed: "There is no harm on persons who believe and perform good acts, what they had eaten (formerly) when they avoided it (now) and they affirmed their faith" (v. 93) up to the end. Allah's Messenger (may peace be upon him) said to me: You are one amongst them.

Book 31, Number 6017:

    Abu Musa reported: When I and my brother came from Yemen we used to consider Ibn Mas'ud and his mother amongst the members of the household. of Allah's Messenger (may peace be upon him) because of their visiting them frequently and staying there for long (periods of) time.

Book 31, Number 6018:

    Abu Musa. reported: I came to Allah's Messenger (may peace be upon him) and thought that 'Abdullah was amongst the members of the family, or like that.

Book 31, Number 6019:

    Abu Ishaq reported that he heard Abu'l-Ahwas say: I was along with Abu Musa and Abu Mas'ud as Ibn Mas'ud died and one of them said to the other: Do you find one like him besides him? Thereupon he said: Do you say this (no one can be his rival)? He was admitted (to the company of the Holy Prophet) whereas we were detained and he had been present in the company of Allah's Messenger (may peace be upon him) whereas we had been absent.

Book 31, Number 6020:

    Abu Ahwas reported: We were in the house of Abu Musa along with some of the companions of 'Abdullah and they were looking at the Holy Book. 'Abdullah stood up, whereupon Abu Mas'ud said: I do not know whether Allah's Messenger, (may peace be upon him) has left after him one having a better knowledge (of Islam) than the man who is standing. Abu Musa said: If you say this, that is correct, because he had been present when we had been absent and he was permitted when we were detained.

Book 31, Number 6021:

    Zaid b. Wahab reported: I was sitting along with Hudhaifa and Abu Musa, and the rest of the hadith is the same.

Book 31, Number 6022:

    'Abdullah (b. Mas'ud) reported that he (said to his companions to conceal their copies of the Qur'an) and further said: He who conceals anything he shall have to bring that which he had concealed on the Day of judgment, and then said: After whose mode of recitation you command me to recite? I in fact recited before AIlah's Messenger (may peace be upon him) more than seventy chapters of the Qur'an and the Companions of Allah's Messenger (may peace be upon him) know it that I have better understanding of the Book of Allah (than they do), and if I were to know that someone had better understanding than I, I would have gone to him. Shaqiq said: I sat in the company of the Companions of Mubkmmad (may peace be upon him) but I did not hear anyone having rejected that (that is, his recitation) or finding fault with it.

Book 31, Number 6023:

    Abdullah reported: By Him besides Whom there is no god, there is no chapter in the Book of Allah about which I do not know as to where it was revealed and there is no verse about which I do not know in what context it was revealed, and if I were to know of one having a better understanding of the Book of Allah than I (and I could reach him) on the back of the mule, I would have definitely gone to him on camel's back.

Book 31, Number 6024:

    Masruq reported: We used to go to Abdullah b. 'Amr and talk to him, Ibn Numair said: One day we made a mention of Abdullah b. Mas'ud, whereupon he said: You have made mention of a person whom I love more than anything else. I heard Allah's Messenger (may peace be upon him) as saying: Learn Qur'an from four persons: Ibn Umm 'Abd (i.e. 'Abdullah b. Mas'ud) he started from him-then Mu'adh b. Jabal and Ubayya b. Ka'b, then Salim the ally of Abu Hudhaifa.

Book 31, Number 6025:

    Masruq reported: We were in the company of Abdullah b 'Amr that we made a mention of a hadith from Abdullah b. Mas'ud; thereupon he said: That is a person whose love ever remains (fresh in my heart) after I heard Allah's Messenger (may peace be upon him) as saying: Learn Qur'an from four persons: Ibn Umm 'Abd, i e. Abdullah b. Mas'ud and he started from his name-then Ubayy b. Ka'b and Mu'adh b Jabal. Zuhri did not make a mention of the words yaquluhu in his narration

Book 31, Number 6026:

    This hadith has been reported on the authority of Abu Bakr b. Abu Shaiba and Abu Kuraib, and both of them said: Abu Mu'awiya narrated to us from A'mash on the authority of Jarir and Waki', and in a narration of Abu Bakr transmitted on the authority of Abu Mu'awiya the mention of Mu'adh has preceded Ubayy's, and in the narration transmitted on the authority of Abu Kuraib, the name of Ubayy preceded Mu'ddh's. This tradition has been transmitted on the authority of Shulba through A'mash, but there is a difference of order of the four.

Book 31, Number 6027:

    Masruq reported: They made a mention of Ibn Mas'ud before 'Abdullah b. Amr, whereupon he said: He is a person whose love is always fresh in my heart after I heard Allah's Messenger (may peace be upon him) as saying: Learn the recita- tion of the Qur'an from four persons: from Ibn Mas'ud, Salim, the ally of Abu Hudhaifa, Ubayy b. Ka'b, Mu'adh b. Jabal.

Book 31, Number 6028:

    Ubaidullah b. Mu'adh reported it on the authority of his father Shu'ba with the same chain of transmitters and he made this addition. He made a mention of these two names but I do not know whose name he mentioned first.

Book 31, Number 6029:

    Anas is reported to have said: Four persons collected the Qur'an during the lifetime of Allah's Messenger (may peace be upon him) and all of them were Ansar: Mu'adh b. Jabal, Ubayy b. Ka'b, Zaid b. Thabit, Abu Zaid. Qatada said: Anas, who was Abu Zaid? He said: He was one of my uncles.

Chapter 23 : THE MERITS OF UBAYY B. KA'B AND A GROUP OF ANSAR (ALLAH BE PLEASED WITH THEM)

Book 31, Number 6030:

    Hammam said: I said to Anas b. Malik: Who collected the Qur'an during the lifetime of Allah's Messenger (may peace be upon him) ? He said: Four (persons), all of them belonging to Ansir: Ubayy b. Ka'b, Mu'adh b. Jabal, Zaid b. Thabit and a person from the Ansar whose Kunya was Abu Zaid.

Book 31, Number 6031:

    Anas b. Malik reported that Allah's Messenger (may peace be upon him) said to Ubayy: Verily Allah, the Exalted and Glorious, has commanded me to recite the Qur'an to you, whereupon he said: (Has) Allah mentioned my name to you ? He said: Allah has mentioned your name to me. Thereupon he began to shed tears (of joy)

Book 31, Number 6032:

    Anas b. Malik reported that Allah's Messenger (may peace be upon him) said to Ubayy b. Ka'b: I have been commanded to recite to you the Sura (al- Bayyinah) which opens with these words (Lam Yakunil-ladhiyna Kafaruu) He said: Has he mentioned to you my name ? He said: Yes; thereupon he shed tears of joy. This hadith has been narrated on the authority of Anas through another chain of transmitters.

Chapter 24 : THE MERITS OF SA'D B MU'ADH (ALLAH BE PLEASED WITH HIM)

Book 31, Number 6033:

    Jabir b. 'Abdullah reported Allah's Messenger (may peace be upon him) as saying while the bier of Sa'd b. Mu'adh was placed before them : The Throne of the most Gracious shook at the death of Sa'd b. Mu'adh.

Book 31, Number 6034:

    Jabir reported that the Throne of the most Compassionate shook because of the death of Sa'd b. Mu'adh.

Book 31, Number 6035:

    Anas b. Malik reported Allah's Messenger (may peace be upon him) as say- ing : That his bier (that of Sa'd) was placed (before them) and the Throne of the most Compassionate shook.

Book 31, Number 6036:

    Al-Bara' reported that a garment of silk was presented to Allah's Messenger (may peace be upon him). His Companions touched it and admired its softness ; there- upon he said : Do you admire the softness of this (cloth) ? The handkerchiefs of Sa'd b. Mu'adh in Paradise are better than this.

Book 31, Number 6037:

    This hadith has been narrated on the authority of Anas b. Malik through another chain of transmitters.

Book 31, Number 6038:

    This hadith has been reported on the authority of Shu'ba combining the two chains of transmitters. Anas b Malik reported that Allah's Messenger (may peace be upon him) was presented a garment of sundus and he prohibited the use of silk. The persons admired it, whereupon he said: By Him in Whose Hand is the life of Muhammad, the kerchiefs of Sa'd b. Mu'adh in Paradise are better than this.

Book 31, Number 6039:

    Anas reported the king of Dumat al-Jandal presented to Allah's Messenger (may peace be upon him) the garment and lie made no mention (of the fact) that he prohibited the use of silk.

Chapter 25 : THE MERITS OF ABU DUJANA (ALLAH BE PLEASED WITH HIM)

Book 31, Number 6040:

    Anas reported that Allah's Messenger (may peace be upon him) took hold of his sword on the Day of Uhud and said: Who would take it from me? All the persons stretched their hands saying: I would do it, I would do it. He (Allah's Apostle) said: Who would take it in order to fulfil its rights? Then the people withdrew their hands. Simak b. Kharasha Abu Dujana said: I am here to take it and fulfil its rights. He took it and struck the heads of the polytheists.

Chapter 26 :THE MERITS OF 'ABDULLAH B.'AMR B. HARAM, THE FATHER OF JABIR (ALLAH BE PLEASED WITH HIM)

Book 31, Number 6041:

    Jabir b. 'Abdullah reported: The dead body of my father was brought and he was covered (with cloth) and it had been mutilated. I made an attempt to lift the cloth, but my people prohibited me to do so. I again made an attempt to lift the cloth, but my people prohibited me. Thereupon Allah's Messenger (may peace be upon him) lifted it or he commanded it to be lifted. He heard the noise (of a loud) weeping, or the noise of a woman mourner. He inquired who she was. They said: The daughter of 'Amr or the sister of Amr, whereupon he said: Why does she weep? The Angels provide him shade with the help of their Wings until he would be lifted (to his heavenly abode)

Book 31, Number 6042:

    Jabir b. 'Abdullah reported: My father fell as a martyr on the Day of Uhud and I attempted to uncover his face and weep, but they (the Companions of the Holy Prophet) forbade me to do this, whereas Allah's Messenger (may peace be upon him) did not forbid me and Fatima bint Amr, the sister of my father, was also weeping There- upon Allah's Messenger (may peace be upon him) said: You may weep or you may not weep; the Angels provide him shade with the help of their wings until you lift him (to be buried in the grave).

Book 31, Number 6043:

    This hadith has been narrated on the authority of Jabir through another chain of transmitters, but with this difference that there is no mention of the Angels and the weeping of a female mourner.

Book 31, Number 6044:

    Jabir reported: My father was brought in a state that his ears had been cut off and (his dead body) was placed before Allah's Apostle (may peace be upon him) , the rest of the hadith is the same.

Chapter 27 :THE MERITS OF JULAIBIB (ALLAH BE PLEASED WITH HIM)

Book 31, Number 6045:

    Abu Barza reported that Allah's Apostle (may peace be upon him) was there in a battlefield that Allah conferred upon him the spoils of war. He said to his Companions: Is anyone missing amongst you? They said: So and so and so. He again said: Is there anyone missing amongst you? They said: So and so and so. He then said: Is there anyone missing amongst you? They said: No. Thereupon he (the Holy Prophet) said: But I am missing Julaibib. They (his Companions) searched him amongst those who had been killed and they found him by the side of seven (dead bodies) whom he had killed and he had been killed (by the oppoments). Allah's Apostle (may peace be upon him) came there and stood (by his side) and said: He killed seven (persons). Then (his opponents) killed him. He is mine and I am his. He then placed him upon his hands and there was none else to lift but Allah's Apostle (may peace be upon him). Then the grave was dug for him and he was placed in the grave and no mention is made of a bath.

Chapter 28 : THE MERITS OF ABU DHARR (ALLAH BE PLEASED WITH HIM)

Book 31, Number 6046:

    'Abdullah b. Samit reported that Abu Dharr said: We set out from our tribe Ghafir who look upon the prohibited months as permissible months. I and my brother Unais and our mother stayed with our maternal uncle who treated us well. The men of his tribe fell jealous and they said: When you are anay from your house, Unais commits adultery with your wife. Our -naternal uncle came and he accused us of the sin which was conveyed to him. I said: You have undone the good you did to us. We cannot stay with you after this. We came to our camels and loaded (our) luggage. Our maternal uncle began to weep covering himself with (a piece of) cloth. We proceeded on until we encamped by the side of Mecca. Unais cast lot on the camels (we had) and an equal number (above that). They both went to a Kahin and he made Unais win and Unais came with our camels and an equal number along with them. He (Abu Dharr) said: My nephew, I used to observe prayer three years before my meeting with Allah's Messenger (may peace be upon him). I said: For whom did you say prayer? He said: For Allah. I said : To which direction did you turn your face (for observing prayer) ? He said: I used to turn my face as Allah has directed me to turn my face. I used to observe the night prayer at the time of the end of night and I fell down in prostration like the mantle until the sun rose over me. Unais said: I have a work in Mecca, so you better stay here. Unais went until he came to Mecca and he came to me late. I said: What did you do ? He said: I met a person in Mecca who is on your religion and he claims that verily it is Allah Who has sent him. I said: What do the people say about him? He said: They say that he is a poet or a Kahin or a magician. Unais who was himself one of the poets said. I have heard the words of a Kahin but his words in no way resemble his (words). And 1 also compared his words to the verses of poets but such words cannot be uttered by any poet. By Allah, he is truthful and they are liars. Then I said: you stay here, until I go, so that I should see him. He said : I came to Mecca and I selected an insignificant person from amongst them and said to him: Where is he whom you call as-Sabi ? He pointed out towards me saying: He is Sabi. Thereupon the people of the valley attacked me with sods and bows until I fell down unconscious. I stood up after havin. regained my consciousness and I found as if I was a red idol. I came to Zamzarn and washed blood from me and drank water from it and listen, O son of my brother, I stayed there for thirty nights or days and there was no food for me but the water of Zamzarn. And I became so bulky that there appeared wrinkles upon my stomach, and I did not feel any hunger in my stomach. It was during this time that the people of Mecca slept in the moonlit night and none was there to eircumambulate the House but only two women who had been invoking the name of Isafa, and Na'ila (the two idols). They came to me while in their circuit and I said: Marry one with the other, but they did not dissuade from their invoking. They came to me and I said to them : Insert wood (in the idols' private parts). (I said this to them in such plain words) as I could not express in metaphorical terms. These women went away crying and saying: Had there been one amongst our people (he would have taught a lesson to you for the obscene words used for our idols before us). These women met Allah's Messenger (may peace be upon him) and Abu Bakr who had also been coming down the hill. He asked them: What has happened to you? They said: There is Sabi, who has hidden himself between the Ka'ba and its curtain. He said: What did he say to you? They said: He uttered such words before us as we cannot express. Allah's Messenger (may peace be upon him) came and he kissed the Black Stone and circumambulated the House along with his Companion and then observed prayer, and when he had finished his prayer, Abu Dharr said: I was the first to greet him with the salutation of peace and uttered (these words) in this way; Allah's Messen- ger, may there be peace upon you, whereupon he said: It may be upon you too and the mercy of Allah. He then said: Who are you ? I said: From the tribe of Ghifar. He leaned his hand and placed his finger on his forehead and I said to myself: Perhaps he has not liked it that I belong to the tribe of Ghifar. I attempted to catch hold of his hand but his friend who knew about him more than I dissuaded me f rom doing so. He then lifted his head and said: Since how long have you been here? I said: I have been here for the last thirty nights or days. He said: Who has been feeding you ? I said: There has been no food for me but the water of Zamzam. I have grown so bulky that there appear wrinkles upon my stomach and I do not feel any hunger. He said: It is blessed (water) and it also serves as food. Thereupon Abu Bakr said: Allah's Messenger, let me serve as a host to him for tonight, and then Allah's Messenger (may peace be upon him) proceeded forth and so did Abu Bakr and I went along with them. Abu Bakr opened the door and then he brought for us the raisins of Ta'if and that was the first food which I ate there. Then I stayed as long as I had to stay. I then came to Allah's Messenaer (may peace be upon him) and he said: I have been shown the land abound- ing in trees and I think it cannot be but that of Yathrib (that is the old name of Medina). You are a preacher to your people on my behalf. I hope Allah would benefit them through you and He would reward you. I came to Unais and he said: What have you done ? I said: I have done that I have embraced Islam and I have testified (to the prophethood of Allah's Messenger). He said: I have no aversion for your religion and I also embrace Islam and testify (to the prophethood of Muhammad). Then both of us came to our mother and she said: I have no aversion for your religion and I also embrace Islam and testify to the prophethood of Muhammad. We then loaded our camels and came to our tribe Ghifir and half of the tribe embraced Islam and their chief was Aimi' b. Rahada Ghifirl and he was their leader and hall of the tribe said: We will embrace Islam when Allah's Messenger (may p,.ace be upon him) would come to Medina, and when Allah's Messenger (may peace be upon him) came to Medina the remaining half also embraced Islam. Then a tribe Aslam came to the Holy Prophet (may peace be upon him) and said: Allah's Messenger, we also embrace Islam like our brothers who have embraced Islam. And they also embraced Islam. Thereupon Allah's Messenger (may peace be upon him) said: Allah granted pardon to the tribe of Ghifar and Allah saved (from destruction) the tribe of Aslam.

Book 31, Number 6047:

    This hadlth has been narrated on the authority of Humaid b. Hilal with the same chain of transmitters but with this addition: "As I came to Mecca, Unais said: (Well), go but be on your guard against the Meccans for they are his enemies and are annoyed with him."

Book 31, Number 6048:

    Abdullah b. Samit reported that Abu Dharr said: Son of my brother, I used to observe prayer two years before the advent of Allah's Apostle (may peace be upon him). I said: To which direction did you turn your face? He said: To which Allah directed me to turn my face. The rest of the hadith is the same but with this addition that they went to a Kahin and his brother Unais began to praise him until he (in verses declared) him (Unais) as winner (in the contest of poetry), and so we got his camels, mixed them with our camels, and there is in this hadith also these words that Allah's Apostle (may peace be upon him) came there and he circumambulated the House and observed two Rak'ahs of prayer behind the Station (of Ibrahim). I came to him and I was the first amongst persons to greet him with Assalam-o-'Alaikum, and I said to Allah's Messenger Let there be peace upon you. And he said: Let there be peace upon you too; who are you? And in the hadith (these words are) also found: Since how long have you been here ? And Abu Bakr said: Let him be my guest tonight.

Book 31, Number 6049:

    Ibn 'Abbas reported that when Abu Dharr heard of the advent of the Apostle (may peace be upon him) in Mecca he said: Brother, ride in this valley and bring information for me about the person who claims that there comes to him information from the Heavens. Listen to his words and then come to me. So he rode on until he came to Mecca and he heard his words (the sacred words of the Holy Prophet) and then came back to Abu Dharr and said: I have seen him exhorting (people) to develop good morals and his expressions can in no way be termed as poetry. He (Abu Dharr) said: I have not been satisfied with it regarding that which I had in my mind (as I sent you). So he took up provisions for the journey and a small water-skin con- taining water (and set forth) until he came to Mecca. He came to the mosque (Ka'ba) and began to find out Allah's Apostle (may peace be upon him) and he did not re- cognise him (the Holy Prophet) and he did not even like that he should ask about him from anyone until it was night, and he slept. 'All saw him and found him to be a stranger. So he went with him. He followed hive but one did not make any inquiry from the other about anything until it was morning. He then brought the water and his provisions to the mosque and spent a day there, but he did not see Allah's Apostle (may peace be upon him) until it was night. He then returned to his bed that there happened to pass 'Ali and he said: This man has not been able to find his destination until this time. He made him stand and he went with him and no one made an in- quiry from his companion about anything. And when it was the third day he did the same. 'Ali made him stand up and brought him along with him. He said: By Him, besides Whom there is no god, why don't you tell me (the reason) which brought you here to this town? He said: (I shall do this) provided you hold me promise and a covenant that you would guide me aright. He then did that. He ('Ali) said : Verily, he Is truthful and he is a Messenger of Allah (may peace be upon him) and when it is morning, follow me and if I would say anything from which I would sense fear about you I would stand (in a manner) as if I was throwing water and if I move on, you then follow me until I get in (some house). He did that and I followed him until he came to Allah's Messenger (may peace be upon him). He entered (the house) of Allah's Apostle (may peace be upon him) along with him and listened to his words and embraced Islam at his very place. Allah's Apostle (may peace be upon him) said to him: Go to your people and inform them until my command reaches you. Thereupon he said: By Him in Whose Hand is my life, I shall say to the people of Mecca this thing at the top of my voice So he set forth until he came to the mosque and then spoke at the top of his voice (saying):I bear testimony to the fact that there is no god but Allah and that Muhammad is the Messenger of Allah. The people attacked him and made him fall down when 'Abbas came and he leaned over him and said: Woe be upon you, don't you know that he is from amongst the tribe of Ghifar and your trad- ing route to Syria passes through (the settlements of this tribe), and he rescued him. He (Abu Dharr) did the same on the next day and they (the Meccans) again attacked him and Abbas leaned upon him and he rescued him.

Chapter 29 : THE MERITS OF JARIR B. ABDULLAH (ALLAH BE PLEASED WITH HIM)

Book 31, Number 6050:

    (6050) Jarir b. 'Abdullah said: Allah's Messenger (may peace be upon him) never refused me permission to see him since I embraced Islam and never looked at me but with a smile.

Book 31, Number 6051:

    Jarir reported: Since I embraced Islam Allah's Messenger (may peace be upon him) never refused to see me and he did not see me but with a smile on his face. Ibn Numair has made this addition to this hadith which has been reported on the authority of Ibn Idris that he (Jarir) made this complaint to him (to the Holy Prophet): I cannot sit upon the horse with firmness, whereupon he (Allah's Apostle) struck his chest with his hand and prayed: O Allah, make him steadfast and rightly-guided.

Book 31, Number 6052:

    Jabir reported that there was in pre-Islamic days a temple called Dhu'l- Khalasah and it was called the Yamanite Ka'ba or the northern Ka'ba. Allah's Messenger (may peace be upon him) said unto me: Will you rid me of Dhu'l-Khalasah and so I went forth at the head of 350 horsemen of the tribe of Ahmas and we destroyed it and killed whomsoever we found there. Then we came back to him (to the Holy Prophet) and informed him and he blessed us and the tribe of Ahmas.

Book 31, Number 6053:

    Jarir b. 'Abdullah al-Bajali said: Allah's Messenger (may peace be upon him) said to me: Can't on rid me of Dhu'I-Khalasah, the idol-house of Khath'am, and this idol-house was called the Yamanite Ka'ba. So I went along with 150 horsemen and I could not sit with steadfastness upon the horse. I made the mention of it to Allah's Messenger (may peace be upon him) and he struck his hand on my chest and said: O Allah, grant him steadfastness and make him the guide of righteousness and the rightly-guided one. So he went away and he set fire to it. Then Jarir sent some person to Allah's Messenger (may peace be upon him) whose Kunya was Abu Arta to give him the happy news about that. He came to Allah's Messenger (may peace be upon him) and said: I have not come to you (but with the news) that we have left Dhu'l-Khalasah as a scabed camel. Thereupon Allah's Messenger (may peace be upon him) blessed the horses of Ahmas and the men of their tribe five times.

Book 31, Number 6054:

    This hadith has been narrated on the authority of Ismail with different chains of transmitters and in the badith transmitted on the authority of Marwan (the words are): "A person giving the glad tidings on behalf of Jarir came or Abu Husain b. Rabi'a came in order to give glad tidings to Allah's Apostle (may peace be upon him).

THE MERITS OF 'ABDULLAH B. ABBAS (ALLAH BE PLEASED WITH HIM) Chapter 30 :

Book 31, Number 6055:

    Ibn 'Abbas reported that Allah's Messenger (may peace be upon him) came to privy and I placed for him water for ablution, When he came out he said: Who placed it here? And in a version of Zuhair they (the Companions) said, and in the version of Abu Bakr (the words are): I said: It is Ibn 'Abbas (who has done that), whereupon he (the Holy Prophet) said: May Allah grant him deep understanding of religion .

Chapter 31 : THE MERITS OF ABDULLAH B. UMAR (ALLAH BE PLEASED WITH HIM)

Book 31, Number 6056:

    Ibn 'Umar reported: I saw in a state of sleep as if I have in my hand a piece of silk cloth and there is no place in the Paradise where I intend to reach but that piece of cloth does not fly towards it. I made a mention of it to Hafsa (the sister of Ibn 'Umar) and Hafsa made a mention of it to Allah's Apostle (may peace be upon him), whereupon Allah's Apostle (may peace be upon him) said: I find 'Abdullah b 'Umar a pious person.

Book 31, Number 6057:

    Ibn 'Umar reported that when a person saw anything in sleep during the lifetime of Allah's Messenger (may peace he upon him) he narrated it to Allah's Messenger, and I also had a longing that I should also see in a dream something which I should narrate to Allah's Apostle (may peace be upon him) and I was at that time an unmarried young man. I was sleeping in the mosque during the lifetime of Allah's Messenger (may peace be upon him) tl)at I saw in a dream as if two Angels have taken hold of me and they have carried me to the fire, and, lo, it was built like the easing of a well and had two pillars like those of a well; and, lo, there were people in it whom I knew and I cried out : I seek refuge with Allah from Hell-fire; I seek refuge with Allah from Hell-fire. Then another Angel joined the two others, and said unto me : You need not fear I narrated this dream to llafsa and she narrated it to Allah's Messenger, whereupon Allah's Apostle said: Worthy is this man Abdullah, O that he would pray at night, and Silim added that Abdullah afterwards slept only but for a small part of the night.

Book 31, Number 6058:

    Ibn Umar reported: I used to spend nights in the mosque and by that time I had no wife and children. I saw in a dream as if I am being taken to a well. I made a mention of it to Allah's Messenger (may peacebe upon him). The rest of the hadith is the same.

Chapter 32 : THE MERITS OF ANAS B. MALIK (ALLAH BE PLEASED WITH HIM)

Book 31, Number 6059:

    Anas reported that Umm Sulaim said (to the Holy Prophet) Allah's Messenger, here is your servant Anas, invoke blessings of Allah upon him. Thereupon he (the Holy Prophet) said: O Allah, make an increase in his wealth, and progeny, and confer blessings upon him in everything Thou hast bestowed upon him.

Book 31, Number 6060:

    Anas reported (that his mother) Umm Sulaim said (to the Holy Prophet) Allah's Messenger, here is your servant Anas. The rest of the hadith is the same.

Book 31, Number 6061:

    This hadith has been reported on the authority of Anas through another chain of transmitters.

Book 31, Number 6062:

    Anas reportedAllah's Apostle (may peace be upon him) visited us and there was none else (in the house) but I, my mother and my mother's sister Umm Haram. My mother said to him : Allah's Messenger, here is a small servant of yours, invoke blessings of Allah upon him. And he invoked blessings for me (that I should be bestowed upon) every good and this was what he (said) at the end of what be supplicated for me: O Allah, make an increase in his wealth, and progeny, and cqnfer blessings (upon him) in (each one) of them.

Book 31, Number 6063:

    Anas reported: My mother Umm Anas came to Allah's Messenger (may peace be upon him). And she prepared my lower garment out of the half of her headdress and (with the other half) she covered my upper body and said: Allah's Messenger, here is my son Unais; I have brought him to you for serving you. Invoke blessings of Allah upon him. Thereupon he (the Holy Prophet) said: O Allah, make an increase in his wealth, and progeny. Anas said : By Allah, my fortune is huge and my children, and grand-children are now more than one hundred.

Book 31, Number 6064:

    Anas b. Malik said: Allah's Messenger (may peace be upon him) passed (by our house) that my mother Umm Sulaim listened to his voice and said: Allah's Messenger, let my father and mother be sacrificed for thee, here is Unais (and requested him to invoke blessings upon me). So Allah's Messenger (may peace be upon him) invoked three blessings upon me. I have seen (the results) of the two in this very world (in regard to wealth and progeny) and I hope to see (the result) of the third one in the Hereafter.

Book 31, Number 6065:

    Anas reported: Allah's Messenger (may peace be upon him) came to me as I was playing with playmates. He greeted and sent me on an errand and I made delay in going to my mother. When I came to her she said: What detained you? I said: Allah's Messenger (may peace be upon him) sent me on an errand. She said: What was the purpose? I said: It is something secret. Therupon she said: Do not then divulge the secret of Allah's Messenger (may peace be upon him) to anyone. Anas said: By Allah, if I were to divulge it to anyone, then, O Thabit, I would have divulged it to you.

Book 31, Number 6066:

    Anas b. Malik reported that Allah's Apostle (may peace be upon him) told me something secretly. I informed none about that and Umm Sulaim asked me about it, but I did not tell her even.

Chapter 33 : THE MERITS OF 'ABDULLAH B. SALAM (ALLAH BE PLEASED WITH HIM)

Book 31, Number 6067:

    'Amir b. Sa'd reported that he heard his father (Sa'd b. Abi Waqqas) say: never heard Allah's Messenger (may peace be upon him) say unto one living and moving about that he was in Paradise except to 'Abdullah b. Salim.

Book 31, Number 6068:

    Qais b. 'Ubada reported:I was in the company of some persons, amongst whom some were the Companions of Allah's Apostle (may peace be upon him) in Medina, that there came a person whose face depicted the fear (of Allah). Some people said: He is a person from amongst the people of Paradise; he is a person from amongst the people of Paradise. He observed two short rak'ahs of prayer and then went out. I followed him and he got into his house and I also got in and we began to converse with each other. And when he became familiar (with me) I said to Him: When you entered (the mosque) before (your entrance in the house) a person said so and so (that you are amongst the people of Paradise), whereupon he said: It is not meet for anyone to say anything which he does not know. I shall (now) tell you why they (say) this. I saw a dream during the lifetime of Allah's Messenger (may peace be upon him) and narrated it to him. I seemed to be in a garden [he described its vastness, its rich fructification and its verdure]; in the midst of it, there stood an iron pillar, with its base in the earth and its summit in the sky: and upon its summit there was a handhold. It was said to me: Climb up this (pillar). I said to him (visitant in the dream): I am unable to do it. Thereupon a helper came to me, and he (supported) me (by catching hold of my) garment from behind and thus helped me with his hand and so I climbed up till I was at the summit of the pillar, and grasped the handhold. It was said to me: Ho d it tightly. It was at this that I woke up when (the handhold) was in fthe grip) of my hand. I narrated it (the dream) to Allah's Apostle (may peace be upon him), whereupon he said: That garden implies al-Islam and that pillar implies the pillar of Islam. And that handhold is the firmest faith (as refered to in the Qur'an). And you will remain attached to Islam until you shall die. And that man was 'Abdullah b. Salim.

Book 31, Number 6069:

    Qais b. 'Ubaida reported: I was (sitting) in a company in which there were (besides others) Sa'd b. Malik and Ibn 'Umar that 'Abdullah b. Saliim happened to pass (by that side). They (the people sitting in that company) said: He is a person from amongst the dwellers of Paradise. I stood up and said to him: They say such and such (thing about you), whereupon he said: Hallowed be Allah, it is not meet for them to say (anything) of which They have no knowledge. Verily I saw as if a pillar had been raised in a green garden and there had been fixed at its (upper) end a handhold and there was a helper at its base. It was said to me: Climb up. So I climbed up and caught hold of the haildhold. I narrated (the contents of this dream) to Allah's Messenger (may peace be upon him), whereupon he said: 'Abdullah would die in a state that he would be catching hold of the firmest handhold (he would die holding fast to the faith).

Book 31, Number 6070:

    Kharasha b. Hurr reported: I was sitting in a circle in the mosque of Medina and there was an old man, quite handsome. He was 'Abdullah b. Salim. He was telling good things to them (to the people sitting in that company). As he stood up (to depart) the people said: He who is desirous of looking at a person from amongst the people of Paradise should see him. I said: By Allah, I will follow him, and would try to know his residence. So I followed him and he walked on until he reached the outskirts of Medina. He then entered his house. I sought permission from him to get in, and he granted me the permission, saying: My nephew, what is the need (that has brought you here) ? I said to him: As you stood up, I heard people say about you: He who is desirous of seeing a person from among the people of Paradise should look at him. So I became desirous of accompanying you. He ('Abdullah b. Salim) said: It is Allah Who knows best about the people of Paradise. I would, however, narrate to you as to why they said like it. (The story is) that while I was asleep (one night) there came to me a person (in the dream) who asked me to stand up. (So I stood up) and he caught hold of my hand and I walked along with him, and, lo, I found some paths on my left and I was about to set out upon them. Thereupon he said to me Do not set yourself on (them) for these are the paths of the leftists (denizens of Hell-fire).Then there were paths leading to the right side, whereupon he said : Set yourself on these paths. We came across a hill and he said to me: Climb up, and I attempted to climb up that I fell upon my buttocks. I made several attempts (but failed to succeed). He led until he came to a pillar (so high) that its upper end touched the sky and its base was in the earth. And there was a handhold at its upper end. He said to me Climb over it. I said: How can I climb upon it, as its upper end touches the sky? He cought hold of my hand and pushed me up and I found myself suspended with the handhold. He then struck the pillar and it fell down, but I remained attached to that handhold until it was morning (and the dream was thus over). I came to Allah's Apostle (may peace be upon him) and narrated it to him. He said: So far as the paths which you saw on your left are concerned, these are paths of the leftists (denizens of Hell) and the paths which you saw on your right, these are the paths of the rightists (the dwellers of Paradise) and the mountain represents the destination of the martyrs which you would not be able to attain. The pillar implies the pillar of Islam. and so far as the handhold is concerned, it implies the handhold of Islam, and you would hold to it fastly until you would meet death.

Chapter 34 : THE MERITS OF HASSAN B. THABIT(ALLAH BE PLEASED WITH HIM)

Book 31, Number 6071:

    Abu Huraira reported that 'Umar happened to pass by Hassan as he was reciting verses in the mosque. He (Hadrat 'Umar) looked towards him (meaningfully), whereupon he (gassin) said: I used to recite (verses) when one better than you (the Holy Prophet) had been present (here). He then looked towards Abu Huraira and said to him: I adjure you by Allah (to tell) if you had not heard Allah's Messenger (may peace be upon him) as saying: (Hassan), give a reply on my behalf; Allah I help him with Ruh-ul-Qudus. He (Abu Huraira) said: By Allah, it is so (i.e. the Holy Prophet actually said these words).

Book 31, Number 6072:

    Ibn Musayyib reported that Hassan said to a circle in which there was also Abu Huraira: Abu Huraira, I adjure you by Allah (to tell) whether you-had not heard Allah's Messenger (may peace be upon him) saying like this.

Book 31, Number 6073:

    'Abd al-Rahman reported that he heard Hassin b. Thabit al-Ansari call Abu Huraira to bear witness by saying: I adjure you by Allah if you had not heard Allah's Apostle (may peace be upon him) saying: Hassin, give a reply on behalf of the Messenger of Allah. O Allah, help him with Ruh-ul-Qudus. Abu Huraira said: Yes, it is so.

Book 31, Number 6074:

    Al-Bari' b. 'Azib reported: I heard Allah's Messenger (may peace be upon him) as saying: Hassan b. Thibit, write satire (against the non-believers); Gabriel is with you. This hadith has been narrated on the authority of Shu'ba with the same chain of transmitters.

Book 31, Number 6075:

    Hisham reported on the authority of his father that Hassan b. Thabit talked much about 'A'isha. I scolded him, whereupon she said: My nephew, leave him for he defended Allah's Messenger (may peace be upon him).

Book 31, Number 6076:

    This hadith has been narrated on the authority of Hishim with the same chain of transmitters.

Book 31, Number 6077:

    Masruq reported: I visited 'A'isha when Hassin was sitting there and reciting verses from his compilation: She is chaste and prudent. There is no calumny against her and she rises up early in the morning without eating the meat of the un- mindful. 'A'isha said: But you are not so. Masruq said: I said to her: Why do you permit him to visit you, whereas Allah has said: "And as for him among them who took upon himself the main part thereof, he shall have a grievous punishment" (XXIV. ll)? Thereupon she said: What tornient can be more severe than this that he has become blind? He used to write satire as a rebuttal on behalf of Allah's Messenger (may peace be upon him).

Book 31, Number 6078:

    This hadith has been reported on the authority of Shu'ba with the same chain of transmitters but with a slight variation of wording.

Book 31, Number 6079:

    'A'isha reported that Hassin said: Allah's Messenger, permit me to write satire against Abu Sufyan, whereupon he said: How can it be because I am also related to him? Thereupon he (Hassan) said: By Him Who has honoured you. I shall draw you out from them (their family) just as hair is drawn out from the fermented (flour). Thereupon Hassan said: The dignity and greatness belongs to the tribe of Bint Makhzum from amongst the tribe of Hisham, whereas your father was a slave.

Book 31, Number 6080:

    'Urwa reported on the same chain of transmitters that Hassan b. Thabit sought permission from Allah's Apostle (may peace be upon him) to satirise against the polytheists, but he did not mention Abu Sufyan. And instead of the word al- Khamir, the word al-'Ajin was used.

Book 31, Number 6081:

    'A'isha reported that Allah's Messenger (may peace be uport him) said. Satirise against the (non-believing amongst the) Quraish, for (the satire) is more grievous to them than the hurt of an arrow. So he (the Holy Prophet) sent (someone) to Ibn Rawiha and asked him to satirise against them, and he composed a satire, but it did not appeal to him (to the Holy Prophet). He then sent (someone) to Ka'b b. Malik (to do the same, but what he composed did not appeal to the Holy Prophet). He then sent one to Hassan b. Thabit. As he got into his presence, Hassan said: Now you have called for this lion who strikes (the enemies) with his tail. He then brought out his tongue and began to move it and said: By Him Who has sent you with Truth, I shall tear them with my tongue as the leather is torn. Thereupon Allah's Messenger (may peace be upon him) said: Don't be hasty; (let) Abu Bakr who has the best know- ledge of the lineage of the Quraish draw a distinction for you in regard to my lineage, as my lineage is thesame as theirs. Hassan then came to him (Abu Bakr) and after making inquiry (in regard to the lineage of the Holy Prophet) came back to him (the holy Prophet) and said: Allah's Messenger, he (Abu Bakr) has drawn a distinction in vour lineage (and that of the Quraish) By Him Who has sent you with Truth, I shall draw out from them (your name) as hair is drawn out from the flour. 'A'isha said: I heard Allah's Messenger (may peace be upon him) as saying to Hassin: Verily Ruh-ul- Qudus would continue to help you so long as you put up a defence on behalf of Allah and His Messenger. And she said: I heard Allah's Messenger (may peace be upon him) saying: Hassan satirised against them and gave satisfaction to the (Muslims) and disquieted (the non-Muslims).

      You satirised Muhammad, but I replied on his behalf,
      And there is reward with Allah for this.
      You satirised Muhammad. virtuous, righteous,
      The Apostle of Allah, whose nature is truthfulness.
      So verily my father and his father and my honour
      Are a protection to the honour of Muhammad;
      May I lose my dear daughter, if you don't see her,
      Wiping away the dust from the two sides of Kada',
      They pull at the rein, going upward;
      On their shoulders are spears thirsting (for the blood of the enemy);
      our steeds are sweating-our women wipe them with their mantles.
      If you had not interfered with us, we would have performed the 'Umra,
      And (then) there was the Victory, and the darkness cleared away.
      Otherwise wait for the fighting on the day in which Allah will honour whom He pleases.
      And Allah said: I have sent a servant who says the Truth in which there is no ambiguity;
      And Allah said: I have prepared an army-they are the Ansar whose object is fighting (the enemy),
      There reaches every day from Ma'add abuse, or fighting or satire;
      Whoever satirises the Apostle from amongst you, or praises him and helps it is all the same,
      And Gabriel, the Apostle of Allah is among us, and the Holy Spirit who has no match.

Chapter 35 : THE MERITS OF ABU HURAIRA AL-DAWSI AL-YAMANI (ALLAH BE PLEASED WITH HIM)

Book 31, Number 6082:

    Abu Huraira reported: I invited my mother, who was a polytlieist, to Islam. I invited her one day and she said to me something about Allah's Messenger (may peace be upon him) which I hated. I came to Allah's Messenger (may peace be upon him) weeping and said: Allah's Messenger, I invited my mother to Islam but she did not accept (my invitation). I invited her today but she said to me something which I did not like. (Kindly) supplicate Allah that He may set the mother of Abu Huraira right. Thereupon Allah's Messenger (may peace be upon him) said: O Allah, set the mother of Abu Huraira on the right path. I came out quite pleased with the supplication of Allah's Apostle (may peace be upon him) and when I came near the door it was closed from within. My mother heard the noise of my footsteps and she said: Abu Huraira, just wait, and I heard the noiee of falling of water. She took a bath and put on the shirt and quickly covered her head with a headdress and opened the door and then said : Abu Huraira, I bear witness to the fact that there is no god but Allah and Mubammad is His bondsman and His Messenger. He (Abu Huraira) said: I went back to Allah's Messenger (may peace be upon him) and (this time) I was shedding the tears of joy. I said: Allah's Messenger, be happy, for Allah has responded to your supplication and He has set on the right path the mother of Abu Huraira. He (the Holy Prophet) praised Allah, and extolled Him and uttered good words. I said: Allah's Messenger, supplicate to Allah so that He may instil love of mine and that of my mother too in the believing servants and let our hearts be filled with their love, whereupon Allah's Messenger (may peace be upon him) said : O Allah, let there be love of these servants of yours, i.e. Abu Huraira and his mother, in the hearts of the believing servants and let their hearts be filled with the love of the believing servants. (Abu Huraira said: This prayer) was so well granted by Allah that no believer was ever born who heard of me and who saw me but did not love me.

Book 31, Number 6083:

    Al-A'raj reported that he heard Abu Huraira as saying: You are under the impression that Abu Huraira transmits so many ahadith from Allah's Messenger (may peace up upon him) ; (bear in mind) Allah is the great Reckoner. I was a poor man and I served Allah's Messenger (may peace be upon him) being satisfied with bare subsistence, whereas the immigrants remained busy with transactions in the bazar; while the Ansar had been engaged in looking after their properties. (He further reported) that Allah's Messenger (may peace be upon him) said : He who spreads the cloth would not forget anything that he would hear from me. I spread my cloth until he narrated something. I then pressed it against my (chest), so I never forgot anything that I heard from him.

Book 31, Number 6084:

    This hadith has been transmitted on the authority of Abu Huraira but with the variation that the hadith transmitted on the authority of Malik conclude with the words of Abu Huraira and there is no mention of a transmission of these from Allah's Apostle (may peace be upon him) : "who spreads his cloth," to the end.

Book 31, Number 6085:

    'A'isha reported : Don't you feel surprised at Abu Huraira? He came (one day) and sat beside the nook of my apartment and began to narrate (the hadith of Allah's Apostle). I was hearing while I was engaged in extolling Allah (reciting Subhan Allah) constantly. He stood up before I finished my repetition of Subhan Allah. if I were to meet him I would have warned him in stern words that Allah's Messenger (may peace be upon him) did not speak so quickly as you talk. Ibn Shihab transmitted on the authority of Ibn Musayyib that Abu Huraira said: People say that Abu Huraira transmits so many ahadith, whereas Allah is the Reckoner, and they say : How is it with Muhajirs and the Ansar that they do not narrate ahadith like him (like Abu Huraira) ? Abu Huraira said: I tell you that my brothers from Ansar remained busy with their lands and my brothers Muhajirs were busy in transactions in the bazars, but I always kept myself attached to Allah's Messenger (may peace be upon him) with bare subsistence. I remained present (in the company of the Holy Prophet), whereas they had been absent. I retained in my mind (what the Holy Prophet said), whereas they forgot it. One day Allah's Messenger (may peace be upon him) said: He who amongst you spreads the cloth and listens to my talk and would then press it against his chest would never forget anything heard from me. So I spread my mantle and when he had concluded his talk I then pressed it against my chest and so I never forgot after that day anything that he (the Holy Prophet) said. And if these two verses would not have been revealed in the Book I would have never transmitted anything (to anybody) : "Those who conceal the clear evidence and the guidance that We revealed" (ii. 159) tip to the last verse.

Book 31, Number 6086:

    This hadith has been transmitted on the authority of Abu Huraira (and the words are) : You say that Abu Huraira narrates so many ahadith from Allah's Messenger (may peace be upon him) ; the rest of the hadith is the same.

Chapter 36 : THE MERITS OF THE PARTICIPANTS IN THE BATTLE OF BADR (ALLAH BE PLEASEIYWITH THEM) AND THE STORY OF HATIB B. ABU BALTA'A

Book 31, Number 6087:

    Ubaidullah b. Rafi', who was the scribe of 'All, reported: I heard 'Ali (Allah be pleased with him) as saying: Allah's Messenger (may peace be upon him) sent me and Zubair and Miqdad saying: Go to the garden of, Khakh [it is a place between Medina and Mecca at a distance of twelve miles from Medina] and there you will find a woman riding a camel. She would be in possession of a letter, which you must get from her. So we rushed on horses and when we met that woman, we asked her to deliver that letter to us. She said : There is no letter with me. We said: Either bring out that letter or we would take off your clothes. She brought out that letter from (the plaited hair of) her head. We delivered that letter to Allah's Messenger (may peace be upon him) in which Hatib b. Abu Balta'a had informed some people amongst the polytheists of Mecca about the affairs of Allah's Messenger (may peace be upon him). Allah's Messenger (may peace be upon him) said: Hatib, what is this? He said: Allah's messenger, do not be hasty in judging my intention. I was a person attached to the Quraish. Sufyan said : He was their ally but had no relationship with them. (Hatib further said) : Those who are with you amongst the emigrants have blood-relationship with them (the Quraish) and thus they would protect their families. I wished that when I had no blood-relationship with them I should find some supporters from (amongst them) who would help my family. I have not done this because of any unbelief or apostasy and I have no liking for the unbelief after I have (accepted) Islam. Thereupon Allah's Apostle (may peace be upon him) said: You have told the truth. 'Umar said : Allah's Messenger, permit me to strike the neck of this hypocrite. But he (the Holy Prophet) said: He was a participant in Badr and you little know that Allah revealed about the people of Badr : Do what you like for there is forgiveness for you. And Allah, the Exalted and Glorious, said : "O you who believe, do not take My enemy and your enemy for friends" (lx. 1). And there is no mention of this verse in the hadith transmitted on the authority of Abu Bakr and Zubair and Ishaq has in his narration made a mention of the recitation of this verse by Sufyan.

Book 31, Number 6088:

    'Ali reported that Allah's Messenger (may peace be upon him) sent me and Abu Marthad al-Ghitnavi and Zubair b. 'Awwam and we were all riders, and he said: Ride on until you reach the garden of Khakh for there is a woman amongst the polytheists and there is a letter with her sent by Hatib to the polytheists; the rest of the hadith is the same.

Book 31, Number 6089:

    Jabir reported that a slave of Hatib came to Allah's Messenger (may peace be upon him) complaining against Hatib and said: Hatib will definitely go to Hell. (But) Allah's Messenger (may peace be upon him) said: You tell a lie; he would not get into that for he had taken part in Badr and in (the expedition of) Hudaibiya.

Chapter 37 : THE MERITS OF THOSE WHO OWED ALLEGIANCE UNDER THE TREE (ALLAH BE PLEASED WITH THEM)

Book 31, Number 6090:

    Umm Mubashshir reported that she heard Allah's Apostle (may peace be upon him) as saying in presence of Hafsa: God willing, the people of the Tree would never enter the fire of Hell one amongst those who owed allegiance under that. She said : Allah's Messenger, why not? He scolded her. Hafsa said: And there is none amongst you but shall have to pass over that (narrow Bridge). Thereupon Allah's Apostle (may peace be upon him) said: Allah, the Exalted and Glorious, has said: We would rescue those persons who are God-conscious and we would leave the tyrants to their fate there (xix. 72).

Chapter 38 : THE MERITS OF ABU MU'SA ASHIARI AND ABU 'AMIR (ALLAH BE PLEASED WITH THEM)

Book 31, Number 6091:

    Abu Musa reported: I was in the company of Allah's Apostle (may peace be upon him) as he had been sitting in Ji'rana (a place) between Mecca and Medina and Bilal was also there, that there came to Allah's Apostle (may peace be upon him) a desert Arab, and he said: Muhammad, fulfill your promise that you made with me. Allah's Messenger (may peace be upon him) said to him: Accept glad tidings. Thereupon the desert Arab said: You shower glad tidings upon me very much; then Allah's Messenger (may peace be upon him) turned towards Abu Musa and Bilal seemingly in a state of annoyance and said: Verily he has rejected glad tidings but you two should accept them. We said: Allah's Messenger, we have readily accepted them. Then Allah's Messenger (may peace be upon him) called for a cup of water and washed his hands in that and face too and put the saliva in it and then said: Drink out of it and pour it over your faces and over your chest and gladden yourselves. They took hold of the cup and did as Allah's Messenger (may peace be upon him) had commanded them to do. Thereupon Umm Salama called from behind the veil: Spare some water in your vessel for your mother also, and they also gave some water which had been spared for her.

Book 31, Number 6092:

    Abu Burda reported on the authority of his father that when Allah's Apostle (may peace be upon him) had been free from the Battle of Hunain, he sent Abu 'Amir as the head of the army of Autas. He had an encounter with Duraid b. as_Simma. Duraid was killed and Allah gave defeat to his friends. Abu Musa said: He (the Holy Prophet) sent me along with Abu 'Amir and Abu 'Amir received a wound in his knee from the arrow,(shot by) a person of Bani Jusham. It stuck in his knee. I went to him and said: Uncle, who shot an arrow upon you? Abu 'Amir pointed out to Abu Musa and said: Verily that one who shot an arrow upon me in fact killed me. Abu Musa said: I followed him with the determination to kill him and overtook him and when he saw me he turned upon his heels. I followed him and I said to him: Don't you feel ashamed (that you run), aren't you an Arab? Why don't you stop ? He stopped and I had an encounter with him and we exchanged the strokes of (swords). I struck him with the sword and killed him. Then I came back to Abu Amir and said: Verily Allah has killed the one who killed you. And he said: Now draw out this arrow. I drew out the arrow and there came out from that (wound) water. Abu 'Amir said: My nephew, go to Allah's Messenger (may peace be upon him) and convey my greetings to him and tell him that Abu Amir begs you to ask forgiveness for him. And Abu Amir appointed me as the chief of the people and he died after a short time. When I came to Allah's Apostle (may peace be upon him) I visited him and he had been lying on the cot woven by strings and there was (no) bed over it and so there had been marks of the strings on the back of Allah's Messenger (may peace be upon him) and on his sides. I narrated to him what had happened to us and narrated to him about Abu Amir and said to him that he had made a request to the effect that forgiveness should be sought for him (from Allah). Thereupon Allah's Messenger (may peace be. upon him) called for water and performed ablution with it. He then lifted his hands and said. O Allah, grant pardon to Thy servant Abu Amir. (The Holy Prophet had raised his hands so high for supplication) that I saw the whiteness of his armpits. He again said: O Allah, grant him distinction amongst the majority of Thine created beings or from amongst the people. I said: Allah's Messenger, ask forgiveness for me too. Thereupon Allah's Apostle (may peace be upon him) said: Allah, forgive the sins of Abdullah b. Qais (Abu Musa Ash'ari) and admit him to an elevated place on the Day of Resurrection. Abu Burda said: One prayer is for abu 'Amir and the other is tor Abu Musa.

Chapter 39 : THE MERITS OF THE ASH'ARITES (ALLAH BE PLEASED WITH THEM)

Book 31, Number 6093:

    Abu Musa reported that Allah's Messenger (may peace be upon him) said: I recognise the voice of the Ash'arites while they recite the Qur'an as they arrive during the night and I also recognise their station from the recital of the Qur'an during the night time, although I have not seen their encampments as they encamp during the day time. And there is a person amongst them, Hakim ; when he encounters the horsemen or the enemies he says to them: My friends command you to wait for them.

Book 31, Number 6094:

    Abu Musa reported that Allah's Messenger (may peace be upon him) said: When the Ash'arites run short of provisions in the campaigns or run short of food for their children in Medina they collect whatever is with them in the cloth and then partake equally from one vessel. They are from me and I am from them.

Chapter 40 : THE MERITS OF ABU SUFYAN B. HARB (ALLAH BE PLEASED WITH HIM)

Book 31, Number 6095:

    Ibn Abbas reported that the Muslims neither looked to Abu Sufyan (with respect) nor did they sit in his company. he (Abu Sufyan) said to Allah's Apostle (may peace be upon him) : Allah's Apostle, confer upon me three things. He replied in the affirmative. He (further) said: I have with me the most handsome and the best (woman) Umm Habiba, daughter of Abu Sufyan; marry her, whereupon he said: Yes. And he again said: Accept Mu'awiya to serve as your scribe. He said: Yes. He again said: Make me the commander (of the Muslim army) so that I should fight against the unbelievers as I fought against the Muslims. He said: Yes. Abu Zumnail said: If he had not asked for these three things from Allah's Apostle (may peace be upon him), he would have never conferred them upon him, for it was (his habit) to accede to everybody's (earnest) request.

Chapter 41 : THE MERITS OF JA'FAR B. ABI TALIB AND ASMA' BINT UMAIS AND OF THE PEOPLE OF THE BOATS (ALLAH BE EASED WITH THEM)

Book 31, Number 6096:

    Abu Musa reported: We were in Yemen when we heard of the migration of Allah's Messenger (may peace be upon him). We also set out as immigrants to him. And I was accompanied by two brothers of mine, I being the youngest of them ; one of them was Abu Burda and the other one was Abu Ruhm, and there were some other persons with them. Some say they were fifty-three or fifty-two persons of my tribe. We embarked upon a boat, and the boat sailed away to the Negus of Abyssinia. There we met Ja'far b. Abu Talib and his companions. Ja'far said : Allall's Messenger (may peace be upon him) has sent us here and has commanded us to stay here and you should also stay with us. So we stayed with him and we came back (to Medina) and met Allah's Messenger (may peace be upon him) when Khaibar had been conquered. He (the Holy Prophet) allocated a share to us and in the ordinary course he did not allocate the share to one who had been absent on the occasion of the conquest of Khaibar but conferred (a share) upon him only who had been present there with him. He, however, made an exception for the people of the boat, viz. for Ja'far and his companions. He allocated a share to them, and some persons from amongst the people said to us, viz. the people of the boat: We have preceded you in migration. Asma' bint 'Umais who had migrated to Abyssinia and had come back along with them (along with immigrants) visited Hafsa, the wife of Allah's Apostle (may peace be upon him). (Accordingly), Umar had been sitting with her (Hafsa). As 'Umar saw Asma, he said : Who is she ? She (Hafsa) said: She is Asma, daughter of 'Umais. He said: She is an Abyssinian and a sea-woman. Asma said: Yes, it is so. Thereupon 'Umar said: We preceded you in migration and so we have more right to Allah's Messenger (may peace be upon him) as compared with you. At this she felt annoyed and said: 'Umar, you are not stating the fact ; by Allah, you had the privilege of being in the company of the Messenger (may peace be upon him) who fed the hungry among you and instructed the ignorant amongst you, whereas we had been far (from here) in the land of Abyssinia amongst the enemies and that was all for Allah and Allah's Messenger (may peace be upon him) and, by Allah, I would never take food nor take water unless I make a mention to Allah's Messenger (may peace be upon him) of what you have said. We remained in that country in constant trouble and dread and I shall talk about it to Allah's Messenger (way peace be upon him) and ask him (about it). By Allah, I shall not tell a lie and deviate (from the truth) and add anything to that. So, when Allah's Apostle (may peace be upon him) came, she said: Allah's Apostle, 'Umar says so and so. Upon this Allah's Messenger (may peace be upon him) said: His right is not more than yours, for him and his companions there is one migration, but for you, i.e. for the people of the boat, there are two migrations. She said: I saw Abu Musa and the people of the boat coming to me in groups and asking me about this hadith, because there was nothing more pleasing and more significant for them than this. Abu Burda reported that Asma said: I saw Abu Musa, asking me to repeat this hadith to him again and again.

Chapter 42 : THE MERITS OF SALMAN, SUHAIB AND BILAL (ALLAH BE PLEASED WITH THEM)

Book 31, Number 6097:

    'A'idh b. Amr reported that Abu Sufyan came to Salman, Suhaib and Bilal in the presence of a group of persons. They said: By Allah, the sword of Allah did not reach the neck of the enemy of Allah as it was required to reach. Thereupon Abu Bakr said: Do you say this to the old man of the Quraish and their chief ? Then he came to Allah's Apostle (may peace be upon'him) and informed him of this. Thereupon he (the Holy Prophet) said: Abu Bakr, you have perhaps annoyed them and if you annoyed them you have in fact annoyed your Lord. So Abu Bakr came to them and said: O my brothers, I have annoyed you. They said: No, our brother, may Allah forgive you

Chapter 43 : THE MERITS OF THE ANSAR (ALLAH BE PLEASED WITH THEM)

Book 31, Number 6098:

    Jabir b. Abdullah reported that it was concerning them (the Ansar) that this verse was revealed, that when the two groups amongst you were about to lose heart and Allah was the Guardian of them both . This concerned Banu Salama and Banu Haritha and we did not like that Allah, the Exalted and Glorious, should not have revealed this verse for the fact that Allah (gave an assurance) of being the Guardian of both.

Book 31, Number 6099:

    Zaid b. Arqam reported that Allah's Messenger (may peace be upon him) said: O Allah,, grant forgiveness to the Ansar, the offspring of the Ansar and the offspring of the offspring of the Ansar. This hadith has been narrated on the authority of Shulba with the same chain of transmitters.

Book 31, Number 6100:

    Anas reported that Allah's Messenger (may peace be upon him) sought forgiveness for the Ansar and he said: I think (he also sought forgiveness) for the children of the Ansar and the slaves and the freed men of the Ansar. I have no doubt about it.

Book 31, Number 6101:

    Anas reported that Allah's Messenger (may peace be upon him) saw children and women of the Ansar coming back from a wedding feast. Allah's Apostle (may peace be upon him) stood up motionless (as a mark of respect) and said: O Allah, (bear witness) (and addressing the Ansar), said: You are dearest to me amongst people, (and said: O Allah (bear witness) (and addressing the Ansar), said: You are dearest to me amongst people. And he meant Ansar.

Book 31, Number 6102:

    Anas b. Malik reported that a woman from the Ansar came to Allah's Messenger (may peace be upon him) and Allah's Messenger (may peace be upon him) stood aside with her and said: By Him in Whose Hand is my life, you are dearest to me amongst the people. He repeated it thrice. This hadith has been reported on the authority of Shu'ba with the same chain of transmitters.

Book 31, Number 6103:

    Anas b. Malik reported Allah's Messenger (may peace be upon him) as saying: The Ansar are my family and my trusted friends. and the people would increase in number whereas they (the Ansar) would become less and less, so appreciate the deeds of those from amongst them who do good and overlook their failings.

Chapter 44 : THE MERITS OF THE SETTLEMENTS OF THE ANSAR

Book 31, Number 6104:

    Abu Usaid reported Allah's Messenger (may peace be upon him) as saying: The worthiest clans of the Ansar are Banu Najjar, thereafter Banu al-Ashhal; thereafter Banu Harith b. Banu Khazraj; thereafter Banu Sa'idah and there is goodness in all clans of the Ansar. Sa'd said: I see that he (the Holy Prophet) has placed others above us. It was said to (him): He has placed you above many others.

Book 31, Number 6105:

    Abu Usaid Ansari has reported this hadith through another chain of transmitters. When the Holy Prophet (may peace be upon him) was marching towards Badr in order

Book 31, Number 6106:

    Anas reported a hadith like this from Allah's Apostle (may peace be upon him) but he has made no mention in the hadith of the words of Sa'd.

Book 31, Number 6107:

    Ibrahim b. Muhammad b. Talha reported: I heard Abu Sa'ld delivering an address in the presence of Abu 'Utba that the Messenger of Allah (may peace be upon him) said: The worthiest settlements of the Ansar are those of Banu Najjar, then of Banu 'Abu al-Ashhal and then of Banu Harith and then of Banu Khazraj and then of the clan of Banu Sa'idah, and if I were to give preference to anyone besides them I would have given preference to my relatives.

Book 31, Number 6108:

    Abu Usaid Ansar reported: I bear witness to the fact that Allah's Messenger (may peace be upon him) said: The best settlements of the Ansar are of those of Banu Najjar, then of Banu 'Abu al-Aslihal and then of Banu Harith b. Khazraj, then of Banu Sa'ida and there is in every settlement of the Ansar good. Abu Salama reported that Abu Usaid said: Can I tell a Iie about Allah's Messenger (may peace be upon him) ? And if I were a liar, I would have started with my tribe Banu Sa'ida. This was conveyed to Sa'd b. 'Ubida and he found (rankling) in his mind and said: We have been left behind (in the sense) that we have been (mentioned) last of the four. He (Sa'd) sid: Saddle my pony so that I should go to Allah's Messenger (may peace be upon him). His nephew saw him and said: Are you going to contradict (the order of) precedence set by Allah's Messenger (may peace be upon him), whereas Allah's Messenger (may peace be upon him) has the best knowledge of it? Is it not sufficient for you that you are the fourth amongst the four (best tribes of the Ansar) ? So he returned and said: Allah and His Messenger know best, and he commanded that his pony should be unsaddled.

Book 31, Number 6109:

    Abu Usaid Ansari reported that he heard Allah's Messenger (may peace be upon him) as saying: The worthiest of the Ansar or the worthiest of the settlements and the clans of Ansar; the rest of the hadith is the same, but there is no mention of the story of Sa'd b. 'Ubida (Allah be pleased with him).

Book 31, Number 6110:

    Abu Huraira reported Allah's Messenger (may peace be upon him) as saying in a large gathering of the Muslims: Should I not tell you of the best clans of the Ansar? They said: Allah's Messenger, (kindly) do this. Thereupon Allah's Messenger said: That is Banu Abd al-Ashhal. They said: Allah's Messenger, then next? He said: Banu Najjar. They again said: Allah's Messenger, then next? He said: Then of Banu Harith b. Khazraj. They then said: Allah's Messenger, then next? He said. Then of Banu Sa'ida. They said: Allah's Messenger, then next? He said: There is good in all the clans of the Ansar. It was upon this that Sa'd b. Ubida stood up in annoyance and said: Are we the last of the four as Allah's Messenger (may peace be upon him) has determined (the order of precedence) of their clans? He decided to talk with Allah's Messenger (may peace be upon him) on this issue, but the people Of his tribe said to him: Be seated, are you not happy with this that Allah's Messenger'(may peace be upon him) has mentioned your clan as one of the four (best) clans and those whom he left and did not mention (the order of their precedence) are more than those whom he mentioned? And Sa'd b. 'Ubada dropped the idea of talking to Allah's Messenger (may peace be upon him) (on this issue).

Chapter 45 : PERTAINING TO THE GOOD WHICH LIES IN ACCOMPANYING THE ANSAR (ALLAH BE PLEASED WITH THEM)

Book 31, Number 6111:

    Anas b. Malik reported: I set out along with Jabrir b. 'Abdullah al-Bajali on a journey and he used to serve me. I said to him: Don't do that. Thereupon he said: I have seen Ansar doing this with Allah's Messenger (may peace be upon him). I swore by Allah whenever I accompany any one of the Ansar, I would serve him and Ibn Muthanni, and Ibn Bashshir made this addition in their narrations: Jarir was older than Anas, and Ibn Bashshir said: He was of a more advanced age as compared with Anas. Allah's Apostle (may peace be upon him) invoked blessings for the tribes of Ghifar and Aslam.

Chapter 46 : ALLAH'S APOSTLE (MAY PEACE BE UPON HIM) INVOKED BLESSINGS UPON THE TRIBES OF GHIFAR AND ASLAM

Book 31, Number 6112:

    Abu Dharr reported Allah's Messenger (may peace be upon him) as saying: Go to your people and say that the Messenger of Allah (may peace be upon him) says: Ghifar (is a tribe) to whom Allah granted pardon, and Aslam (is the tribe) to whom Allah granted safety.

Book 31, Number 6113:

    Abu Dharr reported Allah's Messenger (may peace be upon him) as saying: To the tribe of Aslam Allah has granted safety and to the tribe of Ghifar Allah has granted pardon.

Book 31, Number 6114:

    This hadith has been reported on the authority of Shu'ba with the same chain of transmitters.

Book 31, Number 6115:

    This hadith has been narrated through other chains of transmitters but all of them narrated on the authority of Jabir that Allah's Apostle (may peace be upon him) said: To the tribe of Aslam Allah has granted safety and to the tribe of Ghifar Allah has granted pardon.

Book 31, Number 6116:

    Abu Huraira reported Allah's Messenger (may peace be upon him) as saying: To the tribe of Aslam Allah has granted safety and to the tribe of Ghifar Allah has granted pardon. Verily it is not I that say this, but (it is) Allah the Exalted and Glorious. (who) says this.

Book 31, Number 6117:

    Khufaf b. Jura' reported that Allah's Messenger (may peace be upon him) said in prayer: O Allah, hurl curse upon the tribe of Lihyan and Ri'l aid Dhakwan and Usayya for they disobeyed Allah and His Messenger, (and for) Ghifar Allah has granted pardon and for the tribe of Aslam Allah has granted safety.

Book 31, Number 6118:

    Ibn 'Umar reported Allah's Messenger (may peace be upon him) as saying: Allah has granted pardon to the tribe of Ghifar and to the tribe of Aslam Allah has granted safety and as for Usayya tribe, they disobeyed Allah and His Messenger.

Book 31, Number 6119:

    This hadith has been transmitted on the authority of Ibn Umar with a slight variation of wording (and the wording) that Allah's Messenger (may peace be upon him) said this on the pulpit. This hadith has been reported on the authority of Ibn Umar but through another chain of transmitters.

Chapter 47 : THE MERITS OF THE TRIBES OF GHIFAR, ASHJA', MUZAINA, TAMIM, DAWS AND TAYYI

Book 31, Number 6120:

    Abu Ayyub reported Allah's Messenger (may peace be upon him) as saying: The tribes of Ansar, Muzaina and Juhaina and Ghifar and Ashja' and those from Banu 'Abdullah, they are my friends amongst the people and Allah and His Messenger are their protectors.

Book 31, Number 6121:

    Abu Huraira reported Allah's Messenger (may peace be upon him) as saying: Quraish, Ansar, Muzaina, Juhaina and Ghifar, they are my friends and there is no friend of theirs besides Allah and His Messenger.

Book 31, Number 6122:

    This hadith has been transmitted on the authority of Sa'd b. Ibrahim with a slight variation of wording.

Book 31, Number 6123:

    Abu Huraira reported Allah's Messenger (may peace be upon him) as saying: The tribes of Ashja', Ghifar and Muzaina and from the tribe of Juhaina they are better than Banu Tamim, Banu Amir and the allies of Asad and Ghatfan.

Book 31, Number 6124:

    Abu Huraira reported Allah's Messenger (may peace be upon him) as saying: By Him in Whose Hand is the life of Muhammad, (the tribes of) Ghifar, Aslam, Muzaina, or from the tribe of Juhaina or from the tribe of Muzaina, they would be better in the eye of Allah than Asad, Tayyi, and Ghatfan on the Day of Resurrection.

Book 31, Number 6125:

    Abu Huraira reported Allah's Messenger (may peace be upon him) as saying: Aslam, Ghifar or some people from Muzaina, Juhaina (with the variation of words) are better in the eye of Allah than Asad, Ghatfan, Hawizin and Tamim. The narrator said: I think he also said: "On the Day of Resurrection."

Book 31, Number 6126:

    Abu Bakra reported from his father that al-Aqra' b. Habis reported that he came to Allah's Messenger (may peace be upon him) and said to him: How did the tribes of Aslam, Ghifar, Muzaina (and I think he also said Juhaina and the narrator is in doubt about it) owe allegiance to you, whereas they plundered the pilgrims? Thereupon Allah's Messenger (may peace be upon him) said: "you were to say that Aslam, Ghifar, Muzaina and I think Juhaina are better than Banu Tamim, Banu 'Amir and Asad, Ghatfan, then would these people (of latter group of tribes) be in loss? He said: Yes. Thereupon he (the Holy Prophet) said: By Him in Whose Hand is my life, these people are better than Banu Tamim, Banu Amir, Asad and Ghatfan, and in this hadith of Abu Shaiba (these words are not found) that Muhammad (the narrator) had a doubt about.

Book 31, Number 6127:

    This hadith has been narrated on the authority of Abu Ya'qub Dabbi with the same chain of transmitters but with a slight variation of wording.

Book 31, Number 6128:

    Abu Bakra reported from the Messenger of Allah (may peace be upon him) that Aslam, Ghifar, Muzaina and Juhaina are better than Banu Tamim, Banu Amir and their allies Banu Asad and Ghatfan.

Book 31, Number 6129:

    This hadith has been reported on the authority of Abu Bishr with the same chain of transmitters.

Book 31, Number 6130:

    Abu Bakra reported on the authority of his father that Allah's Messenger (may peace be upon him) said: What is your view if Juhaina, Aslam, Ghifar were better than Banu Tamim, Banu 'Abdullah b. Ghatfan and 'Amir b. Sa'sa'a' respectively (then what would be status of the latter one) ? He said this in a loud voice. They said: Allah's Messenger, they would be definitely at a loss and disadvantage. Thereupon he said: They (the first group) are decidedly better than the others; and in the hadith transmitted on the authority of Abu Kuraib the words are: It you were to find that Juhaina, Muzaina and Aslam and Ghifar (are better than ... ).

Book 31, Number 6131:

    'Adi b. Hatim reported: I came to Umar b. Khattab and he said to me: The first consignment of Sadaqa brought to Allah's Messenger (may peace be upon him) which brightened the face of Allah's Messenger (may peace be upon him) and the faces of his Companions was that of Tayyi.

Book 31, Number 6132:

    Abu Huraira reported that Tufail and his companions said: Allah's Messenger, the tribe of Daws has disbelieved and has belied you, so invoke curse upon them. It was said: Let Daws be destroyed, whereupon he (Allah's Messenger) said: Allah guide aright the tribe of Daws and direct them to me.

Book 31, Number 6133:

    Abu Huraira reported: Since I heard three things from Allah's Messenger (may peace be upon him) my love for Banu Tamim is never on the decline (and these things are): I heard Allah's Messenger (may peace be upon him) as saying about them that they would put up stout resistance against Dajjal amongst my Umma. And he (the narrator) said: (When) the consignment of Zakat was brought to him, Allah's Messenger (may peace be upon him) said: This is the charity of our people, and there was one slave-girl in the house of 'A'isha and she was from the tribe of Banu Tamim; thereupon Allah's Messenger (may peace be upon him) said: Set her free, for she is from the offspring of Isma'il. The other hadith has been transmitted on the authority of Abu Huraira with a slight variation of wording.

Book 31, Number 6134:

    Abu Huraira reported: There are some distinguishing features of Banu Tamim which I heard from Allah's Messenger (may peace be upon him) and my love for them is never on the decline after that and the words are: They are the bravest amongst people in the battlefield and there is no mention of (the word) "Dajjal".

Chapter 48 : THE BEST PERSONS

Book 31, Number 6135:

    Abu Huraira reported Allah's Messenger (may peace be upon him) as saying: You would find people like those of mine, the good amongst you in the Days of Ignorance would be good amongst you in the days of Islam, provided they have an understanding of it and you will find good amongst people the persons who would be averse to position of authority until it is thrust upon them, and you will find the worst amongst persons one who has double face. He comes with one face to them and with the other face to the others.

Book 31, Number 6136:

    This hadith has been transmitted on the authority of Abu Zur'a with a slight variation of wording.

Chapter 49 : CONCERNING THE MERITS OF THE WOMEN OF THE QURAISH

Book 31, Number 6137:

    Abu Huraira reported Allah's Messenger (may peace be upon him) as saying: Good amongst the women are those who ride camels. One of them said: They are pious women of the Quraish, and the other one said: The women of the Quraish are kind to the orphans in their childhood and look after the wealth of their spouses.

Book 31, Number 6138:

    This hadith has been transmitted on the authority of Abu Huraira with a slight variation of wording and there is no word "orphan".

Book 31, Number 6139:

    Abu Huraira reported: I heard Allah's Messenger (may peace be upon him) as saying: The women of the Quraish are good amongst the womenfolk. They ride camels and show affection to their children and zealously guard the wealth of their husbands. Abu Huraira said at the end of this narration that Mary, the daughter of Imran, never rode the camel.

Book 31, Number 6140:

    Abu Huraira reported that Allah's Messenger (may peace be upon him) gave a proposal of marriage to Umm Hani, the daughter of Abu Talib, whereupon she said: Allah's Messenger, I am of an advanced age with a (large) family. Thereupon Allah's Messenger (may peace be upon him) said: The best women are those who ride (the camels); the rest of the hadith is the same but with this difference that, instead of the word Ar'a the word Ahna has been used (and the complete sentence is like this): That they treat children in their childhood with affection.

Book 31, Number 6141:

    Abu Huraira reported Allah's Messenger (may peace be upon him) as saying: The best women who ride the camels are the pious women of the Quraish; they treat with affection children in their childhood and keep a strict watch on the wealth of their spouses.

Book 31, Number 6142:

    This hadith has been reported on the authority of Abu Huraira with the same chain of transmitters.

Chapter 50 : FRATERNITY ESTABLISHED BY ALLAH'S APOSTLE (MAY PEACE BE UPON HIM) AMONGST THE COMPANIONS (ALLAH BE PLEASED WITH THEM)

Book 31, Number 6143:

    Anas reported that Allah's Messenger (may peace be upon him) established fraternity between Abu Ubaida b. Jarrah and Abu Talha.

Book 31, Number 6144:

    It was said to Anas b. Malik: You must have heard this that Allah's Messenger (may peace be upon him) said: There is no alliance (hilf) of brotherhood in Islam. Anas said: Allah's Messenger (may peace be upon him) established the bond of fraternity between the Quraish and the Ansar in his home.

Book 31, Number 6145:

    Anas reported Allah's Messenger (may peace be upon him) established fraternity between the Quraish and the Ansar in his house at Medina.

Book 31, Number 6146:

    Jubair b. Mut'im reported Allah's Messenger (may peace be upon him) as saying: There is no alliance (hilf) in Islam but (the hilf) established in the pre-Islamic days (for good). Islam intensifies and strengthens it.

Chapter 51 : THE PRESENCE OF ALLAH'S APOSTLE (MAY PEACE BE UPON HIM) IS A SOURCE OF SECURITY FOR THE COMPANIONS AND THE PRESENCE OF THE COMPANIONS IS A SOURCE OF SECURITY FOR THE UMMA

Book 31, Number 6147:

    Abu Burda reported on the authority of his father: We offered the sunset prayer along with Allah's Apostle (may peace be upon him). We then said: If we sit (along with Allah's Messenger) and observe night prayer with him it would be very good, so we sat down and he came to us and said: You are still sitting here. I said: Allah's Messenger, we observed evening prayer with you, then we said: Let us sit down and observe night prayer along with you, whereupon he said: You have done well or you have done right. He then lifted his head towards the sky and it often happened that as he lifted his head towards the sky, he said: The stars are a source of security for the sky and when the stars disappear there comes to the sky, i.e. (it meets the same fate) as it has been promised (it would plunge into darkness). And I am a source of safety and security to my Companions and when I would go away there would fall to the lot (of my Companions) as they have been promised with and my Companions are a source of security for the Umma and as they would go there would fall to the lot of my Umma as (its people) have been promised.

Chapter 51 : THE MERITS OF THE COMPANIONS OF THE HOLY PROPHET (MAY PEACE BE UPON HIM) AND OF THOSE WHO ARE NEXT TO THEM AND THEN OF THOSE WHO ARE NEXT TO THEM

Book 31, Number 6148:

    Abu Sa'id Khudri reported Allah's Apostle (may peace be upon him) as saying: A time would come for the people when groups of people would set out for fighting in the cause of Allah and it would be said to them: Is there one amongst you who saw Allah's Messenger (may peace be upon him)? And they would say: Yes, and they would be victorious. Then the people would set out for fighting in the cause of Allah and it would be said to them: Is there one amongst you who saw those (who have had the privilege of sitting in the company of Allah's Messenger (may peace be upon him)? And they would say: Yes, and victory would be granted to them. Then a group of persons would set out for fighting in the cause of Allah and it would be said to them: Is there one amongst you who saw one of those who saw those who (had the privilege) of sitting in the company of Allah's Messenger (may peace be upon him)? And they would say: Yes, and the Victory would be granted to them.

Book 31, Number 6149:

    Abu Sa'id Khudri reported Allah's Messenger (may peace be upon him) as saying: There would come to the people a time when a detachment would be sent for fighting in the cause of Allah and they would say: See, if you can find amongst them someone from amongst the Companions of Allah's Apostle (may peace be upon him). They would find a person and they would be granted victory because of him. Then a second detachment would be sent to them and they would say: Do you find amongst them one who had had the privilege of seeing the Companions of the Apostle of Allah (may peace be upon him)?-and the victory would be granted to them because of him. Then the third detachment would be sent and it would be said to them: See, if you find amongst them (who had had the honour of seeing one) who saw those who saw the Companions of Allah's Apostle (may peace be upon him). Then the fourth detachment would be sent and it would be said to them: See it you find amongst them one who had the privilege (of seeing) one who saw those who saw those who saw the Companions of Allah's Apostle (may peace be upon him), and a person would be found and they would be granted victory because of him.

Book 31, Number 6150:

    Abdullah reported Allah's Messenger (may peace be upon him) as saying: The best of my Umma would be those of the generation nearest to mine. Then those nearest to them, then those nearest to them, then people would come whose witness would precede the oath and the oath will precede the witness. Hannad has not made the mention of Qarn in his narration. Qutaiba said that, instead of the word Qaum, the word Aqwam has been used.

Book 31, Number 6151:

    Abdullah reported: It was asked from Allah's Apostle (may peace be upon him) who amongst the people were the best. He said: (People) of my generation, then those next to them, then those next to them, then there would come a people whose evidence would precede their oath and their oath would precede their evidence. Ibrahim said: They forbade us to make vows and bear witness when we were too young.

Book 31, Number 6152:

    This hadith has been transmitted by Mansur on the authority of Abu al-Ahwas and Jarir with a slight variation of wording.

Book 31, Number 6153:

    'Abdullah (b. Mas'ud) reported Allah's Apostle (may peace be upon him) as saying: The best among people are of my generation, then those next to them. (The narrator said): I do not know whether (he said) it three times or four times. Then there would fellow after them such persons whose evidence would precede the oath, and in case of some others, the oath (would precede) the evidence.

Book 31, Number 6154:

    Abu Huraira reported Allah's Messenger (may, peace be upon him) as saying: The best age of my Umma is one in which I was sent (by Allah as an Apostle), then the one next to that. (The narrator said): And Allah knows best whether he stated this third (time) or not. Then there would come people who would love (to look) bulky and they would hasten to the witness box before they are asked to bear witness.

Book 31, Number 6155:

    This hadith has been reported on the authority of Abu Huraira through another chain of transmitters (but with this variation) that Abu Huraira said: I do not know whether he (the Holy Prophet) said (these words: "Then next") twice or thrice.

Book 31, Number 6156:

    Imran b. Husain reported Allah's-Messenger (may peace be upon him) as saying: The best among you (are) the people (who belong to) my age. Then those next to them, then those next to them, then those next to them. 'Imran said: I do not know whether Allah's Messenger (may peace be upon him) said twice or thrice (the words: "Then next") after (saying) about his (own age but he then said): Then after them (after successors or those who would succeed them) would come a people who would give evidence before they are asked for it, and would be dishonest and not trustworthy, who would make vows but would not fulfil them, and would be significant in being bulky.

Book 31, Number 6157:

    This hadith has been reported on the authority of Shu'ba with the same chain of transmitters (and the words are): I do not know whether he made a mention of two generations after his generation or of the third one too. Shababa said: I heard this from Zahdam b. Mudarrib as he came to me riding a horse for some need and he narrated it to me that he had heard it from 'Imran b. Husain, and in the hadith transmitted on the authority of Yahya and Shababa (the words are): They take an oath but they do not fulfil it, and in the hadith transmitted on the authority of Bahz there the word is Yafun as transmitted on the authority of Ibn Ja'far.

Book 31, Number 6158:

    This hadith has been narrated on the authority of 'Imran b. Husain through another chain of transmitters (and the words are): The best generation of this Umma is the generation to which I have been sent, then the next one, and there is an addition in the hadith transmitted on the authority of Abu 'Awana (and the words are): And Allah knows best whether he made a mention of the third (generation) or not; the rest of the hadith is the same as transmitted by Zahdam on the authority of 'Imran. And in the hadith transmitted by Hisham on the authority of Qatada there is an addition of these words: They take an oath whereas they are not asked to take.

Book 31, Number 6159:

    'A'isha reported that a person asked Allah's Apostle (may peace be upon him) as to who amongst the people were the best. He said: Of the generation to which I belong, then of the second generation (generation adjacent to my generation), then of the third generation (generation adjacent to the second generation).

Chapter 53 : MEANING OF THE SAYING OF THE PROPHET (MAY PEACE BE UPON HIM): "NO PERSON WOULD SURVIVE AFTER A CENTURY WHO IS LIVING BY THIS TIME OF MINE"

Book 31, Number 6160:

    'Abdullah b. Umar reported that Allah's Messenger (may peace be upon him) led us 'Isha' prayer at the latter part of the night and when he had concluded it by salutations he stood up and said : Have you seen this night of yours? At the end of one hundred years after this none would survive on the surface of the earth (from amount my Companions). Ibn Umar said: People were (not understanding) these words of the Messenger of Allah (may peace be upon him) which had been uttered pertaining to one hundred years. Allah's Messenger (may peace be upon him) in fact meant (by these words) that on that day none from amongst those who had been living upon the earth (from amongst his Companions) would survive (after one hundred years) and that would be the end of this generation.

Book 31, Number 6161:

    This hadith has been transmitted by Zuhri on the authority of Ma'mar.

Book 31, Number 6162:

    Jabir b. 'Abdullah reported: I heard Allah's Messenger (may peace be upon him) as saying this one month before his death: You asked me about the Last Hour whereas its knowledge is with Allah. I, however, take an oath and say that none upon the earth, the created beings (from amongst my Companions), would survive at the end of one hundred years. This hadith has been narrated on the authority of Ibn Juraij with the same chain of transmitters, but there is no mention of the words: "one month before his death".

Book 31, Number 6163:

    Jabir b. 'Abdullah reported Allah's Apostle (may peace be upon him) as saying one mouth before his death (or something like it): None amongst the created beings who had been living by that time (during the lifetime of Allah's Apostle) ....'Abd al-Rahman has interpreted these words of Allah's Apostle (may peace be upon him) as: The ages (of the people) would be diminished.

Book 31, Number 6164:

    This hadith has been reported on the authority of Sulaiman Taimi through other chains of transmitters.

Book 31, Number 6165:

    Abu Sa'id reported that when Allah's Apostle (may peace be upon him) came back from Tabuk they (his Companions) asked about the Last Hour. Thereupon Allah's Messenger (may peace be upon him) said: There would be none amongst the created beings living on the earth (who would survive this century).

Book 31, Number 6166:

    Jabir b. 'Abdullah reported that Allah's Messenger (may peace be upon him) said: None amongst the created beings (from my Companions) would survive after one hundred years. Salim said: We made a mention of it to him (Jabir), whereupon he said: It means those who had been living on that day.

Chapter 54 : IT IS FORBIDDEN TO REVILE THE COMPANIONS OF THE HOLY PROPHET (MAY PEACE BE UPON HIM)

Book 31, Number 6167:

    Abu Huraira reported Allah's Messenger (may peace be upon him) as saying: Do not revile my Companions, do not revile my Companions. By Him in Whose Hand is my life, if one amongst you would have spent as much gold as Uhud it would not amount to as much as one much on behalf of one of them or half of it.

Book 31, Number 6168:

    Abu Sa'id reported there was some altercation between Khalid b. Walid and Abd al-Rahman b. 'Auf and Khalid reviled him. Thereupon Allah's Messwger (may peace be upon him) said: None should revile my Companions. for if one amongst you were to spend as much gold as Uhud, it would not amount to as much as one mudd of one of them or half of it.

Book 31, Number 6169:

    This hadith has been transmitted on the authority of al-A'mash and there is no mention by Shu'ba and Waki' of 'Abd al-Rahman b. Auf and Khalid.

Chapter 55 : THE MERITS OF UWAIS QARANI (ALLAH BE PLEASED WITH HIM)

Book 31, Number 6170:

    Usair b. Jabir reported that a delegation from Kufa came to 'Umar and there was a person amongst them who jeered at Uwais. Thereupon Umar said: Is there amongst us one from Qaran? That person came and Umar said: Verily Allah's Messenger (may peace be upon him) has said: There would come to you a person from Yemen who would be called Uwais and he would leave none in Yemen (behind him) except his mother, and he would have the whiteness (due to leprosy) and he supplicated Allah and it was cured except for the size of a dinar or dirham. He who amongst you meets him should ask him to supplicate for forgiveness (from Allah) for you.

Book 31, Number 6171:

    'Umar b. Khattab reported: I heard Allah's Messenger (may peace be upon him) as saying: Worthy amongst the successors would be a person who would be called Uwais. He would have his mother (living with him) and he would have (a small) sign of leprosy. Ask him to beg pardon for you (from Allah).

Book 31, Number 6172:

    Usair b. Jabir reported that when people from Yemen came to help (the Muslim army at the time of jihad) he asked them: Is there amongst you Uwais b. 'Amir? (He continued finding him out) until he met Uwais. He said: Are you Uwais b. ,Amir? He said: Yes. He said: Are you from the tribe of Qaran? He said: Yes. He (Hadrat) 'Umar (again) said: Did you suffer from leprosy and then you were cured from it but for the space of a dirham ? He said: Yes. He ('Umar) said: Is your mother (living) ? He said: Yes. He ('Umar) said: I heard Allah's Messenger (may peace be upon him) say: There would come to you Uwais b. Amir with the reinforcement from the people of Yemen. (He would be) from Qaran, (the branch) of Murid. He had been suffering from leprosy from which he was cured but for a spot of a dirham. His treatment with his mother would have been excellent. If he were to take an oath in the name of Allah, He would honour that. And if it is possible for you, then do ask him to beg forgiveness for you (from your Lord). So he (Uwais) begged forgiveness for him. Umar said : Where do you intend to go ? He said : To Kufa. He ('Umar) said : Let me write a letter for you to its governor, whereupon he (Uwais) said : I love to live amongst the poor people. When it was the next year, a person from among the elite (of Kufa) performed Hajj and he met Umar. He asked him about Uwais. He said: I left him in a state with meagre means of sustenance. (Thereupon) Umar said: I heard Allah's Messenger (may peace be upon him) as saying: There would come to you Uwais b. 'Amir, of Qaran, a branch (of the tribe) of Murid, along with the reinforcement of the people of Yemen. He had been suffering from leprosy which would have been cured but for the space of a dirham. His treatment with his mother would have been very kind. If he would take an oath in the name of Allah (for something) He would honour it. Ask him to beg forgiveness for you (from Allah) in case it is possible for you. So he came to Uwais and said.: Beg forgiveness (from Allah) for me. He (Uwais) said: You have just come from a sacred journey (Hajj) ; you, therefore, ask forgiveness for me. He (the person who had performed Hajj) said: Ask forgiveness for me (from Allah). He (Uwais again) said: You have just come from the sacred journey, so you ask forgiveness for me. (Uwais further) said: Did you meet Umar? He said: Yes. He (Uwais) then begged forgiveness for him (from Allah). So the people came to know about (the status of religious piety) of Uwais. He went away (from that place). Usair said: His clothing consisted of a mantle, and whosoever saw him said: From where did Uwais get this mantle?

Chapter 56 : INSTRUCTIONS OF ALLAH'S APOSTLE (MAY PEACE BE UPON HIM) IN REGARD TO THE PEOPLE OF EGYPT

Book 31, Number 6173:

    Abu Dharr reported Allah's Messenger (may peace be upon him) as saying: You would soon conquer a land where people are in the habit of using foul language. They have a right of kinship upon you. And when you see two persons fighting for the space of a brick, then get out of that. He (Abu Dharr) then happened to pass by Rabila and 'Abd al-Rahman, the two sons of Shurahbil b. Hasana, and they had been disputing for the space of a brick. So he left the land.

Book 31, Number 6174:

    Abu Dharr reported Allah's Messenger (may peace be upon him) as saying: You would soon conquer Egypt and that is a land which is known (as the land of al-qirat). So when you conquer it, treat its inhabitants well. For there lies upon you the responsibility because of blood-tie or relationship of marriage (with them). And when you see two persons falling into dispute amongst themselves for the space of a brick, than get out of that. He (Abu Dharr) said: I saw Abd al-Rahman b. Shurahbil b. Hasana and his brother Rabi'a disputing with one another for the space of a brick. So I left that (land).

Chapter 57 : THE MERITS OF THE PEOPLE OF 'UMAN

Book 31, Number 6175:

    Abu Barza reported that Allah's Messenger (may peace be upon him) sent a person to a tribe amongst the tribes of Arabia. They reviled him and beat him. He came to Allah's Messenger (may peace be upon him) and narrated to him (the story of atrocities perpetrated upon him by the people of the tribe). Thereupon he (the Holy Prophet) said: If you were to come to the people of 'Uman, they would have neither reviled you nor beaten you.

Chapter 58 : PERTAINING TO THE GREAT LIAR OF THAQIF AND THE GREAT SLAUGHTERER

Book 31, Number 6176:

    Abu Naufal reported: I saw (the dead body) of Abdullah b. Zubair hanging on the road of Medina (leading to Mecca). The Quraish passed by it and other people too, that Abdullah b. Umar happened to pass by it. He stood up there and said: May there be peace upon you, Abu Khubaib (the Kunya of Hadrat 'Abdullah b. Zubair), may there be peace upon you Abu Khubaib, may there be peace upon you, Abu Khubaib ! By Allah, I used to forbid you from this; by Allah, I used to forbid you from this, by Allah I used to forbid you from this. By Allah, so far as I know, you had been very much devoted to fasting and prayer and you had been paying very much care to cementing the ties of blood. By Allah, the group to which you belong (are labelled) as (a) wicked (person) is indeed a fine group. Then 'Abdullah b. 'Umar went away. The stand 'Abdullah (b. 'Umar) took in regard to the inhuman treatment (meted out to 'Abdullah b. Zubair) and his words (in that connection) were conveyed to Hajjaj (b. Yusuf) and (as a consequence of that) he (the body of Abdullah b. Zubair) was brought down from the stump (the scaffold) by which it was hanging and thrown into the graves of the Jews. He (Hajjaj) sent (his messenger) to Asma' (bint Abu Bakr, 'Abdullah's mother). But she refused to come. He again sent the messenger to her with the message that she must come, otherwise he would bring her forcibly catching hold of her hair. But she again refused and said: By Allah, I will not come to you until you send one to me who would drag me by pulling my hair. Thereupon he said: Bring me my shoes. He put on his shoes and walked on quickly swollen with vanity and pride until he came to her and said: How do you find what I have done with the enemy of Allah? She said: I find that you wronged him in this world, whereas he has spoiled your next life. It has been conveyed to me that you used to call him ('Abdullah b. Zubair) as the son of one having two belts. By Allah, I am indeed (a woman) of two belts. One is that with the help of which I used to suspend high the food of Allah's Messenger (may peace be upon him) and that of Abu Bakr (making it out of the reach) of animals and, so far as the second belt is concerned, that is the belt which no woman can dispense with. Verily Allah's Messenger (may peace be upon him) told us that in Thaqif, there would be born a great liar and great murderer. The liar we have seen, and as far as the murderer is concerned, I do not find anyone else besides you. 'Thereupon he (Hajjaj) stood up and did not give any reply to her.

Chapter 59 : THE MERITS OF THE PEOPLE OF PERSIA

Book 31, Number 6177:

    Abu Huraira reported Allah's Messenger (may peace be upon him) as saying: If the din were at the Pleiades, even then a person from Persia would have taken hold of it, or one amongst the Persian descent would have surely found it.

Book 31, Number 6178:

    Abu Huraira reported: We were sitting in the company of Allah's Apostle (may peace be upon him) that Sura al-Jumu'a was revealed to him and when he recited (these words) : "Others from amongst them who have not yet joined them," a person amongst them (those who were sitting there) said: Allah's Messenger! But Allah's Apostle (may peace be upon him) made no reply, until he questioned him once, twice or thrice. And there was amongst us Salman the Persian. The Apostle of Allah (may peace be upon him) placed his hand on Salman and then said: Even if faith were near the Pleiades, a man from amongst these would surely find it.

Chapter 60 : THE SIMILITUDE OF PERSONS IS THAT OF CAMELS THAT ONE OUT OF HUNDRED IS NOT FOUND FIT FOR RIDING

Book 31, Number 6179:

    Ibn 'Umar reported Allah's Messenger (may peace be upon him) as saying: You would find people like one hundred camels and you would not find even one (camel) fit for riding.


Book 32: The Book of Virtue, Good Manners and Joining of the Ties of Relationship (KITAB AL-BIRR WAS-SALAT-I-WA'L-ADAB)

KITAB AL-BIRR WAS-SALAT-I-WA'L-ADAB
(THE BOOK OF VIRTUE, GOOD MANNERS AND JOINING OF THE TIES OF RELATIONSHIP)

Back
Chapter 1 : POLITENESS TOWARDS PARENTS AND THEIR RIGHT TO IT

Book 32, Number 6180:

    Abu Huraira reported that a person came to Allah,'s Messenger (may peace be upon him) and said : Who among the people is most deserving of a fine treatment from my hand ? He said : Your mother. He again said : Then who (is the next one) ? He said: Again it is your mother (who deserves the best treatment from you). He said: Then who (is the next one) ? He (the Holy Prophet) said : Again, it is your mother. He (again) said: Then who? Thereupon he said: Then it is your father. In the hadith transmitted on the authority of Qutalba, there is no mention of the word "the people".

Book 32, Number 6181:

    Abu Huraira reported that a person said: Allah's Messenger, who amongst the people is most deserving of my good treatment? He said: Your mother, again your mother, again your mother, then your father, then your nearest relatives according to the order (of nearness).

Book 32, Number 6182:

    Abu Huraira reported: A person came to Allah's Apostle (may peace be upon him). The rest of the hadith is the same as transmitted by jarir but with this addition: By your father, you would get the information.

Book 32, Number 6183:

    This hadith has been narrated on the authority of Ibn Shubruma with the same chain of transmitters and the hadith transmitted on the authority of Wuhaib there is a slight variation of wording. Same is the case with the hadith transmitted on the authority of Muhammad b. Talha (and the words are): "Who amongst the people deserves the best treatment from me".

Book 32, Number 6184:

    Abdullah b. 'Anir reported that a person came to Allah's Apostle (may peace be upon him) and sought permission (to participate) in Jihad, whereupon he (the Holy Prophet) said: Are your parents living? He said: Yes. Thereupon he (the Holy Prophet) said: You should put in your best efforts (in their) service.

Book 32, Number 6185:

    This hadith has been narrated on the authority of Habib with the same chain of transmitters.

Book 32, Number 6186:

    Yazid b. Abu Habib reported that Na'im, the freed slave of Umm Salama, reported to him that 'Abdullah b. 'Amr b. 'As said: There came to Allah's Apostle (may peace be upon him) a person and said: I owe allegiance to you for migration and Jihad seeking reward only from Allah. He (the Holy Prophet) said: Is one from amongst your parents living ? He said : Yes, of course, both are living. He further asked: Do you want to seek reward from Allah? He said: Yes. Thereupon Allah's Messenger (may peace be upon him) said : Go back to your parents and accord them benevolent treatment.

Chapter 2 : THE PREFERENCE OF BENEVOLENT TREATMENT TO PARENTS OVER VOLUNTARY PRAYERS, ETC.

Book 32, Number 6187:

    Abu Huraira reported that Juraij was one who was devoted to (prayer) in the temple. His mother came to him. Humaid said that Abu Rafi' demonstrated before us like the demonstration made by abu Huraira to whom Allah's Messenger (may peace be upon him) had demonstrated as his mother called him placing her palms upon the eyebrows and lifting her head for calling him and said: Juraij, it is your mother, so talk to her. She found him at that time absorbed in prayer, so he said (to himself): O Lord, my mother (is calling me) (whereas I am absorbed) in my prayer. He opted for prayer. She (his mother) went back, then came again for the second time and said: O Juraij, it is your mother (calling you), so talk to me. He said: O Allah. there is my mother also and my prayer, and he opted for prayer. She said: O Allah, this Juraij is my son. I pray to talk to him but he refuses to talk to me. O Allah, don't bring death to him unless he has seen the prostitutes, and had she invoked the curse upon him (from the heart of her heart) he would have been involved in some turmoil. There was a shepherd living near by his temple (the temple where Juraij was engaged in prayer). It so happened that a woman of that village came there and that shepherd committed fornication with her and she became pregnant and gave birth to a child. It was said to her: Whose child is this? She said: He is the child of one who is living in this temple. So there came persons with hatchets and spades. They called Juraij. He was absorbed in prayer and he did not talk to them and they were about to demolish that temple that he saw them and then came to them and they said: Ask her (this woman) what she says. He smiled and then touched the head of the child and said: Who is your father? He (the child) said: My father is the shepherd of the sheep, and when they heard this, they said: We are prepared to rebuild with gold and silver what we have demolished from your temple. He said: No, rebuild it with clay as it had been before. He then went up (to his room and absorbed himself in prayer).

Book 32, Number 6188:

    Abu Huraira reported Allah's Apostle (may peace be upon him) as saying: None spoke in the cradle but only three (persons), Christ son of Mary, the second one the companion of Juraij. Juraij had got constructed a temple and confined himself in that. His mother came to him as he was busy in prayer and she said: Juraij. He said: My Lord, my mother (is calling me while I am engaged in) my prayer. He continued with the prayer. She returned and she came on the next day and he was busy in prayer, and she said: Juraij. And he said: My Lord, my mother (is calling me while I am engaged) in prayer, and he continued with the prayer and she went back, and then on the next day she again came and he was busy in prayer and she said: Juraij. And he said: My Lord, my mother (is calling me while I am engaged in my prayer, and he continued with the prayer, and she said: My Lord, don't give him death unless he has seen the fate of the prostitutes. The story of Juraij and that of his meditation and prayer gained currency amongst Bani Isra'il. There was a prostitute who had been a beauty incarnate. She said (to the people): If you like I can allure him to evil. She presented herself to him but he paid no heed (to her). She came to a shepherd who lived near the temple and she offered herself to him and he had a sexual intercourse with her and so she became pregnant arid when she gave birth to a child she said: This is from Juraij. So they came and asked him to get down and demolished the temple and began to beat him. He said: What is the matter? They said: You have committed fornication with this prostitute and she has given birth to a child from your loins. He said: Where is the child ? They brought him (the child) and he said: just leave me so that I should observe prayer. And he observed prayer and when he finished, he came to the child. He struck his stomach and said: O boy, who is your father? lie said: He is such shepherd. So they turned towards Juraij, kissed him and touched him (for seeking blessing) and said: We are prepared to construct your temple with gold. He said. No, just rebuild it with mud as it had been, and they did that. Then there was a babe who was sucking his mother that a person dressed in fine garment came riding upon a beast. His mother said: O Allah, make my child like this one. He (the babe) left sucking and began to see towards him, and said: O Allah, don't make me like him. He then returned to the chest and began to suck the milk of his mother. He (Abu Huraira) said: I perceived as if I am seeing Allah's Messenger (may peace be upon him) as he is explaining the scene of his sucking milk with his forefinger in his mouth and sucking that. He (Abu Huraira) further reported Allah's Apostle (may be peace upon him) as saying: There happened to pass by him a girl who was being beaten and they were saying: You have committed adultery and you have committed theft and she was saying: Allah is enough for me and He is my good Protector, and his mother said: O Allah, don't make my child like her and he left sucking the milk, and looked towards her and said: O Allah, make me like her, and there was a talk between them. She said: O with shaven head, a good-looking person happened to pass by and I said: O Allah, make my child like him, and you said: O Allah, don't make me like him, and they passed by a girl while they were beating her and saying: You committed fornication and you committed theft, and I said: O Allah, don't make my child like her, and you said: O Allah, make me like her. Thereupon he said: That person was a tyrant, and I said: O Allah, don't make me like him, and they were saying about her: You committed fornication whereas in fact she had not committed that and they were saying: You have committed theft whereas she had not committed theft, so I said: O Allah, make me like her.

Book 32, Number 6189:

    Abu Huraira reported Allah's Apostle (may peace be upon him) as saying: Let him be humbled into dust; let him be humbled into dust. It was said: Allah's Messenger, who is he? He said: He who sees either of his parents during their old age or he sees both of them, but he does not enter Paradise.

Book 32, Number 6190:

    Abu Huraira reported Allah's Messenger (may peace be upon him) as saying: Let him be humbled, let him be humbled. It was said: Allah's Messenger, who is he? He said. He who finds his parents in old age, either one or both of them, and does not enter Paradise.

Book 32, Number 6191:

    Abu Huraira reported Allah's Messenger (may peace be upon him) as saying: Let him be humbled thrice, and the rest of the hadith is the same.

Chapter 3 : KINDNESS TOWARDS THE FRIENDS OF ONE'S FATHER AND MOTHER

Book 32, Number 6192:

    Ibn Dinar reported that a desert Arab met Abdullah b. 'Umar on the way to Mecca. 'Abdullah greeted him and mounted him upon the donkey on which he had been riding and gave him the turban that he had on his head. Ibn Dinar (further) reported: We said to him ('Abdullah b. 'Umar): May Allah do good to you, these are desert Arabs and they are satisfied even with meagre (things). Thereupon Abdullah said: His father was loved dearly by 'Umar b. Khattib and I heard Allah's Messenger (may peace be upon him) as saying: The finest act of goodness on the part of a son is to treat kindly the loved ones of his father.

Book 32, Number 6193:

    'Abdullah b. Umar reported Allah's Apostle (may peace be upon him) as saying: The finest act of goodness is that a person should treat kindly the loved ones of his father.

Book 32, Number 6194:

    Abdullah b. Dinar reported that when 'Abdullah b. 'Umar set out to Mecea,'he kept a donkey with him which he used as a diversion from the tedium of journey on the camel's back and had a turban which he tied round his head. One day, as he was riding the donkey a desert Arab happened to pass by him. He ('Abdullah b. 'Umar) said: Arn't you so and so? He said: Yes He gave him his donkey and said: Ride it, and tie the turban round your head. Some of his companions said: May Allah pardon you, you gave to this desert Arab the donkey on which you enjoyed ride for diversion and the turban which you tied round your.head. Thereupon he said: Verily I heard Allah's Messenger (may peace be upon him) as saying: The finest act of goodness is the kind treatment of a person to the loved ones of his father after his death and the father of this person was a friend of 'Umar.

Book 32, Number 6195:

    Nawwas b. Sim'an al-Ansiri reported: I asked Allah's Messenger (may peace be upon him) about virtue and vice. He said: Virtue is a kind disposition and vice is what rankles in your heart and that you disapprove that people should come to know of it.

Book 32, Number 6196:

    Nawwis b. Sim'in reported: I stayed with Allah's Messenger (may peace be upon him) for one year. What obstructed me to migrate was (nothing) but (persistent) inquiries from him (about Islam). (It was a common observation) that when anyone of us migrated (to Medina) he ceased to ask (too many questions) from Allah's Messenger (may peace be upon him). So I asked him about virtue and vice. Thereupon Allah's Messenger (may peace be upon him) said: Virtue is a kind disposition and vice is what rankles in your mind and that you disapprove of its being known to the people.

Chapter 4 : JOINING THE TIE OF RELATIONSHIP AND PROHIBITION TO BREAK IT

Book 32, Number 6197:

    Abu Huraira reported that Allah's Messenger (may peace be upon him) said: Verily Allah created the universe and when He had finished that, ties of relationship came forward and said This is the place for him who seeks refuge from severing (of blood-relationship). He said: Yes. Are you not satisfied that I should keep relationship with one who joins your ties of relationship and sever it with one who severs your (ties of relationship)? They (the ties of blood) said: Certainly so. Thereupon He said: Well, that is how things are for you. Allah's Messenger (may peace be upon him) then said: Recite if you like: "But if you turn away you are sure to make mischief in the land and cut off the ties of kinship. Those it is whom Allah has cursed, so He has made them deaf and blinded their eyes. Do they not reflect on the Qur'an? Or, are there locks on their hearts?" .

Book 32, Number 6198:

    'A'isha reported Allah's Messenger (may peace be upon him) as saying: The tie of kinship is suspended to the Throne and says: He who unites me Allah would unite him and he who severed me Allah would sever him.

Book 32, Number 6199:

    Jubair b. Mut'im reported on the authority of his father that Allah's Messenger (may peace be upon him) said: The severer would not enter Paradise. Ibn Umar said that Sufyan (explained it as): One who severs the tie of kinship would not enter Paradise.

Book 32, Number 6200:

    Jubair b. Mutlim reported that his father narrated to him that Allah's Messenger (may peace be upon him) said: The severer of the tie of kinship would not get into Paradise.

Book 32, Number 6201:

    This hadith has been narrated on the authority of Zuhri with the same chain of transmitters.

Book 32, Number 6202:

    Anas b. Malik reported: I heard Allah's Messenger (may peace be upon him) as saying: He who is desirous that his means of sustenance should be expanded for him or his age may be lengthened, should join the tie of relationship.

Book 32, Number 6203:

    Anas b. Malik reported that Allah's Messenger (may peace be upon him) said: He who likes that his sustenance should be expanded and his age may be lengthened should join the tie of kinship.

Book 32, Number 6204:

    Abu Huraira reported that a person said: Allah's Messenger, I have relatives with whom I try, to have close relationship, but they sever (this relation). I treat them well, but they treat me ill. I am sweet to them but they are harsh towards me. Upon this he (the Holy Prophet) said: If it is so as you say, then you in fact throw hot ashes (upon their faces) and there would always remain with you on behalf of Allah (an Angel to support you) who would keep you dominant over them so long as you adhere to this (path of righteousness).

Chapter 5 : FORBIDDANCE OF NURSING MUTUAL JEALOUSY, MUTUAL HATRED AND MUTUAL HOSTILITY

Book 32, Number 6205:

    Anas b. Malik reported Allah's Messenger (may peace be upon him) as saying: Neither nurse mutual hatred, nor jealousy, nor enmity, and become as fellow. brothers and servants of Allah. It is not lawful fora Muslim that he should keep his relations estranged with his brother beyond three days.

Book 32, Number 6206:

    Anas b. Malik reported Allah's Messenger (may peace be upon him) as saying like this. This hadith has been narrated through another chain of transmitters.

Book 32, Number 6207:

    This hadith has been narrated on the authority of Zuhri with the same chain of transmitters with the addition of Ibn Uyaina (and the words are) : "Do not cut off (mutual relations)."

Book 32, Number 6208:

    This hadith has been narrated through another chain of transmitters and the hadith transmitted on the authority of Abd al-Razziq (the words are): "Neither nurse grudge nor sever (the ties of kinship), nor nurse enmity."

Book 32, Number 6209:

    Anas reported Allah's Apostle (may peace be upon him) as saying: Nurse no grudge, nurse no aversion and do not sever ties of kinship and live like fellow-brothers as servants of Allah. This hadith has been narrated on the authority of Shu'ba with the same chain of transmitters but with this addition: "As Allah has commanded you."

Chapter 6 : IT IS FORBIDDEN FOR A MUSLIM TO HAVE ESTRANGED RELATIONS WITH THE OTHER MUSLIM BEYOND THREE DAYS WITHOUT ANY REASON OF SHARI'AH

Book 32, Number 6210:

    Abu Ayyub Ansiri reported Allah's Messenger (may peace be upon him) as saying: It is not permissible for a Muslim to have estranged relations with his brother beyond three nights, the one turning one way and the other turning the other way when they meet ; the better of the two is one who is the first to give a greeting.

Book 32, Number 6211:

    This hadith has been transmitted on the authority of Zuhri with a slight variation of wording (and the words are) : "The one turning away and the other turning away when they meet and one avoids the other and the other also avoids him."

Book 32, Number 6212:

    'Abdullah b. 'Umar reported Allah's Messenger (may peace be upon him) as saying: It is not permissible for a Muslim to have estranged relations with his brother beyond three days.

Book 32, Number 6213:

    Abu Huraira reported Allah's Messenger (may peace be upon him) as saying: There should be no estranged relations beyond three days.

Chapter 7 : FORBIDDANCE OF SUSPICION, FAULT-FINDING, AND BIDDING AGAINST THE OTHER (FOR RAISING THE PRICE)

Book 32, Number 6214:

    Abu Huraira reported Allah's Messenger (may peace be upon him) as saying: Avoid suspicion, for suspicion is the gravest lie in talk and do not be inquisitive about one another and do not spy upon one another and do not feel envy with the other, and nurse no malice, and nurse no aversion and hostility against one another. And be fellow-brothers and servants of Allah.

Book 32, Number 6215:

    Abu Huraira reported Allah's Messenger (may peace be upon him) as saying: Don't have estranged relations (with the others) and don't nurse enmity and don't enter into a transaction when the other (has already entered) and be fellow-brothers and servants of Allah.

Book 32, Number 6216:

    Abu Huraira reported Allah's Messenger (may peace be upon him) as saying. Don't nurse malice against one another, don't nurse aversion against one another and don't be inquisitive about one another and don't outbid one another (with a view to raising the price) and be fellow-brothers and servants of Allah.

Book 32, Number 6217:

    This hadith has been narrated on the authority of A'mash with the same chain of transmit ters (and the words are) : "Don't sever relations of kinship, don't bear enmity against one another, don't bear aversion against one another and don't feel envy against the other and live as fellow-brothers as Allah has commanded you.

Book 32, Number 6218:

    Abu Huraira reported Allah's Messenger (may peace be upon him) as saying: Don't bear aversion against one another and don't be jealous of one another and be servants of Allah.

Chapter 8 : IT IS FORBIDDEN TO PERPETRATE ATROCITY UPON A MUSLIM, TO HUMILIATE HIM, TO INSULT HIM, AND INVIOLABLE IS HIS BLOOD, HONOUR AND WEALTH

Book 32, Number 6219:

    Abu Huraira reported Allah's Messenger (may peace be upon him) as saying: Don't nurse grudge and don't bid him out for raising the price and don't nurse aversion or enmity and don't enter into a transaction when the others have entered into that transaction and be as fellow-brothers and servants of Allah. A Muslim is the brother of a Muslim. He neither oppresses him nor humiliates him nor looks down upon him. The piety is here, (and while saying so) he pointed towards his chest thrice. It is a serious evil for a Muslim that he should look down upon his brother Muslim. All things of a Muslim are inviolable for his brother in faith: his blood, his wealth and his honour.

Book 32, Number 6220:

    This hadith has been transmitted on the authority of Abu Huraira with some addition (and it is this): "Verily Allah does not look to your bodies nor to your faces but He looks to your hearts," and he pointed towards the heart with his fingers.

Book 32, Number 6221:

    Abu Huraira reported Allah's Messenger (may peace be upqn him) as saying: Verily Allah does not look to your faces and your wealth but He looks to your heart and to your deeds.

Chapter 9 : IT IS FORBIDDEN TO NURSE RANCOUR

Book 32, Number 6222:

    Abu Huraira reported Allah's Messenger (may peace be upon him) as saying: The gates of Paradise are not opened but on two days, Monday and Thursday. and then every servant (of Allah) is granted pardon who does not associate anything with Allah except the person in whose (heart) there is rancour against his brother. And it would be said : Look towards both of them until there is reconciliation ; look toward both of them until there is reconciliation; look towards both of them until there is reconciliation. This hadith has been narrated on the authority of Suhail who narrated it on the authority of his father with the chain of transmitters of MaIik, but with this variation of wording: ,(Those would not be granted pardon) who bycott each other."

Book 32, Number 6223:

    Abu Huraira reported it as a marfu' hadith (and the words are) : The deeds are presented on every Thursday and Friday and Allah, the Exalted and Glorious. grants pardon to every person who does not associate anything with Allah except the person in whose (heart) there is rancour against his brother. It would be said: Put both of them off until they are reconciled.

Book 32, Number 6224:

    Abu Huraim reported Allah's Messenger (may peace be upon him) as saying The deeds of people would be presented every week on two days, viz. Monday and Thursday, and every believing servant would be granted pardon except the one in whose (heart) there is rancour against his brother and it would he said: Leave them and put them off until they are turned to reconciliation.

Chapter 10 : MERIT OF LOVE FOR THE SAKE OF ALLAH

Book 32, Number 6225:

    Abu Huraira reported Allah's Messenger (may peace be upon him) as saying: Verily. Allah would say on the Day of Resurrection: Where are those who have mutual love for My Glory's sake? Today I shall shelter them in My shadow when there is no other shadow but the shadow of Mine.

Book 32, Number 6226:

    Abu Huraira reported Allah's Apostle (may peace be upon him) as saying: A person visited his brother in another town and Allah deputed an Angel to wait for him on his way and when he came to him he said: Where do you intend to go? He said: I intend to go to my brother in this town. He said: Have you done any favour to him (the repayment of which you intend to get) ? He said: No,excepting this that I love Mm for the sake of Allah, the Exalted and Glorious. Thereupon he said: I am a meesenger to you from, Allah:(to inform you) that Allah loves you as you love him (for His sake) This hadith has been narrated on the authority of Hammid b. Salama with the same of transmitters.

Chapter 11 : MERIT OF VISITING THE SICK

Book 32, Number 6227:

    Abu Rabi' reported directly from Allah's Apostle (may peace upon him) as saying: The one who visits the sick is in fact like one who is in the fruit garden of Paradise so long as he does not return.

Book 32, Number 6228:

    Thauban, the freed slave of Allah's Messenger (may peace be upon him), reported that Allah's Messenger (may peace be upon him) said: He who visits the sick continues to remain in the fruit garden of Paradise until he returns.

Book 32, Number 6229:

    Thauban reported Allah's Apostle (may peace be upon him) as saying: Verily, when a Muslim visits his brother in Islam he is supposed to remain in the fruit garden of Paradise until he returns.

Book 32, Number 6230:

    Thauban, the freed slave of Allah's Messenger (may peace be upon him), reported Allah's Messenger (may peace be upon him) as saying: He who visits the sick is supposed to remain in the fruit garden of Paradise.It was said : Allah's Messenger, what is this Khurfat-ul-jannah? He said: It is a place abounding in fruits.

Book 32, Number 6231:

    This hadith has been narrated on the authority of Asim al-Ahwal with the same chain of transmitters.

Book 32, Number 6232:

    Abu Huraira reported Allah's Messenger (may peace be upon him) as saying : Verily, Allah, the Exalted and Glorious, would say on the Day of Resurrection: O son of Adam, I was sick but you did not visit Me. He would say: O my Lord; how could I visit Thee whereas Thou art the Lord of the worlds? Thereupon He would say: Didn't you know that such and such servant of Mine was sick but you did not visit him and were you not aware of this that if you had visited him, you would have found Me by him? O son of Adam, I asked food from you but you did not feed Me. He would say: My Lord, how could I feed Thee whereas Thou art the Lord of the worlds? He said: Didn't you know that such and such servant of Mine asked food from you but you did not feed him, and were you not aware that if you had fed him you would have found him by My side? (The Lord would again say:) O son of Adam, I asked drink from you but you did not provide Me. He would say: My Lord, how could I provide Thee whereas Thou art the Lord of the worlds? Thereupon He would say: Such and such of servant of Mine asked you for a drink but you did not provide him, and had you provided him drink you would have found him near Me.

Chapter 12 : WHENEVER A BELIEVER FALLS SICK OR IS STRICKEN WITH GRIEF OR SOMETHING LIKE IT, THERE IS A REWARD FOR HIM EVEN IF IT IS PRICKING OF A THORN

Book 32, Number 6233:

    'A'isha reported, I did not see anyone else being afflicted with more severe illness than Allah's Messenger (may peace be upon him). In the narration transmitted by 'Uthman there is a slight variation of wording.

Book 32, Number 6234:

    This hadith has been narrated on the authority of A'mash through other chains of transmitters.

Book 32, Number 6235:

    'Abdullah reported: I visited Allah's Messenger (may peace be upon him) as he was running high temperature. I touched his body with my bard and said to him: Allah's Messenger, you are running high temperature, whereupon Allah's Messenger (may peace be upon him) said : Yes, it is so. I comparatively have a more severe fever than any one of you. I said : Is it because there is a double reward in store for you ? Thereupon Allah's Messenger (may peace be upon him) said : Yes, it is so. And Allah's Messenger (may peace be upon him) again said: When a Muslim falls ill, his compensation is that his minor sins are obliterated just as leaves tall (in autumn). In the hadith transmitted on the authority of Zubair there is (no mention of these words) : "I touched his body with my hands."

Book 32, Number 6236:

    This hadith has been transmitted on the authority of jarir and the hadith transmitted on the authority of Abu Mu'awiya there is an addition of these words: He said: Yes, by Him in Whose Hand is my life, there is no Muslim upon the earth." The rest of the hadith is the same.

Book 32, Number 6237:

    Aswad reported that some young men from the Quraish visited 'A'isha as she was in Mina and they were laughing. She said: What makes you laugh? They said: Such and such person stumbled against the rope of the tent and he was about to break his neck or lose his eyes. She said: Don't laugh for I heard Allah's Messenger (may peace be upon him) as saying: If a Muslim runs a thorn or (gets into trouble) severe than this, there is assured for him (a higher) rank and his sins are obliterated.

Book 32, Number 6238:

    'A'isha reported Allah's Messenger (may peace be upon him) as saying: A believer does not receive (the trouble) of running a thorn or more than that but Allah elevates him in rank or effaces his sins because of tbat.

Book 32, Number 6239:

    'A'isha reported Allah's Messenger (may peace be upon him) as saying: A believer does not undergo (the trouble) of running a thorn or more than that when Allah effaces his sins.

Book 32, Number 6240:

    'A'isha said: No trouble comes to a believer even if it is the pricking of a thorn that it becomes (the means) whereby his sins are effaced or his sins are obliterated. Yazid says: He does not know which word 'Urwa said (whether he said Qussa or Kuffira).

Book 32, Number 6241:

    'A'isha reported: I heard Allah's Messenger (may peace be upon him) as saying: There is nothing (in the form of trouble) that comes to a believer even if it is the pricking of a thorn that there is decreed for him by Allah good or his sins are obliterated.

Book 32, Number 6242:

    Abu Sa'id and abu Huraira reported that they heard Allah's Messenger (may peace be upon him) as saying: Never a believer is stricken with discomfort, hardship or illness, grief or even with mental worry that his sins are not expiated for him.

Book 32, Number 6243:

    Abu Huraira reported that when this verse was revealed: "Whoever does evil will be requited for it" , and when this was conveyed to the Muslims they were greatly perturbed. Thereupon Allah's Messenger (may peace be upon him) said: Be moderate and stand firm in trouble that falls to the lot of a Muslim (as that) is an expiation for him ; even stumbling on the path or the prickin of a thorn (are an expiation for him). Muslim said that 'Umar b. Abd al-Rahman Muhaisin was from amongst the people of Mecca.

Book 32, Number 6244:

    Jabir b. Abdullah reported that Allah's Messenger (may peace be upon him) visited Umm Sa'ib or Umm Musayyib and said: Umm Sa'ib or Umm Musayyib. why is it that you are shivering? She said: "It is fever and may it not be blessed by Allah, whereupon he (the Holy Prophet) said: Don't curse fever for it expiates the sir of the posterity of Adam just as furnace removes the alloy of iron.

Book 32, Number 6245:

    'Ata' b. Abi Rabih said: Ibn Abbas said to me: May I show you a woman of Paradise? I said: Yes. He said: Here is this dark-complexioned woman. She came to Allah's Apostle (may peace be upon him) and said: I am suffering from falling sickness and I become naked; supplicate Allah for me, whereupon he (the Holy Prophet) said: Show endurance as you can do and there would be Paradise for you and, if you desire, I supplicate Allah that He may cure you. She said: I am prepared to show endurance (but the unbearable trouble is) that I become naked, so supplicate Allah that He should not let me become naked, so he supplicated for her.

Chapter 13 : IT IS FORBIDDEN TO COMMIT OPPRESSION

Book 32, Number 6246:

    Abu Dharr reported Allah's Messenger (may peace be upon him) as saying that Allah, the Exalted and Glorious, said: My servants, I have made oppression unlawful for Me and unlawful for you, so do not commit oppression against one another. My servants, all of you are liable to err except one whom I guide on the right path, so seek right guidance from Me so that I should direct you to the right path. O My servants, all of you are hungry (needy) except one whom I feed, so beg food from Me, so that I may give that to you. O My servants, all of you are naked (need clothes) except one whom I provide garments, so beg clothes from Me, so that I should clothe you. O My servants, you commit error night and day and I am there to pardon your sins, so beg pardon from Me so that I should grant you pardon. O My servants, you can neither do Me any harm nor can you do Me any good. O My servants, even if the first amongst you and the last amongst you and even the whole of human race of yours, and that of jinns even, become (equal in) God-conscious like the heart of a single person amongst you, nothing would add to My Power. O My servants, even if the first amongst you and the last amongst you and the whole human race of yours and that of the Jinns too in unison become the most wicked (all beating) like the heart of a single person, it would cause no loss to My Power. O My servants, even if the first amongst you and the last amongst you and the whole human race of yours and that of jinns also all stand in one plain ground and you ask Me and I confer upon every person what he asks for, it would not. in any way, cause any loss to Me (even less) than that which is caused to the ocean by dipping the needle in it. My servants, these for you I shall reward you for thern, so he who deeds of yours which I am recording finds good should praise Allah and he who does not find that should not blame anyone but his ownself. Sa'id said that when Abu Idris Khaulini narrated this hadith he knelt upon his knees.

Book 32, Number 6247:

    Abu Dharr reported Allah's Messenger (may peace be upon him) as saying that he reported it from his Lord, the Exalted and Glorious: Verily I have made oppression unlawful for Me and for My servants too, so do not commit oppression. The rest of the hadith is the same.

Book 32, Number 6248:

    Jabir b. Abdullah reported that Allah's Messenger (may peace be upon him) said: Be on your guardagainst committing oppression, for oppression is a darkness on the Day of Resurrection, and be on your guard against pettimindedness for pettimindedness destroyed those who were before you, as it incited them to shed blood and make lawful what was unlawful for them.

Book 32, Number 6249:

    Ibu 'Umar reported Allah's Messenger (may peace be upon him) as saying: Oppression is the darkness on the Day of Resurrection.

Book 32, Number 6250:

    Salim reported on the authority of his father that Allah's Messenger (may peace be upon him) said: A Muslim is the brother of a fellow-Muslim. He should neither commit oppression upon him nor ruin him, and he who meets the need of a brot'ier, Allah would meet big needs, and he who relieved a Muslim from hardship Allah would relieve him from the hardships to which he would be put on the Day of Resurrection, and he who did not expose (the follies of a Muslim) Allah would conceal his follies on the Day of Resurrection.

Book 32, Number 6251:

    Abu Huraira.reported Allah's Messenger (may peace be upon him) as saying: Do you know who is poor? They (the Companions of the Holy Prophet) said: A poor man amongst us is one who has neither dirham with him nor wealth. He (the Holy Prophet) said: The poor of my Umma would be he who would come on the Day of Resurrecton with prayers and fasts and Zakat but (he would find himself bankrupt on that day as he would have exhausted his funds of virtues) since he hurled abuses upon others, brought calumny against others and unlawfully consumed the wealth of others and shed the blood of others and beat others, and his virtues would be credited to the account of one (who suffered at his hand). And if his good deeds fall short to clear the account, then his sins would be entered in (his account) and he would be thrown in the Hell-Fire.

Book 32, Number 6252:

    Abu Huraira reported Allah's Messenger (may peace be upon him) as saying: The claimants would get their claims on the Day of Ressurection so much so that the hornless sheep would get its claim from the horned sheep.

Book 32, Number 6253:

    Abu Musa reported Allah's Messenger (may peace be upon him) as saying: Allah, the Exalted and Glorious, grants respite to the oppessor.But when He lays Hand upon him, He does not then let him off. Re (the Holy Prophet) then recited this verse: "Such is the chastisement of thy Lord when He chastises the towns (inhabited by) wrongdoing persons. Surely, His punishment is painful, severe"(xi.103).

Chapter 14 : HELP YOUR BROTHER WHETHER IIE IS AN OPPRESSOR OR AN OPPRESSED ONE

Book 32, Number 6254:

    Jabir b. Abdullah reported that two young men, one from the Muhajirin (emigrants) and the other one from the Angr (helpers) fell into dispute and the Muhajir called his fellow Muhajirin, and the Ansari (the helper) called the Ansar (for help). In the meanwhile, Allah's Messenger (may peace be upon him) came there and said: What is this, the proclamation of the days of jahiliya (ignorance)? They said: Allah's Messenger, there is nothing serious. The two young men fell into dispute and the one struck at the back of the other. Thereupon he (the Holy Prophet) said: Well, a person should help his brother whether he is an oppressor or an oppressed. If he is the oppressor he should prevent him from doing it, for that is his help; and if he is the oppressed he should be helped (against oppression).

Book 32, Number 6255:

    Jabir b. Abdullah reported: We were along with Allah's Messenger (may peace be upon him) in an expedition that a person from amongst the emigrants struck at the back of a person from the Ansir. The Ansiri said: O Ansar! And the Muhijir said: O Emigrants! Thereupon Allah's Messenger (may peace be upon him) said: What are these proclamations of the Days of Ignorance ? They said: Allah's Messenger, a person from the emigrants struck at the back of an Ansari, whereupon he said: It is something disgusting. 'Abdullah b. Ubayy heard it and said: They have indeed done it. By Allah, when we would return to Medina the respectable amongst them (the Ansar) would turn away the mean (the emigrants). Thereupon 'Umar said: Permit me so that I should strike the neck of this hypocrite. But he (the Holy Prophet) said: Leave him, the people may not say that Muhammad kills his companions.

Book 32, Number 6256:

    Jabir b. 'Abdullah reported that a person from the emigrants struck the back of an Ansari. He came to Allah's Apostle (may peace be upon him) and asked for compensation. Thereupon Allah's Apostle (may peace be upon him) said: Leave it. for it is something disgusting. Ibn Mansur said that in the narration transmitted on the authority of Amr (these words are also found) : "I heard Jabir."

Chapter 15 : THERE SHOULD BE MUTUAL FELLOW-FEELING AND LOVE AND THE WILL TO HELP EACH OTHER AMONGST THE BELIEVERS

Book 32, Number 6257:

    Abu Musa reported Allah's Messenger (may peace be upon him) as saying: A believer is like a brick for another believer, the one supporting the other.

Book 32, Number 6258:

    Nu'man b. Bashir reported Allah's Messenger (may peace be upon him) as saying: The similitude of believers in regard to mutual love, affection, fellow-feeling is that of one body; when any limb of it aches, the whole body aches, because of sleeplessness and fever.

Book 32, Number 6259:

    Nu'man b. Bashir reported a hadith like this from Allah's Apostle (may peace be upon him).

Book 32, Number 6260:

    Nu'man b. Bashir reported Allah's Messenger (may peace be upon him) as saying: The believers are like one person; if his head aches, the whole body aches with fever and sleeplessness.

Book 32, Number 6261:

    Nu'man b. Bashir reported that Muslims are like one body of a person; if the eye is sore, the whole body aches, and if the head aches, the whole body aches.

Book 32, Number 6262:

    A hadith like this has been narrated on the authority of Nu'man b. Bashir through another chain of transmitters.

Chapter 16 : IT IS FORBIDDEN TO INDULGE IN ABUSING

Book 32, Number 6263:

    Abu Huraira reported Allah's Messenger (may peace be upon him) as saying: When two persons indulge in hurling (abuses) upon one another, it would be the first one who would be the sinner so long as the oppressed does not transgress the limits.

Chapter 17 : THE MERITS OF FORGIVENESS AND HUMILITY

Book 32, Number 6264:

    Abu Huraira reported Allah's Messenger (may peace be upon him) as saying: Charity does not in any way decrease the wealth and the servant who forgives Allah adds to his respect, and the one who shows humility Allah elevates him in the estimation (of the people).

Chapter 18 : THE PROHIBITION OF BACKBITING

Book 32, Number 6265:

    Abu Huraira reported Allah's Messenger (may peace be upon him) as saying: Do you know what is backbiting? They (the Companions) said: Allah and His Messenger know best. Thereupon he (the Holy Prophet) said: Backbiting implies your talking about your brother in a manner which he does not like. It was said to him: What is your opinion about this that if I actually find (that failing) in my brother which I made a mention of ? He said: If (that failing) is actually found (in him) what you assert, you in fact backbited him, and if that is not in him it is a slander.

Chapter 19 : TIDINGS FOR ONE WHOSE FAULTS ALLAH CONCEALED IN THIS WORLD; HE WILL ALSO CONCEAL HIS FAULTS IN THE HEREAFTER

Book 32, Number 6266:

    Abu Huraira reported Allah's Apostle (may peace be upon him) as saying: The servant (whose fault) Allah conceals in this world, Allah would also conceal (his faults) on the Day of Resurrection.

Book 32, Number 6267:

    Abu Huraira reported Allah's Apostle (may peace be upon him) as saying: The servant (who conceals) the faults of others in this world, Allah would conceal his faults on the Day of Resurrection.

Chapter 20 : ACCORDING OF BENEVOLENT TREATMENT TO ONE FROM WHOM ONE EXPECTS TRANSGRESSION

Book 32, Number 6268:

    A'isha reported that a person sought permission from Allah's Apostle (may peace be upon him) to see him. He said: Grant him permission. (and also added:) He is a bad son of his tribe or he is a bad person of his tribe. When he came in he used kind words for him. 'A'isha reported that she said: Allah's Messenger, you said about him what you had to say and then you treated him with kindness. He said: A'isha, verily in the eye of Allah, worst amongst the person in rank on the Day of Resurrection is one whom the people abandon or desert out of the fear of indecency.

Book 32, Number 6269:

    This hadith has been reported on the authority of Ibn Munkadir with the same chain of transmitters but with a slight variation of wording.

Chapter 21 : MERIT OF BENEVOLENT TREATMENT

Book 32, Number 6270:

    Jarir reported from Allah's Messenger (may peace be upon him) : He who is deprived of tenderly feelings is in fact deprived of good.

Book 32, Number 6271:

    Jarir reported Allah's Messenger (may peace be upon him) as saying: He who is deprived of tenderly feelings is in fact deprived of good.

Book 32, Number 6272:

    Jarir b. 'Abdullah reported Allah's Apostle (may peace be upon him) as saying: He who is deprived of tenderly feelings is in fact deprived of good and he who is deprived of tenderly feelings is in fact deprived of good.

Book 32, Number 6273:

    'A'isha, the wife of Allah's Apostle (may peace be upon him), reported that Allah's Messenger (may peace be upon him) said: 'A'isha, verily Allah is kind and He loves kindness and confers upon kindness which he does not confer upon severity and does not confer upon anything else besides it (kindness).

Book 32, Number 6274:

    'A'isha, the wife of Allah's Apostle (may peace be upon him), reported Allah's Apostle (may peace be upon him) as saying: Kindness is not to be found in anything but that it adds to its beauty and it is not withdrawn from anything but it makes it defective.

Book 32, Number 6275:

    This hadith has been reported by Miqdam b. Shuraih b. Hani with the same chain of transmitters but with this addition: "'A'isha mounted upon a wild camel and she began to make that go round and round. Thereupon Allah's Messenger (may peace be upon him) said: You should show kindness, and then he made a mention of this hadith.

Chapter 22 : IT IS FORBIDDEN TO CURSE THE BEASTS

Book 32, Number 6276:

    'Imran b. Husain reported: We were with Allah's Messenger (may peace be upon him) in some of his journeys and there was a woman from the Ansar riding a she-camel that it shied and she invoked curse upon that. Allah's Messenger (may peace be upon him) heard it and said: Unload that and set it free for it is accursed. 'Imran said: I still perceive that (dromedary) walking amongst people and none taking any notice of that.

Book 32, Number 6277:

    'Imran reported: I perceive as if I am looking towards that dromedary, and in the hadith transmitted on the authority of Thaqafi (the words are) : "Unload it and make its back bare for it is accursed."

Book 32, Number 6278:

    Abu Burza al-Aslami reported that a slave-girl was riding a dromedary and there was also the luggage of people upon it. that she suddenly saw Allah's Apostle (may peace be upon him). The way of the mountain was narrow and she said (to that dromedary): Go ahead (but that dromedary did not move). She (that slave-girl), out of anger, said: O Allah, let that (dromedary) be damned. Thereupon Allah's Apostle (may peace be upon him) said: Let the dromedary on which the curse has been invoked not proceed with us.

Book 32, Number 6279:

    This hadith has been narrated on the authority of Sulaiman Taimi with the same chain of transmitters but with a variation of words (and that is) : "By Allah, let that accompany us not which has been damned, or he said like it."

Book 32, Number 6280:

    Abu Huraira reported Allah's Messenger (may peace be upon him) as saying: It does not seem proper for Siddiq that he should be an invoker of curse. This hadith has been narrated on the authority of Abu Kuraib with the same chain of transmitters.

Book 32, Number 6281:

    Zaid b. Aslam reported that 'Abd al-Malik b. Marwan sent some domestic goods for decoration to Umm Darda' on his own behalf, and when it was night 'Abd al-Malik got up and called for the servant. It seemed as if he (the servant) was late (in responding to his call), so he ('Abd al-Malik) invoked curse upon him, and when it was morning Umm Darda' said to him: I heard you cursing your servant during the night when you called him, and she said: I heard Abu Darda' as saying that Allah's Messenger (may peace be upon him) said: The invoker of curse would neither be intercessor nor witness on the Day of Resurrection.

Book 32, Number 6282:

    This hadith has been narrated on the authority of Zaid b. Aslam with the same chain of transmitters.

Book 32, Number 6283:

    Umm Darda' reported on the authority of Abu Darda' as saying: I heard Allah's Messenger (may peace be upon him) as saying: The invoker of curse would neither be witness nor intercessor on the Day of Resurrection.

Book 32, Number 6284:

    Abu Huraira reported it was said to Allah's Messenger (may peace be upon him): Invoke curse upon the polytheists, whereupon he said: I have not been sent as the invoker of curse, but "I have been sent as mercy."

Chapter 23 : HE UPON WHOM ALLAH'S APOSTLE (MAY PEACE BE UPON HIM) INVOKED CURSE WHEREAS HE IN FACT DID NOT DESERVE IT, IT WOULD BE A SOURCE OF REWARD AND MERCY FOR HIM

Book 32, Number 6285:

    A'isha reported that two persons visited Allah's Messenger (may peace be upon him) and both of them talked about a thing, of which I am not aware, but that annoyed him and he invoked curse upon both of them and hurled malediction, and when they went out I said: Allah's Messenger, the good would reach everyone but it would not reach these two. He said : Why so ? I said : Because you have invoked curse and hurled malediction upon both of them. He said: Don't you know that I have made condition with my Lord saying thus: O Allah, I am a human being and that for a Muslim upon whom I invoke curse or hurl malediction make it a source of purity and reward.

Book 32, Number 6286:

    This hadith has been reported on the authority of A'mash with the same chain of transmitters and the hadith transmitted on the authority of 'Isa (the words are) : "He had a private meeting with them and hurled malediction upon them and cursed them and sent them out."

Book 32, Number 6287:

    Abu Huraira reported Allah's Messenger (may peace be upon him) as saying: O Allah, I am a human being and for any person amongst Muslims upon whom I hurl malediction or invoke curse or give him whipping make it a source of purity and mercy.

Book 32, Number 6288:

    Jabir reported Allah's Apostle (may peace be upon him) a hadith like it but with a slight variation of wording.

Book 32, Number 6289:

    This hadith has been transmitted on the authority of A'mash and in the hadith transmitted on the authority of 'Isa the words are: Make it a source of reward, and in the hadith transmitted on the authority of Abu Huraira (the words are) : "Make it a source of mercy."

Book 32, Number 6290:

    Abu Huraira reported Allah's Apostle (may peace be upon him) as saying: O Allah, I make a covenant with Thee against which Thou wouldst never go. I am a human being and thus for a Muslim whom I give any harm or whom I scold or upon whom I invoke curse or whom I beat, make this a source of blessing, purification and nearness to Thee on the Day of Resurrection.

Book 32, Number 6291:

    This hadith has been transmitted on the authority of Abu Zinad with a slight variation of wording.

Book 32, Number 6292:

    A hadith like this has been reported on the authority of Abu Huraira through another chain of transmitters.

Book 32, Number 6293:

    Salim, the freed slave of Nasriyyin, said: I heard Abu Huraira as saying that he heard Allah's Messenger (may peace be upon him) as saying: O Allah, Muhammad is a human being. I lose my temper just as human beings lose temper, and I have held a covenant with Thee which Thou wouldst not break: For a believer whom I give any trouble or invoke curse or beat, make that an expiation (of his sins and a source of) his nearness to Thee on the Day of Resurrection.

Book 32, Number 6294:

    Abu Huraira reported that he heard Allah's Messenger (may peace be upon him) as saying: O Allah, for any believing servant whom I curse make that as a source of nearness to Thee on the Day of Resurrection.

Book 32, Number 6295:

    Abu Huraira reported Allah's Messenger (may peace be upon him) as saying: I have held covenant with Thee which Thou wouldst not break, so for any believer whom I curse or beat, make that an expiation on the Day of Resurrection.

Book 32, Number 6296:

    Jabir b. Abdullah reported Allah's Messenger (may peace be upon him) as saying: I am a human being and I have made this term with my Lord, the Exalted and Glorious: For any servant amongst Muslims whom I curse or scold, make that a source of purity and reward. This hadith has been narrated on the authority of Ibn Juraij with the same chain of transmitters.

Book 32, Number 6297:

    Anas b. Malik reported that there was an orphan girl with Umm Sulaim (who was the mother of Anas). Allah's Messenger (may peace be upon him) saw that orphan girl and said: O, it is you; you have grown young. May you not advance in years! That slave-girl returned to Umm Sulaim weeping. Umm Sulaim said: O daughter, what is the matter with you? She said: Allah's Apostle (may peace be upon him) has invoked curse upon me that I should not grow in age and thus I would never grow in age, or she said, in my (length) of life. Umm Sulaim went out wrapping her head-dress hurriedly until she met Allah's Messenger (may peace be upon him). He said to her: Umm Sulaim, what is the matter with you? She said: Allah's Apostle, you invoked curse upon my orphan girl. He said: Umm Sulaim, what is that? She said: She (the orphan girl) states you have cursed her saying that she might not grow in age or grow in life. Allah's Messenger (may peace be upon him) smiled and then said: Umm Sulaim, don't you know that I have made this term with my Lord. And the term with my Lord is that I said to Him: 1 am a human being and I am pleased just as a human being is pleased and I lose temper just as a human being loses temper, so for any person from amongst my Ummah whom I curse and he in no way deserves it, let that, O Lord, be made a source of purification and purity and nearness to (Allah) on the Day of Resurrection.

Book 32, Number 6298:

    Ibn Abbas reported: I was playing with children that Allah's Messenger (may peace be upon him) happened to pass by (us). I hid myself behind the door. He (the Holy Prophet) came and he patted upon my shoulders and said: Go and call Mu'awiya. I returned and said: He is busy in taking food. He again asked me to go and call Mu'swiya to him. I went (and came back) and said that he was busy in taking food, whereupon he said: May Allah not fill his belly! Ibn Muthanna, said: I asked Umm Umayya what he meant by the word Hatani. He said : It means "he patted my shoulders".

Book 32, Number 6299:

    This hadith has been transmitted on the authority of Ibn Abbas with a slight variation of wording.

Chapter 24 : THE CONDEMNATION OF ONE WHO PLAYS A DOUBLE GAME AND THE PROHIBITION OF THIS BEHAVIOUR

Book 32, Number 6300:

    Abu Huraira reported Allah's Messenger (may peace be upon him) as saying: The worst amongst the people is the double-faced one; he comes to some people with one face and to others with the other face.

Book 32, Number 6301:

    Abu Huraira reported that he heard Allah's Messenger (may peace be upon him) as saying: The worst amongst people is one with the double face. He comes to some people with one face and to others with the other face.

Book 32, Number 6302:

    Abu Huraira reported Allah's Messenger (may peace be upon him) as saying: You will find the worst amongst the people one having double face. He comes to some people with one face and to the others with the other face.

Chapter 25 : FORBIDDANCE OF TELLING A LIE AND THE CASES IN WHICH TELLING OF LIE IS PERMISSIBLE

Book 32, Number 6303:

    Humaid b. 'Abd al-Rahman b. 'Auf reported that his mother Umm Kulthum daughter of 'Uqba b. Abu Mu'ait, and she was one amongst the first emigrants who pledged allegiance to Allah's Apostle (may peace be upon him), as saying that she heard Allah's Messenger (may peace be upon him) as saying: A liar is not one who tries to bring reconciliation amongst people and speaks good (in order to avert dispute), or he conveys good. Ibn Shihab said he did not hear that exemption was granted in anything what the people speak as lie but in three cases: in battle, for bringing reconciliation amongst persons and the narration of the words of the husband to his wife, and the narration of the words of a wife to her husband (in a twisted form in order to bring reconciliation between them).

Book 32, Number 6304:

    This hadith has been narrated on the authority of Ibn Shihab with the same chain of transmitters but with a slight variation of wording.

Book 32, Number 6305:

    This hadith has been transmitted on the authority of Zuhri with a slight variation of wording.

Chapter 26 : SERIOUS PROHIBITION OF TALE-CARRYING

Book 32, Number 6306:

    'Abdullah b. Mas'ud reported that Muhammad (may peace be upon him) said: Should I inform you that slandering, that is in fact a tale-carrying which creates dissension amongst people, (and) he (further) said: The person tells the truth until he is recorded as truthful, and lie tells a lie until lie is recorded as a liar.

Chapter 27 : THE EVIL OF A LIE AND THE GOODNESS OF TRUTH AND ITS MERIT

Book 32, Number 6307:

    'Abdullah reported Allah's Messenger (may peace be upon him) as saying: Truth leads one to Paradise and virtue leads one to Paradise and the person tells the truth until he is recorded as truthful, and lie leads to obscenity and obscenity leads to Hell, and the person tells a lie until he is recorded as a liar.

Book 32, Number 6308:

    'Abdullah b. Mas'ud reported Allah's Messenger (may peace be upon him) as saying: Telling of truth is a virtue and virtue leads to Paradise and the servant who endeavours to tell the truth is recorded as truthful, and lie is obscenity and obscenity leads to Hell-Fire, and the servant who endeavours to tell a lie is recorded as a liar. Ibn Abu Shaiba reported this from Allah's Apostle (may peace be upon him).

Book 32, Number 6309:

    'Abdullah reported Allah's Messenger (may peace be upon him) as saying: It is obligatory for you to tell the truth, for truth leads to virtue and virtue leads to Paradise, and the man who continues to speak the truth and endeavours to tell the truth is eventually recorded as truthful with Allah, and beware of telling of a lie for telling of a lie leads to obscenity and obscenity leads to Hell-Fire, and the person who keeps telling lies and endeavours to tell a lie is recorded as a liar with Allah.

Book 32, Number 6310:

    This hadith has been reported on the authority of A'mash with the same chain of transmitters and no mention is made in the hadith transmitted on the authority of 'Isa (of these words) : "He who endeavours to tell the truth and endeavours to tell a lie," and in the hadith transmitted on the authority of Mushir (the words are): "Until Allah records it".

Chapter 28 : THE MERIT OF SELF-CONTROL AT THE TIME OF ANGER

Book 32, Number 6311:

    Abdullah b. Mas'ud reported Allah's Messenger (may peace be upon him) as saying: Whom do you count as "Raqub" amongst you? They (his Companions) said: One who has no children (the children are born unto him but they do not survive). Thereupon he (the Holy Prophet) said: He is not a Raqub but Raqub is one who does not find his child as the forerunner (in Paradise). He then said: Whom do you count as a wrestler amongst you? We said: He who wrestles with persons. He said : No, it is not he but one who controls himself when in a fit of rage.

Book 32, Number 6312:

    This hadith has been narrated on the authority of A'mash with the same chain of transmitters.

Book 32, Number 6313:

    Abu Huraira reported Allah's Messenger (may peace be upon him) as saying: The strong-man is not one who wrestles well but the strong man is one who controls himself when he is in a fit of rage.

Book 32, Number 6314:

    Abu Huraira reported: I heard Allah's Messenger (may peace be upon him) as saying: One is not strong because of one's wrestling skillfully. They said: Allah's Messenger, then who is strong? He said: He who controls his anger when he is in a fit of rage.

Book 32, Number 6315:

    This hadith has been reported on the authority of Abu Huraira through another chain of transmitters.

Book 32, Number 6316:

    Sulaiman b. Surad reported that two persons abused each other in the presence of Allah's Apostle (may peace be upon him) and the eyes of one of them became red as embers and the veins of his neck were swollen. Thereupon Allah's Messenger (may peace be upon him) said: I know of a wording, if he were to utter that, his fit of rage (would be no more and that wording is) : I seek refuge with Allah from Satan the accursed. The person said: Do you find any madness in me? Ibn al-'Ala' said: Do you see it? And he made no mention of the person.

Book 32, Number 6317:

    Sulaiman b. Surad reported that two persons abused each other in the presence of Allah's Apostle (may peace be upon him) and one of them fell into a rage and his face became red. Allah's Apostle (may peace be upon him) saw him and said: I know of a wording; if he were to utter that, he would get out (of the fit of anger) (and the wording is): I seek refuge with Allah from Satan, the accursed. Thereupon, a person went to him who had heard that from Allah's Apostle (may peace be upon him) and said to him: Do you know what Allah's Messenger (may peace be upon him) said? He (the Holy Prophet) said: I know of a wording; if he were to say that, (the fit) would be no more (and the words are): I seek refuge with Allah from Satan, the accursed. And the person said to him: Do you find me mad?

Book 32, Number 6318:

    This hadith has been reported on the authority of A'mash with the same chain of transmitters.

Chapter 29 : IT IS THE VERY NATURE OF MAN THAT HE LOSES CONTROL

Book 32, Number 6319:

    Anas reported Allah's Messenger (may peace be upon him) as saying: When Allah fashioned Adam in Paradise, He left him as He liked him to leave. Then Iblis roamed round him to see what actually that was and when he found him hollow from within, he recognised that he had been created with a disposition that he would not have control over himself.

Book 32, Number 6320:

    A hadith like this has been narrated on the authority of Humaid with the same chain of transmitters.

Chapter 30 : IT IS FORBIDDEN TO STRIKE AT THE FACE

Book 32, Number 6321:

    Abu Huraira reported Allah's Messenger (may peace be upon him) as saying: When any one of you fights with his brother he should avoid striking at the face.

Book 32, Number 6322:

    This hadith has been transmitted on the authority of Abu Zinad and he said: "When one amongst you strikes (at the face)."

Book 32, Number 6323:

    Abu Huraira reported Allah's Apostle (may peace be upon him) as saying: When any one of you fights with his brother, he should spare his face.

Book 32, Number 6324:

    Abu Huraira reported Allah's Messenger (may peace be upon him) as saying: When any one of you fights with his brother, he should not slap at the face.

Book 32, Number 6325:

    This hadith has been transmitted on the authority of Abu Huraira and in the hadith transmitted on the authority of Ibn Hatim Allah's Apostle (may peace be upon him) is reported to have said : When any one of you fights with his brother, he should avoid his face for Allah created Adam in His own image.

Book 32, Number 6326:

    Abu Huraira reported Allah's Messenger (may peace be upon him) as saying: When any one of you fights with his brother, he should avoid the face.

Chapter 31 : GRIM WARNING TO ONE WHO TORMENTS PEOPLE WITHOUT ANY VALID JUSTIFICATION

Book 32, Number 6327:

    'Urwa reported on the authority of his father that Hisham b. Hakim b. Hizam happened to pass by some people in Syria who had been made to stand in the sun and olive-oil was being poured upon their heads. He said: What is this? It was said: They are being punished for (not paying) the Kharaj (the government revenue). Thereupon he said: Allah would punish those who torment people in this world (without any genuine reason).

Book 32, Number 6328:

    Hisham reported on the authority of his father that Hisham b. Hakim b. Hizam happened to pass by people, the farmers of Syria, who had been made to stand in the sun. He said: What is the matter with them? They said: They have been detained for Jizya. Thereupon Hisham said: I bear testimony to the fact that I heard Allah's Messenger (may peace be upon him) as saying: Allah would torment those who torment people in the world.

Book 32, Number 6329:

    This hadith has been narrated on the authority of Hisham with the same chain of transmitters and he made this addition of Jarir that (Hisham b. Hakim) went to Umair b. Sa'd who was then ruler in Palestine and he narrated to him this hadith and he (submitting before the words of the Prophet) commanded that they should be let off and so they were let off.

Book 32, Number 6330:

    'Urwa b. Zubair reported that Hisham b. Hakim found a person (the ruler of Hims) who had been detaining some Nabateans in connection with the dues of Jizya. He said: What is this? I heard Allah's Messenger (may peace be upon him) as saying: Allah would torment those persons who torment people in the world.

Chapter 32 : HE WHO GOES IN THE MOSQUE OR IN THE BAZAR OR A PLACE OF GATHERING LIKE IT WITH A WEAPON SHOULD SEE THAT THE SPEARHEAD DOES NOT HARM ANYONE

Book 32, Number 6331:

    'Amr heard Jabir as saying: A person happened to come to the mosque with an arrow; thereupon Allah's Messenger (may peace be upon him) said to him: Take hold of its pointed head.

Book 32, Number 6332:

    Jabir b. Abdullah reported that a person happened to come to the mosque with arrows and their iron-ends were exposed, so he was commanded that he should grasp the pointed heads so that these might not do any harm to a Muslim.

Book 32, Number 6333:

    Jabir reported that Allah's Messenger (may peace be upon him) commanded a person who had been distributing arrows freely in the mosque that he should not move about in the mosque but by catching hold of their iron-heads. Ibn Rumh narrated this with a slight variation of wording.

Book 32, Number 6334:

    Abd Musa reported that Allah's Messenger (may peace be upon him) said: When any one of you happens to go to a meeting or the bazar with an arrow in his hand he must grasp its pointed head; then (he again said): He must grasp its pointed head. Abu Musa said: By Allah, we did not court death until some of us had flung arrows upon the faces of one another.

Book 32, Number 6335:

    Abu Musa reported Allah's Apostle (may peace be upon him) assaying: He who amongst you moves in the mosque or in the bazar and there is an arrow with him he should take hold of its iron-head in his palm, so that none amongst the Muslims should receive any injury from it, or he said, should catch its iron-head.

Chapter 33 : THE PROHIBITION OF POINTING A WEAPON TOWARDS A MUSLIM

Book 32, Number 6336:

    Abu Huraira reported: Abu'l-Qasim (the kunya of Allah's Messenger, may peace be upon him), said: He who pointed a weapon towards his brother the angels invoke curse upon him even if he is his real brother so long as he does not abandon it (the pointing of weapon towards one's brother Muslim).

Book 32, Number 6337:

    Abu Huraira reported a hadith like this from Allah's Apostle (may peace be upon him) through another chain of transmitters.

Book 32, Number 6338:

    Abu Huraira reported a hadith from Allah's Messenger (may peace be upon him); (one of them was this) that Allah's Messenger (may peace be upon him) said: None amongst you should point a weapon towards his brother, for he does not know that Satan might cause the weapon (to slip) from his hand and (he may injure anyone) and thus he may fall into Hell-Fire.

Chapter 34 : THE MERIT OF REMOVING OF ANYTHING TROUBLESOME FROM THE PATH

Book 32, Number 6339:

    Abu Huraira reported Allah's Messenger (may peace be upon him) as saying: While a person was going along the path he found a thorny branch upon it. He pushed it to a side and Allah approved (this action) of his and (as a mark of appreciation) granted him pardon.

Book 32, Number 6340:

    Abu Huraira reported Allah's Messenger (may peace be upon him) as saying: A person while walking along the path saw the branches of a tree lying there. He said: By Allah, I shall remove these from this so that these may not do harm to the Muslims, and he was admitted to Paradise.

Book 32, Number 6341:

    Abu Huraira reported Allah's Messenger (may peace be upon him) as saying that he saw a person enjoying himself in Paradise because of the tree that he cut from the path which was a source of inconvenience to the people.

Book 32, Number 6342:

    Abu Huraira reported Allah's Messenger (may peace be upon him) as saying that there was a tree which caused inconvenience to the Muslims; a person came there and cut that (tree) (and thus entered )Paradise).

Book 32, Number 6343:

    Abu Barza reported: I said: Allah's Messenger, teach me something so that I may derive benefit from it. He said: Remove the troublesome thing from the paths of the Muslims.

Book 32, Number 6344:

    Abu Barza reported that he said to Allah's Messenger (may peace be upon him): Allah's Messenger, I do not know whether I would survive after you, so confer upon me something by which Allah should benefit me. Thereupon Allah's Messenger (may peace be upon him) said: Do this and that and remove the troublesome things from the paths.

Chapter 35 : FORBIDDANCE OF TORMENTING THE CAT OR THE ANIMALS LIKE THAT WHICH DO NOT HARM

Book 32, Number 6345:

    Abdullah reported that Allah's Messenger (may peace be upon him) said: A woman was tormented because of a cat which she had confined until it died and she had to get into Hell. She did not allow it either to eat or drink as it was confined, nor did she free it so that it might eat the insects of the earth.

Book 32, Number 6346:

    This hadith has been reported on the authority of Ibn 'Umar through another chain of transmitters. And Ibn 'Umar reported Allah's Messenger (may peace be upon him) as saying : A woman was tormented because of a cat which she had tied and thus allowed it neither to eat or drink nor set it free so that it might eat the insects of the earth.

Book 32, Number 6347:

    This hadith has been narrated on the authority of Abu Huraira through another chain of transmitters.

Book 32, Number 6348:

    Abu Huraira reported from Allah's Messenger (may peace be upon him) A hadith out of which one was this that Allah's Messenger (may peace be upon him) said: A woman got into Hell-Fire because of a cat whom she had tied, and thus it could not eat, and she did not let it free so that it could devour the insects of the earth, until it died.

Chapter 36 : THE PROHIBITION OF PRIDE AND VANITY

Book 32, Number 6349:

    Abu Sa'id Khudri and Abu Huraira reported Allah's Messenger (may peace be upon him) as saying: Allah, the Exalted and Glorious, said: Glory is His lower garment and Majesty is His cloak and (Allah says,) He who contends with Me in regard to them I shall torment him.

Chapter 37 : IT IS FORBIDDEN TO BECOME FRUSTRATED IN REGARD TO THE MERCY OF ALLAH

Book 32, Number 6350:

    Jundub reported that Allah's Messenger (may peace be upon him) stated that a person said: Allah would not forgive such and such (person). Thereupon Allah the Exalted and Glorious, said: Who is he who adjures about Me that I would not grant pardon to so and so; I have granted pardon to so and so and blotted out his deeds (who took an oath that I would not grant pardon to him).

Chapter 38 : THE MERITS OF THE WEAK AND DOWNTRODDEN PEOPLE

Book 32, Number 6351:

    Abu Huraira reported Allah's Messenger (may peace he upon him) as saying: Many a person with disheveled hair and covered with dust is turned away from the doors (whereas he is held in such a high esteem by Allah) that if he were to adjure in the name of Allah (about anything) Allah would fulfil that.

Chapter 39 : IT IS FORBIDDEN TO USE THE EXPRESSION: "THE PEOPLE ARE UNDONE"

Book 32, Number 6352:

    Abu Huraira reported Allah's Messenger (may peace be upon him) as saying: When a person says that people are ruined he is himself ruined. Abu Ishaq said: I do not know whether he said "ahlakahum or ahlakuhum.

Book 32, Number 6353:

    This hadith has been narrated on the authority of Suhail with the same chain of transmitters.

Chapter 40 : BENEVOLENT TREATMENT TOWARDS THE NEIGHBOUR

Book 32, Number 6354:

    'A'isha reported Allah's Messenger (may peace be upon him) as saying: Gabriel impressed upon me (kind treatment) towards the neighbour (so much) that I thought as if he would confer upon him the (right) of inheritance.

Book 32, Number 6355:

    This hadith has been narrated on the authority of 'A'isha through another chain of transmitters.

Book 32, Number 6356:

    Ibn Umar reported Allah's Messenger (may peace be upon him) as saying: Gabriel impressed upon me (the kind treatment) towards the neighbour (so much) that I thought as if he would soon confer upon him the (right) of inheritance.

Book 32, Number 6357:

    Abu Dharr reported Allah's Messenger (may peace be upon him) as saying: Abu Dharr, when you prepare the broth, add water to that and give that (as a present) to your neighbour.

Book 32, Number 6358:

    Abu Dharr reported Allah's Messenger (may peace be upon him) commanded me thus: Whenever you prepare a broth, add water to it, and have in your mind the members of the household of your neighbours and then give them out of this with courtesy.

Chapter 41 : EXCELLENCE OF MEETING ONE WITH A CREERFUL COUNTENANCE

Book 32, Number 6359:

    Abu Dharr reported: Allah's Apostle (may peace be upon him) said to me: Don't consider anything insignificant out of good things even if it is that you meet your brother with a cheerful countenance.

Chapter 42 : THE MERIT OF RECOMMENDATION WHICH INVOLVES NOTHING UNLAWFUL

Book 32, Number 6360:

    Abu Musa reported that when any needy (person) came to Allah's Messenger (may peace be upon him) with a need he commanded him to his Companions, saying: Make a recommendation for him, and you would get the reward. Allah, however, gives the verdict through the tongue of His Apostle what He likes most.

Chapter 43 : THE MERIT OF GOOD COMPANY AND AVOIDANCE FROM EVIL COMPANY

Book 32, Number 6361:

    Abu Musa reported Allah's Messenger (may peace be upon him) as saying: The similitude of good company and that of bad company is that of the owner of musk and of the one (iron-smith) blowing bellows, and the owner of musk would either offer you free of charge or you would buy it from him or you would. smell its pleasant odour, and so far as one who blows the. bellows is concerned, he would either burn your clothes or you shall have to smell its repugnant smell.

Chapter 44 : THE MERIT OF ACCORDING BENEVOLENT TREATMENT TO DAUGHTERS

Book 32, Number 6362:

    'A'isha, the wife of Allah's Apostle (may peace be upon him), said: A woman came to me along with her two daughters. She asked me for (charity) but she found nothing with me except one date, so I gave her that. She accepted it and then divided it between her two daughters and herself ate nothing out of that. She then got up and went out, and so did her two daughters. (In the meanwhile) Allah's Apostle (may peace be upon him) visited me and I narrated to him her story. Thereupon Allah's Apostle (may peace be upon him) said: He who is involved (in the responsibility) of (bringing up) daughters, and he accords benevolent treatment towards them, there would be protection for him against Hell-Fire.

Book 32, Number 6363:

    'A'isha reported: A poor woman came to me along with her daughters. I gave her three dates. She gave a date to each of them and then she took up one date and brought that to her mouth in order to eat that, but her daughters expressed desire to eat it. She then divided the date that she intended to eat between them. This (kind) treatment of her impressed me and I mentioned that which she did to Allah's Messenger (may peace be upon him). Thereupon he said: Verily Allah has assured Paradise for her, because of (this act) of her, or He has rescued her from Hell-Fire.

Book 32, Number 6364:

    Malik reported Allah's Messenger (may peace be upon him) as saying: He, who brought up two girls properly till they grew up, he and I would come (together) (very closely) on the Day of Resurrection, and he interlaced his fingers (for explaining the point of nearness between him and that person).

Chapter 45 : THE MERIT OF ONE WHO RESIGNS HIMSELF TO THE WILL OF GOD CALMLY AT THE TIME OF THE DEATH OF ONE'S SON

Book 32, Number 6365:

    Abu Huraira reported Allah's Apostle (may peace be upon him) as saying: Anyone amongst the Muslims, three of whose children die, and he resigns himself calmly to the will of God, Fire will not touch him but for the fulfilment of the oath.

Book 32, Number 6366:

    This hadith has been reported by Zuhri on the authority of Malik, and in the hadith transmitted on the authority of Sufyan (the words are) : "He would enter into Fire, except for the fulfilment of the oath."

Book 32, Number 6367:

    Abu Huraira reported that Allah's Messenger (may peace be upon him) said to a woman of the Ansar: In case anyone amongst you sees the sad demise of three children of (hers) and she resigns herself to the will of God hoping to get reward, she would be admitted to Paradise. A woman from amongst them said: Allah's Messenger, even if they (the children who die) are two. Thereupon, he (the Holy Prophet,) said: Even if they are two.

Book 32, Number 6368:

    Abu Sa'id Khudri reported that a woman came to Allah's Messenger (may peace be upon him) and said: Allah's Messenger, men receive your instructions; kindly allocate at your convenience a day for us also, on which we would come to you and you would teach us what Allah has taught you. He said: You assemble on such and such a day. They assembled and Allah's Messenger (may peace be upon him) came to them and taught them what Allah had taught him and he then said: No woman amongst you who sends her three children as her forerunners (in the Hereafter) but they would serve him as a protection against Hell-Fire. A woman said: What about two and two and two? Thereupon Allah's Messenger (may peace be upon him) said: Even if they are two and two and two.

Book 32, Number 6369:

    Abu Huraira reported that he (the Holy Prophet) said: Three (children) who die in childhood.

Book 32, Number 6370:

    Abu Hassan reported : I said to Abu Huraira that my two children had died. Would you narrate to me anything from Allah's Messenger (may peace be upon him) a hadith which would soothe our hearts in our bereavements ? He said: Yes. Small children are the fowls of Paradise. If one of them meets his father (or he said his parents) he would take hold of his cloth, or he said with his hand as I take hold of the hem of your cloth (with my hand). And he (the child) would not take off (his hand) from it until Allah causes his father to enter Paradise. This hadith has been narrated on the authority of Tamim with the same chain of transmitters. And he is reported to have said: Did you hear from Allah's Messenger (may peace be upon him) anything which may soothe our heart in our bereavements? He said: Yes.

Book 32, Number 6371:

    Abu Huraira reported that a woman came to Allah's Apostle (may peace be upon him) with her child and said: Allah's Apostle, invoke Allah's blessing upon him for I have already buried three. He said: You have buried three! She said: Yes. Thereupon he (the Holy Prophet) said : You have, indeed, safeguarded yourself against the torment of Hell with a strong safeguard. 'Umar has made a mention of his father, whereas others have not made a mention of his father.

Book 32, Number 6372:

    Abu Huraira reported that a woman came to Allah's Apostle (may peace be upon him) with her child and said: Allah's Messenger, he is ailing, and I am afraid (that he may die), as I have already buried three. Thereupon he said: It (their sad demise) would be a protection against Hell-Fire for you. Zuhair has not mentioned the kunya of Abu Ghiyath; he has mentioned his name.

Chapter 46 : WHEN ALLAH LOVES A SERVANT, HIS FELLOW-SERVANTS ALSO BEGIN TO LOVE HIM

Book 32, Number 6373:

    Abu Huraira reported that Allah's Messenger (may peace be upon him) said: When Allah loves a servant, He calls Gabriel and says: Verily, I so and so; you should also love him, and then Gabriel begins to love him. Then he makes an announcement in the heaven saying: Allah loves so and so and you also love him, and then the inhabitants of the Heaven (the Angels) also begin to love him and then there is conferred honour upon him in the earth; and when Allah is angry with any servant He calls Gabriel and says: I am angry with such and such and you also become angry with him, and then Gabriel also becomes angry and then makes an announcement amongst the inhabitants of heaven: Verily Allah is angry with so-and so, so you also become angry with him, and thus they also become angry with him. Then he becomes the object of wrath on the earth also.

Book 32, Number 6374:

    This hadith has been reported on the authority of Suhail with the same chain of transmitters except with this variation that in the hadith transmitted on the authority of 'Ali' b. Musayyib, there is no mention of (the word) "Anger".

Book 32, Number 6375:

    Suhail b. Abi Salih, reported: We were in Arafa that there happened to pass Umar b. Abd al-'Aziz and he was the Amir of Hajj. People stood up in order to catch a glimpse of him. I said to my father: Father, I think that Allah loves Umar b. Abd al- 'Aziz. He said: How is it? I said: It is because of the love in people's heart for him. Thereupon he said: By One Who created your father, I heard Abu Huraira narrating from Allah's Messenger (may peace be upon him) a hadith like one transmitted on the authority of Suhail.

Chapter 47 : SOULS ARE TROOPS COLLECTED TOGETHER

Book 32, Number 6376:

    Abu Huraira reported Allah's Messenger (may peace be upon him) Saying: Souls are troops collected together and those who familiarised with each other (in the heaven from where these come) would have affinity, with one another (in the world) and those amongst them who opposed each other (in the Heaven) would also be divergent (in the world).

Book 32, Number 6377:

    Abu Huraira narrated directly from Allah's Messenger (may peace be upon him) that he said: People are like mines of gold and silver; those who were excellent in Jahiliya (during the days of ignorance) are excellent In Islam, when they have, an understanding, and the souls are troops collected together and those who had a mutual familiarity amongst themselves in the store of prenatal existence would have affinity amongst them, (in this world also) and those who opposed one of them, would be at variance with one another.

Chapter 48 : A PERSON WOULD BE ALONG WITH HIM WHOM HE LOVES

Book 32, Number 6378:

    Anas b. Malik reported that a desert Arab said to Allah's Messenger (may peace be upon him) : When would be the Last Hour? Allah's Messenger (may peace be upon him) said: What preparation have you made for that? Thereupon he said: The love of Allah and of His Messenger (that is my preparation for the Last Hour) (for the Day of Resurrection). Thereupon he (the Holy Prophet) said: You would be along with one whom you love.

Book 32, Number 6379:

    Anas reported that a person said to Allah's Messenger (may peace be upon him): When would be the Last Hour? He (the Holy Prophet) said: What preparation have you made for that? And he gave no details, but said: I love Allah and His Messenger. Thereupon he (the Holy Prophet) said: You would be along with one whom you love. Anas b. Malik reported through another chain of transmitters that a desert Arab came to Allah's Messenger (may peace be upon, him), the rest of the hadith is the same but with this variation that he said: I have not made much preparations which merit appreciation for myself.

Book 32, Number 6380:

    Anas b. Malik reported that a person came to Allah's Messenger (may peace be upon him) and said to Allah's Messenger: When would be the Last Hour? Thereupon he (the Holy Prophet) said: What preparation have you made for the Last Hour? He said: The love of Allah and of His Messenger (is my only preparation). Thereupon he (the Holy Prophet) said: You would be along with one whom you love. Anas said: Nothing pleased us more after accepting Islam than the words of Allah's Apostle: You would be along with one whom you love. And Anas said. I love Allah and His Messenger and Abu Bakr and Umar, and I hope that I would be along with them although I have not acted like them.

Book 32, Number 6381:

    Anas b. Malik reported Allah's Apostle (may peace be upon him) this hadith through another chain of transmitters but he did not make mention of the words of Anas: I love, and what follows subsequently.

Book 32, Number 6382:

    Anas b. Malik reported: Allah's Messenger (may peace be upon him) and I were coming out of the mosque that we met a person on the threshold of the mosque and he said to Allah's Messenger (may peace be upon him): When would be the Last Hour? Allah's Messenger (may peace be upon him) said: What preparation have you made for that ? The man became silent and then said: Allah's Messenger, I have made no significant preparation with prayer and fasting and charity but I, however, love Allah and His Messenger. Thereupon (the Holy Prophet) said: You would be along with one whom you love.

Book 32, Number 6383:

    This hadith has been narrated on the authority of Anas through another chain of transmitters.

Book 32, Number 6384:

    This hadith has been reported on the authority of Anas with a different chain of transmitters.

Book 32, Number 6385:

    'Abdullah reported that a person came to Allah's Messenger (may peace be upon him) and said to Allah's Messenger (may peace be upon him) : What is your opinion about the person who loves the people but his (acts or deeds are not identical to theirs) ? Thereupon Allah's Messenger (may peace be upon him) said: A person would be along with one whom he loves.

Book 32, Number 6386:

    A hadith like this has been transmitted on the authority of 'Abdullah.

Book 32, Number 6387:

    Abu Musa, reported that a person came to Allah's Messenger (may peace be upon him) ; the rest of the hadith is the same.

Chapter 49 : WHEN A PIOUS PERSON IS PRAISED THAT IS GLAD TIDINGS FOR HIM

Book 32, Number 6388:

    Abu Dharr reported: It was said to Allah's Messenger (may peace be upon him): What is your opinion about the person who has done good deeds and the people praise him ? He said: It is glad tidings for a believer (which he has received in this mortal world).

Book 32, Number 6389:

    This hadith has been narrated through another chain of transmitters also and the one transmitted on the authority of Shu'ba (the words are) : "People love him." In the hadith transmitted on the authority of 'Abd-us-Samad (the words are): "People praise him as stated by Hammad."


Book 33: The Book of Destiny (KITAB-UL-QADR)

KITAB-UL-QADR
BOOK OF DESTINY

Back
INTRODUCTION

    Whether the fate of man is predestined or he himself is the architect of it, is a question which has been very often discussed by scholars of all times. This problem is significantly important as no sensible man. not even the man in the street, can afford to ignore it. Faith in Taqdir (Destiny) has a very deep impact upon our lives and we always find our lives oscillating between determinism and freewill. As a man looks around himself and looks to his own self and within himself, he finds that there are hundred and one things in shaping and reshaping of which he has no hand, e.g. in determining the climate of the land in which he is born, in canalising the courses of rivers which flow therein and in determining the nature of the soil thereof. He finds himself absolutely powerless. As he looks to himself he finds that there are so many things In him which are beyond his control, viz. the measure of intellect he has been endowed with, the shape and form of his physical structure with which he has been sent to this world, and the inclinations and so many other qualities of head and heart which are embedded in his very nature. In all these aspects of life he finds himself helpless before the Great and Mighty Power that created him.

    On the other hand, there are so many things in which man finds himself quite empowered. As he looks to the marvellous achievements of man despite all odds, he finds it difficult to believe that he is a mere puppet in the mighty hand of Nature. This problem of predestination and freewill, in which man finds his life hanging, has been adequately solved by the Qur'an and the Sunnah. We give below a brief summary of their elucidations.

    The first principle which Islam lays down in regard to Taqdir is that man is neither completely the master of his fate nor is he bound to the blind law of predestination. So far as the sovereignty of Allah's Will is concerned, it is all-pervading and nothing falls outside its orbit. Not even a leaf, therefore, stirs without His Will.

      It is His Will that prevails everywhere. To God belongs the sovereignty of Heavens and the Earth. He created what He pleaseth, giving to whom He pleaseth females and to whom He pleaseth males or conjoining them males and females, and He maketh whom He pleaseth barren, verify He hath knowledge and power (xlii. 48).

    Men are, therefore, completely subordinate to the overruling power of God, they cannot do anything unless God wills so.

      "Whom God guideth he is the rightly-guided. Whom he sendeth stray, thou wilt not find a patron to set him right (xviii. 16).

    His mighty grasp is, therefore, over everything. The Almighty Lord,Who has created everything and has determined its nature and course, has in His infinite wisdom and mercy conferred upon man a limited autonomy according to which a man is free to do or not to do a certain thing. It is because of this autonomy enjoyed by man that he is hold accountable for his deeds. The concept of human responsibility and that of his answerability for his deeds and misdeeds becomes meaningless if he is supposed to be deprived of this autonomy. There are, a large number of verses in the Holy Qur'an which make a pointed reference to the autonomy conferred upon man.

      Man shall have nothing but that what he strives for (liii. 39).
      Allah does not change the condition of a people until they change it themselves (viii. 53; xiii. 11).
      Those who strive in His path, are guided in the right path, while those who persist in denial and sinful livifig have their hearts sealed against faith (ii. 7, 26; iv. 155; v;.i. 102).
      Allah does not compel belief and leaves the people free to believe or disbelieve (vi. 35, 150; xvi-. 9).
      Whoever has done an atorn's weight of good shall meet with its reward and whoever has done an atom's weight of evil shall meet with its consequences (xcix. 7-8).

    It should be borne in mind in this connection that the word Taqdir used in the Qur'an does not always signify something predestined. It at times implies a measure or the latent potentialities or possibilities with which Allali created man and all things of Nature. For example: He created everything for its Destiny (or its Measure) (xxv.2). In Sura 54, verse 9 (the words are): We created everything according to a Measure or Destiny. In both these verses Destiny impiies the inward reach of things, their latent potentialities or possibilities.

    The idea of Destiny as we find in the hadith that God wrote down the decrees regarding the created world fifty thousand years before He created the Heavens and the Earth does not in any way mean that God created a block Universe, finished off and complete, bound to the iron formulae of Nature. Here the idea behind Taqdir is that the creation of this universe is not accidental but something preplanned and pre-conceived and it was shaped according to the Grand Design of the Greatest Designer.There is no element of chance in the creation of this Universe. Everything is well-set and well-planned.

    The idea that Allah has a foreknowledge of everything that He created and the events unfold themselves exactly according to it, does not imply that human beings have been completely deprived of the freedom of action. The foreknowledge of God is an acknowledged fact, but it should not be interpreter in the sense of predestination, for if we do so we shall have to conceive of eternity as a storehouse of ready-made events, from which they drop one by one like particles of sand in a glass hour. If we take the foreknowledge to be a reflecting mirror we shall have to deprive the Creator and the Controller of the Universe of His Creative activity.

    Dr Muhammad Iqbal has shed a good deal of light over this problem. He says: "Divine knowledge must be conceived as a living creative activity to which the objects that appear to exist in their own right are organically related. By conceiving God's knowledge as a kind of reflecting mirror, we no doubt save His fore-knowledge of future events, but it is obvious that we do so at the expense of His freedom. The future certainly pre-exists in the organic whole of God's creative life, but it pre-exists as an open possibility, not as a fixed order of events with definite outlines."

    We should bear in mind that the idea of put, present and future is something relative and is conceived by the inite wind of man. It is. however, a great now in the eye of the All-Seeing God. The whole expanse of eternity lies before Him in the shape of now. Knowledge is, therefore, an act of creative activity and not the mere reflection of it. When He decrees a thing it happens and He knows it before it happens. God in Islam is not, therefore, a prisoner of necenity. He is a free Creator.

    The concept of predestination in Islam, therefore, does not in any way mean helpless abandonment of oneself to otherwise unwelcome fate. It means rather co-operation with God, studying His will andbringingoneself into unison with His Planning Will. Destiny as conceived by Islam is, thus, by no stretch of imagination, fatal to the freedom of conduct and unfoldment of one's inherent possibilities; it is a source of inspiration and encouragement and opens up vast fields of human activity. It is not a message of despondency and despair, but a source of solace, comfort and inspiration and a powerful means of evoking a sense of piety and humility and self-surrender to the Will of God. It does not inculcate in mind frustration and pessimism, making his life dark and dreary, devoid of hope and promise for the future, but it teaches him to put his heart and soul in the sublime work as assigned to him by his Master.

Chapter 1 : THE GROWTH OF A CHILD IN THE WOMB OF A MOTHER AND HIS DESTINY IN REGARD TO HIS LIVELIHOOD, HIS DEEDS, BOTH GOOD AND EVIL

Book 33, Number 6390:

    Abdullah (b. Mas'ud) reported that Allah's Messenger (may peace be upon him) who is the most truthful (of the human beings) and his being truthful (is a fact) said: Verily your creation is on this wise. The constituents of one of you are collected for forty days in his mother's womb in the form of blood, after which it becomes a clot of blood in another period of forty days. Then it becomes a lump of flesh and forty days later Allah sends His angel to it with instructions concerning four things, so the angel writes down his livelihood, his death, his deeds, his fortune and misfortune. By Him, besides Whom there is no god, that one amongst you acts like the people deserving Paradise until between him and Paradise there remains but the distance of a cubit, when suddenly the writing of destiny overcomes him and he begins to act like the denizens of Hell and thus enters Hell, and another one acts in the way of the denizens of Hell, until there remains between him and Hell a distance of a cubit that the writing of destiny overcomes him and then he begins to act like the people of Paradise and enters Paradise.

Book 33, Number 6391:

    This hadith has been reported on the authority of A'mash with the same chain of transmitters and in the hadith transmitted on the authority of Waki' (the words are) : "The creation of any one of you is like this that (semen) is collected in the womb of the mother for forty nights," and in the hadith transmitted on the authority of Shu'ba (the words are) : "Forty nights and forty days." And in the hadith transmitted on the authority of Jarir and 'Isa (the words are) : "Forty days."

Book 33, Number 6392:

    Hudhaifa b. Usaid reported directly from Allah's Messenger (may peace be upon him) that lie said: When the drop of (semen) remains in the womb for forty or fifty (days) or forty nights, the angel comes and says : My Lord, will he be good or evil ? And both these things would be written. Then the angel says: My Lord, would he be male or female ? And both these things are written. And his deeds and actions, his death, his livelihood; these are also recorded. Then his document of destiny is rolled and there is no,addition to and subtraction from it.

Book 33, Number 6393:

    'Abdullah b. Mas'ud reported: Evil one is he who is evil in the womb of his mother and the good one is he who takes lesson from the (fate of) others. The narrator came to a person from amongst the Companion of Allah's Me ssenger (may peace be upon him) who was called Hudhaifa b. Usaid Ghifari and said: How can a person be an evil one without (cornmittilng an evil) deed? Thereupon the person said to him: You are surprised at this, whereas I have heard Allah's Messenger (may peace be upon him) as saving: When forty nights pass after the semen gets into the womb, Allah sends the angel and gives him the shape. Then he creates his sense of hearing, sense of sight, his skin, his flesh, his bones, and then says: My Lord, would he be male or female ? And your Lord decides as He desires and the angel then puts down that also and then says: My Lord, what about his age? And your Lord decides as He likes it and the angel puts it down. Then he says: My Lord, what about his livelihood? And then the Lord decides as He likes and the angel writes it down, and then the angel gets out with his scroll of destiny in his hand and nothing is added to it and nothing is subtracted from it.

Book 33, Number 6394:

    This hadith has been narrated on the authority of 'Abdullah b. Mas'ud through another chain of transmitters.

Book 33, Number 6395:

    Abu Tufail reported: I visited Abu Sariha Hudhaifa b. Usaid al-Ghifari who said : I listened with these two ears of mine Allahs Messenger (may peace be upon him) as saying: The semen stays in the womb for forty nights, then the angel, gives it a shape. Zubair said: I think that he said: One who fashions that and decides whether he would be male or female. Then he (the angel) says: Would his limbs be full or imperfect ? And then the Lord makes thein full and perfect or otherwise as He desires. Then he says: My Lord, what about his livelihood, and his death and what about his disposition? And then the Lord decides about his misfortune and fortune.

Book 33, Number 6396:

    Hadhaifa b. Usaid Ghifari, a Companion of Allah's Messenger (may peace be upon him), reported it directly from Allah's Messenger (may peace upon him).as he said: There is an angel who looks after the womb when Allah decides to create any- thing after more than forty nights are over; the rest of the hadith is the same.

Book 33, Number 6397:

    Anas b. Malik reported directly from Allah's Messenger (may peace be upon him) that he said: Allah, the Exlated and Glorious, has appointed an angel as the caretaker of the womb, and he would say: My Lord, it is now a drop of semen; my Lord, It is now a clot of blood; my Lord, it has now become a lump of flesh, and when Allah decides to give it a final shape, the angel says: My Lord, would it be male or female or would he be an evil or a good person? What about his livelihood and his age? And it is all written as he is in the womb of his mother.

Book 33, Number 6398:

    All reported: We were in a funeral in the graveyard of Gharqad that Allah's Messenger (may peace be upon him) came to us and we sat around him. He had a stick with him. He lowered his head and began to scratch the earth with his stick, and then raid: There is not one amongst you whom a scat in Paradise or Hell has not been allotted and about whom it has not been written down whether he would be an evil person or a blessed person. A person said: Allah's Messenger, should we not then depend npon our destiny and abandon our deeds? Thereupon he said: Acts of everyone will be facilitated in, that which has been created for him so that whoever belongs to the com. pany of the blessed will have good works made easier for himand whoever belongs to the unfortunate ones will have evil acts made easier for him. He then recited this verse (from the Qur'an): "Then, who gives to the needy and guardsagainst evil and accepts the excellent (the truth of Islam and the path of righteousness it prescribes), We shall make easy for him the easy end and who is miserly and considers himself above need, We shall make easy for him the dificult end". (XCii. 5-10).

Book 33, Number 6399:

    This hadith has been narrated on the authority of Mansur with the same chain of transmitters but with a slight variation of wording.

Book 33, Number 6400:

    'Ali reported that one day Allah's Messenger (may peace be upon him) was sitting with a wood in his hand and he was scratching the ground. He raised his head and said: There is not one amongst you who has not been allotted his seat in Paradise or Hell. They said: Allah's Messenger. then, why should we perform good deeds, why not depend upon our destiny? Thereupon he said. No, do perform good deeds, for everyone is facilitated in that for which he has been created ; then he recited this verse: "Then, who gives to the needy and guards against evil and accepts the excellent (the truth of Islam and the path of righteousness it prescribes), We shall make easy for him the easy end . . . " (xcii. 5-10).

Book 33, Number 6401:

    This hadith has been narrated on the authority of 'Ali through another chain of transmitters.

Book 33, Number 6402:

    Jabir reported that Suriqa b. Malik b. Ju'shuin came and said: Allah's Messenger, explain our religion to us (in a way) as if we have been created just now. Whosoever deeds we do today, is it because of the fact that-the pens have dried (after recording them) and the destitiles have began to operate or these have effects in future? Thereupon he said: The pens have dried tmd destinies have begun to operate. (Suraqa b. Malik) said: If it Is so, then what is the use of doing good deeds? Zuhair said: Then Abu Zubair said something but I could not understand that and I said. What did he say? Thereupon he said: Act, for everyone is facilitated what he intends to do.

Book 33, Number 6403:

    This hadith has been transmitted on the authority of Jabir b. Abdullah with the same wording (and includes these words) : " Allah's Messenger (may peace be upon him) said: Every doer of deed is facilitated in his action."

Book 33, Number 6404:

    'Imran b. Husain repotted that it was said to Allah's Messenger (may peace be upon him): Has there been drawn a distinction between the people of Paradise and the denizens of hell? He said: Yes. It was again said: (If it is so), then What is the use of doing good deeds ? Thereupon he said: Everyone is facilitated in what has been created for him.

Book 33, Number 6405:

    This hadith has been narrated through other chains of transmiters with slight variations of wording.

Book 33, Number 6406:

    Abu al-Aswad reported that 'Imran b Husain asked him: What is your view, what the people do today in the world, and strive for, is it something decreed for them or preordained for them or will their fate in the Hereafter be deterrained by the fact that their Prophets brought them teaching which they did not act upon ? I said: Of course, it is something which is predetermined for them and preordained for them. He (further) said: Then, would it not be an injustice (to punish them) ? I felt greatly disturbed because of that, and said: Everything is created by Allah and lies in His Power. He would not be questioned as to what He does, but they would be questioned; thereupon he said to me: May Allah have mercy upon you, I did not mean to ask you but for testing your intelligence. Two men of the tribe of Muzaina came to Allah's Messenger (may peace be upon him) and said: Allah's Messenger, what is your opinion that the people do in the world and strive for, is something decreed for them; something preordained for them and will their fate in the Hereafter be determined by the fact that their Prophets brought them teachings which they did not act upon. and thus they became deserving of punishment ? Thereupon, he said: Of course, it happens as it is decreed by Destiny and preordained for them, and this view is confirmed by this verse of the Book of Allah, the Exalted and Glorious: "Consider the soul and Him Who made it perfect, then breathed into it its sin and its piety" (xci. 8).

Book 33, Number 6407:

    Abu Huraira reported Allah's Messenger (way peace be upon him) as saying: Verily, a person performs deeds for a long time like the deeds of the people of Paradise. Then his deeds are terminated like the deeds of the people of Hell and, verily, a person performs deeds like the denizens of Fire for a long time, and then this deed of his is ultimately followed by the deeds of the people of Paradise.

Book 33, Number 6408:

    Sahl b. Sa'd reported it from Allah's Messenger (may peace be upon him) that a person performs deeds like the deeds of the people of Paradise apparently before people and he would be amongst the dwellers of Hell and a person acts apparently like the people of Hell, but (in fact) he would be among the dwellers of Paradise.

Chapter 2 : THE EXCHANGE OF ARGUMENTS BETWEEN ADAM AND MOSES (ALLAH BE PLEASED WITH BOTH OF THEM)

Book 33, Number 6409:

    Abu Huraira reported Allah's Messenger (way peace be upon him) as saying: There was argument between Adam and Moses. Moses said to Adam: You are our father. You did us harm and caused us to get out of Paradise. Adam said to him: You are Moses. Allah selected you (for direct conversation with you) and wrote with His own Hand the Book (Torah) for you. Despite this you blame me for an act which Allah had ordained for me forty years before He created me. Allah's Apostle (may peace be upon him) said:.This is how Adam came the better of Moses and Adam came the better of Moses.

Book 33, Number 6410:

    Abu Huraira reported Allah's Messenger (may peace be upon him) as saying: There was argument between Adam and Moses, and Adam came the better of Moses. Moses said to him : You are the same Adam who misled people, and caused them to get out of Paradise. Adam said: You are the same (Moses) whom Allah endowed the knowledge of everything and selected him amongst the people as His Messenger. He said: Yes. Adam then again said: Even then you blame me for an affair which had been ordained for me before I was created.

Book 33, Number 6411:

    Abu Huraira reported Allah's Messenger (may peace be upon him) as saying: There was an argument between Adam and Moses (peace be upon both of them) in the presence of their Lord. Adam came the better of Moses. Moses said : Are you that Adam whom Allah created with His Hand and breathed into himHis sprit, and commanded angels to fall in prostration before him and He made you live in Paradise with comfort and ease. Then you caused the people to get down to the earth because of your lapse. Adam said: Are you that Moses whom Allah selected for His Messengership and for His conversation with him and conferred upon you the tablets, in which everything was clearly explained and granted you the audience in order to have confidential talk with you. What is your opinion, how long Torah would haye been written before I was created ? Moses said: Forty years before. Adam said: Did you not see these words: Adam committed an error and he was enticed to (do so). He (Moses) said: Yes. Whereupon, he (Adam) said: Do you then blame me for an act which Allah had ordained for me forty years before He created me ? Allah's Messenger (may peace be upon him) said : This is how Adam came the better of Moses.

Book 33, Number 6412:

    Abu Huraira reported Allah's Messenger (may peace be upon him) as saying: There was an argument between Adam and Moses. Moses said: Are you that Adam whose lapse caused you to get out of Paradise ? Adam said to him: Are you that Moses whom Allah selected for His Messengership, for His conversation and you blame me for an affair which had been ordained for me before I was created ? This is how Adam came the better of Moses.

Book 33, Number 6413:

    Abu Huraira narrated a hadith like this through another chain of transmitters.

Book 33, Number 6414:

    This hadith has been narrated on the authority of Abu Huraira through another chain of transmitters.

Book 33, Number 6415:

    Abu Huraira reported a hadith like this through another chain of transmitters.

Book 33, Number 6416:

    Abdullah b. 'Amr b. al-'As reported: I heard Allah's Messenger (may peace be upon him) as saying : Allah ordained the measures (of quality) of the creation fifty thousand years before He created the heavens and the earth, as His Throne was upon water.

Book 33, Number 6417:

    This hadith has been narrated on the authority of Abu Hani with the same chain of transmitters, but there is no mention of "His Throne was upon water."

Chapter 3 : ALLAH TURNS THE HEARTS AS HE DESIRES

Book 33, Number 6418:

    Abdullah b. Amr b. al-'As reported that he heard Allah's Messenger (may peace be upon him) as saying: Verily, the hearts of all the sons of Adam are between the two fingers out of the fingers of the Compassionate Lord as one heart. He turns that to any (direction) He likes. Then Allahs Messenger (may peace be upon him) said : 0 Allah, the Turner of the hearts, turn our hearts to Thine obedience.

Chapter 4 : THERE IS A MEASURE FOR EVERYTHING

Book 33, Number 6419:

    Tawus reported: I found some Companions of Allah's Messenger (may peace be upon him) as saying: Everything is by measure. And he further said: I heard Abdullah b. 'Umar as saying: There is a neasure for everything-even for incapacity and-capability.

Book 33, Number 6420:

    Abu Huraira reported that the polytheists of the Quraish came to have an argument with Allah's Messenger (may peace be upon him) in regard to Destiny and then this verse was revealed: "On the day when they are dragged into the Fire upon their faces , taste the touch of Fire. Surely, We have created everything according to a measure" (liv. 48).

Chapter 5 : THE MEASURE OF THE SON OF ADAM IN REGARD TO ADULTERY, ETC.

Book 33, Number 6421:

    Abu Huraira reported Allah's Apostle (may peace be upon him) as saying: Verily Allah has fixed the very portion of adultery which a man will indulge in, and which he of necessity must comrriit. The adultery of the eye is the lustful look, and the adultery of the tongue is the licentious speech, the heart desires and yearns, which the parts may or may not put into effect.

Book 33, Number 6422:

    Abu Huraira reported Allah's Messenger (may peace be upon him) as saying. Allah fixed the very portion of adultery which a man will indulge in. There would be no escape from it. The adultery of the eye is the lustful look and the adultery of the ears is listening to voluptuous (song or talk) and the adultery of the tongue is licentious speech and the adultery of the hand is the lustful grip (embrace) and the adultery of the feet is to walk (to the place) where he intends to commit adultery and the heart yearns and desires which he may or may not put into effect.

Chapter 6 : EVERYONE IS BORN ACCORDING TO HIS TRUE NATURE AND THE COMMAND PERTAINING TO THE DEMISE OF THE CHILDREN OF THE INFIDELS AND OF THE CHILDREN OF THE MUSLIMS

Book 33, Number 6423:

    There is none born but is created to his true nature (Islam). It is his parents who make him a Jew or a Christian or a Magian quite as beasts produce their young with their limbs perfect. Do you see anything deficient in them? Then he quoted the Qur'an. ,The nature made by Allah in which He has created men there is no altering of Allah's creation ; that is the right religion" (xxx. 33)

Book 33, Number 6424:

    This hadith has been narrated on the authority of Zuhri with the same chain of transmitters and there is no mention of his deficiency in limbs.

Book 33, Number 6425:

    Abu Huraira reported Allah's Messenger (may peace be upon him) as saying: No child is born but upon Fitra. He then said. Recite: The nature made by Allah in which He created man, there is no altering of Allah's nature; that is the right religion."

Book 33, Number 6426:

    Abu Huraira reported Allah's Messenger (may peace be upon him) as saying: No babe is born but upon Fitra. It is his parents who make him a Jew or a Christian or a Polytheist. A person said: Allah's Messenger, what is your opinion if they were to die before that (before reaching the age of adolescence when they can distinguish between right and wrong) ? He said: It is Allah alone Who knows what they would be doing.

Book 33, Number 6427:

    It is reported on the authority of Abu Mu'awiya that (the Holy Prophet) said: Every new-born babe is born on the millat (of Islam and he) remains on this until his tongue is enabled to express himself.
    This hadith has been narratted on the authority of Abu Mu'awiya through another chain of transmitters (and the words are) : "Every child is born but on this Fitra so long as he does not express himself with his tongue."

Book 33, Number 6428:

    Abu Huraira reported from Allah's Messenger (may peace be upom him) many ahadith and one amongst them is that he is reported to have said: An infant is born according to his (true) nature. It is his parents Who make him a Jew, a Christian, just as a she-camel gives birth to its young ones. Do you find any deficiency in their limbs? You cut their ears (i.e. after birth). They (the Companions of the Holy Prophet) said: What is your opinion about him who dies in infancy? Thereupon Allah's Apostle (may peace be upon him) said: It is Allah alone Who knows best what they would be doing.

Book 33, Number 6429:

    Abu Huraira reported Allah's Messenger (may peace be upon him) as saying: The mother of every person gives him birth according to his true nature. It is subsequently his parents who make him a Jew or a Christian or a Magian. Had his parents been Muslim he would have also remained a Muslim. Every person to whom his mother gives birth (has two aspects of his life) ; when his mother gives birth Satan strikes him but it was not the case with Mary and her son (Jesus Christ).

Book 33, Number 6430:

    Abu Huraira reported that Allah's Messenger (may peace be upon him) was asked about the children of the polytheists, whereupon he said: It is Allah Who knows best what they would be doing.

Book 33, Number 6431:

    This hadith has been transmitted on the authority of Shu'aib and Ma'qil with a slight variation of wording.

Book 33, Number 6432:

    Abu Huraira reported that Allahs Messenger (way peace be upon him) was asked about the children of the polytheists who die young. Thereupon Allah's Apostle (may peace be upon him) said: It is Allah Who knows what they would be doing.

Book 33, Number 6433:

    Ibn Abbas reported that Allah's Messenger (may peace be upon him) was asked about the children of the polytheists, whereupon he said: It is Allah alone Who knows what they would be doing according to their creation.

Book 33, Number 6434:

    Ubayy b. Ka'b reported that AUah's Messenger (may peace be upon him) said: The young man whom Khadir killed was a non-believer by his very nature and had he survived he would have involved his parents in defiance and unbelief.

Book 33, Number 6435:

    'A'isha, the mother of the believers, reported that a child died and I said: There is happiness for this child who is a bird from amongst the birds of Paradise. Thereupon Allah's Messenger (may peace be upon him) said: Don't you know that Allah created the Paradise and He created the Hell and He created the dwellers for this (Paradise) and the denizens for this (Hell)?

Book 33, Number 6436:

    'A'isha, the mother of the believers, said that Allah's Messenger (may peace be upon him) was called to lead the funeral prayer of a child of the Ansar. I said: Allah's Messenger, there is happiness for this child who is a bird from the birds of Paradise for it committed no sin nor has he reached the age when one can commit sin. He said: 'A'isha, per adventure, it may be otherwise, because God created for Paradise those who are fit for it while they were yet in their father's loins and created for Hell those who are to go to Hell. He created them for Hell while they were yet in their father's loins.

Book 33, Number 6437:

    This hadith has been narrated on the authority of Yahya with the same chain of transmitters.

Chapter 7 : THE SPAN OF LIFE AND LIVELIHOOD DOES NOT INCREASE OR DECREASE BEYOND THAT WHAT IS LAID DOWN

Book 33, Number 6438:

    Abdullah reported that Umm Habiba, the wife of Allah's Apostle (may peace be upon him), said: 0 Allah, enable me to derive benefit from my husband, the Messenger of Allah (may peace be upon him), and from my father Abu Sufyan and from my brother Mu'awiya. Allah's Apostle (may peace be upon him) said: You have asked from Allah about durations of life already set, and the length of days already allotted and the sustenances the share of which has been fixed. Allah would not do anything earlier before its due time, or He would not delay anything beyond its due time. And if you were to ask Allah to provide you refuge from the torment of the HellFire, or from the torment of the grave, it would have good in store for you and better for you also. He (the narrator) further said: Mention was made before him about monkeys, and Mis'ar (one of the narrators) said: I think that (the narrator) also (made a mention) of the swine, which had suffered metamorphosis. Thereupon he (the Holy Prophet) said: Verily, Allah did not cause the race of those which suffered metamorphosis to grow or they were not survived by young ones. Monkeys and swine had been in existence even before (the metamorphosis of the human beings).

Book 33, Number 6439:

    This hadith has been reported on the authority of Mis'ar with the same chain of transmitters but with this variation that the hadith transmitted on the authority of Ibn Bishr and Waki', the torment of the Hell-Fire and the torment of grave have been mentioned together (and there is no conjunction "iw" or" between them).

Book 33, Number 6440:

    Ibn Mas'dd reported that Umm Habiba said: 0 Allah, enable me to derive benefit from my husband, Allah's Messenger (may peace be upon him), and from my father Abu Sufyan, and from my brother Mu'awiya. Allah's Messenger (may peace be upon him) said to her: Verily, you have asked Allah about the durations of life already set, and the steps which you would take, and the sustenances the share of which is fixed. Nothing would take place earlier than its due time, and nothing would be deferred beyond that when it is due. So, if you were to ask Allah about your safety from the torment of Hell-Fire and from the torment of the grave, it would have been better for you. A person said: Allah's Messenger, what about those apes and swine which suffered metamorphosis? Thereupon Allah's Apostle (may peace be upon him) said: Verily, Allah, the Exalted and Glorious, did not destroy a people or did not torment a people, and let their race grow. Apes and swine had been even before that (when the deniers of truth were tormented and suffered metamorphosis). This hadith has been narrated on the authority of Sufyin through another chain of transmitters but with a slight variation of wording.

Chapter 8 : AFFAIR PERTAINING TO STRENGTH, AND SHEDDING OFF WEAKNESS, AND SEEKING HELP FROM ALLAH AND TRUST IN THE MEASURES SET BY ALLAH

Book 33, Number 6441:

    Abu Huraira reported Allah's Messenger (may peace be upon him) as saying: A strong believer is better and is more lovable to Allah than a weak believer, and there is good in everyone, (but) cherish that which gives you benefit (in the Hereafter) and seek help from Allah and do not lose heart, and if anything (in the form of trouble) comes to you, don't say : If I had not done that, it would not have happened so and so, but say: Allah did that what He had ordained to do and your "if" opens the (gate) for the Satan.


Book 34: The Book of Knowledge (KITAB AL-'ILM)

KITAB AL-'ILM
THE BOOK OF KNOWLEDGE

Back
Chapter 1 : PROHIBITION OF MAKING A HOT PURSUIT OF THE ALLEGORIES CONTAINED IN THE QUR'AN, AND AVOIDING THOSE WHO DO IT, AND OF DISPUTATION IN THE QUR'AN

Book 34, Number 6442:

    'A'isha reported that Allah's Messenger (may peace be upon him) recited (these verses of the Qur'an) : "He it is Who revealed to thee (Muhammad) the Book (the Qur'an) wherein there are clear revelations-these are the substance of the Book and others are allegorical (verses). And as for those who have a yearning for error they go after the allegorical verses seeking (to cause) dissension, by seeking to explain them. And none knows their implications but Allah, and those who are sound in knowledge say: We affirm our faith in everything which is from our Lord. It is only the persons of understanding who really heed" (iii. 6). 'A'isha (further) reported that Allah's Messenger (may peace be upon him) said (in connection with these verses) : When you see such verses, avoid them, for it is they whom Allah has pointed out (in the mentioned verses).

Chapter 2 : PERRAINING TO A DISPUTATIONIST

Book 34, Number 6443:

    'Abdullah b. 'Umar reported: I went to Allah's Messenger (may peace be upon him) in the morning and he heard the voice of two persons who had an argumentation with each other about a verse. Allah's Apostle (may peace be upon him) came to us (and) the (signs) of anger could be seen on his face. He said: Verily, the (peoples) before you were ruined because of their disputation in the Book.

Book 34, Number 6444:

    Jundub b. 'Abdullah al-Bajali reported Allah's Messenger (may peace be upon him) as saying: Recite the Qur'an as long as your hearts agree to do so, and when you feel variance between them (between your hearts and tongues), then get up (and leave its recital for the time being).

Book 34, Number 6445:

    Jundub (i.e. Ibn 'Abdullah) reported that Allah's Messenger (may peace be upon him) said: Recite the Qur'an as long as your hearts agree to do so and when you find variance between them, then stand up.

Book 34, Number 6446:

    Abu Imran reported that Jundub told us as we were young boys living in Kilfa, that Allah's Messenger (may peace be upon him) had said: Recite the Qur'an. The rest of the hadith is the same.

Book 34, Number 6447:

    'A'isha reported Allah's Messenger (may peace be upon him) as saying: The most despicable amongst persons in the eye of Allah is one who tries to fall into dispute with others (for nothing but only to display his knowledge and power of argumentation).

Chapter : FOLLOWING THE FOOTSTEPS OF THE JEWS AND THE CHRISTIANS

Book 34, Number 6448:

    Abu Sa'id al-Khudri reported Allah's Messenger (may peace be upon him) as saying: You would tread the same path as was trodden by those before you inch by inch and step by step so much so that if they had entered into the hole of the lizard, you would follow them in this also. We said: Allah's Messenger, do you mean Jews and Christians (by your words) "those before you" ? He said: Who else (than those two religious groups) ?

Book 34, Number 6449:

    This hadith has been narrated on the authority of 'Ata' b. Yasir through another chain of transmitters.

Chapter 4 : THOSE WHO INDULGED IN HAIR-SPLITTING WERE RUINED

Book 34, Number 6450:

    Abdullah reported Allah's Messenger (may peace be upon him) as saying: Ruined were those who indulged in hair-splitting. He (the Holy Prophet) repeated this thrice.

Chapter 5 : KNOWLEDGE WOULD BE TAKEN AWAY, AND IGNORANCE WOULD PREVAIL UPON PEOPLE AND THE TURMOIL AT THE END OF THE WORLD

Book 34, Number 6451:

    Anas b. Malik reported Allah's Messenger (may peace be upon him) as saying: It is from the conditions of the Last Hour that knowledge would be taken away and ignorance would prevail (upon the world), the liquor would be drunk, and adultery would become rampant.

Book 34, Number 6452:

    Qatida reported that Anas b. Malik said: May I not narrate to you a hadith which I heard from Allah's Messenger (may peace be upon him) which no one would narrate to you after me who would have personally heard it from him (the Holy Prophet) (as I have the good fortune to do so)?-" It is from the signs of the Last Hour that knowledge would be taken away, ignorance would prevail upon (the world), adultery would become common, wine would be drunk, the number of men will fall short and the women would survive (and thus such a disparity would arise in the number of men and women) that there would be one man to look after fifty women.

Book 34, Number 6453:

    This hadith has been transmitted on the authority of Anas b. Malik through another chain of narrators, but with a slight variation of wording.

Book 34, Number 6454:

    Abu Wa'il reported: I was sitting with 'Abdullah and Abu Musa that they reported Allah's Messenger (may peace be upon him) having said: Prior to the Last Hour, there would be a time when knowledge would be taken away, and ignorance would take its place and there would be bloodshed on a large scale.

Book 34, Number 6455:

    This hadith has been narrated on the authority of 'Abdullah (b. Mas'ud) and Abu Musa (al-Asha'ri) through other chains of transmitters.

Book 34, Number 6456:

    A hadith like this has been narrated on the authority of Abu Musa through another chain of transmitters.

Book 34, Number 6457:

    Abu Wa'il reported: I was sitting with Abu Musa and 'Abdullah and they were conversing with each other and Abu Musa reported Allah's Messenger (may peace be upon him) as saying (that we find in the above-mentioned ahadith).

Book 34, Number 6458:

    Abu Huraira reported Allah's Messenger (may peace be upon him) as saying: (When) the time would draw close to the Last Hour, knowledge would be snatched away, turmoil would be rampant, miserliness would be put (in the hearts of the people) and therewould be much bloodshed. They said: What is al-harj? Thereupon he said: It is bloodshed.

Book 34, Number 6459:

    This hadith has been transmitted on the authority of Abu Huraira with a slight variation of wording.

Book 34, Number 6460:

    Abu Huraira reported Allah's Messenger (may peace be upon him) having said: The time would draw close to the Last Hour and knowledge would decrease. The rest of the hadith is the same.

Book 34, Number 6461:

    This hadith has been transmitted on the authority of Abu Huraira through other chains of narrators and there is no mention of : "Miserliness would be put (in the hearts of the people)."

Book 34, Number 6462:

    'Abdullah b. 'Amr b. al-'As reported Allah's Messenger (may peace be upon him) as saying: Verily, Allah does not take away knowledge by snatching it from the people but He takes away knowledge by taking away the scholars, so that when He leaves no learned person, people turn to ignorant as their, leaders; then they are asked to deliver religious verdicts and they deliver them without knowledge, they go astray, and lead others astray.

Book 34, Number 6463:

    This hadith has been narrated on the authority of 'Abdullah b. Umar through other chains of transmitters, but in the hadith transmitted by Umar b. 'Ali there is an addition of these words: I met 'Abdullah b. 'Amr at the end of the year and I asked him about it, and he narrated to us the hadith as he had narrated before that he had heard Allah's Messenger (may peace be upon him) as saying.... (The rest of the hadith is the same).

Book 34, Number 6464:

    This hadith has been narrated on the authority of 'Abdullah b. Amr b. al-'As through another chain of transmitters.

Book 34, Number 6465:

    'Urwa b. Zubair reported that 'A'isha said to him: This news has reached me that 'Abdullah b. 'Amr al-'As would pass by us during the Hajj season, so you meet him and ask him (about religious matters) as he has acquired great knowledge from Allah's Messenger (may peace be upon him). I thus met him and asked him about things which he narrated from Allah's Messenger (may peace be upon him). And amongst these the one he mentioned was that Allah's Apostle (may peace be upon him) said: Verily, Allah does not take away knowledge from people directly but he takes away the scholars and consequently takes away (knowledge) along with them and leaves amongst persons the ignorant as their leaders who deliver religious verdicts without (adequate) knowledge and themselves go astray and lead others astray. 'Urwa said: When I narrated this to 'A'isha, she deemed it too much (to believe) and thus showed reluctance to accept that (as perfectly true) and said to 'Urwa: Did he ('Abdullah b. 'Amr) say to you that he had heard Allah's Apostle (may peace be upon him) as saying: ('Urwa had forgotten to ask this from 'Abdullah b. 'Amr). So when it was the next year, she ('A'isha) said to him ('Urwa): Ibn Amr has come (for Hajj), so meet him. talk to him and ask him about this hadith that he narrated to You (last year on the occasion of the Hajj) pertaining to knowledge. He ('Urwa), said: So I met him, and asked about it and he narrated to me exactly like one that he had narrated (to me) for the first time. So when I informed her ('A'isha) about that, she said: I do not think but this that he has certainly told the truth and I find that he has neither made any addition to it, nor missed anything from it.

Chapter 6 : PERTAINING TO ONE WHO INTRODUCED SOMETHING GOOD OR EVIL, OR HE WHO CALLED TO RIGHTEOUSNESS OR TO THE PATH OF ERROR

Book 34, Number 6466:

    Jarir b. Abdullah reported that some desert Arabs clad in woollen clothes came to Allah's Messenger (may peace be upon him). He saw them in sad plight as they had been hard pressed by need. He (the Holy Prophet) exhorted people to give charity, but they showed some reluctance until (signs) of anger could be seen on his face. Then a person from the Ansar came with a purse containing silver. Then came another person and then other persons followed them in succession until signs of happiness could be seen on his (sacred) face. Thereupon Allah's Messenger (may peace be upon him) said: He who introduced some good practice in Islam which was followed after him (by people) he would be assured of reward like one who followed it, without their rewards being diminished in any respect. And he who introduced some evil practice in Islam which had been followed subsequently (by others), he would be required to bear the burden like that of one who followed this (evil practice) without their's being diminished in any respect.

Book 34, Number 6467:

    Jarir reported that Allah's Messenger (may peace be upon him) delivered an address in which he exhorted people to give charity.

Book 34, Number 6468:

    Jarir b. 'Abdullah reported Allah's Messenger (may peace be upon him) as saying: The servant does not introduce good practice which is followed after him.... The rest of the hadith is the same.

Book 34, Number 6469:

    Jarir transmitted this hadith from his father through another chain of narrators.

Book 34, Number 6470:

    Abu Huraira reported Allah's Messenger (may peace be upon him) as saying: He who called (people) to righteousness, there would be reward (assured) for him like the rewards of those who adhered to it, without their rewards being diminished in any respect. And he who called (people) to error, he shall have to carry (the burden) of its sin, like those who committed it, without their sins being diminished in any respect.


BOOK 35: The Book Pertaining to the Remembrance of Allah, Supplication, Repentance and Seeking Forgiveness (Kitab Al-Dhikr)

KITAB AL-DHIKR
(BOOK PERTAINING TO THE REMEMBRANCE OF ALLAH, SUPPLICATION, REPENTANCE AND SEEKING OF FORGIVENESS)

Back
INTRODUCTION

    Supplication is in fact not only the spontaneous outpourings of man's heart before his Lord, but it is an expression of his sense of nearness to Him, of His Might and Power, of his confidence in His mercy, grace and blessings. If one were to know how much a man supplicates, and what he supplicates about, and how he supplicates, one would be able to see how much spirituality is there in his soul. When a man without any witness speaks with Allah, the soul stands unveiled before its Creator. The higher the note he strikes in his outpouring, the higher is the quality of the faith that is imprinted upon his soul, and serves as a background to all his thought and activity. Thus to understand the spirit of any religion and appraise its value to life and society, supplications serve as the key. The Prophet (may peace be upon him) was a great believer in supplication and prayer. He made supplications to his Lord with zeal and fervour, rarely to be found in the religious literature of the world. One who cares to read them cannot but be overwhelmed with the depth of feelings with which the Holy Prophet (may peace be upon him) approaches his Lord, his intense love for the Great Master, his deep faith in His unbounded Favours, his unshakeable confidence in His Divine Mercy and unflinching faith in His Might and Power, and his sense of deep humility before Him. These are in fact the multi-coloured threads with which is woven the delicate pattern of the Prophet's (may peace be upon him) supplications. In Islam the supplication which a Muslim has been instructed to make whether singly or in congregation, whether at the appointed hour of ritual prayer or at any sudden call or urge to His Lord, reflects the one single attitude of submission, humility and closeness to God. Whatever is the state of spiritual elevation of the supplication he is made to keep this fact constantly in his mind that he is a humble servant of the Lord. That is the reason why most of the supplications in Islam open with an invocation of the Divine Being; either the personal name of God, i.e. Allah, is used or the descriptive title of His Attributes are called out in order to make the worshipper conscious of his own weak and dependent self before his Master. In Islam man seeks to move God to help and grant him what he desires, and at the same time he seeks unconsciously to work upon himself through the realisation of what God means to him, to strengthen, to renew and to refresh his own inner life.

    While the expression of dependence and trust is in reality a prerequisite of supplication in Islam, it covers the whole range of human life with all its needs, longings and problems. Supplication finds expression in a deep and urgent longing for self preservation and deliverance from the oppressive situation, forgiveness of sins, elevation of the soul, goodness of the worldly life and that of the Hereafter. This consciousness of one's absolute dependence upon Him, which pervades the entire stock of the Prophet's (may peace be upon him) supplications, shows man's attitude of perfect resignation before the Mighty Will of the Master, but this resignation has nothing of the spirit of despondence and despair in it; it rather illuminates hope out of conviction that the Being Who is the Lord of man's fate can also help him and save him even in the most trying circumstances.

    The supplications of Muhammad (may peace be upon him) eminently combine in themselves the mystical and the religious traits. While the Muslim supplicates, he, like a mystic, beholds undisturbed with concentrated gaze one Supreme Spiritual Reality Who is the Embodiment and Repository of all values. But, unlike mystics, he, in the hour of contemplation in supplication, does not lose himself but realises himself to be a humble servant of God and therein lies his spiritual strength and unwavering confidence in God.

    The one more distinguishing feature of the supplications taught by Muhammad (may peace be upon him) is that these are all permeated with the spirit of social fellowship. They do not urge man to stand face to face with God in absolute loneliness, isolated from all other human beings. Herein the suppliant begs his Lord with the full consciousness of human brotherhood and with a feeling that the distress which vexes him is not his only, it is that of his brethren. The graces of God and the salvation for which he longs are also the longings of all believers, nay, of the entire humanity. There is no doubt a deep touch of intimate personal and individual contact with God in these supplications, but this contact is not of the nature of a non-Muslim mystic in which the soul is supposed to be unified with God losing all its individual identity. Here the soul has a communion with Allah with full consciousness of man's own self, his social surroundings and responsibilities. That is why most of the supplications have been expressed in the form "We" and Us".

Chapter 1 : EXHORTATION FOR THE REMEMBRANCE OF ALLAH, THE EXALTED

Book , Number 6471:

    Abu Huraira reported Allah's Messenger (may peace be upon him) as saying that Allah, the Exalted and Glorious, thus stated : I am near to the thought of My servant as he thinks about Me, and I am with him as he remembers Me. And if he remembers Me in his heart, I also remember him in My Heart, and if he remembers Me in assembly I remember him in assembly, better than his (remembrance), and if he draws near Me by the span of a palm, I draw near him by the cubit, and if he draws near Me by the cubit I draw near him by the space (covered by) two hands. And if he walks towards Me, I rush towards him.

Book 35, Number 6472:

    This hadith has been narrated on the authority of A'mash with the same chain of transmitters, but there is no mention of these words: "He draws near Me by the space of a hand, I draw near him by the space (covered) by two hands."

Book 35, Number 6473:

    Hammam b. Munabbih reported so many ahadith from Abu Huraira and one out of them is this that Allah's Messenger (may peace be upon him) said that Allah thus stated: When My servant draws close to me by the span of a palm, I draw close to him by the space of a cubit, and when he draws close to Me by the space of a cubit, I draw close to him by the space (covered) by two hands, and when he draws close to Me by the space (covered by) two hands, I go in hurry towards him.

Book 35, Number 6474:

    Abu Huraira reported that Allah's Messenger (may peace be upon him) was travelling along the path leading to Mecca that he happened to pass by a mountain called Jumdan. He said: Proceed on, it is Jumdan, Mufarradun have gone ahead. They (the Companions of the Holy Prophet) said: Allah's Messenger, who are Mufarradun? He said: They are those males and females who remember Allah much.

Chapter 2 : THE NAMES OF ALLAH, THE EXALTED, AND THE MERIT OF ONE WHO ENUMERATES THEM

Book , Number 6475:

    Abu Huraira reported Allah's Messenger (may peace be upon him) as saying: There are ninety-nine names of Allah; he who commits them to memory would get into Paradise. Verily, Allah is Odd (He is one, and it is an odd number) and He loves odd number. And in the narration of Ibn 'Umar (the words are) : "He who enumerated them."

Book 35, Number 6476:

    Abu Huraira reported Allah's Apostle (may peace be upon him) as saying: Verily, there are ninety-nine names for Allah, i.e. hundred excepting one. He who enumerates them would get into Paradise. And Hammam has made this addition on the authority of Abu Huraira who reported it from Allah's Apostle (may peace be upon him) that he said: "He is Odd (one) and loves odd number."

Chapter 3 : SUPPLICATION SHOULD BE MADE WITH CONVICTION AND WILL

Book 35, Number 6477:

    Anas reported Allah's Messenger (may peace be upon him) as saying: When one of you makes supplication, he should supplicate with a will and should not say: O Allah, confer upon me if Thou likest, for there is none to coerce Allah.

Book 35, Number 6478:

    Abu Huraira reported Allah's Messenger (may peace be upon him) as saying: When one of you makes a supplication (to his Lord) one should not say: O Allah, grant me pardon, if Thou so likest, but one should beg one's (Lord) with a will and full devotion, for there is nothing so great in the eye of Allah which He cannot grant.

Book 35, Number 6479:

    Abu Huraira reported Allah's Messenger (may peace be upon him) as saying: None of you should say to Allah (like this): O Allah, grant me mercy, if thou so likest. The supplication (of his) should (be permeated with) conviction (that it would be accepted by the Lord), for Allah is the Doer of (everything) He likes to do, and there is none to force Him (to do or not to do this or that).

Chapter 4 : IT IS NOT SOMETHING APPRECIABLE TO MAKE REQUEST FOR DEATH FROM THE LORD WHEN ONE IS IN TROUBLE

Book 35, Number 6480:

    Anas (b. Malik) reported Allah's Messenger (may peace be upon him) as saying. None of you should make a request for death because of the trouble in which he is involved, but if there is no other help to it, then say: O Allah, keep me alive as long as there is goodness in life for me and bring death to me when there is goodness in death for me.

Book 35, Number 6481:

    This hadith has been narrated on the authority of Anas through another chain of transmitters, but with a small variation of wording.

Book 35, Number 6482:

    Nadr b. Anas reported, as when Anas was alive, that he said: Had Allah's Messenger (may peace be upon him) not stated this.. "None should make a request for death," I would have definitely done that.

Book 35, Number 6483:

    Abu Hazim reported: I visited Khabbab who bad seven cauteries on his stomach and he s aid: Had Allah's Messenger (may peace be upon him) not forbidden us to call for death, I would have done so.

Book 35, Number 6484:

    This hadith has been transmitted on the authority of Isma'il through other chains of narrators.

Book 35, Number 6485:

    Hammam b. Munabbih said: Abu Huraira narrated to us ahadith from Allah's Messenger (may peace be upon him) and out of these one is that Allah's Messenger (may peace be upon him) said: None amongst you should make a request for death, and do not call for it before it comes, for when any one of you dies, he ceases (to do good) deeds and the life of a believer is not prolonged but for goodness.

Chapter 5 : HE WHO LOVES TO MEET ALLAH, ALLAH ALSO LOVES TO MEET HIM, AND HE WHO DISLIKES TO MEET ALLAH, ALLAH ALSO ABHORS TO MEET HIM

Book 35, Number 6486:

    Ubida b. Samit reported Allah's Messenger (may peace be upon him) as saying: He who loves to meet Allah, Allah also loves to meet him, and he who dislikes to meet Allah, Allah also abhors to meet him.

Book 35, Number 6487:

    This hadith has been narrated on the authority of 'Ubada b. Samit through another chain of transmitters.

Book 35, Number 6488:

    A'isha reported that Allah's Messenger (may peace be upon him) said: He who loves to meet Allah, Allah loves to meet him, and he who dislikes to meet Allah, Allah abhors to meet him. I ('A'isha) said : Allah's Apostle, so far as the feeling of aversion against death is concerned, we all have this feeling. Thereupon he (the Holy Prophet) said: It is not that (which you construe), but (this) that when a believer (at the time of death) is given the glad tidings of the mercy of Allah, His Pleasure, and of Paradise, he loves to meet Allah, and Allah also loves to meet him, and when an unbeliever is given the news of the torment at the Hand of Allah, and Hardship to be imposed by Him, he dislikes to meet Allah and Allah also abhors to meet him.

Book 35, Number 6489:

    This hadith has been reported on the authority of Qatida with the same chain of transmitters.

Book 35, Number 6490:

    'A'isha reported Allah's Messenger (may peace be upon him) as saying: He who loves to meet Allah, Allah also loves to meet him, and who dislikes to meet Allah, Allah abhors to meet him. There is death before (one is able to) meet Allah.

Book 35, Number 6491:

    A hadith like this has been narrated on the authority of A'isha through another chain of transmitters.

Book 35, Number 6492:

    Abu Huraira reported Allah's Messenger (may peace be upon him) as saying: He who loves meeting Allah, Allah loves to meet him, and he who dislikes to meet Allah, Allah abhors to meet him. I (Shuraih b. Hani, one of the narrators) came to A'isha and said to her: Mother of the faithful, I heard Abu Huraira narrate from Allah's Messenger (may peace be upon him) which, if it is actually so, is a destruction to us. Thereupon she said: Those are in fact ruined who are ruined at the words of Allah's Messenger (may peace be upon him). What are (the words which in your opinion would cause your destruction)? He said that Allah's Messenger (may peace be upon him) had stated: He who loves to meet Allah, Allah too loves to meet him, and he who dislikes to meet Allah, Allah too abhors to meet him, and there is none amongst us who dons not hate death. Thereupon she said: Allah's Messenger (may peace be upon him) has in fact stated this, but it does not mean what you construe, but it implies (the time) when one loses the lustre of the eye, and there is rattling in the throat, shudder in the body and convulsion in fingers (at the time of death). (It is about this time) that it has been said: He who loves to meet Allah, Allah would love to meet him, and he who dislikes to meet Allah, Allah would abhor to meet him

Book 35, Number 6493:

    This hadith has been reported on the authority of Mutarrif with the same chain of transmitters.

Book 35, Number 6494:

    Abu Musa reported Allah's Apostle (may peace be upon him) as saying: He who loves to meet Allah, Allah too loves to meet him, and he who dislikes to meet Allah, Allah abhors to meet him.

Chapter 6 : MERIT OF REMEMBRANCE OF ALLAH AND CALLING HIM, AND NEARNESS TO ALLAH, THE EXALTED

Book 35, Number 6495:

    Abu Huraira reported Allah's Messenger (may peace be upon him as saying that Allah thus stated: I live in the thought of My servant as he thinks of Me and with him as he calls Me.

Book 35, Number 6496:

    Abu Huraira reported Allah's Apostle (may peace be upon him) as saying that Allah, the Exalted and Glorious, said: When My servant draws close to Me by the span of a palm, I draw close to him by the cubit and when he draws close to Me by the cubit, I draw close to him by the space (covered) by two hands, and when he draws close to Me by the space (covered) by two hands, I go in hurry towards him.

Book 35, Number 6497:

    This hadith has been narrated on the authority of Mu'tamar from his father with the same chain of transmitters, with a slight variation of wording.

Book 35, Number 6498:

    Abu Huraira reported Allah's Messenger (may peace be upon him) as saying that Allah, the Exalted and Glorious, thus stated: I live in the thought of My servant as he thinks about Me, and I am with him, as he remembers Me And if he remembers Me in his heart, I also remember him in My Heart, and if he remembers Me in assembly I remember him in the assembly, better than he (does that), and if he draws near Me by the span of a palm I draw near him by the cubit, and if he draws near Me by the cubit I draw near him by the space (covered by) two hands. And it he walks towards Me, I rush towards him.

Book 35, Number 6499:

    Abu Dharr reported Allah's Messenger (may peace be upon him) as saying that Allah, the Exalted and Glorious, stated: "He who comes with goodness, there are in store for him ten like those and even more than those: 'And he who comes with vice,' it is only for that that he is called to account. I even forgive him (as I like) and he who draws close to Me by the span of a palm I draw close to him by the cubit, and he who draws close to Me by the cubit I draw close to him by the space (covered) by two hands, and he who walks towards Me I rush towards him, and he who meets Me in the state that his sins fill the earth, but not associating anything with Me, I would meet Him with the same (vastness) of pardon (on My behalf)." This hadith has been transmitted on the authority of Waki'.

Book 35, Number 6500:

    A hadith like this has been transmitted on the authority of A'mash with the same chain of transmitters and he (further) said: There is for him ten like that (the good he performed) or more than that.

Chapter 7 :THE DISAPPROVAL OF SUPPLICATION IN WHICH A REQUEST IS MADE TO ALLAH FOR PUNISHMENT OF ONE'S (MISDEEDS) IN THE WORLD

Book 35, Number 6501:

    Anas reported that Allah's Messenger (may peace be upon him) visited a person from amongst the Muslims in order to inquire (about his health) who had grown feeble like the chicken. Allah's Messenger (may peace be upon him) said: Did you supplicate for anything or beg of Him about that? He said: Yes. I used to utter (these words): Impose punishment upon me earlier in this world, what Thou art going to impose upon me in the Hereafter. Thereupon Allah's Messenger (may peace be upon him) said: Hallowed be Allah, you have neither the power nor forbearance to take upon yourself (the burden of His Punishment). Why did you not say this: O Allah, grant us good in the world and good in the Hereafter, and save us from the torment of Fire. He (the Holy Prophet) made this supplication (for him) and he was all right.

Book 35, Number 6502:

    This hadith has been narrated on the authority of Humaid with the same chain of transmitters, but with a slight variation of wording.

Book 35, Number 6503:

    Anas reported that Allah's Messenger (may peace be upon him) visited a person from amongst his Companions who had grown as feeble as the chicken. The rest of the hadith is the same, but with this variation that he (the Holy Prophet) said: You have not power enough to undergo the torment imposed by Allah. And there is no mention of: He supplicated Allah for him and He cured him.

Book 35, Number 6504:

    This hadith had been transmitted on the authority of Anas through another chain of narrators.

Chapter 8 :MERITS OF THE ASSEMBLIES IN WHICH ALLAH IS REMEMBERED

Book 35, Number 6505:

    Abu Huraira reported Allah's Apostle (may peace be upon him) as saying Allah has mobile (squads) of angels, who have no other work (to attend to but) to follow the assemblies of Dhikr and when they find such assemblies in which there is Dhikr (of Allah) they sit in them and some of them surround the others with their wings till the space between them and the sky of the world is fully covered, and when they disperse (after the assembly of Dhikr is adjourned) they go upward to the heaven and Allah, the Exalted and Glorious, asks them although He is best informed about them: Where have you come from? They say: We come from Thine servants upon the earth who had been glorifying Thee (reciting Subhan Allah), uttering Thine Greatness (saying Allah o-Akbar) and uttering Thine Oneness (La ilaha ill Allah) and praising Thee (uttering al-Hamdu Lillah) and begging of Thee. Be would say : What do they beg of Me? They would say: They beg of Thee the Paradise of Thine. He (God) would say : Have they seen My Paradise ? They said : No, our Lord. He would say : (What it would be then) if they were to see Mine Paradise ? They (the angels) said : They seek Thine protection. He (the Lord) would say: Against what do they seek protection of Mine? They (the angels) would say: Our Lord, from the Hell-Fire. He (the Lord) would say: Have they seen My Fire? They would say: No. He (the Lord) would say: What it would be if they were to see My Fire ? They would say : They beg of Thee forgiveness. He would say: I grant pardon to them, and confer upon them what they ask for and grant them protection against which they seek protection. They (the angels) would again say: Our Lord, there is one amongst them such and such simple servant who happened to pass by (that assembly) and sat there along with them (who had been participating in that assembly). He (the Lord) would say: I also grant him pardon, for they are a people the seat-fellows of whom are in no way unfortunate.

Chapter 9 : THE MERIT OF THIS (SUPPLICATION): "O ALLAH, GRANT US THE GOOD IN THE WORLD AND GOOD IN THE HEREAFTER AND SAVE US FROM THE TORMENT OF HELL"

Book 35, Number 6506:

    Qatada asked Anas which Supplication Allah's Apostle (may peace be upon him) frequently made. He said: The supplication that he (the Holy Prophet made very frequently is this: "O Allah, grant us the good in this world and the good in the Hereafter and save us from the torment of Hell-Fire." He (Qatada) said that whenever Anas had to supplicate he made this very supplication, and whenever he (intended) to make another supplication he (inserted) this very supplication in that.

Book 35, Number 6507:

    Anas reported that Allah's Messenger (may peace be upon him) used to supplicate (in these words): "Our Lord, grant us the good in this world and the good in the Hereafter and save us from the torment of Hell Fire."

Chapter 10 :THE MERIT OF PRONOUNCING TAHLIL, TASBIH AND SUPPLICATION

Book 35, Number 6508:

    Abu Huraira reported Allah's Messenger (may peace be upon him) as saying: He who uttered these words: "There is no god but Allah, the One, having no partner with Him. Sovereignty belongs to Him and all the praise is due to Him, and He is Potent over everything" one hundred times every day there is a reward of emancipating ten slaves for him, and there are recorded hundred virtues to his credit, and hundred vices are blotted out from his scroll, and that is a safeguard for him against the Satan on that day till evening and no one brings anything more excellent than this, except one who has done more than this (who utters these words more than one hundred times and does more good acts) and he who utters: "Hallowed be Allah, and all praise is due to Him," one hundred times a day, his sins are obliterated even if they are equal to the extent of the foam of the ocean.

Book 35, Number 6509:

    Abu Huraira reported Allah's Messenger (may peace be upon him) as saying: He who recites in the morning and in the evening (these words): "Hallowed be Allah and all praise is due to Him" one hundred times, he would not bring on the Day of Resurrection anything excellent than this except one who utters these words or utters more than these words.

Book 35, Number 6510:

    'Amr b. Maimun reported: He who uttered: "There is no god but Allah, the One, having no partner with Him, His is the Sovereignty and all praise is due to Him and He is Potent over everything" ten times, he is like one who emancipated four slaves from the progeny of Isma'il. Rabi' b. Khuthaim narrated a hadith like this. Sha'bi reported: I said to Rabi': From whom did you hear it? He said: From 'Amr b. Maimun. I came to 'Amr b. Maimun and said to him: From whom did you hear this hadith? He said: from Ibn Abi Laila. I came to Ibn Abi Laila and said to him: From whom did you hear this hadith? He said: From Abu Ayyub Ansari, who narrated from Allah's Messenger (may peace be upon him).

Book 35, Number 6511:

    Abu Huraira reported Allah's Messenger (may peace be upon him) as saying: Two are the expressions which are light on the tongue, but heavy in scale, dear to the Compassionate One: "Hallowed be Allah and praise is due to Him"; "Hallowed be Allah, the Great."

Book 35, Number 6512:

    Abu Huraira reported Allah's Messenger (may peace be upon him) as saying: The uttering of (these words): "Hallowed be Allah; all praise is due to Allah, there is no god but Allah and Allah is the Greatest," is dearer to me than anything over which the sun rises.

Book 35, Number 6513:

    Mu'sab b. Sa'd reported on the authority of his father that a desert Arab came to Allah's Messenger (may peace be upon him) and said to him: Teach me the words which I should (often) utter. He said: Utter, "There is no god but Allah, the One, having no partner with Him. Allah is the Greatest of the great and all praise is due to Him. Hallowed be Allah, the Lord of the worlds, there is no Might and Power but that of Allah, the All-Powerful and the Wise." He (that desert Arab) said: These all (glorify) my Lord. But what about me? Thereupon he (the Holy Prophet) said: You should say: "O Allah, grant me pardon, have mercy upon me, direct me to righteousness and provide me sustenance." Musa (one of the narrators) said : I think he also said: "Grant me safety." But I cannot say for certain whether he said this or not. Ibn Abi Shaiba has not made a mention of the words of Musa in his narration.

Book 35, Number 6514:

    Abu Malik Ashaja'i reported on the authority of his father that whenever a person embraced Islam, Allah's Messenger (may peace be upon him) instructed him to recilte: "O Allah, grant me pardon, have mercy upon me, direct me to the path of righteousness and provide me sustenance."

Book 35, Number 6515:

    Abu Malik reported on the authority of his father that when a person embraced Islam, Allah's Messenger (may peace be upon him) used to teach him how to observe prayer and then commanded him to supplicate in these words: "O Allah, grant me pardon, have mercy upon me, direct me to the path of righteousness, grant me protection and provide me sustenance."

Book 35, Number 6516:

    Abu Malik reported on the authority Of his father that he heard Allah's Messenger (may peace be upon him) as saying to the person who bad come to him and asked him as to how he should beg his Lord, that he should utter these words: "O Allah, grant me pardon, have mercy upon me, protect me, provide me sustenance," and he collected his fingers together except his thumb and said: It is in these words (that there is supplication) which sums up for you (the good) of this world and that of the Hereafter.

Book 35, Number 6517:

    Mus'ab b. Sa'd reported that his father told him that he had been in the company of Allah's Messenger (may peace be upon him) that he said: Is one amongst you powerless to get one thousand virtues every day. Amongst those who had been sitting there, one asked: How one amongst us can get one thousand virtues every day? He said: Recite: "Hallowed be Allah" one hundred times for (by reciting them) one thousand virtues are recorded (to your credit) and one tbousand vices are blotted out.

Chapter 11 : THE MERIT OF AN ASSEMBLY FOR THE RECITATION OF THE QUR'AN OR FOR TIIE DHIKR (REMEMBRANCE OF ALLAH)

Book 35, Number 6518:

    Abu Huraira reported Allah's Messenger (may peace be upon him) as saying: He who alleviates the suffering of a brother out of the sufferings of the world, Allah would alleviate his suffering from the sufferings of the Day of Resurrection, and he who finds relief for one who is hard pressed, Allah would make things easy for him in the Hereafter, and he who conceals (the faults) of a Muslim, Allah would conceal his faults in the world and in the Hereafter. Allah is at the back of a servant so long as the servant is at the back of his brother, and he who treads the path in search of know- ledge, Allah would make that path easy, leading to Paradise for him and those persons who assemble in the house among the houses of Allah (mosques) and recite the Book of Allah and they learn and teach the Qur'an (among themselves) there would descend upon them the tranquillity and mercy would cover them and the angels would surround them and Allah makes a mention of them in the presence of those near Him, and he who is slow-paced in doing good deeds, his (high) descent does not make him go ahead.

Book 35, Number 6519:

    This hadith has been narrated on the authority of Abu Huraira through another chain of transmitters but with a slight variation of wording.

Book 35, Number 6520:

    Agharr Abi Muslim reported: I bear witness to the fact that both Abu Huraira and Abu Sa'id Khudri were present when Allah's Messenger may peace be upon him) said: The people do not sit but they are surrounded by angels and covered by Mercy, and there descends upon them tranquillity as they remember Allah, and Allah makes a mention of them to those who are near Him. This hadith has been narrated on the authority of Shu'ba with the same chain of transmitters.

Book 35, Number 6521:

    Abu Sa'id Khudri reported that Mu'awiya went to a circle in the mosque and said : What makes you sit here ? They said: We are sitting here in order to re- member Allah. He said: I adjure you by Allah (to tell me whether you are sitting here for this very purpose) ? They said: By Allah, we are sitting here for this very purpose. Thereupon, he said: I have not demanded you to take an oath, because of any allegation against you and none of my rank in the eye of Allah's Messenger (may peace be upon him) is the narrator of so few ahadith as I am. The fact is that Allah's Messenger (may peace be upon him) went out to the circle of his Companions and said: What makes you sit? They said: We are sitting here in order to remember Allah and to praise Him for He guided us to the path of Islam and He conferred favours upgn us. Thereupon he adjured by Allah and asked if that only was the purpose of their sitting there. They said: By Allah, we are not sitting here but for this very purpose, whereupon he (the Messenger) said: I am not asking you to take an oath because of any allegation against you but for the fact that Gabriel came to me and he informed me that Allah, the Exalted and Glorious, was talking to the angels about your magnificence.

Chapter 12 : EXCELLENCE OF SEEKING FORGIVENESS FROM ALLAH AND SEEKING THAT VERY MUCH

Book 35, Number 6522:

    Al-Agharr al-Muzani, who was one amongst the Companions (of the Holy Prophet) reported that Allah's Messenger (may peace be upon him) said: There is (at times) some sort of shade upon my heart, and I seek forgiveness from Allah a hundred times a day.

Book 35, Number 6523:

    Al-Agharr al-Muzani who was from amongst the Companions of Allah's Apostle (may peace be upon him) reported that Ibn 'Umar stated to him that Allah's Messenger (may peace 'be upon him) said: O people, seek repentance from Allah. Verily, I seek repentance from Him a hundred times a day.

Book 35, Number 6524:

    This hadith has been narrated on the authority of Shu'ba with the same chain of transmitters.

Book 35, Number 6525:

    Abu Huraira reported Allah's Messenger (may peace be upon him) as say- ing: He who seeks repentance (from the Lord) before the rising of the sun from the west (before the Day of Resurrection), Allah turns to him with Mercy.

Chapter 13 : EXCELLENCE OF REMEMBERING ALLAH IN A LOW VOICE

Book 35, Number 6526:

    Abu Musa reported: We were along with Allah's Apostle (may peace be upon him) on a journey when the people began to pronounce Allah-o-Akbar in a loud voice. Thereupon Allah's Messenger (may peace be upon him) said: O people, sh mercy to yourselves for you are not calling One Who is deaf or absent. Verily, you are calling One Who is All-Hearing (and) Near to you and is with you. Abu Musa told that he had been behind him (the Holy Prophet) and reciting: "There is neither might nor power but that of Allah." He (the Holy Prophet), while addressing 'Abdullah b. Qais, said: Should I not direct you to a treasure from amongst the treasurers of Para- dise? I ('Abdullah b. Qais) said: Allah's Messenger, do it, of course. Thereupon he (the Holy Prophet) said: Then recite: "There is no might and no power but that of Allah."

Book 35, Number 6527:

    This hadith has been narrated on the authority of 'Asim with the same chain of transmitters.

Book 35, Number 6528:

    Abu Musa reported that he (and his other companions) were climbing upon the hillock along with Allah's Messenger (may peace be upon him) and when any person climbed up, he pronounced (loudly) : "There is no god but Allah, Allah is the Greatest." Thereupon Allah's Apostle (may peace be upon him) said: Verily, you are not supplicating One Who is deaf or absent. He said: Abu Musa or Abdullah b Qais, should I not direct you to the words (which form) the treasure of Paradise ? I said: Allah's Messenger, what are these? He said: "There is no might and no power but that of Allah."

Book 35, Number 6529:

    This hadith has been transmitted on the authority of Abu Musa with a slight variation of wording.

Book 35, Number 6530:

    Abu Musa reported: We were along with Allah's Apostle (may peace be upon him) on a journey; the rest of the hadith is the same as transmitted by A'sim.

Book 35, Number 6531:

    Abu Musa, reported. We were along with Allah's Messenger (may peace be upon him) in an expedition. The rest of the hadith is the same (and there is an addi- tion of these words in that) : "He (the Holy Prophet) said: He Whom you are sup- plicating is nearer to every one of you than the neck of his camel." And there is no mention of these words: "There is no might and no power but that of Allah."

Book 35, Number 6532:

    Abu Musa Ash'ari reported that Allah's Messenger (may peace be upon him) said to him: Should I not direct you to the words from the treasures of Paradise, or he said: Like a treasure from the treasures of Paradise ? I said: Of course, do that. Thereupon he said: "There is no might and no power but that of Allah."

Book 35, Number 6533:

    Abu Bakr reported that he said to Allah's Messenger (may peace be upon him): Teach me a supplication which I should recite in my prayer. Thereupon he (the Holy Prophet) said: Recite: "O Allah, I have done great wrong to myself." According to Qutaiba (the words were:) much (wrong)-there is none to forgive the sins but Thou only, say: "Grant me pardon from Thyself, have mercy upon me for Thou art much Forgiving and Compassionate." This hadith has been transmitted on the authority of 'Amr b. al-'As that Abu Bakr Siddiq said to Allah's Messenger (may peace be upon him): Allah's Messenger. teach me a supplication which I should make in my prayer and in my house. The rest of the hadith is the same except with this variation that he said: Much wrong (Zulman Kathira).

Chapter 14 :SUPPLICATION FOR THE SAFEGUARD OF ONE'S SELF AGAINST THE EVIL OF THE TURMOIL

Book 35, Number 6534:

    'A'isha reported that Allah's Messenger (may peace be upon him) used to make these supplications: "O Allah, I seek refuge in Thee from the trial of Hell-Fire; and from the torment of Hell-Fire; and from the trial of the grave and torment of the grave; and from the evil of the trial of the affluence and from the evil of the trial of poverty and I seek refuge in Thee from the evil of the turmoil of the Dajjal.O Allah, wash away my sins with snow and hail water, purify my heart from the sins as is purified the white garment from the dirt, and keep away at a distance the sins from me as yawns the distance between the East and the West; O Allah, I seek refuge in Thee from sloth, from senility, from sin, and from debt."

Book 35, Number 6535:

    This hadith has been narrated on the authority of Hisham with the same chain of transmitters.

Book 35, Number 6536:

    Anas b. Malik reported that Allah's Messenger (may peace be upon him) used to say: "O Allah, I seek refuge in Thee from incapacity, from indolence, from cowardice, from senility, from miserliness, and I seek refuge in Thee from the torment of the grave and from trial of the life and death."

Book 35, Number 6537:

    Anas reported from Allah's Messenger (may peace be upon him) (this suppli- cation) but with this variation that these words are not found in that supplication: "From the trial of life and death."

Book 35, Number 6538:

    Anas b. Malik reported that Allah's Apostle (may peace be upon him) used to seek refuge in Allah from such things as mentioned in the above-mentioned hadith and from 'miserliness" too.

Book 35, Number 6539:

    Anas reported that Allah's Messenger (may peace he upon him) wed to make this supplication: "O Allah, I seek refuge in Thee from miserliness, from sloth and from decrepitude."

Chapter 15:SEEKING OF REFUGE IN ALLAH FROM THE EVIL OF DESTINY AND FROM THE SEVERITY OF CALAMITY

Book 35, Number 6540:

    Abu Huraira reported that Allah's Apostle (may peace be upon him) used to seek refuge (in Allah) from the evil of destiny and from falling into the hand of calamity and from the mockery of (triumphant) enemies and from the hardship of misery. Abu Sufyan reported: I am in doubt that I have made an addition of one word in this supplication.

Book 35, Number 6541:

    Khaula bint Hakim Sulamiyya reported: I heard Allah's Messenger (may peace be upon him) as saying: When anyone lands at a place, and then says: "I seek refuge in the Perfect Word of Allah from the evil of what He has created," nothing would harm him until he marches from that stopping place.

Book 35, Number 6542:

    Khaula bint Hakim Sulamiyya reported: I heard Allah's Messenger (may peace be upon him) as saying: When any one of you stays at a place, he should say: "I seek refuge in the Perfect Word of Allah from the evil of that He created." Nothing would then do him any harm until he moves from that place. Abu Huraira reported that a person came to Allah's Messenger (may peace be upon him) and said: "Allah's Messenger, I was stung by a scorpion during the night. Thereupon he said: Had you recited these words in the evening: "I seek refuge in the Perfect Word of Allah from the evil of what He created," it would not have done any harm to you.

Book 35, Number 6543:

    This hadith has been transmitted on the authority of Abu Huraira with a slight variation of wording.

Chapter 16 :SUPPLICATION AT THE TIME OF SLEEPING AND GOING TO BED

Book 35, Number 6544:

    Al-Bara' b. 'Azib reported that Allah's, Messenger (may peace be upon said: When you go to bed, perform ablution as is done for prayer; then lie down pn the right side and recite: "O Allah, I turn my face towards Thee and entrust my affair to Thee. I retreat unto Thee for protection with hope in Thee and fear of Thee. There is no resort and no deliverer (from hardship) but Thou only. I affirm my faith in Thine books which Thou revealed and in Thine Apostles whom Thou sent." Make this as the last word of yours (when you go to sleep) and in case you die during that night, you would die upon Fitra (upon Islam). And as I repeated these words in order to commit them to memory, I said: "I affirm my faith in Thy Messenger (Rasul) whom Thou sent." He said: Say: "I affirm my faith in the Apostle (Nabi) whom Thou sent."

Book 35, Number 6545:

    This hadith has been transmitted on the authority of al-Bara' b. 'Azib with a slight variation of wording and there is this addition in the hadith transmitted on the authority of Husain: "In case you get up in the morning, you will get up with bliss."

Book 35, Number 6546:

    Al-Bara' b. 'Azib reported that Allah's Messenger (in may peace be upon him) commanded a person (in these words): When you go to bed during night, you should say: "O Allah, I surrender myself to Thee and entrust my affair to Thee, with hope in Thee and fear of Thee. There is no resort and no deliverer (from hardship but Thou). I affirm my faith in the Book which Thou revealed and in the Messengers whom Thou sent." If you die in this state you would die on Fitra, and Ibn Bashshdr did not make a mention of "night" in this hadith.

Book 35, Number 6547:

    This hadith has been transmitted on the authority of al-Bara' b. 'Azib that Allah's Messenger (may peace be upon him) said to a person: O, so and so, as you go to your bed; the rest of the hadith is the same but with this variation of wording that he said: "Thine Apostle whom Thou sent." If you die that night you would die on Fitra and if you get up in the morning you would get up with a bliss.

Book 35, Number 6548:

    This hadith has been transmitted on the authority of al-Bara' b. 'Azib that Allah's Messenger (may peace be upon him) commanded a person (in these words) and there is no mention of this: "if you get up in the morning you would get up with a bliss."

Book 35, Number 6549:

    Al-Bara' reported that whenever Allah's Messenger (may peace be upon him) went to bed, he said: "O Allah, it is with Thine Name that I live and it is with Thine Name that I die." And when he got up he used to say: "Praise is due to Allah, Who gave us life after our death (sleep) and unto Thee is resurrection."

Book 35, Number 6550:

    Abdullah b. 'Umar commanded a person that as he went to bed, he should say: "O Allah, Thou created my being and it is for Thee to take it to its ultimate goal. And its death and life is due to Thee, and if Thou givest it life, safeguard it; and if Thou bringst death, grant it pardon. O Allah, I beg of Thee safety." A person said to him: Did you hear it from Umar? Thereupon he said: (I have heard from one) who is better than Umar, viz. from Allah's Messenger (may peace be upon him). Ibn Nafi, reported this on the authority of Abdullah b. Harith but he did not make mention of this "that he heard it himself".

Book 35, Number 6551:

    Suhail reported that Abu Salih used to command us (in these words): When any one of you intends to go to sleep, he should lie on the bed on his right side and then say: "O Allah. the Lord of the Heavens and the Lord of the Earth and Lord of the Magnificent Throne, our Lord, and the Lord of evervthina, the Splitter of the grain of corn and the datestone (or fruit kernal), the Revealer of Torah and Injil (Bible) and Criterion (the Holy Qur'an), I seek refuge in Thee from the evil of every- thing Thou art to sieze by the forelock (Thou hast perfect control over it). O Allah, Thou art the First, there is naught before Thee, and Thou art the Last and there is naught after Thee, and Thou art Evident and there is nothing above Thee, and Thou art Innermost and there is nothing beyond Thee. Remove the burden of debt from us and relieve us from want." Abu Salih used to narrate it from Abu Huraira who narrated it from Allah's Apostle (may peace be upon him).

Book 35, Number 6552:

    Abu Huraira reported that Allah's Messenger (may peace be upon him) used to command us that as we go to our bedo, we should utter the words (as mention- ed above) and he also said (these words): "From the evil of every animal, Thou hast hold upon its forelock (Thou bast full control over it)."

Book 35, Number 6553:

    Abu Huraira reported that Fatima (the daughter of the Holy Prophet) came to Allah's Apostle (may peace be upon him) and asked for a servant. He said to her: Say: "O Allah, the Lord of the seven heavens" ; the rest of the hadith is the same.

Book 35, Number 6554:

    Abu Huraira reported Allah's Messenger (may peace be upon him) as say- ing: When any one of you goes to bed, he should take hold of the hem of his lower garment and then should clean (his bed) with the help of that and then should recite the name of Allah for he himself does tiot know what he left behind him on his bed, and when he intends to lie on bed, he should lie on his right side and utter these words: "Hallowed be Allah, my Lord. It is with Thine (grace) that I place my side (upon the bed) and it is with Thee that I take it up (after sleep), and in case Thou withholdst my being (if thou causest me to die), then grant pardon to my being, and if Thou keepst (this process of breathing on), then protect it with that with which Thou protected Thine pious servants."

Book 35, Number 6555:

    This hadith has been narrated on the authority of Ubaidullah b. Umar with the same chain of transmitters and he said: Then utter: "My Lord. with Thine name I place my side and if Thou keepest me alive have mercy upon myself"

Book 35, Number 6556:

    Anas reported Allah's Messenger (may peace be upon him) as saying: When you go to bed, say: "Praise is due to Allab Who fed us, provided us drink, sufficed us and provided us with shelter, for many a people there is none to suffice and none to provide shelter."

Chapter 17 :REFUGE FROM THE EVIL OF WHAT ONE HAS DONE AND WHAT ONE HAS NOT DONE

Book 35, Number 6557:

    Farwa' b. Naufal Ashja'i reported: I asked: 'A'isha, in what words did Allah's Messenger (may peace be upon him) supplicate Allah? She said that he used to utter: "I seek refuge in Thee from the evil of what I did and from the evil of what I did not."

Book 35, Number 6558:

    Farwa' b. Naufal reported: I asked 'A'isha about the supplication that Allah's Messenger (may peace be upon him) made. She said that he used to say: "O Allah, I seek refuge in Thee from the evil of what I have done and from the evil of what I have not done."

Book 35, Number 6559:

    This hadith has been narrated on the authority of Muhammad b. ja'far through another chain of transmitters.

Book 35, Number 6560:

    Farwa' b. Naufal reported on the authority of 'A'isha that Allah's Mes- senger (may peace be upon him) used to supplicate (in these words): "O Allah, I seek refuge in Thee from the evil of what I did and from the evil of what I did not."

Book 35, Number 6561:

    Ibn 'Abbas reported that Allah's Messenger (may peace be upon him) used to say: "O Allah, it is unto Thee that I surrender myself. I affirm my faith in Thee and repose my trust in Thee and turn to Thee in repentance and with Thy help fought my adversaries. O Allah, I seek refuge in Thee with Thine Power; there is no god but Thou, lest Thou leadest me astray. Thou art ever-living that dieth not, while the Jinn and mankind die."

Book 35, Number 6562:

    Abu Huraira reported that when Allah's Messenger (may peace be upon him) set out on a journey in the morning, he used to say: " A listener listened to our praising Allah (for) His goodly trial of us. Our Lord ! acompany us, guard us and bestow upon us Thy grace. I am seeker of refuge in Allah from the Fire."

Book 35, Number 6563:

    Abu Musa Ash'ari reported on the authority of his father that Allahs Apostle (may peace be upon him) used to supplicate in these words: "O Allah, forgive me my faults, my ignorance, my immoderation in my concerns. And Thou art better aware (of my affairs) than myself. O Allah, grant me forgiveness (of the faults which I committed) seriously or otherwise (and which I committed inadvertently and de- liberately. All these (failings) are in me. O Allah, grant me forgiveness from the fault which I did in haste or deferred, which I committed in privacy or in public and Thou art better aware of (them) than myself. Thou art the First and the Last and over all things Thou art Omnipotent."

Book 35, Number 6564:

    This hadith has been narrated on the authority of Shu'ba with the same chain of transmitters.

Book 35, Number6565 :

    Abu Huraira reported that Allah's Messenger (may peace be upon him) used to supplicate (in these words) :"O Allah, set right for me my religion which is the safeguard of my affairs. And set right for me the affairs of my world wherein is my living. And set right for me my Hereafter on which depends my after-life. And make the life for me (a source) of abundance for every good and make my death a source of comfort for me protecting me against every evil."

Book 35, Number 6566:

    Abdullah reported that Allah's Messenger (may peace be upon him) used to supplicate (in these words) : "O Allah. I beg of Thee the right guidance, safeguard against evils, chastity and freedom from want."

Book 35, Number 6567:

    This hadith has been narrated on the authority of Abu Ishaq with the same chain of transmitters but with a slight variation of wording.

Book 35, Number 6568:

    Zaid b. Alqam reported: I am not going to say anything but only that which Allah's Messenger (may peace be upgn him) used to say. He used to supplicate: "O Allah, I seek refuge in Thee from incapacity, from sloth, from cowardice, from miserliness, decrepitude and from torment of the grave. O Allah, grant to my soul the sense of righteousness and purify it, for Thou art the Best Purifier thereof. Thou art the Protecting Friend thereof, and Guardian thereof. O Allah, I seek refuge in Thee from the knowledge which does not benefit, from the heart that does not entertain the fear (of Allah), from the soul that does not feel contented and the supplication that is not responded."

Book 35, Number 6569:

    Abdullah b. Mas'ud reported that when it was evening Allah's Messenger (may peace be upon him) used to supplicate: "We entered upon evening and the whole Kingdom of Allah also entered upon evening and praise is due to Allah. There is no god but Allah, the One Who has no partner with Him." Hasan said that Zubaid reported to him that he memorised it from Ibrahim in these very words. "His is the Sovereignty and Praise is due to Him, and He is Potent over everything. O Allah, I beg of Thee the good of this night and I seek refuge in Thee from the evil of this night and the evil which follows it. O Allah, I seek refuge in Thee from sloth, from the evil of vanity. O Allah, I seek refuge in Thee from torment in the Hell-Fire and from torment in the grave."

Book 35, Number 6570:

    Abdullah reported that when it was evening Allah's Messenger (may peace be upon him) used to supplicate: "We have entered upon evening and so, too, the whole Kingdom of Allah has entered upon evening. Praise is due to Allah. There is no god but Allah, the One having no partner with Him." He (the narrator) said : I think that he also uttered (in this supplication these words) :"His is tne Sovercignty and to Him is praise due and He is Potent over everything. My Lord, I beg of Thee good that lies in this night and good that follows it and I seek refuge in Thee from the evil that lies in this night and from the evil of that which follows it. My Lord, I seek refuge in Thee from sloth, from the evil of vanity. My Lord, I seek refuge in Thee from torment of the Hell-Fire and from torment of the grave." And when it was morning he said like this:"We entered upon morning and the whole Kingdom of Allah enter ed upon morning."

Book 35, Number 6571:

    Abdullah reported that when it was evening Allah's Messenger (may peace be upon him) used to supplicate: "We have entered upon evening and so has the Kingdom of Allah entere d upon evening ; praise is due to Allah, there is no god but Allah the One, and there is no partner with Him. O Allah, I beg of Thee the blessing of this night and the blessing of that which lies in it. I seek refuge in Thee from the evil of it and what lies in it. O Allah, I seek refuge in Thee from sloth, from decrepitude, from the evil of vanity, from trial of the world, and from torment of the grave." Zubaid, through another chain of transmitters, has narrated on the authority of Abdullah directly this addition : "There is no god but Allah, the One, there is no partner with Him, His is the Sovereignty and to Him is praise due and He is Potent over everything."

Book 35, Number 6572:

    This hadith has been transmitted on the authority of Abu Huraira that Allah's Messenge; (may peace be upon him) used to supplicate thus: "There is no god but Allah, the One Who conferred upon His armies the honour of victory and helped His servant rout the clans; there is nothing after that."

Book 35, Number 6573:

    'Ali reported that Allah's Messenger (may peace be upon him) said to him: Say, "O Allah, direct me to the right path and make me adhere to the straight path," and when you make a mention of right guidance, keep in mind the right path and when you consider of the straight (path), keep in mind the straightness of the arrow.

Book 35, Number 6574:

    This hadith has been narrated on the authority of 'Asim b. Kulaib with the same chain of transmitters that Allah's Messenger (may peace be upon him) said to me: Say: "O Allah, I beg of Thee righteousness and adhering to the straight path."

Chapter 18 : THE RECITING OF SUBHAN ALLAH IN THE MORNING AND AT THE TIME OF SLEEPING

Book 35, Number 6575:

    Juwairiya reported that Allah's Messenger (may peace be upon him) came out from (her apartment) in the morning as she was busy in observing her dawn prayer in her place of worship. He came back in the forenoon and she was still sitting there. He (the Holy Prophet) said to her: You have been in the same seat since I left you. She said: Yes. Thereupon Allah's Apostle (may peace be upon him) said: I recited four words three times after I left you and if these are to be weighed against what you have recited since morning these would outweigh them and (these words) are: "Hallowed be Allah and praise is due to Him according to the number of His creation and according to the pleasure of His Self and according to the weight of His Throne and according to the ink (used in recording) words (for His Praise)."

Book 35, Number 6576:

    Juwairiya reported that Allah's Messenger (may peace be upon him) happened to pass by her as she was observing her dawn prayer; or after she had observed her dawn prayer. The rest of the hadith is the same but with this variation that he said: "Hallowed be Allah according to the number of His creation, hallowed be Allah according to the pleasure of His Self, hallowed be Allah according to the weight of His Throne, hallowed be Allah according to the ink used in recording His words."

Book 35, Number 6577:

    It is reported on the authority of Ali that Fatima had corns in her hand because of working at the hand-mill. There had fallen to the lot of Allah's Apostle (may peace be upon him) some prisoners of war. She (Fatima) came to the Holy Prophet (may peace be upon him) but she did not find him (in the house). She met A'isha and informed her (about her hardship). When Allah's Apostle (may peace be upon him) came, she ( A'isha) informed him about the visit of Fatima. ABah's Messenger (may peace be upon him) came to them (Fitima and her family). They had gone to their beds. 'Ali further (reported) : We tried to stand up (as a mark of respect) but Allah's Messenger (may peace be upon him) said: Keep to your beds, and he sat amongst us and I felt coldness of his feet upon my chest. He then said: May I not direct you to something better than what you have asked for ? When you go to your bed, you should recite Takbir (Allah-o-Akbar) thirty-four times and Tasbih (Subhdn Allah) thirty-three times and Tahmid (al-Hamdu li-Allah) thirty-three times, and that is better than the servant for you.

Book 35, Number 6578:

    This hadith has been narrated on the authority of Shu'ba with the same chain of transmitters but. with a slight variation of wording.

Book 35, Number 6579:

    This hadith has been transmitted on the authority of Ibn Abi Laili but with this addition : "Ali said: Ever since I heard this (supplication) from Allah's Apostle (may peace be upon him), I never abandoned it. It was said to him, Not even in the night of Siffin (battle of Siffin) ? He sad: Yes, not even in the night of Siffin,"

Book 35, Number 6580:

    Abu Huraira reported that Fatima came to Allah's Apostle (may peace be upon him) and asked for a servant and told him of the hardship of household work. He said: You would not be able to get a servant from us. May I not direct you to what is better than the servant for you ? Recite Subhaana Allah thirty-three times, al- Hamdu li-Allah thirty-three times and Allah-o-Akbar thirty-four times as you go to bed. This hadith has been narrated on the authority of Suhail with the same chain of transmitters.

Chapter 19 : THE EXCELLENCE OF SUPPLICATING AT THE TIME OF THE CROWING OF THE COCK IN THE MORNING

Book 35, Number 6581:

    Abu Huraira reported Allah's Messenger (may peace be upon him) as say- ing. When you listen to the crowing of the cock, ask Allah for His favour as it sees Angels and when you listen to the braying of the donkey, seek refuge in Allah from the Satan for it sees Satan.

Chapter 20 :SUPPLICATION DURING THE TIME OF TROUBLE

Book 35, Number 6582:

    Ibn 'Abbas reported that Allah's Apostle (may peace be upon him) used to supplicate during the time of trouble (in these words): "There is no god but Allah, the Great, the Tolerant, there is no god but Allah, the Lord of the Magnificent Throne There is no god but Allah, the Lord of the Heaven and the earth, the Lord of the Edifying Throne."

Book 35, Number 6583:

    This hadith has been narrated on the authority of Hisham with the same chain of transmitters.

Book 35, Number 6584:

    Ibn Abbas reported that Allah's Messenger (may peace be upon him) used to supplicate (with these words) and he (uttered these words) at the time of trouble; the rest of the hadith is the same except with this difference that insted of saying: "The Lord of heaven and the earth," he said: "The Lord of the heaven and that of the earth."

Book 35, Number 6585:

    Ibn 'Abbas reported this hadith through another chain of transmitters with a sliglit variation of wording.

Chapter 21 :THE MERIT OF SUBHAN ALLAH WA BI HAMDIHI

Book 35, Number 6586:

    Abu Dharr reported that Allah's Messenger (may peace be upon him) was asked as to which words were the best. He said: Those for which Allah made a choice for His Angels and His servants (and the words are): "Hallowed be Allah and praise is due to Him."

Book 35, Number 6587:

    Abu Dharr reported that Allah's Messenger (may peace be upon him) said: Should I not inform you about the words liked most by Allah? I said: Allah's Mes- senger, do inform me about the words liked most by Allah. He said: Verily, the words liked most by Allah are: "hallowed be Allah and praise is due to Him."

Chapter 22 : EXCELLENCE OF SUPPLICATING FOR THE MUSLIMS BEHIND THEIR BACK (IN THEIR ABSENCE)

Book 35, Number 6588:

    Abu Dharr reported that Allah's Messenger (may peace be upon him) said: There is no believing servant who supplicates for his brother behind his back (in his absence) that the Angels do not say: The same be for you too.

Book 35, Number 6589:

    Umm Darda' reported: My husband reported that he heard Allah's Mes- senger (may peace be upon him) as saying: He who supplicates for his brother behind his back (in his absence), the Angel commissioned (for carrying supplication to his Lord) says: Amen, and it is for you also.

Book 35, Number 6590:

    Safwan (and he was Ibn 'Abdullah b. Safwan, and he had been married to Umm Darda') reported : I visited Abu Darda's house in Syria. I did not find him there but Umm Darda' (was present at the house). She said: Do you intend to perform Hajj during this year? I said: Yes. She said: Do supplicate Allah for blessings upon us, for Allah's Apostle (may peace be upon hiin) used to say: The supplication of a Muslim for his brother at his back (in his absence) is responded so long as he makes a supplica- tion for blessings for his brother and the commissioned Angel says: Amen, and says: May it be for you too I I went to the bazar and met Abfi Dardi' and he narrated like this from Allah's Messenger (may peace be upon him).

Book 35, Number 6591:

    This hadith has been narrated on the authority of Safwan b. 'Abdullah b. Safwan with the same chain of transmitters.

Chapter 23 : EXCELLENCE OF RECITING AL-HAMDU LI-ALLAH AFTER EATING AND DRINKING

Book 35, Number 6592:

    Anas b. Malik reported that Allah's Messenger (may peace be upon him) said: Allah is pleased with His servant who says: Al-Hamdu lillah While taking a morsel of food tnd while drinking.

Chapter 24 :SUPPLICATION IS GRANTED IF THE SUPPLICANT DOES NOT SHOW IMPATIENCE

Book 35, Number 6593:

    Abu Huraira reported that Allah's Messenger (may peace be upon him) said: The supplication of every one of you is granted if he does not grow impatient and says: I supplicated but it was not granted.

Book 35, Number 6594:

    Abu Huraira reported Allah's Messenger (may peace be upon him) as saying: The supplication of one of you is granted if he does not grow impatient and say- I supplicated my Lord but it was not granted.

Book 35, Number 6595:

    Abu Huraira reported Allah's Messenger (may peace be upon him) as saying: The supplication of the servant is granted in case he does not supplicate for sin or for severing the ties of blood, or he does not become impatient. It was said: Allah's Messenger, what does: "If he does not grow impatient" imply? He said: That he should say like this: I supplicated and I supplicated but I did not find it being responded. and theu he becomes frustrated and abandons supplication.


Book 36: The Book of Heart-Melting Traditions (KITAB AL-RIQAQ)

KITAB AL-RIQAQ
(THE BOOK OF HEART-MELTING TRADITIONS)

Back
Chapter 1 : THE MAJORITY IN PARADISE WOULD CONSIST OF THE POOR PIOUS PERSONS AND THE MAJORITY OF THE DENIZENS OF HELL WOULD CONSIST OF WOMEN, AND THE TRIAL BY MEANS OF WOMEN

Book 36, Number 6596:

    Usama b. Zaid reported that Allah's Messenger (way peace be upon him) said: I stood at the door of Paradise and I found that the overwhelming majority of those who entered therein was that of poor persons and the wealthy persons were detained to get into that. The denizens of Hell were commanded to get into Hell, and I stood upon the door of Fire and the majority amongst them who entered there was that of women.

Book 36, Number 6597:

    Ibn Abbas reported that Allah's Messenger (may peace be upon him) said: I had a chance to look into the Paradise and I found that majority of the people was poor and I looked into the Fire and there I found the majority constituted by women.

Book 36, Number 6598:

    This hadith has been narrated on the authority of Ibn 'Abbas through another chain of transmitters.

Book 36, Number 6599:

    Ibn 'Abbas reported that Allah's Messenger (may peace be upon him) stated like this: Re looked into the Fire of Hell. The rest of the hadith is the same.

Book 36, Number 6600:

    Imran b. Husain reported that Allah's Messenger (may peace be upon him) said: Amongst the inmates of Paradise the women would form a minority.

Book 36, Number 6601:

    This hadith has been narrated on the authority of Mutarrif through another chain of transmitters.

Book 36, Number 6602:

    'Abdullah b. Umar reported that Allah's Messenger (may peace be upon him) supplicated in these words: "O Allah, I seek refuge in Thee from the withdrawal of Thine blessing and the change of Thine protection (from me) and from the sudden wrath of Thine, and from every displeasure of Thine."

Book 36, Number 6603:

    Usama b. Zaid reported Allah's Messenger (may peace be upon him) as saying: I have not left after me any (chance) of turmoil more injurious to men than the harm done to the men because of women.

Book 36, Number 6604:

    Usama b. Zaid b. Harith and Sa'id b. Zaid b. 'Amr b. Naufal both reported Allah's Messenger (may peace be upon him) as saying: I have not left after me turmoil for the people but the harm done to men by women.

Book 36, Number 6605:

    This hadith has been narrated on the authority of Sulaiman Taimi with the same chain of transmitters.

Book 36, Number 6606:

    Abu Sa'id Khudri reported that Allah's Messenger (may peace be upon him) said: The world is sweet and green (alluring) and verily Allah is going to install you as vicegerent in it in order to see how you act. So avoid the allurement of women: verily, the first trial for the people of Isri'll was caused by women. And in the hadith transmitted on the authority of Ibn Bashshar the words are : "So that He should see how you act."

Chapter 2 : THE STORY OF THE THREE PERSONS OF THE CAVE AND THEIR MAKING GOOD DEEDS OF THEIRS AS THE MEANS OF RIDDANCE

Book 36, Number 6607:

    'Abdullah b. 'Umar reported that Allah's Messenger (may peace be upon him) said: Three persons set out on a journey. They were overtaken by rain and they had to find protection in a mountain cave where at its mouth there fell a rock of that mountain and thus blocked them altogether. One of them said to the others: Look to your good deeds that you performed for the sake of Allah and then supplicate Allah, the Exalted, that He might rescue you (from this trouble). One of them said: 0 Allah, I had my parents who were old and my wife and my small children also. I tended the flock and when I came back to them in the evening, I milked them (the sheep, goats, cows, etc.) and first served that milk to my parents. One day I was obliged to go out to a distant place in search of fodder and I could not come back before evening and found them (the parents) asleep. I milked the animals as I used to milk and brought milk to them and stood by their heads avoiding to disturb them from sleep and I did not deem it advisable to serve milk to my children before serving them. My children wept near my feet. I remained there in that very state and my parents too until it was morning. And (0 Allah) if Thou art aware that I did this in order to seek Thine pleasure, grant us riddance from this trouble. (The rock slipped a bit) that they could see the sky. The second one said: 0 Allah, I had a female cousin whom I loved more than the men love the women. I wanted to have sexual intercourse with her; she refused but on the condition of getting one hundred dinirs. It was with very great difficulty that I could collect one hundred dinirs and then paid them to her and when I was going to have a sexual intercourse with her, that she said: Servant of Allah, fear Allah and do not break the seal (of chastity) but by lawful means. I got up. 0 Allah, if Thou art aware that I did this in order to seek Thine pleasure, rid us from this trouble. The situation was somewhat eased for them. The third one said : Allah, I employed a workman for a measure of rice. After he had finished his work I gave him his dues (in the form of) a measure of rice, but he did not accept them. I used these rice as seeds ,and that gave a bumper crop and I became rich enough to have cows and flocks (in my possession). He came to me and said: Fear Allah, and commit no crueltv upon me in regard to my dues. I said to him : Takeaway this flock of cows and sheep. He said: Fear Allah and do not make a fun of me. I said: I am not making a fun of you. You take the cows and the flocks. So he took them. 0 Allah, if Thou art aware that I did it for Thine pleasure, case the situation for us. And Allah relieved them from the rest of the trouble.

Book 36, Number 6608:

    This hadith has been transmitted on the authority of Musa b. 'Uqba but with a slight variation of wording.

Book 36, Number 6609:

    Abdullah b 'Umar reported: I heard Allah's Alessenger (may peace be upon him) as saying: Three persons belonging to the earlier Ummahs set out on a journey until they had to spend a night in a cave. The rest of the hadith is the same and the additional words are: "A person amongst them said: 0 Allah, I had my aged parents and I served them milk before I (served that) to my wife, children and my servants." And in case of the second one, the words are: "She avoided me until she was hard pressed because of famine and she came to me and I gave her one hundred and twenty diiiirs " And in cease of the third one (the words are) : "I invested his wages, and it brought profit and, as a result thereof, the merchandise increased and there was abundance of goods." And he (the narrator said) that they got out of the cave and began to walk.


Book 37: The Book Pertaining to repentance and Exhortation to repentance (KITAB AL-TAUBA)

KITAB AL-TAUBA
(BOOK PERTAINING TO REPENTANCE AND EXHORTATION TO REPENTANCE)

Back
Chapter 1 : EXHORTATION FOR REPENTANCE

Book 37, Number 6610:

    Abu Huraira reported Allah's Messenger (may peace be upon him) as saying : Allah, the Exalted and Glorious, said: I live in the thought of My servant and I am with him as he remembers Me. (The Holy Prophet) further said: By Allah, Allah is more pleased wth the repentance of His servant than what one of you would do on finding the lost camel in the waterless desert. When he draws near Me by the span of his hand. I draw near him by the length of a cubit and when he draws near Me by the length of a cubit. I draw near him by the length of a fathom and when he draws near Me walking I draw close to him hurriedly.

Book 37, Number 6611:

    Abu Huraira reported Allah's Messenger (may peace be upon him) as saying: Allah is more pleased with the repentance of His servant when he turns penitently towards Him than one of you would be on finding the lost camel.

Book 37, Number 6612:

    This hadith has been narrated on the authority of Abu Huraira through another chain of transmitters.

Book 37, Number 6613:

    Harith b. Suwaid said: I went to see 'Abdullah to inquire about his health as he was sick and he narrated to us a hadith of Allahs Messenger (may peace be upon him). He heard Allah's Messenger (may peace be upon him) as saying: Allah is more pleased with the repentance of His believing servant than a person who loses his riding beast carrying food and drink. He sleeps (being disappointed of its recovery) and then gets up and goes in search for that, until he is stricken with thirst. then comes back to the place where he had been before and goes to sleep completely exhausted placing his head upon his hands waiting for death. And when he gets up, lot there is before him his riding beast and his provisions of food and drink. Allah is more pleased with the repentance of His servant than the recovery of this riding beast along with the provisions (of food and drink).

Book 37, Number 6614:

    This hadith has been narrated on the authority of A'mash through another chain of transmitters.

Book 37, Number 6615:

    'Abdullah reported Allah's Messenger (may peace be upon him) as saying: Allah is more pleased with the repentance of a believing man. The rest of the hadith is the same.

Book 37, Number 6616:

    Nu'man b. Bashir reported: Allah is more pleased with the repentance of a believing servant than of a person who set out on a journey with a provision of food and drink on the back of his camel. He went on until he came to a waterless desert and he felt like sleeping. So he got down under the shade of a tree and was overcome by sleep and his camel ran away. As he got up he tried to see (the camel) standing upon a mound. but did not find it. He then got upon the other mound, but could not see anything. He then climbed upon the third mound but did not see anything until he came back to the place where he had been previously. And as he was sitting (in utter disappointment) there came to him the camel, till that (camel) placed its nosestring in his hand. Allah is more pleased with the repentance of His servant than the person who found (his lost camel) in this very state. Simak reported that Sha'bi was of the opinion that Nu'min traced it to Allah's Apostle (may peace be upon him). Simak, however, did not hear that himself.

Book 37, Number 6617:

    Al-Bara' b. 'Azib reported Allah's Messenger (may peace be upon him) as saying that Allah's Messenger (may peace be upon him) said: What is your opinion about the delight of a person whose camel loaded with the provisions of food and drink is lost and that moves about with its nosestring trailing upon the waterless desert in which there is neither food nor drink, and lie wanders about in search of that until he is completely exhausted and then accidentally it happens to pass by the trunk of a tree and its nosestring gets entangled in that and he finds it entangled therein? He (in response to the question of the Holy Prophet) said: Allah's Messenger, he would feel highly delighted. Thereupon Allah's Messenger (may peace be upon him) said. By Allah, Allah is more delighted at the repentance of His servant than that person (as he finds his lost) camel.

Book 37, Number 6618:

    Anas b. Malik reported that Allah's Messenger (may peace be upon him) said: Allah is more pleased with the repentance of a servant as he turns towards Him for repentance than this that one amongst you is upon the camel in a waterless desert and there is upon (that camel) his provision of food and drink also and it is lost by him, and he having lost all hope (to get tbat) lies down in the shadow and is disappointed about his camel and there he finds that camel standing before him. He takes hold of his nosestring and then out of boundless joy says: 0 Lord, Thou art my servant and I am Thine Lord. He commits this mistake out of extreme delight.

Book 37, Number 6619:

    Anas b. Malik reported that Allah's Messenger (may peace be upon him) said: Allah is more pleased with the repentance of His servant than if one of you gets up and he finds his camel missing in a waterless desert (and then he accidentally finds it). This hadith has been narrated on the authority of Anas b. Malik through another chain of transmitters.

Chapter 2 : THE OBLITERATION OF SINS WITH THE HELP OF SEEKING FORGIVENESS PROM ALLAH

Book 37, Number 6620:

    Abu Sirma reported that when the time of the death of Abu Ayyub Ansari drew near, he said: I used to conceal from you a thing which I heard from Allah's Messenger (may peace be upon him) and I heard Allah's Messenger (may peace be upon him) as sayirig: Had you not committed sins, Allah would have brought into existence a creation that would have committed sin (and Allah) would have forgiven them.

Book 37, Number 6621:

    Abu Ayyub Ansari reported that Allah's Messenger (may peace be upon him) said: If you were not to commit sins, Allah would have swept you out of existence and would have replaced you by another people who have committed sin, and then asked forgiveness from Allah, and He would have granted them pardon.

Book 37, Number 6622:

    Abu Huraira reported Allah's Messenger (may peace be upon him) having said: By Him in Whose Hand is my life, if you were not to commit sin, Allah would sweep you out of existence and He would replace (you by) those people who would commit sin and seek forgiveness from Allah, and He would have pardoned them.

Chapter 3 : THE EXCELLENCE OF CONSTANT REMEMBRANCE OF ALLAH AND MEDITATION IN THE AFFAIRS OF THE HEREAFTER AND PERMISSION OF ABANDONING IT AT TIMES AND ATTENDING TO THE AFFAIRS OF THE WORLD

Book 37, Number 6623:

    Hanzala Usayyidi, who was amongst the scribes of Allah's Messenger (may peace be upon him). reported: I met Abu Bakr. He said: Who are you? He (Hanzala) said: Hanzala has turned to be a hypocrite. He (Abu Bakr) said: Hallowed be Allah, what are you saying? Thereupon he said: I say that when we are in the company of Allah's Messenger (may peace be upon him) we ponder over Hell-Fire and Paradise as if we are seeing them with our very eyes and when we are away from Allah's Messenger (may peace be upon him) we attend to our wives, our children, our business; most of these things (pertaining to After-life) slip out of our minds. Abu Bakr said: By Allah, I also experience the same. So I and Abu Bakr went to Allah's Messenger (may peace be upon him) and said to him : Allah's Messenger, Hanzala has turned to be a hypocrite. Thereupon Allah's Messenger (may peace be upon him) said: What has happened to you? I said: Allah's Messenger, when we are in your company, we are reminded of Hell-Fire and Paradise as if we are seeing them with our own eyes, but whenever we go away from you and attend to our wives, children and business, much of these things go out of our minds. Thereupon Allah's Messenger (may peace be upon him) said: By Him in Whose Hand is my life, if your state of mind remains the same as it is in my presence and you are always busy in remembrance (of Allah), the Angels will shake hands with you in your beds and in your paths but, Hanzala, time should be devoted (to the worldly affairs) and time (should be devoted to prayer and meditation). He (the Holy Prophet) said this thrice.

Book 37, Number 6624:

    Hanzala reported: We were in the company of Allah's Messenger (may peace be upon him) and he delivered to us a sermon and made a mention of Hell-Fire. Then I came to my house and began to laugh with my children and sport with my wife. (Hanzala) further reported: I went out and met Abu Bakr and made a mention of that to him. Thereupon he said: I have done the same as you have mentioned. So we went to see Allah's Messenger (way peace be upon him) and said to him: Allah's Messenger, Hanzala has turned to he a hypocrite. And he (the Holy Prophet) said Show respite. And then I narrated to him the story, and Abu Bakr said: I have done the same as he has done. Thereupon he (the Holy Prophet) said: Hanzala, there is a time for worldly affairs and a time for (worship and devotion), and if your state of mind is always the same as it is at the time of remembrance of Allah, the Angels would shake hands with you and would greet you on the path by saying: As-Salamu-Alaikum.

Book 37, Number 6625:

    Hanzala Taimi Ufayyidi, the scribe of Allah's Messenger (may peace be upon him), reported: We were in the presence of Allah's Messenger (may peace be upon him) and he brought to our minds the problems pertaining to Paradise and Hell-Fire. The rest of the hadith is the same.

Chapter 4 : THE MERCY OF ALLAH PREDOMINATES HIS WRATH

Book 37, Number 6626:

    Abu Huraira reported that Allah's Messenger (may peace be upon him) said: When Allah created the creation as He was upon the Throne, He put down in His Book: Verily, My mercy predominates My wrath.

Book 37, Number 6627:

    Abu Huraira reported Allah's Messenger (may peace be upon him) as saying: Allah, the Exalted and Glorious, said: My mercy excels My wrath.

Book 37, Number 6628:

    Abu Huraira reported Allah's Messenger (may peace be upon him) as saying : When Allah created the creation, He ordained for Himself and this document is with Him: Verily, My mercy predominates Mv wrath.

Book 37, Number 6629:

    Abu Huraira reported: I heard Allah's Messenger (may peace be upon him) as saying: Allah created mercy in one hundred parts and He retained with Him ninety-nine parts, and He has sent down upon the earth one part, and it is because of this one part that there is mutual love among the creation so much so that the animal lifts up its hoof from its younc, one, fearing that it might harm it.

Book 37, Number 6630:

    Abu Huraira reported Allah's Messenger (may peace be upon him) as saying: Allah created one hundred (parts of mercy) and He distributed one amongst His creation and kept this one hundred excepting one with Himself (for the Day of Resurrection).

Book 37, Number 6631:

    Abu Huraira reported Allah's Messenger (may peace be upon him) as saying : There are one hundred (parts of) mercy for Allah and He has sent down out of these one part of mercy upon the jinn and human beings and the insects and it is because of this (one part) that they love one another, show kindness to one another and even the beast treats its young one with affection, and Allah has reserved ninetynine parts of mercy with which He would treat His servants on the Day of Resurrection.

Book 37, Number 6632:

    Salman Farisi reported Allah's Messenger (may peace be upon him) as saying: Verily, there are one hundred (parts of) mercy for Allah, and it is one part of this mercy by virtue of which there is mutual love between the people and ninety-nine reserved for the Day of Resurrection.

Book 37, Number 6633:

    This hadith has been transmitted on the authority of Mu'tamir, reported on the authority of his father.

Book 37, Number 6634:

    Salman reported that Allah's Messenger (may peace be upon him) said: Verily, Allah created, on the same very day when He created the heavens and the earth, one hundred parts of mercy. Every part of mercy is coextensive with the space between the heavens. and the earth and He out of this mercy endowed one part to the earth and it is because of this that the mother shows affection to her child and even the beasts and birds show kindness to one another and when there would be the Day of Resurrection, Allah would make full (use of Mercy).

Book 37, Number 6635:

    'Umar b. Khattab reported that there were brought some prisoners to Allah's Messenger (may peace be upon him) amongst whom there was also a woman, who was searching (for someone) and when she found a child amongst the prisoners, she took hold of it, pressed it against her chest and provided it suck. Thereupon Allah's Messenger (may peace be upon him) said: Do you think this woman would ever afford to throw her child in the Fire ? We said: By Allah, so far as it lies in her power, she would never throw the child in Fire.' Thereupon Allah's Messenger (may peace be upon him) said: Allah is more kind to His servants than this woman is to her child.

Book 37, Number 6636:

    'Ala' reported on the authority of his father who reported on the authority of Abu Huraira that Allah's Messenger (may peace be upon him) said: If a believer were to know the punishment (in Hell) none would have the audacity to aspire for Paradise (but he would earnestly desire to be rescued from Hell), and if a non-believer were to know what is there with Allah as a mercy. none would have been disappointed in regard to Paradise.

Book 37, Number 6637:

    Abu Huraira reported Allah's Messenger (may peace be upon him) as saying that a person who had never done any good deed asked the members of his family to burn his dead body when he would die and to scatter half of its ashes over the land and half in the ocean. By Allah, if Allah finds him in His grip, He would torment him with a torment with which He did not afflict anyone amongst the people of the world; and when the person died, it was done to him as he had commanded (his family) to do. Allah commanded the land to collect (the ashes scattered on it) and He commanded the ocean and that collected (ashes) contained in it. Allah questioned him why he had done. that He said: My Lord, it is out of Thine fear that I have done it and Thou art well aware of it, and Allah granted him pardon:.

Book 37, Number 6638:

    Abu Huraira reported Allah's Messenger (may peace be upon him) as saying that a person committed sin beyond measure and when he was going to die, he left this will: (When I die), bum my dead body and then cast them (the ashes) to the wind and in the ocean. By Allah, if my Lord takes hold of me, He would torment me as He has not tormented anyone else. They did as he had asked them to do. He (the Lord) said to the earth: Return what you have taken. And he was thus restored to his (original form). He (Allah) said to him: What prompted you to do this? He said: My Lord, it was Thine fear or Thine awe, and Allah pardoned him because of this. Abu Huraira reported Allah's Messenger (may peace be upon him) as saying that a woman was thrown into Hell-Fire because of a cat whom she had tied and did not provide it with food. nor did she set it free to cat insects of the euth until it died inch by inch. Zuhri said: (These two ahidith) show that a person rhould neither feel confident (of getting into Paradise) because of his deeds, nor should he lose (all hopes) of getting into Paradise.

Book 37, Number 6639:

    Abu Huraira reported Allah's Messenger (may peace be upon him) as saying that a servant transgressed the litnit in committing sins. The rest of the hadith is the same but there is no mention of the story of the cat in it and in the hadith transmitted on the authority of Ziibaidl (the words are): "Allah, the Exalted and Glorious, said to everything which had taken a part of lies ashes to return what it had taken."

Book 37, Number 6640:

    Abu Sa'id Khudri reported that Allah's Messenger (may peace be upon him) said that a person amongst the earlier nations before you was conferred property and children by Allah, He said to his children: 'You must do as I command you to do, otherwise I will make others besides you as my inheritors. As I die, burn my body and blow my ashes in the wind as I do not find any merit of mine which would please Allah, and if Allah were to take hold of me, He would punish me. He took a pledge from them and they did as he commanded thein to do. Allah said: What prompted you to do this? He said: My Lord. Thine fear, and Allah did not punish him at all.

Book 37, Number 6641:

    This hadith has been narrated on the authority of Shu'ba with the chain of transmitters but with a slight variation of wording and Qatada explained the word "lam yasiru" as: "I find no good in store for rxie in the eye of Allah."

Chapter 5 : REPENTANCE IS ACCEPTED S0 LONG AS ONE REPENTS AFTER COMMITTING SINS

Book 37, Number 6642:

    Abu Huraira reported from Allah's Messenger (may peace be upon him) that his Lord, the Exalted and Glorious, thus said. A servant committed a sin and he said : O Allah,forgive me my sins, and Allah (the Exalted and Glorious)said :My servant commited a sin and then he came to realise that he has a Lord Who forgives the sins and takes to account (the sinner) for the sin. He then again committed a sin and said: My Lord, forgive me my sin, and Allah, the Exalted and High, said: My servant committed a sin and then came to realise that he has a Lord Who would forgive his sin or would take (him) to account for the sin. He again committed a sin and said: My Lord, forgive me for my sin, and Allah (the Exalted and High) said: My servant sas committed a sin and then came to realise that he has a Lord Who forgives the sins or takes (him) to account for sin. 0 servant, do what you like. I have granted you forgiveness.
    'Abd al-A'la said: I do not know whether he said thrice or four times to do "what you desire". The hadlth has been narrated on the authority of 'Abd al-A'la b. Hammad with the same chain of transmitters.

Book 37, Number 6643:

    Abu Huraira reported lie heard Allah's Messenger (may peace be upon him) as saying that a servant committed a sin. The rest of the hadith is the same, but there is a slight variation of wording.

Book 37, Number 6644:

    Abu Mu'sa reported Allah's Messenger (may peace be upon him) as saying that Allah, the Exalted and Glorious, Stretches out His Hand during the night so that the people repent for the fault committed from dawn till dusk and He stretches out His Hand daring the day so that the people may reprint for the fault committed from dusk to dawn. (He would accept repentance) before the sun rises in the west (before the Day of Resurrection). A hadith like this has been narrated on the authority of Shu'ba with the same chain of transmitters.

Chapter 6 : ALLAH'S SENSE OF HONOUR, AND HIS PROHIBITION OF THE ABOMINABLE ACTS

Book 37, Number 6645:

    'Abdullah reported Allah's Messenger (may peace be upon him) as saying: Nothing is more loveable to Allah than His praise as He has praised Himself and no one is more self-respecting than Allah Himself and it As because of this that He has prohibited abominable acts.

Book 37, Number 6646:

    'Abdullah reported Allah's Messenger (may peace be upon him) as saying: None is more self-respectidg than Allah and it is because of this that He has prohibited abominable acts-both visible and invisible-and none loves His praise more than Allah Himself.

Book 37, Number 6647:

    'Abdullah b. Mas'ud reported it directly from Allah's Messenger (may peace be upon him) that he said: None is more self-respecting than Allah and it is because of this that He has prohibited abominable acts-both visible and invisible and nothing is loved by Allah more than the praise of His Ownself and it is because of this that He has praised Himself.

Book 37, Number 6648:

    Abdullah b. Mas'ud reported that Allah's Messenger (may peace be upon him) said : None loves one's own praise more than Allah, the Exalted and Glurious, does. It is because of this that He has praised Himself, and none is more self-respecting than Allah and it is because of this that He has prohibited abominable acts and there is none who is more anxious to accept the apologies of the people than Allah Himself and it is because of this that He has revealed the Book and sent the Messengers.

Book 37, Number 6649:

    Abu Huraira reported Allah's Messenger (may peace be upon him) as saying : Allah is self-respecting and a believer is also self-respecting and the respect of Allah is injured if a believer does what He has forbidden him to do.

Book 37, Number 6650:

    This hadith has been narrated on the authority of Asma' daughter of Abu Bakr, through another chain of transmitters.

Book 37, Number 6651:

    Abu Salama reported from Abu Huraira that he narrated that Allah's Messenger (may peace be upon hin) said: There is none more self-respecting than Allah, the Exalted and Glorious There is no mention of the narration of Asma'.

Book 37, Number 6652:

    Asma' reported that Allah's Apostle (may peace be upon him) said : There is none more self-respecting than Allah, the Exalted and Glorious.

Book 37, Number 6653:

    Abu Huraira reported Allah's Messenger(may peace be upon him )as saying: A believer is self-respecting and Allah is extremely self-respecting.

Book 37, Number 6654:

    This hadith has been narrated on the authority of Shu'ba through another chain of transmitters.

Chapter 7 : THE WORDS OF ALLAH "THE GOOD DEEDS TAKE AWAY THE EVIL DEEDS"

Book 37, Number 6655:

    'Abdullah b. Mas'ud reported that a person kissed a woman and he came to Allah's Apostle (may peace be upon him) and made a mention of that to him. It was (on this occasion) that this verse was revealed: "And observe prayer at the (two) ends of the day and in the first hours of the night. Surely, good deeds take away evil deeds. That is a reminder for the mindful" (xi. 115). That person said: Allah's Messenger, does it concern me only ? He (the Holy Prophet) said: It concerns every one of my Unimah, who acts according to it.

Book 37, Number 6656:

    Ibn Mas'ud reported that a person came to Allah's Messenger (may peace be upon him) and told him that he had kissed a woman or touched her with his hand or did something like this. He inquired of him about its expiation. It was (on this occasion) that Allah, the Exalted and Glorious, revealed this verse (as mentioned above).

Book 37, Number 6657:

    This hadith has been narrated on the authority of Sulaiman Taimi with the same chain of transmitters that a person had taken liberty with a woman less than fomication. He came to 'Umar b. Khattab and he took it to be a serious offence. Then he came to Abu Bakr and he also took it to be a serious offence. Then he came the Allahs Apostle (may peace be upon him) and he made a mention of this to him. The rest of the hadith is the same.

Book 37, Number 6658:

    'Abdullah reported that a person came to Allah's Apostle (may peace be upon him) and said: Allah's Messenger, I sported with a woman in the outskirts of Medina, and I have committed an offence short of fornication. Here I am (before you), kindly deliver verdict about me which you deem fit. Unar said : Allah concealed your fault. You had better conceal it yourself also. Allah's Apostle (may peace be upon him), however, gave no reply to him. The man stood up and went away and Allah's Apostle (may peace be upon him) sent a person after him to call him and be recited this verse: "And observe prayer at the ends of the day and in the first hours of the night. Surely, good deeds take away evil deeds. That is a reminder for the mindful" (xi. l15). A person amongst the people said: Allah's Apostle, does it concern this marn only? Thereupon he (the Holy Prophet) said: No, but the people at large.

Book 37, Number 6659:

    This hadith has been transmitted by Abu al-Ahwas and in this (these words are) also found: Mu'adh said: Allah's Messenger, does it concern this particular case or to all of us? And he (the Holy Prophet) said: Of course, to all of you.

Book 37, Number 6660:

    Anas reported that a person came to Allah's Apostle (may peace be upon him) said: Allah's Messenger, I have committed an offence which deserves imposition of haad, so impose it upon me according to the Book of Allah. Thereupon he said: Were you not present with us at the time of prayer? He said: Yes.Thereupon he said: You have been granted pardon.

Book 37, Number 6661:

    Abu Umama reported: We were sitting in the mosque in the company of Allah's Messenger (may peace be upon him). A person came there and said: Allah's Messenger, I have committed an offence which deserves the imposition of hadd upon me, so impose it upon me. Allah's Messenger (may peace be upon him) kept silent. He repeated it and said: Allah's Messenger, I have committed an offence which deserves the imposition of hadd upon me, so impose it upon me. He (the Holy Prophet) kept silent, and it was at this time that Iqama was pronounced for prayer (and the prayer was observed). And when Allah's Apostle (may peace be upon him) had concluded the payer that person followed Allah's Messenger (may peace be upon him). Abu Umama said: I too followed Allah's Messenger (may peace be upon him) after he had concluded the prayer, so that I should know what answer he would give to that person. That person remained attached to Allah's Messenger (may peace be upon him) and said: Allah's Messenger, I have committed an offence which deserves imposition of hadd upon me, so impose it upon me. Abu Umama reported that Allah's Messenger (may peace be upon him) said to him: Didn't you see that as you got out of the house, you performed ablution perfectly well. He said: Allah's Messenger, of course. I did it. He again said to him: Then you observed prayer along with us. He said: Allah's Messenger, yes, it is so. Thereupon Allah's Messenger (may peace be upon him) said to him: Verily, Allah has exempted you from the imposition of hadd, or he said. From your sin.

Book 37, Number 6662:

    Abu Sa'id al-Khudri reported Allah's Messenger (may peace be upon him) as saying: There was a person before you who had killed ninety-nine persons and then made an inquiry about the learned persons of the world (who could show him the way to salvation). He was directed to a monk. He came to him and told him that he had killed ninety-nine persons and asked him whether there was any scope for his repentance to be accepted. He said: No. He killed him also and thus completed one hundred. He then asked about the learned persons of the earth and he was directed to a scholar, and he told him that he had killed one hundred persons and asked him whether there was any scope for his repentance to be accepted. He said: Yes; what stands between you and the repentance? You better go to such and such land; there are people devoted to prayer and worship and you also worship along with them and do not come to the land of yours since it was an evil land (for you). So he went away and he had hardly covered half the distance when death came to him and there was a dispute between the angels of mercy and the angels of punishment. The angels of mercy said: This man has come as a penitant and remorseful to Allah and the angels of punishment said: He has done no good at all. Then there came another angel in the form of a human being in order to decide between them. He said: You measure the land to which he has drawn near. They measured it and found him nearer to the land where he intended to go (the land of piety), and so the angels of mercy took possession of it. Qatada said that Hasan told him that it was said to them that as death approached him, he crawled upon his chest (and managed) to slip in the land of mercy.

Book 37, Number 6663:

    Abu Sa'id al-Khudri reported Allah's Messenger (may peace be upon him) as saying that a man killed ninety-nine persons and then he began to make an inquiry whether there was any way left for him for repentance. He came to a monk and asked him about that, and he said: There is no chance for repentance for you. He killed the monk also and then began to make an inquiry and moved from one village to another village where there lived pious persons, and as he had covered some distance, he was overtaken by death, but he managed to crawl upon his chest (to the side nearer to the place where the pious men lived). He died and then there was a dispute between the angels of mercy and the angels of punishment and (when it was measured) he was found to be nearer to the village where pious persons were living equal to the Space of a span and he was thus included among them.

Book 37, Number 6664:

    This hadith has been narrated on the authority of Qatida with the same chain of transmitters but (with this variation of wording): "Allah commanded the earth (from where) he wanted to come out to move itself away and to the other earth (where he wanted to go) to draw nearer."

Chapter 8 : THROWING OF NON-BELIEVERS IN HELL-FIRE FOR BELIEVERS AS DIVINE GRACE AND MERCY

Book 37, Number 6665:

    Abu Musa' reported that Allah's Messenger (may peace be upon him) said: When it will be the Day of Resurrection Allah would deliver to every Muslim a Jew or a Christian and say: That is your rescue from Hell-Fire.

Book 37, Number 6666:

    Abu Burda reported on the authority of his father that Allah's Apostle (may peace be upon him) said: No Muslim would die but Allah would admit in his stead a Jew or a Christian in Hell-Fire. 'Umar b. Abd al-'Aziz took an oath: By One besides Whom there is no god but He, thrice that his father had narrated that to him from Allah's Messenger (may peace be upon him).

Book 37, Number 6667:

    This hadith has been transmitted on the authority of 'Aun b. Utba.

Book 37, Number 6668:

    Abu Burda reported Allah's Messenger (may peace be upon him) as saying: There would come people amongst the Muslims on the Day of Resurrection with as heavy sins as a mountain, and Allah would forgive them and He would place in their stead the Jews and the Christians. (As far as I think), Abu Raub said: I do not know as to who is in doubt. Abu Burda said: I narrated it to 'Umar b. 'Abd al-'Aziz, whereupon he said : Was it your father who narrated it to you from Allah's Apostle (may peace be upon him) ? I said: Yes.

Book 37, Number 6669:

    Safwan b. Muhriz reported that a person said to Ibn 'Umar: How did you hear Allah's Messenger (may peace be upon him) as saying something about intimate conversation ? He said: I heard him say: A believer will be brought to his Lord, the Exalted and Glorious, on the Day of Resurrection and He would place upon him His veil (of Light) and make him confess his faults and say: Do you recognise (your faults) ? He would say: My Lord, I do recognise (them). He (the Lord) would say: I concealed them for you in the world. And today I forgive them. And he would then be given the Book containing (the account of his) good deeds. And so far as the non-believers and hypocrites are concerned, there would be general announcement about them before all creation telling them that these (people, i.e. non-believers and hypocrites) told a lie about Allah.

Chapter 9 : PERTAINING TO THE REPENTANCE OF KA'B B. MALIK AND HIS COMPANIONS

Book 37, Number 6670:

    Ibn Shihab reported that Allah's Messenger (may peace be upon him) made an expedition to Tabuk and he (the Holy Prophet) had in his mind (the idea of threatening the) Christians of Arabia in Syria and those of Rome. Ibn Shihab (further) reported that 'Abd al-Rahman b. 'Abdullah b. Ka'b informed him that Abdullah b. Ka'b who served as the guide of Ka'b b.'Malik as he became blind that he heard Ka'b b. Malik narrate the story of his remaining behind Allah's Messenger (may peace be upon him) from the Battle of Tabuk. Ka'b b. Malik said: I never remained behind Allah's Messenger (may peace be upon him) from any expedition which he undertook except the Battle of Tabuk and that of the Battle of Badr. So far as the Battle of Badr is concerned, nobody was blamed for remaining behind as Allah's Messenger (may peace be upon him) and the Muslims (did not set out for attack but for waylaying) the caravan of the Quraish, but it was Allah Who made them confront their enemies without their intention (to do so). I had the honour to be with Allah's Messenger (may peace be upon him) on the night of 'Aqaba when we pledged our allegiance to Islam and it was more dear to me than my participation in the Battle of Badr, although Badr was more popular amongst people as compared with that (Tabuk). And this is my story of remaining back from Allah's Messenger (may peace be upon him) on the occasion of the Battle of Tabuk. Never did I possess means enough and (my circumstances) more favourable than at the occasion of this expedition. And, by Allah, I had never before this expedition simultaneously in my possession two rides. Allah's Messenger (may peace be upon him) set out for this expedition in extremely hot season; the journey was long and the land (which he and his army had to cover) was waterless and he had to confront a large army, so he informed the Muslims about the actual situation (they had to face), so that they should adequately equip themselves for this expedition, and he also told them the destination where he intended to go. And the Muslims who accompanied Allah's Messenger (may peace be upon him) at that time were large in numbers but there was no proper record of them. Ka'b (further) said : Few were the persons who wanted to absent themselves, and were under the impression that they could easily conceal themselves (and thus remain undetected) until revelations from Allah, the Exalted and Glorious (descended in connection with them). And Allah's Messenger (may peace be upon him) set out on an expedition when the fruits were ripe and their shadows had been lengthened. I had weakness for them and it was during this season that Allah's Messenger (may peace be upon him) made preparations and the Muslims too along with them. I also set out in the morning so that I should make preparations along with them but I came back and did nothing and said to myself : I have means enough (to make preparations) as soon as I like. And I went on doing this (postponing my preparations) until people were about to depart and it was in the morning that Allah's Messenger (may peace be upon him) set out and the Muslims too along with him, but I made no preparations. I went early in the morning and came back, but I made no decision. I continued to do so until they (the Muslims) hastened and covered a good deal of distance. I also made up my mind to march on and to meet them. Would that I had done that but perhaps it was not destined for me. After the departure of Allah's Messenger (may peace be upon him) as I went out amongst people, I was shocked to find that I did not find anyone like me but people who were labelled as hypocrites or the people whom Allah granted exemption because of their incapacity and Allah's Messenger (may peace be upon him) took no notice of me until he had reached Tabuk. (One day as he was sitting amongst the people in Tabuk) he said : What has happened to Ka'b b. Malik ? A person from Banu' Salama said : Allah's Messenger, the (beauty) of his cloak and his appreciation of his sides have allured him and he was thus detained. Mua'dh b. Jabal said: Woe be upon that what you contend. Allah's Messenger, by Allah, we know nothing about him but good. Allah's Messenger (may peace be upon him), however, kept quiet. It was during that time that he (the Holy Prophet) saw a person (dressed in all white (garment) shattering the illusion of eye (mirage). Thereupon Allah's Messenger (may peace be upon him) said: May he be Abu Khaithama and, lo, it was Abu Khaithama al-Ansari and he was that person who contributed a sa' of dates and was scoffed at by the hypocrites. Ka'b b. Malik farther said: When this news reached me that Allah's Messenger (may peace be upon him) was on his way back from Tabuk I was greatly perturbed. I thought of fabricating false stories and asked myself how I would save myself from his anger on the following day. In this connection, I sought the help of every prudent man from amongst the members of my family and when it was said to me that Allah's Messenger (may peace be upon him) was about to arrive, all the false ideas banished (from my mind) and I came to the conclusion that nothing could save me but the telling of truth, so I decided to speak the truth and it was in the morning that Allah's Messenger (may peace be upon him) arrived (in Medina). And it was his habit that as he came back from a journey he first went to the mosque and observed two Rak'ahs of nafl prayer (as a mark of gratitude) and then sat amongst people. And as he did that, those who had remained behind him began to put forward their excuses and take an oath before him and they were more than eighty persons. Allah's Messenger (may peace be upon him) accepted their excuses on the very face of them and accepted their allegiance and sought forgiveness for them and left their secret (intentions) to Allah, until I presented myself to him. I greeted him and he smiled and there was a tinge of anger in that. He (the Holy Prophet) then said to me: Come forward. I went forward until I sat in front of him. He said to me: What kept you back? Could you not afford to go in for a ride ? I said: Allah's Messenger, by Allah, if I were to sit in the presence of anybody else from amongst the worldly people I would have definitely saved myself from his anger on one pretext (or the other) and I have also the knack to fall into argumentation, but, by Allah, I am fully aware of the fact that if I were to put forward before you a false excuse to please you Allah would definitely provoke your wrath upon me, and if I speak the truth you may be annoyed with me, but I hope that Allah would make its end well and, by Allah, there is no valid excuse for me. By Allah, I never possessed so good means, and I never had such favourable conditions for me as I had when I stayed behind you (failed to join the expedition). Thereupon, Allah's Messenger (may peace be upon him) said : This man told the truth, so get up until Allah gives a decision in your case. I stood up and some people of Banu' Salama followed me in hot haste, and they said to me : By Allah, we do not know about you that you committed a sin prior to this. You, however, showed inability to put forward an excuse before Allah's Messenger (may peace be upon him) as those who stayed behind him have put forward excuses. It would have been enough for the forgiveness of your sin that Allah's Messenger (may peace be upon him) would have sought forgiveness for you. By Allah, they continued to incite me until I thought of going back to Allah's Messenger (may peace be upon him) and contradict myself. Then I said to them : Has anyone else also met the same fate ? They said: Yes, two persons have met the same fate as has fallen to you and they have made the sane statement as you have made, and the same verdict has been delivered in their case as it has been delivered in your case. I said: Who are they ? They said: Murara b. ar-Rabi'a 'Amiri and Hilal b. Umayya al-Waqafi. They made a mention of these two pious persons to me who had participated in the Battle of Badr and there was an example for me in them. I went away when they named these two persons. Allah's Messenger (may peace be upon him) forbade the Nluslims to talk with three of us from amongst those (persons) who had stayed behind him. The people began to avoid us and their attitude towards us underwent a change and it seemed as if the whole atmosphere had turned (hostile) against us and it was in fact the same atmosphere ot which I was fully aware and in which I had lived (for a fairly long time). We spent fifty nights in this very state and my two friends confined themselves withen their houses and spent (most of the) time in weeping, but as I was young and strong amongst them I got (out of my house), participated in congregational prayers, moved about in the bazar; but none spoke to me. I came to Allah's Messenger (may peace be upon him) as he sat amongst (people) after the prayer, greeted him and asked myself whether his lips stirred in response to my greetings (or not). Then I observed prayer beside him and looked at him with stealing glances and when I attended to my prayer, he looked at me and when I cast a glance at him he turned away his eyes from me. And when the harsh treatment of the Muslims towards me extended to a (considerable) length of time, I walked until I climbed upon the wall of the garden of Abu Qatada, and he was my cousin, and I had the greatest love for him. I greeted him but, by Allah, he did not respond to my greetings. I said to him: Abu Qatada, I adjure you by Allah, arn't you well aware of the fact that I love Allah and His Messenger (may peace be upon him) the most. He kept quiet. I again repeated saying: I adjure you by Allah. arn't you well aware of the fact that I love Allah and His Messenger (may peace be upon him) the most. He kept quiet. I again adjured him, whereupon he said : Allah and the Messenger (may peace be upon him) are best aware of it. My eyes began to shed tears and I came back climbing down from the wall and as I was walking in the bazar of Medina a Nabatean from amongst the Nabateans of Syria, who had come to sell foodgrains in Medina, asked people to direct him to Ka'b b. Malik. People gave him the indication by pointing towards me. He came to me and delivered to me a letter of the King of Ghassan and as I was a scribe I read that letter and it was written like this: "Coming to my point, it has been conveyed to us that your friend (the Holy Prophet) is subjecting you to cruelty and Allah has not created you for a place where you are to be degraded and where you cannot find your right place, so you come to us that we should accord you honour. As I read that letter I said: This is also a calamity, so I burnt it in the oven. When out of the fifty days, forty days had passed and A11ah' Messenger (may peace be upon him) received no revelation, there came the messenger of Allah's Messenger (may peace be upon him) to me and said: Verily, Allah's Messenger (may peace be upon him) has commanded you to remain separate from your wife. I said: Should I divorce her or what (else) should I do? He said: No, but only remain separate from her and don't have sexual contact with her. The same message was sent to my companions. So I said to my wife: You better go to your parents and stay there with them until Allah gives the decision in my case. The wife of Hilal b. Umayya came to Allah's Messenger (may peace be upon him) and said: Allah's Messenger, Hilal b. Umayya is a senile person, he has no servant. Do you disapprove of my serving him? He said: No, but don't go near him. She said: By Allah, he has no such instinct in him. By Allah, he spends his time in weeping from that day to this day. Some of the members of my family said to me: Were you to seek permission from Allah's Messenger (may peace be upon him) in regard to your wife as he has granted permission to the wife of Hilal b. Umayya to serve him. I said: I would not seek permission from Allah's Messenger (may peace be upon him), for I cannot say what Allah's Apostle may say in response to seeking my permission. Moreover, I am a young man. It was in this state that I spent ten more nights and thus fifty nights had passed that (people) had observed boycott with us. It was on the morning of the fiftieth night that I observed my dawn prayer and was sitting on one of the roofs of our houses. And I was in fact sitting in that very state which Allah, the Exalted and Glorious, has described about us in these words: "Life had become hard for myself and the earth had compressed despite its vastness," that I heard the noise of an announcer from the peak of the hill of Sal' saying at the top of his voice: Ka'b b. Malik, there is glad tidings for you. I fell down in prostration and came to realise that there was (a message of) relief for me. Allah's Messenger (may peace be upon him) had informed the people of the acceptance of our repentance by Allah as he offered the dawn prayer. So the people went on to give us glad tidings and some of them went to my friends in order to give them the glad tidings and a person galloped his horse and came from the tribe of Aslam and his horse reached me more quickly than his voice. And when he came to me whose sound I heard, he gave me the glad tidings. I took off my clothes and clothed him with them because of his bringing good news to me and, by Allah, I possessed nothing else (in the form of clothes) than these two on that occasion, and I asked one to lend me two clothes and dressed myself in them. I came to Allah's Messenger (may peace be upon him) and on my way I met groups of people who greeted me because of (the acceptance of) repentance and they said: Here is a greeting for you for your repentance being accepted by Allah. (I moved on) until I came to the mosque and Allah's Messenger (may peace be upon him) had been sitting there amongst persons. So Talha b. 'Ubaidullah got up and rushed towards me and he shook hands with me and greeted me and, by Allah, no person stood up (to greet me) from amongst the emigrants except he. Ka'b said that he never forgot (this good gesture of) Talha. Ka'b further said : I greeted Allah's Messenger (may peace be upon him) with Assalam-o-'Alaikam and his face was glistening because of delight, and he said : Let there be glad tidings and blessings for you, the like of which (you have neither found nor you will find, as you find today) since your mother gave your birth. I said: Allah's Messenger. is this acceptance of repentance from you or from Allah? He said: No, (it is not from ma), it is from Allah, and it was common with Allah's Messenger (may peace be upon him) that as he was happy his face brightened up and it looked like a part of the moon and it was from this that we recognised it (his delight). As I sat before him, I said: Allah's Messenger, am I allowed to give in charity my wealth for Allah's sake and for the sake of His Messenger (may peace be upon him)? Thereupon Allah's Messenger (may peace be upon him) said: Keep some property with you as it is better for you. I said: I shall keep with me that part (of my property) which fell to my lot (on the occasion of the expedition of) Khaibar. I said: Allah's Messenger, verily, Allah has granted me salvation because of truth and, therefore, (I think) that repentance implies that I should not speak anything but truth as long as I live. He said: By Allah, I do not know whether anyone amongst the Muslims was put to more severe trial than I by Allah because of telling the truth. And since I made a mention of this to Allah's Messenger (may peace be upon him) up to this day I have not told any lie and, by Allah, I have decided not to tell a lie and I hope that Allah would save me (from trials) for the rest of my life and Allah, the Exalted and Glorious, revealed these verses: "Certainly, Allah has turned in Mercy to the Prophet and the emigrants and the helpers who followed him in the hour of hardship after the hearts of a part of them were about to deviate; then He turned to them in mercy. Surely, to them He is Compassionate, Merciful and (He turned in Mercy) to the three who were left behind until the earth despite its vastness became strait for them and their souls were also straitened to them." And this revelation reached up to the (words): "O you who believe, develop God consciousness, and be with the truthful" (ix. 117-118). Ka'b said: By Allah, since Allah directed me to Islam there has been no blessing more significant for me than this truth of mine which I spoke to Allah's Messenger (may peace be upon him) and if I were to tell a lie I would have been ruined as were ruined those who told lies, for in regard to those who told lies Allah used harshest words used for anyone as He descended revelation (and the words of Allah are): "They will swear by Allah to you when you return to them so that you may leave them alone. So leave them alone. Surely, they are unclean and their resort is Hell, recompense for what they earned. They will swear to you that you may be pleased with them but if you are pleased with them, yet surely Allah is not pleased with the transgressing people" (ix. 95-96). K'ab said that the matter of us three persons was deferred as compared with those who took an oath in the presence of Allahs Messenger (may peace be upon him) and he accepted their allegiance and sought forgiveness for them and Allah did not give any decision in regard to us. It was Allah, the Exalted and Glorious, Who gave decisions in our case, three who remained behind. (The words of the Qur'an) "the three who were left behind" do not mean that we remained back from Jihad but these imply that He kept our matter behind them who took oath and presented excuse before Him. This hadith has been narrated on the authority of Zuhri with the same chain of transmitters.

Book 37, Number 6671:

    'Abdullah b. K'ab, who was his (Ka'b's) guide as he became blind, reported that he heard from Ka'b b. Malik the story of his staying behind Allah's Messenger (may peace be upon him) from the expedition of Tabuk. The rest of the hadith is the same (but with this variation) that in the narration transmitted on the authority of Yunus (the words are): When Allah's Messenger (may. peace be upon him) intended to set on an expedition he kept It as a secret, but. be did not do so in thic. expedition. And in the narration transmitted on the authority of Muhammad b. Abdullah b. Muslim, there is no mention of Abu Khaithana (Allah be pleased with him) and no mention of his meeting with Allah's Messenger (may peace be upon him).

Book 37, Number 6672:

    It is reported on the authority of Abdullah b. K'ab and he was the guide of Ka'b as he lost his eyesight and he was the greatest scholar amongst his people and he retained in his mind many ahadith of the Companions of Allah's Messenger (may peace be upon him). He said: I heard my father Ka'b b. Malik, and he fas one of those three whose repentance was accepted (by Allah). He transmitted that He never lagged behind Allah's Messenger (may peace be upon him) from any expedition that he undertook except two expeditions; the rest of the hadith is the same, and in the tradition narrated through another chain of transmitters the words are: "That Allah's Messenger (may peace be upon him) set out on an expedition with a large number of persons more than ten thousand and this could not be recorded in the census register."

Chapter 10 : HADITH PERTAINING TO THE LIE ABOUT (HADRAT) 'A'ISHA SIDDIQA (ALLAH BE PLEASED WITH HER) AND ACCEPTING OF REPENTANCE OF THOSE WHO BROUGHT FALSE ALLEGATION ABOUT HER

Book 37, Number 6673:

    Sa'id b. Musayyib, 'Urwa b. Zubair, 'Alqama b. Waqqas and 'Ubaidullah b. Abdullah b. 'Utba b. Mas'ud--all of them reported the story of the false allegation against 'A'isha, the wife of Allah's Apostle (may peace be upon him). And they (the slanderers) said what they had to say, but Allah exonerated her of this charge and all of them reported a part of the hadith and some of them who had better memories reported more and with better retention, and I tried to retain this hadith (listening) from every one of them that they reported to me and some of them attested the other. (The sumaried substance of the false allegation is this): 'A'isha said: Whenever Allah's Messenger (may peace be upon him) intended to set out on a journey he cast lots amongst his wives and he took one with him in whose favour the lot was cast. It so happened that he cast lots amongst us while setting out on a battle and it was cast in my favour, so I set out along with Allah's Messenger (may peace be upon him). This relates to the period when the revelation concerning the commands of veil had been made. I was carried in a haudaj and I was brought down where we had to stay. In short, when we set out for return journey from the expedition and our caravan was near Medina, Allah's Messenger (may peace be upon him) commanded one night to march forward. I also got up when the command for the march was given and moved on until I went out of the encampments of the army and after relieving myself I came to my place. I touched my chest and found that my necklace which had been made of the stones of zafar had been broken. I retraced my steps and tried to search my necklace and this detained me there. The group of people who saddled my ride and placed my haudaj carrying me upon the camels marched on. They were under the impression that I was in it. The women in those days were light of weight and they did not wear much flesh, as they ate less food ; so they did not perceive the weight of my haudaj as they placed it upon the camel as I was a young girl at that time. So they drove the camel and Eet out and I found my necklace after the army had marched. I came to my place and there was none to call and none to respond (the call). I waited at my place under the impression that when the people would riot find me they would come back. So I kept sitting at my place. I was overpowered by sleep and slept. Safwan b. Mu'attal Sulami Dhakwini, who had lagged behind the army because of taking rest came to my place walking in the latter part of the night and he saw the body of a person who was asleep. He came to me and recognised me as he had seen rue before it was enjoined to observe purda. I got ap by his voice as he recited Inna lillahi wa inna ilaihi raji'un [we are for Allah and to Him we have to return.] and I covered my head with my headdress. By Allah, he did not speak to me a word and I did not hear a word from him except Inna lillahi. He made his camel kneel down and I amounted the camel as he pressed tLe camel's foreleg and he moved on leaning the camel by the nose string on which I was riding until we came to the army where it had encamped for rest because of extreme heat. Woe be upon those who harboured doubts about me and the most notorious among them was 'Abdullah b. Ubayy, the great hypocrite. We came to Medina and I fell sick for a month. The people had been deliberating over the statements of those who had brought these calumnies against me. I was absolutely unaware of anything concerning that. This, however, caused doubt in my mind that I did not see Allah's Messenger (may peace be upon him.) treating me with such kindness with which he treated me as I fell ill before this. The Holy Prophet (may peace be upon him)would coome and greet me with Assalam-o-'Alaikum and only ask me how I was. This caused doubt in my mind, but I was unaware of the evil. I wept outside despite my failing health and there went along with me Umm Mistah and she said the daughter of Abu Rhm b. Muttalib b. 'Abd Manaf and his mother was the daughter of Sakhr b. 'Amir, the sister of the mother of Abu Bakr Sidiq and his son was Mistah b. Uthatha b. 'Abbad b. Muttalib. I and the daughter of Abu Rahm set towards the direction of my house . Something got into the head dress of Umm Mistah and she said: Woe be upon Mistah. And I said. Woe be upon what you say. Do you curse people who had participated in Badr? She said: Innocent woman, have you not heard what he said? I said: What did he say? She conveyed to me the statement of those who had brought false allegations against me. So my illness was aggravated. I went to my house and Allah's Messenger (may peace be upon him) came to me and he greeted me and then said: How is that woman? I said: Do you permit me to go to the (house) of my parents? She (further) said: I had at that time made up my mind to confirm this news from them. Allah's Messenger (may peace be upon him) permitted me. So I came to (the house of) my parents and said to my mother: Mother, do you know what the people are talking about? She said: My daughter, you should not worry. By Allah, if there is a handsome woman who is loved by her husband and he has co-wives also they talk many a thing about her. I said: Hallowed be Allah, what are the people talking about? I wept during the whole night until it was morning and I did not have a wink of sleep and I wept even in the morning. As the revelation was delayed (in regard to this matter), so Allah's Messenger (may peace be upon him) called 'Ali ibn Abi 'Talib and Usama b. Zaid in order to seek their advice in regard to the separation of his wife. Usama b. Zaid told Allah's Messenger (may peace be apen him) about the innocence of his wives and what he knew about his love for them. He said: Allah's Messenger, they are your wives and we know nothing else about thembut goodness. And as for 'Ali b. Abu Talib, he said: Allah has not put any unnecessary burden upon you (in regard to your wives). There are a number of women besides her and if you ask that maidservant (Barira) she will tell you the truth. So, Allah's Messenger (may peace be upon him) called Bailra and said: Barira, did you see anything in 'A'isha which can cause doubt about her? Barira said: By Him Who sent thee with the truth, I have seen nothing objectionable in her but only this much that she is a young girl and she goes to sleep while kneading the flour and the lamb eats that. Thereupon Allah's Messenger (may peace be upon him) mounted the pulpit and sought vindication against 'Abdullah b. Ubayy b. Salul, and he further said: Who would exonerate me from imputations of that person who has troubled (me) in regard to my family? By Allah, I find nothing in my wife but goodness and the person whom the people have mentioned in this connection is, according to my knowledge, a thoroughly pious person, and he did never get into my house but along with me. Sa'd b. Mu'adh stood up and said: Allah's Messenger, I defend your honour against him. If he belong to the tribe of Aus we would strike his neck and if he belongs to the tribe of our brother Khazraj and you order us we would comply with your order. Then Sa'd b. 'Ubada stood up. He was chief of the Khazraj tribe. He was otherwise a pioas man but he had some what tribal partisanship in him and he said to Sa'd b. Mu'adh: By the everlasting existence of Allah. you are not stating the fact, you will not be able to kill him and you will not have the power to do so. Thereupon, Usaid b. Hudair stood up, and he was the first cousin of Sa'd b. Mu'adh and said to Sa'd b. 'Ubada: By the everlasting existence of Allah, you are not stating the fact. We would kill him. You are a hypocrite and so you argue in defence of the hypocrites, and thus both the tribes Aus and Khazraj were flared up, until they were about to fall upon one another and Allah's Messenger (may peace be upon him) kept standing upon the pulpit and Allah's Messenger (may peace be upon him) tried to subside their anger until they became silent and thus there was silence. 'A'isha further reported: I spent the whole day in weeping and even the night and could not have a wink of sleep even next night. My parents thought that this constant weeping of mine would break my heart. I wept and they sat beside me. In the meanwhile a woman of the Ansar came to see me. I permitted her to see me and she also began to weep. And we were in this very state that Allah's Messenger (may peace be upon him) came and he greeted me and then sat down. He had never sat with me since a month when this rumour was afloat, and there was no revelation (to clarity) my case. Allah's Messenger (may peace be upon him) recited Tashahhud (there is no god but Allah and Muhammad is His Apostle) and then said: Coming to the point, 'A'isha, this is what has reached me about you and if you are innocent, Allah would Himself vindicate your honour, and if accidentally there has been a lapse on your part sock forgiveness of Allah; He will pardon thee for when a servant makes a confession of his fault and turns (to Him) penitently, Allah also turns to him (mercifully) accepting his repentance. When Allah's Messenger (may peace be upon him) talked, my tears dried up and not even a single drop of tear was perceived by me (rolling out of my eyes). I said to my father: You give a reply to Allah's Messenger (may peace be upon him) on my behalf. He said: By Allah, I do not know what I should say to Allah's Messenger (may peace be upon him). I then said to my mother: Give a reply to Allah's Messenger (may peace be upon him) on my behalf, but she said: By Allah, I do not know what I should say to Allah's Messenger (may peace be upon him). I was a small girl at that time and I had not read much of the Qur'an (but I said): By Allah, I perceive that you have heard about this and it has settled down in your mind and you have taken it to be true, so if I say to you that I am quite innocent, and Allah knows that I am innocent, you would never believe me to be true, and if I confess to (the alleged) lapse before you, whereas Allah knows that I am completely innocent (and I have not committed this sin at all), in that case You will take me to be true and, by Allah, I, therefore, find no other alternative for me and for you except that what the father of Yousuf said: ,(My course is) comely patience. And Allah it is Whose help is to be sought for in that (predicament) which ye describe" (xii 18). After this I turned my face to the other side and lay down on my bed. By Allah, I was fully aware of this fact that I was innocent but I did not expect that Allah would descend Wahy Matlu (Qur'anic Wahy) in my case as I did not think myself so much important that Allah, the Exalted and Glorious, would speak in this matter in words to be recited. I only hoped that Allah would in vision give an indication of my innocence to Allah's Messenger (may peace be upon him) during his sleep. And, by Allah, Allah's Messenger (may peace be upon him) had not moved an inch from where he had been sitting and none from the members of my family had gone that Allah, the Exalted and Glorious, descended revelation upon Allah's Messenger (may peace be upon him) there and then and he felt the burden which he used to feel at the time of receiving revelation. He began to perspire because of the burden of words of Allah as they descended upon him even during the winter season and there fell the drops of his sweat like silvery beads. When this state of receiving revelation was over, the Messenger of Allah (may peace be upon him) smiled and the first words which he spoke to me were that he said: 'A'isha, there is glad tidings for you. Verily, Allah has vindicated your honour, and my mother who had been standing by me said: Get up (and thank him, i.e. the Holy Prophet). I said: By Allah, I shall not thank him and laud him but Allah Who has descended revelation vindicating my honour. She ('A'isha) said: Allah, the Exalted and Glorious, revealed: "'Verily, those who spread the slander are a gang among you" (and) ten (subsequent) verses in regard to my innocence. She further said: Abu Bakr used to give to Mistah (some stipend) as a token of kinship with him and for his poverty and he (Abu Bakr) said: By Allah, now I would not spend anything for him. 'A'isha said: It was upon this that Allah the Exalted and Glorious revealed this verse: "And let not those who possess dignity and ease among you swear to give to the near of the kin" up to "Yearn ye not that Allah may forgive you?" Hibban b. Musa' said that 'Abdullah b. Mubarak used to say: It is a verse contained in the Book which most (eminently) brightens the hope. Abu Bakr said: By Allah, I wish that Allah should pardon me. I shall never stop this stipend. So he continued to give him the stipend which he had withdrawn. 'A'isha said that Allah's Messenger (way peace be upon him) asked Zainab, daughter of Jahsh, the wife of Allah's Apostle (may peace be upon him), about me what she knew or what she had seen in me, and she said: Allah's Messenger, I shall not say anything without hearing (with my ears) and seeing with my eyes. By Allah, I find nothing in her but goodness. (And she stated this in spite of the fact) that she was the only lady who amongst the wives of Allah's Apostle (may peace be upon him) used to vie with me but Allah saved her in bringing false allegation against me because of her God-consciousness. Her sister Hamna bint Jahsh, however, opposed her and she was undone along with others.

Book 37, Number 6674:

    This hadith has been narrated on the authority of Zuhri through other chains of transmitters but with a slight variation of wording. In the hadith transmitters on the authority of 'Urwa, there is an addition of these words: "'A'isha did not like that Hassan should be rebuked in her presence and she used to say: It was he who wrote this verse also: "'Verily, my father and my mother and my honour, those are all meant for defending the honour of Muhammad against you." And 'Urwa further reported that 'A'isha said: By Allah, the person, about whom the allegation was trade used to say: Hallowed be Allah, by One, in Whose hand is my life, I have never unveiled any woman, and then he die,& as a martyr in the cause of Allah, and in the narration transmitted on the authority of Ya'qub b. Ibrahim., the word is Mu'irin and in the narration transmitted on the'authority of 'Abd al-Razzaq it is Mughirin. 'Abd b. Humaid said: I said to 'Abd al-Razzaq: What does this word Mughirin mean? And he said: Al- waghra means intense heat.

Book 37, Number 6675:

    'A'Isha reported: When I came under discussion what the people had to say about me, Allah's Messenger (may peace be upon him) stood up for delivering an address and he recited tashahhud (I bear witness to the fact that iheie is no god but Allah) and praised Allah, lauded Him what He rightly deserves and then said: Coming to the point. Give me an advice about them who have brought false charge about my family. By Allah, I know no evil in the members of my family and the person in connection with whom the false charge is being levelled, I know no evil in him too. And he never entered my house but in my presence and when I was away on a journey, he remained with me even in that. The rest of the hadith is the same but with this change that Allah's Messenger (may peace be upon him) came to my house and asked my maidservant and she said: By Allah, I know no fault in her but this that she sleeps, and goat comes and eats the kneaded flour. Some of the Companions (of the Holy Prophet) scolded her and said: State the fact before Allah's Messenger (may peace be upon him) and they even made a pointed reference (to this incident). She said: gallowed be Allah. By Allah, I know about her as does the jeweller know about the pure piece of gold. And when this news reached the person in connection with whom the allegation was made he said: Hallowed be Allah. By Allah, I have never unveiled any woman. 'A'isha said: He fell as a martyr in the cause of Allah, and there is this addition in this hadith that the people who had brought false allegation amongst them were Mistah and Hamna and Hassan. And so far as the hypocrite 'Abdullah b. Ubayy is concerned, he was one who tried his best to gather the false news and then gave them the wind. And he was in fact a fabricator and there was Hamna, daughter of Jahsh with him.

Chapter 11 : THE EXONERATION OF THE SLAVEGIRL OF ALLAH'S APOSTLE (MAY PEACE BE UPON HIM) FROM A FALSE CHARGE

Book 37, Number 6676:

    Anas reported that a person was charged with fornication with the slavegirl of Allah's Messenger (may peace be upon him). Thereupon Allah's Messenger (may peace be upon him) said to 'Ali: Go and strike his neck. 'Ali came to him and he found him in a well making his body cool. 'Ali said to him: Come out, and as he took hold of his hand and brought him out, he found that his sexual organ had been cut. Hadrat 'Ali refrained from striking his neck. He came to Allah's Apostle (may peace be upon him) and said: Allah's Messenger, he has not even the sexual organ with him.


BOOK 38: Pertaining To The Charateristics Of The Hypocrites And Command Concerning Them (Kitab Sifat Al-Munafiqin Wa Ahkamihim)

Kitab Sifat Al-Munafiqin Wa Ahkamihim
(Pertaining To The Charateristics Of The Hypocrites And Command Concerning Them )

Back
Chapter 1 : ....

Book 38, Number 6677:

    Zaid b. Arqam reported: We set out on a journey along with Allah's Messenger (may peace be upon him) in which we faced many hardships.'Abdullah b. Ubayy said to his friends: Do not give what you have in your possession to those who are with Allah's Messenger (may peace be upon him) until they desert him. Zubair said: That is the reciting of that person who recited as min haulahu (from around him) and the other reciting is man haulahia (who are around him).And in this case when we would return to Medina the honourable would drive out the meaner therefrom (lxiv. 8).I came to Allah's Apostle (may peace be upon him) and informed him about that and he sent someone to 'Abdullah b. Ubayy and he asked him whether he had said that or not. He took an oath to the fact that he had not done that and told that it was Zaid who had stated a lie to Allah's Messenger (may peace be upon him).Zaid said: I was much perturbed because of this until this verse was revealed attesting my truth: "When the hypocrites come" (lxiii. 1). Allah's Apostle (may peace be upon him) then called them in order to seek forgiveness for them, but they turned away their heads as if they were hooks of wood fixed in the wall (lxiii. 4), and they were in fact apparently good-looking persons.

Book 38, Number 6678 :

    Jabir reported Allah's Apostle (may peace be upon him) came to the grave of 'Abdullah b. Ubayy, brought him out from that, placed him on his knee and put his saliva in his mouth and shrouded him in his own shirt and Allah knows best.

Book 38, Number 6679 :

    Jabir b. 'Abdullah reported that Allah's Messenger (may peace be upon him) came to the grave of 'Abdullah b. Ubayy as he was placed in that.The rest of the hadith is the same.

Book 38, Number 6680 :

    Ibn 'Umar reported that when 'Abdullah b. Ubayy b. Salul died. His son 'Abdullah b. 'Abdullah (b.Ubayy) came to Allah's Messenger (may peace be upon him) and begged him that he should give him his shirt which he would use as a coffin for his father, he gave him that. He then begged that he should conduct funeral prayer for him. Allah's Messenger (may peace be upon him) had hardly got up to observe the prayer for him that 'Umar stood up and caught hold of the garment of Allah's Messenger (may peace be upon him) and said: Allah's Messenger, are you going to conduct prayer for this man, whereas Allah has forbidden you to offer prayer for him? Thereupon Allah's Messenger (may peace be upon him) said: Allah has given me an option as He has said: "You may beg pardon for them or you may not beg pardon for them, and even if you beg pardon for them, seventy times" (ix. 80), and I am going to make an addition to the seventy. He was a hypocrite and Allah's Messenger (may peace be upon him) offered prayer for him and Allah, the Exalted and Glorious, revealed this verse: "Do not offer prayer for any one of them at all and do not stand upon their graves for (offering prayer over them)" (ix. 84).

Book 38, Number 6681 :

    This hadith has been narrated on the authority of 'Abdullah with the same chain of transmitters but with this addition: "He then abandoned offering (funeral) prayer for them."

Book 38, Number 6682 :

    Ibn Mas'ud reported that there gathered near the House three persons amongst whom two were Quraishi and one was a Thaqafi or two were Thaqafis and one was a Quraishi. They lacked understanding but wore more flesh. One of them said: Do you think that Allah hears as we speak? The other one said: He does hear when we speak loudly and He does not hear when we speak in undertones, and still the other one said: If He listens when we speak loudly, He also listens when we speak in undertones. It was on this occasion that this verse was revealed: "You did not conceal yourselves lest your ears, your eyes and your skins would stand witness against you" (xli. 22).

Book 38, Number 6683 :

    This hadith has been narrated on the authority of 'Abdullah through another chain of transmitters.

Book 38, Number 6684 :

    Zaid b. Thabit reported that Allah's Apostle (may peace be upon him) set out for Uhud. Some of those persons who were with them came back.The Companions of Allah's Apostle (may peace be upon him) were divided in two groups. One group said: We would kill them, and the other one said: No, this should not be done, and it was on this occasion that this verse was revealed: "Why should you, then, be two parties in relation to hypocrites ?" (iv. 88).

Book 38, Number 6685 :

    This hadith has been narrated on the authority of Shu'ba with the same chain of transmitters.

Book 38, Number 6686 :

    Abu Sa'id Khudri reported that during the lifetime of Allah's Messenger (may peace be upon him) the hypocrites behaved in this way that when Allah's Apostle (may peace be upon him) set out for a battle, they kept themselves behind, and they became happy that they had managed to sit in the house contrary to (the act of) Allah's Messenger (may peace be upon him), and when Allah's Apostle (may peace he upon him) came back, they put forward excuses and took oath and wished that people should laud them for the deeds which they had not done. It was on this occasion that this verse was revealed: "Think not that those who exult in what they have done, and love to be praised for what they have not done-think not them to be safe from the chastisement; and for them is a painful chastisement" (iii. 18).

Book 38, Number 6687 :

    Humaid b. 'Abd al-Rahman b. 'Auf reported that Marwan said to Rafi', his chamberlain, that he should go to Ibn 'Abbas and ask him: If every one of us be punished for his being happy upon his deed and for his being praised for what he has not done, nobody would be saved from the torment. Ibn 'Abbas said: What you have to do with this verse? It has been in fact revealed in connection with the people of the Book." Then Ibn Abbas recited this verse: "When Allah took a covenant from those who had been given the Book: You shall explain it to people and shall not conceal this" (iii. 186), and then Ibn 'Abbas recited this verse: "Think not that those who exult in what they have done and love to be praised for what they have not done" (iii. 186). Ibn 'Abbas (further) said: Allah's Apostle (may peace be upon him) asked them about something and then they concealed that and they told him something else and they went out and they thought that they had informed him as lie had asked them and they felt happy of what they had concealed.

Book 38, Number 6688 :

    Qais reported: I said to 'Ammar: What is your opinion about that which you have done in case (of your siding with Hadrat 'Ali)? Is it your personal opinion or something you got from Allah's Messenger (may peace be upon him)? 'Ammar said: We have got nothing from Allah's Messenger (may peace be upon him) which people at large did not get, but Hudhaifa told me that Allah's Apostle (may peace be upon him) had especially told him amongst his Companion, that there would be twelve hypocrites out of whom eight would not get into Paradise, until a camel would be able to pass through the needle hole. The ulcer would be itself sufficient (to kill) eight. So far as four are concerned, I do not remember what Shu'ba said about them.

Book 38, Number 6689 :

    Qais b. 'Ubad reported: We said to 'Ammar: Was your fighting (on the side of 'Ali in the Battle of Siffin) a matter of your own choice or you got its hints from Allah's Messenger (may peace be upon him) for it, is likely for one to err in one's own discretion or was it because of any covenant that Allah's Messenger (may peace be upon him) got from you? He said: It was not because of any covenant that Allah's Messenger (may peace be upon him) got from us which he did get from other people, and he further said that Allah's Messenger (may peace be upon him) said: "In my Ummah." And I think that Hudhaifa reported to me and according to Ghundar (the words are) that he said: In my Ummah, there would be twelve hypocrites and they would not be admitted to Paradise and they would not smell its odour, until the camel would pass through a needle's hole. Dubaila (ulcer) would be enough to (torment them)-a kind of flame of Fire which would appear in their shoulders and it would protrude from their chest.

Book 38, Number 6690 :

    Abu Tufail reported that there was a dispute between Hudhaifa and one from the people of Aqaba as it happens amongst people. He said: I adjure you by Allah to tell me as to how many people from Aqaba were. The people said to him (Hudhaifa) to inform him as he had asked. We have been informed that they were fourteen and If you are to be counted amongst them, then they would be fifteen and I state by Allah that twelve amongst them were the enemies of Allah and of His Messenger (may peace be upon him) in this world. The rest of the three put forward this excuse: We did not hear the announcement of Allah's Messenger (may peace be upon him) and we were not aware of the intention of the people as he (the Holy Prophet) had been in the hot atmosphere. He (the Holy Prophet) then said: The water is small in quantity (at the next station). So nobody should go ahead of me, but he found people who had gone ahead of him and he cursed them on that day.

Book 38, Number 6691 :

    Jabir b. Abdullah reported that Allah's Messenger (may peace be upon him) said: He who climbed this hill, the hill of Murar, his sins would be obliterated as were obliterated the sins of Bani Isra'il. So the first to take their horses were the people of Banu Khazraj. Then there was a ceaseless flow of persons and Allah's Messenger (may peace be upon him) said to them: All of you are those who have been pardoned except the owner of a red camel. We came to him and said to him: You also come on, so that Allah's Messenger (may peace be upon him) may seek forgiveness for you. But he said: By Allah, so far as I am concerned, the finding of something lost is dearer to me than seeking of forgiveness for me by your companion (the Holy Prophet), and he remained busy in finding out his lost thing.

Book 38, Number 6692 :

    Jabir b. Abdullah reported Allah's Messenger (may peace be upon him) as saying: He who would climb this hill of Murar. The rest of the hadith is the same but with this variation that it was a desert Arab who was finding out his lost thing.

Book 38, Number 6693 :

    Anas b. Malik reported: There was a person amongst us who belonged to the tribe of Bani Najjar and he recited Sura al-Baqarah and Surat Al-i-'Imran and he used to transcribe for Allah's Messenger (may peace be upon him). He ran away as a rebel and joined the People of the Book. They gave it much importance and said: He is the person who used to transcribe for Muhammad and they were much pleased with him. Time rolled on that Allah caused his death. They dug the grave and buried him therein, but they found to their surprise that the earth had thrown him out over the surface. They again dug the grave for him and buried him but the earth again threw him out upon the surface. They again dug the grave for him and buried him but the earth again threw him out upon the surface. At last they left him unburied.

Book 38, Number 6694 :

    Jabir reported that Allah's Messenger (may peace be upon him) came back from a journey and as he was near Medina, there was such a violent gale that the mountain seemed to be pressed. Allah's Messenger (may peace be upon him) said: This wind has perhaps been made to blow for the death of a hypocrite, and as he reached Medina a notorious hypocrite from amongst the hypocrites had died.

Book 38, Number 6695 :

    Iyas reported on the authority of his father: We went along with Allah's Messenger (may peace be upon him) to visit a person suffering from fever. When I placed my hand upon him, I said: By Allah, I have never seen, till this day, a person running higher temperature than he. Thereupon Allah's Apostle (may peace be upon him), turning his face to his companions, said: May I not inform you of a severer temperature than this which these two persons would run on the Day of Resurrection? And they were two hypocrites riding upon the camel turning their back towards (the Muslims).

Book 38, Number 6696 :

    Ibn Umar reported Allah's Apostle (may peace be upon him) as saying: The similitude of a hypocrite is that of a sheep which roams aimlessly between two flocks. She goes to one at one time and to the other at another time.

Book 38, Number 6697 :

    Ibn Umar reported Allah's Apostle (may peace be upon him) saying like this but with this change of words: "She sometimes finds a way in one flock and then in another flock."


BOOK 39: The Book Giving Description of the Day of Judgement, Paradise and Hell (Kitab Sifat Al-Qiyamah wa'l Janna wa'n-Nar)

KITAB SIFAT AL-QIYAMAH WA'L JANNA WA'N-NAR
(THE BOOK GIVING DESCRIPTION OF THE DAY OF JUDGEMENT, PARADISE AND HELL)

Back
Chapter 1 : DESCRIPTION OF THE DAY OF JUDGMENT,PARADISE AND HELL

Book 39, Number 6698:

    Abu Huraira reported Allah's Messenger (may peace be upon him) as saying: A bulky person would be brought on the Day of judgment and he would not carry the weight to the eye of Allah equal even to that of a gnat. Nor shall We set up a balance for them on the Day of Resurrection" (xviii. 105).

Book 39, Number 6699 :

    Abdullah b. Mas'ud reported that a Jew scholar came to Allah's Apostle (may peace he upon him) and said. Muhammad, or Abu al-Qasim, verify, Allah, the Exalted and Glorious. would carry the Heavens on the Day of Judgment upon one finger and earths upon one finger and the mountains and trees upor one finger and the ocean and moist earth upon one finger-in fact the whole of the creation upon one finger, and then He would stir them and say: I am your Lord, I am your Lord. Thereupon Allah's Messenger (may peace be upon him) smiled testifying what that scholar had said. He then recited this verse: "And they honour not Allah with the honour due to Him; and the whole earth will be in His grip on the Day of Resurrection and the heaven* r*Utd up in His right hand. Glory be to Him I and highly Exalted is Re above what they associate (with Him)" (xxxix. 67).

Book 39, Number 6700 :

    This hadlth has been narrated on the authority of Mansur with the same chain of truemittm (and the words are): A Jew scholar came to Allah's Messenger (may peace be upon him). The rest of the hadith is the same, but there is no mention of "then He would stir them. " But there is this addition: "I saw Allah's Messengcr (may peace be upon him) smiling so much that his front teeth appeared and testifying him (th Jew scholar); then Allah's Messenger (may peace be upon him) recited the verse: "And they honour not Allah with the honour due to Him" (xxxix. 67).

Book 39, Number 6701 :

    Abdullah reported that a person from the People of the Book came to Allah's Apostle (may peace he upon him) and said: Abu al-Qasim, verify, Allah would carry tho Reavmo upon one finger and the earths upon one finger and the trees and moist earth upon one finger and in fact the whole of the creation upon one finger and then say: I am your Lord. I an your Lord. And he (the narrator) further said: I saw Allah's Massenger(may peace be upon him) fooling so much hppy that his front teeth became visible and then he recited the Yeife: "And they honour not Allah with the honour due to Him" (xxxix. 67).

Book 39, Number 6702 :

    This hadith has been narrated on the authority of A'mash with the same chain of transmitters but with a slight variation of wording.

Book 39, Number 6703 :

    Abu Huraira reported Allah's Apostle (may peace be upon him) as saying: Allan, the Exalted and Glorious, will take in His grip the earth ou the Day of Judgment and He would roll up the sky in His right hand and would say: I am the Lord; wbere are the sovereigns of the world?

Book 39, Number 6704 :

    Abdullah b.'Umar reported Allah's Messenger (may peace be upon him) saying: Allah, the Exalted and Glorious, would fold the Heavens on the Day of Judgment and then He would place them on His tight hand and say: I am the Lord; where are the haughty and where are the proud (today)? He would fold the' earth (placing it) on the lef t hand and say: I am the Lord; where are the haughty and where are the proud (today) ?

Book 39, Number 6705 :

    Abdullah b. Miqsam reported that he saw Abdullah b. Umar as he narrated Allah's Messenger (may peace be upon him) as saying: Allah, the Exalted and Glorious, would take in His hand His Heavens and His Earth,and would say: I am Allah. And He would clench His fingers and then would open them (and say): I am your Lord. I saw the pulpit in commotion from underneath because of something (vib-ating)there. And (I felt this commotion so much) that I said (to myself): It may not fall with Allah's Massenger (may peace be upon him) upon it.

Book 39, Number 6706 :

    Abdullah b. Miqsam reported that 'Abdullah b. 'Umar reported: I saw Allah'h Messenger (may peace be upon him) upon the pulpit and he was saying that the Mighty Lord, the Exalted and Glorious would take hold of the Heavens and earth in His hand. The rest of the hadith is the same,

Chapter 2 :THE BEGINNING OF THE CREATION AND THE CREATION OF ADAM (PEACE BE UPON HIM)

Book 39, Number 6707:

    Abu Haraira reported that Allah's Messenger (may peace be upon him) took hold of my hands and said: Allah, the Exalted and Glorious, created the clay on Saturday and He created the mountains on Sunday and He created the trees on Monday and He created the things entailing labour on Tuesday and created light on Wednesday and lie caused the animals to spread on Thursday and created Adam (peace be upon him) after 'Asr on Friday;the last creation at the last hour of the hours of Friday, i.e. between afternoon and night.

Chapter 3 : PERTAINING TO RE-BIRTH, ASSEMBLING AND CHARACTERISTICS OF THE EARTH ON THE DAY OF RESURRECTION

Book 39, Number 6708:

    Sahl b. Sa'd reported that Allah's Messenger (may peace be upon him) said: The people will be assembled on tee Day of Resurrection on a white plain with a reddish tinge like the loaf of white bread with no marks set up for anyone.

Book 39, Number 6709 :

    'A'isha reported: I asked Allah's Messenger (may peace be upon him) about the words of Allah, the Exalted and Glorious: "The day when the earth would be changed for another earth and Heaven would be changed for another Heaven (XiV. 48), (and inquired:) (Allah's Messenger), where would the people be on tnat day? He said: They would be on the Sirit.

Chapter 4 : THE FEAST FOR THE INHABITANTS OF PARADISE

Book 39, Number 6710:

    Abu al-Sa'id Khudri reported Allah's Messenger (may peace be upon him) as saying that the earth would turn to be one single bread on the Day of Resurrection and the Almighty would turn it in His hand as one of you turns a loaf while on a journey. It would be a feast arranged in the honour of the people of Paradise. He (the narrator) further narrated that a person from among the Jews came and he said: Abu al-Qasim, may the Compassionate Lord be pleased with you! May I inform you about the feast arranged in honour of the people of Paradise on the Day of Resurrection? He said: Do it, of course. He said: The earth would become one single bread. Then Allah's Messenger (may peace be upon him) looked towards us and laughed until his molar teeth became visible. He then again said: May I inform you about that with which they would season it? He said: Do it, of course. He said: Their seasoning would be balim and fish. The Companions of the Holy Prophet (may peace be upon him) said: What is this balam? He said: Ox and fish from whose excessive livers seventy thousand people would be able to eat.

Book 39, Number 6711:

    Abu Huraira reported Allah's Messenger (may peace be upon him) as saying: If ten scholars of the Jews would follow me, no Jew would be left upon the surface of the earth who would not embrace Islam.

Chapter 5 : THE QUESTION OF A JEW FROM ALLAH'S MESSENGER (MAY PEACE BE UPON HIM) ABOUT SOUL AND HIS WORDS."THEY ASK THEE ABOUT THE SOUL"

Book 39, Number 6712:

    'Abdullah(b. Mas'ud) reported: As I was going aloog with Allah's Apostle (may peace be upon him) in a cultivable land and he (the Holy Prophet) was walking with the support of a wood, a group of Jews happened to meet him. Some of them said to the others: Ask him about the Soul. They said: Wbat is your doubt about it? There is a possibility that you may ask him about anything (the answer of) which you may not like. They said: Ask him. So one amongst them asked him about the Soul. Allah's Messenger (may peace be upon him) kept quiet and he gave no reply and I came to know that revelation was being sent to him, so I stood at my place and thus this revelation descended upon him: "They ask thee 'about Soul. Say: The Soul is by the Commandment of my Lord, and of Knowledge you are given but a little" (xvii. 58).

Book 39, Number 6713:

    Abdullah reported: I was walking along with Allah's Apostle (may peace be upon him) in a field of Medina. The rest of the hadith is the same, but there is a slight variation of wording.

Book 39, Number 6714:

    Abdullah reported that Allah's Apostle (may peace be upon h@) was reclining against a tree in the garden. The rest of the hadith is the same. but there is a slight variation of wording.

Book 39, Number 6715:

    Khabbab reported that al-As b. Wa'il owed debt to me. I came to him in order to demand that. He said: I will never repay you unless you belie Mubammad. I said: I would never belie Mubammad until you die and you are again raised up. He said: When I would be raised up after death, I would repay your debt when I would get my property and children back. Waki' said: This is how Almash has narrated and it was on this occasion that this verse was revealed: "Hast thou seen him who dis. believes in Our message and says: I shall certainly be given wealth and children' (xis, 77) up to "he would come to Us alone" (xiX. 80).

Book 39, Number 6716:

    This hadith has been narrated on the authority of Khabbib through another chain of transmitters and the words are. I in the pre-Islamic days used to work as an iron-smith. I did some work for 'As b. Wa'il and came to him for getting the remuneration of my wages.

Chapter 6 : PERTAINING TO THE WORDS OF ALLAIIH: ALLAH WOULD NEVER PUNISH THEM SO LONG AS YOU ARE AMONGST THEM"

Book 39, Number 6717:

    Anas b. Malik reported that Abu Jahl said: O Allah, if he is true, then shower upon us the volley of stones from the sky or inflict upon us a grievous torment, and it was on this occasion that this verse was revealed:"'Allah would never torment them so long as you are amongst them. And Allah is not going to torment them as long as they seek forgiveness. And why is it that Allah should not torment them and they prevent people from coming to the sacred mosque...."(viii. 34) to the end.

Chapter 7 : PERTAINING TO THE WORDS OF ALLAH: "NAY, BUT VERILY MAN IS INORDINATE, BECAUSE HE LOOKS UPON HIMSELF AS SELF-SUFFICIENT"

Book 39, Number 6718:

    Abu Huraira reported that Abu Jahl asked (people) whether Mubammad placed his face (on the ground) in their presence. It was said to him: Yes. He said : By Lit and Uzza. If I were to see him do that, I would trample his neck, or I would beamear his face with dust. He came to Allah's Messenger (may peace be upon him) as he was engaged in prayer and thought of trampling his neck (and the people say) that he came near him but turned upon his heels and tried to repulse something with his hands. It was said to him: What is the matter with you ? He said : There is between me and him a ditch of fire and terror and wings. Thereupon Allah's Messenger (may peace he upon him) said: If he were to come near me the angels would have torn him to pieces. Then Allah, the Exalted and Glorious, revealed this verse- (the narrator) said: We do not whether it is the hadith transmitted te Abu Huraira or something conveyed to him from another source : "Nay, man is surely inordinate, because he looks upon himself as self-sufficient. Surely to thy Lord is the return. Hast thou seen him who forbids a servant when he prays ? Seest thou if he is on the right way, or enjoins observance of piety? Seest thou if he [Abu Jah]] denies and turns away? Knowest he not that Allah sees? Nay. if he desists not, We will seize him by the forelock-a lying, sinful forelock. Then let him summon his council. We will summon the guards of the Hell. Nay! Obey not thou him" (Icvi. 6-19). (Rather prostrate thyself.) Ubaidullah made this addition: It was after this that (prostration) was enjoined upon and Ibn Abd al-Ala made this addition that by Nadia he meant his people.

Book 39, Number 6719:

    Masruq reported: We were sitting in the company of Abdullah and he was lying on the bed that a person came and said: Abd Abd al-Rabmin, a story-teller at the gates of Kinda says that the verse (of the Qur'an) which deals with the "smoke" implies that which is about to come and it would hold the breath of the infidels and would inflict the believers with cold. Thereupon Abdullah got up and said in anger. O people, fear Allah and say only that which one knows amongst you and do not say which he does not know and he should simply say: Allah has the best knowledge for He has the best knowledge amongst all of you. It does not behove him to say that which he does not know. Allah has the best knowledge of it. Verily Allah, the Exalted and Glorious, said to His Prophet (may peace be upon him) to state:"I do not ask from you any remuneration and I am not the one to put you in trouble," and when Allah's Mesqenger (may peace be upon him) saw people turning back(from religion) he said: O Allah, afflict thern with seven famines as was done in the case of Yusuf, so they were afflicted with famine by which they were forced to eat everything until they were obliged to eat the hides and the dead bodies because of hunger, and every one of them looked towards the sky and he found a smoke. And Abu Sufyan came and he said: Muhammad, you have come to command us to obey Allah and cement the ties of blood- relation whereas your people are undone ; supplicate Allah for tlicm. Thereupon Allah, the Exalted and Glorious, said: "Wait for the day when there would be clear smoke from the sky which would envelop people and that would be grievous torivent" up to the words: "you are going to return to (evil)." (if this verse implied the torment of the next life) could the chastisement of the next (life) be averted (as the Qur'an states) : On the day when We seize (them) with the most violent seizing; surely We shall exact retribution" (xliv. 16) ? The seizing (in the hadith) implies that of the Day of Badr. And so far as the sign of smoke, seizing, inevitability and signs of Rome are concern- ed, they have become things of the past now.

Book 39, Number 6720:

    Masruq reported that there came to Abdullah a person and said: I have left behind in the mosque a man who explains the Qur'an according to his personal discretion and he explained this verse: "So wait for the day when the Heaven brings a clear smoke." He says that a smoke would come to the people on the Day of Resurrection anl it will withhold breath and they would be inflicted with cold. 'Abdullah said: He who has knowledge should say something and he who has no knowledge should simply say: Allah is best aware. This reflects the understanding of a person that he should say about that which he does not know that it is Allah who knows best. The fact is that when the Quraish disobeyed Allah's Apostle (may peace be upon him) he supplicated Allah that they should be afflicted with famine and starvation as was done in case of Yusuf. And they were so much hard pressed that a person would ace the sky and he would see between him and the sky something like smoke and they were so much hard pressed that they began to cat the bones, and a person came to Allah's Apostle (may peace be upon him) and said: Allah's Messenger. seek forgiveness for the tribe of Mudar for (its people) have been undone. The Messenger (may peace be upon him) said: For Mudar? You are overbold, but he supplicated Allah for them. It was upon this that this verse was revealed: "We shall remove the chastisement a little, but they will surely return to evil" (xliv. 15). lie (the narrator) said: There was a downpoor of rain upon them. When there was some relief for them they returned to the same position as they had been before, and Allah, the Exalted and Glorious, revealed this verse: "So wait for the day when the heaven brings a clear smoke enveloping people. This is a grievous torment on the day when We seize them with the most violent seizing; surely, We shall exact retribution." And this (seizing) implied (Battle) of Badr.

Book 39, Number 6721:

    Abdullah said that five signs have (become things) of the past (and have proved the truth of the Holy Prophet) : (Enveloping) by the smoke, inevitable (punishment to the Meccans at Badr), (the victory of) Rome, (violent) seizing (of the Meccans at Badr) and (the splitting up of) the Moon.

Book 39, Number 6722:

    This hadith has been narrated on the authority of A'mash with the same chain of transmitters.

Book 39, Number 6723:

    Ubayy b. Ka'b reported that the words of Allah, the Exalted and Glorious: "We will, surely, make them taste the lesser punishment before the severer punishment (that haply they may return)" (xxxii. 21) imply the torments of the world. (victory of) Rome, seizing (of the Meccans), or smoke. And Shalba was in doubt about seizing or smoke.

Chapter 8 : THE SPLITTING UP OF THE MOON (A GREAT MIRACLE)

Book 39, Number 6724:

    Abu Ma'mar reported on the authority of Abdullah that the moon was split up during lifetime by Allah's Messenger (may peace be upon him) in two parts and Allah's Messenger (may peace be upon him) said: Bear testimony to this.

Book 39, Number 6725:

    This hadith has been transmitted on the authority of Abdullah b. Mas'ud (who said): We were along with Allah's Messenger (may peace be upon him) at Mina, that moon was split up into two. One of its parts was behind the mountain and the other one was on this side of the mountain. Allah's Messenger (may peace be upbn him) said to us: Bear witness to this.

Book 39, Number 6726:

    'Abdullah b. Mas'ud reported that the moon was split up in two parts during the lifetime of Allah's Messenger (may peace be upon him). The mountain covered one of its parts and one part of it was above the mountain and Allah's Messenger (may peace be upon him) said: Bear witness to this.

Book 39, Number 6727:

    This hadith has been transmitted on the authority of Shu'ba with a slight variation of wording.

Book 39, Number 6728:

    Anas reported that the people of Mecca demanded from Allah's Messenger (may peace be upon him) that he should show them (some) signs (miracles) and he showed them the splitting of the moon. This hadith has been narrated on the authority of Anas through another chain of transmitters.

Book 39, Number 6729:

    Anas reported that the moon was split up in two parts and in the hadith recorded in Abu Dawud, the words are: "The moon was split up into two parts during the life of Allah's Messenger (may peace be upon him)."

Book 39, Number 6730:

    Ibn 'Abbas reported that the moon was split up during the lifetime of Allah's Messenger (may peace he upon him).

Chapter 9 :THERE IS NONE TO SHOW MORE PATIENCE THAN ALLAH, THE EXALTED AND GLORIOUS, ON ATTRIBUTING WRONG THINGS TO HIM

Book 39, Number 6731:

    AbU Musa reported that Allah's Messenger (may peace be upon him) said: There is none to show more patience at listening to the most irksome things than Allah, the Exalted and Glorious.' Partnership is associated to Him (polytheism). and (fatherhood) of a child is attributed to HiM, but in spite of this He protects them (people) and provides them sustenance. This hadith has been transmitted on the authority of Abu Muas with a slight variation of wording.

Book 39, Number 6732:

    Abdullah b. Qais reported from Allah's Messenger (may peace be upon him) that none is more forbearing in listening to the most irksome things than Allah, the Exalted. They associate rivals with him, attribute sonhood to Him, but in spite of this He provides them sustenance, grants them safety, confers upon them so many things.

Book 39, Number 6733:

    Anas b. Malik reported Allah's Messenger (may peace be upon him) as saying: Allah, the Exalted and High, would say to one who shall have to undergo the least torture (on the Day of Resurrection): Would you like to go as ransom if you had all worldly riches; he would say: Yes. Allah would say to him: When you were in the loins of Adam, I demadded from you something easier than this that you should not associate anything with Me. (The narrator says): I think He also said: I would not cause you to enter Hell-Fire but you defied and attributed Divinity (to others besides Me).

Book 39, Number 6734:

    This hadith has been narrated on the authority of Anas b. Malik through another chain of transmitters, but with a slight variation of wording (and the words are): I shall cause him to enter Hell." (The words subsequent to these) have not been mentioned.

Book 39, Number 6735:

    Anas b. Malik reported that Allah's Messenger (may peace be u n him) said: It would be said to the non-believers on the Day of Resurrection: If you were to possess gold, filling the whole earth, would you like to secure your freedom by paying that? He would say: Yes. Thereupon it would be said to him: Something easier (than this) was demanded from you (but you paid no heed to it).

Book 39, Number 6736:

    Anas reported this hadlth through another chain of transmitters and the words are: "It would be said to him: You have told a lie; what had been demanded from you was quite easier than this (the belief in the Oneness of Allah)."

Chapter 10 :THE NON-BELIEVERS WOULD BE MADE TO CRAWL ON THEIR FACES

Book 39, Number 6737:

    Anas b. Malik reported that a person said: Allah's Messenger, how the non-believers would be made to assemble on the Day of Resurrection (by crawling) on their faces? Thereupon he said: Is He Who is powerfnl to make them walk on their feet is not powerful enough to make them (crawl) upon their faces on the Day of Resurrection? Qatada said: Of conrse, it is so. (He adjured): By the might of our Lord.

Chapter 11 : DIPPING OF THE MOST AFFLUENT PEOPLE OF THE WORLD IN THE HELL-FIRE AND DIPPING OF THE MOST (WORLDLY) MISERABLE IN PARADISE

Book 39, Number 6738:

    Anas b. Malik reported that Allah's Messenger (may peace be upon him) said that one amongst the denizens of Hell who had led a life of ease and plenty amongst the people of the world would be made to dip in Fire only once on the Day of Resurrection and then it would be said to him: O, son of Adam, did you find any comfort, did you happen to get any material blessing? He would say: By Allah, no, my Lord. And then that person from amongst the persons of the world be brought who had led the most miserable life (in the world) from amongst the inmates of Paradise .and he would be made to dip once in Paradise and it would be said to him. 0, son of Adam, did you face,any hardship? Or had any distress fallen to your lot? And he would say: By Allah, no, 0 my Lord, never did I face any hardship or experience any distress.

Book 39, Number 6739:

    Anas b. Malik reported that Allah's Messenger (may peace be upon him) said: Verily, Allah does nut treat a believer unjustly in regard to his virtues. He would confer upon him (His blessing) in this world and would give him reward in the Hereafter. And as regards a non-believer. he would be made to taste the reward (of virtue in this world) what as has done for himself so much that when it would be the Hereafter. he would find no virtue for which he should be rewarded.

Book 39, Number 6740:

    Anas b. Malik reported that Allah's Messenger (may peace be upon him) thus told him: When a non-believer does good he is made to taste Its reward in this world. And so far as the believer is concerned, Allah stores (the reward) of his virtues for the Hereafter and provides him sustenance in accordance with his obedience to Him.

Book 39, Number 6741:

    This hadith has been narrated on the authority of Anas b. Malik through another chain of transmitters.

Chapter 12 :THE SIMILITUDE OF A BELIEVER AND A NON-BELIEVER

Book 39, Number 6742:

    Abu Huraira reported Allah's Messenger (may peace be upon him) as saying: The Similitude of a believer is that of (a standing) crop which the air continues to toss from one side to another; in the same way a believer always (receives the strokes) of misfortune. The similitude of a hypocrite is that of a cypress tree which does not move until it is uprooted.

Book 39, Number 6743:

    This badith has been narrated on the authority of Zuhri with the same chain of transmitters, but with a slight variation of wording.

Book 39, Number 6744:

    Ka'b reported that Allah's Messenger (may peace be upon him) said that the similitude of a believer is that of a standing crop in a field which is shaken by wind and then it comes to its original position but it stands at its roots. The similitude of a non-believer is that of a cypress tree which stands on its roots and nothing shakes it but it is uprooted (with) one (violent stroke).

Book 39, Number 6745:

    Ka'b b. Malik reported on the authority of his father that the similitude of a believer is that of a standing crop. The wind sometimes shakes it and sometimes raises it up and then it comes to its destined end. And the similitude of a hypocrite is that of a cypress tree which is not affected by anything but is uprooted once for all. This badith has been narrated through another chain, of transmitters also.

Book 39, Number 6746:

    This hadith has been narrated on the authority of Ibn Ka'b through another chain of transmitters but with a slight variation of wording.

Chapter 13 : THE BELIEVER IS LIKENED TO THE DATE-PALM TREE

Book 39, Number 6747:

    'Abdullah b. Umar reported that Allah's Messenger (may peace be upon him) said: There is a tree amongst trees, the leaves of which do not wither and that is like a Muslim; tell me which that (tree) can be? The people began to think of the trees of the forest. Abdullah said: I thought that it could be the date-palm tree, but I felt hesitant (to say that). They (the Companions) then said: Allah's Messenger, (kindly) tell us which that can be? Thereupon he said:It is the date-palm tree. I made a mention of that to 'Umar, whereupon he said: Had you said that it meant the date-palin tree, this statement of yours (would have been dearer to me) than such and such things.

Book 39, Number 6748:

    Ibn Umar reported that Allah's Messenger (may peace be upon him) one day said to his Companions: Tell me about a tree which has resemblance with a believer. The people began to mention (different) trees of the forest. Ibn 'Umar said: It was instilled in my mind or in my heart and it stuck therein that it implied the date- palm tree. I made up my mind to make a mention of that but could not do that because of the presence of the elderly people there. When there was a hush amongst them (after they had expressed their views), Allah's Messenger (may peace be upon him) said: It Is the date-palm tree.

Book 39, Number 6749:

    Mujahid said: (I have had the privilege) of accompanying Ibn 'Umar up to Medina but I did not hear him narrate anything from Allah's Messenger (may peace be upon him) except one hadith. And he said: We were in the presence of Allah's Messenger (may peace be upon him) that there was brought to him the kernel of a date. The rest of the hadith is the same.

Book 39, Number 6750:

    Mujahid reported: I heard Ibn 'Umar as saying: There was brought to Allah's Messenger (may peace be upon him) the kernel. The rest of the hadith is tile same.

Book 39, Number 6751:

    Ibn Umar reported: We were'in the company of Allah's Messenger (may peace be upon him) that he said: Tell me of a tree which has resemblance to a Muslim and the leaves of which do not wither. Ibrahim said that perhaps Imam Muslim had stated like this: It constantly bears fruit but I have, however, seen [It does not bear fruit constantly]. Ibn Umar said: It crossed my mind that it could be the date-palm tree, but as I saw Aba Bakr and Umar observe silence, I did not deem it fit that I should speak or I should say something. 'Umar said: Had you said so, it would have been dearer to me than such and such thing.

Chapter 14 :THE MISCHIEF OF SATAN IN THE MUSLIM SOCIETY AND SENDING HIS DETACHMENTS FOR THE CREATION OF TURMOIL, AND THERE IS A DEVIL ATTACHED TO EVERY PERSON

Book 39, Number 6752:

    Jabir reported: I heard Allah's Apostle (may peace be upon him) as saying: Verily, the Satan has lost all hopes that the worshippers would ever worship (him) in the peninsula of Arabia, but he (is hopeful) that he would sow the seed of dissension amongst them.

Book 39, Number 6753:

    This hadith has been narrated on the authority of A'mash with the same chain of transmitters.

Book 39, Number 6754:

    Jabir reported: I heard Allah's Messenger (way peace be upon him) as saying: The throne of Iblis is upon the ocean and he sends detachments (to different parts) inorder to put people to trial and the most important figure in his eyes is one who is most notorious in sowing the seed of dissension.

Book 39, Number 6755:

    Jabir reported that Allah's Messenger (may peace be upon him) said: Iblis places his throne upon water; he then sends detachments (for creating dissension); the nearer to him in tank are those who are most notorious in creating dissension. One of them comes and says: I did so and so. And he says: You have done nothing. Then one amongst them comes and says: I did not spare so and so until I sowed the seed of discord between a husband and a wife. The Satan goes near him and says: 'You have done well. A'mash said: He then embraces him.

Book 39, Number 6756:

    Jabir reported that Allah's Apostle (may peace be upqn him) said: The Satan sends detachments of his own in order to put people to trial and the highest in rank, in his eyes, is one who is most notorious in sowing the seed of dissension.

Book 39, Number 6757:

    Abdullah b. Mas'ud reported that Allah's Messenger (may peace be upon him) said: There is none amongst you with whom is not an attache from amongst the jinn (devil). They (the Companions) said: Allah's Messenger, with you too? Thereupon he said: Yes, but Allah helps me against him and so I am safe from his hand and he does not command me but for good.

Book 39, Number 6758:

    This hadith has been narrated on the authority of Mansiir with the same chain of transmitters but with a slight variation of wording.

Book 39, Number 6759:

    A'isha the wife of Allah's Apostle (may peace be upon him), reported that one day Allah's Messenger (may peace be upon him) came out of her (apartment) during the night and she felt jealous. Then he came and he saw me (in what agitated state of mind) I was. He said: A'isha, what has happened to you? Do you feel jealous? Thereupon she said: How can it he (that a woman like me) should not feel jealous in regard to a husband like you. Thereupon Allah's Messenger (may peace be upon him) said: It was your devil who had come to you, and she said: Allah's Mes- senger, is there along with me a devil? He said: Yes. I said: Is devil attached to everyone? He said: Yes. I (Aisha) again said: Allah's Messenger, is it with you also? He said: Yes, but my Lord has helped me against him and as such I am ab solutely safe from his mischief.

Chapter 15 : NONE WOULD ATTAIN SALVATION BECAUSE OF HIS DEEDS BUT IT IS THROUGH LORD'S MERCY(THAT HE WOULD ATTIAN THAT)

Book 39, Number 6760:

    Abu Huraira reported Allah's Messenger (may peace be upon him) as saying: None amongst you would attain salvation purely because of his deeds. A person said: Allah's Messenger, even you also. Thereupon he said: Yes. Not even I, but that Allah wraps me in Mercy, but you should act with moderation.This badith has been transmitted on the authority of Bukair b. al-Ashajj with a slight variation of wording.

Book 39, Number 6761:

    Abu Huraira reported Allah's Messenger (may peace be upon him) as saying: There is none whose deeds alone would entitle him to get into Paradise. It was said to him: And, Allah's Messenger, not even you? Thereupon he said: Not even I, but that my Lord wraps me in Mercy.

Book 39, Number 6762:

    Abu Huraira reported Allah's Messenger (may peace be upon him) as saying: There is none amongst you whose deeds alone would attain salvation for him. They (the Companions) said: Allah's Messenger, not even you? He (the Holy Prophet) said: Not even I, but that Allah wraps me in Mercy and He grants me pardon. Ibn 'Aun pointed towards his head with his hand saying: Not even I, but that Allah wraps me in His Forgiveness and Mercy.

Book 39, Number 6763:

    Abu Huraira reported Allah's Messenger (may peace be upon him) as saying: There is none whose deeds alone can'secure salvation for him. They said: Allah's Messenger, not even you? Thereupon he said: Not even I, but that,the Mercy of Allah should take hold of me.

Book 39, Number 6764:

    Abu Huraira reported Allah's Messenger (may peace be upon him) as saying: None amongst you can get. into Paradise by virtue of his deeds alone. They said: Allah's Messenger, not even you? Thereupon he said: Not even I, but that Allah should wrap me in His Grace and Mercy.

Book 39, Number 6765:

    Abu Huraira reported Allah's Messenger (may peace be upon him) as saying: Observe moderation in deeds (and if it is not possible, try to be near moderation) and understand that none amongst you can attain salvation because of his deeds alone. They said: Allah's Messenger, not even you? Thereupon he said: Not even I, but that Allah should wrap me in His Mercy and Grace.

Book 39, Number 6766:

    This hadith has been narrated on the authority of Jabir through another chain of transmitters.

Book 39, Number 6767:

    A hadith like this has been narrated on the authority of A'mash through two other chains of transmitters. The wording is, however, the same.

Book 39, Number 6768:

    This hadith has been narrated on the authority of Abu Huraira through another chain of transmitters with this addition: "Give them glad tidings".

Book 39, Number 6769:

    Jabir reported: I heard Allah's Apoetle (may peace be upon him) as saying: None of you would get into Paradise because of his good deeds alone, and he would not be rescued from Fire, not even I, but because of the Mercy of Allah.

Book 39, Number 6770:

    A'isha, the wife of Allah's Apostle (may peace be upon him), reported that Allah's Messenger (may peace be upon him) used to say: Observe moderation (in doing deeds), and if yciu fail to observe it perfectly, try to do as much as you can do (to live up to this ideal of moderation) and be happy for none would be able to get into Paradise because of his deeds alone.They (the Companions of the Holy Prophet) said: Allah's Messenger, not even thou? Thereupon he said: Not even I, but that Allah wraps me in His Mercy, and bear this in mind that the deed loved most by Allah is one which is done constantly even though it is insignificant.

Book 39, Number 6771:

    This badith has been narrated on the authority of Musa b. 'Uqba with the same chain of transmitters and he did not make a mention of: "Be happy".

Chapter 16 :THE DOING OF GOOD DEEDS VERY FREQUENTLY AND PUTTING ONE'S BEST EFFORTS IN DEVOTION TO ALLAH

Book 39, Number 6772:

    Mughira b. Shu'ba reported that Allah's Apostle (may peace be upon him) worshipped so much that his feet were swollen. It was said to him: (Why do you undergo so much hardship despite the fact that) Allah has pardoned for you your earlier and later sins? Thereupon he said: May I not (prove myself) to be a grateful servant (of Allah)?

Book 39, Number 6773:

    This hadith has been transmitted on the authority of Mughira b. Shu'ba and the words are: Allah's Apostle (may peace be upon him) kept standing in prayer (for such long hours) that his feet were swollen. They (his Companions) said: Verily, Allah has pardoned for thee the earlier and the later of thine sins. Thereupon he said: Should I not prove myself to be a grateful servant (of Allah)?

Book 39, Number 6774:

    A'isha reported that when Allah's Messenger (may peace be upon him) occupied himself in prayer, he observed such a (long) qiylm (posture of standing in prayer) that his feet were swollen. A'isha said: Allah's Messenger you do this (in spite of the fact) that your earlier and later sins have been pardoned for you? Thereupon, he said. A'isha should I not prove myself to be a thanksgiving servant (of Allah)?

Chapter 17 :MODERATION IN GIVING SERMON

Book 39, Number 6775:

    Shaqiq reported: We were sitting at the door of Abdullah (b. Mas'ud) waiting for him (to come out and deliver a sermon to us). It was at this time that there happened to pass by us Yazid b. Mu'awiya an-Nakha'i. We said: Inform him ('Abdullah b. Mas'ud) of our presence here. He went in and Abdullah b. Mas'ud lost no time in coming out to us and said:I was informed of your presence here but nothing hindered me to come out to you but the fact that I did not like to bore you (by stuffing your minds with sermons) as Allah's Messenger (may peace be upon him) did not deliver us sermon on certain days fearing that it might prove to be boring for us.

Book 39, Number 6776:

    This hadith has been narrated on the authority of 'Abdullah through other chains of transmitters.

Book 39, Number 6777:

    Shaqiq b. Wi'il reported that 'Abdullah used to give us sermon on every Thursday. A person said: Abu 'Abd al-Rahman, we love your talk and so we yearn (to listen to you) and earnestly desire that you should deliver us lecture every day. Thereupon he said: There is nothing to hinder me in giving you talk (every day) but the fact that you may be bored. Allah's Messenger (may peace be upon him) did not deliver sermons on certain days (fearing that we might be bored).


Book 40: The Book Pertaining to Paradise, Its Description, Its Bounties and Its Intimates (KITAB AL-JANNAT WA SIFAT NA'IMIHA WA AHLIHA)

KITAB AL-JANNAT WA SIFAT NA'IMIHA WA AHLIHA
(Book pertaining to paradise, its description, its bounties and its intimates)

Back
Chapter 1 :BOOK PERTAINING TO PARADISE, ITS DESCRIPTION, ITS BOUNTIES AND ITS INTIMATES

Book 40, Number :6778

    Anas b. Malik reported: The Paradise is surrounded by hardships and the Hell-Fire is surrounded by temptations.

Book 40, Number 6779:

    This hadith has been narrated on the authority of Abu Huraira through another chain of transmitters.

Book 40, Number 6780:

    Abu Huraira reported Allah's Apostle (may peace be upon him) as saying that: Allah the Exalted and Glorious, said: I have prepared for My pious servants which no eye has ever seen, and no ear has ever heard, and no human heart has ever perceived but it is testified by the Book of Allah. He then recited: "No soul knows what comfort has been concealed from them, as a reward for what they did". (xxxii.17)

Book 40, Number 6781:

    Abu Huraira reported that Allah's Apostle (may peace be upon him) said: Allah, the Exalted and Glorious, said: I have prepared for My pious servants which no eye (has ever) seen, no ear has (ever) heard and no human heart has ever perceived those bounties leaving apart (those bounties) about which Allah has informed you.

Book 40, Number 6782:

    Abu Huraira reported Allah's Messenger (may peace be upon him) said that Allah, the Exalted and Glorious, said: I have prepared for My pious servants which the eye has seen not, and the ear has heard not and no human heart has ever perceived such bounties leaving aside those about which Allah has informed you. He then recited: "No soul knows what comfort has been hidden for thein".

Book 40, Number 6783:

    Sahl b. Sa'd as-Sa'idi reported: I was in the company of Allah's Messenger (may peace be upon him) that he gave a description of Paradise and then Allah's Apostle (may peace be upon him) concluded with these words: There would be bounties which the eye has not seen and the ear has not heard and no human heart has ever perceived them. He then recited this verse: "They forsake (their) beds, calling upon their Lord in fear and in hope, and spend out of what We have given them. So no soul knows what refreshment of the eyes is hidden for them: a reward for what they did" (xxxii. 16-17)

Chapter 2 :THERE IS IN PARADISE A TREE UNDER THE SHADOW OF WHICH A RIDER CAN TRAVEL FOR A HUNDRED YEARS AND EVEN THEN HE WOULD NOT BE ABLE TO COVER IT

Book , Number :6784

    Abu Huraira reported Allah's Messenger (may peace be upon him) as saying: In Paradise, there is a tree under the shadow of which a rider can travel for a hundred years.

Book 40, Number 6785:

    This hadith has been narrated on the authority of Abu Huraira through another chain of transmitters with the addition of these words: "He will not be able to cover this distance."

Book 40, Number 6786:

    Sahl b. Sa'd reported Allah's Messenger (may peace be upon him) as saying: In Paradise, there is a tree under the shadow of which a rider can travel for a hundred years without covering (the distance) completely. This hadith has also been transmitted on the authority of Abu Sa'id al-Khudri that Allah's Apostle (may peace be upon him) is reported to have said: In Paradise, there is a tree under the shadow of which a rider of a fine and swift-footed horse would travel for a hundred years without covering the distance completely. There would be the pleasure of Allah for the inmates of Paradise and He would never be annoyed with them.

Book 40, Number 6787:

    Abu Sa'id al-Khudri reported that Allah's Apostle (may peace be upon him) said that Allah would say to the inmates of Paradise: O, Dwellers of Paradise, and they would say in response: At thy service and pleasure, our Lord, the good is in Thy Hand. He (the Lord) would say: Are you well pleased now? They would say: Why should we not be pleased, O Lord, when Thou hast given us what Thou hast not given to any of Thy creatures? He would, however, say: May I not give you (something) even more excellent than that? And they would say: 0 Lord, what thing can be more excellent than this? And He would say: I shall cause My pleasure to alight upon you and I shall never be afterwards annoyed with you.

Chapter 3 :THE INMATES OF PARADISE WOULD SEE THE INMATES OF THE UPPER APARTMENT AS ARE SEEN THE PLANETS IN THE SKY

Book 40, Number 6788:

    Sahl b. Sa'd reported Allah's Messenger (may peace be upon him) as saying: The inmates of Paradise will look to the upper apartment of Paradise as you see the planets in the sky. I narrated this hadith to Nu'man b. Abi 'Ayyash and he said: I heard Abu Sa'id al-Khudri as saying: As you see the shining planets in the eastern and western (sides of) horizon.

Book 40, Number 6789:

    This hadith has been narrated on the authority of Abu Hazim through another chain of transmitters.

Book 40, Number 6790:

    Abu Sa'id al-Khudri reported Allah's Messenger (may peace be upon him) as saying: The inmates of Paradise would see the inmates of the apartment over them just as you see the shining planets which remain in the eastern and the western horizon because of the superiority some have over others. They said : Allah's Messenger, would in these abodes of Apostles others besides them not be able to reach? He said: Yes, they will, by Him, in Whose hand is my life, those who believe in God and acknowledge the Truth, will reach them.

Chapter 4 : HE WHO WOULD LOVE TO HAVE A GLIMPSE OF THE SACRED FACE OF THE HOLY PROPHET (MAY PEACE BE UPON HIM) EVEN AT THE COsT OF HIS WHOLE PROPERTY AND HIS FAMILY

Book 40, Number 6791:

    Abu Huraira reported Allah's Messenger (may peace be upon him) as saying: The people most loved by me from amongst my Ummah would be those who would come after me but everyone amongst them would have the keenest desire to catch a glimpse of me even at the cost of his family and wealth.

Chapter 5 :THERE IS A STREET IN PARADISE WHERE THE INMATES OF PARADISE WOULD GET FAVOUR AND GRACE

Book 40, Number 6792:

    Anas b. Malik reported that Allah's Messenger (may peace be upon him) said: In Paradise there is a street to which they would come every Friday. The north wind will blow and would scatter fragrance on their faces and on their clothes and would add to their beauty and loveliness, and then they would go back to their family after having an added lustre to their beauty and loveliness, and their family would say to them: By Allah, you have been increased in beauty and loveliness after leaving us, and they would say: By Allah, you have also increased in beauty and loveliness after us.

Chapter 6 :THE FIRST GROUP THAT WOULD BE ADMITTED TO PARADISE WOULD BE LIKE THE FACE OF THE FULL MOON AND THE DESCRIPTION OF THEIR QUALITIES AND THEIR SPOUSES

Book 40, Number 6793:

    Muhammad reported that some (persons) stated with a sense of pride and some discussed whether there would be more men in Paradise or more women. It was upon this that Abu Huraira reported that Abu'l Qasim (the Holy Prophet) (may peace be upon him) said: The (members) of the first group to get into Paradise would have their faces as bright as full moon during the night, and the next to this group would have their faces as bright as the shining stars in the sky, and every person would have two wives and the marrow of their shanks would glimmer beneath the flesh and there would be none without a wife in Paradise.

Book 40, Number 6794:

    This hadith has been narrated on the authority of Abu Huraira through another chain of transmitters.

Book 40, Number 6795:

    This hadith has been narrated on the authority of Abu Huraira through another chain of transmitters that Allah's Messenger (may peace be upon him) said: The (members of the) first group which would get into Paradise will have their faces as bright as stars in the sky. They would neither pass water, nor void excrement, nor will they suffer from catarrh, nor will they spit, and their combs would be made of gold, and their sweat will be musk, the fuel of their brazier will be aloes, and their wives will be large-eyed maidens and their form would be alike as one single person after the form of their father (Adam) sixty cubits tall.

Book 40, Number 6796:

    Abu Huraira reported Allah's Messenger (may peace be upon him) as saying: The first group of my Ummah to get into Paradise would be like a full moon in the night. Then those who would be next to them; they would be like the most significantly glittering stars in regard to brightness, then after them (others) in ranks. They would neither void excrement, nor pass water, nor suffer from catarrh, nor would they spit. And their combs would be made of gold, and the fuel of their braziers would be aloes and their sweat would be musk and their form would be the form of one single person according to the length of their father sixty cubits tall. This hadith has been transmitted on the authority of Ibn Abi Shaiba with a slight variation of wording.

Chapter 7:THE DESCRIPTION OF PARADISE AND THE REMEMBRANCE OF ALLAH BY ITS INMATES MORNING AND EVENING

Book 40, Number 6797:

    Hammam b. Munabbih reported: These are some of the ahidith which Abu Huraira reported from Allah's Messenger (may peace be upon him) and one is this that he is reported to have said: The (members of the) first group that would be admitted to Paradise would have their faces as bright as full moon during the night. They would neither spit nor suffer catarrh, nor void excrement. They would have their utensils and their combs made of gold and silver and the fuel of their braziers would be aloes and their sweat would be musk and every one of them would have two spouses (so beautiful) that the marrow of their shanks would be visible through the flesh. There would be no dissension amongst them and no enmity in their hearts. Their hearts would be like one heart, glorifying Allah morning and evening.

Book 40, Number 6798:

    Jabir reported: I heard Allah's Apostle (may peace be upon him) as saying that the inmates of Paradise would eat and drink but would neither spit, nor pass water, nor void excrement, nor suffer catarrah. It was said: Then, what would happen with food? Thereupon he said: They would belch and sweat (and it would be over with their food), and their sweat would be that of musk and they would glorify and praise Allah as easily as you breathe.

Book 40, Number 6799:

    This hadith has been transmitted on the authority of A'mash with a slight variation of wording.

Book 40, Number 6800:

    Jabir b. Abdullah reported that Allah's Messenger (may peace be upon him) said that the inmates of Paradise would eat therein and they would also drink, but they would neither void excrement, nor suffer catarrh, nor pass water, and their eating (would be digested) in the form of belching and their sweat would be musk aged they would glorify and praise Allah as easily ai you breathe.

Book 40, Number 6801:

    This hadith has been transmitted on the authority of Jabir with a slight variation of wording.

Chapter 8:THE EVERLASTING BLISS FOR THE INMATES OF PARADISE

Book 40, Number 6802:

    Abu Huraira reported Allah's Apostle (may peace be upon him) as saying: He who would get into Paradise (would be made to enjoy such an everlasting) bliss that he would neither become destitute, nor would his clothes wear out, nor his youth would decline.

Book 40, Number 6803:

    Abu Sa'id al-Khudri and Abu Huraira both reported Allah's Messenger (may peace be upon him) as saying: There would be an announcer (in Paradise) who would make this announcement: Verily I there is in store for you (everlasting) health and that you should never fall ill and that you live (for ever) and do not die at all. And that you would remain young and never grow old. And that you would always live in affluent circumstances and never become destitute, as words of Allah, the Exalted and Glorious, are: "And it would be announced to them: This is the Paradise. You have been made to inherit it for what you used to do".(VII; 43)

Chapter 9:THE DESCRIPTION OF THE TENTS FOR THE INMATES OF PARADISE

Book 40, Number 6804:

    Abu Bakr b. Abdullah b. Qais reported on the authority of his father that Allah's Messenger (may peace be upon him) said that in Paradise there would be for a believer a tent of a single hollowed pearl the breadth of which would be sixty miles. It would be meant for a believer and the believers would go around it and none would be able to see the others.

Book 40, Number 6805:

    Abu Bakr b. Abdullah b. Qais reported on the authority of his father that Allah's Messenger (may peace be upon him) said that in Paradise there would be a tent made of a single hollowed pearl, the breadth of which would be sixty miles from all sides and there would live a family in each corner and the other would not be able to see the believer who goes around them.

Book 40, Number 6806:

    This hadith has been transmitted on the authority of Abu Bakr b. Abu Musa b. Qais who, on the authority of his father, reported the Apostle (may peace be upon him) to have said that there would be a tent made of a pearl whose height towards the sky would be sixty miles. In each corner, there would be a fanaily of the believer, out of sight for the others.

Chapter 10:WHAT RIVERS OF THE WORLD WOULD BE FOUND IN PARADISE

Book 40, Number 6807:

    Abu Huraira reported Allah's Messenger (may peace be upon him) as saying: Saihan, Jaihan, Euphrates and Nile are all among the rivers of Paradise.

Chapter 11:THERE WOULD ENTER PARADISE SOME PEOPLE WHOSE HEARTS WOULD BE'LIKE THOSE OF BIRDS

Book 40, Number 6808:

    Abu Huraira reported Allah's Messenger (may peace be upon him) as saying: There would enter Paradise people whose hearts would be like those of the hearts of birds.

Book 40, Number 6809:

    Abu Huraira reported Allah's Messenger (may peace be upon him) as saying: Allah, the Exalted and Glorious, created Adam in His own image with His length of sixty cubits, and as He created him He told him to greet that group, and that was a party of angels sitting there, and listen to the response that they give him, for it would form his greeting and that of his offspring. He then went away and said: Peace be upon you ! They (the angels) said : May there be peace upon you and the Mercy of Allah, and they made an addition of "Mercy of Allah". So he who would get into Paradise would get in the form of Adarn, his length being sixty cubits, then the people who followed him continued to diminish in size up to this day.

Chapter 12:THE DESCRIPTION OF HELL AND THE INTENSITY OF ITS HEAT AND TORMENTS

Book 40, Number 6810:

    Abu Huraira reported Allah's Messenger (may peace be upon him) as saying: The Hell would he brought on that da (the Day of judgment) with seventy bridles and every bridle would be controlled by seventy angels.

Book 40, Number 6811:

    Abil Huraira reported Allah's Apostle (may peace be upon him) as seying: The fire which sons of Adam burn is only one-seventieth part of the Fire of Hell. His Companions said: By Allah, even ordinary fire would have been enough (to burn people). Thereupon he said: It is sixty-nine parts in excess of (the heat of) fire in this world each of them being equivalent to their heat.

Book 40, Number 6812:

    This hadith has been narrated on the authority of Abn Huraira through another chain of transmitters with a slight variation of wording.

Book 40, Number 6813:

    Abu Huraira reported: We were in the company of Allah's Messenger (may peace be upon him) that we heard a terrible sound. Thereupon Allah's Apostle (may peace be upon him) said: Do you know what (sound) is this? We said: Allah and His Messenger know best. Thereupon he said: That is a stone which was thrown seventy years before in Hell and it has'been constantly slipping down and now it has reached its base.

Book 40, Number 6814:

    This hadith has been narrated on the authority of Abfi Huraira with the same chain of transmitters but with this change of wording that the Holy Prophet (may.peace be upon him) said: It reached at its base and you heard its sound.

Book 40, Number 6815:

    Samura b. Jundub reported Allah's Apostle (may peace -be upon him) as saying: There will be some to whose ankels the fire will reach, some to whose knees, some to whose waist the fire will reach, and some to whose collar-bone the fire will reach.

Book 40, Number 6816:

    Samura b. Jundub reported Allah's Messenger (may peace be upon him) as saying: There would be among them those to whom the fire will reach up to their ankels and to some of them the fire would reach their knees and to some it would reach their waists and to some it would reach up to their collar-bones.

Book 40, Number 6817:

    This hadith has been narrated on the authority of Sa'id with the same chain of transmitters but with a slight variation of wording.

Chapter 13: THE HAUGHTY AND THE PROUD WOULD GET INTO THE FIRE OF HELL AND THE HUMBLE AND MEEK WOULD GET INTO PARADISE

Book 40, Number 6818:

    Abu Huraira reported Allah's Messenger (may peace be upon him) as say- ing: There was a dispute between the Hell and the Paradise and it (the Hell) said: The haughty and the proud would find abode in me. And the Paradise said: The meek and the humble would find their abode in me. Thereupon Allah, the Exalted and Glorious, (addressing the Hell) said: You are (the means) of My punishment by which I punish those of My servants whom I wish. (And addressing the Paradise) He said: You are only My Mercy by means of which 1 shall show mercy to those whom I wish, but each one of you would be full.

Book 40, Number 6819:

    Abu Huraira reported Allah's Messenger (may peace be upon him) as say- ing : The Hell and the Paradise fell into dispute and the Hell said: I have been dis- tinguished by the proud and the haughty. And the Paradise said: What is the matter with me that the meek and the humble amongst people and the downtrodden and the simple enter me? Thereupon Allah said to the Paradise: You are (the means) of My Mercy whereby I show mercy to those of My servants whom 1 wish, and He said to the Hell: You are (the means) of punishment whereby 1 punish those of My servants whoml wish. Both of you will be full. The Hell will riot be filled up until Allah puts down His foot in it. The Hell would say: Enough, enough, enough, and at that time it will be filled up, all its parts integrated together.

Book 40, Number 6820:

    Abu Huraira reported Allah's Apostle (may peace be upon him) as saying: The Paradise and the Hell disputed with each other. The rest of the hadith is the same.

Book 40, Number 6821:

    Hammam b. Munabbih reported that Abu Huraira narrated to them some ahadith of Allah's Messenger (may peace be upon him) and one of them is this that Allah's Messenger (may peace be upon him) said: The Paradise and the Hell fell into dispute and the Hell said: 1 have been distinguished for accommodating (the haughty and proud in me), and the Paradise said: What is the matter that the meek and the humble and the downtrodden and simple would find an abode in me? Thereupon Allah said to Paradise: You are a (means) of My Mercy. 1 shall show mercy through you to one whom I will from amongst My servants. And lie said to the Hell: You are a (sign) of My chastisement and I shall chastise through you anyone whom I will from amongst My servants and both of you,would be full. And as regards the Hell it would not be full until Allah, the Exalted and Glorious, places His foot therein, and it would say: Enough, enough, enough, and it would be then full and the one part would draw very close to the other one and Allah would not treat unjustly anyone amongst His creation and He would create another creation for the Paradise (to accommodate it).

Book 40, Number 6822:

    Abu Sa'id al-Khudri reported that Allah's Messenger (may peace be upon him) said: The Paradise and the Hell disputed with each other. The rest of the hadith is the same as transmitted by Abu Huraira up to the words'. "It is essential for Me to fill up both of you."

Book 40, Number 6823:

    Anas b. Malik reported that Allah's Apostle (may peace be upon him) said that the Hell would continue to say: Is there anything more, until Allah, the Exalted and High, would place His foot therein and that would say: Enough, enough, by Your Honour, and some parts of it would draw close to the other.

Book 40, Number 6824:

    This hadith has been narrated on the authority of Anas through another chain of transmitters.

Book 40, Number 6825:

    'Abd al-Wahhab b. Ata' reported in connection with the words of Allah, the Exalted and the Glorious: We would say to Hell on the Day of Ressurection: Have you been completely filled up? and it would say: Is there anything -more? And he stated on the authority of Anas b. Malik that Allah's Apostle (may peace be upon him) said: (The sinners) would be thrown therein and it would continue to say: Is there anything more, until Allah, the Exalted and Glorious, would keep His foot there- in and some of its part would draw close to the other and it would say: Enough, enough, by Thy Honour and by Thy Dignity, and there would be enough space in Paradise until Allah would create a new creation and He would make them accommo- date that spare place in Paradise.

Book 40, Number 6826:

    Anas reported Allah's Apostle (may peace be upon him) as saying: There would be left some space in Paradise as Allah would like that to be left. Then Allah would create another creation as He would like.

Book 40, Number 6827:

    Abu Sa'id reported Allah's Messenger (may peace be upon him) as saying: Death would be brought on the Day of Resurrection.in the form of a white-coloured ram. Abu Kuraib made this addition: Then it would be made to stand between the Paradise and the Hell. So far as the rest of the hadith is concerned there is perfect agreement (between the two narrators) and it would be said to the inmates of Paradise: Do you recognise this? They would raise up their necks and look towards it and say: Yes,' it is death. Then it would be said to the inmates of Hell-Fire.. Do you recognise this? And they would raise up their necks and look and say: Yes, it is death. Then command would be given for slaughtering that and then it would be said: 0 inmates of Paradise,,there is an everlasting life for you and no death. And then (addressing) to the inmates of the Hell-Fire, it would be said: 0 inmates of Hell-Fire, there is an everlasting living for you and no death. Allah's Messenger (may peace be u@on him) then recited this verse pointing with his hand to this (material) world: "Warn them, this Day of dismay, and when their affairs would be decided and they would be un- mindful and they believe not" (xix. 39).

Book 40, Number 6828:

    Abu Sa'id reported Allah's Messenger (may peace be upon him) as saying: When the inmates of Paradise would be admitted to Paradise and the inmates of Hell would be admitted to Hell, it would be said (to the inmates of Paradise): 0 inmates of Paradise. The rest of the hadith is the same but with this variation (that he only) said. That is the word of Allah, the Exalted. And he did not say: Then Allah's Mes- senger (may peace be upon him) recited, and he did not make a mention of his having pointed with his hand towards the (material) world.

Book 40, Number 6829:

    Abdullah reported that Allah's Messenger (may peace be upon him) said: Allah would admit the inmates of Paradise into Paradise and the inmates of Hell into Hell. Then the announcer would stand between them and say: 0 inmates of Paradise, there is no death for you, 0 inmates of Hell, there is no death for you. You would live for ever therein.

Book 40, Number 6830:

    Umar b. Muhammad b. Zaid b. 'Abdullah b. 'Umar b. al-Khattab reported on the authority of his father Abdullah b. Umar that Allah's Messenger (may peace big upon him) said: When the inmates of Paradise would go to Paradise and the inmates of Hell would go to Hell, death would be called and it would be placed between the Paradise and the Hell and then slaughtered and then the announcer would announce: 0 inmates of Paradise, no death 0 Inmates of Hell-Fire, no death. And it would in. crease the delight of the inmates of Paradise and it would increase the grief of the inmates of Hell-Fire.

Book 40, Number 6831:

    It is transmitted on the authority of Abu Huraira that Allah's Messenger (may peace be upon him) said: The molar tooth of an unbeliever or the canine teeth of an unbeliever will be like Ubud and the thickness of his skin a three night's journey.

Book 40, Number 6832:

    Abu Huraira reported directly from Allah's Messenger (may peace be upon him) that he said: The distance of the two shoulders of the non-believer in Hell will be a three-day journey for a swift rider.

Book 40, Number 6833:

    Haritha b. Wahb reported that he heard Allah's Apostle (may peace be upon him) as saying: May I not inform you about the inmates of Paradise? They said: Do this, of course. Thereupon Allah's Apostle (may peace be upon him) said: Every humble person who is considered to be humble if he were to adjure In the name of Allah, He would fulfil it. He then said: May I not inform you about the denizens of Hell-Fire? They said: Yes. And he said: Every haughty, fat and proud (person).

Book 40, Number 6834:

    This hadith has been narrated on the authority of Shu'ba with the same chain of transmitters but with a slight variation of wording.

Book 40, Number 6835:

    Haritha b. Wahb al-KhuzaIi reported Allah's Messenger (may peace be upon him) as saying: May I not inform you about the inmates of Paradise? (And then informing about them) said: Every meek person who is considered to be humble and if they were to adjure in the name of Allah, Allah would certainly fulfil it. May I not inform you about the inmates of Hell-Fire? They are all proud, mean and haughty.

Book 40, Number 6836:

    Abu Huraira reported Allah's Messenger (may peace be upon him) as say- ing: Many a people with dishevelled hair are driven away from the door (but they are so pious) that if they are to swear in the name of Allah, He would definitely fulfil that.

Book 40, Number 6837:

    'Abdullah b. Zam'a reported that Allah's Messenger (may peace be upon him) delivered an address and he made a mention of the dromedary and also made a mention of one (base person) who cut off Its hind legs, and he recited: "When the basest of them broke forth with mischief" (xei. 12). When A mischievous person, strong even because of the strength of a family like Abu Zam'a, broke forth. He then delivered instruction in regard to the women saying: There is amongst you who beats his woman, and in the narration on the authority of Abu Bakr, the words are: He flogs her like a slave-girl. And in the narration of Abu Kuraib (the words are): He flogs like a slave and then comforts his bed with the help of that at the end of the day, and he then advised in regard to laughing of people at the breaking of wind and said: One of you laughs at that which you yourself do.

Book 40, Number 6838:

    Abu Huraira reported Allah's Messenger (may peace be upon him) as say- ing: I saw 'Amr b. Luhayy b. Qam'a b. Khindif, brother of Bani Ka'b, dragging his Intestines in Fire.

Book 40, Number 6839:

    Sa'id b. Musayyib explained "al-bahira" as that animal which is not milked but for the idols. and none amongst the people milks them, and "as-sa'iba" as that animal which is let loose for the deities. Nothing is loaded over it, and Ibn Musayyib narrated that Abu Huraira stated that Allah's Messenger (may peace be upon him) said: I saw 'Amr b. 'Amir al-Khuzili dragging his intestines in fire and he was the first who devoted animals to deity.

Book 40, Number 6840:

    Abu Huraira reported Allah's Messenger (may peace be upon him) as saying: Two are the types amongst the denizens of Hell, the one possessing whips like the tail of an ox and they flog people with their help. (The second one) the women who would be naked in spite of their being dressed, who are seduced (to wrong paths) and seduce others with their hair high like humps. These women would not get into Paradise and they would not perceive the odour of Paradise, although its frag- rance can be perceived from such and such distance (from great distance).

Book 40, Number 6841:

    Abu Huraira reported Allah's Messenger (may peace be upon him) as saying: If you survive for a time you would certainly see people who would have whips in their hands like the tail of an ox. They would get up in the morning under the wrath of Allah and they would get into the evening with the anger of Allah.

Book 40, Number 6842:

    Abu Huraira reported Allah's Messenger (may peace be upon him) as saying: If you live for a time, you would certainly see people get up (in the morning) in the wrath of Allah and getting into the evening under the curse of Allah, and there would be in their hands (whips) like the tail of an ox.

Chapter 14: PERTAINING TO THE DESTRUCTION OF THE WORLD AND ASSEMBLING ON THE DAY OF RESURRECTION

Book 40, Number 6843:

    This hadith has been narrated through five different chains of transmitters and all of them are narrated on the authority of Mustaurid, brother of Bani Fihr, that Allah's Messenger (may peace be upon him) said: By Allah, this world (is so insigni- ficant in comparison) to the Hereafter that if one of you should dip his finger-(and wnile saying this Yahyg pointed with his forefinger)-in the ocean and then he should see as to what has stuck to it. This hadith has been narrated through another chain of transmitters also but with a slight variation of wording.

Book 40, Number 6844:

    'A'isha reported that she beard Allah's Messenger (may peace be upon him) as saying: The people would be assembled on the Day of Resurrection barefooted, naked and uncircumcised. I said: Allah's Messenger, will the male and the female be together on the Day and would they be looking at one another? Upon this Allah's Messenger (may peace be upon him) said: 'A'isha, the matter would be too serious for them to look to one another.

Book 40, Number 6845:

    This hadith has been narrated on the authority of Hatim b. Abi Saghira with the same chain of transmitters and there is no mention of the word "uncircum- cised."

Book 40, Number 6846:

    Ibn Abbas reported that he heard Allah's Messenger (may peace be upon him) deliver an address and he was saying that they would meet Allah barefooted, naked and uncircumcised.

Book 40, Number 6847:

    This hadith has been narrated through other chains of transmitters on the authority of Ibn Abbas, (and) the words are: While Allah's Messenger (may peace be upon him) stood up to deliver a sermon, he said: 0 people, Allah would make you assemble barefooted, naked and uncircumcised (and then recited the words of the Qur'an): "As We created you for the first time, We shall repeat it. (It is) a promise (binding) upon us. Lo ! We are to perform it, and the first person who would be clothed on the Day of Resurrection would be (Hadrat) Ibrahim (peace be upon him)" and, behold ! some persons of my Ummah would be brought and taken to the left and I would say: My Lord, they are my companions, and it would be said: You do not know what they did after you, and I would say just as the pious servant (Hadrat 'Isa) said: ,I was a witness regarding them as I remained among them and Thou art a witness over everything, so if Thou chastisest them, they are Thy servants and if Thou for- givest them, Thou art Mighty, Wise" (v. 117-118). And it would be said to him: They constantly turned to their heels since you left them. This hadith has been transmitted on the authority of Waki' and Mu'adh (and the words are): "What new things they fabricated."

Book 40, Number 6848:

    Abu Huraira reported Allah's Apostle (may peace be upon him) as saying, The people will be assembled in three categories. Those desirous (of Paradise), fearing (Hell), coming two upon the came], three upon the camel, four upon the camel, ten upon the camel and the rest will be assembled, Hell-Fire being with them when they are at midday where they would spend the night and where they would spend the morning and where they would spend the evening.

Chapter 15:THE DESCRIPTION OF THE DAY OF RESURRECTION (MAY ALLAH SAVE US FROM ITS TERRORS)

Book 40, Number 6849:

    Ibn 'Umar reported Allah's Apostle (may peace be upon him) as saying: When the people would stand before Allah. the Lord of the worlds, each one of them would stand submerged into perspiration up to half of his ears, and there is no mention of the "day" in the badlth transmitted on the authority of Ibn Muthanni.

Book 40, Number 6850:

    This hadith has been transmitted on the authority of Ibn 'Umar but with a slight variation of wording (and the words are) : "One of them would be completely submerged in perspiration up to half of his ears."

Book 40, Number 6851:

    Abu Huraira reported Allah's Messenger (may peace be upon him) as say- ing: The perspiration would spread on the Day of Resurrection upon the earth to the extent of seventy cubits and it would reach up to their mouths or up to their ears. Thaur is not sure (which words) he used (mouth or ears).

Book 40, Number 6852:

    Miqdad b. Aswad reported: I heard Allah's Messenger (may peace he upon him) as saying: On the Day of Resurrection, the sun would draw so close to the people that there woum be left only a distance of one mile. Sulaim b. Amir said: By Allah, I do not know whether he meant by "mile" the mile of the (material) earth or dn instrument used for applying collyrium to the eye. (The Holy Prophet is, however, reported to have said): The people would be submerged in perspiration according to their deeds, some up to their. knees, Some up to the waist and some would have the bridle of perspiration and, while saying this, Allah's Apostle (may peace be upon him) pointed his hand towards his mouth.

Chapter 16:THE QUALITIES BY WHICH THE INMATES OF PARADISE AND THE DENIZENS OF HELL CAN BE RECOGNISED IN THIS WORLD

Book 40, Number 6853:

    'Iyad b. Him-ar reported that Allah's Messenger (may peace be upon him), while delivering a sermon one day, said: Behold, my Lord commanded me that I should teach you which you do not know and which He has taught me today. (He has instructed thus) : The property which I have conferred upon them is lawful for them. I have created My servants as one having a natural inclination to the worship of Allah but it is Satan who turns them away from the right religion and he makes unlawful what has been declared lawful for them and he commands them to ascribe partnership with Re, although he has no justification for that. And verily, Allah looked towards the people of the world and He showed hatred for the Arabs and the non-Arabs, but with the exception of some remnants from the People of the Book. And He (further) said: I have sent thee (the Holy Prophet) in order to put you to test and put (those to test) through y4Pu. And I sent the Book to you which cannot be washed away by water, so that you may recite it while in the state of wakefulness or sleep. Verily, Allah commanded me to burn (kill) the Quraish. I said: My Lord, they would break my head (like the tearing) of bread, and Allah said: You turn them out as they turned you out, you fight against them and We shall help you in this, you should spend and you would be conferred upon. You send an army and I would send an army five times greater than that. Fight against those who disobey you along with those who obey you. The inmates of Paradise are three: One who wields authority and is just and fair, one who Is truthful and has been endowed with power to do good deeds. And the person who is merciful and kind hearted towards his relatives and to every pious Muslim, and one who does not stretch his hand in spite of having a large family to support. And He said: The inmates of Hell are five: the weak who lack power to (avoid evil), the (carefree) who pursue (everything irrespective of the fact that it is good or evil) and who do not have any care for their family or for their wealth. And those dishonest whose greed cannot be concealed even in the case of minor things. And the third. who betray you. morning and evening, in regard to your family and your property. He also made a mention of the miser and the liar and those who are in the habit of abusing people and using obscene and foul language. Abu Ghassan in his narration did not make mention of "Spend and there would be spent for you."

Book 40, Number 6854:

    This hadith has been narrated on the authority of Qatada with the same chain of transmitters but with a slight variation of wording.

Book 40, Number 6855:

    This hadith has been transmitted on the authority of 'Iyad b. Himar that Allah's Messenger (may peace be upon him) gave an address one day. The rest of the hadith is the same.

Book 40, Number 6856:

    Iyad. b. Himar reported tbat, while Allah's Messenger (may peace be upon him) was delivering an address, he stated that Allah commanded me The rest of the hadith is the same, and there is an addition in it : "Allah revealed to me that we should be humble amongst ourselves and none should show pride upon the others, And it does not behove one to do so, and He also said: There are among you people to follow not caring a bit for their family and property. Qatada said: Abu Abdullah, would this happen ? Thereupon he said: Yes. By Allah, I found this in the days of ignorance that a person grazed the goat of a tribe and did not find anyone but their slave-girl (and he did not spare her) but committed adultery with her.

Chapter 17:THE DEAD WOULD BE SHOWN HIS SEAT IN PARADISE AND HELL, AND THE AFFIRMATION OF THE TORMENT OF THE GRAVE AND SEEKING REFUGE FROM IT

Book 40, Number 6857:

    Ibn 'Umar reported Allah's Messenger (may peace be upon him) as say- ing: When any one of you dies, he is shown his seat (in the Hereafter) morning and evening; if he is amongst the inmates of Paradise (he is shown the seat) from amongst the inmates of Paradise and if he is one from amongst the denizens of Hell (he is shown the seat) from amongst the denizens of Hell, and it would be said to him: That is your seat until Allah raises you on the Day of Resurrection (and sends you to your proper seat).

Book 40, Number 6858:

    Ibn Umar reported that Allah's Apostle (may peace be upon him) said: When a person dies, he is shown his seat morning and evening. If he is one amongst the inmates of Paradise (he is shown his seat) in Paradise and if he is one amongst the denizens of Hell-Fire (he is shown his seat) in the Hell-Fire. Then it is said to him: That is your seat where you would be sent on the Day of Resurrection.

Book 40, Number 6859:

    Abu Sa'id al-Khudri reported: I did not hear this badith from Allah's Apostle (may peace be upon him) directly but it was Zaid b. Thibit who narrated it from him. As Allah's Apostle (may peace be upon him) was going along with us towards the dwellings of Bani an-Najjar, riding upon his pony, it shied and he was about to fall. He found four, five or six graves there. He said: Who amongst you knows about those lying in the graves ? A person said: It is I. Thereupon he (the Holy Prophet) said: In what state did they die ? He said: They died as polytheists. He said : These people are passing through the ordeal in the graves. If it were not the reason that you would stop burying (your dead) in the graves on listening to the torment in the grave which I am listening to, I would have certainly made you hear that. Then turning his face towards us, he said: Seek refuge with Allah from the torment of Hell. They said : We seek refuge with Allah from the torment of Hell. He said: Seek refuge with Allah from the torment of the grave. They said: We seek refuge with Allali from the torment of the grave. He said : Seek refuge with Allah from turmoil, its visible and invisible (aspects), and they said : We seek refuge with Allah from turmoil and its visible and invisible aspects and he said : Seek refuge with Allah from the turmoil of the Dajjal, and they said We seek refuge with Allah from the turmoil of the Dajjal.

Book 40, Number 6860:

    Anas reported Allah's Apostle (may peace be upon him) as saying : If you were not (to abandon) the burying of the dead (in the grave), I would have certainly supplicated Allah that He should make you listen the torment of the grave.

Book 40, Number 6861:

    This hadith has been narrated on the authority of Abu Ayyub through some other chains of transmitters (and the words are) : "Allah's Messenger (may peace be upon him) went out after the sun had set and he heard some sound and said: It is the Jews who are being tormented in their graves.

Book 40, Number 6862:

    Anas b. Malik reported Allah's Apostle (may peace be upon him) having said: When the servant is placed in his grave and his companions retrace their steps arid he hears the noise of the footsteps, then two angels come to him and make him sit and say to him: What you have to say about this person (the Holy Prophet) ? If he is d believer, lie would say: I bear testimony to the fact that he is a servant of Allali and His Messenger. Then it would be said to him: Look to your seat in the Hell- Fire, for Allah has substituted (the seat of yours) with a seat in Paradise. Allah's Messenger (may peace be upon him) said: He would be shown both the seats. Qatada said: It was mentioned to us that his grave (the grave of a believer) expands to seventy cubits and is full with verdure until the Day when they would be resurrected.

Book 40, Number 6863:

    Anas b. Malik reported that Allah's Messenger (may peace be upon him) said: When the dead body. is placed in the grave, he listens to the sound of the shoes (as his friends and relatives return after burying him).

Book 40, Number 6864:

    Anas b. Malik reported that Allah's Apostle (may peace be upon him) said: When the servant is placed in his grave and his friends retrace their steps. The rest of the liadith is the same as transmitted by Qatada.

Book 40, Number 6865:

    Al-Bara' b. 'Azib reported Allah's Apostle (may peace be upon him) as saying: This verse: "Allah grants steadfastness to those who believe with firm word," was rereaied in connection with the torment of the grave. It would be said to him: Who is your Lord? And he would say: Allah is my Lord and Muhammad is my Apostle (may peace be upon him), and that is (what is implied) by the words of Allah, the Exalted: "Allah keeps steadfast those who believe with firm word in this world and in the Hereafter."

Book 40, Number 6866:

    Al-Bara' b. 'Azib reported that this verse: "Allah keeps steadfast those who believe with firm word in th;s world and the Hereafter," was revealed in con- nection with the torment of the grave.

Book 40, Number 6867:

    Abu Huraira reported: When the soul of a believer would go out (of his body) it would be received bv two angels who would take it to the sky. Hammad (one of the narrators in the chain of transmitters) mentioned the swetness of its odour, (and further said) that the dwellers of the sky say: Here comes the pious soul from the side of the earth Let there be blessings of Allah upon the body in which it resides. And it is carried (by the angels) to its Lord, the Exalted and Glorious. He would say: Take it to its destined end. And if he is a nonbeliever and as it (the soul) leaves the body-Hammad made a mention of its foul smell and of its being cursed-the dwellers of the sky say: There comes a dirty soul from the side of the earth, and it would be said: Take it to its destined end. Abu Huraira reported that Allah's Messenger (may peace be upon him) put a thin cloth which was with him upon his nose while making a mention (of the foul smell) of the soul of a non-believer.

Book 40, Number 6868:

    Anas b. Malik reported: We were along with Umar between Mecca and Medina that we began to look for the new moon. And I was a man with sharp eye- sight, so I could see it, but none except me saw it. I began to say to 'Umar: Don't you see it? But he would not see it. Thereupon Umar said: I would soon be able to see it (when it will shine more brightly). I lay upon bed. He then made a mention of the people of Badr to us and said: Allah's Messenger (may peace be upon him) showed us one day before (the actual battle) the place of death of the people (participating) in (the Battle) of Badr and he was saying: This would be the place of death of so and so tomorrow, if Allah wills. Umar said: By Him Who sent him with truth, they did not miss the places (of their death) which Allah's Messenger (may peace be upon him) had pointed for them. Then they were all thrown in a well one after another. Allah's Messenger (may peace be upon him) then went to them and said: O, so and so, the son of so and so; O so and so, the son of so and so, have you found correct what Allah and His Messenger had promised you? I have, however, found absolutely true what Allah had promised with me. Umar said: Allah's Messenger, how are you talking with the bodies without soul in them. Thereupon he said: You cannot hear more distinctly than (their hearing) of what I say, but with this exception that they have not power to make any reply.

Book 40, Number 6869:

    Anas b. Malik reported that Allah's Messenger (may peace be upon him) let the dead bodies of the unbelievers who fought in Badr (lie unburied) for three days. He then came to them and sat by their side and called them and said: O Abu Jahl b. Hisham, O Umayya b. Khalaf, O Utba b. Rab'ila, O Shaiba b. Rabi'a, have you not found what your Lord had promised with you to be correct? As for me, I have found the promises of my Lord to be (perfectly) correct. Umar listened to the words of Allah's Apostle (may peace be upon him) and said: Allah's Messenger, how do they listen and respond to you? They are dead and their bodies have decayed. Thereupon he (the Holy Prophet) said: By Him in Whose Hand is my life, what I am saying to them, even you cannot hear more distinctly than they, but they lack the power to reply. Then'he commanded that they should be buried in the well of Badr.

Book 40, Number 6870:

    Aba Talha reported: When it was the Day of Badr and Allah's Apostle (may peace be upon him) had gained victory over them (the Meccans), he commanded more than twenty persons, and in another hadith these are counted as twenty-four persons, from the non-believers of the Quraish to be thrown into the well of Badr. The rest of the hadith is the same.

Chapter 18: THE RECKONING ON THE DAY OF JUDGMENT IS A FACT

Book 40, Number 6871:

    'A'isha reported that Allah's Messenger (may peace be upon him) said: He who is taken to account on the Day of Resurrection is in fact put to torment. I said: Has Allah, the Exalted and Glorious, not said this: 'He will be made subject to an easy reckoning" (Ixxxiv. 8)? Thereupon he said: (What it implies) is not the actual reckoning, but only the presentation of one's deeds to Him. He who is thoroughly examined in reckoning is put to torment.

Book 40, Number 6872:

    This hadith has been narrated on the authority of Ayyub with the same chain of transmitters.

Book 40, Number 6873:

    'A'isha reported Allah's Apostle (may peace be upon him) as saying: Everyone who is reckoned thoroughly is undone. I said: Allah's Messenger, has Allah not called (reckoning) as easy reckoning? Thereupon he said.. It implies only presenta- tion of (one's deeds to Him), but if one is thoroughly examined in reckoning, he in fact is undone.

Book 40, Number 6874:

    'A'isha reported Allah's Apostle (may peace be upon him) as saying: He who is examined thoroughly In reckoning is undone.

Chapter 19: IT IS ESSENTIAL TO HOPE GOOD FROM ALLAH

Book 40, Number 6875:

    Jabir reported: I heard Allah's Apostle (may peace be upon him) as saying three days before his death: None of you should court death but only hoping good from Allah

Book 40, Number 6876:

    This hadith has been narrated on the authority of A'mash with the same chain of transmitters.

Book 40, Number 6877:

    Jabir b. 'Abdullah al-Ansari reported: I heard Allah's Messenger (may peace be upon him) say three days before his death: None of you should die but hoping only good from Allah, the Exalted and Glorious.

Book 40, Number 6878:

    Jabir reported: I heard Allah's Apostle (may peace be upon him) as saying. Every servant would be raised (in the same very state) in which he dies.

Book 40, Number 6879:

    This hadith has been transmitted on the authority of A'mash but with a slight variation of wording.

Book 40, Number 6880:

    Abdullah b. Umar reported: I heard Allah's Messenger (may peace be upon him) as saying: When Allah intends to chastise a people, He chastises all of them then they would be raised according to their deeds.


BOOK 41: The Book Pertaining to the Turmoil and Portents of the Last Hour (Kitab Al-Fitan wa Ashrat As-Sa`ah)

KITAB AL-FITAN WA ASHRAT AS-SA'AH
(BOOK PERTAINING TO THE TURMOIL AND PORTENTS OF THE LAST HOUR)

Back
Chapter 1 : ...

Book 41, Number 6881:

    Zainab bint Jahsh reported that Allah's Apostle (may peace be upon him) got up from sleep saying: There is no god but Allah; there is a destruction in store for Arabia because of turmoil which is at hand, the barrier of Gog and Magog has opened so much. And Sufyan made a sign of ten with the help of his hand (in order to indicate the width of the gap) and I said: Allah's Messenger, would we be perished in spite of the fact that there would be good people amongst us? Thereupon he said: Of course, but only when the evil predominates.

Book 41, Number 6882:

    This hadith has been narrated on the authority of Zainab bint Jahsh with a slight variation in the chain of transmitters.

Book 41, Number 6883:

    Zainab bint Jahsh, the wife of Allah's Apostle (may peace be upon him), reported that one day Allah's Messenger (may peace be upon him) came out in a state of excitement with his face quite red. And he was saying: There is no god but Allah; there is a destruction in store for Arabia beciuse of the turmoil which is near at hand as the barrier of Gog and Magog has been opened like it, and he (in order to explain it) made a ring with the help o his thumb and forefinger. I said: Allah's Messenger, would we be destroyed despite the fact that there would be pious people amongst us ? He said: Yes, when the evil would predominate.

Book 41, Number 6884:

    This hadith has been narrated oil the authority of Zuhri with a different chain of transmitters.

Book 41, Number 6885:

    Abu Huraira reported Allah's Apostle (may peace be upon him) as saying: Today the wall (barrier) of Gog and Magog has been opened so much, and WUhaib (in order to explain it) made the figure of ninety with the help of his hand.

Chapter 2 : THE SINKING OF AN ARMY IN THE EARTH WHICH WOULD ATTACK THE HOUSE

Book 41, Number 6:

    Harith b Abi Rabi'a and 'Abdullah b. Safwan both went to Umm Salama, the Mother of the Faithful, and they asked her about the army which would be sunk in the earth, and this relates to the time when Ibn Zubair (was the governor of Mecca). She reported that Allah's Messenger (may peace be upon him) had said that a seeker of refuge would seek refuge in the Sacred House and an army would be sent to him (in order to kill him) and when it would enter a plain ground, it would be made to sink. I said: Allah's Messenger, what about him who would be made to accompany this army willy nilly? Thereupon he said: He would be made to sink along with them buf he would be raised on the Day of Resurrection on the basis of his intention. Abu Ja'far said.' This plain,ground means the plain ground of Medina.

Book 41, Number 6887:

    This hadith has been narrated on the authority of 'Abdullah b. Rufai, with the same chain of transmitters (but with the addition of these words) : "When I met Abu Ja'far I told him that she (simply) meant the plain ground. Thereupon Abu Ja'far said : No, by God, she meant the plain ground of Medina.

Book 41, Number 6888:

    Abdullah b. Safwan reported that Hafsa told him that she had heard Allah's Apostle (may peace be upon him) as saying : An army would attack this House in order to fight against the inhabitants of this House and when it would be at the plain ground the ranks in the centre of the army would be sunk and the vanguard would call the rear flanks of the army and they would also be sunk and no flank would be left except some people who would go to inform them (their kith and kin). A person (who had been listening to this badith from Abdullah b. Safwan) said: I bear testimony in regard to you that you are not imputing a lie to Hafsa. And I bear testimony to the fact that Hafsa is not telling a lie about Allah's Apostle (may peace be upon him).

Book 41, Number 6889:

    Abdullah b. Safwan reported the Mother of the Faithful as saying that Allah's Messenger (may peace be upon him) said: They would soon seek protection in this House, viz. Ka'ba (the defenceless), people who would have nothing to protect themselves in the shape of weapons or the strength of the people. An army would be sent to fight (and kill) them and when they would enter a plain ground the army would be sunk in it. Yiisuf (one of the narrators) said: It was a people of Syria (hordes of Hajjaj) who had been on that day comin. towards Mecca for an attack (on 'Abdulllah b. Zubair) and Abdullah b. Safwan said: By God, it does not imply this army.

Book 41, Number 6890:

    'A'isha reported that Allah's Messenger (may peace be upon him) was startled in the state of sleep. We said : Allah's Messenger, you have done something in the state of your sleep which you never did before, Thereupon he said: Strange it is that some, people of my Ummah would attack the House (Ka'ba) (for killing) a person who would belong to the tribe of the Quraish and he would try to seek protection in the House. And when they would reach the plain ground they would be sunk. We said: Allah's Messenger, all sorts of people throng the path. Thereupon he said: Yes, there would be amongst them people who would come with definite designs and those who would come under duress and there would be travellers also, but they would all be destroyed through one (stroke) of destruction. though they would be raised in different states (on the Day of Resurrection). Allah would, however, raise them according to their intention.

Chapter 3 : THE TURMOIL WOULD COME LIKE RAINFALL

Book 41, Number 6891:

    Usama reported that Allah's Messenger (may peace be upon him) climbed up a battlement amongst the battlements of Medina and then said: You do not see what I am seeing and I am seeing the places of turmoil between your houses as tile places of rainfall.

Book 41, Number 6892:

    This hadith has been narrated on the authority of Zuhri with the same chain of transmitters.

Book 41, Number 6893:

    Abu Huraira reported Allah's Messenger (may peace be upon him) as saying: There will be soon a period of turmoil in which the one who sits will be better than one who stands and the one who stands will be better than one who walks and the one who walks will be better than one who runs. He who would watch them will be drawn by them. So he who finds a refuge or shelter against it should make it as his resort.

Book 41, Number 6894:

    This hadith has been transmitted on the authority of Abu Huraira but with this variation of wording that in the hadith transmitted on the authority of Abu Bakr, there is an addition of these words: "There is a prayer among prayers ('Asr) and one who misses it is as if his family and property have been ruined."

Book 41, Number 6895:

    Abu Huraira reported Allah's Apostle (may peace be upon him) as saying: There would be turmoil and the one who would sleep would be better than who would be awake and the one who would be awake would be better than one who would stand and one who would stand would be better than one who would run. So he who finds refuge or shelter should take that refuge or shelter.

Book 41, Number 6896:

    Abu Bakra reported Allah's Messenger (may peace be upon him) as saying: There would soon be turmoil. Behold ! there would be turmoil in which the one who would be seated would be better than one who would stand and the one who would stand would be better than one who would run. Behold ! when the turmoil comes or it appears, the one who has camel should stick to his camel and he who has sheep or goat should stick to his sheep and goat and he who has land should stick to the land. A person said: 'Allah's Messenger, what is your opinion about one who has neither camel nor sheep nor land ? Thereupon, he said : He should take hold of his sword and beat its edge with the help of stone and then try to find a way of escape. O Allah, I have conveyed (Thy Message); O Allah, I have conveyed (Thy Message); O Allah, I have conveyed (Thy Message). A person said: Allah's Messenger, what is your opinion it I am drawn to a rank in spite of myself, or in one of the groups and made to march and a man strikes with his sword or there comes an arrow and kills me ? Thereupon he said: He will bear the punishment of his sin and that of yours and he would be one amongst the denizens of Hell.

Book 41, Number 6897:

    This hadith has been transmitted on the authority of Waki' with a slight variation of wording.

Chapter 4 : WHEN TWO MUSLIMS CONFRONT EACH OTHER WITH SWORDS

Book 41, Number 6898:

    Ahnaf b. Qais reported: I set out with the intention of helping this person (Hadrat 'Ali) that Abu Bakra met me. He said: Ahnaf, where do you intend to go? I said: I intend to help the cousin of Allah's Messenger (may peace be upon him), viz. 'Ali. Thereupon he said to me: Ahnaf, go back, for I heard Allah's Messenger (may peace be upon him) as saying: When two Muslims confront one another with swords (in hands) both the slayer and the slain would be in Fire. He (Ahnaf) said: I said, or it was said: Allah's Messenger, it may be the case of one who kills. but what about the slain (why he would be put in Hell-Fire)? Thereupon he said: He also intended to kill his companion.

Book 41, Number 6899:

    Ahnaf b. Qais reported on the authority of Abu Bakra that Allah's Messenger (may peace be upon him) said: When two Muslims confront each other with their swords, both the slayer and the slain are doomed to Hell-Fire.

Book 41, Number 6900:

    This hadith has been narrated on the authority of Hammad through another chain of transmitters.

Book 41, Number 6901:

    Abu Bakra reported Allah's Messenger (may peace be upon him) as saying: When two Muslims (confront each other) and the one amongst them attacks his brother with a weapon, both of them are at the brink of Hell-Fire. And when one of them kills his companion, both of them get into Hell-Fire.

Book 41, Number 6902:

    Abu Huraira reported Allah's Messenger (may peace be upon him) many ahadith and one of them was this: The last Hour will not come until the two parties (of Muslims) confront each other and there is a large-scale massacre amongst them and the claim of both of them is the same.

Book 41, Number 6903:

    Abu Huraira reported Allah's Messenger (may peace be upon him) as saying: The last Hour will not come unless there is much bloodshed. They said: What is harj? Thereupon he said: Bloodshed. bloodshed.

Chapter 5 : THIS UMMAH WOULD BE DESTROYED BY KILLING ONE ANOTHER

Book 41, Number 6904:

    Thauban reported that Allah's Messenger (may peace be upon him) said: Allah drew the ends of the world near one another for my sake. And I have seen its eastern and western ends. And the dominion of my Unimah would reach those ends which have been drawn near me and I have been granted the red and the white trea- sure and I begged my Lord for my Ummah that it should not be destroyed because of famine, nor be dominated by an enemy who is not amongst them to take their lives and destroy them root and branch, and my Lord said: Muhammad, whenever I make a decision, there is none to change it. Well, I grant you for your Ummah that it would not be destroyed by famine and it would not be dominated by an enemy who would not be amongst it and would take their lives and destroy them root and branch even if all the people from the different parts of the world join hands together (for this purpose), but it would be from amongst them, viz. your Ummah, that some people would kill the others or imprison the others.

Book 41, Number 6905:

    Thauban reported that Allah's Messenger (may peace be upon him) said. Verily, Allah drew the ends of the world near me until I saw its cast and west an He bestowed upon me two treasures, the red and the white. The rest of the hadith is the same.

Book 41, Number 6906:

    'Amir b. Sa'd reported on the authority of his father that one day Allah's Messenger (may peace be upon him) came from a high, land. He passed by the mosque of Banu Mu'awiya, went in and observed two rak'ahs there and we also observed prayer along with him and he made a long supplication to his Lord. He then came to us and said: I asked my Lord three things and He has granted me two but has withheld one. I begged my Lord that my Ummah should not be destroyed because of famine and He granted me this. And I begged my Lord that my Ummah should not be destroyed by drowning (by deluge) and He granted me this. And I begged my Lord that there should be no bloodshed among the people of my Ummah. but He did not grant it.

Book 41, Number 6907:

    Amir b. Sa'd reported on the authority of his father that Allah's Messenger (may peace be upon him) came with a group of his Companions and he passed by the mosque of Banu Mu'awiya. The rest of the hadith is the same.

Chapter 6 : THE EVENTS FORETOLD BY THE HOLY PROPHET (MAY PEACE BE UPON HIM) ABOUT THE LAST HOUR

Book 41, Number 6908:

    Hudhaifa b. al-Yaman reported: By Allah, I have the best knowledge amongst people about every turmoil which is going to appear in the period intervening me and the Last Hour; and it is not for the fact that Allah's Messenger (may peace be upon him) told me something confidentially pertaining to it and he did not tell anybody else about it, but it is because of the fact that I was present in the assembly in which he had been describing the turmoil. and he especially made a mention of three turmoils which would not spare anything and amongst these there would be turmoils like storms in the hot season. Some of them would be violent and some of them would be comparatively mild. Hudhaifa said: All (who were present) except I have gone (to the next world).

Book 41, Number 6909:

    Hudhaifa reported that Allah's Messenger (may peace be upon him) stood before us one day and he did not leave anything unsaid (that he had to say) at that very spot which would happen (in the shape of turmoil) up to the Last Hour. Those who had to remember them preserved them in their minds and those who could not remember them forgot them. My friends knew them and there are certain things which slip out of my mind, but I recapitulate them when anyone makes a mention of them just as a person is lost from one's mind but is recalled to him on seeing his face.

Book 41, Number 6910:

    This hadith has been narrated on the authority of A'mash with the same chain of transmitters up to the words: And he forgot who had to forget that and. he did not make a mention of what follows after this.

Book 41, Number 6911:

    Hudhaifa reported: Allah's Messenger (may peace be upon him) informed me of what is going to happen before the approach of the Last Hour. And there is nothing that I did not ask him in this connection except this that I did not ask him as to what would turn the people of Medina out from Medina.

Book 41, Number 6912:

    This hadith has been narrated on the authority of Shu'ba with the same chain of transmitters.

Book 41, Number 6913:

    Abu Zaid (viz. Amr b. Akhtab) reported: Allah's Messenger (may peace be upon him) led us in the dawn prayer and then mounted the pulpit and addressed us until it was (time for the) noon prayer. He then came down the pulpit and observed prayer and then again mounted the pulpit and again addressed us until it was time for the 'Asr prayer. He then again came down and observed the prayer and again mointed the pulpit and addressed us until the sun was set and he informed (about) everything (pertaining to turmoil) that lay hidden in the past and what lies in (the womb) of) the future and the most learned amongst us is one who remembers them well

Chapter 7 : THE TURMOIL WOULD GO LIKE THE MOUNTING WAVES OF THE OCEAN

Book 41, Number 6914:

    Hudhaifa repotted: We were one day in the company of 'Umar that he said: Who amongst you has preserved in his mind most perfectly the hadith of Allah's Messenger (may peace be upon him) in regard to the turmoil as he told about it? I said: It is I. Thereupon he said: You are bold (enough to make this claim). And he further said: How? I said: I heard Allah's Messenger (may peace be upon him) as saying: There would (first) be turmoil for a person in regard to his family, his property, his own self, his children, his neighbours (and the sins comnaitted in their connection) would be expiated by fasting, prayer, charity, enjoining good and prohibiting evil. Thereupon 'Umar said: I do not mean (that turmoil on a small scale) but that one which would eme-ge like the mounting waves of the ocean. I said: Commander of the Faithful, you have nothing to do with it, for the door is closed between you and that. He said: Would that door be broken or opened? I said: No, it would be broken. Thereupon he said: Then it would not be closed despite best efforts. We said to Hudhaifa: Did Umar know the door? Thereupon he said: Yes, he knew it (for certain) just as one knows that night precede the next day. And I narrated to him something in which there was nothing fabricated. Shaqiq (one of the narrators) said: We dared not ask Hudhaifa about that door. So we requested Masrdq to ask him. So he asked him and he said: (By that door, he meant) 'Umar.

Book 41, Number 6915:

    This hadith has been narrated on the authority of Hudhaifa through other chains of transmitters also.

Book 41, Number 6916:

    Hudhaifa reported that Umar said: Who would narrate to us (the ahadith pertaining to turmoil) and he reported a badith similar to these ahadith.

Book 41, Number 6917:

    Jundub reported: I came on the day of Jara'a that a person was (found) sitting. I said: They would shed their blood today. That person said: By Allah. not at all. I said: By Allah, of course, they would do it. He said: By Allah, they would not do it. I said: By Allah, of course, they would do it. He said: By Allah, they would not do it, and I have heard a hadith of Allah's Messenger (may peace be upon him) which I am narrating to you in this connection. I said: You are a bad seat fellow. I have been opposing you since morning and you are listening to me in spite of the fact that you have heard a hadith from Allah's Apostle (may peace be upon him) (contrary to ray statement). I myself felt that there was no use of this annoyance. (He could tell me earlier that it was a hadith of the Holy Prophet (may peace be upon him], and I would not have opposed him at all.) I turned my face toward him and asked him and he was Hadrat Hudhaifa.

Chapter 8 : THE LAST HOUR WOULD NOT COME UNTIL THE EUPIIRATES UNCOVERS A TREASURE OF GOLD

Book 41, Number 6918:

    Abu Huraira reported Allah's Messenger (may peace be upon him) as saying: The Last Hour would not come before the Euphrates uncovers a mountain of gold, for which people would fight. Ninety-nine out of each one hundred would die but every man amongst them would say that perhaps he would be the one who would be saved (and thus possess this gold).

Book 41, Number 6919:

    This hadith has been narrated on the authority of Suhail with the same chain of transmitters but with this addition: "My father said: If you see that, do not even go near it."

Book 41, Number 6920:

    Abu Huraira reported Allah's Messenger (may peace be upon him) as saying: The Last Hour would not come unless the Euphrates would uncover a treasure of gold, so he who finds it should not take anything out of that.

Book 41, Number 6921:

    Abu Huraira reported Allah's Messenger (may peace be upon him) as saying: The Euphrates would soon uncover a mountain of gold but he who is present there should not take anything from that.

Book 41, Number 6922:

    'Abdullah b. Harith b. Naufal reported: I was standing along with Ubayy b. Ka,b and he said: The opinions of the people differ in regard to the achievement of worldly ends. I said: Yes, of course. Thereupon he said: I heard Allah's Messenger (may peace be upon him) as saying: The Euphrates would soon uncover a mountain of gold and when the people would bear of it they would flock towards it but the people who would possess that (treasure) (would say): If we allow these persons to take out of it they would take away the whole of it. So they would fight and ninety-nine out of one hundred would be killed. Abu Kamil in his narration said: I and Abu Ka'b stood under the shade of the battlement of Hassan.

Book 41, Number 6923:

    Abu Huraira reported Allah's Messenger (may peace be upon him) as saying: Iraq would withhold its dirhams and qafiz; Syria would withhold its mudd and dinar and Egypt would withhold its irdab and dinar and you would recoil to that position from where you started and you would recoil to that position from where you started and you would recoil to that position from where you started, the bones and the flesh of Abu Huraira would bear testimony to it.

Chapter 9 : PERTAINING TO THE CONQUEST OF CONSTANTINOPLE AND THE APPEARANCE OF THE DAJJAL AND DESCENT OF JESUS SON OF MARY (JESUS CHRIST)

Book 41, Number 6924:

    Abu Huraira reported Allah's Messenger (may peace be upon him) as saying: The Last Hour would not come until the Romans would land at al-A'maq or in Dabiq. An army consisting of the best (soldiers) of the people of the earth at that time will come from Medina (to counteract them). When they will arrange themselves in ranks, the Romans would say: Do not stand between us and those (Muslims) who took prisoners from amongst us. Let us fight with them; and the Muslims would say: Nay, by Allah, we would never get aside from you and from our brethren that you may fight them. They will then fight and a third (part) of the army would run away, whom Allah will never forgive. A third (part of the army). which would be constituted of excellent martyrs in Allah's eye, would be killed ani the third who would never be put to trial would win and they would be conquerors of Constantinople. And as they would be busy in distributing the spoils of war (amongst themselves) after hanging their swords by the olive trees, the Satan would cry: The Dajjal has taken your place among your family. They would then come out, but it would be of no avail. And when they would come to Syria, he would come out while they would be still preparing themselves for battle drawing up the ranks. Certainly, the time of prayer shall come and then Jesus (peace be upon him) son of Mary would descend and would lead them in prayer. When the enemy of Allah would see him, it would (disappear) just as the salt dissolves itself in water and if he (Jesus) were not to confront them at all, even then it would dissolve completely, but Allah would kill them by his hand and he would show them their blood on his lance (the lance of Jesus Christ).

Chapter 10 : THE LAST HOUR WOULD COME WHEN THE ROMANS WOULD HAVE THE MAXIMUM POPULATION

Book 41, Number 6925:

    Mustaurid al-Qurashi reported: I heard Allah's Messenger (may peace be upon him) as saying: The Last Hour would come (when) the Romans would form a majority amongst people. 'Amr said to him (Mustaurid Qurashi): See what you are saying? He said: I say what I heard from Allah's Messenger (may peace be upon him). Thereupon he said: If you say that, it is a fact for they have four qualities. They have the patience to undergo a trial and immediately restore themselves to sanity after trouble and attack again after flight. They (have the quality) of being good to the destitute and the orphans, to the weak and, fifthly, the good quality in them is that they put resistance against the oppression of kings.

Book 41, Number 6926:

    Mustaurid Qurashi reported: I heard Allah's Messenger (may peace be upon him) as saying: The Last Hour would come when the Romans would form a majority amongst people. This reached 'Amr b. al-'As and he said: What are these ahadith which are being transmitted from you and which you claim to have heard from Allah's Messenger (may peace be upon him)? Mustaurid said to him: I stated only that which I heard from Allah's Messenger (may peace be upon him). Thereupon 'Amr said: If you state this (it is true), for they have the power of tolerance amongst people at the time of turmoil and restore themselves to sanity after trouble, and are good amongst people so far as the destitute and the weak are concerned.

Chapter 11 : THERE WOULD BE MUCH BLOODSHED AMONG ROMANS AT THE TIME OF THE APPEARANCE OF THE DAJJAL

Book 41, Number 6927:

    Yusair b. Jabir reported: Once there blew a red storm in Kufah that there came a person who had nothing to say but (these words): Abdullah b. Mas'ud, the Last Hour has come. He ('Abdullah b. Mas'ud) was sitting reclining against something, and he said: The Last Hour would not come until the people divide in- heritance and rejoice over booty, and then said pointing towards Syria, with the gesture of his hand like this: The enemy shall muster strength against Muslims and the Muslims will muster strength against them (Syrians). I said: You mean Rome? And he said: Yes, and there would be a terrible fight and the Muslims would prepare a detachment (for fighting unto death) which would not return but victorious. They will fight until night will intervene them; both the sides will return without being victorious and both will be wiped out. The Muslims will again prepare a detachment for fighting unto death so that they may not return but victorious. When it would be the fourth day, a new detachment out of the remnant of the Muslims would be prepared and Allah will decree that the enemy should be routed. And they would fight such a fight the like of which would not be seen, so much so that even if a bird were to pass their flanks, it would fall down dead before reaching the end of them. (There would be such a largescale massacre) that when counting would be done, (only) one out of a hundred men related to one another would be found alive. So what can be the joy at the spoils of such war and what inheritance would be divided ! They would be in this very state that they would hear of a calamity more horrible than this. And a cry would reach them: The Dajjil has taken your place among your off- spring. They will, therefore, throw away what would be in their hands and go forward sending ten horsemen,as a scouting party. Allah's Messenger (may peace be upon him) said: I know their names and the names of their forefathers and the colour of their horses. They will be best horsemen on the surface of the earth on that day or amongst the best horsemen on the surface of the earth on that day.

Book 41, Number 6928:

    Jabir reported: I was in the company of Ibn Mas'ud that there blew a red storm. The rest of the hadith is the same.

Book 41, Number 6929:

    Jabir reported: I was in the house of 'Abdullah b. Mas'ud and the house was fully packed that a red storm blew in Kufah.

Chapter 12 : THE CONQUESTS OF THE MUSLIMS BEFORE THE APPEARANCE OF THE DAJJAL

Book 41, Number 6930:

    Nafi' b. Utba reported: We were with Allah's Messenger (may peace be upon him) in an expedition that there came a people to Allah's Apostle (may peace be upon him) from the direction of the west. They were dressed in woollen clothes and they stood near a hillock and they met him as Allah's Messenger (may peace be upon him) was sitting. I said to myself: Better go to them and stand between him and them that they may not attack him. Then I thought that perhaps there had been going on secret negotiation amongst them. I however, went to them and btood between them and him and I remember four of the words (on that occasion) which I repeat (on the fingers of my hand) that he (Allah's Messenger) said: You will attack Arabia and Allah will enable you to conquer it, then you would attack Persia and He would make you to Conquer it. Then you would attack Rome and AllgLh will enable you to conquer it, then you would attack the Dajjal and Allah will enable you to conquer him. Nafi' said: Jabir, we thought that the Dajjal would appear after Rome (Syrian territory) would be conquered.

Chapter 13 : THE SIGNS BEFORE THE APPROACH OF THE LAST HOUR

Book 41, Number 6931:

    Hudhaifa b. Usaid Ghifari reported: Allah's Messenger (may peace be upon him) came to us all of a sudden as we were (busy in a discussion). He said: What do you discuss about? They (the Companions) said. We are discussing about the Last Hour. Thereupon he said: It will not cone until you see ten signs before and (in this connection) he made a mention of the smoke, Dajjal, the beast, the rising of the sun from the west, the descent of Jesus son of Mary (Allah be pleased with him), the Gog and Magog, and land-slidings in three places, one in the east, one in the west and one in Arabia at the end of which fire would burn forth from the Yemen, and would drive people to the place of their assembly.

Book 41, Number 6932:

    Hudhaifa b. Usaid reported: Allah's Apostle (may peace be upon him) was in an apartment and we were beneath that that he peeped in and said to us: What are you discussing about? We said: (We are discussing about the Last) Hour. Thereupon he said: The Last Hour would not come until the ten signs dppear: land-sliding in the east, and land-sliding in the west, and land-sliding in the peninsula of Arabia, the smoke, the Dajjal, the beast of the earth, Gog and Magog, the rising of the sun from the west and the fire which would emit from the lower part of 'Adan. Shu'ba said that 'Abd al-'Aziz b. Rufai' reported on the authority of Abu Tufail who reported on the authority of Abu Sariha a hadith like this that Allah's Apostle (may peace be upon him) did not make a mention of (the tenth sign) but he said that out of the ten one was the descent of Jesus Christ, son of Mary (peace be upon him), and in another version it is theb lowing of the violent gale which would drive the people to the ocean.

Book 41, Number 6933:

    Abu Sariha reported: Allah's Messenger (may peace be upon him) was in an (upper) apartment and we were standing lower to him and discussing (about the Last Hour). The rest of the hadith is the same, and Shu'ba said: I think he also said these words: The fire would descend along with them where they would land and where they would take rest (during midday (it would also cool down for a while). Shu'ba said: This hadith has been transmitted to me through Abu Tufail and Abu Sariha and none could trace it back directly to Allah's Apostle (may peace b.. upon him). However, there is a mention of the descent of Jesus Christ son of Mary in one version and in the other there is a mention of the blowing of a violent would drive them to the ocean.

Book 41, Number 6934:

    Abu Sariha reported: We were discussing the Last Hour) that Allah's Apostle (may peace be upon him) looked towards us. The rest of the hadith is the same and the tenth (sign) was the descent of Jesus Christ son of Mary, and Shu'ba said: 'Abd al-'Aziz did not trace it directly to Allah's Apostle (may peace be upon him).

Chapter 14 : THE LAST HOUR WOULD NOT COME UNTIL THE FIRE EMITS FROM THE EARTH OF HIJAZ

Book 41, Number 6935:

    Abu Huraira reported that Allah's Messenger may peace be upon him) said: The Last Hour would not come until fire emits from the earth of Hijaz which would illuminate the necks of the camels of the Busra.

Book 41, Number 6936:

    Abu Huraira reported that Allah's Messenger (may peace be upon him) said: (The Last Hour would not come) until the habitations of Medina would extend to Ihab or Yahab. Zubair said: I said to Suhail how far these were from Medina. He said: So and so miles.

Book 41, Number 6937:

    Abu Huraira reported Allah's Messenger (may peace be upon him) as saying: The famine would not break otit because of drought, but there would be famine despite heavy rainfall as nothing would grow from the earth.

Book 41, Number 6938:

    Ibn 'Umar reported that he heard Allah's Messenger (may peace be upon him) as saying (in a state) that he had turned his face towards the east: Behold, turmoil would appear from this side, from where the horns of Satan would appear.

Book 41, Number 6939:

    Ibn 'Umar reported that Allah's Messenger (may peace be upon him) stood by the door (of the apartment of) gafsa and, pointing towards the east, he said: The turmoil would appear from this side, viz. where the horns of Satan would appear, and he uttered these words twice or thrice and Ubaidullah b. Sa'ld in his narration said. The Messenger of Allah (may peace be upon him) had been standing by the door of 'A'isha.

Book 41, Number 6940:

    Salim b. Abdullah reported on the authority of his father that Allah's Messenger (may peace be upon him), while turning his face towards the east, said: The turmoil would appear from this side; verily, the turmoil would appear from this side; verily, the turmoil. would appear from this side-the side where appear the horns of Satan.

Book 41, Number 6941:

    Ibn Umar reported that Allah's Messenger (may peace be upon him) came out from the house of 'A'isha and said: It would be from this side that there would appear the height of unbelief, viz. where appear the horns of Satan. i.e. cast.

Book 41, Number 6942:

    Ibn Umar reported: I heard Allah's Messenger (may peace be upon him) as saying while pointing his hands towards the east: The turmoil would appear from this side; verily, the turmoil would appear from this side (he repeated it thrice) where appear the horns of Satan.

Book 41, Number 6943:

    Ibn Fudail reported on the authority of his father that he heard Salim b. 'Abdullah b. 'Umar as saying: O people of Iraq, how strange it is that you ask about the minor sins but commit major sins? I heard from my father 'Abdullah b. 'Umar, narrating that he heard Allah's Messenger (may peace be upon him) as saying while pointing his hand towards the east: Verily. the turmoil would come from this side, from where appear the horns of Satan and you would strike the necks of one another; and Moses killed a person from among the people of Pharaoh unintentionally and Allah, the Exalted and Glorious, said: "You killed a person but We relieved you from the grief and tried you with (many a) trial" (xx. 40). Ahmad b. Umar reported this hadith from Salim, but he did not make a mention of the words: "I heard".

Chapter 15 : THE LAST HOUR WOULD NOT COME UNTIL THE WOMEN OF THE TRIBE OF DAUS WOULD GO ROUND DHI AL-KHALASA

Book 41, Number 6944:

    Abu Huraira reported Allah's Messenger (may peace be upon him) as saying: The Last Hour would not come until the women of the tribe of Daus would be seen going round Dhi al-Khalasa (for worship) and Dhi al-Khalasa is a place in Tabala, where there was a temple in which the people of the tribe of Daus used to worship the idol.

Book 41, Number 6945:

    'A'isha reported: I heard Allah's Messenger (may peace be upon him) as saying: The (system) of night and day would not end until the people have taken to the worship of Lat and 'Uzza. I said: Allah's Messenger, I think when Allah has revealed this verse: "He it is Who has sent His Messenger with right guidance, and true religion, so that He may cause it to prevail upon all religions, though the polytheists are averse (to it)" (ix. 33), it implies that (this promise) is going to be fulfilled. Thereupon he (Allah's Apostle) said: It would happen as Allah would like. Then Allah would send the sweet fragrant air by which everyone who has even a mustard grain of faith in Him would die and those only would survive who would have no goodness in them. And they would revert to the religion of their forefathers.

Book 41, Number 6946:

    This hadith has been narrated on the authority of Ibn Ja'far with the same chain of transmitters.

Chapter 16 : THE LAST HOUR WOULD NOT COME UNTIL A PERSON WOULD PASS BY A GRAVE AND WISH THAT HE SHOULD HAVE BEEN THE OCCUPANT OF THAT GRAVE BECAUSE OF THIS CALAMITY

Book 41, Number 6947:

    Abu Huraira reported Allah's Messenger (may peace be upon him) as saying: The Last Hour would not come until a person would pass by a grave of another person and he would say: I wish it had been my abode.

Book 41, Number 6948:

    Abu Huraira reported Allah's Messenger (may peace be upon him) as saying: By Him, in Whose hand is my life, the world would not come to an end until a person would pass by a grave, would roll over it and express the desire that he should be in the place of the occupant of that grave not because of religious reasons but because of this calamity.

Book 41, Number 6949:

    Abu Huraira reported Allah's Messenger (may peace be upon him) as saying: By Him in Whose Hand is my life, a time would come when the murderer would not know why he has committed the murder, and the victim would not know why he has been killed.

Book 41, Number 6950:

    Abu Huraira reported Allah's Messenger (may peace be upon him) as saying: The world would not come to an end until a day would come to the people on which the murderer would not know as to why he has killed and the slain would not know as to why he has been murdered. It would be said: Why would It happen? To which he replied: It would be because of general massacre and bloodshed. And the slaughterers and the slain would be in Fire, and in the narration of Ibn Aban, the name of Abu Isma'il has been mentioned.

Book 41, Number 6951:

    Abu Huraira reported Allah's Messenger(may peace be upon him) as saying: The Ka'ba would be destroyed by an Abyssinian having two small shanks.

Book 41, Number 6952:

    (The above mentioned) hadith has been narrated on the authority of Abu Huraira through another chain of transmitters.

Book 41, Number 6953:

    Abu Huraira reported Allah's Messenger (may peace be upon him) as saying: It would be an Abyssinian having two small shanks who would destroy the House ol Allah, the Exalted and Glorious.

Book 41, Number 6954:

    Abu Huraira reported Allah's Messengar (may peace be upon him) as saying: The Last Hour would not come before a person of Qahtan comes forth driving people with his stick.

Book 41, Number 6955:

    Abu Huraira reported Allah's Messenger (may peace be upon him) as saying: The day and the night would not come to an end before a man called al-Jahjah would occupy the throne.

Book 41, Number 6956:

    Abu Huraira reported Allah's Messenger (may peace be upon him) as saying: The Last Hour would not come unless you fight with people whose faces are like hammered shields and the Last Hour would not come until you would fight against those wearing the shoes of hair.

Book 41, Number 6957:

    Abu Huraira reported Allah's Messenger (may peace be upon him) as saying: The Last Hour would not come until a people wearing shoes of hair fight against you having their faces like hammered shields.

Book 41, Number 6958:

    Abu Huraira reported Allah's Messenger (may peace be upon him) as saying: The Last Hour would not come until you fight with a people wearing shoes of hair and the Last Hour would not come until you fight with a people having small eyes and broad snub noses.

Book 41, Number 6959:

    Abu Huraira reported Allah's Messenger (may peace be upon him) as saying: The Last Hour would not come until the Muslims fight with the Turks-a people whose faces would be like hammered shields wearing clothes of hair and walking (with shoes) of hair.

Book 41, Number 6960:

    Abu Huraira reported Allah's Messenger (may peace be upon him) as saying: You shall fight in the hours to come against a nation wearing shoes made of hair and faces like hammered shields, with red complexion and small eyes.

Book 41, Number 6961:

    Abu Nadra reported:"We were in the company of Jabir b. 'Abdulldh that he said it may happen that the people of Iraq may not send their qafiz and dirhams (their measures of food stuff and their money). We said : Who would be respolisible for it? He said: The non_Arabs would prevt them. He again said: There is the possibility that the people of Syria may not send their dinar and mudd. We said: Who would be responsible for it? He said This prevention would be made by the Romans. He (Jabir b. Abdullab) kept quiet for a while and then reported Allah',s Messengdt (may peas be upon him) having said There would be a caliph in the last(period) of my Ummah who would freely give handfuls of wealth to thd people wiothout counting it. I said to Abu Nadra and Abu al-'Ala: DO you mean 'Umarb. 'Abd al-Aziz ? They said: No (he would be Imam Mahdi.).

Book 41, Number 6962:

    This hadith hab been narrated by Sa'id with the same chain of transmitters.

Book 41, Number 6963:

    Abu Sa'id reported that Allah's Messenger (may peace he upon him) I said: There would be amongest your caliphs a caliph who would give handfuls of wealth to the, but wbuld not count it. In. the narration transmitted on the authority of Ibn Hujr, there is a slight variation of wording.

Book 41, Number 6964:

    Abu Sa'id and Jabir b. Abdullah reported that Allah's Messenger (may peace be upon him) said: There would be in the last phase of the time a caliph who would distribute wealth but would not count.

Book 41, Number 6965:

    This hadith has been narrated on the authority of Abu Sa'id through another chain of transmitters.

Book 41, Number 6966:

    Abu Sa'id Khudri reported: One who Is better than I informed me, that Allah's Messenger (may peace be upon him) said to 'Ammar as he was digging the ditch (on the ocasion of the Battle of the Ditch) wiping over his head: O son of Summayya you will be involved in trouble and a group of the rebels would kill you.

Book 41, Number 6967:

    This hadith has been transmitted on the same authority but with this variation that the hadith trarismitted on the authority of Nabra (the words are): One Who is better than I informed me, and he was Abu Qatatda, and in the hadith transmitted on the authority of Khalid instead of the word 'bu_us' there is 'dys' or 'yadis', i.e.: "how sad it is".

Book 41, Number 6968:

    This hadith has been transmitted on the authority of Umm Salama that Allah's Messenger (may peace be upon him) said to 'Ammar: A group of rebels would kill you.

Book 41, Number 6969:

    This hadith has been narrated on the authority of Umm Salam through another chain of transmitters.

Book 41, Number 6970:

    Unmm Salama reported that Allah's Messenger (may peace be upon him) said: A band of rebels would kill 'Ammar.

Book 41, Number 6971:

    Abu Huraira reported that Allah's Apostle (may peace be upon him) as saying: This tribe of the Quraish would kill (people) of wy Ummah. They (the Companions) said:What us to do(in such a situations)? Thereupon he said: Would that the people remain aside from them (and not besmear their hand with the blood of the Muslim).

Book 41, Number 6972:

    This hadith has been narrated on the authority of Shu'ba with the same chain of transmitters.

Book 41, Number 6973:

    Abu Huraira reported that Allh's Messenger (may peace be upon him) said: (Khusrau king of Persia) would die and Qaisar (Ceasar King of Rome) would die; there would be no Qaisar after him, but, by one in Whose Hand is my life, you would spend their treasures in the cause of Allah.

Book 41, Number 6974:

    This hadith has been transmitted on the authority of Zuhri.

Book 41, Number 6975:

    Hammam b. Munabbih reported: This is what Abu Huraira reported from Allah's messenger (may peace be upon him) and in this connection he reported so many hadith (and one of them was this) : Allah's Messenger (may peace be upon him) said: Kisra would die and then there would be no Kisra after him. Qaisar would die and there would be no Qaisar after him, but you will distribute their threasuers in thecause of Allah.

Book 41, Number 6976:

    Jabir b. Samura reported that Allah's Messenger (may peace be upon him) said: When Kisra would die there would be no Kisra after him; the rest of the hadith is the same as Abu Huraira reported.

Book 41, Number 6977:

    Jabir b. Samura reported: I heard Allah's Messenger (may peace be upon him) (as sayingt There would lie open for a group of Muslims, or for a group of believers, the treasures of the family of Kisra which would be in the whit (palace). In a version of Qutaiba there is definitely the word "Muslim".

Book 41, Number 6978:

    Jabir b. Samura reported: I heard Allah's Messenger (may peace be upon him) a hadith like this.

Book 41, Number 6979:

    Abu Huraira reported Allah's Apostle (may peace he upon him) saying: You have heard about a city the one side of which is in the land and the other is in the sea (Constantinople). They said: Allall's Messenger, yes. Thererupon he said: The Last Hour would not cmoe unlesss seventy thousand persons from Bani lsra'il would attack it. When they would land there, they will neither fight with weapons nor would shower arrows but would only say: "There is no god but Allah and Allah is the Greatest," that one side of it would fall. Thaur (one of the narrators) said: I think that he said: The part by the side of the ocean. Then they would say for the second time: "There is no god but Allah and Allah is the Greatest" that the second side would also fall, and they would say: "There is no god but Allah and Allah is the Greatest," that the gates would be opened for them and they would enter therein and, they would be collecting spoils of war and distributing them amongst themselves that a noise would be heard and It would be said: Verily, Dajjal has come. And thus they would leave everything there and would turn to him.

Book 41, Number 6980:

    Thaur b. Zaid has narrated this hadith with the same chain of transmitters.

Book 41, Number 6981:

    Ibn 'Umar reported Allah's Messenger (may peace be upon him) as saying: You will fight against the Jews and you will kill them until even a stone would say: Come here, Muslim, there is a Jew (hiding himself behind me); kill him.

Book 41, Number 6982:

    Ubaidullah has reported this hadith with this chain of transmitters (and the Words are): "There is a Jew behind me."

Book 41, Number 6983:

    Abdullah b. 'Umar reported Allah's Messenger (may peace be upon him) as saying: You and the Jews would fight against one another until a stone would say: Muslim, here is a Jew behind me; come and kill him.

Book 41, Number 6984:

    Abdullah b. 'Umar reported that Allah's Messenger (may peace be upon him) said: The Jews will fight against you and you will gain victory over them until the stone would say: Muslim, here is a Jew behind me; kill him.

Book 41, Number 6985:

    Abu Huraira reported Allah's Messenger (may peace be upon him) as saying: The last hour would not come unless the Muslims will fight against the Jews and the Muslims would kill them until the Jews would hide themselves behind a stone or a tree and a stone or a tree would say: Muslim, or the servant of Allah, there is a Jew behind me; come and kill him; but the tree Gharqad would not say, for it is the tree of the Jews.

Book 41, Number 6986:

    Jabir b. Samura reported: I heard Allah's Messenger (may peace be upon him) as saying: Before the Last Hour there would be many liars, and there is an addition in the badith transmitted on the authority of Abu Ahwas of these words: "I said to him: Did you hear it from Allah's Messenger (may peace be upon him)? He said: Yes."

Book 41, Number 6987:

    This hadith has been narrated on the authority of Simak with the same chain of transmitters. and Simak said: I heard my brother say that jabir had stated: Be on your guard against them.

Book 41, Number 6988:

    Abu Huraira reported Allah's Messenger (may peace be upon him) as saying: The Last Hour would not come until there would arise about thirty impostors, liars, and each one of them would claim that he is a messenger of Allah.

Book 41, Number 6989:

    This hadith has been transmitted on the authority of Abu Huraira with a slight variation of wording.

Chapter 17 : STORY OF IBN SAYYAD

Book 41, Number 6990:

    'Abdullah reported: We were along with Allah's Messenger (may peace be upon him) that we happened to pass by children amongst whom there was Ibn Sayyad. The children made their way but Ibn Sayyad kept sitting there (and it seemed) as if Allah's Messenger (may peace be upon him) did not like it (his sitting with the children) and said to him: May your nose he besmeared with dust, don't you bear testimony to the fact that I am the Messenger of Allah? Thereupon he said: No, but you should bear testimony that I am the messenger of Allah. Thereupon 'Umar b. Khattab said: Allah's Messenger, permit me that I should kill him. Thereupon Allah's Messenger (may peace be upon him) said: If he is that person who is in your mind (Dajjal ), you will not be able to kill him.

Book 41, Number 6991:

    'Abdullah reported: We were walking with Allah's Messenger (may peace be upon him) that Ibn Sayyad happened to pass by him. Allah's Messenger (may peace be upon him) said to him: I have concealed for you (something to test you, so tell me that). He said: It is Dukh. Thereupon Allah's Messenger (may peace be upon him) said to him: Be off. You cannot get farther than your rank, whereupon 'Umar said: Allah's Messenger, permit me to strike his neck. Thereupon Allah's Messenger (may peace be upon him) said: Leave him; if he is that one (Dajjal) whom you apprehend, you will not be able to kill him.

Book 41, Number 6992:

    Abu Sa'id reported that Allah's Messenger (may peace be upon him) met him (Ibn Sayyad) and so did Abu Bakr and 'Umar on some of the roads of Medina. Allah's Messenger (may peace be upon him) said: Do you bear testimony to the fact that I am the Messenger of Allah? Thereupon he said: Do you bear testimony to the fact that I am the messenger of Allah? Thereupon Allah's Messenger (may peace be upon him) said: I affirm my faith in Allah and in His Angels and in His Books, and what do you see ? He said: I see the throne over water. Whereupon Allah's Messenger (may peace be upon him) said: You see the throne of Iblis upon the water, and what else do you see? He said: I see two truthfuls and a liar or two liars and one truthful. Thereupon Allah's Messenger (may peace be upon him) said: Leave him He has been confounded.

Book 41, Number 6993:

    Jabir b 'Abdullah reported that Allah's Messenger (may peace be upon him) met Ibn Sa'id(Sayyad) and there were with him Abu Bakr and 'Umar and Ibn Sayyad was in the company of children. The rest of the hadith is the same.

Book 41, Number 6994:

    Abu Sa'id reported: I accompanied Ibn Sayyad to Mecca and he said to me: What I have gathered from people is that theu think that I am Dajjal. Have you not hearde Allah's Messenger (may peace upon him) as saying: He will have no no children, I said: Yes, of course. Thereupon he said: But I have children. Have you not heard Allah's Messenger (may peace be upon him) as saying: He would not enter Mecca and Medina? I said: Yes, of course. Thereupon he said I have been once in Medina and now I intend to go to Mecca. And he said to me at the end of his talk: By Allah: I know his place of birth his abode where he is just now. He (Abu Sa'id) said: This caused confusion in my mind (in regard to his identity).

Book 41, Number 6995:

    Abu Sa'id Khudri reported:Ibn Sa'id said to me somethhing for which I felt ashamed. He said: I can excuse others; but what has gone wrong with you, O Companions of Muhammad, that you take me as Dajjal? Has Allah's Apostle(may peace be upon him) not said that he would be a Jew whereas I am a Muslim and he also said that he would not have children, whereas I have children, and he also said: veryly, Allah has prohibited him to enter Mecca whereas I have performed Pilgrimage, atid.he went on saying this that I was about to be impressed by his tallk. He (however) said this also: I know where he (Dajjal) is and I know his father abd I mother, and it was said to him: Won't you feel pleased if you would be the same person? Thereupon he said: If this offer is made to me, I would noT resent that.

Book 41, Number 6996:

    Abu Sa'id Khudri reported : We came back after having pewrformed Pilgrimage or 'Umra and lbn Sa'id was along with us. And w,e encamped at a place and the people dispersed and I and he were left behind. I felt terribly frightend from him as it was said about him that he was the Dajjal. He brought his goods and placed them by my luggage and I said: It is intense heat. Would you not place that under that tree? And he did that. Then ther appeared before us a flock of sheep. He went and brought a cup of milk and said: Abu Sa'id, drink that. I said it is intense heat and the milk is also hot (whereas the fact was) that I did not like to drink from his hands or to opr to take it from his hand and he said: Abu Sa'id, I think that I should take a rope and suspend it by the tree and then coimmit sucide because of the talks of the people, and he furtlier said. Abu Sa'id he who is ingnoran of the saying of Allah's Messenger (may peace be upon him) (he is to be pardoned), but O people of Ansar, is this hadith of Allah's Messengern(may peace be upon him) concealed from you whereas you have the best konowledge of t this hadith of Allah's Messenger (may peace be upon him) amongst people? Did Allalt's Messenger (may peace be upon him) not say that he(Dajjal) would be a non believer whereas I am a believer? did Allah's Messenger(may peace be upon him) not say he would be barren and no child would be born to hirn, whereas I have left my children in Medina? Did Allh's Messenger (may peace upon him) not say: He would not get into Medina and Mecca whereas I have been coming from Medina and now I intend to go to Mecca? Abu Sa'id said: I was about to accept the excuse put forward by him. that he said: I know the place where he would be born and where he is now. So I said to him: May your whole dayb be spent

Book 41, Number 6997:

    This hadith has transmitted on the authority of Abu Sa'id that Allah's Messenger (may peace be upon him) asked Ibn Sa'id about the earth of Paradise. Thereupon he said: Abu'l-Qasim, It is like a fine white musk,whereupon he (the Holy Prophet) said : 'You have told the the truth.

Book 41, Number 6998:

    Abu Sa'id reported that Ibn Sayyad asked Allah's Messenger (may peace be upon him) about the earth of Paradise. Whereupon he said: It is like white shining pure musk.

Book 41, Number 6999:

    'Muhammad b. Munkadir reported: As I saw Jabir b. 'Abdullah taking an oath in the name of Allah that it was Ibn Sa'id who was the Dajjal I said:Do you take an oath in the name of Allah? Thereupon he said:I heard 'Umar taking an oath in the presence of Allah's Apostle (may peace be upon him) to this effect but Allah's Apostle (may peace be upon him) did not disapprove of it.

Book 41, Number 7000:

    'Abdullah b. Umar reported: 'Umar b. Khattab went along with Allah's Messenger (may peace be upon him) in the company of some persons toIbn Sayyad that he found him playing with children near the bettlement of Bani Maghala and Ibn Sayyad was at that time just at the threshold of adolescence and he did not perceive (the presence of Holy Prophet) until Allah's Messenger (may peace be upon him)struck his back with his hands.Allah's Messenger (may peace be upon him) said: Ibn Sayyad,don't you bear witness that I am the messenger of Allah? Ibn Sayyad looked toward him and he said: I bear witness to the fact that you the messenger of the unlettered.Ibn Sayyad said to the Allah's Messenger (may peace be upon him):Do you bear witness to the fact that I am the messenger of Allah? Allah's Messenger (may peace be upon him) rejected this and said :I affirm my faith in Allah and in His messengers .Then Allah's Messenger (may peace be upon him) said to him: What do you see? Ibn Sayyad said :It us a Dukh. Thereupon Allah's Messenger (may peace be upon him) said : May you be disgraced and dishonoured,you would not not be able to go beyond your rank. 'Umar b. Khattab said :Allah's Messenger, permit me that I should strike his neck. Therupon Allah's Messenger (may peace be upon him) said :If he is the same (Dajjal) who would appear near the Last Hour,you would not be able to overpower him, and he is not that ther is no good for you to kill him. 'Abdullah b. 'Umar further narrated that after some time Allah's Messenger (may peace be upon him) and Ubayy b. Ka'b went towards the palm trees where Ibn Sayyad was. When Allah's Messenger (may peace be upon him) went near the tree he hid himself behind a tree with the intention of hearing something from Ibn sayyad before Ibn Sayyad could see him, but Allah's Messenger (may pcxce be upon him) saw him on a bed with a blanket around him from which a murmuring sound was being heard and Ibn Sayyad's mother saw Allah's Messenger (may peace be upon him) behind the trunk of the palm tree. She said to Ibn Sayyad: Saf (that being his name), here is Muhammad. Thereupon Ibn Sayyad jumped up murmuring and Allah's Messenger (may peace be upon him) said: If she had left him alone he would have made things clear. Abdullah b. Umar told that Allah's Messenger (may peace be upon him) stood up amongst the people and lauded Allah as He deserved, then he made a mention of the Dajjal and said: I warn you of him and there is no Prophet who has not warned his people against the Dajjal. Even Noah warned (against him) but I am going to tell you a thing which no Prophet told his people. You must know that he (the Dajjal) is one-eyed and Allah, the Exalted and Glorious, is not one-eyed. Ibn Shihab said: 'Umar b. Thabit al-Ansari informed me that some of the Companions of Allah's Messenger (may peace be upon him) informed him that the day when Allah's Messenger (may peace be upon him) warned people against the Dajjal, he also said: There would be written between his two eyes (the word) Kafir (infidel) and everyone who would resent his deeds would be able to read or every Muslim would be about to read, and he also said: Bear this thing in mind that none amongst you would be able to see Allah, the Exalted and Glorious, until he dies.

Book 41, Number 7001:

    Abdullah b. Umar reported that Allah's Messenger (may peace be upon him) went along with him in the company of some persons and there was Umar b. Khattab also amongst them till they saw Ibn Sayyad as a young boy just on the threshold of adolescence playing with children near the battlement of Bani Mu'awiya; the rest of the hadith is the same but with these concluding words: "Had his mother left him (to murmur) his matter would have become clear."

Book 41, Number 7002:

    Ibn 'Umar reported that Allah's Messenger (may peace be upon him) happened to pass by Ibn Sayyad along with his Companions including 'Umar b. Khattab as he was playing with children near the battlement of Bani Maghala and he was also a child by that time. The rest of the hadith is the same as narrated by Ibn Umar (in which there is a mention of) setting out of Allah's Apostle (may peace be upon him) along with Ubayy b. Ka'b towards the date-palm trees.

Book 41, Number 7003:

    Nafi' reported that Ibn 'Umar met Ibn Si'id on some of the paths of Medina and he said to him a word which enraged him and he was so much swollen with anger that the way was blocked. Ibn 'Umar went to Hafsa and informed her about this. Thereupon she said: May Allah have mercy upon you, why did you incite Ibn Sayyad in spite of the fact that you knew it would be the extreme anger which would make Dajjal appear in the world?

Book 41, Number 7004:

    Nafi' reported that Ibn 'Umar said: I met lbn Sayyad twice and said to some of them (his friends): You state that it was he (the Dajjal). He said: By Allah, it is not so. I said: You have not told me the truth; by Allah some of you informed me that he would not die until he would have the largest number of offspring and huge wealth and it is he about whom it is thought so. Then Ibn Sayyad talked to us. I then departed and met him again for the second time and his eye had been swollen. I said: What has happened to your eye? He said: I do not know. I said: This is in your head and you do not know about it? He said: If Allah so wills He can create it (eye) in your staff. He then produced a sound like the braying of a donkey. Some of my companions thought that I had struck him with the staff as he was with me that the staff broke into pieces, but, by Allah, I was not conscious of it. He then came to the Mother of the Faithful (Hafsa) and narrated it to her and she said: What concern you have with him? Don't you know that Allah's Apostle (may peace be upon him) said that the first thing (by the incitement of which) he would come out before the public would be his anger?

Chapter 18 : ACCOUNT OF THE DAJJAL AND HIS FEATURES AND WHAT WOULD BE ALONG WITH HIM

Book 41, Number 7005:

    Ibn Umar reported that Allah's Messenger (may peace be upon him). made a mention of Dajjil in the presence of the people and said: Allah is not one-eyed and behold that Dajjal is blind of the right eye and his eye would be like a floating grape.

Book 41, Number 7006:

    This hadith has been narrated on the authority of Ibn 'Umar through another chain of transmitters.

Book 41, Number 7007:

    Anas b. Malik reported that Allah's Messenger (may peace be upon him) said: There is never a prophet who has not warned the Ummah of that one-eyed liar; behold he is one-eyed and your Lord is not one-eyed. On his forehead are the letters k f.r. (Kafir).

Book 41, Number 7008:

    Anas b. Malik reported that Allah's Messenger (may peace be upon him) said: There would be written three letters k.f.r., i.e. Kafir, between the eyes of the Dajjal.

Book 41, Number 7009:

    Anas b. Malik reported that Allah's Messenger (may peace be upon him) said: Dajjal is blind of one eye and there is written between his eyes the word "Kafir". He then spelled the word as k.f.r., which every Muslim would be able to read.

Book 41, Number 7010:

    Hudhalfa reported that Allah's Messenger (may peace be upon him) said: Dajjal is blind of left eye with thick hair and there would be a garden and fire with him and his fire would be a garden and his garden would be fire.

Book 41, Number 7011:

    Hudhaifa reported Allah's Messenger (may peace be upon him) as saying: the Dajjal would have with him water and fire and his fire would bays the effect of cold water and his water would have the effect of fire, so don't put yourself to ruin. Abu Mas'ud reported: I also heard it from Allah's Messenger (may peace be upon him).

Book 41, Number 7012:

    'Uqba b. 'Amr Abu Mas'ud al-Ansari reported : I went to Hudhaifa b. Yaman and said to him: Narrate what you have heard from Allah's Messenger (may peace be upon him) pertaining to the Dajjal. He said that the Dajjal would appear and there would be along with him water ant fire and what the people would see as water that would be fire and that would burn and what would appear as fire that would be water and any one of you who would see that should plunge in that which he sees as fire for it would be sweet, pure water, and 'Uqba said: I also heard it, testifying Hudhaifa.

Book 41, Number 7013:

    Hudhaifa and Ibn Mas'ud met together. Hudhaifa said: I know more than you as to what there would be along with the Dajjal. There would be along with him two canals (one flowing with water) and the other one (having) fire (within it), and what you would see as fire would be water and what you would see as water would be fire. So he who amongst you is able to see that and is desirous of water should drink out of that which he sees as fire.

Book 41, Number 7014:

    Abu Huraira reported Allah's Messenger (may peace be upon him) as saying: May I not inform you about the Dajjal what no Apostle of Allah narrated to his people? He would be blind and he would bring along with him an Image of Paradise and Hell-Fire and what he would call as Paradise that would be Hell-Fire and I warn you as Noah warned his people.

Book 41, Number 7015:

    An-Nawwas b. Sam'an reported that Allah's Messenger (may peace be upon him) made a mention of the Dajjal one day in the morning. He sometimes described him to be insignificant and sometimes described (his turmoil) as very significant rand we felt) as if he were in the cluster of the date-palm trees. When we went to him (to the Holy Prophet) in the evening and he read (the signs of fear) in our faces, he said: What is the matter with you? We said : Allah's Messenger, you made a mention of the Dajjal in the morning (sometimes describing him) to be insignificant and sometimes very important, until we began to think as if he were present in some (near) part of the cluster of the datpalm trees. Thereupon he said: I harbour fear in regard to you in so many other things besides the Dajjal. If he comes forth while I am among on, I shall contend with him on your behalf, but if he comes forth while I am not amongst you, a man must contend on his own behalf and Allah would take care of every Muslim on my behalf (and safeguard him against his evil). He (Dajjal) would be a young man with twisted, contracted hair, and a blind eye. I compare him to 'Abd-ul-'Uzza b. Qatan. He who amongst you would survive to see him should recite over him the opening verses of Sura Kahf (xviii.). He would appear on the way between Syria and Iraq and would spread mischief right and left. O servant of Allah ! adhere (to the path of Truth). We said: Allah's Messenger, how long would he stay on the earth? He said.. For forty days, one day like a year and one day like a month and one day like a week and the rest of the days would be like your days. We said: Allah's Messenger, would one day's prayer suffice for the prayers of day equal to one year? Thereupon he said: No, but you must make an estimate of time (and then observe prayer). We said: Allah's Messenger, how quickly would he walk upon the earth? Thereupon he said: Like cloud driven by the wind. He would come to the people and invite them (to a wrong religion) and they would affirm their faith in him and respond to him. He would then give command to the sky and there would be rainfall upon the earth and it would grow crops. Then in the evening, their posturing animals would come to them with their humps very high and their udders full of milk and their flanks stretched. He would then come to another people and invite them. But they would reject him and he would go away from them and there would be drought for them and nothing would be lef t with them in the form of wealth. He would then walk through the waste, land and say to it: Bring forth your treasures, and the treasures would come out and collect (themselves) before him like the swarm of bees. He would then call a person brimming with youth and strike him with the sword and cut him into two pieces and (make these pieces lie at a distance which is generally) between the archer and his target. He would then call (that young man) and he will come forward laughing with his face gleaming (with happiness) and it would at this very time that Allah would send Christ, son of Mary, and he will descend at the white minaret in the eastern side of Damscus wearing two garments lightly dyed with saffron and placing his hands on the wings of two Angels. When he would lower his head, there would fall beads of perspiration from his head, and when he would raise it up, beads like pearls would scatter from it. Every non-believer who would smell the odour of his self would die and his breath would reach as far as he would be able to see. He would then search for him (Dajjal) until he would catch hold of him at the gate of Ludd and would kill him. Then a people whom Allah had protected would come to Jesus, son of Mary, and he would wipe their faces and would inform them of their ranks in Paradise and it would be under such conditions that Allah would reveal to Jesus these words: I have brought forth from amongst My servants such people against whom none would be able to fight; you take these people safely to Tur, and then Allah would send Gog and Magog and they would swarm down from every slope. The first of them would pass the lake of Tibering and drink out of it. And when the last of them would pass, he would say: There was once water there. Jesus and his companions would then be besieged here (at Tur, and they would be so much hard pressed) that the head of the ox would be dearer to them than one hundred dinirs and Allah's Apostle, Jesus, and his companions would supplicate Allah, Who would send to them insects (which would attack their necks) and in the morning they would perish like one single person. Allah's Apostle, Jesus, and his companions would then come down to the earth and they would not find in the earth as much space as a single span which is not filled with their putrefaction and stench. Allah's Apostle, Jesus, and his companions would then again beseech Allah, Who would send birds whose necks would be like those of bactrin camels and they would carry them and throw them where God would will. Then Allah would send rain which no house of clay or (the tent of) camels' hairs would keep out and it would wash away the earth until it could appear to be a mirror. Then the earth would be told to bring forth its fruit and restore its blessing and, as a result thereof, there would grow (such a big) pomegranate that a group of persons would be able to eat that, and seek shelter under its skin and milch cow would give so much milk that a whole party would be able to drink it. And the milch camel would give such (a large quantity of) milk that the whole tribe would be able to drink out of that and the milch sheep would give so much milk that the whole family would be able to drink out of that and at that time Allah would send a pleasant wind which would soothe (people) even under their armpits, and would take the life of every Muslim and only the wicked would survive who would commit adultery like asses and the Last Hour would come to them.

Book 41, Number 7016:

    This hadith has been narrated on the authority of Jabir with the same chain of transmitters but with this addition that Gog and Magog would walk until they would reach the mountain of al-Khamar and it is a mountain of Bait-ul-Maqdis and they would say: We have killed those who are upon the earth. Let us now kill those who are In the sky and they would throw their arrows towards the sky and the arrows would return to them besmeared with blood. And in the narration of Ibn Hujr (the words are) : "I have sent such persons (Gog and Magog) that none would dare fight against them.

Chapter 18 : THE CHARACTERISTIC OF THE DAJJAL AND A BAN ON HIS ENTRY TO MEDINA AND HIS KILLING OF A BELIEVER AND THEN RESTORING HIM TO LIFE

Book 41, Number 7017:

    Abu Sa'id al-Khudri reported that Allah's Messenger (may peace be upon him) one day gave a detailed account of the Dajjal and in that it was also included: He would come but would not be allowed to ether the mountain passes to Medina. So he will alight at some of the barren tracts near Medina, and a person who would be the best of men or one from amongst the best of men would say to him: I bear testimony to the fact that you are Dajjal about whom Allah's Messenger (may peace be upon him) had informed us. The Dajjal would say: What is your opinion if I kill this (person), then I bring him back to life; even then will you harbour doubt in this matter? They would say: No. He would then kill (the man) and then bring him back to life. When he would bring tha@ person to life, he would say: By Allah, I had no better proof of the fact (that you are a Dajjal) than at the present time (that you are actually so). The Dajjal would then make an attempt to kill him (again) but he would not be able to do that. Abu Ishaq reported that it was said: That person would be Khadir (Allah be pleased with him).

Book 41, Number 7018:

    This hadith has been narrated by Zuhri with the same chain of transmitters.

Book 41, Number 7019:

    Abu Sa'id al-Khudri reported Allah's Messenger (may peace be upon him) as saying: The Dajjal would come forth and a person from amongst the believers would go towards him and the armed men of the Dajjal would meet him and they would say to him: Where do you intend to go? He would say: I intend to go to this one who is coming forth. They would say to him: Don't you believe in our Lord? He would say: There is nothing hidden about our Lord. They would say: Kill him. Then some amongst them would say: Has your master (Dajjal) not forbidden you to kill anyone without (his consent)? And so they would take him to the Dajjal and when the believer would see him, he would say: O people. he is the Dajjil about whom Allah's Messenger (may peace be upon him) has informed (us). The Dajjal would then order for breaking his head and utter (these words): Catch hold of him and break his head. He would be struck even on his back and on his stomach. Then the Dajjal would ask him: Don't you believe in me? He would say: You are a false Masih. He would then order him to be torn (into pieces) with a saw from the parting of his hair up to his legs. After that the Dajjal would walk between the two pieces. He would then say to him: Stand, and he would stand erect. He would then say to him: Don't you believe in me? And the person would say: It has only added to my insight concerning you (that you are really the Dajjal). He would then say: O people, he would not behave with anyone amongst people (in such a manner) after me. The Dajjal would try to catch hold of him so that he should kill him (again). The space between his neck and collar bone would be turned into copper and he would find no means to kill him. So he would catch hold of him by his hand and feet and throw him (into the air) and the people would think as if he had been thrown in the Hell-Fire whereas he would be thrown in Paradise. Thereupon Allah's Messenger (may peace be upon him) said: He would be the most eminent amongst persons in regard to martyrdom in the eye of the Lord of the world.

Chapter 19 : THE DAJJAL WOULD BE VERY INSIGNIFICANT IN THE EYE OF ALLAH, THE MAJESTIC AND GLORIOUS

Book 41, Number 7020:

    Mughira b. Shu'ba reported: No one asked Allah's Messenger (may peace be upon him) more about Dajjil than I asked him. He said: He should not be a source of worry to you for he would not be able to do any harm to you. I said: Allah's Messenger, it is alleged that he would have along with him (abundance of) food and water. Thereupon he said: He would be very insignificant in the eye of Allah (even) with all this.

Book 41, Number 7021:

    Mughira b. Shu'ba reported that none asked Allah's Apostle (may peace be upon him) about Dajjal more than I asked him. I (one of the narrators other than Mughlra b. Shu'ba) said: What'did you ask? Mughira replied: I said that the people alleged that he would have a mountain load of bread and mutton and rivers of water. Thereupon he said: He would be more insignificant in the eye of Allah compared with all this.

Book 41, Number 7022:

    This hadith has been narrated on the authority of Isma'il through other chains of transmitters with a slight variation of wording.

Chapter 21 : THE APPEARANCE OF THE DAJJAL AND HIS STAY UPON THE EARTH AND THE DESCENT OF JESUS AND HIS KILLING HIM (DAJJAL) AND THE DEPARTURE OF GOOD PEOPLE OF STRONG CONVICTION AND THE SURVIVAL OF THE WICKED PEOPLE AND THE WORSHIP OF IDOLS AND THE BLOWING OF THE TRUMPET AND THE RAISING UP FROM THE GRAVES

Book 41, Number 7023:

    'Abdullah b. 'Amr reported that a person came to him and said: What is this hadith that you narrate that the Last Hour would come at such and such time? Thereupon he said: Hallowed be Allah, there is no god but Allah (or the words to the same effect). I have decided that I would not narrate anything to anyone now.I had only said that you would see after some time an important event that the (sacred) House (Ka'ba) would be burnt and it would happen and definitely happen. He then reported that Allah's Messenger (may peace be upon him) said: The Dajjal would appear in my Ummah and he would stay (in the world) for forty-I cannot say whether he meant forty days, forty months or forty years. And Allah would then send Jesus son of Mary who would resemble 'Urwa b Mas'ud. He (Jesus Christ) would chase him and kill him. Then people would live for seven years that there would be no ran. cour between two persons. Then Allah would send cold wind from the side of Syria that none would survive upon the earth having a speck of good in him or faith in him but he would die, so much so that even if some amongst you were to enter the innermost part of the mountain, this wind would reach that place also and that would cause his heath. I heard Allah's Messenger (may peace be upon him) as saying: Only the wicked people would survive and they would be as careless as birds with the charactertistics of beasts. They would never appreciate the good nor condemn evil. Then the Satan would come to them in human form and would say: Don't you respond? And they would say: What do you order us? And he would command them to worship the idols but, in spite of this, they would have abundance of sustenance and lead comfortable lives. Then the trumpet would be blown and no one would hear that but he would bend hfs neck to one side and raise it from the other side and the first one to hear that trumpet would be the person who would be busy in setting right the tank meant for providing water to the camels. He would swoon and the other people would also swoon, then Allah would send or He would cause to send rain which would be like dew and there would grow out of it the bodies of the people. Then the second trumpet would be blown and they would stand up and begin to look (around). Then it would be said: O people, go to your Lord, and make them stand there. And they would be questioned. Then it would be said: Bring out a group (out of them) for the Hell-Fire. And then it would be asked: How much? It would be said: Nine hundred and ninty-nine out of one thousand for the Hell-Fire and that would be the day which would make the children old because of its terror and that would be the day about which it has been said: "On the day when the shank would be uncovered" (lxviii. 42).

Book 41, Number 7024:

    Ya'qub b. 'Asim b. Urwa b. Mas'ud reported: I heard a person saying to 'Abdullah b. Amr: You say that the Last Hour would come at such and such time, whereupon he said: I had made up my mind that I would not narrate anything to you. I only said: But you would soon see after some time a very significant affair, for example the burning of the House (Ka'ba). Shu'ba said like this and 'Abdullah b Amr reported Allah's Messenger (may peace be upon him) having said: The Dajjal would appear in my Ummah. And in another hadith (the words are): None would survive who would have even a speck of faith in his heart, but he would be dead. Muhammad b. ja'far reported that Shu'ba narrated to him this hadith many a time and I also read it out to him many a time.

Book 41, Number 7025:

    Abdullah b. 'Amr reported: I committed to memory a hadith from Allah's Messenger (may peace be upon him) and I did not forget it after I had heard Allah's Messenger (may peace be upon him) as saying: The first sign (nut of the signs of the appearance of the Dajjal) would be the appearance of the sun from the west, the appearance of the beast before the people in the forenoon and whkch of the two hap- pens first, the second one would follow immediately after that.

Book 41, Number 7026:

    Abu Zur'a reported that three persons amongst Muslims had been sitting in Medina in the presence of Marwan b. Hakam and they heard him narrate these signs from him and the first amongst them was the appearance of the Dajjal. 'Abdullah b. 'Amr reported that Marwin said nothing (particular in this connection). I, however, heard a hadith from Allah's Messenger (may peace be upon him) and I did not forget that after I had heard that from Allah's Apostle (may peace be upon him) and he reported a hadith like the foregoing.

Book 41, Number 7027:

    Abu Zur'a reported that there was a discussion in the presence of Marwan about the Last Hour, and Abdullah b. 'Amr said: I heard Allah's Messenger (may peace be upon him) as saying. The rest of the hadith is the same, but there is no mention of forenoon.

Chapter 22 : THE HADITH PERTAINING TO THE SPY OF THE DAJJAL

Book 41, Number 7028:

    Amir b. Sharahil Sha'bi Sha'b Hamdan reported that he asked Fatima, daughter of Qais and sister of ad-Dahhak b. Qais and she was the first amongst the emigrant women: Narrate to me a hadith which you had heard directly from Allah's Messenger (may peace be upon him) and there is no extra link in between them. She said: Very well, if you like, I am prepared to do that, and he said to her: Well, do It and narrate that to me. She said: I married the son of Mughira and he was a chosen young man of Quraish at that time, but he fell as a martyr in the first Jihad (fighting) on the side of Allah's Messenger (may peace be upon him). When I became a widow, 'Abd al-Rahman b. Auf, one amongst the group of the Companions of Allah's Messenger (may peace be upon him), sent me the proposal of marriage. Allah's Messenger (may peace be upon him) also sent me such a message for his freed slave Usama b. Zaid. And it had been conveyed to me that Allah's Messenger (way peace be upon him) had said (about Usama): He who loves me should also love Usima. When Allah's Messenger (may peace be upon him) talked to me (about this matter), I said: My affairs are in your hand. You may marry me to anyone whom you like. He said: You better shift now to the house of Umm Sharik, and Umm Sharik was a rich lady from amongst the Anqir. She spent generously for the cause of Allah and entertained guests very hospitably. I said: Well, I will do as you like. He said: Do not do that for Umm Sharik is a woman who is very frequently vizited by guests and I do not like that your head may be uncovered or the cloth may be removed from your shank and the strangers may catch sight of them which you abhor. You better shift to the house of your cousin 'Abdullah b. 'Amr b. Umm Maktum and he is a person of the Bani Fihr branch of the Quraish, and he belonged to that tribe (to which F5tiina) belonged. So I shifted to that house, and when my period of waiting was over, I heard the voice of an announcer making an announcement that the prayer would be observed in the mosque (where) congregational prayer (is observed). So I set out towards that mosque and observed prayer along with Allah's Messenger (may peace be upon him) and I was in the row of the women which was near the row of men. When Allah's Messenger (may peace be upon him) had finished his prayer, he sat on the pulpit smiling and said: Every worshipper should keep sitting at his place. He then said: Do you know why I had asked you to assemble? They said: Allah and His Messenger know best. He said: By Allah. I have not made you assemble for exhortation or for a warning, but I have detained you here, for Tamim Dari, a Christian, who came and accepted Islam, told me something, which agrees with what I was-telling, yuu about the Dajjal. He narrated to me that he had sailed in a ship along with thirty men of Bani Lakhm and Bani Judham and had been tossed by waves in the ocean for a month. Then these (waves) took them (near) the land within the ocean (island) at the time of sunset. They sat in a small side-boat and entered that Island. There was a beast with long thick hair (and because of these) they could not distinguish his face from his back. They said: Woe to you, who can you be? Thereupon it said: I am al-Jassasa. They said: What is al-Jassasa? And it said: O people, go to this person in the monastery as he is very much eager to know about you. He (the narrator) said: When it named a person for us we were afraid of it lest it should be a Devil. Then we hurriedly went on till we came to that monastery and found a well-built person there with his hands tied to his neck and having iron shackles between his two legs up to the ankles. We said: Woe be upon thee, who are you? And he said: You would soon come to know about me. but tell me who are you. We said: We are people from Arabia and we embarked upon a boat but the sea-waves had been driving us for one month and they brought as near this island. We got Into the side-boats and entered this island and here a beast met us with profusely thick hair and because of the thickness of his hair his face could not be distinguished from his back. We said: Woe be to thee, who are you? It said: I am al- Jassasa. We said: What is al-Jassasa? And it said: You go to this very person in the monastery for he is eagerly waiting for you to know about you. So we came to you in hot haste fearing that that might be the Devil. He (that chained person) said: Tell me about the date-palm trees of Baisan. We &aid: About what aspect of theirs do you seek information ? He said: I ask you whether these trees bear fruit or not. We said: Yes Thereupon he said: I think these would not bear fruits. He said: Inform me about the lake of Tabariyya? We said: Which aspect of it do you want to know? He said: Is there water in it? They said: There is abundance of water in it. Thereupon he said: I think it would soon become dry. He again said: Inform me about the spring of Zughar. They said: Which aspect of it you want to know? He (the chained person) said: Is there water in it and does it irrigate (the land) ? We said to him: Yes, there is abundance of water in it and the inhabitants (of Medina) irrigate (land) with the help of it, He said: Inform me about the unlettered Prophet; what has he done? We said: He has come out from Mecca and has settled In Yathrib (Medina). He said: Do the Arabs fight against him? We said: Yes. He said: How did he deal with him? We informed him that he had overcome those in his neighbourhood and they had submitted themselves before him. Thereupon he said to us: Had it actually happened? We said: Yes. Thereupon he said: If it is so that is better for them that they should show obedience to him. I am going to tell you about. myself and I am Dajjal and would be soon permitted to get out and so I shall get out and travel in the land, and will not spare any town where I would not stay for forty nights except Mecca and Medina as these two (places) are prohibited (areas) for me and I would not make an attempt to enter any one of these two. An angel with a sword in his hand would confront me and would bar my way and there would be angels to guard every passage leading to it; then Allah's Messenger (may peace be upon him) striking the pulpit with the help of the end of his staff said : This implies Taiba meaning Medina. Have I not, told you an account (of the Dajjal) like this?'The people said: Yes, and this account narrated by Tamim Dari was liked by me for it corroborates the account which I gave to you in regard to him (Dajjal) at Medina and Mecca. Behold he (Dajjal) is in the Syrian sea (Mediterranian) or the Yemen sea (Arabian sea). Nay, on the contrary, he As In the east, he is in the east, he is in the east, and he pointed with his hand towards the east. I (Fatima bint Qais) said: I preserved It In my mind (this narration from Allah's Messenger (may peace be upon him).

Book 41, Number 7029:

    Al-Sha'bi reported: We visited Fatima b. Qais and she served us fresh dates which are called rutab and she also served us barley. I asked her about that woman in whose case three divorces had been pronounced as to how much time she should count as the waiting period. She said: My husband pronounced three divorces in my case and Allah's Messenger (may peace be upon him) permitted me to spend any waiting period in my family. (It was during this period) that announcement was made for the people to observe prayer in the bigger Mosque. I went there along with people and I was in the front row meant for women and it was adjacent to the last row of men and I heard Allah's Messenger (may peace be upon him) deliver sermon sitting on the pulpit. He said: The cousin of Tamim (Dari) sailed in the ocean. The rest of the hadith is the same but with this addition: "(I see) as if I am looking to Allah's Apostle (may peace be upon him) pointing his rod towards the land (and saying): It is Taiba, i.e. Medina."

Book 41, Number 7030:

    Tamim Dari came to Allah's Messenger (may peace be upon him) and informed Allah's Messenger (may peace be upon him) that he sailed in an ocean and his ship lost direction and thus landed at an island. They moved about in that land in search of water. There they saw a person who had been pulling his hair. The rest of the hadith is the same. And he (Dajjal) said: If I were to be permitted to set out I would have covered all the lands except Taiba. Then Allah's Messerger (may peace be upon him) brought (Tamim Dari) before the public and he narrated to them and said: That is Taiba and that is the Dajjal.

Book 41, Number 7031:

    Fatima b. Qais reported that Allah's Messenger (may peace be upon him) sat on the pulpit and said: O people, Tamim Dari has reported to me that some persons of his tribe sailed in the ocean in a boat and it capsised and then some of them travelled on one of the planks of the boat and they went to an island in the ocean. The rest of the hadith is the same.

Book 41, Number 7032:

    Anas b. Malik reported that Allah's Messenger (may peace be upon him) said: There will be no land which would not be covered by the Dajjal but Mecca and Medina, and there would no passage out of the passages leading to them which would not be guarded by angels arranged in rows. Then he (the Dajjal) would appear in a barren place adjacent to Medina and it would rock three times that every unbeliever and hypocrite would get out of it towards him.

Book 41, Number 7033:

    This hadith has been transmitted on the authority of Anas that Allah's Messenger (may peace be upon him) said this but with this addition that (the Dajjal would come) and pitch his tent in the waste-land of Juruf and thus there would come out of (the city) every hypocrite, man and woman.

Chapter 23 : THE REMAINING AHADITH PERTAINING TO THE DAJJAL

Book 41, Number 7034:

    Anas b. Malik reported that Allah's Messenger (may peace be upon him) said: The Dajjal would be followed by seventy thousand Jews of Isfahan wearing Persian shawls.

Book 41, Number 7035:

    Umm Sharik reported: I heard Allah's Messenger (may peace be upon him) as saying: The people would run away from the Dajjal seeking shelter in the mountains. She said: Where would be the Arabs then in that day? He said: They would be small in number.

Book 41, Number 7036:

    This hadith has been narrated on the authority of Ibn Juraij with the same chain of transmitters.

Book 41, Number 7037:

    Abu Qatada reported: We used to go to Imran b. Husain passing in front of Hisham b. 'Amir. He, one day, said: You pass by me (in order) to go to some per- sons but (amongst ttie living persons) none remained in the company of Allah's Messenger (may peace be upon him) more than I and none knows more ahadith than I. I heard Allah's Messenger (may peace be upon him) as saying: There would be no creation (creating more trouble) than the Dajjal right from the creation of Adam to the Last Hour.

Book 41, Number 7038:

    This hadith has been transmitted on the authority of 'Imran b. Husain with a slight variation of wording.

Book 41, Number 7039:

    Abu Huraira reported Allah's Messenger (may peace be upon him) having said: Hasten to do good deeds before six things happen: the rising of the sun from the west, the smoke, the Dajjal, the beast and (the death) of one of you or the general turmoil.

Book 41, Number 7040:

    Abu Huraira reported Allah's Messenger (may peace be upon him) as saying: Hasten in performing these good deeds (before these) six things (happen): (the appearance) of tribe Dijjal, the smoke, the beast of the earth, the rising of the sun from the west, the general turmoil (leadina to large-scale massacre) and death of masses and individuals.

Book 41, Number 7041:

    This hadith has been narrated on the authority of Qatada through another chain of transmitters.

Chapter 24 : THE EXCELLENCE OF WORSHIP IN THE PERIOD OF GENERAL TURMOIL

Book 41, Number 7042:

    Ma'qil b. Yasar reported Allah's Apostle (may peace be upon him) as saying: Worshiping during the period of widespread turmoil is like emigration towards me.

Chapter 25 : APPROACH OF THE LAST HOUR

Book 41, Number 7043:

    Abdullah reported Allah's Apostle (may peace be upon him) as saying: The Last Hour would affect (most terribly) the wicked persons.

Book 41, Number 7044:

    This hadith has been reported by Sahl b. Sa'd that he heard Allah's Messenger (may peace be upon him) as saying: I and the Last Hour are (close to each other) like this (and he, in order to explain it) pointed (by joining his) forefinger, (one) next to the thumb and the middle finger (together).

Book 41, Number 7045:

    Anas b. Malik reported that Allah's Messenger (way peace be upon him) said: I and the Last Hour have been sent like this. Shu'ba said: I heard Qatada as saying in his narration: The excellence of one over the other. And I do not know whether he narrated it from Anas or Qatada himself said so.

Book 41, Number 7046:

    Shu'ba reported: I heard Qatada and Abu Tayyab narrating that both of them heard Anas as narrating that Allah's Messenger (may peace be upon him) said: I and the Last Hour have been sent like this, and Shu'ba drew his forefinger and middle finger near each other while narrating it.

Book 41, Number 7047:

    This hadith has been narrated on the authority of Anas through another chain of transmitters.

Book 41, Number 7048:

    Anas reported Allah's Apostle (may peace be upon him) as saying like this, but he narrated it through another chain of transmitters.

Book 41, Number 7049:

    Anas reported Allah's Messenger (may peace be upon him) as saying: I and the Last Hour have been sent like this and (he while doing it) joined the forefinger with the middle finger.

Book 41, Number 7050:

    'A'isha reported that when the desert Arabs came to Allable Messenger (may peace be upon him) they asked about the Last Hour as to when that would come. And he looked towards the youngest amongst them and said: If he lives he would not grow very old that he would find your Last Hour coming to you the would see you dying).

Book 41, Number 7051:

    Anas reported that a person asked Allah's Messenger (may peace be upon him) as to when the Last Hour would come. He had in his presence a young boy of the Ansar who was called Mabammad. Allah's Messenger (may peace be upon bion) said: If this young boy lives. he may not grow very old till (he would see) the Last Hour coming to you.

Book 41, Number 7052:

    Anas b. Malik reported that a person asked Allah's Apostle (may peace be upon him): When would the Last Hour come? Thereupon Allah's Messenger (way peace be upon him) kept quiet for a while. then looked at a young boy in his presence belonging to the tribe of Azd Shanilwa and he said: If this boy lives he would not grow very old till the Last Hour would come to you. Anas said that this young boy was of our age daring those days.

Book 41, Number 7053:

    Anas reported: A young boy of Mughira b. Shu'ba happened to pass by (the Holy Prophet) and he was of my age Thereupon Allah's Apostle (may peace be apon him) said: If he lives long he would not grow very old till the Last Hour would come (to the old People of this generation).

Book 41, Number 7054:

    Abu Huraira reported Allah's Messenger (may peace be upon him) as saying: The Last Hour would come (so sudden) that a person would be milking the she- camel and the (milk) would not reach the brim of the vessel that the Last Hour would come, and the two persons would be engaged in buying and selling of the clothes and their bargain would not be struck before the Last Hour would come. And someone would be setting his tank in order and he would have hardly set it right when the Last Hour would come.

Chapter 26 : THE INTERVAL BETWEEN TWO BLOWINGS OF THE TRUMPET

Book 41, Number 7055:

    Abu Huraira reported Allah's Messenger (may peace be upon him) as saying: Between the two blowiings of the trumpet (there would be an interval of forty). They said: Abu Huraira, do you mean forty days? He said: I cannot say anything. They said: Do you mean fortv months? He said: I cannot say anything They said: Do you mean forty years? He said: I cannot say anything. Then Allah would cause the water to, descend from the sky and they (people) will sprout like vegetable The only thing in a man which would not decay would be one bone (spinal chord) from which the whole frame would be reconstituted on the Day of Resurrection.

Book 41, Number 7056:

    Abu Huraira reported Allah's Messenger (may peace be upon him) as say- ing: The earth would consume every son of Adam except his spinal chord from which his body would be reconstituted (on the Day of Resurrection).

Book 41, Number 7057:

    Abu Huraira reported so many ahadith from Allah's Apostle (may peace be upon him) and amongst these one was this that Allah's Messenger (may peace be upon him) said: There is a bone in the human being which the earth would never consume and it is from this that new bodies would be reconstituted (on the Day of Resurrection). They said: Allah's Messenger, which bone is that? Thereupon he said: It is the spinal bone.


BOOK 42: The Book Pertaining to Piety and Softening of Hearts (Kitab Al-Zuhd wa Al-Raqa'iq)

KITAB AL-ZUHD WA AL-RAQA'IQ
(BOOK PERTAINING TO PIETY AND SOFTENING OF HEARTS)

Back
Chapter 1 : ...

Book 42, Number 7058:

    Abu Huraira reported Allah's Messenger (may peace be upon him) as saying: The world is a prison-house for a believer and Paradise for a non-believer.

Book 42, Number 7059:

    Jabir b. Abdullah reported that Allah's Apostle (may p(-ace be upon him) happened to walk through the bazar coming from the side of 'Aliya and the people were on both his sides.There he found a dead lamb with very short ears. He took hold of his ear and said: Who amongst you would like to have this for a dirham? They said: We do not like to have it even for less than that as it is of no use to us. He said: Do you wish to have it (free of any cost)?They said: By Allah, even if it were alive (we would not have liked to possess that), for there is detect in it as its ear is very short; now it is dead also.Thereupon Allah's Messenger (may peace be upon him) said: By Allah, this world is more insignificant in the eye of Allah as it (this dead lamb) is in your eye.

Book 42, Number 7060:

    Jabir reported Allah's Apostle (may peace be upon him) narrating a hadith like this with a slight variation of wording.

Book 42, Number 7061:

    Mutarrif reported on the authority of his father: I came to Allah's Apostle (may peace be upon him) as he was reciting: "Abundance diverts you" (cii. 1).He said: The son of Adam claims: My wealth, my wealth.And he (the Holy Prophet) said: O son of Adam. is there anything as your belonging except that which you consumed, which you utilised, or which you wore and then it was worn out or you gave as charity and sent it forward?

Book 42, Number 7062:

    Mutarrif reported on the authority of his father: I went to Allah's Apostle (may peace be upon him).The rest of the hadith is the same.

Book 42, Number 7063:

    Abu Huraira reported Allah's Messenger (may peace be upon him) as saying: A servant says, My wealth. my wealth, but out of his wealth three things are only his: whatever he eats and makes use of or by means of which he dresses himself and it wears out or he gives as charity, and this is what he stored for himself (as a reward for the Hereafter), and what is beyond this (it is of no use to you) because you are to depart and leave it for other people.This hadith has been narrated on the authority of al-'Ala' b. 'Abd al-Rahman with the same chain of transmitters.

Book 42, Number 7064:

    Anas b. Malik reported Allah's Messenger (way peace be upon him) as saying: Three things follow the bier of a dead man. two of them come back and one is left with him: the members of his family. wealth and his-good deeds. The members of his family and wealth come back and the deeds alone are left with him.

Book 42, Number 7065:

    'Amr b. 'Auf, who was an ally of Banu 'Amir b. Luwayy (and he was one amongst them) who participated in Badr along with Allah's Messenger (way peace be upon him). reported that , Allah's Messenger (may peace be upon him) sent Abu Ubaida b. Jarrah to Bahrain for collecting Jizya and Allah's Messenger (may peace be upon him) had made a truce with the people of Bahrain and had appointed 'Ala' b. Hadrami and Abu Ubaida (for this purpose). They came with wealth from Bahrain and the Ansar beard about the arrival of Abu Ubaida and they had observed the dawn prayer along with Allah's Messenger (may peace be upon him), and when Allah's Messenger (may peace be upon him) had finished the prayer they (the Ansar) came before him and Allah's Messenger (may peace be upon him) smiled as he saw them and then said: I think you have heard about the arrival of Abu Ubaida with goods from Bahrain. They said: Allah's Messenger. yes, it is so.Thereupon he said: Be happy and be hopeful of that what gives you delight.By Allah, it is not the poverty about which I fear in regard to you but I am afraid in your case that (the worldly) riches way be given to you as were given to those who had gone before you and you begin to vie with one another for them as they vied for them. and these may destroy you as these destroyed them.

Book 42, Number 7066:

    This hadith has been narrated on the authority of Zuhri as reported by Yunus with a slight variation of wording.

Book 42, Number 7067:

    'Abdullah b. 'Amr b. al-As reported that Allah's Messenger (may peace be upon him) said: How would you be, 0 people. when Persia and Rome would be conquered for you?'Abd at-Rahman b Auf said: We would say as Allah has commanded us and we would express our gratitude to Allah Thereupon Allah's Messenger (may peace be upon him) said: Nothing else besides it?You would (in fact) vie with one another, then you would feel jealous. then your relations would be estranged and then you will bear enmity against one another. or something to the same effect.Then you would go to the poor emigrants and would make some the masters of the others.

Book 42, Number 7068:

    Abu Huraira reported that Allah's Messenger (may peace be upon him) said: When one of you looks at one who stands at a higher level than you in regard to wealth and physical structure he should also see one who stands at a lower level than you in regard to these things (in which he stands) at a hi-her level (as compared to him).

Book 42, Number 7069:

    This hadith has been narrated on the authority of Abu Huraira through another chain of transmitters.

Book 42, Number 7070:

    Abu Huraira reported Allah's Messenger (may peace be upon him) as saying: Look at those who stand at a lower level than you but don't look at those who stand at a higher level than you, for this would make the favours (conferred upon you by Allah) insignificant(in your eyes). Abu Mu'awiya said: Upon you.

Book 42, Number 7071:

    Abu Huraira ,narrated that he beard Allah's Messenger (may peace be upon him) as saying: There were three persons in Bani Isra'il, one suffering from leprosy, the other bald-headed and the third one blind. Allah decided to test them. So He sent an angel who came to one who was suffering from leprosy and said: Which thing do you like most? He said: Beautiful colour and fine skin and removal of that which makes me detestable in the eye of people. He wiped him and his illness was no more and he was conferred upon beautiful colour and beautiful skin.He (the angel) again said: Which property do you like most?He said: Camels, or he said: The cow the narrator is, however, doubtful about it, but (out of the persons) suffering from leprosy or baldness one of them definitely said: The came].And the other one said: Cow.And he (one who demanded came]) was bestowed upon a she-camel, in an advanced stage of pregnancy, and while giving he said: May Allah bless you in this I Then he came to the bald-headed person and said: Which thing do you like most?He said: Beautiful hair and that (this baldness) may be removed from me because of which people hate me He wiped his body and his illness was removed and he was bestowed upon beautiful hair, and the angel said: Which wealth do you like most? He said: The cow. And he was given a pregnant cow and while handing it over to him he (the angel) said: May Allah bless you in this I Then he came to the blind man and he said: Which thing do you like most?He said: Allah should restore my eyesight so that I should be able to see people with the help of that.He wiped his body and Allah restored to him his eyesight, and he (the angel) also said: Which wealth do you like most? He said.The flock of sheep.And he was given a pregnant goat and that gave birth to young ones and it so happened that one valley abounded in camels and the other one in goats and the third one in sheep.He then came to one suffering from leprosy in his (old) form and shape and he said: I am a poor person and my provision has run short in my journey and there is none to take me to my destination except with the help of Allah and your favour.I beg of you in His name Who gave you fine colour and fine skin, and the camel in the shape of wealth (to confer upon me) a camel which should carry me in my journey.He said: I have many responsibilities to discharge. Thereupon he said: I perceive as if I recognise you.Were you not suffering from leprosy whom people hated and you were a destitude and Allah conferred upon you (wealth) He said: I have inherited this property from my forefathers.Thereupon he said: If you are a liar may Allah change you to that very position in which you had been.He then came to the one who was bald-headed in his (old) form and said to him the same what he had said to him (one suffering from leprosy) and he gave him the same reply as he had given him and he said: If you 'are a liar, may Allah turn you to your previous position in which you had been.And then he came to the blind man in his (old) form and shape and he said: I am a destitute person and a wayfarer.My provision have ran short and today there is no way to reach the destination but with the help of Allah and then with your help and I beg of you in the (name) of One Who restored your eyesight and gave you the flock of sheep to give me a sheep by which I should be able to make my provisions for the journey.He said: I was blind and Allah restored to me my eyesight; you take whatever you like and leave whatever you like. By Allah.I shall not stand in your way today for what you take in the name of God. Thereupon, he said: You keep with you what you have (in your possession). The fact is that you three were put to test and Allah is well pleased with you and He is annoyed with your companions.

Book 42, Number 7072:

    It is reported on the authority of Amir b. Sa'd that Sa'd b. Abi Waqqas was in the fold of his camels that his son 'Umar came to him.When Sa'd saw him he said: I seek refuge with Allah from the mischief of this rider. And as he got down he said to him: You are busy with your camels and your sheep and you have abandoned people who are contending with one another for kingdom.Sa'd struck his chest and said: Keep quite. I heard Allah's Messenger (may peace be upon him) as saying: Allah loves the servant who is God-conscious and is free from want and is hidden (from the view of people).

Book 42, Number 7073:

    Sa'd b. Abu Waqqas is reported to have, said : By Allah, I am the first person amongst the Arabs to throw an arrow in the cause of Allah and we used to go with Allah's Messenger (may peace be upon him) and there was no food for us to eat but only the leaves of hubla and samur trees (they are wild trees) and as a result thereof one amongst us would relieve himself as does the goat. (How strange it is) that now the people of Banu Asad (the progeny of Zubair) instruct me in religion and try to impose punishment upon me (in regard to it).If it is so (that I am so ignorant of religion), then indeed, I am undone and my deeds have been lost. Ibn Numair, however, did not make a mention of the word (idhan) thus? (in his narration).

Book 42, Number 7074:

    This hadith has been narrated on the authority of Isma'il b. Khalid with the same chain of transmitters and the words are: "One amongst us would relieve himself as the goats do without anything mixing with its excrement."

Book 42, Number 7075:

    'Umair al-'Adawi reported: 'Utba b. Ghazwan delivered us a sermon and he praised Allah and lauded Him, then said : Now coming to the point, verily the world has been given the news of its end and that too quite early. Nothing would be left out of it but only water left in the utensil which its owner leaves, and you are going to shift to an abode which knows no end, and you should shift with the good before you, for we have been told that a stone would be thrown at one side of the Hell and it would go down even for seventy years but would not be able to reach its bottom.By Allah, it would be fully packed.Do you find it something strange, and it has been mentioned that there yawns a distance which one would be able to cover in forty years from one end to another of Paradise, and a day would come when it would be fully packed and you must be knowing that I was the seventh amongst seven who had been with Allah's Messenger (may peace be upon him) and we had nothing to eat but the leaves of the tree until the corners of the mouth were injured. We found a sheet which we tore in two and divided between myself and Sa'd b. Malik. I made the lower garment with halt of it and so did Sa'd make the lower garment with half of it and today there is none amongst us who has not become the governor of a city from amongst the cities (of the Islamic Commonwealth) and I seek refuge with Allah that I should consider myself great whereas I am insignificant in the eye of Allah.Prophethood does not remain for ever and its impact fades with the result that it changes eventually into kingship, and you would soon come to know and experience those rulers who would come after us and see (how far they are from religion).

Book 42, Number 7076:

    Khalid b. 'Umair reported and he had seen the pre-Islamic days also, that 'Uqba b. Ghazwan delivered this address and he was the governor of Basra.The rest of the hadith is the same as transmitted by Shaiban.

Book 42, Number 7077:

    Khalid b. Umair reported: I heard Uqba b. Ghazwan as saving: I found myself as the seventh amongst the seven who had been along with Allah's Messenger (may peace be upon him).We had nothing to eat but the leaves of hubla (a wild tree) until the corners of our mouths were injured.

Book 42, Number 7078:

    Abu Huraira reported that they (the Companions of the Holy Prophet) said: Allah's Messenger, will we be able to see our Lord on the Day of Judgment? He said: Do you feel any difficulty in seeing the sun in the noon when there is no cloud over it? They said: No. He again said: Do you feel any difficulty in seeing the moon on the fourteenth night when there is no cloud over it?They said: No. Thereupon he said: By Allah Who is One in Whose Hand is my life. you will not face any difficulty in seeing your Lord but only so much as you feel in seeing one of them. Then Allah would sit in judgment upon the servant and would say: O, so and so, did I not honour you and make you the chief and provide you the spouse and subdue for you horses, camels, and afforded you an opportunity to rule over your subjects? He would say: Yes.And then it would be said: Did you not think that you would meet Us? And he would say: No. Thereupon He (Allah) would say: Well, We forget you as you forgot Us.Then the second person would be brought for judgment. (And Allah would) say: 0, so and so. did We not honour you and make you the chief and make you pair and subdue for you horses and camels and afford you an opportunity to rule over your subjects?He would say: Yes, my Lord.And He (the Lord) would say: Did you not think that you would be meeting Us?And he would say: No. And then He (Allah) would say: Well, I forget you today as you forgot Us.Then the third -one would be brought and He (Allah) would say to him as He said before.And he (the third person) would say: O, my Lord, I affirmed my faith in Thee and in Thy Book and in Thy Messenger and I observed prayer and fasts and gave charity, and he would speak in good terms like this as he would be able to do.And He (Allah) would say: Well, We will bring our witnesses to you.And the man would think in his mind who would bear witness upon him and then his mouth would be sealed and it would be said to his thighs, to his flesh and to his bones to speak and his thighs. flesh and bones would bear witness to his deeds and it would be done so that he should not be able to make any excuse for himself and he would be a hypocrite and Allah would be annoyed with him.

Book 42, Number 7079:

    Anas b. Malik reported: We were in the company of Allah's Messenger (way peace be upon him) that he smiled and said: Do you know why I laughed? We said: Allah and His Messenger, know best.Thereupon he said: It was because of the (fact that there came to my mind the) talk which the servant would have with his Lord. (on the Day of judgment).He would say: My Lord, have you not guaranteed me protection against injustice? He would say : Yes.Then the servant would say: I do not deem valid any witness against me but my own self, and He would say: Well, enough would he the witness of your self against you and that of the two angels who had been appointed to record your deeds.Then the seal would be set upon his mouth and it would be said to his hands and feet to speak and they would speak of his deeds.Then the mouth would be made free to talk, he would say (to the bands and feet): Be away, let there be curse of Allah upon you.It was for your safety that I contended.

Book 42, Number 7080:

    Abu Huraira reported Allah's Messenger (may peace be upon him) as saying: O Allah, make for the family of Muhammad the provision which is a bare subsistence.

Book 42, Number 7081:

    Abu Huraira reported Allah's Messenger (may peace be upon him) as saying: 0 Allah, provide for the, family of Muhammad their subsistence, and in the narration transmitted on the authority of 'Amr (the words are): " O Allah, provide us subsistence "

Book 42, Number 7082:

    'Umara b. al-Qa'qa' reported this hadith with the same chain of transmitters but instead of the word "qut" (bare subsistence) there has been used the word "Kafaf" (adequate means to meet the needs).

Book 42, Number 7083:

    'A'isha reported: Never had the family of Muhammad (may peace be upon him) eaten to the fill since their, arrival in Medina with the bread of wheat for three successive nights until his (Holy Prophet's) death.

Book 42, Number 7084:

    'A'isha reported Allah's Messenger (may peace be upon him) as saying: Never did Allah's Messenger (may peace be upon him) eat to his fill the bread of wheat for three successive days until he had run the course of his life.

Book 42, Number 7085:

    'A'isha reported: Never did the family of Muhammad (may peace be upon him) eat to the fill the bread of barley for two successive days until Allah's Messenger (may peace be upon him) died.

Book 42, Number 7086:

    'A'isha reported: Never could the family of Muhammad (may peace be upon him) (afford to cat to the fill) the bread of wheat beyond three days (successively).

Book 42, Number 7087:

    'A'isha reported: Never could the family of Muhammad (may peace. be upon him) (afford to eat) the bread of wheat for three (successive days) until he ran the course of his life.

Book 42, Number 7088:

    'A'isha reported: Never could the family of Muhammad (may peace be upon him) (afford to eat) the bread of wheat for two days successively.Even (out of these two days) one (was such wherein he could get) only a date.

Book 42, Number 7089:

    'A'isha reported: We the family of Muhammad (may peace be upon him) used to spend (the whole) month in which we (did not need to) kindle the fire as (we had nothing to cook); we had only dates and water (to fill our bellies).

Book 42, Number 7090:

    This hadith has been narrated on the authority of 'Urwa with the same chain of transmitters (and the words are): "We used to spend-" And he did not make a mention of the family of Muhammad (may peace be upon him), and Abu Kuraib made this addition to his hadith which was transmitted on the authority of Ibn Numair (and the words are): "But this that there was brought to us some meat."

Book 42, Number 7091:

    'A'isha reported that Allah's Messenger (way peace be upon him) died (in such a state) that there had been nothing in my wooden tub which a living being could afford to eat but a handful of barley therein. I had been eating out of that for a fairly long duration when I thought of measuring it and it was almost finished.

Book 42, Number 7092:

    'A'isha used to say to 'Urwa: Son of my sister, by Allah, I used to see the new moon, then the new moon, then the new moon, i.e. three moons in two months, and fire was not kindled in the house of Allah's Messenger (may peace be upon him).I ('Urwa) said: Auntie, then what were your means of sustenance?She said: Dates and water.But it (so happened) that Allah's Messenger (may peace be upon him) had some Ansar as his neighbours and they had milch animals and they used to send to Allah's Messenger (may peace be upon him) some milk of their (animals) and he served that to us.

Book 42, Number 7093:

    'Urwa b. Zubair reported on the authority of 'A'isha, the wife of Allah's Apostle (may peace be upon him), that she said: Allah's Messenger (may peace be upon him) died (in a state) that it never happened that he could eat to his fill the bread with olive oil twice during a day.

Book 42, Number 7094:

    'A'isha reported this hadith through other chains of transmitters also (and the words are) that Allah's Messenger (may peace be upon him) died (in a state) when the people could afford to eat only the dates and water.

Book 42, Number 7095:

    'A'isha reported that Allah's Messenger (may peace be upon him) had died in a state that they could afford to cat two things only: water and dates.

Book 42, Number 7096:

    This hadith has been transmitted on the authority of Sufyan and the words are: "We could not afford to eat to the fill even dates and water."

Book 42, Number 7097:

    Abu Huraira reported: By Him in Whose Hand is my life and Ibn 'Abbad also said: By One in Whose hand is the life of Abu Huraira, Allah's Messenger (may peace be upon him) could not afford to provide adequate food to his family which could (fill their bellies) with bread and wheat for three days successively until he left the world.

Book 42, Number 7098:

    Abu Hazim reported: I saw Abu Huraira point with his finger many a time and saying: By One in Whose Hand is the life of Abu Huraira, Allah's Apostle (may peace be upon him) could not eat to his fill and provide his family bread of wheat beyond three days successively until he left the world.

Book 42, Number 7099:

    Nu'man b. Bashir said: Don't you eat and drink according to your heart's desire, whereas I saw that your Prophet (may peace be upon him) (at times) could not find even an inferior quality of the dates with which he could fill his belly ? Qutaiba, however, did not make a mention of It.

Book 42, Number 7100:

    This hadith has been narrated on the authority of Simak with the same chain of transmitters, with this addition of words: "You are not satisfied with the qualities of dates and butter."

Book 42, Number 7101:

    Simak b. Barb reported: I heard Nu'man deliver an address in which he said that (Hadrat) Umar made a mention of what had fallen to the lot of people out of the material world and he said: I saw Allah's Messenger (may peace be upon him) spend the whole day being upset because of hunger and he could not get even an interior quality of dates with which he could fill his belly.

Book 42, Number 7102:

    'Abd al-Rahman al-Hubuli reported: I heard that a person asked 'Abdullah b. 'Amr b. 'Asas saying: Are we not amongst the destitute of the emigrants ? Abdullah said to him: Have you a spouse with whom you live?He said: Yes.He again said: Then you are amongst the rich.He said: I have a servant also. Thereupon he (Abdullah b. 'Amr b. 'As) said: Then you are amongst the kings.
    Abu 'Abdal-Rahman reported that three persons came to 'Abdullah b. Amr b. 'As while I was sitting with him and they said: By Allah, we have nothing with us either in the form of provision, riding animals or wealth.Thereupon he said to them: I am prepared to do whatever you like.If you come to us, we would give you what Allah would make available for you. and if you like I would make a mention of your case to the ruler, and if you like you can show patience also. for I have beard Allah's Messenger (may peace be upon him) as saying: Destitute amongst the emigrants would precede the rich emigrants by forty years in getting into Paradise on the Day of Resurrection.Thereupon they said: We then, show patience and do not ask for anything.

Chapter 2 : DO NOT ENTER BUT WFEPINGLY THE HABITATIONS OF THOSE WHO COMMITIED ATROKITIES UPON THEMSELVES

Book 42, Number 7103:

    'Abdullah b. Umar reported that Allah's Messenger (may peace be upon him) said in connection with the people of Hijr (Thamud): Do not enter but weepingly (the habitations) of these people who bad been punished by (Allah), and in case you do not feel inclined to weep, then do not enter (these habitations) that you may not meet the same calamity as had fallen to their lot.

Book 42, Number 7104:

    Ibn Shihab reported, and he had been talking about the stony abodes of Thamud, and he said: Salim b. 'Abdullah reported that 'Abdullah b. Umar said : We were passing along with Allah's Messenger (may peace be upon him) through the habitations of Hijr, and Allah's Messenger (may peace be upon him) said: Do not enter but weepingly the habitations of these persons who committed tyranny among themselves, lest the same calamity should fall upon you as it fell upon them.He then urged his mount to proceed quickly and pass through that valley hurriedly.

Book 42, Number 7105:

    Abdullah b. 'Umar reported that the people encamped along with Allah's Messenger (may peace be upon him) in the valley of Hijr, the habitations of Thamud, and they quenched their thirst from the wells thereof and kneaded the flour with it. Thereupon Allah's Messenger (may peace be upon him) commanded that the water collected for drinking should be spilt and the flour should be given to the camels and commanded them that the water for drinking should be taken from that well where the she-camel (of Hadrat Salih) used to come.

Book 42, Number 7106:

    This hadith has been narrated on the authority of 'Abdullah with the same chain of transmitters but with a slight variation of wording.

Chapter 3 : BENEVOLENT TREATMENT TO THE WIDOWS, ORPHANS AND THE POOR

Book 42, Number 7107:

    Abu Huraira reported that Allah's Messenger (may peace be upon him) said: One who makes efforts (for earning to be spent) on a widow and the destitute is like a striver in the cause of Allah, and I think he also said: He is like one who constantly stands for prayer and observes fast without breaking it.

Book 42, Number 7108:

    Abu Huraira reported that Allah's Messenger (may peace be upon him) said: One who looks after the orphan whether he is his relative or not, I and he would be together in Paradise like this, and Malik (explained it) with the gesture by drawing his index finger and middle finger close together.

Chapter 4 : EXCELLENCE OF BUILDING MOSQUES

Book 42, Number 7109:

    Abdullah al-Khaulani reported that when Uthman b. 'Affan tried to rebuild the mosque of Allah's Messenger (may peace be upon him) the people began to talk about this. Uthman b. 'Affan said: You discuss it very much whereas I have heard Allah's Messenger (may peace be upon him) as saying: He who builds a mosque-- and the narrator Bukair said: I think he also said: (for) seeking the pleasure of Allah- Allah would build (a similar house for him in Paradise). and in the narration of Harun (the words are): "A house for him in Paradise."

Book 42, Number 7110:

    Mahmud b. Labid reported that 'Uthman b. 'Affan decided to rebuild the mosque (of Allah's Apostle in Medina) but the people did not like this idea and they wished that it should be preserved in the same (old) form.Thereupon he (Hadrat 'Uthman) said: I heard Allah's Messenger (may peace be upon him) as saying: He who builds a mosque for Allah, Allah would build for him (a house) in Paradise like it.

Book 42, Number 7111:

    This hadith has been narrated on the authority of Ja'far with the same chain of transmitters with this variation (that the words are): "Allah would build for him a house in Paradise."

Chapter 5 : CHARITY TO BE GIVEN TO THE POOR OR THE WAYFARERS

Book 42, Number 7112:

    Abu Huraira reported: While a person was in the wilderness he heard a voice from the cloud (commanding it thus): Irrigate the garden of so and so. (After that the clouds slinked aside and poured water on a stony ground.It filled a channel amongst the channels of that land and that person followed that water and he found a person standing in the garden busy in changing the course of water with the help of a hatchet.He said to him: Servant of Allah, what is your name? he said: So and so. And it was that very name which he had heard from the clouds. and he said to him: Servant of Allah, why do you ask me my name?He said: I beard a voice from the clouds of which It is the downpour, saying: Water the garden of so and to. like your name. What do you do (for the favour) shown to you by Allah in this matter? He said: Now as you state so.I look what yield I get from it. and I give one-third as charity out of it and I and my children eat one-third of it and one-third I return to it as investment.

Book 42, Number 7113:

    This hadith has been narrated on the authority of Wahb b. Kaisan with the same chain of transmitters but with this change that he said: "I earmark one-third for the poor, the needy and the wayfarers."

Chapter 6 : HE WHO ASSOCIATES ONE AS AN OBJECT OF WORSHIP WITH ALLAH IN HIS DEEDS

Book 42, Number 7114:

    Abu Huraira reported Allah's Messenger (may peace be upon him) as stating that Allah the Most High and Exalted said: I am the One, One Who does not stand in need of a partner.If anyone does anything in which he associates anyone else with Me, I shall abandon him with one whom he associates with Allah.

Chapter 7 : THE PROHIBITION OF SIMULATION AND OSTENTATION

Book 42, Number 7115:

    Ibn Abbas reported Allah's Messenger (may peace be upon him) as saying: If anyone wants to have his deeds widely publicised, Allah will publicise (his humiliation).And if anyone makes a hypocritical display (of his deeds) Allah will make a display of him.

Book 42, Number 7116:

    Jundub reported Allah's Messenger (may peace be upon him) as saying: He who wants to publicise (his deeds), Allah will publicise (his humility), and he who makes a hypocritical display (of his deeds), Allah will make a display of him.

Book 42, Number 7117:

    Sufyan reported this hadith with the same chain of transmitters and he made this addition: "I did not hear anyone saying besides him that it was Allah's Messenger (may peace be upon him) who had said so."

Book 42, Number 7118:

    Salama b. Kuhail reported: I heard from Jundub but I did not hear him say like this: "I beard Allah's Messenger (way peace be upon him) as saying this."

Book 42, Number 7119:

    Abu Sufyan reported like that as as-Saduq al-Amin al-Walid b. Harb narrated with the same chain of transmitters.

Chapter 8 : PERTAINING TO THE GUARDING OF TONGUE

Book 42, Number 7120:

    Abu Huraira reported that he heard Allah's Messenger (may peace be upon him) as saying: The servant speaks words for which he is sent down to the Hell-Fire farther than the distance between the cast and the west.

Book 42, Number 7121:

    Abu Huraira reported Allah's Messenger (may peace be upon him) as saying: The servant speaks words that he does not understand its repercussions but he sinks down in Hell-Fire farther than the distance between the east and the west.

Chapter 9 : THE PUNISTIMENT OF ONE WHO COMMANDS OTHERS TO DO GOOD BUT DOES NOT DO IT HIMSELF AND RE FORBIDS OTHERS TO DO EVIL BUT DOES NOT HIMSELF REFRAIN FROM IT

Book 42, Number 7122:

    Shaqiq reported that it was said to Usama b. Zaid: Why don't you visit 'Uthman and talk to him? Thereupon he said: Do you think that I have not talked to him but that I have made you hear? By Allah. I have talked to him (about things) concerning me and him and I did not like to divulge those things about which I had to take the initiative and I do not say to my ruler: "You are the best among people," after I beard Allah's Messenger (may peace be upon him) as saying: A man will be brought on the Day of Resurrection and thrown in Hell-Fire and his intestines will pour forth in Hell and he will go round along with them, as an ass goes round the mill. stone. The denizens of Hell would gather round him and say: 0, so and so, what has happened to you? Were you not enjoining us to do what was reputable and forbid us to do what was disreputable? He will say: Of course, it is so; I used to enjoin (upon people) to do what was reputable but did not practise that myself. I had been forbidding people to do what was disreputable, but practised it myself.

Book 42, Number 7123:

    Abu Wa'il reported: I was in the company of Usama b. Zaid that a person said: What prevents you to visit Uthman and talk to him for what he does? The rest of the hadith is the same.

Chapter 10 : IT IS FORBIDDEN TO PUBLICISE ONE'S SINS

Book 42, Number 7124:

    Abu Huraira reported Allah's Messenger (may peace be upon him) as saying: All the people of my Ummah would get pardon for their sins except those who publicise them. And (it means) that a servant should do a deed during the night and tell the people in the morning that he has done so and so, whereas Allah has concealed it. And he does a deed during the day and when it is night he tells the people, whereas Allah has concealed it. Zuhair has used the word hijar for publicising.

Chapter 11 : SNEEZING AND THE DISAPPROVAL OF YAWNING

Book 42, Number 7125:

    Anas b. Malik reported that two persons sneezed in the presence of Allah's Messenger (may peace be upon him). He (the Messenger of Allah) invoked mercy for one, and did not invoke for the other. The one for whom he had not prayed said: So and so sneezed and you said: May Allah have mercy upon you. I also sneezed but you did not utter these words for me. Thereupon he (the Holy Prophet) said: That person praised Allah, and you did not praise Allah.

Book 42, Number 7126:

    This hadith has been narrated on the authority of Anas through another chain of transmitters.

Book 42, Number 7127:

    Abu Burda reported: I visited Abu Musa, as he was in the house of the daughter of Fadl b. 'Abbas. I sneezed but he did not respond to it (by saying): Allah may have mercy upon you. Then she sneezed and he (Fadl b. 'Abbas) said: May Allah have mercy upon you. I came back to my mother and informed her about it, and when he came to her she said: My son sneezed in your presence and you did not say: "Allah may have mercy upon you, and she sneezed and you said for her: "May Allah have mercy upon you." Thereupon he said: Your son sneezed but he did not praise Allah and I did not beg mercy of Allah for him and she sneezed and she praised Allah and so I said: May Allah have mercy upon you, as I heard Allah's Messenger (may peace be upon him) as saying: When any one of you sneezes he should praise Allah and the other should say: May Allah have mercy upon you, and if he does not praise Allah, no mercy should be begged for him.

Book 42, Number 7128:

    Iyas b. Salama b. al-Akwa reported that his father reported to him that he heard Allah's Apostle (may peace be upon him) as saying: A person sneezed in his presence and he said to him: May Allah have mercy upon you. And he then sneezed for the second time and Allah's Messenger (may peace be upon him) said to him: He is suffering from cold (and no response is necessary).

Book 42, Number 7129:

    Abu Huraira reported Allah's Messenger (may peace be upon him) as saying: The yawning as from the devil. So when one of you yawns he should try to restrain it as far as it lies in his power.

Book 42, Number 7130:

    The son of Abu Said al-Khudri reported on the authority of his father that Allah's Messenger (may peace be upon him) said: When one of you yawns, he should keep his mouth shut with the help of his hand, for it is the devil that enters therein.

Book 42, Number 7131:

    The son of Abu Said al-Khudri reported on the authority of his father that Allah's Messenger (may peace be upon him) said: When one of you yawns, he should try to restrain it with cue help of his hand since it is the Satan that enters therein.

Book 42, Number 7132:

    The son of Abu Said al-Khudri reported on the authority of his father that Allah's Messenger (may peace be upon him) said. When one of you yawns while engaged in prayer, he should try to restrain so far as it lies in his power, since it is the Satan that enter therein.

Book 42, Number 7133:

    Abu Said al-Khudri reported Allah's Messenger (may peace be upon him) a hadith like this through another chain of transmitters.

Chapter 12 : MISCELLANEOUS AHADITH

Book 42, Number 7134:

    'A'isha reported that Allah's Messenger (may peace be upon him) said: The Angels were born out of light and the Jinns were born out of the spark of fire and Adam was born as he has been defined (in the Qur'an) for you (i.e. he is fashioned out of clay).

Book 42, Number 7135:

    Abu Huraira reported that Allah's Messenger (may peace be upon him) said: A group of Bani Isra'il was lost. I do not know what happened to it, but I think (that it 'underwent a process of metamorphosis) and assumed the shape of rats. Don't you see when the milk of the camel is placed before them, these do not drink and when the milk of goat is placed before them, these do drink. Abu Huraira said: I narrated this very hadith to Ka'b and he said: Did you hear this from Allah's Messenger (may peace be upon him)? I (Abu Huraira) said: Yes. He said this again and again, and I said: Have I read Torah? This hadith has been transmitted on the authority of Ishaq with a slight variation of wording.

Book 42, Number 7136:

    Abu Huraira reported that the rat (is the result of) metamorphosis (of a group of Bani Isra'il) and the proof of this is that when the milk of goat is placed before it, it drinks it, and when the milk of the camel is placed before it, it would not taste it at all. Ka'b said: Did you hear it from Allah's Messenger (may peace be upon him)? Thereupon he said: Has Torah been revealed to me?

Chapter 13 : THE BELIEVER DOES NOT PROVIDE OPPORTUNITY TO BE STUNG TWICE FROM ONE (AND THE SAME) HOLE

Book 42, Number 7137:

    Abu Huraira reported that Allah's Messenger (may peace be upon him) said: The believer does not allow to be stung twice from one (and the same) hole. This hadith has been narrated on the authority of Abu Huraira through another chain of transmitters.

Chapter 14 : EVERY ACT OF A BELIEVER IS A BLESSING FOR HIM

Book 42, Number 7138:

    Suhaib reported that Allah's Messenger (may peace be upon him) said: Strange are the ways of a believer for there is good in every affair of his and this is not the case with anyone else except in the case of a believer for if he has an occasion to feel delight, he thanks (God), thus there is a good for him in it, and if he gets into trouble and shows resignation (and endures it patiently), there is a good for him in it.

Chapter 15 : IT IS PROHIBITED TO PRAISE ANYONE SO MUCH THAT THERE MAY BE FEAR OF HIS BEING INTOXICATED BECAUSE OF THAT

Book 42, Number 7139:

    'Abd al-Rahman b. Abu Bakra reported on the authority of his father that a person praised another person in the presence of Allah's Apostle (may peace be upon him), whereupon he said: Woe be to thee, you have broken the neck of your friend, you have broken the neck of your friend-he said this twice. If one of you has to praise his friend at all, he should say: I think (him to be) so and Allah knows it well and I do not know the secret of the heart and Allah knows the destined end, and I cannot testify his purity against Allah but (he appears) to be so and so.

Book 42, Number 7140:

    Abd al-Rahman b. Abu Bakra reported on the authority of his father that a person was mentioned in the presence of Allah's Apostle (may peace be upon him), and a person said: Allah's Messenger, no person is more excellent than he after Allah's Messenger (may peace be upon him). Thereupon Allah's Apostle (may peace be upon him) said: Woe be to thee, you have broken the neck of your friend, and he said this twice. Then Allah's Messenger (may peace be upon him) said: If anyone has to praise his brother at all, he should say: I think him to be so and so, and even on this he should say: I do not consider anyone purer than Allah (considers). This hadith has been transmitted on the authority of Shu'ba with a slight variation of wording.

Book 42, Number 7141:

    Abu Musa reported Allah's Messenger (may peace be upon him) saw a person lauding another person or praising him too much. Thereupon he said: You killed him, or you sliced the back of a person.

Book 42, Number 7142:

    Abu Ma'mar reported that a person lauded a ruler amongst the rulers and Miqdad began to throw dust upon him and he said: Allah's Messenger (may peace be upon him) commanded us that we should throw dust upon the faces of those who shower too much praise.

Book 42, Number 7143:

    Hammam b. al-Harith reported that a person began to praise 'Uthman and Miqdad sat upon his knee; and he was a bulky person and began to throw pebbles upon his (flatterer's) face. Thereupon 'Uthman said: What is the matter with you? And he said: Verily, Allah's Messenger (may peace be upon him) said: When you see those who shower (undue) praise (upon others), throw dust upon their faces.

Book 42, Number 7144:

    This hadith has been narrated on the authority of Miqdad through another chain of transmitters.

Chapter 16 : THE OLDER ONE IS TO BE PREFERRED

Book 42, Number 7145:

    'Abdullah b. Umar reported that Allah's Messenger (may peace be upon him) said: It was shown in a vision that I was rinsing my mouth with miswak and two persons began to contend with one another for getting that miswak. One was older than the other. I gave the miswak to the younger one amongst them, but it was said to me: (Let it be given) to the older one. So I gave it to the older one.

Chapter 17 : TO STATE HADITH AFTER ITS VERIFICATION AND RECORDING OF "KNOWLEDGE"

Book 42, Number 7146:

    It was reported that Abu Huraira used to say: Listen to me, inmate of the apartment; listen to me, inmate of the apartment, while 'A'isha (Allah be pleased with her) had been busy in observing prayer. As she finished prayer, she said to "Urwa: Did you hear his words? And this is how Allah's Messenger (may peace be upon him) used to utter (so distinctly) that if one intended to count (the words uttered) he would be able to do so.

Book 42, Number 7147:

    Abu Sa'id Khudri reported that Allah's Messenger (may peace be upon him) said: Do not take down anything from me, and he who took down anything from me except the Qur'an, he should efface that and narrate from me, for there is no harm in it and he who attributed any falsehood to me-and Hammam said: I think he also said: "deliberately"-he should in fact find his abode in the Hell-Fire.

Chapter 18 : THE STORY OF THE PEOPLE OF THE DITCH, THE MAGICIAN, THE MONK AND THE SLAVE

Book 42, Number 7148:

    Suhaib reported that Allah's Messenger (may peace be upon him) thus said: There lived a king before you and he had a (court) magician.As he (the magician) grew old, he said to the king: I have grown old, send some young boy to me so that I should teach him magic.He (the king) sent to him a young man so that he should train him (in magic).And on his way (to the magician) he (the young man) found a monk sitting there.He (the young man) listened to his (the monk's) talk and was impressed by it.It became his habit that on his way to the magician he met the monk and set there and he came to the magician (late).He (the magician) beat him because of delay.He made a complaint of that to the monk and he said to him: When you feel afraid of the magician, say: Members of my family had detained me.And when you feel afraid of your family you should say: The magician had detained me.It so happened that there came a huge beast (of prey) and it blocked the way of the people, and he (the young boy) said: I will come to know today whether the magician is superior or the monk is superior.He picked up a stone and said: O Allah, if the affair of the monk is dearer to Thee than the affair of the magician, cause death to this animal so that the people should be able to move about freely.He threw that stone towards it and killed it and the people began to move about (on the path freely).He (the young man) then came to that monk and Informed him and the monk said: Sonny, today you are superior to me.Your affair has come to a stage where I find that you would be soon put to a trial, and in case you are put to a trial don't give my clue.That young man began to treat the blind and those suffering from leprosy and he in fact began to cure people from (all kinds) of illness.When a companion of the king who had gone blind heard about him, he came to him with numerous gifts and said: If you cure me all these things collected together here would be yours.Be said: I myself do not cure anyone.It is Allah Who cures and if you affirm faith in Allah, I shall also supplicate Allah to cure you.He affirmed his faith in Allah and Allah cured him and he came to the king and sat by his side as he used to sit before.The king said to him: Who restored your eyesight?He said: My Lord.Thereupon he said: It means that your Lord is One besides me.He said: My Lord and your Lord is Allah, so he (the king) took hold of him and tormented him till he gave a clue of that boy.The young man was thus summoned and the king said to him: O boy, it has been conveyed to me that you have become so much proficient in your magic that you cure the blind and those suffering from leprosy and you do such and such things.Thereupon he said: I do not cure anyone; it is Allah Who cures, and he (the king) took hold of him and began to torment him. So he gave a clue of the monk.The monk was thus summoned and it was said to him: You should turn back from your religion.He, however, refused to do so.He (ordered) for a saw to be brought (and when it was done) he (the king) placed it in the middle of his head and tore it into parts till a part fell down.Then the courtier of the king was brought and it was said to him: Turn back from your religion.Arid he refused to do so, and the saw was placed in the midst of his head and it was torn till a part fell down.Then that young boy was brought and it was said to him: Turn back from your religion.He refused to do so and he was handed over to a group of his courtiers.And he 'said to them: Take him to such and such mountain; make him climb up that mountain and when you reach its top (ask him to renounce his faith) but if he refuses to do so, then throw him (down the mountain).So they took him and made him climb up the mountain and he said: O Allah, save me from them (in any way) Thou likest and the mountain began to quake and they all fell down and that person came walking to the king. The king said to him: What has happened to your companions?He said: Allah has saved me from them.He again handed him to some of his courtiers and said: Take him and carry him in a small boat and when you reach the middle of the ocean (ask him to renounce) his religion, but if he does not renounce his religion throw him (into the water).So they took him and he said: O Allah, save me from them and what they want to do.It was quite soon that the boat turned over and they were drowned and he came walking to the king, and the king said to him: What has happened to your companions?He said: Allah has saved me from them, and he said to the king: You cannot kill me until you do what I ask you to do.And he said: What is that?He said: You should gather people in a plain and hang me by the trunk (of a tree).Then take hold of an arrow from the quiver and say: In the name of Allah, the Lord of the worlds; then shoot an arrow and if you do that then you would be able to kill me.So he (the king) called the people in an open plain and tied him (the boy) to the trunk of a tree, then he took hold of an arrow from his quiver and then placed the arrow in the bow and then said: In the name of Allah, the Lord of the young boy; he then shot an arrow and it bit his temple.He (the boy) placed his hands upon the temple where the arrow had bit him and he died and the people said: We affirm our faith in the Lord of this young man, we affirm our faith in the Lord of this young man, we affirm our faith in the Lord of this young man.The courtiers came to the king and it was said to him: Do you see that Allah has actually done what you aimed at averting.They (the people) have affirmed their faith in the Lord.He (the king) commanded ditches to be dug at important points in the path.When these ditches were dug, and the fire was lit in them it was said (to the people): He who would not turn back from his (boy's) religion would be thrown in the fire or it would be said to them to jump in that. (The people courted death but did not renounce religion) till a woman came with her child and she felt hesitant in jumping into the fire and the child said to her: 0 mother, endure (this ordeal) for it is the Truth.

Chapter 19 : THE STORY OF ABU AL-YASAR AND THE LENGTHY HADITH OF JABIR

Book 42, Number 7149:

    'Ubadab. Walid b. Samit reported: I and my father set out in search of knowledge to a tribe of the Ansar before their death (i.e. before the Companions of the Holy Prophet left the world) and I was the first to meet Abu Yasar, a Companion of Allah's Messenger (may peace be upon him) and there was a young man with him who carried the record of letters with him and there was a mantle prepared by the tribe of Ma'afiri upon him.And his servant too had a Ma'afiri mantle over him.My father said to him: My uncle, I see the signs of anger or that of agony on your face.He said: Yes, such and such person, the son of so and so, of the tribe of Harami owed me a debt. I went to his family, extended salutations and said: Where is he?They said: He is not here.Then came out to me his son who was at the threshold of his youth. I said to him: Where is your father?He said: No sooner did he hear your sound than he hid himself behind my mother's bedstead.I said to him: Walk out to me, for I know where you are.He came out.I said to him: What prompted you to hide yourself from me? He said: By God, whatever I would say to you would not be a lie.By Allah, I fear that I should tell a lie to you and in case of making promise with you I should break it, as you are the Companion of Allah's Messenger (may peace be upon him). The fact is that I was hard up in regard to money.I said: Do you adjure by Allah? He said: I adjure by Allah.I said: Do you adjure by Allah?He said: I adjure by Allah.I said: Do you adjure by Allah?He said: I adjure by Allah.Then he brought his promissory note and he wrote off (the debt) with his hand and said: Make payment when you find yourself solvent enough to pay me back; if you are not, then there is no liability upon you.These two eyes of mine saw, and he (Abu'I-Yasar) placed his fingers upon his eyes and these two ears of mine heard and my heart retained, and he pointed towards his heart that Allah's Messenger (may peace be upon him) said: He who gives time to one who is financially hard up (in the payment of debt) or writes off his debt, Allah will provide him His shadow.I said to him: My uncle, if you get the cloak of your servant and you give him your two clothes, or take his two clothes of Ma'afir and give him your cloak, then there would be one dress for you and one for him.He wiped my head and said: O Allah, bless the son of my brother. O, son of my brother, these two very eyes of mine saw and these two ears of mine listened to and this heart of mine retained this, and he pointed towards the heart that Allah's Messenger (may peace be upon him) said: Feed them (the servants) and clothe them (the servants) what you wear, and if I give him the goods of the world, it is easy for me than this that he should take my virtues on the Day of Resurrection.We went on till we came to Jabir b. Abdullah in the mosque and he was busy in observing prayer in one cloth which he had joined at its opposite ends.I made my way through the people till I sat between him and the Qibla and I said: May Allah have mercy upon you.Do you observe prayer with one cloth on your body whereas your mantle is lying at your side?He pointed me with his hand towards my breast just like this and he separated his fingers and bent them in the shape of a bow.And (he said): I thought that a fool like you should come to me so that he should see me as I do and he should then also do like it. Allah's Messenger (may peace be upon him) came to us in this very mosque and he had in his hand the twig of the palm-tree and he saw mucus towards the Qibla of the mosque and he erased it with the help of the twig.He then came to us and said: Who amongst you likes that Allah should turn His face away from him?We were afraid.He then again said: Who amongst you likes that Allah should turn His face away from him?We were afraid.He again said: Who amongst you likes that Allah should turn His face away from him?We said: Allah's Messenger, none of us likes it. And he said: If one amongst you stands for prayer, Allah, the Exalted and Glorious, is before him he should not spit in front of him, or on his right side, but should spit on his left side beneath his left foot and if he is impelled to do so all of a sudden (in spite of himself) he should then spit in his cloth and fold it in some part of it. (and he further said:) Bring some sweet-smelling thing.A young man who belonged to our tribe stood up, went and brought scent in his palm.Allah's Messenger (may peace be upon him) took that and applied it to the end of that twig and then touched the place where there had been mucus. Jabir said: This is why you should apply scent to your mosques.
    It is reported on the same authority: We set out along with Allah's Messenger (may peace be upon him) on an expedition of Batn Buwat. He (the Holy Prophet) was in search of al-Majdi b. 'Amr al-Juhani. (We had so meagre equipment) that five. six or seven of us had one camel to ride and so we mounted it turn by turn.Once there wan. the turn of an Ansari to ride upon the camel.He made it kneel down to ride over it (and after having. mounted it), he tried to raise it up but it hesitated. So he said.May there be curse of Allah upon you ! Thereupon Allah's Messenger (may peace be upon him) said: Who is there to curse his camel?He said: Allah's Messenger, it' is I. Thereupon he said: Get down from the camel and let us not have in our company the cursed one.Don't curse your own selves, nor your children. nor your belongings.There is the possibility that your curse may synchronies with the time when Allah is about to confer upon you what you demand and thus your prayer may be readily responded.
    It is reported on the same authority: We set out on an expedition along with Allah's Messenger (may peace be upon him) until it was evening, and we had been near a. water reservoir of Arabia.Allah's Messenger (may peace be upon him) said: Who would be the person who would go ahead and set right the reservoir and drink water himself and serve us with it? Jabir said: I stood up and said: Allah's Messenger, it is I who am ready to do that.Thereupon Allah's Messenger (may peace be upon him) said: Who is the person to accompany Jabir?And then Jabbar b. Sakhr stood up.So we went to that well and poured in that tank a bucket or two of water and plastered it with clay and then began to fill it (with water) until it was filled to the brim. Allah's Messenger (may peace be upon him) was the first who appeared before us, and he said: Do you (both) permit me to drink water out of it?We said: Yea, Allah's Messenger.He led his camel to drink water and it drank.He then pulled its rein and it stretched its legs and began to urinate.He then took it aside and made it kneel down at another place and then came to the tank and performed ablution.I then got up and performed ablution like the ablution of Allah's Messenger (may peace be upon him), and Jabbar b. Sakhr went in order to relieve himself and Allah's Messenger (may peace be upon him) got up to observe prayer and there was a mantle over me. I tried to invert its ends but it was too short (to cover my body easily).It had its borders. I then inverted it (the mantle) and drew its opposite ends and then tied them at my neck.I then came and stood upon the left side of Allah's Messenger (may peace be upon him).He caught hold of me and made me go round behind him, until he made me stand on his right side.Then Jabbar b. Sakhr came.He performed ablution and then came and stood on the left side of Allah's Messenger (may peace be upon him).Then Allah's Messenger (may peace be upon him) caught hold of our hands together, pushed us back and made us stand behind him.Then Allah's Messenger (may peace be upon him) began to look upon me with darting looks, but I did not perceive that.After that I became aware of it and he pointed with the gesture of his hand that I should wrap my loin-cloth.When Allah's Messenger (may peace be upon him) had finished the prayer, he said: Jabir! I said:Allah's Messenger, at thy beck and call.He said: When the cloth around you is inadequate, then tie the opposite ends but when it is small, tie it over the lower body.
    Jabir reported: We set out on an expedition with Allah's Messenger (may peace be upon him) and the only means of sustenance for every person amongst us was only one date for a day and we used to chew it.And we struck the leaves with the help of our bow and ate them until the sides of our mouths were injured.It so happened one day that a person was overlooked and not given a date.We carried that person and bore witness to the fact that he had not been given that date so he was offered that and he got up and received that.
    Jabir reported: We set out on an expedition along with Allah's Messenger (may peace be upon him) until we got down at a spacious valley and Allah's Messenger (may peace be upon him) went to relieve himself.I followed him with a bucket full of water and Allah's Messenger (may peace be upon him) looked about and he found no privacy but two trees at the end of the valley and Allah's Messenger (may. peace be upon him) went to one of them and took hold of one of its twigs and said: Be thou under my control by the permission of Allah, and so it came under his control like the camel who has its nosestring in the hand of its rider, and then he came to the second tree and took hold of a twig and said: Be thou under my control with the permission of Allah, and it came under his control, and when he came in the middle of the two trees he joined together the two twigs and said : join with the permission of Allah. Jabir said: I was afraid lest Allah's Messenger (may peace be upon him) should be aware of my nearness and go still farther.And Muhammad b. Abbad has used the word " faitab'd" and I began to talk to myself.And as I saw, I suddenly found Allah's Messenger (may peace be upon him) before me and the two trees were separated and each one of them was standing at its place. I saw Allah's Messenger (may peace be upon him) standing for a short time, nodding his head towards right and left.Isma'il pointed towards the right and left with the help of his head (in order to demonstrate how the Holy Prophet had pointed).Then he (the Holy Prophet) came to me and said: Jabir did you see my place where I was standing?I said: Allah's Messenger, yes.He then said: Then you should go to those two trees and cut a twig from each of them and go to that place with them where I was standing and stand there where I was standing and place a twig on the right and a twig on the left. Jabir said: I set out and took hold of a stone and broke it and sharpened it and then I came to those trees and cut a twig from 'each one of them. I then came dragging them until I stood at the place where Allah's Messenger (may peace be upon him) had been standing and placed a twig on the right and a twig on the left.Then I met him and said: Allah's Messenger, I have done that, but (kindly) explain to me the reason for it.Thereupon he said: I passed by two graves the occupants of which had been undergoing torment. I liked to make intercession for them so that the might be relieved of this torment y as long as these twigs remain fresh. Jabir said: We came back to the (camp of the) army and Allah's Messenger (may peace be upon him) said: Jabir, call people for per- forming wudu. I cried: Come and perform wudu, come and perform wudu, come and perform wudu.I said: Allah's Messenger, there is not even a drop of water in the army camp, and there. was a person who used to cool the water for Allah's Messenger (may peace be upon him) in the old water-skin which kept hanging by the twig.He asked me to go to such and such Ansari and ask him to see if there was any water in that skin.I went to him and cast a glance in it but did not find anything but a drop in the mouth of that water-skin and if I were to draw that, the water-skin's,. dried part would suck it up.I came to Allah's Messenger (may peace be upon him) and said: Allah's Messenger, I have not found anything in it but a drop of water in the mouth of the water-skin and now if I were to draw that, it would be absorbed.He said: Go and bring that to me.I brought that to him.He took hold of it -and began to utter something which I could not understand and then pressed it with his hand and gave that to me and said: Jabir, announce for the tub to be brought.So I announced that the tub of the army (be brought).It was brought accordingly and I placed it before him (the Holy Prophet).Thereupon Allah's Messenger (may peace be upon him) placed his hands in the tub like this: with his fingers stretched out, and then he placed his fingers at the bottom of the tub and said: Jabir, take it (that waters-skin) and pour water over me, by reciting Bismillah, and I poured water and I said: Bismillah, and found water sprouting out between the fingers of Allah's Messenger (may peace be upon him).Then that tub gushed forth until it was filled up and the Messenger (may peace be upon him) said: Jabir, make an announcement to the effect: He who needs water should take that. Jabir said: The people came and got water until they were all satiated.I said: Is there anyone left who wants to get it?And Allah's Messenger (may peace be upon him) then lifted up his hand from that tub and it was still full. Then the people made a complaint to Allah's Messenger (may peace be upon him) about hunger and he said: May Allah provide you food ! We came to the bank of the ocean and the ocean was tossing and it threw out a big animal and we lit fire and cooked it and took it until we had eaten to our heart's content. Jabir said: I and such and such five persons entered Its socket and nobody could see us until we had come out, and we took hold of one of its ribs and twisted it into a sort of arch, then we called the tallest of the persons of the army and the hugest of the camels of the army and it had the big saddle over it, and it could easily pass through it without the rider having need to bend down.

Chapter 20 : THE ACCOUNT OF PROPHET'S (MAY PEACE BE UPON HIM) EMIGRATION

Book 42, Number 7150:

    Al-Bara' b. 'Azib reported that Abu Bakr Siddlq came to the residence of my father ('Azib) and bought a haudaj from him and said to 'Azib: Send your son to my residence (to carry this haudaj), and my father said to me: Carry it (for him).So I carried it and there went along with him (with Abu Bakr) my father in order to fetch its price and he ('Azib) said to Abu Bakr: Abu Bakr, narrate to me what you both did on the night when you set out on a journey along with Allah's Messenger (may peace be upon him).He said: We set out during the night and went on walking until it was noon, and the path was vacant and so none passed by that (until) there appeared prominently before us a large rock.It had its shade and the rays of the sun did not reach that place.So we got down at that place.I then went to the rock and levelled the ground with my hands at the place where the Holy Prophet (may peace be upon him) would take rest under its shade.I then set the bedding and said: Allah's Messenger, go to sleep and I shall keep a watch around you.I went out and watched around him.There we saw a shepherd moving towards that rock with his flock and he intended what we intended (i.e. taking rest).I met him and said to him: Young boy, to which place do you belong?He said: I am a person from Medina.I said, is there any milk in the udders of your sheep and goats?He said: Yes.He took hold of a goat, and I said to him: Clean the udder well so that it should be free from hair, dust and impurity.I saw al-Bara' striking his hand upon the other (to give an indication) how he did that.He milked the goat for me in a wooden cup which he had with him and I had with me a bucket in which I kept water for drinking and for performing ablution.I came to Allah's Apostle (may peace be upon him) and did not like to awaken him from sleep but he was accidentally startled from the sleep.I poured water upon the milk (till It was cold) and I said: Allah's Messenger, take this milk.He then took It and I was delighted and he (the Holy Prophet) said: Is now not the time to march on?I said: Of course.So he marched on after the sun had passed the meridian and Suraqa b. Malik pursued us and we had been walking on soft, level ground.I said: Allah's Messenger, we are about to be overtaken by them.Thereupon he said: Be not grieved.Verily, Allah is with us.Then Allah's Messenger (may peace be upon him) cursed him and his horse sank into the earth.I think he also said: I know you have hurled curse upon me. So supplicate Allah for me and I take an oath that I shall turn everyone away who would come in search of you.So he (Allah's Messenger) supplicated Allah and he was rescued and he came back and to everyone he met, he said: I have combed all this side.In short, he diverted everyone whom he met and he in fact fulfilled his promise.
    Al-Bara' reported: Abu Bakr purchased a saddle from me for thirteen dirhams; the rest of the hadith is the same, and in the narration of Uthman b. 'Umar, the words are: He (Suraqa b. Malik) drew near Allah's Messenger (may peace be upon him), and he (the Holy Prophet) cursed him and his camel sank in the earth up to the belly and he jumped from that and said: Muhammad, I am fully aware of It that it is your doing.Supplicate Allah that He should rescue me from it in which I am (pitchforked) and I give you a solemn pledge that I shall keep this as a secret from all those who are coming after me.Take hold of an arrow out of it (quiver) for you will find my camels and my slaves at such and such place and you can get whatever you need (on showing this arrow).He (the Holy Prophet) said: I don't need your camels.And we (the Holy Prophet and Abu Bakr) came to Medina during the night and the people began to contend as to where Allah's Messenger (may peace be upon him) should reside and he encamped in the tribe of Najjar who were related to 'Abd ul-Muttalib from the side of mother.Allah's Messenger (may peace be upon him) honoured them, then people climbed upon house-top and women also and boys scattered in the way, and they were all crying: Muhammad, Messenger of Allah, Muhammad,Messenger of Allah.


Book 43: Commentary (Kitab Al-Tafsir)

KITAB Al-TAFSIR
(Book of Commentary )

Back
Chapter 1 : ....

Book 43, Number 7151:

    Hammim b. Munabbih reported: This is what Abu Huraira reported to us from Allah's Messenger (may peace be upon him) and in this connection he narrated some of the ahadith and Allah's Messenger (may peace be upon him) said: It was said to people of Israel: Enter this land saying Hitta (Remove Thou from us the burden of our sins), whereupon We would forgive you your sins, but they twisted (this statement) and entered the gate dragging upon their breech and said: The "grain in the ear."

Book 43, Number 7152:

    Anas b. Malik reported that Allah, the Exalted and Glorious, sent revelation to Allah's Messenger (may peace be upon him) just before his death in quick succession until he left for his heavenly home, and the day when he died, he received the revelation profusely.

Book 43, Number 7153:

    Tariq b. Shihab reported that a Jew said to'Umar: You recite a verse which, if it had been revealed in relation to us, we would have taken that day as the day of rejoicing. Thereupon 'Umar said: I know where it was revealed and on the day when it was revealed and where Allah's Messenger (may peace be upon him) had been at that time when it was revealed. It was revealed on the day of 'Arafa (ninth of Dhu'l Hijjah) and Allah's Messenger (may peace be upon him) had been staying in 'Arafat. Sufyan said: I doubt, whether it was Friday or not (and the verse referred to) is this: "Today I have perfected your religion for you and completed My favours upon you "(v. 4).

Book 43, Number 7154:

    Tariq b. Shihab reported that a Jew said to 'Umar: If this verse were revealed in relation to the Jews (i.e. "This day I have perfected your religion for you and have completed My favours for you and have chosen for you al-Islam as religion") we would have taken the day of rejoicing on which this verse was revealed. Thereupon 'Umar said: I know the day on which it was revealed and the hour when it was revealed and where Allah's Messenger (may peace be upon him) had been when it was revealed. It was revealed on the night of Friday and we were in 'Arafat with Alleh's Messenger (may peace be upon him) at that time.

Book 43, Number 7155:

    Tariq b. Shihab reported that a Jew came to 'Umar and said: Commander of the Faithful, there is a verse in your Book, which you recite. Had it been revealed in connection with the Jews, we would have taken it as the day of rejoicing. Thereupon he said: Which verse do you mean? He replied: "This day I have perfected your religion for you and I have completed My favours upon you and I have chosen al-Islam as religion for you." Umar said, I know the day when it was revealed and the place where it was revealed. It was revealed to Allah's Messenger (may peace be upon him) at 'Arafat on Friday.

Book 43, Number 7156:

    'Urwa b. Zubair reported that he asked 'A'isha about the words of Allah: "If you fear that you will not be able to maintain equity amongst the orphan girls, then marry (those) you like from amongst the women two, three or four." She said: O, the son of my sister, the orphan girl is one who is under the patronage of her guardian and she shares with him in his property and her property and beauty fascinate him and her guardian makes up his mind to marry her without giving her due share of the wedding money and is not prepared (to pay so much amount) which anyone else is prepared to pay and so Allah has forbidden to marry these girls but in case when equity is observed as regards the wedding money and they are prepared to pay them the full amount of the wedding money and Allah commanded to marry other women besides them according to the liking of their heart. 'Urwa reported that 'A'isha said that people began to seek verdict from Allah's Messenger (may peace be upon him) after the revelation of this verse about them (orphan girls) and Allah, the Exalted and Glorious, revealed this verse: "They asked thee verdict about women; say: Allah gives verdict to you in regard to them and what is recited to you in the Book about orphan woman, whom you give not what is ordained for them while you like to marry them" (iv. 126). She said: The wording of Allah "what is recited to you" in the Book means the first verse, i.e. "if you fear that you may not be able to observe equity in case of an orphan woman, marry what you like in case of woman" (iv. 3). 'A'isha said: (And as for this verse [iv. 126], i.e. and you intend "to marry one of them from amongst the orphan girls" it pertains to one who is in charge (of orphans) having small amount of wealth and less beauty and they have been forbidden that they should marry what they like of her wealth and beauty out of the orphan girls, but with equity, because of their disliking for them.

Book 43, Number 7157:

    'Urwa reported that he asked 'A'isha about the words of Allah: "If you fear that you will not be able to observe equity in case of orphan girls"; the rest of the hadith is the same but with a slight variation of wording.

Book 43, Number 7158:

    'A'isha said that as for the words of Allah: "If you fear that you would not be able to observe equity in case of orphan girls)," it was revealed in reference to a person who had an orphan girl (as his ward) and he was her guardian, and her heir, and she possessed property, but there was none to contend on her behalf except her ownself. And he (her guardian) did not give her in marriage because of her property and he tortured her and ill-treated her, it was in relation to her that (Allah said:) "If you fear that you would not be able to observe equity in case of orphan girls, then marry whom you like among women," i.e. whatever I have made lawful for you and leave her whom you are putting to torture.

Book 43, Number 7159:

    'A'isha said in connection with His words (those of Allah): "What is recited to you in the Book about orphan women whom you give not what is ordained for them, while you like to marry them," these were revealed in connection with an orphan girl who was in the charge of the person and she shared with him in his property and he was reluctant to marry her himself and was also unwilling to marry her to someone else (fearing) that (that person) would share in his property (as the husband of that girl), preventing her to marry, neither marrying her himself nor marrying her to another person.

Book 43, Number 7160:

    Hisham reported that 'A'isha said in connection with the words of Allah: "They ask thee the religious verdict about women, say: Allah gives you the verdict about them" (iv. 126), that these relate to an orphan girl who is in charge of the person and she shares with him in his property (as a heir) even in the date-palm trees and he is reluctant to give her hand in marriage to any other person lest he (her husband) should partake of his property, and thus keep her in a lingering state.

Book 43, Number 7161:

    Hisham reported on the authority of his father that 'A'isha said in connection with His (Allah's) words: "And whoever is poor let him take reasonably (out of it)" that it was revealed in connection with the custodian of the property of an orphan, who is in charge of her and looks after her; In case he is poor, he is allowed to eat out of that.

Book 43, Number 7162:

    'A'isha reported in connection with the words of Allah, the Exalted: "He who is rich should abstain, and he who is poor may reasonably eat (out of it)" that this was revealed in relation to the guardian of an orphan who is poor; he may get out of that what is reasonable keeping in view his own status of solvency.

Book 43, Number 7163:

    This hadith has been narrated on the authority of Hisham with the same chain of transmitters.

Book 43, Number 7164:

    'A'isha reported that these words of Allah: "When they came upon you from above you and from below you and when the eyes turned dull and the hearts rose up to the throats" (xxxiii. 10) pertain to the day of Ditch.

Book 43, Number 7165:

    'A'isha said in connection with the verse: "And if a woman has reason to fear ill-treatment from her husband or that he might turn away from her" (iv. 128) that it was revealed in case of a woman who had long association with a person (as his wife) and now he intends to divorce her and she says: Do not divorce me, but retain me (as wife in your house) and you are permitted to live with another wife. It is in this context that this verse was revealed.

Book 43, Number 7166:

    'A'isha said in connection with these words of Allah, the Exalted and Glorious: "And if a woman has reason to fear ill-treatment from her husband or that he might turn away from her" that it was revealed in case of a woman who lived with a person and perhaps he does not want to prolong (his relationship with her) whereas she has had sexual relationship with him (and as a result thereof) she got a child from him and she does not like that she should be divorced, so she says to him: I permit you to live with the other wife.

Book 43, Number 7167:

    'Urwa reported on the authority of his father that 'A'isha said to him: O, the son of my sister, the Muslims were commanded to seek forgiveness for the Companions of Allah's Apostle (may peace be upon him) but they reviled him.

Book 43, Number 7168:

    This hadith has been transmitted on the authority of Abu Usama with the same chain of narrators.

Book 43, Number 7169:

    Sa'id b. Jubair reported: The inhabitants of Kufa differed in regard to this verse: "But whoever slays another believer intentionally, his requital shall be Hell" (iv. 92), so I went to Ibn 'Abbas and asked him about it, whereupon he said: This has been revealed and nothing abrogated it.

Book 43, Number 7170:

    This hadith has been transmitted on the authority of Shu'ba with the same chain of narrators but with a slight variation of wording.

Book 43, Number 7171:

    Sa'id b. Jubair reported: 'Abd al Rahman b. Abzi commanded me that I should ask Ibn 'Abbas about these two verses: "He who slays a believer intentionally his requital shall be Hell where he would abide for ever" (iv. 92). So, I asked him and he said: Nothing has abrogated it. And as for this verse: "And they who call not upon another god with Allah and slay not the soul which Allah has forbidden ,except in the cause of justice" (xxv. 68), he (Ibn Abbas) said: This has been revealed in regard to the polytheists."

Book 43, Number 7172:

    Ibn 'Abbas said: This verse was revealed in Mecca : "And they who call not upon another god with Allah and slay not the soul which Allah has forbidden except in the cause of justice" up to the word Muhdana (abased). Thereupon the polytheists said: Islam is of no avail to us for we have made peer with Allah and we killed the soul which Allah had forbidden to do and we committed debauchery, and it was (on this occasion) that Allah, the Exalted and Glorious, revealed this verse: "Except him who repents and believes and does good deeds" up to the end Ibn 'Abbis says: He who enters the fold of Islam and understands its command and then kills the soul there is no repentance for him.

Book 43, Number 7173:

    Sa'id b. Jubair reported: I said to Ibn Abbas: Will the repentance of that person be accepted who kills a believer intentionally ? He said: No. I recited to him this verse of Sura al-Furqan (xix.): "And those who call not upon another god with Allah and slay not the soul which Allah has forbidden except in the cause of justice" to the end of the verse. He said: This is a Meccan verse which has been abrogated by a verse revealed at Medina: "He who slays a believer intentionally, for him is the requital of Hell-Fire where he would abide for ever," and in the narration of Ibn Hisham (the words are) : I recited to him this verse of Sura al-Furqan: "Except one who made repentance."

Book 43, Number 7174:

    Ubaidullah b. 'Abdullah b. 'Utba reported: Ibn Abbas said to me: Do you know-and in the words of Harun (another narrator): Are you aware of-the last Sura which was revealed in the Qur'an as a whole? I said: Yes, "When came the help from Allah and the victory" (cx.). Thereupon, he said: You have told the truth. And in the narration of Abu Shaiba (the words are): Do you know the Sura ? And he did not mention the words "the last one".

Book 43, Number 7175:

    This hadith has been reported on the authority of Abu 'Umais through the same chain of transmitters but with a slight variation of wording.

Book 43, Number 7176:

    Ibn Abbas reported that some Muslims met a person with a small flock of sheep. He said: As-Salam-o-'Alaikum. They caught hold of him and killed him and took possession of his flock. Then this verse was revealed: "He who meets you and extends you salutations, don't say: You are not a Muslim" (iv. 94). Ibn 'Abbas, however, recited the word as-Salam instead of "as-Salam".

Book 43, Number 7177:

    Bara' reported: When the Ansar performed the Pilgrimage, they did not enter their houses but from behind. A person from the Ansar came and he began to enter from his door but it was said to him (why he was doing something in contravention to the common practice of coming to the houses from behind). Then this verse was revealed. "Piety is not that you come to the doors from behind" (ii. 189).

Chapter 2 : PERTAINING TO THE VERSE: 'HAS NOT THE TIME YET COME FOR THE BELIEVERS THAT THEIR HEARTS SHOULD BE HUMBLE FOR THE REMEMBRANCE OF ALLAH?" (lvii. 16)

Book 43, Number 7178:

    Ibn Mas'ud said: Since our acceptance of Islam and the revelation of this verse in which Allah has shown annoyance to us: "Has not the time yet come for the believers that their hearts should be humble for the remembrance of Allah ?" (lvii. 16), there was a gap of four years.

Chapter 3 : PERTAINING TO THE WORDS OF ALLAH: "ADORN YOURSELF AT EVERY PLACE OF WORSHIP" (vii. 31)

Book 43, Number 7179:

    Ibn Abbas reported: During the pre-Islamic days women circumambulated the Ka'ba nakedly, and said: Who would provide cloth to cover the one who is circumambulating the Ka'ba so that she would cover her private parts? And then she would say: Today will be exposed the whole or the part and what is exposed I shall not make it lawful. It was in this connection that the verse was revealed: "Adorn yourself at every place of worship" (vii. 31).

Chapter 4 : COMPEL NOT YOUR SLAVE-GIRLS TO PROSTITUTION

Book 43, Number 7180:

    Jabir reported that 'Abdullah b. Ubayy b. Salul used to say to his slave-girl: Go and fetch something for us by committing prostitution. It was in this connection that Allah, the Exalted and Glorious, revealed this verse: "And compel not your slave-girls to prostitution when they desire to keep chaste in order to seek the frail goods of this world's life, and whoever compels them, then surely after their compulsion Allah is Forgiving, Merciful" (xxiv. 33).

Book 43, Number 7181:

    Jabir reported that 'Abdullah b. Ubayy b. Salul had two slave-girls; one was called Musaika and the other one was called Umaima and he compelled them to prostitution (for which'Abdullah b. Ubayy b. Salul compelled them). They made a complaint about this to Allah's Messenger (may peace be upon him) and it was upon this that this verse was revealed: "And compel not your slave-girls to prostitute" up to the words: "Allah is Forgiving, Merciful."

Chapter 5 : PERTAINING TO THE WORDS OF ALLAH: "THOSE WHOM THEY CALL UPON, THEMSELVES SEEK THE MEANS OF ACCESS TO THEIR LORD" (xvii. 57)

Book 43, Number 7182:

    Abdullah b. Mas'ud reported in connection with the words of Allah, the Exalted and Glorious: "Those to whom they call upon, themselves seek the means or access to their Lord as to whoever of them becomes nearest" (xvii. 57) that it related to a party of Jinn who were being worshipped and they embraced Islam but those who worshipped them kept on worshipping them (though the Jinn whom the misguided people worshipped had become Muslims). It was then that this verse was revealed.

Book 43, Number 7183:

    Abdullah b. Mas'ud reported in connection with the verse: "Those whom they call upon, themselves seek the means of access to their Lord," that it related to a group of people who worshipped a party amongst the Jinn. The group from amongst the Jinn embraced Islam, but the people kept worshipping them as they did before, and it was (on this occasion) that the verse was revealed: "Those whom they call upon, themselves seek the means of access to their Lord." This hadith has been narrated on the authority of Sulaimin with the same chain of transmitters.

Book 43, Number 7184:

    Abdullah b. Mas'ud said in connection with the verse: "Those whom they call upon, themselves seek the means of access to their Lord," that that verse was revealed in connection with a party of Arabs who used to worship a group amnogst the jinn; the jinn embraced Islam but the people kept worshipping them without being conscious of it. Then this verse was revealed: "Those whom they call upon, themselves seek the means of access to their Lord."

Chapter 6 : PERTAINING TO SURAS TAUBA, AL-ANFAL AND HASHR

Book 43, Number 7185:

    Sa'id b. Jubair reported: I said to Ibn 'Abbas about Sura Tauba, whereupon he said: As for Sura Tauba, it is meant to humiliate (the non-believers and the hypocrites). There is constantly revealed in it (the pronoun) minhum (of them) and minhom (of them, i.e. such is the condition of some of them) till they (the Muslims) thought that none would be left unmentioned out of them who would not be blamed (for one fault or the other). I again said: What about Sura Anfal? He said: It pertains to the Battle of Badr. I again asked him about Sura al-Hashr. He said: It was revealed in connection with (the tribe) of Banu Nadir.

Chapter 7 : PERTAINING TO THE PROHIBITION OF WINE

Book 43, Number 7186:

    Ibn 'Umar reported that Umar delivered a sermon on the pulpit of Allah's Messenger (may peace be upon him) and he praised Allah and lauded Him and then said: Now coming to the point. Behold I when the command pertaining to the prohibition of wine was revealed, it was prepared from five things: from wheat, barley, date, grape, honey; and wine is that which clouds the intellect; and O people, I wish Allah's Messenger (may peace be upon him) could have explained to us in (more) detail the laws pertaining to the inheritance of the grandfather, about one who dies leaving no issue, and some of the problems pertaining to interest.

Book 43, Number 7187:

    Ibn 'Umar reported: I heard 'Umar b. Khattab delivering sermon on the pulpit ol Allah's messenger (may peace be upon him) and saying': Now, coming to the point, O people, there was revealed (the command pertaining to the prohibition of wine) and it was prepared (at that time) out of five things: grape, date, honey, wheat, barley, and wine is that which clouds the intellect, and, O people, I wish Allah's Messenger (may peace be upon him) had explained to us in greater detail three things: the inheritance of the grandfather, of one who dies without leaving any issue, and some of the problems of interest.

Book 43, Number 7188:

    This hadith has been transmitted on the same authority but with a slight variation of wording.

Chapter 8 : PERTAINING TO THE VERSE: "THESE TWO ADVERSARIES WHO DISPUTE ABOUT THEIR LORD" (xxii. 19)

Book 43, Number 7189:

    Abu Dharr took an oath that this verse: "These two adversaries who dispute about their Lord" (xxii. 19) was revealed in connection with those who on the Day of Badr came out (of rows to fight against the non-believers and they were) Hamza, 'Ali, 'Ubaida b. Harith (from the side of the Muslims) and 'Utba and Shaiba, both of them the sons of Rabi'a and Walid b. 'Utba (from the side of the non-believers of Mecca).

Book 43, Number 7190:

    This hadith has been narrated on the authority of Abu Dharr through another chain of transmitters.